NVAPI Reference Documentation
NVIDIA
Release 560
Mon Aug 5 2024
  • Main Page
  • Related Pages
  • Topics
  • Data Structures
  • Files
NVIDIA NVAPI

NVIDIA NVAPI is the core software development kit that allows direct access to NVIDIA GPUs and drivers on all Microsoft Windows platforms. NVAPI provides support for categories of operations that range beyond the scope of those found in familiar graphics APIs such as DirectX and OpenGL.

Some of the features that programmers can access using NVAPI include:

  • Driver Management: Initialization and driver version controls.
  • GPU Management: Enumeration of physical and logical GPUs. Thermal and Cooling controls.
  • Display Management: Enumeration of NVDIA displays, display postion and timings controls.
  • System Management: Ability to query chipset and system specific information.
  • Connecting and Configuring Monitors: Ability to set views on multiple target monitors.

Documentation Contents

  • About this Documentation
  • System Requirements
  • Important NVAPI Concepts
  • Deprecation Warnings

Privacy Policy | Manage My Privacy | Do Not Sell or Share My Data | Terms of Service | Accessibility | Corporate Policies | Product Security | Contact

Copyright © 2022-2024 NVIDIA Corporation


  • Main Page
  • Related Pages
  • Topics
  • Data Structures
  • Files
  • NVIDIA NVAPI
About this Documentation

This document is provided to OEMs, game developers, and NVIDIA technology partners.

Navigating the Documentation

This document describes the interface constants, structure definitions, and function prototypes for NvAPI. It is presented as an on-line help file. This format provides hypertext linking between related topics.

The Contents tab lets you access information as follows:

  • NVIDIA NVAPI - Main Page contains supplemental documentation pages.
  • Modules organizes the APIs by groups to help you easily locate a particular API.
  • Data Structures and Files provide a straightforward listing of functions, structures, and data types within the header file.
  • NVIDIA NVAPI contains related documentation pages.


  • Data Structures
  • Files
  • NVIDIA NVAPI
System Requirements

NvAPI Files

Make sure you have the following files:

  • nvapi.h
  • nvapi.lib (for 32-bit support)
  • nvapi64.lib (for 64-bit support)

Operating System and Platforms

The current version of NvAPI is supported on Windows XP, Windows Vista and later, both 32-bit and 64-bit architectures. Some API calls are OS specific–see the individual calls for OS support information.

NVIDIA ForceWare Driver Version

NvAPI is supported on ForceWare driver versions 81.20 and up. See the individual calls for specific driver version information.


  • NVIDIA NVAPI
Important NVAPI Concepts

This section explains the following NVAPI concepts and principles:

  • NvAPI Handles
  • Structure Versions Must be Initialized
  • Use a Static Link with Applications

NvAPI Handles

NvAPI handles are retrieved from various calls and passed to other calls in NvAPI. These are meant to be opaque types, and do not necessarily correspond to specific indices, HDCs, or display indices.
Most handles remain valid until a display re-configuration such as a display mode set, or a GPU reconfiguration such as going into or out of SLI modes. If NvAPI returns NVAPI_HANDLE_INVALIDATED, the application should discard all handles and re-enumerate them.
The following is a description of key NvAPI handles and identifiers:

  • Physical GPU handle: NvPhysicalGpuHandle is a reference to a physical GPU. Each GPU in a multi-GPU board will have its own handle. GPUs are assigned a handle even if they are not in use by the OS.
  • Logical GPU handle: NvLogicalGpuHandle is a reference to one or more physical GPUs acting as a single logical device. A single GPU will have a single logical GPU handle and a single physical GPU handle. Two GPUs acting in an SLI configuration will have a single logical GPU handle and two physical GPU handles.
  • NVIDIA display handle: NVIDIA display handles map one-to-one to the GDI handles for the attached displays in the Windows Display Properties Settings page. NvDisplayHandles reflect only the displays that the OS is aware of. Therefore, there is only one NvDisplayHandle for displays in Clone or Span mode, but there are two in Dualview mode. Some APIs use NvUnAttachedDisplayHandle for GDI dsplays that are not attached.
  • GPU output: GPU output IDs are identifiers for the GPU outputs that drive display devices. The GPU output might or might not be connected to a display, or be active. Each output is identified by a bit setting within a 32-bit unsigned integer. A GPU output mask consists of a 32-bit integer with several bits set, identifying more than one output from the same physical GPU.

The following figures illustrate these four identifiers used by NvAPI under various GPU configurations.

NvAPI Handles—Dualview, Clone and Spanning Modes

NvAPI Handles—SLI Mode

NvAPI Handles—Two GPUs Under Dualview

Structure Versions Must be Initialized

Each structure contains a version field which the caller must initialize so that the API library can track the version that is used by the calling application.
Each structure also has an associated NvAPI macro that you can use to initialize the version field. For example, the macro for structure NV_XXX is NV_XXX_VER. Initialize the version field as follows:

NV_XXX.version = NV_XXX_VER;

Use a Static Link with Applications

NvAPI cannot be dynamically linked to applications. You must create a static link to the library and then call NvAPI_Initialize(), which loads nvapi.dll dynamically.
If the NVIDIA drivers are not installed on the system or nvapi.dll is not present when the application calls NvAPI_Initialize(), the call just returns an error. The application will still load.


  • NVIDIA NVAPI
Deprecation Warnings

All legacy APIs will be deprecated if a replacement is available. When an API is deprecated, it still remains in the code. However, any attempts to use it will result in a warning message recommending alternative APIs and stating that the API will be removed in the future - the API will not remain in the code indefinitely.

As the API is not removed immediately, this gives the client time to bring their code into compliance with the new APIs.

Example of Some Warnings

error C2220: warning treated as error - no 'object' file generated
warning C4996: 'NvAPI_GPU_GetConnectedOutputs': Do not use this function -
it is deprecated in release 290.
Instead, use NvAPI_GPU_GetConnectedDisplayIds.
NvAPI_GPU_GetConnectedDisplayIds
NVAPI_INTERFACE NvAPI_GPU_GetConnectedDisplayIds(__in NvPhysicalGpuHandle hPhysicalGpu, __inout_ecount_part_opt(*pDisplayIdCount, *pDisplayIdCount) NV_GPU_DISPLAYIDS *pDisplayIds, __inout NvU32 *pDisplayIdCount, __in NvU32 flags)

How to Avoid Warnings

There are two courses of action that clients should take to avoid being presented with the warnings. These include a short term phase and a long term phase:

Phase-I (short term):

  • Option 1: Ignore the warning by using CFFLAG. Add “CFLAGS += -wd4996” and “CFLAGS += -wd4995”
  • Option 2: Don't use CFLAG, which treats the warning as an error. Remove “CFLAGS += -WX” from the make file.

Phase-II (long term): Clients need to avoid using the deprecated APIs and switch to the replacement APIs.


Legal Notice

Copyright (c) 2007–2024 NVIDIA Corporation. All rights reserved.

Notice
This software may not, in whole or in part, be copied through any means, mechanical, electromechanical, or otherwise, without the express permission of NVIDIA Corporation.
Information furnished is believed to be accurate and reliable. However, NVIDIA assumes no responsibility for the consequences of use of such information nor for any infringement of patents or other rights of third parties, which may result from its use. No License is granted by implication or otherwise under any patent or patent rights of NVIDIA Corporation. Specifications mentioned in the software are subject to change without notice.
NVIDIA Corporation products are not authorized for use as critical components in life support devices or systems without express written approval of NVIDIA Corporation.

Trademarks
NVIDIA, the NVIDIA logo, and NVIDIA Quadro are registered trademarks or trademarks of NVIDIA Corporation in the United States and/or other countries.
Microsoft, Windows, and the Windows logo are registered trademarks of Microsoft Corporation.
Other company and product names may be trademarks or registered trademarks of the respective companies with which they are associated.


Topics
Here is a list of all topics with brief descriptions:
[detail level 123]
▼ General NVAPI
General NVAPI Functions
General NVAPI Defines, Structs, and Enums
NVAPI Handles
NvAPI Status Values
Graphics Driver APIs
▼ Display APIs
Display Handle Interface
Display Control Interface
▼ GPU APIs
GPU General Control Interface
GPU Performance Interface <br>
GPU Thermal Control Interface
GPU Performance State Interface
GPU Clock Control Interface
GPU Cooler Interface
GPU ECC Interface
▼ Video APIs
▼ Video Input/Output Interface
Stereoscopic 3D APIs
Driver Settings (DRS) APIs
System - General Interface <br>
▼ DirectX APIs
DirectX Interface
DirectX Video Control
TV APIs
▼ System APIs
System - General Interface <br>
▼ OpenGL APIs
GPU General Control Interface
GPU ECC Interface
GPU Clock Control Interface
Display Control Interface
Mosaic APIs
I2C APIs
Quadro G-Sync APIs
Nsight APIs
GRID License APIs


Modules
General NVAPI

Modules

General NVAPI Functions
General NVAPI Defines, Structs, and Enums
NVAPI Handles
NvAPI Status Values

Detailed Description

This section describes APIs that:

  • Initialize the NVAPI library,
  • Return the NVAPI version,
  • Return the human readable error message, It also describes the list of handles and return status indicators.


Functions
General NVAPI Functions
General NVAPI

Functions

NVAPI_INTERFACE NvAPI_Initialize ()
NVAPI_INTERFACE NvAPI_Unload ()
NVAPI_INTERFACE | NvAPI_GetErrorMessage (NvAPI_Status nr, NvAPI_ShortString szDesc)
NVAPI_INTERFACE | NvAPI_GetInterfaceVersionString (NvAPI_ShortString szDesc)
NVAPI_INTERFACE | NvAPI_GetInterfaceVersionStringEx (NvAPI_ShortString szDesc)

Detailed Description

Function Documentation

◆ NvAPI_GetErrorMessage()

NVAPI_INTERFACE NvAPI_GetErrorMessage | ( | NvAPI_Status | nr,
 |  | NvAPI_ShortString | szDesc
 | ) |  |

This function converts an NvAPI error code into a null terminated string.

SUPPORTED OS: Windows 7 and higher

Since
Release: 80
Parameters
nr | The error code to convert
szDesc | The string corresponding to the error code
Returns
NULL terminated string (always, never NULL)

◆ NvAPI_GetInterfaceVersionString()

NVAPI_INTERFACE NvAPI_GetInterfaceVersionString ( NvAPI_ShortString szDesc )

This function returns a string describing the version of the NvAPI library. The contents of the string are human readable. Do not assume a fixed format.

SUPPORTED OS: Windows 7 and higher

Since
Release: 80
Parameters
szDesc User readable string giving NvAPI version information
Returns
See NvAPI Status Values for the list of possible return values.

◆ NvAPI_GetInterfaceVersionStringEx()

NVAPI_INTERFACE NvAPI_GetInterfaceVersionStringEx ( NvAPI_ShortString szDesc )

This function returns a string describing the version of the NvAPI library. The contents of the string are human readable. Do not assume a fixed format.

SUPPORTED OS: Windows 7 and higher

Since
Release: 450
Parameters
szDesc User readable string giving NvAPI version information
Returns
See NvAPI Status Values for the list of possible return values.

◆ NvAPI_Initialize()

NVAPI_INTERFACE NvAPI_Initialize ( )

This function initializes the NvAPI library (if not already initialized) but always increments the ref-counter. This must be called before calling other NvAPI_ functions. Note: It is now mandatory to call NvAPI_Initialize before calling any other NvAPI. NvAPI_Unload should be called to unload the NVAPI Library.

SUPPORTED OS: Windows 7 and higher

Since
Release: 80
Returns
This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.
Return values
NVAPI_LIBRARY_NOT_FOUND Failed to load the NVAPI support library
See also
NvAPI Status Values

◆ NvAPI_Unload()

NVAPI_INTERFACE NvAPI_Unload ( )

DESCRIPTION: Decrements the ref-counter and when it reaches ZERO, unloads NVAPI library. This must be called in pairs with NvAPI_Initialize.

SUPPORTED OS: Windows 7 and higher

   If the client wants unload functionality, it is recommended to always call NvAPI_Initialize and NvAPI_Unload in pairs.

Unloading NvAPI library is not supported when the library is in a resource locked state. Some functions in the NvAPI library initiates an operation or allocates certain resources and there are corresponding functions available, to complete the operation or free the allocated resources. All such function pairs are designed to prevent unloading NvAPI library.

For example, if NvAPI_Unload is called after NvAPI_XXX which locks a resource, it fails with NVAPI_ERROR. Developers need to call the corresponding NvAPI_YYY to unlock the resources, before calling NvAPI_Unload again.

Returns
This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.
Return values
NVAPI_API_IN_USE Atleast an API is still being called hence cannot unload requested driver.


Data Structures | Macros | Typedefs
General NVAPI Defines, Structs, and Enums
General NVAPI

Data Structures

struct | NvSBox
struct | NvGUID

Macros

#define | NVAPI_GENERIC_STRING_MAX 4096
#define | NVAPI_LONG_STRING_MAX 256
#define | NVAPI_SHORT_STRING_MAX 64
#define | NvGUID_Defined
#define | NVAPI_MAX_PHYSICAL_GPUS 64
#define | NVAPI_MAX_PHYSICAL_BRIDGES 100
#define | NVAPI_PHYSICAL_GPUS 32
#define | NVAPI_MAX_LOGICAL_GPUS 64
#define | NVAPI_MAX_AVAILABLE_GPU_TOPOLOGIES 256
#define | NVAPI_MAX_AVAILABLE_SLI_GROUPS 256
#define | NVAPI_MAX_GPU_TOPOLOGIES NVAPI_MAX_PHYSICAL_GPUS
#define | NVAPI_MAX_GPU_PER_TOPOLOGY 8
#define | NVAPI_MAX_DISPLAY_HEADS 2
#define | NVAPI_ADVANCED_DISPLAY_HEADS 4
#define | NVAPI_MAX_DISPLAYS NVAPI_PHYSICAL_GPUS * NVAPI_ADVANCED_DISPLAY_HEADS
#define | NVAPI_MAX_ACPI_IDS 16
#define | NVAPI_MAX_VIEW_MODES 8
#define | NVAPI_SYSTEM_MAX_HWBCS 128
#define | NVAPI_SYSTEM_HWBC_INVALID_ID 0xffffffff
#define | NVAPI_SYSTEM_MAX_DISPLAYS NVAPI_MAX_PHYSICAL_GPUS * NV_MAX_HEADS
#define | NV_MAX_HEADS 4
#define | NVAPI_MAX_HEADS_PER_GPU 32
#define | NV_MAX_VID_STREAMS 4
#define | NV_MAX_VID_STREAMS_EX 20
#define | NV_MAX_VID_PROFILES 4
#define | NVAPI_MAX_AUDIO_DEVICES 16
#define | MAKE_NVAPI_VERSION(typeName, ver) (NvU32)(sizeof(typeName) | ((ver)<<16))
#define | GET_NVAPI_VERSION(ver) (NvU32)((ver)>>16)
#define | GET_NVAPI_SIZE(ver) (NvU32)((ver) & 0xffff)

Typedefs

typedef struct NvGUID | NvLUID
typedef char | NvAPI_String[NVAPI_GENERIC_STRING_MAX]
typedef char | NvAPI_LongString[NVAPI_LONG_STRING_MAX]
typedef char | NvAPI_ShortString[NVAPI_SHORT_STRING_MAX]
typedef NvU16 | NvAPI_UnicodeShortString[NVAPI_SHORT_STRING_MAX]

Detailed Description

<>

Macro Definition Documentation

◆ GET_NVAPI_SIZE

#define GET_NVAPI_SIZE ( ver ) (NvU32)((ver) & 0xffff)

◆ GET_NVAPI_VERSION

#define GET_NVAPI_VERSION ( ver ) (NvU32)((ver)>>16)

◆ MAKE_NVAPI_VERSION

#define MAKE_NVAPI_VERSION | ( | typeName,
 |  | ver
 | ) | (NvU32)(sizeof(typeName) | ((ver)<<16))

NvAPI Version Definition
Maintain per structure specific version define using the MAKE_NVAPI_VERSION macro.
Usage: #define NV_GENLOCK_STATUS_VER MAKE_NVAPI_VERSION(NV_GENLOCK_STATUS, 1)

◆ NV_MAX_HEADS

#define NV_MAX_HEADS 4

Maximum heads, each with NVAPI_DESKTOP_RES resolution.

◆ NV_MAX_VID_PROFILES

#define NV_MAX_VID_PROFILES 4

Maximum number of output video profiles supported.

◆ NV_MAX_VID_STREAMS

#define NV_MAX_VID_STREAMS 4

Maximum number of input video streams, each with a #NVAPI_VIDEO_SRC_INFO.

◆ NV_MAX_VID_STREAMS_EX

#define NV_MAX_VID_STREAMS_EX 20

Increasing MAX no. of input video streams, each with a #NVAPI_VIDEO_SRC_INFO.

◆ NVAPI_ADVANCED_DISPLAY_HEADS

#define NVAPI_ADVANCED_DISPLAY_HEADS 4

◆ NVAPI_GENERIC_STRING_MAX

#define NVAPI_GENERIC_STRING_MAX 4096

◆ NVAPI_LONG_STRING_MAX

#define NVAPI_LONG_STRING_MAX 256

◆ NVAPI_MAX_ACPI_IDS

#define NVAPI_MAX_ACPI_IDS 16

◆ NVAPI_MAX_AUDIO_DEVICES

#define NVAPI_MAX_AUDIO_DEVICES 16

◆ NVAPI_MAX_AVAILABLE_GPU_TOPOLOGIES

#define NVAPI_MAX_AVAILABLE_GPU_TOPOLOGIES 256

◆ NVAPI_MAX_AVAILABLE_SLI_GROUPS

#define NVAPI_MAX_AVAILABLE_SLI_GROUPS 256

◆ NVAPI_MAX_DISPLAY_HEADS

#define NVAPI_MAX_DISPLAY_HEADS 2

◆ NVAPI_MAX_DISPLAYS

#define NVAPI_MAX_DISPLAYS NVAPI_PHYSICAL_GPUS * NVAPI_ADVANCED_DISPLAY_HEADS

◆ NVAPI_MAX_GPU_PER_TOPOLOGY

#define NVAPI_MAX_GPU_PER_TOPOLOGY 8

◆ NVAPI_MAX_GPU_TOPOLOGIES

#define NVAPI_MAX_GPU_TOPOLOGIES NVAPI_MAX_PHYSICAL_GPUS

◆ NVAPI_MAX_HEADS_PER_GPU

#define NVAPI_MAX_HEADS_PER_GPU 32

◆ NVAPI_MAX_LOGICAL_GPUS

#define NVAPI_MAX_LOGICAL_GPUS 64

◆ NVAPI_MAX_PHYSICAL_BRIDGES

#define NVAPI_MAX_PHYSICAL_BRIDGES 100

◆ NVAPI_MAX_PHYSICAL_GPUS

#define NVAPI_MAX_PHYSICAL_GPUS 64

◆ NVAPI_MAX_VIEW_MODES

#define NVAPI_MAX_VIEW_MODES 8

◆ NVAPI_PHYSICAL_GPUS

#define NVAPI_PHYSICAL_GPUS 32

◆ NVAPI_SHORT_STRING_MAX

#define NVAPI_SHORT_STRING_MAX 64

◆ NVAPI_SYSTEM_HWBC_INVALID_ID

#define NVAPI_SYSTEM_HWBC_INVALID_ID 0xffffffff

◆ NVAPI_SYSTEM_MAX_DISPLAYS

#define NVAPI_SYSTEM_MAX_DISPLAYS NVAPI_MAX_PHYSICAL_GPUS * NV_MAX_HEADS

◆ NVAPI_SYSTEM_MAX_HWBCS

#define NVAPI_SYSTEM_MAX_HWBCS 128

◆ NvGUID_Defined

#define NvGUID_Defined

Typedef Documentation

◆ NvAPI_LongString

typedef char NvAPI_LongString[NVAPI_LONG_STRING_MAX]

◆ NvAPI_ShortString

typedef char NvAPI_ShortString[NVAPI_SHORT_STRING_MAX]

◆ NvAPI_String

typedef char NvAPI_String[NVAPI_GENERIC_STRING_MAX]

◆ NvAPI_UnicodeShortString

typedef NvU16 NvAPI_UnicodeShortString[NVAPI_SHORT_STRING_MAX]

◆ NvLUID

typedef struct NvGUID NvLUID


  • Class Hierarchy
  • Data Fields
Data Fields
NvSBox Struct Reference
General NVAPI » General NVAPI Defines, Structs, and Enums

#include <nvapi_lite_common.h>

Data Fields

NvS32 sX
NvS32 sY
NvS32 sWidth
NvS32 sHeight

Field Documentation

◆ sHeight

NvS32 NvSBox::sHeight

◆ sWidth

NvS32 NvSBox::sWidth

◆ sX

NvS32 NvSBox::sX

◆ sY

NvS32 NvSBox::sY
The documentation for this struct was generated from the following file:
  • nvapi_lite_common.h


Data Fields
NvGUID Struct Reference
General NVAPI » General NVAPI Defines, Structs, and Enums

#include <nvapi_lite_common.h>

Data Fields

NvU32 data1
NvU16 data2
NvU16 data3
NvU8 data4 [8]

Field Documentation

◆ data1

NvU32 NvGUID::data1

◆ data2

NvU16 NvGUID::data2

◆ data3

NvU16 NvGUID::data3

◆ data4

NvU8 NvGUID::data4[8]
The documentation for this struct was generated from the following file:
  • nvapi_lite_common.h


Typedefs | Functions
NVAPI Handles
General NVAPI

Typedefs

typedef void * StereoHandle

Functions

NV_DECLARE_HANDLE (NvLogicalGpuHandle)
NV_DECLARE_HANDLE (NvPhysicalGpuHandle)
NV_DECLARE_HANDLE (NvDisplayHandle)
NV_DECLARE_HANDLE (NvMonitorHandle)
NV_DECLARE_HANDLE (NvUnAttachedDisplayHandle)
NV_DECLARE_HANDLE (NvVisualComputingDeviceHandle)
NV_DECLARE_HANDLE (NvEventHandle)
NV_DECLARE_HANDLE (NvHICHandle)
NV_DECLARE_HANDLE (NvGSyncDeviceHandle)
NV_DECLARE_HANDLE (NvVioHandle)
NV_DECLARE_HANDLE (NvTransitionHandle)
NV_DECLARE_HANDLE (NvAudioHandle)
NV_DECLARE_HANDLE (Nv3DVPContextHandle)
NV_DECLARE_HANDLE (Nv3DVPTransceiverHandle)
NV_DECLARE_HANDLE (Nv3DVPGlassesHandle)
NV_DECLARE_HANDLE (NvPcfClientHandle)
NV_DECLARE_HANDLE (NvSourceHandle)
NV_DECLARE_HANDLE (NvTargetHandle)
NV_DECLARE_HANDLE (NVDX_SwapChainHandle)
NV_DECLARE_HANDLE (NvPresentBarrierClientHandle)
#define | NVAPI_DEFAULT_HANDLE 0
#define | NV_BIT(x) (1 << (x))

Detailed Description

NVAPI Handles - These handles are retrieved from various calls and passed in to others in NvAPI These are meant to be opaque types. Do not assume they correspond to indices, HDCs, display indexes or anything else.

Most handles remain valid until a display re-configuration (display mode set) or GPU reconfiguration (going into or out of SLI modes) occurs. If NVAPI_HANDLE_INVALIDATED is received by an app, it should discard all handles, and re-enumerate them.

Macro Definition Documentation

◆ NV_BIT

#define NV_BIT ( x ) (1 << (x))

◆ NVAPI_DEFAULT_HANDLE

#define NVAPI_DEFAULT_HANDLE 0

Typedef Documentation

◆ StereoHandle

typedef void* StereoHandle

A stereo handle, that corresponds to the device interface.

Function Documentation

◆ NV_DECLARE_HANDLE() [1/20]

NV_DECLARE_HANDLE ( Nv3DVPContextHandle )

A handle for a 3D Vision Pro (3DVP) context.

◆ NV_DECLARE_HANDLE() [2/20]

NV_DECLARE_HANDLE ( Nv3DVPGlassesHandle )

A handle for a pair of 3DVP RF shutter glasses.

◆ NV_DECLARE_HANDLE() [3/20]

NV_DECLARE_HANDLE ( Nv3DVPTransceiverHandle )

A handle for a 3DVP RF transceiver.

◆ NV_DECLARE_HANDLE() [4/20]

NV_DECLARE_HANDLE ( NvAudioHandle )

NVIDIA HD Audio Device.

◆ NV_DECLARE_HANDLE() [5/20]

NV_DECLARE_HANDLE ( NvDisplayHandle )

Display Device driven by NVIDIA GPU(s) (an attached display)

◆ NV_DECLARE_HANDLE() [6/20]

NV_DECLARE_HANDLE ( NVDX_SwapChainHandle )

DirectX SwapChain objects.

◆ NV_DECLARE_HANDLE() [7/20]

NV_DECLARE_HANDLE ( NvEventHandle )

A handle to an event registration instance.

◆ NV_DECLARE_HANDLE() [8/20]

NV_DECLARE_HANDLE ( NvGSyncDeviceHandle )

A handle to a Sync device.

◆ NV_DECLARE_HANDLE() [9/20]

NV_DECLARE_HANDLE ( NvHICHandle )

A handle to a Host Interface Card.

◆ NV_DECLARE_HANDLE() [10/20]

NV_DECLARE_HANDLE ( NvLogicalGpuHandle )

One or more physical GPUs acting in concert (SLI)

◆ NV_DECLARE_HANDLE() [11/20]

NV_DECLARE_HANDLE ( NvMonitorHandle )

Monitor handle.

◆ NV_DECLARE_HANDLE() [12/20]

NV_DECLARE_HANDLE ( NvPcfClientHandle )

A handle for NVPCF clients.

◆ NV_DECLARE_HANDLE() [13/20]

NV_DECLARE_HANDLE ( NvPhysicalGpuHandle )

A single physical GPU.

◆ NV_DECLARE_HANDLE() [14/20]

NV_DECLARE_HANDLE ( NvPresentBarrierClientHandle )

PresentBarrier client object

◆ NV_DECLARE_HANDLE() [15/20]

NV_DECLARE_HANDLE ( NvSourceHandle )

Unique source handle on the system.

◆ NV_DECLARE_HANDLE() [16/20]

NV_DECLARE_HANDLE ( NvTargetHandle )

Unique target handle on the system.

◆ NV_DECLARE_HANDLE() [17/20]

NV_DECLARE_HANDLE ( NvTransitionHandle )

A handle to address a single transition request.

◆ NV_DECLARE_HANDLE() [18/20]

NV_DECLARE_HANDLE ( NvUnAttachedDisplayHandle )

Unattached Display Device driven by NVIDIA GPU(s)

◆ NV_DECLARE_HANDLE() [19/20]

NV_DECLARE_HANDLE ( NvVioHandle )

A handle to an SDI device.

◆ NV_DECLARE_HANDLE() [20/20]

NV_DECLARE_HANDLE ( NvVisualComputingDeviceHandle )

A handle to a Visual Computing Device.


Macros | Typedefs | Enumerations
NvAPI Status Values
General NVAPI

Macros

#define NVAPI_API_NOT_INTIALIZED NVAPI_API_NOT_INITIALIZED

Typedefs

typedef enum _NvAPI_Status NvAPI_Status

Enumerations

enum _NvAPI_Status {
NVAPI_OK = 0 , NVAPI_ERROR = -1 , NVAPI_LIBRARY_NOT_FOUND = -2 , NVAPI_NO_IMPLEMENTATION = -3 ,
NVAPI_API_NOT_INITIALIZED = -4 , NVAPI_INVALID_ARGUMENT = -5 , NVAPI_NVIDIA_DEVICE_NOT_FOUND = -6 , NVAPI_END_ENUMERATION = -7 ,
NVAPI_INVALID_HANDLE = -8 , NVAPI_INCOMPATIBLE_STRUCT_VERSION = -9 , NVAPI_HANDLE_INVALIDATED = -10 , NVAPI_OPENGL_CONTEXT_NOT_CURRENT = -11 ,
NVAPI_INVALID_POINTER = -14 , NVAPI_NO_GL_EXPERT = -12 , NVAPI_INSTRUMENTATION_DISABLED = -13 , NVAPI_NO_GL_NSIGHT = -15 ,
NVAPI_EXPECTED_LOGICAL_GPU_HANDLE = -100 , NVAPI_EXPECTED_PHYSICAL_GPU_HANDLE = -101 , NVAPI_EXPECTED_DISPLAY_HANDLE = -102 , NVAPI_INVALID_COMBINATION = -103 ,
NVAPI_NOT_SUPPORTED = -104 , NVAPI_PORTID_NOT_FOUND = -105 , NVAPI_EXPECTED_UNATTACHED_DISPLAY_HANDLE = -106 , NVAPI_INVALID_PERF_LEVEL = -107 ,
NVAPI_DEVICE_BUSY = -108 , NVAPI_NV_PERSIST_FILE_NOT_FOUND = -109 , NVAPI_PERSIST_DATA_NOT_FOUND = -110 , NVAPI_EXPECTED_TV_DISPLAY = -111 ,
NVAPI_EXPECTED_TV_DISPLAY_ON_DCONNECTOR = -112 , NVAPI_NO_ACTIVE_SLI_TOPOLOGY = -113 , NVAPI_SLI_RENDERING_MODE_NOTALLOWED = -114 , NVAPI_EXPECTED_DIGITAL_FLAT_PANEL = -115 ,
NVAPI_ARGUMENT_EXCEED_MAX_SIZE = -116 , NVAPI_DEVICE_SWITCHING_NOT_ALLOWED = -117 , NVAPI_TESTING_CLOCKS_NOT_SUPPORTED = -118 , NVAPI_UNKNOWN_UNDERSCAN_CONFIG = -119 ,
NVAPI_TIMEOUT_RECONFIGURING_GPU_TOPO = -120 , NVAPI_DATA_NOT_FOUND = -121 , NVAPI_EXPECTED_ANALOG_DISPLAY = -122 , NVAPI_NO_VIDLINK = -123 ,
NVAPI_REQUIRES_REBOOT = -124 , NVAPI_INVALID_HYBRID_MODE = -125 , NVAPI_MIXED_TARGET_TYPES = -126 , NVAPI_SYSWOW64_NOT_SUPPORTED = -127 ,
NVAPI_IMPLICIT_SET_GPU_TOPOLOGY_CHANGE_NOT_ALLOWED = -128 , NVAPI_REQUEST_USER_TO_CLOSE_NON_MIGRATABLE_APPS = -129 , NVAPI_OUT_OF_MEMORY = -130 , NVAPI_WAS_STILL_DRAWING = -131 ,
NVAPI_FILE_NOT_FOUND = -132 , NVAPI_TOO_MANY_UNIQUE_STATE_OBJECTS = -133 , NVAPI_INVALID_CALL = -134 , NVAPI_D3D10_1_LIBRARY_NOT_FOUND = -135 ,
NVAPI_FUNCTION_NOT_FOUND = -136 , NVAPI_INVALID_USER_PRIVILEGE = -137 , NVAPI_EXPECTED_NON_PRIMARY_DISPLAY_HANDLE = -138 , NVAPI_EXPECTED_COMPUTE_GPU_HANDLE = -139 ,
NVAPI_STEREO_NOT_INITIALIZED = -140 , NVAPI_STEREO_REGISTRY_ACCESS_FAILED = -141 , NVAPI_STEREO_REGISTRY_PROFILE_TYPE_NOT_SUPPORTED = -142 , NVAPI_STEREO_REGISTRY_VALUE_NOT_SUPPORTED = -143 ,
NVAPI_STEREO_NOT_ENABLED = -144 , NVAPI_STEREO_NOT_TURNED_ON = -145 , NVAPI_STEREO_INVALID_DEVICE_INTERFACE = -146 , NVAPI_STEREO_PARAMETER_OUT_OF_RANGE = -147 ,
NVAPI_STEREO_FRUSTUM_ADJUST_MODE_NOT_SUPPORTED = -148 , NVAPI_TOPO_NOT_POSSIBLE = -149 , NVAPI_MODE_CHANGE_FAILED = -150 , NVAPI_D3D11_LIBRARY_NOT_FOUND = -151 ,
NVAPI_INVALID_ADDRESS = -152 , NVAPI_STRING_TOO_SMALL = -153 , NVAPI_MATCHING_DEVICE_NOT_FOUND = -154 , NVAPI_DRIVER_RUNNING = -155 ,
NVAPI_DRIVER_NOTRUNNING = -156 , NVAPI_ERROR_DRIVER_RELOAD_REQUIRED = -157 , NVAPI_SET_NOT_ALLOWED = -158 , NVAPI_ADVANCED_DISPLAY_TOPOLOGY_REQUIRED = -159 ,
NVAPI_SETTING_NOT_FOUND = -160 , NVAPI_SETTING_SIZE_TOO_LARGE = -161 , NVAPI_TOO_MANY_SETTINGS_IN_PROFILE = -162 , NVAPI_PROFILE_NOT_FOUND = -163 ,
NVAPI_PROFILE_NAME_IN_USE = -164 , NVAPI_PROFILE_NAME_EMPTY = -165 , NVAPI_EXECUTABLE_NOT_FOUND = -166 , NVAPI_EXECUTABLE_ALREADY_IN_USE = -167 ,
NVAPI_DATATYPE_MISMATCH = -168 , NVAPI_PROFILE_REMOVED = -169 , NVAPI_UNREGISTERED_RESOURCE = -170 , NVAPI_ID_OUT_OF_RANGE = -171 ,
NVAPI_DISPLAYCONFIG_VALIDATION_FAILED = -172 , NVAPI_DPMST_CHANGED = -173 , NVAPI_INSUFFICIENT_BUFFER = -174 , NVAPI_ACCESS_DENIED = -175 ,
NVAPI_MOSAIC_NOT_ACTIVE = -176 , NVAPI_SHARE_RESOURCE_RELOCATED = -177 , NVAPI_REQUEST_USER_TO_DISABLE_DWM = -178 , NVAPI_D3D_DEVICE_LOST = -179 ,
NVAPI_INVALID_CONFIGURATION = -180 , NVAPI_STEREO_HANDSHAKE_NOT_DONE = -181 , NVAPI_EXECUTABLE_PATH_IS_AMBIGUOUS = -182 , NVAPI_DEFAULT_STEREO_PROFILE_IS_NOT_DEFINED = -183 ,
NVAPI_DEFAULT_STEREO_PROFILE_DOES_NOT_EXIST = -184 , NVAPI_CLUSTER_ALREADY_EXISTS = -185 , NVAPI_DPMST_DISPLAY_ID_EXPECTED = -186 , NVAPI_INVALID_DISPLAY_ID = -187 ,
NVAPI_STREAM_IS_OUT_OF_SYNC = -188 , NVAPI_INCOMPATIBLE_AUDIO_DRIVER = -189 , NVAPI_VALUE_ALREADY_SET = -190 , NVAPI_TIMEOUT = -191 ,
NVAPI_GPU_WORKSTATION_FEATURE_INCOMPLETE = -192 , NVAPI_STEREO_INIT_ACTIVATION_NOT_DONE = -193 , NVAPI_SYNC_NOT_ACTIVE = -194 , NVAPI_SYNC_MASTER_NOT_FOUND = -195 ,
NVAPI_INVALID_SYNC_TOPOLOGY = -196 , NVAPI_ECID_SIGN_ALGO_UNSUPPORTED = -197 , NVAPI_ECID_KEY_VERIFICATION_FAILED = -198 , NVAPI_FIRMWARE_OUT_OF_DATE = -199 ,
NVAPI_FIRMWARE_REVISION_NOT_SUPPORTED = -200 , NVAPI_LICENSE_CALLER_AUTHENTICATION_FAILED = -201 , NVAPI_D3D_DEVICE_NOT_REGISTERED = -202 , NVAPI_RESOURCE_NOT_ACQUIRED = -203 ,
NVAPI_TIMING_NOT_SUPPORTED = -204 , NVAPI_HDCP_ENCRYPTION_FAILED = -205 , NVAPI_PCLK_LIMITATION_FAILED = -206 , NVAPI_NO_CONNECTOR_FOUND = -207 ,
NVAPI_HDCP_DISABLED = -208 , NVAPI_API_IN_USE = -209 , NVAPI_NVIDIA_DISPLAY_NOT_FOUND = -210 , NVAPI_PRIV_SEC_VIOLATION = -211 ,
NVAPI_INCORRECT_VENDOR = -212 , NVAPI_DISPLAY_IN_USE = -213 , NVAPI_UNSUPPORTED_CONFIG_NON_HDCP_HMD = -214 , NVAPI_MAX_DISPLAY_LIMIT_REACHED = -215 ,
NVAPI_INVALID_DIRECT_MODE_DISPLAY = -216 , NVAPI_GPU_IN_DEBUG_MODE = -217 , NVAPI_D3D_CONTEXT_NOT_FOUND = -218 , NVAPI_STEREO_VERSION_MISMATCH = -219 ,
NVAPI_GPU_NOT_POWERED = -220 , NVAPI_ERROR_DRIVER_RELOAD_IN_PROGRESS = -221 , NVAPI_WAIT_FOR_HW_RESOURCE = -222 , NVAPI_REQUIRE_FURTHER_HDCP_ACTION = -223 ,
NVAPI_DISPLAY_MUX_TRANSITION_FAILED = -224 , NVAPI_INVALID_DSC_VERSION = -225 , NVAPI_INVALID_DSC_SLICECOUNT = -226 , NVAPI_INVALID_DSC_OUTPUT_BPP = -227 ,
NVAPI_FAILED_TO_LOAD_FROM_DRIVER_STORE = -228 , NVAPI_NO_VULKAN = -229 , NVAPI_REQUEST_PENDING = -230 , NVAPI_RESOURCE_IN_USE = -231 ,
NVAPI_INVALID_IMAGE = -232 , NVAPI_INVALID_PTX = -233 , NVAPI_NVLINK_UNCORRECTABLE = -234 , NVAPI_JIT_COMPILER_NOT_FOUND = -235 ,
NVAPI_INVALID_SOURCE = -236 , NVAPI_ILLEGAL_INSTRUCTION = -237 , NVAPI_INVALID_PC = -238 , NVAPI_LAUNCH_FAILED = -239 ,
NVAPI_NOT_PERMITTED = -240 , NVAPI_CALLBACK_ALREADY_REGISTERED = -241 , NVAPI_CALLBACK_NOT_FOUND = -242 , NVAPI_INVALID_OUTPUT_WIRE_FORMAT = -243
}

Detailed Description

All functions return an NvAPI_Status value. For example,

  • Any function receiving an invalid argument will return NVAPI_INVALID_ARGUMENT.
  • If communication with an NVIDIA display driver cannot be established, functions return NVAPI_NVIDIA_DEVICE_NOT_FOUND.
  • If one or more handles passed have been invalidated due to a modeset or SLI reconfiguration event, then functions return NVAPI_HANDLE_INVALIDATED. <>

Macro Definition Documentation

◆ NVAPI_API_NOT_INTIALIZED

#define NVAPI_API_NOT_INTIALIZED NVAPI_API_NOT_INITIALIZED

Fix typo in error code

Typedef Documentation

◆ NvAPI_Status

typedef enum _NvAPI_Status NvAPI_Status

NvAPI Status Values All NvAPI functions return one of these codes. <>

Enumeration Type Documentation

◆ _NvAPI_Status

enum _NvAPI_Status

NvAPI Status Values All NvAPI functions return one of these codes. <>

Enumerator
NVAPI_OK | Success. Request is completed.
NVAPI_ERROR | Generic error.
NVAPI_LIBRARY_NOT_FOUND | NVAPI support library cannot be loaded.
NVAPI_NO_IMPLEMENTATION | not implemented in current driver installation
NVAPI_API_NOT_INITIALIZED | NvAPI_Initialize has not been called (successfully)
NVAPI_INVALID_ARGUMENT | The argument/parameter value is not valid or NULL.
NVAPI_NVIDIA_DEVICE_NOT_FOUND | No NVIDIA display driver, or NVIDIA GPU driving a display, was found.
NVAPI_END_ENUMERATION | No more items to enumerate.
NVAPI_INVALID_HANDLE | Invalid handle.
NVAPI_INCOMPATIBLE_STRUCT_VERSION | An argument's structure version is not supported.
NVAPI_HANDLE_INVALIDATED | The handle is no longer valid (likely due to GPU or display re-configuration)
NVAPI_OPENGL_CONTEXT_NOT_CURRENT | No NVIDIA OpenGL context is current (but needs to be)
NVAPI_INVALID_POINTER | An invalid pointer, usually NULL, was passed as a parameter.
NVAPI_NO_GL_EXPERT | OpenGL Expert is not supported by the current drivers.
NVAPI_INSTRUMENTATION_DISABLED | OpenGL Expert is supported, but driver instrumentation is currently disabled.
NVAPI_NO_GL_NSIGHT | OpenGL does not support Nsight.
NVAPI_EXPECTED_LOGICAL_GPU_HANDLE | Expected a logical GPU handle for one or more parameters.
NVAPI_EXPECTED_PHYSICAL_GPU_HANDLE | Expected a physical GPU handle for one or more parameters.
NVAPI_EXPECTED_DISPLAY_HANDLE | Expected an NV display handle for one or more parameters.
NVAPI_INVALID_COMBINATION | The combination of parameters is not valid.
NVAPI_NOT_SUPPORTED | Requested feature is not supported in the selected GPU.
NVAPI_PORTID_NOT_FOUND | No port ID was found for the I2C transaction.
NVAPI_EXPECTED_UNATTACHED_DISPLAY_HANDLE | Expected an unattached display handle as one of the input parameters.
NVAPI_INVALID_PERF_LEVEL | Invalid perf level.
NVAPI_DEVICE_BUSY | Device is busy; request not fulfilled.
NVAPI_NV_PERSIST_FILE_NOT_FOUND | NV persist file is not found.
NVAPI_PERSIST_DATA_NOT_FOUND | NV persist data is not found.
NVAPI_EXPECTED_TV_DISPLAY | Expected a TV output display.
NVAPI_EXPECTED_TV_DISPLAY_ON_DCONNECTOR | Expected a TV output on the D Connector - HDTV_EIAJ4120.
NVAPI_NO_ACTIVE_SLI_TOPOLOGY | SLI is not active on this device.
NVAPI_SLI_RENDERING_MODE_NOTALLOWED | Setup of SLI rendering mode is not possible right now.
NVAPI_EXPECTED_DIGITAL_FLAT_PANEL | Expected a digital flat panel.
NVAPI_ARGUMENT_EXCEED_MAX_SIZE | Argument exceeds the expected size.
NVAPI_DEVICE_SWITCHING_NOT_ALLOWED | Inhibit is ON due to one of the flags in NV_GPU_DISPLAY_CHANGE_INHIBIT or SLI active.
NVAPI_TESTING_CLOCKS_NOT_SUPPORTED | Testing of clocks is not supported.
NVAPI_UNKNOWN_UNDERSCAN_CONFIG | The specified underscan config is from an unknown source (e.g. INF)
NVAPI_TIMEOUT_RECONFIGURING_GPU_TOPO | Timeout while reconfiguring GPUs.
NVAPI_DATA_NOT_FOUND | Requested data was not found.
NVAPI_EXPECTED_ANALOG_DISPLAY | Expected an analog display.
NVAPI_NO_VIDLINK | No SLI video bridge is present.
NVAPI_REQUIRES_REBOOT | NVAPI requires a reboot for the settings to take effect.
NVAPI_INVALID_HYBRID_MODE | The function is not supported with the current Hybrid mode.
NVAPI_MIXED_TARGET_TYPES | The target types are not all the same.
NVAPI_SYSWOW64_NOT_SUPPORTED | The function is not supported from 32-bit on a 64-bit system.
NVAPI_IMPLICIT_SET_GPU_TOPOLOGY_CHANGE_NOT_ALLOWED | There is no implicit GPU topology active. Use NVAPI_SetHybridMode to change topology.
NVAPI_REQUEST_USER_TO_CLOSE_NON_MIGRATABLE_APPS | Prompt the user to close all non-migratable applications.
NVAPI_OUT_OF_MEMORY | Could not allocate sufficient memory to complete the call.
NVAPI_WAS_STILL_DRAWING | The previous operation that is transferring information to or from this surface is incomplete.
NVAPI_FILE_NOT_FOUND | The file was not found.
NVAPI_TOO_MANY_UNIQUE_STATE_OBJECTS | There are too many unique instances of a particular type of state object.
NVAPI_INVALID_CALL | The method call is invalid. For example, a method's parameter may not be a valid pointer.
NVAPI_D3D10_1_LIBRARY_NOT_FOUND | d3d10_1.dll cannot be loaded.
NVAPI_FUNCTION_NOT_FOUND | Couldn't find the function in the loaded DLL.
NVAPI_INVALID_USER_PRIVILEGE | The application can be elevated to a higher permission level by selecting "Run as Administrator". The application will require Administrator privileges to access this API.
NVAPI_EXPECTED_NON_PRIMARY_DISPLAY_HANDLE | The handle corresponds to GDIPrimary.
NVAPI_EXPECTED_COMPUTE_GPU_HANDLE | Setting Physx GPU requires that the GPU is compute-capable.
NVAPI_STEREO_NOT_INITIALIZED | The Stereo part of NVAPI failed to initialize completely. Check if the stereo driver is installed.
NVAPI_STEREO_REGISTRY_ACCESS_FAILED | Access to stereo-related registry keys or values has failed.
NVAPI_STEREO_REGISTRY_PROFILE_TYPE_NOT_SUPPORTED | The given registry profile type is not supported.
NVAPI_STEREO_REGISTRY_VALUE_NOT_SUPPORTED | The given registry value is not supported.
NVAPI_STEREO_NOT_ENABLED | Stereo is not enabled and the function needed it to execute completely.
NVAPI_STEREO_NOT_TURNED_ON | Stereo is not turned on and the function needed it to execute completely.
NVAPI_STEREO_INVALID_DEVICE_INTERFACE | Invalid device interface.
NVAPI_STEREO_PARAMETER_OUT_OF_RANGE | Separation percentage or JPEG image capture quality is out of [0-100] range.
NVAPI_STEREO_FRUSTUM_ADJUST_MODE_NOT_SUPPORTED | The given frustum adjust mode is not supported.
NVAPI_TOPO_NOT_POSSIBLE | The mosaic topology is not possible given the current state of the hardware.
NVAPI_MODE_CHANGE_FAILED | An attempt to do a display resolution mode change has failed.
NVAPI_D3D11_LIBRARY_NOT_FOUND | d3d11.dll/d3d11_beta.dll cannot be loaded.
NVAPI_INVALID_ADDRESS | Address is outside of valid range.
NVAPI_STRING_TOO_SMALL | The pre-allocated string is too small to hold the result.
NVAPI_MATCHING_DEVICE_NOT_FOUND | The input does not match any of the available devices.
NVAPI_DRIVER_RUNNING | Driver is running.
NVAPI_DRIVER_NOTRUNNING | Driver is not running.
NVAPI_ERROR_DRIVER_RELOAD_REQUIRED | A driver reload is required to apply these settings.
NVAPI_SET_NOT_ALLOWED | Intended setting is not allowed.
NVAPI_ADVANCED_DISPLAY_TOPOLOGY_REQUIRED | Information can't be returned due to "advanced display topology".
NVAPI_SETTING_NOT_FOUND | Setting is not found.
NVAPI_SETTING_SIZE_TOO_LARGE | Setting size is too large.
NVAPI_TOO_MANY_SETTINGS_IN_PROFILE | There are too many settings for a profile.
NVAPI_PROFILE_NOT_FOUND | Profile is not found.
NVAPI_PROFILE_NAME_IN_USE | Profile name is duplicated.
NVAPI_PROFILE_NAME_EMPTY | Profile name is empty.
NVAPI_EXECUTABLE_NOT_FOUND | Application not found in the Profile.
NVAPI_EXECUTABLE_ALREADY_IN_USE | Application already exists in the other profile.
NVAPI_DATATYPE_MISMATCH | Data Type mismatch.
NVAPI_PROFILE_REMOVED | The profile passed as parameter has been removed and is no longer valid.
NVAPI_UNREGISTERED_RESOURCE | An unregistered resource was passed as a parameter.
NVAPI_ID_OUT_OF_RANGE | The DisplayId corresponds to a display which is not within the normal outputId range.
NVAPI_DISPLAYCONFIG_VALIDATION_FAILED | Display topology is not valid so the driver cannot do a mode set on this configuration.
NVAPI_DPMST_CHANGED | Display Port Multi-Stream topology has been changed.
NVAPI_INSUFFICIENT_BUFFER | Input buffer is insufficient to hold the contents.
NVAPI_ACCESS_DENIED | No access to the caller.
NVAPI_MOSAIC_NOT_ACTIVE | The requested action cannot be performed without Mosaic being enabled.
NVAPI_SHARE_RESOURCE_RELOCATED | The surface is relocated away from video memory.
NVAPI_REQUEST_USER_TO_DISABLE_DWM | The user should disable DWM before calling NvAPI.
NVAPI_D3D_DEVICE_LOST | D3D device status is D3DERR_DEVICELOST or D3DERR_DEVICENOTRESET - the user has to reset the device.
NVAPI_INVALID_CONFIGURATION | The requested action cannot be performed in the current state.
NVAPI_STEREO_HANDSHAKE_NOT_DONE | Call failed as stereo handshake not completed.
NVAPI_EXECUTABLE_PATH_IS_AMBIGUOUS | The path provided was too short to determine the correct NVDRS_APPLICATION.
NVAPI_DEFAULT_STEREO_PROFILE_IS_NOT_DEFINED | Default stereo profile is not currently defined.
NVAPI_DEFAULT_STEREO_PROFILE_DOES_NOT_EXIST | Default stereo profile does not exist.
NVAPI_CLUSTER_ALREADY_EXISTS | A cluster is already defined with the given configuration.
NVAPI_DPMST_DISPLAY_ID_EXPECTED | The input display id is not that of a multi stream enabled connector or a display device in a multi stream topology.
NVAPI_INVALID_DISPLAY_ID | The input display id is not valid or the monitor associated to it does not support the current operation.
NVAPI_STREAM_IS_OUT_OF_SYNC | While playing secure audio stream, stream goes out of sync.
NVAPI_INCOMPATIBLE_AUDIO_DRIVER | Older audio driver version than required.
NVAPI_VALUE_ALREADY_SET | Value already set, setting again not allowed.
NVAPI_TIMEOUT | Requested operation timed out.
NVAPI_GPU_WORKSTATION_FEATURE_INCOMPLETE | The requested workstation feature set has incomplete driver internal allocation resources.
NVAPI_STEREO_INIT_ACTIVATION_NOT_DONE | Call failed because InitActivation was not called.
NVAPI_SYNC_NOT_ACTIVE | The requested action cannot be performed without Sync being enabled.
NVAPI_SYNC_MASTER_NOT_FOUND | The requested action cannot be performed without Sync Master being enabled.
NVAPI_INVALID_SYNC_TOPOLOGY | Invalid displays passed in the NV_GSYNC_DISPLAY pointer.
NVAPI_ECID_SIGN_ALGO_UNSUPPORTED | The specified signing algorithm is not supported. Either an incorrect value was entered or the current installed driver/hardware does not support the input value.
NVAPI_ECID_KEY_VERIFICATION_FAILED | The encrypted public key verification has failed.
NVAPI_FIRMWARE_OUT_OF_DATE | The device's firmware is out of date.
NVAPI_FIRMWARE_REVISION_NOT_SUPPORTED | The device's firmware is not supported.
NVAPI_LICENSE_CALLER_AUTHENTICATION_FAILED | The caller is not authorized to modify the License.
NVAPI_D3D_DEVICE_NOT_REGISTERED | The user tried to use a deferred context without registering the device first
NVAPI_RESOURCE_NOT_ACQUIRED | Head or SourceId was not reserved for the VR Display before doing the Modeset or the dedicated display.
NVAPI_TIMING_NOT_SUPPORTED | Provided timing is not supported.
NVAPI_HDCP_ENCRYPTION_FAILED | HDCP Encryption Failed for the device. Would be applicable when the device is HDCP Capable.
NVAPI_PCLK_LIMITATION_FAILED | Provided mode is over sink device pclk limitation.
NVAPI_NO_CONNECTOR_FOUND | No connector on GPU found.
NVAPI_HDCP_DISABLED | When a non-HDCP capable HMD is connected, we would inform user by this code.
NVAPI_API_IN_USE | Atleast an API is still being called.
NVAPI_NVIDIA_DISPLAY_NOT_FOUND | No display found on Nvidia GPU(s).
NVAPI_PRIV_SEC_VIOLATION | Priv security violation, improper access to a secured register.
NVAPI_INCORRECT_VENDOR | NVAPI cannot be called by this vendor.
NVAPI_DISPLAY_IN_USE | DirectMode Display is already in use.
NVAPI_UNSUPPORTED_CONFIG_NON_HDCP_HMD | The Config is having Non-NVidia GPU with Non-HDCP HMD connected.
NVAPI_MAX_DISPLAY_LIMIT_REACHED | GPU's Max Display Limit has Reached.
NVAPI_INVALID_DIRECT_MODE_DISPLAY | DirectMode not Enabled on the Display.
NVAPI_GPU_IN_DEBUG_MODE | GPU is in debug mode, OC is NOT allowed.
NVAPI_D3D_CONTEXT_NOT_FOUND | No NvAPI context was found for this D3D object.
NVAPI_STEREO_VERSION_MISMATCH | there is version mismatch between stereo driver and dx driver
NVAPI_GPU_NOT_POWERED | GPU is not powered and so the request cannot be completed.
NVAPI_ERROR_DRIVER_RELOAD_IN_PROGRESS | The display driver update in progress.
NVAPI_WAIT_FOR_HW_RESOURCE | Wait for HW resources allocation.
NVAPI_REQUIRE_FURTHER_HDCP_ACTION | operation requires further HDCP action
NVAPI_DISPLAY_MUX_TRANSITION_FAILED | Dynamic Mux transition failure.
NVAPI_INVALID_DSC_VERSION | Invalid DSC version.
NVAPI_INVALID_DSC_SLICECOUNT | Invalid DSC slice count.
NVAPI_INVALID_DSC_OUTPUT_BPP | Invalid DSC output BPP.
NVAPI_FAILED_TO_LOAD_FROM_DRIVER_STORE | There was an error while loading nvapi.dll from the driver store.
NVAPI_NO_VULKAN | OpenGL does not export Vulkan fake extensions.
NVAPI_REQUEST_PENDING | A request for NvTOPPs telemetry CData has already been made and is pending a response.
NVAPI_RESOURCE_IN_USE | Operation cannot be performed because the resource is in use.
NVAPI_INVALID_IMAGE | Device kernel image is invalid.
NVAPI_INVALID_PTX | PTX JIT compilation failed.
NVAPI_NVLINK_UNCORRECTABLE | Uncorrectable NVLink error was detected during the execution.
NVAPI_JIT_COMPILER_NOT_FOUND | PTX JIT compiler library was not found.
NVAPI_INVALID_SOURCE | Device kernel source is invalid.
NVAPI_ILLEGAL_INSTRUCTION | While executing a kernel, the device encountered an illegal instruction.
NVAPI_INVALID_PC | While executing a kernel, the device program counter wrapped its address space.
NVAPI_LAUNCH_FAILED | An exception occurred on the device while executing a kernel.
NVAPI_NOT_PERMITTED | Attempted operation is not permitted.
NVAPI_CALLBACK_ALREADY_REGISTERED | The callback function has already been registered.
NVAPI_CALLBACK_NOT_FOUND | The callback function is not found or not registered.
NVAPI_INVALID_OUTPUT_WIRE_FORMAT | Invalid Wire Format for the VR HMD.


Data Structures | Macros | Typedefs | Functions
Graphics Driver APIs

Data Structures

struct | NV_DISPLAY_DRIVER_VERSION
struct | NV_DISPLAY_DRIVER_MEMORY_INFO_V1
struct | NV_DISPLAY_DRIVER_MEMORY_INFO_V2
struct | NV_DISPLAY_DRIVER_MEMORY_INFO_V3
struct | NV_GPU_MEMORY_INFO_EX_V1

Macros

#define | NV_DISPLAY_DRIVER_VERSION_VER MAKE_NVAPI_VERSION(NV_DISPLAY_DRIVER_VERSION,1)
#define | NV_DISPLAY_DRIVER_MEMORY_INFO_VER_1 MAKE_NVAPI_VERSION(NV_DISPLAY_DRIVER_MEMORY_INFO_V1,1)
#define | NV_DISPLAY_DRIVER_MEMORY_INFO_VER_2 MAKE_NVAPI_VERSION(NV_DISPLAY_DRIVER_MEMORY_INFO_V2,2)
#define | NV_DISPLAY_DRIVER_MEMORY_INFO_VER_3 MAKE_NVAPI_VERSION(NV_DISPLAY_DRIVER_MEMORY_INFO_V3,3)
#define | NV_DISPLAY_DRIVER_MEMORY_INFO_VER NV_DISPLAY_DRIVER_MEMORY_INFO_VER_3
#define | NV_GPU_MEMORY_INFO_EX_VER_1 MAKE_NVAPI_VERSION(NV_GPU_MEMORY_INFO_EX_V1,1)
#define | NV_GPU_MEMORY_INFO_EX_VER NV_GPU_MEMORY_INFO_EX_VER_1

Typedefs

typedef NV_DISPLAY_DRIVER_MEMORY_INFO_V3 | NV_DISPLAY_DRIVER_MEMORY_INFO
typedef NV_GPU_MEMORY_INFO_EX_V1 | NV_GPU_MEMORY_INFO_EX

Functions

__nvapi_deprecated_function ("Do not use this function - it is deprecated in release 290. Instead, use NvAPI_SYS_GetDriverAndBranchVersion.") NVAPI_INTERFACE NvAPI_GetDisplayDriverVersion(NvDisplayHandle hNvDisplay
NVAPI_INTERFACE | NvAPI_SYS_GetDriverAndBranchVersion (NvU32 *pDriverVersion, NvAPI_ShortString szBuildBranchString)
__nvapi_deprecated_function ("Do not use this function - it is deprecated in release 520. Instead, use NvAPI_GPU_GetMemoryInfoEx.") NVAPI_INTERFACE NvAPI_GPU_GetMemoryInfo(NvPhysicalGpuHandle hPhysicalGpu
NVAPI_INTERFACE | NvAPI_GPU_GetMemoryInfoEx (NvPhysicalGpuHandle hPhysicalGpu, NV_GPU_MEMORY_INFO_EX *pMemoryInfo)

Detailed Description

The display driver APIs are used to retrieve information about the display driver.

Macro Definition Documentation

◆ NV_DISPLAY_DRIVER_MEMORY_INFO_VER

#define NV_DISPLAY_DRIVER_MEMORY_INFO_VER NV_DISPLAY_DRIVER_MEMORY_INFO_VER_3

◆ NV_DISPLAY_DRIVER_MEMORY_INFO_VER_1

#define NV_DISPLAY_DRIVER_MEMORY_INFO_VER_1 MAKE_NVAPI_VERSION(NV_DISPLAY_DRIVER_MEMORY_INFO_V1,1)

Macro for constructing the version field of NV_DISPLAY_DRIVER_MEMORY_INFO_V1

◆ NV_DISPLAY_DRIVER_MEMORY_INFO_VER_2

#define NV_DISPLAY_DRIVER_MEMORY_INFO_VER_2 MAKE_NVAPI_VERSION(NV_DISPLAY_DRIVER_MEMORY_INFO_V2,2)

Macro for constructing the version field of NV_DISPLAY_DRIVER_MEMORY_INFO_V2

◆ NV_DISPLAY_DRIVER_MEMORY_INFO_VER_3

#define NV_DISPLAY_DRIVER_MEMORY_INFO_VER_3 MAKE_NVAPI_VERSION(NV_DISPLAY_DRIVER_MEMORY_INFO_V3,3)

Macro for constructing the version field of NV_DISPLAY_DRIVER_MEMORY_INFO_V3

◆ NV_DISPLAY_DRIVER_VERSION_VER

#define NV_DISPLAY_DRIVER_VERSION_VER MAKE_NVAPI_VERSION(NV_DISPLAY_DRIVER_VERSION,1)

◆ NV_GPU_MEMORY_INFO_EX_VER

#define NV_GPU_MEMORY_INFO_EX_VER NV_GPU_MEMORY_INFO_EX_VER_1

◆ NV_GPU_MEMORY_INFO_EX_VER_1

#define NV_GPU_MEMORY_INFO_EX_VER_1 MAKE_NVAPI_VERSION(NV_GPU_MEMORY_INFO_EX_V1,1)

Macro for constructing the version field of NV_GPU_MEMORY_INFO_EX_V1

Typedef Documentation

◆ NV_DISPLAY_DRIVER_MEMORY_INFO

typedef NV_DISPLAY_DRIVER_MEMORY_INFO_V3 NV_DISPLAY_DRIVER_MEMORY_INFO

◆ NV_GPU_MEMORY_INFO_EX

typedef NV_GPU_MEMORY_INFO_EX_V1 NV_GPU_MEMORY_INFO_EX

Function Documentation

◆ __nvapi_deprecated_function() [1/2]

__nvapi_deprecated_function | ( | "Do not use this function - it is deprecated in release 290. | Instead,
 |  | use NvAPI_SYS_GetDriverAndBranchVersion." |
 | ) |  |

◆ __nvapi_deprecated_function() [2/2]

__nvapi_deprecated_function | ( | "Do not use this function - it is deprecated in release 520. | Instead,
 |  | use NvAPI_GPU_GetMemoryInfoEx." |
 | ) |  |

DESCRIPTION: This function retrieves the available driver memory footprint for the specified GPU. If the GPU is in TCC Mode, only dedicatedVideoMemory will be returned in pMemoryInfo (NV_DISPLAY_DRIVER_MEMORY_INFO).

TCC_SUPPORTED

Since
Release: 177
Parameters
[in] | hPhysicalGpu | Handle of the physical GPU for which the memory information is to be extracted.
[out] | pMemoryInfo | The memory footprint available in the driver. See NV_DISPLAY_DRIVER_MEMORY_INFO.
Return values
NVAPI_INVALID_ARGUMENT | pMemoryInfo is NULL.
NVAPI_OK | Call successful.
NVAPI_NVIDIA_DEVICE_NOT_FOUND | No NVIDIA GPU driving a display was found.
NVAPI_INCOMPATIBLE_STRUCT_VERSION | NV_DISPLAY_DRIVER_MEMORY_INFO structure version mismatch.

◆ NvAPI_GPU_GetMemoryInfoEx()

NVAPI_INTERFACE NvAPI_GPU_GetMemoryInfoEx | ( | NvPhysicalGpuHandle | hPhysicalGpu,
 |  | NV_GPU_MEMORY_INFO_EX * | pMemoryInfo
 | ) |  |

DESCRIPTION: This function retrieves the available driver memory footprint for the specified GPU. If the GPU is in TCC Mode, only dedicatedVideoMemory will be returned in pMemoryInfo (NV_GPU_MEMORY_INFO_EX).

SUPPORTED OS: Windows 10 and higher

TCC_SUPPORTED

MCDM_SUPPORTED

Since
Release: 520
Parameters
[in] | hPhysicalGpu | Handle of the physical GPU for which the memory information is to be extracted.
[out] | pMemoryInfo | The memory footprint available in the driver. See NV_GPU_MEMORY_INFO_EX.
Return values
NVAPI_INVALID_ARGUMENT | pMemoryInfo is NULL.
NVAPI_OK | Call successful.
NVAPI_NVIDIA_DEVICE_NOT_FOUND | No NVIDIA GPU driving a display was found.
NVAPI_INCOMPATIBLE_STRUCT_VERSION | NV_GPU_MEMORY_INFO_EX structure version mismatch.

◆ NvAPI_SYS_GetDriverAndBranchVersion()

NVAPI_INTERFACE NvAPI_SYS_GetDriverAndBranchVersion | ( | NvU32 * | pDriverVersion,
 |  | NvAPI_ShortString | szBuildBranchString
 | ) |  |

DESCRIPTION: This API returns display driver version and driver-branch string.

SUPPORTED OS: Windows 7 and higher

Parameters
[out] | pDriverVersion | Contains the driver version after successful return.
[out] | szBuildBranchString | Contains the driver-branch string after successful return.
Return values
NVAPI_INVALID_ARGUMENT | either pDriverVersion is NULL or enum index too big
NVAPI_OK | - completed request
NVAPI_API_NOT_INTIALIZED | - NVAPI not initialized
NVAPI_ERROR | - miscellaneous error occurred


Data Fields
NV_DISPLAY_DRIVER_VERSION Struct Reference
Graphics Driver APIs

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 drvVersion
NvU32 bldChangeListNum
NvAPI_ShortString szBuildBranchString
NvAPI_ShortString szAdapterString

Detailed Description

Used in NvAPI_GetDisplayDriverVersion()

The documentation for this struct was generated from the following file:
  • nvapi.h


Main Page

Related Pages

Topics

Data Structures

Files

Modules | Data Structures | Macros | Typedefs | Enumerations | Enumerator | Functions | Variables

Video Input/Output Interface
Video APIs

Modules

Stereoscopic 3D APIs

Driver Settings (DRS) APIs

System - General Interface <br>

Data Structures

struct

_NV_PIXEL_SRSO_1x2::NV_PIXEL_SRSO_1x2_X1

struct

_NV_PIXEL_SRSO_1x2::NV_PIXEL_SRSO_1x2_X2

struct

_NV_PIXEL_SRSO_1x2::NV_PIXEL_SRSO_1x2_X4

struct

_NV_PIXEL_SRSO_1x2::NV_PIXEL_SRSO_1x2_X8

struct

_NV_PIXEL_SRSO_2x1::NV_PIXEL_SRSO_2x1_X1

struct

_NV_PIXEL_SRSO_2x1::NV_PIXEL_SRSO_2x1_X2

struct

_NV_PIXEL_SRSO_2x1::NV_PIXEL_SRSO_2x1_X4

struct

_NV_PIXEL_SRSO_2x2::NV_PIXEL_SRSO_2x2_X1

struct

_NV_PIXEL_SRSO_2x2::NV_PIXEL_SRSO_2x2_X2

struct

_NV_PIXEL_SRSO_2x2::NV_PIXEL_SRSO_2x2_X4

struct

_NV_PIXEL_SRSO_2x4::NV_PIXEL_SRSO_2x4_X1

struct

_NV_PIXEL_SRSO_2x4::NV_PIXEL_SRSO_2x4_X2

struct

_NV_PIXEL_SRSO_4x2::NV_PIXEL_SRSO_4x2_X1

struct

_NV_PIXEL_SRSO_4x4::NV_PIXEL_SRSO_4x4_X1

struct

_NV_LATENCY_RESULT_PARAMS::FrameReport

struct

_NVVIOCAPS

struct

_NVVIOCHANNELSTATUS

struct

_NVVIOINPUTSTATUS

struct

_NVVIOOUTPUTSTATUS

struct

_NVVIOSTATUS

struct

_NVVIOOUTPUTREGION

struct

_NVVIOGAMMARAMP8

struct

_NVVIOGAMMARAMP10

struct

_NVVIOSYNCDELAY

struct

_NVVIOVIDEOMODE

struct

_NVVIOSIGNALFORMATDETAIL

struct

_NVVIODATAFORMATDETAIL

struct

_NVVIOCOLORCONVERSION

struct

_NVVIOGAMMACORRECTION

struct

_NVVIOCOMPOSITERANGE

struct

_NVVIOOUTPUTCONFIG_V1

struct

_NVVIOOUTPUTCONFIG_V2

struct

_NVVIOOUTPUTCONFIG_V3

struct

_NVVIOSTREAM

struct

_NVVIOINPUTCONFIG

struct

_NVVIOCONFIG_V1

struct

_NVVIOCONFIG_V2

struct

_NVVIOCONFIG_V3

struct

NVVIOTOPOLOGYTARGET

struct

_NV_VIO_TOPOLOGY

struct

_NVVIOPCIINFO

struct

NV_LID_DOCK_PARAMS

struct

_NV_DISPLAY_DRIVER_INFO

struct

_NV_DISPLAY_DRIVER_INFO_V2

struct

_NV_PHYSICAL_GPU_HANDLE_DATA

struct

_NV_PHYSICAL_GPUS

struct

_NV_LOGICAL_GPU_HANDLE_DATA

struct

_NV_LOGICAL_GPUS

struct

_NV_CLIENT_CALLBACK_SETTINGS_SUPER_V1

struct

_NV_GPU_CLIENT_PERIODIC_CALLBACK_SETTINGS_SUPER_V1

struct

_NV_GPU_CLIENT_CALLBACK_DATA_SUPER_V1

struct

_NV_GPU_CLIENT_UTILIZATION_DATA_V1

struct

_NV_GPU_CLIENT_CALLBACK_UTILIZATION_DATA_V1

struct

_NV_GPU_CLIENT_UTILIZATION_PERIODIC_CALLBACK_SETTINGS_V1

Macros

#define

NVVIOOWNERID_NONE 0

#define

NVVIO_O_READ 0x00000000

#define

NVVIO_O_WRITE_EXCLUSIVE 0x00010001

#define

NVVIO_VALID_ACCESSRIGHTS

#define

NVVIO_OWNERID_INITIALIZED 0x80000000

#define

NVVIO_OWNERID_EXCLUSIVE 0x40000000

#define

NVVIO_OWNERID_TYPEMASK 0x0FFFFFFF

#define

NVAPI_MAX_VIO_DEVICES 8

#define

NVAPI_MAX_VIO_JACKS 4

#define

NVAPI_MAX_VIO_CHANNELS_PER_JACK 2

#define

NVAPI_MAX_VIO_STREAMS 4

#define

NVAPI_MIN_VIO_STREAMS 1

#define

NVAPI_MAX_VIO_LINKS_PER_STREAM 2

#define

NVAPI_MAX_FRAMELOCK_MAPPING_MODES 20

#define

NVAPI_GVI_MIN_RAW_CAPTURE_IMAGES 1

#define

NVAPI_GVI_MAX_RAW_CAPTURE_IMAGES 32

#define

NVAPI_GVI_DEFAULT_RAW_CAPTURE_IMAGES 5

#define

NVVIOCAPS_VIDOUT_SDI 0x00000001

#define

NVVIOCAPS_SYNC_INTERNAL 0x00000100

#define

NVVIOCAPS_SYNC_GENLOCK 0x00000200

#define

NVVIOCAPS_SYNCSRC_SDI 0x00001000

#define

NVVIOCAPS_SYNCSRC_COMP 0x00002000

#define

NVVIOCAPS_OUTPUTMODE_DESKTOP 0x00010000

#define

NVVIOCAPS_OUTPUTMODE_OPENGL 0x00020000

#define

NVVIOCAPS_VIDIN_SDI 0x00100000

#define

NVVIOCAPS_PACKED_ANC_SUPPORTED 0x00200000

#define

NVVIOCAPS_AUDIO_BLANKING_SUPPORTED 0x00400000

#define

NVVIOCLASS_SDI 0x00000001

#define

NVVIOCAPS_VER1 MAKE_NVAPI_VERSION(NVVIOCAPS,1)

#define

NVVIOCAPS_VER2 MAKE_NVAPI_VERSION(NVVIOCAPS,2)

#define

NVVIOCAPS_VER NVVIOCAPS_VER2

#define

NVVIOSTATUS_VER MAKE_NVAPI_VERSION(NVVIOSTATUS,1)

#define

NVVIOSYNCDELAY_VER MAKE_NVAPI_VERSION(NVVIOSYNCDELAY,1)

#define

NVVIOBUFFERFORMAT_R8G8B8 0x00000001

#define

NVVIOBUFFERFORMAT_R8G8B8Z24 0x00000002

#define

NVVIOBUFFERFORMAT_R8G8B8A8 0x00000004

#define

NVVIOBUFFERFORMAT_R8G8B8A8Z24 0x00000008

#define

NVVIOBUFFERFORMAT_R16FPG16FPB16FP 0x00000010

#define

NVVIOBUFFERFORMAT_R16FPG16FPB16FPZ24 0x00000020

#define

NVVIOBUFFERFORMAT_R16FPG16FPB16FPA16FP 0x00000040

#define

NVVIOBUFFERFORMAT_R16FPG16FPB16FPA16FPZ24 0x00000080

#define

NVVIOCOLORCONVERSION_VER MAKE_NVAPI_VERSION(NVVIOCOLORCONVERSION,1)

#define

NVVIOGAMMACORRECTION_VER MAKE_NVAPI_VERSION(NVVIOGAMMACORRECTION,1)

#define

MAX_NUM_COMPOSITE_RANGE 2

#define

NVVIOCONFIG_SIGNALFORMAT 0x00000001

#define

NVVIOCONFIG_DATAFORMAT 0x00000002

#define

NVVIOCONFIG_OUTPUTREGION 0x00000004

#define

NVVIOCONFIG_OUTPUTAREA 0x00000008

#define

NVVIOCONFIG_COLORCONVERSION 0x00000010

#define

NVVIOCONFIG_GAMMACORRECTION 0x00000020

#define

NVVIOCONFIG_SYNCSOURCEENABLE 0x00000040

#define

NVVIOCONFIG_SYNCDELAY 0x00000080

#define

NVVIOCONFIG_COMPOSITESYNCTYPE 0x00000100

#define

NVVIOCONFIG_FRAMELOCKENABLE 0x00000200

#define

NVVIOCONFIG_422FILTER 0x00000400

#define

NVVIOCONFIG_COMPOSITETERMINATE 0x00000800

#define

NVVIOCONFIG_DATAINTEGRITYCHECK 0x00001000

#define

NVVIOCONFIG_CSCOVERRIDE 0x00002000

#define

NVVIOCONFIG_FLIPQUEUELENGTH 0x00004000

#define

NVVIOCONFIG_ANCTIMECODEGENERATION 0x00008000

#define

NVVIOCONFIG_COMPOSITE 0x00010000

#define

NVVIOCONFIG_ALPHAKEYCOMPOSITE 0x00020000

#define

NVVIOCONFIG_COMPOSITE_Y 0x00040000

#define

NVVIOCONFIG_COMPOSITE_CR 0x00080000

#define

NVVIOCONFIG_COMPOSITE_CB 0x00100000

#define

NVVIOCONFIG_FULL_COLOR_RANGE 0x00200000

#define

NVVIOCONFIG_RGB_DATA 0x00400000

#define

NVVIOCONFIG_RESERVED_SDIOUTPUTENABLE 0x00800000

#define

NVVIOCONFIG_STREAMS 0x01000000

#define

NVVIOCONFIG_ANC_PARITY_COMPUTATION 0x02000000

#define

NVVIOCONFIG_ANC_AUDIO_REPEAT 0x04000000

#define

NVVIOCONFIG_ALLFIELDS

#define

NVVIOCONFIG_VALIDFIELDS

#define

NVVIOCONFIG_DRIVERFIELDS

#define

NVVIOCONFIG_GAMMAFIELDS ( NVVIOCONFIG_GAMMACORRECTION )

#define

NVVIOCONFIG_RMCTRLFIELDS

#define

NVVIOCONFIG_RMSKEWFIELDS ( NVVIOCONFIG_SYNCDELAY )

#define

NVVIOCONFIG_ALLOWSDIRUNNING_FIELDS

#define

NVVIOCONFIG_RMMODESET_FIELDS

#define

NVVIOCONFIG_VER1 MAKE_NVAPI_VERSION(NVVIOCONFIG_V1,1)

#define

NVVIOCONFIG_VER2 MAKE_NVAPI_VERSION(NVVIOCONFIG_V2,2)

#define

NVVIOCONFIG_VER3 MAKE_NVAPI_VERSION(NVVIOCONFIG_V3,3)

#define

NVVIOCONFIG_VER NVVIOCONFIG_VER3

#define

NV_VIO_TOPOLOGY_VER MAKE_NVAPI_VERSION(NV_VIO_TOPOLOGY,1)

#define

NVVIOTOPOLOGY_VER MAKE_NVAPI_VERSION(NVVIOTOPOLOGY,1)

#define

NVVIOPCIINFO_VER1 MAKE_NVAPI_VERSION(NVVIOPCIINFO_V1,1)

#define

NVVIOPCIINFO_VER NVVIOPCIINFO_VER1

#define

NV_LID_DOCK_PARAMS_VER MAKE_NVAPI_VERSION(NV_LID_DOCK_PARAMS,1)

#define

NV_DISPLAY_DRIVER_INFO_VER1 MAKE_NVAPI_VERSION(NV_DISPLAY_DRIVER_INFO_V1, 1)

#define

NV_DISPLAY_DRIVER_INFO_VER2 MAKE_NVAPI_VERSION(NV_DISPLAY_DRIVER_INFO_V2, 2)

#define

NV_DISPLAY_DRIVER_INFO_VER NV_DISPLAY_DRIVER_INFO_VER2

#define

NV_PHYSICAL_GPUS_VER1 MAKE_NVAPI_VERSION(NV_PHYSICAL_GPUS_V1, 1)

#define

NV_PHYSICAL_GPUS_VER NV_PHYSICAL_GPUS_VER1

#define

NV_LOGICAL_GPUS_VER1 MAKE_NVAPI_VERSION(NV_LOGICAL_GPUS_V1, 1)

#define

NV_LOGICAL_GPUS_VER NV_LOGICAL_GPUS_VER1

#define

NV_GPU_CLIENT_UTIL_DOMAINS_MAX_V1 (4)

#define

NV_GPU_CLIENT_UTILIZATION_PERIODIC_CALLBACK_SETTINGS_VER1 MAKE_NVAPI_VERSION(NV_GPU_CLIENT_UTILIZATION_PERIODIC_CALLBACK_SETTINGS_V1, 1)

#define

NV_GPU_CLIENT_UTILIZATION_PERIODIC_CALLBACK_SETTINGS_VER NV_GPU_CLIENT_UTILIZATION_PERIODIC_CALLBACK_SETTINGS_VER1

Typedefs

typedef NvU32

NVVIOOWNERID

typedef enum _NVVIOOWNERTYPE

NVVIOOWNERTYPE

typedef enum _NVVIOSIGNALFORMAT

NVVIOSIGNALFORMAT

typedef enum _NVVIOVIDEOSTANDARD

NVVIOVIDEOSTANDARD

typedef enum _NVVIOVIDEOTYPE

NVVIOVIDEOTYPE

typedef enum _NVVIOINTERLACEMODE

NVVIOINTERLACEMODE

typedef enum _NVVIODATAFORMAT

NVVIODATAFORMAT

typedef enum _NVVIOOUTPUTAREA

NVVIOOUTPUTAREA

typedef enum _NVVIOSYNCSOURCE

NVVIOSYNCSOURCE

typedef enum _NVVIOCOMPSYNCTYPE

NVVIOCOMPSYNCTYPE

typedef enum _NVVIOINPUTOUTPUTSTATUS

NVVIOINPUTOUTPUTSTATUS

typedef enum _NVVIOSYNCSTATUS

NVVIOSYNCSTATUS

typedef enum _NVVIOCAPTURESTATUS

NVVIOCAPTURESTATUS

typedef enum _NVVIOSTATUSTYPE

NVVIOSTATUSTYPE

typedef enum _NVVIOCONFIGTYPE

NVVIOCONFIGTYPE

typedef enum _NVVIOCOLORSPACE

NVVIOCOLORSPACE

typedef enum _NVVIOCOMPONENTSAMPLING

NVVIOCOMPONENTSAMPLING

typedef enum _NVVIOBITSPERCOMPONENT

NVVIOBITSPERCOMPONENT

typedef enum _NVVIOLINKID

NVVIOLINKID

typedef enum _NVVIOANCPARITYCOMPUTATION

NVVIOANCPARITYCOMPUTATION

typedef struct _NVVIOCAPS

NVVIOCAPS

typedef struct _NVVIOCHANNELSTATUS

NVVIOCHANNELSTATUS

typedef struct _NVVIOINPUTSTATUS

NVVIOINPUTSTATUS

typedef struct _NVVIOOUTPUTSTATUS

NVVIOOUTPUTSTATUS

typedef struct _NVVIOSTATUS

NVVIOSTATUS

typedef struct _NVVIOOUTPUTREGION

NVVIOOUTPUTREGION

typedef struct _NVVIOGAMMARAMP8

NVVIOGAMMARAMP8

typedef struct _NVVIOGAMMARAMP10

NVVIOGAMMARAMP10

typedef struct _NVVIOSYNCDELAY

NVVIOSYNCDELAY

typedef struct _NVVIOVIDEOMODE

NVVIOVIDEOMODE

typedef struct _NVVIOSIGNALFORMATDETAIL

NVVIOSIGNALFORMATDETAIL

typedef struct _NVVIODATAFORMATDETAIL

NVVIODATAFORMATDETAIL

typedef struct _NVVIOCOLORCONVERSION

NVVIOCOLORCONVERSION

typedef struct _NVVIOGAMMACORRECTION

NVVIOGAMMACORRECTION

typedef struct _NVVIOCOMPOSITERANGE

NVVIOCOMPOSITERANGE

typedef struct _NVVIOOUTPUTCONFIG_V1

NVVIOOUTPUTCONFIG_V1

typedef struct _NVVIOOUTPUTCONFIG_V2

NVVIOOUTPUTCONFIG_V2

typedef struct _NVVIOOUTPUTCONFIG_V3

NVVIOOUTPUTCONFIG_V3

typedef struct _NVVIOSTREAM

NVVIOSTREAM

typedef struct _NVVIOINPUTCONFIG

NVVIOINPUTCONFIG

typedef struct _NVVIOCONFIG_V1

NVVIOCONFIG_V1

typedef struct _NVVIOCONFIG_V2

NVVIOCONFIG_V2

typedef struct _NVVIOCONFIG_V3

NVVIOCONFIG_V3

typedef NVVIOOUTPUTCONFIG_V3

NVVIOOUTPUTCONFIG

typedef NVVIOCONFIG_V3

NVVIOCONFIG

typedef struct _NV_VIO_TOPOLOGY

NV_VIO_TOPOLOGY

typedef struct _NV_VIO_TOPOLOGY

NVVIOTOPOLOGY

typedef enum _NVVIOPCILINKRATE

NVVIOPCILINKRATE

typedef enum _NVVIOPCILINKWIDTH

NVVIOPCILINKWIDTH

typedef struct _NVVIOPCIINFO

NVVIOPCIINFO_V1

typedef NVVIOPCIINFO_V1

NVVIOPCIINFO

typedef struct _NV_DISPLAY_DRIVER_INFO

NV_DISPLAY_DRIVER_INFO_V1

typedef struct _NV_DISPLAY_DRIVER_INFO_V2

NV_DISPLAY_DRIVER_INFO_V2

typedef NV_DISPLAY_DRIVER_INFO_V2

NV_DISPLAY_DRIVER_INFO

typedef struct _NV_PHYSICAL_GPU_HANDLE_DATA

NV_PHYSICAL_GPU_HANDLE_DATA

typedef struct _NV_PHYSICAL_GPUS

NV_PHYSICAL_GPUS_V1

typedef NV_PHYSICAL_GPUS_V1

NV_PHYSICAL_GPUS

typedef struct _NV_LOGICAL_GPU_HANDLE_DATA

NV_LOGICAL_GPU_HANDLE_DATA

typedef struct _NV_LOGICAL_GPUS

NV_LOGICAL_GPUS_V1

typedef NV_LOGICAL_GPUS_V1

NV_LOGICAL_GPUS

typedef struct _NV_CLIENT_CALLBACK_SETTINGS_SUPER_V1

NV_CLIENT_CALLBACK_SETTINGS_SUPER_V1

typedef NV_CLIENT_CALLBACK_SETTINGS_SUPER_V1

NV_GPU_CLIENT_CALLBACK_SETTINGS_SUPER_V1

typedef struct _NV_GPU_CLIENT_PERIODIC_CALLBACK_SETTINGS_SUPER_V1

NV_GPU_CLIENT_PERIODIC_CALLBACK_SETTINGS_SUPER_V1

typedef struct _NV_GPU_CLIENT_CALLBACK_DATA_SUPER_V1

NV_GPU_CLIENT_CALLBACK_DATA_SUPER_V1

typedef enum _NV_GPU_CLIENT_UTIL_DOMAIN_ID

NV_GPU_CLIENT_UTIL_DOMAIN_ID

typedef struct _NV_GPU_CLIENT_UTILIZATION_DATA_V1

NV_GPU_CLIENT_UTILIZATION_DATA_V1

typedef struct _NV_GPU_CLIENT_CALLBACK_UTILIZATION_DATA_V1

NV_GPU_CLIENT_CALLBACK_UTILIZATION_DATA_V1

typedef void(__cdecl *

NV_GPU_CLIENT_UTILIZATION_PERIODIC_CALLBACK_V1) (NvPhysicalGpuHandle hPhysicalGpu, NV_GPU_CLIENT_CALLBACK_UTILIZATION_DATA_V1 *pData)

typedef struct _NV_GPU_CLIENT_UTILIZATION_PERIODIC_CALLBACK_SETTINGS_V1

NV_GPU_CLIENT_UTILIZATION_PERIODIC_CALLBACK_SETTINGS_V1

typedef NV_GPU_CLIENT_UTILIZATION_PERIODIC_CALLBACK_SETTINGS_V1

NV_GPU_CLIENT_UTILIZATION_PERIODIC_CALLBACK_SETTINGS

Enumerations

enum

_NVVIOOWNERTYPE { NVVIOOWNERTYPE_NONE , NVVIOOWNERTYPE_APPLICATION , NVVIOOWNERTYPE_DESKTOP }

enum

_NVVIOSIGNALFORMAT {
NVVIOSIGNALFORMAT_NONE , NVVIOSIGNALFORMAT_487I_59_94_SMPTE259_NTSC , NVVIOSIGNALFORMAT_576I_50_00_SMPTE259_PAL , NVVIOSIGNALFORMAT_1035I_60_00_SMPTE260 ,
NVVIOSIGNALFORMAT_1035I_59_94_SMPTE260 , NVVIOSIGNALFORMAT_1080I_50_00_SMPTE295 , NVVIOSIGNALFORMAT_1080I_60_00_SMPTE274 , NVVIOSIGNALFORMAT_1080I_59_94_SMPTE274 ,
NVVIOSIGNALFORMAT_1080I_50_00_SMPTE274 , NVVIOSIGNALFORMAT_1080P_30_00_SMPTE274 , NVVIOSIGNALFORMAT_1080P_29_97_SMPTE274 , NVVIOSIGNALFORMAT_1080P_25_00_SMPTE274 ,
NVVIOSIGNALFORMAT_1080P_24_00_SMPTE274 , NVVIOSIGNALFORMAT_1080P_23_976_SMPTE274 , NVVIOSIGNALFORMAT_720P_60_00_SMPTE296 , NVVIOSIGNALFORMAT_720P_59_94_SMPTE296 ,
NVVIOSIGNALFORMAT_720P_50_00_SMPTE296 , NVVIOSIGNALFORMAT_1080I_48_00_SMPTE274 , NVVIOSIGNALFORMAT_1080I_47_96_SMPTE274 , NVVIOSIGNALFORMAT_720P_30_00_SMPTE296 ,
NVVIOSIGNALFORMAT_720P_29_97_SMPTE296 , NVVIOSIGNALFORMAT_720P_25_00_SMPTE296 , NVVIOSIGNALFORMAT_720P_24_00_SMPTE296 , NVVIOSIGNALFORMAT_720P_23_98_SMPTE296 ,
NVVIOSIGNALFORMAT_2048P_30_00_SMPTE372 , NVVIOSIGNALFORMAT_2048P_29_97_SMPTE372 , NVVIOSIGNALFORMAT_2048I_60_00_SMPTE372 , NVVIOSIGNALFORMAT_2048I_59_94_SMPTE372 ,
NVVIOSIGNALFORMAT_2048P_25_00_SMPTE372 , NVVIOSIGNALFORMAT_2048I_50_00_SMPTE372 , NVVIOSIGNALFORMAT_2048P_24_00_SMPTE372 , NVVIOSIGNALFORMAT_2048P_23_98_SMPTE372 ,
NVVIOSIGNALFORMAT_2048I_48_00_SMPTE372 , NVVIOSIGNALFORMAT_2048I_47_96_SMPTE372 , NVVIOSIGNALFORMAT_1080PSF_25_00_SMPTE274 , NVVIOSIGNALFORMAT_1080PSF_29_97_SMPTE274 ,
NVVIOSIGNALFORMAT_1080PSF_30_00_SMPTE274 , NVVIOSIGNALFORMAT_1080PSF_24_00_SMPTE274 , NVVIOSIGNALFORMAT_1080PSF_23_98_SMPTE274 , NVVIOSIGNALFORMAT_1080P_50_00_SMPTE274_3G_LEVEL_A ,
NVVIOSIGNALFORMAT_1080P_59_94_SMPTE274_3G_LEVEL_A , NVVIOSIGNALFORMAT_1080P_60_00_SMPTE274_3G_LEVEL_A , NVVIOSIGNALFORMAT_1080P_60_00_SMPTE274_3G_LEVEL_B , NVVIOSIGNALFORMAT_1080I_60_00_SMPTE274_3G_LEVEL_B ,
NVVIOSIGNALFORMAT_2048I_60_00_SMPTE372_3G_LEVEL_B , NVVIOSIGNALFORMAT_1080P_50_00_SMPTE274_3G_LEVEL_B , NVVIOSIGNALFORMAT_1080I_50_00_SMPTE274_3G_LEVEL_B , NVVIOSIGNALFORMAT_2048I_50_00_SMPTE372_3G_LEVEL_B ,
NVVIOSIGNALFORMAT_1080P_30_00_SMPTE274_3G_LEVEL_B , NVVIOSIGNALFORMAT_2048P_30_00_SMPTE372_3G_LEVEL_B , NVVIOSIGNALFORMAT_1080P_25_00_SMPTE274_3G_LEVEL_B , NVVIOSIGNALFORMAT_2048P_25_00_SMPTE372_3G_LEVEL_B ,
NVVIOSIGNALFORMAT_1080P_24_00_SMPTE274_3G_LEVEL_B , NVVIOSIGNALFORMAT_2048P_24_00_SMPTE372_3G_LEVEL_B , NVVIOSIGNALFORMAT_1080I_48_00_SMPTE274_3G_LEVEL_B , NVVIOSIGNALFORMAT_2048I_48_00_SMPTE372_3G_LEVEL_B ,
NVVIOSIGNALFORMAT_1080P_59_94_SMPTE274_3G_LEVEL_B , NVVIOSIGNALFORMAT_1080I_59_94_SMPTE274_3G_LEVEL_B , NVVIOSIGNALFORMAT_2048I_59_94_SMPTE372_3G_LEVEL_B , NVVIOSIGNALFORMAT_1080P_29_97_SMPTE274_3G_LEVEL_B ,
NVVIOSIGNALFORMAT_2048P_29_97_SMPTE372_3G_LEVEL_B , NVVIOSIGNALFORMAT_1080P_23_98_SMPTE274_3G_LEVEL_B , NVVIOSIGNALFORMAT_2048P_23_98_SMPTE372_3G_LEVEL_B , NVVIOSIGNALFORMAT_1080I_47_96_SMPTE274_3G_LEVEL_B ,
NVVIOSIGNALFORMAT_2048I_47_96_SMPTE372_3G_LEVEL_B , NVVIOSIGNALFORMAT_END
}

enum

_NVVIOVIDEOSTANDARD {
NVVIOVIDEOSTANDARD_SMPTE259 , NVVIOVIDEOSTANDARD_SMPTE260 , NVVIOVIDEOSTANDARD_SMPTE274 , NVVIOVIDEOSTANDARD_SMPTE295 ,
NVVIOVIDEOSTANDARD_SMPTE296 , NVVIOVIDEOSTANDARD_SMPTE372
}

enum

_NVVIOVIDEOTYPE { NVVIOVIDEOTYPE_SD , NVVIOVIDEOTYPE_HD }

enum

_NVVIOINTERLACEMODE { NVVIOINTERLACEMODE_PROGRESSIVE , NVVIOINTERLACEMODE_INTERLACE , NVVIOINTERLACEMODE_PSF }

enum

_NVVIODATAFORMAT {
NVVIODATAFORMAT_UNKNOWN = -1 , NVVIODATAFORMAT_R8G8B8_TO_YCRCB444 , NVVIODATAFORMAT_R8G8B8A8_TO_YCRCBA4444 , NVVIODATAFORMAT_R8G8B8Z10_TO_YCRCBZ4444 ,
NVVIODATAFORMAT_R8G8B8_TO_YCRCB422 , NVVIODATAFORMAT_R8G8B8A8_TO_YCRCBA4224 , NVVIODATAFORMAT_R8G8B8Z10_TO_YCRCBZ4224 , NVVIODATAFORMAT_X8X8X8_444_PASSTHRU ,
NVVIODATAFORMAT_X8X8X8A8_4444_PASSTHRU , NVVIODATAFORMAT_X8X8X8Z10_4444_PASSTHRU , NVVIODATAFORMAT_X10X10X10_444_PASSTHRU , NVVIODATAFORMAT_X10X8X8_444_PASSTHRU ,
NVVIODATAFORMAT_X10X8X8A10_4444_PASSTHRU , NVVIODATAFORMAT_X10X8X8Z10_4444_PASSTHRU , NVVIODATAFORMAT_DUAL_R8G8B8_TO_DUAL_YCRCB422 , NVVIODATAFORMAT_DUAL_X8X8X8_TO_DUAL_422_PASSTHRU ,
NVVIODATAFORMAT_R10G10B10_TO_YCRCB422 , NVVIODATAFORMAT_R10G10B10_TO_YCRCB444 , NVVIODATAFORMAT_X12X12X12_444_PASSTHRU , NVVIODATAFORMAT_X12X12X12_422_PASSTHRU ,
NVVIODATAFORMAT_Y10CR10CB10_TO_YCRCB422 , NVVIODATAFORMAT_Y8CR8CB8_TO_YCRCB422 , NVVIODATAFORMAT_Y10CR8CB8A10_TO_YCRCBA4224 , NVVIODATAFORMAT_R10G10B10_TO_RGB444 ,
NVVIODATAFORMAT_R12G12B12_TO_YCRCB444 , NVVIODATAFORMAT_R12G12B12_TO_YCRCB422
}

enum

_NVVIOOUTPUTAREA { NVVIOOUTPUTAREA_FULLSIZE , NVVIOOUTPUTAREA_SAFEACTION , NVVIOOUTPUTAREA_SAFETITLE }

enum

_NVVIOSYNCSOURCE { NVVIOSYNCSOURCE_SDISYNC , NVVIOSYNCSOURCE_COMPSYNC }

enum

_NVVIOCOMPSYNCTYPE { NVVIOCOMPSYNCTYPE_AUTO , NVVIOCOMPSYNCTYPE_BILEVEL , NVVIOCOMPSYNCTYPE_TRILEVEL }

enum

_NVVIOINPUTOUTPUTSTATUS { NVINPUTOUTPUTSTATUS_OFF , NVINPUTOUTPUTSTATUS_ERROR , NVINPUTOUTPUTSTATUS_SDI_SD , NVINPUTOUTPUTSTATUS_SDI_HD }

enum

_NVVIOSYNCSTATUS {
NVVIOSYNCSTATUS_OFF , NVVIOSYNCSTATUS_ERROR , NVVIOSYNCSTATUS_SYNCLOSS , NVVIOSYNCSTATUS_COMPOSITE ,
NVVIOSYNCSTATUS_SDI_SD , NVVIOSYNCSTATUS_SDI_HD
}

enum

_NVVIOCAPTURESTATUS { NVVIOSTATUS_STOPPED , NVVIOSTATUS_RUNNING , NVVIOSTATUS_ERROR }

enum

_NVVIOSTATUSTYPE { NVVIOSTATUSTYPE_IN , NVVIOSTATUSTYPE_OUT }

enum

_NVVIOCONFIGTYPE { NVVIOCONFIGTYPE_IN , NVVIOCONFIGTYPE_OUT }

enum

_NVVIOCOLORSPACE {
NVVIOCOLORSPACE_UNKNOWN , NVVIOCOLORSPACE_YCBCR , NVVIOCOLORSPACE_YCBCRA , NVVIOCOLORSPACE_YCBCRD ,
NVVIOCOLORSPACE_GBR , NVVIOCOLORSPACE_GBRA , NVVIOCOLORSPACE_GBRD
}

enum

_NVVIOCOMPONENTSAMPLING {
NVVIOCOMPONENTSAMPLING_UNKNOWN , NVVIOCOMPONENTSAMPLING_4444 , NVVIOCOMPONENTSAMPLING_4224 , NVVIOCOMPONENTSAMPLING_444 ,
NVVIOCOMPONENTSAMPLING_422
}

enum

_NVVIOBITSPERCOMPONENT { NVVIOBITSPERCOMPONENT_UNKNOWN , NVVIOBITSPERCOMPONENT_8 , NVVIOBITSPERCOMPONENT_10 , NVVIOBITSPERCOMPONENT_12 }

enum

_NVVIOLINKID {
NVVIOLINKID_UNKNOWN , NVVIOLINKID_A , NVVIOLINKID_B , NVVIOLINKID_C ,
NVVIOLINKID_D
}

enum

_NVVIOANCPARITYCOMPUTATION { NVVIOANCPARITYCOMPUTATION_AUTO , NVVIOANCPARITYCOMPUTATION_ON , NVVIOANCPARITYCOMPUTATION_OFF }

enum

_NVVIOPCILINKRATE { NVVIOPCILINKRATE_UNKNOWN = 0 , NVVIOPCILINKRATE_GEN1 = 1 , NVVIOPCILINKRATE_GEN2 = 2 , NVVIOPCILINKRATE_GEN3 = 3 }

enum

_NVVIOPCILINKWIDTH {
NVVIOPCILINKWIDTH_UNKNOWN = 0 , NVVIOPCILINKWIDTH_x1 = 1 , NVVIOPCILINKWIDTH_x2 = 2 , NVVIOPCILINKWIDTH_x4 = 4 ,
NVVIOPCILINKWIDTH_x8 = 8 , NVVIOPCILINKWIDTH_x16 = 16
}

enum

_NV_GPU_CLIENT_UTIL_DOMAIN_ID { NV_GPU_CLIENT_UTIL_DOMAIN_GRAPHICS = 0 , NV_GPU_CLIENT_UTIL_DOMAIN_FRAME_BUFFER = 1 , NV_GPU_CLIENT_UTIL_DOMAIN_VIDEO = 2 , NV_GPU_CLIENT_UTIL_DOMAIN_RSVD = 3 }

Functions

virtual bool

INvAPI_DirectD3D12GraphicsCommandList::IsValid () const =0

virtual ID3D12GraphicsCommandList *

INvAPI_DirectD3D12GraphicsCommandList::GetID3D12GraphicsCommandList () const =0

void

INvAPI_DirectD3D12GraphicsCommandList::DispatchGraphics (NvU32 numDispatches)

void

INvAPI_DirectD3D12GraphicsCommandList::SetMarker (void *pMarkerData, NvU32 markerSize)

__nvapi_deprecated_function ("Do not use this function - it is deprecated in release 440.") NVAPI_INTERFACE NvAPI_VIO_GetCapabilities(NvVioHandle hVioHandle

__nvapi_deprecated_function ("Do not use this function - it is deprecated in release 290. Instead, use NvAPI_VIO_SetConfig.") NVAPI_INTERFACE NvAPI_VIO_SetCSC(NvVioHandle hVioHandle

__nvapi_deprecated_function ("Do not use this function - it is deprecated in release 290. Instead, use NvAPI_VIO_GetConfig.") NVAPI_INTERFACE NvAPI_VIO_GetCSC(NvVioHandle hVioHandle

NVAPI_INTERFACE

NvAPI_GPU_ClientRegisterForUtilizationSampleUpdates (__in NvPhysicalGpuHandle hPhysicalGpu, __in NV_GPU_CLIENT_UTILIZATION_PERIODIC_CALLBACK_SETTINGS *pCallbackSettings)

Variables

NvU32

NV_EDID_V1::version

NvU8

NV_EDID_V1::EDID_Data [NV_EDID_DATA_SIZE]

NvU32

NV_EDID_V2::version

NvU8

NV_EDID_V2::EDID_Data [NV_EDID_DATA_SIZE]

NvU32

NV_EDID_V2::sizeofEDID

NvU32

NV_EDID_V3::version

NvU8

NV_EDID_V3::EDID_Data [NV_EDID_DATA_SIZE]

NvU32

NV_EDID_V3::sizeofEDID

NvU32

NV_EDID_V3::edidId

NvU32

NV_EDID_V3::offset

float

NV_VIEWPORTF::x

float

NV_VIEWPORTF::y

float

NV_VIEWPORTF::w

float

NV_VIEWPORTF::h

NvU32

tagNV_TIMINGEXT::flag

NvU16

tagNV_TIMINGEXT::rr

NvU32

tagNV_TIMINGEXT::rrx1k

NvU32

tagNV_TIMINGEXT::aspect

NvU16

tagNV_TIMINGEXT::rep

NvU32

tagNV_TIMINGEXT::status

NvU8

tagNV_TIMINGEXT::name [40]

NvU16

_NV_TIMING::HVisible

NvU16

_NV_TIMING::HBorder

NvU16

_NV_TIMING::HFrontPorch

NvU16

_NV_TIMING::HSyncWidth

NvU16

_NV_TIMING::HTotal

NvU8

_NV_TIMING::HSyncPol

NvU16

_NV_TIMING::VVisible

NvU16

_NV_TIMING::VBorder

NvU16

_NV_TIMING::VFrontPorch

NvU16

_NV_TIMING::VSyncWidth

NvU16

_NV_TIMING::VTotal

NvU8

_NV_TIMING::VSyncPol

NvU16

_NV_TIMING::interlaced

NvU32

_NV_TIMING::pclk

NV_TIMINGEXT

_NV_TIMING::etc

NvU32

NV_VIEW_TARGET_INFO::version

NvU32

NV_VIEW_TARGET_INFO::count

NvU32 NV_VIEW_TARGET_INFO::deviceMask

NvU32 NV_VIEW_TARGET_INFO::sourceId

NvU32 NV_VIEW_TARGET_INFO::bPrimary:1

NvU32 NV_VIEW_TARGET_INFO::bInterlaced:1

NvU32 NV_VIEW_TARGET_INFO::bGDIPrimary:1

NvU32 NV_VIEW_TARGET_INFO::bForceModeSet:1

struct {

NvU32 NV_VIEW_TARGET_INFO::deviceMask

NvU32 NV_VIEW_TARGET_INFO::sourceId

NvU32 NV_VIEW_TARGET_INFO::bPrimary:1

NvU32 NV_VIEW_TARGET_INFO::bInterlaced:1

NvU32 NV_VIEW_TARGET_INFO::bGDIPrimary:1

NvU32 NV_VIEW_TARGET_INFO::bForceModeSet:1

}

NV_VIEW_TARGET_INFO::target [NVAPI_MAX_VIEW_TARGET]

NvU32

NV_DISPLAY_PATH::deviceMask

NvU32

NV_DISPLAY_PATH::sourceId

NvU32

NV_DISPLAY_PATH::bPrimary:1

NV_GPU_CONNECTOR_TYPE

NV_DISPLAY_PATH::connector

NvU32

NV_DISPLAY_PATH::width

NvU32

NV_DISPLAY_PATH::height

NvU32

NV_DISPLAY_PATH::depth

NV_FORMAT

NV_DISPLAY_PATH::colorFormat

NV_ROTATE

NV_DISPLAY_PATH::rotation

NV_SCALING

NV_DISPLAY_PATH::scaling

NvU32

NV_DISPLAY_PATH::refreshRate

NvU32

NV_DISPLAY_PATH::interlaced:1

NV_DISPLAY_TV_FORMAT

NV_DISPLAY_PATH::tvFormat

NvU32

NV_DISPLAY_PATH::posx

NvU32

NV_DISPLAY_PATH::posy

NvU32

NV_DISPLAY_PATH::bGDIPrimary:1

NvU32

NV_DISPLAY_PATH::bForceModeSet:1

NvU32

NV_DISPLAY_PATH::bFocusDisplay:1

NvU32

NV_DISPLAY_PATH::gpuId:24

NvU32

NV_DISPLAY_PATH_INFO_V3::version

NvU32

NV_DISPLAY_PATH_INFO_V3::count

NV_DISPLAY_PATH

NV_DISPLAY_PATH_INFO_V3::path [NVAPI_MAX_DISPLAY_PATH]

NvU32

NV_DISPLAY_PATH_INFO::version

NvU32

NV_DISPLAY_PATH_INFO::count

NV_DISPLAY_PATH

NV_DISPLAY_PATH_INFO::path [NVAPI_ADVANCED_MAX_DISPLAY_PATH]

NvS32

_NV_POSITION::x

NvS32

_NV_POSITION::y

NvU32

_NV_RESOLUTION::width

NvU32

_NV_RESOLUTION::height

NvU32

_NV_RESOLUTION::colorDepth

NvU32

_NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_V1::version

NV_ROTATE

_NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_V1::rotation

NV_SCALING

_NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_V1::scaling

NvU32

_NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_V1::refreshRate1K

NvU32

_NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_V1::interlaced:1

NvU32

_NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_V1::primary:1

NvU32

_NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_V1::reservedBit1:1

NvU32

_NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_V1::disableVirtualModeSupport:1

NvU32

_NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_V1::isPreferredUnscaledTarget:1

NvU32

_NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_V1::reserved:27

NV_GPU_CONNECTOR_TYPE

_NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_V1::connector

NV_DISPLAY_TV_FORMAT

_NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_V1::tvFormat

NV_TIMING_OVERRIDE

_NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_V1::timingOverride

NV_TIMING

_NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_V1::timing

NvU32

_NV_DISPLAYCONFIG_PATH_TARGET_INFO_V1::displayId

NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO *

_NV_DISPLAYCONFIG_PATH_TARGET_INFO_V1::details

NvU32

_NV_DISPLAYCONFIG_PATH_TARGET_INFO_V2::displayId

NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO *

_NV_DISPLAYCONFIG_PATH_TARGET_INFO_V2::details

NvU32

_NV_DISPLAYCONFIG_PATH_TARGET_INFO_V2::targetId

NV_RESOLUTION

_NV_DISPLAYCONFIG_SOURCE_MODE_INFO_V1::resolution

NV_FORMAT

_NV_DISPLAYCONFIG_SOURCE_MODE_INFO_V1::colorFormat

NV_POSITION

_NV_DISPLAYCONFIG_SOURCE_MODE_INFO_V1::position

NV_DISPLAYCONFIG_SPANNING_ORIENTATION

_NV_DISPLAYCONFIG_SOURCE_MODE_INFO_V1::spanningOrientation

NvU32

_NV_DISPLAYCONFIG_SOURCE_MODE_INFO_V1::bGDIPrimary: 1

NvU32

_NV_DISPLAYCONFIG_SOURCE_MODE_INFO_V1::bSLIFocus: 1

NvU32

_NV_DISPLAYCONFIG_SOURCE_MODE_INFO_V1::reserved: 30

NvU32

_NV_DISPLAYCONFIG_PATH_INFO_V1::version

NvU32

_NV_DISPLAYCONFIG_PATH_INFO_V1::reserved_sourceId

NvU32

_NV_DISPLAYCONFIG_PATH_INFO_V1::targetInfoCount

NV_DISPLAYCONFIG_PATH_TARGET_INFO_V1 *

_NV_DISPLAYCONFIG_PATH_INFO_V1::targetInfo

NV_DISPLAYCONFIG_SOURCE_MODE_INFO_V1 *

_NV_DISPLAYCONFIG_PATH_INFO_V1::sourceModeInfo

NvU32

_NV_DISPLAYCONFIG_PATH_INFO_V2::version

NvU32 _NV_DISPLAYCONFIG_PATH_INFO_V2::sourceId

NvU32 _NV_DISPLAYCONFIG_PATH_INFO_V2::reserved_sourceId

union {

NvU32 _NV_DISPLAYCONFIG_PATH_INFO_V2::sourceId

NvU32 _NV_DISPLAYCONFIG_PATH_INFO_V2::reserved_sourceId

};

NvU32

_NV_DISPLAYCONFIG_PATH_INFO_V2::targetInfoCount

NV_DISPLAYCONFIG_PATH_TARGET_INFO_V2 *

_NV_DISPLAYCONFIG_PATH_INFO_V2::targetInfo

NV_DISPLAYCONFIG_SOURCE_MODE_INFO_V1 *

_NV_DISPLAYCONFIG_PATH_INFO_V2::sourceModeInfo

NvU32

_NV_DISPLAYCONFIG_PATH_INFO_V2::IsNonNVIDIAAdapter: 1

NvU32

_NV_DISPLAYCONFIG_PATH_INFO_V2::reserved: 31

void *

_NV_DISPLAYCONFIG_PATH_INFO_V2::pOSAdapterID

NvS32

NV_GPU_PERF_PSTATES20_PARAM_DELTA::value

NvS32 NV_GPU_PERF_PSTATES20_PARAM_DELTA::min

NvS32 NV_GPU_PERF_PSTATES20_PARAM_DELTA::max

struct {

NvS32 NV_GPU_PERF_PSTATES20_PARAM_DELTA::min

NvS32 NV_GPU_PERF_PSTATES20_PARAM_DELTA::max

}

NV_GPU_PERF_PSTATES20_PARAM_DELTA::valueRange

NV_GPU_PUBLIC_CLOCK_ID

NV_GPU_PSTATE20_CLOCK_ENTRY_V1::domainId

NV_GPU_PERF_PSTATE20_CLOCK_TYPE_ID

NV_GPU_PSTATE20_CLOCK_ENTRY_V1::typeId

NvU32

NV_GPU_PSTATE20_CLOCK_ENTRY_V1::bIsEditable:1

NvU32

NV_GPU_PSTATE20_CLOCK_ENTRY_V1::reserved:31

NV_GPU_PERF_PSTATES20_PARAM_DELTA

NV_GPU_PSTATE20_CLOCK_ENTRY_V1::freqDelta_kHz

NvU32 NV_GPU_PSTATE20_CLOCK_ENTRY_V1::freq_kHz

struct {

NvU32 NV_GPU_PSTATE20_CLOCK_ENTRY_V1::freq_kHz

} NV_GPU_PSTATE20_CLOCK_ENTRY_V1::single

NvU32 NV_GPU_PSTATE20_CLOCK_ENTRY_V1::minFreq_kHz

NvU32 NV_GPU_PSTATE20_CLOCK_ENTRY_V1::maxFreq_kHz

NV_GPU_PERF_VOLTAGE_INFO_DOMAIN_ID NV_GPU_PSTATE20_CLOCK_ENTRY_V1::domainId

NvU32 NV_GPU_PSTATE20_CLOCK_ENTRY_V1::minVoltage_uV

NvU32 NV_GPU_PSTATE20_CLOCK_ENTRY_V1::maxVoltage_uV

struct {

NvU32 NV_GPU_PSTATE20_CLOCK_ENTRY_V1::minFreq_kHz

NvU32 NV_GPU_PSTATE20_CLOCK_ENTRY_V1::maxFreq_kHz

NV_GPU_PERF_VOLTAGE_INFO_DOMAIN_ID NV_GPU_PSTATE20_CLOCK_ENTRY_V1::domainId

NvU32 NV_GPU_PSTATE20_CLOCK_ENTRY_V1::minVoltage_uV

NvU32 NV_GPU_PSTATE20_CLOCK_ENTRY_V1::maxVoltage_uV

} NV_GPU_PSTATE20_CLOCK_ENTRY_V1::range

union {

struct {

NvU32 NV_GPU_PSTATE20_CLOCK_ENTRY_V1::freq_kHz

} NV_GPU_PSTATE20_CLOCK_ENTRY_V1::single

struct {

NvU32 NV_GPU_PSTATE20_CLOCK_ENTRY_V1::minFreq_kHz

NvU32 NV_GPU_PSTATE20_CLOCK_ENTRY_V1::maxFreq_kHz

NV_GPU_PERF_VOLTAGE_INFO_DOMAIN_ID NV_GPU_PSTATE20_CLOCK_ENTRY_V1::domainId

NvU32 NV_GPU_PSTATE20_CLOCK_ENTRY_V1::minVoltage_uV

NvU32 NV_GPU_PSTATE20_CLOCK_ENTRY_V1::maxVoltage_uV

} NV_GPU_PSTATE20_CLOCK_ENTRY_V1::range

}

NV_GPU_PSTATE20_CLOCK_ENTRY_V1::data

NV_GPU_PERF_VOLTAGE_INFO_DOMAIN_ID

NV_GPU_PSTATE20_BASE_VOLTAGE_ENTRY_V1::domainId

NvU32

NV_GPU_PSTATE20_BASE_VOLTAGE_ENTRY_V1::bIsEditable:1

NvU32

NV_GPU_PSTATE20_BASE_VOLTAGE_ENTRY_V1::reserved:31

NvU32

NV_GPU_PSTATE20_BASE_VOLTAGE_ENTRY_V1::volt_uV

NV_GPU_PERF_PSTATES20_PARAM_DELTA

NV_GPU_PSTATE20_BASE_VOLTAGE_ENTRY_V1::voltDelta_uV

NvU32

NV_GPU_PERF_PSTATES20_INFO_V1::version

NvU32

NV_GPU_PERF_PSTATES20_INFO_V1::bIsEditable:1

NvU32

NV_GPU_PERF_PSTATES20_INFO_V1::reserved:31

NvU32

NV_GPU_PERF_PSTATES20_INFO_V1::numPstates

NvU32

NV_GPU_PERF_PSTATES20_INFO_V1::numClocks

NvU32

NV_GPU_PERF_PSTATES20_INFO_V1::numBaseVoltages

NV_GPU_PERF_PSTATE_ID NV_GPU_PERF_PSTATES20_INFO_V1::pstateId

NvU32 NV_GPU_PERF_PSTATES20_INFO_V1::bIsEditable:1

NvU32 NV_GPU_PERF_PSTATES20_INFO_V1::reserved:31

NV_GPU_PSTATE20_CLOCK_ENTRY_V1 NV_GPU_PERF_PSTATES20_INFO_V1::clocks [NVAPI_MAX_GPU_PSTATE20_CLOCKS]

NV_GPU_PSTATE20_BASE_VOLTAGE_ENTRY_V1 NV_GPU_PERF_PSTATES20_INFO_V1::baseVoltages [NVAPI_MAX_GPU_PSTATE20_BASE_VOLTAGES]

struct {

NV_GPU_PERF_PSTATE_ID NV_GPU_PERF_PSTATES20_INFO_V1::pstateId

NvU32 NV_GPU_PERF_PSTATES20_INFO_V1::bIsEditable:1

NvU32 NV_GPU_PERF_PSTATES20_INFO_V1::reserved:31

NV_GPU_PSTATE20_CLOCK_ENTRY_V1 NV_GPU_PERF_PSTATES20_INFO_V1::clocks [NVAPI_MAX_GPU_PSTATE20_CLOCKS]

NV_GPU_PSTATE20_BASE_VOLTAGE_ENTRY_V1 NV_GPU_PERF_PSTATES20_INFO_V1::baseVoltages [NVAPI_MAX_GPU_PSTATE20_BASE_VOLTAGES]

}

NV_GPU_PERF_PSTATES20_INFO_V1::pstates [NVAPI_MAX_GPU_PSTATE20_PSTATES]

NvU32

_NV_GPU_PERF_PSTATES20_INFO_V2::version

NvU32

_NV_GPU_PERF_PSTATES20_INFO_V2::bIsEditable:1

NvU32

_NV_GPU_PERF_PSTATES20_INFO_V2::reserved:31

NvU32

_NV_GPU_PERF_PSTATES20_INFO_V2::numPstates

NvU32

_NV_GPU_PERF_PSTATES20_INFO_V2::numClocks

NvU32

_NV_GPU_PERF_PSTATES20_INFO_V2::numBaseVoltages

NV_GPU_PERF_PSTATE_ID _NV_GPU_PERF_PSTATES20_INFO_V2::pstateId

NvU32 _NV_GPU_PERF_PSTATES20_INFO_V2::bIsEditable:1

NvU32 _NV_GPU_PERF_PSTATES20_INFO_V2::reserved:31

NV_GPU_PSTATE20_CLOCK_ENTRY_V1 _NV_GPU_PERF_PSTATES20_INFO_V2::clocks [NVAPI_MAX_GPU_PSTATE20_CLOCKS]

NV_GPU_PSTATE20_BASE_VOLTAGE_ENTRY_V1 _NV_GPU_PERF_PSTATES20_INFO_V2::baseVoltages [NVAPI_MAX_GPU_PSTATE20_BASE_VOLTAGES]

struct {

NV_GPU_PERF_PSTATE_ID _NV_GPU_PERF_PSTATES20_INFO_V2::pstateId

NvU32 _NV_GPU_PERF_PSTATES20_INFO_V2::bIsEditable:1

NvU32 _NV_GPU_PERF_PSTATES20_INFO_V2::reserved:31

NV_GPU_PSTATE20_CLOCK_ENTRY_V1 _NV_GPU_PERF_PSTATES20_INFO_V2::clocks [NVAPI_MAX_GPU_PSTATE20_CLOCKS]

NV_GPU_PSTATE20_BASE_VOLTAGE_ENTRY_V1 _NV_GPU_PERF_PSTATES20_INFO_V2::baseVoltages [NVAPI_MAX_GPU_PSTATE20_BASE_VOLTAGES]

}

_NV_GPU_PERF_PSTATES20_INFO_V2::pstates [NVAPI_MAX_GPU_PSTATE20_PSTATES]

NvU32 _NV_GPU_PERF_PSTATES20_INFO_V2::numVoltages

NV_GPU_PSTATE20_BASE_VOLTAGE_ENTRY_V1 _NV_GPU_PERF_PSTATES20_INFO_V2::voltages [NVAPI_MAX_GPU_PSTATE20_BASE_VOLTAGES]

struct {

NvU32 _NV_GPU_PERF_PSTATES20_INFO_V2::numVoltages

NV_GPU_PSTATE20_BASE_VOLTAGE_ENTRY_V1 _NV_GPU_PERF_PSTATES20_INFO_V2::voltages [NVAPI_MAX_GPU_PSTATE20_BASE_VOLTAGES]

}

_NV_GPU_PERF_PSTATES20_INFO_V2::ov

NvU32

NV_DISPLAY_DRIVER_VERSION::version

NvU32

NV_DISPLAY_DRIVER_VERSION::drvVersion

NvU32

NV_DISPLAY_DRIVER_VERSION::bldChangeListNum

NvAPI_ShortString

NV_DISPLAY_DRIVER_VERSION::szBuildBranchString

NvAPI_ShortString

NV_DISPLAY_DRIVER_VERSION::szAdapterString

NvU32

_NV_GPU_DISPLAYIDS::version

NV_MONITOR_CONN_TYPE

_NV_GPU_DISPLAYIDS::connectorType

NvU32

_NV_GPU_DISPLAYIDS::displayId

NvU32

_NV_GPU_DISPLAYIDS::isDynamic: 1

NvU32

_NV_GPU_DISPLAYIDS::isMultiStreamRootNode: 1

NvU32

_NV_GPU_DISPLAYIDS::isActive: 1

NvU32

_NV_GPU_DISPLAYIDS::isCluster: 1

NvU32

_NV_GPU_DISPLAYIDS::isOSVisible: 1

NvU32

_NV_GPU_DISPLAYIDS::isWFD: 1

NvU32

_NV_GPU_DISPLAYIDS::isConnected: 1

NvU32

_NV_GPU_DISPLAYIDS::reservedInternal: 10

NvU32

_NV_GPU_DISPLAYIDS::isPhysicallyConnected: 1

NvU32

_NV_GPU_DISPLAYIDS::reserved: 14

NvU32

_NV_BOARD_INFO::version

NvU8

_NV_BOARD_INFO::BoardNum [16]

NvU32

NV_GPU_ARCH_INFO_V1::version

NvU32

NV_GPU_ARCH_INFO_V1::architecture

NvU32

NV_GPU_ARCH_INFO_V1::implementation

NvU32

NV_GPU_ARCH_INFO_V1::revision

NvU32

NV_GPU_ARCH_INFO_V2::version

NvU32 NV_GPU_ARCH_INFO_V2::architecture

NV_GPU_ARCHITECTURE_ID NV_GPU_ARCH_INFO_V2::architecture_id

union {

NvU32 NV_GPU_ARCH_INFO_V2::architecture

NV_GPU_ARCHITECTURE_ID NV_GPU_ARCH_INFO_V2::architecture_id

};

NvU32 NV_GPU_ARCH_INFO_V2::implementation

NV_GPU_ARCH_IMPLEMENTATION_ID NV_GPU_ARCH_INFO_V2::implementation_id

union {

NvU32 NV_GPU_ARCH_INFO_V2::implementation

NV_GPU_ARCH_IMPLEMENTATION_ID NV_GPU_ARCH_INFO_V2::implementation_id

};

NvU32 NV_GPU_ARCH_INFO_V2::revision

NV_GPU_CHIP_REVISION NV_GPU_ARCH_INFO_V2::revision_id

union {

NvU32 NV_GPU_ARCH_INFO_V2::revision

NV_GPU_CHIP_REVISION NV_GPU_ARCH_INFO_V2::revision_id

};

NvU32

NV_I2C_INFO_V1::version

NvU32

NV_I2C_INFO_V1::displayMask

NvU8

NV_I2C_INFO_V1::bIsDDCPort

NvU8

NV_I2C_INFO_V1::i2cDevAddress

NvU8 *

NV_I2C_INFO_V1::pbI2cRegAddress

NvU32

NV_I2C_INFO_V1::regAddrSize

NvU8 *

NV_I2C_INFO_V1::pbData

NvU32

NV_I2C_INFO_V1::cbSize

NvU32

NV_I2C_INFO_V1::i2cSpeed

NvU32

NV_I2C_INFO_V2::version

NvU32

NV_I2C_INFO_V2::displayMask

NvU8

NV_I2C_INFO_V2::bIsDDCPort

NvU8

NV_I2C_INFO_V2::i2cDevAddress

NvU8 *

NV_I2C_INFO_V2::pbI2cRegAddress

NvU32

NV_I2C_INFO_V2::regAddrSize

NvU8 *

NV_I2C_INFO_V2::pbData

NvU32

NV_I2C_INFO_V2::cbSize

NvU32

NV_I2C_INFO_V2::i2cSpeed

NV_I2C_SPEED

NV_I2C_INFO_V2::i2cSpeedKhz

NvU32

NV_I2C_INFO_V3::version

NvU32

NV_I2C_INFO_V3::displayMask

NvU8

NV_I2C_INFO_V3::bIsDDCPort

NvU8

NV_I2C_INFO_V3::i2cDevAddress

NvU8 *

NV_I2C_INFO_V3::pbI2cRegAddress

NvU32

NV_I2C_INFO_V3::regAddrSize

NvU8 *

NV_I2C_INFO_V3::pbData

NvU32

NV_I2C_INFO_V3::cbSize

NvU32

NV_I2C_INFO_V3::i2cSpeed

NV_I2C_SPEED

NV_I2C_INFO_V3::i2cSpeedKhz

NvU8

NV_I2C_INFO_V3::portId

NvU32

NV_I2C_INFO_V3::bIsPortIdSet

NvU32

NV_GPU_GET_HDCP_SUPPORT_STATUS::version

NV_GPU_HDCP_FUSE_STATE

NV_GPU_GET_HDCP_SUPPORT_STATUS::hdcpFuseState

NV_GPU_HDCP_KEY_SOURCE

NV_GPU_GET_HDCP_SUPPORT_STATUS::hdcpKeySource

NV_GPU_HDCP_KEY_SOURCE_STATE

NV_GPU_GET_HDCP_SUPPORT_STATUS::hdcpKeySourceState

NvU32

NV_COMPUTE_GPU_TOPOLOGY_V1::version

NvU32

NV_COMPUTE_GPU_TOPOLOGY_V1::gpuCount

NvPhysicalGpuHandle NV_COMPUTE_GPU_TOPOLOGY_V1::hPhysicalGpu

NvU32 NV_COMPUTE_GPU_TOPOLOGY_V1::flags

struct {

NvPhysicalGpuHandle NV_COMPUTE_GPU_TOPOLOGY_V1::hPhysicalGpu

NvU32 NV_COMPUTE_GPU_TOPOLOGY_V1::flags

}

NV_COMPUTE_GPU_TOPOLOGY_V1::computeGpus [NVAPI_MAX_GPU_PER_TOPOLOGY]

NvPhysicalGpuHandle

_NV_COMPUTE_GPU::hPhysicalGpu

NvU32

_NV_COMPUTE_GPU::flags

NvU32

_NV_COMPUTE_GPU_TOPOLOGY_V2::version

NvU32

_NV_COMPUTE_GPU_TOPOLOGY_V2::gpuCount

NV_COMPUTE_GPU *

_NV_COMPUTE_GPU_TOPOLOGY_V2::computeGpus

NvU32

NV_GPU_ECC_STATUS_INFO::version

NvU32

NV_GPU_ECC_STATUS_INFO::isSupported: 1

NV_ECC_CONFIGURATION

NV_GPU_ECC_STATUS_INFO::configurationOptions

NvU32

NV_GPU_ECC_STATUS_INFO::isEnabled: 1

NvU32

NV_GPU_ECC_ERROR_INFO::version

NvU64 NV_GPU_ECC_ERROR_INFO::singleBitErrors

NvU64 NV_GPU_ECC_ERROR_INFO::doubleBitErrors

struct {

NvU64 NV_GPU_ECC_ERROR_INFO::singleBitErrors

NvU64 NV_GPU_ECC_ERROR_INFO::doubleBitErrors

}

NV_GPU_ECC_ERROR_INFO::current

NvU64 NV_GPU_ECC_ERROR_INFO::singleBitErrors

NvU64 NV_GPU_ECC_ERROR_INFO::doubleBitErrors

struct {

NvU64 NV_GPU_ECC_ERROR_INFO::singleBitErrors

NvU64 NV_GPU_ECC_ERROR_INFO::doubleBitErrors

}

NV_GPU_ECC_ERROR_INFO::aggregate

NvU32

NV_GPU_ECC_CONFIGURATION_INFO::version

NvU32

NV_GPU_ECC_CONFIGURATION_INFO::isEnabled: 1

NvU32

NV_GPU_ECC_CONFIGURATION_INFO::isEnabledByDefault: 1

NV_QSYNC_EVENT

NV_QSYNC_EVENT_DATA::qsyncEvent

NvU32

NV_QSYNC_EVENT_DATA::reserved [7]

NvU32

NV_EVENT_REGISTER_CALLBACK::version

NV_EVENT_TYPE

NV_EVENT_REGISTER_CALLBACK::eventId

void *

NV_EVENT_REGISTER_CALLBACK::callbackParam

NVAPI_CALLBACK_QSYNCEVENT NV_EVENT_REGISTER_CALLBACK::nvQSYNCEventCallback

union {

NVAPI_CALLBACK_QSYNCEVENT NV_EVENT_REGISTER_CALLBACK::nvQSYNCEventCallback

}

NV_EVENT_REGISTER_CALLBACK::nvCallBackFunc

NvU32

NV_SCANOUT_INTENSITY_DATA_V1::version

NvU32

NV_SCANOUT_INTENSITY_DATA_V1::width

NvU32

NV_SCANOUT_INTENSITY_DATA_V1::height

float *

NV_SCANOUT_INTENSITY_DATA_V1::blendingTexture

NvU32

NV_SCANOUT_INTENSITY_DATA_V2::version

NvU32

NV_SCANOUT_INTENSITY_DATA_V2::width

NvU32

NV_SCANOUT_INTENSITY_DATA_V2::height

float *

NV_SCANOUT_INTENSITY_DATA_V2::blendingTexture

float *

NV_SCANOUT_INTENSITY_DATA_V2::offsetTexture

NvU32

NV_SCANOUT_INTENSITY_DATA_V2::offsetTexChannels

NvU32

_NV_SCANOUT_INTENSITY_STATE_DATA::version

NvU32

_NV_SCANOUT_INTENSITY_STATE_DATA::bEnabled

NvU32

NV_SCANOUT_WARPING_DATA::version

float *

NV_SCANOUT_WARPING_DATA::vertices

NV_GPU_WARPING_VERTICE_FORMAT

NV_SCANOUT_WARPING_DATA::vertexFormat

int

NV_SCANOUT_WARPING_DATA::numVertices

NvSBox *

NV_SCANOUT_WARPING_DATA::textureRect

NvU32

_NV_SCANOUT_WARPING_STATE_DATA::version

NvU32

_NV_SCANOUT_WARPING_STATE_DATA::bEnabled

NvU32

_NV_SCANOUT_INFORMATION::version

NvSBox

_NV_SCANOUT_INFORMATION::sourceDesktopRect

NvSBox

_NV_SCANOUT_INFORMATION::sourceViewportRect

NvSBox

_NV_SCANOUT_INFORMATION::targetViewportRect

NvU32

_NV_SCANOUT_INFORMATION::targetDisplayWidth

NvU32

_NV_SCANOUT_INFORMATION::targetDisplayHeight

NvU32

_NV_SCANOUT_INFORMATION::cloneImportance

NV_ROTATE

_NV_SCANOUT_INFORMATION::sourceToTargetRotation

NvU32

_NV_GPU_VIRTUALIZATION_INFO::version

NV_VIRTUALIZATION_MODE

_NV_GPU_VIRTUALIZATION_INFO::virtualizationMode

NvU32

_NV_GPU_VIRTUALIZATION_INFO::reserved

NvU32

_NV_LOGICAL_GPU_DATA_V1::version

void *

_NV_LOGICAL_GPU_DATA_V1::pOSAdapterId

NvU32

_NV_LOGICAL_GPU_DATA_V1::physicalGpuCount

NvPhysicalGpuHandle

_NV_LOGICAL_GPU_DATA_V1::physicalGpuHandles [NVAPI_MAX_PHYSICAL_GPUS]

NvU32

_NV_LOGICAL_GPU_DATA_V1::reserved [8]

NvU32

_NV_LICENSE_EXPIRY_DETAILS::year

NvU16

_NV_LICENSE_EXPIRY_DETAILS::month

NvU16

_NV_LICENSE_EXPIRY_DETAILS::day

NvU16

_NV_LICENSE_EXPIRY_DETAILS::hour

NvU16

_NV_LICENSE_EXPIRY_DETAILS::min

NvU16

_NV_LICENSE_EXPIRY_DETAILS::sec

NvU8

_NV_LICENSE_EXPIRY_DETAILS::status

NvU32

_NV_LICENSE_FEATURE_DETAILS_V1::version

NvU32

_NV_LICENSE_FEATURE_DETAILS_V1::isEnabled: 1

NvU32

_NV_LICENSE_FEATURE_DETAILS_V1::reserved: 31

NV_LICENSE_FEATURE_TYPE

_NV_LICENSE_FEATURE_DETAILS_V1::featureCode

NvAPI_LicenseString

_NV_LICENSE_FEATURE_DETAILS_V1::licenseInfo

NvU32

_NV_LICENSE_FEATURE_DETAILS_V2::version

NvU32

_NV_LICENSE_FEATURE_DETAILS_V2::isEnabled: 1

NvU32

_NV_LICENSE_FEATURE_DETAILS_V2::reserved: 31

NV_LICENSE_FEATURE_TYPE

_NV_LICENSE_FEATURE_DETAILS_V2::featureCode

NvAPI_LicenseString

_NV_LICENSE_FEATURE_DETAILS_V2::licenseInfo

NvAPI_LicenseString

_NV_LICENSE_FEATURE_DETAILS_V2::productName

NvU32

_NV_LICENSE_FEATURE_DETAILS_V3::version

NvU32

_NV_LICENSE_FEATURE_DETAILS_V3::isEnabled: 1

NvU32

_NV_LICENSE_FEATURE_DETAILS_V3::isFeatureEnabled: 1

NvU32

_NV_LICENSE_FEATURE_DETAILS_V3::reserved: 30

NV_LICENSE_FEATURE_TYPE

_NV_LICENSE_FEATURE_DETAILS_V3::featureCode

NvAPI_LicenseString

_NV_LICENSE_FEATURE_DETAILS_V3::licenseInfo

NvAPI_LicenseString

_NV_LICENSE_FEATURE_DETAILS_V3::productName

NvU32

_NV_LICENSE_FEATURE_DETAILS_V4::version

NvU32

_NV_LICENSE_FEATURE_DETAILS_V4::isEnabled: 1

NvU32

_NV_LICENSE_FEATURE_DETAILS_V4::isFeatureEnabled: 1

NvU32

_NV_LICENSE_FEATURE_DETAILS_V4::reserved: 30

NV_LICENSE_FEATURE_TYPE

_NV_LICENSE_FEATURE_DETAILS_V4::featureCode

NvAPI_LicenseString

_NV_LICENSE_FEATURE_DETAILS_V4::licenseInfo

NvAPI_LicenseString

_NV_LICENSE_FEATURE_DETAILS_V4::productName

NV_LICENSE_EXPIRY_DETAILS

_NV_LICENSE_FEATURE_DETAILS_V4::licenseExpiry

NvU32

_NV_LICENSABLE_FEATURES_V1::version

NvU32

_NV_LICENSABLE_FEATURES_V1::isLicenseSupported: 1

NvU32

_NV_LICENSABLE_FEATURES_V1::reserved: 31

NvU32

_NV_LICENSABLE_FEATURES_V1::licensableFeatureCount

NvU8

_NV_LICENSABLE_FEATURES_V1::signature [NV_LICENSE_SIGNATURE_SIZE]

NV_LICENSE_FEATURE_DETAILS_V1

_NV_LICENSABLE_FEATURES_V1::licenseDetails [NV_LICENSE_MAX_COUNT]

NvU32

_NV_LICENSABLE_FEATURES_V2::version

NvU32

_NV_LICENSABLE_FEATURES_V2::isLicenseSupported: 1

NvU32

_NV_LICENSABLE_FEATURES_V2::reserved: 31

NvU32

_NV_LICENSABLE_FEATURES_V2::licensableFeatureCount

NvU8

_NV_LICENSABLE_FEATURES_V2::signature [NV_LICENSE_SIGNATURE_SIZE]

NV_LICENSE_FEATURE_DETAILS_V2

_NV_LICENSABLE_FEATURES_V2::licenseDetails [NV_LICENSE_MAX_COUNT]

NvU32

_NV_LICENSABLE_FEATURES_V3::version

NvU32

_NV_LICENSABLE_FEATURES_V3::isLicenseSupported: 1

NvU32

_NV_LICENSABLE_FEATURES_V3::reserved: 31

NvU32

_NV_LICENSABLE_FEATURES_V3::licensableFeatureCount

NvU8

_NV_LICENSABLE_FEATURES_V3::signature [NV_LICENSE_SIGNATURE_SIZE]

NV_LICENSE_FEATURE_DETAILS_V3

_NV_LICENSABLE_FEATURES_V3::licenseDetails [NV_LICENSE_MAX_COUNT]

NvU32

_NV_LICENSABLE_FEATURES_V4::version

NvU32

_NV_LICENSABLE_FEATURES_V4::isLicenseSupported: 1

NvU32

_NV_LICENSABLE_FEATURES_V4::reserved: 31

NvU32

_NV_LICENSABLE_FEATURES_V4::licensableFeatureCount

NvU8

_NV_LICENSABLE_FEATURES_V4::signature [NV_LICENSE_SIGNATURE_SIZE]

NV_LICENSE_FEATURE_DETAILS_V4

_NV_LICENSABLE_FEATURES_V4::licenseDetails [NV_LICENSE_MAX_COUNT]

NvU32

NVLINK_GET_CAPS_V1::version

NvU32

NVLINK_GET_CAPS_V1::capsTbl

NvU8

NVLINK_GET_CAPS_V1::lowestNvlinkVersion

NvU8

NVLINK_GET_CAPS_V1::highestNvlinkVersion

NvU8

NVLINK_GET_CAPS_V1::lowestNciVersion

NvU8

NVLINK_GET_CAPS_V1::highestNciVersion

NvU32

NVLINK_GET_CAPS_V1::linkMask

NvU32

NVLINK_DEVICE_INFO_V1::deviceIdFlags

NvU16

NVLINK_DEVICE_INFO_V1::domain

NvU16

NVLINK_DEVICE_INFO_V1::bus

NvU16

NVLINK_DEVICE_INFO_V1::device

NvU16

NVLINK_DEVICE_INFO_V1::function

NvU32

NVLINK_DEVICE_INFO_V1::pciDeviceId

NvU64

NVLINK_DEVICE_INFO_V1::deviceType

NvU8

NVLINK_DEVICE_INFO_V1::deviceUUID [16]

NvU32

NVLINK_LINK_STATUS_INFO_V1::capsTbl

NvU8

NVLINK_LINK_STATUS_INFO_V1::phyType

NvU8

NVLINK_LINK_STATUS_INFO_V1::subLinkWidth

NvU32

NVLINK_LINK_STATUS_INFO_V1::linkState

NvU8

NVLINK_LINK_STATUS_INFO_V1::rxSublinkStatus

NvU8

NVLINK_LINK_STATUS_INFO_V1::txSublinkStatus

NvU8

NVLINK_LINK_STATUS_INFO_V1::nvlinkVersion

NvU8

NVLINK_LINK_STATUS_INFO_V1::nciVersion

NvU8

NVLINK_LINK_STATUS_INFO_V1::phyVersion

NvU32

NVLINK_LINK_STATUS_INFO_V1::nvlinkCommonClockSpeedMhz

NvU32

NVLINK_LINK_STATUS_INFO_V1::nvlinkRefClkSpeedMhz

NvU8

NVLINK_LINK_STATUS_INFO_V1::nvlinkRefClkType

NvU32

NVLINK_LINK_STATUS_INFO_V1::nvlinkLinkClockMhz

NvU32

NVLINK_LINK_STATUS_INFO_V1::connected:1

NvU32

NVLINK_LINK_STATUS_INFO_V1::reserved:31

NvU8

NVLINK_LINK_STATUS_INFO_V1::loopProperty

NvU8

NVLINK_LINK_STATUS_INFO_V1::remoteDeviceLinkNumber

NVLINK_DEVICE_INFO_V1

NVLINK_LINK_STATUS_INFO_V1::remoteDeviceInfo

NvU32

NVLINK_LINK_STATUS_INFO_V2::capsTbl

NvU8

NVLINK_LINK_STATUS_INFO_V2::phyType

NvU8

NVLINK_LINK_STATUS_INFO_V2::subLinkWidth

NvU32

NVLINK_LINK_STATUS_INFO_V2::linkState

NvU8

NVLINK_LINK_STATUS_INFO_V2::rxSublinkStatus

NvU8

NVLINK_LINK_STATUS_INFO_V2::txSublinkStatus

NvU8

NVLINK_LINK_STATUS_INFO_V2::nvlinkVersion

NvU8

NVLINK_LINK_STATUS_INFO_V2::nciVersion

NvU8

NVLINK_LINK_STATUS_INFO_V2::phyVersion

NvU32

NVLINK_LINK_STATUS_INFO_V2::nvlinkCommonClockSpeedMhz

NvU32

NVLINK_LINK_STATUS_INFO_V2::nvlinkRefClkSpeedMhz

NvU8

NVLINK_LINK_STATUS_INFO_V2::nvlinkRefClkType

NvU32

NVLINK_LINK_STATUS_INFO_V2::nvlinkLinkClockMhz

NvU32

NVLINK_LINK_STATUS_INFO_V2::connected:1

NvU32

NVLINK_LINK_STATUS_INFO_V2::reserved:31

NvU8

NVLINK_LINK_STATUS_INFO_V2::loopProperty

NvU8

NVLINK_LINK_STATUS_INFO_V2::remoteDeviceLinkNumber

NVLINK_DEVICE_INFO_V1

NVLINK_LINK_STATUS_INFO_V2::remoteDeviceInfo

NvU8

NVLINK_LINK_STATUS_INFO_V2::localDeviceLinkNumber

NVLINK_DEVICE_INFO_V1

NVLINK_LINK_STATUS_INFO_V2::localDeviceInfo

NvU32

NVLINK_LINK_STATUS_INFO_V2::nvlinkLineRateMbps

NvU32

NVLINK_LINK_STATUS_INFO_V2::reservedEx [8]

NvU32

NVLINK_GET_STATUS_V1::version

NvU32

NVLINK_GET_STATUS_V1::linkMask

NVLINK_LINK_STATUS_INFO_V1

NVLINK_GET_STATUS_V1::linkInfo [NVAPI_NVLINK_MAX_LINKS]

NvU32

NVLINK_GET_STATUS_V2::version

NvU32

NVLINK_GET_STATUS_V2::linkMask

NVLINK_LINK_STATUS_INFO_V2

NVLINK_GET_STATUS_V2::linkInfo [NVAPI_NVLINK_MAX_LINKS]

NvU32

_NV_GPU_INFO_V1::version

NvU32

_NV_GPU_INFO_V1::bIsExternalGpu:1

NvU32

_NV_GPU_INFO_V1::reserved:31

NvU32

_NV_GPU_INFO_V2::version

NvU32

_NV_GPU_INFO_V2::bIsExternalGpu:1

NvU32

_NV_GPU_INFO_V2::reserved0:31

NvU64

_NV_GPU_INFO_V2::reserved1

NvU32

_NV_GPU_INFO_V2::rayTracingCores

NvU32

_NV_GPU_INFO_V2::tensorCores

NvU32

_NV_GPU_INFO_V2::reserved2 [14]

NvU32

_NV_GPU_VR_READY_V1::version

NvU32

_NV_GPU_VR_READY_V1::isVRReady: 1

NvU32

_NV_GPU_VR_READY_V1::reserved: 31

NvU32

_NV_GPU_GSP_INFO_V1::version

NvU8

_NV_GPU_GSP_INFO_V1::firmwareVersion [NVAPI_GPU_MAX_BUILD_VERSION_LENGTH]

NvU32

_NV_GPU_GSP_INFO_V1::reserved

NvU32

NV_GPU_PERF_PSTATES_INFO_V1::version

NvU32

NV_GPU_PERF_PSTATES_INFO_V1::flags

NvU32

NV_GPU_PERF_PSTATES_INFO_V1::numPstates

NvU32

NV_GPU_PERF_PSTATES_INFO_V1::numClocks

NV_GPU_PERF_PSTATE_ID NV_GPU_PERF_PSTATES_INFO_V1::pstateId

NvU32 NV_GPU_PERF_PSTATES_INFO_V1::flags

NV_GPU_PUBLIC_CLOCK_ID NV_GPU_PERF_PSTATES_INFO_V1::domainId

NvU32 NV_GPU_PERF_PSTATES_INFO_V1::flags

NvU32 NV_GPU_PERF_PSTATES_INFO_V1::freq

struct {

NV_GPU_PUBLIC_CLOCK_ID NV_GPU_PERF_PSTATES_INFO_V1::domainId

NvU32 NV_GPU_PERF_PSTATES_INFO_V1::flags

NvU32 NV_GPU_PERF_PSTATES_INFO_V1::freq

} NV_GPU_PERF_PSTATES_INFO_V1::clocks [NVAPI_MAX_GPU_PERF_CLOCKS]

struct {

NV_GPU_PERF_PSTATE_ID NV_GPU_PERF_PSTATES_INFO_V1::pstateId

NvU32 NV_GPU_PERF_PSTATES_INFO_V1::flags

struct {

NV_GPU_PUBLIC_CLOCK_ID NV_GPU_PERF_PSTATES_INFO_V1::domainId

NvU32 NV_GPU_PERF_PSTATES_INFO_V1::flags

NvU32 NV_GPU_PERF_PSTATES_INFO_V1::freq

} NV_GPU_PERF_PSTATES_INFO_V1::clocks [NVAPI_MAX_GPU_PERF_CLOCKS]

}

NV_GPU_PERF_PSTATES_INFO_V1::pstates [NVAPI_MAX_GPU_PERF_PSTATES]

NvU32

NV_GPU_PERF_PSTATES_INFO_V2::version

NvU32

NV_GPU_PERF_PSTATES_INFO_V2::flags

NvU32

NV_GPU_PERF_PSTATES_INFO_V2::numPstates

NvU32

NV_GPU_PERF_PSTATES_INFO_V2::numClocks

NvU32

NV_GPU_PERF_PSTATES_INFO_V2::numVoltages

NV_GPU_PERF_PSTATE_ID NV_GPU_PERF_PSTATES_INFO_V2::pstateId

NvU32 NV_GPU_PERF_PSTATES_INFO_V2::flags

NV_GPU_PUBLIC_CLOCK_ID NV_GPU_PERF_PSTATES_INFO_V2::domainId

NvU32 NV_GPU_PERF_PSTATES_INFO_V2::flags

NvU32 NV_GPU_PERF_PSTATES_INFO_V2::freq

struct {

NV_GPU_PUBLIC_CLOCK_ID NV_GPU_PERF_PSTATES_INFO_V2::domainId

NvU32 NV_GPU_PERF_PSTATES_INFO_V2::flags

NvU32 NV_GPU_PERF_PSTATES_INFO_V2::freq

} NV_GPU_PERF_PSTATES_INFO_V2::clocks [NVAPI_MAX_GPU_PERF_CLOCKS]

NV_GPU_PERF_VOLTAGE_INFO_DOMAIN_ID NV_GPU_PERF_PSTATES_INFO_V2::domainId

NvU32 NV_GPU_PERF_PSTATES_INFO_V2::flags

NvU32 NV_GPU_PERF_PSTATES_INFO_V2::mvolt

struct {

NV_GPU_PERF_VOLTAGE_INFO_DOMAIN_ID NV_GPU_PERF_PSTATES_INFO_V2::domainId

NvU32 NV_GPU_PERF_PSTATES_INFO_V2::flags

NvU32 NV_GPU_PERF_PSTATES_INFO_V2::mvolt

} NV_GPU_PERF_PSTATES_INFO_V2::voltages [NVAPI_MAX_GPU_PERF_VOLTAGES]

struct {

NV_GPU_PERF_PSTATE_ID NV_GPU_PERF_PSTATES_INFO_V2::pstateId

NvU32 NV_GPU_PERF_PSTATES_INFO_V2::flags

struct {

NV_GPU_PUBLIC_CLOCK_ID NV_GPU_PERF_PSTATES_INFO_V2::domainId

NvU32 NV_GPU_PERF_PSTATES_INFO_V2::flags

NvU32 NV_GPU_PERF_PSTATES_INFO_V2::freq

} NV_GPU_PERF_PSTATES_INFO_V2::clocks [NVAPI_MAX_GPU_PERF_CLOCKS]

struct {

NV_GPU_PERF_VOLTAGE_INFO_DOMAIN_ID NV_GPU_PERF_PSTATES_INFO_V2::domainId

NvU32 NV_GPU_PERF_PSTATES_INFO_V2::flags

NvU32 NV_GPU_PERF_PSTATES_INFO_V2::mvolt

} NV_GPU_PERF_PSTATES_INFO_V2::voltages [NVAPI_MAX_GPU_PERF_VOLTAGES]

}

NV_GPU_PERF_PSTATES_INFO_V2::pstates [NVAPI_MAX_GPU_PERF_PSTATES]

NvU32

NV_GPU_DYNAMIC_PSTATES_INFO_EX::version

NvU32

NV_GPU_DYNAMIC_PSTATES_INFO_EX::flags

NvU32 NV_GPU_DYNAMIC_PSTATES_INFO_EX::bIsPresent:1

NvU32 NV_GPU_DYNAMIC_PSTATES_INFO_EX::percentage

struct {

NvU32 NV_GPU_DYNAMIC_PSTATES_INFO_EX::bIsPresent:1

NvU32 NV_GPU_DYNAMIC_PSTATES_INFO_EX::percentage

}

NV_GPU_DYNAMIC_PSTATES_INFO_EX::utilization [NVAPI_MAX_GPU_UTILIZATIONS]

NvU32

NV_GPU_THERMAL_SETTINGS_V1::version

NvU32

NV_GPU_THERMAL_SETTINGS_V1::count

NV_THERMAL_CONTROLLER NV_GPU_THERMAL_SETTINGS_V1::controller

NvU32 NV_GPU_THERMAL_SETTINGS_V1::defaultMinTemp

NvU32 NV_GPU_THERMAL_SETTINGS_V1::defaultMaxTemp

NvU32 NV_GPU_THERMAL_SETTINGS_V1::currentTemp

NV_THERMAL_TARGET NV_GPU_THERMAL_SETTINGS_V1::target

struct {

NV_THERMAL_CONTROLLER NV_GPU_THERMAL_SETTINGS_V1::controller

NvU32 NV_GPU_THERMAL_SETTINGS_V1::defaultMinTemp

NvU32 NV_GPU_THERMAL_SETTINGS_V1::defaultMaxTemp

NvU32 NV_GPU_THERMAL_SETTINGS_V1::currentTemp

NV_THERMAL_TARGET NV_GPU_THERMAL_SETTINGS_V1::target

}

NV_GPU_THERMAL_SETTINGS_V1::sensor [NVAPI_MAX_THERMAL_SENSORS_PER_GPU]

NvU32

NV_GPU_THERMAL_SETTINGS_V2::version

NvU32

NV_GPU_THERMAL_SETTINGS_V2::count

NV_THERMAL_CONTROLLER NV_GPU_THERMAL_SETTINGS_V2::controller

NvS32 NV_GPU_THERMAL_SETTINGS_V2::defaultMinTemp

NvS32 NV_GPU_THERMAL_SETTINGS_V2::defaultMaxTemp

NvS32 NV_GPU_THERMAL_SETTINGS_V2::currentTemp

NV_THERMAL_TARGET NV_GPU_THERMAL_SETTINGS_V2::target

struct {

NV_THERMAL_CONTROLLER NV_GPU_THERMAL_SETTINGS_V2::controller

NvS32 NV_GPU_THERMAL_SETTINGS_V2::defaultMinTemp

NvS32 NV_GPU_THERMAL_SETTINGS_V2::defaultMaxTemp

NvS32 NV_GPU_THERMAL_SETTINGS_V2::currentTemp

NV_THERMAL_TARGET NV_GPU_THERMAL_SETTINGS_V2::target

}

NV_GPU_THERMAL_SETTINGS_V2::sensor [NVAPI_MAX_THERMAL_SENSORS_PER_GPU]

NvU32

NV_GPU_CLOCK_FREQUENCIES_V1::version

NvU32

NV_GPU_CLOCK_FREQUENCIES_V1::reserved

NvU32 NV_GPU_CLOCK_FREQUENCIES_V1::bIsPresent:1

NvU32 NV_GPU_CLOCK_FREQUENCIES_V1::reserved:31

NvU32 NV_GPU_CLOCK_FREQUENCIES_V1::frequency

struct {

NvU32 NV_GPU_CLOCK_FREQUENCIES_V1::bIsPresent:1

NvU32 NV_GPU_CLOCK_FREQUENCIES_V1::reserved:31

NvU32 NV_GPU_CLOCK_FREQUENCIES_V1::frequency

}

NV_GPU_CLOCK_FREQUENCIES_V1::domain [NVAPI_MAX_GPU_PUBLIC_CLOCKS]

NvU32

NV_GPU_CLOCK_FREQUENCIES_V2::version

NvU32

NV_GPU_CLOCK_FREQUENCIES_V2::ClockType:4

NvU32

NV_GPU_CLOCK_FREQUENCIES_V2::reserved:20

NvU32

NV_GPU_CLOCK_FREQUENCIES_V2::reserved1:8

NvU32 NV_GPU_CLOCK_FREQUENCIES_V2::bIsPresent:1

NvU32 NV_GPU_CLOCK_FREQUENCIES_V2::reserved:31

NvU32 NV_GPU_CLOCK_FREQUENCIES_V2::frequency

struct {

NvU32 NV_GPU_CLOCK_FREQUENCIES_V2::bIsPresent:1

NvU32 NV_GPU_CLOCK_FREQUENCIES_V2::reserved:31

NvU32 NV_GPU_CLOCK_FREQUENCIES_V2::frequency

}

NV_GPU_CLOCK_FREQUENCIES_V2::domain [NVAPI_MAX_GPU_PUBLIC_CLOCKS]

NvU32

_NV_GPU_QUERY_ILLUMINATION_SUPPORT_PARM_V1::version

NvPhysicalGpuHandle

_NV_GPU_QUERY_ILLUMINATION_SUPPORT_PARM_V1::hPhysicalGpu

NV_GPU_ILLUMINATION_ATTRIB

_NV_GPU_QUERY_ILLUMINATION_SUPPORT_PARM_V1::Attribute

NvU32

_NV_GPU_QUERY_ILLUMINATION_SUPPORT_PARM_V1::bSupported

NvU32

_NV_GPU_GET_ILLUMINATION_PARM_V1::version

NvPhysicalGpuHandle

_NV_GPU_GET_ILLUMINATION_PARM_V1::hPhysicalGpu

NV_GPU_ILLUMINATION_ATTRIB

_NV_GPU_GET_ILLUMINATION_PARM_V1::Attribute

NvU32

_NV_GPU_GET_ILLUMINATION_PARM_V1::Value

NvU32

_NV_GPU_SET_ILLUMINATION_PARM_V1::version

NvPhysicalGpuHandle

_NV_GPU_SET_ILLUMINATION_PARM_V1::hPhysicalGpu

NV_GPU_ILLUMINATION_ATTRIB

_NV_GPU_SET_ILLUMINATION_PARM_V1::Attribute

NvU32

_NV_GPU_SET_ILLUMINATION_PARM_V1::Value

NvU8

_NV_GPU_CLIENT_ILLUM_DEVICE_INFO_DATA_MCUV10::i2cDevIdx

NvU8

_NV_GPU_CLIENT_ILLUM_DEVICE_INFO_DATA_GPIO_PWM_RGBW::gpioPinRed

NvU8

_NV_GPU_CLIENT_ILLUM_DEVICE_INFO_DATA_GPIO_PWM_RGBW::gpioPinGreen

NvU8

_NV_GPU_CLIENT_ILLUM_DEVICE_INFO_DATA_GPIO_PWM_RGBW::gpioPinBlue

NvU8

_NV_GPU_CLIENT_ILLUM_DEVICE_INFO_DATA_GPIO_PWM_RGBW::gpioPinWhite

NvU8

_NV_GPU_CLIENT_ILLUM_DEVICE_INFO_DATA_GPIO_PWM_SINGLE_COLOR::gpioPinSingleColor

NV_GPU_CLIENT_ILLUM_DEVICE_TYPE

_NV_GPU_CLIENT_ILLUM_DEVICE_INFO_V1::type

NvU32

_NV_GPU_CLIENT_ILLUM_DEVICE_INFO_V1::ctrlModeMask

NV_GPU_CLIENT_ILLUM_DEVICE_INFO_DATA_MCUV10 _NV_GPU_CLIENT_ILLUM_DEVICE_INFO_V1::mcuv10

NV_GPU_CLIENT_ILLUM_DEVICE_INFO_DATA_GPIO_PWM_RGBW _NV_GPU_CLIENT_ILLUM_DEVICE_INFO_V1::gpioPwmRgbwv10

NV_GPU_CLIENT_ILLUM_DEVICE_INFO_DATA_GPIO_PWM_SINGLE_COLOR _NV_GPU_CLIENT_ILLUM_DEVICE_INFO_V1::gpioPwmSingleColorv10

NvU8 _NV_GPU_CLIENT_ILLUM_DEVICE_INFO_V1::rsvd [64]

union {

NV_GPU_CLIENT_ILLUM_DEVICE_INFO_DATA_MCUV10 _NV_GPU_CLIENT_ILLUM_DEVICE_INFO_V1::mcuv10

NV_GPU_CLIENT_ILLUM_DEVICE_INFO_DATA_GPIO_PWM_RGBW _NV_GPU_CLIENT_ILLUM_DEVICE_INFO_V1::gpioPwmRgbwv10

NV_GPU_CLIENT_ILLUM_DEVICE_INFO_DATA_GPIO_PWM_SINGLE_COLOR _NV_GPU_CLIENT_ILLUM_DEVICE_INFO_V1::gpioPwmSingleColorv10

NvU8 _NV_GPU_CLIENT_ILLUM_DEVICE_INFO_V1::rsvd [64]

}

_NV_GPU_CLIENT_ILLUM_DEVICE_INFO_V1::data

NvU32

_NV_GPU_CLIENT_ILLUM_DEVICE_INFO_PARAMS_V1::version

NvU32

_NV_GPU_CLIENT_ILLUM_DEVICE_INFO_PARAMS_V1::numIllumDevices

NvU8

_NV_GPU_CLIENT_ILLUM_DEVICE_INFO_PARAMS_V1::rsvd [64]

NV_GPU_CLIENT_ILLUM_DEVICE_INFO_V1

_NV_GPU_CLIENT_ILLUM_DEVICE_INFO_PARAMS_V1::devices [NV_GPU_CLIENT_ILLUM_DEVICE_NUM_DEVICES_MAX]

NvBool

NV_GPU_CLIENT_ILLUM_DEVICE_SYNC_V1::bSync

NvU64

NV_GPU_CLIENT_ILLUM_DEVICE_SYNC_V1::timeStampms

NvU8

NV_GPU_CLIENT_ILLUM_DEVICE_SYNC_V1::rsvd [64]

NV_GPU_CLIENT_ILLUM_DEVICE_TYPE

NV_GPU_CLIENT_ILLUM_DEVICE_CONTROL_V1::type

NV_GPU_CLIENT_ILLUM_DEVICE_SYNC_V1

NV_GPU_CLIENT_ILLUM_DEVICE_CONTROL_V1::syncData

NvU8

NV_GPU_CLIENT_ILLUM_DEVICE_CONTROL_V1::rsvd [64]

NvU32

NV_GPU_CLIENT_ILLUM_DEVICE_CONTROL_PARAMS_V1::version

NvU32

NV_GPU_CLIENT_ILLUM_DEVICE_CONTROL_PARAMS_V1::numIllumDevices

NvU8

NV_GPU_CLIENT_ILLUM_DEVICE_CONTROL_PARAMS_V1::rsvd [64]

NV_GPU_CLIENT_ILLUM_DEVICE_CONTROL_V1

NV_GPU_CLIENT_ILLUM_DEVICE_CONTROL_PARAMS_V1::devices [NV_GPU_CLIENT_ILLUM_DEVICE_NUM_DEVICES_MAX]

NvU8

_NV_GPU_CLIENT_ILLUM_ZONE_INFO_DATA_RGB::rsvd

NvU8

_NV_GPU_CLIENT_ILLUM_ZONE_INFO_DATA_RGBW::rsvd

NvU8

_NV_GPU_CLIENT_ILLUM_ZONE_INFO_DATA_SINGLE_COLOR::rsvd

NV_GPU_CLIENT_ILLUM_ZONE_TYPE

_NV_GPU_CLIENT_ILLUM_ZONE_INFO_V1::type

NvU8

_NV_GPU_CLIENT_ILLUM_ZONE_INFO_V1::illumDeviceIdx

NvU8

_NV_GPU_CLIENT_ILLUM_ZONE_INFO_V1::provIdx

NV_GPU_CLIENT_ILLUM_ZONE_LOCATION

_NV_GPU_CLIENT_ILLUM_ZONE_INFO_V1::zoneLocation

NV_GPU_CLIENT_ILLUM_ZONE_INFO_DATA_RGB _NV_GPU_CLIENT_ILLUM_ZONE_INFO_V1::rgb

NV_GPU_CLIENT_ILLUM_ZONE_INFO_DATA_RGBW _NV_GPU_CLIENT_ILLUM_ZONE_INFO_V1::rgbw

NV_GPU_CLIENT_ILLUM_ZONE_INFO_DATA_SINGLE_COLOR _NV_GPU_CLIENT_ILLUM_ZONE_INFO_V1::singleColor

NvU8 _NV_GPU_CLIENT_ILLUM_ZONE_INFO_V1::rsvd [64]

union {

NV_GPU_CLIENT_ILLUM_ZONE_INFO_DATA_RGB _NV_GPU_CLIENT_ILLUM_ZONE_INFO_V1::rgb

NV_GPU_CLIENT_ILLUM_ZONE_INFO_DATA_RGBW _NV_GPU_CLIENT_ILLUM_ZONE_INFO_V1::rgbw

NV_GPU_CLIENT_ILLUM_ZONE_INFO_DATA_SINGLE_COLOR _NV_GPU_CLIENT_ILLUM_ZONE_INFO_V1::singleColor

NvU8 _NV_GPU_CLIENT_ILLUM_ZONE_INFO_V1::rsvd [64]

}

_NV_GPU_CLIENT_ILLUM_ZONE_INFO_V1::data

NvU32

_NV_GPU_CLIENT_ILLUM_ZONE_INFO_PARAMS_V1::version

NvU32

_NV_GPU_CLIENT_ILLUM_ZONE_INFO_PARAMS_V1::numIllumZones

NvU8

_NV_GPU_CLIENT_ILLUM_ZONE_INFO_PARAMS_V1::rsvd [64]

NV_GPU_CLIENT_ILLUM_ZONE_INFO_V1

_NV_GPU_CLIENT_ILLUM_ZONE_INFO_PARAMS_V1::zones [NV_GPU_CLIENT_ILLUM_ZONE_NUM_ZONES_MAX]

NvU8

_NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_RGB_PARAMS::colorR

NvU8

_NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_RGB_PARAMS::colorG

NvU8

_NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_RGB_PARAMS::colorB

NvU8

_NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_RGB_PARAMS::brightnessPct

NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_RGB_PARAMS

_NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_RGB::rgbParams

NV_GPU_CLIENT_ILLUM_PIECEWISE_LINEAR_CYCLE_TYPE

_NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR::cycleType

NvU8

_NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR::grpCount

NvU16

_NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR::riseTimems

NvU16

_NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR::fallTimems

NvU16

_NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR::ATimems

NvU16

_NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR::BTimems

NvU16

_NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR::grpIdleTimems

NvU16

_NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR::phaseOffsetms

NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_RGB_PARAMS

_NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR_RGB::rgbParams [NV_GPU_CLIENT_ILLUM_CTRL_MODE_PIECEWISE_LINEAR_COLOR_ENDPOINTS]

NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR

_NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR_RGB::piecewiseLinearData

NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_RGB _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_RGB::manualRGB

NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR_RGB _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_RGB::piecewiseLinearRGB

NvU8 _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_RGB::rsvd [64]

union {

NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_RGB _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_RGB::manualRGB

NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR_RGB _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_RGB::piecewiseLinearRGB

NvU8 _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_RGB::rsvd [64]

}

_NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_RGB::data

NvU8

_NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_COLOR_FIXED_PARAMS::brightnessPct

NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_COLOR_FIXED_PARAMS

_NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_COLOR_FIXED::colorFixedParams

NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_COLOR_FIXED_PARAMS

_NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR_COLOR_FIXED::colorFixedParams [NV_GPU_CLIENT_ILLUM_CTRL_MODE_PIECEWISE_LINEAR_COLOR_ENDPOINTS]

NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR

_NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR_COLOR_FIXED::piecewiseLinearData

NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_COLOR_FIXED _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_COLOR_FIXED::manualColorFixed

NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR_COLOR_FIXED _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_COLOR_FIXED::piecewiseLinearColorFixed

NvU8 _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_COLOR_FIXED::rsvd [64]

union {

NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_COLOR_FIXED _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_COLOR_FIXED::manualColorFixed

NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR_COLOR_FIXED _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_COLOR_FIXED::piecewiseLinearColorFixed

NvU8 _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_COLOR_FIXED::rsvd [64]

}

_NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_COLOR_FIXED::data

NvU8

_NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_RGBW_PARAMS::colorR

NvU8

_NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_RGBW_PARAMS::colorG

NvU8

_NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_RGBW_PARAMS::colorB

NvU8

_NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_RGBW_PARAMS::colorW

NvU8

_NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_RGBW_PARAMS::brightnessPct

NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_RGBW_PARAMS

_NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_RGBW::rgbwParams

NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_RGBW_PARAMS

_NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR_RGBW::rgbwParams [NV_GPU_CLIENT_ILLUM_CTRL_MODE_PIECEWISE_LINEAR_COLOR_ENDPOINTS]

NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR

_NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR_RGBW::piecewiseLinearData

NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_RGBW _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_RGBW::manualRGBW

NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR_RGBW _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_RGBW::piecewiseLinearRGBW

NvU8 _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_RGBW::rsvd [64]

union {

NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_RGBW _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_RGBW::manualRGBW

NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR_RGBW _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_RGBW::piecewiseLinearRGBW

NvU8 _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_RGBW::rsvd [64]

}

_NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_RGBW::data

NvU8

_NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_SINGLE_COLOR_PARAMS::brightnessPct

NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_SINGLE_COLOR_PARAMS

_NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_SINGLE_COLOR::singleColorParams

NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_SINGLE_COLOR_PARAMS

_NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR_SINGLE_COLOR::singleColorParams [NV_GPU_CLIENT_ILLUM_CTRL_MODE_PIECEWISE_LINEAR_COLOR_ENDPOINTS]

NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR

_NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR_SINGLE_COLOR::piecewiseLinearData

NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_SINGLE_COLOR _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_SINGLE_COLOR::manualSingleColor

NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR_SINGLE_COLOR _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_SINGLE_COLOR::piecewiseLinearSingleColor

NvU8 _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_SINGLE_COLOR::rsvd [64]

union {

NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_SINGLE_COLOR _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_SINGLE_COLOR::manualSingleColor

NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR_SINGLE_COLOR _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_SINGLE_COLOR::piecewiseLinearSingleColor

NvU8 _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_SINGLE_COLOR::rsvd [64]

}

_NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_SINGLE_COLOR::data

NV_GPU_CLIENT_ILLUM_ZONE_TYPE

_NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_V1::type

NV_GPU_CLIENT_ILLUM_CTRL_MODE

_NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_V1::ctrlMode

NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_RGB _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_V1::rgb

NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_COLOR_FIXED _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_V1::colorFixed

NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_RGBW _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_V1::rgbw

NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_SINGLE_COLOR _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_V1::singleColor

NvU8 _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_V1::rsvd [64]

union {

NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_RGB _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_V1::rgb

NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_COLOR_FIXED _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_V1::colorFixed

NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_RGBW _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_V1::rgbw

NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_SINGLE_COLOR _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_V1::singleColor

NvU8 _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_V1::rsvd [64]

}

_NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_V1::data

NvU32

_NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_PARAMS_V1::version

NvU32

_NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_PARAMS_V1::bDefault: 1

NvU32

_NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_PARAMS_V1::rsvdField: 31

NvU32

_NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_PARAMS_V1::numIllumZonesControl

NvU8

_NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_PARAMS_V1::rsvd [64]

NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_V1

_NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_PARAMS_V1::zones [NV_GPU_CLIENT_ILLUM_ZONE_NUM_ZONES_MAX]

NvU32

_NV_DISPLAY_PORT_INFO_V1::version

NvU32

_NV_DISPLAY_PORT_INFO_V1::dpcd_ver

NV_DP_LINK_RATE

_NV_DISPLAY_PORT_INFO_V1::maxLinkRate

NV_DP_LANE_COUNT

_NV_DISPLAY_PORT_INFO_V1::maxLaneCount

NV_DP_LINK_RATE

_NV_DISPLAY_PORT_INFO_V1::curLinkRate

NV_DP_LANE_COUNT

_NV_DISPLAY_PORT_INFO_V1::curLaneCount

NV_DP_COLOR_FORMAT

_NV_DISPLAY_PORT_INFO_V1::colorFormat

NV_DP_DYNAMIC_RANGE

_NV_DISPLAY_PORT_INFO_V1::dynamicRange

NV_DP_COLORIMETRY

_NV_DISPLAY_PORT_INFO_V1::colorimetry

NV_DP_BPC

_NV_DISPLAY_PORT_INFO_V1::bpc

NvU32

_NV_DISPLAY_PORT_INFO_V1::isDp: 1

NvU32

_NV_DISPLAY_PORT_INFO_V1::isInternalDp: 1

NvU32

_NV_DISPLAY_PORT_INFO_V1::isColorCtrlSupported: 1

NvU32

_NV_DISPLAY_PORT_INFO_V1::is6BPCSupported: 1

NvU32

_NV_DISPLAY_PORT_INFO_V1::is8BPCSupported: 1

NvU32

_NV_DISPLAY_PORT_INFO_V1::is10BPCSupported: 1

NvU32

_NV_DISPLAY_PORT_INFO_V1::is12BPCSupported: 1

NvU32

_NV_DISPLAY_PORT_INFO_V1::is16BPCSupported: 1

NvU32

_NV_DISPLAY_PORT_INFO_V1::isYCrCb420Supported: 1

NvU32

_NV_DISPLAY_PORT_INFO_V1::isYCrCb422Supported: 1

NvU32

_NV_DISPLAY_PORT_INFO_V1::isYCrCb444Supported: 1

NvU32

_NV_DISPLAY_PORT_INFO_V1::isRgb444SupportedOnCurrentMode: 1

NvU32

_NV_DISPLAY_PORT_INFO_V1::isYCbCr444SupportedOnCurrentMode: 1

NvU32

_NV_DISPLAY_PORT_INFO_V1::isYCbCr422SupportedOnCurrentMode: 1

NvU32

_NV_DISPLAY_PORT_INFO_V1::isYCbCr420SupportedOnCurrentMode: 1

NvU32

_NV_DISPLAY_PORT_INFO_V1::is6BPCSupportedOnCurrentMode: 1

NvU32

_NV_DISPLAY_PORT_INFO_V1::is8BPCSupportedOnCurrentMode: 1

NvU32

_NV_DISPLAY_PORT_INFO_V1::is10BPCSupportedOnCurrentMode: 1

NvU32

_NV_DISPLAY_PORT_INFO_V1::is12BPCSupportedOnCurrentMode: 1

NvU32

_NV_DISPLAY_PORT_INFO_V1::is16BPCSupportedOnCurrentMode: 1

NvU32

_NV_DISPLAY_PORT_INFO_V1::isMonxvYCC601Capable: 1

NvU32

_NV_DISPLAY_PORT_INFO_V1::isMonxvYCC709Capable: 1

NvU32

_NV_DISPLAY_PORT_INFO_V1::isMonsYCC601Capable: 1

NvU32

_NV_DISPLAY_PORT_INFO_V1::isMonAdobeYCC601Capable: 1

NvU32

_NV_DISPLAY_PORT_INFO_V1::isMonAdobeRGBCapable: 1

NvU32

_NV_DISPLAY_PORT_INFO_V1::isMonBT2020RGBCapable: 1

NvU32

_NV_DISPLAY_PORT_INFO_V1::isMonBT2020YCCCapable: 1

NvU32

_NV_DISPLAY_PORT_INFO_V1::isMonBT2020cYCCCapable: 1

NvU32

_NV_DISPLAY_PORT_INFO_V1::reserved: 4

NvU32

NV_DISPLAY_PORT_CONFIG::version

NV_DP_LINK_RATE

NV_DISPLAY_PORT_CONFIG::linkRate

NV_DP_LANE_COUNT

NV_DISPLAY_PORT_CONFIG::laneCount

NV_DP_COLOR_FORMAT

NV_DISPLAY_PORT_CONFIG::colorFormat

NV_DP_DYNAMIC_RANGE

NV_DISPLAY_PORT_CONFIG::dynamicRange

NV_DP_COLORIMETRY

NV_DISPLAY_PORT_CONFIG::colorimetry

NV_DP_BPC

NV_DISPLAY_PORT_CONFIG::bpc

NvU32

NV_DISPLAY_PORT_CONFIG::isHPD: 1

NvU32

NV_DISPLAY_PORT_CONFIG::isSetDeferred: 1

NvU32

NV_DISPLAY_PORT_CONFIG::isChromaLpfOff: 1

NvU32

NV_DISPLAY_PORT_CONFIG::isDitherOff: 1

NvU32

NV_DISPLAY_PORT_CONFIG::testLinkTrain: 1

NvU32

NV_DISPLAY_PORT_CONFIG::testColorChange: 1

NvU32

_NV_HDMI_SUPPORT_INFO_V1::version

NvU32

_NV_HDMI_SUPPORT_INFO_V1::isGpuHDMICapable: 1

NvU32

_NV_HDMI_SUPPORT_INFO_V1::isMonUnderscanCapable: 1

NvU32

_NV_HDMI_SUPPORT_INFO_V1::isMonBasicAudioCapable: 1

NvU32

_NV_HDMI_SUPPORT_INFO_V1::isMonYCbCr444Capable: 1

NvU32

_NV_HDMI_SUPPORT_INFO_V1::isMonYCbCr422Capable: 1

NvU32

_NV_HDMI_SUPPORT_INFO_V1::isMonxvYCC601Capable: 1

NvU32

_NV_HDMI_SUPPORT_INFO_V1::isMonxvYCC709Capable: 1

NvU32

_NV_HDMI_SUPPORT_INFO_V1::isMonHDMI: 1

NvU32

_NV_HDMI_SUPPORT_INFO_V1::reserved: 24

NvU32

_NV_HDMI_SUPPORT_INFO_V1::EDID861ExtRev

NvU32

_NV_HDMI_SUPPORT_INFO_V2::version

NvU32

_NV_HDMI_SUPPORT_INFO_V2::isGpuHDMICapable: 1

NvU32

_NV_HDMI_SUPPORT_INFO_V2::isMonUnderscanCapable: 1

NvU32

_NV_HDMI_SUPPORT_INFO_V2::isMonBasicAudioCapable: 1

NvU32

_NV_HDMI_SUPPORT_INFO_V2::isMonYCbCr444Capable: 1

NvU32

_NV_HDMI_SUPPORT_INFO_V2::isMonYCbCr422Capable: 1

NvU32

_NV_HDMI_SUPPORT_INFO_V2::isMonxvYCC601Capable: 1

NvU32

_NV_HDMI_SUPPORT_INFO_V2::isMonxvYCC709Capable: 1

NvU32

_NV_HDMI_SUPPORT_INFO_V2::isMonHDMI: 1

NvU32

_NV_HDMI_SUPPORT_INFO_V2::isMonsYCC601Capable: 1

NvU32

_NV_HDMI_SUPPORT_INFO_V2::isMonAdobeYCC601Capable: 1

NvU32

_NV_HDMI_SUPPORT_INFO_V2::isMonAdobeRGBCapable: 1

NvU32

_NV_HDMI_SUPPORT_INFO_V2::reserved: 21

NvU32

_NV_HDMI_SUPPORT_INFO_V2::EDID861ExtRev

NvU32

NV_INFOFRAME_PROPERTY::mode: 4

NvU32

NV_INFOFRAME_PROPERTY::blackList: 2

NvU32

NV_INFOFRAME_PROPERTY::reserved: 10

NvU32

NV_INFOFRAME_PROPERTY::version: 8

NvU32

NV_INFOFRAME_PROPERTY::length: 8

NvU32

NV_INFOFRAME_VIDEO::vic: 8

NvU32

NV_INFOFRAME_VIDEO::pixelRepeat: 5

NvU32

NV_INFOFRAME_VIDEO::colorSpace: 3

NvU32

NV_INFOFRAME_VIDEO::colorimetry: 3

NvU32

NV_INFOFRAME_VIDEO::extendedColorimetry: 4

NvU32

NV_INFOFRAME_VIDEO::rgbQuantizationRange: 3

NvU32

NV_INFOFRAME_VIDEO::yccQuantizationRange: 3

NvU32

NV_INFOFRAME_VIDEO::itContent: 2

NvU32

NV_INFOFRAME_VIDEO::contentTypes: 3

NvU32

NV_INFOFRAME_VIDEO::scanInfo: 3

NvU32

NV_INFOFRAME_VIDEO::activeFormatInfoPresent: 2

NvU32

NV_INFOFRAME_VIDEO::activeFormatAspectRatio: 5

NvU32

NV_INFOFRAME_VIDEO::picAspectRatio: 3

NvU32

NV_INFOFRAME_VIDEO::nonuniformScaling: 3

NvU32

NV_INFOFRAME_VIDEO::barInfo: 3

NvU32

NV_INFOFRAME_VIDEO::top_bar: 17

NvU32

NV_INFOFRAME_VIDEO::bottom_bar: 17

NvU32

NV_INFOFRAME_VIDEO::left_bar: 17

NvU32

NV_INFOFRAME_VIDEO::right_bar: 17

NvU32

NV_INFOFRAME_VIDEO::Future17: 2

NvU32

NV_INFOFRAME_VIDEO::Future47: 2

NvU32

NV_INFOFRAME_AUDIO::codingType: 5

NvU32

NV_INFOFRAME_AUDIO::codingExtensionType: 6

NvU32

NV_INFOFRAME_AUDIO::sampleSize: 3

NvU32

NV_INFOFRAME_AUDIO::sampleRate: 4

NvU32

NV_INFOFRAME_AUDIO::channelCount: 4

NvU32

NV_INFOFRAME_AUDIO::speakerPlacement: 9

NvU32

NV_INFOFRAME_AUDIO::downmixInhibit: 2

NvU32

NV_INFOFRAME_AUDIO::lfePlaybackLevel: 3

NvU32

NV_INFOFRAME_AUDIO::levelShift: 5

NvU32

NV_INFOFRAME_AUDIO::Future12: 2

NvU32

NV_INFOFRAME_AUDIO::Future2x: 4

NvU32

NV_INFOFRAME_AUDIO::Future3x: 4

NvU32

NV_INFOFRAME_AUDIO::Future52: 2

NvU32

NV_INFOFRAME_AUDIO::Future6: 9

NvU32

NV_INFOFRAME_AUDIO::Future7: 9

NvU32

NV_INFOFRAME_AUDIO::Future8: 9

NvU32

NV_INFOFRAME_AUDIO::Future9: 9

NvU32

NV_INFOFRAME_AUDIO::Future10: 9

NvU32

NV_INFOFRAME_DATA::version

NvU16

NV_INFOFRAME_DATA::size

NvU8

NV_INFOFRAME_DATA::cmd

NvU8

NV_INFOFRAME_DATA::type

NV_INFOFRAME_PROPERTY NV_INFOFRAME_DATA::property

NV_INFOFRAME_AUDIO NV_INFOFRAME_DATA::audio

NV_INFOFRAME_VIDEO NV_INFOFRAME_DATA::video

union {

NV_INFOFRAME_PROPERTY NV_INFOFRAME_DATA::property

NV_INFOFRAME_AUDIO NV_INFOFRAME_DATA::audio

NV_INFOFRAME_VIDEO NV_INFOFRAME_DATA::video

}

NV_INFOFRAME_DATA::infoframe

NvU32

_NV_COLOR_DATA_V1::version

NvU16

_NV_COLOR_DATA_V1::size

NvU8

_NV_COLOR_DATA_V1::cmd

NvU8 _NV_COLOR_DATA_V1::colorFormat

NvU8 _NV_COLOR_DATA_V1::colorimetry

struct {

NvU8 _NV_COLOR_DATA_V1::colorFormat

NvU8 _NV_COLOR_DATA_V1::colorimetry

}

_NV_COLOR_DATA_V1::data

NvU32

_NV_COLOR_DATA_V2::version

NvU16

_NV_COLOR_DATA_V2::size

NvU8

_NV_COLOR_DATA_V2::cmd

NvU8 _NV_COLOR_DATA_V2::colorFormat

NvU8 _NV_COLOR_DATA_V2::colorimetry

NvU8 _NV_COLOR_DATA_V2::dynamicRange

struct {

NvU8 _NV_COLOR_DATA_V2::colorFormat

NvU8 _NV_COLOR_DATA_V2::colorimetry

NvU8 _NV_COLOR_DATA_V2::dynamicRange

}

_NV_COLOR_DATA_V2::data

NvU32

_NV_COLOR_DATA_V3::version

NvU16

_NV_COLOR_DATA_V3::size

NvU8

_NV_COLOR_DATA_V3::cmd

NvU8 _NV_COLOR_DATA_V3::colorFormat

NvU8 _NV_COLOR_DATA_V3::colorimetry

NvU8 _NV_COLOR_DATA_V3::dynamicRange

NV_BPC _NV_COLOR_DATA_V3::bpc

struct {

NvU8 _NV_COLOR_DATA_V3::colorFormat

NvU8 _NV_COLOR_DATA_V3::colorimetry

NvU8 _NV_COLOR_DATA_V3::dynamicRange

NV_BPC _NV_COLOR_DATA_V3::bpc

}

_NV_COLOR_DATA_V3::data

NvU32

_NV_COLOR_DATA_V4::version

NvU16

_NV_COLOR_DATA_V4::size

NvU8

_NV_COLOR_DATA_V4::cmd

NvU8 _NV_COLOR_DATA_V4::colorFormat

NvU8 _NV_COLOR_DATA_V4::colorimetry

NvU8 _NV_COLOR_DATA_V4::dynamicRange

NV_BPC _NV_COLOR_DATA_V4::bpc

NV_COLOR_SELECTION_POLICY _NV_COLOR_DATA_V4::colorSelectionPolicy

struct {

NvU8 _NV_COLOR_DATA_V4::colorFormat

NvU8 _NV_COLOR_DATA_V4::colorimetry

NvU8 _NV_COLOR_DATA_V4::dynamicRange

NV_BPC _NV_COLOR_DATA_V4::bpc

NV_COLOR_SELECTION_POLICY _NV_COLOR_DATA_V4::colorSelectionPolicy

}

_NV_COLOR_DATA_V4::data

NvU32

_NV_COLOR_DATA_V5::version

NvU16

_NV_COLOR_DATA_V5::size

NvU8

_NV_COLOR_DATA_V5::cmd

NvU8 _NV_COLOR_DATA_V5::colorFormat

NvU8 _NV_COLOR_DATA_V5::colorimetry

NvU8 _NV_COLOR_DATA_V5::dynamicRange

NV_BPC _NV_COLOR_DATA_V5::bpc

NV_COLOR_SELECTION_POLICY _NV_COLOR_DATA_V5::colorSelectionPolicy

NV_DESKTOP_COLOR_DEPTH _NV_COLOR_DATA_V5::depth

struct {

NvU8 _NV_COLOR_DATA_V5::colorFormat

NvU8 _NV_COLOR_DATA_V5::colorimetry

NvU8 _NV_COLOR_DATA_V5::dynamicRange

NV_BPC _NV_COLOR_DATA_V5::bpc

NV_COLOR_SELECTION_POLICY _NV_COLOR_DATA_V5::colorSelectionPolicy

NV_DESKTOP_COLOR_DEPTH _NV_COLOR_DATA_V5::depth

}

_NV_COLOR_DATA_V5::data

NvU32

_NV_HDR_CAPABILITIES_V1::version

NvU32

_NV_HDR_CAPABILITIES_V1::isST2084EotfSupported:1

NvU32

_NV_HDR_CAPABILITIES_V1::isTraditionalHdrGammaSupported:1

NvU32

_NV_HDR_CAPABILITIES_V1::isEdrSupported:1

NvU32

_NV_HDR_CAPABILITIES_V1::driverExpandDefaultHdrParameters:1

NvU32

_NV_HDR_CAPABILITIES_V1::isTraditionalSdrGammaSupported:1

NvU32

_NV_HDR_CAPABILITIES_V1::reserved:27

NV_STATIC_METADATA_DESCRIPTOR_ID

_NV_HDR_CAPABILITIES_V1::static_metadata_descriptor_id

NvU16 _NV_HDR_CAPABILITIES_V1::displayPrimary_x0

NvU16 _NV_HDR_CAPABILITIES_V1::displayPrimary_y0

NvU16 _NV_HDR_CAPABILITIES_V1::displayPrimary_x1

NvU16 _NV_HDR_CAPABILITIES_V1::displayPrimary_y1

NvU16 _NV_HDR_CAPABILITIES_V1::displayPrimary_x2

NvU16 _NV_HDR_CAPABILITIES_V1::displayPrimary_y2

NvU16 _NV_HDR_CAPABILITIES_V1::displayWhitePoint_x

NvU16 _NV_HDR_CAPABILITIES_V1::displayWhitePoint_y

NvU16 _NV_HDR_CAPABILITIES_V1::desired_content_max_luminance

NvU16 _NV_HDR_CAPABILITIES_V1::desired_content_min_luminance

NvU16 _NV_HDR_CAPABILITIES_V1::desired_content_max_frame_average_luminance

struct {

NvU16 _NV_HDR_CAPABILITIES_V1::displayPrimary_x0

NvU16 _NV_HDR_CAPABILITIES_V1::displayPrimary_y0

NvU16 _NV_HDR_CAPABILITIES_V1::displayPrimary_x1

NvU16 _NV_HDR_CAPABILITIES_V1::displayPrimary_y1

NvU16 _NV_HDR_CAPABILITIES_V1::displayPrimary_x2

NvU16 _NV_HDR_CAPABILITIES_V1::displayPrimary_y2

NvU16 _NV_HDR_CAPABILITIES_V1::displayWhitePoint_x

NvU16 _NV_HDR_CAPABILITIES_V1::displayWhitePoint_y

NvU16 _NV_HDR_CAPABILITIES_V1::desired_content_max_luminance

NvU16 _NV_HDR_CAPABILITIES_V1::desired_content_min_luminance

NvU16 _NV_HDR_CAPABILITIES_V1::desired_content_max_frame_average_luminance

}

_NV_HDR_CAPABILITIES_V1::display_data

NvU32

_NV_HDR_CAPABILITIES_V2::version

NvU32

_NV_HDR_CAPABILITIES_V2::isST2084EotfSupported:1

NvU32

_NV_HDR_CAPABILITIES_V2::isTraditionalHdrGammaSupported:1

NvU32

_NV_HDR_CAPABILITIES_V2::isEdrSupported:1

NvU32

_NV_HDR_CAPABILITIES_V2::driverExpandDefaultHdrParameters:1

NvU32

_NV_HDR_CAPABILITIES_V2::isTraditionalSdrGammaSupported:1

NvU32

_NV_HDR_CAPABILITIES_V2::isDolbyVisionSupported:1

NvU32

_NV_HDR_CAPABILITIES_V2::reserved:26

NV_STATIC_METADATA_DESCRIPTOR_ID

_NV_HDR_CAPABILITIES_V2::static_metadata_descriptor_id

NvU16 _NV_HDR_CAPABILITIES_V2::displayPrimary_x0

NvU16 _NV_HDR_CAPABILITIES_V2::displayPrimary_y0

NvU16 _NV_HDR_CAPABILITIES_V2::displayPrimary_x1

NvU16 _NV_HDR_CAPABILITIES_V2::displayPrimary_y1

NvU16 _NV_HDR_CAPABILITIES_V2::displayPrimary_x2

NvU16 _NV_HDR_CAPABILITIES_V2::displayPrimary_y2

NvU16 _NV_HDR_CAPABILITIES_V2::displayWhitePoint_x

NvU16 _NV_HDR_CAPABILITIES_V2::displayWhitePoint_y

NvU16 _NV_HDR_CAPABILITIES_V2::desired_content_max_luminance

NvU16 _NV_HDR_CAPABILITIES_V2::desired_content_min_luminance

NvU16 _NV_HDR_CAPABILITIES_V2::desired_content_max_frame_average_luminance

struct {

NvU16 _NV_HDR_CAPABILITIES_V2::displayPrimary_x0

NvU16 _NV_HDR_CAPABILITIES_V2::displayPrimary_y0

NvU16 _NV_HDR_CAPABILITIES_V2::displayPrimary_x1

NvU16 _NV_HDR_CAPABILITIES_V2::displayPrimary_y1

NvU16 _NV_HDR_CAPABILITIES_V2::displayPrimary_x2

NvU16 _NV_HDR_CAPABILITIES_V2::displayPrimary_y2

NvU16 _NV_HDR_CAPABILITIES_V2::displayWhitePoint_x

NvU16 _NV_HDR_CAPABILITIES_V2::displayWhitePoint_y

NvU16 _NV_HDR_CAPABILITIES_V2::desired_content_max_luminance

NvU16 _NV_HDR_CAPABILITIES_V2::desired_content_min_luminance

NvU16 _NV_HDR_CAPABILITIES_V2::desired_content_max_frame_average_luminance

}

_NV_HDR_CAPABILITIES_V2::display_data

NvU32 _NV_HDR_CAPABILITIES_V2::VSVDB_version: 3

NvU32 _NV_HDR_CAPABILITIES_V2::dm_version: 8

NvU32 _NV_HDR_CAPABILITIES_V2::supports_2160p60hz: 1

NvU32 _NV_HDR_CAPABILITIES_V2::supports_YUV422_12bit: 1

NvU32 _NV_HDR_CAPABILITIES_V2::supports_global_dimming: 1

NvU32 _NV_HDR_CAPABILITIES_V2::colorimetry: 1

NvU32 _NV_HDR_CAPABILITIES_V2::supports_backlight_control: 2

NvU32 _NV_HDR_CAPABILITIES_V2::backlt_min_luma: 2

NvU32 _NV_HDR_CAPABILITIES_V2::interface_supported_by_sink: 2

NvU32 _NV_HDR_CAPABILITIES_V2::supports_10b_12b_444: 2

NvU32 _NV_HDR_CAPABILITIES_V2::reserved: 9

NvU16 _NV_HDR_CAPABILITIES_V2::target_min_luminance

NvU16 _NV_HDR_CAPABILITIES_V2::target_max_luminance

NvU16 _NV_HDR_CAPABILITIES_V2::cc_red_x

NvU16 _NV_HDR_CAPABILITIES_V2::cc_red_y

NvU16 _NV_HDR_CAPABILITIES_V2::cc_green_x

NvU16 _NV_HDR_CAPABILITIES_V2::cc_green_y

NvU16 _NV_HDR_CAPABILITIES_V2::cc_blue_x

NvU16 _NV_HDR_CAPABILITIES_V2::cc_blue_y

NvU16 _NV_HDR_CAPABILITIES_V2::cc_white_x

NvU16 _NV_HDR_CAPABILITIES_V2::cc_white_y

struct {

NvU32 _NV_HDR_CAPABILITIES_V2::VSVDB_version: 3

NvU32 _NV_HDR_CAPABILITIES_V2::dm_version: 8

NvU32 _NV_HDR_CAPABILITIES_V2::supports_2160p60hz: 1

NvU32 _NV_HDR_CAPABILITIES_V2::supports_YUV422_12bit: 1

NvU32 _NV_HDR_CAPABILITIES_V2::supports_global_dimming: 1

NvU32 _NV_HDR_CAPABILITIES_V2::colorimetry: 1

NvU32 _NV_HDR_CAPABILITIES_V2::supports_backlight_control: 2

NvU32 _NV_HDR_CAPABILITIES_V2::backlt_min_luma: 2

NvU32 _NV_HDR_CAPABILITIES_V2::interface_supported_by_sink: 2

NvU32 _NV_HDR_CAPABILITIES_V2::supports_10b_12b_444: 2

NvU32 _NV_HDR_CAPABILITIES_V2::reserved: 9

NvU16 _NV_HDR_CAPABILITIES_V2::target_min_luminance

NvU16 _NV_HDR_CAPABILITIES_V2::target_max_luminance

NvU16 _NV_HDR_CAPABILITIES_V2::cc_red_x

NvU16 _NV_HDR_CAPABILITIES_V2::cc_red_y

NvU16 _NV_HDR_CAPABILITIES_V2::cc_green_x

NvU16 _NV_HDR_CAPABILITIES_V2::cc_green_y

NvU16 _NV_HDR_CAPABILITIES_V2::cc_blue_x

NvU16 _NV_HDR_CAPABILITIES_V2::cc_blue_y

NvU16 _NV_HDR_CAPABILITIES_V2::cc_white_x

NvU16 _NV_HDR_CAPABILITIES_V2::cc_white_y

}

_NV_HDR_CAPABILITIES_V2::dv_static_metadata

NvU32

_NV_HDR_CAPABILITIES_V3::version

NvU32

_NV_HDR_CAPABILITIES_V3::isST2084EotfSupported:1

NvU32

_NV_HDR_CAPABILITIES_V3::isTraditionalHdrGammaSupported:1

NvU32

_NV_HDR_CAPABILITIES_V3::isEdrSupported:1

NvU32

_NV_HDR_CAPABILITIES_V3::driverExpandDefaultHdrParameters:1

NvU32

_NV_HDR_CAPABILITIES_V3::isTraditionalSdrGammaSupported:1

NvU32

_NV_HDR_CAPABILITIES_V3::isDolbyVisionSupported:1

NvU32

_NV_HDR_CAPABILITIES_V3::isHdr10PlusSupported:1

NvU32

_NV_HDR_CAPABILITIES_V3::isHdr10PlusGamingSupported:1

NvU32

_NV_HDR_CAPABILITIES_V3::reserved:24

NV_STATIC_METADATA_DESCRIPTOR_ID

_NV_HDR_CAPABILITIES_V3::static_metadata_descriptor_id

NvU16 _NV_HDR_CAPABILITIES_V3::displayPrimary_x0

NvU16 _NV_HDR_CAPABILITIES_V3::displayPrimary_y0

NvU16 _NV_HDR_CAPABILITIES_V3::displayPrimary_x1

NvU16 _NV_HDR_CAPABILITIES_V3::displayPrimary_y1

NvU16 _NV_HDR_CAPABILITIES_V3::displayPrimary_x2

NvU16 _NV_HDR_CAPABILITIES_V3::displayPrimary_y2

NvU16 _NV_HDR_CAPABILITIES_V3::displayWhitePoint_x

NvU16 _NV_HDR_CAPABILITIES_V3::displayWhitePoint_y

NvU16 _NV_HDR_CAPABILITIES_V3::desired_content_max_luminance

NvU16 _NV_HDR_CAPABILITIES_V3::desired_content_min_luminance

NvU16 _NV_HDR_CAPABILITIES_V3::desired_content_max_frame_average_luminance

struct {

NvU16 _NV_HDR_CAPABILITIES_V3::displayPrimary_x0

NvU16 _NV_HDR_CAPABILITIES_V3::displayPrimary_y0

NvU16 _NV_HDR_CAPABILITIES_V3::displayPrimary_x1

NvU16 _NV_HDR_CAPABILITIES_V3::displayPrimary_y1

NvU16 _NV_HDR_CAPABILITIES_V3::displayPrimary_x2

NvU16 _NV_HDR_CAPABILITIES_V3::displayPrimary_y2

NvU16 _NV_HDR_CAPABILITIES_V3::displayWhitePoint_x

NvU16 _NV_HDR_CAPABILITIES_V3::displayWhitePoint_y

NvU16 _NV_HDR_CAPABILITIES_V3::desired_content_max_luminance

NvU16 _NV_HDR_CAPABILITIES_V3::desired_content_min_luminance

NvU16 _NV_HDR_CAPABILITIES_V3::desired_content_max_frame_average_luminance

}

_NV_HDR_CAPABILITIES_V3::display_data

NvU32 _NV_HDR_CAPABILITIES_V3::VSVDB_version: 3

NvU32 _NV_HDR_CAPABILITIES_V3::dm_version: 8

NvU32 _NV_HDR_CAPABILITIES_V3::supports_2160p60hz: 1

NvU32 _NV_HDR_CAPABILITIES_V3::supports_YUV422_12bit: 1

NvU32 _NV_HDR_CAPABILITIES_V3::supports_global_dimming: 1

NvU32 _NV_HDR_CAPABILITIES_V3::colorimetry: 1

NvU32 _NV_HDR_CAPABILITIES_V3::supports_backlight_control: 2

NvU32 _NV_HDR_CAPABILITIES_V3::backlt_min_luma: 2

NvU32 _NV_HDR_CAPABILITIES_V3::interface_supported_by_sink: 2

NvU32 _NV_HDR_CAPABILITIES_V3::supports_10b_12b_444: 2

NvU32 _NV_HDR_CAPABILITIES_V3::parity: 1

NvU32 _NV_HDR_CAPABILITIES_V3::reserved: 8

NvU16 _NV_HDR_CAPABILITIES_V3::target_min_luminance

NvU16 _NV_HDR_CAPABILITIES_V3::target_max_luminance

NvU16 _NV_HDR_CAPABILITIES_V3::cc_red_x

NvU16 _NV_HDR_CAPABILITIES_V3::cc_red_y

NvU16 _NV_HDR_CAPABILITIES_V3::cc_green_x

NvU16 _NV_HDR_CAPABILITIES_V3::cc_green_y

NvU16 _NV_HDR_CAPABILITIES_V3::cc_blue_x

NvU16 _NV_HDR_CAPABILITIES_V3::cc_blue_y

NvU16 _NV_HDR_CAPABILITIES_V3::cc_white_x

NvU16 _NV_HDR_CAPABILITIES_V3::cc_white_y

struct {

NvU32 _NV_HDR_CAPABILITIES_V3::VSVDB_version: 3

NvU32 _NV_HDR_CAPABILITIES_V3::dm_version: 8

NvU32 _NV_HDR_CAPABILITIES_V3::supports_2160p60hz: 1

NvU32 _NV_HDR_CAPABILITIES_V3::supports_YUV422_12bit: 1

NvU32 _NV_HDR_CAPABILITIES_V3::supports_global_dimming: 1

NvU32 _NV_HDR_CAPABILITIES_V3::colorimetry: 1

NvU32 _NV_HDR_CAPABILITIES_V3::supports_backlight_control: 2

NvU32 _NV_HDR_CAPABILITIES_V3::backlt_min_luma: 2

NvU32 _NV_HDR_CAPABILITIES_V3::interface_supported_by_sink: 2

NvU32 _NV_HDR_CAPABILITIES_V3::supports_10b_12b_444: 2

NvU32 _NV_HDR_CAPABILITIES_V3::parity: 1

NvU32 _NV_HDR_CAPABILITIES_V3::reserved: 8

NvU16 _NV_HDR_CAPABILITIES_V3::target_min_luminance

NvU16 _NV_HDR_CAPABILITIES_V3::target_max_luminance

NvU16 _NV_HDR_CAPABILITIES_V3::cc_red_x

NvU16 _NV_HDR_CAPABILITIES_V3::cc_red_y

NvU16 _NV_HDR_CAPABILITIES_V3::cc_green_x

NvU16 _NV_HDR_CAPABILITIES_V3::cc_green_y

NvU16 _NV_HDR_CAPABILITIES_V3::cc_blue_x

NvU16 _NV_HDR_CAPABILITIES_V3::cc_blue_y

NvU16 _NV_HDR_CAPABILITIES_V3::cc_white_x

NvU16 _NV_HDR_CAPABILITIES_V3::cc_white_y

}

_NV_HDR_CAPABILITIES_V3::dv_static_metadata

NvU16 _NV_HDR_CAPABILITIES_V3::application_version: 2

NvU16 _NV_HDR_CAPABILITIES_V3::full_frame_peak_luminance_index: 2

NvU16 _NV_HDR_CAPABILITIES_V3::peak_luminance_index: 4

NvU16 _NV_HDR_CAPABILITIES_V3::reserved: 8

struct {

NvU16 _NV_HDR_CAPABILITIES_V3::application_version: 2

NvU16 _NV_HDR_CAPABILITIES_V3::full_frame_peak_luminance_index: 2

NvU16 _NV_HDR_CAPABILITIES_V3::peak_luminance_index: 4

NvU16 _NV_HDR_CAPABILITIES_V3::reserved: 8

}

_NV_HDR_CAPABILITIES_V3::hdr10plus_vsvdb

NvU32

_NV_HDR_COLOR_DATA_V1::version

NV_HDR_CMD

_NV_HDR_COLOR_DATA_V1::cmd

NV_HDR_MODE

_NV_HDR_COLOR_DATA_V1::hdrMode

NV_STATIC_METADATA_DESCRIPTOR_ID

_NV_HDR_COLOR_DATA_V1::static_metadata_descriptor_id

NvU16 _NV_HDR_COLOR_DATA_V1::displayPrimary_x0

NvU16 _NV_HDR_COLOR_DATA_V1::displayPrimary_y0

NvU16 _NV_HDR_COLOR_DATA_V1::displayPrimary_x1

NvU16 _NV_HDR_COLOR_DATA_V1::displayPrimary_y1

NvU16 _NV_HDR_COLOR_DATA_V1::displayPrimary_x2

NvU16 _NV_HDR_COLOR_DATA_V1::displayPrimary_y2

NvU16 _NV_HDR_COLOR_DATA_V1::displayWhitePoint_x

NvU16 _NV_HDR_COLOR_DATA_V1::displayWhitePoint_y

NvU16 _NV_HDR_COLOR_DATA_V1::max_display_mastering_luminance

NvU16 _NV_HDR_COLOR_DATA_V1::min_display_mastering_luminance

NvU16 _NV_HDR_COLOR_DATA_V1::max_content_light_level

NvU16 _NV_HDR_COLOR_DATA_V1::max_frame_average_light_level

struct {

NvU16 _NV_HDR_COLOR_DATA_V1::displayPrimary_x0

NvU16 _NV_HDR_COLOR_DATA_V1::displayPrimary_y0

NvU16 _NV_HDR_COLOR_DATA_V1::displayPrimary_x1

NvU16 _NV_HDR_COLOR_DATA_V1::displayPrimary_y1

NvU16 _NV_HDR_COLOR_DATA_V1::displayPrimary_x2

NvU16 _NV_HDR_COLOR_DATA_V1::displayPrimary_y2

NvU16 _NV_HDR_COLOR_DATA_V1::displayWhitePoint_x

NvU16 _NV_HDR_COLOR_DATA_V1::displayWhitePoint_y

NvU16 _NV_HDR_COLOR_DATA_V1::max_display_mastering_luminance

NvU16 _NV_HDR_COLOR_DATA_V1::min_display_mastering_luminance

NvU16 _NV_HDR_COLOR_DATA_V1::max_content_light_level

NvU16 _NV_HDR_COLOR_DATA_V1::max_frame_average_light_level

}

_NV_HDR_COLOR_DATA_V1::mastering_display_data

NvU32

_NV_HDR_COLOR_DATA_V2::version

NV_HDR_CMD

_NV_HDR_COLOR_DATA_V2::cmd

NV_HDR_MODE

_NV_HDR_COLOR_DATA_V2::hdrMode

NV_STATIC_METADATA_DESCRIPTOR_ID

_NV_HDR_COLOR_DATA_V2::static_metadata_descriptor_id

NvU16 _NV_HDR_COLOR_DATA_V2::displayPrimary_x0

NvU16 _NV_HDR_COLOR_DATA_V2::displayPrimary_y0

NvU16 _NV_HDR_COLOR_DATA_V2::displayPrimary_x1

NvU16 _NV_HDR_COLOR_DATA_V2::displayPrimary_y1

NvU16 _NV_HDR_COLOR_DATA_V2::displayPrimary_x2

NvU16 _NV_HDR_COLOR_DATA_V2::displayPrimary_y2

NvU16 _NV_HDR_COLOR_DATA_V2::displayWhitePoint_x

NvU16 _NV_HDR_COLOR_DATA_V2::displayWhitePoint_y

NvU16 _NV_HDR_COLOR_DATA_V2::max_display_mastering_luminance

NvU16 _NV_HDR_COLOR_DATA_V2::min_display_mastering_luminance

NvU16 _NV_HDR_COLOR_DATA_V2::max_content_light_level

NvU16 _NV_HDR_COLOR_DATA_V2::max_frame_average_light_level

struct {

NvU16 _NV_HDR_COLOR_DATA_V2::displayPrimary_x0

NvU16 _NV_HDR_COLOR_DATA_V2::displayPrimary_y0

NvU16 _NV_HDR_COLOR_DATA_V2::displayPrimary_x1

NvU16 _NV_HDR_COLOR_DATA_V2::displayPrimary_y1

NvU16 _NV_HDR_COLOR_DATA_V2::displayPrimary_x2

NvU16 _NV_HDR_COLOR_DATA_V2::displayPrimary_y2

NvU16 _NV_HDR_COLOR_DATA_V2::displayWhitePoint_x

NvU16 _NV_HDR_COLOR_DATA_V2::displayWhitePoint_y

NvU16 _NV_HDR_COLOR_DATA_V2::max_display_mastering_luminance

NvU16 _NV_HDR_COLOR_DATA_V2::min_display_mastering_luminance

NvU16 _NV_HDR_COLOR_DATA_V2::max_content_light_level

NvU16 _NV_HDR_COLOR_DATA_V2::max_frame_average_light_level

}

_NV_HDR_COLOR_DATA_V2::mastering_display_data

NV_COLOR_FORMAT

_NV_HDR_COLOR_DATA_V2::hdrColorFormat

NV_DYNAMIC_RANGE

_NV_HDR_COLOR_DATA_V2::hdrDynamicRange

NV_BPC

_NV_HDR_COLOR_DATA_V2::hdrBpc

NvU32

_NV_HDR_METADATA_V1::version

NvU16

_NV_HDR_METADATA_V1::displayPrimary_x0

NvU16

_NV_HDR_METADATA_V1::displayPrimary_y0

NvU16

_NV_HDR_METADATA_V1::displayPrimary_x1

NvU16

_NV_HDR_METADATA_V1::displayPrimary_y1

NvU16

_NV_HDR_METADATA_V1::displayPrimary_x2

NvU16

_NV_HDR_METADATA_V1::displayPrimary_y2

NvU16

_NV_HDR_METADATA_V1::displayWhitePoint_x

NvU16

_NV_HDR_METADATA_V1::displayWhitePoint_y

NvU16

_NV_HDR_METADATA_V1::max_display_mastering_luminance

NvU16

_NV_HDR_METADATA_V1::min_display_mastering_luminance

NvU16

_NV_HDR_METADATA_V1::max_content_light_level

NvU16

_NV_HDR_METADATA_V1::max_frame_average_light_level

NvU32

NV_TIMING_FLAG::isInterlaced: 4

NvU32

NV_TIMING_FLAG::reserved0: 12

NvU32 NV_TIMING_FLAG::tvFormat: 8

NvU32 NV_TIMING_FLAG::ceaId: 8

NvU32 NV_TIMING_FLAG::nvPsfId: 8

union {

NvU32 NV_TIMING_FLAG::tvFormat: 8

NvU32 NV_TIMING_FLAG::ceaId: 8

NvU32 NV_TIMING_FLAG::nvPsfId: 8

};

NvU32

NV_TIMING_FLAG::scaling: 8

NvU32

_NV_TIMING_INPUT::version

NvU32

_NV_TIMING_INPUT::width

NvU32

_NV_TIMING_INPUT::height

float

_NV_TIMING_INPUT::rr

NV_TIMING_FLAG

_NV_TIMING_INPUT::flag

NV_TIMING_OVERRIDE

_NV_TIMING_INPUT::type

NvU8

_NV_MONITOR_CAPS_VCDB::quantizationRangeYcc: 1

NvU8

_NV_MONITOR_CAPS_VCDB::quantizationRangeRgb: 1

NvU8

_NV_MONITOR_CAPS_VCDB::scanInfoPreferredVideoFormat: 2

NvU8

_NV_MONITOR_CAPS_VCDB::scanInfoITVideoFormats: 2

NvU8

_NV_MONITOR_CAPS_VCDB::scanInfoCEVideoFormats: 2

NvU8

_NV_MONITOR_CAPS_VSDB::sourcePhysicalAddressB: 4

NvU8

_NV_MONITOR_CAPS_VSDB::sourcePhysicalAddressA: 4

NvU8

_NV_MONITOR_CAPS_VSDB::sourcePhysicalAddressD: 4

NvU8

_NV_MONITOR_CAPS_VSDB::sourcePhysicalAddressC: 4

NvU8

_NV_MONITOR_CAPS_VSDB::supportDualDviOperation: 1

NvU8

_NV_MONITOR_CAPS_VSDB::reserved6: 2

NvU8

_NV_MONITOR_CAPS_VSDB::supportDeepColorYCbCr444: 1

NvU8

_NV_MONITOR_CAPS_VSDB::supportDeepColor30bits: 1

NvU8

_NV_MONITOR_CAPS_VSDB::supportDeepColor36bits: 1

NvU8

_NV_MONITOR_CAPS_VSDB::supportDeepColor48bits: 1

NvU8

_NV_MONITOR_CAPS_VSDB::supportAI: 1

NvU8

_NV_MONITOR_CAPS_VSDB::maxTmdsClock

NvU8

_NV_MONITOR_CAPS_VSDB::cnc0SupportGraphicsTextContent: 1

NvU8

_NV_MONITOR_CAPS_VSDB::cnc1SupportPhotoContent: 1

NvU8

_NV_MONITOR_CAPS_VSDB::cnc2SupportCinemaContent: 1

NvU8

_NV_MONITOR_CAPS_VSDB::cnc3SupportGameContent: 1

NvU8

_NV_MONITOR_CAPS_VSDB::reserved8: 1

NvU8

_NV_MONITOR_CAPS_VSDB::hasVicEntries: 1

NvU8

_NV_MONITOR_CAPS_VSDB::hasInterlacedLatencyField: 1

NvU8

_NV_MONITOR_CAPS_VSDB::hasLatencyField: 1

NvU8

_NV_MONITOR_CAPS_VSDB::videoLatency

NvU8

_NV_MONITOR_CAPS_VSDB::audioLatency

NvU8

_NV_MONITOR_CAPS_VSDB::interlacedVideoLatency

NvU8

_NV_MONITOR_CAPS_VSDB::interlacedAudioLatency

NvU8

_NV_MONITOR_CAPS_VSDB::reserved13: 7

NvU8

_NV_MONITOR_CAPS_VSDB::has3dEntries: 1

NvU8

_NV_MONITOR_CAPS_VSDB::hdmi3dLength: 5

NvU8

_NV_MONITOR_CAPS_VSDB::hdmiVicLength: 3

NvU8

_NV_MONITOR_CAPS_VSDB::hdmi_vic [7]

NvU8

_NV_MONITOR_CAPS_VSDB::hdmi_3d [31]

NvU8

_NV_MONITOR_CAPS_GENERIC::supportVRR: 1

NvU8

_NV_MONITOR_CAPS_GENERIC::supportULMB: 1

NvU8

_NV_MONITOR_CAPS_GENERIC::isTrueGsync: 1

NvU8

_NV_MONITOR_CAPS_GENERIC::isRLACapable: 1

NvU8

_NV_MONITOR_CAPS_GENERIC::currentlyCapableOfVRR: 1

NvU8

_NV_MONITOR_CAPS_GENERIC::reserved: 3

NvU32

_NV_MONITOR_CAPABILITIES_V1::version

NvU16

_NV_MONITOR_CAPABILITIES_V1::size

NvU32

_NV_MONITOR_CAPABILITIES_V1::infoType

NvU32

_NV_MONITOR_CAPABILITIES_V1::connectorType

NvU8

_NV_MONITOR_CAPABILITIES_V1::bIsValidInfo: 1

NV_MONITOR_CAPS_VSDB _NV_MONITOR_CAPABILITIES_V1::vsdb

NV_MONITOR_CAPS_VCDB _NV_MONITOR_CAPABILITIES_V1::vcdb

NV_MONITOR_CAPS_GENERIC _NV_MONITOR_CAPABILITIES_V1::caps

union {

NV_MONITOR_CAPS_VSDB _NV_MONITOR_CAPABILITIES_V1::vsdb

NV_MONITOR_CAPS_VCDB _NV_MONITOR_CAPABILITIES_V1::vcdb

NV_MONITOR_CAPS_GENERIC _NV_MONITOR_CAPABILITIES_V1::caps

}

_NV_MONITOR_CAPABILITIES_V1::data

NvU32

_NV_MONITOR_COLOR_DATA::version

NV_DP_COLOR_FORMAT

_NV_MONITOR_COLOR_DATA::colorFormat

NV_DP_BPC

_NV_MONITOR_COLOR_DATA::backendBitDepths

NvU32

NV_CUSTOM_DISPLAY::version

NvU32

NV_CUSTOM_DISPLAY::width

NvU32

NV_CUSTOM_DISPLAY::height

NvU32

NV_CUSTOM_DISPLAY::depth

NV_FORMAT

NV_CUSTOM_DISPLAY::colorFormat

NV_VIEWPORTF

NV_CUSTOM_DISPLAY::srcPartition

float

NV_CUSTOM_DISPLAY::xRatio

float

NV_CUSTOM_DISPLAY::yRatio

NV_TIMING

NV_CUSTOM_DISPLAY::timing

NvU32

NV_CUSTOM_DISPLAY::hwModeSetOnly: 1

NvU32

_NV_EDID_DATA_V1::version

NvU8 *

_NV_EDID_DATA_V1::pEDID

NvU32

_NV_EDID_DATA_V1::sizeOfEDID

NvU32

_NV_EDID_DATA_V2::version

NvU8 *

_NV_EDID_DATA_V2::pEDID

NvU32

_NV_EDID_DATA_V2::sizeOfEDID

NvU32

_NV_EDID_DATA_V2::reserved [8]

NvU32

_NV_GET_ADAPTIVE_SYNC_DATA_V1::version

NvU32

_NV_GET_ADAPTIVE_SYNC_DATA_V1::maxFrameInterval

NvU32

_NV_GET_ADAPTIVE_SYNC_DATA_V1::bDisableAdaptiveSync: 1

NvU32

_NV_GET_ADAPTIVE_SYNC_DATA_V1::bDisableFrameSplitting: 1

NvU32

_NV_GET_ADAPTIVE_SYNC_DATA_V1::reserved: 30

NvU32

_NV_GET_ADAPTIVE_SYNC_DATA_V1::lastFlipRefreshCount

NvU64

_NV_GET_ADAPTIVE_SYNC_DATA_V1::lastFlipTimeStamp

NvU32

_NV_GET_ADAPTIVE_SYNC_DATA_V1::reservedEx [4]

NvU32

_NV_SET_ADAPTIVE_SYNC_DATA_V1::version

NvU32

_NV_SET_ADAPTIVE_SYNC_DATA_V1::maxFrameInterval

NvU32

_NV_SET_ADAPTIVE_SYNC_DATA_V1::bDisableAdaptiveSync: 1

NvU32

_NV_SET_ADAPTIVE_SYNC_DATA_V1::bDisableFrameSplitting: 1

NvU32

_NV_SET_ADAPTIVE_SYNC_DATA_V1::reserved: 30

NvU32

_NV_SET_ADAPTIVE_SYNC_DATA_V1::reservedEx [7]

NvU32

_NV_GET_VIRTUAL_REFRESH_RATE_DATA_V1::version

NvU32

_NV_GET_VIRTUAL_REFRESH_RATE_DATA_V1::frameIntervalUs

NvU32

_NV_GET_VIRTUAL_REFRESH_RATE_DATA_V1::reservedEx [8]

NvU32

_NV_SET_VIRTUAL_REFRESH_RATE_DATA_V1::version

NvU32

_NV_SET_VIRTUAL_REFRESH_RATE_DATA_V1::frameIntervalUs

NvU32

_NV_SET_VIRTUAL_REFRESH_RATE_DATA_V1::reservedEx [8]

NvU32

NV_SET_PREFERRED_STEREO_DISPLAY_V1::version

NvU32

NV_SET_PREFERRED_STEREO_DISPLAY_V1::displayId

NvU32

NV_SET_PREFERRED_STEREO_DISPLAY_V1::reserved

NvU32

NV_GET_PREFERRED_STEREO_DISPLAY_V1::version

NvU32

NV_GET_PREFERRED_STEREO_DISPLAY_V1::displayId

NvU32

NV_GET_PREFERRED_STEREO_DISPLAY_V1::reserved

NvU32

_NV_MANAGED_DEDICATED_DISPLAY_INFO::version

NvU32

_NV_MANAGED_DEDICATED_DISPLAY_INFO::displayId

NvU32

_NV_MANAGED_DEDICATED_DISPLAY_INFO::isAcquired: 1

NvU32

_NV_MANAGED_DEDICATED_DISPLAY_INFO::isMosaic: 1

NvU32

_NV_MANAGED_DEDICATED_DISPLAY_INFO::reserved: 30

NvU32

_NV_MANAGED_DEDICATED_DISPLAY_METADATA::version

NvU32

_NV_MANAGED_DEDICATED_DISPLAY_METADATA::displayId

NvU32

_NV_MANAGED_DEDICATED_DISPLAY_METADATA::bSetPosition: 1

NvU32

_NV_MANAGED_DEDICATED_DISPLAY_METADATA::bRemovePosition: 1

NvU32

_NV_MANAGED_DEDICATED_DISPLAY_METADATA::bPositionIsAvailable: 1

NvU32

_NV_MANAGED_DEDICATED_DISPLAY_METADATA::bSetName: 1

NvU32

_NV_MANAGED_DEDICATED_DISPLAY_METADATA::bRemoveName: 1

NvU32

_NV_MANAGED_DEDICATED_DISPLAY_METADATA::bNameIsAvailable: 1

NvU32

_NV_MANAGED_DEDICATED_DISPLAY_METADATA::reserved: 26

NvS32

_NV_MANAGED_DEDICATED_DISPLAY_METADATA::positionX

NvS32

_NV_MANAGED_DEDICATED_DISPLAY_METADATA::positionY

NvAPI_ShortString

_NV_MANAGED_DEDICATED_DISPLAY_METADATA::name

NvU32

_NV_GET_VRR_INFO_V1::version

NvU32

_NV_GET_VRR_INFO_V1::bIsVRREnabled: 1

NvU32

_NV_GET_VRR_INFO_V1::bIsVRRPossible: 1

NvU32

_NV_GET_VRR_INFO_V1::bIsVRRRequested: 1

NvU32

_NV_GET_VRR_INFO_V1::bIsVRRIndicatorEnabled: 1

NvU32

_NV_GET_VRR_INFO_V1::bIsDisplayInVRRMode: 1

NvU32

_NV_GET_VRR_INFO_V1::reserved: 27

NvU32

_NV_GET_VRR_INFO_V1::reservedEx [4]

NvU32

NV_MOSAIC_TOPO_DETAILS::version

NvLogicalGpuHandle

NV_MOSAIC_TOPO_DETAILS::hLogicalGPU

NvU32

NV_MOSAIC_TOPO_DETAILS::validityMask

NvU32

NV_MOSAIC_TOPO_DETAILS::rowCount

NvU32

NV_MOSAIC_TOPO_DETAILS::colCount

NvPhysicalGpuHandle NV_MOSAIC_TOPO_DETAILS::hPhysicalGPU

NvU32 NV_MOSAIC_TOPO_DETAILS::displayOutputId

NvS32 NV_MOSAIC_TOPO_DETAILS::overlapX

NvS32 NV_MOSAIC_TOPO_DETAILS::overlapY

struct {

NvPhysicalGpuHandle NV_MOSAIC_TOPO_DETAILS::hPhysicalGPU

NvU32 NV_MOSAIC_TOPO_DETAILS::displayOutputId

NvS32 NV_MOSAIC_TOPO_DETAILS::overlapX

NvS32 NV_MOSAIC_TOPO_DETAILS::overlapY

}

NV_MOSAIC_TOPO_DETAILS::gpuLayout [NVAPI_MAX_MOSAIC_DISPLAY_ROWS][NVAPI_MAX_MOSAIC_DISPLAY_COLUMNS]

NvU32

NV_MOSAIC_TOPO_BRIEF::version

NV_MOSAIC_TOPO

NV_MOSAIC_TOPO_BRIEF::topo

NvU32

NV_MOSAIC_TOPO_BRIEF::enabled

NvU32

NV_MOSAIC_TOPO_BRIEF::isPossible

NvU32

_NV_MOSAIC_DISPLAY_SETTING_V1::version

NvU32

_NV_MOSAIC_DISPLAY_SETTING_V1::width

NvU32

_NV_MOSAIC_DISPLAY_SETTING_V1::height

NvU32

_NV_MOSAIC_DISPLAY_SETTING_V1::bpp

NvU32

_NV_MOSAIC_DISPLAY_SETTING_V1::freq

NvU32

NV_MOSAIC_DISPLAY_SETTING_V2::version

NvU32

NV_MOSAIC_DISPLAY_SETTING_V2::width

NvU32

NV_MOSAIC_DISPLAY_SETTING_V2::height

NvU32

NV_MOSAIC_DISPLAY_SETTING_V2::bpp

NvU32

NV_MOSAIC_DISPLAY_SETTING_V2::freq

NvU32

NV_MOSAIC_DISPLAY_SETTING_V2::rrx1k

NvU32

_NV_MOSAIC_SUPPORTED_TOPO_INFO_V1::version

NvU32

_NV_MOSAIC_SUPPORTED_TOPO_INFO_V1::topoBriefsCount

NV_MOSAIC_TOPO_BRIEF

_NV_MOSAIC_SUPPORTED_TOPO_INFO_V1::topoBriefs [NV_MOSAIC_TOPO_MAX]

NvU32

_NV_MOSAIC_SUPPORTED_TOPO_INFO_V1::displaySettingsCount

NV_MOSAIC_DISPLAY_SETTING_V1

_NV_MOSAIC_SUPPORTED_TOPO_INFO_V1::displaySettings [NV_MOSAIC_DISPLAY_SETTINGS_MAX]

NvU32

_NV_MOSAIC_SUPPORTED_TOPO_INFO_V2::version

NvU32

_NV_MOSAIC_SUPPORTED_TOPO_INFO_V2::topoBriefsCount

NV_MOSAIC_TOPO_BRIEF

_NV_MOSAIC_SUPPORTED_TOPO_INFO_V2::topoBriefs [NV_MOSAIC_TOPO_MAX]

NvU32

_NV_MOSAIC_SUPPORTED_TOPO_INFO_V2::displaySettingsCount

NV_MOSAIC_DISPLAY_SETTING_V2

_NV_MOSAIC_SUPPORTED_TOPO_INFO_V2::displaySettings [NV_MOSAIC_DISPLAY_SETTINGS_MAX]

NvU32

NV_MOSAIC_TOPO_GROUP::version

NV_MOSAIC_TOPO_BRIEF

NV_MOSAIC_TOPO_GROUP::brief

NvU32

NV_MOSAIC_TOPO_GROUP::count

NV_MOSAIC_TOPO_DETAILS

NV_MOSAIC_TOPO_GROUP::topos [NV_MOSAIC_MAX_TOPO_PER_TOPO_GROUP]

NvU32

_NV_MOSAIC_GRID_TOPO_DISPLAY_V1::displayId

NvS32

_NV_MOSAIC_GRID_TOPO_DISPLAY_V1::overlapX

NvS32

_NV_MOSAIC_GRID_TOPO_DISPLAY_V1::overlapY

NV_ROTATE

_NV_MOSAIC_GRID_TOPO_DISPLAY_V1::rotation

NvU32

_NV_MOSAIC_GRID_TOPO_DISPLAY_V1::cloneGroup

NvU32

_NV_MOSAIC_GRID_TOPO_DISPLAY_V2::version

NvU32

_NV_MOSAIC_GRID_TOPO_DISPLAY_V2::displayId

NvS32

_NV_MOSAIC_GRID_TOPO_DISPLAY_V2::overlapX

NvS32

_NV_MOSAIC_GRID_TOPO_DISPLAY_V2::overlapY

NV_ROTATE

_NV_MOSAIC_GRID_TOPO_DISPLAY_V2::rotation

NvU32

_NV_MOSAIC_GRID_TOPO_DISPLAY_V2::cloneGroup

NV_PIXEL_SHIFT_TYPE

_NV_MOSAIC_GRID_TOPO_DISPLAY_V2::pixelShiftType

NvU32

_NV_MOSAIC_GRID_TOPO_V1::version

NvU32

_NV_MOSAIC_GRID_TOPO_V1::rows

NvU32

_NV_MOSAIC_GRID_TOPO_V1::columns

NvU32

_NV_MOSAIC_GRID_TOPO_V1::displayCount

NvU32

_NV_MOSAIC_GRID_TOPO_V1::applyWithBezelCorrect: 1

NvU32

_NV_MOSAIC_GRID_TOPO_V1::immersiveGaming: 1

NvU32

_NV_MOSAIC_GRID_TOPO_V1::baseMosaic: 1

NvU32

_NV_MOSAIC_GRID_TOPO_V1::driverReloadAllowed: 1

NvU32

_NV_MOSAIC_GRID_TOPO_V1::acceleratePrimaryDisplay: 1

NvU32

_NV_MOSAIC_GRID_TOPO_V1::reserved: 27

NV_MOSAIC_GRID_TOPO_DISPLAY_V1

_NV_MOSAIC_GRID_TOPO_V1::displays [NV_MOSAIC_MAX_DISPLAYS]

NV_MOSAIC_DISPLAY_SETTING_V1

_NV_MOSAIC_GRID_TOPO_V1::displaySettings

NvU32

_NV_MOSAIC_GRID_TOPO_V2::version

NvU32

_NV_MOSAIC_GRID_TOPO_V2::rows

NvU32

_NV_MOSAIC_GRID_TOPO_V2::columns

NvU32

_NV_MOSAIC_GRID_TOPO_V2::displayCount

NvU32

_NV_MOSAIC_GRID_TOPO_V2::applyWithBezelCorrect: 1

NvU32

_NV_MOSAIC_GRID_TOPO_V2::immersiveGaming: 1

NvU32

_NV_MOSAIC_GRID_TOPO_V2::baseMosaic: 1

NvU32

_NV_MOSAIC_GRID_TOPO_V2::driverReloadAllowed: 1

NvU32

_NV_MOSAIC_GRID_TOPO_V2::acceleratePrimaryDisplay: 1

NvU32

_NV_MOSAIC_GRID_TOPO_V2::pixelShift: 1

NvU32

_NV_MOSAIC_GRID_TOPO_V2::reserved: 26

NV_MOSAIC_GRID_TOPO_DISPLAY_V2

_NV_MOSAIC_GRID_TOPO_V2::displays [NV_MOSAIC_MAX_DISPLAYS]

NV_MOSAIC_DISPLAY_SETTING_V1

_NV_MOSAIC_GRID_TOPO_V2::displaySettings

NvU32

NV_MOSAIC_DISPLAY_TOPO_STATUS::version

NvU32

NV_MOSAIC_DISPLAY_TOPO_STATUS::errorFlags

NvU32

NV_MOSAIC_DISPLAY_TOPO_STATUS::warningFlags

NvU32

NV_MOSAIC_DISPLAY_TOPO_STATUS::displayCount

NvU32 NV_MOSAIC_DISPLAY_TOPO_STATUS::displayId

NvU32 NV_MOSAIC_DISPLAY_TOPO_STATUS::errorFlags

NvU32 NV_MOSAIC_DISPLAY_TOPO_STATUS::warningFlags

NvU32 NV_MOSAIC_DISPLAY_TOPO_STATUS::supportsRotation: 1

NvU32 NV_MOSAIC_DISPLAY_TOPO_STATUS::reserved: 31

struct {

NvU32 NV_MOSAIC_DISPLAY_TOPO_STATUS::displayId

NvU32 NV_MOSAIC_DISPLAY_TOPO_STATUS::errorFlags

NvU32 NV_MOSAIC_DISPLAY_TOPO_STATUS::warningFlags

NvU32 NV_MOSAIC_DISPLAY_TOPO_STATUS::supportsRotation: 1

NvU32 NV_MOSAIC_DISPLAY_TOPO_STATUS::reserved: 31

}

NV_MOSAIC_DISPLAY_TOPO_STATUS::displays [NVAPI_MAX_DISPLAYS]

NvU32

NV_MOSAIC_TOPOLOGY::version

NvU32

NV_MOSAIC_TOPOLOGY::rowCount

NvU32

NV_MOSAIC_TOPOLOGY::colCount

NvPhysicalGpuHandle NV_MOSAIC_TOPOLOGY::hPhysicalGPU

NvU32 NV_MOSAIC_TOPOLOGY::displayOutputId

NvS32 NV_MOSAIC_TOPOLOGY::overlapX

NvS32 NV_MOSAIC_TOPOLOGY::overlapY

struct {

NvPhysicalGpuHandle NV_MOSAIC_TOPOLOGY::hPhysicalGPU

NvU32 NV_MOSAIC_TOPOLOGY::displayOutputId

NvS32 NV_MOSAIC_TOPOLOGY::overlapX

NvS32 NV_MOSAIC_TOPOLOGY::overlapY

}

NV_MOSAIC_TOPOLOGY::gpuLayout [NVAPI_MAX_MOSAIC_DISPLAY_ROWS][NVAPI_MAX_MOSAIC_DISPLAY_COLUMNS]

NvU32

NV_MOSAIC_SUPPORTED_TOPOLOGIES::version

NvU32

NV_MOSAIC_SUPPORTED_TOPOLOGIES::totalCount

NV_MOSAIC_TOPOLOGY

NV_MOSAIC_SUPPORTED_TOPOLOGIES::topos [NVAPI_MAX_MOSAIC_TOPOS]

NvU32

_NV_GSYNC_CAPABILITIES_V1::version

NvU32

_NV_GSYNC_CAPABILITIES_V1::boardId

NvU32

_NV_GSYNC_CAPABILITIES_V1::revision

NvU32

_NV_GSYNC_CAPABILITIES_V1::capFlags

NvU32

_NV_GSYNC_CAPABILITIES_V2::version

NvU32

_NV_GSYNC_CAPABILITIES_V2::boardId

NvU32

_NV_GSYNC_CAPABILITIES_V2::revision

NvU32

_NV_GSYNC_CAPABILITIES_V2::capFlags

NvU32

_NV_GSYNC_CAPABILITIES_V2::extendedRevision

NvU32

_NV_GSYNC_CAPABILITIES_V3::version

NvU32

_NV_GSYNC_CAPABILITIES_V3::boardId

NvU32

_NV_GSYNC_CAPABILITIES_V3::revision

NvU32

_NV_GSYNC_CAPABILITIES_V3::capFlags

NvU32

_NV_GSYNC_CAPABILITIES_V3::extendedRevision

NvU32

_NV_GSYNC_CAPABILITIES_V3::bIsMulDivSupported: 1

NvU32

_NV_GSYNC_CAPABILITIES_V3::reserved: 31

NvU32

_NV_GSYNC_CAPABILITIES_V3::maxMulDivValue

NvU32

_NV_GSYNC_GPU::version

NvPhysicalGpuHandle

_NV_GSYNC_GPU::hPhysicalGpu

NVAPI_GSYNC_GPU_TOPOLOGY_CONNECTOR

_NV_GSYNC_GPU::connector

NvPhysicalGpuHandle

_NV_GSYNC_GPU::hProxyPhysicalGpu

NvU32

_NV_GSYNC_GPU::isSynced: 1

NvU32

_NV_GSYNC_GPU::reserved: 31

NvU32

_NV_GSYNC_DISPLAY::version

NvU32

_NV_GSYNC_DISPLAY::displayId

NvU32

_NV_GSYNC_DISPLAY::isMasterable: 1

NvU32

_NV_GSYNC_DISPLAY::reserved: 31

NVAPI_GSYNC_DISPLAY_SYNC_STATE

_NV_GSYNC_DISPLAY::syncState

NvU32

_NV_GSYNC_DELAY::version

NvU32

_NV_GSYNC_DELAY::numLines

NvU32

_NV_GSYNC_DELAY::numPixels

NvU32

_NV_GSYNC_DELAY::maxLines

NvU32

_NV_GSYNC_DELAY::minPixels

NvU32

_NV_GSYNC_CONTROL_PARAMS_V1::version

NVAPI_GSYNC_POLARITY

_NV_GSYNC_CONTROL_PARAMS_V1::polarity

NVAPI_GSYNC_VIDEO_MODE

_NV_GSYNC_CONTROL_PARAMS_V1::vmode

NvU32

_NV_GSYNC_CONTROL_PARAMS_V1::interval

NVAPI_GSYNC_SYNC_SOURCE

_NV_GSYNC_CONTROL_PARAMS_V1::source

NvU32

_NV_GSYNC_CONTROL_PARAMS_V1::interlaceMode:1

NvU32

_NV_GSYNC_CONTROL_PARAMS_V1::syncSourceIsOutput:1

NvU32

_NV_GSYNC_CONTROL_PARAMS_V1::reserved:30

NV_GSYNC_DELAY

_NV_GSYNC_CONTROL_PARAMS_V1::syncSkew

NV_GSYNC_DELAY

_NV_GSYNC_CONTROL_PARAMS_V1::startupDelay

NvU32

_NV_GSYNC_CONTROL_PARAMS_V2::version

NVAPI_GSYNC_POLARITY

_NV_GSYNC_CONTROL_PARAMS_V2::polarity

NVAPI_GSYNC_VIDEO_MODE

_NV_GSYNC_CONTROL_PARAMS_V2::vmode

NvU32

_NV_GSYNC_CONTROL_PARAMS_V2::interval

NVAPI_GSYNC_SYNC_SOURCE

_NV_GSYNC_CONTROL_PARAMS_V2::source

NvU32

_NV_GSYNC_CONTROL_PARAMS_V2::interlaceMode:1

NvU32

_NV_GSYNC_CONTROL_PARAMS_V2::syncSourceIsOutput:1

NvU32

_NV_GSYNC_CONTROL_PARAMS_V2::reserved:30

NV_GSYNC_DELAY

_NV_GSYNC_CONTROL_PARAMS_V2::syncSkew

NV_GSYNC_DELAY

_NV_GSYNC_CONTROL_PARAMS_V2::startupDelay

NVAPI_GSYNC_MULTIPLY_DIVIDE_MODE

_NV_GSYNC_CONTROL_PARAMS_V2::multiplyDivideMode

NvU8

_NV_GSYNC_CONTROL_PARAMS_V2::multiplyDivideValue

NvU32

_NV_GSYNC_STATUS::version

NvU32

_NV_GSYNC_STATUS::bIsSynced

NvU32

_NV_GSYNC_STATUS::bIsStereoSynced

NvU32

_NV_GSYNC_STATUS::bIsSyncSignalAvailable

NvU32

_NV_GSYNC_STATUS_PARAMS_V1::version

NvU32

_NV_GSYNC_STATUS_PARAMS_V1::refreshRate

NVAPI_GSYNC_RJ45_IO

_NV_GSYNC_STATUS_PARAMS_V1::RJ45_IO [NVAPI_MAX_RJ45_PER_GSYNC]

NvU32

_NV_GSYNC_STATUS_PARAMS_V1::RJ45_Ethernet [NVAPI_MAX_RJ45_PER_GSYNC]

NvU32

_NV_GSYNC_STATUS_PARAMS_V1::houseSyncIncoming

NvU32

_NV_GSYNC_STATUS_PARAMS_V1::bHouseSync

NvU32

_NV_GSYNC_STATUS_PARAMS_V2::version

NvU32

_NV_GSYNC_STATUS_PARAMS_V2::refreshRate

NVAPI_GSYNC_RJ45_IO

_NV_GSYNC_STATUS_PARAMS_V2::RJ45_IO [NVAPI_MAX_RJ45_PER_GSYNC]

NvU32

_NV_GSYNC_STATUS_PARAMS_V2::RJ45_Ethernet [NVAPI_MAX_RJ45_PER_GSYNC]

NvU32

_NV_GSYNC_STATUS_PARAMS_V2::houseSyncIncoming

NvU32

_NV_GSYNC_STATUS_PARAMS_V2::bHouseSync

NvU32

_NV_GSYNC_STATUS_PARAMS_V2::bInternalSlave: 1

NvU32

_NV_GSYNC_STATUS_PARAMS_V2::reserved: 31

NvU32

_NV_DX_VIDEO_STEREO_INFO::dwVersion

NVDX_ObjectHandle

_NV_DX_VIDEO_STEREO_INFO::hSurface

NVDX_ObjectHandle

_NV_DX_VIDEO_STEREO_INFO::hLinkedSurface

NV_STEREO_VIDEO_FORMAT

_NV_DX_VIDEO_STEREO_INFO::eFormat

NvS32

_NV_DX_VIDEO_STEREO_INFO::sViewOffset

BOOL

_NV_DX_VIDEO_STEREO_INFO::bStereoEnable

NvU32

_NV_JOIN_PRESENT_BARRIER_PARAMS::dwVersion

NvU32

_NV_PRESENT_BARRIER_FRAME_STATISTICS::dwVersion

NV_PRESENT_BARRIER_SYNC_MODE

_NV_PRESENT_BARRIER_FRAME_STATISTICS::SyncMode

NvU32

_NV_PRESENT_BARRIER_FRAME_STATISTICS::PresentCount

NvU32

_NV_PRESENT_BARRIER_FRAME_STATISTICS::PresentInSyncCount

NvU32

_NV_PRESENT_BARRIER_FRAME_STATISTICS::FlipInSyncCount

NvU32

_NV_PRESENT_BARRIER_FRAME_STATISTICS::RefreshCount

D3D11_FILL_MODE

NvAPI_D3D11_RASTERIZER_DESC_EX::FillMode

D3D11_CULL_MODE

NvAPI_D3D11_RASTERIZER_DESC_EX::CullMode

BOOL

NvAPI_D3D11_RASTERIZER_DESC_EX::FrontCounterClockwise

INT

NvAPI_D3D11_RASTERIZER_DESC_EX::DepthBias

FLOAT

NvAPI_D3D11_RASTERIZER_DESC_EX::DepthBiasClamp

FLOAT

NvAPI_D3D11_RASTERIZER_DESC_EX::SlopeScaledDepthBias

BOOL

NvAPI_D3D11_RASTERIZER_DESC_EX::DepthClipEnable

BOOL

NvAPI_D3D11_RASTERIZER_DESC_EX::ScissorEnable

BOOL

NvAPI_D3D11_RASTERIZER_DESC_EX::MultisampleEnable

BOOL

NvAPI_D3D11_RASTERIZER_DESC_EX::AntialiasedLineEnable

NvU32

NvAPI_D3D11_RASTERIZER_DESC_EX::ForcedSampleCount

bool

NvAPI_D3D11_RASTERIZER_DESC_EX::ProgrammableSamplePositionsEnable

bool

NvAPI_D3D11_RASTERIZER_DESC_EX::InterleavedSamplingEnable

NvU8

NvAPI_D3D11_RASTERIZER_DESC_EX::SampleCount

NvU8

NvAPI_D3D11_RASTERIZER_DESC_EX::SamplePositionsX [16]

NvU8

NvAPI_D3D11_RASTERIZER_DESC_EX::SamplePositionsY [16]

bool

NvAPI_D3D11_RASTERIZER_DESC_EX::ConservativeRasterEnable

NVAPI_QUAD_FILLMODE

NvAPI_D3D11_RASTERIZER_DESC_EX::QuadFillMode

bool

NvAPI_D3D11_RASTERIZER_DESC_EX::PostZCoverageEnable

bool

NvAPI_D3D11_RASTERIZER_DESC_EX::CoverageToColorEnable

NvU8

NvAPI_D3D11_RASTERIZER_DESC_EX::CoverageToColorRTIndex

bool

NvAPI_D3D11_RASTERIZER_DESC_EX::TargetIndepentRasterWithDepth

NvU8

NvAPI_D3D11_RASTERIZER_DESC_EX::reserved [63]

NVAPI_ANSEL_FEATURE

NVAPI_ANSEL_FEATURE_CONFIGURATION_STRUCT::featureId

NVAPI_ANSEL_FEATURE_STATE

NVAPI_ANSEL_FEATURE_CONFIGURATION_STRUCT::featureState

UINT

NVAPI_ANSEL_FEATURE_CONFIGURATION_STRUCT::hotkey

NvU32

NVAPI_ANSEL_CONFIGURATION_STRUCT_V1::version

NVAPI_ANSEL_HOTKEY_MODIFIER

NVAPI_ANSEL_CONFIGURATION_STRUCT_V1::hotkeyModifier

UINT

NVAPI_ANSEL_CONFIGURATION_STRUCT_V1::keyEnable

UINT

NVAPI_ANSEL_CONFIGURATION_STRUCT_V1::numAnselFeatures

NVAPI_ANSEL_FEATURE_CONFIGURATION_STRUCT *

NVAPI_ANSEL_CONFIGURATION_STRUCT_V1::pAnselFeatures

BOOL

_NV_D3D11_FEATURE_DATA_RASTERIZER_SUPPORT::TargetIndependentRasterWithDepth

BOOL

_NV_D3D11_FEATURE_DATA_RASTERIZER_SUPPORT::ProgrammableSamplePositions

BOOL

_NV_D3D11_FEATURE_DATA_RASTERIZER_SUPPORT::InterleavedSampling

BOOL

_NV_D3D11_FEATURE_DATA_RASTERIZER_SUPPORT::ConservativeRaster

BOOL

_NV_D3D11_FEATURE_DATA_RASTERIZER_SUPPORT::PostZCoverage

BOOL

_NV_D3D11_FEATURE_DATA_RASTERIZER_SUPPORT::CoverageToColor

UINT

_NV_CUSTOM_SEMANTIC::version

NV_CUSTOM_SEMANTIC_TYPE

_NV_CUSTOM_SEMANTIC::NVCustomSemanticType

NvAPI_LongString

_NV_CUSTOM_SEMANTIC::NVCustomSemanticNameString

BOOL

_NV_CUSTOM_SEMANTIC::RegisterSpecified

NvU32

_NV_CUSTOM_SEMANTIC::RegisterNum

NvU32

_NV_CUSTOM_SEMANTIC::RegisterMask

NvU32

_NV_CUSTOM_SEMANTIC::Reserved

UINT

NvAPI_D3D11_CREATE_GEOMETRY_SHADER_EX_V5::version

BOOL

NvAPI_D3D11_CREATE_GEOMETRY_SHADER_EX_V5::UseViewportMask

BOOL

NvAPI_D3D11_CREATE_GEOMETRY_SHADER_EX_V5::OffsetRtIndexByVpIndex

BOOL

NvAPI_D3D11_CREATE_GEOMETRY_SHADER_EX_V5::ForceFastGS

BOOL

NvAPI_D3D11_CREATE_GEOMETRY_SHADER_EX_V5::DontUseViewportOrder

BOOL

NvAPI_D3D11_CREATE_GEOMETRY_SHADER_EX_V5::UseAttributeSkipMask

BOOL

NvAPI_D3D11_CREATE_GEOMETRY_SHADER_EX_V5::UseCoordinateSwizzle

NvAPI_D3D11_SWIZZLE_MODE *

NvAPI_D3D11_CREATE_GEOMETRY_SHADER_EX_V5::pCoordinateSwizzling

NvU32

NvAPI_D3D11_CREATE_GEOMETRY_SHADER_EX_V5::NumCustomSemantics

NV_CUSTOM_SEMANTIC *

NvAPI_D3D11_CREATE_GEOMETRY_SHADER_EX_V5::pCustomSemantics

BOOL

NvAPI_D3D11_CREATE_GEOMETRY_SHADER_EX_V5::ConvertToFastGS

BOOL

NvAPI_D3D11_CREATE_GEOMETRY_SHADER_EX_V5::UseSpecificShaderExt

UINT

NvAPI_D3D11_CREATE_VERTEX_SHADER_EX_V1::version

NvU32

NvAPI_D3D11_CREATE_VERTEX_SHADER_EX_V1::NumCustomSemantics

NV_CUSTOM_SEMANTIC *

NvAPI_D3D11_CREATE_VERTEX_SHADER_EX_V1::pCustomSemantics

UINT

NvAPI_D3D11_CREATE_VERTEX_SHADER_EX_V2::version

NvU32

NvAPI_D3D11_CREATE_VERTEX_SHADER_EX_V2::NumCustomSemantics

NV_CUSTOM_SEMANTIC *

NvAPI_D3D11_CREATE_VERTEX_SHADER_EX_V2::pCustomSemantics

BOOL

NvAPI_D3D11_CREATE_VERTEX_SHADER_EX_V2::UseWithFastGS

UINT

NvAPI_D3D11_CREATE_VERTEX_SHADER_EX_V3::version

NvU32

NvAPI_D3D11_CREATE_VERTEX_SHADER_EX_V3::NumCustomSemantics

NV_CUSTOM_SEMANTIC *

NvAPI_D3D11_CREATE_VERTEX_SHADER_EX_V3::pCustomSemantics

BOOL

NvAPI_D3D11_CREATE_VERTEX_SHADER_EX_V3::UseWithFastGS

BOOL

NvAPI_D3D11_CREATE_VERTEX_SHADER_EX_V3::UseSpecificShaderExt

UINT

NvAPI_D3D11_CREATE_HULL_SHADER_EX_V1::version

NvU32

NvAPI_D3D11_CREATE_HULL_SHADER_EX_V1::NumCustomSemantics

NV_CUSTOM_SEMANTIC *

NvAPI_D3D11_CREATE_HULL_SHADER_EX_V1::pCustomSemantics

BOOL

NvAPI_D3D11_CREATE_HULL_SHADER_EX_V1::UseWithFastGS

UINT

NvAPI_D3D11_CREATE_HULL_SHADER_EX_V2::version

NvU32

NvAPI_D3D11_CREATE_HULL_SHADER_EX_V2::NumCustomSemantics

NV_CUSTOM_SEMANTIC *

NvAPI_D3D11_CREATE_HULL_SHADER_EX_V2::pCustomSemantics

BOOL

NvAPI_D3D11_CREATE_HULL_SHADER_EX_V2::UseWithFastGS

BOOL

NvAPI_D3D11_CREATE_HULL_SHADER_EX_V2::UseSpecificShaderExt

UINT

NvAPI_D3D11_CREATE_DOMAIN_SHADER_EX_V1::version

NvU32

NvAPI_D3D11_CREATE_DOMAIN_SHADER_EX_V1::NumCustomSemantics

NV_CUSTOM_SEMANTIC *

NvAPI_D3D11_CREATE_DOMAIN_SHADER_EX_V1::pCustomSemantics

UINT

NvAPI_D3D11_CREATE_DOMAIN_SHADER_EX_V2::version

NvU32

NvAPI_D3D11_CREATE_DOMAIN_SHADER_EX_V2::NumCustomSemantics

NV_CUSTOM_SEMANTIC *

NvAPI_D3D11_CREATE_DOMAIN_SHADER_EX_V2::pCustomSemantics

BOOL

NvAPI_D3D11_CREATE_DOMAIN_SHADER_EX_V2::UseWithFastGS

UINT

NvAPI_D3D11_CREATE_DOMAIN_SHADER_EX_V3::version

NvU32

NvAPI_D3D11_CREATE_DOMAIN_SHADER_EX_V3::NumCustomSemantics

NV_CUSTOM_SEMANTIC *

NvAPI_D3D11_CREATE_DOMAIN_SHADER_EX_V3::pCustomSemantics

BOOL

NvAPI_D3D11_CREATE_DOMAIN_SHADER_EX_V3::UseWithFastGS

BOOL

NvAPI_D3D11_CREATE_DOMAIN_SHADER_EX_V3::UseSpecificShaderExt

UINT

NvAPI_D3D11_CREATE_PIXEL_SHADER_EX_V1::version

NvU32

NvAPI_D3D11_CREATE_PIXEL_SHADER_EX_V1::NumCustomSemantics

NV_CUSTOM_SEMANTIC *

NvAPI_D3D11_CREATE_PIXEL_SHADER_EX_V1::pCustomSemantics

UINT

NvAPI_D3D11_CREATE_PIXEL_SHADER_EX_V2::version

NvU32

NvAPI_D3D11_CREATE_PIXEL_SHADER_EX_V2::NumCustomSemantics

NV_CUSTOM_SEMANTIC *

NvAPI_D3D11_CREATE_PIXEL_SHADER_EX_V2::pCustomSemantics

NvU32

NvAPI_D3D11_CREATE_PIXEL_SHADER_EX_V2::bEnableSuperSamplingPredicationForVRS: 1

NvU32

NvAPI_D3D11_CREATE_PIXEL_SHADER_EX_V2::bEnableSuperSamplingPredicationForVRSAllAttributes: 1

NvU32

NvAPI_D3D11_CREATE_PIXEL_SHADER_EX_V2::reserved: 30

NvU32

NvAPI_D3D11_CREATE_FASTGS_EXPLICIT_DESC_V1::version

NvU32

NvAPI_D3D11_CREATE_FASTGS_EXPLICIT_DESC_V1::flags

NvAPI_D3D11_SWIZZLE_MODE *

NvAPI_D3D11_CREATE_FASTGS_EXPLICIT_DESC_V1::pCoordinateSwizzling

NvU32

NVAPI_D3D12_PSO_EXTENSION_DESC_V1::baseVersion

NV_PSO_EXTENSION

NVAPI_D3D12_PSO_EXTENSION_DESC_V1::psoExtension

NvU32

NVAPI_D3D12_PSO_RASTERIZER_STATE_DESC_V1::version

bool

NVAPI_D3D12_PSO_RASTERIZER_STATE_DESC_V1::ProgrammableSamplePositionsEnable

bool

NVAPI_D3D12_PSO_RASTERIZER_STATE_DESC_V1::InterleavedSamplingEnable

NvU8

NVAPI_D3D12_PSO_RASTERIZER_STATE_DESC_V1::SampleCount

NvU8

NVAPI_D3D12_PSO_RASTERIZER_STATE_DESC_V1::SamplePositionsX [16]

NvU8

NVAPI_D3D12_PSO_RASTERIZER_STATE_DESC_V1::SamplePositionsY [16]

NVAPI_QUAD_FILLMODE

NVAPI_D3D12_PSO_RASTERIZER_STATE_DESC_V1::QuadFillMode

bool

NVAPI_D3D12_PSO_RASTERIZER_STATE_DESC_V1::PostZCoverageEnable

bool

NVAPI_D3D12_PSO_RASTERIZER_STATE_DESC_V1::CoverageToColorEnable

NvU8

NVAPI_D3D12_PSO_RASTERIZER_STATE_DESC_V1::CoverageToColorRTIndex

bool

NVAPI_D3D12_PSO_RASTERIZER_STATE_DESC_V1::TargetIndepentRasterWithDepth

NvU8

NVAPI_D3D12_PSO_RASTERIZER_STATE_DESC_V1::ForcedSampleCount

NvU8

NVAPI_D3D12_PSO_RASTERIZER_STATE_DESC_V1::reserved [62]

NvU32

NVAPI_D3D12_PSO_CREATE_FASTGS_EXPLICIT_DESC_V1::version

NvU32

NVAPI_D3D12_PSO_CREATE_FASTGS_EXPLICIT_DESC_V1::flags

NvAPI_D3D11_SWIZZLE_MODE *

NVAPI_D3D12_PSO_CREATE_FASTGS_EXPLICIT_DESC_V1::pCoordinateSwizzling

NvU32

NVAPI_D3D12_PSO_REQUEST_FAST_GEOMETRY_SHADER_DESC_V1::version

NvU32

NVAPI_D3D12_PSO_GEOMETRY_SHADER_DESC_V5::version

BOOL

NVAPI_D3D12_PSO_GEOMETRY_SHADER_DESC_V5::UseViewportMask

BOOL

NVAPI_D3D12_PSO_GEOMETRY_SHADER_DESC_V5::OffsetRtIndexByVpIndex

BOOL

NVAPI_D3D12_PSO_GEOMETRY_SHADER_DESC_V5::ForceFastGS

BOOL

NVAPI_D3D12_PSO_GEOMETRY_SHADER_DESC_V5::DontUseViewportOrder

BOOL

NVAPI_D3D12_PSO_GEOMETRY_SHADER_DESC_V5::UseAttributeSkipMask

BOOL

NVAPI_D3D12_PSO_GEOMETRY_SHADER_DESC_V5::UseCoordinateSwizzle

NvAPI_D3D11_SWIZZLE_MODE *

NVAPI_D3D12_PSO_GEOMETRY_SHADER_DESC_V5::pCoordinateSwizzling

NvU32

NVAPI_D3D12_PSO_GEOMETRY_SHADER_DESC_V5::NumCustomSemantics

NV_CUSTOM_SEMANTIC *

NVAPI_D3D12_PSO_GEOMETRY_SHADER_DESC_V5::pCustomSemantics

BOOL

NVAPI_D3D12_PSO_GEOMETRY_SHADER_DESC_V5::ConvertToFastGS

BOOL

NVAPI_D3D12_PSO_GEOMETRY_SHADER_DESC_V5::UseSpecificShaderExt

NvU32

NVAPI_D3D12_PSO_VERTEX_SHADER_DESC_V1::version

NvU32

NVAPI_D3D12_PSO_VERTEX_SHADER_DESC_V1::NumCustomSemantics

NV_CUSTOM_SEMANTIC *

NVAPI_D3D12_PSO_VERTEX_SHADER_DESC_V1::pCustomSemantics

BOOL

NVAPI_D3D12_PSO_VERTEX_SHADER_DESC_V2::UseWithFastGS

BOOL

NVAPI_D3D12_PSO_VERTEX_SHADER_DESC_V3::UseSpecificShaderExt

NvU32

NVAPI_D3D12_PSO_HULL_SHADER_DESC_V1::version

NvU32

NVAPI_D3D12_PSO_HULL_SHADER_DESC_V1::NumCustomSemantics

NV_CUSTOM_SEMANTIC *

NVAPI_D3D12_PSO_HULL_SHADER_DESC_V1::pCustomSemantics

BOOL

NVAPI_D3D12_PSO_HULL_SHADER_DESC_V1::UseWithFastGS

BOOL

NVAPI_D3D12_PSO_HULL_SHADER_DESC_V2::UseSpecificShaderExt

NvU32

NVAPI_D3D12_PSO_DOMAIN_SHADER_DESC_V1::version

NvU32

NVAPI_D3D12_PSO_DOMAIN_SHADER_DESC_V1::NumCustomSemantics

NV_CUSTOM_SEMANTIC *

NVAPI_D3D12_PSO_DOMAIN_SHADER_DESC_V1::pCustomSemantics

BOOL

NVAPI_D3D12_PSO_DOMAIN_SHADER_DESC_V2::UseWithFastGS

BOOL

NVAPI_D3D12_PSO_DOMAIN_SHADER_DESC_V3::UseSpecificShaderExt

NvU32

NVAPI_D3D12_PSO_ENABLE_DEPTH_BOUND_TEST_DESC_V1::version

bool

NVAPI_D3D12_PSO_ENABLE_DEPTH_BOUND_TEST_DESC_V1::EnableDBT

NvU32

NVAPI_D3D12_PSO_SET_SHADER_EXTENSION_SLOT_DESC_V1::version

NvU32

NVAPI_D3D12_PSO_SET_SHADER_EXTENSION_SLOT_DESC_V1::uavSlot

NvU32

NVAPI_D3D12_PSO_SET_SHADER_EXTENSION_SLOT_DESC_V1::registerSpace

NvU32

_NV_HEAP_PARAMS_V1::version

NV_D3D12_HEAP_FLAGS

_NV_HEAP_PARAMS_V1::NVHeapFlags

NvU32

NVAPI_UAV_INFO_V1::version

NvU32

NVAPI_UAV_INFO_V1::surfaceHandle

NvU64

NVAPI_UAV_INFO_V1::gpuVAStart

NvU64

NVAPI_UAV_INFO_V1::gpuVASize

NvU32

NVAPI_UAV_INFO_V2::version

NvU32

NVAPI_UAV_INFO_V2::surfaceHandle

NvU64

NVAPI_UAV_INFO_V2::gpuVAStart

NvU64

NVAPI_UAV_INFO_V2::gpuVASize

NvU64

NVAPI_UAV_INFO_V2::outFlags

NvU32

NV_GET_GPU_VIRTUAL_ADDRESS_V1::version

NVDX_ObjectHandle

NV_GET_GPU_VIRTUAL_ADDRESS_V1::hResource

NvU64

NV_GET_GPU_VIRTUAL_ADDRESS_V1::gpuVAStart

NvU64

NV_GET_GPU_VIRTUAL_ADDRESS_V1::gpuVASize

GUID

NVAPI_META_COMMAND_DESC::Id

LPCWSTR

NVAPI_META_COMMAND_DESC::Name

NV_D3D_GRAPHICS_STATES

NVAPI_META_COMMAND_DESC::InitializationDirtyState

NV_D3D_GRAPHICS_STATES

NVAPI_META_COMMAND_DESC::ExecutionDirtyState

NvU64

NV_META_COMMAND_TENSOR_DESC::DataType

NvU64

NV_META_COMMAND_TENSOR_DESC::Layout

NvU64

NV_META_COMMAND_TENSOR_DESC::Flags

NvU64

NV_META_COMMAND_TENSOR_DESC::DimensionCount

NvU64

NV_META_COMMAND_TENSOR_DESC::Size [NV_META_COMMAND_MAX_TENSOR_DIM]

NvU64

NV_META_COMMAND_TENSOR_DESC::Stride [NV_META_COMMAND_MAX_TENSOR_DIM]

NvU64

NV_META_COMMAND_ACTIVATION_DESC::Function

float

NV_META_COMMAND_ACTIVATION_DESC::Params [NV_META_COMMAND_ACTIVATION_MAX_PARAMS]

NV_META_COMMAND_BOOL

NV_META_COMMAND_OPTIONAL_TENSOR_DESC::IsNull

NV_META_COMMAND_BOOL

NV_META_COMMAND_OPTIONAL_ACTIVATION_DESC::IsNull

NV_META_COMMAND_PADDING_MODE

NV_META_COMMAND_PADDING_DESC::Mode

float

NV_META_COMMAND_PADDING_DESC::ConstantPadVal

NV_META_COMMAND_TENSOR_DESC

NV_META_COMMAND_CREATE_CONVOLUTION_EX_DESC::DescIn

NV_META_COMMAND_TENSOR_DESC

NV_META_COMMAND_CREATE_CONVOLUTION_EX_DESC::DescFilter

NV_META_COMMAND_OPTIONAL_TENSOR_DESC

NV_META_COMMAND_CREATE_CONVOLUTION_EX_DESC::DescBias

NV_META_COMMAND_TENSOR_DESC

NV_META_COMMAND_CREATE_CONVOLUTION_EX_DESC::DescOut

NvU64

NV_META_COMMAND_CREATE_CONVOLUTION_EX_DESC::Mode

NvU64

NV_META_COMMAND_CREATE_CONVOLUTION_EX_DESC::Direction

NvU64

NV_META_COMMAND_CREATE_CONVOLUTION_EX_DESC::Precision

NV_META_COMMAND_OPTIONAL_ACTIVATION_DESC

NV_META_COMMAND_CREATE_CONVOLUTION_EX_DESC::Activation

NV_META_COMMAND_PADDING_DESC

NV_META_COMMAND_CREATE_CONVOLUTION_EX_DESC::Padding

NV_META_COMMAND_BOOL

NV_META_COMMAND_CREATE_CONVOLUTION_EX_DESC::PerChannelScaling

float

NV_META_COMMAND_CREATE_CONVOLUTION_EX_DESC::Alpha1

float

NV_META_COMMAND_CREATE_CONVOLUTION_EX_DESC::Alpha2

NvU64

NV_META_COMMAND_CREATE_CONVOLUTION_EX_DESC::Stride [NV_META_COMMAND_NUM_SPATIAL_DIM]

NvU64

NV_META_COMMAND_CREATE_CONVOLUTION_EX_DESC::Dilation [NV_META_COMMAND_NUM_SPATIAL_DIM]

NvU64

NV_META_COMMAND_CREATE_CONVOLUTION_EX_DESC::StartPadding [NV_META_COMMAND_NUM_SPATIAL_DIM]

NvU64

NV_META_COMMAND_CREATE_CONVOLUTION_EX_DESC::EndPadding [NV_META_COMMAND_NUM_SPATIAL_DIM]

NvU64

NV_META_COMMAND_CREATE_CONVOLUTION_EX_DESC::DimensionCount

NvU64

NV_META_COMMAND_CREATE_CONVOLUTION_EX_DESC::GroupCount

NV_META_COMMAND_CONVOLUTION_POOL_MODE

NV_META_COMMAND_CONVOLUTION_FUSE_DESC::PoolMode

NV_META_COMMAND_CONVOLUTION_UPSAMPLE_MODE

NV_META_COMMAND_CONVOLUTION_FUSE_DESC::UpsampleMode

NV_META_COMMAND_CONVOLUTION_SKIP_MODE

NV_META_COMMAND_CONVOLUTION_FUSE_DESC::SkipMode

NV_META_COMMAND_BOOL

NV_META_COMMAND_CONVOLUTION_FUSE_DESC::OutputPrepool

NV_META_COMMAND_CONVOLUTION_FUSE_DESC

NV_META_COMMAND_CREATE_CONVOLUTION_EX_FUSED_DESC::FuseDesc

NV_META_COMMAND_TENSOR_DESC

NV_META_COMMAND_CREATE_GEMM_DESC::DescA

NV_META_COMMAND_TENSOR_DESC

NV_META_COMMAND_CREATE_GEMM_DESC::DescB

NV_META_COMMAND_OPTIONAL_TENSOR_DESC

NV_META_COMMAND_CREATE_GEMM_DESC::DescC

NV_META_COMMAND_TENSOR_DESC

NV_META_COMMAND_CREATE_GEMM_DESC::DescOut

NvU64

NV_META_COMMAND_CREATE_GEMM_DESC::Precision

NvU64

NV_META_COMMAND_CREATE_GEMM_DESC::TransA

NvU64

NV_META_COMMAND_CREATE_GEMM_DESC::TransB

float

NV_META_COMMAND_CREATE_GEMM_DESC::Alpha

float

NV_META_COMMAND_CREATE_GEMM_DESC::Beta

NV_META_COMMAND_OPTIONAL_ACTIVATION_DESC

NV_META_COMMAND_CREATE_GEMM_DESC::Activation

NVDX_ObjectHandle NV_D3D11_META_COMMAND_RESOURCE::ResourceHandle

NvU64 NV_D3D11_META_COMMAND_RESOURCE::unused

union {

NVDX_ObjectHandle NV_D3D11_META_COMMAND_RESOURCE::ResourceHandle

NvU64 NV_D3D11_META_COMMAND_RESOURCE::unused

};

NvU64

NV_D3D11_META_COMMAND_RESOURCE::Offset

NV_D3D11_META_COMMAND_RESOURCE

NV_D3D11_META_COMMAND_INITIALIZE_CONVOLUTION_EX_DESC::PersistentResource

NV_D3D11_META_COMMAND_RESOURCE

NV_D3D11_META_COMMAND_EXECUTE_CONVOLUTION_EX_DESC::InputResource

NV_D3D11_META_COMMAND_RESOURCE

NV_D3D11_META_COMMAND_EXECUTE_CONVOLUTION_EX_DESC::FilterResource

NV_D3D11_META_COMMAND_RESOURCE

NV_D3D11_META_COMMAND_EXECUTE_CONVOLUTION_EX_DESC::BiasResource

NV_D3D11_META_COMMAND_RESOURCE

NV_D3D11_META_COMMAND_EXECUTE_CONVOLUTION_EX_DESC::OutputResource

NV_D3D11_META_COMMAND_RESOURCE

NV_D3D11_META_COMMAND_EXECUTE_CONVOLUTION_EX_DESC::Alpha1Resource

NV_D3D11_META_COMMAND_RESOURCE

NV_D3D11_META_COMMAND_EXECUTE_CONVOLUTION_EX_DESC::Alpha2Resource

NV_D3D11_META_COMMAND_RESOURCE

NV_D3D11_META_COMMAND_EXECUTE_CONVOLUTION_EX_DESC::SkipConnectionResource

NV_D3D11_META_COMMAND_RESOURCE

NV_D3D11_META_COMMAND_EXECUTE_CONVOLUTION_EX_DESC::PersistentResource

NV_D3D11_META_COMMAND_RESOURCE

NV_D3D11_META_COMMAND_EXECUTE_CONVOLUTION_EX_DESC::TemporaryResource

NV_D3D11_META_COMMAND_RESOURCE

NV_D3D11_META_COMMAND_INITIALIZE_GEMM_DESC::PersistentResource

NV_D3D11_META_COMMAND_RESOURCE

NV_D3D11_META_COMMAND_EXECUTE_GEMM_DESC::AResource

NV_D3D11_META_COMMAND_RESOURCE

NV_D3D11_META_COMMAND_EXECUTE_GEMM_DESC::BResource

NV_D3D11_META_COMMAND_RESOURCE

NV_D3D11_META_COMMAND_EXECUTE_GEMM_DESC::CResource

NV_D3D11_META_COMMAND_RESOURCE

NV_D3D11_META_COMMAND_EXECUTE_GEMM_DESC::OutputResource

NV_D3D11_META_COMMAND_RESOURCE

NV_D3D11_META_COMMAND_EXECUTE_GEMM_DESC::PersistentResource

NV_D3D11_META_COMMAND_RESOURCE

NV_D3D11_META_COMMAND_EXECUTE_GEMM_DESC::TemporaryResource

D3D12_GPU_VIRTUAL_ADDRESS

NV_D3D12_META_COMMAND_INITIALIZE_CONVOLUTION_EX_DESC::PersistentResource

D3D12_GPU_VIRTUAL_ADDRESS

NV_D3D12_META_COMMAND_EXECUTE_CONVOLUTION_EX_DESC::InputResource

D3D12_GPU_VIRTUAL_ADDRESS

NV_D3D12_META_COMMAND_EXECUTE_CONVOLUTION_EX_DESC::FilterResource

D3D12_GPU_VIRTUAL_ADDRESS

NV_D3D12_META_COMMAND_EXECUTE_CONVOLUTION_EX_DESC::BiasResource

D3D12_GPU_VIRTUAL_ADDRESS

NV_D3D12_META_COMMAND_EXECUTE_CONVOLUTION_EX_DESC::OutputResource

D3D12_GPU_VIRTUAL_ADDRESS

NV_D3D12_META_COMMAND_EXECUTE_CONVOLUTION_EX_DESC::Alpha1Resource

D3D12_GPU_VIRTUAL_ADDRESS

NV_D3D12_META_COMMAND_EXECUTE_CONVOLUTION_EX_DESC::Alpha2Resource

D3D12_GPU_VIRTUAL_ADDRESS

NV_D3D12_META_COMMAND_EXECUTE_CONVOLUTION_EX_DESC::SkipConnectionResource

D3D12_GPU_VIRTUAL_ADDRESS

NV_D3D12_META_COMMAND_EXECUTE_CONVOLUTION_EX_DESC::PersistentResource

D3D12_GPU_VIRTUAL_ADDRESS

NV_D3D12_META_COMMAND_EXECUTE_CONVOLUTION_EX_DESC::TemporaryResource

NvU64

NV_D3D12_META_COMMAND_INITIALIZE_GEMM_DESC::PersistentResource

NvU64

NV_D3D12_META_COMMAND_EXECUTE_GEMM_DESC::AResource

NvU64

NV_D3D12_META_COMMAND_EXECUTE_GEMM_DESC::BResource

NvU64

NV_D3D12_META_COMMAND_EXECUTE_GEMM_DESC::CResource

NvU64

NV_D3D12_META_COMMAND_EXECUTE_GEMM_DESC::OutputResource

NvU64

NV_D3D12_META_COMMAND_EXECUTE_GEMM_DESC::PersistentResource

NvU64

NV_D3D12_META_COMMAND_EXECUTE_GEMM_DESC::TemporaryResource

NvU32

_NV_RESOURCE_PARAMS_V1::version

NV_D3D12_RESOURCE_FLAGS

_NV_RESOURCE_PARAMS_V1::NVResourceFlags

NvU32

_NV_MULTIGPU_CAPS_V1::multiGPUVersion

NvU32

_NV_MULTIGPU_CAPS_V1::reserved

NvU32

_NV_MULTIGPU_CAPS_V1::nTotalGPUs

NvU32

_NV_MULTIGPU_CAPS_V1::nSLIGPUs

NvU32

_NV_MULTIGPU_CAPS_V1::videoBridgePresent

NvU32

_NV_MULTIGPU_CAPS_V2::multiGPUVersion

NvU32 _NV_MULTIGPU_CAPS_V2::reserved

NvU32 _NV_MULTIGPU_CAPS_V2::version

union {

NvU32 _NV_MULTIGPU_CAPS_V2::reserved

NvU32 _NV_MULTIGPU_CAPS_V2::version

};

NvU32

_NV_MULTIGPU_CAPS_V2::nTotalGPUs

NvU32

_NV_MULTIGPU_CAPS_V2::nSLIGPUs

NvU32

_NV_MULTIGPU_CAPS_V2::videoBridgePresent

NvU32

_NV_MULTIGPU_CAPS_V2::NvLinkPresent

NvU32

_NV_MULTIGPU_CAPS_V2::fastNvLinkReads

NvU32

_NV_QUERY_SINGLE_PASS_STEREO_SUPPORT_PARAMS_V1::version

NvU32

_NV_QUERY_SINGLE_PASS_STEREO_SUPPORT_PARAMS_V1::bSinglePassStereoSupported

NvU32

_NV_QUERY_SINGLE_PASS_STEREO_SUPPORT_PARAMS_V2::version

NvU32

_NV_QUERY_SINGLE_PASS_STEREO_SUPPORT_PARAMS_V2::bSinglePassStereoSupported: 1

NvU32

_NV_QUERY_SINGLE_PASS_STEREO_SUPPORT_PARAMS_V2::bSinglePassStereoXYZWSupported: 1

NvU32

_NV_QUERY_SINGLE_PASS_STEREO_SUPPORT_PARAMS_V2::reserved: 30

NvU32

_NV_QUERY_MULTIVIEW_SUPPORT_PARAMS_V1::version

NvU32

_NV_QUERY_MULTIVIEW_SUPPORT_PARAMS_V1::bMultiViewSupported: 1

NvU32

_NV_QUERY_MULTIVIEW_SUPPORT_PARAMS_V1::bSinglePassStereoSupported: 1

NvU32

_NV_QUERY_MULTIVIEW_SUPPORT_PARAMS_V1::bSinglePassStereoXYZWSupported: 1

NvU32

_NV_QUERY_MULTIVIEW_SUPPORT_PARAMS_V1::reserved: 29

NvU32

_NV_MULTIVIEW_PARAMS_V1::version

NvU32

_NV_MULTIVIEW_PARAMS_V1::numViews

NvU32

_NV_MULTIVIEW_PARAMS_V1::renderTargetIndexOffset [NV_MULTIVIEW_MAX_SUPPORTED_VIEWS]

NvU8

_NV_MULTIVIEW_PARAMS_V1::independentViewportMaskEnable

NvU32

_NV_QUERY_MODIFIED_W_SUPPORT_PARAMS::version

NvU32

_NV_QUERY_MODIFIED_W_SUPPORT_PARAMS::bModifiedWSupported

float

_NV_MODIFIED_W_COEFFICIENTS::fA

float

_NV_MODIFIED_W_COEFFICIENTS::fB

float

_NV_MODIFIED_W_COEFFICIENTS::fAReserved

float

_NV_MODIFIED_W_COEFFICIENTS::fBReserved

float

_NV_MODIFIED_W_COEFFICIENTS::fReserved [2]

NvU32

_NV_MODIFIED_W_PARAMS::version

NvU32

_NV_MODIFIED_W_PARAMS::numEntries

NV_MODIFIED_W_COEFFICIENTS

_NV_MODIFIED_W_PARAMS::modifiedWCoefficients [NV_MODIFIED_W_MAX_VIEWPORTS]

NvU32

_NV_MODIFIED_W_PARAMS::id

NvU32

_NV_MODIFIED_W_PARAMS::reserved [NV_MODIFIED_W_MAX_VIEWPORTS]

NvU32

_NV_D3D_LATELATCH_OBJECT_DESC_V1::version

NvU32

_NV_D3D_LATELATCH_OBJECT_DESC_V1::numBuffers

D3D11_BUFFER_DESC **

_NV_D3D_LATELATCH_OBJECT_DESC_V1::ppBufferDesc

ID3DLateLatchObject **

_NV_D3D_LATELATCH_OBJECT_DESC_V1::ppD3DLateLatchObject

NvU32

_NV_QUERY_LATELATCH_SUPPORT_PARAMS::version

NvU32

_NV_QUERY_LATELATCH_SUPPORT_PARAMS::bLateLatchSupported

__in NvU32

_NV_D3D12_MOSAIC_GETCOMPANIONALLOCATIONS::version

__in ID3D12Device *

_NV_D3D12_MOSAIC_GETCOMPANIONALLOCATIONS::pDevice

__in ID3D12Resource *

_NV_D3D12_MOSAIC_GETCOMPANIONALLOCATIONS::pSwapChainBuffer

__in NvU32

_NV_D3D12_MOSAIC_GETCOMPANIONALLOCATIONS::companionBufferCount

__inout ID3D12Resource **

_NV_D3D12_MOSAIC_GETCOMPANIONALLOCATIONS::ppCompanionResources

__in NvU32

_NV_D3D12_MOSAIC_GETVIEWPORTANDGPUPARTITIONS::version

__in ID3D12Device *

_NV_D3D12_MOSAIC_GETVIEWPORTANDGPUPARTITIONS::pDevice

__in ID3D12Resource *

_NV_D3D12_MOSAIC_GETVIEWPORTANDGPUPARTITIONS::pSwapChainBuffer

__inout NvU32 *

_NV_D3D12_MOSAIC_GETVIEWPORTANDGPUPARTITIONS::pPartitionCount

__inout RECT *

_NV_D3D12_MOSAIC_GETVIEWPORTANDGPUPARTITIONS::pViewport

__inout NvU32 *

_NV_D3D12_MOSAIC_GETVIEWPORTANDGPUPARTITIONS::pNodeMask

NvU32

_NV_D3D1x_GRAPHICS_CAPS_V1::bExclusiveScissorRectsSupported: 1

NvU32

_NV_D3D1x_GRAPHICS_CAPS_V1::bVariablePixelRateShadingSupported: 1

NvU32

_NV_D3D1x_GRAPHICS_CAPS_V1::reservedBits: 30

NvU32

_NV_D3D1x_GRAPHICS_CAPS_V1::reserved [7]

NvU32

_NV_D3D1x_GRAPHICS_CAPS_V2::bExclusiveScissorRectsSupported: 1

NvU32

_NV_D3D1x_GRAPHICS_CAPS_V2::bVariablePixelRateShadingSupported: 1

NvU32

_NV_D3D1x_GRAPHICS_CAPS_V2::bFastUAVClearSupported: 1

NvU32

_NV_D3D1x_GRAPHICS_CAPS_V2::reservedBits: 29

NvU16

_NV_D3D1x_GRAPHICS_CAPS_V2::majorSMVersion

NvU16

_NV_D3D1x_GRAPHICS_CAPS_V2::minorSMVersion

NvU32

_NV_D3D1x_GRAPHICS_CAPS_V2::reserved [14]

NvU32

_NV_D3D12_GRAPHICS_CAPS_V1::bExclusiveScissorRectsSupported: 1

NvU32

_NV_D3D12_GRAPHICS_CAPS_V1::bVariablePixelRateShadingSupported: 1

NvU32

_NV_D3D12_GRAPHICS_CAPS_V1::bFastUAVClearSupported: 1

NvU32

_NV_D3D12_GRAPHICS_CAPS_V1::reservedBits: 29

NvU16

_NV_D3D12_GRAPHICS_CAPS_V1::majorSMVersion

NvU16

_NV_D3D12_GRAPHICS_CAPS_V1::minorSMVersion

NvU32

_NV_D3D12_GRAPHICS_CAPS_V1::reserved [6]

bool

_NV_D3D11_EXCLUSIVE_SCISSOR_RECT_DESC_V1::enableExclusiveScissorRect

D3D11_RECT

_NV_D3D11_EXCLUSIVE_SCISSOR_RECT_DESC_V1::scissorRect

NvU32

_NV_D3D11_EXCLUSIVE_SCISSOR_RECTS_DESC_V1::version

NvU32

_NV_D3D11_EXCLUSIVE_SCISSOR_RECTS_DESC_V1::numRects

NV_D3D11_EXCLUSIVE_SCISSOR_RECT_DESC_V1 *

_NV_D3D11_EXCLUSIVE_SCISSOR_RECTS_DESC_V1::pRects

bool

_NV_D3D11_VIEWPORT_SHADING_RATE_DESC_V1::enableVariablePixelShadingRate

NV_PIXEL_SHADING_RATE

_NV_D3D11_VIEWPORT_SHADING_RATE_DESC_V1::shadingRateTable [NV_MAX_PIXEL_SHADING_RATES]

NvU32

_NV_D3D11_VIEWPORTS_SHADING_RATE_DESC_V1::version

NvU32

_NV_D3D11_VIEWPORTS_SHADING_RATE_DESC_V1::numViewports

NV_D3D11_VIEWPORT_SHADING_RATE_DESC_V1 *

_NV_D3D11_VIEWPORTS_SHADING_RATE_DESC_V1::pViewports

UINT

_NV_TEX2D_SRRV::MipSlice

UINT

_NV_TEX2D_ARRAY_SRRV::MipSlice

UINT

_NV_TEX2D_ARRAY_SRRV::FirstArraySlice

UINT

_NV_TEX2D_ARRAY_SRRV::ArraySize

NvU32

_NV_D3D11_SHADING_RATE_RESOURCE_VIEW_DESC_V1::version

DXGI_FORMAT

_NV_D3D11_SHADING_RATE_RESOURCE_VIEW_DESC_V1::Format

NV_SRRV_DIMENSION

_NV_D3D11_SHADING_RATE_RESOURCE_VIEW_DESC_V1::ViewDimension

NV_TEX2D_SRRV _NV_D3D11_SHADING_RATE_RESOURCE_VIEW_DESC_V1::Texture2D

NV_TEX2D_ARRAY_SRRV _NV_D3D11_SHADING_RATE_RESOURCE_VIEW_DESC_V1::Texture2DArray

union {

NV_TEX2D_SRRV _NV_D3D11_SHADING_RATE_RESOURCE_VIEW_DESC_V1::Texture2D

NV_TEX2D_ARRAY_SRRV _NV_D3D11_SHADING_RATE_RESOURCE_VIEW_DESC_V1::Texture2DArray

};

NvU8

_NV_PIXEL_SRSO_1x2::NV_PIXEL_SRSO_1x2_X1::Y [2]

struct _NV_PIXEL_SRSO_1x2::NV_PIXEL_SRSO_1x2_X1

_NV_PIXEL_SRSO_1x2::X1

NvU8

_NV_PIXEL_SRSO_1x2::NV_PIXEL_SRSO_1x2_X2::YS [2][2]

struct _NV_PIXEL_SRSO_1x2::NV_PIXEL_SRSO_1x2_X2

_NV_PIXEL_SRSO_1x2::X2

NvU8

_NV_PIXEL_SRSO_1x2::NV_PIXEL_SRSO_1x2_X4::YS [2][4]

struct _NV_PIXEL_SRSO_1x2::NV_PIXEL_SRSO_1x2_X4

_NV_PIXEL_SRSO_1x2::X4

NvU8

_NV_PIXEL_SRSO_1x2::NV_PIXEL_SRSO_1x2_X8::YS [2][8]

struct _NV_PIXEL_SRSO_1x2::NV_PIXEL_SRSO_1x2_X8

_NV_PIXEL_SRSO_1x2::X8

NvU8

_NV_PIXEL_SRSO_2x1::NV_PIXEL_SRSO_2x1_X1::X [2]

struct _NV_PIXEL_SRSO_2x1::NV_PIXEL_SRSO_2x1_X1

_NV_PIXEL_SRSO_2x1::X1

NvU8

_NV_PIXEL_SRSO_2x1::NV_PIXEL_SRSO_2x1_X2::XS [2][2]

struct _NV_PIXEL_SRSO_2x1::NV_PIXEL_SRSO_2x1_X2

_NV_PIXEL_SRSO_2x1::X2

NvU8

_NV_PIXEL_SRSO_2x1::NV_PIXEL_SRSO_2x1_X4::XS [2][4]

struct _NV_PIXEL_SRSO_2x1::NV_PIXEL_SRSO_2x1_X4

_NV_PIXEL_SRSO_2x1::X4

NvU8

_NV_PIXEL_SRSO_2x2::NV_PIXEL_SRSO_2x2_X1::YX [2][2]

struct _NV_PIXEL_SRSO_2x2::NV_PIXEL_SRSO_2x2_X1

_NV_PIXEL_SRSO_2x2::X1

NvU8

_NV_PIXEL_SRSO_2x2::NV_PIXEL_SRSO_2x2_X2::YXS [2][2][2]

struct _NV_PIXEL_SRSO_2x2::NV_PIXEL_SRSO_2x2_X2

_NV_PIXEL_SRSO_2x2::X2

NvU8

_NV_PIXEL_SRSO_2x2::NV_PIXEL_SRSO_2x2_X4::YXS [2][2][4]

struct _NV_PIXEL_SRSO_2x2::NV_PIXEL_SRSO_2x2_X4

_NV_PIXEL_SRSO_2x2::X4

NvU8

_NV_PIXEL_SRSO_2x4::NV_PIXEL_SRSO_2x4_X1::YX [4][2]

struct _NV_PIXEL_SRSO_2x4::NV_PIXEL_SRSO_2x4_X1

_NV_PIXEL_SRSO_2x4::X1

NvU8

_NV_PIXEL_SRSO_2x4::NV_PIXEL_SRSO_2x4_X2::YXS [4][2][2]

struct _NV_PIXEL_SRSO_2x4::NV_PIXEL_SRSO_2x4_X2

_NV_PIXEL_SRSO_2x4::X2

NvU8

_NV_PIXEL_SRSO_4x2::NV_PIXEL_SRSO_4x2_X1::YX [2][4]

struct _NV_PIXEL_SRSO_4x2::NV_PIXEL_SRSO_4x2_X1

_NV_PIXEL_SRSO_4x2::X1

NvU8

_NV_PIXEL_SRSO_4x4::NV_PIXEL_SRSO_4x4_X1::YX [4][4]

struct _NV_PIXEL_SRSO_4x4::NV_PIXEL_SRSO_4x4_X1

_NV_PIXEL_SRSO_4x4::X1

NvU32

_NV_PIXEL_SHADING_RATE_SAMPLE_ORDER_TABLE_V1::version

NV_PIXEL_SRSO_1x2

_NV_PIXEL_SHADING_RATE_SAMPLE_ORDER_TABLE_V1::Pixel_1x2

NV_PIXEL_SRSO_2x1

_NV_PIXEL_SHADING_RATE_SAMPLE_ORDER_TABLE_V1::Pixel_2x1

NV_PIXEL_SRSO_2x2

_NV_PIXEL_SHADING_RATE_SAMPLE_ORDER_TABLE_V1::Pixel_2x2

NV_PIXEL_SRSO_2x4

_NV_PIXEL_SHADING_RATE_SAMPLE_ORDER_TABLE_V1::Pixel_2x4

NV_PIXEL_SRSO_4x2

_NV_PIXEL_SHADING_RATE_SAMPLE_ORDER_TABLE_V1::Pixel_4x2

NV_PIXEL_SRSO_4x4

_NV_PIXEL_SHADING_RATE_SAMPLE_ORDER_TABLE_V1::Pixel_4x4

NvU32

_NV_VRS_HELPER_LATCH_GAZE_PARAMS_V1::version

NvU32

_NV_VRS_HELPER_LATCH_GAZE_PARAMS_V1::flags

NvU32

_NV_FOVEATED_RENDERING_CUSTOM_SHADING_RATE_PRESET_DESC_V1::version

NV_PIXEL_SHADING_RATE

_NV_FOVEATED_RENDERING_CUSTOM_SHADING_RATE_PRESET_DESC_V1::InnerMostRegionShadingRate

NV_PIXEL_SHADING_RATE

_NV_FOVEATED_RENDERING_CUSTOM_SHADING_RATE_PRESET_DESC_V1::MiddleRegionShadingRate

NV_PIXEL_SHADING_RATE

_NV_FOVEATED_RENDERING_CUSTOM_SHADING_RATE_PRESET_DESC_V1::PeripheralRegionShadingRate

NvU32

_NV_FOVEATED_RENDERING_CUSTOM_FOVEATION_PATTERN_PRESET_DESC_V1::version

float

_NV_FOVEATED_RENDERING_CUSTOM_FOVEATION_PATTERN_PRESET_DESC_V1::fInnermostRadii [2]

float

_NV_FOVEATED_RENDERING_CUSTOM_FOVEATION_PATTERN_PRESET_DESC_V1::fMiddleRadii [2]

float

_NV_FOVEATED_RENDERING_CUSTOM_FOVEATION_PATTERN_PRESET_DESC_V1::fPeripheralRadii [2]

NvU32

_NV_FOVEATED_RENDERING_DESC_V1::version

NvU32

_NV_FOVEATED_RENDERING_DESC_V1::flags

NV_FOVEATED_RENDERING_SHADING_RATE_PRESET

_NV_FOVEATED_RENDERING_DESC_V1::ShadingRatePreset

NV_FOVEATED_RENDERING_CUSTOM_SHADING_RATE_PRESET_DESC_V1

_NV_FOVEATED_RENDERING_DESC_V1::ShadingRateCustomPresetDesc

NV_FOVEATED_RENDERING_FOVEATION_PATTERN_PRESET

_NV_FOVEATED_RENDERING_DESC_V1::FoveationPatternPreset

NV_FOVEATED_RENDERING_CUSTOM_FOVEATION_PATTERN_PRESET_DESC_V1

_NV_FOVEATED_RENDERING_DESC_V1::FoveationPatternCustomPresetDesc

NvU32

_NV_FOVEATED_RENDERING_DESC_V1::GazeDataDeviceId

NvU32

_NV_VRS_HELPER_ENABLE_PARAMS_V1::version

NvU32

_NV_VRS_HELPER_ENABLE_PARAMS_V1::flags

NV_VRS_RENDER_MODE

_NV_VRS_HELPER_ENABLE_PARAMS_V1::RenderMode

NV_VRS_CONTENT_TYPE

_NV_VRS_HELPER_ENABLE_PARAMS_V1::ContentType

NV_FOVEATED_RENDERING_DESC_V1

_NV_VRS_HELPER_ENABLE_PARAMS_V1::sFoveatedRenderingDesc

NvU32

_NV_VRS_HELPER_DISABLE_PARAMS_V1::version

NvU32

_NV_VRS_HELPER_DISABLE_PARAMS_V1::reserved

NvU32

_NV_VRS_HELPER_GET_SHADING_RATE_RESOURCE_PARAMS_V1::version

IUnknown **

_NV_VRS_HELPER_GET_SHADING_RATE_RESOURCE_PARAMS_V1::ppShadingRateResource

NV_PIXEL_SHADING_RATE

_NV_VRS_HELPER_GET_SHADING_RATE_RESOURCE_PARAMS_V1::shadingRateTable [NV_MAX_PIXEL_SHADING_RATES]

NvU32

_NV_VRS_HELPER_PURGE_INTERNAL_RESOURCES_PARAMS_V1::version

NvU32

_NV_VRS_HELPER_PURGE_INTERNAL_RESOURCES_PARAMS_V1::reserved

NvU32

_NV_VRS_HELPER_INIT_PARAMS_V1::version

NvU32

_NV_VRS_HELPER_INIT_PARAMS_V1::flags

ID3DNvVRSHelper_V1 **

_NV_VRS_HELPER_INIT_PARAMS_V1::ppVRSHelper

NvU32

_NV_FOVEATED_RENDERING_GAZE_DATA_PER_EYE::version

NvU32

_NV_FOVEATED_RENDERING_GAZE_DATA_PER_EYE::GazeDataValidityFlags

float

_NV_FOVEATED_RENDERING_GAZE_DATA_PER_EYE::fGazeOrigin_mm [3]

float

_NV_FOVEATED_RENDERING_GAZE_DATA_PER_EYE::fGazeDirection [3]

float

_NV_FOVEATED_RENDERING_GAZE_DATA_PER_EYE::fGazeNormalizedLocation [2]

float

_NV_FOVEATED_RENDERING_GAZE_DATA_PER_EYE::fGazeVelocity [2]

float

_NV_FOVEATED_RENDERING_GAZE_DATA_PER_EYE::fPupilDiameter_mm

float

_NV_FOVEATED_RENDERING_GAZE_DATA_PER_EYE::fEyeOpenness

BOOL

_NV_FOVEATED_RENDERING_GAZE_DATA_PER_EYE::bInSaccade

NvU32

_NV_FOVEATED_RENDERING_UPDATE_GAZE_DATA_PARAMS::version

NvU32

_NV_FOVEATED_RENDERING_UPDATE_GAZE_DATA_PARAMS::flags

NvU64

_NV_FOVEATED_RENDERING_UPDATE_GAZE_DATA_PARAMS::Timestamp

NV_FOVEATED_RENDERING_GAZE_DATA_PER_EYE_V1 _NV_FOVEATED_RENDERING_UPDATE_GAZE_DATA_PARAMS::sMonoData

NV_FOVEATED_RENDERING_GAZE_DATA_PER_EYE_V1 _NV_FOVEATED_RENDERING_UPDATE_GAZE_DATA_PARAMS::sLeftEye

NV_FOVEATED_RENDERING_GAZE_DATA_PER_EYE_V1 _NV_FOVEATED_RENDERING_UPDATE_GAZE_DATA_PARAMS::sRightEye

struct {

NV_FOVEATED_RENDERING_GAZE_DATA_PER_EYE_V1 _NV_FOVEATED_RENDERING_UPDATE_GAZE_DATA_PARAMS::sLeftEye

NV_FOVEATED_RENDERING_GAZE_DATA_PER_EYE_V1 _NV_FOVEATED_RENDERING_UPDATE_GAZE_DATA_PARAMS::sRightEye

} _NV_FOVEATED_RENDERING_UPDATE_GAZE_DATA_PARAMS::sStereoData

union {

NV_FOVEATED_RENDERING_GAZE_DATA_PER_EYE_V1 _NV_FOVEATED_RENDERING_UPDATE_GAZE_DATA_PARAMS::sMonoData

struct {

NV_FOVEATED_RENDERING_GAZE_DATA_PER_EYE_V1 _NV_FOVEATED_RENDERING_UPDATE_GAZE_DATA_PARAMS::sLeftEye

NV_FOVEATED_RENDERING_GAZE_DATA_PER_EYE_V1 _NV_FOVEATED_RENDERING_UPDATE_GAZE_DATA_PARAMS::sRightEye

} _NV_FOVEATED_RENDERING_UPDATE_GAZE_DATA_PARAMS::sStereoData

};

NvU32

_NV_GAZE_HANDLER_INIT_PARAMS_V2::version

NvU32

_NV_GAZE_HANDLER_INIT_PARAMS_V2::GazeDataDeviceId

NV_GAZE_DATA_TYPE

_NV_GAZE_HANDLER_INIT_PARAMS_V2::GazeDataType

NvU32

_NV_GAZE_HANDLER_INIT_PARAMS_V2::flags

float

_NV_GAZE_HANDLER_INIT_PARAMS_V2::fHorizontalFOV

float

_NV_GAZE_HANDLER_INIT_PARAMS_V2::fVericalFOV

ID3DNvGazeHandler_V2 **

_NV_GAZE_HANDLER_INIT_PARAMS_V2::ppNvGazeHandler

NvU32

_NV_GAZE_HANDLER_INIT_PARAMS_V1::version

NvU32

_NV_GAZE_HANDLER_INIT_PARAMS_V1::GazeDataDeviceId

NV_GAZE_DATA_TYPE

_NV_GAZE_HANDLER_INIT_PARAMS_V1::GazeDataType

NvU32

_NV_GAZE_HANDLER_INIT_PARAMS_V1::flags

float

_NV_GAZE_HANDLER_INIT_PARAMS_V1::fHorizontalFOV

float

_NV_GAZE_HANDLER_INIT_PARAMS_V1::fVericalFOV

ID3DNvGazeHandler_V1 **

_NV_GAZE_HANDLER_INIT_PARAMS_V1::ppNvGazeHandler

float

_NV_MRS_CUSTOM_CONFIG_V1::centerWidth

float

_NV_MRS_CUSTOM_CONFIG_V1::centerHeight

float

_NV_MRS_CUSTOM_CONFIG_V1::centerX

float

_NV_MRS_CUSTOM_CONFIG_V1::centerY

float

_NV_MRS_CUSTOM_CONFIG_V1::densityScaleX [3]

float

_NV_MRS_CUSTOM_CONFIG_V1::densityScaleY [3]

float

_NV_MRS_INSTANCED_STEREO_CONFIG_V1::centerWidth [2]

float

_NV_MRS_INSTANCED_STEREO_CONFIG_V1::centerHeight

float

_NV_MRS_INSTANCED_STEREO_CONFIG_V1::centerX [2]

float

_NV_MRS_INSTANCED_STEREO_CONFIG_V1::centerY

float

_NV_MRS_INSTANCED_STEREO_CONFIG_V1::densityScaleX [5]

float

_NV_MRS_INSTANCED_STEREO_CONFIG_V1::densityScaleY [3]

float

_NV_LMS_CUSTOM_CONFIG_V1::warpLeft

float

_NV_LMS_CUSTOM_CONFIG_V1::warpRight

float

_NV_LMS_CUSTOM_CONFIG_V1::warpUp

float

_NV_LMS_CUSTOM_CONFIG_V1::warpDown

float

_NV_LMS_CUSTOM_CONFIG_V1::relativeSizeLeft

float

_NV_LMS_CUSTOM_CONFIG_V1::relativeSizeRight

float

_NV_LMS_CUSTOM_CONFIG_V1::relativeSizeUp

float

_NV_LMS_CUSTOM_CONFIG_V1::relativeSizeDown

NV_LMS_CUSTOM_CONFIG_V1

_NV_LMS_INSTANCED_STEREO_CONFIG_V1::sLeftConfig

NV_LMS_CUSTOM_CONFIG_V1

_NV_LMS_INSTANCED_STEREO_CONFIG_V1::sRightConfig

NvU32

_NV_CUSTOM_RECTS_V1::numViewports [NV_SMP_ASSIST_MINIMAL_LEVEL_NUM_EYE_INDICES]

D3D11_VIEWPORT *

_NV_CUSTOM_RECTS_V1::pViewports [NV_SMP_ASSIST_MINIMAL_LEVEL_NUM_EYE_INDICES]

D3D11_RECT *

_NV_CUSTOM_RECTS_V1::pScissors [NV_SMP_ASSIST_MINIMAL_LEVEL_NUM_EYE_INDICES]

NvU32

_NV_SMP_ASSIST_ENABLE_PARAMS_V1::version

NV_SMP_ASSIST_EYE_INDEX

_NV_SMP_ASSIST_ENABLE_PARAMS_V1::eEyeIndex

NvU32

_NV_SMP_ASSIST_DISABLE_PARAMS_V1::version

NvU32

_NV_SMP_ASSIST_DISABLE_PARAMS_V1::Reserved

float

_NV_SMP_ASSIST_FASTGSCBDATA_V1::NDCSplitsX [2]

float

_NV_SMP_ASSIST_FASTGSCBDATA_V1::NDCSplitsY [2]

float

_NV_SMP_ASSIST_FASTGSCBDATA_MRS_INSTANCED_STEREO_V1::NDCSplitsX [4]

float

_NV_SMP_ASSIST_FASTGSCBDATA_MRS_INSTANCED_STEREO_V1::NDCSplitsY [2]

float

_NV_SMP_ASSIST_REMAPCBDATA_V1::ClipToWindowSplitsX [2]

float

_NV_SMP_ASSIST_REMAPCBDATA_V1::ClipToWindowSplitsY [2]

float

_NV_SMP_ASSIST_REMAPCBDATA_V1::ClipToWindowX [3][2]

float

_NV_SMP_ASSIST_REMAPCBDATA_V1::ClipToWindowY [3][2]

float

_NV_SMP_ASSIST_REMAPCBDATA_V1::ClipToWindowZ [2]

float

_NV_SMP_ASSIST_REMAPCBDATA_V1::WindowToClipSplitsX [2]

float

_NV_SMP_ASSIST_REMAPCBDATA_V1::WindowToClipSplitsY [2]

float

_NV_SMP_ASSIST_REMAPCBDATA_V1::WindowToClipX [3][2]

float

_NV_SMP_ASSIST_REMAPCBDATA_V1::WindowToClipY [3][2]

float

_NV_SMP_ASSIST_REMAPCBDATA_V1::WindowToClipZ [2]

float

_NV_SMP_ASSIST_REMAPCBDATA_V1::BoundingRectOriginX

float

_NV_SMP_ASSIST_REMAPCBDATA_V1::BoundingRectOriginY

float

_NV_SMP_ASSIST_REMAPCBDATA_V1::BoundingRectSizeWidth

float

_NV_SMP_ASSIST_REMAPCBDATA_V1::BoundingRectSizeHeight

float

_NV_SMP_ASSIST_REMAPCBDATA_V1::BoundingRectSizeInvWidth

float

_NV_SMP_ASSIST_REMAPCBDATA_V1::BoundingRectSizeInvHeight

float

_NV_SMP_ASSIST_REMAPCBDATA_V1::Padding [2]

NvU32

_NV_SMP_ASSIST_GET_CONSTANTS_V3::version

NV_SMP_ASSIST_EYE_INDEX

_NV_SMP_ASSIST_GET_CONSTANTS_V3::eEyeIndex

NvU32

_NV_SMP_ASSIST_GET_CONSTANTS_V3::numViewports

D3D11_VIEWPORT *

_NV_SMP_ASSIST_GET_CONSTANTS_V3::pViewports

D3D11_RECT *

_NV_SMP_ASSIST_GET_CONSTANTS_V3::pScissors

NV_SMP_ASSIST_TYPE

_NV_SMP_ASSIST_GET_CONSTANTS_V3::eSMPAssistType

NV_SMP_ASSIST_LEVEL

_NV_SMP_ASSIST_GET_CONSTANTS_V3::eSMPAssistLevel

NV_MRS_CUSTOM_CONFIG_V1 _NV_SMP_ASSIST_GET_CONSTANTS_V3::sMRSConfig

NV_LMS_CUSTOM_CONFIG_V1 _NV_SMP_ASSIST_GET_CONSTANTS_V3::sLMSConfig

union {

NV_MRS_CUSTOM_CONFIG_V1 _NV_SMP_ASSIST_GET_CONSTANTS_V3::sMRSConfig

NV_LMS_CUSTOM_CONFIG_V1 _NV_SMP_ASSIST_GET_CONSTANTS_V3::sLMSConfig

};

float

_NV_SMP_ASSIST_GET_CONSTANTS_V3::projectionSizeWidth

float

_NV_SMP_ASSIST_GET_CONSTANTS_V3::projectionSizeHeight

NV_SMP_ASSIST_FASTGSCBDATA_V1 *

_NV_SMP_ASSIST_GET_CONSTANTS_V3::pFastGSCBData

NV_SMP_ASSIST_REMAPCBDATA_V1 *

_NV_SMP_ASSIST_GET_CONSTANTS_V3::pRemapCBData

D3D11_VIEWPORT

_NV_SMP_ASSIST_GET_CONSTANTS_V3::boundingViewport

D3D11_RECT

_NV_SMP_ASSIST_GET_CONSTANTS_V3::boundingScissor

NV_MRS_INSTANCED_STEREO_CONFIG_V1 _NV_SMP_ASSIST_GET_CONSTANTS_V3::sMRS_ISConfig

NV_LMS_INSTANCED_STEREO_CONFIG_V1 _NV_SMP_ASSIST_GET_CONSTANTS_V3::sLMS_ISConfig

union {

NV_MRS_INSTANCED_STEREO_CONFIG_V1 _NV_SMP_ASSIST_GET_CONSTANTS_V3::sMRS_ISConfig

NV_LMS_INSTANCED_STEREO_CONFIG_V1 _NV_SMP_ASSIST_GET_CONSTANTS_V3::sLMS_ISConfig

};

NV_SMP_ASSIST_FASTGSCBDATA_MRS_INSTANCED_STEREO_V1 *

_NV_SMP_ASSIST_GET_CONSTANTS_V3::pFastGSCBDataMRS_IS

NvU32

_NV_SMP_ASSIST_SETUP_PARAMS_V1::version

NV_MRS_CONFIG _NV_SMP_ASSIST_SETUP_PARAMS_V1::eMRSConfig

NV_LMS_CONFIG _NV_SMP_ASSIST_SETUP_PARAMS_V1::eLMSConfig

NV_MRS_CUSTOM_CONFIG_V1 _NV_SMP_ASSIST_SETUP_PARAMS_V1::sMRSCustomConfig

NV_LMS_CUSTOM_CONFIG_V1 _NV_SMP_ASSIST_SETUP_PARAMS_V1::sLMSCustomConfig

NV_CUSTOM_RECTS_V1 _NV_SMP_ASSIST_SETUP_PARAMS_V1::sCustomRects

union {

NV_MRS_CONFIG _NV_SMP_ASSIST_SETUP_PARAMS_V1::eMRSConfig

NV_LMS_CONFIG _NV_SMP_ASSIST_SETUP_PARAMS_V1::eLMSConfig

NV_MRS_CUSTOM_CONFIG_V1 _NV_SMP_ASSIST_SETUP_PARAMS_V1::sMRSCustomConfig

NV_LMS_CUSTOM_CONFIG_V1 _NV_SMP_ASSIST_SETUP_PARAMS_V1::sLMSCustomConfig

NV_CUSTOM_RECTS_V1 _NV_SMP_ASSIST_SETUP_PARAMS_V1::sCustomRects

};

float

_NV_SMP_ASSIST_SETUP_PARAMS_V1::resolutionScale

D3D11_VIEWPORT

_NV_SMP_ASSIST_SETUP_PARAMS_V1::boundingBox

float

_NV_SMP_ASSIST_SETUP_PARAMS_V1::vpOffsets [2]

NvU32

_NV_SMP_ASSIST_UPDATE_INSTANCEDSTEREO_DATA_PARAMS_V1::version

NV_SMP_ASSIST_TYPE

_NV_SMP_ASSIST_UPDATE_INSTANCEDSTEREO_DATA_PARAMS_V1::eSMPAssistType

float

_NV_SMP_ASSIST_UPDATE_INSTANCEDSTEREO_DATA_PARAMS_V1::leftCoeffs [4]

float

_NV_SMP_ASSIST_UPDATE_INSTANCEDSTEREO_DATA_PARAMS_V1::leftConst

float

_NV_SMP_ASSIST_UPDATE_INSTANCEDSTEREO_DATA_PARAMS_V1::rightCoeffs [4]

float

_NV_SMP_ASSIST_UPDATE_INSTANCEDSTEREO_DATA_PARAMS_V1::rightConst

NvU32

_NV_SMP_ASSIST_INITIALIZE_PARAMS_V1::version

NV_SMP_ASSIST_TYPE

_NV_SMP_ASSIST_INITIALIZE_PARAMS_V1::eSMPAssistType

NV_SMP_ASSIST_LEVEL

_NV_SMP_ASSIST_INITIALIZE_PARAMS_V1::eSMPAssistLevel

NvU32

_NV_SMP_ASSIST_INITIALIZE_PARAMS_V1::flags

ID3DNvSMPAssist **

_NV_SMP_ASSIST_INITIALIZE_PARAMS_V1::ppD3DNvSMPAssist

NvU32

_NV_QUERY_SMP_ASSIST_SUPPORT_PARAMS_V1::version

NV_SMP_ASSIST_TYPE

_NV_QUERY_SMP_ASSIST_SUPPORT_PARAMS_V1::eSMPAssistType

NV_SMP_ASSIST_LEVEL

_NV_QUERY_SMP_ASSIST_SUPPORT_PARAMS_V1::eSMPAssistLevel

NvBool

_NV_QUERY_SMP_ASSIST_SUPPORT_PARAMS_V1::bSMPAssistSupported

NvU32

_NV_GET_SLEEP_STATUS_PARAMS::version

NvBool

_NV_GET_SLEEP_STATUS_PARAMS::bLowLatencyMode

NvBool

_NV_GET_SLEEP_STATUS_PARAMS::bFsVrr

NvBool

_NV_GET_SLEEP_STATUS_PARAMS::bCplVsyncOn

NvU32

_NV_GET_SLEEP_STATUS_PARAMS::sleepIntervalUs

NvBool

_NV_GET_SLEEP_STATUS_PARAMS::bUseGameSleep

NvU8

_NV_GET_SLEEP_STATUS_PARAMS::rsvd [121]

NvU32

_NV_SET_SLEEP_MODE_PARAMS::version

NvBool

_NV_SET_SLEEP_MODE_PARAMS::bLowLatencyMode

NvBool

_NV_SET_SLEEP_MODE_PARAMS::bLowLatencyBoost

NvU32

_NV_SET_SLEEP_MODE_PARAMS::minimumIntervalUs

NvBool

_NV_SET_SLEEP_MODE_PARAMS::bUseMarkersToOptimize

NvU8

_NV_SET_SLEEP_MODE_PARAMS::rsvd [31]

NvU32

_NV_SET_REFLEX_SYNC_PARAMS::version

NvU32

_NV_SET_REFLEX_SYNC_PARAMS::bEnable:1

NvU32

_NV_SET_REFLEX_SYNC_PARAMS::bDisable:1

NvU32

_NV_SET_REFLEX_SYNC_PARAMS::flagsRsvd:30

NvU32

_NV_SET_REFLEX_SYNC_PARAMS::vblankIntervalUs

NvS32

_NV_SET_REFLEX_SYNC_PARAMS::timeInQueueUs

NvU32

_NV_SET_REFLEX_SYNC_PARAMS::timeInQueueUsTarget

NvU8

_NV_SET_REFLEX_SYNC_PARAMS::rsvd [28]

NvU32

_NV_LATENCY_RESULT_PARAMS::version

NvU64

_NV_LATENCY_RESULT_PARAMS::FrameReport::frameID

NvU64

_NV_LATENCY_RESULT_PARAMS::FrameReport::inputSampleTime

NvU64

_NV_LATENCY_RESULT_PARAMS::FrameReport::simStartTime

NvU64

_NV_LATENCY_RESULT_PARAMS::FrameReport::simEndTime

NvU64

_NV_LATENCY_RESULT_PARAMS::FrameReport::renderSubmitStartTime

NvU64

_NV_LATENCY_RESULT_PARAMS::FrameReport::renderSubmitEndTime

NvU64

_NV_LATENCY_RESULT_PARAMS::FrameReport::presentStartTime

NvU64

_NV_LATENCY_RESULT_PARAMS::FrameReport::presentEndTime

NvU64

_NV_LATENCY_RESULT_PARAMS::FrameReport::driverStartTime

NvU64

_NV_LATENCY_RESULT_PARAMS::FrameReport::driverEndTime

NvU64

_NV_LATENCY_RESULT_PARAMS::FrameReport::osRenderQueueStartTime

NvU64

_NV_LATENCY_RESULT_PARAMS::FrameReport::osRenderQueueEndTime

NvU64

_NV_LATENCY_RESULT_PARAMS::FrameReport::gpuRenderStartTime

NvU64

_NV_LATENCY_RESULT_PARAMS::FrameReport::gpuRenderEndTime

NvU32

_NV_LATENCY_RESULT_PARAMS::FrameReport::gpuActiveRenderTimeUs

NvU32

_NV_LATENCY_RESULT_PARAMS::FrameReport::gpuFrameTimeUs

NvU8

_NV_LATENCY_RESULT_PARAMS::FrameReport::rsvd [120]

struct _NV_LATENCY_RESULT_PARAMS::FrameReport

_NV_LATENCY_RESULT_PARAMS::frameReport [64]

NvU8

_NV_LATENCY_RESULT_PARAMS::rsvd [32]

NvU32

_NV_LATENCY_MARKER_PARAMS::version

NvU64

_NV_LATENCY_MARKER_PARAMS::frameID

NV_LATENCY_MARKER_TYPE

_NV_LATENCY_MARKER_PARAMS::markerType

NvU64

_NV_LATENCY_MARKER_PARAMS::rsvd0

NvU8

_NV_LATENCY_MARKER_PARAMS::rsvd [56]

NvU32

_NV_ASYNC_FRAME_MARKER_PARAMS_V1::version

NvU64

_NV_ASYNC_FRAME_MARKER_PARAMS_V1::frameID

NV_LATENCY_MARKER_TYPE

_NV_ASYNC_FRAME_MARKER_PARAMS_V1::markerType

NvU64

_NV_ASYNC_FRAME_MARKER_PARAMS_V1::presentFrameID

NvU8

_NV_ASYNC_FRAME_MARKER_PARAMS_V1::rsvd [56]

size_t

NVAPI_D3D12_CREATE_CUBIN_SHADER_PARAMS::structSizeIn

size_t

NVAPI_D3D12_CREATE_CUBIN_SHADER_PARAMS::structSizeOut

ID3D12Device *

NVAPI_D3D12_CREATE_CUBIN_SHADER_PARAMS::pDevice

const void *

NVAPI_D3D12_CREATE_CUBIN_SHADER_PARAMS::pCubin

NvU32

NVAPI_D3D12_CREATE_CUBIN_SHADER_PARAMS::size

NvU32

NVAPI_D3D12_CREATE_CUBIN_SHADER_PARAMS::blockX

NvU32

NVAPI_D3D12_CREATE_CUBIN_SHADER_PARAMS::blockY

NvU32

NVAPI_D3D12_CREATE_CUBIN_SHADER_PARAMS::blockZ

NvU32

NVAPI_D3D12_CREATE_CUBIN_SHADER_PARAMS::dynSharedMemBytes

const char *

NVAPI_D3D12_CREATE_CUBIN_SHADER_PARAMS::pShaderName

NvU32

NVAPI_D3D12_CREATE_CUBIN_SHADER_PARAMS::flags

NVDX_ObjectHandle

NVAPI_D3D12_CREATE_CUBIN_SHADER_PARAMS::hShader

size_t

NVAPI_D3D12_GET_CUDA_MERGED_TEXTURE_SAMPLER_OBJECT_PARAMS::structSizeIn

size_t

NVAPI_D3D12_GET_CUDA_MERGED_TEXTURE_SAMPLER_OBJECT_PARAMS::structSizeOut

ID3D12Device *

NVAPI_D3D12_GET_CUDA_MERGED_TEXTURE_SAMPLER_OBJECT_PARAMS::pDevice

D3D12_CPU_DESCRIPTOR_HANDLE

NVAPI_D3D12_GET_CUDA_MERGED_TEXTURE_SAMPLER_OBJECT_PARAMS::texDesc

D3D12_CPU_DESCRIPTOR_HANDLE

NVAPI_D3D12_GET_CUDA_MERGED_TEXTURE_SAMPLER_OBJECT_PARAMS::smpDesc

NvU64

NVAPI_D3D12_GET_CUDA_MERGED_TEXTURE_SAMPLER_OBJECT_PARAMS::textureHandle

size_t

NVAPI_D3D12_GET_CUDA_INDEPENDENT_DESCRIPTOR_OBJECT_PARAMS::structSizeIn

size_t

NVAPI_D3D12_GET_CUDA_INDEPENDENT_DESCRIPTOR_OBJECT_PARAMS::structSizeOut

ID3D12Device *

NVAPI_D3D12_GET_CUDA_INDEPENDENT_DESCRIPTOR_OBJECT_PARAMS::pDevice

NVAPI_D3D12_GET_CUDA_INDEPENDENT_DESCRIPTOR_OBJECT_TYPE

NVAPI_D3D12_GET_CUDA_INDEPENDENT_DESCRIPTOR_OBJECT_PARAMS::type

D3D12_CPU_DESCRIPTOR_HANDLE

NVAPI_D3D12_GET_CUDA_INDEPENDENT_DESCRIPTOR_OBJECT_PARAMS::desc

NvU64

NVAPI_D3D12_GET_CUDA_INDEPENDENT_DESCRIPTOR_OBJECT_PARAMS::handle

NvU32

_NVAPI_DIM3::x

NvU32

_NVAPI_DIM3::y

NvU32

_NVAPI_DIM3::z

NVDX_ObjectHandle

_NVAPI_CU_KERNEL_LAUNCH_PARAMS::hFunction

NVAPI_DIM3

_NVAPI_CU_KERNEL_LAUNCH_PARAMS::gridDim

NVAPI_DIM3

_NVAPI_CU_KERNEL_LAUNCH_PARAMS::blockDim

NvU32

_NVAPI_CU_KERNEL_LAUNCH_PARAMS::dynSharedMemBytes

void const *

_NVAPI_CU_KERNEL_LAUNCH_PARAMS::pParams

NvU32

_NVAPI_CU_KERNEL_LAUNCH_PARAMS::paramSize

NVDX_ObjectHandle

_NVAPI_CU_KERNEL_LAUNCH_PARAMS_EX::hFunction

NVAPI_DIM3

_NVAPI_CU_KERNEL_LAUNCH_PARAMS_EX::gridDim

NVAPI_DIM3

_NVAPI_CU_KERNEL_LAUNCH_PARAMS_EX::blockDim

NvU32

_NVAPI_CU_KERNEL_LAUNCH_PARAMS_EX::dynSharedMemBytes

void const *

_NVAPI_CU_KERNEL_LAUNCH_PARAMS_EX::pParams

NvU32

_NVAPI_CU_KERNEL_LAUNCH_PARAMS_EX::paramSize

void **

_NVAPI_CU_KERNEL_LAUNCH_PARAMS_EX::kernelParams

NvU32

_NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_USAGE_COUNT::count

NvU32

_NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_USAGE_COUNT::subdivisionLevel

NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_FORMAT

_NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_USAGE_COUNT::format

NvU32

_NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_DESC::byteOffset

NvU16

_NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_DESC::subdivisionLevel

NvU16

_NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_DESC::format

NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_BUILD_FLAGS

_NVAPI_D3D12_BUILD_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_INPUTS::flags

NvU32

_NVAPI_D3D12_BUILD_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_INPUTS::numDMMUsageCounts

const NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_USAGE_COUNT *

_NVAPI_D3D12_BUILD_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_INPUTS::pDMMUsageCounts

D3D12_GPU_VIRTUAL_ADDRESS

_NVAPI_D3D12_BUILD_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_INPUTS::inputBuffer

D3D12_GPU_VIRTUAL_ADDRESS_AND_STRIDE

_NVAPI_D3D12_BUILD_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_INPUTS::perDMMDescs

NvU64

_NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PREBUILD_INFO::resultDataMaxSizeInBytes

NvU64

_NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PREBUILD_INFO::scratchDataSizeInBytes

NvU32

_NVAPI_GET_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PREBUILD_INFO_PARAMS_V1::version

const NVAPI_D3D12_BUILD_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_INPUTS *

_NVAPI_GET_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PREBUILD_INFO_PARAMS_V1::pDesc

NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PREBUILD_INFO *

_NVAPI_GET_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PREBUILD_INFO_PARAMS_V1::pInfo

NvU32

_NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_USAGE_COUNT::count

NvU32

_NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_USAGE_COUNT::subdivisionLevel

NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_FORMAT

_NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_USAGE_COUNT::format

NvU32

_NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_DESC::byteOffset

NvU16

_NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_DESC::subdivisionLevel

NvU16

_NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_DESC::format

NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_ARRAY_BUILD_FLAGS

_NVAPI_D3D12_BUILD_RAYTRACING_OPACITY_MICROMAP_ARRAY_INPUTS::flags

NvU32

_NVAPI_D3D12_BUILD_RAYTRACING_OPACITY_MICROMAP_ARRAY_INPUTS::numOMMUsageCounts

const NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_USAGE_COUNT *

_NVAPI_D3D12_BUILD_RAYTRACING_OPACITY_MICROMAP_ARRAY_INPUTS::pOMMUsageCounts

D3D12_GPU_VIRTUAL_ADDRESS

_NVAPI_D3D12_BUILD_RAYTRACING_OPACITY_MICROMAP_ARRAY_INPUTS::inputBuffer

D3D12_GPU_VIRTUAL_ADDRESS_AND_STRIDE

_NVAPI_D3D12_BUILD_RAYTRACING_OPACITY_MICROMAP_ARRAY_INPUTS::perOMMDescs

NvU64

_NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_ARRAY_PREBUILD_INFO::resultDataMaxSizeInBytes

NvU64

_NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_ARRAY_PREBUILD_INFO::scratchDataSizeInBytes

NvU32

_NVAPI_GET_RAYTRACING_OPACITY_MICROMAP_ARRAY_PREBUILD_INFO_PARAMS_V1::version

const NVAPI_D3D12_BUILD_RAYTRACING_OPACITY_MICROMAP_ARRAY_INPUTS *

_NVAPI_GET_RAYTRACING_OPACITY_MICROMAP_ARRAY_PREBUILD_INFO_PARAMS_V1::pDesc

NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_ARRAY_PREBUILD_INFO *

_NVAPI_GET_RAYTRACING_OPACITY_MICROMAP_ARRAY_PREBUILD_INFO_PARAMS_V1::pInfo

NvU32

_NVAPI_D3D12_SET_CREATE_PIPELINE_STATE_OPTIONS_PARAMS_V1::version

NvU32

_NVAPI_D3D12_SET_CREATE_PIPELINE_STATE_OPTIONS_PARAMS_V1::flags

NvU32

_NVAPI_CHECK_DRIVER_MATCHING_IDENTIFIER_EX_PARAMS_V1::version

NVAPI_D3D12_SERIALIZED_DATA_TYPE_EX

_NVAPI_CHECK_DRIVER_MATCHING_IDENTIFIER_EX_PARAMS_V1::serializedDataType

const D3D12_SERIALIZED_DATA_DRIVER_MATCHING_IDENTIFIER *

_NVAPI_CHECK_DRIVER_MATCHING_IDENTIFIER_EX_PARAMS_V1::pIdentifierToCheck

D3D12_DRIVER_MATCHING_IDENTIFIER_STATUS

_NVAPI_CHECK_DRIVER_MATCHING_IDENTIFIER_EX_PARAMS_V1::checkStatus

D3D12_GPU_VIRTUAL_ADDRESS_AND_STRIDE

_NVAPI_D3D12_RAYTRACING_GEOMETRY_OMM_ATTACHMENT_DESC::opacityMicromapIndexBuffer

DXGI_FORMAT

_NVAPI_D3D12_RAYTRACING_GEOMETRY_OMM_ATTACHMENT_DESC::opacityMicromapIndexFormat

NvU32

_NVAPI_D3D12_RAYTRACING_GEOMETRY_OMM_ATTACHMENT_DESC::opacityMicromapBaseLocation

D3D12_GPU_VIRTUAL_ADDRESS

_NVAPI_D3D12_RAYTRACING_GEOMETRY_OMM_ATTACHMENT_DESC::opacityMicromapArray

NvU32

_NVAPI_D3D12_RAYTRACING_GEOMETRY_OMM_ATTACHMENT_DESC::numOMMUsageCounts

const NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_USAGE_COUNT *

_NVAPI_D3D12_RAYTRACING_GEOMETRY_OMM_ATTACHMENT_DESC::pOMMUsageCounts

D3D12_GPU_VIRTUAL_ADDRESS_AND_STRIDE

_NVAPI_D3D12_RAYTRACING_GEOMETRY_DMM_ATTACHMENT_DESC::triangleMicromapIndexBuffer

DXGI_FORMAT

_NVAPI_D3D12_RAYTRACING_GEOMETRY_DMM_ATTACHMENT_DESC::triangleMicromapIndexFormat

NvU32

_NVAPI_D3D12_RAYTRACING_GEOMETRY_DMM_ATTACHMENT_DESC::triangleMicromapBaseLocation

D3D12_GPU_VIRTUAL_ADDRESS_AND_STRIDE

_NVAPI_D3D12_RAYTRACING_GEOMETRY_DMM_ATTACHMENT_DESC::trianglePrimitiveFlagsBuffer

D3D12_GPU_VIRTUAL_ADDRESS_AND_STRIDE

_NVAPI_D3D12_RAYTRACING_GEOMETRY_DMM_ATTACHMENT_DESC::vertexBiasAndScaleBuffer

DXGI_FORMAT

_NVAPI_D3D12_RAYTRACING_GEOMETRY_DMM_ATTACHMENT_DESC::vertexBiasAndScaleFormat

D3D12_GPU_VIRTUAL_ADDRESS_AND_STRIDE

_NVAPI_D3D12_RAYTRACING_GEOMETRY_DMM_ATTACHMENT_DESC::vertexDisplacementVectorBuffer

DXGI_FORMAT

_NVAPI_D3D12_RAYTRACING_GEOMETRY_DMM_ATTACHMENT_DESC::vertexDisplacementVectorFormat

D3D12_GPU_VIRTUAL_ADDRESS

_NVAPI_D3D12_RAYTRACING_GEOMETRY_DMM_ATTACHMENT_DESC::displacementMicromapArray

NvU32

_NVAPI_D3D12_RAYTRACING_GEOMETRY_DMM_ATTACHMENT_DESC::numDMMUsageCounts

const NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_USAGE_COUNT *

_NVAPI_D3D12_RAYTRACING_GEOMETRY_DMM_ATTACHMENT_DESC::pDMMUsageCounts

D3D12_RAYTRACING_GEOMETRY_TRIANGLES_DESC

_NVAPI_D3D12_RAYTRACING_GEOMETRY_DMM_TRIANGLES_DESC::triangles

NVAPI_D3D12_RAYTRACING_GEOMETRY_DMM_ATTACHMENT_DESC

_NVAPI_D3D12_RAYTRACING_GEOMETRY_DMM_TRIANGLES_DESC::dmmAttachment

D3D12_RAYTRACING_GEOMETRY_TRIANGLES_DESC

_NVAPI_D3D12_RAYTRACING_GEOMETRY_OMM_TRIANGLES_DESC::triangles

NVAPI_D3D12_RAYTRACING_GEOMETRY_OMM_ATTACHMENT_DESC

_NVAPI_D3D12_RAYTRACING_GEOMETRY_OMM_TRIANGLES_DESC::ommAttachment

NVAPI_D3D12_RAYTRACING_GEOMETRY_TYPE_EX

_NVAPI_D3D12_RAYTRACING_GEOMETRY_DESC_EX::type

D3D12_RAYTRACING_GEOMETRY_FLAGS

_NVAPI_D3D12_RAYTRACING_GEOMETRY_DESC_EX::flags

D3D12_RAYTRACING_GEOMETRY_TRIANGLES_DESC _NVAPI_D3D12_RAYTRACING_GEOMETRY_DESC_EX::triangles

D3D12_RAYTRACING_GEOMETRY_AABBS_DESC _NVAPI_D3D12_RAYTRACING_GEOMETRY_DESC_EX::aabbs

NVAPI_D3D12_RAYTRACING_GEOMETRY_OMM_TRIANGLES_DESC _NVAPI_D3D12_RAYTRACING_GEOMETRY_DESC_EX::ommTriangles

NVAPI_D3D12_RAYTRACING_GEOMETRY_DMM_TRIANGLES_DESC _NVAPI_D3D12_RAYTRACING_GEOMETRY_DESC_EX::dmmTriangles

union {

D3D12_RAYTRACING_GEOMETRY_TRIANGLES_DESC _NVAPI_D3D12_RAYTRACING_GEOMETRY_DESC_EX::triangles

D3D12_RAYTRACING_GEOMETRY_AABBS_DESC _NVAPI_D3D12_RAYTRACING_GEOMETRY_DESC_EX::aabbs

NVAPI_D3D12_RAYTRACING_GEOMETRY_OMM_TRIANGLES_DESC _NVAPI_D3D12_RAYTRACING_GEOMETRY_DESC_EX::ommTriangles

NVAPI_D3D12_RAYTRACING_GEOMETRY_DMM_TRIANGLES_DESC _NVAPI_D3D12_RAYTRACING_GEOMETRY_DESC_EX::dmmTriangles

};

D3D12_RAYTRACING_ACCELERATION_STRUCTURE_TYPE

_NVAPI_D3D12_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_INPUTS_EX::type

NVAPI_D3D12_RAYTRACING_ACCELERATION_STRUCTURE_BUILD_FLAGS_EX

_NVAPI_D3D12_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_INPUTS_EX::flags

NvU32

_NVAPI_D3D12_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_INPUTS_EX::numDescs

D3D12_ELEMENTS_LAYOUT

_NVAPI_D3D12_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_INPUTS_EX::descsLayout

NvU32

_NVAPI_D3D12_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_INPUTS_EX::geometryDescStrideInBytes

D3D12_GPU_VIRTUAL_ADDRESS _NVAPI_D3D12_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_INPUTS_EX::instanceDescs

const NVAPI_D3D12_RAYTRACING_GEOMETRY_DESC_EX * _NVAPI_D3D12_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_INPUTS_EX::pGeometryDescs

const NVAPI_D3D12_RAYTRACING_GEOMETRY_DESC_EX *const * _NVAPI_D3D12_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_INPUTS_EX::ppGeometryDescs

union {

D3D12_GPU_VIRTUAL_ADDRESS _NVAPI_D3D12_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_INPUTS_EX::instanceDescs

const NVAPI_D3D12_RAYTRACING_GEOMETRY_DESC_EX * _NVAPI_D3D12_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_INPUTS_EX::pGeometryDescs

const NVAPI_D3D12_RAYTRACING_GEOMETRY_DESC_EX *const * _NVAPI_D3D12_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_INPUTS_EX::ppGeometryDescs

};

NvU32

_NVAPI_GET_RAYTRACING_ACCELERATION_STRUCTURE_PREBUILD_INFO_EX_PARAMS_V1::version

const NVAPI_D3D12_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_INPUTS_EX *

_NVAPI_GET_RAYTRACING_ACCELERATION_STRUCTURE_PREBUILD_INFO_EX_PARAMS_V1::pDesc

D3D12_RAYTRACING_ACCELERATION_STRUCTURE_PREBUILD_INFO *

_NVAPI_GET_RAYTRACING_ACCELERATION_STRUCTURE_PREBUILD_INFO_EX_PARAMS_V1::pInfo

D3D12_GPU_VIRTUAL_ADDRESS

_NVAPI_D3D12_BUILD_RAYTRACING_OPACITY_MICROMAP_ARRAY_DESC::destOpacityMicromapArrayData

NVAPI_D3D12_BUILD_RAYTRACING_OPACITY_MICROMAP_ARRAY_INPUTS

_NVAPI_D3D12_BUILD_RAYTRACING_OPACITY_MICROMAP_ARRAY_DESC::inputs

D3D12_GPU_VIRTUAL_ADDRESS

_NVAPI_D3D12_BUILD_RAYTRACING_OPACITY_MICROMAP_ARRAY_DESC::scratchOpacityMicromapArrayData

NvU64

_NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_ARRAY_POSTBUILD_INFO_CURRENT_SIZE_DESC::currentSizeInBytes

D3D12_GPU_VIRTUAL_ADDRESS

_NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_ARRAY_POSTBUILD_INFO_DESC::destBuffer

NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_ARRAY_POSTBUILD_INFO_TYPE

_NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_ARRAY_POSTBUILD_INFO_DESC::infoType

NvU32

_NVAPI_BUILD_RAYTRACING_OPACITY_MICROMAP_ARRAY_PARAMS_V1::version

const NVAPI_D3D12_BUILD_RAYTRACING_OPACITY_MICROMAP_ARRAY_DESC *

_NVAPI_BUILD_RAYTRACING_OPACITY_MICROMAP_ARRAY_PARAMS_V1::pDesc

NvU32

_NVAPI_BUILD_RAYTRACING_OPACITY_MICROMAP_ARRAY_PARAMS_V1::numPostbuildInfoDescs

const NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_ARRAY_POSTBUILD_INFO_DESC *

_NVAPI_BUILD_RAYTRACING_OPACITY_MICROMAP_ARRAY_PARAMS_V1::pPostbuildInfoDescs

NvU32

_NVAPI_RELOCATE_RAYTRACING_OPACITY_MICROMAP_ARRAY_PARAMS_V1::version

D3D12_GPU_VIRTUAL_ADDRESS

_NVAPI_RELOCATE_RAYTRACING_OPACITY_MICROMAP_ARRAY_PARAMS_V1::opacityMicromapArray

D3D12_GPU_VIRTUAL_ADDRESS

_NVAPI_D3D12_BUILD_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_DESC::destDisplacementMicromapArrayData

NVAPI_D3D12_BUILD_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_INPUTS

_NVAPI_D3D12_BUILD_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_DESC::inputs

D3D12_GPU_VIRTUAL_ADDRESS

_NVAPI_D3D12_BUILD_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_DESC::scratchDisplacementMicromapArrayData

NvU64

_NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_POSTBUILD_INFO_CURRENT_SIZE_DESC::currentSizeInBytes

D3D12_GPU_VIRTUAL_ADDRESS

_NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_POSTBUILD_INFO_DESC::destBuffer

NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_POSTBUILD_INFO_TYPE

_NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_POSTBUILD_INFO_DESC::infoType

NvU32

_NVAPI_BUILD_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PARAMS_V1::version

const NVAPI_D3D12_BUILD_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_DESC *

_NVAPI_BUILD_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PARAMS_V1::pDesc

NvU32

_NVAPI_BUILD_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PARAMS_V1::numPostbuildInfoDescs

const NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_POSTBUILD_INFO_DESC *

_NVAPI_BUILD_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PARAMS_V1::pPostbuildInfoDescs

NvU32

_NVAPI_RELOCATE_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PARAMS_V1::version

D3D12_GPU_VIRTUAL_ADDRESS

_NVAPI_RELOCATE_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PARAMS_V1::displacementMicromapArray

NvU32

_NVAPI_EMIT_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_POSTBUILD_INFO_PARAMS_V1::version

const NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_POSTBUILD_INFO_DESC *

_NVAPI_EMIT_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_POSTBUILD_INFO_PARAMS_V1::pDesc

NvU32

_NVAPI_EMIT_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_POSTBUILD_INFO_PARAMS_V1::numSources

const D3D12_GPU_VIRTUAL_ADDRESS *

_NVAPI_EMIT_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_POSTBUILD_INFO_PARAMS_V1::pSources

NvU32

_NVAPI_EMIT_RAYTRACING_OPACITY_MICROMAP_ARRAY_POSTBUILD_INFO_PARAMS_V1::version

const NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_ARRAY_POSTBUILD_INFO_DESC *

_NVAPI_EMIT_RAYTRACING_OPACITY_MICROMAP_ARRAY_POSTBUILD_INFO_PARAMS_V1::pDesc

NvU32

_NVAPI_EMIT_RAYTRACING_OPACITY_MICROMAP_ARRAY_POSTBUILD_INFO_PARAMS_V1::numSources

const D3D12_GPU_VIRTUAL_ADDRESS *

_NVAPI_EMIT_RAYTRACING_OPACITY_MICROMAP_ARRAY_POSTBUILD_INFO_PARAMS_V1::pSources

D3D12_GPU_VIRTUAL_ADDRESS

_NVAPI_D3D12_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_DESC_EX::destAccelerationStructureData

NVAPI_D3D12_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_INPUTS_EX

_NVAPI_D3D12_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_DESC_EX::inputs

D3D12_GPU_VIRTUAL_ADDRESS

_NVAPI_D3D12_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_DESC_EX::sourceAccelerationStructureData

D3D12_GPU_VIRTUAL_ADDRESS

_NVAPI_D3D12_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_DESC_EX::scratchAccelerationStructureData

NvU32

_NVAPI_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_EX_PARAMS_V1::version

const NVAPI_D3D12_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_DESC_EX *

_NVAPI_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_EX_PARAMS_V1::pDesc

NvU32

_NVAPI_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_EX_PARAMS_V1::numPostbuildInfoDescs

const D3D12_RAYTRACING_ACCELERATION_STRUCTURE_POSTBUILD_INFO_DESC *

_NVAPI_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_EX_PARAMS_V1::pPostbuildInfoDescs

NvU64

_NV_D3D12_WORKSTATION_FEATURE_RDMA_PROPERTIES::rdmaHeapSize

NvU32

_NV_D3D12_WORKSTATION_FEATURE_PROPERTIES::version

NV_D3D12_WORKSTATION_FEATURE_TYPE

_NV_D3D12_WORKSTATION_FEATURE_PROPERTIES::workstationFeatureType

NvBool

_NV_D3D12_WORKSTATION_FEATURE_PROPERTIES::supported

NV_D3D12_WORKSTATION_FEATURE_RDMA_PROPERTIES _NV_D3D12_WORKSTATION_FEATURE_PROPERTIES::rdmaInfo

union {

NV_D3D12_WORKSTATION_FEATURE_RDMA_PROPERTIES _NV_D3D12_WORKSTATION_FEATURE_PROPERTIES::rdmaInfo

};

NvU32

_NVVIOCAPS::version

NvAPI_String

_NVVIOCAPS::adapterName

NvU32

_NVVIOCAPS::adapterClass

NvU32

_NVVIOCAPS::adapterCaps

NvU32

_NVVIOCAPS::dipSwitch

NvU32

_NVVIOCAPS::dipSwitchReserved

NvU32

_NVVIOCAPS::boardID

NvU32 _NVVIOCAPS::majorVersion

NvU32 _NVVIOCAPS::minorVersion

struct {

NvU32 _NVVIOCAPS::majorVersion

NvU32 _NVVIOCAPS::minorVersion

}

_NVVIOCAPS::driver

NvU32 _NVVIOCAPS::majorVersion

NvU32 _NVVIOCAPS::minorVersion

struct {

NvU32 _NVVIOCAPS::majorVersion

NvU32 _NVVIOCAPS::minorVersion

}

_NVVIOCAPS::firmWare

NVVIOOWNERID

_NVVIOCAPS::ownerId

NVVIOOWNERTYPE

_NVVIOCAPS::ownerType

NvU32

_NVVIOCHANNELSTATUS::smpte352

NVVIOSIGNALFORMAT

_NVVIOCHANNELSTATUS::signalFormat

NVVIOBITSPERCOMPONENT

_NVVIOCHANNELSTATUS::bitsPerComponent

NVVIOCOMPONENTSAMPLING

_NVVIOCHANNELSTATUS::samplingFormat

NVVIOCOLORSPACE

_NVVIOCHANNELSTATUS::colorSpace

NVVIOLINKID

_NVVIOCHANNELSTATUS::linkID

NVVIOCHANNELSTATUS

_NVVIOINPUTSTATUS::vidIn [NVAPI_MAX_VIO_JACKS][NVAPI_MAX_VIO_CHANNELS_PER_JACK]

NVVIOCAPTURESTATUS

_NVVIOINPUTSTATUS::captureStatus

NVVIOINPUTOUTPUTSTATUS

_NVVIOOUTPUTSTATUS::vid1Out

NVVIOINPUTOUTPUTSTATUS

_NVVIOOUTPUTSTATUS::vid2Out

NVVIOSYNCSTATUS

_NVVIOOUTPUTSTATUS::sdiSyncIn

NVVIOSYNCSTATUS

_NVVIOOUTPUTSTATUS::compSyncIn

NvU32

_NVVIOOUTPUTSTATUS::syncEnable

NVVIOSYNCSOURCE

_NVVIOOUTPUTSTATUS::syncSource

NVVIOSIGNALFORMAT

_NVVIOOUTPUTSTATUS::syncFormat

NvU32

_NVVIOOUTPUTSTATUS::frameLockEnable

NvU32

_NVVIOOUTPUTSTATUS::outputVideoLocked

NvU32

_NVVIOOUTPUTSTATUS::dataIntegrityCheckErrorCount

NvU32

_NVVIOOUTPUTSTATUS::dataIntegrityCheckEnabled

NvU32

_NVVIOOUTPUTSTATUS::dataIntegrityCheckFailed

NvU32

_NVVIOOUTPUTSTATUS::uSyncSourceLocked

NvU32

_NVVIOOUTPUTSTATUS::uPowerOn

NvU32

_NVVIOSTATUS::version

NVVIOSTATUSTYPE

_NVVIOSTATUS::nvvioStatusType

NVVIOINPUTSTATUS _NVVIOSTATUS::inStatus

NVVIOOUTPUTSTATUS _NVVIOSTATUS::outStatus

union {

NVVIOINPUTSTATUS _NVVIOSTATUS::inStatus

NVVIOOUTPUTSTATUS _NVVIOSTATUS::outStatus

}

_NVVIOSTATUS::vioStatus

NvU32

_NVVIOOUTPUTREGION::x

NvU32

_NVVIOOUTPUTREGION::y

NvU32

_NVVIOOUTPUTREGION::width

NvU32

_NVVIOOUTPUTREGION::height

NvU16

_NVVIOGAMMARAMP8::uRed [256]

NvU16

_NVVIOGAMMARAMP8::uGreen [256]

NvU16

_NVVIOGAMMARAMP8::uBlue [256]

NvU16

_NVVIOGAMMARAMP10::uRed [1024]

NvU16

_NVVIOGAMMARAMP10::uGreen [1024]

NvU16

_NVVIOGAMMARAMP10::uBlue [1024]

NvU32

_NVVIOSYNCDELAY::version

NvU32

_NVVIOSYNCDELAY::horizontalDelay

NvU32

_NVVIOSYNCDELAY::verticalDelay

NvU32

_NVVIOVIDEOMODE::horizontalPixels

NvU32

_NVVIOVIDEOMODE::verticalLines

float

_NVVIOVIDEOMODE::fFrameRate

NVVIOINTERLACEMODE

_NVVIOVIDEOMODE::interlaceMode

NVVIOVIDEOSTANDARD

_NVVIOVIDEOMODE::videoStandard

NVVIOVIDEOTYPE

_NVVIOVIDEOMODE::videoType

NVVIOSIGNALFORMAT

_NVVIOSIGNALFORMATDETAIL::signalFormat

NVVIOVIDEOMODE

_NVVIOSIGNALFORMATDETAIL::videoMode

NVVIODATAFORMAT

_NVVIODATAFORMATDETAIL::dataFormat

NvU32

_NVVIODATAFORMATDETAIL::vioCaps

NvU32

_NVVIOCOLORCONVERSION::version

float

_NVVIOCOLORCONVERSION::colorMatrix [3][3]

float

_NVVIOCOLORCONVERSION::colorOffset [3]

float

_NVVIOCOLORCONVERSION::colorScale [3]

NvU32

_NVVIOCOLORCONVERSION::compositeSafe

NvU32

_NVVIOGAMMACORRECTION::version

NvU32

_NVVIOGAMMACORRECTION::vioGammaCorrectionType

NVVIOGAMMARAMP8 _NVVIOGAMMACORRECTION::gammaRamp8

NVVIOGAMMARAMP10 _NVVIOGAMMACORRECTION::gammaRamp10

union {

NVVIOGAMMARAMP8 _NVVIOGAMMACORRECTION::gammaRamp8

NVVIOGAMMARAMP10 _NVVIOGAMMACORRECTION::gammaRamp10

}

_NVVIOGAMMACORRECTION::gammaRamp

float

_NVVIOGAMMACORRECTION::fGammaValueR

float

_NVVIOGAMMACORRECTION::fGammaValueG

float

_NVVIOGAMMACORRECTION::fGammaValueB

NvU32

_NVVIOCOMPOSITERANGE::uRange

NvU32

_NVVIOCOMPOSITERANGE::uEnabled

NvU32

_NVVIOCOMPOSITERANGE::uMin

NvU32

_NVVIOCOMPOSITERANGE::uMax

NVVIOSIGNALFORMAT

_NVVIOOUTPUTCONFIG_V1::signalFormat

NVVIODATAFORMAT

_NVVIOOUTPUTCONFIG_V1::dataFormat

NVVIOOUTPUTREGION

_NVVIOOUTPUTCONFIG_V1::outputRegion

NVVIOOUTPUTAREA

_NVVIOOUTPUTCONFIG_V1::outputArea

NVVIOCOLORCONVERSION

_NVVIOOUTPUTCONFIG_V1::colorConversion

NVVIOGAMMACORRECTION

_NVVIOOUTPUTCONFIG_V1::gammaCorrection

NvU32

_NVVIOOUTPUTCONFIG_V1::syncEnable

NVVIOSYNCSOURCE

_NVVIOOUTPUTCONFIG_V1::syncSource

NVVIOSYNCDELAY

_NVVIOOUTPUTCONFIG_V1::syncDelay

NVVIOCOMPSYNCTYPE

_NVVIOOUTPUTCONFIG_V1::compositeSyncType

NvU32

_NVVIOOUTPUTCONFIG_V1::frameLockEnable

NvU32

_NVVIOOUTPUTCONFIG_V1::psfSignalFormat

NvU32

_NVVIOOUTPUTCONFIG_V1::enable422Filter

NvU32

_NVVIOOUTPUTCONFIG_V1::compositeTerminate

NvU32

_NVVIOOUTPUTCONFIG_V1::enableDataIntegrityCheck

NvU32

_NVVIOOUTPUTCONFIG_V1::cscOverride

NvU32

_NVVIOOUTPUTCONFIG_V1::flipQueueLength

NvU32

_NVVIOOUTPUTCONFIG_V1::enableANCTimeCodeGeneration

NvU32

_NVVIOOUTPUTCONFIG_V1::enableComposite

NvU32

_NVVIOOUTPUTCONFIG_V1::enableAlphaKeyComposite

NVVIOCOMPOSITERANGE

_NVVIOOUTPUTCONFIG_V1::compRange

NvU8

_NVVIOOUTPUTCONFIG_V1::reservedData [256]

NvU32

_NVVIOOUTPUTCONFIG_V1::enableFullColorRange

NvU32

_NVVIOOUTPUTCONFIG_V1::enableRGBData

NVVIOSIGNALFORMAT

_NVVIOOUTPUTCONFIG_V2::signalFormat

NVVIODATAFORMAT

_NVVIOOUTPUTCONFIG_V2::dataFormat

NVVIOOUTPUTREGION

_NVVIOOUTPUTCONFIG_V2::outputRegion

NVVIOOUTPUTAREA

_NVVIOOUTPUTCONFIG_V2::outputArea

NVVIOCOLORCONVERSION

_NVVIOOUTPUTCONFIG_V2::colorConversion

NVVIOGAMMACORRECTION

_NVVIOOUTPUTCONFIG_V2::gammaCorrection

NvU32

_NVVIOOUTPUTCONFIG_V2::syncEnable

NVVIOSYNCSOURCE

_NVVIOOUTPUTCONFIG_V2::syncSource

NVVIOSYNCDELAY

_NVVIOOUTPUTCONFIG_V2::syncDelay

NVVIOCOMPSYNCTYPE

_NVVIOOUTPUTCONFIG_V2::compositeSyncType

NvU32

_NVVIOOUTPUTCONFIG_V2::frameLockEnable

NvU32

_NVVIOOUTPUTCONFIG_V2::psfSignalFormat

NvU32

_NVVIOOUTPUTCONFIG_V2::enable422Filter

NvU32

_NVVIOOUTPUTCONFIG_V2::compositeTerminate

NvU32

_NVVIOOUTPUTCONFIG_V2::enableDataIntegrityCheck

NvU32

_NVVIOOUTPUTCONFIG_V2::cscOverride

NvU32

_NVVIOOUTPUTCONFIG_V2::flipQueueLength

NvU32

_NVVIOOUTPUTCONFIG_V2::enableANCTimeCodeGeneration

NvU32

_NVVIOOUTPUTCONFIG_V2::enableComposite

NvU32

_NVVIOOUTPUTCONFIG_V2::enableAlphaKeyComposite

NVVIOCOMPOSITERANGE

_NVVIOOUTPUTCONFIG_V2::compRange

NvU8

_NVVIOOUTPUTCONFIG_V2::reservedData [256]

NvU32

_NVVIOOUTPUTCONFIG_V2::enableFullColorRange

NvU32

_NVVIOOUTPUTCONFIG_V2::enableRGBData

NVVIOANCPARITYCOMPUTATION

_NVVIOOUTPUTCONFIG_V2::ancParityComputation

NVVIOSIGNALFORMAT

_NVVIOOUTPUTCONFIG_V3::signalFormat

NVVIODATAFORMAT

_NVVIOOUTPUTCONFIG_V3::dataFormat

NVVIOOUTPUTREGION

_NVVIOOUTPUTCONFIG_V3::outputRegion

NVVIOOUTPUTAREA

_NVVIOOUTPUTCONFIG_V3::outputArea

NVVIOCOLORCONVERSION

_NVVIOOUTPUTCONFIG_V3::colorConversion

NVVIOGAMMACORRECTION

_NVVIOOUTPUTCONFIG_V3::gammaCorrection

NvU32

_NVVIOOUTPUTCONFIG_V3::syncEnable

NVVIOSYNCSOURCE

_NVVIOOUTPUTCONFIG_V3::syncSource

NVVIOSYNCDELAY

_NVVIOOUTPUTCONFIG_V3::syncDelay

NVVIOCOMPSYNCTYPE

_NVVIOOUTPUTCONFIG_V3::compositeSyncType

NvU32

_NVVIOOUTPUTCONFIG_V3::frameLockEnable

NvU32

_NVVIOOUTPUTCONFIG_V3::psfSignalFormat

NvU32

_NVVIOOUTPUTCONFIG_V3::enable422Filter

NvU32

_NVVIOOUTPUTCONFIG_V3::compositeTerminate

NvU32

_NVVIOOUTPUTCONFIG_V3::enableDataIntegrityCheck

NvU32

_NVVIOOUTPUTCONFIG_V3::cscOverride

NvU32

_NVVIOOUTPUTCONFIG_V3::flipQueueLength

NvU32

_NVVIOOUTPUTCONFIG_V3::enableANCTimeCodeGeneration

NvU32

_NVVIOOUTPUTCONFIG_V3::enableComposite

NvU32

_NVVIOOUTPUTCONFIG_V3::enableAlphaKeyComposite

NVVIOCOMPOSITERANGE

_NVVIOOUTPUTCONFIG_V3::compRange

NvU8

_NVVIOOUTPUTCONFIG_V3::reservedData [256]

NvU32

_NVVIOOUTPUTCONFIG_V3::enableFullColorRange

NvU32

_NVVIOOUTPUTCONFIG_V3::enableRGBData

NVVIOANCPARITYCOMPUTATION

_NVVIOOUTPUTCONFIG_V3::ancParityComputation

NvU32

_NVVIOOUTPUTCONFIG_V3::enableAudioBlanking

NvU32

_NVVIOSTREAM::bitsPerComponent

NVVIOCOMPONENTSAMPLING

_NVVIOSTREAM::sampling

NvU32

_NVVIOSTREAM::expansionEnable

NvU32

_NVVIOSTREAM::numLinks

NvU32 _NVVIOSTREAM::jack

NvU32 _NVVIOSTREAM::channel

struct {

NvU32 _NVVIOSTREAM::jack

NvU32 _NVVIOSTREAM::channel

}

_NVVIOSTREAM::links [NVAPI_MAX_VIO_LINKS_PER_STREAM]

NvU32

_NVVIOINPUTCONFIG::numRawCaptureImages

NVVIOSIGNALFORMAT

_NVVIOINPUTCONFIG::signalFormat

NvU32

_NVVIOINPUTCONFIG::numStreams

NVVIOSTREAM

_NVVIOINPUTCONFIG::streams [NVAPI_MAX_VIO_STREAMS]

NvU32

_NVVIOINPUTCONFIG::bTestMode

NvU32

_NVVIOCONFIG_V1::version

NvU32

_NVVIOCONFIG_V1::fields

NVVIOCONFIGTYPE

_NVVIOCONFIG_V1::nvvioConfigType

NVVIOINPUTCONFIG _NVVIOCONFIG_V1::inConfig

NVVIOOUTPUTCONFIG_V1 _NVVIOCONFIG_V1::outConfig

union {

NVVIOINPUTCONFIG _NVVIOCONFIG_V1::inConfig

NVVIOOUTPUTCONFIG_V1 _NVVIOCONFIG_V1::outConfig

}

_NVVIOCONFIG_V1::vioConfig

NvU32

_NVVIOCONFIG_V2::version

NvU32

_NVVIOCONFIG_V2::fields

NVVIOCONFIGTYPE

_NVVIOCONFIG_V2::nvvioConfigType

NVVIOINPUTCONFIG _NVVIOCONFIG_V2::inConfig

NVVIOOUTPUTCONFIG_V2 _NVVIOCONFIG_V2::outConfig

union {

NVVIOINPUTCONFIG _NVVIOCONFIG_V2::inConfig

NVVIOOUTPUTCONFIG_V2 _NVVIOCONFIG_V2::outConfig

}

_NVVIOCONFIG_V2::vioConfig

NvU32

_NVVIOCONFIG_V3::version

NvU32

_NVVIOCONFIG_V3::fields

NVVIOCONFIGTYPE

_NVVIOCONFIG_V3::nvvioConfigType

NVVIOINPUTCONFIG _NVVIOCONFIG_V3::inConfig

NVVIOOUTPUTCONFIG_V3 _NVVIOCONFIG_V3::outConfig

union {

NVVIOINPUTCONFIG _NVVIOCONFIG_V3::inConfig

NVVIOOUTPUTCONFIG_V3 _NVVIOCONFIG_V3::outConfig

}

_NVVIOCONFIG_V3::vioConfig

NvPhysicalGpuHandle

NVVIOTOPOLOGYTARGET::hPhysicalGpu

NvVioHandle

NVVIOTOPOLOGYTARGET::hVioHandle

NvU32

NVVIOTOPOLOGYTARGET::vioId

NvU32

NVVIOTOPOLOGYTARGET::outputId

NvU32

_NV_VIO_TOPOLOGY::version

NvU32

_NV_VIO_TOPOLOGY::vioTotalDeviceCount

NVVIOTOPOLOGYTARGET

_NV_VIO_TOPOLOGY::vioTarget [NVAPI_MAX_VIO_DEVICES]

NVVIOCAPS *

pAdapterCaps

NvU32

vioClass

NvU32 NVVIOOWNERTYPE

ownerType

NvU32

bRelease

NvU32 *

pWait

NVVIOCONFIG *

pConfig

NVVIOCOLORCONVERSION *

pCSC

NVVIOGAMMACORRECTION *

pGamma

const NVVIOSYNCDELAY *

pSyncDelay

NvU32

_NVVIOPCIINFO::version

NvU32

_NVVIOPCIINFO::pciDeviceId

NvU32

_NVVIOPCIINFO::pciSubSystemId

NvU32

_NVVIOPCIINFO::pciRevisionId

NvU32

_NVVIOPCIINFO::pciDomain

NvU32

_NVVIOPCIINFO::pciBus

NvU32

_NVVIOPCIINFO::pciSlot

NVVIOPCILINKWIDTH

_NVVIOPCIINFO::pciLinkWidth

NVVIOPCILINKRATE

_NVVIOPCIINFO::pciLinkRate

__inout NVVIOPCIINFO *

pVioPCIInfo

NvU32

srcEnumIndex

NvU32 NvU32

destEnumIndex

NvU32 NvU32 NvU32 *

pbCompatible

NvU32 *

vioDeviceCount

NvU32

enumIndex

NvU32 NVVIOSIGNALFORMATDETAIL *

pSignalFormatDetail

NvU32 NVVIODATAFORMATDETAIL *

pDataFormatDetail

NvU32

_NVAPI_STEREO_CAPS::version

NvU32

_NVAPI_STEREO_CAPS::supportsWindowedModeOff: 1

NvU32

_NVAPI_STEREO_CAPS::supportsWindowedModeAutomatic: 1

NvU32

_NVAPI_STEREO_CAPS::supportsWindowedModePersistent: 1

NvU32

_NVAPI_STEREO_CAPS::reserved: 29

NvU32

_NVAPI_STEREO_CAPS::reserved2 [3]

NvU32

_NVDRS_GPU_SUPPORT::geforce: 1

NvU32

_NVDRS_GPU_SUPPORT::quadro: 1

NvU32

_NVDRS_GPU_SUPPORT::nvs: 1

NvU32

_NVDRS_GPU_SUPPORT::reserved4: 1

NvU32

_NVDRS_GPU_SUPPORT::reserved5: 1

NvU32

_NVDRS_GPU_SUPPORT::reserved6: 1

NvU32

_NVDRS_GPU_SUPPORT::reserved7: 1

NvU32

_NVDRS_GPU_SUPPORT::reserved8: 1

NvU32

_NVDRS_GPU_SUPPORT::reserved9: 1

NvU32

_NVDRS_GPU_SUPPORT::reserved10: 1

NvU32

_NVDRS_GPU_SUPPORT::reserved11: 1

NvU32

_NVDRS_GPU_SUPPORT::reserved12: 1

NvU32

_NVDRS_GPU_SUPPORT::reserved13: 1

NvU32

_NVDRS_GPU_SUPPORT::reserved14: 1

NvU32

_NVDRS_GPU_SUPPORT::reserved15: 1

NvU32

_NVDRS_GPU_SUPPORT::reserved16: 1

NvU32

_NVDRS_GPU_SUPPORT::reserved17: 1

NvU32

_NVDRS_GPU_SUPPORT::reserved18: 1

NvU32

_NVDRS_GPU_SUPPORT::reserved19: 1

NvU32

_NVDRS_GPU_SUPPORT::reserved20: 1

NvU32

_NVDRS_GPU_SUPPORT::reserved21: 1

NvU32

_NVDRS_GPU_SUPPORT::reserved22: 1

NvU32

_NVDRS_GPU_SUPPORT::reserved23: 1

NvU32

_NVDRS_GPU_SUPPORT::reserved24: 1

NvU32

_NVDRS_GPU_SUPPORT::reserved25: 1

NvU32

_NVDRS_GPU_SUPPORT::reserved26: 1

NvU32

_NVDRS_GPU_SUPPORT::reserved27: 1

NvU32

_NVDRS_GPU_SUPPORT::reserved28: 1

NvU32

_NVDRS_GPU_SUPPORT::reserved29: 1

NvU32

_NVDRS_GPU_SUPPORT::reserved30: 1

NvU32

_NVDRS_GPU_SUPPORT::reserved31: 1

NvU32

_NVDRS_GPU_SUPPORT::reserved32: 1

NvU32

_NVDRS_BINARY_SETTING::valueLength

NvU8

_NVDRS_BINARY_SETTING::valueData [NVAPI_BINARY_DATA_MAX]

NvU32

_NVDRS_SETTING_VALUES::version

NvU32

_NVDRS_SETTING_VALUES::numSettingValues

NVDRS_SETTING_TYPE

_NVDRS_SETTING_VALUES::settingType

NvU32 _NVDRS_SETTING_VALUES::u32DefaultValue

NVDRS_BINARY_SETTING _NVDRS_SETTING_VALUES::binaryDefaultValue

NvAPI_UnicodeString _NVDRS_SETTING_VALUES::wszDefaultValue

union {

NvU32 _NVDRS_SETTING_VALUES::u32DefaultValue

NVDRS_BINARY_SETTING _NVDRS_SETTING_VALUES::binaryDefaultValue

NvAPI_UnicodeString _NVDRS_SETTING_VALUES::wszDefaultValue

};

NvU32 _NVDRS_SETTING_VALUES::u32Value

NVDRS_BINARY_SETTING _NVDRS_SETTING_VALUES::binaryValue

NvAPI_UnicodeString _NVDRS_SETTING_VALUES::wszValue

union {

NvU32 _NVDRS_SETTING_VALUES::u32Value

NVDRS_BINARY_SETTING _NVDRS_SETTING_VALUES::binaryValue

NvAPI_UnicodeString _NVDRS_SETTING_VALUES::wszValue

}

_NVDRS_SETTING_VALUES::settingValues [NVAPI_SETTING_MAX_VALUES]

NvU32

_NVDRS_SETTING_V1::version

NvAPI_UnicodeString

_NVDRS_SETTING_V1::settingName

NvU32

_NVDRS_SETTING_V1::settingId

NVDRS_SETTING_TYPE

_NVDRS_SETTING_V1::settingType

NVDRS_SETTING_LOCATION

_NVDRS_SETTING_V1::settingLocation

NvU32

_NVDRS_SETTING_V1::isCurrentPredefined

NvU32

_NVDRS_SETTING_V1::isPredefinedValid

NvU32 _NVDRS_SETTING_V1::u32PredefinedValue

NVDRS_BINARY_SETTING _NVDRS_SETTING_V1::binaryPredefinedValue

NvAPI_UnicodeString _NVDRS_SETTING_V1::wszPredefinedValue

union {

NvU32 _NVDRS_SETTING_V1::u32PredefinedValue

NVDRS_BINARY_SETTING _NVDRS_SETTING_V1::binaryPredefinedValue

NvAPI_UnicodeString _NVDRS_SETTING_V1::wszPredefinedValue

};

NvU32 _NVDRS_SETTING_V1::u32CurrentValue

NVDRS_BINARY_SETTING _NVDRS_SETTING_V1::binaryCurrentValue

NvAPI_UnicodeString _NVDRS_SETTING_V1::wszCurrentValue

union {

NvU32 _NVDRS_SETTING_V1::u32CurrentValue

NVDRS_BINARY_SETTING _NVDRS_SETTING_V1::binaryCurrentValue

NvAPI_UnicodeString _NVDRS_SETTING_V1::wszCurrentValue

};

NvU32

_NVDRS_APPLICATION_V1::version

NvU32

_NVDRS_APPLICATION_V1::isPredefined

NvAPI_UnicodeString

_NVDRS_APPLICATION_V1::appName

NvAPI_UnicodeString

_NVDRS_APPLICATION_V1::userFriendlyName

NvAPI_UnicodeString

_NVDRS_APPLICATION_V1::launcher

NvU32

_NVDRS_APPLICATION_V2::version

NvU32

_NVDRS_APPLICATION_V2::isPredefined

NvAPI_UnicodeString

_NVDRS_APPLICATION_V2::appName

NvAPI_UnicodeString

_NVDRS_APPLICATION_V2::userFriendlyName

NvAPI_UnicodeString

_NVDRS_APPLICATION_V2::launcher

NvAPI_UnicodeString

_NVDRS_APPLICATION_V2::fileInFolder

NvU32

_NVDRS_APPLICATION_V3::version

NvU32

_NVDRS_APPLICATION_V3::isPredefined

NvAPI_UnicodeString

_NVDRS_APPLICATION_V3::appName

NvAPI_UnicodeString

_NVDRS_APPLICATION_V3::userFriendlyName

NvAPI_UnicodeString

_NVDRS_APPLICATION_V3::launcher

NvAPI_UnicodeString

_NVDRS_APPLICATION_V3::fileInFolder

NvU32

_NVDRS_APPLICATION_V3::isMetro:1

NvU32

_NVDRS_APPLICATION_V3::isCommandLine:1

NvU32

_NVDRS_APPLICATION_V3::reserved:30

NvU32

_NVDRS_APPLICATION_V4::version

NvU32

_NVDRS_APPLICATION_V4::isPredefined

NvAPI_UnicodeString

_NVDRS_APPLICATION_V4::appName

NvAPI_UnicodeString

_NVDRS_APPLICATION_V4::userFriendlyName

NvAPI_UnicodeString

_NVDRS_APPLICATION_V4::launcher

NvAPI_UnicodeString

_NVDRS_APPLICATION_V4::fileInFolder

NvU32

_NVDRS_APPLICATION_V4::isMetro:1

NvU32

_NVDRS_APPLICATION_V4::isCommandLine:1

NvU32

_NVDRS_APPLICATION_V4::reserved:30

NvAPI_UnicodeString

_NVDRS_APPLICATION_V4::commandLine

NvU32

_NVDRS_PROFILE_V1::version

NvAPI_UnicodeString

_NVDRS_PROFILE_V1::profileName

NVDRS_GPU_SUPPORT

_NVDRS_PROFILE_V1::gpuSupport

NvU32

_NVDRS_PROFILE_V1::isPredefined

NvU32

_NVDRS_PROFILE_V1::numOfApps

NvU32

_NVDRS_PROFILE_V1::numOfSettings

NvU32

NV_CHIPSET_INFO_v4::version

NvU32

NV_CHIPSET_INFO_v4::vendorId

NvU32

NV_CHIPSET_INFO_v4::deviceId

NvAPI_ShortString

NV_CHIPSET_INFO_v4::szVendorName

NvAPI_ShortString

NV_CHIPSET_INFO_v4::szChipsetName

NvU32

NV_CHIPSET_INFO_v4::flags

NvU32

NV_CHIPSET_INFO_v4::subSysVendorId

NvU32

NV_CHIPSET_INFO_v4::subSysDeviceId

NvAPI_ShortString

NV_CHIPSET_INFO_v4::szSubSysVendorName

NvU32

NV_CHIPSET_INFO_v4::HBvendorId

NvU32

NV_CHIPSET_INFO_v4::HBdeviceId

NvU32

NV_CHIPSET_INFO_v4::HBsubSysVendorId

NvU32

NV_CHIPSET_INFO_v4::HBsubSysDeviceId

NvU32

NV_CHIPSET_INFO_v3::version

NvU32

NV_CHIPSET_INFO_v3::vendorId

NvU32

NV_CHIPSET_INFO_v3::deviceId

NvAPI_ShortString

NV_CHIPSET_INFO_v3::szVendorName

NvAPI_ShortString

NV_CHIPSET_INFO_v3::szChipsetName

NvU32

NV_CHIPSET_INFO_v3::flags

NvU32

NV_CHIPSET_INFO_v3::subSysVendorId

NvU32

NV_CHIPSET_INFO_v3::subSysDeviceId

NvAPI_ShortString

NV_CHIPSET_INFO_v3::szSubSysVendorName

NvU32

NV_CHIPSET_INFO_v2::version

NvU32

NV_CHIPSET_INFO_v2::vendorId

NvU32

NV_CHIPSET_INFO_v2::deviceId

NvAPI_ShortString

NV_CHIPSET_INFO_v2::szVendorName

NvAPI_ShortString

NV_CHIPSET_INFO_v2::szChipsetName

NvU32

NV_CHIPSET_INFO_v2::flags

NvU32

NV_CHIPSET_INFO_v1::version

NvU32

NV_CHIPSET_INFO_v1::vendorId

NvU32

NV_CHIPSET_INFO_v1::deviceId

NvAPI_ShortString

NV_CHIPSET_INFO_v1::szVendorName

NvAPI_ShortString

NV_CHIPSET_INFO_v1::szChipsetName

NvU32

NV_LID_DOCK_PARAMS::version

NvU32

NV_LID_DOCK_PARAMS::currentLidState

NvU32

NV_LID_DOCK_PARAMS::currentDockState

NvU32

NV_LID_DOCK_PARAMS::currentLidPolicy

NvU32

NV_LID_DOCK_PARAMS::currentDockPolicy

NvU32

NV_LID_DOCK_PARAMS::forcedLidMechanismPresent

NvU32

NV_LID_DOCK_PARAMS::forcedDockMechanismPresent

NvU32

_NV_DISPLAY_DRIVER_INFO::version

NvU32

_NV_DISPLAY_DRIVER_INFO::driverVersion

NvAPI_ShortString

_NV_DISPLAY_DRIVER_INFO::szBuildBranch

NvU32

_NV_DISPLAY_DRIVER_INFO::bIsDCHDriver: 1

NvU32

_NV_DISPLAY_DRIVER_INFO::bIsNVIDIAStudioPackage: 1

NvU32

_NV_DISPLAY_DRIVER_INFO::bIsNVIDIAGameReadyPackage: 1

NvU32

_NV_DISPLAY_DRIVER_INFO::bIsNVIDIARTXProductionBranchPackage: 1

NvU32

_NV_DISPLAY_DRIVER_INFO::bIsNVIDIARTXNewFeatureBranchPackage: 1

NvU32

_NV_DISPLAY_DRIVER_INFO::reserved: 27

NvU32

_NV_DISPLAY_DRIVER_INFO_V2::version

NvU32

_NV_DISPLAY_DRIVER_INFO_V2::driverVersion

NvAPI_ShortString

_NV_DISPLAY_DRIVER_INFO_V2::szBuildBranch

NvU32

_NV_DISPLAY_DRIVER_INFO_V2::bIsDCHDriver: 1

NvU32

_NV_DISPLAY_DRIVER_INFO_V2::bIsNVIDIAStudioPackage: 1

NvU32

_NV_DISPLAY_DRIVER_INFO_V2::bIsNVIDIAGameReadyPackage: 1

NvU32

_NV_DISPLAY_DRIVER_INFO_V2::bIsNVIDIARTXProductionBranchPackage: 1

NvU32

_NV_DISPLAY_DRIVER_INFO_V2::bIsNVIDIARTXNewFeatureBranchPackage: 1

NvU32

_NV_DISPLAY_DRIVER_INFO_V2::reserved: 27

NvAPI_ShortString

_NV_DISPLAY_DRIVER_INFO_V2::szBuildBaseBranch

NvU32

_NV_DISPLAY_DRIVER_INFO_V2::reservedEx

NvPhysicalGpuHandle

_NV_PHYSICAL_GPU_HANDLE_DATA::hPhysicalGpu

NV_ADAPTER_TYPE

_NV_PHYSICAL_GPU_HANDLE_DATA::adapterType

NvU32

_NV_PHYSICAL_GPU_HANDLE_DATA::reserved2 [4]

NvU32

_NV_PHYSICAL_GPUS::version

NV_PHYSICAL_GPU_HANDLE_DATA

_NV_PHYSICAL_GPUS::gpuHandleData [NVAPI_MAX_PHYSICAL_GPUS]

NvU32

_NV_PHYSICAL_GPUS::gpuHandleCount

NvU32

_NV_PHYSICAL_GPUS::reserved [4]

NvLogicalGpuHandle

_NV_LOGICAL_GPU_HANDLE_DATA::hLogicalGpu

NV_ADAPTER_TYPE

_NV_LOGICAL_GPU_HANDLE_DATA::adapterType

NvU32

_NV_LOGICAL_GPU_HANDLE_DATA::reserved [4]

NvU32

_NV_LOGICAL_GPUS::version

NV_LOGICAL_GPU_HANDLE_DATA

_NV_LOGICAL_GPUS::gpuHandleData [NVAPI_MAX_LOGICAL_GPUS]

NvU32

_NV_LOGICAL_GPUS::gpuHandleCount

NvU32

_NV_LOGICAL_GPUS::reserved [4]

void *

_NV_CLIENT_CALLBACK_SETTINGS_SUPER_V1::pCallbackParam

NvU8

_NV_CLIENT_CALLBACK_SETTINGS_SUPER_V1::rsvd [64]

NV_GPU_CLIENT_CALLBACK_SETTINGS_SUPER_V1

_NV_GPU_CLIENT_PERIODIC_CALLBACK_SETTINGS_SUPER_V1::super

NvU32

_NV_GPU_CLIENT_PERIODIC_CALLBACK_SETTINGS_SUPER_V1::callbackPeriodms

NvU8

_NV_GPU_CLIENT_PERIODIC_CALLBACK_SETTINGS_SUPER_V1::rsvd [64]

void *

_NV_GPU_CLIENT_CALLBACK_DATA_SUPER_V1::pCallbackParam

NvU8

_NV_GPU_CLIENT_CALLBACK_DATA_SUPER_V1::rsvd [64]

NV_GPU_CLIENT_UTIL_DOMAIN_ID

_NV_GPU_CLIENT_UTILIZATION_DATA_V1::utilId

NvU32

_NV_GPU_CLIENT_UTILIZATION_DATA_V1::utilizationPercent

NvU8

_NV_GPU_CLIENT_UTILIZATION_DATA_V1::rsvd [61]

NV_GPU_CLIENT_CALLBACK_DATA_SUPER_V1

_NV_GPU_CLIENT_CALLBACK_UTILIZATION_DATA_V1::super

NvU32

_NV_GPU_CLIENT_CALLBACK_UTILIZATION_DATA_V1::numUtils

NvU64

_NV_GPU_CLIENT_CALLBACK_UTILIZATION_DATA_V1::timestamp

NvU8

_NV_GPU_CLIENT_CALLBACK_UTILIZATION_DATA_V1::rsvd [64]

NV_GPU_CLIENT_UTILIZATION_DATA_V1

_NV_GPU_CLIENT_CALLBACK_UTILIZATION_DATA_V1::utils [NV_GPU_CLIENT_UTIL_DOMAINS_MAX_V1]

NvU32

_NV_GPU_CLIENT_UTILIZATION_PERIODIC_CALLBACK_SETTINGS_V1::version

NV_GPU_CLIENT_PERIODIC_CALLBACK_SETTINGS_SUPER_V1

_NV_GPU_CLIENT_UTILIZATION_PERIODIC_CALLBACK_SETTINGS_V1::super

NV_GPU_CLIENT_UTILIZATION_PERIODIC_CALLBACK_V1

_NV_GPU_CLIENT_UTILIZATION_PERIODIC_CALLBACK_SETTINGS_V1::callback

NvU8

_NV_GPU_CLIENT_UTILIZATION_PERIODIC_CALLBACK_SETTINGS_V1::rsvd [64]

Detailed Description

Function: NvAPI_VIO_GetCapabilities

Description: This API determine the graphics adapter video I/O capabilities.

Since

Release: 190

Parameters

[in]

NvVioHandle

The caller provides the SDI device handle as input.

[out]

pAdapterCaps

Pointer to receive capabilities

Return values

:

NVAPI_NOT_SUPPORTED API is not supported

Macro Definition Documentation

◆ MAX_NUM_COMPOSITE_RANGE

#define MAX_NUM_COMPOSITE_RANGE 2

Maximum number of ranges per channel.

◆ NV_DISPLAY_DRIVER_INFO_VER

#define NV_DISPLAY_DRIVER_INFO_VER NV_DISPLAY_DRIVER_INFO_VER2

◆ NV_DISPLAY_DRIVER_INFO_VER1

#define NV_DISPLAY_DRIVER_INFO_VER1 MAKE_NVAPI_VERSION(NV_DISPLAY_DRIVER_INFO_V1, 1)

◆ NV_DISPLAY_DRIVER_INFO_VER2

#define NV_DISPLAY_DRIVER_INFO_VER2 MAKE_NVAPI_VERSION(NV_DISPLAY_DRIVER_INFO_V2, 2)

◆ NV_GPU_CLIENT_UTIL_DOMAINS_MAX_V1

#define NV_GPU_CLIENT_UTIL_DOMAINS_MAX_V1 (4)

◆ NV_GPU_CLIENT_UTILIZATION_PERIODIC_CALLBACK_SETTINGS_VER

#define NV_GPU_CLIENT_UTILIZATION_PERIODIC_CALLBACK_SETTINGS_VER NV_GPU_CLIENT_UTILIZATION_PERIODIC_CALLBACK_SETTINGS_VER1

◆ NV_GPU_CLIENT_UTILIZATION_PERIODIC_CALLBACK_SETTINGS_VER1

#define NV_GPU_CLIENT_UTILIZATION_PERIODIC_CALLBACK_SETTINGS_VER1 MAKE_NVAPI_VERSION(NV_GPU_CLIENT_UTILIZATION_PERIODIC_CALLBACK_SETTINGS_V1, 1)

◆ NV_LID_DOCK_PARAMS_VER

#define NV_LID_DOCK_PARAMS_VER MAKE_NVAPI_VERSION(NV_LID_DOCK_PARAMS,1)

ingroup sysgeneral

◆ NV_LOGICAL_GPUS_VER

#define NV_LOGICAL_GPUS_VER NV_LOGICAL_GPUS_VER1

◆ NV_LOGICAL_GPUS_VER1

#define NV_LOGICAL_GPUS_VER1 MAKE_NVAPI_VERSION(NV_LOGICAL_GPUS_V1, 1)

◆ NV_PHYSICAL_GPUS_VER

#define NV_PHYSICAL_GPUS_VER NV_PHYSICAL_GPUS_VER1

◆ NV_PHYSICAL_GPUS_VER1

#define NV_PHYSICAL_GPUS_VER1 MAKE_NVAPI_VERSION(NV_PHYSICAL_GPUS_V1, 1)

◆ NV_VIO_TOPOLOGY_VER

#define NV_VIO_TOPOLOGY_VER MAKE_NVAPI_VERSION(NV_VIO_TOPOLOGY,1)

Macro for constructing the version field of NV_VIO_TOPOLOGY.

◆ NVAPI_GVI_DEFAULT_RAW_CAPTURE_IMAGES

#define NVAPI_GVI_DEFAULT_RAW_CAPTURE_IMAGES 5

Default number of capture images.

◆ NVAPI_GVI_MAX_RAW_CAPTURE_IMAGES

#define NVAPI_GVI_MAX_RAW_CAPTURE_IMAGES 32

Max number of capture images

◆ NVAPI_GVI_MIN_RAW_CAPTURE_IMAGES

#define NVAPI_GVI_MIN_RAW_CAPTURE_IMAGES 1

Min number of capture images.

◆ NVAPI_MAX_FRAMELOCK_MAPPING_MODES

#define NVAPI_MAX_FRAMELOCK_MAPPING_MODES 20

◆ NVAPI_MAX_VIO_CHANNELS_PER_JACK

#define NVAPI_MAX_VIO_CHANNELS_PER_JACK 2

Each physical jack an on SDI input card can have two "channels" in the case of "3G" VideoFormats, as specified by SMPTE 425; for non-3G VideoFormats, only the first channel within a physical jack is valid.

◆ NVAPI_MAX_VIO_DEVICES

#define NVAPI_MAX_VIO_DEVICES 8

Assumption, maximum 4 SDI input and 4 SDI output cards supported on a system.

◆ NVAPI_MAX_VIO_JACKS

#define NVAPI_MAX_VIO_JACKS 4

4 physical jacks supported on each SDI input card.

◆ NVAPI_MAX_VIO_LINKS_PER_STREAM

#define NVAPI_MAX_VIO_LINKS_PER_STREAM 2

SDI input supports a max of 2 links per stream.

◆ NVAPI_MAX_VIO_STREAMS

#define NVAPI_MAX_VIO_STREAMS 4

4 Streams, 1 per physical jack

◆ NVAPI_MIN_VIO_STREAMS

#define NVAPI_MIN_VIO_STREAMS 1

◆ NVVIO_O_READ

#define NVVIO_O_READ 0x00000000

Read access (not applicable for video output)

◆ NVVIO_O_WRITE_EXCLUSIVE

#define NVVIO_O_WRITE_EXCLUSIVE 0x00010001

Write exclusive access (not applicable for video input)

◆ NVVIO_OWNERID_EXCLUSIVE

#define NVVIO_OWNERID_EXCLUSIVE 0x40000000

VIO_DATA.ulOwnerID next-bit is set only if device is currently in exclusive write access mode from NvAPI_VIO_Open()

◆ NVVIO_OWNERID_INITIALIZED

#define NVVIO_OWNERID_INITIALIZED 0x80000000

VIO_DATA.ulOwnerID high-bit is set only if device has been initialized by VIOAPI examined at NvAPI_GetCapabilities|NvAPI_VIO_Open to determine if settings need to be applied from registry or POR state read

◆ NVVIO_OWNERID_TYPEMASK

#define NVVIO_OWNERID_TYPEMASK 0x0FFFFFFF

mask for NVVIOOWNERTYPE_xxx

VIO_DATA.ulOwnerID lower bits are: NVGVOOWNERTYPE_xxx enumerations indicating use context

◆ NVVIO_VALID_ACCESSRIGHTS

#define NVVIO_VALID_ACCESSRIGHTS

Value:

(NVVIO_O_READ | \

NVVIO_O_WRITE_EXCLUSIVE )

NVVIO_O_WRITE_EXCLUSIVE

#define NVVIO_O_WRITE_EXCLUSIVE

Write exclusive access (not applicable for video input)

Definition nvapi.h:19981

NVVIO_O_READ

#define NVVIO_O_READ

Read access (not applicable for video output)

Definition nvapi.h:19978

◆ NVVIOBUFFERFORMAT_R16FPG16FPB16FP

#define NVVIOBUFFERFORMAT_R16FPG16FPB16FP 0x00000010

R16FP:G16FP:B16FP.

◆ NVVIOBUFFERFORMAT_R16FPG16FPB16FPA16FP

#define NVVIOBUFFERFORMAT_R16FPG16FPB16FPA16FP 0x00000040

R16FP:G16FP:B16FP:A16FP.

◆ NVVIOBUFFERFORMAT_R16FPG16FPB16FPA16FPZ24

#define NVVIOBUFFERFORMAT_R16FPG16FPB16FPA16FPZ24 0x00000080

R16FP:G16FP:B16FP:A16FP:Z24.

◆ NVVIOBUFFERFORMAT_R16FPG16FPB16FPZ24

#define NVVIOBUFFERFORMAT_R16FPG16FPB16FPZ24 0x00000020

R16FP:G16FP:B16FP:Z24.

◆ NVVIOBUFFERFORMAT_R8G8B8

#define NVVIOBUFFERFORMAT_R8G8B8 0x00000001

R8:G8:B8.

◆ NVVIOBUFFERFORMAT_R8G8B8A8

#define NVVIOBUFFERFORMAT_R8G8B8A8 0x00000004

R8:G8:B8:A8.

◆ NVVIOBUFFERFORMAT_R8G8B8A8Z24

#define NVVIOBUFFERFORMAT_R8G8B8A8Z24 0x00000008

R8:G8:B8:A8:Z24

◆ NVVIOBUFFERFORMAT_R8G8B8Z24

#define NVVIOBUFFERFORMAT_R8G8B8Z24 0x00000002

R8:G8:B8:Z24

◆ NVVIOCAPS_AUDIO_BLANKING_SUPPORTED

#define NVVIOCAPS_AUDIO_BLANKING_SUPPORTED 0x00400000

Supports ANC audio blanking.

◆ NVVIOCAPS_OUTPUTMODE_DESKTOP

#define NVVIOCAPS_OUTPUTMODE_DESKTOP 0x00010000

Supports Desktop transparent mode.

◆ NVVIOCAPS_OUTPUTMODE_OPENGL

#define NVVIOCAPS_OUTPUTMODE_OPENGL 0x00020000

Supports OpenGL application mode.

◆ NVVIOCAPS_PACKED_ANC_SUPPORTED

#define NVVIOCAPS_PACKED_ANC_SUPPORTED 0x00200000

Supports Packed ANC.

◆ NVVIOCAPS_SYNC_GENLOCK

#define NVVIOCAPS_SYNC_GENLOCK 0x00000200

Supports Genlock timing source.

◆ NVVIOCAPS_SYNC_INTERNAL

#define NVVIOCAPS_SYNC_INTERNAL 0x00000100

Supports Internal timing source.

◆ NVVIOCAPS_SYNCSRC_COMP

#define NVVIOCAPS_SYNCSRC_COMP 0x00002000

Supports Composite synchronization input.

◆ NVVIOCAPS_SYNCSRC_SDI

#define NVVIOCAPS_SYNCSRC_SDI 0x00001000

Supports Serial Digital Interface (SDI) synchronization input.

◆ NVVIOCAPS_VER

#define NVVIOCAPS_VER NVVIOCAPS_VER2

◆ NVVIOCAPS_VER1

#define NVVIOCAPS_VER1 MAKE_NVAPI_VERSION(NVVIOCAPS,1)

Macro for constructing the version field of NVVIOCAPS.

◆ NVVIOCAPS_VER2

#define NVVIOCAPS_VER2 MAKE_NVAPI_VERSION(NVVIOCAPS,2)

◆ NVVIOCAPS_VIDIN_SDI

#define NVVIOCAPS_VIDIN_SDI 0x00100000

Supports Serial Digital Interface (SDI) input.

◆ NVVIOCAPS_VIDOUT_SDI

#define NVVIOCAPS_VIDOUT_SDI 0x00000001

Supports Serial Digital Interface (SDI) output.

◆ NVVIOCLASS_SDI

#define NVVIOCLASS_SDI 0x00000001

SDI-class interface: SDI output with two genlock inputs.

◆ NVVIOCOLORCONVERSION_VER

#define NVVIOCOLORCONVERSION_VER MAKE_NVAPI_VERSION(NVVIOCOLORCONVERSION,1)

macro for constructing the version field of _NVVIOCOLORCONVERSION.

◆ NVVIOCONFIG_422FILTER

#define NVVIOCONFIG_422FILTER 0x00000400

fields: bEnable422Filter

◆ NVVIOCONFIG_ALLFIELDS

#define NVVIOCONFIG_ALLFIELDS

Value:

( NVVIOCONFIG_SIGNALFORMAT | \

NVVIOCONFIG_DATAFORMAT | \

NVVIOCONFIG_OUTPUTREGION | \

NVVIOCONFIG_OUTPUTAREA | \

NVVIOCONFIG_COLORCONVERSION | \

NVVIOCONFIG_GAMMACORRECTION | \

NVVIOCONFIG_SYNCSOURCEENABLE | \

NVVIOCONFIG_SYNCDELAY | \

NVVIOCONFIG_COMPOSITESYNCTYPE | \

NVVIOCONFIG_FRAMELOCKENABLE | \

NVVIOCONFIG_422FILTER | \

NVVIOCONFIG_COMPOSITETERMINATE | \

NVVIOCONFIG_DATAINTEGRITYCHECK | \

NVVIOCONFIG_CSCOVERRIDE | \

NVVIOCONFIG_FLIPQUEUELENGTH | \

NVVIOCONFIG_ANCTIMECODEGENERATION | \

NVVIOCONFIG_COMPOSITE | \

NVVIOCONFIG_ALPHAKEYCOMPOSITE | \

NVVIOCONFIG_COMPOSITE_Y | \

NVVIOCONFIG_COMPOSITE_CR | \

NVVIOCONFIG_COMPOSITE_CB | \

NVVIOCONFIG_FULL_COLOR_RANGE | \

NVVIOCONFIG_RGB_DATA | \

NVVIOCONFIG_RESERVED_SDIOUTPUTENABLE | \

NVVIOCONFIG_STREAMS | \

NVVIOCONFIG_ANC_PARITY_COMPUTATION | \

NVVIOCONFIG_ANC_AUDIO_REPEAT )

NVVIOCONFIG_422FILTER

#define NVVIOCONFIG_422FILTER

fields: bEnable422Filter

Definition nvapi.h:20575

NVVIOCONFIG_COMPOSITE_CR

#define NVVIOCONFIG_COMPOSITE_CR

fields: compRange

Definition nvapi.h:20584

NVVIOCONFIG_COMPOSITE_CB

#define NVVIOCONFIG_COMPOSITE_CB

fields: compRange

Definition nvapi.h:20585

NVVIOCONFIG_FLIPQUEUELENGTH

#define NVVIOCONFIG_FLIPQUEUELENGTH

fields: flipqueuelength control

Definition nvapi.h:20579

NVVIOCONFIG_COLORCONVERSION

#define NVVIOCONFIG_COLORCONVERSION

fields: colorConversion

Definition nvapi.h:20569

NVVIOCONFIG_SYNCSOURCEENABLE

#define NVVIOCONFIG_SYNCSOURCEENABLE

fields: syncSource and syncEnable

Definition nvapi.h:20571

NVVIOCONFIG_SIGNALFORMAT

#define NVVIOCONFIG_SIGNALFORMAT

fields: signalFormat

Definition nvapi.h:20565

NVVIOCONFIG_ANC_AUDIO_REPEAT

#define NVVIOCONFIG_ANC_AUDIO_REPEAT

fields: enableAudioBlanking

Definition nvapi.h:20591

NVVIOCONFIG_STREAMS

#define NVVIOCONFIG_STREAMS

fields: streams

Definition nvapi.h:20589

NVVIOCONFIG_DATAFORMAT

#define NVVIOCONFIG_DATAFORMAT

fields: dataFormat

Definition nvapi.h:20566

NVVIOCONFIG_FULL_COLOR_RANGE

#define NVVIOCONFIG_FULL_COLOR_RANGE

fields: bEnableFullColorRange

Definition nvapi.h:20586

NVVIOCONFIG_OUTPUTREGION

#define NVVIOCONFIG_OUTPUTREGION

fields: outputRegion

Definition nvapi.h:20567

NVVIOCONFIG_DATAINTEGRITYCHECK

#define NVVIOCONFIG_DATAINTEGRITYCHECK

fields: bEnableDataIntegrityCheck (Not supported on Quadro FX 4000 SDI)

Definition nvapi.h:20577

NVVIOCONFIG_OUTPUTAREA

#define NVVIOCONFIG_OUTPUTAREA

fields: outputArea

Definition nvapi.h:20568

NVVIOCONFIG_COMPOSITE_Y

#define NVVIOCONFIG_COMPOSITE_Y

fields: compRange

Definition nvapi.h:20583

NVVIOCONFIG_COMPOSITE

#define NVVIOCONFIG_COMPOSITE

fields: bEnableComposite

Definition nvapi.h:20581

NVVIOCONFIG_ALPHAKEYCOMPOSITE

#define NVVIOCONFIG_ALPHAKEYCOMPOSITE

fields: bEnableAlphaKeyComposite

Definition nvapi.h:20582

NVVIOCONFIG_GAMMACORRECTION

#define NVVIOCONFIG_GAMMACORRECTION

fields: gammaCorrection

Definition nvapi.h:20570

NVVIOCONFIG_COMPOSITESYNCTYPE

#define NVVIOCONFIG_COMPOSITESYNCTYPE

fields: compositeSyncType

Definition nvapi.h:20573

NVVIOCONFIG_ANC_PARITY_COMPUTATION

#define NVVIOCONFIG_ANC_PARITY_COMPUTATION

fields: ancParityComputation

Definition nvapi.h:20590

NVVIOCONFIG_CSCOVERRIDE

#define NVVIOCONFIG_CSCOVERRIDE

fields: colorConversion override

Definition nvapi.h:20578

NVVIOCONFIG_COMPOSITETERMINATE

#define NVVIOCONFIG_COMPOSITETERMINATE

fields: bCompositeTerminate (Not supported on Quadro FX 4000 SDI)

Definition nvapi.h:20576

NVVIOCONFIG_SYNCDELAY

#define NVVIOCONFIG_SYNCDELAY

fields: syncDelay

Definition nvapi.h:20572

NVVIOCONFIG_FRAMELOCKENABLE

#define NVVIOCONFIG_FRAMELOCKENABLE

fields: EnableFramelock

Definition nvapi.h:20574

NVVIOCONFIG_RESERVED_SDIOUTPUTENABLE

#define NVVIOCONFIG_RESERVED_SDIOUTPUTENABLE

fields: bEnableSDIOutput

Definition nvapi.h:20588

NVVIOCONFIG_ANCTIMECODEGENERATION

#define NVVIOCONFIG_ANCTIMECODEGENERATION

fields: bEnableANCTimeCodeGeneration

Definition nvapi.h:20580

NVVIOCONFIG_RGB_DATA

#define NVVIOCONFIG_RGB_DATA

fields: bEnableRGBData

Definition nvapi.h:20587

◆ NVVIOCONFIG_ALLOWSDIRUNNING_FIELDS

#define NVVIOCONFIG_ALLOWSDIRUNNING_FIELDS

Value:

( NVVIOCONFIG_DATAINTEGRITYCHECK | \

NVVIOCONFIG_SYNCDELAY | \

NVVIOCONFIG_CSCOVERRIDE | \

NVVIOCONFIG_ANCTIMECODEGENERATION | \

NVVIOCONFIG_COMPOSITE | \

NVVIOCONFIG_ALPHAKEYCOMPOSITE | \

NVVIOCONFIG_COMPOSITE_Y | \

NVVIOCONFIG_COMPOSITE_CR | \

NVVIOCONFIG_COMPOSITE_CB | \

NVVIOCONFIG_ANC_PARITY_COMPUTATION)

◆ NVVIOCONFIG_ALPHAKEYCOMPOSITE

#define NVVIOCONFIG_ALPHAKEYCOMPOSITE 0x00020000

fields: bEnableAlphaKeyComposite

◆ NVVIOCONFIG_ANC_AUDIO_REPEAT

#define NVVIOCONFIG_ANC_AUDIO_REPEAT 0x04000000

fields: enableAudioBlanking

◆ NVVIOCONFIG_ANC_PARITY_COMPUTATION

#define NVVIOCONFIG_ANC_PARITY_COMPUTATION 0x02000000

fields: ancParityComputation

◆ NVVIOCONFIG_ANCTIMECODEGENERATION

#define NVVIOCONFIG_ANCTIMECODEGENERATION 0x00008000

fields: bEnableANCTimeCodeGeneration

◆ NVVIOCONFIG_COLORCONVERSION

#define NVVIOCONFIG_COLORCONVERSION 0x00000010

fields: colorConversion

◆ NVVIOCONFIG_COMPOSITE

#define NVVIOCONFIG_COMPOSITE 0x00010000

fields: bEnableComposite

◆ NVVIOCONFIG_COMPOSITE_CB

#define NVVIOCONFIG_COMPOSITE_CB 0x00100000

fields: compRange

◆ NVVIOCONFIG_COMPOSITE_CR

#define NVVIOCONFIG_COMPOSITE_CR 0x00080000

fields: compRange

◆ NVVIOCONFIG_COMPOSITE_Y

#define NVVIOCONFIG_COMPOSITE_Y 0x00040000

fields: compRange

◆ NVVIOCONFIG_COMPOSITESYNCTYPE

#define NVVIOCONFIG_COMPOSITESYNCTYPE 0x00000100

fields: compositeSyncType

◆ NVVIOCONFIG_COMPOSITETERMINATE

#define NVVIOCONFIG_COMPOSITETERMINATE 0x00000800

fields: bCompositeTerminate (Not supported on Quadro FX 4000 SDI)

◆ NVVIOCONFIG_CSCOVERRIDE

#define NVVIOCONFIG_CSCOVERRIDE 0x00002000

fields: colorConversion override

◆ NVVIOCONFIG_DATAFORMAT

#define NVVIOCONFIG_DATAFORMAT 0x00000002

fields: dataFormat

◆ NVVIOCONFIG_DATAINTEGRITYCHECK

#define NVVIOCONFIG_DATAINTEGRITYCHECK 0x00001000

fields: bEnableDataIntegrityCheck (Not supported on Quadro FX 4000 SDI)

◆ NVVIOCONFIG_DRIVERFIELDS

#define NVVIOCONFIG_DRIVERFIELDS

Value:

( NVVIOCONFIG_OUTPUTREGION | \

NVVIOCONFIG_OUTPUTAREA | \

NVVIOCONFIG_COLORCONVERSION | \

NVVIOCONFIG_FLIPQUEUELENGTH)

◆ NVVIOCONFIG_FLIPQUEUELENGTH

#define NVVIOCONFIG_FLIPQUEUELENGTH 0x00004000

fields: flipqueuelength control

◆ NVVIOCONFIG_FRAMELOCKENABLE

#define NVVIOCONFIG_FRAMELOCKENABLE 0x00000200

fields: EnableFramelock

◆ NVVIOCONFIG_FULL_COLOR_RANGE

#define NVVIOCONFIG_FULL_COLOR_RANGE 0x00200000

fields: bEnableFullColorRange

◆ NVVIOCONFIG_GAMMACORRECTION

#define NVVIOCONFIG_GAMMACORRECTION 0x00000020

fields: gammaCorrection

◆ NVVIOCONFIG_GAMMAFIELDS

#define NVVIOCONFIG_GAMMAFIELDS ( NVVIOCONFIG_GAMMACORRECTION )

◆ NVVIOCONFIG_OUTPUTAREA

#define NVVIOCONFIG_OUTPUTAREA 0x00000008

fields: outputArea

◆ NVVIOCONFIG_OUTPUTREGION

#define NVVIOCONFIG_OUTPUTREGION 0x00000004

fields: outputRegion

◆ NVVIOCONFIG_RESERVED_SDIOUTPUTENABLE

#define NVVIOCONFIG_RESERVED_SDIOUTPUTENABLE 0x00800000

fields: bEnableSDIOutput

◆ NVVIOCONFIG_RGB_DATA

#define NVVIOCONFIG_RGB_DATA 0x00400000

fields: bEnableRGBData

◆ NVVIOCONFIG_RMCTRLFIELDS

#define NVVIOCONFIG_RMCTRLFIELDS

Value:

( NVVIOCONFIG_SIGNALFORMAT | \

NVVIOCONFIG_DATAFORMAT | \

NVVIOCONFIG_SYNCSOURCEENABLE | \

NVVIOCONFIG_COMPOSITESYNCTYPE | \

NVVIOCONFIG_FRAMELOCKENABLE | \

NVVIOCONFIG_422FILTER | \

NVVIOCONFIG_COMPOSITETERMINATE | \

NVVIOCONFIG_DATAINTEGRITYCHECK | \

NVVIOCONFIG_COMPOSITE | \

NVVIOCONFIG_ALPHAKEYCOMPOSITE | \

NVVIOCONFIG_COMPOSITE_Y | \

NVVIOCONFIG_COMPOSITE_CR | \

NVVIOCONFIG_COMPOSITE_CB)

◆ NVVIOCONFIG_RMMODESET_FIELDS

#define NVVIOCONFIG_RMMODESET_FIELDS

Value:

( NVVIOCONFIG_SIGNALFORMAT | \

NVVIOCONFIG_DATAFORMAT | \

NVVIOCONFIG_SYNCSOURCEENABLE | \

NVVIOCONFIG_FRAMELOCKENABLE | \

NVVIOCONFIG_COMPOSITESYNCTYPE | \

NVVIOCONFIG_ANC_AUDIO_REPEAT)

◆ NVVIOCONFIG_RMSKEWFIELDS

#define NVVIOCONFIG_RMSKEWFIELDS ( NVVIOCONFIG_SYNCDELAY )

◆ NVVIOCONFIG_SIGNALFORMAT

#define NVVIOCONFIG_SIGNALFORMAT 0x00000001

fields: signalFormat

◆ NVVIOCONFIG_STREAMS

#define NVVIOCONFIG_STREAMS 0x01000000

fields: streams

◆ NVVIOCONFIG_SYNCDELAY

#define NVVIOCONFIG_SYNCDELAY 0x00000080

fields: syncDelay

◆ NVVIOCONFIG_SYNCSOURCEENABLE

#define NVVIOCONFIG_SYNCSOURCEENABLE 0x00000040

fields: syncSource and syncEnable

◆ NVVIOCONFIG_VALIDFIELDS

#define NVVIOCONFIG_VALIDFIELDS

Value:

( NVVIOCONFIG_SIGNALFORMAT | \

NVVIOCONFIG_DATAFORMAT | \

NVVIOCONFIG_OUTPUTREGION | \

NVVIOCONFIG_OUTPUTAREA | \

NVVIOCONFIG_COLORCONVERSION | \

NVVIOCONFIG_GAMMACORRECTION | \

NVVIOCONFIG_SYNCSOURCEENABLE | \

NVVIOCONFIG_SYNCDELAY | \

NVVIOCONFIG_COMPOSITESYNCTYPE | \

NVVIOCONFIG_FRAMELOCKENABLE | \

NVVIOCONFIG_RESERVED_SDIOUTPUTENABLE | \

NVVIOCONFIG_422FILTER | \

NVVIOCONFIG_COMPOSITETERMINATE | \

NVVIOCONFIG_DATAINTEGRITYCHECK | \

NVVIOCONFIG_CSCOVERRIDE | \

NVVIOCONFIG_FLIPQUEUELENGTH | \

NVVIOCONFIG_ANCTIMECODEGENERATION | \

NVVIOCONFIG_COMPOSITE | \

NVVIOCONFIG_ALPHAKEYCOMPOSITE | \

NVVIOCONFIG_COMPOSITE_Y | \

NVVIOCONFIG_COMPOSITE_CR | \

NVVIOCONFIG_COMPOSITE_CB | \

NVVIOCONFIG_FULL_COLOR_RANGE | \

NVVIOCONFIG_RGB_DATA | \

NVVIOCONFIG_RESERVED_SDIOUTPUTENABLE | \

NVVIOCONFIG_STREAMS | \

NVVIOCONFIG_ANC_PARITY_COMPUTATION | \

NVVIOCONFIG_ANC_AUDIO_REPEAT)

◆ NVVIOCONFIG_VER

#define NVVIOCONFIG_VER NVVIOCONFIG_VER3

◆ NVVIOCONFIG_VER1

#define NVVIOCONFIG_VER1 MAKE_NVAPI_VERSION(NVVIOCONFIG_V1,1)

◆ NVVIOCONFIG_VER2

#define NVVIOCONFIG_VER2 MAKE_NVAPI_VERSION(NVVIOCONFIG_V2,2)

◆ NVVIOCONFIG_VER3

#define NVVIOCONFIG_VER3 MAKE_NVAPI_VERSION(NVVIOCONFIG_V3,3)

◆ NVVIOGAMMACORRECTION_VER

#define NVVIOGAMMACORRECTION_VER MAKE_NVAPI_VERSION(NVVIOGAMMACORRECTION,1)

Macro for constructing thevesion field of _NVVIOGAMMACORRECTION.

◆ NVVIOOWNERID_NONE

#define NVVIOOWNERID_NONE 0

Unregistered ownerId

◆ NVVIOPCIINFO_VER

#define NVVIOPCIINFO_VER NVVIOPCIINFO_VER1

◆ NVVIOPCIINFO_VER1

#define NVVIOPCIINFO_VER1 MAKE_NVAPI_VERSION(NVVIOPCIINFO_V1,1)

◆ NVVIOSTATUS_VER

#define NVVIOSTATUS_VER MAKE_NVAPI_VERSION(NVVIOSTATUS,1)

Macro for constructingthe version field of NVVIOSTATUS.

◆ NVVIOSYNCDELAY_VER

#define NVVIOSYNCDELAY_VER MAKE_NVAPI_VERSION(NVVIOSYNCDELAY,1)

Macro for constructing the version field of NVVIOSYNCDELAY.

◆ NVVIOTOPOLOGY_VER

#define NVVIOTOPOLOGY_VER MAKE_NVAPI_VERSION(NVVIOTOPOLOGY,1)

Macro for constructing the version field of NVVIOTOPOLOGY.

Typedef Documentation

◆ NV_CLIENT_CALLBACK_SETTINGS_SUPER_V1

typedef struct _NV_CLIENT_CALLBACK_SETTINGS_SUPER_V1 NV_CLIENT_CALLBACK_SETTINGS_SUPER_V1

Callback settings common to all client callbacks.

◆ NV_DISPLAY_DRIVER_INFO

typedef NV_DISPLAY_DRIVER_INFO_V2 NV_DISPLAY_DRIVER_INFO

◆ NV_DISPLAY_DRIVER_INFO_V1

typedef struct _NV_DISPLAY_DRIVER_INFO NV_DISPLAY_DRIVER_INFO_V1

◆ NV_DISPLAY_DRIVER_INFO_V2

typedef struct _NV_DISPLAY_DRIVER_INFO_V2 NV_DISPLAY_DRIVER_INFO_V2

◆ NV_GPU_CLIENT_CALLBACK_DATA_SUPER_V1

typedef struct _NV_GPU_CLIENT_CALLBACK_DATA_SUPER_V1 NV_GPU_CLIENT_CALLBACK_DATA_SUPER_V1

Callback data common to all client callbacks.

◆ NV_GPU_CLIENT_CALLBACK_SETTINGS_SUPER_V1

typedef NV_CLIENT_CALLBACK_SETTINGS_SUPER_V1 NV_GPU_CLIENT_CALLBACK_SETTINGS_SUPER_V1

◆ NV_GPU_CLIENT_CALLBACK_UTILIZATION_DATA_V1

typedef struct _NV_GPU_CLIENT_CALLBACK_UTILIZATION_DATA_V1 NV_GPU_CLIENT_CALLBACK_UTILIZATION_DATA_V1

Data passed back to callback registered with NvAPI_GPU_ClientRegisterForUtilizationSampleUpdates.

◆ NV_GPU_CLIENT_PERIODIC_CALLBACK_SETTINGS_SUPER_V1

typedef struct _NV_GPU_CLIENT_PERIODIC_CALLBACK_SETTINGS_SUPER_V1 NV_GPU_CLIENT_PERIODIC_CALLBACK_SETTINGS_SUPER_V1

Callback settings common to all periodic client callbacks.

◆ NV_GPU_CLIENT_UTIL_DOMAIN_ID

typedef enum _NV_GPU_CLIENT_UTIL_DOMAIN_ID NV_GPU_CLIENT_UTIL_DOMAIN_ID

Enumeration of different utilization domains

◆ NV_GPU_CLIENT_UTILIZATION_DATA_V1

typedef struct _NV_GPU_CLIENT_UTILIZATION_DATA_V1 NV_GPU_CLIENT_UTILIZATION_DATA_V1

Data specific to a single utilization domain.

◆ NV_GPU_CLIENT_UTILIZATION_PERIODIC_CALLBACK_SETTINGS

typedef NV_GPU_CLIENT_UTILIZATION_PERIODIC_CALLBACK_SETTINGS_V1 NV_GPU_CLIENT_UTILIZATION_PERIODIC_CALLBACK_SETTINGS

◆ NV_GPU_CLIENT_UTILIZATION_PERIODIC_CALLBACK_SETTINGS_V1

typedef struct _NV_GPU_CLIENT_UTILIZATION_PERIODIC_CALLBACK_SETTINGS_V1 NV_GPU_CLIENT_UTILIZATION_PERIODIC_CALLBACK_SETTINGS_V1

Data required to register a periodic callback for utilization data.

◆ NV_GPU_CLIENT_UTILIZATION_PERIODIC_CALLBACK_V1

typedef void(__cdecl * NV_GPU_CLIENT_UTILIZATION_PERIODIC_CALLBACK_V1) (NvPhysicalGpuHandle hPhysicalGpu, NV_GPU_CLIENT_CALLBACK_UTILIZATION_DATA_V1 *pData)

Function prototype for a periodic utilization data callback that will be registered with NvAPI.

◆ NV_LOGICAL_GPU_HANDLE_DATA

typedef struct _NV_LOGICAL_GPU_HANDLE_DATA NV_LOGICAL_GPU_HANDLE_DATA

◆ NV_LOGICAL_GPUS

typedef NV_LOGICAL_GPUS_V1 NV_LOGICAL_GPUS

◆ NV_LOGICAL_GPUS_V1

typedef struct _NV_LOGICAL_GPUS NV_LOGICAL_GPUS_V1

◆ NV_PHYSICAL_GPU_HANDLE_DATA

typedef struct _NV_PHYSICAL_GPU_HANDLE_DATA NV_PHYSICAL_GPU_HANDLE_DATA

◆ NV_PHYSICAL_GPUS

typedef NV_PHYSICAL_GPUS_V1 NV_PHYSICAL_GPUS

◆ NV_PHYSICAL_GPUS_V1

typedef struct _NV_PHYSICAL_GPUS NV_PHYSICAL_GPUS_V1

◆ NV_VIO_TOPOLOGY

typedef struct _NV_VIO_TOPOLOGY NV_VIO_TOPOLOGY

◆ NVVIOANCPARITYCOMPUTATION

typedef enum _NVVIOANCPARITYCOMPUTATION NVVIOANCPARITYCOMPUTATION

◆ NVVIOBITSPERCOMPONENT

typedef enum _NVVIOBITSPERCOMPONENT NVVIOBITSPERCOMPONENT

◆ NVVIOCAPS

typedef struct _NVVIOCAPS NVVIOCAPS

Device capabilities.

◆ NVVIOCAPTURESTATUS

typedef enum _NVVIOCAPTURESTATUS NVVIOCAPTURESTATUS

Video Capture Status.

◆ NVVIOCHANNELSTATUS

typedef struct _NVVIOCHANNELSTATUS NVVIOCHANNELSTATUS

Input channel status.

◆ NVVIOCOLORCONVERSION

typedef struct _NVVIOCOLORCONVERSION NVVIOCOLORCONVERSION

Colorspace conversion.

◆ NVVIOCOLORSPACE

typedef enum _NVVIOCOLORSPACE NVVIOCOLORSPACE

◆ NVVIOCOMPONENTSAMPLING

typedef enum _NVVIOCOMPONENTSAMPLING NVVIOCOMPONENTSAMPLING

Component sampling.

◆ NVVIOCOMPOSITERANGE

typedef struct _NVVIOCOMPOSITERANGE NVVIOCOMPOSITERANGE

◆ NVVIOCOMPSYNCTYPE

typedef enum _NVVIOCOMPSYNCTYPE NVVIOCOMPSYNCTYPE

Composite synchronization type.

◆ NVVIOCONFIG

typedef NVVIOCONFIG_V3 NVVIOCONFIG

◆ NVVIOCONFIG_V1

typedef struct _NVVIOCONFIG_V1 NVVIOCONFIG_V1

◆ NVVIOCONFIG_V2

typedef struct _NVVIOCONFIG_V2 NVVIOCONFIG_V2

◆ NVVIOCONFIG_V3

typedef struct _NVVIOCONFIG_V3 NVVIOCONFIG_V3

◆ NVVIOCONFIGTYPE

typedef enum _NVVIOCONFIGTYPE NVVIOCONFIGTYPE

Device configuration.

◆ NVVIODATAFORMAT

typedef enum _NVVIODATAFORMAT NVVIODATAFORMAT

Video data format.

◆ NVVIODATAFORMATDETAIL

typedef struct _NVVIODATAFORMATDETAIL NVVIODATAFORMATDETAIL

Data format details.

◆ NVVIOGAMMACORRECTION

typedef struct _NVVIOGAMMACORRECTION NVVIOGAMMACORRECTION

Gamma correction.

◆ NVVIOGAMMARAMP10

typedef struct _NVVIOGAMMARAMP10 NVVIOGAMMARAMP10

Gamma ramp (10-bit index)

◆ NVVIOGAMMARAMP8

typedef struct _NVVIOGAMMARAMP8 NVVIOGAMMARAMP8

Gamma ramp (8-bit index)

◆ NVVIOINPUTCONFIG

typedef struct _NVVIOINPUTCONFIG NVVIOINPUTCONFIG

Input device configuration.

◆ NVVIOINPUTOUTPUTSTATUS

typedef enum _NVVIOINPUTOUTPUTSTATUS NVVIOINPUTOUTPUTSTATUS

Video input output status.

◆ NVVIOINPUTSTATUS

typedef struct _NVVIOINPUTSTATUS NVVIOINPUTSTATUS

Input device status.

◆ NVVIOINTERLACEMODE

typedef enum _NVVIOINTERLACEMODE NVVIOINTERLACEMODE

Interlace mode.

◆ NVVIOLINKID

typedef enum _NVVIOLINKID NVVIOLINKID

◆ NVVIOOUTPUTAREA

typedef enum _NVVIOOUTPUTAREA NVVIOOUTPUTAREA

Video output area.

◆ NVVIOOUTPUTCONFIG

typedef NVVIOOUTPUTCONFIG_V3 NVVIOOUTPUTCONFIG

◆ NVVIOOUTPUTCONFIG_V1

typedef struct _NVVIOOUTPUTCONFIG_V1 NVVIOOUTPUTCONFIG_V1

Output device configuration.

◆ NVVIOOUTPUTCONFIG_V2

typedef struct _NVVIOOUTPUTCONFIG_V2 NVVIOOUTPUTCONFIG_V2

◆ NVVIOOUTPUTCONFIG_V3

typedef struct _NVVIOOUTPUTCONFIG_V3 NVVIOOUTPUTCONFIG_V3

◆ NVVIOOUTPUTREGION

typedef struct _NVVIOOUTPUTREGION NVVIOOUTPUTREGION

Output region.

◆ NVVIOOUTPUTSTATUS

typedef struct _NVVIOOUTPUTSTATUS NVVIOOUTPUTSTATUS

Output device status.

◆ NVVIOOWNERID

typedef NvU32 NVVIOOWNERID

Unique identifier for VIO owner (process identifier or NVVIOOWNERID_NONE)

◆ NVVIOOWNERTYPE

typedef enum _NVVIOOWNERTYPE NVVIOOWNERTYPE

Owner type for device.

◆ NVVIOPCIINFO

typedef NVVIOPCIINFO_V1 NVVIOPCIINFO

◆ NVVIOPCIINFO_V1

typedef struct _NVVIOPCIINFO NVVIOPCIINFO_V1

◆ NVVIOPCILINKRATE

typedef enum _NVVIOPCILINKRATE NVVIOPCILINKRATE

◆ NVVIOPCILINKWIDTH

typedef enum _NVVIOPCILINKWIDTH NVVIOPCILINKWIDTH

◆ NVVIOSIGNALFORMAT

typedef enum _NVVIOSIGNALFORMAT NVVIOSIGNALFORMAT

Video signal format and resolution.

◆ NVVIOSIGNALFORMATDETAIL

typedef struct _NVVIOSIGNALFORMATDETAIL NVVIOSIGNALFORMATDETAIL

Signal format details.

◆ NVVIOSTATUS

typedef struct _NVVIOSTATUS NVVIOSTATUS

Video device status.

◆ NVVIOSTATUSTYPE

typedef enum _NVVIOSTATUSTYPE NVVIOSTATUSTYPE

Video Capture Status.

◆ NVVIOSTREAM

typedef struct _NVVIOSTREAM NVVIOSTREAM

Stream configuration.

◆ NVVIOSYNCDELAY

typedef struct _NVVIOSYNCDELAY NVVIOSYNCDELAY

Sync delay.

◆ NVVIOSYNCSOURCE

typedef enum _NVVIOSYNCSOURCE NVVIOSYNCSOURCE

Synchronization source.

◆ NVVIOSYNCSTATUS

typedef enum _NVVIOSYNCSTATUS NVVIOSYNCSTATUS

Synchronization input status.

◆ NVVIOTOPOLOGY

typedef struct _NV_VIO_TOPOLOGY NVVIOTOPOLOGY

◆ NVVIOVIDEOMODE

typedef struct _NVVIOVIDEOMODE NVVIOVIDEOMODE

Video mode information.

◆ NVVIOVIDEOSTANDARD

typedef enum _NVVIOVIDEOSTANDARD NVVIOVIDEOSTANDARD

SMPTE standards format.

◆ NVVIOVIDEOTYPE

typedef enum _NVVIOVIDEOTYPE NVVIOVIDEOTYPE

HD or SD video type.

Enumeration Type Documentation

◆ _NV_GPU_CLIENT_UTIL_DOMAIN_ID

enum _NV_GPU_CLIENT_UTIL_DOMAIN_ID

Enumeration of different utilization domains

Enumerator

NV_GPU_CLIENT_UTIL_DOMAIN_GRAPHICS

NV_GPU_CLIENT_UTIL_DOMAIN_FRAME_BUFFER

NV_GPU_CLIENT_UTIL_DOMAIN_VIDEO

NV_GPU_CLIENT_UTIL_DOMAIN_RSVD

Reserved for future use.

◆ _NVVIOANCPARITYCOMPUTATION

enum _NVVIOANCPARITYCOMPUTATION

Enumerator

NVVIOANCPARITYCOMPUTATION_AUTO

NVVIOANCPARITYCOMPUTATION_ON

NVVIOANCPARITYCOMPUTATION_OFF

◆ _NVVIOBITSPERCOMPONENT

enum _NVVIOBITSPERCOMPONENT

Enumerator

NVVIOBITSPERCOMPONENT_UNKNOWN

NVVIOBITSPERCOMPONENT_8

NVVIOBITSPERCOMPONENT_10

NVVIOBITSPERCOMPONENT_12

◆ _NVVIOCAPTURESTATUS

enum _NVVIOCAPTURESTATUS

Video Capture Status.

Enumerator

NVVIOSTATUS_STOPPED

Sync not detected.

NVVIOSTATUS_RUNNING

Error detected.

NVVIOSTATUS_ERROR

Genlock in use, format mismatch with output.

◆ _NVVIOCOLORSPACE

enum _NVVIOCOLORSPACE

Enumerator

NVVIOCOLORSPACE_UNKNOWN

NVVIOCOLORSPACE_YCBCR

NVVIOCOLORSPACE_YCBCRA

NVVIOCOLORSPACE_YCBCRD

NVVIOCOLORSPACE_GBR

NVVIOCOLORSPACE_GBRA

NVVIOCOLORSPACE_GBRD

◆ _NVVIOCOMPONENTSAMPLING

enum _NVVIOCOMPONENTSAMPLING

Component sampling.

Enumerator

NVVIOCOMPONENTSAMPLING_UNKNOWN

NVVIOCOMPONENTSAMPLING_4444

NVVIOCOMPONENTSAMPLING_4224

NVVIOCOMPONENTSAMPLING_444

NVVIOCOMPONENTSAMPLING_422

◆ _NVVIOCOMPSYNCTYPE

enum _NVVIOCOMPSYNCTYPE

Composite synchronization type.

Enumerator

NVVIOCOMPSYNCTYPE_AUTO

Auto-detect.

NVVIOCOMPSYNCTYPE_BILEVEL

Bi-level signal.

NVVIOCOMPSYNCTYPE_TRILEVEL

Tri-level signal.

◆ _NVVIOCONFIGTYPE

enum _NVVIOCONFIGTYPE

Device configuration.

Enumerator

NVVIOCONFIGTYPE_IN

Input Status.

NVVIOCONFIGTYPE_OUT

Output Status.

◆ _NVVIODATAFORMAT

enum _NVVIODATAFORMAT

Video data format.

Enumerator

NVVIODATAFORMAT_UNKNOWN

Invalid DataFormat.

NVVIODATAFORMAT_R8G8B8_TO_YCRCB444

R8:G8:B8 => YCrCb (4:4:4)

NVVIODATAFORMAT_R8G8B8A8_TO_YCRCBA4444

R8:G8:B8:A8 => YCrCbA (4:4:4:4)

NVVIODATAFORMAT_R8G8B8Z10_TO_YCRCBZ4444

R8:G8:B8:Z10 => YCrCbZ (4:4:4:4)

NVVIODATAFORMAT_R8G8B8_TO_YCRCB422

R8:G8:B8 => YCrCb (4:2:2)

NVVIODATAFORMAT_R8G8B8A8_TO_YCRCBA4224

R8:G8:B8:A8 => YCrCbA (4:2:2:4)

NVVIODATAFORMAT_R8G8B8Z10_TO_YCRCBZ4224

R8:G8:B8:Z10 => YCrCbZ (4:2:2:4)

NVVIODATAFORMAT_X8X8X8_444_PASSTHRU

R8:G8:B8 => RGB (4:4:4)

NVVIODATAFORMAT_X8X8X8A8_4444_PASSTHRU

R8:G8:B8:A8 => RGBA (4:4:4:4)

NVVIODATAFORMAT_X8X8X8Z10_4444_PASSTHRU

R8:G8:B8:Z10 => RGBZ (4:4:4:4)

NVVIODATAFORMAT_X10X10X10_444_PASSTHRU

Y10:CR10:CB10 => YCrCb (4:4:4)

NVVIODATAFORMAT_X10X8X8_444_PASSTHRU

Y10:CR8:CB8 => YCrCb (4:4:4)

NVVIODATAFORMAT_X10X8X8A10_4444_PASSTHRU

Y10:CR8:CB8:A10 => YCrCbA (4:4:4:4)

NVVIODATAFORMAT_X10X8X8Z10_4444_PASSTHRU

Y10:CR8:CB8:Z10 => YCrCbZ (4:4:4:4)

NVVIODATAFORMAT_DUAL_R8G8B8_TO_DUAL_YCRCB422

R8:G8:B8 + R8:G8:B8 => YCrCb (4:2:2 + 4:2:2)

NVVIODATAFORMAT_DUAL_X8X8X8_TO_DUAL_422_PASSTHRU

Y8:CR8:CB8 + Y8:CR8:CB8 => YCrCb (4:2:2 + 4:2:2)

NVVIODATAFORMAT_R10G10B10_TO_YCRCB422

R10:G10:B10 => YCrCb (4:2:2)

NVVIODATAFORMAT_R10G10B10_TO_YCRCB444

R10:G10:B10 => YCrCb (4:4:4)

NVVIODATAFORMAT_X12X12X12_444_PASSTHRU

X12:X12:X12 => XXX (4:4:4)

NVVIODATAFORMAT_X12X12X12_422_PASSTHRU

X12:X12:X12 => XXX (4:2:2)

NVVIODATAFORMAT_Y10CR10CB10_TO_YCRCB422

Y10:CR10:CB10 => YCrCb (4:2:2)

NVVIODATAFORMAT_Y8CR8CB8_TO_YCRCB422

Y8:CR8:CB8 => YCrCb (4:2:2)

NVVIODATAFORMAT_Y10CR8CB8A10_TO_YCRCBA4224

Y10:CR8:CB8:A10 => YCrCbA (4:2:2:4)

NVVIODATAFORMAT_R10G10B10_TO_RGB444

R10:G10:B10 => RGB (4:4:4)

NVVIODATAFORMAT_R12G12B12_TO_YCRCB444

R12:G12:B12 => YCrCb (4:4:4)

NVVIODATAFORMAT_R12G12B12_TO_YCRCB422

R12:G12:B12 => YCrCb (4:2:2)

◆ _NVVIOINPUTOUTPUTSTATUS

enum _NVVIOINPUTOUTPUTSTATUS

Video input output status.

Enumerator

NVINPUTOUTPUTSTATUS_OFF

Not in use.

NVINPUTOUTPUTSTATUS_ERROR

Error detected.

NVINPUTOUTPUTSTATUS_SDI_SD

SDI (standard-definition)

NVINPUTOUTPUTSTATUS_SDI_HD

SDI (high-definition)

◆ _NVVIOINTERLACEMODE

enum _NVVIOINTERLACEMODE

Interlace mode.

Enumerator

NVVIOINTERLACEMODE_PROGRESSIVE

Progressive (p)

NVVIOINTERLACEMODE_INTERLACE

Interlace (i)

NVVIOINTERLACEMODE_PSF

Progressive Segment Frame (psf)

◆ _NVVIOLINKID

enum _NVVIOLINKID

Enumerator

NVVIOLINKID_UNKNOWN

NVVIOLINKID_A

NVVIOLINKID_B

NVVIOLINKID_C

NVVIOLINKID_D

◆ _NVVIOOUTPUTAREA

enum _NVVIOOUTPUTAREA

Video output area.

Enumerator

NVVIOOUTPUTAREA_FULLSIZE

Output to entire video resolution (full size)

NVVIOOUTPUTAREA_SAFEACTION

Output to centered 90% of video resolution (safe action)

NVVIOOUTPUTAREA_SAFETITLE

Output to centered 80% of video resolution (safe title)

◆ _NVVIOOWNERTYPE

enum _NVVIOOWNERTYPE

Owner type for device.

Enumerator

NVVIOOWNERTYPE_NONE

No owner for the device.

NVVIOOWNERTYPE_APPLICATION

Application owns the device.

NVVIOOWNERTYPE_DESKTOP

Desktop transparent mode owns the device (not applicable for video input)

◆ _NVVIOPCILINKRATE

enum _NVVIOPCILINKRATE

Enumerator

NVVIOPCILINKRATE_UNKNOWN

NVVIOPCILINKRATE_GEN1

NVVIOPCILINKRATE_GEN2

NVVIOPCILINKRATE_GEN3

◆ _NVVIOPCILINKWIDTH

enum _NVVIOPCILINKWIDTH

Enumerator

NVVIOPCILINKWIDTH_UNKNOWN

NVVIOPCILINKWIDTH_x1

NVVIOPCILINKWIDTH_x2

NVVIOPCILINKWIDTH_x4

NVVIOPCILINKWIDTH_x8

NVVIOPCILINKWIDTH_x16

◆ _NVVIOSIGNALFORMAT

enum _NVVIOSIGNALFORMAT

Video signal format and resolution.

Enumerator

NVVIOSIGNALFORMAT_NONE

Invalid signal format.

NVVIOSIGNALFORMAT_487I_59_94_SMPTE259_NTSC

01 487i 59.94Hz (SMPTE259) NTSC

NVVIOSIGNALFORMAT_576I_50_00_SMPTE259_PAL

02 576i 50.00Hz (SMPTE259) PAL

NVVIOSIGNALFORMAT_1035I_60_00_SMPTE260

03 1035i 60.00Hz (SMPTE260)

NVVIOSIGNALFORMAT_1035I_59_94_SMPTE260

04 1035i 59.94Hz (SMPTE260)

NVVIOSIGNALFORMAT_1080I_50_00_SMPTE295

05 1080i 50.00Hz (SMPTE295)

NVVIOSIGNALFORMAT_1080I_60_00_SMPTE274

06 1080i 60.00Hz (SMPTE274)

NVVIOSIGNALFORMAT_1080I_59_94_SMPTE274

07 1080i 59.94Hz (SMPTE274)

NVVIOSIGNALFORMAT_1080I_50_00_SMPTE274

08 1080i 50.00Hz (SMPTE274)

NVVIOSIGNALFORMAT_1080P_30_00_SMPTE274

09 1080p 30.00Hz (SMPTE274)

NVVIOSIGNALFORMAT_1080P_29_97_SMPTE274

10 1080p 29.97Hz (SMPTE274)

NVVIOSIGNALFORMAT_1080P_25_00_SMPTE274

11 1080p 25.00Hz (SMPTE274)

NVVIOSIGNALFORMAT_1080P_24_00_SMPTE274

12 1080p 24.00Hz (SMPTE274)

NVVIOSIGNALFORMAT_1080P_23_976_SMPTE274

13 1080p 23.976Hz (SMPTE274)

NVVIOSIGNALFORMAT_720P_60_00_SMPTE296

14 720p 60.00Hz (SMPTE296)

NVVIOSIGNALFORMAT_720P_59_94_SMPTE296

15 720p 59.94Hz (SMPTE296)

NVVIOSIGNALFORMAT_720P_50_00_SMPTE296

16 720p 50.00Hz (SMPTE296)

NVVIOSIGNALFORMAT_1080I_48_00_SMPTE274

17 1080I 48.00Hz (SMPTE274)

NVVIOSIGNALFORMAT_1080I_47_96_SMPTE274

18 1080I 47.96Hz (SMPTE274)

NVVIOSIGNALFORMAT_720P_30_00_SMPTE296

19 720p 30.00Hz (SMPTE296)

NVVIOSIGNALFORMAT_720P_29_97_SMPTE296

20 720p 29.97Hz (SMPTE296)

NVVIOSIGNALFORMAT_720P_25_00_SMPTE296

21 720p 25.00Hz (SMPTE296)

NVVIOSIGNALFORMAT_720P_24_00_SMPTE296

22 720p 24.00Hz (SMPTE296)

NVVIOSIGNALFORMAT_720P_23_98_SMPTE296

23 720p 23.98Hz (SMPTE296)

NVVIOSIGNALFORMAT_2048P_30_00_SMPTE372

24 2048p 30.00Hz (SMPTE372)

NVVIOSIGNALFORMAT_2048P_29_97_SMPTE372

25 2048p 29.97Hz (SMPTE372)

NVVIOSIGNALFORMAT_2048I_60_00_SMPTE372

26 2048i 60.00Hz (SMPTE372)

NVVIOSIGNALFORMAT_2048I_59_94_SMPTE372

27 2048i 59.94Hz (SMPTE372)

NVVIOSIGNALFORMAT_2048P_25_00_SMPTE372

28 2048p 25.00Hz (SMPTE372)

NVVIOSIGNALFORMAT_2048I_50_00_SMPTE372

29 2048i 50.00Hz (SMPTE372)

NVVIOSIGNALFORMAT_2048P_24_00_SMPTE372

30 2048p 24.00Hz (SMPTE372)

NVVIOSIGNALFORMAT_2048P_23_98_SMPTE372

31 2048p 23.98Hz (SMPTE372)

NVVIOSIGNALFORMAT_2048I_48_00_SMPTE372

32 2048i 48.00Hz (SMPTE372)

NVVIOSIGNALFORMAT_2048I_47_96_SMPTE372

33 2048i 47.96Hz (SMPTE372)

NVVIOSIGNALFORMAT_1080PSF_25_00_SMPTE274

34 1080PsF 25.00Hz (SMPTE274)

NVVIOSIGNALFORMAT_1080PSF_29_97_SMPTE274

35 1080PsF 29.97Hz (SMPTE274)

NVVIOSIGNALFORMAT_1080PSF_30_00_SMPTE274

36 1080PsF 30.00Hz (SMPTE274)

NVVIOSIGNALFORMAT_1080PSF_24_00_SMPTE274

37 1080PsF 24.00Hz (SMPTE274)

NVVIOSIGNALFORMAT_1080PSF_23_98_SMPTE274

38 1080PsF 23.98Hz (SMPTE274)

NVVIOSIGNALFORMAT_1080P_50_00_SMPTE274_3G_LEVEL_A

39 1080P 50.00Hz (SMPTE274) 3G Level A

NVVIOSIGNALFORMAT_1080P_59_94_SMPTE274_3G_LEVEL_A

40 1080P 59.94Hz (SMPTE274) 3G Level A

NVVIOSIGNALFORMAT_1080P_60_00_SMPTE274_3G_LEVEL_A

41 1080P 60.00Hz (SMPTE274) 3G Level A

NVVIOSIGNALFORMAT_1080P_60_00_SMPTE274_3G_LEVEL_B

42 1080p 60.00Hz (SMPTE274) 3G Level B

NVVIOSIGNALFORMAT_1080I_60_00_SMPTE274_3G_LEVEL_B

43 1080i 60.00Hz (SMPTE274) 3G Level B

NVVIOSIGNALFORMAT_2048I_60_00_SMPTE372_3G_LEVEL_B

44 2048i 60.00Hz (SMPTE372) 3G Level B

NVVIOSIGNALFORMAT_1080P_50_00_SMPTE274_3G_LEVEL_B

45 1080p 50.00Hz (SMPTE274) 3G Level B

NVVIOSIGNALFORMAT_1080I_50_00_SMPTE274_3G_LEVEL_B

46 1080i 50.00Hz (SMPTE274) 3G Level B

NVVIOSIGNALFORMAT_2048I_50_00_SMPTE372_3G_LEVEL_B

47 2048i 50.00Hz (SMPTE372) 3G Level B

NVVIOSIGNALFORMAT_1080P_30_00_SMPTE274_3G_LEVEL_B

48 1080p 30.00Hz (SMPTE274) 3G Level B

NVVIOSIGNALFORMAT_2048P_30_00_SMPTE372_3G_LEVEL_B

49 2048p 30.00Hz (SMPTE372) 3G Level B

NVVIOSIGNALFORMAT_1080P_25_00_SMPTE274_3G_LEVEL_B

50 1080p 25.00Hz (SMPTE274) 3G Level B

NVVIOSIGNALFORMAT_2048P_25_00_SMPTE372_3G_LEVEL_B

51 2048p 25.00Hz (SMPTE372) 3G Level B

NVVIOSIGNALFORMAT_1080P_24_00_SMPTE274_3G_LEVEL_B

52 1080p 24.00Hz (SMPTE274) 3G Level B

NVVIOSIGNALFORMAT_2048P_24_00_SMPTE372_3G_LEVEL_B

53 2048p 24.00Hz (SMPTE372) 3G Level B

NVVIOSIGNALFORMAT_1080I_48_00_SMPTE274_3G_LEVEL_B

54 1080i 48.00Hz (SMPTE274) 3G Level B

NVVIOSIGNALFORMAT_2048I_48_00_SMPTE372_3G_LEVEL_B

55 2048i 48.00Hz (SMPTE372) 3G Level B

NVVIOSIGNALFORMAT_1080P_59_94_SMPTE274_3G_LEVEL_B

56 1080p 59.94Hz (SMPTE274) 3G Level B

NVVIOSIGNALFORMAT_1080I_59_94_SMPTE274_3G_LEVEL_B

57 1080i 59.94Hz (SMPTE274) 3G Level B

NVVIOSIGNALFORMAT_2048I_59_94_SMPTE372_3G_LEVEL_B

58 2048i 59.94Hz (SMPTE372) 3G Level B

NVVIOSIGNALFORMAT_1080P_29_97_SMPTE274_3G_LEVEL_B

59 1080p 29.97Hz (SMPTE274) 3G Level B

NVVIOSIGNALFORMAT_2048P_29_97_SMPTE372_3G_LEVEL_B

60 2048p 29.97Hz (SMPTE372) 3G Level B

NVVIOSIGNALFORMAT_1080P_23_98_SMPTE274_3G_LEVEL_B

61 1080p 29.98Hz (SMPTE274) 3G Level B

NVVIOSIGNALFORMAT_2048P_23_98_SMPTE372_3G_LEVEL_B

62 2048p 29.98Hz (SMPTE372) 3G Level B

NVVIOSIGNALFORMAT_1080I_47_96_SMPTE274_3G_LEVEL_B

63 1080i 47.96Hz (SMPTE274) 3G Level B

NVVIOSIGNALFORMAT_2048I_47_96_SMPTE372_3G_LEVEL_B

64 2048i 47.96Hz (SMPTE372) 3G Level B

NVVIOSIGNALFORMAT_END

65 To indicate end of signal format list

◆ _NVVIOSTATUSTYPE

enum _NVVIOSTATUSTYPE

Video Capture Status.

Enumerator

NVVIOSTATUSTYPE_IN

Input Status.

NVVIOSTATUSTYPE_OUT

Output Status.

◆ _NVVIOSYNCSOURCE

enum _NVVIOSYNCSOURCE

Synchronization source.

Enumerator

NVVIOSYNCSOURCE_SDISYNC

SDI Sync (Digital input)

NVVIOSYNCSOURCE_COMPSYNC

COMP Sync (Composite input)

◆ _NVVIOSYNCSTATUS

enum _NVVIOSYNCSTATUS

Synchronization input status.

Enumerator

NVVIOSYNCSTATUS_OFF

Sync not detected.

NVVIOSYNCSTATUS_ERROR

Error detected.

NVVIOSYNCSTATUS_SYNCLOSS

Genlock in use, format mismatch with output.

NVVIOSYNCSTATUS_COMPOSITE

Composite sync.

NVVIOSYNCSTATUS_SDI_SD

SDI sync (standard-definition)

NVVIOSYNCSTATUS_SDI_HD

SDI sync (high-definition)

◆ _NVVIOVIDEOSTANDARD

enum _NVVIOVIDEOSTANDARD

SMPTE standards format.

Enumerator

NVVIOVIDEOSTANDARD_SMPTE259

SMPTE259.

NVVIOVIDEOSTANDARD_SMPTE260

SMPTE260.

NVVIOVIDEOSTANDARD_SMPTE274

SMPTE274.

NVVIOVIDEOSTANDARD_SMPTE295

SMPTE295.

NVVIOVIDEOSTANDARD_SMPTE296

SMPTE296.

NVVIOVIDEOSTANDARD_SMPTE372

SMPTE372.

◆ _NVVIOVIDEOTYPE

enum _NVVIOVIDEOTYPE

HD or SD video type.

Enumerator

NVVIOVIDEOTYPE_SD

Standard-definition (SD)

NVVIOVIDEOTYPE_HD

High-definition (HD)

Function Documentation

◆ __nvapi_deprecated_function() [1/3]

__nvapi_deprecated_function

(

"Do not use this function - it is deprecated in release 290.

Instead,

use NvAPI_VIO_GetConfig."

)

Function: NvAPI_VIO_GetCSC

Description: This API gets the colorspace conversion parameters.

Since

Release: 190

Parameters

[in]

NvVioHandle

The caller provides the SDI device handle as input.

[out]

pCSC

Pointer to CSC parameters

Return values

:

NVAPI_NOT_SUPPORTED API is not supported

Function: NvAPI_VIO_GetGamma

Description: This API gets the gamma conversion parameters.

Since

Release: 190

Parameters

[in]

NvVioHandle

The caller provides the SDI device handle as input.

[out]

pGamma

Pointer to gamma parameters

Return values

:

NVAPI_NOT_SUPPORTED API is not supported

Function: NvAPI_VIO_GetSyncDelay

Description: This API gets the sync delay parameters.

Since

Release: 190

Parameters

[in]

NvVioHandle

The caller provides the SDI device handle as input.

[out]

pSyncDelay

Pointer to sync delay parameters

Return values

:

NVAPI_NOT_SUPPORTED API is not supported

◆ __nvapi_deprecated_function() [2/3]

__nvapi_deprecated_function

(

"Do not use this function - it is deprecated in release 290.

Instead,

use NvAPI_VIO_SetConfig."

)

Function: NvAPI_VIO_SetCSC

Description: This API sets the colorspace conversion parameters.

Since

Release: 190

Parameters

[in]

NvVioHandle

The caller provides the SDI device handle as input.

[in]

pCSC

Pointer to CSC parameters

Return values

:

NVAPI_NOT_SUPPORTED API is not supported

Function: NvAPI_VIO_SetGamma

Description: This API sets the gamma conversion parameters.

Since

Release: 190

Parameters

[in]

NvVioHandle

The caller provides the SDI device handle as input.

[in]

pGamma

Pointer to gamma parameters

Return values

:

NVAPI_NOT_SUPPORTED API is not supported

Function: NvAPI_VIO_SetSyncDelay

Description: This API sets the sync delay parameters.

Since

Release: 190

Parameters

[in]

NvVioHandle

The caller provides the SDI device handle as input.

[in]

pSyncDelay

Pointer to sync delay parameters

Return values

:

NVAPI_NOT_SUPPORTED API is not supported

◆ __nvapi_deprecated_function() [3/3]

__nvapi_deprecated_function

(

"Do not use this function - it is deprecated in release 440."

)

Function: NvAPI_VIO_Open

Description: This API opens the graphics adapter for video I/O operations using the OpenGL application interface. Read operations are permitted in this mode by multiple clients, but Write operations are application exclusive.

Since

Release: 190

Parameters

[in]

NvVioHandle

The caller provides the SDI output device handle as input.

[in]

vioClass

Class interface (NVVIOCLASS_* value)

[in]

ownerType

Specify NVVIOOWNERTYPE_APPLICATION or NVVIOOWNERTYPE_DESKTOP.

Return values

:

NVAPI_NOT_SUPPORTED API is not supported

Function: NvAPI_VIO_Close

Description: This API closes the graphics adapter for graphics-to-video operations using the OpenGL application interface. Closing an OpenGL handle releases the device.

Since

Release: 190

Parameters

[in]

NvVioHandle

The caller provides the SDI output device handle as input.

[in]

bRelease

boolean value to either keep or release ownership

Return values

:

NVAPI_NOT_SUPPORTED API is not supported

Function: NvAPI_VIO_Status

Description: This API gets the Video I/O LED status.

Since

Release: 190

Parameters

[in]

NvVioHandle

The caller provides the SDI device handle as input.

[out]

pStatus

Return pointer to NVVIOSTATUS

Return values

:

NVAPI_NOT_SUPPORTED API is not supported

Function: NvAPI_VIO_SyncFormatDetect

Description: This API detects the Video I/O incoming sync video format.

Since

Release: 190

Parameters

[in]

NvVioHandle

The caller provides the SDI device handle as input.

[out]

pWait

Pointer to receive how many milliseconds will lapse before VIOStatus returns the detected syncFormat.

Return values

:

NVAPI_NOT_SUPPORTED API is not supported

Function: NvAPI_VIO_GetConfig

Description: This API gets the graphics-to-video configuration.

Since

Release: 190

Parameters

[in]

NvVioHandle

The caller provides the SDI device handle as input.

[out]

pConfig

Pointer to the graphics-to-video configuration

Return values

:

NVAPI_NOT_SUPPORTED API is not supported

Function: NvAPI_VIO_SetConfig

Description: This API sets the graphics-to-video configuration.

Since

Release: 190

Parameters

[in]

NvVioHandle

The caller provides the SDI device handle as input.

[in]

pConfig

Pointer to Graphics-to-Video configuration

Return values

:

NVAPI_NOT_SUPPORTED API is not supported

:

NVAPI_NOT_SUPPORTED API is not supported

Function: NvAPI_VIO_IsRunning

Description: This API determines if Video I/O is running.

Since

Release: 190

Parameters

[in]

NvVioHandle[IN]

The caller provides the SDI device handle as input.

Return values

:

NVAPI_NOT_SUPPORTED API is not supported

Function: NvAPI_VIO_Start

Description: This API starts Video I/O. This API should be called for NVVIOOWNERTYPE_DESKTOP only and will not work for OGL applications.

Since

Release: 190

Parameters

[in]

NvVioHandle[IN]

The caller provides the SDI device handle as input.

Return values

:

NVAPI_NOT_SUPPORTED API is not supported

Function: NvAPI_VIO_Stop

Description: This API stops Video I/O. This API should be called for NVVIOOWNERTYPE_DESKTOP only and will not work for OGL applications.

Since

Release: 190

Parameters

[in]

NvVioHandle[IN]

The caller provides the SDI device handle as input.

Return values

:

NVAPI_NOT_SUPPORTED API is not supported

Function: NvAPI_VIO_IsFrameLockModeCompatible

Description: This API checks whether modes are compatible in frame lock mode.

Since

Release: 190

Parameters

[in]

NvVioHandle

The caller provides the SDI device handle as input.

[in]

srcEnumIndex

Source Enumeration index

[in]

destEnumIndex

Destination Enumeration index

[out]

pbCompatible

Pointer to receive compatibility

Return values

:

NVAPI_NOT_SUPPORTED API is not supported

Function: NvAPI_VIO_EnumDevices

Description: This API enumerate all VIO devices connected to the system.

Since

Release: 190

Parameters

[out]

NvVioHandle

User passes the pointer of NvVioHandle[] array to get handles to all the connected video I/O devices.

[out]

vioDeviceCount

User gets total number of VIO devices connected to the system.

Return values

:

NVAPI_NOT_SUPPORTED API is not supported

Function: NvAPI_VIO_QueryTopology

Description: This API queries the valid SDI topologies.

Since

Release: 190

Parameters

[out]

pNvVIOTopology

User passes the pointer to NVVIOTOPOLOGY to fetch all valid SDI topologies.

Return values

:

NVAPI_NOT_SUPPORTED API is not supported

Function: NvAPI_VIO_EnumSignalFormats

Description: This API enumerates signal formats supported by Video I/O.

Since

Release: 190

Parameters

[in]

NvVioHandle

The caller provides the SDI device handle as input.

[in]

enumIndex

Enumeration index

[out]

pSignalFormatDetail

Pointer to receive detail or NULL

Return values

:

NVAPI_NOT_SUPPORTED API is not supported

Function: NvAPI_VIO_EnumDataFormats

Description: This API enumerates data formats supported by Video I/O.

Since

Release: 190

Parameters

[in]

NvVioHandle

The caller provides the SDI device handle as input.

[in]

enumIndex

Enumeration index

[out]

pDataFormatDetail

Pointer to receive detail or NULL

Return values

:

NVAPI_NOT_SUPPORTED API is not supported

◆ DispatchGraphics()

void INvAPI_DirectD3D12GraphicsCommandList::DispatchGraphics

(

NvU32

numDispatches

)

◆ GetID3D12GraphicsCommandList()

virtual ID3D12GraphicsCommandList * INvAPI_DirectD3D12GraphicsCommandList::GetID3D12GraphicsCommandList

(

)

const

pure virtual

◆ IsValid()

virtual bool INvAPI_DirectD3D12GraphicsCommandList::IsValid

(

)

const

pure virtual

◆ NvAPI_GPU_ClientRegisterForUtilizationSampleUpdates()

NVAPI_INTERFACE NvAPI_GPU_ClientRegisterForUtilizationSampleUpdates

(

__in NvPhysicalGpuHandle

hPhysicalGpu,

__in NV_GPU_CLIENT_UTILIZATION_PERIODIC_CALLBACK_SETTINGS *

pCallbackSettings

)

◆ SetMarker()

void INvAPI_DirectD3D12GraphicsCommandList::SetMarker

(

void *

pMarkerData,

NvU32

markerSize

)

Variable Documentation

◆ [union]

union { ... } NV_GPU_ARCH_INFO_V2

◆ [union]

union { ... } NV_GPU_ARCH_INFO_V2

◆ [union]

union { ... } NV_GPU_ARCH_INFO_V2

◆ [union]

union { ... } _NV_DISPLAYCONFIG_PATH_INFO_V2

◆ [union]

union { ... } NV_TIMING_FLAG

◆ [union]

union { ... } NV_D3D11_META_COMMAND_RESOURCE

◆ [union]

union { ... } _NV_MULTIGPU_CAPS_V2

◆ [union]

union { ... } _NV_D3D11_SHADING_RATE_RESOURCE_VIEW_DESC_V1

◆ [union]

union { ... } _NV_FOVEATED_RENDERING_UPDATE_GAZE_DATA_PARAMS

◆ [union]

union { ... } _NV_SMP_ASSIST_GET_CONSTANTS_V3

◆ [union]

union { ... } _NV_SMP_ASSIST_GET_CONSTANTS_V3

◆ [union]

union { ... } _NV_SMP_ASSIST_SETUP_PARAMS_V1

◆ [union]

union { ... } _NVAPI_D3D12_RAYTRACING_GEOMETRY_DESC_EX

◆ [union]

union { ... } _NVAPI_D3D12_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_INPUTS_EX

◆ [union]

union { ... } _NV_D3D12_WORKSTATION_FEATURE_PROPERTIES

◆ [union]

union { ... } _NVDRS_SETTING_VALUES

◆ [union]

union { ... } _NVDRS_SETTING_V1

◆ [union]

union { ... } _NVDRS_SETTING_V1

◆ aabbs [1/2]

D3D12_RAYTRACING_GEOMETRY_AABBS_DESC _NVAPI_D3D12_RAYTRACING_GEOMETRY_DESC_EX::aabbs

Describes AABB geometry if type is NVAPI_D3D12_RAYTRACING_GEOMETRY_TYPE_PROCEDURAL_PRIMITIVE_AABBS_EX. Otherwise, this parameter is unused (space repurposed in a union).

◆ [] [2/2]

D3D12_RAYTRACING_GEOMETRY_AABBS_DESC { ... } ::aabbs

Describes AABB geometry if type is NVAPI_D3D12_RAYTRACING_GEOMETRY_TYPE_PROCEDURAL_PRIMITIVE_AABBS_EX. Otherwise, this parameter is unused (space repurposed in a union).

◆ acceleratePrimaryDisplay [1/2]

NvU32 _NV_MOSAIC_GRID_TOPO_V1::acceleratePrimaryDisplay

Enable SLI acceleration on the primary display while in single-wide mode (For Immersive Gaming only). Will not be persisted. Value undefined on get.

◆ acceleratePrimaryDisplay [2/2]

NvU32 _NV_MOSAIC_GRID_TOPO_V2::acceleratePrimaryDisplay

Enable SLI acceleration on the primary display while in single-wide mode (For Immersive Gaming only). Will not be persisted. Value undefined on get.

◆ Activation [1/2]

NV_META_COMMAND_OPTIONAL_ACTIVATION_DESC NV_META_COMMAND_CREATE_CONVOLUTION_EX_DESC::Activation

◆ Activation [2/2]

NV_META_COMMAND_OPTIONAL_ACTIVATION_DESC NV_META_COMMAND_CREATE_GEMM_DESC::Activation

◆ activeFormatAspectRatio

NvU32 NV_INFOFRAME_VIDEO::activeFormatAspectRatio

◆ activeFormatInfoPresent

NvU32 NV_INFOFRAME_VIDEO::activeFormatInfoPresent

◆ adapterCaps

NvU32 _NVVIOCAPS::adapterCaps

Graphics adapter capabilities (NVVIOCAPS_* mask)

◆ adapterClass

NvU32 _NVVIOCAPS::adapterClass

Graphics adapter classes (NVVIOCLASS_SDI mask)

◆ adapterName

NvAPI_String _NVVIOCAPS::adapterName

Graphics adapter name.

◆ adapterType [1/2]

NV_ADAPTER_TYPE _NV_PHYSICAL_GPU_HANDLE_DATA::adapterType

◆ adapterType [2/2]

NV_ADAPTER_TYPE _NV_LOGICAL_GPU_HANDLE_DATA::adapterType

◆ [struct]

struct { ... } NV_GPU_ECC_ERROR_INFO::aggregate

◆ Alpha

float NV_META_COMMAND_CREATE_GEMM_DESC::Alpha

◆ Alpha1

float NV_META_COMMAND_CREATE_CONVOLUTION_EX_DESC::Alpha1

◆ Alpha1Resource [1/2]

NV_D3D11_META_COMMAND_RESOURCE NV_D3D11_META_COMMAND_EXECUTE_CONVOLUTION_EX_DESC::Alpha1Resource

◆ Alpha1Resource [2/2]

D3D12_GPU_VIRTUAL_ADDRESS NV_D3D12_META_COMMAND_EXECUTE_CONVOLUTION_EX_DESC::Alpha1Resource

◆ Alpha2

float NV_META_COMMAND_CREATE_CONVOLUTION_EX_DESC::Alpha2

◆ Alpha2Resource [1/2]

NV_D3D11_META_COMMAND_RESOURCE NV_D3D11_META_COMMAND_EXECUTE_CONVOLUTION_EX_DESC::Alpha2Resource

◆ Alpha2Resource [2/2]

D3D12_GPU_VIRTUAL_ADDRESS NV_D3D12_META_COMMAND_EXECUTE_CONVOLUTION_EX_DESC::Alpha2Resource

◆ ancParityComputation [1/2]

NVVIOANCPARITYCOMPUTATION _NVVIOOUTPUTCONFIG_V2::ancParityComputation

Enable HW ANC parity bit computation (auto/on/off)

◆ ancParityComputation [2/2]

NVVIOANCPARITYCOMPUTATION _NVVIOOUTPUTCONFIG_V3::ancParityComputation

Enable HW ANC parity bit computation (auto/on/off)

◆ AntialiasedLineEnable

BOOL NvAPI_D3D11_RASTERIZER_DESC_EX::AntialiasedLineEnable

◆ [] [1/2]

NvU16 { ... } ::application_version

Application version of HDR10+ Vendor Specific Video Data Block.

◆ application_version [2/2]

NvU16 _NV_HDR_CAPABILITIES_V3::application_version

Application version of HDR10+ Vendor Specific Video Data Block.

◆ applyWithBezelCorrect [1/2]

NvU32 _NV_MOSAIC_GRID_TOPO_V1::applyWithBezelCorrect

When enabling and doing the modeset, do we switch to the bezel-corrected resolution.

◆ applyWithBezelCorrect [2/2]

NvU32 _NV_MOSAIC_GRID_TOPO_V2::applyWithBezelCorrect

When enabling and doing the modeset, do we switch to the bezel-corrected resolution.

◆ appName [1/4]

NvAPI_UnicodeString _NVDRS_APPLICATION_V1::appName

String name of the Application.

◆ appName [2/4]

NvAPI_UnicodeString _NVDRS_APPLICATION_V2::appName

String name of the Application.

◆ appName [3/4]

NvAPI_UnicodeString _NVDRS_APPLICATION_V3::appName

String name of the Application.

◆ appName [4/4]

NvAPI_UnicodeString _NVDRS_APPLICATION_V4::appName

String name of the Application.

◆ architecture [1/3]

NvU32 NV_GPU_ARCH_INFO_V1::architecture

◆ [] [2/3]

NvU32 { ... } ::architecture

architecture and architecture_id are the same. The former is NvU32 while the latter is an enum made for readability.

◆ architecture [3/3]

NvU32 NV_GPU_ARCH_INFO_V2::architecture

architecture and architecture_id are the same. The former is NvU32 while the latter is an enum made for readability.

◆ [] [1/2]

NV_GPU_ARCHITECTURE_ID { ... } ::architecture_id

specifies the architecture level for the GPU.

◆ architecture_id [2/2]

NV_GPU_ARCHITECTURE_ID NV_GPU_ARCH_INFO_V2::architecture_id

specifies the architecture level for the GPU.

◆ AResource [1/2]

NV_D3D11_META_COMMAND_RESOURCE NV_D3D11_META_COMMAND_EXECUTE_GEMM_DESC::AResource

◆ AResource [2/2]

NvU64 NV_D3D12_META_COMMAND_EXECUTE_GEMM_DESC::AResource

◆ ArraySize

UINT _NV_TEX2D_ARRAY_SRRV::ArraySize

◆ aspect

NvU32 tagNV_TIMINGEXT::aspect

Display aspect ratio Hi(aspect):horizontal-aspect, Low(aspect):vertical-aspect.

◆ ATimems

NvU16 _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR::ATimems

Time in ms to remain at color A before color A to color B transition.

◆ Attribute [1/3]

NV_GPU_ILLUMINATION_ATTRIB _NV_GPU_QUERY_ILLUMINATION_SUPPORT_PARM_V1::Attribute

An enumeration value specifying the Illumination attribute to be querried. refer to enum NV_GPU_ILLUMINATION_ATTRIB.

◆ Attribute [2/3]

NV_GPU_ILLUMINATION_ATTRIB _NV_GPU_GET_ILLUMINATION_PARM_V1::Attribute

An enumeration value specifying the Illumination attribute to be querried. refer to enum NV_GPU_ILLUMINATION_ATTRIB.

◆ Attribute [3/3]

NV_GPU_ILLUMINATION_ATTRIB _NV_GPU_SET_ILLUMINATION_PARM_V1::Attribute

An enumeration value specifying the Illumination attribute to be querried. refer to enum NV_GPU_ILLUMINATION_ATTRIB.

◆ [] [1/2]

NV_INFOFRAME_AUDIO { ... } ::audio

◆ audio [2/2]

NV_INFOFRAME_AUDIO NV_INFOFRAME_DATA::audio

◆ audioLatency

NvU8 _NV_MONITOR_CAPS_VSDB::audioLatency

Byte 7.

◆ backendBitDepths

NV_DP_BPC _NV_MONITOR_COLOR_DATA::backendBitDepths

One of the supported bit depths.

◆ backlt_min_luma [1/4]

NvU32 _NV_HDR_CAPABILITIES_V2::backlt_min_luma

It is the level for Backlt min luminance value.

◆ [] [2/4]

NvU32 { ... } ::backlt_min_luma

It is the level for Backlt min luminance value.

◆ backlt_min_luma [3/4]

NvU32 _NV_HDR_CAPABILITIES_V3::backlt_min_luma

It is the level for Backlt min luminance value (reserved = 0x3 in latest DV spec).

◆ [] [4/4]

NvU32 { ... } ::backlt_min_luma

It is the level for Backlt min luminance value (reserved = 0x3 in latest DV spec).

◆ barInfo

NvU32 NV_INFOFRAME_VIDEO::barInfo

◆ baseMosaic [1/2]

NvU32 _NV_MOSAIC_GRID_TOPO_V1::baseMosaic

Enable as Base Mosaic (Panoramic) instead of Mosaic SLI (for NVS and Quadro-boards only)

◆ baseMosaic [2/2]

NvU32 _NV_MOSAIC_GRID_TOPO_V2::baseMosaic

Enable as Base Mosaic (Panoramic) instead of Mosaic SLI (for NVS and Quadro-boards only)

◆ baseVersion

NvU32 NVAPI_D3D12_PSO_EXTENSION_DESC_V1::baseVersion

◆ baseVoltages [1/4]

NV_GPU_PSTATE20_BASE_VOLTAGE_ENTRY_V1 NV_GPU_PERF_PSTATES20_INFO_V1::baseVoltages[NVAPI_MAX_GPU_PSTATE20_BASE_VOLTAGES]

Array of baseVoltage entries Valid index range is 0 to numBaseVoltages-1

◆ [] [2/4]

NV_GPU_PSTATE20_BASE_VOLTAGE_ENTRY_V1 { ... } ::baseVoltages[NVAPI_MAX_GPU_PSTATE20_BASE_VOLTAGES]

Array of baseVoltage entries Valid index range is 0 to numBaseVoltages-1

◆ [] [3/4]

NV_GPU_PSTATE20_BASE_VOLTAGE_ENTRY_V1 { ... } ::baseVoltages[NVAPI_MAX_GPU_PSTATE20_BASE_VOLTAGES]

Array of baseVoltage entries Valid index range is 0 to numBaseVoltages-1

◆ baseVoltages [4/4]

NV_GPU_PSTATE20_BASE_VOLTAGE_ENTRY_V1 _NV_GPU_PERF_PSTATES20_INFO_V2::baseVoltages[NVAPI_MAX_GPU_PSTATE20_BASE_VOLTAGES]

Array of baseVoltage entries Valid index range is 0 to numBaseVoltages-1

◆ bCplVsyncOn

NvBool _NV_GET_SLEEP_STATUS_PARAMS::bCplVsyncOn

(OUT) Is Control Panel overriding VSYNC ON?

◆ bDefault

NvU32 _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_PARAMS_V1::bDefault

Bit field specifying the set of values to retrieve or set

default (NV_TRUE)

currently active (NV_FALSE).

◆ bDisable

NvU32 _NV_SET_REFLEX_SYNC_PARAMS::bDisable

(IN) Disable Reflex Sync

◆ bDisableAdaptiveSync [1/2]

NvU32 _NV_GET_ADAPTIVE_SYNC_DATA_V1::bDisableAdaptiveSync

[out] Indicates if adaptive sync is disabled on the display.

◆ bDisableAdaptiveSync [2/2]

NvU32 _NV_SET_ADAPTIVE_SYNC_DATA_V1::bDisableAdaptiveSync

[in] Indicates if adaptive sync is disabled on the display.

◆ bDisableFrameSplitting [1/2]

NvU32 _NV_GET_ADAPTIVE_SYNC_DATA_V1::bDisableFrameSplitting

[out] Indicates if frame splitting is disabled on the display.

◆ bDisableFrameSplitting [2/2]

NvU32 _NV_SET_ADAPTIVE_SYNC_DATA_V1::bDisableFrameSplitting

[in] Indicates if Frame Splitting should be disabled.

◆ bEnable

NvU32 _NV_SET_REFLEX_SYNC_PARAMS::bEnable

(IN) Enable Reflex Sync

◆ bEnabled [1/2]

NvU32 _NV_SCANOUT_INTENSITY_STATE_DATA::bEnabled

intensity is enabled or not

◆ bEnabled [2/2]

NvU32 _NV_SCANOUT_WARPING_STATE_DATA::bEnabled

warping is enabled or not

◆ bEnableSuperSamplingPredicationForVRS

NvU32 NvAPI_D3D11_CREATE_PIXEL_SHADER_EX_V2::bEnableSuperSamplingPredicationForVRS

◆ bEnableSuperSamplingPredicationForVRSAllAttributes

NvU32 NvAPI_D3D11_CREATE_PIXEL_SHADER_EX_V2::bEnableSuperSamplingPredicationForVRSAllAttributes

◆ Beta

float NV_META_COMMAND_CREATE_GEMM_DESC::Beta

◆ bExclusiveScissorRectsSupported [1/3]

NvU32 _NV_D3D1x_GRAPHICS_CAPS_V1::bExclusiveScissorRectsSupported

(OUT) Outputs whether Exclusive Scissor Rects are supported or not

◆ bExclusiveScissorRectsSupported [2/3]

NvU32 _NV_D3D1x_GRAPHICS_CAPS_V2::bExclusiveScissorRectsSupported

(OUT) Outputs whether Exclusive Scissor Rects are supported or not

◆ bExclusiveScissorRectsSupported [3/3]

NvU32 _NV_D3D12_GRAPHICS_CAPS_V1::bExclusiveScissorRectsSupported

(OUT) Outputs whether Exclusive Scissor Rects are supported or not

◆ bFastUAVClearSupported [1/2]

NvU32 _NV_D3D1x_GRAPHICS_CAPS_V2::bFastUAVClearSupported

(OUT) Outputs whether UAVClear is implemented using ZBC rather than compute shader

◆ bFastUAVClearSupported [2/2]

NvU32 _NV_D3D12_GRAPHICS_CAPS_V1::bFastUAVClearSupported

(OUT) Outputs whether UAVClear is implemented using ZBC rather than compute shader

◆ bFocusDisplay

NvU32 NV_DISPLAY_PATH::bFocusDisplay

(IN) If set, this display path should have the focus after the GPU topology change

◆ [] [1/3]

NvU32 { ... } ::bForceModeSet

(IN) Used only on Win7 and higher during a call to NvAPI_SetView(). Turns off optimization & forces OS to set supplied mode.

◆ bForceModeSet [2/3]

NvU32 NV_VIEW_TARGET_INFO::bForceModeSet

(IN) Used only on Win7 and higher during a call to NvAPI_SetView(). Turns off optimization & forces OS to set supplied mode.

◆ bForceModeSet [3/3]

NvU32 NV_DISPLAY_PATH::bForceModeSet

(IN) Used only on Win7 and higher during a call to NvAPI_SetViewEx(). Turns off optimization & forces OS to set supplied mode.

◆ bFsVrr

NvBool _NV_GET_SLEEP_STATUS_PARAMS::bFsVrr

(OUT) Is fullscreen VRR enabled?

◆ bGDIPrimary [1/4]

NvU32 NV_VIEW_TARGET_INFO::bGDIPrimary

(IN/OUT) Indicates if this is the desktop GDI primary.

◆ [] [2/4]

NvU32 { ... } ::bGDIPrimary

(IN/OUT) Indicates if this is the desktop GDI primary.

◆ bGDIPrimary [3/4]

NvU32 NV_DISPLAY_PATH::bGDIPrimary

(IN/OUT) Indicates if this is the desktop GDI primary.

◆ bGDIPrimary [4/4]

NvU32 _NV_DISPLAYCONFIG_SOURCE_MODE_INFO_V1::bGDIPrimary

◆ bHouseSync [1/2]

NvU32 _NV_GSYNC_STATUS_PARAMS_V1::bHouseSync

Is house sync connected?

◆ bHouseSync [2/2]

NvU32 _NV_GSYNC_STATUS_PARAMS_V2::bHouseSync

Is house sync connected?

◆ BiasResource [1/2]

NV_D3D11_META_COMMAND_RESOURCE NV_D3D11_META_COMMAND_EXECUTE_CONVOLUTION_EX_DESC::BiasResource

◆ BiasResource [2/2]

D3D12_GPU_VIRTUAL_ADDRESS NV_D3D12_META_COMMAND_EXECUTE_CONVOLUTION_EX_DESC::BiasResource

◆ [] [1/2]

NVDRS_BINARY_SETTING { ... } ::binaryCurrentValue

Accessing current Binary value of this setting. Must be allocated by caller with valueLength specifying buffer size, or only valueLength will be filled in.

◆ binaryCurrentValue [2/2]

NVDRS_BINARY_SETTING _NVDRS_SETTING_V1::binaryCurrentValue

Accessing current Binary value of this setting. Must be allocated by caller with valueLength specifying buffer size, or only valueLength will be filled in.

◆ [] [1/2]

NVDRS_BINARY_SETTING { ... } ::binaryDefaultValue

Accessing default Binary value of this setting. Must be allocated by caller with valueLength specifying buffer size, or only valueLength will be filled in.

◆ binaryDefaultValue [2/2]

NVDRS_BINARY_SETTING _NVDRS_SETTING_VALUES::binaryDefaultValue

Accessing default Binary value of this setting. Must be allocated by caller with valueLength specifying buffer size, or only valueLength will be filled in.

◆ binaryPredefinedValue [1/2]

NVDRS_BINARY_SETTING _NVDRS_SETTING_V1::binaryPredefinedValue

Accessing default Binary value of this setting. Must be allocated by caller with valueLength specifying buffer size, or only valueLength will be filled in.

◆ [] [2/2]

NVDRS_BINARY_SETTING { ... } ::binaryPredefinedValue

Accessing default Binary value of this setting. Must be allocated by caller with valueLength specifying buffer size, or only valueLength will be filled in.

◆ [] [1/2]

NVDRS_BINARY_SETTING { ... } ::binaryValue

All possible Binary values for a setting.

◆ binaryValue [2/2]

NVDRS_BINARY_SETTING _NVDRS_SETTING_VALUES::binaryValue

All possible Binary values for a setting.

◆ bInSaccade

BOOL _NV_FOVEATED_RENDERING_GAZE_DATA_PER_EYE::bInSaccade

(IN) Use flag NV_GAZE_EYE_SACCADE_DATA_VALID. Denotes whether eye is currently in saccade movement or not.

◆ [] [1/2]

NvU32 { ... } ::bInterlaced

(IN/OUT) Indicates if the timing being used on this monitor is interlaced.

◆ bInterlaced [2/2]

NvU32 NV_VIEW_TARGET_INFO::bInterlaced

(IN/OUT) Indicates if the timing being used on this monitor is interlaced.

◆ bInternalSlave

NvU32 _NV_GSYNC_STATUS_PARAMS_V2::bInternalSlave

Valid only for P2061 board. If set to 1, it means that this P2061 board receives input from another P2061 board.

◆ bIsDCHDriver [1/2]

NvU32 _NV_DISPLAY_DRIVER_INFO::bIsDCHDriver

Contains the driver DCH status after successful return. Value of 1 means that this is DCH driver. Value of 0 means that this is not a DCH driver (NVAPI may be unable to query the DCH status of the driver due to some registry API errors, in that case the API will return with NVAPI_ERROR)

◆ bIsDCHDriver [2/2]

NvU32 _NV_DISPLAY_DRIVER_INFO_V2::bIsDCHDriver

Contains the driver DCH status after successful return. Value of 1 means that this is DCH driver. Value of 0 means that this is not a DCH driver (NVAPI may be unable to query the DCH status of the driver due to some registry API errors, in that case the API will return with NVAPI_ERROR)

◆ bIsDDCPort [1/3]

NvU8 NV_I2C_INFO_V1::bIsDDCPort

This flag indicates either the DDC port (TRUE) or the communication port (FALSE) of the concerned display.

◆ bIsDDCPort [2/3]

NvU8 NV_I2C_INFO_V2::bIsDDCPort

This flag indicates either the DDC port (TRUE) or the communication port (FALSE) of the concerned display.

◆ bIsDDCPort [3/3]

NvU8 NV_I2C_INFO_V3::bIsDDCPort

This flag indicates either the DDC port (TRUE) or the communication port (FALSE) of the concerned display.

◆ bIsDisplayInVRRMode

NvU32 _NV_GET_VRR_INFO_V1::bIsDisplayInVRRMode

[out] Set to true if the display is in VRR Mode.

◆ bIsEditable [1/6]

NvU32 NV_GPU_PSTATE20_CLOCK_ENTRY_V1::bIsEditable

◆ bIsEditable [2/6]

NvU32 NV_GPU_PSTATE20_BASE_VOLTAGE_ENTRY_V1::bIsEditable

◆ bIsEditable [3/6]

NvU32 NV_GPU_PERF_PSTATES20_INFO_V1::bIsEditable

◆ [] [4/6]

NvU32 { ... } ::bIsEditable

◆ bIsEditable [5/6]

NvU32 _NV_GPU_PERF_PSTATES20_INFO_V2::bIsEditable

◆ [] [6/6]

NvU32 { ... } ::bIsEditable

◆ bIsExternalGpu [1/2]

NvU32 _NV_GPU_INFO_V1::bIsExternalGpu

This flag is set for external GPU.

◆ bIsExternalGpu [2/2]

NvU32 _NV_GPU_INFO_V2::bIsExternalGpu

This flag is set for external GPU.

◆ bIsMulDivSupported

NvU32 _NV_GSYNC_CAPABILITIES_V3::bIsMulDivSupported

Indicates if multiplication/division of the frequency of house sync signal is supported.

◆ bIsNVIDIAGameReadyPackage [1/2]

NvU32 _NV_DISPLAY_DRIVER_INFO::bIsNVIDIAGameReadyPackage

On successful return, this field provides information about whether the installed driver is from an NVIDIA Game Ready Driver package. Value of 1 means that this driver is from the NVIDIA Game Ready Driver package.

◆ bIsNVIDIAGameReadyPackage [2/2]

NvU32 _NV_DISPLAY_DRIVER_INFO_V2::bIsNVIDIAGameReadyPackage

On successful return, this field provides information about whether the installed driver is from an NVIDIA Game Ready Driver package. Value of 1 means that this driver is from the NVIDIA Game Ready Driver package.

◆ bIsNVIDIARTXNewFeatureBranchPackage [1/2]

NvU32 _NV_DISPLAY_DRIVER_INFO::bIsNVIDIARTXNewFeatureBranchPackage

On successful return, this field confirms whether the installed driver package is from an NVIDIA RTX New Feature Branch. This driver typically gives access to new features, bug fixes, new operating system support, and other driver enhancements offered between NVIDIA RTX Enterprise Production Branch releases. Support duration for NVIDIA RTX New Feature Branches is shorter than that for NVIDIA RTX Enterprise Production Branches. Value of 1 means that this driver is from the NVIDIA RTX New Feature Branch package.

◆ bIsNVIDIARTXNewFeatureBranchPackage [2/2]

NvU32 _NV_DISPLAY_DRIVER_INFO_V2::bIsNVIDIARTXNewFeatureBranchPackage

On successful return, this field confirms whether the installed driver package is from an NVIDIA RTX New Feature Branch. This driver typically gives access to new features, bug fixes, new operating system support, and other driver enhancements offered between NVIDIA RTX Enterprise Production Branch releases. Support duration for NVIDIA RTX New Feature Branches is shorter than that for NVIDIA RTX Enterprise Production Branches. Value of 1 means that this driver is from the NVIDIA RTX New Feature Branch package.

◆ bIsNVIDIARTXProductionBranchPackage [1/2]

NvU32 _NV_DISPLAY_DRIVER_INFO::bIsNVIDIARTXProductionBranchPackage

On successful return, this field confirms whether the installed driver package is from an NVIDIA RTX Enterprise Production Branch which offers ISV certifications, long life-cycle support, regular security updates, and access to the same functionality as corresponding NVIDIA Studio Driver Packages (i.e., of the same driver version number). Value of 1 means that this driver is from the NVIDIA RTX Enterprise Production Branch package.

◆ bIsNVIDIARTXProductionBranchPackage [2/2]

NvU32 _NV_DISPLAY_DRIVER_INFO_V2::bIsNVIDIARTXProductionBranchPackage

On successful return, this field confirms whether the installed driver package is from an NVIDIA RTX Enterprise Production Branch which offers ISV certifications, long life-cycle support, regular security updates, and access to the same functionality as corresponding NVIDIA Studio Driver Packages (i.e., of the same driver version number). Value of 1 means that this driver is from the NVIDIA RTX Enterprise Production Branch package.

◆ bIsNVIDIAStudioPackage [1/2]

NvU32 _NV_DISPLAY_DRIVER_INFO::bIsNVIDIAStudioPackage

On successful return, this field provides information about whether the installed driver is from an NVIDIA Studio Driver package. Value of 1 means that this driver is from the NVIDIA Studio Driver package.

◆ bIsNVIDIAStudioPackage [2/2]

NvU32 _NV_DISPLAY_DRIVER_INFO_V2::bIsNVIDIAStudioPackage

On successful return, this field provides information about whether the installed driver is from an NVIDIA Studio Driver package. Value of 1 means that this driver is from the NVIDIA Studio Driver package.

◆ bIsPortIdSet

NvU32 NV_I2C_INFO_V3::bIsPortIdSet

set this flag on if and only if portid value is set

◆ [] [1/6]

NvU32 { ... } ::bIsPresent

Set if this utilization domain is present on this GPU.

◆ bIsPresent [2/6]

NvU32 NV_GPU_DYNAMIC_PSTATES_INFO_EX::bIsPresent

Set if this utilization domain is present on this GPU.

◆ bIsPresent [3/6]

NvU32 NV_GPU_CLOCK_FREQUENCIES_V1::bIsPresent

Set if this domain is present on this GPU.

◆ [] [4/6]

NvU32 { ... } ::bIsPresent

Set if this domain is present on this GPU.

◆ [] [5/6]

NvU32 { ... } ::bIsPresent

Set if this domain is present on this GPU.

◆ bIsPresent [6/6]

NvU32 NV_GPU_CLOCK_FREQUENCIES_V2::bIsPresent

Set if this domain is present on this GPU.

◆ bIsStereoSynced

NvU32 _NV_GSYNC_STATUS::bIsStereoSynced

Does the phase of the timing signal from the GPU = the phase of the master sync signal?

◆ bIsSynced

NvU32 _NV_GSYNC_STATUS::bIsSynced

Is timing in sync?

◆ bIsSyncSignalAvailable

NvU32 _NV_GSYNC_STATUS::bIsSyncSignalAvailable

Is the sync signal available?

◆ bIsValidInfo

NvU8 _NV_MONITOR_CAPABILITIES_V1::bIsValidInfo

Boolean : Returns invalid if requested info is not present such as VCDB not present.

◆ bIsVRREnabled

NvU32 _NV_GET_VRR_INFO_V1::bIsVRREnabled

[out] Set if VRR Mode is currently active on given display.

◆ bIsVRRIndicatorEnabled

NvU32 _NV_GET_VRR_INFO_V1::bIsVRRIndicatorEnabled

[out] Set to true if the VRR indicator is enabled. This can be done through the NVIDIA Control Panel.

◆ bIsVRRPossible

NvU32 _NV_GET_VRR_INFO_V1::bIsVRRPossible

[out] Set to true if VRR Mode is possible on the given display.

◆ bIsVRRRequested

NvU32 _NV_GET_VRR_INFO_V1::bIsVRRRequested

[out] Set to true if VRR Mode is requested for the given display.

◆ bitsPerComponent [1/2]

NVVIOBITSPERCOMPONENT _NVVIOCHANNELSTATUS::bitsPerComponent

Bits per component.

◆ bitsPerComponent [2/2]

NvU32 _NVVIOSTREAM::bitsPerComponent

Bits per component.

◆ blackList

NvU32 NV_INFOFRAME_PROPERTY::blackList

◆ bLateLatchSupported

NvU32 _NV_QUERY_LATELATCH_SUPPORT_PARAMS::bLateLatchSupported

(OUT) LateLatch supported

◆ bldChangeListNum

NvU32 NV_DISPLAY_DRIVER_VERSION::bldChangeListNum

◆ blendingTexture [1/2]

float* NV_SCANOUT_INTENSITY_DATA_V1::blendingTexture

array of floating values building an intensity RGB texture

◆ blendingTexture [2/2]

float* NV_SCANOUT_INTENSITY_DATA_V2::blendingTexture

array of floating values building an intensity RGB texture

◆ blockDim [1/2]

NVAPI_DIM3 _NVAPI_CU_KERNEL_LAUNCH_PARAMS::blockDim

◆ blockDim [2/2]

NVAPI_DIM3 _NVAPI_CU_KERNEL_LAUNCH_PARAMS_EX::blockDim

◆ blockX

NvU32 NVAPI_D3D12_CREATE_CUBIN_SHADER_PARAMS::blockX

[in] size of CTA / thread block/group

◆ blockY

NvU32 NVAPI_D3D12_CREATE_CUBIN_SHADER_PARAMS::blockY

[in]

◆ blockZ

NvU32 NVAPI_D3D12_CREATE_CUBIN_SHADER_PARAMS::blockZ

[in]

◆ bLowLatencyBoost

NvBool _NV_SET_SLEEP_MODE_PARAMS::bLowLatencyBoost

(IN) Request maximum GPU clock frequency regardless of workload.

◆ bLowLatencyMode [1/2]

NvBool _NV_GET_SLEEP_STATUS_PARAMS::bLowLatencyMode

(OUT) Is low latency mode enabled?

◆ bLowLatencyMode [2/2]

NvBool _NV_SET_SLEEP_MODE_PARAMS::bLowLatencyMode

(IN) Low latency mode enable/disable.

◆ bModifiedWSupported

NvU32 _NV_QUERY_MODIFIED_W_SUPPORT_PARAMS::bModifiedWSupported

◆ bMultiViewSupported

NvU32 _NV_QUERY_MULTIVIEW_SUPPORT_PARAMS_V1::bMultiViewSupported

◆ bNameIsAvailable

NvU32 _NV_MANAGED_DEDICATED_DISPLAY_METADATA::bNameIsAvailable

[out] Query call: 1 in case the information in variable/field "name" is valid (has been set before). 0 otherwise.

◆ boardId [1/3]

NvU32 _NV_GSYNC_CAPABILITIES_V1::boardId

Board ID.

◆ boardId [2/3]

NvU32 _NV_GSYNC_CAPABILITIES_V2::boardId

Board ID.

◆ boardId [3/3]

NvU32 _NV_GSYNC_CAPABILITIES_V3::boardId

Board ID.

◆ boardID

NvU32 _NVVIOCAPS::boardID

Board ID

◆ BoardNum

NvU8 _NV_BOARD_INFO::BoardNum[16]

Board Serial Number.

◆ bottom_bar

NvU32 NV_INFOFRAME_VIDEO::bottom_bar

◆ boundingBox

D3D11_VIEWPORT _NV_SMP_ASSIST_SETUP_PARAMS_V1::boundingBox

(IN) Rect on the rendertarget, to place the projection

◆ BoundingRectOriginX

float _NV_SMP_ASSIST_REMAPCBDATA_V1::BoundingRectOriginX

◆ BoundingRectOriginY

float _NV_SMP_ASSIST_REMAPCBDATA_V1::BoundingRectOriginY

◆ BoundingRectSizeHeight

float _NV_SMP_ASSIST_REMAPCBDATA_V1::BoundingRectSizeHeight

◆ BoundingRectSizeInvHeight

float _NV_SMP_ASSIST_REMAPCBDATA_V1::BoundingRectSizeInvHeight

◆ BoundingRectSizeInvWidth

float _NV_SMP_ASSIST_REMAPCBDATA_V1::BoundingRectSizeInvWidth

◆ BoundingRectSizeWidth

float _NV_SMP_ASSIST_REMAPCBDATA_V1::BoundingRectSizeWidth

◆ boundingScissor

D3D11_RECT _NV_SMP_ASSIST_GET_CONSTANTS_V3::boundingScissor

(OUT) If eSMPType is MRS or LMS then this will be a union of the individual scissor rects populated in pScissors

◆ boundingViewport

D3D11_VIEWPORT _NV_SMP_ASSIST_GET_CONSTANTS_V3::boundingViewport

(OUT) If eSMPType is MRS or LMS then this will be a union of the individual viewports populated in pViewports

◆ bpc [1/8]

NV_DP_BPC _NV_DISPLAY_PORT_INFO_V1::bpc

Current bit-per-component.

◆ bpc [2/8]

NV_DP_BPC NV_DISPLAY_PORT_CONFIG::bpc

Bit-per-component.

◆ bpc [3/8]

NV_BPC _NV_COLOR_DATA_V3::bpc

One of NV_BPC enum values.

◆ [] [4/8]

NV_BPC { ... } ::bpc

One of NV_BPC enum values.

◆ [] [5/8]

NV_BPC { ... } ::bpc

One of NV_BPC enum values.

◆ bpc [6/8]

NV_BPC _NV_COLOR_DATA_V4::bpc

One of NV_BPC enum values.

◆ [] [7/8]

NV_BPC { ... } ::bpc

One of NV_BPC enum values.

◆ bpc [8/8]

NV_BPC _NV_COLOR_DATA_V5::bpc

One of NV_BPC enum values.

◆ bPositionIsAvailable

NvU32 _NV_MANAGED_DEDICATED_DISPLAY_METADATA::bPositionIsAvailable

[out] Query call: 1 in case the information in variables/fields "positionX" and "positionY" is valid (has been set before). 0 otherwise.

◆ bpp [1/2]

NvU32 _NV_MOSAIC_DISPLAY_SETTING_V1::bpp

Bits per pixel.

◆ bpp [2/2]

NvU32 NV_MOSAIC_DISPLAY_SETTING_V2::bpp

Bits per pixel.

◆ bPrimary [1/3]

NvU32 NV_VIEW_TARGET_INFO::bPrimary

(OUT) Indicates if this is the GPU's primary view target. This is not the desktop GDI primary. NvAPI_SetView automatically selects the first target in NV_VIEW_TARGET_INFO index 0 as the GPU's primary view.

◆ [] [2/3]

NvU32 { ... } ::bPrimary

(OUT) Indicates if this is the GPU's primary view target. This is not the desktop GDI primary. NvAPI_SetView automatically selects the first target in NV_VIEW_TARGET_INFO index 0 as the GPU's primary view.

◆ bPrimary [3/3]

NvU32 NV_DISPLAY_PATH::bPrimary

(IN/OUT) Indicates if this is the GPU's primary view target. This is not the desktop GDI primary. NvAPI_SetViewEx() automatically selects the first target in NV_DISPLAY_PATH_INFO index 0 as the GPU's primary view.

◆ bRelease

NvU32 bRelease

◆ bRemoveName

NvU32 _NV_MANAGED_DEDICATED_DISPLAY_METADATA::bRemoveName

[in] Set call: 1 in case the stored name metadata should be set to 'not defined',N/A. 0 otherwise.

◆ bRemovePosition

NvU32 _NV_MANAGED_DEDICATED_DISPLAY_METADATA::bRemovePosition

[in] Set call: 1 in case the stored positionX and positionY metadata should be set to 'not defined', N/A. 0 otherwise.

◆ BResource [1/2]

NV_D3D11_META_COMMAND_RESOURCE NV_D3D11_META_COMMAND_EXECUTE_GEMM_DESC::BResource

◆ BResource [2/2]

NvU64 NV_D3D12_META_COMMAND_EXECUTE_GEMM_DESC::BResource

◆ brief

NV_MOSAIC_TOPO_BRIEF NV_MOSAIC_TOPO_GROUP::brief

The brief details of this topo.

◆ brightnessPct [1/4]

NvU8 _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_RGB_PARAMS::brightnessPct

Brightness perecentage value of the zone.

◆ brightnessPct [2/4]

NvU8 _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_COLOR_FIXED_PARAMS::brightnessPct

Brightness percentage value of the zone.

◆ brightnessPct [3/4]

NvU8 _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_RGBW_PARAMS::brightnessPct

Brightness percentage value of the zone.

◆ brightnessPct [4/4]

NvU8 _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_SINGLE_COLOR_PARAMS::brightnessPct

Brightness percentage value of the zone.

◆ bSetName

NvU32 _NV_MANAGED_DEDICATED_DISPLAY_METADATA::bSetName

[in] Set call: 1 in case the information in variable/field "name" should be stored as metadata. 0 otherwise.

◆ bSetPosition

NvU32 _NV_MANAGED_DEDICATED_DISPLAY_METADATA::bSetPosition

[in] Set call: 1 in case the information in variables/fields "positionX" and "positionY" should be stored as metadata. 0 otherwise.

◆ bSinglePassStereoSupported [1/3]

NvU32 _NV_QUERY_SINGLE_PASS_STEREO_SUPPORT_PARAMS_V1::bSinglePassStereoSupported

◆ bSinglePassStereoSupported [2/3]

NvU32 _NV_QUERY_SINGLE_PASS_STEREO_SUPPORT_PARAMS_V2::bSinglePassStereoSupported

◆ bSinglePassStereoSupported [3/3]

NvU32 _NV_QUERY_MULTIVIEW_SUPPORT_PARAMS_V1::bSinglePassStereoSupported

◆ bSinglePassStereoXYZWSupported [1/2]

NvU32 _NV_QUERY_SINGLE_PASS_STEREO_SUPPORT_PARAMS_V2::bSinglePassStereoXYZWSupported

◆ bSinglePassStereoXYZWSupported [2/2]

NvU32 _NV_QUERY_MULTIVIEW_SUPPORT_PARAMS_V1::bSinglePassStereoXYZWSupported

◆ bSLIFocus

NvU32 _NV_DISPLAYCONFIG_SOURCE_MODE_INFO_V1::bSLIFocus

◆ bSMPAssistSupported

NvBool _NV_QUERY_SMP_ASSIST_SUPPORT_PARAMS_V1::bSMPAssistSupported

(OUT) SMP Assist supported or not

◆ bStereoEnable

BOOL _NV_DX_VIDEO_STEREO_INFO::bStereoEnable

Whether stereo rendering should be enabled (if FALSE, only left view will be used)

◆ bSupported

NvU32 _NV_GPU_QUERY_ILLUMINATION_SUPPORT_PARM_V1::bSupported

A boolean indicating if the attribute is supported.

◆ bSync

NvBool NV_GPU_CLIENT_ILLUM_DEVICE_SYNC_V1::bSync

Boolean representing the need for synchronization.

◆ bTestMode

NvU32 _NVVIOINPUTCONFIG::bTestMode

This attribute controls the GVI test mode. Possible values 0/1. When testmode enabled, the GVI device will generate fake data as quickly as possible.

◆ BTimems

NvU16 _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR::BTimems

Time in ms to remain at color B before color B to color A transition.

◆ bus

NvU16 NVLINK_DEVICE_INFO_V1::bus

◆ bUseGameSleep

NvBool _NV_GET_SLEEP_STATUS_PARAMS::bUseGameSleep

(OUT) Is NvAPI_D3D_Sleep() being called?

◆ bUseMarkersToOptimize

NvBool _NV_SET_SLEEP_MODE_PARAMS::bUseMarkersToOptimize

(IN) Allow latency markers to be used for runtime optimizations.

◆ bVariablePixelRateShadingSupported [1/3]

NvU32 _NV_D3D1x_GRAPHICS_CAPS_V1::bVariablePixelRateShadingSupported

(OUT) Outputs whether Variable Pixel Shading Rates are supported or not

◆ bVariablePixelRateShadingSupported [2/3]

NvU32 _NV_D3D1x_GRAPHICS_CAPS_V2::bVariablePixelRateShadingSupported

(OUT) Outputs whether Variable Pixel Shading Rates are supported or not

◆ bVariablePixelRateShadingSupported [3/3]

NvU32 _NV_D3D12_GRAPHICS_CAPS_V1::bVariablePixelRateShadingSupported

(OUT) Outputs whether Variable Pixel Shading Rates are supported or not

◆ byteOffset [1/2]

NvU32 _NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_DESC::byteOffset

Byte offset from the inputBuffer, specified in the input structure NVAPI_D3D12_BUILD_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_INPUTS, to where the input DMM data is located.

◆ byteOffset [2/2]

NvU32 _NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_DESC::byteOffset

Byte offset from the inputBuffer, specified in the input structure NVAPI_D3D12_BUILD_RAYTRACING_OPACITY_MICROMAP_ARRAY_INPUTS, to where the input OMM data is located.

◆ callback

NV_GPU_CLIENT_UTILIZATION_PERIODIC_CALLBACK_V1 _NV_GPU_CLIENT_UTILIZATION_PERIODIC_CALLBACK_SETTINGS_V1::callback

[in] Callback. Pass in NULL or nullptr to indicate request to unregister.

◆ callbackParam

void* NV_EVENT_REGISTER_CALLBACK::callbackParam

This value will be passed back to the callback function when an event occurs.

◆ callbackPeriodms

NvU32 _NV_GPU_CLIENT_PERIODIC_CALLBACK_SETTINGS_SUPER_V1::callbackPeriodms

[in] Minimum interval at which callback will be called.

The callback may be invoked slower than this interval if underlying sampling rate does not align precisely to the provided period.

◆ capFlags [1/3]

NvU32 _NV_GSYNC_CAPABILITIES_V1::capFlags

Capabilities of the Sync board. Reserved for future use.

◆ capFlags [2/3]

NvU32 _NV_GSYNC_CAPABILITIES_V2::capFlags

Capabilities of the Sync board. Reserved for future use.

◆ capFlags [3/3]

NvU32 _NV_GSYNC_CAPABILITIES_V3::capFlags

Capabilities of the Sync board. Reserved for future use.

◆ caps [1/2]

NV_MONITOR_CAPS_GENERIC _NV_MONITOR_CAPABILITIES_V1::caps

◆ [] [2/2]

NV_MONITOR_CAPS_GENERIC { ... } ::caps

◆ capsTbl [1/3]

NvU32 NVLINK_GET_CAPS_V1::capsTbl

This is bit field for getting different global caps.The individual bitfields are specified by NVAPI_NVLINK_CAPS_*.

◆ capsTbl [2/3]

NvU32 NVLINK_LINK_STATUS_INFO_V1::capsTbl

This is bit field for getting different global caps.The individual bitfields are specified by NVAPI_NVLINK_CAPS_*.

◆ capsTbl [3/3]

NvU32 NVLINK_LINK_STATUS_INFO_V2::capsTbl

This is bit field for getting different global caps.The individual bitfields are specified by NVAPI_NVLINK_CAPS_*.

◆ captureStatus

NVVIOCAPTURESTATUS _NVVIOINPUTSTATUS::captureStatus

status of video capture

◆ cbSize [1/3]

NvU32 NV_I2C_INFO_V1::cbSize

The size of the data buffer, pbData, to be read or written.

◆ cbSize [2/3]

NvU32 NV_I2C_INFO_V2::cbSize

The size of the data buffer, pbData, to be read or written.

◆ cbSize [3/3]

NvU32 NV_I2C_INFO_V3::cbSize

The size of the data buffer, pbData, to be read or written.

◆ [] [1/4]

NvU16 { ... } ::cc_blue_x

Blue primary chromaticity coordinate x.

◆ cc_blue_x [2/4]

NvU16 _NV_HDR_CAPABILITIES_V2::cc_blue_x

Blue primary chromaticity coordinate x.

◆ cc_blue_x [3/4]

NvU16 _NV_HDR_CAPABILITIES_V3::cc_blue_x

Blue primary chromaticity coordinate x.

◆ [] [4/4]

NvU16 { ... } ::cc_blue_x

Blue primary chromaticity coordinate x.

◆ cc_blue_y [1/4]

NvU16 _NV_HDR_CAPABILITIES_V2::cc_blue_y

Blue primary chromaticity coordinate y.

◆ [] [2/4]

NvU16 { ... } ::cc_blue_y

Blue primary chromaticity coordinate y.

◆ [] [3/4]

NvU16 { ... } ::cc_blue_y

Blue primary chromaticity coordinate y.

◆ cc_blue_y [4/4]

NvU16 _NV_HDR_CAPABILITIES_V3::cc_blue_y

Blue primary chromaticity coordinate y.

◆ cc_green_x [1/4]

NvU16 _NV_HDR_CAPABILITIES_V2::cc_green_x

Green primary chromaticity coordinate x.

◆ [] [2/4]

NvU16 { ... } ::cc_green_x

Green primary chromaticity coordinate x.

◆ [] [3/4]

NvU16 { ... } ::cc_green_x

Green primary chromaticity coordinate x.

◆ cc_green_x [4/4]

NvU16 _NV_HDR_CAPABILITIES_V3::cc_green_x

Green primary chromaticity coordinate x.

◆ [] [1/4]

NvU16 { ... } ::cc_green_y

Green primary chromaticity coordinate Y.

◆ cc_green_y [2/4]

NvU16 _NV_HDR_CAPABILITIES_V2::cc_green_y

Green primary chromaticity coordinate Y.

◆ [] [3/4]

NvU16 { ... } ::cc_green_y

Green primary chromaticity coordinate Y.

◆ cc_green_y [4/4]

NvU16 _NV_HDR_CAPABILITIES_V3::cc_green_y

Green primary chromaticity coordinate Y.

◆ [] [1/4]

NvU16 { ... } ::cc_red_x

Red primary chromaticity coordinate x.

◆ cc_red_x [2/4]

NvU16 _NV_HDR_CAPABILITIES_V2::cc_red_x

Red primary chromaticity coordinate x.

◆ [] [3/4]

NvU16 { ... } ::cc_red_x

Red primary chromaticity coordinate x.

◆ cc_red_x [4/4]

NvU16 _NV_HDR_CAPABILITIES_V3::cc_red_x

Red primary chromaticity coordinate x.

◆ cc_red_y [1/4]

NvU16 _NV_HDR_CAPABILITIES_V2::cc_red_y

Red primary chromaticity coordinate y.

◆ [] [2/4]

NvU16 { ... } ::cc_red_y

Red primary chromaticity coordinate y.

◆ [] [3/4]

NvU16 { ... } ::cc_red_y

Red primary chromaticity coordinate y.

◆ cc_red_y [4/4]

NvU16 _NV_HDR_CAPABILITIES_V3::cc_red_y

Red primary chromaticity coordinate y.

◆ [] [1/4]

NvU16 { ... } ::cc_white_x

White primary chromaticity coordinate x.

◆ cc_white_x [2/4]

NvU16 _NV_HDR_CAPABILITIES_V2::cc_white_x

White primary chromaticity coordinate x.

◆ [] [3/4]

NvU16 { ... } ::cc_white_x

White primary chromaticity coordinate x.

◆ cc_white_x [4/4]

NvU16 _NV_HDR_CAPABILITIES_V3::cc_white_x

White primary chromaticity coordinate x.

◆ cc_white_y [1/4]

NvU16 _NV_HDR_CAPABILITIES_V2::cc_white_y

White primary chromaticity coordinate y.

◆ [] [2/4]

NvU16 { ... } ::cc_white_y

White primary chromaticity coordinate y.

◆ [] [3/4]

NvU16 { ... } ::cc_white_y

White primary chromaticity coordinate y.

◆ cc_white_y [4/4]

NvU16 _NV_HDR_CAPABILITIES_V3::cc_white_y

White primary chromaticity coordinate y.

◆ [] [1/2]

NvU32 { ... } ::ceaId

The EIA/CEA 861B/D predefined short timing descriptor ID. Used when the timing type is NV_TIMING_OVERRIDE_EIA861 and width==height==rr==0.

◆ ceaId [2/2]

NvU32 NV_TIMING_FLAG::ceaId

The EIA/CEA 861B/D predefined short timing descriptor ID. Used when the timing type is NV_TIMING_OVERRIDE_EIA861 and width==height==rr==0.

◆ centerHeight [1/2]

float _NV_MRS_CUSTOM_CONFIG_V1::centerHeight

◆ centerHeight [2/2]

float _NV_MRS_INSTANCED_STEREO_CONFIG_V1::centerHeight

◆ centerWidth [1/2]

float _NV_MRS_CUSTOM_CONFIG_V1::centerWidth

(IN) Size of the central viewport, ranging (0,1], where 1 is full original viewport size

◆ centerWidth [2/2]

float _NV_MRS_INSTANCED_STEREO_CONFIG_V1::centerWidth[2]

< (OUT) MRS Instanced stereo config returned by the SMP Assist GetConstants API

(OUT) Size of the central viewport, ranging (0,1], where 1 is full original viewport size

◆ centerX [1/2]

float _NV_MRS_CUSTOM_CONFIG_V1::centerX

(IN) Location of the central viewport, ranging 0..1, where 0.5 is the center of the screen

◆ centerX [2/2]

float _NV_MRS_INSTANCED_STEREO_CONFIG_V1::centerX[2]

(OUT) Location of the central viewport, ranging 0..1, where 0.5 is the center of the screen

◆ centerY [1/2]

float _NV_MRS_CUSTOM_CONFIG_V1::centerY

◆ centerY [2/2]

float _NV_MRS_INSTANCED_STEREO_CONFIG_V1::centerY

◆ [] [1/2]

NvU32 { ... } ::channel

specified (0-based) jack

◆ channel [2/2]

NvU32 _NVVIOSTREAM::channel

specified (0-based) jack

◆ channelCount

NvU32 NV_INFOFRAME_AUDIO::channelCount

◆ checkStatus

D3D12_DRIVER_MATCHING_IDENTIFIER_STATUS _NVAPI_CHECK_DRIVER_MATCHING_IDENTIFIER_EX_PARAMS_V1::checkStatus

[out] Result of the check; see D3D12_DRIVER_MATCHING_IDENTIFIER_STATUS.

◆ ClipToWindowSplitsX

float _NV_SMP_ASSIST_REMAPCBDATA_V1::ClipToWindowSplitsX[2]

< (OUT) Constant buffer data to supply the UV-remapping helper functions

◆ ClipToWindowSplitsY

float _NV_SMP_ASSIST_REMAPCBDATA_V1::ClipToWindowSplitsY[2]

◆ ClipToWindowX

float _NV_SMP_ASSIST_REMAPCBDATA_V1::ClipToWindowX[3][2]

◆ ClipToWindowY

float _NV_SMP_ASSIST_REMAPCBDATA_V1::ClipToWindowY[3][2]

◆ ClipToWindowZ

float _NV_SMP_ASSIST_REMAPCBDATA_V1::ClipToWindowZ[2]

◆ [struct] [1/8]

struct { ... } NV_GPU_PERF_PSTATES_INFO_V1::clocks[NVAPI_MAX_GPU_PERF_CLOCKS]

◆ [struct] [2/8]

struct { ... } NV_GPU_PERF_PSTATES_INFO_V1::clocks[NVAPI_MAX_GPU_PERF_CLOCKS]

◆ [struct] [3/8]

struct { ... } NV_GPU_PERF_PSTATES_INFO_V2::clocks[NVAPI_MAX_GPU_PERF_CLOCKS]

◆ [struct] [4/8]

struct { ... } NV_GPU_PERF_PSTATES_INFO_V2::clocks[NVAPI_MAX_GPU_PERF_CLOCKS]

◆ [] [5/8]

NV_GPU_PSTATE20_CLOCK_ENTRY_V1 { ... } ::clocks[NVAPI_MAX_GPU_PSTATE20_CLOCKS]

Array of clock entries Valid index range is 0 to numClocks-1

◆ clocks [6/8]

NV_GPU_PSTATE20_CLOCK_ENTRY_V1 NV_GPU_PERF_PSTATES20_INFO_V1::clocks[NVAPI_MAX_GPU_PSTATE20_CLOCKS]

Array of clock entries Valid index range is 0 to numClocks-1

◆ clocks [7/8]

NV_GPU_PSTATE20_CLOCK_ENTRY_V1 _NV_GPU_PERF_PSTATES20_INFO_V2::clocks[NVAPI_MAX_GPU_PSTATE20_CLOCKS]

Array of clock entries Valid index range is 0 to numClocks-1

◆ [] [8/8]

NV_GPU_PSTATE20_CLOCK_ENTRY_V1 { ... } ::clocks[NVAPI_MAX_GPU_PSTATE20_CLOCKS]

Array of clock entries Valid index range is 0 to numClocks-1

◆ ClockType

NvU32 NV_GPU_CLOCK_FREQUENCIES_V2::ClockType

One of NV_GPU_CLOCK_FREQUENCIES_CLOCK_TYPE. Used to specify the type of clock to be returned.

◆ cloneGroup [1/2]

NvU32 _NV_MOSAIC_GRID_TOPO_DISPLAY_V1::cloneGroup

Reserved, must be 0.

◆ cloneGroup [2/2]

NvU32 _NV_MOSAIC_GRID_TOPO_DISPLAY_V2::cloneGroup

Reserved, must be 0.

◆ cloneImportance

NvU32 _NV_SCANOUT_INFORMATION::cloneImportance

If targets are cloned views of the sourceDesktopRect the cloned targets have an importance assigned (0:primary,1 secondary,...).

◆ cmd [1/8]

NvU8 NV_INFOFRAME_DATA::cmd

The actions to perform from NV_INFOFRAME_CMD.

◆ cmd [2/8]

NvU8 _NV_COLOR_DATA_V1::cmd

◆ cmd [3/8]

NvU8 _NV_COLOR_DATA_V2::cmd

◆ cmd [4/8]

NvU8 _NV_COLOR_DATA_V3::cmd

◆ cmd [5/8]

NvU8 _NV_COLOR_DATA_V4::cmd

◆ cmd [6/8]

NvU8 _NV_COLOR_DATA_V5::cmd

◆ cmd [7/8]

NV_HDR_CMD _NV_HDR_COLOR_DATA_V1::cmd

Command get/set.

◆ cmd [8/8]

NV_HDR_CMD _NV_HDR_COLOR_DATA_V2::cmd

Command get/set.

◆ cnc0SupportGraphicsTextContent

NvU8 _NV_MONITOR_CAPS_VSDB::cnc0SupportGraphicsTextContent

Byte 5.

◆ cnc1SupportPhotoContent

NvU8 _NV_MONITOR_CAPS_VSDB::cnc1SupportPhotoContent

Byte 5.

◆ cnc2SupportCinemaContent

NvU8 _NV_MONITOR_CAPS_VSDB::cnc2SupportCinemaContent

Byte 5.

◆ cnc3SupportGameContent

NvU8 _NV_MONITOR_CAPS_VSDB::cnc3SupportGameContent

Byte 5.

◆ codingExtensionType

NvU32 NV_INFOFRAME_AUDIO::codingExtensionType

◆ codingType

NvU32 NV_INFOFRAME_AUDIO::codingType

◆ colCount [1/2]

NvU32 NV_MOSAIC_TOPO_DETAILS::colCount

Number of displays in a column.

◆ colCount [2/2]

NvU32 NV_MOSAIC_TOPOLOGY::colCount

Vertical display count.

◆ colorB [1/2]

NvU8 _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_RGB_PARAMS::colorB

Blue compenent of color applied to the zone.

◆ colorB [2/2]

NvU8 _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_RGBW_PARAMS::colorB

Blue component of color applied to the zone.

◆ colorConversion [1/3]

NVVIOCOLORCONVERSION _NVVIOOUTPUTCONFIG_V1::colorConversion

Color conversion.

◆ colorConversion [2/3]

NVVIOCOLORCONVERSION _NVVIOOUTPUTCONFIG_V2::colorConversion

Color conversion.

◆ colorConversion [3/3]

NVVIOCOLORCONVERSION _NVVIOOUTPUTCONFIG_V3::colorConversion

Color conversion.

◆ colorDepth

NvU32 _NV_RESOLUTION::colorDepth

◆ [] [1/2]

NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_COLOR_FIXED { ... } ::colorFixed

◆ colorFixed [2/2]

NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_COLOR_FIXED _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_V1::colorFixed

◆ colorFixedParams [1/2]

NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_COLOR_FIXED_PARAMS _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_COLOR_FIXED::colorFixedParams

Parameters required to represent control mode of type NV_GPU_CLIENT_ILLUM_CTRL_MODE_MANUAL_RGB.

◆ colorFixedParams [2/2]

NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_COLOR_FIXED_PARAMS _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR_COLOR_FIXED::colorFixedParams[NV_GPU_CLIENT_ILLUM_CTRL_MODE_PIECEWISE_LINEAR_COLOR_ENDPOINTS]

Parameters required to represent control mode of type NV_GPU_CLIENT_ILLUM_CTRL_MODE_PIECEWISE_LINEAR_RGB.

◆ colorFormat [1/16]

NV_FORMAT NV_DISPLAY_PATH::colorFormat

Color format if it needs to be specified. Not used now.

◆ colorFormat [2/16]

NV_FORMAT _NV_DISPLAYCONFIG_SOURCE_MODE_INFO_V1::colorFormat

Ignored at present, must be NV_FORMAT_UNKNOWN (0)

◆ colorFormat [3/16]

NV_DP_COLOR_FORMAT _NV_DISPLAY_PORT_INFO_V1::colorFormat

Current color format.

◆ colorFormat [4/16]

NV_DP_COLOR_FORMAT NV_DISPLAY_PORT_CONFIG::colorFormat

Color format to set.

◆ [] [5/16]

NvU8 { ... } ::colorFormat

One of NV_COLOR_FORMAT enum values.

◆ colorFormat [6/16]

NvU8 _NV_COLOR_DATA_V1::colorFormat

One of NV_COLOR_FORMAT enum values.

◆ [] [7/16]

NvU8 { ... } ::colorFormat

One of NV_COLOR_FORMAT enum values.

◆ colorFormat [8/16]

NvU8 _NV_COLOR_DATA_V2::colorFormat

One of NV_COLOR_FORMAT enum values.

◆ colorFormat [9/16]

NvU8 _NV_COLOR_DATA_V3::colorFormat

One of NV_COLOR_FORMAT enum values.

◆ [] [10/16]

NvU8 { ... } ::colorFormat

One of NV_COLOR_FORMAT enum values.

◆ colorFormat [11/16]

NvU8 _NV_COLOR_DATA_V4::colorFormat

One of NV_COLOR_FORMAT enum values.

◆ [] [12/16]

NvU8 { ... } ::colorFormat

One of NV_COLOR_FORMAT enum values.

◆ colorFormat [13/16]

NvU8 _NV_COLOR_DATA_V5::colorFormat

One of NV_COLOR_FORMAT enum values.

◆ [] [14/16]

NvU8 { ... } ::colorFormat

One of NV_COLOR_FORMAT enum values.

◆ colorFormat [15/16]

NV_DP_COLOR_FORMAT _NV_MONITOR_COLOR_DATA::colorFormat

One of the supported color formats.

◆ colorFormat [16/16]

NV_FORMAT NV_CUSTOM_DISPLAY::colorFormat

Color format (optional)

◆ colorG [1/2]

NvU8 _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_RGB_PARAMS::colorG

Green compenent of color applied to the zone.

◆ colorG [2/2]

NvU8 _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_RGBW_PARAMS::colorG

Green component of color applied to the zone.

◆ colorimetry [1/17]

NV_DP_COLORIMETRY _NV_DISPLAY_PORT_INFO_V1::colorimetry

Ignored in RGB space.

◆ colorimetry [2/17]

NV_DP_COLORIMETRY NV_DISPLAY_PORT_CONFIG::colorimetry

Ignored in RGB space.

◆ colorimetry [3/17]

NvU32 NV_INFOFRAME_VIDEO::colorimetry

◆ colorimetry [4/17]

NvU8 _NV_COLOR_DATA_V1::colorimetry

One of NV_COLOR_COLORIMETRY enum values.

◆ [] [5/17]

NvU8 { ... } ::colorimetry

One of NV_COLOR_COLORIMETRY enum values.

◆ colorimetry [6/17]

NvU8 _NV_COLOR_DATA_V2::colorimetry

One of NV_COLOR_COLORIMETRY enum values.

◆ [] [7/17]

NvU8 { ... } ::colorimetry

One of NV_COLOR_COLORIMETRY enum values.

◆ [] [8/17]

NvU8 { ... } ::colorimetry

One of NV_COLOR_COLORIMETRY enum values.

◆ colorimetry [9/17]

NvU8 _NV_COLOR_DATA_V3::colorimetry

One of NV_COLOR_COLORIMETRY enum values.

◆ colorimetry [10/17]

NvU8 _NV_COLOR_DATA_V4::colorimetry

One of NV_COLOR_COLORIMETRY enum values.

◆ [] [11/17]

NvU8 { ... } ::colorimetry

One of NV_COLOR_COLORIMETRY enum values.

◆ [] [12/17]

NvU8 { ... } ::colorimetry

One of NV_COLOR_COLORIMETRY enum values.

◆ colorimetry [13/17]

NvU8 _NV_COLOR_DATA_V5::colorimetry

One of NV_COLOR_COLORIMETRY enum values.

◆ [] [14/17]

NvU32 { ... } ::colorimetry

If set indicates sink supports DCI P3 colorimetry, REc709 otherwise.

◆ colorimetry [15/17]

NvU32 _NV_HDR_CAPABILITIES_V2::colorimetry

If set indicates sink supports DCI P3 colorimetry, REc709 otherwise.

◆ colorimetry [16/17]

NvU32 _NV_HDR_CAPABILITIES_V3::colorimetry

If set indicates sink supports DCI P3 colorimetry, REc709 otherwise.

◆ [] [17/17]

NvU32 { ... } ::colorimetry

If set indicates sink supports DCI P3 colorimetry, REc709 otherwise.

◆ colorMatrix

float _NVVIOCOLORCONVERSION::colorMatrix[3][3]

Output[n] =.

◆ colorOffset

float _NVVIOCOLORCONVERSION::colorOffset[3]

Input[0] * colorMatrix[n][0] +.

◆ colorR [1/2]

NvU8 _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_RGB_PARAMS::colorR

Red compenent of color applied to the zone.

◆ colorR [2/2]

NvU8 _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_RGBW_PARAMS::colorR

Red component of color applied to the zone.

◆ colorScale

float _NVVIOCOLORCONVERSION::colorScale[3]

Input[1] * colorMatrix[n][1] + Input[2] * colorMatrix[n][2] + OutputRange * colorOffset[n] where OutputRange is the standard magnitude of Output[n][n] and colorMatrix and colorOffset values are within the range -1.0 to +1.0

◆ [] [1/4]

NV_COLOR_SELECTION_POLICY { ... } ::colorSelectionPolicy

One of the color selection policy.

◆ colorSelectionPolicy [2/4]

NV_COLOR_SELECTION_POLICY _NV_COLOR_DATA_V4::colorSelectionPolicy

One of the color selection policy.

◆ [] [3/4]

NV_COLOR_SELECTION_POLICY { ... } ::colorSelectionPolicy

One of the color selection policy.

◆ colorSelectionPolicy [4/4]

NV_COLOR_SELECTION_POLICY _NV_COLOR_DATA_V5::colorSelectionPolicy

One of the color selection policy.

◆ colorSpace [1/2]

NvU32 NV_INFOFRAME_VIDEO::colorSpace

◆ colorSpace [2/2]

NVVIOCOLORSPACE _NVVIOCHANNELSTATUS::colorSpace

Color space.

◆ colorW

NvU8 _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_RGBW_PARAMS::colorW

White component of color applied to the zone.

◆ columns [1/2]

NvU32 _NV_MOSAIC_GRID_TOPO_V1::columns

Number of columns.

◆ columns [2/2]

NvU32 _NV_MOSAIC_GRID_TOPO_V2::columns

Number of columns.

◆ commandLine

NvAPI_UnicodeString _NVDRS_APPLICATION_V4::commandLine

If isCommandLine is set to 0 this must be an empty. If isCommandLine is set to 1 this contains application's command line as if it was returned by GetCommandLineW.

◆ companionBufferCount

__in NvU32 _NV_D3D12_MOSAIC_GETCOMPANIONALLOCATIONS::companionBufferCount

The number of ID3D12Resource pointers requested to be returned in the ppComanionResources array, which should match ID3D12Device::GetNodeCount for the complete set of companion allocations.

◆ compositeSafe

NvU32 _NVVIOCOLORCONVERSION::compositeSafe

compositeSafe constrains luminance range when using composite output

◆ compositeSyncType [1/3]

NVVIOCOMPSYNCTYPE _NVVIOOUTPUTCONFIG_V1::compositeSyncType

Composite sync type.

◆ compositeSyncType [2/3]

NVVIOCOMPSYNCTYPE _NVVIOOUTPUTCONFIG_V2::compositeSyncType

Composite sync type.

◆ compositeSyncType [3/3]

NVVIOCOMPSYNCTYPE _NVVIOOUTPUTCONFIG_V3::compositeSyncType

Composite sync type.

◆ compositeTerminate [1/3]

NvU32 _NVVIOOUTPUTCONFIG_V1::compositeTerminate

Composite termination.

◆ compositeTerminate [2/3]

NvU32 _NVVIOOUTPUTCONFIG_V2::compositeTerminate

Composite termination.

◆ compositeTerminate [3/3]

NvU32 _NVVIOOUTPUTCONFIG_V3::compositeTerminate

Composite termination.

◆ compRange [1/3]

NVVIOCOMPOSITERANGE _NVVIOOUTPUTCONFIG_V1::compRange

Composite ranges.

◆ compRange [2/3]

NVVIOCOMPOSITERANGE _NVVIOOUTPUTCONFIG_V2::compRange

Composite ranges.

◆ compRange [3/3]

NVVIOCOMPOSITERANGE _NVVIOOUTPUTCONFIG_V3::compRange

Composite ranges.

◆ compSyncIn

NVVIOSYNCSTATUS _NVVIOOUTPUTSTATUS::compSyncIn

Composite sync input status.

◆ [struct] [1/2]

struct { ... } NV_COMPUTE_GPU_TOPOLOGY_V1::computeGpus[NVAPI_MAX_GPU_PER_TOPOLOGY]

Array of compute-capable physical GPUs.

◆ computeGpus [2/2]

NV_COMPUTE_GPU* _NV_COMPUTE_GPU_TOPOLOGY_V2::computeGpus

Array of compute-capable physical GPUs (allocate memory of size of Physical gpuCount of system).

◆ configurationOptions

NV_ECC_CONFIGURATION NV_GPU_ECC_STATUS_INFO::configurationOptions

Supported ECC memory feature configuration options.

◆ connected [1/2]

NvU32 NVLINK_LINK_STATUS_INFO_V1::connected

This field specifies if any device is connected on the other end of the link.

◆ connected [2/2]

NvU32 NVLINK_LINK_STATUS_INFO_V2::connected

This field specifies if any device is connected on the other end of the link.

◆ connector [1/3]

NV_GPU_CONNECTOR_TYPE NV_DISPLAY_PATH::connector

(IN) Specify connector type. For TV only.

◆ connector [2/3]

NV_GPU_CONNECTOR_TYPE _NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_V1::connector

Specify connector type. For TV only, ignored if tvFormat == NV_DISPLAY_TV_FORMAT_NONE.

◆ connector [3/3]

NVAPI_GSYNC_GPU_TOPOLOGY_CONNECTOR _NV_GSYNC_GPU::connector

Indicates which connector on the device the GPU is connected to.

◆ connectorType [1/2]

NV_MONITOR_CONN_TYPE _NV_GPU_DISPLAYIDS::connectorType

out: vga, tv, dvi, hdmi and dp. This is reserved for future use and clients should not rely on this information. Instead get the GPU connector type from NvAPI_GPU_GetConnectorInfo/NvAPI_GPU_GetConnectorInfoEx

◆ connectorType [2/2]

NvU32 _NV_MONITOR_CAPABILITIES_V1::connectorType

Out: VGA, TV, DVI, HDMI, DP.

◆ ConservativeRaster

BOOL _NV_D3D11_FEATURE_DATA_RASTERIZER_SUPPORT::ConservativeRaster

◆ ConservativeRasterEnable

bool NvAPI_D3D11_RASTERIZER_DESC_EX::ConservativeRasterEnable

◆ ConstantPadVal

float NV_META_COMMAND_PADDING_DESC::ConstantPadVal

◆ ContentType

NV_VRS_CONTENT_TYPE _NV_VRS_HELPER_ENABLE_PARAMS_V1::ContentType

(IN) This defines the type of content with which the VRS pattern will be generated

◆ contentTypes

NvU32 NV_INFOFRAME_VIDEO::contentTypes

◆ [] [1/4]

NV_THERMAL_CONTROLLER { ... } ::controller

internal, ADM1032, MAX6649...

◆ controller [2/4]

NV_THERMAL_CONTROLLER NV_GPU_THERMAL_SETTINGS_V1::controller

internal, ADM1032, MAX6649...

◆ [] [3/4]

NV_THERMAL_CONTROLLER { ... } ::controller

internal, ADM1032, MAX6649...

◆ controller [4/4]

NV_THERMAL_CONTROLLER NV_GPU_THERMAL_SETTINGS_V2::controller

internal, ADM1032, MAX6649...

◆ ConvertToFastGS [1/2]

BOOL NvAPI_D3D11_CREATE_GEOMETRY_SHADER_EX_V5::ConvertToFastGS

◆ ConvertToFastGS [2/2]

BOOL NVAPI_D3D12_PSO_GEOMETRY_SHADER_DESC_V5::ConvertToFastGS

◆ count [1/8]

NvU32 NV_VIEW_TARGET_INFO::count

(IN) target count

◆ count [2/8]

NvU32 NV_DISPLAY_PATH_INFO_V3::count

(IN) Path count

◆ count [3/8]

NvU32 NV_DISPLAY_PATH_INFO::count

(IN) Path count

◆ count [4/8]

NvU32 NV_GPU_THERMAL_SETTINGS_V1::count

number of associated thermal sensors

◆ count [5/8]

NvU32 NV_GPU_THERMAL_SETTINGS_V2::count

number of associated thermal sensors

◆ count [6/8]

NvU32 NV_MOSAIC_TOPO_GROUP::count

Number of topos in array below.

◆ count [7/8]

NvU32 _NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_USAGE_COUNT::count

For DMM Array builds: total number of DMMs in the DMM Array with the particular subdivisionLevel and format specified in this descriptor. For BLAS builds: total number of DMMs with the subdivisionLevel and format combination that is referenced from the BLAS.

◆ count [8/8]

NvU32 _NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_USAGE_COUNT::count

Total number of OMMs in the OMM Array with the particular subdivisionLevel and format specified in this descriptor.

◆ CoverageToColor

BOOL _NV_D3D11_FEATURE_DATA_RASTERIZER_SUPPORT::CoverageToColor

◆ CoverageToColorEnable [1/2]

bool NvAPI_D3D11_RASTERIZER_DESC_EX::CoverageToColorEnable

◆ CoverageToColorEnable [2/2]

bool NVAPI_D3D12_PSO_RASTERIZER_STATE_DESC_V1::CoverageToColorEnable

◆ CoverageToColorRTIndex [1/2]

NvU8 NvAPI_D3D11_RASTERIZER_DESC_EX::CoverageToColorRTIndex

◆ CoverageToColorRTIndex [2/2]

NvU8 NVAPI_D3D12_PSO_RASTERIZER_STATE_DESC_V1::CoverageToColorRTIndex

◆ CResource [1/2]

NV_D3D11_META_COMMAND_RESOURCE NV_D3D11_META_COMMAND_EXECUTE_GEMM_DESC::CResource

◆ CResource [2/2]

NvU64 NV_D3D12_META_COMMAND_EXECUTE_GEMM_DESC::CResource

◆ cscOverride [1/3]

NvU32 _NVVIOOUTPUTCONFIG_V1::cscOverride

Use provided CSC color matrix to overwrite.

◆ cscOverride [2/3]

NvU32 _NVVIOOUTPUTCONFIG_V2::cscOverride

Use provided CSC color matrix to overwrite.

◆ cscOverride [3/3]

NvU32 _NVVIOOUTPUTCONFIG_V3::cscOverride

Use provided CSC color matrix to overwrite.

◆ ctrlMode

NV_GPU_CLIENT_ILLUM_CTRL_MODE _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_V1::ctrlMode

◆ ctrlModeMask

NvU32 _NV_GPU_CLIENT_ILLUM_DEVICE_INFO_V1::ctrlModeMask

Supported control modes for this illumination device.

◆ CullMode

D3D11_CULL_MODE NvAPI_D3D11_RASTERIZER_DESC_EX::CullMode

◆ curLaneCount

NV_DP_LANE_COUNT _NV_DISPLAY_PORT_INFO_V1::curLaneCount

Current lane count.

◆ curLinkRate

NV_DP_LINK_RATE _NV_DISPLAY_PORT_INFO_V1::curLinkRate

Current link rate.

◆ [struct]

struct { ... } NV_GPU_ECC_ERROR_INFO::current

◆ currentDockPolicy

NvU32 NV_LID_DOCK_PARAMS::currentDockPolicy

◆ currentDockState

NvU32 NV_LID_DOCK_PARAMS::currentDockState

◆ currentLidPolicy

NvU32 NV_LID_DOCK_PARAMS::currentLidPolicy

◆ currentLidState

NvU32 NV_LID_DOCK_PARAMS::currentLidState

Structure version, constructed from the macro NV_LID_DOCK_PARAMS_VER.

◆ currentlyCapableOfVRR

NvU8 _NV_MONITOR_CAPS_GENERIC::currentlyCapableOfVRR

monitor currently supports VRR on applied display settings. Valid for NV_MONITOR_CAPS_TYPE_GENERIC only.

◆ currentSizeInBytes [1/2]

NvU64 _NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_ARRAY_POSTBUILD_INFO_CURRENT_SIZE_DESC::currentSizeInBytes

Size of the OMM Array buffer. The queried size may be smaller than the size reported by NvAPI_D3D12_GetRaytracingOpacityMicromapArrayPrebuildInfo(). This allows the application to move and relocate the OMM Array to a smaller buffer to reclaim any unused memory after the OMM Array build is complete.

◆ currentSizeInBytes [2/2]

NvU64 _NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_POSTBUILD_INFO_CURRENT_SIZE_DESC::currentSizeInBytes

Size of the DMM Array buffer. The queried size may be smaller than the size reported by NvAPI_D3D12_GetRaytracingDisplacementMicromapArrayPrebuildInfo(). This allows the application to move and relocate the DMM Array to a smaller buffer to reclaim any unused memory after the DMM Array build is complete.

◆ [] [1/4]

NvU32 { ... } ::currentTemp

The current temperature value of the thermal sensor in degree Celsius.

◆ currentTemp [2/4]

NvU32 NV_GPU_THERMAL_SETTINGS_V1::currentTemp

The current temperature value of the thermal sensor in degree Celsius.

◆ [] [3/4]

NvS32 { ... } ::currentTemp

Current temperature value of the thermal sensor in degree Celsius.

◆ currentTemp [4/4]

NvS32 NV_GPU_THERMAL_SETTINGS_V2::currentTemp

Current temperature value of the thermal sensor in degree Celsius.

◆ cycleType

NV_GPU_CLIENT_ILLUM_PIECEWISE_LINEAR_CYCLE_TYPE _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR::cycleType

Type of cycle effect to apply.

◆ [union] [1/14]

union { ... } NV_GPU_PSTATE20_CLOCK_ENTRY_V1::data

Clock domain type dependant information.

◆ [union] [2/14]

union { ... } _NV_GPU_CLIENT_ILLUM_DEVICE_INFO_V1::data

Union of illumination device info data. Interpreted as per NV_GPU_CLIENT_ILLUM_DEVICE_INFO_V1::type

◆ [union] [3/14]

union { ... } _NV_GPU_CLIENT_ILLUM_ZONE_INFO_V1::data

◆ [union] [4/14]

union { ... } _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_RGB::data

Union of illumination zone control data for zone of type NV_GPU_CLIENT_ILLUM_ZONE_TYPE_RGB. Interpreted as per ctrlMode.

◆ [union] [5/14]

union { ... } _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_COLOR_FIXED::data

Union of illum zone control data for zone of type NV_GPU_CLIENT_ILLUM_ZONE_TYPE_COLOR_FIXED. Interpreted as per ctrlMode.

◆ [union] [6/14]

union { ... } _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_RGBW::data

Union of illum zone control data for zone of type NV_GPU_ILLUM_ZONE_TYPE_RGBW. Interpreted as per ctrlMode.

◆ [union] [7/14]

union { ... } _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_SINGLE_COLOR::data

Union of illum zone control data for zone of type NV_GPU_ILLUM_ZONE_TYPE_SINGLE_COLOR. Interpreted as per ctrlMode.

◆ [union] [8/14]

union { ... } _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_V1::data

◆ [struct] [9/14]

struct { ... } _NV_COLOR_DATA_V1::data

◆ [struct] [10/14]

struct { ... } _NV_COLOR_DATA_V2::data

◆ [struct] [11/14]

struct { ... } _NV_COLOR_DATA_V3::data

◆ [struct] [12/14]

struct { ... } _NV_COLOR_DATA_V4::data

◆ [struct] [13/14]

struct { ... } _NV_COLOR_DATA_V5::data

◆ [union] [14/14]

union { ... } _NV_MONITOR_CAPABILITIES_V1::data

◆ dataFormat [1/4]

NVVIODATAFORMAT _NVVIODATAFORMATDETAIL::dataFormat

Data format enumerated value.

◆ dataFormat [2/4]

NVVIODATAFORMAT _NVVIOOUTPUTCONFIG_V1::dataFormat

Data format for video output.

◆ dataFormat [3/4]

NVVIODATAFORMAT _NVVIOOUTPUTCONFIG_V2::dataFormat

Data format for video output.

◆ dataFormat [4/4]

NVVIODATAFORMAT _NVVIOOUTPUTCONFIG_V3::dataFormat

Data format for video output.

◆ dataIntegrityCheckEnabled

NvU32 _NVVIOOUTPUTSTATUS::dataIntegrityCheckEnabled

Data integrity check status enabled.

◆ dataIntegrityCheckErrorCount

NvU32 _NVVIOOUTPUTSTATUS::dataIntegrityCheckErrorCount

Data integrity check error count.

◆ dataIntegrityCheckFailed

NvU32 _NVVIOOUTPUTSTATUS::dataIntegrityCheckFailed

Data integrity check status failed.

◆ DataType

NvU64 NV_META_COMMAND_TENSOR_DESC::DataType

◆ day

NvU16 _NV_LICENSE_EXPIRY_DETAILS::day

Day value of license expiry.

◆ [] [1/4]

NvU32 { ... } ::defaultMaxTemp

The max default temperature value of the thermal sensor in degree Celsius.

◆ defaultMaxTemp [2/4]

NvU32 NV_GPU_THERMAL_SETTINGS_V1::defaultMaxTemp

The max default temperature value of the thermal sensor in degree Celsius.

◆ [] [3/4]

NvS32 { ... } ::defaultMaxTemp

Maximum default temperature value of the thermal sensor in degree Celsius.

◆ defaultMaxTemp [4/4]

NvS32 NV_GPU_THERMAL_SETTINGS_V2::defaultMaxTemp

Maximum default temperature value of the thermal sensor in degree Celsius.

◆ [] [1/4]

NvU32 { ... } ::defaultMinTemp

The min default temperature value of the thermal sensor in degree Celsius.

◆ defaultMinTemp [2/4]

NvU32 NV_GPU_THERMAL_SETTINGS_V1::defaultMinTemp

The min default temperature value of the thermal sensor in degree Celsius.

◆ [] [3/4]

NvS32 { ... } ::defaultMinTemp

Minimum default temperature value of the thermal sensor in degree Celsius.

◆ defaultMinTemp [4/4]

NvS32 NV_GPU_THERMAL_SETTINGS_V2::defaultMinTemp

Minimum default temperature value of the thermal sensor in degree Celsius.

◆ densityScaleX [1/2]

float _NV_MRS_CUSTOM_CONFIG_V1::densityScaleX[3]

(IN) Pixel density scale factors: how much the linear pixel density is scaled within each row and column (1.0 = full density)

◆ densityScaleX [2/2]

float _NV_MRS_INSTANCED_STEREO_CONFIG_V1::densityScaleX[5]

(OUT) Pixel density scale factors: how much the linear pixel density is scaled within each row and column (1.0 = full density)

◆ densityScaleY [1/2]

float _NV_MRS_CUSTOM_CONFIG_V1::densityScaleY[3]

◆ densityScaleY [2/2]

float _NV_MRS_INSTANCED_STEREO_CONFIG_V1::densityScaleY[3]

◆ depth [1/4]

NvU32 NV_DISPLAY_PATH::depth

(IN) Depth of the mode

◆ [] [2/4]

NV_DESKTOP_COLOR_DEPTH { ... } ::depth

One of NV_DESKTOP_COLOR_DEPTH enum values.

◆ depth [3/4]

NV_DESKTOP_COLOR_DEPTH _NV_COLOR_DATA_V5::depth

One of NV_DESKTOP_COLOR_DEPTH enum values.

◆ depth [4/4]

NvU32 NV_CUSTOM_DISPLAY::depth

Source surface color depth."0" means all 8/16/32bpp.

◆ DepthBias

INT NvAPI_D3D11_RASTERIZER_DESC_EX::DepthBias

◆ DepthBiasClamp

FLOAT NvAPI_D3D11_RASTERIZER_DESC_EX::DepthBiasClamp

◆ DepthClipEnable

BOOL NvAPI_D3D11_RASTERIZER_DESC_EX::DepthClipEnable

◆ desc

D3D12_CPU_DESCRIPTOR_HANDLE NVAPI_D3D12_GET_CUDA_INDEPENDENT_DESCRIPTOR_OBJECT_PARAMS::desc

[in] CPU descriptor handle of the UAV

◆ DescA

NV_META_COMMAND_TENSOR_DESC NV_META_COMMAND_CREATE_GEMM_DESC::DescA

◆ DescB

NV_META_COMMAND_TENSOR_DESC NV_META_COMMAND_CREATE_GEMM_DESC::DescB

◆ DescBias

NV_META_COMMAND_OPTIONAL_TENSOR_DESC NV_META_COMMAND_CREATE_CONVOLUTION_EX_DESC::DescBias

◆ DescC

NV_META_COMMAND_OPTIONAL_TENSOR_DESC NV_META_COMMAND_CREATE_GEMM_DESC::DescC

◆ DescFilter

NV_META_COMMAND_TENSOR_DESC NV_META_COMMAND_CREATE_CONVOLUTION_EX_DESC::DescFilter

◆ DescIn

NV_META_COMMAND_TENSOR_DESC NV_META_COMMAND_CREATE_CONVOLUTION_EX_DESC::DescIn

◆ DescOut [1/2]

NV_META_COMMAND_TENSOR_DESC NV_META_COMMAND_CREATE_CONVOLUTION_EX_DESC::DescOut

◆ DescOut [2/2]

NV_META_COMMAND_TENSOR_DESC NV_META_COMMAND_CREATE_GEMM_DESC::DescOut

◆ descsLayout

D3D12_ELEMENTS_LAYOUT _NVAPI_D3D12_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_INPUTS_EX::descsLayout

If type is D3D12_RAYTRACING_ACCELERATION_STRUCTURE_BOTTOM_LEVEL, it specifies which of pGeometryDescs and ppGeometryDescs to use. Otherwise, this parameter is unused.

◆ desired_content_max_frame_average_luminance [1/6]

NvU16 _NV_HDR_CAPABILITIES_V1::desired_content_max_frame_average_luminance

Desired maximum Frame-Average Light Level (MaxFALL) of HDR content ([0x0001-0xFFFF] = [1.0 - 65535.0] cd/m^2)

◆ [] [2/6]

NvU16 { ... } ::desired_content_max_frame_average_luminance

Desired maximum Frame-Average Light Level (MaxFALL) of HDR content ([0x0001-0xFFFF] = [1.0 - 65535.0] cd/m^2)

◆ desired_content_max_frame_average_luminance [3/6]

NvU16 _NV_HDR_CAPABILITIES_V2::desired_content_max_frame_average_luminance

Desired maximum Frame-Average Light Level (MaxFALL) of HDR content ([0x0001-0xFFFF] = [1.0 - 65535.0] cd/m^2)

◆ [] [4/6]

NvU16 { ... } ::desired_content_max_frame_average_luminance

Desired maximum Frame-Average Light Level (MaxFALL) of HDR content ([0x0001-0xFFFF] = [1.0 - 65535.0] cd/m^2)

◆ desired_content_max_frame_average_luminance [5/6]

NvU16 _NV_HDR_CAPABILITIES_V3::desired_content_max_frame_average_luminance

Desired maximum Frame-Average Light Level (MaxFALL) of HDR content ([0x0000-0xFFFF] = [0.0 - 65535.0] cd/m^2, in units of 1 cd/m^2)

◆ [] [6/6]

NvU16 { ... } ::desired_content_max_frame_average_luminance

Desired maximum Frame-Average Light Level (MaxFALL) of HDR content ([0x0000-0xFFFF] = [0.0 - 65535.0] cd/m^2, in units of 1 cd/m^2)

◆ desired_content_max_luminance [1/6]

NvU16 _NV_HDR_CAPABILITIES_V1::desired_content_max_luminance

Maximum display luminance = desired max luminance of HDR content ([0x0001-0xFFFF] = [1.0 - 65535.0] cd/m^2)

◆ [] [2/6]

NvU16 { ... } ::desired_content_max_luminance

Maximum display luminance = desired max luminance of HDR content ([0x0001-0xFFFF] = [1.0 - 65535.0] cd/m^2)

◆ [] [3/6]

NvU16 { ... } ::desired_content_max_luminance

Maximum display luminance = desired max luminance of HDR content ([0x0001-0xFFFF] = [1.0 - 65535.0] cd/m^2)

◆ desired_content_max_luminance [4/6]

NvU16 _NV_HDR_CAPABILITIES_V2::desired_content_max_luminance

Maximum display luminance = desired max luminance of HDR content ([0x0001-0xFFFF] = [1.0 - 65535.0] cd/m^2)

◆ [] [5/6]

NvU16 { ... } ::desired_content_max_luminance

Maximum display luminance = desired max luminance of HDR content ([0x0000-0xFFFF] = [0.0 - 65535.0] cd/m^2, in units of 1 cd/m^2)

◆ desired_content_max_luminance [6/6]

NvU16 _NV_HDR_CAPABILITIES_V3::desired_content_max_luminance

Maximum display luminance = desired max luminance of HDR content ([0x0000-0xFFFF] = [0.0 - 65535.0] cd/m^2, in units of 1 cd/m^2)

◆ [] [1/6]

NvU16 { ... } ::desired_content_min_luminance

Minimum display luminance = desired min luminance of HDR content ([0x0001-0xFFFF] = [1.0 - 6.55350] cd/m^2)

◆ desired_content_min_luminance [2/6]

NvU16 _NV_HDR_CAPABILITIES_V1::desired_content_min_luminance

Minimum display luminance = desired min luminance of HDR content ([0x0001-0xFFFF] = [1.0 - 6.55350] cd/m^2)

◆ desired_content_min_luminance [3/6]

NvU16 _NV_HDR_CAPABILITIES_V2::desired_content_min_luminance

Minimum display luminance = desired min luminance of HDR content ([0x0001-0xFFFF] = [1.0 - 6.55350] cd/m^2)

◆ [] [4/6]

NvU16 { ... } ::desired_content_min_luminance

Minimum display luminance = desired min luminance of HDR content ([0x0001-0xFFFF] = [1.0 - 6.55350] cd/m^2)

◆ [] [5/6]

NvU16 { ... } ::desired_content_min_luminance

Minimum display luminance = desired min luminance of HDR content ([0x0000-0xFFFF] = [0.0 - 6.55350] cd/m^2, in units of 0.0001 cd/m^2)

◆ desired_content_min_luminance [6/6]

NvU16 _NV_HDR_CAPABILITIES_V3::desired_content_min_luminance

Minimum display luminance = desired min luminance of HDR content ([0x0000-0xFFFF] = [0.0 - 6.55350] cd/m^2, in units of 0.0001 cd/m^2)

◆ destAccelerationStructureData

D3D12_GPU_VIRTUAL_ADDRESS _NVAPI_D3D12_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_DESC_EX::destAccelerationStructureData

Memory where the resulting acceleration structure will be stored.

◆ destBuffer [1/2]

D3D12_GPU_VIRTUAL_ADDRESS _NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_ARRAY_POSTBUILD_INFO_DESC::destBuffer

Result storage. Size required and the layout of the contents written by the system depend on infoType. The memory pointed to must be in state D3D12_RESOURCE_STATE_UNORDERED_ACCESS. The memory must be aligned to the natural alignment for the members of the particular output structure being generated (e.g. 8 bytes for a struct with the largest member being NvU64).

◆ destBuffer [2/2]

D3D12_GPU_VIRTUAL_ADDRESS _NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_POSTBUILD_INFO_DESC::destBuffer

Result storage. Size required and the layout of the contents written by the system depend on infoType. The memory pointed to must be in state D3D12_RESOURCE_STATE_UNORDERED_ACCESS. The memory must be aligned to the natural alignment for the members of the particular output structure being generated (e.g. 8 bytes for a struct with the largest member being NvU64).

◆ destDisplacementMicromapArrayData

D3D12_GPU_VIRTUAL_ADDRESS _NVAPI_D3D12_BUILD_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_DESC::destDisplacementMicromapArrayData

Output location for the DMM Array build. NvAPI_D3D12_GetRaytracingDisplacementMicromapArrayPrebuildInfo() reports the amount of memory required for the result given a set of input parameters. The address must be aligned to 256 bytes (NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_BYTE_ALIGNMENT).

◆ destEnumIndex

NvU32 NvU32 destEnumIndex

◆ destOpacityMicromapArrayData

D3D12_GPU_VIRTUAL_ADDRESS _NVAPI_D3D12_BUILD_RAYTRACING_OPACITY_MICROMAP_ARRAY_DESC::destOpacityMicromapArrayData

Output location for the OMM Array build. NvAPI_D3D12_GetRaytracingOpacityMicromapArrayPrebuildInfo() reports the amount of memory required for the result given a set of input parameters. The address must be aligned to 256 bytes (NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_ARRAY_BYTE_ALIGNMENT).

◆ details [1/2]

NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO* _NV_DISPLAYCONFIG_PATH_TARGET_INFO_V1::details

May be NULL if no advanced settings are required. NULL for Non-NVIDIA Display.

◆ details [2/2]

NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO* _NV_DISPLAYCONFIG_PATH_TARGET_INFO_V2::details

May be NULL if no advanced settings are required.

◆ device

NvU16 NVLINK_DEVICE_INFO_V1::device

◆ deviceId [1/4]

NvU32 NV_CHIPSET_INFO_v4::deviceId

Chipset device identification.

◆ deviceId [2/4]

NvU32 NV_CHIPSET_INFO_v3::deviceId

device ID

◆ deviceId [3/4]

NvU32 NV_CHIPSET_INFO_v2::deviceId

device ID

◆ deviceId [4/4]

NvU32 NV_CHIPSET_INFO_v1::deviceId

◆ deviceIdFlags

NvU32 NVLINK_DEVICE_INFO_V1::deviceIdFlags

ID Flags, Bitmask that specifies which IDs are valid for the GPU. Refer NVAPI_NVLINK_DEVICE_INFO_DEVICE_ID_FLAGS_* for possible values. If NVAPI_NVLINK_DEVICE_INFO_DEVICE_ID_FLAGS_PCI is set, PCI information is valid. If NVAPI_NVLINK_DEVICE_INFO_DEVICE_ID_FLAGS_UUID is set, UUID is valid.

◆ deviceMask [1/3]

NvU32 NV_VIEW_TARGET_INFO::deviceMask

(IN/OUT) Device mask

◆ [] [2/3]

NvU32 { ... } ::deviceMask

(IN/OUT) Device mask

◆ deviceMask [3/3]

NvU32 NV_DISPLAY_PATH::deviceMask

(IN) Device mask

◆ devices [1/2]

NV_GPU_CLIENT_ILLUM_DEVICE_INFO_V1 _NV_GPU_CLIENT_ILLUM_DEVICE_INFO_PARAMS_V1::devices[NV_GPU_CLIENT_ILLUM_DEVICE_NUM_DEVICES_MAX]

◆ devices [2/2]

NV_GPU_CLIENT_ILLUM_DEVICE_CONTROL_V1 NV_GPU_CLIENT_ILLUM_DEVICE_CONTROL_PARAMS_V1::devices[NV_GPU_CLIENT_ILLUM_DEVICE_NUM_DEVICES_MAX]

◆ deviceType

NvU64 NVLINK_DEVICE_INFO_V1::deviceType

GPU Type. See NVAPI_NVLINK_DEVICE_INFO_DEVICE_TYPE_* for possible values.

◆ deviceUUID

NvU8 NVLINK_DEVICE_INFO_V1::deviceUUID[16]

GPU UUID.

◆ Dilation

NvU64 NV_META_COMMAND_CREATE_CONVOLUTION_EX_DESC::Dilation[NV_META_COMMAND_NUM_SPATIAL_DIM]

◆ DimensionCount [1/2]

NvU64 NV_META_COMMAND_TENSOR_DESC::DimensionCount

◆ DimensionCount [2/2]

NvU64 NV_META_COMMAND_CREATE_CONVOLUTION_EX_DESC::DimensionCount

◆ dipSwitch

NvU32 _NVVIOCAPS::dipSwitch

On-board DIP switch settings bits.

◆ dipSwitchReserved

NvU32 _NVVIOCAPS::dipSwitchReserved

On-board DIP switch settings reserved bits.

◆ Direction

NvU64 NV_META_COMMAND_CREATE_CONVOLUTION_EX_DESC::Direction

◆ disableVirtualModeSupport

NvU32 _NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_V1::disableVirtualModeSupport

◆ displacementMicromapArray [1/2]

D3D12_GPU_VIRTUAL_ADDRESS _NVAPI_D3D12_RAYTRACING_GEOMETRY_DMM_ATTACHMENT_DESC::displacementMicromapArray

Pointer to a DMM Array used by this geometry. Unlike vertex, index, and transform buffers, this resource is dereferenced during raytracing.

◆ displacementMicromapArray [2/2]

D3D12_GPU_VIRTUAL_ADDRESS _NVAPI_RELOCATE_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PARAMS_V1::displacementMicromapArray

[in] DMM Array current memory address; it must be 256-byte aligned (NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_BYTE_ALIGNMENT).

◆ [struct] [1/3]

struct { ... } _NV_HDR_CAPABILITIES_V1::display_data

◆ [struct] [2/3]

struct { ... } _NV_HDR_CAPABILITIES_V2::display_data

◆ [struct] [3/3]

struct { ... } _NV_HDR_CAPABILITIES_V3::display_data

◆ displayCount [1/3]

NvU32 _NV_MOSAIC_GRID_TOPO_V1::displayCount

Number of display details.

◆ displayCount [2/3]

NvU32 _NV_MOSAIC_GRID_TOPO_V2::displayCount

Number of display details.

◆ displayCount [3/3]

NvU32 NV_MOSAIC_DISPLAY_TOPO_STATUS::displayCount

(OUT) The number of valid entries in the displays array.

◆ displayId [1/12]

NvU32 _NV_DISPLAYCONFIG_PATH_TARGET_INFO_V1::displayId

Display ID.

◆ displayId [2/12]

NvU32 _NV_DISPLAYCONFIG_PATH_TARGET_INFO_V2::displayId

Display ID.

◆ displayId [3/12]

NvU32 _NV_GPU_DISPLAYIDS::displayId

this is a unique identifier for each device

◆ displayId [4/12]

NvU32 NV_SET_PREFERRED_STEREO_DISPLAY_V1::displayId

[in] Monitor Identifier to be set

◆ displayId [5/12]

NvU32 NV_GET_PREFERRED_STEREO_DISPLAY_V1::displayId

[out] The queried stereo display

◆ displayId [6/12]

NvU32 _NV_MANAGED_DEDICATED_DISPLAY_INFO::displayId

[out] DisplayId.

◆ displayId [7/12]

NvU32 _NV_MANAGED_DEDICATED_DISPLAY_METADATA::displayId

[in] DisplayId to identify the display connector the metadata operation is requested for.

◆ displayId [8/12]

NvU32 _NV_MOSAIC_GRID_TOPO_DISPLAY_V1::displayId

DisplayID of the display.

◆ displayId [9/12]

NvU32 _NV_MOSAIC_GRID_TOPO_DISPLAY_V2::displayId

DisplayID of the display.

◆ [] [10/12]

NvU32 { ... } ::displayId

(OUT) The DisplayID of this display.

◆ displayId [11/12]

NvU32 NV_MOSAIC_DISPLAY_TOPO_STATUS::displayId

(OUT) The DisplayID of this display.

◆ displayId [12/12]

NvU32 _NV_GSYNC_DISPLAY::displayId

display identifier for displays.The GPU to which it is connected, can be retireved from NvAPI_SYS_GetPhysicalGpuFromDisplayId

◆ displayMask [1/3]

NvU32 NV_I2C_INFO_V1::displayMask

The Display Mask of the concerned display.

◆ displayMask [2/3]

NvU32 NV_I2C_INFO_V2::displayMask

The Display Mask of the concerned display.

◆ displayMask [3/3]

NvU32 NV_I2C_INFO_V3::displayMask

The Display Mask of the concerned display.

◆ [] [1/4]

NvU32 { ... } ::displayOutputId

Connected display target (0 if no display connected)

◆ displayOutputId [2/4]

NvU32 NV_MOSAIC_TOPO_DETAILS::displayOutputId

Connected display target (0 if no display connected)

◆ [] [3/4]

NvU32 { ... } ::displayOutputId

Connected display target.

◆ displayOutputId [4/4]

NvU32 NV_MOSAIC_TOPOLOGY::displayOutputId

Connected display target.

◆ displayPrimary_x0 [1/11]

NvU16 _NV_HDR_CAPABILITIES_V1::displayPrimary_x0

x coordinate of color primary 0 (e.g. Red) of the display ([0x0000-0xC350] = [0.0 - 1.0])

◆ [] [2/11]

NvU16 { ... } ::displayPrimary_x0

x coordinate of color primary 0 (e.g. Red) of the display ([0x0000-0xC350] = [0.0 - 1.0])

◆ displayPrimary_x0 [3/11]

NvU16 _NV_HDR_CAPABILITIES_V2::displayPrimary_x0

x coordinate of color primary 0 (e.g. Red) of the display ([0x0000-0xC350] = [0.0 - 1.0])

◆ [] [4/11]

NvU16 { ... } ::displayPrimary_x0

x coordinate of color primary 0 (e.g. Red) of the display ([0x0000-0xC350] = [0.0 - 1.0])

◆ displayPrimary_x0 [5/11]

NvU16 _NV_HDR_CAPABILITIES_V3::displayPrimary_x0

x coordinate of color primary 0 (e.g. Red) of the display ([0x0000-0xC350] = [0.0 - 1.0])

◆ [] [6/11]

NvU16 { ... } ::displayPrimary_x0

x coordinate of color primary 0 (e.g. Red) of the display ([0x0000-0xC350] = [0.0 - 1.0])

◆ displayPrimary_x0 [7/11]

NvU16 _NV_HDR_COLOR_DATA_V1::displayPrimary_x0

x coordinate of color primary 0 (e.g. Red) of mastering display ([0x0000-0xC350] = [0.0 - 1.0])

◆ [] [8/11]

NvU16 { ... } ::displayPrimary_x0

x coordinate of color primary 0 (e.g. Red) of mastering display ([0x0000-0xC350] = [0.0 - 1.0])

◆ [] [9/11]

NvU16 { ... } ::displayPrimary_x0

x coordinate of color primary 0 (e.g. Red) of mastering display ([0x0000-0xC350] = [0.0 - 1.0])

◆ displayPrimary_x0 [10/11]

NvU16 _NV_HDR_COLOR_DATA_V2::displayPrimary_x0

x coordinate of color primary 0 (e.g. Red) of mastering display ([0x0000-0xC350] = [0.0 - 1.0])

◆ displayPrimary_x0 [11/11]

NvU16 _NV_HDR_METADATA_V1::displayPrimary_x0

x coordinate of color primary 0 (e.g. Red) of mastering display ([0x0000-0xC350] = [0.0 - 1.0])

◆ [] [1/11]

NvU16 { ... } ::displayPrimary_x1

x coordinate of color primary 1 (e.g. Green) of the display ([0x0000-0xC350] = [0.0 - 1.0])

◆ displayPrimary_x1 [2/11]

NvU16 _NV_HDR_CAPABILITIES_V1::displayPrimary_x1

x coordinate of color primary 1 (e.g. Green) of the display ([0x0000-0xC350] = [0.0 - 1.0])

◆ [] [3/11]

NvU16 { ... } ::displayPrimary_x1

x coordinate of color primary 1 (e.g. Green) of the display ([0x0000-0xC350] = [0.0 - 1.0])

◆ displayPrimary_x1 [4/11]

NvU16 _NV_HDR_CAPABILITIES_V2::displayPrimary_x1

x coordinate of color primary 1 (e.g. Green) of the display ([0x0000-0xC350] = [0.0 - 1.0])

◆ [] [5/11]

NvU16 { ... } ::displayPrimary_x1

x coordinate of color primary 1 (e.g. Green) of the display ([0x0000-0xC350] = [0.0 - 1.0])

◆ displayPrimary_x1 [6/11]

NvU16 _NV_HDR_CAPABILITIES_V3::displayPrimary_x1

x coordinate of color primary 1 (e.g. Green) of the display ([0x0000-0xC350] = [0.0 - 1.0])

◆ displayPrimary_x1 [7/11]

NvU16 _NV_HDR_COLOR_DATA_V1::displayPrimary_x1

x coordinate of color primary 1 (e.g. Green) of mastering display ([0x0000-0xC350] = [0.0 - 1.0])

◆ [] [8/11]

NvU16 { ... } ::displayPrimary_x1

x coordinate of color primary 1 (e.g. Green) of mastering display ([0x0000-0xC350] = [0.0 - 1.0])

◆ displayPrimary_x1 [9/11]

NvU16 _NV_HDR_COLOR_DATA_V2::displayPrimary_x1

x coordinate of color primary 1 (e.g. Green) of mastering display ([0x0000-0xC350] = [0.0 - 1.0])

◆ [] [10/11]

NvU16 { ... } ::displayPrimary_x1

x coordinate of color primary 1 (e.g. Green) of mastering display ([0x0000-0xC350] = [0.0 - 1.0])

◆ displayPrimary_x1 [11/11]

NvU16 _NV_HDR_METADATA_V1::displayPrimary_x1

x coordinate of color primary 1 (e.g. Green) of mastering display ([0x0000-0xC350] = [0.0 - 1.0])

◆ [] [1/11]

NvU16 { ... } ::displayPrimary_x2

x coordinate of color primary 2 (e.g. Blue) of the display ([0x0000-0xC350] = [0.0 - 1.0])

◆ displayPrimary_x2 [2/11]

NvU16 _NV_HDR_CAPABILITIES_V1::displayPrimary_x2

x coordinate of color primary 2 (e.g. Blue) of the display ([0x0000-0xC350] = [0.0 - 1.0])

◆ displayPrimary_x2 [3/11]

NvU16 _NV_HDR_CAPABILITIES_V2::displayPrimary_x2

x coordinate of color primary 2 (e.g. Blue) of the display ([0x0000-0xC350] = [0.0 - 1.0])

◆ [] [4/11]

NvU16 { ... } ::displayPrimary_x2

x coordinate of color primary 2 (e.g. Blue) of the display ([0x0000-0xC350] = [0.0 - 1.0])

◆ [] [5/11]

NvU16 { ... } ::displayPrimary_x2

x coordinate of color primary 2 (e.g. Blue) of the display ([0x0000-0xC350] = [0.0 - 1.0])

◆ displayPrimary_x2 [6/11]

NvU16 _NV_HDR_CAPABILITIES_V3::displayPrimary_x2

x coordinate of color primary 2 (e.g. Blue) of the display ([0x0000-0xC350] = [0.0 - 1.0])

◆ displayPrimary_x2 [7/11]

NvU16 _NV_HDR_COLOR_DATA_V1::displayPrimary_x2

x coordinate of color primary 2 (e.g. Blue) of mastering display ([0x0000-0xC350] = [0.0 - 1.0])

◆ [] [8/11]

NvU16 { ... } ::displayPrimary_x2

x coordinate of color primary 2 (e.g. Blue) of mastering display ([0x0000-0xC350] = [0.0 - 1.0])

◆ displayPrimary_x2 [9/11]

NvU16 _NV_HDR_COLOR_DATA_V2::displayPrimary_x2

x coordinate of color primary 2 (e.g. Blue) of mastering display ([0x0000-0xC350] = [0.0 - 1.0])

◆ [] [10/11]

NvU16 { ... } ::displayPrimary_x2

x coordinate of color primary 2 (e.g. Blue) of mastering display ([0x0000-0xC350] = [0.0 - 1.0])

◆ displayPrimary_x2 [11/11]

NvU16 _NV_HDR_METADATA_V1::displayPrimary_x2

x coordinate of color primary 2 (e.g. Blue) of mastering display ([0x0000-0xC350] = [0.0 - 1.0])

◆ [] [1/11]

NvU16 { ... } ::displayPrimary_y0

y coordinate of color primary 0 (e.g. Red) of the display ([0x0000-0xC350] = [0.0 - 1.0])

◆ displayPrimary_y0 [2/11]

NvU16 _NV_HDR_CAPABILITIES_V1::displayPrimary_y0

y coordinate of color primary 0 (e.g. Red) of the display ([0x0000-0xC350] = [0.0 - 1.0])

◆ displayPrimary_y0 [3/11]

NvU16 _NV_HDR_CAPABILITIES_V2::displayPrimary_y0

y coordinate of color primary 0 (e.g. Red) of the display ([0x0000-0xC350] = [0.0 - 1.0])

◆ [] [4/11]

NvU16 { ... } ::displayPrimary_y0

y coordinate of color primary 0 (e.g. Red) of the display ([0x0000-0xC350] = [0.0 - 1.0])

◆ displayPrimary_y0 [5/11]

NvU16 _NV_HDR_CAPABILITIES_V3::displayPrimary_y0

y coordinate of color primary 0 (e.g. Red) of the display ([0x0000-0xC350] = [0.0 - 1.0])

◆ [] [6/11]

NvU16 { ... } ::displayPrimary_y0

y coordinate of color primary 0 (e.g. Red) of the display ([0x0000-0xC350] = [0.0 - 1.0])

◆ [] [7/11]

NvU16 { ... } ::displayPrimary_y0

y coordinate of color primary 0 (e.g. Red) of mastering display ([0x0000-0xC350] = [0.0 - 1.0])

◆ displayPrimary_y0 [8/11]

NvU16 _NV_HDR_COLOR_DATA_V1::displayPrimary_y0

y coordinate of color primary 0 (e.g. Red) of mastering display ([0x0000-0xC350] = [0.0 - 1.0])

◆ displayPrimary_y0 [9/11]

NvU16 _NV_HDR_COLOR_DATA_V2::displayPrimary_y0

y coordinate of color primary 0 (e.g. Red) of mastering display ([0x0000-0xC350] = [0.0 - 1.0])

◆ [] [10/11]

NvU16 { ... } ::displayPrimary_y0

y coordinate of color primary 0 (e.g. Red) of mastering display ([0x0000-0xC350] = [0.0 - 1.0])

◆ displayPrimary_y0 [11/11]

NvU16 _NV_HDR_METADATA_V1::displayPrimary_y0

y coordinate of color primary 0 (e.g. Red) of mastering display ([0x0000-0xC350] = [0.0 - 1.0])

◆ displayPrimary_y1 [1/11]

NvU16 _NV_HDR_CAPABILITIES_V1::displayPrimary_y1

y coordinate of color primary 1 (e.g. Green) of the display ([0x0000-0xC350] = [0.0 - 1.0])

◆ [] [2/11]

NvU16 { ... } ::displayPrimary_y1

y coordinate of color primary 1 (e.g. Green) of the display ([0x0000-0xC350] = [0.0 - 1.0])

◆ [] [3/11]

NvU16 { ... } ::displayPrimary_y1

y coordinate of color primary 1 (e.g. Green) of the display ([0x0000-0xC350] = [0.0 - 1.0])

◆ displayPrimary_y1 [4/11]

NvU16 _NV_HDR_CAPABILITIES_V2::displayPrimary_y1

y coordinate of color primary 1 (e.g. Green) of the display ([0x0000-0xC350] = [0.0 - 1.0])

◆ displayPrimary_y1 [5/11]

NvU16 _NV_HDR_CAPABILITIES_V3::displayPrimary_y1

y coordinate of color primary 1 (e.g. Green) of the display ([0x0000-0xC350] = [0.0 - 1.0])

◆ [] [6/11]

NvU16 { ... } ::displayPrimary_y1

y coordinate of color primary 1 (e.g. Green) of the display ([0x0000-0xC350] = [0.0 - 1.0])

◆ [] [7/11]

NvU16 { ... } ::displayPrimary_y1

y coordinate of color primary 1 (e.g. Green) of mastering display ([0x0000-0xC350] = [0.0 - 1.0])

◆ displayPrimary_y1 [8/11]

NvU16 _NV_HDR_COLOR_DATA_V1::displayPrimary_y1

y coordinate of color primary 1 (e.g. Green) of mastering display ([0x0000-0xC350] = [0.0 - 1.0])

◆ displayPrimary_y1 [9/11]

NvU16 _NV_HDR_COLOR_DATA_V2::displayPrimary_y1

y coordinate of color primary 1 (e.g. Green) of mastering display ([0x0000-0xC350] = [0.0 - 1.0])

◆ [] [10/11]

NvU16 { ... } ::displayPrimary_y1

y coordinate of color primary 1 (e.g. Green) of mastering display ([0x0000-0xC350] = [0.0 - 1.0])

◆ displayPrimary_y1 [11/11]

NvU16 _NV_HDR_METADATA_V1::displayPrimary_y1

y coordinate of color primary 1 (e.g. Green) of mastering display ([0x0000-0xC350] = [0.0 - 1.0])

◆ displayPrimary_y2 [1/11]

NvU16 _NV_HDR_CAPABILITIES_V1::displayPrimary_y2

y coordinate of color primary 2 (e.g. Blue) of the display ([0x0000-0xC350] = [0.0 - 1.0])

◆ [] [2/11]

NvU16 { ... } ::displayPrimary_y2

y coordinate of color primary 2 (e.g. Blue) of the display ([0x0000-0xC350] = [0.0 - 1.0])

◆ [] [3/11]

NvU16 { ... } ::displayPrimary_y2

y coordinate of color primary 2 (e.g. Blue) of the display ([0x0000-0xC350] = [0.0 - 1.0])

◆ displayPrimary_y2 [4/11]

NvU16 _NV_HDR_CAPABILITIES_V2::displayPrimary_y2

y coordinate of color primary 2 (e.g. Blue) of the display ([0x0000-0xC350] = [0.0 - 1.0])

◆ [] [5/11]

NvU16 { ... } ::displayPrimary_y2

y coordinate of color primary 2 (e.g. Blue) of the display ([0x0000-0xC350] = [0.0 - 1.0])

◆ displayPrimary_y2 [6/11]

NvU16 _NV_HDR_CAPABILITIES_V3::displayPrimary_y2

y coordinate of color primary 2 (e.g. Blue) of the display ([0x0000-0xC350] = [0.0 - 1.0])

◆ [] [7/11]

NvU16 { ... } ::displayPrimary_y2

y coordinate of color primary 2 (e.g. Blue) of mastering display ([0x0000-0xC350] = [0.0 - 1.0])

◆ displayPrimary_y2 [8/11]

NvU16 _NV_HDR_COLOR_DATA_V1::displayPrimary_y2

y coordinate of color primary 2 (e.g. Blue) of mastering display ([0x0000-0xC350] = [0.0 - 1.0])

◆ displayPrimary_y2 [9/11]

NvU16 _NV_HDR_COLOR_DATA_V2::displayPrimary_y2

y coordinate of color primary 2 (e.g. Blue) of mastering display ([0x0000-0xC350] = [0.0 - 1.0])

◆ [] [10/11]

NvU16 { ... } ::displayPrimary_y2

y coordinate of color primary 2 (e.g. Blue) of mastering display ([0x0000-0xC350] = [0.0 - 1.0])

◆ displayPrimary_y2 [11/11]

NvU16 _NV_HDR_METADATA_V1::displayPrimary_y2

y coordinate of color primary 2 (e.g. Blue) of mastering display ([0x0000-0xC350] = [0.0 - 1.0])

◆ displays [1/3]

NV_MOSAIC_GRID_TOPO_DISPLAY_V1 _NV_MOSAIC_GRID_TOPO_V1::displays[NV_MOSAIC_MAX_DISPLAYS]

Displays are done as [(row * columns) + column].

◆ displays [2/3]

NV_MOSAIC_GRID_TOPO_DISPLAY_V2 _NV_MOSAIC_GRID_TOPO_V2::displays[NV_MOSAIC_MAX_DISPLAYS]

Displays are done as [(row * columns) + column].

◆ [struct] [3/3]

struct { ... } NV_MOSAIC_DISPLAY_TOPO_STATUS::displays[NVAPI_MAX_DISPLAYS]

◆ displaySettings [1/4]

NV_MOSAIC_DISPLAY_SETTING_V1 _NV_MOSAIC_SUPPORTED_TOPO_INFO_V1::displaySettings[NV_MOSAIC_DISPLAY_SETTINGS_MAX]

List of per display settings possible.

◆ displaySettings [2/4]

NV_MOSAIC_DISPLAY_SETTING_V2 _NV_MOSAIC_SUPPORTED_TOPO_INFO_V2::displaySettings[NV_MOSAIC_DISPLAY_SETTINGS_MAX]

List of per display settings possible.

◆ displaySettings [3/4]

NV_MOSAIC_DISPLAY_SETTING_V1 _NV_MOSAIC_GRID_TOPO_V1::displaySettings

Display settings.

◆ displaySettings [4/4]

NV_MOSAIC_DISPLAY_SETTING_V1 _NV_MOSAIC_GRID_TOPO_V2::displaySettings

Display settings.

◆ displaySettingsCount [1/2]

NvU32 _NV_MOSAIC_SUPPORTED_TOPO_INFO_V1::displaySettingsCount

Number of display settings in below array.

◆ displaySettingsCount [2/2]

NvU32 _NV_MOSAIC_SUPPORTED_TOPO_INFO_V2::displaySettingsCount

Number of display settings in below array.

◆ displayWhitePoint_x [1/11]

NvU16 _NV_HDR_CAPABILITIES_V1::displayWhitePoint_x

x coordinate of white point of the display ([0x0000-0xC350] = [0.0 - 1.0])

◆ [] [2/11]

NvU16 { ... } ::displayWhitePoint_x

x coordinate of white point of the display ([0x0000-0xC350] = [0.0 - 1.0])

◆ [] [3/11]

NvU16 { ... } ::displayWhitePoint_x

x coordinate of white point of the display ([0x0000-0xC350] = [0.0 - 1.0])

◆ displayWhitePoint_x [4/11]

NvU16 _NV_HDR_CAPABILITIES_V2::displayWhitePoint_x

x coordinate of white point of the display ([0x0000-0xC350] = [0.0 - 1.0])

◆ [] [5/11]

NvU16 { ... } ::displayWhitePoint_x

x coordinate of white point of the display ([0x0000-0xC350] = [0.0 - 1.0])

◆ displayWhitePoint_x [6/11]

NvU16 _NV_HDR_CAPABILITIES_V3::displayWhitePoint_x

x coordinate of white point of the display ([0x0000-0xC350] = [0.0 - 1.0])

◆ displayWhitePoint_x [7/11]

NvU16 _NV_HDR_COLOR_DATA_V1::displayWhitePoint_x

x coordinate of white point of mastering display ([0x0000-0xC350] = [0.0 - 1.0])

◆ [] [8/11]

NvU16 { ... } ::displayWhitePoint_x

x coordinate of white point of mastering display ([0x0000-0xC350] = [0.0 - 1.0])

◆ [] [9/11]

NvU16 { ... } ::displayWhitePoint_x

x coordinate of white point of mastering display ([0x0000-0xC350] = [0.0 - 1.0])

◆ displayWhitePoint_x [10/11]

NvU16 _NV_HDR_COLOR_DATA_V2::displayWhitePoint_x

x coordinate of white point of mastering display ([0x0000-0xC350] = [0.0 - 1.0])

◆ displayWhitePoint_x [11/11]

NvU16 _NV_HDR_METADATA_V1::displayWhitePoint_x

x coordinate of white point of mastering display ([0x0000-0xC350] = [0.0 - 1.0])

◆ displayWhitePoint_y [1/11]

NvU16 _NV_HDR_CAPABILITIES_V1::displayWhitePoint_y

y coordinate of white point of the display ([0x0000-0xC350] = [0.0 - 1.0])

◆ [] [2/11]

NvU16 { ... } ::displayWhitePoint_y

y coordinate of white point of the display ([0x0000-0xC350] = [0.0 - 1.0])

◆ [] [3/11]

NvU16 { ... } ::displayWhitePoint_y

y coordinate of white point of the display ([0x0000-0xC350] = [0.0 - 1.0])

◆ displayWhitePoint_y [4/11]

NvU16 _NV_HDR_CAPABILITIES_V2::displayWhitePoint_y

y coordinate of white point of the display ([0x0000-0xC350] = [0.0 - 1.0])

◆ [] [5/11]

NvU16 { ... } ::displayWhitePoint_y

y coordinate of white point of the display ([0x0000-0xC350] = [0.0 - 1.0])

◆ displayWhitePoint_y [6/11]

NvU16 _NV_HDR_CAPABILITIES_V3::displayWhitePoint_y

y coordinate of white point of the display ([0x0000-0xC350] = [0.0 - 1.0])

◆ displayWhitePoint_y [7/11]

NvU16 _NV_HDR_COLOR_DATA_V1::displayWhitePoint_y

y coordinate of white point of mastering display ([0x0000-0xC350] = [0.0 - 1.0])

◆ [] [8/11]

NvU16 { ... } ::displayWhitePoint_y

y coordinate of white point of mastering display ([0x0000-0xC350] = [0.0 - 1.0])

◆ [] [9/11]

NvU16 { ... } ::displayWhitePoint_y

y coordinate of white point of mastering display ([0x0000-0xC350] = [0.0 - 1.0])

◆ displayWhitePoint_y [10/11]

NvU16 _NV_HDR_COLOR_DATA_V2::displayWhitePoint_y

y coordinate of white point of mastering display ([0x0000-0xC350] = [0.0 - 1.0])

◆ displayWhitePoint_y [11/11]

NvU16 _NV_HDR_METADATA_V1::displayWhitePoint_y

y coordinate of white point of mastering display ([0x0000-0xC350] = [0.0 - 1.0])

◆ dm_version [1/4]

NvU32 _NV_HDR_CAPABILITIES_V2::dm_version

Upper Nibble represents major version of Display Management(DM) while lower represents minor version of DM.

◆ [] [2/4]

NvU32 { ... } ::dm_version

Upper Nibble represents major version of Display Management(DM) while lower represents minor version of DM.

◆ dm_version [3/4]

NvU32 _NV_HDR_CAPABILITIES_V3::dm_version

Upper Nibble represents major version of Display Management(DM) while lower represents minor version of DM.

◆ [] [4/4]

NvU32 { ... } ::dm_version

Upper Nibble represents major version of Display Management(DM) while lower represents minor version of DM.

◆ dmmAttachment

NVAPI_D3D12_RAYTRACING_GEOMETRY_DMM_ATTACHMENT_DESC _NVAPI_D3D12_RAYTRACING_GEOMETRY_DMM_TRIANGLES_DESC::dmmAttachment

Displacement Micromap attachment descriptor.

◆ [] [1/2]

NVAPI_D3D12_RAYTRACING_GEOMETRY_DMM_TRIANGLES_DESC { ... } ::dmmTriangles

Describes micro-triangle geometry, if type is NVAPI_D3D12_RAYTRACING_GEOMETRY_TYPE_DMM_TRIANGLES_EX. Otherwise, this parameter is unused (space repurposed in a union).

◆ dmmTriangles [2/2]

NVAPI_D3D12_RAYTRACING_GEOMETRY_DMM_TRIANGLES_DESC _NVAPI_D3D12_RAYTRACING_GEOMETRY_DESC_EX::dmmTriangles

Describes micro-triangle geometry, if type is NVAPI_D3D12_RAYTRACING_GEOMETRY_TYPE_DMM_TRIANGLES_EX. Otherwise, this parameter is unused (space repurposed in a union).

◆ domain [1/3]

NvU16 NVLINK_DEVICE_INFO_V1::domain

domain, bus, device, function, pciDeviceId : PCI information for the GPU.

◆ [struct] [2/3]

struct { ... } NV_GPU_CLOCK_FREQUENCIES_V1::domain[NVAPI_MAX_GPU_PUBLIC_CLOCKS]

◆ [struct] [3/3]

struct { ... } NV_GPU_CLOCK_FREQUENCIES_V2::domain[NVAPI_MAX_GPU_PUBLIC_CLOCKS]

◆ domainId [1/10]

NV_GPU_PUBLIC_CLOCK_ID NV_GPU_PSTATE20_CLOCK_ENTRY_V1::domainId

ID of the clock domain.

◆ [] [2/10]

NV_GPU_PERF_VOLTAGE_INFO_DOMAIN_ID { ... } ::domainId

Voltage domain ID and value range in (uV) required for this clock.

◆ domainId [3/10]

NV_GPU_PERF_VOLTAGE_INFO_DOMAIN_ID NV_GPU_PSTATE20_CLOCK_ENTRY_V1::domainId

Voltage domain ID and value range in (uV) required for this clock.

◆ domainId [4/10]

NV_GPU_PERF_VOLTAGE_INFO_DOMAIN_ID NV_GPU_PSTATE20_BASE_VOLTAGE_ENTRY_V1::domainId

ID of the voltage domain.

◆ [] [5/10]

NV_GPU_PUBLIC_CLOCK_ID { ... } ::domainId

ID of the clock domain.

◆ domainId [6/10]

NV_GPU_PUBLIC_CLOCK_ID NV_GPU_PERF_PSTATES_INFO_V1::domainId

ID of the clock domain.

◆ domainId [7/10]

NV_GPU_PUBLIC_CLOCK_ID NV_GPU_PERF_PSTATES_INFO_V2::domainId

◆ [] [8/10]

NV_GPU_PUBLIC_CLOCK_ID { ... } ::domainId

◆ [] [9/10]

NV_GPU_PERF_VOLTAGE_INFO_DOMAIN_ID { ... } ::domainId

ID of the voltage domain, containing flags and mvolt info.

◆ domainId [10/10]

NV_GPU_PERF_VOLTAGE_INFO_DOMAIN_ID NV_GPU_PERF_PSTATES_INFO_V2::domainId

ID of the voltage domain, containing flags and mvolt info.

◆ DontUseViewportOrder [1/2]

BOOL NvAPI_D3D11_CREATE_GEOMETRY_SHADER_EX_V5::DontUseViewportOrder

◆ DontUseViewportOrder [2/2]

BOOL NVAPI_D3D12_PSO_GEOMETRY_SHADER_DESC_V5::DontUseViewportOrder

◆ doubleBitErrors [1/3]

NvU64 NV_GPU_ECC_ERROR_INFO::doubleBitErrors

Number of double-bit ECC errors detected since last boot.

Number of double-bit ECC errors detected since last counter reset.

◆ [] [2/3]

NvU64 { ... } ::doubleBitErrors

Number of double-bit ECC errors detected since last boot.

◆ [] [3/3]

NvU64 { ... } ::doubleBitErrors

Number of double-bit ECC errors detected since last counter reset.

◆ downmixInhibit

NvU32 NV_INFOFRAME_AUDIO::downmixInhibit

◆ dpcd_ver

NvU32 _NV_DISPLAY_PORT_INFO_V1::dpcd_ver

DPCD version of the monitor.

◆ [struct]

struct { ... } _NVVIOCAPS::driver

Driver version.

◆ driverEndTime

NvU64 _NV_LATENCY_RESULT_PARAMS::FrameReport::driverEndTime

◆ driverExpandDefaultHdrParameters [1/3]

NvU32 _NV_HDR_CAPABILITIES_V1::driverExpandDefaultHdrParameters

If set, driver will expand default (=zero) HDR capabilities parameters contained in display's EDID. Boolean: 0 = report actual HDR parameters, 1 = expand default HDR parameters;

◆ driverExpandDefaultHdrParameters [2/3]

NvU32 _NV_HDR_CAPABILITIES_V2::driverExpandDefaultHdrParameters

If set, driver will expand default (=zero) HDR capabilities parameters contained in display's EDID. Boolean: 0 = report actual HDR parameters, 1 = expand default HDR parameters;

◆ driverExpandDefaultHdrParameters [3/3]

NvU32 _NV_HDR_CAPABILITIES_V3::driverExpandDefaultHdrParameters

If set, driver will expand default (=zero) HDR capabilities parameters contained in display's EDID. Boolean: 0 = report actual HDR parameters, 1 = expand default HDR parameters;

◆ driverReloadAllowed [1/2]

NvU32 _NV_MOSAIC_GRID_TOPO_V1::driverReloadAllowed

If necessary, reloading the driver is permitted (for Vista and above only). Will not be persisted. Value undefined on get.

◆ driverReloadAllowed [2/2]

NvU32 _NV_MOSAIC_GRID_TOPO_V2::driverReloadAllowed

If necessary, reloading the driver is permitted (for Vista and above only). Will not be persisted. Value undefined on get.

◆ driverStartTime

NvU64 _NV_LATENCY_RESULT_PARAMS::FrameReport::driverStartTime

◆ driverVersion [1/2]

NvU32 _NV_DISPLAY_DRIVER_INFO::driverVersion

Contains the driver version after successful return.

◆ driverVersion [2/2]

NvU32 _NV_DISPLAY_DRIVER_INFO_V2::driverVersion

Contains the driver version after successful return.

◆ drvVersion

NvU32 NV_DISPLAY_DRIVER_VERSION::drvVersion

◆ [struct] [1/2]

struct { ... } _NV_HDR_CAPABILITIES_V2::dv_static_metadata

◆ [struct] [2/2]

struct { ... } _NV_HDR_CAPABILITIES_V3::dv_static_metadata

◆ dwVersion [1/3]

NvU32 _NV_DX_VIDEO_STEREO_INFO::dwVersion

Must be NV_DX_VIDEO_STEREO_INFO_VER.

◆ dwVersion [2/3]

NvU32 _NV_JOIN_PRESENT_BARRIER_PARAMS::dwVersion

Must be NV_JOIN_PRESENT_BARRIER_PARAMS_VER1.

◆ dwVersion [3/3]

NvU32 _NV_PRESENT_BARRIER_FRAME_STATISTICS::dwVersion

Must be NV_PRESENT_BARRIER_FRAME_STATICS_VER1.

◆ dynamicRange [1/10]

NV_DP_DYNAMIC_RANGE _NV_DISPLAY_PORT_INFO_V1::dynamicRange

Dynamic range.

◆ dynamicRange [2/10]

NV_DP_DYNAMIC_RANGE NV_DISPLAY_PORT_CONFIG::dynamicRange

Dynamic range.

◆ dynamicRange [3/10]

NvU8 _NV_COLOR_DATA_V2::dynamicRange

One of NV_DYNAMIC_RANGE enum values.

◆ [] [4/10]

NvU8 { ... } ::dynamicRange

One of NV_DYNAMIC_RANGE enum values.

◆ dynamicRange [5/10]

NvU8 _NV_COLOR_DATA_V3::dynamicRange

One of NV_DYNAMIC_RANGE enum values.

◆ [] [6/10]

NvU8 { ... } ::dynamicRange

One of NV_DYNAMIC_RANGE enum values.

◆ [] [7/10]

NvU8 { ... } ::dynamicRange

One of NV_DYNAMIC_RANGE enum values.

◆ dynamicRange [8/10]

NvU8 _NV_COLOR_DATA_V4::dynamicRange

One of NV_DYNAMIC_RANGE enum values.

◆ [] [9/10]

NvU8 { ... } ::dynamicRange

One of NV_DYNAMIC_RANGE enum values.

◆ dynamicRange [10/10]

NvU8 _NV_COLOR_DATA_V5::dynamicRange

One of NV_DYNAMIC_RANGE enum values.

◆ dynSharedMemBytes [1/3]

NvU32 NVAPI_D3D12_CREATE_CUBIN_SHADER_PARAMS::dynSharedMemBytes

[in] dynamic shared memory required by the shader in bytes

◆ dynSharedMemBytes [2/3]

NvU32 _NVAPI_CU_KERNEL_LAUNCH_PARAMS::dynSharedMemBytes

◆ dynSharedMemBytes [3/3]

NvU32 _NVAPI_CU_KERNEL_LAUNCH_PARAMS_EX::dynSharedMemBytes

◆ EDID861ExtRev [1/2]

NvU32 _NV_HDMI_SUPPORT_INFO_V1::EDID861ExtRev

Revision number of the EDID 861 extension.

◆ EDID861ExtRev [2/2]

NvU32 _NV_HDMI_SUPPORT_INFO_V2::EDID861ExtRev

Revision number of the EDID 861 extension.

◆ EDID_Data [1/3]

NvU8 NV_EDID_V1::EDID_Data[NV_EDID_DATA_SIZE]

◆ EDID_Data [2/3]

NvU8 NV_EDID_V2::EDID_Data[NV_EDID_DATA_SIZE]

◆ EDID_Data [3/3]

NvU8 NV_EDID_V3::EDID_Data[NV_EDID_DATA_SIZE]

◆ edidId

NvU32 NV_EDID_V3::edidId

ID which always returned in a monotonically increasing counter. Across a split-EDID read we need to verify that all calls returned the same edidId. This counter is incremented if we get the updated EDID.

◆ eEyeIndex [1/2]

NV_SMP_ASSIST_EYE_INDEX _NV_SMP_ASSIST_ENABLE_PARAMS_V1::eEyeIndex

(IN) Rendering mode for upcoming draw calls (Mono/Stereo-Left/Stereo-Right/Instanced Stereo)

◆ eEyeIndex [2/2]

NV_SMP_ASSIST_EYE_INDEX _NV_SMP_ASSIST_GET_CONSTANTS_V3::eEyeIndex

(IN) Viewports/scissors/constant buffer data corresponding to the input eEyeIndex will be returned

◆ eFormat

NV_STEREO_VIDEO_FORMAT _NV_DX_VIDEO_STEREO_INFO::eFormat

Stereo format of the surface.

◆ [] [1/2]

NV_LMS_CONFIG { ... } ::eLMSConfig

(IN) If eSMPAssistType is LMS and SMP Assist Level is Full then provide LMS config enum

◆ eLMSConfig [2/2]

NV_LMS_CONFIG _NV_SMP_ASSIST_SETUP_PARAMS_V1::eLMSConfig

(IN) If eSMPAssistType is LMS and SMP Assist Level is Full then provide LMS config enum

◆ eMRSConfig [1/2]

NV_MRS_CONFIG _NV_SMP_ASSIST_SETUP_PARAMS_V1::eMRSConfig

(IN) If eSMPAssistType is MRS and SMP Assist Level is Full then provide MRS config enum

◆ [] [2/2]

NV_MRS_CONFIG { ... } ::eMRSConfig

(IN) If eSMPAssistType is MRS and SMP Assist Level is Full then provide MRS config enum

◆ enable422Filter [1/3]

NvU32 _NVVIOOUTPUTCONFIG_V1::enable422Filter

Enables/Disables 4:2:2 filter.

◆ enable422Filter [2/3]

NvU32 _NVVIOOUTPUTCONFIG_V2::enable422Filter

Enables/Disables 4:2:2 filter.

◆ enable422Filter [3/3]

NvU32 _NVVIOOUTPUTCONFIG_V3::enable422Filter

Enables/Disables 4:2:2 filter.

◆ enableAlphaKeyComposite [1/3]

NvU32 _NVVIOOUTPUTCONFIG_V1::enableAlphaKeyComposite

Enable Alpha key composite.

◆ enableAlphaKeyComposite [2/3]

NvU32 _NVVIOOUTPUTCONFIG_V2::enableAlphaKeyComposite

Enable Alpha key composite.

◆ enableAlphaKeyComposite [3/3]

NvU32 _NVVIOOUTPUTCONFIG_V3::enableAlphaKeyComposite

Enable Alpha key composite.

◆ enableANCTimeCodeGeneration [1/3]

NvU32 _NVVIOOUTPUTCONFIG_V1::enableANCTimeCodeGeneration

Enable SDI ANC time code generation.

◆ enableANCTimeCodeGeneration [2/3]

NvU32 _NVVIOOUTPUTCONFIG_V2::enableANCTimeCodeGeneration

Enable SDI ANC time code generation.

◆ enableANCTimeCodeGeneration [3/3]

NvU32 _NVVIOOUTPUTCONFIG_V3::enableANCTimeCodeGeneration

Enable SDI ANC time code generation.

◆ enableAudioBlanking

NvU32 _NVVIOOUTPUTCONFIG_V3::enableAudioBlanking

Enable HANC audio blanking on repeat frames.

◆ enableComposite [1/3]

NvU32 _NVVIOOUTPUTCONFIG_V1::enableComposite

Enable composite.

◆ enableComposite [2/3]

NvU32 _NVVIOOUTPUTCONFIG_V2::enableComposite

Enable composite.

◆ enableComposite [3/3]

NvU32 _NVVIOOUTPUTCONFIG_V3::enableComposite

Enable composite.

◆ enabled

NvU32 NV_MOSAIC_TOPO_BRIEF::enabled

1 if topo is enabled, else 0

◆ enableDataIntegrityCheck [1/3]

NvU32 _NVVIOOUTPUTCONFIG_V1::enableDataIntegrityCheck

Enable data integrity check: true - enable, false - disable.

◆ enableDataIntegrityCheck [2/3]

NvU32 _NVVIOOUTPUTCONFIG_V2::enableDataIntegrityCheck

Enable data integrity check: true - enable, false - disable.

◆ enableDataIntegrityCheck [3/3]

NvU32 _NVVIOOUTPUTCONFIG_V3::enableDataIntegrityCheck

Enable data integrity check: true - enable, false - disable.

◆ EnableDBT

bool NVAPI_D3D12_PSO_ENABLE_DEPTH_BOUND_TEST_DESC_V1::EnableDBT

◆ enableExclusiveScissorRect

bool _NV_D3D11_EXCLUSIVE_SCISSOR_RECT_DESC_V1::enableExclusiveScissorRect

(IN) Control of enabling Exclusive ScissorRect per rect

◆ enableFullColorRange [1/3]

NvU32 _NVVIOOUTPUTCONFIG_V1::enableFullColorRange

Flag indicating Full Color Range.

◆ enableFullColorRange [2/3]

NvU32 _NVVIOOUTPUTCONFIG_V2::enableFullColorRange

Flag indicating Full Color Range.

◆ enableFullColorRange [3/3]

NvU32 _NVVIOOUTPUTCONFIG_V3::enableFullColorRange

Flag indicating Full Color Range.

◆ enableRGBData [1/3]

NvU32 _NVVIOOUTPUTCONFIG_V1::enableRGBData

Indicates data is in RGB format.

◆ enableRGBData [2/3]

NvU32 _NVVIOOUTPUTCONFIG_V2::enableRGBData

Indicates data is in RGB format.

◆ enableRGBData [3/3]

NvU32 _NVVIOOUTPUTCONFIG_V3::enableRGBData

Indicates data is in RGB format.

◆ enableVariablePixelShadingRate

bool _NV_D3D11_VIEWPORT_SHADING_RATE_DESC_V1::enableVariablePixelShadingRate

(IN) Control of enabling Variable Pixel Shading Rate per viewport

◆ EndPadding

NvU64 NV_META_COMMAND_CREATE_CONVOLUTION_EX_DESC::EndPadding[NV_META_COMMAND_NUM_SPATIAL_DIM]

◆ enumIndex

NvU32 enumIndex

◆ errorFlags [1/2]

NvU32 NV_MOSAIC_DISPLAY_TOPO_STATUS::errorFlags

(OUT) Any of the NV_MOSAIC_DISPLAYTOPO_ERROR_* flags.

(OUT) Any of the NV_MOSAIC_DISPLAYCAPS_PROBLEM_* flags.

◆ [] [2/2]

NvU32 { ... } ::errorFlags

(OUT) Any of the NV_MOSAIC_DISPLAYCAPS_PROBLEM_* flags.

◆ eSMPAssistLevel [1/3]

NV_SMP_ASSIST_LEVEL _NV_SMP_ASSIST_GET_CONSTANTS_V3::eSMPAssistLevel

(OUT) SMP Assist level provided in Init call

◆ eSMPAssistLevel [2/3]

NV_SMP_ASSIST_LEVEL _NV_SMP_ASSIST_INITIALIZE_PARAMS_V1::eSMPAssistLevel

(IN) Full/Partial/Minimal

◆ eSMPAssistLevel [3/3]

NV_SMP_ASSIST_LEVEL _NV_QUERY_SMP_ASSIST_SUPPORT_PARAMS_V1::eSMPAssistLevel

(IN) Full/Partial/Minimal

◆ eSMPAssistType [1/4]

NV_SMP_ASSIST_TYPE _NV_SMP_ASSIST_GET_CONSTANTS_V3::eSMPAssistType

(OUT) SMP type provided in Init call

◆ eSMPAssistType [2/4]

NV_SMP_ASSIST_TYPE _NV_SMP_ASSIST_UPDATE_INSTANCEDSTEREO_DATA_PARAMS_V1::eSMPAssistType

◆ eSMPAssistType [3/4]

NV_SMP_ASSIST_TYPE _NV_SMP_ASSIST_INITIALIZE_PARAMS_V1::eSMPAssistType

(IN) None/MRS/LMS

◆ eSMPAssistType [4/4]

NV_SMP_ASSIST_TYPE _NV_QUERY_SMP_ASSIST_SUPPORT_PARAMS_V1::eSMPAssistType

(IN) None/MRS/LMS

◆ etc

NV_TIMINGEXT _NV_TIMING::etc

◆ eventId

NV_EVENT_TYPE NV_EVENT_REGISTER_CALLBACK::eventId

ID of the event being sent.

◆ ExecutionDirtyState

NV_D3D_GRAPHICS_STATES NVAPI_META_COMMAND_DESC::ExecutionDirtyState

◆ expansionEnable

NvU32 _NVVIOSTREAM::expansionEnable

Enable/disable 4:2:2->4:4:4 expansion.

◆ extendedColorimetry

NvU32 NV_INFOFRAME_VIDEO::extendedColorimetry

◆ extendedRevision [1/2]

NvU32 _NV_GSYNC_CAPABILITIES_V2::extendedRevision

FPGA minor revision.

◆ extendedRevision [2/2]

NvU32 _NV_GSYNC_CAPABILITIES_V3::extendedRevision

FPGA minor revision.

◆ fA

float _NV_MODIFIED_W_COEFFICIENTS::fA

◆ fallTimems

NvU16 _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR::fallTimems

Time in ms to transition from color B to color A.

◆ fAReserved

float _NV_MODIFIED_W_COEFFICIENTS::fAReserved

◆ fastNvLinkReads

NvU32 _NV_MULTIGPU_CAPS_V2::fastNvLinkReads

◆ fB

float _NV_MODIFIED_W_COEFFICIENTS::fB

◆ fBReserved

float _NV_MODIFIED_W_COEFFICIENTS::fBReserved

◆ featureCode [1/4]

NV_LICENSE_FEATURE_TYPE _NV_LICENSE_FEATURE_DETAILS_V1::featureCode

Feature code that corresponds to the licensable feature.

◆ featureCode [2/4]

NV_LICENSE_FEATURE_TYPE _NV_LICENSE_FEATURE_DETAILS_V2::featureCode

Feature code that corresponds to the licensable feature.

◆ featureCode [3/4]

NV_LICENSE_FEATURE_TYPE _NV_LICENSE_FEATURE_DETAILS_V3::featureCode

Feature code that corresponds to the licensable feature.

◆ featureCode [4/4]

NV_LICENSE_FEATURE_TYPE _NV_LICENSE_FEATURE_DETAILS_V4::featureCode

Feature code that corresponds to the licensable feature.

◆ featureId

NVAPI_ANSEL_FEATURE NVAPI_ANSEL_FEATURE_CONFIGURATION_STRUCT::featureId

Id of the feature.

◆ featureState

NVAPI_ANSEL_FEATURE_STATE NVAPI_ANSEL_FEATURE_CONFIGURATION_STRUCT::featureState

Whether the feature is enabled or not.

◆ fEyeOpenness

float _NV_FOVEATED_RENDERING_GAZE_DATA_PER_EYE::fEyeOpenness

(IN) Use flag NV_GAZE_EYE_OPENNESS_VALID. Unused at the moment.

◆ fFrameRate

float _NVVIOVIDEOMODE::fFrameRate

Frame rate.

◆ fGammaValueB

float _NVVIOGAMMACORRECTION::fGammaValueB

Blue Gamma value within gamma ranges. 0.5 - 6.0.

◆ fGammaValueG

float _NVVIOGAMMACORRECTION::fGammaValueG

Green Gamma value within gamma ranges. 0.5 - 6.0.

◆ fGammaValueR

float _NVVIOGAMMACORRECTION::fGammaValueR

Red Gamma value within gamma ranges. 0.5 - 6.0.

◆ fGazeDirection

float _NV_FOVEATED_RENDERING_GAZE_DATA_PER_EYE::fGazeDirection[3]

(IN) Use flag NV_GAZE_DIRECTION_VALID. Normalized direction of the gaze of the eye. Used for calculating the gaze location using the FOV.

◆ fGazeNormalizedLocation

float _NV_FOVEATED_RENDERING_GAZE_DATA_PER_EYE::fGazeNormalizedLocation[2]

(IN) Use flag NV_GAZE_LOCATION_VALID. Precalculated normalized gaze location in limits (-1 to +1) for X and Y. Center of the screen denotes (0, 0). If this is valid, this will be given higher priority than direction.

◆ fGazeOrigin_mm

float _NV_FOVEATED_RENDERING_GAZE_DATA_PER_EYE::fGazeOrigin_mm[3]

(IN) Use flag NV_GAZE_ORIGIN_VALID. Origin of the eye in millimeters. Used mainly to detect whether Left Eye or Right Eye.

◆ fGazeVelocity

float _NV_FOVEATED_RENDERING_GAZE_DATA_PER_EYE::fGazeVelocity[2]

(IN) Use flag NV_GAZE_VELOCITY_VALID. Optional: Velocity of the eye on the normalized space in each direction. Central foveated region would be skewed in the direction of the velocity.

◆ fHorizontalFOV [1/2]

float _NV_GAZE_HANDLER_INIT_PARAMS_V2::fHorizontalFOV

(IN) Horizontal Field of View

◆ fHorizontalFOV [2/2]

float _NV_GAZE_HANDLER_INIT_PARAMS_V1::fHorizontalFOV

(IN) Horizontal Field of View

◆ fields [1/3]

NvU32 _NVVIOCONFIG_V1::fields

Caller sets to NVVIOCONFIG_* mask for fields to use.

◆ fields [2/3]

NvU32 _NVVIOCONFIG_V2::fields

Caller sets to NVVIOCONFIG_* mask for fields to use.

◆ fields [3/3]

NvU32 _NVVIOCONFIG_V3::fields

Caller sets to NVVIOCONFIG_* mask for fields to use.

◆ fileInFolder [1/3]

NvAPI_UnicodeString _NVDRS_APPLICATION_V2::fileInFolder

Select this application only if this file is found. When specifying multiple files, separate them using the ':' character.

◆ fileInFolder [2/3]

NvAPI_UnicodeString _NVDRS_APPLICATION_V3::fileInFolder

Select this application only if this file is found. When specifying multiple files, separate them using the ':' character.

◆ fileInFolder [3/3]

NvAPI_UnicodeString _NVDRS_APPLICATION_V4::fileInFolder

Select this application only if this file is found. When specifying multiple files, separate them using the ':' character.

◆ FillMode

D3D11_FILL_MODE NvAPI_D3D11_RASTERIZER_DESC_EX::FillMode

◆ FilterResource [1/2]

NV_D3D11_META_COMMAND_RESOURCE NV_D3D11_META_COMMAND_EXECUTE_CONVOLUTION_EX_DESC::FilterResource

◆ FilterResource [2/2]

D3D12_GPU_VIRTUAL_ADDRESS NV_D3D12_META_COMMAND_EXECUTE_CONVOLUTION_EX_DESC::FilterResource

◆ fInnermostRadii

float _NV_FOVEATED_RENDERING_CUSTOM_FOVEATION_PATTERN_PRESET_DESC_V1::fInnermostRadii[2]

(IN) Horizontal and vertical radius for the inner-most region of the foveated rendering pattern

◆ [struct]

struct { ... } _NVVIOCAPS::firmWare

Firmware version.

◆ firmwareVersion

NvU8 _NV_GPU_GSP_INFO_V1::firmwareVersion[NVAPI_GPU_MAX_BUILD_VERSION_LENGTH]

[out] Contains GSP firmware version

◆ FirstArraySlice

UINT _NV_TEX2D_ARRAY_SRRV::FirstArraySlice

◆ flag [1/2]

NvU32 tagNV_TIMINGEXT::flag

Reserved for NVIDIA hardware-based enhancement, such as double-scan.

◆ flag [2/2]

NV_TIMING_FLAG _NV_TIMING_INPUT::flag

Flag containing additional info for timing calculation.

◆ [] [1/30]

NvU32 { ... } ::flags

One or more flags from nvcomp_gpu_top.

◆ flags [2/30]

NvU32 NV_COMPUTE_GPU_TOPOLOGY_V1::flags

One or more flags from nvcomp_gpu_top.

◆ flags [3/30]

NvU32 _NV_COMPUTE_GPU::flags

One or more flags from nvcomp_gpu_top.

◆ flags [4/30]

NvU32 NV_GPU_PERF_PSTATES_INFO_V1::flags

Reserved. Must be set to 0.

bit 0 indicates if perfmon is enabled or not

bit 1 indicates if dynamic Pstate is capable or not

bit 2 indicates if dynamic Pstate is enable or not

all other bits must be set to 0

bit 0 indicates if the PCIE limit is GEN1 or GEN2

bit 1 indicates if the Pstate is overclocked or not

bit 2 indicates if the Pstate is overclockable or not

all other bits must be set to 0

◆ [] [5/30]

NvU32 { ... } ::flags

bit 0 indicates if the PCIE limit is GEN1 or GEN2

bit 1 indicates if the Pstate is overclocked or not

bit 2 indicates if the Pstate is overclockable or not

all other bits must be set to 0

◆ [] [6/30]

NvU32 { ... } ::flags

Reserved. Must be set to 0.

◆ flags [7/30]

NvU32 NV_GPU_PERF_PSTATES_INFO_V2::flags

Reserved for future use. Must be set to 0.

bit 0 indicates if perfmon is enabled or not

bit 1 indicates if dynamic Pstate is capable or not

bit 2 indicates if dynamic Pstate is enable or not

all other bits must be set to 0

bit 0 indicates if the PCIE limit is GEN1 or GEN2

bit 1 indicates if the Pstate is overclocked or not

bit 2 indicates if the Pstate is overclockable or not

all other bits must be set to 0

bit 0 indicates if this clock is overclockable all other bits must be set to 0

◆ [] [8/30]

NvU32 { ... } ::flags

bit 0 indicates if the PCIE limit is GEN1 or GEN2

bit 1 indicates if the Pstate is overclocked or not

bit 2 indicates if the Pstate is overclockable or not

all other bits must be set to 0

◆ [] [9/30]

NvU32 { ... } ::flags

bit 0 indicates if this clock is overclockable all other bits must be set to 0

◆ [] [10/30]

NvU32 { ... } ::flags

Reserved for future use. Must be set to 0.

◆ flags [11/30]

NvU32 NV_GPU_DYNAMIC_PSTATES_INFO_EX::flags

bit 0 indicates if the dynamic Pstate is enabled or not

◆ flags [12/30]

NvU32 NvAPI_D3D11_CREATE_FASTGS_EXPLICIT_DESC_V1::flags

◆ flags [13/30]

NvU32 NVAPI_D3D12_PSO_CREATE_FASTGS_EXPLICIT_DESC_V1::flags

◆ Flags

NvU64 NV_META_COMMAND_TENSOR_DESC::Flags

◆ flags [14/30]

NvU32 _NV_VRS_HELPER_LATCH_GAZE_PARAMS_V1::flags

(IN) Reserved for future use

◆ flags [15/30]

NvU32 _NV_FOVEATED_RENDERING_DESC_V1::flags

(IN) Reserved for future use

◆ flags [16/30]

NvU32 _NV_VRS_HELPER_ENABLE_PARAMS_V1::flags

(IN) Reserved for future use

◆ flags [17/30]

NvU32 _NV_VRS_HELPER_INIT_PARAMS_V1::flags

(IN) Reserved for future use

◆ flags [18/30]

NvU32 _NV_FOVEATED_RENDERING_UPDATE_GAZE_DATA_PARAMS::flags

(IN) Reserved for future use

◆ flags [19/30]

NvU32 _NV_GAZE_HANDLER_INIT_PARAMS_V2::flags

(IN) Reserved for future use

◆ flags [20/30]

NvU32 _NV_GAZE_HANDLER_INIT_PARAMS_V1::flags

(IN) Reserved for future use

◆ flags [21/30]

NvU32 _NV_SMP_ASSIST_INITIALIZE_PARAMS_V1::flags

(IN) Flags, if any

◆ flags [22/30]

NvU32 NVAPI_D3D12_CREATE_CUBIN_SHADER_PARAMS::flags

[in] reserved, set to 0

◆ flags [23/30]

NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_BUILD_FLAGS _NVAPI_D3D12_BUILD_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_INPUTS::flags

Flags which apply to all DMMs in the array.

◆ flags [24/30]

NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_ARRAY_BUILD_FLAGS _NVAPI_D3D12_BUILD_RAYTRACING_OPACITY_MICROMAP_ARRAY_INPUTS::flags

Flags which apply to all OMMs in the array.

◆ flags [25/30]

NvU32 _NVAPI_D3D12_SET_CREATE_PIPELINE_STATE_OPTIONS_PARAMS_V1::flags

[in] A bitwise OR of one or more NVAPI_D3D12_PIPELINE_CREATION_STATE_FLAGS flags for raytracing pipeline creation.

◆ flags [26/30]

D3D12_RAYTRACING_GEOMETRY_FLAGS _NVAPI_D3D12_RAYTRACING_GEOMETRY_DESC_EX::flags

Flags affecting how this geometry is processed by the raytracing pipeline.

◆ flags [27/30]

NVAPI_D3D12_RAYTRACING_ACCELERATION_STRUCTURE_BUILD_FLAGS_EX _NVAPI_D3D12_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_INPUTS_EX::flags

Options influencing how the acceleration structure is built and which of its features can be used.

◆ flags [28/30]

NvU32 NV_CHIPSET_INFO_v4::flags

Chipset info flags - obsolete.

◆ flags [29/30]

NvU32 NV_CHIPSET_INFO_v3::flags

Chipset info flags - obsolete.

◆ flags [30/30]

NvU32 NV_CHIPSET_INFO_v2::flags

Chipset info flags.

◆ flagsRsvd

NvU32 _NV_SET_REFLEX_SYNC_PARAMS::flagsRsvd

(IN) Reserved flag bits. Must be set to 0s.

◆ FlipInSyncCount

NvU32 _NV_PRESENT_BARRIER_FRAME_STATISTICS::FlipInSyncCount

The total count of flips from this client since the returned SyncMode is PRESENT_BARRIER_SYNC_SYSTEM or PRESENT_BARRIER_SYNC_CLUSTER. If the returned SyncMode is any other mode, this value is 0. This count is set back to 0 in case the SyncMode switches away from PRESENT_BARRIER_SYNC_SYSTEM or PRESENT_BARRIER_SYNC_CLUSTER.

◆ flipQueueLength [1/3]

NvU32 _NVVIOOUTPUTCONFIG_V1::flipQueueLength

Number of buffers used for the internal flipqueue.

◆ flipQueueLength [2/3]

NvU32 _NVVIOOUTPUTCONFIG_V2::flipQueueLength

Number of buffers used for the internal flip queue.

◆ flipQueueLength [3/3]

NvU32 _NVVIOOUTPUTCONFIG_V3::flipQueueLength

Number of buffers used for the internal flip queue.

◆ fMiddleRadii

float _NV_FOVEATED_RENDERING_CUSTOM_FOVEATION_PATTERN_PRESET_DESC_V1::fMiddleRadii[2]

(IN) Horizontal and vertical radius for the middle region of the foveated rendering pattern

◆ forcedDockMechanismPresent

NvU32 NV_LID_DOCK_PARAMS::forcedDockMechanismPresent

◆ forcedLidMechanismPresent

NvU32 NV_LID_DOCK_PARAMS::forcedLidMechanismPresent

◆ ForcedSampleCount [1/2]

NvU32 NvAPI_D3D11_RASTERIZER_DESC_EX::ForcedSampleCount

◆ ForcedSampleCount [2/2]

NvU8 NVAPI_D3D12_PSO_RASTERIZER_STATE_DESC_V1::ForcedSampleCount

◆ ForceFastGS [1/2]

BOOL NvAPI_D3D11_CREATE_GEOMETRY_SHADER_EX_V5::ForceFastGS

◆ ForceFastGS [2/2]

BOOL NVAPI_D3D12_PSO_GEOMETRY_SHADER_DESC_V5::ForceFastGS

◆ Format

DXGI_FORMAT _NV_D3D11_SHADING_RATE_RESOURCE_VIEW_DESC_V1::Format

(IN) Format of the resource used as Shading Rate Surface. Should be either DXGI_FORMAT_R8_UINT or DXGI_FORMAT_R8_TYPELESS

◆ format [1/4]

NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_FORMAT _NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_USAGE_COUNT::format

Displacement Micromap format.

◆ format [2/4]

NvU16 _NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_DESC::format

Format of the DMM of type NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_FORMAT.

◆ format [3/4]

NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_FORMAT _NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_USAGE_COUNT::format

Opacity Micromap format.

◆ format [4/4]

NvU16 _NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_DESC::format

Format of the OMM of type NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_FORMAT.

◆ FoveationPatternCustomPresetDesc

NV_FOVEATED_RENDERING_CUSTOM_FOVEATION_PATTERN_PRESET_DESC_V1 _NV_FOVEATED_RENDERING_DESC_V1::FoveationPatternCustomPresetDesc

(IN) To be provided only if FoveationPatternPreset is NV_FOVEATED_RENDERING_FOVEATION_PATTERN_PRESET_CUSTOM

◆ FoveationPatternPreset

NV_FOVEATED_RENDERING_FOVEATION_PATTERN_PRESET _NV_FOVEATED_RENDERING_DESC_V1::FoveationPatternPreset

(IN) Preset of the foveation pattern

◆ fPeripheralRadii

float _NV_FOVEATED_RENDERING_CUSTOM_FOVEATION_PATTERN_PRESET_DESC_V1::fPeripheralRadii[2]

(IN) Horizontal and vertical radius for the peripheral region of the foveated rendering pattern

◆ fPupilDiameter_mm

float _NV_FOVEATED_RENDERING_GAZE_DATA_PER_EYE::fPupilDiameter_mm

(IN) Use flag NV_GAZE_PUPIL_DIAMETER_VALID. Unused at the moment.

◆ frameID [1/3]

NvU64 _NV_LATENCY_RESULT_PARAMS::FrameReport::frameID

◆ frameID [2/3]

NvU64 _NV_LATENCY_MARKER_PARAMS::frameID

◆ frameID [3/3]

NvU64 _NV_ASYNC_FRAME_MARKER_PARAMS_V1::frameID

◆ frameIntervalUs [1/2]

NvU32 _NV_GET_VIRTUAL_REFRESH_RATE_DATA_V1::frameIntervalUs

[out] frame interval in micro seconds if Virtual RR is currently applied

◆ frameIntervalUs [2/2]

NvU32 _NV_SET_VIRTUAL_REFRESH_RATE_DATA_V1::frameIntervalUs

[in] frame interval in micro seconds if Virtual RR is currently applied

◆ frameLockEnable [1/4]

NvU32 _NVVIOOUTPUTSTATUS::frameLockEnable

Framelock enable flag.

◆ frameLockEnable [2/4]

NvU32 _NVVIOOUTPUTCONFIG_V1::frameLockEnable

Flag indicating whether framelock was on/off.

◆ frameLockEnable [3/4]

NvU32 _NVVIOOUTPUTCONFIG_V2::frameLockEnable

Flag indicating whether framelock was on/off.

◆ frameLockEnable [4/4]

NvU32 _NVVIOOUTPUTCONFIG_V3::frameLockEnable

Flag indicating whether framelock was on/off.

◆ frameReport

struct _NV_LATENCY_RESULT_PARAMS::FrameReport _NV_LATENCY_RESULT_PARAMS::frameReport[64]

◆ [] [1/6]

NvU32 { ... } ::freq

Clock frequency in kHz.

◆ freq [2/6]

NvU32 NV_GPU_PERF_PSTATES_INFO_V1::freq

Clock frequency in kHz.

◆ freq [3/6]

NvU32 NV_GPU_PERF_PSTATES_INFO_V2::freq

◆ [] [4/6]

NvU32 { ... } ::freq

◆ freq [5/6]

NvU32 _NV_MOSAIC_DISPLAY_SETTING_V1::freq

Display frequency.

◆ freq [6/6]

NvU32 NV_MOSAIC_DISPLAY_SETTING_V2::freq

Display frequency.

◆ [] [1/2]

NvU32 { ... } ::freq_kHz

Clock frequency within given pstate in (kHz)

◆ freq_kHz [2/2]

NvU32 NV_GPU_PSTATE20_CLOCK_ENTRY_V1::freq_kHz

Clock frequency within given pstate in (kHz)

◆ freqDelta_kHz

NV_GPU_PERF_PSTATES20_PARAM_DELTA NV_GPU_PSTATE20_CLOCK_ENTRY_V1::freqDelta_kHz

Current frequency delta from nominal settings in (kHz)

◆ frequency [1/4]

NvU32 NV_GPU_CLOCK_FREQUENCIES_V1::frequency

Clock frequency (kHz)

◆ [] [2/4]

NvU32 { ... } ::frequency

Clock frequency (kHz)

◆ [] [3/4]

NvU32 { ... } ::frequency

Clock frequency (kHz)

◆ frequency [4/4]

NvU32 NV_GPU_CLOCK_FREQUENCIES_V2::frequency

Clock frequency (kHz)

◆ fReserved

float _NV_MODIFIED_W_COEFFICIENTS::fReserved[2]

◆ FrontCounterClockwise

BOOL NvAPI_D3D11_RASTERIZER_DESC_EX::FrontCounterClockwise

◆ [] [1/2]

NvU16 { ... } ::full_frame_peak_luminance_index

Full frame peak luminance index.

◆ full_frame_peak_luminance_index [2/2]

NvU16 _NV_HDR_CAPABILITIES_V3::full_frame_peak_luminance_index

Full frame peak luminance index.

◆ function

NvU16 NVLINK_DEVICE_INFO_V1::function

◆ Function

NvU64 NV_META_COMMAND_ACTIVATION_DESC::Function

◆ FuseDesc

NV_META_COMMAND_CONVOLUTION_FUSE_DESC NV_META_COMMAND_CREATE_CONVOLUTION_EX_FUSED_DESC::FuseDesc

◆ Future10

NvU32 NV_INFOFRAME_AUDIO::Future10

◆ Future12

NvU32 NV_INFOFRAME_AUDIO::Future12

◆ Future17

NvU32 NV_INFOFRAME_VIDEO::Future17

◆ Future2x

NvU32 NV_INFOFRAME_AUDIO::Future2x

◆ Future3x

NvU32 NV_INFOFRAME_AUDIO::Future3x

◆ Future47

NvU32 NV_INFOFRAME_VIDEO::Future47

◆ Future52

NvU32 NV_INFOFRAME_AUDIO::Future52

◆ Future6

NvU32 NV_INFOFRAME_AUDIO::Future6

◆ Future7

NvU32 NV_INFOFRAME_AUDIO::Future7

◆ Future8

NvU32 NV_INFOFRAME_AUDIO::Future8

◆ Future9

NvU32 NV_INFOFRAME_AUDIO::Future9

◆ fVericalFOV [1/2]

float _NV_GAZE_HANDLER_INIT_PARAMS_V2::fVericalFOV

(IN) Vertical Field of View

◆ fVericalFOV [2/2]

float _NV_GAZE_HANDLER_INIT_PARAMS_V1::fVericalFOV

(IN) Vertical Field of View

◆ gammaCorrection [1/3]

NVVIOGAMMACORRECTION _NVVIOOUTPUTCONFIG_V1::gammaCorrection

◆ gammaCorrection [2/3]

NVVIOGAMMACORRECTION _NVVIOOUTPUTCONFIG_V2::gammaCorrection

◆ gammaCorrection [3/3]

NVVIOGAMMACORRECTION _NVVIOOUTPUTCONFIG_V3::gammaCorrection

◆ [union]

union { ... } _NVVIOGAMMACORRECTION::gammaRamp

Gamma correction:

◆ [] [1/2]

NVVIOGAMMARAMP10 { ... } ::gammaRamp10

Gamma ramp (10-bit index, 16-bit values)

◆ gammaRamp10 [2/2]

NVVIOGAMMARAMP10 _NVVIOGAMMACORRECTION::gammaRamp10

Gamma ramp (10-bit index, 16-bit values)

◆ [] [1/2]

NVVIOGAMMARAMP8 { ... } ::gammaRamp8

Gamma ramp (8-bit index, 16-bit values)

◆ gammaRamp8 [2/2]

NVVIOGAMMARAMP8 _NVVIOGAMMACORRECTION::gammaRamp8

Gamma ramp (8-bit index, 16-bit values)

◆ GazeDataDeviceId [1/3]

NvU32 _NV_FOVEATED_RENDERING_DESC_V1::GazeDataDeviceId

(IN) ID of the gaze data provider. Needed only for supporting more than one device with eye tracking.

◆ GazeDataDeviceId [2/3]

NvU32 _NV_GAZE_HANDLER_INIT_PARAMS_V2::GazeDataDeviceId

(IN) ID of the gaze data provider. Needed only for supporting more than one device with eye tracking.

◆ GazeDataDeviceId [3/3]

NvU32 _NV_GAZE_HANDLER_INIT_PARAMS_V1::GazeDataDeviceId

(IN) ID of the gaze data provider. Needed only for supporting more than one device with eye tracking.

◆ GazeDataType [1/2]

NV_GAZE_DATA_TYPE _NV_GAZE_HANDLER_INIT_PARAMS_V2::GazeDataType

(IN) Describes whether gaze is Mono or Stereo

◆ GazeDataType [2/2]

NV_GAZE_DATA_TYPE _NV_GAZE_HANDLER_INIT_PARAMS_V1::GazeDataType

(IN) Describes whether gaze is Mono or Stereo

◆ GazeDataValidityFlags

NvU32 _NV_FOVEATED_RENDERING_GAZE_DATA_PER_EYE::GazeDataValidityFlags

(IN) To be populated with OR'ing flags from NV_GAZE_DATA_VALIDITY_FLAGS

◆ geforce

NvU32 _NVDRS_GPU_SUPPORT::geforce

◆ geometryDescStrideInBytes

NvU32 _NVAPI_D3D12_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_INPUTS_EX::geometryDescStrideInBytes

Stride between consecutive geometry descriptors. Should typically be set to sizeof(NVAPI_D3D12_RAYTRACING_GEOMETRY_DESC_EX). Only used if type is D3D12_RAYTRACING_ACCELERATION_STRUCTURE_TYPE_BOTTOM_LEVEL and descLayout is D3D12_ELEMENTS_LAYOUT_ARRAY. This field guarantees backwards compatibility, even if the geometry descriptor size increases in future NVAPI versions.

◆ gpioPinBlue

NvU8 _NV_GPU_CLIENT_ILLUM_DEVICE_INFO_DATA_GPIO_PWM_RGBW::gpioPinBlue

Blue drive GPIO pin.

◆ gpioPinGreen

NvU8 _NV_GPU_CLIENT_ILLUM_DEVICE_INFO_DATA_GPIO_PWM_RGBW::gpioPinGreen

Green drive GPIO pin.

◆ gpioPinRed

NvU8 _NV_GPU_CLIENT_ILLUM_DEVICE_INFO_DATA_GPIO_PWM_RGBW::gpioPinRed

Red drive GPIO pin.

◆ gpioPinSingleColor

NvU8 _NV_GPU_CLIENT_ILLUM_DEVICE_INFO_DATA_GPIO_PWM_SINGLE_COLOR::gpioPinSingleColor

Single Color GPIO pin.

◆ gpioPinWhite

NvU8 _NV_GPU_CLIENT_ILLUM_DEVICE_INFO_DATA_GPIO_PWM_RGBW::gpioPinWhite

White drive GPIO pin.

◆ [] [1/2]

NV_GPU_CLIENT_ILLUM_DEVICE_INFO_DATA_GPIO_PWM_RGBW { ... } ::gpioPwmRgbwv10

◆ gpioPwmRgbwv10 [2/2]

NV_GPU_CLIENT_ILLUM_DEVICE_INFO_DATA_GPIO_PWM_RGBW _NV_GPU_CLIENT_ILLUM_DEVICE_INFO_V1::gpioPwmRgbwv10

◆ [] [1/2]

NV_GPU_CLIENT_ILLUM_DEVICE_INFO_DATA_GPIO_PWM_SINGLE_COLOR { ... } ::gpioPwmSingleColorv10

◆ gpioPwmSingleColorv10 [2/2]

NV_GPU_CLIENT_ILLUM_DEVICE_INFO_DATA_GPIO_PWM_SINGLE_COLOR _NV_GPU_CLIENT_ILLUM_DEVICE_INFO_V1::gpioPwmSingleColorv10

◆ gpuActiveRenderTimeUs

NvU32 _NV_LATENCY_RESULT_PARAMS::FrameReport::gpuActiveRenderTimeUs

(OUT) Difference between gpuRenderStartTime and gpuRenderEndTime, excluding the idles in between, in microseconds.

◆ gpuCount [1/2]

NvU32 NV_COMPUTE_GPU_TOPOLOGY_V1::gpuCount

Total number of compute-capable GPUs.

◆ gpuCount [2/2]

NvU32 _NV_COMPUTE_GPU_TOPOLOGY_V2::gpuCount

Size of array.

◆ gpuFrameTimeUs

NvU32 _NV_LATENCY_RESULT_PARAMS::FrameReport::gpuFrameTimeUs

(OUT) Difference between previous and current frame's gpuRenderEndTime, in microseconds.

◆ gpuHandleCount [1/2]

NvU32 _NV_PHYSICAL_GPUS::gpuHandleCount

◆ gpuHandleCount [2/2]

NvU32 _NV_LOGICAL_GPUS::gpuHandleCount

◆ gpuHandleData [1/2]

NV_LOGICAL_GPU_HANDLE_DATA _NV_LOGICAL_GPUS::gpuHandleData[NVAPI_MAX_LOGICAL_GPUS]

◆ gpuHandleData [2/2]

NV_PHYSICAL_GPU_HANDLE_DATA _NV_PHYSICAL_GPUS::gpuHandleData[NVAPI_MAX_PHYSICAL_GPUS]

◆ gpuId

NvU32 NV_DISPLAY_PATH::gpuId

(IN) the physical display/target Gpu id which is the owner of the scan out (for SLI multimon, display from the slave Gpu)

◆ [struct] [1/2]

struct { ... } NV_MOSAIC_TOPO_DETAILS::gpuLayout[NVAPI_MAX_MOSAIC_DISPLAY_ROWS][NVAPI_MAX_MOSAIC_DISPLAY_COLUMNS]

◆ [struct] [2/2]

struct { ... } NV_MOSAIC_TOPOLOGY::gpuLayout[NVAPI_MAX_MOSAIC_DISPLAY_ROWS][NVAPI_MAX_MOSAIC_DISPLAY_COLUMNS]

◆ gpuRenderEndTime

NvU64 _NV_LATENCY_RESULT_PARAMS::FrameReport::gpuRenderEndTime

◆ gpuRenderStartTime

NvU64 _NV_LATENCY_RESULT_PARAMS::FrameReport::gpuRenderStartTime

◆ gpuSupport

NVDRS_GPU_SUPPORT _NVDRS_PROFILE_V1::gpuSupport

This read-only flag indicates the profile support on either Quadro, or Geforce, or both.

◆ gpuVASize [1/3]

NvU64 NVAPI_UAV_INFO_V1::gpuVASize

[OUT] virtual memory size

◆ gpuVASize [2/3]

NvU64 NVAPI_UAV_INFO_V2::gpuVASize

[OUT] virtual memory size

◆ gpuVASize [3/3]

NvU64 NV_GET_GPU_VIRTUAL_ADDRESS_V1::gpuVASize

[OUT] virtual memory size

◆ gpuVAStart [1/3]

NvU64 NVAPI_UAV_INFO_V1::gpuVAStart

[OUT] gpu virtual address where resource starts

◆ gpuVAStart [2/3]

NvU64 NVAPI_UAV_INFO_V2::gpuVAStart

[OUT] gpu virtual address where resource starts

◆ gpuVAStart [3/3]

NvU64 NV_GET_GPU_VIRTUAL_ADDRESS_V1::gpuVAStart

[OUT] gpu virtual address where resource starts

◆ gridDim [1/2]

NVAPI_DIM3 _NVAPI_CU_KERNEL_LAUNCH_PARAMS::gridDim

◆ gridDim [2/2]

NVAPI_DIM3 _NVAPI_CU_KERNEL_LAUNCH_PARAMS_EX::gridDim

◆ GroupCount

NvU64 NV_META_COMMAND_CREATE_CONVOLUTION_EX_DESC::GroupCount

◆ grpCount

NvU8 _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR::grpCount

Number of times to repeat function within group period.

◆ grpIdleTimems

NvU16 _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR::grpIdleTimems

Time in ms to remain idle before next group of repeated function cycles.

◆ h

float NV_VIEWPORTF::h

Height of the viewport.

◆ handle

NvU64 NVAPI_D3D12_GET_CUDA_INDEPENDENT_DESCRIPTOR_OBJECT_PARAMS::handle

[out] A pointer to memory that receives the driver handle

◆ has3dEntries

NvU8 _NV_MONITOR_CAPS_VSDB::has3dEntries

Byte 10.

◆ hasInterlacedLatencyField

NvU8 _NV_MONITOR_CAPS_VSDB::hasInterlacedLatencyField

Byte 5.

◆ hasLatencyField

NvU8 _NV_MONITOR_CAPS_VSDB::hasLatencyField

Byte 5.

◆ hasVicEntries

NvU8 _NV_MONITOR_CAPS_VSDB::hasVicEntries

Byte 5.

◆ HBdeviceId

NvU32 NV_CHIPSET_INFO_v4::HBdeviceId

Host bridge device identification.

◆ HBorder

NvU16 _NV_TIMING::HBorder

horizontal border

◆ HBsubSysDeviceId

NvU32 NV_CHIPSET_INFO_v4::HBsubSysDeviceId

Host bridge subsystem device identification.

◆ HBsubSysVendorId

NvU32 NV_CHIPSET_INFO_v4::HBsubSysVendorId

Host bridge subsystem vendor identification.

◆ HBvendorId

NvU32 NV_CHIPSET_INFO_v4::HBvendorId

Host bridge vendor identification.

◆ hdcpFuseState

NV_GPU_HDCP_FUSE_STATE NV_GPU_GET_HDCP_SUPPORT_STATUS::hdcpFuseState

Structure version constucted by macro NV_GPU_GET_HDCP_SUPPORT_STATUS.

◆ hdcpKeySource

NV_GPU_HDCP_KEY_SOURCE NV_GPU_GET_HDCP_SUPPORT_STATUS::hdcpKeySource

GPU's HDCP fuse state.

◆ hdcpKeySourceState

NV_GPU_HDCP_KEY_SOURCE_STATE NV_GPU_GET_HDCP_SUPPORT_STATUS::hdcpKeySourceState

GPU's HDCP key source.

◆ hdmi3dLength

NvU8 _NV_MONITOR_CAPS_VSDB::hdmi3dLength

Byte 11.

◆ hdmi_3d

NvU8 _NV_MONITOR_CAPS_VSDB::hdmi_3d[31]

Keeping maximum length for 5 bits.

◆ hdmi_vic

NvU8 _NV_MONITOR_CAPS_VSDB::hdmi_vic[7]

Keeping maximum length for 3 bits.

◆ hdmiVicLength

NvU8 _NV_MONITOR_CAPS_VSDB::hdmiVicLength

Byte 11.

◆ [struct]

struct { ... } _NV_HDR_CAPABILITIES_V3::hdr10plus_vsvdb

◆ hdrBpc

NV_BPC _NV_HDR_COLOR_DATA_V2::hdrBpc

Optional, One of NV_BPC enum values, if set it will apply requested color depth Dolby Vision mode: DV supports specific combinations of colorformat, dynamic range and bpc. Please refer Dolby Vision specification. If invalid or no combination is passed driver will force default combination of RGB format + full range + 8bpc. HDR mode: These fields are ignored in hdr mode

◆ hdrColorFormat

NV_COLOR_FORMAT _NV_HDR_COLOR_DATA_V2::hdrColorFormat

Optional, One of NV_COLOR_FORMAT enum values, if set it will apply requested color format for HDR session.

◆ hdrDynamicRange

NV_DYNAMIC_RANGE _NV_HDR_COLOR_DATA_V2::hdrDynamicRange

Optional, One of NV_DYNAMIC_RANGE enum values, if set it will apply requested dynamic range for HDR session.

◆ hdrMode [1/2]

NV_HDR_MODE _NV_HDR_COLOR_DATA_V1::hdrMode

HDR mode.

◆ hdrMode [2/2]

NV_HDR_MODE _NV_HDR_COLOR_DATA_V2::hdrMode

HDR mode.

◆ height [1/9]

NvU32 NV_DISPLAY_PATH::height

(IN) Height of the mode

◆ height [2/9]

NvU32 _NV_RESOLUTION::height

◆ height [3/9]

NvU32 NV_SCANOUT_INTENSITY_DATA_V1::height

height of the input texture

◆ height [4/9]

NvU32 NV_SCANOUT_INTENSITY_DATA_V2::height

height of the input texture

◆ height [5/9]

NvU32 _NV_TIMING_INPUT::height

Visible vertical size.

◆ height [6/9]

NvU32 NV_CUSTOM_DISPLAY::height

Source surface(source mode) height.

◆ height [7/9]

NvU32 _NV_MOSAIC_DISPLAY_SETTING_V1::height

Per-display height.

◆ height [8/9]

NvU32 NV_MOSAIC_DISPLAY_SETTING_V2::height

Per-display height.

◆ height [9/9]

NvU32 _NVVIOOUTPUTREGION::height

Height of region in pixels.

◆ HFrontPorch

NvU16 _NV_TIMING::HFrontPorch

horizontal front porch

◆ hFunction [1/2]

NVDX_ObjectHandle _NVAPI_CU_KERNEL_LAUNCH_PARAMS::hFunction

◆ hFunction [2/2]

NVDX_ObjectHandle _NVAPI_CU_KERNEL_LAUNCH_PARAMS_EX::hFunction

◆ highestNciVersion

NvU8 NVLINK_GET_CAPS_V1::highestNciVersion

This field specifies the highest supported NCI version for this GPU.

◆ highestNvlinkVersion

NvU8 NVLINK_GET_CAPS_V1::highestNvlinkVersion

This field specifies the highest supported NVLink version for this GPU.

◆ hLinkedSurface

NVDX_ObjectHandle _NV_DX_VIDEO_STEREO_INFO::hLinkedSurface

The linked surface (must be valid when eFormat==NV_STEREO_VIDEO_FORMAT_TWO_FRAMES_LR)

◆ hLogicalGPU

NvLogicalGpuHandle NV_MOSAIC_TOPO_DETAILS::hLogicalGPU

Logical GPU for this topology.

◆ hLogicalGpu

NvLogicalGpuHandle _NV_LOGICAL_GPU_HANDLE_DATA::hLogicalGpu

◆ horizontalDelay

NvU32 _NVVIOSYNCDELAY::horizontalDelay

Horizontal delay in pixels.

◆ horizontalPixels

NvU32 _NVVIOVIDEOMODE::horizontalPixels

Horizontal resolution (in pixels)

◆ hotkey

UINT NVAPI_ANSEL_FEATURE_CONFIGURATION_STRUCT::hotkey

An optional virtual key associated with this feature.

◆ hotkeyModifier

NVAPI_ANSEL_HOTKEY_MODIFIER NVAPI_ANSEL_CONFIGURATION_STRUCT_V1::hotkeyModifier

Modifier key to use in hotkey combination.

◆ hour

NvU16 _NV_LICENSE_EXPIRY_DETAILS::hour

Hour value of license expiry.

◆ houseSyncIncoming [1/2]

NvU32 _NV_GSYNC_STATUS_PARAMS_V1::houseSyncIncoming

Incoming house sync frequency in Hz.

◆ houseSyncIncoming [2/2]

NvU32 _NV_GSYNC_STATUS_PARAMS_V2::houseSyncIncoming

Incoming house sync frequency in Hz.

◆ hPhysicalGpu [1/9]

NvPhysicalGpuHandle NV_COMPUTE_GPU_TOPOLOGY_V1::hPhysicalGpu

Compute-capable physical GPU handle.

◆ [] [2/9]

NvPhysicalGpuHandle { ... } ::hPhysicalGpu

Compute-capable physical GPU handle.

◆ hPhysicalGpu [3/9]

NvPhysicalGpuHandle _NV_COMPUTE_GPU::hPhysicalGpu

Compute-capable physical GPU handle.

◆ hPhysicalGpu [4/9]

NvPhysicalGpuHandle _NV_GPU_QUERY_ILLUMINATION_SUPPORT_PARM_V1::hPhysicalGpu

The handle of the GPU that you are checking for the specified attribute. note that this is the GPU that is managing the attribute. Only a single GPU can manage an given attribute on a given HW element, regardless of how many are attatched. I.E. only one GPU will be used to control the brightness of the LED on an SLI bridge, regardless of how many are physicaly attached. You enumerate thru the GPUs with this call to determine which GPU is managing the attribute.

◆ hPhysicalGpu [5/9]

NvPhysicalGpuHandle _NV_GPU_GET_ILLUMINATION_PARM_V1::hPhysicalGpu

The handle of the GPU that you are checking for the specified attribute. Note that this is the GPU that is managing the attribute. Only a single GPU can manage an given attribute on a given HW element, regardless of how many are attatched. I.E. only one GPU will be used to control the brightness of the LED on an SLI bridge, regardless of how many are physicaly attached. You enumerate thru the GPUs with this call to determine which GPU is managing the attribute.

◆ hPhysicalGpu [6/9]

NvPhysicalGpuHandle _NV_GPU_SET_ILLUMINATION_PARM_V1::hPhysicalGpu

The handle of the GPU that you are checking for the specified attribute. Note that this is the GPU that is managing the attribute. Only a single GPU can manage an given attribute on a given HW element, regardless of how many are attatched. I.E. only one GPU will be used to control the brightness of the LED on an SLI bridge, regardless of how many are physicaly attached. You enumerate thru the GPUs with this call to determine which GPU is managing the attribute.

◆ [] [1/4]

NvPhysicalGpuHandle { ... } ::hPhysicalGPU

Physical GPU to be used in the topology (0 if GPU missing)

◆ hPhysicalGPU [2/4]

NvPhysicalGpuHandle NV_MOSAIC_TOPO_DETAILS::hPhysicalGPU

Physical GPU to be used in the topology (0 if GPU missing)

◆ [] [3/4]

NvPhysicalGpuHandle { ... } ::hPhysicalGPU

Physical GPU to be used in the topology.

◆ hPhysicalGPU [4/4]

NvPhysicalGpuHandle NV_MOSAIC_TOPOLOGY::hPhysicalGPU

Physical GPU to be used in the topology.

◆ hPhysicalGpu [7/9]

NvPhysicalGpuHandle _NV_GSYNC_GPU::hPhysicalGpu

GPU handle.

◆ hPhysicalGpu [8/9]

NvPhysicalGpuHandle NVVIOTOPOLOGYTARGET::hPhysicalGpu

Handle to Physical GPU (This could be NULL for GVI device if its not binded)

◆ hPhysicalGpu [9/9]

NvPhysicalGpuHandle _NV_PHYSICAL_GPU_HANDLE_DATA::hPhysicalGpu

◆ hProxyPhysicalGpu

NvPhysicalGpuHandle _NV_GSYNC_GPU::hProxyPhysicalGpu

GPU through which hPhysicalGpu is connected to the Sync device (if not directly connected)

this is NULL otherwise

◆ hResource

NVDX_ObjectHandle NV_GET_GPU_VIRTUAL_ADDRESS_V1::hResource

[IN]

◆ hShader

NVDX_ObjectHandle NVAPI_D3D12_CREATE_CUBIN_SHADER_PARAMS::hShader

[out] variable that receives the handle to the created shader.

◆ hSurface

NVDX_ObjectHandle _NV_DX_VIDEO_STEREO_INFO::hSurface

The surface whose stereo format is to be set.

◆ HSyncPol

NvU8 _NV_TIMING::HSyncPol

horizontal sync polarity: 1-negative, 0-positive

◆ HSyncWidth

NvU16 _NV_TIMING::HSyncWidth

horizontal sync width

◆ HTotal

NvU16 _NV_TIMING::HTotal

horizontal total

◆ hVioHandle

NvVioHandle NVVIOTOPOLOGYTARGET::hVioHandle

handle to SDI Input/Output device

◆ HVisible

NvU16 _NV_TIMING::HVisible

horizontal visible

◆ hwModeSetOnly

NvU32 NV_CUSTOM_DISPLAY::hwModeSetOnly

If set, it means a hardware modeset without OS update.

◆ i2cDevAddress [1/3]

NvU8 NV_I2C_INFO_V1::i2cDevAddress

The address of the I2C slave. The address should be shifted left by one. For example, the I2C address 0x50, often used for reading EDIDs, would be stored here as 0xA0. This matches the position within the byte sent by the master, as the last bit is reserved to specify the read or write direction.

◆ i2cDevAddress [2/3]

NvU8 NV_I2C_INFO_V2::i2cDevAddress

The address of the I2C slave. The address should be shifted left by one. For example, the I2C address 0x50, often used for reading EDIDs, would be stored here as 0xA0. This matches the position within the byte sent by the master, as the last bit is reserved to specify the read or write direction.

◆ i2cDevAddress [3/3]

NvU8 NV_I2C_INFO_V3::i2cDevAddress

The address of the I2C slave. The address should be shifted left by one. For example, the I2C address 0x50, often used for reading EDIDs, would be stored here as 0xA0. This matches the position within the byte sent by the master, as the last bit is reserved to specify the read or write direction.

◆ i2cDevIdx

NvU8 _NV_GPU_CLIENT_ILLUM_DEVICE_INFO_DATA_MCUV10::i2cDevIdx

I2C Device Index: Pointing to the illumination device in I2C Devices Table.

◆ i2cSpeed [1/3]

NvU32 NV_I2C_INFO_V1::i2cSpeed

The target speed of the transaction (between 28Kbps to 40Kbps; not guaranteed).

◆ i2cSpeed [2/3]

NvU32 NV_I2C_INFO_V2::i2cSpeed

Deprecated, Must be set to NVAPI_I2C_SPEED_DEPRECATED.

◆ i2cSpeed [3/3]

NvU32 NV_I2C_INFO_V3::i2cSpeed

Deprecated, Must be set to NVAPI_I2C_SPEED_DEPRECATED.

◆ i2cSpeedKhz [1/2]

NV_I2C_SPEED NV_I2C_INFO_V2::i2cSpeedKhz

The target speed of the transaction in (kHz) (Chosen from the enum NV_I2C_SPEED).

◆ i2cSpeedKhz [2/2]

NV_I2C_SPEED NV_I2C_INFO_V3::i2cSpeedKhz

The target speed of the transaction in (kHz) (Chosen from the enum NV_I2C_SPEED).

◆ Id

GUID NVAPI_META_COMMAND_DESC::Id

◆ id

NvU32 _NV_MODIFIED_W_PARAMS::id

◆ illumDeviceIdx

NvU8 _NV_GPU_CLIENT_ILLUM_ZONE_INFO_V1::illumDeviceIdx

Index pointing to an Illumination Device that controls this zone.

◆ immersiveGaming [1/2]

NvU32 _NV_MOSAIC_GRID_TOPO_V1::immersiveGaming

Enable as immersive gaming instead of Mosaic SLI (for Quadro-boards only)

◆ immersiveGaming [2/2]

NvU32 _NV_MOSAIC_GRID_TOPO_V2::immersiveGaming

Enable as immersive gaming instead of Mosaic SLI (for Quadro-boards only)

◆ implementation [1/3]

NvU32 NV_GPU_ARCH_INFO_V1::implementation

◆ implementation [2/3]

NvU32 NV_GPU_ARCH_INFO_V2::implementation

implementation and implementation_id are the same. The former is NvU32 while the latter is an enum made for readability.

◆ [] [3/3]

NvU32 { ... } ::implementation

implementation and implementation_id are the same. The former is NvU32 while the latter is an enum made for readability.

◆ implementation_id [1/2]

NV_GPU_ARCH_IMPLEMENTATION_ID NV_GPU_ARCH_INFO_V2::implementation_id

specifies the implementation of the architecture for the GPU.

◆ [] [2/2]

NV_GPU_ARCH_IMPLEMENTATION_ID { ... } ::implementation_id

specifies the implementation of the architecture for the GPU.

◆ inConfig [1/6]

NVVIOINPUTCONFIG _NVVIOCONFIG_V1::inConfig

Input device configuration.

◆ [] [2/6]

NVVIOINPUTCONFIG { ... } ::inConfig

Input device configuration.

◆ inConfig [3/6]

NVVIOINPUTCONFIG _NVVIOCONFIG_V2::inConfig

Input device configuration.

◆ [] [4/6]

NVVIOINPUTCONFIG { ... } ::inConfig

Input device configuration.

◆ inConfig [5/6]

NVVIOINPUTCONFIG _NVVIOCONFIG_V3::inConfig

Input device configuration.

◆ [] [6/6]

NVVIOINPUTCONFIG { ... } ::inConfig

Input device configuration.

◆ independentViewportMaskEnable

NvU8 _NV_MULTIVIEW_PARAMS_V1::independentViewportMaskEnable

◆ [union]

union { ... } NV_INFOFRAME_DATA::infoframe

◆ infoType [1/3]

NvU32 _NV_MONITOR_CAPABILITIES_V1::infoType

◆ infoType [2/3]

NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_ARRAY_POSTBUILD_INFO_TYPE _NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_ARRAY_POSTBUILD_INFO_DESC::infoType

Type of postbuild information to retrieve.

◆ infoType [3/3]

NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_POSTBUILD_INFO_TYPE _NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_POSTBUILD_INFO_DESC::infoType

Type of postbuild information to retrieve.

◆ InitializationDirtyState

NV_D3D_GRAPHICS_STATES NVAPI_META_COMMAND_DESC::InitializationDirtyState

◆ InnerMostRegionShadingRate

NV_PIXEL_SHADING_RATE _NV_FOVEATED_RENDERING_CUSTOM_SHADING_RATE_PRESET_DESC_V1::InnerMostRegionShadingRate

(IN) Shading Rate for the inner-most region of the foveated rendering pattern

◆ inputBuffer [1/2]

D3D12_GPU_VIRTUAL_ADDRESS _NVAPI_D3D12_BUILD_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_INPUTS::inputBuffer

Address for raw DMM input data; it must be 256-byte aligned (NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_BYTE_ALIGNMENT) It is recommended to try to organize DMMs together in memory that are expected to be used close together spatially.

◆ inputBuffer [2/2]

D3D12_GPU_VIRTUAL_ADDRESS _NVAPI_D3D12_BUILD_RAYTRACING_OPACITY_MICROMAP_ARRAY_INPUTS::inputBuffer

Address for raw OMM input data; it must be 256-byte aligned. It is recommended to try to organize OMMs together in memory that are expected to be used close together spatially.

◆ InputResource [1/2]

NV_D3D11_META_COMMAND_RESOURCE NV_D3D11_META_COMMAND_EXECUTE_CONVOLUTION_EX_DESC::InputResource

◆ InputResource [2/2]

D3D12_GPU_VIRTUAL_ADDRESS NV_D3D12_META_COMMAND_EXECUTE_CONVOLUTION_EX_DESC::InputResource

◆ inputs [1/3]

NVAPI_D3D12_BUILD_RAYTRACING_OPACITY_MICROMAP_ARRAY_INPUTS _NVAPI_D3D12_BUILD_RAYTRACING_OPACITY_MICROMAP_ARRAY_DESC::inputs

Description of the input data for the OMM Array build.

◆ inputs [2/3]

NVAPI_D3D12_BUILD_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_INPUTS _NVAPI_D3D12_BUILD_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_DESC::inputs

Description of the input data for the DMM Array build.

◆ inputs [3/3]

NVAPI_D3D12_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_INPUTS_EX _NVAPI_D3D12_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_DESC_EX::inputs

The inputs to the build process.

◆ inputSampleTime

NvU64 _NV_LATENCY_RESULT_PARAMS::FrameReport::inputSampleTime

◆ instanceDescs [1/2]

D3D12_GPU_VIRTUAL_ADDRESS _NVAPI_D3D12_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_INPUTS_EX::instanceDescs

If type is D3D12_RAYTRACING_ACCELERATION_STRUCTURE_TOP_LEVEL, the referenced instance structures can used the extended set of flags NVAPI_D3D12_RAYTRACING_INSTANCE_FLAGS_EX in place of the D3D12_RAYTRACING_INSTANCE_FLAGS mentioned in D3D12_RAYTRACING_INSTANCE_DESC. Otherwise, this parameter is unused (space repurposed in a union).

◆ [] [2/2]

D3D12_GPU_VIRTUAL_ADDRESS { ... } ::instanceDescs

If type is D3D12_RAYTRACING_ACCELERATION_STRUCTURE_TOP_LEVEL, the referenced instance structures can used the extended set of flags NVAPI_D3D12_RAYTRACING_INSTANCE_FLAGS_EX in place of the D3D12_RAYTRACING_INSTANCE_FLAGS mentioned in D3D12_RAYTRACING_INSTANCE_DESC. Otherwise, this parameter is unused (space repurposed in a union).

◆ inStatus [1/2]

NVVIOINPUTSTATUS _NVVIOSTATUS::inStatus

Input device status.

◆ [] [2/2]

NVVIOINPUTSTATUS { ... } ::inStatus

Input device status.

◆ [] [1/4]

NvU32 { ... } ::interface_supported_by_sink

Indicates the interface (standard or low latency) supported by the sink.

◆ interface_supported_by_sink [2/4]

NvU32 _NV_HDR_CAPABILITIES_V2::interface_supported_by_sink

Indicates the interface (standard or low latency) supported by the sink.

◆ interface_supported_by_sink [3/4]

NvU32 _NV_HDR_CAPABILITIES_V3::interface_supported_by_sink

Indicates the interface (standard or low latency) supported by the sink.

◆ [] [4/4]

NvU32 { ... } ::interface_supported_by_sink

Indicates the interface (standard or low latency) supported by the sink.

◆ interlaced [1/3]

NvU16 _NV_TIMING::interlaced

1-interlaced, 0-progressive

◆ interlaced [2/3]

NvU32 NV_DISPLAY_PATH::interlaced

(IN) Interlaced mode flag

◆ interlaced [3/3]

NvU32 _NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_V1::interlaced

(IN) Interlaced mode flag, ignored if refreshRate == 0

◆ interlacedAudioLatency

NvU8 _NV_MONITOR_CAPS_VSDB::interlacedAudioLatency

Byte 9.

◆ interlacedVideoLatency

NvU8 _NV_MONITOR_CAPS_VSDB::interlacedVideoLatency

Byte 8.

◆ interlaceMode [1/3]

NvU32 _NV_GSYNC_CONTROL_PARAMS_V1::interlaceMode

interlace mode for a Sync device

◆ interlaceMode [2/3]

NvU32 _NV_GSYNC_CONTROL_PARAMS_V2::interlaceMode

interlace mode for a Sync device

◆ interlaceMode [3/3]

NVVIOINTERLACEMODE _NVVIOVIDEOMODE::interlaceMode

Interlace mode.

◆ InterleavedSampling

BOOL _NV_D3D11_FEATURE_DATA_RASTERIZER_SUPPORT::InterleavedSampling

◆ InterleavedSamplingEnable [1/2]

bool NvAPI_D3D11_RASTERIZER_DESC_EX::InterleavedSamplingEnable

◆ InterleavedSamplingEnable [2/2]

bool NVAPI_D3D12_PSO_RASTERIZER_STATE_DESC_V1::InterleavedSamplingEnable

◆ interval [1/2]

NvU32 _NV_GSYNC_CONTROL_PARAMS_V1::interval

Number of pulses to wait between framelock signal generation.

◆ interval [2/2]

NvU32 _NV_GSYNC_CONTROL_PARAMS_V2::interval

Number of pulses to wait between framelock signal generation.

◆ is10BPCSupported

NvU32 _NV_DISPLAY_PORT_INFO_V1::is10BPCSupported

If 10 bpc is supported.

◆ is10BPCSupportedOnCurrentMode

NvU32 _NV_DISPLAY_PORT_INFO_V1::is10BPCSupportedOnCurrentMode

◆ is12BPCSupported

NvU32 _NV_DISPLAY_PORT_INFO_V1::is12BPCSupported

If 12 bpc is supported.

◆ is12BPCSupportedOnCurrentMode

NvU32 _NV_DISPLAY_PORT_INFO_V1::is12BPCSupportedOnCurrentMode

◆ is16BPCSupported

NvU32 _NV_DISPLAY_PORT_INFO_V1::is16BPCSupported

If 16 bpc is supported.

◆ is16BPCSupportedOnCurrentMode

NvU32 _NV_DISPLAY_PORT_INFO_V1::is16BPCSupportedOnCurrentMode

◆ is6BPCSupported

NvU32 _NV_DISPLAY_PORT_INFO_V1::is6BPCSupported

If 6 bpc is supported.

◆ is6BPCSupportedOnCurrentMode

NvU32 _NV_DISPLAY_PORT_INFO_V1::is6BPCSupportedOnCurrentMode

◆ is8BPCSupported

NvU32 _NV_DISPLAY_PORT_INFO_V1::is8BPCSupported

If 8 bpc is supported.

◆ is8BPCSupportedOnCurrentMode

NvU32 _NV_DISPLAY_PORT_INFO_V1::is8BPCSupportedOnCurrentMode

◆ isAcquired

NvU32 _NV_MANAGED_DEDICATED_DISPLAY_INFO::isAcquired

[out] If bit is set, this display has been acquired by another process through NvAPI_DISP_AcquireDedicatedDisplay().

◆ isActive

NvU32 _NV_GPU_DISPLAYIDS::isActive

if bit is set then this display is being actively driven

◆ isChromaLpfOff

NvU32 NV_DISPLAY_PORT_CONFIG::isChromaLpfOff

Force the chroma low_pass_filter to be off.

◆ isCluster

NvU32 _NV_GPU_DISPLAYIDS::isCluster

if bit is set then this display is the representative display

◆ isColorCtrlSupported

NvU32 _NV_DISPLAY_PORT_INFO_V1::isColorCtrlSupported

If the color format change is supported.

◆ isCommandLine [1/2]

NvU32 _NVDRS_APPLICATION_V3::isCommandLine

Command line parsing for the application name.

◆ isCommandLine [2/2]

NvU32 _NVDRS_APPLICATION_V4::isCommandLine

Command line parsing for the application name.

◆ isConnected

NvU32 _NV_GPU_DISPLAYIDS::isConnected

if bit is set, then this display is connected

◆ isCurrentPredefined

NvU32 _NVDRS_SETTING_V1::isCurrentPredefined

It is different than 0 if the currentValue is a predefined Value, 0 if the currentValue is a user value.

◆ isDitherOff

NvU32 NV_DISPLAY_PORT_CONFIG::isDitherOff

Force to turn off dither.

◆ isDolbyVisionSupported [1/2]

NvU32 _NV_HDR_CAPABILITIES_V2::isDolbyVisionSupported

Dolby Vision Support. Boolean: 0 = not supported, 1 = supported;.

◆ isDolbyVisionSupported [2/2]

NvU32 _NV_HDR_CAPABILITIES_V3::isDolbyVisionSupported

Dolby Vision Support. Boolean: 0 = not supported, 1 = supported;.

◆ isDp

NvU32 _NV_DISPLAY_PORT_INFO_V1::isDp

If the monitor is driven by a DisplayPort.

◆ isDynamic

NvU32 _NV_GPU_DISPLAYIDS::isDynamic

if bit is set then this display is part of MST topology and it's a dynamic

◆ isEdrSupported [1/3]

NvU32 _NV_HDR_CAPABILITIES_V1::isEdrSupported

Extended Dynamic Range on SDR displays. Boolean: 0 = not supported, 1 = supported;.

◆ isEdrSupported [2/3]

NvU32 _NV_HDR_CAPABILITIES_V2::isEdrSupported

Extended Dynamic Range on SDR displays. Boolean: 0 = not supported, 1 = supported;.

◆ isEdrSupported [3/3]

NvU32 _NV_HDR_CAPABILITIES_V3::isEdrSupported

Extended Dynamic Range on SDR displays. Boolean: 0 = not supported, 1 = supported;.

◆ isEnabled [1/6]

NvU32 NV_GPU_ECC_STATUS_INFO::isEnabled

Active ECC memory setting.

◆ isEnabled [2/6]

NvU32 NV_GPU_ECC_CONFIGURATION_INFO::isEnabled

Structure version.

◆ isEnabled [3/6]

NvU32 _NV_LICENSE_FEATURE_DETAILS_V1::isEnabled

The current state of the licensed feature, true=enabled, false=disabled.

◆ isEnabled [4/6]

NvU32 _NV_LICENSE_FEATURE_DETAILS_V2::isEnabled

The current state of the licensed feature, true=enabled, false=disabled.

◆ isEnabled [5/6]

NvU32 _NV_LICENSE_FEATURE_DETAILS_V3::isEnabled

The current state of license, true=licensed, false=unlicensed.

◆ isEnabled [6/6]

NvU32 _NV_LICENSE_FEATURE_DETAILS_V4::isEnabled

The current state of license, true=licensed, false=unlicensed.

◆ isEnabledByDefault

NvU32 NV_GPU_ECC_CONFIGURATION_INFO::isEnabledByDefault

Current ECC configuration stored in non-volatile memory.

◆ isFeatureEnabled [1/2]

NvU32 _NV_LICENSE_FEATURE_DETAILS_V3::isFeatureEnabled

The current state of feature, true=enabled, false=disabled.

◆ isFeatureEnabled [2/2]

NvU32 _NV_LICENSE_FEATURE_DETAILS_V4::isFeatureEnabled

The current state of feature, true=enabled, false=disabled.

◆ isGpuHDMICapable [1/2]

NvU32 _NV_HDMI_SUPPORT_INFO_V1::isGpuHDMICapable

If the GPU can handle HDMI.

◆ isGpuHDMICapable [2/2]

NvU32 _NV_HDMI_SUPPORT_INFO_V2::isGpuHDMICapable

If the GPU can handle HDMI.

◆ isHdr10PlusGamingSupported

NvU32 _NV_HDR_CAPABILITIES_V3::isHdr10PlusGamingSupported

HDR10+ Gaming, a.k.a HDR10+ Source Side Tonemapping (SSTM), is supported.

◆ isHdr10PlusSupported

NvU32 _NV_HDR_CAPABILITIES_V3::isHdr10PlusSupported

HDR10+ (Sink Side Tonemapping) is supported.

◆ isHPD

NvU32 NV_DISPLAY_PORT_CONFIG::isHPD

If the control panel is making this call due to HPD.

◆ isInterlaced

NvU32 NV_TIMING_FLAG::isInterlaced

To retrieve interlaced/progressive timing.

◆ isInternalDp

NvU32 _NV_DISPLAY_PORT_INFO_V1::isInternalDp

If the monitor is driven by an NV Dp transmitter.

◆ isLicenseSupported [1/4]

NvU32 _NV_LICENSABLE_FEATURES_V1::isLicenseSupported

True if Software Licensing is supported.

◆ isLicenseSupported [2/4]

NvU32 _NV_LICENSABLE_FEATURES_V2::isLicenseSupported

True if Software Licensing is supported.

◆ isLicenseSupported [3/4]

NvU32 _NV_LICENSABLE_FEATURES_V3::isLicenseSupported

True if Software Licensing is supported.

◆ isLicenseSupported [4/4]

NvU32 _NV_LICENSABLE_FEATURES_V4::isLicenseSupported

True if Software Licensing is supported.

◆ isMasterable

NvU32 _NV_GSYNC_DISPLAY::isMasterable

Can this display be the master? (Read only)

◆ isMetro [1/2]

NvU32 _NVDRS_APPLICATION_V3::isMetro

Windows 8 style app.

◆ isMetro [2/2]

NvU32 _NVDRS_APPLICATION_V4::isMetro

Windows 8 style app.

◆ isMonAdobeRGBCapable [1/2]

NvU32 _NV_DISPLAY_PORT_INFO_V1::isMonAdobeRGBCapable

◆ isMonAdobeRGBCapable [2/2]

NvU32 _NV_HDMI_SUPPORT_INFO_V2::isMonAdobeRGBCapable

if AdobeRGB extended colorimetry is supported

◆ isMonAdobeYCC601Capable [1/2]

NvU32 _NV_DISPLAY_PORT_INFO_V1::isMonAdobeYCC601Capable

◆ isMonAdobeYCC601Capable [2/2]

NvU32 _NV_HDMI_SUPPORT_INFO_V2::isMonAdobeYCC601Capable

if AdobeYCC601 extended colorimetry is supported

◆ isMonBasicAudioCapable [1/2]

NvU32 _NV_HDMI_SUPPORT_INFO_V1::isMonBasicAudioCapable

If the monitor supports basic audio.

◆ isMonBasicAudioCapable [2/2]

NvU32 _NV_HDMI_SUPPORT_INFO_V2::isMonBasicAudioCapable

If the monitor supports basic audio.

◆ isMonBT2020cYCCCapable

NvU32 _NV_DISPLAY_PORT_INFO_V1::isMonBT2020cYCCCapable

◆ isMonBT2020RGBCapable

NvU32 _NV_DISPLAY_PORT_INFO_V1::isMonBT2020RGBCapable

◆ isMonBT2020YCCCapable

NvU32 _NV_DISPLAY_PORT_INFO_V1::isMonBT2020YCCCapable

◆ isMonHDMI [1/2]

NvU32 _NV_HDMI_SUPPORT_INFO_V1::isMonHDMI

If the monitor is HDMI (with IEEE's HDMI registry ID)

◆ isMonHDMI [2/2]

NvU32 _NV_HDMI_SUPPORT_INFO_V2::isMonHDMI

If the monitor is HDMI (with IEEE's HDMI registry ID)

◆ isMonsYCC601Capable [1/2]

NvU32 _NV_DISPLAY_PORT_INFO_V1::isMonsYCC601Capable

◆ isMonsYCC601Capable [2/2]

NvU32 _NV_HDMI_SUPPORT_INFO_V2::isMonsYCC601Capable

if sYCC601 extended colorimetry is supported

◆ isMonUnderscanCapable [1/2]

NvU32 _NV_HDMI_SUPPORT_INFO_V1::isMonUnderscanCapable

If the monitor supports underscan.

◆ isMonUnderscanCapable [2/2]

NvU32 _NV_HDMI_SUPPORT_INFO_V2::isMonUnderscanCapable

If the monitor supports underscan.

◆ isMonxvYCC601Capable [1/3]

NvU32 _NV_DISPLAY_PORT_INFO_V1::isMonxvYCC601Capable

◆ isMonxvYCC601Capable [2/3]

NvU32 _NV_HDMI_SUPPORT_INFO_V1::isMonxvYCC601Capable

If xvYCC 601 is supported.

◆ isMonxvYCC601Capable [3/3]

NvU32 _NV_HDMI_SUPPORT_INFO_V2::isMonxvYCC601Capable

If xvYCC extended colorimetry 601 is supported.

◆ isMonxvYCC709Capable [1/3]

NvU32 _NV_DISPLAY_PORT_INFO_V1::isMonxvYCC709Capable

◆ isMonxvYCC709Capable [2/3]

NvU32 _NV_HDMI_SUPPORT_INFO_V1::isMonxvYCC709Capable

If xvYCC 709 is supported.

◆ isMonxvYCC709Capable [3/3]

NvU32 _NV_HDMI_SUPPORT_INFO_V2::isMonxvYCC709Capable

If xvYCC extended colorimetry 709 is supported.

◆ isMonYCbCr422Capable [1/2]

NvU32 _NV_HDMI_SUPPORT_INFO_V1::isMonYCbCr422Capable

If YCbCr 4:2:2 is supported.

◆ isMonYCbCr422Capable [2/2]

NvU32 _NV_HDMI_SUPPORT_INFO_V2::isMonYCbCr422Capable

If YCbCr 4:2:2 is supported.

◆ isMonYCbCr444Capable [1/2]

NvU32 _NV_HDMI_SUPPORT_INFO_V1::isMonYCbCr444Capable

If YCbCr 4:4:4 is supported.

◆ isMonYCbCr444Capable [2/2]

NvU32 _NV_HDMI_SUPPORT_INFO_V2::isMonYCbCr444Capable

If YCbCr 4:4:4 is supported.

◆ isMosaic

NvU32 _NV_MANAGED_DEDICATED_DISPLAY_INFO::isMosaic

[out] If bit is set, this display represents a Mosaic grid.

◆ isMultiStreamRootNode

NvU32 _NV_GPU_DISPLAYIDS::isMultiStreamRootNode

if bit is set then this displayID belongs to a multi stream enabled connector(root node). Note that when multi stream is enabled and a single multi stream capable monitor is connected to it, the monitor will share the display id with the RootNode. When there is more than one monitor connected in a multi stream topology, then the root node will have a separate displayId.

◆ IsNonNVIDIAAdapter

NvU32 _NV_DISPLAYCONFIG_PATH_INFO_V2::IsNonNVIDIAAdapter

True for non-NVIDIA adapter.

◆ IsNull [1/2]

NV_META_COMMAND_BOOL NV_META_COMMAND_OPTIONAL_TENSOR_DESC::IsNull

◆ IsNull [2/2]

NV_META_COMMAND_BOOL NV_META_COMMAND_OPTIONAL_ACTIVATION_DESC::IsNull

◆ isOSVisible

NvU32 _NV_GPU_DISPLAYIDS::isOSVisible

if bit is set, then this display is reported to the OS

◆ isPhysicallyConnected

NvU32 _NV_GPU_DISPLAYIDS::isPhysicallyConnected

if bit is set, then this display is a phycially connected display; Valid only when isConnected bit is set

◆ isPossible

NvU32 NV_MOSAIC_TOPO_BRIEF::isPossible

1 if topo can be enabled, else 0

◆ isPredefined [1/5]

NvU32 _NVDRS_APPLICATION_V1::isPredefined

Is the application userdefined/predefined.

◆ isPredefined [2/5]

NvU32 _NVDRS_APPLICATION_V2::isPredefined

Is the application userdefined/predefined.

◆ isPredefined [3/5]

NvU32 _NVDRS_APPLICATION_V3::isPredefined

Is the application userdefined/predefined.

◆ isPredefined [4/5]

NvU32 _NVDRS_APPLICATION_V4::isPredefined

Is the application userdefined/predefined.

◆ isPredefined [5/5]

NvU32 _NVDRS_PROFILE_V1::isPredefined

Is the Profile user-defined, or predefined.

◆ isPredefinedValid

NvU32 _NVDRS_SETTING_V1::isPredefinedValid

It is different than 0 if the PredefinedValue union contains a valid value.

◆ isPreferredUnscaledTarget

NvU32 _NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_V1::isPreferredUnscaledTarget

◆ isRgb444SupportedOnCurrentMode

NvU32 _NV_DISPLAY_PORT_INFO_V1::isRgb444SupportedOnCurrentMode

If Rgb444 is supported on the current mode.

◆ isRLACapable

NvU8 _NV_MONITOR_CAPS_GENERIC::isRLACapable

whether monitor supports RLA

◆ isSetDeferred

NvU32 NV_DISPLAY_PORT_CONFIG::isSetDeferred

Requires an OS modeset to finalize the setup if set.

◆ isST2084EotfSupported [1/3]

NvU32 _NV_HDR_CAPABILITIES_V1::isST2084EotfSupported

HDMI2.0a UHDA HDR with ST2084 EOTF (CEA861.3). Boolean: 0 = not supported, 1 = supported;.

◆ isST2084EotfSupported [2/3]

NvU32 _NV_HDR_CAPABILITIES_V2::isST2084EotfSupported

HDMI2.0a UHDA HDR with ST2084 EOTF (CEA861.3). Boolean: 0 = not supported, 1 = supported;.

◆ isST2084EotfSupported [3/3]

NvU32 _NV_HDR_CAPABILITIES_V3::isST2084EotfSupported

HDMI2.0a UHDA HDR with ST2084 EOTF (CEA861.3). Boolean: 0 = not supported, 1 = supported;.

◆ isSupported

NvU32 NV_GPU_ECC_STATUS_INFO::isSupported

ECC memory feature support.

◆ isSynced

NvU32 _NV_GSYNC_GPU::isSynced

Whether this GPU is sync'd or not.

◆ isTraditionalHdrGammaSupported [1/3]

NvU32 _NV_HDR_CAPABILITIES_V1::isTraditionalHdrGammaSupported

HDMI2.0a traditional HDR gamma (CEA861.3). Boolean: 0 = not supported, 1 = supported;.

◆ isTraditionalHdrGammaSupported [2/3]

NvU32 _NV_HDR_CAPABILITIES_V2::isTraditionalHdrGammaSupported

HDMI2.0a traditional HDR gamma (CEA861.3). Boolean: 0 = not supported, 1 = supported;.

◆ isTraditionalHdrGammaSupported [3/3]

NvU32 _NV_HDR_CAPABILITIES_V3::isTraditionalHdrGammaSupported

HDMI2.0a traditional HDR gamma (CEA861.3). Boolean: 0 = not supported, 1 = supported;.

◆ isTraditionalSdrGammaSupported [1/3]

NvU32 _NV_HDR_CAPABILITIES_V1::isTraditionalSdrGammaSupported

HDMI2.0a traditional SDR gamma (CEA861.3). Boolean: 0 = not supported, 1 = supported;.

◆ isTraditionalSdrGammaSupported [2/3]

NvU32 _NV_HDR_CAPABILITIES_V2::isTraditionalSdrGammaSupported

HDMI2.0a traditional SDR gamma (CEA861.3). Boolean: 0 = not supported, 1 = supported;.

◆ isTraditionalSdrGammaSupported [3/3]

NvU32 _NV_HDR_CAPABILITIES_V3::isTraditionalSdrGammaSupported

HDMI2.0a traditional SDR gamma (CEA861.3). Boolean: 0 = not supported, 1 = supported;.

◆ isTrueGsync

NvU8 _NV_MONITOR_CAPS_GENERIC::isTrueGsync

whether the monitor is actually GSYNC or adaptive sync monitor : 0 for adaptive sync.

◆ isVRReady

NvU32 _NV_GPU_VR_READY_V1::isVRReady

Is the requested GPU VR ready.

◆ isWFD

NvU32 _NV_GPU_DISPLAYIDS::isWFD

Deprecated. Will always return 0.

◆ isYCbCr420SupportedOnCurrentMode

NvU32 _NV_DISPLAY_PORT_INFO_V1::isYCbCr420SupportedOnCurrentMode

If YCbCr420 is supported on the current mode.

◆ isYCbCr422SupportedOnCurrentMode

NvU32 _NV_DISPLAY_PORT_INFO_V1::isYCbCr422SupportedOnCurrentMode

If YCbCr422 is supported on the current mode.

◆ isYCbCr444SupportedOnCurrentMode

NvU32 _NV_DISPLAY_PORT_INFO_V1::isYCbCr444SupportedOnCurrentMode

If YCbCr444 is supported on the current mode.

◆ isYCrCb420Supported

NvU32 _NV_DISPLAY_PORT_INFO_V1::isYCrCb420Supported

If YCrCb420 is supported.

◆ isYCrCb422Supported

NvU32 _NV_DISPLAY_PORT_INFO_V1::isYCrCb422Supported

If YCrCb422 is supported.

◆ isYCrCb444Supported

NvU32 _NV_DISPLAY_PORT_INFO_V1::isYCrCb444Supported

If YCrCb444 is supported.

◆ itContent

NvU32 NV_INFOFRAME_VIDEO::itContent

◆ jack [1/2]

NvU32 _NVVIOSTREAM::jack

This stream's link[i] will use the specified (0-based) channel within the.

◆ [] [2/2]

NvU32 { ... } ::jack

This stream's link[i] will use the specified (0-based) channel within the.

◆ kernelParams

void** _NVAPI_CU_KERNEL_LAUNCH_PARAMS_EX::kernelParams

◆ keyEnable

UINT NVAPI_ANSEL_CONFIGURATION_STRUCT_V1::keyEnable

VKEY to enable/disable Ansel.

◆ laneCount

NV_DP_LANE_COUNT NV_DISPLAY_PORT_CONFIG::laneCount

Lane count.

◆ lastFlipRefreshCount

NvU32 _NV_GET_ADAPTIVE_SYNC_DATA_V1::lastFlipRefreshCount

[out] Number of times the last flip was shown on the screen

◆ lastFlipTimeStamp

NvU64 _NV_GET_ADAPTIVE_SYNC_DATA_V1::lastFlipTimeStamp

[out] Timestamp for the lastest flip on the screen

◆ launcher [1/4]

NvAPI_UnicodeString _NVDRS_APPLICATION_V1::launcher

Indicates the name (if any) of the launcher that starts the application

◆ launcher [2/4]

NvAPI_UnicodeString _NVDRS_APPLICATION_V2::launcher

Indicates the name (if any) of the launcher that starts the Application.

◆ launcher [3/4]

NvAPI_UnicodeString _NVDRS_APPLICATION_V3::launcher

Indicates the name (if any) of the launcher that starts the Application.

◆ launcher [4/4]

NvAPI_UnicodeString _NVDRS_APPLICATION_V4::launcher

Indicates the name (if any) of the launcher that starts the Application.

◆ Layout

NvU64 NV_META_COMMAND_TENSOR_DESC::Layout

◆ left_bar

NvU32 NV_INFOFRAME_VIDEO::left_bar

◆ leftCoeffs

float _NV_SMP_ASSIST_UPDATE_INSTANCEDSTEREO_DATA_PARAMS_V1::leftCoeffs[4]

◆ leftConst

float _NV_SMP_ASSIST_UPDATE_INSTANCEDSTEREO_DATA_PARAMS_V1::leftConst

◆ length

NvU32 NV_INFOFRAME_PROPERTY::length

◆ levelShift

NvU32 NV_INFOFRAME_AUDIO::levelShift

◆ lfePlaybackLevel

NvU32 NV_INFOFRAME_AUDIO::lfePlaybackLevel

◆ licensableFeatureCount [1/4]

NvU32 _NV_LICENSABLE_FEATURES_V1::licensableFeatureCount

The number of licensable features.

◆ licensableFeatureCount [2/4]

NvU32 _NV_LICENSABLE_FEATURES_V2::licensableFeatureCount

The number of licensable features.

◆ licensableFeatureCount [3/4]

NvU32 _NV_LICENSABLE_FEATURES_V3::licensableFeatureCount

The number of licensable features.

◆ licensableFeatureCount [4/4]

NvU32 _NV_LICENSABLE_FEATURES_V4::licensableFeatureCount

The number of licensable features.

◆ licenseDetails [1/4]

NV_LICENSE_FEATURE_DETAILS_V1 _NV_LICENSABLE_FEATURES_V1::licenseDetails[NV_LICENSE_MAX_COUNT]

Array of licensable features.

◆ licenseDetails [2/4]

NV_LICENSE_FEATURE_DETAILS_V2 _NV_LICENSABLE_FEATURES_V2::licenseDetails[NV_LICENSE_MAX_COUNT]

Array of licensable features.

◆ licenseDetails [3/4]

NV_LICENSE_FEATURE_DETAILS_V3 _NV_LICENSABLE_FEATURES_V3::licenseDetails[NV_LICENSE_MAX_COUNT]

Array of licensable features.

◆ licenseDetails [4/4]

NV_LICENSE_FEATURE_DETAILS_V4 _NV_LICENSABLE_FEATURES_V4::licenseDetails[NV_LICENSE_MAX_COUNT]

Array of licensable features.

◆ licenseExpiry

NV_LICENSE_EXPIRY_DETAILS _NV_LICENSE_FEATURE_DETAILS_V4::licenseExpiry

License expiry information.

◆ licenseInfo [1/4]

NvAPI_LicenseString _NV_LICENSE_FEATURE_DETAILS_V1::licenseInfo

Deprecated.

◆ licenseInfo [2/4]

NvAPI_LicenseString _NV_LICENSE_FEATURE_DETAILS_V2::licenseInfo

Deprecated.

◆ licenseInfo [3/4]

NvAPI_LicenseString _NV_LICENSE_FEATURE_DETAILS_V3::licenseInfo

Deprecated.

◆ licenseInfo [4/4]

NvAPI_LicenseString _NV_LICENSE_FEATURE_DETAILS_V4::licenseInfo

Deprecated.

◆ linkID

NVVIOLINKID _NVVIOCHANNELSTATUS::linkID

Link ID.

◆ linkInfo [1/2]

NVLINK_LINK_STATUS_INFO_V1 NVLINK_GET_STATUS_V1::linkInfo[NVAPI_NVLINK_MAX_LINKS]

This structure stores the per-link status of different NVLink parameters. The link is identified by the index.

◆ linkInfo [2/2]

NVLINK_LINK_STATUS_INFO_V2 NVLINK_GET_STATUS_V2::linkInfo[NVAPI_NVLINK_MAX_LINKS]

This structure stores the per-link status of different NVLink parameters. The link is identified by the index.

◆ linkMask [1/3]

NvU32 NVLINK_GET_CAPS_V1::linkMask

This field provides a bitfield mask of NVLink links enabled on this GPU.

◆ linkMask [2/3]

NvU32 NVLINK_GET_STATUS_V1::linkMask

This parameter specifies for which links we want the status.

◆ linkMask [3/3]

NvU32 NVLINK_GET_STATUS_V2::linkMask

This parameter specifies for which links we want the status.

◆ linkRate

NV_DP_LINK_RATE NV_DISPLAY_PORT_CONFIG::linkRate

Link rate.

◆ [struct]

struct { ... } _NVVIOSTREAM::links[NVAPI_MAX_VIO_LINKS_PER_STREAM]

◆ linkState [1/2]

NvU32 NVLINK_LINK_STATUS_INFO_V1::linkState

This field specifies the current state of the link.See NVAPI_NVLINK_GET_NVLINK_STATUS_LINK_STATE_* for possible values.

◆ linkState [2/2]

NvU32 NVLINK_LINK_STATUS_INFO_V2::linkState

This field specifies the current state of the link.See NVAPI_NVLINK_GET_NVLINK_STATUS_LINK_STATE_* for possible values.

◆ localDeviceInfo

NVLINK_DEVICE_INFO_V1 NVLINK_LINK_STATUS_INFO_V2::localDeviceInfo

This field stores the device information for the local end of the link.

◆ localDeviceLinkNumber

NvU8 NVLINK_LINK_STATUS_INFO_V2::localDeviceLinkNumber

This field specifies the link number on the local end of the link.

◆ loopProperty [1/2]

NvU8 NVLINK_LINK_STATUS_INFO_V1::loopProperty

This field specifies if the link is a loopback/loopout link. See NVAPI_NVLINK_STATUS_LOOP_PROPERTY_* for possible values.

◆ loopProperty [2/2]

NvU8 NVLINK_LINK_STATUS_INFO_V2::loopProperty

This field specifies if the link is a loopback/loopout link. See NVAPI_NVLINK_STATUS_LOOP_PROPERTY_* for possible values.

◆ lowestNciVersion

NvU8 NVLINK_GET_CAPS_V1::lowestNciVersion

This field specifies the lowest supported NCI version for this GPU.

◆ lowestNvlinkVersion

NvU8 NVLINK_GET_CAPS_V1::lowestNvlinkVersion

This field specifies the lowest supported NVLink version for this GPU.

◆ majorSMVersion [1/2]

NvU16 _NV_D3D1x_GRAPHICS_CAPS_V2::majorSMVersion

(OUT) Major SM version of the device

◆ majorSMVersion [2/2]

NvU16 _NV_D3D12_GRAPHICS_CAPS_V1::majorSMVersion

(OUT) Major SM version of the device

◆ [] [1/3]

NvU32 { ... } ::majorVersion

Major version. For GVI, majorVersion contains MajorVersion(HIWORD) And MinorVersion(LOWORD)

◆ majorVersion [2/3]

NvU32 _NVVIOCAPS::majorVersion

Major version. For GVI, majorVersion contains MajorVersion(HIWORD) And MinorVersion(LOWORD)

Major version. In version 2, for both GVI and GVO, majorVersion contains MajorVersion(HIWORD) And MinorVersion(LOWORD)

◆ [] [3/3]

NvU32 { ... } ::majorVersion

Major version. In version 2, for both GVI and GVO, majorVersion contains MajorVersion(HIWORD) And MinorVersion(LOWORD)

◆ manualColorFixed [1/2]

NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_COLOR_FIXED _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_COLOR_FIXED::manualColorFixed

◆ [] [2/2]

NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_COLOR_FIXED { ... } ::manualColorFixed

◆ manualRGB [1/2]

NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_RGB _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_RGB::manualRGB

◆ [] [2/2]

NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_RGB { ... } ::manualRGB

◆ manualRGBW [1/2]

NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_RGBW _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_RGBW::manualRGBW

◆ [] [2/2]

NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_RGBW { ... } ::manualRGBW

◆ [] [1/2]

NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_SINGLE_COLOR { ... } ::manualSingleColor

◆ manualSingleColor [2/2]

NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_SINGLE_COLOR _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_SINGLE_COLOR::manualSingleColor

◆ markerType [1/2]

NV_LATENCY_MARKER_TYPE _NV_LATENCY_MARKER_PARAMS::markerType

◆ markerType [2/2]

NV_LATENCY_MARKER_TYPE _NV_ASYNC_FRAME_MARKER_PARAMS_V1::markerType

◆ [struct] [1/2]

struct { ... } _NV_HDR_COLOR_DATA_V1::mastering_display_data

◆ [struct] [2/2]

struct { ... } _NV_HDR_COLOR_DATA_V2::mastering_display_data

◆ max [1/2]

NvS32 NV_GPU_PERF_PSTATES20_PARAM_DELTA::max

Max value allowed for parameter delta (in respective units [kHz, uV])

◆ [] [2/2]

NvS32 { ... } ::max

Max value allowed for parameter delta (in respective units [kHz, uV])

◆ max_content_light_level [1/5]

NvU16 _NV_HDR_COLOR_DATA_V1::max_content_light_level

Maximum Content Light level (MaxCLL) ([0x0001-0xFFFF] = [1.0 - 65535.0] cd/m^2)

◆ [] [2/5]

NvU16 { ... } ::max_content_light_level

Maximum Content Light level (MaxCLL) ([0x0001-0xFFFF] = [1.0 - 65535.0] cd/m^2)

◆ max_content_light_level [3/5]

NvU16 _NV_HDR_COLOR_DATA_V2::max_content_light_level

Maximum Content Light level (MaxCLL) ([0x0001-0xFFFF] = [1.0 - 65535.0] cd/m^2)

◆ [] [4/5]

NvU16 { ... } ::max_content_light_level

Maximum Content Light level (MaxCLL) ([0x0001-0xFFFF] = [1.0 - 65535.0] cd/m^2)

◆ max_content_light_level [5/5]

NvU16 _NV_HDR_METADATA_V1::max_content_light_level

Maximum Content Light level (MaxCLL) ([0x0000-0xFFFF] = [0.0 - 65535.0] cd/m^2, in units of 1 cd/m^2)

◆ [] [1/5]

NvU16 { ... } ::max_display_mastering_luminance

Maximum display mastering luminance ([0x0001-0xFFFF] = [1.0 - 65535.0] cd/m^2)

◆ max_display_mastering_luminance [2/5]

NvU16 _NV_HDR_COLOR_DATA_V1::max_display_mastering_luminance

Maximum display mastering luminance ([0x0001-0xFFFF] = [1.0 - 65535.0] cd/m^2)

◆ max_display_mastering_luminance [3/5]

NvU16 _NV_HDR_COLOR_DATA_V2::max_display_mastering_luminance

Maximum display mastering luminance ([0x0001-0xFFFF] = [1.0 - 65535.0] cd/m^2)

◆ [] [4/5]

NvU16 { ... } ::max_display_mastering_luminance

Maximum display mastering luminance ([0x0001-0xFFFF] = [1.0 - 65535.0] cd/m^2)

◆ max_display_mastering_luminance [5/5]

NvU16 _NV_HDR_METADATA_V1::max_display_mastering_luminance

Maximum display mastering luminance ([0x0000-0xFFFF] = [0.0 - 65535.0] cd/m^2, in units of 1 cd/m^2)

◆ max_frame_average_light_level [1/5]

NvU16 _NV_HDR_COLOR_DATA_V1::max_frame_average_light_level

Maximum Frame-Average Light Level (MaxFALL) ([0x0001-0xFFFF] = [1.0 - 65535.0] cd/m^2)

◆ [] [2/5]

NvU16 { ... } ::max_frame_average_light_level

Maximum Frame-Average Light Level (MaxFALL) ([0x0001-0xFFFF] = [1.0 - 65535.0] cd/m^2)

◆ [] [3/5]

NvU16 { ... } ::max_frame_average_light_level

Maximum Frame-Average Light Level (MaxFALL) ([0x0001-0xFFFF] = [1.0 - 65535.0] cd/m^2)

◆ max_frame_average_light_level [4/5]

NvU16 _NV_HDR_COLOR_DATA_V2::max_frame_average_light_level

Maximum Frame-Average Light Level (MaxFALL) ([0x0001-0xFFFF] = [1.0 - 65535.0] cd/m^2)

◆ max_frame_average_light_level [5/5]

NvU16 _NV_HDR_METADATA_V1::max_frame_average_light_level

Maximum Frame-Average Light Level (MaxFALL) ([0x0000-0xFFFF] = [0.0 - 65535.0] cd/m^2, in units of 1 cd/m^2)

◆ maxFrameInterval [1/2]

NvU32 _NV_GET_ADAPTIVE_SYNC_DATA_V1::maxFrameInterval

[out] maximum frame interval in micro seconds as set previously using NvAPI_DISP_SetAdaptiveSyncData function. If default values from EDID are used, this parameter returns 0.

◆ maxFrameInterval [2/2]

NvU32 _NV_SET_ADAPTIVE_SYNC_DATA_V1::maxFrameInterval

[in] maximum frame interval in micro seconds. If maxFrameInterval is send as 0, default values from EDID will be used.

◆ maxFreq_kHz [1/2]

NvU32 NV_GPU_PSTATE20_CLOCK_ENTRY_V1::maxFreq_kHz

Max clock frequency within given pstate in (kHz)

◆ [] [2/2]

NvU32 { ... } ::maxFreq_kHz

Max clock frequency within given pstate in (kHz)

◆ maxLaneCount

NV_DP_LANE_COUNT _NV_DISPLAY_PORT_INFO_V1::maxLaneCount

Maximum supported lane count.

◆ maxLines

NvU32 _NV_GSYNC_DELAY::maxLines

maximum number of lines supported at current display mode to induce delay. Updated by NvAPI_GSync_GetControlParameters(). Read only.

◆ maxLinkRate

NV_DP_LINK_RATE _NV_DISPLAY_PORT_INFO_V1::maxLinkRate

Maximum supported link rate.

◆ maxMulDivValue

NvU32 _NV_GSYNC_CAPABILITIES_V3::maxMulDivValue

This parameter returns the maximum possible value that can be programmed for multiplying / dividing house sync. Only valid if bIsMulDivSupported is set to 1.

◆ maxTmdsClock

NvU8 _NV_MONITOR_CAPS_VSDB::maxTmdsClock

Bye 4.

◆ maxVoltage_uV [1/2]

NvU32 NV_GPU_PSTATE20_CLOCK_ENTRY_V1::maxVoltage_uV

◆ [] [2/2]

NvU32 { ... } ::maxVoltage_uV

◆ mcuv10 [1/2]

NV_GPU_CLIENT_ILLUM_DEVICE_INFO_DATA_MCUV10 _NV_GPU_CLIENT_ILLUM_DEVICE_INFO_V1::mcuv10

◆ [] [2/2]

NV_GPU_CLIENT_ILLUM_DEVICE_INFO_DATA_MCUV10 { ... } ::mcuv10

◆ MiddleRegionShadingRate

NV_PIXEL_SHADING_RATE _NV_FOVEATED_RENDERING_CUSTOM_SHADING_RATE_PRESET_DESC_V1::MiddleRegionShadingRate

(IN) Shading Rate for the middle region of the foveated rendering pattern

◆ [] [1/3]

NvS32 { ... } ::min

Min value allowed for parameter delta (in respective units [kHz, uV])

◆ min [2/3]

NvS32 NV_GPU_PERF_PSTATES20_PARAM_DELTA::min

Min value allowed for parameter delta (in respective units [kHz, uV])

◆ min [3/3]

NvU16 _NV_LICENSE_EXPIRY_DETAILS::min

Minutes value of license expiry.

◆ [] [1/5]

NvU16 { ... } ::min_display_mastering_luminance

Minimum display mastering luminance ([0x0001-0xFFFF] = [1.0 - 6.55350] cd/m^2)

◆ min_display_mastering_luminance [2/5]

NvU16 _NV_HDR_COLOR_DATA_V1::min_display_mastering_luminance

Minimum display mastering luminance ([0x0001-0xFFFF] = [1.0 - 6.55350] cd/m^2)

◆ min_display_mastering_luminance [3/5]

NvU16 _NV_HDR_COLOR_DATA_V2::min_display_mastering_luminance

Minimum display mastering luminance ([0x0001-0xFFFF] = [1.0 - 6.55350] cd/m^2)

◆ [] [4/5]

NvU16 { ... } ::min_display_mastering_luminance

Minimum display mastering luminance ([0x0001-0xFFFF] = [1.0 - 6.55350] cd/m^2)

◆ min_display_mastering_luminance [5/5]

NvU16 _NV_HDR_METADATA_V1::min_display_mastering_luminance

Minimum display mastering luminance ([0x0000-0xFFFF] = [0.0 - 6.55350] cd/m^2, in units of 0.0001 cd/m^2)

◆ minFreq_kHz [1/2]

NvU32 NV_GPU_PSTATE20_CLOCK_ENTRY_V1::minFreq_kHz

Min clock frequency within given pstate in (kHz)

◆ [] [2/2]

NvU32 { ... } ::minFreq_kHz

Min clock frequency within given pstate in (kHz)

◆ minimumIntervalUs

NvU32 _NV_SET_SLEEP_MODE_PARAMS::minimumIntervalUs

(IN) Minimum frame interval in microseconds. 0 = no frame rate limit.

◆ minorSMVersion [1/2]

NvU16 _NV_D3D1x_GRAPHICS_CAPS_V2::minorSMVersion

(OUT) Minor SM version of the device

◆ minorSMVersion [2/2]

NvU16 _NV_D3D12_GRAPHICS_CAPS_V1::minorSMVersion

(OUT) Minor SM version of the device

◆ [] [1/3]

NvU32 { ... } ::minorVersion

Minor version. For GVI, minorVersion contains Revison(HIWORD) And Build(LOWORD)

◆ minorVersion [2/3]

NvU32 _NVVIOCAPS::minorVersion

Minor version. For GVI, minorVersion contains Revison(HIWORD) And Build(LOWORD)

Minor version. In version 2, for both GVI and GVO, minorVersion contains Revison(HIWORD) And Build(LOWORD)

◆ [] [3/3]

NvU32 { ... } ::minorVersion

Minor version. In version 2, for both GVI and GVO, minorVersion contains Revison(HIWORD) And Build(LOWORD)

◆ minPixels

NvU32 _NV_GSYNC_DELAY::minPixels

minimum number of pixels required at current display mode to induce delay. Updated by NvAPI_GSync_GetControlParameters(). Read only.

◆ minVoltage_uV [1/2]

NvU32 NV_GPU_PSTATE20_CLOCK_ENTRY_V1::minVoltage_uV

◆ [] [2/2]

NvU32 { ... } ::minVoltage_uV

◆ MipSlice [1/2]

UINT _NV_TEX2D_SRRV::MipSlice

◆ MipSlice [2/2]

UINT _NV_TEX2D_ARRAY_SRRV::MipSlice

◆ mode

NvU32 NV_INFOFRAME_PROPERTY::mode

◆ Mode [1/2]

NV_META_COMMAND_PADDING_MODE NV_META_COMMAND_PADDING_DESC::Mode

◆ Mode [2/2]

NvU64 NV_META_COMMAND_CREATE_CONVOLUTION_EX_DESC::Mode

◆ modifiedWCoefficients

NV_MODIFIED_W_COEFFICIENTS _NV_MODIFIED_W_PARAMS::modifiedWCoefficients[NV_MODIFIED_W_MAX_VIEWPORTS]

◆ month

NvU16 _NV_LICENSE_EXPIRY_DETAILS::month

Month value of license expiry.

◆ multiGPUVersion [1/2]

NvU32 _NV_MULTIGPU_CAPS_V1::multiGPUVersion

◆ multiGPUVersion [2/2]

NvU32 _NV_MULTIGPU_CAPS_V2::multiGPUVersion

◆ multiplyDivideMode

NVAPI_GSYNC_MULTIPLY_DIVIDE_MODE _NV_GSYNC_CONTROL_PARAMS_V2::multiplyDivideMode

Indicates multiplier/divider mode for the housesync signal. While setting multiplyDivideMode, source needs to be set as NVAPI_GSYNC_SYNC_SOURCE_HOUSESYNC.

◆ multiplyDivideValue

NvU8 _NV_GSYNC_CONTROL_PARAMS_V2::multiplyDivideValue

Indicates the multiplier/divider value for the housesync signal. Only supported if bIsMulDivSupported field of the structure NV_GSYNC_CAPABILITIES is set to 1. The maximum supported value for this field can be obtained from maxMulDivValue field of the structure NV_GSYNC_CAPABILITIES.

◆ MultisampleEnable

BOOL NvAPI_D3D11_RASTERIZER_DESC_EX::MultisampleEnable

◆ mvolt [1/2]

NvU32 NV_GPU_PERF_PSTATES_INFO_V2::mvolt

Voltage in mV.

◆ [] [2/2]

NvU32 { ... } ::mvolt

Voltage in mV.

◆ name [1/2]

NvU8 tagNV_TIMINGEXT::name[40]

Timing name.

◆ name [2/2]

NvAPI_ShortString _NV_MANAGED_DEDICATED_DISPLAY_METADATA::name

[in][out] Metadata for the virtual name of for the display connector specified by displayId. Valid characters are in the range of 32 ' ' (space) to 126 '~' (both included).

◆ Name

LPCWSTR NVAPI_META_COMMAND_DESC::Name

◆ nciVersion [1/2]

NvU8 NVLINK_LINK_STATUS_INFO_V1::nciVersion

This field specifies the NCI version supported by the link.

◆ nciVersion [2/2]

NvU8 NVLINK_LINK_STATUS_INFO_V2::nciVersion

This field specifies the NCI version supported by the link.

◆ NDCSplitsX [1/2]

float _NV_SMP_ASSIST_FASTGSCBDATA_V1::NDCSplitsX[2]

(OUT) FastGS constant buffer data for Multi-Res Shading/ Lens Matched Shading

◆ NDCSplitsX [2/2]

float _NV_SMP_ASSIST_FASTGSCBDATA_MRS_INSTANCED_STEREO_V1::NDCSplitsX[4]

(OUT) FastGS constant buffer data for Multi-Res Shading (Instanced stereo). 2 splits for left eye followed by 2 splits for right eye

◆ NDCSplitsY [1/2]

float _NV_SMP_ASSIST_FASTGSCBDATA_V1::NDCSplitsY[2]

◆ NDCSplitsY [2/2]

float _NV_SMP_ASSIST_FASTGSCBDATA_MRS_INSTANCED_STEREO_V1::NDCSplitsY[2]

◆ nonuniformScaling

NvU32 NV_INFOFRAME_VIDEO::nonuniformScaling

◆ nSLIGPUs [1/2]

NvU32 _NV_MULTIGPU_CAPS_V1::nSLIGPUs

◆ nSLIGPUs [2/2]

NvU32 _NV_MULTIGPU_CAPS_V2::nSLIGPUs

◆ nTotalGPUs [1/2]

NvU32 _NV_MULTIGPU_CAPS_V1::nTotalGPUs

◆ nTotalGPUs [2/2]

NvU32 _NV_MULTIGPU_CAPS_V2::nTotalGPUs

◆ numAnselFeatures

UINT NVAPI_ANSEL_CONFIGURATION_STRUCT_V1::numAnselFeatures

Number of features in pAnselFeatures.

◆ numBaseVoltages [1/2]

NvU32 NV_GPU_PERF_PSTATES20_INFO_V1::numBaseVoltages

Number of populated base voltages (per pstate)

◆ numBaseVoltages [2/2]

NvU32 _NV_GPU_PERF_PSTATES20_INFO_V2::numBaseVoltages

Number of populated base voltages (per pstate)

◆ numBuffers

NvU32 _NV_D3D_LATELATCH_OBJECT_DESC_V1::numBuffers

◆ numClocks [1/4]

NvU32 NV_GPU_PERF_PSTATES20_INFO_V1::numClocks

Number of populated clocks (per pstate)

◆ numClocks [2/4]

NvU32 _NV_GPU_PERF_PSTATES20_INFO_V2::numClocks

Number of populated clocks (per pstate)

◆ numClocks [3/4]

NvU32 NV_GPU_PERF_PSTATES_INFO_V1::numClocks

The number of clock domains supported by each P-State.

◆ numClocks [4/4]

NvU32 NV_GPU_PERF_PSTATES_INFO_V2::numClocks

The number of clock domains supported by each P-State.

◆ NumCustomSemantics [1/15]

NvU32 NvAPI_D3D11_CREATE_GEOMETRY_SHADER_EX_V5::NumCustomSemantics

◆ NumCustomSemantics [2/15]

NvU32 NvAPI_D3D11_CREATE_VERTEX_SHADER_EX_V1::NumCustomSemantics

◆ NumCustomSemantics [3/15]

NvU32 NvAPI_D3D11_CREATE_VERTEX_SHADER_EX_V2::NumCustomSemantics

◆ NumCustomSemantics [4/15]

NvU32 NvAPI_D3D11_CREATE_VERTEX_SHADER_EX_V3::NumCustomSemantics

◆ NumCustomSemantics [5/15]

NvU32 NvAPI_D3D11_CREATE_HULL_SHADER_EX_V1::NumCustomSemantics

◆ NumCustomSemantics [6/15]

NvU32 NvAPI_D3D11_CREATE_HULL_SHADER_EX_V2::NumCustomSemantics

◆ NumCustomSemantics [7/15]

NvU32 NvAPI_D3D11_CREATE_DOMAIN_SHADER_EX_V1::NumCustomSemantics

◆ NumCustomSemantics [8/15]

NvU32 NvAPI_D3D11_CREATE_DOMAIN_SHADER_EX_V2::NumCustomSemantics

◆ NumCustomSemantics [9/15]

NvU32 NvAPI_D3D11_CREATE_DOMAIN_SHADER_EX_V3::NumCustomSemantics

◆ NumCustomSemantics [10/15]

NvU32 NvAPI_D3D11_CREATE_PIXEL_SHADER_EX_V1::NumCustomSemantics

◆ NumCustomSemantics [11/15]

NvU32 NvAPI_D3D11_CREATE_PIXEL_SHADER_EX_V2::NumCustomSemantics

◆ NumCustomSemantics [12/15]

NvU32 NVAPI_D3D12_PSO_GEOMETRY_SHADER_DESC_V5::NumCustomSemantics

◆ NumCustomSemantics [13/15]

NvU32 NVAPI_D3D12_PSO_VERTEX_SHADER_DESC_V1::NumCustomSemantics

◆ NumCustomSemantics [14/15]

NvU32 NVAPI_D3D12_PSO_HULL_SHADER_DESC_V1::NumCustomSemantics

◆ NumCustomSemantics [15/15]

NvU32 NVAPI_D3D12_PSO_DOMAIN_SHADER_DESC_V1::NumCustomSemantics

◆ numDescs

NvU32 _NVAPI_D3D12_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_INPUTS_EX::numDescs

If type is D3D12_RAYTRACING_ACCELERATION_STRUCTURE_TOP_LEVEL, it represents the number of descriptions stored in instanceDescs. Otherwise, it contains the number of geometry descriptions stored in pGeometryDescs or ppGeometryDescs.

◆ numDMMUsageCounts [1/2]

NvU32 _NVAPI_D3D12_BUILD_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_INPUTS::numDMMUsageCounts

Number of DMM usage count entries in the pDMMUsageCounts array.

◆ numDMMUsageCounts [2/2]

NvU32 _NVAPI_D3D12_RAYTRACING_GEOMETRY_DMM_ATTACHMENT_DESC::numDMMUsageCounts

Number of DMM usage count entries in the pDMMUsageCounts array.

◆ numEntries

NvU32 _NV_MODIFIED_W_PARAMS::numEntries

◆ numIllumDevices [1/2]

NvU32 _NV_GPU_CLIENT_ILLUM_DEVICE_INFO_PARAMS_V1::numIllumDevices

Number of illumination devices present.

◆ numIllumDevices [2/2]

NvU32 NV_GPU_CLIENT_ILLUM_DEVICE_CONTROL_PARAMS_V1::numIllumDevices

Number of illumination devices present.

◆ numIllumZones

NvU32 _NV_GPU_CLIENT_ILLUM_ZONE_INFO_PARAMS_V1::numIllumZones

Number of illumination zones present.

◆ numIllumZonesControl

NvU32 _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_PARAMS_V1::numIllumZonesControl

Number of illumination zones present.

◆ numLines

NvU32 _NV_GSYNC_DELAY::numLines

delay to be induced in number of horizontal lines.

◆ numLinks

NvU32 _NVVIOSTREAM::numLinks

Number of active links.

◆ numOfApps

NvU32 _NVDRS_PROFILE_V1::numOfApps

Total number of applications that belong to this profile. Read-only.

◆ numOfSettings

NvU32 _NVDRS_PROFILE_V1::numOfSettings

Total number of settings applied for this Profile. Read-only.

◆ numOMMUsageCounts [1/2]

NvU32 _NVAPI_D3D12_BUILD_RAYTRACING_OPACITY_MICROMAP_ARRAY_INPUTS::numOMMUsageCounts

Number of OMM usage count entries in the pOMMUsageCounts array.

◆ numOMMUsageCounts [2/2]

NvU32 _NVAPI_D3D12_RAYTRACING_GEOMETRY_OMM_ATTACHMENT_DESC::numOMMUsageCounts

Number of OMM usage count entries in the pOMMUsageCounts array.

◆ numPixels

NvU32 _NV_GSYNC_DELAY::numPixels

delay to be induced in number of pixels.

◆ numPostbuildInfoDescs [1/3]

NvU32 _NVAPI_BUILD_RAYTRACING_OPACITY_MICROMAP_ARRAY_PARAMS_V1::numPostbuildInfoDescs

[in] Size of postbuild info desc array. Set to 0 if none are needed.

◆ numPostbuildInfoDescs [2/3]

NvU32 _NVAPI_BUILD_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PARAMS_V1::numPostbuildInfoDescs

[in] Size of postbuild info desc array. Set to 0 if none are needed.

◆ numPostbuildInfoDescs [3/3]

NvU32 _NVAPI_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_EX_PARAMS_V1::numPostbuildInfoDescs

[in] Size of postbuild info desc array. Set to 0 if none are needed.

◆ numPstates [1/4]

NvU32 NV_GPU_PERF_PSTATES20_INFO_V1::numPstates

Number of populated pstates.

◆ numPstates [2/4]

NvU32 _NV_GPU_PERF_PSTATES20_INFO_V2::numPstates

Number of populated pstates.

◆ numPstates [3/4]

NvU32 NV_GPU_PERF_PSTATES_INFO_V1::numPstates

The number of available p-states.

◆ numPstates [4/4]

NvU32 NV_GPU_PERF_PSTATES_INFO_V2::numPstates

The number of available p-states.

◆ numRawCaptureImages

NvU32 _NVVIOINPUTCONFIG::numRawCaptureImages

numRawCaptureImages is the number of frames to keep in the capture queue. must be between NVAPI_GVI_MIN_RAW_CAPTURE_IMAGES and NVAPI_GVI_MAX_RAW_CAPTURE_IMAGES,

◆ numRects

NvU32 _NV_D3D11_EXCLUSIVE_SCISSOR_RECTS_DESC_V1::numRects

(IN) Number of Exclusive Scissor Rects to be set.

◆ numSettingValues

NvU32 _NVDRS_SETTING_VALUES::numSettingValues

Total number of values available in a setting.

◆ numSources [1/2]

NvU32 _NVAPI_EMIT_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_POSTBUILD_INFO_PARAMS_V1::numSources

[in] Number of DMM Arrays in pSources.

◆ numSources [2/2]

NvU32 _NVAPI_EMIT_RAYTRACING_OPACITY_MICROMAP_ARRAY_POSTBUILD_INFO_PARAMS_V1::numSources

[in] Number of OMM Arrays in pSources.

◆ numStreams

NvU32 _NVVIOINPUTCONFIG::numStreams

Number of active streams.

◆ numUtils

NvU32 _NV_GPU_CLIENT_CALLBACK_UTILIZATION_DATA_V1::numUtils

[out] Number of valid entries in utils array.

◆ numVertices

int NV_SCANOUT_WARPING_DATA::numVertices

number of the input vertices

◆ numViewports [1/3]

NvU32 _NV_D3D11_VIEWPORTS_SHADING_RATE_DESC_V1::numViewports

(IN) Number of viewports with shading rate set.

◆ numViewports [2/3]

NvU32 _NV_CUSTOM_RECTS_V1::numViewports[NV_SMP_ASSIST_MINIMAL_LEVEL_NUM_EYE_INDICES]

◆ numViewports [3/3]

NvU32 _NV_SMP_ASSIST_GET_CONSTANTS_V3::numViewports

(OUT) Number of valid viewport entries

◆ numViews

NvU32 _NV_MULTIVIEW_PARAMS_V1::numViews

◆ numVoltages [1/3]

NvU32 _NV_GPU_PERF_PSTATES20_INFO_V2::numVoltages

Number of populated voltages.

◆ [] [2/3]

NvU32 { ... } ::numVoltages

Number of populated voltages.

◆ numVoltages [3/3]

NvU32 NV_GPU_PERF_PSTATES_INFO_V2::numVoltages

◆ [union]

union { ... } NV_EVENT_REGISTER_CALLBACK::nvCallBackFunc

◆ NVCustomSemanticNameString

NvAPI_LongString _NV_CUSTOM_SEMANTIC::NVCustomSemanticNameString

◆ NVCustomSemanticType

NV_CUSTOM_SEMANTIC_TYPE _NV_CUSTOM_SEMANTIC::NVCustomSemanticType

◆ NVHeapFlags

NV_D3D12_HEAP_FLAGS _NV_HEAP_PARAMS_V1::NVHeapFlags

Additional NV specific flags.

◆ nvlinkCommonClockSpeedMhz [1/2]

NvU32 NVLINK_LINK_STATUS_INFO_V1::nvlinkCommonClockSpeedMhz

This field gives the value of nvlink common clock in MHz.

◆ nvlinkCommonClockSpeedMhz [2/2]

NvU32 NVLINK_LINK_STATUS_INFO_V2::nvlinkCommonClockSpeedMhz

This field gives the value of nvlink common clock in MHz.

◆ nvlinkLineRateMbps

NvU32 NVLINK_LINK_STATUS_INFO_V2::nvlinkLineRateMbps

Bit rate at which bits toggle on wires in megabits per second.

◆ nvlinkLinkClockMhz [1/2]

NvU32 NVLINK_LINK_STATUS_INFO_V1::nvlinkLinkClockMhz

This field gives the actual clock/speed at which links is running in MHz.

◆ nvlinkLinkClockMhz [2/2]

NvU32 NVLINK_LINK_STATUS_INFO_V2::nvlinkLinkClockMhz

This field gives the actual clock/speed at which links is running in MHz.

◆ NvLinkPresent

NvU32 _NV_MULTIGPU_CAPS_V2::NvLinkPresent

◆ nvlinkRefClkSpeedMhz [1/2]

NvU32 NVLINK_LINK_STATUS_INFO_V1::nvlinkRefClkSpeedMhz

This field gives the value of nvlink refclk clock in MHz.

◆ nvlinkRefClkSpeedMhz [2/2]

NvU32 NVLINK_LINK_STATUS_INFO_V2::nvlinkRefClkSpeedMhz

This field gives the value of nvlink refclk clock in MHz.

◆ nvlinkRefClkType [1/2]

NvU8 NVLINK_LINK_STATUS_INFO_V1::nvlinkRefClkType

This field specifies whether refclk is taken from NVHS reflck or PEX refclk for the current GPU.See NVAPI_NVLINK_REFCLK_TYPE_INVALID* for possible values.

◆ nvlinkRefClkType [2/2]

NvU8 NVLINK_LINK_STATUS_INFO_V2::nvlinkRefClkType

This field specifies whether refclk is taken from NVHS reflck or PEX refclk for the current GPU.See NVAPI_NVLINK_REFCLK_TYPE_INVALID* for possible values.

◆ nvlinkVersion [1/2]

NvU8 NVLINK_LINK_STATUS_INFO_V1::nvlinkVersion

This field specifies the NVLink version supported by the link.

◆ nvlinkVersion [2/2]

NvU8 NVLINK_LINK_STATUS_INFO_V2::nvlinkVersion

This field specifies the NVLink version supported by the link.

◆ nvPsfId [1/2]

NvU32 NV_TIMING_FLAG::nvPsfId

The NV predefined PsF format Id. Used when the timing type is NV_TIMING_OVERRIDE_NV_PREDEFINED.

◆ [] [2/2]

NvU32 { ... } ::nvPsfId

The NV predefined PsF format Id. Used when the timing type is NV_TIMING_OVERRIDE_NV_PREDEFINED.

◆ [] [1/2]

NVAPI_CALLBACK_QSYNCEVENT { ... } ::nvQSYNCEventCallback

Callback function pointer for QSYNC events.

◆ nvQSYNCEventCallback [2/2]

NVAPI_CALLBACK_QSYNCEVENT NV_EVENT_REGISTER_CALLBACK::nvQSYNCEventCallback

Callback function pointer for QSYNC events.

◆ NVResourceFlags

NV_D3D12_RESOURCE_FLAGS _NV_RESOURCE_PARAMS_V1::NVResourceFlags

Additional NV specific flags (set the NV_D3D12_RESOURCE_FLAG_HTEX bit to create HTEX texture)

◆ nvs

NvU32 _NVDRS_GPU_SUPPORT::nvs

◆ nvvioConfigType [1/3]

NVVIOCONFIGTYPE _NVVIOCONFIG_V1::nvvioConfigType

Input or Output configuration.

◆ nvvioConfigType [2/3]

NVVIOCONFIGTYPE _NVVIOCONFIG_V2::nvvioConfigType

Input or Output configuration.

◆ nvvioConfigType [3/3]

NVVIOCONFIGTYPE _NVVIOCONFIG_V3::nvvioConfigType

Input or Output configuration.

◆ nvvioStatusType

NVVIOSTATUSTYPE _NVVIOSTATUS::nvvioStatusType

Input or Output status.

◆ offset

NvU32 NV_EDID_V3::offset

Which 256-byte page of the EDID we want to read. Start at 0. If the read succeeds with edidSize > NV_EDID_DATA_SIZE, call back again with offset+256 until we have read the entire buffer

◆ Offset

NvU64 NV_D3D11_META_COMMAND_RESOURCE::Offset

◆ OffsetRtIndexByVpIndex [1/2]

BOOL NvAPI_D3D11_CREATE_GEOMETRY_SHADER_EX_V5::OffsetRtIndexByVpIndex

◆ OffsetRtIndexByVpIndex [2/2]

BOOL NVAPI_D3D12_PSO_GEOMETRY_SHADER_DESC_V5::OffsetRtIndexByVpIndex

◆ offsetTexChannels

NvU32 NV_SCANOUT_INTENSITY_DATA_V2::offsetTexChannels

number of channels per pixel in the offset texture

◆ offsetTexture

float* NV_SCANOUT_INTENSITY_DATA_V2::offsetTexture

array of floating values building an offset texture

◆ ommAttachment

NVAPI_D3D12_RAYTRACING_GEOMETRY_OMM_ATTACHMENT_DESC _NVAPI_D3D12_RAYTRACING_GEOMETRY_OMM_TRIANGLES_DESC::ommAttachment

Opacity Micromap attachment descriptor.

◆ ommTriangles [1/2]

NVAPI_D3D12_RAYTRACING_GEOMETRY_OMM_TRIANGLES_DESC _NVAPI_D3D12_RAYTRACING_GEOMETRY_DESC_EX::ommTriangles

Describes triangle geometry which may optionally use Opacity Micromaps, if type is NVAPI_D3D12_RAYTRACING_GEOMETRY_TYPE_OMM_TRIANGLES_EX. Otherwise, this parameter is unused (space repurposed in a union).

◆ [] [2/2]

NVAPI_D3D12_RAYTRACING_GEOMETRY_OMM_TRIANGLES_DESC { ... } ::ommTriangles

Describes triangle geometry which may optionally use Opacity Micromaps, if type is NVAPI_D3D12_RAYTRACING_GEOMETRY_TYPE_OMM_TRIANGLES_EX. Otherwise, this parameter is unused (space repurposed in a union).

◆ opacityMicromapArray [1/2]

D3D12_GPU_VIRTUAL_ADDRESS _NVAPI_D3D12_RAYTRACING_GEOMETRY_OMM_ATTACHMENT_DESC::opacityMicromapArray

Pointer to an OMM Array used by this geometry; it may be set to NULL if no non-uniform OMMs are used. Unlike vertex, index, and transform buffers, this resource is dereferenced during raytracing.

◆ opacityMicromapArray [2/2]

D3D12_GPU_VIRTUAL_ADDRESS _NVAPI_RELOCATE_RAYTRACING_OPACITY_MICROMAP_ARRAY_PARAMS_V1::opacityMicromapArray

[in] OMM Array current memory address; it must be 256-byte aligned (NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_ARRAY_BYTE_ALIGNMENT).

◆ opacityMicromapBaseLocation

NvU32 _NVAPI_D3D12_RAYTRACING_GEOMETRY_OMM_ATTACHMENT_DESC::opacityMicromapBaseLocation

Constant added to all non-negative OMM indices in opacityMicromapIndexBuffer.

◆ opacityMicromapIndexBuffer

D3D12_GPU_VIRTUAL_ADDRESS_AND_STRIDE _NVAPI_D3D12_RAYTRACING_GEOMETRY_OMM_ATTACHMENT_DESC::opacityMicromapIndexBuffer

Optional buffer specifying which OMM index to use for each triangle; if NULL, there is a 1:1 mapping between input triangles and OMM Array entries. Special values can be used to encode OMMs with uniform state for individual triangles (see NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_SPECIAL_INDEX). For BLAS updates, this input buffer must match that of the original build if the NVAPI_D3D12_RAYTRACING_ACCELERATION_STRUCTURE_BUILD_FLAG_ALLOW_OMM_UPDATE_EX build flag is not set.

◆ opacityMicromapIndexFormat

DXGI_FORMAT _NVAPI_D3D12_RAYTRACING_GEOMETRY_OMM_ATTACHMENT_DESC::opacityMicromapIndexFormat

Format of opacityMicromapIndexBuffer, either DXGI_FORMAT_R32_UINT or DXGI_FORMAT_R16_UINT.

◆ osRenderQueueEndTime

NvU64 _NV_LATENCY_RESULT_PARAMS::FrameReport::osRenderQueueEndTime

◆ osRenderQueueStartTime

NvU64 _NV_LATENCY_RESULT_PARAMS::FrameReport::osRenderQueueStartTime

◆ outConfig [1/6]

NVVIOOUTPUTCONFIG_V1 _NVVIOCONFIG_V1::outConfig

Output device configuration.

◆ [] [2/6]

NVVIOOUTPUTCONFIG_V1 { ... } ::outConfig

Output device configuration.

◆ [] [3/6]

NVVIOOUTPUTCONFIG_V2 { ... } ::outConfig

Output device configuration.

◆ outConfig [4/6]

NVVIOOUTPUTCONFIG_V2 _NVVIOCONFIG_V2::outConfig

Output device configuration.

◆ [] [5/6]

NVVIOOUTPUTCONFIG_V3 { ... } ::outConfig

Output device configuration.

◆ outConfig [6/6]

NVVIOOUTPUTCONFIG_V3 _NVVIOCONFIG_V3::outConfig

Output device configuration.

◆ outFlags

NvU64 NVAPI_UAV_INFO_V2::outFlags

◆ outputArea [1/3]

NVVIOOUTPUTAREA _NVVIOOUTPUTCONFIG_V1::outputArea

Usable resolution for video output (safe area)

◆ outputArea [2/3]

NVVIOOUTPUTAREA _NVVIOOUTPUTCONFIG_V2::outputArea

Usable resolution for video output (safe area)

◆ outputArea [3/3]

NVVIOOUTPUTAREA _NVVIOOUTPUTCONFIG_V3::outputArea

Usable resolution for video output (safe area)

◆ outputId

NvU32 NVVIOTOPOLOGYTARGET::outputId

outputId will be 0 for GVI device.

deviceMask of the SDI display connected to GVO device.

◆ OutputPrepool

NV_META_COMMAND_BOOL NV_META_COMMAND_CONVOLUTION_FUSE_DESC::OutputPrepool

◆ outputRegion [1/3]

NVVIOOUTPUTREGION _NVVIOOUTPUTCONFIG_V1::outputRegion

Region for video output (Desktop mode)

◆ outputRegion [2/3]

NVVIOOUTPUTREGION _NVVIOOUTPUTCONFIG_V2::outputRegion

Region for video output (Desktop mode)

◆ outputRegion [3/3]

NVVIOOUTPUTREGION _NVVIOOUTPUTCONFIG_V3::outputRegion

Region for video output (Desktop mode)

◆ OutputResource [1/4]

NV_D3D11_META_COMMAND_RESOURCE NV_D3D11_META_COMMAND_EXECUTE_CONVOLUTION_EX_DESC::OutputResource

◆ OutputResource [2/4]

NV_D3D11_META_COMMAND_RESOURCE NV_D3D11_META_COMMAND_EXECUTE_GEMM_DESC::OutputResource

◆ OutputResource [3/4]

D3D12_GPU_VIRTUAL_ADDRESS NV_D3D12_META_COMMAND_EXECUTE_CONVOLUTION_EX_DESC::OutputResource

◆ OutputResource [4/4]

NvU64 NV_D3D12_META_COMMAND_EXECUTE_GEMM_DESC::OutputResource

◆ outputVideoLocked

NvU32 _NVVIOOUTPUTSTATUS::outputVideoLocked

Output locked status.

◆ outStatus [1/2]

NVVIOOUTPUTSTATUS _NVVIOSTATUS::outStatus

Output device status.

◆ [] [2/2]

NVVIOOUTPUTSTATUS { ... } ::outStatus

Output device status.

◆ [struct]

struct { ... } _NV_GPU_PERF_PSTATES20_INFO_V2::ov

OV settings - Please refer to NVIDIA over-volting recommendation to understand impact of this functionality Valid index range is 0 to numVoltages-1

◆ overlapX [1/6]

NvS32 NV_MOSAIC_TOPO_DETAILS::overlapX

Pixels of overlap on left of target: (+overlap, -gap)

◆ [] [2/6]

NvS32 { ... } ::overlapX

Pixels of overlap on left of target: (+overlap, -gap)

◆ overlapX [3/6]

NvS32 _NV_MOSAIC_GRID_TOPO_DISPLAY_V1::overlapX

(+overlap, -gap)

◆ overlapX [4/6]

NvS32 _NV_MOSAIC_GRID_TOPO_DISPLAY_V2::overlapX

(+overlap, -gap)

◆ overlapX [5/6]

NvS32 NV_MOSAIC_TOPOLOGY::overlapX

Pixels of overlap on the left of target: (+overlap, -gap)

◆ [] [6/6]

NvS32 { ... } ::overlapX

Pixels of overlap on the left of target: (+overlap, -gap)

◆ overlapY [1/6]

NvS32 NV_MOSAIC_TOPO_DETAILS::overlapY

Pixels of overlap on top of target: (+overlap, -gap)

◆ [] [2/6]

NvS32 { ... } ::overlapY

Pixels of overlap on top of target: (+overlap, -gap)

◆ overlapY [3/6]

NvS32 _NV_MOSAIC_GRID_TOPO_DISPLAY_V1::overlapY

(+overlap, -gap)

◆ overlapY [4/6]

NvS32 _NV_MOSAIC_GRID_TOPO_DISPLAY_V2::overlapY

(+overlap, -gap)

◆ overlapY [5/6]

NvS32 NV_MOSAIC_TOPOLOGY::overlapY

Pixels of overlap on the top of target: (+overlap, -gap)

◆ [] [6/6]

NvS32 { ... } ::overlapY

Pixels of overlap on the top of target: (+overlap, -gap)

◆ ownerId

NVVIOOWNERID _NVVIOCAPS::ownerId

Unique identifier for owner of video output (NVVIOOWNERID_INVALID if free running)

◆ ownerType [1/2]

NVVIOOWNERTYPE _NVVIOCAPS::ownerType

Owner type (OpenGL application or Desktop mode)

◆ ownerType [2/2]

NvU32 NVVIOOWNERTYPE ownerType

◆ pAdapterCaps

NVVIOCAPS* pAdapterCaps

◆ Padding [1/2]

NV_META_COMMAND_PADDING_DESC NV_META_COMMAND_CREATE_CONVOLUTION_EX_DESC::Padding

◆ Padding [2/2]

float _NV_SMP_ASSIST_REMAPCBDATA_V1::Padding[2]

◆ pAnselFeatures

NVAPI_ANSEL_FEATURE_CONFIGURATION_STRUCT* NVAPI_ANSEL_CONFIGURATION_STRUCT_V1::pAnselFeatures

Array of features configurations.

◆ Params

float NV_META_COMMAND_ACTIVATION_DESC::Params[NV_META_COMMAND_ACTIVATION_MAX_PARAMS]

◆ paramSize [1/2]

NvU32 _NVAPI_CU_KERNEL_LAUNCH_PARAMS::paramSize

◆ paramSize [2/2]

NvU32 _NVAPI_CU_KERNEL_LAUNCH_PARAMS_EX::paramSize

◆ parity [1/2]

NvU32 _NV_HDR_CAPABILITIES_V3::parity

resolution and frame-rate relationships between Dolby Vision and other video processing

◆ [] [2/2]

NvU32 { ... } ::parity

resolution and frame-rate relationships between Dolby Vision and other video processing

◆ path [1/2]

NV_DISPLAY_PATH NV_DISPLAY_PATH_INFO::path[NVAPI_ADVANCED_MAX_DISPLAY_PATH]

◆ path [2/2]

NV_DISPLAY_PATH NV_DISPLAY_PATH_INFO_V3::path[NVAPI_MAX_DISPLAY_PATH]

◆ pbCompatible

NvU32 NvU32 NvU32* pbCompatible

◆ pbData [1/3]

NvU8* NV_I2C_INFO_V1::pbData

The buffer of data which is to be read or written (depending on the command).

◆ pbData [2/3]

NvU8* NV_I2C_INFO_V2::pbData

The buffer of data which is to be read or written (depending on the command).

◆ pbData [3/3]

NvU8* NV_I2C_INFO_V3::pbData

The buffer of data which is to be read or written (depending on the command).

◆ pbI2cRegAddress [1/3]

NvU8* NV_I2C_INFO_V1::pbI2cRegAddress

The I2C target register address. May be NULL, which indicates no register address should be sent.

◆ pbI2cRegAddress [2/3]

NvU8* NV_I2C_INFO_V2::pbI2cRegAddress

The I2C target register address. May be NULL, which indicates no register address should be sent.

◆ pbI2cRegAddress [3/3]

NvU8* NV_I2C_INFO_V3::pbI2cRegAddress

The I2C target register address. May be NULL, which indicates no register address should be sent.

◆ pCallbackParam [1/2]

void* _NV_CLIENT_CALLBACK_SETTINGS_SUPER_V1::pCallbackParam

[in] Generic callback parameter which will be passed to the callback.

◆ pCallbackParam [2/2]

void* _NV_GPU_CLIENT_CALLBACK_DATA_SUPER_V1::pCallbackParam

[out] Generic callback parameter which was passed in at registration time.

◆ pciBus

NvU32 _NVVIOPCIINFO::pciBus

specifies the PCI bus number of the GVI device.

◆ pciDeviceId [1/2]

NvU32 NVLINK_DEVICE_INFO_V1::pciDeviceId

◆ pciDeviceId [2/2]

NvU32 _NVVIOPCIINFO::pciDeviceId

specifies the internal PCI device identifier for the GVI.

◆ pciDomain

NvU32 _NVVIOPCIINFO::pciDomain

specifies the PCI domain of the GVI device.

◆ pciLinkRate

NVVIOPCILINKRATE _NVVIOPCIINFO::pciLinkRate

specifies the the negotiated PCIE link rate.

◆ pciLinkWidth

NVVIOPCILINKWIDTH _NVVIOPCIINFO::pciLinkWidth

specifies the the negotiated PCIE link width.

◆ pciRevisionId

NvU32 _NVVIOPCIINFO::pciRevisionId

specifies the internal PCI device-specific revision identifier for the GVI.

◆ pciSlot

NvU32 _NVVIOPCIINFO::pciSlot

specifies the PCI slot number of the GVI device.

◆ pciSubSystemId

NvU32 _NVVIOPCIINFO::pciSubSystemId

specifies the internal PCI subsystem identifier for the GVI.

◆ pclk

NvU32 _NV_TIMING::pclk

pixel clock in 10 kHz

◆ pConfig

const NVVIOCONFIG * pConfig

◆ pCoordinateSwizzling [1/4]

NvAPI_D3D11_SWIZZLE_MODE* NvAPI_D3D11_CREATE_GEOMETRY_SHADER_EX_V5::pCoordinateSwizzling

◆ pCoordinateSwizzling [2/4]

NvAPI_D3D11_SWIZZLE_MODE* NvAPI_D3D11_CREATE_FASTGS_EXPLICIT_DESC_V1::pCoordinateSwizzling

◆ pCoordinateSwizzling [3/4]

NvAPI_D3D11_SWIZZLE_MODE* NVAPI_D3D12_PSO_CREATE_FASTGS_EXPLICIT_DESC_V1::pCoordinateSwizzling

◆ pCoordinateSwizzling [4/4]

NvAPI_D3D11_SWIZZLE_MODE* NVAPI_D3D12_PSO_GEOMETRY_SHADER_DESC_V5::pCoordinateSwizzling

◆ pCSC

NVVIOCOLORCONVERSION * pCSC

◆ pCubin

const void* NVAPI_D3D12_CREATE_CUBIN_SHADER_PARAMS::pCubin

[in] pointer to blob containing the cubin

◆ pCustomSemantics [1/15]

NV_CUSTOM_SEMANTIC* NvAPI_D3D11_CREATE_GEOMETRY_SHADER_EX_V5::pCustomSemantics

◆ pCustomSemantics [2/15]

NV_CUSTOM_SEMANTIC* NvAPI_D3D11_CREATE_VERTEX_SHADER_EX_V1::pCustomSemantics

◆ pCustomSemantics [3/15]

NV_CUSTOM_SEMANTIC* NvAPI_D3D11_CREATE_VERTEX_SHADER_EX_V2::pCustomSemantics

◆ pCustomSemantics [4/15]

NV_CUSTOM_SEMANTIC* NvAPI_D3D11_CREATE_VERTEX_SHADER_EX_V3::pCustomSemantics

◆ pCustomSemantics [5/15]

NV_CUSTOM_SEMANTIC* NvAPI_D3D11_CREATE_HULL_SHADER_EX_V1::pCustomSemantics

◆ pCustomSemantics [6/15]

NV_CUSTOM_SEMANTIC* NvAPI_D3D11_CREATE_HULL_SHADER_EX_V2::pCustomSemantics

◆ pCustomSemantics [7/15]

NV_CUSTOM_SEMANTIC* NvAPI_D3D11_CREATE_DOMAIN_SHADER_EX_V1::pCustomSemantics

◆ pCustomSemantics [8/15]

NV_CUSTOM_SEMANTIC* NvAPI_D3D11_CREATE_DOMAIN_SHADER_EX_V2::pCustomSemantics

◆ pCustomSemantics [9/15]

NV_CUSTOM_SEMANTIC* NvAPI_D3D11_CREATE_DOMAIN_SHADER_EX_V3::pCustomSemantics

◆ pCustomSemantics [10/15]

NV_CUSTOM_SEMANTIC* NvAPI_D3D11_CREATE_PIXEL_SHADER_EX_V1::pCustomSemantics

◆ pCustomSemantics [11/15]

NV_CUSTOM_SEMANTIC* NvAPI_D3D11_CREATE_PIXEL_SHADER_EX_V2::pCustomSemantics

◆ pCustomSemantics [12/15]

NV_CUSTOM_SEMANTIC* NVAPI_D3D12_PSO_GEOMETRY_SHADER_DESC_V5::pCustomSemantics

◆ pCustomSemantics [13/15]

NV_CUSTOM_SEMANTIC* NVAPI_D3D12_PSO_VERTEX_SHADER_DESC_V1::pCustomSemantics

◆ pCustomSemantics [14/15]

NV_CUSTOM_SEMANTIC* NVAPI_D3D12_PSO_HULL_SHADER_DESC_V1::pCustomSemantics

◆ pCustomSemantics [15/15]

NV_CUSTOM_SEMANTIC* NVAPI_D3D12_PSO_DOMAIN_SHADER_DESC_V1::pCustomSemantics

◆ pDataFormatDetail

NvU32 NVVIODATAFORMATDETAIL* pDataFormatDetail

◆ pDesc [1/8]

const NVAPI_D3D12_BUILD_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_INPUTS* _NVAPI_GET_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PREBUILD_INFO_PARAMS_V1::pDesc

[in] Description of the DMM Array build.

◆ pDesc [2/8]

const NVAPI_D3D12_BUILD_RAYTRACING_OPACITY_MICROMAP_ARRAY_INPUTS* _NVAPI_GET_RAYTRACING_OPACITY_MICROMAP_ARRAY_PREBUILD_INFO_PARAMS_V1::pDesc

[in] Description of the OMM Array build.

◆ pDesc [3/8]

const NVAPI_D3D12_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_INPUTS_EX* _NVAPI_GET_RAYTRACING_ACCELERATION_STRUCTURE_PREBUILD_INFO_EX_PARAMS_V1::pDesc

[in] Description of the acceleration-structure build.

◆ pDesc [4/8]

const NVAPI_D3D12_BUILD_RAYTRACING_OPACITY_MICROMAP_ARRAY_DESC* _NVAPI_BUILD_RAYTRACING_OPACITY_MICROMAP_ARRAY_PARAMS_V1::pDesc

[in] Description of the OMM Array build.

◆ pDesc [5/8]

const NVAPI_D3D12_BUILD_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_DESC* _NVAPI_BUILD_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PARAMS_V1::pDesc

[in] Description of the DMM Array build.

◆ pDesc [6/8]

const NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_POSTBUILD_INFO_DESC* _NVAPI_EMIT_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_POSTBUILD_INFO_PARAMS_V1::pDesc

[in] Description of which postbuild info to emit.

◆ pDesc [7/8]

const NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_ARRAY_POSTBUILD_INFO_DESC* _NVAPI_EMIT_RAYTRACING_OPACITY_MICROMAP_ARRAY_POSTBUILD_INFO_PARAMS_V1::pDesc

[in] Description of which postbuild info to emit.

◆ pDesc [8/8]

const NVAPI_D3D12_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_DESC_EX* _NVAPI_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_EX_PARAMS_V1::pDesc

[in] Description of the acceleration structure to build.

◆ pDevice [1/5]

__in ID3D12Device* _NV_D3D12_MOSAIC_GETCOMPANIONALLOCATIONS::pDevice

The ID3D12Device created by application.

◆ pDevice [2/5]

__in ID3D12Device* _NV_D3D12_MOSAIC_GETVIEWPORTANDGPUPARTITIONS::pDevice

The ID3D12Device created by application.

◆ pDevice [3/5]

ID3D12Device* NVAPI_D3D12_CREATE_CUBIN_SHADER_PARAMS::pDevice

[in] pointer to ID3D12Device object

◆ pDevice [4/5]

ID3D12Device* NVAPI_D3D12_GET_CUDA_MERGED_TEXTURE_SAMPLER_OBJECT_PARAMS::pDevice

[in] pointer to ID3D12Device object

◆ pDevice [5/5]

ID3D12Device* NVAPI_D3D12_GET_CUDA_INDEPENDENT_DESCRIPTOR_OBJECT_PARAMS::pDevice

[in] Pointer to ID3D12Device object

◆ pDMMUsageCounts [1/2]

const NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_USAGE_COUNT* _NVAPI_D3D12_BUILD_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_INPUTS::pDMMUsageCounts

Usage counts for each subdivision level and format combination across all the DMM entries in the build.

◆ pDMMUsageCounts [2/2]

const NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_USAGE_COUNT* _NVAPI_D3D12_RAYTRACING_GEOMETRY_DMM_ATTACHMENT_DESC::pDMMUsageCounts

Usage counts for each subdivision level and format combination across all the DMM entries referred-to by the DMM index buffer specified by this geometry.

◆ [] [1/2]

NvU16 { ... } ::peak_luminance_index

Peak luminance index.

◆ peak_luminance_index [2/2]

NvU16 _NV_HDR_CAPABILITIES_V3::peak_luminance_index

Peak luminance index.

◆ pEDID [1/2]

NvU8* _NV_EDID_DATA_V1::pEDID

Pointer to EDID data.

◆ pEDID [2/2]

NvU8* _NV_EDID_DATA_V2::pEDID

Pointer to EDID data.

◆ [] [1/2]

NvU32 { ... } ::percentage

Percentage of time where the domain is considered busy in the last 1 second interval.

◆ percentage [2/2]

NvU32 NV_GPU_DYNAMIC_PSTATES_INFO_EX::percentage

Percentage of time where the domain is considered busy in the last 1 second interval.

◆ PerChannelScaling

NV_META_COMMAND_BOOL NV_META_COMMAND_CREATE_CONVOLUTION_EX_DESC::PerChannelScaling

◆ perDMMDescs

D3D12_GPU_VIRTUAL_ADDRESS_AND_STRIDE _NVAPI_D3D12_BUILD_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_INPUTS::perDMMDescs

GPU array with one NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_DESC entry per DMM.

◆ PeripheralRegionShadingRate

NV_PIXEL_SHADING_RATE _NV_FOVEATED_RENDERING_CUSTOM_SHADING_RATE_PRESET_DESC_V1::PeripheralRegionShadingRate

(IN) Shading Rate for the peripheral region of the foveated rendering pattern

◆ perOMMDescs

D3D12_GPU_VIRTUAL_ADDRESS_AND_STRIDE _NVAPI_D3D12_BUILD_RAYTRACING_OPACITY_MICROMAP_ARRAY_INPUTS::perOMMDescs

GPU array with one NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_DESC entry per OMM.

◆ PersistentResource [1/8]

NV_D3D11_META_COMMAND_RESOURCE NV_D3D11_META_COMMAND_INITIALIZE_CONVOLUTION_EX_DESC::PersistentResource

◆ PersistentResource [2/8]

NV_D3D11_META_COMMAND_RESOURCE NV_D3D11_META_COMMAND_EXECUTE_CONVOLUTION_EX_DESC::PersistentResource

◆ PersistentResource [3/8]

NV_D3D11_META_COMMAND_RESOURCE NV_D3D11_META_COMMAND_INITIALIZE_GEMM_DESC::PersistentResource

◆ PersistentResource [4/8]

NV_D3D11_META_COMMAND_RESOURCE NV_D3D11_META_COMMAND_EXECUTE_GEMM_DESC::PersistentResource

◆ PersistentResource [5/8]

D3D12_GPU_VIRTUAL_ADDRESS NV_D3D12_META_COMMAND_INITIALIZE_CONVOLUTION_EX_DESC::PersistentResource

◆ PersistentResource [6/8]

D3D12_GPU_VIRTUAL_ADDRESS NV_D3D12_META_COMMAND_EXECUTE_CONVOLUTION_EX_DESC::PersistentResource

◆ PersistentResource [7/8]

NvU64 NV_D3D12_META_COMMAND_INITIALIZE_GEMM_DESC::PersistentResource

◆ PersistentResource [8/8]

NvU64 NV_D3D12_META_COMMAND_EXECUTE_GEMM_DESC::PersistentResource

◆ pFastGSCBData

NV_SMP_ASSIST_FASTGSCBDATA_V1* _NV_SMP_ASSIST_GET_CONSTANTS_V3::pFastGSCBData

(OUT) If not NULL, this will contain constant buffer data to supply the FastGS for culling primitives per-viewport

◆ pFastGSCBDataMRS_IS

NV_SMP_ASSIST_FASTGSCBDATA_MRS_INSTANCED_STEREO_V1* _NV_SMP_ASSIST_GET_CONSTANTS_V3::pFastGSCBDataMRS_IS

(OUT) If non-NULL and eSMPAssistType is MRS and eEyeIndex is NV_SMP_ASSIST_EYE_INDEX_INSTANCED_STEREO then MRS Instanced stereo FastGS constant buffer data will be populated

◆ pGamma

NVVIOGAMMACORRECTION * pGamma

◆ [] [1/2]

const NVAPI_D3D12_RAYTRACING_GEOMETRY_DESC_EX* { ... } ::pGeometryDescs

If type is D3D12_RAYTRACING_ACCELERATION_STRUCTURE_BOTTOM_LEVEL and descLayout is D3D12_ELEMENTS_LAYOUT_ARRAY, it contains the descriptions of all geometries to be built into a BLAS. Otherwise, this parameter is unused (space repurposed in a union).

◆ pGeometryDescs [2/2]

const NVAPI_D3D12_RAYTRACING_GEOMETRY_DESC_EX* _NVAPI_D3D12_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_INPUTS_EX::pGeometryDescs

If type is D3D12_RAYTRACING_ACCELERATION_STRUCTURE_BOTTOM_LEVEL and descLayout is D3D12_ELEMENTS_LAYOUT_ARRAY, it contains the descriptions of all geometries to be built into a BLAS. Otherwise, this parameter is unused (space repurposed in a union).

◆ phaseOffsetms

NvU16 _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR::phaseOffsetms

Time in ms to offset the cycle relative to other zones.

◆ physicalGpuCount

NvU32 _NV_LOGICAL_GPU_DATA_V1::physicalGpuCount

[out] Number of physical GPU handles associated with the specified logical GPU handle.

◆ physicalGpuHandles

NvPhysicalGpuHandle _NV_LOGICAL_GPU_DATA_V1::physicalGpuHandles[NVAPI_MAX_PHYSICAL_GPUS]

[out] This array will be filled with physical GPU handles associated with the given logical GPU handle. The array index refers to the Physical Gpu Index (Idx). Idx value is the same as D3D11 MultiGPUDevice GPU index, D3D12 node index, OpenGL GL_NV_gpu_multicast GPU index. When converted to a bit mask (1 << Idx), it matches:

Vulkan deviceNodeMask in VkPhysicalDeviceIDProperties

CUDA deviceNodeMask returned by cuDeviceGetLuid

◆ phyType [1/2]

NvU8 NVLINK_LINK_STATUS_INFO_V1::phyType

This field specifies the type of PHY (NVHS or GRS) being used for this link.

◆ phyType [2/2]

NvU8 NVLINK_LINK_STATUS_INFO_V2::phyType

This field specifies the type of PHY (NVHS or GRS) being used for this link.

◆ phyVersion [1/2]

NvU8 NVLINK_LINK_STATUS_INFO_V1::phyVersion

This field specifies the version of PHY being used by the link.

◆ phyVersion [2/2]

NvU8 NVLINK_LINK_STATUS_INFO_V2::phyVersion

This field specifies the version of PHY being used by the link.

◆ picAspectRatio

NvU32 NV_INFOFRAME_VIDEO::picAspectRatio

◆ pIdentifierToCheck

const D3D12_SERIALIZED_DATA_DRIVER_MATCHING_IDENTIFIER* _NVAPI_CHECK_DRIVER_MATCHING_IDENTIFIER_EX_PARAMS_V1::pIdentifierToCheck

[in] Identifier from the header of the serialized data to check with the driver; see D3D12_SERIALIZED_DATA_DRIVER_MATCHING_IDENTIFIER. Information about how to retrieve that identifier can be found in the description of each NVAPI_D3D12_SERIALIZED_DATA_TYPE_EX enum.

◆ [] [1/2]

NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR_COLOR_FIXED { ... } ::piecewiseLinearColorFixed

◆ piecewiseLinearColorFixed [2/2]

NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR_COLOR_FIXED _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_COLOR_FIXED::piecewiseLinearColorFixed

◆ piecewiseLinearData [1/4]

NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR_RGB::piecewiseLinearData

◆ piecewiseLinearData [2/4]

NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR_COLOR_FIXED::piecewiseLinearData

◆ piecewiseLinearData [3/4]

NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR_RGBW::piecewiseLinearData

◆ piecewiseLinearData [4/4]

NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR_SINGLE_COLOR::piecewiseLinearData

◆ [] [1/2]

NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR_RGB { ... } ::piecewiseLinearRGB

◆ piecewiseLinearRGB [2/2]

NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR_RGB _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_RGB::piecewiseLinearRGB

◆ [] [1/2]

NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR_RGBW { ... } ::piecewiseLinearRGBW

◆ piecewiseLinearRGBW [2/2]

NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR_RGBW _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_RGBW::piecewiseLinearRGBW

◆ piecewiseLinearSingleColor [1/2]

NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR_SINGLE_COLOR _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_SINGLE_COLOR::piecewiseLinearSingleColor

◆ [] [2/2]

NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR_SINGLE_COLOR { ... } ::piecewiseLinearSingleColor

◆ pInfo [1/3]

NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PREBUILD_INFO* _NVAPI_GET_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PREBUILD_INFO_PARAMS_V1::pInfo

[out] Result of the query.

◆ pInfo [2/3]

NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_ARRAY_PREBUILD_INFO* _NVAPI_GET_RAYTRACING_OPACITY_MICROMAP_ARRAY_PREBUILD_INFO_PARAMS_V1::pInfo

[out] Result of the query.

◆ pInfo [3/3]

D3D12_RAYTRACING_ACCELERATION_STRUCTURE_PREBUILD_INFO* _NVAPI_GET_RAYTRACING_ACCELERATION_STRUCTURE_PREBUILD_INFO_EX_PARAMS_V1::pInfo

[out] Result of the query.

◆ Pixel_1x2

NV_PIXEL_SRSO_1x2 _NV_PIXEL_SHADING_RATE_SAMPLE_ORDER_TABLE_V1::Pixel_1x2

◆ Pixel_2x1

NV_PIXEL_SRSO_2x1 _NV_PIXEL_SHADING_RATE_SAMPLE_ORDER_TABLE_V1::Pixel_2x1

◆ Pixel_2x2

NV_PIXEL_SRSO_2x2 _NV_PIXEL_SHADING_RATE_SAMPLE_ORDER_TABLE_V1::Pixel_2x2

◆ Pixel_2x4

NV_PIXEL_SRSO_2x4 _NV_PIXEL_SHADING_RATE_SAMPLE_ORDER_TABLE_V1::Pixel_2x4

◆ Pixel_4x2

NV_PIXEL_SRSO_4x2 _NV_PIXEL_SHADING_RATE_SAMPLE_ORDER_TABLE_V1::Pixel_4x2

◆ Pixel_4x4

NV_PIXEL_SRSO_4x4 _NV_PIXEL_SHADING_RATE_SAMPLE_ORDER_TABLE_V1::Pixel_4x4

◆ pixelRepeat

NvU32 NV_INFOFRAME_VIDEO::pixelRepeat

◆ pixelShift

NvU32 _NV_MOSAIC_GRID_TOPO_V2::pixelShift

Enable Pixel shift.

◆ pixelShiftType

NV_PIXEL_SHIFT_TYPE _NV_MOSAIC_GRID_TOPO_DISPLAY_V2::pixelShiftType

Type of the pixel shift enabled display.

◆ pNodeMask

__inout NvU32* _NV_D3D12_MOSAIC_GETVIEWPORTANDGPUPARTITIONS::pNodeMask

An optional array to hold the GPU mask where this viewport must be valid per partition. When this is valid pViewport must also be valid.

◆ polarity [1/2]

NVAPI_GSYNC_POLARITY _NV_GSYNC_CONTROL_PARAMS_V1::polarity

Leading edge / Falling edge / both.

◆ polarity [2/2]

NVAPI_GSYNC_POLARITY _NV_GSYNC_CONTROL_PARAMS_V2::polarity

Leading edge / Falling edge / both.

◆ pOMMUsageCounts [1/2]

const NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_USAGE_COUNT* _NVAPI_D3D12_BUILD_RAYTRACING_OPACITY_MICROMAP_ARRAY_INPUTS::pOMMUsageCounts

Usage counts for each subdivision level and format combination across all the OMM entries in the build.

◆ pOMMUsageCounts [2/2]

const NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_USAGE_COUNT* _NVAPI_D3D12_RAYTRACING_GEOMETRY_OMM_ATTACHMENT_DESC::pOMMUsageCounts

Usage counts for each subdivision level and format combination across all the OMM entries referred-to by the OMM index buffer specified by this geometry.

◆ PoolMode

NV_META_COMMAND_CONVOLUTION_POOL_MODE NV_META_COMMAND_CONVOLUTION_FUSE_DESC::PoolMode

◆ portId

NvU8 NV_I2C_INFO_V3::portId

The portid on which device is connected (remember to set bIsPortIdSet if this value is set) Optional for pre-Kepler

◆ pOSAdapterID

void* _NV_DISPLAYCONFIG_PATH_INFO_V2::pOSAdapterID

Used by Non-NVIDIA adapter for pointer to OS Adapter of LUID type, type casted to void *.

◆ pOSAdapterId

void* _NV_LOGICAL_GPU_DATA_V1::pOSAdapterId

[out] Returns OS-AdapterId. User must send memory buffer of size atleast equal to the size of LUID structure before calling the NVAPI.

◆ position

NV_POSITION _NV_DISPLAYCONFIG_SOURCE_MODE_INFO_V1::position

Is all positions are 0 or invalid, displays will be automatically positioned from left to right with GDI Primary at 0,0, and all other displays in the order of the path array.

◆ positionX

NvS32 _NV_MANAGED_DEDICATED_DISPLAY_METADATA::positionX

[in][out] Metadata for the virtual horizontal position for the display connector specified by displayId.

◆ positionY

NvS32 _NV_MANAGED_DEDICATED_DISPLAY_METADATA::positionY

[in][out] Metadata for the virtual vertical position for the display connector specified by displayId.

◆ PostZCoverage

BOOL _NV_D3D11_FEATURE_DATA_RASTERIZER_SUPPORT::PostZCoverage

◆ PostZCoverageEnable [1/2]

bool NvAPI_D3D11_RASTERIZER_DESC_EX::PostZCoverageEnable

◆ PostZCoverageEnable [2/2]

bool NVAPI_D3D12_PSO_RASTERIZER_STATE_DESC_V1::PostZCoverageEnable

◆ posx

NvU32 NV_DISPLAY_PATH::posx

(IN/OUT) X-offset of this display on the Windows desktop

◆ posy

NvU32 NV_DISPLAY_PATH::posy

(IN/OUT) Y-offset of this display on the Windows desktop

◆ pParams [1/2]

void const* _NVAPI_CU_KERNEL_LAUNCH_PARAMS::pParams

◆ pParams [2/2]

void const* _NVAPI_CU_KERNEL_LAUNCH_PARAMS_EX::pParams

◆ pPartitionCount

__inout NvU32* _NV_D3D12_MOSAIC_GETVIEWPORTANDGPUPARTITIONS::pPartitionCount

A variable to receive the number of NV_MGPU_MOSAIC_DISPLAY_SURFACE_PARTITION elements returned or that holds the size of pPartitions when it is non-NULL.

◆ ppBufferDesc

D3D11_BUFFER_DESC** _NV_D3D_LATELATCH_OBJECT_DESC_V1::ppBufferDesc

◆ ppCompanionResources

__inout ID3D12Resource** _NV_D3D12_MOSAIC_GETCOMPANIONALLOCATIONS::ppCompanionResources

An array of ID3D12Resource pointers sized to match companionBufferCount, which will receive the companion allocations.

◆ ppD3DLateLatchObject

ID3DLateLatchObject** _NV_D3D_LATELATCH_OBJECT_DESC_V1::ppD3DLateLatchObject

◆ ppD3DNvSMPAssist

ID3DNvSMPAssist** _NV_SMP_ASSIST_INITIALIZE_PARAMS_V1::ppD3DNvSMPAssist

(OUT) Interface pointer returned by the Init call. Use for future Enable/Disable etc. calls

◆ ppGeometryDescs [1/2]

const NVAPI_D3D12_RAYTRACING_GEOMETRY_DESC_EX* const* _NVAPI_D3D12_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_INPUTS_EX::ppGeometryDescs

If type is D3D12_RAYTRACING_ACCELERATION_STRUCTURE_BOTTOM_LEVEL and descLayout is D3D12_ELEMENTS_LAYOUT_ARRAY_OF_POINTERS, it contains the addresses of descriptions for all geometries to be built into a BLAS. Otherwise, this parameter is unused (space repurposed in a union).

◆ [] [2/2]

const NVAPI_D3D12_RAYTRACING_GEOMETRY_DESC_EX* const* { ... } ::ppGeometryDescs

If type is D3D12_RAYTRACING_ACCELERATION_STRUCTURE_BOTTOM_LEVEL and descLayout is D3D12_ELEMENTS_LAYOUT_ARRAY_OF_POINTERS, it contains the addresses of descriptions for all geometries to be built into a BLAS. Otherwise, this parameter is unused (space repurposed in a union).

◆ ppNvGazeHandler [1/2]

ID3DNvGazeHandler_V2** _NV_GAZE_HANDLER_INIT_PARAMS_V2::ppNvGazeHandler

(OUT) Interface for Gaze Data Handler

◆ ppNvGazeHandler [2/2]

ID3DNvGazeHandler_V1** _NV_GAZE_HANDLER_INIT_PARAMS_V1::ppNvGazeHandler

(OUT) Interface for Gaze Data Handler

◆ pPostbuildInfoDescs [1/3]

const NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_ARRAY_POSTBUILD_INFO_DESC* _NVAPI_BUILD_RAYTRACING_OPACITY_MICROMAP_ARRAY_PARAMS_V1::pPostbuildInfoDescs

[in] Optional array of descriptions for postbuild info to generate describing properties of the acceleration structure that was built. [in] Any given postbuild info type, D3D12_RAYTRACING_ACCEELRATION_STRUCTURE_POSTBUILD_INFO_TYPE, can only be selected for output by at most one array entry.

◆ pPostbuildInfoDescs [2/3]

const NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_POSTBUILD_INFO_DESC* _NVAPI_BUILD_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PARAMS_V1::pPostbuildInfoDescs

[in] Optional array of descriptions for postbuild info to generate describing properties of the acceleration structure that was built. [in] Any given postbuild info type, D3D12_RAYTRACING_ACCEELRATION_STRUCTURE_POSTBUILD_INFO_TYPE, can only be selected for output by at most one array entry.

◆ pPostbuildInfoDescs [3/3]

const D3D12_RAYTRACING_ACCELERATION_STRUCTURE_POSTBUILD_INFO_DESC* _NVAPI_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_EX_PARAMS_V1::pPostbuildInfoDescs

[in] Optional array of descriptions for postbuild info to generate describing properties of the acceleration structure that was built. Any given postbuild info type, D3D12_RAYTRACING_ACCEELRATION_STRUCTURE_POSTBUILD_INFO_TYPE, can only be selected for output by at most one array entry.

◆ ppShadingRateResource

IUnknown** _NV_VRS_HELPER_GET_SHADING_RATE_RESOURCE_PARAMS_V1::ppShadingRateResource

(OUT) Pointer to 2D Texture resource with currently applied shading rate pattern

◆ ppVRSHelper

ID3DNvVRSHelper_V1** _NV_VRS_HELPER_INIT_PARAMS_V1::ppVRSHelper

(OUT) Interface for Shading Rate Pattern Tracker

◆ Precision [1/2]

NvU64 NV_META_COMMAND_CREATE_CONVOLUTION_EX_DESC::Precision

◆ Precision [2/2]

NvU64 NV_META_COMMAND_CREATE_GEMM_DESC::Precision

◆ pRects

NV_D3D11_EXCLUSIVE_SCISSOR_RECT_DESC_V1* _NV_D3D11_EXCLUSIVE_SCISSOR_RECTS_DESC_V1::pRects

(IN) Array of NV_D3D11_EXCLUSIVE_SCISSOR_RECT_DESC with number of elements equal to Exclusive Scissor Rects

◆ pRemapCBData

NV_SMP_ASSIST_REMAPCBDATA_V1* _NV_SMP_ASSIST_GET_CONSTANTS_V3::pRemapCBData

(OUT) If not NULL, this will contain constant buffer data to supply the UV-remapping helper functions

◆ PresentCount

NvU32 _NV_PRESENT_BARRIER_FRAME_STATISTICS::PresentCount

The total count of times that a frame has been presented from this client after it joined presentBarrier successfully.

◆ presentEndTime

NvU64 _NV_LATENCY_RESULT_PARAMS::FrameReport::presentEndTime

◆ presentFrameID

NvU64 _NV_ASYNC_FRAME_MARKER_PARAMS_V1::presentFrameID

◆ PresentInSyncCount

NvU32 _NV_PRESENT_BARRIER_FRAME_STATISTICS::PresentInSyncCount

The total count of times that a frame has been presented from this client and that has happened since the returned SyncMode is PRESENT_BARRIER_SYNC_SYSTEM or PRESENT_BARRIER_SYNC_CLUSTER. If the returned SyncMode is any other mode, this value is 0. This count is set back to 0 in case the SyncMode switches away from PRESENT_BARRIER_SYNC_SYSTEM or PRESENT_BARRIER_SYNC_CLUSTER.

◆ presentStartTime

NvU64 _NV_LATENCY_RESULT_PARAMS::FrameReport::presentStartTime

◆ primary

NvU32 _NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_V1::primary

(IN) Declares primary display in clone configuration. This is NOT GDI Primary. Only one target can be primary per source. If no primary is specified, the first target will automatically be primary.

◆ productName [1/3]

NvAPI_LicenseString _NV_LICENSE_FEATURE_DETAILS_V2::productName

Nvidia Grid licensable product name.

◆ productName [2/3]

NvAPI_LicenseString _NV_LICENSE_FEATURE_DETAILS_V3::productName

Nvidia Grid licensable product name.

◆ productName [3/3]

NvAPI_LicenseString _NV_LICENSE_FEATURE_DETAILS_V4::productName

Nvidia Grid licensable product name.

◆ profileName

NvAPI_UnicodeString _NVDRS_PROFILE_V1::profileName

String name of the Profile.

◆ ProgrammableSamplePositions

BOOL _NV_D3D11_FEATURE_DATA_RASTERIZER_SUPPORT::ProgrammableSamplePositions

◆ ProgrammableSamplePositionsEnable [1/2]

bool NvAPI_D3D11_RASTERIZER_DESC_EX::ProgrammableSamplePositionsEnable

◆ ProgrammableSamplePositionsEnable [2/2]

bool NVAPI_D3D12_PSO_RASTERIZER_STATE_DESC_V1::ProgrammableSamplePositionsEnable

◆ projectionSizeHeight

float _NV_SMP_ASSIST_GET_CONSTANTS_V3::projectionSizeHeight

(OUT)

◆ projectionSizeWidth

float _NV_SMP_ASSIST_GET_CONSTANTS_V3::projectionSizeWidth

(OUT) MRS/LMS projection size

◆ property [1/2]

NV_INFOFRAME_PROPERTY NV_INFOFRAME_DATA::property

This is NVIDIA-specific and corresponds to the property cmds and associated infoframe.

◆ [] [2/2]

NV_INFOFRAME_PROPERTY { ... } ::property

This is NVIDIA-specific and corresponds to the property cmds and associated infoframe.

◆ provIdx

NvU8 _NV_GPU_CLIENT_ILLUM_ZONE_INFO_V1::provIdx

Provider index for representing logical to physical zone mapping.

◆ pScissors [1/2]

D3D11_RECT* _NV_CUSTOM_RECTS_V1::pScissors[NV_SMP_ASSIST_MINIMAL_LEVEL_NUM_EYE_INDICES]

(IN) Scissors, for each eye index, that should be set when app calls Enable(eyeIndex)

◆ pScissors [2/2]

D3D11_RECT* _NV_SMP_ASSIST_GET_CONSTANTS_V3::pScissors

(OUT) If not NULL, this will contain the scissors computed by the driver based on init params

◆ psfSignalFormat [1/3]

NvU32 _NVVIOOUTPUTCONFIG_V1::psfSignalFormat

Indicates whether contained format is PSF Signal format.

◆ psfSignalFormat [2/3]

NvU32 _NVVIOOUTPUTCONFIG_V2::psfSignalFormat

Indicates whether contained format is PSF Signal format.

◆ psfSignalFormat [3/3]

NvU32 _NVVIOOUTPUTCONFIG_V3::psfSignalFormat

Indicates whether contained format is PSF Signal format.

◆ pShaderName

const char* NVAPI_D3D12_CREATE_CUBIN_SHADER_PARAMS::pShaderName

[in] pointer to shader name, acts as identifier for SLI special handling, doesn't need to be accurate

◆ pSignalFormatDetail

NvU32 NVVIOSIGNALFORMATDETAIL* pSignalFormatDetail

◆ psoExtension

NV_PSO_EXTENSION NVAPI_D3D12_PSO_EXTENSION_DESC_V1::psoExtension

◆ pSources [1/2]

const D3D12_GPU_VIRTUAL_ADDRESS* _NVAPI_EMIT_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_POSTBUILD_INFO_PARAMS_V1::pSources

[in] List of DMM Arrays for which postbuild info should be emitted.

◆ pSources [2/2]

const D3D12_GPU_VIRTUAL_ADDRESS* _NVAPI_EMIT_RAYTRACING_OPACITY_MICROMAP_ARRAY_POSTBUILD_INFO_PARAMS_V1::pSources

[in] List of OMM Arrays for which postbuild info should be emitted.

◆ [] [1/8]

NV_GPU_PERF_PSTATE_ID { ... } ::pstateId

ID of the P-State.

◆ pstateId [2/8]

NV_GPU_PERF_PSTATE_ID NV_GPU_PERF_PSTATES20_INFO_V1::pstateId

ID of the P-State.

◆ [] [3/8]

NV_GPU_PERF_PSTATE_ID { ... } ::pstateId

ID of the P-State.

◆ pstateId [4/8]

NV_GPU_PERF_PSTATE_ID _NV_GPU_PERF_PSTATES20_INFO_V2::pstateId

ID of the P-State.

◆ pstateId [5/8]

NV_GPU_PERF_PSTATE_ID NV_GPU_PERF_PSTATES_INFO_V1::pstateId

ID of the p-state.

◆ [] [6/8]

NV_GPU_PERF_PSTATE_ID { ... } ::pstateId

ID of the p-state.

◆ [] [7/8]

NV_GPU_PERF_PSTATE_ID { ... } ::pstateId

ID of the p-state.

◆ pstateId [8/8]

NV_GPU_PERF_PSTATE_ID NV_GPU_PERF_PSTATES_INFO_V2::pstateId

ID of the p-state.

◆ [struct] [1/4]

struct { ... } NV_GPU_PERF_PSTATES_INFO_V1::pstates[NVAPI_MAX_GPU_PERF_PSTATES]

◆ [struct] [2/4]

struct { ... } NV_GPU_PERF_PSTATES_INFO_V2::pstates[NVAPI_MAX_GPU_PERF_PSTATES]

Valid index range is 0 to numVoltages-1.

◆ [struct] [3/4]

struct { ... } NV_GPU_PERF_PSTATES20_INFO_V1::pstates[NVAPI_MAX_GPU_PSTATE20_PSTATES]

Performance state (P-State) settings Valid index range is 0 to numPstates-1

◆ [struct] [4/4]

struct { ... } _NV_GPU_PERF_PSTATES20_INFO_V2::pstates[NVAPI_MAX_GPU_PSTATE20_PSTATES]

Performance state (P-State) settings Valid index range is 0 to numPstates-1

◆ pSwapChainBuffer [1/2]

__in ID3D12Resource* _NV_D3D12_MOSAIC_GETCOMPANIONALLOCATIONS::pSwapChainBuffer

The ID3D12Resource part of the application swap chain that has companion allocations.

◆ pSwapChainBuffer [2/2]

__in ID3D12Resource* _NV_D3D12_MOSAIC_GETVIEWPORTANDGPUPARTITIONS::pSwapChainBuffer

The ID3D12Resource part of the application swap chain.

◆ pSyncDelay

NVVIOSYNCDELAY * pSyncDelay

◆ pViewport

__inout RECT* _NV_D3D12_MOSAIC_GETVIEWPORTANDGPUPARTITIONS::pViewport

An optional array to hold the viewport information per partition. When this is valid pNodeMask must also be valid.

◆ pViewports [1/3]

NV_D3D11_VIEWPORT_SHADING_RATE_DESC_V1* _NV_D3D11_VIEWPORTS_SHADING_RATE_DESC_V1::pViewports

(IN) Array of NV_D3D11_VIEWPORT_SHADING_RATE_DESC with number of elements equal to NumViewports

◆ pViewports [2/3]

D3D11_VIEWPORT* _NV_CUSTOM_RECTS_V1::pViewports[NV_SMP_ASSIST_MINIMAL_LEVEL_NUM_EYE_INDICES]

(IN) Viewports, for each eye index, that should be set when app calls Enable(eyeIndex)

◆ pViewports [3/3]

D3D11_VIEWPORT* _NV_SMP_ASSIST_GET_CONSTANTS_V3::pViewports

(OUT) If not NULL, this will contain the viewports computed by driver based on init params

◆ pVioPCIInfo

__inout NVVIOPCIINFO* pVioPCIInfo

◆ pWait

NvU32* pWait

◆ qsyncEvent

NV_QSYNC_EVENT NV_QSYNC_EVENT_DATA::qsyncEvent

◆ QuadFillMode [1/2]

NVAPI_QUAD_FILLMODE NvAPI_D3D11_RASTERIZER_DESC_EX::QuadFillMode

◆ QuadFillMode [2/2]

NVAPI_QUAD_FILLMODE NVAPI_D3D12_PSO_RASTERIZER_STATE_DESC_V1::QuadFillMode

◆ quadro

NvU32 _NVDRS_GPU_SUPPORT::quadro

◆ quantizationRangeRgb

NvU8 _NV_MONITOR_CAPS_VCDB::quantizationRangeRgb

◆ quantizationRangeYcc

NvU8 _NV_MONITOR_CAPS_VCDB::quantizationRangeYcc

◆ [struct] [1/2]

struct { ... } NV_GPU_PSTATE20_CLOCK_ENTRY_V1::range

◆ [struct] [2/2]

struct { ... } NV_GPU_PSTATE20_CLOCK_ENTRY_V1::range

◆ rayTracingCores

NvU32 _NV_GPU_INFO_V2::rayTracingCores

Number of "Ray Tracing Cores" supported by the GPU.

◆ rdmaHeapSize

NvU64 _NV_D3D12_WORKSTATION_FEATURE_RDMA_PROPERTIES::rdmaHeapSize

◆ rdmaInfo [1/2]

NV_D3D12_WORKSTATION_FEATURE_RDMA_PROPERTIES _NV_D3D12_WORKSTATION_FEATURE_PROPERTIES::rdmaInfo

(OUT) RDMA feature related information, returned only if workstationFeatureType is NV_D3D12_WORKSTATION_FEATURE_TYPE_RDMA_BAR1_SUPPORT

◆ [] [2/2]

NV_D3D12_WORKSTATION_FEATURE_RDMA_PROPERTIES { ... } ::rdmaInfo

(OUT) RDMA feature related information, returned only if workstationFeatureType is NV_D3D12_WORKSTATION_FEATURE_TYPE_RDMA_BAR1_SUPPORT

◆ RefreshCount

NvU32 _NV_PRESENT_BARRIER_FRAME_STATISTICS::RefreshCount

The total count of v-blanks since the returned SyncMode of this client is PRESENT_BARRIER_SYNC_SYSTEM or PRESENT_BARRIER_SYNC_CLUSTER. If the returned SyncMode is any other mode, this value is 0. This count is set back to 0 in case the SyncMode switches away from PRESENT_BARRIER_SYNC_SYSTEM or PRESENT_BARRIER_SYNC_CLUSTER.

◆ refreshRate [1/3]

NvU32 NV_DISPLAY_PATH::refreshRate

(IN) Refresh rate of the mode

◆ refreshRate [2/3]

NvU32 _NV_GSYNC_STATUS_PARAMS_V1::refreshRate

The refresh rate.

◆ refreshRate [3/3]

NvU32 _NV_GSYNC_STATUS_PARAMS_V2::refreshRate

The refresh rate.

◆ refreshRate1K

NvU32 _NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_V1::refreshRate1K

(IN) Non-interlaced Refresh Rate of the mode, multiplied by 1000, 0 = ignored This is the value which driver reports to the OS.

◆ regAddrSize [1/3]

NvU32 NV_I2C_INFO_V1::regAddrSize

The size in bytes of target register address. If pbI2cRegAddress is NULL, this field must be 0.

◆ regAddrSize [2/3]

NvU32 NV_I2C_INFO_V2::regAddrSize

The size in bytes of target register address. If pbI2cRegAddress is NULL, this field must be 0.

◆ regAddrSize [3/3]

NvU32 NV_I2C_INFO_V3::regAddrSize

The size in bytes of target register address. If pbI2cRegAddress is NULL, this field must be 0.

◆ RegisterMask

NvU32 _NV_CUSTOM_SEMANTIC::RegisterMask

◆ RegisterNum

NvU32 _NV_CUSTOM_SEMANTIC::RegisterNum

◆ registerSpace

NvU32 NVAPI_D3D12_PSO_SET_SHADER_EXTENSION_SLOT_DESC_V1::registerSpace

◆ RegisterSpecified

BOOL _NV_CUSTOM_SEMANTIC::RegisterSpecified

◆ relativeSizeDown

float _NV_LMS_CUSTOM_CONFIG_V1::relativeSizeDown

(IN) LMS params to control the height of the 2 lower quandrants relative to the bounding box height

◆ relativeSizeLeft

float _NV_LMS_CUSTOM_CONFIG_V1::relativeSizeLeft

(IN) LMS params to control the width of the 2 left quandrants relative to the bounding box width

◆ relativeSizeRight

float _NV_LMS_CUSTOM_CONFIG_V1::relativeSizeRight

(IN) LMS params to control the width of the 2 right quandrants relative to the bounding box width

◆ relativeSizeUp

float _NV_LMS_CUSTOM_CONFIG_V1::relativeSizeUp

(IN) LMS params to control the height of the 2 upper quandrants relative to the bounding box height

◆ remoteDeviceInfo [1/2]

NVLINK_DEVICE_INFO_V1 NVLINK_LINK_STATUS_INFO_V1::remoteDeviceInfo

This field stores the GPU information for the remote end of the link.

◆ remoteDeviceInfo [2/2]

NVLINK_DEVICE_INFO_V1 NVLINK_LINK_STATUS_INFO_V2::remoteDeviceInfo

This field stores the device information for the remote end of the link.

◆ remoteDeviceLinkNumber [1/2]

NvU8 NVLINK_LINK_STATUS_INFO_V1::remoteDeviceLinkNumber

This field specifies the link number on the remote end of the link.

◆ remoteDeviceLinkNumber [2/2]

NvU8 NVLINK_LINK_STATUS_INFO_V2::remoteDeviceLinkNumber

This field specifies the link number on the remote end of the link.

◆ RenderMode

NV_VRS_RENDER_MODE _NV_VRS_HELPER_ENABLE_PARAMS_V1::RenderMode

(IN) This defines whether subsequent render calls are for mono/stereo

◆ renderSubmitEndTime

NvU64 _NV_LATENCY_RESULT_PARAMS::FrameReport::renderSubmitEndTime

◆ renderSubmitStartTime

NvU64 _NV_LATENCY_RESULT_PARAMS::FrameReport::renderSubmitStartTime

◆ renderTargetIndexOffset

NvU32 _NV_MULTIVIEW_PARAMS_V1::renderTargetIndexOffset[NV_MULTIVIEW_MAX_SUPPORTED_VIEWS]

◆ rep

NvU16 tagNV_TIMINGEXT::rep

Bit-wise pixel repetition factor: 0x1:no pixel repetition; 0x2:each pixel repeats twice horizontally,..

◆ reserved [1/82]

NvU32 _NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_V1::reserved

◆ reserved [2/82]

NvU32 _NV_DISPLAYCONFIG_SOURCE_MODE_INFO_V1::reserved

Must be 0.

◆ reserved [3/82]

NvU32 _NV_DISPLAYCONFIG_PATH_INFO_V2::reserved

Must be 0.

◆ reserved [4/82]

NvU32 NV_GPU_PSTATE20_CLOCK_ENTRY_V1::reserved

These bits are reserved for future use (must be always 0)

◆ reserved [5/82]

NvU32 NV_GPU_PSTATE20_BASE_VOLTAGE_ENTRY_V1::reserved

These bits are reserved for future use (must be always 0)

◆ reserved [6/82]

NvU32 NV_GPU_PERF_PSTATES20_INFO_V1::reserved

These bits are reserved for future use (must be always 0)

◆ [] [7/82]

NvU32 { ... } ::reserved

These bits are reserved for future use (must be always 0)

◆ reserved [8/82]

NvU32 _NV_GPU_PERF_PSTATES20_INFO_V2::reserved

These bits are reserved for future use (must be always 0)

◆ [] [9/82]

NvU32 { ... } ::reserved

These bits are reserved for future use (must be always 0)

◆ reserved [10/82]

NvU32 _NV_GPU_DISPLAYIDS::reserved

must be zero

◆ reserved [11/82]

NvU32 _NV_GPU_VIRTUALIZATION_INFO::reserved

reserved for future use. Should be set to ZERO.

◆ reserved [12/82]

NvU32 _NV_LICENSE_FEATURE_DETAILS_V1::reserved

Reserved.

◆ reserved [13/82]

NvU32 _NV_LICENSE_FEATURE_DETAILS_V2::reserved

Reserved.

◆ reserved [14/82]

NvU32 _NV_LICENSE_FEATURE_DETAILS_V3::reserved

Reserved.

◆ reserved [15/82]

NvU32 _NV_LICENSE_FEATURE_DETAILS_V4::reserved

Reserved.

◆ reserved [16/82]

NvU32 _NV_LICENSABLE_FEATURES_V1::reserved

Reserved.

◆ reserved [17/82]

NvU32 _NV_LICENSABLE_FEATURES_V2::reserved

Reserved.

◆ reserved [18/82]

NvU32 _NV_LICENSABLE_FEATURES_V3::reserved

Reserved.

◆ reserved [19/82]

NvU32 _NV_LICENSABLE_FEATURES_V4::reserved

Reserved.

◆ reserved [20/82]

NvU32 NVLINK_LINK_STATUS_INFO_V1::reserved

Reserved for future use.

◆ reserved [21/82]

NvU32 NVLINK_LINK_STATUS_INFO_V2::reserved

Reserved for future use.

◆ reserved [22/82]

NvU32 _NV_GPU_INFO_V1::reserved

Reserved for future use.

◆ reserved [23/82]

NvU32 _NV_GPU_VR_READY_V1::reserved

◆ reserved [24/82]

NvU32 _NV_GPU_GSP_INFO_V1::reserved

Reserved for future use.

◆ reserved [25/82]

NvU32 NV_GPU_CLOCK_FREQUENCIES_V1::reserved

These bits are reserved for future use.

◆ [] [26/82]

NvU32 { ... } ::reserved

These bits are reserved for future use.

◆ reserved [27/82]

NvU32 NV_GPU_CLOCK_FREQUENCIES_V2::reserved

These bits are reserved for future use. Must be set to 0.

These bits are reserved for future use.

◆ [] [28/82]

NvU32 { ... } ::reserved

These bits are reserved for future use.

◆ reserved [29/82]

NvU32 _NV_DISPLAY_PORT_INFO_V1::reserved

reserved

◆ reserved [30/82]

NvU32 _NV_HDMI_SUPPORT_INFO_V1::reserved

Reserved.

◆ reserved [31/82]

NvU32 _NV_HDMI_SUPPORT_INFO_V2::reserved

Reserved.

◆ reserved [32/82]

NvU32 NV_INFOFRAME_PROPERTY::reserved

◆ reserved [33/82]

NvU32 _NV_HDR_CAPABILITIES_V1::reserved

◆ reserved [34/82]

NvU32 _NV_HDR_CAPABILITIES_V2::reserved

Should be set to zero All values below are encoded use DolbyVisionHDMITransmissionSpecification document to decode

◆ [] [35/82]

NvU32 { ... } ::reserved

Should be set to zero All values below are encoded use DolbyVisionHDMITransmissionSpecification document to decode

◆ reserved [36/82]

NvU32 _NV_HDR_CAPABILITIES_V3::reserved

Should be set to zero.

All values below are encoded use DolbyVisionHDMITransmissionSpecification document to decode

◆ [] [37/82]

NvU32 { ... } ::reserved

Should be set to zero.

All values below are encoded use DolbyVisionHDMITransmissionSpecification document to decode

◆ reserved [38/82]

NvU16 _NV_HDR_CAPABILITIES_V3::reserved

◆ [] [39/82]

NvU16 { ... } ::reserved

◆ reserved [40/82]

NvU8 _NV_MONITOR_CAPS_GENERIC::reserved

◆ reserved [41/82]

NvU32 _NV_GET_ADAPTIVE_SYNC_DATA_V1::reserved

reserved for future use.

◆ reserved [42/82]

NvU32 _NV_SET_ADAPTIVE_SYNC_DATA_V1::reserved

reserved for future use.

◆ reserved [43/82]

NvU32 NV_SET_PREFERRED_STEREO_DISPLAY_V1::reserved

Reserved for future use without adding versioning.

◆ reserved [44/82]

NvU32 NV_GET_PREFERRED_STEREO_DISPLAY_V1::reserved

Reserved for future use without adding versioning.

◆ reserved [45/82]

NvU32 _NV_MANAGED_DEDICATED_DISPLAY_INFO::reserved

[out] Reserved for future use without adding versioning.

◆ reserved [46/82]

NvU32 _NV_MANAGED_DEDICATED_DISPLAY_METADATA::reserved

[in][out] Reserved for future use without adding versioning.

◆ reserved [47/82]

NvU32 _NV_GET_VRR_INFO_V1::reserved

Reserved for future use.

◆ reserved [48/82]

NvU32 _NV_MOSAIC_GRID_TOPO_V1::reserved

Reserved, must be 0.

◆ reserved [49/82]

NvU32 _NV_MOSAIC_GRID_TOPO_V2::reserved

Reserved, must be 0.

◆ [] [50/82]

NvU32 { ... } ::reserved

(OUT) reserved

◆ reserved [51/82]

NvU32 NV_MOSAIC_DISPLAY_TOPO_STATUS::reserved

(OUT) reserved

◆ reserved [52/82]

NvU32 _NV_GSYNC_CAPABILITIES_V3::reserved

Reserved for future use.

◆ reserved [53/82]

NvU32 _NV_GSYNC_GPU::reserved

Should be set to ZERO.

◆ reserved [54/82]

NvU32 _NV_GSYNC_DISPLAY::reserved

Should be set to ZERO.

◆ reserved [55/82]

NvU32 _NV_GSYNC_CONTROL_PARAMS_V1::reserved

should be set zero

◆ reserved [56/82]

NvU32 _NV_GSYNC_CONTROL_PARAMS_V2::reserved

should be set zero

◆ reserved [57/82]

NvU32 _NV_GSYNC_STATUS_PARAMS_V2::reserved

Reserved for future use.

◆ Reserved [1/2]

NvU32 _NV_CUSTOM_SEMANTIC::Reserved

◆ reserved [58/82]

NvU32 NvAPI_D3D11_CREATE_PIXEL_SHADER_EX_V2::reserved

◆ reserved [59/82]

NvU32 _NV_MULTIGPU_CAPS_V1::reserved

◆ [] [60/82]

NvU32 { ... } ::reserved

◆ reserved [61/82]

NvU32 _NV_MULTIGPU_CAPS_V2::reserved

◆ reserved [62/82]

NvU32 _NV_QUERY_SINGLE_PASS_STEREO_SUPPORT_PARAMS_V2::reserved

◆ reserved [63/82]

NvU32 _NV_QUERY_MULTIVIEW_SUPPORT_PARAMS_V1::reserved

◆ reserved [64/82]

NvU32 _NV_D3D1x_GRAPHICS_CAPS_V2::reserved[14]

◆ reserved [65/82]

NvU32 _NV_VRS_HELPER_DISABLE_PARAMS_V1::reserved

(IN) Reserved for future use

◆ reserved [66/82]

NvU32 _NV_VRS_HELPER_PURGE_INTERNAL_RESOURCES_PARAMS_V1::reserved

(IN) Reserved for future use

◆ Reserved [2/2]

NvU32 _NV_SMP_ASSIST_DISABLE_PARAMS_V1::Reserved

(IN) Unused.

◆ reserved [67/82]

NvU32 _NVAPI_STEREO_CAPS::reserved

◆ reserved [68/82]

NvU32 _NVDRS_APPLICATION_V3::reserved

Reserved. Should be 0.

◆ reserved [69/82]

NvU32 _NVDRS_APPLICATION_V4::reserved

Reserved. Should be 0.

◆ reserved [70/82]

NvU32 _NV_DISPLAY_DRIVER_INFO::reserved

Reserved for future use.

◆ reserved [71/82]

NvU32 _NV_DISPLAY_DRIVER_INFO_V2::reserved

Reserved for future use.

◆ reserved [72/82]

NvU32 _NV_PHYSICAL_GPUS::reserved[4]

◆ reserved [73/82]

NvU32 _NV_LOGICAL_GPU_HANDLE_DATA::reserved[4]

◆ reserved [74/82]

NvU32 _NV_LOGICAL_GPUS::reserved[4]

◆ reserved [75/82]

NvU8 NVAPI_D3D12_PSO_RASTERIZER_STATE_DESC_V1::reserved[62]

◆ reserved [76/82]

NvU8 NvAPI_D3D11_RASTERIZER_DESC_EX::reserved[63]

◆ reserved [77/82]

NvU32 _NV_D3D12_GRAPHICS_CAPS_V1::reserved[6]

◆ reserved [78/82]

NvU32 NV_QSYNC_EVENT_DATA::reserved[7]

◆ reserved [79/82]

NvU32 _NV_D3D1x_GRAPHICS_CAPS_V1::reserved[7]

◆ reserved [80/82]

NvU32 _NV_LOGICAL_GPU_DATA_V1::reserved[8]

Reserved for future use. Should be set to ZERO.

◆ reserved [81/82]

NvU32 _NV_EDID_DATA_V2::reserved[8]

Reserved for future use.

◆ reserved [82/82]

NvU32 _NV_MODIFIED_W_PARAMS::reserved[NV_MODIFIED_W_MAX_VIEWPORTS]

◆ reserved0 [1/2]

NvU32 _NV_GPU_INFO_V2::reserved0

Reserved for future use.

◆ reserved0 [2/2]

NvU32 NV_TIMING_FLAG::reserved0

◆ reserved1 [1/2]

NvU64 _NV_GPU_INFO_V2::reserved1

Reserved for future use.

◆ reserved1 [2/2]

NvU32 NV_GPU_CLOCK_FREQUENCIES_V2::reserved1

These bits are reserved.

◆ reserved10

NvU32 _NVDRS_GPU_SUPPORT::reserved10

◆ reserved11

NvU32 _NVDRS_GPU_SUPPORT::reserved11

◆ reserved12

NvU32 _NVDRS_GPU_SUPPORT::reserved12

◆ reserved13 [1/2]

NvU8 _NV_MONITOR_CAPS_VSDB::reserved13

Byte 10.

◆ reserved13 [2/2]

NvU32 _NVDRS_GPU_SUPPORT::reserved13

◆ reserved14

NvU32 _NVDRS_GPU_SUPPORT::reserved14

◆ reserved15

NvU32 _NVDRS_GPU_SUPPORT::reserved15

◆ reserved16

NvU32 _NVDRS_GPU_SUPPORT::reserved16

◆ reserved17

NvU32 _NVDRS_GPU_SUPPORT::reserved17

◆ reserved18

NvU32 _NVDRS_GPU_SUPPORT::reserved18

◆ reserved19

NvU32 _NVDRS_GPU_SUPPORT::reserved19

◆ reserved2 [1/3]

NvU32 _NV_GPU_INFO_V2::reserved2[14]

Reserved for future use.

◆ reserved2 [2/3]

NvU32 _NVAPI_STEREO_CAPS::reserved2[3]

◆ reserved2 [3/3]

NvU32 _NV_PHYSICAL_GPU_HANDLE_DATA::reserved2[4]

◆ reserved20

NvU32 _NVDRS_GPU_SUPPORT::reserved20

◆ reserved21

NvU32 _NVDRS_GPU_SUPPORT::reserved21

◆ reserved22

NvU32 _NVDRS_GPU_SUPPORT::reserved22

◆ reserved23

NvU32 _NVDRS_GPU_SUPPORT::reserved23

◆ reserved24

NvU32 _NVDRS_GPU_SUPPORT::reserved24

◆ reserved25

NvU32 _NVDRS_GPU_SUPPORT::reserved25

◆ reserved26

NvU32 _NVDRS_GPU_SUPPORT::reserved26

◆ reserved27

NvU32 _NVDRS_GPU_SUPPORT::reserved27

◆ reserved28

NvU32 _NVDRS_GPU_SUPPORT::reserved28

◆ reserved29

NvU32 _NVDRS_GPU_SUPPORT::reserved29

◆ reserved30

NvU32 _NVDRS_GPU_SUPPORT::reserved30

◆ reserved31

NvU32 _NVDRS_GPU_SUPPORT::reserved31

◆ reserved32

NvU32 _NVDRS_GPU_SUPPORT::reserved32

◆ reserved4

NvU32 _NVDRS_GPU_SUPPORT::reserved4

◆ reserved5

NvU32 _NVDRS_GPU_SUPPORT::reserved5

◆ reserved6 [1/2]

NvU8 _NV_MONITOR_CAPS_VSDB::reserved6

Byte 3.

◆ reserved6 [2/2]

NvU32 _NVDRS_GPU_SUPPORT::reserved6

◆ reserved7

NvU32 _NVDRS_GPU_SUPPORT::reserved7

◆ reserved8 [1/2]

NvU8 _NV_MONITOR_CAPS_VSDB::reserved8

Byte 5.

◆ reserved8 [2/2]

NvU32 _NVDRS_GPU_SUPPORT::reserved8

◆ reserved9

NvU32 _NVDRS_GPU_SUPPORT::reserved9

◆ reserved_sourceId [1/3]

NvU32 _NV_DISPLAYCONFIG_PATH_INFO_V1::reserved_sourceId

This field is reserved. There is ongoing debate if we need this field. Identifies sourceIds used by Windows. If all sourceIds are 0, these will be computed automatically.

◆ [] [2/3]

NvU32 { ... } ::reserved_sourceId

Only for compatibility.

◆ reserved_sourceId [3/3]

NvU32 _NV_DISPLAYCONFIG_PATH_INFO_V2::reserved_sourceId

Only for compatibility.

◆ reservedBit1

NvU32 _NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_V1::reservedBit1

◆ reservedBits [1/3]

NvU32 _NV_D3D1x_GRAPHICS_CAPS_V1::reservedBits

◆ reservedBits [2/3]

NvU32 _NV_D3D1x_GRAPHICS_CAPS_V2::reservedBits

◆ reservedBits [3/3]

NvU32 _NV_D3D12_GRAPHICS_CAPS_V1::reservedBits

◆ reservedData [1/3]

NvU8 _NVVIOOUTPUTCONFIG_V1::reservedData[256]

Inicates last stored SDI output state TRUE-ON / FALSE-OFF.

◆ reservedData [2/3]

NvU8 _NVVIOOUTPUTCONFIG_V2::reservedData[256]

Indicates last stored SDI output state TRUE-ON / FALSE-OFF.

◆ reservedData [3/3]

NvU8 _NVVIOOUTPUTCONFIG_V3::reservedData[256]

Indicates last stored SDI output state TRUE-ON / FALSE-OFF.

◆ reservedEx [1/7]

NvU32 _NV_GET_ADAPTIVE_SYNC_DATA_V1::reservedEx[4]

reserved for future use.

◆ reservedEx [2/7]

NvU32 _NV_GET_VRR_INFO_V1::reservedEx[4]

Reserved for future use.

◆ reservedEx [3/7]

NvU32 _NV_SET_ADAPTIVE_SYNC_DATA_V1::reservedEx[7]

reserved for future use.

◆ reservedEx [4/7]

NvU32 NVLINK_LINK_STATUS_INFO_V2::reservedEx[8]

Reserved for future use to avoid versioning.

◆ reservedEx [5/7]

NvU32 _NV_GET_VIRTUAL_REFRESH_RATE_DATA_V1::reservedEx[8]

reserved for future use.

◆ reservedEx [6/7]

NvU32 _NV_SET_VIRTUAL_REFRESH_RATE_DATA_V1::reservedEx[8]

reserved for future use.

◆ reservedEx [7/7]

NvU32 _NV_DISPLAY_DRIVER_INFO_V2::reservedEx

Reserved for future use.

◆ reservedInternal

NvU32 _NV_GPU_DISPLAYIDS::reservedInternal

Do not use.

◆ resolution

NV_RESOLUTION _NV_DISPLAYCONFIG_SOURCE_MODE_INFO_V1::resolution

◆ resolutionScale

float _NV_SMP_ASSIST_SETUP_PARAMS_V1::resolutionScale

(IN) A resolution multiplier in the range [0.1, 3.0] if app wants to render at higher resolution

◆ ResourceHandle [1/2]

NVDX_ObjectHandle NV_D3D11_META_COMMAND_RESOURCE::ResourceHandle

◆ [] [2/2]

NVDX_ObjectHandle { ... } ::ResourceHandle

◆ resultDataMaxSizeInBytes [1/2]

NvU64 _NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PREBUILD_INFO::resultDataMaxSizeInBytes

Size required to hold the result of a DMM Array build based on the specified inputs.

◆ resultDataMaxSizeInBytes [2/2]

NvU64 _NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_ARRAY_PREBUILD_INFO::resultDataMaxSizeInBytes

Size required to hold the result of an OMM Array build based on the specified inputs.

◆ revision [1/6]

NvU32 NV_GPU_ARCH_INFO_V1::revision

◆ revision [2/6]

NvU32 NV_GPU_ARCH_INFO_V2::revision

revision and revision_id are the same. The former is NvU32 while the latter is an enum made for readability.

◆ [] [3/6]

NvU32 { ... } ::revision

revision and revision_id are the same. The former is NvU32 while the latter is an enum made for readability.

◆ revision [4/6]

NvU32 _NV_GSYNC_CAPABILITIES_V1::revision

FPGA Revision.

◆ revision [5/6]

NvU32 _NV_GSYNC_CAPABILITIES_V2::revision

FPGA major revision.

◆ revision [6/6]

NvU32 _NV_GSYNC_CAPABILITIES_V3::revision

FPGA major revision.

◆ revision_id [1/2]

NV_GPU_CHIP_REVISION NV_GPU_ARCH_INFO_V2::revision_id

specifies the architecture revision of the GPU.

◆ [] [2/2]

NV_GPU_CHIP_REVISION { ... } ::revision_id

specifies the architecture revision of the GPU.

◆ rgb [1/4]

NV_GPU_CLIENT_ILLUM_ZONE_INFO_DATA_RGB _NV_GPU_CLIENT_ILLUM_ZONE_INFO_V1::rgb

◆ [] [2/4]

NV_GPU_CLIENT_ILLUM_ZONE_INFO_DATA_RGB { ... } ::rgb

◆ rgb [3/4]

NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_RGB _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_V1::rgb

◆ [] [4/4]

NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_RGB { ... } ::rgb

◆ rgbParams [1/2]

NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_RGB_PARAMS _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_RGB::rgbParams

Parameters required to represent control mode of type NV_GPU_CLIENT_ILLUM_CTRL_MODE_MANUAL_RGB.

◆ rgbParams [2/2]

NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_RGB_PARAMS _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR_RGB::rgbParams[NV_GPU_CLIENT_ILLUM_CTRL_MODE_PIECEWISE_LINEAR_COLOR_ENDPOINTS]

Parameters required to represent control mode of type NV_GPU_CLIENT_ILLUM_CTRL_MODE_PIECEWISE_LINEAR_RGB.

◆ rgbQuantizationRange

NvU32 NV_INFOFRAME_VIDEO::rgbQuantizationRange

◆ [] [1/4]

NV_GPU_CLIENT_ILLUM_ZONE_INFO_DATA_RGBW { ... } ::rgbw

◆ rgbw [2/4]

NV_GPU_CLIENT_ILLUM_ZONE_INFO_DATA_RGBW _NV_GPU_CLIENT_ILLUM_ZONE_INFO_V1::rgbw

◆ [] [3/4]

NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_RGBW { ... } ::rgbw

◆ rgbw [4/4]

NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_RGBW _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_V1::rgbw

◆ rgbwParams [1/2]

NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_RGBW_PARAMS _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_RGBW::rgbwParams

Parameters required to represent control mode of type NV_GPU_ILLUM_CTRL_MODE_MANUAL_RGBW.

◆ rgbwParams [2/2]

NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_RGBW_PARAMS _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR_RGBW::rgbwParams[NV_GPU_CLIENT_ILLUM_CTRL_MODE_PIECEWISE_LINEAR_COLOR_ENDPOINTS]

Parameters required to represent control mode of type NV_GPU_ILLUM_CTRL_MODE_PIECEWISE_LINEAR_RGBW.

◆ right_bar

NvU32 NV_INFOFRAME_VIDEO::right_bar

◆ rightCoeffs

float _NV_SMP_ASSIST_UPDATE_INSTANCEDSTEREO_DATA_PARAMS_V1::rightCoeffs[4]

◆ rightConst

float _NV_SMP_ASSIST_UPDATE_INSTANCEDSTEREO_DATA_PARAMS_V1::rightConst

◆ riseTimems

NvU16 _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR::riseTimems

Time in ms to transition from color A to color B.

◆ RJ45_Ethernet [1/2]

NvU32 _NV_GSYNC_STATUS_PARAMS_V1::RJ45_Ethernet[NVAPI_MAX_RJ45_PER_GSYNC]

Connected to ethernet hub? [ERRONEOUSLY CONNECTED!].

◆ RJ45_Ethernet [2/2]

NvU32 _NV_GSYNC_STATUS_PARAMS_V2::RJ45_Ethernet[NVAPI_MAX_RJ45_PER_GSYNC]

Connected to ethernet hub? [ERRONEOUSLY CONNECTED!].

◆ RJ45_IO [1/2]

NVAPI_GSYNC_RJ45_IO _NV_GSYNC_STATUS_PARAMS_V1::RJ45_IO[NVAPI_MAX_RJ45_PER_GSYNC]

Configured as input / output.

◆ RJ45_IO [2/2]

NVAPI_GSYNC_RJ45_IO _NV_GSYNC_STATUS_PARAMS_V2::RJ45_IO[NVAPI_MAX_RJ45_PER_GSYNC]

Configured as input / output.

◆ rotation [1/4]

NV_ROTATE NV_DISPLAY_PATH::rotation

(IN) Rotation setting.

◆ rotation [2/4]

NV_ROTATE _NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_V1::rotation

(IN) rotation setting.

◆ rotation [3/4]

NV_ROTATE _NV_MOSAIC_GRID_TOPO_DISPLAY_V1::rotation

Rotation of display.

◆ rotation [4/4]

NV_ROTATE _NV_MOSAIC_GRID_TOPO_DISPLAY_V2::rotation

Rotation of display.

◆ rowCount [1/2]

NvU32 NV_MOSAIC_TOPO_DETAILS::rowCount

Number of displays in a row.

◆ rowCount [2/2]

NvU32 NV_MOSAIC_TOPOLOGY::rowCount

Horizontal display count.

◆ rows [1/2]

NvU32 _NV_MOSAIC_GRID_TOPO_V1::rows

Number of rows.

◆ rows [2/2]

NvU32 _NV_MOSAIC_GRID_TOPO_V2::rows

Number of rows.

◆ rr [1/2]

NvU16 tagNV_TIMINGEXT::rr

Logical refresh rate to present.

◆ rr [2/2]

float _NV_TIMING_INPUT::rr

Timing refresh rate.

◆ rrx1k [1/2]

NvU32 tagNV_TIMINGEXT::rrx1k

Physical vertical refresh rate in 0.001Hz.

◆ rrx1k [2/2]

NvU32 NV_MOSAIC_DISPLAY_SETTING_V2::rrx1k

Display frequency in x1k.

◆ rsvd [1/36]

NvU8 _NV_GPU_CLIENT_ILLUM_ZONE_INFO_DATA_SINGLE_COLOR::rsvd

◆ rsvd [2/36]

NvU8 _NV_LATENCY_RESULT_PARAMS::FrameReport::rsvd[120]

◆ [] [3/36]

NvU8 { ... } ::rsvd[64]

Reserved bytes for possible future extension of this struct.

◆ rsvd [4/36]

NvU8 _NV_GPU_CLIENT_ILLUM_DEVICE_INFO_V1::rsvd

Reserved bytes for possible future extension of this struct.

Reserved for future.

◆ rsvd [5/36]

NvU8 _NV_GPU_CLIENT_ILLUM_ZONE_INFO_DATA_RGB::rsvd

◆ rsvd [6/36]

NvU8 _NV_GPU_CLIENT_ILLUM_ZONE_INFO_DATA_RGBW::rsvd

◆ rsvd [7/36]

NvU8 _NV_GET_SLEEP_STATUS_PARAMS::rsvd[121]

(IN) Reserved. Must be set to 0s.

◆ rsvd [8/36]

NvU8 _NV_SET_REFLEX_SYNC_PARAMS::rsvd[28]

(IN) Reserved. Must be set to 0s.

◆ rsvd [9/36]

NvU8 _NV_SET_SLEEP_MODE_PARAMS::rsvd[31]

(IN) Reserved. Must be set to 0s.

◆ rsvd [10/36]

NvU8 _NV_LATENCY_RESULT_PARAMS::rsvd[32]

◆ rsvd [11/36]

NvU8 _NV_LATENCY_MARKER_PARAMS::rsvd[56]

◆ rsvd [12/36]

NvU8 _NV_ASYNC_FRAME_MARKER_PARAMS_V1::rsvd[56]

◆ rsvd [13/36]

NvU8 _NV_GPU_CLIENT_UTILIZATION_DATA_V1::rsvd[61]

Reserved bytes for future expansion.

◆ rsvd [14/36]

NvU8 _NV_GPU_CLIENT_ILLUM_DEVICE_INFO_PARAMS_V1::rsvd[64]

Reserved bytes for possible future extension of this struct.

◆ rsvd [15/36]

NvU8 NV_GPU_CLIENT_ILLUM_DEVICE_SYNC_V1::rsvd[64]

Reserved for future.

◆ rsvd [16/36]

NvU8 NV_GPU_CLIENT_ILLUM_DEVICE_CONTROL_V1::rsvd[64]

Reserved for future.

◆ rsvd [17/36]

NvU8 NV_GPU_CLIENT_ILLUM_DEVICE_CONTROL_PARAMS_V1::rsvd[64]

Reserved bytes for possible future extension of this struct.

◆ rsvd [18/36]

NvU8 _NV_GPU_CLIENT_ILLUM_ZONE_INFO_V1::rsvd

Reserved bytes for possible future extension of this struct.

◆ [] [19/36]

NvU8 { ... } ::rsvd[64]

Reserved bytes for possible future extension of this struct.

◆ rsvd [20/36]

NvU8 _NV_GPU_CLIENT_ILLUM_ZONE_INFO_PARAMS_V1::rsvd[64]

Reserved bytes for possible future extension of this struct.

◆ [] [21/36]

NvU8 { ... } ::rsvd[64]

Reserved bytes for possible future extension of this struct.

◆ rsvd [22/36]

NvU8 _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_RGB::rsvd

Reserved bytes for possible future extension of this struct.

Reserved for future.

◆ rsvd [23/36]

NvU8 _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_COLOR_FIXED::rsvd

Reserved bytes for possible future extension of this struct.

Reserved for future.

◆ [] [24/36]

NvU8 { ... } ::rsvd[64]

Reserved bytes for possible future extension of this struct.

◆ rsvd [25/36]

NvU8 _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_RGBW::rsvd

Reserved bytes for possible future extension of this struct.

Reserved for future.

◆ [] [26/36]

NvU8 { ... } ::rsvd[64]

Reserved bytes for possible future extension of this struct.

◆ rsvd [27/36]

NvU8 _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_SINGLE_COLOR::rsvd

Reserved bytes for possible future extension of this struct.

Reserved for future.

◆ [] [28/36]

NvU8 { ... } ::rsvd[64]

Reserved bytes for possible future extension of this struct.

◆ [] [29/36]

NvU8 { ... } ::rsvd[64]

◆ rsvd [30/36]

NvU8 _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_V1::rsvd

◆ rsvd [31/36]

NvU8 _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_PARAMS_V1::rsvd[64]

Reserved bytes for possible future extension of this struct.

◆ rsvd [32/36]

NvU8 _NV_CLIENT_CALLBACK_SETTINGS_SUPER_V1::rsvd[64]

Reserved bytes for future expansion.

◆ rsvd [33/36]

NvU8 _NV_GPU_CLIENT_PERIODIC_CALLBACK_SETTINGS_SUPER_V1::rsvd[64]

Reserved bytes for future expansion.

◆ rsvd [34/36]

NvU8 _NV_GPU_CLIENT_CALLBACK_DATA_SUPER_V1::rsvd[64]

Reserved bytes for future expansion.

◆ rsvd [35/36]

NvU8 _NV_GPU_CLIENT_CALLBACK_UTILIZATION_DATA_V1::rsvd[64]

Reserved bytes for future expansion.

◆ rsvd [36/36]

NvU8 _NV_GPU_CLIENT_UTILIZATION_PERIODIC_CALLBACK_SETTINGS_V1::rsvd[64]

Reserved bytes for future expansion.

◆ rsvd0

NvU64 _NV_LATENCY_MARKER_PARAMS::rsvd0

◆ rsvdField

NvU32 _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_PARAMS_V1::rsvdField

◆ rxSublinkStatus [1/2]

NvU8 NVLINK_LINK_STATUS_INFO_V1::rxSublinkStatus

This field specifies the current state of RX sublink.See NVAPI_NVLINK_GET_NVLINK_STATUS_SUBLINK_RX_STATE_* for possible values.

◆ rxSublinkStatus [2/2]

NvU8 NVLINK_LINK_STATUS_INFO_V2::rxSublinkStatus

This field specifies the current state of RX sublink.See NVAPI_NVLINK_GET_NVLINK_STATUS_SUBLINK_RX_STATE_* for possible values.

◆ SampleCount [1/2]

NvU8 NvAPI_D3D11_RASTERIZER_DESC_EX::SampleCount

◆ SampleCount [2/2]

NvU8 NVAPI_D3D12_PSO_RASTERIZER_STATE_DESC_V1::SampleCount

◆ SamplePositionsX [1/2]

NvU8 NvAPI_D3D11_RASTERIZER_DESC_EX::SamplePositionsX[16]

◆ SamplePositionsX [2/2]

NvU8 NVAPI_D3D12_PSO_RASTERIZER_STATE_DESC_V1::SamplePositionsX[16]

◆ SamplePositionsY [1/2]

NvU8 NvAPI_D3D11_RASTERIZER_DESC_EX::SamplePositionsY[16]

◆ SamplePositionsY [2/2]

NvU8 NVAPI_D3D12_PSO_RASTERIZER_STATE_DESC_V1::SamplePositionsY[16]

◆ sampleRate

NvU32 NV_INFOFRAME_AUDIO::sampleRate

◆ sampleSize

NvU32 NV_INFOFRAME_AUDIO::sampleSize

◆ sampling

NVVIOCOMPONENTSAMPLING _NVVIOSTREAM::sampling

Sampling

◆ samplingFormat

NVVIOCOMPONENTSAMPLING _NVVIOCHANNELSTATUS::samplingFormat

Sampling format.

◆ scaling [1/3]

NV_SCALING NV_DISPLAY_PATH::scaling

(IN) Scaling setting

◆ scaling [2/3]

NV_SCALING _NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_V1::scaling

(IN) scaling setting.

◆ scaling [3/3]

NvU32 NV_TIMING_FLAG::scaling

Define preferred scaling.

◆ scanInfo

NvU32 NV_INFOFRAME_VIDEO::scanInfo

◆ scanInfoCEVideoFormats

NvU8 _NV_MONITOR_CAPS_VCDB::scanInfoCEVideoFormats

◆ scanInfoITVideoFormats

NvU8 _NV_MONITOR_CAPS_VCDB::scanInfoITVideoFormats

◆ scanInfoPreferredVideoFormat

NvU8 _NV_MONITOR_CAPS_VCDB::scanInfoPreferredVideoFormat

◆ ScissorEnable

BOOL NvAPI_D3D11_RASTERIZER_DESC_EX::ScissorEnable

◆ scissorRect

D3D11_RECT _NV_D3D11_EXCLUSIVE_SCISSOR_RECT_DESC_V1::scissorRect

(IN) Single rect dimensions

◆ scratchAccelerationStructureData

D3D12_GPU_VIRTUAL_ADDRESS _NVAPI_D3D12_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_DESC_EX::scratchAccelerationStructureData

Memory that will be temporarily used during the building process.

◆ scratchDataSizeInBytes [1/2]

NvU64 _NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PREBUILD_INFO::scratchDataSizeInBytes

Scratch storage on GPU required during DMM Array build based on the specified inputs.

◆ scratchDataSizeInBytes [2/2]

NvU64 _NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_ARRAY_PREBUILD_INFO::scratchDataSizeInBytes

Scratch storage on GPU required during OMM Array build based on the specified inputs.

◆ scratchDisplacementMicromapArrayData

D3D12_GPU_VIRTUAL_ADDRESS _NVAPI_D3D12_BUILD_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_DESC::scratchDisplacementMicromapArrayData

Location where the build will store temporary data. NvAPI_D3D12_GetRaytracingDisplacementMicromapArrayPrebuildInfo() reports the amount of scratch memory the implementation will need for a given set of input parameters. The address must be aligned to 256 bytes (NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_BYTE_ALIGNMENT). Contents of this memory going into a build on the GPU timeline are irrelevant and will not be preserved. After the build is complete on the GPU timeline, the memory is left with whatever undefined contents the build finished with. The memory pointed to must be in state D3D12_RESOURCE_STATE_UNORDERED_ACCESS.

◆ scratchOpacityMicromapArrayData

D3D12_GPU_VIRTUAL_ADDRESS _NVAPI_D3D12_BUILD_RAYTRACING_OPACITY_MICROMAP_ARRAY_DESC::scratchOpacityMicromapArrayData

Location where the build will store temporary data. NvAPI_D3D12_GetRaytracingOpacityMicromapArrayPrebuildInfo() reports the amount of scratch memory the implementation will need for a given set of input parameters. The address must be aligned to 256 bytes (NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_ARRAY_BYTE_ALIGNMENT). Contents of this memory going into a build on the GPU timeline are irrelevant and will not be preserved. After the build is complete on the GPU timeline, the memory is left with whatever undefined contents the build finished with. The memory pointed to must be in state D3D12_RESOURCE_STATE_UNORDERED_ACCESS.

◆ sCustomRects [1/2]

NV_CUSTOM_RECTS_V1 _NV_SMP_ASSIST_SETUP_PARAMS_V1::sCustomRects

(IN) If SMP Assist Level is Minimal, provide custom viewports and scissor rects for each eye index.

◆ [] [2/2]

NV_CUSTOM_RECTS_V1 { ... } ::sCustomRects

(IN) If SMP Assist Level is Minimal, provide custom viewports and scissor rects for each eye index.

◆ sdiSyncIn

NVVIOSYNCSTATUS _NVVIOOUTPUTSTATUS::sdiSyncIn

SDI sync input status.

◆ sec

NvU16 _NV_LICENSE_EXPIRY_DETAILS::sec

Seconds value of license expiry.

◆ [struct] [1/2]

struct { ... } NV_GPU_THERMAL_SETTINGS_V1::sensor[NVAPI_MAX_THERMAL_SENSORS_PER_GPU]

◆ [struct] [2/2]

struct { ... } NV_GPU_THERMAL_SETTINGS_V2::sensor[NVAPI_MAX_THERMAL_SENSORS_PER_GPU]

◆ serializedDataType

NVAPI_D3D12_SERIALIZED_DATA_TYPE_EX _NVAPI_CHECK_DRIVER_MATCHING_IDENTIFIER_EX_PARAMS_V1::serializedDataType

[in] Type of data to be deserialized; see NVAPI_D3D12_SERIALIZED_DATA_TYPE_EX.

◆ settingId

NvU32 _NVDRS_SETTING_V1::settingId

32 bit setting Id

◆ settingLocation

NVDRS_SETTING_LOCATION _NVDRS_SETTING_V1::settingLocation

Describes where the value in CurrentValue comes from.

◆ settingName

NvAPI_UnicodeString _NVDRS_SETTING_V1::settingName

String name of setting.

◆ settingType [1/2]

NVDRS_SETTING_TYPE _NVDRS_SETTING_VALUES::settingType

Type of setting value.

◆ settingType [2/2]

NVDRS_SETTING_TYPE _NVDRS_SETTING_V1::settingType

Type of setting value.

◆ [union]

union { ... } _NVDRS_SETTING_VALUES::settingValues[NVAPI_SETTING_MAX_VALUES]

◆ sFoveatedRenderingDesc

NV_FOVEATED_RENDERING_DESC_V1 _NV_VRS_HELPER_ENABLE_PARAMS_V1::sFoveatedRenderingDesc

(IN) Provide this if ContentType has NV_VRS_CONTENT_TYPE_FOVEATED_RENDERING flag

◆ ShadingRateCustomPresetDesc

NV_FOVEATED_RENDERING_CUSTOM_SHADING_RATE_PRESET_DESC_V1 _NV_FOVEATED_RENDERING_DESC_V1::ShadingRateCustomPresetDesc

(IN) To be provided only if ShadingRatePreset is NV_FOVEATED_RENDERING_SHADING_RATE_PRESET_CUSTOM

◆ ShadingRatePreset

NV_FOVEATED_RENDERING_SHADING_RATE_PRESET _NV_FOVEATED_RENDERING_DESC_V1::ShadingRatePreset

(IN) Preset of the shading rate

◆ shadingRateTable [1/2]

NV_PIXEL_SHADING_RATE _NV_D3D11_VIEWPORT_SHADING_RATE_DESC_V1::shadingRateTable[NV_MAX_PIXEL_SHADING_RATES]

(IN) Lookup table of converting Shading Rate Index to NV_PIXEL_SHADING_RATE

◆ shadingRateTable [2/2]

NV_PIXEL_SHADING_RATE _NV_VRS_HELPER_GET_SHADING_RATE_RESOURCE_PARAMS_V1::shadingRateTable[NV_MAX_PIXEL_SHADING_RATES]

(OUT) Shading Rate Table filled by the driver

◆ signalFormat [1/6]

NVVIOSIGNALFORMAT _NVVIOCHANNELSTATUS::signalFormat

Signal format.

◆ signalFormat [2/6]

NVVIOSIGNALFORMAT _NVVIOSIGNALFORMATDETAIL::signalFormat

Signal format enumerated value.

◆ signalFormat [3/6]

NVVIOSIGNALFORMAT _NVVIOOUTPUTCONFIG_V1::signalFormat

Signal format for video output.

◆ signalFormat [4/6]

NVVIOSIGNALFORMAT _NVVIOOUTPUTCONFIG_V2::signalFormat

Signal format for video output.

◆ signalFormat [5/6]

NVVIOSIGNALFORMAT _NVVIOOUTPUTCONFIG_V3::signalFormat

Signal format for video output.

◆ signalFormat [6/6]

NVVIOSIGNALFORMAT _NVVIOINPUTCONFIG::signalFormat

Signal format. Please note that both numRawCaptureImages and signalFormat should be set together.

◆ signature [1/4]

NvU8 _NV_LICENSABLE_FEATURES_V1::signature[NV_LICENSE_SIGNATURE_SIZE]

Dynamic signature required for Authentication of the components, signature length limited to NV_LICENSE_SIGNATURE_SIZE

◆ signature [2/4]

NvU8 _NV_LICENSABLE_FEATURES_V2::signature[NV_LICENSE_SIGNATURE_SIZE]

Dynamic signature required for Authentication of the components, signature length limited to NV_LICENSE_SIGNATURE_SIZE

◆ signature [3/4]

NvU8 _NV_LICENSABLE_FEATURES_V3::signature[NV_LICENSE_SIGNATURE_SIZE]

Dynamic signature required for Authentication of the components, signature length limited to NV_LICENSE_SIGNATURE_SIZE

◆ signature [4/4]

NvU8 _NV_LICENSABLE_FEATURES_V4::signature[NV_LICENSE_SIGNATURE_SIZE]

Dynamic signature required for Authentication of the components, signature length limited to NV_LICENSE_SIGNATURE_SIZE

◆ simEndTime

NvU64 _NV_LATENCY_RESULT_PARAMS::FrameReport::simEndTime

◆ simStartTime

NvU64 _NV_LATENCY_RESULT_PARAMS::FrameReport::simStartTime

◆ [struct] [1/2]

struct { ... } NV_GPU_PSTATE20_CLOCK_ENTRY_V1::single

◆ [struct] [2/2]

struct { ... } NV_GPU_PSTATE20_CLOCK_ENTRY_V1::single

◆ singleBitErrors [1/3]

NvU64 NV_GPU_ECC_ERROR_INFO::singleBitErrors

Number of single-bit ECC errors detected since last boot.

Number of single-bit ECC errors detected since last counter reset.

◆ [] [2/3]

NvU64 { ... } ::singleBitErrors

Number of single-bit ECC errors detected since last boot.

◆ [] [3/3]

NvU64 { ... } ::singleBitErrors

Number of single-bit ECC errors detected since last counter reset.

◆ singleColor [1/4]

NV_GPU_CLIENT_ILLUM_ZONE_INFO_DATA_SINGLE_COLOR _NV_GPU_CLIENT_ILLUM_ZONE_INFO_V1::singleColor

◆ [] [2/4]

NV_GPU_CLIENT_ILLUM_ZONE_INFO_DATA_SINGLE_COLOR { ... } ::singleColor

◆ singleColor [3/4]

NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_SINGLE_COLOR _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_V1::singleColor

◆ [] [4/4]

NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_SINGLE_COLOR { ... } ::singleColor

◆ singleColorParams [1/2]

NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_SINGLE_COLOR_PARAMS _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_SINGLE_COLOR::singleColorParams

Parameters required to represent control mode of type NV_GPU_ILLUM_CTRL_MODE_MANUAL_SINGLE_COLOR.

◆ singleColorParams [2/2]

NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_SINGLE_COLOR_PARAMS _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR_SINGLE_COLOR::singleColorParams[NV_GPU_CLIENT_ILLUM_CTRL_MODE_PIECEWISE_LINEAR_COLOR_ENDPOINTS]

Parameters required to represent control mode of type NV_GPU_ILLUM_CTRL_MODE_PIECEWISE_LINEAR_SINGLE_COLOR.

◆ size [1/8]

NvU16 NV_INFOFRAME_DATA::size

size of this structure

◆ size [2/8]

NvU16 _NV_COLOR_DATA_V1::size

Size of this structure.

◆ size [3/8]

NvU16 _NV_COLOR_DATA_V2::size

Size of this structure.

◆ size [4/8]

NvU16 _NV_COLOR_DATA_V3::size

Size of this structure.

◆ size [5/8]

NvU16 _NV_COLOR_DATA_V4::size

Size of this structure.

◆ size [6/8]

NvU16 _NV_COLOR_DATA_V5::size

Size of this structure.

◆ size [7/8]

NvU16 _NV_MONITOR_CAPABILITIES_V1::size

◆ Size

NvU64 NV_META_COMMAND_TENSOR_DESC::Size[NV_META_COMMAND_MAX_TENSOR_DIM]

◆ size [8/8]

NvU32 NVAPI_D3D12_CREATE_CUBIN_SHADER_PARAMS::size

[in] size of pCubin blob in bytes

◆ sizeofEDID [1/2]

NvU32 NV_EDID_V2::sizeofEDID

◆ sizeofEDID [2/2]

NvU32 NV_EDID_V3::sizeofEDID

◆ sizeOfEDID [1/2]

NvU32 _NV_EDID_DATA_V1::sizeOfEDID

Size of EDID data.

◆ sizeOfEDID [2/2]

NvU32 _NV_EDID_DATA_V2::sizeOfEDID

Size of EDID data.

◆ SkipConnectionResource [1/2]

NV_D3D11_META_COMMAND_RESOURCE NV_D3D11_META_COMMAND_EXECUTE_CONVOLUTION_EX_DESC::SkipConnectionResource

◆ SkipConnectionResource [2/2]

D3D12_GPU_VIRTUAL_ADDRESS NV_D3D12_META_COMMAND_EXECUTE_CONVOLUTION_EX_DESC::SkipConnectionResource

◆ SkipMode

NV_META_COMMAND_CONVOLUTION_SKIP_MODE NV_META_COMMAND_CONVOLUTION_FUSE_DESC::SkipMode

◆ sleepIntervalUs

NvU32 _NV_GET_SLEEP_STATUS_PARAMS::sleepIntervalUs

(OUT) Latest sleep interval in microseconds.

◆ sLeftConfig

NV_LMS_CUSTOM_CONFIG_V1 _NV_LMS_INSTANCED_STEREO_CONFIG_V1::sLeftConfig

< (OUT) LMS Instanced stereo config returned by the SMP Assist GetConstants API

(OUT) LMS config for the Left eye view

◆ sLeftEye [1/2]

NV_FOVEATED_RENDERING_GAZE_DATA_PER_EYE_V1 _NV_FOVEATED_RENDERING_UPDATE_GAZE_DATA_PARAMS::sLeftEye

(IN) Gaze data for Left Eye of Stereo rendering mode

◆ [] [2/2]

NV_FOVEATED_RENDERING_GAZE_DATA_PER_EYE_V1 { ... } ::sLeftEye

(IN) Gaze data for Left Eye of Stereo rendering mode

◆ sLMS_ISConfig [1/2]

NV_LMS_INSTANCED_STEREO_CONFIG_V1 _NV_SMP_ASSIST_GET_CONSTANTS_V3::sLMS_ISConfig

(OUT) If eSMPAssistType is LMS and eEyeIndex is NV_SMP_ASSIST_EYE_INDEX_INSTANCED_STEREO then LMS Instanced stereo config will be populated

◆ [] [2/2]

NV_LMS_INSTANCED_STEREO_CONFIG_V1 { ... } ::sLMS_ISConfig

(OUT) If eSMPAssistType is LMS and eEyeIndex is NV_SMP_ASSIST_EYE_INDEX_INSTANCED_STEREO then LMS Instanced stereo config will be populated

◆ [] [1/2]

NV_LMS_CUSTOM_CONFIG_V1 { ... } ::sLMSConfig

(OUT) If eSMPAssistType is LMS, then LMS config will be populated

◆ sLMSConfig [2/2]

NV_LMS_CUSTOM_CONFIG_V1 _NV_SMP_ASSIST_GET_CONSTANTS_V3::sLMSConfig

(OUT) If eSMPAssistType is LMS, then LMS config will be populated

◆ [] [1/2]

NV_LMS_CUSTOM_CONFIG_V1 { ... } ::sLMSCustomConfig

(IN) If eSMPAssistType is LMS and SMP Assist Level is Partial, then provide LMS config

◆ sLMSCustomConfig [2/2]

NV_LMS_CUSTOM_CONFIG_V1 _NV_SMP_ASSIST_SETUP_PARAMS_V1::sLMSCustomConfig

(IN) If eSMPAssistType is LMS and SMP Assist Level is Partial, then provide LMS config

◆ SlopeScaledDepthBias

FLOAT NvAPI_D3D11_RASTERIZER_DESC_EX::SlopeScaledDepthBias

◆ [] [1/2]

NV_FOVEATED_RENDERING_GAZE_DATA_PER_EYE_V1 { ... } ::sMonoData

(IN) Gaze data for Mono rendering mode

◆ sMonoData [2/2]

NV_FOVEATED_RENDERING_GAZE_DATA_PER_EYE_V1 _NV_FOVEATED_RENDERING_UPDATE_GAZE_DATA_PARAMS::sMonoData

(IN) Gaze data for Mono rendering mode

◆ smpDesc

D3D12_CPU_DESCRIPTOR_HANDLE NVAPI_D3D12_GET_CUDA_MERGED_TEXTURE_SAMPLER_OBJECT_PARAMS::smpDesc

[in] CPU descriptor handle of the sampler (set to 0 if sampler isn't required)

◆ smpte352

NvU32 _NVVIOCHANNELSTATUS::smpte352

4-byte SMPTE 352 video payload identifier

◆ sMRS_ISConfig [1/2]

NV_MRS_INSTANCED_STEREO_CONFIG_V1 _NV_SMP_ASSIST_GET_CONSTANTS_V3::sMRS_ISConfig

(OUT) If eSMPAssistType is MRS and eEyeIndex is NV_SMP_ASSIST_EYE_INDEX_INSTANCED_STEREO then MRS Instanced stereo config will be populated

◆ [] [2/2]

NV_MRS_INSTANCED_STEREO_CONFIG_V1 { ... } ::sMRS_ISConfig

(OUT) If eSMPAssistType is MRS and eEyeIndex is NV_SMP_ASSIST_EYE_INDEX_INSTANCED_STEREO then MRS Instanced stereo config will be populated

◆ [] [1/2]

NV_MRS_CUSTOM_CONFIG_V1 { ... } ::sMRSConfig

(OUT) If eSMPAssistType is MRS, then MRS config will be populated

◆ sMRSConfig [2/2]

NV_MRS_CUSTOM_CONFIG_V1 _NV_SMP_ASSIST_GET_CONSTANTS_V3::sMRSConfig

(OUT) If eSMPAssistType is MRS, then MRS config will be populated

◆ sMRSCustomConfig [1/2]

NV_MRS_CUSTOM_CONFIG_V1 _NV_SMP_ASSIST_SETUP_PARAMS_V1::sMRSCustomConfig

(IN) If eSMPAssistType is MRS and SMP Assist Level is Partial, then provide MRS config

◆ [] [2/2]

NV_MRS_CUSTOM_CONFIG_V1 { ... } ::sMRSCustomConfig

(IN) If eSMPAssistType is MRS and SMP Assist Level is Partial, then provide MRS config

◆ source [1/2]

NVAPI_GSYNC_SYNC_SOURCE _NV_GSYNC_CONTROL_PARAMS_V1::source

VSync/House sync.

◆ source [2/2]

NVAPI_GSYNC_SYNC_SOURCE _NV_GSYNC_CONTROL_PARAMS_V2::source

VSync/House sync.

◆ sourceAccelerationStructureData

D3D12_GPU_VIRTUAL_ADDRESS _NVAPI_D3D12_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_DESC_EX::sourceAccelerationStructureData

The acceleration structure to be updated. Otherwise if the acceleration structure should be rebuilt entirely, this value must be NULL.

◆ sourceDesktopRect

NvSBox _NV_SCANOUT_INFORMATION::sourceDesktopRect

Operating system display device rect in desktop coordinates displayId is scanning out from.

◆ sourceId [1/5]

NvU32 NV_VIEW_TARGET_INFO::sourceId

(IN/OUT) Source ID - values will be based on the number of heads exposed per GPU.

◆ [] [2/5]

NvU32 { ... } ::sourceId

(IN/OUT) Source ID - values will be based on the number of heads exposed per GPU.

◆ sourceId [3/5]

NvU32 NV_DISPLAY_PATH::sourceId

(IN) Values will be based on the number of heads exposed per GPU(0, 1?)

◆ sourceId [4/5]

NvU32 _NV_DISPLAYCONFIG_PATH_INFO_V2::sourceId

Identifies sourceId used by Windows CCD. This can be optionally set.

◆ [] [5/5]

NvU32 { ... } ::sourceId

Identifies sourceId used by Windows CCD. This can be optionally set.

◆ sourceModeInfo [1/2]

NV_DISPLAYCONFIG_SOURCE_MODE_INFO_V1* _NV_DISPLAYCONFIG_PATH_INFO_V1::sourceModeInfo

May be NULL if mode info is not important.

◆ sourceModeInfo [2/2]

NV_DISPLAYCONFIG_SOURCE_MODE_INFO_V1* _NV_DISPLAYCONFIG_PATH_INFO_V2::sourceModeInfo

May be NULL if mode info is not important.

◆ sourcePhysicalAddressA

NvU8 _NV_MONITOR_CAPS_VSDB::sourcePhysicalAddressA

Byte 1.

◆ sourcePhysicalAddressB

NvU8 _NV_MONITOR_CAPS_VSDB::sourcePhysicalAddressB

Byte 1.

◆ sourcePhysicalAddressC

NvU8 _NV_MONITOR_CAPS_VSDB::sourcePhysicalAddressC

Byte 2.

◆ sourcePhysicalAddressD

NvU8 _NV_MONITOR_CAPS_VSDB::sourcePhysicalAddressD

Byte 2.

◆ sourceToTargetRotation

NV_ROTATE _NV_SCANOUT_INFORMATION::sourceToTargetRotation

Rotation performed between the sourceViewportRect and the targetViewportRect.

◆ sourceViewportRect

NvSBox _NV_SCANOUT_INFORMATION::sourceViewportRect

Area inside the sourceDesktopRect which is scanned out to the display.

◆ spanningOrientation

NV_DISPLAYCONFIG_SPANNING_ORIENTATION _NV_DISPLAYCONFIG_SOURCE_MODE_INFO_V1::spanningOrientation

Spanning is only supported on XP.

◆ speakerPlacement

NvU32 NV_INFOFRAME_AUDIO::speakerPlacement

◆ srcEnumIndex

NvU32 srcEnumIndex

◆ srcPartition

NV_VIEWPORTF NV_CUSTOM_DISPLAY::srcPartition

For multimon support, should be set to (0,0,1.0,1.0) for now.

◆ sRightConfig

NV_LMS_CUSTOM_CONFIG_V1 _NV_LMS_INSTANCED_STEREO_CONFIG_V1::sRightConfig

(OUT) LMS config for the Right eye view

◆ sRightEye [1/2]

NV_FOVEATED_RENDERING_GAZE_DATA_PER_EYE_V1 _NV_FOVEATED_RENDERING_UPDATE_GAZE_DATA_PARAMS::sRightEye

(IN) Gaze data for Right Eye of Stereo rendering mode

◆ [] [2/2]

NV_FOVEATED_RENDERING_GAZE_DATA_PER_EYE_V1 { ... } ::sRightEye

(IN) Gaze data for Right Eye of Stereo rendering mode

◆ [struct] [1/2]

struct { ... } _NV_FOVEATED_RENDERING_UPDATE_GAZE_DATA_PARAMS::sStereoData

◆ [struct] [2/2]

struct { ... } _NV_FOVEATED_RENDERING_UPDATE_GAZE_DATA_PARAMS::sStereoData

◆ StartPadding

NvU64 NV_META_COMMAND_CREATE_CONVOLUTION_EX_DESC::StartPadding[NV_META_COMMAND_NUM_SPATIAL_DIM]

◆ startupDelay [1/2]

NV_GSYNC_DELAY _NV_GSYNC_CONTROL_PARAMS_V1::startupDelay

Sync start delay for master.

◆ startupDelay [2/2]

NV_GSYNC_DELAY _NV_GSYNC_CONTROL_PARAMS_V2::startupDelay

Sync start delay for master.

◆ static_metadata_descriptor_id [1/5]

NV_STATIC_METADATA_DESCRIPTOR_ID _NV_HDR_CAPABILITIES_V1::static_metadata_descriptor_id

Static Metadata Descriptor Id (0 for static metadata type 1)

◆ static_metadata_descriptor_id [2/5]

NV_STATIC_METADATA_DESCRIPTOR_ID _NV_HDR_CAPABILITIES_V2::static_metadata_descriptor_id

Static Metadata Descriptor Id (0 for static metadata type 1)

◆ static_metadata_descriptor_id [3/5]

NV_STATIC_METADATA_DESCRIPTOR_ID _NV_HDR_CAPABILITIES_V3::static_metadata_descriptor_id

Static Metadata Descriptor Id (0 for static metadata type 1)

◆ static_metadata_descriptor_id [4/5]

NV_STATIC_METADATA_DESCRIPTOR_ID _NV_HDR_COLOR_DATA_V1::static_metadata_descriptor_id

Static Metadata Descriptor Id (0 for static metadata type 1)

◆ static_metadata_descriptor_id [5/5]

NV_STATIC_METADATA_DESCRIPTOR_ID _NV_HDR_COLOR_DATA_V2::static_metadata_descriptor_id

Static Metadata Descriptor Id (0 for static metadata type 1)

◆ status [1/2]

NvU32 tagNV_TIMINGEXT::status

Timing standard.

◆ status [2/2]

NvU8 _NV_LICENSE_EXPIRY_DETAILS::status

License expiry status.

◆ streams

NVVIOSTREAM _NVVIOINPUTCONFIG::streams[NVAPI_MAX_VIO_STREAMS]

Stream configurations.

◆ Stride [1/2]

NvU64 NV_META_COMMAND_TENSOR_DESC::Stride[NV_META_COMMAND_MAX_TENSOR_DIM]

◆ Stride [2/2]

NvU64 NV_META_COMMAND_CREATE_CONVOLUTION_EX_DESC::Stride[NV_META_COMMAND_NUM_SPATIAL_DIM]

◆ structSizeIn [1/3]

size_t NVAPI_D3D12_CREATE_CUBIN_SHADER_PARAMS::structSizeIn

[in] Caller's version of input params

◆ structSizeIn [2/3]

size_t NVAPI_D3D12_GET_CUDA_MERGED_TEXTURE_SAMPLER_OBJECT_PARAMS::structSizeIn

[in] Caller's version of input params

◆ structSizeIn [3/3]

size_t NVAPI_D3D12_GET_CUDA_INDEPENDENT_DESCRIPTOR_OBJECT_PARAMS::structSizeIn

[in] Caller's version of input params

◆ structSizeOut [1/3]

size_t NVAPI_D3D12_CREATE_CUBIN_SHADER_PARAMS::structSizeOut

[out] Driver's version of input params

◆ structSizeOut [2/3]

size_t NVAPI_D3D12_GET_CUDA_MERGED_TEXTURE_SAMPLER_OBJECT_PARAMS::structSizeOut

[out] Driver's version of input params

◆ structSizeOut [3/3]

size_t NVAPI_D3D12_GET_CUDA_INDEPENDENT_DESCRIPTOR_OBJECT_PARAMS::structSizeOut

[out] Driver's version of input params

◆ subdivisionLevel [1/4]

NvU32 _NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_USAGE_COUNT::subdivisionLevel

Number of subdivisions for the DMM; valid inputs are [0, 5] (NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_DC1_MAX_SUBDIVISION_LEVEL). The total number of micro-triangles is 4subdivisionLevel.

◆ subdivisionLevel [2/4]

NvU16 _NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_DESC::subdivisionLevel

Number of subdivisions for the DMM; valid inputs are [0, 5] (NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_DC1_MAX_SUBDIVISION_LEVEL). The total number of micro-triangles is 4subdivisionLevel.

◆ subdivisionLevel [3/4]

NvU32 _NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_USAGE_COUNT::subdivisionLevel

Number of subdivisions for the OMM; valid inputs are [0, 12] (NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_OC1_MAX_SUBDIVISION_LEVEL). The total number of micro-triangles is 4subdivisionLevel.

◆ subdivisionLevel [4/4]

NvU16 _NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_DESC::subdivisionLevel

Number of subdivisions for the OMM; valid inputs are [0, 12] (NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_OC1_MAX_SUBDIVISION_LEVEL). The total number of micro-triangles is 4subdivisionLevel.

◆ subLinkWidth [1/2]

NvU8 NVLINK_LINK_STATUS_INFO_V1::subLinkWidth

This field specifies the no. of lanes per sublink.

◆ subLinkWidth [2/2]

NvU8 NVLINK_LINK_STATUS_INFO_V2::subLinkWidth

This field specifies the no. of lanes per sublink.

◆ subSysDeviceId [1/2]

NvU32 NV_CHIPSET_INFO_v4::subSysDeviceId

Chipset subsystem device identification.

◆ subSysDeviceId [2/2]

NvU32 NV_CHIPSET_INFO_v3::subSysDeviceId

subsystem device ID

◆ subSysVendorId [1/2]

NvU32 NV_CHIPSET_INFO_v4::subSysVendorId

Chipset subsystem vendor identification.

◆ subSysVendorId [2/2]

NvU32 NV_CHIPSET_INFO_v3::subSysVendorId

subsystem vendor ID

◆ super [1/3]

NV_GPU_CLIENT_CALLBACK_SETTINGS_SUPER_V1 _NV_GPU_CLIENT_PERIODIC_CALLBACK_SETTINGS_SUPER_V1::super

[in] Super class data.

◆ super [2/3]

NV_GPU_CLIENT_CALLBACK_DATA_SUPER_V1 _NV_GPU_CLIENT_CALLBACK_UTILIZATION_DATA_V1::super

[out] Super struct.

◆ super [3/3]

NV_GPU_CLIENT_PERIODIC_CALLBACK_SETTINGS_SUPER_V1 _NV_GPU_CLIENT_UTILIZATION_PERIODIC_CALLBACK_SETTINGS_V1::super

[in] Generic callback settings. Some data within will be passed to the callback when invoked.

◆ supportAI

NvU8 _NV_MONITOR_CAPS_VSDB::supportAI

Byte 3.

◆ supportDeepColor30bits

NvU8 _NV_MONITOR_CAPS_VSDB::supportDeepColor30bits

Byte 3.

◆ supportDeepColor36bits

NvU8 _NV_MONITOR_CAPS_VSDB::supportDeepColor36bits

Byte 3.

◆ supportDeepColor48bits

NvU8 _NV_MONITOR_CAPS_VSDB::supportDeepColor48bits

Byte 3.

◆ supportDeepColorYCbCr444

NvU8 _NV_MONITOR_CAPS_VSDB::supportDeepColorYCbCr444

Byte 3.

◆ supportDualDviOperation

NvU8 _NV_MONITOR_CAPS_VSDB::supportDualDviOperation

Byte 3.

◆ supported

NvBool _NV_D3D12_WORKSTATION_FEATURE_PROPERTIES::supported

(OUT) boolean returning if feature is supported

◆ [] [1/4]

NvU32 { ... } ::supports_10b_12b_444

It is set when interface supported is low latency, it tells whether it supports 10 bit or 12 bit RGB 4:4:4 or YCbCr 4:4:4 or both.

◆ supports_10b_12b_444 [2/4]

NvU32 _NV_HDR_CAPABILITIES_V2::supports_10b_12b_444

It is set when interface supported is low latency, it tells whether it supports 10 bit or 12 bit RGB 4:4:4 or YCbCr 4:4:4 or both.

◆ supports_10b_12b_444 [3/4]

NvU32 _NV_HDR_CAPABILITIES_V3::supports_10b_12b_444

It is set when interface supported is low latency, it tells whether it supports 10 bit or 12 bit RGB 4:4:4 or YCbCr 4:4:4 or both.

◆ [] [4/4]

NvU32 { ... } ::supports_10b_12b_444

It is set when interface supported is low latency, it tells whether it supports 10 bit or 12 bit RGB 4:4:4 or YCbCr 4:4:4 or both.

◆ supports_2160p60hz [1/4]

NvU32 _NV_HDR_CAPABILITIES_V2::supports_2160p60hz

If set sink is capable of 4kx2k @ 60hz.

◆ [] [2/4]

NvU32 { ... } ::supports_2160p60hz

If set sink is capable of 4kx2k @ 60hz.

◆ [] [3/4]

NvU32 { ... } ::supports_2160p60hz

If set sink is capable of 4kx2k @ 60hz.

◆ supports_2160p60hz [4/4]

NvU32 _NV_HDR_CAPABILITIES_V3::supports_2160p60hz

If set sink is capable of 4kx2k @ 60hz.

◆ [] [1/4]

NvU32 { ... } ::supports_backlight_control

This is set when sink is using lowlatency interface and can control its backlight.

◆ supports_backlight_control [2/4]

NvU32 _NV_HDR_CAPABILITIES_V2::supports_backlight_control

This is set when sink is using lowlatency interface and can control its backlight.

◆ supports_backlight_control [3/4]

NvU32 _NV_HDR_CAPABILITIES_V3::supports_backlight_control

This is set when sink is using lowlatency interface and can control its backlight.

◆ [] [4/4]

NvU32 { ... } ::supports_backlight_control

This is set when sink is using lowlatency interface and can control its backlight.

◆ [] [1/4]

NvU32 { ... } ::supports_global_dimming

Indicates if sink supports global dimming.

◆ supports_global_dimming [2/4]

NvU32 _NV_HDR_CAPABILITIES_V2::supports_global_dimming

Indicates if sink supports global dimming.

◆ supports_global_dimming [3/4]

NvU32 _NV_HDR_CAPABILITIES_V3::supports_global_dimming

Indicates if sink supports global dimming.

◆ [] [4/4]

NvU32 { ... } ::supports_global_dimming

Indicates if sink supports global dimming.

◆ [] [1/4]

NvU32 { ... } ::supports_YUV422_12bit

If set, sink is capable of YUV422-12 bit.

◆ supports_YUV422_12bit [2/4]

NvU32 _NV_HDR_CAPABILITIES_V2::supports_YUV422_12bit

If set, sink is capable of YUV422-12 bit.

◆ supports_YUV422_12bit [3/4]

NvU32 _NV_HDR_CAPABILITIES_V3::supports_YUV422_12bit

If set, sink is capable of YUV422-12 bit.

◆ [] [4/4]

NvU32 { ... } ::supports_YUV422_12bit

If set, sink is capable of YUV422-12 bit.

◆ [] [1/2]

NvU32 { ... } ::supportsRotation

(OUT) This display can be rotated

◆ supportsRotation [2/2]

NvU32 NV_MOSAIC_DISPLAY_TOPO_STATUS::supportsRotation

(OUT) This display can be rotated

◆ supportsWindowedModeAutomatic

NvU32 _NVAPI_STEREO_CAPS::supportsWindowedModeAutomatic

◆ supportsWindowedModeOff

NvU32 _NVAPI_STEREO_CAPS::supportsWindowedModeOff

◆ supportsWindowedModePersistent

NvU32 _NVAPI_STEREO_CAPS::supportsWindowedModePersistent

◆ supportULMB

NvU8 _NV_MONITOR_CAPS_GENERIC::supportULMB

monitor supports ULMB with variable refresh rate. Valid for NV_MONITOR_CAPS_TYPE_GENERIC only.

◆ supportVRR

NvU8 _NV_MONITOR_CAPS_GENERIC::supportVRR

monitor supports variable refresh rate. Valid for NV_MONITOR_CAPS_TYPE_GENERIC only.

◆ surfaceHandle [1/2]

NvU32 NVAPI_UAV_INFO_V1::surfaceHandle

[OUT] driver handle for a UAV (that can be used as a cudaSurfaceObject_t)

◆ surfaceHandle [2/2]

NvU32 NVAPI_UAV_INFO_V2::surfaceHandle

[OUT] driver handle for a UAV (that can be used as a cudaSurfaceObject_t)

◆ sViewOffset

NvS32 _NV_DX_VIDEO_STEREO_INFO::sViewOffset

Signed offset of each view (positive offset indicating left view is shifted left)

◆ syncData

NV_GPU_CLIENT_ILLUM_DEVICE_SYNC_V1 NV_GPU_CLIENT_ILLUM_DEVICE_CONTROL_V1::syncData

Structure containing the synchronization data for the illumination device.

◆ syncDelay [1/3]

NVVIOSYNCDELAY _NVVIOOUTPUTCONFIG_V1::syncDelay

Sync delay.

◆ syncDelay [2/3]

NVVIOSYNCDELAY _NVVIOOUTPUTCONFIG_V2::syncDelay

Sync delay.

◆ syncDelay [3/3]

NVVIOSYNCDELAY _NVVIOOUTPUTCONFIG_V3::syncDelay

Sync delay.

◆ syncEnable [1/4]

NvU32 _NVVIOOUTPUTSTATUS::syncEnable

Sync enable (TRUE if using syncSource)

◆ syncEnable [2/4]

NvU32 _NVVIOOUTPUTCONFIG_V1::syncEnable

Sync enable (TRUE to use syncSource)

◆ syncEnable [3/4]

NvU32 _NVVIOOUTPUTCONFIG_V2::syncEnable

Sync enable (TRUE to use syncSource)

◆ syncEnable [4/4]

NvU32 _NVVIOOUTPUTCONFIG_V3::syncEnable

Sync enable (TRUE to use syncSource)

◆ syncFormat

NVVIOSIGNALFORMAT _NVVIOOUTPUTSTATUS::syncFormat

Sync format.

◆ SyncMode

NV_PRESENT_BARRIER_SYNC_MODE _NV_PRESENT_BARRIER_FRAME_STATISTICS::SyncMode

The presentBarrier mode of this client from last present call.

◆ syncSkew [1/2]

NV_GSYNC_DELAY _NV_GSYNC_CONTROL_PARAMS_V1::syncSkew

The time delay between the frame sync signal and the GPUs signal.

◆ syncSkew [2/2]

NV_GSYNC_DELAY _NV_GSYNC_CONTROL_PARAMS_V2::syncSkew

The time delay between the frame sync signal and the GPUs signal.

◆ syncSource [1/4]

NVVIOSYNCSOURCE _NVVIOOUTPUTSTATUS::syncSource

Sync source.

◆ syncSource [2/4]

NVVIOSYNCSOURCE _NVVIOOUTPUTCONFIG_V1::syncSource

Sync source.

◆ syncSource [3/4]

NVVIOSYNCSOURCE _NVVIOOUTPUTCONFIG_V2::syncSource

Sync source.

◆ syncSource [4/4]

NVVIOSYNCSOURCE _NVVIOOUTPUTCONFIG_V3::syncSource

Sync source.

◆ syncSourceIsOutput [1/2]

NvU32 _NV_GSYNC_CONTROL_PARAMS_V1::syncSourceIsOutput

Set this to make house sync as an output; valid only when NV_GSYNC_CONTROL_PARAMS::source is NVAPI_GSYNC_SYNC_SOURCE_VSYNC on P2061 boards. syncSourceIsOutput should always be NVAPI_GSYNC_SYNC_SOURCE_HOUSESYNC i.e. 0 on P2060 boards or when NV_GSYNC_CONTROL_PARAMS::source is set to NVAPI_GSYNC_SYNC_SOURCE_HOUSESYNC.

◆ syncSourceIsOutput [2/2]

NvU32 _NV_GSYNC_CONTROL_PARAMS_V2::syncSourceIsOutput

Set this to make house sync as an output; valid only when NV_GSYNC_CONTROL_PARAMS::source is NVAPI_GSYNC_SYNC_SOURCE_VSYNC on P2061 boards. syncSourceIsOutput should always be NVAPI_GSYNC_SYNC_SOURCE_HOUSESYNC i.e. 0 on P2060 boards or when NV_GSYNC_CONTROL_PARAMS::source is set to NVAPI_GSYNC_SYNC_SOURCE_HOUSESYNC.

◆ syncState

NVAPI_GSYNC_DISPLAY_SYNC_STATE _NV_GSYNC_DISPLAY::syncState

Is this display slave/master (Retrieved with topology or set by caller for enable/disable sync)

◆ szAdapterString

NvAPI_ShortString NV_DISPLAY_DRIVER_VERSION::szAdapterString

◆ szBuildBaseBranch

NvAPI_ShortString _NV_DISPLAY_DRIVER_INFO_V2::szBuildBaseBranch

(OUT) Contains the driver base branch string after successful return.

◆ szBuildBranch [1/2]

NvAPI_ShortString _NV_DISPLAY_DRIVER_INFO::szBuildBranch

Contains the driver-branch string after successful return.

◆ szBuildBranch [2/2]

NvAPI_ShortString _NV_DISPLAY_DRIVER_INFO_V2::szBuildBranch

Contains the driver-branch string after successful return.

◆ szBuildBranchString

NvAPI_ShortString NV_DISPLAY_DRIVER_VERSION::szBuildBranchString

◆ szChipsetName [1/4]

NvAPI_ShortString NV_CHIPSET_INFO_v4::szChipsetName

Chipset device Name.

◆ szChipsetName [2/4]

NvAPI_ShortString NV_CHIPSET_INFO_v3::szChipsetName

device Name

◆ szChipsetName [3/4]

NvAPI_ShortString NV_CHIPSET_INFO_v2::szChipsetName

device Name

◆ szChipsetName [4/4]

NvAPI_ShortString NV_CHIPSET_INFO_v1::szChipsetName

◆ szSubSysVendorName [1/2]

NvAPI_ShortString NV_CHIPSET_INFO_v4::szSubSysVendorName

subsystem vendor Name

◆ szSubSysVendorName [2/2]

NvAPI_ShortString NV_CHIPSET_INFO_v3::szSubSysVendorName

subsystem vendor Name

◆ szVendorName [1/4]

NvAPI_ShortString NV_CHIPSET_INFO_v4::szVendorName

Chipset vendor Name.

◆ szVendorName [2/4]

NvAPI_ShortString NV_CHIPSET_INFO_v3::szVendorName

vendor Name

◆ szVendorName [3/4]

NvAPI_ShortString NV_CHIPSET_INFO_v2::szVendorName

vendor Name

◆ szVendorName [4/4]

NvAPI_ShortString NV_CHIPSET_INFO_v1::szVendorName

◆ [struct] [1/5]

struct { ... } NV_VIEW_TARGET_INFO::target[NVAPI_MAX_VIEW_TARGET]

◆ target [2/5]

NV_THERMAL_TARGET NV_GPU_THERMAL_SETTINGS_V1::target

Thermal sensor targeted @ GPU, memory, chipset, powersupply, Visual Computing Device, etc.

◆ [] [3/5]

NV_THERMAL_TARGET { ... } ::target

Thermal sensor targeted @ GPU, memory, chipset, powersupply, Visual Computing Device, etc.

◆ target [4/5]

NV_THERMAL_TARGET NV_GPU_THERMAL_SETTINGS_V2::target

Thermal sensor targeted - GPU, memory, chipset, powersupply, Visual Computing Device, etc.

◆ [] [5/5]

NV_THERMAL_TARGET { ... } ::target

Thermal sensor targeted - GPU, memory, chipset, powersupply, Visual Computing Device, etc.

◆ target_max_luminance [1/4]

NvU16 _NV_HDR_CAPABILITIES_V2::target_max_luminance

Represents max luminance level of sink.

◆ [] [2/4]

NvU16 { ... } ::target_max_luminance

Represents max luminance level of sink.

◆ [] [3/4]

NvU16 { ... } ::target_max_luminance

Represents max luminance level of sink.

◆ target_max_luminance [4/4]

NvU16 _NV_HDR_CAPABILITIES_V3::target_max_luminance

Represents max luminance level of sink.

◆ [] [1/4]

NvU16 { ... } ::target_min_luminance

Represents min luminance level of Sink.

◆ target_min_luminance [2/4]

NvU16 _NV_HDR_CAPABILITIES_V2::target_min_luminance

Represents min luminance level of Sink.

◆ [] [3/4]

NvU16 { ... } ::target_min_luminance

Represents min luminance level of Sink.

◆ target_min_luminance [4/4]

NvU16 _NV_HDR_CAPABILITIES_V3::target_min_luminance

Represents min luminance level of Sink.

◆ targetDisplayHeight

NvU32 _NV_SCANOUT_INFORMATION::targetDisplayHeight

Vertical size of the active resolution scanned out to the display.

◆ targetDisplayWidth

NvU32 _NV_SCANOUT_INFORMATION::targetDisplayWidth

Horizontal size of the active resolution scanned out to the display.

◆ targetId

NvU32 _NV_DISPLAYCONFIG_PATH_TARGET_INFO_V2::targetId

Windows CCD target ID. Must be present only for non-NVIDIA adapter, for NVIDIA adapter this parameter is ignored.

◆ TargetIndependentRasterWithDepth

BOOL _NV_D3D11_FEATURE_DATA_RASTERIZER_SUPPORT::TargetIndependentRasterWithDepth

◆ TargetIndepentRasterWithDepth [1/2]

bool NvAPI_D3D11_RASTERIZER_DESC_EX::TargetIndepentRasterWithDepth

◆ TargetIndepentRasterWithDepth [2/2]

bool NVAPI_D3D12_PSO_RASTERIZER_STATE_DESC_V1::TargetIndepentRasterWithDepth

◆ targetInfo [1/2]

NV_DISPLAYCONFIG_PATH_TARGET_INFO_V1* _NV_DISPLAYCONFIG_PATH_INFO_V1::targetInfo

◆ targetInfo [2/2]

NV_DISPLAYCONFIG_PATH_TARGET_INFO_V2* _NV_DISPLAYCONFIG_PATH_INFO_V2::targetInfo

◆ targetInfoCount [1/2]

NvU32 _NV_DISPLAYCONFIG_PATH_INFO_V1::targetInfoCount

Number of elements in targetInfo array.

◆ targetInfoCount [2/2]

NvU32 _NV_DISPLAYCONFIG_PATH_INFO_V2::targetInfoCount

Number of elements in targetInfo array.

◆ targetViewportRect

NvSBox _NV_SCANOUT_INFORMATION::targetViewportRect

Area inside the rect described by targetDisplayWidth/Height sourceViewportRect is scanned out to.

◆ TemporaryResource [1/4]

NV_D3D11_META_COMMAND_RESOURCE NV_D3D11_META_COMMAND_EXECUTE_CONVOLUTION_EX_DESC::TemporaryResource

◆ TemporaryResource [2/4]

NV_D3D11_META_COMMAND_RESOURCE NV_D3D11_META_COMMAND_EXECUTE_GEMM_DESC::TemporaryResource

◆ TemporaryResource [3/4]

D3D12_GPU_VIRTUAL_ADDRESS NV_D3D12_META_COMMAND_EXECUTE_CONVOLUTION_EX_DESC::TemporaryResource

◆ TemporaryResource [4/4]

NvU64 NV_D3D12_META_COMMAND_EXECUTE_GEMM_DESC::TemporaryResource

◆ tensorCores

NvU32 _NV_GPU_INFO_V2::tensorCores

Number of "Tensor Cores" supported by the GPU.

◆ testColorChange

NvU32 NV_DISPLAY_PORT_CONFIG::testColorChange

If testing mode, skip validation.

◆ testLinkTrain

NvU32 NV_DISPLAY_PORT_CONFIG::testLinkTrain

If testing mode, skip validation.

◆ texDesc

D3D12_CPU_DESCRIPTOR_HANDLE NVAPI_D3D12_GET_CUDA_MERGED_TEXTURE_SAMPLER_OBJECT_PARAMS::texDesc

[in] CPU descriptor handle of the texture (SRV)

◆ Texture2D [1/2]

NV_TEX2D_SRRV _NV_D3D11_SHADING_RATE_RESOURCE_VIEW_DESC_V1::Texture2D

◆ [] [2/2]

NV_TEX2D_SRRV { ... } ::Texture2D

◆ Texture2DArray [1/2]

NV_TEX2D_ARRAY_SRRV _NV_D3D11_SHADING_RATE_RESOURCE_VIEW_DESC_V1::Texture2DArray

◆ [] [2/2]

NV_TEX2D_ARRAY_SRRV { ... } ::Texture2DArray

◆ textureHandle

NvU64 NVAPI_D3D12_GET_CUDA_MERGED_TEXTURE_SAMPLER_OBJECT_PARAMS::textureHandle

[out] A variable that receives the driver handle

◆ textureRect

NvSBox* NV_SCANOUT_WARPING_DATA::textureRect

rectangle in desktop coordinates describing the source area for the warping

◆ timeInQueueUs

NvS32 _NV_SET_REFLEX_SYNC_PARAMS::timeInQueueUs

(IN) Amount of time in the completed frame queue. Can be negative. (0 means N/A)

◆ timeInQueueUsTarget

NvU32 _NV_SET_REFLEX_SYNC_PARAMS::timeInQueueUsTarget

(IN) Target amount of time in the completed frame queue. (0 means N/A)

◆ Timestamp

NvU64 _NV_FOVEATED_RENDERING_UPDATE_GAZE_DATA_PARAMS::Timestamp

(IN) Timestamp at which the gaze data has been captured. Should be larger than timestamp provided at previous update.

◆ timestamp

NvU64 _NV_GPU_CLIENT_CALLBACK_UTILIZATION_DATA_V1::timestamp

[out] Time at which data was collected. Represented as elapsed microseconds since 00:00:00 UTC on January 1, 1970.

◆ timeStampms

NvU64 NV_GPU_CLIENT_ILLUM_DEVICE_SYNC_V1::timeStampms

Time stamp value required for synchronization.

◆ timing [1/2]

NV_TIMING _NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_V1::timing

Scan out timing, valid only if timingOverride == NV_TIMING_OVERRIDE_CUST The value NV_TIMING::NV_TIMINGEXT::rrx1k is obtained from the EDID. The driver may tweak this value for HDTV, stereo, etc., before reporting it to the OS.

◆ timing [2/2]

NV_TIMING NV_CUSTOM_DISPLAY::timing

Timing used to program TMDS/DAC/LVDS/HDMI/TVEncoder, etc.

◆ timingOverride

NV_TIMING_OVERRIDE _NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_V1::timingOverride

Ignored if timingOverride == NV_TIMING_OVERRIDE_CURRENT.

◆ top_bar

NvU32 NV_INFOFRAME_VIDEO::top_bar

◆ topo

NV_MOSAIC_TOPO NV_MOSAIC_TOPO_BRIEF::topo

The topology.

◆ topoBriefs [1/2]

NV_MOSAIC_TOPO_BRIEF _NV_MOSAIC_SUPPORTED_TOPO_INFO_V1::topoBriefs[NV_MOSAIC_TOPO_MAX]

List of supported topologies with only brief details.

◆ topoBriefs [2/2]

NV_MOSAIC_TOPO_BRIEF _NV_MOSAIC_SUPPORTED_TOPO_INFO_V2::topoBriefs[NV_MOSAIC_TOPO_MAX]

List of supported topologies with only brief details.

◆ topoBriefsCount [1/2]

NvU32 _NV_MOSAIC_SUPPORTED_TOPO_INFO_V1::topoBriefsCount

Number of topologies in below array.

◆ topoBriefsCount [2/2]

NvU32 _NV_MOSAIC_SUPPORTED_TOPO_INFO_V2::topoBriefsCount

Number of topologies in below array.

◆ topos [1/2]

NV_MOSAIC_TOPO_DETAILS NV_MOSAIC_TOPO_GROUP::topos[NV_MOSAIC_MAX_TOPO_PER_TOPO_GROUP]

◆ topos [2/2]

NV_MOSAIC_TOPOLOGY NV_MOSAIC_SUPPORTED_TOPOLOGIES::topos[NVAPI_MAX_MOSAIC_TOPOS]

Maximum number of topologies.

◆ totalCount

NvU32 NV_MOSAIC_SUPPORTED_TOPOLOGIES::totalCount

Count of valid topologies.

◆ TransA

NvU64 NV_META_COMMAND_CREATE_GEMM_DESC::TransA

◆ TransB

NvU64 NV_META_COMMAND_CREATE_GEMM_DESC::TransB

◆ triangleMicromapBaseLocation

NvU32 _NVAPI_D3D12_RAYTRACING_GEOMETRY_DMM_ATTACHMENT_DESC::triangleMicromapBaseLocation

Constant added to all DMM indices in displacementMicromapIndexBuffer.

◆ triangleMicromapIndexBuffer

D3D12_GPU_VIRTUAL_ADDRESS_AND_STRIDE _NVAPI_D3D12_RAYTRACING_GEOMETRY_DMM_ATTACHMENT_DESC::triangleMicromapIndexBuffer

Optional buffer specifying which DMM index to use for each triangle; if NULL, there is a 1:1 mapping between input triangles and DMM Array entries. For BLAS updates, this input buffer must match that of the original build.

◆ triangleMicromapIndexFormat

DXGI_FORMAT _NVAPI_D3D12_RAYTRACING_GEOMETRY_DMM_ATTACHMENT_DESC::triangleMicromapIndexFormat

Format of displacementMicromapIndexBuffer, either DXGI_FORMAT_R32_UINT or DXGI_FORMAT_R16_UINT.

◆ trianglePrimitiveFlagsBuffer

D3D12_GPU_VIRTUAL_ADDRESS_AND_STRIDE _NVAPI_D3D12_RAYTRACING_GEOMETRY_DMM_ATTACHMENT_DESC::trianglePrimitiveFlagsBuffer

Optional, per-triangle UINT8 mode flags (NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_PRIMITIVE_FLAGS)

◆ triangles [1/4]

D3D12_RAYTRACING_GEOMETRY_TRIANGLES_DESC _NVAPI_D3D12_RAYTRACING_GEOMETRY_DMM_TRIANGLES_DESC::triangles

Triangle mesh descriptor.

◆ triangles [2/4]

D3D12_RAYTRACING_GEOMETRY_TRIANGLES_DESC _NVAPI_D3D12_RAYTRACING_GEOMETRY_OMM_TRIANGLES_DESC::triangles

Triangle mesh descriptor.

◆ triangles [3/4]

D3D12_RAYTRACING_GEOMETRY_TRIANGLES_DESC _NVAPI_D3D12_RAYTRACING_GEOMETRY_DESC_EX::triangles

Describes triangle geometry if type is NVAPI_D3D12_RAYTRACING_GEOMETRY_TYPE_TRIANGLES_EX. Otherwise, this parameter is unused (space repurposed in a union).

◆ [] [4/4]

D3D12_RAYTRACING_GEOMETRY_TRIANGLES_DESC { ... } ::triangles

Describes triangle geometry if type is NVAPI_D3D12_RAYTRACING_GEOMETRY_TYPE_TRIANGLES_EX. Otherwise, this parameter is unused (space repurposed in a union).

◆ tvFormat [1/4]

NV_DISPLAY_TV_FORMAT NV_DISPLAY_PATH::tvFormat

(IN) To choose the last TV format set this value to NV_DISPLAY_TV_FORMAT_NONE

◆ tvFormat [2/4]

NV_DISPLAY_TV_FORMAT _NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_V1::tvFormat

(IN) to choose the last TV format set this value to NV_DISPLAY_TV_FORMAT_NONE In case of NvAPI_DISP_GetDisplayConfig(), this field will indicate the currently applied TV format; if no TV format is applied, this field will have NV_DISPLAY_TV_FORMAT_NONE value. In case of NvAPI_DISP_SetDisplayConfig(), this field should only be set in case of TVs; for other displays this field will be ignored and resolution & refresh rate specified in input will be used to apply the TV format.

◆ [] [3/4]

NvU32 { ... } ::tvFormat

The actual analog HD/SDTV format. Used when the timing type is NV_TIMING_OVERRIDE_ANALOG_TV and width==height==rr==0.

◆ tvFormat [4/4]

NvU32 NV_TIMING_FLAG::tvFormat

The actual analog HD/SDTV format. Used when the timing type is NV_TIMING_OVERRIDE_ANALOG_TV and width==height==rr==0.

◆ txSublinkStatus [1/2]

NvU8 NVLINK_LINK_STATUS_INFO_V1::txSublinkStatus

This field specifies the current state of TX sublink.See NVAPI_NVLINK_GET_NVLINK_STATUS_SUBLINK_TX_STATE_* for possible values.

◆ txSublinkStatus [2/2]

NvU8 NVLINK_LINK_STATUS_INFO_V2::txSublinkStatus

This field specifies the current state of TX sublink.See NVAPI_NVLINK_GET_NVLINK_STATUS_SUBLINK_TX_STATE_* for possible values.

◆ type [1/9]

NV_GPU_CLIENT_ILLUM_DEVICE_TYPE _NV_GPU_CLIENT_ILLUM_DEVICE_INFO_V1::type

Type of the illumination device.

◆ type [2/9]

NV_GPU_CLIENT_ILLUM_DEVICE_TYPE NV_GPU_CLIENT_ILLUM_DEVICE_CONTROL_V1::type

Type of the illum device.

◆ type [3/9]

NV_GPU_CLIENT_ILLUM_ZONE_TYPE _NV_GPU_CLIENT_ILLUM_ZONE_INFO_V1::type

◆ type [4/9]

NV_GPU_CLIENT_ILLUM_ZONE_TYPE _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_V1::type

◆ type [5/9]

NvU8 NV_INFOFRAME_DATA::type

type of infoframe

◆ type [6/9]

NV_TIMING_OVERRIDE _NV_TIMING_INPUT::type

Timing type(formula) to use for calculating the timing.

◆ type [7/9]

NVAPI_D3D12_GET_CUDA_INDEPENDENT_DESCRIPTOR_OBJECT_TYPE NVAPI_D3D12_GET_CUDA_INDEPENDENT_DESCRIPTOR_OBJECT_PARAMS::type

[in] Type of the descriptor

◆ type [8/9]

NVAPI_D3D12_RAYTRACING_GEOMETRY_TYPE_EX _NVAPI_D3D12_RAYTRACING_GEOMETRY_DESC_EX::type

The type of geometry stored in the union of this structure.

◆ type [9/9]

D3D12_RAYTRACING_ACCELERATION_STRUCTURE_TYPE _NVAPI_D3D12_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_INPUTS_EX::type

Whether a top-level acceleration structure (TLAS) or bottom-level acceleration structure (BLAS) will be built using this information.

◆ typeId

NV_GPU_PERF_PSTATE20_CLOCK_TYPE_ID NV_GPU_PSTATE20_CLOCK_ENTRY_V1::typeId

Clock type ID.

◆ [] [1/2]

NvU32 { ... } ::u32CurrentValue

Accessing current DWORD value of this setting.

◆ u32CurrentValue [2/2]

NvU32 _NVDRS_SETTING_V1::u32CurrentValue

Accessing current DWORD value of this setting.

◆ [] [1/2]

NvU32 { ... } ::u32DefaultValue

Accessing default DWORD value of this setting.

◆ u32DefaultValue [2/2]

NvU32 _NVDRS_SETTING_VALUES::u32DefaultValue

Accessing default DWORD value of this setting.

◆ u32PredefinedValue [1/2]

NvU32 _NVDRS_SETTING_V1::u32PredefinedValue

Accessing default DWORD value of this setting.

◆ [] [2/2]

NvU32 { ... } ::u32PredefinedValue

Accessing default DWORD value of this setting.

◆ u32Value [1/2]

NvU32 _NVDRS_SETTING_VALUES::u32Value

< NOT mixed types.

All possible DWORD values for a setting

◆ [] [2/2]

NvU32 { ... } ::u32Value

< NOT mixed types.

All possible DWORD values for a setting

◆ uavSlot

NvU32 NVAPI_D3D12_PSO_SET_SHADER_EXTENSION_SLOT_DESC_V1::uavSlot

◆ uBlue [1/2]

NvU16 _NVVIOGAMMARAMP10::uBlue[1024]

Blue channel gamma ramp (10-bit index, 16-bit values)

◆ uBlue [2/2]

NvU16 _NVVIOGAMMARAMP8::uBlue[256]

Blue channel gamma ramp (8-bit index, 16-bit values)

◆ uEnabled

NvU32 _NVVIOCOMPOSITERANGE::uEnabled

◆ uGreen [1/2]

NvU16 _NVVIOGAMMARAMP10::uGreen[1024]

Green channel gamma ramp (10-bit index, 16-bit values)

◆ uGreen [2/2]

NvU16 _NVVIOGAMMARAMP8::uGreen[256]

Green channel gamma ramp (8-bit index, 16-bit values)

◆ uMax

NvU32 _NVVIOCOMPOSITERANGE::uMax

◆ uMin

NvU32 _NVVIOCOMPOSITERANGE::uMin

◆ [] [1/2]

NvU64 { ... } ::unused

◆ unused [2/2]

NvU64 NV_D3D11_META_COMMAND_RESOURCE::unused

◆ uPowerOn

NvU32 _NVVIOOUTPUTSTATUS::uPowerOn

TRUE: indicates there is sufficient power.

◆ UpsampleMode

NV_META_COMMAND_CONVOLUTION_UPSAMPLE_MODE NV_META_COMMAND_CONVOLUTION_FUSE_DESC::UpsampleMode

◆ uRange

NvU32 _NVVIOCOMPOSITERANGE::uRange

◆ uRed [1/2]

NvU16 _NVVIOGAMMARAMP10::uRed[1024]

Red channel gamma ramp (10-bit index, 16-bit values)

◆ uRed [2/2]

NvU16 _NVVIOGAMMARAMP8::uRed[256]

Red channel gamma ramp (8-bit index, 16-bit values)

◆ UseAttributeSkipMask [1/2]

BOOL NvAPI_D3D11_CREATE_GEOMETRY_SHADER_EX_V5::UseAttributeSkipMask

◆ UseAttributeSkipMask [2/2]

BOOL NVAPI_D3D12_PSO_GEOMETRY_SHADER_DESC_V5::UseAttributeSkipMask

◆ UseCoordinateSwizzle [1/2]

BOOL NvAPI_D3D11_CREATE_GEOMETRY_SHADER_EX_V5::UseCoordinateSwizzle

◆ UseCoordinateSwizzle [2/2]

BOOL NVAPI_D3D12_PSO_GEOMETRY_SHADER_DESC_V5::UseCoordinateSwizzle

◆ userFriendlyName [1/4]

NvAPI_UnicodeString _NVDRS_APPLICATION_V1::userFriendlyName

UserFriendly name of the Application.

◆ userFriendlyName [2/4]

NvAPI_UnicodeString _NVDRS_APPLICATION_V2::userFriendlyName

UserFriendly name of the Application.

◆ userFriendlyName [3/4]

NvAPI_UnicodeString _NVDRS_APPLICATION_V3::userFriendlyName

UserFriendly name of the Application.

◆ userFriendlyName [4/4]

NvAPI_UnicodeString _NVDRS_APPLICATION_V4::userFriendlyName

UserFriendly name of the Application.

◆ UseSpecificShaderExt [1/8]

BOOL NvAPI_D3D11_CREATE_GEOMETRY_SHADER_EX_V5::UseSpecificShaderExt

◆ UseSpecificShaderExt [2/8]

BOOL NvAPI_D3D11_CREATE_VERTEX_SHADER_EX_V3::UseSpecificShaderExt

◆ UseSpecificShaderExt [3/8]

BOOL NvAPI_D3D11_CREATE_HULL_SHADER_EX_V2::UseSpecificShaderExt

◆ UseSpecificShaderExt [4/8]

BOOL NvAPI_D3D11_CREATE_DOMAIN_SHADER_EX_V3::UseSpecificShaderExt

◆ UseSpecificShaderExt [5/8]

BOOL NVAPI_D3D12_PSO_GEOMETRY_SHADER_DESC_V5::UseSpecificShaderExt

◆ UseSpecificShaderExt [6/8]

BOOL NVAPI_D3D12_PSO_VERTEX_SHADER_DESC_V3::UseSpecificShaderExt

◆ UseSpecificShaderExt [7/8]

BOOL NVAPI_D3D12_PSO_HULL_SHADER_DESC_V2::UseSpecificShaderExt

◆ UseSpecificShaderExt [8/8]

BOOL NVAPI_D3D12_PSO_DOMAIN_SHADER_DESC_V3::UseSpecificShaderExt

◆ UseViewportMask [1/2]

BOOL NvAPI_D3D11_CREATE_GEOMETRY_SHADER_EX_V5::UseViewportMask

◆ UseViewportMask [2/2]

BOOL NVAPI_D3D12_PSO_GEOMETRY_SHADER_DESC_V5::UseViewportMask

◆ UseWithFastGS [1/9]

BOOL NvAPI_D3D11_CREATE_VERTEX_SHADER_EX_V2::UseWithFastGS

◆ UseWithFastGS [2/9]

BOOL NvAPI_D3D11_CREATE_VERTEX_SHADER_EX_V3::UseWithFastGS

◆ UseWithFastGS [3/9]

BOOL NvAPI_D3D11_CREATE_HULL_SHADER_EX_V1::UseWithFastGS

◆ UseWithFastGS [4/9]

BOOL NvAPI_D3D11_CREATE_HULL_SHADER_EX_V2::UseWithFastGS

◆ UseWithFastGS [5/9]

BOOL NvAPI_D3D11_CREATE_DOMAIN_SHADER_EX_V2::UseWithFastGS

◆ UseWithFastGS [6/9]

BOOL NvAPI_D3D11_CREATE_DOMAIN_SHADER_EX_V3::UseWithFastGS

◆ UseWithFastGS [7/9]

BOOL NVAPI_D3D12_PSO_VERTEX_SHADER_DESC_V2::UseWithFastGS

◆ UseWithFastGS [8/9]

BOOL NVAPI_D3D12_PSO_HULL_SHADER_DESC_V1::UseWithFastGS

◆ UseWithFastGS [9/9]

BOOL NVAPI_D3D12_PSO_DOMAIN_SHADER_DESC_V2::UseWithFastGS

◆ uSyncSourceLocked

NvU32 _NVVIOOUTPUTSTATUS::uSyncSourceLocked

genlocked to framelocked to ref signal

◆ utilId

NV_GPU_CLIENT_UTIL_DOMAIN_ID _NV_GPU_CLIENT_UTILIZATION_DATA_V1::utilId

[out] Utilization domain identifier.

◆ [struct]

struct { ... } NV_GPU_DYNAMIC_PSTATES_INFO_EX::utilization[NVAPI_MAX_GPU_UTILIZATIONS]

◆ utilizationPercent

NvU32 _NV_GPU_CLIENT_UTILIZATION_DATA_V1::utilizationPercent

[out] Percentage of time where the domain is considered busy since the last sample. Units of percent*100; i.e. 5000 = 50%.

◆ utils

NV_GPU_CLIENT_UTILIZATION_DATA_V1 _NV_GPU_CLIENT_CALLBACK_UTILIZATION_DATA_V1::utils[NV_GPU_CLIENT_UTIL_DOMAINS_MAX_V1]

[out] Status data for each utilization domain.

◆ validityMask

NvU32 NV_MOSAIC_TOPO_DETAILS::validityMask

0 means topology is valid with the current hardware. If not 0, inspect bits against NV_MOSAIC_TOPO_VALIDITY_*.

◆ value

NvS32 NV_GPU_PERF_PSTATES20_PARAM_DELTA::value

Value of parameter delta (in respective units [kHz, uV])

◆ Value [1/2]

NvU32 _NV_GPU_GET_ILLUMINATION_PARM_V1::Value

A DWORD that will contain the current value of the specified attribute. This is specified as a percentage of the full range of the attribute (0-100; 0 = off, 100 = full brightness)

◆ Value [2/2]

NvU32 _NV_GPU_SET_ILLUMINATION_PARM_V1::Value

A DWORD containing the new value for the specified attribute. This should be specified as a percentage of the full range of the attribute (0-100; 0 = off, 100 = full brightness) If a value is specified outside this range, NVAPI_INVALID_ARGUMENT will be returned.

◆ valueData

NvU8 _NVDRS_BINARY_SETTING::valueData[NVAPI_BINARY_DATA_MAX]

◆ valueLength

NvU32 _NVDRS_BINARY_SETTING::valueLength

valueLength should always be in number of bytes.

◆ [struct]

struct { ... } NV_GPU_PERF_PSTATES20_PARAM_DELTA::valueRange

◆ vblankIntervalUs

NvU32 _NV_SET_REFLEX_SYNC_PARAMS::vblankIntervalUs

(IN) Interval between VBLANKs in microseconds. (0 means N/A)

◆ VBorder

NvU16 _NV_TIMING::VBorder

vertical border

◆ vcdb [1/2]

NV_MONITOR_CAPS_VCDB _NV_MONITOR_CAPABILITIES_V1::vcdb

◆ [] [2/2]

NV_MONITOR_CAPS_VCDB { ... } ::vcdb

◆ vendorId [1/4]

NvU32 NV_CHIPSET_INFO_v4::vendorId

Chipset vendor identification.

◆ vendorId [2/4]

NvU32 NV_CHIPSET_INFO_v3::vendorId

vendor ID

◆ vendorId [3/4]

NvU32 NV_CHIPSET_INFO_v2::vendorId

vendor ID

◆ vendorId [4/4]

NvU32 NV_CHIPSET_INFO_v1::vendorId

◆ version [1/230]

NvU32 NV_EDID_V1::version

◆ version [2/230]

NvU32 NV_EDID_V2::version

Structure version.

◆ version [3/230]

NvU32 NV_EDID_V3::version

Structure version.

◆ version [4/230]

NvU32 NV_VIEW_TARGET_INFO::version

(IN) structure version

◆ version [5/230]

NvU32 NV_DISPLAY_PATH_INFO_V3::version

(IN) Structure version

◆ version [6/230]

NvU32 NV_DISPLAY_PATH_INFO::version

(IN) Structure version

◆ version [7/230]

NvU32 _NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_V1::version

◆ version [8/230]

NvU32 _NV_DISPLAYCONFIG_PATH_INFO_V1::version

◆ version [9/230]

NvU32 _NV_DISPLAYCONFIG_PATH_INFO_V2::version

◆ version [10/230]

NvU32 NV_GPU_PERF_PSTATES20_INFO_V1::version

Version info of the structure (NV_GPU_PERF_PSTATES20_INFO_VER<n>)

◆ version [11/230]

NvU32 _NV_GPU_PERF_PSTATES20_INFO_V2::version

Version info of the structure (NV_GPU_PERF_PSTATES20_INFO_VER<n>)

◆ version [12/230]

NvU32 NV_DISPLAY_DRIVER_VERSION::version

◆ version [13/230]

NvU32 _NV_GPU_DISPLAYIDS::version

◆ version [14/230]

NvU32 _NV_BOARD_INFO::version

structure version

◆ version [15/230]

NvU32 NV_GPU_ARCH_INFO_V1::version

◆ version [16/230]

NvU32 NV_GPU_ARCH_INFO_V2::version

◆ version [17/230]

NvU32 NV_I2C_INFO_V1::version

The structure version.

◆ version [18/230]

NvU32 NV_I2C_INFO_V2::version

The structure version.

◆ version [19/230]

NvU32 NV_I2C_INFO_V3::version

The structure version.

◆ version [20/230]

NvU32 NV_GPU_GET_HDCP_SUPPORT_STATUS::version

◆ version [21/230]

NvU32 NV_COMPUTE_GPU_TOPOLOGY_V1::version

Structure version.

◆ version [22/230]

NvU32 _NV_COMPUTE_GPU_TOPOLOGY_V2::version

Structure version.

◆ version [23/230]

NvU32 NV_GPU_ECC_STATUS_INFO::version

Structure version.

◆ version [24/230]

NvU32 NV_GPU_ECC_ERROR_INFO::version

Structure version.

◆ version [25/230]

NvU32 NV_GPU_ECC_CONFIGURATION_INFO::version

◆ version [26/230]

NvU32 NV_EVENT_REGISTER_CALLBACK::version

version field to ensure minimum version compatibility

◆ version [27/230]

NvU32 NV_SCANOUT_INTENSITY_DATA_V1::version

version of this structure

◆ version [28/230]

NvU32 NV_SCANOUT_INTENSITY_DATA_V2::version

version of this structure

◆ version [29/230]

NvU32 _NV_SCANOUT_INTENSITY_STATE_DATA::version

version of this structure

◆ version [30/230]

NvU32 NV_SCANOUT_WARPING_DATA::version

version of this structure

◆ version [31/230]

NvU32 _NV_SCANOUT_WARPING_STATE_DATA::version

version of this structure

◆ version [32/230]

NvU32 _NV_SCANOUT_INFORMATION::version

Structure version, needs to be initialized with NV_SCANOUT_INFORMATION_VER.

◆ version [33/230]

NvU32 _NV_GPU_VIRTUALIZATION_INFO::version

Structure version.

◆ version [34/230]

NvU32 _NV_LOGICAL_GPU_DATA_V1::version

[in] Structure version.

◆ version [35/230]

NvU32 _NV_LICENSE_FEATURE_DETAILS_V1::version

IN - Structure version.

◆ version [36/230]

NvU32 _NV_LICENSE_FEATURE_DETAILS_V2::version

Unused.

◆ version [37/230]

NvU32 _NV_LICENSE_FEATURE_DETAILS_V3::version

Unused.

◆ version [38/230]

NvU32 _NV_LICENSE_FEATURE_DETAILS_V4::version

Unused.

◆ version [39/230]

NvU32 _NV_LICENSABLE_FEATURES_V1::version

IN - Structure version.

◆ version [40/230]

NvU32 _NV_LICENSABLE_FEATURES_V2::version

IN - Structure version.

◆ version [41/230]

NvU32 _NV_LICENSABLE_FEATURES_V3::version

IN - Structure version.

◆ version [42/230]

NvU32 _NV_LICENSABLE_FEATURES_V4::version

IN - Structure version.

◆ version [43/230]

NvU32 NVLINK_GET_CAPS_V1::version

Version of this structure. Must always be first element in this structure.

◆ version [44/230]

NvU32 NVLINK_GET_STATUS_V1::version

Version of this structure. Must always be first element in this structure.

◆ version [45/230]

NvU32 NVLINK_GET_STATUS_V2::version

Version of this structure. Must always be first element in this structure.

◆ version [46/230]

NvU32 _NV_GPU_INFO_V1::version

Structure Version.

◆ version [47/230]

NvU32 _NV_GPU_INFO_V2::version

Structure Version.

◆ version [48/230]

NvU32 _NV_GPU_VR_READY_V1::version

Structure Version.

◆ version [49/230]

NvU32 _NV_GPU_GSP_INFO_V1::version

[in] Structure version

◆ version [50/230]

NvU32 NV_GPU_PERF_PSTATES_INFO_V1::version

◆ version [51/230]

NvU32 NV_GPU_PERF_PSTATES_INFO_V2::version

◆ version [52/230]

NvU32 NV_GPU_DYNAMIC_PSTATES_INFO_EX::version

Structure version.

◆ version [53/230]

NvU32 NV_GPU_THERMAL_SETTINGS_V1::version

structure version

◆ version [54/230]

NvU32 NV_GPU_THERMAL_SETTINGS_V2::version

structure version

◆ version [55/230]

NvU32 NV_GPU_CLOCK_FREQUENCIES_V1::version

Structure version.

◆ version [56/230]

NvU32 NV_GPU_CLOCK_FREQUENCIES_V2::version

Structure version.

◆ version [57/230]

NvU32 _NV_GPU_QUERY_ILLUMINATION_SUPPORT_PARM_V1::version

Version of this structure.

◆ version [58/230]

NvU32 _NV_GPU_GET_ILLUMINATION_PARM_V1::version

Version of this structure.

◆ version [59/230]

NvU32 _NV_GPU_SET_ILLUMINATION_PARM_V1::version

Version of this structure.

◆ version [60/230]

NvU32 _NV_GPU_CLIENT_ILLUM_DEVICE_INFO_PARAMS_V1::version

Version of structure. Must always be first member.

◆ version [61/230]

NvU32 NV_GPU_CLIENT_ILLUM_DEVICE_CONTROL_PARAMS_V1::version

Version of structure. Must always be first member.

◆ version [62/230]

NvU32 _NV_GPU_CLIENT_ILLUM_ZONE_INFO_PARAMS_V1::version

Version of structure. Must always be first member.

◆ version [63/230]

NvU32 _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_PARAMS_V1::version

◆ version [64/230]

NvU32 _NV_DISPLAY_PORT_INFO_V1::version

Structure version.

◆ version [65/230]

NvU32 NV_DISPLAY_PORT_CONFIG::version

Structure version - 2 is the latest.

◆ version [66/230]

NvU32 _NV_HDMI_SUPPORT_INFO_V1::version

Structure version.

◆ version [67/230]

NvU32 _NV_HDMI_SUPPORT_INFO_V2::version

Structure version.

◆ version [68/230]

NvU32 NV_INFOFRAME_PROPERTY::version

◆ version [69/230]

NvU32 NV_INFOFRAME_DATA::version

version of this structure

◆ version [70/230]

NvU32 _NV_COLOR_DATA_V1::version

Version of this structure.

◆ version [71/230]

NvU32 _NV_COLOR_DATA_V2::version

Version of this structure.

◆ version [72/230]

NvU32 _NV_COLOR_DATA_V3::version

Version of this structure.

◆ version [73/230]

NvU32 _NV_COLOR_DATA_V4::version

Version of this structure.

◆ version [74/230]

NvU32 _NV_COLOR_DATA_V5::version

Version of this structure.

◆ version [75/230]

NvU32 _NV_HDR_CAPABILITIES_V1::version

Version of this structure.

◆ version [76/230]

NvU32 _NV_HDR_CAPABILITIES_V2::version

Version of this structure.

◆ version [77/230]

NvU32 _NV_HDR_CAPABILITIES_V3::version

Version of this structure.

◆ version [78/230]

NvU32 _NV_HDR_COLOR_DATA_V1::version

Version of this structure.

◆ version [79/230]

NvU32 _NV_HDR_COLOR_DATA_V2::version

Version of this structure.

◆ version [80/230]

NvU32 _NV_HDR_METADATA_V1::version

Version of this structure.

◆ version [81/230]

NvU32 _NV_TIMING_INPUT::version

(IN) structure version

◆ version [82/230]

NvU32 _NV_MONITOR_CAPABILITIES_V1::version

◆ version [83/230]

NvU32 _NV_MONITOR_COLOR_DATA::version

◆ version [84/230]

NvU32 NV_CUSTOM_DISPLAY::version

◆ version [85/230]

NvU32 _NV_EDID_DATA_V1::version

Structure version.

◆ version [86/230]

NvU32 _NV_EDID_DATA_V2::version

Structure version.

◆ version [87/230]

NvU32 _NV_GET_ADAPTIVE_SYNC_DATA_V1::version

[in] structure version

◆ version [88/230]

NvU32 _NV_SET_ADAPTIVE_SYNC_DATA_V1::version

[in] structure version

◆ version [89/230]

NvU32 _NV_GET_VIRTUAL_REFRESH_RATE_DATA_V1::version

[in] structure version

◆ version [90/230]

NvU32 _NV_SET_VIRTUAL_REFRESH_RATE_DATA_V1::version

[in] structure version

◆ version [91/230]

NvU32 NV_SET_PREFERRED_STEREO_DISPLAY_V1::version

[in] Structure version

◆ version [92/230]

NvU32 NV_GET_PREFERRED_STEREO_DISPLAY_V1::version

[in] Structure version

◆ version [93/230]

NvU32 _NV_MANAGED_DEDICATED_DISPLAY_INFO::version

[in] Version of this structure.

◆ version [94/230]

NvU32 _NV_MANAGED_DEDICATED_DISPLAY_METADATA::version

[in] Version of this structure.

◆ version [95/230]

NvU32 _NV_GET_VRR_INFO_V1::version

[in] Structure version

◆ version [96/230]

NvU32 NV_MOSAIC_TOPO_DETAILS::version

Version of this structure.

◆ version [97/230]

NvU32 NV_MOSAIC_TOPO_BRIEF::version

Version of this structure.

◆ version [98/230]

NvU32 _NV_MOSAIC_DISPLAY_SETTING_V1::version

Version of this structure.

◆ version [99/230]

NvU32 NV_MOSAIC_DISPLAY_SETTING_V2::version

Version of this structure.

◆ version [100/230]

NvU32 _NV_MOSAIC_SUPPORTED_TOPO_INFO_V1::version

Version of this structure.

◆ version [101/230]

NvU32 _NV_MOSAIC_SUPPORTED_TOPO_INFO_V2::version

Version of this structure.

◆ version [102/230]

NvU32 NV_MOSAIC_TOPO_GROUP::version

Version of this structure.

◆ version [103/230]

NvU32 _NV_MOSAIC_GRID_TOPO_DISPLAY_V2::version

Version of this structure.

◆ version [104/230]

NvU32 _NV_MOSAIC_GRID_TOPO_V1::version

Version of this structure.

◆ version [105/230]

NvU32 _NV_MOSAIC_GRID_TOPO_V2::version

Version of this structure.

◆ version [106/230]

NvU32 NV_MOSAIC_DISPLAY_TOPO_STATUS::version

◆ version [107/230]

NvU32 NV_MOSAIC_TOPOLOGY::version

Version number of the mosaic topology.

◆ version [108/230]

NvU32 NV_MOSAIC_SUPPORTED_TOPOLOGIES::version

◆ version [109/230]

NvU32 _NV_GSYNC_CAPABILITIES_V1::version

Version of the structure.

◆ version [110/230]

NvU32 _NV_GSYNC_CAPABILITIES_V2::version

Version of the structure.

◆ version [111/230]

NvU32 _NV_GSYNC_CAPABILITIES_V3::version

Version of the structure.

◆ version [112/230]

NvU32 _NV_GSYNC_GPU::version

Version of the structure.

◆ version [113/230]

NvU32 _NV_GSYNC_DISPLAY::version

Version of the structure.

◆ version [114/230]

NvU32 _NV_GSYNC_DELAY::version

Version of the structure.

◆ version [115/230]

NvU32 _NV_GSYNC_CONTROL_PARAMS_V1::version

Version of the structure.

◆ version [116/230]

NvU32 _NV_GSYNC_CONTROL_PARAMS_V2::version

Version of the structure.

◆ version [117/230]

NvU32 _NV_GSYNC_STATUS::version

Version of the structure.

◆ version [118/230]

NvU32 _NV_GSYNC_STATUS_PARAMS_V1::version

◆ version [119/230]

NvU32 _NV_GSYNC_STATUS_PARAMS_V2::version

◆ version [120/230]

NvU32 NVAPI_ANSEL_CONFIGURATION_STRUCT_V1::version

Structure version.

◆ version [121/230]

UINT _NV_CUSTOM_SEMANTIC::version

◆ version [122/230]

UINT NvAPI_D3D11_CREATE_GEOMETRY_SHADER_EX_V5::version

◆ version [123/230]

UINT NvAPI_D3D11_CREATE_VERTEX_SHADER_EX_V1::version

◆ version [124/230]

UINT NvAPI_D3D11_CREATE_VERTEX_SHADER_EX_V2::version

◆ version [125/230]

UINT NvAPI_D3D11_CREATE_VERTEX_SHADER_EX_V3::version

◆ version [126/230]

UINT NvAPI_D3D11_CREATE_HULL_SHADER_EX_V1::version

◆ version [127/230]

UINT NvAPI_D3D11_CREATE_HULL_SHADER_EX_V2::version

◆ version [128/230]

UINT NvAPI_D3D11_CREATE_DOMAIN_SHADER_EX_V1::version

◆ version [129/230]

UINT NvAPI_D3D11_CREATE_DOMAIN_SHADER_EX_V2::version

◆ version [130/230]

UINT NvAPI_D3D11_CREATE_DOMAIN_SHADER_EX_V3::version

◆ version [131/230]

UINT NvAPI_D3D11_CREATE_PIXEL_SHADER_EX_V1::version

◆ version [132/230]

UINT NvAPI_D3D11_CREATE_PIXEL_SHADER_EX_V2::version

◆ version [133/230]

NvU32 NvAPI_D3D11_CREATE_FASTGS_EXPLICIT_DESC_V1::version

◆ version [134/230]

NvU32 NVAPI_D3D12_PSO_RASTERIZER_STATE_DESC_V1::version

◆ version [135/230]

NvU32 NVAPI_D3D12_PSO_CREATE_FASTGS_EXPLICIT_DESC_V1::version

◆ version [136/230]

NvU32 NVAPI_D3D12_PSO_REQUEST_FAST_GEOMETRY_SHADER_DESC_V1::version

◆ version [137/230]

NvU32 NVAPI_D3D12_PSO_GEOMETRY_SHADER_DESC_V5::version

◆ version [138/230]

NvU32 NVAPI_D3D12_PSO_VERTEX_SHADER_DESC_V1::version

◆ version [139/230]

NvU32 NVAPI_D3D12_PSO_HULL_SHADER_DESC_V1::version

◆ version [140/230]

NvU32 NVAPI_D3D12_PSO_DOMAIN_SHADER_DESC_V1::version

◆ version [141/230]

NvU32 NVAPI_D3D12_PSO_ENABLE_DEPTH_BOUND_TEST_DESC_V1::version

◆ version [142/230]

NvU32 NVAPI_D3D12_PSO_SET_SHADER_EXTENSION_SLOT_DESC_V1::version

◆ version [143/230]

NvU32 _NV_HEAP_PARAMS_V1::version

Version of structure. Must always be first member.

◆ version [144/230]

NvU32 NVAPI_UAV_INFO_V1::version

Structure version.

◆ version [145/230]

NvU32 NVAPI_UAV_INFO_V2::version

Structure version.

◆ version [146/230]

NvU32 NV_GET_GPU_VIRTUAL_ADDRESS_V1::version

[IN]

◆ version [147/230]

NvU32 _NV_RESOURCE_PARAMS_V1::version

Version of structure. Must always be first member.

◆ version [148/230]

NvU32 _NV_MULTIGPU_CAPS_V2::version

The version of the structure.

◆ [] [149/230]

NvU32 { ... } ::version

The version of the structure.

◆ version [150/230]

NvU32 _NV_QUERY_SINGLE_PASS_STEREO_SUPPORT_PARAMS_V1::version

◆ version [151/230]

NvU32 _NV_QUERY_SINGLE_PASS_STEREO_SUPPORT_PARAMS_V2::version

◆ version [152/230]

NvU32 _NV_QUERY_MULTIVIEW_SUPPORT_PARAMS_V1::version

◆ version [153/230]

NvU32 _NV_MULTIVIEW_PARAMS_V1::version

◆ version [154/230]

NvU32 _NV_QUERY_MODIFIED_W_SUPPORT_PARAMS::version

◆ version [155/230]

NvU32 _NV_MODIFIED_W_PARAMS::version

◆ version [156/230]

NvU32 _NV_D3D_LATELATCH_OBJECT_DESC_V1::version

◆ version [157/230]

NvU32 _NV_QUERY_LATELATCH_SUPPORT_PARAMS::version

(IN) Parameter structure version

◆ version [158/230]

__in NvU32 _NV_D3D12_MOSAIC_GETCOMPANIONALLOCATIONS::version

Structure version.

◆ version [159/230]

__in NvU32 _NV_D3D12_MOSAIC_GETVIEWPORTANDGPUPARTITIONS::version

Structure version.

◆ version [160/230]

NvU32 _NV_D3D11_EXCLUSIVE_SCISSOR_RECTS_DESC_V1::version

(IN) Parameter struct version

◆ version [161/230]

NvU32 _NV_D3D11_VIEWPORTS_SHADING_RATE_DESC_V1::version

(IN) Struct version

◆ version [162/230]

NvU32 _NV_D3D11_SHADING_RATE_RESOURCE_VIEW_DESC_V1::version

(IN) Parameter struct version

◆ version [163/230]

NvU32 _NV_PIXEL_SHADING_RATE_SAMPLE_ORDER_TABLE_V1::version

◆ version [164/230]

NvU32 _NV_VRS_HELPER_LATCH_GAZE_PARAMS_V1::version

(IN) Struct version

◆ version [165/230]

NvU32 _NV_FOVEATED_RENDERING_CUSTOM_SHADING_RATE_PRESET_DESC_V1::version

◆ version [166/230]

NvU32 _NV_FOVEATED_RENDERING_CUSTOM_FOVEATION_PATTERN_PRESET_DESC_V1::version

◆ version [167/230]

NvU32 _NV_FOVEATED_RENDERING_DESC_V1::version

(IN) Struct version

◆ version [168/230]

NvU32 _NV_VRS_HELPER_ENABLE_PARAMS_V1::version

(IN) Struct version

◆ version [169/230]

NvU32 _NV_VRS_HELPER_DISABLE_PARAMS_V1::version

(IN) Struct version

◆ version [170/230]

NvU32 _NV_VRS_HELPER_GET_SHADING_RATE_RESOURCE_PARAMS_V1::version

(IN) Struct version

◆ version [171/230]

NvU32 _NV_VRS_HELPER_PURGE_INTERNAL_RESOURCES_PARAMS_V1::version

(IN) Struct version

◆ version [172/230]

NvU32 _NV_VRS_HELPER_INIT_PARAMS_V1::version

(IN) Struct version

◆ version [173/230]

NvU32 _NV_FOVEATED_RENDERING_GAZE_DATA_PER_EYE::version

(IN) Version of the structure

◆ version [174/230]

NvU32 _NV_FOVEATED_RENDERING_UPDATE_GAZE_DATA_PARAMS::version

(IN) Struct version

◆ version [175/230]

NvU32 _NV_GAZE_HANDLER_INIT_PARAMS_V2::version

(IN) Struct version

◆ version [176/230]

NvU32 _NV_GAZE_HANDLER_INIT_PARAMS_V1::version

(IN) Struct version

◆ version [177/230]

NvU32 _NV_SMP_ASSIST_ENABLE_PARAMS_V1::version

(IN) Structure version

◆ version [178/230]

NvU32 _NV_SMP_ASSIST_DISABLE_PARAMS_V1::version

(IN) Structure version

◆ version [179/230]

NvU32 _NV_SMP_ASSIST_GET_CONSTANTS_V3::version

(IN) Structure version

◆ version [180/230]

NvU32 _NV_SMP_ASSIST_SETUP_PARAMS_V1::version

(IN) Structure version

◆ version [181/230]

NvU32 _NV_SMP_ASSIST_UPDATE_INSTANCEDSTEREO_DATA_PARAMS_V1::version

(IN) Structure version

◆ version [182/230]

NvU32 _NV_SMP_ASSIST_INITIALIZE_PARAMS_V1::version

(IN) Structure version

◆ version [183/230]

NvU32 _NV_QUERY_SMP_ASSIST_SUPPORT_PARAMS_V1::version

(IN) Structure version

◆ version [184/230]

NvU32 _NV_GET_SLEEP_STATUS_PARAMS::version

(IN) Structure version

◆ version [185/230]

NvU32 _NV_SET_SLEEP_MODE_PARAMS::version

(IN) Structure version

◆ version [186/230]

NvU32 _NV_SET_REFLEX_SYNC_PARAMS::version

(IN) Structure version

◆ version [187/230]

NvU32 _NV_LATENCY_RESULT_PARAMS::version

(IN) Structure version

◆ version [188/230]

NvU32 _NV_LATENCY_MARKER_PARAMS::version

(IN) Structure version

◆ version [189/230]

NvU32 _NV_ASYNC_FRAME_MARKER_PARAMS_V1::version

(IN) Structure version

◆ version [190/230]

NvU32 _NVAPI_GET_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PREBUILD_INFO_PARAMS_V1::version

[in] Structure version; it should be set to NVAPI_GET_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PREBUILD_INFO_PARAMS_VER.

◆ version [191/230]

NvU32 _NVAPI_GET_RAYTRACING_OPACITY_MICROMAP_ARRAY_PREBUILD_INFO_PARAMS_V1::version

[in] Structure version; it should be set to NVAPI_GET_RAYTRACING_OPACITY_MICROMAP_ARRAY_PREBUILD_INFO_PARAMS_VER.

◆ version [192/230]

NvU32 _NVAPI_D3D12_SET_CREATE_PIPELINE_STATE_OPTIONS_PARAMS_V1::version

[in] Structure version; it should be set to NVAPI_D3D12_SET_CREATE_PIPELINE_STATE_OPTIONS_PARAMS_VER.

◆ version [193/230]

NvU32 _NVAPI_CHECK_DRIVER_MATCHING_IDENTIFIER_EX_PARAMS_V1::version

[in] Structure version; it should be set to NVAPI_CHECK_DRIVER_MATCHING_IDENTIFIER_EX_PARAMS_VER.

◆ version [194/230]

NvU32 _NVAPI_GET_RAYTRACING_ACCELERATION_STRUCTURE_PREBUILD_INFO_EX_PARAMS_V1::version

[in] Structure version; it should be set to NVAPI_GET_RAYTRACING_ACCELERATION_STRUCTURE_PREBUILD_INFO_EX_PARAMS_VER.

◆ version [195/230]

NvU32 _NVAPI_BUILD_RAYTRACING_OPACITY_MICROMAP_ARRAY_PARAMS_V1::version

[in] Structure version; it should be set to NVAPI_BUILD_RAYTRACING_OPACITY_MICROMAP_ARRAY_PARAMS_VER.

◆ version [196/230]

NvU32 _NVAPI_RELOCATE_RAYTRACING_OPACITY_MICROMAP_ARRAY_PARAMS_V1::version

[in] Structure version; it should be set to NVAPI_RELOCATE_RAYTRACING_OPACITY_MICROMAP_ARRAY_PARAMS_VER.

◆ version [197/230]

NvU32 _NVAPI_BUILD_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PARAMS_V1::version

[in] Structure version; it should be set to NVAPI_BUILD_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PARAMS_VER.

◆ version [198/230]

NvU32 _NVAPI_RELOCATE_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PARAMS_V1::version

[in] Structure version; it should be set to NVAPI_RELOCATE_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PARAMS_VER.

◆ version [199/230]

NvU32 _NVAPI_EMIT_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_POSTBUILD_INFO_PARAMS_V1::version

[in] Structure version; it should be set to NVAPI_EMIT_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_POSTBUILD_INFO_PARAMS_VER.

◆ version [200/230]

NvU32 _NVAPI_EMIT_RAYTRACING_OPACITY_MICROMAP_ARRAY_POSTBUILD_INFO_PARAMS_V1::version

[in] Structure version; it should be set to NVAPI_EMIT_RAYTRACING_OPACITY_MICROMAP_ARRAY_POSTBUILD_INFO_PARAMS_VER.

◆ version [201/230]

NvU32 _NVAPI_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_EX_PARAMS_V1::version

[in] Structure version; it should be set to NVAPI_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_EX_PARAMS_VER.

◆ version [202/230]

NvU32 _NV_D3D12_WORKSTATION_FEATURE_PROPERTIES::version

(IN) Structure version

◆ version [203/230]

NvU32 _NVVIOCAPS::version

Structure version.

◆ version [204/230]

NvU32 _NVVIOSTATUS::version

Structure version.

◆ version [205/230]

NvU32 _NVVIOSYNCDELAY::version

Structure version.

◆ version [206/230]

NvU32 _NVVIOCOLORCONVERSION::version

Structure version.

◆ version [207/230]

NvU32 _NVVIOGAMMACORRECTION::version

Structure version.

◆ version [208/230]

NvU32 _NVVIOCONFIG_V1::version

Structure version.

◆ version [209/230]

NvU32 _NVVIOCONFIG_V2::version

Structure version.

◆ version [210/230]

NvU32 _NVVIOCONFIG_V3::version

Structure version.

◆ version [211/230]

NvU32 _NV_VIO_TOPOLOGY::version

◆ version [212/230]

NvU32 _NVVIOPCIINFO::version

Structure version.

◆ version [213/230]

NvU32 _NVAPI_STEREO_CAPS::version

◆ version [214/230]

NvU32 _NVDRS_SETTING_VALUES::version

Structure Version.

◆ version [215/230]

NvU32 _NVDRS_SETTING_V1::version

Structure Version.

◆ version [216/230]

NvU32 _NVDRS_APPLICATION_V1::version

Structure Version.

◆ version [217/230]

NvU32 _NVDRS_APPLICATION_V2::version

Structure Version.

◆ version [218/230]

NvU32 _NVDRS_APPLICATION_V3::version

Structure Version.

◆ version [219/230]

NvU32 _NVDRS_APPLICATION_V4::version

Structure Version.

◆ version [220/230]

NvU32 _NVDRS_PROFILE_V1::version

Structure Version.

◆ version [221/230]

NvU32 NV_CHIPSET_INFO_v4::version

structure version

◆ version [222/230]

NvU32 NV_CHIPSET_INFO_v3::version

structure version

◆ version [223/230]

NvU32 NV_CHIPSET_INFO_v2::version

structure version

◆ version [224/230]

NvU32 NV_CHIPSET_INFO_v1::version

◆ version [225/230]

NvU32 NV_LID_DOCK_PARAMS::version

◆ version [226/230]

NvU32 _NV_DISPLAY_DRIVER_INFO::version

Structure Version.

◆ version [227/230]

NvU32 _NV_DISPLAY_DRIVER_INFO_V2::version

Structure Version.

◆ version [228/230]

NvU32 _NV_PHYSICAL_GPUS::version

◆ version [229/230]

NvU32 _NV_LOGICAL_GPUS::version

◆ version [230/230]

NvU32 _NV_GPU_CLIENT_UTILIZATION_PERIODIC_CALLBACK_SETTINGS_V1::version

[in] Structure Version, must always be first.

◆ vertexBiasAndScaleBuffer

D3D12_GPU_VIRTUAL_ADDRESS_AND_STRIDE _NVAPI_D3D12_RAYTRACING_GEOMETRY_DMM_ATTACHMENT_DESC::vertexBiasAndScaleBuffer

Optional displacement base vertex bias and displacement vector scale buffer. If not supplied, bias defaults to 0 and scale to 1.

◆ vertexBiasAndScaleFormat

DXGI_FORMAT _NVAPI_D3D12_RAYTRACING_GEOMETRY_DMM_ATTACHMENT_DESC::vertexBiasAndScaleFormat

Format of displacementBiasAndScaleBuffer. Supported formats are DXGI_FORMAT_R16G16_FLOAT and DXGI_FORMAT_R32G32_FLOAT.

◆ vertexDisplacementVectorBuffer

D3D12_GPU_VIRTUAL_ADDRESS_AND_STRIDE _NVAPI_D3D12_RAYTRACING_GEOMETRY_DMM_ATTACHMENT_DESC::vertexDisplacementVectorBuffer

Per-vertex displacement vector buffer. This buffer is indexed using the index buffer from the base triangle geometry.

◆ vertexDisplacementVectorFormat

DXGI_FORMAT _NVAPI_D3D12_RAYTRACING_GEOMETRY_DMM_ATTACHMENT_DESC::vertexDisplacementVectorFormat

Format of displacementVectorBuffer. Supported formats are DXGI_FORMAT_R32G32B32_FLOAT, DXGI_FORMAT_R32G32B32A32_FLOAT, and DXGI_FORMAT_R16G16B16A16_FLOAT (The Alpha channel is ignored, and stride can be set accordingly).

◆ vertexFormat

NV_GPU_WARPING_VERTICE_FORMAT NV_SCANOUT_WARPING_DATA::vertexFormat

format of the input vertices

◆ verticalDelay

NvU32 _NVVIOSYNCDELAY::verticalDelay

Vertical delay in lines.

◆ verticalLines

NvU32 _NVVIOVIDEOMODE::verticalLines

Vertical resolution for frame (in lines)

◆ vertices

float* NV_SCANOUT_WARPING_DATA::vertices

width of the input texture

◆ VFrontPorch

NvU16 _NV_TIMING::VFrontPorch

vertical front porch

◆ vic

NvU32 NV_INFOFRAME_VIDEO::vic

◆ vid1Out

NVVIOINPUTOUTPUTSTATUS _NVVIOOUTPUTSTATUS::vid1Out

Video 1 output status.

◆ vid2Out

NVVIOINPUTOUTPUTSTATUS _NVVIOOUTPUTSTATUS::vid2Out

Video 2 output status.

◆ [] [1/2]

NV_INFOFRAME_VIDEO { ... } ::video

◆ video [2/2]

NV_INFOFRAME_VIDEO NV_INFOFRAME_DATA::video

◆ videoBridgePresent [1/2]

NvU32 _NV_MULTIGPU_CAPS_V1::videoBridgePresent

◆ videoBridgePresent [2/2]

NvU32 _NV_MULTIGPU_CAPS_V2::videoBridgePresent

◆ videoLatency

NvU8 _NV_MONITOR_CAPS_VSDB::videoLatency

Byte 6.

◆ videoMode

NVVIOVIDEOMODE _NVVIOSIGNALFORMATDETAIL::videoMode

Video mode for signal format.

◆ videoStandard

NVVIOVIDEOSTANDARD _NVVIOVIDEOMODE::videoStandard

SMPTE standards format.

◆ videoType

NVVIOVIDEOTYPE _NVVIOVIDEOMODE::videoType

HD or SD signal classification.

◆ vidIn

NVVIOCHANNELSTATUS _NVVIOINPUTSTATUS::vidIn[NVAPI_MAX_VIO_JACKS][NVAPI_MAX_VIO_CHANNELS_PER_JACK]

Video input status per channel within a jack.

◆ ViewDimension

NV_SRRV_DIMENSION _NV_D3D11_SHADING_RATE_RESOURCE_VIEW_DESC_V1::ViewDimension

(IN) This declares whether the Shading Rate Surface is a simple 2D Texture or Array of 2D Textures

◆ vioCaps

NvU32 _NVVIODATAFORMATDETAIL::vioCaps

Data format capabilities (NVVIOCAPS_* mask)

◆ vioClass

NvU32 vioClass

◆ [union] [1/3]

union { ... } _NVVIOCONFIG_V1::vioConfig

◆ [union] [2/3]

union { ... } _NVVIOCONFIG_V2::vioConfig

◆ [union] [3/3]

union { ... } _NVVIOCONFIG_V3::vioConfig

◆ vioDeviceCount

NvU32* vioDeviceCount

◆ vioGammaCorrectionType

NvU32 _NVVIOGAMMACORRECTION::vioGammaCorrectionType

Gamma correction type (8-bit or 10-bit)

◆ vioId

NvU32 NVVIOTOPOLOGYTARGET::vioId

device Id of SDI Input/Output device

◆ [union]

union { ... } _NVVIOSTATUS::vioStatus

◆ vioTarget

NVVIOTOPOLOGYTARGET _NV_VIO_TOPOLOGY::vioTarget[NVAPI_MAX_VIO_DEVICES]

Array of video I/O targets.

◆ vioTotalDeviceCount

NvU32 _NV_VIO_TOPOLOGY::vioTotalDeviceCount

How many video I/O targets are valid.

◆ virtualizationMode

NV_VIRTUALIZATION_MODE _NV_GPU_VIRTUALIZATION_INFO::virtualizationMode

one of NV_VIRTUALIZATION_MODE.

◆ vmode [1/2]

NVAPI_GSYNC_VIDEO_MODE _NV_GSYNC_CONTROL_PARAMS_V1::vmode

None, TTL, NTSCPALSECAM, HDTV.

◆ vmode [2/2]

NVAPI_GSYNC_VIDEO_MODE _NV_GSYNC_CONTROL_PARAMS_V2::vmode

None, TTL, NTSCPALSECAM, HDTV.

◆ volt_uV

NvU32 NV_GPU_PSTATE20_BASE_VOLTAGE_ENTRY_V1::volt_uV

Current base voltage settings in [uV].

◆ [struct] [1/4]

struct { ... } NV_GPU_PERF_PSTATES_INFO_V2::voltages[NVAPI_MAX_GPU_PERF_VOLTAGES]

◆ [struct] [2/4]

struct { ... } NV_GPU_PERF_PSTATES_INFO_V2::voltages[NVAPI_MAX_GPU_PERF_VOLTAGES]

◆ voltages [3/4]

NV_GPU_PSTATE20_BASE_VOLTAGE_ENTRY_V1 _NV_GPU_PERF_PSTATES20_INFO_V2::voltages[NVAPI_MAX_GPU_PSTATE20_BASE_VOLTAGES]

Array of voltage entries Valid index range is 0 to numVoltages-1

◆ [] [4/4]

NV_GPU_PSTATE20_BASE_VOLTAGE_ENTRY_V1 { ... } ::voltages[NVAPI_MAX_GPU_PSTATE20_BASE_VOLTAGES]

Array of voltage entries Valid index range is 0 to numVoltages-1

◆ voltDelta_uV

NV_GPU_PERF_PSTATES20_PARAM_DELTA NV_GPU_PSTATE20_BASE_VOLTAGE_ENTRY_V1::voltDelta_uV

◆ vpOffsets

float _NV_SMP_ASSIST_SETUP_PARAMS_V1::vpOffsets[2]

(IN) Default set to 0. If non-zero, MRS/LMS viewports' TopLeftX and TopLeftY will be offset by vpOffsets[0] and vpOffsets[1] respectively.

◆ vsdb [1/2]

NV_MONITOR_CAPS_VSDB _NV_MONITOR_CAPABILITIES_V1::vsdb

◆ [] [2/2]

NV_MONITOR_CAPS_VSDB { ... } ::vsdb

◆ VSVDB_version [1/4]

NvU32 _NV_HDR_CAPABILITIES_V2::VSVDB_version

Version of Vendor Data block,Version 0: 25 bytes Version 1: 14 bytes.

◆ [] [2/4]

NvU32 { ... } ::VSVDB_version

Version of Vendor Data block,Version 0: 25 bytes Version 1: 14 bytes.

◆ VSVDB_version [3/4]

NvU32 _NV_HDR_CAPABILITIES_V3::VSVDB_version

Version of Vendor Data block,Version 0: 25 bytes Version 1: 14 bytes.

◆ [] [4/4]

NvU32 { ... } ::VSVDB_version

Version of Vendor Data block,Version 0: 25 bytes Version 1: 14 bytes.

◆ VSyncPol

NvU8 _NV_TIMING::VSyncPol

vertical sync polarity: 1-negative, 0-positive

◆ VSyncWidth

NvU16 _NV_TIMING::VSyncWidth

vertical sync width

◆ VTotal

NvU16 _NV_TIMING::VTotal

vertical total

◆ VVisible

NvU16 _NV_TIMING::VVisible

vertical visible

◆ w

float NV_VIEWPORTF::w

Width of the viewport.

◆ warningFlags [1/2]

NvU32 NV_MOSAIC_DISPLAY_TOPO_STATUS::warningFlags

(OUT) Any of the NV_MOSAIC_DISPLAYTOPO_WARNING_* flags.

◆ [] [2/2]

NvU32 { ... } ::warningFlags

(OUT) Any of the NV_MOSAIC_DISPLAYTOPO_WARNING_* flags.

◆ warpDown

float _NV_LMS_CUSTOM_CONFIG_V1::warpDown

(IN) LMS params to control warping of the 2 lower quadrants

◆ warpLeft

float _NV_LMS_CUSTOM_CONFIG_V1::warpLeft

(IN) LMS params to control warping of the 2 left quadrants

◆ warpRight

float _NV_LMS_CUSTOM_CONFIG_V1::warpRight

(IN) LMS params to control warping of the 2 right quadrants

◆ warpUp

float _NV_LMS_CUSTOM_CONFIG_V1::warpUp

(IN) LMS params to control warping of the 2 upper quadrants

◆ width [1/9]

NvU32 NV_DISPLAY_PATH::width

(IN) Width of the mode

◆ width [2/9]

NvU32 _NV_RESOLUTION::width

◆ width [3/9]

NvU32 NV_SCANOUT_INTENSITY_DATA_V1::width

width of the input texture

◆ width [4/9]

NvU32 NV_SCANOUT_INTENSITY_DATA_V2::width

width of the input texture

◆ width [5/9]

NvU32 _NV_TIMING_INPUT::width

Visible horizontal size.

◆ width [6/9]

NvU32 NV_CUSTOM_DISPLAY::width

Source surface(source mode) width.

◆ width [7/9]

NvU32 _NV_MOSAIC_DISPLAY_SETTING_V1::width

Per-display width.

◆ width [8/9]

NvU32 NV_MOSAIC_DISPLAY_SETTING_V2::width

Per-display width.

◆ width [9/9]

NvU32 _NVVIOOUTPUTREGION::width

Width of region in pixels.

◆ WindowToClipSplitsX

float _NV_SMP_ASSIST_REMAPCBDATA_V1::WindowToClipSplitsX[2]

◆ WindowToClipSplitsY

float _NV_SMP_ASSIST_REMAPCBDATA_V1::WindowToClipSplitsY[2]

◆ WindowToClipX

float _NV_SMP_ASSIST_REMAPCBDATA_V1::WindowToClipX[3][2]

◆ WindowToClipY

float _NV_SMP_ASSIST_REMAPCBDATA_V1::WindowToClipY[3][2]

◆ WindowToClipZ

float _NV_SMP_ASSIST_REMAPCBDATA_V1::WindowToClipZ[2]

◆ workstationFeatureType

NV_D3D12_WORKSTATION_FEATURE_TYPE _NV_D3D12_WORKSTATION_FEATURE_PROPERTIES::workstationFeatureType

(IN) the type of workstation feature to be queried

◆ [] [1/2]

NvAPI_UnicodeString { ... } ::wszCurrentValue

Accessing current unicode string value of this setting.

◆ wszCurrentValue [2/2]

NvAPI_UnicodeString _NVDRS_SETTING_V1::wszCurrentValue

Accessing current unicode string value of this setting.

◆ wszDefaultValue [1/2]

NvAPI_UnicodeString _NVDRS_SETTING_VALUES::wszDefaultValue

Accessing default unicode string value of this setting.

◆ [] [2/2]

NvAPI_UnicodeString { ... } ::wszDefaultValue

Accessing default unicode string value of this setting.

◆ wszPredefinedValue [1/2]

NvAPI_UnicodeString _NVDRS_SETTING_V1::wszPredefinedValue

Accessing default unicode string value of this setting.

◆ [] [2/2]

NvAPI_UnicodeString { ... } ::wszPredefinedValue

Accessing default unicode string value of this setting.

◆ wszValue [1/2]

NvAPI_UnicodeString _NVDRS_SETTING_VALUES::wszValue

Accessing current unicode string value of this setting.

◆ [] [2/2]

NvAPI_UnicodeString { ... } ::wszValue

Accessing current unicode string value of this setting.

◆ x [1/4]

float NV_VIEWPORTF::x

x-coordinate of the viewport top-left point

◆ x [2/4]

NvS32 _NV_POSITION::x

◆ X

NvU8 _NV_PIXEL_SRSO_2x1::NV_PIXEL_SRSO_2x1_X1::X[2]

◆ x [3/4]

NvU32 _NVAPI_DIM3::x

◆ x [4/4]

NvU32 _NVVIOOUTPUTREGION::x

Horizontal origin in pixels.

◆ X1 [1/6]

struct _NV_PIXEL_SRSO_1x2::NV_PIXEL_SRSO_1x2_X1 _NV_PIXEL_SRSO_1x2::X1

◆ X1 [2/6]

struct _NV_PIXEL_SRSO_2x1::NV_PIXEL_SRSO_2x1_X1 _NV_PIXEL_SRSO_2x1::X1

◆ X1 [3/6]

struct _NV_PIXEL_SRSO_2x2::NV_PIXEL_SRSO_2x2_X1 _NV_PIXEL_SRSO_2x2::X1

◆ X1 [4/6]

struct _NV_PIXEL_SRSO_2x4::NV_PIXEL_SRSO_2x4_X1 _NV_PIXEL_SRSO_2x4::X1

◆ X1 [5/6]

struct _NV_PIXEL_SRSO_4x2::NV_PIXEL_SRSO_4x2_X1 _NV_PIXEL_SRSO_4x2::X1

◆ X1 [6/6]

struct _NV_PIXEL_SRSO_4x4::NV_PIXEL_SRSO_4x4_X1 _NV_PIXEL_SRSO_4x4::X1

◆ X2 [1/4]

struct _NV_PIXEL_SRSO_1x2::NV_PIXEL_SRSO_1x2_X2 _NV_PIXEL_SRSO_1x2::X2

◆ X2 [2/4]

struct _NV_PIXEL_SRSO_2x1::NV_PIXEL_SRSO_2x1_X2 _NV_PIXEL_SRSO_2x1::X2

◆ X2 [3/4]

struct _NV_PIXEL_SRSO_2x2::NV_PIXEL_SRSO_2x2_X2 _NV_PIXEL_SRSO_2x2::X2

◆ X2 [4/4]

struct _NV_PIXEL_SRSO_2x4::NV_PIXEL_SRSO_2x4_X2 _NV_PIXEL_SRSO_2x4::X2

◆ X4 [1/3]

struct _NV_PIXEL_SRSO_1x2::NV_PIXEL_SRSO_1x2_X4 _NV_PIXEL_SRSO_1x2::X4

◆ X4 [2/3]

struct _NV_PIXEL_SRSO_2x1::NV_PIXEL_SRSO_2x1_X4 _NV_PIXEL_SRSO_2x1::X4

◆ X4 [3/3]

struct _NV_PIXEL_SRSO_2x2::NV_PIXEL_SRSO_2x2_X4 _NV_PIXEL_SRSO_2x2::X4

◆ X8

struct _NV_PIXEL_SRSO_1x2::NV_PIXEL_SRSO_1x2_X8 _NV_PIXEL_SRSO_1x2::X8

◆ xRatio

float NV_CUSTOM_DISPLAY::xRatio

Horizontal scaling ratio.

◆ XS [1/2]

NvU8 _NV_PIXEL_SRSO_2x1::NV_PIXEL_SRSO_2x1_X2::XS[2][2]

◆ XS [2/2]

NvU8 _NV_PIXEL_SRSO_2x1::NV_PIXEL_SRSO_2x1_X4::XS[2][4]

◆ y [1/4]

float NV_VIEWPORTF::y

y-coordinate of the viewport top-left point

◆ y [2/4]

NvS32 _NV_POSITION::y

◆ Y

NvU8 _NV_PIXEL_SRSO_1x2::NV_PIXEL_SRSO_1x2_X1::Y[2]

◆ y [3/4]

NvU32 _NVAPI_DIM3::y

◆ y [4/4]

NvU32 _NVVIOOUTPUTREGION::y

Vertical origin in pixels.

◆ yccQuantizationRange

NvU32 NV_INFOFRAME_VIDEO::yccQuantizationRange

◆ year

NvU32 _NV_LICENSE_EXPIRY_DETAILS::year

Year value of license expiry.

◆ yRatio

float NV_CUSTOM_DISPLAY::yRatio

Vertical scaling ratio.

◆ YS [1/3]

NvU8 _NV_PIXEL_SRSO_1x2::NV_PIXEL_SRSO_1x2_X2::YS[2][2]

◆ YS [2/3]

NvU8 _NV_PIXEL_SRSO_1x2::NV_PIXEL_SRSO_1x2_X4::YS[2][4]

◆ YS [3/3]

NvU8 _NV_PIXEL_SRSO_1x2::NV_PIXEL_SRSO_1x2_X8::YS[2][8]

◆ YX [1/4]

NvU8 _NV_PIXEL_SRSO_2x2::NV_PIXEL_SRSO_2x2_X1::YX[2][2]

◆ YX [2/4]

NvU8 _NV_PIXEL_SRSO_4x2::NV_PIXEL_SRSO_4x2_X1::YX[2][4]

◆ YX [3/4]

NvU8 _NV_PIXEL_SRSO_2x4::NV_PIXEL_SRSO_2x4_X1::YX[4][2]

◆ YX [4/4]

NvU8 _NV_PIXEL_SRSO_4x4::NV_PIXEL_SRSO_4x4_X1::YX[4][4]

◆ YXS [1/3]

NvU8 _NV_PIXEL_SRSO_2x2::NV_PIXEL_SRSO_2x2_X2::YXS[2][2][2]

◆ YXS [2/3]

NvU8 _NV_PIXEL_SRSO_2x2::NV_PIXEL_SRSO_2x2_X4::YXS[2][2][4]

◆ YXS [3/3]

NvU8 _NV_PIXEL_SRSO_2x4::NV_PIXEL_SRSO_2x4_X2::YXS[4][2][2]

◆ z

NvU32 _NVAPI_DIM3::z

◆ zoneLocation

NV_GPU_CLIENT_ILLUM_ZONE_LOCATION _NV_GPU_CLIENT_ILLUM_ZONE_INFO_V1::zoneLocation

Location of the zone on the board.

◆ zones [1/2]

NV_GPU_CLIENT_ILLUM_ZONE_INFO_V1 _NV_GPU_CLIENT_ILLUM_ZONE_INFO_PARAMS_V1::zones[NV_GPU_CLIENT_ILLUM_ZONE_NUM_ZONES_MAX]

◆ zones [2/2]

NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_V1 _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_PARAMS_V1::zones[NV_GPU_CLIENT_ILLUM_ZONE_NUM_ZONES_MAX]


Data Fields
NV_DISPLAY_DRIVER_MEMORY_INFO_V1 Struct Reference
Graphics Driver APIs

#include <nvapi_lite_common.h>

Data Fields

NvU32 version
NvU32 dedicatedVideoMemory
NvU32 availableDedicatedVideoMemory
NvU32 systemVideoMemory
NvU32 sharedSystemMemory

Detailed Description

Used in NvAPI_GPU_GetMemoryInfo().

Field Documentation

◆ availableDedicatedVideoMemory

NvU32 NV_DISPLAY_DRIVER_MEMORY_INFO_V1::availableDedicatedVideoMemory

Size(in kb) of the available physical framebuffer for allocating video memory surfaces.

◆ dedicatedVideoMemory

NvU32 NV_DISPLAY_DRIVER_MEMORY_INFO_V1::dedicatedVideoMemory

Size(in kb) of the physical framebuffer.

◆ sharedSystemMemory

NvU32 NV_DISPLAY_DRIVER_MEMORY_INFO_V1::sharedSystemMemory

Size(in kb) of shared system memory that driver is allowed to commit for surfaces across all allocations.

◆ systemVideoMemory

NvU32 NV_DISPLAY_DRIVER_MEMORY_INFO_V1::systemVideoMemory

Size(in kb) of system memory the driver allocates at load time.

◆ version

NvU32 NV_DISPLAY_DRIVER_MEMORY_INFO_V1::version

Version info.

The documentation for this struct was generated from the following file:
  • nvapi_lite_common.h


Data Fields
NV_DISPLAY_DRIVER_MEMORY_INFO_V2 Struct Reference
Graphics Driver APIs

#include <nvapi_lite_common.h>

Data Fields

NvU32 version
NvU32 dedicatedVideoMemory
NvU32 availableDedicatedVideoMemory
NvU32 systemVideoMemory
NvU32 sharedSystemMemory
NvU32 curAvailableDedicatedVideoMemory

Detailed Description

Used in NvAPI_GPU_GetMemoryInfo().

Field Documentation

◆ availableDedicatedVideoMemory

NvU32 NV_DISPLAY_DRIVER_MEMORY_INFO_V2::availableDedicatedVideoMemory

Size(in kb) of the available physical framebuffer for allocating video memory surfaces.

◆ curAvailableDedicatedVideoMemory

NvU32 NV_DISPLAY_DRIVER_MEMORY_INFO_V2::curAvailableDedicatedVideoMemory

Size(in kb) of the current available physical framebuffer for allocating video memory surfaces.

◆ dedicatedVideoMemory

NvU32 NV_DISPLAY_DRIVER_MEMORY_INFO_V2::dedicatedVideoMemory

Size(in kb) of the physical framebuffer.

◆ sharedSystemMemory

NvU32 NV_DISPLAY_DRIVER_MEMORY_INFO_V2::sharedSystemMemory

Size(in kb) of shared system memory that driver is allowed to commit for surfaces across all allocations.

◆ systemVideoMemory

NvU32 NV_DISPLAY_DRIVER_MEMORY_INFO_V2::systemVideoMemory

Size(in kb) of system memory the driver allocates at load time.

◆ version

NvU32 NV_DISPLAY_DRIVER_MEMORY_INFO_V2::version

Version info.

The documentation for this struct was generated from the following file:
  • nvapi_lite_common.h


Data Fields
NV_DISPLAY_DRIVER_MEMORY_INFO_V3 Struct Reference
Graphics Driver APIs

#include <nvapi_lite_common.h>

Data Fields

NvU32 version
NvU32 dedicatedVideoMemory
NvU32 availableDedicatedVideoMemory
NvU32 systemVideoMemory
NvU32 sharedSystemMemory
NvU32 curAvailableDedicatedVideoMemory
NvU32 dedicatedVideoMemoryEvictionsSize
NvU32 dedicatedVideoMemoryEvictionCount

Detailed Description

Used in NvAPI_GPU_GetMemoryInfo().

Field Documentation

◆ availableDedicatedVideoMemory

NvU32 NV_DISPLAY_DRIVER_MEMORY_INFO_V3::availableDedicatedVideoMemory

Size(in kb) of the available physical framebuffer for allocating video memory surfaces.

◆ curAvailableDedicatedVideoMemory

NvU32 NV_DISPLAY_DRIVER_MEMORY_INFO_V3::curAvailableDedicatedVideoMemory

Size(in kb) of the current available physical framebuffer for allocating video memory surfaces.

◆ dedicatedVideoMemory

NvU32 NV_DISPLAY_DRIVER_MEMORY_INFO_V3::dedicatedVideoMemory

Size(in kb) of the physical framebuffer.

◆ dedicatedVideoMemoryEvictionCount

NvU32 NV_DISPLAY_DRIVER_MEMORY_INFO_V3::dedicatedVideoMemoryEvictionCount

Indicates the number of eviction events that caused an allocation to be removed from dedicated video memory to free GPU video memory to make room for other allocations.

◆ dedicatedVideoMemoryEvictionsSize

NvU32 NV_DISPLAY_DRIVER_MEMORY_INFO_V3::dedicatedVideoMemoryEvictionsSize

Size(in kb) of the total size of memory released as a result of the evictions.

◆ sharedSystemMemory

NvU32 NV_DISPLAY_DRIVER_MEMORY_INFO_V3::sharedSystemMemory

Size(in kb) of shared system memory that driver is allowed to commit for surfaces across all allocations.

◆ systemVideoMemory

NvU32 NV_DISPLAY_DRIVER_MEMORY_INFO_V3::systemVideoMemory

Size(in kb) of system memory the driver allocates at load time.

◆ version

NvU32 NV_DISPLAY_DRIVER_MEMORY_INFO_V3::version

Version info.

The documentation for this struct was generated from the following file:
  • nvapi_lite_common.h


Data Fields
NV_GPU_MEMORY_INFO_EX_V1 Struct Reference
Graphics Driver APIs

#include <nvapi_lite_common.h>

Data Fields

NvU32 version
NvU64 dedicatedVideoMemory
NvU64 availableDedicatedVideoMemory
NvU64 systemVideoMemory
NvU64 sharedSystemMemory
NvU64 curAvailableDedicatedVideoMemory
NvU64 dedicatedVideoMemoryEvictionsSize
NvU64 dedicatedVideoMemoryEvictionCount
NvU64 dedicatedVideoMemoryPromotionsSize
NvU64 dedicatedVideoMemoryPromotionCount

Detailed Description

Used in NvAPI_GPU_GetMemoryInfoEx().

Field Documentation

◆ availableDedicatedVideoMemory

NvU64 NV_GPU_MEMORY_INFO_EX_V1::availableDedicatedVideoMemory

Size(in bytes) of the available physical framebuffer for allocating video memory surfaces.

◆ curAvailableDedicatedVideoMemory

NvU64 NV_GPU_MEMORY_INFO_EX_V1::curAvailableDedicatedVideoMemory

Size(in bytes) of the current available physical framebuffer for allocating video memory surfaces.

◆ dedicatedVideoMemory

NvU64 NV_GPU_MEMORY_INFO_EX_V1::dedicatedVideoMemory

Size(in bytes) of the physical framebuffer. Refers to the dedicated video memory on discrete GPUs. It is more performant for GPU operations than the reserved systemVideoMemory.

◆ dedicatedVideoMemoryEvictionCount

NvU64 NV_GPU_MEMORY_INFO_EX_V1::dedicatedVideoMemoryEvictionCount

Indicates the number of eviction events that caused an allocation to be removed from dedicated video memory to free GPU video memory to make room for other allocations.

◆ dedicatedVideoMemoryEvictionsSize

NvU64 NV_GPU_MEMORY_INFO_EX_V1::dedicatedVideoMemoryEvictionsSize

Size(in bytes) of the total size of memory released as a result of the evictions.

◆ dedicatedVideoMemoryPromotionCount

NvU64 NV_GPU_MEMORY_INFO_EX_V1::dedicatedVideoMemoryPromotionCount

Indicates the number of promotion events that caused an allocation to be promoted to dedicated video memory.

◆ dedicatedVideoMemoryPromotionsSize

NvU64 NV_GPU_MEMORY_INFO_EX_V1::dedicatedVideoMemoryPromotionsSize

Size(in bytes) of the total size of memory allocated as a result of the promotions.

◆ sharedSystemMemory

NvU64 NV_GPU_MEMORY_INFO_EX_V1::sharedSystemMemory

Size(in bytes) of shared system memory that driver is allowed to commit for surfaces across all allocations. On discrete GPUs, it is used to utilize system memory for various operations. It does not need to be reserved during boot. It may be used by both GPU and CPU, and has an “on-demand” type of usage.

◆ systemVideoMemory

NvU64 NV_GPU_MEMORY_INFO_EX_V1::systemVideoMemory

Size(in bytes) of system memory the driver allocates at load time. It is a substitute for dedicated video memory. Typically used with integrated GPUs that do not have dedicated video memory.

◆ version

NvU32 NV_GPU_MEMORY_INFO_EX_V1::version

Structure version.

The documentation for this struct was generated from the following file:
  • nvapi_lite_common.h


Modules
Display APIs

Modules

Display Handle Interface
Display Control Interface

Detailed Description

The Display APIs include

  • Display handle functions: Retrieve the handle for the specified display.
  • Display control functions: Retrieve and control various display settings such as display name, refresh rate, hardware cursor, etc.


Functions
Display Handle Interface
Display APIs

Functions

NVAPI_INTERFACE | NvAPI_EnumNvidiaDisplayHandle (NvU32 thisEnum, NvDisplayHandle *pNvDispHandle)
NVAPI_INTERFACE | NvAPI_EnumNvidiaUnAttachedDisplayHandle (NvU32 thisEnum, NvUnAttachedDisplayHandle *pNvUnAttachedDispHandle)
NVAPI_INTERFACE | NvAPI_GetAssociatedNvidiaDisplayHandle (const char *szDisplayName, NvDisplayHandle *pNvDispHandle)
NVAPI_INTERFACE | NvAPI_DISP_GetAssociatedUnAttachedNvidiaDisplayHandle (const char *szDisplayName, NvUnAttachedDisplayHandle *pNvUnAttachedDispHandle)

Detailed Description

Function Documentation

◆ NvAPI_DISP_GetAssociatedUnAttachedNvidiaDisplayHandle()

NVAPI_INTERFACE NvAPI_DISP_GetAssociatedUnAttachedNvidiaDisplayHandle | ( | const char * | szDisplayName,
 |  | NvUnAttachedDisplayHandle * | pNvUnAttachedDispHandle
 | ) |  |

DESCRIPTION: This function returns the handle of an unattached NVIDIA display that is associated with the given display name (such as "\\DISPLAY1").

SUPPORTED OS: Windows 7 and higher

Since
Release: 185
Return values
NVAPI_INVALID_ARGUMENT | Either argument is NULL.
NVAPI_OK | *pNvUnAttachedDispHandle is now valid.
NVAPI_NVIDIA_DEVICE_NOT_FOUND | No NVIDIA device maps to that display name.

◆ NvAPI_EnumNvidiaDisplayHandle()

NVAPI_INTERFACE NvAPI_EnumNvidiaDisplayHandle | ( | NvU32 | thisEnum,
 |  | NvDisplayHandle * | pNvDispHandle
 | ) |  |

This function returns the handle of the NVIDIA display specified by the enum index (thisEnum). The client should keep enumerating until it returns error.

Note: Display handles can get invalidated on a modeset, so the calling applications need to renum the handles after every modeset.

SUPPORTED OS: Windows 7 and higher

Since
Release: 80
Parameters
[in] | thisEnum | The index of the NVIDIA display.
[out] | pNvDispHandle | Pointer to the NVIDIA display handle.
Return values
NVAPI_INVALID_ARGUMENT | Either the handle pointer is NULL or enum index too big
NVAPI_OK | Return a valid NvDisplayHandle based on the enum index
NVAPI_NVIDIA_DEVICE_NOT_FOUND | No NVIDIA device found in the system
NVAPI_END_ENUMERATION | No more display device to enumerate

◆ NvAPI_EnumNvidiaUnAttachedDisplayHandle()

NVAPI_INTERFACE NvAPI_EnumNvidiaUnAttachedDisplayHandle | ( | NvU32 | thisEnum,
 |  | NvUnAttachedDisplayHandle * | pNvUnAttachedDispHandle
 | ) |  |

This function returns the handle of the NVIDIA unattached display specified by the enum index (thisEnum). The client should keep enumerating until it returns error. Note: Display handles can get invalidated on a modeset, so the calling applications need to renum the handles after every modeset.

SUPPORTED OS: Windows 7 and higher

Since
Release: 80
Parameters
[in] | thisEnum | The index of the NVIDIA display.
[out] | pNvUnAttachedDispHandle | Pointer to the NVIDIA display handle of the unattached display.
Return values
NVAPI_INVALID_ARGUMENT | Either the handle pointer is NULL or enum index too big
NVAPI_OK | Return a valid NvDisplayHandle based on the enum index
NVAPI_NVIDIA_DEVICE_NOT_FOUND | No NVIDIA device found in the system
NVAPI_END_ENUMERATION | No more display device to enumerate.

◆ NvAPI_GetAssociatedNvidiaDisplayHandle()

NVAPI_INTERFACE NvAPI_GetAssociatedNvidiaDisplayHandle | ( | const char * | szDisplayName,
 |  | NvDisplayHandle * | pNvDispHandle
 | ) |  |

This function returns the handle of the NVIDIA display that is associated with the given display "name" (such as "\\.\DISPLAY1").

SUPPORTED OS: Windows 7 and higher

Since
Release: 80
Return values
NVAPI_INVALID_ARGUMENT | Either argument is NULL
NVAPI_OK | *pNvDispHandle is now valid
NVAPI_NVIDIA_DEVICE_NOT_FOUND | No NVIDIA device maps to that display name


Data Structures | Macros | Typedefs | Enumerations | Functions
Display Control Interface
Display APIs | OpenGL APIs

Data Structures

struct | tagNV_TIMINGEXT
struct | _NV_TIMING
struct | NV_VIEW_TARGET_INFO
struct | NV_DISPLAY_PATH
struct | NV_DISPLAY_PATH_INFO_V3
struct | NV_DISPLAY_PATH_INFO
struct | _NV_POSITION
struct | _NV_RESOLUTION
struct | _NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_V1
struct | _NV_DISPLAYCONFIG_PATH_TARGET_INFO_V1
struct | _NV_DISPLAYCONFIG_PATH_TARGET_INFO_V2
struct | _NV_DISPLAYCONFIG_SOURCE_MODE_INFO_V1
struct | _NV_DISPLAYCONFIG_PATH_INFO_V1
struct | _NV_DISPLAYCONFIG_PATH_INFO_V2
struct | _NV_DISPLAY_PORT_INFO_V1
struct | NV_DISPLAY_PORT_CONFIG
struct | _NV_HDMI_SUPPORT_INFO_V1
struct | NV_TIMING_FLAG
struct | _NV_TIMING_INPUT
struct | _NV_MONITOR_COLOR_DATA
struct | NV_CUSTOM_DISPLAY
struct | _NV_EDID_DATA_V1
struct | NV_SET_PREFERRED_STEREO_DISPLAY_V1
struct | NV_GET_PREFERRED_STEREO_DISPLAY_V1
struct | _NV_GET_VRR_INFO_V1

Macros

#define | NVFORMAT_MAKEFOURCC(ch0, ch1, ch2, ch3)
#define | NV_TIMING_H_SYNC_POSITIVE 0
#define | NV_TIMING_H_SYNC_NEGATIVE 1
#define | NV_TIMING_H_SYNC_DEFAULT NV_TIMING_H_SYNC_NEGATIVE
#define | NV_TIMING_V_SYNC_POSITIVE 0
#define | NV_TIMING_V_SYNC_NEGATIVE 1
#define | NV_TIMING_V_SYNC_DEFAULT NV_TIMING_V_SYNC_POSITIVE
#define | NV_TIMING_PROGRESSIVE 0
#define | NV_TIMING_INTERLACED 1
#define | NV_TIMING_INTERLACED_EXTRA_VBLANK_ON_FIELD2 1
#define | NV_TIMING_INTERLACED_NO_EXTRA_VBLANK_ON_FIELD2 2
#define | NV_VIEW_TARGET_INFO_VER MAKE_NVAPI_VERSION(NV_VIEW_TARGET_INFO,2)
#define | NVAPI_MAX_DISPLAY_PATH NVAPI_MAX_VIEW_TARGET
#define | NVAPI_ADVANCED_MAX_DISPLAY_PATH NVAPI_ADVANCED_MAX_VIEW_TARGET
#define | NV_DISPLAY_PATH_INFO_VER NV_DISPLAY_PATH_INFO_VER4
#define | NV_DISPLAY_PATH_INFO_VER4 MAKE_NVAPI_VERSION(NV_DISPLAY_PATH_INFO,4)
#define | NV_DISPLAY_PATH_INFO_VER3 MAKE_NVAPI_VERSION(NV_DISPLAY_PATH_INFO,3)
#define | NV_DISPLAY_PATH_INFO_VER2 MAKE_NVAPI_VERSION(NV_DISPLAY_PATH_INFO,2)
#define | NV_DISPLAY_PATH_INFO_VER1 MAKE_NVAPI_VERSION(NV_DISPLAY_PATH_INFO,1)
#define | NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_VER1 MAKE_NVAPI_VERSION(NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_V1,1)
#define | NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_VER NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_VER1
#define | _NV_DISPLAYCONFIG_PATH_INFO_V2 _NV_DISPLAYCONFIG_PATH_INFO
#define | NV_DISPLAYCONFIG_PATH_INFO_VER1 MAKE_NVAPI_VERSION(NV_DISPLAYCONFIG_PATH_INFO_V1,1)
#define | NV_DISPLAYCONFIG_PATH_INFO_VER2 MAKE_NVAPI_VERSION(NV_DISPLAYCONFIG_PATH_INFO_V2,2)
#define | NV_DISPLAY_PORT_CONFIG_VER MAKE_NVAPI_VERSION(NV_DISPLAY_PORT_CONFIG,2)
#define | NV_DISPLAY_PORT_CONFIG_VER_1 MAKE_NVAPI_VERSION(NV_DISPLAY_PORT_CONFIG,1)
#define | NV_DISPLAY_PORT_CONFIG_VER_2 MAKE_NVAPI_VERSION(NV_DISPLAY_PORT_CONFIG,2)
#define | NV_MONITOR_COLOR_CAPS_VER1 MAKE_NVAPI_VERSION(NV_MONITOR_COLOR_CAPS_V1,1)
#define | NV_CUSTOM_DISPLAY_VER MAKE_NVAPI_VERSION(NV_CUSTOM_DISPLAY,1)
#define | NV_SET_PREFERRED_STEREO_DISPLAY_VER1 MAKE_NVAPI_VERSION(NV_SET_PREFERRED_STEREO_DISPLAY_V1,1)
#define | NV_SET_PREFERRED_STEREO_DISPLAY_VER NV_SET_PREFERRED_STEREO_DISPLAY_VER1
#define | NV_GET_PREFERRED_STEREO_DISPLAY_VER1 MAKE_NVAPI_VERSION(NV_GET_PREFERRED_STEREO_DISPLAY_V1,1)
#define | NV_GET_PREFERRED_STEREO_DISPLAY_VER NV_GET_PREFERRED_STEREO_DISPLAY_VER1

Typedefs

typedef enum _NV_DP_LINK_RATE | NV_DP_LINK_RATE
typedef enum _NV_DP_LANE_COUNT | NV_DP_LANE_COUNT
typedef enum _NV_DP_COLOR_FORMAT | NV_DP_COLOR_FORMAT
typedef enum _NV_DP_COLORIMETRY | NV_DP_COLORIMETRY
typedef enum _NV_DP_DYNAMIC_RANGE | NV_DP_DYNAMIC_RANGE
typedef enum _NV_DP_BPC | NV_DP_BPC
typedef enum _NV_SCALING | NV_SCALING
typedef enum _NV_ROTATE | NV_ROTATE
typedef enum _NV_FORMAT | NV_FORMAT
typedef enum _NV_TIMING_OVERRIDE | NV_TIMING_OVERRIDE
typedef struct tagNV_TIMINGEXT | NV_TIMINGEXT
typedef struct _NV_TIMING | NV_TIMING
typedef struct _NV_POSITION | NV_POSITION
typedef struct _NV_RESOLUTION | NV_RESOLUTION
typedef struct _NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_V1 | NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_V1
typedef NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_V1 | NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO
typedef struct _NV_DISPLAYCONFIG_PATH_TARGET_INFO_V1 | NV_DISPLAYCONFIG_PATH_TARGET_INFO_V1
typedef struct _NV_DISPLAYCONFIG_PATH_TARGET_INFO_V2 | NV_DISPLAYCONFIG_PATH_TARGET_INFO_V2
typedef NV_DISPLAYCONFIG_PATH_TARGET_INFO_V2 | NV_DISPLAYCONFIG_PATH_TARGET_INFO
typedef enum _NV_DISPLAYCONFIG_SPANNING_ORIENTATION | NV_DISPLAYCONFIG_SPANNING_ORIENTATION
typedef struct _NV_DISPLAYCONFIG_SOURCE_MODE_INFO_V1 | NV_DISPLAYCONFIG_SOURCE_MODE_INFO_V1
typedef struct _NV_DISPLAYCONFIG_PATH_INFO_V1 | NV_DISPLAYCONFIG_PATH_INFO_V1
typedef struct _NV_DISPLAYCONFIG_PATH_INFO_V2 | NV_DISPLAYCONFIG_PATH_INFO_V2
typedef enum _NV_DISPLAYCONFIG_FLAGS | NV_DISPLAYCONFIG_FLAGS
typedef struct _NV_DISPLAY_PORT_INFO_V1 | NV_DISPLAY_PORT_INFO_V1
typedef struct _NV_HDMI_SUPPORT_INFO_V1 | NV_HDMI_SUPPORT_INFO_V1
typedef struct _NV_TIMING_INPUT | NV_TIMING_INPUT
typedef struct _NV_MONITOR_COLOR_DATA | NV_MONITOR_COLOR_CAPS_V1
typedef NV_SET_PREFERRED_STEREO_DISPLAY_V1 | NV_SET_PREFERRED_STEREO_DISPLAY
typedef NV_GET_PREFERRED_STEREO_DISPLAY_V1 | NV_GET_PREFERRED_STEREO_DISPLAY
typedef struct _NV_GET_VRR_INFO_V1 | NV_GET_VRR_INFO_V1

Enumerations

enum _NV_DP_LINK_RATE {
NV_DP_1_62GBPS = 6 , NV_DP_2_70GBPS = 0xA , NV_DP_5_40GBPS = 0x14 , NV_DP_8_10GBPS = 0x1E ,
NV_EDP_2_16GBPS = 8 , NV_EDP_2_43GBPS = 9 , NV_EDP_3_24GBPS = 0xC , NV_EDP_4_32GBPS = 0x10
}
enum | _NV_DP_LANE_COUNT { NV_DP_1_LANE = 1 , NV_DP_2_LANE = 2 , NV_DP_4_LANE = 4 }
enum | _NV_DP_COLOR_FORMAT { NV_DP_COLOR_FORMAT_RGB = 0 , NV_DP_COLOR_FORMAT_YCbCr422 , NV_DP_COLOR_FORMAT_YCbCr444 }
enum | _NV_DP_COLORIMETRY { NV_DP_COLORIMETRY_RGB = 0 , NV_DP_COLORIMETRY_YCbCr_ITU601 , NV_DP_COLORIMETRY_YCbCr_ITU709 }
enum | _NV_DP_DYNAMIC_RANGE { NV_DP_DYNAMIC_RANGE_VESA = 0 , NV_DP_DYNAMIC_RANGE_CEA }
enum _NV_DP_BPC {
NV_DP_BPC_DEFAULT = 0 , NV_DP_BPC_6 , NV_DP_BPC_8 , NV_DP_BPC_10 ,
NV_DP_BPC_12 , NV_DP_BPC_16
}
enum _NV_SCALING {
NV_SCALING_DEFAULT = 0 , NV_SCALING_GPU_SCALING_TO_CLOSEST = 1 , NV_SCALING_GPU_SCALING_TO_NATIVE = 2 , NV_SCALING_GPU_SCANOUT_TO_NATIVE = 3 ,
NV_SCALING_GPU_SCALING_TO_ASPECT_SCANOUT_TO_NATIVE = 5 , NV_SCALING_GPU_SCALING_TO_ASPECT_SCANOUT_TO_CLOSEST = 6 , NV_SCALING_GPU_SCANOUT_TO_CLOSEST = 7 , NV_SCALING_GPU_INTEGER_ASPECT_SCALING = 8 ,
NV_SCALING_MONITOR_SCALING = NV_SCALING_GPU_SCALING_TO_CLOSEST , NV_SCALING_ADAPTER_SCALING = NV_SCALING_GPU_SCALING_TO_NATIVE , NV_SCALING_CENTERED = NV_SCALING_GPU_SCANOUT_TO_NATIVE , NV_SCALING_ASPECT_SCALING = NV_SCALING_GPU_SCALING_TO_ASPECT_SCANOUT_TO_NATIVE ,
NV_SCALING_CUSTOMIZED = 255
}
enum _NV_ROTATE {
NV_ROTATE_0 = 0 , NV_ROTATE_90 = 1 , NV_ROTATE_180 = 2 , NV_ROTATE_270 = 3 ,
NV_ROTATE_IGNORED = 4
}
enum _NV_FORMAT {
NV_FORMAT_UNKNOWN = 0 , NV_FORMAT_P8 = 41 , NV_FORMAT_R5G6B5 = 23 , NV_FORMAT_A8R8G8B8 = 21 ,
NV_FORMAT_A16B16G16R16F = 113
}
enum _NV_TIMING_OVERRIDE {
NV_TIMING_OVERRIDE_CURRENT = 0 , NV_TIMING_OVERRIDE_AUTO , NV_TIMING_OVERRIDE_EDID , NV_TIMING_OVERRIDE_DMT ,
NV_TIMING_OVERRIDE_DMT_RB , NV_TIMING_OVERRIDE_CVT , NV_TIMING_OVERRIDE_CVT_RB , NV_TIMING_OVERRIDE_GTF ,
NV_TIMING_OVERRIDE_EIA861 , NV_TIMING_OVERRIDE_ANALOG_TV , NV_TIMING_OVERRIDE_CUST , NV_TIMING_OVERRIDE_NV_PREDEFINED ,
NV_TIMING_OVERRIDE_NV_PSF = NV_TIMING_OVERRIDE_NV_PREDEFINED , NV_TIMING_OVERRIDE_NV_ASPR , NV_TIMING_OVERRIDE_SDI , NV_TIMING_OVRRIDE_MAX
}
enum | _NV_DISPLAYCONFIG_SPANNING_ORIENTATION { NV_DISPLAYCONFIG_SPAN_NONE = 0 , NV_DISPLAYCONFIG_SPAN_HORIZONTAL = 1 , NV_DISPLAYCONFIG_SPAN_VERTICAL = 2 }
enum _NV_DISPLAYCONFIG_FLAGS {
NV_DISPLAYCONFIG_VALIDATE_ONLY = 0x00000001 , NV_DISPLAYCONFIG_SAVE_TO_PERSISTENCE = 0x00000002 , NV_DISPLAYCONFIG_DRIVER_RELOAD_ALLOWED = 0x00000004 , NV_DISPLAYCONFIG_FORCE_MODE_ENUMERATION = 0x00000008 ,
NV_FORCE_COMMIT_VIDPN = 0x00000010
}
enum NV_INFOFRAME_CMD {
NV_INFOFRAME_CMD_GET_DEFAULT = 0 , NV_INFOFRAME_CMD_RESET , NV_INFOFRAME_CMD_GET , NV_INFOFRAME_CMD_SET ,
NV_INFOFRAME_CMD_GET_OVERRIDE , NV_INFOFRAME_CMD_SET_OVERRIDE , NV_INFOFRAME_CMD_GET_PROPERTY , NV_INFOFRAME_CMD_SET_PROPERTY
}

Functions

__nvapi_deprecated_function ("Do not use this function - it is deprecated in release 290. Instead, use NvAPI_DISP_SetDisplayConfig.") NVAPI_INTERFACE NvAPI_SetViewEx(NvDisplayHandle hNvDisplay
NVAPI_INTERFACE | NvAPI_CreateDisplayFromUnAttachedDisplay (NvUnAttachedDisplayHandle hNvUnAttachedDisp, NvDisplayHandle *pNvDisplay)
NVAPI_INTERFACE | NvAPI_GetAssociatedNvidiaDisplayName (NvDisplayHandle NvDispHandle, NvAPI_ShortString szDisplayName)
NVAPI_INTERFACE | NvAPI_GetUnAttachedAssociatedDisplayName (NvUnAttachedDisplayHandle hNvUnAttachedDisp, NvAPI_ShortString szDisplayName)
NVAPI_INTERFACE | NvAPI_EnableHWCursor (NvDisplayHandle hNvDisplay)
NVAPI_INTERFACE | NvAPI_DisableHWCursor (NvDisplayHandle hNvDisplay)
NVAPI_INTERFACE | NvAPI_GetVBlankCounter (NvDisplayHandle hNvDisplay, NvU32 *pCounter)
NVAPI_INTERFACE | NvAPI_SetRefreshRateOverride (NvDisplayHandle hNvDisplay, NvU32 outputsMask, float refreshRate, NvU32 bSetDeferred)
NVAPI_INTERFACE | NvAPI_GetAssociatedDisplayOutputId (NvDisplayHandle hNvDisplay, NvU32 *pOutputId)
NVAPI_INTERFACE | NvAPI_GetDisplayPortInfo (__in_opt NvDisplayHandle hNvDisplay, __in NvU32 outputId, __inout NV_DISPLAY_PORT_INFO *pInfo)
NVAPI_INTERFACE | NvAPI_SetDisplayPort (NvDisplayHandle hNvDisplay, NvU32 outputId, NV_DISPLAY_PORT_CONFIG *pCfg)
NVAPI_INTERFACE | NvAPI_GetHDMISupportInfo (__in_opt NvDisplayHandle hNvDisplay, __in NvU32 outputId, __inout NV_HDMI_SUPPORT_INFO *pInfo)
NVAPI_INTERFACE | NvAPI_Disp_InfoFrameControl (__in NvU32 displayId, __inout NV_INFOFRAME_DATA *pInfoframeData)
NVAPI_INTERFACE | NvAPI_DISP_GetTiming (__in NvU32 displayId, __in NV_TIMING_INPUT *timingInput, __out NV_TIMING *pTiming)
NVAPI_INTERFACE | NvAPI_DISP_GetMonitorCapabilities (__in NvU32 displayId, __inout NV_MONITOR_CAPABILITIES *pMonitorCapabilities)
NVAPI_INTERFACE | NvAPI_DISP_GetMonitorColorCapabilities (__in NvU32 displayId, __inout_ecount_part_opt(*pColorCapsCount, *pColorCapsCount) NV_MONITOR_COLOR_CAPS *pMonitorColorCapabilities, __inout NvU32 *pColorCapsCount)
NVAPI_INTERFACE | NvAPI_DISP_EnumCustomDisplay (__in NvU32 displayId, __in NvU32 index, __inout NV_CUSTOM_DISPLAY *pCustDisp)
NVAPI_INTERFACE | NvAPI_DISP_TryCustomDisplay (__in_ecount(count) NvU32 *pDisplayIds, __in NvU32 count, __in_ecount(count) NV_CUSTOM_DISPLAY *pCustDisp)
NVAPI_INTERFACE | NvAPI_DISP_DeleteCustomDisplay (__in_ecount(count) NvU32 *pDisplayIds, __in NvU32 count, __in NV_CUSTOM_DISPLAY *pCustDisp)
NVAPI_INTERFACE | NvAPI_DISP_SaveCustomDisplay (__in_ecount(count) NvU32 *pDisplayIds, __in NvU32 count, __in NvU32 isThisOutputIdOnly, __in NvU32 isThisMonitorIdOnly)
NVAPI_INTERFACE | NvAPI_DISP_RevertCustomDisplayTrial (__in_ecount(count) NvU32 *pDisplayIds, __in NvU32 count)
__nvapi_deprecated_function ("Do not use this function - it is deprecated in release 290. Instead, use NvAPI_DISP_GetDisplayConfig.") NVAPI_INTERFACE NvAPI_GetView(NvDisplayHandle hNvDisplay
NVAPI_INTERFACE | NvAPI_GetSupportedViews (NvDisplayHandle hNvDisplay, NV_TARGET_VIEW_MODE *pTargetViews, NvU32 *pViewCount)
NVAPI_INTERFACE | NvAPI_DISP_GetDisplayIdByDisplayName (const char *displayName, NvU32 *displayId)
NVAPI_INTERFACE | NvAPI_DISP_GetDisplayConfig (__inout NvU32 *pathInfoCount, __out_ecount_full_opt(*pathInfoCount) NV_DISPLAYCONFIG_PATH_INFO *pathInfo)
NVAPI_INTERFACE | NvAPI_DISP_SetDisplayConfig (__in NvU32 pathInfoCount, __in_ecount(pathInfoCount) NV_DISPLAYCONFIG_PATH_INFO *pathInfo, __in NvU32 flags)
NVAPI_INTERFACE | NvAPI_DISP_SetPreferredStereoDisplay (__in NV_SET_PREFERRED_STEREO_DISPLAY *pPreferredStereoDisplay)
NVAPI_INTERFACE | NvAPI_DISP_GetPreferredStereoDisplay (__inout NV_GET_PREFERRED_STEREO_DISPLAY *pPreferredStereoDisplay)
NVAPI_INTERFACE | NvAPI_DISP_AcquireDedicatedDisplay (__in NvU32 displayId, __inout NvU64 *pDisplaySourceHandle)
NVAPI_INTERFACE | NvAPI_DISP_ReleaseDedicatedDisplay (__in NvU32 displayId)
NVAPI_INTERFACE | NvAPI_Disp_GetVRRInfo (__in NvU32 displayId, __inout NV_GET_VRR_INFO *pVrrInfo)
NVAPI_INTERFACE | NvAPI_DISP_GetGDIPrimaryDisplayId (NvU32 *displayId)
NVAPI_INTERFACE | NvAPI_DISP_GetAdaptiveSyncData (__in NvU32 displayId, __inout NV_GET_ADAPTIVE_SYNC_DATA *pAdaptiveSyncData)
NVAPI_INTERFACE | NvAPI_DISP_SetAdaptiveSyncData (__in NvU32 displayId, __in NV_SET_ADAPTIVE_SYNC_DATA *pAdaptiveSyncData)
NVAPI_INTERFACE | NvAPI_DISP_GetVirtualRefreshRateData (__in NvU32 displayId, __inout NV_GET_VIRTUAL_REFRESH_RATE_DATA *pVirtualRefreshRateData)
NVAPI_INTERFACE | NvAPI_DISP_SetVirtualRefreshRateData (__in NvU32 displayId, __in NV_SET_VIRTUAL_REFRESH_RATE_DATA *pVirtualRefreshRateData)
enum | NV_MONITOR_CAPS_TYPE { NV_MONITOR_CAPS_TYPE_HDMI_VSDB = 0x1000 , NV_MONITOR_CAPS_TYPE_HDMI_VCDB = 0x1001 , NV_MONITOR_CAPS_TYPE_GENERIC = 0x1002 }
enum _NV_TARGET_VIEW_MODE {
NV_VIEW_MODE_STANDARD = 0 , NV_VIEW_MODE_CLONE = 1 , NV_VIEW_MODE_HSPAN = 2 , NV_VIEW_MODE_VSPAN = 3 ,
NV_VIEW_MODE_DUALVIEW = 4 , NV_VIEW_MODE_MULTIVIEW = 5
}
typedef enum _NV_TARGET_VIEW_MODE | NV_TARGET_VIEW_MODE
#define | NVAPI_MAX_VIEW_TARGET 2
#define | NVAPI_ADVANCED_MAX_VIEW_TARGET 4
#define | _NV_TARGET_VIEW_MODE_
typedef struct _NV_EDID_DATA_V1 | NV_EDID_DATA_V1
NVAPI_INTERFACE | NvAPI_DISP_GetEdidData (__in NvU32 displayId, __inout NV_EDID_DATA *pEdidParams, __inout NV_EDID_FLAG *pFlag)
NVAPI_INTERFACE | NvAPI_Disp_ColorControl (NvU32 displayId, NV_COLOR_DATA *pColorData)

Detailed Description

Timing-related constants

Macro for constructing the version fields of NV_DISPLAY_PATH_INFO

Macro for constructing the version field of NV_DISPLAY_PORT_CONFIG

Macro Definition Documentation

◆ _NV_DISPLAYCONFIG_PATH_INFO_V2

#define _NV_DISPLAYCONFIG_PATH_INFO_V2 _NV_DISPLAYCONFIG_PATH_INFO

This define is temporary and must be removed once DVS failure is fixed.

◆ _NV_TARGET_VIEW_MODE_

#define _NV_TARGET_VIEW_MODE_

Used in NvAPI_SetView().

◆ NV_CUSTOM_DISPLAY_VER

#define NV_CUSTOM_DISPLAY_VER MAKE_NVAPI_VERSION(NV_CUSTOM_DISPLAY,1)

Used in NV_CUSTOM_DISPLAY.

◆ NV_DISPLAY_PATH_INFO_VER

#define NV_DISPLAY_PATH_INFO_VER NV_DISPLAY_PATH_INFO_VER4

◆ NV_DISPLAY_PATH_INFO_VER1

#define NV_DISPLAY_PATH_INFO_VER1 MAKE_NVAPI_VERSION(NV_DISPLAY_PATH_INFO,1)

◆ NV_DISPLAY_PATH_INFO_VER2

#define NV_DISPLAY_PATH_INFO_VER2 MAKE_NVAPI_VERSION(NV_DISPLAY_PATH_INFO,2)

◆ NV_DISPLAY_PATH_INFO_VER3

#define NV_DISPLAY_PATH_INFO_VER3 MAKE_NVAPI_VERSION(NV_DISPLAY_PATH_INFO,3)

◆ NV_DISPLAY_PATH_INFO_VER4

#define NV_DISPLAY_PATH_INFO_VER4 MAKE_NVAPI_VERSION(NV_DISPLAY_PATH_INFO,4)

◆ NV_DISPLAY_PORT_CONFIG_VER

#define NV_DISPLAY_PORT_CONFIG_VER MAKE_NVAPI_VERSION(NV_DISPLAY_PORT_CONFIG,2)

◆ NV_DISPLAY_PORT_CONFIG_VER_1

#define NV_DISPLAY_PORT_CONFIG_VER_1 MAKE_NVAPI_VERSION(NV_DISPLAY_PORT_CONFIG,1)

Macro for constructing the version field of NV_DISPLAY_PORT_CONFIG.

◆ NV_DISPLAY_PORT_CONFIG_VER_2

#define NV_DISPLAY_PORT_CONFIG_VER_2 MAKE_NVAPI_VERSION(NV_DISPLAY_PORT_CONFIG,2)

Macro for constructing the version field of NV_DISPLAY_PORT_CONFIG.

◆ NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_VER

#define NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_VER NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_VER1

◆ NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_VER1

#define NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_VER1 MAKE_NVAPI_VERSION(NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_V1,1)

◆ NV_DISPLAYCONFIG_PATH_INFO_VER1

#define NV_DISPLAYCONFIG_PATH_INFO_VER1 MAKE_NVAPI_VERSION(NV_DISPLAYCONFIG_PATH_INFO_V1,1)

◆ NV_DISPLAYCONFIG_PATH_INFO_VER2

#define NV_DISPLAYCONFIG_PATH_INFO_VER2 MAKE_NVAPI_VERSION(NV_DISPLAYCONFIG_PATH_INFO_V2,2)

◆ NV_GET_PREFERRED_STEREO_DISPLAY_VER

#define NV_GET_PREFERRED_STEREO_DISPLAY_VER NV_GET_PREFERRED_STEREO_DISPLAY_VER1

◆ NV_GET_PREFERRED_STEREO_DISPLAY_VER1

#define NV_GET_PREFERRED_STEREO_DISPLAY_VER1 MAKE_NVAPI_VERSION(NV_GET_PREFERRED_STEREO_DISPLAY_V1,1)

◆ NV_MONITOR_COLOR_CAPS_VER1

#define NV_MONITOR_COLOR_CAPS_VER1 MAKE_NVAPI_VERSION(NV_MONITOR_COLOR_CAPS_V1,1)

◆ NV_SET_PREFERRED_STEREO_DISPLAY_VER

#define NV_SET_PREFERRED_STEREO_DISPLAY_VER NV_SET_PREFERRED_STEREO_DISPLAY_VER1

◆ NV_SET_PREFERRED_STEREO_DISPLAY_VER1

#define NV_SET_PREFERRED_STEREO_DISPLAY_VER1 MAKE_NVAPI_VERSION(NV_SET_PREFERRED_STEREO_DISPLAY_V1,1)

◆ NV_TIMING_H_SYNC_DEFAULT

#define NV_TIMING_H_SYNC_DEFAULT NV_TIMING_H_SYNC_NEGATIVE

◆ NV_TIMING_H_SYNC_NEGATIVE

#define NV_TIMING_H_SYNC_NEGATIVE 1

◆ NV_TIMING_H_SYNC_POSITIVE

#define NV_TIMING_H_SYNC_POSITIVE 0

◆ NV_TIMING_INTERLACED

#define NV_TIMING_INTERLACED 1

◆ NV_TIMING_INTERLACED_EXTRA_VBLANK_ON_FIELD2

#define NV_TIMING_INTERLACED_EXTRA_VBLANK_ON_FIELD2 1

◆ NV_TIMING_INTERLACED_NO_EXTRA_VBLANK_ON_FIELD2

#define NV_TIMING_INTERLACED_NO_EXTRA_VBLANK_ON_FIELD2 2

◆ NV_TIMING_PROGRESSIVE

#define NV_TIMING_PROGRESSIVE 0

◆ NV_TIMING_V_SYNC_DEFAULT

#define NV_TIMING_V_SYNC_DEFAULT NV_TIMING_V_SYNC_POSITIVE

◆ NV_TIMING_V_SYNC_NEGATIVE

#define NV_TIMING_V_SYNC_NEGATIVE 1

◆ NV_TIMING_V_SYNC_POSITIVE

#define NV_TIMING_V_SYNC_POSITIVE 0

◆ NV_VIEW_TARGET_INFO_VER

#define NV_VIEW_TARGET_INFO_VER MAKE_NVAPI_VERSION(NV_VIEW_TARGET_INFO,2)

◆ NVAPI_ADVANCED_MAX_DISPLAY_PATH

#define NVAPI_ADVANCED_MAX_DISPLAY_PATH NVAPI_ADVANCED_MAX_VIEW_TARGET

◆ NVAPI_ADVANCED_MAX_VIEW_TARGET

#define NVAPI_ADVANCED_MAX_VIEW_TARGET 4

Used in NvAPI_SetView().

◆ NVAPI_MAX_DISPLAY_PATH

#define NVAPI_MAX_DISPLAY_PATH NVAPI_MAX_VIEW_TARGET

◆ NVAPI_MAX_VIEW_TARGET

#define NVAPI_MAX_VIEW_TARGET 2

Used in NvAPI_SetView().

◆ NVFORMAT_MAKEFOURCC

#define NVFORMAT_MAKEFOURCC | ( | ch0,
 |  | ch1,
 |  | ch2,
 |  | ch3
 | ) |
Value:
((NvU32)(NvU8)(ch0) | ((NvU32)(NvU8)(ch1) << 8) | \
((NvU32)(NvU8)(ch2) << 16) | ((NvU32)(NvU8)(ch3) << 24 ))
NvU32
unsigned long NvU32
Definition nvapi_lite_common.h:85
NvU8
unsigned char NvU8
Definition nvapi_lite_common.h:95

Color formats- used in NvAPI_SetViewEx().

Typedef Documentation

◆ NV_DISPLAY_PORT_INFO_V1

typedef struct _NV_DISPLAY_PORT_INFO_V1 NV_DISPLAY_PORT_INFO_V1

Used in NvAPI_GetDisplayPortInfo().

◆ NV_DISPLAYCONFIG_FLAGS

typedef enum _NV_DISPLAYCONFIG_FLAGS NV_DISPLAYCONFIG_FLAGS

◆ NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO

typedef NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_V1 NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO

◆ NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_V1

typedef struct _NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_V1 NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_V1

◆ NV_DISPLAYCONFIG_PATH_INFO_V1

typedef struct _NV_DISPLAYCONFIG_PATH_INFO_V1 NV_DISPLAYCONFIG_PATH_INFO_V1

◆ NV_DISPLAYCONFIG_PATH_INFO_V2

typedef struct _NV_DISPLAYCONFIG_PATH_INFO_V2 NV_DISPLAYCONFIG_PATH_INFO_V2

◆ NV_DISPLAYCONFIG_PATH_TARGET_INFO

typedef NV_DISPLAYCONFIG_PATH_TARGET_INFO_V2 NV_DISPLAYCONFIG_PATH_TARGET_INFO

As version is not defined for this structure, we will be using version of NV_DISPLAYCONFIG_PATH_INFO

◆ NV_DISPLAYCONFIG_PATH_TARGET_INFO_V1

typedef struct _NV_DISPLAYCONFIG_PATH_TARGET_INFO_V1 NV_DISPLAYCONFIG_PATH_TARGET_INFO_V1

◆ NV_DISPLAYCONFIG_PATH_TARGET_INFO_V2

typedef struct _NV_DISPLAYCONFIG_PATH_TARGET_INFO_V2 NV_DISPLAYCONFIG_PATH_TARGET_INFO_V2

◆ NV_DISPLAYCONFIG_SOURCE_MODE_INFO_V1

typedef struct _NV_DISPLAYCONFIG_SOURCE_MODE_INFO_V1 NV_DISPLAYCONFIG_SOURCE_MODE_INFO_V1

◆ NV_DISPLAYCONFIG_SPANNING_ORIENTATION

typedef enum _NV_DISPLAYCONFIG_SPANNING_ORIENTATION NV_DISPLAYCONFIG_SPANNING_ORIENTATION

◆ NV_DP_BPC

typedef enum _NV_DP_BPC NV_DP_BPC

Used in NV_DISPLAY_PORT_INFO.

◆ NV_DP_COLOR_FORMAT

typedef enum _NV_DP_COLOR_FORMAT NV_DP_COLOR_FORMAT

Used in NV_DISPLAY_PORT_INFO.

◆ NV_DP_COLORIMETRY

typedef enum _NV_DP_COLORIMETRY NV_DP_COLORIMETRY

Used in NV_DISPLAY_PORT_INFO.

◆ NV_DP_DYNAMIC_RANGE

typedef enum _NV_DP_DYNAMIC_RANGE NV_DP_DYNAMIC_RANGE

Used in NV_DISPLAY_PORT_INFO.

◆ NV_DP_LANE_COUNT

typedef enum _NV_DP_LANE_COUNT NV_DP_LANE_COUNT

Used in NV_DISPLAY_PORT_INFO.

◆ NV_DP_LINK_RATE

typedef enum _NV_DP_LINK_RATE NV_DP_LINK_RATE

Used in NV_DISPLAY_PORT_INFO.

◆ NV_EDID_DATA_V1

typedef struct _NV_EDID_DATA_V1 NV_EDID_DATA_V1
DESCRIPTION: This API returns the EDID data for the specified display Id.
(NvAPI_GPU_GetConnectedDisplayIds() can be used to get the DisplayIds).
USAGE: The caller has to call this API two times to fetch the required details as follows:
First Pass : Caller should call NvAPI_DISP_GetEdidData() with pEdidParams->pEDID set to NULL,
to get the size of the EDID buffer in pEdidParams->sizeOfEDID.
Second Pass: Allocate memory for the EDID buffer of the size - pEdidParams->sizeOfEDID,
and call the API again to get the EDID buffer populated.
\param [in] displayId - NVIDIA Display ID
\param [inout] pEdidParams - Pointer to the structure that contains - pointer to EDID buffer and its size
\param [inout] pFlag - The type of EDID to be retrieved (IN).
To only retrieve the EDID type, the user should send pEdidParams->pEDID as NULL and
pEdidParams->sizeOfEDID as 0.
SUPPORTED OS: Windows 7 and higher
\since Release: 400
\return This API can return any of the error codes enumerated in #NvAPI_Status.
If there are return error codes with specific meaning for this API, they are listed below.
NVAPI_INSUFFICIENT_BUFFER: Reallocate buffer with pEdidParams->sizeOfEDID and call again to get complete data.
In this case pEdidParams->pEDID contains undefined data.
This error occurs only when pEdidParams->pEDID is present.
NvAPI_GPU_GetConnectedDisplayIds
NVAPI_INTERFACE NvAPI_GPU_GetConnectedDisplayIds(__in NvPhysicalGpuHandle hPhysicalGpu, __inout_ecount_part_opt(*pDisplayIdCount, *pDisplayIdCount) NV_GPU_DISPLAYIDS *pDisplayIds, __inout NvU32 *pDisplayIdCount, __in NvU32 flags)
NVAPI_INSUFFICIENT_BUFFER
@ NVAPI_INSUFFICIENT_BUFFER
Input buffer is insufficient to hold the contents.
Definition nvapi_lite_common.h:350
NvAPI_DISP_GetEdidData
NVAPI_INTERFACE NvAPI_DISP_GetEdidData(__in NvU32 displayId, __inout NV_EDID_DATA *pEdidParams, __inout NV_EDID_FLAG *pFlag)

◆ NV_FORMAT

typedef enum _NV_FORMAT NV_FORMAT

Color formats- used in NvAPI_SetViewEx().

◆ NV_GET_PREFERRED_STEREO_DISPLAY

typedef NV_GET_PREFERRED_STEREO_DISPLAY_V1 NV_GET_PREFERRED_STEREO_DISPLAY

◆ NV_GET_VRR_INFO_V1

typedef struct _NV_GET_VRR_INFO_V1 NV_GET_VRR_INFO_V1

◆ NV_HDMI_SUPPORT_INFO_V1

typedef struct _NV_HDMI_SUPPORT_INFO_V1 NV_HDMI_SUPPORT_INFO_V1

Used in NvAPI_GetHDMISupportInfo().

◆ NV_MONITOR_COLOR_CAPS_V1

typedef struct _NV_MONITOR_COLOR_DATA NV_MONITOR_COLOR_CAPS_V1

◆ NV_POSITION

typedef struct _NV_POSITION NV_POSITION

◆ NV_RESOLUTION

typedef struct _NV_RESOLUTION NV_RESOLUTION

◆ NV_ROTATE

typedef enum _NV_ROTATE NV_ROTATE

Rotate modes- used in NvAPI_SetViewEx().

◆ NV_SCALING

typedef enum _NV_SCALING NV_SCALING

Scaling modes - used in NvAPI_SetViewEx().

◆ NV_SET_PREFERRED_STEREO_DISPLAY

typedef NV_SET_PREFERRED_STEREO_DISPLAY_V1 NV_SET_PREFERRED_STEREO_DISPLAY

◆ NV_TARGET_VIEW_MODE

typedef enum _NV_TARGET_VIEW_MODE NV_TARGET_VIEW_MODE

Used in NvAPI_SetView().

◆ NV_TIMING

typedef struct _NV_TIMING NV_TIMING

The very basic timing structure based on the VESA standard:

|<----------------------------htotal--------------------------->|
---------"active" video-------->|<-------blanking------>|<-----
|<-------hvisible-------->|<-hb->|<-hfp->|<-hsw->|<-hbp->|<-hb->|
--------- -+-------------------------+ | | | | |
A A | | | | | | |
: : | | | | | | |
: : | | | | | | |
:vertical| addressable video | | | | | |
: visible| | | | | | |
: : | | | | | | |
: : | | | | | | |
vertical V | | | | | | |
total --+-------------------------+ | | | | |
: vb border | | | | |
: -----------------------------------+ | | | |
: vfp front porch | | | |
: -------------------------------------------+ | | |
: vsw sync width | | |
: ---------------------------------------------------+ | |
: vbp back porch | |
: -----------------------------------------------------------+ |
V vb border |
---------------------------------------------------------------------------+

◆ NV_TIMING_INPUT

typedef struct _NV_TIMING_INPUT NV_TIMING_INPUT

Used in NvAPI_DISP_GetTiming().

◆ NV_TIMING_OVERRIDE

typedef enum _NV_TIMING_OVERRIDE NV_TIMING_OVERRIDE

The timing override is not supported yet; must be set to _AUTO.

◆ NV_TIMINGEXT

typedef struct tagNV_TIMINGEXT NV_TIMINGEXT

NVIDIA-specific timing extras
Used in NV_TIMING.

Enumeration Type Documentation

◆ _NV_DISPLAYCONFIG_FLAGS

enum _NV_DISPLAYCONFIG_FLAGS
Enumerator
NV_DISPLAYCONFIG_VALIDATE_ONLY |
NV_DISPLAYCONFIG_SAVE_TO_PERSISTENCE |
NV_DISPLAYCONFIG_DRIVER_RELOAD_ALLOWED | Driver reload is permitted if necessary.
NV_DISPLAYCONFIG_FORCE_MODE_ENUMERATION | Refresh OS mode list.
NV_FORCE_COMMIT_VIDPN | Tell OS to avoid optimizing CommitVidPn call during a modeset.

◆ _NV_DISPLAYCONFIG_SPANNING_ORIENTATION

enum _NV_DISPLAYCONFIG_SPANNING_ORIENTATION
Enumerator
NV_DISPLAYCONFIG_SPAN_NONE
NV_DISPLAYCONFIG_SPAN_HORIZONTAL
NV_DISPLAYCONFIG_SPAN_VERTICAL

◆ _NV_DP_BPC

enum _NV_DP_BPC

Used in NV_DISPLAY_PORT_INFO.

Enumerator
NV_DP_BPC_DEFAULT
NV_DP_BPC_6
NV_DP_BPC_8
NV_DP_BPC_10
NV_DP_BPC_12
NV_DP_BPC_16

◆ _NV_DP_COLOR_FORMAT

enum _NV_DP_COLOR_FORMAT

Used in NV_DISPLAY_PORT_INFO.

Enumerator
NV_DP_COLOR_FORMAT_RGB
NV_DP_COLOR_FORMAT_YCbCr422
NV_DP_COLOR_FORMAT_YCbCr444

◆ _NV_DP_COLORIMETRY

enum _NV_DP_COLORIMETRY

Used in NV_DISPLAY_PORT_INFO.

Enumerator
NV_DP_COLORIMETRY_RGB
NV_DP_COLORIMETRY_YCbCr_ITU601
NV_DP_COLORIMETRY_YCbCr_ITU709

◆ _NV_DP_DYNAMIC_RANGE

enum _NV_DP_DYNAMIC_RANGE

Used in NV_DISPLAY_PORT_INFO.

Enumerator
NV_DP_DYNAMIC_RANGE_VESA
NV_DP_DYNAMIC_RANGE_CEA

◆ _NV_DP_LANE_COUNT

enum _NV_DP_LANE_COUNT

Used in NV_DISPLAY_PORT_INFO.

Enumerator
NV_DP_1_LANE
NV_DP_2_LANE
NV_DP_4_LANE

◆ _NV_DP_LINK_RATE

enum _NV_DP_LINK_RATE

Used in NV_DISPLAY_PORT_INFO.

Enumerator
NV_DP_1_62GBPS
NV_DP_2_70GBPS
NV_DP_5_40GBPS
NV_DP_8_10GBPS
NV_EDP_2_16GBPS
NV_EDP_2_43GBPS
NV_EDP_3_24GBPS
NV_EDP_4_32GBPS

◆ _NV_FORMAT

enum _NV_FORMAT

Color formats- used in NvAPI_SetViewEx().

Enumerator
NV_FORMAT_UNKNOWN | unknown. Driver will choose one as following value.
NV_FORMAT_P8 | for 8bpp mode
NV_FORMAT_R5G6B5 | for 16bpp mode
NV_FORMAT_A8R8G8B8 | for 32bpp mode
NV_FORMAT_A16B16G16R16F | for 64bpp(floating point) mode.

◆ _NV_ROTATE

enum _NV_ROTATE

Rotate modes- used in NvAPI_SetViewEx().

Enumerator
NV_ROTATE_0
NV_ROTATE_90
NV_ROTATE_180
NV_ROTATE_270
NV_ROTATE_IGNORED

◆ _NV_SCALING

enum _NV_SCALING

Scaling modes - used in NvAPI_SetViewEx().

Enumerator
NV_SCALING_DEFAULT | No change.
NV_SCALING_GPU_SCALING_TO_CLOSEST | Balanced - Full Screen.
NV_SCALING_GPU_SCALING_TO_NATIVE | Force GPU - Full Screen.
NV_SCALING_GPU_SCANOUT_TO_NATIVE | Force GPU - Centered\No Scaling.
NV_SCALING_GPU_SCALING_TO_ASPECT_SCANOUT_TO_NATIVE | Force GPU - Aspect Ratio.
NV_SCALING_GPU_SCALING_TO_ASPECT_SCANOUT_TO_CLOSEST | Balanced - Aspect Ratio.
NV_SCALING_GPU_SCANOUT_TO_CLOSEST | Balanced - Centered\No Scaling.
NV_SCALING_GPU_INTEGER_ASPECT_SCALING | Force GPU - Integer Scaling.
NV_SCALING_MONITOR_SCALING |
NV_SCALING_ADAPTER_SCALING |
NV_SCALING_CENTERED |
NV_SCALING_ASPECT_SCALING |
NV_SCALING_CUSTOMIZED | For future use.

◆ _NV_TARGET_VIEW_MODE

enum _NV_TARGET_VIEW_MODE

Used in NvAPI_SetView().

Enumerator
NV_VIEW_MODE_STANDARD
NV_VIEW_MODE_CLONE
NV_VIEW_MODE_HSPAN
NV_VIEW_MODE_VSPAN
NV_VIEW_MODE_DUALVIEW
NV_VIEW_MODE_MULTIVIEW

◆ _NV_TIMING_OVERRIDE

enum _NV_TIMING_OVERRIDE

The timing override is not supported yet; must be set to _AUTO.

Enumerator
NV_TIMING_OVERRIDE_CURRENT | get the current timing
NV_TIMING_OVERRIDE_AUTO | the timing the driver will use based the current policy
NV_TIMING_OVERRIDE_EDID | EDID timing.
NV_TIMING_OVERRIDE_DMT | VESA DMT timing.
NV_TIMING_OVERRIDE_DMT_RB | VESA DMT timing with reduced blanking.
NV_TIMING_OVERRIDE_CVT | VESA CVT timing.
NV_TIMING_OVERRIDE_CVT_RB | VESA CVT timing with reduced blanking.
NV_TIMING_OVERRIDE_GTF | VESA GTF timing.
NV_TIMING_OVERRIDE_EIA861 | EIA 861x pre-defined timing.
NV_TIMING_OVERRIDE_ANALOG_TV | analog SD/HDTV timing
NV_TIMING_OVERRIDE_CUST | NV custom timings.
NV_TIMING_OVERRIDE_NV_PREDEFINED | NV pre-defined timing (basically the PsF timings)
NV_TIMING_OVERRIDE_NV_PSF |
NV_TIMING_OVERRIDE_NV_ASPR |
NV_TIMING_OVERRIDE_SDI | Override for SDI timing.
NV_TIMING_OVRRIDE_MAX |

◆ NV_INFOFRAME_CMD

enum NV_INFOFRAME_CMD
Enumerator
NV_INFOFRAME_CMD_GET_DEFAULT | Returns the fields in the infoframe with values set by the manufacturer - NVIDIA/OEM.
NV_INFOFRAME_CMD_RESET | Sets the fields in the infoframe to auto, and infoframe to the default infoframe for use in a set.
NV_INFOFRAME_CMD_GET | Get the current infoframe state.
NV_INFOFRAME_CMD_SET | Set the current infoframe state (flushed to the monitor), the values are one time and do not persist.
NV_INFOFRAME_CMD_GET_OVERRIDE | Get the override infoframe state, non-override fields will be set to value = AUTO, overridden fields will have the current override values.
NV_INFOFRAME_CMD_SET_OVERRIDE | Set the override infoframe state, non-override fields will be set to value = AUTO, other values indicate override; persist across modeset/reboot.
NV_INFOFRAME_CMD_GET_PROPERTY | get properties associated with infoframe (each of the infoframe type will have properties)
NV_INFOFRAME_CMD_SET_PROPERTY | set properties associated with infoframe

◆ NV_MONITOR_CAPS_TYPE

enum NV_MONITOR_CAPS_TYPE

HDMI-related and extended CAPs.

Enumerator
NV_MONITOR_CAPS_TYPE_HDMI_VSDB
NV_MONITOR_CAPS_TYPE_HDMI_VCDB
NV_MONITOR_CAPS_TYPE_GENERIC

Function Documentation

◆ __nvapi_deprecated_function() [1/2]

__nvapi_deprecated_function | ( | "Do not use this function - it is deprecated in release 290. | Instead,
 |  | use NvAPI_DISP_GetDisplayConfig." |
 | ) |  |

This API lets caller retrieve the target display arrangement for selected source display handle.

Note
Display PATH with this API is limited to single GPU. DUALVIEW across GPUs will be returned as STANDARD VIEW. Use NvAPI_SYS_GetDisplayTopologies() to query views across GPUs.
Since
Release: 85
Parameters
[in] | hNvDisplay | NVIDIA Display selection. It can be NVAPI_DEFAULT_HANDLE or a handle enumerated from NvAPI_EnumNVidiaDisplayHandle().
[out] | pTargets | User allocated storage to retrieve an array of NV_VIEW_TARGET_INFO. Can be NULL to retrieve the targetCount.
[in,out] | targetMaskCount | Count of target device mask specified in pTargetMask.
[out] | targetView | Target view selected from NV_TARGET_VIEW_MODE.
Return values
NVAPI_OK | Completed request
NVAPI_ERROR | Miscellaneous error occurred
NVAPI_INVALID_ARGUMENT | Invalid input parameter.

DESCRIPTION: This API lets caller retrieve the target display arrangement for selected source display handle.

Note
Display PATH with this API is limited to single GPU. DUALVIEW across GPUs will be returned as STANDARD VIEW. Use NvAPI_SYS_GetDisplayTopologies() to query views across GPUs.
Since
Release: 165
Parameters
[in] | hNvDisplay | NVIDIA Display selection. NVAPI_DEFAULT_HANDLE is not allowed, it has to be a handle enumerated with NvAPI_EnumNVidiaDisplayHandle().
[in,out] | pPathInfo | Count field should be set to NVAPI_MAX_DISPLAY_PATH. Can be NULL to retrieve just the pathCount.
[in,out] | pPathCount | Number of elements in array pPathInfo->path.
[out] | pTargetViewMode | Display view selected from NV_TARGET_VIEW_MODE.
Return values
NVAPI_OK | Completed request
NVAPI_API_NOT_INTIALIZED | NVAPI not initialized
NVAPI_ERROR | Miscellaneous error occurred
NVAPI_INVALID_ARGUMENT | Invalid input parameter.
NVAPI_EXPECTED_DISPLAY_HANDLE | hNvDisplay is not a valid display handle.

◆ __nvapi_deprecated_function() [2/2]

__nvapi_deprecated_function | ( | "Do not use this function - it is deprecated in release 290. | Instead,
 |  | use NvAPI_DISP_SetDisplayConfig." |
 | ) |  |

◆ NvAPI_CreateDisplayFromUnAttachedDisplay()

NVAPI_INTERFACE NvAPI_CreateDisplayFromUnAttachedDisplay | ( | NvUnAttachedDisplayHandle | hNvUnAttachedDisp,
 |  | NvDisplayHandle * | pNvDisplay
 | ) |  |

This function converts the unattached display handle to an active attached display handle.

At least one GPU must be present in the system and running an NVIDIA display driver.

SUPPORTED OS: Windows 7 and higher

Since
Release: 80
Return values
NVAPI_INVALID_ARGUMENT | hNvUnAttachedDisp is not valid or pNvDisplay is NULL.
NVAPI_OK | One or more handles were returned
NVAPI_NVIDIA_DEVICE_NOT_FOUND | No NVIDIA GPU driving a display was found

◆ NvAPI_DisableHWCursor()

NVAPI_INTERFACE NvAPI_DisableHWCursor ( NvDisplayHandle hNvDisplay )

This function disables hardware cursor support

SUPPORTED OS: Windows XP

Since
Release: 80
Returns
NVAPI_ERROR or NVAPI_OK

◆ NvAPI_DISP_AcquireDedicatedDisplay()

NVAPI_INTERFACE NvAPI_DISP_AcquireDedicatedDisplay | ( | __in NvU32 | displayId,
 |  | __inout NvU64 * | pDisplaySourceHandle
 | ) |  |

SUPPORTED OS: Windows 10 and higher DESCRIPTION: This API requests exclusive access to the specified dedicated display managed by the Nvidia driver. If the call succeeds, a handle is returned which could be opened as a DisplaySource. The call fails if the display is not managed by the Nvidia driver. The call fails if the display has already been acquired by another process.

Since
Release: 495
Parameters
[in] | displayId | Display ID of the dedicated display to be acquired.
[in/out] | pDisplaySourceHandle Pointer to memory that receives the shared handle to a DisplaySource.
Return values
NVAPI_OK | The call succeeded.
NVAPI_ERROR | The call failed.
NVAPI_NO_IMPLEMENTATION | The API not implemented.
NVAPI_INVALID_POINTER | An invalid pointer was passed as an argument.
NVAPI_API_NOT_INITIALIZED | NvAPI not initialized.
NVAPI_INVALID_DISPLAY_ID | An invalid displayId was passed as an argument.
NVAPI_UNREGISTERED_RESOURCE | The display is not managed by the Nvidia driver.
NVAPI_RESOURCE_IN_USE | The display has already been acquired by another process.

◆ NvAPI_Disp_ColorControl()

NvAPI_Disp_ColorControl | ( | NvU32 | displayId,
 |  | NV_COLOR_DATA * | pColorData
 | ) |  |

DESCRIPTION: This API controls the Color values.

SUPPORTED OS: Windows 7 and higher

Parameters
[in] | displayId | Monitor Identifier
[in,out] | pColorData | Contains data corresponding to color information
Returns
RETURN STATUS: NVAPI_OK, NVAPI_ERROR, NVAPI_INVALID_ARGUMENT

◆ NvAPI_DISP_DeleteCustomDisplay()

NVAPI_INTERFACE NvAPI_DISP_DeleteCustomDisplay | ( | __in_ecount(count) NvU32 * | pDisplayIds,
 |  | __in NvU32 | count,
 |  | __in NV_CUSTOM_DISPLAY * | pCustDisp
 | ) |  |

DESCRIPTION: This function deletes the custom display configuration, specified from the registry for all the displays whose display IDs are passed.

SUPPORTED OS: Windows 7 and higher

Since
Release: 313
Parameters
[in] | pDisplayIds | Array of Dispaly IDs on which custom display configuration is to be saved.
[in] | count | Total number of the incoming Dispaly IDs. This is for the multi-head support.
[in] | pCustDisp | Pointer to the NV_CUSTOM_DISPLAY structure
Returns
This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.
Return values
NVAPI_INVALID_DISPLAY_ID Custom Timing is not supported on the Display, whose display id is passed

◆ NvAPI_DISP_EnumCustomDisplay()

NVAPI_INTERFACE NvAPI_DISP_EnumCustomDisplay | ( | __in NvU32 | displayId,
 |  | __in NvU32 | index,
 |  | __inout NV_CUSTOM_DISPLAY * | pCustDisp
 | ) |  |

DESCRIPTION: This API enumerates the custom timing specified by the enum index. The client should keep enumerating until it returns NVAPI_END_ENUMERATION.

SUPPORTED OS: Windows 7 and higher

Since
Release: 313
Parameters
[in] | displayId | Dispaly ID of the display.
[in] | index | Enum index
[in,out] | pCustDisp | Pointer to the NV_CUSTOM_DISPLAY structure
Returns
This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.
Return values
NVAPI_INVALID_DISPLAY_ID Custom Timing is not supported on the Display, whose display id is passed

◆ NvAPI_DISP_GetAdaptiveSyncData()

NvAPI_DISP_GetAdaptiveSyncData | ( | __in NvU32 | displayId,
 |  | __inout NV_GET_ADAPTIVE_SYNC_DATA * | pAdaptiveSyncData
 | ) |  |
DESCRIPTION: This function is used to get data for the Adaptive Sync Display.
SUPPORTED OS: Windows 10 and higher
\since Release: 415
\param [in] displayId - display id of the display
\param [inout] pAdaptiveSyncData - A pointer to NV_GET_ADAPTIVE_SYNC_DATA, containing the information about the values of parameters that are to be retrieved on given display.
\return This API can return any of the error codes enumerated in
#NvAPI_Status. If there are return error codes with specific
meaning for this API, they are listed below.
NV_GET_ADAPTIVE_SYNC_DATA
NV_GET_ADAPTIVE_SYNC_DATA_V1 NV_GET_ADAPTIVE_SYNC_DATA
Definition nvapi.h:8756

◆ NvAPI_DISP_GetDisplayConfig()

NVAPI_INTERFACE NvAPI_DISP_GetDisplayConfig | ( | __inout NvU32 * | pathInfoCount,
 |  | __out_ecount_full_opt *pathInfoCount NV_DISPLAYCONFIG_PATH_INFO * | pathInfo
 | ) |  |

DESCRIPTION: This API lets caller retrieve the current global display configuration. USAGE: The caller might have to call this three times to fetch all the required configuration details as follows: First Pass: Caller should Call NvAPI_DISP_GetDisplayConfig() with pathInfo set to NULL to fetch pathInfoCount. Second Pass: Allocate memory for pathInfo with respect to the number of pathInfoCount(from First Pass) to fetch targetInfoCount. If sourceModeInfo is needed allocate memory or it can be initialized to NULL. Third Pass(Optional, only required if target information is required): Allocate memory for targetInfo with respect to number of targetInfoCount(from Second Pass). SUPPORTED OS: Windows 7 and higher

Parameters
[in,out] | pathInfoCount | Number of elements in pathInfo array, returns number of valid topologies, this cannot be null.
[in,out] | pathInfo | Array of path information
Returns
This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.
Return values
NVAPI_INVALID_ARGUMENT - Invalid input parameter. Following can be the reason for this return value:
  1. pathInfoCount is NULL.
  2. *pathInfoCount is 0 and pathInfo is not NULL.
  3. *pathInfoCount is not 0 and pathInfo is NULL.
NVAPI_DEVICE_BUSY - ModeSet has not yet completed. Please wait and call it again.

◆ NvAPI_DISP_GetDisplayIdByDisplayName()

NVAPI_INTERFACE NvAPI_DISP_GetDisplayIdByDisplayName | ( | const char * | displayName,
 |  | NvU32 * | displayId
 | ) |  |

SUPPORTED OS: Windows 7 and higher DESCRIPTION: This API retrieves the Display Id of a given display by display name. The display must be active to retrieve the displayId. In the case of clone mode or Surround gaming, the primary or top-left display will be returned.

Parameters
[in] | displayName | Name of display (Eg: "\\DISPLAY1" to retrieve the displayId for.
[out] | displayId | Display ID of the requested display.

retval NVAPI_OK: Capabilties have been returned. retval NVAPI_INVALID_ARGUMENT: One or more args passed in are invalid. retval NVAPI_API_NOT_INTIALIZED: The NvAPI API needs to be initialized first retval NVAPI_NO_IMPLEMENTATION: This entrypoint not available retval NVAPI_ERROR: Miscellaneous error occurred

◆ NvAPI_DISP_GetEdidData()

NVAPI_INTERFACE NvAPI_DISP_GetEdidData | ( | __in NvU32 | displayId,
 |  | __inout NV_EDID_DATA * | pEdidParams,
 |  | __inout NV_EDID_FLAG * | pFlag
 | ) |  |
DESCRIPTION: This API returns the EDID data for the specified display Id.
(NvAPI_GPU_GetConnectedDisplayIds() can be used to get the DisplayIds).
USAGE: The caller has to call this API two times to fetch the required details as follows:
First Pass : Caller should call NvAPI_DISP_GetEdidData() with pEdidParams->pEDID set to NULL,
to get the size of the EDID buffer in pEdidParams->sizeOfEDID.
Second Pass: Allocate memory for the EDID buffer of the size - pEdidParams->sizeOfEDID,
and call the API again to get the EDID buffer populated.
\param [in] displayId - NVIDIA Display ID
\param [inout] pEdidParams - Pointer to the structure that contains - pointer to EDID buffer and its size
\param [inout] pFlag - The type of EDID to be retrieved (IN).
To only retrieve the EDID type, the user should send pEdidParams->pEDID as NULL and
pEdidParams->sizeOfEDID as 0.
SUPPORTED OS: Windows 7 and higher
\since Release: 400
\return This API can return any of the error codes enumerated in #NvAPI_Status.
If there are return error codes with specific meaning for this API, they are listed below.
NVAPI_INSUFFICIENT_BUFFER: Reallocate buffer with pEdidParams->sizeOfEDID and call again to get complete data.
In this case pEdidParams->pEDID contains undefined data.
This error occurs only when pEdidParams->pEDID is present.

◆ NvAPI_DISP_GetGDIPrimaryDisplayId()

NVAPI_INTERFACE NvAPI_DISP_GetGDIPrimaryDisplayId ( NvU32 * displayId )

SUPPORTED OS: Windows 7 and higher DESCRIPTION: This API returns the Display ID of the GDI Primary.

Parameters
[out] displayId Display ID of the GDI Primary display.
Return values
NVAPI_OK | Capabilties have been returned.
NVAPI_NVIDIA_DEVICE_NOT_FOUND | GDI Primary not on an NVIDIA GPU.
NVAPI_INVALID_ARGUMENT | One or more args passed in are invalid.
NVAPI_API_NOT_INTIALIZED | The NvAPI API needs to be initialized first
NVAPI_NO_IMPLEMENTATION | This entrypoint not available
NVAPI_ERROR | Miscellaneous error occurred

◆ NvAPI_DISP_GetMonitorCapabilities()

NVAPI_INTERFACE NvAPI_DISP_GetMonitorCapabilities | ( | __in NvU32 | displayId,
 |  | __inout NV_MONITOR_CAPABILITIES * | pMonitorCapabilities
 | ) |  |

SUPPORTED OS: Windows 7 and higher

◆ NvAPI_DISP_GetMonitorColorCapabilities()

NVAPI_INTERFACE NvAPI_DISP_GetMonitorColorCapabilities | ( | __in NvU32 | displayId,
 |  | __inout_ecount_part_opt *, *pColorCapsCount NV_MONITOR_COLOR_CAPS * | pMonitorColorCapabilities,
 |  | __inout NvU32 * | pColorCapsCount
 | ) |  |

DESCRIPTION: This API returns all the color formats and bit depth values supported by a given DP monitor.

USAGE: Sequence of calls which caller should make to get the information.

  1. First call NvAPI_DISP_GetMonitorColorCapabilities() with pMonitorColorCapabilities as NULL to get the count.
  2. Allocate memory for color caps(NV_MONITOR_COLOR_CAPS) array.
  3. Call NvAPI_DISP_GetMonitorColorCapabilities() again with the pointer to the memory allocated to get all the color capabilities.

Note :

  1. pColorCapsCount should never be NULL, else the API will fail with NVAPI_INVALID_ARGUMENT.
  2. *pColorCapsCount returned from the API will always be the actual count in any/every call.
  3. Memory size to be allocated should be (*pColorCapsCount * sizeof(NV_MONITOR_COLOR_CAPS)).
  4. If the memory allocated is less than what is required to return all the timings, this API will return the amount of information which can fit in user provided buffer and API will return NVAPI_INSUFFICIENT_BUFFER.
  5. If the caller specifies a greater value for *pColorCapsCount in second call to NvAPI_DISP_GetMonitorColorCapabilities() than what was returned from first call, the API will return only the actual number of elements in the color capabilities array and the extra buffer will remain unused.

SUPPORTED OS: Windows 7 and higher

Parameters
[in] | displayId | Monitor Identifier
[in,out] | pMonitorColorCapabilities | The monitor color capabilities information
[in,out] pColorCapsCount - During input, the number of elements allocated for the pMonitorColorCapabilities pointer
  • During output, the actual number of color data elements the monitor supports
Returns
This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.
Return values
NVAPI_INSUFFICIENT_BUFFER | The input buffer size is not sufficient to hold the total contents. In this case *pColorCapsCount will hold the required amount of elements.
NVAPI_INVALID_DISPLAY_ID | The input monitor is either not connected or is not a DP panel.

◆ NvAPI_DISP_GetPreferredStereoDisplay()

NVAPI_INTERFACE NvAPI_DISP_GetPreferredStereoDisplay ( __inout NV_GET_PREFERRED_STEREO_DISPLAY * pPreferredStereoDisplay )

DESCRIPTION: Queries the displayId of the display output driving the 3pin DIN stereo signal, if any. SUPPORTED OS: Windows 10 and higher

Since
Release: 470
Parameters
[in,out] pPreferredStereoDisplay Pointer to a NV_GET_PREFERRED_STEREO_DISPLAY structure
Return values
NVAPI_OK | completed request
NVAPI_ERROR | miscellaneous error occurred
NVAPI_INVALID_ARGUMENT | Invalid input parameter.
NVAPI_INVALID_POINTER | An invalid pointer was passed as an argument (probably NULL).

◆ NvAPI_DISP_GetTiming()

NVAPI_INTERFACE NvAPI_DISP_GetTiming | ( | __in NvU32 | displayId,
 |  | __in NV_TIMING_INPUT * | timingInput,
 |  | __out NV_TIMING * | pTiming
 | ) |  |

DESCRIPTION: This function calculates the timing from the visible width/height/refresh-rate and timing type info.

SUPPORTED OS: Windows 7 and higher

Since
Release: 313
Parameters
[in] | displayId | Display ID of the display.
[in] | timingInput | Inputs used for calculating the timing.
[out] | pTiming | Pointer to the NV_TIMING structure.
Returns
This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.

◆ NvAPI_DISP_GetVirtualRefreshRateData()

NvAPI_DISP_GetVirtualRefreshRateData | ( | __in NvU32 | displayId,
 |  | __inout NV_GET_VIRTUAL_REFRESH_RATE_DATA * | pVirtualRefreshRateData
 | ) |  |
DESCRIPTION: This function is used to get Virtual Refresh Rate data for a VRR Capable Display.
SUPPORTED OS: Windows 10 and higher
\since Release: 510
\param [in] displayId - display id of the display
\param [inout] pVirtualRefreshRateData - A pointer to NV_GET_VIRTUAL_REFRESH_RATE_DATA, containing the information about the values of parameters that are to be retrieved on given display.
\return This API can return any of the error codes enumerated in
#NvAPI_Status. If there are return error codes with specific
meaning for this API, they are listed below.
NV_GET_VIRTUAL_REFRESH_RATE_DATA
NV_GET_VIRTUAL_REFRESH_RATE_DATA_V1 NV_GET_VIRTUAL_REFRESH_RATE_DATA
Definition nvapi.h:8829

◆ NvAPI_Disp_GetVRRInfo()

NVAPI_INTERFACE NvAPI_Disp_GetVRRInfo | ( | __in NvU32 | displayId,
 |  | __inout NV_GET_VRR_INFO * | pVrrInfo
 | ) |  |

DESCRIPTION: This API returns Variable Refresh Rate(VRR) information for the given display ID.

SUPPORTED OS: Windows 10 and higher

Since
Release: 525
Parameters
[in,out] pVrrInfo Pointer to the NV_GET_VRR_INFO structure.
Returns
This API can return any of the error codes enumerated in NvAPI_Status.

◆ NvAPI_Disp_InfoFrameControl()

NVAPI_INTERFACE NvAPI_Disp_InfoFrameControl | ( | __in NvU32 | displayId,
 |  | __inout NV_INFOFRAME_DATA * | pInfoframeData
 | ) |  |

DESCRIPTION: This API controls the InfoFrame values.

SUPPORTED OS: Windows 7 and higher

Parameters
[in] | displayId | Monitor Identifier
[in,out] | pInfoframeData | Contains data corresponding to InfoFrame
Returns
This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.

◆ NvAPI_DISP_ReleaseDedicatedDisplay()

NVAPI_INTERFACE NvAPI_DISP_ReleaseDedicatedDisplay ( __in NvU32 displayId )

SUPPORTED OS: Windows 10 and higher DESCRIPTION: This API releases the exclusive ownership of a specific dedicated display previously acquired by the process.

Since
Release: 495
Parameters
[in] displayId Display ID of the dedicated display to be released.
Return values
NVAPI_OK | The call succeeded.
NVAPI_ERROR | The call failed.
NVAPI_NO_IMPLEMENTATION | The API not implemented.
NVAPI_API_NOT_INITIALIZED | NvAPI not initialized.
NVAPI_UNREGISTERED_RESOURCE | The display is not managed by the Nvidia driver.
::NVAPI_DDISPLAY_NOT_ACQUIRED | The display is not acquired by the process.

◆ NvAPI_DISP_RevertCustomDisplayTrial()

NVAPI_INTERFACE NvAPI_DISP_RevertCustomDisplayTrial | ( | __in_ecount(count) NvU32 * | pDisplayIds,
 |  | __in NvU32 | count
 | ) |  |

DESCRIPTION: This API is used to restore the display configuration, that was changed by calling NvAPI_DISP_TryCustomDisplay(). This function must be called only after a custom display configuration is tested on the hardware, using NvAPI_DISP_TryCustomDisplay(), otherwise no action is taken. On Vista, NvAPI_DISP_RevertCustomDisplayTrial should be called with an active display that was affected during the NvAPI_DISP_TryCustomDisplay() call, per GPU.

SUPPORTED OS: Windows 7 and higher

Since
Release: 313
Parameters
[in] | pDisplayIds | Pointer to display Id, of an active display.
[in] | count | Total number of incoming Display IDs. For future use only. Currently it is expected to be passed as 1.
Returns
This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.

◆ NvAPI_DISP_SaveCustomDisplay()

NVAPI_INTERFACE NvAPI_DISP_SaveCustomDisplay | ( | __in_ecount(count) NvU32 * | pDisplayIds,
 |  | __in NvU32 | count,
 |  | __in NvU32 | isThisOutputIdOnly,
 |  | __in NvU32 | isThisMonitorIdOnly
 | ) |  |

DESCRIPTION: This function saves the current hardware display configuration on the specified Display IDs as a custom display configuration. This function should be called right after NvAPI_DISP_TryCustomDisplay() to save the custom display from the current hardware context. This function will not do anything if the custom display configuration is not tested on the hardware.

SUPPORTED OS: Windows 7 and higher

Since
Release: 313
Parameters
[in] | pDisplayIds | Array of Dispaly IDs on which custom display configuration is to be saved.
[in] | count | Total number of the incoming Dispaly IDs. This is for the multi-head support.
[in] | isThisOutputIdOnly | If set, the saved custom display will only be applied on the monitor with the same outputId (see NvAPI Handles).
[in] | isThisMonitorIdOnly | If set, the saved custom display will only be applied on the monitor with the same EDID ID or the same TV connector in case of analog TV.
Returns
This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.
Return values
NVAPI_INVALID_DISPLAY_ID Custom Timing is not supported on the Display, whose display id is passed

◆ NvAPI_DISP_SetAdaptiveSyncData()

NvAPI_DISP_SetAdaptiveSyncData | ( | __in NvU32 | displayId,
 |  | __in NV_SET_ADAPTIVE_SYNC_DATA * | pAdaptiveSyncData
 | ) |  |
DESCRIPTION: This function is used to set data for Adaptive Sync Display.
SUPPORTED OS: Windows 10 and higher
\since Release: 415
\param [in] displayId - display id of the display
\param [in] pAdaptiveSyncData - A pointer to NV_SET_ADAPTIVE_SYNC_DATA, containing the information about the values of parameters that are to be set on given display.
\return This API can return any of the error codes enumerated in
#NvAPI_Status. If there are return error codes with specific
meaning for this API, they are listed below.
NV_SET_ADAPTIVE_SYNC_DATA
NV_SET_ADAPTIVE_SYNC_DATA_V1 NV_SET_ADAPTIVE_SYNC_DATA
Definition nvapi.h:8794

◆ NvAPI_DISP_SetDisplayConfig()

NVAPI_INTERFACE NvAPI_DISP_SetDisplayConfig | ( | __in NvU32 | pathInfoCount,
 |  | __in_ecount(pathInfoCount) NV_DISPLAYCONFIG_PATH_INFO * | pathInfo,
 |  | __in NvU32 | flags
 | ) |  |

DESCRIPTION: This API lets caller apply a global display configuration across multiple GPUs.

If all sourceIds are zero, then NvAPI will pick up sourceId's based on the following criteria :

  • If user provides sourceModeInfo then we are trying to assign 0th sourceId always to GDIPrimary. This is needed since active windows always moves along with 0th sourceId.
  • For rest of the paths, we are incrementally assigning the sourceId per adapter basis.
  • If user doesn't provide sourceModeInfo then NVAPI just picks up some default sourceId's in incremental order. Note : NVAPI will not intelligently choose the sourceIDs for any configs that does not need a modeset.

SUPPORTED OS: Windows 7 and higher

Parameters
[in] | pathInfoCount | Number of supplied elements in pathInfo
[in] | pathInfo | Array of path information
[in] | flags | A bitwise OR of supported flags from NV_DISPLAYCONFIG_FLAGS.
Return values
NVAPI_OK | - completed request
NVAPI_API_NOT_INTIALIZED | - NVAPI not initialized
NVAPI_ERROR | - miscellaneous error occurred
NVAPI_INVALID_ARGUMENT | - Invalid input parameter.

◆ NvAPI_DISP_SetPreferredStereoDisplay()

NVAPI_INTERFACE NvAPI_DISP_SetPreferredStereoDisplay ( __in NV_SET_PREFERRED_STEREO_DISPLAY * pPreferredStereoDisplay )

DESCRIPTION: Specifies a display output that drives the 3pin DIN output signal in a workstation stereo system environment. If display output is specified as a displayId of 0, the preferred stereo display target is reset to the driver default selection.

SUPPORTED OS: Windows 10 and higher

Since
Release: 470
Parameters
[in] pPreferredStereoDisplay Pointer to a NV_SET_PREFERRED_STEREO_DISPLAY structure
Return values
NVAPI_OK | completed request
NVAPI_ERROR | miscellaneous error occurred
NVAPI_INVALID_ARGUMENT | Invalid input parameter.
NVAPI_INVALID_USER_PRIVILEGE | - The application will require Administrator privileges to access this API. The application can be elevated to a higher permission level by selecting "Run as Administrator".

◆ NvAPI_DISP_SetVirtualRefreshRateData()

NvAPI_DISP_SetVirtualRefreshRateData | ( | __in NvU32 | displayId,
 |  | __in NV_SET_VIRTUAL_REFRESH_RATE_DATA * | pVirtualRefreshRateData
 | ) |  |
DESCRIPTION: This function is used to set Virtual Refresh Rate data for a VRR Capable Display.
SUPPORTED OS: Windows 10 and higher
\since Release: 510
\param [in] displayId - display id of the display
\param [inout] pVirtualRefreshRateData - A pointer to NV_SET_VIRTUAL_REFRESH_RATE_DATA, containing the information about the values of parameters that are to be retrieved on given display.
\return This API can return any of the error codes enumerated in
#NvAPI_Status. If there are return error codes with specific
meaning for this API, they are listed below.
NV_SET_VIRTUAL_REFRESH_RATE_DATA
NV_SET_VIRTUAL_REFRESH_RATE_DATA_V1 NV_SET_VIRTUAL_REFRESH_RATE_DATA
Definition nvapi.h:8863

◆ NvAPI_DISP_TryCustomDisplay()

NVAPI_INTERFACE NvAPI_DISP_TryCustomDisplay | ( | __in_ecount(count) NvU32 * | pDisplayIds,
 |  | __in NvU32 | count,
 |  | __in_ecount(count) NV_CUSTOM_DISPLAY * | pCustDisp
 | ) |  |

DESCRIPTION: This API is used to set up a custom display without saving the configuration on multiple displays.

Note
All the members of srcPartition, present in NV_CUSTOM_DISPLAY structure, should have their range in (0.0,1.0). In clone mode the timings can applied to both the target monitors but only one target at a time.
For the secondary target the applied timings works under the following conditions:
  • If the secondary monitor EDID supports the selected timing, OR
  • If the selected custom timings can be scaled by the secondary monitor for the selected source resolution on the primary, OR
  • If the selected custom timings matches the existing source resolution on the primary. Setting up a custom display on non-active but connected monitors is supported only for Win7 and above.

SUPPORTED OS: Windows 7 and higher

Since
Release: 313
Parameters
[in] | pDisplayIds | Array of the target display Dispaly IDs - See NvAPI Handles.
[in] | count | Total number of the incoming Display IDs and corresponding NV_CUSTOM_DISPLAY structure. This is for the multi-head support.
[in] | pCustDisp | Pointer to the NV_CUSTOM_DISPLAY structure array.
Returns
This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.
Return values
NVAPI_INVALID_DISPLAY_ID Custom Timing is not supported on the Display, whose display id is passed

◆ NvAPI_EnableHWCursor()

NVAPI_INTERFACE NvAPI_EnableHWCursor ( NvDisplayHandle hNvDisplay )

This function enables hardware cursor support

SUPPORTED OS: Windows XP

Since
Release: 80
Returns
NVAPI_ERROR or NVAPI_OK

◆ NvAPI_GetAssociatedDisplayOutputId()

NVAPI_INTERFACE NvAPI_GetAssociatedDisplayOutputId | ( | NvDisplayHandle | hNvDisplay,
 |  | NvU32 * | pOutputId
 | ) |  |

This function gets the active outputId associated with the display handle.

SUPPORTED OS: Windows 7 and higher

Since
Release: 90
Parameters
[in] | hNvDisplay | NVIDIA Display selection. It can be NVAPI_DEFAULT_HANDLE or a handle enumerated from NvAPI_EnumNVidiaDisplayHandle().
[out] | outputId | The active display output ID associated with the selected display handle hNvDisplay. The outputid will have only one bit set. In the case of Clone or Span mode, this will indicate the display outputId of the primary display that the GPU is driving. See NvAPI Handles.
Return values
NVAPI_OK | Call successful.
NVAPI_NVIDIA_DEVICE_NOT_FOUND | No NVIDIA GPU driving a display was found.
NVAPI_EXPECTED_DISPLAY_HANDLE | hNvDisplay is not a valid display handle.

◆ NvAPI_GetAssociatedNvidiaDisplayName()

NVAPI_INTERFACE NvAPI_GetAssociatedNvidiaDisplayName | ( | NvDisplayHandle | NvDispHandle,
 |  | NvAPI_ShortString | szDisplayName
 | ) |  |

For a given NVIDIA display handle, this function returns a string (such as "\\.\DISPLAY1") to identify the display.

SUPPORTED OS: Windows 7 and higher

Since
Release: 80
Return values
NVAPI_INVALID_ARGUMENT | Either argument is NULL
NVAPI_OK | *pNvDispHandle is now valid
NVAPI_NVIDIA_DEVICE_NOT_FOUND | No NVIDIA device maps to that display name

◆ NvAPI_GetDisplayPortInfo()

NVAPI_INTERFACE NvAPI_GetDisplayPortInfo | ( | __in_opt NvDisplayHandle | hNvDisplay,
 |  | __in NvU32 | outputId,
 |  | __inout NV_DISPLAY_PORT_INFO * | pInfo
 | ) |  |

◆ NvAPI_GetHDMISupportInfo()

NVAPI_INTERFACE NvAPI_GetHDMISupportInfo | ( | __in_opt NvDisplayHandle | hNvDisplay,
 |  | __in NvU32 | outputId,
 |  | __inout NV_HDMI_SUPPORT_INFO * | pInfo
 | ) |  |

◆ NvAPI_GetSupportedViews()

NVAPI_INTERFACE NvAPI_GetSupportedViews | ( | NvDisplayHandle | hNvDisplay,
 |  | NV_TARGET_VIEW_MODE * | pTargetViews,
 |  | NvU32 * | pViewCount
 | ) |  |

This API lets caller enumerate all the supported NVIDIA display views - nView and Dualview modes.

SUPPORTED OS: Windows 7 and higher

Since
Release: 85
Parameters
[in] | hNvDisplay | NVIDIA Display selection. It can be NVAPI_DEFAULT_HANDLE or a handle enumerated from NvAPI_EnumNVidiaDisplayHandle().
[out] | pTargetViews | Array of supported views. Can be NULL to retrieve the pViewCount first.
[in,out] | pViewCount | Count of supported views.
Return values
NVAPI_OK | Completed request
NVAPI_ERROR | Miscellaneous error occurred
NVAPI_INVALID_ARGUMENT | Invalid input parameter.

◆ NvAPI_GetUnAttachedAssociatedDisplayName()

NVAPI_INTERFACE NvAPI_GetUnAttachedAssociatedDisplayName | ( | NvUnAttachedDisplayHandle | hNvUnAttachedDisp,
 |  | NvAPI_ShortString | szDisplayName
 | ) |  |

This function returns the display name given, for example, "\\DISPLAY1", using the unattached NVIDIA display handle

SUPPORTED OS: Windows 7 and higher

Since
Release: 95
Return values
NVAPI_INVALID_ARGUMENT | Either argument is NULL
NVAPI_OK | *pNvDispHandle is now valid
NVAPI_NVIDIA_DEVICE_NOT_FOUND | No NVIDIA device maps to that display name

◆ NvAPI_GetVBlankCounter()

NVAPI_INTERFACE NvAPI_GetVBlankCounter | ( | NvDisplayHandle | hNvDisplay,
 |  | NvU32 * | pCounter
 | ) |  |

This function gets the V-blank counter

SUPPORTED OS: Windows 7 and higher

Since
Release: 80
Returns
NVAPI_ERROR or NVAPI_OK

◆ NvAPI_SetDisplayPort()

NVAPI_INTERFACE NvAPI_SetDisplayPort | ( | NvDisplayHandle | hNvDisplay,
 |  | NvU32 | outputId,
 |  | NV_DISPLAY_PORT_CONFIG * | pCfg
 | ) |  |

◆ NvAPI_SetRefreshRateOverride()

NVAPI_INTERFACE NvAPI_SetRefreshRateOverride | ( | NvDisplayHandle | hNvDisplay,
 |  | NvU32 | outputsMask,
 |  | float | refreshRate,
 |  | NvU32 | bSetDeferred
 | ) |  |

This function overrides the refresh rate on the given display/outputsMask. The new refresh rate can be applied right away in this API call or deferred to be applied with the next OS modeset. The override is good for only one modeset (regardless whether it's deferred or immediate).

SUPPORTED OS: Windows XP

Since
Release: 80
Parameters
[in] | hNvDisplay | The NVIDIA display handle. It can be NVAPI_DEFAULT_HANDLE or a handle enumerated from NvAPI_EnumNVidiaDisplayHandle().
[in] | outputsMask | A set of bits that identify all target outputs which are associated with the NVIDIA display handle to apply the refresh rate override. When SLI is enabled, the outputsMask only applies to the GPU that is driving the display output.
[in] | refreshRate | The override value. "0.0" means cancel the override.
[in] bSetDeferred
  • "0": Apply the refresh rate override immediately in this API call.
  • "1": Apply refresh rate at the next OS modeset.
Return values
NVAPI_INVALID_ARGUMENT | hNvDisplay or outputsMask is invalid
NVAPI_OK | The refresh rate override is correct set
NVAPI_ERROR | The operation failed


Data Fields
tagNV_TIMINGEXT Struct Reference
Display APIs | OpenGL APIs » Display Control Interface

#include <nvapi.h>

Data Fields

NvU32 flag
NvU16 rr
NvU32 rrx1k
NvU32 aspect
NvU16 rep
NvU32 status
NvU8 name [40]

Detailed Description

NVIDIA-specific timing extras
Used in NV_TIMING.

The documentation for this struct was generated from the following file:


Data Fields
_NV_TIMING Struct Reference
Display APIs | OpenGL APIs » Display Control Interface

#include <nvapi.h>

Data Fields

NvU16 HVisible
NvU16 HBorder
NvU16 HFrontPorch
NvU16 HSyncWidth
NvU16 HTotal
NvU8 HSyncPol
NvU16 VVisible
NvU16 VBorder
NvU16 VFrontPorch
NvU16 VSyncWidth
NvU16 VTotal
NvU8 VSyncPol
NvU16 interlaced
NvU32 pclk
NV_TIMINGEXT etc

Detailed Description

The very basic timing structure based on the VESA standard:

|<----------------------------htotal--------------------------->|
---------"active" video-------->|<-------blanking------>|<-----
|<-------hvisible-------->|<-hb->|<-hfp->|<-hsw->|<-hbp->|<-hb->|
--------- -+-------------------------+ | | | | |
A A | | | | | | |
: : | | | | | | |
: : | | | | | | |
:vertical| addressable video | | | | | |
: visible| | | | | | |
: : | | | | | | |
: : | | | | | | |
vertical V | | | | | | |
total --+-------------------------+ | | | | |
: vb border | | | | |
: -----------------------------------+ | | | |
: vfp front porch | | | |
: -------------------------------------------+ | | |
: vsw sync width | | |
: ---------------------------------------------------+ | |
: vbp back porch | |
: -----------------------------------------------------------+ |
V vb border |
---------------------------------------------------------------------------+
The documentation for this struct was generated from the following file:


Data Fields
NV_VIEW_TARGET_INFO Struct Reference
Display APIs | OpenGL APIs » Display Control Interface

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 count
struct {
NvU32 NV_VIEW_TARGET_INFO::deviceMask
NvU32 NV_VIEW_TARGET_INFO::sourceId
NvU32 NV_VIEW_TARGET_INFO::bPrimary:1
NvU32 NV_VIEW_TARGET_INFO::bInterlaced:1
NvU32 NV_VIEW_TARGET_INFO::bGDIPrimary:1
NvU32 NV_VIEW_TARGET_INFO::bForceModeSet:1
} target [NVAPI_MAX_VIEW_TARGET]

Detailed Description

Used in NvAPI_SetView() and NvAPI_GetView()

The documentation for this struct was generated from the following file:


Data Fields
NV_DISPLAY_PATH Struct Reference
Display APIs | OpenGL APIs » Display Control Interface

#include <nvapi.h>

Data Fields

NvU32 deviceMask
NvU32 sourceId
NvU32 | bPrimary:1
NV_GPU_CONNECTOR_TYPE connector
NvU32 width
NvU32 height
NvU32 depth
NV_FORMAT colorFormat
NV_ROTATE rotation
NV_SCALING scaling
NvU32 refreshRate
NvU32 | interlaced:1
NV_DISPLAY_TV_FORMAT tvFormat
NvU32 posx
NvU32 posy
NvU32 | bGDIPrimary:1
NvU32 | bForceModeSet:1
NvU32 | bFocusDisplay:1
NvU32 | gpuId:24

Detailed Description

Used in NV_DISPLAY_PATH_INFO.

The documentation for this struct was generated from the following file:


Data Fields
NV_DISPLAY_PATH_INFO_V3 Struct Reference
Display APIs | OpenGL APIs » Display Control Interface

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 count
NV_DISPLAY_PATH path [NVAPI_MAX_DISPLAY_PATH]

Detailed Description

Used in NvAPI_SetViewEx() and NvAPI_GetViewEx().

The documentation for this struct was generated from the following file:


Data Fields
NV_DISPLAY_PATH_INFO Struct Reference
Display APIs | OpenGL APIs » Display Control Interface

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 count
NV_DISPLAY_PATH path [NVAPI_ADVANCED_MAX_DISPLAY_PATH]

Detailed Description

Used in NvAPI_SetViewEx() and NvAPI_GetViewEx().

The documentation for this struct was generated from the following file:


Data Fields
_NV_POSITION Struct Reference
Display APIs | OpenGL APIs » Display Control Interface

#include <nvapi.h>

Data Fields

NvS32 x
NvS32 y
The documentation for this struct was generated from the following file:


Data Fields
_NV_RESOLUTION Struct Reference
Display APIs | OpenGL APIs » Display Control Interface

#include <nvapi.h>

Data Fields

NvU32 width
NvU32 height
NvU32 colorDepth
The documentation for this struct was generated from the following file:


Data Fields
_NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_V1 Struct Reference
Display APIs | OpenGL APIs » Display Control Interface

#include <nvapi.h>

Data Fields

NvU32 version
NV_ROTATE rotation
NV_SCALING scaling
NvU32 refreshRate1K
NvU32 | interlaced:1
NvU32 | primary:1
NvU32 | reservedBit1:1
NvU32 | disableVirtualModeSupport:1
NvU32 | isPreferredUnscaledTarget:1
NvU32 | reserved:27
NV_GPU_CONNECTOR_TYPE connector
NV_DISPLAY_TV_FORMAT tvFormat
NV_TIMING_OVERRIDE timingOverride
NV_TIMING timing
The documentation for this struct was generated from the following file:


Data Fields
_NV_DISPLAYCONFIG_PATH_TARGET_INFO_V1 Struct Reference
Display APIs | OpenGL APIs » Display Control Interface

#include <nvapi.h>

Data Fields

NvU32 displayId
NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO * details
The documentation for this struct was generated from the following file:


Data Fields
_NV_DISPLAYCONFIG_PATH_TARGET_INFO_V2 Struct Reference
Display APIs | OpenGL APIs » Display Control Interface

#include <nvapi.h>

Data Fields

NvU32 displayId
NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO * details
NvU32 targetId
The documentation for this struct was generated from the following file:


Data Fields
_NV_DISPLAYCONFIG_SOURCE_MODE_INFO_V1 Struct Reference
Display APIs | OpenGL APIs » Display Control Interface

#include <nvapi.h>

Data Fields

NV_RESOLUTION resolution
NV_FORMAT colorFormat
NV_POSITION position
NV_DISPLAYCONFIG_SPANNING_ORIENTATION spanningOrientation
NvU32 | bGDIPrimary: 1
NvU32 | bSLIFocus: 1
NvU32 | reserved: 30
The documentation for this struct was generated from the following file:


Data Fields
_NV_DISPLAYCONFIG_PATH_INFO_V1 Struct Reference
Display APIs | OpenGL APIs » Display Control Interface

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 reserved_sourceId
NvU32 targetInfoCount
NV_DISPLAYCONFIG_PATH_TARGET_INFO_V1 * targetInfo
NV_DISPLAYCONFIG_SOURCE_MODE_INFO_V1 * sourceModeInfo
The documentation for this struct was generated from the following file:


Data Fields
_NV_DISPLAYCONFIG_PATH_INFO_V2 Struct Reference
Display APIs | OpenGL APIs » Display Control Interface

#include <nvapi.h>

Data Fields

NvU32 version
union {
NvU32 _NV_DISPLAYCONFIG_PATH_INFO_V2::sourceId
NvU32 _NV_DISPLAYCONFIG_PATH_INFO_V2::reserved_sourceId
};
NvU32 targetInfoCount
NV_DISPLAYCONFIG_PATH_TARGET_INFO_V2 * targetInfo
NV_DISPLAYCONFIG_SOURCE_MODE_INFO_V1 * sourceModeInfo
NvU32 | IsNonNVIDIAAdapter: 1
NvU32 | reserved: 31
void * | pOSAdapterID
The documentation for this struct was generated from the following file:


Data Fields
_NV_DISPLAY_PORT_INFO_V1 Struct Reference
OpenGL APIs | Display APIs | OpenGL APIs » Display Control Interface

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 dpcd_ver
NV_DP_LINK_RATE maxLinkRate
NV_DP_LANE_COUNT maxLaneCount
NV_DP_LINK_RATE curLinkRate
NV_DP_LANE_COUNT curLaneCount
NV_DP_COLOR_FORMAT colorFormat
NV_DP_DYNAMIC_RANGE dynamicRange
NV_DP_COLORIMETRY colorimetry
NV_DP_BPC bpc
NvU32 | isDp: 1
NvU32 | isInternalDp: 1
NvU32 | isColorCtrlSupported: 1
NvU32 | is6BPCSupported: 1
NvU32 | is8BPCSupported: 1
NvU32 | is10BPCSupported: 1
NvU32 | is12BPCSupported: 1
NvU32 | is16BPCSupported: 1
NvU32 | isYCrCb420Supported: 1
NvU32 | isYCrCb422Supported: 1
NvU32 | isYCrCb444Supported: 1
NvU32 | isRgb444SupportedOnCurrentMode: 1
NvU32 | isYCbCr444SupportedOnCurrentMode: 1
NvU32 | isYCbCr422SupportedOnCurrentMode: 1
NvU32 | isYCbCr420SupportedOnCurrentMode: 1
NvU32 | is6BPCSupportedOnCurrentMode: 1
NvU32 | is8BPCSupportedOnCurrentMode: 1
NvU32 | is10BPCSupportedOnCurrentMode: 1
NvU32 | is12BPCSupportedOnCurrentMode: 1
NvU32 | is16BPCSupportedOnCurrentMode: 1
NvU32 | isMonxvYCC601Capable: 1
NvU32 | isMonxvYCC709Capable: 1
NvU32 | isMonsYCC601Capable: 1
NvU32 | isMonAdobeYCC601Capable: 1
NvU32 | isMonAdobeRGBCapable: 1
NvU32 | isMonBT2020RGBCapable: 1
NvU32 | isMonBT2020YCCCapable: 1
NvU32 | isMonBT2020cYCCCapable: 1
NvU32 | reserved: 4

Detailed Description

Used in NvAPI_GetDisplayPortInfo().

The documentation for this struct was generated from the following file:


Data Fields
NV_DISPLAY_PORT_CONFIG Struct Reference
OpenGL APIs | Display APIs | OpenGL APIs » Display Control Interface

#include <nvapi.h>

Data Fields

NvU32 version
NV_DP_LINK_RATE linkRate
NV_DP_LANE_COUNT laneCount
NV_DP_COLOR_FORMAT colorFormat
NV_DP_DYNAMIC_RANGE dynamicRange
NV_DP_COLORIMETRY colorimetry
NV_DP_BPC bpc
NvU32 | isHPD: 1
NvU32 | isSetDeferred: 1
NvU32 | isChromaLpfOff: 1
NvU32 | isDitherOff: 1
NvU32 | testLinkTrain: 1
NvU32 | testColorChange: 1

Detailed Description

DisplayPort configuration settings - used in NvAPI_SetDisplayPort().

The documentation for this struct was generated from the following file:


Data Fields
_NV_HDMI_SUPPORT_INFO_V1 Struct Reference
OpenGL APIs | Display APIs | OpenGL APIs » Display Control Interface

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 | isGpuHDMICapable: 1
NvU32 | isMonUnderscanCapable: 1
NvU32 | isMonBasicAudioCapable: 1
NvU32 | isMonYCbCr444Capable: 1
NvU32 | isMonYCbCr422Capable: 1
NvU32 | isMonxvYCC601Capable: 1
NvU32 | isMonxvYCC709Capable: 1
NvU32 | isMonHDMI: 1
NvU32 | reserved: 24
NvU32 EDID861ExtRev

Detailed Description

Used in NvAPI_GetHDMISupportInfo().

The documentation for this struct was generated from the following file:


Data Fields
NV_TIMING_FLAG Struct Reference
OpenGL APIs | Display APIs | OpenGL APIs » Display Control Interface

#include <nvapi.h>

Data Fields

NvU32 | isInterlaced: 4
NvU32 | reserved0: 12
union {
NvU32 NV_TIMING_FLAG::tvFormat: 8
NvU32 NV_TIMING_FLAG::ceaId: 8
NvU32 NV_TIMING_FLAG::nvPsfId: 8
};
NvU32 | scaling: 8

Detailed Description

Used in NvAPI_DISP_GetTiming().

The documentation for this struct was generated from the following file:


Data Fields
_NV_TIMING_INPUT Struct Reference
OpenGL APIs | Display APIs | OpenGL APIs » Display Control Interface

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 width
NvU32 height
float rr
NV_TIMING_FLAG flag
NV_TIMING_OVERRIDE type

Detailed Description

Used in NvAPI_DISP_GetTiming().

The documentation for this struct was generated from the following file:


Data Fields
_NV_MONITOR_COLOR_DATA Struct Reference
OpenGL APIs | Display APIs | OpenGL APIs » Display Control Interface

#include <nvapi.h>

Data Fields

NvU32 version
NV_DP_COLOR_FORMAT colorFormat
NV_DP_BPC backendBitDepths
The documentation for this struct was generated from the following file:


Data Fields
NV_CUSTOM_DISPLAY Struct Reference
OpenGL APIs | Display APIs | OpenGL APIs » Display Control Interface

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 width
NvU32 height
NvU32 depth
NV_FORMAT colorFormat
NV_VIEWPORTF srcPartition
float | xRatio
float | yRatio
NV_TIMING timing
NvU32 | hwModeSetOnly: 1

Detailed Description

Used in NvAPI_DISP_EnumCustomDisplay() and NvAPI_DISP_TryCustomDisplay().

The documentation for this struct was generated from the following file:


Data Fields
_NV_EDID_DATA_V1 Struct Reference
OpenGL APIs | Display APIs | OpenGL APIs » Display Control Interface

#include <nvapi.h>

Data Fields

NvU32 version
NvU8 * pEDID
NvU32 sizeOfEDID
The documentation for this struct was generated from the following file:


Data Fields
NV_SET_PREFERRED_STEREO_DISPLAY_V1 Struct Reference
OpenGL APIs | Display APIs | OpenGL APIs » Display Control Interface

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 displayId
NvU32 reserved
The documentation for this struct was generated from the following file:


Data Fields
NV_GET_PREFERRED_STEREO_DISPLAY_V1 Struct Reference
OpenGL APIs | Display APIs | OpenGL APIs » Display Control Interface

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 displayId
NvU32 reserved
The documentation for this struct was generated from the following file:


Data Fields
_NV_GET_VRR_INFO_V1 Struct Reference
OpenGL APIs | Display APIs | OpenGL APIs » Display Control Interface

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 | bIsVRREnabled: 1
NvU32 | bIsVRRPossible: 1
NvU32 | bIsVRRRequested: 1
NvU32 | bIsVRRIndicatorEnabled: 1
NvU32 | bIsDisplayInVRRMode: 1
NvU32 | reserved: 27
NvU32 | reservedEx [4]
The documentation for this struct was generated from the following file:


Modules | Data Structures | Macros | Typedefs | Enumerations | Functions | Variables
OpenGL APIs

Modules

GPU General Control Interface
GPU ECC Interface
GPU Clock Control Interface
Display Control Interface
Mosaic APIs

Data Structures

struct | NV_GPU_ECC_STATUS_INFO
struct | NV_GPU_ECC_ERROR_INFO
struct | NV_GPU_ECC_CONFIGURATION_INFO
struct | NV_QSYNC_EVENT_DATA
struct | NV_EVENT_REGISTER_CALLBACK
struct | NV_SCANOUT_INTENSITY_DATA_V1
struct | NV_SCANOUT_INTENSITY_DATA_V2
struct | _NV_SCANOUT_INTENSITY_STATE_DATA
struct | NV_SCANOUT_WARPING_DATA
struct | _NV_SCANOUT_WARPING_STATE_DATA
struct | _NV_SCANOUT_INFORMATION
struct | _NV_GPU_VIRTUALIZATION_INFO
struct | _NV_LOGICAL_GPU_DATA_V1
struct | _NV_LICENSE_EXPIRY_DETAILS
struct | _NV_LICENSE_FEATURE_DETAILS_V1
struct | _NV_LICENSE_FEATURE_DETAILS_V2
struct | _NV_LICENSE_FEATURE_DETAILS_V3
struct | _NV_LICENSE_FEATURE_DETAILS_V4
struct | _NV_LICENSABLE_FEATURES_V1
struct | _NV_LICENSABLE_FEATURES_V2
struct | _NV_LICENSABLE_FEATURES_V3
struct | _NV_LICENSABLE_FEATURES_V4
struct | NVLINK_GET_CAPS_V1
struct | NVLINK_DEVICE_INFO_V1
struct | NVLINK_LINK_STATUS_INFO_V1
struct | NVLINK_LINK_STATUS_INFO_V2
struct | NVLINK_GET_STATUS_V1
struct | NVLINK_GET_STATUS_V2
struct | _NV_GPU_INFO_V1
struct | _NV_GPU_INFO_V2
struct | _NV_GPU_VR_READY_V1
struct | _NV_GPU_GSP_INFO_V1
struct | NV_GPU_PERF_PSTATES_INFO_V1
struct | NV_GPU_PERF_PSTATES_INFO_V2
struct | NV_GPU_DYNAMIC_PSTATES_INFO_EX
struct | NV_GPU_THERMAL_SETTINGS_V1
struct | NV_GPU_THERMAL_SETTINGS_V2
struct | NV_GPU_CLOCK_FREQUENCIES_V1
struct | NV_GPU_CLOCK_FREQUENCIES_V2
struct | _NV_GPU_QUERY_ILLUMINATION_SUPPORT_PARM_V1
struct | _NV_GPU_GET_ILLUMINATION_PARM_V1
struct | _NV_GPU_SET_ILLUMINATION_PARM_V1
struct | _NV_GPU_CLIENT_ILLUM_DEVICE_INFO_DATA_MCUV10
struct | _NV_GPU_CLIENT_ILLUM_DEVICE_INFO_DATA_GPIO_PWM_RGBW
struct | _NV_GPU_CLIENT_ILLUM_DEVICE_INFO_DATA_GPIO_PWM_SINGLE_COLOR
struct | _NV_GPU_CLIENT_ILLUM_DEVICE_INFO_V1
struct | _NV_GPU_CLIENT_ILLUM_DEVICE_INFO_PARAMS_V1
struct | NV_GPU_CLIENT_ILLUM_DEVICE_SYNC_V1
struct | NV_GPU_CLIENT_ILLUM_DEVICE_CONTROL_V1
struct | NV_GPU_CLIENT_ILLUM_DEVICE_CONTROL_PARAMS_V1
struct | _NV_GPU_CLIENT_ILLUM_ZONE_INFO_DATA_RGB
struct | _NV_GPU_CLIENT_ILLUM_ZONE_INFO_DATA_RGBW
struct | _NV_GPU_CLIENT_ILLUM_ZONE_INFO_DATA_SINGLE_COLOR
struct | _NV_GPU_CLIENT_ILLUM_ZONE_INFO_V1
struct | _NV_GPU_CLIENT_ILLUM_ZONE_INFO_PARAMS_V1
struct | _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_RGB_PARAMS
struct | _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_RGB
struct | _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR
struct | _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR_RGB
struct | _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_RGB
struct | _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_COLOR_FIXED_PARAMS
struct | _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_COLOR_FIXED
struct | _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR_COLOR_FIXED
struct | _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_COLOR_FIXED
struct | _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_RGBW_PARAMS
struct | _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_RGBW
struct | _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR_RGBW
struct | _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_RGBW
struct | _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_SINGLE_COLOR_PARAMS
struct | _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_SINGLE_COLOR
struct | _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR_SINGLE_COLOR
struct | _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_SINGLE_COLOR
struct | _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_V1
struct | _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_PARAMS_V1
struct | _NV_DISPLAY_PORT_INFO_V1
struct | NV_DISPLAY_PORT_CONFIG
struct | _NV_HDMI_SUPPORT_INFO_V1
struct | _NV_HDMI_SUPPORT_INFO_V2
struct | NV_INFOFRAME_PROPERTY
struct | NV_INFOFRAME_VIDEO
struct | NV_INFOFRAME_AUDIO
struct | NV_INFOFRAME_DATA
struct | _NV_COLOR_DATA_V1
struct | _NV_COLOR_DATA_V2
struct | _NV_COLOR_DATA_V3
struct | _NV_COLOR_DATA_V4
struct | _NV_COLOR_DATA_V5
struct | _NV_HDR_CAPABILITIES_V1
struct | _NV_HDR_CAPABILITIES_V2
struct | _NV_HDR_CAPABILITIES_V3
struct | _NV_HDR_COLOR_DATA_V1
struct | _NV_HDR_COLOR_DATA_V2
struct | _NV_HDR_METADATA_V1
struct | NV_TIMING_FLAG
struct | _NV_TIMING_INPUT
struct | _NV_MONITOR_CAPS_VCDB
struct | _NV_MONITOR_CAPS_VSDB
struct | _NV_MONITOR_CAPS_GENERIC
struct | _NV_MONITOR_CAPABILITIES_V1
struct | _NV_MONITOR_COLOR_DATA
struct | NV_CUSTOM_DISPLAY
struct | _NV_EDID_DATA_V1
struct | _NV_EDID_DATA_V2
struct | _NV_GET_ADAPTIVE_SYNC_DATA_V1
struct | _NV_SET_ADAPTIVE_SYNC_DATA_V1
struct | _NV_GET_VIRTUAL_REFRESH_RATE_DATA_V1
struct | _NV_SET_VIRTUAL_REFRESH_RATE_DATA_V1
struct | NV_SET_PREFERRED_STEREO_DISPLAY_V1
struct | NV_GET_PREFERRED_STEREO_DISPLAY_V1
struct | _NV_MANAGED_DEDICATED_DISPLAY_INFO
struct | _NV_MANAGED_DEDICATED_DISPLAY_METADATA
struct | _NV_GET_VRR_INFO_V1
struct | _NV_MOSAIC_GRID_TOPO_DISPLAY_V1
struct | _NV_MOSAIC_GRID_TOPO_DISPLAY_V2
struct | _NV_MOSAIC_GRID_TOPO_V1
struct | _NV_MOSAIC_GRID_TOPO_V2
struct | NV_MOSAIC_DISPLAY_TOPO_STATUS
struct | _NV_GSYNC_CAPABILITIES_V1
struct | _NV_GSYNC_CAPABILITIES_V2
struct | _NV_GSYNC_CAPABILITIES_V3
struct | _NV_GSYNC_GPU
struct | _NV_GSYNC_DISPLAY
struct | _NV_GSYNC_DELAY
struct | _NV_GSYNC_CONTROL_PARAMS_V1
struct | _NV_GSYNC_CONTROL_PARAMS_V2
struct | _NV_GSYNC_STATUS
struct | _NV_GSYNC_STATUS_PARAMS_V1
struct | _NV_GSYNC_STATUS_PARAMS_V2

Macros

#define | NV_EVENT_REGISTER_CALLBACK_VERSION MAKE_NVAPI_VERSION(NV_EVENT_REGISTER_CALLBACK,1)
#define | NV_SCANOUT_INTENSITY_DATA_VER2 MAKE_NVAPI_VERSION(NV_SCANOUT_INTENSITY_DATA_V2, 2)
#define | NV_SCANOUT_INTENSITY_DATA_VER NV_SCANOUT_INTENSITY_DATA_VER2
#define | NV_SCANOUT_INFORMATION_VER MAKE_NVAPI_VERSION(NV_SCANOUT_INFORMATION,1)
#define | NV_LOGICAL_GPU_DATA_VER1 MAKE_NVAPI_VERSION(NV_LOGICAL_GPU_DATA_V1,1)
#define | NV_LOGICAL_GPU_DATA_VER NV_LOGICAL_GPU_DATA_VER1
#define | NVAPI_NVLINK_COUNTER_MAX_TYPES 32
#define | NVAPI_NVLINK_MAX_LINKS 32
#define | NV_GPU_INFO_VER1 MAKE_NVAPI_VERSION(NV_GPU_INFO_V1, 1)
#define | NV_GPU_INFO_VER2 MAKE_NVAPI_VERSION(NV_GPU_INFO_V2, 2)
#define | NV_GPU_INFO_VER NV_GPU_INFO_VER2
#define | NV_GPU_VR_READY_VER1 MAKE_NVAPI_VERSION(NV_GPU_VR_READY_V1, 1)
#define | NV_GPU_VR_READY_VER NV_GPU_VR_READY_VER1
#define | NV_GPU_GSP_INFO_VER NV_GPU_GSP_INFO_VER1
#define | NV_GPU_MAX_CLOCK_FREQUENCIES 3
#define | NV_GPU_CLIENT_ILLUM_CTRL_MODE_PIECEWISE_LINEAR_COLOR_ENDPOINTS 2
#define | NV_GPU_CLIENT_ILLUM_DEVICE_NUM_DEVICES_MAX 32
#define | NV_GPU_CLIENT_ILLUM_DEVICE_INFO_PARAMS_VER_1 MAKE_NVAPI_VERSION(NV_GPU_CLIENT_ILLUM_DEVICE_INFO_PARAMS_V1, 1)
#define | NV_GPU_CLIENT_ILLUM_DEVICE_INFO_PARAMS_VER NV_GPU_CLIENT_ILLUM_DEVICE_INFO_PARAMS_VER_1
#define | NV_GPU_CLIENT_ILLUM_DEVICE_CONTROL_PARAMS_VER_1 MAKE_NVAPI_VERSION(NV_GPU_CLIENT_ILLUM_DEVICE_CONTROL_PARAMS_V1, 1)
#define | NV_GPU_CLIENT_ILLUM_DEVICE_CONTROL_PARAMS_VER NV_GPU_CLIENT_ILLUM_DEVICE_CONTROL_PARAMS_VER_1
#define | NV_GPU_CLIENT_ILLUM_ZONE_NUM_ZONES_MAX 32
#define | NV_GPU_CLIENT_ILLUM_ZONE_INFO_PARAMS_VER_1 MAKE_NVAPI_VERSION(NV_GPU_CLIENT_ILLUM_ZONE_INFO_PARAMS_V1, 1)
#define | NV_GPU_CLIENT_ILLUM_ZONE_INFO_PARAMS_VER NV_GPU_CLIENT_ILLUM_ZONE_INFO_PARAMS_VER_1
#define | NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_PARAMS_VER_1 MAKE_NVAPI_VERSION(NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_PARAMS_V1, 1)
#define | NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_PARAMS_VER NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_PARAMS_VER_1
#define | NV_DISPLAY_PORT_INFO_VER1 MAKE_NVAPI_VERSION(NV_DISPLAY_PORT_INFO,1)
#define | NV_DISPLAY_PORT_INFO_VER2 MAKE_NVAPI_VERSION(NV_DISPLAY_PORT_INFO,2)
#define | NV_DISPLAY_PORT_INFO_VER NV_DISPLAY_PORT_INFO_VER2
#define | NV_HDMI_SUPPORT_INFO_VER1 MAKE_NVAPI_VERSION(NV_HDMI_SUPPORT_INFO_V1, 1)
#define | NV_HDMI_SUPPORT_INFO_VER2 MAKE_NVAPI_VERSION(NV_HDMI_SUPPORT_INFO_V2, 2)
#define | NV_HDMI_SUPPORT_INFO_VER NV_HDMI_SUPPORT_INFO_VER2
#define | NV_INFOFRAME_DATA_VER MAKE_NVAPI_VERSION(NV_INFOFRAME_DATA,1)
#define | NV_HDR_CAPABILITIES_VER1 MAKE_NVAPI_VERSION(NV_HDR_CAPABILITIES_V1, 1)
#define | NV_HDR_CAPABILITIES_VER2 MAKE_NVAPI_VERSION(NV_HDR_CAPABILITIES_V2, 2)
#define | NV_HDR_CAPABILITIES_VER3 MAKE_NVAPI_VERSION(NV_HDR_CAPABILITIES_V3, 3)
#define | NV_HDR_CAPABILITIES_VER NV_HDR_CAPABILITIES_VER3
#define | NV_HDR_COLOR_DATA_VER1 MAKE_NVAPI_VERSION(NV_HDR_COLOR_DATA_V1, 1)
#define | NV_HDR_COLOR_DATA_VER2 MAKE_NVAPI_VERSION(NV_HDR_COLOR_DATA_V2, 2)
#define | NV_HDR_COLOR_DATA_VER NV_HDR_COLOR_DATA_VER2
#define | NV_TIMING_INPUT_VER MAKE_NVAPI_VERSION(NV_TIMING_INPUT,1)
#define | NV_MONITOR_COLOR_CAPS_VER NV_MONITOR_COLOR_CAPS_VER1
#define | NV_GET_ADAPTIVE_SYNC_DATA_VER1 MAKE_NVAPI_VERSION(NV_GET_ADAPTIVE_SYNC_DATA_V1,1)
#define | NV_GET_ADAPTIVE_SYNC_DATA_VER NV_GET_ADAPTIVE_SYNC_DATA_VER1
#define | NV_SET_ADAPTIVE_SYNC_DATA_VER1 MAKE_NVAPI_VERSION(NV_SET_ADAPTIVE_SYNC_DATA_V1,1)
#define | NV_SET_ADAPTIVE_SYNC_DATA_VER NV_SET_ADAPTIVE_SYNC_DATA_VER1
#define | NV_GET_VIRTUAL_REFRESH_RATE_DATA_VER1 MAKE_NVAPI_VERSION(_NV_GET_VIRTUAL_REFRESH_RATE_DATA_V1,1)
#define | NV_GET_VIRTUAL_REFRESH_RATE_DATA_VER NV_GET_VIRTUAL_REFRESH_RATE_DATA_VER1
#define | NV_SET_VIRTUAL_REFRESH_RATE_DATA_VER1 MAKE_NVAPI_VERSION(_NV_SET_VIRTUAL_REFRESH_RATE_DATA_V1,1)
#define | NV_SET_VIRTUAL_REFRESH_RATE_DATA_VER NV_SET_VIRTUAL_REFRESH_RATE_DATA_VER1
#define | NV_MANAGED_DEDICATED_DISPLAY_INFO_VER1 MAKE_NVAPI_VERSION(NV_MANAGED_DEDICATED_DISPLAY_INFO_V1,1)
#define | NV_MANAGED_DEDICATED_DISPLAY_INFO_VER NV_MANAGED_DEDICATED_DISPLAY_INFO_VER1
#define | NV_MANAGED_DEDICATED_DISPLAY_METADATA_VER1 MAKE_NVAPI_VERSION(NV_MANAGED_DEDICATED_DISPLAY_METADATA_V1,1)
#define | NV_MANAGED_DEDICATED_DISPLAY_METADATA_VER NV_MANAGED_DEDICATED_DISPLAY_METADATA_VER1
#define | NV_GET_VRR_INFO_VER1 MAKE_NVAPI_VERSION(NV_GET_VRR_INFO_V1,1)
#define | NV_GET_VRR_INFO_VER NV_GET_VRR_INFO_VER1
#define | NV_MOSAIC_DISPLAYCAPS_PROBLEM_DISPLAY_ON_INVALID_GPU NV_BIT(0)
#define | NV_MOSAIC_DISPLAYCAPS_PROBLEM_DISPLAY_ON_WRONG_CONNECTOR NV_BIT(1)
#define | NV_MOSAIC_DISPLAYCAPS_PROBLEM_NO_COMMON_TIMINGS NV_BIT(2)
#define | NV_MOSAIC_DISPLAYCAPS_PROBLEM_NO_EDID_AVAILABLE NV_BIT(3)
#define | NV_MOSAIC_DISPLAYCAPS_PROBLEM_MISMATCHED_OUTPUT_TYPE NV_BIT(4)
#define | NV_MOSAIC_DISPLAYCAPS_PROBLEM_NO_DISPLAY_CONNECTED NV_BIT(5)
#define | NV_MOSAIC_DISPLAYCAPS_PROBLEM_NO_GPU_TOPOLOGY NV_BIT(6)
#define | NV_MOSAIC_DISPLAYCAPS_PROBLEM_NOT_SUPPORTED NV_BIT(7)
#define | NV_MOSAIC_DISPLAYCAPS_PROBLEM_NO_SLI_BRIDGE NV_BIT(8)
#define | NV_MOSAIC_DISPLAYCAPS_PROBLEM_ECC_ENABLED NV_BIT(9)
#define | NV_MOSAIC_DISPLAYCAPS_PROBLEM_GPU_TOPOLOGY_NOT_SUPPORTED NV_BIT(10)
#define | NV_MOSAIC_SETDISPLAYTOPO_FLAG_CURRENT_GPU_TOPOLOGY NV_BIT(0)
#define | NV_MOSAIC_SETDISPLAYTOPO_FLAG_NO_DRIVER_RELOAD NV_BIT(1)
#define | NV_MOSAIC_SETDISPLAYTOPO_FLAG_MAXIMIZE_PERFORMANCE NV_BIT(2)
#define | NV_MOSAIC_SETDISPLAYTOPO_FLAG_ALLOW_INVALID NV_BIT(3)
#define | NVAPI_MAX_GSYNC_DEVICES 4
#define | NVAPI_GSYNC_BOARD_ID_P358 856
#define | NVAPI_GSYNC_BOARD_ID_P2060 8288
#define | NVAPI_GSYNC_BOARD_ID_P2061 8289
#define | NV_GSYNC_CAPABILITIES_VER2 MAKE_NVAPI_VERSION(NV_GSYNC_CAPABILITIES_V2,2)
#define | NV_GSYNC_CAPABILITIES_VER3 MAKE_NVAPI_VERSION(NV_GSYNC_CAPABILITIES_V3,3)
#define | NV_GSYNC_CAPABILITIES_VER NV_GSYNC_CAPABILITIES_VER3
#define | NV_GSYNC_DISPLAY_VER MAKE_NVAPI_VERSION(NV_GSYNC_DISPLAY,1)
#define | NV_GSYNC_GPU_VER MAKE_NVAPI_VERSION(NV_GSYNC_GPU,1)
#define | NV_GSYNC_DELAY_VER MAKE_NVAPI_VERSION(NV_GSYNC_DELAY,1)
#define | NV_GSYNC_CONTROL_PARAMS_VER1 MAKE_NVAPI_VERSION(NV_GSYNC_CONTROL_PARAMS_V1,1)
#define | NV_GSYNC_CONTROL_PARAMS_VER2 MAKE_NVAPI_VERSION(NV_GSYNC_CONTROL_PARAMS_V2,2)
#define | NV_GSYNC_CONTROL_PARAMS_VER NV_GSYNC_CONTROL_PARAMS_VER2
#define | NV_GSYNC_STATUS_VER MAKE_NVAPI_VERSION(NV_GSYNC_STATUS,1)
#define | NV_GSYNC_STATUS_PARAMS_VER2 MAKE_NVAPI_VERSION(NV_GSYNC_STATUS_PARAMS_V2,2)
#define | NV_GSYNC_STATUS_PARAMS_VER NV_GSYNC_STATUS_PARAMS_VER2

Typedefs

typedef void(* | NVAPI_OGLEXPERT_CALLBACK) (unsigned int categoryId, unsigned int messageId, unsigned int detailLevel, int objectId, const char *messageStr)
typedef enum _NV_ECC_CONFIGURATION | NV_ECC_CONFIGURATION
typedef void(__cdecl * | NVAPI_CALLBACK_QSYNCEVENT) (NV_QSYNC_EVENT_DATA qyncEventData, void *callbackParam)
typedef struct NV_EVENT_REGISTER_CALLBACK * | PNV_EVENT_REGISTER_CALLBACK
typedef NV_SCANOUT_INTENSITY_DATA_V2 | NV_SCANOUT_INTENSITY_DATA
typedef struct _NV_GPU_INFO_V1 | NV_GPU_INFO_V1
typedef struct _NV_GPU_INFO_V2 | NV_GPU_INFO_V2
typedef NV_GPU_INFO_V2 | NV_GPU_INFO
typedef struct _NV_GPU_VR_READY_V1 | NV_GPU_VR_READY_V1
typedef NV_GPU_VR_READY_V1 | NV_GPU_VR_READY
typedef enum _NV_ADAPTER_TYPE | NV_ADAPTER_TYPE
typedef NV_GPU_GSP_INFO_V1 | NV_GPU_GSP_INFO
typedef enum _NVAPI_GPU_PERF_DECREASE | NVAPI_GPU_PERF_DECREASE
typedef struct _NV_GPU_CLIENT_ILLUM_DEVICE_INFO_DATA_MCUV10 | NV_GPU_CLIENT_ILLUM_DEVICE_INFO_DATA_MCUV10
typedef struct _NV_GPU_CLIENT_ILLUM_DEVICE_INFO_DATA_GPIO_PWM_RGBW | NV_GPU_CLIENT_ILLUM_DEVICE_INFO_DATA_GPIO_PWM_RGBW
typedef struct _NV_GPU_CLIENT_ILLUM_DEVICE_INFO_DATA_GPIO_PWM_SINGLE_COLOR | NV_GPU_CLIENT_ILLUM_DEVICE_INFO_DATA_GPIO_PWM_SINGLE_COLOR
typedef struct _NV_GPU_CLIENT_ILLUM_DEVICE_INFO_V1 | NV_GPU_CLIENT_ILLUM_DEVICE_INFO_V1
typedef struct _NV_GPU_CLIENT_ILLUM_DEVICE_INFO_PARAMS_V1 | NV_GPU_CLIENT_ILLUM_DEVICE_INFO_PARAMS_V1
typedef NV_GPU_CLIENT_ILLUM_DEVICE_INFO_PARAMS_V1 | NV_GPU_CLIENT_ILLUM_DEVICE_INFO_PARAMS
typedef NV_GPU_CLIENT_ILLUM_DEVICE_CONTROL_V1 | NV_GPU_CLIENT_ILLUM_DEVICE_CONTROL
typedef NV_GPU_CLIENT_ILLUM_DEVICE_CONTROL_PARAMS_V1 | NV_GPU_CLIENT_ILLUM_DEVICE_CONTROL_PARAMS
typedef struct _NV_GPU_CLIENT_ILLUM_ZONE_INFO_DATA_RGB | NV_GPU_CLIENT_ILLUM_ZONE_INFO_DATA_RGB
typedef struct _NV_GPU_CLIENT_ILLUM_ZONE_INFO_DATA_RGBW | NV_GPU_CLIENT_ILLUM_ZONE_INFO_DATA_RGBW
typedef struct _NV_GPU_CLIENT_ILLUM_ZONE_INFO_DATA_SINGLE_COLOR | NV_GPU_CLIENT_ILLUM_ZONE_INFO_DATA_SINGLE_COLOR
typedef struct _NV_GPU_CLIENT_ILLUM_ZONE_INFO_V1 | NV_GPU_CLIENT_ILLUM_ZONE_INFO_V1
typedef struct _NV_GPU_CLIENT_ILLUM_ZONE_INFO_PARAMS_V1 | NV_GPU_CLIENT_ILLUM_ZONE_INFO_PARAMS_V1
typedef NV_GPU_CLIENT_ILLUM_ZONE_INFO_PARAMS_V1 | NV_GPU_CLIENT_ILLUM_ZONE_INFO_PARAMS
typedef struct _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_RGB_PARAMS | NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_RGB_PARAMS
typedef struct _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_RGB | NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_RGB
typedef struct _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR | NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR
typedef struct _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR_RGB | NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR_RGB
typedef struct _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_RGB | NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_RGB
typedef struct _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_COLOR_FIXED_PARAMS | NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_COLOR_FIXED_PARAMS
typedef struct _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_COLOR_FIXED | NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_COLOR_FIXED
typedef struct _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR_COLOR_FIXED | NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR_COLOR_FIXED
typedef struct _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_COLOR_FIXED | NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_COLOR_FIXED
typedef struct _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_RGBW_PARAMS | NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_RGBW_PARAMS
typedef struct _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_RGBW | NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_RGBW
typedef struct _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR_RGBW | NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR_RGBW
typedef struct _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_RGBW | NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_RGBW
typedef struct _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_SINGLE_COLOR_PARAMS | NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_SINGLE_COLOR_PARAMS
typedef struct _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_SINGLE_COLOR | NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_SINGLE_COLOR
typedef struct _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR_SINGLE_COLOR | NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR_SINGLE_COLOR
typedef struct _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_SINGLE_COLOR | NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_SINGLE_COLOR
typedef struct _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_V1 | NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_V1
typedef struct _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_PARAMS_V1 | NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_PARAMS_V1
typedef NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_PARAMS_V1 | NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_PARAMS
typedef NV_DISPLAY_PORT_INFO_V1 | NV_DISPLAY_PORT_INFO
typedef struct _NV_HDMI_SUPPORT_INFO_V2 | NV_HDMI_SUPPORT_INFO_V2
typedef NV_HDMI_SUPPORT_INFO_V2 | NV_HDMI_SUPPORT_INFO
typedef struct _NV_HDR_CAPABILITIES_V1 | NV_HDR_CAPABILITIES_V1
typedef struct _NV_HDR_CAPABILITIES_V2 | NV_HDR_CAPABILITIES_V2
typedef struct _NV_HDR_CAPABILITIES_V3 | NV_HDR_CAPABILITIES_V3
typedef NV_HDR_CAPABILITIES_V3 | NV_HDR_CAPABILITIES
typedef struct _NV_HDR_COLOR_DATA_V1 | NV_HDR_COLOR_DATA_V1
typedef struct _NV_HDR_COLOR_DATA_V2 | NV_HDR_COLOR_DATA_V2
typedef NV_HDR_COLOR_DATA_V2 | NV_HDR_COLOR_DATA
typedef NV_MONITOR_COLOR_CAPS_V1 | NV_MONITOR_COLOR_CAPS
typedef struct _NV_GET_ADAPTIVE_SYNC_DATA_V1 | NV_GET_ADAPTIVE_SYNC_DATA_V1
typedef NV_GET_ADAPTIVE_SYNC_DATA_V1 | NV_GET_ADAPTIVE_SYNC_DATA
typedef struct _NV_SET_ADAPTIVE_SYNC_DATA_V1 | NV_SET_ADAPTIVE_SYNC_DATA_V1
typedef NV_SET_ADAPTIVE_SYNC_DATA_V1 | NV_SET_ADAPTIVE_SYNC_DATA
typedef struct _NV_GET_VIRTUAL_REFRESH_RATE_DATA_V1 | NV_GET_VIRTUAL_REFRESH_RATE_DATA_V1
typedef NV_GET_VIRTUAL_REFRESH_RATE_DATA_V1 | NV_GET_VIRTUAL_REFRESH_RATE_DATA
typedef struct _NV_SET_VIRTUAL_REFRESH_RATE_DATA_V1 | NV_SET_VIRTUAL_REFRESH_RATE_DATA_V1
typedef NV_SET_VIRTUAL_REFRESH_RATE_DATA_V1 | NV_SET_VIRTUAL_REFRESH_RATE_DATA
typedef struct _NV_MANAGED_DEDICATED_DISPLAY_INFO | NV_MANAGED_DEDICATED_DISPLAY_INFO_V1
typedef NV_MANAGED_DEDICATED_DISPLAY_INFO_V1 | NV_MANAGED_DEDICATED_DISPLAY_INFO
typedef struct _NV_MANAGED_DEDICATED_DISPLAY_METADATA | NV_MANAGED_DEDICATED_DISPLAY_METADATA_V1
typedef NV_MANAGED_DEDICATED_DISPLAY_METADATA_V1 | NV_MANAGED_DEDICATED_DISPLAY_METADATA
typedef NV_GET_VRR_INFO_V1 | NV_GET_VRR_INFO
typedef struct _NV_GSYNC_CAPABILITIES_V1 | NV_GSYNC_CAPABILITIES_V1
typedef struct _NV_GSYNC_CAPABILITIES_V2 | NV_GSYNC_CAPABILITIES_V2
typedef struct _NV_GSYNC_CAPABILITIES_V3 | NV_GSYNC_CAPABILITIES_V3
typedef NV_GSYNC_CAPABILITIES_V3 | NV_GSYNC_CAPABILITIES
typedef enum _NVAPI_GSYNC_GPU_TOPOLOGY_CONNECTOR | NVAPI_GSYNC_GPU_TOPOLOGY_CONNECTOR
typedef enum _NVAPI_GSYNC_DISPLAY_SYNC_STATE | NVAPI_GSYNC_DISPLAY_SYNC_STATE
typedef struct _NV_GSYNC_GPU | NV_GSYNC_GPU
typedef struct _NV_GSYNC_DISPLAY | NV_GSYNC_DISPLAY
typedef enum _NVAPI_GSYNC_VIDEO_MODE | NVAPI_GSYNC_VIDEO_MODE
typedef enum _NVAPI_GSYNC_SYNC_SOURCE | NVAPI_GSYNC_SYNC_SOURCE
typedef struct _NV_GSYNC_DELAY | NV_GSYNC_DELAY
typedef struct _NV_GSYNC_CONTROL_PARAMS_V1 | NV_GSYNC_CONTROL_PARAMS_V1
typedef enum _NVAPI_GSYNC_MULTIPLY_DIVIDE_MODE | NVAPI_GSYNC_MULTIPLY_DIVIDE_MODE
typedef struct _NV_GSYNC_CONTROL_PARAMS_V2 | NV_GSYNC_CONTROL_PARAMS_V2
typedef NV_GSYNC_CONTROL_PARAMS_V2 | NV_GSYNC_CONTROL_PARAMS
typedef enum _NVAPI_GSYNC_DELAY_TYPE | NVAPI_GSYNC_DELAY_TYPE
typedef struct _NV_GSYNC_STATUS | NV_GSYNC_STATUS
typedef enum _NVAPI_GSYNC_RJ45_IO | NVAPI_GSYNC_RJ45_IO
typedef struct _NV_GSYNC_STATUS_PARAMS_V2 | NV_GSYNC_STATUS_PARAMS_V2
typedef NV_GSYNC_STATUS_PARAMS_V2 | NV_GSYNC_STATUS_PARAMS

Enumerations

enum | _NV_ECC_CONFIGURATION { NV_ECC_CONFIGURATION_NOT_SUPPORTED = 0 , NV_ECC_CONFIGURATION_DEFERRED , NV_ECC_CONFIGURATION_IMMEDIATE }
enum NV_QSYNC_EVENT {
NV_QSYNC_EVENT_NONE = 0 , NV_QSYNC_EVENT_SYNC_LOSS = 1 , NV_QSYNC_EVENT_SYNC_GAIN = 2 , NV_QSYNC_EVENT_HOUSESYNC_GAIN = 3 ,
NV_QSYNC_EVENT_HOUSESYNC_LOSS = 4 , NV_QSYNC_EVENT_RJ45_GAIN = 5 , NV_QSYNC_EVENT_RJ45_LOSS = 6
}
enum | NV_EVENT_TYPE { NV_EVENT_TYPE_NONE = 0 , NV_EVENT_TYPE_QSYNC = 6 }
enum | NV_GPU_SCANOUT_COMPOSITION_PARAMETER { NV_GPU_SCANOUT_COMPOSITION_PARAMETER_WARPING_RESAMPLING_METHOD = 0 }
enum NV_GPU_SCANOUT_COMPOSITION_PARAMETER_VALUE {
NV_GPU_SCANOUT_COMPOSITION_PARAMETER_SET_TO_DEFAULT = 0 , NV_GPU_SCANOUT_COMPOSITION_PARAMETER_VALUE_WARPING_RESAMPLING_METHOD_BILINEAR = 0x100 , NV_GPU_SCANOUT_COMPOSITION_PARAMETER_VALUE_WARPING_RESAMPLING_METHOD_BICUBIC_TRIANGULAR = 0x101 , NV_GPU_SCANOUT_COMPOSITION_PARAMETER_VALUE_WARPING_RESAMPLING_METHOD_BICUBIC_BELL_SHAPED = 0x102 ,
NV_GPU_SCANOUT_COMPOSITION_PARAMETER_VALUE_WARPING_RESAMPLING_METHOD_BICUBIC_BSPLINE = 0x103 , NV_GPU_SCANOUT_COMPOSITION_PARAMETER_VALUE_WARPING_RESAMPLING_METHOD_BICUBIC_ADAPTIVE_TRIANGULAR = 0x104 , NV_GPU_SCANOUT_COMPOSITION_PARAMETER_VALUE_WARPING_RESAMPLING_METHOD_BICUBIC_ADAPTIVE_BELL_SHAPED = 0x105 , NV_GPU_SCANOUT_COMPOSITION_PARAMETER_VALUE_WARPING_RESAMPLING_METHOD_BICUBIC_ADAPTIVE_BSPLINE = 0x106
}
enum _NV_ADAPTER_TYPE {
NV_ADAPTER_TYPE_UNKNOWN = 0x0 , NV_ADAPTER_TYPE_WDDM = NV_BIT(0) , NV_ADAPTER_TYPE_MCDM = NV_BIT(1) , NV_ADAPTER_TYPE_TCC = NV_BIT(2) ,
NV_ADAPTER_TYPE_LAST = 0xFFFFFFFF
}
enum _NVAPI_GPU_PERF_DECREASE {
NV_GPU_PERF_DECREASE_NONE = 0 , NV_GPU_PERF_DECREASE_REASON_THERMAL_PROTECTION = 0x00000001 , NV_GPU_PERF_DECREASE_REASON_POWER_CONTROL = 0x00000002 , NV_GPU_PERF_DECREASE_REASON_AC_BATT = 0x00000004 ,
NV_GPU_PERF_DECREASE_REASON_API_TRIGGERED = 0x00000008 , NV_GPU_PERF_DECREASE_REASON_INSUFFICIENT_POWER = 0x00000010 , NV_GPU_PERF_DECREASE_REASON_UNKNOWN = 0x80000000
}
enum NV_GPU_CLIENT_ILLUM_CTRL_MODE {
NV_GPU_CLIENT_ILLUM_CTRL_MODE_MANUAL_RGB = 0 , NV_GPU_CLIENT_ILLUM_CTRL_MODE_PIECEWISE_LINEAR_RGB , NV_GPU_CLIENT_ILLUM_CTRL_MODE_MANUAL = 0 , NV_GPU_CLIENT_ILLUM_CTRL_MODE_PIECEWISE_LINEAR ,
NV_GPU_CLIENT_ILLUM_CTRL_MODE_INVALID = 0xFF
}
enum NV_GPU_CLIENT_ILLUM_ZONE_LOCATION {
NV_GPU_CLIENT_ILLUM_ZONE_LOCATION_GPU_TOP_0 = 0x00 , NV_GPU_CLIENT_ILLUM_ZONE_LOCATION_GPU_FRONT_0 = 0x08 , NV_GPU_CLIENT_ILLUM_ZONE_LOCATION_GPU_BACK_0 = 0x0C , NV_GPU_CLIENT_ILLUM_ZONE_LOCATION_SLI_TOP_0 = 0x20 ,
NV_GPU_CLIENT_ILLUM_ZONE_LOCATION_INVALID = 0xFFFFFFFF
}
enum | NV_GPU_CLIENT_ILLUM_DEVICE_TYPE { NV_GPU_CLIENT_ILLUM_DEVICE_TYPE_INVALID = 0 , NV_GPU_CLIENT_ILLUM_DEVICE_TYPE_MCUV10 , NV_GPU_CLIENT_ILLUM_DEVICE_TYPE_GPIO_PWM_RGBW_V10 , NV_GPU_CLIENT_ILLUM_DEVICE_TYPE_GPIO_PWM_SINGLE_COLOR_V10 }
enum NV_GPU_CLIENT_ILLUM_ZONE_TYPE {
NV_GPU_CLIENT_ILLUM_ZONE_TYPE_INVALID = 0 , NV_GPU_CLIENT_ILLUM_ZONE_TYPE_RGB , NV_GPU_CLIENT_ILLUM_ZONE_TYPE_COLOR_FIXED , NV_GPU_CLIENT_ILLUM_ZONE_TYPE_RGBW ,
NV_GPU_CLIENT_ILLUM_ZONE_TYPE_SINGLE_COLOR
}
enum | NV_GPU_CLIENT_ILLUM_PIECEWISE_LINEAR_CYCLE_TYPE { NV_GPU_CLIENT_ILLUM_PIECEWISE_LINEAR_CYCLE_HALF_HALT = 0 , NV_GPU_CLIENT_ILLUM_PIECEWISE_LINEAR_CYCLE_FULL_HALT , NV_GPU_CLIENT_ILLUM_PIECEWISE_LINEAR_CYCLE_FULL_REPEAT , NV_GPU_CLIENT_ILLUM_PIECEWISE_LINEAR_CYCLE_INVALID = 0xFF }
enum | NV_INFOFRAME_PROPERTY_MODE { NV_INFOFRAME_PROPERTY_MODE_AUTO = 0 , NV_INFOFRAME_PROPERTY_MODE_ENABLE , NV_INFOFRAME_PROPERTY_MODE_DISABLE , NV_INFOFRAME_PROPERTY_MODE_ALLOW_OVERRIDE }
enum | NV_INFOFRAME_PROPERTY_BLACKLIST { NV_INFOFRAME_PROPERTY_BLACKLIST_FALSE = 0 , NV_INFOFRAME_PROPERTY_BLACKLIST_TRUE }
enum NV_INFOFRAME_FIELD_VALUE_AVI_SCANINFO {
NV_INFOFRAME_FIELD_VALUE_AVI_SCANINFO_NODATA = 0 , NV_INFOFRAME_FIELD_VALUE_AVI_SCANINFO_OVERSCAN , NV_INFOFRAME_FIELD_VALUE_AVI_SCANINFO_UNDERSCAN , NV_INFOFRAME_FIELD_VALUE_AVI_SCANINFO_FUTURE ,
NV_INFOFRAME_FIELD_VALUE_AVI_SCANINFO_AUTO = 7
}
enum NV_INFOFRAME_FIELD_VALUE_AVI_BARDATA {
NV_INFOFRAME_FIELD_VALUE_AVI_BARDATA_NOT_PRESENT = 0 , NV_INFOFRAME_FIELD_VALUE_AVI_BARDATA_VERTICAL_PRESENT , NV_INFOFRAME_FIELD_VALUE_AVI_BARDATA_HORIZONTAL_PRESENT , NV_INFOFRAME_FIELD_VALUE_AVI_BARDATA_BOTH_PRESENT ,
NV_INFOFRAME_FIELD_VALUE_AVI_BARDATA_AUTO = 7
}
enum | NV_INFOFRAME_FIELD_VALUE_AVI_ACTIVEFORMATINFO { NV_INFOFRAME_FIELD_VALUE_AVI_AFI_ABSENT = 0 , NV_INFOFRAME_FIELD_VALUE_AVI_AFI_PRESENT , NV_INFOFRAME_FIELD_VALUE_AVI_AFI_AUTO = 3 }
enum NV_INFOFRAME_FIELD_VALUE_AVI_COLORFORMAT {
NV_INFOFRAME_FIELD_VALUE_AVI_COLORFORMAT_RGB = 0 , NV_INFOFRAME_FIELD_VALUE_AVI_COLORFORMAT_YCbCr422 , NV_INFOFRAME_FIELD_VALUE_AVI_COLORFORMAT_YCbCr444 , NV_INFOFRAME_FIELD_VALUE_AVI_COLORFORMAT_FUTURE ,
NV_INFOFRAME_FIELD_VALUE_AVI_COLORFORMAT_AUTO = 7
}
enum | NV_INFOFRAME_FIELD_VALUE_AVI_F17 { NV_INFOFRAME_FIELD_VALUE_AVI_F17_FALSE = 0 , NV_INFOFRAME_FIELD_VALUE_AVI_F17_TRUE , NV_INFOFRAME_FIELD_VALUE_AVI_F17_AUTO = 3 }
enum NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION {
NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_NO_AFD = 0 , NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_RESERVE01 , NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_RESERVE02 , NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_RESERVE03 ,
NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_LETTERBOX_GT16x9 , NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_RESERVE05 , NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_RESERVE06 , NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_RESERVE07 ,
NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_EQUAL_CODEDFRAME = 8 , NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_CENTER_4x3 , NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_CENTER_16x9 , NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_CENTER_14x9 ,
NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_RESERVE12 , NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_4x3_ON_14x9 , NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_16x9_ON_14x9 , NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_16x9_ON_4x3 ,
NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_AUTO = 31
}
enum NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOCODEDFRAME {
NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOCODEDFRAME_NO_DATA = 0 , NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOCODEDFRAME_4x3 , NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOCODEDFRAME_16x9 , NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOCODEDFRAME_FUTURE ,
NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOCODEDFRAME_AUTO = 7
}
enum NV_INFOFRAME_FIELD_VALUE_AVI_COLORIMETRY {
NV_INFOFRAME_FIELD_VALUE_AVI_COLORIMETRY_NO_DATA = 0 , NV_INFOFRAME_FIELD_VALUE_AVI_COLORIMETRY_SMPTE_170M , NV_INFOFRAME_FIELD_VALUE_AVI_COLORIMETRY_ITUR_BT709 , NV_INFOFRAME_FIELD_VALUE_AVI_COLORIMETRY_USE_EXTENDED_COLORIMETRY ,
NV_INFOFRAME_FIELD_VALUE_AVI_COLORIMETRY_AUTO = 7
}
enum NV_INFOFRAME_FIELD_VALUE_AVI_NONUNIFORMPICTURESCALING {
NV_INFOFRAME_FIELD_VALUE_AVI_NONUNIFORMPICTURESCALING_NO_DATA = 0 , NV_INFOFRAME_FIELD_VALUE_AVI_NONUNIFORMPICTURESCALING_HORIZONTAL , NV_INFOFRAME_FIELD_VALUE_AVI_NONUNIFORMPICTURESCALING_VERTICAL , NV_INFOFRAME_FIELD_VALUE_AVI_NONUNIFORMPICTURESCALING_BOTH ,
NV_INFOFRAME_FIELD_VALUE_AVI_NONUNIFORMPICTURESCALING_AUTO = 7
}
enum NV_INFOFRAME_FIELD_VALUE_AVI_RGBQUANTIZATION {
NV_INFOFRAME_FIELD_VALUE_AVI_RGBQUANTIZATION_DEFAULT = 0 , NV_INFOFRAME_FIELD_VALUE_AVI_RGBQUANTIZATION_LIMITED_RANGE , NV_INFOFRAME_FIELD_VALUE_AVI_RGBQUANTIZATION_FULL_RANGE , NV_INFOFRAME_FIELD_VALUE_AVI_RGBQUANTIZATION_RESERVED ,
NV_INFOFRAME_FIELD_VALUE_AVI_RGBQUANTIZATION_AUTO = 7
}
enum NV_INFOFRAME_FIELD_VALUE_AVI_EXTENDEDCOLORIMETRY {
NV_INFOFRAME_FIELD_VALUE_AVI_EXTENDEDCOLORIMETRY_XVYCC601 = 0 , NV_INFOFRAME_FIELD_VALUE_AVI_EXTENDEDCOLORIMETRY_XVYCC709 , NV_INFOFRAME_FIELD_VALUE_AVI_EXTENDEDCOLORIMETRY_SYCC601 , NV_INFOFRAME_FIELD_VALUE_AVI_EXTENDEDCOLORIMETRY_ADOBEYCC601 ,
NV_INFOFRAME_FIELD_VALUE_AVI_EXTENDEDCOLORIMETRY_ADOBERGB , NV_INFOFRAME_FIELD_VALUE_AVI_EXTENDEDCOLORIMETRY_RESERVED05 , NV_INFOFRAME_FIELD_VALUE_AVI_EXTENDEDCOLORIMETRY_RESERVED06 , NV_INFOFRAME_FIELD_VALUE_AVI_EXTENDEDCOLORIMETRY_RESERVED07 ,
NV_INFOFRAME_FIELD_VALUE_AVI_EXTENDEDCOLORIMETRY_AUTO = 15
}
enum | NV_INFOFRAME_FIELD_VALUE_AVI_ITC { NV_INFOFRAME_FIELD_VALUE_AVI_ITC_VIDEO_CONTENT = 0 , NV_INFOFRAME_FIELD_VALUE_AVI_ITC_ITCONTENT , NV_INFOFRAME_FIELD_VALUE_AVI_ITC_AUTO = 3 }
enum NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION {
NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_NONE = 0 , NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_X02 , NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_X03 , NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_X04 ,
NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_X05 , NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_X06 , NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_X07 , NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_X08 ,
NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_X09 , NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_X10 , NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_RESERVED10 , NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_RESERVED11 ,
NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_RESERVED12 , NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_RESERVED13 , NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_RESERVED14 , NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_RESERVED15 ,
NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_AUTO = 31
}
enum NV_INFOFRAME_FIELD_VALUE_AVI_CONTENTTYPE {
NV_INFOFRAME_FIELD_VALUE_AVI_CONTENTTYPE_GRAPHICS = 0 , NV_INFOFRAME_FIELD_VALUE_AVI_CONTENTTYPE_PHOTO , NV_INFOFRAME_FIELD_VALUE_AVI_CONTENTTYPE_CINEMA , NV_INFOFRAME_FIELD_VALUE_AVI_CONTENTTYPE_GAME ,
NV_INFOFRAME_FIELD_VALUE_AVI_CONTENTTYPE_AUTO = 7
}
enum NV_INFOFRAME_FIELD_VALUE_AVI_YCCQUANTIZATION {
NV_INFOFRAME_FIELD_VALUE_AVI_YCCQUANTIZATION_LIMITED_RANGE = 0 , NV_INFOFRAME_FIELD_VALUE_AVI_YCCQUANTIZATION_FULL_RANGE , NV_INFOFRAME_FIELD_VALUE_AVI_YCCQUANTIZATION_RESERVED02 , NV_INFOFRAME_FIELD_VALUE_AVI_YCCQUANTIZATION_RESERVED03 ,
NV_INFOFRAME_FIELD_VALUE_AVI_YCCQUANTIZATION_AUTO = 7
}
enum NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELCOUNT {
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELCOUNT_IN_HEADER = 0 , NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELCOUNT_2 , NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELCOUNT_3 , NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELCOUNT_4 ,
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELCOUNT_5 , NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELCOUNT_6 , NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELCOUNT_7 , NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELCOUNT_8 ,
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELCOUNT_AUTO = 15
}
enum NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE {
NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_IN_HEADER = 0 , NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_PCM , NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_AC3 , NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_MPEG1 ,
NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_MP3 , NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_MPEG2 , NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_AACLC , NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_DTS ,
NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_ATRAC , NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_DSD , NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_EAC3 , NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_DTSHD ,
NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_MLP , NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_DST , NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_WMAPRO , NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_USE_CODING_EXTENSION_TYPE ,
NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_AUTO = 31
}
enum NV_INFOFRAME_FIELD_VALUE_AUDIO_SAMPLESIZE {
NV_INFOFRAME_FIELD_VALUE_AUDIO_SAMPLESIZE_IN_HEADER = 0 , NV_INFOFRAME_FIELD_VALUE_AUDIO_SAMPLESIZE_16BITS , NV_INFOFRAME_FIELD_VALUE_AUDIO_SAMPLESIZE_20BITS , NV_INFOFRAME_FIELD_VALUE_AUDIO_SAMPLESIZE_24BITS ,
NV_INFOFRAME_FIELD_VALUE_AUDIO_SAMPLESIZE_AUTO = 7
}
enum NV_INFOFRAME_FIELD_VALUE_AUDIO_SAMPLEFREQUENCY {
NV_INFOFRAME_FIELD_VALUE_AUDIO_SAMPLEFREQUENCY_IN_HEADER = 0 , NV_INFOFRAME_FIELD_VALUE_AUDIO_SAMPLEFREQUENCY_32000HZ , NV_INFOFRAME_FIELD_VALUE_AUDIO_SAMPLEFREQUENCY_44100HZ , NV_INFOFRAME_FIELD_VALUE_AUDIO_SAMPLEFREQUENCY_48000HZ ,
NV_INFOFRAME_FIELD_VALUE_AUDIO_SAMPLEFREQUENCY_88200KHZ , NV_INFOFRAME_FIELD_VALUE_AUDIO_SAMPLEFREQUENCY_96000KHZ , NV_INFOFRAME_FIELD_VALUE_AUDIO_SAMPLEFREQUENCY_176400KHZ , NV_INFOFRAME_FIELD_VALUE_AUDIO_SAMPLEFREQUENCY_192000KHZ ,
NV_INFOFRAME_FIELD_VALUE_AUDIO_SAMPLEFREQUENCY_AUTO = 15
}
enum NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE {
NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_USE_CODING_TYPE = 0 , NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_HEAAC , NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_HEAACV2 , NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_MPEGSURROUND ,
NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE04 , NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE05 , NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE06 , NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE07 ,
NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE08 , NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE09 , NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE10 , NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE11 ,
NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE12 , NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE13 , NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE14 , NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE15 ,
NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE16 , NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE17 , NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE18 , NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE19 ,
NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE20 , NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE21 , NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE22 , NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE23 ,
NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE24 , NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE25 , NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE26 , NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE27 ,
NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE28 , NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE29 , NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE30 , NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE31 ,
NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_AUTO = 63
}
enum NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION {
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_X_X_X_X_X_FR_FL =0 , NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_X_X_X_X_LFE_FR_FL , NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_X_X_X_FC_X_FR_FL , NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_X_X_X_FC_LFE_FR_FL ,
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_X_X_RC_X_X_FR_FL , NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_X_X_RC_X_LFE_FR_FL , NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_X_X_RC_FC_X_FR_FL , NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_X_X_RC_FC_LFE_FR_FL ,
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_X_RR_RL_X_X_FR_FL , NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_X_RR_RL_X_LFE_FR_FL , NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_X_RR_RL_FC_X_FR_FL , NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_X_RR_RL_FC_LFE_FR_FL ,
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_RC_RR_RL_X_X_FR_FL , NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_RC_RR_RL_X_LFE_FR_FL , NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_RC_RR_RL_FC_X_FR_FL , NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_RC_RR_RL_FC_LFE_FR_FL ,
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_RRC_RLC_RR_RL_X_X_FR_FL , NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_RRC_RLC_RR_RL_X_LFE_FR_FL , NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_RRC_RLC_RR_RL_FC_X_FR_FL , NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_RRC_RLC_RR_RL_FC_LFE_FR_FL ,
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRC_FLC_X_X_X_X_FR_FL , NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRC_FLC_X_X_X_LFE_FR_FL , NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRC_FLC_X_X_FC_X_FR_FL , NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRC_FLC_X_X_FC_LFE_FR_FL ,
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRC_FLC_X_RC_X_X_FR_FL , NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRC_FLC_X_RC_X_LFE_FR_FL , NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRC_FLC_X_RC_FC_X_FR_FL , NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRC_FLC_X_RC_FC_LFE_FR_FL ,
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRC_FLC_RR_RL_X_X_FR_FL , NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRC_FLC_RR_RL_X_LFE_FR_FL , NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRC_FLC_RR_RL_FC_X_FR_FL , NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRC_FLC_RR_RL_FC_LFE_FR_FL ,
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_FCH_RR_RL_FC_X_FR_FL , NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_FCH_RR_RL_FC_LFE_FR_FL , NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_TC_X_RR_RL_FC_X_FR_FL , NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_TC_X_RR_RL_FC_LFE_FR_FL ,
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRH_FLH_RR_RL_X_X_FR_FL , NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRH_FLH_RR_RL_X_LFE_FR_FL , NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRW_FLW_RR_RL_X_X_FR_FL , NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRW_FLW_RR_RL_X_LFE_FR_FL ,
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_TC_RC_RR_RL_FC_X_FR_FL , NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_TC_RC_RR_RL_FC_LFE_FR_FL , NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FCH_RC_RR_RL_FC_X_FR_FL , NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FCH_RC_RR_RL_FC_LFE_FR_FL ,
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_TC_FCH_RR_RL_FC_X_FR_FL , NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_TC_FCH_RR_RL_FC_LFE_FR_FL , NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRH_FLH_RR_RL_FC_X_FR_FL , NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRH_FLH_RR_RL_FC_LFE_FR_FL ,
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRW_FLW_RR_RL_FC_X_FR_FL , NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRW_FLW_RR_RL_FC_LFE_FR_FL = 0X31 , NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_AUTO = 0x1FF
}
enum NV_INFOFRAME_FIELD_VALUE_AUDIO_LFEPLAYBACKLEVEL {
NV_INFOFRAME_FIELD_VALUE_AUDIO_LFEPLAYBACKLEVEL_NO_DATA = 0 , NV_INFOFRAME_FIELD_VALUE_AUDIO_LFEPLAYBACKLEVEL_0DB , NV_INFOFRAME_FIELD_VALUE_AUDIO_LFEPLAYBACKLEVEL_PLUS10DB , NV_INFOFRAME_FIELD_VALUE_AUDIO_LFEPLAYBACKLEVEL_RESERVED03 ,
NV_INFOFRAME_FIELD_VALUE_AUDIO_LFEPLAYBACKLEVEL_AUTO = 7
}
enum NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES {
NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_0DB = 0 , NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_1DB , NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_2DB , NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_3DB ,
NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_4DB , NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_5DB , NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_6DB , NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_7DB ,
NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_8DB , NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_9DB , NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_10DB , NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_11DB ,
NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_12DB , NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_13DB , NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_14DB , NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_15DB ,
NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_AUTO = 31
}
enum | NV_INFOFRAME_FIELD_VALUE_AUDIO_DOWNMIX { NV_INFOFRAME_FIELD_VALUE_AUDIO_DOWNMIX_PERMITTED = 0 , NV_INFOFRAME_FIELD_VALUE_AUDIO_DOWNMIX_PROHIBITED , NV_INFOFRAME_FIELD_VALUE_AUDIO_DOWNMIX_AUTO = 3 }
enum | NV_STATIC_METADATA_DESCRIPTOR_ID { NV_STATIC_METADATA_TYPE_1 = 0 }
enum | NV_HDR_CMD { NV_HDR_CMD_GET = 0 , NV_HDR_CMD_SET = 1 }
enum NV_HDR_MODE {
NV_HDR_MODE_OFF = 0 , NV_HDR_MODE_UHDA = 2 , NV_HDR_MODE_UHDA_PASSTHROUGH = 5 , NV_HDR_MODE_DOLBY_VISION = 7 ,
NV_HDR_MODE_EDR = 3 , NV_HDR_MODE_SDR = 4 , NV_HDR_MODE_UHDA_NB = 6 , NV_HDR_MODE_UHDBD = 2
}
enum _NVAPI_GSYNC_GPU_TOPOLOGY_CONNECTOR {
NVAPI_GSYNC_GPU_TOPOLOGY_CONNECTOR_NONE = 0 , NVAPI_GSYNC_GPU_TOPOLOGY_CONNECTOR_PRIMARY = 1 , NVAPI_GSYNC_GPU_TOPOLOGY_CONNECTOR_SECONDARY = 2 , NVAPI_GSYNC_GPU_TOPOLOGY_CONNECTOR_TERTIARY = 3 ,
NVAPI_GSYNC_GPU_TOPOLOGY_CONNECTOR_QUARTERNARY = 4
}
enum | _NVAPI_GSYNC_DISPLAY_SYNC_STATE { NVAPI_GSYNC_DISPLAY_SYNC_STATE_UNSYNCED = 0 , NVAPI_GSYNC_DISPLAY_SYNC_STATE_SLAVE = 1 , NVAPI_GSYNC_DISPLAY_SYNC_STATE_MASTER = 2 }
enum _NVAPI_GSYNC_VIDEO_MODE {
NVAPI_GSYNC_VIDEO_MODE_NONE = 0 , NVAPI_GSYNC_VIDEO_MODE_TTL = 1 , NVAPI_GSYNC_VIDEO_MODE_NTSCPALSECAM = 2 , NVAPI_GSYNC_VIDEO_MODE_HDTV = 3 ,
NVAPI_GSYNC_VIDEO_MODE_COMPOSITE = 4
}
enum | _NVAPI_GSYNC_SYNC_SOURCE { NVAPI_GSYNC_SYNC_SOURCE_VSYNC = 0 , NVAPI_GSYNC_SYNC_SOURCE_HOUSESYNC = 1 }
enum | _NVAPI_GSYNC_MULTIPLY_DIVIDE_MODE { NVAPI_GSYNC_UNDEFINED_MODE = 0 , NVAPI_GSYNC_MULTIPLY_MODE = 1 , NVAPI_GSYNC_DIVIDE_MODE = 2 }
enum | _NVAPI_GSYNC_DELAY_TYPE { NVAPI_GSYNC_DELAY_TYPE_UNKNOWN = 0 , NVAPI_GSYNC_DELAY_TYPE_SYNC_SKEW = 1 , NVAPI_GSYNC_DELAY_TYPE_STARTUP = 2 }
enum | _NVAPI_GSYNC_RJ45_IO { NVAPI_GSYNC_RJ45_OUTPUT = 0 , NVAPI_GSYNC_RJ45_INPUT = 1 , NVAPI_GSYNC_RJ45_UNUSED = 2 }

Functions

NVAPI_INTERFACE | NvAPI_OGL_ExpertModeSet (NvU32 expertDetailLevel, NvU32 expertReportMask, NvU32 expertOutputMask, NVAPI_OGLEXPERT_CALLBACK expertCallback)
NVAPI_INTERFACE | NvAPI_OGL_ExpertModeGet (NvU32 *pExpertDetailLevel, NvU32 *pExpertReportMask, NvU32 *pExpertOutputMask, NVAPI_OGLEXPERT_CALLBACK *pExpertCallback)
__nvapi_deprecated_function ("Do not use this function - it is deprecated in release 319.") NVAPI_INTERFACE NvAPI_GPU_CudaEnumComputeCapableGpus(__inout NV_COMPUTE_GPU_TOPOLOGY *pComputeTopo)
NVAPI_INTERFACE | NvAPI_GPU_NVLINK_GetCaps (__in NvPhysicalGpuHandle hPhysicalGpu, __inout NVLINK_GET_CAPS *capsParams)
NVAPI_INTERFACE | NvAPI_GPU_NVLINK_GetStatus (__in NvPhysicalGpuHandle hPhysicalGpu, __inout NVLINK_GET_STATUS *statusParams)
NVAPI_INTERFACE | NvAPI_GPU_ClientIllumDevicesGetInfo (__in NvPhysicalGpuHandle hPhysicalGpu, __inout NV_GPU_CLIENT_ILLUM_DEVICE_INFO_PARAMS *pIllumDevicesInfo)
NVAPI_INTERFACE | NvAPI_GPU_ClientIllumDevicesGetControl (__in NvPhysicalGpuHandle hPhysicalGpu, __inout NV_GPU_CLIENT_ILLUM_DEVICE_CONTROL_PARAMS *pClientIllumDevicesControl)
NVAPI_INTERFACE | NvAPI_GPU_ClientIllumDevicesSetControl (__in NvPhysicalGpuHandle hPhysicalGpu, __inout NV_GPU_CLIENT_ILLUM_DEVICE_CONTROL_PARAMS *pClientIllumDevicesControl)
NVAPI_INTERFACE | NvAPI_GPU_ClientIllumZonesGetInfo (__in NvPhysicalGpuHandle hPhysicalGpu, __inout NV_GPU_CLIENT_ILLUM_ZONE_INFO_PARAMS *pIllumZonesInfo)
NVAPI_INTERFACE | NvAPI_GPU_ClientIllumZonesGetControl (__in NvPhysicalGpuHandle hPhysicalGpu, __inout NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_PARAMS *pIllumZonesControl)
NVAPI_INTERFACE | NvAPI_GPU_ClientIllumZonesSetControl (__in NvPhysicalGpuHandle hPhysicalGpu, __inout NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_PARAMS *pIllumZonesControl)
NVAPI_INTERFACE | NvAPI_Mosaic_EnumDisplayModes (__in NV_MOSAIC_GRID_TOPO *pGridTopology, __inout_ecount_part_opt(*pDisplayCount, *pDisplayCount) NV_MOSAIC_DISPLAY_SETTING *pDisplaySettings, __inout NvU32 *pDisplayCount)

Variables

void * | pOSAdapterId
NV_GPU_PERF_PSTATES_INFO * pPerfPstatesInfo
NV_GPU_PERF_PSTATES_INFO NvU32 inputFlags
NV_VIEW_TARGET_INFO * pTargets
NV_VIEW_TARGET_INFO NvU32 * pTargetMaskCount
NV_VIEW_TARGET_INFO NvU32 NV_TARGET_VIEW_MODE * pTargetView
NV_DISPLAY_PATH_INFO * pPathInfo
NV_DISPLAY_PATH_INFO NvU32 * pPathCount
NV_DISPLAY_PATH_INFO NvU32 NV_TARGET_VIEW_MODE * pTargetViewMode
enum _NV_LICENSE_FEATURE_TYPE {
NV_LICENSE_FEATURE_UNKNOWN = 0 , NV_LICENSE_FEATURE_VGPU = 1 , NV_LICENSE_FEATURE_NVIDIA_RTX = 2 , NV_LICENSE_FEATURE_QUADRO = NV_LICENSE_FEATURE_NVIDIA_RTX ,
NV_LICENSE_FEATURE_GAMING = 3 , NV_LICENSE_FEATURE_COMPUTE = 4
}
typedef char | NvAPI_LicenseString[NV_LICENSE_INFO_MAX_LENGTH]
typedef enum _NV_LICENSE_FEATURE_TYPE | NV_LICENSE_FEATURE_TYPE
typedef struct _NV_LICENSE_EXPIRY_DETAILS | NV_LICENSE_EXPIRY_DETAILS
typedef struct _NV_LICENSE_FEATURE_DETAILS_V1 | NV_LICENSE_FEATURE_DETAILS_V1
typedef struct _NV_LICENSE_FEATURE_DETAILS_V2 | NV_LICENSE_FEATURE_DETAILS_V2
typedef struct _NV_LICENSE_FEATURE_DETAILS_V3 | NV_LICENSE_FEATURE_DETAILS_V3
typedef struct _NV_LICENSE_FEATURE_DETAILS_V4 | NV_LICENSE_FEATURE_DETAILS_V4
typedef NV_LICENSE_FEATURE_DETAILS_V1 | NV_LICENSE_FEATURE_DETAILS
typedef struct _NV_LICENSABLE_FEATURES_V1 | NV_LICENSABLE_FEATURES_V1
typedef struct _NV_LICENSABLE_FEATURES_V2 | NV_LICENSABLE_FEATURES_V2
typedef struct _NV_LICENSABLE_FEATURES_V3 | NV_LICENSABLE_FEATURES_V3
typedef struct _NV_LICENSABLE_FEATURES_V4 | NV_LICENSABLE_FEATURES_V4
typedef NV_LICENSABLE_FEATURES_V4 | NV_LICENSABLE_FEATURES
#define | NV_LICENSE_SIGNATURE_SIZE (128)
#define | NV_LICENSE_INFO_MAX_LENGTH (128)
#define | NV_LICENSE_FEATURE_DETAILS_VER1 MAKE_NVAPI_VERSION(NV_LICENSE_FEATURE_DETAILS_V1, 1)
#define | NV_LICENSE_FEATURE_DETAILS_VER NV_LICENSE_FEATURE_DETAILS_VER1
#define | NV_LICENSABLE_FEATURES_VER1 MAKE_NVAPI_VERSION(NV_LICENSABLE_FEATURES_V1, 1)
#define | NV_LICENSABLE_FEATURES_VER2 MAKE_NVAPI_VERSION(NV_LICENSABLE_FEATURES_V2, 2)
#define | NV_LICENSABLE_FEATURES_VER3 MAKE_NVAPI_VERSION(NV_LICENSABLE_FEATURES_V3, 3)
#define | NV_LICENSABLE_FEATURES_VER4 MAKE_NVAPI_VERSION(NV_LICENSABLE_FEATURES_V4, 4)
#define | NV_LICENSABLE_FEATURES_VER NV_LICENSABLE_FEATURES_VER4
enum _NVAPI_NVLINK_DEVICE_INFO_DEVICE_TYPE {
NVAPI_NVLINK_DEVICE_INFO_DEVICE_TYPE_EBRIDGE , NVAPI_NVLINK_DEVICE_INFO_DEVICE_TYPE_NPU , NVAPI_NVLINK_DEVICE_INFO_DEVICE_TYPE_GPU , NVAPI_NVLINK_DEVICE_INFO_DEVICE_TYPE_SWITCH ,
NVAPI_NVLINK_DEVICE_INFO_DEVICE_TYPE_TEGRA , NVAPI_NVLINK_DEVICE_INFO_DEVICE_TYPE_NONE , NVAPI_NVLINK_DEVICE_INFO_DEVICE_UUID_INVALID
}
enum _NVAPI_NVLINK_STATUS_LINK_STATE {
NVAPI_NVLINK_STATUS_LINK_STATE_UNKNOWN , NVAPI_NVLINK_STATUS_LINK_STATE_INIT , NVAPI_NVLINK_STATUS_LINK_STATE_HWCFG , NVAPI_NVLINK_STATUS_LINK_STATE_SWCFG ,
NVAPI_NVLINK_STATUS_LINK_STATE_ACTIVE , NVAPI_NVLINK_STATUS_LINK_STATE_FAULT , NVAPI_NVLINK_STATUS_LINK_STATE_RECOVERY , NVAPI_NVLINK_STATUS_LINK_STATE_RECOVERY_AC ,
NVAPI_NVLINK_STATUS_LINK_STATE_RECOVERY_AX , NVAPI_NVLINK_STATUS_LINK_STATE_INVALID = 0xFFFFFFFF
}
enum _NVAPI_NVLINK_STATUS_SUBLINK_RX_STATE {
NVAPI_NVLINK_STATUS_SUBLINK_RX_STATE_UNKNOWN , NVAPI_NVLINK_STATUS_SUBLINK_RX_STATE_HIGH_SPEED_1 , NVAPI_NVLINK_STATUS_SUBLINK_RX_STATE_LOW_POWER , NVAPI_NVLINK_STATUS_SUBLINK_RX_STATE_TRAINING ,
NVAPI_NVLINK_STATUS_SUBLINK_RX_STATE_SAFE_MODE , NVAPI_NVLINK_STATUS_SUBLINK_RX_STATE_OFF , NVAPI_NVLINK_STATUS_SUBLINK_RX_STATE_TEST , NVAPI_NVLINK_STATUS_SUBLINK_RX_STATE_FAULT ,
NVAPI_NVLINK_STATUS_SUBLINK_RX_STATE_INVALID = 0xFF
}
enum _NVAPI_NVLINK_STATUS_SUBLINK_TX_STATE {
NVAPI_NVLINK_STATUS_SUBLINK_TX_STATE_UNKNOWN , NVAPI_NVLINK_STATUS_SUBLINK_TX_STATE_HIGH_SPEED_1 , NVAPI_NVLINK_STATUS_SUBLINK_TX_STATE_LOW_POWER , NVAPI_NVLINK_STATUS_SUBLINK_TX_STATE_TRAINING ,
NVAPI_NVLINK_STATUS_SUBLINK_TX_STATE_SAFE_MODE , NVAPI_NVLINK_STATUS_SUBLINK_TX_STATE_OFF , NVAPI_NVLINK_STATUS_SUBLINK_TX_STATE_TEST , NVAPI_NVLINK_STATUS_SUBLINK_TX_STATE_FAULT ,
NVAPI_NVLINK_STATUS_SUBLINK_TX_STATE_INVALID = 0xFF
}
typedef enum _NVAPI_NVLINK_DEVICE_INFO_DEVICE_TYPE | NVAPI_NVLINK_DEVICE_INFO_DEVICE_TYPE
typedef enum _NVAPI_NVLINK_STATUS_LINK_STATE | NVAPI_NVLINK_STATUS_LINK_STATE
typedef enum _NVAPI_NVLINK_STATUS_SUBLINK_RX_STATE | NVAPI_NVLINK_STATUS_SUBLINK_RX_STATE
typedef enum _NVAPI_NVLINK_STATUS_SUBLINK_TX_STATE | NVAPI_NVLINK_STATUS_SUBLINK_TX_STATE
typedef NVLINK_GET_STATUS_V2 | NVLINK_GET_STATUS
#define | NVAPI_NVLINK_DEVICE_INFO_DEVICE_ID_FLAGS_NONE (0x00000000)
#define | NVAPI_NVLINK_DEVICE_INFO_DEVICE_ID_FLAGS_PCI (0x00000001)
#define | NVAPI_NVLINK_DEVICE_INFO_DEVICE_ID_FLAGS_UUID (0x00000002)
#define | NVAPI_NVLINK_STATUS_PHY_NVHS (0x00000001)
#define | NVAPI_NVLINK_STATUS_PHY_GRS (0x00000002)
#define | NVAPI_NVLINK_STATUS_PHY_INVALID (0x000000FF)
#define | NVAPI_NVLINK_STATUS_NVLINK_VERSION_1_0 (0x00000001)
#define | NVAPI_NVLINK_STATUS_NVLINK_VERSION_2_0 (0x00000002)
#define | NVAPI_NVLINK_STATUS_NVLINK_VERSION_INVALID (0x000000FF)
#define | NVAPI_NVLINK_STATUS_NCI_VERSION_1_0 (0x00000001)
#define | NVAPI_NVLINK_STATUS_NCI_VERSION_2_0 (0x00000002)
#define | NVAPI_NVLINK_STATUS_NCI_VERSION_INVALID (0x000000FF)
#define | NVAPI_NVLINK_STATUS_NVHS_VERSION_1_0 (0x00000001)
#define | NVAPI_NVLINK_STATUS_NVHS_VERSION_INVALID (0x000000FF)
#define | NVAPI_NVLINK_STATUS_GRS_VERSION_1_0 (0x00000001)
#define | NVAPI_NVLINK_STATUS_GRS_VERSION_INVALID (0x000000FF)
#define | NVAPI_NVLINK_STATUS_CONNECTED_TRUE (0x00000001)
#define | NVAPI_NVLINK_STATUS_CONNECTED_FALSE (0x00000000)
#define | NVAPI_NVLINK_STATUS_LOOP_PROPERTY_LOOPBACK (0x00000001)
#define | NVAPI_NVLINK_STATUS_LOOP_PROPERTY_LOOPOUT (0x00000002)
#define | NVAPI_NVLINK_STATUS_LOOP_PROPERTY_NONE (0x00000000)
#define | NVAPI_NVLINK_STATUS_REMOTE_LINK_NUMBER_INVALID (0x000000FF)
#define | NVAPI_NVLINK_REFCLK_TYPE_INVALID (0x00)
#define | NVAPI_NVLINK_REFCLK_TYPE_NVHS (0x01)
#define | NVAPI_NVLINK_REFCLK_TYPE_PEX (0x02)
#define | NVLINK_GET_STATUS_VER1 MAKE_NVAPI_VERSION(NVLINK_GET_STATUS_V1, 1)
#define | NVLINK_GET_STATUS_VER2 MAKE_NVAPI_VERSION(NVLINK_GET_STATUS_V2, 2)
#define | NVLINK_GET_STATUS_VER NVLINK_GET_STATUS_VER2
enum | NV_COLOR_CMD { NV_COLOR_CMD_GET = 1 , NV_COLOR_CMD_SET , NV_COLOR_CMD_IS_SUPPORTED_COLOR , NV_COLOR_CMD_GET_DEFAULT }
enum NV_COLOR_FORMAT {
NV_COLOR_FORMAT_RGB = 0 , NV_COLOR_FORMAT_YUV422 , NV_COLOR_FORMAT_YUV444 , NV_COLOR_FORMAT_YUV420 ,
NV_COLOR_FORMAT_DEFAULT = 0xFE , NV_COLOR_FORMAT_AUTO = 0xFF
}
enum NV_COLOR_COLORIMETRY {
NV_COLOR_COLORIMETRY_RGB = 0 , NV_COLOR_COLORIMETRY_YCC601 , NV_COLOR_COLORIMETRY_YCC709 , NV_COLOR_COLORIMETRY_XVYCC601 ,
NV_COLOR_COLORIMETRY_XVYCC709 , NV_COLOR_COLORIMETRY_SYCC601 , NV_COLOR_COLORIMETRY_ADOBEYCC601 , NV_COLOR_COLORIMETRY_ADOBERGB ,
NV_COLOR_COLORIMETRY_BT2020RGB , NV_COLOR_COLORIMETRY_BT2020YCC , NV_COLOR_COLORIMETRY_BT2020cYCC , NV_COLOR_COLORIMETRY_DEFAULT = 0xFE ,
NV_COLOR_COLORIMETRY_AUTO = 0xFF
}
enum | _NV_DYNAMIC_RANGE { NV_DYNAMIC_RANGE_VESA = 0x0 , NV_DYNAMIC_RANGE_CEA = 0x1 , NV_DYNAMIC_RANGE_AUTO = 0xFF }
enum _NV_BPC {
NV_BPC_DEFAULT = 0 , NV_BPC_6 = 1 , NV_BPC_8 = 2 , NV_BPC_10 = 3 ,
NV_BPC_12 = 4 , NV_BPC_16 = 5
}
enum | _NV_COLOR_SELECTION_POLICY { NV_COLOR_SELECTION_POLICY_USER = 0 , NV_COLOR_SELECTION_POLICY_BEST_QUALITY = 1 , NV_COLOR_SELECTION_POLICY_DEFAULT = NV_COLOR_SELECTION_POLICY_BEST_QUALITY , NV_COLOR_SELECTION_POLICY_UNKNOWN = 0xFF }
enum _NV_DESKTOP_COLOR_DEPTH {
NV_DESKTOP_COLOR_DEPTH_DEFAULT = 0x0 , NV_DESKTOP_COLOR_DEPTH_8BPC = 0x1 , NV_DESKTOP_COLOR_DEPTH_10BPC = 0x2 , NV_DESKTOP_COLOR_DEPTH_16BPC_FLOAT = 0x3 ,
NV_DESKTOP_COLOR_DEPTH_16BPC_FLOAT_WCG = 0x4 , NV_DESKTOP_COLOR_DEPTH_16BPC_FLOAT_HDR = 0x5 , NV_DESKTOP_COLOR_DEPTH_MAX_VALUE = NV_DESKTOP_COLOR_DEPTH_16BPC_FLOAT_HDR
}
typedef enum _NV_DYNAMIC_RANGE | NV_DYNAMIC_RANGE
typedef enum _NV_BPC | NV_BPC
typedef enum _NV_COLOR_SELECTION_POLICY | NV_COLOR_SELECTION_POLICY
typedef enum _NV_DESKTOP_COLOR_DEPTH | NV_DESKTOP_COLOR_DEPTH
typedef struct _NV_COLOR_DATA_V1 | NV_COLOR_DATA_V1
typedef struct _NV_COLOR_DATA_V2 | NV_COLOR_DATA_V2
typedef struct _NV_COLOR_DATA_V3 | NV_COLOR_DATA_V3
typedef struct _NV_COLOR_DATA_V4 | NV_COLOR_DATA_V4
typedef struct _NV_COLOR_DATA_V5 | NV_COLOR_DATA_V5
typedef NV_COLOR_DATA_V5 | NV_COLOR_DATA
NVAPI_INTERFACE | NvAPI_Disp_ColorControl (NvU32 displayId, NV_COLOR_DATA *pColorData)
#define | NV_COLOR_DATA_VER1 MAKE_NVAPI_VERSION(NV_COLOR_DATA_V1, 1)
#define | NV_COLOR_DATA_VER2 MAKE_NVAPI_VERSION(NV_COLOR_DATA_V2, 2)
#define | NV_COLOR_DATA_VER3 MAKE_NVAPI_VERSION(NV_COLOR_DATA_V3, 3)
#define | NV_COLOR_DATA_VER4 MAKE_NVAPI_VERSION(NV_COLOR_DATA_V4, 4)
#define | NV_COLOR_DATA_VER5 MAKE_NVAPI_VERSION(NV_COLOR_DATA_V5, 5)
#define | NV_COLOR_DATA_VER NV_COLOR_DATA_VER5
enum | _NV_COLORSPACE_TYPE { NV_COLORSPACE_sRGB = 0 , NV_COLORSPACE_xRGB = 1 , NV_COLORSPACE_REC2100 = 12 }
enum | _NV_DISPLAY_OUTPUT_MODE { NV_DISPLAY_OUTPUT_MODE_SDR = 0 , NV_DISPLAY_OUTPUT_MODE_HDR10 = 1 , NV_DISPLAY_OUTPUT_MODE_HDR10PLUS_GAMING = 2 }
enum | _NV_HDR_TONEMAPPING_METHOD { NV_HDR_TONEMAPPING_APP = 0 , NV_HDR_TONEMAPPING_GPU = 1 }
typedef enum _NV_COLORSPACE_TYPE | NV_COLORSPACE_TYPE
typedef struct _NV_HDR_METADATA_V1 | NV_HDR_METADATA_V1
typedef NV_HDR_METADATA_V1 | NV_HDR_METADATA
typedef enum _NV_DISPLAY_OUTPUT_MODE | NV_DISPLAY_OUTPUT_MODE
typedef enum _NV_HDR_TONEMAPPING_METHOD | NV_HDR_TONEMAPPING_METHOD
NVAPI_INTERFACE | NvAPI_Disp_HdrColorControl (__in NvU32 displayId, __inout NV_HDR_COLOR_DATA *pHdrColorData)
NVAPI_INTERFACE | NvAPI_Disp_SetSourceColorSpace (__in NvU32 displayId, __in NV_COLORSPACE_TYPE colorSpaceType)
NVAPI_INTERFACE | NvAPI_Disp_GetSourceColorSpace (__in NvU32 displayId, __inout NV_COLORSPACE_TYPE *pColorSpaceType, NvU64 sourcePID)
NVAPI_INTERFACE | NvAPI_Disp_SetSourceHdrMetadata (__in NvU32 displayId, __in NV_HDR_METADATA *pMetadata)
NVAPI_INTERFACE | NvAPI_Disp_GetSourceHdrMetadata (__in NvU32 displayId, __inout NV_HDR_METADATA *pMetadata, NvU64 sourcePID)
NVAPI_INTERFACE | NvAPI_Disp_SetOutputMode (__in NvU32 displayId, __inout NV_DISPLAY_OUTPUT_MODE *pDisplayMode)
NVAPI_INTERFACE | NvAPI_Disp_GetOutputMode (__in NvU32 displayId, __inout NV_DISPLAY_OUTPUT_MODE *pDisplayMode)
NVAPI_INTERFACE | NvAPI_Disp_SetHdrToneMapping (__in NvU32 displayId, __in NV_HDR_TONEMAPPING_METHOD hdrTonemapping)
NVAPI_INTERFACE | NvAPI_Disp_GetHdrToneMapping (__in NvU32 displayId, __inout NV_HDR_TONEMAPPING_METHOD *pHdrTonemapping)
#define | NV_SOURCE_PID_CURRENT 0
#define | NV_HDR_METADATA_VER1 MAKE_NVAPI_VERSION(NV_HDR_METADATA_V1, 1)
#define | NV_HDR_METADATA_VER NV_HDR_METADATA_VER1
enum _NV_PIXEL_SHIFT_TYPE {
NV_PIXEL_SHIFT_TYPE_NO_PIXEL_SHIFT = 0 , NV_PIXEL_SHIFT_TYPE_2x2_TOP_LEFT_PIXELS = 1 , NV_PIXEL_SHIFT_TYPE_2x2_BOTTOM_RIGHT_PIXELS = 2 , NV_PIXEL_SHIFT_TYPE_2x2_TOP_RIGHT_PIXELS = 4 ,
NV_PIXEL_SHIFT_TYPE_2x2_BOTTOM_LEFT_PIXELS = 8
}
typedef enum _NV_PIXEL_SHIFT_TYPE | NV_PIXEL_SHIFT_TYPE
typedef struct _NV_MOSAIC_GRID_TOPO_DISPLAY_V2 | NV_MOSAIC_GRID_TOPO_DISPLAY_V2
typedef NV_MOSAIC_GRID_TOPO_DISPLAY_V1 | NV_MOSAIC_GRID_TOPO_DISPLAY
typedef struct _NV_MOSAIC_GRID_TOPO_V1 | NV_MOSAIC_GRID_TOPO_V1
typedef struct _NV_MOSAIC_GRID_TOPO_V2 | NV_MOSAIC_GRID_TOPO_V2
typedef NV_MOSAIC_GRID_TOPO_V2 | NV_MOSAIC_GRID_TOPO
typedef struct _NV_MOSAIC_GRID_TOPO_DISPLAY_V1 | NV_MOSAIC_GRID_TOPO_DISPLAY_V1
#define | NV_MOSAIC_GRID_TOPO_VER1 MAKE_NVAPI_VERSION(NV_MOSAIC_GRID_TOPO_V1,1)
#define | NV_MOSAIC_GRID_TOPO_VER2 MAKE_NVAPI_VERSION(NV_MOSAIC_GRID_TOPO_V2,2)
#define | NV_MOSAIC_GRID_TOPO_VER NV_MOSAIC_GRID_TOPO_VER2
enum | NV_MONITOR_CAPS_TYPE { NV_MONITOR_CAPS_TYPE_HDMI_VSDB = 0x1000 , NV_MONITOR_CAPS_TYPE_HDMI_VCDB = 0x1001 , NV_MONITOR_CAPS_TYPE_GENERIC = 0x1002 }
typedef struct _NV_MONITOR_CAPS_VCDB | NV_MONITOR_CAPS_VCDB
typedef struct _NV_MONITOR_CAPS_VSDB | NV_MONITOR_CAPS_VSDB
typedef struct _NV_MONITOR_CAPS_GENERIC | NV_MONITOR_CAPS_GENERIC
typedef struct _NV_MONITOR_CAPABILITIES_V1 | NV_MONITOR_CAPABILITIES_V1
typedef NV_MONITOR_CAPABILITIES_V1 | NV_MONITOR_CAPABILITIES
#define | NV_MONITOR_CAPABILITIES_VER1 MAKE_NVAPI_VERSION(NV_MONITOR_CAPABILITIES_V1,1)
#define | NV_MONITOR_CAPABILITIES_VER NV_MONITOR_CAPABILITIES_VER1
typedef NVLINK_GET_CAPS_V1 | NVLINK_GET_CAPS
#define | NVAPI_NVLINK_CAPS_SUPPORTED 0x00000001
#define | NVAPI_NVLINK_CAPS_P2P_SUPPORTED 0x00000002
#define | NVAPI_NVLINK_CAPS_SYSMEM_ACCESS 0x00000004
#define | NVAPI_NVLINK_CAPS_P2P_ATOMICS 0x00000008
#define | NVAPI_NVLINK_CAPS_SYSMEM_ATOMICS 0x00000010
#define | NVAPI_NVLINK_CAPS_PEX_TUNNELING 0x00000020
#define | NVAPI_NVLINK_CAPS_SLI_BRIDGE 0x00000040
#define | NVAPI_NVLINK_CAPS_SLI_BRIDGE_SENSABLE 0x00000080
#define | NVAPI_NVLINK_CAPS_POWER_STATE_L0 0x00000100
#define | NVAPI_NVLINK_CAPS_POWER_STATE_L1 0x00000200
#define | NVAPI_NVLINK_CAPS_POWER_STATE_L2 0x00000400
#define | NVAPI_NVLINK_CAPS_POWER_STATE_L3 0x00000800
#define | NVAPI_NVLINK_CAPS_VALID 0x00001000
#define | NVAPI_NVLINK_CAPS_NVLINK_VERSION_INVALID (0x00000000)
#define | NVAPI_NVLINK_CAPS_NVLINK_VERSION_1_0 (0x00000001)
#define | NVAPI_NVLINK_CAPS_NVLINK_VERSION_2_0 (0x00000002)
#define | NVAPI_NVLINK_CAPS_NCI_VERSION_INVALID (0x00000000)
#define | NVAPI_NVLINK_CAPS_NCI_VERSION_1_0 (0x00000001)
#define | NVAPI_NVLINK_CAPS_NCI_VERSION_2_0 (0x00000002)
#define | NVLINK_GET_CAPS_VER1 MAKE_NVAPI_VERSION(NVLINK_GET_CAPS_V1, 1)
#define | NVLINK_GET_CAPS_VER NVLINK_GET_CAPS_VER1
typedef struct _NV_EDID_DATA_V2 | NV_EDID_DATA_V2
typedef NV_EDID_DATA_V2 | NV_EDID_DATA
typedef struct _NV_EDID_DATA_V1 | NV_EDID_DATA_V1
NVAPI_INTERFACE | NvAPI_DISP_GetEdidData (__in NvU32 displayId, __inout NV_EDID_DATA *pEdidParams, __inout NV_EDID_FLAG *pFlag)
#define | NV_EDID_DATA_VER1 MAKE_NVAPI_VERSION(NV_EDID_DATA_V1, 1)
#define | NV_EDID_DATA_VER2 MAKE_NVAPI_VERSION(NV_EDID_DATA_V2, 2)
#define | NV_EDID_DATA_VER NV_EDID_DATA_VER2

NvAPI_OGL_ExpertModeDefaultsSet[Get] Functions

NvU32 * pOutputsMask
NVAPI_INTERFACE | NvAPI_OGL_ExpertModeDefaultsSet (NvU32 expertDetailLevel, NvU32 expertReportMask, NvU32 expertOutputMask)
NVAPI_INTERFACE | NvAPI_OGL_ExpertModeDefaultsGet (NvU32 *pExpertDetailLevel, NvU32 *pExpertReportMask, NvU32 *pExpertOutputMask)
NVAPI_INTERFACE | NvAPI_Disp_GetHdrCapabilities (__in NvU32 displayId, __inout NV_HDR_CAPABILITIES *pHdrCapabilities)

NvAPI_OGL_ExpertModeSet[Get] Functions

#define | NVAPI_OGLEXPERT_DETAIL_NONE 0x00000000
#define | NVAPI_OGLEXPERT_DETAIL_ERROR 0x00000001
#define | NVAPI_OGLEXPERT_DETAIL_SWFALLBACK 0x00000002
#define | NVAPI_OGLEXPERT_DETAIL_BASIC_INFO 0x00000004
#define | NVAPI_OGLEXPERT_DETAIL_DETAILED_INFO 0x00000008
#define | NVAPI_OGLEXPERT_DETAIL_PERFORMANCE_WARNING 0x00000010
#define | NVAPI_OGLEXPERT_DETAIL_QUALITY_WARNING 0x00000020
#define | NVAPI_OGLEXPERT_DETAIL_USAGE_WARNING 0x00000040
#define | NVAPI_OGLEXPERT_DETAIL_ALL 0xFFFFFFFF
#define | NVAPI_OGLEXPERT_REPORT_NONE 0x00000000
#define | NVAPI_OGLEXPERT_REPORT_ERROR 0x00000001
#define | NVAPI_OGLEXPERT_REPORT_SWFALLBACK 0x00000002
#define | NVAPI_OGLEXPERT_REPORT_PIPELINE_VERTEX 0x00000004
#define | NVAPI_OGLEXPERT_REPORT_PIPELINE_GEOMETRY 0x00000008
#define | NVAPI_OGLEXPERT_REPORT_PIPELINE_XFB 0x00000010
#define | NVAPI_OGLEXPERT_REPORT_PIPELINE_RASTER 0x00000020
#define | NVAPI_OGLEXPERT_REPORT_PIPELINE_FRAGMENT 0x00000040
#define | NVAPI_OGLEXPERT_REPORT_PIPELINE_ROP 0x00000080
#define | NVAPI_OGLEXPERT_REPORT_PIPELINE_FRAMEBUFFER 0x00000100
#define | NVAPI_OGLEXPERT_REPORT_PIPELINE_PIXEL 0x00000200
#define | NVAPI_OGLEXPERT_REPORT_PIPELINE_TEXTURE 0x00000400
#define | NVAPI_OGLEXPERT_REPORT_OBJECT_BUFFEROBJECT 0x00000800
#define | NVAPI_OGLEXPERT_REPORT_OBJECT_TEXTURE 0x00001000
#define | NVAPI_OGLEXPERT_REPORT_OBJECT_PROGRAM 0x00002000
#define | NVAPI_OGLEXPERT_REPORT_OBJECT_FBO 0x00004000
#define | NVAPI_OGLEXPERT_REPORT_FEATURE_SLI 0x00008000
#define | NVAPI_OGLEXPERT_REPORT_ALL 0xFFFFFFFF
#define | NVAPI_OGLEXPERT_OUTPUT_TO_NONE 0x00000000
#define | NVAPI_OGLEXPERT_OUTPUT_TO_CONSOLE 0x00000001
#define | NVAPI_OGLEXPERT_OUTPUT_TO_DEBUGGER 0x00000004
#define | NVAPI_OGLEXPERT_OUTPUT_TO_CALLBACK 0x00000008
#define | NVAPI_OGLEXPERT_OUTPUT_TO_ALL 0xFFFFFFFF
#define | NV_GPU_PERF_PSTATES_INFO_VER2 MAKE_NVAPI_VERSION(NV_GPU_PERF_PSTATES_INFO_V2,2)
#define | NV_GPU_PERF_PSTATES_INFO_VER3 MAKE_NVAPI_VERSION(NV_GPU_PERF_PSTATES_INFO_V2,3)
#define | NV_GPU_PERF_PSTATES_INFO_VER NV_GPU_PERF_PSTATES_INFO_VER3
#define | NV_GPU_THERMAL_SETTINGS_VER_2 MAKE_NVAPI_VERSION(NV_GPU_THERMAL_SETTINGS_V2,2)
#define | NV_GPU_THERMAL_SETTINGS_VER NV_GPU_THERMAL_SETTINGS_VER_2

Detailed Description

The OpenGL APIs configure OpenGL Expert Mode, an API usage feedback and advice reporting mechanism.

This function configures OpenGL Expert Mode, an API usage feedback and advice reporting mechanism. The effects of this call are applied only to the current context, and are reset to the defaults when the context is destroyed.

Note
This feature is valid at runtime only when GLExpert functionality has been built into the OpenGL driver installed on the system. All Windows Vista OpenGL drivers provided by NVIDIA have this instrumentation included by default. Windows XP, however, requires a special display driver available with the NVIDIA PerfSDK found at developer.nvidia.com.
These functions are valid only for the current OpenGL context. Calling these functions prior to creating a context and calling MakeCurrent with it will result in errors and undefined behavior.

SUPPORTED OS: Windows 7 and higher

Since
Release: 80
Parameters
expertDetailMask | Mask made up of NVAPI_OGLEXPERT_DETAIL bits, this parameter specifies the detail level in the feedback stream.
expertReportMask | Mask made up of NVAPI_OGLEXPERT_REPORT bits, this parameter specifies the areas of functional interest.
expertOutputMask | Mask made up of NVAPI_OGLEXPERT_OUTPUT bits, this parameter specifies the feedback output location.
expertCallback | Used in conjunction with OUTPUT_TO_CALLBACK, this is a simple callback function the user may use to obtain the feedback stream. The function will be called once per fully qualified feedback stream extry.
Return values
NVAPI_API_NOT_INTIALIZED | NVAPI not initialized
NVAPI_NVIDIA_DEVICE_NOT_FOUND | No NVIDIA GPU found
NVAPI_OPENGL_CONTEXT_NOT_CURRENT | No NVIDIA OpenGL context which supports GLExpert has been made current
NVAPI_ERROR | OpenGL driver failed to load properly
NVAPI_OK | Success

SUPPORTED OS: Windows 7 and higher

Macro Definition Documentation

◆ NV_COLOR_DATA_VER

#define NV_COLOR_DATA_VER NV_COLOR_DATA_VER5

See Table 14 of CEA-861E. Not all of this is supported by the GPU.

◆ NV_COLOR_DATA_VER1

#define NV_COLOR_DATA_VER1 MAKE_NVAPI_VERSION(NV_COLOR_DATA_V1, 1)

See Table 14 of CEA-861E. Not all of this is supported by the GPU.

◆ NV_COLOR_DATA_VER2

#define NV_COLOR_DATA_VER2 MAKE_NVAPI_VERSION(NV_COLOR_DATA_V2, 2)

See Table 14 of CEA-861E. Not all of this is supported by the GPU.

◆ NV_COLOR_DATA_VER3

#define NV_COLOR_DATA_VER3 MAKE_NVAPI_VERSION(NV_COLOR_DATA_V3, 3)

See Table 14 of CEA-861E. Not all of this is supported by the GPU.

◆ NV_COLOR_DATA_VER4

#define NV_COLOR_DATA_VER4 MAKE_NVAPI_VERSION(NV_COLOR_DATA_V4, 4)

See Table 14 of CEA-861E. Not all of this is supported by the GPU.

◆ NV_COLOR_DATA_VER5

#define NV_COLOR_DATA_VER5 MAKE_NVAPI_VERSION(NV_COLOR_DATA_V5, 5)

See Table 14 of CEA-861E. Not all of this is supported by the GPU.

◆ NV_DISPLAY_PORT_INFO_VER

#define NV_DISPLAY_PORT_INFO_VER NV_DISPLAY_PORT_INFO_VER2

◆ NV_DISPLAY_PORT_INFO_VER1

#define NV_DISPLAY_PORT_INFO_VER1 MAKE_NVAPI_VERSION(NV_DISPLAY_PORT_INFO,1)

Macro for constructing the version field of NV_DISPLAY_PORT_INFO.

◆ NV_DISPLAY_PORT_INFO_VER2

#define NV_DISPLAY_PORT_INFO_VER2 MAKE_NVAPI_VERSION(NV_DISPLAY_PORT_INFO,2)

◆ NV_EDID_DATA_VER

#define NV_EDID_DATA_VER NV_EDID_DATA_VER2
DESCRIPTION: This API returns the EDID data for the specified display Id.
(NvAPI_GPU_GetConnectedDisplayIds() can be used to get the DisplayIds).
USAGE: The caller has to call this API two times to fetch the required details as follows:
First Pass : Caller should call NvAPI_DISP_GetEdidData() with pEdidParams->pEDID set to NULL,
to get the size of the EDID buffer in pEdidParams->sizeOfEDID.
Second Pass: Allocate memory for the EDID buffer of the size - pEdidParams->sizeOfEDID,
and call the API again to get the EDID buffer populated.
\param [in] displayId - NVIDIA Display ID
\param [inout] pEdidParams - Pointer to the structure that contains - pointer to EDID buffer and its size
\param [inout] pFlag - The type of EDID to be retrieved (IN).
To only retrieve the EDID type, the user should send pEdidParams->pEDID as NULL and
pEdidParams->sizeOfEDID as 0.
SUPPORTED OS: Windows 7 and higher
\since Release: 400
\return This API can return any of the error codes enumerated in #NvAPI_Status.
If there are return error codes with specific meaning for this API, they are listed below.
NVAPI_INSUFFICIENT_BUFFER: Reallocate buffer with pEdidParams->sizeOfEDID and call again to get complete data.
In this case pEdidParams->pEDID contains undefined data.
This error occurs only when pEdidParams->pEDID is present.
NvAPI_GPU_GetConnectedDisplayIds
NVAPI_INTERFACE NvAPI_GPU_GetConnectedDisplayIds(__in NvPhysicalGpuHandle hPhysicalGpu, __inout_ecount_part_opt(*pDisplayIdCount, *pDisplayIdCount) NV_GPU_DISPLAYIDS *pDisplayIds, __inout NvU32 *pDisplayIdCount, __in NvU32 flags)
NVAPI_INSUFFICIENT_BUFFER
@ NVAPI_INSUFFICIENT_BUFFER
Input buffer is insufficient to hold the contents.
Definition nvapi_lite_common.h:350
NvAPI_DISP_GetEdidData
NVAPI_INTERFACE NvAPI_DISP_GetEdidData(__in NvU32 displayId, __inout NV_EDID_DATA *pEdidParams, __inout NV_EDID_FLAG *pFlag)

◆ NV_EDID_DATA_VER1

#define NV_EDID_DATA_VER1 MAKE_NVAPI_VERSION(NV_EDID_DATA_V1, 1)
DESCRIPTION: This API returns the EDID data for the specified display Id.
(NvAPI_GPU_GetConnectedDisplayIds() can be used to get the DisplayIds).
USAGE: The caller has to call this API two times to fetch the required details as follows:
First Pass : Caller should call NvAPI_DISP_GetEdidData() with pEdidParams->pEDID set to NULL,
to get the size of the EDID buffer in pEdidParams->sizeOfEDID.
Second Pass: Allocate memory for the EDID buffer of the size - pEdidParams->sizeOfEDID,
and call the API again to get the EDID buffer populated.
\param [in] displayId - NVIDIA Display ID
\param [inout] pEdidParams - Pointer to the structure that contains - pointer to EDID buffer and its size
\param [inout] pFlag - The type of EDID to be retrieved (IN).
To only retrieve the EDID type, the user should send pEdidParams->pEDID as NULL and
pEdidParams->sizeOfEDID as 0.
SUPPORTED OS: Windows 7 and higher
\since Release: 400
\return This API can return any of the error codes enumerated in #NvAPI_Status.
If there are return error codes with specific meaning for this API, they are listed below.
NVAPI_INSUFFICIENT_BUFFER: Reallocate buffer with pEdidParams->sizeOfEDID and call again to get complete data.
In this case pEdidParams->pEDID contains undefined data.
This error occurs only when pEdidParams->pEDID is present.

◆ NV_EDID_DATA_VER2

#define NV_EDID_DATA_VER2 MAKE_NVAPI_VERSION(NV_EDID_DATA_V2, 2)
DESCRIPTION: This API returns the EDID data for the specified display Id.
(NvAPI_GPU_GetConnectedDisplayIds() can be used to get the DisplayIds).
USAGE: The caller has to call this API two times to fetch the required details as follows:
First Pass : Caller should call NvAPI_DISP_GetEdidData() with pEdidParams->pEDID set to NULL,
to get the size of the EDID buffer in pEdidParams->sizeOfEDID.
Second Pass: Allocate memory for the EDID buffer of the size - pEdidParams->sizeOfEDID,
and call the API again to get the EDID buffer populated.
\param [in] displayId - NVIDIA Display ID
\param [inout] pEdidParams - Pointer to the structure that contains - pointer to EDID buffer and its size
\param [inout] pFlag - The type of EDID to be retrieved (IN).
To only retrieve the EDID type, the user should send pEdidParams->pEDID as NULL and
pEdidParams->sizeOfEDID as 0.
SUPPORTED OS: Windows 7 and higher
\since Release: 400
\return This API can return any of the error codes enumerated in #NvAPI_Status.
If there are return error codes with specific meaning for this API, they are listed below.
NVAPI_INSUFFICIENT_BUFFER: Reallocate buffer with pEdidParams->sizeOfEDID and call again to get complete data.
In this case pEdidParams->pEDID contains undefined data.
This error occurs only when pEdidParams->pEDID is present.

◆ NV_EVENT_REGISTER_CALLBACK_VERSION

#define NV_EVENT_REGISTER_CALLBACK_VERSION MAKE_NVAPI_VERSION(NV_EVENT_REGISTER_CALLBACK,1)

Macro for constructing the version field of NV_EVENT_REGISTER_CALLBACK.

◆ NV_GET_ADAPTIVE_SYNC_DATA_VER

#define NV_GET_ADAPTIVE_SYNC_DATA_VER NV_GET_ADAPTIVE_SYNC_DATA_VER1

◆ NV_GET_ADAPTIVE_SYNC_DATA_VER1

#define NV_GET_ADAPTIVE_SYNC_DATA_VER1 MAKE_NVAPI_VERSION(NV_GET_ADAPTIVE_SYNC_DATA_V1,1)

◆ NV_GET_VIRTUAL_REFRESH_RATE_DATA_VER

#define NV_GET_VIRTUAL_REFRESH_RATE_DATA_VER NV_GET_VIRTUAL_REFRESH_RATE_DATA_VER1

◆ NV_GET_VIRTUAL_REFRESH_RATE_DATA_VER1

#define NV_GET_VIRTUAL_REFRESH_RATE_DATA_VER1 MAKE_NVAPI_VERSION(_NV_GET_VIRTUAL_REFRESH_RATE_DATA_V1,1)

◆ NV_GET_VRR_INFO_VER

#define NV_GET_VRR_INFO_VER NV_GET_VRR_INFO_VER1

◆ NV_GET_VRR_INFO_VER1

#define NV_GET_VRR_INFO_VER1 MAKE_NVAPI_VERSION(NV_GET_VRR_INFO_V1,1)

◆ NV_GPU_CLIENT_ILLUM_CTRL_MODE_PIECEWISE_LINEAR_COLOR_ENDPOINTS

#define NV_GPU_CLIENT_ILLUM_CTRL_MODE_PIECEWISE_LINEAR_COLOR_ENDPOINTS 2

Number of color points for the piecewise linear control mode.

◆ NV_GPU_CLIENT_ILLUM_DEVICE_CONTROL_PARAMS_VER

#define NV_GPU_CLIENT_ILLUM_DEVICE_CONTROL_PARAMS_VER NV_GPU_CLIENT_ILLUM_DEVICE_CONTROL_PARAMS_VER_1

◆ NV_GPU_CLIENT_ILLUM_DEVICE_CONTROL_PARAMS_VER_1

#define NV_GPU_CLIENT_ILLUM_DEVICE_CONTROL_PARAMS_VER_1 MAKE_NVAPI_VERSION(NV_GPU_CLIENT_ILLUM_DEVICE_CONTROL_PARAMS_V1, 1)

◆ NV_GPU_CLIENT_ILLUM_DEVICE_INFO_PARAMS_VER

#define NV_GPU_CLIENT_ILLUM_DEVICE_INFO_PARAMS_VER NV_GPU_CLIENT_ILLUM_DEVICE_INFO_PARAMS_VER_1

◆ NV_GPU_CLIENT_ILLUM_DEVICE_INFO_PARAMS_VER_1

#define NV_GPU_CLIENT_ILLUM_DEVICE_INFO_PARAMS_VER_1 MAKE_NVAPI_VERSION(NV_GPU_CLIENT_ILLUM_DEVICE_INFO_PARAMS_V1, 1)

◆ NV_GPU_CLIENT_ILLUM_DEVICE_NUM_DEVICES_MAX

#define NV_GPU_CLIENT_ILLUM_DEVICE_NUM_DEVICES_MAX 32

◆ NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_PARAMS_VER

#define NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_PARAMS_VER NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_PARAMS_VER_1

◆ NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_PARAMS_VER_1

#define NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_PARAMS_VER_1 MAKE_NVAPI_VERSION(NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_PARAMS_V1, 1)

◆ NV_GPU_CLIENT_ILLUM_ZONE_INFO_PARAMS_VER

#define NV_GPU_CLIENT_ILLUM_ZONE_INFO_PARAMS_VER NV_GPU_CLIENT_ILLUM_ZONE_INFO_PARAMS_VER_1

◆ NV_GPU_CLIENT_ILLUM_ZONE_INFO_PARAMS_VER_1

#define NV_GPU_CLIENT_ILLUM_ZONE_INFO_PARAMS_VER_1 MAKE_NVAPI_VERSION(NV_GPU_CLIENT_ILLUM_ZONE_INFO_PARAMS_V1, 1)

◆ NV_GPU_CLIENT_ILLUM_ZONE_NUM_ZONES_MAX

#define NV_GPU_CLIENT_ILLUM_ZONE_NUM_ZONES_MAX 32

◆ NV_GPU_GSP_INFO_VER

#define NV_GPU_GSP_INFO_VER NV_GPU_GSP_INFO_VER1

◆ NV_GPU_INFO_VER

#define NV_GPU_INFO_VER NV_GPU_INFO_VER2

◆ NV_GPU_INFO_VER1

#define NV_GPU_INFO_VER1 MAKE_NVAPI_VERSION(NV_GPU_INFO_V1, 1)

◆ NV_GPU_INFO_VER2

#define NV_GPU_INFO_VER2 MAKE_NVAPI_VERSION(NV_GPU_INFO_V2, 2)

◆ NV_GPU_MAX_CLOCK_FREQUENCIES

#define NV_GPU_MAX_CLOCK_FREQUENCIES 3

◆ NV_GPU_PERF_PSTATES_INFO_VER

#define NV_GPU_PERF_PSTATES_INFO_VER NV_GPU_PERF_PSTATES_INFO_VER3

Macro for constructing the version field of NV_GPU_PERF_PSTATES_INFO.

◆ NV_GPU_PERF_PSTATES_INFO_VER2

#define NV_GPU_PERF_PSTATES_INFO_VER2 MAKE_NVAPI_VERSION(NV_GPU_PERF_PSTATES_INFO_V2,2)

Macro for constructing the version field of NV_GPU_PERF_PSTATES_INFO_V2.

◆ NV_GPU_PERF_PSTATES_INFO_VER3

#define NV_GPU_PERF_PSTATES_INFO_VER3 MAKE_NVAPI_VERSION(NV_GPU_PERF_PSTATES_INFO_V2,3)

Macro for constructing the version field of NV_GPU_PERF_PSTATES_INFO_V2.

◆ NV_GPU_THERMAL_SETTINGS_VER

#define NV_GPU_THERMAL_SETTINGS_VER NV_GPU_THERMAL_SETTINGS_VER_2

Macro for constructing the version field of NV_GPU_THERMAL_SETTINGS.

◆ NV_GPU_THERMAL_SETTINGS_VER_2

#define NV_GPU_THERMAL_SETTINGS_VER_2 MAKE_NVAPI_VERSION(NV_GPU_THERMAL_SETTINGS_V2,2)

Macro for constructing the version field of NV_GPU_THERMAL_SETTINGS_V2.

◆ NV_GPU_VR_READY_VER

#define NV_GPU_VR_READY_VER NV_GPU_VR_READY_VER1

◆ NV_GPU_VR_READY_VER1

#define NV_GPU_VR_READY_VER1 MAKE_NVAPI_VERSION(NV_GPU_VR_READY_V1, 1)

◆ NV_GSYNC_CAPABILITIES_VER

#define NV_GSYNC_CAPABILITIES_VER NV_GSYNC_CAPABILITIES_VER3

◆ NV_GSYNC_CAPABILITIES_VER2

#define NV_GSYNC_CAPABILITIES_VER2 MAKE_NVAPI_VERSION(NV_GSYNC_CAPABILITIES_V2,2)

◆ NV_GSYNC_CAPABILITIES_VER3

#define NV_GSYNC_CAPABILITIES_VER3 MAKE_NVAPI_VERSION(NV_GSYNC_CAPABILITIES_V3,3)

◆ NV_GSYNC_CONTROL_PARAMS_VER

#define NV_GSYNC_CONTROL_PARAMS_VER NV_GSYNC_CONTROL_PARAMS_VER2

◆ NV_GSYNC_CONTROL_PARAMS_VER1

#define NV_GSYNC_CONTROL_PARAMS_VER1 MAKE_NVAPI_VERSION(NV_GSYNC_CONTROL_PARAMS_V1,1)

◆ NV_GSYNC_CONTROL_PARAMS_VER2

#define NV_GSYNC_CONTROL_PARAMS_VER2 MAKE_NVAPI_VERSION(NV_GSYNC_CONTROL_PARAMS_V2,2)

◆ NV_GSYNC_DELAY_VER

#define NV_GSYNC_DELAY_VER MAKE_NVAPI_VERSION(NV_GSYNC_DELAY,1)

◆ NV_GSYNC_DISPLAY_VER

#define NV_GSYNC_DISPLAY_VER MAKE_NVAPI_VERSION(NV_GSYNC_DISPLAY,1)

◆ NV_GSYNC_GPU_VER

#define NV_GSYNC_GPU_VER MAKE_NVAPI_VERSION(NV_GSYNC_GPU,1)

◆ NV_GSYNC_STATUS_PARAMS_VER

#define NV_GSYNC_STATUS_PARAMS_VER NV_GSYNC_STATUS_PARAMS_VER2

◆ NV_GSYNC_STATUS_PARAMS_VER2

#define NV_GSYNC_STATUS_PARAMS_VER2 MAKE_NVAPI_VERSION(NV_GSYNC_STATUS_PARAMS_V2,2)

◆ NV_GSYNC_STATUS_VER

#define NV_GSYNC_STATUS_VER MAKE_NVAPI_VERSION(NV_GSYNC_STATUS,1)

Macro for constructing the version field for NV_GSYNC_STATUS.

◆ NV_HDMI_SUPPORT_INFO_VER

#define NV_HDMI_SUPPORT_INFO_VER NV_HDMI_SUPPORT_INFO_VER2

◆ NV_HDMI_SUPPORT_INFO_VER1

#define NV_HDMI_SUPPORT_INFO_VER1 MAKE_NVAPI_VERSION(NV_HDMI_SUPPORT_INFO_V1, 1)

◆ NV_HDMI_SUPPORT_INFO_VER2

#define NV_HDMI_SUPPORT_INFO_VER2 MAKE_NVAPI_VERSION(NV_HDMI_SUPPORT_INFO_V2, 2)

◆ NV_HDR_CAPABILITIES_VER

#define NV_HDR_CAPABILITIES_VER NV_HDR_CAPABILITIES_VER3

◆ NV_HDR_CAPABILITIES_VER1

#define NV_HDR_CAPABILITIES_VER1 MAKE_NVAPI_VERSION(NV_HDR_CAPABILITIES_V1, 1)

◆ NV_HDR_CAPABILITIES_VER2

#define NV_HDR_CAPABILITIES_VER2 MAKE_NVAPI_VERSION(NV_HDR_CAPABILITIES_V2, 2)

◆ NV_HDR_CAPABILITIES_VER3

#define NV_HDR_CAPABILITIES_VER3 MAKE_NVAPI_VERSION(NV_HDR_CAPABILITIES_V3, 3)

◆ NV_HDR_COLOR_DATA_VER

#define NV_HDR_COLOR_DATA_VER NV_HDR_COLOR_DATA_VER2

◆ NV_HDR_COLOR_DATA_VER1

#define NV_HDR_COLOR_DATA_VER1 MAKE_NVAPI_VERSION(NV_HDR_COLOR_DATA_V1, 1)

◆ NV_HDR_COLOR_DATA_VER2

#define NV_HDR_COLOR_DATA_VER2 MAKE_NVAPI_VERSION(NV_HDR_COLOR_DATA_V2, 2)

◆ NV_HDR_METADATA_VER

#define NV_HDR_METADATA_VER NV_HDR_METADATA_VER1

DESCRIPTION: This API sets HDR metadata of the source identified by the process id of the caller

SUPPORTED OS: Windows 7 and higher

Since
Release: 525
Parameters
[in] | displayId | Monitor Identifier
[in] | pMetadata | HDR metadata
Returns
This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.

◆ NV_HDR_METADATA_VER1

#define NV_HDR_METADATA_VER1 MAKE_NVAPI_VERSION(NV_HDR_METADATA_V1, 1)

DESCRIPTION: This API sets HDR metadata of the source identified by the process id of the caller

SUPPORTED OS: Windows 7 and higher

Since
Release: 525
Parameters
[in] | displayId | Monitor Identifier
[in] | pMetadata | HDR metadata
Returns
This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.

◆ NV_INFOFRAME_DATA_VER

#define NV_INFOFRAME_DATA_VER MAKE_NVAPI_VERSION(NV_INFOFRAME_DATA,1)

Macro for constructing the version field of NV_INFOFRAME_DATA.

◆ NV_LICENSABLE_FEATURES_VER

#define NV_LICENSABLE_FEATURES_VER NV_LICENSABLE_FEATURES_VER4

Maximum number of supported Feature License.

◆ NV_LICENSABLE_FEATURES_VER1

#define NV_LICENSABLE_FEATURES_VER1 MAKE_NVAPI_VERSION(NV_LICENSABLE_FEATURES_V1, 1)

Maximum number of supported Feature License.

◆ NV_LICENSABLE_FEATURES_VER2

#define NV_LICENSABLE_FEATURES_VER2 MAKE_NVAPI_VERSION(NV_LICENSABLE_FEATURES_V2, 2)

Maximum number of supported Feature License.

◆ NV_LICENSABLE_FEATURES_VER3

#define NV_LICENSABLE_FEATURES_VER3 MAKE_NVAPI_VERSION(NV_LICENSABLE_FEATURES_V3, 3)

Maximum number of supported Feature License.

◆ NV_LICENSABLE_FEATURES_VER4

#define NV_LICENSABLE_FEATURES_VER4 MAKE_NVAPI_VERSION(NV_LICENSABLE_FEATURES_V4, 4)

Maximum number of supported Feature License.

◆ NV_LICENSE_FEATURE_DETAILS_VER

#define NV_LICENSE_FEATURE_DETAILS_VER NV_LICENSE_FEATURE_DETAILS_VER1

Maximum number of supported Feature License.

◆ NV_LICENSE_FEATURE_DETAILS_VER1

#define NV_LICENSE_FEATURE_DETAILS_VER1 MAKE_NVAPI_VERSION(NV_LICENSE_FEATURE_DETAILS_V1, 1)

Maximum number of supported Feature License.

◆ NV_LICENSE_INFO_MAX_LENGTH

#define NV_LICENSE_INFO_MAX_LENGTH (128)

Length for Grid License.

◆ NV_LICENSE_SIGNATURE_SIZE

#define NV_LICENSE_SIGNATURE_SIZE (128)

Signature length for GRID License.

◆ NV_LOGICAL_GPU_DATA_VER

#define NV_LOGICAL_GPU_DATA_VER NV_LOGICAL_GPU_DATA_VER1

◆ NV_LOGICAL_GPU_DATA_VER1

#define NV_LOGICAL_GPU_DATA_VER1 MAKE_NVAPI_VERSION(NV_LOGICAL_GPU_DATA_V1,1)

◆ NV_MANAGED_DEDICATED_DISPLAY_INFO_VER

#define NV_MANAGED_DEDICATED_DISPLAY_INFO_VER NV_MANAGED_DEDICATED_DISPLAY_INFO_VER1

◆ NV_MANAGED_DEDICATED_DISPLAY_INFO_VER1

#define NV_MANAGED_DEDICATED_DISPLAY_INFO_VER1 MAKE_NVAPI_VERSION(NV_MANAGED_DEDICATED_DISPLAY_INFO_V1,1)

◆ NV_MANAGED_DEDICATED_DISPLAY_METADATA_VER

#define NV_MANAGED_DEDICATED_DISPLAY_METADATA_VER NV_MANAGED_DEDICATED_DISPLAY_METADATA_VER1

◆ NV_MANAGED_DEDICATED_DISPLAY_METADATA_VER1

#define NV_MANAGED_DEDICATED_DISPLAY_METADATA_VER1 MAKE_NVAPI_VERSION(NV_MANAGED_DEDICATED_DISPLAY_METADATA_V1,1)

◆ NV_MONITOR_CAPABILITIES_VER

#define NV_MONITOR_CAPABILITIES_VER NV_MONITOR_CAPABILITIES_VER1

Macro for constructing the version field of NV_MONITOR_CAPABILITIES_V1.

◆ NV_MONITOR_CAPABILITIES_VER1

#define NV_MONITOR_CAPABILITIES_VER1 MAKE_NVAPI_VERSION(NV_MONITOR_CAPABILITIES_V1,1)

Macro for constructing the version field of NV_MONITOR_CAPABILITIES_V1.

◆ NV_MONITOR_COLOR_CAPS_VER

#define NV_MONITOR_COLOR_CAPS_VER NV_MONITOR_COLOR_CAPS_VER1

◆ NV_MOSAIC_DISPLAYCAPS_PROBLEM_DISPLAY_ON_INVALID_GPU

#define NV_MOSAIC_DISPLAYCAPS_PROBLEM_DISPLAY_ON_INVALID_GPU NV_BIT(0)

since Release R290

◆ NV_MOSAIC_DISPLAYCAPS_PROBLEM_DISPLAY_ON_WRONG_CONNECTOR

#define NV_MOSAIC_DISPLAYCAPS_PROBLEM_DISPLAY_ON_WRONG_CONNECTOR NV_BIT(1)

◆ NV_MOSAIC_DISPLAYCAPS_PROBLEM_ECC_ENABLED

#define NV_MOSAIC_DISPLAYCAPS_PROBLEM_ECC_ENABLED NV_BIT(9)

◆ NV_MOSAIC_DISPLAYCAPS_PROBLEM_GPU_TOPOLOGY_NOT_SUPPORTED

#define NV_MOSAIC_DISPLAYCAPS_PROBLEM_GPU_TOPOLOGY_NOT_SUPPORTED NV_BIT(10)

◆ NV_MOSAIC_DISPLAYCAPS_PROBLEM_MISMATCHED_OUTPUT_TYPE

#define NV_MOSAIC_DISPLAYCAPS_PROBLEM_MISMATCHED_OUTPUT_TYPE NV_BIT(4)

◆ NV_MOSAIC_DISPLAYCAPS_PROBLEM_NO_COMMON_TIMINGS

#define NV_MOSAIC_DISPLAYCAPS_PROBLEM_NO_COMMON_TIMINGS NV_BIT(2)

◆ NV_MOSAIC_DISPLAYCAPS_PROBLEM_NO_DISPLAY_CONNECTED

#define NV_MOSAIC_DISPLAYCAPS_PROBLEM_NO_DISPLAY_CONNECTED NV_BIT(5)

◆ NV_MOSAIC_DISPLAYCAPS_PROBLEM_NO_EDID_AVAILABLE

#define NV_MOSAIC_DISPLAYCAPS_PROBLEM_NO_EDID_AVAILABLE NV_BIT(3)

◆ NV_MOSAIC_DISPLAYCAPS_PROBLEM_NO_GPU_TOPOLOGY

#define NV_MOSAIC_DISPLAYCAPS_PROBLEM_NO_GPU_TOPOLOGY NV_BIT(6)

◆ NV_MOSAIC_DISPLAYCAPS_PROBLEM_NO_SLI_BRIDGE

#define NV_MOSAIC_DISPLAYCAPS_PROBLEM_NO_SLI_BRIDGE NV_BIT(8)

◆ NV_MOSAIC_DISPLAYCAPS_PROBLEM_NOT_SUPPORTED

#define NV_MOSAIC_DISPLAYCAPS_PROBLEM_NOT_SUPPORTED NV_BIT(7)

◆ NV_MOSAIC_GRID_TOPO_VER

#define NV_MOSAIC_GRID_TOPO_VER NV_MOSAIC_GRID_TOPO_VER2

Macro for constructing the version field of NV_MOSAIC_GRID_TOPO.

◆ NV_MOSAIC_GRID_TOPO_VER1

#define NV_MOSAIC_GRID_TOPO_VER1 MAKE_NVAPI_VERSION(NV_MOSAIC_GRID_TOPO_V1,1)

Macro for constructing the version field of NV_MOSAIC_GRID_TOPO.

◆ NV_MOSAIC_GRID_TOPO_VER2

#define NV_MOSAIC_GRID_TOPO_VER2 MAKE_NVAPI_VERSION(NV_MOSAIC_GRID_TOPO_V2,2)

Macro for constructing the version field of NV_MOSAIC_GRID_TOPO.

◆ NV_MOSAIC_SETDISPLAYTOPO_FLAG_ALLOW_INVALID

#define NV_MOSAIC_SETDISPLAYTOPO_FLAG_ALLOW_INVALID NV_BIT(3)

Do not return an error if no configuration will work with all of the grids.

◆ NV_MOSAIC_SETDISPLAYTOPO_FLAG_CURRENT_GPU_TOPOLOGY

#define NV_MOSAIC_SETDISPLAYTOPO_FLAG_CURRENT_GPU_TOPOLOGY NV_BIT(0)

Do not change the current GPU topology. If the NO_DRIVER_RELOAD bit is not specified, then it may still require a driver reload.

◆ NV_MOSAIC_SETDISPLAYTOPO_FLAG_MAXIMIZE_PERFORMANCE

#define NV_MOSAIC_SETDISPLAYTOPO_FLAG_MAXIMIZE_PERFORMANCE NV_BIT(2)

When choosing a GPU topology, choose the topology with the best performance. Without this flag, it will choose the topology that uses the smallest number of GPU's.

◆ NV_MOSAIC_SETDISPLAYTOPO_FLAG_NO_DRIVER_RELOAD

#define NV_MOSAIC_SETDISPLAYTOPO_FLAG_NO_DRIVER_RELOAD NV_BIT(1)

Do not allow a driver reload. That is, stick with the same master GPU as well as the same SLI configuration.

◆ NV_SCANOUT_INFORMATION_VER

#define NV_SCANOUT_INFORMATION_VER MAKE_NVAPI_VERSION(NV_SCANOUT_INFORMATION,1)

◆ NV_SCANOUT_INTENSITY_DATA_VER

#define NV_SCANOUT_INTENSITY_DATA_VER NV_SCANOUT_INTENSITY_DATA_VER2

◆ NV_SCANOUT_INTENSITY_DATA_VER2

#define NV_SCANOUT_INTENSITY_DATA_VER2 MAKE_NVAPI_VERSION(NV_SCANOUT_INTENSITY_DATA_V2, 2)

◆ NV_SET_ADAPTIVE_SYNC_DATA_VER

#define NV_SET_ADAPTIVE_SYNC_DATA_VER NV_SET_ADAPTIVE_SYNC_DATA_VER1

◆ NV_SET_ADAPTIVE_SYNC_DATA_VER1

#define NV_SET_ADAPTIVE_SYNC_DATA_VER1 MAKE_NVAPI_VERSION(NV_SET_ADAPTIVE_SYNC_DATA_V1,1)

◆ NV_SET_VIRTUAL_REFRESH_RATE_DATA_VER

#define NV_SET_VIRTUAL_REFRESH_RATE_DATA_VER NV_SET_VIRTUAL_REFRESH_RATE_DATA_VER1

◆ NV_SET_VIRTUAL_REFRESH_RATE_DATA_VER1

#define NV_SET_VIRTUAL_REFRESH_RATE_DATA_VER1 MAKE_NVAPI_VERSION(_NV_SET_VIRTUAL_REFRESH_RATE_DATA_V1,1)

◆ NV_SOURCE_PID_CURRENT

#define NV_SOURCE_PID_CURRENT 0

DESCRIPTION: This API sets HDR metadata of the source identified by the process id of the caller

SUPPORTED OS: Windows 7 and higher

Since
Release: 525
Parameters
[in] | displayId | Monitor Identifier
[in] | pMetadata | HDR metadata
Returns
This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.

◆ NV_TIMING_INPUT_VER

#define NV_TIMING_INPUT_VER MAKE_NVAPI_VERSION(NV_TIMING_INPUT,1)

◆ NVAPI_GSYNC_BOARD_ID_P2060

#define NVAPI_GSYNC_BOARD_ID_P2060 8288

GSync board ID 0x2060, see NV_GSYNC_CAPABILITIES.

◆ NVAPI_GSYNC_BOARD_ID_P2061

#define NVAPI_GSYNC_BOARD_ID_P2061 8289

GSync board ID 0x2061, see NV_GSYNC_CAPABILITIES.

Since
Release: 375

◆ NVAPI_GSYNC_BOARD_ID_P358

#define NVAPI_GSYNC_BOARD_ID_P358 856

GSync board ID 0x358, see NV_GSYNC_CAPABILITIES.

◆ NVAPI_MAX_GSYNC_DEVICES

#define NVAPI_MAX_GSYNC_DEVICES 4

◆ NVAPI_NVLINK_CAPS_NCI_VERSION_1_0

#define NVAPI_NVLINK_CAPS_NCI_VERSION_1_0 (0x00000001)

Set if NVLink is present and supported on this GPU.This field is used for global caps only and NOT for per-link caps.

Used in NvAPI_GPU_NVLINK_GetCaps()

◆ NVAPI_NVLINK_CAPS_NCI_VERSION_2_0

#define NVAPI_NVLINK_CAPS_NCI_VERSION_2_0 (0x00000002)

Set if NVLink is present and supported on this GPU.This field is used for global caps only and NOT for per-link caps.

Used in NvAPI_GPU_NVLINK_GetCaps()

◆ NVAPI_NVLINK_CAPS_NCI_VERSION_INVALID

#define NVAPI_NVLINK_CAPS_NCI_VERSION_INVALID (0x00000000)

Set if NVLink is present and supported on this GPU.This field is used for global caps only and NOT for per-link caps.

Used in NvAPI_GPU_NVLINK_GetCaps()

◆ NVAPI_NVLINK_CAPS_NVLINK_VERSION_1_0

#define NVAPI_NVLINK_CAPS_NVLINK_VERSION_1_0 (0x00000001)

Set if NVLink is present and supported on this GPU.This field is used for global caps only and NOT for per-link caps.

Used in NvAPI_GPU_NVLINK_GetCaps()

◆ NVAPI_NVLINK_CAPS_NVLINK_VERSION_2_0

#define NVAPI_NVLINK_CAPS_NVLINK_VERSION_2_0 (0x00000002)

Set if NVLink is present and supported on this GPU.This field is used for global caps only and NOT for per-link caps.

Used in NvAPI_GPU_NVLINK_GetCaps()

◆ NVAPI_NVLINK_CAPS_NVLINK_VERSION_INVALID

#define NVAPI_NVLINK_CAPS_NVLINK_VERSION_INVALID (0x00000000)

Set if NVLink is present and supported on this GPU.This field is used for global caps only and NOT for per-link caps.

Used in NvAPI_GPU_NVLINK_GetCaps()

◆ NVAPI_NVLINK_CAPS_P2P_ATOMICS

#define NVAPI_NVLINK_CAPS_P2P_ATOMICS 0x00000008

Set if P2P atomics are supported over NVLink on this GPU.

◆ NVAPI_NVLINK_CAPS_P2P_SUPPORTED

#define NVAPI_NVLINK_CAPS_P2P_SUPPORTED 0x00000002

Set if P2P over NVLink is supported on this GPU.

◆ NVAPI_NVLINK_CAPS_PEX_TUNNELING

#define NVAPI_NVLINK_CAPS_PEX_TUNNELING 0x00000020

Set if PEX tunneling over NVLink is supported on this GPU.

◆ NVAPI_NVLINK_CAPS_POWER_STATE_L0

#define NVAPI_NVLINK_CAPS_POWER_STATE_L0 0x00000100

This bit is set if L0 is a supported power state on this GPU.

◆ NVAPI_NVLINK_CAPS_POWER_STATE_L1

#define NVAPI_NVLINK_CAPS_POWER_STATE_L1 0x00000200

This bit is set if L1 is a supported power state on this GPU.

◆ NVAPI_NVLINK_CAPS_POWER_STATE_L2

#define NVAPI_NVLINK_CAPS_POWER_STATE_L2 0x00000400

This bit is set if L2 is a supported power state on this GPU.

◆ NVAPI_NVLINK_CAPS_POWER_STATE_L3

#define NVAPI_NVLINK_CAPS_POWER_STATE_L3 0x00000800

This bit is set if L3 is a supported power state on this GPU.

◆ NVAPI_NVLINK_CAPS_SLI_BRIDGE

#define NVAPI_NVLINK_CAPS_SLI_BRIDGE 0x00000040

Set if SLI over NVLink is supported on this GPU.

◆ NVAPI_NVLINK_CAPS_SLI_BRIDGE_SENSABLE

#define NVAPI_NVLINK_CAPS_SLI_BRIDGE_SENSABLE 0x00000080

This bit is set if capable of sensing SLI bridges.

◆ NVAPI_NVLINK_CAPS_SUPPORTED

#define NVAPI_NVLINK_CAPS_SUPPORTED 0x00000001

Set if NVLink is present and supported on this GPU.This field is used for global caps only and NOT for per-link caps.

Used in NvAPI_GPU_NVLINK_GetCaps()

◆ NVAPI_NVLINK_CAPS_SYSMEM_ACCESS

#define NVAPI_NVLINK_CAPS_SYSMEM_ACCESS 0x00000004

Set if sysmem can be accessed over NVLink on this GPU.

◆ NVAPI_NVLINK_CAPS_SYSMEM_ATOMICS

#define NVAPI_NVLINK_CAPS_SYSMEM_ATOMICS 0x00000010

Set if sysmem atomic transcations are supported over NVLink on this GPU.

◆ NVAPI_NVLINK_CAPS_VALID

#define NVAPI_NVLINK_CAPS_VALID 0x00001000

Set if this link is supported on this GPU.This field is used for per-link caps only and NOT for global caps.

◆ NVAPI_NVLINK_COUNTER_MAX_TYPES

#define NVAPI_NVLINK_COUNTER_MAX_TYPES 32

◆ NVAPI_NVLINK_DEVICE_INFO_DEVICE_ID_FLAGS_NONE

#define NVAPI_NVLINK_DEVICE_INFO_DEVICE_ID_FLAGS_NONE (0x00000000)

Used in NvAPI_GPU_NVLINK_GetStatus()

◆ NVAPI_NVLINK_DEVICE_INFO_DEVICE_ID_FLAGS_PCI

#define NVAPI_NVLINK_DEVICE_INFO_DEVICE_ID_FLAGS_PCI (0x00000001)

Used in NvAPI_GPU_NVLINK_GetStatus()

◆ NVAPI_NVLINK_DEVICE_INFO_DEVICE_ID_FLAGS_UUID

#define NVAPI_NVLINK_DEVICE_INFO_DEVICE_ID_FLAGS_UUID (0x00000002)

Used in NvAPI_GPU_NVLINK_GetStatus()

◆ NVAPI_NVLINK_MAX_LINKS

#define NVAPI_NVLINK_MAX_LINKS 32

◆ NVAPI_NVLINK_REFCLK_TYPE_INVALID

#define NVAPI_NVLINK_REFCLK_TYPE_INVALID (0x00)

Used in NvAPI_GPU_NVLINK_GetStatus()

◆ NVAPI_NVLINK_REFCLK_TYPE_NVHS

#define NVAPI_NVLINK_REFCLK_TYPE_NVHS (0x01)

Used in NvAPI_GPU_NVLINK_GetStatus()

◆ NVAPI_NVLINK_REFCLK_TYPE_PEX

#define NVAPI_NVLINK_REFCLK_TYPE_PEX (0x02)

Used in NvAPI_GPU_NVLINK_GetStatus()

◆ NVAPI_NVLINK_STATUS_CONNECTED_FALSE

#define NVAPI_NVLINK_STATUS_CONNECTED_FALSE (0x00000000)

Used in NvAPI_GPU_NVLINK_GetStatus()

◆ NVAPI_NVLINK_STATUS_CONNECTED_TRUE

#define NVAPI_NVLINK_STATUS_CONNECTED_TRUE (0x00000001)

Used in NvAPI_GPU_NVLINK_GetStatus()

◆ NVAPI_NVLINK_STATUS_GRS_VERSION_1_0

#define NVAPI_NVLINK_STATUS_GRS_VERSION_1_0 (0x00000001)

Used in NvAPI_GPU_NVLINK_GetStatus()

◆ NVAPI_NVLINK_STATUS_GRS_VERSION_INVALID

#define NVAPI_NVLINK_STATUS_GRS_VERSION_INVALID (0x000000FF)

Used in NvAPI_GPU_NVLINK_GetStatus()

◆ NVAPI_NVLINK_STATUS_LOOP_PROPERTY_LOOPBACK

#define NVAPI_NVLINK_STATUS_LOOP_PROPERTY_LOOPBACK (0x00000001)

Used in NvAPI_GPU_NVLINK_GetStatus()

◆ NVAPI_NVLINK_STATUS_LOOP_PROPERTY_LOOPOUT

#define NVAPI_NVLINK_STATUS_LOOP_PROPERTY_LOOPOUT (0x00000002)

Used in NvAPI_GPU_NVLINK_GetStatus()

◆ NVAPI_NVLINK_STATUS_LOOP_PROPERTY_NONE

#define NVAPI_NVLINK_STATUS_LOOP_PROPERTY_NONE (0x00000000)

Used in NvAPI_GPU_NVLINK_GetStatus()

◆ NVAPI_NVLINK_STATUS_NCI_VERSION_1_0

#define NVAPI_NVLINK_STATUS_NCI_VERSION_1_0 (0x00000001)

Used in NvAPI_GPU_NVLINK_GetStatus()

◆ NVAPI_NVLINK_STATUS_NCI_VERSION_2_0

#define NVAPI_NVLINK_STATUS_NCI_VERSION_2_0 (0x00000002)

Used in NvAPI_GPU_NVLINK_GetStatus()

◆ NVAPI_NVLINK_STATUS_NCI_VERSION_INVALID

#define NVAPI_NVLINK_STATUS_NCI_VERSION_INVALID (0x000000FF)

Used in NvAPI_GPU_NVLINK_GetStatus()

◆ NVAPI_NVLINK_STATUS_NVHS_VERSION_1_0

#define NVAPI_NVLINK_STATUS_NVHS_VERSION_1_0 (0x00000001)

Used in NvAPI_GPU_NVLINK_GetStatus()

◆ NVAPI_NVLINK_STATUS_NVHS_VERSION_INVALID

#define NVAPI_NVLINK_STATUS_NVHS_VERSION_INVALID (0x000000FF)

Used in NvAPI_GPU_NVLINK_GetStatus()

◆ NVAPI_NVLINK_STATUS_NVLINK_VERSION_1_0

#define NVAPI_NVLINK_STATUS_NVLINK_VERSION_1_0 (0x00000001)

Used in NvAPI_GPU_NVLINK_GetStatus()

◆ NVAPI_NVLINK_STATUS_NVLINK_VERSION_2_0

#define NVAPI_NVLINK_STATUS_NVLINK_VERSION_2_0 (0x00000002)

Used in NvAPI_GPU_NVLINK_GetStatus()

◆ NVAPI_NVLINK_STATUS_NVLINK_VERSION_INVALID

#define NVAPI_NVLINK_STATUS_NVLINK_VERSION_INVALID (0x000000FF)

Used in NvAPI_GPU_NVLINK_GetStatus()

◆ NVAPI_NVLINK_STATUS_PHY_GRS

#define NVAPI_NVLINK_STATUS_PHY_GRS (0x00000002)

Used in NvAPI_GPU_NVLINK_GetStatus()

◆ NVAPI_NVLINK_STATUS_PHY_INVALID

#define NVAPI_NVLINK_STATUS_PHY_INVALID (0x000000FF)

Used in NvAPI_GPU_NVLINK_GetStatus()

◆ NVAPI_NVLINK_STATUS_PHY_NVHS

#define NVAPI_NVLINK_STATUS_PHY_NVHS (0x00000001)

Used in NvAPI_GPU_NVLINK_GetStatus()

◆ NVAPI_NVLINK_STATUS_REMOTE_LINK_NUMBER_INVALID

#define NVAPI_NVLINK_STATUS_REMOTE_LINK_NUMBER_INVALID (0x000000FF)

Used in NvAPI_GPU_NVLINK_GetStatus()

◆ NVAPI_OGLEXPERT_DETAIL_ALL

#define NVAPI_OGLEXPERT_DETAIL_ALL 0xFFFFFFFF

◆ NVAPI_OGLEXPERT_DETAIL_BASIC_INFO

#define NVAPI_OGLEXPERT_DETAIL_BASIC_INFO 0x00000004

◆ NVAPI_OGLEXPERT_DETAIL_DETAILED_INFO

#define NVAPI_OGLEXPERT_DETAIL_DETAILED_INFO 0x00000008

◆ NVAPI_OGLEXPERT_DETAIL_ERROR

#define NVAPI_OGLEXPERT_DETAIL_ERROR 0x00000001

◆ NVAPI_OGLEXPERT_DETAIL_NONE

#define NVAPI_OGLEXPERT_DETAIL_NONE 0x00000000

◆ NVAPI_OGLEXPERT_DETAIL_PERFORMANCE_WARNING

#define NVAPI_OGLEXPERT_DETAIL_PERFORMANCE_WARNING 0x00000010

◆ NVAPI_OGLEXPERT_DETAIL_QUALITY_WARNING

#define NVAPI_OGLEXPERT_DETAIL_QUALITY_WARNING 0x00000020

◆ NVAPI_OGLEXPERT_DETAIL_SWFALLBACK

#define NVAPI_OGLEXPERT_DETAIL_SWFALLBACK 0x00000002

◆ NVAPI_OGLEXPERT_DETAIL_USAGE_WARNING

#define NVAPI_OGLEXPERT_DETAIL_USAGE_WARNING 0x00000040

◆ NVAPI_OGLEXPERT_OUTPUT_TO_ALL

#define NVAPI_OGLEXPERT_OUTPUT_TO_ALL 0xFFFFFFFF

◆ NVAPI_OGLEXPERT_OUTPUT_TO_CALLBACK

#define NVAPI_OGLEXPERT_OUTPUT_TO_CALLBACK 0x00000008

◆ NVAPI_OGLEXPERT_OUTPUT_TO_CONSOLE

#define NVAPI_OGLEXPERT_OUTPUT_TO_CONSOLE 0x00000001

◆ NVAPI_OGLEXPERT_OUTPUT_TO_DEBUGGER

#define NVAPI_OGLEXPERT_OUTPUT_TO_DEBUGGER 0x00000004

◆ NVAPI_OGLEXPERT_OUTPUT_TO_NONE

#define NVAPI_OGLEXPERT_OUTPUT_TO_NONE 0x00000000

◆ NVAPI_OGLEXPERT_REPORT_ALL

#define NVAPI_OGLEXPERT_REPORT_ALL 0xFFFFFFFF

◆ NVAPI_OGLEXPERT_REPORT_ERROR

#define NVAPI_OGLEXPERT_REPORT_ERROR 0x00000001

◆ NVAPI_OGLEXPERT_REPORT_FEATURE_SLI

#define NVAPI_OGLEXPERT_REPORT_FEATURE_SLI 0x00008000

◆ NVAPI_OGLEXPERT_REPORT_NONE

#define NVAPI_OGLEXPERT_REPORT_NONE 0x00000000

◆ NVAPI_OGLEXPERT_REPORT_OBJECT_BUFFEROBJECT

#define NVAPI_OGLEXPERT_REPORT_OBJECT_BUFFEROBJECT 0x00000800

◆ NVAPI_OGLEXPERT_REPORT_OBJECT_FBO

#define NVAPI_OGLEXPERT_REPORT_OBJECT_FBO 0x00004000

◆ NVAPI_OGLEXPERT_REPORT_OBJECT_PROGRAM

#define NVAPI_OGLEXPERT_REPORT_OBJECT_PROGRAM 0x00002000

◆ NVAPI_OGLEXPERT_REPORT_OBJECT_TEXTURE

#define NVAPI_OGLEXPERT_REPORT_OBJECT_TEXTURE 0x00001000

◆ NVAPI_OGLEXPERT_REPORT_PIPELINE_FRAGMENT

#define NVAPI_OGLEXPERT_REPORT_PIPELINE_FRAGMENT 0x00000040

◆ NVAPI_OGLEXPERT_REPORT_PIPELINE_FRAMEBUFFER

#define NVAPI_OGLEXPERT_REPORT_PIPELINE_FRAMEBUFFER 0x00000100

◆ NVAPI_OGLEXPERT_REPORT_PIPELINE_GEOMETRY

#define NVAPI_OGLEXPERT_REPORT_PIPELINE_GEOMETRY 0x00000008

◆ NVAPI_OGLEXPERT_REPORT_PIPELINE_PIXEL

#define NVAPI_OGLEXPERT_REPORT_PIPELINE_PIXEL 0x00000200

◆ NVAPI_OGLEXPERT_REPORT_PIPELINE_RASTER

#define NVAPI_OGLEXPERT_REPORT_PIPELINE_RASTER 0x00000020

◆ NVAPI_OGLEXPERT_REPORT_PIPELINE_ROP

#define NVAPI_OGLEXPERT_REPORT_PIPELINE_ROP 0x00000080

◆ NVAPI_OGLEXPERT_REPORT_PIPELINE_TEXTURE

#define NVAPI_OGLEXPERT_REPORT_PIPELINE_TEXTURE 0x00000400

◆ NVAPI_OGLEXPERT_REPORT_PIPELINE_VERTEX

#define NVAPI_OGLEXPERT_REPORT_PIPELINE_VERTEX 0x00000004

◆ NVAPI_OGLEXPERT_REPORT_PIPELINE_XFB

#define NVAPI_OGLEXPERT_REPORT_PIPELINE_XFB 0x00000010

◆ NVAPI_OGLEXPERT_REPORT_SWFALLBACK

#define NVAPI_OGLEXPERT_REPORT_SWFALLBACK 0x00000002

◆ NVLINK_GET_CAPS_VER

#define NVLINK_GET_CAPS_VER NVLINK_GET_CAPS_VER1

Set if NVLink is present and supported on this GPU.This field is used for global caps only and NOT for per-link caps.

Used in NvAPI_GPU_NVLINK_GetCaps()

◆ NVLINK_GET_CAPS_VER1

#define NVLINK_GET_CAPS_VER1 MAKE_NVAPI_VERSION(NVLINK_GET_CAPS_V1, 1)

Set if NVLink is present and supported on this GPU.This field is used for global caps only and NOT for per-link caps.

Used in NvAPI_GPU_NVLINK_GetCaps()

◆ NVLINK_GET_STATUS_VER

#define NVLINK_GET_STATUS_VER NVLINK_GET_STATUS_VER2

Used in NvAPI_GPU_NVLINK_GetStatus()

◆ NVLINK_GET_STATUS_VER1

#define NVLINK_GET_STATUS_VER1 MAKE_NVAPI_VERSION(NVLINK_GET_STATUS_V1, 1)

Used in NvAPI_GPU_NVLINK_GetStatus()

◆ NVLINK_GET_STATUS_VER2

#define NVLINK_GET_STATUS_VER2 MAKE_NVAPI_VERSION(NVLINK_GET_STATUS_V2, 2)

Used in NvAPI_GPU_NVLINK_GetStatus()

Typedef Documentation

◆ NV_ADAPTER_TYPE

typedef enum _NV_ADAPTER_TYPE NV_ADAPTER_TYPE

◆ NV_BPC

typedef enum _NV_BPC NV_BPC

See Table 14 of CEA-861E. Not all of this is supported by the GPU.

◆ NV_COLOR_DATA

typedef NV_COLOR_DATA_V5 NV_COLOR_DATA

See Table 14 of CEA-861E. Not all of this is supported by the GPU.

◆ NV_COLOR_DATA_V1

typedef struct _NV_COLOR_DATA_V1 NV_COLOR_DATA_V1

See Table 14 of CEA-861E. Not all of this is supported by the GPU.

◆ NV_COLOR_DATA_V2

typedef struct _NV_COLOR_DATA_V2 NV_COLOR_DATA_V2

See Table 14 of CEA-861E. Not all of this is supported by the GPU.

◆ NV_COLOR_DATA_V3

typedef struct _NV_COLOR_DATA_V3 NV_COLOR_DATA_V3

See Table 14 of CEA-861E. Not all of this is supported by the GPU.

◆ NV_COLOR_DATA_V4

typedef struct _NV_COLOR_DATA_V4 NV_COLOR_DATA_V4

See Table 14 of CEA-861E. Not all of this is supported by the GPU.

◆ NV_COLOR_DATA_V5

typedef struct _NV_COLOR_DATA_V5 NV_COLOR_DATA_V5

See Table 14 of CEA-861E. Not all of this is supported by the GPU.

◆ NV_COLOR_SELECTION_POLICY

typedef enum _NV_COLOR_SELECTION_POLICY NV_COLOR_SELECTION_POLICY

See Table 14 of CEA-861E. Not all of this is supported by the GPU.

◆ NV_COLORSPACE_TYPE

typedef enum _NV_COLORSPACE_TYPE NV_COLORSPACE_TYPE

DESCRIPTION: This API sets HDR metadata of the source identified by the process id of the caller

SUPPORTED OS: Windows 7 and higher

Since
Release: 525
Parameters
[in] | displayId | Monitor Identifier
[in] | pMetadata | HDR metadata
Returns
This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.

◆ NV_DESKTOP_COLOR_DEPTH

typedef enum _NV_DESKTOP_COLOR_DEPTH NV_DESKTOP_COLOR_DEPTH

See Table 14 of CEA-861E. Not all of this is supported by the GPU.

◆ NV_DISPLAY_OUTPUT_MODE

typedef enum _NV_DISPLAY_OUTPUT_MODE NV_DISPLAY_OUTPUT_MODE

DESCRIPTION: This API sets HDR metadata of the source identified by the process id of the caller

SUPPORTED OS: Windows 7 and higher

Since
Release: 525
Parameters
[in] | displayId | Monitor Identifier
[in] | pMetadata | HDR metadata
Returns
This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.

◆ NV_DISPLAY_PORT_INFO

typedef NV_DISPLAY_PORT_INFO_V1 NV_DISPLAY_PORT_INFO

◆ NV_DYNAMIC_RANGE

typedef enum _NV_DYNAMIC_RANGE NV_DYNAMIC_RANGE

See Table 14 of CEA-861E. Not all of this is supported by the GPU.

◆ NV_ECC_CONFIGURATION

typedef enum _NV_ECC_CONFIGURATION NV_ECC_CONFIGURATION

◆ NV_EDID_DATA

typedef NV_EDID_DATA_V2 NV_EDID_DATA
DESCRIPTION: This API returns the EDID data for the specified display Id.
(NvAPI_GPU_GetConnectedDisplayIds() can be used to get the DisplayIds).
USAGE: The caller has to call this API two times to fetch the required details as follows:
First Pass : Caller should call NvAPI_DISP_GetEdidData() with pEdidParams->pEDID set to NULL,
to get the size of the EDID buffer in pEdidParams->sizeOfEDID.
Second Pass: Allocate memory for the EDID buffer of the size - pEdidParams->sizeOfEDID,
and call the API again to get the EDID buffer populated.
\param [in] displayId - NVIDIA Display ID
\param [inout] pEdidParams - Pointer to the structure that contains - pointer to EDID buffer and its size
\param [inout] pFlag - The type of EDID to be retrieved (IN).
To only retrieve the EDID type, the user should send pEdidParams->pEDID as NULL and
pEdidParams->sizeOfEDID as 0.
SUPPORTED OS: Windows 7 and higher
\since Release: 400
\return This API can return any of the error codes enumerated in #NvAPI_Status.
If there are return error codes with specific meaning for this API, they are listed below.
NVAPI_INSUFFICIENT_BUFFER: Reallocate buffer with pEdidParams->sizeOfEDID and call again to get complete data.
In this case pEdidParams->pEDID contains undefined data.
This error occurs only when pEdidParams->pEDID is present.

◆ NV_EDID_DATA_V1

typedef struct _NV_EDID_DATA_V1 NV_EDID_DATA_V1
DESCRIPTION: This API returns the EDID data for the specified display Id.
(NvAPI_GPU_GetConnectedDisplayIds() can be used to get the DisplayIds).
USAGE: The caller has to call this API two times to fetch the required details as follows:
First Pass : Caller should call NvAPI_DISP_GetEdidData() with pEdidParams->pEDID set to NULL,
to get the size of the EDID buffer in pEdidParams->sizeOfEDID.
Second Pass: Allocate memory for the EDID buffer of the size - pEdidParams->sizeOfEDID,
and call the API again to get the EDID buffer populated.
\param [in] displayId - NVIDIA Display ID
\param [inout] pEdidParams - Pointer to the structure that contains - pointer to EDID buffer and its size
\param [inout] pFlag - The type of EDID to be retrieved (IN).
To only retrieve the EDID type, the user should send pEdidParams->pEDID as NULL and
pEdidParams->sizeOfEDID as 0.
SUPPORTED OS: Windows 7 and higher
\since Release: 400
\return This API can return any of the error codes enumerated in #NvAPI_Status.
If there are return error codes with specific meaning for this API, they are listed below.
NVAPI_INSUFFICIENT_BUFFER: Reallocate buffer with pEdidParams->sizeOfEDID and call again to get complete data.
In this case pEdidParams->pEDID contains undefined data.
This error occurs only when pEdidParams->pEDID is present.

◆ NV_EDID_DATA_V2

typedef struct _NV_EDID_DATA_V2 NV_EDID_DATA_V2
DESCRIPTION: This API returns the EDID data for the specified display Id.
(NvAPI_GPU_GetConnectedDisplayIds() can be used to get the DisplayIds).
USAGE: The caller has to call this API two times to fetch the required details as follows:
First Pass : Caller should call NvAPI_DISP_GetEdidData() with pEdidParams->pEDID set to NULL,
to get the size of the EDID buffer in pEdidParams->sizeOfEDID.
Second Pass: Allocate memory for the EDID buffer of the size - pEdidParams->sizeOfEDID,
and call the API again to get the EDID buffer populated.
\param [in] displayId - NVIDIA Display ID
\param [inout] pEdidParams - Pointer to the structure that contains - pointer to EDID buffer and its size
\param [inout] pFlag - The type of EDID to be retrieved (IN).
To only retrieve the EDID type, the user should send pEdidParams->pEDID as NULL and
pEdidParams->sizeOfEDID as 0.
SUPPORTED OS: Windows 7 and higher
\since Release: 400
\return This API can return any of the error codes enumerated in #NvAPI_Status.
If there are return error codes with specific meaning for this API, they are listed below.
NVAPI_INSUFFICIENT_BUFFER: Reallocate buffer with pEdidParams->sizeOfEDID and call again to get complete data.
In this case pEdidParams->pEDID contains undefined data.
This error occurs only when pEdidParams->pEDID is present.

◆ NV_GET_ADAPTIVE_SYNC_DATA

typedef NV_GET_ADAPTIVE_SYNC_DATA_V1 NV_GET_ADAPTIVE_SYNC_DATA

◆ NV_GET_ADAPTIVE_SYNC_DATA_V1

typedef struct _NV_GET_ADAPTIVE_SYNC_DATA_V1 NV_GET_ADAPTIVE_SYNC_DATA_V1

◆ NV_GET_VIRTUAL_REFRESH_RATE_DATA

typedef NV_GET_VIRTUAL_REFRESH_RATE_DATA_V1 NV_GET_VIRTUAL_REFRESH_RATE_DATA

◆ NV_GET_VIRTUAL_REFRESH_RATE_DATA_V1

typedef struct _NV_GET_VIRTUAL_REFRESH_RATE_DATA_V1 NV_GET_VIRTUAL_REFRESH_RATE_DATA_V1

◆ NV_GET_VRR_INFO

typedef NV_GET_VRR_INFO_V1 NV_GET_VRR_INFO

◆ NV_GPU_CLIENT_ILLUM_DEVICE_CONTROL

typedef NV_GPU_CLIENT_ILLUM_DEVICE_CONTROL_V1 NV_GPU_CLIENT_ILLUM_DEVICE_CONTROL

◆ NV_GPU_CLIENT_ILLUM_DEVICE_CONTROL_PARAMS

typedef NV_GPU_CLIENT_ILLUM_DEVICE_CONTROL_PARAMS_V1 NV_GPU_CLIENT_ILLUM_DEVICE_CONTROL_PARAMS

◆ NV_GPU_CLIENT_ILLUM_DEVICE_INFO_DATA_GPIO_PWM_RGBW

typedef struct _NV_GPU_CLIENT_ILLUM_DEVICE_INFO_DATA_GPIO_PWM_RGBW NV_GPU_CLIENT_ILLUM_DEVICE_INFO_DATA_GPIO_PWM_RGBW

Used in NV_GPU_CLIENT_ILLUM_DEVICE_INFO_V1 Describes the static information of illum device type GPIO_PWM_RGBW.

◆ NV_GPU_CLIENT_ILLUM_DEVICE_INFO_DATA_GPIO_PWM_SINGLE_COLOR

typedef struct _NV_GPU_CLIENT_ILLUM_DEVICE_INFO_DATA_GPIO_PWM_SINGLE_COLOR NV_GPU_CLIENT_ILLUM_DEVICE_INFO_DATA_GPIO_PWM_SINGLE_COLOR

Used in NV_GPU_CLIENT_ILLUM_DEVICE_INFO_V1 Describes the static information of illum device type GPIO_PWM_SINGLE_COLOR.

◆ NV_GPU_CLIENT_ILLUM_DEVICE_INFO_DATA_MCUV10

typedef struct _NV_GPU_CLIENT_ILLUM_DEVICE_INFO_DATA_MCUV10 NV_GPU_CLIENT_ILLUM_DEVICE_INFO_DATA_MCUV10

Used in NV_GPU_CLIENT_ILLUM_DEVICE_INFO_V1 Describes the static information of illumination device type MCUV10.

◆ NV_GPU_CLIENT_ILLUM_DEVICE_INFO_PARAMS

typedef NV_GPU_CLIENT_ILLUM_DEVICE_INFO_PARAMS_V1 NV_GPU_CLIENT_ILLUM_DEVICE_INFO_PARAMS

◆ NV_GPU_CLIENT_ILLUM_DEVICE_INFO_PARAMS_V1

typedef struct _NV_GPU_CLIENT_ILLUM_DEVICE_INFO_PARAMS_V1 NV_GPU_CLIENT_ILLUM_DEVICE_INFO_PARAMS_V1

◆ NV_GPU_CLIENT_ILLUM_DEVICE_INFO_V1

typedef struct _NV_GPU_CLIENT_ILLUM_DEVICE_INFO_V1 NV_GPU_CLIENT_ILLUM_DEVICE_INFO_V1

◆ NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_COLOR_FIXED

typedef struct _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_COLOR_FIXED NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_COLOR_FIXED

Used in NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_V1 Describes the control data for illum zone of type NV_GPU_CLIENT_ILLUM_ZONE_TYPE_COLOR_FIXED.

◆ NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_COLOR_FIXED

typedef struct _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_COLOR_FIXED NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_COLOR_FIXED

Used in NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_COLOR_FIXED Data required to represent control mode of type NV_GPU_CLIENT_ILLUM_CTRL_MODE_MANUAL_RGB.

◆ NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_COLOR_FIXED_PARAMS

typedef struct _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_COLOR_FIXED_PARAMS NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_COLOR_FIXED_PARAMS

Used in NV_GPU_ILLUM_ZONE_CONTROL_DATA_MANUAL_COLOR_FIXED Parameters required to represent control mode of type NV_GPU_ILLUM_CTRL_MODE_MANUAL_RGB.

◆ NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_RGB

typedef struct _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_RGB NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_RGB

Used in NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_RGB Data required to represent control mode of type NV_GPU_CLIENT_ILLUM_CTRL_MODE_MANUAL_RGB.

◆ NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_RGB_PARAMS

typedef struct _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_RGB_PARAMS NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_RGB_PARAMS

Used in NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_RGB Parameters required to represent control mode of type NV_GPU_CLIENT_ILLUM_CTRL_MODE_MANUAL_RGB.

◆ NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_RGBW

typedef struct _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_RGBW NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_RGBW

Used in NV_GPU_ILLUM_ZONE_CONTROL_DATA_RGBW Data required to represent control mode of type NV_GPU_ILLUM_CTRL_MODE_MANUAL_RGBW.

◆ NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_RGBW_PARAMS

typedef struct _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_RGBW_PARAMS NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_RGBW_PARAMS

Used in NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_RGBW Parameters required to represent control mode of type NV_GPU_CLIENT_ILLUM_CTRL_MODE_MANUAL_RGBW.

◆ NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_SINGLE_COLOR

typedef struct _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_SINGLE_COLOR NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_SINGLE_COLOR

Used in NV_GPU_ILLUM_ZONE_CONTROL_DATA_SINGLE_COLOR Data required to represent control mode of type NV_GPU_ILLUM_CTRL_MODE_MANUAL_SINGLE_COLOR.

◆ NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_SINGLE_COLOR_PARAMS

typedef struct _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_SINGLE_COLOR_PARAMS NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_SINGLE_COLOR_PARAMS

Used in NV_GPU_ILLUM_ZONE_CONTROL_DATA_MANUAL_SINGLE_COLOR Parameters required to represent control mode of type NV_GPU_ILLUM_CTRL_MODE_MANUAL_SINGLE_COLOR.

◆ NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR

typedef struct _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR

Used in NV_GPU_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR_RGB Data required to represent control mode of type NV_GPU_ILLUM_CTRL_MODE_PIECEWISE_LINEAR_RGB.

◆ NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR_COLOR_FIXED

typedef struct _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR_COLOR_FIXED NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR_COLOR_FIXED

Used in NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_COLOR_FIXED Data required to represent control mode of type NV_GPU_CLIENT_ILLUM_CTRL_MODE_PIECEWISE_LINEAR_RGB.

◆ NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR_RGB

typedef struct _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR_RGB NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR_RGB

Used in NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_RGB Data required to represent control mode of type NV_GPU_CLIENT_ILLUM_CTRL_MODE_PIECEWISE_LINEAR_RGB.

◆ NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR_RGBW

typedef struct _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR_RGBW NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR_RGBW

Used in NV_GPU_ILLUM_ZONE_CONTROL_DATA_RGBW Data required to represent control mode of type NV_GPU_ILLUM_CTRL_MODE_PIECEWISE_LINEAR_RGBW.

◆ NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR_SINGLE_COLOR

typedef struct _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR_SINGLE_COLOR NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR_SINGLE_COLOR

Used in NV_GPU_ILLUM_ZONE_CONTROL_DATA_SINGLE_COLOR Data required to represent control mode of type NV_GPU_ILLUM_CTRL_MODE_PIECEWISE_LINEAR_SINGLE_COLOR.

◆ NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_RGB

typedef struct _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_RGB NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_RGB

Used in NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_V1 Describes the control data for illumination zone of type NV_GPU_CLIENT_ILLUM_ZONE_TYPE_RGB.

◆ NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_RGBW

typedef struct _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_RGBW NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_RGBW

Used in NV_GPU_ILLUM_ZONE_CONTROL_V1 Describes the control data for illum zone of type NV_GPU_ILLUM_ZONE_TYPE_RGBW.

◆ NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_SINGLE_COLOR

typedef struct _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_SINGLE_COLOR NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_SINGLE_COLOR

Used in NV_GPU_ILLUM_ZONE_CONTROL_V1 Describes the control data for illum zone of type NV_GPU_ILLUM_ZONE_TYPE_SINGLE_COLOR.

◆ NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_PARAMS

typedef NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_PARAMS_V1 NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_PARAMS

◆ NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_PARAMS_V1

typedef struct _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_PARAMS_V1 NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_PARAMS_V1

◆ NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_V1

typedef struct _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_V1 NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_V1

◆ NV_GPU_CLIENT_ILLUM_ZONE_INFO_DATA_RGB

typedef struct _NV_GPU_CLIENT_ILLUM_ZONE_INFO_DATA_RGB NV_GPU_CLIENT_ILLUM_ZONE_INFO_DATA_RGB

◆ NV_GPU_CLIENT_ILLUM_ZONE_INFO_DATA_RGBW

typedef struct _NV_GPU_CLIENT_ILLUM_ZONE_INFO_DATA_RGBW NV_GPU_CLIENT_ILLUM_ZONE_INFO_DATA_RGBW

Used in NV_GPU_CLIENT_ILLUM_ZONE_INFO_V1 Describes the static information of illum zone type RGBW.

◆ NV_GPU_CLIENT_ILLUM_ZONE_INFO_DATA_SINGLE_COLOR

typedef struct _NV_GPU_CLIENT_ILLUM_ZONE_INFO_DATA_SINGLE_COLOR NV_GPU_CLIENT_ILLUM_ZONE_INFO_DATA_SINGLE_COLOR

Used in NV_GPU_CLIENT_ILLUM_ZONE_INFO_V1 Describes the static information of illum zone type SINGLE_COLOR.

◆ NV_GPU_CLIENT_ILLUM_ZONE_INFO_PARAMS

typedef NV_GPU_CLIENT_ILLUM_ZONE_INFO_PARAMS_V1 NV_GPU_CLIENT_ILLUM_ZONE_INFO_PARAMS

◆ NV_GPU_CLIENT_ILLUM_ZONE_INFO_PARAMS_V1

typedef struct _NV_GPU_CLIENT_ILLUM_ZONE_INFO_PARAMS_V1 NV_GPU_CLIENT_ILLUM_ZONE_INFO_PARAMS_V1

◆ NV_GPU_CLIENT_ILLUM_ZONE_INFO_V1

typedef struct _NV_GPU_CLIENT_ILLUM_ZONE_INFO_V1 NV_GPU_CLIENT_ILLUM_ZONE_INFO_V1

◆ NV_GPU_GSP_INFO

typedef NV_GPU_GSP_INFO_V1 NV_GPU_GSP_INFO

◆ NV_GPU_INFO

typedef NV_GPU_INFO_V2 NV_GPU_INFO

◆ NV_GPU_INFO_V1

typedef struct _NV_GPU_INFO_V1 NV_GPU_INFO_V1

◆ NV_GPU_INFO_V2

typedef struct _NV_GPU_INFO_V2 NV_GPU_INFO_V2

◆ NV_GPU_VR_READY

typedef NV_GPU_VR_READY_V1 NV_GPU_VR_READY

◆ NV_GPU_VR_READY_V1

typedef struct _NV_GPU_VR_READY_V1 NV_GPU_VR_READY_V1

◆ NV_GSYNC_CAPABILITIES

typedef NV_GSYNC_CAPABILITIES_V3 NV_GSYNC_CAPABILITIES

◆ NV_GSYNC_CAPABILITIES_V1

typedef struct _NV_GSYNC_CAPABILITIES_V1 NV_GSYNC_CAPABILITIES_V1

Used in NvAPI_GSync_QueryCapabilities().

◆ NV_GSYNC_CAPABILITIES_V2

typedef struct _NV_GSYNC_CAPABILITIES_V2 NV_GSYNC_CAPABILITIES_V2

◆ NV_GSYNC_CAPABILITIES_V3

typedef struct _NV_GSYNC_CAPABILITIES_V3 NV_GSYNC_CAPABILITIES_V3

◆ NV_GSYNC_CONTROL_PARAMS

typedef NV_GSYNC_CONTROL_PARAMS_V2 NV_GSYNC_CONTROL_PARAMS

◆ NV_GSYNC_CONTROL_PARAMS_V1

typedef struct _NV_GSYNC_CONTROL_PARAMS_V1 NV_GSYNC_CONTROL_PARAMS_V1

Used in NvAPI_GSync_GetControlParameters() and NvAPI_GSync_SetControlParameters().

◆ NV_GSYNC_CONTROL_PARAMS_V2

typedef struct _NV_GSYNC_CONTROL_PARAMS_V2 NV_GSYNC_CONTROL_PARAMS_V2

◆ NV_GSYNC_DELAY

typedef struct _NV_GSYNC_DELAY NV_GSYNC_DELAY

Used in NV_GSYNC_CONTROL_PARAMS.

◆ NV_GSYNC_DISPLAY

typedef struct _NV_GSYNC_DISPLAY NV_GSYNC_DISPLAY

◆ NV_GSYNC_GPU

typedef struct _NV_GSYNC_GPU NV_GSYNC_GPU

◆ NV_GSYNC_STATUS

typedef struct _NV_GSYNC_STATUS NV_GSYNC_STATUS

Used in NvAPI_GSync_GetSyncStatus().

◆ NV_GSYNC_STATUS_PARAMS

typedef NV_GSYNC_STATUS_PARAMS_V2 NV_GSYNC_STATUS_PARAMS

◆ NV_GSYNC_STATUS_PARAMS_V2

typedef struct _NV_GSYNC_STATUS_PARAMS_V2 NV_GSYNC_STATUS_PARAMS_V2

◆ NV_HDMI_SUPPORT_INFO

typedef NV_HDMI_SUPPORT_INFO_V2 NV_HDMI_SUPPORT_INFO

◆ NV_HDMI_SUPPORT_INFO_V2

typedef struct _NV_HDMI_SUPPORT_INFO_V2 NV_HDMI_SUPPORT_INFO_V2

◆ NV_HDR_CAPABILITIES

typedef NV_HDR_CAPABILITIES_V3 NV_HDR_CAPABILITIES

◆ NV_HDR_CAPABILITIES_V1

typedef struct _NV_HDR_CAPABILITIES_V1 NV_HDR_CAPABILITIES_V1

◆ NV_HDR_CAPABILITIES_V2

typedef struct _NV_HDR_CAPABILITIES_V2 NV_HDR_CAPABILITIES_V2

◆ NV_HDR_CAPABILITIES_V3

typedef struct _NV_HDR_CAPABILITIES_V3 NV_HDR_CAPABILITIES_V3

◆ NV_HDR_COLOR_DATA

typedef NV_HDR_COLOR_DATA_V2 NV_HDR_COLOR_DATA

◆ NV_HDR_COLOR_DATA_V1

typedef struct _NV_HDR_COLOR_DATA_V1 NV_HDR_COLOR_DATA_V1

◆ NV_HDR_COLOR_DATA_V2

typedef struct _NV_HDR_COLOR_DATA_V2 NV_HDR_COLOR_DATA_V2

◆ NV_HDR_METADATA

typedef NV_HDR_METADATA_V1 NV_HDR_METADATA

DESCRIPTION: This API sets HDR metadata of the source identified by the process id of the caller

SUPPORTED OS: Windows 7 and higher

Since
Release: 525
Parameters
[in] | displayId | Monitor Identifier
[in] | pMetadata | HDR metadata
Returns
This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.

◆ NV_HDR_METADATA_V1

typedef struct _NV_HDR_METADATA_V1 NV_HDR_METADATA_V1

DESCRIPTION: This API sets HDR metadata of the source identified by the process id of the caller

SUPPORTED OS: Windows 7 and higher

Since
Release: 525
Parameters
[in] | displayId | Monitor Identifier
[in] | pMetadata | HDR metadata
Returns
This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.

◆ NV_HDR_TONEMAPPING_METHOD

typedef enum _NV_HDR_TONEMAPPING_METHOD NV_HDR_TONEMAPPING_METHOD

DESCRIPTION: This API sets HDR metadata of the source identified by the process id of the caller

SUPPORTED OS: Windows 7 and higher

Since
Release: 525
Parameters
[in] | displayId | Monitor Identifier
[in] | pMetadata | HDR metadata
Returns
This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.

◆ NV_LICENSABLE_FEATURES

typedef NV_LICENSABLE_FEATURES_V4 NV_LICENSABLE_FEATURES

Maximum number of supported Feature License.

◆ NV_LICENSABLE_FEATURES_V1

typedef struct _NV_LICENSABLE_FEATURES_V1 NV_LICENSABLE_FEATURES_V1

Licensable features.

◆ NV_LICENSABLE_FEATURES_V2

typedef struct _NV_LICENSABLE_FEATURES_V2 NV_LICENSABLE_FEATURES_V2

Maximum number of supported Feature License.

◆ NV_LICENSABLE_FEATURES_V3

typedef struct _NV_LICENSABLE_FEATURES_V3 NV_LICENSABLE_FEATURES_V3

Maximum number of supported Feature License.

◆ NV_LICENSABLE_FEATURES_V4

typedef struct _NV_LICENSABLE_FEATURES_V4 NV_LICENSABLE_FEATURES_V4

Maximum number of supported Feature License.

◆ NV_LICENSE_EXPIRY_DETAILS

typedef struct _NV_LICENSE_EXPIRY_DETAILS NV_LICENSE_EXPIRY_DETAILS

Used in NV_LICENSE_FEATURE_DETAILS

The 'status' variable holds any one of the following license expiry status codes : 0 - Expiry information not available 1 - Invalid expiry or error fetching expiry 2 - Valid expiry 3 - Expiry not applicable 4 - Permanent expiry

◆ NV_LICENSE_FEATURE_DETAILS

typedef NV_LICENSE_FEATURE_DETAILS_V1 NV_LICENSE_FEATURE_DETAILS

Maximum number of supported Feature License.

◆ NV_LICENSE_FEATURE_DETAILS_V1

typedef struct _NV_LICENSE_FEATURE_DETAILS_V1 NV_LICENSE_FEATURE_DETAILS_V1

Used in NV_LICENSABLE_FEATURES.

◆ NV_LICENSE_FEATURE_DETAILS_V2

typedef struct _NV_LICENSE_FEATURE_DETAILS_V2 NV_LICENSE_FEATURE_DETAILS_V2

Maximum number of supported Feature License.

◆ NV_LICENSE_FEATURE_DETAILS_V3

typedef struct _NV_LICENSE_FEATURE_DETAILS_V3 NV_LICENSE_FEATURE_DETAILS_V3

Maximum number of supported Feature License.

◆ NV_LICENSE_FEATURE_DETAILS_V4

typedef struct _NV_LICENSE_FEATURE_DETAILS_V4 NV_LICENSE_FEATURE_DETAILS_V4

Maximum number of supported Feature License.

◆ NV_LICENSE_FEATURE_TYPE

typedef enum _NV_LICENSE_FEATURE_TYPE NV_LICENSE_FEATURE_TYPE

Used in NV_LICENSE_FEATURE_DETAILS.

◆ NV_MANAGED_DEDICATED_DISPLAY_INFO

typedef NV_MANAGED_DEDICATED_DISPLAY_INFO_V1 NV_MANAGED_DEDICATED_DISPLAY_INFO

◆ NV_MANAGED_DEDICATED_DISPLAY_INFO_V1

typedef struct _NV_MANAGED_DEDICATED_DISPLAY_INFO NV_MANAGED_DEDICATED_DISPLAY_INFO_V1

SUPPORTED OS: Windows 10 and higher

◆ NV_MANAGED_DEDICATED_DISPLAY_METADATA

typedef NV_MANAGED_DEDICATED_DISPLAY_METADATA_V1 NV_MANAGED_DEDICATED_DISPLAY_METADATA

◆ NV_MANAGED_DEDICATED_DISPLAY_METADATA_V1

typedef struct _NV_MANAGED_DEDICATED_DISPLAY_METADATA NV_MANAGED_DEDICATED_DISPLAY_METADATA_V1

SUPPORTED OS: Windows 11 and higher

◆ NV_MONITOR_CAPABILITIES

typedef NV_MONITOR_CAPABILITIES_V1 NV_MONITOR_CAPABILITIES

Macro for constructing the version field of NV_MONITOR_CAPABILITIES_V1.

◆ NV_MONITOR_CAPABILITIES_V1

typedef struct _NV_MONITOR_CAPABILITIES_V1 NV_MONITOR_CAPABILITIES_V1

See NvAPI_DISP_GetMonitorCapabilities().

◆ NV_MONITOR_CAPS_GENERIC

typedef struct _NV_MONITOR_CAPS_GENERIC NV_MONITOR_CAPS_GENERIC

Macro for constructing the version field of NV_MONITOR_CAPABILITIES_V1.

◆ NV_MONITOR_CAPS_VCDB

typedef struct _NV_MONITOR_CAPS_VCDB NV_MONITOR_CAPS_VCDB

Macro for constructing the version field of NV_MONITOR_CAPABILITIES_V1.

◆ NV_MONITOR_CAPS_VSDB

typedef struct _NV_MONITOR_CAPS_VSDB NV_MONITOR_CAPS_VSDB

See NvAPI_DISP_GetMonitorCapabilities().

◆ NV_MONITOR_COLOR_CAPS

typedef NV_MONITOR_COLOR_CAPS_V1 NV_MONITOR_COLOR_CAPS

◆ NV_MOSAIC_GRID_TOPO

typedef NV_MOSAIC_GRID_TOPO_V2 NV_MOSAIC_GRID_TOPO

Macro for constructing the version field of NV_MOSAIC_GRID_TOPO.

◆ NV_MOSAIC_GRID_TOPO_DISPLAY

typedef NV_MOSAIC_GRID_TOPO_DISPLAY_V1 NV_MOSAIC_GRID_TOPO_DISPLAY

Macro for constructing the version field of NV_MOSAIC_GRID_TOPO.

◆ NV_MOSAIC_GRID_TOPO_DISPLAY_V1

typedef struct _NV_MOSAIC_GRID_TOPO_DISPLAY_V1 NV_MOSAIC_GRID_TOPO_DISPLAY_V1

Macro for constructing the version field of NV_MOSAIC_GRID_TOPO.

◆ NV_MOSAIC_GRID_TOPO_DISPLAY_V2

typedef struct _NV_MOSAIC_GRID_TOPO_DISPLAY_V2 NV_MOSAIC_GRID_TOPO_DISPLAY_V2

Macro for constructing the version field of NV_MOSAIC_GRID_TOPO.

◆ NV_MOSAIC_GRID_TOPO_V1

typedef struct _NV_MOSAIC_GRID_TOPO_V1 NV_MOSAIC_GRID_TOPO_V1

Macro for constructing the version field of NV_MOSAIC_GRID_TOPO.

◆ NV_MOSAIC_GRID_TOPO_V2

typedef struct _NV_MOSAIC_GRID_TOPO_V2 NV_MOSAIC_GRID_TOPO_V2

Macro for constructing the version field of NV_MOSAIC_GRID_TOPO.

◆ NV_PIXEL_SHIFT_TYPE

typedef enum _NV_PIXEL_SHIFT_TYPE NV_PIXEL_SHIFT_TYPE

Macro for constructing the version field of NV_MOSAIC_GRID_TOPO.

◆ NV_SCANOUT_INTENSITY_DATA

typedef NV_SCANOUT_INTENSITY_DATA_V2 NV_SCANOUT_INTENSITY_DATA

◆ NV_SET_ADAPTIVE_SYNC_DATA

typedef NV_SET_ADAPTIVE_SYNC_DATA_V1 NV_SET_ADAPTIVE_SYNC_DATA

◆ NV_SET_ADAPTIVE_SYNC_DATA_V1

typedef struct _NV_SET_ADAPTIVE_SYNC_DATA_V1 NV_SET_ADAPTIVE_SYNC_DATA_V1

◆ NV_SET_VIRTUAL_REFRESH_RATE_DATA

typedef NV_SET_VIRTUAL_REFRESH_RATE_DATA_V1 NV_SET_VIRTUAL_REFRESH_RATE_DATA

◆ NV_SET_VIRTUAL_REFRESH_RATE_DATA_V1

typedef struct _NV_SET_VIRTUAL_REFRESH_RATE_DATA_V1 NV_SET_VIRTUAL_REFRESH_RATE_DATA_V1

◆ NVAPI_CALLBACK_QSYNCEVENT

typedef void(__cdecl * NVAPI_CALLBACK_QSYNCEVENT) (NV_QSYNC_EVENT_DATA qyncEventData, void *callbackParam)

Callback for QSYNC event.

◆ NVAPI_GPU_PERF_DECREASE

typedef enum _NVAPI_GPU_PERF_DECREASE NVAPI_GPU_PERF_DECREASE

Used in NvAPI_GPU_GetPerfDecreaseInfo. Bit masks for knowing the exact reason for performance decrease

◆ NVAPI_GSYNC_DELAY_TYPE

typedef enum _NVAPI_GSYNC_DELAY_TYPE NVAPI_GSYNC_DELAY_TYPE

Used in NvAPI_GSync_AdjustSyncDelay()

◆ NVAPI_GSYNC_DISPLAY_SYNC_STATE

typedef enum _NVAPI_GSYNC_DISPLAY_SYNC_STATE NVAPI_GSYNC_DISPLAY_SYNC_STATE

Display sync states. Used in NV_GSYNC_DISPLAY.

◆ NVAPI_GSYNC_GPU_TOPOLOGY_CONNECTOR

typedef enum _NVAPI_GSYNC_GPU_TOPOLOGY_CONNECTOR NVAPI_GSYNC_GPU_TOPOLOGY_CONNECTOR

Connector values for a GPU. Used in NV_GSYNC_GPU.

◆ NVAPI_GSYNC_MULTIPLY_DIVIDE_MODE

typedef enum _NVAPI_GSYNC_MULTIPLY_DIVIDE_MODE NVAPI_GSYNC_MULTIPLY_DIVIDE_MODE

Used in NV_GSYNC_CONTROL_PARAMS.

◆ NVAPI_GSYNC_RJ45_IO

typedef enum _NVAPI_GSYNC_RJ45_IO NVAPI_GSYNC_RJ45_IO

Used in NV_GSYNC_STATUS_PARAMS.

◆ NVAPI_GSYNC_SYNC_SOURCE

typedef enum _NVAPI_GSYNC_SYNC_SOURCE NVAPI_GSYNC_SYNC_SOURCE

Used in NV_GSYNC_CONTROL_PARAMS.

◆ NVAPI_GSYNC_VIDEO_MODE

typedef enum _NVAPI_GSYNC_VIDEO_MODE NVAPI_GSYNC_VIDEO_MODE

Used in NV_GSYNC_CONTROL_PARAMS.

◆ NvAPI_LicenseString

typedef char NvAPI_LicenseString[NV_LICENSE_INFO_MAX_LENGTH]

License string.

◆ NVAPI_NVLINK_DEVICE_INFO_DEVICE_TYPE

typedef enum _NVAPI_NVLINK_DEVICE_INFO_DEVICE_TYPE NVAPI_NVLINK_DEVICE_INFO_DEVICE_TYPE

Used in NvAPI_GPU_NVLINK_GetStatus()

◆ NVAPI_NVLINK_STATUS_LINK_STATE

typedef enum _NVAPI_NVLINK_STATUS_LINK_STATE NVAPI_NVLINK_STATUS_LINK_STATE

Used in NvAPI_GPU_NVLINK_GetStatus()

◆ NVAPI_NVLINK_STATUS_SUBLINK_RX_STATE

typedef enum _NVAPI_NVLINK_STATUS_SUBLINK_RX_STATE NVAPI_NVLINK_STATUS_SUBLINK_RX_STATE

Used in NvAPI_GPU_NVLINK_GetStatus()

◆ NVAPI_NVLINK_STATUS_SUBLINK_TX_STATE

typedef enum _NVAPI_NVLINK_STATUS_SUBLINK_TX_STATE NVAPI_NVLINK_STATUS_SUBLINK_TX_STATE

Used in NvAPI_GPU_NVLINK_GetStatus()

◆ NVAPI_OGLEXPERT_CALLBACK

typedef void(* NVAPI_OGLEXPERT_CALLBACK) (unsigned int categoryId, unsigned int messageId, unsigned int detailLevel, int objectId, const char *messageStr)

DESCRIPTION: Used in conjunction with OUTPUT_TO_CALLBACK, this is a simple callback function the user may use to obtain the feedback stream. The function will be called once per fully qualified feedback stream entry.

Parameters
categoryId | Contains the bit from the NVAPI_OGLEXPERT_REPORT mask that corresponds to the current message
messageId | Unique ID for the current message
detailLevel | Contains the bit from the NVAPI_OGLEXPERT_DETAIL mask that corresponds to the current message
objectId | Unique ID of the object that corresponds to the current message
messageStr | Text string from the current message

◆ NVLINK_GET_CAPS

typedef NVLINK_GET_CAPS_V1 NVLINK_GET_CAPS

Set if NVLink is present and supported on this GPU.This field is used for global caps only and NOT for per-link caps.

Used in NvAPI_GPU_NVLINK_GetCaps()

◆ NVLINK_GET_STATUS

typedef NVLINK_GET_STATUS_V2 NVLINK_GET_STATUS

Used in NvAPI_GPU_NVLINK_GetStatus()

◆ PNV_EVENT_REGISTER_CALLBACK

typedef struct NV_EVENT_REGISTER_CALLBACK * PNV_EVENT_REGISTER_CALLBACK

Enumeration Type Documentation

◆ _NV_ADAPTER_TYPE

enum _NV_ADAPTER_TYPE
Enumerator
NV_ADAPTER_TYPE_UNKNOWN
NV_ADAPTER_TYPE_WDDM
NV_ADAPTER_TYPE_MCDM
NV_ADAPTER_TYPE_TCC
NV_ADAPTER_TYPE_LAST

◆ _NV_BPC

enum _NV_BPC

See Table 14 of CEA-861E. Not all of this is supported by the GPU.

Enumerator
NV_BPC_DEFAULT
NV_BPC_6
NV_BPC_8
NV_BPC_10
NV_BPC_12
NV_BPC_16

◆ _NV_COLOR_SELECTION_POLICY

enum _NV_COLOR_SELECTION_POLICY

See Table 14 of CEA-861E. Not all of this is supported by the GPU.

Enumerator
NV_COLOR_SELECTION_POLICY_USER | app/nvcpl make decision to select the desire color format
NV_COLOR_SELECTION_POLICY_BEST_QUALITY | driver/ OS make decision to select the best color format
NV_COLOR_SELECTION_POLICY_DEFAULT |
NV_COLOR_SELECTION_POLICY_UNKNOWN |

◆ _NV_COLORSPACE_TYPE

enum _NV_COLORSPACE_TYPE

DESCRIPTION: This API sets HDR metadata of the source identified by the process id of the caller

SUPPORTED OS: Windows 7 and higher

Since
Release: 525
Parameters
[in] | displayId | Monitor Identifier
[in] | pMetadata | HDR metadata
Returns
This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.
Enumerator
NV_COLORSPACE_sRGB | sRGB IEC 61966-2-1:1999 == DXGI_COLOR_SPACE_RGB_FULL_G22_NONE_P709
NV_COLORSPACE_xRGB | FP16 linear with sRGB color primaries == DXGI_COLOR_SPACE_RGB_FULL_G10_NONE_P709.
NV_COLORSPACE_REC2100 | ITU-R Rec BT.2100 (HDR10) == DXGI_COLOR_SPACE_RGB_FULL_G2084_NONE_P2020.

◆ _NV_DESKTOP_COLOR_DEPTH

enum _NV_DESKTOP_COLOR_DEPTH

See Table 14 of CEA-861E. Not all of this is supported by the GPU.

Enumerator
NV_DESKTOP_COLOR_DEPTH_DEFAULT
NV_DESKTOP_COLOR_DEPTH_8BPC
NV_DESKTOP_COLOR_DEPTH_10BPC
NV_DESKTOP_COLOR_DEPTH_16BPC_FLOAT
NV_DESKTOP_COLOR_DEPTH_16BPC_FLOAT_WCG
NV_DESKTOP_COLOR_DEPTH_16BPC_FLOAT_HDR
NV_DESKTOP_COLOR_DEPTH_MAX_VALUE

◆ _NV_DISPLAY_OUTPUT_MODE

enum _NV_DISPLAY_OUTPUT_MODE

DESCRIPTION: This API sets HDR metadata of the source identified by the process id of the caller

SUPPORTED OS: Windows 7 and higher

Since
Release: 525
Parameters
[in] | displayId | Monitor Identifier
[in] | pMetadata | HDR metadata
Returns
This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.
Enumerator
NV_DISPLAY_OUTPUT_MODE_SDR
NV_DISPLAY_OUTPUT_MODE_HDR10
NV_DISPLAY_OUTPUT_MODE_HDR10PLUS_GAMING

◆ _NV_DYNAMIC_RANGE

enum _NV_DYNAMIC_RANGE

See Table 14 of CEA-861E. Not all of this is supported by the GPU.

Enumerator
NV_DYNAMIC_RANGE_VESA
NV_DYNAMIC_RANGE_CEA
NV_DYNAMIC_RANGE_AUTO

◆ _NV_ECC_CONFIGURATION

enum _NV_ECC_CONFIGURATION
Enumerator
NV_ECC_CONFIGURATION_NOT_SUPPORTED |
NV_ECC_CONFIGURATION_DEFERRED | Changes require a POST to take effect.
NV_ECC_CONFIGURATION_IMMEDIATE | Changes can optionally be made to take effect immediately.

◆ _NV_HDR_TONEMAPPING_METHOD

enum _NV_HDR_TONEMAPPING_METHOD

DESCRIPTION: This API sets HDR metadata of the source identified by the process id of the caller

SUPPORTED OS: Windows 7 and higher

Since
Release: 525
Parameters
[in] | displayId | Monitor Identifier
[in] | pMetadata | HDR metadata
Returns
This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.
Enumerator
NV_HDR_TONEMAPPING_APP
NV_HDR_TONEMAPPING_GPU

◆ _NV_LICENSE_FEATURE_TYPE

enum _NV_LICENSE_FEATURE_TYPE

Used in NV_LICENSE_FEATURE_DETAILS.

Enumerator
NV_LICENSE_FEATURE_UNKNOWN |
NV_LICENSE_FEATURE_VGPU |
NV_LICENSE_FEATURE_NVIDIA_RTX |
NV_LICENSE_FEATURE_QUADRO | DEPRECATED name - do not use.
NV_LICENSE_FEATURE_GAMING |
NV_LICENSE_FEATURE_COMPUTE |

◆ _NV_PIXEL_SHIFT_TYPE

enum _NV_PIXEL_SHIFT_TYPE

Macro for constructing the version field of NV_MOSAIC_GRID_TOPO.

Enumerator
NV_PIXEL_SHIFT_TYPE_NO_PIXEL_SHIFT | No pixel shift will be applied to this display.
NV_PIXEL_SHIFT_TYPE_2x2_TOP_LEFT_PIXELS | This display will be used to scanout top left pixels in 2x2 PixelShift configuration.
NV_PIXEL_SHIFT_TYPE_2x2_BOTTOM_RIGHT_PIXELS | This display will be used to scanout bottom right pixels in 2x2 PixelShift configuration.
NV_PIXEL_SHIFT_TYPE_2x2_TOP_RIGHT_PIXELS | This display will be used to scanout top right pixels in 2x2 PixelShift configuration.
NV_PIXEL_SHIFT_TYPE_2x2_BOTTOM_LEFT_PIXELS | This display will be used to scanout bottom left pixels in 2x2 PixelShift configuration.

◆ _NVAPI_GPU_PERF_DECREASE

enum _NVAPI_GPU_PERF_DECREASE

Used in NvAPI_GPU_GetPerfDecreaseInfo. Bit masks for knowing the exact reason for performance decrease

Enumerator
NV_GPU_PERF_DECREASE_NONE | No Slowdown detected.
NV_GPU_PERF_DECREASE_REASON_THERMAL_PROTECTION | Thermal slowdown/shutdown/POR thermal protection.
NV_GPU_PERF_DECREASE_REASON_POWER_CONTROL | Power capping / pstate cap.
NV_GPU_PERF_DECREASE_REASON_AC_BATT | AC->BATT event.
NV_GPU_PERF_DECREASE_REASON_API_TRIGGERED | API triggered slowdown.
NV_GPU_PERF_DECREASE_REASON_INSUFFICIENT_POWER | Power connector missing.
NV_GPU_PERF_DECREASE_REASON_UNKNOWN | Unknown reason.

◆ _NVAPI_GSYNC_DELAY_TYPE

enum _NVAPI_GSYNC_DELAY_TYPE

Used in NvAPI_GSync_AdjustSyncDelay()

Enumerator
NVAPI_GSYNC_DELAY_TYPE_UNKNOWN
NVAPI_GSYNC_DELAY_TYPE_SYNC_SKEW
NVAPI_GSYNC_DELAY_TYPE_STARTUP

◆ _NVAPI_GSYNC_DISPLAY_SYNC_STATE

enum _NVAPI_GSYNC_DISPLAY_SYNC_STATE

Display sync states. Used in NV_GSYNC_DISPLAY.

Enumerator
NVAPI_GSYNC_DISPLAY_SYNC_STATE_UNSYNCED
NVAPI_GSYNC_DISPLAY_SYNC_STATE_SLAVE
NVAPI_GSYNC_DISPLAY_SYNC_STATE_MASTER

◆ _NVAPI_GSYNC_GPU_TOPOLOGY_CONNECTOR

enum _NVAPI_GSYNC_GPU_TOPOLOGY_CONNECTOR

Connector values for a GPU. Used in NV_GSYNC_GPU.

Enumerator
NVAPI_GSYNC_GPU_TOPOLOGY_CONNECTOR_NONE
NVAPI_GSYNC_GPU_TOPOLOGY_CONNECTOR_PRIMARY
NVAPI_GSYNC_GPU_TOPOLOGY_CONNECTOR_SECONDARY
NVAPI_GSYNC_GPU_TOPOLOGY_CONNECTOR_TERTIARY
NVAPI_GSYNC_GPU_TOPOLOGY_CONNECTOR_QUARTERNARY

◆ _NVAPI_GSYNC_MULTIPLY_DIVIDE_MODE

enum _NVAPI_GSYNC_MULTIPLY_DIVIDE_MODE

Used in NV_GSYNC_CONTROL_PARAMS.

Enumerator
NVAPI_GSYNC_UNDEFINED_MODE
NVAPI_GSYNC_MULTIPLY_MODE
NVAPI_GSYNC_DIVIDE_MODE

◆ _NVAPI_GSYNC_RJ45_IO

enum _NVAPI_GSYNC_RJ45_IO

Used in NV_GSYNC_STATUS_PARAMS.

Enumerator
NVAPI_GSYNC_RJ45_OUTPUT |
NVAPI_GSYNC_RJ45_INPUT |
NVAPI_GSYNC_RJ45_UNUSED | This field is used to notify that the framelock is not actually present.

◆ _NVAPI_GSYNC_SYNC_SOURCE

enum _NVAPI_GSYNC_SYNC_SOURCE

Used in NV_GSYNC_CONTROL_PARAMS.

Enumerator
NVAPI_GSYNC_SYNC_SOURCE_VSYNC
NVAPI_GSYNC_SYNC_SOURCE_HOUSESYNC

◆ _NVAPI_GSYNC_VIDEO_MODE

enum _NVAPI_GSYNC_VIDEO_MODE

Used in NV_GSYNC_CONTROL_PARAMS.

Enumerator
NVAPI_GSYNC_VIDEO_MODE_NONE
NVAPI_GSYNC_VIDEO_MODE_TTL
NVAPI_GSYNC_VIDEO_MODE_NTSCPALSECAM
NVAPI_GSYNC_VIDEO_MODE_HDTV
NVAPI_GSYNC_VIDEO_MODE_COMPOSITE

◆ _NVAPI_NVLINK_DEVICE_INFO_DEVICE_TYPE

enum _NVAPI_NVLINK_DEVICE_INFO_DEVICE_TYPE

Used in NvAPI_GPU_NVLINK_GetStatus()

Enumerator
NVAPI_NVLINK_DEVICE_INFO_DEVICE_TYPE_EBRIDGE
NVAPI_NVLINK_DEVICE_INFO_DEVICE_TYPE_NPU
NVAPI_NVLINK_DEVICE_INFO_DEVICE_TYPE_GPU
NVAPI_NVLINK_DEVICE_INFO_DEVICE_TYPE_SWITCH
NVAPI_NVLINK_DEVICE_INFO_DEVICE_TYPE_TEGRA
NVAPI_NVLINK_DEVICE_INFO_DEVICE_TYPE_NONE
NVAPI_NVLINK_DEVICE_INFO_DEVICE_UUID_INVALID

◆ _NVAPI_NVLINK_STATUS_LINK_STATE

enum _NVAPI_NVLINK_STATUS_LINK_STATE

Used in NvAPI_GPU_NVLINK_GetStatus()

Enumerator
NVAPI_NVLINK_STATUS_LINK_STATE_UNKNOWN
NVAPI_NVLINK_STATUS_LINK_STATE_INIT
NVAPI_NVLINK_STATUS_LINK_STATE_HWCFG
NVAPI_NVLINK_STATUS_LINK_STATE_SWCFG
NVAPI_NVLINK_STATUS_LINK_STATE_ACTIVE
NVAPI_NVLINK_STATUS_LINK_STATE_FAULT
NVAPI_NVLINK_STATUS_LINK_STATE_RECOVERY
NVAPI_NVLINK_STATUS_LINK_STATE_RECOVERY_AC
NVAPI_NVLINK_STATUS_LINK_STATE_RECOVERY_AX
NVAPI_NVLINK_STATUS_LINK_STATE_INVALID

◆ _NVAPI_NVLINK_STATUS_SUBLINK_RX_STATE

enum _NVAPI_NVLINK_STATUS_SUBLINK_RX_STATE

Used in NvAPI_GPU_NVLINK_GetStatus()

Enumerator
NVAPI_NVLINK_STATUS_SUBLINK_RX_STATE_UNKNOWN
NVAPI_NVLINK_STATUS_SUBLINK_RX_STATE_HIGH_SPEED_1
NVAPI_NVLINK_STATUS_SUBLINK_RX_STATE_LOW_POWER
NVAPI_NVLINK_STATUS_SUBLINK_RX_STATE_TRAINING
NVAPI_NVLINK_STATUS_SUBLINK_RX_STATE_SAFE_MODE
NVAPI_NVLINK_STATUS_SUBLINK_RX_STATE_OFF
NVAPI_NVLINK_STATUS_SUBLINK_RX_STATE_TEST
NVAPI_NVLINK_STATUS_SUBLINK_RX_STATE_FAULT
NVAPI_NVLINK_STATUS_SUBLINK_RX_STATE_INVALID

◆ _NVAPI_NVLINK_STATUS_SUBLINK_TX_STATE

enum _NVAPI_NVLINK_STATUS_SUBLINK_TX_STATE

Used in NvAPI_GPU_NVLINK_GetStatus()

Enumerator
NVAPI_NVLINK_STATUS_SUBLINK_TX_STATE_UNKNOWN
NVAPI_NVLINK_STATUS_SUBLINK_TX_STATE_HIGH_SPEED_1
NVAPI_NVLINK_STATUS_SUBLINK_TX_STATE_LOW_POWER
NVAPI_NVLINK_STATUS_SUBLINK_TX_STATE_TRAINING
NVAPI_NVLINK_STATUS_SUBLINK_TX_STATE_SAFE_MODE
NVAPI_NVLINK_STATUS_SUBLINK_TX_STATE_OFF
NVAPI_NVLINK_STATUS_SUBLINK_TX_STATE_TEST
NVAPI_NVLINK_STATUS_SUBLINK_TX_STATE_FAULT
NVAPI_NVLINK_STATUS_SUBLINK_TX_STATE_INVALID

◆ NV_COLOR_CMD

enum NV_COLOR_CMD

See Table 14 of CEA-861E. Not all of this is supported by the GPU.

Enumerator
NV_COLOR_CMD_GET
NV_COLOR_CMD_SET
NV_COLOR_CMD_IS_SUPPORTED_COLOR
NV_COLOR_CMD_GET_DEFAULT

◆ NV_COLOR_COLORIMETRY

enum NV_COLOR_COLORIMETRY

See Table 14 of CEA-861E. Not all of this is supported by the GPU.

Enumerator
NV_COLOR_COLORIMETRY_RGB
NV_COLOR_COLORIMETRY_YCC601
NV_COLOR_COLORIMETRY_YCC709
NV_COLOR_COLORIMETRY_XVYCC601
NV_COLOR_COLORIMETRY_XVYCC709
NV_COLOR_COLORIMETRY_SYCC601
NV_COLOR_COLORIMETRY_ADOBEYCC601
NV_COLOR_COLORIMETRY_ADOBERGB
NV_COLOR_COLORIMETRY_BT2020RGB
NV_COLOR_COLORIMETRY_BT2020YCC
NV_COLOR_COLORIMETRY_BT2020cYCC
NV_COLOR_COLORIMETRY_DEFAULT
NV_COLOR_COLORIMETRY_AUTO

◆ NV_COLOR_FORMAT

enum NV_COLOR_FORMAT

See Table 14 of CEA-861E. Not all of this is supported by the GPU.

Enumerator
NV_COLOR_FORMAT_RGB
NV_COLOR_FORMAT_YUV422
NV_COLOR_FORMAT_YUV444
NV_COLOR_FORMAT_YUV420
NV_COLOR_FORMAT_DEFAULT
NV_COLOR_FORMAT_AUTO

◆ NV_EVENT_TYPE

enum NV_EVENT_TYPE

Enum for Event IDs.

Enumerator
NV_EVENT_TYPE_NONE
NV_EVENT_TYPE_QSYNC

◆ NV_GPU_CLIENT_ILLUM_CTRL_MODE

enum NV_GPU_CLIENT_ILLUM_CTRL_MODE

Enumeration of control modes that can be applied to Illumination Zones.

Enumerator
NV_GPU_CLIENT_ILLUM_CTRL_MODE_MANUAL_RGB
NV_GPU_CLIENT_ILLUM_CTRL_MODE_PIECEWISE_LINEAR_RGB
NV_GPU_CLIENT_ILLUM_CTRL_MODE_MANUAL
NV_GPU_CLIENT_ILLUM_CTRL_MODE_PIECEWISE_LINEAR
NV_GPU_CLIENT_ILLUM_CTRL_MODE_INVALID

◆ NV_GPU_CLIENT_ILLUM_DEVICE_TYPE

enum NV_GPU_CLIENT_ILLUM_DEVICE_TYPE

Enumeration of ILLUM_DEVICEs.

Enumerator
NV_GPU_CLIENT_ILLUM_DEVICE_TYPE_INVALID
NV_GPU_CLIENT_ILLUM_DEVICE_TYPE_MCUV10
NV_GPU_CLIENT_ILLUM_DEVICE_TYPE_GPIO_PWM_RGBW_V10
NV_GPU_CLIENT_ILLUM_DEVICE_TYPE_GPIO_PWM_SINGLE_COLOR_V10

◆ NV_GPU_CLIENT_ILLUM_PIECEWISE_LINEAR_CYCLE_TYPE

enum NV_GPU_CLIENT_ILLUM_PIECEWISE_LINEAR_CYCLE_TYPE

Enumeration of Cycle types for piecewise linear control mode.

Enumerator
NV_GPU_CLIENT_ILLUM_PIECEWISE_LINEAR_CYCLE_HALF_HALT
NV_GPU_CLIENT_ILLUM_PIECEWISE_LINEAR_CYCLE_FULL_HALT
NV_GPU_CLIENT_ILLUM_PIECEWISE_LINEAR_CYCLE_FULL_REPEAT
NV_GPU_CLIENT_ILLUM_PIECEWISE_LINEAR_CYCLE_INVALID

◆ NV_GPU_CLIENT_ILLUM_ZONE_LOCATION

enum NV_GPU_CLIENT_ILLUM_ZONE_LOCATION

Enumeration of locations where an Illumination Zone might be present. Encoding used - 1:0 - Number specifier (0) 4:2 - Location (TOP) 7:5 - Type (GPU/SLI)

Enumerator
NV_GPU_CLIENT_ILLUM_ZONE_LOCATION_GPU_TOP_0
NV_GPU_CLIENT_ILLUM_ZONE_LOCATION_GPU_FRONT_0
NV_GPU_CLIENT_ILLUM_ZONE_LOCATION_GPU_BACK_0
NV_GPU_CLIENT_ILLUM_ZONE_LOCATION_SLI_TOP_0
NV_GPU_CLIENT_ILLUM_ZONE_LOCATION_INVALID

◆ NV_GPU_CLIENT_ILLUM_ZONE_TYPE

enum NV_GPU_CLIENT_ILLUM_ZONE_TYPE

Enumeration of ILLUM_ZONEs.

Enumerator
NV_GPU_CLIENT_ILLUM_ZONE_TYPE_INVALID
NV_GPU_CLIENT_ILLUM_ZONE_TYPE_RGB
NV_GPU_CLIENT_ILLUM_ZONE_TYPE_COLOR_FIXED
NV_GPU_CLIENT_ILLUM_ZONE_TYPE_RGBW
NV_GPU_CLIENT_ILLUM_ZONE_TYPE_SINGLE_COLOR

◆ NV_GPU_SCANOUT_COMPOSITION_PARAMETER

enum NV_GPU_SCANOUT_COMPOSITION_PARAMETER
Enumerator
NV_GPU_SCANOUT_COMPOSITION_PARAMETER_WARPING_RESAMPLING_METHOD

◆ NV_GPU_SCANOUT_COMPOSITION_PARAMETER_VALUE

enum NV_GPU_SCANOUT_COMPOSITION_PARAMETER_VALUE

This enum defines a collection of possible scanout composition values that can be used to configure possible scanout composition settings. (Currently the only parameter defined is the WARPING_RESAMPLING_METHOD).

Enumerator
NV_GPU_SCANOUT_COMPOSITION_PARAMETER_SET_TO_DEFAULT
NV_GPU_SCANOUT_COMPOSITION_PARAMETER_VALUE_WARPING_RESAMPLING_METHOD_BILINEAR
NV_GPU_SCANOUT_COMPOSITION_PARAMETER_VALUE_WARPING_RESAMPLING_METHOD_BICUBIC_TRIANGULAR
NV_GPU_SCANOUT_COMPOSITION_PARAMETER_VALUE_WARPING_RESAMPLING_METHOD_BICUBIC_BELL_SHAPED
NV_GPU_SCANOUT_COMPOSITION_PARAMETER_VALUE_WARPING_RESAMPLING_METHOD_BICUBIC_BSPLINE
NV_GPU_SCANOUT_COMPOSITION_PARAMETER_VALUE_WARPING_RESAMPLING_METHOD_BICUBIC_ADAPTIVE_TRIANGULAR
NV_GPU_SCANOUT_COMPOSITION_PARAMETER_VALUE_WARPING_RESAMPLING_METHOD_BICUBIC_ADAPTIVE_BELL_SHAPED
NV_GPU_SCANOUT_COMPOSITION_PARAMETER_VALUE_WARPING_RESAMPLING_METHOD_BICUBIC_ADAPTIVE_BSPLINE

◆ NV_HDR_CMD

enum NV_HDR_CMD
Enumerator
NV_HDR_CMD_GET | Get current HDR output configuration.
NV_HDR_CMD_SET | Set HDR output configuration.

◆ NV_HDR_MODE

enum NV_HDR_MODE
Enumerator
NV_HDR_MODE_OFF | Turn off HDR.
NV_HDR_MODE_UHDA | Source: CCCS [a.k.a FP16 scRGB, linear, sRGB primaries, [-65504,0, 65504] range, RGB(1,1,1) = 80nits] Output : UHDA HDR [a.k.a HDR10, RGB/YCC 10/12bpc ST2084(PQ) EOTF RGB(1,1,1) = 10000 nits, Rec2020 color primaries, ST2086 static HDR metadata]. This is the only supported production HDR mode.
NV_HDR_MODE_UHDA_PASSTHROUGH | Experimental mode only, not for production! Source: HDR10 RGB 10bpc Output: HDR10 RGB 10 bpc - signal UHDA HDR mode (PQ + Rec2020) to the sink but send source pixel values unmodified (no PQ or Rec2020 conversions) - assumes source is already in HDR10 format.
NV_HDR_MODE_DOLBY_VISION | Experimental mode only, not for production! Source: RGB8 Dolby Vision encoded (12 bpc YCbCr422 packed into RGB8) Output: Dolby Vision encoded : Application is to encoded frames in DV format and embed DV dynamic metadata as described in Dolby Vision specification.
NV_HDR_MODE_EDR | Do not use! Internal test mode only, to be removed. Source: CCCS (a.k.a FP16 scRGB) Output : EDR (Extended Dynamic Range) - HDR content is tonemapped and gamut mapped to output on regular SDR display set to max luminance ( ~300 nits ).
NV_HDR_MODE_SDR | Do not use! Internal test mode only, to be removed. Source: any Output: SDR (Standard Dynamic Range), we continuously send SDR EOTF InfoFrame signaling, HDMI compliance testing.
NV_HDR_MODE_UHDA_NB | Do not use! Internal test mode only, to be removed. Source: CCCS (a.k.a FP16 scRGB) Output : notebook HDR.
NV_HDR_MODE_UHDBD | Do not use! Obsolete, to be removed. NV_HDR_MODE_UHDBD == NV_HDR_MODE_UHDA, reflects obsolete pre-UHDA naming convention.

◆ NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION

enum NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION

Byte 4 related.

Enumerator
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_X_X_X_X_X_FR_FL
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_X_X_X_X_LFE_FR_FL
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_X_X_X_FC_X_FR_FL
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_X_X_X_FC_LFE_FR_FL
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_X_X_RC_X_X_FR_FL
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_X_X_RC_X_LFE_FR_FL
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_X_X_RC_FC_X_FR_FL
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_X_X_RC_FC_LFE_FR_FL
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_X_RR_RL_X_X_FR_FL
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_X_RR_RL_X_LFE_FR_FL
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_X_RR_RL_FC_X_FR_FL
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_X_RR_RL_FC_LFE_FR_FL
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_RC_RR_RL_X_X_FR_FL
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_RC_RR_RL_X_LFE_FR_FL
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_RC_RR_RL_FC_X_FR_FL
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_RC_RR_RL_FC_LFE_FR_FL
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_RRC_RLC_RR_RL_X_X_FR_FL
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_RRC_RLC_RR_RL_X_LFE_FR_FL
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_RRC_RLC_RR_RL_FC_X_FR_FL
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_RRC_RLC_RR_RL_FC_LFE_FR_FL
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRC_FLC_X_X_X_X_FR_FL
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRC_FLC_X_X_X_LFE_FR_FL
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRC_FLC_X_X_FC_X_FR_FL
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRC_FLC_X_X_FC_LFE_FR_FL
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRC_FLC_X_RC_X_X_FR_FL
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRC_FLC_X_RC_X_LFE_FR_FL
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRC_FLC_X_RC_FC_X_FR_FL
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRC_FLC_X_RC_FC_LFE_FR_FL
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRC_FLC_RR_RL_X_X_FR_FL
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRC_FLC_RR_RL_X_LFE_FR_FL
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRC_FLC_RR_RL_FC_X_FR_FL
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRC_FLC_RR_RL_FC_LFE_FR_FL
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_FCH_RR_RL_FC_X_FR_FL
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_FCH_RR_RL_FC_LFE_FR_FL
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_TC_X_RR_RL_FC_X_FR_FL
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_TC_X_RR_RL_FC_LFE_FR_FL
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRH_FLH_RR_RL_X_X_FR_FL
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRH_FLH_RR_RL_X_LFE_FR_FL
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRW_FLW_RR_RL_X_X_FR_FL
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRW_FLW_RR_RL_X_LFE_FR_FL
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_TC_RC_RR_RL_FC_X_FR_FL
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_TC_RC_RR_RL_FC_LFE_FR_FL
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FCH_RC_RR_RL_FC_X_FR_FL
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FCH_RC_RR_RL_FC_LFE_FR_FL
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_TC_FCH_RR_RL_FC_X_FR_FL
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_TC_FCH_RR_RL_FC_LFE_FR_FL
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRH_FLH_RR_RL_FC_X_FR_FL
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRH_FLH_RR_RL_FC_LFE_FR_FL
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRW_FLW_RR_RL_FC_X_FR_FL
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRW_FLW_RR_RL_FC_LFE_FR_FL
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_AUTO

◆ NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELCOUNT

enum NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELCOUNT

Byte 1 related.

Enumerator
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELCOUNT_IN_HEADER
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELCOUNT_2
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELCOUNT_3
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELCOUNT_4
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELCOUNT_5
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELCOUNT_6
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELCOUNT_7
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELCOUNT_8
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELCOUNT_AUTO

◆ NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE

enum NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE

Byte 3 related.

Enumerator
NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_USE_CODING_TYPE
NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_HEAAC
NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_HEAACV2
NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_MPEGSURROUND
NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE04
NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE05
NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE06
NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE07
NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE08
NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE09
NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE10
NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE11
NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE12
NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE13
NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE14
NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE15
NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE16
NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE17
NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE18
NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE19
NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE20
NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE21
NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE22
NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE23
NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE24
NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE25
NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE26
NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE27
NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE28
NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE29
NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE30
NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE31
NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_AUTO

◆ NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE

enum NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE
Enumerator
NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_IN_HEADER
NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_PCM
NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_AC3
NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_MPEG1
NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_MP3
NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_MPEG2
NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_AACLC
NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_DTS
NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_ATRAC
NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_DSD
NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_EAC3
NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_DTSHD
NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_MLP
NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_DST
NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_WMAPRO
NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_USE_CODING_EXTENSION_TYPE
NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_AUTO

◆ NV_INFOFRAME_FIELD_VALUE_AUDIO_DOWNMIX

enum NV_INFOFRAME_FIELD_VALUE_AUDIO_DOWNMIX
Enumerator
NV_INFOFRAME_FIELD_VALUE_AUDIO_DOWNMIX_PERMITTED
NV_INFOFRAME_FIELD_VALUE_AUDIO_DOWNMIX_PROHIBITED
NV_INFOFRAME_FIELD_VALUE_AUDIO_DOWNMIX_AUTO

◆ NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES

enum NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES
Enumerator
NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_0DB
NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_1DB
NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_2DB
NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_3DB
NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_4DB
NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_5DB
NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_6DB
NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_7DB
NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_8DB
NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_9DB
NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_10DB
NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_11DB
NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_12DB
NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_13DB
NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_14DB
NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_15DB
NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_AUTO

◆ NV_INFOFRAME_FIELD_VALUE_AUDIO_LFEPLAYBACKLEVEL

enum NV_INFOFRAME_FIELD_VALUE_AUDIO_LFEPLAYBACKLEVEL

Byte 5 related.

Enumerator
NV_INFOFRAME_FIELD_VALUE_AUDIO_LFEPLAYBACKLEVEL_NO_DATA
NV_INFOFRAME_FIELD_VALUE_AUDIO_LFEPLAYBACKLEVEL_0DB
NV_INFOFRAME_FIELD_VALUE_AUDIO_LFEPLAYBACKLEVEL_PLUS10DB
NV_INFOFRAME_FIELD_VALUE_AUDIO_LFEPLAYBACKLEVEL_RESERVED03
NV_INFOFRAME_FIELD_VALUE_AUDIO_LFEPLAYBACKLEVEL_AUTO

◆ NV_INFOFRAME_FIELD_VALUE_AUDIO_SAMPLEFREQUENCY

enum NV_INFOFRAME_FIELD_VALUE_AUDIO_SAMPLEFREQUENCY
Enumerator
NV_INFOFRAME_FIELD_VALUE_AUDIO_SAMPLEFREQUENCY_IN_HEADER
NV_INFOFRAME_FIELD_VALUE_AUDIO_SAMPLEFREQUENCY_32000HZ
NV_INFOFRAME_FIELD_VALUE_AUDIO_SAMPLEFREQUENCY_44100HZ
NV_INFOFRAME_FIELD_VALUE_AUDIO_SAMPLEFREQUENCY_48000HZ
NV_INFOFRAME_FIELD_VALUE_AUDIO_SAMPLEFREQUENCY_88200KHZ
NV_INFOFRAME_FIELD_VALUE_AUDIO_SAMPLEFREQUENCY_96000KHZ
NV_INFOFRAME_FIELD_VALUE_AUDIO_SAMPLEFREQUENCY_176400KHZ
NV_INFOFRAME_FIELD_VALUE_AUDIO_SAMPLEFREQUENCY_192000KHZ
NV_INFOFRAME_FIELD_VALUE_AUDIO_SAMPLEFREQUENCY_AUTO

◆ NV_INFOFRAME_FIELD_VALUE_AUDIO_SAMPLESIZE

enum NV_INFOFRAME_FIELD_VALUE_AUDIO_SAMPLESIZE

Byte 2 related.

Enumerator
NV_INFOFRAME_FIELD_VALUE_AUDIO_SAMPLESIZE_IN_HEADER
NV_INFOFRAME_FIELD_VALUE_AUDIO_SAMPLESIZE_16BITS
NV_INFOFRAME_FIELD_VALUE_AUDIO_SAMPLESIZE_20BITS
NV_INFOFRAME_FIELD_VALUE_AUDIO_SAMPLESIZE_24BITS
NV_INFOFRAME_FIELD_VALUE_AUDIO_SAMPLESIZE_AUTO

◆ NV_INFOFRAME_FIELD_VALUE_AVI_ACTIVEFORMATINFO

enum NV_INFOFRAME_FIELD_VALUE_AVI_ACTIVEFORMATINFO
Enumerator
NV_INFOFRAME_FIELD_VALUE_AVI_AFI_ABSENT
NV_INFOFRAME_FIELD_VALUE_AVI_AFI_PRESENT
NV_INFOFRAME_FIELD_VALUE_AVI_AFI_AUTO

◆ NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION

enum NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION

Byte2 related.

Enumerator
NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_NO_AFD
NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_RESERVE01
NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_RESERVE02
NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_RESERVE03
NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_LETTERBOX_GT16x9
NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_RESERVE05
NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_RESERVE06
NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_RESERVE07
NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_EQUAL_CODEDFRAME
NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_CENTER_4x3
NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_CENTER_16x9
NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_CENTER_14x9
NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_RESERVE12
NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_4x3_ON_14x9
NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_16x9_ON_14x9
NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_16x9_ON_4x3
NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_AUTO

◆ NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOCODEDFRAME

enum NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOCODEDFRAME
Enumerator
NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOCODEDFRAME_NO_DATA
NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOCODEDFRAME_4x3
NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOCODEDFRAME_16x9
NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOCODEDFRAME_FUTURE
NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOCODEDFRAME_AUTO

◆ NV_INFOFRAME_FIELD_VALUE_AVI_BARDATA

enum NV_INFOFRAME_FIELD_VALUE_AVI_BARDATA
Enumerator
NV_INFOFRAME_FIELD_VALUE_AVI_BARDATA_NOT_PRESENT
NV_INFOFRAME_FIELD_VALUE_AVI_BARDATA_VERTICAL_PRESENT
NV_INFOFRAME_FIELD_VALUE_AVI_BARDATA_HORIZONTAL_PRESENT
NV_INFOFRAME_FIELD_VALUE_AVI_BARDATA_BOTH_PRESENT
NV_INFOFRAME_FIELD_VALUE_AVI_BARDATA_AUTO

◆ NV_INFOFRAME_FIELD_VALUE_AVI_COLORFORMAT

enum NV_INFOFRAME_FIELD_VALUE_AVI_COLORFORMAT
Enumerator
NV_INFOFRAME_FIELD_VALUE_AVI_COLORFORMAT_RGB
NV_INFOFRAME_FIELD_VALUE_AVI_COLORFORMAT_YCbCr422
NV_INFOFRAME_FIELD_VALUE_AVI_COLORFORMAT_YCbCr444
NV_INFOFRAME_FIELD_VALUE_AVI_COLORFORMAT_FUTURE
NV_INFOFRAME_FIELD_VALUE_AVI_COLORFORMAT_AUTO

◆ NV_INFOFRAME_FIELD_VALUE_AVI_COLORIMETRY

enum NV_INFOFRAME_FIELD_VALUE_AVI_COLORIMETRY
Enumerator
NV_INFOFRAME_FIELD_VALUE_AVI_COLORIMETRY_NO_DATA
NV_INFOFRAME_FIELD_VALUE_AVI_COLORIMETRY_SMPTE_170M
NV_INFOFRAME_FIELD_VALUE_AVI_COLORIMETRY_ITUR_BT709
NV_INFOFRAME_FIELD_VALUE_AVI_COLORIMETRY_USE_EXTENDED_COLORIMETRY
NV_INFOFRAME_FIELD_VALUE_AVI_COLORIMETRY_AUTO

◆ NV_INFOFRAME_FIELD_VALUE_AVI_CONTENTTYPE

enum NV_INFOFRAME_FIELD_VALUE_AVI_CONTENTTYPE
Enumerator
NV_INFOFRAME_FIELD_VALUE_AVI_CONTENTTYPE_GRAPHICS
NV_INFOFRAME_FIELD_VALUE_AVI_CONTENTTYPE_PHOTO
NV_INFOFRAME_FIELD_VALUE_AVI_CONTENTTYPE_CINEMA
NV_INFOFRAME_FIELD_VALUE_AVI_CONTENTTYPE_GAME
NV_INFOFRAME_FIELD_VALUE_AVI_CONTENTTYPE_AUTO

◆ NV_INFOFRAME_FIELD_VALUE_AVI_EXTENDEDCOLORIMETRY

enum NV_INFOFRAME_FIELD_VALUE_AVI_EXTENDEDCOLORIMETRY
Enumerator
NV_INFOFRAME_FIELD_VALUE_AVI_EXTENDEDCOLORIMETRY_XVYCC601
NV_INFOFRAME_FIELD_VALUE_AVI_EXTENDEDCOLORIMETRY_XVYCC709
NV_INFOFRAME_FIELD_VALUE_AVI_EXTENDEDCOLORIMETRY_SYCC601
NV_INFOFRAME_FIELD_VALUE_AVI_EXTENDEDCOLORIMETRY_ADOBEYCC601
NV_INFOFRAME_FIELD_VALUE_AVI_EXTENDEDCOLORIMETRY_ADOBERGB
NV_INFOFRAME_FIELD_VALUE_AVI_EXTENDEDCOLORIMETRY_RESERVED05
NV_INFOFRAME_FIELD_VALUE_AVI_EXTENDEDCOLORIMETRY_RESERVED06
NV_INFOFRAME_FIELD_VALUE_AVI_EXTENDEDCOLORIMETRY_RESERVED07
NV_INFOFRAME_FIELD_VALUE_AVI_EXTENDEDCOLORIMETRY_AUTO

◆ NV_INFOFRAME_FIELD_VALUE_AVI_F17

enum NV_INFOFRAME_FIELD_VALUE_AVI_F17
Enumerator
NV_INFOFRAME_FIELD_VALUE_AVI_F17_FALSE
NV_INFOFRAME_FIELD_VALUE_AVI_F17_TRUE
NV_INFOFRAME_FIELD_VALUE_AVI_F17_AUTO

◆ NV_INFOFRAME_FIELD_VALUE_AVI_ITC

enum NV_INFOFRAME_FIELD_VALUE_AVI_ITC
Enumerator
NV_INFOFRAME_FIELD_VALUE_AVI_ITC_VIDEO_CONTENT
NV_INFOFRAME_FIELD_VALUE_AVI_ITC_ITCONTENT
NV_INFOFRAME_FIELD_VALUE_AVI_ITC_AUTO

◆ NV_INFOFRAME_FIELD_VALUE_AVI_NONUNIFORMPICTURESCALING

enum NV_INFOFRAME_FIELD_VALUE_AVI_NONUNIFORMPICTURESCALING

Byte 3 related.

Enumerator
NV_INFOFRAME_FIELD_VALUE_AVI_NONUNIFORMPICTURESCALING_NO_DATA
NV_INFOFRAME_FIELD_VALUE_AVI_NONUNIFORMPICTURESCALING_HORIZONTAL
NV_INFOFRAME_FIELD_VALUE_AVI_NONUNIFORMPICTURESCALING_VERTICAL
NV_INFOFRAME_FIELD_VALUE_AVI_NONUNIFORMPICTURESCALING_BOTH
NV_INFOFRAME_FIELD_VALUE_AVI_NONUNIFORMPICTURESCALING_AUTO

◆ NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION

enum NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION

Byte 4 related.

Enumerator
NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_NONE
NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_X02
NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_X03
NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_X04
NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_X05
NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_X06
NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_X07
NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_X08
NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_X09
NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_X10
NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_RESERVED10
NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_RESERVED11
NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_RESERVED12
NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_RESERVED13
NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_RESERVED14
NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_RESERVED15
NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_AUTO

◆ NV_INFOFRAME_FIELD_VALUE_AVI_RGBQUANTIZATION

enum NV_INFOFRAME_FIELD_VALUE_AVI_RGBQUANTIZATION
Enumerator
NV_INFOFRAME_FIELD_VALUE_AVI_RGBQUANTIZATION_DEFAULT
NV_INFOFRAME_FIELD_VALUE_AVI_RGBQUANTIZATION_LIMITED_RANGE
NV_INFOFRAME_FIELD_VALUE_AVI_RGBQUANTIZATION_FULL_RANGE
NV_INFOFRAME_FIELD_VALUE_AVI_RGBQUANTIZATION_RESERVED
NV_INFOFRAME_FIELD_VALUE_AVI_RGBQUANTIZATION_AUTO

◆ NV_INFOFRAME_FIELD_VALUE_AVI_SCANINFO

enum NV_INFOFRAME_FIELD_VALUE_AVI_SCANINFO

Byte1 related.

Enumerator
NV_INFOFRAME_FIELD_VALUE_AVI_SCANINFO_NODATA
NV_INFOFRAME_FIELD_VALUE_AVI_SCANINFO_OVERSCAN
NV_INFOFRAME_FIELD_VALUE_AVI_SCANINFO_UNDERSCAN
NV_INFOFRAME_FIELD_VALUE_AVI_SCANINFO_FUTURE
NV_INFOFRAME_FIELD_VALUE_AVI_SCANINFO_AUTO

◆ NV_INFOFRAME_FIELD_VALUE_AVI_YCCQUANTIZATION

enum NV_INFOFRAME_FIELD_VALUE_AVI_YCCQUANTIZATION
Enumerator
NV_INFOFRAME_FIELD_VALUE_AVI_YCCQUANTIZATION_LIMITED_RANGE
NV_INFOFRAME_FIELD_VALUE_AVI_YCCQUANTIZATION_FULL_RANGE
NV_INFOFRAME_FIELD_VALUE_AVI_YCCQUANTIZATION_RESERVED02
NV_INFOFRAME_FIELD_VALUE_AVI_YCCQUANTIZATION_RESERVED03
NV_INFOFRAME_FIELD_VALUE_AVI_YCCQUANTIZATION_AUTO

◆ NV_INFOFRAME_PROPERTY_BLACKLIST

enum NV_INFOFRAME_PROPERTY_BLACKLIST

Returns whether the current monitor is in blacklist or force this monitor to be in blacklist.

Enumerator
NV_INFOFRAME_PROPERTY_BLACKLIST_FALSE
NV_INFOFRAME_PROPERTY_BLACKLIST_TRUE

◆ NV_INFOFRAME_PROPERTY_MODE

enum NV_INFOFRAME_PROPERTY_MODE
Enumerator
NV_INFOFRAME_PROPERTY_MODE_AUTO | Driver determines whether to send infoframes.
NV_INFOFRAME_PROPERTY_MODE_ENABLE | Driver always sends infoframe.
NV_INFOFRAME_PROPERTY_MODE_DISABLE | Driver never sends infoframe.
NV_INFOFRAME_PROPERTY_MODE_ALLOW_OVERRIDE | Driver only sends infoframe when client requests it via infoframe escape call.

◆ NV_MONITOR_CAPS_TYPE

enum NV_MONITOR_CAPS_TYPE

HDMI-related and extended CAPs.

Enumerator
NV_MONITOR_CAPS_TYPE_HDMI_VSDB
NV_MONITOR_CAPS_TYPE_HDMI_VCDB
NV_MONITOR_CAPS_TYPE_GENERIC

◆ NV_QSYNC_EVENT

enum NV_QSYNC_EVENT
Enumerator
NV_QSYNC_EVENT_NONE
NV_QSYNC_EVENT_SYNC_LOSS
NV_QSYNC_EVENT_SYNC_GAIN
NV_QSYNC_EVENT_HOUSESYNC_GAIN
NV_QSYNC_EVENT_HOUSESYNC_LOSS
NV_QSYNC_EVENT_RJ45_GAIN
NV_QSYNC_EVENT_RJ45_LOSS

◆ NV_STATIC_METADATA_DESCRIPTOR_ID

enum NV_STATIC_METADATA_DESCRIPTOR_ID
Enumerator
NV_STATIC_METADATA_TYPE_1

Tells the type of structure used to define the Static Metadata Descriptor block.

Function Documentation

◆ __nvapi_deprecated_function()

__nvapi_deprecated_function ( "Do not use this function - it is deprecated in release 319." )

DESCRIPTION: This API enumerates one or more compute-capable GPUs. Note that this API is deprecated and should no longer be used for new software development.

Since
Release: 180
Parameters
[in,out] pComputeTopo Pointer to the structure NV_COMPUTE_GPU_TOPOLOGY.
Return values
NVAPI_OK | The request was completed successfully. The gpuCount indicates if one or more compute-capable GPUs are found. gpuCount >= 1 means atleast one compute-capable GPU is found.
NVAPI_INCOMPATIBLE_STRUCT_VERSION | Structure version is not supported, initialize to NV_COMPUTE_GPU_TOPOLOGY_VER.
NVAPI_ERROR | Enumeration of the GPUs failed. Make sure at least one NVIDIA GPU exists in the system.

◆ NvAPI_Disp_ColorControl()

NvAPI_Disp_ColorControl | ( | NvU32 | displayId,
 |  | NV_COLOR_DATA * | pColorData
 | ) |  |

DESCRIPTION: This API controls the Color values.

SUPPORTED OS: Windows 7 and higher

Parameters
[in] | displayId | Monitor Identifier
[in,out] | pColorData | Contains data corresponding to color information
Returns
RETURN STATUS: NVAPI_OK, NVAPI_ERROR, NVAPI_INVALID_ARGUMENT

◆ NvAPI_DISP_GetEdidData()

NVAPI_INTERFACE NvAPI_DISP_GetEdidData | ( | __in NvU32 | displayId,
 |  | __inout NV_EDID_DATA * | pEdidParams,
 |  | __inout NV_EDID_FLAG * | pFlag
 | ) |  |
DESCRIPTION: This API returns the EDID data for the specified display Id.
(NvAPI_GPU_GetConnectedDisplayIds() can be used to get the DisplayIds).
USAGE: The caller has to call this API two times to fetch the required details as follows:
First Pass : Caller should call NvAPI_DISP_GetEdidData() with pEdidParams->pEDID set to NULL,
to get the size of the EDID buffer in pEdidParams->sizeOfEDID.
Second Pass: Allocate memory for the EDID buffer of the size - pEdidParams->sizeOfEDID,
and call the API again to get the EDID buffer populated.
\param [in] displayId - NVIDIA Display ID
\param [inout] pEdidParams - Pointer to the structure that contains - pointer to EDID buffer and its size
\param [inout] pFlag - The type of EDID to be retrieved (IN).
To only retrieve the EDID type, the user should send pEdidParams->pEDID as NULL and
pEdidParams->sizeOfEDID as 0.
SUPPORTED OS: Windows 7 and higher
\since Release: 400
\return This API can return any of the error codes enumerated in #NvAPI_Status.
If there are return error codes with specific meaning for this API, they are listed below.
NVAPI_INSUFFICIENT_BUFFER: Reallocate buffer with pEdidParams->sizeOfEDID and call again to get complete data.
In this case pEdidParams->pEDID contains undefined data.
This error occurs only when pEdidParams->pEDID is present.

◆ NvAPI_Disp_GetHdrCapabilities()

NVAPI_INTERFACE NvAPI_Disp_GetHdrCapabilities | ( | __in NvU32 | displayId,
 |  | __inout NV_HDR_CAPABILITIES * | pHdrCapabilities
 | ) |  |

◆ NvAPI_Disp_GetHdrToneMapping()

NvAPI_Disp_GetHdrToneMapping | ( | __in NvU32 | displayId,
 |  | __inout NV_HDR_TONEMAPPING_METHOD * | pHdrTonemapping
 | ) |  |

DESCRIPTION: This API gets HDR tonemapping method for the display.

SUPPORTED OS: Windows 7 and higher

Since
Release: 525
Parameters
[in] | displayId | display identifier
[out] | pHdrTonemapping | HDR tonemapping method
Returns
This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.

◆ NvAPI_Disp_GetOutputMode()

NvAPI_Disp_GetOutputMode | ( | __in NvU32 | displayId,
 |  | __inout NV_DISPLAY_OUTPUT_MODE * | pDisplayMode
 | ) |  |

DESCRIPTION: This API gets display output mode.

SUPPORTED OS: Windows 7 and higher

Since
Release: 525
Parameters
[in] | displayId | Display identifier
[out] | pDisplayMode | Current display output mode
Returns
This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.

◆ NvAPI_Disp_GetSourceColorSpace()

NVAPI_INTERFACE NvAPI_Disp_GetSourceColorSpace | ( | __in NvU32 | displayId,
 |  | __inout NV_COLORSPACE_TYPE * | pColorSpaceType,
 |  | NvU64 | sourcePID
 | ) |  |

DESCRIPTION: This API sets HDR metadata of the source identified by the process id of the caller

SUPPORTED OS: Windows 7 and higher

Since
Release: 525
Parameters
[in] | displayId | Monitor Identifier
[in] | pMetadata | HDR metadata
Returns
This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.

◆ NvAPI_Disp_GetSourceHdrMetadata()

NVAPI_INTERFACE NvAPI_Disp_GetSourceHdrMetadata | ( | __in NvU32 | displayId,
 |  | __inout NV_HDR_METADATA * | pMetadata,
 |  | NvU64 | sourcePID
 | ) |  |

DESCRIPTION: This API sets HDR metadata of the source identified by the process id of the caller

SUPPORTED OS: Windows 7 and higher

Since
Release: 525
Parameters
[in] | displayId | Monitor Identifier
[in] | pMetadata | HDR metadata
Returns
This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.

◆ NvAPI_Disp_HdrColorControl()

NVAPI_INTERFACE NvAPI_Disp_HdrColorControl | ( | __in NvU32 | displayId,
 |  | __inout NV_HDR_COLOR_DATA * | pHdrColorData
 | ) |  |

DESCRIPTION: This API sets HDR metadata of the source identified by the process id of the caller

SUPPORTED OS: Windows 7 and higher

Since
Release: 525
Parameters
[in] | displayId | Monitor Identifier
[in] | pMetadata | HDR metadata
Returns
This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.

◆ NvAPI_Disp_SetHdrToneMapping()

NvAPI_Disp_SetHdrToneMapping | ( | __in NvU32 | displayId,
 |  | __in NV_HDR_TONEMAPPING_METHOD | hdrTonemapping
 | ) |  |

DESCRIPTION: This API sets HDR tonemapping method for the display

SUPPORTED OS: Windows 7 and higher

Since
Release: 525
Parameters
[in] | displayId | Display identifier
[in] | hdrTonemapping | HDR tonemapping method
Returns
This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.

◆ NvAPI_Disp_SetOutputMode()

NvAPI_Disp_SetOutputMode | ( | __in NvU32 | displayId,
 |  | __inout NV_DISPLAY_OUTPUT_MODE * | pDisplayMode
 | ) |  |

DESCRIPTION: This API sets display output mode and returns the display output mode used by the OS before the API call. Only one application at a time can override OS display output mode.

SUPPORTED OS: Windows 7 and higher

Since
Release: 525
Parameters
[in] | displayId | Display identifier
[in,out] | pDisplayMode | New/original display output mode
Returns
This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.
Return values
NVAPI_RESOURCE_IN_USE the output mode can't be changed as it is already overriden by another application.

◆ NvAPI_Disp_SetSourceColorSpace()

NVAPI_INTERFACE NvAPI_Disp_SetSourceColorSpace | ( | __in NvU32 | displayId,
 |  | __in NV_COLORSPACE_TYPE | colorSpaceType
 | ) |  |

DESCRIPTION: This API sets HDR metadata of the source identified by the process id of the caller

SUPPORTED OS: Windows 7 and higher

Since
Release: 525
Parameters
[in] | displayId | Monitor Identifier
[in] | pMetadata | HDR metadata
Returns
This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.

◆ NvAPI_Disp_SetSourceHdrMetadata()

NvAPI_Disp_SetSourceHdrMetadata | ( | __in NvU32 | displayId,
 |  | __in NV_HDR_METADATA * | pMetadata
 | ) |  |

DESCRIPTION: This API sets HDR metadata of the source identified by the process id of the caller

SUPPORTED OS: Windows 7 and higher

Since
Release: 525
Parameters
[in] | displayId | Monitor Identifier
[in] | pMetadata | HDR metadata
Returns
This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.

◆ NvAPI_GPU_ClientIllumDevicesGetControl()

NVAPI_INTERFACE NvAPI_GPU_ClientIllumDevicesGetControl | ( | __in NvPhysicalGpuHandle | hPhysicalGpu,
 |  | __inout NV_GPU_CLIENT_ILLUM_DEVICE_CONTROL_PARAMS * | pClientIllumDevicesControl
 | ) |  |

FUNCTION NAME: NvAPI_GPU_ClientIllumDevicesGetControl

DESCRIPTION: This API gets control parameters about illumination devices on the given GPU. SUPPORTED OS: Windows 7 and higher

TCC_SUPPORTED

MCDM_SUPPORTED

Since
Release: 400
Parameters
[in] | hPhysicalGpu | The physical GPU handle
[in,out] | pIllumDevicesControl | Pointer to structure containing control information about illum devices.
Returns
This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.

◆ NvAPI_GPU_ClientIllumDevicesGetInfo()

NVAPI_INTERFACE NvAPI_GPU_ClientIllumDevicesGetInfo | ( | __in NvPhysicalGpuHandle | hPhysicalGpu,
 |  | __inout NV_GPU_CLIENT_ILLUM_DEVICE_INFO_PARAMS * | pIllumDevicesInfo
 | ) |  |

FUNCTION NAME: NvAPI_GPU_ClientIllumDevicesGetInfo

DESCRIPTION: This API returns static information about illumination devices on the given GPU. SUPPORTED OS: Windows 7 and higher

TCC_SUPPORTED

MCDM_SUPPORTED

Since
Release: 400
Parameters
[in] | hPhysicalGpu | The physical GPU handle
[out] | pIllumDevicesInfo | Pointer to structure containing static information about illumination devices.
Returns
This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.

◆ NvAPI_GPU_ClientIllumDevicesSetControl()

NVAPI_INTERFACE NvAPI_GPU_ClientIllumDevicesSetControl | ( | __in NvPhysicalGpuHandle | hPhysicalGpu,
 |  | __inout NV_GPU_CLIENT_ILLUM_DEVICE_CONTROL_PARAMS * | pClientIllumDevicesControl
 | ) |  |

FUNCTION NAME: NvAPI_GPU_ClientIllumDevicesSetControl

DESCRIPTION: This API sets control parameters about illumination devices on the given GPU. SUPPORTED OS: Windows 7 and higher

TCC_SUPPORTED

MCDM_SUPPORTED

Since
Release: 400
Parameters
[in] | hPhysicalGpu | The physical GPU handle
[in,out] | pClientIllumDevicesControl | Pointer to structure containing control information about illum devices.
Returns
This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.

◆ NvAPI_GPU_ClientIllumZonesGetControl()

NVAPI_INTERFACE NvAPI_GPU_ClientIllumZonesGetControl | ( | __in NvPhysicalGpuHandle | hPhysicalGpu,
 |  | __inout NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_PARAMS * | pIllumZonesControl
 | ) |  |

FUNCTION NAME: NvAPI_GPU_ClientIllumZonesGetControl

DESCRIPTION: Accessor for control information about illumination zones on the given GPU. SUPPORTED OS: Windows 7 and higher

TCC_SUPPORTED

MCDM_SUPPORTED

Since
Release: 400
Parameters
[in] | hPhysicalGpu | The physical GPU handle
[out] | pIllumZonesControl | Pointer to structure containing control information about illumination zones.
Returns
This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.

◆ NvAPI_GPU_ClientIllumZonesGetInfo()

NVAPI_INTERFACE NvAPI_GPU_ClientIllumZonesGetInfo | ( | __in NvPhysicalGpuHandle | hPhysicalGpu,
 |  | __inout NV_GPU_CLIENT_ILLUM_ZONE_INFO_PARAMS * | pIllumZonesInfo
 | ) |  |

FUNCTION NAME: NvAPI_GPU_ClientIllumZonesGetInfo

DESCRIPTION: This API returns static information about illumination zones on the given GPU. SUPPORTED OS: Windows 7 and higher

TCC_SUPPORTED

MCDM_SUPPORTED

Since
Release: 400
Parameters
[in] | hPhysicalGpu | The physical GPU handle
[out] | pIllumZonesInfo | Pointer to structure containing static information about illumination devices.
Returns
This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.

◆ NvAPI_GPU_ClientIllumZonesSetControl()

NVAPI_INTERFACE NvAPI_GPU_ClientIllumZonesSetControl | ( | __in NvPhysicalGpuHandle | hPhysicalGpu,
 |  | __inout NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_PARAMS * | pIllumZonesControl
 | ) |  |

FUNCTION NAME: NvAPI_GPU_ClientIllumZonesSetControl

DESCRIPTION: Mutator for control information about illumination zones on the given GPU. SUPPORTED OS: Windows 7 and higher

TCC_SUPPORTED

MCDM_SUPPORTED

Since
Release: 400
Parameters
[in] | hPhysicalGpu | The physical GPU handle
[out] | pIllumZonesControl | Pointer to structure containing control information about illumination zones.
Returns
This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.

◆ NvAPI_GPU_NVLINK_GetCaps()

NVAPI_INTERFACE NvAPI_GPU_NVLINK_GetCaps | ( | __in NvPhysicalGpuHandle | hPhysicalGpu,
 |  | __inout NVLINK_GET_CAPS * | capsParams
 | ) |  |

DESCRIPTION: This function returns the NVLink capabilities supported by the GPU. SUPPORTED OS: Windows 7 and higher

Since
Release: 361
Parameters
[in] | hPhysicalGpu | GPU selection
[in,out] | NVLINK_GET_CAPS | This structure contains the output parameters. Also need to specify the version.
Return values
NVAPI_INVALID_USER_PRIVILEGE - The caller does not have administrative privileges
Returns
This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.

◆ NvAPI_GPU_NVLINK_GetStatus()

NVAPI_INTERFACE NvAPI_GPU_NVLINK_GetStatus | ( | __in NvPhysicalGpuHandle | hPhysicalGpu,
 |  | __inout NVLINK_GET_STATUS * | statusParams
 | ) |  |

DESCRIPTION: This function returns the NVLink status. SUPPORTED OS: Windows 7 and higher

Since
Release: 361
Parameters
[in] | hPhysicalGpu | GPU selection
[in,out] | NVLINK_GET_STATUS | This structure contains the input and output parameters. linkMask is the input param while others are output parameters. Also need to specify the version.
Return values
NVAPI_INVALID_USER_PRIVILEGE - The caller does not have administrative privileges
Returns
This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.

◆ NvAPI_Mosaic_EnumDisplayModes()

NVAPI_INTERFACE NvAPI_Mosaic_EnumDisplayModes | ( | __in NV_MOSAIC_GRID_TOPO * | pGridTopology,
 |  | __inout_ecount_part_opt *, *pDisplayCount NV_MOSAIC_DISPLAY_SETTING * | pDisplaySettings,
 |  | __inout NvU32 * | pDisplayCount
 | ) |  |

DESCRIPTION: Determines the set of available display modes for a given grid topology.

SUPPORTED OS: Windows 7 and higher

Parameters
[in] | pGridTopology | The grid topology to use.
[in,out] | pDisplaySettings | A pointer to an array of display settings to populate, or NULL to find out the total number of available modes.
[in,out] | pDisplayCount | If pDisplaySettings is not NULL, then pDisplayCount should point to the number of elements in the pDisplaySettings array. On return, it will contain the number of modes that were actually returned. If pDisplaySettings is NULL, then pDisplayCount will receive the total number of modes that are available.
Return values
NVAPI_OK | Capabilities have been returned.
NVAPI_INVALID_ARGUMENT | One or more args passed in are invalid.
NVAPI_API_NOT_INTIALIZED | The NvAPI API needs to be initialized first
NVAPI_NO_IMPLEMENTATION | This entrypoint not available
NVAPI_ERROR | Miscellaneous error occurred

◆ NvAPI_OGL_ExpertModeDefaultsGet()

NVAPI_INTERFACE NvAPI_OGL_ExpertModeDefaultsGet | ( | NvU32 * | pExpertDetailLevel,
 |  | NvU32 * | pExpertReportMask,
 |  | NvU32 * | pExpertOutputMask
 | ) |  |

Get uncached connected devices.

◆ NvAPI_OGL_ExpertModeDefaultsSet()

NVAPI_INTERFACE NvAPI_OGL_ExpertModeDefaultsSet | ( | NvU32 | expertDetailLevel,
 |  | NvU32 | expertReportMask,
 |  | NvU32 | expertOutputMask
 | ) |  |

This function configures OpenGL Expert Mode global defaults. These settings apply to any OpenGL application which starts up after these values are applied (i.e. these settings do not apply to currently running applications).

SUPPORTED OS: Windows 7 and higher

Since
Release: 80
Parameters
expertDetailLevel | Value which specifies the detail level in the feedback stream. This is a mask made up of NVAPI_OGLEXPERT_LEVEL bits.
expertReportMask | Mask made up of NVAPI_OGLEXPERT_REPORT bits, this parameter specifies the areas of functional interest.
expertOutputMask | Mask made up of NVAPI_OGLEXPERT_OUTPUT bits, this parameter specifies the feedback output location. Note that using OUTPUT_TO_CALLBACK here is meaningless and has no effect, but using it will not cause an error.
Returns
NVAPI_ERROR or NVAPI_OK

SUPPORTED OS: Windows 7 and higher

◆ NvAPI_OGL_ExpertModeGet()

NVAPI_INTERFACE NvAPI_OGL_ExpertModeGet | ( | NvU32 * | pExpertDetailLevel,
 |  | NvU32 * | pExpertReportMask,
 |  | NvU32 * | pExpertOutputMask,
 |  | NVAPI_OGLEXPERT_CALLBACK * | pExpertCallback
 | ) |  |

◆ NvAPI_OGL_ExpertModeSet()

NVAPI_INTERFACE NvAPI_OGL_ExpertModeSet | ( | NvU32 | expertDetailLevel,
 |  | NvU32 | expertReportMask,
 |  | NvU32 | expertOutputMask,
 |  | NVAPI_OGLEXPERT_CALLBACK | expertCallback
 | ) |  |

SUPPORTED OS: Windows 7 and higher

Variable Documentation

◆ inputFlags

NV_GPU_PERF_PSTATES_INFO NvU32 inputFlags

◆ pOSAdapterId

void* pOSAdapterId

◆ pOutputsMask

NvU32 * pOutputsMask

Get uncached connected devices.

◆ pPathCount

NV_DISPLAY_PATH_INFO NvU32* pPathCount

◆ pPathInfo

NV_DISPLAY_PATH_INFO * pPathInfo

◆ pPerfPstatesInfo

NV_GPU_PERF_PSTATES_INFO* pPerfPstatesInfo

◆ pTargetMaskCount

NV_VIEW_TARGET_INFO NvU32* pTargetMaskCount

◆ pTargets

NV_VIEW_TARGET_INFO* pTargets

◆ pTargetView

NV_VIEW_TARGET_INFO NvU32 NV_TARGET_VIEW_MODE* pTargetView

◆ pTargetViewMode

NV_DISPLAY_PATH_INFO NvU32 NV_TARGET_VIEW_MODE* pTargetViewMode


Modules
GPU APIs

Modules

GPU General Control Interface
GPU Performance Interface <br>
GPU Thermal Control Interface
GPU Performance State Interface
GPU Clock Control Interface
GPU Cooler Interface
GPU ECC Interface

Detailed Description

The GPU APIs retrieve and control various attributes of the GPU, such as outputs, VBIOS revision, APG rate, frame buffer size, and thermal settings.


Data Structures | Macros | Typedefs | Enumerations | Functions | Variables
GPU General Control Interface
GPU APIs | OpenGL APIs

Data Structures

struct | _NV_GPU_DISPLAYIDS
struct | _NV_BOARD_INFO
struct | NV_GPU_ARCH_INFO_V1
struct | NV_GPU_ARCH_INFO_V2
struct | NV_I2C_INFO_V1
struct | NV_I2C_INFO_V2
struct | NV_I2C_INFO_V3
struct | NV_GPU_GET_HDCP_SUPPORT_STATUS
struct | NV_COMPUTE_GPU_TOPOLOGY_V1
struct | _NV_COMPUTE_GPU
struct | _NV_COMPUTE_GPU_TOPOLOGY_V2
struct | NV_SCANOUT_INTENSITY_DATA_V1
struct | NV_SCANOUT_INTENSITY_DATA_V2
struct | _NV_SCANOUT_INTENSITY_STATE_DATA
struct | NV_SCANOUT_WARPING_DATA
struct | _NV_SCANOUT_WARPING_STATE_DATA
struct | _NV_SCANOUT_INFORMATION
struct | _NV_GPU_VIRTUALIZATION_INFO
struct | _NV_LOGICAL_GPU_DATA_V1
struct | _NV_GPU_GSP_INFO_V1
struct | _NV_GPU_QUERY_ILLUMINATION_SUPPORT_PARM_V1
struct | _NV_GPU_GET_ILLUMINATION_PARM_V1
struct | _NV_GPU_SET_ILLUMINATION_PARM_V1

Macros

#define | NV_EDID_DATA_SIZE_MAX 1024
#define | NV_GPU_DISPLAYIDS_VER1 MAKE_NVAPI_VERSION(NV_GPU_DISPLAYIDS,1)
#define | NV_GPU_DISPLAYIDS_VER2 MAKE_NVAPI_VERSION(NV_GPU_DISPLAYIDS,3)
#define | NV_GPU_DISPLAYIDS_VER NV_GPU_DISPLAYIDS_VER2
#define | NV_BOARD_INFO_VER1 MAKE_NVAPI_VERSION(NV_BOARD_INFO_V1,1)
#define | NV_BOARD_INFO_VER NV_BOARD_INFO_VER1
#define | NV_GPU_ARCH_INFO_VER_1 MAKE_NVAPI_VERSION(NV_GPU_ARCH_INFO_V1,1)
#define | NV_GPU_ARCH_INFO_VER_2 MAKE_NVAPI_VERSION(NV_GPU_ARCH_INFO_V2,2)
#define | NV_GPU_ARCH_INFO_VER NV_GPU_ARCH_INFO_VER_2
#define | NV_GPU_GET_HDCP_SUPPORT_STATUS_VER MAKE_NVAPI_VERSION(NV_GPU_GET_HDCP_SUPPORT_STATUS,1)
#define | NV_COMPUTE_GPU_TOPOLOGY_VER1 MAKE_NVAPI_VERSION(NV_COMPUTE_GPU_TOPOLOGY_V1,1)
#define | NV_COMPUTE_GPU_TOPOLOGY_VER MAKE_NVAPI_VERSION(NV_COMPUTE_GPU_TOPOLOGY_V2,2)
#define | NV_SCANOUT_INTENSITY_DATA_VER1 MAKE_NVAPI_VERSION(NV_SCANOUT_INTENSITY_DATA_V1, 1)
#define | NV_SCANOUT_INTENSITY_STATE_VER MAKE_NVAPI_VERSION(NV_SCANOUT_INTENSITY_STATE_DATA, 1)
#define | NV_SCANOUT_WARPING_VER MAKE_NVAPI_VERSION(NV_SCANOUT_WARPING_DATA, 1)
#define | NV_SCANOUT_WARPING_STATE_VER MAKE_NVAPI_VERSION(NV_SCANOUT_WARPING_STATE_DATA, 1)
#define | NV_GPU_VIRTUALIZATION_INFO_VER1 MAKE_NVAPI_VERSION(NV_GPU_VIRTUALIZATION_INFO_V1,1)
#define | NV_GPU_VIRTUALIZATION_INFO_VER NV_GPU_VIRTUALIZATION_INFO_VER1
#define | NVAPI_GPU_MAX_BUILD_VERSION_LENGTH (0x0000040)
#define | NV_GPU_GSP_INFO_VER1 MAKE_NVAPI_VERSION(NV_GPU_GSP_INFO_V1, 1)
#define | NV_GPU_QUERY_ILLUMINATION_SUPPORT_PARM_VER_1 MAKE_NVAPI_VERSION(NV_GPU_QUERY_ILLUMINATION_SUPPORT_PARM_V1,1)
#define | NV_GPU_QUERY_ILLUMINATION_SUPPORT_PARM_VER NV_GPU_QUERY_ILLUMINATION_SUPPORT_PARM_VER_1
#define | NV_GPU_GET_ILLUMINATION_PARM_VER_1 MAKE_NVAPI_VERSION(NV_GPU_GET_ILLUMINATION_PARM_V1,1)
#define | NV_GPU_GET_ILLUMINATION_PARM_VER NV_GPU_GET_ILLUMINATION_PARM_VER_1
#define | NV_GPU_SET_ILLUMINATION_PARM_VER_1 MAKE_NVAPI_VERSION(NV_GPU_SET_ILLUMINATION_PARM_V1,1)
#define | NV_GPU_SET_ILLUMINATION_PARM_VER NV_GPU_SET_ILLUMINATION_PARM_VER_1

Typedefs

typedef enum _NV_GPU_CONNECTOR_TYPE | NV_GPU_CONNECTOR_TYPE
typedef struct _NV_GPU_DISPLAYIDS | NV_GPU_DISPLAYIDS
typedef enum _NV_GPU_OUTPUT_TYPE | NV_GPU_OUTPUT_TYPE
typedef enum _NV_GPU_TYPE | NV_GPU_TYPE
typedef enum _NV_GPU_BUS_TYPE | NV_GPU_BUS_TYPE
typedef struct _NV_BOARD_INFO | NV_BOARD_INFO_V1
typedef NV_BOARD_INFO_V1 | NV_BOARD_INFO
typedef enum _NV_GPU_ARCHITECTURE_ID | NV_GPU_ARCHITECTURE_ID
typedef enum _NV_GPU_ARCH_IMPLEMENTATION_ID | NV_GPU_ARCH_IMPLEMENTATION_ID
typedef enum _NV_GPU_CHIP_REVISION | NV_GPU_CHIP_REVISION
typedef NV_GPU_ARCH_INFO_V2 | NV_GPU_ARCH_INFO
typedef enum _NV_GPU_HDCP_FUSE_STATE | NV_GPU_HDCP_FUSE_STATE
typedef enum _NV_GPU_HDCP_KEY_SOURCE | NV_GPU_HDCP_KEY_SOURCE
typedef enum _NV_GPU_HDCP_KEY_SOURCE_STATE | NV_GPU_HDCP_KEY_SOURCE_STATE
typedef struct _NV_COMPUTE_GPU | NV_COMPUTE_GPU
typedef struct _NV_COMPUTE_GPU_TOPOLOGY_V2 | NV_COMPUTE_GPU_TOPOLOGY_V2
typedef NV_COMPUTE_GPU_TOPOLOGY_V2 | NV_COMPUTE_GPU_TOPOLOGY
typedef enum _NV_GPU_WORKSTATION_FEATURE_TYPE | NV_GPU_WORKSTATION_FEATURE_TYPE
typedef struct _NV_SCANOUT_INTENSITY_STATE_DATA | NV_SCANOUT_INTENSITY_STATE_DATA
typedef struct _NV_SCANOUT_WARPING_STATE_DATA | NV_SCANOUT_WARPING_STATE_DATA
typedef struct _NV_SCANOUT_INFORMATION | NV_SCANOUT_INFORMATION
typedef enum _NV_VIRTUALIZATION_MODE | NV_VIRTUALIZATION_MODE
typedef struct _NV_GPU_VIRTUALIZATION_INFO | NV_GPU_VIRTUALIZATION_INFO_V1
typedef NV_GPU_VIRTUALIZATION_INFO_V1 | NV_GPU_VIRTUALIZATION_INFO
typedef struct _NV_LOGICAL_GPU_DATA_V1 | NV_LOGICAL_GPU_DATA_V1
typedef NV_LOGICAL_GPU_DATA_V1 | NV_LOGICAL_GPU_DATA
typedef struct _NV_GPU_GSP_INFO_V1 | NV_GPU_GSP_INFO_V1
typedef enum _NV_GPU_ILLUMINATION_ATTRIB | NV_GPU_ILLUMINATION_ATTRIB
typedef struct _NV_GPU_QUERY_ILLUMINATION_SUPPORT_PARM_V1 | NV_GPU_QUERY_ILLUMINATION_SUPPORT_PARM_V1
typedef NV_GPU_QUERY_ILLUMINATION_SUPPORT_PARM_V1 | NV_GPU_QUERY_ILLUMINATION_SUPPORT_PARM
typedef struct _NV_GPU_GET_ILLUMINATION_PARM_V1 | NV_GPU_GET_ILLUMINATION_PARM_V1
typedef NV_GPU_GET_ILLUMINATION_PARM_V1 | NV_GPU_GET_ILLUMINATION_PARM
typedef struct _NV_GPU_SET_ILLUMINATION_PARM_V1 | NV_GPU_SET_ILLUMINATION_PARM_V1
typedef NV_GPU_SET_ILLUMINATION_PARM_V1 | NV_GPU_SET_ILLUMINATION_PARM

Enumerations

enum _NV_GPU_CONNECTOR_TYPE {
NVAPI_GPU_CONNECTOR_VGA_15_PIN = 0x00000000 , NVAPI_GPU_CONNECTOR_TV_COMPOSITE = 0x00000010 , NVAPI_GPU_CONNECTOR_TV_SVIDEO = 0x00000011 , NVAPI_GPU_CONNECTOR_TV_HDTV_COMPONENT = 0x00000013 ,
NVAPI_GPU_CONNECTOR_TV_SCART = 0x00000014 , NVAPI_GPU_CONNECTOR_TV_COMPOSITE_SCART_ON_EIAJ4120 = 0x00000016 , NVAPI_GPU_CONNECTOR_TV_HDTV_EIAJ4120 = 0x00000017 , NVAPI_GPU_CONNECTOR_PC_POD_HDTV_YPRPB = 0x00000018 ,
NVAPI_GPU_CONNECTOR_PC_POD_SVIDEO = 0x00000019 , NVAPI_GPU_CONNECTOR_PC_POD_COMPOSITE = 0x0000001A , NVAPI_GPU_CONNECTOR_DVI_I_TV_SVIDEO = 0x00000020 , NVAPI_GPU_CONNECTOR_DVI_I_TV_COMPOSITE = 0x00000021 ,
NVAPI_GPU_CONNECTOR_DVI_I = 0x00000030 , NVAPI_GPU_CONNECTOR_DVI_D = 0x00000031 , NVAPI_GPU_CONNECTOR_ADC = 0x00000032 , NVAPI_GPU_CONNECTOR_LFH_DVI_I_1 = 0x00000038 ,
NVAPI_GPU_CONNECTOR_LFH_DVI_I_2 = 0x00000039 , NVAPI_GPU_CONNECTOR_SPWG = 0x00000040 , NVAPI_GPU_CONNECTOR_OEM = 0x00000041 , NVAPI_GPU_CONNECTOR_DISPLAYPORT_EXTERNAL = 0x00000046 ,
NVAPI_GPU_CONNECTOR_DISPLAYPORT_INTERNAL = 0x00000047 , NVAPI_GPU_CONNECTOR_DISPLAYPORT_MINI_EXT = 0x00000048 , NVAPI_GPU_CONNECTOR_HDMI_A = 0x00000061 , NVAPI_GPU_CONNECTOR_HDMI_C_MINI = 0x00000063 ,
NVAPI_GPU_CONNECTOR_LFH_DISPLAYPORT_1 = 0x00000064 , NVAPI_GPU_CONNECTOR_LFH_DISPLAYPORT_2 = 0x00000065 , NVAPI_GPU_CONNECTOR_VIRTUAL_WFD = 0x00000070 , NVAPI_GPU_CONNECTOR_USB_C = 0x00000071 ,
NVAPI_GPU_CONNECTOR_UNKNOWN = 0xFFFFFFFF
}
enum | NV_SYSTEM_TYPE { NV_SYSTEM_TYPE_UNKNOWN = 0 , NV_SYSTEM_TYPE_LAPTOP = 1 , NV_SYSTEM_TYPE_DESKTOP = 2 }
enum | _NV_GPU_OUTPUT_TYPE { NVAPI_GPU_OUTPUT_UNKNOWN = 0 , NVAPI_GPU_OUTPUT_CRT = 1 , NVAPI_GPU_OUTPUT_DFP = 2 , NVAPI_GPU_OUTPUT_TV = 3 }
enum | _NV_GPU_TYPE { NV_SYSTEM_TYPE_GPU_UNKNOWN = 0 , NV_SYSTEM_TYPE_IGPU = 1 , NV_SYSTEM_TYPE_DGPU = 2 }
enum _NV_GPU_BUS_TYPE {
NVAPI_GPU_BUS_TYPE_UNDEFINED = 0 , NVAPI_GPU_BUS_TYPE_PCI = 1 , NVAPI_GPU_BUS_TYPE_AGP = 2 , NVAPI_GPU_BUS_TYPE_PCI_EXPRESS = 3 ,
NVAPI_GPU_BUS_TYPE_FPCI = 4 , NVAPI_GPU_BUS_TYPE_AXI = 5
}
enum _NV_GPU_ARCHITECTURE_ID {
NV_GPU_ARCHITECTURE_T2X = 0xE0000020 , NV_GPU_ARCHITECTURE_T3X = 0xE0000030 , NV_GPU_ARCHITECTURE_T4X = 0xE0000040 , NV_GPU_ARCHITECTURE_T12X = 0xE0000040 ,
NV_GPU_ARCHITECTURE_NV40 = 0x00000040 , NV_GPU_ARCHITECTURE_NV50 = 0x00000050 , NV_GPU_ARCHITECTURE_G78 = 0x00000060 , NV_GPU_ARCHITECTURE_G80 = 0x00000080 ,
NV_GPU_ARCHITECTURE_G90 = 0x00000090 , NV_GPU_ARCHITECTURE_GT200 = 0x000000A0 , NV_GPU_ARCHITECTURE_GF100 = 0x000000C0 , NV_GPU_ARCHITECTURE_GF110 = 0x000000D0 ,
NV_GPU_ARCHITECTURE_GK100 = 0x000000E0 , NV_GPU_ARCHITECTURE_GK110 = 0x000000F0 , NV_GPU_ARCHITECTURE_GK200 = 0x00000100 , NV_GPU_ARCHITECTURE_GM000 = 0x00000110 ,
NV_GPU_ARCHITECTURE_GM200 = 0x00000120 , NV_GPU_ARCHITECTURE_GP100 = 0x00000130 , NV_GPU_ARCHITECTURE_GV100 = 0x00000140 , NV_GPU_ARCHITECTURE_GV110 = 0x00000150 ,
NV_GPU_ARCHITECTURE_TU100 = 0x00000160 , NV_GPU_ARCHITECTURE_GA100 = 0x00000170 , NV_GPU_ARCHITECTURE_AD100 = 0x00000190
}
enum _NV_GPU_ARCH_IMPLEMENTATION_ID {
NV_GPU_ARCH_IMPLEMENTATION_T20 = 0x00000000 , NV_GPU_ARCH_IMPLEMENTATION_T30 = 0x00000000 , NV_GPU_ARCH_IMPLEMENTATION_T35 = 0x00000005 , NV_GPU_ARCH_IMPLEMENTATION_T40 = 0x00000000 ,
NV_GPU_ARCH_IMPLEMENTATION_T124 = 0x00000000 , NV_GPU_ARCH_IMPLEMENTATION_NV40 = 0x00000000 , NV_GPU_ARCH_IMPLEMENTATION_NV41 = 0x00000001 , NV_GPU_ARCH_IMPLEMENTATION_NV42 = 0x00000002 ,
NV_GPU_ARCH_IMPLEMENTATION_NV43 = 0x00000003 , NV_GPU_ARCH_IMPLEMENTATION_NV44 = 0x00000004 , NV_GPU_ARCH_IMPLEMENTATION_NV44A = 0x0000000A , NV_GPU_ARCH_IMPLEMENTATION_NV46 = 0x00000006 ,
NV_GPU_ARCH_IMPLEMENTATION_NV47 = 0x00000007 , NV_GPU_ARCH_IMPLEMENTATION_NV49 = 0x00000009 , NV_GPU_ARCH_IMPLEMENTATION_NV4B = 0x0000000B , NV_GPU_ARCH_IMPLEMENTATION_NV4C = 0x0000000C ,
NV_GPU_ARCH_IMPLEMENTATION_NV4E = 0x0000000E , NV_GPU_ARCH_IMPLEMENTATION_NV50 = 0x00000000 , NV_GPU_ARCH_IMPLEMENTATION_NV63 = 0x00000003 , NV_GPU_ARCH_IMPLEMENTATION_NV67 = 0x00000007 ,
NV_GPU_ARCH_IMPLEMENTATION_G84 = 0x00000004 , NV_GPU_ARCH_IMPLEMENTATION_G86 = 0x00000006 , NV_GPU_ARCH_IMPLEMENTATION_G92 = 0x00000002 , NV_GPU_ARCH_IMPLEMENTATION_G94 = 0x00000004 ,
NV_GPU_ARCH_IMPLEMENTATION_G96 = 0x00000006 , NV_GPU_ARCH_IMPLEMENTATION_G98 = 0x00000008 , NV_GPU_ARCH_IMPLEMENTATION_GT200 = 0x00000000 , NV_GPU_ARCH_IMPLEMENTATION_GT212 = 0x00000002 ,
NV_GPU_ARCH_IMPLEMENTATION_GT214 = 0x00000004 , NV_GPU_ARCH_IMPLEMENTATION_GT215 = 0x00000003 , NV_GPU_ARCH_IMPLEMENTATION_GT216 = 0x00000005 , NV_GPU_ARCH_IMPLEMENTATION_GT218 = 0x00000008 ,
NV_GPU_ARCH_IMPLEMENTATION_MCP77 = 0x0000000A , NV_GPU_ARCH_IMPLEMENTATION_GT21C = 0x0000000B , NV_GPU_ARCH_IMPLEMENTATION_MCP79 = 0x0000000C , NV_GPU_ARCH_IMPLEMENTATION_GT21A = 0x0000000D ,
NV_GPU_ARCH_IMPLEMENTATION_MCP89 = 0x0000000F , NV_GPU_ARCH_IMPLEMENTATION_GF100 = 0x00000000 , NV_GPU_ARCH_IMPLEMENTATION_GF104 = 0x00000004 , NV_GPU_ARCH_IMPLEMENTATION_GF106 = 0x00000003 ,
NV_GPU_ARCH_IMPLEMENTATION_GF108 = 0x00000001 , NV_GPU_ARCH_IMPLEMENTATION_GF110 = 0x00000000 , NV_GPU_ARCH_IMPLEMENTATION_GF116 = 0x00000006 , NV_GPU_ARCH_IMPLEMENTATION_GF117 = 0x00000007 ,
NV_GPU_ARCH_IMPLEMENTATION_GF118 = 0x00000008 , NV_GPU_ARCH_IMPLEMENTATION_GF119 = 0x00000009 , NV_GPU_ARCH_IMPLEMENTATION_GK104 = 0x00000004 , NV_GPU_ARCH_IMPLEMENTATION_GK106 = 0x00000006 ,
NV_GPU_ARCH_IMPLEMENTATION_GK107 = 0x00000007 , NV_GPU_ARCH_IMPLEMENTATION_GK20A = 0x0000000A , NV_GPU_ARCH_IMPLEMENTATION_GK110 = 0x00000000 , NV_GPU_ARCH_IMPLEMENTATION_GK208 = 0x00000008 ,
NV_GPU_ARCH_IMPLEMENTATION_GM204 = 0x00000004 , NV_GPU_ARCH_IMPLEMENTATION_GM206 = 0x00000006 , NV_GPU_ARCH_IMPLEMENTATION_GP100 = 0x00000000 , NV_GPU_ARCH_IMPLEMENTATION_GP000 = 0x00000001 ,
NV_GPU_ARCH_IMPLEMENTATION_GP102 = 0x00000002 , NV_GPU_ARCH_IMPLEMENTATION_GP104 = 0x00000004 , NV_GPU_ARCH_IMPLEMENTATION_GP106 = 0x00000006 , NV_GPU_ARCH_IMPLEMENTATION_GP107 = 0x00000007 ,
NV_GPU_ARCH_IMPLEMENTATION_GP108 = 0x00000008 , NV_GPU_ARCH_IMPLEMENTATION_GV100 = 0x00000000 , NV_GPU_ARCH_IMPLEMENTATION_GV10B = 0x0000000B , NV_GPU_ARCH_IMPLEMENTATION_TU100 = 0x00000000 ,
NV_GPU_ARCH_IMPLEMENTATION_TU102 = 0x00000002 , NV_GPU_ARCH_IMPLEMENTATION_TU104 = 0x00000004 , NV_GPU_ARCH_IMPLEMENTATION_TU106 = 0x00000006 , NV_GPU_ARCH_IMPLEMENTATION_TU116 = 0x00000008 ,
NV_GPU_ARCH_IMPLEMENTATION_TU117 = 0x00000007 , NV_GPU_ARCH_IMPLEMENTATION_TU000 = 0x00000001 , NV_GPU_ARCH_IMPLEMENTATION_GA100 = 0x00000000 , NV_GPU_ARCH_IMPLEMENTATION_GA102 = 0x00000002 ,
NV_GPU_ARCH_IMPLEMENTATION_GA104 = 0x00000004 , NV_GPU_ARCH_IMPLEMENTATION_AD102 = 0x00000002 , NV_GPU_ARCH_IMPLEMENTATION_AD103 = 0x00000003 , NV_GPU_ARCH_IMPLEMENTATION_AD104 = 0x00000004
}
enum _NV_GPU_CHIP_REVISION {
NV_GPU_CHIP_REV_EMULATION_QT = 0x00000000 , NV_GPU_CHIP_REV_EMULATION_FPGA = 0x00000001 , NV_GPU_CHIP_REV_A01 = 0x00000011 , NV_GPU_CHIP_REV_A02 = 0x00000012 ,
NV_GPU_CHIP_REV_A03 = 0x00000013 , NV_GPU_CHIP_REV_UNKNOWN = 0xffffffff
}
enum NVAPI_GPU_WORKSTATION_FEATURE_MASK {
NVAPI_GPU_WORKSTATION_FEATURE_MASK_SWAPGROUP = 0x00000001 , NVAPI_GPU_WORKSTATION_FEATURE_MASK_STEREO = 0x00000010 , NVAPI_GPU_WORKSTATION_FEATURE_MASK_WARPING = 0x00000100 , NVAPI_GPU_WORKSTATION_FEATURE_MASK_PIXINTENSITY = 0x00000200 ,
NVAPI_GPU_WORKSTATION_FEATURE_MASK_GRAYSCALE = 0x00000400 , NVAPI_GPU_WORKSTATION_FEATURE_MASK_BPC10 = 0x00001000
}
enum | _NV_GPU_HDCP_FUSE_STATE { NV_GPU_HDCP_FUSE_STATE_UNKNOWN = 0 , NV_GPU_HDCP_FUSE_STATE_DISABLED = 1 , NV_GPU_HDCP_FUSE_STATE_ENABLED = 2 }
enum _NV_GPU_HDCP_KEY_SOURCE {
NV_GPU_HDCP_KEY_SOURCE_UNKNOWN = 0 , NV_GPU_HDCP_KEY_SOURCE_NONE = 1 , NV_GPU_HDCP_KEY_SOURCE_CRYPTO_ROM = 2 , NV_GPU_HDCP_KEY_SOURCE_SBIOS = 3 ,
NV_GPU_HDCP_KEY_SOURCE_I2C_ROM = 4 , NV_GPU_HDCP_KEY_SOURCE_FUSES = 5
}
enum | _NV_GPU_HDCP_KEY_SOURCE_STATE { NV_GPU_HDCP_KEY_SOURCE_STATE_UNKNOWN = 0 , NV_GPU_HDCP_KEY_SOURCE_STATE_ABSENT = 1 , NV_GPU_HDCP_KEY_SOURCE_STATE_PRESENT = 2 }
enum | _NV_GPU_WORKSTATION_FEATURE_TYPE { NV_GPU_WORKSTATION_FEATURE_TYPE_NVIDIA_RTX_VR_READY = 1 , NV_GPU_WORKSTATION_FEATURE_TYPE_QUADRO_VR_READY = NV_GPU_WORKSTATION_FEATURE_TYPE_NVIDIA_RTX_VR_READY , NV_GPU_WORKSTATION_FEATURE_TYPE_PROVIZ = 2 }
enum | NV_GPU_WARPING_VERTICE_FORMAT { NV_GPU_WARPING_VERTICE_FORMAT_TRIANGLESTRIP_XYUVRQ = 0 , NV_GPU_WARPING_VERTICE_FORMAT_TRIANGLES_XYUVRQ = 1 }
enum | _NV_VIRTUALIZATION_MODE { NV_VIRTUALIZATION_MODE_NONE = 0 , NV_VIRTUALIZATION_MODE_NMOS = 1 , NV_VIRTUALIZATION_MODE_VGX = 2 , NV_VIRTUALIZATION_MODE_HOST_VGPU = 3 }
enum | _NV_GPU_ILLUMINATION_ATTRIB { NV_GPU_IA_LOGO_BRIGHTNESS = 0 , NV_GPU_IA_SLI_BRIGHTNESS = 1 }

Functions

NVAPI_INTERFACE | NvAPI_GPU_GetEDID (NvPhysicalGpuHandle hPhysicalGpu, NvU32 displayOutputId, NV_EDID *pEDID)
NVAPI_INTERFACE | NvAPI_GPU_GetConnectedDisplayIds (__in NvPhysicalGpuHandle hPhysicalGpu, __inout_ecount_part_opt(*pDisplayIdCount, *pDisplayIdCount) NV_GPU_DISPLAYIDS *pDisplayIds, __inout NvU32 *pDisplayIdCount, __in NvU32 flags)
NVAPI_INTERFACE | NvAPI_GPU_GetAllDisplayIds (__in NvPhysicalGpuHandle hPhysicalGpu, __inout_ecount_part_opt(*pDisplayIdCount, *pDisplayIdCount) NV_GPU_DISPLAYIDS *pDisplayIds, __inout NvU32 *pDisplayIdCount)
NVAPI_INTERFACE | NvAPI_GPU_GetSystemType (NvPhysicalGpuHandle hPhysicalGpu, NV_SYSTEM_TYPE *pSystemType)
NVAPI_INTERFACE | NvAPI_GPU_GetActiveOutputs (NvPhysicalGpuHandle hPhysicalGpu, NvU32 *pOutputsMask)
NVAPI_INTERFACE | NvAPI_GPU_SetEDID (NvPhysicalGpuHandle hPhysicalGpu, NvU32 displayOutputId, NV_EDID *pEDID)
NVAPI_INTERFACE | NvAPI_GPU_GetOutputType (NvPhysicalGpuHandle hPhysicalGpu, NvU32 outputId, NV_GPU_OUTPUT_TYPE *pOutputType)
NVAPI_INTERFACE | NvAPI_GPU_ValidateOutputCombination (NvPhysicalGpuHandle hPhysicalGpu, NvU32 outputsMask)
NVAPI_INTERFACE | NvAPI_GPU_GetFullName (NvPhysicalGpuHandle hPhysicalGpu, NvAPI_ShortString szName)
NVAPI_INTERFACE | NvAPI_GPU_GetPCIIdentifiers (NvPhysicalGpuHandle hPhysicalGpu, NvU32 *pDeviceId, NvU32 *pSubSystemId, NvU32 *pRevisionId, NvU32 *pExtDeviceId)
NVAPI_INTERFACE | NvAPI_GPU_GetGPUType (__in NvPhysicalGpuHandle hPhysicalGpu, __inout NV_GPU_TYPE *pGpuType)
NVAPI_INTERFACE | NvAPI_GPU_GetBusType (NvPhysicalGpuHandle hPhysicalGpu, NV_GPU_BUS_TYPE *pBusType)
NVAPI_INTERFACE | NvAPI_GPU_GetBusId (NvPhysicalGpuHandle hPhysicalGpu, NvU32 *pBusId)
NVAPI_INTERFACE | NvAPI_GPU_GetBusSlotId (NvPhysicalGpuHandle hPhysicalGpu, NvU32 *pBusSlotId)
NVAPI_INTERFACE | NvAPI_GPU_GetIRQ (NvPhysicalGpuHandle hPhysicalGpu, NvU32 *pIRQ)
NVAPI_INTERFACE | NvAPI_GPU_GetVbiosRevision (NvPhysicalGpuHandle hPhysicalGpu, NvU32 *pBiosRevision)
NVAPI_INTERFACE | NvAPI_GPU_GetVbiosOEMRevision (NvPhysicalGpuHandle hPhysicalGpu, NvU32 *pBiosRevision)
NVAPI_INTERFACE | NvAPI_GPU_GetVbiosVersionString (NvPhysicalGpuHandle hPhysicalGpu, NvAPI_ShortString szBiosRevision)
__nvapi_deprecated_function ("Do not use this function - it is deprecated in release 455.") NVAPI_INTERFACE NvAPI_GPU_GetAGPAperture(NvPhysicalGpuHandle hPhysicalGpu
NVAPI_INTERFACE | NvAPI_GPU_GetCurrentPCIEDownstreamWidth (NvPhysicalGpuHandle hPhysicalGpu, NvU32 *pWidth)
NVAPI_INTERFACE | NvAPI_GPU_GetPhysicalFrameBufferSize (NvPhysicalGpuHandle hPhysicalGpu, NvU32 *pSize)
NVAPI_INTERFACE | NvAPI_GPU_GetVirtualFrameBufferSize (NvPhysicalGpuHandle hPhysicalGpu, NvU32 *pSize)
__nvapi_deprecated_function ("Do not use this function - it is deprecated in release 460.") NVAPI_INTERFACE NvAPI_GPU_GetQuadroStatus(NvPhysicalGpuHandle hPhysicalGpu
NVAPI_INTERFACE | NvAPI_GPU_GetBoardInfo (NvPhysicalGpuHandle hPhysicalGpu, NV_BOARD_INFO *pBoardInfo)
NVAPI_INTERFACE | NvAPI_GPU_GetRamBusWidth (NvPhysicalGpuHandle hPhysicalGpu, NvU32 *pBusWidth)
NVAPI_INTERFACE | NvAPI_GPU_GetArchInfo (NvPhysicalGpuHandle hPhysicalGpu, NV_GPU_ARCH_INFO *pGpuArchInfo)
NVAPI_INTERFACE | NvAPI_GPU_WorkstationFeatureSetup (__in NvPhysicalGpuHandle hPhysicalGpu, __in NvU32 featureEnableMask, __in NvU32 featureDisableMask)
NVAPI_INTERFACE | NvAPI_GPU_WorkstationFeatureQuery (__in NvPhysicalGpuHandle hPhysicalGpu, __out_opt NvU32 *pConfiguredFeatureMask, __out_opt NvU32 *pConsistentFeatureMask)
NVAPI_INTERFACE | NvAPI_GPU_GetHDCPSupportStatus (NvPhysicalGpuHandle hPhysicalGpu, NV_GPU_GET_HDCP_SUPPORT_STATUS *pGetHDCPSupportStatus)
NVAPI_INTERFACE | NvAPI_GPU_SetScanoutIntensity (NvU32 displayId, NV_SCANOUT_INTENSITY_DATA *scanoutIntensityData, int *pbSticky)
NVAPI_INTERFACE | NvAPI_GPU_GetScanoutIntensityState (__in NvU32 displayId, __inout NV_SCANOUT_INTENSITY_STATE_DATA *scanoutIntensityStateData)
NVAPI_INTERFACE | NvAPI_GPU_SetScanoutWarping (NvU32 displayId, NV_SCANOUT_WARPING_DATA *scanoutWarpingData, int *piMaxNumVertices, int *pbSticky)
NVAPI_INTERFACE | NvAPI_GPU_GetScanoutWarpingState (__in NvU32 displayId, __inout NV_SCANOUT_WARPING_STATE_DATA *scanoutWarpingStateData)
NVAPI_INTERFACE | NvAPI_GPU_SetScanoutCompositionParameter (NvU32 displayId, NV_GPU_SCANOUT_COMPOSITION_PARAMETER parameter, NV_GPU_SCANOUT_COMPOSITION_PARAMETER_VALUE parameterValue, float *pContainer)
NVAPI_INTERFACE | NvAPI_GPU_GetScanoutCompositionParameter (__in NvU32 displayId, __in NV_GPU_SCANOUT_COMPOSITION_PARAMETER parameter, __out NV_GPU_SCANOUT_COMPOSITION_PARAMETER_VALUE *parameterData, __out float *pContainer)
NVAPI_INTERFACE | NvAPI_GPU_GetScanoutConfiguration (NvU32 displayId, NvSBox *desktopRect, NvSBox *scanoutRect)
NVAPI_INTERFACE | NvAPI_GPU_GetScanoutConfigurationEx (__in NvU32 displayId, __inout NV_SCANOUT_INFORMATION *pScanoutInformation)
__nvapi_deprecated_function ("Do not use this function - it is deprecated in release 520. Instead, use NvAPI_GPU_GetLogicalGpuInfo.") NVAPI_INTERFACE NvAPI_GPU_GetAdapterIdFromPhysicalGpu(NvPhysicalGpuHandle hPhysicalGpu
NVAPI_INTERFACE | NvAPI_GPU_GetVirtualizationInfo (__in NvPhysicalGpuHandle hPhysicalGpu, __inout NV_GPU_VIRTUALIZATION_INFO *pVirtualizationInfo)
NVAPI_INTERFACE | NvAPI_GPU_GetLogicalGpuInfo (__in NvLogicalGpuHandle hLogicalGpu, __inout NV_LOGICAL_GPU_DATA *pLogicalGpuData)
NVAPI_INTERFACE | NvAPI_GPU_GetGPUInfo (__in NvPhysicalGpuHandle hPhysicalGpu, __inout NV_GPU_INFO *pGpuInfo)
NVAPI_INTERFACE | NvAPI_GPU_GetVRReadyData (__in NvPhysicalGpuHandle hPhysicalGpu, __inout NV_GPU_VR_READY *pGpuVrReadyData)
NVAPI_INTERFACE | NvAPI_GPU_GetGspFeatures (__in NvPhysicalGpuHandle hPhysicalGpu, __inout NV_GPU_GSP_INFO *pGspInfo)
NVAPI_INTERFACE | NvAPI_GPU_QueryIlluminationSupport (__inout NV_GPU_QUERY_ILLUMINATION_SUPPORT_PARM *pIlluminationSupportInfo)
NVAPI_INTERFACE | NvAPI_GPU_GetIllumination (NV_GPU_GET_ILLUMINATION_PARM *pIlluminationInfo)
NVAPI_INTERFACE | NvAPI_GPU_SetIllumination (NV_GPU_SET_ILLUMINATION_PARM *pIlluminationInfo)
NVAPI_INTERFACE | NvAPI_Event_RegisterCallback (PNV_EVENT_REGISTER_CALLBACK eventCallback, NvEventHandle *phClient)
NVAPI_INTERFACE | NvAPI_Event_UnregisterCallback (NvEventHandle hClient)
NVAPI_INTERFACE | NvAPI_DISP_GetNvManagedDedicatedDisplays (__inout NvU32 *pDedicatedDisplayCount, __inout NV_MANAGED_DEDICATED_DISPLAY_INFO *pDedicatedDisplays)
NVAPI_INTERFACE | NvAPI_DISP_GetNvManagedDedicatedDisplayMetadata (__inout NV_MANAGED_DEDICATED_DISPLAY_METADATA *pDedicatedDisplayMetadata)
NVAPI_INTERFACE | NvAPI_DISP_SetNvManagedDedicatedDisplayMetadata (__inout NV_MANAGED_DEDICATED_DISPLAY_METADATA *pDedicatedDisplayMetadata)
NVAPI_INTERFACE | NvAPI_DestroyPresentBarrierClient (__in NvPresentBarrierClientHandle presentBarrierClient)
NVAPI_INTERFACE | NvAPI_JoinPresentBarrier (__in NvPresentBarrierClientHandle presentBarrierClient, __in NV_JOIN_PRESENT_BARRIER_PARAMS *pParams)
NVAPI_INTERFACE | NvAPI_LeavePresentBarrier (__in NvPresentBarrierClientHandle presentBarrierClient)
NVAPI_INTERFACE | NvAPI_QueryPresentBarrierFrameStatistics (__in NvPresentBarrierClientHandle presentBarrierClient, __out NV_PRESENT_BARRIER_FRAME_STATISTICS *pFrameStats)
NVAPI_INTERFACE | NvAPI_SYS_GetDisplayDriverInfo (__inout NV_DISPLAY_DRIVER_INFO *pDriverInfo)
NVAPI_INTERFACE | NvAPI_EnumPhysicalGPUs (NvPhysicalGpuHandle nvGPUHandle[NVAPI_MAX_PHYSICAL_GPUS], NvU32 *pGpuCount)
NVAPI_INTERFACE | NvAPI_GPU_QueryWorkstationFeatureSupport (NvPhysicalGpuHandle physicalGpu, NV_GPU_WORKSTATION_FEATURE_TYPE gpuWorkstationFeature)

Variables

NvU32 * pSize
NvU32 * pRate
NvU32 * pStatus

NvAPI_OGL_ExpertModeDefaultsSet[Get] Functions

enum NV_MONITOR_CONN_TYPE {
NV_MONITOR_CONN_TYPE_UNINITIALIZED = 0 , NV_MONITOR_CONN_TYPE_VGA , NV_MONITOR_CONN_TYPE_COMPONENT , NV_MONITOR_CONN_TYPE_SVIDEO ,
NV_MONITOR_CONN_TYPE_HDMI , NV_MONITOR_CONN_TYPE_DVI , NV_MONITOR_CONN_TYPE_LVDS , NV_MONITOR_CONN_TYPE_DP ,
NV_MONITOR_CONN_TYPE_COMPOSITE , NV_MONITOR_CONN_TYPE_UNKNOWN = -1
}
NvU32 * pOutputsMask
NVAPI_INTERFACE | NvAPI_EnumTCCPhysicalGPUs (NvPhysicalGpuHandle nvGPUHandle[NVAPI_MAX_PHYSICAL_GPUS], NvU32 *pGpuCount)
NVAPI_INTERFACE | NvAPI_EnumLogicalGPUs (NvLogicalGpuHandle nvGPUHandle[NVAPI_MAX_LOGICAL_GPUS], NvU32 *pGpuCount)
NVAPI_INTERFACE | NvAPI_GetPhysicalGPUsFromDisplay (NvDisplayHandle hNvDisp, NvPhysicalGpuHandle nvGPUHandle[NVAPI_MAX_PHYSICAL_GPUS], NvU32 *pGpuCount)
NVAPI_INTERFACE | NvAPI_GetPhysicalGPUFromUnAttachedDisplay (NvUnAttachedDisplayHandle hNvUnAttachedDisp, NvPhysicalGpuHandle *pPhysicalGpu)
NVAPI_INTERFACE | NvAPI_GetLogicalGPUFromDisplay (NvDisplayHandle hNvDisp, NvLogicalGpuHandle *pLogicalGPU)
NVAPI_INTERFACE | NvAPI_GetLogicalGPUFromPhysicalGPU (NvPhysicalGpuHandle hPhysicalGPU, NvLogicalGpuHandle *pLogicalGPU)
NVAPI_INTERFACE | NvAPI_GetPhysicalGPUsFromLogicalGPU (NvLogicalGpuHandle hLogicalGPU, NvPhysicalGpuHandle hPhysicalGPU[NVAPI_MAX_PHYSICAL_GPUS], NvU32 *pGpuCount)
NVAPI_INTERFACE | NvAPI_GetPhysicalGPUFromGPUID (NvU32 gpuId, NvPhysicalGpuHandle *pPhysicalGPU)
NVAPI_INTERFACE | NvAPI_GetGPUIDfromPhysicalGPU (NvPhysicalGpuHandle hPhysicalGpu, NvU32 *pGpuId)
NVAPI_INTERFACE | NvAPI_GPU_GetShaderSubPipeCount (NvPhysicalGpuHandle hPhysicalGpu, NvU32 *pCount)
NVAPI_INTERFACE | NvAPI_GPU_GetGpuCoreCount (NvPhysicalGpuHandle hPhysicalGpu, NvU32 *pCount)
__nvapi_deprecated_function ("Do not use this function - it is deprecated in release 290. Instead, use NvAPI_GPU_GetAllDisplayIds.") NVAPI_INTERFACE NvAPI_GPU_GetAllOutputs(NvPhysicalGpuHandle hPhysicalGpu
__nvapi_deprecated_function ("Do not use this function - it is deprecated in release 290. Instead, use NvAPI_GPU_GetConnectedDisplayIds.") NVAPI_INTERFACE NvAPI_GPU_GetConnectedOutputs(NvPhysicalGpuHandle hPhysicalGpu
NVAPI_INTERFACE | NvAPI_OGL_ExpertModeDefaultsSet (NvU32 expertDetailLevel, NvU32 expertReportMask, NvU32 expertOutputMask)
NVAPI_INTERFACE | NvAPI_OGL_ExpertModeDefaultsGet (NvU32 *pExpertDetailLevel, NvU32 *pExpertReportMask, NvU32 *pExpertOutputMask)
#define | NV_GPU_CONNECTED_IDS_FLAG_UNCACHED NV_BIT(0)
#define | NV_GPU_CONNECTED_IDS_FLAG_SLI NV_BIT(1)
#define | NV_GPU_CONNECTED_IDS_FLAG_LIDSTATE NV_BIT(2)
#define | NV_GPU_CONNECTED_IDS_FLAG_FAKE NV_BIT(3)
#define | NV_GPU_CONNECTED_IDS_FLAG_EXCLUDE_MST NV_BIT(4)
enum NV_I2C_SPEED {
NVAPI_I2C_SPEED_DEFAULT , NVAPI_I2C_SPEED_3KHZ , NVAPI_I2C_SPEED_10KHZ , NVAPI_I2C_SPEED_33KHZ ,
NVAPI_I2C_SPEED_100KHZ , NVAPI_I2C_SPEED_200KHZ , NVAPI_I2C_SPEED_400KHZ
}
typedef NV_I2C_INFO_V3 | NV_I2C_INFO
#define | NVAPI_MAX_SIZEOF_I2C_REG_ADDRESS 4
#define | NVAPI_DISPLAY_DEVICE_MASK_MAX 24
#define | NVAPI_I2C_SPEED_DEPRECATED 0xFFFF
#define | NV_I2C_INFO_VER3 MAKE_NVAPI_VERSION(NV_I2C_INFO_V3,3)
#define | NV_I2C_INFO_VER2 MAKE_NVAPI_VERSION(NV_I2C_INFO_V2,2)
#define | NV_I2C_INFO_VER1 MAKE_NVAPI_VERSION(NV_I2C_INFO_V1,1)
#define | NV_I2C_INFO_VER NV_I2C_INFO_VER3
typedef NV_EDID_V3 | NV_EDID
#define | NV_EDID_V1_DATA_SIZE 256
#define | NV_EDID_DATA_SIZE NV_EDID_V1_DATA_SIZE
#define | NV_EDID_VER1 MAKE_NVAPI_VERSION(NV_EDID_V1,1)
#define | NV_EDID_VER2 MAKE_NVAPI_VERSION(NV_EDID_V2,2)
#define | NV_EDID_VER3 MAKE_NVAPI_VERSION(NV_EDID_V3,3)
#define | NV_EDID_VER NV_EDID_VER3
#define | NV_COMPUTE_GPU_TOPOLOGY_PHYSICS_CAPABLE NV_BIT(0)
#define | NV_COMPUTE_GPU_TOPOLOGY_PHYSICS_ENABLE NV_BIT(1)
#define | NV_COMPUTE_GPU_TOPOLOGY_PHYSICS_DEDICATED NV_BIT(2)
#define | NV_COMPUTE_GPU_TOPOLOGY_PHYSICS_RECOMMENDED NV_BIT(3)
#define | NV_COMPUTE_GPU_TOPOLOGY_CUDA_AVAILABLE NV_BIT(4)
#define | NV_COMPUTE_GPU_TOPOLOGY_CUDA_CAPABLE NV_BIT(16)
#define | NV_COMPUTE_GPU_TOPOLOGY_CUDA_DISABLED NV_BIT(17)
#define | NV_COMPUTE_GPU_TOPOLOGY_PHYSICS_AVAILABLE NV_BIT(21)

Detailed Description

The general GPU APIs are used to get general information about the GPU, such as outputs, VBIOS revision, APG rate, and frame buffer size.

Macro Definition Documentation

◆ NV_BOARD_INFO_VER

#define NV_BOARD_INFO_VER NV_BOARD_INFO_VER1

◆ NV_BOARD_INFO_VER1

#define NV_BOARD_INFO_VER1 MAKE_NVAPI_VERSION(NV_BOARD_INFO_V1,1)

◆ NV_COMPUTE_GPU_TOPOLOGY_CUDA_AVAILABLE

#define NV_COMPUTE_GPU_TOPOLOGY_CUDA_AVAILABLE NV_BIT(4)

This is Read only GPU flag.

◆ NV_COMPUTE_GPU_TOPOLOGY_CUDA_CAPABLE

#define NV_COMPUTE_GPU_TOPOLOGY_CUDA_CAPABLE NV_BIT(16)

This is Read only GPU flag.

◆ NV_COMPUTE_GPU_TOPOLOGY_CUDA_DISABLED

#define NV_COMPUTE_GPU_TOPOLOGY_CUDA_DISABLED NV_BIT(17)

This is Read only GPU flag.

◆ NV_COMPUTE_GPU_TOPOLOGY_PHYSICS_AVAILABLE

#define NV_COMPUTE_GPU_TOPOLOGY_PHYSICS_AVAILABLE NV_BIT(21)

This is Read only GPU flag - PhysX is able to use this GPU (PhysX is installed, etc)

◆ NV_COMPUTE_GPU_TOPOLOGY_PHYSICS_CAPABLE

#define NV_COMPUTE_GPU_TOPOLOGY_PHYSICS_CAPABLE NV_BIT(0)

This is Read only GPU flag - Physics capable GPU.

defgroup nvcomp_gpu_top NVIDIA Compute GPU Topology Flags

◆ NV_COMPUTE_GPU_TOPOLOGY_PHYSICS_DEDICATED

#define NV_COMPUTE_GPU_TOPOLOGY_PHYSICS_DEDICATED NV_BIT(2)

This is Read only GPU flag - Physics enabled GPU which is dedicated for physics indicates this compute capable GPU was automatically made usable for Physx on CUDA.

◆ NV_COMPUTE_GPU_TOPOLOGY_PHYSICS_ENABLE

#define NV_COMPUTE_GPU_TOPOLOGY_PHYSICS_ENABLE NV_BIT(1)

This is Read/Write GPU flag - Indicates GPU is already enabled for physics.

◆ NV_COMPUTE_GPU_TOPOLOGY_PHYSICS_RECOMMENDED

#define NV_COMPUTE_GPU_TOPOLOGY_PHYSICS_RECOMMENDED NV_BIT(3)

This is Read only GPU flag - Physics GPU which is recommended by the driver.

◆ NV_COMPUTE_GPU_TOPOLOGY_VER

#define NV_COMPUTE_GPU_TOPOLOGY_VER MAKE_NVAPI_VERSION(NV_COMPUTE_GPU_TOPOLOGY_V2,2)

◆ NV_COMPUTE_GPU_TOPOLOGY_VER1

#define NV_COMPUTE_GPU_TOPOLOGY_VER1 MAKE_NVAPI_VERSION(NV_COMPUTE_GPU_TOPOLOGY_V1,1)

Macro for constructing the version field of NV_COMPUTE_GPU_TOPOLOGY.

◆ NV_EDID_DATA_SIZE

#define NV_EDID_DATA_SIZE NV_EDID_V1_DATA_SIZE

◆ NV_EDID_DATA_SIZE_MAX

#define NV_EDID_DATA_SIZE_MAX 1024

Used in NvAPI_DISP_GetEdidData This is the current size supported by Nvidia Display Driver and may change in future.

◆ NV_EDID_V1_DATA_SIZE

#define NV_EDID_V1_DATA_SIZE 256

◆ NV_EDID_VER

#define NV_EDID_VER NV_EDID_VER3

◆ NV_EDID_VER1

#define NV_EDID_VER1 MAKE_NVAPI_VERSION(NV_EDID_V1,1)

◆ NV_EDID_VER2

#define NV_EDID_VER2 MAKE_NVAPI_VERSION(NV_EDID_V2,2)

◆ NV_EDID_VER3

#define NV_EDID_VER3 MAKE_NVAPI_VERSION(NV_EDID_V3,3)

◆ NV_GPU_ARCH_INFO_VER

#define NV_GPU_ARCH_INFO_VER NV_GPU_ARCH_INFO_VER_2

◆ NV_GPU_ARCH_INFO_VER_1

#define NV_GPU_ARCH_INFO_VER_1 MAKE_NVAPI_VERSION(NV_GPU_ARCH_INFO_V1,1)

◆ NV_GPU_ARCH_INFO_VER_2

#define NV_GPU_ARCH_INFO_VER_2 MAKE_NVAPI_VERSION(NV_GPU_ARCH_INFO_V2,2)

◆ NV_GPU_CONNECTED_IDS_FLAG_EXCLUDE_MST

#define NV_GPU_CONNECTED_IDS_FLAG_EXCLUDE_MST NV_BIT(4)

Excludes devices that are part of the multi stream topology.

◆ NV_GPU_CONNECTED_IDS_FLAG_FAKE

#define NV_GPU_CONNECTED_IDS_FLAG_FAKE NV_BIT(3)

Get devices that includes the fake connected monitors.

◆ NV_GPU_CONNECTED_IDS_FLAG_LIDSTATE

#define NV_GPU_CONNECTED_IDS_FLAG_LIDSTATE NV_BIT(2)

Get devices such that to reflect the Lid State.

◆ NV_GPU_CONNECTED_IDS_FLAG_SLI

#define NV_GPU_CONNECTED_IDS_FLAG_SLI NV_BIT(1)

Get devices such that those can be selected in an SLI configuration.

◆ NV_GPU_CONNECTED_IDS_FLAG_UNCACHED

#define NV_GPU_CONNECTED_IDS_FLAG_UNCACHED NV_BIT(0)

Get uncached connected devices.

◆ NV_GPU_DISPLAYIDS_VER

#define NV_GPU_DISPLAYIDS_VER NV_GPU_DISPLAYIDS_VER2

◆ NV_GPU_DISPLAYIDS_VER1

#define NV_GPU_DISPLAYIDS_VER1 MAKE_NVAPI_VERSION(NV_GPU_DISPLAYIDS,1)

Macro for constructing the version field of _NV_GPU_DISPLAYIDS

◆ NV_GPU_DISPLAYIDS_VER2

#define NV_GPU_DISPLAYIDS_VER2 MAKE_NVAPI_VERSION(NV_GPU_DISPLAYIDS,3)

◆ NV_GPU_GET_HDCP_SUPPORT_STATUS_VER

#define NV_GPU_GET_HDCP_SUPPORT_STATUS_VER MAKE_NVAPI_VERSION(NV_GPU_GET_HDCP_SUPPORT_STATUS,1)

Macro for constructing the version for structure NV_GPU_GET_HDCP_SUPPORT_STATUS.

◆ NV_GPU_GET_ILLUMINATION_PARM_VER

#define NV_GPU_GET_ILLUMINATION_PARM_VER NV_GPU_GET_ILLUMINATION_PARM_VER_1

◆ NV_GPU_GET_ILLUMINATION_PARM_VER_1

#define NV_GPU_GET_ILLUMINATION_PARM_VER_1 MAKE_NVAPI_VERSION(NV_GPU_GET_ILLUMINATION_PARM_V1,1)

◆ NV_GPU_GSP_INFO_VER1

#define NV_GPU_GSP_INFO_VER1 MAKE_NVAPI_VERSION(NV_GPU_GSP_INFO_V1, 1)

Macro for constructing the version field of NV_GPU_GSP_INFO_V1

◆ NV_GPU_QUERY_ILLUMINATION_SUPPORT_PARM_VER

#define NV_GPU_QUERY_ILLUMINATION_SUPPORT_PARM_VER NV_GPU_QUERY_ILLUMINATION_SUPPORT_PARM_VER_1

◆ NV_GPU_QUERY_ILLUMINATION_SUPPORT_PARM_VER_1

#define NV_GPU_QUERY_ILLUMINATION_SUPPORT_PARM_VER_1 MAKE_NVAPI_VERSION(NV_GPU_QUERY_ILLUMINATION_SUPPORT_PARM_V1,1)

◆ NV_GPU_SET_ILLUMINATION_PARM_VER

#define NV_GPU_SET_ILLUMINATION_PARM_VER NV_GPU_SET_ILLUMINATION_PARM_VER_1

◆ NV_GPU_SET_ILLUMINATION_PARM_VER_1

#define NV_GPU_SET_ILLUMINATION_PARM_VER_1 MAKE_NVAPI_VERSION(NV_GPU_SET_ILLUMINATION_PARM_V1,1)

◆ NV_GPU_VIRTUALIZATION_INFO_VER

#define NV_GPU_VIRTUALIZATION_INFO_VER NV_GPU_VIRTUALIZATION_INFO_VER1

◆ NV_GPU_VIRTUALIZATION_INFO_VER1

#define NV_GPU_VIRTUALIZATION_INFO_VER1 MAKE_NVAPI_VERSION(NV_GPU_VIRTUALIZATION_INFO_V1,1)

◆ NV_I2C_INFO_VER

#define NV_I2C_INFO_VER NV_I2C_INFO_VER3

◆ NV_I2C_INFO_VER1

#define NV_I2C_INFO_VER1 MAKE_NVAPI_VERSION(NV_I2C_INFO_V1,1)

◆ NV_I2C_INFO_VER2

#define NV_I2C_INFO_VER2 MAKE_NVAPI_VERSION(NV_I2C_INFO_V2,2)

◆ NV_I2C_INFO_VER3

#define NV_I2C_INFO_VER3 MAKE_NVAPI_VERSION(NV_I2C_INFO_V3,3)

◆ NV_SCANOUT_INTENSITY_DATA_VER1

#define NV_SCANOUT_INTENSITY_DATA_VER1 MAKE_NVAPI_VERSION(NV_SCANOUT_INTENSITY_DATA_V1, 1)

◆ NV_SCANOUT_INTENSITY_STATE_VER

#define NV_SCANOUT_INTENSITY_STATE_VER MAKE_NVAPI_VERSION(NV_SCANOUT_INTENSITY_STATE_DATA, 1)

◆ NV_SCANOUT_WARPING_STATE_VER

#define NV_SCANOUT_WARPING_STATE_VER MAKE_NVAPI_VERSION(NV_SCANOUT_WARPING_STATE_DATA, 1)

◆ NV_SCANOUT_WARPING_VER

#define NV_SCANOUT_WARPING_VER MAKE_NVAPI_VERSION(NV_SCANOUT_WARPING_DATA, 1)

◆ NVAPI_DISPLAY_DEVICE_MASK_MAX

#define NVAPI_DISPLAY_DEVICE_MASK_MAX 24

◆ NVAPI_GPU_MAX_BUILD_VERSION_LENGTH

#define NVAPI_GPU_MAX_BUILD_VERSION_LENGTH (0x0000040)

◆ NVAPI_I2C_SPEED_DEPRECATED

#define NVAPI_I2C_SPEED_DEPRECATED 0xFFFF

◆ NVAPI_MAX_SIZEOF_I2C_REG_ADDRESS

#define NVAPI_MAX_SIZEOF_I2C_REG_ADDRESS 4

Typedef Documentation

◆ NV_BOARD_INFO

typedef NV_BOARD_INFO_V1 NV_BOARD_INFO

◆ NV_BOARD_INFO_V1

typedef struct _NV_BOARD_INFO NV_BOARD_INFO_V1

◆ NV_COMPUTE_GPU

typedef struct _NV_COMPUTE_GPU NV_COMPUTE_GPU

◆ NV_COMPUTE_GPU_TOPOLOGY

typedef NV_COMPUTE_GPU_TOPOLOGY_V2 NV_COMPUTE_GPU_TOPOLOGY

◆ NV_COMPUTE_GPU_TOPOLOGY_V2

typedef struct _NV_COMPUTE_GPU_TOPOLOGY_V2 NV_COMPUTE_GPU_TOPOLOGY_V2

◆ NV_EDID

typedef NV_EDID_V3 NV_EDID

◆ NV_GPU_ARCH_IMPLEMENTATION_ID

typedef enum _NV_GPU_ARCH_IMPLEMENTATION_ID NV_GPU_ARCH_IMPLEMENTATION_ID

NV_GPU_ARCH_INFO() values to identify GPU Architecture Implementation.

◆ NV_GPU_ARCH_INFO

typedef NV_GPU_ARCH_INFO_V2 NV_GPU_ARCH_INFO

◆ NV_GPU_ARCHITECTURE_ID

typedef enum _NV_GPU_ARCHITECTURE_ID NV_GPU_ARCHITECTURE_ID

NV_GPU_ARCH_INFO() values to identify Architecture level for the GPU.

◆ NV_GPU_BUS_TYPE

typedef enum _NV_GPU_BUS_TYPE NV_GPU_BUS_TYPE

Used in NvAPI_GPU_GetBusType()

◆ NV_GPU_CHIP_REVISION

typedef enum _NV_GPU_CHIP_REVISION NV_GPU_CHIP_REVISION

◆ NV_GPU_CONNECTOR_TYPE

typedef enum _NV_GPU_CONNECTOR_TYPE NV_GPU_CONNECTOR_TYPE

Used in NV_GPU_CONNECTOR_DATA

◆ NV_GPU_DISPLAYIDS

typedef struct _NV_GPU_DISPLAYIDS NV_GPU_DISPLAYIDS

◆ NV_GPU_GET_ILLUMINATION_PARM

typedef NV_GPU_GET_ILLUMINATION_PARM_V1 NV_GPU_GET_ILLUMINATION_PARM

◆ NV_GPU_GET_ILLUMINATION_PARM_V1

typedef struct _NV_GPU_GET_ILLUMINATION_PARM_V1 NV_GPU_GET_ILLUMINATION_PARM_V1

◆ NV_GPU_GSP_INFO_V1

typedef struct _NV_GPU_GSP_INFO_V1 NV_GPU_GSP_INFO_V1

Used in NvAPI_GPU_GetGspFeatures().

◆ NV_GPU_HDCP_FUSE_STATE

typedef enum _NV_GPU_HDCP_FUSE_STATE NV_GPU_HDCP_FUSE_STATE

HDCP fuse states - used in NV_GPU_GET_HDCP_SUPPORT_STATUS.

◆ NV_GPU_HDCP_KEY_SOURCE

typedef enum _NV_GPU_HDCP_KEY_SOURCE NV_GPU_HDCP_KEY_SOURCE

HDCP key sources - used in NV_GPU_GET_HDCP_SUPPORT_STATUS.

◆ NV_GPU_HDCP_KEY_SOURCE_STATE

typedef enum _NV_GPU_HDCP_KEY_SOURCE_STATE NV_GPU_HDCP_KEY_SOURCE_STATE

HDCP key source states - used in NV_GPU_GET_HDCP_SUPPORT_STATUS.

◆ NV_GPU_ILLUMINATION_ATTRIB

typedef enum _NV_GPU_ILLUMINATION_ATTRIB NV_GPU_ILLUMINATION_ATTRIB

◆ NV_GPU_OUTPUT_TYPE

typedef enum _NV_GPU_OUTPUT_TYPE NV_GPU_OUTPUT_TYPE

used in NvAPI_GPU_GetOutputType()

◆ NV_GPU_QUERY_ILLUMINATION_SUPPORT_PARM

typedef NV_GPU_QUERY_ILLUMINATION_SUPPORT_PARM_V1 NV_GPU_QUERY_ILLUMINATION_SUPPORT_PARM

◆ NV_GPU_QUERY_ILLUMINATION_SUPPORT_PARM_V1

typedef struct _NV_GPU_QUERY_ILLUMINATION_SUPPORT_PARM_V1 NV_GPU_QUERY_ILLUMINATION_SUPPORT_PARM_V1

◆ NV_GPU_SET_ILLUMINATION_PARM

typedef NV_GPU_SET_ILLUMINATION_PARM_V1 NV_GPU_SET_ILLUMINATION_PARM

◆ NV_GPU_SET_ILLUMINATION_PARM_V1

typedef struct _NV_GPU_SET_ILLUMINATION_PARM_V1 NV_GPU_SET_ILLUMINATION_PARM_V1

◆ NV_GPU_TYPE

typedef enum _NV_GPU_TYPE NV_GPU_TYPE

Used in NvAPI_GPU_GetGPUType().

◆ NV_GPU_VIRTUALIZATION_INFO

typedef NV_GPU_VIRTUALIZATION_INFO_V1 NV_GPU_VIRTUALIZATION_INFO

◆ NV_GPU_VIRTUALIZATION_INFO_V1

typedef struct _NV_GPU_VIRTUALIZATION_INFO NV_GPU_VIRTUALIZATION_INFO_V1

◆ NV_GPU_WORKSTATION_FEATURE_TYPE

typedef enum _NV_GPU_WORKSTATION_FEATURE_TYPE NV_GPU_WORKSTATION_FEATURE_TYPE

◆ NV_I2C_INFO

typedef NV_I2C_INFO_V3 NV_I2C_INFO

◆ NV_LOGICAL_GPU_DATA

typedef NV_LOGICAL_GPU_DATA_V1 NV_LOGICAL_GPU_DATA

◆ NV_LOGICAL_GPU_DATA_V1

typedef struct _NV_LOGICAL_GPU_DATA_V1 NV_LOGICAL_GPU_DATA_V1

◆ NV_SCANOUT_INFORMATION

typedef struct _NV_SCANOUT_INFORMATION NV_SCANOUT_INFORMATION

Used in NvAPI_GPU_GetScanoutConfigurationEx().

◆ NV_SCANOUT_INTENSITY_STATE_DATA

typedef struct _NV_SCANOUT_INTENSITY_STATE_DATA NV_SCANOUT_INTENSITY_STATE_DATA

◆ NV_SCANOUT_WARPING_STATE_DATA

typedef struct _NV_SCANOUT_WARPING_STATE_DATA NV_SCANOUT_WARPING_STATE_DATA

◆ NV_VIRTUALIZATION_MODE

typedef enum _NV_VIRTUALIZATION_MODE NV_VIRTUALIZATION_MODE

Enumeration Type Documentation

◆ _NV_GPU_ARCH_IMPLEMENTATION_ID

enum _NV_GPU_ARCH_IMPLEMENTATION_ID

NV_GPU_ARCH_INFO() values to identify GPU Architecture Implementation.

Enumerator
NV_GPU_ARCH_IMPLEMENTATION_T20
NV_GPU_ARCH_IMPLEMENTATION_T30
NV_GPU_ARCH_IMPLEMENTATION_T35
NV_GPU_ARCH_IMPLEMENTATION_T40
NV_GPU_ARCH_IMPLEMENTATION_T124
NV_GPU_ARCH_IMPLEMENTATION_NV40
NV_GPU_ARCH_IMPLEMENTATION_NV41
NV_GPU_ARCH_IMPLEMENTATION_NV42
NV_GPU_ARCH_IMPLEMENTATION_NV43
NV_GPU_ARCH_IMPLEMENTATION_NV44
NV_GPU_ARCH_IMPLEMENTATION_NV44A
NV_GPU_ARCH_IMPLEMENTATION_NV46
NV_GPU_ARCH_IMPLEMENTATION_NV47
NV_GPU_ARCH_IMPLEMENTATION_NV49
NV_GPU_ARCH_IMPLEMENTATION_NV4B
NV_GPU_ARCH_IMPLEMENTATION_NV4C
NV_GPU_ARCH_IMPLEMENTATION_NV4E
NV_GPU_ARCH_IMPLEMENTATION_NV50
NV_GPU_ARCH_IMPLEMENTATION_NV63
NV_GPU_ARCH_IMPLEMENTATION_NV67
NV_GPU_ARCH_IMPLEMENTATION_G84
NV_GPU_ARCH_IMPLEMENTATION_G86
NV_GPU_ARCH_IMPLEMENTATION_G92
NV_GPU_ARCH_IMPLEMENTATION_G94
NV_GPU_ARCH_IMPLEMENTATION_G96
NV_GPU_ARCH_IMPLEMENTATION_G98
NV_GPU_ARCH_IMPLEMENTATION_GT200
NV_GPU_ARCH_IMPLEMENTATION_GT212
NV_GPU_ARCH_IMPLEMENTATION_GT214
NV_GPU_ARCH_IMPLEMENTATION_GT215
NV_GPU_ARCH_IMPLEMENTATION_GT216
NV_GPU_ARCH_IMPLEMENTATION_GT218
NV_GPU_ARCH_IMPLEMENTATION_MCP77
NV_GPU_ARCH_IMPLEMENTATION_GT21C
NV_GPU_ARCH_IMPLEMENTATION_MCP79
NV_GPU_ARCH_IMPLEMENTATION_GT21A
NV_GPU_ARCH_IMPLEMENTATION_MCP89
NV_GPU_ARCH_IMPLEMENTATION_GF100
NV_GPU_ARCH_IMPLEMENTATION_GF104
NV_GPU_ARCH_IMPLEMENTATION_GF106
NV_GPU_ARCH_IMPLEMENTATION_GF108
NV_GPU_ARCH_IMPLEMENTATION_GF110
NV_GPU_ARCH_IMPLEMENTATION_GF116
NV_GPU_ARCH_IMPLEMENTATION_GF117
NV_GPU_ARCH_IMPLEMENTATION_GF118
NV_GPU_ARCH_IMPLEMENTATION_GF119
NV_GPU_ARCH_IMPLEMENTATION_GK104
NV_GPU_ARCH_IMPLEMENTATION_GK106
NV_GPU_ARCH_IMPLEMENTATION_GK107
NV_GPU_ARCH_IMPLEMENTATION_GK20A
NV_GPU_ARCH_IMPLEMENTATION_GK110
NV_GPU_ARCH_IMPLEMENTATION_GK208
NV_GPU_ARCH_IMPLEMENTATION_GM204
NV_GPU_ARCH_IMPLEMENTATION_GM206
NV_GPU_ARCH_IMPLEMENTATION_GP100
NV_GPU_ARCH_IMPLEMENTATION_GP000
NV_GPU_ARCH_IMPLEMENTATION_GP102
NV_GPU_ARCH_IMPLEMENTATION_GP104
NV_GPU_ARCH_IMPLEMENTATION_GP106
NV_GPU_ARCH_IMPLEMENTATION_GP107
NV_GPU_ARCH_IMPLEMENTATION_GP108
NV_GPU_ARCH_IMPLEMENTATION_GV100
NV_GPU_ARCH_IMPLEMENTATION_GV10B
NV_GPU_ARCH_IMPLEMENTATION_TU100
NV_GPU_ARCH_IMPLEMENTATION_TU102
NV_GPU_ARCH_IMPLEMENTATION_TU104
NV_GPU_ARCH_IMPLEMENTATION_TU106
NV_GPU_ARCH_IMPLEMENTATION_TU116
NV_GPU_ARCH_IMPLEMENTATION_TU117
NV_GPU_ARCH_IMPLEMENTATION_TU000
NV_GPU_ARCH_IMPLEMENTATION_GA100
NV_GPU_ARCH_IMPLEMENTATION_GA102
NV_GPU_ARCH_IMPLEMENTATION_GA104
NV_GPU_ARCH_IMPLEMENTATION_AD102
NV_GPU_ARCH_IMPLEMENTATION_AD103
NV_GPU_ARCH_IMPLEMENTATION_AD104

◆ _NV_GPU_ARCHITECTURE_ID

enum _NV_GPU_ARCHITECTURE_ID

NV_GPU_ARCH_INFO() values to identify Architecture level for the GPU.

Enumerator
NV_GPU_ARCHITECTURE_T2X
NV_GPU_ARCHITECTURE_T3X
NV_GPU_ARCHITECTURE_T4X
NV_GPU_ARCHITECTURE_T12X
NV_GPU_ARCHITECTURE_NV40
NV_GPU_ARCHITECTURE_NV50
NV_GPU_ARCHITECTURE_G78
NV_GPU_ARCHITECTURE_G80
NV_GPU_ARCHITECTURE_G90
NV_GPU_ARCHITECTURE_GT200
NV_GPU_ARCHITECTURE_GF100
NV_GPU_ARCHITECTURE_GF110
NV_GPU_ARCHITECTURE_GK100
NV_GPU_ARCHITECTURE_GK110
NV_GPU_ARCHITECTURE_GK200
NV_GPU_ARCHITECTURE_GM000
NV_GPU_ARCHITECTURE_GM200
NV_GPU_ARCHITECTURE_GP100
NV_GPU_ARCHITECTURE_GV100
NV_GPU_ARCHITECTURE_GV110
NV_GPU_ARCHITECTURE_TU100
NV_GPU_ARCHITECTURE_GA100
NV_GPU_ARCHITECTURE_AD100

◆ _NV_GPU_BUS_TYPE

enum _NV_GPU_BUS_TYPE

Used in NvAPI_GPU_GetBusType()

Enumerator
NVAPI_GPU_BUS_TYPE_UNDEFINED
NVAPI_GPU_BUS_TYPE_PCI
NVAPI_GPU_BUS_TYPE_AGP
NVAPI_GPU_BUS_TYPE_PCI_EXPRESS
NVAPI_GPU_BUS_TYPE_FPCI
NVAPI_GPU_BUS_TYPE_AXI

◆ _NV_GPU_CHIP_REVISION

enum _NV_GPU_CHIP_REVISION
Enumerator
NV_GPU_CHIP_REV_EMULATION_QT | QT chip.
NV_GPU_CHIP_REV_EMULATION_FPGA | FPGA implementation of the chipset.
NV_GPU_CHIP_REV_A01 | First silicon chipset revision.
NV_GPU_CHIP_REV_A02 | Second Silicon chipset revision.
NV_GPU_CHIP_REV_A03 | Third Silicon chipset revision.
NV_GPU_CHIP_REV_UNKNOWN | Unknown chip revision.

◆ _NV_GPU_CONNECTOR_TYPE

enum _NV_GPU_CONNECTOR_TYPE

Used in NV_GPU_CONNECTOR_DATA

Enumerator
NVAPI_GPU_CONNECTOR_VGA_15_PIN |
NVAPI_GPU_CONNECTOR_TV_COMPOSITE |
NVAPI_GPU_CONNECTOR_TV_SVIDEO |
NVAPI_GPU_CONNECTOR_TV_HDTV_COMPONENT |
NVAPI_GPU_CONNECTOR_TV_SCART |
NVAPI_GPU_CONNECTOR_TV_COMPOSITE_SCART_ON_EIAJ4120 |
NVAPI_GPU_CONNECTOR_TV_HDTV_EIAJ4120 |
NVAPI_GPU_CONNECTOR_PC_POD_HDTV_YPRPB |
NVAPI_GPU_CONNECTOR_PC_POD_SVIDEO |
NVAPI_GPU_CONNECTOR_PC_POD_COMPOSITE |
NVAPI_GPU_CONNECTOR_DVI_I_TV_SVIDEO |
NVAPI_GPU_CONNECTOR_DVI_I_TV_COMPOSITE |
NVAPI_GPU_CONNECTOR_DVI_I |
NVAPI_GPU_CONNECTOR_DVI_D |
NVAPI_GPU_CONNECTOR_ADC |
NVAPI_GPU_CONNECTOR_LFH_DVI_I_1 |
NVAPI_GPU_CONNECTOR_LFH_DVI_I_2 |
NVAPI_GPU_CONNECTOR_SPWG |
NVAPI_GPU_CONNECTOR_OEM |
NVAPI_GPU_CONNECTOR_DISPLAYPORT_EXTERNAL |
NVAPI_GPU_CONNECTOR_DISPLAYPORT_INTERNAL |
NVAPI_GPU_CONNECTOR_DISPLAYPORT_MINI_EXT |
NVAPI_GPU_CONNECTOR_HDMI_A |
NVAPI_GPU_CONNECTOR_HDMI_C_MINI |
NVAPI_GPU_CONNECTOR_LFH_DISPLAYPORT_1 |
NVAPI_GPU_CONNECTOR_LFH_DISPLAYPORT_2 |
NVAPI_GPU_CONNECTOR_VIRTUAL_WFD | Deprecated.
NVAPI_GPU_CONNECTOR_USB_C |
NVAPI_GPU_CONNECTOR_UNKNOWN |

◆ _NV_GPU_HDCP_FUSE_STATE

enum _NV_GPU_HDCP_FUSE_STATE

HDCP fuse states - used in NV_GPU_GET_HDCP_SUPPORT_STATUS.

Enumerator
NV_GPU_HDCP_FUSE_STATE_UNKNOWN
NV_GPU_HDCP_FUSE_STATE_DISABLED
NV_GPU_HDCP_FUSE_STATE_ENABLED

◆ _NV_GPU_HDCP_KEY_SOURCE

enum _NV_GPU_HDCP_KEY_SOURCE

HDCP key sources - used in NV_GPU_GET_HDCP_SUPPORT_STATUS.

Enumerator
NV_GPU_HDCP_KEY_SOURCE_UNKNOWN
NV_GPU_HDCP_KEY_SOURCE_NONE
NV_GPU_HDCP_KEY_SOURCE_CRYPTO_ROM
NV_GPU_HDCP_KEY_SOURCE_SBIOS
NV_GPU_HDCP_KEY_SOURCE_I2C_ROM
NV_GPU_HDCP_KEY_SOURCE_FUSES

◆ _NV_GPU_HDCP_KEY_SOURCE_STATE

enum _NV_GPU_HDCP_KEY_SOURCE_STATE

HDCP key source states - used in NV_GPU_GET_HDCP_SUPPORT_STATUS.

Enumerator
NV_GPU_HDCP_KEY_SOURCE_STATE_UNKNOWN
NV_GPU_HDCP_KEY_SOURCE_STATE_ABSENT
NV_GPU_HDCP_KEY_SOURCE_STATE_PRESENT

◆ _NV_GPU_ILLUMINATION_ATTRIB

enum _NV_GPU_ILLUMINATION_ATTRIB
Enumerator
NV_GPU_IA_LOGO_BRIGHTNESS
NV_GPU_IA_SLI_BRIGHTNESS

◆ _NV_GPU_OUTPUT_TYPE

enum _NV_GPU_OUTPUT_TYPE

used in NvAPI_GPU_GetOutputType()

Enumerator
NVAPI_GPU_OUTPUT_UNKNOWN |
NVAPI_GPU_OUTPUT_CRT | CRT display device.
NVAPI_GPU_OUTPUT_DFP | Digital Flat Panel display device.
NVAPI_GPU_OUTPUT_TV | TV display device.

◆ _NV_GPU_TYPE

enum _NV_GPU_TYPE

Used in NvAPI_GPU_GetGPUType().

Enumerator
NV_SYSTEM_TYPE_GPU_UNKNOWN |
NV_SYSTEM_TYPE_IGPU | Integrated GPU.
NV_SYSTEM_TYPE_DGPU | Discrete GPU.

◆ _NV_GPU_WORKSTATION_FEATURE_TYPE

enum _NV_GPU_WORKSTATION_FEATURE_TYPE
Enumerator
NV_GPU_WORKSTATION_FEATURE_TYPE_NVIDIA_RTX_VR_READY | NVIDIA RTX VR Ready.
NV_GPU_WORKSTATION_FEATURE_TYPE_QUADRO_VR_READY | DEPRECATED name - do not use.
NV_GPU_WORKSTATION_FEATURE_TYPE_PROVIZ |

◆ _NV_VIRTUALIZATION_MODE

enum _NV_VIRTUALIZATION_MODE
Enumerator
NV_VIRTUALIZATION_MODE_NONE | Represents Bare Metal GPU.
NV_VIRTUALIZATION_MODE_NMOS | Represents GPU-Passthrough.
NV_VIRTUALIZATION_MODE_VGX | Represents vGPU inside virtual machine.
NV_VIRTUALIZATION_MODE_HOST_VGPU | Represents VGX hypervisor in vGPU mode.

◆ NV_GPU_WARPING_VERTICE_FORMAT

enum NV_GPU_WARPING_VERTICE_FORMAT
Enumerator
NV_GPU_WARPING_VERTICE_FORMAT_TRIANGLESTRIP_XYUVRQ
NV_GPU_WARPING_VERTICE_FORMAT_TRIANGLES_XYUVRQ

◆ NV_I2C_SPEED

enum NV_I2C_SPEED
Enumerator
NVAPI_I2C_SPEED_DEFAULT | Set i2cSpeedKhz to I2C_SPEED_DEFAULT if default I2C speed is to be chosen, ie.use the current frequency setting.
NVAPI_I2C_SPEED_3KHZ |
NVAPI_I2C_SPEED_10KHZ |
NVAPI_I2C_SPEED_33KHZ |
NVAPI_I2C_SPEED_100KHZ |
NVAPI_I2C_SPEED_200KHZ |
NVAPI_I2C_SPEED_400KHZ |

◆ NV_MONITOR_CONN_TYPE

enum NV_MONITOR_CONN_TYPE

Get uncached connected devices.

Enumerator
NV_MONITOR_CONN_TYPE_UNINITIALIZED
NV_MONITOR_CONN_TYPE_VGA
NV_MONITOR_CONN_TYPE_COMPONENT
NV_MONITOR_CONN_TYPE_SVIDEO
NV_MONITOR_CONN_TYPE_HDMI
NV_MONITOR_CONN_TYPE_DVI
NV_MONITOR_CONN_TYPE_LVDS
NV_MONITOR_CONN_TYPE_DP
NV_MONITOR_CONN_TYPE_COMPOSITE
NV_MONITOR_CONN_TYPE_UNKNOWN

◆ NV_SYSTEM_TYPE

enum NV_SYSTEM_TYPE

Used in NvAPI_GPU_GetSystemType()

Enumerator
NV_SYSTEM_TYPE_UNKNOWN
NV_SYSTEM_TYPE_LAPTOP
NV_SYSTEM_TYPE_DESKTOP

◆ NVAPI_GPU_WORKSTATION_FEATURE_MASK

enum NVAPI_GPU_WORKSTATION_FEATURE_MASK
Enumerator
NVAPI_GPU_WORKSTATION_FEATURE_MASK_SWAPGROUP
NVAPI_GPU_WORKSTATION_FEATURE_MASK_STEREO
NVAPI_GPU_WORKSTATION_FEATURE_MASK_WARPING
NVAPI_GPU_WORKSTATION_FEATURE_MASK_PIXINTENSITY
NVAPI_GPU_WORKSTATION_FEATURE_MASK_GRAYSCALE
NVAPI_GPU_WORKSTATION_FEATURE_MASK_BPC10

Function Documentation

◆ __nvapi_deprecated_function() [1/5]

__nvapi_deprecated_function | ( | "Do not use this function - it is deprecated in release 290. | Instead,
 |  | use NvAPI_GPU_GetAllDisplayIds." |
 | ) |  |

This function returns set of all GPU-output identifiers as a bitmask.

Since
Release: 85
Return values
NVAPI_INVALID_ARGUMENT | hPhysicalGpu or pOutputsMask is NULL.
NVAPI_OK | *pOutputsMask contains a set of GPU-output identifiers.
NVAPI_NVIDIA_DEVICE_NOT_FOUND | No NVIDIA GPU driving a display was found.
NVAPI_EXPECTED_PHYSICAL_GPU_HANDLE | hPhysicalGpu was not a physical GPU handle.

◆ __nvapi_deprecated_function() [2/5]

__nvapi_deprecated_function | ( | "Do not use this function - it is deprecated in release 290. | Instead,
 |  | use NvAPI_GPU_GetConnectedDisplayIds." |
 | ) |  |

This function is the same as NvAPI_GPU_GetAllOutputs() but returns only the set of GPU output identifiers that are connected to display devices.

Since
Release: 80
Return values
NVAPI_INVALID_ARGUMENT | hPhysicalGpu or pOutputsMask is NULL.
NVAPI_OK | *pOutputsMask contains a set of GPU-output identifiers.
NVAPI_NVIDIA_DEVICE_NOT_FOUND | No NVIDIA GPU driving a display was found.
NVAPI_EXPECTED_PHYSICAL_GPU_HANDLE | hPhysicalGpu was not a physical GPU handle.

DESCRIPTION: This function is the same as NvAPI_GPU_GetConnectedOutputs() but returns only the set of GPU-output identifiers that can be selected in an SLI configuration. NOTE: This function matches NvAPI_GPU_GetConnectedOutputs()

  • On systems which are not SLI capable.
  • If the queried GPU is not part of a valid SLI group.
Since
Release: 170
Return values
NVAPI_INVALID_ARGUMENT | hPhysicalGpu or pOutputsMask is NULL
NVAPI_OK | *pOutputsMask contains a set of GPU-output identifiers
NVAPI_NVIDIA_DEVICE_NOT_FOUND | No NVIDIA GPU driving a display was found
NVAPI_EXPECTED_PHYSICAL_GPU_HANDLE | hPhysicalGpu was not a physical GPU handle

This function is similar to NvAPI_GPU_GetConnectedOutputs(), and returns the connected display identifiers that are connected as an output mask but unlike NvAPI_GPU_GetConnectedOutputs() this API "always" reflects the Lid State in the output mask. Thus if you expect the LID close state to be available in the connection mask use this API.

  • If LID is closed then this API will remove the LID panel from the connected display identifiers.
  • If LID is open then this API will reflect the LID panel in the connected display identifiers.
Note
This API should be used on notebook systems and on systems where the LID state is required in the connection output mask. On desktop systems the returned identifiers will match NvAPI_GPU_GetConnectedOutputs().
Since
Release: 95
Return values
NVAPI_INVALID_ARGUMENT | hPhysicalGpu or pOutputsMask is NULL
NVAPI_OK | *pOutputsMask contains a set of GPU-output identifiers
NVAPI_NVIDIA_DEVICE_NOT_FOUND | No NVIDIA GPU driving a display was found
NVAPI_EXPECTED_PHYSICAL_GPU_HANDLE | hPhysicalGpu was not a physical GPU handle

DESCRIPTION: This function is the same as NvAPI_GPU_GetConnectedOutputsWithLidState() but returns only the set of GPU-output identifiers that can be selected in an SLI configuration. With SLI disabled, this function matches NvAPI_GPU_GetConnectedOutputsWithLidState().

Since
Release: 170
Return values
NVAPI_INVALID_ARGUMENT | hPhysicalGpu or pOutputsMask is NULL
NVAPI_OK | *pOutputsMask contains a set of GPU-output identifiers
NVAPI_NVIDIA_DEVICE_NOT_FOUND | No NVIDIA GPU driving a display was found
NVAPI_EXPECTED_PHYSICAL_GPU_HANDLE | hPhysicalGpu was not a physical GPU handle

◆ __nvapi_deprecated_function() [3/5]

__nvapi_deprecated_function ( "Do not use this function - it is deprecated in release 455." )

This function returns the AGP aperture in megabytes.

TCC_SUPPORTED

Since
Release: 90
Return values
NVAPI_NOT_SUPPORTED

This function returns the current AGP Rate (0 = AGP not present, 1 = 1x, 2 = 2x, etc.).

TCC_SUPPORTED

Since
Release: 90
Return values
NVAPI_NOT_SUPPORTED

◆ __nvapi_deprecated_function() [4/5]

__nvapi_deprecated_function ( "Do not use this function - it is deprecated in release 460." )

This function retrieves the Quadro status for the GPU (1 if Quadro, 0 if GeForce)

This API is deprecated and it is recommended to instead query NV_GPU_WORKSTATION_FEATURE_TYPE_PROVIZ support from the API NvAPI_GPU_QueryWorkstationFeatureSupport.

Since
Release: 80
Returns
NVAPI_ERROR or NVAPI_OK

◆ __nvapi_deprecated_function() [5/5]

__nvapi_deprecated_function | ( | "Do not use this function - it is deprecated in release 520. | Instead,
 |  | use NvAPI_GPU_GetLogicalGpuInfo." |
 | ) |  |

DESCRIPTION: This API returns the OS-AdapterID from physicalGpu Handle. OS-AdapterID is the Adapter ID that is used by Win7 CCD APIs. This API is deprecated. Please use NvAPI_GPU_GetLogicalGpuInfo to get the OS-AdapterID. NvAPI_GetLogicalGPUFromPhysicalGPU can be used to get the logical GPU handle associated with specified physical GPU handle.

Parameters
[in] | hPhysicalGpu | PhysicalGpu Handle
[out] | pOSAdapterId | Returns OS-AdapterId, it is typed as void * to avoid dependency with windows.h. User must type cast it to LUID.
Return values
NVAPI_INVALID_ARGUMENT | pOSAdapterId is NULL; hPhysicalGpu is invalid
NVAPI_OK | *pOSAdapterId contains valid data.
NVAPI_NOT_SUPPORTED | This API is not supported on the system.

◆ NvAPI_DestroyPresentBarrierClient()

NVAPI_INTERFACE NvAPI_DestroyPresentBarrierClient ( __in NvPresentBarrierClientHandle presentBarrierClient )

SUPPORTED OS: Windows 10 and higher DESCRIPTION: This API destroys a presentBarrier client, and must be called after client leaves presentBarrier to avoid memory leak.

Since
Release: 470
Parameters
[in] presentBarrierClient An NvPresentBarrierClientHandle handle created by NvAPI_xxxx_CreatedPresentBarrierClient
Returns
NVAPI_OK the call succeeded
NVAPI_INVALID_HANDLE an invalid NvPresentBarrierClientHandle was passed as an argument
NVAPI_NO_IMPLEMENTATION the API is not implemented
Return values
NVAPI_API_NOT_INITIALIZED NvAPI not initialized

◆ NvAPI_DISP_GetNvManagedDedicatedDisplayMetadata()

NVAPI_INTERFACE NvAPI_DISP_GetNvManagedDedicatedDisplayMetadata ( __inout NV_MANAGED_DEDICATED_DISPLAY_METADATA * pDedicatedDisplayMetadata )

DESCRIPTION: This API returns metadata which has been set for the display connector in question. Main use case would be to query the data for an Nvidia managed dedicated display. The function will work for any valid displayId though.

Since
Release: 550
Parameters
[in/out] pDedicatedDisplayMetadata Data structure containing input and output data.
Return values
NVAPI_OK | The call succeeded.
NVAPI_ERROR | The call failed.
NVAPI_NO_IMPLEMENTATION | The API is not implemented in current driver.
NVAPI_NOT_SUPPORTED | The API is not supported on the current operating system or gpu.
NVAPI_OUT_OF_MEMORY | There wasn't sufficient memory to complete the call.
NVAPI_INVALID_POINTER | An invalid pointer was passed as an argument.
NVAPI_API_NOT_INITIALIZED | NvAPI was not initialized.
NVAPI_INCOMPATIBLE_STRUCT_VERSION | The version of the NV_MANAGED_DEDICATED_DISPLAY_METADATA structure is invalid.

◆ NvAPI_DISP_GetNvManagedDedicatedDisplays()

NVAPI_INTERFACE NvAPI_DISP_GetNvManagedDedicatedDisplays | ( | __inout NvU32 * | pDedicatedDisplayCount,
 |  | __inout NV_MANAGED_DEDICATED_DISPLAY_INFO * | pDedicatedDisplays
 | ) |  |

DESCRIPTION: This API returns the count of dedicated displays managed by the Nvidia driver, and specific driver info of each display. This API does not return VR displays.

HOW TO USE: 1) First make a call NvAPI_DISP_GetNvManagedDedicatedDisplays to get the number of dedicated displays managed by the Nvidia driver by passing pDedicatedDisplays as NULL. On call success: 2) Allocate memory based on pDisplayCount, then call NvAPI_DISP_GetNvManagedDedicatedDisplays to populate pDedicatedDisplays.

Since
Release: 495
Parameters
[in/out] | pDedicatedDisplayCount The count of dedicated displays managed by the Nvidia driver.
[in/out] | pDedicatedDisplays Pointer to an array of NV_MANAGED_DEDICATED_DISPLAY_INFO data structure.
Return values
NVAPI_OK | The call succeeded.
NVAPI_ERROR | The call failed.
NVAPI_NO_IMPLEMENTATION | The API is not implemented in current driver.
NVAPI_OUT_OF_MEMORY | Could not allocate sufficient memory to complete the call.
NVAPI_INVALID_POINTER | An invalid pointer was passed as an argument.
NVAPI_API_NOT_INITIALIZED | NvAPI was not initialized.
NVAPI_INCOMPATIBLE_STRUCT_VERSION | The version of NV_MANAGED_DEDICATED_DISPLAY_INFO structure is invalid.

◆ NvAPI_DISP_SetNvManagedDedicatedDisplayMetadata()

NVAPI_INTERFACE NvAPI_DISP_SetNvManagedDedicatedDisplayMetadata ( __inout NV_MANAGED_DEDICATED_DISPLAY_METADATA * pDedicatedDisplayMetadata )

SUPPORTED OS: Windows 11 and higher DESCRIPTION: This API allows to set metadata for the display connector in question. Main use case would be to set the data for an Nvidia managed dedicated display. The function will work for any valid displayId though.

Since
Release: 550
Parameters
[in/out] pDedicatedDisplayMetadata Data structure containing input and output data.
Return values
NVAPI_OK | The call succeeded.
NVAPI_ERROR | The call failed.
NVAPI_NO_IMPLEMENTATION | The API is not implemented in current driver.
NVAPI_NOT_SUPPORTED | The API is not supported on the current operating system or gpu.
NVAPI_OUT_OF_MEMORY | There wasn't sufficient memory to complete the call.
NVAPI_INVALID_POINTER | An invalid pointer was passed as an argument.
NVAPI_API_NOT_INITIALIZED | NvAPI was not initialized.
NVAPI_INCOMPATIBLE_STRUCT_VERSION | The version of the NV_MANAGED_DEDICATED_DISPLAY_METADATA structure is invalid.
NVAPI_INVALID_USER_PRIVILEGE | The caller doesn't have the required administrator privileges to access this API.
NVAPI_INVALID_ARGUMENT | Characters in pDedicatedDisplayMetadata->name are out of the allowed range.

◆ NvAPI_EnumLogicalGPUs()

NVAPI_INTERFACE NvAPI_EnumLogicalGPUs | ( | NvLogicalGpuHandle | nvGPUHandle[NVAPI_MAX_LOGICAL_GPUS],
 |  | NvU32 * | pGpuCount
 | ) |  |

This function returns an array of logical GPU handles.

Each handle represents one or more GPUs acting in concert as a single graphics device.

At least one GPU must be present in the system and running an NVIDIA display driver.

The array nvGPUHandle will be filled with logical GPU handle values. The returned gpuCount determines how many entries in the array are valid.

Note
All logical GPUs handles get invalidated on a GPU topology change, so the calling application is required to renum the logical GPU handles to get latest physical handle mapping after every GPU topology change activated by a call to NvAPI_SetGpuTopologies().

To detect if SLI rendering is enabled, use NvAPI_D3D_GetCurrentSLIState().

SUPPORTED OS: Windows 7 and higher

Since
Release: 80
Return values
NVAPI_INVALID_ARGUMENT | nvGPUHandle or pGpuCount is NULL
NVAPI_OK | One or more handles were returned
NVAPI_NVIDIA_DEVICE_NOT_FOUND | No NVIDIA GPU driving a display was found

◆ NvAPI_EnumPhysicalGPUs()

NVAPI_INTERFACE NvAPI_EnumPhysicalGPUs | ( | NvPhysicalGpuHandle | nvGPUHandle[NVAPI_MAX_PHYSICAL_GPUS],
 |  | NvU32 * | pGpuCount
 | ) |  |

This function returns an array of physical GPU handles. Each handle represents a physical GPU present in the system. That GPU may be part of an SLI configuration, or may not be visible to the OS directly.

At least one GPU must be present in the system and running an NVIDIA display driver.

The array nvGPUHandle will be filled with physical GPU handle values. The returned gpuCount determines how many entries in the array are valid.

Note
In drivers older than 105.00, all physical GPU handles get invalidated on a modeset. So the calling applications need to renum the handles after every modeset.
With drivers 105.00 and up, all physical GPU handles are constant. Physical GPU handles are constant as long as the GPUs are not physically moved and the SBIOS VGA order is unchanged.

For GPU handles in TCC MODE please use NvAPI_EnumTCCPhysicalGPUs()

SUPPORTED OS: Windows 7 and higher

Introduced in
Since
Release: 80
Return values
NVAPI_INVALID_ARGUMENT | nvGPUHandle or pGpuCount is NULL
NVAPI_OK | One or more handles were returned
NVAPI_NVIDIA_DEVICE_NOT_FOUND | No NVIDIA GPU driving a display was found

◆ NvAPI_EnumTCCPhysicalGPUs()

NVAPI_INTERFACE NvAPI_EnumTCCPhysicalGPUs | ( | NvPhysicalGpuHandle | nvGPUHandle[NVAPI_MAX_PHYSICAL_GPUS],
 |  | NvU32 * | pGpuCount
 | ) |  |

This function returns an array of physical GPU handles that are in TCC Mode. Each handle represents a physical GPU present in the system in TCC Mode. That GPU may not be visible to the OS directly.

The array nvGPUHandle will be filled with physical GPU handle values. The returned gpuCount determines how many entries in the array are valid.

NOTE: Handles enumerated by this API are only valid for NvAPIs that are tagged as TCC_SUPPORTED If handle is passed to any other API, it will fail with NVAPI_INVALID_HANDLE

For WDDM GPU handles please use NvAPI_EnumPhysicalGPUs()

SUPPORTED OS: Windows 7 and higher

Parameters
[out] | nvGPUHandle | Physical GPU array that will contain all TCC Physical GPUs
[out] | pGpuCount | count represent the number of valid entries in nvGPUHandle
Return values
NVAPI_INVALID_ARGUMENT nvGPUHandle or pGpuCount is NULL

◆ NvAPI_Event_RegisterCallback()

NVAPI_INTERFACE NvAPI_Event_RegisterCallback | ( | PNV_EVENT_REGISTER_CALLBACK | eventCallback,
 |  | NvEventHandle * | phClient
 | ) |  |

DESCRIPTION: This API registers the process for events. This API should be called for each eventcallback. The handle returned to the client will be common across all eventCallbacks.

SUPPORTED OS: Windows 7 and higher

Parameters
[in] | eventCallback | Pointer to NV_EVENT_REGISTER_CALLBACK structure to call on new events
[out] | phClient | Handle to client for use with unregister function
Return values
NVAPI_OK | - completed request
NVAPI_API_NOT_INTIALIZED | - NvAPI not initialized
NVAPI_INVALID_ARGUMENT | - Invalid argument
NVAPI_ERROR | - miscellaneous error occurred

◆ NvAPI_Event_UnregisterCallback()

NVAPI_INTERFACE NvAPI_Event_UnregisterCallback ( NvEventHandle hClient )

DESCRIPTION: This API unregister an event handle. This API should be called only once per process(irrespective of the number of callbacks registered).

SUPPORTED OS: Windows 7 and higher

Parameters
[in] hClient Handle associated with this listeners event queue. Same as returned from NvAPI_Event_RegisterCallback().
Return values
NVAPI_OK | - completed request
NVAPI_API_NOT_INTIALIZED | - NvAPI not initialized
NVAPI_INVALID_ARGUMENT | - Invalid argument
NVAPI_ERROR | - miscellaneous error occurred

◆ NvAPI_GetGPUIDfromPhysicalGPU()

NVAPI_INTERFACE NvAPI_GetGPUIDfromPhysicalGPU | ( | NvPhysicalGpuHandle | hPhysicalGpu,
 |  | NvU32 * | pGpuId
 | ) |  |

Do not use this function for new software development.

SUPPORTED OS: Windows 10 and higher

TCC_SUPPORTED

MCDM_SUPPORTED

Since
Release: 95
Return values
NVAPI_INVALID_ARGUMENT | hPhysicalGpu is NULL or invalid. Re-enumerate the GPU handles.
NVAPI_OK | Handle was returned
NVAPI_NVIDIA_DEVICE_NOT_FOUND | No NVIDIA GPU driving a display was found

◆ NvAPI_GetLogicalGPUFromDisplay()

NVAPI_INTERFACE NvAPI_GetLogicalGPUFromDisplay | ( | NvDisplayHandle | hNvDisp,
 |  | NvLogicalGpuHandle * | pLogicalGPU
 | ) |  |

This function returns the logical GPU handle associated with the specified display. At least one GPU must be present in the system and running an NVIDIA display driver. hNvDisp can be NVAPI_DEFAULT_HANDLE or a handle enumerated from NvAPI_EnumNVidiaDisplayHandle().

SUPPORTED OS: Windows 7 and higher

Since
Release: 80
Return values
NVAPI_INVALID_ARGUMENT | hNvDisp is not valid; pLogicalGPU is NULL
NVAPI_OK | One or more handles were returned
NVAPI_NVIDIA_DEVICE_NOT_FOUND | No NVIDIA GPU driving a display was found

◆ NvAPI_GetLogicalGPUFromPhysicalGPU()

NVAPI_INTERFACE NvAPI_GetLogicalGPUFromPhysicalGPU | ( | NvPhysicalGpuHandle | hPhysicalGPU,
 |  | NvLogicalGpuHandle * | pLogicalGPU
 | ) |  |

This function returns the logical GPU handle associated with specified physical GPU handle. At least one GPU must be present in the system and running an NVIDIA display driver.

SUPPORTED OS: Windows 7 and higher

Since
Release: 80
Return values
NVAPI_INVALID_ARGUMENT | hPhysicalGPU is not valid; pLogicalGPU is NULL
NVAPI_OK | One or more handles were returned
NVAPI_NVIDIA_DEVICE_NOT_FOUND | No NVIDIA GPU driving a display was found

◆ NvAPI_GetPhysicalGPUFromGPUID()

NVAPI_INTERFACE NvAPI_GetPhysicalGPUFromGPUID | ( | NvU32 | gpuId,
 |  | NvPhysicalGpuHandle * | pPhysicalGPU
 | ) |  |

Do not use this function for new software development.

SUPPORTED OS: Windows 10 and higher

TCC_SUPPORTED

MCDM_SUPPORTED

Since
Release: 80
Return values
NVAPI_INVALID_ARGUMENT | gpuId is zero or pPhysicalGPU is NULL
NVAPI_OK | Handle was returned
NVAPI_NVIDIA_DEVICE_NOT_FOUND | No NVIDIA GPU driving a display was found

◆ NvAPI_GetPhysicalGPUFromUnAttachedDisplay()

NVAPI_INTERFACE NvAPI_GetPhysicalGPUFromUnAttachedDisplay | ( | NvUnAttachedDisplayHandle | hNvUnAttachedDisp,
 |  | NvPhysicalGpuHandle * | pPhysicalGpu
 | ) |  |

This function returns a physical GPU handle associated with the specified unattached display. The source GPU is a physical render GPU which renders the frame buffer but may or may not drive the scan out.

At least one GPU must be present in the system and running an NVIDIA display driver.

SUPPORTED OS: Windows 7 and higher

Since
Release: 80
Return values
NVAPI_INVALID_ARGUMENT | hNvUnAttachedDisp is not valid or pPhysicalGpu is NULL.
NVAPI_OK | One or more handles were returned
NVAPI_NVIDIA_DEVICE_NOT_FOUND | No NVIDIA GPU driving a display was found

◆ NvAPI_GetPhysicalGPUsFromDisplay()

NVAPI_INTERFACE NvAPI_GetPhysicalGPUsFromDisplay | ( | NvDisplayHandle | hNvDisp,
 |  | NvPhysicalGpuHandle | nvGPUHandle[NVAPI_MAX_PHYSICAL_GPUS],
 |  | NvU32 * | pGpuCount
 | ) |  |

This function returns an array of physical GPU handles associated with the specified display.

At least one GPU must be present in the system and running an NVIDIA display driver.

The array nvGPUHandle will be filled with physical GPU handle values. The returned gpuCount determines how many entries in the array are valid.

If the display corresponds to more than one physical GPU, the first GPU returned is the one with the attached active output.

SUPPORTED OS: Windows 7 and higher

Since
Release: 80
Return values
NVAPI_INVALID_ARGUMENT | hNvDisp is not valid; nvGPUHandle or pGpuCount is NULL
NVAPI_OK | One or more handles were returned
NVAPI_NVIDIA_DEVICE_NOT_FOUND | no NVIDIA GPU driving a display was found

◆ NvAPI_GetPhysicalGPUsFromLogicalGPU()

NVAPI_INTERFACE NvAPI_GetPhysicalGPUsFromLogicalGPU | ( | NvLogicalGpuHandle | hLogicalGPU,
 |  | NvPhysicalGpuHandle | hPhysicalGPU[NVAPI_MAX_PHYSICAL_GPUS],
 |  | NvU32 * | pGpuCount
 | ) |  |

This function returns the physical GPU handles associated with the specified logical GPU handle. At least one GPU must be present in the system and running an NVIDIA display driver.

The array hPhysicalGPU will be filled with physical GPU handle values. The returned gpuCount determines how many entries in the array are valid.

SUPPORTED OS: Windows 7 and higher

Since
Release: 80
Return values
NVAPI_INVALID_ARGUMENT | hLogicalGPU is not valid; hPhysicalGPU is NULL
NVAPI_OK | One or more handles were returned
NVAPI_NVIDIA_DEVICE_NOT_FOUND | No NVIDIA GPU driving a display was found
NVAPI_EXPECTED_LOGICAL_GPU_HANDLE | hLogicalGPU was not a logical GPU handle

◆ NvAPI_GPU_GetActiveOutputs()

NVAPI_INTERFACE NvAPI_GPU_GetActiveOutputs | ( | NvPhysicalGpuHandle | hPhysicalGpu,
 |  | NvU32 * | pOutputsMask
 | ) |  |

This function is the same as NvAPI_GPU_GetAllOutputs but returns only the set of GPU output identifiers that are actively driving display devices.

SUPPORTED OS: Windows 7 and higher

Since
Release: 85
Return values
NVAPI_INVALID_ARGUMENT | hPhysicalGpu or pOutputsMask is NULL.
NVAPI_OK | *pOutputsMask contains a set of GPU-output identifiers.
NVAPI_NVIDIA_DEVICE_NOT_FOUND | No NVIDIA GPU driving a display was found.
NVAPI_EXPECTED_PHYSICAL_GPU_HANDLE | hPhysicalGpu was not a physical GPU handle.

◆ NvAPI_GPU_GetAllDisplayIds()

NVAPI_INTERFACE NvAPI_GPU_GetAllDisplayIds | ( | __in NvPhysicalGpuHandle | hPhysicalGpu,
 |  | __inout_ecount_part_opt *, *pDisplayIdCount NV_GPU_DISPLAYIDS * | pDisplayIds,
 |  | __inout NvU32 * | pDisplayIdCount
 | ) |  |

DESCRIPTION: This API returns display IDs for all possible outputs on the GPU. For DPMST connector, it will return display IDs for all the video sinks in the topology.
HOW TO USE: 1. The first call should be made to get the all display ID count. To get the display ID count, send in
a) hPhysicalGpu - a valid WDDM type GPU handle(enumerated using NvAPI_SYS_GetPhysicalGPUs()) as input,
b) pDisplayIds - NULL, as we just want to get the display ID count.
c) pDisplayIdCount - a valid pointer to NvU32, whose value is set to ZERO.
If all parameters are correct and this call is successful, this call will return the display ID's count.

  1. To get the display ID array, make the second call to NvAPI_GPU_GetAllDisplayIds() with
    a) hPhysicalGpu - should be same value which was sent in first call,
    b) pDisplayIds - pointer to the display ID array allocated by caller based on display ID count,
    eg. malloc(sizeof(NV_GPU_DISPLAYIDS) * pDisplayIdCount).
    c) pDisplayIdCount - a valid pointer to NvU32. This indicates for how many display IDs
    the memory is allocated(pDisplayIds) by the caller.
    If all parameters are correct and this call is successful, this call will return the display ID array and actual display ID count (which was obtained in the first call to NvAPI_GPU_GetAllDisplayIds). If the input display ID count is less than the actual display ID count, it will overwrite the input and give the pDisplayIdCount as actual count and the API will return NVAPI_INSUFFICIENT_BUFFER.

SUPPORTED OS: Windows 7 and higher

Parameters
[in] | hPhysicalGpu | GPU selection.
[in,out] | DisplayIds | Pointer to an array of NV_GPU_DISPLAYIDS structures, each entry represents one displayID and its attributes.
[in,out] | pDisplayIdCount | As input, this parameter indicates the number of display's id's for which caller has allocated the memory. As output, it will return the actual number of display IDs.
Returns
This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.
Return values
NVAPI_INSUFFICIENT_BUFFER When the input buffer(pDisplayIds) is less than the actual number of display IDs, this API will return NVAPI_INSUFFICIENT_BUFFER.

◆ NvAPI_GPU_GetArchInfo()

NvAPI_GPU_GetArchInfo | ( | NvPhysicalGpuHandle | hPhysicalGpu,
 |  | NV_GPU_ARCH_INFO * | pGpuArchInfo
 | ) |  |

This function retrieves the architecture, implementation and chip revision for the specified GPU .

SUPPORTED OS: Windows 7 and higher

TCC_SUPPORTED

MCDM_SUPPORTED

Since
Release: 85
Returns
This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.

◆ NvAPI_GPU_GetBoardInfo()

NVAPI_INTERFACE NvAPI_GPU_GetBoardInfo | ( | NvPhysicalGpuHandle | hPhysicalGpu,
 |  | NV_BOARD_INFO * | pBoardInfo
 | ) |  |

SUPPORTED OS: Windows 7 and higher DESCRIPTION: This API Retrieves the Board information (a unique GPU Board Serial Number) stored in the InfoROM.

Parameters
[in] | hPhysicalGpu | Physical GPU Handle.
[in,out] | NV_BOARD_INFO | Board Information.

TCC_SUPPORTED

MCDM_SUPPORTED

Return values
NVAPI_OK | completed request
NVAPI_ERROR | miscellaneous error occurred
NVAPI_EXPECTED_PHYSICAL_GPU_HANDLE | handle passed is not a physical GPU handle
NVAPI_API_NOT_INTIALIZED | NVAPI not initialized
NVAPI_INVALID_POINTER | pBoardInfo is NULL
NVAPI_INCOMPATIBLE_STRUCT_VERSION | the version of the INFO struct is not supported

◆ NvAPI_GPU_GetBusId()

NVAPI_INTERFACE NvAPI_GPU_GetBusId | ( | NvPhysicalGpuHandle | hPhysicalGpu,
 |  | NvU32 * | pBusId
 | ) |  |

DESCRIPTION: Returns the ID of the bus associated with this GPU.

SUPPORTED OS: Windows 7 and higher

TCC_SUPPORTED

MCDM_SUPPORTED

Since
Release: 167
Return values
NVAPI_INVALID_ARGUMENT | hPhysicalGpu or pBusId is NULL.
NVAPI_OK | *pBusId contains the bus ID.
NVAPI_NVIDIA_DEVICE_NOT_FOUND | No NVIDIA GPU driving a display was found.
NVAPI_EXPECTED_PHYSICAL_GPU_HANDLE | hPhysicalGpu was not a physical GPU handle.

◆ NvAPI_GPU_GetBusSlotId()

NVAPI_INTERFACE NvAPI_GPU_GetBusSlotId | ( | NvPhysicalGpuHandle | hPhysicalGpu,
 |  | NvU32 * | pBusSlotId
 | ) |  |

DESCRIPTION: Returns the ID of the bus slot associated with this GPU.

SUPPORTED OS: Windows 7 and higher

TCC_SUPPORTED

MCDM_SUPPORTED

Since
Release: 167
Return values
NVAPI_INVALID_ARGUMENT | hPhysicalGpu or pBusSlotId is NULL.
NVAPI_OK | *pBusSlotId contains the bus slot ID.
NVAPI_NVIDIA_DEVICE_NOT_FOUND | No NVIDIA GPU driving a display was found.
NVAPI_EXPECTED_PHYSICAL_GPU_HANDLE | hPhysicalGpu was not a physical GPU handle.

◆ NvAPI_GPU_GetBusType()

NVAPI_INTERFACE NvAPI_GPU_GetBusType | ( | NvPhysicalGpuHandle | hPhysicalGpu,
 |  | NV_GPU_BUS_TYPE * | pBusType
 | ) |  |

This function returns the type of bus associated with this GPU.

SUPPORTED OS: Windows 7 and higher

TCC_SUPPORTED

MCDM_SUPPORTED

Since
Release: 90
Returns
This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.
Return values
NVAPI_INVALID_ARGUMENT | hPhysicalGpu or pBusType is NULL.
NVAPI_OK | *pBusType contains bus identifier.

◆ NvAPI_GPU_GetConnectedDisplayIds()

NVAPI_INTERFACE NvAPI_GPU_GetConnectedDisplayIds | ( | __in NvPhysicalGpuHandle | hPhysicalGpu,
 |  | __inout_ecount_part_opt *, *pDisplayIdCount NV_GPU_DISPLAYIDS * | pDisplayIds,
 |  | __inout NvU32 * | pDisplayIdCount,
 |  | __in NvU32 | flags
 | ) |  |

DESCRIPTION: Due to space limitation NvAPI_GPU_GetConnectedOutputs can return maximum 32 devices, but this is no longer true for DPMST. NvAPI_GPU_GetConnectedDisplayIds will return all the connected display devices in the form of displayIds for the associated hPhysicalGpu. This function can accept set of flags to request cached, uncached, sli and lid to get the connected devices. Default value for flags will be cached .

HOW TO USE: 1) for each PhysicalGpu, make a call to get the number of connected displayId's using NvAPI_GPU_GetConnectedDisplayIds by passing the pDisplayIds as NULL On call success:

2) If pDisplayIdCount is greater than 0, allocate memory based on pDisplayIdCount. Then make a call NvAPI_GPU_GetConnectedDisplayIds to populate DisplayIds. However, if pDisplayIdCount is 0, do not make this call. SUPPORTED OS: Windows 7 and higher

Parameters
[in] | hPhysicalGpu | - GPU selection
[in] | flags | - One or more defines from NV_GPU_CONNECTED_IDS_FLAG_* as valid flags.
[in,out] | pDisplayIds | - Pointer to an NV_GPU_DISPLAYIDS struct, each entry represents a one displayID and its attributes
[in] | pDisplayIdCount | - Number of displayId's.
Return values
NVAPI_INVALID_ARGUMENT | hPhysicalGpu or pDisplayIds or pDisplayIdCount is NULL
NVAPI_OK | *pDisplayIds contains a set of GPU-output identifiers
NVAPI_NVIDIA_DEVICE_NOT_FOUND | no NVIDIA GPU driving a display was found
NVAPI_EXPECTED_PHYSICAL_GPU_HANDLE | hPhysicalGpu was not a physical GPU handle

◆ NvAPI_GPU_GetCurrentPCIEDownstreamWidth()

NVAPI_INTERFACE NvAPI_GPU_GetCurrentPCIEDownstreamWidth | ( | NvPhysicalGpuHandle | hPhysicalGpu,
 |  | NvU32 * | pWidth
 | ) |  |

This function returns the number of PCIE lanes being used for the PCIE interface downstream from the GPU.

SUPPORTED OS: Windows 7 and higher

TCC_SUPPORTED

MCDM_SUPPORTED

Since
Release: 90
Return values
NVAPI_INVALID_ARGUMENT | pWidth is NULL.
NVAPI_OK | Call successful.
NVAPI_NVIDIA_DEVICE_NOT_FOUND | No NVIDIA GPU driving a display was found.
NVAPI_EXPECTED_PHYSICAL_GPU_HANDLE | hPhysicalGpu was not a physical GPU handle.

◆ NvAPI_GPU_GetEDID()

NvAPI_GPU_GetEDID | ( | NvPhysicalGpuHandle | hPhysicalGpu,
 |  | NvU32 | displayOutputId,
 |  | NV_EDID * | pEDID
 | ) |  |

This function returns the EDID data for the specified GPU handle and connection bit mask. displayOutputId should have exactly 1 bit set to indicate a single display. See NvAPI Handles.

SUPPORTED OS: Windows 7 and higher

Since
Release: 85
Return values
NVAPI_INVALID_ARGUMENT | pEDID is NULL; displayOutputId has 0 or > 1 bits set
NVAPI_OK | *pEDID contains valid data.
NVAPI_NVIDIA_DEVICE_NOT_FOUND | No NVIDIA GPU driving a display was found.
NVAPI_EXPECTED_PHYSICAL_GPU_HANDLE | hPhysicalGpu was not a physical GPU handle.
NVAPI_DATA_NOT_FOUND | The requested display does not contain an EDID.

◆ NvAPI_GPU_GetFullName()

NVAPI_INTERFACE NvAPI_GPU_GetFullName | ( | NvPhysicalGpuHandle | hPhysicalGpu,
 |  | NvAPI_ShortString | szName
 | ) |  |

This function retrieves the full GPU name as an ASCII string - for example, "Quadro FX 1400".

SUPPORTED OS: Windows 7 and higher

TCC_SUPPORTED

MCDM_SUPPORTED

Since
Release: 90
Returns
NVAPI_ERROR or NVAPI_OK

◆ NvAPI_GPU_GetGpuCoreCount()

NVAPI_INTERFACE NvAPI_GPU_GetGpuCoreCount | ( | NvPhysicalGpuHandle | hPhysicalGpu,
 |  | NvU32 * | pCount
 | ) |  |

DESCRIPTION: Retrieves the total number of cores defined for a GPU. Returns 0 on architectures that don't define GPU cores.

SUPPORTED OS: Windows 7 and higher

TCC_SUPPORTED

MCDM_SUPPORTED

Return values
NVAPI_INVALID_ARGUMENT | pCount is NULL
NVAPI_OK | *pCount is set
NVAPI_NVIDIA_DEVICE_NOT_FOUND | no NVIDIA GPU driving a display was found
NVAPI_EXPECTED_PHYSICAL_GPU_HANDLE | hPhysicalGpu was not a physical GPU handle
NVAPI_NOT_SUPPORTED | API call is not supported on current architecture

◆ NvAPI_GPU_GetGPUInfo()

NVAPI_INTERFACE NvAPI_GPU_GetGPUInfo | ( | __in NvPhysicalGpuHandle | hPhysicalGpu,
 |  | __inout NV_GPU_INFO * | pGpuInfo
 | ) |  |

DESCRIPTION: This API will return NVIDIA GPU related information.

SUPPORTED OS: Windows 7 and higher

TCC_SUPPORTED

MCDM_SUPPORTED

Since
Release: 400
Parameters
[in,out] pGpuInfo - This structure will be filled with required information.
Returns
This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.

◆ NvAPI_GPU_GetGPUType()

NVAPI_INTERFACE NvAPI_GPU_GetGPUType | ( | __in NvPhysicalGpuHandle | hPhysicalGpu,
 |  | __inout NV_GPU_TYPE * | pGpuType
 | ) |  |

DESCRIPTION: This function returns the GPU type (integrated or discrete). See NV_GPU_TYPE.

SUPPORTED OS: Windows 7 and higher

TCC_SUPPORTED

MCDM_SUPPORTED

Since
Release: 173
Return values
NVAPI_INVALID_ARGUMENT | hPhysicalGpu
NVAPI_OK | *pGpuType contains the GPU type
NVAPI_NVIDIA_DEVICE_NOT_FOUND | No NVIDIA GPU driving a display was found
NVAPI_EXPECTED_PHYSICAL_GPU_HANDLE | hPhysicalGpu was not a physical GPU handle

◆ NvAPI_GPU_GetGspFeatures()

NVAPI_INTERFACE NvAPI_GPU_GetGspFeatures | ( | __in NvPhysicalGpuHandle | hPhysicalGpu,
 |  | __inout NV_GPU_GSP_INFO * | pGspInfo
 | ) |  |

DESCRIPTION: If the device has GSP running, this function populates firmwareVersion field with GSP firmware version and returns NVAPI_OK Otherwise returns NVAPI_NOT_SUPPORTED

SUPPORTED OS: Windows 10 and higher

TCC_SUPPORTED

MCDM_SUPPORTED

Since
Release: 550
Parameters
[in] | hPhysicalGpu | GPU selection
[out] | pGspInfo | GSP firmware version
Return values
NVAPI_INVALID_ARGUMENT | pMemoryInfo is NULL
NVAPI_OK | call successful
NVAPI_API_NOT_INTIALIZED | nvapi not initialized
NVAPI_EXPECTED_PHYSICAL_GPU_HANDLE | hPhysicalGpu was not a physical GPU handle
NVAPI_INCOMPATIBLE_STRUCT_VERSION | NV_GPU_GSP_INFO structure version mismatch
NVAPI_NOT_SUPPORTED | GSP is not running/supported on this device

◆ NvAPI_GPU_GetHDCPSupportStatus()

NvAPI_GPU_GetHDCPSupportStatus | ( | NvPhysicalGpuHandle | hPhysicalGpu,
 |  | NV_GPU_GET_HDCP_SUPPORT_STATUS * | pGetHDCPSupportStatus
 | ) |  |

DESCRIPTION: This function returns a GPU's HDCP support status.

SUPPORTED OS: Windows 7 and higher

TCC_SUPPORTED

MCDM_SUPPORTED

Since
Release: 175
Return values
NVAPI_OK
NVAPI_ERROR
NVAPI_INVALID_ARGUMENT
NVAPI_HANDLE_INVALIDATED
NVAPI_EXPECTED_PHYSICAL_GPU_HANDLE
NVAPI_INCOMPATIBLE_STRUCT_VERSION

◆ NvAPI_GPU_GetIllumination()

NVAPI_INTERFACE NvAPI_GPU_GetIllumination ( NV_GPU_GET_ILLUMINATION_PARM * pIlluminationInfo )

◆ NvAPI_GPU_GetIRQ()

NVAPI_INTERFACE NvAPI_GPU_GetIRQ | ( | NvPhysicalGpuHandle | hPhysicalGpu,
 |  | NvU32 * | pIRQ
 | ) |  |

This function returns the interrupt number associated with this GPU.

SUPPORTED OS: Windows 7 and higher

TCC_SUPPORTED

MCDM_SUPPORTED

Since
Release: 90
Return values
NVAPI_INVALID_ARGUMENT | hPhysicalGpu or pIRQ is NULL.
NVAPI_OK | *pIRQ contains interrupt number.
NVAPI_NVIDIA_DEVICE_NOT_FOUND | No NVIDIA GPU driving a display was found.
NVAPI_EXPECTED_PHYSICAL_GPU_HANDLE | hPhysicalGpu was not a physical GPU handle.

◆ NvAPI_GPU_GetLogicalGpuInfo()

NVAPI_INTERFACE NvAPI_GPU_GetLogicalGpuInfo | ( | __in NvLogicalGpuHandle | hLogicalGpu,
 |  | __inout NV_LOGICAL_GPU_DATA * | pLogicalGpuData
 | ) |  |

This function is used to query Logical GPU information.

SUPPORTED OS: Windows 7 and higher

Since
Release: 421
Parameters
[in] | hLogicalGpu | logical GPU Handle.
[in,out] | pLogicalGpuData | Pointer to NV_LOGICAL_GPU_DATA structure.
Returns
This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.

◆ NvAPI_GPU_GetOutputType()

NvAPI_GPU_GetOutputType | ( | NvPhysicalGpuHandle | hPhysicalGpu,
 |  | NvU32 | outputId,
 |  | NV_GPU_OUTPUT_TYPE * | pOutputType
 | ) |  |

This function returns the output type. User can either specify both 'physical GPU handle and outputId (exactly 1 bit set - see NvAPI Handles)' or a valid displayId in the outputId parameter.

SUPPORTED OS: Windows 7 and higher

\Version Earliest supported ForceWare version: 82.61

Return values
NVAPI_INVALID_ARGUMENT | outputId, pOutputType is NULL; or if outputId parameter is not displayId and either it has > 1 bit set or hPhysicalGpu is NULL.
NVAPI_OK | *pOutputType contains a NvGpuOutputType value
NVAPI_NVIDIA_DEVICE_NOT_FOUND | No NVIDIA GPU driving a display was found
NVAPI_EXPECTED_PHYSICAL_GPU_HANDLE | hPhysicalGpu was not a physical GPU handle

◆ NvAPI_GPU_GetPCIIdentifiers()

NVAPI_INTERFACE NvAPI_GPU_GetPCIIdentifiers | ( | NvPhysicalGpuHandle | hPhysicalGpu,
 |  | NvU32 * | pDeviceId,
 |  | NvU32 * | pSubSystemId,
 |  | NvU32 * | pRevisionId,
 |  | NvU32 * | pExtDeviceId
 | ) |  |

This function returns the PCI identifiers associated with this GPU.

SUPPORTED OS: Windows 7 and higher

TCC_SUPPORTED

MCDM_SUPPORTED

Since
Release: 90
Parameters
DeviceId | The internal PCI device identifier for the GPU.
SubSystemId | The internal PCI subsystem identifier for the GPU.
RevisionId | The internal PCI device-specific revision identifier for the GPU.
ExtDeviceId | The external PCI device identifier for the GPU.
Return values
NVAPI_INVALID_ARGUMENT | hPhysicalGpu or an argument is NULL
NVAPI_OK | Arguments are populated with PCI identifiers
NVAPI_NVIDIA_DEVICE_NOT_FOUND | No NVIDIA GPU driving a display was found
NVAPI_EXPECTED_PHYSICAL_GPU_HANDLE | hPhysicalGpu was not a physical GPU handle

◆ NvAPI_GPU_GetPhysicalFrameBufferSize()

NVAPI_INTERFACE NvAPI_GPU_GetPhysicalFrameBufferSize | ( | NvPhysicalGpuHandle | hPhysicalGpu,
 |  | NvU32 * | pSize
 | ) |  |

This function returns the physical size of framebuffer in KB. This does NOT include any system RAM that may be dedicated for use by the GPU.

SUPPORTED OS: Windows 7 and higher

TCC_SUPPORTED

MCDM_SUPPORTED

Since
Release: 90
Return values
NVAPI_INVALID_ARGUMENT | pSize is NULL
NVAPI_OK | Call successful
NVAPI_NVIDIA_DEVICE_NOT_FOUND | No NVIDIA GPU driving a display was found
NVAPI_EXPECTED_PHYSICAL_GPU_HANDLE | hPhysicalGpu was not a physical GPU handle

◆ NvAPI_GPU_GetRamBusWidth()

NVAPI_INTERFACE NvAPI_GPU_GetRamBusWidth | ( | NvPhysicalGpuHandle | hPhysicalGpu,
 |  | NvU32 * | pBusWidth
 | ) |  |

This function returns the width of the GPU's RAM memory bus.

SUPPORTED OS: Windows 7 and higher

TCC_SUPPORTED

MCDM_SUPPORTED

Since
Release: 100
Returns
NVAPI_ERROR or NVAPI_OK

◆ NvAPI_GPU_GetScanoutCompositionParameter()

NVAPI_INTERFACE NvAPI_GPU_GetScanoutCompositionParameter | ( | __in NvU32 | displayId,
 |  | __in NV_GPU_SCANOUT_COMPOSITION_PARAMETER | parameter,
 |  | __out NV_GPU_SCANOUT_COMPOSITION_PARAMETER_VALUE * | parameterData,
 |  | __out float * | pContainer
 | ) |  |

DESCRIPTION: This API queries current state of one of the various scanout composition parameters on the specified display.

SUPPORTED OS: Windows 7 and higher

Parameters
[in] | displayId | combined physical display and GPU identifier of the display to query the configuration.
[in] | parameter | scanout composition parameter to by queried.
[out] | parameterData | scanout composition parameter data.
[out] | pContainer | Additional container for returning data associated with the specified parameter
Returns
This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.
Return values
NVAPI_INVALID_ARGUMENT | Invalid input parameters.
NVAPI_API_NOT_INITIALIZED | NvAPI not initialized.
NVAPI_NOT_SUPPORTED | Interface not supported by the driver used, or only supported on selected GPUs.
NVAPI_OK | Feature enabled.
NVAPI_ERROR | Miscellaneous error occurred.

◆ NvAPI_GPU_GetScanoutConfiguration()

NVAPI_INTERFACE NvAPI_GPU_GetScanoutConfiguration | ( | NvU32 | displayId,
 |  | NvSBox * | desktopRect,
 |  | NvSBox * | scanoutRect
 | ) |  |

DESCRIPTION: This API queries the desktop and scanout portion of the specified display.

SUPPORTED OS: Windows 7 and higher

Parameters
[in] | displayId | combined physical display and GPU identifier of the display to query the configuration.
[in,out] | desktopRect | desktop area of the display in desktop coordinates.
[in,out] | scanoutRect | scanout area of the display relative to desktopRect.
Return values
NVAPI_INVALID_ARGUMENT | Invalid input parameters.
NVAPI_API_NOT_INITIALIZED | NvAPI not initialized.
NVAPI_NOT_SUPPORTED | Interface not supported by the driver used, or only supported on selected GPUs.
NVAPI_OK | Feature enabled.
NVAPI_ERROR | Miscellaneous error occurred.

◆ NvAPI_GPU_GetScanoutConfigurationEx()

NVAPI_INTERFACE NvAPI_GPU_GetScanoutConfigurationEx | ( | __in NvU32 | displayId,
 |  | __inout NV_SCANOUT_INFORMATION * | pScanoutInformation
 | ) |  |

DESCRIPTION: This API queries the desktop and scanout portion of the specified display.

SUPPORTED OS: Windows 7 and higher

Since
Release: 331
Parameters
[in] | displayId | combined physical display and GPU identifier of the display to query the configuration.
[in,out] | pScanoutInformation | desktop area to displayId mapping information.
Returns
This API can return any of the error codes enumerated in NvAPI_Status.

◆ NvAPI_GPU_GetScanoutIntensityState()

NVAPI_INTERFACE NvAPI_GPU_GetScanoutIntensityState | ( | __in NvU32 | displayId,
 |  | __inout NV_SCANOUT_INTENSITY_STATE_DATA * | scanoutIntensityStateData
 | ) |  |

DESCRIPTION: This API queries current state of the intensity feature on the specified display.

SUPPORTED OS: Windows 7 and higher

Parameters
[in] | displayId | combined physical display and GPU identifier of the display to query the configuration.
[in,out] | scanoutIntensityStateData | intensity state data.
Returns
This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.
Return values
NVAPI_INVALID_ARGUMENT | Invalid input parameters.
NVAPI_API_NOT_INITIALIZED | NvAPI not initialized.
NVAPI_NOT_SUPPORTED | Interface not supported by the driver used, or only supported on selected GPUs.
NVAPI_OK | Feature enabled.
NVAPI_ERROR | Miscellaneous error occurred.

◆ NvAPI_GPU_GetScanoutWarpingState()

NVAPI_INTERFACE NvAPI_GPU_GetScanoutWarpingState | ( | __in NvU32 | displayId,
 |  | __inout NV_SCANOUT_WARPING_STATE_DATA * | scanoutWarpingStateData
 | ) |  |

DESCRIPTION: This API queries current state of the warping feature on the specified display.

SUPPORTED OS: Windows 7 and higher

Parameters
[in] | displayId | combined physical display and GPU identifier of the display to query the configuration.
[in,out] | scanoutWarpingStateData | warping state data.
Returns
This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.
Return values
NVAPI_INVALID_ARGUMENT | Invalid input parameters.
NVAPI_API_NOT_INITIALIZED | NvAPI not initialized.
NVAPI_NOT_SUPPORTED | Interface not supported by the driver used, or only supported on selected GPUs.
NVAPI_OK | Feature enabled.
NVAPI_ERROR | Miscellaneous error occurred.

◆ NvAPI_GPU_GetShaderSubPipeCount()

NVAPI_INTERFACE NvAPI_GPU_GetShaderSubPipeCount | ( | NvPhysicalGpuHandle | hPhysicalGpu,
 |  | NvU32 * | pCount
 | ) |  |

DESCRIPTION: This function retrieves the number of Shader SubPipes on the GPU On newer architectures, this corresponds to the number of SM units

SUPPORTED OS: Windows 7 and higher

TCC_SUPPORTED

MCDM_SUPPORTED

Since
Release: 170
Return values
NVAPI_INVALID_ARGUMENT | pCount is NULL
NVAPI_OK | *pCount is set
NVAPI_NVIDIA_DEVICE_NOT_FOUND | no NVIDIA GPU driving a display was found
NVAPI_EXPECTED_PHYSICAL_GPU_HANDLE | hPhysicalGpu was not a physical GPU handle

◆ NvAPI_GPU_GetSystemType()

NvAPI_GPU_GetSystemType | ( | NvPhysicalGpuHandle | hPhysicalGpu,
 |  | NV_SYSTEM_TYPE * | pSystemType
 | ) |  |

This function identifies whether the GPU is a notebook GPU or a desktop GPU.

SUPPORTED OS: Windows 7 and higher

TCC_SUPPORTED

MCDM_SUPPORTED

Since
Release: 95
Return values
NVAPI_INVALID_ARGUMENT | hPhysicalGpu or pOutputsMask is NULL
NVAPI_OK | *pSystemType contains the GPU system type
NVAPI_NVIDIA_DEVICE_NOT_FOUND | No NVIDIA GPU driving a display was found
NVAPI_EXPECTED_PHYSICAL_GPU_HANDLE | hPhysicalGpu was not a physical GPU handle

◆ NvAPI_GPU_GetVbiosOEMRevision()

NVAPI_INTERFACE NvAPI_GPU_GetVbiosOEMRevision | ( | NvPhysicalGpuHandle | hPhysicalGpu,
 |  | NvU32 * | pBiosRevision
 | ) |  |

This function returns the OEM revision of the video BIOS associated with this GPU.

SUPPORTED OS: Windows 7 and higher

TCC_SUPPORTED

MCDM_SUPPORTED

Since
Release: 90
Return values
NVAPI_INVALID_ARGUMENT | hPhysicalGpu or pBiosRevision is NULL
NVAPI_OK | *pBiosRevision contains revision number
NVAPI_NVIDIA_DEVICE_NOT_FOUND | No NVIDIA GPU driving a display was found
NVAPI_EXPECTED_PHYSICAL_GPU_HANDLE | hPhysicalGpu was not a physical GPU handle

◆ NvAPI_GPU_GetVbiosRevision()

NVAPI_INTERFACE NvAPI_GPU_GetVbiosRevision | ( | NvPhysicalGpuHandle | hPhysicalGpu,
 |  | NvU32 * | pBiosRevision
 | ) |  |

This function returns the revision of the video BIOS associated with this GPU.

SUPPORTED OS: Windows 7 and higher

TCC_SUPPORTED

MCDM_SUPPORTED

Since
Release: 90
Return values
NVAPI_INVALID_ARGUMENT | hPhysicalGpu or pBiosRevision is NULL.
NVAPI_OK | *pBiosRevision contains revision number.
NVAPI_NVIDIA_DEVICE_NOT_FOUND | No NVIDIA GPU driving a display was found.
NVAPI_EXPECTED_PHYSICAL_GPU_HANDLE | hPhysicalGpu was not a physical GPU handle.

◆ NvAPI_GPU_GetVbiosVersionString()

NVAPI_INTERFACE NvAPI_GPU_GetVbiosVersionString | ( | NvPhysicalGpuHandle | hPhysicalGpu,
 |  | NvAPI_ShortString | szBiosRevision
 | ) |  |

This function returns the full video BIOS version string in the form of xx.xx.xx.xx.yy where

  • xx numbers come from NvAPI_GPU_GetVbiosRevision() and
  • yy comes from NvAPI_GPU_GetVbiosOEMRevision().

SUPPORTED OS: Windows 7 and higher

TCC_SUPPORTED

MCDM_SUPPORTED

Since
Release: 90
Return values
NVAPI_INVALID_ARGUMENT | hPhysicalGpu is NULL.
NVAPI_OK | szBiosRevision contains version string.
NVAPI_NVIDIA_DEVICE_NOT_FOUND | No NVIDIA GPU driving a display was found.
NVAPI_EXPECTED_PHYSICAL_GPU_HANDLE | hPhysicalGpu was not a physical GPU handle.

◆ NvAPI_GPU_GetVirtualFrameBufferSize()

NVAPI_INTERFACE NvAPI_GPU_GetVirtualFrameBufferSize | ( | NvPhysicalGpuHandle | hPhysicalGpu,
 |  | NvU32 * | pSize
 | ) |  |

This function returns the virtual size of framebuffer in KB. This includes the physical RAM plus any system RAM that has been dedicated for use by the GPU.

SUPPORTED OS: Windows 7 and higher

TCC_SUPPORTED

MCDM_SUPPORTED

Since
Release: 90
Return values
NVAPI_INVALID_ARGUMENT | pSize is NULL.
NVAPI_OK | Call successful.
NVAPI_NVIDIA_DEVICE_NOT_FOUND | No NVIDIA GPU driving a display was found.
NVAPI_EXPECTED_PHYSICAL_GPU_HANDLE | hPhysicalGpu was not a physical GPU handle.

◆ NvAPI_GPU_GetVirtualizationInfo()

NVAPI_INTERFACE NvAPI_GPU_GetVirtualizationInfo | ( | __in NvPhysicalGpuHandle | hPhysicalGpu,
 |  | __inout NV_GPU_VIRTUALIZATION_INFO * | pVirtualizationInfo
 | ) |  |

FUNCTION NAME: NvAPI_GPU_GetVirtualizationInfo

DESCRIPTION: This API returns virtualization information of the GPU

SUPPORTED OS: Windows 7 and higher

TCC_SUPPORTED

MCDM_SUPPORTED

Since
Release: 367
Parameters
[in,out] pVirtualizationInfo Pointer to NV_GPU_VIRTUALIZATION_INFO structure.
Returns
This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.

◆ NvAPI_GPU_GetVRReadyData()

NVAPI_INTERFACE NvAPI_GPU_GetVRReadyData | ( | __in NvPhysicalGpuHandle | hPhysicalGpu,
 |  | __inout NV_GPU_VR_READY * | pGpuVrReadyData
 | ) |  |

DESCRIPTION: This API will return NVIDIA GPU VR Ready state.

SUPPORTED OS: Windows 10 and higher

TCC_SUPPORTED

MCDM_SUPPORTED

Since
Release: 465
Parameters
[in,out] pGpuVrReadyData - This structure will be filled with required information.
Returns
This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.

◆ NvAPI_GPU_QueryIlluminationSupport()

NVAPI_INTERFACE NvAPI_GPU_QueryIlluminationSupport ( __inout NV_GPU_QUERY_ILLUMINATION_SUPPORT_PARM * pIlluminationSupportInfo )

◆ NvAPI_GPU_QueryWorkstationFeatureSupport()

NvAPI_GPU_QueryWorkstationFeatureSupport | ( | NvPhysicalGpuHandle | physicalGpu,
 |  | NV_GPU_WORKSTATION_FEATURE_TYPE | gpuWorkstationFeature
 | ) |  |
DESCRIPTION: Indicates whether a queried workstation feature is supported by the requested GPU.
SUPPORTED OS: Windows 10 and higher
\since Release: 440
DESCRIPTION: This API, when called with a valid physical gpu handle as Input, lets caller know whether the given workstation feature is supported by this GPU.
PARAMETERS: physicalGpu(IN) : The handle of the GPU for the which caller wants to get the support information.
gpuWorkstationFeature(IN ) : The feature for the GPU in question. One of the values from enum NV_GPU_WORKSTATION_FEATURE_TYPE.
\return This API can return any of the error codes enumerated in #NvAPI_Status listed below
\retval ::NVAPI_OK the queried workstation feature is supported on the given GPU.
\retval ::NVAPI_NO_IMPLEMENTATION the current driver doesn't support this interface.
\retval ::NVAPI_INVALID_HANDLE the incoming physicalGpu handle is invalid.
\retval ::NVAPI_NOT_SUPPORTED the requested gpuWorkstationFeature is not supported in the selected GPU.
\retval ::NVAPI_SETTING_NOT_FOUND the requested gpuWorkstationFeature is unknown to the current driver version.
NV_GPU_WORKSTATION_FEATURE_TYPE
enum _NV_GPU_WORKSTATION_FEATURE_TYPE NV_GPU_WORKSTATION_FEATURE_TYPE
NvAPI_Status
enum _NvAPI_Status NvAPI_Status
NVAPI_NO_IMPLEMENTATION
@ NVAPI_NO_IMPLEMENTATION
not implemented in current driver installation
Definition nvapi_lite_common.h:261
NVAPI_OK
@ NVAPI_OK
Success. Request is completed.
Definition nvapi_lite_common.h:258

◆ NvAPI_GPU_SetEDID()

NVAPI_INTERFACE NvAPI_GPU_SetEDID | ( | NvPhysicalGpuHandle | hPhysicalGpu,
 |  | NvU32 | displayOutputId,
 |  | NV_EDID * | pEDID
 | ) |  |

Thus function sets the EDID data for the specified GPU handle and connection bit mask. User can either send (Gpu handle & output id) or only display Id in variable displayOutputId parameter & hPhysicalGpu parameter can be default handle (0).

Note
The EDID will be cached across the boot session and will be enumerated to the OS in this call. To remove the EDID set sizeofEDID to zero. OS and NVAPI connection status APIs will reflect the newly set or removed EDID dynamically.
    This feature will NOT be supported on the following boards:
    - GeForce
    - Quadro VX
    - Tesla
SUPPORTED OS: Windows 7 and higher
Since
Release: 100
Return values
NVAPI_INVALID_ARGUMENT | pEDID is NULL; displayOutputId has 0 or > 1 bits set
NVAPI_OK | *pEDID data was applied to the requested displayOutputId.
NVAPI_NVIDIA_DEVICE_NOT_FOUND | No NVIDIA GPU driving a display was found.
NVAPI_EXPECTED_PHYSICAL_GPU_HANDLE | hPhysicalGpu was not a physical GPU handle.
NVAPI_NOT_SUPPORTED | For the above mentioned GPUs
NVAPI_INVALID_USER_PRIVILEGE | The application will require Administrator privileges to access this API. The application can be elevated to a higher permission level by selecting "Run as Administrator".

◆ NvAPI_GPU_SetIllumination()

NVAPI_INTERFACE NvAPI_GPU_SetIllumination ( NV_GPU_SET_ILLUMINATION_PARM * pIlluminationInfo )

◆ NvAPI_GPU_SetScanoutCompositionParameter()

NVAPI_INTERFACE NvAPI_GPU_SetScanoutCompositionParameter | ( | NvU32 | displayId,
 |  | NV_GPU_SCANOUT_COMPOSITION_PARAMETER | parameter,
 |  | NV_GPU_SCANOUT_COMPOSITION_PARAMETER_VALUE | parameterValue,
 |  | float * | pContainer
 | ) |  |

DESCRIPTION: This API sets various parameters that configure the scanout composition feature on the specified display. (currently there is only one configurable parameter defined: WARPING_RESAMPLING_METHOD, but this function is designed to support the addition of parameters as needed.)

SUPPORTED OS: Windows 7 and higher

Parameters
[in] | displayId | Combined physical display and GPU identifier of the display to apply the intensity control
[in] | parameter | The scanout composition parameter to be set
[in] | parameterValue | The data to be set for the specified parameter
[in] | pContainer | Additional container for data associated with the specified parameter
Return values
NVAPI_INVALID_ARGUMENT | Invalid input parameters.
NVAPI_API_NOT_INITIALIZED | NvAPI not initialized.
NVAPI_NOT_SUPPORTED | Interface not supported by the driver used, or only supported on selected GPUs
NVAPI_INVALID_ARGUMENT | Invalid input data.
NVAPI_OK | Feature enabled.
NVAPI_ERROR | Miscellaneous error occurred.

◆ NvAPI_GPU_SetScanoutIntensity()

NVAPI_INTERFACE NvAPI_GPU_SetScanoutIntensity | ( | NvU32 | displayId,
 |  | NV_SCANOUT_INTENSITY_DATA * | scanoutIntensityData,
 |  | int * | pbSticky
 | ) |  |

DESCRIPTION: This API enables and sets up per-pixel intensity feature on the specified display.

SUPPORTED OS: Windows 7 and higher

Parameters
[in] | displayId | combined physical display and GPU identifier of the display to apply the intensity control.
[in] | scanoutIntensityData | the intensity texture info.
[out] | pbSticky(OUT) | indicates whether the settings will be kept over a reboot.
Return values
NVAPI_INVALID_ARGUMENT | Invalid input parameters.
NVAPI_API_NOT_INITIALIZED | NvAPI not initialized.
NVAPI_NOT_SUPPORTED | Interface not supported by the driver used, or only supported on selected GPUs
NVAPI_INVALID_ARGUMENT | Invalid input data.
NVAPI_INCOMPATIBLE_STRUCT_VERSION | NV_SCANOUT_INTENSITY_DATA structure version mismatch.
NVAPI_OK | Feature enabled.
NVAPI_ERROR | Miscellaneous error occurred.

◆ NvAPI_GPU_SetScanoutWarping()

NVAPI_INTERFACE NvAPI_GPU_SetScanoutWarping | ( | NvU32 | displayId,
 |  | NV_SCANOUT_WARPING_DATA * | scanoutWarpingData,
 |  | int * | piMaxNumVertices,
 |  | int * | pbSticky
 | ) |  |

DESCRIPTION: This API enables and sets up the warping feature on the specified display.

SUPPORTED OS: Windows 7 and higher

Parameters
[in] | displayId | Combined physical display and GPU identifier of the display to apply the intensity control
[in] | scanoutWarpingData | The warping data info
[out] | pbSticky | Indicates whether the settings will be kept over a reboot.
Return values
NVAPI_INVALID_ARGUMENT | Invalid input parameters.
NVAPI_API_NOT_INITIALIZED | NvAPI not initialized.
NVAPI_NOT_SUPPORTED | Interface not supported by the driver used, or only supported on selected GPUs
NVAPI_INVALID_ARGUMENT | Invalid input data.
NVAPI_INCOMPATIBLE_STRUCT_VERSION | NV_SCANOUT_WARPING_DATA structure version mismatch.
NVAPI_OK | Feature enabled.
NVAPI_ERROR | Miscellaneous error occurred.

◆ NvAPI_GPU_ValidateOutputCombination()

NVAPI_INTERFACE NvAPI_GPU_ValidateOutputCombination | ( | NvPhysicalGpuHandle | hPhysicalGpu,
 |  | NvU32 | outputsMask
 | ) |  |

This function determines if a set of GPU outputs can be active simultaneously. While a GPU may have <n> outputs, typically they cannot all be active at the same time due to internal resource sharing.

Given a physical GPU handle and a mask of candidate outputs, this call will return NVAPI_OK if all of the specified outputs can be driven simultaneously. It will return NVAPI_INVALID_COMBINATION if they cannot.

Use NvAPI_GPU_GetAllOutputs() to determine which outputs are candidates.

SUPPORTED OS: Windows 7 and higher

Since
Release: 85
Return values
NVAPI_OK | Combination of outputs in outputsMask are valid (can be active simultaneously).
NVAPI_INVALID_COMBINATION | Combination of outputs in outputsMask are NOT valid.
NVAPI_INVALID_ARGUMENT | hPhysicalGpu or outputsMask does not have at least 2 bits set.
NVAPI_EXPECTED_PHYSICAL_GPU_HANDLE | hPhysicalGpu was not a physical GPU handle.
NVAPI_NVIDIA_DEVICE_NOT_FOUND | No NVIDIA GPU driving a display was found.

◆ NvAPI_GPU_WorkstationFeatureQuery()

NVAPI_INTERFACE NvAPI_GPU_WorkstationFeatureQuery | ( | __in NvPhysicalGpuHandle | hPhysicalGpu,
 |  | __out_opt NvU32 * | pConfiguredFeatureMask,
 |  | __out_opt NvU32 * | pConsistentFeatureMask
 | ) |  |

DESCRIPTION: This API queries the current set of workstation features.

SUPPORTED OS: Windows 7

Parameters
[in] | hPhysicalGpu | Physical GPU Handle of the display adapter to be configured. GPU handles may be retrieved using NvAPI_EnumPhysicalGPUs.
[out] | pConfiguredFeatureMask | Mask of features requested for use by client drivers
[out] | pConsistentFeatureMask | Mask of features that have all resources allocated for completeness.
Return values
NVAPI_OK | configuration request succeeded
NVAPI_ERROR | configuration request failed
NVAPI_EXPECTED_PHYSICAL_GPU_HANDLE | hPhysicalGpu is not a physical GPU handle.
NVAPI_NO_IMPLEMENTATION | OS below Win7, implemented only for Win7 but returns NVAPI_OK on OS above Win7 to keep compatibility with apps written against Win7.

◆ NvAPI_GPU_WorkstationFeatureSetup()

NVAPI_INTERFACE NvAPI_GPU_WorkstationFeatureSetup | ( | __in NvPhysicalGpuHandle | hPhysicalGpu,
 |  | __in NvU32 | featureEnableMask,
 |  | __in NvU32 | featureDisableMask
 | ) |  |

◆ NvAPI_JoinPresentBarrier()

NVAPI_INTERFACE NvAPI_JoinPresentBarrier | ( | __in NvPresentBarrierClientHandle | presentBarrierClient,
 |  | __in NV_JOIN_PRESENT_BARRIER_PARAMS * | pParams
 | ) |  |

DESCRIPTION: This API adds a registered PresentBarrier client to the presentBarrier. If the call suceeds, image present of the registered scanout resources from this client is under the synchronization of presentBarrier.

Since
Release: 470
Parameters
[in] | presentBarrierClient | An NvPresentBarrierClientHandle handle created by NvAPI_xxxx_CreatedPresentBarrierClient
[in] | pParams | Parameters to joining presentBarrier.
Return values
NVAPI_OK | the call succeeded
NVAPI_ERROR | the call failed
NVAPI_NO_IMPLEMENTATION | the interface is not implemented
NVAPI_INCOMPATIBLE_STRUCT_VERSION | the version of data structure is not correct
NVAPI_INVALID_HANDLE | an invalid NvPresentBarrierClientHandle was passed as an argument
NVAPI_INVALID_POINTER | an invalid pointer was passed as an argument (probably NULL)
NVAPI_API_NOT_INITIALIZED | NvAPI not initialized

◆ NvAPI_LeavePresentBarrier()

NVAPI_INTERFACE NvAPI_LeavePresentBarrier ( __in NvPresentBarrierClientHandle presentBarrierClient )

SUPPORTED OS: Windows 10 and higher DESCRIPTION: This API removes a registered client from presentBarrier. If this client does not join presentBarrier, this function does nothing.

Since
Release: 470
Parameters
[in] presentBarrierClient An NvPresentBarrierClientHandle handle created by NvAPI_xxxxx_CreatePresentBarrierClient.
Return values
NVAPI_OK | the call succeeded
NVAPI_ERROR | the call failed
NVAPI_NO_IMPLEMENTATION | the interface is not implemented
NVAPI_INVALID_HANDLE | an invalid NvPresentBarrierClientHandle was passed as an argument
NVAPI_API_NOT_INITIALIZED | NvAPI not initialized

◆ NvAPI_OGL_ExpertModeDefaultsGet()

NVAPI_INTERFACE NvAPI_OGL_ExpertModeDefaultsGet | ( | NvU32 * | pExpertDetailLevel,
 |  | NvU32 * | pExpertReportMask,
 |  | NvU32 * | pExpertOutputMask
 | ) |  |

Get uncached connected devices.

◆ NvAPI_OGL_ExpertModeDefaultsSet()

NVAPI_INTERFACE NvAPI_OGL_ExpertModeDefaultsSet | ( | NvU32 | expertDetailLevel,
 |  | NvU32 | expertReportMask,
 |  | NvU32 | expertOutputMask
 | ) |  |

This function configures OpenGL Expert Mode global defaults. These settings apply to any OpenGL application which starts up after these values are applied (i.e. these settings do not apply to currently running applications).

SUPPORTED OS: Windows 7 and higher

Since
Release: 80
Parameters
expertDetailLevel | Value which specifies the detail level in the feedback stream. This is a mask made up of NVAPI_OGLEXPERT_LEVEL bits.
expertReportMask | Mask made up of NVAPI_OGLEXPERT_REPORT bits, this parameter specifies the areas of functional interest.
expertOutputMask | Mask made up of NVAPI_OGLEXPERT_OUTPUT bits, this parameter specifies the feedback output location. Note that using OUTPUT_TO_CALLBACK here is meaningless and has no effect, but using it will not cause an error.
Returns
NVAPI_ERROR or NVAPI_OK

SUPPORTED OS: Windows 7 and higher

◆ NvAPI_QueryPresentBarrierFrameStatistics()

NVAPI_INTERFACE NvAPI_QueryPresentBarrierFrameStatistics | ( | __in NvPresentBarrierClientHandle | presentBarrierClient,
 |  | __out NV_PRESENT_BARRIER_FRAME_STATISTICS * | pFrameStats
 | ) |  |

DESCRIPTION: This API returns the presentBarrier frame statistics of last present call from this client. If the client did not join presentBarrier, the SyncMode is returned as PRESENT_BARRIER_NOT_JOINED, and all other fields are reset. Driver does not retain any presentBarrier info of the client once it leaves presentBarrier.

Since
Release: 470
Parameters
[in] | presentBarrierClient | An NvPresentBarrierClientHandle handle created by NvAPI_xxxxx_CreatePresentBarrierClient.
[out] | pFrameStats | Pointer to NV_PRESENT_BARRIER_FRAME_STATISTICS structure about presentBarrier statistics.
Return values
NVAPI_OK | the call succeeded
NVAPI_ERROR | the call failed
NVAPI_NO_IMPLEMENTATION | the interface is not implemented
NVAPI_INVALID_HANDLE | an invalid NvPresentBarrierClientHandle was passed as an argument
NVAPI_INVALID_POINTER | an invalid pointer was passed as an argument (probably NULL)
NVAPI_INCOMPATIBLE_STRUCT_VERSION | invalid version of frameStatistics params
NVAPI_API_NOT_INITIALIZED | NvAPI not initialized

◆ NvAPI_SYS_GetDisplayDriverInfo()

NVAPI_INTERFACE NvAPI_SYS_GetDisplayDriverInfo ( __inout NV_DISPLAY_DRIVER_INFO * pDriverInfo )

DESCRIPTION: This API will return information related to the NVIDIA Display Driver. Note that out of the driver types - Studio, Game Ready, RTX Production Branch, RTX New Feature Branch - only one driver type can be available in system. If NVAPI is unable to get the information of particular driver type, we report all flags as 0 (Unknown).

SUPPORTED OS: Windows 7 and higher

Since
Release: 396
Parameters
[in,out] pDriverInfo - This structure will be filled with required information.
Returns
This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.

Variable Documentation

◆ pOutputsMask

NvU32 * pOutputsMask

Get uncached connected devices.

◆ pRate

NvU32* pRate

◆ pSize

NvU32* pSize

◆ pStatus

NVVIOSTATUS* pStatus


Data Fields
_NV_GPU_DISPLAYIDS Struct Reference
GPU APIs | OpenGL APIs » GPU General Control Interface

#include <nvapi.h>

Data Fields

NvU32 version
NV_MONITOR_CONN_TYPE connectorType
NvU32 displayId
NvU32 | isDynamic: 1
NvU32 | isMultiStreamRootNode: 1
NvU32 | isActive: 1
NvU32 | isCluster: 1
NvU32 | isOSVisible: 1
NvU32 | isWFD: 1
NvU32 | isConnected: 1
NvU32 | reservedInternal: 10
NvU32 | isPhysicallyConnected: 1
NvU32 | reserved: 14
The documentation for this struct was generated from the following file:


Data Fields
_NV_BOARD_INFO Struct Reference
GPU APIs | OpenGL APIs » GPU General Control Interface

#include <nvapi.h>

Data Fields

NvU32 version
NvU8 BoardNum [16]
The documentation for this struct was generated from the following file:


Data Fields
NV_GPU_ARCH_INFO_V1 Struct Reference
GPU APIs | OpenGL APIs » GPU General Control Interface

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 architecture
NvU32 implementation
NvU32 revision

Detailed Description

Used in NvAPI_GPU_GetArchInfo()

The documentation for this struct was generated from the following file:


Data Fields
NV_GPU_ARCH_INFO_V2 Struct Reference
GPU APIs | OpenGL APIs » GPU General Control Interface

#include <nvapi.h>

Data Fields

NvU32 version
union {
NvU32 NV_GPU_ARCH_INFO_V2::architecture
NV_GPU_ARCHITECTURE_ID NV_GPU_ARCH_INFO_V2::architecture_id
};
union {
NvU32 NV_GPU_ARCH_INFO_V2::implementation
NV_GPU_ARCH_IMPLEMENTATION_ID NV_GPU_ARCH_INFO_V2::implementation_id
};
union {
NvU32 NV_GPU_ARCH_INFO_V2::revision
NV_GPU_CHIP_REVISION NV_GPU_ARCH_INFO_V2::revision_id
};

Detailed Description

Used in NvAPI_GPU_GetArchInfo()

The documentation for this struct was generated from the following file:


Data Fields
NV_I2C_INFO_V1 Struct Reference
GPU APIs | OpenGL APIs » GPU General Control Interface

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 displayMask
NvU8 bIsDDCPort
NvU8 i2cDevAddress
NvU8 * pbI2cRegAddress
NvU32 regAddrSize
NvU8 * pbData
NvU32 cbSize
NvU32 i2cSpeed

Detailed Description

Used in NvAPI_I2CRead() and NvAPI_I2CWrite()

The documentation for this struct was generated from the following file:


Data Fields
NV_I2C_INFO_V2 Struct Reference
GPU APIs | OpenGL APIs » GPU General Control Interface

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 displayMask
NvU8 bIsDDCPort
NvU8 i2cDevAddress
NvU8 * pbI2cRegAddress
NvU32 regAddrSize
NvU8 * pbData
NvU32 cbSize
NvU32 i2cSpeed
NV_I2C_SPEED i2cSpeedKhz

Detailed Description

Used in NvAPI_I2CRead() and NvAPI_I2CWrite()

The documentation for this struct was generated from the following file:


Data Fields
NV_I2C_INFO_V3 Struct Reference
GPU APIs | OpenGL APIs » GPU General Control Interface

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 displayMask
NvU8 bIsDDCPort
NvU8 i2cDevAddress
NvU8 * pbI2cRegAddress
NvU32 regAddrSize
NvU8 * pbData
NvU32 cbSize
NvU32 i2cSpeed
NV_I2C_SPEED i2cSpeedKhz
NvU8 portId
NvU32 bIsPortIdSet

Detailed Description

Used in NvAPI_I2CRead() and NvAPI_I2CWrite()

The documentation for this struct was generated from the following file:


Data Fields
NV_GPU_GET_HDCP_SUPPORT_STATUS Struct Reference
GPU APIs | OpenGL APIs » GPU General Control Interface

#include <nvapi.h>

Data Fields

NvU32 version
NV_GPU_HDCP_FUSE_STATE hdcpFuseState
NV_GPU_HDCP_KEY_SOURCE hdcpKeySource
NV_GPU_HDCP_KEY_SOURCE_STATE hdcpKeySourceState

Detailed Description

HDPC support status - used in NvAPI_GPU_GetHDCPSupportStatus()

The documentation for this struct was generated from the following file:


Data Fields
NV_COMPUTE_GPU_TOPOLOGY_V1 Struct Reference
GPU APIs | OpenGL APIs » GPU General Control Interface

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 gpuCount
struct {
NvPhysicalGpuHandle NV_COMPUTE_GPU_TOPOLOGY_V1::hPhysicalGpu
NvU32 NV_COMPUTE_GPU_TOPOLOGY_V1::flags
} computeGpus [NVAPI_MAX_GPU_PER_TOPOLOGY]
The documentation for this struct was generated from the following file:


Data Fields
_NV_COMPUTE_GPU Struct Reference
GPU APIs | OpenGL APIs » GPU General Control Interface

#include <nvapi.h>

Data Fields

NvPhysicalGpuHandle hPhysicalGpu
NvU32 flags
The documentation for this struct was generated from the following file:


Data Fields
_NV_COMPUTE_GPU_TOPOLOGY_V2 Struct Reference
GPU APIs | OpenGL APIs » GPU General Control Interface

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 gpuCount
NV_COMPUTE_GPU * computeGpus
The documentation for this struct was generated from the following file:


Data Fields
NV_SCANOUT_INTENSITY_DATA_V1 Struct Reference
OpenGL APIs | GPU APIs | OpenGL APIs » GPU General Control Interface

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 width
NvU32 height
float * blendingTexture
The documentation for this struct was generated from the following file:


Data Fields
NV_SCANOUT_INTENSITY_DATA_V2 Struct Reference
OpenGL APIs | GPU APIs | OpenGL APIs » GPU General Control Interface

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 width
NvU32 height
float * | blendingTexture
float * | offsetTexture
NvU32 offsetTexChannels
The documentation for this struct was generated from the following file:


Data Fields
_NV_SCANOUT_INTENSITY_STATE_DATA Struct Reference
OpenGL APIs | GPU APIs | OpenGL APIs » GPU General Control Interface

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 bEnabled
The documentation for this struct was generated from the following file:


Data Fields
NV_SCANOUT_WARPING_DATA Struct Reference
OpenGL APIs | GPU APIs | OpenGL APIs » GPU General Control Interface

#include <nvapi.h>

Data Fields

NvU32 version
float * | vertices
NV_GPU_WARPING_VERTICE_FORMAT vertexFormat
int | numVertices
NvSBox * textureRect
The documentation for this struct was generated from the following file:


Data Fields
_NV_SCANOUT_WARPING_STATE_DATA Struct Reference
OpenGL APIs | GPU APIs | OpenGL APIs » GPU General Control Interface

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 bEnabled
The documentation for this struct was generated from the following file:


Data Fields
_NV_SCANOUT_INFORMATION Struct Reference
OpenGL APIs | GPU APIs | OpenGL APIs » GPU General Control Interface

#include <nvapi.h>

Data Fields

NvU32 version
NvSBox sourceDesktopRect
NvSBox sourceViewportRect
NvSBox targetViewportRect
NvU32 targetDisplayWidth
NvU32 targetDisplayHeight
NvU32 cloneImportance
NV_ROTATE sourceToTargetRotation

Detailed Description

Used in NvAPI_GPU_GetScanoutConfigurationEx().

The documentation for this struct was generated from the following file:


Data Fields
_NV_GPU_VIRTUALIZATION_INFO Struct Reference
OpenGL APIs | GPU APIs | OpenGL APIs » GPU General Control Interface

#include <nvapi.h>

Data Fields

NvU32 version
NV_VIRTUALIZATION_MODE virtualizationMode
NvU32 reserved
The documentation for this struct was generated from the following file:


Data Fields
_NV_LOGICAL_GPU_DATA_V1 Struct Reference
OpenGL APIs | GPU APIs | OpenGL APIs » GPU General Control Interface

#include <nvapi.h>

Data Fields

NvU32 version
void * | pOSAdapterId
NvU32 physicalGpuCount
NvPhysicalGpuHandle | physicalGpuHandles [NVAPI_MAX_PHYSICAL_GPUS]
NvU32 | reserved [8]
The documentation for this struct was generated from the following file:


Data Fields
_NV_GPU_GSP_INFO_V1 Struct Reference
OpenGL APIs | GPU APIs | OpenGL APIs » GPU General Control Interface

#include <nvapi.h>

Data Fields

NvU32 version
NvU8 firmwareVersion [NVAPI_GPU_MAX_BUILD_VERSION_LENGTH]
NvU32 reserved

Detailed Description

Used in NvAPI_GPU_GetGspFeatures().

The documentation for this struct was generated from the following file:


Data Fields
_NV_GPU_QUERY_ILLUMINATION_SUPPORT_PARM_V1 Struct Reference
OpenGL APIs | GPU APIs | OpenGL APIs » GPU General Control Interface

#include <nvapi.h>

Data Fields

NvU32 version
NvPhysicalGpuHandle hPhysicalGpu
NV_GPU_ILLUMINATION_ATTRIB Attribute
NvU32 bSupported
The documentation for this struct was generated from the following file:


Data Fields
_NV_GPU_GET_ILLUMINATION_PARM_V1 Struct Reference
OpenGL APIs | GPU APIs | OpenGL APIs » GPU General Control Interface

#include <nvapi.h>

Data Fields

NvU32 version
NvPhysicalGpuHandle hPhysicalGpu
NV_GPU_ILLUMINATION_ATTRIB Attribute
NvU32 Value
The documentation for this struct was generated from the following file:


Data Fields
_NV_GPU_SET_ILLUMINATION_PARM_V1 Struct Reference
OpenGL APIs | GPU APIs | OpenGL APIs » GPU General Control Interface

#include <nvapi.h>

Data Fields

NvU32 version
NvPhysicalGpuHandle hPhysicalGpu
NV_GPU_ILLUMINATION_ATTRIB Attribute
NvU32 Value
The documentation for this struct was generated from the following file:


Functions
I2C APIs

Functions

NVAPI_INTERFACE | NvAPI_I2CRead (NvPhysicalGpuHandle hPhysicalGpu, NV_I2C_INFO *pI2cInfo)
NVAPI_INTERFACE | NvAPI_I2CWrite (NvPhysicalGpuHandle hPhysicalGpu, NV_I2C_INFO *pI2cInfo)
#define | NVAPI_MAX_SIZEOF_I2C_DATA_BUFFER 4096
#define | NVAPI_MAX_SIZEOF_I2C_REG_ADDRESS 4
#define | NVAPI_DISPLAY_DEVICE_MASK_MAX 24
#define | NVAPI_I2C_SPEED_DEPRECATED 0xFFFF
#define | NV_I2C_INFO_VER3 MAKE_NVAPI_VERSION(NV_I2C_INFO_V3,3)
#define | NV_I2C_INFO_VER2 MAKE_NVAPI_VERSION(NV_I2C_INFO_V2,2)
#define | NV_I2C_INFO_VER1 MAKE_NVAPI_VERSION(NV_I2C_INFO_V1,1)
#define | NV_I2C_INFO_VER NV_I2C_INFO_VER3
enum NV_I2C_SPEED {
NVAPI_I2C_SPEED_DEFAULT , NVAPI_I2C_SPEED_3KHZ , NVAPI_I2C_SPEED_10KHZ , NVAPI_I2C_SPEED_33KHZ ,
NVAPI_I2C_SPEED_100KHZ , NVAPI_I2C_SPEED_200KHZ , NVAPI_I2C_SPEED_400KHZ
}
typedef NV_I2C_INFO_V3 | NV_I2C_INFO

Detailed Description

The I2C APIs are used to read or write data to DDC monitors using the I2C protocol.

Macro Definition Documentation

◆ NV_I2C_INFO_VER

#define NV_I2C_INFO_VER NV_I2C_INFO_VER3

◆ NV_I2C_INFO_VER1

#define NV_I2C_INFO_VER1 MAKE_NVAPI_VERSION(NV_I2C_INFO_V1,1)

◆ NV_I2C_INFO_VER2

#define NV_I2C_INFO_VER2 MAKE_NVAPI_VERSION(NV_I2C_INFO_V2,2)

◆ NV_I2C_INFO_VER3

#define NV_I2C_INFO_VER3 MAKE_NVAPI_VERSION(NV_I2C_INFO_V3,3)

◆ NVAPI_DISPLAY_DEVICE_MASK_MAX

#define NVAPI_DISPLAY_DEVICE_MASK_MAX 24

◆ NVAPI_I2C_SPEED_DEPRECATED

#define NVAPI_I2C_SPEED_DEPRECATED 0xFFFF

◆ NVAPI_MAX_SIZEOF_I2C_DATA_BUFFER

#define NVAPI_MAX_SIZEOF_I2C_DATA_BUFFER 4096

◆ NVAPI_MAX_SIZEOF_I2C_REG_ADDRESS

#define NVAPI_MAX_SIZEOF_I2C_REG_ADDRESS 4

Typedef Documentation

◆ NV_I2C_INFO

typedef NV_I2C_INFO_V3 NV_I2C_INFO

Enumeration Type Documentation

◆ NV_I2C_SPEED

enum NV_I2C_SPEED
Enumerator
NVAPI_I2C_SPEED_DEFAULT | Set i2cSpeedKhz to I2C_SPEED_DEFAULT if default I2C speed is to be chosen, ie.use the current frequency setting.
NVAPI_I2C_SPEED_3KHZ |
NVAPI_I2C_SPEED_10KHZ |
NVAPI_I2C_SPEED_33KHZ |
NVAPI_I2C_SPEED_100KHZ |
NVAPI_I2C_SPEED_200KHZ |
NVAPI_I2C_SPEED_400KHZ |

Function Documentation

◆ NvAPI_I2CRead()

NVAPI_INTERFACE NvAPI_I2CRead | ( | NvPhysicalGpuHandle | hPhysicalGpu,
 |  | NV_I2C_INFO * | pI2cInfo
 | ) |  |

This function reads the data buffer from the I2C port. The I2C request must be for a DDC port: pI2cInfo->bIsDDCPort = 1.

A data buffer size larger than 16 bytes may be rejected if a register address is specified. In such a case, NVAPI_ARGUMENT_EXCEED_MAX_SIZE would be returned.

If a register address is specified (i.e. regAddrSize is positive), then the transaction will be performed in the combined format described in the I2C specification. The register address will be written, followed by reading into the data buffer.

SUPPORTED OS: Windows 7 and higher

Since
Release: 85
Parameters
[in] | hPhysicalGPU | GPU selection.
[out] | NV_I2C_INFO | *pI2cInfo The I2C data input structure
Return values
NVAPI_OK | Completed request
NVAPI_ERROR | Miscellaneous error occurred.
NVAPI_HANDLE_INVALIDATED | Handle passed has been invalidated (see user guide).
NVAPI_EXPECTED_PHYSICAL_GPU_HANDLE | Handle passed is not a physical GPU handle.
NVAPI_INCOMPATIBLE_STRUCT_VERSION | Structure version is not supported.
NVAPI_INVALID_ARGUMENT | - argument does not meet specified requirements
NVAPI_ARGUMENT_EXCEED_MAX_SIZE | - an argument exceeds the maximum

◆ NvAPI_I2CWrite()

NVAPI_INTERFACE NvAPI_I2CWrite | ( | NvPhysicalGpuHandle | hPhysicalGpu,
 |  | NV_I2C_INFO * | pI2cInfo
 | ) |  |

This function writes the data buffer to the I2C port.

           The I2C request must be for a DDC port: pI2cInfo->bIsDDCPort = 1.

           A data buffer size larger than 16 bytes may be rejected if a register address is specified.  In such a case,
           NVAPI_ARGUMENT_EXCEED_MAX_SIZE would be returned.

           If a register address is specified (i.e. regAddrSize is positive), then the register address will be written
           and the data buffer will immediately follow without a restart.

SUPPORTED OS: Windows 7 and higher

Since
Release: 85
Parameters
[in] | hPhysicalGPU | GPU selection.
[in] | pI2cInfo | The I2C data input structure
Return values
NVAPI_OK | Completed request
NVAPI_ERROR | Miscellaneous error occurred.
NVAPI_HANDLE_INVALIDATED | Handle passed has been invalidated (see user guide).
NVAPI_EXPECTED_PHYSICAL_GPU_HANDLE | Handle passed is not a physical GPU handle.
NVAPI_INCOMPATIBLE_STRUCT_VERSION | Structure version is not supported.
NVAPI_INVALID_ARGUMENT | Argument does not meet specified requirements
NVAPI_ARGUMENT_EXCEED_MAX_SIZE | Argument exceeds the maximum


Functions
GPU Performance Interface <br>
GPU APIs

Functions

NVAPI_INTERFACE NvAPI_GPU_GetPerfDecreaseInfo (__in NvPhysicalGpuHandle hPhysicalGpu, __inout NvU32 *pPerfDecrInfo)

Detailed Description

Function Documentation

◆ NvAPI_GPU_GetPerfDecreaseInfo()

NVAPI_INTERFACE NvAPI_GPU_GetPerfDecreaseInfo | ( | __in NvPhysicalGpuHandle | hPhysicalGpu,
 |  | __inout NvU32 * | pPerfDecrInfo
 | ) |  |

DESCRIPTION: This function retrieves - in NvU32 variable - reasons for the current performance decrease.

SUPPORTED OS: Windows 7 and higher

Parameters
[in] | hPhysicalGPU | (IN) - GPU for which performance decrease is to be evaluated.
[out] | pPerfDecrInfo | (OUT) - Pointer to a NvU32 variable containing performance decrease info
Returns
This API can return any of the error codes enumerated in NvAPI_Status.


Data Structures | Macros | Typedefs | Enumerations | Functions
GPU Thermal Control Interface
GPU APIs

Data Structures

struct | NV_GPU_THERMAL_SETTINGS_V1
struct | NV_GPU_THERMAL_SETTINGS_V2

Macros

#define NVAPI_MAX_THERMAL_SENSORS_PER_GPU 3

Typedefs

typedef NV_GPU_THERMAL_SETTINGS_V2 NV_GPU_THERMAL_SETTINGS

Enumerations

enum NV_THERMAL_TARGET {
NVAPI_THERMAL_TARGET_NONE = 0 , NVAPI_THERMAL_TARGET_GPU = 1 , NVAPI_THERMAL_TARGET_MEMORY = 2 , NVAPI_THERMAL_TARGET_POWER_SUPPLY = 4 ,
NVAPI_THERMAL_TARGET_BOARD = 8 , NVAPI_THERMAL_TARGET_VCD_BOARD = 9 , NVAPI_THERMAL_TARGET_VCD_INLET = 10 , NVAPI_THERMAL_TARGET_VCD_OUTLET = 11 ,
NVAPI_THERMAL_TARGET_ALL = 15 , NVAPI_THERMAL_TARGET_UNKNOWN = -1
}
enum NV_THERMAL_CONTROLLER {
NVAPI_THERMAL_CONTROLLER_NONE = 0 , NVAPI_THERMAL_CONTROLLER_GPU_INTERNAL , NVAPI_THERMAL_CONTROLLER_ADM1032 , NVAPI_THERMAL_CONTROLLER_MAX6649 ,
NVAPI_THERMAL_CONTROLLER_MAX1617 , NVAPI_THERMAL_CONTROLLER_LM99 , NVAPI_THERMAL_CONTROLLER_LM89 , NVAPI_THERMAL_CONTROLLER_LM64 ,
NVAPI_THERMAL_CONTROLLER_ADT7473 , NVAPI_THERMAL_CONTROLLER_SBMAX6649 , NVAPI_THERMAL_CONTROLLER_VBIOSEVT , NVAPI_THERMAL_CONTROLLER_OS ,
NVAPI_THERMAL_CONTROLLER_UNKNOWN = -1
}

Functions

NVAPI_INTERFACE | NvAPI_GPU_GetThermalSettings (NvPhysicalGpuHandle hPhysicalGpu, NvU32 sensorIndex, NV_GPU_THERMAL_SETTINGS *pThermalSettings)
#define | NV_GPU_THERMAL_SETTINGS_VER_1 MAKE_NVAPI_VERSION(NV_GPU_THERMAL_SETTINGS_V1,1)
#define | NV_GPU_THERMAL_SETTINGS_VER_2 MAKE_NVAPI_VERSION(NV_GPU_THERMAL_SETTINGS_V2,2)
#define | NV_GPU_THERMAL_SETTINGS_VER NV_GPU_THERMAL_SETTINGS_VER_2

Detailed Description

The GPU thermal control APIs are used to get temperature levels from the various thermal sensors associated with the GPU.

Macro Definition Documentation

◆ NV_GPU_THERMAL_SETTINGS_VER

#define NV_GPU_THERMAL_SETTINGS_VER NV_GPU_THERMAL_SETTINGS_VER_2

Macro for constructing the version field of NV_GPU_THERMAL_SETTINGS.

◆ NV_GPU_THERMAL_SETTINGS_VER_1

#define NV_GPU_THERMAL_SETTINGS_VER_1 MAKE_NVAPI_VERSION(NV_GPU_THERMAL_SETTINGS_V1,1)

Macro for constructing the version field of NV_GPU_THERMAL_SETTINGS_V1.

◆ NV_GPU_THERMAL_SETTINGS_VER_2

#define NV_GPU_THERMAL_SETTINGS_VER_2 MAKE_NVAPI_VERSION(NV_GPU_THERMAL_SETTINGS_V2,2)

Macro for constructing the version field of NV_GPU_THERMAL_SETTINGS_V2.

◆ NVAPI_MAX_THERMAL_SENSORS_PER_GPU

#define NVAPI_MAX_THERMAL_SENSORS_PER_GPU 3

Typedef Documentation

◆ NV_GPU_THERMAL_SETTINGS

typedef NV_GPU_THERMAL_SETTINGS_V2 NV_GPU_THERMAL_SETTINGS

Enumeration Type Documentation

◆ NV_THERMAL_CONTROLLER

enum NV_THERMAL_CONTROLLER

Used in NV_GPU_THERMAL_SETTINGS

Enumerator
NVAPI_THERMAL_CONTROLLER_NONE
NVAPI_THERMAL_CONTROLLER_GPU_INTERNAL
NVAPI_THERMAL_CONTROLLER_ADM1032
NVAPI_THERMAL_CONTROLLER_MAX6649
NVAPI_THERMAL_CONTROLLER_MAX1617
NVAPI_THERMAL_CONTROLLER_LM99
NVAPI_THERMAL_CONTROLLER_LM89
NVAPI_THERMAL_CONTROLLER_LM64
NVAPI_THERMAL_CONTROLLER_ADT7473
NVAPI_THERMAL_CONTROLLER_SBMAX6649
NVAPI_THERMAL_CONTROLLER_VBIOSEVT
NVAPI_THERMAL_CONTROLLER_OS
NVAPI_THERMAL_CONTROLLER_UNKNOWN

◆ NV_THERMAL_TARGET

enum NV_THERMAL_TARGET

Used in NV_GPU_THERMAL_SETTINGS

Enumerator
NVAPI_THERMAL_TARGET_NONE |
NVAPI_THERMAL_TARGET_GPU | GPU core temperature requires NvPhysicalGpuHandle.
NVAPI_THERMAL_TARGET_MEMORY | GPU memory temperature requires NvPhysicalGpuHandle.
NVAPI_THERMAL_TARGET_POWER_SUPPLY | GPU power supply temperature requires NvPhysicalGpuHandle.
NVAPI_THERMAL_TARGET_BOARD | GPU board ambient temperature requires NvPhysicalGpuHandle.
NVAPI_THERMAL_TARGET_VCD_BOARD | Visual Computing Device Board temperature requires NvVisualComputingDeviceHandle.
NVAPI_THERMAL_TARGET_VCD_INLET | Visual Computing Device Inlet temperature requires NvVisualComputingDeviceHandle.
NVAPI_THERMAL_TARGET_VCD_OUTLET | Visual Computing Device Outlet temperature requires NvVisualComputingDeviceHandle.
NVAPI_THERMAL_TARGET_ALL |
NVAPI_THERMAL_TARGET_UNKNOWN |

Function Documentation

◆ NvAPI_GPU_GetThermalSettings()

NVAPI_INTERFACE NvAPI_GPU_GetThermalSettings | ( | NvPhysicalGpuHandle | hPhysicalGpu,
 |  | NvU32 | sensorIndex,
 |  | NV_GPU_THERMAL_SETTINGS * | pThermalSettings
 | ) |  |

This function retrieves the thermal information of all thermal sensors or specific thermal sensor associated with the selected GPU. Thermal sensors are indexed 0 to NVAPI_MAX_THERMAL_SENSORS_PER_GPU-1.

  • To retrieve specific thermal sensor info, set the sensorIndex to the required thermal sensor index.
  • To retrieve info for all sensors, set sensorIndex to NVAPI_THERMAL_TARGET_ALL.

SUPPORTED OS: Windows 7 and higher

TCC_SUPPORTED

MCDM_SUPPORTED

Since
Release: 85
Parameters
[in] | hPhysicalGPU | GPU selection.
[in] | sensorIndex | Explicit thermal sensor index selection.
[out] | pThermalSettings | Array of thermal settings.
Return values
NVAPI_OK | Completed request
NVAPI_ERROR | Miscellaneous error occurred.
NVAPI_INVALID_ARGUMENT | pThermalInfo is NULL.
NVAPI_HANDLE_INVALIDATED | Handle passed has been invalidated (see user guide).
NVAPI_EXPECTED_PHYSICAL_GPU_HANDLE | Handle passed is not a physical GPU handle.
NVAPI_INCOMPATIBLE_STRUCT_VERSION | The version of the INFO struct is not supported.


Data Fields
NV_GPU_THERMAL_SETTINGS_V1 Struct Reference
OpenGL APIs | GPU APIs » GPU Thermal Control Interface

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 count
struct {
NV_THERMAL_CONTROLLER NV_GPU_THERMAL_SETTINGS_V1::controller
NvU32 NV_GPU_THERMAL_SETTINGS_V1::defaultMinTemp
NvU32 NV_GPU_THERMAL_SETTINGS_V1::defaultMaxTemp
NvU32 NV_GPU_THERMAL_SETTINGS_V1::currentTemp
NV_THERMAL_TARGET NV_GPU_THERMAL_SETTINGS_V1::target
} sensor [NVAPI_MAX_THERMAL_SENSORS_PER_GPU]

Detailed Description

Used in NvAPI_GPU_GetThermalSettings()

The documentation for this struct was generated from the following file:


Data Fields
NV_GPU_THERMAL_SETTINGS_V2 Struct Reference
OpenGL APIs | GPU APIs » GPU Thermal Control Interface

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 count
struct {
NV_THERMAL_CONTROLLER NV_GPU_THERMAL_SETTINGS_V2::controller
NvS32 NV_GPU_THERMAL_SETTINGS_V2::defaultMinTemp
NvS32 NV_GPU_THERMAL_SETTINGS_V2::defaultMaxTemp
NvS32 NV_GPU_THERMAL_SETTINGS_V2::currentTemp
NV_THERMAL_TARGET NV_GPU_THERMAL_SETTINGS_V2::target
} sensor [NVAPI_MAX_THERMAL_SENSORS_PER_GPU]
The documentation for this struct was generated from the following file:


Data Structures | Macros | Typedefs | Enumerations | Functions
GPU Performance State Interface
GPU APIs

Data Structures

struct | NV_GPU_PERF_PSTATES20_PARAM_DELTA
struct | NV_GPU_PSTATE20_CLOCK_ENTRY_V1
struct | NV_GPU_PSTATE20_BASE_VOLTAGE_ENTRY_V1
struct | NV_GPU_PERF_PSTATES20_INFO_V1
struct | _NV_GPU_PERF_PSTATES20_INFO_V2
struct | NV_GPU_PERF_PSTATES_INFO_V1
struct | NV_GPU_PERF_PSTATES_INFO_V2
struct | NV_GPU_DYNAMIC_PSTATES_INFO_EX

Macros

#define | NVAPI_MAX_GPU_PSTATE20_PSTATES 16
#define | NVAPI_MAX_GPU_PSTATE20_CLOCKS 8
#define | NVAPI_MAX_GPU_PSTATE20_BASE_VOLTAGES 4
#define | NV_GPU_PERF_PSTATES20_INFO_VER1 MAKE_NVAPI_VERSION(NV_GPU_PERF_PSTATES20_INFO_V1,1)
#define | NV_GPU_PERF_PSTATES20_INFO_VER2 MAKE_NVAPI_VERSION(NV_GPU_PERF_PSTATES20_INFO_V2,2)
#define | NV_GPU_PERF_PSTATES20_INFO_VER3 MAKE_NVAPI_VERSION(NV_GPU_PERF_PSTATES20_INFO_V2,3)
#define | NV_GPU_PERF_PSTATES20_INFO_VER NV_GPU_PERF_PSTATES20_INFO_VER3
#define | NVAPI_MAX_GPU_UTILIZATIONS 8
#define | NV_GPU_DYNAMIC_PSTATES_INFO_EX_VER MAKE_NVAPI_VERSION(NV_GPU_DYNAMIC_PSTATES_INFO_EX,1)

Typedefs

typedef enum _NV_GPU_PERF_PSTATE_ID | NV_GPU_PERF_PSTATE_ID
typedef struct _NV_GPU_PERF_PSTATES20_INFO_V2 | NV_GPU_PERF_PSTATES20_INFO_V2
typedef NV_GPU_PERF_PSTATES20_INFO_V2 | NV_GPU_PERF_PSTATES20_INFO
typedef NV_GPU_PERF_PSTATES_INFO_V2 | NV_GPU_PERF_PSTATES_INFO

Enumerations

enum _NV_GPU_PERF_PSTATE_ID {
NVAPI_GPU_PERF_PSTATE_P0 = 0 , NVAPI_GPU_PERF_PSTATE_P1 , NVAPI_GPU_PERF_PSTATE_P2 , NVAPI_GPU_PERF_PSTATE_P3 ,
NVAPI_GPU_PERF_PSTATE_P4 , NVAPI_GPU_PERF_PSTATE_P5 , NVAPI_GPU_PERF_PSTATE_P6 , NVAPI_GPU_PERF_PSTATE_P7 ,
NVAPI_GPU_PERF_PSTATE_P8 , NVAPI_GPU_PERF_PSTATE_P9 , NVAPI_GPU_PERF_PSTATE_P10 , NVAPI_GPU_PERF_PSTATE_P11 ,
NVAPI_GPU_PERF_PSTATE_P12 , NVAPI_GPU_PERF_PSTATE_P13 , NVAPI_GPU_PERF_PSTATE_P14 , NVAPI_GPU_PERF_PSTATE_P15 ,
NVAPI_GPU_PERF_PSTATE_UNDEFINED = NVAPI_MAX_GPU_PERF_PSTATES , NVAPI_GPU_PERF_PSTATE_ALL
}
enum NV_GPU_PERF_PSTATE20_CLOCK_TYPE_ID { NVAPI_GPU_PERF_PSTATE20_CLOCK_TYPE_SINGLE = 0 , NVAPI_GPU_PERF_PSTATE20_CLOCK_TYPE_RANGE }

Functions

__nvapi_deprecated_function ("Do not use this function - it is deprecated in release 304. Instead, use NvAPI_GPU_GetPstates20.") NVAPI_INTERFACE NvAPI_GPU_GetPstatesInfoEx(NvPhysicalGpuHandle hPhysicalGpu
NVAPI_INTERFACE | NvAPI_GPU_GetPstates20 (__in NvPhysicalGpuHandle hPhysicalGpu, __inout NV_GPU_PERF_PSTATES20_INFO *pPstatesInfo)
NVAPI_INTERFACE | NvAPI_GPU_GetCurrentPstate (NvPhysicalGpuHandle hPhysicalGpu, NV_GPU_PERF_PSTATE_ID *pCurrentPstate)
NVAPI_INTERFACE | NvAPI_GPU_GetDynamicPstatesInfoEx (NvPhysicalGpuHandle hPhysicalGpu, NV_GPU_DYNAMIC_PSTATES_INFO_EX *pDynamicPstatesInfoEx)
#define | NV_GPU_PERF_PSTATES_INFO_VER1 MAKE_NVAPI_VERSION(NV_GPU_PERF_PSTATES_INFO_V1,1)
#define | NV_GPU_PERF_PSTATES_INFO_VER2 MAKE_NVAPI_VERSION(NV_GPU_PERF_PSTATES_INFO_V2,2)
#define | NV_GPU_PERF_PSTATES_INFO_VER3 MAKE_NVAPI_VERSION(NV_GPU_PERF_PSTATES_INFO_V2,3)
#define | NV_GPU_PERF_PSTATES_INFO_VER NV_GPU_PERF_PSTATES_INFO_VER3

Detailed Description

The GPU performance state APIs are used to get and set various performance levels on a per-GPU basis. P-States are GPU active/executing performance capability and power consumption states.

P-States range from P0 to P15, with P0 being the highest performance/power state, and P15 being the lowest performance/power state. Each P-State maps to a performance level. Not all P-States are available on a given system. The definition of each P-States are currently as follows:

  • P0/P1 - Maximum 3D performance
  • P2/P3 - Balanced 3D performance-power
  • P8 - Basic HD video playback
  • P10 - DVD playback
  • P12 - Minimum idle power consumption

Macro Definition Documentation

◆ NV_GPU_DYNAMIC_PSTATES_INFO_EX_VER

#define NV_GPU_DYNAMIC_PSTATES_INFO_EX_VER MAKE_NVAPI_VERSION(NV_GPU_DYNAMIC_PSTATES_INFO_EX,1)

Macro for constructing the version field of NV_GPU_DYNAMIC_PSTATES_INFO_EX

◆ NV_GPU_PERF_PSTATES20_INFO_VER

#define NV_GPU_PERF_PSTATES20_INFO_VER NV_GPU_PERF_PSTATES20_INFO_VER3

Macro for constructing the version field of NV_GPU_PERF_PSTATES20_INFO.

◆ NV_GPU_PERF_PSTATES20_INFO_VER1

#define NV_GPU_PERF_PSTATES20_INFO_VER1 MAKE_NVAPI_VERSION(NV_GPU_PERF_PSTATES20_INFO_V1,1)

Macro for constructing the version field of NV_GPU_PERF_PSTATES20_INFO_V1.

◆ NV_GPU_PERF_PSTATES20_INFO_VER2

#define NV_GPU_PERF_PSTATES20_INFO_VER2 MAKE_NVAPI_VERSION(NV_GPU_PERF_PSTATES20_INFO_V2,2)

Macro for constructing the version field of NV_GPU_PERF_PSTATES20_INFO_V2.

◆ NV_GPU_PERF_PSTATES20_INFO_VER3

#define NV_GPU_PERF_PSTATES20_INFO_VER3 MAKE_NVAPI_VERSION(NV_GPU_PERF_PSTATES20_INFO_V2,3)

Macro for constructing the version field of NV_GPU_PERF_PSTATES20_INFO_V2.

◆ NV_GPU_PERF_PSTATES_INFO_VER

#define NV_GPU_PERF_PSTATES_INFO_VER NV_GPU_PERF_PSTATES_INFO_VER3

Macro for constructing the version field of NV_GPU_PERF_PSTATES_INFO.

◆ NV_GPU_PERF_PSTATES_INFO_VER1

#define NV_GPU_PERF_PSTATES_INFO_VER1 MAKE_NVAPI_VERSION(NV_GPU_PERF_PSTATES_INFO_V1,1)

Macro for constructing the version field of NV_GPU_PERF_PSTATES_INFO_V1.

◆ NV_GPU_PERF_PSTATES_INFO_VER2

#define NV_GPU_PERF_PSTATES_INFO_VER2 MAKE_NVAPI_VERSION(NV_GPU_PERF_PSTATES_INFO_V2,2)

Macro for constructing the version field of NV_GPU_PERF_PSTATES_INFO_V2.

◆ NV_GPU_PERF_PSTATES_INFO_VER3

#define NV_GPU_PERF_PSTATES_INFO_VER3 MAKE_NVAPI_VERSION(NV_GPU_PERF_PSTATES_INFO_V2,3)

Macro for constructing the version field of NV_GPU_PERF_PSTATES_INFO_V2.

◆ NVAPI_MAX_GPU_PSTATE20_BASE_VOLTAGES

#define NVAPI_MAX_GPU_PSTATE20_BASE_VOLTAGES 4

◆ NVAPI_MAX_GPU_PSTATE20_CLOCKS

#define NVAPI_MAX_GPU_PSTATE20_CLOCKS 8

◆ NVAPI_MAX_GPU_PSTATE20_PSTATES

#define NVAPI_MAX_GPU_PSTATE20_PSTATES 16

◆ NVAPI_MAX_GPU_UTILIZATIONS

#define NVAPI_MAX_GPU_UTILIZATIONS 8

Typedef Documentation

◆ NV_GPU_PERF_PSTATE_ID

typedef enum _NV_GPU_PERF_PSTATE_ID NV_GPU_PERF_PSTATE_ID

◆ NV_GPU_PERF_PSTATES20_INFO

typedef NV_GPU_PERF_PSTATES20_INFO_V2 NV_GPU_PERF_PSTATES20_INFO

◆ NV_GPU_PERF_PSTATES20_INFO_V2

typedef struct _NV_GPU_PERF_PSTATES20_INFO_V2 NV_GPU_PERF_PSTATES20_INFO_V2

Used in NvAPI_GPU_GetPstates20() interface call.

◆ NV_GPU_PERF_PSTATES_INFO

typedef NV_GPU_PERF_PSTATES_INFO_V2 NV_GPU_PERF_PSTATES_INFO

Enumeration Type Documentation

◆ _NV_GPU_PERF_PSTATE_ID

enum _NV_GPU_PERF_PSTATE_ID
Enumerator
NVAPI_GPU_PERF_PSTATE_P0
NVAPI_GPU_PERF_PSTATE_P1
NVAPI_GPU_PERF_PSTATE_P2
NVAPI_GPU_PERF_PSTATE_P3
NVAPI_GPU_PERF_PSTATE_P4
NVAPI_GPU_PERF_PSTATE_P5
NVAPI_GPU_PERF_PSTATE_P6
NVAPI_GPU_PERF_PSTATE_P7
NVAPI_GPU_PERF_PSTATE_P8
NVAPI_GPU_PERF_PSTATE_P9
NVAPI_GPU_PERF_PSTATE_P10
NVAPI_GPU_PERF_PSTATE_P11
NVAPI_GPU_PERF_PSTATE_P12
NVAPI_GPU_PERF_PSTATE_P13
NVAPI_GPU_PERF_PSTATE_P14
NVAPI_GPU_PERF_PSTATE_P15
NVAPI_GPU_PERF_PSTATE_UNDEFINED
NVAPI_GPU_PERF_PSTATE_ALL

◆ NV_GPU_PERF_PSTATE20_CLOCK_TYPE_ID

enum NV_GPU_PERF_PSTATE20_CLOCK_TYPE_ID

Used to identify clock type.

Enumerator
NVAPI_GPU_PERF_PSTATE20_CLOCK_TYPE_SINGLE | Clock domains that use single frequency value within given pstate.
NVAPI_GPU_PERF_PSTATE20_CLOCK_TYPE_RANGE | Clock domains that allow range of frequency values within given pstate.

Function Documentation

◆ __nvapi_deprecated_function()

__nvapi_deprecated_function | ( | "Do not use this function - it is deprecated in release 304. | Instead,
 |  | use NvAPI_GPU_GetPstates20." |
 | ) |  |

DESCRIPTION: This API retrieves all performance states (P-States) information.

             P-States are GPU active/executing performance capability and power consumption states.

             P-States ranges from P0 to P15, with P0 being the highest performance/power state, and
             P15 being the lowest performance/power state. Each P-State, if available, maps to a
             performance level. Not all P-States are available on a given system. The definitions
             of each P-State are currently as follows: \n
             - P0/P1 - Maximum 3D performance
             - P2/P3 - Balanced 3D performance-power
             - P8 - Basic HD video playback
             - P10 - DVD playback
             - P12 - Minimum idle power consumption
Parameters
[in] hPhysicalGPU GPU selection.
[out] pPerfPstatesInfo P-States information retrieved, as detailed below:
  • flags is reserved for future use.
  • numPstates is the number of available P-States
  • numClocks is the number of clock domains supported by each P-State
  • pstates has valid index range from 0 to numPstates - 1
  • pstates[i].pstateId is the ID of the P-State, containing the following info:
    • pstates[i].flags containing the following info:
      • bit 0 indicates if the PCIE limit is GEN1 or GEN2
      • bit 1 indicates if the Pstate is overclocked or not
      • bit 2 indicates if the Pstate is overclockable or not
    • pstates[i].clocks has valid index range from 0 to numClocks -1
    • pstates[i].clocks[j].domainId is the public ID of the clock domain, containing the following info:
      • pstates[i].clocks[j].flags containing the following info: bit 0 indicates if the clock domain is overclockable or not
      • pstates[i].clocks[j].freq is the clock frequency in kHz
    • pstates[i].voltages has a valid index range from 0 to numVoltages - 1
    • pstates[i].voltages[j].domainId is the ID of the voltage domain, containing the following info:
      • pstates[i].voltages[j].flags is reserved for future use.
      • pstates[i].voltages[j].mvolt is the voltage in mV inputFlags(IN) - This can be used to select various options:
    • if bit 0 is set, pPerfPstatesInfo would contain the default settings instead of the current, possibily overclocked settings.
    • if bit 1 is set, pPerfPstatesInfo would contain the maximum clock frequencies instead of the nominal frequencies.
    • if bit 2 is set, pPerfPstatesInfo would contain the minimum clock frequencies instead of the nominal frequencies.
    • all other bits must be set to 0.
Return values
NVAPI_OK | Completed request
NVAPI_ERROR | Miscellaneous error occurred
NVAPI_HANDLE_INVALIDATED | Handle passed has been invalidated (see user guide)
NVAPI_EXPECTED_PHYSICAL_GPU_HANDLE | Handle passed is not a physical GPU handle
NVAPI_INCOMPATIBLE_STRUCT_VERSION | The version of the NV_GPU_PERF_PSTATES struct is not supported

◆ NvAPI_GPU_GetCurrentPstate()

NVAPI_INTERFACE NvAPI_GPU_GetCurrentPstate | ( | NvPhysicalGpuHandle | hPhysicalGpu,
 |  | NV_GPU_PERF_PSTATE_ID * | pCurrentPstate
 | ) |  |

DESCRIPTION: This function retrieves the current performance state (P-State).

SUPPORTED OS: Windows 7 and higher

Since
Release: 165

TCC_SUPPORTED

MCDM_SUPPORTED

Parameters
[in] | hPhysicalGPU | GPU selection
[out] | pCurrentPstate | The ID of the current P-State of the GPU - see NV_GPU_PERF_PSTATES.
Return values
NVAPI_OK | Completed request
NVAPI_ERROR | Miscellaneous error occurred.
NVAPI_HANDLE_INVALIDATED | Handle passed has been invalidated (see user guide).
NVAPI_EXPECTED_PHYSICAL_GPU_HANDLE | Handle passed is not a physical GPU handle.
NVAPI_NOT_SUPPORTED | P-States is not supported on this setup.

◆ NvAPI_GPU_GetDynamicPstatesInfoEx()

NVAPI_INTERFACE NvAPI_GPU_GetDynamicPstatesInfoEx | ( | NvPhysicalGpuHandle | hPhysicalGpu,
 |  | NV_GPU_DYNAMIC_PSTATES_INFO_EX * | pDynamicPstatesInfoEx
 | ) |  |

DESCRIPTION: This API retrieves the NV_GPU_DYNAMIC_PSTATES_INFO_EX structure for the specified physical GPU. Each domain's info is indexed in the array. For example:

  • pDynamicPstatesInfo->utilization[NVAPI_GPU_UTILIZATION_DOMAIN_GPU] holds the info for the GPU domain. There are currently 4 domains for which GPU utilization and dynamic P-State thresholds can be retrieved: graphic engine (GPU), frame buffer (FB), video engine (VID), and bus interface (BUS).

SUPPORTED OS: Windows 7 and higher

TCC_SUPPORTED

MCDM_SUPPORTED

Since
Release: 185
Return values
NVAPI_OK
NVAPI_ERROR
NVAPI_INVALID_ARGUMENT | pDynamicPstatesInfo is NULL
NVAPI_HANDLE_INVALIDATED
NVAPI_EXPECTED_PHYSICAL_GPU_HANDLE
NVAPI_INCOMPATIBLE_STRUCT_VERSION | The version of the INFO struct is not supported

◆ NvAPI_GPU_GetPstates20()

NVAPI_INTERFACE NvAPI_GPU_GetPstates20 | ( | __in NvPhysicalGpuHandle | hPhysicalGpu,
 |  | __inout NV_GPU_PERF_PSTATES20_INFO * | pPstatesInfo
 | ) |  |

DESCRIPTION: This API retrieves all performance states (P-States) 2.0 information.

            P-States are GPU active/executing performance capability states.
            They range from P0 to P15, with P0 being the highest performance state,
            and P15 being the lowest performance state. Each P-State, if available,
            maps to a performance level. Not all P-States are available on a given system.
            The definition of each P-States are currently as follow:
            - P0/P1 - Maximum 3D performance
            - P2/P3 - Balanced 3D performance-power
            - P8 - Basic HD video playback
            - P10 - DVD playback
            - P12 - Minimum idle power consumption

TCC_SUPPORTED

MCDM_SUPPORTED

Since
Release: 295

SUPPORTED OS: Windows 7 and higher

Parameters
[in] | hPhysicalGPU | GPU selection
[out] | pPstatesInfo | P-States information retrieved, as documented in declaration above
Returns
This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.


Data Fields
NV_GPU_PERF_PSTATES20_PARAM_DELTA Struct Reference
GPU APIs » GPU Performance State Interface

#include <nvapi.h>

Data Fields

NvS32 value
struct {
NvS32 NV_GPU_PERF_PSTATES20_PARAM_DELTA::min
NvS32 NV_GPU_PERF_PSTATES20_PARAM_DELTA::max
} valueRange

Detailed Description

Used to describe both voltage and frequency deltas.

The documentation for this struct was generated from the following file:


Data Fields
NV_GPU_PSTATE20_CLOCK_ENTRY_V1 Struct Reference
GPU APIs » GPU Performance State Interface

#include <nvapi.h>

Data Fields

NV_GPU_PUBLIC_CLOCK_ID domainId
NV_GPU_PERF_PSTATE20_CLOCK_TYPE_ID typeId
NvU32 | bIsEditable:1
NvU32 | reserved:31
NV_GPU_PERF_PSTATES20_PARAM_DELTA freqDelta_kHz
union {
struct {
NvU32 NV_GPU_PSTATE20_CLOCK_ENTRY_V1::freq_kHz
} NV_GPU_PSTATE20_CLOCK_ENTRY_V1::single
struct {
NvU32 NV_GPU_PSTATE20_CLOCK_ENTRY_V1::minFreq_kHz
NvU32 NV_GPU_PSTATE20_CLOCK_ENTRY_V1::maxFreq_kHz
NV_GPU_PERF_VOLTAGE_INFO_DOMAIN_ID NV_GPU_PSTATE20_CLOCK_ENTRY_V1::domainId
NvU32 NV_GPU_PSTATE20_CLOCK_ENTRY_V1::minVoltage_uV
NvU32 NV_GPU_PSTATE20_CLOCK_ENTRY_V1::maxVoltage_uV
} NV_GPU_PSTATE20_CLOCK_ENTRY_V1::range
} data

Detailed Description

Used to describe single clock entry.

The documentation for this struct was generated from the following file:


Data Fields
NV_GPU_PSTATE20_BASE_VOLTAGE_ENTRY_V1 Struct Reference
GPU APIs » GPU Performance State Interface

#include <nvapi.h>

Data Fields

NV_GPU_PERF_VOLTAGE_INFO_DOMAIN_ID domainId
NvU32 | bIsEditable:1
NvU32 | reserved:31
NvU32 volt_uV
NV_GPU_PERF_PSTATES20_PARAM_DELTA voltDelta_uV

Detailed Description

Used to describe single base voltage entry.

The documentation for this struct was generated from the following file:


Data Fields
NV_GPU_PERF_PSTATES20_INFO_V1 Struct Reference
GPU APIs » GPU Performance State Interface

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 | bIsEditable:1
NvU32 | reserved:31
NvU32 numPstates
NvU32 numClocks
NvU32 numBaseVoltages
struct {
NV_GPU_PERF_PSTATE_ID NV_GPU_PERF_PSTATES20_INFO_V1::pstateId
NvU32 NV_GPU_PERF_PSTATES20_INFO_V1::bIsEditable:1
NvU32 NV_GPU_PERF_PSTATES20_INFO_V1::reserved:31
NV_GPU_PSTATE20_CLOCK_ENTRY_V1 NV_GPU_PERF_PSTATES20_INFO_V1::clocks [NVAPI_MAX_GPU_PSTATE20_CLOCKS]
NV_GPU_PSTATE20_BASE_VOLTAGE_ENTRY_V1 NV_GPU_PERF_PSTATES20_INFO_V1::baseVoltages [NVAPI_MAX_GPU_PSTATE20_BASE_VOLTAGES]
} pstates [NVAPI_MAX_GPU_PSTATE20_PSTATES]

Detailed Description

Used in NvAPI_GPU_GetPstates20() interface call.

The documentation for this struct was generated from the following file:


Data Fields
_NV_GPU_PERF_PSTATES20_INFO_V2 Struct Reference
GPU APIs » GPU Performance State Interface

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 | bIsEditable:1
NvU32 | reserved:31
NvU32 numPstates
NvU32 numClocks
NvU32 numBaseVoltages
struct {
NV_GPU_PERF_PSTATE_ID _NV_GPU_PERF_PSTATES20_INFO_V2::pstateId
NvU32 _NV_GPU_PERF_PSTATES20_INFO_V2::bIsEditable:1
NvU32 _NV_GPU_PERF_PSTATES20_INFO_V2::reserved:31
NV_GPU_PSTATE20_CLOCK_ENTRY_V1 _NV_GPU_PERF_PSTATES20_INFO_V2::clocks [NVAPI_MAX_GPU_PSTATE20_CLOCKS]
NV_GPU_PSTATE20_BASE_VOLTAGE_ENTRY_V1 _NV_GPU_PERF_PSTATES20_INFO_V2::baseVoltages [NVAPI_MAX_GPU_PSTATE20_BASE_VOLTAGES]
} pstates [NVAPI_MAX_GPU_PSTATE20_PSTATES]
struct {
NvU32 _NV_GPU_PERF_PSTATES20_INFO_V2::numVoltages
NV_GPU_PSTATE20_BASE_VOLTAGE_ENTRY_V1 _NV_GPU_PERF_PSTATES20_INFO_V2::voltages [NVAPI_MAX_GPU_PSTATE20_BASE_VOLTAGES]
} ov

Detailed Description

Used in NvAPI_GPU_GetPstates20() interface call.

The documentation for this struct was generated from the following file:


Data Fields
NV_GPU_PERF_PSTATES_INFO_V1 Struct Reference
OpenGL APIs | GPU APIs » GPU Performance State Interface

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 flags
NvU32 numPstates
NvU32 numClocks
struct {
NV_GPU_PERF_PSTATE_ID NV_GPU_PERF_PSTATES_INFO_V1::pstateId
NvU32 NV_GPU_PERF_PSTATES_INFO_V1::flags
struct {
NV_GPU_PUBLIC_CLOCK_ID NV_GPU_PERF_PSTATES_INFO_V1::domainId
NvU32 NV_GPU_PERF_PSTATES_INFO_V1::flags
NvU32 NV_GPU_PERF_PSTATES_INFO_V1::freq
} NV_GPU_PERF_PSTATES_INFO_V1::clocks [NVAPI_MAX_GPU_PERF_CLOCKS]
} pstates [NVAPI_MAX_GPU_PERF_PSTATES]

Detailed Description

Used in NvAPI_GPU_GetPstatesInfoEx()

The documentation for this struct was generated from the following file:


Data Fields
NV_GPU_PERF_PSTATES_INFO_V2 Struct Reference
OpenGL APIs | GPU APIs » GPU Performance State Interface

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 flags
NvU32 numPstates
NvU32 numClocks
NvU32 numVoltages
struct {
NV_GPU_PERF_PSTATE_ID NV_GPU_PERF_PSTATES_INFO_V2::pstateId
NvU32 NV_GPU_PERF_PSTATES_INFO_V2::flags
struct {
NV_GPU_PUBLIC_CLOCK_ID NV_GPU_PERF_PSTATES_INFO_V2::domainId
NvU32 NV_GPU_PERF_PSTATES_INFO_V2::flags
NvU32 NV_GPU_PERF_PSTATES_INFO_V2::freq
} NV_GPU_PERF_PSTATES_INFO_V2::clocks [NVAPI_MAX_GPU_PERF_CLOCKS]
struct {
NV_GPU_PERF_VOLTAGE_INFO_DOMAIN_ID NV_GPU_PERF_PSTATES_INFO_V2::domainId
NvU32 NV_GPU_PERF_PSTATES_INFO_V2::flags
NvU32 NV_GPU_PERF_PSTATES_INFO_V2::mvolt
} NV_GPU_PERF_PSTATES_INFO_V2::voltages [NVAPI_MAX_GPU_PERF_VOLTAGES]
} pstates [NVAPI_MAX_GPU_PERF_PSTATES]
The documentation for this struct was generated from the following file:


Data Fields
NV_GPU_DYNAMIC_PSTATES_INFO_EX Struct Reference
OpenGL APIs | GPU APIs » GPU Performance State Interface

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 flags
struct {
NvU32 NV_GPU_DYNAMIC_PSTATES_INFO_EX::bIsPresent:1
NvU32 NV_GPU_DYNAMIC_PSTATES_INFO_EX::percentage
} utilization [NVAPI_MAX_GPU_UTILIZATIONS]

Detailed Description

Used in NvAPI_GPU_GetDynamicPstatesInfoEx().

The documentation for this struct was generated from the following file:


Data Structures | Macros | Typedefs | Enumerations | Functions
GPU Clock Control Interface
GPU APIs | OpenGL APIs

Data Structures

struct | NV_GPU_CLOCK_FREQUENCIES_V1
struct | NV_GPU_CLOCK_FREQUENCIES_V2

Macros

#define | NV_GPU_CLOCK_FREQUENCIES_VER_1 MAKE_NVAPI_VERSION(NV_GPU_CLOCK_FREQUENCIES_V1,1)
#define | NV_GPU_CLOCK_FREQUENCIES_VER_2 MAKE_NVAPI_VERSION(NV_GPU_CLOCK_FREQUENCIES_V2,2)
#define | NV_GPU_CLOCK_FREQUENCIES_VER_3 MAKE_NVAPI_VERSION(NV_GPU_CLOCK_FREQUENCIES_V2,3)
#define | NV_GPU_CLOCK_FREQUENCIES_VER NV_GPU_CLOCK_FREQUENCIES_VER_3

Typedefs

typedef enum _NV_GPU_PERF_VOLTAGE_INFO_DOMAIN_ID | NV_GPU_PERF_VOLTAGE_INFO_DOMAIN_ID
typedef enum _NV_GPU_PUBLIC_CLOCK_ID | NV_GPU_PUBLIC_CLOCK_ID
typedef NV_GPU_CLOCK_FREQUENCIES_V2 | NV_GPU_CLOCK_FREQUENCIES

Enumerations

enum | _NV_GPU_PERF_VOLTAGE_INFO_DOMAIN_ID { NVAPI_GPU_PERF_VOLTAGE_INFO_DOMAIN_CORE = 0 , NVAPI_GPU_PERF_VOLTAGE_INFO_DOMAIN_UNDEFINED = NVAPI_MAX_GPU_PERF_VOLTAGES }
enum _NV_GPU_PUBLIC_CLOCK_ID {
NVAPI_GPU_PUBLIC_CLOCK_GRAPHICS = 0 , NVAPI_GPU_PUBLIC_CLOCK_MEMORY = 4 , NVAPI_GPU_PUBLIC_CLOCK_PROCESSOR = 7 , NVAPI_GPU_PUBLIC_CLOCK_VIDEO = 8 ,
NVAPI_GPU_PUBLIC_CLOCK_UNDEFINED = NVAPI_MAX_GPU_PUBLIC_CLOCKS
}
enum | NV_GPU_CLOCK_FREQUENCIES_CLOCK_TYPE { NV_GPU_CLOCK_FREQUENCIES_CURRENT_FREQ = 0 , NV_GPU_CLOCK_FREQUENCIES_BASE_CLOCK = 1 , NV_GPU_CLOCK_FREQUENCIES_BOOST_CLOCK = 2 , NV_GPU_CLOCK_FREQUENCIES_CLOCK_TYPE_NUM = NV_GPU_MAX_CLOCK_FREQUENCIES }

Functions

NVAPI_INTERFACE | NvAPI_GPU_GetAllClockFrequencies (__in NvPhysicalGpuHandle hPhysicalGPU, __inout NV_GPU_CLOCK_FREQUENCIES *pClkFreqs)
#define | NVAPI_MAX_GPU_CLOCKS 32
#define | NVAPI_MAX_GPU_PUBLIC_CLOCKS 32
#define | NVAPI_MAX_GPU_PERF_CLOCKS 32
#define | NVAPI_MAX_GPU_PERF_VOLTAGES 16
#define | NVAPI_MAX_GPU_PERF_PSTATES 16

Detailed Description

The GPU clock control APIs are used to get and set individual clock domains on a per-GPU basis.

Macro Definition Documentation

◆ NV_GPU_CLOCK_FREQUENCIES_VER

#define NV_GPU_CLOCK_FREQUENCIES_VER NV_GPU_CLOCK_FREQUENCIES_VER_3

◆ NV_GPU_CLOCK_FREQUENCIES_VER_1

#define NV_GPU_CLOCK_FREQUENCIES_VER_1 MAKE_NVAPI_VERSION(NV_GPU_CLOCK_FREQUENCIES_V1,1)

◆ NV_GPU_CLOCK_FREQUENCIES_VER_2

#define NV_GPU_CLOCK_FREQUENCIES_VER_2 MAKE_NVAPI_VERSION(NV_GPU_CLOCK_FREQUENCIES_V2,2)

◆ NV_GPU_CLOCK_FREQUENCIES_VER_3

#define NV_GPU_CLOCK_FREQUENCIES_VER_3 MAKE_NVAPI_VERSION(NV_GPU_CLOCK_FREQUENCIES_V2,3)

◆ NVAPI_MAX_GPU_CLOCKS

#define NVAPI_MAX_GPU_CLOCKS 32

◆ NVAPI_MAX_GPU_PERF_CLOCKS

#define NVAPI_MAX_GPU_PERF_CLOCKS 32

◆ NVAPI_MAX_GPU_PERF_PSTATES

#define NVAPI_MAX_GPU_PERF_PSTATES 16

◆ NVAPI_MAX_GPU_PERF_VOLTAGES

#define NVAPI_MAX_GPU_PERF_VOLTAGES 16

◆ NVAPI_MAX_GPU_PUBLIC_CLOCKS

#define NVAPI_MAX_GPU_PUBLIC_CLOCKS 32

Typedef Documentation

◆ NV_GPU_CLOCK_FREQUENCIES

typedef NV_GPU_CLOCK_FREQUENCIES_V2 NV_GPU_CLOCK_FREQUENCIES

Used in NvAPI_GPU_GetAllClockFrequencies()

◆ NV_GPU_PERF_VOLTAGE_INFO_DOMAIN_ID

typedef enum _NV_GPU_PERF_VOLTAGE_INFO_DOMAIN_ID NV_GPU_PERF_VOLTAGE_INFO_DOMAIN_ID

◆ NV_GPU_PUBLIC_CLOCK_ID

typedef enum _NV_GPU_PUBLIC_CLOCK_ID NV_GPU_PUBLIC_CLOCK_ID

Enumeration Type Documentation

◆ _NV_GPU_PERF_VOLTAGE_INFO_DOMAIN_ID

enum _NV_GPU_PERF_VOLTAGE_INFO_DOMAIN_ID
Enumerator
NVAPI_GPU_PERF_VOLTAGE_INFO_DOMAIN_CORE
NVAPI_GPU_PERF_VOLTAGE_INFO_DOMAIN_UNDEFINED

◆ _NV_GPU_PUBLIC_CLOCK_ID

enum _NV_GPU_PUBLIC_CLOCK_ID
Enumerator
NVAPI_GPU_PUBLIC_CLOCK_GRAPHICS
NVAPI_GPU_PUBLIC_CLOCK_MEMORY
NVAPI_GPU_PUBLIC_CLOCK_PROCESSOR
NVAPI_GPU_PUBLIC_CLOCK_VIDEO
NVAPI_GPU_PUBLIC_CLOCK_UNDEFINED

◆ NV_GPU_CLOCK_FREQUENCIES_CLOCK_TYPE

enum NV_GPU_CLOCK_FREQUENCIES_CLOCK_TYPE

Used in NvAPI_GPU_GetAllClockFrequencies()

Enumerator
NV_GPU_CLOCK_FREQUENCIES_CURRENT_FREQ
NV_GPU_CLOCK_FREQUENCIES_BASE_CLOCK
NV_GPU_CLOCK_FREQUENCIES_BOOST_CLOCK
NV_GPU_CLOCK_FREQUENCIES_CLOCK_TYPE_NUM

Function Documentation

◆ NvAPI_GPU_GetAllClockFrequencies()

NVAPI_INTERFACE NvAPI_GPU_GetAllClockFrequencies | ( | __in NvPhysicalGpuHandle | hPhysicalGPU,
 |  | __inout NV_GPU_CLOCK_FREQUENCIES * | pClkFreqs
 | ) |  |

This function retrieves the NV_GPU_CLOCK_FREQUENCIES structure for the specified physical GPU.

For each clock domain:

  • bIsPresent is set for each domain that is present on the GPU
  • frequency is the domain's clock freq in kHz

Each domain's info is indexed in the array. For example: clkFreqs.domain[NVAPI_GPU_PUBLIC_CLOCK_MEMORY] holds the info for the MEMORY domain.

SUPPORTED OS: Windows 7 and higher

TCC_SUPPORTED

MCDM_SUPPORTED

Since
Release: 295
Returns
This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.
Return values
NVAPI_INVALID_ARGUMENT pClkFreqs is NULL.


Data Fields
NV_GPU_CLOCK_FREQUENCIES_V1 Struct Reference
OpenGL APIs | GPU APIs | OpenGL APIs » GPU Clock Control Interface

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 reserved
struct {
NvU32 NV_GPU_CLOCK_FREQUENCIES_V1::bIsPresent:1
NvU32 NV_GPU_CLOCK_FREQUENCIES_V1::reserved:31
NvU32 NV_GPU_CLOCK_FREQUENCIES_V1::frequency
} domain [NVAPI_MAX_GPU_PUBLIC_CLOCKS]

Detailed Description

Used in NvAPI_GPU_GetAllClockFrequencies()

The documentation for this struct was generated from the following file:


Data Fields
NV_GPU_CLOCK_FREQUENCIES_V2 Struct Reference
OpenGL APIs | GPU APIs | OpenGL APIs » GPU Clock Control Interface

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 | ClockType:4
NvU32 | reserved:20
NvU32 | reserved1:8
struct {
NvU32 NV_GPU_CLOCK_FREQUENCIES_V2::bIsPresent:1
NvU32 NV_GPU_CLOCK_FREQUENCIES_V2::reserved:31
NvU32 NV_GPU_CLOCK_FREQUENCIES_V2::frequency
} domain [NVAPI_MAX_GPU_PUBLIC_CLOCKS]

Detailed Description

Used in NvAPI_GPU_GetAllClockFrequencies()

The documentation for this struct was generated from the following file:


Functions
GPU Cooler Interface
GPU APIs

Functions

NVAPI_INTERFACE NvAPI_GPU_GetTachReading (NvPhysicalGpuHandle hPhysicalGPU, NvU32 *pValue)

Detailed Description

The GPU cooler APIs are used to get and set the fan level or equivalent cooler levels for various target devices associated with the GPU.

Function Documentation

◆ NvAPI_GPU_GetTachReading()

NVAPI_INTERFACE NvAPI_GPU_GetTachReading | ( | NvPhysicalGpuHandle | hPhysicalGPU,
 |  | NvU32 * | pValue
 | ) |  |

DESCRIPTION: This API retrieves the fan speed tachometer reading for the specified physical GPU.

HOW TO USE:

  • NvU32 Value = 0;
  • ret = NvAPI_GPU_GetTachReading(hPhysicalGpu, &Value);
  • On call success:
  • Value contains the tachometer reading

SUPPORTED OS: Windows 7 and higher

TCC_SUPPORTED

MCDM_SUPPORTED

Parameters
[in] | hPhysicalGpu | GPU selection.
[out] | pValue | Pointer to a variable to get the tachometer reading
Return values
NVAPI_OK | - completed request
NVAPI_ERROR | - miscellaneous error occurred
NVAPI_NOT_SUPPORTED | - functionality not supported
NVAPI_API_NOT_INTIALIZED | - nvapi not initialized
NVAPI_INVALID_ARGUMENT | - invalid argument passed
NVAPI_HANDLE_INVALIDATED | - handle passed has been invalidated (see user guide)
NVAPI_EXPECTED_PHYSICAL_GPU_HANDLE | - handle passed is not a physical GPU handle


Data Structures | Macros | Functions
GPU ECC Interface
GPU APIs | OpenGL APIs

Data Structures

struct | NV_GPU_ECC_STATUS_INFO
struct | NV_GPU_ECC_ERROR_INFO
struct | NV_GPU_ECC_CONFIGURATION_INFO

Macros

#define | NV_GPU_ECC_STATUS_INFO_VER MAKE_NVAPI_VERSION(NV_GPU_ECC_STATUS_INFO,1)
#define | NV_GPU_ECC_ERROR_INFO_VER MAKE_NVAPI_VERSION(NV_GPU_ECC_ERROR_INFO,1)
#define | NV_GPU_ECC_CONFIGURATION_INFO_VER MAKE_NVAPI_VERSION(NV_GPU_ECC_CONFIGURATION_INFO,1)

Functions

NVAPI_INTERFACE | NvAPI_GPU_GetECCStatusInfo (NvPhysicalGpuHandle hPhysicalGpu, NV_GPU_ECC_STATUS_INFO *pECCStatusInfo)
NVAPI_INTERFACE | NvAPI_GPU_GetECCErrorInfo (NvPhysicalGpuHandle hPhysicalGpu, NV_GPU_ECC_ERROR_INFO *pECCErrorInfo)
NVAPI_INTERFACE | NvAPI_GPU_ResetECCErrorInfo (NvPhysicalGpuHandle hPhysicalGpu, NvU8 bResetCurrent, NvU8 bResetAggregate)
NVAPI_INTERFACE | NvAPI_GPU_GetECCConfigurationInfo (NvPhysicalGpuHandle hPhysicalGpu, NV_GPU_ECC_CONFIGURATION_INFO *pECCConfigurationInfo)
NVAPI_INTERFACE | NvAPI_GPU_SetECCConfiguration (NvPhysicalGpuHandle hPhysicalGpu, NvU8 bEnable, NvU8 bEnableImmediately)

Detailed Description

The GPU ECC APIs are used to configure ECC-capable GPUs.

Used in NV_GPU_ECC_STATUS_INFO.

Macro Definition Documentation

◆ NV_GPU_ECC_CONFIGURATION_INFO_VER

#define NV_GPU_ECC_CONFIGURATION_INFO_VER MAKE_NVAPI_VERSION(NV_GPU_ECC_CONFIGURATION_INFO,1)

Macro for consstructing the verion field of NV_GPU_ECC_CONFIGURATION_INFO

◆ NV_GPU_ECC_ERROR_INFO_VER

#define NV_GPU_ECC_ERROR_INFO_VER MAKE_NVAPI_VERSION(NV_GPU_ECC_ERROR_INFO,1)

Macro for constructing the version field of NV_GPU_ECC_ERROR_INFO

◆ NV_GPU_ECC_STATUS_INFO_VER

#define NV_GPU_ECC_STATUS_INFO_VER MAKE_NVAPI_VERSION(NV_GPU_ECC_STATUS_INFO,1)

Macro for constructing the version field of NV_GPU_ECC_STATUS_INFO

Function Documentation

◆ NvAPI_GPU_GetECCConfigurationInfo()

NVAPI_INTERFACE NvAPI_GPU_GetECCConfigurationInfo | ( | NvPhysicalGpuHandle | hPhysicalGpu,
 |  | NV_GPU_ECC_CONFIGURATION_INFO * | pECCConfigurationInfo
 | ) |  |

◆ NvAPI_GPU_GetECCErrorInfo()

NVAPI_INTERFACE NvAPI_GPU_GetECCErrorInfo | ( | NvPhysicalGpuHandle | hPhysicalGpu,
 |  | NV_GPU_ECC_ERROR_INFO * | pECCErrorInfo
 | ) |  |

◆ NvAPI_GPU_GetECCStatusInfo()

NVAPI_INTERFACE NvAPI_GPU_GetECCStatusInfo | ( | NvPhysicalGpuHandle | hPhysicalGpu,
 |  | NV_GPU_ECC_STATUS_INFO * | pECCStatusInfo
 | ) |  |

◆ NvAPI_GPU_ResetECCErrorInfo()

NVAPI_INTERFACE NvAPI_GPU_ResetECCErrorInfo | ( | NvPhysicalGpuHandle | hPhysicalGpu,
 |  | NvU8 | bResetCurrent,
 |  | NvU8 | bResetAggregate
 | ) |  |

DESCRIPTION: This function resets ECC memory error counters.

SUPPORTED OS: Windows 7 and higher

TCC_SUPPORTED

MCDM_SUPPORTED

\requires Administrator privileges since release 430.39

Parameters
[in] | hPhysicalGpu | A handle identifying the physical GPU for which ECC error information is to be cleared.
[in] | bResetCurrent | Reset the current ECC error counters.
[in] | bResetAggregate | Reset the aggregate ECC error counters.
Returns
This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.
Return values
NVAPI_INVALID_USER_PRIVILEGE - The application will require Administrator privileges to access this API. The application can be elevated to a higher permission level by selecting "Run as Administrator".

◆ NvAPI_GPU_SetECCConfiguration()

NVAPI_INTERFACE NvAPI_GPU_SetECCConfiguration | ( | NvPhysicalGpuHandle | hPhysicalGpu,
 |  | NvU8 | bEnable,
 |  | NvU8 | bEnableImmediately
 | ) |  |

DESCRIPTION: This function updates the ECC memory configuration setting.

SUPPORTED OS: Windows 7 and higher

TCC_SUPPORTED

MCDM_SUPPORTED

\requires Administrator privileges since release 430.39

Parameters
[in] | hPhysicalGpu | A handle identifying the physical GPU for which to update the ECC configuration setting.
[in] | bEnable | The new ECC configuration setting.
[in] | bEnableImmediately | Request that the new setting take effect immediately.
Returns
This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.
Return values
NVAPI_INVALID_CONFIGURATION | - Possibly SLI is enabled. Disable SLI and retry.
NVAPI_INVALID_USER_PRIVILEGE | - The application will require Administrator privileges to access this API. The application can be elevated to a higher permission level by selecting "Run as Administrator".


Data Fields
NV_GPU_ECC_STATUS_INFO Struct Reference
OpenGL APIs | GPU APIs | OpenGL APIs » GPU ECC Interface

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 | isSupported: 1
NV_ECC_CONFIGURATION configurationOptions
NvU32 | isEnabled: 1

Detailed Description

Used in NvAPI_GPU_GetECCStatusInfo().

The documentation for this struct was generated from the following file:


Data Fields
NV_GPU_ECC_ERROR_INFO Struct Reference
OpenGL APIs | GPU APIs | OpenGL APIs » GPU ECC Interface

#include <nvapi.h>

Data Fields

NvU32 version
struct {
NvU64 NV_GPU_ECC_ERROR_INFO::singleBitErrors
NvU64 NV_GPU_ECC_ERROR_INFO::doubleBitErrors
} current
struct {
NvU64 NV_GPU_ECC_ERROR_INFO::singleBitErrors
NvU64 NV_GPU_ECC_ERROR_INFO::doubleBitErrors
} aggregate

Detailed Description

Used in NvAPI_GPU_GetECCErrorInfo()/

The documentation for this struct was generated from the following file:


Data Fields
NV_GPU_ECC_CONFIGURATION_INFO Struct Reference
OpenGL APIs | GPU APIs | OpenGL APIs » GPU ECC Interface

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 | isEnabled: 1
NvU32 | isEnabledByDefault: 1

Detailed Description

Used in NvAPI_GPU_GetECCConfigurationInfo().

The documentation for this struct was generated from the following file:


Modules
Video APIs

Modules

Video Input/Output Interface

Detailed Description

Privacy Policy | Manage My Privacy | Do Not Sell or Share My Data | Terms of Service | Accessibility | Corporate Policies | Product Security | Contact

Copyright © 2022-2024 NVIDIA Corporation


Data Structures | Macros | Typedefs | Enumerations | Functions
Stereoscopic 3D APIs
Video APIs » Video Input/Output Interface

Data Structures

struct _NVAPI_STEREO_CAPS

Macros

#define | NVAPI_STEREO_CAPS_VER1 MAKE_NVAPI_VERSION(NVAPI_STEREO_CAPS,1)
#define | NVAPI_STEREO_CAPS_VER NVAPI_STEREO_CAPS_VER1
#define | NVAPI_STEREO_QUADBUFFERED_API_VERSION 0x2

Typedefs

typedef enum _NV_StereoRegistryProfileType | NV_STEREO_REGISTRY_PROFILE_TYPE
typedef enum _NV_StereoRegistryID | NV_STEREO_REGISTRY_ID
typedef struct _NVAPI_STEREO_CAPS | NVAPI_STEREO_CAPS_V1
typedef NVAPI_STEREO_CAPS_V1 | NVAPI_STEREO_CAPS
typedef enum _NV_FrustumAdjustMode | NV_FRUSTUM_ADJUST_MODE
typedef enum _NVAPI_STEREO_INIT_ACTIVATION_FLAGS | NVAPI_STEREO_INIT_ACTIVATION_FLAGS
typedef enum _NV_StereoSwapChainMode | NV_STEREO_SWAPCHAIN_MODE
typedef enum _NV_StereoActiveEye | NV_STEREO_ACTIVE_EYE
typedef enum _NV_StereoDriverMode | NV_STEREO_DRIVER_MODE
typedef enum _NVAPI_STEREO_SURFACECREATEMODE | NVAPI_STEREO_SURFACECREATEMODE

Enumerations

enum | _NV_StereoRegistryProfileType { NVAPI_STEREO_DEFAULT_REGISTRY_PROFILE , NVAPI_STEREO_DX9_REGISTRY_PROFILE , NVAPI_STEREO_DX10_REGISTRY_PROFILE }
enum | _NV_StereoRegistryID { NVAPI_CONVERGENCE_ID , NVAPI_FRUSTUM_ADJUST_MODE_ID }
enum | _NV_FrustumAdjustMode { NVAPI_NO_FRUSTUM_ADJUST , NVAPI_FRUSTUM_STRETCH , NVAPI_FRUSTUM_CLEAR_EDGES }
enum | _NVAPI_STEREO_INIT_ACTIVATION_FLAGS { NVAPI_STEREO_INIT_ACTIVATION_IMMEDIATE = 0X00 , NVAPI_STEREO_INIT_ACTIVATION_DELAYED = 0x01 }
enum | _NV_StereoSwapChainMode { NVAPI_STEREO_SWAPCHAIN_DEFAULT = 0 , NVAPI_STEREO_SWAPCHAIN_STEREO = 1 , NVAPI_STEREO_SWAPCHAIN_MONO = 2 }
enum | _NV_StereoActiveEye { NVAPI_STEREO_EYE_RIGHT = 1 , NVAPI_STEREO_EYE_LEFT = 2 , NVAPI_STEREO_EYE_MONO = 3 }
enum | _NV_StereoDriverMode { NVAPI_STEREO_DRIVER_MODE_AUTOMATIC = 0 , NVAPI_STEREO_DRIVER_MODE_DIRECT = 2 }
enum | _NVAPI_STEREO_SURFACECREATEMODE { NVAPI_STEREO_SURFACECREATEMODE_AUTO , NVAPI_STEREO_SURFACECREATEMODE_FORCESTEREO , NVAPI_STEREO_SURFACECREATEMODE_FORCEMONO }

Functions

NVAPI_INTERFACE | NvAPI_Stereo_CreateConfigurationProfileRegistryKey (NV_STEREO_REGISTRY_PROFILE_TYPE registryProfileType)
NVAPI_INTERFACE | NvAPI_Stereo_DeleteConfigurationProfileRegistryKey (NV_STEREO_REGISTRY_PROFILE_TYPE registryProfileType)
NVAPI_INTERFACE | NvAPI_Stereo_SetConfigurationProfileValue (NV_STEREO_REGISTRY_PROFILE_TYPE registryProfileType, NV_STEREO_REGISTRY_ID valueRegistryID, void *pValue)
NVAPI_INTERFACE | NvAPI_Stereo_DeleteConfigurationProfileValue (NV_STEREO_REGISTRY_PROFILE_TYPE registryProfileType, NV_STEREO_REGISTRY_ID valueRegistryID)
NVAPI_INTERFACE | NvAPI_Stereo_GetStereoSupport (__in NvMonitorHandle hMonitor, __out NVAPI_STEREO_CAPS *pCaps)
NVAPI_INTERFACE | NvAPI_Stereo_DecreaseSeparation (StereoHandle stereoHandle)
NVAPI_INTERFACE | NvAPI_Stereo_IncreaseSeparation (StereoHandle stereoHandle)
NVAPI_INTERFACE | NvAPI_Stereo_DecreaseConvergence (StereoHandle stereoHandle)
NVAPI_INTERFACE | NvAPI_Stereo_IncreaseConvergence (StereoHandle stereoHandle)
NVAPI_INTERFACE | NvAPI_Stereo_GetFrustumAdjustMode (StereoHandle stereoHandle, NV_FRUSTUM_ADJUST_MODE *pFrustumAdjustMode)
NVAPI_INTERFACE | NvAPI_Stereo_SetFrustumAdjustMode (StereoHandle stereoHandle, NV_FRUSTUM_ADJUST_MODE newFrustumAdjustModeValue)
NVAPI_INTERFACE | NvAPI_Stereo_CaptureJpegImage (StereoHandle stereoHandle, NvU32 quality)
NVAPI_INTERFACE | NvAPI_Stereo_InitActivation (__in StereoHandle hStereoHandle, __in NVAPI_STEREO_INIT_ACTIVATION_FLAGS flags)
NVAPI_INTERFACE | NvAPI_Stereo_Trigger_Activation (__in StereoHandle hStereoHandle)
NVAPI_INTERFACE | NvAPI_Stereo_CapturePngImage (StereoHandle stereoHandle)
NVAPI_INTERFACE | NvAPI_Stereo_ReverseStereoBlitControl (StereoHandle hStereoHandle, NvU8 TurnOn)
NVAPI_INTERFACE | NvAPI_Stereo_SetNotificationMessage (StereoHandle hStereoHandle, NvU64 hWnd, NvU64 messageID)
NVAPI_INTERFACE | NvAPI_D3D1x_CreateSwapChain (StereoHandle hStereoHandle, DXGI_SWAP_CHAIN_DESC *pDesc, IDXGISwapChain **ppSwapChain, NV_STEREO_SWAPCHAIN_MODE mode)
NVAPI_INTERFACE | NvAPI_D3D9_CreateSwapChain (StereoHandle hStereoHandle, D3DPRESENT_PARAMETERS *pPresentationParameters, IDirect3DSwapChain9 **ppSwapChain, NV_STEREO_SWAPCHAIN_MODE mode)
NVAPI_INTERFACE | NvAPI_Stereo_Enable (void)
NVAPI_INTERFACE | NvAPI_Stereo_Disable (void)
NVAPI_INTERFACE | NvAPI_Stereo_IsEnabled (NvU8 *pIsStereoEnabled)
NVAPI_INTERFACE | NvAPI_Stereo_CreateHandleFromIUnknown (IUnknown *pDevice, StereoHandle *pStereoHandle)
NVAPI_INTERFACE | NvAPI_Stereo_DestroyHandle (StereoHandle stereoHandle)
NVAPI_INTERFACE | NvAPI_Stereo_Activate (StereoHandle stereoHandle)
NVAPI_INTERFACE | NvAPI_Stereo_Deactivate (StereoHandle stereoHandle)
NVAPI_INTERFACE | NvAPI_Stereo_IsActivated (StereoHandle stereoHandle, NvU8 *pIsStereoOn)
NVAPI_INTERFACE | NvAPI_Stereo_GetSeparation (StereoHandle stereoHandle, float *pSeparationPercentage)
NVAPI_INTERFACE | NvAPI_Stereo_SetSeparation (StereoHandle stereoHandle, float newSeparationPercentage)
NVAPI_INTERFACE | NvAPI_Stereo_GetConvergence (StereoHandle stereoHandle, float *pConvergence)
NVAPI_INTERFACE | NvAPI_Stereo_SetConvergence (StereoHandle stereoHandle, float newConvergence)
NVAPI_INTERFACE | NvAPI_Stereo_SetActiveEye (StereoHandle hStereoHandle, NV_STEREO_ACTIVE_EYE StereoEye)
NVAPI_INTERFACE | NvAPI_Stereo_SetDriverMode (NV_STEREO_DRIVER_MODE mode)
NVAPI_INTERFACE | NvAPI_Stereo_GetEyeSeparation (StereoHandle hStereoHandle, float *pSeparation)
NVAPI_INTERFACE | NvAPI_Stereo_IsWindowedModeSupported (NvU8 *bSupported)
NVAPI_INTERFACE | NvAPI_Stereo_SetSurfaceCreationMode (__in StereoHandle hStereoHandle, __in NVAPI_STEREO_SURFACECREATEMODE creationMode)
NVAPI_INTERFACE | NvAPI_Stereo_GetSurfaceCreationMode (__in StereoHandle hStereoHandle, __in NVAPI_STEREO_SURFACECREATEMODE *pCreationMode)
NVAPI_INTERFACE | NvAPI_Stereo_Debug_WasLastDrawStereoized (__in StereoHandle hStereoHandle, __out NvU8 *pWasStereoized)
NVAPI_INTERFACE | NvAPI_Stereo_SetDefaultProfile (__in const char *szProfileName)
NVAPI_INTERFACE | NvAPI_Stereo_GetDefaultProfile (__in NvU32 cbSizeIn, __out_bcount_part_opt(cbSizeIn, *pcbSizeOut) char *szProfileName, __out NvU32 *pcbSizeOut)

Detailed Description

These APIs control NVIDIA Stereoscopic 3D.

DESCRIPTION: This API allows an application to enable stereo viewing, without the need of a GUID/Key pair This API cannot be used to enable stereo viewing on 3DTV.

HOW TO USE: Call this function immediately after device creation, then follow with a reset.
Very generically: Create Device->Create Stereo Handle->InitActivation->Reset Device

SUPPORTED OS: Windows 7 and higher

Since
Release: 302
Parameters
[in] | stereoHandle | Stereo handle corresponding to the device interface.
[in] | bDelayed | Use delayed activation
Returns
This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.
Return values
NVAPI_STEREO_NOT_INITIALIZED - Stereo part of NVAPI not initialized.

Macro Definition Documentation

◆ NVAPI_STEREO_CAPS_VER

#define NVAPI_STEREO_CAPS_VER NVAPI_STEREO_CAPS_VER1

◆ NVAPI_STEREO_CAPS_VER1

#define NVAPI_STEREO_CAPS_VER1 MAKE_NVAPI_VERSION(NVAPI_STEREO_CAPS,1)

◆ NVAPI_STEREO_QUADBUFFERED_API_VERSION

#define NVAPI_STEREO_QUADBUFFERED_API_VERSION 0x2

Typedef Documentation

◆ NV_FRUSTUM_ADJUST_MODE

typedef enum _NV_FrustumAdjustMode NV_FRUSTUM_ADJUST_MODE

Used in NvAPI_Stereo_GetFrustumAdjustMode().

◆ NV_STEREO_ACTIVE_EYE

typedef enum _NV_StereoActiveEye NV_STEREO_ACTIVE_EYE

◆ NV_STEREO_DRIVER_MODE

typedef enum _NV_StereoDriverMode NV_STEREO_DRIVER_MODE

◆ NV_STEREO_REGISTRY_ID

typedef enum _NV_StereoRegistryID NV_STEREO_REGISTRY_ID

Used in NvAPI_Stereo_SetConfigurationProfileValue()

◆ NV_STEREO_REGISTRY_PROFILE_TYPE

typedef enum _NV_StereoRegistryProfileType NV_STEREO_REGISTRY_PROFILE_TYPE

Used in NvAPI_Stereo_CreateConfigurationProfileRegistryKey()

◆ NV_STEREO_SWAPCHAIN_MODE

typedef enum _NV_StereoSwapChainMode NV_STEREO_SWAPCHAIN_MODE

◆ NVAPI_STEREO_CAPS

typedef NVAPI_STEREO_CAPS_V1 NVAPI_STEREO_CAPS

◆ NVAPI_STEREO_CAPS_V1

typedef struct _NVAPI_STEREO_CAPS NVAPI_STEREO_CAPS_V1

◆ NVAPI_STEREO_INIT_ACTIVATION_FLAGS

typedef enum _NVAPI_STEREO_INIT_ACTIVATION_FLAGS NVAPI_STEREO_INIT_ACTIVATION_FLAGS

InitActivation Flags.

◆ NVAPI_STEREO_SURFACECREATEMODE

typedef enum _NVAPI_STEREO_SURFACECREATEMODE NVAPI_STEREO_SURFACECREATEMODE

\function NvAPI_Stereo_SetSurfaceCreationMode(StereoHandle hStereoHandle, NVAPI_STEREO_SURFACECREATEMODE creationMode)

Parameters
[in] | hStereoHandle | Stereo handle that corresponds to the device interface.
[in] | creationMode | New surface creation mode for this device interface.
Since
Release: 285

SUPPORTED OS: Windows 7 and higher

DESCRIPTION: This API sets surface creation mode for this device interface.

WHEN TO USE: After the stereo handle for device interface is created via successful call to appropriate NvAPI_Stereo_CreateHandleFrom function.

Returns
This API can return any of the error codes enumerated in NvAPI_Status. There are no return error codes with specific meaning for this API.

Enumeration Type Documentation

◆ _NV_FrustumAdjustMode

enum _NV_FrustumAdjustMode

Used in NvAPI_Stereo_GetFrustumAdjustMode().

Enumerator
NVAPI_NO_FRUSTUM_ADJUST | Do not adjust frustum.
NVAPI_FRUSTUM_STRETCH | Stretch images in X.
NVAPI_FRUSTUM_CLEAR_EDGES | Clear corresponding edges for each eye.

◆ _NV_StereoActiveEye

enum _NV_StereoActiveEye
Enumerator
NVAPI_STEREO_EYE_RIGHT
NVAPI_STEREO_EYE_LEFT
NVAPI_STEREO_EYE_MONO

◆ _NV_StereoDriverMode

enum _NV_StereoDriverMode
Enumerator
NVAPI_STEREO_DRIVER_MODE_AUTOMATIC
NVAPI_STEREO_DRIVER_MODE_DIRECT

◆ _NV_StereoRegistryID

enum _NV_StereoRegistryID

Used in NvAPI_Stereo_SetConfigurationProfileValue()

Enumerator
NVAPI_CONVERGENCE_ID | Symbolic constant for convergence registry ID.
NVAPI_FRUSTUM_ADJUST_MODE_ID | Symbolic constant for frustum adjust mode registry ID.

◆ _NV_StereoRegistryProfileType

enum _NV_StereoRegistryProfileType

Used in NvAPI_Stereo_CreateConfigurationProfileRegistryKey()

Enumerator
NVAPI_STEREO_DEFAULT_REGISTRY_PROFILE | Default registry configuration profile.
NVAPI_STEREO_DX9_REGISTRY_PROFILE | Separate registry configuration profile for a DirectX 9 executable.
NVAPI_STEREO_DX10_REGISTRY_PROFILE | Separate registry configuration profile for a DirectX 10 executable.

◆ _NV_StereoSwapChainMode

enum _NV_StereoSwapChainMode
Enumerator
NVAPI_STEREO_SWAPCHAIN_DEFAULT
NVAPI_STEREO_SWAPCHAIN_STEREO
NVAPI_STEREO_SWAPCHAIN_MONO

◆ _NVAPI_STEREO_INIT_ACTIVATION_FLAGS

enum _NVAPI_STEREO_INIT_ACTIVATION_FLAGS

InitActivation Flags.

Enumerator
NVAPI_STEREO_INIT_ACTIVATION_IMMEDIATE
NVAPI_STEREO_INIT_ACTIVATION_DELAYED

◆ _NVAPI_STEREO_SURFACECREATEMODE

enum _NVAPI_STEREO_SURFACECREATEMODE

\function NvAPI_Stereo_SetSurfaceCreationMode(StereoHandle hStereoHandle, NVAPI_STEREO_SURFACECREATEMODE creationMode)

Parameters
[in] | hStereoHandle | Stereo handle that corresponds to the device interface.
[in] | creationMode | New surface creation mode for this device interface.
Since
Release: 285

SUPPORTED OS: Windows 7 and higher

DESCRIPTION: This API sets surface creation mode for this device interface.

WHEN TO USE: After the stereo handle for device interface is created via successful call to appropriate NvAPI_Stereo_CreateHandleFrom function.

Returns
This API can return any of the error codes enumerated in NvAPI_Status. There are no return error codes with specific meaning for this API.
Enumerator
NVAPI_STEREO_SURFACECREATEMODE_AUTO | Use driver registry profile settings for surface creation mode.
NVAPI_STEREO_SURFACECREATEMODE_FORCESTEREO | Always create stereo surfaces.
NVAPI_STEREO_SURFACECREATEMODE_FORCEMONO | Always create mono surfaces.

Function Documentation

◆ NvAPI_D3D1x_CreateSwapChain()

NVAPI_INTERFACE NvAPI_D3D1x_CreateSwapChain | ( | StereoHandle | hStereoHandle,
 |  | DXGI_SWAP_CHAIN_DESC * | pDesc,
 |  | IDXGISwapChain ** | ppSwapChain,
 |  | NV_STEREO_SWAPCHAIN_MODE | mode
 | ) |  |

DESCRIPTION: This API allows the user to create a mono or a stereo swap chain.

     NOTE: NvAPI_D3D1x_CreateSwapChain is a wrapper of the method IDXGIFactory::CreateSwapChain which
           additionally notifies the D3D driver of the mode in which stereo mode the swap chain is to be
           created.
Since
Release: 285

SUPPORTED OS: Windows 7 and higher

Parameters
[in] | hStereoHandle | Stereo handle that corresponds to the device interface. A pointer to the device that will write 2D images to the swap chain.
[in] | pDesc | A pointer to the swap-chain description (DXGI_SWAP_CHAIN_DESC). This parameter cannot be NULL.
[out] | ppSwapChain | A pointer to the swap chain created.
[in] | mode | The stereo mode fot the swap chain. NVAPI_STEREO_SWAPCHAIN_DEFAULT NVAPI_STEREO_SWAPCHAIN_STEREO NVAPI_STEREO_SWAPCHAIN_MONO
Return values
NVAPI_OK | The swap chain was created successfully.
NVAPI_ERROR | The operation failed.

◆ NvAPI_D3D9_CreateSwapChain()

NVAPI_INTERFACE NvAPI_D3D9_CreateSwapChain | ( | StereoHandle | hStereoHandle,
 |  | D3DPRESENT_PARAMETERS * | pPresentationParameters,
 |  | IDirect3DSwapChain9 ** | ppSwapChain,
 |  | NV_STEREO_SWAPCHAIN_MODE | mode
 | ) |  |

DESCRIPTION: This API allows the user to create a mono or a stereo swap chain.

     NOTE: NvAPI_D3D9_CreateSwapChain is a wrapper of the method IDirect3DDevice9::CreateAdditionalSwapChain which
           additionally notifies the D3D driver if the swap chain creation mode must be stereo or mono.
Since
Release: 285

SUPPORTED OS: Windows 7 and higher

Parameters
[in] | hStereoHandle | Stereo handle that corresponds to the device interface.
[in,out] | pPresentationParameters | A pointer to the swap-chain description (DXGI). This parameter cannot be NULL.
[out] | ppSwapChain | A pointer to the swap chain created.
[in] | mode | The stereo mode for the swap chain. NVAPI_STEREO_SWAPCHAIN_DEFAULT NVAPI_STEREO_SWAPCHAIN_STEREO NVAPI_STEREO_SWAPCHAIN_MONO
Return values
NVAPI_OK | The swap chain creation was successful
NVAPI_ERROR | The operation failed.

◆ NvAPI_Stereo_Activate()

NVAPI_INTERFACE NvAPI_Stereo_Activate ( StereoHandle stereoHandle )

DESCRIPTION: This API activates stereo for the device interface corresponding to the given stereo handle. Activating stereo is possible only if stereo was enabled previously in the registry. If stereo is not activated, then calls to functions that require that stereo is activated have no effect, and will return the appropriate error code.

WHEN TO USE: After the stereo handle for the device interface is created via successfull call to the appropriate NvAPI_Stereo_CreateHandleFrom() function.

SUPPORTED OS: Windows 7 and higher

Since
Release: 180
Parameters
[in] stereoHandle Stereo handle corresponding to the device interface.
Return values
NVAPI_OK | Stereo is turned on.
NVAPI_STEREO_INVALID_DEVICE_INTERFACE | Device interface is not valid. Create again, then attach again.
NVAPI_API_NOT_INTIALIZED
NVAPI_STEREO_NOT_INITIALIZED | Stereo part of NVAPI not initialized.
NVAPI_ERROR

◆ NvAPI_Stereo_CaptureJpegImage()

NVAPI_INTERFACE NvAPI_Stereo_CaptureJpegImage | ( | StereoHandle | stereoHandle,
 |  | NvU32 | quality
 | ) |  |

DESCRIPTION: This API captures the current stereo image in JPEG stereo format with the given quality. Only the last capture call per flip will be effective.

WHEN TO USE: After the stereo handle for the device interface is created via successfull call to the appropriate NvAPI_Stereo_CreateHandleFrom() function.

SUPPORTED OS: Windows 7 and higher

Since
Release: 180
Parameters
[in] | stereoHandle | Stereo handle that corresponds to the device interface.
[in] | quality | Quality of the JPEG image to be captured. Integer value betweeen 0 and 100.
Return values
NVAPI_OK | Image captured.
NVAPI_STEREO_INVALID_DEVICE_INTERFACE | Device interface is not valid. Create again, then attach again.
NVAPI_API_NOT_INTIALIZED
NVAPI_STEREO_NOT_INITIALIZED
NVAPI_STEREO_PARAMETER_OUT_OF_RANGE | Given quality is out of [0..100] range.
NVAPI_ERROR

◆ NvAPI_Stereo_CapturePngImage()

NVAPI_INTERFACE NvAPI_Stereo_CapturePngImage ( StereoHandle stereoHandle )

DESCRIPTION: This API captures the current stereo image in PNG stereo format. Only the last capture call per flip will be effective.

WHEN TO USE: After the stereo handle for the device interface is created via successfull call to the appropriate NvAPI_Stereo_CreateHandleFrom() function.

SUPPORTED OS: Windows 7 and higher

Since
Release: 180
Parameters
[in] stereoHandle Stereo handle corresponding to the device interface.
Return values
NVAPI_OK | Image captured.
NVAPI_STEREO_INVALID_DEVICE_INTERFACE | Device interface is not valid. Create again, then attach again.
NVAPI_API_NOT_INTIALIZED
NVAPI_STEREO_NOT_INITIALIZED | Stereo part of NVAPI not initialized.
NVAPI_ERROR

◆ NvAPI_Stereo_CreateConfigurationProfileRegistryKey()

NVAPI_INTERFACE NvAPI_Stereo_CreateConfigurationProfileRegistryKey ( NV_STEREO_REGISTRY_PROFILE_TYPE registryProfileType )

◆ NvAPI_Stereo_CreateHandleFromIUnknown()

NVAPI_INTERFACE NvAPI_Stereo_CreateHandleFromIUnknown | ( | IUnknown * | pDevice,
 |  | StereoHandle * | pStereoHandle
 | ) |  |

DESCRIPTION: This API creates a stereo handle that is used in subsequent calls related to a given device interface. This must be called before any other NvAPI_Stereo_ function for that handle. Multiple devices can be used at one time using multiple calls to this function (one per each device).

HOW TO USE: After the Direct3D device is created, create the stereo handle. On call success:

  1. Use all other NvAPI_Stereo_ functions that have stereo handle as first parameter.
  2. After the device interface that corresponds to the the stereo handle is destroyed, the application should call NvAPI_DestroyStereoHandle() for that stereo handle.

WHEN TO USE: After the stereo handle for the device interface is created via successfull call to the appropriate NvAPI_Stereo_CreateHandleFrom() function.

SUPPORTED OS: Windows 7 and higher

Since
Release: 180
Parameters
[in] | pDevice | Pointer to IUnknown interface that is IDirect3DDevice9* in DX9, ID3D10Device*.
[out] | pStereoHandle | Pointer to the newly created stereo handle.
Return values
NVAPI_OK | Stereo handle is created for given device interface.
NVAPI_INVALID_ARGUMENT | Provided device interface is invalid.
NVAPI_API_NOT_INTIALIZED
NVAPI_STEREO_NOT_INITIALIZED | Stereo part of NVAPI not initialized.
NVAPI_ERROR

◆ NvAPI_Stereo_Deactivate()

NVAPI_INTERFACE NvAPI_Stereo_Deactivate ( StereoHandle stereoHandle )

DESCRIPTION: This API deactivates stereo for the given device interface. If stereo is not activated, then calls to functions that require that stereo is activated have no effect, and will return the appropriate error code.

WHEN TO USE: After the stereo handle for the device interface is created via successfull call to the appropriate NvAPI_Stereo_CreateHandleFrom() function.

SUPPORTED OS: Windows 7 and higher

Since
Release: 180
Parameters
[in] stereoHandle Stereo handle that corresponds to the device interface.
Return values
NVAPI_OK | Stereo is turned off.
NVAPI_STEREO_INVALID_DEVICE_INTERFACE | Device interface is not valid. Create again, then attach again.
NVAPI_API_NOT_INTIALIZED
NVAPI_STEREO_NOT_INITIALIZED | Stereo part of NVAPI not initialized.
NVAPI_ERROR

◆ NvAPI_Stereo_Debug_WasLastDrawStereoized()

NVAPI_INTERFACE NvAPI_Stereo_Debug_WasLastDrawStereoized | ( | __in StereoHandle | hStereoHandle,
 |  | __out NvU8 * | pWasStereoized
 | ) |  |
Parameters
[in] | hStereoHandle | Stereo handle that corresponds to the device interface.
[out] | pWasStereoized | Address where result of the inquiry will be placed.

SUPPORTED OS: Windows 7 and higher

DESCRIPTION: This API checks if the last draw call was stereoized. It is a very expensive to call and should be used for debugging purpose only.

WHEN TO USE: After the stereo handle for device interface is created via successful call to appropriate NvAPI_Stereo_CreateHandleFrom function.

Returns
This API can return any of the error codes enumerated in NvAPI_Status. There are no return error codes with specific meaning for this API.

◆ NvAPI_Stereo_DecreaseConvergence()

NVAPI_INTERFACE NvAPI_Stereo_DecreaseConvergence ( StereoHandle stereoHandle )

DESCRIPTION: This API decreases convergence for the given device interface (just like the Ctrl+F5 hotkey).

WHEN TO USE: After the stereo handle for the device interface is created via successfull call to the appropriate NvAPI_Stereo_CreateHandleFrom() function.

SUPPORTED OS: Windows 7 and higher

Since
Release: 180
Parameters
[in] stereoHandle Stereo handle that corresponds to the device interface.
Return values
NVAPI_OK | - Decrease of convergence was successfull.
NVAPI_STEREO_INVALID_DEVICE_INTERFACE | - Device interface is not valid. Create again, then attach again.
NVAPI_API_NOT_INTIALIZED | - NVAPI not initialized.
NVAPI_STEREO_NOT_INITIALIZED | - Stereo part of NVAPI not initialized.
NVAPI_ERROR | - Something is wrong (generic error).

◆ NvAPI_Stereo_DecreaseSeparation()

NVAPI_INTERFACE NvAPI_Stereo_DecreaseSeparation ( StereoHandle stereoHandle )

DESCRIPTION: This API decreases separation for the given device interface (just like the Ctrl+F3 hotkey).

WHEN TO USE: After the stereo handle for device interface is created via successfull call to the appropriate NvAPI_Stereo_CreateHandleFrom() function.

SUPPORTED OS: Windows 7 and higher

Since
Release: 180
Parameters
[in] stereoHandle Stereo handle that corresponds to the device interface.
Return values
NVAPI_OK | - Decrease of separation percentage was successfull.
NVAPI_STEREO_INVALID_DEVICE_INTERFACE | - Device interface is not valid. Create again, then attach again.
NVAPI_API_NOT_INTIALIZED | - NVAPI not initialized.
NVAPI_STEREO_NOT_INITIALIZED | - Stereo part of NVAPI not initialized.
NVAPI_ERROR | - Something is wrong (generic error).

◆ NvAPI_Stereo_DeleteConfigurationProfileRegistryKey()

NVAPI_INTERFACE NvAPI_Stereo_DeleteConfigurationProfileRegistryKey ( NV_STEREO_REGISTRY_PROFILE_TYPE registryProfileType )

DESCRIPTION: Removes configuration registry key for current application.

           If an application already has a configuration profile prior to this function call,
           the function attempts to remove the application's configuration profile registry key from the registry.
           If there is no configuration profile registry key prior to the function call,
           the function does nothing and does not report an error.

SUPPORTED OS: Windows 7 and higher

Since
Release: 180
Parameters
[in] registryProfileType Type of profile that the application wants to delete. This should be one of the symbolic constants defined in NV_STEREO_REGISTRY_PROFILE_TYPE. Any other value will cause the function to do nothing and return ::NV_STEREO_REGISTRY_PROFILE_TYPE_NOT_SUPPORTED.
Return values
NVAPI_OK | Key does not exist in the registry any more.
NVAPI_STEREO_REGISTRY_PROFILE_TYPE_NOT_SUPPORTED | This profile type is not supported.
NVAPI_STEREO_REGISTRY_ACCESS_FAILED | Access to registry failed.
NVAPI_API_NOT_INTIALIZED | NVAPI is not initialized.
NVAPI_STEREO_NOT_INITIALIZED | Stereo part of NVAPI is not initialized.
NVAPI_ERROR

◆ NvAPI_Stereo_DeleteConfigurationProfileValue()

NVAPI_INTERFACE NvAPI_Stereo_DeleteConfigurationProfileValue | ( | NV_STEREO_REGISTRY_PROFILE_TYPE | registryProfileType,
 |  | NV_STEREO_REGISTRY_ID | valueRegistryID
 | ) |  |

DESCRIPTION: This API removes the given value from the application's configuration profile registry key. If there is no such value, the function does nothing and does not report an error.

SUPPORTED OS: Windows 7 and higher

Since
Release: 180
Parameters
[in] | registryProfileType | The type of profile the application wants to access. It should be one of the symbolic constants defined in NV_STEREO_REGISTRY_PROFILE_TYPE. Any other value will cause function to do nothing and return ::NV_STEREO_REGISTRY_PROFILE_TYPE_NOT_SUPPORTED.
[in] | valueRegistryID | ID of the value that is being deleted. It should be one of the symbolic constants defined in NV_STEREO_REGISTRY_PROFILE_TYPE. Any other value will cause function to do nothing and return NVAPI_STEREO_REGISTRY_VALUE_NOT_SUPPORTED.
Return values
NVAPI_OK | Value does not exist in registry any more.
NVAPI_STEREO_REGISTRY_PROFILE_TYPE_NOT_SUPPORTED | This profile type is not supported.
NVAPI_STEREO_REGISTRY_VALUE_NOT_SUPPORTED | This value is not supported.
NVAPI_STEREO_REGISTRY_ACCESS_FAILED | Access to registry failed.
NVAPI_API_NOT_INTIALIZED
NVAPI_STEREO_NOT_INITIALIZED | Stereo part of NVAPI not initialized.
NVAPI_ERROR

◆ NvAPI_Stereo_DestroyHandle()

NVAPI_INTERFACE NvAPI_Stereo_DestroyHandle ( StereoHandle stereoHandle )

DESCRIPTION: This API destroys the stereo handle created with one of the NvAPI_Stereo_CreateHandleFrom() functions. This should be called after the device corresponding to the handle has been destroyed.

SUPPORTED OS: Windows 7 and higher

Since
Release: 180
Parameters
[in] stereoHandle Stereo handle that is to be destroyed.
Return values
NVAPI_OK | Stereo handle is destroyed.
NVAPI_API_NOT_INTIALIZED
NVAPI_STEREO_NOT_INITIALIZED | Stereo part of NVAPI not initialized.
NVAPI_ERROR

◆ NvAPI_Stereo_Disable()

NVAPI_INTERFACE NvAPI_Stereo_Disable ( void )

DESCRIPTION: This API disables stereo mode in the registry. Calls to this function affect the entire system. If stereo is not enabled, then calls to functions that require that stereo is enabled have no effect, and will return the appropriate error code.

SUPPORTED OS: Windows 7 and higher

Since
Release: 180
Return values
NVAPI_OK | Stereo is now disabled.
NVAPI_API_NOT_INTIALIZED
NVAPI_STEREO_NOT_INITIALIZED | Stereo part of NVAPI not initialized.
NVAPI_ERROR

◆ NvAPI_Stereo_Enable()

NVAPI_INTERFACE NvAPI_Stereo_Enable ( void )

DESCRIPTION: This APU enables stereo mode in the registry. Calls to this function affect the entire system. If stereo is not enabled, then calls to functions that require that stereo is enabled have no effect, and will return the appropriate error code.

SUPPORTED OS: Windows 7 and higher

Since
Release: 180
Return values
NVAPI_OK | Stereo is now enabled.
NVAPI_API_NOT_INTIALIZED
NVAPI_STEREO_NOT_INITIALIZED | Stereo part of NVAPI not initialized.
NVAPI_ERROR

◆ NvAPI_Stereo_GetConvergence()

NVAPI_INTERFACE NvAPI_Stereo_GetConvergence | ( | StereoHandle | stereoHandle,
 |  | float * | pConvergence
 | ) |  |

DESCRIPTION: This API gets the current convergence value.

WHEN TO USE: After the stereo handle for the device interface is created via successfull call to the appropriate NvAPI_Stereo_CreateHandleFrom() function.

SUPPORTED OS: Windows 7 and higher

Since
Release: 180
Parameters
[in] | stereoHandle | Stereo handle that corresponds to the device interface.
[out] | pConvergence | Address of float type variable to store current convergence value in.
Return values
NVAPI_OK | Retrieval of convergence value was successfull.
NVAPI_STEREO_INVALID_DEVICE_INTERFACE | Device interface is not valid. Create again, then attach again.
NVAPI_API_NOT_INTIALIZED
NVAPI_STEREO_NOT_INITIALIZED | Stereo part of NVAPI not initialized.
NVAPI_ERROR

◆ NvAPI_Stereo_GetDefaultProfile()

NVAPI_INTERFACE NvAPI_Stereo_GetDefaultProfile | ( | __in NvU32 | cbSizeIn,
 |  | __out_bcount_part_opt(cbSizeIn, *pcbSizeOut) char * | szProfileName,
 |  | __out NvU32 * | pcbSizeOut
 | ) |  |

SUPPORTED OS: Windows 7 and higher

DESCRIPTION: This API retrieves the current default stereo profile.

         After call cbSizeOut contain 0 if default profile is not set required buffer size cbSizeOut.
         To get needed buffer size this function can be called with szProfileName==0 and cbSizeIn == 0.

WHEN TO USE: This API can be called at any time.

Parameters
[in] cbSizeIn Size of buffer allocated for default stereo profile name.
[out] | szProfileName | Default stereo profile name.
[out] | pcbSizeOut | Required buffer size.

==0 - there is no default stereo profile name currently set

!=0 - size of buffer required for currently set default stereo profile name including trailing '0'.

Returns
This API can return any of the error codes enumerated in NvAPI_Status. Error codes specific to this API are described below.
Return values
NVAPI_SUCCESS | - Default stereo profile name has been copied into szProfileName.
NVAPI_DEFAULT_STEREO_PROFILE_IS_NOT_DEFINED | - There is no default stereo profile set at this time.
NVAPI_INVALID_ARGUMENT | - pcbSizeOut == 0 or cbSizeIn >= *pcbSizeOut && szProfileName == 0
NVAPI_INSUFFICIENT_BUFFER | - cbSizeIn < *pcbSizeOut

◆ NvAPI_Stereo_GetEyeSeparation()

NVAPI_INTERFACE NvAPI_Stereo_GetEyeSeparation | ( | StereoHandle | hStereoHandle,
 |  | float * | pSeparation
 | ) |  |

DESCRIPTION: This API returns eye separation as a ratio of <between eye distance>/<physical screen width>.

HOW TO USE: After the stereo handle for device interface is created via successfull call to appropriate API. Applies only to DirectX 9 and up.

SUPPORTED OS: Windows 7 and higher

Parameters
[in] | stereoHandle | Stereo handle that corresponds to the device interface.
[out] | pSeparation | Eye separation.
Return values
NVAPI_OK | Active eye is set.
NVAPI_STEREO_INVALID_DEVICE_INTERFACE | Device interface is not valid. Create again, then attach again.
NVAPI_API_NOT_INTIALIZED | NVAPI not initialized.
NVAPI_STEREO_NOT_INITIALIZED | Stereo part of NVAPI not initialized.
NVAPI_ERROR | (generic error).

◆ NvAPI_Stereo_GetFrustumAdjustMode()

NVAPI_INTERFACE NvAPI_Stereo_GetFrustumAdjustMode | ( | StereoHandle | stereoHandle,
 |  | NV_FRUSTUM_ADJUST_MODE * | pFrustumAdjustMode
 | ) |  |

◆ NvAPI_Stereo_GetSeparation()

NVAPI_INTERFACE NvAPI_Stereo_GetSeparation | ( | StereoHandle | stereoHandle,
 |  | float * | pSeparationPercentage
 | ) |  |

DESCRIPTION: This API gets current separation value (in percents).

WHEN TO USE: After the stereo handle for the device interface is created via successfull call to the appropriate NvAPI_Stereo_CreateHandleFrom() function.

SUPPORTED OS: Windows 7 and higher

Since
Release: 180
Parameters
[in] | stereoHandle | Stereo handle that corresponds to the device interface.
[out] | pSeparationPercentage | Address of float type variable to store current separation percentage in.
Return values
NVAPI_OK | Retrieval of separation percentage was successfull.
NVAPI_STEREO_INVALID_DEVICE_INTERFACE | Device interface is not valid. Create again, then attach again.
NVAPI_API_NOT_INTIALIZED
NVAPI_STEREO_NOT_INITIALIZED | Stereo part of NVAPI not initialized.
NVAPI_ERROR

◆ NvAPI_Stereo_GetStereoSupport()

NVAPI_INTERFACE NvAPI_Stereo_GetStereoSupport | ( | __in NvMonitorHandle | hMonitor,
 |  | __out NVAPI_STEREO_CAPS * | pCaps
 | ) |  |

DESCRIPTION: This API checks what kind of stereo support is currently supported on a particular display. If the the display is prohibited from showing stereo (e.g. secondary in a multi-mon setup), we will return 0 for all stereo modes (full screen exclusive, automatic windowed, persistent windowed). Otherwise, we will check which stereo mode is supported. On 120Hz display, this will be what the user chooses in control panel. On HDMI 1.4 display, persistent windowed mode is always assumed to be supported. Note that this function does not check if the CURRENT RESOLUTION/REFRESH RATE can support stereo. For HDMI 1.4, it is the app's responsibility to change the resolution/refresh rate to one that is 3D compatible. For 120Hz, the driver will ALWAYS force 120Hz anyway.

SUPPORTED OS: Windows 7 and higher

Since
Release: 304
Parameters
[in] | hMonitor | handle to monitor that app is going to run on
[out] | pCaps | Address where the result of the inquiry will be placed. *pCaps is defined in NVAPI_STEREO_CAPS.
Returns
This API can return any of the following error codes enumerated in NvAPI_Status
Return values
NVAPI_OK

◆ NvAPI_Stereo_GetSurfaceCreationMode()

NVAPI_INTERFACE NvAPI_Stereo_GetSurfaceCreationMode | ( | __in StereoHandle | hStereoHandle,
 |  | __in NVAPI_STEREO_SURFACECREATEMODE * | pCreationMode
 | ) |  |

\function NvAPI_Stereo_GetSurfaceCreationMode(StereoHandle hStereoHandle, NVAPI_STEREO_SURFACECREATEMODE* pCreationMode)

Parameters
[in] | hStereoHandle | Stereo handle that corresponds to the device interface.
[out] | pCreationMode | The current creation mode for this device interface.
Since
Release: 295

SUPPORTED OS: Windows 7 and higher

DESCRIPTION: This API gets surface creation mode for this device interface.

WHEN TO USE: After the stereo handle for device interface is created via successful call to appropriate NvAPI_Stereo_CreateHandleFrom function.

Returns
This API can return any of the error codes enumerated in NvAPI_Status. There are no return error codes with specific meaning for this API.

◆ NvAPI_Stereo_IncreaseConvergence()

NVAPI_INTERFACE NvAPI_Stereo_IncreaseConvergence ( StereoHandle stereoHandle )

DESCRIPTION: This API increases convergence for given the device interface (just like the Ctrl+F5 hotkey).

WHEN TO USE: After the stereo handle for the device interface is created via successfull call to the appropriate NvAPI_Stereo_CreateHandleFrom() function.

SUPPORTED OS: Windows 7 and higher

Since
Release: 180
Parameters
[in] stereoHandle Stereo handle that corresponds to the device interface.
Return values
NVAPI_OK | Increase of convergence was successfull.
NVAPI_STEREO_INVALID_DEVICE_INTERFACE | Device interface is not valid. Create again, then attach again.
NVAPI_API_NOT_INTIALIZED
NVAPI_STEREO_NOT_INITIALIZED | Stereo part of NVAPI not initialized.
NVAPI_ERROR

◆ NvAPI_Stereo_IncreaseSeparation()

NVAPI_INTERFACE NvAPI_Stereo_IncreaseSeparation ( StereoHandle stereoHandle )

DESCRIPTION: This API increases separation for the given device interface (just like the Ctrl+F4 hotkey).

WHEN TO USE: After the stereo handle for the device interface is created via successfull call to the appropriate NvAPI_Stereo_CreateHandleFrom() function.

SUPPORTED OS: Windows 7 and higher

Since
Release: 180
Parameters
[in] stereoHandle Stereo handle that corresponds to the device interface.
Return values
NVAPI_OK | Increase of separation percentage was successfull.
NVAPI_STEREO_INVALID_DEVICE_INTERFACE | Device interface is not valid. Create again, then attach again.
NVAPI_API_NOT_INTIALIZED | NVAPI not initialized.
NVAPI_STEREO_NOT_INITIALIZED | Stereo part of NVAPI not initialized.
NVAPI_ERROR | Something is wrong (generic error).

◆ NvAPI_Stereo_InitActivation()

NVAPI_INTERFACE NvAPI_Stereo_InitActivation | ( | __in StereoHandle | hStereoHandle,
 |  | __in NVAPI_STEREO_INIT_ACTIVATION_FLAGS | flags
 | ) |  |

◆ NvAPI_Stereo_IsActivated()

NVAPI_INTERFACE NvAPI_Stereo_IsActivated | ( | StereoHandle | stereoHandle,
 |  | NvU8 * | pIsStereoOn
 | ) |  |

DESCRIPTION: This API checks if stereo is activated for the given device interface.

WHEN TO USE: After the stereo handle for the device interface is created via successfull call to the appropriate NvAPI_Stereo_CreateHandleFrom() function.

SUPPORTED OS: Windows 7 and higher

Since
Release: 180
Parameters
[in] | stereoHandle | Stereo handle that corresponds to the device interface.
[in] | pIsStereoOn | Address where result of the inquiry will be placed.
Return values
NVAPI_OK | - Check was sucessfully completed and result reflects current state of stereo (on/off).
NVAPI_STEREO_INVALID_DEVICE_INTERFACE | - Device interface is not valid. Create again, then attach again.
NVAPI_API_NOT_INTIALIZED | - NVAPI not initialized.
NVAPI_STEREO_NOT_INITIALIZED | - Stereo part of NVAPI not initialized.
NVAPI_ERROR | - Something is wrong (generic error).

◆ NvAPI_Stereo_IsEnabled()

NVAPI_INTERFACE NvAPI_Stereo_IsEnabled ( NvU8 * pIsStereoEnabled )

DESCRIPTION: This API checks if stereo mode is enabled in the registry.

SUPPORTED OS: Windows 7 and higher

Since
Release: 180
Parameters
[out] pIsStereoEnabled Address where the result of the inquiry will be placed.
Return values
NVAPI_OK | Check was sucessfully completed and result reflects current state of stereo availability.
NVAPI_API_NOT_INTIALIZED
NVAPI_STEREO_NOT_INITIALIZED | Stereo part of NVAPI not initialized.
NVAPI_ERROR

◆ NvAPI_Stereo_IsWindowedModeSupported()

NVAPI_INTERFACE NvAPI_Stereo_IsWindowedModeSupported ( NvU8 * bSupported )

DESCRIPTION: This API returns availability of windowed mode stereo

SUPPORTED OS: Windows 7 and higher

Parameters
[out] bSupported(OUT) != 0 - supported,
== 0 - is not supported
Return values
NVAPI_OK | Retrieval of frustum adjust mode was successfull.
NVAPI_API_NOT_INTIALIZED | NVAPI not initialized.
NVAPI_STEREO_NOT_INITIALIZED | Stereo part of NVAPI not initialized.
NVAPI_ERROR | Something is wrong (generic error).

◆ NvAPI_Stereo_ReverseStereoBlitControl()

NVAPI_INTERFACE NvAPI_Stereo_ReverseStereoBlitControl | ( | StereoHandle | hStereoHandle,
 |  | NvU8 | TurnOn
 | ) |  |

DESCRIPTION: This API turns on/off reverse stereo blit.

HOW TO USE: Use after the stereo handle for the device interface is created via successfull call to the appropriate NvAPI_Stereo_CreateHandleFrom() function. After reversed stereo blit control is turned on, blits from the stereo surface will produce the right-eye image in the left side of the destination surface and the left-eye image in the right side of the destination surface.

In DirectX 9, the destination surface must be created as the render target, and StretchRect must be used. Conditions:

  • DstWidth == 2*SrcWidth
  • DstHeight == SrcHeight
  • Src surface is the stereo surface.
  • SrcRect must be {0,0,SrcWidth,SrcHeight}
  • DstRect must be {0,0,DstWidth,DstHeight}

In DirectX 10, ResourceCopyRegion must be used. Conditions:

  • DstWidth == 2*SrcWidth
  • DstHeight == SrcHeight
  • dstX == 0,
  • dstY == 0,
  • dstZ == 0,
  • SrcBox: left=top=front==0; right==SrcWidth; bottom==SrcHeight; back==1;

SUPPORTED OS: Windows 7 and higher

Since
Release: 185
Parameters
[in] stereoHandle Stereo handle corresponding to the device interface.
[in] TurnOn != 0 : Turns on
== 0 : Turns off
Return values
NVAPI_OK | Retrieval of frustum adjust mode was successfull.
NVAPI_STEREO_INVALID_DEVICE_INTERFACE | Device interface is not valid. Create again, then attach again.
NVAPI_API_NOT_INTIALIZED
NVAPI_STEREO_NOT_INITIALIZED | Stereo part of NVAPI not initialized.
NVAPI_ERROR

◆ NvAPI_Stereo_SetActiveEye()

NvAPI_Stereo_SetActiveEye | ( | StereoHandle | hStereoHandle,
 |  | NV_STEREO_ACTIVE_EYE | StereoEye
 | ) |  |

DESCRIPTION: This API sets the back buffer to left or right in Direct stereo mode.

HOW TO USE: After the stereo handle for device interface is created via successfull call to appropriate NvAPI_Stereo_CreateHandleFrom function.

Since
Release: 285

SUPPORTED OS: Windows 7 and higher

Parameters
[in] | stereoHandle | Stereo handle that corresponds to the device interface.
[in] | StereoEye | Defines active eye in Direct stereo mode
Return values
NVAPI_OK | - Active eye is set.
NVAPI_STEREO_INVALID_DEVICE_INTERFACE | - Device interface is not valid. Create again, then attach again.
NVAPI_API_NOT_INTIALIZED | - NVAPI not initialized.
NVAPI_STEREO_NOT_INITIALIZED | - Stereo part of NVAPI not initialized.
NVAPI_INVALID_ARGUMENT | - StereoEye parameter has not allowed value.
NVAPI_SET_NOT_ALLOWED | - Current stereo mode is not Direct
NVAPI_ERROR | - Something is wrong (generic error).

◆ NvAPI_Stereo_SetConfigurationProfileValue()

NVAPI_INTERFACE NvAPI_Stereo_SetConfigurationProfileValue | ( | NV_STEREO_REGISTRY_PROFILE_TYPE | registryProfileType,
 |  | NV_STEREO_REGISTRY_ID | valueRegistryID,
 |  | void * | pValue
 | ) |  |

◆ NvAPI_Stereo_SetConvergence()

NVAPI_INTERFACE NvAPI_Stereo_SetConvergence | ( | StereoHandle | stereoHandle,
 |  | float | newConvergence
 | ) |  |

DESCRIPTION: This API sets convergence to the given value.

WHEN TO USE: After the stereo handle for the device interface is created via successfull call to the appropriate NvAPI_Stereo_CreateHandleFrom() function.

SUPPORTED OS: Windows 7 and higher

Since
Release: 180
Parameters
[in] | stereoHandle | Stereo handle that corresponds to the device interface.
[in] | newConvergence | New value for convergence.
Return values
NVAPI_OK | Setting of convergence value was successfull.
NVAPI_STEREO_INVALID_DEVICE_INTERFACE | Device interface is not valid. Create again, then attach again.
NVAPI_API_NOT_INTIALIZED
NVAPI_STEREO_NOT_INITIALIZED | Stereo part of NVAPI not initialized.
NVAPI_ERROR

◆ NvAPI_Stereo_SetDefaultProfile()

NVAPI_INTERFACE NvAPI_Stereo_SetDefaultProfile ( __in const char * szProfileName )

SUPPORTED OS: Windows 7 and higher

DESCRIPTION: This API defines the stereo profile used by the driver in case the application has no associated profile.

WHEN TO USE: To take effect, this API must be called before D3D device is created. Calling once a device has been created will not affect the current device.

Parameters
[in] szProfileName Default profile name.
Returns
This API can return any of the error codes enumerated in NvAPI_Status. Error codes specific to this API are described below.
Return values
NVAPI_SUCCESS | - Default stereo profile name has been copied into szProfileName.
NVAPI_INVALID_ARGUMENT | - szProfileName == NULL.
NVAPI_DEFAULT_STEREO_PROFILE_DOES_NOT_EXIST | - Default stereo profile does not exist

◆ NvAPI_Stereo_SetDriverMode()

NvAPI_Stereo_SetDriverMode ( NV_STEREO_DRIVER_MODE mode )

DESCRIPTION: This API sets the 3D stereo driver mode: Direct or Automatic

HOW TO USE: This API must be called before the device is created. Applies to DirectX 9 and higher.

Since
Release: 285

SUPPORTED OS: Windows 7 and higher

Parameters
[in] mode Defines the 3D stereo driver mode: Direct or Automatic
Return values
NVAPI_OK | Active eye is set.
NVAPI_API_NOT_INTIALIZED | NVAPI not initialized.
NVAPI_STEREO_NOT_INITIALIZED | Stereo part of NVAPI not initialized.
NVAPI_INVALID_ARGUMENT | mode parameter has not allowed value.
NVAPI_ERROR | Something is wrong (generic error).

◆ NvAPI_Stereo_SetFrustumAdjustMode()

NVAPI_INTERFACE NvAPI_Stereo_SetFrustumAdjustMode | ( | StereoHandle | stereoHandle,
 |  | NV_FRUSTUM_ADJUST_MODE | newFrustumAdjustModeValue
 | ) |  |

DESCRIPTION: This API sets the current frustum adjust mode value.

WHEN TO USE: After the stereo handle for the device interface is created via successfull call to the appropriate NvAPI_Stereo_CreateHandleFrom() function.

SUPPORTED OS: Windows 7 and higher

Since
Release: 180
Parameters
[in] | stereoHandle | Stereo handle that corresponds to the device interface.
[in] | newFrustumAdjustModeValue | New value for frustum adjust mode. It should be one of the symbolic constants defined in NV_FRUSTUM_ADJUST_MODE. Any other value will cause function to do nothing and return NVAPI_STEREO_FRUSTUM_ADJUST_MODE_NOT_SUPPORTED.
Return values
NVAPI_OK | Retrieval of frustum adjust mode was successfull.
NVAPI_STEREO_INVALID_DEVICE_INTERFACE | Device interface is not valid. Create again, then attach again.
NVAPI_API_NOT_INTIALIZED
NVAPI_STEREO_NOT_INITIALIZED | Stereo part of NVAPI not initialized.
NVAPI_STEREO_FRUSTUM_ADJUST_MODE_NOT_SUPPORTED | Given frustum adjust mode is not supported.
NVAPI_ERROR

◆ NvAPI_Stereo_SetNotificationMessage()

NVAPI_INTERFACE NvAPI_Stereo_SetNotificationMessage | ( | StereoHandle | hStereoHandle,
 |  | NvU64 | hWnd,
 |  | NvU64 | messageID
 | ) |  |

DESCRIPTION: This API is a Setup notification message that the stereo driver uses to notify the application when the user changes the stereo driver state.

When the user changes the stereo state (Activated or Deactivated, separation or conversion) the stereo driver posts a defined message with the following parameters:

lParam is the current conversion. (Actual conversion is *(float*)&lParam )

wParam == MAKEWPARAM(l, h) where

  • l == 0 if stereo is deactivated
  • l == 1 if stereo is deactivated
  • h is the current separation. (Actual separation is float(h*100.f/0xFFFF)

Call this API with NULL hWnd to prohibit notification.

WHEN TO USE: Use after the stereo handle for device interface is created via successful call to appropriate NvAPI_Stereo_CreateHandleFrom() function.

SUPPORTED OS: Windows 7 and higher

Since
Release: 180
Parameters
[in] | stereoHandle | Stereo handle corresponding to the device interface.
[in] | hWnd | Window HWND that will be notified when the user changes the stereo driver state. Actual HWND must be cast to an NvU64.
[in] | messageID | MessageID of the message that will be posted to hWnd
Return values
NVAPI_OK | Notification set.
NVAPI_STEREO_INVALID_DEVICE_INTERFACE | Device interface is not valid. Create again, then attach again.
NVAPI_API_NOT_INTIALIZED
NVAPI_STEREO_NOT_INITIALIZED | Stereo part of NVAPI not initialized.
NVAPI_ERROR

◆ NvAPI_Stereo_SetSeparation()

NVAPI_INTERFACE NvAPI_Stereo_SetSeparation | ( | StereoHandle | stereoHandle,
 |  | float | newSeparationPercentage
 | ) |  |

DESCRIPTION: This API sets separation to given percentage.

WHEN TO USE: After the stereo handle for the device interface is created via successfull call to appropriate NvAPI_Stereo_CreateHandleFrom() function.

SUPPORTED OS: Windows 7 and higher

Since
Release: 180
Parameters
[in] | stereoHandle | Stereo handle that corresponds to the device interface.
[in] | newSeparationPercentage | New value for separation percentage.
Return values
NVAPI_OK | Setting of separation percentage was successfull.
NVAPI_STEREO_INVALID_DEVICE_INTERFACE | Device interface is not valid. Create again, then attach again.
NVAPI_API_NOT_INTIALIZED | NVAPI not initialized.
NVAPI_STEREO_NOT_INITIALIZED | Stereo part of NVAPI not initialized.
NVAPI_STEREO_PARAMETER_OUT_OF_RANGE | Given separation percentage is out of [0..100] range.
NVAPI_ERROR

◆ NvAPI_Stereo_SetSurfaceCreationMode()

NVAPI_INTERFACE NvAPI_Stereo_SetSurfaceCreationMode | ( | __in StereoHandle | hStereoHandle,
 |  | __in NVAPI_STEREO_SURFACECREATEMODE | creationMode
 | ) |  |

◆ NvAPI_Stereo_Trigger_Activation()

NVAPI_INTERFACE NvAPI_Stereo_Trigger_Activation ( __in StereoHandle hStereoHandle )

DESCRIPTION: This API allows an application to trigger creation of a stereo desktop, in case the creation was stopped on application launch.

SUPPORTED OS: Windows 7 and higher

Since
Release: 302
Parameters
[in] stereoHandle Stereo handle that corresponds to the device interface.
Returns
This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.
Return values
NVAPI_STEREO_INIT_ACTIVATION_NOT_DONE | - Stereo InitActivation not called.
NVAPI_STEREO_NOT_INITIALIZED | - Stereo part of NVAPI not initialized.


Data Fields
_NVAPI_STEREO_CAPS Struct Reference
Video APIs » Video Input/Output Interface » Stereoscopic 3D APIs

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 | supportsWindowedModeOff: 1
NvU32 | supportsWindowedModeAutomatic: 1
NvU32 | supportsWindowedModePersistent: 1
NvU32 | reserved: 29
NvU32 | reserved2 [3]
The documentation for this struct was generated from the following file:


Data Structures | Macros | Typedefs | Enumerations | Functions
Driver Settings (DRS) APIs
Video APIs » Video Input/Output Interface

Data Structures

struct | _NVDRS_GPU_SUPPORT
struct | _NVDRS_BINARY_SETTING
struct | _NVDRS_SETTING_VALUES
struct | _NVDRS_SETTING_V1
struct | _NVDRS_APPLICATION_V1
struct | _NVDRS_APPLICATION_V2
struct | _NVDRS_APPLICATION_V3
struct | _NVDRS_APPLICATION_V4
struct | _NVDRS_PROFILE_V1

Macros

#define | NVAPI_DRS_GLOBAL_PROFILE ((NvDRSProfileHandle) -1)
#define | NVAPI_SETTING_MAX_VALUES 100
#define | NVDRS_SETTING_VALUES_VER MAKE_NVAPI_VERSION(NVDRS_SETTING_VALUES,1)
#define | NVDRS_SETTING_VER1 MAKE_NVAPI_VERSION(NVDRS_SETTING_V1, 1)
#define | NVDRS_SETTING_VER NVDRS_SETTING_VER1
#define | NVDRS_APPLICATION_VER_V1 MAKE_NVAPI_VERSION(NVDRS_APPLICATION_V1,1)
#define | NVDRS_APPLICATION_VER_V2 MAKE_NVAPI_VERSION(NVDRS_APPLICATION_V2,2)
#define | NVDRS_APPLICATION_VER_V3 MAKE_NVAPI_VERSION(NVDRS_APPLICATION_V3,3)
#define | NVDRS_APPLICATION_VER_V4 MAKE_NVAPI_VERSION(NVDRS_APPLICATION_V4,4)
#define | NVDRS_APPLICATION_VER NVDRS_APPLICATION_VER_V4
#define | NVDRS_PROFILE_VER1 MAKE_NVAPI_VERSION(NVDRS_PROFILE_V1,1)
#define | NVDRS_PROFILE_VER NVDRS_PROFILE_VER1

Typedefs

typedef enum _NVDRS_SETTING_TYPE | NVDRS_SETTING_TYPE
typedef enum _NVDRS_SETTING_LOCATION | NVDRS_SETTING_LOCATION
typedef struct _NVDRS_GPU_SUPPORT | NVDRS_GPU_SUPPORT
typedef struct _NVDRS_BINARY_SETTING | NVDRS_BINARY_SETTING
typedef struct _NVDRS_SETTING_VALUES | NVDRS_SETTING_VALUES
typedef struct _NVDRS_SETTING_V1 | NVDRS_SETTING_V1
typedef NVDRS_SETTING_V1 | NVDRS_SETTING
typedef struct _NVDRS_APPLICATION_V1 | NVDRS_APPLICATION_V1
typedef struct _NVDRS_APPLICATION_V2 | NVDRS_APPLICATION_V2
typedef struct _NVDRS_APPLICATION_V3 | NVDRS_APPLICATION_V3
typedef struct _NVDRS_APPLICATION_V4 | NVDRS_APPLICATION_V4
typedef NVDRS_APPLICATION_V4 | NVDRS_APPLICATION
typedef struct _NVDRS_PROFILE_V1 | NVDRS_PROFILE_V1
typedef NVDRS_PROFILE_V1 | NVDRS_PROFILE

Enumerations

enum | _NVDRS_SETTING_TYPE { NVDRS_DWORD_TYPE , NVDRS_BINARY_TYPE , NVDRS_STRING_TYPE , NVDRS_WSTRING_TYPE }
enum | _NVDRS_SETTING_LOCATION { NVDRS_CURRENT_PROFILE_LOCATION , NVDRS_GLOBAL_PROFILE_LOCATION , NVDRS_BASE_PROFILE_LOCATION , NVDRS_DEFAULT_PROFILE_LOCATION }

Functions

NV_DECLARE_HANDLE (NvDRSSessionHandle)
NV_DECLARE_HANDLE (NvDRSProfileHandle)
NVAPI_INTERFACE | NvAPI_DRS_CreateSession (NvDRSSessionHandle *phSession)
NVAPI_INTERFACE | NvAPI_DRS_DestroySession (NvDRSSessionHandle hSession)
NVAPI_INTERFACE | NvAPI_DRS_LoadSettings (NvDRSSessionHandle hSession)
NVAPI_INTERFACE | NvAPI_DRS_SaveSettings (NvDRSSessionHandle hSession)
NVAPI_INTERFACE | NvAPI_DRS_LoadSettingsFromFile (NvDRSSessionHandle hSession, NvAPI_UnicodeString fileName)
NVAPI_INTERFACE | NvAPI_DRS_SaveSettingsToFile (NvDRSSessionHandle hSession, NvAPI_UnicodeString fileName)
NVAPI_INTERFACE | NvAPI_DRS_CreateProfile (NvDRSSessionHandle hSession, NVDRS_PROFILE *pProfileInfo, NvDRSProfileHandle *phProfile)
NVAPI_INTERFACE | NvAPI_DRS_DeleteProfile (NvDRSSessionHandle hSession, NvDRSProfileHandle hProfile)
NVAPI_INTERFACE | NvAPI_DRS_SetCurrentGlobalProfile (NvDRSSessionHandle hSession, NvAPI_UnicodeString wszGlobalProfileName)
NVAPI_INTERFACE | NvAPI_DRS_GetCurrentGlobalProfile (NvDRSSessionHandle hSession, NvDRSProfileHandle *phProfile)
NVAPI_INTERFACE | NvAPI_DRS_GetProfileInfo (NvDRSSessionHandle hSession, NvDRSProfileHandle hProfile, NVDRS_PROFILE *pProfileInfo)
NVAPI_INTERFACE | NvAPI_DRS_SetProfileInfo (NvDRSSessionHandle hSession, NvDRSProfileHandle hProfile, NVDRS_PROFILE *pProfileInfo)
NVAPI_INTERFACE | NvAPI_DRS_FindProfileByName (NvDRSSessionHandle hSession, NvAPI_UnicodeString profileName, NvDRSProfileHandle *phProfile)
NVAPI_INTERFACE | NvAPI_DRS_EnumProfiles (NvDRSSessionHandle hSession, NvU32 index, NvDRSProfileHandle *phProfile)
NVAPI_INTERFACE | NvAPI_DRS_GetNumProfiles (NvDRSSessionHandle hSession, NvU32 *numProfiles)
NVAPI_INTERFACE | NvAPI_DRS_CreateApplication (NvDRSSessionHandle hSession, NvDRSProfileHandle hProfile, NVDRS_APPLICATION *pApplication)
NVAPI_INTERFACE | NvAPI_DRS_DeleteApplicationEx (NvDRSSessionHandle hSession, NvDRSProfileHandle hProfile, NVDRS_APPLICATION *pApp)
NVAPI_INTERFACE | NvAPI_DRS_DeleteApplication (NvDRSSessionHandle hSession, NvDRSProfileHandle hProfile, NvAPI_UnicodeString appName)
NVAPI_INTERFACE | NvAPI_DRS_GetApplicationInfo (NvDRSSessionHandle hSession, NvDRSProfileHandle hProfile, NvAPI_UnicodeString appName, NVDRS_APPLICATION *pApplication)
NVAPI_INTERFACE | NvAPI_DRS_EnumApplications (NvDRSSessionHandle hSession, NvDRSProfileHandle hProfile, NvU32 startIndex, NvU32 *appCount, NVDRS_APPLICATION *pApplication)
NVAPI_INTERFACE | NvAPI_DRS_FindApplicationByName (__in NvDRSSessionHandle hSession, __in NvAPI_UnicodeString appName, __out NvDRSProfileHandle *phProfile, __inout NVDRS_APPLICATION *pApplication)
NVAPI_INTERFACE | NvAPI_DRS_SetSetting (NvDRSSessionHandle hSession, NvDRSProfileHandle hProfile, NVDRS_SETTING *pSetting)
NVAPI_INTERFACE | NvAPI_DRS_GetSetting (NvDRSSessionHandle hSession, NvDRSProfileHandle hProfile, NvU32 settingId, NVDRS_SETTING *pSetting)
NVAPI_INTERFACE | NvAPI_DRS_EnumSettings (NvDRSSessionHandle hSession, NvDRSProfileHandle hProfile, NvU32 startIndex, NvU32 *settingsCount, NVDRS_SETTING *pSetting)
NVAPI_INTERFACE | NvAPI_DRS_EnumAvailableSettingIds (NvU32 *pSettingIds, NvU32 *pMaxCount)
NVAPI_INTERFACE | NvAPI_DRS_EnumAvailableSettingValues (NvU32 settingId, NvU32 *pMaxNumValues, NVDRS_SETTING_VALUES *pSettingValues)
NVAPI_INTERFACE | NvAPI_DRS_GetSettingIdFromName (NvAPI_UnicodeString settingName, NvU32 *pSettingId)
NVAPI_INTERFACE | NvAPI_DRS_GetSettingNameFromId (NvU32 settingId, NvAPI_UnicodeString *pSettingName)
NVAPI_INTERFACE | NvAPI_DRS_DeleteProfileSetting (NvDRSSessionHandle hSession, NvDRSProfileHandle hProfile, NvU32 settingId)
NVAPI_INTERFACE | NvAPI_DRS_RestoreAllDefaults (NvDRSSessionHandle hSession)
NVAPI_INTERFACE | NvAPI_DRS_RestoreProfileDefault (NvDRSSessionHandle hSession, NvDRSProfileHandle hProfile)
NVAPI_INTERFACE | NvAPI_DRS_RestoreProfileDefaultSetting (NvDRSSessionHandle hSession, NvDRSProfileHandle hProfile, NvU32 settingId)
NVAPI_INTERFACE | NvAPI_DRS_GetBaseProfile (NvDRSSessionHandle hSession, NvDRSProfileHandle *phProfile)

Detailed Description

DRS, or DRiver Settings, is a new framework introduced in R256 that handles the storage, management, API layers, and related infrastructure of 3D settings, application profiles, and other settings.

Macro Definition Documentation

◆ NVAPI_DRS_GLOBAL_PROFILE

#define NVAPI_DRS_GLOBAL_PROFILE ((NvDRSProfileHandle) -1)

◆ NVAPI_SETTING_MAX_VALUES

#define NVAPI_SETTING_MAX_VALUES 100

◆ NVDRS_APPLICATION_VER

#define NVDRS_APPLICATION_VER NVDRS_APPLICATION_VER_V4

◆ NVDRS_APPLICATION_VER_V1

#define NVDRS_APPLICATION_VER_V1 MAKE_NVAPI_VERSION(NVDRS_APPLICATION_V1,1)

◆ NVDRS_APPLICATION_VER_V2

#define NVDRS_APPLICATION_VER_V2 MAKE_NVAPI_VERSION(NVDRS_APPLICATION_V2,2)

◆ NVDRS_APPLICATION_VER_V3

#define NVDRS_APPLICATION_VER_V3 MAKE_NVAPI_VERSION(NVDRS_APPLICATION_V3,3)

◆ NVDRS_APPLICATION_VER_V4

#define NVDRS_APPLICATION_VER_V4 MAKE_NVAPI_VERSION(NVDRS_APPLICATION_V4,4)

◆ NVDRS_PROFILE_VER

#define NVDRS_PROFILE_VER NVDRS_PROFILE_VER1

◆ NVDRS_PROFILE_VER1

#define NVDRS_PROFILE_VER1 MAKE_NVAPI_VERSION(NVDRS_PROFILE_V1,1)

Macro for constructing the version field of NVDRS_PROFILE.

◆ NVDRS_SETTING_VALUES_VER

#define NVDRS_SETTING_VALUES_VER MAKE_NVAPI_VERSION(NVDRS_SETTING_VALUES,1)

Macro for constructing the version field of _NVDRS_SETTING_VALUES.

◆ NVDRS_SETTING_VER

#define NVDRS_SETTING_VER NVDRS_SETTING_VER1

◆ NVDRS_SETTING_VER1

#define NVDRS_SETTING_VER1 MAKE_NVAPI_VERSION(NVDRS_SETTING_V1, 1)

Macro for constructing the version field of ::_NVDRS_SETTING.

Typedef Documentation

◆ NVDRS_APPLICATION

typedef NVDRS_APPLICATION_V4 NVDRS_APPLICATION

◆ NVDRS_APPLICATION_V1

typedef struct _NVDRS_APPLICATION_V1 NVDRS_APPLICATION_V1

◆ NVDRS_APPLICATION_V2

typedef struct _NVDRS_APPLICATION_V2 NVDRS_APPLICATION_V2

◆ NVDRS_APPLICATION_V3

typedef struct _NVDRS_APPLICATION_V3 NVDRS_APPLICATION_V3

◆ NVDRS_APPLICATION_V4

typedef struct _NVDRS_APPLICATION_V4 NVDRS_APPLICATION_V4

◆ NVDRS_BINARY_SETTING

typedef struct _NVDRS_BINARY_SETTING NVDRS_BINARY_SETTING

Enum to decide on the datatype of setting value.

◆ NVDRS_GPU_SUPPORT

typedef struct _NVDRS_GPU_SUPPORT NVDRS_GPU_SUPPORT

◆ NVDRS_PROFILE

typedef NVDRS_PROFILE_V1 NVDRS_PROFILE

◆ NVDRS_PROFILE_V1

typedef struct _NVDRS_PROFILE_V1 NVDRS_PROFILE_V1

◆ NVDRS_SETTING

typedef NVDRS_SETTING_V1 NVDRS_SETTING

◆ NVDRS_SETTING_LOCATION

typedef enum _NVDRS_SETTING_LOCATION NVDRS_SETTING_LOCATION

◆ NVDRS_SETTING_TYPE

typedef enum _NVDRS_SETTING_TYPE NVDRS_SETTING_TYPE

◆ NVDRS_SETTING_V1

typedef struct _NVDRS_SETTING_V1 NVDRS_SETTING_V1

◆ NVDRS_SETTING_VALUES

typedef struct _NVDRS_SETTING_VALUES NVDRS_SETTING_VALUES

Enumeration Type Documentation

◆ _NVDRS_SETTING_LOCATION

enum _NVDRS_SETTING_LOCATION
Enumerator
NVDRS_CURRENT_PROFILE_LOCATION
NVDRS_GLOBAL_PROFILE_LOCATION
NVDRS_BASE_PROFILE_LOCATION
NVDRS_DEFAULT_PROFILE_LOCATION

◆ _NVDRS_SETTING_TYPE

enum _NVDRS_SETTING_TYPE
Enumerator
NVDRS_DWORD_TYPE
NVDRS_BINARY_TYPE
NVDRS_STRING_TYPE
NVDRS_WSTRING_TYPE

Function Documentation

◆ NV_DECLARE_HANDLE() [1/2]

NV_DECLARE_HANDLE ( NvDRSProfileHandle )

◆ NV_DECLARE_HANDLE() [2/2]

NV_DECLARE_HANDLE ( NvDRSSessionHandle )

◆ NvAPI_DRS_CreateApplication()

NVAPI_INTERFACE NvAPI_DRS_CreateApplication | ( | NvDRSSessionHandle | hSession,
 |  | NvDRSProfileHandle | hProfile,
 |  | NVDRS_APPLICATION * | pApplication
 | ) |  |

DESCRIPTION: This API adds an executable name to a profile.

SUPPORTED OS: Windows 7 and higher

Parameters
[in] | hSession | Input to the session handle.
[in] | hProfile | Input profile handle.
[in] | *pApplication | Input NVDRS_APPLICATION struct with the executable name to be added.
Return values
NVAPI_OK | SUCCESS
NVAPI_ERROR | For miscellaneous errors.

◆ NvAPI_DRS_CreateProfile()

NVAPI_INTERFACE NvAPI_DRS_CreateProfile | ( | NvDRSSessionHandle | hSession,
 |  | NVDRS_PROFILE * | pProfileInfo,
 |  | NvDRSProfileHandle * | phProfile
 | ) |  |

DESCRIPTION: This API creates an empty profile.

SUPPORTED OS: Windows 7 and higher

Parameters
[in] | hSession | Input to the session handle.
[in] | *pProfileInfo | Input pointer to NVDRS_PROFILE.
[in] | *phProfile | Returns pointer to profile handle.
Return values
NVAPI_OK | SUCCESS
NVAPI_ERROR | For miscellaneous errors.

◆ NvAPI_DRS_CreateSession()

NVAPI_INTERFACE NvAPI_DRS_CreateSession ( NvDRSSessionHandle * phSession )

DESCRIPTION: This API allocates memory and initializes the session.

SUPPORTED OS: Windows 7 and higher

Parameters
[out] *phSession Return pointer to the session handle.
Return values
NVAPI_OK | SUCCESS
NVAPI_ERROR | For miscellaneous errors.

◆ NvAPI_DRS_DeleteApplication()

NVAPI_INTERFACE NvAPI_DRS_DeleteApplication | ( | NvDRSSessionHandle | hSession,
 |  | NvDRSProfileHandle | hProfile,
 |  | NvAPI_UnicodeString | appName
 | ) |  |

DESCRIPTION: This API removes an executable name from a profile.

SUPPORTED OS: Windows 7 and higher

Parameters
[in] | hSessionPARAMETERS | Input to the session handle.
[in] | hProfile | Input profile handle.
[in] | appName | Input the executable name to be removed.
Return values
NVAPI_OK | SUCCESS
NVAPI_ERROR | For miscellaneous errors.
NVAPI_EXECUTABLE_PATH_IS_AMBIGUOUS | If the path provided could refer to two different executables, this error will be returned

◆ NvAPI_DRS_DeleteApplicationEx()

NVAPI_INTERFACE NvAPI_DRS_DeleteApplicationEx | ( | NvDRSSessionHandle | hSession,
 |  | NvDRSProfileHandle | hProfile,
 |  | NVDRS_APPLICATION * | pApp
 | ) |  |

DESCRIPTION: This API removes an executable from a profile.

SUPPORTED OS: Windows 7 and higher

Parameters
[in] | hSession | - Input to the session handle.
[in] | hProfile | - Input profile handle.
[in] | *pApp | - Input all the information about the application to be removed.
Return values
NVAPI_OK | SUCCESS
NVAPI_ERROR | For miscellaneous errors.
NVAPI_EXECUTABLE_PATH_IS_AMBIGUOUS | If the path provided could refer to two different executables, this error will be returned.

◆ NvAPI_DRS_DeleteProfile()

NVAPI_INTERFACE NvAPI_DRS_DeleteProfile | ( | NvDRSSessionHandle | hSession,
 |  | NvDRSProfileHandle | hProfile
 | ) |  |

DESCRIPTION: This API deletes a profile or sets it back to a predefined value.

SUPPORTED OS: Windows 7 and higher

Parameters
[in] | hSession | Input to the session handle.
[in] | hProfile | Input profile handle.
Return values
NVAPI_OK | SUCCESS if the profile is found
NVAPI_ERROR | For miscellaneous errors.

◆ NvAPI_DRS_DeleteProfileSetting()

NVAPI_INTERFACE NvAPI_DRS_DeleteProfileSetting | ( | NvDRSSessionHandle | hSession,
 |  | NvDRSProfileHandle | hProfile,
 |  | NvU32 | settingId
 | ) |  |

DESCRIPTION: This API deletes a setting or sets it back to predefined value.

SUPPORTED OS: Windows 7 and higher

Parameters
[in] | hSession | Input to the session handle.
[in] | hProfile | Input profile handle.
[in] | settingId | Input settingId to be deleted.
Return values
NVAPI_OK | SUCCESS if the profile is found
NVAPI_ERROR | For miscellaneous errors.

◆ NvAPI_DRS_DestroySession()

NVAPI_INTERFACE NvAPI_DRS_DestroySession ( NvDRSSessionHandle hSession )

DESCRIPTION: This API frees the allocation: cleanup of NvDrsSession.

SUPPORTED OS: Windows 7 and higher

Parameters
[in] hSession Input to the session handle.
Return values
NVAPI_OK | SUCCESS
NVAPI_ERROR | For miscellaneous errors.

◆ NvAPI_DRS_EnumApplications()

NVAPI_INTERFACE NvAPI_DRS_EnumApplications | ( | NvDRSSessionHandle | hSession,
 |  | NvDRSProfileHandle | hProfile,
 |  | NvU32 | startIndex,
 |  | NvU32 * | appCount,
 |  | NVDRS_APPLICATION * | pApplication
 | ) |  |

DESCRIPTION: This API enumerates all the applications in a given profile from the starting index to the maximum length.

SUPPORTED OS: Windows 7 and higher

Parameters
[in] | hSession | Input to the session handle.
[in] | hProfile | Input profile handle.
[in] | startIndex | Indicates starting index for enumeration.
[in,out] | *appCount | Input maximum length of the passed in arrays. Returns the actual length.
[out] | *pApplication | Returns NVDRS_APPLICATION struct with all the attributes.
Return values
NVAPI_OK | SUCCESS
NVAPI_ERROR | For miscellaneous errors.
NVAPI_END_ENUMERATION | startIndex exceeds the total appCount.

◆ NvAPI_DRS_EnumAvailableSettingIds()

NVAPI_INTERFACE NvAPI_DRS_EnumAvailableSettingIds | ( | NvU32 * | pSettingIds,
 |  | NvU32 * | pMaxCount
 | ) |  |

DESCRIPTION: This API enumerates all the Ids of all the settings recognized by NVAPI.

SUPPORTED OS: Windows 7 and higher

Parameters
[out] | pSettingIds | User-provided array of length *pMaxCount that NVAPI will fill with IDs.
[in,out] | pMaxCount | Input max length of the passed in array, Returns the actual length.
Return values
NVAPI_OK | SUCCESS
NVAPI_ERROR | For miscellaneous errors. NVAPI_END_ENUMERATION: the provided pMaxCount is not enough to hold all settingIds.

◆ NvAPI_DRS_EnumAvailableSettingValues()

NVAPI_INTERFACE NvAPI_DRS_EnumAvailableSettingValues | ( | NvU32 | settingId,
 |  | NvU32 * | pMaxNumValues,
 |  | NVDRS_SETTING_VALUES * | pSettingValues
 | ) |  |

DESCRIPTION: This API enumerates all available setting values for a given setting.

SUPPORTED OS: Windows 7 and higher

Parameters
[in] | settingId | Input settingId.
[in,out] | pMaxNumValues | Input max length of the passed in arrays, Returns the actual length.
[out] | *pSettingValues | Returns all available setting values and its count.
Return values
NVAPI_OK | SUCCESS
NVAPI_ERROR | For miscellaneous errors.

◆ NvAPI_DRS_EnumProfiles()

NVAPI_INTERFACE NvAPI_DRS_EnumProfiles | ( | NvDRSSessionHandle | hSession,
 |  | NvU32 | index,
 |  | NvDRSProfileHandle * | phProfile
 | ) |  |

DESCRIPTION: This API enumerates through all the profiles in the session.

SUPPORTED OS: Windows 7 and higher

Parameters
[in] | hSession | Input to the session handle.
[in] | index | Input the index for enumeration.
[out] | *phProfile | Returns profile handle.

RETURN STATUS: NVAPI_OK: SUCCESS if the profile is found NVAPI_ERROR: For miscellaneous errors. NVAPI_END_ENUMERATION: index exceeds the total number of available Profiles in DB.

◆ NvAPI_DRS_EnumSettings()

NVAPI_INTERFACE NvAPI_DRS_EnumSettings | ( | NvDRSSessionHandle | hSession,
 |  | NvDRSProfileHandle | hProfile,
 |  | NvU32 | startIndex,
 |  | NvU32 * | settingsCount,
 |  | NVDRS_SETTING * | pSetting
 | ) |  |

DESCRIPTION: This API enumerates all the settings of a given profile from startIndex to the maximum length.

SUPPORTED OS: Windows 7 and higher

Parameters
[in] | hSession | Input to the session handle.
[in] | hProfile | Input profile handle.
[in] | startIndex | Indicates starting index for enumeration.
[in,out] | *settingsCount | Input max length of the passed in arrays, Returns the actual length.
[out] | *pSetting | Returns all the settings info.
Return values
NVAPI_OK | SUCCESS
NVAPI_ERROR | For miscellaneous errors.
NVAPI_END_ENUMERATION | startIndex exceeds the total appCount.

◆ NvAPI_DRS_FindApplicationByName()

NVAPI_INTERFACE NvAPI_DRS_FindApplicationByName | ( | __in NvDRSSessionHandle | hSession,
 |  | __in NvAPI_UnicodeString | appName,
 |  | __out NvDRSProfileHandle * | phProfile,
 |  | __inout NVDRS_APPLICATION * | pApplication
 | ) |  |

DESCRIPTION: This API searches the application and the associated profile for the given application name. If a fully qualified path is provided, this function will always return the profile the driver will apply upon running the application (on the path provided).

SUPPORTED OS: Windows 7 and higher

Parameters
[in] | hSession | Input to the hSession handle
[in] | appName | Input appName. For best results, provide a fully qualified path of the type c:/Folder1/Folder2/App.exe
[out] | *phProfile | Returns profile handle.
[in,out] | *pApplication | Returns NVDRS_APPLICATION struct pointer.
Returns
This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below:
Return values
::NVAPI_APPLICATION_NOT_FOUND | If App not found
NVAPI_EXECUTABLE_PATH_IS_AMBIGUOUS | If the input appName was not fully qualified, this error might return in the case of multiple matches

◆ NvAPI_DRS_FindProfileByName()

NVAPI_INTERFACE NvAPI_DRS_FindProfileByName | ( | NvDRSSessionHandle | hSession,
 |  | NvAPI_UnicodeString | profileName,
 |  | NvDRSProfileHandle * | phProfile
 | ) |  |

DESCRIPTION: This API finds a profile in the current session.

SUPPORTED OS: Windows 7 and higher

Parameters
[in] | hSession | Input to the session handle.
[in] | profileName | Input profileName.
[out] | phProfile | Input profile handle.
Return values
NVAPI_OK | SUCCESS if the profile is found
NVAPI_PROFILE_NOT_FOUND | if profile is not found
NVAPI_ERROR | For miscellaneous errors.

◆ NvAPI_DRS_GetApplicationInfo()

NVAPI_INTERFACE NvAPI_DRS_GetApplicationInfo | ( | NvDRSSessionHandle | hSession,
 |  | NvDRSProfileHandle | hProfile,
 |  | NvAPI_UnicodeString | appName,
 |  | NVDRS_APPLICATION * | pApplication
 | ) |  |

DESCRIPTION: This API gets information about the given application. The input application name must match exactly what the Profile has stored for the application. This function is better used to retrieve application information from a previous enumeration.

SUPPORTED OS: Windows 7 and higher

Parameters
[in] | hSession | Input to the session handle.
[in] | hProfile | Input profile handle.
[in] | appName | Input application name.
[out] | *pApplication | Returns NVDRS_APPLICATION struct with all the attributes.
Returns
This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.
Return values
NVAPI_EXECUTABLE_PATH_IS_AMBIGUOUS The application name could not
NVAPI_EXECUTABLE_NOT_FOUND No application with that name is found on the profile.

◆ NvAPI_DRS_GetBaseProfile()

NVAPI_INTERFACE NvAPI_DRS_GetBaseProfile | ( | NvDRSSessionHandle | hSession,
 |  | NvDRSProfileHandle * | phProfile
 | ) |  |

DESCRIPTION: Returns the handle to the current global profile.

SUPPORTED OS: Windows 7 and higher

Parameters
[in] | hSession | Input to the session handle.
[in] | *phProfile | Returns Base profile handle.
Return values
NVAPI_OK | SUCCESS if the profile is found
NVAPI_ERROR | For miscellaneous errors.

◆ NvAPI_DRS_GetCurrentGlobalProfile()

NVAPI_INTERFACE NvAPI_DRS_GetCurrentGlobalProfile | ( | NvDRSSessionHandle | hSession,
 |  | NvDRSProfileHandle * | phProfile
 | ) |  |

DESCRIPTION: This API returns the handle to the current global profile.

SUPPORTED OS: Windows 7 and higher

Parameters
[in] | hSession | Input to the session handle.
[out] | *phProfile | Returns current Global profile handle.
Return values
NVAPI_OK | SUCCESS
NVAPI_ERROR | For miscellaneous errors.

◆ NvAPI_DRS_GetNumProfiles()

NVAPI_INTERFACE NvAPI_DRS_GetNumProfiles | ( | NvDRSSessionHandle | hSession,
 |  | NvU32 * | numProfiles
 | ) |  |

DESCRIPTION: This API obtains the number of profiles in the current session object.

SUPPORTED OS: Windows 7 and higher

Parameters
[in] | hSession | Input to the session handle.
out] | *numProfiles Returns count of profiles in the current hSession.
Return values
NVAPI_OK | SUCCESS
NVAPI_API_NOT_INTIALIZED | Failed to initialize.
NVAPI_INVALID_ARGUMENT | Invalid Arguments.

◆ NvAPI_DRS_GetProfileInfo()

NVAPI_INTERFACE NvAPI_DRS_GetProfileInfo | ( | NvDRSSessionHandle | hSession,
 |  | NvDRSProfileHandle | hProfile,
 |  | NVDRS_PROFILE * | pProfileInfo
 | ) |  |

DESCRIPTION: This API gets information about the given profile. User needs to specify the name of the Profile.

SUPPORTED OS: Windows 7 and higher

Parameters
[in] | hSession | Input to the session handle.
[in] | hProfile | Input profile handle.
[out] | *pProfileInfo | Return the profile info.
Return values
NVAPI_OK | SUCCESS
NVAPI_ERROR | For miscellaneous errors.

◆ NvAPI_DRS_GetSetting()

NVAPI_INTERFACE NvAPI_DRS_GetSetting | ( | NvDRSSessionHandle | hSession,
 |  | NvDRSProfileHandle | hProfile,
 |  | NvU32 | settingId,
 |  | NVDRS_SETTING * | pSetting
 | ) |  |

DESCRIPTION: This API gets information about the given setting.

SUPPORTED OS: Windows 7 and higher

Parameters
[in] | hSession | Input to the session handle.
[in] | hProfile | Input profile handle.
[in] | settingId | Input settingId.
[out] | *pSetting | Returns all the setting info
Return values
NVAPI_OK | SUCCESS
NVAPI_ERROR | For miscellaneous errors.

◆ NvAPI_DRS_GetSettingIdFromName()

NVAPI_INTERFACE NvAPI_DRS_GetSettingIdFromName | ( | NvAPI_UnicodeString | settingName,
 |  | NvU32 * | pSettingId
 | ) |  |

DESCRIPTION: This API gets the binary ID of a setting given the setting name.

SUPPORTED OS: Windows 7 and higher

Parameters
[in] | settingName | Input Unicode settingName.
[out] | *pSettingId | Returns corresponding settingId.
Return values
NVAPI_OK | SUCCESS if the profile is found
NVAPI_PROFILE_NOT_FOUND | if profile is not found
NVAPI_SETTING_NOT_FOUND | if setting is not found
NVAPI_ERROR | For miscellaneous errors.

◆ NvAPI_DRS_GetSettingNameFromId()

NVAPI_INTERFACE NvAPI_DRS_GetSettingNameFromId | ( | NvU32 | settingId,
 |  | NvAPI_UnicodeString * | pSettingName
 | ) |  |

DESCRIPTION: This API gets the setting name given the binary ID.

SUPPORTED OS: Windows 7 and higher

Parameters
[in] | settingId | Input settingId.
[in] | *pSettingName | Returns corresponding Unicode settingName.
Return values
NVAPI_OK | SUCCESS if the profile is found
NVAPI_PROFILE_NOT_FOUND | if profile is not found
NVAPI_SETTING_NOT_FOUND | if setting is not found
NVAPI_ERROR | For miscellaneous errors.

◆ NvAPI_DRS_LoadSettings()

NVAPI_INTERFACE NvAPI_DRS_LoadSettings ( NvDRSSessionHandle hSession )

DESCRIPTION: This API loads and parses the settings data.

SUPPORTED OS: Windows 7 and higher

Parameters
[in] hSession Input to the session handle.
Return values
NVAPI_OK | SUCCESS
NVAPI_ERROR | For miscellaneous errors.

◆ NvAPI_DRS_LoadSettingsFromFile()

NVAPI_INTERFACE NvAPI_DRS_LoadSettingsFromFile | ( | NvDRSSessionHandle | hSession,
 |  | NvAPI_UnicodeString | fileName
 | ) |  |

DESCRIPTION: This API loads settings from the given file path.

SUPPORTED OS: Windows 7 and higher

Parameters
[in] | hSession | Input to the session handle
[in] | fileName | Binary File Name/Path
Return values
NVAPI_OK | SUCCESS
NVAPI_ERROR | For miscellaneous errors.

◆ NvAPI_DRS_RestoreAllDefaults()

NVAPI_INTERFACE NvAPI_DRS_RestoreAllDefaults ( NvDRSSessionHandle hSession )

DESCRIPTION: This API restores the whole system to predefined(default) values.

SUPPORTED OS: Windows 7 and higher

Parameters
[in] hSession Input to the session handle.
Return values
NVAPI_OK | SUCCESS if the profile is found
NVAPI_ERROR | For miscellaneous errors.

◆ NvAPI_DRS_RestoreProfileDefault()

NVAPI_INTERFACE NvAPI_DRS_RestoreProfileDefault | ( | NvDRSSessionHandle | hSession,
 |  | NvDRSProfileHandle | hProfile
 | ) |  |

DESCRIPTION: This API restores the given profile to predefined(default) values. Any and all user specified modifications will be removed. If the whole profile was set by the user, the profile will be removed.

SUPPORTED OS: Windows 7 and higher

Parameters
[in] | hSession | Input to the session handle.
[in] | hProfile | Input profile handle.
Return values
NVAPI_OK | SUCCESS if the profile is found
NVAPI_ERROR | For miscellaneous errors.
NVAPI_PROFILE_REMOVED | SUCCESS, and the hProfile is no longer valid.
NVAPI_ERROR | For miscellaneous errors.

◆ NvAPI_DRS_RestoreProfileDefaultSetting()

NVAPI_INTERFACE NvAPI_DRS_RestoreProfileDefaultSetting | ( | NvDRSSessionHandle | hSession,
 |  | NvDRSProfileHandle | hProfile,
 |  | NvU32 | settingId
 | ) |  |

DESCRIPTION: This API restores the given profile setting to predefined(default) values.

SUPPORTED OS: Windows 7 and higher

Parameters
[in] | hSession | Input to the session handle.
[in] | hProfile | Input profile handle.
[in] | settingId | Input settingId.
Return values
NVAPI_OK | SUCCESS if the profile is found
NVAPI_ERROR | For miscellaneous errors.

◆ NvAPI_DRS_SaveSettings()

NVAPI_INTERFACE NvAPI_DRS_SaveSettings ( NvDRSSessionHandle hSession )

DESCRIPTION: This API saves the settings data to the system.

SUPPORTED OS: Windows 7 and higher

Parameters
[in] hSession Input to the session handle.
Return values
NVAPI_OK | SUCCESS
NVAPI_ERROR | For miscellaneous errors.

◆ NvAPI_DRS_SaveSettingsToFile()

NVAPI_INTERFACE NvAPI_DRS_SaveSettingsToFile | ( | NvDRSSessionHandle | hSession,
 |  | NvAPI_UnicodeString | fileName
 | ) |  |

DESCRIPTION: This API saves settings to the given file path.

SUPPORTED OS: Windows 7 and higher

Parameters
[in] | hSession | Input to the session handle.
[in] | fileName | Binary File Name/Path
Return values
NVAPI_OK | SUCCESS
NVAPI_ERROR | For miscellaneous errors.

◆ NvAPI_DRS_SetCurrentGlobalProfile()

NVAPI_INTERFACE NvAPI_DRS_SetCurrentGlobalProfile | ( | NvDRSSessionHandle | hSession,
 |  | NvAPI_UnicodeString | wszGlobalProfileName
 | ) |  |

DESCRIPTION: This API sets the current global profile in the driver.

SUPPORTED OS: Windows 7 and higher

Parameters
[in] | hSession | Input to the session handle.
[in] | wszGlobalProfileName | Input current Global profile name.
Return values
NVAPI_OK | SUCCESS
NVAPI_ERROR | For miscellaneous errors.

◆ NvAPI_DRS_SetProfileInfo()

NVAPI_INTERFACE NvAPI_DRS_SetProfileInfo | ( | NvDRSSessionHandle | hSession,
 |  | NvDRSProfileHandle | hProfile,
 |  | NVDRS_PROFILE * | pProfileInfo
 | ) |  |

DESCRIPTION: Specifies flags for a given profile. Currently only the NVDRS_GPU_SUPPORT is used to update the profile. Neither the name, number of settings or applications or other profile information can be changed with this function.

SUPPORTED OS: Windows 7 and higher

Parameters
[in] | hSession | Input to the session handle.
[in] | hProfile | Input profile handle.
[in] | *pProfileInfo | Input the new profile info.
Return values
NVAPI_OK | SUCCESS
NVAPI_ERROR | For miscellaneous errors.

◆ NvAPI_DRS_SetSetting()

NVAPI_INTERFACE NvAPI_DRS_SetSetting | ( | NvDRSSessionHandle | hSession,
 |  | NvDRSProfileHandle | hProfile,
 |  | NVDRS_SETTING * | pSetting
 | ) |  |

DESCRIPTION: This API adds/modifies a setting to a profile.

SUPPORTED OS: Windows 7 and higher

Parameters
[in] | hSession | Input to the session handle.
[in] | hProfile | Input profile handle.
[in] | *pSetting | Input NVDRS_SETTING struct pointer.
Return values
NVAPI_OK | SUCCESS
NVAPI_ERROR | For miscellaneous errors.


Data Fields
_NVDRS_GPU_SUPPORT Struct Reference
Video APIs » Video Input/Output Interface » Driver Settings (DRS) APIs

#include <nvapi.h>

Data Fields

NvU32 | geforce: 1
NvU32 | quadro: 1
NvU32 | nvs: 1
NvU32 | reserved4: 1
NvU32 | reserved5: 1
NvU32 | reserved6: 1
NvU32 | reserved7: 1
NvU32 | reserved8: 1
NvU32 | reserved9: 1
NvU32 | reserved10: 1
NvU32 | reserved11: 1
NvU32 | reserved12: 1
NvU32 | reserved13: 1
NvU32 | reserved14: 1
NvU32 | reserved15: 1
NvU32 | reserved16: 1
NvU32 | reserved17: 1
NvU32 | reserved18: 1
NvU32 | reserved19: 1
NvU32 | reserved20: 1
NvU32 | reserved21: 1
NvU32 | reserved22: 1
NvU32 | reserved23: 1
NvU32 | reserved24: 1
NvU32 | reserved25: 1
NvU32 | reserved26: 1
NvU32 | reserved27: 1
NvU32 | reserved28: 1
NvU32 | reserved29: 1
NvU32 | reserved30: 1
NvU32 | reserved31: 1
NvU32 | reserved32: 1
The documentation for this struct was generated from the following file:


Data Fields
_NVDRS_BINARY_SETTING Struct Reference
Video APIs » Video Input/Output Interface » Driver Settings (DRS) APIs

#include <nvapi.h>

Data Fields

NvU32 valueLength
NvU8 valueData [NVAPI_BINARY_DATA_MAX]

Detailed Description

Enum to decide on the datatype of setting value.

The documentation for this struct was generated from the following file:


Data Fields
_NVDRS_SETTING_VALUES Struct Reference
Video APIs » Video Input/Output Interface » Driver Settings (DRS) APIs

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 numSettingValues
NVDRS_SETTING_TYPE settingType
union {
NvU32 _NVDRS_SETTING_VALUES::u32DefaultValue
NVDRS_BINARY_SETTING _NVDRS_SETTING_VALUES::binaryDefaultValue
NvAPI_UnicodeString _NVDRS_SETTING_VALUES::wszDefaultValue
};
union {
NvU32 _NVDRS_SETTING_VALUES::u32Value
NVDRS_BINARY_SETTING _NVDRS_SETTING_VALUES::binaryValue
NvAPI_UnicodeString _NVDRS_SETTING_VALUES::wszValue
} settingValues [NVAPI_SETTING_MAX_VALUES]
The documentation for this struct was generated from the following file:


Data Fields
_NVDRS_SETTING_V1 Struct Reference
Video APIs » Video Input/Output Interface » Driver Settings (DRS) APIs

#include <nvapi.h>

Data Fields

NvU32 version
NvAPI_UnicodeString settingName
NvU32 settingId
NVDRS_SETTING_TYPE settingType
NVDRS_SETTING_LOCATION settingLocation
NvU32 isCurrentPredefined
NvU32 isPredefinedValid
union {
NvU32 _NVDRS_SETTING_V1::u32PredefinedValue
NVDRS_BINARY_SETTING _NVDRS_SETTING_V1::binaryPredefinedValue
NvAPI_UnicodeString _NVDRS_SETTING_V1::wszPredefinedValue
};
union {
NvU32 _NVDRS_SETTING_V1::u32CurrentValue
NVDRS_BINARY_SETTING _NVDRS_SETTING_V1::binaryCurrentValue
NvAPI_UnicodeString _NVDRS_SETTING_V1::wszCurrentValue
};
The documentation for this struct was generated from the following file:


Data Fields
_NVDRS_APPLICATION_V1 Struct Reference
Video APIs » Video Input/Output Interface » Driver Settings (DRS) APIs

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 isPredefined
NvAPI_UnicodeString appName
NvAPI_UnicodeString userFriendlyName
NvAPI_UnicodeString launcher
The documentation for this struct was generated from the following file:


Data Fields
_NVDRS_APPLICATION_V2 Struct Reference
Video APIs » Video Input/Output Interface » Driver Settings (DRS) APIs

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 isPredefined
NvAPI_UnicodeString appName
NvAPI_UnicodeString userFriendlyName
NvAPI_UnicodeString launcher
NvAPI_UnicodeString fileInFolder
The documentation for this struct was generated from the following file:


Data Fields
_NVDRS_APPLICATION_V3 Struct Reference
Video APIs » Video Input/Output Interface » Driver Settings (DRS) APIs

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 isPredefined
NvAPI_UnicodeString appName
NvAPI_UnicodeString userFriendlyName
NvAPI_UnicodeString launcher
NvAPI_UnicodeString fileInFolder
NvU32 | isMetro:1
NvU32 | isCommandLine:1
NvU32 | reserved:30
The documentation for this struct was generated from the following file:


Data Fields
_NVDRS_APPLICATION_V4 Struct Reference
Video APIs » Video Input/Output Interface » Driver Settings (DRS) APIs

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 isPredefined
NvAPI_UnicodeString appName
NvAPI_UnicodeString userFriendlyName
NvAPI_UnicodeString launcher
NvAPI_UnicodeString fileInFolder
NvU32 | isMetro:1
NvU32 | isCommandLine:1
NvU32 | reserved:30
NvAPI_UnicodeString commandLine
The documentation for this struct was generated from the following file:


Data Fields
_NVDRS_PROFILE_V1 Struct Reference
Video APIs » Video Input/Output Interface » Driver Settings (DRS) APIs

#include <nvapi.h>

Data Fields

NvU32 version
NvAPI_UnicodeString profileName
NVDRS_GPU_SUPPORT gpuSupport
NvU32 isPredefined
NvU32 numOfApps
NvU32 numOfSettings
The documentation for this struct was generated from the following file:


Data Structures | Macros | Enumerations | Functions
System - General Interface <br>
System APIs | Video APIs » Video Input/Output Interface

Data Structures

struct | NV_CHIPSET_INFO_v4
struct | NV_CHIPSET_INFO_v3
struct | NV_CHIPSET_INFO_v2
struct | NV_CHIPSET_INFO_v1
struct | NV_LID_DOCK_PARAMS

Macros

#define | NV_CHIPSET_INFO_VER_1 MAKE_NVAPI_VERSION(NV_CHIPSET_INFO_v1,1)
#define | NV_CHIPSET_INFO_VER_2 MAKE_NVAPI_VERSION(NV_CHIPSET_INFO_v2,2)
#define | NV_CHIPSET_INFO_VER_3 MAKE_NVAPI_VERSION(NV_CHIPSET_INFO_v3,3)
#define | NV_CHIPSET_INFO_VER_4 MAKE_NVAPI_VERSION(NV_CHIPSET_INFO_v4,4)
#define | NV_CHIPSET_INFO NV_CHIPSET_INFO_v4
#define | NV_CHIPSET_INFO_VER NV_CHIPSET_INFO_VER_4

Enumerations

enum NV_CHIPSET_INFO_FLAGS { NV_CHIPSET_INFO_HYBRID = 0x00000001 }

Functions

NVAPI_INTERFACE | NvAPI_SYS_GetChipSetInfo (NV_CHIPSET_INFO *pChipSetInfo)
NVAPI_INTERFACE | NvAPI_SYS_GetLidAndDockInfo (NV_LID_DOCK_PARAMS *pLidAndDock)
NVAPI_INTERFACE | NvAPI_SYS_GetDisplayIdFromGpuAndOutputId (NvPhysicalGpuHandle hPhysicalGpu, NvU32 outputId, NvU32 *displayId)
NVAPI_INTERFACE | NvAPI_SYS_GetGpuAndOutputIdFromDisplayId (NvU32 displayId, NvPhysicalGpuHandle *hPhysicalGpu, NvU32 *outputId)
NVAPI_INTERFACE | NvAPI_SYS_GetPhysicalGpuFromDisplayId (NvU32 displayId, NvPhysicalGpuHandle *hPhysicalGpu)
NVAPI_INTERFACE | NvAPI_SYS_GetPhysicalGPUs (__inout NV_PHYSICAL_GPUS *pPhysicalGPUs)
NVAPI_INTERFACE | NvAPI_SYS_GetLogicalGPUs (__inout NV_LOGICAL_GPUS *pLogicalGPUs)

Detailed Description

The System APIs retrieve chipset information such as vendor/device name and IDs, and CPU information such as processor type, speed, embedded CPU name, etc.

Macro Definition Documentation

◆ NV_CHIPSET_INFO

#define NV_CHIPSET_INFO NV_CHIPSET_INFO_v4

◆ NV_CHIPSET_INFO_VER

#define NV_CHIPSET_INFO_VER NV_CHIPSET_INFO_VER_4

◆ NV_CHIPSET_INFO_VER_1

#define NV_CHIPSET_INFO_VER_1 MAKE_NVAPI_VERSION(NV_CHIPSET_INFO_v1,1)

◆ NV_CHIPSET_INFO_VER_2

#define NV_CHIPSET_INFO_VER_2 MAKE_NVAPI_VERSION(NV_CHIPSET_INFO_v2,2)

◆ NV_CHIPSET_INFO_VER_3

#define NV_CHIPSET_INFO_VER_3 MAKE_NVAPI_VERSION(NV_CHIPSET_INFO_v3,3)

◆ NV_CHIPSET_INFO_VER_4

#define NV_CHIPSET_INFO_VER_4 MAKE_NVAPI_VERSION(NV_CHIPSET_INFO_v4,4)

Enumeration Type Documentation

◆ NV_CHIPSET_INFO_FLAGS

enum NV_CHIPSET_INFO_FLAGS
Enumerator
NV_CHIPSET_INFO_HYBRID

Function Documentation

◆ NvAPI_SYS_GetChipSetInfo()

NVAPI_INTERFACE NvAPI_SYS_GetChipSetInfo ( NV_CHIPSET_INFO * pChipSetInfo )

This function returns information about the system's chipset.

SUPPORTED OS: Windows 7 and higher

Since
Release: 95
Return values
NVAPI_INVALID_ARGUMENT | pChipSetInfo is NULL.
NVAPI_OK | *pChipSetInfo is now set.
NVAPI_INCOMPATIBLE_STRUCT_VERSION | NV_CHIPSET_INFO version not compatible with driver.

◆ NvAPI_SYS_GetDisplayIdFromGpuAndOutputId()

NVAPI_INTERFACE NvAPI_SYS_GetDisplayIdFromGpuAndOutputId | ( | NvPhysicalGpuHandle | hPhysicalGpu,
 |  | NvU32 | outputId,
 |  | NvU32 * | displayId
 | ) |  |

DESCRIPTION: This API converts a Physical GPU handle and output ID to a display ID.

SUPPORTED OS: Windows 7 and higher

Parameters
[in] | hPhysicalGpu | Handle to the physical GPU
[in] | outputId | Connected display output ID on the target GPU - must only have one bit set
[out] | displayId | Pointer to an NvU32 which contains the display ID
Return values
NVAPI_OK | - completed request
NVAPI_API_NOT_INTIALIZED | - NVAPI not initialized
NVAPI_ERROR | - miscellaneous error occurred
NVAPI_INVALID_ARGUMENT | - Invalid input parameter.

◆ NvAPI_SYS_GetGpuAndOutputIdFromDisplayId()

NVAPI_INTERFACE NvAPI_SYS_GetGpuAndOutputIdFromDisplayId | ( | NvU32 | displayId,
 |  | NvPhysicalGpuHandle * | hPhysicalGpu,
 |  | NvU32 * | outputId
 | ) |  |

DESCRIPTION: This API converts a display ID to a Physical GPU handle and output ID.

SUPPORTED OS: Windows 7 and higher

Parameters
[in] | displayId | Display ID of display to retrieve GPU and outputId for
[out] | hPhysicalGpu | Handle to the physical GPU
[out] | outputId | ) Connected display output ID on the target GPU will only have one bit set.
Return values
NVAPI_OK
NVAPI_API_NOT_INTIALIZED
NVAPI_ID_OUT_OF_RANGE The DisplayId corresponds to a display which is not within the normal outputId range.
NVAPI_ERROR
NVAPI_INVALID_ARGUMENT

◆ NvAPI_SYS_GetLidAndDockInfo()

NVAPI_INTERFACE NvAPI_SYS_GetLidAndDockInfo ( NV_LID_DOCK_PARAMS * pLidAndDock )

DESCRIPTION: This function returns the current lid and dock information.

SUPPORTED OS: Windows 7 and higher

Since
Release: 177
Return values
NVAPI_OK
NVAPI_ERROR
NVAPI_NOT_SUPPORTED
NVAPI_HANDLE_INVALIDATED
NVAPI_API_NOT_INTIALIZED

◆ NvAPI_SYS_GetLogicalGPUs()

NVAPI_INTERFACE NvAPI_SYS_GetLogicalGPUs ( __inout NV_LOGICAL_GPUS * pLogicalGPUs )

DESCRIPTION: This API will return the GPU handles for all the logical GPUs in the system. Additional metadata is also returned with each handle.

SUPPORTED OS: Windows 10 and higher

MCDM_SUPPORTED

Since
Release: 530
Parameters
[in,out] pLogicalGPUs - Pointer to the structure holding the logical GPU handle related information.
Returns
This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.
Return values
NVAPI_NVIDIA_DEVICE_NOT_FOUND No GPU handles are enumerated.

◆ NvAPI_SYS_GetPhysicalGpuFromDisplayId()

NVAPI_INTERFACE NvAPI_SYS_GetPhysicalGpuFromDisplayId | ( | NvU32 | displayId,
 |  | NvPhysicalGpuHandle * | hPhysicalGpu
 | ) |  |
DESCRIPTION: This API retrieves the Physical GPU handle of the connected display
\since Release: 313
SUPPORTED OS: Windows 7 and higher
PARAMETERS: displayId(IN) - Display ID of display to retrieve
GPU handle
hPhysicalGpu(OUT) - Handle to the physical GPU
RETURN STATUS:
NVAPI_OK - completed request
NVAPI_API_NOT_INTIALIZED - NVAPI not initialized
NVAPI_ERROR - miscellaneous error occurred
NVAPI_INVALID_ARGUMENT - Invalid input parameter.
NVAPI_API_NOT_INTIALIZED
#define NVAPI_API_NOT_INTIALIZED
Definition nvapi.h:75
NVAPI_OK
@ NVAPI_OK
Success. Request is completed.
Definition nvapi_lite_common.h:258
NVAPI_INVALID_ARGUMENT
@ NVAPI_INVALID_ARGUMENT
The argument/parameter value is not valid or NULL.
Definition nvapi_lite_common.h:263
NVAPI_ERROR
@ NVAPI_ERROR
Generic error.
Definition nvapi_lite_common.h:259

◆ NvAPI_SYS_GetPhysicalGPUs()

NVAPI_INTERFACE NvAPI_SYS_GetPhysicalGPUs ( __inout NV_PHYSICAL_GPUS * pPhysicalGPUs )

DESCRIPTION: This API will return the GPU handles for all the physical GPUs in the system. Additional metadata is also returned with each handle.

SUPPORTED OS: Windows 10 and higher

TCC_SUPPORTED

MCDM_SUPPORTED

Since
Release: 530
Parameters
[in,out] pPhysicalGPUs - Pointer to the structure holding the physical GPU handle related information.
Returns
This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.
Return values
NVAPI_NVIDIA_DEVICE_NOT_FOUND No GPU handles are enumerated.


Data Fields
NV_CHIPSET_INFO_v4 Struct Reference
System APIs | Video APIs » Video Input/Output Interface » System - General Interface <br>

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 vendorId
NvU32 deviceId
NvAPI_ShortString szVendorName
NvAPI_ShortString szChipsetName
NvU32 flags
NvU32 subSysVendorId
NvU32 subSysDeviceId
NvAPI_ShortString szSubSysVendorName
NvU32 HBvendorId
NvU32 HBdeviceId
NvU32 HBsubSysVendorId
NvU32 HBsubSysDeviceId
The documentation for this struct was generated from the following file:


Data Fields
NV_CHIPSET_INFO_v3 Struct Reference
System APIs | Video APIs » Video Input/Output Interface » System - General Interface <br>

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 vendorId
NvU32 deviceId
NvAPI_ShortString szVendorName
NvAPI_ShortString szChipsetName
NvU32 flags
NvU32 subSysVendorId
NvU32 subSysDeviceId
NvAPI_ShortString szSubSysVendorName
The documentation for this struct was generated from the following file:


Data Fields
NV_CHIPSET_INFO_v2 Struct Reference
System APIs | Video APIs » Video Input/Output Interface » System - General Interface <br>

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 vendorId
NvU32 deviceId
NvAPI_ShortString szVendorName
NvAPI_ShortString szChipsetName
NvU32 flags
The documentation for this struct was generated from the following file:


Data Fields
NV_CHIPSET_INFO_v1 Struct Reference
System APIs | Video APIs » Video Input/Output Interface » System - General Interface <br>

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 vendorId
NvU32 deviceId
NvAPI_ShortString szVendorName
NvAPI_ShortString szChipsetName
The documentation for this struct was generated from the following file:


Data Fields
NV_LID_DOCK_PARAMS Struct Reference
Video APIs » Video Input/Output Interface | System APIs | Video APIs » Video Input/Output Interface » System - General Interface <br>

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 currentLidState
NvU32 currentDockState
NvU32 currentLidPolicy
NvU32 currentDockPolicy
NvU32 forcedLidMechanismPresent
NvU32 forcedDockMechanismPresent

Detailed Description

Lid and dock information - used in NvAPI_GetLidDockInfo()

The documentation for this struct was generated from the following file:


  • _NV_PIXEL_SRSO_1x2
  • NV_PIXEL_SRSO_1x2_X1
Data Fields
_NV_PIXEL_SRSO_1x2::NV_PIXEL_SRSO_1x2_X1 Struct Reference
Video APIs » Video Input/Output Interface

#include <nvapi.h>

Data Fields

NvU8 Y [2]
The documentation for this struct was generated from the following file:


  • _NV_PIXEL_SRSO_1x2
  • NV_PIXEL_SRSO_1x2_X2
Data Fields
_NV_PIXEL_SRSO_1x2::NV_PIXEL_SRSO_1x2_X2 Struct Reference
Video APIs » Video Input/Output Interface

#include <nvapi.h>

Data Fields

NvU8 YS [2][2]
The documentation for this struct was generated from the following file:


  • _NV_PIXEL_SRSO_1x2
  • NV_PIXEL_SRSO_1x2_X4
Data Fields
_NV_PIXEL_SRSO_1x2::NV_PIXEL_SRSO_1x2_X4 Struct Reference
Video APIs » Video Input/Output Interface

#include <nvapi.h>

Data Fields

NvU8 YS [2][4]
The documentation for this struct was generated from the following file:


  • _NV_PIXEL_SRSO_1x2
  • NV_PIXEL_SRSO_1x2_X8
Data Fields
_NV_PIXEL_SRSO_1x2::NV_PIXEL_SRSO_1x2_X8 Struct Reference
Video APIs » Video Input/Output Interface

#include <nvapi.h>

Data Fields

NvU8 YS [2][8]
The documentation for this struct was generated from the following file:


  • _NV_PIXEL_SRSO_2x1
  • NV_PIXEL_SRSO_2x1_X1
Data Fields
_NV_PIXEL_SRSO_2x1::NV_PIXEL_SRSO_2x1_X1 Struct Reference
Video APIs » Video Input/Output Interface

#include <nvapi.h>

Data Fields

NvU8 X [2]
The documentation for this struct was generated from the following file:


  • _NV_PIXEL_SRSO_2x1
  • NV_PIXEL_SRSO_2x1_X2
Data Fields
_NV_PIXEL_SRSO_2x1::NV_PIXEL_SRSO_2x1_X2 Struct Reference
Video APIs » Video Input/Output Interface

#include <nvapi.h>

Data Fields

NvU8 XS [2][2]
The documentation for this struct was generated from the following file:


  • _NV_PIXEL_SRSO_2x1
  • NV_PIXEL_SRSO_2x1_X4
Data Fields
_NV_PIXEL_SRSO_2x1::NV_PIXEL_SRSO_2x1_X4 Struct Reference
Video APIs » Video Input/Output Interface

#include <nvapi.h>

Data Fields

NvU8 XS [2][4]
The documentation for this struct was generated from the following file:


  • _NV_PIXEL_SRSO_2x2
  • NV_PIXEL_SRSO_2x2_X1
Data Fields
_NV_PIXEL_SRSO_2x2::NV_PIXEL_SRSO_2x2_X1 Struct Reference
Video APIs » Video Input/Output Interface

#include <nvapi.h>

Data Fields

NvU8 YX [2][2]
The documentation for this struct was generated from the following file:


  • _NV_PIXEL_SRSO_2x2
  • NV_PIXEL_SRSO_2x2_X2
Data Fields
_NV_PIXEL_SRSO_2x2::NV_PIXEL_SRSO_2x2_X2 Struct Reference
Video APIs » Video Input/Output Interface

#include <nvapi.h>

Data Fields

NvU8 YXS [2][2][2]
The documentation for this struct was generated from the following file:


  • _NV_PIXEL_SRSO_2x2
  • NV_PIXEL_SRSO_2x2_X4
Data Fields
_NV_PIXEL_SRSO_2x2::NV_PIXEL_SRSO_2x2_X4 Struct Reference
Video APIs » Video Input/Output Interface

#include <nvapi.h>

Data Fields

NvU8 YXS [2][2][4]
The documentation for this struct was generated from the following file:


  • _NV_PIXEL_SRSO_2x4
  • NV_PIXEL_SRSO_2x4_X1
Data Fields
_NV_PIXEL_SRSO_2x4::NV_PIXEL_SRSO_2x4_X1 Struct Reference
Video APIs » Video Input/Output Interface

#include <nvapi.h>

Data Fields

NvU8 YX [4][2]
The documentation for this struct was generated from the following file:


  • _NV_PIXEL_SRSO_2x4
  • NV_PIXEL_SRSO_2x4_X2
Data Fields
_NV_PIXEL_SRSO_2x4::NV_PIXEL_SRSO_2x4_X2 Struct Reference
Video APIs » Video Input/Output Interface

#include <nvapi.h>

Data Fields

NvU8 YXS [4][2][2]
The documentation for this struct was generated from the following file:


  • _NV_PIXEL_SRSO_4x2
  • NV_PIXEL_SRSO_4x2_X1
Data Fields
_NV_PIXEL_SRSO_4x2::NV_PIXEL_SRSO_4x2_X1 Struct Reference
Video APIs » Video Input/Output Interface

#include <nvapi.h>

Data Fields

NvU8 YX [2][4]
The documentation for this struct was generated from the following file:


  • _NV_PIXEL_SRSO_4x4
  • NV_PIXEL_SRSO_4x4_X1
Data Fields
_NV_PIXEL_SRSO_4x4::NV_PIXEL_SRSO_4x4_X1 Struct Reference
Video APIs » Video Input/Output Interface

#include <nvapi.h>

Data Fields

NvU8 YX [4][4]
The documentation for this struct was generated from the following file:


  • _NV_LATENCY_RESULT_PARAMS
  • FrameReport
Data Fields
_NV_LATENCY_RESULT_PARAMS::FrameReport Struct Reference
Video APIs » Video Input/Output Interface

#include <nvapi.h>

Data Fields

NvU64 frameID
NvU64 inputSampleTime
NvU64 simStartTime
NvU64 simEndTime
NvU64 renderSubmitStartTime
NvU64 renderSubmitEndTime
NvU64 presentStartTime
NvU64 presentEndTime
NvU64 driverStartTime
NvU64 driverEndTime
NvU64 osRenderQueueStartTime
NvU64 osRenderQueueEndTime
NvU64 gpuRenderStartTime
NvU64 gpuRenderEndTime
NvU32 gpuActiveRenderTimeUs
NvU32 gpuFrameTimeUs
NvU8 rsvd [120]
The documentation for this struct was generated from the following file:


Data Fields
_NVVIOCAPS Struct Reference
Video APIs » Video Input/Output Interface

#include <nvapi.h>

Data Fields

NvU32 version
NvAPI_String adapterName
NvU32 adapterClass
NvU32 adapterCaps
NvU32 dipSwitch
NvU32 dipSwitchReserved
NvU32 boardID
struct {
NvU32 _NVVIOCAPS::majorVersion
NvU32 _NVVIOCAPS::minorVersion
} driver
struct {
NvU32 _NVVIOCAPS::majorVersion
NvU32 _NVVIOCAPS::minorVersion
} firmWare
NVVIOOWNERID ownerId
NVVIOOWNERTYPE ownerType

Detailed Description

Device capabilities.

The documentation for this struct was generated from the following file:


Data Fields
_NVVIOCHANNELSTATUS Struct Reference
Video APIs » Video Input/Output Interface

#include <nvapi.h>

Data Fields

NvU32 smpte352
NVVIOSIGNALFORMAT signalFormat
NVVIOBITSPERCOMPONENT bitsPerComponent
NVVIOCOMPONENTSAMPLING samplingFormat
NVVIOCOLORSPACE colorSpace
NVVIOLINKID linkID

Detailed Description

Input channel status.

The documentation for this struct was generated from the following file:


Data Fields
_NVVIOINPUTSTATUS Struct Reference
Video APIs » Video Input/Output Interface

#include <nvapi.h>

Data Fields

NVVIOCHANNELSTATUS vidIn [NVAPI_MAX_VIO_JACKS][NVAPI_MAX_VIO_CHANNELS_PER_JACK]
NVVIOCAPTURESTATUS captureStatus

Detailed Description

Input device status.

The documentation for this struct was generated from the following file:


Data Fields
_NVVIOOUTPUTSTATUS Struct Reference
Video APIs » Video Input/Output Interface

#include <nvapi.h>

Data Fields

NVVIOINPUTOUTPUTSTATUS vid1Out
NVVIOINPUTOUTPUTSTATUS vid2Out
NVVIOSYNCSTATUS sdiSyncIn
NVVIOSYNCSTATUS compSyncIn
NvU32 syncEnable
NVVIOSYNCSOURCE syncSource
NVVIOSIGNALFORMAT syncFormat
NvU32 frameLockEnable
NvU32 outputVideoLocked
NvU32 dataIntegrityCheckErrorCount
NvU32 dataIntegrityCheckEnabled
NvU32 dataIntegrityCheckFailed
NvU32 uSyncSourceLocked
NvU32 uPowerOn

Detailed Description

Output device status.

The documentation for this struct was generated from the following file:


Data Fields
_NVVIOSTATUS Struct Reference
Video APIs » Video Input/Output Interface

#include <nvapi.h>

Data Fields

NvU32 version
NVVIOSTATUSTYPE nvvioStatusType
union {
NVVIOINPUTSTATUS _NVVIOSTATUS::inStatus
NVVIOOUTPUTSTATUS _NVVIOSTATUS::outStatus
} vioStatus

Detailed Description

Video device status.

The documentation for this struct was generated from the following file:


Data Fields
_NVVIOOUTPUTREGION Struct Reference
Video APIs » Video Input/Output Interface

#include <nvapi.h>

Data Fields

NvU32 x
NvU32 y
NvU32 width
NvU32 height

Detailed Description

Output region.

The documentation for this struct was generated from the following file:


Data Fields
_NVVIOGAMMARAMP8 Struct Reference
Video APIs » Video Input/Output Interface

#include <nvapi.h>

Data Fields

NvU16 | uRed [256]
NvU16 | uGreen [256]
NvU16 | uBlue [256]

Detailed Description

Gamma ramp (8-bit index)

The documentation for this struct was generated from the following file:


Data Fields
_NVVIOGAMMARAMP10 Struct Reference
Video APIs » Video Input/Output Interface

#include <nvapi.h>

Data Fields

NvU16 | uRed [1024]
NvU16 | uGreen [1024]
NvU16 | uBlue [1024]

Detailed Description

Gamma ramp (10-bit index)

The documentation for this struct was generated from the following file:


Data Fields
_NVVIOSYNCDELAY Struct Reference
Video APIs » Video Input/Output Interface

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 horizontalDelay
NvU32 verticalDelay

Detailed Description

Sync delay.

The documentation for this struct was generated from the following file:


Data Fields
_NVVIOVIDEOMODE Struct Reference
Video APIs » Video Input/Output Interface

#include <nvapi.h>

Data Fields

NvU32 horizontalPixels
NvU32 verticalLines
float fFrameRate
NVVIOINTERLACEMODE interlaceMode
NVVIOVIDEOSTANDARD videoStandard
NVVIOVIDEOTYPE videoType

Detailed Description

Video mode information.

The documentation for this struct was generated from the following file:


Data Fields
_NVVIOSIGNALFORMATDETAIL Struct Reference
Video APIs » Video Input/Output Interface

#include <nvapi.h>

Data Fields

NVVIOSIGNALFORMAT signalFormat
NVVIOVIDEOMODE videoMode

Detailed Description

Signal format details.

The documentation for this struct was generated from the following file:


Data Fields
_NVVIODATAFORMATDETAIL Struct Reference
Video APIs » Video Input/Output Interface

#include <nvapi.h>

Data Fields

NVVIODATAFORMAT dataFormat
NvU32 vioCaps

Detailed Description

Data format details.

The documentation for this struct was generated from the following file:


Data Fields
_NVVIOCOLORCONVERSION Struct Reference
Video APIs » Video Input/Output Interface

#include <nvapi.h>

Data Fields

NvU32 version
float | colorMatrix [3][3]
float | colorOffset [3]
float | colorScale [3]
NvU32 compositeSafe

Detailed Description

Colorspace conversion.

The documentation for this struct was generated from the following file:


Data Fields
_NVVIOGAMMACORRECTION Struct Reference
Video APIs » Video Input/Output Interface

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 vioGammaCorrectionType
union {
NVVIOGAMMARAMP8 _NVVIOGAMMACORRECTION::gammaRamp8
NVVIOGAMMARAMP10 _NVVIOGAMMACORRECTION::gammaRamp10
} gammaRamp
float | fGammaValueR
float | fGammaValueG
float | fGammaValueB

Detailed Description

Gamma correction.

The documentation for this struct was generated from the following file:


Data Fields
_NVVIOCOMPOSITERANGE Struct Reference
Video APIs » Video Input/Output Interface

#include <nvapi.h>

Data Fields

NvU32 uRange
NvU32 uEnabled
NvU32 uMin
NvU32 uMax
The documentation for this struct was generated from the following file:


Data Fields
_NVVIOOUTPUTCONFIG_V1 Struct Reference
Video APIs » Video Input/Output Interface

#include <nvapi.h>

Data Fields

NVVIOSIGNALFORMAT signalFormat
NVVIODATAFORMAT dataFormat
NVVIOOUTPUTREGION outputRegion
NVVIOOUTPUTAREA outputArea
NVVIOCOLORCONVERSION colorConversion
NVVIOGAMMACORRECTION gammaCorrection
NvU32 syncEnable
NVVIOSYNCSOURCE syncSource
NVVIOSYNCDELAY syncDelay
NVVIOCOMPSYNCTYPE compositeSyncType
NvU32 frameLockEnable
NvU32 psfSignalFormat
NvU32 enable422Filter
NvU32 compositeTerminate
NvU32 enableDataIntegrityCheck
NvU32 cscOverride
NvU32 flipQueueLength
NvU32 enableANCTimeCodeGeneration
NvU32 enableComposite
NvU32 enableAlphaKeyComposite
NVVIOCOMPOSITERANGE compRange
NvU8 reservedData [256]
NvU32 enableFullColorRange
NvU32 enableRGBData

Detailed Description

Output device configuration.

The documentation for this struct was generated from the following file:


Data Fields
_NVVIOOUTPUTCONFIG_V2 Struct Reference
Video APIs » Video Input/Output Interface

#include <nvapi.h>

Data Fields

NVVIOSIGNALFORMAT signalFormat
NVVIODATAFORMAT dataFormat
NVVIOOUTPUTREGION outputRegion
NVVIOOUTPUTAREA outputArea
NVVIOCOLORCONVERSION colorConversion
NVVIOGAMMACORRECTION gammaCorrection
NvU32 syncEnable
NVVIOSYNCSOURCE syncSource
NVVIOSYNCDELAY syncDelay
NVVIOCOMPSYNCTYPE compositeSyncType
NvU32 frameLockEnable
NvU32 psfSignalFormat
NvU32 enable422Filter
NvU32 compositeTerminate
NvU32 enableDataIntegrityCheck
NvU32 cscOverride
NvU32 flipQueueLength
NvU32 enableANCTimeCodeGeneration
NvU32 enableComposite
NvU32 enableAlphaKeyComposite
NVVIOCOMPOSITERANGE compRange
NvU8 reservedData [256]
NvU32 enableFullColorRange
NvU32 enableRGBData
NVVIOANCPARITYCOMPUTATION ancParityComputation
The documentation for this struct was generated from the following file:


Data Fields
_NVVIOOUTPUTCONFIG_V3 Struct Reference
Video APIs » Video Input/Output Interface

#include <nvapi.h>

Data Fields

NVVIOSIGNALFORMAT signalFormat
NVVIODATAFORMAT dataFormat
NVVIOOUTPUTREGION outputRegion
NVVIOOUTPUTAREA outputArea
NVVIOCOLORCONVERSION colorConversion
NVVIOGAMMACORRECTION gammaCorrection
NvU32 syncEnable
NVVIOSYNCSOURCE syncSource
NVVIOSYNCDELAY syncDelay
NVVIOCOMPSYNCTYPE compositeSyncType
NvU32 frameLockEnable
NvU32 psfSignalFormat
NvU32 enable422Filter
NvU32 compositeTerminate
NvU32 enableDataIntegrityCheck
NvU32 cscOverride
NvU32 flipQueueLength
NvU32 enableANCTimeCodeGeneration
NvU32 enableComposite
NvU32 enableAlphaKeyComposite
NVVIOCOMPOSITERANGE compRange
NvU8 reservedData [256]
NvU32 enableFullColorRange
NvU32 enableRGBData
NVVIOANCPARITYCOMPUTATION ancParityComputation
NvU32 enableAudioBlanking
The documentation for this struct was generated from the following file:


Data Fields
_NVVIOSTREAM Struct Reference
Video APIs » Video Input/Output Interface

#include <nvapi.h>

Data Fields

NvU32 bitsPerComponent
NVVIOCOMPONENTSAMPLING sampling
NvU32 expansionEnable
NvU32 numLinks
struct {
NvU32 _NVVIOSTREAM::jack
NvU32 _NVVIOSTREAM::channel
} links [NVAPI_MAX_VIO_LINKS_PER_STREAM]

Detailed Description

Stream configuration.

The documentation for this struct was generated from the following file:


Data Fields
_NVVIOINPUTCONFIG Struct Reference
Video APIs » Video Input/Output Interface

#include <nvapi.h>

Data Fields

NvU32 numRawCaptureImages
NVVIOSIGNALFORMAT signalFormat
NvU32 numStreams
NVVIOSTREAM streams [NVAPI_MAX_VIO_STREAMS]
NvU32 bTestMode

Detailed Description

Input device configuration.

The documentation for this struct was generated from the following file:


Data Fields
_NVVIOCONFIG_V1 Struct Reference
Video APIs » Video Input/Output Interface

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 fields
NVVIOCONFIGTYPE nvvioConfigType
union {
NVVIOINPUTCONFIG _NVVIOCONFIG_V1::inConfig
NVVIOOUTPUTCONFIG_V1 _NVVIOCONFIG_V1::outConfig
} vioConfig
The documentation for this struct was generated from the following file:


Data Fields
_NVVIOCONFIG_V2 Struct Reference
Video APIs » Video Input/Output Interface

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 fields
NVVIOCONFIGTYPE nvvioConfigType
union {
NVVIOINPUTCONFIG _NVVIOCONFIG_V2::inConfig
NVVIOOUTPUTCONFIG_V2 _NVVIOCONFIG_V2::outConfig
} vioConfig
The documentation for this struct was generated from the following file:


Data Fields
_NVVIOCONFIG_V3 Struct Reference
Video APIs » Video Input/Output Interface

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 fields
NVVIOCONFIGTYPE nvvioConfigType
union {
NVVIOINPUTCONFIG _NVVIOCONFIG_V3::inConfig
NVVIOOUTPUTCONFIG_V3 _NVVIOCONFIG_V3::outConfig
} vioConfig
The documentation for this struct was generated from the following file:


Data Fields
NVVIOTOPOLOGYTARGET Struct Reference
Video APIs » Video Input/Output Interface

#include <nvapi.h>

Data Fields

NvPhysicalGpuHandle | hPhysicalGpu
NvVioHandle | hVioHandle
NvU32 vioId
NvU32 outputId
The documentation for this struct was generated from the following file:


Data Fields
_NV_VIO_TOPOLOGY Struct Reference
Video APIs » Video Input/Output Interface

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 vioTotalDeviceCount
NVVIOTOPOLOGYTARGET vioTarget [NVAPI_MAX_VIO_DEVICES]
The documentation for this struct was generated from the following file:


Data Fields
_NVVIOPCIINFO Struct Reference
Video APIs » Video Input/Output Interface

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 pciDeviceId
NvU32 pciSubSystemId
NvU32 pciRevisionId
NvU32 pciDomain
NvU32 pciBus
NvU32 pciSlot
NVVIOPCILINKWIDTH pciLinkWidth
NVVIOPCILINKRATE pciLinkRate
The documentation for this struct was generated from the following file:


Data Fields
_NV_DISPLAY_DRIVER_INFO Struct Reference
Video APIs » Video Input/Output Interface

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 driverVersion
NvAPI_ShortString szBuildBranch
NvU32 | bIsDCHDriver: 1
NvU32 | bIsNVIDIAStudioPackage: 1
NvU32 | bIsNVIDIAGameReadyPackage: 1
NvU32 | bIsNVIDIARTXProductionBranchPackage: 1
NvU32 | bIsNVIDIARTXNewFeatureBranchPackage: 1
NvU32 | reserved: 27
The documentation for this struct was generated from the following file:


Data Fields
_NV_DISPLAY_DRIVER_INFO_V2 Struct Reference
Video APIs » Video Input/Output Interface

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 driverVersion
NvAPI_ShortString szBuildBranch
NvU32 | bIsDCHDriver: 1
NvU32 | bIsNVIDIAStudioPackage: 1
NvU32 | bIsNVIDIAGameReadyPackage: 1
NvU32 | bIsNVIDIARTXProductionBranchPackage: 1
NvU32 | bIsNVIDIARTXNewFeatureBranchPackage: 1
NvU32 | reserved: 27
NvAPI_ShortString szBuildBaseBranch
NvU32 reservedEx
The documentation for this struct was generated from the following file:


Data Fields
_NV_PHYSICAL_GPU_HANDLE_DATA Struct Reference
Video APIs » Video Input/Output Interface

#include <nvapi.h>

Data Fields

NvPhysicalGpuHandle | hPhysicalGpu
NV_ADAPTER_TYPE adapterType
NvU32 | reserved2 [4]
The documentation for this struct was generated from the following file:


Data Fields
_NV_PHYSICAL_GPUS Struct Reference
Video APIs » Video Input/Output Interface

#include <nvapi.h>

Data Fields

NvU32 version
NV_PHYSICAL_GPU_HANDLE_DATA gpuHandleData [NVAPI_MAX_PHYSICAL_GPUS]
NvU32 gpuHandleCount
NvU32 reserved [4]
The documentation for this struct was generated from the following file:


Data Fields
_NV_LOGICAL_GPU_HANDLE_DATA Struct Reference
Video APIs » Video Input/Output Interface

#include <nvapi.h>

Data Fields

NvLogicalGpuHandle | hLogicalGpu
NV_ADAPTER_TYPE adapterType
NvU32 | reserved [4]
The documentation for this struct was generated from the following file:


Data Fields
_NV_LOGICAL_GPUS Struct Reference
Video APIs » Video Input/Output Interface

#include <nvapi.h>

Data Fields

NvU32 version
NV_LOGICAL_GPU_HANDLE_DATA gpuHandleData [NVAPI_MAX_LOGICAL_GPUS]
NvU32 gpuHandleCount
NvU32 reserved [4]
The documentation for this struct was generated from the following file:


Data Fields
_NV_CLIENT_CALLBACK_SETTINGS_SUPER_V1 Struct Reference
Video APIs » Video Input/Output Interface

#include <nvapi.h>

Data Fields

void * | pCallbackParam
NvU8 | rsvd [64]

Detailed Description

Callback settings common to all client callbacks.

The documentation for this struct was generated from the following file:


Data Fields
_NV_GPU_CLIENT_PERIODIC_CALLBACK_SETTINGS_SUPER_V1 Struct Reference
Video APIs » Video Input/Output Interface

#include <nvapi.h>

Data Fields

NV_GPU_CLIENT_CALLBACK_SETTINGS_SUPER_V1 super
NvU32 callbackPeriodms
NvU8 rsvd [64]

Detailed Description

Callback settings common to all periodic client callbacks.

The documentation for this struct was generated from the following file:


Data Fields
_NV_GPU_CLIENT_CALLBACK_DATA_SUPER_V1 Struct Reference
Video APIs » Video Input/Output Interface

#include <nvapi.h>

Data Fields

void * | pCallbackParam
NvU8 | rsvd [64]

Detailed Description

Callback data common to all client callbacks.

The documentation for this struct was generated from the following file:


Data Fields
_NV_GPU_CLIENT_UTILIZATION_DATA_V1 Struct Reference
Video APIs » Video Input/Output Interface

#include <nvapi.h>

Data Fields

NV_GPU_CLIENT_UTIL_DOMAIN_ID utilId
NvU32 utilizationPercent
NvU8 rsvd [61]

Detailed Description

Data specific to a single utilization domain.

The documentation for this struct was generated from the following file:


Data Fields
_NV_GPU_CLIENT_CALLBACK_UTILIZATION_DATA_V1 Struct Reference
Video APIs » Video Input/Output Interface

#include <nvapi.h>

Data Fields

NV_GPU_CLIENT_CALLBACK_DATA_SUPER_V1 super
NvU32 numUtils
NvU64 timestamp
NvU8 rsvd [64]
NV_GPU_CLIENT_UTILIZATION_DATA_V1 utils [NV_GPU_CLIENT_UTIL_DOMAINS_MAX_V1]

Detailed Description

Data passed back to callback registered with NvAPI_GPU_ClientRegisterForUtilizationSampleUpdates.

The documentation for this struct was generated from the following file:


Data Fields
_NV_GPU_CLIENT_UTILIZATION_PERIODIC_CALLBACK_SETTINGS_V1 Struct Reference
Video APIs » Video Input/Output Interface

#include <nvapi.h>

Data Fields

NvU32 version
NV_GPU_CLIENT_PERIODIC_CALLBACK_SETTINGS_SUPER_V1 super
NV_GPU_CLIENT_UTILIZATION_PERIODIC_CALLBACK_V1 callback
NvU8 rsvd [64]

Detailed Description

Data required to register a periodic callback for utilization data.

The documentation for this struct was generated from the following file:


Data Structures | Macros | Typedefs | Enumerations | Functions
DirectX Interface
DirectX APIs

Data Structures

struct | NV_D3D11_META_COMMAND_RESOURCE
struct | NV_D3D12_META_COMMAND_INITIALIZE_CONVOLUTION_EX_DESC
struct | _NV_MULTIGPU_CAPS_V1
struct | _NV_QUERY_SINGLE_PASS_STEREO_SUPPORT_PARAMS_V1
struct | _NV_QUERY_MULTIVIEW_SUPPORT_PARAMS_V1
struct | _NV_MULTIVIEW_PARAMS_V1
struct | _NV_QUERY_MODIFIED_W_SUPPORT_PARAMS
struct | _NV_QUERY_LATELATCH_SUPPORT_PARAMS
struct | _NV_D3D1x_GRAPHICS_CAPS_V1
struct | _NV_D3D12_GRAPHICS_CAPS_V1
struct | _NV_D3D11_EXCLUSIVE_SCISSOR_RECT_DESC_V1
struct | _NV_PIXEL_SRSO_1x2
struct | _NV_QUERY_SMP_ASSIST_SUPPORT_PARAMS_V1
struct | _NV_GET_SLEEP_STATUS_PARAMS
struct | _NV_SET_SLEEP_MODE_PARAMS
struct | _NV_SET_REFLEX_SYNC_PARAMS
struct | _NV_LATENCY_RESULT_PARAMS
struct | _NV_LATENCY_MARKER_PARAMS
struct | _NV_ASYNC_FRAME_MARKER_PARAMS_V1
struct | _NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_USAGE_COUNT
struct | _NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_DESC
struct | _NVAPI_D3D12_BUILD_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_INPUTS
struct | _NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PREBUILD_INFO
struct | _NVAPI_GET_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PREBUILD_INFO_PARAMS_V1
struct | _NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_USAGE_COUNT
struct | _NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_DESC
struct | _NVAPI_D3D12_BUILD_RAYTRACING_OPACITY_MICROMAP_ARRAY_INPUTS
struct | _NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_ARRAY_PREBUILD_INFO
struct | _NVAPI_GET_RAYTRACING_OPACITY_MICROMAP_ARRAY_PREBUILD_INFO_PARAMS_V1
struct | _NVAPI_D3D12_SET_CREATE_PIPELINE_STATE_OPTIONS_PARAMS_V1
struct | _NVAPI_CHECK_DRIVER_MATCHING_IDENTIFIER_EX_PARAMS_V1
struct | _NVAPI_D3D12_RAYTRACING_GEOMETRY_OMM_ATTACHMENT_DESC
struct | _NVAPI_D3D12_RAYTRACING_GEOMETRY_DMM_ATTACHMENT_DESC
struct | _NVAPI_D3D12_RAYTRACING_GEOMETRY_DMM_TRIANGLES_DESC
struct | _NVAPI_D3D12_RAYTRACING_GEOMETRY_OMM_TRIANGLES_DESC
struct | _NVAPI_D3D12_RAYTRACING_GEOMETRY_DESC_EX
struct | _NVAPI_D3D12_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_INPUTS_EX
struct | _NVAPI_GET_RAYTRACING_ACCELERATION_STRUCTURE_PREBUILD_INFO_EX_PARAMS_V1
struct | _NVAPI_D3D12_BUILD_RAYTRACING_OPACITY_MICROMAP_ARRAY_DESC
struct | _NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_ARRAY_POSTBUILD_INFO_CURRENT_SIZE_DESC
struct | _NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_ARRAY_POSTBUILD_INFO_DESC
struct | _NVAPI_BUILD_RAYTRACING_OPACITY_MICROMAP_ARRAY_PARAMS_V1
struct | _NVAPI_RELOCATE_RAYTRACING_OPACITY_MICROMAP_ARRAY_PARAMS_V1
struct | _NVAPI_D3D12_BUILD_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_DESC
struct | _NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_POSTBUILD_INFO_CURRENT_SIZE_DESC
struct | _NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_POSTBUILD_INFO_DESC
struct | _NVAPI_BUILD_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PARAMS_V1
struct | _NVAPI_RELOCATE_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PARAMS_V1
struct | _NVAPI_EMIT_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_POSTBUILD_INFO_PARAMS_V1
struct | _NVAPI_EMIT_RAYTRACING_OPACITY_MICROMAP_ARRAY_POSTBUILD_INFO_PARAMS_V1
struct | _NVAPI_D3D12_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_DESC_EX
struct | _NVAPI_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_EX_PARAMS_V1
struct | NV_GET_CURRENT_SLI_STATE_V1

Macros

#define | NVAPI_COPY_ASYNCHRONOUSLY 1
#define | NV_MAX_PIXEL_SHADING_RATES 16
#define | NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_ARRAY_BYTE_ALIGNMENT 256
#define | NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_OC1_MAX_SUBDIVISION_LEVEL 12
#define | NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_BYTE_ALIGNMENT 256
#define | NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_DC1_MAX_SUBDIVISION_LEVEL 5
#define | NV_GET_CURRENT_SLI_STATE_VER1 MAKE_NVAPI_VERSION(NV_GET_CURRENT_SLI_STATE_V1,1)

Typedefs

typedef enum _NVAPI_D3D11_INSERTWFI_FLAG | NVAPI_D3D11_INSERTWFI_FLAG
typedef enum _NVAPI_ANSEL_FEATURE | NVAPI_ANSEL_FEATURE
typedef enum _NV_RESOLVE_MODE | NV_RESOLVE_MODE
typedef enum _NV_PSO_EXTENSION | NV_PSO_EXTENSION
typedef enum _NV_COMPUTE_SHADER_DERIVATIVES | NV_COMPUTE_SHADER_DERIVATIVES
typedef struct _NV_MULTIGPU_CAPS_V1 | NV_MULTIGPU_CAPS_V1
typedef struct _NV_MULTIGPU_CAPS_V1 * | PNV_MULTIGPU_CAPS_V1
typedef struct _NV_QUERY_SINGLE_PASS_STEREO_SUPPORT_PARAMS_V1 | NV_QUERY_SINGLE_PASS_STEREO_SUPPORT_PARAMS_V1
typedef struct _NV_QUERY_MULTIVIEW_SUPPORT_PARAMS_V1 | NV_QUERY_MULTIVIEW_SUPPORT_PARAMS_V1
typedef struct _NV_MULTIVIEW_PARAMS_V1 | NV_MULTIVIEW_PARAMS_V1
typedef struct _NV_QUERY_MODIFIED_W_SUPPORT_PARAMS | NV_QUERY_MODIFIED_W_SUPPORT_PARAMS_V1
typedef ID3DLateLatchObject_V1 | ID3DLateLatchObject
typedef struct _NV_QUERY_LATELATCH_SUPPORT_PARAMS | NV_QUERY_LATELATCH_SUPPORT_PARAMS_V1
typedef enum _IMPLICIT_SLI_CONTROL | IMPLICIT_SLI_CONTROL
typedef struct _NV_D3D1x_GRAPHICS_CAPS_V1 | NV_D3D1x_GRAPHICS_CAPS_V1
typedef struct _NV_D3D12_GRAPHICS_CAPS_V1 | NV_D3D12_GRAPHICS_CAPS_V1
typedef struct _NV_D3D11_EXCLUSIVE_SCISSOR_RECT_DESC_V1 | NV_D3D11_EXCLUSIVE_SCISSOR_RECT_DESC_V1
typedef struct _NV_PIXEL_SRSO_1x2 | NV_PIXEL_SRSO_1x2
typedef enum NV_SMP_ASSIST_TYPE | NV_SMP_ASSIST_TYPE
typedef struct _NV_QUERY_SMP_ASSIST_SUPPORT_PARAMS_V1 | NV_QUERY_SMP_ASSIST_SUPPORT_PARAMS_V1
typedef struct _NV_GET_SLEEP_STATUS_PARAMS | NV_GET_SLEEP_STATUS_PARAMS_V1
typedef struct _NV_SET_SLEEP_MODE_PARAMS | NV_SET_SLEEP_MODE_PARAMS_V1
typedef struct _NV_SET_REFLEX_SYNC_PARAMS | NV_SET_REFLEX_SYNC_PARAMS_V1
typedef struct _NV_LATENCY_RESULT_PARAMS | NV_LATENCY_RESULT_PARAMS_V1
typedef struct _NV_LATENCY_MARKER_PARAMS | NV_LATENCY_MARKER_PARAMS_V1
typedef struct _NV_ASYNC_FRAME_MARKER_PARAMS_V1 | NV_ASYNC_FRAME_MARKER_PARAMS_V1
typedef enum _NVAPI_D3D12_RAYTRACING_THREAD_REORDERING_CAPS | NVAPI_D3D12_RAYTRACING_THREAD_REORDERING_CAPS
typedef enum _NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_CAPS | NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_CAPS
typedef enum _NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_CAPS | NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_CAPS
typedef enum _NVAPI_D3D12_RAYTRACING_CAPS_TYPE | NVAPI_D3D12_RAYTRACING_CAPS_TYPE
typedef enum _NVAPI_D3D12_RAYTRACING_VALIDATION_FLAGS | NVAPI_D3D12_RAYTRACING_VALIDATION_FLAGS
typedef enum _NVAPI_D3D12_RAYTRACING_VALIDATION_MESSAGE_SEVERITY | NVAPI_D3D12_RAYTRACING_VALIDATION_MESSAGE_SEVERITY
typedef void(__stdcall * | NVAPI_D3D12_RAYTRACING_VALIDATION_MESSAGE_CALLBACK) (void *pUserData, NVAPI_D3D12_RAYTRACING_VALIDATION_MESSAGE_SEVERITY severity, const char *messageCode, const char *message, const char *messageDetails)
typedef enum _NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_BUILD_FLAGS | NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_BUILD_FLAGS
typedef enum _NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_FORMAT | NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_FORMAT
typedef struct _NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_USAGE_COUNT | NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_USAGE_COUNT
typedef struct _NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_DESC | NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_DESC
typedef struct _NVAPI_D3D12_BUILD_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_INPUTS | NVAPI_D3D12_BUILD_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_INPUTS
typedef struct _NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PREBUILD_INFO | NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PREBUILD_INFO
typedef struct _NVAPI_GET_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PREBUILD_INFO_PARAMS_V1 | NVAPI_GET_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PREBUILD_INFO_PARAMS_V1
typedef enum _NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_ARRAY_BUILD_FLAGS | NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_ARRAY_BUILD_FLAGS
typedef enum _NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_FORMAT | NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_FORMAT
typedef struct _NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_USAGE_COUNT | NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_USAGE_COUNT
typedef struct _NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_DESC | NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_DESC
typedef struct _NVAPI_D3D12_BUILD_RAYTRACING_OPACITY_MICROMAP_ARRAY_INPUTS | NVAPI_D3D12_BUILD_RAYTRACING_OPACITY_MICROMAP_ARRAY_INPUTS
typedef struct _NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_ARRAY_PREBUILD_INFO | NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_ARRAY_PREBUILD_INFO
typedef struct _NVAPI_GET_RAYTRACING_OPACITY_MICROMAP_ARRAY_PREBUILD_INFO_PARAMS_V1 | NVAPI_GET_RAYTRACING_OPACITY_MICROMAP_ARRAY_PREBUILD_INFO_PARAMS_V1
typedef enum _NVAPI_D3D12_PIPELINE_CREATION_STATE_FLAGS | NVAPI_D3D12_PIPELINE_CREATION_STATE_FLAGS
typedef struct _NVAPI_D3D12_SET_CREATE_PIPELINE_STATE_OPTIONS_PARAMS_V1 | NVAPI_D3D12_SET_CREATE_PIPELINE_STATE_OPTIONS_PARAMS_V1
typedef enum _NVAPI_D3D12_SERIALIZED_DATA_TYPE_EX | NVAPI_D3D12_SERIALIZED_DATA_TYPE_EX
typedef struct _NVAPI_CHECK_DRIVER_MATCHING_IDENTIFIER_EX_PARAMS_V1 | NVAPI_CHECK_DRIVER_MATCHING_IDENTIFIER_EX_PARAMS_V1
typedef enum _NVAPI_D3D12_RAYTRACING_ACCELERATION_STRUCTURE_BUILD_FLAGS_EX | NVAPI_D3D12_RAYTRACING_ACCELERATION_STRUCTURE_BUILD_FLAGS_EX
typedef enum _NVAPI_D3D12_RAYTRACING_GEOMETRY_TYPE_EX | NVAPI_D3D12_RAYTRACING_GEOMETRY_TYPE_EX
typedef enum _NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_SPECIAL_INDEX | NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_SPECIAL_INDEX
typedef struct _NVAPI_D3D12_RAYTRACING_GEOMETRY_OMM_ATTACHMENT_DESC | NVAPI_D3D12_RAYTRACING_GEOMETRY_OMM_ATTACHMENT_DESC
typedef enum _NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_PRIMITIVE_FLAGS | NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_PRIMITIVE_FLAGS
typedef struct _NVAPI_D3D12_RAYTRACING_GEOMETRY_DMM_ATTACHMENT_DESC | NVAPI_D3D12_RAYTRACING_GEOMETRY_DMM_ATTACHMENT_DESC
typedef struct _NVAPI_D3D12_RAYTRACING_GEOMETRY_DMM_TRIANGLES_DESC | NVAPI_D3D12_RAYTRACING_GEOMETRY_DMM_TRIANGLES_DESC
typedef struct _NVAPI_D3D12_RAYTRACING_GEOMETRY_OMM_TRIANGLES_DESC | NVAPI_D3D12_RAYTRACING_GEOMETRY_OMM_TRIANGLES_DESC
typedef struct _NVAPI_D3D12_RAYTRACING_GEOMETRY_DESC_EX | NVAPI_D3D12_RAYTRACING_GEOMETRY_DESC_EX
typedef enum _NVAPI_D3D12_RAYTRACING_INSTANCE_FLAGS_EX | NVAPI_D3D12_RAYTRACING_INSTANCE_FLAGS_EX
typedef struct _NVAPI_D3D12_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_INPUTS_EX | NVAPI_D3D12_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_INPUTS_EX
typedef struct _NVAPI_GET_RAYTRACING_ACCELERATION_STRUCTURE_PREBUILD_INFO_EX_PARAMS_V1 | NVAPI_GET_RAYTRACING_ACCELERATION_STRUCTURE_PREBUILD_INFO_EX_PARAMS_V1
typedef struct _NVAPI_D3D12_BUILD_RAYTRACING_OPACITY_MICROMAP_ARRAY_DESC | NVAPI_D3D12_BUILD_RAYTRACING_OPACITY_MICROMAP_ARRAY_DESC
typedef struct _NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_ARRAY_POSTBUILD_INFO_CURRENT_SIZE_DESC | NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_ARRAY_POSTBUILD_INFO_CURRENT_SIZE_DESC
typedef enum _NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_ARRAY_POSTBUILD_INFO_TYPE | NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_ARRAY_POSTBUILD_INFO_TYPE
typedef struct _NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_ARRAY_POSTBUILD_INFO_DESC | NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_ARRAY_POSTBUILD_INFO_DESC
typedef struct _NVAPI_BUILD_RAYTRACING_OPACITY_MICROMAP_ARRAY_PARAMS_V1 | NVAPI_BUILD_RAYTRACING_OPACITY_MICROMAP_ARRAY_PARAMS_V1
typedef struct _NVAPI_RELOCATE_RAYTRACING_OPACITY_MICROMAP_ARRAY_PARAMS_V1 | NVAPI_RELOCATE_RAYTRACING_OPACITY_MICROMAP_ARRAY_PARAMS_V1
typedef struct _NVAPI_D3D12_BUILD_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_DESC | NVAPI_D3D12_BUILD_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_DESC
typedef struct _NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_POSTBUILD_INFO_CURRENT_SIZE_DESC | NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_POSTBUILD_INFO_CURRENT_SIZE_DESC
typedef enum _NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_POSTBUILD_INFO_TYPE | NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_POSTBUILD_INFO_TYPE
typedef struct _NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_POSTBUILD_INFO_DESC | NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_POSTBUILD_INFO_DESC
typedef struct _NVAPI_BUILD_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PARAMS_V1 | NVAPI_BUILD_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PARAMS_V1
typedef struct _NVAPI_RELOCATE_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PARAMS_V1 | NVAPI_RELOCATE_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PARAMS_V1
typedef struct _NVAPI_EMIT_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_POSTBUILD_INFO_PARAMS_V1 | NVAPI_EMIT_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_POSTBUILD_INFO_PARAMS_V1
typedef struct _NVAPI_EMIT_RAYTRACING_OPACITY_MICROMAP_ARRAY_POSTBUILD_INFO_PARAMS_V1 | NVAPI_EMIT_RAYTRACING_OPACITY_MICROMAP_ARRAY_POSTBUILD_INFO_PARAMS_V1
typedef struct _NVAPI_D3D12_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_DESC_EX | NVAPI_D3D12_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_DESC_EX
typedef struct _NVAPI_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_EX_PARAMS_V1 | NVAPI_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_EX_PARAMS_V1
typedef enum _NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_STATE | NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_STATE
typedef enum _NVAPI_RAY_FLAGS_EX | NVAPI_RAY_FLAG_EX
typedef enum _NVAPI_D3D_SETRESOURCEHINT_CATEGORY | NVAPI_D3D_SETRESOURCEHINT_CATEGORY
typedef enum _NVAPI_D3D_SETRESOURCEHINT_SLI | NVAPI_D3D_SETRESOURCEHINT_SLI
typedef enum _NVAPI_D3D_RESOURCERENDERING_FLAG | NVAPI_D3D_RESOURCERENDERING_FLAG

Enumerations

enum | NVAPI_ALIAS_SURFACE_FLAG { NVAPI_ALIAS_SURFACE_FLAG_NONE = 0x00000000 , NVAPI_ALIAS_SURFACE_FLAG_USE_SUPER = 0x00000001 , NVAPI_ALIAS_SURFACE_FLAG_MASK = 0x00000001 }
enum | _NVAPI_D3D11_INSERTWFI_FLAG { NVAPI_D3D_BEGIN_UAV_OVERLAP_NO_WFI = 0x00000000 , NVAPI_D3D_BEGIN_UAV_OVERLAP_GFX_WFI = 0x00000001 , NVAPI_D3D_BEGIN_UAV_OVERLAP_COMP_WFI = 0x00000002 }
enum NVAPI_VSYNC_MODE {
NVAPI_VSYNC_DEFAULT , NVAPI_VSYNC_OFF , NVAPI_VSYNC_ON , NVAPI_VSYNC_ADAPTIVE ,
NVAPI_VSYNC_ADAPTIVE_HALF_REFRESH_RATE
}
enum | _NVAPI_ANSEL_FEATURE { NVAPI_ANSEL_FEATURE_UNKNOWN = 0 , NVAPI_ANSEL_FEATURE_BLACK_AND_WHITE = 1 , NVAPI_ANSEL_FEATURE_HUDLESS = 2 }
enum | _NV_RESOLVE_MODE { NV_RESOLVE_MODE_SAMPLE_0 }
enum _NV_PSO_EXTENSION {
NV_PSO_RASTER_EXTENSION = 0 , NV_PSO_REQUEST_FASTGS_EXTENSION = 1 , NV_PSO_GEOMETRY_SHADER_EXTENSION = 2 , NV_PSO_ENABLE_DEPTH_BOUND_TEST_EXTENSION = 3 ,
NV_PSO_EXPLICIT_FASTGS_EXTENSION = 4 , NV_PSO_SET_SHADER_EXTNENSION_SLOT_AND_SPACE = 5 , NV_PSO_SET_SHADER_EXTENSION_SLOT_AND_SPACE = 5 , NV_PSO_VERTEX_SHADER_EXTENSION = 6 ,
NV_PSO_DOMAIN_SHADER_EXTENSION = 7 , NV_PSO_HULL_SHADER_EXTENSION = 9
}
enum | _NV_COMPUTE_SHADER_DERIVATIVES { NV_COMPUTE_SHADER_DERIVATIVE_NONE = 0 , NV_COMPUTE_SHADER_DERIVATIVE_GROUP_LINEAR = 1 , NV_COMPUTE_SHADER_DERIVATIVE_GROUP_QUADS = 2 }
enum | NV_D3D12_HEAP_FLAGS { NV_D3D12_HEAP_FLAG_NONE = 0 , NV_D3D12_HEAP_FLAG_CPUVISIBLE_VIDMEM = 1 }
enum | NV_D3D12_RESOURCE_FLAGS { NV_D3D12_RESOURCE_FLAG_NONE = 0 , NV_D3D12_RESOURCE_FLAG_HTEX = 1 , NV_D3D12_RESOURCE_FLAG_CPUVISIBLE_VIDMEM = 2 }
enum | _IMPLICIT_SLI_CONTROL { DISABLE_IMPLICIT_SLI = 0 , ENABLE_IMPLICIT_SLI = 1 }
enum | NV_SMP_ASSIST_TYPE { NV_SMP_ASSIST_NONE = 0 , NV_SMP_ASSIST_MRS = 1 , NV_SMP_ASSIST_LMS = 2 , NV_SMP_ASSIST_NUM_TYPES }
enum NV_LATENCY_MARKER_TYPE {
SIMULATION_START = 0 , SIMULATION_END = 1 , RENDERSUBMIT_START = 2 , RENDERSUBMIT_END = 3 ,
PRESENT_START = 4 , PRESENT_END = 5 , INPUT_SAMPLE = 6 , TRIGGER_FLASH = 7 ,
PC_LATENCY_PING = 8 , OUT_OF_BAND_RENDERSUBMIT_START = 9 , OUT_OF_BAND_RENDERSUBMIT_END = 10 , OUT_OF_BAND_PRESENT_START = 11 ,
OUT_OF_BAND_PRESENT_END = 12
}
enum | NV_OUT_OF_BAND_CQ_TYPE { OUT_OF_BAND_RENDER = 0 , OUT_OF_BAND_PRESENT = 1 , OUT_OF_BAND_IGNORE = 2 }
enum | _NVAPI_D3D12_RAYTRACING_THREAD_REORDERING_CAPS { NVAPI_D3D12_RAYTRACING_THREAD_REORDERING_CAP_NONE = 0x0 , NVAPI_D3D12_RAYTRACING_THREAD_REORDERING_CAP_STANDARD = NV_BIT(0) }
enum | _NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_CAPS { NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_CAP_NONE = 0x0 , NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_CAP_STANDARD = NV_BIT(0) }
enum | _NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_CAPS { NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_CAP_NONE = 0x0 , NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_CAP_STANDARD = NV_BIT(0) }
enum | _NVAPI_D3D12_RAYTRACING_CAPS_TYPE { NVAPI_D3D12_RAYTRACING_CAPS_TYPE_THREAD_REORDERING = 0 , NVAPI_D3D12_RAYTRACING_CAPS_TYPE_OPACITY_MICROMAP = 1 , NVAPI_D3D12_RAYTRACING_CAPS_TYPE_DISPLACEMENT_MICROMAP = 2 , NVAPI_D3D12_RAYTRACING_CAPS_TYPE_INVALID = -1 }
enum | _NVAPI_D3D12_RAYTRACING_VALIDATION_FLAGS { NVAPI_D3D12_RAYTRACING_VALIDATION_FLAG_NONE = 0x0 }
enum | _NVAPI_D3D12_RAYTRACING_VALIDATION_MESSAGE_SEVERITY { NVAPI_D3D12_RAYTRACING_VALIDATION_MESSAGE_SEVERITY_ERROR = 0x0 , NVAPI_D3D12_RAYTRACING_VALIDATION_MESSAGE_SEVERITY_WARNING = 0x1 }
enum | _NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_BUILD_FLAGS { NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_BUILD_FLAG_NONE = 0x0 , NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_BUILD_FLAG_PREFER_FAST_TRACE = NV_BIT(0) , NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_BUILD_FLAG_PREFER_FAST_BUILD = NV_BIT(1) }
enum | _NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_FORMAT { NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_FORMAT_DC1_64_TRIS_64_BYTES = 0x1 , NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_FORMAT_DC1_256_TRIS_128_BYTES = 0x2 , NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_FORMAT_DC1_1024_TRIS_128_BYTES = 0x3 }
enum | _NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_ARRAY_BUILD_FLAGS { NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_ARRAY_BUILD_FLAG_NONE = 0x0 , NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_ARRAY_BUILD_FLAG_PREFER_FAST_TRACE = NV_BIT(0) , NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_ARRAY_BUILD_FLAG_PREFER_FAST_BUILD = NV_BIT(1) }
enum | _NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_FORMAT { NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_FORMAT_OC1_2_STATE = 0x1 , NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_FORMAT_OC1_4_STATE = 0x2 }
enum | _NVAPI_D3D12_PIPELINE_CREATION_STATE_FLAGS { NVAPI_D3D12_PIPELINE_CREATION_STATE_FLAGS_NONE = 0 , NVAPI_D3D12_PIPELINE_CREATION_STATE_FLAGS_ENABLE_OMM_SUPPORT = NV_BIT(0) , NVAPI_D3D12_PIPELINE_CREATION_STATE_FLAGS_ENABLE_DMM_SUPPORT = NV_BIT(1) }
enum | _NVAPI_D3D12_SERIALIZED_DATA_TYPE_EX { NVAPI_D3D12_SERIALIZED_DATA_RAYTRACING_ACCELERATION_STRUCTURE_EX = 0x0 , NVAPI_D3D12_SERIALIZED_DATA_RAYTRACING_OPACITY_MICROMAP_ARRAY_EX = 0x1 , NVAPI_D3D12_SERIALIZED_DATA_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_EX = 0x2 }
enum _NVAPI_D3D12_RAYTRACING_ACCELERATION_STRUCTURE_BUILD_FLAGS_EX {
NVAPI_D3D12_RAYTRACING_ACCELERATION_STRUCTURE_BUILD_FLAG_NONE_EX = 0x0 , NVAPI_D3D12_RAYTRACING_ACCELERATION_STRUCTURE_BUILD_FLAG_ALLOW_UPDATE_EX = NV_BIT(0) , NVAPI_D3D12_RAYTRACING_ACCELERATION_STRUCTURE_BUILD_FLAG_ALLOW_COMPACTION_EX = NV_BIT(1) , NVAPI_D3D12_RAYTRACING_ACCELERATION_STRUCTURE_BUILD_FLAG_PREFER_FAST_TRACE_EX = NV_BIT(2) ,
NVAPI_D3D12_RAYTRACING_ACCELERATION_STRUCTURE_BUILD_FLAG_PREFER_FAST_BUILD_EX = NV_BIT(3) , NVAPI_D3D12_RAYTRACING_ACCELERATION_STRUCTURE_BUILD_FLAG_MINIMIZE_MEMORY_EX = NV_BIT(4) , NVAPI_D3D12_RAYTRACING_ACCELERATION_STRUCTURE_BUILD_FLAG_PERFORM_UPDATE_EX = NV_BIT(5) , NVAPI_D3D12_RAYTRACING_ACCELERATION_STRUCTURE_BUILD_FLAG_ALLOW_OMM_UPDATE_EX = NV_BIT(6) ,
NVAPI_D3D12_RAYTRACING_ACCELERATION_STRUCTURE_BUILD_FLAG_ALLOW_DISABLE_OMMS_EX = NV_BIT(7) , NVAPI_D3D12_RAYTRACING_ACCELERATION_STRUCTURE_BUILD_FLAG_ALLOW_OMM_OPACITY_STATES_UPDATE_EX = NV_BIT(8) , NVAPI_D3D12_RAYTRACING_ACCELERATION_STRUCTURE_BUILD_FLAG_ALLOW_DATA_ACCESS_EX = NV_BIT(9)
}
enum | _NVAPI_D3D12_RAYTRACING_GEOMETRY_TYPE_EX { NVAPI_D3D12_RAYTRACING_GEOMETRY_TYPE_TRIANGLES_EX = 0x0 , NVAPI_D3D12_RAYTRACING_GEOMETRY_TYPE_PROCEDURAL_PRIMITIVE_AABBS_EX = 0x1 , NVAPI_D3D12_RAYTRACING_GEOMETRY_TYPE_OMM_TRIANGLES_EX = 0x2 , NVAPI_D3D12_RAYTRACING_GEOMETRY_TYPE_DMM_TRIANGLES_EX = 0x3 }
enum | _NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_SPECIAL_INDEX { NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_SPECIAL_INDEX_FULLY_TRANSPARENT = -1 , NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_SPECIAL_INDEX_FULLY_OPAQUE = -2 , NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_SPECIAL_INDEX_FULLY_UNKNOWN_TRANSPARENT = -3 , NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_SPECIAL_INDEX_FULLY_UNKNOWN_OPAQUE = -4 }
enum | _NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_PRIMITIVE_FLAGS { NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_PRIMITIVE_FLAG_DECIMATE_01 = NV_BIT(0) , NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_PRIMITIVE_FLAG_DECIMATE_12 = NV_BIT(1) , NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_PRIMITIVE_FLAG_DECIMATE_20 = NV_BIT(2) }
enum _NVAPI_D3D12_RAYTRACING_INSTANCE_FLAGS_EX {
NVAPI_D3D12_RAYTRACING_INSTANCE_FLAG_NONE_EX = 0x0 , NVAPI_D3D12_RAYTRACING_INSTANCE_FLAG_TRIANGLE_CULL_DISABLE_EX = NV_BIT(0) , NVAPI_D3D12_RAYTRACING_INSTANCE_FLAG_TRIANGLE_FRONT_COUNTERCLOCKWISE_EX = NV_BIT(1) , NVAPI_D3D12_RAYTRACING_INSTANCE_FLAG_FORCE_OPAQUE_EX = NV_BIT(2) ,
NVAPI_D3D12_RAYTRACING_INSTANCE_FLAG_FORCE_NON_OPAQUE_EX = NV_BIT(3) , NVAPI_D3D12_RAYTRACING_INSTANCE_FLAG_FORCE_OMM_2_STATE_EX = NV_BIT(4) , NVAPI_D3D12_RAYTRACING_INSTANCE_FLAG_DISABLE_OMMS_EX = NV_BIT(5)
}
enum | _NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_ARRAY_POSTBUILD_INFO_TYPE { NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_ARRAY_POSTBUILD_INFO_CURRENT_SIZE = 0x0 }
enum | _NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_POSTBUILD_INFO_TYPE { NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_POSTBUILD_INFO_CURRENT_SIZE = 0x0 }
enum | _NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_STATE { NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_STATE_TRANSPARENT = 0 , NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_STATE_OPAQUE = 1 , NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_STATE_UNKNOWN_TRANSPARENT = 2 , NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_STATE_UNKNOWN_OPAQUE = 3 }
enum _NVAPI_RAY_FLAGS_EX {
NVAPI_RAY_FLAG_NONE_EX = 0x0 , NVAPI_RAY_FLAG_FORCE_OPAQUE_EX = NV_BIT( 0) , NVAPI_RAY_FLAG_FORCE_NON_OPAQUE_EX = NV_BIT( 1) , NVAPI_RAY_FLAG_ACCEPT_FIRST_HIT_AND_END_SEARCH_EX = NV_BIT( 2) ,
NVAPI_RAY_FLAG_SKIP_CLOSEST_HIT_SHADER_EX = NV_BIT( 3) , NVAPI_RAY_FLAG_CULL_BACK_FACING_TRIANGLES_EX = NV_BIT( 4) , NVAPI_RAY_FLAG_CULL_FRONT_FACING_TRIANGLES_EX = NV_BIT( 5) , NVAPI_RAY_FLAG_CULL_OPAQUE_EX = NV_BIT( 6) ,
NVAPI_RAY_FLAG_CULL_NON_OPAQUE_EX = NV_BIT( 7) , NVAPI_RAY_FLAG_SKIP_TRIANGLES_EX = NV_BIT( 8) , NVAPI_RAY_FLAG_SKIP_PROCEDURAL_PRIMITIVES_EX = NV_BIT( 9) , NVAPI_RAY_FLAG_FORCE_OMM_2_STATE_EX = NV_BIT(10)
}
enum NVAPI_DEVICE_FEATURE_LEVEL {
NVAPI_DEVICE_FEATURE_LEVEL_NULL = -1 , NVAPI_DEVICE_FEATURE_LEVEL_10_0 = 0 , NVAPI_DEVICE_FEATURE_LEVEL_10_0_PLUS = 1 , NVAPI_DEVICE_FEATURE_LEVEL_10_1 = 2 ,
NVAPI_DEVICE_FEATURE_LEVEL_11_0 = 3
}
enum | _NVAPI_D3D_SETRESOURCEHINT_CATEGORY { NVAPI_D3D_SRH_CATEGORY_SLI = 1 }
enum | _NVAPI_D3D_SETRESOURCEHINT_SLI { NVAPI_D3D_SRH_SLI_APP_CONTROLLED_INTERFRAME_CONTENT_SYNC = 1 , NVAPI_D3D_SRH_SLI_ASK_FOR_BROADCAST_USAGE = 2 , NVAPI_D3D_SRH_SLI_RESPECT_DRIVER_INTERFRAME_CONTENT_SYNC = 3 }
enum | _NVAPI_D3D_RESOURCERENDERING_FLAG { NVAPI_D3D_RR_FLAG_DEFAULTS = 0x00000000 , NVAPI_D3D_RR_FLAG_FORCE_DISCARD_CONTENT = 0x00000001 , NVAPI_D3D_RR_FLAG_FORCE_KEEP_CONTENT = 0x00000002 , NVAPI_D3D_RR_FLAG_MULTI_FRAME = 0x00000004 }

Functions

NVAPI_INTERFACE | NvAPI_D3D9_RegisterResource (IDirect3DResource9 *pResource)
NVAPI_INTERFACE | NvAPI_D3D9_UnregisterResource (IDirect3DResource9 *pResource)
NVAPI_INTERFACE | NvAPI_D3D9_AliasSurfaceAsTexture (IDirect3DDevice9 *pDev, IDirect3DSurface9 *pSurface, IDirect3DTexture9 **ppTexture, DWORD dwFlag)
NVAPI_INTERFACE | NvAPI_D3D9_StretchRectEx (IDirect3DDevice9 *pDevice, IDirect3DResource9 *pSourceResource, CONST RECT *pSourceRect, IDirect3DResource9 *pDestResource, CONST RECT *pDestRect, D3DTEXTUREFILTERTYPE Filter)
NVAPI_INTERFACE | NvAPI_D3D9_ClearRT (IDirect3DDevice9 *pDevice, NvU32 dwNumRects, CONST RECT *pRects, float r, float g, float b, float a)
NVAPI_INTERFACE | NvAPI_D3D9_GetSurfaceHandle (IDirect3DSurface9 *pSurface, NVDX_ObjectHandle *pHandle)
NVAPI_INTERFACE | NvAPI_D3D10_SetDepthBoundsTest (ID3D10Device *pDev, NvU32 bEnable, float fMinDepth, float fMaxDepth)
NVAPI_INTERFACE | NvAPI_D3D11_IsNvShaderExtnOpCodeSupported (__in IUnknown *pDev, __in NvU32 opCode, __out bool *pSupported)
NVAPI_INTERFACE | NvAPI_D3D11_SetNvShaderExtnSlot (__in IUnknown *pDev, __in NvU32 uavSlot)
NVAPI_INTERFACE | NvAPI_D3D12_SetNvShaderExtnSlotSpace (__in IUnknown *pDev, __in NvU32 uavSlot, __in NvU32 uavSpace)
NVAPI_INTERFACE | NvAPI_D3D12_SetNvShaderExtnSlotSpaceLocalThread (__in IUnknown *pDev, __in NvU32 uavSlot, __in NvU32 uavSpace)
NVAPI_INTERFACE | NvAPI_D3D11_SetNvShaderExtnSlotLocalThread (__in IUnknown *pDev, __in NvU32 uavSlot)
NVAPI_INTERFACE | NvAPI_D3D11_BeginUAVOverlap (__in IUnknown *pDeviceOrContext)
NVAPI_INTERFACE | NvAPI_D3D11_EndUAVOverlap (__in IUnknown *pDeviceOrContext)
NVAPI_INTERFACE | NvAPI_D3D_SetFPSIndicatorState (IUnknown *pDev, NvU8 doEnable)
NVAPI_INTERFACE | NvAPI_D3D9_Present (IDirect3DDevice9 *pDevice, IDirect3DSwapChain9 *pSwapChain, const RECT *pSourceRect, const RECT *pDestRect, HWND hDestWindowOverride, const RGNDATA *pDirtyRegion)
NVAPI_INTERFACE | NvAPI_D3D9_QueryFrameCount (IDirect3DDevice9 *pDevice, NvU32 *pFrameCount)
NVAPI_INTERFACE | NvAPI_D3D9_ResetFrameCount (IDirect3DDevice9 *pDevice)
NVAPI_INTERFACE | NvAPI_D3D9_QueryMaxSwapGroup (IDirect3DDevice9 *pDevice, NvU32 *pMaxGroups, NvU32 *pMaxBarriers)
NVAPI_INTERFACE | NvAPI_D3D9_QuerySwapGroup (IDirect3DDevice9 *pDevice, IDirect3DSwapChain9 *pSwapChain, NvU32 *pSwapGroup, NvU32 *pSwapBarrier)
NVAPI_INTERFACE | NvAPI_D3D9_JoinSwapGroup (IDirect3DDevice9 *pDevice, IDirect3DSwapChain9 *pSwapChain, NvU32 group, BOOL blocking)
NVAPI_INTERFACE | NvAPI_D3D9_BindSwapBarrier (IDirect3DDevice9 *pDevice, NvU32 group, NvU32 barrier)
NVAPI_INTERFACE | NvAPI_D3D_SetVerticalSyncMode (__in IUnknown *pDevice, __in NVAPI_VSYNC_MODE vsyncMode)
NVAPI_INTERFACE | NvAPI_D3D1x_Present (IUnknown *pDevice, IDXGISwapChain *pSwapChain, UINT SyncInterval, UINT Flags)
NVAPI_INTERFACE | NvAPI_D3D1x_QueryFrameCount (IUnknown *pDevice, NvU32 *pFrameCount)
NVAPI_INTERFACE | NvAPI_D3D1x_ResetFrameCount (IUnknown *pDevice)
NVAPI_INTERFACE | NvAPI_D3D1x_QueryMaxSwapGroup (IUnknown *pDevice, NvU32 *pMaxGroups, NvU32 *pMaxBarriers)
NVAPI_INTERFACE | NvAPI_D3D1x_QuerySwapGroup (IUnknown *pDevice, IDXGISwapChain *pSwapChain, NvU32 *pSwapGroup, NvU32 *pSwapBarrier)
NVAPI_INTERFACE | NvAPI_D3D1x_JoinSwapGroup (IUnknown *pDevice, IDXGISwapChain *pSwapChain, NvU32 group, BOOL blocking)
NVAPI_INTERFACE | NvAPI_D3D1x_BindSwapBarrier (IUnknown *pDevice, NvU32 group, NvU32 barrier)
NVAPI_INTERFACE | NvAPI_D3D12_QueryPresentBarrierSupport (__in ID3D12Device *pDevice, __out bool *pSupported)
NVAPI_INTERFACE | NvAPI_D3D12_CreatePresentBarrierClient (__in ID3D12Device *pDevice, __in IDXGISwapChain *pSwapChain, __out NvPresentBarrierClientHandle *pPresentBarrierClient)
NVAPI_INTERFACE | NvAPI_D3D12_RegisterPresentBarrierResources (__in NvPresentBarrierClientHandle presentBarrierClient, __in ID3D12Fence *pFence, __in ID3D12Resource **ppResources, __in NvU32 numResources)
NVAPI_INTERFACE | NvAPI_D3D12_CreateDDisplayPresentBarrierClient (__in ID3D12Device *pDevice, __in NvU32 sourceId, __out NvPresentBarrierClientHandle *pPresentBarrierClient)
NVAPI_INTERFACE | NvAPI_D3D11_CreateRasterizerState (__in ID3D11Device *pDevice, __in const NvAPI_D3D11_RASTERIZER_DESC_EX *pRasterizerDesc, __out ID3D11RasterizerState **ppRasterizerState)
NVAPI_INTERFACE | NvAPI_D3D11_CheckFeatureSupport (__in ID3D11Device *pDevice, __in NV_D3D11_FEATURE Feature, __out void *pFeatureSupportData, __in UINT FeatureSupportDataSize)
NVAPI_INTERFACE | NvAPI_D3D11_CreateImplicitMSAATexture2D (__in ID3D11Device *pDevice, __in const D3D11_TEXTURE2D_DESC *pDesc, __out ID3D11Texture2D **ppTexture2D)
NVAPI_INTERFACE | NvAPI_D3D12_CreateCommittedImplicitMSAATexture2D (__in ID3D12Device *pDevice, __in const D3D12_HEAP_PROPERTIES *pHeapProperties, D3D12_HEAP_FLAGS HeapFlags, __in const D3D12_RESOURCE_DESC *pDesc, D3D12_RESOURCE_STATES InitialResourceState, __in_opt const D3D12_CLEAR_VALUE *pOptimizedClearValue, REFIID riidResource, __out void **ppvResource)
NVAPI_INTERFACE | NvAPI_D3D11_ResolveSubresourceRegion (__in ID3D11Device *pDevice, __in ID3D11Texture2D *pDstResource, __in UINT DstSubresource, __in UINT DstX, __in UINT DstY, __in ID3D11Texture2D *pSrcResource, __in UINT SrcSubresource, __in_opt const RECT *pSrcRect, __in DXGI_FORMAT Format, __in NV_RESOLVE_MODE ResolveMode)
NVAPI_INTERFACE | NvAPI_D3D12_ResolveSubresourceRegion (__in ID3D12GraphicsCommandList1 *pCommandList, __in ID3D12Resource *pDstResource, __in UINT DstSubresource, __in UINT DstX, __in UINT DstY, __in ID3D12Resource *pSrcResource, __in UINT SrcSubresource, __in_opt RECT *pSrcRect, __in DXGI_FORMAT Format, __in NV_RESOLVE_MODE ResolveMode)
NVAPI_INTERFACE | NvAPI_D3D11_AliasMSAATexture2DAsNonMSAA (__in ID3D11Device *pDevice, __in ID3D11Texture2D *pInputTex, __out ID3D11Texture2D **ppOutTex)
NVAPI_INTERFACE | NvAPI_D3D11_DecompressView (__in ID3D11Device *pDevice, __in ID3D11DeviceContext *pDeviceContext, __in ID3D11View *pView)
NVAPI_INTERFACE | NvAPI_D3D12_CreateGraphicsPipelineState (__in ID3D12Device *pDevice, __in const D3D12_GRAPHICS_PIPELINE_STATE_DESC *pPSODesc, NvU32 numExtensions, __in const NVAPI_D3D12_PSO_EXTENSION_DESC **ppExtensions, __out ID3D12PipelineState **ppPSO)
NVAPI_INTERFACE | NvAPI_D3D12_CreateComputePipelineState (__in ID3D12Device *pDevice, __in const D3D12_COMPUTE_PIPELINE_STATE_DESC *pPSODesc, NvU32 numExtensions, __in const NVAPI_D3D12_PSO_EXTENSION_DESC **ppExtensions, __out ID3D12PipelineState **ppPSO)
NVAPI_INTERFACE | NvAPI_D3D12_SetDepthBoundsTestValues (__in ID3D12GraphicsCommandList *pCommandList, __in const float minDepth, __in const float maxDepth)
NVAPI_INTERFACE | NvAPI_D3D12_CreateReservedResource (__in ID3D12Device *pDevice, __in const D3D12_RESOURCE_DESC *pDesc, __in D3D12_RESOURCE_STATES InitialState, __in const D3D12_CLEAR_VALUE *pOptimizedClearValue, __in REFIID riid, __out void **ppvResource, __in bool bTexture2DArrayMipPack, __in ID3D12Heap *pHeap)
NVAPI_INTERFACE | NvAPI_D3D12_CreateHeap (__in ID3D12Device *pDevice, __in const D3D12_HEAP_DESC *pDesc, __in REFIID riid, __out void **ppvHeap)
NVAPI_INTERFACE | NvAPI_D3D12_QueryCpuVisibleVidmem (__in ID3D12Device *pDevice, __out NvU64 *pTotalBytes, __out NvU64 *pFreeBytes)
NVAPI_INTERFACE | NvAPI_D3D12_ReservedResourceGetDesc (__in ID3D12Resource *pReservedResource, __out D3D12_RESOURCE_DESC *pDesc)
NVAPI_INTERFACE | NvAPI_D3D12_UpdateTileMappings (__in ID3D12CommandQueue *pCommandQueue, __in ID3D12Resource *pResource, __in UINT NumResourceRegions, __in const D3D12_TILED_RESOURCE_COORDINATE *pResourceRegionStartCoordinates, __in const D3D12_TILE_REGION_SIZE *pResourceRegionSizes, __in ID3D12Heap *pHeap, __in UINT NumRanges, __in const D3D12_TILE_RANGE_FLAGS *pRangeFlags, __in const UINT *pHeapRangeStartOffsets, __in const UINT *pRangeTileCounts, __in D3D12_TILE_MAPPING_FLAGS Flags)
NVAPI_INTERFACE | NvAPI_D3D12_CopyTileMappings (__in ID3D12CommandQueue *pCommandQueue, __in ID3D12Resource *pDstResource, __in const D3D12_TILED_RESOURCE_COORDINATE *pDstRegionStartCoordinate, __in ID3D12Resource *pSrcResource, __in const D3D12_TILED_RESOURCE_COORDINATE *pSrcRegionStartCoordinate, __in const D3D12_TILE_REGION_SIZE *pRegionSize, __in D3D12_TILE_MAPPING_FLAGS Flags)
NVAPI_INTERFACE | NvAPI_D3D12_ResourceAliasingBarrier (__in ID3D12GraphicsCommandList *pCommandList, __in UINT NumBarriers, __in const D3D12_RESOURCE_BARRIER *pBarriers)
NVAPI_INTERFACE | NvAPI_D3D11_EnumerateMetaCommands (__in ID3D11Device *pDevice, __inout NvU32 *pNumMetaCommands, __out_ecount_opt(*pNumMetaCommands) NVAPI_META_COMMAND_DESC *pDescs)
NVAPI_INTERFACE | NvAPI_D3D11_InitializeMetaCommand (__in ID3D11DeviceContext *pDeviceContext, __in ID3D11NvMetaCommand *pMetaCommand, __in_bcount(InitializationParametersDataSize) const void *pInitializationParametersData, __in NvU32 InitializationParametersDataSize)
NVAPI_INTERFACE | NvAPI_D3D11_ExecuteMetaCommand (__in ID3D11DeviceContext *pDeviceContext, __in ID3D11NvMetaCommand *pMetaCommand, __in_bcount(ExecutionParametersDataSize) const void *pExecutionParametersData, __in NvU32 ExecutionParametersDataSize)
NVAPI_INTERFACE | NvAPI_D3D12_EnumerateMetaCommands (__in ID3D12Device *pDevice, __inout NvU32 *pNumMetaCommands, __out_ecount_opt(*pNumMetaCommands) NVAPI_META_COMMAND_DESC *pDescs)
NVAPI_INTERFACE | NvAPI_D3D12_InitializeMetaCommand (__in ID3D12GraphicsCommandList *pCommandlist, __in ID3D12NvMetaCommand *pMetaCommand, __in_bcount(InitializationParametersDataSize) const void *pInitializationParametersData, __in NvU32 InitializationParametersDataSize)
NVAPI_INTERFACE | NvAPI_D3D12_ExecuteMetaCommand (__in ID3D12GraphicsCommandList *pCommandlist, __in ID3D12NvMetaCommand *pMetaCommand, __in_bcount(ExecutionParametersDataSize) const void *pExecutionParametersData, __in NvU32 ExecutionParametersDataSize)
NVAPI_INTERFACE | NvAPI_D3D12_GetCopyableFootprints (__in ID3D12Device *pDevice, __in const D3D12_RESOURCE_DESC *pResourceDesc, __in const NV_RESOURCE_PARAMS *pNVResourceParams, __in UINT FirstSubresource, __in UINT NumSubresources, __in UINT64 BaseOffset, __out_ecount_opt(NumSubresources) D3D12_PLACED_SUBRESOURCE_FOOTPRINT *pLayouts, __out_ecount_opt(NumSubresources) UINT *pNumRows, __out_ecount_opt(NumSubresources) UINT64 *pRowSizeInBytes, __out_opt UINT64 *pTotalBytes)
NVAPI_INTERFACE | NvAPI_D3D12_CopyTextureRegion (__in ID3D12GraphicsCommandList *pCommandList, __in const D3D12_TEXTURE_COPY_LOCATION *pDst, __in UINT DstX, __in UINT DstY, __in UINT DstZ, __in const D3D12_TEXTURE_COPY_LOCATION *pSrc, __in_opt const D3D12_BOX *pSrcBox)
NVAPI_INTERFACE | NvAPI_D3D12_IsNvShaderExtnOpCodeSupported (__in ID3D12Device *pDevice, __in NvU32 opCode, __out bool *pSupported)
NVAPI_INTERFACE | NvAPI_D3D12_GetOptimalThreadCountForMesh (__in ID3D12Device *pDevice, __out NvU32 *pThreadCount)
NVAPI_INTERFACE | NvAPI_D3D_IsGSyncCapable (__in IUnknown *pDeviceOrContext, __in NVDX_ObjectHandle primarySurface, __out BOOL *pIsGsyncCapable)
NVAPI_INTERFACE | NvAPI_D3D_IsGSyncActive (__in IUnknown *pDeviceOrContext, __in NVDX_ObjectHandle primarySurface, __out BOOL *pIsGsyncActive)
NVAPI_INTERFACE | NvAPI_D3D1x_DisableShaderDiskCache (IUnknown *pDevice)
NVAPI_INTERFACE | NvAPI_D3D11_MultiGPU_GetCaps (__inout PNV_MULTIGPU_CAPS pMultiGPUCaps)
NVAPI_INTERFACE | NvAPI_D3D11_MultiGPU_Init (__in bool bEnable)
NVAPI_INTERFACE | NvAPI_D3D11_CreateMultiGPUDevice (__in ID3D11Device *pDevice, __in ULONG version, __out ULONG *currentVersion, __out ID3D11MultiGPUDevice **ppD3D11MultiGPUDevice, __in UINT maxGpus=ALL_GPUS)
NVAPI_INTERFACE | NvAPI_D3D_QuerySinglePassStereoSupport (__in IUnknown *pDevice, __inout NV_QUERY_SINGLE_PASS_STEREO_SUPPORT_PARAMS *pQuerySinglePassStereoSupportedParams)
NVAPI_INTERFACE | NvAPI_D3D_SetSinglePassStereoMode (__in IUnknown *pDevOrContext, __in NvU32 numViews, __in NvU32 renderTargetIndexOffset, __in NvU8 independentViewportMaskEnable)
NVAPI_INTERFACE | NvAPI_D3D12_QuerySinglePassStereoSupport (__in ID3D12Device *pDevice, __inout NV_QUERY_SINGLE_PASS_STEREO_SUPPORT_PARAMS *pQuerySinglePassStereoSupportedParams)
NVAPI_INTERFACE | NvAPI_D3D12_SetSinglePassStereoMode (__in ID3D12GraphicsCommandList *pCommandList, __in NvU32 numViews, __in NvU32 renderTargetIndexOffset, __in NvU8 independentViewportMaskEnable)
NVAPI_INTERFACE | NvAPI_D3D_QueryMultiViewSupport (__in IUnknown *pDevice, __inout NV_QUERY_MULTIVIEW_SUPPORT_PARAMS *pQueryMultiViewSupportedParams)
NVAPI_INTERFACE | NvAPI_D3D_SetMultiViewMode (__in IUnknown *pDevOrContext, __in NV_MULTIVIEW_PARAMS *pMultiViewParams)
NVAPI_INTERFACE | NvAPI_D3D_QueryModifiedWSupport (__in IUnknown *pDev, __inout NV_QUERY_MODIFIED_W_SUPPORT_PARAMS *pQueryModifiedWSupportedParams)
NVAPI_INTERFACE | NvAPI_D3D_SetModifiedWMode (__in IUnknown *pDevOrContext, __in NV_MODIFIED_W_PARAMS *psModifiedWParams)
NVAPI_INTERFACE | NvAPI_D3D12_QueryModifiedWSupport (__in ID3D12Device *pDevice, __inout NV_QUERY_MODIFIED_W_SUPPORT_PARAMS *pQueryModifiedWSupportedParams)
NVAPI_INTERFACE | NvAPI_D3D12_SetModifiedWMode (__in ID3D12GraphicsCommandList *pCommandList, __in NV_MODIFIED_W_PARAMS *pModifiedWParams)
DECLARE_INTERFACE (ID3DLateLatchObject_V1)
NVAPI_INTERFACE | NvAPI_D3D_CreateLateLatchObject (__in IUnknown *pDevice, __inout NV_D3D_LATELATCH_OBJECT_DESC *pLateLatchObjectDesc)
NVAPI_INTERFACE | NvAPI_D3D_QueryLateLatchSupport (__in IUnknown *pDevice, __inout NV_QUERY_LATELATCH_SUPPORT_PARAMS *pQueryLateLatchSupportParams)
NVAPI_INTERFACE | NvAPI_D3D_RegisterDevice (__in IUnknown *pDev)
NVAPI_INTERFACE | NvAPI_D3D11_MultiDrawInstancedIndirect (__in ID3D11DeviceContext *pDevContext11, __in NvU32 drawCount, __in ID3D11Buffer *pBuffer, __in NvU32 alignedByteOffsetForArgs, __in NvU32 alignedByteStrideForArgs)
NVAPI_INTERFACE | NvAPI_D3D11_MultiDrawIndexedInstancedIndirect (__in ID3D11DeviceContext *pDevContext11, __in NvU32 drawCount, __in ID3D11Buffer *pBuffer, __in NvU32 alignedByteOffsetForArgs, __in NvU32 alignedByteStrideForArgs)
NVAPI_INTERFACE | NvAPI_D3D_ImplicitSLIControl (__in IMPLICIT_SLI_CONTROL implicitSLIControl)
NVAPI_INTERFACE | NvAPI_D3D12_GetNeedsAppFPBlendClamping (__in ID3D12Device *pDevice, __out bool *pAppClampNeeded)
NVAPI_INTERFACE | NvAPI_D3D12_UseDriverHeapPriorities (__in ID3D12Device *pDevice)
NVAPI_INTERFACE | NvAPI_D3D12_Mosaic_GetCompanionAllocations (__inout NV_D3D12_MOSAIC_GETCOMPANIONALLOCATIONS *params)
NVAPI_INTERFACE | NvAPI_D3D12_Mosaic_GetViewportAndGpuPartitions (__inout NV_D3D12_MOSAIC_GETVIEWPORTANDGPUPARTITIONS *params)
NVAPI_INTERFACE | NvAPI_D3D1x_GetGraphicsCapabilities (__in IUnknown *pDevice, __in NvU32 structVersion, __inout NV_D3D1x_GRAPHICS_CAPS *pGraphicsCaps)
NVAPI_INTERFACE | NvAPI_D3D12_GetGraphicsCapabilities (__in IUnknown *pDevice, __in NvU32 structVersion, __inout NV_D3D12_GRAPHICS_CAPS *pGraphicsCaps)
NVAPI_INTERFACE | NvAPI_D3D11_RSSetExclusiveScissorRects (__in IUnknown *pContext, __in NV_D3D11_EXCLUSIVE_SCISSOR_RECTS_DESC *pExclusiveScissorRectsDesc)
NVAPI_INTERFACE | NvAPI_D3D11_RSSetViewportsPixelShadingRates (__in IUnknown *pContext, __in NV_D3D11_VIEWPORTS_SHADING_RATE_DESC *pShadingRateDesc)
NVAPI_INTERFACE | NvAPI_D3D11_CreateShadingRateResourceView (__in ID3D11Device *pDevice, __in ID3D11Resource *pShadingRateResource, __in NV_D3D11_SHADING_RATE_RESOURCE_VIEW_DESC *pShadingRateResourceViewDesc, __out ID3D11NvShadingRateResourceView **ppShadingRateResourceView)
NVAPI_INTERFACE | NvAPI_D3D11_RSSetShadingRateResourceView (__in IUnknown *pContext, __in ID3D11NvShadingRateResourceView *pShadingRateResourceView)
NVAPI_INTERFACE | NvAPI_D3D11_RSGetPixelShadingRateSampleOrder (__in IUnknown *pContext, __out NV_PIXEL_SHADING_RATE_SAMPLE_ORDER_TABLE *pSampleOrderTable)
NVAPI_INTERFACE | NvAPI_D3D11_RSSetPixelShadingRateSampleOrder (__in IUnknown *pContext, __in NV_PIXEL_SHADING_RATE_SAMPLE_ORDER_TABLE *pSampleOrderTable)
NVAPI_INTERFACE | NvAPI_D3D_InitializeVRSHelper (__in IUnknown *pDevice, __inout NV_VRS_HELPER_INIT_PARAMS *pInitializeVRSHelperParams)
NVAPI_INTERFACE | NvAPI_D3D_InitializeNvGazeHandler (__in IUnknown *pDevice, __inout NV_GAZE_HANDLER_INIT_PARAMS *pInitializeNvGazeHandlerParams)
NVAPI_INTERFACE | NvAPI_D3D_InitializeSMPAssist (__in IUnknown *pDevice, __inout NV_SMP_ASSIST_INITIALIZE_PARAMS *pSMPAssistInitParams)
NVAPI_INTERFACE | NvAPI_D3D_QuerySMPAssistSupport (__in IUnknown *pDev, __inout NV_QUERY_SMP_ASSIST_SUPPORT_PARAMS *pQuerySMPAssistSupportParams)
NVAPI_INTERFACE | NvAPI_D3D_GetSleepStatus (__in IUnknown *pDev, __in NV_GET_SLEEP_STATUS_PARAMS *pGetSleepStatusParams)
NVAPI_INTERFACE | NvAPI_D3D_SetSleepMode (__in IUnknown *pDev, __in NV_SET_SLEEP_MODE_PARAMS *pSetSleepModeParams)
NVAPI_INTERFACE | NvAPI_D3D_Sleep (__in IUnknown *pDev)
NVAPI_INTERFACE | NvAPI_D3D_SetReflexSync (__in IUnknown *pDev, __in NV_SET_REFLEX_SYNC_PARAMS *pSetReflexSyncParams)
NVAPI_INTERFACE | NvAPI_D3D_GetLatency (__in IUnknown *pDev, __out NV_LATENCY_RESULT_PARAMS *pGetLatencyParams)
NVAPI_INTERFACE | NvAPI_D3D_SetLatencyMarker (__in IUnknown *pDev, __in NV_LATENCY_MARKER_PARAMS *pSetLatencyMarkerParams)
NVAPI_INTERFACE | NvAPI_D3D12_SetAsyncFrameMarker (__in ID3D12CommandQueue *pCommandQueue, __in NV_ASYNC_FRAME_MARKER_PARAMS *pSetAsyncFrameMarkerParams)
NVAPI_INTERFACE | NvAPI_D3D12_NotifyOutOfBandCommandQueue (__in ID3D12CommandQueue *pCommandQueue, __in NV_OUT_OF_BAND_CQ_TYPE cqType)
NVAPI_INTERFACE | NvAPI_D3D12_SetCreateCommandQueueLowLatencyHint (__in ID3D12Device *pDevice)
NVAPI_INTERFACE | NvAPI_D3D12_GetRaytracingCaps (__in ID3D12Device *pDevice, __in NVAPI_D3D12_RAYTRACING_CAPS_TYPE type, __out void *pData, __in size_t dataSize)
NVAPI_INTERFACE | NvAPI_D3D12_EnableRaytracingValidation (__in ID3D12Device5 *pDevice, __in NVAPI_D3D12_RAYTRACING_VALIDATION_FLAGS flags)
NVAPI_INTERFACE | NvAPI_D3D12_RegisterRaytracingValidationMessageCallback (__in ID3D12Device5 *pDevice, __in NVAPI_D3D12_RAYTRACING_VALIDATION_MESSAGE_CALLBACK pfnMessageCallback, __in_opt void *pUserData, __out void **pHandle)
NVAPI_INTERFACE | NvAPI_D3D12_UnregisterRaytracingValidationMessageCallback (__in ID3D12Device5 *pDevice, __in void *handle)
NVAPI_INTERFACE | NvAPI_D3D12_FlushRaytracingValidationMessages (__in ID3D12Device5 *pDevice)
NVAPI_INTERFACE | NvAPI_D3D12_GetRaytracingDisplacementMicromapArrayPrebuildInfo (__in ID3D12Device5 *pDevice, __inout NVAPI_GET_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PREBUILD_INFO_PARAMS *pParams)
NVAPI_INTERFACE | NvAPI_D3D12_GetRaytracingOpacityMicromapArrayPrebuildInfo (__in ID3D12Device5 *pDevice, __inout NVAPI_GET_RAYTRACING_OPACITY_MICROMAP_ARRAY_PREBUILD_INFO_PARAMS *pParams)
NVAPI_INTERFACE | NvAPI_D3D12_SetCreatePipelineStateOptions (__in ID3D12Device5 *pDevice, __in const NVAPI_D3D12_SET_CREATE_PIPELINE_STATE_OPTIONS_PARAMS *pState)
NVAPI_INTERFACE | NvAPI_D3D12_CheckDriverMatchingIdentifierEx (__in ID3D12Device5 *pDevice, __inout NVAPI_CHECK_DRIVER_MATCHING_IDENTIFIER_EX_PARAMS *pParams)
NVAPI_INTERFACE | NvAPI_D3D12_GetRaytracingAccelerationStructurePrebuildInfoEx (__in ID3D12Device5 *pDevice, __inout NVAPI_GET_RAYTRACING_ACCELERATION_STRUCTURE_PREBUILD_INFO_EX_PARAMS *pParams)
NVAPI_INTERFACE | NvAPI_D3D12_BuildRaytracingOpacityMicromapArray (__in ID3D12GraphicsCommandList4 *pCommandList, __in NVAPI_BUILD_RAYTRACING_OPACITY_MICROMAP_ARRAY_PARAMS *pParams)
NVAPI_INTERFACE | NvAPI_D3D12_RelocateRaytracingOpacityMicromapArray (__in ID3D12GraphicsCommandList4 *pCommandList, __in const NVAPI_RELOCATE_RAYTRACING_OPACITY_MICROMAP_ARRAY_PARAMS *pParams)
NVAPI_INTERFACE | NvAPI_D3D12_BuildRaytracingDisplacementMicromapArray (__in ID3D12GraphicsCommandList4 *pCommandList, __in NVAPI_BUILD_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PARAMS *pParams)
NVAPI_INTERFACE | NvAPI_D3D12_RelocateRaytracingDisplacementMicromapArray (__in ID3D12GraphicsCommandList4 *pCommandList, __in const NVAPI_RELOCATE_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PARAMS *pParams)
NVAPI_INTERFACE | NvAPI_D3D12_EmitRaytracingDisplacementMicromapArrayPostbuildInfo (__in ID3D12GraphicsCommandList4 *pCommandList, __in const NVAPI_EMIT_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_POSTBUILD_INFO_PARAMS *pParams)
NVAPI_INTERFACE | NvAPI_D3D12_EmitRaytracingOpacityMicromapArrayPostbuildInfo (__in ID3D12GraphicsCommandList4 *pCommandList, __in const NVAPI_EMIT_RAYTRACING_OPACITY_MICROMAP_ARRAY_POSTBUILD_INFO_PARAMS *pParams)
NVAPI_INTERFACE | NvAPI_D3D12_BuildRaytracingAccelerationStructureEx (__in ID3D12GraphicsCommandList4 *pCommandList, __in const NVAPI_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_EX_PARAMS *pParams)
NVAPI_INTERFACE | NvAPI_D3D12_QueryWorkstationFeatureProperties (__in ID3D12Device *pDevice, __inout NVAPI_D3D12_WORKSTATION_FEATURE_PROPERTIES_PARAMS *pWorkstationFeatureProperties)
NVAPI_INTERFACE | NvAPI_D3D12_CreateCommittedRDMABuffer (__in ID3D12Device *pDevice, __in NvU64 size, __in NvU32 heapCreationNodeMask, __in NvU32 heapVisibleNodeMask, __in REFIID riidResource, __out void **ppvResource, __out void **ppRDMAAddress)
NVAPI_INTERFACE | NvAPI_DirectD3D12GraphicsCommandList_Create (__in ID3D12GraphicsCommandList *pDXD3D12GraphicsCommandList, __out INvAPI_DirectD3D12GraphicsCommandList **ppReturnD3D12GraphicsCommandList)
NVAPI_INTERFACE | NvAPI_DirectD3D12GraphicsCommandList_Release (__in INvAPI_DirectD3D12GraphicsCommandList *pD3D12GraphicsCommandList)
NVAPI_INTERFACE | NvAPI_DirectD3D12GraphicsCommandList_Reset (__in INvAPI_DirectD3D12GraphicsCommandList *pD3D12GraphicsCommandList)
NVAPI_INTERFACE | NvAPI_D3D_GetObjectHandleForResource (IUnknown *pDevice, IUnknown *pResource, NVDX_ObjectHandle *pHandle)
NVAPI_INTERFACE | NvAPI_D3D11_CreateDevice (IDXGIAdapter *pAdapter, D3D_DRIVER_TYPE DriverType, HMODULE Software, UINT Flags, CONST D3D_FEATURE_LEVEL *pFeatureLevels, UINT FeatureLevels, UINT SDKVersion, ID3D11Device **ppDevice, D3D_FEATURE_LEVEL *pFeatureLevel, ID3D11DeviceContext **ppImmediateContext, NVAPI_DEVICE_FEATURE_LEVEL *pSupportedLevel)
NVAPI_INTERFACE | NvAPI_D3D11_CreateDeviceAndSwapChain (IDXGIAdapter *pAdapter, D3D_DRIVER_TYPE DriverType, HMODULE Software, UINT Flags, CONST D3D_FEATURE_LEVEL *pFeatureLevels, UINT FeatureLevels, UINT SDKVersion, CONST DXGI_SWAP_CHAIN_DESC *pSwapChainDesc, IDXGISwapChain **ppSwapChain, ID3D11Device **ppDevice, D3D_FEATURE_LEVEL *pFeatureLevel, ID3D11DeviceContext **ppImmediateContext, NVAPI_DEVICE_FEATURE_LEVEL *pSupportedLevel)
NVAPI_INTERFACE | NvAPI_D3D11_SetDepthBoundsTest (IUnknown *pDeviceOrContext, NvU32 bEnable, float fMinDepth, float fMaxDepth)
NVAPI_INTERFACE | NvAPI_D3D_GetCurrentSLIState (IUnknown *pDevice, NV_GET_CURRENT_SLI_STATE *pSliState)
NVAPI_INTERFACE | NvAPI_D3D_SetResourceHint (IUnknown *pDev, NVDX_ObjectHandle obj, NVAPI_D3D_SETRESOURCEHINT_CATEGORY dwHintCategory, NvU32 dwHintName, NvU32 *pdwHintValue)
NVAPI_INTERFACE | NvAPI_D3D_BeginResourceRendering (IUnknown *pDeviceOrContext, NVDX_ObjectHandle obj, NvU32 Flags)
NVAPI_INTERFACE | NvAPI_D3D_EndResourceRendering (IUnknown *pDeviceOrContext, NVDX_ObjectHandle obj, NvU32 Flags)

Detailed Description

Macro Definition Documentation

◆ NV_GET_CURRENT_SLI_STATE_VER1

#define NV_GET_CURRENT_SLI_STATE_VER1 MAKE_NVAPI_VERSION(NV_GET_CURRENT_SLI_STATE_V1,1)

◆ NV_MAX_PIXEL_SHADING_RATES

#define NV_MAX_PIXEL_SHADING_RATES 16

See NvAPI_D3D11_RSSetViewportsPixelShadingRates

◆ NVAPI_COPY_ASYNCHRONOUSLY

#define NVAPI_COPY_ASYNCHRONOUSLY 1

SUPPORTED OS: Windows 7 and higher

DESCRIPTION: This function returns ID3D11MultiGPUDevice used for multi GPU VR support
\param [in] pDevice current d3d device
\param [in] version version of requested ID3D11MultiGPUDevice.
\param [out] currentVersion pointer to returned current version of ID3D11MultiGPUDevice.
\param [out] ppD3D11MultiGPUDevice pointer to returned ID3D11MultiGPUDevice.
\param [in] maxGpus max number of gpus this ID3D11MultiGPUDevice is allowed to use
\return ::NVAPI_OK if the call succeeds.
NVAPI_INVALID_ARGUMENT if NvAPI_D3D11_MultiGPU_Init() was not enabled prior to the creation of the D3D11 device,
or if maxGpus is greater than the number of GPUs in the SLI group.
NVAPI_NO_ACTIVE_SLI_TOPOLOGY on single-GPU systems, or
if SLI has not been enabled in the NVIDIA control panel.
NVAPI_INVALID_CALL if there is already an ID3D11MultiGPUDevice created for the specified ID3D11Device.
NVAPI_INCOMPATIBLE_STRUCT_VERSION if requested interface version is greater than the one that is supported by installed.
driver. In this case currentVersion will contain version supported by installed driver.
NvAPI_D3D11_MultiGPU_Init
NVAPI_INTERFACE NvAPI_D3D11_MultiGPU_Init(__in bool bEnable)
NVAPI_INVALID_CALL
@ NVAPI_INVALID_CALL
The method call is invalid. For example, a method's parameter may not be a valid pointer.
Definition nvapi_lite_common.h:309
NVAPI_INCOMPATIBLE_STRUCT_VERSION
@ NVAPI_INCOMPATIBLE_STRUCT_VERSION
An argument's structure version is not supported.
Definition nvapi_lite_common.h:267
NVAPI_NO_ACTIVE_SLI_TOPOLOGY
@ NVAPI_NO_ACTIVE_SLI_TOPOLOGY
SLI is not active on this device.
Definition nvapi_lite_common.h:288
NVAPI_INVALID_ARGUMENT
@ NVAPI_INVALID_ARGUMENT
The argument/parameter value is not valid or NULL.
Definition nvapi_lite_common.h:263
ID3D11MultiGPUDevice
ID3D11MultiGPUDevice_V1 ID3D11MultiGPUDevice
Definition nvapi.h:15704

◆ NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_BYTE_ALIGNMENT

#define NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_BYTE_ALIGNMENT 256

Mandatory alignment for the address of a DMM Array.

◆ NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_DC1_MAX_SUBDIVISION_LEVEL

#define NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_DC1_MAX_SUBDIVISION_LEVEL 5

Highest subdivision-level allowed with DC1.

◆ NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_ARRAY_BYTE_ALIGNMENT

#define NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_ARRAY_BYTE_ALIGNMENT 256

Mandatory alignment for the address of an OMM Array.

◆ NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_OC1_MAX_SUBDIVISION_LEVEL

#define NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_OC1_MAX_SUBDIVISION_LEVEL 12

Highest subdivision-level allowed with OC1.

Typedef Documentation

◆ ID3DLateLatchObject

typedef ID3DLateLatchObject_V1 ID3DLateLatchObject

See NvAPI_D3D_CreateLateLatchObject

◆ IMPLICIT_SLI_CONTROL

typedef enum _IMPLICIT_SLI_CONTROL IMPLICIT_SLI_CONTROL

SUPPORTED OS: Windows 7 and higher This function enables/disables the SLI rendering mode. It has to be called prior to D3D device creation. Once this function is called with DISABLE_IMPLICIT_SLI parameter all subsequently created devices will be forced to run in a single gpu mode until the same function is called with ENABLE_IMPLICIT_SLI parameter. The enable call will force all subsequently created devices to run in default implicit SLI mode being determined by an application profile or a global control panel SLI setting. This NvAPI call is supported in all DX10+ versions of the driver. It is supported on all Windows versions.

Return values
NVAPI_OK | Completed request
NVAPI_ERROR | Error occurred

◆ NV_ASYNC_FRAME_MARKER_PARAMS_V1

typedef struct _NV_ASYNC_FRAME_MARKER_PARAMS_V1 NV_ASYNC_FRAME_MARKER_PARAMS_V1

SUPPORTED OS: Windows 10 and higher

Used in NvAPI_D3D12_SetAsyncFrameMarker

◆ NV_COMPUTE_SHADER_DERIVATIVES

typedef enum _NV_COMPUTE_SHADER_DERIVATIVES NV_COMPUTE_SHADER_DERIVATIVES

Enum for compute shader derivative modes

◆ NV_D3D11_EXCLUSIVE_SCISSOR_RECT_DESC_V1

typedef struct _NV_D3D11_EXCLUSIVE_SCISSOR_RECT_DESC_V1 NV_D3D11_EXCLUSIVE_SCISSOR_RECT_DESC_V1

See NvAPI_D3D11_RSSetExclusiveScissorRects

◆ NV_D3D12_GRAPHICS_CAPS_V1

typedef struct _NV_D3D12_GRAPHICS_CAPS_V1 NV_D3D12_GRAPHICS_CAPS_V1

See NvAPI_D3D12_GetGraphicsCapabilities

◆ NV_D3D1x_GRAPHICS_CAPS_V1

typedef struct _NV_D3D1x_GRAPHICS_CAPS_V1 NV_D3D1x_GRAPHICS_CAPS_V1

See NvAPI_D3D1x_GetGraphicsCapabilities

◆ NV_GET_SLEEP_STATUS_PARAMS_V1

typedef struct _NV_GET_SLEEP_STATUS_PARAMS NV_GET_SLEEP_STATUS_PARAMS_V1

SUPPORTED OS: Windows 7 and higher

Used to get sleep status

◆ NV_LATENCY_MARKER_PARAMS_V1

typedef struct _NV_LATENCY_MARKER_PARAMS NV_LATENCY_MARKER_PARAMS_V1

SUPPORTED OS: Windows 7 and higher

Used set latency markers

◆ NV_LATENCY_RESULT_PARAMS_V1

typedef struct _NV_LATENCY_RESULT_PARAMS NV_LATENCY_RESULT_PARAMS_V1

SUPPORTED OS: Windows 7 and higher

Used to get latency report.

◆ NV_MULTIGPU_CAPS_V1

typedef struct _NV_MULTIGPU_CAPS_V1 NV_MULTIGPU_CAPS_V1

SUPPORTED OS: Windows 7 and higher DESCRIPTION: Request to get multi GPU extension caps.

Parameters
[in/out] pMultiGPUCaps Pointer to a structure returning multi GPU caps
Return values
NVAPI_OK | Call succeeded.
NVAPI_ERROR | Call failed.

◆ NV_MULTIVIEW_PARAMS_V1

typedef struct _NV_MULTIVIEW_PARAMS_V1 NV_MULTIVIEW_PARAMS_V1

SUPPORTED OS: Windows 7 and higher

Used for setting the Mode for MultiView HW Feature. <>

◆ NV_PIXEL_SRSO_1x2

typedef struct _NV_PIXEL_SRSO_1x2 NV_PIXEL_SRSO_1x2

See NvAPI_D3D11_RSGetPixelShadingRateSampleOrder See NvAPI_D3D11_RSSetPixelShadingRateSampleOrder

◆ NV_PSO_EXTENSION

typedef enum _NV_PSO_EXTENSION NV_PSO_EXTENSION

Enum for CreatePSO extensions.

constant 5 is assigned to two members of this enum becuase the first member name contains a typo: EXTNENSION. Please use the correctly-spelled enumerator.

◆ NV_QUERY_LATELATCH_SUPPORT_PARAMS_V1

typedef struct _NV_QUERY_LATELATCH_SUPPORT_PARAMS NV_QUERY_LATELATCH_SUPPORT_PARAMS_V1

See NvAPI_D3D_QueryLateLatchSupport

◆ NV_QUERY_MODIFIED_W_SUPPORT_PARAMS_V1

typedef struct _NV_QUERY_MODIFIED_W_SUPPORT_PARAMS NV_QUERY_MODIFIED_W_SUPPORT_PARAMS_V1

SUPPORTED OS: Windows 7 and higher

Used to query the support of Lens Matched Shading HW feature <>

◆ NV_QUERY_MULTIVIEW_SUPPORT_PARAMS_V1

typedef struct _NV_QUERY_MULTIVIEW_SUPPORT_PARAMS_V1 NV_QUERY_MULTIVIEW_SUPPORT_PARAMS_V1

SUPPORTED OS: Windows 7 and higher

Used to query the support of MultiView HW feature <>

◆ NV_QUERY_SINGLE_PASS_STEREO_SUPPORT_PARAMS_V1

typedef struct _NV_QUERY_SINGLE_PASS_STEREO_SUPPORT_PARAMS_V1 NV_QUERY_SINGLE_PASS_STEREO_SUPPORT_PARAMS_V1

SUPPORTED OS: Windows 7 and higher

Used to query the support of Single Pass Stereo HW feature <>

◆ NV_QUERY_SMP_ASSIST_SUPPORT_PARAMS_V1

typedef struct _NV_QUERY_SMP_ASSIST_SUPPORT_PARAMS_V1 NV_QUERY_SMP_ASSIST_SUPPORT_PARAMS_V1

SUPPORTED OS: Windows 7 and higher

◆ NV_RESOLVE_MODE

typedef enum _NV_RESOLVE_MODE NV_RESOLVE_MODE

SUPPORTED OS: Windows 10 and higher

Valid modes for NvAPI_D3D11_ResolveSubresourceRegion() and NvAPI_D3D12_ResolveSubresourceRegion

◆ NV_SET_REFLEX_SYNC_PARAMS_V1

typedef struct _NV_SET_REFLEX_SYNC_PARAMS NV_SET_REFLEX_SYNC_PARAMS_V1

SUPPORTED OS: Windows 10 and higher

Used to send Reflex Sync data to UMD

◆ NV_SET_SLEEP_MODE_PARAMS_V1

typedef struct _NV_SET_SLEEP_MODE_PARAMS NV_SET_SLEEP_MODE_PARAMS_V1

SUPPORTED OS: Windows 7 and higher

Used to set sleep mode

◆ NV_SMP_ASSIST_TYPE

typedef enum NV_SMP_ASSIST_TYPE NV_SMP_ASSIST_TYPE

SUPPORTED OS: Windows 7 and higher

◆ NVAPI_ANSEL_FEATURE

typedef enum _NVAPI_ANSEL_FEATURE NVAPI_ANSEL_FEATURE

SUPPORTED OS: Windows 7 and higher

DESCRIPTION: This function configure the setting of AnselShim, including hotkey.
\param [in] pDevice current d3d device (should be ID3D11Device, ID3D10Device, or ID3D12Device)
\param [in] pAnselConfig configuration of Ansel to be set, including hotkey setting
\return ::NVAPI_OK if the call succeeds.

◆ NVAPI_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_EX_PARAMS_V1

typedef struct _NVAPI_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_EX_PARAMS_V1 NVAPI_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_EX_PARAMS_V1

Parameters given to NvAPI_D3D12_RelocateRaytracingOpacityMicromapArray().

◆ NVAPI_BUILD_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PARAMS_V1

typedef struct _NVAPI_BUILD_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PARAMS_V1 NVAPI_BUILD_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PARAMS_V1

Parameters given to NvAPI_D3D12_BuildRaytracingDisplacementMicromapArray().

◆ NVAPI_BUILD_RAYTRACING_OPACITY_MICROMAP_ARRAY_PARAMS_V1

typedef struct _NVAPI_BUILD_RAYTRACING_OPACITY_MICROMAP_ARRAY_PARAMS_V1 NVAPI_BUILD_RAYTRACING_OPACITY_MICROMAP_ARRAY_PARAMS_V1

Parameters given to NvAPI_D3D12_BuildRaytracingOpacityMicromapArray().

◆ NVAPI_CHECK_DRIVER_MATCHING_IDENTIFIER_EX_PARAMS_V1

typedef struct _NVAPI_CHECK_DRIVER_MATCHING_IDENTIFIER_EX_PARAMS_V1 NVAPI_CHECK_DRIVER_MATCHING_IDENTIFIER_EX_PARAMS_V1

Parameters given to NvAPI_D3D12_CheckDriverMatchingIdentifierEx().

◆ NVAPI_D3D11_INSERTWFI_FLAG

typedef enum _NVAPI_D3D11_INSERTWFI_FLAG NVAPI_D3D11_INSERTWFI_FLAG

DESCRIPTION: Causes the driver to skip synchronization that is normally needed when accessing UAVs. Applications must use this with caution otherwise this might cause data hazards when multiple draw calls/compute shader launches are accessing same memory locations

SUPPORTED OS: Windows 7 and higher

Parameters
[in] | *pDeviceOrContext | pointer to D3D11 device, or D3D11 device context
[in] | insertWFIFlags | bit fields to indicate which WFI would be inserted (gfx / compute / both).

RETURN STATUS: This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.

◆ NVAPI_D3D12_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_DESC_EX

typedef struct _NVAPI_D3D12_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_DESC_EX NVAPI_D3D12_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_DESC_EX

This structure extends D3D12_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_DESC by supporting additional geometry types as inputs. For more information on the different members, please check Microsoft's DirectX Raytracing Specification.

◆ NVAPI_D3D12_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_INPUTS_EX

typedef struct _NVAPI_D3D12_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_INPUTS_EX NVAPI_D3D12_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_INPUTS_EX

This structure extends D3D12_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_INPUTS by supporting additional geometry types. Only modified members are fully described below; for more information on the other members, please check Microsoft's DirectX Raytracing Specification.

◆ NVAPI_D3D12_BUILD_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_DESC

typedef struct _NVAPI_D3D12_BUILD_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_DESC NVAPI_D3D12_BUILD_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_DESC

Description of the inputs and memory areas used during the building of DMM Arrays.

◆ NVAPI_D3D12_BUILD_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_INPUTS

typedef struct _NVAPI_D3D12_BUILD_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_INPUTS NVAPI_D3D12_BUILD_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_INPUTS

Input structure to DMM Array construction. Individual DMMs are accessed via indices when used in bottom-level acceleration structure (BLAS) construction.

◆ NVAPI_D3D12_BUILD_RAYTRACING_OPACITY_MICROMAP_ARRAY_DESC

typedef struct _NVAPI_D3D12_BUILD_RAYTRACING_OPACITY_MICROMAP_ARRAY_DESC NVAPI_D3D12_BUILD_RAYTRACING_OPACITY_MICROMAP_ARRAY_DESC

Description of the inputs and memory areas used during the building of OMM Arrays.

◆ NVAPI_D3D12_BUILD_RAYTRACING_OPACITY_MICROMAP_ARRAY_INPUTS

typedef struct _NVAPI_D3D12_BUILD_RAYTRACING_OPACITY_MICROMAP_ARRAY_INPUTS NVAPI_D3D12_BUILD_RAYTRACING_OPACITY_MICROMAP_ARRAY_INPUTS

Input structure to OMM Array construction. Individual OMMs are accessed via indices when used in bottom-level acceleration structure (BLAS) construction.

◆ NVAPI_D3D12_PIPELINE_CREATION_STATE_FLAGS

typedef enum _NVAPI_D3D12_PIPELINE_CREATION_STATE_FLAGS NVAPI_D3D12_PIPELINE_CREATION_STATE_FLAGS

Pipeline creation state flags.

◆ NVAPI_D3D12_RAYTRACING_ACCELERATION_STRUCTURE_BUILD_FLAGS_EX

typedef enum _NVAPI_D3D12_RAYTRACING_ACCELERATION_STRUCTURE_BUILD_FLAGS_EX NVAPI_D3D12_RAYTRACING_ACCELERATION_STRUCTURE_BUILD_FLAGS_EX

This enum extends D3D12_RAYTRACING_ACCELERATION_STRUCTURE_BUILD_FLAGS with modified and additional values. Only modified/new values are fully described; for more information on the other values, please check Microsoft's DirectX Raytracing Specification.

◆ NVAPI_D3D12_RAYTRACING_CAPS_TYPE

typedef enum _NVAPI_D3D12_RAYTRACING_CAPS_TYPE NVAPI_D3D12_RAYTRACING_CAPS_TYPE

List of Raytracing CAPS types that can be queried.

◆ NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_BUILD_FLAGS

typedef enum _NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_BUILD_FLAGS NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_BUILD_FLAGS

SUPPORTED OS: Windows 10 and higher Flags specifying building instructions and hints when constructing a DMM Array.

◆ NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_POSTBUILD_INFO_CURRENT_SIZE_DESC

typedef struct _NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_POSTBUILD_INFO_CURRENT_SIZE_DESC NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_POSTBUILD_INFO_CURRENT_SIZE_DESC

Structure emitted by NvAPI_D3D12_EmitRaytracingDisplacementMicromapArrayPostbuildInfo(), and optionally NvAPI_D3D12_BuildRaytracingDisplacementMicromapArray(), when type equals NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_POSTBUILD_INFO_CURRENT_SIZE.

◆ NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_POSTBUILD_INFO_DESC

typedef struct _NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_POSTBUILD_INFO_DESC NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_POSTBUILD_INFO_DESC

Description of the postbuild information to generate from a DMM Array.

◆ NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_POSTBUILD_INFO_TYPE

typedef enum _NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_POSTBUILD_INFO_TYPE NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_POSTBUILD_INFO_TYPE

Type of postbuild info to emit after a DMM Array build.

◆ NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PREBUILD_INFO

typedef struct _NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PREBUILD_INFO NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PREBUILD_INFO

Conservative memory requirements for building a DMM Array.

◆ NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_CAPS

typedef enum _NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_CAPS NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_CAPS

Flags specifying raytracing Displacement Micromap support. Additional flags will be added as support becomes available.

◆ NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_DESC

typedef struct _NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_DESC NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_DESC

Describes one Displacement Micromap.

◆ NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_FORMAT

typedef enum _NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_FORMAT NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_FORMAT

Specifies the input Displacement Micromap formats. The DC1 (Displacement Compression 1) format follows the space-filling curve in barycentric space over the uniformly tessellated micro-triangles.

Note
This is a 16-bit value when used in NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_DESC

◆ NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_PRIMITIVE_FLAGS

typedef enum _NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_PRIMITIVE_FLAGS NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_PRIMITIVE_FLAGS

The edge vA..vB is decimated: after subdivision the number of micro-triangles on that edge is halved. (i.e. the neighboring primitive can have a lower subdivision level without introducing cracks)

◆ NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_USAGE_COUNT

typedef struct _NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_USAGE_COUNT NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_USAGE_COUNT

Number of DMMs of a specific configuration in a DMM Array or BLAS build. Used to compute conservative buffer size estimates for DMM Array and BLAS builds.

◆ NVAPI_D3D12_RAYTRACING_GEOMETRY_DESC_EX

typedef struct _NVAPI_D3D12_RAYTRACING_GEOMETRY_DESC_EX NVAPI_D3D12_RAYTRACING_GEOMETRY_DESC_EX

This structure extends D3D12_RAYTRACING_GEOMETRY_DESC by supporting additional geometry types. Only new members are fully described below; for more information on the other members, please check Microsoft's DirectX Raytracing Specification.

◆ NVAPI_D3D12_RAYTRACING_GEOMETRY_DMM_ATTACHMENT_DESC

typedef struct _NVAPI_D3D12_RAYTRACING_GEOMETRY_DMM_ATTACHMENT_DESC NVAPI_D3D12_RAYTRACING_GEOMETRY_DMM_ATTACHMENT_DESC

Geometry descriptor attachment with Displacement Micromaps.

◆ NVAPI_D3D12_RAYTRACING_GEOMETRY_DMM_TRIANGLES_DESC

typedef struct _NVAPI_D3D12_RAYTRACING_GEOMETRY_DMM_TRIANGLES_DESC NVAPI_D3D12_RAYTRACING_GEOMETRY_DMM_TRIANGLES_DESC

Geometry triangle descriptor with attached augmented Displacement Micromaps.

◆ NVAPI_D3D12_RAYTRACING_GEOMETRY_OMM_ATTACHMENT_DESC

typedef struct _NVAPI_D3D12_RAYTRACING_GEOMETRY_OMM_ATTACHMENT_DESC NVAPI_D3D12_RAYTRACING_GEOMETRY_OMM_ATTACHMENT_DESC

Geometry descriptor attachment with Opacity Micromaps.

◆ NVAPI_D3D12_RAYTRACING_GEOMETRY_OMM_TRIANGLES_DESC

typedef struct _NVAPI_D3D12_RAYTRACING_GEOMETRY_OMM_TRIANGLES_DESC NVAPI_D3D12_RAYTRACING_GEOMETRY_OMM_TRIANGLES_DESC

Geometry triangle descriptor with attached augmented Opacity Micromaps.

◆ NVAPI_D3D12_RAYTRACING_GEOMETRY_TYPE_EX

typedef enum _NVAPI_D3D12_RAYTRACING_GEOMETRY_TYPE_EX NVAPI_D3D12_RAYTRACING_GEOMETRY_TYPE_EX

This enum extends D3D12_RAYTRACING_GEOMETRY_TYPE with additional values. Only new values are fully described below; for more information on the other values, please check Microsoft's DirectX Raytracing Specification.

◆ NVAPI_D3D12_RAYTRACING_INSTANCE_FLAGS_EX

typedef enum _NVAPI_D3D12_RAYTRACING_INSTANCE_FLAGS_EX NVAPI_D3D12_RAYTRACING_INSTANCE_FLAGS_EX

This enum extends D3D12_RAYTRACING_INSTANCE_FLAGS with additional values. Only new values are fully described below; for more information on the other values, please check Microsoft's DirectX Raytracing Specification.

◆ NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_ARRAY_BUILD_FLAGS

typedef enum _NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_ARRAY_BUILD_FLAGS NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_ARRAY_BUILD_FLAGS

SUPPORTED OS: Windows 10 and higher Flags specifying building instructions and hints when constructing an OMM Array.

◆ NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_ARRAY_POSTBUILD_INFO_CURRENT_SIZE_DESC

typedef struct _NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_ARRAY_POSTBUILD_INFO_CURRENT_SIZE_DESC NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_ARRAY_POSTBUILD_INFO_CURRENT_SIZE_DESC

Structure emitted by NvAPI_D3D12_EmitRaytracingOpacityMicromapArrayPostbuildInfo(), and optionally NvAPI_D3D12_BuildRaytracingOpacityMicromapArray(), when type equals NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_ARRAY_POSTBUILD_INFO_CURRENT_SIZE.

◆ NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_ARRAY_POSTBUILD_INFO_DESC

typedef struct _NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_ARRAY_POSTBUILD_INFO_DESC NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_ARRAY_POSTBUILD_INFO_DESC

Description of the postbuild information to generate from an OMM Array.

◆ NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_ARRAY_POSTBUILD_INFO_TYPE

typedef enum _NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_ARRAY_POSTBUILD_INFO_TYPE NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_ARRAY_POSTBUILD_INFO_TYPE

Type of postbuild info to emit after an OMM Array build.

◆ NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_ARRAY_PREBUILD_INFO

typedef struct _NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_ARRAY_PREBUILD_INFO NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_ARRAY_PREBUILD_INFO

Conservative memory requirements for building an OMM Array.

◆ NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_CAPS

typedef enum _NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_CAPS NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_CAPS

Flags specifying raytracing Opacity Micromap support. Additional flags will be added as support becomes available.

◆ NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_DESC

typedef struct _NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_DESC NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_DESC

Describes one Opacity Micromap.

◆ NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_FORMAT

typedef enum _NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_FORMAT NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_FORMAT

Specifies the input Opacity Micromap formats. The OC1 (Opacity Compression 1) format follows the space-filling curve in barycentric space over the uniformly tessellated micro-triangles.

Note
This is a 16-bit value when used in NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_DESC.

◆ NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_SPECIAL_INDEX

typedef enum _NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_SPECIAL_INDEX NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_SPECIAL_INDEX

If a triangle has a uniform OMM state in a BLAS build, it is preferable to signal this explicitly rather than attaching a single state OMM. This can be accomplished by supplying these special indices as entries in opacityMicromapIndexBuffer, in NVAPI_D3D12_RAYTRACING_GEOMETRY_OMM_TRIANGLES_DESC.

◆ NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_STATE

typedef enum _NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_STATE NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_STATE

Opacity Micromap micro-triangle states. Not part of any input, but listed here for convenience.

◆ NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_USAGE_COUNT

typedef struct _NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_USAGE_COUNT NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_USAGE_COUNT

Number of OMMs of a specific configuration in an OMM Array. Used to compute conservative buffer size estimates for OMM Array builds.

◆ NVAPI_D3D12_RAYTRACING_THREAD_REORDERING_CAPS

typedef enum _NVAPI_D3D12_RAYTRACING_THREAD_REORDERING_CAPS NVAPI_D3D12_RAYTRACING_THREAD_REORDERING_CAPS

Flags specifying raytracing thread reordering hardware support. Additional flags will be added as support becomes available.

◆ NVAPI_D3D12_RAYTRACING_VALIDATION_FLAGS

typedef enum _NVAPI_D3D12_RAYTRACING_VALIDATION_FLAGS NVAPI_D3D12_RAYTRACING_VALIDATION_FLAGS

Flags specifying validation behaviour for raytracing operations.

See NvAPI_D3D12_EnableRaytracingValidation

◆ NVAPI_D3D12_RAYTRACING_VALIDATION_MESSAGE_CALLBACK

typedef void(__stdcall * NVAPI_D3D12_RAYTRACING_VALIDATION_MESSAGE_CALLBACK) (void *pUserData, NVAPI_D3D12_RAYTRACING_VALIDATION_MESSAGE_SEVERITY severity, const char *messageCode, const char *message, const char *messageDetails)

Callback for raytracing validation messages.

Parameters
[in] | pUserData | User data pointer as provided to callback registration.
[in] | severity | Severity of message.
[in] | messageCode | Type of reported validation message.
[in] | message | Human-readable description of what the message code means.
[in] | messageDetails | Additional human-readable context for validation message. May contain newlines.

See NvAPI_D3D12_RegisterRaytracingValidationMessageCallback

◆ NVAPI_D3D12_RAYTRACING_VALIDATION_MESSAGE_SEVERITY

typedef enum _NVAPI_D3D12_RAYTRACING_VALIDATION_MESSAGE_SEVERITY NVAPI_D3D12_RAYTRACING_VALIDATION_MESSAGE_SEVERITY

Severity classification of validation messages.

See NVAPI_D3D12_RAYTRACING_VALIDATION_MESSAGE_CALLBACK

◆ NVAPI_D3D12_SERIALIZED_DATA_TYPE_EX

typedef enum _NVAPI_D3D12_SERIALIZED_DATA_TYPE_EX NVAPI_D3D12_SERIALIZED_DATA_TYPE_EX

Type of serialized data.

◆ NVAPI_D3D12_SET_CREATE_PIPELINE_STATE_OPTIONS_PARAMS_V1

typedef struct _NVAPI_D3D12_SET_CREATE_PIPELINE_STATE_OPTIONS_PARAMS_V1 NVAPI_D3D12_SET_CREATE_PIPELINE_STATE_OPTIONS_PARAMS_V1

State used when creating new pipelines.

◆ NVAPI_D3D_RESOURCERENDERING_FLAG

typedef enum _NVAPI_D3D_RESOURCERENDERING_FLAG NVAPI_D3D_RESOURCERENDERING_FLAG

Used in NvAPI_D3D_BeginResourceRendering().

◆ NVAPI_D3D_SETRESOURCEHINT_CATEGORY

typedef enum _NVAPI_D3D_SETRESOURCEHINT_CATEGORY NVAPI_D3D_SETRESOURCEHINT_CATEGORY

Valid categories for NvAPI_D3D_SetResourceHint()

◆ NVAPI_D3D_SETRESOURCEHINT_SLI

typedef enum _NVAPI_D3D_SETRESOURCEHINT_SLI NVAPI_D3D_SETRESOURCEHINT_SLI

Types of SLI hints;
NVAPI_D3D_SRH_SLI_APP_CONTROLLED_INTERFRAME_CONTENT_SYNC: Valid values : 0 or 1
Default value: 0
Explanation: If the value is 1, the driver will not track any rendering operations that would mark this resource as dirty, avoiding any form of synchronization across frames rendered in parallel in multiple GPUs in AFR mode.

NVAPI_D3D_SRH_SLI_ASK_FOR_BROADCAST_USAGE: Valid values : 0 or 1
Default value: 0
Explanation: If the value is 1, the driver will try to perform operations which involved target resource in broadcast, where it's possible. Hint is static and must be set before resource starts using.

NVAPI_D3D_SRH_SLI_RESPECT_DRIVER_INTERFRAME_CONTENT_SYNC: Valid values : 0 or 1
Default value: 0
Explanation: If the value is 1, the driver will do dirty resource resolve regardless of discard flags in the application profile or AFR-FriendlyD3DHints.exe name using.

◆ NVAPI_EMIT_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_POSTBUILD_INFO_PARAMS_V1

typedef struct _NVAPI_EMIT_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_POSTBUILD_INFO_PARAMS_V1 NVAPI_EMIT_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_POSTBUILD_INFO_PARAMS_V1

Parameters given to NvAPI_D3D12_EmitRaytracingDisplacementMicromapArrayPostbuildInfo().

◆ NVAPI_EMIT_RAYTRACING_OPACITY_MICROMAP_ARRAY_POSTBUILD_INFO_PARAMS_V1

typedef struct _NVAPI_EMIT_RAYTRACING_OPACITY_MICROMAP_ARRAY_POSTBUILD_INFO_PARAMS_V1 NVAPI_EMIT_RAYTRACING_OPACITY_MICROMAP_ARRAY_POSTBUILD_INFO_PARAMS_V1

Parameters given to NvAPI_D3D12_EmitRaytracingOpacityMicromapArrayPostbuildInfo().

◆ NVAPI_GET_RAYTRACING_ACCELERATION_STRUCTURE_PREBUILD_INFO_EX_PARAMS_V1

typedef struct _NVAPI_GET_RAYTRACING_ACCELERATION_STRUCTURE_PREBUILD_INFO_EX_PARAMS_V1 NVAPI_GET_RAYTRACING_ACCELERATION_STRUCTURE_PREBUILD_INFO_EX_PARAMS_V1

Parameters given to NvAPI_D3D12_GetRaytracingAccelerationStructurePrebuildInfoEx().

◆ NVAPI_GET_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PREBUILD_INFO_PARAMS_V1

typedef struct _NVAPI_GET_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PREBUILD_INFO_PARAMS_V1 NVAPI_GET_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PREBUILD_INFO_PARAMS_V1

Parameters given to NvAPI_D3D12_GetRaytracingDisplacementMicromapArrayPrebuildInfo().

◆ NVAPI_GET_RAYTRACING_OPACITY_MICROMAP_ARRAY_PREBUILD_INFO_PARAMS_V1

typedef struct _NVAPI_GET_RAYTRACING_OPACITY_MICROMAP_ARRAY_PREBUILD_INFO_PARAMS_V1 NVAPI_GET_RAYTRACING_OPACITY_MICROMAP_ARRAY_PREBUILD_INFO_PARAMS_V1

Parameters given to NvAPI_D3D12_GetRaytracingOpacityMicromapArrayPrebuildInfo().

◆ NVAPI_RAY_FLAG_EX

typedef enum _NVAPI_RAY_FLAGS_EX NVAPI_RAY_FLAG_EX

A list of flags that can be given to the TraceRay() function in HLSL. Only new or modified values are fully described below; for more information on the other values, please check Microsoft's DirectX Raytracing Specification.

◆ NVAPI_RELOCATE_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PARAMS_V1

typedef struct _NVAPI_RELOCATE_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PARAMS_V1 NVAPI_RELOCATE_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PARAMS_V1

Parameters given to NvAPI_D3D12_RelocateRaytracingDisplacementMicromapArray().

◆ NVAPI_RELOCATE_RAYTRACING_OPACITY_MICROMAP_ARRAY_PARAMS_V1

typedef struct _NVAPI_RELOCATE_RAYTRACING_OPACITY_MICROMAP_ARRAY_PARAMS_V1 NVAPI_RELOCATE_RAYTRACING_OPACITY_MICROMAP_ARRAY_PARAMS_V1

Parameters given to NvAPI_D3D12_RelocateRaytracingOpacityMicromapArray().

◆ PNV_MULTIGPU_CAPS_V1

typedef struct _NV_MULTIGPU_CAPS_V1 * PNV_MULTIGPU_CAPS_V1

Enumeration Type Documentation

◆ _IMPLICIT_SLI_CONTROL

enum _IMPLICIT_SLI_CONTROL

SUPPORTED OS: Windows 7 and higher This function enables/disables the SLI rendering mode. It has to be called prior to D3D device creation. Once this function is called with DISABLE_IMPLICIT_SLI parameter all subsequently created devices will be forced to run in a single gpu mode until the same function is called with ENABLE_IMPLICIT_SLI parameter. The enable call will force all subsequently created devices to run in default implicit SLI mode being determined by an application profile or a global control panel SLI setting. This NvAPI call is supported in all DX10+ versions of the driver. It is supported on all Windows versions.

Return values
NVAPI_OK | Completed request
NVAPI_ERROR | Error occurred
Enumerator
DISABLE_IMPLICIT_SLI
ENABLE_IMPLICIT_SLI

◆ _NV_COMPUTE_SHADER_DERIVATIVES

enum _NV_COMPUTE_SHADER_DERIVATIVES

Enum for compute shader derivative modes

Enumerator
NV_COMPUTE_SHADER_DERIVATIVE_NONE
NV_COMPUTE_SHADER_DERIVATIVE_GROUP_LINEAR
NV_COMPUTE_SHADER_DERIVATIVE_GROUP_QUADS

◆ _NV_PSO_EXTENSION

enum _NV_PSO_EXTENSION

Enum for CreatePSO extensions.

constant 5 is assigned to two members of this enum becuase the first member name contains a typo: EXTNENSION. Please use the correctly-spelled enumerator.

Enumerator
NV_PSO_RASTER_EXTENSION
NV_PSO_REQUEST_FASTGS_EXTENSION
NV_PSO_GEOMETRY_SHADER_EXTENSION
NV_PSO_ENABLE_DEPTH_BOUND_TEST_EXTENSION
NV_PSO_EXPLICIT_FASTGS_EXTENSION
NV_PSO_SET_SHADER_EXTNENSION_SLOT_AND_SPACE
NV_PSO_SET_SHADER_EXTENSION_SLOT_AND_SPACE
NV_PSO_VERTEX_SHADER_EXTENSION
NV_PSO_DOMAIN_SHADER_EXTENSION
NV_PSO_HULL_SHADER_EXTENSION

◆ _NV_RESOLVE_MODE

enum _NV_RESOLVE_MODE

SUPPORTED OS: Windows 10 and higher

Valid modes for NvAPI_D3D11_ResolveSubresourceRegion() and NvAPI_D3D12_ResolveSubresourceRegion

Enumerator
NV_RESOLVE_MODE_SAMPLE_0

◆ _NVAPI_ANSEL_FEATURE

enum _NVAPI_ANSEL_FEATURE

SUPPORTED OS: Windows 7 and higher

DESCRIPTION: This function configure the setting of AnselShim, including hotkey.
\param [in] pDevice current d3d device (should be ID3D11Device, ID3D10Device, or ID3D12Device)
\param [in] pAnselConfig configuration of Ansel to be set, including hotkey setting
\return ::NVAPI_OK if the call succeeds.
Enumerator
NVAPI_ANSEL_FEATURE_UNKNOWN
NVAPI_ANSEL_FEATURE_BLACK_AND_WHITE
NVAPI_ANSEL_FEATURE_HUDLESS

◆ _NVAPI_D3D11_INSERTWFI_FLAG

enum _NVAPI_D3D11_INSERTWFI_FLAG

DESCRIPTION: Causes the driver to skip synchronization that is normally needed when accessing UAVs. Applications must use this with caution otherwise this might cause data hazards when multiple draw calls/compute shader launches are accessing same memory locations

SUPPORTED OS: Windows 7 and higher

Parameters
[in] | *pDeviceOrContext | pointer to D3D11 device, or D3D11 device context
[in] | insertWFIFlags | bit fields to indicate which WFI would be inserted (gfx / compute / both).

RETURN STATUS: This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.

Enumerator
NVAPI_D3D_BEGIN_UAV_OVERLAP_NO_WFI | no WFI
NVAPI_D3D_BEGIN_UAV_OVERLAP_GFX_WFI | (bit 0) force graphics WFI
NVAPI_D3D_BEGIN_UAV_OVERLAP_COMP_WFI | (bit 1) force compute WFI

◆ _NVAPI_D3D12_PIPELINE_CREATION_STATE_FLAGS

enum _NVAPI_D3D12_PIPELINE_CREATION_STATE_FLAGS

Pipeline creation state flags.

Enumerator
NVAPI_D3D12_PIPELINE_CREATION_STATE_FLAGS_NONE | [in] No pipeline flags.
NVAPI_D3D12_PIPELINE_CREATION_STATE_FLAGS_ENABLE_OMM_SUPPORT | [in] Change whether raytracing pipelines are created with support for Opacity Micromaps. If a triangle with an OMM is encountered during traversal and the pipeline was not created with support for them, behavior is undefined. Support should only be enabled if there are OMMs present, since it may incur a small penalty on traversal performance overall.
NVAPI_D3D12_PIPELINE_CREATION_STATE_FLAGS_ENABLE_DMM_SUPPORT | [in] Change whether raytracing pipelines are created with support for Displacement Micromaps. If a triangle with a DMM is encountered during traversal and the pipeline was not created with support for them, behavior is undefined. Support should only be enabled if there are DMMs present, since it may incur a small penalty on traversal performance overall.

◆ _NVAPI_D3D12_RAYTRACING_ACCELERATION_STRUCTURE_BUILD_FLAGS_EX

enum _NVAPI_D3D12_RAYTRACING_ACCELERATION_STRUCTURE_BUILD_FLAGS_EX

This enum extends D3D12_RAYTRACING_ACCELERATION_STRUCTURE_BUILD_FLAGS with modified and additional values. Only modified/new values are fully described; for more information on the other values, please check Microsoft's DirectX Raytracing Specification.

Enumerator
NVAPI_D3D12_RAYTRACING_ACCELERATION_STRUCTURE_BUILD_FLAG_NONE_EX | No options specified for the acceleration structure build.
NVAPI_D3D12_RAYTRACING_ACCELERATION_STRUCTURE_BUILD_FLAG_ALLOW_UPDATE_EX | Allow the acceleration structure to later be updated (via the flag NVAPI_D3D12_RAYTRACING_ACCELERATION_STRUCTURE_BUILD_FLAG_PERFORM_UPDATE_EX), rather than always requiring a full rebuild.
NVAPI_D3D12_RAYTRACING_ACCELERATION_STRUCTURE_BUILD_FLAG_ALLOW_COMPACTION_EX | Allow for the acceleration structure to later be compacted.
NVAPI_D3D12_RAYTRACING_ACCELERATION_STRUCTURE_BUILD_FLAG_PREFER_FAST_TRACE_EX | Favorize higher raytracing performance at the cost of longer build times.
NVAPI_D3D12_RAYTRACING_ACCELERATION_STRUCTURE_BUILD_FLAG_PREFER_FAST_BUILD_EX | Favorize faster build times at the cost of lower raytracing performance.
NVAPI_D3D12_RAYTRACING_ACCELERATION_STRUCTURE_BUILD_FLAG_MINIMIZE_MEMORY_EX | Minimize the memory footprint of the produced acceleration structure, potentially at the cost of longer build time or lower raytracing performance.
NVAPI_D3D12_RAYTRACING_ACCELERATION_STRUCTURE_BUILD_FLAG_PERFORM_UPDATE_EX | Instead of rebuilding the acceleration structure from scratch, the existing acceleration structure will be updated. Added behaviour: If NVAPI_D3D12_RAYTRACING_ACCELERATION_STRUCTURE_BUILD_FLAG_ALLOW_OMM_UPDATE_EX is specified, OMM references may be changed along with positions when an update is performed.
NVAPI_D3D12_RAYTRACING_ACCELERATION_STRUCTURE_BUILD_FLAG_ALLOW_OMM_UPDATE_EX | The acceleration structure (AS) supports updating OMM contents (base OMM Array and/or indices). Specifying this flag may result in larger AS size and may reduce traversal performance.
NVAPI_D3D12_RAYTRACING_ACCELERATION_STRUCTURE_BUILD_FLAG_ALLOW_DISABLE_OMMS_EX | Only applicable for BLAS builds. If enabled, any instances referencing this BLAS are allowed to disable the OMM test through the NVAPI_D3D12_RAYTRACING_INSTANCE_FLAG_DISABLE_OMMS_EX flag. Specifying this build flag may result in some reductions in traversal performance.
NVAPI_D3D12_RAYTRACING_ACCELERATION_STRUCTURE_BUILD_FLAG_ALLOW_OMM_OPACITY_STATES_UPDATE_EX | The acceleration structure (AS) supports updating OMM data (encoded opacity values). Specifying this flag may reduce traversal performance.
NVAPI_D3D12_RAYTRACING_ACCELERATION_STRUCTURE_BUILD_FLAG_ALLOW_DATA_ACCESS_EX | Allows triangle and micro-triangle data to be accessed through the BLAS via shader intrinsics.

◆ _NVAPI_D3D12_RAYTRACING_CAPS_TYPE

enum _NVAPI_D3D12_RAYTRACING_CAPS_TYPE

List of Raytracing CAPS types that can be queried.

Enumerator
NVAPI_D3D12_RAYTRACING_CAPS_TYPE_THREAD_REORDERING
NVAPI_D3D12_RAYTRACING_CAPS_TYPE_OPACITY_MICROMAP
NVAPI_D3D12_RAYTRACING_CAPS_TYPE_DISPLACEMENT_MICROMAP
NVAPI_D3D12_RAYTRACING_CAPS_TYPE_INVALID

◆ _NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_BUILD_FLAGS

enum _NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_BUILD_FLAGS

SUPPORTED OS: Windows 10 and higher Flags specifying building instructions and hints when constructing a DMM Array.

Enumerator
NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_BUILD_FLAG_NONE | No options specified for the DMM Array build.
NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_BUILD_FLAG_PREFER_FAST_TRACE | Allow the DMM Array build to take a little longer in order to optimize for traversal performance. This flag is incompatible with NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_BUILD_FLAG_PREFER_FAST_BUILD.
NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_BUILD_FLAG_PREFER_FAST_BUILD | Spend as little time as possible on the DMM Array build with some potential loss to traversal performance. This flag is incompatible with NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_BUILD_FLAG_PREFER_FAST_TRACE.

◆ _NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_POSTBUILD_INFO_TYPE

enum _NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_POSTBUILD_INFO_TYPE

Type of postbuild info to emit after a DMM Array build.

Enumerator
NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_POSTBUILD_INFO_CURRENT_SIZE

Size of the current DMM Array. May be smaller than reported by the NvAPI_D3D12_GetRaytracingDisplacementMicromapArrayPrebuildInfo() call. Unused memory can be reclaimed by copying the DMM Array into a new resource; see NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_POSTBUILD_INFO_CURRENT_SIZE_DESC.

◆ _NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_CAPS

enum _NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_CAPS

Flags specifying raytracing Displacement Micromap support. Additional flags will be added as support becomes available.

Enumerator
NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_CAP_NONE | Displacement Micromap support is not available. The application must not attempt to use any DMM entrypoints or flags.
NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_CAP_STANDARD | Standard Displacement Micromap support is available.

◆ _NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_FORMAT

enum _NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_FORMAT

Specifies the input Displacement Micromap formats. The DC1 (Displacement Compression 1) format follows the space-filling curve in barycentric space over the uniformly tessellated micro-triangles.

Note
This is a 16-bit value when used in NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_DESC
Enumerator
NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_FORMAT_DC1_64_TRIS_64_BYTES | 64 micro-triangles packed into 64 bytes
NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_FORMAT_DC1_256_TRIS_128_BYTES | 256 micro-triangles packed into 128 bytes
NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_FORMAT_DC1_1024_TRIS_128_BYTES | 1024 micro-triangles packed into 128 bytes

◆ _NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_PRIMITIVE_FLAGS

enum _NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_PRIMITIVE_FLAGS

The edge vA..vB is decimated: after subdivision the number of micro-triangles on that edge is halved. (i.e. the neighboring primitive can have a lower subdivision level without introducing cracks)

Enumerator
NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_PRIMITIVE_FLAG_DECIMATE_01
NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_PRIMITIVE_FLAG_DECIMATE_12
NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_PRIMITIVE_FLAG_DECIMATE_20

◆ _NVAPI_D3D12_RAYTRACING_GEOMETRY_TYPE_EX

enum _NVAPI_D3D12_RAYTRACING_GEOMETRY_TYPE_EX

This enum extends D3D12_RAYTRACING_GEOMETRY_TYPE with additional values. Only new values are fully described below; for more information on the other values, please check Microsoft's DirectX Raytracing Specification.

Enumerator
NVAPI_D3D12_RAYTRACING_GEOMETRY_TYPE_TRIANGLES_EX | This geometry is made of basic triangles.
NVAPI_D3D12_RAYTRACING_GEOMETRY_TYPE_PROCEDURAL_PRIMITIVE_AABBS_EX | This geometry is made of axis-aligned bounding boxes (AABBs).
NVAPI_D3D12_RAYTRACING_GEOMETRY_TYPE_OMM_TRIANGLES_EX | Shares most fields with the basic triangle geometry type, but allows an OMM Array to be attached to the geometry. The basic triangle type and this OMM-enabled type geometries may be mixed in the same BLAS build.
NVAPI_D3D12_RAYTRACING_GEOMETRY_TYPE_DMM_TRIANGLES_EX | Triangle geometry with attached DMM data. This geometry cannot be mixed with other geometry types in the same BLAS.

◆ _NVAPI_D3D12_RAYTRACING_INSTANCE_FLAGS_EX

enum _NVAPI_D3D12_RAYTRACING_INSTANCE_FLAGS_EX

This enum extends D3D12_RAYTRACING_INSTANCE_FLAGS with additional values. Only new values are fully described below; for more information on the other values, please check Microsoft's DirectX Raytracing Specification.

Enumerator
NVAPI_D3D12_RAYTRACING_INSTANCE_FLAG_NONE_EX | No options specified for this instance.
NVAPI_D3D12_RAYTRACING_INSTANCE_FLAG_TRIANGLE_CULL_DISABLE_EX | Disable triangle culling for this instance.
NVAPI_D3D12_RAYTRACING_INSTANCE_FLAG_TRIANGLE_FRONT_COUNTERCLOCKWISE_EX | Use counter-clockwise winding for defining front faces, instead of the default of clockwise winding.
NVAPI_D3D12_RAYTRACING_INSTANCE_FLAG_FORCE_OPAQUE_EX | Force all geometries in this instance to be opaque.
NVAPI_D3D12_RAYTRACING_INSTANCE_FLAG_FORCE_NON_OPAQUE_EX | All geometries in this instance will be processed as if they never had the D3D12_RAYTRACING_GEOMETRY_FLAG_OPAQUE flag applied to them.
NVAPI_D3D12_RAYTRACING_INSTANCE_FLAG_FORCE_OMM_2_STATE_EX | Ignore the Unknown state and only consider the Transparent/Opaque bit for all 4-state OMMs encountered during traversal. This flag has no effect if NVAPI_D3D12_RAYTRACING_INSTANCE_FLAG_DISABLE_OMMS_EX is set.
NVAPI_D3D12_RAYTRACING_INSTANCE_FLAG_DISABLE_OMMS_EX | Disable OMMs for all triangles, and revert to using geometry opaque/non-opaque state instead (legacy behavior). This flag is only valid if the referenced BLAS was built with the NVAPI_D3D12_RAYTRACING_ACCELERATION_STRUCTURE_BUILD_FLAG_ALLOW_DISABLE_OMMS_EX flag; omitting that flag during BLAS build will result in undefined behavior.

◆ _NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_ARRAY_BUILD_FLAGS

enum _NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_ARRAY_BUILD_FLAGS

SUPPORTED OS: Windows 10 and higher Flags specifying building instructions and hints when constructing an OMM Array.

Enumerator
NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_ARRAY_BUILD_FLAG_NONE | No options specified for the OMM Array build.
NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_ARRAY_BUILD_FLAG_PREFER_FAST_TRACE | Allow the OMM Array build to take a little longer in order to optimize for traversal performance. This flag is incompatible with NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_ARRAY_BUILD_FLAG_PREFER_FAST_BUILD.
NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_ARRAY_BUILD_FLAG_PREFER_FAST_BUILD | Spend as little time as possible on the OMM Array build with some potential loss to traversal performance. This flag is incompatible with NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_ARRAY_BUILD_FLAG_PREFER_FAST_TRACE.

◆ _NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_ARRAY_POSTBUILD_INFO_TYPE

enum _NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_ARRAY_POSTBUILD_INFO_TYPE

Type of postbuild info to emit after an OMM Array build.

Enumerator
NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_ARRAY_POSTBUILD_INFO_CURRENT_SIZE

Size of the current OMM Array. May be smaller than reported by the NvAPI_D3D12_GetRaytracingOpacityMicromapArrayPrebuildInfo() call. Unused memory can be reclaimed by copying the OMM Array into a new resource; see NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_ARRAY_POSTBUILD_INFO_CURRENT_SIZE_DESC.

◆ _NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_CAPS

enum _NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_CAPS

Flags specifying raytracing Opacity Micromap support. Additional flags will be added as support becomes available.

Enumerator
NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_CAP_NONE | Opacity Micromap support is not available. The application must not attempt to use any OMM entrypoints or flags.
NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_CAP_STANDARD | Standard Opacity Micromap support is available.

◆ _NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_FORMAT

enum _NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_FORMAT

Specifies the input Opacity Micromap formats. The OC1 (Opacity Compression 1) format follows the space-filling curve in barycentric space over the uniformly tessellated micro-triangles.

Note
This is a 16-bit value when used in NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_DESC.
Enumerator
NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_FORMAT_OC1_2_STATE | 2-state (Transparent/Opaque) format.
NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_FORMAT_OC1_4_STATE | 4-state (Transparent/Opaque, Known/Unknown) format.

◆ _NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_SPECIAL_INDEX

enum _NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_SPECIAL_INDEX

If a triangle has a uniform OMM state in a BLAS build, it is preferable to signal this explicitly rather than attaching a single state OMM. This can be accomplished by supplying these special indices as entries in opacityMicromapIndexBuffer, in NVAPI_D3D12_RAYTRACING_GEOMETRY_OMM_TRIANGLES_DESC.

Enumerator
NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_SPECIAL_INDEX_FULLY_TRANSPARENT | Uniform transparent OMM state.
NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_SPECIAL_INDEX_FULLY_OPAQUE | Uniform opaque OMM state.
NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_SPECIAL_INDEX_FULLY_UNKNOWN_TRANSPARENT | Uniform unknown-transparent OMM state.
NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_SPECIAL_INDEX_FULLY_UNKNOWN_OPAQUE | Uniform unknown-opaque OMM state.

◆ _NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_STATE

enum _NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_STATE

Opacity Micromap micro-triangle states. Not part of any input, but listed here for convenience.

Enumerator
NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_STATE_TRANSPARENT

Transparent OMM state: hit is ignored.

NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_STATE_OPAQUE

Opaque OMM state: hit is committed.

NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_STATE_UNKNOWN_TRANSPARENT

Unknown-transparent OMM state.

  • If operating in 2-state mode, ignore hit.
  • If operating in 4-state mode, invoke any-hit shader.
NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_STATE_UNKNOWN_OPAQUE

Unknown-opaque OMM state.

  • If operating in 2-state mode, commit hit.
  • If operating in 4-state mode, invoke any-hit shader.

◆ _NVAPI_D3D12_RAYTRACING_THREAD_REORDERING_CAPS

enum _NVAPI_D3D12_RAYTRACING_THREAD_REORDERING_CAPS

Flags specifying raytracing thread reordering hardware support. Additional flags will be added as support becomes available.

Enumerator
NVAPI_D3D12_RAYTRACING_THREAD_REORDERING_CAP_NONE | Thread reordering acts as a no-op.
NVAPI_D3D12_RAYTRACING_THREAD_REORDERING_CAP_STANDARD | Standard thread reordering is supported.

◆ _NVAPI_D3D12_RAYTRACING_VALIDATION_FLAGS

enum _NVAPI_D3D12_RAYTRACING_VALIDATION_FLAGS

Flags specifying validation behaviour for raytracing operations.

See NvAPI_D3D12_EnableRaytracingValidation

Enumerator
NVAPI_D3D12_RAYTRACING_VALIDATION_FLAG_NONE

No validation flags.

◆ _NVAPI_D3D12_RAYTRACING_VALIDATION_MESSAGE_SEVERITY

enum _NVAPI_D3D12_RAYTRACING_VALIDATION_MESSAGE_SEVERITY

Severity classification of validation messages.

See NVAPI_D3D12_RAYTRACING_VALIDATION_MESSAGE_CALLBACK

Enumerator
NVAPI_D3D12_RAYTRACING_VALIDATION_MESSAGE_SEVERITY_ERROR | Error message (indicates likely bug)
NVAPI_D3D12_RAYTRACING_VALIDATION_MESSAGE_SEVERITY_WARNING | Warning message (indicates inadvisable usage or possible bug)

◆ _NVAPI_D3D12_SERIALIZED_DATA_TYPE_EX

enum _NVAPI_D3D12_SERIALIZED_DATA_TYPE_EX

Type of serialized data.

Enumerator
NVAPI_D3D12_SERIALIZED_DATA_RAYTRACING_ACCELERATION_STRUCTURE_EX | Serialized data contains a raytracing acceleration structure. Starting from offset 0, the first bytes of the serialized acceleration structure can be reinterpreted as D3D12_SERIALIZED_RAYTRACING_ACCELERATION_STRUCTURE_HEADER. That structure contains the identifier to be passed along to NvAPI_D3D12_CheckDriverMatchingIdentifierEx().
NVAPI_D3D12_SERIALIZED_DATA_RAYTRACING_OPACITY_MICROMAP_ARRAY_EX | Data blob contains an OMM Array. Starting from offset 0, the first bytes of the OMM Array can be reinterpreted as D3D12_SERIALIZED_DATA_DRIVER_MATCHING_IDENTIFIER.
NVAPI_D3D12_SERIALIZED_DATA_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_EX | Data blob contains a DMM Array. Starting from offset 0, the first bytes of the DMM Array can be reinterpreted as D3D12_SERIALIZED_DATA_DRIVER_MATCHING_IDENTIFIER.

◆ _NVAPI_D3D_RESOURCERENDERING_FLAG

enum _NVAPI_D3D_RESOURCERENDERING_FLAG

Used in NvAPI_D3D_BeginResourceRendering().

Enumerator
NVAPI_D3D_RR_FLAG_DEFAULTS | All bits set to 0 are defaults.
NVAPI_D3D_RR_FLAG_FORCE_DISCARD_CONTENT | (bit 0) The flag forces to discard previous content of the resource regardless of the NvApiHints_Sli_Disable_InterframeSync hint
NVAPI_D3D_RR_FLAG_FORCE_KEEP_CONTENT | (bit 1) The flag forces to respect previous content of the resource regardless of the NvApiHints_Sli_Disable_InterframeSync hint
NVAPI_D3D_RR_FLAG_MULTI_FRAME | (bit 2) The flag hints the driver that content will be used for many frames. If not specified then the driver assumes that content is used only on the next frame

◆ _NVAPI_D3D_SETRESOURCEHINT_CATEGORY

enum _NVAPI_D3D_SETRESOURCEHINT_CATEGORY

Valid categories for NvAPI_D3D_SetResourceHint()

Enumerator
NVAPI_D3D_SRH_CATEGORY_SLI

◆ _NVAPI_D3D_SETRESOURCEHINT_SLI

enum _NVAPI_D3D_SETRESOURCEHINT_SLI

Types of SLI hints;
NVAPI_D3D_SRH_SLI_APP_CONTROLLED_INTERFRAME_CONTENT_SYNC: Valid values : 0 or 1
Default value: 0
Explanation: If the value is 1, the driver will not track any rendering operations that would mark this resource as dirty, avoiding any form of synchronization across frames rendered in parallel in multiple GPUs in AFR mode.

NVAPI_D3D_SRH_SLI_ASK_FOR_BROADCAST_USAGE: Valid values : 0 or 1
Default value: 0
Explanation: If the value is 1, the driver will try to perform operations which involved target resource in broadcast, where it's possible. Hint is static and must be set before resource starts using.

NVAPI_D3D_SRH_SLI_RESPECT_DRIVER_INTERFRAME_CONTENT_SYNC: Valid values : 0 or 1
Default value: 0
Explanation: If the value is 1, the driver will do dirty resource resolve regardless of discard flags in the application profile or AFR-FriendlyD3DHints.exe name using.

Enumerator
NVAPI_D3D_SRH_SLI_APP_CONTROLLED_INTERFRAME_CONTENT_SYNC
NVAPI_D3D_SRH_SLI_ASK_FOR_BROADCAST_USAGE
NVAPI_D3D_SRH_SLI_RESPECT_DRIVER_INTERFRAME_CONTENT_SYNC

◆ _NVAPI_RAY_FLAGS_EX

enum _NVAPI_RAY_FLAGS_EX

A list of flags that can be given to the TraceRay() function in HLSL. Only new or modified values are fully described below; for more information on the other values, please check Microsoft's DirectX Raytracing Specification.

Enumerator
NVAPI_RAY_FLAG_NONE_EX | No flag specified.
NVAPI_RAY_FLAG_FORCE_OPAQUE_EX | Consider all intersected geometries to be opaque, regardless of the flags specified at the geometry and instance level.
NVAPI_RAY_FLAG_FORCE_NON_OPAQUE_EX | Consider all intersected geometries to be non-opaque, regardless of the flags specified at the geometry and instance level.
NVAPI_RAY_FLAG_ACCEPT_FIRST_HIT_AND_END_SEARCH_EX | End the traversal as soon as a geometry is hit, and that hit is not ignored by the any hit shader.
NVAPI_RAY_FLAG_SKIP_CLOSEST_HIT_SHADER_EX | Do not invoke the closest hit shader once the traversal ends.
NVAPI_RAY_FLAG_CULL_BACK_FACING_TRIANGLES_EX | Never intersect triangle geometries that are back facing with regard to the ray.
NVAPI_RAY_FLAG_CULL_FRONT_FACING_TRIANGLES_EX | Never intersect triangle geometries that are front facing with regard to the ray.
NVAPI_RAY_FLAG_CULL_OPAQUE_EX | Never intersect geometries that were flagged as opaque.
NVAPI_RAY_FLAG_CULL_NON_OPAQUE_EX | Never intersect geometries that were not flagged as opaque.
NVAPI_RAY_FLAG_SKIP_TRIANGLES_EX | Never intersect triangle geometries.
NVAPI_RAY_FLAG_SKIP_PROCEDURAL_PRIMITIVES_EX | Never intersect AABB geometries.
NVAPI_RAY_FLAG_FORCE_OMM_2_STATE_EX | Treat unknown-opaque and unknown-transparent as opaque and transparent, respectively, during traversal. If an instance is flagged with NVAPI_D3D12_RAYTRACING_INSTANCE_FLAG_DISABLE_OMMS_EX, that takes precedence over this flag.

◆ NV_D3D12_HEAP_FLAGS

enum NV_D3D12_HEAP_FLAGS
Since
Release: 465
DESCRIPTION: NvAPI_D3D12_CreateHeap2 is a wrapper of ID3D12Device::CreateHeap
NV_D3D12_HEAP_FLAG_CPUVISIBLE_VIDMEM gives driver hint to create the heap on vidmem
only upload heaps use this flag currently, others behave exactly as ID3D12Device::CreateHeap
Best practice: Query available space in cpu visible vidmem using NvAPI_D3D12_QueryCpuVisibleVidmem
before using this flag
\param [in] pDevice A pointer to D3D12 device.
\param [in] pDesc A pointer to a D3D12_HEAP_DESC structure that describes the heap
\param [in] pNVHeapParams A pointer to a NV_HEAP_PARAMS structure that gives additional NV specific resource creation information(NV_D3D12_HEAP_FLAGS below for more info)
\param [in] riid The globally unique identifier (GUID) for the resource interface.
\param [out] ppvHeap A pointer to a memory block that receives a pointer to the heap. Cannot be NULL.
SUPPORTED OS: Windows 10 and higher
\return This API can return any of the error codes enumerated in
#NvAPI_Status. If there are return error codes with specific
meaning for this API, they are listed below.
NV_D3D12_HEAP_FLAGS
NV_D3D12_HEAP_FLAGS
Definition nvapi.h:13890
NvAPI_D3D12_QueryCpuVisibleVidmem
NVAPI_INTERFACE NvAPI_D3D12_QueryCpuVisibleVidmem(__in ID3D12Device *pDevice, __out NvU64 *pTotalBytes, __out NvU64 *pFreeBytes)
NV_D3D12_HEAP_FLAG_CPUVISIBLE_VIDMEM
@ NV_D3D12_HEAP_FLAG_CPUVISIBLE_VIDMEM
Hint to create heap in cpuvisible vidmem.
Definition nvapi.h:13892
NvAPI_D3D12_CreateHeap2
NVAPI_INTERFACE NvAPI_D3D12_CreateHeap2(__in ID3D12Device *pDevice, __in const D3D12_HEAP_DESC *pDesc, __in const NV_HEAP_PARAMS *pNVHeapParams, __in REFIID riid, __out void **ppvHeap)
_NV_HEAP_PARAMS_V1
Definition nvapi.h:13896
Enumerator
NV_D3D12_HEAP_FLAG_NONE |
NV_D3D12_HEAP_FLAG_CPUVISIBLE_VIDMEM | Hint to create heap in cpuvisible vidmem.

◆ NV_D3D12_RESOURCE_FLAGS

enum NV_D3D12_RESOURCE_FLAGS
Since
Release: 384
DESCRIPTION: Wrapper around ID3D12Device::CreateCommittedResource to allow creation of resources according to params provided.
HTEX resource is created when NV_D3D12_RESOURCE_FLAG_HTEX is set in the nvResourceFlags parameter.
NV_D3D12_RESOURCE_FLAG_CPUVISIBLE_VIDMEM gives driver hint to create the resource on cpu visible vidmem
only upload resources use this flag currently, others behave exactly as ID3D12Device::CreateCommittedResource
Otherwise the function behaves exactly same as regular ID3D12Device::CreateCommittedResource.
When NV_D3D12_RESOURCE_FLAG_HTEX is set, the texels are centered on integer coordinates and filtering
and LOD are calculated based on the size minus one, which then allows the edges to filter to the exact texels on the edge,
eliminating the border/edge filtering issue. Dimension of next mip level is CEIL(currentMipDimension/2), and size of smallest mip is 2x2.
Note that NV_D3D12_RESOURCE_FLAG_HTEX can't be used for shared resources.
Best practice: Query available space in cpu visible vidmem using NvAPI_D3D12_QueryCpuVisibleVidmem
before using NV_D3D12_RESOURCE_FLAG_CPUVISIBLE_VIDMEM
\param [in] pDevice A pointer to D3D12 device.
\param [in] pHeapProperties A pointer to a D3D12_HEAP_PROPERTIES structure that provides properties for the resource's heap.
\param [in] HeapFlags Heap options, as a bitwise-OR'd combination of D3D12_HEAP_FLAGS enumeration constants.
\param [in] pDesc A pointer to a D3D12_RESOURCE_DESC structure that describes the resource.
\param [in] InitialState The initial state of the resource, as a bitwise-OR'd combination of D3D12_RESOURCE_STATES enumeration constants.
\param [in] pOptimizedClearValue Specifies a D3D12_CLEAR_VALUE that describes the default value for a clear color.
\param [in] pNVResourceParams A pointer to a structure containing additional NV specific resource creation information (see NV_D3D12_RESOURCE_FLAGS below for more info on flags)
\param [in] riid The globally unique identifier (GUID) for the resource interface.
\param [out] ppvResource A pointer to memory that receives the requested interface pointer to the created resource object.
ppvResource can be NULL, to enable capability testing. When ppvResource is NULL, no object will be created and pSupported
will be set to true when pResourceDesc is valid.
\param [out] pSupported optional, needed only for capability testing when ppvResource is NULL
SUPPORTED OS: Windows 10
\return This API can return any of the error codes enumerated in
#NvAPI_Status. If there are return error codes with specific
meaning for this API, they are listed below.
NV_D3D12_RESOURCE_FLAGS
NV_D3D12_RESOURCE_FLAGS
Definition nvapi.h:15201
NV_D3D12_RESOURCE_FLAG_CPUVISIBLE_VIDMEM
@ NV_D3D12_RESOURCE_FLAG_CPUVISIBLE_VIDMEM
Hint to create resource in cpuvisible vidmem.
Definition nvapi.h:15204
NV_D3D12_RESOURCE_FLAG_HTEX
@ NV_D3D12_RESOURCE_FLAG_HTEX
Create HTEX texture.
Definition nvapi.h:15203
Enumerator
NV_D3D12_RESOURCE_FLAG_NONE |
NV_D3D12_RESOURCE_FLAG_HTEX | Create HTEX texture.
NV_D3D12_RESOURCE_FLAG_CPUVISIBLE_VIDMEM | Hint to create resource in cpuvisible vidmem.

◆ NV_LATENCY_MARKER_TYPE

enum NV_LATENCY_MARKER_TYPE

SUPPORTED OS: Windows 7 and higher

Used define latency marker type

Enumerator
SIMULATION_START
SIMULATION_END
RENDERSUBMIT_START
RENDERSUBMIT_END
PRESENT_START
PRESENT_END
INPUT_SAMPLE
TRIGGER_FLASH
PC_LATENCY_PING
OUT_OF_BAND_RENDERSUBMIT_START
OUT_OF_BAND_RENDERSUBMIT_END
OUT_OF_BAND_PRESENT_START
OUT_OF_BAND_PRESENT_END

◆ NV_OUT_OF_BAND_CQ_TYPE

enum NV_OUT_OF_BAND_CQ_TYPE

SUPPORTED OS: Windows 10 and higher

Used in NvAPI_D3D12_NotifyOutOfBandCommandQueue

Enumerator
OUT_OF_BAND_RENDER
OUT_OF_BAND_PRESENT
OUT_OF_BAND_IGNORE

◆ NV_SMP_ASSIST_TYPE

enum NV_SMP_ASSIST_TYPE

SUPPORTED OS: Windows 7 and higher

Enumerator
NV_SMP_ASSIST_NONE
NV_SMP_ASSIST_MRS
NV_SMP_ASSIST_LMS
NV_SMP_ASSIST_NUM_TYPES

◆ NVAPI_ALIAS_SURFACE_FLAG

enum NVAPI_ALIAS_SURFACE_FLAG

See NvAPI_D3D9_AliasSurfaceAsTexture().

Enumerator
NVAPI_ALIAS_SURFACE_FLAG_NONE |
NVAPI_ALIAS_SURFACE_FLAG_USE_SUPER | Use the surface's msaa buffer directly as a texture, rather than resolving. (This is much slower, but potentially has higher quality.)
NVAPI_ALIAS_SURFACE_FLAG_MASK |

◆ NVAPI_DEVICE_FEATURE_LEVEL

enum NVAPI_DEVICE_FEATURE_LEVEL

D3D_FEATURE_LEVEL supported - used in NvAPI_D3D11_CreateDevice() and NvAPI_D3D11_CreateDeviceAndSwapChain()

Enumerator
NVAPI_DEVICE_FEATURE_LEVEL_NULL
NVAPI_DEVICE_FEATURE_LEVEL_10_0
NVAPI_DEVICE_FEATURE_LEVEL_10_0_PLUS
NVAPI_DEVICE_FEATURE_LEVEL_10_1
NVAPI_DEVICE_FEATURE_LEVEL_11_0

◆ NVAPI_VSYNC_MODE

enum NVAPI_VSYNC_MODE
Enumerator
NVAPI_VSYNC_DEFAULT | Fall back to the default settings.
NVAPI_VSYNC_OFF | Force vertical sync off when performance is more important than image quality and for benchmarking".
NVAPI_VSYNC_ON | Force vertical sync on when image quality is more important than performance.
NVAPI_VSYNC_ADAPTIVE | Select adaptive to turn vertical sync on or off based on the frame rate. Vertical sync will only be on for frame rates above the monitor refresh rate.
NVAPI_VSYNC_ADAPTIVE_HALF_REFRESH_RATE |

Function Documentation

◆ DECLARE_INTERFACE()

DECLARE_INTERFACE ( ID3DLateLatchObject_V1 )

See NvAPI_D3D_CreateLateLatchObject

Release the created LateLatch object and associated buffers.

Request to queue the latch operation to the GPU.

Get ID3D11Buffer* available at the given 'index'

Returns the number of late latch buffers created for this LateLatchObject.

Fully update all LateLatch buffers with new data.

Partially update one of the LateLatch buffers with new data.

References __in.

◆ NvAPI_D3D10_SetDepthBoundsTest()

NVAPI_INTERFACE NvAPI_D3D10_SetDepthBoundsTest | ( | ID3D10Device * | pDev,
 |  | NvU32 | bEnable,
 |  | float | fMinDepth,
 |  | float | fMaxDepth
 | ) |  |

DESCRIPTION: This function enables/disables the depth bounds test.

SUPPORTED OS: Windows 7 and higher

Parameters
[in] | pDev | The device to set the depth bounds test
[in] | bEnable | Enable(non-zero)/disable(zero) the depth bounds test
[in] | fMinDepth | The minimum depth for the depth bounds test
[in] fMaxDepth The maximum depth for the depth bounds test
The valid values for fMinDepth and fMaxDepth are such that 0 <= fMinDepth <= fMaxDepth <= 1
Returns
NVAPI_OK if the depth bounds test was correctly enabled or disabled

◆ NvAPI_D3D11_AliasMSAATexture2DAsNonMSAA()

NVAPI_INTERFACE NvAPI_D3D11_AliasMSAATexture2DAsNonMSAA | ( | __in ID3D11Device * | pDevice,
 |  | __in ID3D11Texture2D * | pInputTex,
 |  | __out ID3D11Texture2D ** | ppOutTex
 | ) |  |

SUPPORTED OS: Windows 8 and higher SUPPORTED OS: Windows 8 and higher SUPPORTED OS: Windows 8 and higher SUPPORTED OS: Windows 8 and higher SUPPORTED OS: Windows 7 and higher

DESCRIPTION: This function allows creating (aliasing) a non-MSAA Texture2D object using the same memory as the given multi-sampled
texture (pInputTex). The surface created would be bloated in width and height but it will have SampleCount = 1
For 2X MSAA: OutTex.Width = InputTex.Width * 2, outTex.Height = InputTex.Height
For 4X MSAA: OutTex.Width = InputTex.Width * 2, outTex.Height = InputTex.Height * 2
For 8X MSAA: OutTex.Width = InputTex.Width * 4, outTex.Height = InputTex.Height * 2
Only textures SampleQuality = 0 can be aliased as Non MSAA
The app should ensure that original texture is released only after the aliased copy is released.
This function is free-threaded create compatible i.e. it can be called from a different thread
than the one calling immediate device setstate functions.
\param [in] pDevice current d3d device
\param [in] pInputTex The MultiSampled Texture2D resource that is being aliased
\param [out] ppOutTex The aliased non AA copy MultiSampled Texture2D resource
\return :: NVAPI_OK if the call succeeds.

◆ NvAPI_D3D11_BeginUAVOverlap()

NVAPI_INTERFACE NvAPI_D3D11_BeginUAVOverlap ( __in IUnknown * pDeviceOrContext )

DESCRIPTION: Causes the driver to skip synchronization that is normally needed when accessing UAVs. Applications must use this with caution otherwise this might cause data hazards when multiple draw calls/compute shader launches are accessing same memory locations

SUPPORTED OS: Windows 7 and higher

Parameters
[in] *pDeviceOrContext pointer to D3D11 device, or D3D11 device context

RETURN STATUS: This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.

◆ NvAPI_D3D11_CheckFeatureSupport()

NVAPI_INTERFACE NvAPI_D3D11_CheckFeatureSupport | ( | __in ID3D11Device * | pDevice,
 |  | __in NV_D3D11_FEATURE | Feature,
 |  | __out void * | pFeatureSupportData,
 |  | __in UINT | FeatureSupportDataSize
 | ) |  |

DESCRIPTION: This function gets information about the features that are supported by the current graphics driver.

Parameters
[in] | pDevice | The device on which to query for support.
[in] | Feature | A member of the NvAPI_D3D11_FEATURE enumerated type that describes which feature to query for suppor.
[in] | pFeatureSupportData | Upon completion of the method, the passed structure is filled with data that describes the feature support.
[out] | FeatureSupportDataSize | The size of the structure passed to the pFeatureSupportData parameter.
Since
Release: 410

RETURN STATUS: This API can return any of the error codes enumerated in NvAPI_Status.

Return values
: Returns NVAPI_OK if successful; returns NVAPI_INVALID_ARGUMENT if an unsupported data type is passed to the pFeatureSupportData parameter or a size mismatch is detected for the FeatureSupportDataSize parameter;

◆ NvAPI_D3D11_CreateDevice()

NVAPI_INTERFACE NvAPI_D3D11_CreateDevice | ( | IDXGIAdapter * | pAdapter,
 |  | D3D_DRIVER_TYPE | DriverType,
 |  | HMODULE | Software,
 |  | UINT | Flags,
 |  | CONST D3D_FEATURE_LEVEL * | pFeatureLevels,
 |  | UINT | FeatureLevels,
 |  | UINT | SDKVersion,
 |  | ID3D11Device ** | ppDevice,
 |  | D3D_FEATURE_LEVEL * | pFeatureLevel,
 |  | ID3D11DeviceContext ** | ppImmediateContext,
 |  | NVAPI_DEVICE_FEATURE_LEVEL * | pSupportedLevel
 | ) |  |

DESCRIPTION: This function tries to create a DirectX 11 device. If the call fails (if we are running on pre-DirectX 11 hardware), depending on the type of hardware it will try to create a DirectX 10.1 OR DirectX 10.0+ OR DirectX 10.0 device. The function call is the same as D3D11CreateDevice(), but with an extra argument (D3D_FEATURE_LEVEL supported by the device) that the function fills in. This argument can contain -1 (NVAPI_DEVICE_FEATURE_LEVEL_NULL), if the requested featureLevel is less than DirecX 10.0.

NOTE: When NvAPI_D3D11_CreateDevice is called with 10+ feature level we have an issue on few set of tesla hardware (G80/G84/G86/G92/G94/G96) which does not support all feature level 10+ functionality e.g. calling driver with mismatch between RenderTarget and Depth Buffer. App developers should take into consideration such limitation when using NVAPI on such tesla hardwares. SUPPORTED OS: Windows 7 and higher

Since
Release: 185
Parameters
[in] | pAdapter
[in] | DriverType
[in] | Software
[in] | Flags
[in] | *pFeatureLevels
[in] | FeatureLevels
[in] | SDKVersion
[in] | **ppDevice
[in] | *pFeatureLevel
[in] | **ppImmediateContext
[in] | *pSupportedLevel | D3D_FEATURE_LEVEL supported
Returns
NVAPI_OK if the createDevice call succeeded.

◆ NvAPI_D3D11_CreateDeviceAndSwapChain()

NVAPI_INTERFACE NvAPI_D3D11_CreateDeviceAndSwapChain | ( | IDXGIAdapter * | pAdapter,
 |  | D3D_DRIVER_TYPE | DriverType,
 |  | HMODULE | Software,
 |  | UINT | Flags,
 |  | CONST D3D_FEATURE_LEVEL * | pFeatureLevels,
 |  | UINT | FeatureLevels,
 |  | UINT | SDKVersion,
 |  | CONST DXGI_SWAP_CHAIN_DESC * | pSwapChainDesc,
 |  | IDXGISwapChain ** | ppSwapChain,
 |  | ID3D11Device ** | ppDevice,
 |  | D3D_FEATURE_LEVEL * | pFeatureLevel,
 |  | ID3D11DeviceContext ** | ppImmediateContext,
 |  | NVAPI_DEVICE_FEATURE_LEVEL * | pSupportedLevel
 | ) |  |

DESCRIPTION: This function tries to create a DirectX 11 device and swap chain. If the call fails (if we are running on pre=DirectX 11 hardware), depending on the type of hardware it will try to create a DirectX 10.1 OR DirectX 10.0+ OR DirectX 10.0 device. The function call is the same as D3D11CreateDeviceAndSwapChain,
but with an extra argument (D3D_FEATURE_LEVEL supported by the device) that the function fills in. This argument can contain -1 (NVAPI_DEVICE_FEATURE_LEVEL_NULL), if the requested featureLevel is less than DirectX 10.0.

SUPPORTED OS: Windows 7 and higher

Since
Release: 185
Parameters
[in] | pAdapter
[in] | DriverType
[in] | Software
[in] | Flags
[in] | *pFeatureLevels
[in] | FeatureLevels
[in] | SDKVersion
[in] | *pSwapChainDesc
[in] | **ppSwapChain
[in] | **ppDevice
[in] | *pFeatureLevel
[in] | **ppImmediateContext
[in] | *pSupportedLevel | D3D_FEATURE_LEVEL supported

return NVAPI_OK if the createDevice with swap chain call succeeded.

◆ NvAPI_D3D11_CreateImplicitMSAATexture2D()

NVAPI_INTERFACE NvAPI_D3D11_CreateImplicitMSAATexture2D | ( | __in ID3D11Device * | pDevice,
 |  | __in const D3D11_TEXTURE2D_DESC * | pDesc,
 |  | __out ID3D11Texture2D ** | ppTexture2D
 | ) |  |

SUPPORTED OS: Windows 10 and higher

Since
Release: 410
DESCRIPTION: NvAPI_D3D11_CreateImplicitMSAATexture2D is a simple wrapper of ID3D11Device::CreateTexture2D
which allows to create multisampled 2D texture that is exposed to DX runtime as non-multisampled texture.
\param [in] pDevice Current d3d device
\param [in] pDesc A pointer to a D3D11_TEXTURE2D_DESC structure that describes a 2D texture resource.
To create a typeless resource that can be interpreted at runtime into different,
compatible formats, specify a typeless format in the texture description.
To generatemipmap levels automatically, set the number of mipmap levels to 0.
SampleDesc.SampleCount specifies actual resource sample count, while D3D runtime object
sees resource as non-multisampled.
\param [out] ppTexture2D A pointer to a buffer that receives a pointer to a ID3D11Texture2D interface for the
created texture.
\return This API can return any of the error codes enumerated in
#NvAPI_Status. See MSDN for the API specific error codes.
NvAPI_D3D11_CreateImplicitMSAATexture2D
NVAPI_INTERFACE NvAPI_D3D11_CreateImplicitMSAATexture2D(__in ID3D11Device *pDevice, __in const D3D11_TEXTURE2D_DESC *pDesc, __out ID3D11Texture2D **ppTexture2D)
NvAPI_Status
enum _NvAPI_Status NvAPI_Status

◆ NvAPI_D3D11_CreateMultiGPUDevice()

NVAPI_INTERFACE NvAPI_D3D11_CreateMultiGPUDevice | ( | __in ID3D11Device * | pDevice,
 |  | __in ULONG | version,
 |  | __out ULONG * | currentVersion,
 |  | __out ID3D11MultiGPUDevice ** | ppD3D11MultiGPUDevice,
 |  | __in UINT | maxGpus = ALL_GPUS
 | ) |  |

◆ NvAPI_D3D11_CreateRasterizerState()

NVAPI_INTERFACE NvAPI_D3D11_CreateRasterizerState | ( | __in ID3D11Device * | pDevice,
 |  | __in const NvAPI_D3D11_RASTERIZER_DESC_EX * | pRasterizerDesc,
 |  | __out ID3D11RasterizerState ** | ppRasterizerState
 | ) |  |
DESCRIPTION: This function is an extension of ID3D11Device::CreateRasterizerState with additional raster states
If programmable sample positions is used, to decompress the surface using the currently bound
programmable sample positions, use function NvAPI_D3D11_DecompressView.
This function is free-threaded create compatible i.e. it can be called from a different thread
than the one calling immediate device setstate functions.
\param [in] pDevice current d3d device
\param [in] pRasterizerDesc Rasterizer state description of type NVAPI_D3D11_RASTERIZER_DESC_EX
\param [out] ppRasterizerState ID3D11RasterizerState
\return ::NVAPI_OK if the call succeeds.
NvAPI_D3D11_DecompressView
NVAPI_INTERFACE NvAPI_D3D11_DecompressView(__in ID3D11Device *pDevice, __in ID3D11DeviceContext *pDeviceContext, __in ID3D11View *pView)

◆ NvAPI_D3D11_CreateShadingRateResourceView()

NVAPI_INTERFACE NvAPI_D3D11_CreateShadingRateResourceView | ( | __in ID3D11Device * | pDevice,
 |  | __in ID3D11Resource * | pShadingRateResource,
 |  | __in NV_D3D11_SHADING_RATE_RESOURCE_VIEW_DESC * | pShadingRateResourceViewDesc,
 |  | __out ID3D11NvShadingRateResourceView ** | ppShadingRateResourceView
 | ) |  |

DESCRIPTION: Creates Shading Rate Resource View by taking ID3D11Resource as an input Shading Rate Surface.

SUPPORTED OS: Windows 7 and higher

Since
Release: 410
Parameters
[in] | pDevice | The device to be used for creating the Shading Rate Resource View
[in] | pShadingRateResource | Shading Rate Resource on which the view is to be created.
Note
This should be of format DXGI_FORMAT_R8_UINT or DXGI_FORMAT_R8_TYPELESS
This should be confined to size calculated using render target dimensions, NV_VARIABLE_PIXEL_SHADING_TILE_WIDTH and NV_VARIABLE_PIXEL_SHADING_TILE_HEIGHT
Parameters
[in] | pShadingRateDesc | Shading Rate Resource View descriptor
[out] | ppShadingRateResourceView | Address of a pointer to ID3D11NvShadingRateResourceView for returning the newly created Shading Rate Resource View
Returns
This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below. (none)

◆ NvAPI_D3D11_DecompressView()

NVAPI_INTERFACE NvAPI_D3D11_DecompressView | ( | __in ID3D11Device * | pDevice,
 |  | __in ID3D11DeviceContext * | pDeviceContext,
 |  | __in ID3D11View * | pView
 | ) |  |

SUPPORTED OS: Windows 7 and higher

DESCRIPTION: This function is used to decompress a surface using the currently bound programmable sample positions.
This is needed:
- When writing to a surface in a region previously rendered by different sample positions and no clear was done.
- When reading a surface in a shader that was rendered using non-standard sample positions.
- When copying from a surface that was rendered using non-standard sample positions.
\param [in] pDevice Current d3d11 device
\param [in] pDeviceContext Current d3d11 device context
\param [in] pView Current view to decompress
\return ::NVAPI_OK if the call succeeds.

◆ NvAPI_D3D11_EndUAVOverlap()

NVAPI_INTERFACE NvAPI_D3D11_EndUAVOverlap ( __in IUnknown * pDeviceOrContext )

DESCRIPTION: Re-enables driver synchronization between calls that access same UAVs See NvAPI_D3D_BeginUAVOverlap for more details.

SUPPORTED OS: Windows 7 and higher

Parameters
[in] *pDeviceOrContext pointer to D3D11 device, or D3D11 device context

RETURN STATUS: This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.

◆ NvAPI_D3D11_EnumerateMetaCommands()

NVAPI_INTERFACE NvAPI_D3D11_EnumerateMetaCommands | ( | __in ID3D11Device * | pDevice,
 |  | __inout NvU32 * | pNumMetaCommands,
 |  | __out_ecount_opt *pNumMetaCommands NVAPI_META_COMMAND_DESC * | pDescs
 | ) |  |
Since
Release: 400
DESCRIPTION: Enumerates MetaCommands supported on the system
\param [in] pDevice A pointer to D3D11 device.
\param [in/out] pNumMetaCommands Should be non-null. When the value pointed by pNumMetaCommands is 0 (or when pDescs is NULL), the function returns number of metacommands supported.
When the value pointed is non-zero, the value indicates number of Metacommand descriptions to be populated in pDescs array.
\param [out] pDescs Pointer to array where Metacommand descriptions will be returned. Can be null to indicate that the app is querying the number of supported metacommands.
Otherwise should have enough space to hold *pNumMetaCommands descriptors
SUPPORTED OS: Windows 10
\return This API can return any of the error codes enumerated in
#NvAPI_Status. If there are return error codes with specific
meaning for this API, they are listed below.

◆ NvAPI_D3D11_ExecuteMetaCommand()

NVAPI_INTERFACE NvAPI_D3D11_ExecuteMetaCommand | ( | __in ID3D11DeviceContext * | pDeviceContext,
 |  | __in ID3D11NvMetaCommand * | pMetaCommand,
 |  | __in_bcount(ExecutionParametersDataSize) const void * | pExecutionParametersData,
 |  | __in NvU32 | ExecutionParametersDataSize
 | ) |  |
Since
Release: 400
DESCRIPTION: Executes the given MetaCommand with the parameters passed in
\param [in] pDeviceContext A pointer to the d3d11 device context
\param [in] pMetaCommand the MetaCommand to execute
\param [in] pExecutionParametersData Structure containing parameters
\param [in] ExecutionParametersDataSize Size of the parameter structure in bytes
SUPPORTED OS: Windows 10
\return This API can return any of the error codes enumerated in
#NvAPI_Status. If there are return error codes with specific
meaning for this API, they are listed below.

◆ NvAPI_D3D11_InitializeMetaCommand()

NVAPI_INTERFACE NvAPI_D3D11_InitializeMetaCommand | ( | __in ID3D11DeviceContext * | pDeviceContext,
 |  | __in ID3D11NvMetaCommand * | pMetaCommand,
 |  | __in_bcount(InitializationParametersDataSize) const void * | pInitializationParametersData,
 |  | __in NvU32 | InitializationParametersDataSize
 | ) |  |
Since
Release: 400
DESCRIPTION: Initializes the given MetaCommand with the parameters passed in
\param [in] pDeviceContext A pointer to the d3d11 device context
\param [in] pMetaCommand the MetaCommand to initialize
\param [in] pInitializationParametersData Structure containing parameters
\param [in] InitializationParametersDataSize Size of the parameter structure in bytes
SUPPORTED OS: Windows 10
\return This API can return any of the error codes enumerated in
#NvAPI_Status. If there are return error codes with specific
meaning for this API, they are listed below.

◆ NvAPI_D3D11_IsNvShaderExtnOpCodeSupported()

NVAPI_INTERFACE NvAPI_D3D11_IsNvShaderExtnOpCodeSupported | ( | __in IUnknown * | pDev,
 |  | __in NvU32 | opCode,
 |  | __out bool * | pSupported
 | ) |  |

DESCRIPTION: This function checks if a nv HLSL shader extension opcode is supported on current hardware. List of opcodes is in nvShaderExtnEnums.h To use Nvidia HLSL extensions the application must include nvHLSLExtns.h in the hlsl shader code. See nvHLSLExtns.h for more details on supported opcodes.

This function can be called from a different thread than the one calling immediate device setstate functions.

SUPPORTED OS: Windows 7 and higher

Parameters
[in] | pDev | The device on which to query for support, should be a ID3D11Device+ device
[in] | opCode | the opcode to check
[out] | pSupported | true if supported, false otherwise

RETURN STATUS: This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.

Return values
: NVAPI_OK if the call succeeded

◆ NvAPI_D3D11_MultiDrawIndexedInstancedIndirect()

NVAPI_INTERFACE NvAPI_D3D11_MultiDrawIndexedInstancedIndirect | ( | __in ID3D11DeviceContext * | pDevContext11,
 |  | __in NvU32 | drawCount,
 |  | __in ID3D11Buffer * | pBuffer,
 |  | __in NvU32 | alignedByteOffsetForArgs,
 |  | __in NvU32 | alignedByteStrideForArgs
 | ) |  |

DESCRIPTION: Extension of DrawIndexedInstancedIndirect that takes a draw count in. The effect of this function is to loop over that draw count and perform the DrawIndexedInstancedIndirect operation each time, incrementing the buffer offset by the supplied stride each time.

SUPPORTED OS: Windows 7 and higher

Parameters
[in] | *pDevContext11 | Pointer to D3D11 device context (IC or DC)
[in] | drawCount | Do DrawIndexedInstancedIndirect operation this many times
[in] | *pBuffer | ID3D11Buffer that contains the command parameters
[in] | alignedByteOffsetForArgs | Start in pBuffer of the command parameters
[in] | alignedByteStrideForArgs | Stride of the command parameters - must be >= 5 * sizeof(NvU32)

RETURN STATUS: This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.

Return values
NVAPI_D3D_DEVICE_NOT_REGISTERED When MultiDraw is called on a deferred context, and the device has not yet been registered (NvAPI_D3D_RegisterDevice), this error is returned.

◆ NvAPI_D3D11_MultiDrawInstancedIndirect()

NVAPI_INTERFACE NvAPI_D3D11_MultiDrawInstancedIndirect | ( | __in ID3D11DeviceContext * | pDevContext11,
 |  | __in NvU32 | drawCount,
 |  | __in ID3D11Buffer * | pBuffer,
 |  | __in NvU32 | alignedByteOffsetForArgs,
 |  | __in NvU32 | alignedByteStrideForArgs
 | ) |  |

DESCRIPTION: Extension of DrawInstancedIndirect that takes a draw count in. The effect of this function is to loop over that draw count and perform the DrawInstancedIndirect operation each time, incrementing the buffer offset by the supplied stride each time.

SUPPORTED OS: Windows 7 and higher

Parameters
[in] | *pDevContext11 | Pointer to D3D11 device context (IC or DC)
[in] | drawCount | Do DrawInstancedIndirect operation this many times
[in] | *pBuffer | ID3D11Buffer that contains the command parameters
[in] | alignedByteOffsetForArgs | Start in pBuffer of the command parameters
[in] | alignedByteStrideForArgs | Stride of the command parameters - must be >= 4 * sizeof(NvU32)

RETURN STATUS: This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.

Return values
NVAPI_D3D_DEVICE_NOT_REGISTERED When MultiDraw is called on a deferred context, and the device has not yet been registered (NvAPI_D3D_RegisterDevice), this error is returned.

◆ NvAPI_D3D11_MultiGPU_GetCaps()

NVAPI_INTERFACE NvAPI_D3D11_MultiGPU_GetCaps ( __inout PNV_MULTIGPU_CAPS pMultiGPUCaps )

SUPPORTED OS: Windows 7 and higher

◆ NvAPI_D3D11_MultiGPU_Init()

NVAPI_INTERFACE NvAPI_D3D11_MultiGPU_Init ( __in bool bEnable )

SUPPORTED OS: Windows 7 and higher DESCRIPTION: Request to enable/disable multi GPU extension. Also if enabled automatically disables auto stereo.

Parameters
[in] bEnable if true enables the extension for all subsequently created devices. Otherwise disables it
Return values
NVAPI_OK | Call succeeded.
NVAPI_ERROR | Call failed.

◆ NvAPI_D3D11_ResolveSubresourceRegion()

NVAPI_INTERFACE NvAPI_D3D11_ResolveSubresourceRegion | ( | __in ID3D11Device * | pDevice,
 |  | __in ID3D11Texture2D * | pDstResource,
 |  | __in UINT | DstSubresource,
 |  | __in UINT | DstX,
 |  | __in UINT | DstY,
 |  | __in ID3D11Texture2D * | pSrcResource,
 |  | __in UINT | SrcSubresource,
 |  | __in_opt const RECT * | pSrcRect,
 |  | __in DXGI_FORMAT | Format,
 |  | __in NV_RESOLVE_MODE | ResolveMode
 | ) |  |
Since
Release: 410
DESCRIPTION: NvAPI_D3D11_ResolveSubresourceRegion is D3D11 an analog of D3D12 ResolveSubresourceRegion.
\param [in] pDstResource Destination resource. Must be a created with the D3D11_USAGE_DEFAULT flag and be single-sampled.
\param [in] DstSubresource A zero-based index, that identifies the destination subresource. Use D3D11CalcSubresource to calculate the index.
\param [in] DstX The X coordinate of the left-most edge of the destination region.
The width of the destination region is the same as the width of the source rect.
\param [in] DstY The Y coordinate of the top-most edge of the destination region.
The height of the destination region is the same as the height of the source rect.
\param [in] pSrcResource Source resource. Must be multisampled.
\param [in] SrcSubresource The source subresource of the source resource.
\param [in] pSrcRect Specifies the rectangular region of the source resource to be resolved.
Passing NULL for pSrcRect specifies that the entire subresource is to be resolved.
\param [in] Format A DXGI_FORMAT that indicates how the multisampled resource will be resolved to a single-sampled resource.
\param [in] ResolveMode Specifies the operation used to resolve the source samples. NV_RESOLVE_MODE_SAMPLE_0 is the only supported mode.
NV_RESOLVE_MODE_SAMPLE_0 outputs sample 0 and discards all other samples.
\return This API can return any of the error codes enumerated in
#NvAPI_Status. See MSDN for the API specific error codes.
NvAPI_D3D11_ResolveSubresourceRegion
NVAPI_INTERFACE NvAPI_D3D11_ResolveSubresourceRegion(__in ID3D11Device *pDevice, __in ID3D11Texture2D *pDstResource, __in UINT DstSubresource, __in UINT DstX, __in UINT DstY, __in ID3D11Texture2D *pSrcResource, __in UINT SrcSubresource, __in_opt const RECT *pSrcRect, __in DXGI_FORMAT Format, __in NV_RESOLVE_MODE ResolveMode)
NV_RESOLVE_MODE_SAMPLE_0
@ NV_RESOLVE_MODE_SAMPLE_0
Definition nvapi.h:12509

◆ NvAPI_D3D11_RSGetPixelShadingRateSampleOrder()

NVAPI_INTERFACE NvAPI_D3D11_RSGetPixelShadingRateSampleOrder | ( | __in IUnknown * | pContext,
 |  | __out NV_PIXEL_SHADING_RATE_SAMPLE_ORDER_TABLE * | pSampleOrderTable
 | ) |  |

DESCRIPTION: Get the Sample Order for Variable Shading Rate

SUPPORTED OS: Windows 7 and higher

Since
Release: 410
Parameters
[in] | pContext | The device context (ID3D11DeviceContext) used for getting the Shading Rate Sample Order
[out] | pSampleOrderTable | A pointer to NV_PIXEL_SHADING_RATE_SAMPLE_ORDER_TABLE where the current Sample Order for Variable Pixel Rate Shading that is returned
Returns
This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below. (none)

◆ NvAPI_D3D11_RSSetExclusiveScissorRects()

NVAPI_INTERFACE NvAPI_D3D11_RSSetExclusiveScissorRects | ( | __in IUnknown * | pContext,
 |  | __in NV_D3D11_EXCLUSIVE_SCISSOR_RECTS_DESC * | pExclusiveScissorRectsDesc
 | ) |  |

DESCRIPTION: Sets Exclusive Scissor Rects. The content bounded within the Scissor Rects will be excluded from rendering unlike regular Scissor Rects. These are orthogonal with Regular Scissor Rects.

SUPPORTED OS: Windows 7 and higher

Since
Release: 410
Parameters
[in] | pContext | The device context (ID3D11DeviceContext) to be used for setting the Exclusive Scissor Rects.
[in] | pExclusiveScissorRectsDesc | Description of the Exclusive Scissor Rects duly filled with their dimensions and control over enablement of individual ScissorRect
Returns
This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below. (none)

◆ NvAPI_D3D11_RSSetPixelShadingRateSampleOrder()

NVAPI_INTERFACE NvAPI_D3D11_RSSetPixelShadingRateSampleOrder | ( | __in IUnknown * | pContext,
 |  | __in NV_PIXEL_SHADING_RATE_SAMPLE_ORDER_TABLE * | pSampleOrderTable
 | ) |  |

DESCRIPTION: Set the Sample Order for Variable Shading Rate

SUPPORTED OS: Windows 7 and higher

Since
Release: 410
Parameters
[in] | pContext | The device context (ID3D11DeviceContext) used for setting the Shading Rate Sample Order
[out] | pSampleOrderTable | Sample Order for Variable Shading Rate to be set
Returns
This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below. (none)

◆ NvAPI_D3D11_RSSetShadingRateResourceView()

NVAPI_INTERFACE NvAPI_D3D11_RSSetShadingRateResourceView | ( | __in IUnknown * | pContext,
 |  | __in ID3D11NvShadingRateResourceView * | pShadingRateResourceView
 | ) |  |

DESCRIPTION: Sets Shading Rate Resource View

SUPPORTED OS: Windows 7 and higher

Since
Release: 410
Parameters
[in] | pContext | The device context (ID3D11DeviceContext) used for setting the Shading Rate Resource View
[out] | pShadingRateResourceView | Shading Rate Resource View to be set
Note
See NvAPI_D3D11_CreateShadingRateResourceView
Passing this as null will reset Shading Rate Resource View to defaults
Returns
This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below. (none)

◆ NvAPI_D3D11_RSSetViewportsPixelShadingRates()

NVAPI_INTERFACE NvAPI_D3D11_RSSetViewportsPixelShadingRates | ( | __in IUnknown * | pContext,
 |  | __in NV_D3D11_VIEWPORTS_SHADING_RATE_DESC * | pShadingRateDesc
 | ) |  |

DESCRIPTION: Sets Pixel Shading Rates and Enables/Disables per-viewport Variable Pixel Shading Rate feature

SUPPORTED OS: Windows 7 and higher

Since
Release: 410
Parameters
[in] | pContext | The device context (ID3D11DeviceContext) to be used for setting the Viewports Shading Rates
[in] | pShadingRateDesc | Shading rate descriptor
Returns
This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below. (none)

◆ NvAPI_D3D11_SetDepthBoundsTest()

NVAPI_INTERFACE NvAPI_D3D11_SetDepthBoundsTest | ( | IUnknown * | pDeviceOrContext,
 |  | NvU32 | bEnable,
 |  | float | fMinDepth,
 |  | float | fMaxDepth
 | ) |  |

DESCRIPTION: This function enables/disables the depth bounds test

SUPPORTED OS: Windows 7 and higher

Parameters
[in] | pDeviceOrContext | The device or device context to set depth bounds test
[in] | bEnable | Enable(non-zero)/disable(zero) the depth bounds test
[in] | fMinDepth | The minimum depth for depth bounds test
[in] | fMaxDepth | The maximum depth for depth bounds test The valid values for fMinDepth and fMaxDepth are such that 0 <= fMinDepth <= fMaxDepth <= 1
Returns
NVAPI_OK if the depth bounds test was correcly enabled or disabled

◆ NvAPI_D3D11_SetNvShaderExtnSlot()

NVAPI_INTERFACE NvAPI_D3D11_SetNvShaderExtnSlot | ( | __in IUnknown * | pDev,
 |  | __in NvU32 | uavSlot
 | ) |  |

DESCRIPTION: This function sets the fake UAV slot that is used by Nvidia HLSL shader extensions globally. All createShader calls made to the driver after setting this slot would treat writes/reads to this UAV in a different way. Applications are expected to bind null UAV to this slot. The same slot is used for all shader stages. To disable shader extensions the app need to set this uav slot to 0xFFFFFFFF. To use Nvidia HLSL extensions the application must include nvHLSLExtns.h in the hlsl shader code. See nvHLSLExtns.h for more details.

This function can be called from a different thread than the one calling immediate device setstate functions.

SUPPORTED OS: Windows 7 and higher

Parameters
[in] | pDev | The device for which to set the extension slot should be a ID3D11Device+ device
[in] | uavSlot | the uav slot to use

RETURN STATUS: This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.

Return values
: NVAPI_OK : success, the uavSlot was set sucessfully

◆ NvAPI_D3D11_SetNvShaderExtnSlotLocalThread()

NVAPI_INTERFACE NvAPI_D3D11_SetNvShaderExtnSlotLocalThread | ( | __in IUnknown * | pDev,
 |  | __in NvU32 | uavSlot
 | ) |  |

DESCRIPTION: This function sets the fake UAV slot that is used by Nvidia HLSL shader extensions on local thread. All createShader calls on the same thread that calls this function after setting this slot would treat writes/reads to this UAV in a different way. Applications are expected to bind null UAV to this slot. The same slot is used for all shader stages. To disable shader extensions the app may set this uav slot to 0xFFFFFFFF. To use Nvidia HLSL extensions the application must include nvHLSLExtns.h in the hlsl shader code. See nvHLSLExtns.h for more details.

This function can be called from a different thread than the one calling immediate device setstate functions.

SUPPORTED OS: Windows 7 and higher

Since
Release: 387
Parameters
[in] | pDev | The device for which to set the extension slot should be a ID3D11Device+ device
[in] | uavSlot | the uav slot to use

RETURN STATUS: This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.

Return values
: NVAPI_OK : success, the uavSlot was set sucessfully

◆ NvAPI_D3D12_BuildRaytracingAccelerationStructureEx()

NVAPI_INTERFACE NvAPI_D3D12_BuildRaytracingAccelerationStructureEx | ( | __in ID3D12GraphicsCommandList4 * | pCommandList,
 |  | __in const NVAPI_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_EX_PARAMS * | pParams
 | ) |  |

DESCRIPTION: Perform an acceleration structure build on the GPU. Also optionally output postbuild information immediately after the build. This function is an extension of ID3D12GraphicsCommandList4::BuildRaytracingAccelerationStructure() with additional serialized data types.

Note
Only supported on GPUs capable of DXR. Some of the flags and fields have further restrictions, in which case their description will include a note with more details.

SUPPORTED OS: Windows 10 and higher

Since
Release: 520
Parameters
[in] | pCommandList | Command list on which the command will execute.
[in] | pParams | Wrapper around the inputs and outputs of the function.
Returns
This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.
Return values
NVAPI_INVALID_COMBINATION pParams->pPostbuildInfoDescs was set to NULL while pParams->numPostbuildInfoDescs is non zero.

◆ NvAPI_D3D12_BuildRaytracingDisplacementMicromapArray()

NVAPI_INTERFACE NvAPI_D3D12_BuildRaytracingDisplacementMicromapArray | ( | __in ID3D12GraphicsCommandList4 * | pCommandList,
 |  | __in NVAPI_BUILD_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PARAMS * | pParams
 | ) |  |

DESCRIPTION: Construct DMM Array for a collection of DMMs on the GPU. The CPU-side input buffers are not referenced after this call. The GPU-side input resources are not referenced after the build has concluded after ExecuteCommandList(). Additionally, the application may optionally output postbuild information immediately after the build.

SUPPORTED OS: Windows 10 and higher

Since
Release: 525
Parameters
[in] | pCommandList | Command list on which the command will execute.
[in] | pParams | Wrapper around the inputs of the function.
Returns
This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.
Return values
NVAPI_INVALID_COMBINATION pParams->pPostbuildInfoDescs was set to NULL while pParams->numPostbuildInfoDescs is non zero.

◆ NvAPI_D3D12_BuildRaytracingOpacityMicromapArray()

NVAPI_INTERFACE NvAPI_D3D12_BuildRaytracingOpacityMicromapArray | ( | __in ID3D12GraphicsCommandList4 * | pCommandList,
 |  | __in NVAPI_BUILD_RAYTRACING_OPACITY_MICROMAP_ARRAY_PARAMS * | pParams
 | ) |  |

DESCRIPTION: Construct OMM Array for a collection of OMMs on the GPU. The CPU-side input buffers are not referenced after this call. The GPU-side input resources are not referenced after the build has concluded after ExecuteCommandList(). Additionally, the application may optionally output postbuild information immediately after the build.

SUPPORTED OS: Windows 10 and higher

Since
Release: 520
Parameters
[in] | pCommandList | Command list on which the command will execute.
[in] | pParams | Wrapper around the inputs and outputs of the function.
Returns
This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.
Return values
NVAPI_INVALID_COMBINATION pParams->pPostbuildInfoDescs was set to NULL while pParams->numPostbuildInfoDescs is non zero.

◆ NvAPI_D3D12_CheckDriverMatchingIdentifierEx()

NVAPI_INTERFACE NvAPI_D3D12_CheckDriverMatchingIdentifierEx | ( | __in ID3D12Device5 * | pDevice,
 |  | __inout NVAPI_CHECK_DRIVER_MATCHING_IDENTIFIER_EX_PARAMS * | pParams
 | ) |  |

DESCRIPTION: This function is an extension of ID3D12Device5::CheckDriverMatchingIdentifier() with additional serialized data types.

SUPPORTED OS: Windows 10 and higher

Since
Release: 520
Parameters
[in] | pDevice | Device on which the data will be deserialized.
[in,out] | pParams | Wrapper around the inputs and outputs of the function.
Returns
This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.

◆ NvAPI_D3D12_CopyTextureRegion()

NVAPI_INTERFACE NvAPI_D3D12_CopyTextureRegion | ( | __in ID3D12GraphicsCommandList * | pCommandList,
 |  | __in const D3D12_TEXTURE_COPY_LOCATION * | pDst,
 |  | __in UINT | DstX,
 |  | __in UINT | DstY,
 |  | __in UINT | DstZ,
 |  | __in const D3D12_TEXTURE_COPY_LOCATION * | pSrc,
 |  | __in_opt const D3D12_BOX * | pSrcBox
 | ) |  |
Since
Release: 384
DESCRIPTION: Wrapper around ID3D12GraphicsCommandList::CopyTextureRegion for allowing copying to/from HTEX resources
created using NvAPI_D3D12_CreatePlacedResource with NV_D3D12_RESOURCE_FLAG_HTEX flag.
\param [in] pCommandList A pointer to D3D12 graphics command list.
\param [in] pDst Specifies the destination D3D12_TEXTURE_COPY_LOCATION. The subresource referred to must be in the D3D12_RESOURCE_STATE_COPY_DEST state.
\param [in] DstX The x-coordinate of the upper left corner of the destination region.
\param [in] DstY The y-coordinate of the upper left corner of the destination region.
\param [in] DstZ The z-coordinate of the upper left corner of the destination region.
\param [in] pSrc Specifies the source D3D12_TEXTURE_COPY_LOCATION. The subresource referred to must be in the D3D12_RESOURCE_STATE_COPY_SOURCE state.
\param [in] pSrcBox Specifies an optional D3D12_BOX that sets the size of the source texture to copy.
SUPPORTED OS: Windows 10
\return This API can return any of the error codes enumerated in
#NvAPI_Status. If there are return error codes with specific
meaning for this API, they are listed below.

◆ NvAPI_D3D12_CopyTileMappings()

NVAPI_INTERFACE NvAPI_D3D12_CopyTileMappings | ( | __in ID3D12CommandQueue * | pCommandQueue,
 |  | __in ID3D12Resource * | pDstResource,
 |  | __in const D3D12_TILED_RESOURCE_COORDINATE * | pDstRegionStartCoordinate,
 |  | __in ID3D12Resource * | pSrcResource,
 |  | __in const D3D12_TILED_RESOURCE_COORDINATE * | pSrcRegionStartCoordinate,
 |  | __in const D3D12_TILE_REGION_SIZE * | pRegionSize,
 |  | __in D3D12_TILE_MAPPING_FLAGS | Flags
 | ) |  |
Since
Release: 375
DESCRIPTION: NvAPI_D3D12_CopyTileMappings is an extension of ID3D12CommandQueue::CopyTileMappings
pDstResource and pSrcResource must be created by NvAPI_D3D12_CreateReservedResource.
\param [in] pCommandQueue A pointer to ID3D12CommandQueue.
\param [in] pDstResource Tiled resource created by NvAPI_D3D12_CreateReservedResource to copy tile mappings into.
\param [in] pDstRegionStartCoordinate A pointer to a D3D12_TILED_RESOURCE_COORDINATE structure that describes the starting coordinates of the destination reserved resource.
\param [in] pSrcResource Tiled resource created by NvAPI_D3D12_CreateReservedResource to copy tile mappings from.
\param [in] pSourceRegionStartCoordinate A pointer to a D3D12_TILED_RESOURCE_COORDINATE structure that describes the starting coordinates of the source reserved resource.
\param [in] pTileRegionSize A pointer to a D3D12_TILE_REGION_SIZE structure that describes the size of the reserved region.
\param [in] Flags One member of D3D12_TILE_MAPPING_FLAGS.
SUPPORTED OS: Windows 10
\return This API can return any of the error codes enumerated in
#NvAPI_Status. If there are return error codes with specific
meaning for this API, they are listed below.
NvAPI_D3D12_CopyTileMappings
NVAPI_INTERFACE NvAPI_D3D12_CopyTileMappings(__in ID3D12CommandQueue *pCommandQueue, __in ID3D12Resource *pDstResource, __in const D3D12_TILED_RESOURCE_COORDINATE *pDstRegionStartCoordinate, __in ID3D12Resource *pSrcResource, __in const D3D12_TILED_RESOURCE_COORDINATE *pSrcRegionStartCoordinate, __in const D3D12_TILE_REGION_SIZE *pRegionSize, __in D3D12_TILE_MAPPING_FLAGS Flags)
NvAPI_D3D12_CreateReservedResource
NVAPI_INTERFACE NvAPI_D3D12_CreateReservedResource(__in ID3D12Device *pDevice, __in const D3D12_RESOURCE_DESC *pDesc, __in D3D12_RESOURCE_STATES InitialState, __in const D3D12_CLEAR_VALUE *pOptimizedClearValue, __in REFIID riid, __out void **ppvResource, __in bool bTexture2DArrayMipPack, __in ID3D12Heap *pHeap)

◆ NvAPI_D3D12_CreateCommittedImplicitMSAATexture2D()

NVAPI_INTERFACE NvAPI_D3D12_CreateCommittedImplicitMSAATexture2D | ( | __in ID3D12Device * | pDevice,
 |  | __in const D3D12_HEAP_PROPERTIES * | pHeapProperties,
 |  | D3D12_HEAP_FLAGS | HeapFlags,
 |  | __in const D3D12_RESOURCE_DESC * | pDesc,
 |  | D3D12_RESOURCE_STATES | InitialResourceState,
 |  | __in_opt const D3D12_CLEAR_VALUE * | pOptimizedClearValue,
 |  | REFIID | riidResource,
 |  | __out void ** | ppvResource
 | ) |  |

SUPPORTED OS: Windows 10 and higher

Since
Release: 410
DESCRIPTION: NvAPI_D3D12_CreateCommittedImplicitMSAATexture2D is a simple wrapper of ID3D12Device::CreateCommittedResource
which allows to create multisampled 2D texture that is exposed to DX runtime as non-multisampled texture.
\param [in] pDevice Current d3d device
\param [in] pDesc A pointer to a D3D12_RESOURCE_DESC structure that describes a 2D texture resource.
To create a typeless resource that can be interpreted at runtime into different,
compatible formats, specify a typeless format in the texture description.
To generatemipmap levels automatically, set the number of mipmap levels to 0.
SampleDesc.SampleCount specifies actual resource sample count, while D3D runtime object
sees resource as non-multisampled.
\param [in] pHeapProperties, HeapFlags, InitialResourceState, pOptimizedClearValue, riidResource See D3D12 docs
\param [out] ppResource Same ID3D12Device::CreateCommittedResource
\return This API can return any of the error codes enumerated in
#NvAPI_Status. See MSDN for the API specific error codes.
NvAPI_D3D12_CreateCommittedImplicitMSAATexture2D
NVAPI_INTERFACE NvAPI_D3D12_CreateCommittedImplicitMSAATexture2D(__in ID3D12Device *pDevice, __in const D3D12_HEAP_PROPERTIES *pHeapProperties, D3D12_HEAP_FLAGS HeapFlags, __in const D3D12_RESOURCE_DESC *pDesc, D3D12_RESOURCE_STATES InitialResourceState, __in_opt const D3D12_CLEAR_VALUE *pOptimizedClearValue, REFIID riidResource, __out void **ppvResource)

◆ NvAPI_D3D12_CreateCommittedRDMABuffer()

NVAPI_INTERFACE NvAPI_D3D12_CreateCommittedRDMABuffer | ( | __in ID3D12Device * | pDevice,
 |  | __in NvU64 | size,
 |  | __in NvU32 | heapCreationNodeMask,
 |  | __in NvU32 | heapVisibleNodeMask,
 |  | __in REFIID | riidResource,
 |  | __out void ** | ppvResource,
 |  | __out void ** | ppRDMAAddress
 | ) |  |
Since
Release: 530
DESCRIPTION: NvAPI_D3D12_CreateCommittedRDMABuffer is a wrapper of ID3D12Device::CreateCommittedResource
which allows to allocate linear memory which can be used for remote direct memory access (RDMA) from other devices.
It creates an implicit D3D12 heap of the requested size, allocates the resource and returns an RDMA address for remote direct memory access.
The created memory will reside on the specified device local memory and won't be cpu accessible.
\param [in] pDevice A pointer to a D3D12 device.
\param [in] size Size in bytes of the linear buffer to be allocated for the resource.
\param [in] heapCreationNodeMask This mask indicates the node where the resource should be created.
\param [in] heapVisibleNodeMask This mask indicates on which nodes the resource is accessible.
\param [in] riidResource The globally unique identifier (GUID) for the resource interface.
\param [out] ppvResource A pointer to memory that receives the requested interface pointer to the created resource object.
\param [out] ppRDMAAddress A pointer to memory that receives the Bar1 memory region for remote direct memory access.
SUPPORTED OS: Windows 10 and higher
\return This API can return any of the error codes enumerated in
#NvAPI_Status.
NvAPI_D3D12_CreateCommittedRDMABuffer
NVAPI_INTERFACE NvAPI_D3D12_CreateCommittedRDMABuffer(__in ID3D12Device *pDevice, __in NvU64 size, __in NvU32 heapCreationNodeMask, __in NvU32 heapVisibleNodeMask, __in REFIID riidResource, __out void **ppvResource, __out void **ppRDMAAddress)

◆ NvAPI_D3D12_CreateComputePipelineState()

NVAPI_INTERFACE NvAPI_D3D12_CreateComputePipelineState | ( | __in ID3D12Device * | pDevice,
 |  | __in const D3D12_COMPUTE_PIPELINE_STATE_DESC * | pPSODesc,
 |  | NvU32 | numExtensions,
 |  | __in const NVAPI_D3D12_PSO_EXTENSION_DESC ** | ppExtensions,
 |  | __out ID3D12PipelineState ** | ppPSO
 | ) |  |
DESCRIPTION: This function will create PSO with provided extensions
\param [in] pDevice Current d3d device
\param [in] pPSODesc PSO description of type D3D12_COMPUTE_PIPELINE_STATE_DESC
\param [in] numExtensions Number of extensions
\param [in] ppExtensions Array of PSO extensions (see NV_PSO_EXTENSION for possible extensions)
\param [out] ppPSO Output PSO object of type ID3D12PipelineState
\since Release: 364
SUPPORTED OS: Windows 10
\return ::NVAPI_OK if the call succeeds.
NV_PSO_EXTENSION
enum _NV_PSO_EXTENSION NV_PSO_EXTENSION

◆ NvAPI_D3D12_CreateDDisplayPresentBarrierClient()

NVAPI_INTERFACE NvAPI_D3D12_CreateDDisplayPresentBarrierClient | ( | __in ID3D12Device * | pDevice,
 |  | __in NvU32 | sourceId,
 |  | __out NvPresentBarrierClientHandle * | pPresentBarrierClient
 | ) |  |

SUPPORTED OS: Windows 10 and higher DESCRIPTION: This API returns an NvPresentBarrierClientHandle handle.

Since
Release: 510
Parameters
[in] | pDevice | The ID3D12Device device which executes the rendering commands of this PresentBarrier client. It must be created on the same adapter as DisplayDevice.
[in] | sourceId | The adapter-relative identifier for the DisplaySource obtained from DisplaySource.SourceId().
[OUT] | pPresentBarrierClient Pointer to an NvPresentBarrierClientHandle handle created by the driver on success.
Returns
NVAPI_OK the call succeeded
NVAPI_ERROR the call failed
NVAPI_INVALID_POINTER an invalid pointer was passed as an argument
NVAPI_INVALID_HANDLE the input displaySource handle is not owned by the process
NVAPI_NOT_SUPPORTED PresentBarrier featue is not supported on this configuration
NVAPI_NO_IMPLEMENTATION the API is not implemented
Return values
NVAPI_API_NOT_INITIALIZED NvAPI not initialized

◆ NvAPI_D3D12_CreateGraphicsPipelineState()

NVAPI_INTERFACE NvAPI_D3D12_CreateGraphicsPipelineState | ( | __in ID3D12Device * | pDevice,
 |  | __in const D3D12_GRAPHICS_PIPELINE_STATE_DESC * | pPSODesc,
 |  | NvU32 | numExtensions,
 |  | __in const NVAPI_D3D12_PSO_EXTENSION_DESC ** | ppExtensions,
 |  | __out ID3D12PipelineState ** | ppPSO
 | ) |  |
DESCRIPTION: This function will create PSO with provided extensions
\note Note that "Cached PSO" functionality is not supported with the Pipeline State Object created using
this NvAPI. GetCachedBlob() should not be called with such a PSO.
\param [in] pDevice Current d3d device
\param [in] pPSODesc PSO description of type D3D12_GRAPHICS_PIPELINE_STATE_DESC
\param [in] numExtensions Number of extensions
\param [in] ppExtensions Array of PSO extensions (see NV_PSO_EXTENSION for possible extensions)
\param [out] ppPSO Output PSO object of type ID3D12PipelineState
SUPPORTED OS: Windows 10
\return ::NVAPI_OK if the call succeeds.
NVAPI_OK
@ NVAPI_OK
Success. Request is completed.
Definition nvapi_lite_common.h:258

◆ NvAPI_D3D12_CreateHeap()

NVAPI_INTERFACE NvAPI_D3D12_CreateHeap | ( | __in ID3D12Device * | pDevice,
 |  | __in const D3D12_HEAP_DESC * | pDesc,
 |  | __in REFIID | riid,
 |  | __out void ** | ppvHeap
 | ) |  |
Since
Release: 375
DESCRIPTION: NvAPI_D3D12_CreateHeap is a safe replacement of ID3D12Device::CreateHeap with no functionality change and overhead.
In NvAPI_D3D12_UpdateTileMappings, pTilePool must be created with NvAPI_D3D12_CreateHeap and otherwise NvAPI_D3D12_UpdateTileMappings will fail.
In other word, any tile pool used in NvAPI_D3D12_UpdateTileMappings must be created by NvAPI_D3D12_CreateHeap.
\param [in] pDevice A pointer to D3D12 device.
\param [in] pDesc A pointer to a D3D12_HEAP_DESC structure that describes the heap.
\param [in] riid The globally unique identifier (GUID) for the resource interface.
\param [out] ppvHeap A pointer to a memory block that receives a pointer to the heap. Cannot be NULL.
SUPPORTED OS: Windows 10
\return This API can return any of the error codes enumerated in
#NvAPI_Status. If there are return error codes with specific
meaning for this API, they are listed below.
NvAPI_D3D12_UpdateTileMappings
NVAPI_INTERFACE NvAPI_D3D12_UpdateTileMappings(__in ID3D12CommandQueue *pCommandQueue, __in ID3D12Resource *pResource, __in UINT NumResourceRegions, __in const D3D12_TILED_RESOURCE_COORDINATE *pResourceRegionStartCoordinates, __in const D3D12_TILE_REGION_SIZE *pResourceRegionSizes, __in ID3D12Heap *pHeap, __in UINT NumRanges, __in const D3D12_TILE_RANGE_FLAGS *pRangeFlags, __in const UINT *pHeapRangeStartOffsets, __in const UINT *pRangeTileCounts, __in D3D12_TILE_MAPPING_FLAGS Flags)
NvAPI_D3D12_CreateHeap
NVAPI_INTERFACE NvAPI_D3D12_CreateHeap(__in ID3D12Device *pDevice, __in const D3D12_HEAP_DESC *pDesc, __in REFIID riid, __out void **ppvHeap)

◆ NvAPI_D3D12_CreatePresentBarrierClient()

NVAPI_INTERFACE NvAPI_D3D12_CreatePresentBarrierClient | ( | __in ID3D12Device * | pDevice,
 |  | __in IDXGISwapChain * | pSwapChain,
 |  | __out NvPresentBarrierClientHandle * | pPresentBarrierClient
 | ) |  |

SUPPORTED OS: Windows 10 and higher DESCRIPTION: This API returns an NvPresentBarrierClientHandle handle, which owns the swapchain to be synchronized through PresentBarrier. This handle is used in other PresentBarrier functions.

Since
Release: 470
Parameters
[in] | pDevice | The ID3D12Device device which owns the SwapChain as a PresentBarrier client.
[in] | pSwapChain | The IDXGISwapChain interface that presentBarrier is operated on.
[OUT] | pPresentBarrierClient Pointer to an NvPresentBarrierClientHandle handle created by the driver on success.
Returns
NVAPI_OK the call succeeded
NVAPI_ERROR the call failed
NVAPI_INVALID_POINTER an invalid pointer was passed as an argument
NVAPI_NO_IMPLEMENTATION the API is not implemented
Return values
NVAPI_API_NOT_INITIALIZED NvAPI not initialized

◆ NvAPI_D3D12_CreateReservedResource()

NVAPI_INTERFACE NvAPI_D3D12_CreateReservedResource | ( | __in ID3D12Device * | pDevice,
 |  | __in const D3D12_RESOURCE_DESC * | pDesc,
 |  | __in D3D12_RESOURCE_STATES | InitialState,
 |  | __in const D3D12_CLEAR_VALUE * | pOptimizedClearValue,
 |  | __in REFIID | riid,
 |  | __out void ** | ppvResource,
 |  | __in bool | bTexture2DArrayMipPack,
 |  | __in ID3D12Heap * | pHeap
 | ) |  |
Since
Release: 375
DESCRIPTION: Tiled resource is supported for Texture2D Array, however, but only when mip packing is not triggered.
So any mip level cannot be smaller than a single tile size(64KB).
This set of API is an extension of D3D12 support for tiled resource to allow a tiled texture2D array with mip packing.
If any of API from this set is used, using all of them is highly recommended.
It includes NvAPI_D3D12_CreateReservedResource, NvAPI_D3D12_CreateHeap, NvAPI_D3D12_ReservedResourceGetDesc,
NvAPI_D3D12_UpdateTileMappings, NvAPI_D3D12_CopyTileMappings, NvAPI_D3D12_ResourceAliasingBarrier.
Reminder: all API in this set other than NvAPI_D3D12_CreateReservedResource won't has D3D Debug Layer information.
NvAPI_D3D12_CreateReservedResource is an extension of ID3D12Device::CreateReservedResource.
Use this function to create a tiled Texture2D array with mip packing.
Runtime doesn't know the created resource is actually a tiled resource.
Any other D3D12 API where runtime will check whether resource is tiled or not, has a corresponding NVAPI version and they should be used.
Different from DX11 implementation, we highly recommend replace all ID3D12Device::CreateReservedResource with NvAPI_D3D12_CreateReservedResource,
and use bTexture2DArrayMipPack to control which creation to use.
Otherwise, NvAPI_D3D12_ResourceAliasingBarrier will fail if any resource is not created by NvAPI_D3D12_CreateReservedResource.
DX11 implementation doesn't have this restriction and resource created by NVAPI and D3D API can be used together.
pHeap is necessary when bTexture2DArrayMipPack is true. pHeap can be any heap and this API doens't change anything to it.
\param [in] pDevice A pointer to D3D12 device.
\param [in] pDesc A pointer to a D3D12_RESOURCE_DESC structure that describes the resource.
\param [in] InitialState The initial state of the resource, as a bitwise-OR'd combination of D3D12_RESOURCE_STATES enumeration constants.
\param [in] pOptimizedClearValue Specifies a D3D12_CLEAR_VALUE that describes the default value for a clear color.
\param [in] riid The globally unique identifier (GUID) for the resource interface.
\param [out] ppvResource A pointer to a memory block that receives a pointer to the resource. Cannot be NULL.
\param [in] bTexture2DArrayMipPack Whether pDesc indicates it's a texture2D array resource with mip packing.
TRUE: Use NVAPI to create. Will check pHeap to be not NULL.
FALSE: Standard D3D12 API will be used, use DebugDevice to check any runtime ERROR. Won't check pHeap
\param [in] pHeap A pointer to ID3D12Heap. Cannot be NULL when bTexture2DArrayMipPack is true.
SUPPORTED OS: Windows 10
\return This API can return any of the error codes enumerated in
#NvAPI_Status. If there are return error codes with specific
meaning for this API, they are listed below.
NvAPI_D3D12_ReservedResourceGetDesc
NVAPI_INTERFACE NvAPI_D3D12_ReservedResourceGetDesc(__in ID3D12Resource *pReservedResource, __out D3D12_RESOURCE_DESC *pDesc)
NvAPI_D3D12_ResourceAliasingBarrier
NVAPI_INTERFACE NvAPI_D3D12_ResourceAliasingBarrier(__in ID3D12GraphicsCommandList *pCommandList, __in UINT NumBarriers, __in const D3D12_RESOURCE_BARRIER *pBarriers)

◆ NvAPI_D3D12_EmitRaytracingDisplacementMicromapArrayPostbuildInfo()

NVAPI_INTERFACE NvAPI_D3D12_EmitRaytracingDisplacementMicromapArrayPostbuildInfo | ( | __in ID3D12GraphicsCommandList4 * | pCommandList,
 |  | __in const NVAPI_EMIT_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_POSTBUILD_INFO_PARAMS * | pParams
 | ) |  |

DESCRIPTION: Emits information about one or more DMM Arrays, only available after the DMM Array constructions have finished.

SUPPORTED OS: Windows 10 and higher

Since
Release: 525
Parameters
[in] | pCommandList | Command list on which the command will execute.
[in] | pParams | Wrapper around the inputs of the function.
Returns
This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.

◆ NvAPI_D3D12_EmitRaytracingOpacityMicromapArrayPostbuildInfo()

NVAPI_INTERFACE NvAPI_D3D12_EmitRaytracingOpacityMicromapArrayPostbuildInfo | ( | __in ID3D12GraphicsCommandList4 * | pCommandList,
 |  | __in const NVAPI_EMIT_RAYTRACING_OPACITY_MICROMAP_ARRAY_POSTBUILD_INFO_PARAMS * | pParams
 | ) |  |

DESCRIPTION: Emits information about one or more OMM Arrays, only available after the OMM Array constructions have finished.

SUPPORTED OS: Windows 10 and higher

Since
Release: 520
Parameters
[in] | pCommandList | Command list on which the command will execute.
[in] | pParams | Wrapper around the inputs and outputs of the function.
Returns
This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.

◆ NvAPI_D3D12_EnableRaytracingValidation()

NVAPI_INTERFACE NvAPI_D3D12_EnableRaytracingValidation | ( | __in ID3D12Device5 * | pDevice,
 |  | __in NVAPI_D3D12_RAYTRACING_VALIDATION_FLAGS | flags
 | ) |  |

DESCRIPTION: Enable raytracing validation for a device. This function must be called before any other raytracing-related function is invoked on the device. Raytracing validation can only be enabled when the NV_ALLOW_RAYTRACING_VALIDATION envvar is set to 1.

SUPPORTED OS: Windows 10 and higher

Since
Release: 545
Parameters
[in] | pDevice | Pointer to the device on which raytracing validation should be enabled.
[in] | flags | Raytracing validation flags.
Returns
This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.
Return values
NVAPI_OK | Completed request
NVAPI_INVALID_POINTER | A null pointer was passed as device argument
NVAPI_INVALID_ARGUMENT | An unsupported flag was specified
NVAPI_INVALID_CALL | The call was made too late (other raytracing-related calls have already been made)
NVAPI_ACCESS_DENIED | Validation is not allowed by envvar

◆ NvAPI_D3D12_EnumerateMetaCommands()

NVAPI_INTERFACE NvAPI_D3D12_EnumerateMetaCommands | ( | __in ID3D12Device * | pDevice,
 |  | __inout NvU32 * | pNumMetaCommands,
 |  | __out_ecount_opt *pNumMetaCommands NVAPI_META_COMMAND_DESC * | pDescs
 | ) |  |
Since
Release: 400
DESCRIPTION: Enumerates MetaCommands supported on the system
\param [in] pDevice A pointer to D3D12 device.
\param [in/out] pNumMetaCommands Should be non-null. When the value pointed by pNumMetaCommands is 0 or when pDescs is NULL, the function returns number of metacommands supported.
When the value pointed is non-zero, the value indicates number of Metacommand descriptions to be populated in pDescs array.
\param [out] pDescs Pointer to array where Metacommand descriptions will be returned. Can be null to indicate that the app is querying the number of supported metacommands.
Otherwise should have enough space to hold *pNumMetaCommands descriptors
SUPPORTED OS: Windows 10
\return This API can return any of the error codes enumerated in
#NvAPI_Status. If there are return error codes with specific
meaning for this API, they are listed below.

◆ NvAPI_D3D12_ExecuteMetaCommand()

NVAPI_INTERFACE NvAPI_D3D12_ExecuteMetaCommand | ( | __in ID3D12GraphicsCommandList * | pCommandlist,
 |  | __in ID3D12NvMetaCommand * | pMetaCommand,
 |  | __in_bcount(ExecutionParametersDataSize) const void * | pExecutionParametersData,
 |  | __in NvU32 | ExecutionParametersDataSize
 | ) |  |
Since
Release: 400
DESCRIPTION: Executes the given MetaCommand with the parameters passed in
\param [in] pCommandList A pointer to D3D12 command list.
\param [in] pMetaCommand the MetaCommand to execute
\param [in] pExecutionParametersData Structure containing parameters
\param [in] ExecutionParametersDataSize Size of the parameter structure in bytes
SUPPORTED OS: Windows 10
\return This API can return any of the error codes enumerated in
#NvAPI_Status. If there are return error codes with specific
meaning for this API, they are listed below.

◆ NvAPI_D3D12_FlushRaytracingValidationMessages()

NVAPI_INTERFACE NvAPI_D3D12_FlushRaytracingValidationMessages ( __in ID3D12Device5 * pDevice )

DESCRIPTION: Flush any validation messages that have not yet been reported. This guarantees that any validation messages for work which is known to be complete on the GPU at the time of the call are reported to registered callbacks. This operation is lightweight if the flushed device does not have raytracing validation enabled.

SUPPORTED OS: Windows 10 and higher

Since
Release: 545
Parameters
[in] pDevice Pointer to the device on which raytracing validation messages should be flushed.
Returns
This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.
Return values
NVAPI_OK | Completed request
NVAPI_INVALID_POINTER | A null pointer was passed as device argument

◆ NvAPI_D3D12_GetCopyableFootprints()

NVAPI_INTERFACE NvAPI_D3D12_GetCopyableFootprints | ( | __in ID3D12Device * | pDevice,
 |  | __in const D3D12_RESOURCE_DESC * | pResourceDesc,
 |  | __in const NV_RESOURCE_PARAMS * | pNVResourceParams,
 |  | __in UINT | FirstSubresource,
 |  | __in UINT | NumSubresources,
 |  | __in UINT64 | BaseOffset,
 |  | __out_ecount_opt(NumSubresources) D3D12_PLACED_SUBRESOURCE_FOOTPRINT * | pLayouts,
 |  | __out_ecount_opt(NumSubresources) UINT * | pNumRows,
 |  | __out_ecount_opt(NumSubresources) UINT64 * | pRowSizeInBytes,
 |  | __out_opt UINT64 * | pTotalBytes
 | ) |  |
Since
Release: 384
DESCRIPTION: Wrapper around ID3D12Device::GetCopyableFootprints for getting correct staging resource footprint for HTEX resources
created using NvAPI_D3D12_CreateCommittedResource / NvAPI_D3D12_CreatePlacedResource with NV_D3D12_RESOURCE_FLAG_HTEX flag
\param [in] pDevice A pointer to D3D12 device.
\param [in] pResourceDesc A description of the resource, as a pointer to a D3D12_RESOURCE_DESC structure.
\param [in] pNVResourceParams A pointer to a structure containing additional NV specific resource information
\param [in] FirstSubresource Index of the first subresource in the resource. The range of valid values is 0 to D3D12_REQ_SUBRESOURCES
\param [in] NumSubresources The number of subresources in the resource. The range of valid values is 0 to (D3D12_REQ_SUBRESOURCES - FirstSubresource).
\param [in] BaseOffset The offset, in bytes, to the resource.
\param [out] pLayouts A pointer to an array (of length NumSubresources) of D3D12_PLACED_SUBRESOURCE_FOOTPRINT structures, to be filled with the
description and placement of each subresource.
\param [out] pRowSizeInBytes A pointer to an array (of length NumSubresources) of integer variables, each entry to be
filled with the unpadded size in bytes of a row, of each subresource.
\param [out] pTotalBytes A pointer to an integer variable, to be filled with the total size, in bytes.
SUPPORTED OS: Windows 10
\return This API can return any of the error codes enumerated in
#NvAPI_Status. If there are return error codes with specific
meaning for this API, they are listed below.
NvAPI_D3D12_CreateCommittedResource
NVAPI_INTERFACE NvAPI_D3D12_CreateCommittedResource(__in ID3D12Device *pDevice, __in const D3D12_HEAP_PROPERTIES *pHeapProperties, __in D3D12_HEAP_FLAGS HeapFlags, __in const D3D12_RESOURCE_DESC *pDesc, __in D3D12_RESOURCE_STATES InitialState, __in const D3D12_CLEAR_VALUE *pOptimizedClearValue, __in const NV_RESOURCE_PARAMS *pNVResourceParams, __in REFIID riid, __out_opt void **ppvResource, __out_opt bool *pSupported)

◆ NvAPI_D3D12_GetGraphicsCapabilities()

NVAPI_INTERFACE NvAPI_D3D12_GetGraphicsCapabilities | ( | __in IUnknown * | pDevice,
 |  | __in NvU32 | structVersion,
 |  | __inout NV_D3D12_GRAPHICS_CAPS * | pGraphicsCaps
 | ) |  |

DESCRIPTION: Get the graphics capabilities for current hardware/software setup

SUPPORTED OS: Windows 10 and higher

Since
Release: 410
Parameters
[in] | pDevice | The ID3D12Device device to be used for getting the graphics capabilities.
[in] | structVersion | Version of the caps struct. Should be set to NV_D3D12_GRAPHICS_CAPS_VER.
[in,out] | pGraphicsCaps | Pointer to a NV_D3D12_GRAPHICS_CAPS_CAPS struct created by app. Graphics capabilities will be filled in this struct by the driver.
Returns
This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below. (none)

◆ NvAPI_D3D12_GetNeedsAppFPBlendClamping()

NVAPI_INTERFACE NvAPI_D3D12_GetNeedsAppFPBlendClamping | ( | __in ID3D12Device * | pDevice,
 |  | __out bool * | pAppClampNeeded
 | ) |  |
DESCRIPTION: This function returns whether the application needs to do FP blend clamping itself
\param [in] pDevice Current d3d device
\param [out] pAppClampNeeded If true, app needs to clamp. If false, HW does the clamping
\return This API can return any of the error codes enumerated in
#NvAPI_Status. If there are return error codes with specific
meaning for this API, they are listed below.
\since Release: 375
SUPPORTED OS: Windows 10

◆ NvAPI_D3D12_GetOptimalThreadCountForMesh()

NVAPI_INTERFACE NvAPI_D3D12_GetOptimalThreadCountForMesh | ( | __in ID3D12Device * | pDevice,
 |  | __out NvU32 * | pThreadCount
 | ) |  |

DESCRIPTION: This function returns optimal thread count for mesh and task aka amplification shaders if Meshlets supported Otherwise returns 0.

Since
Release: 510 SUPPORTED OS: Windows 10 and higher
Parameters
[in] | pDevice | The device on which to query thread count
[out] | pThreadCount | optimal thread count if Meshlets supported, 0 otherwise

RETURN STATUS: This API can return any of the error codes enumerated in NvAPI_Status.

Return values
: NVAPI_OK if the call succeeded

◆ NvAPI_D3D12_GetRaytracingAccelerationStructurePrebuildInfoEx()

NVAPI_INTERFACE NvAPI_D3D12_GetRaytracingAccelerationStructurePrebuildInfoEx | ( | __in ID3D12Device5 * | pDevice,
 |  | __inout NVAPI_GET_RAYTRACING_ACCELERATION_STRUCTURE_PREBUILD_INFO_EX_PARAMS * | pParams
 | ) |  |

DESCRIPTION: This function is an extension of ID3D12Device5::GetRaytracingAccelerationStructurePrebuildInfo() with additional input types.

Note
Only supported on GPUs capable of DXR. Some of the flags and fields have further restrictions, in which case their description will include a note with more details.

SUPPORTED OS: Windows 10 and higher

Since
Release: 520
Parameters
[in] | pDevice | Device on which the acceleration structure will be built.
[in,out] | pParams | Wrapper around the inputs and outputs of the function.
Returns
This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.

◆ NvAPI_D3D12_GetRaytracingCaps()

NVAPI_INTERFACE NvAPI_D3D12_GetRaytracingCaps | ( | __in ID3D12Device * | pDevice,
 |  | __in NVAPI_D3D12_RAYTRACING_CAPS_TYPE | type,
 |  | __out void * | pData,
 |  | __in size_t | dataSize
 | ) |  |

DESCRIPTION: Query raytracing capabilities of a device.

SUPPORTED OS: Windows 10 and higher

Since
Release: 520
Parameters
[in] | pDevice | Pointer to the device on which raytracing caps should be queried from.
[in] | type | Raytracing caps type requested. (ex: NVAPI_D3D12_RAYTRACING_CAPS_TYPE_THREAD_REORDERING)
[out] | pData | Pointer to memory that receives caps. (ex: NVAPI_D3D12_RAYTRACING_THREAD_REORDERING_CAPS*)
[in] | dataSize | Size in bytes to return to pData. Must match the size of the caps data requested. (ex: sizeof(NVAPI_D3D12_RAYTRACING_THREAD_REORDERING_CAPS))
Returns
This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.
Return values
NVAPI_OK | Completed request
NVAPI_INVALID_POINTER | A null pointer was passed as an argument
NVAPI_INVALID_ARGUMENT | At least one of the arguments are invalid
NVAPI_ERROR | Error occurred

◆ NvAPI_D3D12_GetRaytracingDisplacementMicromapArrayPrebuildInfo()

NVAPI_INTERFACE NvAPI_D3D12_GetRaytracingDisplacementMicromapArrayPrebuildInfo | ( | __in ID3D12Device5 * | pDevice,
 |  | __inout NVAPI_GET_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PREBUILD_INFO_PARAMS * | pParams
 | ) |  |

DESCRIPTION: Query conservative memory requirements for building a DMM (Displacement Micromap) Array. The returned size is conservative for DMM Array builds containing a lower or equal number of entries for each resolution and format combination.

SUPPORTED OS: Windows 10 and higher

Since
Release: 525
Parameters
[in] | pDevice | Device on which the DMM Array will be built.
[in,out] | pParams | Wrapper around the inputs and outputs of the function.
Returns
This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.

◆ NvAPI_D3D12_GetRaytracingOpacityMicromapArrayPrebuildInfo()

NVAPI_INTERFACE NvAPI_D3D12_GetRaytracingOpacityMicromapArrayPrebuildInfo | ( | __in ID3D12Device5 * | pDevice,
 |  | __inout NVAPI_GET_RAYTRACING_OPACITY_MICROMAP_ARRAY_PREBUILD_INFO_PARAMS * | pParams
 | ) |  |

DESCRIPTION: Query conservative memory requirements for building an OMM (Opacity Micromap) Array. The returned size is conservative for OMM Array builds containing a lower or equal number of entries for each resolution and format combination.

SUPPORTED OS: Windows 10 and higher

Since
Release: 520
Parameters
[in] | pDevice | Device on which the OMM Array will be built.
[in,out] | pParams | Wrapper around the inputs and outputs of the function.
Returns
This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.

◆ NvAPI_D3D12_InitializeMetaCommand()

NVAPI_INTERFACE NvAPI_D3D12_InitializeMetaCommand | ( | __in ID3D12GraphicsCommandList * | pCommandlist,
 |  | __in ID3D12NvMetaCommand * | pMetaCommand,
 |  | __in_bcount(InitializationParametersDataSize) const void * | pInitializationParametersData,
 |  | __in NvU32 | InitializationParametersDataSize
 | ) |  |
Since
Release: 400
DESCRIPTION: Initializes the given MetaCommand with the parameters passed in
\param [in] pCommandList A pointer to D3D12 command list.
\param [in] pMetaCommand the MetaCommand to initialize
\param [in] pInitializationParametersData Structure containing parameters
\param [in] InitializationParametersDataSize Size of the parameter structure in bytes
SUPPORTED OS: Windows 10
\return This API can return any of the error codes enumerated in
#NvAPI_Status. If there are return error codes with specific
meaning for this API, they are listed below.

◆ NvAPI_D3D12_IsNvShaderExtnOpCodeSupported()

NVAPI_INTERFACE NvAPI_D3D12_IsNvShaderExtnOpCodeSupported | ( | __in ID3D12Device * | pDevice,
 |  | __in NvU32 | opCode,
 |  | __out bool * | pSupported
 | ) |  |

DESCRIPTION: This function checks if a nv HLSL shader extension opcode is supported on current hardware. List of opcodes is in nvShaderExtnEnums.h To use Nvidia HLSL extensions the application must include nvHLSLExtns.h in the hlsl shader code. See nvHLSLExtns.h for more details on supported opcodes.

Since
Release: 364

SUPPORTED OS: Windows 10

Parameters
[in] | pDev | The device on which to query for support
[in] | opCode | the opcode to check
[out] | pSupported | true if supported, false otherwise

RETURN STATUS: This API can return any of the error codes enumerated in NvAPI_Status.

Return values
: NVAPI_OK if the call succeeded

◆ NvAPI_D3D12_Mosaic_GetCompanionAllocations()

NVAPI_INTERFACE NvAPI_D3D12_Mosaic_GetCompanionAllocations ( __inout NV_D3D12_MOSAIC_GETCOMPANIONALLOCATIONS * params )

DESCRIPTION: Queries the driver for internally created allocations that accompany a swap chain buffer for present-related operations. Surfaces returned by this interface must be destroied at the same time that the original swap chain buffer is destroyed. In general this occurs prior to a ResizeBuffers call, or when the swap chain is released. Note that this function only works in Landscape orientation due to Windows behavior, and attempts to utilize it with any type of display rotation will result in failure.

Parameters
[in,out] companionBufferCount The parameters for this function.
Return values
NVAPI_OK | Call succeeded.
NVAPI_ERROR | Call failed.
NVAPI_INVALID_ARGUMENT | One or more arguments are invalid.
NVAPI_INVALID_CALL | System configuration does not support this interface (eg, display is rotated, mosaic not enabled, etc)

<>

◆ NvAPI_D3D12_Mosaic_GetViewportAndGpuPartitions()

NVAPI_INTERFACE NvAPI_D3D12_Mosaic_GetViewportAndGpuPartitions ( __inout NV_D3D12_MOSAIC_GETVIEWPORTANDGPUPARTITIONS * params )

DESCRIPTION: Queries the driver for how a swap chain display surface is subdivided across devices in relation to display connectivity. Call this interface with NULL pPartitions in order to know how many subdivisions exist and allocate the proper size to hold all data. Call it a second time with a properly sized partitions array to receive all subdivisions along with GPU node masks of each rectangle. Note that this function only works in Landscape orientation due to Windows behavior, and attempts to utilize it with any type of display rotation will result in failure.

Parameters
[in,out] params The parameters for this function.
Return values
NVAPI_OK | Call succeeded.
NVAPI_ERROR | Call failed.
NVAPI_INVALID_ARGUMENT | One or more arguments are invalid.
NVAPI_INVALID_CALL | System configuration does not support this interface (eg, display is rotated, mosaic not enabled, etc)

<>

◆ NvAPI_D3D12_NotifyOutOfBandCommandQueue()

NVAPI_INTERFACE NvAPI_D3D12_NotifyOutOfBandCommandQueue | ( | __in ID3D12CommandQueue * | pCommandQueue,
 |  | __in NV_OUT_OF_BAND_CQ_TYPE | cqType
 | ) |  |

DESCRIPTION: Notifies the driver that this command queue runs out of band from the application's frame cadence.

Since
Release: 520
Parameters
[in] | pCommandQueue | The D3D12CommandQueue
[in] | cqType | The type of out of band command queue SUPPORTED OS: Windows 10 and higher
Returns
This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.

◆ NvAPI_D3D12_QueryCpuVisibleVidmem()

NVAPI_INTERFACE NvAPI_D3D12_QueryCpuVisibleVidmem | ( | __in ID3D12Device * | pDevice,
 |  | __out NvU64 * | pTotalBytes,
 |  | __out NvU64 * | pFreeBytes
 | ) |  |
Since
Release: 465
DESCRIPTION: NvAPI_D3D12_QueryCpuVisibleVidmem queries total bytes and unused bytes in
cpu visible vdmem
\param [in] pDevice A pointer to D3D12 device.
\param [out] pTotalBytes Total bytes in cpu visible vidmem
\param [out] pFreeBytes Unused bytes in cpu visible vidmem
SUPPORTED OS: Windows 10 and higher
\return This API can return any of the error codes enumerated in
#NvAPI_Status. If there are return error codes with specific
meaning for this API, they are listed below.

◆ NvAPI_D3D12_QueryModifiedWSupport()

NVAPI_INTERFACE NvAPI_D3D12_QueryModifiedWSupport | ( | __in ID3D12Device * | pDevice,
 |  | __inout NV_QUERY_MODIFIED_W_SUPPORT_PARAMS * | pQueryModifiedWSupportedParams
 | ) |  |

DESCRIPTION: Queries the support of Modified-W feature on current setup and returns appropriate boolean value.

SUPPORTED OS: Windows 10

Parameters
[in] | pDevice | The ID3D12Device Device created by application
[in,out] | pQueryModifiedWSupportedParams | Stores value of whether Modified-W is supported on current setup or not.
Return values
NVAPI_OK | Call succeeded.
NVAPI_ERROR | Call failed.
NVAPI_INVALID_ARGUMENT | One or more arguments are invalid.

<>

◆ NvAPI_D3D12_QueryPresentBarrierSupport()

NVAPI_INTERFACE NvAPI_D3D12_QueryPresentBarrierSupport | ( | __in ID3D12Device * | pDevice,
 |  | __out bool * | pSupported
 | ) |  |

SUPPORTED OS: Windows 10 and higher DESCRIPTION: This API returns if presentBarrier feature is supported on the specified device.

Since
Release: 470
Parameters
[in] | pDevice | The ID3D12Device device which owns the SwapChain as a PresentBarrier client.
[out] | pSupported | Pointer to a boolean returning true if supported, false otherwise.
Returns
NVAPI_OK the call succeeded
NVAPI_ERROR the call failed
NVAPI_NO_IMPLEMENTATION the API is not implemented
NVAPI_INVALID_POINTER an invalid pointer was passed as an argument
Return values
NVAPI_API_NOT_INITIALIZED NvAPI not initialized

◆ NvAPI_D3D12_QuerySinglePassStereoSupport()

NVAPI_INTERFACE NvAPI_D3D12_QuerySinglePassStereoSupport | ( | __in ID3D12Device * | pDevice,
 |  | __inout NV_QUERY_SINGLE_PASS_STEREO_SUPPORT_PARAMS * | pQuerySinglePassStereoSupportedParams
 | ) |  |

DESCRIPTION: Queries the support of Single Pass Stereo feature on current setup and returns appropriate boolean value.

SUPPORTED OS: Windows 10

Parameters
[in] | pDevice | The IDirect3DDevice12 to use.
[in,out] | pQuerySinglePassStereoSupportedParams | Stores value of whether Single Pass Stereo is supported on current setup or not.
Return values
NVAPI_OK | Call succeeded.
NVAPI_ERROR | Call failed.
NVAPI_INVALID_ARGUMENT | One or more arguments are invalid.

<>

◆ NvAPI_D3D12_QueryWorkstationFeatureProperties()

NVAPI_INTERFACE NvAPI_D3D12_QueryWorkstationFeatureProperties | ( | __in ID3D12Device * | pDevice,
 |  | __inout NVAPI_D3D12_WORKSTATION_FEATURE_PROPERTIES_PARAMS * | pWorkstationFeatureProperties
 | ) |  |

DESCRIPTION: This API returns information about the properties of specific workstation features on the specified device.

Since
Release: 530
Parameters
[in] | pDevice | The ID3D12Device device which is queried for feature properties
[in,out] | pWorkstationFeatureProperties | Pointer to a structure containing workstation feature query information.
Returns
NVAPI_OK the call succeeded
NVAPI_ERROR the call failed
NVAPI_NO_IMPLEMENTATION the API is not implemented
NVAPI_INVALID_POINTER an invalid pointer was passed as an argument
Return values
NVAPI_API_NOT_INITIALIZED NvAPI not initialized

SUPPORTED OS: Windows 10 and higher

◆ NvAPI_D3D12_RegisterPresentBarrierResources()

NVAPI_INTERFACE NvAPI_D3D12_RegisterPresentBarrierResources | ( | __in NvPresentBarrierClientHandle | presentBarrierClient,
 |  | __in ID3D12Fence * | pFence,
 |  | __in ID3D12Resource ** | ppResources,
 |  | __in NvU32 | numResources
 | ) |  |

SUPPORTED OS: Windows 10 and higher DESCRIPTION: This API registers scanout resources of a presentBarrier client to the presentBarrier, and a fence object which is used for presentBarrier synchronization. Once the registration has completed successfully, it is not allowed to add additional resources, i.e. the number of back buffers and fence object are not allowed to be changed. However, application must call this function whenever the back buffers are changed, e.g. ResizeBuffers() is called.

Since
Release: 470
Parameters
[in] | presentBarrierClient | The NvPresentBarrierClientHandle client handle that owns the resources.
[in] | pFence | An ID3D12Fence object created by the application and used for present synchronization through presentBarrier. Application must wait on this fence to ensure the scanout resources are ready for use in the next rendering loop. The fence is only signaled by the driver and must not be signaled through any other queue command. The fence value must be monotonically increasing on every present call, and tracked by the application.
[in] | ppResources | An array of ID3D12Resource to be synchronized through presentBarrier, and the size is specified by numResources.
[in] | numResources | The number of ID3D12Resource elements in ppResources.
Returns
NVAPI_OK the call succeeded
NVAPI_ERROR the call failed
NVAPI_NO_IMPLEMENTATION the API is not implemented
NVAPI_INVALID_POINTER an invalid pointer was passed as an argument
NVAPI_INVALID_HANDLE an invalid NvPresentBarrierClientHandle was passed as an argument
NVAPI_INVALID_ARGUMENT an invalid number of resources was passed as an argument
Return values
NVAPI_API_NOT_INITIALIZED NvAPI not initialized

◆ NvAPI_D3D12_RegisterRaytracingValidationMessageCallback()

NVAPI_INTERFACE NvAPI_D3D12_RegisterRaytracingValidationMessageCallback | ( | __in ID3D12Device5 * | pDevice,
 |  | __in NVAPI_D3D12_RAYTRACING_VALIDATION_MESSAGE_CALLBACK | pfnMessageCallback,
 |  | __in_opt void * | pUserData,
 |  | __out void ** | pHandle
 | ) |  |

DESCRIPTION: Register a message callback for raytracing validation messages. The provided callback may be invoked by the driver using any thread at any time until the callback is unregistered. It is invalid to register/unregister callbacks from within the callback. It is invalid to create or destroy objects for the device or record commands onto command lists from within the callback.

SUPPORTED OS: Windows 10 and higher

Since
Release: 545
Parameters
[in] | pDevice | Pointer to the device from which to obtain raytracing validation messages.
[in] | pfnMessageCallback | Callback used to report validation messages.
[in] | pUserData | [optional] User data to pass as argument to message callback.
[out] | pHandle | Handle that may be used to unregister the callback.
Returns
This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.
Return values
NVAPI_OK | Completed request
NVAPI_INVALID_POINTER | A null pointer was passed as an argument

◆ NvAPI_D3D12_RelocateRaytracingDisplacementMicromapArray()

NVAPI_INTERFACE NvAPI_D3D12_RelocateRaytracingDisplacementMicromapArray | ( | __in ID3D12GraphicsCommandList4 * | pCommandList,
 |  | __in const NVAPI_RELOCATE_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PARAMS * | pParams
 | ) |  |

DESCRIPTION: Makes the DMM Array usable at its current location in memory. A DMM Array that has been copied to a new location must be relocated using this function before it may be attached to any BLAS.

SUPPORTED OS: Windows 10 and higher

Since
Release: 525
Parameters
[in] | pCommandList | Command list on which the command will execute.
[in] | pParams | Wrapper around the inputs of the function.
Returns
This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.

◆ NvAPI_D3D12_RelocateRaytracingOpacityMicromapArray()

NVAPI_INTERFACE NvAPI_D3D12_RelocateRaytracingOpacityMicromapArray | ( | __in ID3D12GraphicsCommandList4 * | pCommandList,
 |  | __in const NVAPI_RELOCATE_RAYTRACING_OPACITY_MICROMAP_ARRAY_PARAMS * | pParams
 | ) |  |

DESCRIPTION: Makes the OMM Array usable at its current location in memory. An OMM Array that has been copied to a new location must be relocated using this function before it may be attached to any BLAS.

SUPPORTED OS: Windows 10 and higher

Since
Release: 520
Parameters
[in] | pCommandList | Command list on which the command will execute.
[in] | pParams | Wrapper around the inputs and outputs of the function.
Returns
This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.

◆ NvAPI_D3D12_ReservedResourceGetDesc()

NVAPI_INTERFACE NvAPI_D3D12_ReservedResourceGetDesc | ( | __in ID3D12Resource * | pReservedResource,
 |  | __out D3D12_RESOURCE_DESC * | pDesc
 | ) |  |
Since
Release: 375
DESCRIPTION: NvAPI_D3D12_ReservedResourceGetDesc is an simple wrapper of ID3D12Resource::GetDesc when pReservedResource is created by NvAPI_D3D12_CreateReservedResource.
Runtime doesn't know the created resource is actually a tiled resource if bTexture2DArrayMipPack = true in NvAPI_D3D12_CreateReservedResource.
So calling ID3D12Resource::GetDesc on such resource will get a desc with D3D12_TEXTURE_LAYOUT_UNKNOWN in Layout instead of D3D12_TEXTURE_LAYOUT_64KB_UNDEFINED_SWIZZLE.
This wrapper API just set Layout to D3D12_TEXTURE_LAYOUT_64KB_UNDEFINED_SWIZZLE if Layout is D3D12_TEXTURE_LAYOUT_UNKNOWN.
\param [in] pReservedResource Pointer of reserved resource to get resource desc from.
\param [out] pDesc Pointer to a resource description.
SUPPORTED OS: Windows 10
\return This API can return any of the error codes enumerated in
#NvAPI_Status. If there are return error codes with specific
meaning for this API, they are listed below.

◆ NvAPI_D3D12_ResolveSubresourceRegion()

NVAPI_INTERFACE NvAPI_D3D12_ResolveSubresourceRegion | ( | __in ID3D12GraphicsCommandList1 * | pCommandList,
 |  | __in ID3D12Resource * | pDstResource,
 |  | __in UINT | DstSubresource,
 |  | __in UINT | DstX,
 |  | __in UINT | DstY,
 |  | __in ID3D12Resource * | pSrcResource,
 |  | __in UINT | SrcSubresource,
 |  | __in_opt RECT * | pSrcRect,
 |  | __in DXGI_FORMAT | Format,
 |  | __in NV_RESOLVE_MODE | ResolveMode
 | ) |  |

SUPPORTED OS: Windows 10 and higher

Since
Release: 410
DESCRIPTION: NvAPI_D3D12_ResolveSubresourceRegion is D3D11 an analog of D3D12 ResolveSubresourceRegion.
\param [in] pDstResource Destination resource. Must be a created with the D3D11_USAGE_DEFAULT flag and be single-sampled.
\param [in] DstSubresource A zero-based index, that identifies the destination subresource. Use D3D11CalcSubresource to calculate the index.
\param [in] DstX The X coordinate of the left-most edge of the destination region.
The width of the destination region is the same as the width of the source rect.
\param [in] DstY The Y coordinate of the top-most edge of the destination region.
The height of the destination region is the same as the height of the source rect.
\param [in] pSrcResource Source resource. Must be multisampled.
\param [in] SrcSubresource The source subresource of the source resource.
\param [in] pSrcRect Specifies the rectangular region of the source resource to be resolved.
Passing NULL for pSrcRect specifies that the entire subresource is to be resolved.
\param [in] Format A DXGI_FORMAT that indicates how the multisampled resource will be resolved to a single-sampled resource.
\param [in] ResolveMode Specifies the operation used to resolve the source samples. NV_RESOLVE_MODE_SAMPLE_0 is the only supported mode.
NV_RESOLVE_MODE_SAMPLE_0 outputs sample 0 and discards all other samples.
\return This API can return any of the error codes enumerated in
#NvAPI_Status. See MSDN for the API specific error codes.
NvAPI_D3D12_ResolveSubresourceRegion
NVAPI_INTERFACE NvAPI_D3D12_ResolveSubresourceRegion(__in ID3D12GraphicsCommandList1 *pCommandList, __in ID3D12Resource *pDstResource, __in UINT DstSubresource, __in UINT DstX, __in UINT DstY, __in ID3D12Resource *pSrcResource, __in UINT SrcSubresource, __in_opt RECT *pSrcRect, __in DXGI_FORMAT Format, __in NV_RESOLVE_MODE ResolveMode)

◆ NvAPI_D3D12_ResourceAliasingBarrier()

NVAPI_INTERFACE NvAPI_D3D12_ResourceAliasingBarrier | ( | __in ID3D12GraphicsCommandList * | pCommandList,
 |  | __in UINT | NumBarriers,
 |  | __in const D3D12_RESOURCE_BARRIER * | pBarriers
 | ) |  |
Since
Release: 375
DESCRIPTION: NvAPI_D3D12_ResourceAliasingBarrier is an extension of ID3D12GraphicsCommandList::ResourceBarrier, but only for D3D12_RESOURCE_ALIASING_BARRIER.
Both resource in pBarriers must be created by NvAPI_D3D12_CreateReservedTexture2DArray.
\param [in] pCommandList A pointer to ID3D12GraphicsCommandList.
\param [in] NumBarriers The number of submitted barrier descriptions.
\param [in] pBarriers Pointer to an array of barrier descriptions with D3D12_RESOURCE_ALIASING_BARRIER type only.
SUPPORTED OS: Windows 10
\return This API can return any of the error codes enumerated in
#NvAPI_Status. If there are return error codes with specific
meaning for this API, they are listed below.

◆ NvAPI_D3D12_SetAsyncFrameMarker()

NVAPI_INTERFACE NvAPI_D3D12_SetAsyncFrameMarker | ( | __in ID3D12CommandQueue * | pCommandQueue,
 |  | __in NV_ASYNC_FRAME_MARKER_PARAMS * | pSetAsyncFrameMarkerParams
 | ) |  |

DESCRIPTION: Set an async frame marker for present and out-of-band render tracking.

Since
Release: 520
Parameters
[in] | pCommandQueue | The D3D12CommandQueue
[in] | pSetAsyncFrameMarkerParams | The async frame marker structure SUPPORTED OS: Windows 10 and higher
Returns
This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.

◆ NvAPI_D3D12_SetCreateCommandQueueLowLatencyHint()

NVAPI_INTERFACE NvAPI_D3D12_SetCreateCommandQueueLowLatencyHint ( __in ID3D12Device * pDevice )

DESCRIPTION: Reserved call.

Since
Release: 530
Parameters
[in] pDevice The creating device SUPPORTED OS: Windows 10 and higher
Returns
This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.

◆ NvAPI_D3D12_SetCreatePipelineStateOptions()

NVAPI_INTERFACE NvAPI_D3D12_SetCreatePipelineStateOptions | ( | __in ID3D12Device5 * | pDevice,
 |  | __in const NVAPI_D3D12_SET_CREATE_PIPELINE_STATE_OPTIONS_PARAMS * | pState
 | ) |  |

DESCRIPTION: Globally change the state affecting pipeline creations. This affects all pipelines created after this call, and until this function is called again.

Note
Only supported on GPUs capable of DXR. Some of the flags and fields have further restrictions, in which case their description will include a note with more details.

SUPPORTED OS: Windows 10 and higher

Since
Release: 520
Parameters
[in] | pDevice | Device on which the pipelines will be created.
[in] | pState | State to be applied to all future pipeline creations.
Returns
This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.

◆ NvAPI_D3D12_SetDepthBoundsTestValues()

NVAPI_INTERFACE NvAPI_D3D12_SetDepthBoundsTestValues | ( | __in ID3D12GraphicsCommandList * | pCommandList,
 |  | __in const float | minDepth,
 |  | __in const float | maxDepth
 | ) |  |
DESCRIPTION: This function will set the minDepth and maxDepth values for depth bounds test
To enable/ disable depth bounds test use PSO extension NV_PSO_ENABLE_DEPTH_BOUND_TEST_EXTENSION
in the nvapi NvAPI_D3D12_CreateGraphicsPipelineState
\param [in] pCommandList Command List to set depth bounds test
\param [in] minDepth min value for depth bound test
\param [in] maxDepth max value for depth bound test
The valid values for minDepth and maxDepth are such that 0 <= minDepth <= maxDepth <= 1
SUPPORTED OS: Windows 10
\return ::NVAPI_OK if the call succeeds.
NV_PSO_ENABLE_DEPTH_BOUND_TEST_EXTENSION
@ NV_PSO_ENABLE_DEPTH_BOUND_TEST_EXTENSION
Definition nvapi.h:13444

◆ NvAPI_D3D12_SetModifiedWMode()

NVAPI_INTERFACE NvAPI_D3D12_SetModifiedWMode | ( | __in ID3D12GraphicsCommandList * | pCommandList,
 |  | __in NV_MODIFIED_W_PARAMS * | pModifiedWParams
 | ) |  |

DESCRIPTION: Set the Modified-W state and A, B coefficients for HW support

Note
Note that Modified-W state persists on a particular CommandList till it is closed. The state is reset to default (disabled) for every newly created CommandList. One must call NvAPI_D3D12_QueryModifiedWSupport() to confirm that the current setup supports Modified-W before calling this set-function.

SUPPORTED OS: Windows 10

Parameters
[in] | pCommandList | The command list in which we will add push buffer commmands for enabling Modified-W feature Note: Command list of type D3D12_COMMAND_LIST_TYPE_BUNDLE is not allowed for setting the state of this feature.
[in] | pModifiedWParams | Modified-W parameters.
Return values
NVAPI_OK | Call succeeded.
NVAPI_ERROR | Call failed.
NVAPI_INVALID_ARGUMENT | One or more arguments are invalid.

<>

◆ NvAPI_D3D12_SetNvShaderExtnSlotSpace()

NVAPI_INTERFACE NvAPI_D3D12_SetNvShaderExtnSlotSpace | ( | __in IUnknown * | pDev,
 |  | __in NvU32 | uavSlot,
 |  | __in NvU32 | uavSpace
 | ) |  |

DESCRIPTION: This function is specifically created for ray tracing since we do not currently support PSOs with DXR. This function sets the device's fake UAV slot and space that is used by Nvidia HLSL shader extensions globally. All state objects created by the driver after setting this slot would treat writes/reads to this UAV in a different way. Applications are expected to bind null UAV to this slot. The same slot is used for all shader stages. To disable shader extensions the app need to set this uav slot to 0xFFFFFFFF. To use Nvidia HLSL extensions the application must include nvHLSLExtns.h in the hlsl shader code. See nvHLSLExtns.h for more details.

This function can be called from a different thread than the one calling immediate device setstate functions.

SUPPORTED OS: Windows 7 and higher

Parameters
[in] | pDev | The device for which to set the extension slot should be a ID3D12Device+ device
[in] | uavSlot | The uav slot to use
[in] | uavSpace | The uav space to use

RETURN STATUS: This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.

Return values
: NVAPI_OK : success, the uavSlot and uavSpace were set sucessfully

◆ NvAPI_D3D12_SetNvShaderExtnSlotSpaceLocalThread()

NVAPI_INTERFACE NvAPI_D3D12_SetNvShaderExtnSlotSpaceLocalThread | ( | __in IUnknown * | pDev,
 |  | __in NvU32 | uavSlot,
 |  | __in NvU32 | uavSpace
 | ) |  |

DESCRIPTION: This function is specifically created for ray tracing shaders since we do not currently support PSOs with DXR. This function sets the device's fake UAV slot that is used by Nvidia HLSL shader extensions on local thread. All state objects created by the driver on the same thread that call this function after setting this slot would treat writes/reads to this UAV in a different way. Applications are expected to bind null UAV to this slot. The same slot is used for all shader stages for the device. To disable shader extensions the app may set this uav slot to 0xFFFFFFFF. To use Nvidia HLSL extensions the application must include nvHLSLExtns.h in the hlsl shader code. See nvHLSLExtns.h for more details.

This function can be called from a different thread than the one calling immediate device setstate functions.

SUPPORTED OS: Windows 7 and higher

Since
Release: 387
Parameters
[in] | pDev | The device for which to set the extension slot should be a ID3D12Device+ device
[in] | uavSlot | the uav slot to use
[in] | uavSpace | the uav space to use

RETURN STATUS: This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.

Return values
: NVAPI_OK : success, the uavSlot and uavSpace were set sucessfully

◆ NvAPI_D3D12_SetSinglePassStereoMode()

NVAPI_INTERFACE NvAPI_D3D12_SetSinglePassStereoMode | ( | __in ID3D12GraphicsCommandList * | pCommandList,
 |  | __in NvU32 | numViews,
 |  | __in NvU32 | renderTargetIndexOffset,
 |  | __in NvU8 | independentViewportMaskEnable
 | ) |  |

DESCRIPTION: Set the Single Pass Stereo state.

Note
Note that Single Pass Stereo state persists on a particular CommandList till it is closed. The state is reset to default (disabled) for every newly created CommandList. One must call NvAPI_D3D12_QuerySinglePassStereoSupport() to confirm that the current setup supports Single Pass Stereo before calling this set-function.

SUPPORTED OS: Windows 10

Parameters
[in] | pCommandList | The command list in which we will add push buffer commmands for enabling Single Pass Stereo feature Note: Command list of type D3D12_COMMAND_LIST_TYPE_BUNDLE is not allowed for setting the state of this feature.
[in] | numViews | Number of views to render.
[in] | RenderTargetIndexOffset | Offset between render targets of the different views.
[in] | IndependentViewportMaskEnable | Is the independent viewport mask enabled.
Return values
NVAPI_OK | Call succeeded.
NVAPI_ERROR | Call failed.
NVAPI_INVALID_ARGUMENT | One or more arguments are invalid.

◆ NvAPI_D3D12_UnregisterRaytracingValidationMessageCallback()

NVAPI_INTERFACE NvAPI_D3D12_UnregisterRaytracingValidationMessageCallback | ( | __in ID3D12Device5 * | pDevice,
 |  | __in void * | handle
 | ) |  |

DESCRIPTION: Unregister a previously registered message callback for raytracing validation messages. The provided callback will not be invoked once the unregister call has returned.

SUPPORTED OS: Windows 10 and higher

Since
Release: 545
Parameters
[in] | pDevice | Pointer to the device from which to stop obtaining raytracing validation messages.
[in] | handle | Handle to which callback should be unregistered, obtained at registration.
Returns
This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.
Return values
NVAPI_OK | Completed request
NVAPI_INVALID_POINTER | A null pointer was passed as device argument
NVAPI_INVALID_ARGUMENT | Callback handle not recognized

◆ NvAPI_D3D12_UpdateTileMappings()

NVAPI_INTERFACE NvAPI_D3D12_UpdateTileMappings | ( | __in ID3D12CommandQueue * | pCommandQueue,
 |  | __in ID3D12Resource * | pResource,
 |  | __in UINT | NumResourceRegions,
 |  | __in const D3D12_TILED_RESOURCE_COORDINATE * | pResourceRegionStartCoordinates,
 |  | __in const D3D12_TILE_REGION_SIZE * | pResourceRegionSizes,
 |  | __in ID3D12Heap * | pHeap,
 |  | __in UINT | NumRanges,
 |  | __in const D3D12_TILE_RANGE_FLAGS * | pRangeFlags,
 |  | __in const UINT * | pHeapRangeStartOffsets,
 |  | __in const UINT * | pRangeTileCounts,
 |  | __in D3D12_TILE_MAPPING_FLAGS | Flags
 | ) |  |
Since
Release: 375
DESCRIPTION: NvAPI_D3D12_UpdateTileMappings is an extension of ID3D12CommandQueue::UpdateTileMappings.
pTiledResource must be created by NvAPI_D3D12_CreateReservedResource.
pTilePool must be created by NvAPI_D3D12_CreateHeap.
\param [in] pCommandQueue A pointer to ID3D12CommandQueue.
\param [in] pTiledResource A pointer to the tiled resource created by NvAPI_D3D12_CreateReservedResource.
\param [in] NumTiledResourceRegions The number of tiled resource regions.
\param [in] pTiledResourceRegionStartCoordinates An array of D3D12_TILED_RESOURCE_COORDINATE structures that describe the starting coordinates of the tiled resource regions. Cannot be NULL.
\param [in] pTiledResourceRegionSizes An array of D3D12_TILE_REGION_SIZE structures that describe the sizes of the tiled resource regions. Cannot be NULL.
\param [in] pTilePool A pointer to the resource heap created by NvAPI_D3D12_CreateHeap.
\param [in] NumRanges The number of tile-pool ranges.
\param [in] pRangeFlags A pointer to an array of D3D12_TILE_RANGE_FLAGS values that describes each tile range.
\param [in] pTilePoolStartOffsets An array of offsets into the tile pool. These are 0-based tile offsets, counting in tiles (not bytes).
\param [in] pRangeTileCounts An array of values that specify the number of tiles in each tile-pool range.
\param [in] Flags A combination of D3D12_TILE_MAPPING_FLAGS values that are combined by using a bitwise OR operation.
SUPPORTED OS: Windows 10
\return This API can return any of the error codes enumerated in
#NvAPI_Status. If there are return error codes with specific
meaning for this API, they are listed below.

◆ NvAPI_D3D12_UseDriverHeapPriorities()

NVAPI_INTERFACE NvAPI_D3D12_UseDriverHeapPriorities ( __in ID3D12Device * pDevice )

SUPPORTED OS: Windows 10

DESCRIPTION: Sets the driver to override Microsoft's heap allocation priority values with Nvidia driver priority values. Use this once per process before allocating resources.
\param [in] pDevice The IDirect3DDevice12 to use.
\return This API can return any of the error codes enumerated in
#NvAPI_Status. If there are return error codes with specific
meaning for this API, they are listed below.
\since Release: 381

◆ NvAPI_D3D1x_BindSwapBarrier()

NVAPI_INTERFACE NvAPI_D3D1x_BindSwapBarrier | ( | IUnknown * | pDevice,
 |  | NvU32 | group,
 |  | NvU32 | barrier
 | ) |  |

DESCRIPTION: This API causes a SwapGroup to be bound to or released from the specified SwapBarrier.

Parameters
[in] | pDevice | The caller provides the D3D device that owns the SwapChain used as a SwapGroup client. pDevice can be either ID3D10Device or ID3D10Device1 or ID3D11Device or ID3D12Device.
[in] | group | The caller specifies the SwapGroup to be bound to the SwapBarrier.
[in] barrier The caller specifies the SwapBarrier that the SwapGroup should be bound to.
  • If the value of barrier is zero, the SwapGroup releases the SwapBarrier.
  • The SwapGroup will be bound to the SwapBarrier if the value of barrier is a positive integer less than or equal to the maximum number of SwapBarriers queried by NvAPI_D3D1x_QueryMaxSwapGroup. SUPPORTED OS: Windows 7 and higher
Return values
NVAPI_OK | the SwapGroup is bound to the specified SwapBarrier
NVAPI_ERROR | The operation failed.
NVAPI_INVALID_ARGUMENT | One or more args passed in are invalid.
NVAPI_API_NOT_INITIALIZED | NvAPI was not yet initialized.

◆ NvAPI_D3D1x_DisableShaderDiskCache()

NVAPI_INTERFACE NvAPI_D3D1x_DisableShaderDiskCache ( IUnknown * pDevice )

SUPPORTED OS: Windows 7 and higher DESCRIPTION: Disables driver managed caching of shader compilations to disk

Parameters
[in] pDevice Device to disabled the shader disk cache on
Return values
NVAPI_OK | Shader disk cache was disabled
NVAPI_ERROR | The operation failed.
NVAPI_INVALID_ARGUMENT | Argument passed in is invalid.

◆ NvAPI_D3D1x_GetGraphicsCapabilities()

NVAPI_INTERFACE NvAPI_D3D1x_GetGraphicsCapabilities | ( | __in IUnknown * | pDevice,
 |  | __in NvU32 | structVersion,
 |  | __inout NV_D3D1x_GRAPHICS_CAPS * | pGraphicsCaps
 | ) |  |

DESCRIPTION: Get the graphics capabilities for current hardware/software setup

SUPPORTED OS: Windows 7 and higher

Since
Release: 410
Parameters
[in] | pDevice | The ID3D11Device device to be used for getting the graphics capabilities.
[in] | structVersion | Version of the caps struct. Should be set to NV_D3D1x_GRAPHICS_CAPS_VER.
[in,out] | pGraphicsCaps | Pointer to a NV_D3D1x_GRAPHICS_CAPS_CAPS struct created by app. Graphics capabilities will be filled in this struct by the driver.
Returns
This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below. (none)

◆ NvAPI_D3D1x_JoinSwapGroup()

NVAPI_INTERFACE NvAPI_D3D1x_JoinSwapGroup | ( | IUnknown * | pDevice,
 |  | IDXGISwapChain * | pSwapChain,
 |  | NvU32 | group,
 |  | BOOL | blocking
 | ) |  |

DESCRIPTION: This API causes the SwapChain of a SwapGroup client to join or leave the specified SwapGroup.

Parameters
[in] | pDevice | The caller provides the D3D device that owns the SwapChain used as a SwapGroup client. pDevice can be either ID3D10Device or ID3D10Device1 or ID3D11Device or ID3D12Device.
[in] | pSwapChain | The IDXGISwapChain interface that is used as the SwapGroup client.
[in] group The caller specifies the SwapGroup which the SwapChain should join.
  • If the value of group is zero, the SwapChain leaves the SwapGroup.
  • The SwapChain joins a SwapGroup if the SwapGroup number is a positive integer less than or equal to the maximum number of SwapGroups queried by NvAPI_SwapGroup_QueryMaxSwapGroup.
[in] | blocking | The caller specifies that a presentation of this SwapChain should return immediately or block until all members of the SwapGroup are ready and the presentation was actually executed. A boolean value of false means the Present operation returns immediately and a value of true means the Present operation is blocking.

SUPPORTED OS: Windows 7 and higher

Return values
NVAPI_OK | the SwapChain joined/left the SwapGroup accordingly
NVAPI_ERROR | The operation failed.
NVAPI_INVALID_ARGUMENT | One or more args passed in are invalid.
NVAPI_API_NOT_INITIALIZED | NvAPI was not yet initialized.

◆ NvAPI_D3D1x_Present()

NVAPI_INTERFACE NvAPI_D3D1x_Present | ( | IUnknown * | pDevice,
 |  | IDXGISwapChain * | pSwapChain,
 |  | UINT | SyncInterval,
 |  | UINT | Flags
 | ) |  |

DESCRIPTION: Presents the contents of the next buffer in the sequence of back buffers owned by a D3D device. This Present operation supports using a SwapGroup and SwapBarrier on the SwapChain that owns the back buffer to be presented.

NOTE: NvAPI_D3D1x_Present is a wrapper of the method IDXGISwapChain::Present which additionally notifies the D3D driver of the SwapChain used by the runtime for presentation, thus allowing the D3D driver to apply SwapGroup and SwapBarrier functionality to that SwapChain.

SUPPORTED OS: Windows 7 and higher

Parameters
[in] | pDevice | The D3D device interface that is used to issue the Present operation, using the following IDirect3DDevice9::Present input parameters. pDevice can be either ID3D10Device or ID3D10Device1 or ID3D11Device or ID3D12Device.
[in] | pSwapChain | The IDXGISwapChain interface that is intended to present
[in] SyncInterval An integer that specifies the how to synchronize presentation of a frame with the vertical blank. Values are:
  • 0: The presentation occurs immediately, there is no synchronization.
  • 1,2,3,4 : Synchronize presentation after the n'th vertical blank.
[in] | Flags | An integer value that contains swap-chain presentation options as defined in DXGI_PRESENT.
Return values
NVAPI_OK | the Present operation was successfully executed
NVAPI_DEVICE_BUSY the Present operation failed with an error DXGI_ERROR_DEVICE_RESET or DXGI_ERROR_DEVICE_REMOVED,
NVAPI_ERROR | the communication with the D3D driver failed, SwapGroup/SwapBarrier may not be possible.
NVAPI_API_NOT_INITIALIZED | NvAPI was not yet initialized.

◆ NvAPI_D3D1x_QueryFrameCount()

NVAPI_INTERFACE NvAPI_D3D1x_QueryFrameCount | ( | IUnknown * | pDevice,
 |  | NvU32 * | pFrameCount
 | ) |  |

DESCRIPTION: This API queries the universal framecounter of the Quadro-Sync master device.

Parameters
[in] | pDevice | The caller provides the D3D device that has access to the Quadro-Sync device, pDevice can be either ID3D10Device or ID3D10Device1 or ID3D11Device or ID3D12Device.
[out] | pFrameCount | The caller provides the storage space where the framecount is stored.

SUPPORTED OS: Windows 7 and higher

Return values
NVAPI_OK | *pFrameCount populated with framecount value.
NVAPI_ERROR | The operation failed.
NVAPI_INVALID_ARGUMENT | One or more args passed in are invalid.
NVAPI_API_NOT_INITIALIZED | NvAPI was not yet initialized.

◆ NvAPI_D3D1x_QueryMaxSwapGroup()

NVAPI_INTERFACE NvAPI_D3D1x_QueryMaxSwapGroup | ( | IUnknown * | pDevice,
 |  | NvU32 * | pMaxGroups,
 |  | NvU32 * | pMaxBarriers
 | ) |  |

DESCRIPTION: This API queries the number of supported SwapGroups and SwapBarriers in the graphics system.

Parameters
[in] | pDevice | The caller provides the D3D device that is intended to use SwapGroup functionality. pDevice can be either ID3D10Device or ID3D10Device1 or ID3D11Device or ID3D12Device.
[out] | pMaxGroups | The caller provides the storage space where the number of available SwapGroups is stored.
[out] | pMaxBarriers | The caller provides the storage space where the number of available SwapBarriers is stored.

SUPPORTED OS: Windows 7 and higher

Return values
NVAPI_OK | the number of SwapGroups and SwapBarriers has been stored
NVAPI_ERROR | The operation failed.
NVAPI_INVALID_ARGUMENT | One or more args passed in are invalid.
NVAPI_API_NOT_INITIALIZED | NvAPI was not yet initialized.

◆ NvAPI_D3D1x_QuerySwapGroup()

NVAPI_INTERFACE NvAPI_D3D1x_QuerySwapGroup | ( | IUnknown * | pDevice,
 |  | IDXGISwapChain * | pSwapChain,
 |  | NvU32 * | pSwapGroup,
 |  | NvU32 * | pSwapBarrier
 | ) |  |

DESCRIPTION: This API queries the current SwapGroup and SwapBarrier that a SwapChain of a specific client device is bound to.

Parameters
[in] | pDevice | The caller provides the D3D device that owns the SwapChain used as a SwapGroup client. pDevice can be either ID3D10Device or ID3D10Device1 or ID3D11Device or ID3D12Device.
[in] | pSwapChain | The IDXGISwapChain interface that is used as the SwapGroup client.
[out] | pSwapGroup | The caller provides the storage space where the current SwapGroup is stored.
[out] | pSwapBarrier | The caller provides the storage space where the current SwapBarrier is stored.

SUPPORTED OS: Windows 7 and higher

Return values
NVAPI_OK | the current SwapGroup and SwapBarrier has been stored
NVAPI_ERROR | The operation failed.
NVAPI_INVALID_ARGUMENT | One or more args passed in are invalid.
NVAPI_API_NOT_INITIALIZED | NvAPI was not yet initialized.

◆ NvAPI_D3D1x_ResetFrameCount()

NVAPI_INTERFACE NvAPI_D3D1x_ResetFrameCount ( IUnknown * pDevice )

DESCRIPTION: This API resets the universal framecounter on the Quadro-Sync master device.

Parameters
[in] pDevice The caller provides the D3D device that has access to the Quadro-Sync device, pDevice can be either ID3D10Device or ID3D10Device1 or ID3D11Device or ID3D12Device.

SUPPORTED OS: Windows 7 and higher

Return values
NVAPI_OK | framecounter has been reset
NVAPI_ERROR | The operation failed.
NVAPI_INVALID_ARGUMENT | pDevice arg passed in is invalid.
NVAPI_API_NOT_INITIALIZED | NvAPI was not yet initialized.

◆ NvAPI_D3D9_AliasSurfaceAsTexture()

NvAPI_D3D9_AliasSurfaceAsTexture | ( | IDirect3DDevice9 * | pDev,
 |  | IDirect3DSurface9 * | pSurface,
 |  | IDirect3DTexture9 ** | ppTexture,
 |  | DWORD | dwFlag
 | ) |  |

DESCRIPTION: Create a texture that is an alias of a surface registered with NvAPI. The new texture can be bound with IDirect3DDevice9::SetTexture(). Note that the texture must be unbound before drawing to the surface again. Unless the USE_SUPER flag is passed, MSAA surfaces will be resolved before being used as a texture. MSAA depth buffers are resolved with a point filter, and non-depth MSAA surfaces are resolved with a linear filter.

SUPPORTED OS: Windows 7 and higher

Parameters
[in] | pDev | The D3D device that owns the objects
[in] | pSurface | Pointer to a surface that has been registered with NvAPI to which a texture alias is to be provided
[out] | ppTexture | Fill with the texture created
[in] | dwFlag | NVAPI_ALIAS_SURFACE_FLAG to describe how to handle the texture
Return values
NVAPI_OK | completed request
NVAPI_INVALID_POINTER | A null pointer was passed as an argument
NVAPI_INVALID_ARGUMENT | One of the arguments was invalid, probably dwFlag.
NVAPI_UNREGISTERED_RESOURCE | pSurface has not been registered with NvAPI
NVAPI_ERROR | error occurred

◆ NvAPI_D3D9_BindSwapBarrier()

NVAPI_INTERFACE NvAPI_D3D9_BindSwapBarrier | ( | IDirect3DDevice9 * | pDevice,
 |  | NvU32 | group,
 |  | NvU32 | barrier
 | ) |  |

DESCRIPTION: This API causes a SwapGroup to be bound to or released from the specified SwapBarrier.

Parameters
[in] | pDevice | The caller provides the DirectX 9 device that is used as a swapgroup client
[in] | group | The caller specifies the SwapGroup to be bound to the SwapBarrier.
[in] barrier The caller specifies the SwapBarrier that the SwapGroup should be bound to.
  • If the value of barrier is zero, the SwapGroup will be released from the SwapBarrier.
  • The SwapGroup will be bound to the SwapBarrier if the value of barrier is a positive integer less than or equal to the maximum number of SwapBarriers queried by NvAPI_SwapGroup_QueryMaxSwapGroup.

SUPPORTED OS: Windows 7 and higher

Return values
NVAPI_OK | the SwapGroup is bound to or released from the specified SwapBarrier
NVAPI_ERROR | The operation failed.
NVAPI_INVALID_ARGUMENT | One or more args passed in are invalid.
NVAPI_API_NOT_INITIALIZED | NvAPI was not yet initialized.

◆ NvAPI_D3D9_ClearRT()

NVAPI_INTERFACE NvAPI_D3D9_ClearRT | ( | IDirect3DDevice9 * | pDevice,
 |  | NvU32 | dwNumRects,
 |  | CONST RECT * | pRects,
 |  | float | r,
 |  | float | g,
 |  | float | b,
 |  | float | a
 | ) |  |

DESCRIPTION: This API Clears the currently bound render target(s) with the given color

SUPPORTED OS: Windows 7 and higher

Parameters
[in] | pDevice | The D3D device that owns the objects.
[in] | dwNumRects | The no of rectangles to clear. If 0, clear the entire surface (clipped to viewport)
[in] | pRects | Defines the rectangles to clear. Should be NULL if dwNumRects == 0
[in] | r | red component of the clear color
[in] | g | green component of the clear color
[in] | b | blue component of the clear color
[in] | a | alpha component of the clear color
Returns
This API can return any of the error codes enumerated in NvAPI_Status.

◆ NvAPI_D3D9_GetSurfaceHandle()

NVAPI_INTERFACE NvAPI_D3D9_GetSurfaceHandle | ( | IDirect3DSurface9 * | pSurface,
 |  | NVDX_ObjectHandle * | pHandle
 | ) |  |

SUPPORTED OS: Windows 7 and higher This function gets the handle of a given surface. This handle uniquely identifies the surface through all NvAPI entries.

Since
Release: 313
Parameters
[in] | pSurface | Surface to be identified
[out] | pHandle | Will be filled by the return handle
Returns
An int which could be an NvAPI status or DX HRESULT code

◆ NvAPI_D3D9_JoinSwapGroup()

NVAPI_INTERFACE NvAPI_D3D9_JoinSwapGroup | ( | IDirect3DDevice9 * | pDevice,
 |  | IDirect3DSwapChain9 * | pSwapChain,
 |  | NvU32 | group,
 |  | BOOL | blocking
 | ) |  |

DESCRIPTION: This API causes the SwapChain of a SwapGroup client to join or leave the specified SwapGroup.

Parameters
[in] | pDevice | The caller provides the DirectX 9 device that is used as a swapgroup client
[in] pSwapChain The caller provides the IDirect3DSwapChain9 interface as a handle to the SwapChain
that belongs to the swapgroup client device
[in] group The caller specifies the SwapGroup which the SwapChain should join.
  • If the value of group is zero, the SwapChain leaves the SwapGroup.
  • The SwapChain joins a SwapGroup if the SwapGroup number is a positive integer less than or equal to the maximum number of SwapGroups queried by NvAPI_SwapGroup_QueryMaxSwapGroup.
[in] | blocking | The caller specifies that a presentation of this SwapChain should return immediately or block until all members of the SwapGroup are ready and the presentation was actually executed. A boolean value of false means the Present operation returns immediately and a value of true means the Present operation is blocking.

SUPPORTED OS: Windows 7 and higher

Return values
NVAPI_OK | the SwapChain joined/left the SwapGroup accordingly
NVAPI_ERROR | The operation failed.
NVAPI_INVALID_ARGUMENT | One or more args passed in are invalid.
NVAPI_API_NOT_INITIALIZED | NvAPI was not yet initialized.

◆ NvAPI_D3D9_Present()

NVAPI_INTERFACE NvAPI_D3D9_Present | ( | IDirect3DDevice9 * | pDevice,
 |  | IDirect3DSwapChain9 * | pSwapChain,
 |  | const RECT * | pSourceRect,
 |  | const RECT * | pDestRect,
 |  | HWND | hDestWindowOverride,
 |  | const RGNDATA * | pDirtyRegion
 | ) |  |

DESCRIPTION: This API presents the contents of the next buffer in the sequence of back buffers owned by a IDirect3DDevice9 device. This Present operation supports using a SwapGroup and SwapBarrier on the SwapChain that owns the back buffer to be presented.

NOTE: NvAPI_D3D9_Present is a wrapper of the method IDirect3DDevice9::Present which additionally notifies the D3D driver of the SwapChain used by the runtime for presentation, thus allowing the D3D driver to apply SwapGroup and SwapBarrier functionality to that SwapChain.

SUPPORTED OS: Windows 7 and higher

Parameters
[in] | pDevice | The IDirect3DDevice9 interface that is used to issue the Present, using the following IDirect3DDevice9::Present input parameters
[in] | pSwapChain | Optional pointer to a IDirect3DSwapChain9 interface. If provided, the presentation is executed using this interface (i.e. pSwapChain->Present()) for the given swapchain only. If NULL, the presentation is executed on the device for all swapchains as in pDevice->Present()
[in] | pSourceRect | A pointer to a RECT structure containing the source rectangle. If NULL, the entire source surface is presented.
[in] | pDestRect | A pointer to a RECT structure containing the destination rectangle, in window client coordinates. If NULL, the entire client area is filled.
[in] | hDestWindowOverride | A pointer to a destination window whose client area is taken as the target for this presentation. If this value is NULL, then the hWndDeviceWindow member of D3DPRESENT_PARAMTERS is taken.
[in] | pDirtyRegion | (IN) A pointer to a region to be presented. It must be NULL unless the swap chain was reated with D3DSWAPEFFECT_COPY. If this value is non-NULL, the contained region is expressed in back buffer coordinates.
Return values
NVAPI_OK | the Present operation was successfully executed
NVAPI_D3D_DEVICE_LOST D3D device status is D3DERR_DEVICELOST or D3DERR_DEVICENOTRESET, the caller has to reset device
NVAPI_DEVICE_BUSY | the Present operation failed with an error other than D3DERR_DEVICELOST or D3DERR_DEVICENOTRESET
NVAPI_ERROR | the communication with the D3D driver failed, SwapGroup/SwapBarrier may not be possible.
NVAPI_API_NOT_INITIALIZED | NvAPI was not yet initialized.

◆ NvAPI_D3D9_QueryFrameCount()

NVAPI_INTERFACE NvAPI_D3D9_QueryFrameCount | ( | IDirect3DDevice9 * | pDevice,
 |  | NvU32 * | pFrameCount
 | ) |  |

DESCRIPTION: This API queries the universal framecounter of the Quadro-Sync master device.

Parameters
[in] | pDevice | The caller provides the DX9 device that has access to the Quadro-Sync device
[out] | pFrameCount | The caller provides the storage space where the framecount is stored.

SUPPORTED OS: Windows 7 and higher

Return values
NVAPI_OK | *pFrameCount populated with framecount value.
NVAPI_ERROR | The operation failed.
NVAPI_INVALID_ARGUMENT | One or more args passed in are invalid.
NVAPI_API_NOT_INITIALIZED | NvAPI was not yet initialized.

◆ NvAPI_D3D9_QueryMaxSwapGroup()

NVAPI_INTERFACE NvAPI_D3D9_QueryMaxSwapGroup | ( | IDirect3DDevice9 * | pDevice,
 |  | NvU32 * | pMaxGroups,
 |  | NvU32 * | pMaxBarriers
 | ) |  |

DESCRIPTION: This API queries the number of supported SwapGroups and SwapBarriers in the graphics system.

Parameters
[in] | pDevice | The caller provides the DirectX 9 device that is used as a swapgroup client
[out] | pMaxGroups | The caller provides the storage space where the number of available SwapGroups is stored.
[out] | pMaxBarriers | The caller provides the storage space where the number of available SwapBarriers is stored.

SUPPORTED OS: Windows 7 and higher

Return values
NVAPI_OK | the number of SwapGroups and SwapBarriers has been stored
NVAPI_ERROR | The operation failed.
NVAPI_INVALID_ARGUMENT | One or more args passed in are invalid.
NVAPI_API_NOT_INITIALIZED | NvAPI was not yet initialized.

◆ NvAPI_D3D9_QuerySwapGroup()

NVAPI_INTERFACE NvAPI_D3D9_QuerySwapGroup | ( | IDirect3DDevice9 * | pDevice,
 |  | IDirect3DSwapChain9 * | pSwapChain,
 |  | NvU32 * | pSwapGroup,
 |  | NvU32 * | pSwapBarrier
 | ) |  |

DESCRIPTION: This API queries the current SwapGroup and SwapBarrier that a SwapChain of a specific client device is bound to.

Parameters
[in] | pDevice | The caller provides the DirectX 9 device that is used as a swapgroup client
[in] pSwapChain The caller provides the IDirect3DSwapChain9 interface as a handle to the SwapChain
that belongs to the swapgroup client device
[out] | pSwapGroup | The caller provides the storage space where the current SwapGroup is stored.
[out] | pSwapBarrier | The caller provides the storage space where the current SwapBarrier is stored.

SUPPORTED OS: Windows 7 and higher

Return values
NVAPI_OK | the current SwapGroup and SwapBarrier has been stored
NVAPI_ERROR | The operation failed.
NVAPI_INVALID_ARGUMENT | One or more args passed in are invalid.
NVAPI_API_NOT_INITIALIZED | NvAPI was not yet initialized.

◆ NvAPI_D3D9_RegisterResource()

NVAPI_INTERFACE NvAPI_D3D9_RegisterResource ( IDirect3DResource9 * pResource )

DESCRIPTION: This API binds a resource (surface/texture) so that it can be retrieved internally by NVAPI.

SUPPORTED OS: Windows 7 and higher

Parameters
[in] pResource surface/texture
Returns
NVAPI_OK, NVAPI_ERROR

◆ NvAPI_D3D9_ResetFrameCount()

NVAPI_INTERFACE NvAPI_D3D9_ResetFrameCount ( IDirect3DDevice9 * pDevice )

DESCRIPTION: This API resets the universal framecounter on the Quadro-Sync master device.

Parameters
[in] pDevice The caller provides the DX9 device that has access to the Quadro-Sync device

SUPPORTED OS: Windows 7 and higher

Return values
NVAPI_OK | framecounter has been reset
NVAPI_ERROR | The operation failed.
NVAPI_INVALID_ARGUMENT | One or more args passed in are invalid.
NVAPI_API_NOT_INITIALIZED | NvAPI was not yet initialized.

◆ NvAPI_D3D9_StretchRectEx()

NVAPI_INTERFACE NvAPI_D3D9_StretchRectEx | ( | IDirect3DDevice9 * | pDevice,
 |  | IDirect3DResource9 * | pSourceResource,
 |  | CONST RECT * | pSourceRect,
 |  | IDirect3DResource9 * | pDestResource,
 |  | CONST RECT * | pDestRect,
 |  | D3DTEXTUREFILTERTYPE | Filter
 | ) |  |

DESCRIPTION: This API copies the contents of the source resource to the destination resource. This function can convert between a wider range of surfaces than IDirect3DDevice9::StretchRect. For example, it can copy from a depth/stencil surface to a texture.

The source and destination resources must be registered with NvAPI before being used with NvAPI_D3D9_StretchRectEx().

SUPPORTED OS: Windows 7 and higher

Parameters
[in] | pDevice | The D3D device that owns the objects.
[in] | pSourceResource | Pointer to the source resource.
[in] | pSrcRect | Defines the rectangle on the source to copy from. If NULL, copy from the entire resource.
[in] | pDestResource | Pointer to the destination resource.
[in] | pDstRect | Defines the rectangle on the destination to copy to. If NULL, copy to the entire resource.
[in] | Filter | Choose a filtering method: D3DTEXF_NONE, D3DTEXF_POINT, D3DTEXF_LINEAR.
Return values
NVAPI_OK | completed request
NVAPI_INVALID_POINTER | An invalid pointer was passed as an argument (probably NULL)
NVAPI_INVALID_ARGUMENT | One of the arguments was invalid
NVAPI_UNREGISTERED_RESOURCE | a resource was passed in without being registered
NVAPI_ERROR | error occurred

◆ NvAPI_D3D9_UnregisterResource()

NVAPI_INTERFACE NvAPI_D3D9_UnregisterResource ( IDirect3DResource9 * pResource )

DESCRIPTION: This API unbinds a resource (surface/texture) after use.

SUPPORTED OS: Windows 7 and higher

Parameters
[in] pResource surface/texture
Returns
NVAPI_OK, NVAPI_ERROR

◆ NvAPI_D3D_BeginResourceRendering()

NvAPI_D3D_BeginResourceRendering | ( | IUnknown * | pDeviceOrContext,
 |  | NVDX_ObjectHandle | obj,
 |  | NvU32 | Flags
 | ) |  |

DESCRIPTION: This function tells the driver that the resource will begin to receive updates. It must be used in combination with NvAPI_D3D_EndResourceRendering(). The primary use of this function is allow the driver to initiate early inter-frame synchronization of resources while running in AFR SLI mode.

SUPPORTED OS: Windows 7 and higher

Since
Release: 185
Parameters
[in] | pDev | IDirect3DDevice9, ID3D10Device, ID3D11Device or ID3D11DeviceContext that is using the resource
[in] | obj | Previously obtained HV resource handle
[in] | Flags | The flags for functionality applied to resource while being used.
Return values
NVAPI_OK | Function succeeded, if used properly and driver can initiate proper sync'ing of the resources.
NVAPI_INVALID_ARGUMENT | Bad argument(s) or invalid flag values
NVAPI_INVALID_CALL | Mismatched begin/end calls

◆ NvAPI_D3D_CreateLateLatchObject()

NVAPI_INTERFACE NvAPI_D3D_CreateLateLatchObject | ( | __in IUnknown * | pDevice,
 |  | __inout NV_D3D_LATELATCH_OBJECT_DESC * | pLateLatchObjectDesc
 | ) |  |

DESCRIPTION: Creates a Late Latch Object interface

SUPPORTED OS: Windows 7 and higher

Since
Release: 384
Parameters
[in] | pDevice | Current ID3D11Device.
[in,out] | pLateLatchObjectDesc | Pointer to in/out structure for late latch object creation

RETURN STATUS: This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.

◆ NvAPI_D3D_EndResourceRendering()

NVAPI_INTERFACE NvAPI_D3D_EndResourceRendering | ( | IUnknown * | pDeviceOrContext,
 |  | NVDX_ObjectHandle | obj,
 |  | NvU32 | Flags
 | ) |  |

DESCRIPTION: This function tells the driver that the resource is done receiving updates. It must be used in combination with NvAPI_D3D_BeginResourceRendering(). The primary use of this function is allow the driver to initiate early inter-frame syncs of resources while running in AFR SLI mode.

SUPPORTED OS: Windows 7 and higher

Since
Release: 185
Parameters
[in] | pDev | IDirect3DDevice9, ID3D10Device, ID3D11Device or ID3D11DeviceContext that is using the resource
[in] | obj | Previously obtained HV resource handle
[in] | Flags | Reserved, must be zero
Return values
NVAPI_OK | Function succeeded, if used properly and driver can initiate proper sync'ing of the resources.
NVAPI_INVALID_ARGUMENT | Bad argument(s) or invalid flag values
NVAPI_INVALID_CALL | Mismatched begin/end calls

◆ NvAPI_D3D_GetCurrentSLIState()

NVAPI_INTERFACE NvAPI_D3D_GetCurrentSLIState | ( | IUnknown * | pDevice,
 |  | NV_GET_CURRENT_SLI_STATE * | pSliState
 | ) |  |

DESCRIPTION: This function returns the current SLI state for the specified device. The structure contains the number of AFR groups, the current AFR group index, and what the AFR group index will be for the next frame. pDevice can be either a IDirect3DDevice9 or ID3D10Device pointer.

SUPPORTED OS: Windows 7 and higher

Since
Release: 173
Return values
NVAPI_OK | Completed request
NVAPI_ERROR | Error occurred

◆ NvAPI_D3D_GetLatency()

NVAPI_INTERFACE NvAPI_D3D_GetLatency | ( | __in IUnknown * | pDev,
 |  | __out NV_LATENCY_RESULT_PARAMS * | pGetLatencyParams
 | ) |  |

DESCRIPTION: Get a latency report including the timestamps of the application latency markers set with NvAPI_D3D_SetLatencyMarker as well as driver, OS queue and graphics hardware times. Requires calling NvAPI_D3D_SetLatencyMarker with incrementing frameID for valid results. Rendering for at least 90 frames is recommended to properly fill out the structure. The newest completed frame is at the end (element 63) and is preceeded by older frames. If not enough frames are valid then all frames are returned with all zeroes.

Since
Release: 455
Parameters
[in] | pDev | The target device
[in] | pGetLatencyParams | The latency result structure. SUPPORTED OS: Windows 7 and higher
Returns
This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.

◆ NvAPI_D3D_GetObjectHandleForResource()

NVAPI_INTERFACE NvAPI_D3D_GetObjectHandleForResource | ( | IUnknown * | pDevice,
 |  | IUnknown * | pResource,
 |  | NVDX_ObjectHandle * | pHandle
 | ) |  |

DESCRIPTION: This API gets a handle to a resource.

Parameters
[in] | pDev | The ID3D11Device, ID3D10Device or IDirect3DDevice9 or ID3D11DeviceContext to use
[in] | pResource | The ID3D11Resource, ID3D10Resource or IDirect3DResource9 from which we want the NvAPI handle
[out] | pHandle | A handle to the resource

SUPPORTED OS: Windows 7 and higher

Since
Release: 185
Returns
NVAPI_OK if the handle was populated.

◆ NvAPI_D3D_GetSleepStatus()

NVAPI_INTERFACE NvAPI_D3D_GetSleepStatus | ( | __in IUnknown * | pDev,
 |  | __in NV_GET_SLEEP_STATUS_PARAMS * | pGetSleepStatusParams
 | ) |  |

DESCRIPTION: This function can be used to get the latest sleep status: bLowLatencyMode indicates whether low latency mode is currently enabled in the driver. Note that it may not always reflect the previously requested sleep mode, as the feature may not be available on the platform, or the setting has been overridden by the control panel, for example. bFsVrr indicates fullscreen GSYNC or GSYNC Compatible mode. It is valid only when the application is in the foreground. bCplVsyncOn indicates Control Panel VSYNC ON override.

Since
Release: 455
Parameters
[in] | pDev | The target device.
[in] | pGetSleepStatusParams | Sleep status params. SUPPORTED OS: Windows 7 and higher
Returns
This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.

◆ NvAPI_D3D_ImplicitSLIControl()

NVAPI_INTERFACE NvAPI_D3D_ImplicitSLIControl ( __in IMPLICIT_SLI_CONTROL implicitSLIControl )

◆ NvAPI_D3D_InitializeNvGazeHandler()

NVAPI_INTERFACE NvAPI_D3D_InitializeNvGazeHandler | ( | __in IUnknown * | pDevice,
 |  | __inout NV_GAZE_HANDLER_INIT_PARAMS * | pInitializeNvGazeHandlerParams
 | ) |  |

SUPPORTED OS: Windows 7 and higher DESCRIPTION: Creates an interface for updating and managing gaze data

SUPPORTED OS: Windows 7 and higher

Since
Release: 430
Parameters
[in] pDevice The device to be used for creating the Gaze Handler interface
Note
This should be same as the device used with VRS Handler. See also: NvAPI_D3D_InitializeVRSHelper.
Parameters
[in] pInitializeNvGazeHandlerParams Descriptor for Gaze Data Handler initialization
Returns
This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below. (none)

◆ NvAPI_D3D_InitializeSMPAssist()

NVAPI_INTERFACE NvAPI_D3D_InitializeSMPAssist | ( | __in IUnknown * | pDevice,
 |  | __inout NV_SMP_ASSIST_INITIALIZE_PARAMS * | pSMPAssistInitParams
 | ) |  |

DESCRIPTION: Initialize SMP Assist extension. Take the SMPAssist(MRS/LMS) params from the application. Provide the application with a interface pointer for future use.

Since
Release: 396
Parameters
[in] | pDevice | Pointer to IUnknown (Currently supports ID3D11Device)
[in,out] | pSMPAssistInitParams | SMP Assist initialization params
Returns
This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.
Return values
NVAPI_OK | Call succeeded.
NVAPI_ERROR | Call failed.
NVAPI_INVALID_ARGUMENT | One of the required input arguments was NULL

◆ NvAPI_D3D_InitializeVRSHelper()

NVAPI_INTERFACE NvAPI_D3D_InitializeVRSHelper | ( | __in IUnknown * | pDevice,
 |  | __inout NV_VRS_HELPER_INIT_PARAMS * | pInitializeVRSHelperParams
 | ) |  |

SUPPORTED OS: Windows 7 and higher DESCRIPTION: Creates an interface for updating, enabling and disabling internally tracked shading rate pattern for Variable Rate Shading

SUPPORTED OS: Windows 7 and higher

Since
Release: 430
Parameters
[in] pDevice The device to be used for creating the VRS Handler interface
Note
This should be same the device used for Gaze Handler. See also: NvAPI_D3D_InitializeNvGazeHandler.
Parameters
[in] pInitializeVRSHelperParams Descriptor for VRS Helper initialization
Returns
This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below. (none)

◆ NvAPI_D3D_IsGSyncActive()

NVAPI_INTERFACE NvAPI_D3D_IsGSyncActive | ( | __in IUnknown * | pDeviceOrContext,
 |  | __in NVDX_ObjectHandle | primarySurface,
 |  | __out BOOL * | pIsGsyncActive
 | ) |  |

FUNCTION NAME: NvAPI_D3D_IsGSyncActive DESCRIPTION: This API get the G-Sync state for the given device context. This is only reliable after the first present call has completed. As it is a bit time consuming, It should not be called per frame.

Parameters
[in] | pDeviceOrContext | The D3D9, D3D10, D3D11 device, or D3D11 device context
[in] | NVDX_ObjectHandle | The handle of primary surface
[out] | pIsGsyncActive | if G-Sync is active, *pisGsyncActive is true.

SUPPORTED OS: Windows 7 and higher

RETURN STATUS: This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.

◆ NvAPI_D3D_IsGSyncCapable()

NVAPI_INTERFACE NvAPI_D3D_IsGSyncCapable | ( | __in IUnknown * | pDeviceOrContext,
 |  | __in NVDX_ObjectHandle | primarySurface,
 |  | __out BOOL * | pIsGsyncCapable
 | ) |  |

FUNCTION NAME: NvAPI_D3D_IsGSyncCapable DESCRIPTION: This API gets G-Sync capability for the given device context. This is only reliable after the first present call has completed.

Parameters
[in] | pDeviceOrContext | The D3D9, D3D10, D3D11 device, or D3D11 device context
[in] | NVDX_ObjectHandle | The handle of primary surface
[out] | pIsGsyncCapable | if G-Sync can be enabled, *pIsGsyncCapable is true.

SUPPORTED OS: Windows 7 and higher

RETURN STATUS: This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.

◆ NvAPI_D3D_QueryLateLatchSupport()

NVAPI_INTERFACE NvAPI_D3D_QueryLateLatchSupport | ( | __in IUnknown * | pDevice,
 |  | __inout NV_QUERY_LATELATCH_SUPPORT_PARAMS * | pQueryLateLatchSupportParams
 | ) |  |

DESCRIPTION: Queries the support of DX11 Late Latch feature on current setup.

SUPPORTED OS: Windows 7 and higher

Since
Release: 384
Parameters
[in] | pDevice | Current ID3D11Device.
[in,out] | pQueryLateLatchSupportParams | Stores value of whether Late Latch is supported on current setup or not.

RETURN STATUS: This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.

<>

◆ NvAPI_D3D_QueryModifiedWSupport()

NVAPI_INTERFACE NvAPI_D3D_QueryModifiedWSupport | ( | __in IUnknown * | pDev,
 |  | __inout NV_QUERY_MODIFIED_W_SUPPORT_PARAMS * | pQueryModifiedWSupportedParams
 | ) |  |

DESCRIPTION: Queries the support of Modified W feature on current setup and returns appropriate boolean value.

SUPPORTED OS: Windows 7 and higher

Parameters
[in] | pDevice | The ID3D11Device to use.
[in,out] | pQueryModifiedWSupportedParams | Stores value of whether Modified W is supported on current setup or not.
Return values
NVAPI_OK | Call succeeded.
NVAPI_ERROR | Call failed.
NVAPI_INVALID_ARGUMENT | One or more arguments are invalid.

<>

◆ NvAPI_D3D_QueryMultiViewSupport()

NVAPI_INTERFACE NvAPI_D3D_QueryMultiViewSupport | ( | __in IUnknown * | pDevice,
 |  | __inout NV_QUERY_MULTIVIEW_SUPPORT_PARAMS * | pQueryMultiViewSupportedParams
 | ) |  |

DESCRIPTION: Queries the support of MultiView feature on current setup and returns appropriate boolean value.

SUPPORTED OS: Windows 7 and higher

Since
Release: 410
Parameters
[in] | pDevice | The ID3D11Device to use.
[in,out] | pMultiViewSupportedParams | Stores value of whether MultiView is supported on current setup or not.
Returns
This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below. (none)

<>

◆ NvAPI_D3D_QuerySinglePassStereoSupport()

NVAPI_INTERFACE NvAPI_D3D_QuerySinglePassStereoSupport | ( | __in IUnknown * | pDevice,
 |  | __inout NV_QUERY_SINGLE_PASS_STEREO_SUPPORT_PARAMS * | pQuerySinglePassStereoSupportedParams
 | ) |  |

DESCRIPTION: Queries the support of Single Pass Stereo feature on current setup and returns appropriate boolean value.

SUPPORTED OS: Windows 7 and higher

Parameters
[in] | pDevice | The ID3D11Device to use.
[in,out] | pSinglePassStereoSupportedParams | Stores value of whether Single Pass Stereo is supported on current setup or not.
Return values
NVAPI_OK | Call succeeded.
NVAPI_ERROR | Call failed.
NVAPI_INVALID_ARGUMENT | One or more arguments are invalid.

<>

◆ NvAPI_D3D_QuerySMPAssistSupport()

NVAPI_INTERFACE NvAPI_D3D_QuerySMPAssistSupport | ( | __in IUnknown * | pDev,
 |  | __inout NV_QUERY_SMP_ASSIST_SUPPORT_PARAMS * | pQuerySMPAssistSupportParams
 | ) |  |

SUPPORTED OS: Windows 7 and higher DESCRIPTION: Query SMP assist extension support.

Since
Release: 396
Parameters
[in] | pDev | Pointer to IUnknown (Currently supports ID3D11Device)
[out] | pQuerySMPAssistSupportParams | Pointer to a structure returning requested SMP assist support
Returns
This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.
Return values
NVAPI_NOT_SUPPORTED | Requested SMP assist is not supported.
NVAPI_OK | Call succeeded. Check value of pQuerySMPAssistSupportParams->bSMPAssistSupported
NVAPI_INVALID_POINTER | pDev or pQuerySMPAssistSupportParams was a NULL pointer

◆ NvAPI_D3D_RegisterDevice()

NVAPI_INTERFACE NvAPI_D3D_RegisterDevice ( __in IUnknown * pDev )

DESCRIPTION: Tells NvAPI about a D3D device. This must be called prior to using any DX1x deferred-context calls.

SUPPORTED OS: Windows 7 and higher

Parameters
[in] pDev The ID3D10Device or ID3D11Device to use.

RETURN STATUS: This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.

<>

◆ NvAPI_D3D_SetFPSIndicatorState()

NVAPI_INTERFACE NvAPI_D3D_SetFPSIndicatorState | ( | IUnknown * | pDev,
 |  | NvU8 | doEnable
 | ) |  |

DESCRIPTION: Display an overlay that tracks the number of times the app presents per second, or,
the number of frames-per-second (FPS)

SUPPORTED OS: Windows 7 and higher

Parameters
[in] bool Whether or not to enable the fps indicator.
Returns
NVAPI_OK, NVAPI_ERROR

<>

◆ NvAPI_D3D_SetLatencyMarker()

NVAPI_INTERFACE NvAPI_D3D_SetLatencyMarker | ( | __in IUnknown * | pDev,
 |  | __in NV_LATENCY_MARKER_PARAMS * | pSetLatencyMarkerParams
 | ) |  |

DESCRIPTION: Set a latency marker to be tracked by the NvAPI_D3D_GetLatency function. SIMULATION_START must be the first marker sent in a frame, after the previous frame's Sleep call (if used). INPUT_SAMPLE may be sent to record the moment user input was sampled and should come between SIMULATION_START and SIMULATION_END. RENDERSUBMIT_START should come before any Direct3D calls are made for the given frame and RENDERSUBMIT_END should come before calling Present. PRESENT_START and END should wrap the Present call to inform the driver of a present block done by the OS before the driver receives the Present. TRIGGER_FLASH tells the driver to render its flash indicator for latency testing, typically driven by a mouse click. The frameID can start at an abitrary moment in the application lifetime but must strictly increment from that point forward for consistent results.

Since
Release: 455
Parameters
[in] | pDev | The target device
[in] | pSetLatencyMarkerParams | The latency marker structure SUPPORTED OS: Windows 7 and higher
Returns
This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.

◆ NvAPI_D3D_SetModifiedWMode()

NVAPI_INTERFACE NvAPI_D3D_SetModifiedWMode | ( | __in IUnknown * | pDevOrContext,
 |  | __in NV_MODIFIED_W_PARAMS * | psModifiedWParams
 | ) |  |

DESCRIPTION: Set the Modified W state and A,B coefficients for HW support

Note
Note that this is an asynchronous function and returns NVAPI_OK if all arguments are valid. Returned value NVAPI_OK does not reflect that Modified-W is supported or is set in hardware. One must call NvAPI_D3D_QueryModifiedWSupport() to confirm that the current setup supports Modified-W before calling this set-function.

SUPPORTED OS: Windows 7 and higher

Parameters
[in] | pDevOrContext | The ID3D11Device or ID3D11DeviceContext to use.
[in] | psModifiedWParams | Modified W parameters.
Return values
NVAPI_OK | Call succeeded.
NVAPI_ERROR | Call failed.
NVAPI_INVALID_ARGUMENT | One or more arguments are invalid.

<>

◆ NvAPI_D3D_SetMultiViewMode()

NVAPI_INTERFACE NvAPI_D3D_SetMultiViewMode | ( | __in IUnknown * | pDevOrContext,
 |  | __in NV_MULTIVIEW_PARAMS * | pMultiViewParams
 | ) |  |

DESCRIPTION: Set the MultiView state

Note
Note that this is an asynchronous function and returns NVAPI_OK if all arguments are valid. Returned value NVAPI_OK does not reflect that MultiView is supported or is set in hardware. One must call NvAPI_D3D_QueryMultiViewSupport() to confirm that the current setup supports MultiView before calling this set-function.

SUPPORTED OS: Windows 7 and higher

Since
Release: 410
Parameters
[in] | pDevOrContext | The ID3D11Device or ID3D11DeviceContext to use.
[in] | pMultiViewParams | MultiView Params
Returns
This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below. (none)

<>

◆ NvAPI_D3D_SetReflexSync()

NVAPI_INTERFACE NvAPI_D3D_SetReflexSync | ( | __in IUnknown * | pDev,
 |  | __in NV_SET_REFLEX_SYNC_PARAMS * | pSetReflexSyncParams
 | ) |  |

DESCRIPTION: This function can be used to enable/disable Reflex Sync, and to pass in essential data for the Reflex Sync operation.

Since
Release: 530
Parameters
[in] | pDev | The target device.
[in] | pSetReflexSyncParams | Reflex Sync params. SUPPORTED OS: Windows 10 and higher
Returns
This API can return any of the error codes enumerated in NvAPI_Status.

◆ NvAPI_D3D_SetResourceHint()

NvAPI_D3D_SetResourceHint | ( | IUnknown * | pDev,
 |  | NVDX_ObjectHandle | obj,
 |  | NVAPI_D3D_SETRESOURCEHINT_CATEGORY | dwHintCategory,
 |  | NvU32 | dwHintName,
 |  | NvU32 * | pdwHintValue
 | ) |  |

DESCRIPTION: This is a general purpose function for passing down various resource related hints to the driver. Hints are divided into categories and types within each category. For DX11 devices this function is free-threaded. An application is responsible to complete this call before making use of the resource in a rendering context (therefore applying inter-thread synchronization as appropriate). As a debug help to an application the driver enforces that a resource in this call was never bound.

SUPPORTED OS: Windows 7 and higher

Since
Release: 185
Parameters
[in] | pDev | The ID3D10Device or IDirect3DDevice9 that is a using the resource
[in] | obj | Previously obtained HV resource handle
[in] | dwHintCategory | Category of the hints
[in] | dwHintName | A hint within this category
[in/out] | *pdwHintValue Pointer to location containing hint value, function returns previous hint value in this slot
Returns
an int which could be an NvAPI status or DX HRESULT code
Return values
NVAPI_OK
NVAPI_INVALID_ARGUMENT
NVAPI_INVALID_CALL It is illegal to change a hint dynamically when the resource is already bound.

◆ NvAPI_D3D_SetSinglePassStereoMode()

NVAPI_INTERFACE NvAPI_D3D_SetSinglePassStereoMode | ( | __in IUnknown * | pDevOrContext,
 |  | __in NvU32 | numViews,
 |  | __in NvU32 | renderTargetIndexOffset,
 |  | __in NvU8 | independentViewportMaskEnable
 | ) |  |

DESCRIPTION: Set the Single Pass Stereo state

Note
Note that this is an asynchronous function and returns NVAPI_OK if all arguments are valid. Returned value NVAPI_OK does not reflect that Single Pass Stereo is supported or is set in hardware. One must call NvAPI_D3D_QuerySinglePassStereoSupport() to confirm that the current setup supports Single Pass Stereo before calling this set-function.

SUPPORTED OS: Windows 7 and higher

Parameters
[in] | pDevOrContext | The ID3D11Device or ID3D11DeviceContext to use.
[in] | numViews | Number of views to render.
[in] | renderTargetIndexOffset | Offset between render targets of the different views.
[in] | independentViewportMaskEnable | Is the independent viewport mask enabled.
Return values
NVAPI_OK | Call succeeded.
NVAPI_ERROR | Call failed.
NVAPI_INVALID_ARGUMENT | One or more arguments are invalid.

<>

◆ NvAPI_D3D_SetSleepMode()

NVAPI_INTERFACE NvAPI_D3D_SetSleepMode | ( | __in IUnknown * | pDev,
 |  | __in NV_SET_SLEEP_MODE_PARAMS * | pSetSleepModeParams
 | ) |  |

DESCRIPTION: This function can be used to update sleep mode dynamically. The settings are not dependent to each other, meaning low latency mode can be enabled/disabled regardless of whether minimum interval is set or not. The former is to intelligently lower latency without impacting frame rate. The later is to limit frame rate (e.g. minimumIntervalUs = 10000 limits frame rate to 100 FPS). They work well separately and/or together. Note that minimumIntervalUs usage is not limited to lowering latency, so feel free to use it to limit frame rate for menu, cut scenes, etc. Note that low latency mode can be enabled, and/or minimum interval can be set, even without using NvAPI_D3D_Sleep(). However, without it, the sleep to achieve these features would happen at a less optimal point, resulting in higher overall latency. The bLowLatencyBoost will request the GPU run at max clocks even in scenarios where it is idle most of the frame and would normally try to save power. This can decrease latency in CPU-limited scenarios. While this function can be called as often as needed, it is not necessary nor recommended to call this too frequently (e.g. every frame), as the settings persist for the target device.

Since
Release: 455
Parameters
[in] | pDev | The target device.
[in] | pSetSleepModeParams | Sleep mode params. SUPPORTED OS: Windows 7 and higher
Returns
This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.

◆ NvAPI_D3D_SetVerticalSyncMode()

NVAPI_INTERFACE NvAPI_D3D_SetVerticalSyncMode | ( | __in IUnknown * | pDevice,
 |  | __in NVAPI_VSYNC_MODE | vsyncMode
 | ) |  |

DESCRIPTION: This API set the vertical sync mode for the given device context.

Parameters
[in] | pDevice | The caller provides the device and can be either IDirect3DDevice9 or ID3D10Device or ID3D10Device1 or ID3D11Device.
[in] | vsyncMode | The caller specifies the NVAPI_VSYNC_MODE to be set.

SUPPORTED OS: Windows Vista

RETURN STATUS: This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.

◆ NvAPI_D3D_Sleep()

NVAPI_INTERFACE NvAPI_D3D_Sleep ( __in IUnknown * pDev )

DESCRIPTION: It is recommended to call this function at the very start of each frame (e.g. before input sampling). If there is a need to sleep, due to frame rate limit and/or low latency features, for example, this call provides an entry point for the driver to sleep at the most optimal spot to achieve the lowest latency. It is recommended to call this function even when low latency mode is disabled and minimum interval is 0. Other features, such as Maximum Frame Rate setting, could be enabled in the control panel to benefit from this. It is OK to start (or stop) using this function at any time. However, when using this function, it must be called exactly once on each frame. If this function is not called, after several frames, the driver would fallback to sleep at its less optimal spot.

Since
Release: 455
Parameters
[in] pDev The target device. SUPPORTED OS: Windows 7 and higher
Returns
This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.

◆ NvAPI_DirectD3D12GraphicsCommandList_Create()

NVAPI_INTERFACE NvAPI_DirectD3D12GraphicsCommandList_Create | ( | __in ID3D12GraphicsCommandList * | pDXD3D12GraphicsCommandList,
 |  | __out INvAPI_DirectD3D12GraphicsCommandList ** | ppReturnD3D12GraphicsCommandList
 | ) |  |

DESCRIPTION: Create the NvAPI_DirectD3D12GraphicsCommandList handle. This function must be called after ID3D12Device::CreateCommandList.

Parameters
[in] | pDXD3D12GraphicsCommandList | The ID3D12GraphicsCommandList
[out] | ppReturnD3D12GraphicsCommandList | The corresponding NvAPI_DirectD3D12GraphicsCommandList handle SUPPORTED OS: Windows 10 and higher
Returns
This API can return any of the error codes enumerated in NvAPI_Status.

◆ NvAPI_DirectD3D12GraphicsCommandList_Release()

NVAPI_INTERFACE NvAPI_DirectD3D12GraphicsCommandList_Release ( __in INvAPI_DirectD3D12GraphicsCommandList * pD3D12GraphicsCommandList )

DESCRIPTION: release the NvAPI_DirectD3D12GraphicsCommandList handle.

Parameters
[in] pD3D12GraphicsCommandList The NvAPI_DirectD3D12GraphicsCommandList handle to release SUPPORTED OS: Windows 10 and higher
Returns
This API can return any of the error codes enumerated in NvAPI_Status.

◆ NvAPI_DirectD3D12GraphicsCommandList_Reset()

NVAPI_INTERFACE NvAPI_DirectD3D12GraphicsCommandList_Reset ( __in INvAPI_DirectD3D12GraphicsCommandList * pD3D12GraphicsCommandList )

DESCRIPTION: reset the NvAPI_DirectD3D12GraphicsCommandList handle. This function must be called after ID3D12GraphicsCommandList::Reset() and before any other NvAPI_Direct function calls such as dispatchGraphics() etc.

Parameters
[in] pD3D12GraphicsCommandList The NvAPI_DirectD3D12GraphicsCommandList handle to reset SUPPORTED OS: Windows 10 and higher
Returns
This API can return any of the error codes enumerated in NvAPI_Status.


Typedefs | Enumerations
TV APIs

Typedefs

typedef enum _NV_DISPLAY_TV_FORMAT NV_DISPLAY_TV_FORMAT

Enumerations

enum _NV_DISPLAY_TV_FORMAT {
NV_DISPLAY_TV_FORMAT_NONE = 0 , NV_DISPLAY_TV_FORMAT_SD_NTSCM = 0x00000001 , NV_DISPLAY_TV_FORMAT_SD_NTSCJ = 0x00000002 , NV_DISPLAY_TV_FORMAT_SD_PALM = 0x00000004 ,
NV_DISPLAY_TV_FORMAT_SD_PALBDGH = 0x00000008 , NV_DISPLAY_TV_FORMAT_SD_PALN = 0x00000010 , NV_DISPLAY_TV_FORMAT_SD_PALNC = 0x00000020 , NV_DISPLAY_TV_FORMAT_SD_576i = 0x00000100 ,
NV_DISPLAY_TV_FORMAT_SD_480i = 0x00000200 , NV_DISPLAY_TV_FORMAT_ED_480p = 0x00000400 , NV_DISPLAY_TV_FORMAT_ED_576p = 0x00000800 , NV_DISPLAY_TV_FORMAT_HD_720p = 0x00001000 ,
NV_DISPLAY_TV_FORMAT_HD_1080i = 0x00002000 , NV_DISPLAY_TV_FORMAT_HD_1080p = 0x00004000 , NV_DISPLAY_TV_FORMAT_HD_720p50 = 0x00008000 , NV_DISPLAY_TV_FORMAT_HD_1080p24 = 0x00010000 ,
NV_DISPLAY_TV_FORMAT_HD_1080i50 = 0x00020000 , NV_DISPLAY_TV_FORMAT_HD_1080p50 = 0x00040000 , NV_DISPLAY_TV_FORMAT_UHD_4Kp30 = 0x00080000 , NV_DISPLAY_TV_FORMAT_UHD_4Kp30_3840 = NV_DISPLAY_TV_FORMAT_UHD_4Kp30 ,
NV_DISPLAY_TV_FORMAT_UHD_4Kp25 = 0x00100000 , NV_DISPLAY_TV_FORMAT_UHD_4Kp25_3840 = NV_DISPLAY_TV_FORMAT_UHD_4Kp25 , NV_DISPLAY_TV_FORMAT_UHD_4Kp24 = 0x00200000 , NV_DISPLAY_TV_FORMAT_UHD_4Kp24_3840 = NV_DISPLAY_TV_FORMAT_UHD_4Kp24 ,
NV_DISPLAY_TV_FORMAT_UHD_4Kp24_SMPTE = 0x00400000 , NV_DISPLAY_TV_FORMAT_UHD_4Kp50_3840 = 0x00800000 , NV_DISPLAY_TV_FORMAT_UHD_4Kp60_3840 = 0x00900000 , NV_DISPLAY_TV_FORMAT_UHD_4Kp30_4096 = 0x00A00000 ,
NV_DISPLAY_TV_FORMAT_UHD_4Kp25_4096 = 0x00B00000 , NV_DISPLAY_TV_FORMAT_UHD_4Kp24_4096 = 0x00C00000 , NV_DISPLAY_TV_FORMAT_UHD_4Kp50_4096 = 0x00D00000 , NV_DISPLAY_TV_FORMAT_UHD_4Kp60_4096 = 0x00E00000 ,
NV_DISPLAY_TV_FORMAT_UHD_8Kp24_7680 = 0x01000000 , NV_DISPLAY_TV_FORMAT_UHD_8Kp25_7680 = 0x02000000 , NV_DISPLAY_TV_FORMAT_UHD_8Kp30_7680 = 0x04000000 , NV_DISPLAY_TV_FORMAT_UHD_8Kp48_7680 = 0x08000000 ,
NV_DISPLAY_TV_FORMAT_UHD_8Kp50_7680 = 0x09000000 , NV_DISPLAY_TV_FORMAT_UHD_8Kp60_7680 = 0x0A000000 , NV_DISPLAY_TV_FORMAT_UHD_8Kp100_7680 = 0x0B000000 , NV_DISPLAY_TV_FORMAT_UHD_8Kp120_7680 = 0x0C000000 ,
NV_DISPLAY_TV_FORMAT_UHD_4Kp48_3840 = 0x0D000000 , NV_DISPLAY_TV_FORMAT_UHD_4Kp48_4096 = 0x0E000000 , NV_DISPLAY_TV_FORMAT_UHD_4Kp100_4096 = 0x0F000000 , NV_DISPLAY_TV_FORMAT_UHD_4Kp100_3840 = 0x10000000 ,
NV_DISPLAY_TV_FORMAT_UHD_4Kp120_4096 = 0x11000000 , NV_DISPLAY_TV_FORMAT_UHD_4Kp120_3840 = 0x12000000 , NV_DISPLAY_TV_FORMAT_UHD_4Kp100_5120 = 0x13000000 , NV_DISPLAY_TV_FORMAT_UHD_4Kp120_5120 = 0x14000000 ,
NV_DISPLAY_TV_FORMAT_UHD_4Kp24_5120 = 0x15000000 , NV_DISPLAY_TV_FORMAT_UHD_4Kp25_5120 = 0x16000000 , NV_DISPLAY_TV_FORMAT_UHD_4Kp30_5120 = 0x17000000 , NV_DISPLAY_TV_FORMAT_UHD_4Kp48_5120 = 0x18000000 ,
NV_DISPLAY_TV_FORMAT_UHD_4Kp50_5120 = 0x19000000 , NV_DISPLAY_TV_FORMAT_UHD_4Kp60_5120 = 0x20000000 , NV_DISPLAY_TV_FORMAT_UHD_10Kp24_10240 = 0x21000000 , NV_DISPLAY_TV_FORMAT_UHD_10Kp25_10240 = 0x22000000 ,
NV_DISPLAY_TV_FORMAT_UHD_10Kp30_10240 = 0x23000000 , NV_DISPLAY_TV_FORMAT_UHD_10Kp48_10240 = 0x24000000 , NV_DISPLAY_TV_FORMAT_UHD_10Kp50_10240 = 0x25000000 , NV_DISPLAY_TV_FORMAT_UHD_10Kp60_10240 = 0x26000000 ,
NV_DISPLAY_TV_FORMAT_UHD_10Kp100_10240 = 0x27000000 , NV_DISPLAY_TV_FORMAT_UHD_10Kp120_10240 = 0x28000000 , NV_DISPLAY_TV_FORMAT_SD_OTHER = 0x30000000 , NV_DISPLAY_TV_FORMAT_ED_OTHER = 0x40000000 ,
NV_DISPLAY_TV_FORMAT_HD_OTHER = 0x50000000 , NV_DISPLAY_TV_FORMAT_ANY = 0x80000000
}

Detailed Description

The TV APIs are used to retrieve TV-related information such as HDTV connector types, TV encoder types, and TV formats.

Typedef Documentation

◆ NV_DISPLAY_TV_FORMAT

typedef enum _NV_DISPLAY_TV_FORMAT NV_DISPLAY_TV_FORMAT

Used in NV_DISPLAY_TV_OUTPUT_INFO

Enumeration Type Documentation

◆ _NV_DISPLAY_TV_FORMAT

enum _NV_DISPLAY_TV_FORMAT

Used in NV_DISPLAY_TV_OUTPUT_INFO

Enumerator
NV_DISPLAY_TV_FORMAT_NONE
NV_DISPLAY_TV_FORMAT_SD_NTSCM
NV_DISPLAY_TV_FORMAT_SD_NTSCJ
NV_DISPLAY_TV_FORMAT_SD_PALM
NV_DISPLAY_TV_FORMAT_SD_PALBDGH
NV_DISPLAY_TV_FORMAT_SD_PALN
NV_DISPLAY_TV_FORMAT_SD_PALNC
NV_DISPLAY_TV_FORMAT_SD_576i
NV_DISPLAY_TV_FORMAT_SD_480i
NV_DISPLAY_TV_FORMAT_ED_480p
NV_DISPLAY_TV_FORMAT_ED_576p
NV_DISPLAY_TV_FORMAT_HD_720p
NV_DISPLAY_TV_FORMAT_HD_1080i
NV_DISPLAY_TV_FORMAT_HD_1080p
NV_DISPLAY_TV_FORMAT_HD_720p50
NV_DISPLAY_TV_FORMAT_HD_1080p24
NV_DISPLAY_TV_FORMAT_HD_1080i50
NV_DISPLAY_TV_FORMAT_HD_1080p50
NV_DISPLAY_TV_FORMAT_UHD_4Kp30
NV_DISPLAY_TV_FORMAT_UHD_4Kp30_3840
NV_DISPLAY_TV_FORMAT_UHD_4Kp25
NV_DISPLAY_TV_FORMAT_UHD_4Kp25_3840
NV_DISPLAY_TV_FORMAT_UHD_4Kp24
NV_DISPLAY_TV_FORMAT_UHD_4Kp24_3840
NV_DISPLAY_TV_FORMAT_UHD_4Kp24_SMPTE
NV_DISPLAY_TV_FORMAT_UHD_4Kp50_3840
NV_DISPLAY_TV_FORMAT_UHD_4Kp60_3840
NV_DISPLAY_TV_FORMAT_UHD_4Kp30_4096
NV_DISPLAY_TV_FORMAT_UHD_4Kp25_4096
NV_DISPLAY_TV_FORMAT_UHD_4Kp24_4096
NV_DISPLAY_TV_FORMAT_UHD_4Kp50_4096
NV_DISPLAY_TV_FORMAT_UHD_4Kp60_4096
NV_DISPLAY_TV_FORMAT_UHD_8Kp24_7680
NV_DISPLAY_TV_FORMAT_UHD_8Kp25_7680
NV_DISPLAY_TV_FORMAT_UHD_8Kp30_7680
NV_DISPLAY_TV_FORMAT_UHD_8Kp48_7680
NV_DISPLAY_TV_FORMAT_UHD_8Kp50_7680
NV_DISPLAY_TV_FORMAT_UHD_8Kp60_7680
NV_DISPLAY_TV_FORMAT_UHD_8Kp100_7680
NV_DISPLAY_TV_FORMAT_UHD_8Kp120_7680
NV_DISPLAY_TV_FORMAT_UHD_4Kp48_3840
NV_DISPLAY_TV_FORMAT_UHD_4Kp48_4096
NV_DISPLAY_TV_FORMAT_UHD_4Kp100_4096
NV_DISPLAY_TV_FORMAT_UHD_4Kp100_3840
NV_DISPLAY_TV_FORMAT_UHD_4Kp120_4096
NV_DISPLAY_TV_FORMAT_UHD_4Kp120_3840
NV_DISPLAY_TV_FORMAT_UHD_4Kp100_5120
NV_DISPLAY_TV_FORMAT_UHD_4Kp120_5120
NV_DISPLAY_TV_FORMAT_UHD_4Kp24_5120
NV_DISPLAY_TV_FORMAT_UHD_4Kp25_5120
NV_DISPLAY_TV_FORMAT_UHD_4Kp30_5120
NV_DISPLAY_TV_FORMAT_UHD_4Kp48_5120
NV_DISPLAY_TV_FORMAT_UHD_4Kp50_5120
NV_DISPLAY_TV_FORMAT_UHD_4Kp60_5120
NV_DISPLAY_TV_FORMAT_UHD_10Kp24_10240
NV_DISPLAY_TV_FORMAT_UHD_10Kp25_10240
NV_DISPLAY_TV_FORMAT_UHD_10Kp30_10240
NV_DISPLAY_TV_FORMAT_UHD_10Kp48_10240
NV_DISPLAY_TV_FORMAT_UHD_10Kp50_10240
NV_DISPLAY_TV_FORMAT_UHD_10Kp60_10240
NV_DISPLAY_TV_FORMAT_UHD_10Kp100_10240
NV_DISPLAY_TV_FORMAT_UHD_10Kp120_10240
NV_DISPLAY_TV_FORMAT_SD_OTHER
NV_DISPLAY_TV_FORMAT_ED_OTHER
NV_DISPLAY_TV_FORMAT_HD_OTHER
NV_DISPLAY_TV_FORMAT_ANY


Data Structures | Macros | Typedefs | Enumerations | Functions
Mosaic APIs
OpenGL APIs

Data Structures

struct | NV_MOSAIC_TOPO_DETAILS
struct | NV_MOSAIC_TOPO_BRIEF
struct | _NV_MOSAIC_DISPLAY_SETTING_V1
struct | NV_MOSAIC_DISPLAY_SETTING_V2
struct | _NV_MOSAIC_SUPPORTED_TOPO_INFO_V1
struct | _NV_MOSAIC_SUPPORTED_TOPO_INFO_V2
struct | NV_MOSAIC_TOPO_GROUP
struct | _NV_MOSAIC_GRID_TOPO_DISPLAY_V1
struct | NV_MOSAIC_DISPLAY_TOPO_STATUS
struct | NV_MOSAIC_TOPOLOGY
struct | NV_MOSAIC_SUPPORTED_TOPOLOGIES

Macros

#define | NVAPI_MAX_MOSAIC_DISPLAY_ROWS 8
#define | NVAPI_MAX_MOSAIC_DISPLAY_ROWS 8
#define | NVAPI_MAX_MOSAIC_DISPLAY_COLUMNS 8
#define | NVAPI_MAX_MOSAIC_DISPLAY_COLUMNS 8
#define | NV_MOSAIC_TOPO_VALIDITY_VALID 0x00000000
#define | NV_MOSAIC_TOPO_VALIDITY_MISSING_GPU 0x00000001
#define | NV_MOSAIC_TOPO_VALIDITY_MISSING_DISPLAY 0x00000002
#define | NV_MOSAIC_TOPO_VALIDITY_MIXED_DISPLAY_TYPES 0x00000004
#define | NVAPI_MOSAIC_TOPO_DETAILS_VER MAKE_NVAPI_VERSION(NV_MOSAIC_TOPO_DETAILS,1)
#define | NVAPI_MOSAIC_TOPO_BRIEF_VER MAKE_NVAPI_VERSION(NV_MOSAIC_TOPO_BRIEF,1)
#define | NVAPI_MOSAIC_DISPLAY_SETTING_VER1 MAKE_NVAPI_VERSION(NV_MOSAIC_DISPLAY_SETTING_V1,1)
#define | NVAPI_MOSAIC_DISPLAY_SETTING_VER2 MAKE_NVAPI_VERSION(NV_MOSAIC_DISPLAY_SETTING_V2,2)
#define | NVAPI_MOSAIC_DISPLAY_SETTING_VER NVAPI_MOSAIC_DISPLAY_SETTING_VER2
#define | NV_MOSAIC_DISPLAY_SETTINGS_MAX 40
#define | NVAPI_MOSAIC_SUPPORTED_TOPO_INFO_VER1 MAKE_NVAPI_VERSION(NV_MOSAIC_SUPPORTED_TOPO_INFO_V1,1)
#define | NVAPI_MOSAIC_SUPPORTED_TOPO_INFO_VER2 MAKE_NVAPI_VERSION(NV_MOSAIC_SUPPORTED_TOPO_INFO_V2,2)
#define | NVAPI_MOSAIC_SUPPORTED_TOPO_INFO_VER NVAPI_MOSAIC_SUPPORTED_TOPO_INFO_VER2
#define | NV_MOSAIC_TOPO_IDX_DEFAULT 0
#define | NV_MOSAIC_TOPO_IDX_LEFT_EYE 0
#define | NV_MOSAIC_TOPO_IDX_RIGHT_EYE 1
#define | NV_MOSAIC_TOPO_NUM_EYES 2
#define | NV_MOSAIC_MAX_TOPO_PER_TOPO_GROUP 2
#define | NVAPI_MOSAIC_TOPO_GROUP_VER MAKE_NVAPI_VERSION(NV_MOSAIC_TOPO_GROUP,1)
#define | NV_MOSAIC_DISPLAYTOPO_WARNING_DISPLAY_POSITION NV_BIT(0)
#define | NV_MOSAIC_DISPLAYTOPO_WARNING_DRIVER_RELOAD_REQUIRED NV_BIT(1)
#define | NV_MOSAIC_DISPLAY_TOPO_STATUS_VER MAKE_NVAPI_VERSION(NV_MOSAIC_DISPLAY_TOPO_STATUS,1)
#define | NVAPI_MAX_MOSAIC_TOPOS 16
#define | NVAPI_MOSAIC_TOPOLOGY_VER MAKE_NVAPI_VERSION(NV_MOSAIC_TOPOLOGY,1)
#define | NVAPI_MOSAIC_SUPPORTED_TOPOLOGIES_VER MAKE_NVAPI_VERSION(NV_MOSAIC_SUPPORTED_TOPOLOGIES,1)

Typedefs

typedef struct _NV_MOSAIC_DISPLAY_SETTING_V1 | NV_MOSAIC_DISPLAY_SETTING_V1
typedef struct NV_MOSAIC_DISPLAY_SETTING_V2 | NV_MOSAIC_DISPLAY_SETTING_V2
typedef NV_MOSAIC_DISPLAY_SETTING_V2 | NV_MOSAIC_DISPLAY_SETTING
typedef struct _NV_MOSAIC_SUPPORTED_TOPO_INFO_V1 | NV_MOSAIC_SUPPORTED_TOPO_INFO_V1
typedef struct _NV_MOSAIC_SUPPORTED_TOPO_INFO_V2 | NV_MOSAIC_SUPPORTED_TOPO_INFO_V2
typedef NV_MOSAIC_SUPPORTED_TOPO_INFO_V2 | NV_MOSAIC_SUPPORTED_TOPO_INFO

Enumerations

enum NV_MOSAIC_TOPO_TYPE {
NV_MOSAIC_TOPO_TYPE_ALL , NV_MOSAIC_TOPO_TYPE_BASIC , NV_MOSAIC_TOPO_TYPE_PASSIVE_STEREO , NV_MOSAIC_TOPO_TYPE_SCALED_CLONE ,
NV_MOSAIC_TOPO_TYPE_PASSIVE_STEREO_SCALED_CLONE , NV_MOSAIC_TOPO_TYPE_MAX
}
enum NV_MOSAIC_TOPO {
NV_MOSAIC_TOPO_NONE , NV_MOSAIC_TOPO_BEGIN_BASIC , NV_MOSAIC_TOPO_1x2_BASIC = NV_MOSAIC_TOPO_BEGIN_BASIC , NV_MOSAIC_TOPO_2x1_BASIC ,
NV_MOSAIC_TOPO_1x3_BASIC , NV_MOSAIC_TOPO_3x1_BASIC , NV_MOSAIC_TOPO_1x4_BASIC , NV_MOSAIC_TOPO_4x1_BASIC ,
NV_MOSAIC_TOPO_2x2_BASIC , NV_MOSAIC_TOPO_2x3_BASIC , NV_MOSAIC_TOPO_2x4_BASIC , NV_MOSAIC_TOPO_3x2_BASIC ,
NV_MOSAIC_TOPO_4x2_BASIC , NV_MOSAIC_TOPO_1x5_BASIC , NV_MOSAIC_TOPO_1x6_BASIC , NV_MOSAIC_TOPO_7x1_BASIC ,
NV_MOSAIC_TOPO_END_BASIC = NV_MOSAIC_TOPO_7x1_BASIC + 9 , NV_MOSAIC_TOPO_BEGIN_PASSIVE_STEREO , NV_MOSAIC_TOPO_1x2_PASSIVE_STEREO = NV_MOSAIC_TOPO_BEGIN_PASSIVE_STEREO , NV_MOSAIC_TOPO_2x1_PASSIVE_STEREO ,
NV_MOSAIC_TOPO_1x3_PASSIVE_STEREO , NV_MOSAIC_TOPO_3x1_PASSIVE_STEREO , NV_MOSAIC_TOPO_1x4_PASSIVE_STEREO , NV_MOSAIC_TOPO_4x1_PASSIVE_STEREO ,
NV_MOSAIC_TOPO_2x2_PASSIVE_STEREO , NV_MOSAIC_TOPO_END_PASSIVE_STEREO = NV_MOSAIC_TOPO_2x2_PASSIVE_STEREO + 4 , NV_MOSAIC_TOPO_MAX
}

Functions

NVAPI_INTERFACE | NvAPI_Mosaic_GetSupportedTopoInfo (NV_MOSAIC_SUPPORTED_TOPO_INFO *pSupportedTopoInfo, NV_MOSAIC_TOPO_TYPE type)
NVAPI_INTERFACE | NvAPI_Mosaic_GetTopoGroup (NV_MOSAIC_TOPO_BRIEF *pTopoBrief, NV_MOSAIC_TOPO_GROUP *pTopoGroup)
NVAPI_INTERFACE | NvAPI_Mosaic_GetOverlapLimits (NV_MOSAIC_TOPO_BRIEF *pTopoBrief, NV_MOSAIC_DISPLAY_SETTING *pDisplaySetting, NvS32 *pMinOverlapX, NvS32 *pMaxOverlapX, NvS32 *pMinOverlapY, NvS32 *pMaxOverlapY)
NVAPI_INTERFACE | NvAPI_Mosaic_SetCurrentTopo (NV_MOSAIC_TOPO_BRIEF *pTopoBrief, NV_MOSAIC_DISPLAY_SETTING *pDisplaySetting, NvS32 overlapX, NvS32 overlapY, NvU32 enable)
NVAPI_INTERFACE | NvAPI_Mosaic_GetCurrentTopo (NV_MOSAIC_TOPO_BRIEF *pTopoBrief, NV_MOSAIC_DISPLAY_SETTING *pDisplaySetting, NvS32 *pOverlapX, NvS32 *pOverlapY)
NVAPI_INTERFACE | NvAPI_Mosaic_EnableCurrentTopo (NvU32 enable)
NVAPI_INTERFACE | NvAPI_Mosaic_SetDisplayGrids (__in_ecount(gridCount) NV_MOSAIC_GRID_TOPO *pGridTopologies, __in NvU32 gridCount, __in NvU32 setTopoFlags)
NVAPI_INTERFACE | NvAPI_Mosaic_ValidateDisplayGrids (__in NvU32 setTopoFlags, __in_ecount(gridCount) NV_MOSAIC_GRID_TOPO *pGridTopologies, __inout_ecount_full(gridCount) NV_MOSAIC_DISPLAY_TOPO_STATUS *pTopoStatus, __in NvU32 gridCount)
NVAPI_INTERFACE | NvAPI_Mosaic_EnumDisplayGrids (__inout_ecount_part_opt(*pGridCount, *pGridCount) NV_MOSAIC_GRID_TOPO *pGridTopologies, __inout NvU32 *pGridCount)
NVAPI_INTERFACE | NvAPI_GetSupportedMosaicTopologies (NV_MOSAIC_SUPPORTED_TOPOLOGIES *pMosaicTopos)
NVAPI_INTERFACE | NvAPI_GetCurrentMosaicTopology (NV_MOSAIC_TOPOLOGY *pMosaicTopo, NvU32 *pEnabled)
NVAPI_INTERFACE | NvAPI_SetCurrentMosaicTopology (NV_MOSAIC_TOPOLOGY *pMosaicTopo)
NVAPI_INTERFACE | NvAPI_EnableCurrentMosaicTopology (NvU32 enable)
NVAPI_INTERFACE | NvAPI_Mosaic_GetDisplayViewportsByResolution (NvU32 displayId, NvU32 srcWidth, NvU32 srcHeight, NV_RECT viewports[NV_MOSAIC_MAX_DISPLAYS], NvU8 *bezelCorrected)
typedef struct _NV_MOSAIC_GRID_TOPO_DISPLAY_V1 | NV_MOSAIC_GRID_TOPO_DISPLAY_V1

Detailed Description

MOSAIC mode allows multi-display target scan out from a single source.

The following is an example of a MOSAIC 1x4 topology with 8-pixel horizontal overlap:

//!+----------------------++----------------------++----------------------++----------------------+
//!|                    ->||<- 8 pixels           ||                      ||                      |
//!|                      ||                      ||                      ||                      |
//!|                      ||                      ||                      ||                      |
//!|       DVI1           ||          DVI2        ||         DVI3         ||        DVI4          |
//!|                      ||                      ||                      ||                      |
//!|                      ||                      ||                      ||                      |
//!|                      ||                      ||                      ||                      |
//!|                      ||                      ||                      ||                      |
//!+----------------------++----------------------++----------------------++----------------------+
//!

Macro Definition Documentation

◆ NV_MOSAIC_DISPLAY_SETTINGS_MAX

#define NV_MOSAIC_DISPLAY_SETTINGS_MAX 40

Set a reasonable maximum number of display settings to support so arrays are bound.

◆ NV_MOSAIC_DISPLAY_TOPO_STATUS_VER

#define NV_MOSAIC_DISPLAY_TOPO_STATUS_VER MAKE_NVAPI_VERSION(NV_MOSAIC_DISPLAY_TOPO_STATUS,1)

◆ NV_MOSAIC_DISPLAYTOPO_WARNING_DISPLAY_POSITION

#define NV_MOSAIC_DISPLAYTOPO_WARNING_DISPLAY_POSITION NV_BIT(0)

Indicates that a display's position in the grid is sub-optimal.

◆ NV_MOSAIC_DISPLAYTOPO_WARNING_DRIVER_RELOAD_REQUIRED

#define NV_MOSAIC_DISPLAYTOPO_WARNING_DRIVER_RELOAD_REQUIRED NV_BIT(1)

Indicates that SetDisplaySettings would need to perform a driver reload.

◆ NV_MOSAIC_MAX_TOPO_PER_TOPO_GROUP

#define NV_MOSAIC_MAX_TOPO_PER_TOPO_GROUP 2

This defines the maximum number of topos that can be in a topo group. At this time, it is set to 2 because our largest topo group (passive stereo) only needs 2 topos (left eye and right eye).

If a new topo group with more than 2 topos is added above, then this number will also have to be incremented.

◆ NV_MOSAIC_TOPO_IDX_DEFAULT

#define NV_MOSAIC_TOPO_IDX_DEFAULT 0

◆ NV_MOSAIC_TOPO_IDX_LEFT_EYE

#define NV_MOSAIC_TOPO_IDX_LEFT_EYE 0

◆ NV_MOSAIC_TOPO_IDX_RIGHT_EYE

#define NV_MOSAIC_TOPO_IDX_RIGHT_EYE 1

◆ NV_MOSAIC_TOPO_NUM_EYES

#define NV_MOSAIC_TOPO_NUM_EYES 2

◆ NV_MOSAIC_TOPO_VALIDITY_MISSING_DISPLAY

#define NV_MOSAIC_TOPO_VALIDITY_MISSING_DISPLAY 0x00000002

Not enough displays were found to fill the entire topology. displayOutputId will be 0 for these.

◆ NV_MOSAIC_TOPO_VALIDITY_MISSING_GPU

#define NV_MOSAIC_TOPO_VALIDITY_MISSING_GPU 0x00000001

Not enough SLI GPUs were found to fill the entire topology. hPhysicalGPU will be 0 for these.

◆ NV_MOSAIC_TOPO_VALIDITY_MIXED_DISPLAY_TYPES

#define NV_MOSAIC_TOPO_VALIDITY_MIXED_DISPLAY_TYPES 0x00000004

The topoogy is only possible with displays of the same NV_GPU_OUTPUT_TYPE. Check displayOutputIds to make sure they are all CRTs, or all DFPs.

◆ NV_MOSAIC_TOPO_VALIDITY_VALID

#define NV_MOSAIC_TOPO_VALIDITY_VALID 0x00000000

The topology is valid.

◆ NVAPI_MAX_MOSAIC_DISPLAY_COLUMNS [1/2]

#define NVAPI_MAX_MOSAIC_DISPLAY_COLUMNS 8

Used in NV_MOSAIC_TOPOLOGY.

◆ NVAPI_MAX_MOSAIC_DISPLAY_COLUMNS [2/2]

#define NVAPI_MAX_MOSAIC_DISPLAY_COLUMNS 8

Used in NV_MOSAIC_TOPOLOGY.

◆ NVAPI_MAX_MOSAIC_DISPLAY_ROWS [1/2]

#define NVAPI_MAX_MOSAIC_DISPLAY_ROWS 8

Used in NV_MOSAIC_TOPOLOGY.

◆ NVAPI_MAX_MOSAIC_DISPLAY_ROWS [2/2]

#define NVAPI_MAX_MOSAIC_DISPLAY_ROWS 8

Used in NV_MOSAIC_TOPOLOGY.

◆ NVAPI_MAX_MOSAIC_TOPOS

#define NVAPI_MAX_MOSAIC_TOPOS 16

Used in NV_MOSAIC_TOPOLOGY.

◆ NVAPI_MOSAIC_DISPLAY_SETTING_VER

#define NVAPI_MOSAIC_DISPLAY_SETTING_VER NVAPI_MOSAIC_DISPLAY_SETTING_VER2

◆ NVAPI_MOSAIC_DISPLAY_SETTING_VER1

#define NVAPI_MOSAIC_DISPLAY_SETTING_VER1 MAKE_NVAPI_VERSION(NV_MOSAIC_DISPLAY_SETTING_V1,1)

Macro for constructing the version field of NV_MOSAIC_DISPLAY_SETTING.

◆ NVAPI_MOSAIC_DISPLAY_SETTING_VER2

#define NVAPI_MOSAIC_DISPLAY_SETTING_VER2 MAKE_NVAPI_VERSION(NV_MOSAIC_DISPLAY_SETTING_V2,2)

◆ NVAPI_MOSAIC_SUPPORTED_TOPO_INFO_VER

#define NVAPI_MOSAIC_SUPPORTED_TOPO_INFO_VER NVAPI_MOSAIC_SUPPORTED_TOPO_INFO_VER2

◆ NVAPI_MOSAIC_SUPPORTED_TOPO_INFO_VER1

#define NVAPI_MOSAIC_SUPPORTED_TOPO_INFO_VER1 MAKE_NVAPI_VERSION(NV_MOSAIC_SUPPORTED_TOPO_INFO_V1,1)

Macro forconstructing the version field of NV_MOSAIC_SUPPORTED_TOPO_INFO.

◆ NVAPI_MOSAIC_SUPPORTED_TOPO_INFO_VER2

#define NVAPI_MOSAIC_SUPPORTED_TOPO_INFO_VER2 MAKE_NVAPI_VERSION(NV_MOSAIC_SUPPORTED_TOPO_INFO_V2,2)

◆ NVAPI_MOSAIC_SUPPORTED_TOPOLOGIES_VER

#define NVAPI_MOSAIC_SUPPORTED_TOPOLOGIES_VER MAKE_NVAPI_VERSION(NV_MOSAIC_SUPPORTED_TOPOLOGIES,1)

Used in NV_MOSAIC_SUPPORTED_TOPOLOGIES.

◆ NVAPI_MOSAIC_TOPO_BRIEF_VER

#define NVAPI_MOSAIC_TOPO_BRIEF_VER MAKE_NVAPI_VERSION(NV_MOSAIC_TOPO_BRIEF,1)

Macro for constructing the version field of NV_MOSAIC_TOPO_BRIEF.

◆ NVAPI_MOSAIC_TOPO_DETAILS_VER

#define NVAPI_MOSAIC_TOPO_DETAILS_VER MAKE_NVAPI_VERSION(NV_MOSAIC_TOPO_DETAILS,1)

Macro for constructing te vesion field of NV_MOSAIC_TOPO_DETAILS.

◆ NVAPI_MOSAIC_TOPO_GROUP_VER

#define NVAPI_MOSAIC_TOPO_GROUP_VER MAKE_NVAPI_VERSION(NV_MOSAIC_TOPO_GROUP,1)

Macro for constructing the version field of NV_MOSAIC_TOPO_GROUP.

◆ NVAPI_MOSAIC_TOPOLOGY_VER

#define NVAPI_MOSAIC_TOPOLOGY_VER MAKE_NVAPI_VERSION(NV_MOSAIC_TOPOLOGY,1)

Used in NV_MOSAIC_TOPOLOGY.

Typedef Documentation

◆ NV_MOSAIC_DISPLAY_SETTING

typedef NV_MOSAIC_DISPLAY_SETTING_V2 NV_MOSAIC_DISPLAY_SETTING

◆ NV_MOSAIC_DISPLAY_SETTING_V1

typedef struct _NV_MOSAIC_DISPLAY_SETTING_V1 NV_MOSAIC_DISPLAY_SETTING_V1

Basic per-display settings that are used in setting/getting the Mosaic mode.

◆ NV_MOSAIC_DISPLAY_SETTING_V2

typedef struct NV_MOSAIC_DISPLAY_SETTING_V2 NV_MOSAIC_DISPLAY_SETTING_V2

◆ NV_MOSAIC_GRID_TOPO_DISPLAY_V1

typedef struct _NV_MOSAIC_GRID_TOPO_DISPLAY_V1 NV_MOSAIC_GRID_TOPO_DISPLAY_V1

Macro for constructing the version field of NV_MOSAIC_GRID_TOPO.

◆ NV_MOSAIC_SUPPORTED_TOPO_INFO

typedef NV_MOSAIC_SUPPORTED_TOPO_INFO_V2 NV_MOSAIC_SUPPORTED_TOPO_INFO

◆ NV_MOSAIC_SUPPORTED_TOPO_INFO_V1

typedef struct _NV_MOSAIC_SUPPORTED_TOPO_INFO_V1 NV_MOSAIC_SUPPORTED_TOPO_INFO_V1

This structure is used to contain a list of supported Mosaic topologies along with the display settings that can be used.

◆ NV_MOSAIC_SUPPORTED_TOPO_INFO_V2

typedef struct _NV_MOSAIC_SUPPORTED_TOPO_INFO_V2 NV_MOSAIC_SUPPORTED_TOPO_INFO_V2

Enumeration Type Documentation

◆ NV_MOSAIC_TOPO

enum NV_MOSAIC_TOPO

This is a complete list of supported Mosaic topologies.

Using a "Basic" topology combines multiple monitors to create a single desktop.

Using a "Passive" topology combines multiples monitors to create a passive stereo desktop. In passive stereo, two identical topologies combine - one topology is used for the right eye and the other identical //! topology (targeting different displays) is used for the left eye.

NOTE: common\inc\nvEscDef.h shadows a couple PASSIVE_STEREO enums. If this enum list changes and effects the value of NV_MOSAIC_TOPO_BEGIN_PASSIVE_STEREO please update the corresponding value in nvEscDef.h

Enumerator
NV_MOSAIC_TOPO_NONE |
NV_MOSAIC_TOPO_BEGIN_BASIC |
NV_MOSAIC_TOPO_1x2_BASIC |
NV_MOSAIC_TOPO_2x1_BASIC |
NV_MOSAIC_TOPO_1x3_BASIC |
NV_MOSAIC_TOPO_3x1_BASIC |
NV_MOSAIC_TOPO_1x4_BASIC |
NV_MOSAIC_TOPO_4x1_BASIC |
NV_MOSAIC_TOPO_2x2_BASIC |
NV_MOSAIC_TOPO_2x3_BASIC |
NV_MOSAIC_TOPO_2x4_BASIC |
NV_MOSAIC_TOPO_3x2_BASIC |
NV_MOSAIC_TOPO_4x2_BASIC |
NV_MOSAIC_TOPO_1x5_BASIC |
NV_MOSAIC_TOPO_1x6_BASIC |
NV_MOSAIC_TOPO_7x1_BASIC |
NV_MOSAIC_TOPO_END_BASIC |
NV_MOSAIC_TOPO_BEGIN_PASSIVE_STEREO |
NV_MOSAIC_TOPO_1x2_PASSIVE_STEREO |
NV_MOSAIC_TOPO_2x1_PASSIVE_STEREO |
NV_MOSAIC_TOPO_1x3_PASSIVE_STEREO |
NV_MOSAIC_TOPO_3x1_PASSIVE_STEREO |
NV_MOSAIC_TOPO_1x4_PASSIVE_STEREO |
NV_MOSAIC_TOPO_4x1_PASSIVE_STEREO |
NV_MOSAIC_TOPO_2x2_PASSIVE_STEREO |
NV_MOSAIC_TOPO_END_PASSIVE_STEREO |
NV_MOSAIC_TOPO_MAX | Total number of topologies.

◆ NV_MOSAIC_TOPO_TYPE

enum NV_MOSAIC_TOPO_TYPE

These values refer to the different types of Mosaic topologies that are possible. When getting the supported Mosaic topologies, you can specify one of these types to narrow down the returned list to only those that match the given type.

Enumerator
NV_MOSAIC_TOPO_TYPE_ALL | All mosaic topologies.
NV_MOSAIC_TOPO_TYPE_BASIC | Basic Mosaic topologies.
NV_MOSAIC_TOPO_TYPE_PASSIVE_STEREO | Passive Stereo topologies.
NV_MOSAIC_TOPO_TYPE_SCALED_CLONE | Not supported at this time.
NV_MOSAIC_TOPO_TYPE_PASSIVE_STEREO_SCALED_CLONE | Not supported at this time.
NV_MOSAIC_TOPO_TYPE_MAX | Always leave this at end of the enum.

Function Documentation

◆ NvAPI_EnableCurrentMosaicTopology()

NVAPI_INTERFACE NvAPI_EnableCurrentMosaicTopology ( NvU32 enable )

DESCRIPTION: This API enables or disables the current Mosaic topology. When enabling, the last Mosaic topology will be set.

  • If enabled, enumeration of display settings will include valid Mosaic resolutions.
  • If disabled, enumeration of display settings will not include Mosaic resolutions.

SUPPORTED OS: Windows XP

Since
Release: 177
Parameters
[in] enable TRUE to enable the Mosaic Topology, FALSE to disable it.
Return values
NVAPI_OK | Call succeeded
NVAPI_INVALID_ARGUMENT | One or more arguments are invalid
NVAPI_NVIDIA_DEVICE_NOT_FOUND | No NVIDIA GPU driving a display was found
NVAPI_NOT_SUPPORTED | Mosaic is not supported with GPUs on this system.
NVAPI_NO_ACTIVE_SLI_TOPOLOGY | SLI is not enabled, yet needs to be, in order for this function to succeed.

◆ NvAPI_GetCurrentMosaicTopology()

NVAPI_INTERFACE NvAPI_GetCurrentMosaicTopology | ( | NV_MOSAIC_TOPOLOGY * | pMosaicTopo,
 |  | NvU32 * | pEnabled
 | ) |  |

DESCRIPTION: This API gets the current Mosaic topology.

SUPPORTED OS: Windows XP

Since
Release: 177
Parameters
[out] | pMosaicTopo | The current Mosaic topology
[out] | pEnabled | TRUE if returned topology is currently enabled, else FALSE
Return values
NVAPI_OK | Call succeeded
NVAPI_INVALID_ARGUMENT | One or more arguments are invalid
NVAPI_NVIDIA_DEVICE_NOT_FOUND | No NVIDIA GPU driving a display was found
NVAPI_NOT_SUPPORTED | Mosaic is not supported with GPUs on this system.
NVAPI_NO_ACTIVE_SLI_TOPOLOGY | SLI is not enabled, yet needs to be, in order for this function to succeed.

◆ NvAPI_GetSupportedMosaicTopologies()

NVAPI_INTERFACE NvAPI_GetSupportedMosaicTopologies ( NV_MOSAIC_SUPPORTED_TOPOLOGIES * pMosaicTopos )

DESCRIPTION: This API returns all valid Mosaic topologies.

SUPPORTED OS: Windows XP

Since
Release: 177
Parameters
[out] pMosaicTopos An array of valid Mosaic topologies.
Return values
NVAPI_OK | Call succeeded; 1 or more topologies were returned
NVAPI_INVALID_ARGUMENT | One or more arguments are invalid
NVAPI_MIXED_TARGET_TYPES | Mosaic topology is only possible with all targets of the same NV_GPU_OUTPUT_TYPE.
NVAPI_NVIDIA_DEVICE_NOT_FOUND | No NVIDIA GPU driving a display was found
NVAPI_NOT_SUPPORTED | Mosaic is not supported with GPUs on this system.
NVAPI_NO_ACTIVE_SLI_TOPOLOGY | SLI is not enabled, yet needs to be, in order for this function to succeed.

◆ NvAPI_Mosaic_EnableCurrentTopo()

NVAPI_INTERFACE NvAPI_Mosaic_EnableCurrentTopo ( NvU32 enable )

DESCRIPTION: This API enables or disables the current Mosaic topology based on the setting of the incoming 'enable' parameter.

An "enable" setting enables the current (previously set) Mosaic topology. Note that when the current Mosaic topology is retrieved, it must have an isPossible value of 1 or an error will occur.

A "disable" setting disables the current Mosaic topology. The topology information will persist, even across reboots. To re-enable the Mosaic topology, call this function again with the enable parameter set to 1.

SUPPORTED OS: Windows 7 and higher

Since
Release: 185
Parameters
[in] enable 1 to enable the current Mosaic topo, 0 to disable it.
Return values
NVAPI_OK | The Mosaic topo was enabled/disabled.
NVAPI_NOT_SUPPORTED | Mosaic is not supported with the existing hardware.
NVAPI_INVALID_ARGUMENT | One or more arguments passed in are invalid.
NVAPI_TOPO_NOT_POSSIBLE | The current topology is not currently possible.
NVAPI_MODE_CHANGE_FAILED | There was an error changing the display mode.
NVAPI_ERROR | Miscellaneous error occurred.

◆ NvAPI_Mosaic_EnumDisplayGrids()

NVAPI_INTERFACE NvAPI_Mosaic_EnumDisplayGrids | ( | __inout_ecount_part_opt *, *pGridCount NV_MOSAIC_GRID_TOPO * | pGridTopologies,
 |  | __inout NvU32 * | pGridCount
 | ) |  |

SUPPORTED OS: Windows 7 and higher DESCRIPTION: Enumerates the current active grid topologies. This includes Mosaic, IG, and Panoramic topologies, as well as single displays.

If pGridTopologies is NULL, then pGridCount will be set to the number of active grid topologies.

If pGridTopologies is not NULL, then pGridCount contains the maximum number of grid topologies to return. On return, pGridCount will be set to the number of grid topologies that were returned.

Parameters
[out] | pGridTopologies | The list of active grid topologies.
[in,out] | pGridCount | A pointer to the number of grid topologies returned.
Return values
NVAPI_OK | Capabilties have been returned.
NVAPI_END_ENUMERATION | There are no more topologies to return.
NVAPI_INVALID_ARGUMENT | One or more args passed in are invalid.
NVAPI_API_NOT_INTIALIZED | The NvAPI API needs to be initialized first
NVAPI_NO_IMPLEMENTATION | This entrypoint not available
NVAPI_ERROR | Miscellaneous error occurred

◆ NvAPI_Mosaic_GetCurrentTopo()

NVAPI_INTERFACE NvAPI_Mosaic_GetCurrentTopo | ( | NV_MOSAIC_TOPO_BRIEF * | pTopoBrief,
 |  | NV_MOSAIC_DISPLAY_SETTING * | pDisplaySetting,
 |  | NvS32 * | pOverlapX,
 |  | NvS32 * | pOverlapY
 | ) |  |

DESCRIPTION: This API returns information for the current Mosaic topology. This includes topology, display settings, and overlap values.

You can call NvAPI_Mosaic_GetTopoGroup() with the topology if you require more information.

If there isn't a current topology, then pTopoBrief->topo will be NV_MOSAIC_TOPO_NONE.

SUPPORTED OS: Windows 7 and higher

Since
Release: 185
Parameters
[out] | pTopoBrief | The current Mosaic topology
[out] | pDisplaySetting | The current per-display settings
[out] | pOverlapX | The pixel overlap between horizontal displays
[out] | pOverlapY | The pixel overlap between vertical displays
Return values
NVAPI_OK | Success getting current info.
NVAPI_NOT_SUPPORTED | Mosaic is not supported with the existing hardware.
NVAPI_INVALID_ARGUMENT | One or more argumentss passed in are invalid.
NVAPI_API_NOT_INTIALIZED | The NvAPI API needs to be initialized first.
NVAPI_NO_IMPLEMENTATION | This entry point not available.
NVAPI_ERROR | Miscellaneous error occurred.

◆ NvAPI_Mosaic_GetDisplayViewportsByResolution()

NVAPI_INTERFACE NvAPI_Mosaic_GetDisplayViewportsByResolution | ( | NvU32 | displayId,
 |  | NvU32 | srcWidth,
 |  | NvU32 | srcHeight,
 |  | NV_RECT | viewports[NV_MOSAIC_MAX_DISPLAYS],
 |  | NvU8 * | bezelCorrected
 | ) |  |

DESCRIPTION: This API returns the viewports that would be applied on the requested display.

Parameters
[in] | displayId | Display ID of a single display in the active mosaic topology to query.
[in] | srcWidth | Width of full display topology. If both width and height are 0, the current resolution is used.
[in] | srcHeight | Height of full display topology. If both width and height are 0, the current resolution is used.
[out] viewports Array of NV_RECT viewports. SUPPORTED OS: Windows 7 and higher
                             If the requested resolution is a single-wide
                             resolution, only viewports[0] will
                             contain the viewport details, regardless
                             of which display is driving the display.
[out] | bezelCorrected | Returns 1 if the requested resolution is bezel corrected. May be NULL.
Return values
NVAPI_OK | Capabilties have been returned.
NVAPI_INVALID_ARGUMENT | One or more args passed in are invalid.
NVAPI_API_NOT_INTIALIZED | The NvAPI API needs to be initialized first
NVAPI_MOSAIC_NOT_ACTIVE | The display does not belong to an active Mosaic Topology
NVAPI_NO_IMPLEMENTATION | This entrypoint not available
NVAPI_ERROR | Miscellaneous error occurred

◆ NvAPI_Mosaic_GetOverlapLimits()

NVAPI_INTERFACE NvAPI_Mosaic_GetOverlapLimits | ( | NV_MOSAIC_TOPO_BRIEF * | pTopoBrief,
 |  | NV_MOSAIC_DISPLAY_SETTING * | pDisplaySetting,
 |  | NvS32 * | pMinOverlapX,
 |  | NvS32 * | pMaxOverlapX,
 |  | NvS32 * | pMinOverlapY,
 |  | NvS32 * | pMaxOverlapY
 | ) |  |

DESCRIPTION: This API returns the X and Y overlap limits required if the given Mosaic topology and display settings are to be used.

SUPPORTED OS: Windows 7 and higher

Since
Release: 185
Parameters
[in] | pTopoBrief | The topology for getting limits This must be one of the topo briefs returned from NvAPI_Mosaic_GetSupportedTopoInfo().
[in] | pDisplaySetting | The display settings for getting the limits. This must be one of the settings returned from NvAPI_Mosaic_GetSupportedTopoInfo().
[out] | pMinOverlapX | X overlap minimum
[out] | pMaxOverlapX | X overlap maximum
[out] | pMinOverlapY | Y overlap minimum
[out] | pMaxOverlapY | Y overlap maximum
Return values
NVAPI_OK | Details were retrieved successfully.
NVAPI_NOT_SUPPORTED | Mosaic is not supported with the existing hardware.
NVAPI_INVALID_ARGUMENT | One or more argumentss passed in are invalid.
NVAPI_API_NOT_INTIALIZED | The NvAPI API needs to be initialized first.
NVAPI_NO_IMPLEMENTATION | This entrypoint not available.
NVAPI_INCOMPATIBLE_STRUCT_VERSION | The version of the structure passed in is not compatible with this entry point.
NVAPI_ERROR | Miscellaneous error occurred.

◆ NvAPI_Mosaic_GetSupportedTopoInfo()

NVAPI_INTERFACE NvAPI_Mosaic_GetSupportedTopoInfo | ( | NV_MOSAIC_SUPPORTED_TOPO_INFO * | pSupportedTopoInfo,
 |  | NV_MOSAIC_TOPO_TYPE | type
 | ) |  |

DESCRIPTION: This API returns information on the topologies and display resolutions supported by Mosaic mode.

NOTE: Not all topologies returned can be set immediately. See 'OUT' Notes below.

Once you get the list of supported topologies, you can call NvAPI_Mosaic_GetTopoGroup() with one of the Mosaic topologies if you need more information about it.

'IN' Notes: pSupportedTopoInfo->version must be set before calling this function. If the specified version is not supported by this implementation, an error will be returned (NVAPI_INCOMPATIBLE_STRUCT_VERSION).

'OUT' Notes: Some of the topologies returned might not be valid for one reason or another. It could be due to mismatched or missing displays. It could also be because the required number of GPUs is not found. At a high level, you can see if the topology is valid and can be enabled by looking at the pSupportedTopoInfo->topoBriefs[xxx].isPossible flag. If this is true, the topology can be enabled. If it is false, you can find out why it cannot be enabled by getting the details of the topology via NvAPI_Mosaic_GetTopoGroup(). From there, look at the validityMask of the individual topologies. The bits can be tested against the NV_MOSAIC_TOPO_VALIDITY_* bits.

It is possible for this function to return NVAPI_OK with no topologies listed in the return structure. If this is the case, it means that the current hardware DOES support Mosaic, but with the given configuration no valid topologies were found. This most likely means that SLI was not enabled for the hardware. Once enabled, you should see valid topologies returned from this function.

SUPPORTED OS: Windows 7 and higher

Since
Release: 185
Parameters
[in,out] | pSupportedTopoInfo | Information about what topologies and display resolutions are supported for Mosaic.
[in] | type | The type of topologies the caller is interested in getting. See NV_MOSAIC_TOPO_TYPE for possible values.
Return values
NVAPI_OK | No errors in returning supported topologies.
NVAPI_NOT_SUPPORTED | Mosaic is not supported with the existing hardware.
NVAPI_INVALID_ARGUMENT | One or more arguments passed in are invalid.
NVAPI_API_NOT_INTIALIZED | The NvAPI API needs to be initialized first.
NVAPI_NO_IMPLEMENTATION | This entrypoint not available.
NVAPI_INCOMPATIBLE_STRUCT_VERSION | The version of the structure passed in is not
NVAPI_ERROR | Miscellaneous error occurred.

◆ NvAPI_Mosaic_GetTopoGroup()

NVAPI_INTERFACE NvAPI_Mosaic_GetTopoGroup | ( | NV_MOSAIC_TOPO_BRIEF * | pTopoBrief,
 |  | NV_MOSAIC_TOPO_GROUP * | pTopoGroup
 | ) |  |

DESCRIPTION: This API returns a structure filled with the details of the specified Mosaic topology.

If the pTopoBrief passed in matches the current topology, then information in the brief and group structures will reflect what is current. Thus the brief would have the current 'enable' status, and the group would have the current overlap values. If there is no match, then the returned brief has an 'enable' status of FALSE (since it is obviously not enabled), and the overlap values will be 0.

'IN' Notes: pTopoGroup->version must be set before calling this function. If the specified version is not supported by this implementation, an error will be returned (NVAPI_INCOMPATIBLE_STRUCT_VERSION).

SUPPORTED OS: Windows 7 and higher

Since
Release: 185
Parameters
[in] | pTopoBrief | The topology for getting the details This must be one of the topology briefs returned from NvAPI_Mosaic_GetSupportedTopoInfo().
[in,out] | pTopoGroup | The topology details matching the brief
Return values
NVAPI_OK | Details were retrieved successfully.
NVAPI_NOT_SUPPORTED | Mosaic is not supported with the existing hardware.
NVAPI_INVALID_ARGUMENT | One or more argumentss passed in are invalid.
NVAPI_API_NOT_INTIALIZED | The NvAPI API needs to be initialized first.
NVAPI_NO_IMPLEMENTATION | This entrypoint not available.
NVAPI_INCOMPATIBLE_STRUCT_VERSION | The version of the structure passed in is not
NVAPI_ERROR | Miscellaneous error occurred.

◆ NvAPI_Mosaic_SetCurrentTopo()

NVAPI_INTERFACE NvAPI_Mosaic_SetCurrentTopo | ( | NV_MOSAIC_TOPO_BRIEF * | pTopoBrief,
 |  | NV_MOSAIC_DISPLAY_SETTING * | pDisplaySetting,
 |  | NvS32 | overlapX,
 |  | NvS32 | overlapY,
 |  | NvU32 | enable
 | ) |  |

DESCRIPTION: This API sets the Mosaic topology and performs a mode switch using the given display settings.

If NVAPI_OK is returned, the current Mosaic topology was set correctly. Any other status returned means the topology was not set, and remains what it was before this function was called.

SUPPORTED OS: Windows 7 and higher

Since
Release: 185
Parameters
[in] | pTopoBrief | The topology to set. This must be one of the topologies returned from NvAPI_Mosaic_GetSupportedTopoInfo(), and it must have an isPossible value of 1.
[in] | pDisplaySetting | The per display settings to be used in the Mosaic mode. This must be one of the settings returned from NvAPI_Mosaic_GetSupportedTopoInfo().
[in] | overlapX | The pixel overlap to use between horizontal displays (use positive a number for overlap, or a negative number to create a gap.) If the overlap is out of bounds for what is possible given the topo and display setting, the overlap will be clamped.
[in] | overlapY | The pixel overlap to use between vertical displays (use positive a number for overlap, or a negative number to create a gap.) If the overlap is out of bounds for what is possible given the topo and display setting, the overlap will be clamped.
[in] enable If 1, the topology being set will also be enabled, meaning that the mode set will occur.
If 0, you don't want to be in Mosaic mode right now, but want to set the current Mosaic topology so you can enable it later with NvAPI_Mosaic_EnableCurrentTopo().
Return values
NVAPI_OK | The Mosaic topology was set.
NVAPI_NOT_SUPPORTED | Mosaic is not supported with the existing hardware.
NVAPI_INVALID_ARGUMENT | One or more argumentss passed in are invalid.
NVAPI_TOPO_NOT_POSSIBLE | The topology passed in is not currently possible.
NVAPI_API_NOT_INTIALIZED | The NvAPI API needs to be initialized first.
NVAPI_NO_IMPLEMENTATION | This entrypoint not available.
NVAPI_INCOMPATIBLE_STRUCT_VERSION | The version of the structure passed in is not compatible with this entrypoint.
NVAPI_MODE_CHANGE_FAILED | There was an error changing the display mode.
NVAPI_ERROR | Miscellaneous error occurred.

◆ NvAPI_Mosaic_SetDisplayGrids()

NVAPI_INTERFACE NvAPI_Mosaic_SetDisplayGrids | ( | __in_ecount(gridCount) NV_MOSAIC_GRID_TOPO * | pGridTopologies,
 |  | __in NvU32 | gridCount,
 |  | __in NvU32 | setTopoFlags
 | ) |  |

DESCRIPTION: Sets a new display topology, replacing any existing topologies that use the same displays.

This function will look for an SLI configuration that will allow the display topology to work.

To revert to a single display, specify that display as a 1x1 grid.

SUPPORTED OS: Windows 7 and higher

Parameters
[in] | pGridTopologies | The topology details to set.
[in] | gridCount | The number of elements in the pGridTopologies array.
[in] | setTopoFlags | Zero or more of the NVAPI_MOSAIC_SETDISPLAYTOPO_FLAG_* flags.
Return values
NVAPI_OK | Capabilities have been returned.
NVAPI_INVALID_ARGUMENT | One or more args passed in are invalid.
NVAPI_API_NOT_INTIALIZED | The NvAPI API needs to be initialized first
NVAPI_NO_IMPLEMENTATION | This entrypoint not available
NVAPI_NO_ACTIVE_SLI_TOPOLOGY | No matching GPU topologies could be found.
NVAPI_TOPO_NOT_POSSIBLE | One or more of the display grids are not valid.
NVAPI_ERROR | Miscellaneous error occurred

◆ NvAPI_Mosaic_ValidateDisplayGrids()

NVAPI_INTERFACE NvAPI_Mosaic_ValidateDisplayGrids | ( | __in NvU32 | setTopoFlags,
 |  | __in_ecount(gridCount) NV_MOSAIC_GRID_TOPO * | pGridTopologies,
 |  | __inout_ecount_full(gridCount) NV_MOSAIC_DISPLAY_TOPO_STATUS * | pTopoStatus,
 |  | __in NvU32 | gridCount
 | ) |  |

DESCRIPTION: Determines if a list of grid topologies is valid. It will choose an SLI configuration in the same way that NvAPI_Mosaic_SetDisplayGrids() does.

On return, each element in the pTopoStatus array will contain any errors or warnings about each grid topology. If any error flags are set, then the topology is not valid. If any warning flags are set, then the topology is valid, but sub-optimal.

If the ALLOW_INVALID flag is set, then it will continue to validate the grids even if no SLI configuration will allow all of the grids. In this case, a grid grid with no matching GPU topology will have the error flags NO_GPU_TOPOLOGY or NOT_SUPPORTED set.

If the ALLOW_INVALID flag is not set and no matching SLI configuration is found, then it will skip the rest of the validation and return NVAPI_NO_ACTIVE_SLI_TOPOLOGY.

SUPPORTED OS: Windows 7 and higher

Parameters
[in] | setTopoFlags | Zero or more of the NVAPI_MOSAIC_SETDISPLAYTOPO_FLAG_* flags.
[in] | pGridTopologies | The array of grid topologies to verify.
[in,out] | pTopoStatus | The array of problems and warnings with each grid topology.
[in] | gridCount | The number of elements in the pGridTopologies and pTopoStatus arrays.
Return values
NVAPI_OK | Capabilities have been returned.
NVAPI_INVALID_ARGUMENT | One or more args passed in are invalid.
NVAPI_API_NOT_INTIALIZED | The NvAPI API needs to be initialized first
NVAPI_NO_IMPLEMENTATION | This entrypoint not available
NVAPI_NO_ACTIVE_SLI_TOPOLOGY | No matching GPU topologies could be found.
NVAPI_ERROR | Miscellaneous error occurred

◆ NvAPI_SetCurrentMosaicTopology()

NVAPI_INTERFACE NvAPI_SetCurrentMosaicTopology ( NV_MOSAIC_TOPOLOGY * pMosaicTopo )

DESCRIPTION: This API sets the Mosaic topology, and enables it so that the Mosaic display settings are enumerated upon request.

SUPPORTED OS: Windows XP

Since
Release: 177
Parameters
[in] pMosaicTopo A valid Mosaic topology
Return values
NVAPI_OK | Call succeeded
NVAPI_INVALID_ARGUMENT | One or more arguments are invalid
NVAPI_NVIDIA_DEVICE_NOT_FOUND | No NVIDIA GPU driving a display was found
NVAPI_NOT_SUPPORTED | Mosaic is not supported with GPUs on this system.
NVAPI_NO_ACTIVE_SLI_TOPOLOGY | SLI is not enabled, yet needs to be, in order for this function to succeed.


Data Structures | Macros | Typedefs | Enumerations | Functions
DirectX Video Control
DirectX APIs

Data Structures

struct _NV_DX_VIDEO_STEREO_INFO

Macros

#define | NV_STEREO_VIDEO_FORMAT_DEFINE
#define | NV_DX_VIDEO_STEREO_INFO_VER MAKE_NVAPI_VERSION(NV_DX_VIDEO_STEREO_INFO,1)

Typedefs

typedef enum _NV_STEREO_VIDEO_FORMAT | NV_STEREO_VIDEO_FORMAT
typedef struct _NV_DX_VIDEO_STEREO_INFO | NV_DX_VIDEO_STEREO_INFO

Enumerations

enum _NV_STEREO_VIDEO_FORMAT {
NV_STEREO_VIDEO_FORMAT_NOT_STEREO = 0 , NV_STEREO_VIDEO_FORMAT_SIDE_BY_SIDE_LR = 1 , NV_STEREO_VIDEO_FORMAT_SIDE_BY_SIDE_RL = 2 , NV_STEREO_VIDEO_FORMAT_TOP_BOTTOM_LR = 3 ,
NV_STEREO_VIDEO_FORMAT_TOP_BOTTOM_RL = 4 , NV_STEREO_VIDEO_FORMAT_ROW_INTERLEAVE_LR = 5 , NV_STEREO_VIDEO_FORMAT_ROW_INTERLEAVE_RL = 6 , NV_STEREO_VIDEO_FORMAT_TWO_FRAMES_LR = 7 ,
NV_STEREO_VIDEO_FORMAT_MONO_PLUS_OFFSET = 8 , NV_STEREO_VIDEO_FORMAT_LAST = 9
}

Functions

NVAPI_INTERFACE NvAPI_D3D9_VideoSetStereoInfo (IDirect3DDevice9 *pDev, NV_DX_VIDEO_STEREO_INFO *pStereoInfo)

Detailed Description

See also vidcontrol

SUPPORTED OS: Windows 7 and higher

Macro Definition Documentation

◆ NV_DX_VIDEO_STEREO_INFO_VER

#define NV_DX_VIDEO_STEREO_INFO_VER MAKE_NVAPI_VERSION(NV_DX_VIDEO_STEREO_INFO,1)

Macro for constructing the version field of NV_DX_VIDEO_STEREO_INFO.

◆ NV_STEREO_VIDEO_FORMAT_DEFINE

#define NV_STEREO_VIDEO_FORMAT_DEFINE

Typedef Documentation

◆ NV_DX_VIDEO_STEREO_INFO

typedef struct _NV_DX_VIDEO_STEREO_INFO NV_DX_VIDEO_STEREO_INFO

◆ NV_STEREO_VIDEO_FORMAT

typedef enum _NV_STEREO_VIDEO_FORMAT NV_STEREO_VIDEO_FORMAT

Enumeration Type Documentation

◆ _NV_STEREO_VIDEO_FORMAT

enum _NV_STEREO_VIDEO_FORMAT
Enumerator
NV_STEREO_VIDEO_FORMAT_NOT_STEREO
NV_STEREO_VIDEO_FORMAT_SIDE_BY_SIDE_LR
NV_STEREO_VIDEO_FORMAT_SIDE_BY_SIDE_RL
NV_STEREO_VIDEO_FORMAT_TOP_BOTTOM_LR
NV_STEREO_VIDEO_FORMAT_TOP_BOTTOM_RL
NV_STEREO_VIDEO_FORMAT_ROW_INTERLEAVE_LR
NV_STEREO_VIDEO_FORMAT_ROW_INTERLEAVE_RL
NV_STEREO_VIDEO_FORMAT_TWO_FRAMES_LR
NV_STEREO_VIDEO_FORMAT_MONO_PLUS_OFFSET
NV_STEREO_VIDEO_FORMAT_LAST

Function Documentation

◆ NvAPI_D3D9_VideoSetStereoInfo()

NvAPI_D3D9_VideoSetStereoInfo | ( | IDirect3DDevice9 * | pDev,
 |  | NV_DX_VIDEO_STEREO_INFO * | pStereoInfo
 | ) |  |
DESCRIPTION: This api specifies the stereo format of a surface, so that the
surface could be used for stereo video processing or compositing.
In particular, this api could be used to link the left and right
views of a decoded picture.
\since Release: 313
INPUT: pDev - The device on which the stereo surface will be used
pStereoInfo - The stereo format of the surface
RETURN STATUS: an int which could be an NvAPI status or DX HRESULT code


Data Structures | Macros | Typedefs | Enumerations | Functions
Quadro G-Sync APIs

Data Structures

struct _NV_GSYNC_STATUS_PARAMS_V1

Macros

#define | NV_GSYNC_CAPABILITIES_VER1 MAKE_NVAPI_VERSION(NV_GSYNC_CAPABILITIES_V1,1)
#define | NVAPI_MAX_RJ45_PER_GSYNC 2
#define | NV_GSYNC_STATUS_PARAMS_VER1 MAKE_NVAPI_VERSION(NV_GSYNC_STATUS_PARAMS_V1,1)

Typedefs

typedef enum _NVAPI_GSYNC_POLARITY | NVAPI_GSYNC_POLARITY
typedef struct _NV_GSYNC_STATUS_PARAMS_V1 | NV_GSYNC_STATUS_PARAMS_V1

Enumerations

enum _NVAPI_GSYNC_POLARITY { NVAPI_GSYNC_POLARITY_RISING_EDGE = 0 , NVAPI_GSYNC_POLARITY_FALLING_EDGE = 1 , NVAPI_GSYNC_POLARITY_BOTH_EDGES = 2 }

Functions

NVAPI_INTERFACE | NvAPI_GSync_EnumSyncDevices (__out NvGSyncDeviceHandle nvGSyncHandles[NVAPI_MAX_GSYNC_DEVICES], __out NvU32 *gsyncCount)
NVAPI_INTERFACE | NvAPI_GSync_QueryCapabilities (__in NvGSyncDeviceHandle hNvGSyncDevice, __inout NV_GSYNC_CAPABILITIES *pNvGSyncCapabilities)
NVAPI_INTERFACE | NvAPI_GSync_GetTopology (__in NvGSyncDeviceHandle hNvGSyncDevice, __inout_opt NvU32 *gsyncGpuCount, __inout_ecount_part_opt(*gsyncGpuCount, *gsyncGpuCount) NV_GSYNC_GPU *gsyncGPUs, __inout_opt NvU32 *gsyncDisplayCount, __inout_ecount_part_opt(*gsyncDisplayCount, *gsyncDisplayCount) NV_GSYNC_DISPLAY *gsyncDisplays)
NVAPI_INTERFACE | NvAPI_GSync_SetSyncStateSettings (__in NvU32 gsyncDisplayCount, __in_ecount(gsyncDisplayCount) NV_GSYNC_DISPLAY *pGsyncDisplays, __in NvU32 flags)
NVAPI_INTERFACE | NvAPI_GSync_GetControlParameters (__in NvGSyncDeviceHandle hNvGSyncDevice, __inout NV_GSYNC_CONTROL_PARAMS *pGsyncControls)
NVAPI_INTERFACE | NvAPI_GSync_SetControlParameters (__in NvGSyncDeviceHandle hNvGSyncDevice, __inout NV_GSYNC_CONTROL_PARAMS *pGsyncControls)
NVAPI_INTERFACE | NvAPI_GSync_AdjustSyncDelay (__in NvGSyncDeviceHandle hNvGSyncDevice, __in NVAPI_GSYNC_DELAY_TYPE delayType, __inout NV_GSYNC_DELAY *pGsyncDelay, __out_opt NvU32 *syncSteps)
NVAPI_INTERFACE | NvAPI_GSync_GetSyncStatus (__in NvGSyncDeviceHandle hNvGSyncDevice, __in NvPhysicalGpuHandle hPhysicalGpu, __inout NV_GSYNC_STATUS *status)
NVAPI_INTERFACE | NvAPI_GSync_GetStatusParameters (NvGSyncDeviceHandle hNvGSyncDevice, NV_GSYNC_STATUS_PARAMS *pStatusParams)

Detailed Description

These APIs control NVIDIA Quadro G-Sync.

Macro Definition Documentation

◆ NV_GSYNC_CAPABILITIES_VER1

#define NV_GSYNC_CAPABILITIES_VER1 MAKE_NVAPI_VERSION(NV_GSYNC_CAPABILITIES_V1,1)

Macro for constructing the version field of NV_GSYNC_CAPABILITIES.

◆ NV_GSYNC_STATUS_PARAMS_VER1

#define NV_GSYNC_STATUS_PARAMS_VER1 MAKE_NVAPI_VERSION(NV_GSYNC_STATUS_PARAMS_V1,1)

Macro for constructing the version field of NV_GSYNC_STATUS_PARAMS

◆ NVAPI_MAX_RJ45_PER_GSYNC

#define NVAPI_MAX_RJ45_PER_GSYNC 2

Typedef Documentation

◆ NV_GSYNC_STATUS_PARAMS_V1

typedef struct _NV_GSYNC_STATUS_PARAMS_V1 NV_GSYNC_STATUS_PARAMS_V1

Used in NvAPI_GSync_GetStatusParameters().

◆ NVAPI_GSYNC_POLARITY

typedef enum _NVAPI_GSYNC_POLARITY NVAPI_GSYNC_POLARITY

Source signal edge to be used for output pulse. See NV_GSYNC_CONTROL_PARAMS.

Enumeration Type Documentation

◆ _NVAPI_GSYNC_POLARITY

enum _NVAPI_GSYNC_POLARITY

Source signal edge to be used for output pulse. See NV_GSYNC_CONTROL_PARAMS.

Enumerator
NVAPI_GSYNC_POLARITY_RISING_EDGE
NVAPI_GSYNC_POLARITY_FALLING_EDGE
NVAPI_GSYNC_POLARITY_BOTH_EDGES

Function Documentation

◆ NvAPI_GSync_AdjustSyncDelay()

NVAPI_INTERFACE NvAPI_GSync_AdjustSyncDelay | ( | __in NvGSyncDeviceHandle | hNvGSyncDevice,
 |  | __in NVAPI_GSYNC_DELAY_TYPE | delayType,
 |  | __inout NV_GSYNC_DELAY * | pGsyncDelay,
 |  | __out_opt NvU32 * | syncSteps
 | ) |  |

DESCRIPTION: This API adjusts the skew and startDelay to the closest possible values. Use this API before calling NvAPI_GSync_SetControlParameters for skew or startDelay.

SUPPORTED OS: Windows 7 and higher

Since
Release: 319
Parameters
[in] | hNvGSyncDevice- | The caller provides the handle of the Sync device for which to get parameters
[in] | delayType- | Specifies whether the delay is syncSkew or startupDelay.
[in,out] | *pGsyncDelay- | The caller provides NV_GSYNC_DELAY. skew and startDelay will be adjusted and updated to the closest values.
[out] | *syncSteps- | This parameter is optional. It returns the sync delay in unit steps. If 0, it means either the NV_GSYNC_DELAY::numPixels is less than NV_GSYNC_DELAY::minPixels or NV_GSYNC_DELAY::numOfLines exceeds the NV_GSYNC_DELAY::maxLines.
Returns
This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.

◆ NvAPI_GSync_EnumSyncDevices()

NVAPI_INTERFACE NvAPI_GSync_EnumSyncDevices | ( | __out NvGSyncDeviceHandle | nvGSyncHandles[NVAPI_MAX_GSYNC_DEVICES],
 |  | __out NvU32 * | gsyncCount
 | ) |  |

DESCRIPTION: This API returns an array of Sync device handles. A Sync device handle represents a single Sync device on the system.

SUPPORTED OS: Windows 7 and higher

Since
Release: 313
Parameters
[out] | nvGSyncHandles- | The caller provides an array of handles, which must contain at least NVAPI_MAX_GSYNC_DEVICES elements. The API will zero out the entire array and then fill in one or more handles. If an error occurs, the array is invalid.
[out] | *gsyncCount- | The caller provides the storage space. NvAPI_GSync_EnumSyncDevices sets *gsyncCount to indicate how many of the elements in the nvGSyncHandles[] array are valid. If an error occurs, *gsyncCount will be set to zero.
Returns
This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.
Return values
NVAPI_INVALID_ARGUMENT | nvGSyncHandles or gsyncCount is NULL.
NVAPI_NVIDIA_DEVICE_NOT_FOUND | The queried Graphics system does not have any Sync Device.

◆ NvAPI_GSync_GetControlParameters()

NVAPI_INTERFACE NvAPI_GSync_GetControlParameters | ( | __in NvGSyncDeviceHandle | hNvGSyncDevice,
 |  | __inout NV_GSYNC_CONTROL_PARAMS * | pGsyncControls
 | ) |  |

DESCRIPTION: This API queries for sync control parameters as defined in NV_GSYNC_CONTROL_PARAMS.

SUPPORTED OS: Windows 7 and higher

Since
Release: 313
Parameters
[in] | hNvGSyncDevice- | The caller provides the handle of the Sync device for which to get parameters
[in,out] | *pGsyncControls- | The caller provides the storage space. NvAPI_GSync_GetControlParameters() populates *pGsyncControls with values.
Returns
This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.
Return values
NVAPI_INVALID_ARGUMENT | hNvGSyncDevice is NULL.
NVAPI_NVIDIA_DEVICE_NOT_FOUND | The queried Graphics system does not have any Sync Device.

◆ NvAPI_GSync_GetStatusParameters()

NVAPI_INTERFACE NvAPI_GSync_GetStatusParameters | ( | NvGSyncDeviceHandle | hNvGSyncDevice,
 |  | NV_GSYNC_STATUS_PARAMS * | pStatusParams
 | ) |  |

DESCRIPTION: This API queries for sync status parameters as defined in NV_GSYNC_STATUS_PARAMS.

SUPPORTED OS: Windows 7 and higher

Since
Release: 313
Parameters
[in] | hNvGSyncDevice | The caller provides the handle of the GSync device for which to get parameters
[out] | *pStatusParams | The caller provides the storage space. NvAPI_GSync_GetStatusParameters populates *pStatusParams with values.
Returns
This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.
Return values
NVAPI_INVALID_ARGUMENT | hNvGSyncDevice is NULL / pStatusParams is NULL.
NVAPI_NVIDIA_DEVICE_NOT_FOUND | The queried Graphics system does not have any GSync Device.

◆ NvAPI_GSync_GetSyncStatus()

NVAPI_INTERFACE NvAPI_GSync_GetSyncStatus | ( | __in NvGSyncDeviceHandle | hNvGSyncDevice,
 |  | __in NvPhysicalGpuHandle | hPhysicalGpu,
 |  | __inout NV_GSYNC_STATUS * | status
 | ) |  |

DESCRIPTION: This API queries the sync status of a GPU - timing, stereosync and sync signal availability.

SUPPORTED OS: Windows 7 and higher

Since
Release: 313
Parameters
[in] | hNvGSyncDevice- | Handle of the Sync device
[in] | hPhysicalGpu- | GPU to be queried for sync status.
[out] | *status- | The caller provides the storage space. NvAPI_GSync_GetSyncStatus() populates *status with values - timing, stereosync and signal availability. On error, *status is set to NULL.
Returns
This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.
Return values
NVAPI_INVALID_ARGUMENT | hNvGSyncDevice is NULL / SyncTarget is NULL.
NVAPI_NVIDIA_DEVICE_NOT_FOUND | The queried Graphics system does not have any G-Sync Device.

◆ NvAPI_GSync_GetTopology()

NVAPI_INTERFACE NvAPI_GSync_GetTopology | ( | __in NvGSyncDeviceHandle | hNvGSyncDevice,
 |  | __inout_opt NvU32 * | gsyncGpuCount,
 |  | __inout_ecount_part_opt *, *gsyncGpuCount NV_GSYNC_GPU * | gsyncGPUs,
 |  | __inout_opt NvU32 * | gsyncDisplayCount,
 |  | __inout_ecount_part_opt *, *gsyncDisplayCount NV_GSYNC_DISPLAY * | gsyncDisplays
 | ) |  |

DESCRIPTION: This API returns the topology for the specified Sync device.

SUPPORTED OS: Windows 7 and higher

Since
Release: 313
Parameters
[in] | hNvGSyncDevice- | The caller provides the handle for a Sync device for which the topology will be queried.
[in,out] | gsyncGpuCount- | It returns number of GPUs connected to Sync device
[in,out] | gsyncGPUs- | It returns info about GPUs connected to Sync device
[in,out] | gsyncDisplayCount- | It returns number of active displays that belongs to Sync device
[in,out] | gsyncDisplays- | It returns info about all active displays that belongs to Sync device

HOW TO USE: 1) make a call to get the number of GPUs connected OR displays synced through Sync device by passing the gsyncGPUs OR gsyncDisplays as NULL respectively. Both gsyncGpuCount and gsyncDisplayCount can be retrieved in same call by passing both gsyncGPUs and gsyncDisplays as NULL On call success: 2) Allocate memory based on gsyncGpuCount(for gsyncGPUs) and/or gsyncDisplayCount(for gsyncDisplays) then make a call to populate gsyncGPUs and/or gsyncDisplays respectively.

Returns
This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.
Return values
NVAPI_INVALID_ARGUMENT | hNvGSyncDevice is NULL.
NVAPI_NVIDIA_DEVICE_NOT_FOUND | The queried Graphics system does not have any Sync Device.
NVAPI_INSUFFICIENT_BUFFER | When the actual number of GPUs/displays in the topology exceed the number of elements allocated for SyncGPUs/SyncDisplays respectively.

◆ NvAPI_GSync_QueryCapabilities()

NVAPI_INTERFACE NvAPI_GSync_QueryCapabilities | ( | __in NvGSyncDeviceHandle | hNvGSyncDevice,
 |  | __inout NV_GSYNC_CAPABILITIES * | pNvGSyncCapabilities
 | ) |  |

DESCRIPTION: This API returns the capabilities of the Sync device.

SUPPORTED OS: Windows 7 and higher

Since
Release: 313
Parameters
[in] | hNvGSyncDevice- | The handle for a Sync device for which the capabilities will be queried.
[in,out] | *pNvGSyncCapabilities- | The caller provides the storage space. NvAPI_GSync_QueryCapabilities() sets *pNvGSyncCapabilities to the version and capabilities details of the Sync device If an error occurs, *pNvGSyncCapabilities will be set to NULL.
Returns
This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.
Return values
NVAPI_INVALID_ARGUMENT | hNvGSyncDevice is NULL.
NVAPI_NVIDIA_DEVICE_NOT_FOUND | The queried Graphics system does not have any Sync Device.

◆ NvAPI_GSync_SetControlParameters()

NVAPI_INTERFACE NvAPI_GSync_SetControlParameters | ( | __in NvGSyncDeviceHandle | hNvGSyncDevice,
 |  | __inout NV_GSYNC_CONTROL_PARAMS * | pGsyncControls
 | ) |  |

DESCRIPTION: This API sets control parameters as defined in NV_SYNC_CONTROL_PARAMS.

SUPPORTED OS: Windows 7 and higher

Since
Release: 313
Parameters
[in] | hNvGSyncDevice- | The caller provides the handle of the Sync device for which to get parameters
[in,out] | *pGsyncControls- | The caller provides NV_GSYNC_CONTROL_PARAMS. skew and startDelay will be updated to the applied values.
Returns
This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.
Return values
NVAPI_INVALID_ARGUMENT | hNvGSyncDevice is NULL.
NVAPI_NVIDIA_DEVICE_NOT_FOUND | The queried Graphics system does not have any Sync Device.
NVAPI_INVALID_USER_PRIVILEGE | The application will require Administrator privileges to access this API. The application can be elevated to a higher permission level by selecting "Run as Administrator".

◆ NvAPI_GSync_SetSyncStateSettings()

NVAPI_INTERFACE NvAPI_GSync_SetSyncStateSettings | ( | __in NvU32 | gsyncDisplayCount,
 |  | __in_ecount(gsyncDisplayCount) NV_GSYNC_DISPLAY * | pGsyncDisplays,
 |  | __in NvU32 | flags
 | ) |  |

DESCRIPTION: Sets a new sync state for the displays in system.

SUPPORTED OS: Windows 7 and higher

Since
Release: 313
Parameters
[in] | gsyncDisplayCount- | The number of displays in gsyncDisplays.
[in] | pGsyncDisplays- | The caller provides the structure containing all displays that need to be synchronized in the system. The displays that are not part of pGsyncDisplays, will be un-synchronized.
[in] | flags- | Reserved for future use.
Returns
This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.
Return values
NVAPI_INVALID_ARGUMENT | If the display topology or count not valid.
NVAPI_NVIDIA_DEVICE_NOT_FOUND | The queried Graphics system does not have any Sync Device.
NVAPI_INVALID_SYNC_TOPOLOGY | 1.If any mosaic grid is partial. 2.If timing(HVisible/VVisible/refreshRate) applied of any display is different. 3.If There is a across GPU mosaic grid in system and that is not a part of pGsyncDisplays.
NVAPI_INVALID_USER_PRIVILEGE | The application will require Administrator privileges to access this API. The application can be elevated to a higher permission level by selecting "Run as Administrator".


Modules
DirectX APIs

Modules

DirectX Interface
DirectX Video Control

Detailed Description

Privacy Policy | Manage My Privacy | Do Not Sell or Share My Data | Terms of Service | Accessibility | Corporate Policies | Product Security | Contact

Copyright © 2022-2024 NVIDIA Corporation


Data Fields
NV_D3D11_META_COMMAND_RESOURCE Struct Reference
DirectX APIs » DirectX Interface

#include <nvapi.h>

Data Fields

union {
NVDX_ObjectHandle NV_D3D11_META_COMMAND_RESOURCE::ResourceHandle
NvU64 NV_D3D11_META_COMMAND_RESOURCE::unused
};
NvU64 Offset

Detailed Description

Since
Release: 400
DESCRIPTION: Creates a MetaCommand object which can be used to execute optimized operations exposed by driver like convolutions.
\param [in] pDevice A pointer to D3D11 device.
\param [in] CommandId GUID of the operations to perform
\param [in] pCreationParametersData structure containing all creation parameters for the requested Metacommand
\param [in] CreationParametersDataSize size of parameter data structure
\param [out] ppMetaCommand A pointer to memory that receives the pointer to the created MetaCommand object.
SUPPORTED OS: Windows 10
\return This API can return any of the error codes enumerated in
#NvAPI_Status. If there are return error codes with specific
meaning for this API, they are listed below.
NVAPI_NOT_SUPPORTED - The requested Metacommand is not supported.
NVAPI_NOT_SUPPORTED
@ NVAPI_NOT_SUPPORTED
Requested feature is not supported in the selected GPU.
Definition nvapi_lite_common.h:279
The documentation for this struct was generated from the following file:


Data Fields
NV_D3D12_META_COMMAND_INITIALIZE_CONVOLUTION_EX_DESC Struct Reference
DirectX APIs » DirectX Interface

#include <nvapi.h>

Data Fields

D3D12_GPU_VIRTUAL_ADDRESS PersistentResource

Detailed Description

Since
Release: 400
DESCRIPTION: Creates a MetaCommand object which can be used to execute optimized operations exposed by driver like convolutions.
\param [in] pDevice A pointer to D3D12 device.
\param [in] CommandId GUID of the operations to perform
\param [in] NodeMask GPU mask for which metacommand is to be created. Set it to 0 for single GPU systems
\param [in] pCreationParametersData structure containing all creation parameters for the requested Metacommand
\param [in] CreationParametersDataSize size of parameter data structure
\param [out] ppMetaCommand A pointer to memory that receives the pointer to the created MetaCommand object.
SUPPORTED OS: Windows 10
\return This API can return any of the error codes enumerated in
#NvAPI_Status. If there are return error codes with specific
meaning for this API, they are listed below.
NVAPI_NOT_SUPPORTED - The requested Metacommand is not supported.
NVAPI_NOT_SUPPORTED
@ NVAPI_NOT_SUPPORTED
Requested feature is not supported in the selected GPU.
Definition nvapi_lite_common.h:279
The documentation for this struct was generated from the following file:


Data Fields
_NV_MULTIGPU_CAPS_V1 Struct Reference
DirectX APIs » DirectX Interface

#include <nvapi.h>

Data Fields

NvU32 multiGPUVersion
NvU32 reserved
NvU32 nTotalGPUs
NvU32 nSLIGPUs
NvU32 videoBridgePresent

Detailed Description

SUPPORTED OS: Windows 7 and higher DESCRIPTION: Request to get multi GPU extension caps.

Parameters
[in/out] pMultiGPUCaps Pointer to a structure returning multi GPU caps
Return values
NVAPI_OK | Call succeeded.
NVAPI_ERROR | Call failed.
The documentation for this struct was generated from the following file:


Data Fields
_NV_QUERY_SINGLE_PASS_STEREO_SUPPORT_PARAMS_V1 Struct Reference
DirectX APIs » DirectX Interface

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 bSinglePassStereoSupported

Detailed Description

SUPPORTED OS: Windows 7 and higher

Used to query the support of Single Pass Stereo HW feature <>

The documentation for this struct was generated from the following file:


Data Fields
_NV_QUERY_MULTIVIEW_SUPPORT_PARAMS_V1 Struct Reference
DirectX APIs » DirectX Interface

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 | bMultiViewSupported: 1
NvU32 | bSinglePassStereoSupported: 1
NvU32 | bSinglePassStereoXYZWSupported: 1
NvU32 | reserved: 29

Detailed Description

SUPPORTED OS: Windows 7 and higher

Used to query the support of MultiView HW feature <>

The documentation for this struct was generated from the following file:


Data Fields
_NV_MULTIVIEW_PARAMS_V1 Struct Reference
DirectX APIs » DirectX Interface

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 numViews
NvU32 renderTargetIndexOffset [NV_MULTIVIEW_MAX_SUPPORTED_VIEWS]
NvU8 independentViewportMaskEnable

Detailed Description

SUPPORTED OS: Windows 7 and higher

Used for setting the Mode for MultiView HW Feature. <>

The documentation for this struct was generated from the following file:


Data Fields
_NV_QUERY_MODIFIED_W_SUPPORT_PARAMS Struct Reference
DirectX APIs » DirectX Interface

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 bModifiedWSupported

Detailed Description

SUPPORTED OS: Windows 7 and higher

Used to query the support of Lens Matched Shading HW feature <>

The documentation for this struct was generated from the following file:


Data Fields
_NV_QUERY_LATELATCH_SUPPORT_PARAMS Struct Reference
DirectX APIs » DirectX Interface

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 bLateLatchSupported

Detailed Description

See NvAPI_D3D_QueryLateLatchSupport

The documentation for this struct was generated from the following file:


Data Fields
_NV_D3D1x_GRAPHICS_CAPS_V1 Struct Reference
DirectX APIs » DirectX Interface

#include <nvapi.h>

Data Fields

NvU32 | bExclusiveScissorRectsSupported: 1
NvU32 | bVariablePixelRateShadingSupported: 1
NvU32 | reservedBits: 30
NvU32 | reserved [7]

Detailed Description

See NvAPI_D3D1x_GetGraphicsCapabilities

The documentation for this struct was generated from the following file:


Data Fields
_NV_D3D12_GRAPHICS_CAPS_V1 Struct Reference
DirectX APIs » DirectX Interface

#include <nvapi.h>

Data Fields

NvU32 | bExclusiveScissorRectsSupported: 1
NvU32 | bVariablePixelRateShadingSupported: 1
NvU32 | bFastUAVClearSupported: 1
NvU32 | reservedBits: 29
NvU16 majorSMVersion
NvU16 minorSMVersion
NvU32 | reserved [6]

Detailed Description

See NvAPI_D3D12_GetGraphicsCapabilities

The documentation for this struct was generated from the following file:


Data Fields
_NV_D3D11_EXCLUSIVE_SCISSOR_RECT_DESC_V1 Struct Reference
DirectX APIs » DirectX Interface

#include <nvapi.h>

Data Fields

bool | enableExclusiveScissorRect
D3D11_RECT | scissorRect

Detailed Description

See NvAPI_D3D11_RSSetExclusiveScissorRects

The documentation for this struct was generated from the following file:


Data Structures | Data Fields
_NV_PIXEL_SRSO_1x2 Struct Reference
DirectX APIs » DirectX Interface

#include <nvapi.h>

Data Structures

struct | NV_PIXEL_SRSO_1x2_X1
struct | NV_PIXEL_SRSO_1x2_X2
struct | NV_PIXEL_SRSO_1x2_X4
struct | NV_PIXEL_SRSO_1x2_X8

Data Fields

struct _NV_PIXEL_SRSO_1x2::NV_PIXEL_SRSO_1x2_X1 | X1
struct _NV_PIXEL_SRSO_1x2::NV_PIXEL_SRSO_1x2_X2 | X2
struct _NV_PIXEL_SRSO_1x2::NV_PIXEL_SRSO_1x2_X4 | X4
struct _NV_PIXEL_SRSO_1x2::NV_PIXEL_SRSO_1x2_X8 | X8

Detailed Description

See NvAPI_D3D11_RSGetPixelShadingRateSampleOrder See NvAPI_D3D11_RSSetPixelShadingRateSampleOrder

The documentation for this struct was generated from the following file:


Data Fields
_NV_QUERY_SMP_ASSIST_SUPPORT_PARAMS_V1 Struct Reference
DirectX APIs » DirectX Interface

#include <nvapi.h>

Data Fields

NvU32 version
NV_SMP_ASSIST_TYPE eSMPAssistType
NV_SMP_ASSIST_LEVEL eSMPAssistLevel
NvBool bSMPAssistSupported

Detailed Description

SUPPORTED OS: Windows 7 and higher

The documentation for this struct was generated from the following file:


Data Fields
_NV_GET_SLEEP_STATUS_PARAMS Struct Reference
DirectX APIs » DirectX Interface

#include <nvapi.h>

Data Fields

NvU32 version
NvBool bLowLatencyMode
NvBool bFsVrr
NvBool bCplVsyncOn
NvU32 sleepIntervalUs
NvBool bUseGameSleep
NvU8 rsvd [121]

Detailed Description

SUPPORTED OS: Windows 7 and higher

Used to get sleep status

The documentation for this struct was generated from the following file:


Data Fields
_NV_SET_SLEEP_MODE_PARAMS Struct Reference
DirectX APIs » DirectX Interface

#include <nvapi.h>

Data Fields

NvU32 version
NvBool bLowLatencyMode
NvBool bLowLatencyBoost
NvU32 minimumIntervalUs
NvBool bUseMarkersToOptimize
NvU8 rsvd [31]

Detailed Description

SUPPORTED OS: Windows 7 and higher

Used to set sleep mode

The documentation for this struct was generated from the following file:


Data Fields
_NV_SET_REFLEX_SYNC_PARAMS Struct Reference
DirectX APIs » DirectX Interface

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 | bEnable:1
NvU32 | bDisable:1
NvU32 | flagsRsvd:30
NvU32 vblankIntervalUs
NvS32 timeInQueueUs
NvU32 timeInQueueUsTarget
NvU8 | rsvd [28]

Detailed Description

SUPPORTED OS: Windows 10 and higher

Used to send Reflex Sync data to UMD

The documentation for this struct was generated from the following file:


Data Structures | Data Fields
_NV_LATENCY_RESULT_PARAMS Struct Reference
DirectX APIs » DirectX Interface

#include <nvapi.h>

Data Structures

struct FrameReport

Data Fields

NvU32 version
struct _NV_LATENCY_RESULT_PARAMS::FrameReport | frameReport [64]
NvU8 | rsvd [32]

Detailed Description

SUPPORTED OS: Windows 7 and higher

Used to get latency report.

The documentation for this struct was generated from the following file:


Data Fields
_NV_LATENCY_MARKER_PARAMS Struct Reference
DirectX APIs » DirectX Interface

#include <nvapi.h>

Data Fields

NvU32 version
NvU64 frameID
NV_LATENCY_MARKER_TYPE markerType
NvU64 rsvd0
NvU8 rsvd [56]

Detailed Description

SUPPORTED OS: Windows 7 and higher

Used set latency markers

The documentation for this struct was generated from the following file:


Data Fields
_NV_ASYNC_FRAME_MARKER_PARAMS_V1 Struct Reference
DirectX APIs » DirectX Interface

#include <nvapi.h>

Data Fields

NvU32 version
NvU64 frameID
NV_LATENCY_MARKER_TYPE markerType
NvU64 presentFrameID
NvU8 rsvd [56]

Detailed Description

SUPPORTED OS: Windows 10 and higher

Used in NvAPI_D3D12_SetAsyncFrameMarker

The documentation for this struct was generated from the following file:


Data Fields
_NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_USAGE_COUNT Struct Reference
DirectX APIs » DirectX Interface

#include <nvapi.h>

Data Fields

NvU32 count
NvU32 subdivisionLevel
NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_FORMAT format

Detailed Description

Number of DMMs of a specific configuration in a DMM Array or BLAS build. Used to compute conservative buffer size estimates for DMM Array and BLAS builds.

The documentation for this struct was generated from the following file:


Data Fields
_NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_DESC Struct Reference
DirectX APIs » DirectX Interface

#include <nvapi.h>

Data Fields

NvU32 byteOffset
NvU16 subdivisionLevel
NvU16 format

Detailed Description

Describes one Displacement Micromap.

The documentation for this struct was generated from the following file:


Data Fields
_NVAPI_D3D12_BUILD_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_INPUTS Struct Reference
DirectX APIs » DirectX Interface

#include <nvapi.h>

Data Fields

NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_BUILD_FLAGS flags
NvU32 numDMMUsageCounts
const NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_USAGE_COUNT * | pDMMUsageCounts
D3D12_GPU_VIRTUAL_ADDRESS | inputBuffer
D3D12_GPU_VIRTUAL_ADDRESS_AND_STRIDE | perDMMDescs

Detailed Description

Input structure to DMM Array construction. Individual DMMs are accessed via indices when used in bottom-level acceleration structure (BLAS) construction.

The documentation for this struct was generated from the following file:


Data Fields
_NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PREBUILD_INFO Struct Reference
DirectX APIs » DirectX Interface

#include <nvapi.h>

Data Fields

NvU64 resultDataMaxSizeInBytes
NvU64 scratchDataSizeInBytes

Detailed Description

Conservative memory requirements for building a DMM Array.

The documentation for this struct was generated from the following file:


Data Fields
_NVAPI_GET_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PREBUILD_INFO_PARAMS_V1 Struct Reference
DirectX APIs » DirectX Interface

#include <nvapi.h>

Data Fields

NvU32 version
const NVAPI_D3D12_BUILD_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_INPUTS * pDesc
NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PREBUILD_INFO * pInfo

Detailed Description

Parameters given to NvAPI_D3D12_GetRaytracingDisplacementMicromapArrayPrebuildInfo().

The documentation for this struct was generated from the following file:


Data Fields
_NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_USAGE_COUNT Struct Reference
DirectX APIs » DirectX Interface

#include <nvapi.h>

Data Fields

NvU32 count
NvU32 subdivisionLevel
NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_FORMAT format

Detailed Description

Number of OMMs of a specific configuration in an OMM Array. Used to compute conservative buffer size estimates for OMM Array builds.

The documentation for this struct was generated from the following file:


Data Fields
_NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_DESC Struct Reference
DirectX APIs » DirectX Interface

#include <nvapi.h>

Data Fields

NvU32 byteOffset
NvU16 subdivisionLevel
NvU16 format

Detailed Description

Describes one Opacity Micromap.

The documentation for this struct was generated from the following file:


Data Fields
_NVAPI_D3D12_BUILD_RAYTRACING_OPACITY_MICROMAP_ARRAY_INPUTS Struct Reference
DirectX APIs » DirectX Interface

#include <nvapi.h>

Data Fields

NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_ARRAY_BUILD_FLAGS flags
NvU32 numOMMUsageCounts
const NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_USAGE_COUNT * | pOMMUsageCounts
D3D12_GPU_VIRTUAL_ADDRESS | inputBuffer
D3D12_GPU_VIRTUAL_ADDRESS_AND_STRIDE | perOMMDescs

Detailed Description

Input structure to OMM Array construction. Individual OMMs are accessed via indices when used in bottom-level acceleration structure (BLAS) construction.

The documentation for this struct was generated from the following file:


Data Fields
_NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_ARRAY_PREBUILD_INFO Struct Reference
DirectX APIs » DirectX Interface

#include <nvapi.h>

Data Fields

NvU64 resultDataMaxSizeInBytes
NvU64 scratchDataSizeInBytes

Detailed Description

Conservative memory requirements for building an OMM Array.

The documentation for this struct was generated from the following file:


Data Fields
_NVAPI_GET_RAYTRACING_OPACITY_MICROMAP_ARRAY_PREBUILD_INFO_PARAMS_V1 Struct Reference
DirectX APIs » DirectX Interface

#include <nvapi.h>

Data Fields

NvU32 version
const NVAPI_D3D12_BUILD_RAYTRACING_OPACITY_MICROMAP_ARRAY_INPUTS * pDesc
NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_ARRAY_PREBUILD_INFO * pInfo

Detailed Description

Parameters given to NvAPI_D3D12_GetRaytracingOpacityMicromapArrayPrebuildInfo().

The documentation for this struct was generated from the following file:


Data Fields
_NVAPI_D3D12_SET_CREATE_PIPELINE_STATE_OPTIONS_PARAMS_V1 Struct Reference
DirectX APIs » DirectX Interface

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 flags

Detailed Description

State used when creating new pipelines.

The documentation for this struct was generated from the following file:


Data Fields
_NVAPI_CHECK_DRIVER_MATCHING_IDENTIFIER_EX_PARAMS_V1 Struct Reference
DirectX APIs » DirectX Interface

#include <nvapi.h>

Data Fields

NvU32 version
NVAPI_D3D12_SERIALIZED_DATA_TYPE_EX serializedDataType
const D3D12_SERIALIZED_DATA_DRIVER_MATCHING_IDENTIFIER * | pIdentifierToCheck
D3D12_DRIVER_MATCHING_IDENTIFIER_STATUS | checkStatus

Detailed Description

Parameters given to NvAPI_D3D12_CheckDriverMatchingIdentifierEx().

The documentation for this struct was generated from the following file:


Data Fields
_NVAPI_D3D12_RAYTRACING_GEOMETRY_OMM_ATTACHMENT_DESC Struct Reference
DirectX APIs » DirectX Interface

#include <nvapi.h>

Data Fields

D3D12_GPU_VIRTUAL_ADDRESS_AND_STRIDE | opacityMicromapIndexBuffer
DXGI_FORMAT | opacityMicromapIndexFormat
NvU32 opacityMicromapBaseLocation
D3D12_GPU_VIRTUAL_ADDRESS | opacityMicromapArray
NvU32 numOMMUsageCounts
const NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_USAGE_COUNT * | pOMMUsageCounts

Detailed Description

Geometry descriptor attachment with Opacity Micromaps.

The documentation for this struct was generated from the following file:


Data Fields
_NVAPI_D3D12_RAYTRACING_GEOMETRY_DMM_ATTACHMENT_DESC Struct Reference
DirectX APIs » DirectX Interface

#include <nvapi.h>

Data Fields

D3D12_GPU_VIRTUAL_ADDRESS_AND_STRIDE | triangleMicromapIndexBuffer
DXGI_FORMAT | triangleMicromapIndexFormat
NvU32 triangleMicromapBaseLocation
D3D12_GPU_VIRTUAL_ADDRESS_AND_STRIDE | trianglePrimitiveFlagsBuffer
D3D12_GPU_VIRTUAL_ADDRESS_AND_STRIDE | vertexBiasAndScaleBuffer
DXGI_FORMAT | vertexBiasAndScaleFormat
D3D12_GPU_VIRTUAL_ADDRESS_AND_STRIDE | vertexDisplacementVectorBuffer
DXGI_FORMAT | vertexDisplacementVectorFormat
D3D12_GPU_VIRTUAL_ADDRESS | displacementMicromapArray
NvU32 numDMMUsageCounts
const NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_USAGE_COUNT * | pDMMUsageCounts

Detailed Description

Geometry descriptor attachment with Displacement Micromaps.

The documentation for this struct was generated from the following file:


Data Fields
_NVAPI_D3D12_RAYTRACING_GEOMETRY_DMM_TRIANGLES_DESC Struct Reference
DirectX APIs » DirectX Interface

#include <nvapi.h>

Data Fields

D3D12_RAYTRACING_GEOMETRY_TRIANGLES_DESC triangles
NVAPI_D3D12_RAYTRACING_GEOMETRY_DMM_ATTACHMENT_DESC dmmAttachment

Detailed Description

Geometry triangle descriptor with attached augmented Displacement Micromaps.

The documentation for this struct was generated from the following file:


Data Fields
_NVAPI_D3D12_RAYTRACING_GEOMETRY_OMM_TRIANGLES_DESC Struct Reference
DirectX APIs » DirectX Interface

#include <nvapi.h>

Data Fields

D3D12_RAYTRACING_GEOMETRY_TRIANGLES_DESC triangles
NVAPI_D3D12_RAYTRACING_GEOMETRY_OMM_ATTACHMENT_DESC ommAttachment

Detailed Description

Geometry triangle descriptor with attached augmented Opacity Micromaps.

The documentation for this struct was generated from the following file:


Data Fields
_NVAPI_D3D12_RAYTRACING_GEOMETRY_DESC_EX Struct Reference
DirectX APIs » DirectX Interface

#include <nvapi.h>

Data Fields

NVAPI_D3D12_RAYTRACING_GEOMETRY_TYPE_EX type
D3D12_RAYTRACING_GEOMETRY_FLAGS flags
union {
D3D12_RAYTRACING_GEOMETRY_TRIANGLES_DESC _NVAPI_D3D12_RAYTRACING_GEOMETRY_DESC_EX::triangles
D3D12_RAYTRACING_GEOMETRY_AABBS_DESC _NVAPI_D3D12_RAYTRACING_GEOMETRY_DESC_EX::aabbs
NVAPI_D3D12_RAYTRACING_GEOMETRY_OMM_TRIANGLES_DESC _NVAPI_D3D12_RAYTRACING_GEOMETRY_DESC_EX::ommTriangles
NVAPI_D3D12_RAYTRACING_GEOMETRY_DMM_TRIANGLES_DESC _NVAPI_D3D12_RAYTRACING_GEOMETRY_DESC_EX::dmmTriangles
};

Detailed Description

This structure extends D3D12_RAYTRACING_GEOMETRY_DESC by supporting additional geometry types. Only new members are fully described below; for more information on the other members, please check Microsoft's DirectX Raytracing Specification.

The documentation for this struct was generated from the following file:


Data Fields
_NVAPI_D3D12_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_INPUTS_EX Struct Reference
DirectX APIs » DirectX Interface

#include <nvapi.h>

Data Fields

D3D12_RAYTRACING_ACCELERATION_STRUCTURE_TYPE | type
NVAPI_D3D12_RAYTRACING_ACCELERATION_STRUCTURE_BUILD_FLAGS_EX flags
NvU32 numDescs
D3D12_ELEMENTS_LAYOUT | descsLayout
NvU32 geometryDescStrideInBytes
union {
D3D12_GPU_VIRTUAL_ADDRESS _NVAPI_D3D12_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_INPUTS_EX::instanceDescs
const NVAPI_D3D12_RAYTRACING_GEOMETRY_DESC_EX * _NVAPI_D3D12_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_INPUTS_EX::pGeometryDescs
const NVAPI_D3D12_RAYTRACING_GEOMETRY_DESC_EX *const * _NVAPI_D3D12_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_INPUTS_EX::ppGeometryDescs
};

Detailed Description

This structure extends D3D12_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_INPUTS by supporting additional geometry types. Only modified members are fully described below; for more information on the other members, please check Microsoft's DirectX Raytracing Specification.

The documentation for this struct was generated from the following file:


Data Fields
_NVAPI_GET_RAYTRACING_ACCELERATION_STRUCTURE_PREBUILD_INFO_EX_PARAMS_V1 Struct Reference
DirectX APIs » DirectX Interface

#include <nvapi.h>

Data Fields

NvU32 version
const NVAPI_D3D12_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_INPUTS_EX * | pDesc
D3D12_RAYTRACING_ACCELERATION_STRUCTURE_PREBUILD_INFO * | pInfo

Detailed Description

Parameters given to NvAPI_D3D12_GetRaytracingAccelerationStructurePrebuildInfoEx().

The documentation for this struct was generated from the following file:


Data Fields
_NVAPI_D3D12_BUILD_RAYTRACING_OPACITY_MICROMAP_ARRAY_DESC Struct Reference
DirectX APIs » DirectX Interface

#include <nvapi.h>

Data Fields

D3D12_GPU_VIRTUAL_ADDRESS | destOpacityMicromapArrayData
NVAPI_D3D12_BUILD_RAYTRACING_OPACITY_MICROMAP_ARRAY_INPUTS inputs
D3D12_GPU_VIRTUAL_ADDRESS | scratchOpacityMicromapArrayData

Detailed Description

Description of the inputs and memory areas used during the building of OMM Arrays.

The documentation for this struct was generated from the following file:


Data Fields
_NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_ARRAY_POSTBUILD_INFO_CURRENT_SIZE_DESC Struct Reference
DirectX APIs » DirectX Interface

#include <nvapi.h>

Data Fields

NvU64 currentSizeInBytes

Detailed Description

Structure emitted by NvAPI_D3D12_EmitRaytracingOpacityMicromapArrayPostbuildInfo(), and optionally NvAPI_D3D12_BuildRaytracingOpacityMicromapArray(), when type equals NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_ARRAY_POSTBUILD_INFO_CURRENT_SIZE.

The documentation for this struct was generated from the following file:


Data Fields
_NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_ARRAY_POSTBUILD_INFO_DESC Struct Reference
DirectX APIs » DirectX Interface

#include <nvapi.h>

Data Fields

D3D12_GPU_VIRTUAL_ADDRESS destBuffer
NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_ARRAY_POSTBUILD_INFO_TYPE infoType

Detailed Description

Description of the postbuild information to generate from an OMM Array.

The documentation for this struct was generated from the following file:


Data Fields
_NVAPI_BUILD_RAYTRACING_OPACITY_MICROMAP_ARRAY_PARAMS_V1 Struct Reference
DirectX APIs » DirectX Interface

#include <nvapi.h>

Data Fields

NvU32 version
const NVAPI_D3D12_BUILD_RAYTRACING_OPACITY_MICROMAP_ARRAY_DESC * | pDesc
NvU32 numPostbuildInfoDescs
const NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_ARRAY_POSTBUILD_INFO_DESC * | pPostbuildInfoDescs

Detailed Description

Parameters given to NvAPI_D3D12_BuildRaytracingOpacityMicromapArray().

The documentation for this struct was generated from the following file:


Data Fields
_NVAPI_RELOCATE_RAYTRACING_OPACITY_MICROMAP_ARRAY_PARAMS_V1 Struct Reference
DirectX APIs » DirectX Interface

#include <nvapi.h>

Data Fields

NvU32 version
D3D12_GPU_VIRTUAL_ADDRESS opacityMicromapArray

Detailed Description

Parameters given to NvAPI_D3D12_RelocateRaytracingOpacityMicromapArray().

The documentation for this struct was generated from the following file:


Data Fields
_NVAPI_D3D12_BUILD_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_DESC Struct Reference
DirectX APIs » DirectX Interface

#include <nvapi.h>

Data Fields

D3D12_GPU_VIRTUAL_ADDRESS | destDisplacementMicromapArrayData
NVAPI_D3D12_BUILD_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_INPUTS inputs
D3D12_GPU_VIRTUAL_ADDRESS | scratchDisplacementMicromapArrayData

Detailed Description

Description of the inputs and memory areas used during the building of DMM Arrays.

The documentation for this struct was generated from the following file:


Data Fields
_NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_POSTBUILD_INFO_CURRENT_SIZE_DESC Struct Reference
DirectX APIs » DirectX Interface

#include <nvapi.h>

Data Fields

NvU64 currentSizeInBytes

Detailed Description

Structure emitted by NvAPI_D3D12_EmitRaytracingDisplacementMicromapArrayPostbuildInfo(), and optionally NvAPI_D3D12_BuildRaytracingDisplacementMicromapArray(), when type equals NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_POSTBUILD_INFO_CURRENT_SIZE.

The documentation for this struct was generated from the following file:


Data Fields
_NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_POSTBUILD_INFO_DESC Struct Reference
DirectX APIs » DirectX Interface

#include <nvapi.h>

Data Fields

D3D12_GPU_VIRTUAL_ADDRESS destBuffer
NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_POSTBUILD_INFO_TYPE infoType

Detailed Description

Description of the postbuild information to generate from a DMM Array.

The documentation for this struct was generated from the following file:


Data Fields
_NVAPI_BUILD_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PARAMS_V1 Struct Reference
DirectX APIs » DirectX Interface

#include <nvapi.h>

Data Fields

NvU32 version
const NVAPI_D3D12_BUILD_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_DESC * | pDesc
NvU32 numPostbuildInfoDescs
const NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_POSTBUILD_INFO_DESC * | pPostbuildInfoDescs

Detailed Description

Parameters given to NvAPI_D3D12_BuildRaytracingDisplacementMicromapArray().

The documentation for this struct was generated from the following file:


Data Fields
_NVAPI_RELOCATE_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PARAMS_V1 Struct Reference
DirectX APIs » DirectX Interface

#include <nvapi.h>

Data Fields

NvU32 version
D3D12_GPU_VIRTUAL_ADDRESS displacementMicromapArray

Detailed Description

Parameters given to NvAPI_D3D12_RelocateRaytracingDisplacementMicromapArray().

The documentation for this struct was generated from the following file:


Data Fields
_NVAPI_EMIT_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_POSTBUILD_INFO_PARAMS_V1 Struct Reference
DirectX APIs » DirectX Interface

#include <nvapi.h>

Data Fields

NvU32 version
const NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_POSTBUILD_INFO_DESC * | pDesc
NvU32 numSources
const D3D12_GPU_VIRTUAL_ADDRESS * | pSources

Detailed Description

Parameters given to NvAPI_D3D12_EmitRaytracingDisplacementMicromapArrayPostbuildInfo().

The documentation for this struct was generated from the following file:


Data Fields
_NVAPI_EMIT_RAYTRACING_OPACITY_MICROMAP_ARRAY_POSTBUILD_INFO_PARAMS_V1 Struct Reference
DirectX APIs » DirectX Interface

#include <nvapi.h>

Data Fields

NvU32 version
const NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_ARRAY_POSTBUILD_INFO_DESC * | pDesc
NvU32 numSources
const D3D12_GPU_VIRTUAL_ADDRESS * | pSources

Detailed Description

Parameters given to NvAPI_D3D12_EmitRaytracingOpacityMicromapArrayPostbuildInfo().

The documentation for this struct was generated from the following file:


Data Fields
_NVAPI_D3D12_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_DESC_EX Struct Reference
DirectX APIs » DirectX Interface

#include <nvapi.h>

Data Fields

D3D12_GPU_VIRTUAL_ADDRESS | destAccelerationStructureData
NVAPI_D3D12_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_INPUTS_EX inputs
D3D12_GPU_VIRTUAL_ADDRESS | sourceAccelerationStructureData
D3D12_GPU_VIRTUAL_ADDRESS | scratchAccelerationStructureData

Detailed Description

This structure extends D3D12_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_DESC by supporting additional geometry types as inputs. For more information on the different members, please check Microsoft's DirectX Raytracing Specification.

The documentation for this struct was generated from the following file:


Data Fields
_NVAPI_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_EX_PARAMS_V1 Struct Reference
DirectX APIs » DirectX Interface

#include <nvapi.h>

Data Fields

NvU32 version
const NVAPI_D3D12_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_DESC_EX * | pDesc
NvU32 numPostbuildInfoDescs
const D3D12_RAYTRACING_ACCELERATION_STRUCTURE_POSTBUILD_INFO_DESC * | pPostbuildInfoDescs

Detailed Description

Parameters given to NvAPI_D3D12_RelocateRaytracingOpacityMicromapArray().

The documentation for this struct was generated from the following file:


Data Fields
NV_GET_CURRENT_SLI_STATE_V1 Struct Reference
DirectX APIs » DirectX Interface

#include <nvapi_lite_sli.h>

Data Fields

NvU32 version
NvU32 maxNumAFRGroups
NvU32 numAFRGroups
NvU32 currentAFRIndex
NvU32 nextFrameAFRIndex
NvU32 previousFrameAFRIndex
NvU32 bIsCurAFRGroupNew

Detailed Description

Used in NvAPI_D3D10_GetCurrentSLIState(), and NvAPI_D3D_GetCurrentSLIState().

Field Documentation

◆ bIsCurAFRGroupNew

NvU32 NV_GET_CURRENT_SLI_STATE_V1::bIsCurAFRGroupNew

[OUT] Boolean: Is this frame the first time running on the current AFR group

◆ currentAFRIndex

NvU32 NV_GET_CURRENT_SLI_STATE_V1::currentAFRIndex

[OUT] The AFR group index for the frame currently being rendered

◆ maxNumAFRGroups

NvU32 NV_GET_CURRENT_SLI_STATE_V1::maxNumAFRGroups

[OUT] The maximum possible value of numAFRGroups

◆ nextFrameAFRIndex

NvU32 NV_GET_CURRENT_SLI_STATE_V1::nextFrameAFRIndex

[OUT] What the AFR group index will be for the next frame (i.e. after calling Present)

◆ numAFRGroups

NvU32 NV_GET_CURRENT_SLI_STATE_V1::numAFRGroups

[OUT] The number of AFR groups enabled in the system

◆ previousFrameAFRIndex

NvU32 NV_GET_CURRENT_SLI_STATE_V1::previousFrameAFRIndex

[OUT] The AFR group index that was used for the previous frame (~0 if more than one frame has not been rendered yet)

◆ version

NvU32 NV_GET_CURRENT_SLI_STATE_V1::version

Structure version.

The documentation for this struct was generated from the following file:
  • nvapi_lite_sli.h


Data Fields
_NV_DX_VIDEO_STEREO_INFO Struct Reference
DirectX APIs » DirectX Video Control

#include <nvapi.h>

Data Fields

NvU32 dwVersion
NVDX_ObjectHandle | hSurface
NVDX_ObjectHandle | hLinkedSurface
NV_STEREO_VIDEO_FORMAT eFormat
NvS32 sViewOffset
BOOL | bStereoEnable
The documentation for this struct was generated from the following file:


Modules
System APIs

Modules

System - General Interface <br>

Detailed Description

Privacy Policy | Manage My Privacy | Do Not Sell or Share My Data | Terms of Service | Accessibility | Corporate Policies | Product Security | Contact

Copyright © 2022-2024 NVIDIA Corporation


Data Fields
NV_MOSAIC_TOPO_DETAILS Struct Reference
OpenGL APIs » Mosaic APIs

#include <nvapi.h>

Data Fields

NvU32 version
NvLogicalGpuHandle hLogicalGPU
NvU32 validityMask
NvU32 rowCount
NvU32 colCount
struct {
NvPhysicalGpuHandle NV_MOSAIC_TOPO_DETAILS::hPhysicalGPU
NvU32 NV_MOSAIC_TOPO_DETAILS::displayOutputId
NvS32 NV_MOSAIC_TOPO_DETAILS::overlapX
NvS32 NV_MOSAIC_TOPO_DETAILS::overlapY
} gpuLayout [NVAPI_MAX_MOSAIC_DISPLAY_ROWS][NVAPI_MAX_MOSAIC_DISPLAY_COLUMNS]

Detailed Description

This structure defines the topology details.

The documentation for this struct was generated from the following file:


Data Fields
NV_MOSAIC_TOPO_BRIEF Struct Reference
OpenGL APIs » Mosaic APIs

#include <nvapi.h>

Data Fields

NvU32 version
NV_MOSAIC_TOPO topo
NvU32 enabled
NvU32 isPossible

Detailed Description

This is a "topology brief" structure. It tells you what you need to know about a topology at a high level. A list of these is returned when you query for the supported Mosaic information.

If you need more detailed information about the topology, call NvAPI_Mosaic_GetTopoGroup() with the topology value from this structure.

The documentation for this struct was generated from the following file:


Data Fields
_NV_MOSAIC_DISPLAY_SETTING_V1 Struct Reference
OpenGL APIs » Mosaic APIs

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 width
NvU32 height
NvU32 bpp
NvU32 freq

Detailed Description

Basic per-display settings that are used in setting/getting the Mosaic mode.

The documentation for this struct was generated from the following file:


Data Fields
NV_MOSAIC_DISPLAY_SETTING_V2 Struct Reference
OpenGL APIs » Mosaic APIs

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 width
NvU32 height
NvU32 bpp
NvU32 freq
NvU32 rrx1k
The documentation for this struct was generated from the following file:


Data Fields
_NV_MOSAIC_SUPPORTED_TOPO_INFO_V1 Struct Reference
OpenGL APIs » Mosaic APIs

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 topoBriefsCount
NV_MOSAIC_TOPO_BRIEF topoBriefs [NV_MOSAIC_TOPO_MAX]
NvU32 displaySettingsCount
NV_MOSAIC_DISPLAY_SETTING_V1 displaySettings [NV_MOSAIC_DISPLAY_SETTINGS_MAX]

Detailed Description

This structure is used to contain a list of supported Mosaic topologies along with the display settings that can be used.

The documentation for this struct was generated from the following file:


Data Fields
_NV_MOSAIC_SUPPORTED_TOPO_INFO_V2 Struct Reference
OpenGL APIs » Mosaic APIs

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 topoBriefsCount
NV_MOSAIC_TOPO_BRIEF topoBriefs [NV_MOSAIC_TOPO_MAX]
NvU32 displaySettingsCount
NV_MOSAIC_DISPLAY_SETTING_V2 displaySettings [NV_MOSAIC_DISPLAY_SETTINGS_MAX]
The documentation for this struct was generated from the following file:


Data Fields
NV_MOSAIC_TOPO_GROUP Struct Reference
OpenGL APIs » Mosaic APIs

#include <nvapi.h>

Data Fields

NvU32 version
NV_MOSAIC_TOPO_BRIEF brief
NvU32 count
NV_MOSAIC_TOPO_DETAILS topos [NV_MOSAIC_MAX_TOPO_PER_TOPO_GROUP]

Detailed Description

This structure defines a group of topologies that work together to create one overall layout. All of the supported topologies are represented with this structure.

For example, a 'Passive Stereo' topology would be represented with this structure, and would have separate topology details for the left and right eyes. The count would be 2. A 'Basic' topology is also represented by this structure, with a count of 1.

The structure is primarily used internally, but is exposed to applications in a read-only fashion because there are some details in it that might be useful (like the number of rows/cols, or connected display information). A user can get the filled-in structure by calling NvAPI_Mosaic_GetTopoGroup().

You can then look at the detailed values within the structure. There are no entrypoints which take this structure as input (effectively making it read-only).

The documentation for this struct was generated from the following file:


Data Fields
_NV_MOSAIC_GRID_TOPO_DISPLAY_V1 Struct Reference
OpenGL APIs | OpenGL APIs » Mosaic APIs

#include <nvapi.h>

Data Fields

NvU32 displayId
NvS32 overlapX
NvS32 overlapY
NV_ROTATE rotation
NvU32 cloneGroup
The documentation for this struct was generated from the following file:


Data Fields
NV_MOSAIC_DISPLAY_TOPO_STATUS Struct Reference
OpenGL APIs | OpenGL APIs » Mosaic APIs

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 errorFlags
NvU32 warningFlags
NvU32 displayCount
struct {
NvU32 NV_MOSAIC_DISPLAY_TOPO_STATUS::displayId
NvU32 NV_MOSAIC_DISPLAY_TOPO_STATUS::errorFlags
NvU32 NV_MOSAIC_DISPLAY_TOPO_STATUS::warningFlags
NvU32 NV_MOSAIC_DISPLAY_TOPO_STATUS::supportsRotation: 1
NvU32 NV_MOSAIC_DISPLAY_TOPO_STATUS::reserved: 31
} displays [NVAPI_MAX_DISPLAYS]
The documentation for this struct was generated from the following file:


Data Fields
NV_MOSAIC_TOPOLOGY Struct Reference
OpenGL APIs » Mosaic APIs

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 rowCount
NvU32 colCount
struct {
NvPhysicalGpuHandle NV_MOSAIC_TOPOLOGY::hPhysicalGPU
NvU32 NV_MOSAIC_TOPOLOGY::displayOutputId
NvS32 NV_MOSAIC_TOPOLOGY::overlapX
NvS32 NV_MOSAIC_TOPOLOGY::overlapY
} gpuLayout [NVAPI_MAX_MOSAIC_DISPLAY_ROWS][NVAPI_MAX_MOSAIC_DISPLAY_COLUMNS]

Detailed Description

Used in NvAPI_GetCurrentMosaicTopology() and NvAPI_SetCurrentMosaicTopology().

The documentation for this struct was generated from the following file:


Data Fields
NV_MOSAIC_SUPPORTED_TOPOLOGIES Struct Reference
OpenGL APIs » Mosaic APIs

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 totalCount
NV_MOSAIC_TOPOLOGY topos [NVAPI_MAX_MOSAIC_TOPOS]

Detailed Description

Used in NvAPI_GetSupportedMosaicTopologies().

The documentation for this struct was generated from the following file:


Data Fields
NV_QSYNC_EVENT_DATA Struct Reference
OpenGL APIs

#include <nvapi.h>

Data Fields

NV_QSYNC_EVENT qsyncEvent
NvU32 reserved [7]
The documentation for this struct was generated from the following file:


Data Fields
NV_EVENT_REGISTER_CALLBACK Struct Reference
OpenGL APIs

#include <nvapi.h>

Data Fields

NvU32 version
NV_EVENT_TYPE eventId
void * callbackParam
union {
NVAPI_CALLBACK_QSYNCEVENT NV_EVENT_REGISTER_CALLBACK::nvQSYNCEventCallback
} nvCallBackFunc

Detailed Description

Core NV_EVENT_REGISTER_CALLBACK structure declaration.

The documentation for this struct was generated from the following file:


Data Fields
_NV_LICENSE_EXPIRY_DETAILS Struct Reference
OpenGL APIs

#include <nvapi.h>

Data Fields

NvU32 year
NvU16 month
NvU16 day
NvU16 hour
NvU16 min
NvU16 sec
NvU8 status

Detailed Description

Used in NV_LICENSE_FEATURE_DETAILS

The 'status' variable holds any one of the following license expiry status codes : 0 - Expiry information not available 1 - Invalid expiry or error fetching expiry 2 - Valid expiry 3 - Expiry not applicable 4 - Permanent expiry

The documentation for this struct was generated from the following file:


Data Fields
_NV_LICENSE_FEATURE_DETAILS_V1 Struct Reference
OpenGL APIs

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 | isEnabled: 1
NvU32 | reserved: 31
NV_LICENSE_FEATURE_TYPE featureCode
NvAPI_LicenseString licenseInfo

Detailed Description

Used in NV_LICENSABLE_FEATURES.

The documentation for this struct was generated from the following file:


Data Fields
_NV_LICENSE_FEATURE_DETAILS_V2 Struct Reference
OpenGL APIs

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 | isEnabled: 1
NvU32 | reserved: 31
NV_LICENSE_FEATURE_TYPE featureCode
NvAPI_LicenseString licenseInfo
NvAPI_LicenseString productName
The documentation for this struct was generated from the following file:


Data Fields
_NV_LICENSE_FEATURE_DETAILS_V3 Struct Reference
OpenGL APIs

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 | isEnabled: 1
NvU32 | isFeatureEnabled: 1
NvU32 | reserved: 30
NV_LICENSE_FEATURE_TYPE featureCode
NvAPI_LicenseString licenseInfo
NvAPI_LicenseString productName
The documentation for this struct was generated from the following file:


Data Fields
_NV_LICENSE_FEATURE_DETAILS_V4 Struct Reference
OpenGL APIs

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 | isEnabled: 1
NvU32 | isFeatureEnabled: 1
NvU32 | reserved: 30
NV_LICENSE_FEATURE_TYPE featureCode
NvAPI_LicenseString licenseInfo
NvAPI_LicenseString productName
NV_LICENSE_EXPIRY_DETAILS licenseExpiry
The documentation for this struct was generated from the following file:


Data Fields
_NV_LICENSABLE_FEATURES_V1 Struct Reference
OpenGL APIs

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 | isLicenseSupported: 1
NvU32 | reserved: 31
NvU32 licensableFeatureCount
NvU8 signature [NV_LICENSE_SIGNATURE_SIZE]
NV_LICENSE_FEATURE_DETAILS_V1 licenseDetails [NV_LICENSE_MAX_COUNT]

Detailed Description

Licensable features.

The documentation for this struct was generated from the following file:


Data Fields
_NV_LICENSABLE_FEATURES_V2 Struct Reference
OpenGL APIs

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 | isLicenseSupported: 1
NvU32 | reserved: 31
NvU32 licensableFeatureCount
NvU8 signature [NV_LICENSE_SIGNATURE_SIZE]
NV_LICENSE_FEATURE_DETAILS_V2 licenseDetails [NV_LICENSE_MAX_COUNT]
The documentation for this struct was generated from the following file:


Data Fields
_NV_LICENSABLE_FEATURES_V3 Struct Reference
OpenGL APIs

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 | isLicenseSupported: 1
NvU32 | reserved: 31
NvU32 licensableFeatureCount
NvU8 signature [NV_LICENSE_SIGNATURE_SIZE]
NV_LICENSE_FEATURE_DETAILS_V3 licenseDetails [NV_LICENSE_MAX_COUNT]
The documentation for this struct was generated from the following file:


Data Fields
_NV_LICENSABLE_FEATURES_V4 Struct Reference
OpenGL APIs

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 | isLicenseSupported: 1
NvU32 | reserved: 31
NvU32 licensableFeatureCount
NvU8 signature [NV_LICENSE_SIGNATURE_SIZE]
NV_LICENSE_FEATURE_DETAILS_V4 licenseDetails [NV_LICENSE_MAX_COUNT]
The documentation for this struct was generated from the following file:


Data Fields
NVLINK_GET_CAPS_V1 Struct Reference
OpenGL APIs

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 capsTbl
NvU8 lowestNvlinkVersion
NvU8 highestNvlinkVersion
NvU8 lowestNciVersion
NvU8 highestNciVersion
NvU32 linkMask
The documentation for this struct was generated from the following file:


Data Fields
NVLINK_DEVICE_INFO_V1 Struct Reference
OpenGL APIs

#include <nvapi.h>

Data Fields

NvU32 deviceIdFlags
NvU16 domain
NvU16 bus
NvU16 device
NvU16 function
NvU32 pciDeviceId
NvU64 deviceType
NvU8 deviceUUID [16]
The documentation for this struct was generated from the following file:


Data Fields
NVLINK_LINK_STATUS_INFO_V1 Struct Reference
OpenGL APIs

#include <nvapi.h>

Data Fields

NvU32 capsTbl
NvU8 phyType
NvU8 subLinkWidth
NvU32 linkState
NvU8 rxSublinkStatus
NvU8 txSublinkStatus
NvU8 nvlinkVersion
NvU8 nciVersion
NvU8 phyVersion
NvU32 nvlinkCommonClockSpeedMhz
NvU32 nvlinkRefClkSpeedMhz
NvU8 nvlinkRefClkType
NvU32 nvlinkLinkClockMhz
NvU32 | connected:1
NvU32 | reserved:31
NvU8 loopProperty
NvU8 remoteDeviceLinkNumber
NVLINK_DEVICE_INFO_V1 remoteDeviceInfo
The documentation for this struct was generated from the following file:


Data Fields
NVLINK_LINK_STATUS_INFO_V2 Struct Reference
OpenGL APIs

#include <nvapi.h>

Data Fields

NvU32 capsTbl
NvU8 phyType
NvU8 subLinkWidth
NvU32 linkState
NvU8 rxSublinkStatus
NvU8 txSublinkStatus
NvU8 nvlinkVersion
NvU8 nciVersion
NvU8 phyVersion
NvU32 nvlinkCommonClockSpeedMhz
NvU32 nvlinkRefClkSpeedMhz
NvU8 nvlinkRefClkType
NvU32 nvlinkLinkClockMhz
NvU32 | connected:1
NvU32 | reserved:31
NvU8 loopProperty
NvU8 remoteDeviceLinkNumber
NVLINK_DEVICE_INFO_V1 remoteDeviceInfo
NvU8 localDeviceLinkNumber
NVLINK_DEVICE_INFO_V1 localDeviceInfo
NvU32 nvlinkLineRateMbps
NvU32 | reservedEx [8]
The documentation for this struct was generated from the following file:


Data Fields
NVLINK_GET_STATUS_V1 Struct Reference
OpenGL APIs

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 linkMask
NVLINK_LINK_STATUS_INFO_V1 linkInfo [NVAPI_NVLINK_MAX_LINKS]
The documentation for this struct was generated from the following file:


Data Fields
NVLINK_GET_STATUS_V2 Struct Reference
OpenGL APIs

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 linkMask
NVLINK_LINK_STATUS_INFO_V2 linkInfo [NVAPI_NVLINK_MAX_LINKS]
The documentation for this struct was generated from the following file:


Data Fields
_NV_GPU_INFO_V1 Struct Reference
OpenGL APIs

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 | bIsExternalGpu:1
NvU32 | reserved:31
The documentation for this struct was generated from the following file:


Data Fields
_NV_GPU_INFO_V2 Struct Reference
OpenGL APIs

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 | bIsExternalGpu:1
NvU32 | reserved0:31
NvU64 reserved1
NvU32 rayTracingCores
NvU32 tensorCores
NvU32 | reserved2 [14]
The documentation for this struct was generated from the following file:


Data Fields
_NV_GPU_VR_READY_V1 Struct Reference
OpenGL APIs

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 | isVRReady: 1
NvU32 | reserved: 31
The documentation for this struct was generated from the following file:


Data Fields
_NV_GPU_CLIENT_ILLUM_DEVICE_INFO_DATA_MCUV10 Struct Reference
OpenGL APIs

#include <nvapi.h>

Data Fields

NvU8 i2cDevIdx

Detailed Description

Used in NV_GPU_CLIENT_ILLUM_DEVICE_INFO_V1 Describes the static information of illumination device type MCUV10.

The documentation for this struct was generated from the following file:


Data Fields
_NV_GPU_CLIENT_ILLUM_DEVICE_INFO_DATA_GPIO_PWM_RGBW Struct Reference
OpenGL APIs

#include <nvapi.h>

Data Fields

NvU8 gpioPinRed
NvU8 gpioPinGreen
NvU8 gpioPinBlue
NvU8 gpioPinWhite

Detailed Description

Used in NV_GPU_CLIENT_ILLUM_DEVICE_INFO_V1 Describes the static information of illum device type GPIO_PWM_RGBW.

The documentation for this struct was generated from the following file:


Data Fields
_NV_GPU_CLIENT_ILLUM_DEVICE_INFO_DATA_GPIO_PWM_SINGLE_COLOR Struct Reference
OpenGL APIs

#include <nvapi.h>

Data Fields

NvU8 gpioPinSingleColor

Detailed Description

Used in NV_GPU_CLIENT_ILLUM_DEVICE_INFO_V1 Describes the static information of illum device type GPIO_PWM_SINGLE_COLOR.

The documentation for this struct was generated from the following file:


Data Fields
_NV_GPU_CLIENT_ILLUM_DEVICE_INFO_V1 Struct Reference
OpenGL APIs

#include <nvapi.h>

Data Fields

NV_GPU_CLIENT_ILLUM_DEVICE_TYPE type
NvU32 ctrlModeMask
union {
NV_GPU_CLIENT_ILLUM_DEVICE_INFO_DATA_MCUV10 _NV_GPU_CLIENT_ILLUM_DEVICE_INFO_V1::mcuv10
NV_GPU_CLIENT_ILLUM_DEVICE_INFO_DATA_GPIO_PWM_RGBW _NV_GPU_CLIENT_ILLUM_DEVICE_INFO_V1::gpioPwmRgbwv10
NV_GPU_CLIENT_ILLUM_DEVICE_INFO_DATA_GPIO_PWM_SINGLE_COLOR _NV_GPU_CLIENT_ILLUM_DEVICE_INFO_V1::gpioPwmSingleColorv10
NvU8 _NV_GPU_CLIENT_ILLUM_DEVICE_INFO_V1::rsvd [64]
} data
The documentation for this struct was generated from the following file:


Data Fields
_NV_GPU_CLIENT_ILLUM_DEVICE_INFO_PARAMS_V1 Struct Reference
OpenGL APIs

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 numIllumDevices
NvU8 rsvd [64]
NV_GPU_CLIENT_ILLUM_DEVICE_INFO_V1 devices [NV_GPU_CLIENT_ILLUM_DEVICE_NUM_DEVICES_MAX]
The documentation for this struct was generated from the following file:


Data Fields
NV_GPU_CLIENT_ILLUM_DEVICE_SYNC_V1 Struct Reference
OpenGL APIs

#include <nvapi.h>

Data Fields

NvBool bSync
NvU64 timeStampms
NvU8 rsvd [64]

Detailed Description

Structure representing the data required for synchronization.

The documentation for this struct was generated from the following file:


Data Fields
NV_GPU_CLIENT_ILLUM_DEVICE_CONTROL_V1 Struct Reference
OpenGL APIs

#include <nvapi.h>

Data Fields

NV_GPU_CLIENT_ILLUM_DEVICE_TYPE type
NV_GPU_CLIENT_ILLUM_DEVICE_SYNC_V1 syncData
NvU8 rsvd [64]

Detailed Description

Structure representing the device control parameters of each ILLUM_DEVICE.

The documentation for this struct was generated from the following file:


Data Fields
NV_GPU_CLIENT_ILLUM_DEVICE_CONTROL_PARAMS_V1 Struct Reference
OpenGL APIs

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 numIllumDevices
NvU8 rsvd [64]
NV_GPU_CLIENT_ILLUM_DEVICE_CONTROL_V1 devices [NV_GPU_CLIENT_ILLUM_DEVICE_NUM_DEVICES_MAX]

Detailed Description

Structure representing the control parameters of ILLUM_DEVICE-s.

The documentation for this struct was generated from the following file:


Data Fields
_NV_GPU_CLIENT_ILLUM_ZONE_INFO_DATA_RGB Struct Reference
OpenGL APIs

#include <nvapi.h>

Data Fields

NvU8 rsvd
The documentation for this struct was generated from the following file:


Data Fields
_NV_GPU_CLIENT_ILLUM_ZONE_INFO_DATA_RGBW Struct Reference
OpenGL APIs

#include <nvapi.h>

Data Fields

NvU8 rsvd

Detailed Description

Used in NV_GPU_CLIENT_ILLUM_ZONE_INFO_V1 Describes the static information of illum zone type RGBW.

The documentation for this struct was generated from the following file:


Data Fields
_NV_GPU_CLIENT_ILLUM_ZONE_INFO_DATA_SINGLE_COLOR Struct Reference
OpenGL APIs

#include <nvapi.h>

Data Fields

NvU8 rsvd

Detailed Description

Used in NV_GPU_CLIENT_ILLUM_ZONE_INFO_V1 Describes the static information of illum zone type SINGLE_COLOR.

The documentation for this struct was generated from the following file:


Data Fields
_NV_GPU_CLIENT_ILLUM_ZONE_INFO_V1 Struct Reference
OpenGL APIs

#include <nvapi.h>

Data Fields

NV_GPU_CLIENT_ILLUM_ZONE_TYPE type
NvU8 illumDeviceIdx
NvU8 provIdx
NV_GPU_CLIENT_ILLUM_ZONE_LOCATION zoneLocation
union {
NV_GPU_CLIENT_ILLUM_ZONE_INFO_DATA_RGB _NV_GPU_CLIENT_ILLUM_ZONE_INFO_V1::rgb
NV_GPU_CLIENT_ILLUM_ZONE_INFO_DATA_RGBW _NV_GPU_CLIENT_ILLUM_ZONE_INFO_V1::rgbw
NV_GPU_CLIENT_ILLUM_ZONE_INFO_DATA_SINGLE_COLOR _NV_GPU_CLIENT_ILLUM_ZONE_INFO_V1::singleColor
NvU8 _NV_GPU_CLIENT_ILLUM_ZONE_INFO_V1::rsvd [64]
} data
The documentation for this struct was generated from the following file:


Data Fields
_NV_GPU_CLIENT_ILLUM_ZONE_INFO_PARAMS_V1 Struct Reference
OpenGL APIs

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 numIllumZones
NvU8 rsvd [64]
NV_GPU_CLIENT_ILLUM_ZONE_INFO_V1 zones [NV_GPU_CLIENT_ILLUM_ZONE_NUM_ZONES_MAX]
The documentation for this struct was generated from the following file:


Data Fields
_NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_RGB_PARAMS Struct Reference
OpenGL APIs

#include <nvapi.h>

Data Fields

NvU8 colorR
NvU8 colorG
NvU8 colorB
NvU8 brightnessPct

Detailed Description

Used in NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_RGB Parameters required to represent control mode of type NV_GPU_CLIENT_ILLUM_CTRL_MODE_MANUAL_RGB.

The documentation for this struct was generated from the following file:


Data Fields
_NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_RGB Struct Reference
OpenGL APIs

#include <nvapi.h>

Data Fields

NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_RGB_PARAMS rgbParams

Detailed Description

Used in NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_RGB Data required to represent control mode of type NV_GPU_CLIENT_ILLUM_CTRL_MODE_MANUAL_RGB.

The documentation for this struct was generated from the following file:


Data Fields
_NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR Struct Reference
OpenGL APIs

#include <nvapi.h>

Data Fields

NV_GPU_CLIENT_ILLUM_PIECEWISE_LINEAR_CYCLE_TYPE cycleType
NvU8 grpCount
NvU16 riseTimems
NvU16 fallTimems
NvU16 ATimems
NvU16 BTimems
NvU16 grpIdleTimems
NvU16 phaseOffsetms

Detailed Description

Used in NV_GPU_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR_RGB Data required to represent control mode of type NV_GPU_ILLUM_CTRL_MODE_PIECEWISE_LINEAR_RGB.

The documentation for this struct was generated from the following file:


Data Fields
_NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR_RGB Struct Reference
OpenGL APIs

#include <nvapi.h>

Data Fields

NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_RGB_PARAMS rgbParams [NV_GPU_CLIENT_ILLUM_CTRL_MODE_PIECEWISE_LINEAR_COLOR_ENDPOINTS]
NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR piecewiseLinearData

Detailed Description

Used in NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_RGB Data required to represent control mode of type NV_GPU_CLIENT_ILLUM_CTRL_MODE_PIECEWISE_LINEAR_RGB.

The documentation for this struct was generated from the following file:


Data Fields
_NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_RGB Struct Reference
OpenGL APIs

#include <nvapi.h>

Data Fields

union {
NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_RGB _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_RGB::manualRGB
NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR_RGB _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_RGB::piecewiseLinearRGB
NvU8 _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_RGB::rsvd [64]
} data

Detailed Description

Used in NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_V1 Describes the control data for illumination zone of type NV_GPU_CLIENT_ILLUM_ZONE_TYPE_RGB.

The documentation for this struct was generated from the following file:


Data Fields
_NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_COLOR_FIXED_PARAMS Struct Reference
OpenGL APIs

#include <nvapi.h>

Data Fields

NvU8 brightnessPct

Detailed Description

Used in NV_GPU_ILLUM_ZONE_CONTROL_DATA_MANUAL_COLOR_FIXED Parameters required to represent control mode of type NV_GPU_ILLUM_CTRL_MODE_MANUAL_RGB.

The documentation for this struct was generated from the following file:


Data Fields
_NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_COLOR_FIXED Struct Reference
OpenGL APIs

#include <nvapi.h>

Data Fields

NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_COLOR_FIXED_PARAMS colorFixedParams

Detailed Description

Used in NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_COLOR_FIXED Data required to represent control mode of type NV_GPU_CLIENT_ILLUM_CTRL_MODE_MANUAL_RGB.

The documentation for this struct was generated from the following file:


Data Fields
_NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR_COLOR_FIXED Struct Reference
OpenGL APIs

#include <nvapi.h>

Data Fields

NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_COLOR_FIXED_PARAMS colorFixedParams [NV_GPU_CLIENT_ILLUM_CTRL_MODE_PIECEWISE_LINEAR_COLOR_ENDPOINTS]
NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR piecewiseLinearData

Detailed Description

Used in NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_COLOR_FIXED Data required to represent control mode of type NV_GPU_CLIENT_ILLUM_CTRL_MODE_PIECEWISE_LINEAR_RGB.

The documentation for this struct was generated from the following file:


Data Fields
_NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_COLOR_FIXED Struct Reference
OpenGL APIs

#include <nvapi.h>

Data Fields

union {
NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_COLOR_FIXED _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_COLOR_FIXED::manualColorFixed
NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR_COLOR_FIXED _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_COLOR_FIXED::piecewiseLinearColorFixed
NvU8 _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_COLOR_FIXED::rsvd [64]
} data

Detailed Description

Used in NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_V1 Describes the control data for illum zone of type NV_GPU_CLIENT_ILLUM_ZONE_TYPE_COLOR_FIXED.

The documentation for this struct was generated from the following file:


Data Fields
_NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_RGBW_PARAMS Struct Reference
OpenGL APIs

#include <nvapi.h>

Data Fields

NvU8 colorR
NvU8 colorG
NvU8 colorB
NvU8 colorW
NvU8 brightnessPct

Detailed Description

Used in NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_RGBW Parameters required to represent control mode of type NV_GPU_CLIENT_ILLUM_CTRL_MODE_MANUAL_RGBW.

The documentation for this struct was generated from the following file:


Data Fields
_NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_RGBW Struct Reference
OpenGL APIs

#include <nvapi.h>

Data Fields

NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_RGBW_PARAMS rgbwParams

Detailed Description

Used in NV_GPU_ILLUM_ZONE_CONTROL_DATA_RGBW Data required to represent control mode of type NV_GPU_ILLUM_CTRL_MODE_MANUAL_RGBW.

The documentation for this struct was generated from the following file:


Data Fields
_NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR_RGBW Struct Reference
OpenGL APIs

#include <nvapi.h>

Data Fields

NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_RGBW_PARAMS rgbwParams [NV_GPU_CLIENT_ILLUM_CTRL_MODE_PIECEWISE_LINEAR_COLOR_ENDPOINTS]
NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR piecewiseLinearData

Detailed Description

Used in NV_GPU_ILLUM_ZONE_CONTROL_DATA_RGBW Data required to represent control mode of type NV_GPU_ILLUM_CTRL_MODE_PIECEWISE_LINEAR_RGBW.

The documentation for this struct was generated from the following file:


Data Fields
_NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_RGBW Struct Reference
OpenGL APIs

#include <nvapi.h>

Data Fields

union {
NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_RGBW _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_RGBW::manualRGBW
NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR_RGBW _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_RGBW::piecewiseLinearRGBW
NvU8 _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_RGBW::rsvd [64]
} data

Detailed Description

Used in NV_GPU_ILLUM_ZONE_CONTROL_V1 Describes the control data for illum zone of type NV_GPU_ILLUM_ZONE_TYPE_RGBW.

The documentation for this struct was generated from the following file:


Data Fields
_NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_SINGLE_COLOR_PARAMS Struct Reference
OpenGL APIs

#include <nvapi.h>

Data Fields

NvU8 brightnessPct

Detailed Description

Used in NV_GPU_ILLUM_ZONE_CONTROL_DATA_MANUAL_SINGLE_COLOR Parameters required to represent control mode of type NV_GPU_ILLUM_CTRL_MODE_MANUAL_SINGLE_COLOR.

The documentation for this struct was generated from the following file:


Data Fields
_NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_SINGLE_COLOR Struct Reference
OpenGL APIs

#include <nvapi.h>

Data Fields

NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_SINGLE_COLOR_PARAMS singleColorParams

Detailed Description

Used in NV_GPU_ILLUM_ZONE_CONTROL_DATA_SINGLE_COLOR Data required to represent control mode of type NV_GPU_ILLUM_CTRL_MODE_MANUAL_SINGLE_COLOR.

The documentation for this struct was generated from the following file:


Data Fields
_NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR_SINGLE_COLOR Struct Reference
OpenGL APIs

#include <nvapi.h>

Data Fields

NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_SINGLE_COLOR_PARAMS singleColorParams [NV_GPU_CLIENT_ILLUM_CTRL_MODE_PIECEWISE_LINEAR_COLOR_ENDPOINTS]
NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR piecewiseLinearData

Detailed Description

Used in NV_GPU_ILLUM_ZONE_CONTROL_DATA_SINGLE_COLOR Data required to represent control mode of type NV_GPU_ILLUM_CTRL_MODE_PIECEWISE_LINEAR_SINGLE_COLOR.

The documentation for this struct was generated from the following file:


Data Fields
_NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_SINGLE_COLOR Struct Reference
OpenGL APIs

#include <nvapi.h>

Data Fields

union {
NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_SINGLE_COLOR _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_SINGLE_COLOR::manualSingleColor
NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR_SINGLE_COLOR _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_SINGLE_COLOR::piecewiseLinearSingleColor
NvU8 _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_SINGLE_COLOR::rsvd [64]
} data

Detailed Description

Used in NV_GPU_ILLUM_ZONE_CONTROL_V1 Describes the control data for illum zone of type NV_GPU_ILLUM_ZONE_TYPE_SINGLE_COLOR.

The documentation for this struct was generated from the following file:


Data Fields
_NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_V1 Struct Reference
OpenGL APIs

#include <nvapi.h>

Data Fields

NV_GPU_CLIENT_ILLUM_ZONE_TYPE type
NV_GPU_CLIENT_ILLUM_CTRL_MODE ctrlMode
union {
NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_RGB _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_V1::rgb
NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_COLOR_FIXED _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_V1::colorFixed
NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_RGBW _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_V1::rgbw
NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_SINGLE_COLOR _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_V1::singleColor
NvU8 _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_V1::rsvd [64]
} data
The documentation for this struct was generated from the following file:


Data Fields
_NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_PARAMS_V1 Struct Reference
OpenGL APIs

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 | bDefault: 1
NvU32 | rsvdField: 31
NvU32 numIllumZonesControl
NvU8 | rsvd [64]
NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_V1 zones [NV_GPU_CLIENT_ILLUM_ZONE_NUM_ZONES_MAX]
The documentation for this struct was generated from the following file:


Data Fields
_NV_HDMI_SUPPORT_INFO_V2 Struct Reference
OpenGL APIs

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 | isGpuHDMICapable: 1
NvU32 | isMonUnderscanCapable: 1
NvU32 | isMonBasicAudioCapable: 1
NvU32 | isMonYCbCr444Capable: 1
NvU32 | isMonYCbCr422Capable: 1
NvU32 | isMonxvYCC601Capable: 1
NvU32 | isMonxvYCC709Capable: 1
NvU32 | isMonHDMI: 1
NvU32 | isMonsYCC601Capable: 1
NvU32 | isMonAdobeYCC601Capable: 1
NvU32 | isMonAdobeRGBCapable: 1
NvU32 | reserved: 21
NvU32 EDID861ExtRev
The documentation for this struct was generated from the following file:


Data Fields
NV_INFOFRAME_PROPERTY Struct Reference
OpenGL APIs

#include <nvapi.h>

Data Fields

NvU32 | mode: 4
NvU32 | blackList: 2
NvU32 | reserved: 10
NvU32 | version: 8
NvU32 | length: 8
The documentation for this struct was generated from the following file:


Data Fields
NV_INFOFRAME_VIDEO Struct Reference
OpenGL APIs

#include <nvapi.h>

Data Fields

NvU32 | vic: 8
NvU32 | pixelRepeat: 5
NvU32 | colorSpace: 3
NvU32 | colorimetry: 3
NvU32 | extendedColorimetry: 4
NvU32 | rgbQuantizationRange: 3
NvU32 | yccQuantizationRange: 3
NvU32 | itContent: 2
NvU32 | contentTypes: 3
NvU32 | scanInfo: 3
NvU32 | activeFormatInfoPresent: 2
NvU32 | activeFormatAspectRatio: 5
NvU32 | picAspectRatio: 3
NvU32 | nonuniformScaling: 3
NvU32 | barInfo: 3
NvU32 | top_bar: 17
NvU32 | bottom_bar: 17
NvU32 | left_bar: 17
NvU32 | right_bar: 17
NvU32 | Future17: 2
NvU32 | Future47: 2

Detailed Description

Adding an Auto bit to each field.

The documentation for this struct was generated from the following file:


Data Fields
NV_INFOFRAME_AUDIO Struct Reference
OpenGL APIs

#include <nvapi.h>

Data Fields

NvU32 | codingType: 5
NvU32 | codingExtensionType: 6
NvU32 | sampleSize: 3
NvU32 | sampleRate: 4
NvU32 | channelCount: 4
NvU32 | speakerPlacement: 9
NvU32 | downmixInhibit: 2
NvU32 | lfePlaybackLevel: 3
NvU32 | levelShift: 5
NvU32 | Future12: 2
NvU32 | Future2x: 4
NvU32 | Future3x: 4
NvU32 | Future52: 2
NvU32 | Future6: 9
NvU32 | Future7: 9
NvU32 | Future8: 9
NvU32 | Future9: 9
NvU32 | Future10: 9
The documentation for this struct was generated from the following file:


Data Fields
NV_INFOFRAME_DATA Struct Reference
OpenGL APIs

#include <nvapi.h>

Data Fields

NvU32 version
NvU16 size
NvU8 cmd
NvU8 type
union {
NV_INFOFRAME_PROPERTY NV_INFOFRAME_DATA::property
NV_INFOFRAME_AUDIO NV_INFOFRAME_DATA::audio
NV_INFOFRAME_VIDEO NV_INFOFRAME_DATA::video
} infoframe
The documentation for this struct was generated from the following file:


Data Fields
_NV_COLOR_DATA_V1 Struct Reference
OpenGL APIs

#include <nvapi.h>

Data Fields

NvU32 version
NvU16 size
NvU8 cmd
struct {
NvU8 _NV_COLOR_DATA_V1::colorFormat
NvU8 _NV_COLOR_DATA_V1::colorimetry
} data
The documentation for this struct was generated from the following file:


Data Fields
_NV_COLOR_DATA_V2 Struct Reference
OpenGL APIs

#include <nvapi.h>

Data Fields

NvU32 version
NvU16 size
NvU8 cmd
struct {
NvU8 _NV_COLOR_DATA_V2::colorFormat
NvU8 _NV_COLOR_DATA_V2::colorimetry
NvU8 _NV_COLOR_DATA_V2::dynamicRange
} data
The documentation for this struct was generated from the following file:


Data Fields
_NV_COLOR_DATA_V3 Struct Reference
OpenGL APIs

#include <nvapi.h>

Data Fields

NvU32 version
NvU16 size
NvU8 cmd
struct {
NvU8 _NV_COLOR_DATA_V3::colorFormat
NvU8 _NV_COLOR_DATA_V3::colorimetry
NvU8 _NV_COLOR_DATA_V3::dynamicRange
NV_BPC _NV_COLOR_DATA_V3::bpc
} data
The documentation for this struct was generated from the following file:


Data Fields
_NV_COLOR_DATA_V4 Struct Reference
OpenGL APIs

#include <nvapi.h>

Data Fields

NvU32 version
NvU16 size
NvU8 cmd
struct {
NvU8 _NV_COLOR_DATA_V4::colorFormat
NvU8 _NV_COLOR_DATA_V4::colorimetry
NvU8 _NV_COLOR_DATA_V4::dynamicRange
NV_BPC _NV_COLOR_DATA_V4::bpc
NV_COLOR_SELECTION_POLICY _NV_COLOR_DATA_V4::colorSelectionPolicy
} data
The documentation for this struct was generated from the following file:


Data Fields
_NV_COLOR_DATA_V5 Struct Reference
OpenGL APIs

#include <nvapi.h>

Data Fields

NvU32 version
NvU16 size
NvU8 cmd
struct {
NvU8 _NV_COLOR_DATA_V5::colorFormat
NvU8 _NV_COLOR_DATA_V5::colorimetry
NvU8 _NV_COLOR_DATA_V5::dynamicRange
NV_BPC _NV_COLOR_DATA_V5::bpc
NV_COLOR_SELECTION_POLICY _NV_COLOR_DATA_V5::colorSelectionPolicy
NV_DESKTOP_COLOR_DEPTH _NV_COLOR_DATA_V5::depth
} data
The documentation for this struct was generated from the following file:


Data Fields
_NV_HDR_CAPABILITIES_V1 Struct Reference
OpenGL APIs

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 | isST2084EotfSupported:1
NvU32 | isTraditionalHdrGammaSupported:1
NvU32 | isEdrSupported:1
NvU32 | driverExpandDefaultHdrParameters:1
NvU32 | isTraditionalSdrGammaSupported:1
NvU32 | reserved:27
NV_STATIC_METADATA_DESCRIPTOR_ID static_metadata_descriptor_id
struct {
NvU16 _NV_HDR_CAPABILITIES_V1::displayPrimary_x0
NvU16 _NV_HDR_CAPABILITIES_V1::displayPrimary_y0
NvU16 _NV_HDR_CAPABILITIES_V1::displayPrimary_x1
NvU16 _NV_HDR_CAPABILITIES_V1::displayPrimary_y1
NvU16 _NV_HDR_CAPABILITIES_V1::displayPrimary_x2
NvU16 _NV_HDR_CAPABILITIES_V1::displayPrimary_y2
NvU16 _NV_HDR_CAPABILITIES_V1::displayWhitePoint_x
NvU16 _NV_HDR_CAPABILITIES_V1::displayWhitePoint_y
NvU16 _NV_HDR_CAPABILITIES_V1::desired_content_max_luminance
NvU16 _NV_HDR_CAPABILITIES_V1::desired_content_min_luminance
NvU16 _NV_HDR_CAPABILITIES_V1::desired_content_max_frame_average_luminance
} display_data
The documentation for this struct was generated from the following file:


Data Fields
_NV_HDR_CAPABILITIES_V2 Struct Reference
OpenGL APIs

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 | isST2084EotfSupported:1
NvU32 | isTraditionalHdrGammaSupported:1
NvU32 | isEdrSupported:1
NvU32 | driverExpandDefaultHdrParameters:1
NvU32 | isTraditionalSdrGammaSupported:1
NvU32 | isDolbyVisionSupported:1
NvU32 | reserved:26
NV_STATIC_METADATA_DESCRIPTOR_ID static_metadata_descriptor_id
struct {
NvU16 _NV_HDR_CAPABILITIES_V2::displayPrimary_x0
NvU16 _NV_HDR_CAPABILITIES_V2::displayPrimary_y0
NvU16 _NV_HDR_CAPABILITIES_V2::displayPrimary_x1
NvU16 _NV_HDR_CAPABILITIES_V2::displayPrimary_y1
NvU16 _NV_HDR_CAPABILITIES_V2::displayPrimary_x2
NvU16 _NV_HDR_CAPABILITIES_V2::displayPrimary_y2
NvU16 _NV_HDR_CAPABILITIES_V2::displayWhitePoint_x
NvU16 _NV_HDR_CAPABILITIES_V2::displayWhitePoint_y
NvU16 _NV_HDR_CAPABILITIES_V2::desired_content_max_luminance
NvU16 _NV_HDR_CAPABILITIES_V2::desired_content_min_luminance
NvU16 _NV_HDR_CAPABILITIES_V2::desired_content_max_frame_average_luminance
} display_data
struct {
NvU32 _NV_HDR_CAPABILITIES_V2::VSVDB_version: 3
NvU32 _NV_HDR_CAPABILITIES_V2::dm_version: 8
NvU32 _NV_HDR_CAPABILITIES_V2::supports_2160p60hz: 1
NvU32 _NV_HDR_CAPABILITIES_V2::supports_YUV422_12bit: 1
NvU32 _NV_HDR_CAPABILITIES_V2::supports_global_dimming: 1
NvU32 _NV_HDR_CAPABILITIES_V2::colorimetry: 1
NvU32 _NV_HDR_CAPABILITIES_V2::supports_backlight_control: 2
NvU32 _NV_HDR_CAPABILITIES_V2::backlt_min_luma: 2
NvU32 _NV_HDR_CAPABILITIES_V2::interface_supported_by_sink: 2
NvU32 _NV_HDR_CAPABILITIES_V2::supports_10b_12b_444: 2
NvU32 _NV_HDR_CAPABILITIES_V2::reserved: 9
NvU16 _NV_HDR_CAPABILITIES_V2::target_min_luminance
NvU16 _NV_HDR_CAPABILITIES_V2::target_max_luminance
NvU16 _NV_HDR_CAPABILITIES_V2::cc_red_x
NvU16 _NV_HDR_CAPABILITIES_V2::cc_red_y
NvU16 _NV_HDR_CAPABILITIES_V2::cc_green_x
NvU16 _NV_HDR_CAPABILITIES_V2::cc_green_y
NvU16 _NV_HDR_CAPABILITIES_V2::cc_blue_x
NvU16 _NV_HDR_CAPABILITIES_V2::cc_blue_y
NvU16 _NV_HDR_CAPABILITIES_V2::cc_white_x
NvU16 _NV_HDR_CAPABILITIES_V2::cc_white_y
} dv_static_metadata
The documentation for this struct was generated from the following file:


Data Fields
_NV_HDR_CAPABILITIES_V3 Struct Reference
OpenGL APIs

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 | isST2084EotfSupported:1
NvU32 | isTraditionalHdrGammaSupported:1
NvU32 | isEdrSupported:1
NvU32 | driverExpandDefaultHdrParameters:1
NvU32 | isTraditionalSdrGammaSupported:1
NvU32 | isDolbyVisionSupported:1
NvU32 | isHdr10PlusSupported:1
NvU32 | isHdr10PlusGamingSupported:1
NvU32 | reserved:24
NV_STATIC_METADATA_DESCRIPTOR_ID static_metadata_descriptor_id
struct {
NvU16 _NV_HDR_CAPABILITIES_V3::displayPrimary_x0
NvU16 _NV_HDR_CAPABILITIES_V3::displayPrimary_y0
NvU16 _NV_HDR_CAPABILITIES_V3::displayPrimary_x1
NvU16 _NV_HDR_CAPABILITIES_V3::displayPrimary_y1
NvU16 _NV_HDR_CAPABILITIES_V3::displayPrimary_x2
NvU16 _NV_HDR_CAPABILITIES_V3::displayPrimary_y2
NvU16 _NV_HDR_CAPABILITIES_V3::displayWhitePoint_x
NvU16 _NV_HDR_CAPABILITIES_V3::displayWhitePoint_y
NvU16 _NV_HDR_CAPABILITIES_V3::desired_content_max_luminance
NvU16 _NV_HDR_CAPABILITIES_V3::desired_content_min_luminance
NvU16 _NV_HDR_CAPABILITIES_V3::desired_content_max_frame_average_luminance
} display_data
struct {
NvU32 _NV_HDR_CAPABILITIES_V3::VSVDB_version: 3
NvU32 _NV_HDR_CAPABILITIES_V3::dm_version: 8
NvU32 _NV_HDR_CAPABILITIES_V3::supports_2160p60hz: 1
NvU32 _NV_HDR_CAPABILITIES_V3::supports_YUV422_12bit: 1
NvU32 _NV_HDR_CAPABILITIES_V3::supports_global_dimming: 1
NvU32 _NV_HDR_CAPABILITIES_V3::colorimetry: 1
NvU32 _NV_HDR_CAPABILITIES_V3::supports_backlight_control: 2
NvU32 _NV_HDR_CAPABILITIES_V3::backlt_min_luma: 2
NvU32 _NV_HDR_CAPABILITIES_V3::interface_supported_by_sink: 2
NvU32 _NV_HDR_CAPABILITIES_V3::supports_10b_12b_444: 2
NvU32 _NV_HDR_CAPABILITIES_V3::parity: 1
NvU32 _NV_HDR_CAPABILITIES_V3::reserved: 8
NvU16 _NV_HDR_CAPABILITIES_V3::target_min_luminance
NvU16 _NV_HDR_CAPABILITIES_V3::target_max_luminance
NvU16 _NV_HDR_CAPABILITIES_V3::cc_red_x
NvU16 _NV_HDR_CAPABILITIES_V3::cc_red_y
NvU16 _NV_HDR_CAPABILITIES_V3::cc_green_x
NvU16 _NV_HDR_CAPABILITIES_V3::cc_green_y
NvU16 _NV_HDR_CAPABILITIES_V3::cc_blue_x
NvU16 _NV_HDR_CAPABILITIES_V3::cc_blue_y
NvU16 _NV_HDR_CAPABILITIES_V3::cc_white_x
NvU16 _NV_HDR_CAPABILITIES_V3::cc_white_y
} dv_static_metadata
struct {
NvU16 _NV_HDR_CAPABILITIES_V3::application_version: 2
NvU16 _NV_HDR_CAPABILITIES_V3::full_frame_peak_luminance_index: 2
NvU16 _NV_HDR_CAPABILITIES_V3::peak_luminance_index: 4
NvU16 _NV_HDR_CAPABILITIES_V3::reserved: 8
} hdr10plus_vsvdb
The documentation for this struct was generated from the following file:


Data Fields
_NV_HDR_COLOR_DATA_V1 Struct Reference
OpenGL APIs

#include <nvapi.h>

Data Fields

NvU32 version
NV_HDR_CMD cmd
NV_HDR_MODE hdrMode
NV_STATIC_METADATA_DESCRIPTOR_ID static_metadata_descriptor_id
struct {
NvU16 _NV_HDR_COLOR_DATA_V1::displayPrimary_x0
NvU16 _NV_HDR_COLOR_DATA_V1::displayPrimary_y0
NvU16 _NV_HDR_COLOR_DATA_V1::displayPrimary_x1
NvU16 _NV_HDR_COLOR_DATA_V1::displayPrimary_y1
NvU16 _NV_HDR_COLOR_DATA_V1::displayPrimary_x2
NvU16 _NV_HDR_COLOR_DATA_V1::displayPrimary_y2
NvU16 _NV_HDR_COLOR_DATA_V1::displayWhitePoint_x
NvU16 _NV_HDR_COLOR_DATA_V1::displayWhitePoint_y
NvU16 _NV_HDR_COLOR_DATA_V1::max_display_mastering_luminance
NvU16 _NV_HDR_COLOR_DATA_V1::min_display_mastering_luminance
NvU16 _NV_HDR_COLOR_DATA_V1::max_content_light_level
NvU16 _NV_HDR_COLOR_DATA_V1::max_frame_average_light_level
} mastering_display_data
The documentation for this struct was generated from the following file:


Data Fields
_NV_HDR_COLOR_DATA_V2 Struct Reference
OpenGL APIs

#include <nvapi.h>

Data Fields

NvU32 version
NV_HDR_CMD cmd
NV_HDR_MODE hdrMode
NV_STATIC_METADATA_DESCRIPTOR_ID static_metadata_descriptor_id
struct {
NvU16 _NV_HDR_COLOR_DATA_V2::displayPrimary_x0
NvU16 _NV_HDR_COLOR_DATA_V2::displayPrimary_y0
NvU16 _NV_HDR_COLOR_DATA_V2::displayPrimary_x1
NvU16 _NV_HDR_COLOR_DATA_V2::displayPrimary_y1
NvU16 _NV_HDR_COLOR_DATA_V2::displayPrimary_x2
NvU16 _NV_HDR_COLOR_DATA_V2::displayPrimary_y2
NvU16 _NV_HDR_COLOR_DATA_V2::displayWhitePoint_x
NvU16 _NV_HDR_COLOR_DATA_V2::displayWhitePoint_y
NvU16 _NV_HDR_COLOR_DATA_V2::max_display_mastering_luminance
NvU16 _NV_HDR_COLOR_DATA_V2::min_display_mastering_luminance
NvU16 _NV_HDR_COLOR_DATA_V2::max_content_light_level
NvU16 _NV_HDR_COLOR_DATA_V2::max_frame_average_light_level
} mastering_display_data
NV_COLOR_FORMAT hdrColorFormat
NV_DYNAMIC_RANGE hdrDynamicRange
NV_BPC hdrBpc
The documentation for this struct was generated from the following file:


Data Fields
_NV_HDR_METADATA_V1 Struct Reference
OpenGL APIs

#include <nvapi.h>

Data Fields

NvU32 version
NvU16 displayPrimary_x0
NvU16 displayPrimary_y0
NvU16 displayPrimary_x1
NvU16 displayPrimary_y1
NvU16 displayPrimary_x2
NvU16 displayPrimary_y2
NvU16 displayWhitePoint_x
NvU16 displayWhitePoint_y
NvU16 max_display_mastering_luminance
NvU16 min_display_mastering_luminance
NvU16 max_content_light_level
NvU16 max_frame_average_light_level
The documentation for this struct was generated from the following file:


Data Fields
_NV_MONITOR_CAPS_VCDB Struct Reference
OpenGL APIs

#include <nvapi.h>

Data Fields

NvU8 | quantizationRangeYcc: 1
NvU8 | quantizationRangeRgb: 1
NvU8 | scanInfoPreferredVideoFormat: 2
NvU8 | scanInfoITVideoFormats: 2
NvU8 | scanInfoCEVideoFormats: 2
The documentation for this struct was generated from the following file:


Data Fields
_NV_MONITOR_CAPS_VSDB Struct Reference
OpenGL APIs

#include <nvapi.h>

Data Fields

NvU8 | sourcePhysicalAddressB: 4
NvU8 | sourcePhysicalAddressA: 4
NvU8 | sourcePhysicalAddressD: 4
NvU8 | sourcePhysicalAddressC: 4
NvU8 | supportDualDviOperation: 1
NvU8 | reserved6: 2
NvU8 | supportDeepColorYCbCr444: 1
NvU8 | supportDeepColor30bits: 1
NvU8 | supportDeepColor36bits: 1
NvU8 | supportDeepColor48bits: 1
NvU8 | supportAI: 1
NvU8 maxTmdsClock
NvU8 | cnc0SupportGraphicsTextContent: 1
NvU8 | cnc1SupportPhotoContent: 1
NvU8 | cnc2SupportCinemaContent: 1
NvU8 | cnc3SupportGameContent: 1
NvU8 | reserved8: 1
NvU8 | hasVicEntries: 1
NvU8 | hasInterlacedLatencyField: 1
NvU8 | hasLatencyField: 1
NvU8 videoLatency
NvU8 audioLatency
NvU8 interlacedVideoLatency
NvU8 interlacedAudioLatency
NvU8 | reserved13: 7
NvU8 | has3dEntries: 1
NvU8 | hdmi3dLength: 5
NvU8 | hdmiVicLength: 3
NvU8 | hdmi_vic [7]
NvU8 | hdmi_3d [31]

Detailed Description

See NvAPI_DISP_GetMonitorCapabilities().

The documentation for this struct was generated from the following file:


Data Fields
_NV_MONITOR_CAPS_GENERIC Struct Reference
OpenGL APIs

#include <nvapi.h>

Data Fields

NvU8 | supportVRR: 1
NvU8 | supportULMB: 1
NvU8 | isTrueGsync: 1
NvU8 | isRLACapable: 1
NvU8 | currentlyCapableOfVRR: 1
NvU8 | reserved: 3
The documentation for this struct was generated from the following file:


Data Fields
_NV_MONITOR_CAPABILITIES_V1 Struct Reference
OpenGL APIs

#include <nvapi.h>

Data Fields

NvU32 version
NvU16 size
NvU32 infoType
NvU32 connectorType
NvU8 bIsValidInfo: 1
union {
NV_MONITOR_CAPS_VSDB _NV_MONITOR_CAPABILITIES_V1::vsdb
NV_MONITOR_CAPS_VCDB _NV_MONITOR_CAPABILITIES_V1::vcdb
NV_MONITOR_CAPS_GENERIC _NV_MONITOR_CAPABILITIES_V1::caps
} data

Detailed Description

See NvAPI_DISP_GetMonitorCapabilities().

The documentation for this struct was generated from the following file:


Data Fields
_NV_EDID_DATA_V2 Struct Reference
OpenGL APIs

#include <nvapi.h>

Data Fields

NvU32 version
NvU8 * pEDID
NvU32 sizeOfEDID
NvU32 reserved [8]
The documentation for this struct was generated from the following file:


Data Fields
_NV_GET_ADAPTIVE_SYNC_DATA_V1 Struct Reference
OpenGL APIs

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 maxFrameInterval
NvU32 | bDisableAdaptiveSync: 1
NvU32 | bDisableFrameSplitting: 1
NvU32 | reserved: 30
NvU32 lastFlipRefreshCount
NvU64 lastFlipTimeStamp
NvU32 | reservedEx [4]
The documentation for this struct was generated from the following file:


Data Fields
_NV_SET_ADAPTIVE_SYNC_DATA_V1 Struct Reference
OpenGL APIs

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 maxFrameInterval
NvU32 | bDisableAdaptiveSync: 1
NvU32 | bDisableFrameSplitting: 1
NvU32 | reserved: 30
NvU32 | reservedEx [7]
The documentation for this struct was generated from the following file:


Data Fields
_NV_GET_VIRTUAL_REFRESH_RATE_DATA_V1 Struct Reference
OpenGL APIs

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 frameIntervalUs
NvU32 reservedEx [8]
The documentation for this struct was generated from the following file:


Data Fields
_NV_SET_VIRTUAL_REFRESH_RATE_DATA_V1 Struct Reference
OpenGL APIs

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 frameIntervalUs
NvU32 reservedEx [8]
The documentation for this struct was generated from the following file:


Data Fields
_NV_MANAGED_DEDICATED_DISPLAY_INFO Struct Reference
OpenGL APIs

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 displayId
NvU32 | isAcquired: 1
NvU32 | isMosaic: 1
NvU32 | reserved: 30

Detailed Description

SUPPORTED OS: Windows 10 and higher

The documentation for this struct was generated from the following file:


Data Fields
_NV_MANAGED_DEDICATED_DISPLAY_METADATA Struct Reference
OpenGL APIs

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 displayId
NvU32 | bSetPosition: 1
NvU32 | bRemovePosition: 1
NvU32 | bPositionIsAvailable: 1
NvU32 | bSetName: 1
NvU32 | bRemoveName: 1
NvU32 | bNameIsAvailable: 1
NvU32 | reserved: 26
NvS32 positionX
NvS32 positionY
NvAPI_ShortString name

Detailed Description

SUPPORTED OS: Windows 11 and higher

The documentation for this struct was generated from the following file:


Data Fields
_NV_MOSAIC_GRID_TOPO_DISPLAY_V2 Struct Reference
OpenGL APIs

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 displayId
NvS32 overlapX
NvS32 overlapY
NV_ROTATE rotation
NvU32 cloneGroup
NV_PIXEL_SHIFT_TYPE pixelShiftType
The documentation for this struct was generated from the following file:


Data Fields
_NV_MOSAIC_GRID_TOPO_V1 Struct Reference
OpenGL APIs

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 rows
NvU32 columns
NvU32 displayCount
NvU32 | applyWithBezelCorrect: 1
NvU32 | immersiveGaming: 1
NvU32 | baseMosaic: 1
NvU32 | driverReloadAllowed: 1
NvU32 | acceleratePrimaryDisplay: 1
NvU32 | reserved: 27
NV_MOSAIC_GRID_TOPO_DISPLAY_V1 displays [NV_MOSAIC_MAX_DISPLAYS]
NV_MOSAIC_DISPLAY_SETTING_V1 displaySettings
The documentation for this struct was generated from the following file:


Data Fields
_NV_MOSAIC_GRID_TOPO_V2 Struct Reference
OpenGL APIs

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 rows
NvU32 columns
NvU32 displayCount
NvU32 | applyWithBezelCorrect: 1
NvU32 | immersiveGaming: 1
NvU32 | baseMosaic: 1
NvU32 | driverReloadAllowed: 1
NvU32 | acceleratePrimaryDisplay: 1
NvU32 | pixelShift: 1
NvU32 | reserved: 26
NV_MOSAIC_GRID_TOPO_DISPLAY_V2 displays [NV_MOSAIC_MAX_DISPLAYS]
NV_MOSAIC_DISPLAY_SETTING_V1 displaySettings
The documentation for this struct was generated from the following file:


Data Fields
_NV_GSYNC_CAPABILITIES_V1 Struct Reference
OpenGL APIs

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 boardId
NvU32 revision
NvU32 capFlags

Detailed Description

Used in NvAPI_GSync_QueryCapabilities().

The documentation for this struct was generated from the following file:


Data Fields
_NV_GSYNC_CAPABILITIES_V2 Struct Reference
OpenGL APIs

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 boardId
NvU32 revision
NvU32 capFlags
NvU32 extendedRevision
The documentation for this struct was generated from the following file:


Data Fields
_NV_GSYNC_CAPABILITIES_V3 Struct Reference
OpenGL APIs

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 boardId
NvU32 revision
NvU32 capFlags
NvU32 extendedRevision
NvU32 | bIsMulDivSupported: 1
NvU32 | reserved: 31
NvU32 maxMulDivValue
The documentation for this struct was generated from the following file:


Data Fields
_NV_GSYNC_GPU Struct Reference
OpenGL APIs

#include <nvapi.h>

Data Fields

NvU32 version
NvPhysicalGpuHandle | hPhysicalGpu
NVAPI_GSYNC_GPU_TOPOLOGY_CONNECTOR connector
NvPhysicalGpuHandle | hProxyPhysicalGpu
NvU32 | isSynced: 1
NvU32 | reserved: 31
The documentation for this struct was generated from the following file:


Data Fields
_NV_GSYNC_DISPLAY Struct Reference
OpenGL APIs

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 displayId
NvU32 | isMasterable: 1
NvU32 | reserved: 31
NVAPI_GSYNC_DISPLAY_SYNC_STATE syncState
The documentation for this struct was generated from the following file:


Data Fields
_NV_GSYNC_DELAY Struct Reference
OpenGL APIs

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 numLines
NvU32 numPixels
NvU32 maxLines
NvU32 minPixels

Detailed Description

Used in NV_GSYNC_CONTROL_PARAMS.

The documentation for this struct was generated from the following file:


Data Fields
_NV_GSYNC_CONTROL_PARAMS_V1 Struct Reference
OpenGL APIs

#include <nvapi.h>

Data Fields

NvU32 version
NVAPI_GSYNC_POLARITY polarity
NVAPI_GSYNC_VIDEO_MODE vmode
NvU32 interval
NVAPI_GSYNC_SYNC_SOURCE source
NvU32 | interlaceMode:1
NvU32 | syncSourceIsOutput:1
NvU32 | reserved:30
NV_GSYNC_DELAY syncSkew
NV_GSYNC_DELAY startupDelay

Detailed Description

Used in NvAPI_GSync_GetControlParameters() and NvAPI_GSync_SetControlParameters().

The documentation for this struct was generated from the following file:


Data Fields
_NV_GSYNC_CONTROL_PARAMS_V2 Struct Reference
OpenGL APIs

#include <nvapi.h>

Data Fields

NvU32 version
NVAPI_GSYNC_POLARITY polarity
NVAPI_GSYNC_VIDEO_MODE vmode
NvU32 interval
NVAPI_GSYNC_SYNC_SOURCE source
NvU32 | interlaceMode:1
NvU32 | syncSourceIsOutput:1
NvU32 | reserved:30
NV_GSYNC_DELAY syncSkew
NV_GSYNC_DELAY startupDelay
NVAPI_GSYNC_MULTIPLY_DIVIDE_MODE multiplyDivideMode
NvU8 multiplyDivideValue
The documentation for this struct was generated from the following file:


Data Fields
_NV_GSYNC_STATUS Struct Reference
OpenGL APIs

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 bIsSynced
NvU32 bIsStereoSynced
NvU32 bIsSyncSignalAvailable

Detailed Description

Used in NvAPI_GSync_GetSyncStatus().

The documentation for this struct was generated from the following file:


Data Fields
_NV_GSYNC_STATUS_PARAMS_V1 Struct Reference
OpenGL APIs | Quadro G-Sync APIs

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 refreshRate
NVAPI_GSYNC_RJ45_IO RJ45_IO [NVAPI_MAX_RJ45_PER_GSYNC]
NvU32 RJ45_Ethernet [NVAPI_MAX_RJ45_PER_GSYNC]
NvU32 houseSyncIncoming
NvU32 bHouseSync

Detailed Description

Used in NvAPI_GSync_GetStatusParameters().

The documentation for this struct was generated from the following file:


Data Fields
_NV_GSYNC_STATUS_PARAMS_V2 Struct Reference
OpenGL APIs

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 refreshRate
NVAPI_GSYNC_RJ45_IO RJ45_IO [NVAPI_MAX_RJ45_PER_GSYNC]
NvU32 RJ45_Ethernet [NVAPI_MAX_RJ45_PER_GSYNC]
NvU32 houseSyncIncoming
NvU32 bHouseSync
NvU32 | bInternalSlave: 1
NvU32 | reserved: 31
The documentation for this struct was generated from the following file:


Functions
GRID License APIs

Functions

NVAPI_INTERFACE | NvAPI_GPU_GetLicensableFeatures (__in NvPhysicalGpuHandle hPhysicalGpu, __inout NV_LICENSABLE_FEATURES *pLicensableFeatures)
#define | NV_LICENSE_MAX_COUNT 3
#define | NV_LICENSE_SIGNATURE_SIZE (128)
#define | NV_LICENSE_INFO_MAX_LENGTH (128)
#define | NV_LICENSE_FEATURE_DETAILS_VER1 MAKE_NVAPI_VERSION(NV_LICENSE_FEATURE_DETAILS_V1, 1)
#define | NV_LICENSE_FEATURE_DETAILS_VER NV_LICENSE_FEATURE_DETAILS_VER1
#define | NV_LICENSABLE_FEATURES_VER1 MAKE_NVAPI_VERSION(NV_LICENSABLE_FEATURES_V1, 1)
#define | NV_LICENSABLE_FEATURES_VER2 MAKE_NVAPI_VERSION(NV_LICENSABLE_FEATURES_V2, 2)
#define | NV_LICENSABLE_FEATURES_VER3 MAKE_NVAPI_VERSION(NV_LICENSABLE_FEATURES_V3, 3)
#define | NV_LICENSABLE_FEATURES_VER4 MAKE_NVAPI_VERSION(NV_LICENSABLE_FEATURES_V4, 4)
#define | NV_LICENSABLE_FEATURES_VER NV_LICENSABLE_FEATURES_VER4
enum _NV_LICENSE_FEATURE_TYPE {
NV_LICENSE_FEATURE_UNKNOWN = 0 , NV_LICENSE_FEATURE_VGPU = 1 , NV_LICENSE_FEATURE_NVIDIA_RTX = 2 , NV_LICENSE_FEATURE_QUADRO = NV_LICENSE_FEATURE_NVIDIA_RTX ,
NV_LICENSE_FEATURE_GAMING = 3 , NV_LICENSE_FEATURE_COMPUTE = 4
}
typedef char | NvAPI_LicenseString[NV_LICENSE_INFO_MAX_LENGTH]
typedef enum _NV_LICENSE_FEATURE_TYPE | NV_LICENSE_FEATURE_TYPE
typedef struct _NV_LICENSE_EXPIRY_DETAILS | NV_LICENSE_EXPIRY_DETAILS
typedef struct _NV_LICENSE_FEATURE_DETAILS_V1 | NV_LICENSE_FEATURE_DETAILS_V1
typedef struct _NV_LICENSE_FEATURE_DETAILS_V2 | NV_LICENSE_FEATURE_DETAILS_V2
typedef struct _NV_LICENSE_FEATURE_DETAILS_V3 | NV_LICENSE_FEATURE_DETAILS_V3
typedef struct _NV_LICENSE_FEATURE_DETAILS_V4 | NV_LICENSE_FEATURE_DETAILS_V4
typedef NV_LICENSE_FEATURE_DETAILS_V1 | NV_LICENSE_FEATURE_DETAILS
typedef struct _NV_LICENSABLE_FEATURES_V1 | NV_LICENSABLE_FEATURES_V1
typedef struct _NV_LICENSABLE_FEATURES_V2 | NV_LICENSABLE_FEATURES_V2
typedef struct _NV_LICENSABLE_FEATURES_V3 | NV_LICENSABLE_FEATURES_V3
typedef struct _NV_LICENSABLE_FEATURES_V4 | NV_LICENSABLE_FEATURES_V4
typedef NV_LICENSABLE_FEATURES_V4 | NV_LICENSABLE_FEATURES

Detailed Description

Interface to the NVIDIA GRID licensing feature

Macro Definition Documentation

◆ NV_LICENSABLE_FEATURES_VER

#define NV_LICENSABLE_FEATURES_VER NV_LICENSABLE_FEATURES_VER4

Maximum number of supported Feature License.

◆ NV_LICENSABLE_FEATURES_VER1

#define NV_LICENSABLE_FEATURES_VER1 MAKE_NVAPI_VERSION(NV_LICENSABLE_FEATURES_V1, 1)

Maximum number of supported Feature License.

◆ NV_LICENSABLE_FEATURES_VER2

#define NV_LICENSABLE_FEATURES_VER2 MAKE_NVAPI_VERSION(NV_LICENSABLE_FEATURES_V2, 2)

Maximum number of supported Feature License.

◆ NV_LICENSABLE_FEATURES_VER3

#define NV_LICENSABLE_FEATURES_VER3 MAKE_NVAPI_VERSION(NV_LICENSABLE_FEATURES_V3, 3)

Maximum number of supported Feature License.

◆ NV_LICENSABLE_FEATURES_VER4

#define NV_LICENSABLE_FEATURES_VER4 MAKE_NVAPI_VERSION(NV_LICENSABLE_FEATURES_V4, 4)

Maximum number of supported Feature License.

◆ NV_LICENSE_FEATURE_DETAILS_VER

#define NV_LICENSE_FEATURE_DETAILS_VER NV_LICENSE_FEATURE_DETAILS_VER1

Maximum number of supported Feature License.

◆ NV_LICENSE_FEATURE_DETAILS_VER1

#define NV_LICENSE_FEATURE_DETAILS_VER1 MAKE_NVAPI_VERSION(NV_LICENSE_FEATURE_DETAILS_V1, 1)

Maximum number of supported Feature License.

◆ NV_LICENSE_INFO_MAX_LENGTH

#define NV_LICENSE_INFO_MAX_LENGTH (128)

Length for Grid License.

◆ NV_LICENSE_MAX_COUNT

#define NV_LICENSE_MAX_COUNT 3

Maximum number of supported Feature License.

◆ NV_LICENSE_SIGNATURE_SIZE

#define NV_LICENSE_SIGNATURE_SIZE (128)

Signature length for GRID License.

Typedef Documentation

◆ NV_LICENSABLE_FEATURES

typedef NV_LICENSABLE_FEATURES_V4 NV_LICENSABLE_FEATURES

Maximum number of supported Feature License.

◆ NV_LICENSABLE_FEATURES_V1

typedef struct _NV_LICENSABLE_FEATURES_V1 NV_LICENSABLE_FEATURES_V1

Licensable features.

◆ NV_LICENSABLE_FEATURES_V2

typedef struct _NV_LICENSABLE_FEATURES_V2 NV_LICENSABLE_FEATURES_V2

Maximum number of supported Feature License.

◆ NV_LICENSABLE_FEATURES_V3

typedef struct _NV_LICENSABLE_FEATURES_V3 NV_LICENSABLE_FEATURES_V3

Maximum number of supported Feature License.

◆ NV_LICENSABLE_FEATURES_V4

typedef struct _NV_LICENSABLE_FEATURES_V4 NV_LICENSABLE_FEATURES_V4

Maximum number of supported Feature License.

◆ NV_LICENSE_EXPIRY_DETAILS

typedef struct _NV_LICENSE_EXPIRY_DETAILS NV_LICENSE_EXPIRY_DETAILS

Used in NV_LICENSE_FEATURE_DETAILS

The 'status' variable holds any one of the following license expiry status codes : 0 - Expiry information not available 1 - Invalid expiry or error fetching expiry 2 - Valid expiry 3 - Expiry not applicable 4 - Permanent expiry

◆ NV_LICENSE_FEATURE_DETAILS

typedef NV_LICENSE_FEATURE_DETAILS_V1 NV_LICENSE_FEATURE_DETAILS

Maximum number of supported Feature License.

◆ NV_LICENSE_FEATURE_DETAILS_V1

typedef struct _NV_LICENSE_FEATURE_DETAILS_V1 NV_LICENSE_FEATURE_DETAILS_V1

Used in NV_LICENSABLE_FEATURES.

◆ NV_LICENSE_FEATURE_DETAILS_V2

typedef struct _NV_LICENSE_FEATURE_DETAILS_V2 NV_LICENSE_FEATURE_DETAILS_V2

Maximum number of supported Feature License.

◆ NV_LICENSE_FEATURE_DETAILS_V3

typedef struct _NV_LICENSE_FEATURE_DETAILS_V3 NV_LICENSE_FEATURE_DETAILS_V3

Maximum number of supported Feature License.

◆ NV_LICENSE_FEATURE_DETAILS_V4

typedef struct _NV_LICENSE_FEATURE_DETAILS_V4 NV_LICENSE_FEATURE_DETAILS_V4

Maximum number of supported Feature License.

◆ NV_LICENSE_FEATURE_TYPE

typedef enum _NV_LICENSE_FEATURE_TYPE NV_LICENSE_FEATURE_TYPE

Used in NV_LICENSE_FEATURE_DETAILS.

◆ NvAPI_LicenseString

typedef char NvAPI_LicenseString[NV_LICENSE_INFO_MAX_LENGTH]

License string.

Enumeration Type Documentation

◆ _NV_LICENSE_FEATURE_TYPE

enum _NV_LICENSE_FEATURE_TYPE

Used in NV_LICENSE_FEATURE_DETAILS.

Enumerator
NV_LICENSE_FEATURE_UNKNOWN |
NV_LICENSE_FEATURE_VGPU |
NV_LICENSE_FEATURE_NVIDIA_RTX |
NV_LICENSE_FEATURE_QUADRO | DEPRECATED name - do not use.
NV_LICENSE_FEATURE_GAMING |
NV_LICENSE_FEATURE_COMPUTE |

Function Documentation

◆ NvAPI_GPU_GetLicensableFeatures()

NVAPI_INTERFACE NvAPI_GPU_GetLicensableFeatures | ( | __in NvPhysicalGpuHandle | hPhysicalGpu,
 |  | __inout NV_LICENSABLE_FEATURES * | pLicensableFeatures
 | ) |  |

DESCRIPTION: This function call identifies whether licenses are supported on this system and if they are supported, returns the details of the features that can be licensed.

SUPPORTED OS: Windows 7 and higher

TCC_SUPPORTED

MCDM_SUPPORTED

Parameters
[in] | hPhysicalGpu | GPU selection
[in,out] | pLicensableFeatures | Licensable features information.
Returns
This API can return any of the error codes enumerated in NvAPI_Status. If there are return error codes with specific meaning for this API, they are listed below.


Functions
Nsight APIs

Functions

NVAPI_INTERFACE NvAPI_D3D11_GetResourceHandle (ID3D11Device *pDev, ID3D11Resource *pResource, NVDX_ObjectHandle *phObject)

Detailed Description

These APIs support the Parallel Nsight development-environment program.

Function Documentation

◆ NvAPI_D3D11_GetResourceHandle()

NVAPI_INTERFACE NvAPI_D3D11_GetResourceHandle | ( | ID3D11Device * | pDev,
 |  | ID3D11Resource * | pResource,
 |  | NVDX_ObjectHandle * | phObject
 | ) |  |
DESCRIPTION: This function retrieves a driver handle to a DX10 resource
INPUT: pDev The device on which the resource was created
pResource The resource for which we want to retrieve a
driver handle.
SUPPORTED OS: Windows 7 and higher
OUTPUT: phObject Pointer to an NvAPI handle to be populated
on success
RETURN STATUS: NVAPI_OK if and only if phObject was populated with a valid
driver handle
NVAPI_OK
@ NVAPI_OK
Success. Request is completed.
Definition nvapi_lite_common.h:258


Data Structures
Here are the data structures with brief descriptions:
[detail level 12]
C _NV_ASYNC_FRAME_MARKER_PARAMS_V1 |
C _NV_BOARD_INFO |
C _NV_CLIENT_CALLBACK_SETTINGS_SUPER_V1 |
C _NV_COLOR_DATA_V1 |
C _NV_COLOR_DATA_V2 |
C _NV_COLOR_DATA_V3 |
C _NV_COLOR_DATA_V4 |
C _NV_COLOR_DATA_V5 |
C _NV_COMPUTE_GPU |
C _NV_COMPUTE_GPU_TOPOLOGY_V2 |
C _NV_CUSTOM_RECTS_V1 |
C _NV_CUSTOM_SEMANTIC |
C _NV_D3D11_EXCLUSIVE_SCISSOR_RECT_DESC_V1 |
C _NV_D3D11_EXCLUSIVE_SCISSOR_RECTS_DESC_V1 |
C _NV_D3D11_FEATURE_DATA_RASTERIZER_SUPPORT |
C _NV_D3D11_SHADING_RATE_RESOURCE_VIEW_DESC_V1 |
C _NV_D3D11_VIEWPORT_SHADING_RATE_DESC_V1 |
C _NV_D3D11_VIEWPORTS_SHADING_RATE_DESC_V1 |
C _NV_D3D12_GRAPHICS_CAPS_V1 |
C _NV_D3D12_MOSAIC_GETCOMPANIONALLOCATIONS |
C _NV_D3D12_MOSAIC_GETVIEWPORTANDGPUPARTITIONS |
C _NV_D3D12_WORKSTATION_FEATURE_PROPERTIES |
C _NV_D3D12_WORKSTATION_FEATURE_RDMA_PROPERTIES |
C _NV_D3D1x_GRAPHICS_CAPS_V1 |
C _NV_D3D1x_GRAPHICS_CAPS_V2 |
C _NV_D3D_LATELATCH_OBJECT_DESC_V1 |
C _NV_DISPLAY_DRIVER_INFO |
C _NV_DISPLAY_DRIVER_INFO_V2 |
C _NV_DISPLAY_PORT_INFO_V1 |
C _NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_V1 |
C _NV_DISPLAYCONFIG_PATH_INFO_V1 |
C _NV_DISPLAYCONFIG_PATH_INFO_V2 |
C _NV_DISPLAYCONFIG_PATH_TARGET_INFO_V1 |
C _NV_DISPLAYCONFIG_PATH_TARGET_INFO_V2 |
C _NV_DISPLAYCONFIG_SOURCE_MODE_INFO_V1 |
C _NV_DX_VIDEO_STEREO_INFO |
C _NV_EDID_DATA_V1 |
C _NV_EDID_DATA_V2 |
C _NV_FOVEATED_RENDERING_CUSTOM_FOVEATION_PATTERN_PRESET_DESC_V1 |
C _NV_FOVEATED_RENDERING_CUSTOM_SHADING_RATE_PRESET_DESC_V1 |
C _NV_FOVEATED_RENDERING_DESC_V1 |
C _NV_FOVEATED_RENDERING_GAZE_DATA_PER_EYE |
C _NV_FOVEATED_RENDERING_UPDATE_GAZE_DATA_PARAMS |
C _NV_GAZE_HANDLER_INIT_PARAMS_V1 |
C _NV_GAZE_HANDLER_INIT_PARAMS_V2 |
C _NV_GET_ADAPTIVE_SYNC_DATA_V1 |
C _NV_GET_SLEEP_STATUS_PARAMS |
C _NV_GET_VIRTUAL_REFRESH_RATE_DATA_V1 |
C _NV_GET_VRR_INFO_V1 |
C _NV_GPU_CLIENT_CALLBACK_DATA_SUPER_V1 |
C _NV_GPU_CLIENT_CALLBACK_UTILIZATION_DATA_V1 |
C _NV_GPU_CLIENT_ILLUM_DEVICE_INFO_DATA_GPIO_PWM_RGBW |
C _NV_GPU_CLIENT_ILLUM_DEVICE_INFO_DATA_GPIO_PWM_SINGLE_COLOR |
C _NV_GPU_CLIENT_ILLUM_DEVICE_INFO_DATA_MCUV10 |
C _NV_GPU_CLIENT_ILLUM_DEVICE_INFO_PARAMS_V1 |
C _NV_GPU_CLIENT_ILLUM_DEVICE_INFO_V1 |
C _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_COLOR_FIXED |
C _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_COLOR_FIXED |
C _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_COLOR_FIXED_PARAMS |
C _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_RGB |
C _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_RGB_PARAMS |
C _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_RGBW |
C _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_RGBW_PARAMS |
C _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_SINGLE_COLOR |
C _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_SINGLE_COLOR_PARAMS |
C _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR |
C _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR_COLOR_FIXED |
C _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR_RGB |
C _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR_RGBW |
C _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR_SINGLE_COLOR |
C _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_RGB |
C _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_RGBW |
C _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_SINGLE_COLOR |
C _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_PARAMS_V1 |
C _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_V1 |
C _NV_GPU_CLIENT_ILLUM_ZONE_INFO_DATA_RGB |
C _NV_GPU_CLIENT_ILLUM_ZONE_INFO_DATA_RGBW |
C _NV_GPU_CLIENT_ILLUM_ZONE_INFO_DATA_SINGLE_COLOR |
C _NV_GPU_CLIENT_ILLUM_ZONE_INFO_PARAMS_V1 |
C _NV_GPU_CLIENT_ILLUM_ZONE_INFO_V1 |
C _NV_GPU_CLIENT_PERIODIC_CALLBACK_SETTINGS_SUPER_V1 |
C _NV_GPU_CLIENT_UTILIZATION_DATA_V1 |
C _NV_GPU_CLIENT_UTILIZATION_PERIODIC_CALLBACK_SETTINGS_V1 |
C _NV_GPU_DISPLAYIDS |
C _NV_GPU_GET_ILLUMINATION_PARM_V1 |
C _NV_GPU_GSP_INFO_V1 |
C _NV_GPU_INFO_V1 |
C _NV_GPU_INFO_V2 |
C _NV_GPU_PERF_PSTATES20_INFO_V2 | Used in NvAPI_GPU_GetPstates20() interface call
C _NV_GPU_QUERY_ILLUMINATION_SUPPORT_PARM_V1 |
C _NV_GPU_SET_ILLUMINATION_PARM_V1 |
C _NV_GPU_VIRTUALIZATION_INFO |
C _NV_GPU_VR_READY_V1 |
C _NV_GSYNC_CAPABILITIES_V1 | Used in NvAPI_GSync_QueryCapabilities()
C _NV_GSYNC_CAPABILITIES_V2 |
C _NV_GSYNC_CAPABILITIES_V3 |
C _NV_GSYNC_CONTROL_PARAMS_V1 | Used in NvAPI_GSync_GetControlParameters() and NvAPI_GSync_SetControlParameters()
C _NV_GSYNC_CONTROL_PARAMS_V2 |
C _NV_GSYNC_DELAY | Used in NV_GSYNC_CONTROL_PARAMS
C _NV_GSYNC_DISPLAY |
C _NV_GSYNC_GPU |
C _NV_GSYNC_STATUS | Used in NvAPI_GSync_GetSyncStatus()
C _NV_GSYNC_STATUS_PARAMS_V1 |
C _NV_GSYNC_STATUS_PARAMS_V2 |
C _NV_HDMI_SUPPORT_INFO_V1 |
C _NV_HDMI_SUPPORT_INFO_V2 |
C _NV_HDR_CAPABILITIES_V1 |
C _NV_HDR_CAPABILITIES_V2 |
C _NV_HDR_CAPABILITIES_V3 |
C _NV_HDR_COLOR_DATA_V1 |
C _NV_HDR_COLOR_DATA_V2 |
C _NV_HDR_METADATA_V1 |
C _NV_HEAP_PARAMS_V1 |
C _NV_JOIN_PRESENT_BARRIER_PARAMS |
C _NV_LATENCY_MARKER_PARAMS |
►C _NV_LATENCY_RESULT_PARAMS |
C FrameReport |
C _NV_LICENSABLE_FEATURES_V1 | Licensable features
C _NV_LICENSABLE_FEATURES_V2 |
C _NV_LICENSABLE_FEATURES_V3 |
C _NV_LICENSABLE_FEATURES_V4 |
C _NV_LICENSE_EXPIRY_DETAILS |
C _NV_LICENSE_FEATURE_DETAILS_V1 | Used in NV_LICENSABLE_FEATURES
C _NV_LICENSE_FEATURE_DETAILS_V2 |
C _NV_LICENSE_FEATURE_DETAILS_V3 |
C _NV_LICENSE_FEATURE_DETAILS_V4 |
C _NV_LMS_CUSTOM_CONFIG_V1 |
C _NV_LMS_INSTANCED_STEREO_CONFIG_V1 |
C _NV_LOGICAL_GPU_DATA_V1 |
C _NV_LOGICAL_GPU_HANDLE_DATA |
C _NV_LOGICAL_GPUS |
C _NV_MANAGED_DEDICATED_DISPLAY_INFO |
C _NV_MANAGED_DEDICATED_DISPLAY_METADATA |
C _NV_MODIFIED_W_COEFFICIENTS |
C _NV_MODIFIED_W_PARAMS |
C _NV_MONITOR_CAPABILITIES_V1 | See NvAPI_DISP_GetMonitorCapabilities()
C _NV_MONITOR_CAPS_GENERIC |
C _NV_MONITOR_CAPS_VCDB |
C _NV_MONITOR_CAPS_VSDB | See NvAPI_DISP_GetMonitorCapabilities()
C _NV_MONITOR_COLOR_DATA |
C _NV_MOSAIC_DISPLAY_SETTING_V1 | Basic per-display settings that are used in setting/getting the Mosaic mode
C _NV_MOSAIC_GRID_TOPO_DISPLAY_V1 |
C _NV_MOSAIC_GRID_TOPO_DISPLAY_V2 |
C _NV_MOSAIC_GRID_TOPO_V1 |
C _NV_MOSAIC_GRID_TOPO_V2 |
C _NV_MOSAIC_SUPPORTED_TOPO_INFO_V1 |
C _NV_MOSAIC_SUPPORTED_TOPO_INFO_V2 |
C _NV_MRS_CUSTOM_CONFIG_V1 |
C _NV_MRS_INSTANCED_STEREO_CONFIG_V1 |
C _NV_MULTIGPU_CAPS_V1 |
C _NV_MULTIGPU_CAPS_V2 |
C _NV_MULTIVIEW_PARAMS_V1 |
C _NV_PHYSICAL_GPU_HANDLE_DATA |
C _NV_PHYSICAL_GPUS |
C _NV_PIXEL_SHADING_RATE_SAMPLE_ORDER_TABLE_V1 |
►C _NV_PIXEL_SRSO_1x2 |
C NV_PIXEL_SRSO_1x2_X1 |
C NV_PIXEL_SRSO_1x2_X2 |
C NV_PIXEL_SRSO_1x2_X4 |
C NV_PIXEL_SRSO_1x2_X8 |
►C _NV_PIXEL_SRSO_2x1 |
C NV_PIXEL_SRSO_2x1_X1 |
C NV_PIXEL_SRSO_2x1_X2 |
C NV_PIXEL_SRSO_2x1_X4 |
►C _NV_PIXEL_SRSO_2x2 |
C NV_PIXEL_SRSO_2x2_X1 |
C NV_PIXEL_SRSO_2x2_X2 |
C NV_PIXEL_SRSO_2x2_X4 |
►C _NV_PIXEL_SRSO_2x4 |
C NV_PIXEL_SRSO_2x4_X1 |
C NV_PIXEL_SRSO_2x4_X2 |
►C _NV_PIXEL_SRSO_4x2 |
C NV_PIXEL_SRSO_4x2_X1 |
►C _NV_PIXEL_SRSO_4x4 |
C NV_PIXEL_SRSO_4x4_X1 |
C _NV_POSITION |
C _NV_PRESENT_BARRIER_FRAME_STATISTICS |
C _NV_QUERY_LATELATCH_SUPPORT_PARAMS |
C _NV_QUERY_MODIFIED_W_SUPPORT_PARAMS |
C _NV_QUERY_MULTIVIEW_SUPPORT_PARAMS_V1 |
C _NV_QUERY_SINGLE_PASS_STEREO_SUPPORT_PARAMS_V1 |
C _NV_QUERY_SINGLE_PASS_STEREO_SUPPORT_PARAMS_V2 |
C _NV_QUERY_SMP_ASSIST_SUPPORT_PARAMS_V1 |
C _NV_RECT |
C _NV_RESOLUTION |
C _NV_RESOURCE_PARAMS_V1 |
C _NV_SCANOUT_INFORMATION |
C _NV_SCANOUT_INTENSITY_STATE_DATA |
C _NV_SCANOUT_WARPING_STATE_DATA |
C _NV_SET_ADAPTIVE_SYNC_DATA_V1 |
C _NV_SET_REFLEX_SYNC_PARAMS |
C _NV_SET_SLEEP_MODE_PARAMS |
C _NV_SET_VIRTUAL_REFRESH_RATE_DATA_V1 |
C _NV_SMP_ASSIST_DISABLE_PARAMS_V1 |
C _NV_SMP_ASSIST_ENABLE_PARAMS_V1 |
C _NV_SMP_ASSIST_FASTGSCBDATA_MRS_INSTANCED_STEREO_V1 |
C _NV_SMP_ASSIST_FASTGSCBDATA_V1 |
C _NV_SMP_ASSIST_GET_CONSTANTS_V3 |
C _NV_SMP_ASSIST_INITIALIZE_PARAMS_V1 |
C _NV_SMP_ASSIST_REMAPCBDATA_V1 |
C _NV_SMP_ASSIST_SETUP_PARAMS_V1 |
C _NV_SMP_ASSIST_UPDATE_INSTANCEDSTEREO_DATA_PARAMS_V1 |
C _NV_TEX2D_ARRAY_SRRV |
C _NV_TEX2D_SRRV |
C _NV_TIMING |
C _NV_TIMING_INPUT |
C _NV_VIO_TOPOLOGY |
C _NV_VRS_HELPER_DISABLE_PARAMS_V1 |
C _NV_VRS_HELPER_ENABLE_PARAMS_V1 |
C _NV_VRS_HELPER_GET_SHADING_RATE_RESOURCE_PARAMS_V1 |
C _NV_VRS_HELPER_INIT_PARAMS_V1 |
C _NV_VRS_HELPER_LATCH_GAZE_PARAMS_V1 |
C _NV_VRS_HELPER_PURGE_INTERNAL_RESOURCES_PARAMS_V1 |
C _NVAPI_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_EX_PARAMS_V1 |
C _NVAPI_BUILD_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PARAMS_V1 |
C _NVAPI_BUILD_RAYTRACING_OPACITY_MICROMAP_ARRAY_PARAMS_V1 |
C _NVAPI_CHECK_DRIVER_MATCHING_IDENTIFIER_EX_PARAMS_V1 |
C _NVAPI_CU_KERNEL_LAUNCH_PARAMS |
C _NVAPI_CU_KERNEL_LAUNCH_PARAMS_EX |
C _NVAPI_D3D12_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_DESC_EX |
C _NVAPI_D3D12_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_INPUTS_EX |
C _NVAPI_D3D12_BUILD_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_DESC |
C _NVAPI_D3D12_BUILD_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_INPUTS |
C _NVAPI_D3D12_BUILD_RAYTRACING_OPACITY_MICROMAP_ARRAY_DESC |
C _NVAPI_D3D12_BUILD_RAYTRACING_OPACITY_MICROMAP_ARRAY_INPUTS |
C _NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_POSTBUILD_INFO_CURRENT_SIZE_DESC |
C _NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_POSTBUILD_INFO_DESC |
C _NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PREBUILD_INFO |
C _NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_DESC |
C _NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_USAGE_COUNT |
C _NVAPI_D3D12_RAYTRACING_GEOMETRY_DESC_EX |
C _NVAPI_D3D12_RAYTRACING_GEOMETRY_DMM_ATTACHMENT_DESC |
C _NVAPI_D3D12_RAYTRACING_GEOMETRY_DMM_TRIANGLES_DESC |
C _NVAPI_D3D12_RAYTRACING_GEOMETRY_OMM_ATTACHMENT_DESC |
C _NVAPI_D3D12_RAYTRACING_GEOMETRY_OMM_TRIANGLES_DESC |
C _NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_ARRAY_POSTBUILD_INFO_CURRENT_SIZE_DESC |
C _NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_ARRAY_POSTBUILD_INFO_DESC |
C _NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_ARRAY_PREBUILD_INFO |
C _NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_DESC |
C _NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_USAGE_COUNT |
C _NVAPI_D3D12_SET_CREATE_PIPELINE_STATE_OPTIONS_PARAMS_V1 |
C _NVAPI_DIM3 |
C _NVAPI_EMIT_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_POSTBUILD_INFO_PARAMS_V1 |
C _NVAPI_EMIT_RAYTRACING_OPACITY_MICROMAP_ARRAY_POSTBUILD_INFO_PARAMS_V1 |
C _NVAPI_GET_RAYTRACING_ACCELERATION_STRUCTURE_PREBUILD_INFO_EX_PARAMS_V1 |
C _NVAPI_GET_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PREBUILD_INFO_PARAMS_V1 |
C _NVAPI_GET_RAYTRACING_OPACITY_MICROMAP_ARRAY_PREBUILD_INFO_PARAMS_V1 |
C _NVAPI_RELOCATE_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PARAMS_V1 |
C _NVAPI_RELOCATE_RAYTRACING_OPACITY_MICROMAP_ARRAY_PARAMS_V1 |
C _NVAPI_STEREO_CAPS |
C _NVDRS_APPLICATION_V1 |
C _NVDRS_APPLICATION_V2 |
C _NVDRS_APPLICATION_V3 |
C _NVDRS_APPLICATION_V4 |
C _NVDRS_BINARY_SETTING | Enum to decide on the datatype of setting value
C _NVDRS_GPU_SUPPORT |
C _NVDRS_PROFILE_V1 |
C _NVDRS_SETTING_V1 |
C _NVDRS_SETTING_VALUES |
C _NVVIOCAPS | Device capabilities
C _NVVIOCHANNELSTATUS | Input channel status
C _NVVIOCOLORCONVERSION | Colorspace conversion
C _NVVIOCOMPOSITERANGE |
C _NVVIOCONFIG_V1 |
C _NVVIOCONFIG_V2 |
C _NVVIOCONFIG_V3 |
C _NVVIODATAFORMATDETAIL | Data format details
C _NVVIOGAMMACORRECTION | Gamma correction
C _NVVIOGAMMARAMP10 | Gamma ramp (10-bit index)
C _NVVIOGAMMARAMP8 | Gamma ramp (8-bit index)
C _NVVIOINPUTCONFIG | Input device configuration
C _NVVIOINPUTSTATUS | Input device status
C _NVVIOOUTPUTCONFIG_V1 | Output device configuration
C _NVVIOOUTPUTCONFIG_V2 |
C _NVVIOOUTPUTCONFIG_V3 |
C _NVVIOOUTPUTREGION | Output region
C _NVVIOOUTPUTSTATUS | Output device status
C _NVVIOPCIINFO |
C _NVVIOSIGNALFORMATDETAIL | Signal format details
C _NVVIOSTATUS | Video device status
C _NVVIOSTREAM | Stream configuration
C _NVVIOSYNCDELAY | Sync delay
C _NVVIOVIDEOMODE | Video mode information
C _SettingDWORDNameString |
C _SettingWSTRINGNameString |
C INvAPI_DirectD3D12GraphicsCommandList |
C NV_CHIPSET_INFO_v1 |
C NV_CHIPSET_INFO_v2 |
C NV_CHIPSET_INFO_v3 |
C NV_CHIPSET_INFO_v4 |
C NV_COMPUTE_GPU_TOPOLOGY_V1 |
C NV_CUSTOM_DISPLAY |
C NV_D3D11_META_COMMAND_EXECUTE_CONVOLUTION_EX_DESC |
C NV_D3D11_META_COMMAND_EXECUTE_GEMM_DESC |
C NV_D3D11_META_COMMAND_INITIALIZE_CONVOLUTION_EX_DESC |
C NV_D3D11_META_COMMAND_INITIALIZE_GEMM_DESC |
C NV_D3D11_META_COMMAND_RESOURCE |
C NV_D3D12_META_COMMAND_EXECUTE_CONVOLUTION_EX_DESC |
C NV_D3D12_META_COMMAND_EXECUTE_GEMM_DESC |
C NV_D3D12_META_COMMAND_INITIALIZE_CONVOLUTION_EX_DESC |
C NV_D3D12_META_COMMAND_INITIALIZE_GEMM_DESC |
C NV_DISPLAY_DRIVER_MEMORY_INFO_V1 |
C NV_DISPLAY_DRIVER_MEMORY_INFO_V2 |
C NV_DISPLAY_DRIVER_MEMORY_INFO_V3 |
C NV_DISPLAY_DRIVER_VERSION |
C NV_DISPLAY_PATH |
C NV_DISPLAY_PATH_INFO |
C NV_DISPLAY_PATH_INFO_V3 |
C NV_DISPLAY_PORT_CONFIG |
C NV_EDID_V1 |
C NV_EDID_V2 | Used in NvAPI_GPU_GetEDID()
C NV_EDID_V3 | Used in NvAPI_GPU_GetEDID()
C NV_EVENT_REGISTER_CALLBACK | Core NV_EVENT_REGISTER_CALLBACK structure declaration
C NV_GET_CURRENT_SLI_STATE_V1 |
C NV_GET_CURRENT_SLI_STATE_V2 |
C NV_GET_GPU_VIRTUAL_ADDRESS_V1 |
C NV_GET_PREFERRED_STEREO_DISPLAY_V1 |
C NV_GPU_ARCH_INFO_V1 | Used in NvAPI_GPU_GetArchInfo()
C NV_GPU_ARCH_INFO_V2 |
C NV_GPU_CLIENT_ILLUM_DEVICE_CONTROL_PARAMS_V1 |
C NV_GPU_CLIENT_ILLUM_DEVICE_CONTROL_V1 |
C NV_GPU_CLIENT_ILLUM_DEVICE_SYNC_V1 |
C NV_GPU_CLOCK_FREQUENCIES_V1 |
C NV_GPU_CLOCK_FREQUENCIES_V2 |
C NV_GPU_DYNAMIC_PSTATES_INFO_EX |
C NV_GPU_ECC_CONFIGURATION_INFO |
C NV_GPU_ECC_ERROR_INFO |
C NV_GPU_ECC_STATUS_INFO |
C NV_GPU_GET_HDCP_SUPPORT_STATUS | HDPC support status - used in NvAPI_GPU_GetHDCPSupportStatus()
C NV_GPU_MEMORY_INFO_EX_V1 |
C NV_GPU_PERF_PSTATES20_INFO_V1 | Used in NvAPI_GPU_GetPstates20() interface call
C NV_GPU_PERF_PSTATES20_PARAM_DELTA | Used to describe both voltage and frequency deltas
C NV_GPU_PERF_PSTATES_INFO_V1 |
C NV_GPU_PERF_PSTATES_INFO_V2 |
C NV_GPU_PSTATE20_BASE_VOLTAGE_ENTRY_V1 | Used to describe single base voltage entry
C NV_GPU_PSTATE20_CLOCK_ENTRY_V1 | Used to describe single clock entry
C NV_GPU_THERMAL_SETTINGS_V1 |
C NV_GPU_THERMAL_SETTINGS_V2 |
C NV_I2C_INFO_V1 | Used in NvAPI_I2CRead() and NvAPI_I2CWrite()
C NV_I2C_INFO_V2 | Used in NvAPI_I2CRead() and NvAPI_I2CWrite()
C NV_I2C_INFO_V3 | Used in NvAPI_I2CRead() and NvAPI_I2CWrite()
C NV_INFOFRAME_AUDIO |
C NV_INFOFRAME_DATA |
C NV_INFOFRAME_PROPERTY |
C NV_INFOFRAME_VIDEO | Adding an Auto bit to each field
C NV_LID_DOCK_PARAMS |
C NV_META_COMMAND_ACTIVATION_DESC |
C NV_META_COMMAND_CONVOLUTION_FUSE_DESC |
C NV_META_COMMAND_CREATE_CONVOLUTION_EX_DESC |
C NV_META_COMMAND_CREATE_CONVOLUTION_EX_FUSED_DESC |
C NV_META_COMMAND_CREATE_GEMM_DESC |
C NV_META_COMMAND_OPTIONAL_ACTIVATION_DESC |
C NV_META_COMMAND_OPTIONAL_TENSOR_DESC |
C NV_META_COMMAND_PADDING_DESC |
C NV_META_COMMAND_TENSOR_DESC |
C NV_MOSAIC_DISPLAY_SETTING_V2 |
C NV_MOSAIC_DISPLAY_TOPO_STATUS |
C NV_MOSAIC_SUPPORTED_TOPOLOGIES | Used in NvAPI_GetSupportedMosaicTopologies()
C NV_MOSAIC_TOPO_BRIEF |
C NV_MOSAIC_TOPO_DETAILS | This structure defines the topology details
C NV_MOSAIC_TOPO_GROUP |
C NV_MOSAIC_TOPOLOGY | Used in NvAPI_GetCurrentMosaicTopology() and NvAPI_SetCurrentMosaicTopology()
C NV_QSYNC_EVENT_DATA |
C NV_SCANOUT_INTENSITY_DATA_V1 |
C NV_SCANOUT_INTENSITY_DATA_V2 |
C NV_SCANOUT_WARPING_DATA |
C NV_SET_PREFERRED_STEREO_DISPLAY_V1 |
C NV_TIMING_FLAG |
C NV_VIEW_TARGET_INFO |
C NV_VIEWPORTF |
C NVAPI_ANSEL_CONFIGURATION_STRUCT_V1 |
C NVAPI_ANSEL_FEATURE_CONFIGURATION_STRUCT |
C NvAPI_D3D11_CREATE_DOMAIN_SHADER_EX_V1 |
C NvAPI_D3D11_CREATE_DOMAIN_SHADER_EX_V2 |
C NvAPI_D3D11_CREATE_DOMAIN_SHADER_EX_V3 |
C NvAPI_D3D11_CREATE_FASTGS_EXPLICIT_DESC_V1 |
C NvAPI_D3D11_CREATE_GEOMETRY_SHADER_EX_V5 |
C NvAPI_D3D11_CREATE_HULL_SHADER_EX_V1 |
C NvAPI_D3D11_CREATE_HULL_SHADER_EX_V2 |
C NvAPI_D3D11_CREATE_PIXEL_SHADER_EX_V1 |
C NvAPI_D3D11_CREATE_PIXEL_SHADER_EX_V2 |
C NvAPI_D3D11_CREATE_VERTEX_SHADER_EX_V1 |
C NvAPI_D3D11_CREATE_VERTEX_SHADER_EX_V2 |
C NvAPI_D3D11_CREATE_VERTEX_SHADER_EX_V3 |
C NvAPI_D3D11_RASTERIZER_DESC_EX |
C NVAPI_D3D12_CREATE_CUBIN_SHADER_PARAMS |
C NVAPI_D3D12_GET_CUDA_INDEPENDENT_DESCRIPTOR_OBJECT_PARAMS |
C NVAPI_D3D12_GET_CUDA_MERGED_TEXTURE_SAMPLER_OBJECT_PARAMS |
C NVAPI_D3D12_PSO_CREATE_FASTGS_EXPLICIT_DESC_V1 |
C NVAPI_D3D12_PSO_DOMAIN_SHADER_DESC_V1 |
C NVAPI_D3D12_PSO_DOMAIN_SHADER_DESC_V2 |
C NVAPI_D3D12_PSO_DOMAIN_SHADER_DESC_V3 |
C NVAPI_D3D12_PSO_ENABLE_DEPTH_BOUND_TEST_DESC_V1 |
C NVAPI_D3D12_PSO_EXTENSION_DESC_V1 |
C NVAPI_D3D12_PSO_GEOMETRY_SHADER_DESC_V5 |
C NVAPI_D3D12_PSO_HULL_SHADER_DESC_V1 |
C NVAPI_D3D12_PSO_HULL_SHADER_DESC_V2 |
C NVAPI_D3D12_PSO_RASTERIZER_STATE_DESC_V1 |
C NVAPI_D3D12_PSO_REQUEST_FAST_GEOMETRY_SHADER_DESC_V1 |
C NVAPI_D3D12_PSO_SET_SHADER_EXTENSION_SLOT_DESC_V1 |
C NVAPI_D3D12_PSO_VERTEX_SHADER_DESC_V1 |
C NVAPI_D3D12_PSO_VERTEX_SHADER_DESC_V2 |
C NVAPI_D3D12_PSO_VERTEX_SHADER_DESC_V3 |
C NVAPI_META_COMMAND_DESC |
C NVAPI_UAV_INFO_V1 |
C NVAPI_UAV_INFO_V2 |
C NvGUID |
C NVLINK_DEVICE_INFO_V1 |
C NVLINK_GET_CAPS_V1 |
C NVLINK_GET_STATUS_V1 |
C NVLINK_GET_STATUS_V2 |
C NVLINK_LINK_STATUS_INFO_V1 |
C NVLINK_LINK_STATUS_INFO_V2 |
C NvSBox |
C NvShaderExtnStruct |
C NVVIOTOPOLOGYTARGET |
C tagNV_TIMINGEXT |


Data Fields
_NV_CUSTOM_RECTS_V1 Struct Reference

#include <nvapi.h>

Data Fields

NvU32 numViewports [NV_SMP_ASSIST_MINIMAL_LEVEL_NUM_EYE_INDICES]
D3D11_VIEWPORT * | pViewports [NV_SMP_ASSIST_MINIMAL_LEVEL_NUM_EYE_INDICES]
D3D11_RECT * | pScissors [NV_SMP_ASSIST_MINIMAL_LEVEL_NUM_EYE_INDICES]
The documentation for this struct was generated from the following file:


Data Fields
_NV_CUSTOM_SEMANTIC Struct Reference

#include <nvapi.h>

Data Fields

UINT | version
NV_CUSTOM_SEMANTIC_TYPE NVCustomSemanticType
NvAPI_LongString NVCustomSemanticNameString
BOOL | RegisterSpecified
NvU32 RegisterNum
NvU32 RegisterMask
NvU32 Reserved
The documentation for this struct was generated from the following file:


Data Fields
_NV_D3D11_EXCLUSIVE_SCISSOR_RECTS_DESC_V1 Struct Reference

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 numRects
NV_D3D11_EXCLUSIVE_SCISSOR_RECT_DESC_V1 * pRects
The documentation for this struct was generated from the following file:


Data Fields
_NV_D3D11_FEATURE_DATA_RASTERIZER_SUPPORT Struct Reference

#include <nvapi.h>

Data Fields

BOOL | TargetIndependentRasterWithDepth
BOOL | ProgrammableSamplePositions
BOOL | InterleavedSampling
BOOL | ConservativeRaster
BOOL | PostZCoverage
BOOL | CoverageToColor
The documentation for this struct was generated from the following file:


Data Fields
_NV_D3D11_SHADING_RATE_RESOURCE_VIEW_DESC_V1 Struct Reference

#include <nvapi.h>

Data Fields

NvU32 version
DXGI_FORMAT Format
NV_SRRV_DIMENSION ViewDimension
union {
NV_TEX2D_SRRV _NV_D3D11_SHADING_RATE_RESOURCE_VIEW_DESC_V1::Texture2D
NV_TEX2D_ARRAY_SRRV _NV_D3D11_SHADING_RATE_RESOURCE_VIEW_DESC_V1::Texture2DArray
};
The documentation for this struct was generated from the following file:


Data Fields
_NV_D3D11_VIEWPORT_SHADING_RATE_DESC_V1 Struct Reference

#include <nvapi.h>

Data Fields

bool enableVariablePixelShadingRate
NV_PIXEL_SHADING_RATE shadingRateTable [NV_MAX_PIXEL_SHADING_RATES]
The documentation for this struct was generated from the following file:


Data Fields
_NV_D3D11_VIEWPORTS_SHADING_RATE_DESC_V1 Struct Reference

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 numViewports
NV_D3D11_VIEWPORT_SHADING_RATE_DESC_V1 * pViewports
The documentation for this struct was generated from the following file:


Data Fields
_NV_D3D12_MOSAIC_GETCOMPANIONALLOCATIONS Struct Reference

#include <nvapi.h>

Data Fields

__in NvU32 version
__in ID3D12Device * | pDevice
__in ID3D12Resource * | pSwapChainBuffer
__in NvU32 companionBufferCount
__inout ID3D12Resource ** | ppCompanionResources

Detailed Description

SUPPORTED OS: Windows 10 and higher

The documentation for this struct was generated from the following file:


Data Fields
_NV_D3D12_MOSAIC_GETVIEWPORTANDGPUPARTITIONS Struct Reference

#include <nvapi.h>

Data Fields

__in NvU32 version
__in ID3D12Device * | pDevice
__in ID3D12Resource * | pSwapChainBuffer
__inout NvU32 * pPartitionCount
__inout RECT * | pViewport
__inout NvU32 * pNodeMask

Detailed Description

SUPPORTED OS: Windows 10 and higher

The documentation for this struct was generated from the following file:


Data Fields
_NV_D3D12_WORKSTATION_FEATURE_PROPERTIES Struct Reference

#include <nvapi.h>

Data Fields

NvU32 version
NV_D3D12_WORKSTATION_FEATURE_TYPE workstationFeatureType
NvBool supported
union {
NV_D3D12_WORKSTATION_FEATURE_RDMA_PROPERTIES _NV_D3D12_WORKSTATION_FEATURE_PROPERTIES::rdmaInfo
};
The documentation for this struct was generated from the following file:


Data Fields
_NV_D3D12_WORKSTATION_FEATURE_RDMA_PROPERTIES Struct Reference

#include <nvapi.h>

Data Fields

NvU64 rdmaHeapSize
The documentation for this struct was generated from the following file:


Data Fields
_NV_D3D1x_GRAPHICS_CAPS_V2 Struct Reference

#include <nvapi.h>

Data Fields

NvU32 | bExclusiveScissorRectsSupported: 1
NvU32 | bVariablePixelRateShadingSupported: 1
NvU32 | bFastUAVClearSupported: 1
NvU32 | reservedBits: 29
NvU16 majorSMVersion
NvU16 minorSMVersion
NvU32 | reserved [14]
The documentation for this struct was generated from the following file:


Data Fields
_NV_D3D_LATELATCH_OBJECT_DESC_V1 Struct Reference

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 numBuffers
D3D11_BUFFER_DESC ** ppBufferDesc
ID3DLateLatchObject ** ppD3DLateLatchObject
The documentation for this struct was generated from the following file:


Data Fields
_NV_FOVEATED_RENDERING_CUSTOM_FOVEATION_PATTERN_PRESET_DESC_V1 Struct Reference

#include <nvapi.h>

Data Fields

NvU32 version
float | fInnermostRadii [2]
float | fMiddleRadii [2]
float | fPeripheralRadii [2]
The documentation for this struct was generated from the following file:


Data Fields
_NV_FOVEATED_RENDERING_CUSTOM_SHADING_RATE_PRESET_DESC_V1 Struct Reference

#include <nvapi.h>

Data Fields

NvU32 version
NV_PIXEL_SHADING_RATE InnerMostRegionShadingRate
NV_PIXEL_SHADING_RATE MiddleRegionShadingRate
NV_PIXEL_SHADING_RATE PeripheralRegionShadingRate
The documentation for this struct was generated from the following file:


Data Fields
_NV_FOVEATED_RENDERING_DESC_V1 Struct Reference

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 flags
NV_FOVEATED_RENDERING_SHADING_RATE_PRESET ShadingRatePreset
NV_FOVEATED_RENDERING_CUSTOM_SHADING_RATE_PRESET_DESC_V1 ShadingRateCustomPresetDesc
NV_FOVEATED_RENDERING_FOVEATION_PATTERN_PRESET FoveationPatternPreset
NV_FOVEATED_RENDERING_CUSTOM_FOVEATION_PATTERN_PRESET_DESC_V1 FoveationPatternCustomPresetDesc
NvU32 GazeDataDeviceId
The documentation for this struct was generated from the following file:


Data Fields
_NV_FOVEATED_RENDERING_GAZE_DATA_PER_EYE Struct Reference

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 GazeDataValidityFlags
float | fGazeOrigin_mm [3]
float | fGazeDirection [3]
float | fGazeNormalizedLocation [2]
float | fGazeVelocity [2]
float | fPupilDiameter_mm
float | fEyeOpenness
BOOL | bInSaccade
The documentation for this struct was generated from the following file:


Data Fields
_NV_FOVEATED_RENDERING_UPDATE_GAZE_DATA_PARAMS Struct Reference

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 flags
NvU64 Timestamp
union {
NV_FOVEATED_RENDERING_GAZE_DATA_PER_EYE_V1 _NV_FOVEATED_RENDERING_UPDATE_GAZE_DATA_PARAMS::sMonoData
struct {
NV_FOVEATED_RENDERING_GAZE_DATA_PER_EYE_V1 _NV_FOVEATED_RENDERING_UPDATE_GAZE_DATA_PARAMS::sLeftEye
NV_FOVEATED_RENDERING_GAZE_DATA_PER_EYE_V1 _NV_FOVEATED_RENDERING_UPDATE_GAZE_DATA_PARAMS::sRightEye
} _NV_FOVEATED_RENDERING_UPDATE_GAZE_DATA_PARAMS::sStereoData
};
The documentation for this struct was generated from the following file:


Data Fields
_NV_GAZE_HANDLER_INIT_PARAMS_V1 Struct Reference

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 GazeDataDeviceId
NV_GAZE_DATA_TYPE GazeDataType
NvU32 flags
float | fHorizontalFOV
float | fVericalFOV
ID3DNvGazeHandler_V1 ** | ppNvGazeHandler
The documentation for this struct was generated from the following file:


Data Fields
_NV_GAZE_HANDLER_INIT_PARAMS_V2 Struct Reference

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 GazeDataDeviceId
NV_GAZE_DATA_TYPE GazeDataType
NvU32 flags
float | fHorizontalFOV
float | fVericalFOV
ID3DNvGazeHandler_V2 ** | ppNvGazeHandler
The documentation for this struct was generated from the following file:


Data Fields
_NV_HEAP_PARAMS_V1 Struct Reference

#include <nvapi.h>

Data Fields

NvU32 version
NV_D3D12_HEAP_FLAGS NVHeapFlags
The documentation for this struct was generated from the following file:


Data Fields
_NV_JOIN_PRESENT_BARRIER_PARAMS Struct Reference

#include <nvapi.h>

Data Fields

NvU32 dwVersion

Detailed Description

SUPPORTED OS: Windows 10 and higher

The documentation for this struct was generated from the following file:


Data Fields
_NV_LMS_CUSTOM_CONFIG_V1 Struct Reference

#include <nvapi.h>

Data Fields

float | warpLeft
float | warpRight
float | warpUp
float | warpDown
float | relativeSizeLeft
float | relativeSizeRight
float | relativeSizeUp
float | relativeSizeDown
The documentation for this struct was generated from the following file:


Data Fields
_NV_LMS_INSTANCED_STEREO_CONFIG_V1 Struct Reference

#include <nvapi.h>

Data Fields

NV_LMS_CUSTOM_CONFIG_V1 sLeftConfig
NV_LMS_CUSTOM_CONFIG_V1 sRightConfig
The documentation for this struct was generated from the following file:


Data Fields
_NV_MODIFIED_W_COEFFICIENTS Struct Reference

#include <nvapi.h>

Data Fields

float | fA
float | fB
float | fAReserved
float | fBReserved
float | fReserved [2]
The documentation for this struct was generated from the following file:


Data Fields
_NV_MODIFIED_W_PARAMS Struct Reference

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 numEntries
NV_MODIFIED_W_COEFFICIENTS modifiedWCoefficients [NV_MODIFIED_W_MAX_VIEWPORTS]
NvU32 id
NvU32 reserved [NV_MODIFIED_W_MAX_VIEWPORTS]
The documentation for this struct was generated from the following file:


Data Fields
_NV_MRS_CUSTOM_CONFIG_V1 Struct Reference

#include <nvapi.h>

Data Fields

float | centerWidth
float | centerHeight
float | centerX
float | centerY
float | densityScaleX [3]
float | densityScaleY [3]
The documentation for this struct was generated from the following file:


Data Fields
_NV_MRS_INSTANCED_STEREO_CONFIG_V1 Struct Reference

#include <nvapi.h>

Data Fields

float | centerWidth [2]
float | centerHeight
float | centerX [2]
float | centerY
float | densityScaleX [5]
float | densityScaleY [3]
The documentation for this struct was generated from the following file:


Data Fields
_NV_MULTIGPU_CAPS_V2 Struct Reference

#include <nvapi.h>

Data Fields

NvU32 multiGPUVersion
union {
NvU32 _NV_MULTIGPU_CAPS_V2::reserved
NvU32 _NV_MULTIGPU_CAPS_V2::version
};
NvU32 nTotalGPUs
NvU32 nSLIGPUs
NvU32 videoBridgePresent
NvU32 NvLinkPresent
NvU32 fastNvLinkReads

Detailed Description

SUPPORTED OS: Windows 7 and higher

The documentation for this struct was generated from the following file:


Data Fields
_NV_PIXEL_SHADING_RATE_SAMPLE_ORDER_TABLE_V1 Struct Reference

#include <nvapi.h>

Data Fields

NvU32 version
NV_PIXEL_SRSO_1x2 Pixel_1x2
NV_PIXEL_SRSO_2x1 Pixel_2x1
NV_PIXEL_SRSO_2x2 Pixel_2x2
NV_PIXEL_SRSO_2x4 Pixel_2x4
NV_PIXEL_SRSO_4x2 Pixel_4x2
NV_PIXEL_SRSO_4x4 Pixel_4x4
The documentation for this struct was generated from the following file:


Data Structures | Data Fields
_NV_PIXEL_SRSO_2x1 Struct Reference

#include <nvapi.h>

Data Structures

struct | NV_PIXEL_SRSO_2x1_X1
struct | NV_PIXEL_SRSO_2x1_X2
struct | NV_PIXEL_SRSO_2x1_X4

Data Fields

struct _NV_PIXEL_SRSO_2x1::NV_PIXEL_SRSO_2x1_X1 | X1
struct _NV_PIXEL_SRSO_2x1::NV_PIXEL_SRSO_2x1_X2 | X2
struct _NV_PIXEL_SRSO_2x1::NV_PIXEL_SRSO_2x1_X4 | X4
The documentation for this struct was generated from the following file:


Data Structures | Data Fields
_NV_PIXEL_SRSO_2x2 Struct Reference

#include <nvapi.h>

Data Structures

struct | NV_PIXEL_SRSO_2x2_X1
struct | NV_PIXEL_SRSO_2x2_X2
struct | NV_PIXEL_SRSO_2x2_X4

Data Fields

struct _NV_PIXEL_SRSO_2x2::NV_PIXEL_SRSO_2x2_X1 | X1
struct _NV_PIXEL_SRSO_2x2::NV_PIXEL_SRSO_2x2_X2 | X2
struct _NV_PIXEL_SRSO_2x2::NV_PIXEL_SRSO_2x2_X4 | X4
The documentation for this struct was generated from the following file:


Data Structures | Data Fields
_NV_PIXEL_SRSO_2x4 Struct Reference

#include <nvapi.h>

Data Structures

struct | NV_PIXEL_SRSO_2x4_X1
struct | NV_PIXEL_SRSO_2x4_X2

Data Fields

struct _NV_PIXEL_SRSO_2x4::NV_PIXEL_SRSO_2x4_X1 | X1
struct _NV_PIXEL_SRSO_2x4::NV_PIXEL_SRSO_2x4_X2 | X2
The documentation for this struct was generated from the following file:


Data Structures | Data Fields
_NV_PIXEL_SRSO_4x2 Struct Reference

#include <nvapi.h>

Data Structures

struct NV_PIXEL_SRSO_4x2_X1

Data Fields

struct _NV_PIXEL_SRSO_4x2::NV_PIXEL_SRSO_4x2_X1 X1
The documentation for this struct was generated from the following file:


Data Structures | Data Fields
_NV_PIXEL_SRSO_4x4 Struct Reference

#include <nvapi.h>

Data Structures

struct NV_PIXEL_SRSO_4x4_X1

Data Fields

struct _NV_PIXEL_SRSO_4x4::NV_PIXEL_SRSO_4x4_X1 X1
The documentation for this struct was generated from the following file:


Data Fields
_NV_PRESENT_BARRIER_FRAME_STATISTICS Struct Reference

#include <nvapi.h>

Data Fields

NvU32 dwVersion
NV_PRESENT_BARRIER_SYNC_MODE SyncMode
NvU32 PresentCount
NvU32 PresentInSyncCount
NvU32 FlipInSyncCount
NvU32 RefreshCount
The documentation for this struct was generated from the following file:


Data Fields
_NV_QUERY_SINGLE_PASS_STEREO_SUPPORT_PARAMS_V2 Struct Reference

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 | bSinglePassStereoSupported: 1
NvU32 | bSinglePassStereoXYZWSupported: 1
NvU32 | reserved: 30
The documentation for this struct was generated from the following file:


Data Fields
_NV_RECT Struct Reference

#include <nvapi_lite_common.h>

Data Fields

NvU32 left
NvU32 top
NvU32 right
NvU32 bottom

Field Documentation

◆ bottom

NvU32 _NV_RECT::bottom

◆ left

NvU32 _NV_RECT::left

◆ right

NvU32 _NV_RECT::right

◆ top

NvU32 _NV_RECT::top
The documentation for this struct was generated from the following file:
  • nvapi_lite_common.h


Data Fields
_NV_RESOURCE_PARAMS_V1 Struct Reference

#include <nvapi.h>

Data Fields

NvU32 version
NV_D3D12_RESOURCE_FLAGS NVResourceFlags
The documentation for this struct was generated from the following file:


Data Fields
_NV_SMP_ASSIST_DISABLE_PARAMS_V1 Struct Reference

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 Reserved
The documentation for this struct was generated from the following file:


Data Fields
_NV_SMP_ASSIST_ENABLE_PARAMS_V1 Struct Reference

#include <nvapi.h>

Data Fields

NvU32 version
NV_SMP_ASSIST_EYE_INDEX eEyeIndex
The documentation for this struct was generated from the following file:


Data Fields
_NV_SMP_ASSIST_FASTGSCBDATA_MRS_INSTANCED_STEREO_V1 Struct Reference

#include <nvapi.h>

Data Fields

float | NDCSplitsX [4]
float | NDCSplitsY [2]
The documentation for this struct was generated from the following file:


Data Fields
_NV_SMP_ASSIST_FASTGSCBDATA_V1 Struct Reference

#include <nvapi.h>

Data Fields

float | NDCSplitsX [2]
float | NDCSplitsY [2]
The documentation for this struct was generated from the following file:


Data Fields
_NV_SMP_ASSIST_GET_CONSTANTS_V3 Struct Reference

#include <nvapi.h>

Data Fields

NvU32 version
NV_SMP_ASSIST_EYE_INDEX eEyeIndex
NvU32 numViewports
D3D11_VIEWPORT * | pViewports
D3D11_RECT * | pScissors
NV_SMP_ASSIST_TYPE eSMPAssistType
NV_SMP_ASSIST_LEVEL eSMPAssistLevel
union {
NV_MRS_CUSTOM_CONFIG_V1 _NV_SMP_ASSIST_GET_CONSTANTS_V3::sMRSConfig
NV_LMS_CUSTOM_CONFIG_V1 _NV_SMP_ASSIST_GET_CONSTANTS_V3::sLMSConfig
};
float | projectionSizeWidth
float | projectionSizeHeight
NV_SMP_ASSIST_FASTGSCBDATA_V1 * pFastGSCBData
NV_SMP_ASSIST_REMAPCBDATA_V1 * pRemapCBData
D3D11_VIEWPORT | boundingViewport
D3D11_RECT | boundingScissor
union {
NV_MRS_INSTANCED_STEREO_CONFIG_V1 _NV_SMP_ASSIST_GET_CONSTANTS_V3::sMRS_ISConfig
NV_LMS_INSTANCED_STEREO_CONFIG_V1 _NV_SMP_ASSIST_GET_CONSTANTS_V3::sLMS_ISConfig
};
NV_SMP_ASSIST_FASTGSCBDATA_MRS_INSTANCED_STEREO_V1 * pFastGSCBDataMRS_IS

Detailed Description

SUPPORTED OS: Windows 7 and higher

The documentation for this struct was generated from the following file:


Data Fields
_NV_SMP_ASSIST_INITIALIZE_PARAMS_V1 Struct Reference

#include <nvapi.h>

Data Fields

NvU32 version
NV_SMP_ASSIST_TYPE eSMPAssistType
NV_SMP_ASSIST_LEVEL eSMPAssistLevel
NvU32 flags
ID3DNvSMPAssist ** ppD3DNvSMPAssist

Detailed Description

SUPPORTED OS: Windows 7 and higher

The documentation for this struct was generated from the following file:


Data Fields
_NV_SMP_ASSIST_REMAPCBDATA_V1 Struct Reference

#include <nvapi.h>

Data Fields

float | ClipToWindowSplitsX [2]
float | ClipToWindowSplitsY [2]
float | ClipToWindowX [3][2]
float | ClipToWindowY [3][2]
float | ClipToWindowZ [2]
float | WindowToClipSplitsX [2]
float | WindowToClipSplitsY [2]
float | WindowToClipX [3][2]
float | WindowToClipY [3][2]
float | WindowToClipZ [2]
float | BoundingRectOriginX
float | BoundingRectOriginY
float | BoundingRectSizeWidth
float | BoundingRectSizeHeight
float | BoundingRectSizeInvWidth
float | BoundingRectSizeInvHeight
float | Padding [2]
The documentation for this struct was generated from the following file:


Data Fields
_NV_SMP_ASSIST_SETUP_PARAMS_V1 Struct Reference

#include <nvapi.h>

Data Fields

NvU32 version
union {
NV_MRS_CONFIG _NV_SMP_ASSIST_SETUP_PARAMS_V1::eMRSConfig
NV_LMS_CONFIG _NV_SMP_ASSIST_SETUP_PARAMS_V1::eLMSConfig
NV_MRS_CUSTOM_CONFIG_V1 _NV_SMP_ASSIST_SETUP_PARAMS_V1::sMRSCustomConfig
NV_LMS_CUSTOM_CONFIG_V1 _NV_SMP_ASSIST_SETUP_PARAMS_V1::sLMSCustomConfig
NV_CUSTOM_RECTS_V1 _NV_SMP_ASSIST_SETUP_PARAMS_V1::sCustomRects
};
float | resolutionScale
D3D11_VIEWPORT | boundingBox
float | vpOffsets [2]

Detailed Description

SUPPORTED OS: Windows 7 and higher

The documentation for this struct was generated from the following file:


Data Fields
_NV_SMP_ASSIST_UPDATE_INSTANCEDSTEREO_DATA_PARAMS_V1 Struct Reference

#include <nvapi.h>

Data Fields

NvU32 version
NV_SMP_ASSIST_TYPE eSMPAssistType
float | leftCoeffs [4]
float | leftConst
float | rightCoeffs [4]
float | rightConst
The documentation for this struct was generated from the following file:


Data Fields
_NV_TEX2D_ARRAY_SRRV Struct Reference

#include <nvapi.h>

Data Fields

UINT | MipSlice
UINT | FirstArraySlice
UINT | ArraySize
The documentation for this struct was generated from the following file:


Data Fields
_NV_TEX2D_SRRV Struct Reference

#include <nvapi.h>

Data Fields

UINT MipSlice
The documentation for this struct was generated from the following file:


Data Fields
_NV_VRS_HELPER_DISABLE_PARAMS_V1 Struct Reference

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 reserved
The documentation for this struct was generated from the following file:


Data Fields
_NV_VRS_HELPER_ENABLE_PARAMS_V1 Struct Reference

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 flags
NV_VRS_RENDER_MODE RenderMode
NV_VRS_CONTENT_TYPE ContentType
NV_FOVEATED_RENDERING_DESC_V1 sFoveatedRenderingDesc
The documentation for this struct was generated from the following file:


Data Fields
_NV_VRS_HELPER_GET_SHADING_RATE_RESOURCE_PARAMS_V1 Struct Reference

#include <nvapi.h>

Data Fields

NvU32 version
IUnknown ** ppShadingRateResource
NV_PIXEL_SHADING_RATE shadingRateTable [NV_MAX_PIXEL_SHADING_RATES]
The documentation for this struct was generated from the following file:


Data Fields
_NV_VRS_HELPER_INIT_PARAMS_V1 Struct Reference

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 flags
ID3DNvVRSHelper_V1 ** ppVRSHelper
The documentation for this struct was generated from the following file:


Data Fields
_NV_VRS_HELPER_LATCH_GAZE_PARAMS_V1 Struct Reference

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 flags

Detailed Description

SUPPORTED OS: Windows 7 and higher

The documentation for this struct was generated from the following file:


Data Fields
_NV_VRS_HELPER_PURGE_INTERNAL_RESOURCES_PARAMS_V1 Struct Reference

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 reserved
The documentation for this struct was generated from the following file:


Data Fields
_NVAPI_CU_KERNEL_LAUNCH_PARAMS Struct Reference

#include <nvapi.h>

Data Fields

NVDX_ObjectHandle | hFunction
NVAPI_DIM3 gridDim
NVAPI_DIM3 blockDim
NvU32 dynSharedMemBytes
void const * | pParams
NvU32 paramSize
The documentation for this struct was generated from the following file:


Data Fields
_NVAPI_CU_KERNEL_LAUNCH_PARAMS_EX Struct Reference

#include <nvapi.h>

Data Fields

NVDX_ObjectHandle | hFunction
NVAPI_DIM3 gridDim
NVAPI_DIM3 blockDim
NvU32 dynSharedMemBytes
void const * | pParams
NvU32 paramSize
void ** | kernelParams

Detailed Description

SUPPORTED OS: Windows 10 and higher

The documentation for this struct was generated from the following file:


Data Fields
_NVAPI_DIM3 Struct Reference

#include <nvapi.h>

Data Fields

NvU32 x
NvU32 y
NvU32 z

Detailed Description

SUPPORTED OS: Windows 10 and higher

The documentation for this struct was generated from the following file:


Data Fields
_SettingDWORDNameString Struct Reference

#include <NvApiDriverSettings.h>

Data Fields

NvU32 settingId
const wchar_t * settingNameString
NvU32 numSettingValues
NvU32 * settingValues
NvU32 defaultValue

Field Documentation

◆ defaultValue

NvU32 _SettingDWORDNameString::defaultValue

◆ numSettingValues

NvU32 _SettingDWORDNameString::numSettingValues

◆ settingId

NvU32 _SettingDWORDNameString::settingId

◆ settingNameString

const wchar_t* _SettingDWORDNameString::settingNameString

◆ settingValues

NvU32* _SettingDWORDNameString::settingValues
The documentation for this struct was generated from the following file:
  • NvApiDriverSettings.h


Data Fields
_SettingWSTRINGNameString Struct Reference

#include <NvApiDriverSettings.h>

Data Fields

NvU32 settingId
const wchar_t * | settingNameString
NvU32 numSettingValues
const wchar_t ** | settingValues
const wchar_t * | defaultValue

Field Documentation

◆ defaultValue

const wchar_t* _SettingWSTRINGNameString::defaultValue

◆ numSettingValues

NvU32 _SettingWSTRINGNameString::numSettingValues

◆ settingId

NvU32 _SettingWSTRINGNameString::settingId

◆ settingNameString

const wchar_t* _SettingWSTRINGNameString::settingNameString

◆ settingValues

const wchar_t** _SettingWSTRINGNameString::settingValues
The documentation for this struct was generated from the following file:
  • NvApiDriverSettings.h


Public Member Functions
INvAPI_DirectD3D12GraphicsCommandList Class Referenceabstract

#include <nvapi.h>

Public Member Functions

virtual bool | IsValid () const =0
virtual ID3D12GraphicsCommandList * | GetID3D12GraphicsCommandList () const =0
void | DispatchGraphics (NvU32 numDispatches)
void | SetMarker (void *pMarkerData, NvU32 markerSize)

Detailed Description

SUPPORTED OS: Windows 10 and higher

The documentation for this class was generated from the following file:


Data Fields
NV_D3D11_META_COMMAND_EXECUTE_CONVOLUTION_EX_DESC Struct Reference

#include <nvapi.h>

Data Fields

NV_D3D11_META_COMMAND_RESOURCE InputResource
NV_D3D11_META_COMMAND_RESOURCE FilterResource
NV_D3D11_META_COMMAND_RESOURCE BiasResource
NV_D3D11_META_COMMAND_RESOURCE OutputResource
NV_D3D11_META_COMMAND_RESOURCE Alpha1Resource
NV_D3D11_META_COMMAND_RESOURCE Alpha2Resource
NV_D3D11_META_COMMAND_RESOURCE SkipConnectionResource
NV_D3D11_META_COMMAND_RESOURCE PersistentResource
NV_D3D11_META_COMMAND_RESOURCE TemporaryResource
The documentation for this struct was generated from the following file:


Data Fields
NV_D3D11_META_COMMAND_EXECUTE_GEMM_DESC Struct Reference

#include <nvapi.h>

Data Fields

NV_D3D11_META_COMMAND_RESOURCE AResource
NV_D3D11_META_COMMAND_RESOURCE BResource
NV_D3D11_META_COMMAND_RESOURCE CResource
NV_D3D11_META_COMMAND_RESOURCE OutputResource
NV_D3D11_META_COMMAND_RESOURCE PersistentResource
NV_D3D11_META_COMMAND_RESOURCE TemporaryResource
The documentation for this struct was generated from the following file:


Data Fields
NV_D3D11_META_COMMAND_INITIALIZE_CONVOLUTION_EX_DESC Struct Reference

#include <nvapi.h>

Data Fields

NV_D3D11_META_COMMAND_RESOURCE PersistentResource
The documentation for this struct was generated from the following file:


Data Fields
NV_D3D11_META_COMMAND_INITIALIZE_GEMM_DESC Struct Reference

#include <nvapi.h>

Data Fields

NV_D3D11_META_COMMAND_RESOURCE PersistentResource
The documentation for this struct was generated from the following file:


Data Fields
NV_D3D12_META_COMMAND_EXECUTE_CONVOLUTION_EX_DESC Struct Reference

#include <nvapi.h>

Data Fields

D3D12_GPU_VIRTUAL_ADDRESS | InputResource
D3D12_GPU_VIRTUAL_ADDRESS | FilterResource
D3D12_GPU_VIRTUAL_ADDRESS | BiasResource
D3D12_GPU_VIRTUAL_ADDRESS | OutputResource
D3D12_GPU_VIRTUAL_ADDRESS | Alpha1Resource
D3D12_GPU_VIRTUAL_ADDRESS | Alpha2Resource
D3D12_GPU_VIRTUAL_ADDRESS | SkipConnectionResource
D3D12_GPU_VIRTUAL_ADDRESS | PersistentResource
D3D12_GPU_VIRTUAL_ADDRESS | TemporaryResource
The documentation for this struct was generated from the following file:


Data Fields
NV_D3D12_META_COMMAND_EXECUTE_GEMM_DESC Struct Reference

#include <nvapi.h>

Data Fields

NvU64 AResource
NvU64 BResource
NvU64 CResource
NvU64 OutputResource
NvU64 PersistentResource
NvU64 TemporaryResource
The documentation for this struct was generated from the following file:


Data Fields
NV_D3D12_META_COMMAND_INITIALIZE_GEMM_DESC Struct Reference

#include <nvapi.h>

Data Fields

NvU64 PersistentResource
The documentation for this struct was generated from the following file:


Data Fields
NV_EDID_V1 Struct Reference

#include <nvapi.h>

Data Fields

NvU32 version
NvU8 EDID_Data [NV_EDID_DATA_SIZE]
The documentation for this struct was generated from the following file:


Data Fields
NV_EDID_V2 Struct Reference

#include <nvapi.h>

Data Fields

NvU32 version
NvU8 EDID_Data [NV_EDID_DATA_SIZE]
NvU32 sizeofEDID

Detailed Description

Used in NvAPI_GPU_GetEDID()

The documentation for this struct was generated from the following file:


Data Fields
NV_EDID_V3 Struct Reference

#include <nvapi.h>

Data Fields

NvU32 version
NvU8 EDID_Data [NV_EDID_DATA_SIZE]
NvU32 sizeofEDID
NvU32 edidId
NvU32 offset

Detailed Description

Used in NvAPI_GPU_GetEDID()

The documentation for this struct was generated from the following file:


Data Fields
NV_GET_CURRENT_SLI_STATE_V2 Struct Reference

#include <nvapi_lite_sli.h>

Data Fields

NvU32 version
NvU32 maxNumAFRGroups
NvU32 numAFRGroups
NvU32 currentAFRIndex
NvU32 nextFrameAFRIndex
NvU32 previousFrameAFRIndex
NvU32 bIsCurAFRGroupNew
NvU32 numVRSLIGpus

Field Documentation

◆ bIsCurAFRGroupNew

NvU32 NV_GET_CURRENT_SLI_STATE_V2::bIsCurAFRGroupNew

[OUT] Boolean: Is this frame the first time running on the current AFR group

◆ currentAFRIndex

NvU32 NV_GET_CURRENT_SLI_STATE_V2::currentAFRIndex

[OUT] The AFR group index for the frame currently being rendered

◆ maxNumAFRGroups

NvU32 NV_GET_CURRENT_SLI_STATE_V2::maxNumAFRGroups

[OUT] The maximum possible value of numAFRGroups

◆ nextFrameAFRIndex

NvU32 NV_GET_CURRENT_SLI_STATE_V2::nextFrameAFRIndex

[OUT] What the AFR group index will be for the next frame (i.e. after calling Present)

◆ numAFRGroups

NvU32 NV_GET_CURRENT_SLI_STATE_V2::numAFRGroups

[OUT] The number of AFR groups enabled in the system

◆ numVRSLIGpus

NvU32 NV_GET_CURRENT_SLI_STATE_V2::numVRSLIGpus

[OUT] The number of GPUs used in VR-SLI. If it is 0 VR-SLI is not active

◆ previousFrameAFRIndex

NvU32 NV_GET_CURRENT_SLI_STATE_V2::previousFrameAFRIndex

[OUT] The AFR group index that was used for the previous frame (~0 if more than one frame has not been rendered yet)

◆ version

NvU32 NV_GET_CURRENT_SLI_STATE_V2::version

Structure version.

The documentation for this struct was generated from the following file:
  • nvapi_lite_sli.h


Data Fields
NV_GET_GPU_VIRTUAL_ADDRESS_V1 Struct Reference

#include <nvapi.h>

Data Fields

NvU32 version
NVDX_ObjectHandle hResource
NvU64 gpuVAStart
NvU64 gpuVASize
The documentation for this struct was generated from the following file:


Data Fields
NV_META_COMMAND_ACTIVATION_DESC Struct Reference

#include <nvapi.h>

Inheritance diagram for NV_META_COMMAND_ACTIVATION_DESC:
NV_META_COMMAND_OPTIONAL_ACTIVATION_DESC

Data Fields

NvU64 Function
float Params [NV_META_COMMAND_ACTIVATION_MAX_PARAMS]
The documentation for this struct was generated from the following file:


Data Fields
NV_META_COMMAND_CONVOLUTION_FUSE_DESC Struct Reference

#include <nvapi.h>

Data Fields

NV_META_COMMAND_CONVOLUTION_POOL_MODE PoolMode
NV_META_COMMAND_CONVOLUTION_UPSAMPLE_MODE UpsampleMode
NV_META_COMMAND_CONVOLUTION_SKIP_MODE SkipMode
NV_META_COMMAND_BOOL OutputPrepool
The documentation for this struct was generated from the following file:


Data Fields
NV_META_COMMAND_CREATE_CONVOLUTION_EX_DESC Struct Reference

#include <nvapi.h>

Inheritance diagram for NV_META_COMMAND_CREATE_CONVOLUTION_EX_DESC:
NV_META_COMMAND_CREATE_CONVOLUTION_EX_FUSED_DESC

Data Fields

NV_META_COMMAND_TENSOR_DESC DescIn
NV_META_COMMAND_TENSOR_DESC DescFilter
NV_META_COMMAND_OPTIONAL_TENSOR_DESC DescBias
NV_META_COMMAND_TENSOR_DESC DescOut
NvU64 Mode
NvU64 Direction
NvU64 Precision
NV_META_COMMAND_OPTIONAL_ACTIVATION_DESC Activation
NV_META_COMMAND_PADDING_DESC Padding
NV_META_COMMAND_BOOL PerChannelScaling
float | Alpha1
float | Alpha2
NvU64 Stride [NV_META_COMMAND_NUM_SPATIAL_DIM]
NvU64 Dilation [NV_META_COMMAND_NUM_SPATIAL_DIM]
NvU64 StartPadding [NV_META_COMMAND_NUM_SPATIAL_DIM]
NvU64 EndPadding [NV_META_COMMAND_NUM_SPATIAL_DIM]
NvU64 DimensionCount
NvU64 GroupCount
The documentation for this struct was generated from the following file:


Data Fields
NV_META_COMMAND_CREATE_CONVOLUTION_EX_FUSED_DESC Struct Reference

#include <nvapi.h>

Inheritance diagram for NV_META_COMMAND_CREATE_CONVOLUTION_EX_FUSED_DESC:
NV_META_COMMAND_CREATE_CONVOLUTION_EX_DESC

Data Fields

NV_META_COMMAND_CONVOLUTION_FUSE_DESC FuseDesc
- Data Fields inherited from NV_META_COMMAND_CREATE_CONVOLUTION_EX_DESC
NV_META_COMMAND_TENSOR_DESC DescIn
NV_META_COMMAND_TENSOR_DESC DescFilter
NV_META_COMMAND_OPTIONAL_TENSOR_DESC DescBias
NV_META_COMMAND_TENSOR_DESC DescOut
NvU64 Mode
NvU64 Direction
NvU64 Precision
NV_META_COMMAND_OPTIONAL_ACTIVATION_DESC Activation
NV_META_COMMAND_PADDING_DESC Padding
NV_META_COMMAND_BOOL PerChannelScaling
float | Alpha1
float | Alpha2
NvU64 Stride [NV_META_COMMAND_NUM_SPATIAL_DIM]
NvU64 Dilation [NV_META_COMMAND_NUM_SPATIAL_DIM]
NvU64 StartPadding [NV_META_COMMAND_NUM_SPATIAL_DIM]
NvU64 EndPadding [NV_META_COMMAND_NUM_SPATIAL_DIM]
NvU64 DimensionCount
NvU64 GroupCount
The documentation for this struct was generated from the following file:


Data Fields
NV_META_COMMAND_CREATE_GEMM_DESC Struct Reference

#include <nvapi.h>

Data Fields

NV_META_COMMAND_TENSOR_DESC DescA
NV_META_COMMAND_TENSOR_DESC DescB
NV_META_COMMAND_OPTIONAL_TENSOR_DESC DescC
NV_META_COMMAND_TENSOR_DESC DescOut
NvU64 Precision
NvU64 TransA
NvU64 TransB
float | Alpha
float | Beta
NV_META_COMMAND_OPTIONAL_ACTIVATION_DESC Activation
The documentation for this struct was generated from the following file:


Data Fields
NV_META_COMMAND_OPTIONAL_ACTIVATION_DESC Struct Reference

#include <nvapi.h>

Inheritance diagram for NV_META_COMMAND_OPTIONAL_ACTIVATION_DESC:
NV_META_COMMAND_ACTIVATION_DESC

Data Fields

NV_META_COMMAND_BOOL IsNull
- Data Fields inherited from NV_META_COMMAND_ACTIVATION_DESC
NvU64 Function
float Params [NV_META_COMMAND_ACTIVATION_MAX_PARAMS]
The documentation for this struct was generated from the following file:


Data Fields
NV_META_COMMAND_OPTIONAL_TENSOR_DESC Struct Reference

#include <nvapi.h>

Inheritance diagram for NV_META_COMMAND_OPTIONAL_TENSOR_DESC:
NV_META_COMMAND_TENSOR_DESC

Data Fields

NV_META_COMMAND_BOOL IsNull
- Data Fields inherited from NV_META_COMMAND_TENSOR_DESC
NvU64 DataType
NvU64 Layout
NvU64 Flags
NvU64 DimensionCount
NvU64 Size [NV_META_COMMAND_MAX_TENSOR_DIM]
NvU64 Stride [NV_META_COMMAND_MAX_TENSOR_DIM]
The documentation for this struct was generated from the following file:


Data Fields
NV_META_COMMAND_PADDING_DESC Struct Reference

#include <nvapi.h>

Data Fields

NV_META_COMMAND_PADDING_MODE Mode
float ConstantPadVal
The documentation for this struct was generated from the following file:


Data Fields
NV_META_COMMAND_TENSOR_DESC Struct Reference

#include <nvapi.h>

Inheritance diagram for NV_META_COMMAND_TENSOR_DESC:
NV_META_COMMAND_OPTIONAL_TENSOR_DESC

Data Fields

NvU64 DataType
NvU64 Layout
NvU64 Flags
NvU64 DimensionCount
NvU64 Size [NV_META_COMMAND_MAX_TENSOR_DIM]
NvU64 Stride [NV_META_COMMAND_MAX_TENSOR_DIM]
The documentation for this struct was generated from the following file:


Data Fields
NV_VIEWPORTF Struct Reference

#include <nvapi.h>

Data Fields

float | x
float | y
float | w
float | h
The documentation for this struct was generated from the following file:


Data Fields
NVAPI_ANSEL_CONFIGURATION_STRUCT_V1 Struct Reference

#include <nvapi.h>

Data Fields

NvU32 version
NVAPI_ANSEL_HOTKEY_MODIFIER hotkeyModifier
UINT | keyEnable
UINT | numAnselFeatures
NVAPI_ANSEL_FEATURE_CONFIGURATION_STRUCT * pAnselFeatures
The documentation for this struct was generated from the following file:


Data Fields
NVAPI_ANSEL_FEATURE_CONFIGURATION_STRUCT Struct Reference

#include <nvapi.h>

Data Fields

NVAPI_ANSEL_FEATURE featureId
NVAPI_ANSEL_FEATURE_STATE featureState
UINT hotkey
The documentation for this struct was generated from the following file:


Data Fields
NvAPI_D3D11_CREATE_DOMAIN_SHADER_EX_V1 Struct Reference

#include <nvapi.h>

Data Fields

UINT version
NvU32 NumCustomSemantics
NV_CUSTOM_SEMANTIC * pCustomSemantics

Detailed Description

SUPPORTED OS: Windows 7 and higher

The documentation for this struct was generated from the following file:


Data Fields
NvAPI_D3D11_CREATE_DOMAIN_SHADER_EX_V2 Struct Reference

#include <nvapi.h>

Data Fields

UINT | version
NvU32 NumCustomSemantics
NV_CUSTOM_SEMANTIC * pCustomSemantics
BOOL | UseWithFastGS
The documentation for this struct was generated from the following file:


Data Fields
NvAPI_D3D11_CREATE_DOMAIN_SHADER_EX_V3 Struct Reference

#include <nvapi.h>

Data Fields

UINT | version
NvU32 NumCustomSemantics
NV_CUSTOM_SEMANTIC * pCustomSemantics
BOOL | UseWithFastGS
BOOL | UseSpecificShaderExt
The documentation for this struct was generated from the following file:


Data Fields
NvAPI_D3D11_CREATE_FASTGS_EXPLICIT_DESC_V1 Struct Reference

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 flags
NvAPI_D3D11_SWIZZLE_MODE * pCoordinateSwizzling
The documentation for this struct was generated from the following file:


Data Fields
NvAPI_D3D11_CREATE_GEOMETRY_SHADER_EX_V5 Struct Reference

#include <nvapi.h>

Data Fields

UINT | version
BOOL | UseViewportMask
BOOL | OffsetRtIndexByVpIndex
BOOL | ForceFastGS
BOOL | DontUseViewportOrder
BOOL | UseAttributeSkipMask
BOOL | UseCoordinateSwizzle
NvAPI_D3D11_SWIZZLE_MODE * pCoordinateSwizzling
NvU32 NumCustomSemantics
NV_CUSTOM_SEMANTIC * pCustomSemantics
BOOL | ConvertToFastGS
BOOL | UseSpecificShaderExt
The documentation for this struct was generated from the following file:


Data Fields
NvAPI_D3D11_CREATE_HULL_SHADER_EX_V1 Struct Reference

#include <nvapi.h>

Data Fields

UINT | version
NvU32 NumCustomSemantics
NV_CUSTOM_SEMANTIC * pCustomSemantics
BOOL | UseWithFastGS

Detailed Description

SUPPORTED OS: Windows 7 and higher

The documentation for this struct was generated from the following file:


Data Fields
NvAPI_D3D11_CREATE_HULL_SHADER_EX_V2 Struct Reference

#include <nvapi.h>

Data Fields

UINT | version
NvU32 NumCustomSemantics
NV_CUSTOM_SEMANTIC * pCustomSemantics
BOOL | UseWithFastGS
BOOL | UseSpecificShaderExt
The documentation for this struct was generated from the following file:


Data Fields
NvAPI_D3D11_CREATE_PIXEL_SHADER_EX_V1 Struct Reference

#include <nvapi.h>

Data Fields

UINT version
NvU32 NumCustomSemantics
NV_CUSTOM_SEMANTIC * pCustomSemantics

Detailed Description

SUPPORTED OS: Windows 7 and higher

The documentation for this struct was generated from the following file:


Data Fields
NvAPI_D3D11_CREATE_PIXEL_SHADER_EX_V2 Struct Reference

#include <nvapi.h>

Data Fields

UINT | version
NvU32 NumCustomSemantics
NV_CUSTOM_SEMANTIC * pCustomSemantics
NvU32 | bEnableSuperSamplingPredicationForVRS: 1
NvU32 | bEnableSuperSamplingPredicationForVRSAllAttributes: 1
NvU32 | reserved: 30
The documentation for this struct was generated from the following file:


Data Fields
NvAPI_D3D11_CREATE_VERTEX_SHADER_EX_V1 Struct Reference

#include <nvapi.h>

Data Fields

UINT version
NvU32 NumCustomSemantics
NV_CUSTOM_SEMANTIC * pCustomSemantics

Detailed Description

SUPPORTED OS: Windows 7 and higher

The documentation for this struct was generated from the following file:


Data Fields
NvAPI_D3D11_CREATE_VERTEX_SHADER_EX_V2 Struct Reference

#include <nvapi.h>

Data Fields

UINT | version
NvU32 NumCustomSemantics
NV_CUSTOM_SEMANTIC * pCustomSemantics
BOOL | UseWithFastGS
The documentation for this struct was generated from the following file:


Data Fields
NvAPI_D3D11_CREATE_VERTEX_SHADER_EX_V3 Struct Reference

#include <nvapi.h>

Data Fields

UINT | version
NvU32 NumCustomSemantics
NV_CUSTOM_SEMANTIC * pCustomSemantics
BOOL | UseWithFastGS
BOOL | UseSpecificShaderExt
The documentation for this struct was generated from the following file:


Data Fields
NvAPI_D3D11_RASTERIZER_DESC_EX Struct Reference

#include <nvapi.h>

Data Fields

D3D11_FILL_MODE | FillMode
D3D11_CULL_MODE | CullMode
BOOL | FrontCounterClockwise
INT | DepthBias
FLOAT | DepthBiasClamp
FLOAT | SlopeScaledDepthBias
BOOL | DepthClipEnable
BOOL | ScissorEnable
BOOL | MultisampleEnable
BOOL | AntialiasedLineEnable
NvU32 ForcedSampleCount
bool | ProgrammableSamplePositionsEnable
bool | InterleavedSamplingEnable
NvU8 SampleCount
NvU8 | SamplePositionsX [16]
NvU8 | SamplePositionsY [16]
bool | ConservativeRasterEnable
NVAPI_QUAD_FILLMODE QuadFillMode
bool | PostZCoverageEnable
bool | CoverageToColorEnable
NvU8 CoverageToColorRTIndex
bool | TargetIndepentRasterWithDepth
NvU8 | reserved [63]

Detailed Description

SUPPORTED OS: Windows 7 and higher

The documentation for this struct was generated from the following file:


Data Fields
NVAPI_D3D12_CREATE_CUBIN_SHADER_PARAMS Struct Reference

#include <nvapi.h>

Data Fields

size_t | structSizeIn
size_t | structSizeOut
ID3D12Device * | pDevice
const void * | pCubin
NvU32 size
NvU32 blockX
NvU32 blockY
NvU32 blockZ
NvU32 dynSharedMemBytes
const char * | pShaderName
NvU32 flags
NVDX_ObjectHandle | hShader

Detailed Description

SUPPORTED OS: Windows 10 and higher

The documentation for this struct was generated from the following file:


Data Fields
NVAPI_D3D12_GET_CUDA_INDEPENDENT_DESCRIPTOR_OBJECT_PARAMS Struct Reference

#include <nvapi.h>

Data Fields

size_t | structSizeIn
size_t | structSizeOut
ID3D12Device * | pDevice
NVAPI_D3D12_GET_CUDA_INDEPENDENT_DESCRIPTOR_OBJECT_TYPE type
D3D12_CPU_DESCRIPTOR_HANDLE | desc
NvU64 handle
The documentation for this struct was generated from the following file:


Data Fields
NVAPI_D3D12_GET_CUDA_MERGED_TEXTURE_SAMPLER_OBJECT_PARAMS Struct Reference

#include <nvapi.h>

Data Fields

size_t | structSizeIn
size_t | structSizeOut
ID3D12Device * | pDevice
D3D12_CPU_DESCRIPTOR_HANDLE | texDesc
D3D12_CPU_DESCRIPTOR_HANDLE | smpDesc
NvU64 textureHandle

Detailed Description

SUPPORTED OS: Windows 10 and higher

The documentation for this struct was generated from the following file:


Data Fields
NVAPI_D3D12_PSO_CREATE_FASTGS_EXPLICIT_DESC_V1 Struct Reference

#include <nvapi.h>

Inheritance diagram for NVAPI_D3D12_PSO_CREATE_FASTGS_EXPLICIT_DESC_V1:
NVAPI_D3D12_PSO_EXTENSION_DESC_V1

Data Fields

NvU32 version
NvU32 flags
NvAPI_D3D11_SWIZZLE_MODE * pCoordinateSwizzling
- Data Fields inherited from NVAPI_D3D12_PSO_EXTENSION_DESC_V1
NvU32 baseVersion
NV_PSO_EXTENSION psoExtension
The documentation for this struct was generated from the following file:


Data Fields
NVAPI_D3D12_PSO_DOMAIN_SHADER_DESC_V1 Struct Reference

#include <nvapi.h>

Inheritance diagram for NVAPI_D3D12_PSO_DOMAIN_SHADER_DESC_V1:
NVAPI_D3D12_PSO_EXTENSION_DESC_V1 NVAPI_D3D12_PSO_DOMAIN_SHADER_DESC_V2 NVAPI_D3D12_PSO_DOMAIN_SHADER_DESC_V3

Data Fields

NvU32 version
NvU32 NumCustomSemantics
NV_CUSTOM_SEMANTIC * pCustomSemantics
- Data Fields inherited from NVAPI_D3D12_PSO_EXTENSION_DESC_V1
NvU32 baseVersion
NV_PSO_EXTENSION psoExtension
The documentation for this struct was generated from the following file:


Data Fields
NVAPI_D3D12_PSO_DOMAIN_SHADER_DESC_V2 Struct Reference

#include <nvapi.h>

Inheritance diagram for NVAPI_D3D12_PSO_DOMAIN_SHADER_DESC_V2:
NVAPI_D3D12_PSO_DOMAIN_SHADER_DESC_V1 NVAPI_D3D12_PSO_EXTENSION_DESC_V1 NVAPI_D3D12_PSO_DOMAIN_SHADER_DESC_V3

Data Fields

BOOL UseWithFastGS
- Data Fields inherited from NVAPI_D3D12_PSO_DOMAIN_SHADER_DESC_V1
NvU32 version
NvU32 NumCustomSemantics
NV_CUSTOM_SEMANTIC * pCustomSemantics
- Data Fields inherited from NVAPI_D3D12_PSO_EXTENSION_DESC_V1
NvU32 baseVersion
NV_PSO_EXTENSION psoExtension
The documentation for this struct was generated from the following file:


Data Fields
NVAPI_D3D12_PSO_DOMAIN_SHADER_DESC_V3 Struct Reference

#include <nvapi.h>

Inheritance diagram for NVAPI_D3D12_PSO_DOMAIN_SHADER_DESC_V3:
NVAPI_D3D12_PSO_DOMAIN_SHADER_DESC_V2 NVAPI_D3D12_PSO_DOMAIN_SHADER_DESC_V1 NVAPI_D3D12_PSO_EXTENSION_DESC_V1

Data Fields

BOOL | UseSpecificShaderExt
- Data Fields inherited from NVAPI_D3D12_PSO_DOMAIN_SHADER_DESC_V2
BOOL | UseWithFastGS
- Data Fields inherited from NVAPI_D3D12_PSO_DOMAIN_SHADER_DESC_V1
NvU32 version
NvU32 NumCustomSemantics
NV_CUSTOM_SEMANTIC * pCustomSemantics
- Data Fields inherited from NVAPI_D3D12_PSO_EXTENSION_DESC_V1
NvU32 baseVersion
NV_PSO_EXTENSION psoExtension
The documentation for this struct was generated from the following file:


Data Fields
NVAPI_D3D12_PSO_ENABLE_DEPTH_BOUND_TEST_DESC_V1 Struct Reference

#include <nvapi.h>

Inheritance diagram for NVAPI_D3D12_PSO_ENABLE_DEPTH_BOUND_TEST_DESC_V1:
NVAPI_D3D12_PSO_EXTENSION_DESC_V1

Data Fields

NvU32 version
bool EnableDBT
- Data Fields inherited from NVAPI_D3D12_PSO_EXTENSION_DESC_V1
NvU32 baseVersion
NV_PSO_EXTENSION psoExtension
The documentation for this struct was generated from the following file:


Data Fields
NVAPI_D3D12_PSO_EXTENSION_DESC_V1 Struct Reference

#include <nvapi.h>

Inheritance diagram for NVAPI_D3D12_PSO_EXTENSION_DESC_V1:
NVAPI_D3D12_PSO_CREATE_FASTGS_EXPLICIT_DESC_V1 NVAPI_D3D12_PSO_DOMAIN_SHADER_DESC_V1 NVAPI_D3D12_PSO_ENABLE_DEPTH_BOUND_TEST_DESC_V1 NVAPI_D3D12_PSO_GEOMETRY_SHADER_DESC_V5 NVAPI_D3D12_PSO_HULL_SHADER_DESC_V1 NVAPI_D3D12_PSO_RASTERIZER_STATE_DESC_V1 NVAPI_D3D12_PSO_REQUEST_FAST_GEOMETRY_SHADER_DESC_V1 NVAPI_D3D12_PSO_SET_SHADER_EXTENSION_SLOT_DESC_V1 NVAPI_D3D12_PSO_VERTEX_SHADER_DESC_V1

Data Fields

NvU32 baseVersion
NV_PSO_EXTENSION psoExtension
The documentation for this struct was generated from the following file:


Data Fields
NVAPI_D3D12_PSO_GEOMETRY_SHADER_DESC_V5 Struct Reference

#include <nvapi.h>

Inheritance diagram for NVAPI_D3D12_PSO_GEOMETRY_SHADER_DESC_V5:
NVAPI_D3D12_PSO_EXTENSION_DESC_V1

Data Fields

NvU32 version
BOOL | UseViewportMask
BOOL | OffsetRtIndexByVpIndex
BOOL | ForceFastGS
BOOL | DontUseViewportOrder
BOOL | UseAttributeSkipMask
BOOL | UseCoordinateSwizzle
NvAPI_D3D11_SWIZZLE_MODE * pCoordinateSwizzling
NvU32 NumCustomSemantics
NV_CUSTOM_SEMANTIC * pCustomSemantics
BOOL | ConvertToFastGS
BOOL | UseSpecificShaderExt
- Data Fields inherited from NVAPI_D3D12_PSO_EXTENSION_DESC_V1
NvU32 baseVersion
NV_PSO_EXTENSION psoExtension
The documentation for this struct was generated from the following file:


Data Fields
NVAPI_D3D12_PSO_HULL_SHADER_DESC_V1 Struct Reference

#include <nvapi.h>

Inheritance diagram for NVAPI_D3D12_PSO_HULL_SHADER_DESC_V1:
NVAPI_D3D12_PSO_EXTENSION_DESC_V1 NVAPI_D3D12_PSO_HULL_SHADER_DESC_V2

Data Fields

NvU32 version
NvU32 NumCustomSemantics
NV_CUSTOM_SEMANTIC * pCustomSemantics
BOOL UseWithFastGS
- Data Fields inherited from NVAPI_D3D12_PSO_EXTENSION_DESC_V1
NvU32 baseVersion
NV_PSO_EXTENSION psoExtension
The documentation for this struct was generated from the following file:


Data Fields
NVAPI_D3D12_PSO_HULL_SHADER_DESC_V2 Struct Reference

#include <nvapi.h>

Inheritance diagram for NVAPI_D3D12_PSO_HULL_SHADER_DESC_V2:
NVAPI_D3D12_PSO_HULL_SHADER_DESC_V1 NVAPI_D3D12_PSO_EXTENSION_DESC_V1

Data Fields

BOOL | UseSpecificShaderExt
- Data Fields inherited from NVAPI_D3D12_PSO_HULL_SHADER_DESC_V1
NvU32 version
NvU32 NumCustomSemantics
NV_CUSTOM_SEMANTIC * pCustomSemantics
BOOL | UseWithFastGS
- Data Fields inherited from NVAPI_D3D12_PSO_EXTENSION_DESC_V1
NvU32 baseVersion
NV_PSO_EXTENSION psoExtension
The documentation for this struct was generated from the following file:


Data Fields
NVAPI_D3D12_PSO_RASTERIZER_STATE_DESC_V1 Struct Reference

#include <nvapi.h>

Inheritance diagram for NVAPI_D3D12_PSO_RASTERIZER_STATE_DESC_V1:
NVAPI_D3D12_PSO_EXTENSION_DESC_V1

Data Fields

NvU32 version
bool | ProgrammableSamplePositionsEnable
bool | InterleavedSamplingEnable
NvU8 SampleCount
NvU8 | SamplePositionsX [16]
NvU8 | SamplePositionsY [16]
NVAPI_QUAD_FILLMODE QuadFillMode
bool | PostZCoverageEnable
bool | CoverageToColorEnable
NvU8 CoverageToColorRTIndex
bool | TargetIndepentRasterWithDepth
NvU8 ForcedSampleCount
NvU8 | reserved [62]
- Data Fields inherited from NVAPI_D3D12_PSO_EXTENSION_DESC_V1
NvU32 baseVersion
NV_PSO_EXTENSION psoExtension
The documentation for this struct was generated from the following file:


Data Fields
NVAPI_D3D12_PSO_REQUEST_FAST_GEOMETRY_SHADER_DESC_V1 Struct Reference

#include <nvapi.h>

Inheritance diagram for NVAPI_D3D12_PSO_REQUEST_FAST_GEOMETRY_SHADER_DESC_V1:
NVAPI_D3D12_PSO_EXTENSION_DESC_V1

Data Fields

NvU32 version
- Data Fields inherited from NVAPI_D3D12_PSO_EXTENSION_DESC_V1
NvU32 baseVersion
NV_PSO_EXTENSION psoExtension
The documentation for this struct was generated from the following file:


Data Fields
NVAPI_D3D12_PSO_SET_SHADER_EXTENSION_SLOT_DESC_V1 Struct Reference

#include <nvapi.h>

Inheritance diagram for NVAPI_D3D12_PSO_SET_SHADER_EXTENSION_SLOT_DESC_V1:
NVAPI_D3D12_PSO_EXTENSION_DESC_V1

Data Fields

NvU32 version
NvU32 uavSlot
NvU32 registerSpace
- Data Fields inherited from NVAPI_D3D12_PSO_EXTENSION_DESC_V1
NvU32 baseVersion
NV_PSO_EXTENSION psoExtension
The documentation for this struct was generated from the following file:


Data Fields
NVAPI_D3D12_PSO_VERTEX_SHADER_DESC_V1 Struct Reference

#include <nvapi.h>

Inheritance diagram for NVAPI_D3D12_PSO_VERTEX_SHADER_DESC_V1:
NVAPI_D3D12_PSO_EXTENSION_DESC_V1 NVAPI_D3D12_PSO_VERTEX_SHADER_DESC_V2 NVAPI_D3D12_PSO_VERTEX_SHADER_DESC_V3

Data Fields

NvU32 version
NvU32 NumCustomSemantics
NV_CUSTOM_SEMANTIC * pCustomSemantics
- Data Fields inherited from NVAPI_D3D12_PSO_EXTENSION_DESC_V1
NvU32 baseVersion
NV_PSO_EXTENSION psoExtension
The documentation for this struct was generated from the following file:


Data Fields
NVAPI_D3D12_PSO_VERTEX_SHADER_DESC_V2 Struct Reference

#include <nvapi.h>

Inheritance diagram for NVAPI_D3D12_PSO_VERTEX_SHADER_DESC_V2:
NVAPI_D3D12_PSO_VERTEX_SHADER_DESC_V1 NVAPI_D3D12_PSO_EXTENSION_DESC_V1 NVAPI_D3D12_PSO_VERTEX_SHADER_DESC_V3

Data Fields

BOOL UseWithFastGS
- Data Fields inherited from NVAPI_D3D12_PSO_VERTEX_SHADER_DESC_V1
NvU32 version
NvU32 NumCustomSemantics
NV_CUSTOM_SEMANTIC * pCustomSemantics
- Data Fields inherited from NVAPI_D3D12_PSO_EXTENSION_DESC_V1
NvU32 baseVersion
NV_PSO_EXTENSION psoExtension
The documentation for this struct was generated from the following file:


Data Fields
NVAPI_D3D12_PSO_VERTEX_SHADER_DESC_V3 Struct Reference

#include <nvapi.h>

Inheritance diagram for NVAPI_D3D12_PSO_VERTEX_SHADER_DESC_V3:
NVAPI_D3D12_PSO_VERTEX_SHADER_DESC_V2 NVAPI_D3D12_PSO_VERTEX_SHADER_DESC_V1 NVAPI_D3D12_PSO_EXTENSION_DESC_V1

Data Fields

BOOL | UseSpecificShaderExt
- Data Fields inherited from NVAPI_D3D12_PSO_VERTEX_SHADER_DESC_V2
BOOL | UseWithFastGS
- Data Fields inherited from NVAPI_D3D12_PSO_VERTEX_SHADER_DESC_V1
NvU32 version
NvU32 NumCustomSemantics
NV_CUSTOM_SEMANTIC * pCustomSemantics
- Data Fields inherited from NVAPI_D3D12_PSO_EXTENSION_DESC_V1
NvU32 baseVersion
NV_PSO_EXTENSION psoExtension
The documentation for this struct was generated from the following file:


Data Fields
NVAPI_META_COMMAND_DESC Struct Reference

#include <nvapi.h>

Data Fields

GUID | Id
LPCWSTR | Name
NV_D3D_GRAPHICS_STATES InitializationDirtyState
NV_D3D_GRAPHICS_STATES ExecutionDirtyState
The documentation for this struct was generated from the following file:


Data Fields
NVAPI_UAV_INFO_V1 Struct Reference

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 surfaceHandle
NvU64 gpuVAStart
NvU64 gpuVASize

Detailed Description

SUPPORTED OS: Windows 10 and higher

The documentation for this struct was generated from the following file:


Data Fields
NVAPI_UAV_INFO_V2 Struct Reference

#include <nvapi.h>

Data Fields

NvU32 version
NvU32 surfaceHandle
NvU64 gpuVAStart
NvU64 gpuVASize
NvU64 outFlags
The documentation for this struct was generated from the following file:


Data Fields
NvShaderExtnStruct Struct Reference

#include <nvHLSLExtnsInternal.h>

Data Fields

uint | opcode
uint | rid
uint | sid
uint4 | dst1u
uint4 | src3u
uint4 | src4u
uint4 | src5u
uint4 | src0u
uint4 | src1u
uint4 | src2u
uint4 | dst0u
uint | markUavRef
uint | numOutputsForIncCounter
float | padding1 [27]

Field Documentation

◆ dst0u

uint4 NvShaderExtnStruct::dst0u

◆ dst1u

uint4 NvShaderExtnStruct::dst1u

◆ markUavRef

uint NvShaderExtnStruct::markUavRef

◆ numOutputsForIncCounter

uint NvShaderExtnStruct::numOutputsForIncCounter

◆ opcode

uint NvShaderExtnStruct::opcode

◆ padding1

float NvShaderExtnStruct::padding1[27]

◆ rid

uint NvShaderExtnStruct::rid

◆ sid

uint NvShaderExtnStruct::sid

◆ src0u

uint4 NvShaderExtnStruct::src0u

◆ src1u

uint4 NvShaderExtnStruct::src1u

◆ src2u

uint4 NvShaderExtnStruct::src2u

◆ src3u

uint4 NvShaderExtnStruct::src3u

◆ src4u

uint4 NvShaderExtnStruct::src4u

◆ src5u

uint4 NvShaderExtnStruct::src5u
The documentation for this struct was generated from the following file:
  • nvHLSLExtnsInternal.h


Class Hierarchy
This inheritance list is sorted roughly, but not completely, alphabetically:
[detail level 1234]
C _NV_ASYNC_FRAME_MARKER_PARAMS_V1 |
C _NV_BOARD_INFO |
C _NV_CLIENT_CALLBACK_SETTINGS_SUPER_V1 |
C _NV_COLOR_DATA_V1 |
C _NV_COLOR_DATA_V2 |
C _NV_COLOR_DATA_V3 |
C _NV_COLOR_DATA_V4 |
C _NV_COLOR_DATA_V5 |
C _NV_COMPUTE_GPU |
C _NV_COMPUTE_GPU_TOPOLOGY_V2 |
C _NV_CUSTOM_RECTS_V1 |
C _NV_CUSTOM_SEMANTIC |
C _NV_D3D11_EXCLUSIVE_SCISSOR_RECT_DESC_V1 |
C _NV_D3D11_EXCLUSIVE_SCISSOR_RECTS_DESC_V1 |
C _NV_D3D11_FEATURE_DATA_RASTERIZER_SUPPORT |
C _NV_D3D11_SHADING_RATE_RESOURCE_VIEW_DESC_V1 |
C _NV_D3D11_VIEWPORT_SHADING_RATE_DESC_V1 |
C _NV_D3D11_VIEWPORTS_SHADING_RATE_DESC_V1 |
C _NV_D3D12_GRAPHICS_CAPS_V1 |
C _NV_D3D12_MOSAIC_GETCOMPANIONALLOCATIONS |
C _NV_D3D12_MOSAIC_GETVIEWPORTANDGPUPARTITIONS |
C _NV_D3D12_WORKSTATION_FEATURE_PROPERTIES |
C _NV_D3D12_WORKSTATION_FEATURE_RDMA_PROPERTIES |
C _NV_D3D1x_GRAPHICS_CAPS_V1 |
C _NV_D3D1x_GRAPHICS_CAPS_V2 |
C _NV_D3D_LATELATCH_OBJECT_DESC_V1 |
C _NV_DISPLAY_DRIVER_INFO |
C _NV_DISPLAY_DRIVER_INFO_V2 |
C _NV_DISPLAY_PORT_INFO_V1 |
C _NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_V1 |
C _NV_DISPLAYCONFIG_PATH_INFO_V1 |
C _NV_DISPLAYCONFIG_PATH_INFO_V2 |
C _NV_DISPLAYCONFIG_PATH_TARGET_INFO_V1 |
C _NV_DISPLAYCONFIG_PATH_TARGET_INFO_V2 |
C _NV_DISPLAYCONFIG_SOURCE_MODE_INFO_V1 |
C _NV_DX_VIDEO_STEREO_INFO |
C _NV_EDID_DATA_V1 |
C _NV_EDID_DATA_V2 |
C _NV_FOVEATED_RENDERING_CUSTOM_FOVEATION_PATTERN_PRESET_DESC_V1 |
C _NV_FOVEATED_RENDERING_CUSTOM_SHADING_RATE_PRESET_DESC_V1 |
C _NV_FOVEATED_RENDERING_DESC_V1 |
C _NV_FOVEATED_RENDERING_GAZE_DATA_PER_EYE |
C _NV_FOVEATED_RENDERING_UPDATE_GAZE_DATA_PARAMS |
C _NV_GAZE_HANDLER_INIT_PARAMS_V1 |
C _NV_GAZE_HANDLER_INIT_PARAMS_V2 |
C _NV_GET_ADAPTIVE_SYNC_DATA_V1 |
C _NV_GET_SLEEP_STATUS_PARAMS |
C _NV_GET_VIRTUAL_REFRESH_RATE_DATA_V1 |
C _NV_GET_VRR_INFO_V1 |
C _NV_GPU_CLIENT_CALLBACK_DATA_SUPER_V1 |
C _NV_GPU_CLIENT_CALLBACK_UTILIZATION_DATA_V1 |
C _NV_GPU_CLIENT_ILLUM_DEVICE_INFO_DATA_GPIO_PWM_RGBW |
C _NV_GPU_CLIENT_ILLUM_DEVICE_INFO_DATA_GPIO_PWM_SINGLE_COLOR |
C _NV_GPU_CLIENT_ILLUM_DEVICE_INFO_DATA_MCUV10 |
C _NV_GPU_CLIENT_ILLUM_DEVICE_INFO_PARAMS_V1 |
C _NV_GPU_CLIENT_ILLUM_DEVICE_INFO_V1 |
C _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_COLOR_FIXED |
C _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_COLOR_FIXED |
C _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_COLOR_FIXED_PARAMS |
C _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_RGB |
C _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_RGB_PARAMS |
C _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_RGBW |
C _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_RGBW_PARAMS |
C _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_SINGLE_COLOR |
C _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_SINGLE_COLOR_PARAMS |
C _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR |
C _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR_COLOR_FIXED |
C _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR_RGB |
C _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR_RGBW |
C _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR_SINGLE_COLOR |
C _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_RGB |
C _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_RGBW |
C _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_SINGLE_COLOR |
C _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_PARAMS_V1 |
C _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_V1 |
C _NV_GPU_CLIENT_ILLUM_ZONE_INFO_DATA_RGB |
C _NV_GPU_CLIENT_ILLUM_ZONE_INFO_DATA_RGBW |
C _NV_GPU_CLIENT_ILLUM_ZONE_INFO_DATA_SINGLE_COLOR |
C _NV_GPU_CLIENT_ILLUM_ZONE_INFO_PARAMS_V1 |
C _NV_GPU_CLIENT_ILLUM_ZONE_INFO_V1 |
C _NV_GPU_CLIENT_PERIODIC_CALLBACK_SETTINGS_SUPER_V1 |
C _NV_GPU_CLIENT_UTILIZATION_DATA_V1 |
C _NV_GPU_CLIENT_UTILIZATION_PERIODIC_CALLBACK_SETTINGS_V1 |
C _NV_GPU_DISPLAYIDS |
C _NV_GPU_GET_ILLUMINATION_PARM_V1 |
C _NV_GPU_GSP_INFO_V1 |
C _NV_GPU_INFO_V1 |
C _NV_GPU_INFO_V2 |
C _NV_GPU_PERF_PSTATES20_INFO_V2 | Used in NvAPI_GPU_GetPstates20() interface call
C _NV_GPU_QUERY_ILLUMINATION_SUPPORT_PARM_V1 |
C _NV_GPU_SET_ILLUMINATION_PARM_V1 |
C _NV_GPU_VIRTUALIZATION_INFO |
C _NV_GPU_VR_READY_V1 |
C _NV_GSYNC_CAPABILITIES_V1 | Used in NvAPI_GSync_QueryCapabilities()
C _NV_GSYNC_CAPABILITIES_V2 |
C _NV_GSYNC_CAPABILITIES_V3 |
C _NV_GSYNC_CONTROL_PARAMS_V1 | Used in NvAPI_GSync_GetControlParameters() and NvAPI_GSync_SetControlParameters()
C _NV_GSYNC_CONTROL_PARAMS_V2 |
C _NV_GSYNC_DELAY | Used in NV_GSYNC_CONTROL_PARAMS
C _NV_GSYNC_DISPLAY |
C _NV_GSYNC_GPU |
C _NV_GSYNC_STATUS | Used in NvAPI_GSync_GetSyncStatus()
C _NV_GSYNC_STATUS_PARAMS_V1 |
C _NV_GSYNC_STATUS_PARAMS_V2 |
C _NV_HDMI_SUPPORT_INFO_V1 |
C _NV_HDMI_SUPPORT_INFO_V2 |
C _NV_HDR_CAPABILITIES_V1 |
C _NV_HDR_CAPABILITIES_V2 |
C _NV_HDR_CAPABILITIES_V3 |
C _NV_HDR_COLOR_DATA_V1 |
C _NV_HDR_COLOR_DATA_V2 |
C _NV_HDR_METADATA_V1 |
C _NV_HEAP_PARAMS_V1 |
C _NV_JOIN_PRESENT_BARRIER_PARAMS |
C _NV_LATENCY_MARKER_PARAMS |
C _NV_LATENCY_RESULT_PARAMS |
C _NV_LICENSABLE_FEATURES_V1 | Licensable features
C _NV_LICENSABLE_FEATURES_V2 |
C _NV_LICENSABLE_FEATURES_V3 |
C _NV_LICENSABLE_FEATURES_V4 |
C _NV_LICENSE_EXPIRY_DETAILS |
C _NV_LICENSE_FEATURE_DETAILS_V1 | Used in NV_LICENSABLE_FEATURES
C _NV_LICENSE_FEATURE_DETAILS_V2 |
C _NV_LICENSE_FEATURE_DETAILS_V3 |
C _NV_LICENSE_FEATURE_DETAILS_V4 |
C _NV_LMS_CUSTOM_CONFIG_V1 |
C _NV_LMS_INSTANCED_STEREO_CONFIG_V1 |
C _NV_LOGICAL_GPU_DATA_V1 |
C _NV_LOGICAL_GPU_HANDLE_DATA |
C _NV_LOGICAL_GPUS |
C _NV_MANAGED_DEDICATED_DISPLAY_INFO |
C _NV_MANAGED_DEDICATED_DISPLAY_METADATA |
C _NV_MODIFIED_W_COEFFICIENTS |
C _NV_MODIFIED_W_PARAMS |
C _NV_MONITOR_CAPABILITIES_V1 | See NvAPI_DISP_GetMonitorCapabilities()
C _NV_MONITOR_CAPS_GENERIC |
C _NV_MONITOR_CAPS_VCDB |
C _NV_MONITOR_CAPS_VSDB | See NvAPI_DISP_GetMonitorCapabilities()
C _NV_MONITOR_COLOR_DATA |
C _NV_MOSAIC_DISPLAY_SETTING_V1 | Basic per-display settings that are used in setting/getting the Mosaic mode
C _NV_MOSAIC_GRID_TOPO_DISPLAY_V1 |
C _NV_MOSAIC_GRID_TOPO_DISPLAY_V2 |
C _NV_MOSAIC_GRID_TOPO_V1 |
C _NV_MOSAIC_GRID_TOPO_V2 |
C _NV_MOSAIC_SUPPORTED_TOPO_INFO_V1 |
C _NV_MOSAIC_SUPPORTED_TOPO_INFO_V2 |
C _NV_MRS_CUSTOM_CONFIG_V1 |
C _NV_MRS_INSTANCED_STEREO_CONFIG_V1 |
C _NV_MULTIGPU_CAPS_V1 |
C _NV_MULTIGPU_CAPS_V2 |
C _NV_MULTIVIEW_PARAMS_V1 |
C _NV_PHYSICAL_GPU_HANDLE_DATA |
C _NV_PHYSICAL_GPUS |
C _NV_PIXEL_SHADING_RATE_SAMPLE_ORDER_TABLE_V1 |
C _NV_PIXEL_SRSO_1x2 |
C _NV_PIXEL_SRSO_2x1 |
C _NV_PIXEL_SRSO_2x2 |
C _NV_PIXEL_SRSO_2x4 |
C _NV_PIXEL_SRSO_4x2 |
C _NV_PIXEL_SRSO_4x4 |
C _NV_POSITION |
C _NV_PRESENT_BARRIER_FRAME_STATISTICS |
C _NV_QUERY_LATELATCH_SUPPORT_PARAMS |
C _NV_QUERY_MODIFIED_W_SUPPORT_PARAMS |
C _NV_QUERY_MULTIVIEW_SUPPORT_PARAMS_V1 |
C _NV_QUERY_SINGLE_PASS_STEREO_SUPPORT_PARAMS_V1 |
C _NV_QUERY_SINGLE_PASS_STEREO_SUPPORT_PARAMS_V2 |
C _NV_QUERY_SMP_ASSIST_SUPPORT_PARAMS_V1 |
C _NV_RECT |
C _NV_RESOLUTION |
C _NV_RESOURCE_PARAMS_V1 |
C _NV_SCANOUT_INFORMATION |
C _NV_SCANOUT_INTENSITY_STATE_DATA |
C _NV_SCANOUT_WARPING_STATE_DATA |
C _NV_SET_ADAPTIVE_SYNC_DATA_V1 |
C _NV_SET_REFLEX_SYNC_PARAMS |
C _NV_SET_SLEEP_MODE_PARAMS |
C _NV_SET_VIRTUAL_REFRESH_RATE_DATA_V1 |
C _NV_SMP_ASSIST_DISABLE_PARAMS_V1 |
C _NV_SMP_ASSIST_ENABLE_PARAMS_V1 |
C _NV_SMP_ASSIST_FASTGSCBDATA_MRS_INSTANCED_STEREO_V1 |
C _NV_SMP_ASSIST_FASTGSCBDATA_V1 |
C _NV_SMP_ASSIST_GET_CONSTANTS_V3 |
C _NV_SMP_ASSIST_INITIALIZE_PARAMS_V1 |
C _NV_SMP_ASSIST_REMAPCBDATA_V1 |
C _NV_SMP_ASSIST_SETUP_PARAMS_V1 |
C _NV_SMP_ASSIST_UPDATE_INSTANCEDSTEREO_DATA_PARAMS_V1 |
C _NV_TEX2D_ARRAY_SRRV |
C _NV_TEX2D_SRRV |
C _NV_TIMING |
C _NV_TIMING_INPUT |
C _NV_VIO_TOPOLOGY |
C _NV_VRS_HELPER_DISABLE_PARAMS_V1 |
C _NV_VRS_HELPER_ENABLE_PARAMS_V1 |
C _NV_VRS_HELPER_GET_SHADING_RATE_RESOURCE_PARAMS_V1 |
C _NV_VRS_HELPER_INIT_PARAMS_V1 |
C _NV_VRS_HELPER_LATCH_GAZE_PARAMS_V1 |
C _NV_VRS_HELPER_PURGE_INTERNAL_RESOURCES_PARAMS_V1 |
C _NVAPI_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_EX_PARAMS_V1 |
C _NVAPI_BUILD_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PARAMS_V1 |
C _NVAPI_BUILD_RAYTRACING_OPACITY_MICROMAP_ARRAY_PARAMS_V1 |
C _NVAPI_CHECK_DRIVER_MATCHING_IDENTIFIER_EX_PARAMS_V1 |
C _NVAPI_CU_KERNEL_LAUNCH_PARAMS |
C _NVAPI_CU_KERNEL_LAUNCH_PARAMS_EX |
C _NVAPI_D3D12_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_DESC_EX |
C _NVAPI_D3D12_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_INPUTS_EX |
C _NVAPI_D3D12_BUILD_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_DESC |
C _NVAPI_D3D12_BUILD_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_INPUTS |
C _NVAPI_D3D12_BUILD_RAYTRACING_OPACITY_MICROMAP_ARRAY_DESC |
C _NVAPI_D3D12_BUILD_RAYTRACING_OPACITY_MICROMAP_ARRAY_INPUTS |
C _NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_POSTBUILD_INFO_CURRENT_SIZE_DESC |
C _NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_POSTBUILD_INFO_DESC |
C _NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PREBUILD_INFO |
C _NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_DESC |
C _NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_USAGE_COUNT |
C _NVAPI_D3D12_RAYTRACING_GEOMETRY_DESC_EX |
C _NVAPI_D3D12_RAYTRACING_GEOMETRY_DMM_ATTACHMENT_DESC |
C _NVAPI_D3D12_RAYTRACING_GEOMETRY_DMM_TRIANGLES_DESC |
C _NVAPI_D3D12_RAYTRACING_GEOMETRY_OMM_ATTACHMENT_DESC |
C _NVAPI_D3D12_RAYTRACING_GEOMETRY_OMM_TRIANGLES_DESC |
C _NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_ARRAY_POSTBUILD_INFO_CURRENT_SIZE_DESC |
C _NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_ARRAY_POSTBUILD_INFO_DESC |
C _NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_ARRAY_PREBUILD_INFO |
C _NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_DESC |
C _NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_USAGE_COUNT |
C _NVAPI_D3D12_SET_CREATE_PIPELINE_STATE_OPTIONS_PARAMS_V1 |
C _NVAPI_DIM3 |
C _NVAPI_EMIT_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_POSTBUILD_INFO_PARAMS_V1 |
C _NVAPI_EMIT_RAYTRACING_OPACITY_MICROMAP_ARRAY_POSTBUILD_INFO_PARAMS_V1 |
C _NVAPI_GET_RAYTRACING_ACCELERATION_STRUCTURE_PREBUILD_INFO_EX_PARAMS_V1 |
C _NVAPI_GET_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PREBUILD_INFO_PARAMS_V1 |
C _NVAPI_GET_RAYTRACING_OPACITY_MICROMAP_ARRAY_PREBUILD_INFO_PARAMS_V1 |
C _NVAPI_RELOCATE_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PARAMS_V1 |
C _NVAPI_RELOCATE_RAYTRACING_OPACITY_MICROMAP_ARRAY_PARAMS_V1 |
C _NVAPI_STEREO_CAPS |
C _NVDRS_APPLICATION_V1 |
C _NVDRS_APPLICATION_V2 |
C _NVDRS_APPLICATION_V3 |
C _NVDRS_APPLICATION_V4 |
C _NVDRS_BINARY_SETTING | Enum to decide on the datatype of setting value
C _NVDRS_GPU_SUPPORT |
C _NVDRS_PROFILE_V1 |
C _NVDRS_SETTING_V1 |
C _NVDRS_SETTING_VALUES |
C _NVVIOCAPS | Device capabilities
C _NVVIOCHANNELSTATUS | Input channel status
C _NVVIOCOLORCONVERSION | Colorspace conversion
C _NVVIOCOMPOSITERANGE |
C _NVVIOCONFIG_V1 |
C _NVVIOCONFIG_V2 |
C _NVVIOCONFIG_V3 |
C _NVVIODATAFORMATDETAIL | Data format details
C _NVVIOGAMMACORRECTION | Gamma correction
C _NVVIOGAMMARAMP10 | Gamma ramp (10-bit index)
C _NVVIOGAMMARAMP8 | Gamma ramp (8-bit index)
C _NVVIOINPUTCONFIG | Input device configuration
C _NVVIOINPUTSTATUS | Input device status
C _NVVIOOUTPUTCONFIG_V1 | Output device configuration
C _NVVIOOUTPUTCONFIG_V2 |
C _NVVIOOUTPUTCONFIG_V3 |
C _NVVIOOUTPUTREGION | Output region
C _NVVIOOUTPUTSTATUS | Output device status
C _NVVIOPCIINFO |
C _NVVIOSIGNALFORMATDETAIL | Signal format details
C _NVVIOSTATUS | Video device status
C _NVVIOSTREAM | Stream configuration
C _NVVIOSYNCDELAY | Sync delay
C _NVVIOVIDEOMODE | Video mode information
C _SettingDWORDNameString |
C _SettingWSTRINGNameString |
C _NV_LATENCY_RESULT_PARAMS::FrameReport |
C INvAPI_DirectD3D12GraphicsCommandList |
C NV_CHIPSET_INFO_v1 |
C NV_CHIPSET_INFO_v2 |
C NV_CHIPSET_INFO_v3 |
C NV_CHIPSET_INFO_v4 |
C NV_COMPUTE_GPU_TOPOLOGY_V1 |
C NV_CUSTOM_DISPLAY |
C NV_D3D11_META_COMMAND_EXECUTE_CONVOLUTION_EX_DESC |
C NV_D3D11_META_COMMAND_EXECUTE_GEMM_DESC |
C NV_D3D11_META_COMMAND_INITIALIZE_CONVOLUTION_EX_DESC |
C NV_D3D11_META_COMMAND_INITIALIZE_GEMM_DESC |
C NV_D3D11_META_COMMAND_RESOURCE |
C NV_D3D12_META_COMMAND_EXECUTE_CONVOLUTION_EX_DESC |
C NV_D3D12_META_COMMAND_EXECUTE_GEMM_DESC |
C NV_D3D12_META_COMMAND_INITIALIZE_CONVOLUTION_EX_DESC |
C NV_D3D12_META_COMMAND_INITIALIZE_GEMM_DESC |
C NV_DISPLAY_DRIVER_MEMORY_INFO_V1 |
C NV_DISPLAY_DRIVER_MEMORY_INFO_V2 |
C NV_DISPLAY_DRIVER_MEMORY_INFO_V3 |
C NV_DISPLAY_DRIVER_VERSION |
C NV_DISPLAY_PATH |
C NV_DISPLAY_PATH_INFO |
C NV_DISPLAY_PATH_INFO_V3 |
C NV_DISPLAY_PORT_CONFIG |
C NV_EDID_V1 |
C NV_EDID_V2 | Used in NvAPI_GPU_GetEDID()
C NV_EDID_V3 | Used in NvAPI_GPU_GetEDID()
C NV_EVENT_REGISTER_CALLBACK | Core NV_EVENT_REGISTER_CALLBACK structure declaration
C NV_GET_CURRENT_SLI_STATE_V1 |
C NV_GET_CURRENT_SLI_STATE_V2 |
C NV_GET_GPU_VIRTUAL_ADDRESS_V1 |
C NV_GET_PREFERRED_STEREO_DISPLAY_V1 |
C NV_GPU_ARCH_INFO_V1 | Used in NvAPI_GPU_GetArchInfo()
C NV_GPU_ARCH_INFO_V2 |
C NV_GPU_CLIENT_ILLUM_DEVICE_CONTROL_PARAMS_V1 |
C NV_GPU_CLIENT_ILLUM_DEVICE_CONTROL_V1 |
C NV_GPU_CLIENT_ILLUM_DEVICE_SYNC_V1 |
C NV_GPU_CLOCK_FREQUENCIES_V1 |
C NV_GPU_CLOCK_FREQUENCIES_V2 |
C NV_GPU_DYNAMIC_PSTATES_INFO_EX |
C NV_GPU_ECC_CONFIGURATION_INFO |
C NV_GPU_ECC_ERROR_INFO |
C NV_GPU_ECC_STATUS_INFO |
C NV_GPU_GET_HDCP_SUPPORT_STATUS | HDPC support status - used in NvAPI_GPU_GetHDCPSupportStatus()
C NV_GPU_MEMORY_INFO_EX_V1 |
C NV_GPU_PERF_PSTATES20_INFO_V1 | Used in NvAPI_GPU_GetPstates20() interface call
C NV_GPU_PERF_PSTATES20_PARAM_DELTA | Used to describe both voltage and frequency deltas
C NV_GPU_PERF_PSTATES_INFO_V1 |
C NV_GPU_PERF_PSTATES_INFO_V2 |
C NV_GPU_PSTATE20_BASE_VOLTAGE_ENTRY_V1 | Used to describe single base voltage entry
C NV_GPU_PSTATE20_CLOCK_ENTRY_V1 | Used to describe single clock entry
C NV_GPU_THERMAL_SETTINGS_V1 |
C NV_GPU_THERMAL_SETTINGS_V2 |
C NV_I2C_INFO_V1 | Used in NvAPI_I2CRead() and NvAPI_I2CWrite()
C NV_I2C_INFO_V2 | Used in NvAPI_I2CRead() and NvAPI_I2CWrite()
C NV_I2C_INFO_V3 | Used in NvAPI_I2CRead() and NvAPI_I2CWrite()
C NV_INFOFRAME_AUDIO |
C NV_INFOFRAME_DATA |
C NV_INFOFRAME_PROPERTY |
C NV_INFOFRAME_VIDEO | Adding an Auto bit to each field
C NV_LID_DOCK_PARAMS |
►C NV_META_COMMAND_ACTIVATION_DESC |
C NV_META_COMMAND_OPTIONAL_ACTIVATION_DESC |
C NV_META_COMMAND_CONVOLUTION_FUSE_DESC |
►C NV_META_COMMAND_CREATE_CONVOLUTION_EX_DESC |
C NV_META_COMMAND_CREATE_CONVOLUTION_EX_FUSED_DESC |
C NV_META_COMMAND_CREATE_GEMM_DESC |
C NV_META_COMMAND_PADDING_DESC |
►C NV_META_COMMAND_TENSOR_DESC |
C NV_META_COMMAND_OPTIONAL_TENSOR_DESC |
C NV_MOSAIC_DISPLAY_SETTING_V2 |
C NV_MOSAIC_DISPLAY_TOPO_STATUS |
C NV_MOSAIC_SUPPORTED_TOPOLOGIES | Used in NvAPI_GetSupportedMosaicTopologies()
C NV_MOSAIC_TOPO_BRIEF |
C NV_MOSAIC_TOPO_DETAILS | This structure defines the topology details
C NV_MOSAIC_TOPO_GROUP |
C NV_MOSAIC_TOPOLOGY | Used in NvAPI_GetCurrentMosaicTopology() and NvAPI_SetCurrentMosaicTopology()
C _NV_PIXEL_SRSO_1x2::NV_PIXEL_SRSO_1x2_X1 |
C _NV_PIXEL_SRSO_1x2::NV_PIXEL_SRSO_1x2_X2 |
C _NV_PIXEL_SRSO_1x2::NV_PIXEL_SRSO_1x2_X4 |
C _NV_PIXEL_SRSO_1x2::NV_PIXEL_SRSO_1x2_X8 |
C _NV_PIXEL_SRSO_2x1::NV_PIXEL_SRSO_2x1_X1 |
C _NV_PIXEL_SRSO_2x1::NV_PIXEL_SRSO_2x1_X2 |
C _NV_PIXEL_SRSO_2x1::NV_PIXEL_SRSO_2x1_X4 |
C _NV_PIXEL_SRSO_2x2::NV_PIXEL_SRSO_2x2_X1 |
C _NV_PIXEL_SRSO_2x2::NV_PIXEL_SRSO_2x2_X2 |
C _NV_PIXEL_SRSO_2x2::NV_PIXEL_SRSO_2x2_X4 |
C _NV_PIXEL_SRSO_2x4::NV_PIXEL_SRSO_2x4_X1 |
C _NV_PIXEL_SRSO_2x4::NV_PIXEL_SRSO_2x4_X2 |
C _NV_PIXEL_SRSO_4x2::NV_PIXEL_SRSO_4x2_X1 |
C _NV_PIXEL_SRSO_4x4::NV_PIXEL_SRSO_4x4_X1 |
C NV_QSYNC_EVENT_DATA |
C NV_SCANOUT_INTENSITY_DATA_V1 |
C NV_SCANOUT_INTENSITY_DATA_V2 |
C NV_SCANOUT_WARPING_DATA |
C NV_SET_PREFERRED_STEREO_DISPLAY_V1 |
C NV_TIMING_FLAG |
C NV_VIEW_TARGET_INFO |
C NV_VIEWPORTF |
C NVAPI_ANSEL_CONFIGURATION_STRUCT_V1 |
C NVAPI_ANSEL_FEATURE_CONFIGURATION_STRUCT |
C NvAPI_D3D11_CREATE_DOMAIN_SHADER_EX_V1 |
C NvAPI_D3D11_CREATE_DOMAIN_SHADER_EX_V2 |
C NvAPI_D3D11_CREATE_DOMAIN_SHADER_EX_V3 |
C NvAPI_D3D11_CREATE_FASTGS_EXPLICIT_DESC_V1 |
C NvAPI_D3D11_CREATE_GEOMETRY_SHADER_EX_V5 |
C NvAPI_D3D11_CREATE_HULL_SHADER_EX_V1 |
C NvAPI_D3D11_CREATE_HULL_SHADER_EX_V2 |
C NvAPI_D3D11_CREATE_PIXEL_SHADER_EX_V1 |
C NvAPI_D3D11_CREATE_PIXEL_SHADER_EX_V2 |
C NvAPI_D3D11_CREATE_VERTEX_SHADER_EX_V1 |
C NvAPI_D3D11_CREATE_VERTEX_SHADER_EX_V2 |
C NvAPI_D3D11_CREATE_VERTEX_SHADER_EX_V3 |
C NvAPI_D3D11_RASTERIZER_DESC_EX |
C NVAPI_D3D12_CREATE_CUBIN_SHADER_PARAMS |
C NVAPI_D3D12_GET_CUDA_INDEPENDENT_DESCRIPTOR_OBJECT_PARAMS |
C NVAPI_D3D12_GET_CUDA_MERGED_TEXTURE_SAMPLER_OBJECT_PARAMS |
►C NVAPI_D3D12_PSO_EXTENSION_DESC_V1 |
C NVAPI_D3D12_PSO_CREATE_FASTGS_EXPLICIT_DESC_V1 |
►C NVAPI_D3D12_PSO_DOMAIN_SHADER_DESC_V1 |
►C NVAPI_D3D12_PSO_DOMAIN_SHADER_DESC_V2 |
C NVAPI_D3D12_PSO_DOMAIN_SHADER_DESC_V3 |
C NVAPI_D3D12_PSO_ENABLE_DEPTH_BOUND_TEST_DESC_V1 |
C NVAPI_D3D12_PSO_GEOMETRY_SHADER_DESC_V5 |
►C NVAPI_D3D12_PSO_HULL_SHADER_DESC_V1 |
C NVAPI_D3D12_PSO_HULL_SHADER_DESC_V2 |
C NVAPI_D3D12_PSO_RASTERIZER_STATE_DESC_V1 |
C NVAPI_D3D12_PSO_REQUEST_FAST_GEOMETRY_SHADER_DESC_V1 |
C NVAPI_D3D12_PSO_SET_SHADER_EXTENSION_SLOT_DESC_V1 |
►C NVAPI_D3D12_PSO_VERTEX_SHADER_DESC_V1 |
►C NVAPI_D3D12_PSO_VERTEX_SHADER_DESC_V2 |
C NVAPI_D3D12_PSO_VERTEX_SHADER_DESC_V3 |
C NVAPI_META_COMMAND_DESC |
C NVAPI_UAV_INFO_V1 |
C NVAPI_UAV_INFO_V2 |
C NvGUID |
C NVLINK_DEVICE_INFO_V1 |
C NVLINK_GET_CAPS_V1 |
C NVLINK_GET_STATUS_V1 |
C NVLINK_GET_STATUS_V2 |
C NVLINK_LINK_STATUS_INFO_V1 |
C NVLINK_LINK_STATUS_INFO_V2 |
C NvSBox |
C NvShaderExtnStruct |
C NVVIOTOPOLOGYTARGET |
C tagNV_TIMINGEXT |


  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all struct and union fields with links to the structures/unions they belong to:

- a -

  • aabbs : _NVAPI_D3D12_RAYTRACING_GEOMETRY_DESC_EX
  • acceleratePrimaryDisplay : _NV_MOSAIC_GRID_TOPO_V1, _NV_MOSAIC_GRID_TOPO_V2
  • Activation : NV_META_COMMAND_CREATE_CONVOLUTION_EX_DESC, NV_META_COMMAND_CREATE_GEMM_DESC
  • activeFormatAspectRatio : NV_INFOFRAME_VIDEO
  • activeFormatInfoPresent : NV_INFOFRAME_VIDEO
  • adapterCaps : _NVVIOCAPS
  • adapterClass : _NVVIOCAPS
  • adapterName : _NVVIOCAPS
  • adapterType : _NV_LOGICAL_GPU_HANDLE_DATA, _NV_PHYSICAL_GPU_HANDLE_DATA
  • aggregate : NV_GPU_ECC_ERROR_INFO
  • Alpha : NV_META_COMMAND_CREATE_GEMM_DESC
  • Alpha1 : NV_META_COMMAND_CREATE_CONVOLUTION_EX_DESC
  • Alpha1Resource : NV_D3D11_META_COMMAND_EXECUTE_CONVOLUTION_EX_DESC, NV_D3D12_META_COMMAND_EXECUTE_CONVOLUTION_EX_DESC
  • Alpha2 : NV_META_COMMAND_CREATE_CONVOLUTION_EX_DESC
  • Alpha2Resource : NV_D3D11_META_COMMAND_EXECUTE_CONVOLUTION_EX_DESC, NV_D3D12_META_COMMAND_EXECUTE_CONVOLUTION_EX_DESC
  • ancParityComputation : _NVVIOOUTPUTCONFIG_V2, _NVVIOOUTPUTCONFIG_V3
  • AntialiasedLineEnable : NvAPI_D3D11_RASTERIZER_DESC_EX
  • application_version : _NV_HDR_CAPABILITIES_V3
  • applyWithBezelCorrect : _NV_MOSAIC_GRID_TOPO_V1, _NV_MOSAIC_GRID_TOPO_V2
  • appName : _NVDRS_APPLICATION_V1, _NVDRS_APPLICATION_V2, _NVDRS_APPLICATION_V3, _NVDRS_APPLICATION_V4
  • architecture : NV_GPU_ARCH_INFO_V1, NV_GPU_ARCH_INFO_V2
  • architecture_id : NV_GPU_ARCH_INFO_V2
  • AResource : NV_D3D11_META_COMMAND_EXECUTE_GEMM_DESC, NV_D3D12_META_COMMAND_EXECUTE_GEMM_DESC
  • ArraySize : _NV_TEX2D_ARRAY_SRRV
  • aspect : tagNV_TIMINGEXT
  • ATimems : _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR
  • Attribute : _NV_GPU_GET_ILLUMINATION_PARM_V1, _NV_GPU_QUERY_ILLUMINATION_SUPPORT_PARM_V1, _NV_GPU_SET_ILLUMINATION_PARM_V1
  • audio : NV_INFOFRAME_DATA
  • audioLatency : _NV_MONITOR_CAPS_VSDB
  • availableDedicatedVideoMemory : NV_DISPLAY_DRIVER_MEMORY_INFO_V1, NV_DISPLAY_DRIVER_MEMORY_INFO_V2, NV_DISPLAY_DRIVER_MEMORY_INFO_V3, NV_GPU_MEMORY_INFO_EX_V1


  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all struct and union fields with links to the structures/unions they belong to:

- b -

  • backendBitDepths : _NV_MONITOR_COLOR_DATA
  • backlt_min_luma : _NV_HDR_CAPABILITIES_V2, _NV_HDR_CAPABILITIES_V3
  • barInfo : NV_INFOFRAME_VIDEO
  • baseMosaic : _NV_MOSAIC_GRID_TOPO_V1, _NV_MOSAIC_GRID_TOPO_V2
  • baseVersion : NVAPI_D3D12_PSO_EXTENSION_DESC_V1
  • baseVoltages : _NV_GPU_PERF_PSTATES20_INFO_V2, NV_GPU_PERF_PSTATES20_INFO_V1
  • bCplVsyncOn : _NV_GET_SLEEP_STATUS_PARAMS
  • bDefault : _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_PARAMS_V1
  • bDisable : _NV_SET_REFLEX_SYNC_PARAMS
  • bDisableAdaptiveSync : _NV_GET_ADAPTIVE_SYNC_DATA_V1, _NV_SET_ADAPTIVE_SYNC_DATA_V1
  • bDisableFrameSplitting : _NV_GET_ADAPTIVE_SYNC_DATA_V1, _NV_SET_ADAPTIVE_SYNC_DATA_V1
  • bEnable : _NV_SET_REFLEX_SYNC_PARAMS
  • bEnabled : _NV_SCANOUT_INTENSITY_STATE_DATA, _NV_SCANOUT_WARPING_STATE_DATA
  • bEnableSuperSamplingPredicationForVRS : NvAPI_D3D11_CREATE_PIXEL_SHADER_EX_V2
  • bEnableSuperSamplingPredicationForVRSAllAttributes : NvAPI_D3D11_CREATE_PIXEL_SHADER_EX_V2
  • Beta : NV_META_COMMAND_CREATE_GEMM_DESC
  • bExclusiveScissorRectsSupported : _NV_D3D12_GRAPHICS_CAPS_V1, _NV_D3D1x_GRAPHICS_CAPS_V1, _NV_D3D1x_GRAPHICS_CAPS_V2
  • bFastUAVClearSupported : _NV_D3D12_GRAPHICS_CAPS_V1, _NV_D3D1x_GRAPHICS_CAPS_V2
  • bFocusDisplay : NV_DISPLAY_PATH
  • bForceModeSet : NV_DISPLAY_PATH, NV_VIEW_TARGET_INFO
  • bFsVrr : _NV_GET_SLEEP_STATUS_PARAMS
  • bGDIPrimary : _NV_DISPLAYCONFIG_SOURCE_MODE_INFO_V1, NV_DISPLAY_PATH, NV_VIEW_TARGET_INFO
  • bHouseSync : _NV_GSYNC_STATUS_PARAMS_V1, _NV_GSYNC_STATUS_PARAMS_V2
  • BiasResource : NV_D3D11_META_COMMAND_EXECUTE_CONVOLUTION_EX_DESC, NV_D3D12_META_COMMAND_EXECUTE_CONVOLUTION_EX_DESC
  • binaryCurrentValue : _NVDRS_SETTING_V1
  • binaryDefaultValue : _NVDRS_SETTING_VALUES
  • binaryPredefinedValue : _NVDRS_SETTING_V1
  • binaryValue : _NVDRS_SETTING_VALUES
  • bInSaccade : _NV_FOVEATED_RENDERING_GAZE_DATA_PER_EYE
  • bInterlaced : NV_VIEW_TARGET_INFO
  • bInternalSlave : _NV_GSYNC_STATUS_PARAMS_V2
  • bIsCurAFRGroupNew : NV_GET_CURRENT_SLI_STATE_V1, NV_GET_CURRENT_SLI_STATE_V2
  • bIsDCHDriver : _NV_DISPLAY_DRIVER_INFO, _NV_DISPLAY_DRIVER_INFO_V2
  • bIsDDCPort : NV_I2C_INFO_V1, NV_I2C_INFO_V2, NV_I2C_INFO_V3
  • bIsDisplayInVRRMode : _NV_GET_VRR_INFO_V1
  • bIsEditable : _NV_GPU_PERF_PSTATES20_INFO_V2, NV_GPU_PERF_PSTATES20_INFO_V1, NV_GPU_PSTATE20_BASE_VOLTAGE_ENTRY_V1, NV_GPU_PSTATE20_CLOCK_ENTRY_V1
  • bIsExternalGpu : _NV_GPU_INFO_V1, _NV_GPU_INFO_V2
  • bIsMulDivSupported : _NV_GSYNC_CAPABILITIES_V3
  • bIsNVIDIAGameReadyPackage : _NV_DISPLAY_DRIVER_INFO, _NV_DISPLAY_DRIVER_INFO_V2
  • bIsNVIDIARTXNewFeatureBranchPackage : _NV_DISPLAY_DRIVER_INFO, _NV_DISPLAY_DRIVER_INFO_V2
  • bIsNVIDIARTXProductionBranchPackage : _NV_DISPLAY_DRIVER_INFO, _NV_DISPLAY_DRIVER_INFO_V2
  • bIsNVIDIAStudioPackage : _NV_DISPLAY_DRIVER_INFO, _NV_DISPLAY_DRIVER_INFO_V2
  • bIsPortIdSet : NV_I2C_INFO_V3
  • bIsPresent : NV_GPU_CLOCK_FREQUENCIES_V1, NV_GPU_CLOCK_FREQUENCIES_V2, NV_GPU_DYNAMIC_PSTATES_INFO_EX
  • bIsStereoSynced : _NV_GSYNC_STATUS
  • bIsSynced : _NV_GSYNC_STATUS
  • bIsSyncSignalAvailable : _NV_GSYNC_STATUS
  • bIsValidInfo : _NV_MONITOR_CAPABILITIES_V1
  • bIsVRREnabled : _NV_GET_VRR_INFO_V1
  • bIsVRRIndicatorEnabled : _NV_GET_VRR_INFO_V1
  • bIsVRRPossible : _NV_GET_VRR_INFO_V1
  • bIsVRRRequested : _NV_GET_VRR_INFO_V1
  • bitsPerComponent : _NVVIOCHANNELSTATUS, _NVVIOSTREAM
  • blackList : NV_INFOFRAME_PROPERTY
  • bLateLatchSupported : _NV_QUERY_LATELATCH_SUPPORT_PARAMS
  • bldChangeListNum : NV_DISPLAY_DRIVER_VERSION
  • blendingTexture : NV_SCANOUT_INTENSITY_DATA_V1, NV_SCANOUT_INTENSITY_DATA_V2
  • blockDim : _NVAPI_CU_KERNEL_LAUNCH_PARAMS, _NVAPI_CU_KERNEL_LAUNCH_PARAMS_EX
  • blockX : NVAPI_D3D12_CREATE_CUBIN_SHADER_PARAMS
  • blockY : NVAPI_D3D12_CREATE_CUBIN_SHADER_PARAMS
  • blockZ : NVAPI_D3D12_CREATE_CUBIN_SHADER_PARAMS
  • bLowLatencyBoost : _NV_SET_SLEEP_MODE_PARAMS
  • bLowLatencyMode : _NV_GET_SLEEP_STATUS_PARAMS, _NV_SET_SLEEP_MODE_PARAMS
  • bModifiedWSupported : _NV_QUERY_MODIFIED_W_SUPPORT_PARAMS
  • bMultiViewSupported : _NV_QUERY_MULTIVIEW_SUPPORT_PARAMS_V1
  • bNameIsAvailable : _NV_MANAGED_DEDICATED_DISPLAY_METADATA
  • boardId : _NV_GSYNC_CAPABILITIES_V1, _NV_GSYNC_CAPABILITIES_V2, _NV_GSYNC_CAPABILITIES_V3
  • boardID : _NVVIOCAPS
  • BoardNum : _NV_BOARD_INFO
  • bottom : _NV_RECT
  • bottom_bar : NV_INFOFRAME_VIDEO
  • boundingBox : _NV_SMP_ASSIST_SETUP_PARAMS_V1
  • BoundingRectOriginX : _NV_SMP_ASSIST_REMAPCBDATA_V1
  • BoundingRectOriginY : _NV_SMP_ASSIST_REMAPCBDATA_V1
  • BoundingRectSizeHeight : _NV_SMP_ASSIST_REMAPCBDATA_V1
  • BoundingRectSizeInvHeight : _NV_SMP_ASSIST_REMAPCBDATA_V1
  • BoundingRectSizeInvWidth : _NV_SMP_ASSIST_REMAPCBDATA_V1
  • BoundingRectSizeWidth : _NV_SMP_ASSIST_REMAPCBDATA_V1
  • boundingScissor : _NV_SMP_ASSIST_GET_CONSTANTS_V3
  • boundingViewport : _NV_SMP_ASSIST_GET_CONSTANTS_V3
  • bpc : _NV_COLOR_DATA_V3, _NV_COLOR_DATA_V4, _NV_COLOR_DATA_V5, _NV_DISPLAY_PORT_INFO_V1, NV_DISPLAY_PORT_CONFIG
  • bPositionIsAvailable : _NV_MANAGED_DEDICATED_DISPLAY_METADATA
  • bpp : _NV_MOSAIC_DISPLAY_SETTING_V1, NV_MOSAIC_DISPLAY_SETTING_V2
  • bPrimary : NV_DISPLAY_PATH, NV_VIEW_TARGET_INFO
  • bRemoveName : _NV_MANAGED_DEDICATED_DISPLAY_METADATA
  • bRemovePosition : _NV_MANAGED_DEDICATED_DISPLAY_METADATA
  • BResource : NV_D3D11_META_COMMAND_EXECUTE_GEMM_DESC, NV_D3D12_META_COMMAND_EXECUTE_GEMM_DESC
  • brief : NV_MOSAIC_TOPO_GROUP
  • brightnessPct : _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_COLOR_FIXED_PARAMS, _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_RGB_PARAMS, _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_RGBW_PARAMS, _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_SINGLE_COLOR_PARAMS
  • bSetName : _NV_MANAGED_DEDICATED_DISPLAY_METADATA
  • bSetPosition : _NV_MANAGED_DEDICATED_DISPLAY_METADATA
  • bSinglePassStereoSupported : _NV_QUERY_MULTIVIEW_SUPPORT_PARAMS_V1, _NV_QUERY_SINGLE_PASS_STEREO_SUPPORT_PARAMS_V1, _NV_QUERY_SINGLE_PASS_STEREO_SUPPORT_PARAMS_V2
  • bSinglePassStereoXYZWSupported : _NV_QUERY_MULTIVIEW_SUPPORT_PARAMS_V1, _NV_QUERY_SINGLE_PASS_STEREO_SUPPORT_PARAMS_V2
  • bSLIFocus : _NV_DISPLAYCONFIG_SOURCE_MODE_INFO_V1
  • bSMPAssistSupported : _NV_QUERY_SMP_ASSIST_SUPPORT_PARAMS_V1
  • bStereoEnable : _NV_DX_VIDEO_STEREO_INFO
  • bSupported : _NV_GPU_QUERY_ILLUMINATION_SUPPORT_PARM_V1
  • bSync : NV_GPU_CLIENT_ILLUM_DEVICE_SYNC_V1
  • bTestMode : _NVVIOINPUTCONFIG
  • BTimems : _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR
  • bus : NVLINK_DEVICE_INFO_V1
  • bUseGameSleep : _NV_GET_SLEEP_STATUS_PARAMS
  • bUseMarkersToOptimize : _NV_SET_SLEEP_MODE_PARAMS
  • bVariablePixelRateShadingSupported : _NV_D3D12_GRAPHICS_CAPS_V1, _NV_D3D1x_GRAPHICS_CAPS_V1, _NV_D3D1x_GRAPHICS_CAPS_V2
  • byteOffset : _NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_DESC, _NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_DESC


  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all struct and union fields with links to the structures/unions they belong to:

- c -

  • callback : _NV_GPU_CLIENT_UTILIZATION_PERIODIC_CALLBACK_SETTINGS_V1
  • callbackParam : NV_EVENT_REGISTER_CALLBACK
  • callbackPeriodms : _NV_GPU_CLIENT_PERIODIC_CALLBACK_SETTINGS_SUPER_V1
  • capFlags : _NV_GSYNC_CAPABILITIES_V1, _NV_GSYNC_CAPABILITIES_V2, _NV_GSYNC_CAPABILITIES_V3
  • caps : _NV_MONITOR_CAPABILITIES_V1
  • capsTbl : NVLINK_GET_CAPS_V1, NVLINK_LINK_STATUS_INFO_V1, NVLINK_LINK_STATUS_INFO_V2
  • captureStatus : _NVVIOINPUTSTATUS
  • cbSize : NV_I2C_INFO_V1, NV_I2C_INFO_V2, NV_I2C_INFO_V3
  • cc_blue_x : _NV_HDR_CAPABILITIES_V2, _NV_HDR_CAPABILITIES_V3
  • cc_blue_y : _NV_HDR_CAPABILITIES_V2, _NV_HDR_CAPABILITIES_V3
  • cc_green_x : _NV_HDR_CAPABILITIES_V2, _NV_HDR_CAPABILITIES_V3
  • cc_green_y : _NV_HDR_CAPABILITIES_V2, _NV_HDR_CAPABILITIES_V3
  • cc_red_x : _NV_HDR_CAPABILITIES_V2, _NV_HDR_CAPABILITIES_V3
  • cc_red_y : _NV_HDR_CAPABILITIES_V2, _NV_HDR_CAPABILITIES_V3
  • cc_white_x : _NV_HDR_CAPABILITIES_V2, _NV_HDR_CAPABILITIES_V3
  • cc_white_y : _NV_HDR_CAPABILITIES_V2, _NV_HDR_CAPABILITIES_V3
  • ceaId : NV_TIMING_FLAG
  • centerHeight : _NV_MRS_CUSTOM_CONFIG_V1, _NV_MRS_INSTANCED_STEREO_CONFIG_V1
  • centerWidth : _NV_MRS_CUSTOM_CONFIG_V1, _NV_MRS_INSTANCED_STEREO_CONFIG_V1
  • centerX : _NV_MRS_CUSTOM_CONFIG_V1, _NV_MRS_INSTANCED_STEREO_CONFIG_V1
  • centerY : _NV_MRS_CUSTOM_CONFIG_V1, _NV_MRS_INSTANCED_STEREO_CONFIG_V1
  • channel : _NVVIOSTREAM
  • channelCount : NV_INFOFRAME_AUDIO
  • checkStatus : _NVAPI_CHECK_DRIVER_MATCHING_IDENTIFIER_EX_PARAMS_V1
  • ClipToWindowSplitsX : _NV_SMP_ASSIST_REMAPCBDATA_V1
  • ClipToWindowSplitsY : _NV_SMP_ASSIST_REMAPCBDATA_V1
  • ClipToWindowX : _NV_SMP_ASSIST_REMAPCBDATA_V1
  • ClipToWindowY : _NV_SMP_ASSIST_REMAPCBDATA_V1
  • ClipToWindowZ : _NV_SMP_ASSIST_REMAPCBDATA_V1
  • clocks : _NV_GPU_PERF_PSTATES20_INFO_V2, NV_GPU_PERF_PSTATES20_INFO_V1, NV_GPU_PERF_PSTATES_INFO_V1, NV_GPU_PERF_PSTATES_INFO_V2
  • ClockType : NV_GPU_CLOCK_FREQUENCIES_V2
  • cloneGroup : _NV_MOSAIC_GRID_TOPO_DISPLAY_V1, _NV_MOSAIC_GRID_TOPO_DISPLAY_V2
  • cloneImportance : _NV_SCANOUT_INFORMATION
  • cmd : _NV_COLOR_DATA_V1, _NV_COLOR_DATA_V2, _NV_COLOR_DATA_V3, _NV_COLOR_DATA_V4, _NV_COLOR_DATA_V5, _NV_HDR_COLOR_DATA_V1, _NV_HDR_COLOR_DATA_V2, NV_INFOFRAME_DATA
  • cnc0SupportGraphicsTextContent : _NV_MONITOR_CAPS_VSDB
  • cnc1SupportPhotoContent : _NV_MONITOR_CAPS_VSDB
  • cnc2SupportCinemaContent : _NV_MONITOR_CAPS_VSDB
  • cnc3SupportGameContent : _NV_MONITOR_CAPS_VSDB
  • codingExtensionType : NV_INFOFRAME_AUDIO
  • codingType : NV_INFOFRAME_AUDIO
  • colCount : NV_MOSAIC_TOPO_DETAILS, NV_MOSAIC_TOPOLOGY
  • colorB : _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_RGB_PARAMS, _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_RGBW_PARAMS
  • colorConversion : _NVVIOOUTPUTCONFIG_V1, _NVVIOOUTPUTCONFIG_V2, _NVVIOOUTPUTCONFIG_V3
  • colorDepth : _NV_RESOLUTION
  • colorFixed : _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_V1
  • colorFixedParams : _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_COLOR_FIXED, _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR_COLOR_FIXED
  • colorFormat : _NV_COLOR_DATA_V1, _NV_COLOR_DATA_V2, _NV_COLOR_DATA_V3, _NV_COLOR_DATA_V4, _NV_COLOR_DATA_V5, _NV_DISPLAY_PORT_INFO_V1, _NV_DISPLAYCONFIG_SOURCE_MODE_INFO_V1, _NV_MONITOR_COLOR_DATA, NV_CUSTOM_DISPLAY, NV_DISPLAY_PATH, NV_DISPLAY_PORT_CONFIG
  • colorG : _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_RGB_PARAMS, _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_RGBW_PARAMS
  • colorimetry : _NV_COLOR_DATA_V1, _NV_COLOR_DATA_V2, _NV_COLOR_DATA_V3, _NV_COLOR_DATA_V4, _NV_COLOR_DATA_V5, _NV_DISPLAY_PORT_INFO_V1, _NV_HDR_CAPABILITIES_V2, _NV_HDR_CAPABILITIES_V3, NV_DISPLAY_PORT_CONFIG, NV_INFOFRAME_VIDEO
  • colorMatrix : _NVVIOCOLORCONVERSION
  • colorOffset : _NVVIOCOLORCONVERSION
  • colorR : _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_RGB_PARAMS, _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_RGBW_PARAMS
  • colorScale : _NVVIOCOLORCONVERSION
  • colorSelectionPolicy : _NV_COLOR_DATA_V4, _NV_COLOR_DATA_V5
  • colorSpace : _NVVIOCHANNELSTATUS, NV_INFOFRAME_VIDEO
  • colorW : _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_RGBW_PARAMS
  • columns : _NV_MOSAIC_GRID_TOPO_V1, _NV_MOSAIC_GRID_TOPO_V2
  • commandLine : _NVDRS_APPLICATION_V4
  • companionBufferCount : _NV_D3D12_MOSAIC_GETCOMPANIONALLOCATIONS
  • compositeSafe : _NVVIOCOLORCONVERSION
  • compositeSyncType : _NVVIOOUTPUTCONFIG_V1, _NVVIOOUTPUTCONFIG_V2, _NVVIOOUTPUTCONFIG_V3
  • compositeTerminate : _NVVIOOUTPUTCONFIG_V1, _NVVIOOUTPUTCONFIG_V2, _NVVIOOUTPUTCONFIG_V3
  • compRange : _NVVIOOUTPUTCONFIG_V1, _NVVIOOUTPUTCONFIG_V2, _NVVIOOUTPUTCONFIG_V3
  • compSyncIn : _NVVIOOUTPUTSTATUS
  • computeGpus : _NV_COMPUTE_GPU_TOPOLOGY_V2, NV_COMPUTE_GPU_TOPOLOGY_V1
  • configurationOptions : NV_GPU_ECC_STATUS_INFO
  • connected : NVLINK_LINK_STATUS_INFO_V1, NVLINK_LINK_STATUS_INFO_V2
  • connector : _NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_V1, _NV_GSYNC_GPU, NV_DISPLAY_PATH
  • connectorType : _NV_GPU_DISPLAYIDS, _NV_MONITOR_CAPABILITIES_V1
  • ConservativeRaster : _NV_D3D11_FEATURE_DATA_RASTERIZER_SUPPORT
  • ConservativeRasterEnable : NvAPI_D3D11_RASTERIZER_DESC_EX
  • ConstantPadVal : NV_META_COMMAND_PADDING_DESC
  • ContentType : _NV_VRS_HELPER_ENABLE_PARAMS_V1
  • contentTypes : NV_INFOFRAME_VIDEO
  • controller : NV_GPU_THERMAL_SETTINGS_V1, NV_GPU_THERMAL_SETTINGS_V2
  • ConvertToFastGS : NvAPI_D3D11_CREATE_GEOMETRY_SHADER_EX_V5, NVAPI_D3D12_PSO_GEOMETRY_SHADER_DESC_V5
  • count : _NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_USAGE_COUNT, _NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_USAGE_COUNT, NV_DISPLAY_PATH_INFO, NV_DISPLAY_PATH_INFO_V3, NV_GPU_THERMAL_SETTINGS_V1, NV_GPU_THERMAL_SETTINGS_V2, NV_MOSAIC_TOPO_GROUP, NV_VIEW_TARGET_INFO
  • CoverageToColor : _NV_D3D11_FEATURE_DATA_RASTERIZER_SUPPORT
  • CoverageToColorEnable : NvAPI_D3D11_RASTERIZER_DESC_EX, NVAPI_D3D12_PSO_RASTERIZER_STATE_DESC_V1
  • CoverageToColorRTIndex : NvAPI_D3D11_RASTERIZER_DESC_EX, NVAPI_D3D12_PSO_RASTERIZER_STATE_DESC_V1
  • CResource : NV_D3D11_META_COMMAND_EXECUTE_GEMM_DESC, NV_D3D12_META_COMMAND_EXECUTE_GEMM_DESC
  • cscOverride : _NVVIOOUTPUTCONFIG_V1, _NVVIOOUTPUTCONFIG_V2, _NVVIOOUTPUTCONFIG_V3
  • ctrlMode : _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_V1
  • ctrlModeMask : _NV_GPU_CLIENT_ILLUM_DEVICE_INFO_V1
  • CullMode : NvAPI_D3D11_RASTERIZER_DESC_EX
  • curAvailableDedicatedVideoMemory : NV_DISPLAY_DRIVER_MEMORY_INFO_V2, NV_DISPLAY_DRIVER_MEMORY_INFO_V3, NV_GPU_MEMORY_INFO_EX_V1
  • curLaneCount : _NV_DISPLAY_PORT_INFO_V1
  • curLinkRate : _NV_DISPLAY_PORT_INFO_V1
  • current : NV_GPU_ECC_ERROR_INFO
  • currentAFRIndex : NV_GET_CURRENT_SLI_STATE_V1, NV_GET_CURRENT_SLI_STATE_V2
  • currentDockPolicy : NV_LID_DOCK_PARAMS
  • currentDockState : NV_LID_DOCK_PARAMS
  • currentLidPolicy : NV_LID_DOCK_PARAMS
  • currentLidState : NV_LID_DOCK_PARAMS
  • currentlyCapableOfVRR : _NV_MONITOR_CAPS_GENERIC
  • currentSizeInBytes : _NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_POSTBUILD_INFO_CURRENT_SIZE_DESC, _NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_ARRAY_POSTBUILD_INFO_CURRENT_SIZE_DESC
  • currentTemp : NV_GPU_THERMAL_SETTINGS_V1, NV_GPU_THERMAL_SETTINGS_V2
  • cycleType : _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR


  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all struct and union fields with links to the structures/unions they belong to:

- d -

  • data : _NV_COLOR_DATA_V1, _NV_COLOR_DATA_V2, _NV_COLOR_DATA_V3, _NV_COLOR_DATA_V4, _NV_COLOR_DATA_V5, _NV_GPU_CLIENT_ILLUM_DEVICE_INFO_V1, _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_COLOR_FIXED, _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_RGB, _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_RGBW, _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_SINGLE_COLOR, _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_V1, _NV_GPU_CLIENT_ILLUM_ZONE_INFO_V1, _NV_MONITOR_CAPABILITIES_V1, NV_GPU_PSTATE20_CLOCK_ENTRY_V1
  • data1 : NvGUID
  • data2 : NvGUID
  • data3 : NvGUID
  • data4 : NvGUID
  • dataFormat : _NVVIODATAFORMATDETAIL, _NVVIOOUTPUTCONFIG_V1, _NVVIOOUTPUTCONFIG_V2, _NVVIOOUTPUTCONFIG_V3
  • dataIntegrityCheckEnabled : _NVVIOOUTPUTSTATUS
  • dataIntegrityCheckErrorCount : _NVVIOOUTPUTSTATUS
  • dataIntegrityCheckFailed : _NVVIOOUTPUTSTATUS
  • DataType : NV_META_COMMAND_TENSOR_DESC
  • day : _NV_LICENSE_EXPIRY_DETAILS
  • dedicatedVideoMemory : NV_DISPLAY_DRIVER_MEMORY_INFO_V1, NV_DISPLAY_DRIVER_MEMORY_INFO_V2, NV_DISPLAY_DRIVER_MEMORY_INFO_V3, NV_GPU_MEMORY_INFO_EX_V1
  • dedicatedVideoMemoryEvictionCount : NV_DISPLAY_DRIVER_MEMORY_INFO_V3, NV_GPU_MEMORY_INFO_EX_V1
  • dedicatedVideoMemoryEvictionsSize : NV_DISPLAY_DRIVER_MEMORY_INFO_V3, NV_GPU_MEMORY_INFO_EX_V1
  • dedicatedVideoMemoryPromotionCount : NV_GPU_MEMORY_INFO_EX_V1
  • dedicatedVideoMemoryPromotionsSize : NV_GPU_MEMORY_INFO_EX_V1
  • defaultMaxTemp : NV_GPU_THERMAL_SETTINGS_V1, NV_GPU_THERMAL_SETTINGS_V2
  • defaultMinTemp : NV_GPU_THERMAL_SETTINGS_V1, NV_GPU_THERMAL_SETTINGS_V2
  • defaultValue : _SettingDWORDNameString, _SettingWSTRINGNameString
  • densityScaleX : _NV_MRS_CUSTOM_CONFIG_V1, _NV_MRS_INSTANCED_STEREO_CONFIG_V1
  • densityScaleY : _NV_MRS_CUSTOM_CONFIG_V1, _NV_MRS_INSTANCED_STEREO_CONFIG_V1
  • depth : _NV_COLOR_DATA_V5, NV_CUSTOM_DISPLAY, NV_DISPLAY_PATH
  • DepthBias : NvAPI_D3D11_RASTERIZER_DESC_EX
  • DepthBiasClamp : NvAPI_D3D11_RASTERIZER_DESC_EX
  • DepthClipEnable : NvAPI_D3D11_RASTERIZER_DESC_EX
  • desc : NVAPI_D3D12_GET_CUDA_INDEPENDENT_DESCRIPTOR_OBJECT_PARAMS
  • DescA : NV_META_COMMAND_CREATE_GEMM_DESC
  • DescB : NV_META_COMMAND_CREATE_GEMM_DESC
  • DescBias : NV_META_COMMAND_CREATE_CONVOLUTION_EX_DESC
  • DescC : NV_META_COMMAND_CREATE_GEMM_DESC
  • DescFilter : NV_META_COMMAND_CREATE_CONVOLUTION_EX_DESC
  • DescIn : NV_META_COMMAND_CREATE_CONVOLUTION_EX_DESC
  • DescOut : NV_META_COMMAND_CREATE_CONVOLUTION_EX_DESC, NV_META_COMMAND_CREATE_GEMM_DESC
  • descsLayout : _NVAPI_D3D12_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_INPUTS_EX
  • desired_content_max_frame_average_luminance : _NV_HDR_CAPABILITIES_V1, _NV_HDR_CAPABILITIES_V2, _NV_HDR_CAPABILITIES_V3
  • desired_content_max_luminance : _NV_HDR_CAPABILITIES_V1, _NV_HDR_CAPABILITIES_V2, _NV_HDR_CAPABILITIES_V3
  • desired_content_min_luminance : _NV_HDR_CAPABILITIES_V1, _NV_HDR_CAPABILITIES_V2, _NV_HDR_CAPABILITIES_V3
  • destAccelerationStructureData : _NVAPI_D3D12_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_DESC_EX
  • destBuffer : _NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_POSTBUILD_INFO_DESC, _NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_ARRAY_POSTBUILD_INFO_DESC
  • destDisplacementMicromapArrayData : _NVAPI_D3D12_BUILD_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_DESC
  • destOpacityMicromapArrayData : _NVAPI_D3D12_BUILD_RAYTRACING_OPACITY_MICROMAP_ARRAY_DESC
  • details : _NV_DISPLAYCONFIG_PATH_TARGET_INFO_V1, _NV_DISPLAYCONFIG_PATH_TARGET_INFO_V2
  • device : NVLINK_DEVICE_INFO_V1
  • deviceId : NV_CHIPSET_INFO_v1, NV_CHIPSET_INFO_v2, NV_CHIPSET_INFO_v3, NV_CHIPSET_INFO_v4
  • deviceIdFlags : NVLINK_DEVICE_INFO_V1
  • deviceMask : NV_DISPLAY_PATH, NV_VIEW_TARGET_INFO
  • devices : _NV_GPU_CLIENT_ILLUM_DEVICE_INFO_PARAMS_V1, NV_GPU_CLIENT_ILLUM_DEVICE_CONTROL_PARAMS_V1
  • deviceType : NVLINK_DEVICE_INFO_V1
  • deviceUUID : NVLINK_DEVICE_INFO_V1
  • Dilation : NV_META_COMMAND_CREATE_CONVOLUTION_EX_DESC
  • DimensionCount : NV_META_COMMAND_CREATE_CONVOLUTION_EX_DESC, NV_META_COMMAND_TENSOR_DESC
  • dipSwitch : _NVVIOCAPS
  • dipSwitchReserved : _NVVIOCAPS
  • Direction : NV_META_COMMAND_CREATE_CONVOLUTION_EX_DESC
  • disableVirtualModeSupport : _NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_V1
  • DispatchGraphics() : INvAPI_DirectD3D12GraphicsCommandList
  • displacementMicromapArray : _NVAPI_D3D12_RAYTRACING_GEOMETRY_DMM_ATTACHMENT_DESC, _NVAPI_RELOCATE_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PARAMS_V1
  • display_data : _NV_HDR_CAPABILITIES_V1, _NV_HDR_CAPABILITIES_V2, _NV_HDR_CAPABILITIES_V3
  • displayCount : _NV_MOSAIC_GRID_TOPO_V1, _NV_MOSAIC_GRID_TOPO_V2, NV_MOSAIC_DISPLAY_TOPO_STATUS
  • displayId : _NV_DISPLAYCONFIG_PATH_TARGET_INFO_V1, _NV_DISPLAYCONFIG_PATH_TARGET_INFO_V2, _NV_GPU_DISPLAYIDS, _NV_GSYNC_DISPLAY, _NV_MANAGED_DEDICATED_DISPLAY_INFO, _NV_MANAGED_DEDICATED_DISPLAY_METADATA, _NV_MOSAIC_GRID_TOPO_DISPLAY_V1, _NV_MOSAIC_GRID_TOPO_DISPLAY_V2, NV_GET_PREFERRED_STEREO_DISPLAY_V1, NV_MOSAIC_DISPLAY_TOPO_STATUS, NV_SET_PREFERRED_STEREO_DISPLAY_V1
  • displayMask : NV_I2C_INFO_V1, NV_I2C_INFO_V2, NV_I2C_INFO_V3
  • displayOutputId : NV_MOSAIC_TOPO_DETAILS, NV_MOSAIC_TOPOLOGY
  • displayPrimary_x0 : _NV_HDR_CAPABILITIES_V1, _NV_HDR_CAPABILITIES_V2, _NV_HDR_CAPABILITIES_V3, _NV_HDR_COLOR_DATA_V1, _NV_HDR_COLOR_DATA_V2, _NV_HDR_METADATA_V1
  • displayPrimary_x1 : _NV_HDR_CAPABILITIES_V1, _NV_HDR_CAPABILITIES_V2, _NV_HDR_CAPABILITIES_V3, _NV_HDR_COLOR_DATA_V1, _NV_HDR_COLOR_DATA_V2, _NV_HDR_METADATA_V1
  • displayPrimary_x2 : _NV_HDR_CAPABILITIES_V1, _NV_HDR_CAPABILITIES_V2, _NV_HDR_CAPABILITIES_V3, _NV_HDR_COLOR_DATA_V1, _NV_HDR_COLOR_DATA_V2, _NV_HDR_METADATA_V1
  • displayPrimary_y0 : _NV_HDR_CAPABILITIES_V1, _NV_HDR_CAPABILITIES_V2, _NV_HDR_CAPABILITIES_V3, _NV_HDR_COLOR_DATA_V1, _NV_HDR_COLOR_DATA_V2, _NV_HDR_METADATA_V1
  • displayPrimary_y1 : _NV_HDR_CAPABILITIES_V1, _NV_HDR_CAPABILITIES_V2, _NV_HDR_CAPABILITIES_V3, _NV_HDR_COLOR_DATA_V1, _NV_HDR_COLOR_DATA_V2, _NV_HDR_METADATA_V1
  • displayPrimary_y2 : _NV_HDR_CAPABILITIES_V1, _NV_HDR_CAPABILITIES_V2, _NV_HDR_CAPABILITIES_V3, _NV_HDR_COLOR_DATA_V1, _NV_HDR_COLOR_DATA_V2, _NV_HDR_METADATA_V1
  • displays : _NV_MOSAIC_GRID_TOPO_V1, _NV_MOSAIC_GRID_TOPO_V2, NV_MOSAIC_DISPLAY_TOPO_STATUS
  • displaySettings : _NV_MOSAIC_GRID_TOPO_V1, _NV_MOSAIC_GRID_TOPO_V2, _NV_MOSAIC_SUPPORTED_TOPO_INFO_V1, _NV_MOSAIC_SUPPORTED_TOPO_INFO_V2
  • displaySettingsCount : _NV_MOSAIC_SUPPORTED_TOPO_INFO_V1, _NV_MOSAIC_SUPPORTED_TOPO_INFO_V2
  • displayWhitePoint_x : _NV_HDR_CAPABILITIES_V1, _NV_HDR_CAPABILITIES_V2, _NV_HDR_CAPABILITIES_V3, _NV_HDR_COLOR_DATA_V1, _NV_HDR_COLOR_DATA_V2, _NV_HDR_METADATA_V1
  • displayWhitePoint_y : _NV_HDR_CAPABILITIES_V1, _NV_HDR_CAPABILITIES_V2, _NV_HDR_CAPABILITIES_V3, _NV_HDR_COLOR_DATA_V1, _NV_HDR_COLOR_DATA_V2, _NV_HDR_METADATA_V1
  • dm_version : _NV_HDR_CAPABILITIES_V2, _NV_HDR_CAPABILITIES_V3
  • dmmAttachment : _NVAPI_D3D12_RAYTRACING_GEOMETRY_DMM_TRIANGLES_DESC
  • dmmTriangles : _NVAPI_D3D12_RAYTRACING_GEOMETRY_DESC_EX
  • domain : NV_GPU_CLOCK_FREQUENCIES_V1, NV_GPU_CLOCK_FREQUENCIES_V2, NVLINK_DEVICE_INFO_V1
  • domainId : NV_GPU_PERF_PSTATES_INFO_V1, NV_GPU_PERF_PSTATES_INFO_V2, NV_GPU_PSTATE20_BASE_VOLTAGE_ENTRY_V1, NV_GPU_PSTATE20_CLOCK_ENTRY_V1
  • DontUseViewportOrder : NvAPI_D3D11_CREATE_GEOMETRY_SHADER_EX_V5, NVAPI_D3D12_PSO_GEOMETRY_SHADER_DESC_V5
  • doubleBitErrors : NV_GPU_ECC_ERROR_INFO
  • downmixInhibit : NV_INFOFRAME_AUDIO
  • dpcd_ver : _NV_DISPLAY_PORT_INFO_V1
  • driver : _NVVIOCAPS
  • driverEndTime : _NV_LATENCY_RESULT_PARAMS::FrameReport
  • driverExpandDefaultHdrParameters : _NV_HDR_CAPABILITIES_V1, _NV_HDR_CAPABILITIES_V2, _NV_HDR_CAPABILITIES_V3
  • driverReloadAllowed : _NV_MOSAIC_GRID_TOPO_V1, _NV_MOSAIC_GRID_TOPO_V2
  • driverStartTime : _NV_LATENCY_RESULT_PARAMS::FrameReport
  • driverVersion : _NV_DISPLAY_DRIVER_INFO, _NV_DISPLAY_DRIVER_INFO_V2
  • drvVersion : NV_DISPLAY_DRIVER_VERSION
  • dst0u : NvShaderExtnStruct
  • dst1u : NvShaderExtnStruct
  • dv_static_metadata : _NV_HDR_CAPABILITIES_V2, _NV_HDR_CAPABILITIES_V3
  • dwVersion : _NV_DX_VIDEO_STEREO_INFO, _NV_JOIN_PRESENT_BARRIER_PARAMS, _NV_PRESENT_BARRIER_FRAME_STATISTICS
  • dynamicRange : _NV_COLOR_DATA_V2, _NV_COLOR_DATA_V3, _NV_COLOR_DATA_V4, _NV_COLOR_DATA_V5, _NV_DISPLAY_PORT_INFO_V1, NV_DISPLAY_PORT_CONFIG
  • dynSharedMemBytes : _NVAPI_CU_KERNEL_LAUNCH_PARAMS, _NVAPI_CU_KERNEL_LAUNCH_PARAMS_EX, NVAPI_D3D12_CREATE_CUBIN_SHADER_PARAMS


  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all struct and union fields with links to the structures/unions they belong to:

- e -

  • EDID861ExtRev : _NV_HDMI_SUPPORT_INFO_V1, _NV_HDMI_SUPPORT_INFO_V2
  • EDID_Data : NV_EDID_V1, NV_EDID_V2, NV_EDID_V3
  • edidId : NV_EDID_V3
  • eEyeIndex : _NV_SMP_ASSIST_ENABLE_PARAMS_V1, _NV_SMP_ASSIST_GET_CONSTANTS_V3
  • eFormat : _NV_DX_VIDEO_STEREO_INFO
  • eLMSConfig : _NV_SMP_ASSIST_SETUP_PARAMS_V1
  • eMRSConfig : _NV_SMP_ASSIST_SETUP_PARAMS_V1
  • enable422Filter : _NVVIOOUTPUTCONFIG_V1, _NVVIOOUTPUTCONFIG_V2, _NVVIOOUTPUTCONFIG_V3
  • enableAlphaKeyComposite : _NVVIOOUTPUTCONFIG_V1, _NVVIOOUTPUTCONFIG_V2, _NVVIOOUTPUTCONFIG_V3
  • enableANCTimeCodeGeneration : _NVVIOOUTPUTCONFIG_V1, _NVVIOOUTPUTCONFIG_V2, _NVVIOOUTPUTCONFIG_V3
  • enableAudioBlanking : _NVVIOOUTPUTCONFIG_V3
  • enableComposite : _NVVIOOUTPUTCONFIG_V1, _NVVIOOUTPUTCONFIG_V2, _NVVIOOUTPUTCONFIG_V3
  • enabled : NV_MOSAIC_TOPO_BRIEF
  • enableDataIntegrityCheck : _NVVIOOUTPUTCONFIG_V1, _NVVIOOUTPUTCONFIG_V2, _NVVIOOUTPUTCONFIG_V3
  • EnableDBT : NVAPI_D3D12_PSO_ENABLE_DEPTH_BOUND_TEST_DESC_V1
  • enableExclusiveScissorRect : _NV_D3D11_EXCLUSIVE_SCISSOR_RECT_DESC_V1
  • enableFullColorRange : _NVVIOOUTPUTCONFIG_V1, _NVVIOOUTPUTCONFIG_V2, _NVVIOOUTPUTCONFIG_V3
  • enableRGBData : _NVVIOOUTPUTCONFIG_V1, _NVVIOOUTPUTCONFIG_V2, _NVVIOOUTPUTCONFIG_V3
  • enableVariablePixelShadingRate : _NV_D3D11_VIEWPORT_SHADING_RATE_DESC_V1
  • EndPadding : NV_META_COMMAND_CREATE_CONVOLUTION_EX_DESC
  • errorFlags : NV_MOSAIC_DISPLAY_TOPO_STATUS
  • eSMPAssistLevel : _NV_QUERY_SMP_ASSIST_SUPPORT_PARAMS_V1, _NV_SMP_ASSIST_GET_CONSTANTS_V3, _NV_SMP_ASSIST_INITIALIZE_PARAMS_V1
  • eSMPAssistType : _NV_QUERY_SMP_ASSIST_SUPPORT_PARAMS_V1, _NV_SMP_ASSIST_GET_CONSTANTS_V3, _NV_SMP_ASSIST_INITIALIZE_PARAMS_V1, _NV_SMP_ASSIST_UPDATE_INSTANCEDSTEREO_DATA_PARAMS_V1
  • etc : _NV_TIMING
  • eventId : NV_EVENT_REGISTER_CALLBACK
  • ExecutionDirtyState : NVAPI_META_COMMAND_DESC
  • expansionEnable : _NVVIOSTREAM
  • extendedColorimetry : NV_INFOFRAME_VIDEO
  • extendedRevision : _NV_GSYNC_CAPABILITIES_V2, _NV_GSYNC_CAPABILITIES_V3


  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all struct and union fields with links to the structures/unions they belong to:

- f -

  • fA : _NV_MODIFIED_W_COEFFICIENTS
  • fallTimems : _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR
  • fAReserved : _NV_MODIFIED_W_COEFFICIENTS
  • fastNvLinkReads : _NV_MULTIGPU_CAPS_V2
  • fB : _NV_MODIFIED_W_COEFFICIENTS
  • fBReserved : _NV_MODIFIED_W_COEFFICIENTS
  • featureCode : _NV_LICENSE_FEATURE_DETAILS_V1, _NV_LICENSE_FEATURE_DETAILS_V2, _NV_LICENSE_FEATURE_DETAILS_V3, _NV_LICENSE_FEATURE_DETAILS_V4
  • featureId : NVAPI_ANSEL_FEATURE_CONFIGURATION_STRUCT
  • featureState : NVAPI_ANSEL_FEATURE_CONFIGURATION_STRUCT
  • fEyeOpenness : _NV_FOVEATED_RENDERING_GAZE_DATA_PER_EYE
  • fFrameRate : _NVVIOVIDEOMODE
  • fGammaValueB : _NVVIOGAMMACORRECTION
  • fGammaValueG : _NVVIOGAMMACORRECTION
  • fGammaValueR : _NVVIOGAMMACORRECTION
  • fGazeDirection : _NV_FOVEATED_RENDERING_GAZE_DATA_PER_EYE
  • fGazeNormalizedLocation : _NV_FOVEATED_RENDERING_GAZE_DATA_PER_EYE
  • fGazeOrigin_mm : _NV_FOVEATED_RENDERING_GAZE_DATA_PER_EYE
  • fGazeVelocity : _NV_FOVEATED_RENDERING_GAZE_DATA_PER_EYE
  • fHorizontalFOV : _NV_GAZE_HANDLER_INIT_PARAMS_V1, _NV_GAZE_HANDLER_INIT_PARAMS_V2
  • fields : _NVVIOCONFIG_V1, _NVVIOCONFIG_V2, _NVVIOCONFIG_V3
  • fileInFolder : _NVDRS_APPLICATION_V2, _NVDRS_APPLICATION_V3, _NVDRS_APPLICATION_V4
  • FillMode : NvAPI_D3D11_RASTERIZER_DESC_EX
  • FilterResource : NV_D3D11_META_COMMAND_EXECUTE_CONVOLUTION_EX_DESC, NV_D3D12_META_COMMAND_EXECUTE_CONVOLUTION_EX_DESC
  • fInnermostRadii : _NV_FOVEATED_RENDERING_CUSTOM_FOVEATION_PATTERN_PRESET_DESC_V1
  • firmWare : _NVVIOCAPS
  • firmwareVersion : _NV_GPU_GSP_INFO_V1
  • FirstArraySlice : _NV_TEX2D_ARRAY_SRRV
  • flag : _NV_TIMING_INPUT, tagNV_TIMINGEXT
  • flags : _NV_COMPUTE_GPU, _NV_FOVEATED_RENDERING_DESC_V1, _NV_FOVEATED_RENDERING_UPDATE_GAZE_DATA_PARAMS, _NV_GAZE_HANDLER_INIT_PARAMS_V1, _NV_GAZE_HANDLER_INIT_PARAMS_V2, _NV_SMP_ASSIST_INITIALIZE_PARAMS_V1, _NV_VRS_HELPER_ENABLE_PARAMS_V1, _NV_VRS_HELPER_INIT_PARAMS_V1, _NV_VRS_HELPER_LATCH_GAZE_PARAMS_V1, _NVAPI_D3D12_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_INPUTS_EX, _NVAPI_D3D12_BUILD_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_INPUTS, _NVAPI_D3D12_BUILD_RAYTRACING_OPACITY_MICROMAP_ARRAY_INPUTS, _NVAPI_D3D12_RAYTRACING_GEOMETRY_DESC_EX, _NVAPI_D3D12_SET_CREATE_PIPELINE_STATE_OPTIONS_PARAMS_V1, NV_CHIPSET_INFO_v2, NV_CHIPSET_INFO_v3, NV_CHIPSET_INFO_v4, NV_COMPUTE_GPU_TOPOLOGY_V1, NV_GPU_DYNAMIC_PSTATES_INFO_EX, NV_GPU_PERF_PSTATES_INFO_V1, NV_GPU_PERF_PSTATES_INFO_V2
  • Flags : NV_META_COMMAND_TENSOR_DESC
  • flags : NvAPI_D3D11_CREATE_FASTGS_EXPLICIT_DESC_V1, NVAPI_D3D12_CREATE_CUBIN_SHADER_PARAMS, NVAPI_D3D12_PSO_CREATE_FASTGS_EXPLICIT_DESC_V1
  • flagsRsvd : _NV_SET_REFLEX_SYNC_PARAMS
  • FlipInSyncCount : _NV_PRESENT_BARRIER_FRAME_STATISTICS
  • flipQueueLength : _NVVIOOUTPUTCONFIG_V1, _NVVIOOUTPUTCONFIG_V2, _NVVIOOUTPUTCONFIG_V3
  • fMiddleRadii : _NV_FOVEATED_RENDERING_CUSTOM_FOVEATION_PATTERN_PRESET_DESC_V1
  • forcedDockMechanismPresent : NV_LID_DOCK_PARAMS
  • forcedLidMechanismPresent : NV_LID_DOCK_PARAMS
  • ForcedSampleCount : NvAPI_D3D11_RASTERIZER_DESC_EX, NVAPI_D3D12_PSO_RASTERIZER_STATE_DESC_V1
  • ForceFastGS : NvAPI_D3D11_CREATE_GEOMETRY_SHADER_EX_V5, NVAPI_D3D12_PSO_GEOMETRY_SHADER_DESC_V5
  • Format : _NV_D3D11_SHADING_RATE_RESOURCE_VIEW_DESC_V1
  • format : _NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_DESC, _NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_USAGE_COUNT, _NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_DESC, _NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_USAGE_COUNT
  • FoveationPatternCustomPresetDesc : _NV_FOVEATED_RENDERING_DESC_V1
  • FoveationPatternPreset : _NV_FOVEATED_RENDERING_DESC_V1
  • fPeripheralRadii : _NV_FOVEATED_RENDERING_CUSTOM_FOVEATION_PATTERN_PRESET_DESC_V1
  • fPupilDiameter_mm : _NV_FOVEATED_RENDERING_GAZE_DATA_PER_EYE
  • frameID : _NV_ASYNC_FRAME_MARKER_PARAMS_V1, _NV_LATENCY_MARKER_PARAMS, _NV_LATENCY_RESULT_PARAMS::FrameReport
  • frameIntervalUs : _NV_GET_VIRTUAL_REFRESH_RATE_DATA_V1, _NV_SET_VIRTUAL_REFRESH_RATE_DATA_V1
  • frameLockEnable : _NVVIOOUTPUTCONFIG_V1, _NVVIOOUTPUTCONFIG_V2, _NVVIOOUTPUTCONFIG_V3, _NVVIOOUTPUTSTATUS
  • frameReport : _NV_LATENCY_RESULT_PARAMS
  • freq : _NV_MOSAIC_DISPLAY_SETTING_V1, NV_GPU_PERF_PSTATES_INFO_V1, NV_GPU_PERF_PSTATES_INFO_V2, NV_MOSAIC_DISPLAY_SETTING_V2
  • freq_kHz : NV_GPU_PSTATE20_CLOCK_ENTRY_V1
  • freqDelta_kHz : NV_GPU_PSTATE20_CLOCK_ENTRY_V1
  • frequency : NV_GPU_CLOCK_FREQUENCIES_V1, NV_GPU_CLOCK_FREQUENCIES_V2
  • fReserved : _NV_MODIFIED_W_COEFFICIENTS
  • FrontCounterClockwise : NvAPI_D3D11_RASTERIZER_DESC_EX
  • full_frame_peak_luminance_index : _NV_HDR_CAPABILITIES_V3
  • Function : NV_META_COMMAND_ACTIVATION_DESC
  • function : NVLINK_DEVICE_INFO_V1
  • FuseDesc : NV_META_COMMAND_CREATE_CONVOLUTION_EX_FUSED_DESC
  • Future10 : NV_INFOFRAME_AUDIO
  • Future12 : NV_INFOFRAME_AUDIO
  • Future17 : NV_INFOFRAME_VIDEO
  • Future2x : NV_INFOFRAME_AUDIO
  • Future3x : NV_INFOFRAME_AUDIO
  • Future47 : NV_INFOFRAME_VIDEO
  • Future52 : NV_INFOFRAME_AUDIO
  • Future6 : NV_INFOFRAME_AUDIO
  • Future7 : NV_INFOFRAME_AUDIO
  • Future8 : NV_INFOFRAME_AUDIO
  • Future9 : NV_INFOFRAME_AUDIO
  • fVericalFOV : _NV_GAZE_HANDLER_INIT_PARAMS_V1, _NV_GAZE_HANDLER_INIT_PARAMS_V2


  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all struct and union fields with links to the structures/unions they belong to:

- g -

  • gammaCorrection : _NVVIOOUTPUTCONFIG_V1, _NVVIOOUTPUTCONFIG_V2, _NVVIOOUTPUTCONFIG_V3
  • gammaRamp : _NVVIOGAMMACORRECTION
  • gammaRamp10 : _NVVIOGAMMACORRECTION
  • gammaRamp8 : _NVVIOGAMMACORRECTION
  • GazeDataDeviceId : _NV_FOVEATED_RENDERING_DESC_V1, _NV_GAZE_HANDLER_INIT_PARAMS_V1, _NV_GAZE_HANDLER_INIT_PARAMS_V2
  • GazeDataType : _NV_GAZE_HANDLER_INIT_PARAMS_V1, _NV_GAZE_HANDLER_INIT_PARAMS_V2
  • GazeDataValidityFlags : _NV_FOVEATED_RENDERING_GAZE_DATA_PER_EYE
  • geforce : _NVDRS_GPU_SUPPORT
  • geometryDescStrideInBytes : _NVAPI_D3D12_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_INPUTS_EX
  • GetID3D12GraphicsCommandList() : INvAPI_DirectD3D12GraphicsCommandList
  • gpioPinBlue : _NV_GPU_CLIENT_ILLUM_DEVICE_INFO_DATA_GPIO_PWM_RGBW
  • gpioPinGreen : _NV_GPU_CLIENT_ILLUM_DEVICE_INFO_DATA_GPIO_PWM_RGBW
  • gpioPinRed : _NV_GPU_CLIENT_ILLUM_DEVICE_INFO_DATA_GPIO_PWM_RGBW
  • gpioPinSingleColor : _NV_GPU_CLIENT_ILLUM_DEVICE_INFO_DATA_GPIO_PWM_SINGLE_COLOR
  • gpioPinWhite : _NV_GPU_CLIENT_ILLUM_DEVICE_INFO_DATA_GPIO_PWM_RGBW
  • gpioPwmRgbwv10 : _NV_GPU_CLIENT_ILLUM_DEVICE_INFO_V1
  • gpioPwmSingleColorv10 : _NV_GPU_CLIENT_ILLUM_DEVICE_INFO_V1
  • gpuActiveRenderTimeUs : _NV_LATENCY_RESULT_PARAMS::FrameReport
  • gpuCount : _NV_COMPUTE_GPU_TOPOLOGY_V2, NV_COMPUTE_GPU_TOPOLOGY_V1
  • gpuFrameTimeUs : _NV_LATENCY_RESULT_PARAMS::FrameReport
  • gpuHandleCount : _NV_LOGICAL_GPUS, _NV_PHYSICAL_GPUS
  • gpuHandleData : _NV_LOGICAL_GPUS, _NV_PHYSICAL_GPUS
  • gpuId : NV_DISPLAY_PATH
  • gpuLayout : NV_MOSAIC_TOPO_DETAILS, NV_MOSAIC_TOPOLOGY
  • gpuRenderEndTime : _NV_LATENCY_RESULT_PARAMS::FrameReport
  • gpuRenderStartTime : _NV_LATENCY_RESULT_PARAMS::FrameReport
  • gpuSupport : _NVDRS_PROFILE_V1
  • gpuVASize : NV_GET_GPU_VIRTUAL_ADDRESS_V1, NVAPI_UAV_INFO_V1, NVAPI_UAV_INFO_V2
  • gpuVAStart : NV_GET_GPU_VIRTUAL_ADDRESS_V1, NVAPI_UAV_INFO_V1, NVAPI_UAV_INFO_V2
  • gridDim : _NVAPI_CU_KERNEL_LAUNCH_PARAMS, _NVAPI_CU_KERNEL_LAUNCH_PARAMS_EX
  • GroupCount : NV_META_COMMAND_CREATE_CONVOLUTION_EX_DESC
  • grpCount : _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR
  • grpIdleTimems : _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR


  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all struct and union fields with links to the structures/unions they belong to:

- h -

  • h : NV_VIEWPORTF
  • handle : NVAPI_D3D12_GET_CUDA_INDEPENDENT_DESCRIPTOR_OBJECT_PARAMS
  • has3dEntries : _NV_MONITOR_CAPS_VSDB
  • hasInterlacedLatencyField : _NV_MONITOR_CAPS_VSDB
  • hasLatencyField : _NV_MONITOR_CAPS_VSDB
  • hasVicEntries : _NV_MONITOR_CAPS_VSDB
  • HBdeviceId : NV_CHIPSET_INFO_v4
  • HBorder : _NV_TIMING
  • HBsubSysDeviceId : NV_CHIPSET_INFO_v4
  • HBsubSysVendorId : NV_CHIPSET_INFO_v4
  • HBvendorId : NV_CHIPSET_INFO_v4
  • hdcpFuseState : NV_GPU_GET_HDCP_SUPPORT_STATUS
  • hdcpKeySource : NV_GPU_GET_HDCP_SUPPORT_STATUS
  • hdcpKeySourceState : NV_GPU_GET_HDCP_SUPPORT_STATUS
  • hdmi3dLength : _NV_MONITOR_CAPS_VSDB
  • hdmi_3d : _NV_MONITOR_CAPS_VSDB
  • hdmi_vic : _NV_MONITOR_CAPS_VSDB
  • hdmiVicLength : _NV_MONITOR_CAPS_VSDB
  • hdr10plus_vsvdb : _NV_HDR_CAPABILITIES_V3
  • hdrBpc : _NV_HDR_COLOR_DATA_V2
  • hdrColorFormat : _NV_HDR_COLOR_DATA_V2
  • hdrDynamicRange : _NV_HDR_COLOR_DATA_V2
  • hdrMode : _NV_HDR_COLOR_DATA_V1, _NV_HDR_COLOR_DATA_V2
  • height : _NV_MOSAIC_DISPLAY_SETTING_V1, _NV_RESOLUTION, _NV_TIMING_INPUT, _NVVIOOUTPUTREGION, NV_CUSTOM_DISPLAY, NV_DISPLAY_PATH, NV_MOSAIC_DISPLAY_SETTING_V2, NV_SCANOUT_INTENSITY_DATA_V1, NV_SCANOUT_INTENSITY_DATA_V2
  • HFrontPorch : _NV_TIMING
  • hFunction : _NVAPI_CU_KERNEL_LAUNCH_PARAMS, _NVAPI_CU_KERNEL_LAUNCH_PARAMS_EX
  • highestNciVersion : NVLINK_GET_CAPS_V1
  • highestNvlinkVersion : NVLINK_GET_CAPS_V1
  • hLinkedSurface : _NV_DX_VIDEO_STEREO_INFO
  • hLogicalGpu : _NV_LOGICAL_GPU_HANDLE_DATA
  • hLogicalGPU : NV_MOSAIC_TOPO_DETAILS
  • horizontalDelay : _NVVIOSYNCDELAY
  • horizontalPixels : _NVVIOVIDEOMODE
  • hotkey : NVAPI_ANSEL_FEATURE_CONFIGURATION_STRUCT
  • hotkeyModifier : NVAPI_ANSEL_CONFIGURATION_STRUCT_V1
  • hour : _NV_LICENSE_EXPIRY_DETAILS
  • houseSyncIncoming : _NV_GSYNC_STATUS_PARAMS_V1, _NV_GSYNC_STATUS_PARAMS_V2
  • hPhysicalGpu : _NV_COMPUTE_GPU, _NV_GPU_GET_ILLUMINATION_PARM_V1, _NV_GPU_QUERY_ILLUMINATION_SUPPORT_PARM_V1, _NV_GPU_SET_ILLUMINATION_PARM_V1, _NV_GSYNC_GPU, _NV_PHYSICAL_GPU_HANDLE_DATA, NV_COMPUTE_GPU_TOPOLOGY_V1
  • hPhysicalGPU : NV_MOSAIC_TOPO_DETAILS, NV_MOSAIC_TOPOLOGY
  • hPhysicalGpu : NVVIOTOPOLOGYTARGET
  • hProxyPhysicalGpu : _NV_GSYNC_GPU
  • hResource : NV_GET_GPU_VIRTUAL_ADDRESS_V1
  • hShader : NVAPI_D3D12_CREATE_CUBIN_SHADER_PARAMS
  • hSurface : _NV_DX_VIDEO_STEREO_INFO
  • HSyncPol : _NV_TIMING
  • HSyncWidth : _NV_TIMING
  • HTotal : _NV_TIMING
  • hVioHandle : NVVIOTOPOLOGYTARGET
  • HVisible : _NV_TIMING
  • hwModeSetOnly : NV_CUSTOM_DISPLAY


  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all struct and union fields with links to the structures/unions they belong to:

- i -

  • i2cDevAddress : NV_I2C_INFO_V1, NV_I2C_INFO_V2, NV_I2C_INFO_V3
  • i2cDevIdx : _NV_GPU_CLIENT_ILLUM_DEVICE_INFO_DATA_MCUV10
  • i2cSpeed : NV_I2C_INFO_V1, NV_I2C_INFO_V2, NV_I2C_INFO_V3
  • i2cSpeedKhz : NV_I2C_INFO_V2, NV_I2C_INFO_V3
  • id : _NV_MODIFIED_W_PARAMS
  • Id : NVAPI_META_COMMAND_DESC
  • illumDeviceIdx : _NV_GPU_CLIENT_ILLUM_ZONE_INFO_V1
  • immersiveGaming : _NV_MOSAIC_GRID_TOPO_V1, _NV_MOSAIC_GRID_TOPO_V2
  • implementation : NV_GPU_ARCH_INFO_V1, NV_GPU_ARCH_INFO_V2
  • implementation_id : NV_GPU_ARCH_INFO_V2
  • inConfig : _NVVIOCONFIG_V1, _NVVIOCONFIG_V2, _NVVIOCONFIG_V3
  • independentViewportMaskEnable : _NV_MULTIVIEW_PARAMS_V1
  • infoframe : NV_INFOFRAME_DATA
  • infoType : _NV_MONITOR_CAPABILITIES_V1, _NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_POSTBUILD_INFO_DESC, _NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_ARRAY_POSTBUILD_INFO_DESC
  • InitializationDirtyState : NVAPI_META_COMMAND_DESC
  • InnerMostRegionShadingRate : _NV_FOVEATED_RENDERING_CUSTOM_SHADING_RATE_PRESET_DESC_V1
  • inputBuffer : _NVAPI_D3D12_BUILD_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_INPUTS, _NVAPI_D3D12_BUILD_RAYTRACING_OPACITY_MICROMAP_ARRAY_INPUTS
  • InputResource : NV_D3D11_META_COMMAND_EXECUTE_CONVOLUTION_EX_DESC, NV_D3D12_META_COMMAND_EXECUTE_CONVOLUTION_EX_DESC
  • inputs : _NVAPI_D3D12_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_DESC_EX, _NVAPI_D3D12_BUILD_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_DESC, _NVAPI_D3D12_BUILD_RAYTRACING_OPACITY_MICROMAP_ARRAY_DESC
  • inputSampleTime : _NV_LATENCY_RESULT_PARAMS::FrameReport
  • instanceDescs : _NVAPI_D3D12_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_INPUTS_EX
  • inStatus : _NVVIOSTATUS
  • interface_supported_by_sink : _NV_HDR_CAPABILITIES_V2, _NV_HDR_CAPABILITIES_V3
  • interlaced : _NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_V1, _NV_TIMING, NV_DISPLAY_PATH
  • interlacedAudioLatency : _NV_MONITOR_CAPS_VSDB
  • interlacedVideoLatency : _NV_MONITOR_CAPS_VSDB
  • interlaceMode : _NV_GSYNC_CONTROL_PARAMS_V1, _NV_GSYNC_CONTROL_PARAMS_V2, _NVVIOVIDEOMODE
  • InterleavedSampling : _NV_D3D11_FEATURE_DATA_RASTERIZER_SUPPORT
  • InterleavedSamplingEnable : NvAPI_D3D11_RASTERIZER_DESC_EX, NVAPI_D3D12_PSO_RASTERIZER_STATE_DESC_V1
  • interval : _NV_GSYNC_CONTROL_PARAMS_V1, _NV_GSYNC_CONTROL_PARAMS_V2
  • is10BPCSupported : _NV_DISPLAY_PORT_INFO_V1
  • is10BPCSupportedOnCurrentMode : _NV_DISPLAY_PORT_INFO_V1
  • is12BPCSupported : _NV_DISPLAY_PORT_INFO_V1
  • is12BPCSupportedOnCurrentMode : _NV_DISPLAY_PORT_INFO_V1
  • is16BPCSupported : _NV_DISPLAY_PORT_INFO_V1
  • is16BPCSupportedOnCurrentMode : _NV_DISPLAY_PORT_INFO_V1
  • is6BPCSupported : _NV_DISPLAY_PORT_INFO_V1
  • is6BPCSupportedOnCurrentMode : _NV_DISPLAY_PORT_INFO_V1
  • is8BPCSupported : _NV_DISPLAY_PORT_INFO_V1
  • is8BPCSupportedOnCurrentMode : _NV_DISPLAY_PORT_INFO_V1
  • isAcquired : _NV_MANAGED_DEDICATED_DISPLAY_INFO
  • isActive : _NV_GPU_DISPLAYIDS
  • isChromaLpfOff : NV_DISPLAY_PORT_CONFIG
  • isCluster : _NV_GPU_DISPLAYIDS
  • isColorCtrlSupported : _NV_DISPLAY_PORT_INFO_V1
  • isCommandLine : _NVDRS_APPLICATION_V3, _NVDRS_APPLICATION_V4
  • isConnected : _NV_GPU_DISPLAYIDS
  • isCurrentPredefined : _NVDRS_SETTING_V1
  • isDitherOff : NV_DISPLAY_PORT_CONFIG
  • isDolbyVisionSupported : _NV_HDR_CAPABILITIES_V2, _NV_HDR_CAPABILITIES_V3
  • isDp : _NV_DISPLAY_PORT_INFO_V1
  • isDynamic : _NV_GPU_DISPLAYIDS
  • isEdrSupported : _NV_HDR_CAPABILITIES_V1, _NV_HDR_CAPABILITIES_V2, _NV_HDR_CAPABILITIES_V3
  • isEnabled : _NV_LICENSE_FEATURE_DETAILS_V1, _NV_LICENSE_FEATURE_DETAILS_V2, _NV_LICENSE_FEATURE_DETAILS_V3, _NV_LICENSE_FEATURE_DETAILS_V4, NV_GPU_ECC_CONFIGURATION_INFO, NV_GPU_ECC_STATUS_INFO
  • isEnabledByDefault : NV_GPU_ECC_CONFIGURATION_INFO
  • isFeatureEnabled : _NV_LICENSE_FEATURE_DETAILS_V3, _NV_LICENSE_FEATURE_DETAILS_V4
  • isGpuHDMICapable : _NV_HDMI_SUPPORT_INFO_V1, _NV_HDMI_SUPPORT_INFO_V2
  • isHdr10PlusGamingSupported : _NV_HDR_CAPABILITIES_V3
  • isHdr10PlusSupported : _NV_HDR_CAPABILITIES_V3
  • isHPD : NV_DISPLAY_PORT_CONFIG
  • isInterlaced : NV_TIMING_FLAG
  • isInternalDp : _NV_DISPLAY_PORT_INFO_V1
  • isLicenseSupported : _NV_LICENSABLE_FEATURES_V1, _NV_LICENSABLE_FEATURES_V2, _NV_LICENSABLE_FEATURES_V3, _NV_LICENSABLE_FEATURES_V4
  • isMasterable : _NV_GSYNC_DISPLAY
  • isMetro : _NVDRS_APPLICATION_V3, _NVDRS_APPLICATION_V4
  • isMonAdobeRGBCapable : _NV_DISPLAY_PORT_INFO_V1, _NV_HDMI_SUPPORT_INFO_V2
  • isMonAdobeYCC601Capable : _NV_DISPLAY_PORT_INFO_V1, _NV_HDMI_SUPPORT_INFO_V2
  • isMonBasicAudioCapable : _NV_HDMI_SUPPORT_INFO_V1, _NV_HDMI_SUPPORT_INFO_V2
  • isMonBT2020cYCCCapable : _NV_DISPLAY_PORT_INFO_V1
  • isMonBT2020RGBCapable : _NV_DISPLAY_PORT_INFO_V1
  • isMonBT2020YCCCapable : _NV_DISPLAY_PORT_INFO_V1
  • isMonHDMI : _NV_HDMI_SUPPORT_INFO_V1, _NV_HDMI_SUPPORT_INFO_V2
  • isMonsYCC601Capable : _NV_DISPLAY_PORT_INFO_V1, _NV_HDMI_SUPPORT_INFO_V2
  • isMonUnderscanCapable : _NV_HDMI_SUPPORT_INFO_V1, _NV_HDMI_SUPPORT_INFO_V2
  • isMonxvYCC601Capable : _NV_DISPLAY_PORT_INFO_V1, _NV_HDMI_SUPPORT_INFO_V1, _NV_HDMI_SUPPORT_INFO_V2
  • isMonxvYCC709Capable : _NV_DISPLAY_PORT_INFO_V1, _NV_HDMI_SUPPORT_INFO_V1, _NV_HDMI_SUPPORT_INFO_V2
  • isMonYCbCr422Capable : _NV_HDMI_SUPPORT_INFO_V1, _NV_HDMI_SUPPORT_INFO_V2
  • isMonYCbCr444Capable : _NV_HDMI_SUPPORT_INFO_V1, _NV_HDMI_SUPPORT_INFO_V2
  • isMosaic : _NV_MANAGED_DEDICATED_DISPLAY_INFO
  • isMultiStreamRootNode : _NV_GPU_DISPLAYIDS
  • IsNonNVIDIAAdapter : _NV_DISPLAYCONFIG_PATH_INFO_V2
  • IsNull : NV_META_COMMAND_OPTIONAL_ACTIVATION_DESC, NV_META_COMMAND_OPTIONAL_TENSOR_DESC
  • isOSVisible : _NV_GPU_DISPLAYIDS
  • isPhysicallyConnected : _NV_GPU_DISPLAYIDS
  • isPossible : NV_MOSAIC_TOPO_BRIEF
  • isPredefined : _NVDRS_APPLICATION_V1, _NVDRS_APPLICATION_V2, _NVDRS_APPLICATION_V3, _NVDRS_APPLICATION_V4, _NVDRS_PROFILE_V1
  • isPredefinedValid : _NVDRS_SETTING_V1
  • isPreferredUnscaledTarget : _NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_V1
  • isRgb444SupportedOnCurrentMode : _NV_DISPLAY_PORT_INFO_V1
  • isRLACapable : _NV_MONITOR_CAPS_GENERIC
  • isSetDeferred : NV_DISPLAY_PORT_CONFIG
  • isST2084EotfSupported : _NV_HDR_CAPABILITIES_V1, _NV_HDR_CAPABILITIES_V2, _NV_HDR_CAPABILITIES_V3
  • isSupported : NV_GPU_ECC_STATUS_INFO
  • isSynced : _NV_GSYNC_GPU
  • isTraditionalHdrGammaSupported : _NV_HDR_CAPABILITIES_V1, _NV_HDR_CAPABILITIES_V2, _NV_HDR_CAPABILITIES_V3
  • isTraditionalSdrGammaSupported : _NV_HDR_CAPABILITIES_V1, _NV_HDR_CAPABILITIES_V2, _NV_HDR_CAPABILITIES_V3
  • isTrueGsync : _NV_MONITOR_CAPS_GENERIC
  • IsValid() : INvAPI_DirectD3D12GraphicsCommandList
  • isVRReady : _NV_GPU_VR_READY_V1
  • isWFD : _NV_GPU_DISPLAYIDS
  • isYCbCr420SupportedOnCurrentMode : _NV_DISPLAY_PORT_INFO_V1
  • isYCbCr422SupportedOnCurrentMode : _NV_DISPLAY_PORT_INFO_V1
  • isYCbCr444SupportedOnCurrentMode : _NV_DISPLAY_PORT_INFO_V1
  • isYCrCb420Supported : _NV_DISPLAY_PORT_INFO_V1
  • isYCrCb422Supported : _NV_DISPLAY_PORT_INFO_V1
  • isYCrCb444Supported : _NV_DISPLAY_PORT_INFO_V1
  • itContent : NV_INFOFRAME_VIDEO


  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all struct and union fields with links to the structures/unions they belong to:

- j -

  • jack : _NVVIOSTREAM


  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all struct and union fields with links to the structures/unions they belong to:

- k -

  • kernelParams : _NVAPI_CU_KERNEL_LAUNCH_PARAMS_EX
  • keyEnable : NVAPI_ANSEL_CONFIGURATION_STRUCT_V1


  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all struct and union fields with links to the structures/unions they belong to:

- l -

  • laneCount : NV_DISPLAY_PORT_CONFIG
  • lastFlipRefreshCount : _NV_GET_ADAPTIVE_SYNC_DATA_V1
  • lastFlipTimeStamp : _NV_GET_ADAPTIVE_SYNC_DATA_V1
  • launcher : _NVDRS_APPLICATION_V1, _NVDRS_APPLICATION_V2, _NVDRS_APPLICATION_V3, _NVDRS_APPLICATION_V4
  • Layout : NV_META_COMMAND_TENSOR_DESC
  • left : _NV_RECT
  • left_bar : NV_INFOFRAME_VIDEO
  • leftCoeffs : _NV_SMP_ASSIST_UPDATE_INSTANCEDSTEREO_DATA_PARAMS_V1
  • leftConst : _NV_SMP_ASSIST_UPDATE_INSTANCEDSTEREO_DATA_PARAMS_V1
  • length : NV_INFOFRAME_PROPERTY
  • levelShift : NV_INFOFRAME_AUDIO
  • lfePlaybackLevel : NV_INFOFRAME_AUDIO
  • licensableFeatureCount : _NV_LICENSABLE_FEATURES_V1, _NV_LICENSABLE_FEATURES_V2, _NV_LICENSABLE_FEATURES_V3, _NV_LICENSABLE_FEATURES_V4
  • licenseDetails : _NV_LICENSABLE_FEATURES_V1, _NV_LICENSABLE_FEATURES_V2, _NV_LICENSABLE_FEATURES_V3, _NV_LICENSABLE_FEATURES_V4
  • licenseExpiry : _NV_LICENSE_FEATURE_DETAILS_V4
  • licenseInfo : _NV_LICENSE_FEATURE_DETAILS_V1, _NV_LICENSE_FEATURE_DETAILS_V2, _NV_LICENSE_FEATURE_DETAILS_V3, _NV_LICENSE_FEATURE_DETAILS_V4
  • linkID : _NVVIOCHANNELSTATUS
  • linkInfo : NVLINK_GET_STATUS_V1, NVLINK_GET_STATUS_V2
  • linkMask : NVLINK_GET_CAPS_V1, NVLINK_GET_STATUS_V1, NVLINK_GET_STATUS_V2
  • linkRate : NV_DISPLAY_PORT_CONFIG
  • links : _NVVIOSTREAM
  • linkState : NVLINK_LINK_STATUS_INFO_V1, NVLINK_LINK_STATUS_INFO_V2
  • localDeviceInfo : NVLINK_LINK_STATUS_INFO_V2
  • localDeviceLinkNumber : NVLINK_LINK_STATUS_INFO_V2
  • loopProperty : NVLINK_LINK_STATUS_INFO_V1, NVLINK_LINK_STATUS_INFO_V2
  • lowestNciVersion : NVLINK_GET_CAPS_V1
  • lowestNvlinkVersion : NVLINK_GET_CAPS_V1


  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all struct and union fields with links to the structures/unions they belong to:

- m -

  • majorSMVersion : _NV_D3D12_GRAPHICS_CAPS_V1, _NV_D3D1x_GRAPHICS_CAPS_V2
  • majorVersion : _NVVIOCAPS
  • manualColorFixed : _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_COLOR_FIXED
  • manualRGB : _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_RGB
  • manualRGBW : _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_RGBW
  • manualSingleColor : _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_SINGLE_COLOR
  • markerType : _NV_ASYNC_FRAME_MARKER_PARAMS_V1, _NV_LATENCY_MARKER_PARAMS
  • markUavRef : NvShaderExtnStruct
  • mastering_display_data : _NV_HDR_COLOR_DATA_V1, _NV_HDR_COLOR_DATA_V2
  • max : NV_GPU_PERF_PSTATES20_PARAM_DELTA
  • max_content_light_level : _NV_HDR_COLOR_DATA_V1, _NV_HDR_COLOR_DATA_V2, _NV_HDR_METADATA_V1
  • max_display_mastering_luminance : _NV_HDR_COLOR_DATA_V1, _NV_HDR_COLOR_DATA_V2, _NV_HDR_METADATA_V1
  • max_frame_average_light_level : _NV_HDR_COLOR_DATA_V1, _NV_HDR_COLOR_DATA_V2, _NV_HDR_METADATA_V1
  • maxFrameInterval : _NV_GET_ADAPTIVE_SYNC_DATA_V1, _NV_SET_ADAPTIVE_SYNC_DATA_V1
  • maxFreq_kHz : NV_GPU_PSTATE20_CLOCK_ENTRY_V1
  • maxLaneCount : _NV_DISPLAY_PORT_INFO_V1
  • maxLines : _NV_GSYNC_DELAY
  • maxLinkRate : _NV_DISPLAY_PORT_INFO_V1
  • maxMulDivValue : _NV_GSYNC_CAPABILITIES_V3
  • maxNumAFRGroups : NV_GET_CURRENT_SLI_STATE_V1, NV_GET_CURRENT_SLI_STATE_V2
  • maxTmdsClock : _NV_MONITOR_CAPS_VSDB
  • maxVoltage_uV : NV_GPU_PSTATE20_CLOCK_ENTRY_V1
  • mcuv10 : _NV_GPU_CLIENT_ILLUM_DEVICE_INFO_V1
  • MiddleRegionShadingRate : _NV_FOVEATED_RENDERING_CUSTOM_SHADING_RATE_PRESET_DESC_V1
  • min : _NV_LICENSE_EXPIRY_DETAILS, NV_GPU_PERF_PSTATES20_PARAM_DELTA
  • min_display_mastering_luminance : _NV_HDR_COLOR_DATA_V1, _NV_HDR_COLOR_DATA_V2, _NV_HDR_METADATA_V1
  • minFreq_kHz : NV_GPU_PSTATE20_CLOCK_ENTRY_V1
  • minimumIntervalUs : _NV_SET_SLEEP_MODE_PARAMS
  • minorSMVersion : _NV_D3D12_GRAPHICS_CAPS_V1, _NV_D3D1x_GRAPHICS_CAPS_V2
  • minorVersion : _NVVIOCAPS
  • minPixels : _NV_GSYNC_DELAY
  • minVoltage_uV : NV_GPU_PSTATE20_CLOCK_ENTRY_V1
  • MipSlice : _NV_TEX2D_ARRAY_SRRV, _NV_TEX2D_SRRV
  • mode : NV_INFOFRAME_PROPERTY
  • Mode : NV_META_COMMAND_CREATE_CONVOLUTION_EX_DESC, NV_META_COMMAND_PADDING_DESC
  • modifiedWCoefficients : _NV_MODIFIED_W_PARAMS
  • month : _NV_LICENSE_EXPIRY_DETAILS
  • multiGPUVersion : _NV_MULTIGPU_CAPS_V1, _NV_MULTIGPU_CAPS_V2
  • multiplyDivideMode : _NV_GSYNC_CONTROL_PARAMS_V2
  • multiplyDivideValue : _NV_GSYNC_CONTROL_PARAMS_V2
  • MultisampleEnable : NvAPI_D3D11_RASTERIZER_DESC_EX
  • mvolt : NV_GPU_PERF_PSTATES_INFO_V2


  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all struct and union fields with links to the structures/unions they belong to:

- n -

  • name : _NV_MANAGED_DEDICATED_DISPLAY_METADATA
  • Name : NVAPI_META_COMMAND_DESC
  • name : tagNV_TIMINGEXT
  • nciVersion : NVLINK_LINK_STATUS_INFO_V1, NVLINK_LINK_STATUS_INFO_V2
  • NDCSplitsX : _NV_SMP_ASSIST_FASTGSCBDATA_MRS_INSTANCED_STEREO_V1, _NV_SMP_ASSIST_FASTGSCBDATA_V1
  • NDCSplitsY : _NV_SMP_ASSIST_FASTGSCBDATA_MRS_INSTANCED_STEREO_V1, _NV_SMP_ASSIST_FASTGSCBDATA_V1
  • nextFrameAFRIndex : NV_GET_CURRENT_SLI_STATE_V1, NV_GET_CURRENT_SLI_STATE_V2
  • nonuniformScaling : NV_INFOFRAME_VIDEO
  • nSLIGPUs : _NV_MULTIGPU_CAPS_V1, _NV_MULTIGPU_CAPS_V2
  • nTotalGPUs : _NV_MULTIGPU_CAPS_V1, _NV_MULTIGPU_CAPS_V2
  • numAFRGroups : NV_GET_CURRENT_SLI_STATE_V1, NV_GET_CURRENT_SLI_STATE_V2
  • numAnselFeatures : NVAPI_ANSEL_CONFIGURATION_STRUCT_V1
  • numBaseVoltages : _NV_GPU_PERF_PSTATES20_INFO_V2, NV_GPU_PERF_PSTATES20_INFO_V1
  • numBuffers : _NV_D3D_LATELATCH_OBJECT_DESC_V1
  • numClocks : _NV_GPU_PERF_PSTATES20_INFO_V2, NV_GPU_PERF_PSTATES20_INFO_V1, NV_GPU_PERF_PSTATES_INFO_V1, NV_GPU_PERF_PSTATES_INFO_V2
  • NumCustomSemantics : NvAPI_D3D11_CREATE_DOMAIN_SHADER_EX_V1, NvAPI_D3D11_CREATE_DOMAIN_SHADER_EX_V2, NvAPI_D3D11_CREATE_DOMAIN_SHADER_EX_V3, NvAPI_D3D11_CREATE_GEOMETRY_SHADER_EX_V5, NvAPI_D3D11_CREATE_HULL_SHADER_EX_V1, NvAPI_D3D11_CREATE_HULL_SHADER_EX_V2, NvAPI_D3D11_CREATE_PIXEL_SHADER_EX_V1, NvAPI_D3D11_CREATE_PIXEL_SHADER_EX_V2, NvAPI_D3D11_CREATE_VERTEX_SHADER_EX_V1, NvAPI_D3D11_CREATE_VERTEX_SHADER_EX_V2, NvAPI_D3D11_CREATE_VERTEX_SHADER_EX_V3, NVAPI_D3D12_PSO_DOMAIN_SHADER_DESC_V1, NVAPI_D3D12_PSO_GEOMETRY_SHADER_DESC_V5, NVAPI_D3D12_PSO_HULL_SHADER_DESC_V1, NVAPI_D3D12_PSO_VERTEX_SHADER_DESC_V1
  • numDescs : _NVAPI_D3D12_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_INPUTS_EX
  • numDMMUsageCounts : _NVAPI_D3D12_BUILD_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_INPUTS, _NVAPI_D3D12_RAYTRACING_GEOMETRY_DMM_ATTACHMENT_DESC
  • numEntries : _NV_MODIFIED_W_PARAMS
  • numIllumDevices : _NV_GPU_CLIENT_ILLUM_DEVICE_INFO_PARAMS_V1, NV_GPU_CLIENT_ILLUM_DEVICE_CONTROL_PARAMS_V1
  • numIllumZones : _NV_GPU_CLIENT_ILLUM_ZONE_INFO_PARAMS_V1
  • numIllumZonesControl : _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_PARAMS_V1
  • numLines : _NV_GSYNC_DELAY
  • numLinks : _NVVIOSTREAM
  • numOfApps : _NVDRS_PROFILE_V1
  • numOfSettings : _NVDRS_PROFILE_V1
  • numOMMUsageCounts : _NVAPI_D3D12_BUILD_RAYTRACING_OPACITY_MICROMAP_ARRAY_INPUTS, _NVAPI_D3D12_RAYTRACING_GEOMETRY_OMM_ATTACHMENT_DESC
  • numOutputsForIncCounter : NvShaderExtnStruct
  • numPixels : _NV_GSYNC_DELAY
  • numPostbuildInfoDescs : _NVAPI_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_EX_PARAMS_V1, _NVAPI_BUILD_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PARAMS_V1, _NVAPI_BUILD_RAYTRACING_OPACITY_MICROMAP_ARRAY_PARAMS_V1
  • numPstates : _NV_GPU_PERF_PSTATES20_INFO_V2, NV_GPU_PERF_PSTATES20_INFO_V1, NV_GPU_PERF_PSTATES_INFO_V1, NV_GPU_PERF_PSTATES_INFO_V2
  • numRawCaptureImages : _NVVIOINPUTCONFIG
  • numRects : _NV_D3D11_EXCLUSIVE_SCISSOR_RECTS_DESC_V1
  • numSettingValues : _NVDRS_SETTING_VALUES, _SettingDWORDNameString, _SettingWSTRINGNameString
  • numSources : _NVAPI_EMIT_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_POSTBUILD_INFO_PARAMS_V1, _NVAPI_EMIT_RAYTRACING_OPACITY_MICROMAP_ARRAY_POSTBUILD_INFO_PARAMS_V1
  • numStreams : _NVVIOINPUTCONFIG
  • numUtils : _NV_GPU_CLIENT_CALLBACK_UTILIZATION_DATA_V1
  • numVertices : NV_SCANOUT_WARPING_DATA
  • numViewports : _NV_CUSTOM_RECTS_V1, _NV_D3D11_VIEWPORTS_SHADING_RATE_DESC_V1, _NV_SMP_ASSIST_GET_CONSTANTS_V3
  • numViews : _NV_MULTIVIEW_PARAMS_V1
  • numVoltages : _NV_GPU_PERF_PSTATES20_INFO_V2, NV_GPU_PERF_PSTATES_INFO_V2
  • numVRSLIGpus : NV_GET_CURRENT_SLI_STATE_V2
  • nvCallBackFunc : NV_EVENT_REGISTER_CALLBACK
  • NVCustomSemanticNameString : _NV_CUSTOM_SEMANTIC
  • NVCustomSemanticType : _NV_CUSTOM_SEMANTIC
  • NVHeapFlags : _NV_HEAP_PARAMS_V1
  • nvlinkCommonClockSpeedMhz : NVLINK_LINK_STATUS_INFO_V1, NVLINK_LINK_STATUS_INFO_V2
  • nvlinkLineRateMbps : NVLINK_LINK_STATUS_INFO_V2
  • nvlinkLinkClockMhz : NVLINK_LINK_STATUS_INFO_V1, NVLINK_LINK_STATUS_INFO_V2
  • NvLinkPresent : _NV_MULTIGPU_CAPS_V2
  • nvlinkRefClkSpeedMhz : NVLINK_LINK_STATUS_INFO_V1, NVLINK_LINK_STATUS_INFO_V2
  • nvlinkRefClkType : NVLINK_LINK_STATUS_INFO_V1, NVLINK_LINK_STATUS_INFO_V2
  • nvlinkVersion : NVLINK_LINK_STATUS_INFO_V1, NVLINK_LINK_STATUS_INFO_V2
  • nvPsfId : NV_TIMING_FLAG
  • nvQSYNCEventCallback : NV_EVENT_REGISTER_CALLBACK
  • NVResourceFlags : _NV_RESOURCE_PARAMS_V1
  • nvs : _NVDRS_GPU_SUPPORT
  • nvvioConfigType : _NVVIOCONFIG_V1, _NVVIOCONFIG_V2, _NVVIOCONFIG_V3
  • nvvioStatusType : _NVVIOSTATUS


  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all struct and union fields with links to the structures/unions they belong to:

- o -

  • Offset : NV_D3D11_META_COMMAND_RESOURCE
  • offset : NV_EDID_V3
  • OffsetRtIndexByVpIndex : NvAPI_D3D11_CREATE_GEOMETRY_SHADER_EX_V5, NVAPI_D3D12_PSO_GEOMETRY_SHADER_DESC_V5
  • offsetTexChannels : NV_SCANOUT_INTENSITY_DATA_V2
  • offsetTexture : NV_SCANOUT_INTENSITY_DATA_V2
  • ommAttachment : _NVAPI_D3D12_RAYTRACING_GEOMETRY_OMM_TRIANGLES_DESC
  • ommTriangles : _NVAPI_D3D12_RAYTRACING_GEOMETRY_DESC_EX
  • opacityMicromapArray : _NVAPI_D3D12_RAYTRACING_GEOMETRY_OMM_ATTACHMENT_DESC, _NVAPI_RELOCATE_RAYTRACING_OPACITY_MICROMAP_ARRAY_PARAMS_V1
  • opacityMicromapBaseLocation : _NVAPI_D3D12_RAYTRACING_GEOMETRY_OMM_ATTACHMENT_DESC
  • opacityMicromapIndexBuffer : _NVAPI_D3D12_RAYTRACING_GEOMETRY_OMM_ATTACHMENT_DESC
  • opacityMicromapIndexFormat : _NVAPI_D3D12_RAYTRACING_GEOMETRY_OMM_ATTACHMENT_DESC
  • opcode : NvShaderExtnStruct
  • osRenderQueueEndTime : _NV_LATENCY_RESULT_PARAMS::FrameReport
  • osRenderQueueStartTime : _NV_LATENCY_RESULT_PARAMS::FrameReport
  • outConfig : _NVVIOCONFIG_V1, _NVVIOCONFIG_V2, _NVVIOCONFIG_V3
  • outFlags : NVAPI_UAV_INFO_V2
  • outputArea : _NVVIOOUTPUTCONFIG_V1, _NVVIOOUTPUTCONFIG_V2, _NVVIOOUTPUTCONFIG_V3
  • outputId : NVVIOTOPOLOGYTARGET
  • OutputPrepool : NV_META_COMMAND_CONVOLUTION_FUSE_DESC
  • outputRegion : _NVVIOOUTPUTCONFIG_V1, _NVVIOOUTPUTCONFIG_V2, _NVVIOOUTPUTCONFIG_V3
  • OutputResource : NV_D3D11_META_COMMAND_EXECUTE_CONVOLUTION_EX_DESC, NV_D3D11_META_COMMAND_EXECUTE_GEMM_DESC, NV_D3D12_META_COMMAND_EXECUTE_CONVOLUTION_EX_DESC, NV_D3D12_META_COMMAND_EXECUTE_GEMM_DESC
  • outputVideoLocked : _NVVIOOUTPUTSTATUS
  • outStatus : _NVVIOSTATUS
  • ov : _NV_GPU_PERF_PSTATES20_INFO_V2
  • overlapX : _NV_MOSAIC_GRID_TOPO_DISPLAY_V1, _NV_MOSAIC_GRID_TOPO_DISPLAY_V2, NV_MOSAIC_TOPO_DETAILS, NV_MOSAIC_TOPOLOGY
  • overlapY : _NV_MOSAIC_GRID_TOPO_DISPLAY_V1, _NV_MOSAIC_GRID_TOPO_DISPLAY_V2, NV_MOSAIC_TOPO_DETAILS, NV_MOSAIC_TOPOLOGY
  • ownerId : _NVVIOCAPS
  • ownerType : _NVVIOCAPS


  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all struct and union fields with links to the structures/unions they belong to:

- p -

  • Padding : _NV_SMP_ASSIST_REMAPCBDATA_V1, NV_META_COMMAND_CREATE_CONVOLUTION_EX_DESC
  • padding1 : NvShaderExtnStruct
  • pAnselFeatures : NVAPI_ANSEL_CONFIGURATION_STRUCT_V1
  • Params : NV_META_COMMAND_ACTIVATION_DESC
  • paramSize : _NVAPI_CU_KERNEL_LAUNCH_PARAMS, _NVAPI_CU_KERNEL_LAUNCH_PARAMS_EX
  • parity : _NV_HDR_CAPABILITIES_V3
  • path : NV_DISPLAY_PATH_INFO, NV_DISPLAY_PATH_INFO_V3
  • pbData : NV_I2C_INFO_V1, NV_I2C_INFO_V2, NV_I2C_INFO_V3
  • pbI2cRegAddress : NV_I2C_INFO_V1, NV_I2C_INFO_V2, NV_I2C_INFO_V3
  • pCallbackParam : _NV_CLIENT_CALLBACK_SETTINGS_SUPER_V1, _NV_GPU_CLIENT_CALLBACK_DATA_SUPER_V1
  • pciBus : _NVVIOPCIINFO
  • pciDeviceId : _NVVIOPCIINFO, NVLINK_DEVICE_INFO_V1
  • pciDomain : _NVVIOPCIINFO
  • pciLinkRate : _NVVIOPCIINFO
  • pciLinkWidth : _NVVIOPCIINFO
  • pciRevisionId : _NVVIOPCIINFO
  • pciSlot : _NVVIOPCIINFO
  • pciSubSystemId : _NVVIOPCIINFO
  • pclk : _NV_TIMING
  • pCoordinateSwizzling : NvAPI_D3D11_CREATE_FASTGS_EXPLICIT_DESC_V1, NvAPI_D3D11_CREATE_GEOMETRY_SHADER_EX_V5, NVAPI_D3D12_PSO_CREATE_FASTGS_EXPLICIT_DESC_V1, NVAPI_D3D12_PSO_GEOMETRY_SHADER_DESC_V5
  • pCubin : NVAPI_D3D12_CREATE_CUBIN_SHADER_PARAMS
  • pCustomSemantics : NvAPI_D3D11_CREATE_DOMAIN_SHADER_EX_V1, NvAPI_D3D11_CREATE_DOMAIN_SHADER_EX_V2, NvAPI_D3D11_CREATE_DOMAIN_SHADER_EX_V3, NvAPI_D3D11_CREATE_GEOMETRY_SHADER_EX_V5, NvAPI_D3D11_CREATE_HULL_SHADER_EX_V1, NvAPI_D3D11_CREATE_HULL_SHADER_EX_V2, NvAPI_D3D11_CREATE_PIXEL_SHADER_EX_V1, NvAPI_D3D11_CREATE_PIXEL_SHADER_EX_V2, NvAPI_D3D11_CREATE_VERTEX_SHADER_EX_V1, NvAPI_D3D11_CREATE_VERTEX_SHADER_EX_V2, NvAPI_D3D11_CREATE_VERTEX_SHADER_EX_V3, NVAPI_D3D12_PSO_DOMAIN_SHADER_DESC_V1, NVAPI_D3D12_PSO_GEOMETRY_SHADER_DESC_V5, NVAPI_D3D12_PSO_HULL_SHADER_DESC_V1, NVAPI_D3D12_PSO_VERTEX_SHADER_DESC_V1
  • pDesc : _NVAPI_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_EX_PARAMS_V1, _NVAPI_BUILD_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PARAMS_V1, _NVAPI_BUILD_RAYTRACING_OPACITY_MICROMAP_ARRAY_PARAMS_V1, _NVAPI_EMIT_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_POSTBUILD_INFO_PARAMS_V1, _NVAPI_EMIT_RAYTRACING_OPACITY_MICROMAP_ARRAY_POSTBUILD_INFO_PARAMS_V1, _NVAPI_GET_RAYTRACING_ACCELERATION_STRUCTURE_PREBUILD_INFO_EX_PARAMS_V1, _NVAPI_GET_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PREBUILD_INFO_PARAMS_V1, _NVAPI_GET_RAYTRACING_OPACITY_MICROMAP_ARRAY_PREBUILD_INFO_PARAMS_V1
  • pDevice : _NV_D3D12_MOSAIC_GETCOMPANIONALLOCATIONS, _NV_D3D12_MOSAIC_GETVIEWPORTANDGPUPARTITIONS, NVAPI_D3D12_CREATE_CUBIN_SHADER_PARAMS, NVAPI_D3D12_GET_CUDA_INDEPENDENT_DESCRIPTOR_OBJECT_PARAMS, NVAPI_D3D12_GET_CUDA_MERGED_TEXTURE_SAMPLER_OBJECT_PARAMS
  • pDMMUsageCounts : _NVAPI_D3D12_BUILD_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_INPUTS, _NVAPI_D3D12_RAYTRACING_GEOMETRY_DMM_ATTACHMENT_DESC
  • peak_luminance_index : _NV_HDR_CAPABILITIES_V3
  • pEDID : _NV_EDID_DATA_V1, _NV_EDID_DATA_V2
  • percentage : NV_GPU_DYNAMIC_PSTATES_INFO_EX
  • PerChannelScaling : NV_META_COMMAND_CREATE_CONVOLUTION_EX_DESC
  • perDMMDescs : _NVAPI_D3D12_BUILD_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_INPUTS
  • PeripheralRegionShadingRate : _NV_FOVEATED_RENDERING_CUSTOM_SHADING_RATE_PRESET_DESC_V1
  • perOMMDescs : _NVAPI_D3D12_BUILD_RAYTRACING_OPACITY_MICROMAP_ARRAY_INPUTS
  • PersistentResource : NV_D3D11_META_COMMAND_EXECUTE_CONVOLUTION_EX_DESC, NV_D3D11_META_COMMAND_EXECUTE_GEMM_DESC, NV_D3D11_META_COMMAND_INITIALIZE_CONVOLUTION_EX_DESC, NV_D3D11_META_COMMAND_INITIALIZE_GEMM_DESC, NV_D3D12_META_COMMAND_EXECUTE_CONVOLUTION_EX_DESC, NV_D3D12_META_COMMAND_EXECUTE_GEMM_DESC, NV_D3D12_META_COMMAND_INITIALIZE_CONVOLUTION_EX_DESC, NV_D3D12_META_COMMAND_INITIALIZE_GEMM_DESC
  • pFastGSCBData : _NV_SMP_ASSIST_GET_CONSTANTS_V3
  • pFastGSCBDataMRS_IS : _NV_SMP_ASSIST_GET_CONSTANTS_V3
  • pGeometryDescs : _NVAPI_D3D12_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_INPUTS_EX
  • phaseOffsetms : _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR
  • physicalGpuCount : _NV_LOGICAL_GPU_DATA_V1
  • physicalGpuHandles : _NV_LOGICAL_GPU_DATA_V1
  • phyType : NVLINK_LINK_STATUS_INFO_V1, NVLINK_LINK_STATUS_INFO_V2
  • phyVersion : NVLINK_LINK_STATUS_INFO_V1, NVLINK_LINK_STATUS_INFO_V2
  • picAspectRatio : NV_INFOFRAME_VIDEO
  • pIdentifierToCheck : _NVAPI_CHECK_DRIVER_MATCHING_IDENTIFIER_EX_PARAMS_V1
  • piecewiseLinearColorFixed : _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_COLOR_FIXED
  • piecewiseLinearData : _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR_COLOR_FIXED, _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR_RGB, _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR_RGBW, _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR_SINGLE_COLOR
  • piecewiseLinearRGB : _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_RGB
  • piecewiseLinearRGBW : _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_RGBW
  • piecewiseLinearSingleColor : _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_SINGLE_COLOR
  • pInfo : _NVAPI_GET_RAYTRACING_ACCELERATION_STRUCTURE_PREBUILD_INFO_EX_PARAMS_V1, _NVAPI_GET_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PREBUILD_INFO_PARAMS_V1, _NVAPI_GET_RAYTRACING_OPACITY_MICROMAP_ARRAY_PREBUILD_INFO_PARAMS_V1
  • Pixel_1x2 : _NV_PIXEL_SHADING_RATE_SAMPLE_ORDER_TABLE_V1
  • Pixel_2x1 : _NV_PIXEL_SHADING_RATE_SAMPLE_ORDER_TABLE_V1
  • Pixel_2x2 : _NV_PIXEL_SHADING_RATE_SAMPLE_ORDER_TABLE_V1
  • Pixel_2x4 : _NV_PIXEL_SHADING_RATE_SAMPLE_ORDER_TABLE_V1
  • Pixel_4x2 : _NV_PIXEL_SHADING_RATE_SAMPLE_ORDER_TABLE_V1
  • Pixel_4x4 : _NV_PIXEL_SHADING_RATE_SAMPLE_ORDER_TABLE_V1
  • pixelRepeat : NV_INFOFRAME_VIDEO
  • pixelShift : _NV_MOSAIC_GRID_TOPO_V2
  • pixelShiftType : _NV_MOSAIC_GRID_TOPO_DISPLAY_V2
  • pNodeMask : _NV_D3D12_MOSAIC_GETVIEWPORTANDGPUPARTITIONS
  • polarity : _NV_GSYNC_CONTROL_PARAMS_V1, _NV_GSYNC_CONTROL_PARAMS_V2
  • pOMMUsageCounts : _NVAPI_D3D12_BUILD_RAYTRACING_OPACITY_MICROMAP_ARRAY_INPUTS, _NVAPI_D3D12_RAYTRACING_GEOMETRY_OMM_ATTACHMENT_DESC
  • PoolMode : NV_META_COMMAND_CONVOLUTION_FUSE_DESC
  • portId : NV_I2C_INFO_V3
  • pOSAdapterID : _NV_DISPLAYCONFIG_PATH_INFO_V2
  • pOSAdapterId : _NV_LOGICAL_GPU_DATA_V1
  • position : _NV_DISPLAYCONFIG_SOURCE_MODE_INFO_V1
  • positionX : _NV_MANAGED_DEDICATED_DISPLAY_METADATA
  • positionY : _NV_MANAGED_DEDICATED_DISPLAY_METADATA
  • PostZCoverage : _NV_D3D11_FEATURE_DATA_RASTERIZER_SUPPORT
  • PostZCoverageEnable : NvAPI_D3D11_RASTERIZER_DESC_EX, NVAPI_D3D12_PSO_RASTERIZER_STATE_DESC_V1
  • posx : NV_DISPLAY_PATH
  • posy : NV_DISPLAY_PATH
  • pParams : _NVAPI_CU_KERNEL_LAUNCH_PARAMS, _NVAPI_CU_KERNEL_LAUNCH_PARAMS_EX
  • pPartitionCount : _NV_D3D12_MOSAIC_GETVIEWPORTANDGPUPARTITIONS
  • ppBufferDesc : _NV_D3D_LATELATCH_OBJECT_DESC_V1
  • ppCompanionResources : _NV_D3D12_MOSAIC_GETCOMPANIONALLOCATIONS
  • ppD3DLateLatchObject : _NV_D3D_LATELATCH_OBJECT_DESC_V1
  • ppD3DNvSMPAssist : _NV_SMP_ASSIST_INITIALIZE_PARAMS_V1
  • ppGeometryDescs : _NVAPI_D3D12_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_INPUTS_EX
  • ppNvGazeHandler : _NV_GAZE_HANDLER_INIT_PARAMS_V1, _NV_GAZE_HANDLER_INIT_PARAMS_V2
  • pPostbuildInfoDescs : _NVAPI_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_EX_PARAMS_V1, _NVAPI_BUILD_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PARAMS_V1, _NVAPI_BUILD_RAYTRACING_OPACITY_MICROMAP_ARRAY_PARAMS_V1
  • ppShadingRateResource : _NV_VRS_HELPER_GET_SHADING_RATE_RESOURCE_PARAMS_V1
  • ppVRSHelper : _NV_VRS_HELPER_INIT_PARAMS_V1
  • Precision : NV_META_COMMAND_CREATE_CONVOLUTION_EX_DESC, NV_META_COMMAND_CREATE_GEMM_DESC
  • pRects : _NV_D3D11_EXCLUSIVE_SCISSOR_RECTS_DESC_V1
  • pRemapCBData : _NV_SMP_ASSIST_GET_CONSTANTS_V3
  • PresentCount : _NV_PRESENT_BARRIER_FRAME_STATISTICS
  • presentEndTime : _NV_LATENCY_RESULT_PARAMS::FrameReport
  • presentFrameID : _NV_ASYNC_FRAME_MARKER_PARAMS_V1
  • PresentInSyncCount : _NV_PRESENT_BARRIER_FRAME_STATISTICS
  • presentStartTime : _NV_LATENCY_RESULT_PARAMS::FrameReport
  • previousFrameAFRIndex : NV_GET_CURRENT_SLI_STATE_V1, NV_GET_CURRENT_SLI_STATE_V2
  • primary : _NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_V1
  • productName : _NV_LICENSE_FEATURE_DETAILS_V2, _NV_LICENSE_FEATURE_DETAILS_V3, _NV_LICENSE_FEATURE_DETAILS_V4
  • profileName : _NVDRS_PROFILE_V1
  • ProgrammableSamplePositions : _NV_D3D11_FEATURE_DATA_RASTERIZER_SUPPORT
  • ProgrammableSamplePositionsEnable : NvAPI_D3D11_RASTERIZER_DESC_EX, NVAPI_D3D12_PSO_RASTERIZER_STATE_DESC_V1
  • projectionSizeHeight : _NV_SMP_ASSIST_GET_CONSTANTS_V3
  • projectionSizeWidth : _NV_SMP_ASSIST_GET_CONSTANTS_V3
  • property : NV_INFOFRAME_DATA
  • provIdx : _NV_GPU_CLIENT_ILLUM_ZONE_INFO_V1
  • pScissors : _NV_CUSTOM_RECTS_V1, _NV_SMP_ASSIST_GET_CONSTANTS_V3
  • psfSignalFormat : _NVVIOOUTPUTCONFIG_V1, _NVVIOOUTPUTCONFIG_V2, _NVVIOOUTPUTCONFIG_V3
  • pShaderName : NVAPI_D3D12_CREATE_CUBIN_SHADER_PARAMS
  • psoExtension : NVAPI_D3D12_PSO_EXTENSION_DESC_V1
  • pSources : _NVAPI_EMIT_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_POSTBUILD_INFO_PARAMS_V1, _NVAPI_EMIT_RAYTRACING_OPACITY_MICROMAP_ARRAY_POSTBUILD_INFO_PARAMS_V1
  • pstateId : _NV_GPU_PERF_PSTATES20_INFO_V2, NV_GPU_PERF_PSTATES20_INFO_V1, NV_GPU_PERF_PSTATES_INFO_V1, NV_GPU_PERF_PSTATES_INFO_V2
  • pstates : _NV_GPU_PERF_PSTATES20_INFO_V2, NV_GPU_PERF_PSTATES20_INFO_V1, NV_GPU_PERF_PSTATES_INFO_V1, NV_GPU_PERF_PSTATES_INFO_V2
  • pSwapChainBuffer : _NV_D3D12_MOSAIC_GETCOMPANIONALLOCATIONS, _NV_D3D12_MOSAIC_GETVIEWPORTANDGPUPARTITIONS
  • pViewport : _NV_D3D12_MOSAIC_GETVIEWPORTANDGPUPARTITIONS
  • pViewports : _NV_CUSTOM_RECTS_V1, _NV_D3D11_VIEWPORTS_SHADING_RATE_DESC_V1, _NV_SMP_ASSIST_GET_CONSTANTS_V3


  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all struct and union fields with links to the structures/unions they belong to:

- q -

  • qsyncEvent : NV_QSYNC_EVENT_DATA
  • QuadFillMode : NvAPI_D3D11_RASTERIZER_DESC_EX, NVAPI_D3D12_PSO_RASTERIZER_STATE_DESC_V1
  • quadro : _NVDRS_GPU_SUPPORT
  • quantizationRangeRgb : _NV_MONITOR_CAPS_VCDB
  • quantizationRangeYcc : _NV_MONITOR_CAPS_VCDB


  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all struct and union fields with links to the structures/unions they belong to:

- r -

  • range : NV_GPU_PSTATE20_CLOCK_ENTRY_V1
  • rayTracingCores : _NV_GPU_INFO_V2
  • rdmaHeapSize : _NV_D3D12_WORKSTATION_FEATURE_RDMA_PROPERTIES
  • rdmaInfo : _NV_D3D12_WORKSTATION_FEATURE_PROPERTIES
  • RefreshCount : _NV_PRESENT_BARRIER_FRAME_STATISTICS
  • refreshRate : _NV_GSYNC_STATUS_PARAMS_V1, _NV_GSYNC_STATUS_PARAMS_V2, NV_DISPLAY_PATH
  • refreshRate1K : _NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_V1
  • regAddrSize : NV_I2C_INFO_V1, NV_I2C_INFO_V2, NV_I2C_INFO_V3
  • RegisterMask : _NV_CUSTOM_SEMANTIC
  • RegisterNum : _NV_CUSTOM_SEMANTIC
  • registerSpace : NVAPI_D3D12_PSO_SET_SHADER_EXTENSION_SLOT_DESC_V1
  • RegisterSpecified : _NV_CUSTOM_SEMANTIC
  • relativeSizeDown : _NV_LMS_CUSTOM_CONFIG_V1
  • relativeSizeLeft : _NV_LMS_CUSTOM_CONFIG_V1
  • relativeSizeRight : _NV_LMS_CUSTOM_CONFIG_V1
  • relativeSizeUp : _NV_LMS_CUSTOM_CONFIG_V1
  • remoteDeviceInfo : NVLINK_LINK_STATUS_INFO_V1, NVLINK_LINK_STATUS_INFO_V2
  • remoteDeviceLinkNumber : NVLINK_LINK_STATUS_INFO_V1, NVLINK_LINK_STATUS_INFO_V2
  • RenderMode : _NV_VRS_HELPER_ENABLE_PARAMS_V1
  • renderSubmitEndTime : _NV_LATENCY_RESULT_PARAMS::FrameReport
  • renderSubmitStartTime : _NV_LATENCY_RESULT_PARAMS::FrameReport
  • renderTargetIndexOffset : _NV_MULTIVIEW_PARAMS_V1
  • rep : tagNV_TIMINGEXT
  • Reserved : _NV_CUSTOM_SEMANTIC
  • reserved : _NV_D3D12_GRAPHICS_CAPS_V1, _NV_D3D1x_GRAPHICS_CAPS_V1, _NV_D3D1x_GRAPHICS_CAPS_V2, _NV_DISPLAY_DRIVER_INFO, _NV_DISPLAY_DRIVER_INFO_V2, _NV_DISPLAY_PORT_INFO_V1, _NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_V1, _NV_DISPLAYCONFIG_PATH_INFO_V2, _NV_DISPLAYCONFIG_SOURCE_MODE_INFO_V1, _NV_EDID_DATA_V2, _NV_GET_ADAPTIVE_SYNC_DATA_V1, _NV_GET_VRR_INFO_V1, _NV_GPU_DISPLAYIDS, _NV_GPU_GSP_INFO_V1, _NV_GPU_INFO_V1, _NV_GPU_PERF_PSTATES20_INFO_V2, _NV_GPU_VIRTUALIZATION_INFO, _NV_GPU_VR_READY_V1, _NV_GSYNC_CAPABILITIES_V3, _NV_GSYNC_CONTROL_PARAMS_V1, _NV_GSYNC_CONTROL_PARAMS_V2, _NV_GSYNC_DISPLAY, _NV_GSYNC_GPU, _NV_GSYNC_STATUS_PARAMS_V2, _NV_HDMI_SUPPORT_INFO_V1, _NV_HDMI_SUPPORT_INFO_V2, _NV_HDR_CAPABILITIES_V1, _NV_HDR_CAPABILITIES_V2, _NV_HDR_CAPABILITIES_V3, _NV_LICENSABLE_FEATURES_V1, _NV_LICENSABLE_FEATURES_V2, _NV_LICENSABLE_FEATURES_V3, _NV_LICENSABLE_FEATURES_V4, _NV_LICENSE_FEATURE_DETAILS_V1, _NV_LICENSE_FEATURE_DETAILS_V2, _NV_LICENSE_FEATURE_DETAILS_V3, _NV_LICENSE_FEATURE_DETAILS_V4, _NV_LOGICAL_GPU_DATA_V1, _NV_LOGICAL_GPU_HANDLE_DATA, _NV_LOGICAL_GPUS, _NV_MANAGED_DEDICATED_DISPLAY_INFO, _NV_MANAGED_DEDICATED_DISPLAY_METADATA, _NV_MODIFIED_W_PARAMS, _NV_MONITOR_CAPS_GENERIC, _NV_MOSAIC_GRID_TOPO_V1, _NV_MOSAIC_GRID_TOPO_V2, _NV_MULTIGPU_CAPS_V1, _NV_MULTIGPU_CAPS_V2, _NV_PHYSICAL_GPUS, _NV_QUERY_MULTIVIEW_SUPPORT_PARAMS_V1, _NV_QUERY_SINGLE_PASS_STEREO_SUPPORT_PARAMS_V2, _NV_SET_ADAPTIVE_SYNC_DATA_V1
  • Reserved : _NV_SMP_ASSIST_DISABLE_PARAMS_V1
  • reserved : _NV_VRS_HELPER_DISABLE_PARAMS_V1, _NV_VRS_HELPER_PURGE_INTERNAL_RESOURCES_PARAMS_V1, _NVAPI_STEREO_CAPS, _NVDRS_APPLICATION_V3, _NVDRS_APPLICATION_V4, NV_GET_PREFERRED_STEREO_DISPLAY_V1, NV_GPU_CLOCK_FREQUENCIES_V1, NV_GPU_CLOCK_FREQUENCIES_V2, NV_GPU_PERF_PSTATES20_INFO_V1, NV_GPU_PSTATE20_BASE_VOLTAGE_ENTRY_V1, NV_GPU_PSTATE20_CLOCK_ENTRY_V1, NV_INFOFRAME_PROPERTY, NV_MOSAIC_DISPLAY_TOPO_STATUS, NV_QSYNC_EVENT_DATA, NV_SET_PREFERRED_STEREO_DISPLAY_V1, NvAPI_D3D11_CREATE_PIXEL_SHADER_EX_V2, NvAPI_D3D11_RASTERIZER_DESC_EX, NVAPI_D3D12_PSO_RASTERIZER_STATE_DESC_V1, NVLINK_LINK_STATUS_INFO_V1, NVLINK_LINK_STATUS_INFO_V2
  • reserved0 : _NV_GPU_INFO_V2, NV_TIMING_FLAG
  • reserved1 : _NV_GPU_INFO_V2, NV_GPU_CLOCK_FREQUENCIES_V2
  • reserved10 : _NVDRS_GPU_SUPPORT
  • reserved11 : _NVDRS_GPU_SUPPORT
  • reserved12 : _NVDRS_GPU_SUPPORT
  • reserved13 : _NV_MONITOR_CAPS_VSDB, _NVDRS_GPU_SUPPORT
  • reserved14 : _NVDRS_GPU_SUPPORT
  • reserved15 : _NVDRS_GPU_SUPPORT
  • reserved16 : _NVDRS_GPU_SUPPORT
  • reserved17 : _NVDRS_GPU_SUPPORT
  • reserved18 : _NVDRS_GPU_SUPPORT
  • reserved19 : _NVDRS_GPU_SUPPORT
  • reserved2 : _NV_GPU_INFO_V2, _NV_PHYSICAL_GPU_HANDLE_DATA, _NVAPI_STEREO_CAPS
  • reserved20 : _NVDRS_GPU_SUPPORT
  • reserved21 : _NVDRS_GPU_SUPPORT
  • reserved22 : _NVDRS_GPU_SUPPORT
  • reserved23 : _NVDRS_GPU_SUPPORT
  • reserved24 : _NVDRS_GPU_SUPPORT
  • reserved25 : _NVDRS_GPU_SUPPORT
  • reserved26 : _NVDRS_GPU_SUPPORT
  • reserved27 : _NVDRS_GPU_SUPPORT
  • reserved28 : _NVDRS_GPU_SUPPORT
  • reserved29 : _NVDRS_GPU_SUPPORT
  • reserved30 : _NVDRS_GPU_SUPPORT
  • reserved31 : _NVDRS_GPU_SUPPORT
  • reserved32 : _NVDRS_GPU_SUPPORT
  • reserved4 : _NVDRS_GPU_SUPPORT
  • reserved5 : _NVDRS_GPU_SUPPORT
  • reserved6 : _NV_MONITOR_CAPS_VSDB, _NVDRS_GPU_SUPPORT
  • reserved7 : _NVDRS_GPU_SUPPORT
  • reserved8 : _NV_MONITOR_CAPS_VSDB, _NVDRS_GPU_SUPPORT
  • reserved9 : _NVDRS_GPU_SUPPORT
  • reserved_sourceId : _NV_DISPLAYCONFIG_PATH_INFO_V1, _NV_DISPLAYCONFIG_PATH_INFO_V2
  • reservedBit1 : _NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_V1
  • reservedBits : _NV_D3D12_GRAPHICS_CAPS_V1, _NV_D3D1x_GRAPHICS_CAPS_V1, _NV_D3D1x_GRAPHICS_CAPS_V2
  • reservedData : _NVVIOOUTPUTCONFIG_V1, _NVVIOOUTPUTCONFIG_V2, _NVVIOOUTPUTCONFIG_V3
  • reservedEx : _NV_DISPLAY_DRIVER_INFO_V2, _NV_GET_ADAPTIVE_SYNC_DATA_V1, _NV_GET_VIRTUAL_REFRESH_RATE_DATA_V1, _NV_GET_VRR_INFO_V1, _NV_SET_ADAPTIVE_SYNC_DATA_V1, _NV_SET_VIRTUAL_REFRESH_RATE_DATA_V1, NVLINK_LINK_STATUS_INFO_V2
  • reservedInternal : _NV_GPU_DISPLAYIDS
  • resolution : _NV_DISPLAYCONFIG_SOURCE_MODE_INFO_V1
  • resolutionScale : _NV_SMP_ASSIST_SETUP_PARAMS_V1
  • ResourceHandle : NV_D3D11_META_COMMAND_RESOURCE
  • resultDataMaxSizeInBytes : _NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PREBUILD_INFO, _NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_ARRAY_PREBUILD_INFO
  • revision : _NV_GSYNC_CAPABILITIES_V1, _NV_GSYNC_CAPABILITIES_V2, _NV_GSYNC_CAPABILITIES_V3, NV_GPU_ARCH_INFO_V1, NV_GPU_ARCH_INFO_V2
  • revision_id : NV_GPU_ARCH_INFO_V2
  • rgb : _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_V1, _NV_GPU_CLIENT_ILLUM_ZONE_INFO_V1
  • rgbParams : _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_RGB, _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR_RGB
  • rgbQuantizationRange : NV_INFOFRAME_VIDEO
  • rgbw : _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_V1, _NV_GPU_CLIENT_ILLUM_ZONE_INFO_V1
  • rgbwParams : _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_RGBW, _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR_RGBW
  • rid : NvShaderExtnStruct
  • right : _NV_RECT
  • right_bar : NV_INFOFRAME_VIDEO
  • rightCoeffs : _NV_SMP_ASSIST_UPDATE_INSTANCEDSTEREO_DATA_PARAMS_V1
  • rightConst : _NV_SMP_ASSIST_UPDATE_INSTANCEDSTEREO_DATA_PARAMS_V1
  • riseTimems : _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR
  • RJ45_Ethernet : _NV_GSYNC_STATUS_PARAMS_V1, _NV_GSYNC_STATUS_PARAMS_V2
  • RJ45_IO : _NV_GSYNC_STATUS_PARAMS_V1, _NV_GSYNC_STATUS_PARAMS_V2
  • rotation : _NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_V1, _NV_MOSAIC_GRID_TOPO_DISPLAY_V1, _NV_MOSAIC_GRID_TOPO_DISPLAY_V2, NV_DISPLAY_PATH
  • rowCount : NV_MOSAIC_TOPO_DETAILS, NV_MOSAIC_TOPOLOGY
  • rows : _NV_MOSAIC_GRID_TOPO_V1, _NV_MOSAIC_GRID_TOPO_V2
  • rr : _NV_TIMING_INPUT, tagNV_TIMINGEXT
  • rrx1k : NV_MOSAIC_DISPLAY_SETTING_V2, tagNV_TIMINGEXT
  • rsvd : _NV_ASYNC_FRAME_MARKER_PARAMS_V1, _NV_CLIENT_CALLBACK_SETTINGS_SUPER_V1, _NV_GET_SLEEP_STATUS_PARAMS, _NV_GPU_CLIENT_CALLBACK_DATA_SUPER_V1, _NV_GPU_CLIENT_CALLBACK_UTILIZATION_DATA_V1, _NV_GPU_CLIENT_ILLUM_DEVICE_INFO_PARAMS_V1, _NV_GPU_CLIENT_ILLUM_DEVICE_INFO_V1, _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_COLOR_FIXED, _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_RGB, _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_RGBW, _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_SINGLE_COLOR, _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_PARAMS_V1, _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_V1, _NV_GPU_CLIENT_ILLUM_ZONE_INFO_DATA_RGB, _NV_GPU_CLIENT_ILLUM_ZONE_INFO_DATA_RGBW, _NV_GPU_CLIENT_ILLUM_ZONE_INFO_DATA_SINGLE_COLOR, _NV_GPU_CLIENT_ILLUM_ZONE_INFO_PARAMS_V1, _NV_GPU_CLIENT_ILLUM_ZONE_INFO_V1, _NV_GPU_CLIENT_PERIODIC_CALLBACK_SETTINGS_SUPER_V1, _NV_GPU_CLIENT_UTILIZATION_DATA_V1, _NV_GPU_CLIENT_UTILIZATION_PERIODIC_CALLBACK_SETTINGS_V1, _NV_LATENCY_MARKER_PARAMS, _NV_LATENCY_RESULT_PARAMS::FrameReport, _NV_LATENCY_RESULT_PARAMS, _NV_SET_REFLEX_SYNC_PARAMS, _NV_SET_SLEEP_MODE_PARAMS, NV_GPU_CLIENT_ILLUM_DEVICE_CONTROL_PARAMS_V1, NV_GPU_CLIENT_ILLUM_DEVICE_CONTROL_V1, NV_GPU_CLIENT_ILLUM_DEVICE_SYNC_V1
  • rsvd0 : _NV_LATENCY_MARKER_PARAMS
  • rsvdField : _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_PARAMS_V1
  • rxSublinkStatus : NVLINK_LINK_STATUS_INFO_V1, NVLINK_LINK_STATUS_INFO_V2


  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all struct and union fields with links to the structures/unions they belong to:

- s -

  • SampleCount : NvAPI_D3D11_RASTERIZER_DESC_EX, NVAPI_D3D12_PSO_RASTERIZER_STATE_DESC_V1
  • SamplePositionsX : NvAPI_D3D11_RASTERIZER_DESC_EX, NVAPI_D3D12_PSO_RASTERIZER_STATE_DESC_V1
  • SamplePositionsY : NvAPI_D3D11_RASTERIZER_DESC_EX, NVAPI_D3D12_PSO_RASTERIZER_STATE_DESC_V1
  • sampleRate : NV_INFOFRAME_AUDIO
  • sampleSize : NV_INFOFRAME_AUDIO
  • sampling : _NVVIOSTREAM
  • samplingFormat : _NVVIOCHANNELSTATUS
  • scaling : _NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_V1, NV_DISPLAY_PATH, NV_TIMING_FLAG
  • scanInfo : NV_INFOFRAME_VIDEO
  • scanInfoCEVideoFormats : _NV_MONITOR_CAPS_VCDB
  • scanInfoITVideoFormats : _NV_MONITOR_CAPS_VCDB
  • scanInfoPreferredVideoFormat : _NV_MONITOR_CAPS_VCDB
  • ScissorEnable : NvAPI_D3D11_RASTERIZER_DESC_EX
  • scissorRect : _NV_D3D11_EXCLUSIVE_SCISSOR_RECT_DESC_V1
  • scratchAccelerationStructureData : _NVAPI_D3D12_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_DESC_EX
  • scratchDataSizeInBytes : _NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PREBUILD_INFO, _NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_ARRAY_PREBUILD_INFO
  • scratchDisplacementMicromapArrayData : _NVAPI_D3D12_BUILD_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_DESC
  • scratchOpacityMicromapArrayData : _NVAPI_D3D12_BUILD_RAYTRACING_OPACITY_MICROMAP_ARRAY_DESC
  • sCustomRects : _NV_SMP_ASSIST_SETUP_PARAMS_V1
  • sdiSyncIn : _NVVIOOUTPUTSTATUS
  • sec : _NV_LICENSE_EXPIRY_DETAILS
  • sensor : NV_GPU_THERMAL_SETTINGS_V1, NV_GPU_THERMAL_SETTINGS_V2
  • serializedDataType : _NVAPI_CHECK_DRIVER_MATCHING_IDENTIFIER_EX_PARAMS_V1
  • SetMarker() : INvAPI_DirectD3D12GraphicsCommandList
  • settingId : _NVDRS_SETTING_V1, _SettingDWORDNameString, _SettingWSTRINGNameString
  • settingLocation : _NVDRS_SETTING_V1
  • settingName : _NVDRS_SETTING_V1
  • settingNameString : _SettingDWORDNameString, _SettingWSTRINGNameString
  • settingType : _NVDRS_SETTING_V1, _NVDRS_SETTING_VALUES
  • settingValues : _NVDRS_SETTING_VALUES, _SettingDWORDNameString, _SettingWSTRINGNameString
  • sFoveatedRenderingDesc : _NV_VRS_HELPER_ENABLE_PARAMS_V1
  • ShadingRateCustomPresetDesc : _NV_FOVEATED_RENDERING_DESC_V1
  • ShadingRatePreset : _NV_FOVEATED_RENDERING_DESC_V1
  • shadingRateTable : _NV_D3D11_VIEWPORT_SHADING_RATE_DESC_V1, _NV_VRS_HELPER_GET_SHADING_RATE_RESOURCE_PARAMS_V1
  • sharedSystemMemory : NV_DISPLAY_DRIVER_MEMORY_INFO_V1, NV_DISPLAY_DRIVER_MEMORY_INFO_V2, NV_DISPLAY_DRIVER_MEMORY_INFO_V3, NV_GPU_MEMORY_INFO_EX_V1
  • sHeight : NvSBox
  • sid : NvShaderExtnStruct
  • signalFormat : _NVVIOCHANNELSTATUS, _NVVIOINPUTCONFIG, _NVVIOOUTPUTCONFIG_V1, _NVVIOOUTPUTCONFIG_V2, _NVVIOOUTPUTCONFIG_V3, _NVVIOSIGNALFORMATDETAIL
  • signature : _NV_LICENSABLE_FEATURES_V1, _NV_LICENSABLE_FEATURES_V2, _NV_LICENSABLE_FEATURES_V3, _NV_LICENSABLE_FEATURES_V4
  • simEndTime : _NV_LATENCY_RESULT_PARAMS::FrameReport
  • simStartTime : _NV_LATENCY_RESULT_PARAMS::FrameReport
  • single : NV_GPU_PSTATE20_CLOCK_ENTRY_V1
  • singleBitErrors : NV_GPU_ECC_ERROR_INFO
  • singleColor : _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_V1, _NV_GPU_CLIENT_ILLUM_ZONE_INFO_V1
  • singleColorParams : _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_SINGLE_COLOR, _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR_SINGLE_COLOR
  • size : _NV_COLOR_DATA_V1, _NV_COLOR_DATA_V2, _NV_COLOR_DATA_V3, _NV_COLOR_DATA_V4, _NV_COLOR_DATA_V5, _NV_MONITOR_CAPABILITIES_V1, NV_INFOFRAME_DATA
  • Size : NV_META_COMMAND_TENSOR_DESC
  • size : NVAPI_D3D12_CREATE_CUBIN_SHADER_PARAMS
  • sizeOfEDID : _NV_EDID_DATA_V1, _NV_EDID_DATA_V2
  • sizeofEDID : NV_EDID_V2, NV_EDID_V3
  • SkipConnectionResource : NV_D3D11_META_COMMAND_EXECUTE_CONVOLUTION_EX_DESC, NV_D3D12_META_COMMAND_EXECUTE_CONVOLUTION_EX_DESC
  • SkipMode : NV_META_COMMAND_CONVOLUTION_FUSE_DESC
  • sleepIntervalUs : _NV_GET_SLEEP_STATUS_PARAMS
  • sLeftConfig : _NV_LMS_INSTANCED_STEREO_CONFIG_V1
  • sLeftEye : _NV_FOVEATED_RENDERING_UPDATE_GAZE_DATA_PARAMS
  • sLMS_ISConfig : _NV_SMP_ASSIST_GET_CONSTANTS_V3
  • sLMSConfig : _NV_SMP_ASSIST_GET_CONSTANTS_V3
  • sLMSCustomConfig : _NV_SMP_ASSIST_SETUP_PARAMS_V1
  • SlopeScaledDepthBias : NvAPI_D3D11_RASTERIZER_DESC_EX
  • sMonoData : _NV_FOVEATED_RENDERING_UPDATE_GAZE_DATA_PARAMS
  • smpDesc : NVAPI_D3D12_GET_CUDA_MERGED_TEXTURE_SAMPLER_OBJECT_PARAMS
  • smpte352 : _NVVIOCHANNELSTATUS
  • sMRS_ISConfig : _NV_SMP_ASSIST_GET_CONSTANTS_V3
  • sMRSConfig : _NV_SMP_ASSIST_GET_CONSTANTS_V3
  • sMRSCustomConfig : _NV_SMP_ASSIST_SETUP_PARAMS_V1
  • source : _NV_GSYNC_CONTROL_PARAMS_V1, _NV_GSYNC_CONTROL_PARAMS_V2
  • sourceAccelerationStructureData : _NVAPI_D3D12_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_DESC_EX
  • sourceDesktopRect : _NV_SCANOUT_INFORMATION
  • sourceId : _NV_DISPLAYCONFIG_PATH_INFO_V2, NV_DISPLAY_PATH, NV_VIEW_TARGET_INFO
  • sourceModeInfo : _NV_DISPLAYCONFIG_PATH_INFO_V1, _NV_DISPLAYCONFIG_PATH_INFO_V2
  • sourcePhysicalAddressA : _NV_MONITOR_CAPS_VSDB
  • sourcePhysicalAddressB : _NV_MONITOR_CAPS_VSDB
  • sourcePhysicalAddressC : _NV_MONITOR_CAPS_VSDB
  • sourcePhysicalAddressD : _NV_MONITOR_CAPS_VSDB
  • sourceToTargetRotation : _NV_SCANOUT_INFORMATION
  • sourceViewportRect : _NV_SCANOUT_INFORMATION
  • spanningOrientation : _NV_DISPLAYCONFIG_SOURCE_MODE_INFO_V1
  • speakerPlacement : NV_INFOFRAME_AUDIO
  • src0u : NvShaderExtnStruct
  • src1u : NvShaderExtnStruct
  • src2u : NvShaderExtnStruct
  • src3u : NvShaderExtnStruct
  • src4u : NvShaderExtnStruct
  • src5u : NvShaderExtnStruct
  • srcPartition : NV_CUSTOM_DISPLAY
  • sRightConfig : _NV_LMS_INSTANCED_STEREO_CONFIG_V1
  • sRightEye : _NV_FOVEATED_RENDERING_UPDATE_GAZE_DATA_PARAMS
  • sStereoData : _NV_FOVEATED_RENDERING_UPDATE_GAZE_DATA_PARAMS
  • StartPadding : NV_META_COMMAND_CREATE_CONVOLUTION_EX_DESC
  • startupDelay : _NV_GSYNC_CONTROL_PARAMS_V1, _NV_GSYNC_CONTROL_PARAMS_V2
  • static_metadata_descriptor_id : _NV_HDR_CAPABILITIES_V1, _NV_HDR_CAPABILITIES_V2, _NV_HDR_CAPABILITIES_V3, _NV_HDR_COLOR_DATA_V1, _NV_HDR_COLOR_DATA_V2
  • status : _NV_LICENSE_EXPIRY_DETAILS, tagNV_TIMINGEXT
  • streams : _NVVIOINPUTCONFIG
  • Stride : NV_META_COMMAND_CREATE_CONVOLUTION_EX_DESC, NV_META_COMMAND_TENSOR_DESC
  • structSizeIn : NVAPI_D3D12_CREATE_CUBIN_SHADER_PARAMS, NVAPI_D3D12_GET_CUDA_INDEPENDENT_DESCRIPTOR_OBJECT_PARAMS, NVAPI_D3D12_GET_CUDA_MERGED_TEXTURE_SAMPLER_OBJECT_PARAMS
  • structSizeOut : NVAPI_D3D12_CREATE_CUBIN_SHADER_PARAMS, NVAPI_D3D12_GET_CUDA_INDEPENDENT_DESCRIPTOR_OBJECT_PARAMS, NVAPI_D3D12_GET_CUDA_MERGED_TEXTURE_SAMPLER_OBJECT_PARAMS
  • subdivisionLevel : _NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_DESC, _NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_USAGE_COUNT, _NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_DESC, _NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_USAGE_COUNT
  • subLinkWidth : NVLINK_LINK_STATUS_INFO_V1, NVLINK_LINK_STATUS_INFO_V2
  • subSysDeviceId : NV_CHIPSET_INFO_v3, NV_CHIPSET_INFO_v4
  • subSysVendorId : NV_CHIPSET_INFO_v3, NV_CHIPSET_INFO_v4
  • super : _NV_GPU_CLIENT_CALLBACK_UTILIZATION_DATA_V1, _NV_GPU_CLIENT_PERIODIC_CALLBACK_SETTINGS_SUPER_V1, _NV_GPU_CLIENT_UTILIZATION_PERIODIC_CALLBACK_SETTINGS_V1
  • supportAI : _NV_MONITOR_CAPS_VSDB
  • supportDeepColor30bits : _NV_MONITOR_CAPS_VSDB
  • supportDeepColor36bits : _NV_MONITOR_CAPS_VSDB
  • supportDeepColor48bits : _NV_MONITOR_CAPS_VSDB
  • supportDeepColorYCbCr444 : _NV_MONITOR_CAPS_VSDB
  • supportDualDviOperation : _NV_MONITOR_CAPS_VSDB
  • supported : _NV_D3D12_WORKSTATION_FEATURE_PROPERTIES
  • supports_10b_12b_444 : _NV_HDR_CAPABILITIES_V2, _NV_HDR_CAPABILITIES_V3
  • supports_2160p60hz : _NV_HDR_CAPABILITIES_V2, _NV_HDR_CAPABILITIES_V3
  • supports_backlight_control : _NV_HDR_CAPABILITIES_V2, _NV_HDR_CAPABILITIES_V3
  • supports_global_dimming : _NV_HDR_CAPABILITIES_V2, _NV_HDR_CAPABILITIES_V3
  • supports_YUV422_12bit : _NV_HDR_CAPABILITIES_V2, _NV_HDR_CAPABILITIES_V3
  • supportsRotation : NV_MOSAIC_DISPLAY_TOPO_STATUS
  • supportsWindowedModeAutomatic : _NVAPI_STEREO_CAPS
  • supportsWindowedModeOff : _NVAPI_STEREO_CAPS
  • supportsWindowedModePersistent : _NVAPI_STEREO_CAPS
  • supportULMB : _NV_MONITOR_CAPS_GENERIC
  • supportVRR : _NV_MONITOR_CAPS_GENERIC
  • surfaceHandle : NVAPI_UAV_INFO_V1, NVAPI_UAV_INFO_V2
  • sViewOffset : _NV_DX_VIDEO_STEREO_INFO
  • sWidth : NvSBox
  • sX : NvSBox
  • sY : NvSBox
  • syncData : NV_GPU_CLIENT_ILLUM_DEVICE_CONTROL_V1
  • syncDelay : _NVVIOOUTPUTCONFIG_V1, _NVVIOOUTPUTCONFIG_V2, _NVVIOOUTPUTCONFIG_V3
  • syncEnable : _NVVIOOUTPUTCONFIG_V1, _NVVIOOUTPUTCONFIG_V2, _NVVIOOUTPUTCONFIG_V3, _NVVIOOUTPUTSTATUS
  • syncFormat : _NVVIOOUTPUTSTATUS
  • SyncMode : _NV_PRESENT_BARRIER_FRAME_STATISTICS
  • syncSkew : _NV_GSYNC_CONTROL_PARAMS_V1, _NV_GSYNC_CONTROL_PARAMS_V2
  • syncSource : _NVVIOOUTPUTCONFIG_V1, _NVVIOOUTPUTCONFIG_V2, _NVVIOOUTPUTCONFIG_V3, _NVVIOOUTPUTSTATUS
  • syncSourceIsOutput : _NV_GSYNC_CONTROL_PARAMS_V1, _NV_GSYNC_CONTROL_PARAMS_V2
  • syncState : _NV_GSYNC_DISPLAY
  • systemVideoMemory : NV_DISPLAY_DRIVER_MEMORY_INFO_V1, NV_DISPLAY_DRIVER_MEMORY_INFO_V2, NV_DISPLAY_DRIVER_MEMORY_INFO_V3, NV_GPU_MEMORY_INFO_EX_V1
  • szAdapterString : NV_DISPLAY_DRIVER_VERSION
  • szBuildBaseBranch : _NV_DISPLAY_DRIVER_INFO_V2
  • szBuildBranch : _NV_DISPLAY_DRIVER_INFO, _NV_DISPLAY_DRIVER_INFO_V2
  • szBuildBranchString : NV_DISPLAY_DRIVER_VERSION
  • szChipsetName : NV_CHIPSET_INFO_v1, NV_CHIPSET_INFO_v2, NV_CHIPSET_INFO_v3, NV_CHIPSET_INFO_v4
  • szSubSysVendorName : NV_CHIPSET_INFO_v3, NV_CHIPSET_INFO_v4
  • szVendorName : NV_CHIPSET_INFO_v1, NV_CHIPSET_INFO_v2, NV_CHIPSET_INFO_v3, NV_CHIPSET_INFO_v4


  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all struct and union fields with links to the structures/unions they belong to:

- t -

  • target : NV_GPU_THERMAL_SETTINGS_V1, NV_GPU_THERMAL_SETTINGS_V2, NV_VIEW_TARGET_INFO
  • target_max_luminance : _NV_HDR_CAPABILITIES_V2, _NV_HDR_CAPABILITIES_V3
  • target_min_luminance : _NV_HDR_CAPABILITIES_V2, _NV_HDR_CAPABILITIES_V3
  • targetDisplayHeight : _NV_SCANOUT_INFORMATION
  • targetDisplayWidth : _NV_SCANOUT_INFORMATION
  • targetId : _NV_DISPLAYCONFIG_PATH_TARGET_INFO_V2
  • TargetIndependentRasterWithDepth : _NV_D3D11_FEATURE_DATA_RASTERIZER_SUPPORT
  • TargetIndepentRasterWithDepth : NvAPI_D3D11_RASTERIZER_DESC_EX, NVAPI_D3D12_PSO_RASTERIZER_STATE_DESC_V1
  • targetInfo : _NV_DISPLAYCONFIG_PATH_INFO_V1, _NV_DISPLAYCONFIG_PATH_INFO_V2
  • targetInfoCount : _NV_DISPLAYCONFIG_PATH_INFO_V1, _NV_DISPLAYCONFIG_PATH_INFO_V2
  • targetViewportRect : _NV_SCANOUT_INFORMATION
  • TemporaryResource : NV_D3D11_META_COMMAND_EXECUTE_CONVOLUTION_EX_DESC, NV_D3D11_META_COMMAND_EXECUTE_GEMM_DESC, NV_D3D12_META_COMMAND_EXECUTE_CONVOLUTION_EX_DESC, NV_D3D12_META_COMMAND_EXECUTE_GEMM_DESC
  • tensorCores : _NV_GPU_INFO_V2
  • testColorChange : NV_DISPLAY_PORT_CONFIG
  • testLinkTrain : NV_DISPLAY_PORT_CONFIG
  • texDesc : NVAPI_D3D12_GET_CUDA_MERGED_TEXTURE_SAMPLER_OBJECT_PARAMS
  • Texture2D : _NV_D3D11_SHADING_RATE_RESOURCE_VIEW_DESC_V1
  • Texture2DArray : _NV_D3D11_SHADING_RATE_RESOURCE_VIEW_DESC_V1
  • textureHandle : NVAPI_D3D12_GET_CUDA_MERGED_TEXTURE_SAMPLER_OBJECT_PARAMS
  • textureRect : NV_SCANOUT_WARPING_DATA
  • timeInQueueUs : _NV_SET_REFLEX_SYNC_PARAMS
  • timeInQueueUsTarget : _NV_SET_REFLEX_SYNC_PARAMS
  • Timestamp : _NV_FOVEATED_RENDERING_UPDATE_GAZE_DATA_PARAMS
  • timestamp : _NV_GPU_CLIENT_CALLBACK_UTILIZATION_DATA_V1
  • timeStampms : NV_GPU_CLIENT_ILLUM_DEVICE_SYNC_V1
  • timing : _NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_V1, NV_CUSTOM_DISPLAY
  • timingOverride : _NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_V1
  • top : _NV_RECT
  • top_bar : NV_INFOFRAME_VIDEO
  • topo : NV_MOSAIC_TOPO_BRIEF
  • topoBriefs : _NV_MOSAIC_SUPPORTED_TOPO_INFO_V1, _NV_MOSAIC_SUPPORTED_TOPO_INFO_V2
  • topoBriefsCount : _NV_MOSAIC_SUPPORTED_TOPO_INFO_V1, _NV_MOSAIC_SUPPORTED_TOPO_INFO_V2
  • topos : NV_MOSAIC_SUPPORTED_TOPOLOGIES, NV_MOSAIC_TOPO_GROUP
  • totalCount : NV_MOSAIC_SUPPORTED_TOPOLOGIES
  • TransA : NV_META_COMMAND_CREATE_GEMM_DESC
  • TransB : NV_META_COMMAND_CREATE_GEMM_DESC
  • triangleMicromapBaseLocation : _NVAPI_D3D12_RAYTRACING_GEOMETRY_DMM_ATTACHMENT_DESC
  • triangleMicromapIndexBuffer : _NVAPI_D3D12_RAYTRACING_GEOMETRY_DMM_ATTACHMENT_DESC
  • triangleMicromapIndexFormat : _NVAPI_D3D12_RAYTRACING_GEOMETRY_DMM_ATTACHMENT_DESC
  • trianglePrimitiveFlagsBuffer : _NVAPI_D3D12_RAYTRACING_GEOMETRY_DMM_ATTACHMENT_DESC
  • triangles : _NVAPI_D3D12_RAYTRACING_GEOMETRY_DESC_EX, _NVAPI_D3D12_RAYTRACING_GEOMETRY_DMM_TRIANGLES_DESC, _NVAPI_D3D12_RAYTRACING_GEOMETRY_OMM_TRIANGLES_DESC
  • tvFormat : _NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_V1, NV_DISPLAY_PATH, NV_TIMING_FLAG
  • txSublinkStatus : NVLINK_LINK_STATUS_INFO_V1, NVLINK_LINK_STATUS_INFO_V2
  • type : _NV_GPU_CLIENT_ILLUM_DEVICE_INFO_V1, _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_V1, _NV_GPU_CLIENT_ILLUM_ZONE_INFO_V1, _NV_TIMING_INPUT, _NVAPI_D3D12_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_INPUTS_EX, _NVAPI_D3D12_RAYTRACING_GEOMETRY_DESC_EX, NV_GPU_CLIENT_ILLUM_DEVICE_CONTROL_V1, NV_INFOFRAME_DATA, NVAPI_D3D12_GET_CUDA_INDEPENDENT_DESCRIPTOR_OBJECT_PARAMS
  • typeId : NV_GPU_PSTATE20_CLOCK_ENTRY_V1


  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all struct and union fields with links to the structures/unions they belong to:

- u -

  • u32CurrentValue : _NVDRS_SETTING_V1
  • u32DefaultValue : _NVDRS_SETTING_VALUES
  • u32PredefinedValue : _NVDRS_SETTING_V1
  • u32Value : _NVDRS_SETTING_VALUES
  • uavSlot : NVAPI_D3D12_PSO_SET_SHADER_EXTENSION_SLOT_DESC_V1
  • uBlue : _NVVIOGAMMARAMP10, _NVVIOGAMMARAMP8
  • uEnabled : _NVVIOCOMPOSITERANGE
  • uGreen : _NVVIOGAMMARAMP10, _NVVIOGAMMARAMP8
  • uMax : _NVVIOCOMPOSITERANGE
  • uMin : _NVVIOCOMPOSITERANGE
  • unused : NV_D3D11_META_COMMAND_RESOURCE
  • uPowerOn : _NVVIOOUTPUTSTATUS
  • UpsampleMode : NV_META_COMMAND_CONVOLUTION_FUSE_DESC
  • uRange : _NVVIOCOMPOSITERANGE
  • uRed : _NVVIOGAMMARAMP10, _NVVIOGAMMARAMP8
  • UseAttributeSkipMask : NvAPI_D3D11_CREATE_GEOMETRY_SHADER_EX_V5, NVAPI_D3D12_PSO_GEOMETRY_SHADER_DESC_V5
  • UseCoordinateSwizzle : NvAPI_D3D11_CREATE_GEOMETRY_SHADER_EX_V5, NVAPI_D3D12_PSO_GEOMETRY_SHADER_DESC_V5
  • userFriendlyName : _NVDRS_APPLICATION_V1, _NVDRS_APPLICATION_V2, _NVDRS_APPLICATION_V3, _NVDRS_APPLICATION_V4
  • UseSpecificShaderExt : NvAPI_D3D11_CREATE_DOMAIN_SHADER_EX_V3, NvAPI_D3D11_CREATE_GEOMETRY_SHADER_EX_V5, NvAPI_D3D11_CREATE_HULL_SHADER_EX_V2, NvAPI_D3D11_CREATE_VERTEX_SHADER_EX_V3, NVAPI_D3D12_PSO_DOMAIN_SHADER_DESC_V3, NVAPI_D3D12_PSO_GEOMETRY_SHADER_DESC_V5, NVAPI_D3D12_PSO_HULL_SHADER_DESC_V2, NVAPI_D3D12_PSO_VERTEX_SHADER_DESC_V3
  • UseViewportMask : NvAPI_D3D11_CREATE_GEOMETRY_SHADER_EX_V5, NVAPI_D3D12_PSO_GEOMETRY_SHADER_DESC_V5
  • UseWithFastGS : NvAPI_D3D11_CREATE_DOMAIN_SHADER_EX_V2, NvAPI_D3D11_CREATE_DOMAIN_SHADER_EX_V3, NvAPI_D3D11_CREATE_HULL_SHADER_EX_V1, NvAPI_D3D11_CREATE_HULL_SHADER_EX_V2, NvAPI_D3D11_CREATE_VERTEX_SHADER_EX_V2, NvAPI_D3D11_CREATE_VERTEX_SHADER_EX_V3, NVAPI_D3D12_PSO_DOMAIN_SHADER_DESC_V2, NVAPI_D3D12_PSO_HULL_SHADER_DESC_V1, NVAPI_D3D12_PSO_VERTEX_SHADER_DESC_V2
  • uSyncSourceLocked : _NVVIOOUTPUTSTATUS
  • utilId : _NV_GPU_CLIENT_UTILIZATION_DATA_V1
  • utilization : NV_GPU_DYNAMIC_PSTATES_INFO_EX
  • utilizationPercent : _NV_GPU_CLIENT_UTILIZATION_DATA_V1
  • utils : _NV_GPU_CLIENT_CALLBACK_UTILIZATION_DATA_V1


  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all struct and union fields with links to the structures/unions they belong to:

- v -

  • validityMask : NV_MOSAIC_TOPO_DETAILS
  • Value : _NV_GPU_GET_ILLUMINATION_PARM_V1, _NV_GPU_SET_ILLUMINATION_PARM_V1
  • value : NV_GPU_PERF_PSTATES20_PARAM_DELTA
  • valueData : _NVDRS_BINARY_SETTING
  • valueLength : _NVDRS_BINARY_SETTING
  • valueRange : NV_GPU_PERF_PSTATES20_PARAM_DELTA
  • vblankIntervalUs : _NV_SET_REFLEX_SYNC_PARAMS
  • VBorder : _NV_TIMING
  • vcdb : _NV_MONITOR_CAPABILITIES_V1
  • vendorId : NV_CHIPSET_INFO_v1, NV_CHIPSET_INFO_v2, NV_CHIPSET_INFO_v3, NV_CHIPSET_INFO_v4
  • version : _NV_ASYNC_FRAME_MARKER_PARAMS_V1, _NV_BOARD_INFO, _NV_COLOR_DATA_V1, _NV_COLOR_DATA_V2, _NV_COLOR_DATA_V3, _NV_COLOR_DATA_V4, _NV_COLOR_DATA_V5, _NV_COMPUTE_GPU_TOPOLOGY_V2, _NV_CUSTOM_SEMANTIC, _NV_D3D11_EXCLUSIVE_SCISSOR_RECTS_DESC_V1, _NV_D3D11_SHADING_RATE_RESOURCE_VIEW_DESC_V1, _NV_D3D11_VIEWPORTS_SHADING_RATE_DESC_V1, _NV_D3D12_MOSAIC_GETCOMPANIONALLOCATIONS, _NV_D3D12_MOSAIC_GETVIEWPORTANDGPUPARTITIONS, _NV_D3D12_WORKSTATION_FEATURE_PROPERTIES, _NV_D3D_LATELATCH_OBJECT_DESC_V1, _NV_DISPLAY_DRIVER_INFO, _NV_DISPLAY_DRIVER_INFO_V2, _NV_DISPLAY_PORT_INFO_V1, _NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_V1, _NV_DISPLAYCONFIG_PATH_INFO_V1, _NV_DISPLAYCONFIG_PATH_INFO_V2, _NV_EDID_DATA_V1, _NV_EDID_DATA_V2, _NV_FOVEATED_RENDERING_CUSTOM_FOVEATION_PATTERN_PRESET_DESC_V1, _NV_FOVEATED_RENDERING_CUSTOM_SHADING_RATE_PRESET_DESC_V1, _NV_FOVEATED_RENDERING_DESC_V1, _NV_FOVEATED_RENDERING_GAZE_DATA_PER_EYE, _NV_FOVEATED_RENDERING_UPDATE_GAZE_DATA_PARAMS, _NV_GAZE_HANDLER_INIT_PARAMS_V1, _NV_GAZE_HANDLER_INIT_PARAMS_V2, _NV_GET_ADAPTIVE_SYNC_DATA_V1, _NV_GET_SLEEP_STATUS_PARAMS, _NV_GET_VIRTUAL_REFRESH_RATE_DATA_V1, _NV_GET_VRR_INFO_V1, _NV_GPU_CLIENT_ILLUM_DEVICE_INFO_PARAMS_V1, _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_PARAMS_V1, _NV_GPU_CLIENT_ILLUM_ZONE_INFO_PARAMS_V1, _NV_GPU_CLIENT_UTILIZATION_PERIODIC_CALLBACK_SETTINGS_V1, _NV_GPU_DISPLAYIDS, _NV_GPU_GET_ILLUMINATION_PARM_V1, _NV_GPU_GSP_INFO_V1, _NV_GPU_INFO_V1, _NV_GPU_INFO_V2, _NV_GPU_PERF_PSTATES20_INFO_V2, _NV_GPU_QUERY_ILLUMINATION_SUPPORT_PARM_V1, _NV_GPU_SET_ILLUMINATION_PARM_V1, _NV_GPU_VIRTUALIZATION_INFO, _NV_GPU_VR_READY_V1, _NV_GSYNC_CAPABILITIES_V1, _NV_GSYNC_CAPABILITIES_V2, _NV_GSYNC_CAPABILITIES_V3, _NV_GSYNC_CONTROL_PARAMS_V1, _NV_GSYNC_CONTROL_PARAMS_V2, _NV_GSYNC_DELAY, _NV_GSYNC_DISPLAY, _NV_GSYNC_GPU, _NV_GSYNC_STATUS, _NV_GSYNC_STATUS_PARAMS_V1, _NV_GSYNC_STATUS_PARAMS_V2, _NV_HDMI_SUPPORT_INFO_V1, _NV_HDMI_SUPPORT_INFO_V2, _NV_HDR_CAPABILITIES_V1, _NV_HDR_CAPABILITIES_V2, _NV_HDR_CAPABILITIES_V3, _NV_HDR_COLOR_DATA_V1, _NV_HDR_COLOR_DATA_V2, _NV_HDR_METADATA_V1, _NV_HEAP_PARAMS_V1, _NV_LATENCY_MARKER_PARAMS, _NV_LATENCY_RESULT_PARAMS, _NV_LICENSABLE_FEATURES_V1, _NV_LICENSABLE_FEATURES_V2, _NV_LICENSABLE_FEATURES_V3, _NV_LICENSABLE_FEATURES_V4, _NV_LICENSE_FEATURE_DETAILS_V1, _NV_LICENSE_FEATURE_DETAILS_V2, _NV_LICENSE_FEATURE_DETAILS_V3, _NV_LICENSE_FEATURE_DETAILS_V4, _NV_LOGICAL_GPU_DATA_V1, _NV_LOGICAL_GPUS, _NV_MANAGED_DEDICATED_DISPLAY_INFO, _NV_MANAGED_DEDICATED_DISPLAY_METADATA, _NV_MODIFIED_W_PARAMS, _NV_MONITOR_CAPABILITIES_V1, _NV_MONITOR_COLOR_DATA, _NV_MOSAIC_DISPLAY_SETTING_V1, _NV_MOSAIC_GRID_TOPO_DISPLAY_V2, _NV_MOSAIC_GRID_TOPO_V1, _NV_MOSAIC_GRID_TOPO_V2, _NV_MOSAIC_SUPPORTED_TOPO_INFO_V1, _NV_MOSAIC_SUPPORTED_TOPO_INFO_V2, _NV_MULTIGPU_CAPS_V2, _NV_MULTIVIEW_PARAMS_V1, _NV_PHYSICAL_GPUS, _NV_PIXEL_SHADING_RATE_SAMPLE_ORDER_TABLE_V1, _NV_QUERY_LATELATCH_SUPPORT_PARAMS, _NV_QUERY_MODIFIED_W_SUPPORT_PARAMS, _NV_QUERY_MULTIVIEW_SUPPORT_PARAMS_V1, _NV_QUERY_SINGLE_PASS_STEREO_SUPPORT_PARAMS_V1, _NV_QUERY_SINGLE_PASS_STEREO_SUPPORT_PARAMS_V2, _NV_QUERY_SMP_ASSIST_SUPPORT_PARAMS_V1, _NV_RESOURCE_PARAMS_V1, _NV_SCANOUT_INFORMATION, _NV_SCANOUT_INTENSITY_STATE_DATA, _NV_SCANOUT_WARPING_STATE_DATA, _NV_SET_ADAPTIVE_SYNC_DATA_V1, _NV_SET_REFLEX_SYNC_PARAMS, _NV_SET_SLEEP_MODE_PARAMS, _NV_SET_VIRTUAL_REFRESH_RATE_DATA_V1, _NV_SMP_ASSIST_DISABLE_PARAMS_V1, _NV_SMP_ASSIST_ENABLE_PARAMS_V1, _NV_SMP_ASSIST_GET_CONSTANTS_V3, _NV_SMP_ASSIST_INITIALIZE_PARAMS_V1, _NV_SMP_ASSIST_SETUP_PARAMS_V1, _NV_SMP_ASSIST_UPDATE_INSTANCEDSTEREO_DATA_PARAMS_V1, _NV_TIMING_INPUT, _NV_VIO_TOPOLOGY, _NV_VRS_HELPER_DISABLE_PARAMS_V1, _NV_VRS_HELPER_ENABLE_PARAMS_V1, _NV_VRS_HELPER_GET_SHADING_RATE_RESOURCE_PARAMS_V1, _NV_VRS_HELPER_INIT_PARAMS_V1, _NV_VRS_HELPER_LATCH_GAZE_PARAMS_V1, _NV_VRS_HELPER_PURGE_INTERNAL_RESOURCES_PARAMS_V1, _NVAPI_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_EX_PARAMS_V1, _NVAPI_BUILD_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PARAMS_V1, _NVAPI_BUILD_RAYTRACING_OPACITY_MICROMAP_ARRAY_PARAMS_V1, _NVAPI_CHECK_DRIVER_MATCHING_IDENTIFIER_EX_PARAMS_V1, _NVAPI_D3D12_SET_CREATE_PIPELINE_STATE_OPTIONS_PARAMS_V1, _NVAPI_EMIT_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_POSTBUILD_INFO_PARAMS_V1, _NVAPI_EMIT_RAYTRACING_OPACITY_MICROMAP_ARRAY_POSTBUILD_INFO_PARAMS_V1, _NVAPI_GET_RAYTRACING_ACCELERATION_STRUCTURE_PREBUILD_INFO_EX_PARAMS_V1, _NVAPI_GET_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PREBUILD_INFO_PARAMS_V1, _NVAPI_GET_RAYTRACING_OPACITY_MICROMAP_ARRAY_PREBUILD_INFO_PARAMS_V1, _NVAPI_RELOCATE_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PARAMS_V1, _NVAPI_RELOCATE_RAYTRACING_OPACITY_MICROMAP_ARRAY_PARAMS_V1, _NVAPI_STEREO_CAPS, _NVDRS_APPLICATION_V1, _NVDRS_APPLICATION_V2, _NVDRS_APPLICATION_V3, _NVDRS_APPLICATION_V4, _NVDRS_PROFILE_V1, _NVDRS_SETTING_V1, _NVDRS_SETTING_VALUES, _NVVIOCAPS, _NVVIOCOLORCONVERSION, _NVVIOCONFIG_V1, _NVVIOCONFIG_V2, _NVVIOCONFIG_V3, _NVVIOGAMMACORRECTION, _NVVIOPCIINFO, _NVVIOSTATUS, _NVVIOSYNCDELAY, NV_CHIPSET_INFO_v1, NV_CHIPSET_INFO_v2, NV_CHIPSET_INFO_v3, NV_CHIPSET_INFO_v4, NV_COMPUTE_GPU_TOPOLOGY_V1, NV_CUSTOM_DISPLAY, NV_DISPLAY_DRIVER_MEMORY_INFO_V1, NV_DISPLAY_DRIVER_MEMORY_INFO_V2, NV_DISPLAY_DRIVER_MEMORY_INFO_V3, NV_DISPLAY_DRIVER_VERSION, NV_DISPLAY_PATH_INFO, NV_DISPLAY_PATH_INFO_V3, NV_DISPLAY_PORT_CONFIG, NV_EDID_V1, NV_EDID_V2, NV_EDID_V3, NV_EVENT_REGISTER_CALLBACK, NV_GET_CURRENT_SLI_STATE_V1, NV_GET_CURRENT_SLI_STATE_V2, NV_GET_GPU_VIRTUAL_ADDRESS_V1, NV_GET_PREFERRED_STEREO_DISPLAY_V1, NV_GPU_ARCH_INFO_V1, NV_GPU_ARCH_INFO_V2, NV_GPU_CLIENT_ILLUM_DEVICE_CONTROL_PARAMS_V1, NV_GPU_CLOCK_FREQUENCIES_V1, NV_GPU_CLOCK_FREQUENCIES_V2, NV_GPU_DYNAMIC_PSTATES_INFO_EX, NV_GPU_ECC_CONFIGURATION_INFO, NV_GPU_ECC_ERROR_INFO, NV_GPU_ECC_STATUS_INFO, NV_GPU_GET_HDCP_SUPPORT_STATUS, NV_GPU_MEMORY_INFO_EX_V1, NV_GPU_PERF_PSTATES20_INFO_V1, NV_GPU_PERF_PSTATES_INFO_V1, NV_GPU_PERF_PSTATES_INFO_V2, NV_GPU_THERMAL_SETTINGS_V1, NV_GPU_THERMAL_SETTINGS_V2, NV_I2C_INFO_V1, NV_I2C_INFO_V2, NV_I2C_INFO_V3, NV_INFOFRAME_DATA, NV_INFOFRAME_PROPERTY, NV_LID_DOCK_PARAMS, NV_MOSAIC_DISPLAY_SETTING_V2, NV_MOSAIC_DISPLAY_TOPO_STATUS, NV_MOSAIC_SUPPORTED_TOPOLOGIES, NV_MOSAIC_TOPO_BRIEF, NV_MOSAIC_TOPO_DETAILS, NV_MOSAIC_TOPO_GROUP, NV_MOSAIC_TOPOLOGY, NV_SCANOUT_INTENSITY_DATA_V1, NV_SCANOUT_INTENSITY_DATA_V2, NV_SCANOUT_WARPING_DATA, NV_SET_PREFERRED_STEREO_DISPLAY_V1, NV_VIEW_TARGET_INFO, NVAPI_ANSEL_CONFIGURATION_STRUCT_V1, NvAPI_D3D11_CREATE_DOMAIN_SHADER_EX_V1, NvAPI_D3D11_CREATE_DOMAIN_SHADER_EX_V2, NvAPI_D3D11_CREATE_DOMAIN_SHADER_EX_V3, NvAPI_D3D11_CREATE_FASTGS_EXPLICIT_DESC_V1, NvAPI_D3D11_CREATE_GEOMETRY_SHADER_EX_V5, NvAPI_D3D11_CREATE_HULL_SHADER_EX_V1, NvAPI_D3D11_CREATE_HULL_SHADER_EX_V2, NvAPI_D3D11_CREATE_PIXEL_SHADER_EX_V1, NvAPI_D3D11_CREATE_PIXEL_SHADER_EX_V2, NvAPI_D3D11_CREATE_VERTEX_SHADER_EX_V1, NvAPI_D3D11_CREATE_VERTEX_SHADER_EX_V2, NvAPI_D3D11_CREATE_VERTEX_SHADER_EX_V3, NVAPI_D3D12_PSO_CREATE_FASTGS_EXPLICIT_DESC_V1, NVAPI_D3D12_PSO_DOMAIN_SHADER_DESC_V1, NVAPI_D3D12_PSO_ENABLE_DEPTH_BOUND_TEST_DESC_V1, NVAPI_D3D12_PSO_GEOMETRY_SHADER_DESC_V5, NVAPI_D3D12_PSO_HULL_SHADER_DESC_V1, NVAPI_D3D12_PSO_RASTERIZER_STATE_DESC_V1, NVAPI_D3D12_PSO_REQUEST_FAST_GEOMETRY_SHADER_DESC_V1, NVAPI_D3D12_PSO_SET_SHADER_EXTENSION_SLOT_DESC_V1, NVAPI_D3D12_PSO_VERTEX_SHADER_DESC_V1, NVAPI_UAV_INFO_V1, NVAPI_UAV_INFO_V2, NVLINK_GET_CAPS_V1, NVLINK_GET_STATUS_V1, NVLINK_GET_STATUS_V2
  • vertexBiasAndScaleBuffer : _NVAPI_D3D12_RAYTRACING_GEOMETRY_DMM_ATTACHMENT_DESC
  • vertexBiasAndScaleFormat : _NVAPI_D3D12_RAYTRACING_GEOMETRY_DMM_ATTACHMENT_DESC
  • vertexDisplacementVectorBuffer : _NVAPI_D3D12_RAYTRACING_GEOMETRY_DMM_ATTACHMENT_DESC
  • vertexDisplacementVectorFormat : _NVAPI_D3D12_RAYTRACING_GEOMETRY_DMM_ATTACHMENT_DESC
  • vertexFormat : NV_SCANOUT_WARPING_DATA
  • verticalDelay : _NVVIOSYNCDELAY
  • verticalLines : _NVVIOVIDEOMODE
  • vertices : NV_SCANOUT_WARPING_DATA
  • VFrontPorch : _NV_TIMING
  • vic : NV_INFOFRAME_VIDEO
  • vid1Out : _NVVIOOUTPUTSTATUS
  • vid2Out : _NVVIOOUTPUTSTATUS
  • video : NV_INFOFRAME_DATA
  • videoBridgePresent : _NV_MULTIGPU_CAPS_V1, _NV_MULTIGPU_CAPS_V2
  • videoLatency : _NV_MONITOR_CAPS_VSDB
  • videoMode : _NVVIOSIGNALFORMATDETAIL
  • videoStandard : _NVVIOVIDEOMODE
  • videoType : _NVVIOVIDEOMODE
  • vidIn : _NVVIOINPUTSTATUS
  • ViewDimension : _NV_D3D11_SHADING_RATE_RESOURCE_VIEW_DESC_V1
  • vioCaps : _NVVIODATAFORMATDETAIL
  • vioConfig : _NVVIOCONFIG_V1, _NVVIOCONFIG_V2, _NVVIOCONFIG_V3
  • vioGammaCorrectionType : _NVVIOGAMMACORRECTION
  • vioId : NVVIOTOPOLOGYTARGET
  • vioStatus : _NVVIOSTATUS
  • vioTarget : _NV_VIO_TOPOLOGY
  • vioTotalDeviceCount : _NV_VIO_TOPOLOGY
  • virtualizationMode : _NV_GPU_VIRTUALIZATION_INFO
  • vmode : _NV_GSYNC_CONTROL_PARAMS_V1, _NV_GSYNC_CONTROL_PARAMS_V2
  • volt_uV : NV_GPU_PSTATE20_BASE_VOLTAGE_ENTRY_V1
  • voltages : _NV_GPU_PERF_PSTATES20_INFO_V2, NV_GPU_PERF_PSTATES_INFO_V2
  • voltDelta_uV : NV_GPU_PSTATE20_BASE_VOLTAGE_ENTRY_V1
  • vpOffsets : _NV_SMP_ASSIST_SETUP_PARAMS_V1
  • vsdb : _NV_MONITOR_CAPABILITIES_V1
  • VSVDB_version : _NV_HDR_CAPABILITIES_V2, _NV_HDR_CAPABILITIES_V3
  • VSyncPol : _NV_TIMING
  • VSyncWidth : _NV_TIMING
  • VTotal : _NV_TIMING
  • VVisible : _NV_TIMING


  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all struct and union fields with links to the structures/unions they belong to:

- w -

  • w : NV_VIEWPORTF
  • warningFlags : NV_MOSAIC_DISPLAY_TOPO_STATUS
  • warpDown : _NV_LMS_CUSTOM_CONFIG_V1
  • warpLeft : _NV_LMS_CUSTOM_CONFIG_V1
  • warpRight : _NV_LMS_CUSTOM_CONFIG_V1
  • warpUp : _NV_LMS_CUSTOM_CONFIG_V1
  • width : _NV_MOSAIC_DISPLAY_SETTING_V1, _NV_RESOLUTION, _NV_TIMING_INPUT, _NVVIOOUTPUTREGION, NV_CUSTOM_DISPLAY, NV_DISPLAY_PATH, NV_MOSAIC_DISPLAY_SETTING_V2, NV_SCANOUT_INTENSITY_DATA_V1, NV_SCANOUT_INTENSITY_DATA_V2
  • WindowToClipSplitsX : _NV_SMP_ASSIST_REMAPCBDATA_V1
  • WindowToClipSplitsY : _NV_SMP_ASSIST_REMAPCBDATA_V1
  • WindowToClipX : _NV_SMP_ASSIST_REMAPCBDATA_V1
  • WindowToClipY : _NV_SMP_ASSIST_REMAPCBDATA_V1
  • WindowToClipZ : _NV_SMP_ASSIST_REMAPCBDATA_V1
  • workstationFeatureType : _NV_D3D12_WORKSTATION_FEATURE_PROPERTIES
  • wszCurrentValue : _NVDRS_SETTING_V1
  • wszDefaultValue : _NVDRS_SETTING_VALUES
  • wszPredefinedValue : _NVDRS_SETTING_V1
  • wszValue : _NVDRS_SETTING_VALUES


  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all struct and union fields with links to the structures/unions they belong to:

- x -

  • X : _NV_PIXEL_SRSO_2x1::NV_PIXEL_SRSO_2x1_X1
  • x : _NV_POSITION, _NVAPI_DIM3, _NVVIOOUTPUTREGION, NV_VIEWPORTF
  • X1 : _NV_PIXEL_SRSO_1x2, _NV_PIXEL_SRSO_2x1, _NV_PIXEL_SRSO_2x2, _NV_PIXEL_SRSO_2x4, _NV_PIXEL_SRSO_4x2, _NV_PIXEL_SRSO_4x4
  • X2 : _NV_PIXEL_SRSO_1x2, _NV_PIXEL_SRSO_2x1, _NV_PIXEL_SRSO_2x2, _NV_PIXEL_SRSO_2x4
  • X4 : _NV_PIXEL_SRSO_1x2, _NV_PIXEL_SRSO_2x1, _NV_PIXEL_SRSO_2x2
  • X8 : _NV_PIXEL_SRSO_1x2
  • xRatio : NV_CUSTOM_DISPLAY
  • XS : _NV_PIXEL_SRSO_2x1::NV_PIXEL_SRSO_2x1_X2, _NV_PIXEL_SRSO_2x1::NV_PIXEL_SRSO_2x1_X4


  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all struct and union fields with links to the structures/unions they belong to:

- y -

  • Y : _NV_PIXEL_SRSO_1x2::NV_PIXEL_SRSO_1x2_X1
  • y : _NV_POSITION, _NVAPI_DIM3, _NVVIOOUTPUTREGION, NV_VIEWPORTF
  • yccQuantizationRange : NV_INFOFRAME_VIDEO
  • year : _NV_LICENSE_EXPIRY_DETAILS
  • yRatio : NV_CUSTOM_DISPLAY
  • YS : _NV_PIXEL_SRSO_1x2::NV_PIXEL_SRSO_1x2_X2, _NV_PIXEL_SRSO_1x2::NV_PIXEL_SRSO_1x2_X4, _NV_PIXEL_SRSO_1x2::NV_PIXEL_SRSO_1x2_X8
  • YX : _NV_PIXEL_SRSO_2x2::NV_PIXEL_SRSO_2x2_X1, _NV_PIXEL_SRSO_2x4::NV_PIXEL_SRSO_2x4_X1, _NV_PIXEL_SRSO_4x2::NV_PIXEL_SRSO_4x2_X1, _NV_PIXEL_SRSO_4x4::NV_PIXEL_SRSO_4x4_X1
  • YXS : _NV_PIXEL_SRSO_2x2::NV_PIXEL_SRSO_2x2_X2, _NV_PIXEL_SRSO_2x2::NV_PIXEL_SRSO_2x2_X4, _NV_PIXEL_SRSO_2x4::NV_PIXEL_SRSO_2x4_X2


  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all struct and union fields with links to the structures/unions they belong to:

- z -

  • z : _NVAPI_DIM3
  • zoneLocation : _NV_GPU_CLIENT_ILLUM_ZONE_INFO_V1
  • zones : _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_PARAMS_V1, _NV_GPU_CLIENT_ILLUM_ZONE_INFO_PARAMS_V1


  • All
  • Functions
  • Variables
Here is a list of all functions with links to the structures/unions they belong to:
  • DispatchGraphics() : INvAPI_DirectD3D12GraphicsCommandList
  • GetID3D12GraphicsCommandList() : INvAPI_DirectD3D12GraphicsCommandList
  • IsValid() : INvAPI_DirectD3D12GraphicsCommandList
  • SetMarker() : INvAPI_DirectD3D12GraphicsCommandList


  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all variables with links to the structures/unions they belong to:

- a -

  • aabbs : _NVAPI_D3D12_RAYTRACING_GEOMETRY_DESC_EX
  • acceleratePrimaryDisplay : _NV_MOSAIC_GRID_TOPO_V1, _NV_MOSAIC_GRID_TOPO_V2
  • Activation : NV_META_COMMAND_CREATE_CONVOLUTION_EX_DESC, NV_META_COMMAND_CREATE_GEMM_DESC
  • activeFormatAspectRatio : NV_INFOFRAME_VIDEO
  • activeFormatInfoPresent : NV_INFOFRAME_VIDEO
  • adapterCaps : _NVVIOCAPS
  • adapterClass : _NVVIOCAPS
  • adapterName : _NVVIOCAPS
  • adapterType : _NV_LOGICAL_GPU_HANDLE_DATA, _NV_PHYSICAL_GPU_HANDLE_DATA
  • aggregate : NV_GPU_ECC_ERROR_INFO
  • Alpha : NV_META_COMMAND_CREATE_GEMM_DESC
  • Alpha1 : NV_META_COMMAND_CREATE_CONVOLUTION_EX_DESC
  • Alpha1Resource : NV_D3D11_META_COMMAND_EXECUTE_CONVOLUTION_EX_DESC, NV_D3D12_META_COMMAND_EXECUTE_CONVOLUTION_EX_DESC
  • Alpha2 : NV_META_COMMAND_CREATE_CONVOLUTION_EX_DESC
  • Alpha2Resource : NV_D3D11_META_COMMAND_EXECUTE_CONVOLUTION_EX_DESC, NV_D3D12_META_COMMAND_EXECUTE_CONVOLUTION_EX_DESC
  • ancParityComputation : _NVVIOOUTPUTCONFIG_V2, _NVVIOOUTPUTCONFIG_V3
  • AntialiasedLineEnable : NvAPI_D3D11_RASTERIZER_DESC_EX
  • application_version : _NV_HDR_CAPABILITIES_V3
  • applyWithBezelCorrect : _NV_MOSAIC_GRID_TOPO_V1, _NV_MOSAIC_GRID_TOPO_V2
  • appName : _NVDRS_APPLICATION_V1, _NVDRS_APPLICATION_V2, _NVDRS_APPLICATION_V3, _NVDRS_APPLICATION_V4
  • architecture : NV_GPU_ARCH_INFO_V1, NV_GPU_ARCH_INFO_V2
  • architecture_id : NV_GPU_ARCH_INFO_V2
  • AResource : NV_D3D11_META_COMMAND_EXECUTE_GEMM_DESC, NV_D3D12_META_COMMAND_EXECUTE_GEMM_DESC
  • ArraySize : _NV_TEX2D_ARRAY_SRRV
  • aspect : tagNV_TIMINGEXT
  • ATimems : _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR
  • Attribute : _NV_GPU_GET_ILLUMINATION_PARM_V1, _NV_GPU_QUERY_ILLUMINATION_SUPPORT_PARM_V1, _NV_GPU_SET_ILLUMINATION_PARM_V1
  • audio : NV_INFOFRAME_DATA
  • audioLatency : _NV_MONITOR_CAPS_VSDB
  • availableDedicatedVideoMemory : NV_DISPLAY_DRIVER_MEMORY_INFO_V1, NV_DISPLAY_DRIVER_MEMORY_INFO_V2, NV_DISPLAY_DRIVER_MEMORY_INFO_V3, NV_GPU_MEMORY_INFO_EX_V1


  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all variables with links to the structures/unions they belong to:

- b -

  • backendBitDepths : _NV_MONITOR_COLOR_DATA
  • backlt_min_luma : _NV_HDR_CAPABILITIES_V2, _NV_HDR_CAPABILITIES_V3
  • barInfo : NV_INFOFRAME_VIDEO
  • baseMosaic : _NV_MOSAIC_GRID_TOPO_V1, _NV_MOSAIC_GRID_TOPO_V2
  • baseVersion : NVAPI_D3D12_PSO_EXTENSION_DESC_V1
  • baseVoltages : _NV_GPU_PERF_PSTATES20_INFO_V2, NV_GPU_PERF_PSTATES20_INFO_V1
  • bCplVsyncOn : _NV_GET_SLEEP_STATUS_PARAMS
  • bDefault : _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_PARAMS_V1
  • bDisable : _NV_SET_REFLEX_SYNC_PARAMS
  • bDisableAdaptiveSync : _NV_GET_ADAPTIVE_SYNC_DATA_V1, _NV_SET_ADAPTIVE_SYNC_DATA_V1
  • bDisableFrameSplitting : _NV_GET_ADAPTIVE_SYNC_DATA_V1, _NV_SET_ADAPTIVE_SYNC_DATA_V1
  • bEnable : _NV_SET_REFLEX_SYNC_PARAMS
  • bEnabled : _NV_SCANOUT_INTENSITY_STATE_DATA, _NV_SCANOUT_WARPING_STATE_DATA
  • bEnableSuperSamplingPredicationForVRS : NvAPI_D3D11_CREATE_PIXEL_SHADER_EX_V2
  • bEnableSuperSamplingPredicationForVRSAllAttributes : NvAPI_D3D11_CREATE_PIXEL_SHADER_EX_V2
  • Beta : NV_META_COMMAND_CREATE_GEMM_DESC
  • bExclusiveScissorRectsSupported : _NV_D3D12_GRAPHICS_CAPS_V1, _NV_D3D1x_GRAPHICS_CAPS_V1, _NV_D3D1x_GRAPHICS_CAPS_V2
  • bFastUAVClearSupported : _NV_D3D12_GRAPHICS_CAPS_V1, _NV_D3D1x_GRAPHICS_CAPS_V2
  • bFocusDisplay : NV_DISPLAY_PATH
  • bForceModeSet : NV_DISPLAY_PATH, NV_VIEW_TARGET_INFO
  • bFsVrr : _NV_GET_SLEEP_STATUS_PARAMS
  • bGDIPrimary : _NV_DISPLAYCONFIG_SOURCE_MODE_INFO_V1, NV_DISPLAY_PATH, NV_VIEW_TARGET_INFO
  • bHouseSync : _NV_GSYNC_STATUS_PARAMS_V1, _NV_GSYNC_STATUS_PARAMS_V2
  • BiasResource : NV_D3D11_META_COMMAND_EXECUTE_CONVOLUTION_EX_DESC, NV_D3D12_META_COMMAND_EXECUTE_CONVOLUTION_EX_DESC
  • binaryCurrentValue : _NVDRS_SETTING_V1
  • binaryDefaultValue : _NVDRS_SETTING_VALUES
  • binaryPredefinedValue : _NVDRS_SETTING_V1
  • binaryValue : _NVDRS_SETTING_VALUES
  • bInSaccade : _NV_FOVEATED_RENDERING_GAZE_DATA_PER_EYE
  • bInterlaced : NV_VIEW_TARGET_INFO
  • bInternalSlave : _NV_GSYNC_STATUS_PARAMS_V2
  • bIsCurAFRGroupNew : NV_GET_CURRENT_SLI_STATE_V1, NV_GET_CURRENT_SLI_STATE_V2
  • bIsDCHDriver : _NV_DISPLAY_DRIVER_INFO, _NV_DISPLAY_DRIVER_INFO_V2
  • bIsDDCPort : NV_I2C_INFO_V1, NV_I2C_INFO_V2, NV_I2C_INFO_V3
  • bIsDisplayInVRRMode : _NV_GET_VRR_INFO_V1
  • bIsEditable : _NV_GPU_PERF_PSTATES20_INFO_V2, NV_GPU_PERF_PSTATES20_INFO_V1, NV_GPU_PSTATE20_BASE_VOLTAGE_ENTRY_V1, NV_GPU_PSTATE20_CLOCK_ENTRY_V1
  • bIsExternalGpu : _NV_GPU_INFO_V1, _NV_GPU_INFO_V2
  • bIsMulDivSupported : _NV_GSYNC_CAPABILITIES_V3
  • bIsNVIDIAGameReadyPackage : _NV_DISPLAY_DRIVER_INFO, _NV_DISPLAY_DRIVER_INFO_V2
  • bIsNVIDIARTXNewFeatureBranchPackage : _NV_DISPLAY_DRIVER_INFO, _NV_DISPLAY_DRIVER_INFO_V2
  • bIsNVIDIARTXProductionBranchPackage : _NV_DISPLAY_DRIVER_INFO, _NV_DISPLAY_DRIVER_INFO_V2
  • bIsNVIDIAStudioPackage : _NV_DISPLAY_DRIVER_INFO, _NV_DISPLAY_DRIVER_INFO_V2
  • bIsPortIdSet : NV_I2C_INFO_V3
  • bIsPresent : NV_GPU_CLOCK_FREQUENCIES_V1, NV_GPU_CLOCK_FREQUENCIES_V2, NV_GPU_DYNAMIC_PSTATES_INFO_EX
  • bIsStereoSynced : _NV_GSYNC_STATUS
  • bIsSynced : _NV_GSYNC_STATUS
  • bIsSyncSignalAvailable : _NV_GSYNC_STATUS
  • bIsValidInfo : _NV_MONITOR_CAPABILITIES_V1
  • bIsVRREnabled : _NV_GET_VRR_INFO_V1
  • bIsVRRIndicatorEnabled : _NV_GET_VRR_INFO_V1
  • bIsVRRPossible : _NV_GET_VRR_INFO_V1
  • bIsVRRRequested : _NV_GET_VRR_INFO_V1
  • bitsPerComponent : _NVVIOCHANNELSTATUS, _NVVIOSTREAM
  • blackList : NV_INFOFRAME_PROPERTY
  • bLateLatchSupported : _NV_QUERY_LATELATCH_SUPPORT_PARAMS
  • bldChangeListNum : NV_DISPLAY_DRIVER_VERSION
  • blendingTexture : NV_SCANOUT_INTENSITY_DATA_V1, NV_SCANOUT_INTENSITY_DATA_V2
  • blockDim : _NVAPI_CU_KERNEL_LAUNCH_PARAMS, _NVAPI_CU_KERNEL_LAUNCH_PARAMS_EX
  • blockX : NVAPI_D3D12_CREATE_CUBIN_SHADER_PARAMS
  • blockY : NVAPI_D3D12_CREATE_CUBIN_SHADER_PARAMS
  • blockZ : NVAPI_D3D12_CREATE_CUBIN_SHADER_PARAMS
  • bLowLatencyBoost : _NV_SET_SLEEP_MODE_PARAMS
  • bLowLatencyMode : _NV_GET_SLEEP_STATUS_PARAMS, _NV_SET_SLEEP_MODE_PARAMS
  • bModifiedWSupported : _NV_QUERY_MODIFIED_W_SUPPORT_PARAMS
  • bMultiViewSupported : _NV_QUERY_MULTIVIEW_SUPPORT_PARAMS_V1
  • bNameIsAvailable : _NV_MANAGED_DEDICATED_DISPLAY_METADATA
  • boardId : _NV_GSYNC_CAPABILITIES_V1, _NV_GSYNC_CAPABILITIES_V2, _NV_GSYNC_CAPABILITIES_V3
  • boardID : _NVVIOCAPS
  • BoardNum : _NV_BOARD_INFO
  • bottom : _NV_RECT
  • bottom_bar : NV_INFOFRAME_VIDEO
  • boundingBox : _NV_SMP_ASSIST_SETUP_PARAMS_V1
  • BoundingRectOriginX : _NV_SMP_ASSIST_REMAPCBDATA_V1
  • BoundingRectOriginY : _NV_SMP_ASSIST_REMAPCBDATA_V1
  • BoundingRectSizeHeight : _NV_SMP_ASSIST_REMAPCBDATA_V1
  • BoundingRectSizeInvHeight : _NV_SMP_ASSIST_REMAPCBDATA_V1
  • BoundingRectSizeInvWidth : _NV_SMP_ASSIST_REMAPCBDATA_V1
  • BoundingRectSizeWidth : _NV_SMP_ASSIST_REMAPCBDATA_V1
  • boundingScissor : _NV_SMP_ASSIST_GET_CONSTANTS_V3
  • boundingViewport : _NV_SMP_ASSIST_GET_CONSTANTS_V3
  • bpc : _NV_COLOR_DATA_V3, _NV_COLOR_DATA_V4, _NV_COLOR_DATA_V5, _NV_DISPLAY_PORT_INFO_V1, NV_DISPLAY_PORT_CONFIG
  • bPositionIsAvailable : _NV_MANAGED_DEDICATED_DISPLAY_METADATA
  • bpp : _NV_MOSAIC_DISPLAY_SETTING_V1, NV_MOSAIC_DISPLAY_SETTING_V2
  • bPrimary : NV_DISPLAY_PATH, NV_VIEW_TARGET_INFO
  • bRemoveName : _NV_MANAGED_DEDICATED_DISPLAY_METADATA
  • bRemovePosition : _NV_MANAGED_DEDICATED_DISPLAY_METADATA
  • BResource : NV_D3D11_META_COMMAND_EXECUTE_GEMM_DESC, NV_D3D12_META_COMMAND_EXECUTE_GEMM_DESC
  • brief : NV_MOSAIC_TOPO_GROUP
  • brightnessPct : _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_COLOR_FIXED_PARAMS, _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_RGB_PARAMS, _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_RGBW_PARAMS, _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_SINGLE_COLOR_PARAMS
  • bSetName : _NV_MANAGED_DEDICATED_DISPLAY_METADATA
  • bSetPosition : _NV_MANAGED_DEDICATED_DISPLAY_METADATA
  • bSinglePassStereoSupported : _NV_QUERY_MULTIVIEW_SUPPORT_PARAMS_V1, _NV_QUERY_SINGLE_PASS_STEREO_SUPPORT_PARAMS_V1, _NV_QUERY_SINGLE_PASS_STEREO_SUPPORT_PARAMS_V2
  • bSinglePassStereoXYZWSupported : _NV_QUERY_MULTIVIEW_SUPPORT_PARAMS_V1, _NV_QUERY_SINGLE_PASS_STEREO_SUPPORT_PARAMS_V2
  • bSLIFocus : _NV_DISPLAYCONFIG_SOURCE_MODE_INFO_V1
  • bSMPAssistSupported : _NV_QUERY_SMP_ASSIST_SUPPORT_PARAMS_V1
  • bStereoEnable : _NV_DX_VIDEO_STEREO_INFO
  • bSupported : _NV_GPU_QUERY_ILLUMINATION_SUPPORT_PARM_V1
  • bSync : NV_GPU_CLIENT_ILLUM_DEVICE_SYNC_V1
  • bTestMode : _NVVIOINPUTCONFIG
  • BTimems : _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR
  • bus : NVLINK_DEVICE_INFO_V1
  • bUseGameSleep : _NV_GET_SLEEP_STATUS_PARAMS
  • bUseMarkersToOptimize : _NV_SET_SLEEP_MODE_PARAMS
  • bVariablePixelRateShadingSupported : _NV_D3D12_GRAPHICS_CAPS_V1, _NV_D3D1x_GRAPHICS_CAPS_V1, _NV_D3D1x_GRAPHICS_CAPS_V2
  • byteOffset : _NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_DESC, _NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_DESC


  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all variables with links to the structures/unions they belong to:

- c -

  • callback : _NV_GPU_CLIENT_UTILIZATION_PERIODIC_CALLBACK_SETTINGS_V1
  • callbackParam : NV_EVENT_REGISTER_CALLBACK
  • callbackPeriodms : _NV_GPU_CLIENT_PERIODIC_CALLBACK_SETTINGS_SUPER_V1
  • capFlags : _NV_GSYNC_CAPABILITIES_V1, _NV_GSYNC_CAPABILITIES_V2, _NV_GSYNC_CAPABILITIES_V3
  • caps : _NV_MONITOR_CAPABILITIES_V1
  • capsTbl : NVLINK_GET_CAPS_V1, NVLINK_LINK_STATUS_INFO_V1, NVLINK_LINK_STATUS_INFO_V2
  • captureStatus : _NVVIOINPUTSTATUS
  • cbSize : NV_I2C_INFO_V1, NV_I2C_INFO_V2, NV_I2C_INFO_V3
  • cc_blue_x : _NV_HDR_CAPABILITIES_V2, _NV_HDR_CAPABILITIES_V3
  • cc_blue_y : _NV_HDR_CAPABILITIES_V2, _NV_HDR_CAPABILITIES_V3
  • cc_green_x : _NV_HDR_CAPABILITIES_V2, _NV_HDR_CAPABILITIES_V3
  • cc_green_y : _NV_HDR_CAPABILITIES_V2, _NV_HDR_CAPABILITIES_V3
  • cc_red_x : _NV_HDR_CAPABILITIES_V2, _NV_HDR_CAPABILITIES_V3
  • cc_red_y : _NV_HDR_CAPABILITIES_V2, _NV_HDR_CAPABILITIES_V3
  • cc_white_x : _NV_HDR_CAPABILITIES_V2, _NV_HDR_CAPABILITIES_V3
  • cc_white_y : _NV_HDR_CAPABILITIES_V2, _NV_HDR_CAPABILITIES_V3
  • ceaId : NV_TIMING_FLAG
  • centerHeight : _NV_MRS_CUSTOM_CONFIG_V1, _NV_MRS_INSTANCED_STEREO_CONFIG_V1
  • centerWidth : _NV_MRS_CUSTOM_CONFIG_V1, _NV_MRS_INSTANCED_STEREO_CONFIG_V1
  • centerX : _NV_MRS_CUSTOM_CONFIG_V1, _NV_MRS_INSTANCED_STEREO_CONFIG_V1
  • centerY : _NV_MRS_CUSTOM_CONFIG_V1, _NV_MRS_INSTANCED_STEREO_CONFIG_V1
  • channel : _NVVIOSTREAM
  • channelCount : NV_INFOFRAME_AUDIO
  • checkStatus : _NVAPI_CHECK_DRIVER_MATCHING_IDENTIFIER_EX_PARAMS_V1
  • ClipToWindowSplitsX : _NV_SMP_ASSIST_REMAPCBDATA_V1
  • ClipToWindowSplitsY : _NV_SMP_ASSIST_REMAPCBDATA_V1
  • ClipToWindowX : _NV_SMP_ASSIST_REMAPCBDATA_V1
  • ClipToWindowY : _NV_SMP_ASSIST_REMAPCBDATA_V1
  • ClipToWindowZ : _NV_SMP_ASSIST_REMAPCBDATA_V1
  • clocks : _NV_GPU_PERF_PSTATES20_INFO_V2, NV_GPU_PERF_PSTATES20_INFO_V1, NV_GPU_PERF_PSTATES_INFO_V1, NV_GPU_PERF_PSTATES_INFO_V2
  • ClockType : NV_GPU_CLOCK_FREQUENCIES_V2
  • cloneGroup : _NV_MOSAIC_GRID_TOPO_DISPLAY_V1, _NV_MOSAIC_GRID_TOPO_DISPLAY_V2
  • cloneImportance : _NV_SCANOUT_INFORMATION
  • cmd : _NV_COLOR_DATA_V1, _NV_COLOR_DATA_V2, _NV_COLOR_DATA_V3, _NV_COLOR_DATA_V4, _NV_COLOR_DATA_V5, _NV_HDR_COLOR_DATA_V1, _NV_HDR_COLOR_DATA_V2, NV_INFOFRAME_DATA
  • cnc0SupportGraphicsTextContent : _NV_MONITOR_CAPS_VSDB
  • cnc1SupportPhotoContent : _NV_MONITOR_CAPS_VSDB
  • cnc2SupportCinemaContent : _NV_MONITOR_CAPS_VSDB
  • cnc3SupportGameContent : _NV_MONITOR_CAPS_VSDB
  • codingExtensionType : NV_INFOFRAME_AUDIO
  • codingType : NV_INFOFRAME_AUDIO
  • colCount : NV_MOSAIC_TOPO_DETAILS, NV_MOSAIC_TOPOLOGY
  • colorB : _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_RGB_PARAMS, _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_RGBW_PARAMS
  • colorConversion : _NVVIOOUTPUTCONFIG_V1, _NVVIOOUTPUTCONFIG_V2, _NVVIOOUTPUTCONFIG_V3
  • colorDepth : _NV_RESOLUTION
  • colorFixed : _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_V1
  • colorFixedParams : _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_COLOR_FIXED, _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR_COLOR_FIXED
  • colorFormat : _NV_COLOR_DATA_V1, _NV_COLOR_DATA_V2, _NV_COLOR_DATA_V3, _NV_COLOR_DATA_V4, _NV_COLOR_DATA_V5, _NV_DISPLAY_PORT_INFO_V1, _NV_DISPLAYCONFIG_SOURCE_MODE_INFO_V1, _NV_MONITOR_COLOR_DATA, NV_CUSTOM_DISPLAY, NV_DISPLAY_PATH, NV_DISPLAY_PORT_CONFIG
  • colorG : _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_RGB_PARAMS, _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_RGBW_PARAMS
  • colorimetry : _NV_COLOR_DATA_V1, _NV_COLOR_DATA_V2, _NV_COLOR_DATA_V3, _NV_COLOR_DATA_V4, _NV_COLOR_DATA_V5, _NV_DISPLAY_PORT_INFO_V1, _NV_HDR_CAPABILITIES_V2, _NV_HDR_CAPABILITIES_V3, NV_DISPLAY_PORT_CONFIG, NV_INFOFRAME_VIDEO
  • colorMatrix : _NVVIOCOLORCONVERSION
  • colorOffset : _NVVIOCOLORCONVERSION
  • colorR : _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_RGB_PARAMS, _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_RGBW_PARAMS
  • colorScale : _NVVIOCOLORCONVERSION
  • colorSelectionPolicy : _NV_COLOR_DATA_V4, _NV_COLOR_DATA_V5
  • colorSpace : _NVVIOCHANNELSTATUS, NV_INFOFRAME_VIDEO
  • colorW : _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_RGBW_PARAMS
  • columns : _NV_MOSAIC_GRID_TOPO_V1, _NV_MOSAIC_GRID_TOPO_V2
  • commandLine : _NVDRS_APPLICATION_V4
  • companionBufferCount : _NV_D3D12_MOSAIC_GETCOMPANIONALLOCATIONS
  • compositeSafe : _NVVIOCOLORCONVERSION
  • compositeSyncType : _NVVIOOUTPUTCONFIG_V1, _NVVIOOUTPUTCONFIG_V2, _NVVIOOUTPUTCONFIG_V3
  • compositeTerminate : _NVVIOOUTPUTCONFIG_V1, _NVVIOOUTPUTCONFIG_V2, _NVVIOOUTPUTCONFIG_V3
  • compRange : _NVVIOOUTPUTCONFIG_V1, _NVVIOOUTPUTCONFIG_V2, _NVVIOOUTPUTCONFIG_V3
  • compSyncIn : _NVVIOOUTPUTSTATUS
  • computeGpus : _NV_COMPUTE_GPU_TOPOLOGY_V2, NV_COMPUTE_GPU_TOPOLOGY_V1
  • configurationOptions : NV_GPU_ECC_STATUS_INFO
  • connected : NVLINK_LINK_STATUS_INFO_V1, NVLINK_LINK_STATUS_INFO_V2
  • connector : _NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_V1, _NV_GSYNC_GPU, NV_DISPLAY_PATH
  • connectorType : _NV_GPU_DISPLAYIDS, _NV_MONITOR_CAPABILITIES_V1
  • ConservativeRaster : _NV_D3D11_FEATURE_DATA_RASTERIZER_SUPPORT
  • ConservativeRasterEnable : NvAPI_D3D11_RASTERIZER_DESC_EX
  • ConstantPadVal : NV_META_COMMAND_PADDING_DESC
  • ContentType : _NV_VRS_HELPER_ENABLE_PARAMS_V1
  • contentTypes : NV_INFOFRAME_VIDEO
  • controller : NV_GPU_THERMAL_SETTINGS_V1, NV_GPU_THERMAL_SETTINGS_V2
  • ConvertToFastGS : NvAPI_D3D11_CREATE_GEOMETRY_SHADER_EX_V5, NVAPI_D3D12_PSO_GEOMETRY_SHADER_DESC_V5
  • count : _NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_USAGE_COUNT, _NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_USAGE_COUNT, NV_DISPLAY_PATH_INFO, NV_DISPLAY_PATH_INFO_V3, NV_GPU_THERMAL_SETTINGS_V1, NV_GPU_THERMAL_SETTINGS_V2, NV_MOSAIC_TOPO_GROUP, NV_VIEW_TARGET_INFO
  • CoverageToColor : _NV_D3D11_FEATURE_DATA_RASTERIZER_SUPPORT
  • CoverageToColorEnable : NvAPI_D3D11_RASTERIZER_DESC_EX, NVAPI_D3D12_PSO_RASTERIZER_STATE_DESC_V1
  • CoverageToColorRTIndex : NvAPI_D3D11_RASTERIZER_DESC_EX, NVAPI_D3D12_PSO_RASTERIZER_STATE_DESC_V1
  • CResource : NV_D3D11_META_COMMAND_EXECUTE_GEMM_DESC, NV_D3D12_META_COMMAND_EXECUTE_GEMM_DESC
  • cscOverride : _NVVIOOUTPUTCONFIG_V1, _NVVIOOUTPUTCONFIG_V2, _NVVIOOUTPUTCONFIG_V3
  • ctrlMode : _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_V1
  • ctrlModeMask : _NV_GPU_CLIENT_ILLUM_DEVICE_INFO_V1
  • CullMode : NvAPI_D3D11_RASTERIZER_DESC_EX
  • curAvailableDedicatedVideoMemory : NV_DISPLAY_DRIVER_MEMORY_INFO_V2, NV_DISPLAY_DRIVER_MEMORY_INFO_V3, NV_GPU_MEMORY_INFO_EX_V1
  • curLaneCount : _NV_DISPLAY_PORT_INFO_V1
  • curLinkRate : _NV_DISPLAY_PORT_INFO_V1
  • current : NV_GPU_ECC_ERROR_INFO
  • currentAFRIndex : NV_GET_CURRENT_SLI_STATE_V1, NV_GET_CURRENT_SLI_STATE_V2
  • currentDockPolicy : NV_LID_DOCK_PARAMS
  • currentDockState : NV_LID_DOCK_PARAMS
  • currentLidPolicy : NV_LID_DOCK_PARAMS
  • currentLidState : NV_LID_DOCK_PARAMS
  • currentlyCapableOfVRR : _NV_MONITOR_CAPS_GENERIC
  • currentSizeInBytes : _NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_POSTBUILD_INFO_CURRENT_SIZE_DESC, _NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_ARRAY_POSTBUILD_INFO_CURRENT_SIZE_DESC
  • currentTemp : NV_GPU_THERMAL_SETTINGS_V1, NV_GPU_THERMAL_SETTINGS_V2
  • cycleType : _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR


  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all variables with links to the structures/unions they belong to:

- d -

  • data : _NV_COLOR_DATA_V1, _NV_COLOR_DATA_V2, _NV_COLOR_DATA_V3, _NV_COLOR_DATA_V4, _NV_COLOR_DATA_V5, _NV_GPU_CLIENT_ILLUM_DEVICE_INFO_V1, _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_COLOR_FIXED, _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_RGB, _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_RGBW, _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_SINGLE_COLOR, _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_V1, _NV_GPU_CLIENT_ILLUM_ZONE_INFO_V1, _NV_MONITOR_CAPABILITIES_V1, NV_GPU_PSTATE20_CLOCK_ENTRY_V1
  • data1 : NvGUID
  • data2 : NvGUID
  • data3 : NvGUID
  • data4 : NvGUID
  • dataFormat : _NVVIODATAFORMATDETAIL, _NVVIOOUTPUTCONFIG_V1, _NVVIOOUTPUTCONFIG_V2, _NVVIOOUTPUTCONFIG_V3
  • dataIntegrityCheckEnabled : _NVVIOOUTPUTSTATUS
  • dataIntegrityCheckErrorCount : _NVVIOOUTPUTSTATUS
  • dataIntegrityCheckFailed : _NVVIOOUTPUTSTATUS
  • DataType : NV_META_COMMAND_TENSOR_DESC
  • day : _NV_LICENSE_EXPIRY_DETAILS
  • dedicatedVideoMemory : NV_DISPLAY_DRIVER_MEMORY_INFO_V1, NV_DISPLAY_DRIVER_MEMORY_INFO_V2, NV_DISPLAY_DRIVER_MEMORY_INFO_V3, NV_GPU_MEMORY_INFO_EX_V1
  • dedicatedVideoMemoryEvictionCount : NV_DISPLAY_DRIVER_MEMORY_INFO_V3, NV_GPU_MEMORY_INFO_EX_V1
  • dedicatedVideoMemoryEvictionsSize : NV_DISPLAY_DRIVER_MEMORY_INFO_V3, NV_GPU_MEMORY_INFO_EX_V1
  • dedicatedVideoMemoryPromotionCount : NV_GPU_MEMORY_INFO_EX_V1
  • dedicatedVideoMemoryPromotionsSize : NV_GPU_MEMORY_INFO_EX_V1
  • defaultMaxTemp : NV_GPU_THERMAL_SETTINGS_V1, NV_GPU_THERMAL_SETTINGS_V2
  • defaultMinTemp : NV_GPU_THERMAL_SETTINGS_V1, NV_GPU_THERMAL_SETTINGS_V2
  • defaultValue : _SettingDWORDNameString, _SettingWSTRINGNameString
  • densityScaleX : _NV_MRS_CUSTOM_CONFIG_V1, _NV_MRS_INSTANCED_STEREO_CONFIG_V1
  • densityScaleY : _NV_MRS_CUSTOM_CONFIG_V1, _NV_MRS_INSTANCED_STEREO_CONFIG_V1
  • depth : _NV_COLOR_DATA_V5, NV_CUSTOM_DISPLAY, NV_DISPLAY_PATH
  • DepthBias : NvAPI_D3D11_RASTERIZER_DESC_EX
  • DepthBiasClamp : NvAPI_D3D11_RASTERIZER_DESC_EX
  • DepthClipEnable : NvAPI_D3D11_RASTERIZER_DESC_EX
  • desc : NVAPI_D3D12_GET_CUDA_INDEPENDENT_DESCRIPTOR_OBJECT_PARAMS
  • DescA : NV_META_COMMAND_CREATE_GEMM_DESC
  • DescB : NV_META_COMMAND_CREATE_GEMM_DESC
  • DescBias : NV_META_COMMAND_CREATE_CONVOLUTION_EX_DESC
  • DescC : NV_META_COMMAND_CREATE_GEMM_DESC
  • DescFilter : NV_META_COMMAND_CREATE_CONVOLUTION_EX_DESC
  • DescIn : NV_META_COMMAND_CREATE_CONVOLUTION_EX_DESC
  • DescOut : NV_META_COMMAND_CREATE_CONVOLUTION_EX_DESC, NV_META_COMMAND_CREATE_GEMM_DESC
  • descsLayout : _NVAPI_D3D12_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_INPUTS_EX
  • desired_content_max_frame_average_luminance : _NV_HDR_CAPABILITIES_V1, _NV_HDR_CAPABILITIES_V2, _NV_HDR_CAPABILITIES_V3
  • desired_content_max_luminance : _NV_HDR_CAPABILITIES_V1, _NV_HDR_CAPABILITIES_V2, _NV_HDR_CAPABILITIES_V3
  • desired_content_min_luminance : _NV_HDR_CAPABILITIES_V1, _NV_HDR_CAPABILITIES_V2, _NV_HDR_CAPABILITIES_V3
  • destAccelerationStructureData : _NVAPI_D3D12_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_DESC_EX
  • destBuffer : _NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_POSTBUILD_INFO_DESC, _NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_ARRAY_POSTBUILD_INFO_DESC
  • destDisplacementMicromapArrayData : _NVAPI_D3D12_BUILD_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_DESC
  • destOpacityMicromapArrayData : _NVAPI_D3D12_BUILD_RAYTRACING_OPACITY_MICROMAP_ARRAY_DESC
  • details : _NV_DISPLAYCONFIG_PATH_TARGET_INFO_V1, _NV_DISPLAYCONFIG_PATH_TARGET_INFO_V2
  • device : NVLINK_DEVICE_INFO_V1
  • deviceId : NV_CHIPSET_INFO_v1, NV_CHIPSET_INFO_v2, NV_CHIPSET_INFO_v3, NV_CHIPSET_INFO_v4
  • deviceIdFlags : NVLINK_DEVICE_INFO_V1
  • deviceMask : NV_DISPLAY_PATH, NV_VIEW_TARGET_INFO
  • devices : _NV_GPU_CLIENT_ILLUM_DEVICE_INFO_PARAMS_V1, NV_GPU_CLIENT_ILLUM_DEVICE_CONTROL_PARAMS_V1
  • deviceType : NVLINK_DEVICE_INFO_V1
  • deviceUUID : NVLINK_DEVICE_INFO_V1
  • Dilation : NV_META_COMMAND_CREATE_CONVOLUTION_EX_DESC
  • DimensionCount : NV_META_COMMAND_CREATE_CONVOLUTION_EX_DESC, NV_META_COMMAND_TENSOR_DESC
  • dipSwitch : _NVVIOCAPS
  • dipSwitchReserved : _NVVIOCAPS
  • Direction : NV_META_COMMAND_CREATE_CONVOLUTION_EX_DESC
  • disableVirtualModeSupport : _NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_V1
  • displacementMicromapArray : _NVAPI_D3D12_RAYTRACING_GEOMETRY_DMM_ATTACHMENT_DESC, _NVAPI_RELOCATE_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PARAMS_V1
  • display_data : _NV_HDR_CAPABILITIES_V1, _NV_HDR_CAPABILITIES_V2, _NV_HDR_CAPABILITIES_V3
  • displayCount : _NV_MOSAIC_GRID_TOPO_V1, _NV_MOSAIC_GRID_TOPO_V2, NV_MOSAIC_DISPLAY_TOPO_STATUS
  • displayId : _NV_DISPLAYCONFIG_PATH_TARGET_INFO_V1, _NV_DISPLAYCONFIG_PATH_TARGET_INFO_V2, _NV_GPU_DISPLAYIDS, _NV_GSYNC_DISPLAY, _NV_MANAGED_DEDICATED_DISPLAY_INFO, _NV_MANAGED_DEDICATED_DISPLAY_METADATA, _NV_MOSAIC_GRID_TOPO_DISPLAY_V1, _NV_MOSAIC_GRID_TOPO_DISPLAY_V2, NV_GET_PREFERRED_STEREO_DISPLAY_V1, NV_MOSAIC_DISPLAY_TOPO_STATUS, NV_SET_PREFERRED_STEREO_DISPLAY_V1
  • displayMask : NV_I2C_INFO_V1, NV_I2C_INFO_V2, NV_I2C_INFO_V3
  • displayOutputId : NV_MOSAIC_TOPO_DETAILS, NV_MOSAIC_TOPOLOGY
  • displayPrimary_x0 : _NV_HDR_CAPABILITIES_V1, _NV_HDR_CAPABILITIES_V2, _NV_HDR_CAPABILITIES_V3, _NV_HDR_COLOR_DATA_V1, _NV_HDR_COLOR_DATA_V2, _NV_HDR_METADATA_V1
  • displayPrimary_x1 : _NV_HDR_CAPABILITIES_V1, _NV_HDR_CAPABILITIES_V2, _NV_HDR_CAPABILITIES_V3, _NV_HDR_COLOR_DATA_V1, _NV_HDR_COLOR_DATA_V2, _NV_HDR_METADATA_V1
  • displayPrimary_x2 : _NV_HDR_CAPABILITIES_V1, _NV_HDR_CAPABILITIES_V2, _NV_HDR_CAPABILITIES_V3, _NV_HDR_COLOR_DATA_V1, _NV_HDR_COLOR_DATA_V2, _NV_HDR_METADATA_V1
  • displayPrimary_y0 : _NV_HDR_CAPABILITIES_V1, _NV_HDR_CAPABILITIES_V2, _NV_HDR_CAPABILITIES_V3, _NV_HDR_COLOR_DATA_V1, _NV_HDR_COLOR_DATA_V2, _NV_HDR_METADATA_V1
  • displayPrimary_y1 : _NV_HDR_CAPABILITIES_V1, _NV_HDR_CAPABILITIES_V2, _NV_HDR_CAPABILITIES_V3, _NV_HDR_COLOR_DATA_V1, _NV_HDR_COLOR_DATA_V2, _NV_HDR_METADATA_V1
  • displayPrimary_y2 : _NV_HDR_CAPABILITIES_V1, _NV_HDR_CAPABILITIES_V2, _NV_HDR_CAPABILITIES_V3, _NV_HDR_COLOR_DATA_V1, _NV_HDR_COLOR_DATA_V2, _NV_HDR_METADATA_V1
  • displays : _NV_MOSAIC_GRID_TOPO_V1, _NV_MOSAIC_GRID_TOPO_V2, NV_MOSAIC_DISPLAY_TOPO_STATUS
  • displaySettings : _NV_MOSAIC_GRID_TOPO_V1, _NV_MOSAIC_GRID_TOPO_V2, _NV_MOSAIC_SUPPORTED_TOPO_INFO_V1, _NV_MOSAIC_SUPPORTED_TOPO_INFO_V2
  • displaySettingsCount : _NV_MOSAIC_SUPPORTED_TOPO_INFO_V1, _NV_MOSAIC_SUPPORTED_TOPO_INFO_V2
  • displayWhitePoint_x : _NV_HDR_CAPABILITIES_V1, _NV_HDR_CAPABILITIES_V2, _NV_HDR_CAPABILITIES_V3, _NV_HDR_COLOR_DATA_V1, _NV_HDR_COLOR_DATA_V2, _NV_HDR_METADATA_V1
  • displayWhitePoint_y : _NV_HDR_CAPABILITIES_V1, _NV_HDR_CAPABILITIES_V2, _NV_HDR_CAPABILITIES_V3, _NV_HDR_COLOR_DATA_V1, _NV_HDR_COLOR_DATA_V2, _NV_HDR_METADATA_V1
  • dm_version : _NV_HDR_CAPABILITIES_V2, _NV_HDR_CAPABILITIES_V3
  • dmmAttachment : _NVAPI_D3D12_RAYTRACING_GEOMETRY_DMM_TRIANGLES_DESC
  • dmmTriangles : _NVAPI_D3D12_RAYTRACING_GEOMETRY_DESC_EX
  • domain : NV_GPU_CLOCK_FREQUENCIES_V1, NV_GPU_CLOCK_FREQUENCIES_V2, NVLINK_DEVICE_INFO_V1
  • domainId : NV_GPU_PERF_PSTATES_INFO_V1, NV_GPU_PERF_PSTATES_INFO_V2, NV_GPU_PSTATE20_BASE_VOLTAGE_ENTRY_V1, NV_GPU_PSTATE20_CLOCK_ENTRY_V1
  • DontUseViewportOrder : NvAPI_D3D11_CREATE_GEOMETRY_SHADER_EX_V5, NVAPI_D3D12_PSO_GEOMETRY_SHADER_DESC_V5
  • doubleBitErrors : NV_GPU_ECC_ERROR_INFO
  • downmixInhibit : NV_INFOFRAME_AUDIO
  • dpcd_ver : _NV_DISPLAY_PORT_INFO_V1
  • driver : _NVVIOCAPS
  • driverEndTime : _NV_LATENCY_RESULT_PARAMS::FrameReport
  • driverExpandDefaultHdrParameters : _NV_HDR_CAPABILITIES_V1, _NV_HDR_CAPABILITIES_V2, _NV_HDR_CAPABILITIES_V3
  • driverReloadAllowed : _NV_MOSAIC_GRID_TOPO_V1, _NV_MOSAIC_GRID_TOPO_V2
  • driverStartTime : _NV_LATENCY_RESULT_PARAMS::FrameReport
  • driverVersion : _NV_DISPLAY_DRIVER_INFO, _NV_DISPLAY_DRIVER_INFO_V2
  • drvVersion : NV_DISPLAY_DRIVER_VERSION
  • dst0u : NvShaderExtnStruct
  • dst1u : NvShaderExtnStruct
  • dv_static_metadata : _NV_HDR_CAPABILITIES_V2, _NV_HDR_CAPABILITIES_V3
  • dwVersion : _NV_DX_VIDEO_STEREO_INFO, _NV_JOIN_PRESENT_BARRIER_PARAMS, _NV_PRESENT_BARRIER_FRAME_STATISTICS
  • dynamicRange : _NV_COLOR_DATA_V2, _NV_COLOR_DATA_V3, _NV_COLOR_DATA_V4, _NV_COLOR_DATA_V5, _NV_DISPLAY_PORT_INFO_V1, NV_DISPLAY_PORT_CONFIG
  • dynSharedMemBytes : _NVAPI_CU_KERNEL_LAUNCH_PARAMS, _NVAPI_CU_KERNEL_LAUNCH_PARAMS_EX, NVAPI_D3D12_CREATE_CUBIN_SHADER_PARAMS


  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all variables with links to the structures/unions they belong to:

- e -

  • EDID861ExtRev : _NV_HDMI_SUPPORT_INFO_V1, _NV_HDMI_SUPPORT_INFO_V2
  • EDID_Data : NV_EDID_V1, NV_EDID_V2, NV_EDID_V3
  • edidId : NV_EDID_V3
  • eEyeIndex : _NV_SMP_ASSIST_ENABLE_PARAMS_V1, _NV_SMP_ASSIST_GET_CONSTANTS_V3
  • eFormat : _NV_DX_VIDEO_STEREO_INFO
  • eLMSConfig : _NV_SMP_ASSIST_SETUP_PARAMS_V1
  • eMRSConfig : _NV_SMP_ASSIST_SETUP_PARAMS_V1
  • enable422Filter : _NVVIOOUTPUTCONFIG_V1, _NVVIOOUTPUTCONFIG_V2, _NVVIOOUTPUTCONFIG_V3
  • enableAlphaKeyComposite : _NVVIOOUTPUTCONFIG_V1, _NVVIOOUTPUTCONFIG_V2, _NVVIOOUTPUTCONFIG_V3
  • enableANCTimeCodeGeneration : _NVVIOOUTPUTCONFIG_V1, _NVVIOOUTPUTCONFIG_V2, _NVVIOOUTPUTCONFIG_V3
  • enableAudioBlanking : _NVVIOOUTPUTCONFIG_V3
  • enableComposite : _NVVIOOUTPUTCONFIG_V1, _NVVIOOUTPUTCONFIG_V2, _NVVIOOUTPUTCONFIG_V3
  • enabled : NV_MOSAIC_TOPO_BRIEF
  • enableDataIntegrityCheck : _NVVIOOUTPUTCONFIG_V1, _NVVIOOUTPUTCONFIG_V2, _NVVIOOUTPUTCONFIG_V3
  • EnableDBT : NVAPI_D3D12_PSO_ENABLE_DEPTH_BOUND_TEST_DESC_V1
  • enableExclusiveScissorRect : _NV_D3D11_EXCLUSIVE_SCISSOR_RECT_DESC_V1
  • enableFullColorRange : _NVVIOOUTPUTCONFIG_V1, _NVVIOOUTPUTCONFIG_V2, _NVVIOOUTPUTCONFIG_V3
  • enableRGBData : _NVVIOOUTPUTCONFIG_V1, _NVVIOOUTPUTCONFIG_V2, _NVVIOOUTPUTCONFIG_V3
  • enableVariablePixelShadingRate : _NV_D3D11_VIEWPORT_SHADING_RATE_DESC_V1
  • EndPadding : NV_META_COMMAND_CREATE_CONVOLUTION_EX_DESC
  • errorFlags : NV_MOSAIC_DISPLAY_TOPO_STATUS
  • eSMPAssistLevel : _NV_QUERY_SMP_ASSIST_SUPPORT_PARAMS_V1, _NV_SMP_ASSIST_GET_CONSTANTS_V3, _NV_SMP_ASSIST_INITIALIZE_PARAMS_V1
  • eSMPAssistType : _NV_QUERY_SMP_ASSIST_SUPPORT_PARAMS_V1, _NV_SMP_ASSIST_GET_CONSTANTS_V3, _NV_SMP_ASSIST_INITIALIZE_PARAMS_V1, _NV_SMP_ASSIST_UPDATE_INSTANCEDSTEREO_DATA_PARAMS_V1
  • etc : _NV_TIMING
  • eventId : NV_EVENT_REGISTER_CALLBACK
  • ExecutionDirtyState : NVAPI_META_COMMAND_DESC
  • expansionEnable : _NVVIOSTREAM
  • extendedColorimetry : NV_INFOFRAME_VIDEO
  • extendedRevision : _NV_GSYNC_CAPABILITIES_V2, _NV_GSYNC_CAPABILITIES_V3


  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all variables with links to the structures/unions they belong to:

- f -

  • fA : _NV_MODIFIED_W_COEFFICIENTS
  • fallTimems : _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR
  • fAReserved : _NV_MODIFIED_W_COEFFICIENTS
  • fastNvLinkReads : _NV_MULTIGPU_CAPS_V2
  • fB : _NV_MODIFIED_W_COEFFICIENTS
  • fBReserved : _NV_MODIFIED_W_COEFFICIENTS
  • featureCode : _NV_LICENSE_FEATURE_DETAILS_V1, _NV_LICENSE_FEATURE_DETAILS_V2, _NV_LICENSE_FEATURE_DETAILS_V3, _NV_LICENSE_FEATURE_DETAILS_V4
  • featureId : NVAPI_ANSEL_FEATURE_CONFIGURATION_STRUCT
  • featureState : NVAPI_ANSEL_FEATURE_CONFIGURATION_STRUCT
  • fEyeOpenness : _NV_FOVEATED_RENDERING_GAZE_DATA_PER_EYE
  • fFrameRate : _NVVIOVIDEOMODE
  • fGammaValueB : _NVVIOGAMMACORRECTION
  • fGammaValueG : _NVVIOGAMMACORRECTION
  • fGammaValueR : _NVVIOGAMMACORRECTION
  • fGazeDirection : _NV_FOVEATED_RENDERING_GAZE_DATA_PER_EYE
  • fGazeNormalizedLocation : _NV_FOVEATED_RENDERING_GAZE_DATA_PER_EYE
  • fGazeOrigin_mm : _NV_FOVEATED_RENDERING_GAZE_DATA_PER_EYE
  • fGazeVelocity : _NV_FOVEATED_RENDERING_GAZE_DATA_PER_EYE
  • fHorizontalFOV : _NV_GAZE_HANDLER_INIT_PARAMS_V1, _NV_GAZE_HANDLER_INIT_PARAMS_V2
  • fields : _NVVIOCONFIG_V1, _NVVIOCONFIG_V2, _NVVIOCONFIG_V3
  • fileInFolder : _NVDRS_APPLICATION_V2, _NVDRS_APPLICATION_V3, _NVDRS_APPLICATION_V4
  • FillMode : NvAPI_D3D11_RASTERIZER_DESC_EX
  • FilterResource : NV_D3D11_META_COMMAND_EXECUTE_CONVOLUTION_EX_DESC, NV_D3D12_META_COMMAND_EXECUTE_CONVOLUTION_EX_DESC
  • fInnermostRadii : _NV_FOVEATED_RENDERING_CUSTOM_FOVEATION_PATTERN_PRESET_DESC_V1
  • firmWare : _NVVIOCAPS
  • firmwareVersion : _NV_GPU_GSP_INFO_V1
  • FirstArraySlice : _NV_TEX2D_ARRAY_SRRV
  • flag : _NV_TIMING_INPUT, tagNV_TIMINGEXT
  • flags : _NV_COMPUTE_GPU, _NV_FOVEATED_RENDERING_DESC_V1, _NV_FOVEATED_RENDERING_UPDATE_GAZE_DATA_PARAMS, _NV_GAZE_HANDLER_INIT_PARAMS_V1, _NV_GAZE_HANDLER_INIT_PARAMS_V2, _NV_SMP_ASSIST_INITIALIZE_PARAMS_V1, _NV_VRS_HELPER_ENABLE_PARAMS_V1, _NV_VRS_HELPER_INIT_PARAMS_V1, _NV_VRS_HELPER_LATCH_GAZE_PARAMS_V1, _NVAPI_D3D12_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_INPUTS_EX, _NVAPI_D3D12_BUILD_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_INPUTS, _NVAPI_D3D12_BUILD_RAYTRACING_OPACITY_MICROMAP_ARRAY_INPUTS, _NVAPI_D3D12_RAYTRACING_GEOMETRY_DESC_EX, _NVAPI_D3D12_SET_CREATE_PIPELINE_STATE_OPTIONS_PARAMS_V1, NV_CHIPSET_INFO_v2, NV_CHIPSET_INFO_v3, NV_CHIPSET_INFO_v4, NV_COMPUTE_GPU_TOPOLOGY_V1, NV_GPU_DYNAMIC_PSTATES_INFO_EX, NV_GPU_PERF_PSTATES_INFO_V1, NV_GPU_PERF_PSTATES_INFO_V2
  • Flags : NV_META_COMMAND_TENSOR_DESC
  • flags : NvAPI_D3D11_CREATE_FASTGS_EXPLICIT_DESC_V1, NVAPI_D3D12_CREATE_CUBIN_SHADER_PARAMS, NVAPI_D3D12_PSO_CREATE_FASTGS_EXPLICIT_DESC_V1
  • flagsRsvd : _NV_SET_REFLEX_SYNC_PARAMS
  • FlipInSyncCount : _NV_PRESENT_BARRIER_FRAME_STATISTICS
  • flipQueueLength : _NVVIOOUTPUTCONFIG_V1, _NVVIOOUTPUTCONFIG_V2, _NVVIOOUTPUTCONFIG_V3
  • fMiddleRadii : _NV_FOVEATED_RENDERING_CUSTOM_FOVEATION_PATTERN_PRESET_DESC_V1
  • forcedDockMechanismPresent : NV_LID_DOCK_PARAMS
  • forcedLidMechanismPresent : NV_LID_DOCK_PARAMS
  • ForcedSampleCount : NvAPI_D3D11_RASTERIZER_DESC_EX, NVAPI_D3D12_PSO_RASTERIZER_STATE_DESC_V1
  • ForceFastGS : NvAPI_D3D11_CREATE_GEOMETRY_SHADER_EX_V5, NVAPI_D3D12_PSO_GEOMETRY_SHADER_DESC_V5
  • Format : _NV_D3D11_SHADING_RATE_RESOURCE_VIEW_DESC_V1
  • format : _NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_DESC, _NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_USAGE_COUNT, _NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_DESC, _NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_USAGE_COUNT
  • FoveationPatternCustomPresetDesc : _NV_FOVEATED_RENDERING_DESC_V1
  • FoveationPatternPreset : _NV_FOVEATED_RENDERING_DESC_V1
  • fPeripheralRadii : _NV_FOVEATED_RENDERING_CUSTOM_FOVEATION_PATTERN_PRESET_DESC_V1
  • fPupilDiameter_mm : _NV_FOVEATED_RENDERING_GAZE_DATA_PER_EYE
  • frameID : _NV_ASYNC_FRAME_MARKER_PARAMS_V1, _NV_LATENCY_MARKER_PARAMS, _NV_LATENCY_RESULT_PARAMS::FrameReport
  • frameIntervalUs : _NV_GET_VIRTUAL_REFRESH_RATE_DATA_V1, _NV_SET_VIRTUAL_REFRESH_RATE_DATA_V1
  • frameLockEnable : _NVVIOOUTPUTCONFIG_V1, _NVVIOOUTPUTCONFIG_V2, _NVVIOOUTPUTCONFIG_V3, _NVVIOOUTPUTSTATUS
  • frameReport : _NV_LATENCY_RESULT_PARAMS
  • freq : _NV_MOSAIC_DISPLAY_SETTING_V1, NV_GPU_PERF_PSTATES_INFO_V1, NV_GPU_PERF_PSTATES_INFO_V2, NV_MOSAIC_DISPLAY_SETTING_V2
  • freq_kHz : NV_GPU_PSTATE20_CLOCK_ENTRY_V1
  • freqDelta_kHz : NV_GPU_PSTATE20_CLOCK_ENTRY_V1
  • frequency : NV_GPU_CLOCK_FREQUENCIES_V1, NV_GPU_CLOCK_FREQUENCIES_V2
  • fReserved : _NV_MODIFIED_W_COEFFICIENTS
  • FrontCounterClockwise : NvAPI_D3D11_RASTERIZER_DESC_EX
  • full_frame_peak_luminance_index : _NV_HDR_CAPABILITIES_V3
  • Function : NV_META_COMMAND_ACTIVATION_DESC
  • function : NVLINK_DEVICE_INFO_V1
  • FuseDesc : NV_META_COMMAND_CREATE_CONVOLUTION_EX_FUSED_DESC
  • Future10 : NV_INFOFRAME_AUDIO
  • Future12 : NV_INFOFRAME_AUDIO
  • Future17 : NV_INFOFRAME_VIDEO
  • Future2x : NV_INFOFRAME_AUDIO
  • Future3x : NV_INFOFRAME_AUDIO
  • Future47 : NV_INFOFRAME_VIDEO
  • Future52 : NV_INFOFRAME_AUDIO
  • Future6 : NV_INFOFRAME_AUDIO
  • Future7 : NV_INFOFRAME_AUDIO
  • Future8 : NV_INFOFRAME_AUDIO
  • Future9 : NV_INFOFRAME_AUDIO
  • fVericalFOV : _NV_GAZE_HANDLER_INIT_PARAMS_V1, _NV_GAZE_HANDLER_INIT_PARAMS_V2


  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all variables with links to the structures/unions they belong to:

- g -

  • gammaCorrection : _NVVIOOUTPUTCONFIG_V1, _NVVIOOUTPUTCONFIG_V2, _NVVIOOUTPUTCONFIG_V3
  • gammaRamp : _NVVIOGAMMACORRECTION
  • gammaRamp10 : _NVVIOGAMMACORRECTION
  • gammaRamp8 : _NVVIOGAMMACORRECTION
  • GazeDataDeviceId : _NV_FOVEATED_RENDERING_DESC_V1, _NV_GAZE_HANDLER_INIT_PARAMS_V1, _NV_GAZE_HANDLER_INIT_PARAMS_V2
  • GazeDataType : _NV_GAZE_HANDLER_INIT_PARAMS_V1, _NV_GAZE_HANDLER_INIT_PARAMS_V2
  • GazeDataValidityFlags : _NV_FOVEATED_RENDERING_GAZE_DATA_PER_EYE
  • geforce : _NVDRS_GPU_SUPPORT
  • geometryDescStrideInBytes : _NVAPI_D3D12_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_INPUTS_EX
  • gpioPinBlue : _NV_GPU_CLIENT_ILLUM_DEVICE_INFO_DATA_GPIO_PWM_RGBW
  • gpioPinGreen : _NV_GPU_CLIENT_ILLUM_DEVICE_INFO_DATA_GPIO_PWM_RGBW
  • gpioPinRed : _NV_GPU_CLIENT_ILLUM_DEVICE_INFO_DATA_GPIO_PWM_RGBW
  • gpioPinSingleColor : _NV_GPU_CLIENT_ILLUM_DEVICE_INFO_DATA_GPIO_PWM_SINGLE_COLOR
  • gpioPinWhite : _NV_GPU_CLIENT_ILLUM_DEVICE_INFO_DATA_GPIO_PWM_RGBW
  • gpioPwmRgbwv10 : _NV_GPU_CLIENT_ILLUM_DEVICE_INFO_V1
  • gpioPwmSingleColorv10 : _NV_GPU_CLIENT_ILLUM_DEVICE_INFO_V1
  • gpuActiveRenderTimeUs : _NV_LATENCY_RESULT_PARAMS::FrameReport
  • gpuCount : _NV_COMPUTE_GPU_TOPOLOGY_V2, NV_COMPUTE_GPU_TOPOLOGY_V1
  • gpuFrameTimeUs : _NV_LATENCY_RESULT_PARAMS::FrameReport
  • gpuHandleCount : _NV_LOGICAL_GPUS, _NV_PHYSICAL_GPUS
  • gpuHandleData : _NV_LOGICAL_GPUS, _NV_PHYSICAL_GPUS
  • gpuId : NV_DISPLAY_PATH
  • gpuLayout : NV_MOSAIC_TOPO_DETAILS, NV_MOSAIC_TOPOLOGY
  • gpuRenderEndTime : _NV_LATENCY_RESULT_PARAMS::FrameReport
  • gpuRenderStartTime : _NV_LATENCY_RESULT_PARAMS::FrameReport
  • gpuSupport : _NVDRS_PROFILE_V1
  • gpuVASize : NV_GET_GPU_VIRTUAL_ADDRESS_V1, NVAPI_UAV_INFO_V1, NVAPI_UAV_INFO_V2
  • gpuVAStart : NV_GET_GPU_VIRTUAL_ADDRESS_V1, NVAPI_UAV_INFO_V1, NVAPI_UAV_INFO_V2
  • gridDim : _NVAPI_CU_KERNEL_LAUNCH_PARAMS, _NVAPI_CU_KERNEL_LAUNCH_PARAMS_EX
  • GroupCount : NV_META_COMMAND_CREATE_CONVOLUTION_EX_DESC
  • grpCount : _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR
  • grpIdleTimems : _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR


  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all variables with links to the structures/unions they belong to:

- h -

  • h : NV_VIEWPORTF
  • handle : NVAPI_D3D12_GET_CUDA_INDEPENDENT_DESCRIPTOR_OBJECT_PARAMS
  • has3dEntries : _NV_MONITOR_CAPS_VSDB
  • hasInterlacedLatencyField : _NV_MONITOR_CAPS_VSDB
  • hasLatencyField : _NV_MONITOR_CAPS_VSDB
  • hasVicEntries : _NV_MONITOR_CAPS_VSDB
  • HBdeviceId : NV_CHIPSET_INFO_v4
  • HBorder : _NV_TIMING
  • HBsubSysDeviceId : NV_CHIPSET_INFO_v4
  • HBsubSysVendorId : NV_CHIPSET_INFO_v4
  • HBvendorId : NV_CHIPSET_INFO_v4
  • hdcpFuseState : NV_GPU_GET_HDCP_SUPPORT_STATUS
  • hdcpKeySource : NV_GPU_GET_HDCP_SUPPORT_STATUS
  • hdcpKeySourceState : NV_GPU_GET_HDCP_SUPPORT_STATUS
  • hdmi3dLength : _NV_MONITOR_CAPS_VSDB
  • hdmi_3d : _NV_MONITOR_CAPS_VSDB
  • hdmi_vic : _NV_MONITOR_CAPS_VSDB
  • hdmiVicLength : _NV_MONITOR_CAPS_VSDB
  • hdr10plus_vsvdb : _NV_HDR_CAPABILITIES_V3
  • hdrBpc : _NV_HDR_COLOR_DATA_V2
  • hdrColorFormat : _NV_HDR_COLOR_DATA_V2
  • hdrDynamicRange : _NV_HDR_COLOR_DATA_V2
  • hdrMode : _NV_HDR_COLOR_DATA_V1, _NV_HDR_COLOR_DATA_V2
  • height : _NV_MOSAIC_DISPLAY_SETTING_V1, _NV_RESOLUTION, _NV_TIMING_INPUT, _NVVIOOUTPUTREGION, NV_CUSTOM_DISPLAY, NV_DISPLAY_PATH, NV_MOSAIC_DISPLAY_SETTING_V2, NV_SCANOUT_INTENSITY_DATA_V1, NV_SCANOUT_INTENSITY_DATA_V2
  • HFrontPorch : _NV_TIMING
  • hFunction : _NVAPI_CU_KERNEL_LAUNCH_PARAMS, _NVAPI_CU_KERNEL_LAUNCH_PARAMS_EX
  • highestNciVersion : NVLINK_GET_CAPS_V1
  • highestNvlinkVersion : NVLINK_GET_CAPS_V1
  • hLinkedSurface : _NV_DX_VIDEO_STEREO_INFO
  • hLogicalGpu : _NV_LOGICAL_GPU_HANDLE_DATA
  • hLogicalGPU : NV_MOSAIC_TOPO_DETAILS
  • horizontalDelay : _NVVIOSYNCDELAY
  • horizontalPixels : _NVVIOVIDEOMODE
  • hotkey : NVAPI_ANSEL_FEATURE_CONFIGURATION_STRUCT
  • hotkeyModifier : NVAPI_ANSEL_CONFIGURATION_STRUCT_V1
  • hour : _NV_LICENSE_EXPIRY_DETAILS
  • houseSyncIncoming : _NV_GSYNC_STATUS_PARAMS_V1, _NV_GSYNC_STATUS_PARAMS_V2
  • hPhysicalGpu : _NV_COMPUTE_GPU, _NV_GPU_GET_ILLUMINATION_PARM_V1, _NV_GPU_QUERY_ILLUMINATION_SUPPORT_PARM_V1, _NV_GPU_SET_ILLUMINATION_PARM_V1, _NV_GSYNC_GPU, _NV_PHYSICAL_GPU_HANDLE_DATA, NV_COMPUTE_GPU_TOPOLOGY_V1
  • hPhysicalGPU : NV_MOSAIC_TOPO_DETAILS, NV_MOSAIC_TOPOLOGY
  • hPhysicalGpu : NVVIOTOPOLOGYTARGET
  • hProxyPhysicalGpu : _NV_GSYNC_GPU
  • hResource : NV_GET_GPU_VIRTUAL_ADDRESS_V1
  • hShader : NVAPI_D3D12_CREATE_CUBIN_SHADER_PARAMS
  • hSurface : _NV_DX_VIDEO_STEREO_INFO
  • HSyncPol : _NV_TIMING
  • HSyncWidth : _NV_TIMING
  • HTotal : _NV_TIMING
  • hVioHandle : NVVIOTOPOLOGYTARGET
  • HVisible : _NV_TIMING
  • hwModeSetOnly : NV_CUSTOM_DISPLAY


  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all variables with links to the structures/unions they belong to:

- i -

  • i2cDevAddress : NV_I2C_INFO_V1, NV_I2C_INFO_V2, NV_I2C_INFO_V3
  • i2cDevIdx : _NV_GPU_CLIENT_ILLUM_DEVICE_INFO_DATA_MCUV10
  • i2cSpeed : NV_I2C_INFO_V1, NV_I2C_INFO_V2, NV_I2C_INFO_V3
  • i2cSpeedKhz : NV_I2C_INFO_V2, NV_I2C_INFO_V3
  • id : _NV_MODIFIED_W_PARAMS
  • Id : NVAPI_META_COMMAND_DESC
  • illumDeviceIdx : _NV_GPU_CLIENT_ILLUM_ZONE_INFO_V1
  • immersiveGaming : _NV_MOSAIC_GRID_TOPO_V1, _NV_MOSAIC_GRID_TOPO_V2
  • implementation : NV_GPU_ARCH_INFO_V1, NV_GPU_ARCH_INFO_V2
  • implementation_id : NV_GPU_ARCH_INFO_V2
  • inConfig : _NVVIOCONFIG_V1, _NVVIOCONFIG_V2, _NVVIOCONFIG_V3
  • independentViewportMaskEnable : _NV_MULTIVIEW_PARAMS_V1
  • infoframe : NV_INFOFRAME_DATA
  • infoType : _NV_MONITOR_CAPABILITIES_V1, _NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_POSTBUILD_INFO_DESC, _NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_ARRAY_POSTBUILD_INFO_DESC
  • InitializationDirtyState : NVAPI_META_COMMAND_DESC
  • InnerMostRegionShadingRate : _NV_FOVEATED_RENDERING_CUSTOM_SHADING_RATE_PRESET_DESC_V1
  • inputBuffer : _NVAPI_D3D12_BUILD_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_INPUTS, _NVAPI_D3D12_BUILD_RAYTRACING_OPACITY_MICROMAP_ARRAY_INPUTS
  • InputResource : NV_D3D11_META_COMMAND_EXECUTE_CONVOLUTION_EX_DESC, NV_D3D12_META_COMMAND_EXECUTE_CONVOLUTION_EX_DESC
  • inputs : _NVAPI_D3D12_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_DESC_EX, _NVAPI_D3D12_BUILD_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_DESC, _NVAPI_D3D12_BUILD_RAYTRACING_OPACITY_MICROMAP_ARRAY_DESC
  • inputSampleTime : _NV_LATENCY_RESULT_PARAMS::FrameReport
  • instanceDescs : _NVAPI_D3D12_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_INPUTS_EX
  • inStatus : _NVVIOSTATUS
  • interface_supported_by_sink : _NV_HDR_CAPABILITIES_V2, _NV_HDR_CAPABILITIES_V3
  • interlaced : _NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_V1, _NV_TIMING, NV_DISPLAY_PATH
  • interlacedAudioLatency : _NV_MONITOR_CAPS_VSDB
  • interlacedVideoLatency : _NV_MONITOR_CAPS_VSDB
  • interlaceMode : _NV_GSYNC_CONTROL_PARAMS_V1, _NV_GSYNC_CONTROL_PARAMS_V2, _NVVIOVIDEOMODE
  • InterleavedSampling : _NV_D3D11_FEATURE_DATA_RASTERIZER_SUPPORT
  • InterleavedSamplingEnable : NvAPI_D3D11_RASTERIZER_DESC_EX, NVAPI_D3D12_PSO_RASTERIZER_STATE_DESC_V1
  • interval : _NV_GSYNC_CONTROL_PARAMS_V1, _NV_GSYNC_CONTROL_PARAMS_V2
  • is10BPCSupported : _NV_DISPLAY_PORT_INFO_V1
  • is10BPCSupportedOnCurrentMode : _NV_DISPLAY_PORT_INFO_V1
  • is12BPCSupported : _NV_DISPLAY_PORT_INFO_V1
  • is12BPCSupportedOnCurrentMode : _NV_DISPLAY_PORT_INFO_V1
  • is16BPCSupported : _NV_DISPLAY_PORT_INFO_V1
  • is16BPCSupportedOnCurrentMode : _NV_DISPLAY_PORT_INFO_V1
  • is6BPCSupported : _NV_DISPLAY_PORT_INFO_V1
  • is6BPCSupportedOnCurrentMode : _NV_DISPLAY_PORT_INFO_V1
  • is8BPCSupported : _NV_DISPLAY_PORT_INFO_V1
  • is8BPCSupportedOnCurrentMode : _NV_DISPLAY_PORT_INFO_V1
  • isAcquired : _NV_MANAGED_DEDICATED_DISPLAY_INFO
  • isActive : _NV_GPU_DISPLAYIDS
  • isChromaLpfOff : NV_DISPLAY_PORT_CONFIG
  • isCluster : _NV_GPU_DISPLAYIDS
  • isColorCtrlSupported : _NV_DISPLAY_PORT_INFO_V1
  • isCommandLine : _NVDRS_APPLICATION_V3, _NVDRS_APPLICATION_V4
  • isConnected : _NV_GPU_DISPLAYIDS
  • isCurrentPredefined : _NVDRS_SETTING_V1
  • isDitherOff : NV_DISPLAY_PORT_CONFIG
  • isDolbyVisionSupported : _NV_HDR_CAPABILITIES_V2, _NV_HDR_CAPABILITIES_V3
  • isDp : _NV_DISPLAY_PORT_INFO_V1
  • isDynamic : _NV_GPU_DISPLAYIDS
  • isEdrSupported : _NV_HDR_CAPABILITIES_V1, _NV_HDR_CAPABILITIES_V2, _NV_HDR_CAPABILITIES_V3
  • isEnabled : _NV_LICENSE_FEATURE_DETAILS_V1, _NV_LICENSE_FEATURE_DETAILS_V2, _NV_LICENSE_FEATURE_DETAILS_V3, _NV_LICENSE_FEATURE_DETAILS_V4, NV_GPU_ECC_CONFIGURATION_INFO, NV_GPU_ECC_STATUS_INFO
  • isEnabledByDefault : NV_GPU_ECC_CONFIGURATION_INFO
  • isFeatureEnabled : _NV_LICENSE_FEATURE_DETAILS_V3, _NV_LICENSE_FEATURE_DETAILS_V4
  • isGpuHDMICapable : _NV_HDMI_SUPPORT_INFO_V1, _NV_HDMI_SUPPORT_INFO_V2
  • isHdr10PlusGamingSupported : _NV_HDR_CAPABILITIES_V3
  • isHdr10PlusSupported : _NV_HDR_CAPABILITIES_V3
  • isHPD : NV_DISPLAY_PORT_CONFIG
  • isInterlaced : NV_TIMING_FLAG
  • isInternalDp : _NV_DISPLAY_PORT_INFO_V1
  • isLicenseSupported : _NV_LICENSABLE_FEATURES_V1, _NV_LICENSABLE_FEATURES_V2, _NV_LICENSABLE_FEATURES_V3, _NV_LICENSABLE_FEATURES_V4
  • isMasterable : _NV_GSYNC_DISPLAY
  • isMetro : _NVDRS_APPLICATION_V3, _NVDRS_APPLICATION_V4
  • isMonAdobeRGBCapable : _NV_DISPLAY_PORT_INFO_V1, _NV_HDMI_SUPPORT_INFO_V2
  • isMonAdobeYCC601Capable : _NV_DISPLAY_PORT_INFO_V1, _NV_HDMI_SUPPORT_INFO_V2
  • isMonBasicAudioCapable : _NV_HDMI_SUPPORT_INFO_V1, _NV_HDMI_SUPPORT_INFO_V2
  • isMonBT2020cYCCCapable : _NV_DISPLAY_PORT_INFO_V1
  • isMonBT2020RGBCapable : _NV_DISPLAY_PORT_INFO_V1
  • isMonBT2020YCCCapable : _NV_DISPLAY_PORT_INFO_V1
  • isMonHDMI : _NV_HDMI_SUPPORT_INFO_V1, _NV_HDMI_SUPPORT_INFO_V2
  • isMonsYCC601Capable : _NV_DISPLAY_PORT_INFO_V1, _NV_HDMI_SUPPORT_INFO_V2
  • isMonUnderscanCapable : _NV_HDMI_SUPPORT_INFO_V1, _NV_HDMI_SUPPORT_INFO_V2
  • isMonxvYCC601Capable : _NV_DISPLAY_PORT_INFO_V1, _NV_HDMI_SUPPORT_INFO_V1, _NV_HDMI_SUPPORT_INFO_V2
  • isMonxvYCC709Capable : _NV_DISPLAY_PORT_INFO_V1, _NV_HDMI_SUPPORT_INFO_V1, _NV_HDMI_SUPPORT_INFO_V2
  • isMonYCbCr422Capable : _NV_HDMI_SUPPORT_INFO_V1, _NV_HDMI_SUPPORT_INFO_V2
  • isMonYCbCr444Capable : _NV_HDMI_SUPPORT_INFO_V1, _NV_HDMI_SUPPORT_INFO_V2
  • isMosaic : _NV_MANAGED_DEDICATED_DISPLAY_INFO
  • isMultiStreamRootNode : _NV_GPU_DISPLAYIDS
  • IsNonNVIDIAAdapter : _NV_DISPLAYCONFIG_PATH_INFO_V2
  • IsNull : NV_META_COMMAND_OPTIONAL_ACTIVATION_DESC, NV_META_COMMAND_OPTIONAL_TENSOR_DESC
  • isOSVisible : _NV_GPU_DISPLAYIDS
  • isPhysicallyConnected : _NV_GPU_DISPLAYIDS
  • isPossible : NV_MOSAIC_TOPO_BRIEF
  • isPredefined : _NVDRS_APPLICATION_V1, _NVDRS_APPLICATION_V2, _NVDRS_APPLICATION_V3, _NVDRS_APPLICATION_V4, _NVDRS_PROFILE_V1
  • isPredefinedValid : _NVDRS_SETTING_V1
  • isPreferredUnscaledTarget : _NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_V1
  • isRgb444SupportedOnCurrentMode : _NV_DISPLAY_PORT_INFO_V1
  • isRLACapable : _NV_MONITOR_CAPS_GENERIC
  • isSetDeferred : NV_DISPLAY_PORT_CONFIG
  • isST2084EotfSupported : _NV_HDR_CAPABILITIES_V1, _NV_HDR_CAPABILITIES_V2, _NV_HDR_CAPABILITIES_V3
  • isSupported : NV_GPU_ECC_STATUS_INFO
  • isSynced : _NV_GSYNC_GPU
  • isTraditionalHdrGammaSupported : _NV_HDR_CAPABILITIES_V1, _NV_HDR_CAPABILITIES_V2, _NV_HDR_CAPABILITIES_V3
  • isTraditionalSdrGammaSupported : _NV_HDR_CAPABILITIES_V1, _NV_HDR_CAPABILITIES_V2, _NV_HDR_CAPABILITIES_V3
  • isTrueGsync : _NV_MONITOR_CAPS_GENERIC
  • isVRReady : _NV_GPU_VR_READY_V1
  • isWFD : _NV_GPU_DISPLAYIDS
  • isYCbCr420SupportedOnCurrentMode : _NV_DISPLAY_PORT_INFO_V1
  • isYCbCr422SupportedOnCurrentMode : _NV_DISPLAY_PORT_INFO_V1
  • isYCbCr444SupportedOnCurrentMode : _NV_DISPLAY_PORT_INFO_V1
  • isYCrCb420Supported : _NV_DISPLAY_PORT_INFO_V1
  • isYCrCb422Supported : _NV_DISPLAY_PORT_INFO_V1
  • isYCrCb444Supported : _NV_DISPLAY_PORT_INFO_V1
  • itContent : NV_INFOFRAME_VIDEO


  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all variables with links to the structures/unions they belong to:

- j -

  • jack : _NVVIOSTREAM


  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all variables with links to the structures/unions they belong to:

- k -

  • kernelParams : _NVAPI_CU_KERNEL_LAUNCH_PARAMS_EX
  • keyEnable : NVAPI_ANSEL_CONFIGURATION_STRUCT_V1


  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all variables with links to the structures/unions they belong to:

- l -

  • laneCount : NV_DISPLAY_PORT_CONFIG
  • lastFlipRefreshCount : _NV_GET_ADAPTIVE_SYNC_DATA_V1
  • lastFlipTimeStamp : _NV_GET_ADAPTIVE_SYNC_DATA_V1
  • launcher : _NVDRS_APPLICATION_V1, _NVDRS_APPLICATION_V2, _NVDRS_APPLICATION_V3, _NVDRS_APPLICATION_V4
  • Layout : NV_META_COMMAND_TENSOR_DESC
  • left : _NV_RECT
  • left_bar : NV_INFOFRAME_VIDEO
  • leftCoeffs : _NV_SMP_ASSIST_UPDATE_INSTANCEDSTEREO_DATA_PARAMS_V1
  • leftConst : _NV_SMP_ASSIST_UPDATE_INSTANCEDSTEREO_DATA_PARAMS_V1
  • length : NV_INFOFRAME_PROPERTY
  • levelShift : NV_INFOFRAME_AUDIO
  • lfePlaybackLevel : NV_INFOFRAME_AUDIO
  • licensableFeatureCount : _NV_LICENSABLE_FEATURES_V1, _NV_LICENSABLE_FEATURES_V2, _NV_LICENSABLE_FEATURES_V3, _NV_LICENSABLE_FEATURES_V4
  • licenseDetails : _NV_LICENSABLE_FEATURES_V1, _NV_LICENSABLE_FEATURES_V2, _NV_LICENSABLE_FEATURES_V3, _NV_LICENSABLE_FEATURES_V4
  • licenseExpiry : _NV_LICENSE_FEATURE_DETAILS_V4
  • licenseInfo : _NV_LICENSE_FEATURE_DETAILS_V1, _NV_LICENSE_FEATURE_DETAILS_V2, _NV_LICENSE_FEATURE_DETAILS_V3, _NV_LICENSE_FEATURE_DETAILS_V4
  • linkID : _NVVIOCHANNELSTATUS
  • linkInfo : NVLINK_GET_STATUS_V1, NVLINK_GET_STATUS_V2
  • linkMask : NVLINK_GET_CAPS_V1, NVLINK_GET_STATUS_V1, NVLINK_GET_STATUS_V2
  • linkRate : NV_DISPLAY_PORT_CONFIG
  • links : _NVVIOSTREAM
  • linkState : NVLINK_LINK_STATUS_INFO_V1, NVLINK_LINK_STATUS_INFO_V2
  • localDeviceInfo : NVLINK_LINK_STATUS_INFO_V2
  • localDeviceLinkNumber : NVLINK_LINK_STATUS_INFO_V2
  • loopProperty : NVLINK_LINK_STATUS_INFO_V1, NVLINK_LINK_STATUS_INFO_V2
  • lowestNciVersion : NVLINK_GET_CAPS_V1
  • lowestNvlinkVersion : NVLINK_GET_CAPS_V1


  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all variables with links to the structures/unions they belong to:

- m -

  • majorSMVersion : _NV_D3D12_GRAPHICS_CAPS_V1, _NV_D3D1x_GRAPHICS_CAPS_V2
  • majorVersion : _NVVIOCAPS
  • manualColorFixed : _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_COLOR_FIXED
  • manualRGB : _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_RGB
  • manualRGBW : _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_RGBW
  • manualSingleColor : _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_SINGLE_COLOR
  • markerType : _NV_ASYNC_FRAME_MARKER_PARAMS_V1, _NV_LATENCY_MARKER_PARAMS
  • markUavRef : NvShaderExtnStruct
  • mastering_display_data : _NV_HDR_COLOR_DATA_V1, _NV_HDR_COLOR_DATA_V2
  • max : NV_GPU_PERF_PSTATES20_PARAM_DELTA
  • max_content_light_level : _NV_HDR_COLOR_DATA_V1, _NV_HDR_COLOR_DATA_V2, _NV_HDR_METADATA_V1
  • max_display_mastering_luminance : _NV_HDR_COLOR_DATA_V1, _NV_HDR_COLOR_DATA_V2, _NV_HDR_METADATA_V1
  • max_frame_average_light_level : _NV_HDR_COLOR_DATA_V1, _NV_HDR_COLOR_DATA_V2, _NV_HDR_METADATA_V1
  • maxFrameInterval : _NV_GET_ADAPTIVE_SYNC_DATA_V1, _NV_SET_ADAPTIVE_SYNC_DATA_V1
  • maxFreq_kHz : NV_GPU_PSTATE20_CLOCK_ENTRY_V1
  • maxLaneCount : _NV_DISPLAY_PORT_INFO_V1
  • maxLines : _NV_GSYNC_DELAY
  • maxLinkRate : _NV_DISPLAY_PORT_INFO_V1
  • maxMulDivValue : _NV_GSYNC_CAPABILITIES_V3
  • maxNumAFRGroups : NV_GET_CURRENT_SLI_STATE_V1, NV_GET_CURRENT_SLI_STATE_V2
  • maxTmdsClock : _NV_MONITOR_CAPS_VSDB
  • maxVoltage_uV : NV_GPU_PSTATE20_CLOCK_ENTRY_V1
  • mcuv10 : _NV_GPU_CLIENT_ILLUM_DEVICE_INFO_V1
  • MiddleRegionShadingRate : _NV_FOVEATED_RENDERING_CUSTOM_SHADING_RATE_PRESET_DESC_V1
  • min : _NV_LICENSE_EXPIRY_DETAILS, NV_GPU_PERF_PSTATES20_PARAM_DELTA
  • min_display_mastering_luminance : _NV_HDR_COLOR_DATA_V1, _NV_HDR_COLOR_DATA_V2, _NV_HDR_METADATA_V1
  • minFreq_kHz : NV_GPU_PSTATE20_CLOCK_ENTRY_V1
  • minimumIntervalUs : _NV_SET_SLEEP_MODE_PARAMS
  • minorSMVersion : _NV_D3D12_GRAPHICS_CAPS_V1, _NV_D3D1x_GRAPHICS_CAPS_V2
  • minorVersion : _NVVIOCAPS
  • minPixels : _NV_GSYNC_DELAY
  • minVoltage_uV : NV_GPU_PSTATE20_CLOCK_ENTRY_V1
  • MipSlice : _NV_TEX2D_ARRAY_SRRV, _NV_TEX2D_SRRV
  • mode : NV_INFOFRAME_PROPERTY
  • Mode : NV_META_COMMAND_CREATE_CONVOLUTION_EX_DESC, NV_META_COMMAND_PADDING_DESC
  • modifiedWCoefficients : _NV_MODIFIED_W_PARAMS
  • month : _NV_LICENSE_EXPIRY_DETAILS
  • multiGPUVersion : _NV_MULTIGPU_CAPS_V1, _NV_MULTIGPU_CAPS_V2
  • multiplyDivideMode : _NV_GSYNC_CONTROL_PARAMS_V2
  • multiplyDivideValue : _NV_GSYNC_CONTROL_PARAMS_V2
  • MultisampleEnable : NvAPI_D3D11_RASTERIZER_DESC_EX
  • mvolt : NV_GPU_PERF_PSTATES_INFO_V2


  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all variables with links to the structures/unions they belong to:

- n -

  • name : _NV_MANAGED_DEDICATED_DISPLAY_METADATA
  • Name : NVAPI_META_COMMAND_DESC
  • name : tagNV_TIMINGEXT
  • nciVersion : NVLINK_LINK_STATUS_INFO_V1, NVLINK_LINK_STATUS_INFO_V2
  • NDCSplitsX : _NV_SMP_ASSIST_FASTGSCBDATA_MRS_INSTANCED_STEREO_V1, _NV_SMP_ASSIST_FASTGSCBDATA_V1
  • NDCSplitsY : _NV_SMP_ASSIST_FASTGSCBDATA_MRS_INSTANCED_STEREO_V1, _NV_SMP_ASSIST_FASTGSCBDATA_V1
  • nextFrameAFRIndex : NV_GET_CURRENT_SLI_STATE_V1, NV_GET_CURRENT_SLI_STATE_V2
  • nonuniformScaling : NV_INFOFRAME_VIDEO
  • nSLIGPUs : _NV_MULTIGPU_CAPS_V1, _NV_MULTIGPU_CAPS_V2
  • nTotalGPUs : _NV_MULTIGPU_CAPS_V1, _NV_MULTIGPU_CAPS_V2
  • numAFRGroups : NV_GET_CURRENT_SLI_STATE_V1, NV_GET_CURRENT_SLI_STATE_V2
  • numAnselFeatures : NVAPI_ANSEL_CONFIGURATION_STRUCT_V1
  • numBaseVoltages : _NV_GPU_PERF_PSTATES20_INFO_V2, NV_GPU_PERF_PSTATES20_INFO_V1
  • numBuffers : _NV_D3D_LATELATCH_OBJECT_DESC_V1
  • numClocks : _NV_GPU_PERF_PSTATES20_INFO_V2, NV_GPU_PERF_PSTATES20_INFO_V1, NV_GPU_PERF_PSTATES_INFO_V1, NV_GPU_PERF_PSTATES_INFO_V2
  • NumCustomSemantics : NvAPI_D3D11_CREATE_DOMAIN_SHADER_EX_V1, NvAPI_D3D11_CREATE_DOMAIN_SHADER_EX_V2, NvAPI_D3D11_CREATE_DOMAIN_SHADER_EX_V3, NvAPI_D3D11_CREATE_GEOMETRY_SHADER_EX_V5, NvAPI_D3D11_CREATE_HULL_SHADER_EX_V1, NvAPI_D3D11_CREATE_HULL_SHADER_EX_V2, NvAPI_D3D11_CREATE_PIXEL_SHADER_EX_V1, NvAPI_D3D11_CREATE_PIXEL_SHADER_EX_V2, NvAPI_D3D11_CREATE_VERTEX_SHADER_EX_V1, NvAPI_D3D11_CREATE_VERTEX_SHADER_EX_V2, NvAPI_D3D11_CREATE_VERTEX_SHADER_EX_V3, NVAPI_D3D12_PSO_DOMAIN_SHADER_DESC_V1, NVAPI_D3D12_PSO_GEOMETRY_SHADER_DESC_V5, NVAPI_D3D12_PSO_HULL_SHADER_DESC_V1, NVAPI_D3D12_PSO_VERTEX_SHADER_DESC_V1
  • numDescs : _NVAPI_D3D12_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_INPUTS_EX
  • numDMMUsageCounts : _NVAPI_D3D12_BUILD_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_INPUTS, _NVAPI_D3D12_RAYTRACING_GEOMETRY_DMM_ATTACHMENT_DESC
  • numEntries : _NV_MODIFIED_W_PARAMS
  • numIllumDevices : _NV_GPU_CLIENT_ILLUM_DEVICE_INFO_PARAMS_V1, NV_GPU_CLIENT_ILLUM_DEVICE_CONTROL_PARAMS_V1
  • numIllumZones : _NV_GPU_CLIENT_ILLUM_ZONE_INFO_PARAMS_V1
  • numIllumZonesControl : _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_PARAMS_V1
  • numLines : _NV_GSYNC_DELAY
  • numLinks : _NVVIOSTREAM
  • numOfApps : _NVDRS_PROFILE_V1
  • numOfSettings : _NVDRS_PROFILE_V1
  • numOMMUsageCounts : _NVAPI_D3D12_BUILD_RAYTRACING_OPACITY_MICROMAP_ARRAY_INPUTS, _NVAPI_D3D12_RAYTRACING_GEOMETRY_OMM_ATTACHMENT_DESC
  • numOutputsForIncCounter : NvShaderExtnStruct
  • numPixels : _NV_GSYNC_DELAY
  • numPostbuildInfoDescs : _NVAPI_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_EX_PARAMS_V1, _NVAPI_BUILD_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PARAMS_V1, _NVAPI_BUILD_RAYTRACING_OPACITY_MICROMAP_ARRAY_PARAMS_V1
  • numPstates : _NV_GPU_PERF_PSTATES20_INFO_V2, NV_GPU_PERF_PSTATES20_INFO_V1, NV_GPU_PERF_PSTATES_INFO_V1, NV_GPU_PERF_PSTATES_INFO_V2
  • numRawCaptureImages : _NVVIOINPUTCONFIG
  • numRects : _NV_D3D11_EXCLUSIVE_SCISSOR_RECTS_DESC_V1
  • numSettingValues : _NVDRS_SETTING_VALUES, _SettingDWORDNameString, _SettingWSTRINGNameString
  • numSources : _NVAPI_EMIT_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_POSTBUILD_INFO_PARAMS_V1, _NVAPI_EMIT_RAYTRACING_OPACITY_MICROMAP_ARRAY_POSTBUILD_INFO_PARAMS_V1
  • numStreams : _NVVIOINPUTCONFIG
  • numUtils : _NV_GPU_CLIENT_CALLBACK_UTILIZATION_DATA_V1
  • numVertices : NV_SCANOUT_WARPING_DATA
  • numViewports : _NV_CUSTOM_RECTS_V1, _NV_D3D11_VIEWPORTS_SHADING_RATE_DESC_V1, _NV_SMP_ASSIST_GET_CONSTANTS_V3
  • numViews : _NV_MULTIVIEW_PARAMS_V1
  • numVoltages : _NV_GPU_PERF_PSTATES20_INFO_V2, NV_GPU_PERF_PSTATES_INFO_V2
  • numVRSLIGpus : NV_GET_CURRENT_SLI_STATE_V2
  • nvCallBackFunc : NV_EVENT_REGISTER_CALLBACK
  • NVCustomSemanticNameString : _NV_CUSTOM_SEMANTIC
  • NVCustomSemanticType : _NV_CUSTOM_SEMANTIC
  • NVHeapFlags : _NV_HEAP_PARAMS_V1
  • nvlinkCommonClockSpeedMhz : NVLINK_LINK_STATUS_INFO_V1, NVLINK_LINK_STATUS_INFO_V2
  • nvlinkLineRateMbps : NVLINK_LINK_STATUS_INFO_V2
  • nvlinkLinkClockMhz : NVLINK_LINK_STATUS_INFO_V1, NVLINK_LINK_STATUS_INFO_V2
  • NvLinkPresent : _NV_MULTIGPU_CAPS_V2
  • nvlinkRefClkSpeedMhz : NVLINK_LINK_STATUS_INFO_V1, NVLINK_LINK_STATUS_INFO_V2
  • nvlinkRefClkType : NVLINK_LINK_STATUS_INFO_V1, NVLINK_LINK_STATUS_INFO_V2
  • nvlinkVersion : NVLINK_LINK_STATUS_INFO_V1, NVLINK_LINK_STATUS_INFO_V2
  • nvPsfId : NV_TIMING_FLAG
  • nvQSYNCEventCallback : NV_EVENT_REGISTER_CALLBACK
  • NVResourceFlags : _NV_RESOURCE_PARAMS_V1
  • nvs : _NVDRS_GPU_SUPPORT
  • nvvioConfigType : _NVVIOCONFIG_V1, _NVVIOCONFIG_V2, _NVVIOCONFIG_V3
  • nvvioStatusType : _NVVIOSTATUS


  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all variables with links to the structures/unions they belong to:

- o -

  • Offset : NV_D3D11_META_COMMAND_RESOURCE
  • offset : NV_EDID_V3
  • OffsetRtIndexByVpIndex : NvAPI_D3D11_CREATE_GEOMETRY_SHADER_EX_V5, NVAPI_D3D12_PSO_GEOMETRY_SHADER_DESC_V5
  • offsetTexChannels : NV_SCANOUT_INTENSITY_DATA_V2
  • offsetTexture : NV_SCANOUT_INTENSITY_DATA_V2
  • ommAttachment : _NVAPI_D3D12_RAYTRACING_GEOMETRY_OMM_TRIANGLES_DESC
  • ommTriangles : _NVAPI_D3D12_RAYTRACING_GEOMETRY_DESC_EX
  • opacityMicromapArray : _NVAPI_D3D12_RAYTRACING_GEOMETRY_OMM_ATTACHMENT_DESC, _NVAPI_RELOCATE_RAYTRACING_OPACITY_MICROMAP_ARRAY_PARAMS_V1
  • opacityMicromapBaseLocation : _NVAPI_D3D12_RAYTRACING_GEOMETRY_OMM_ATTACHMENT_DESC
  • opacityMicromapIndexBuffer : _NVAPI_D3D12_RAYTRACING_GEOMETRY_OMM_ATTACHMENT_DESC
  • opacityMicromapIndexFormat : _NVAPI_D3D12_RAYTRACING_GEOMETRY_OMM_ATTACHMENT_DESC
  • opcode : NvShaderExtnStruct
  • osRenderQueueEndTime : _NV_LATENCY_RESULT_PARAMS::FrameReport
  • osRenderQueueStartTime : _NV_LATENCY_RESULT_PARAMS::FrameReport
  • outConfig : _NVVIOCONFIG_V1, _NVVIOCONFIG_V2, _NVVIOCONFIG_V3
  • outFlags : NVAPI_UAV_INFO_V2
  • outputArea : _NVVIOOUTPUTCONFIG_V1, _NVVIOOUTPUTCONFIG_V2, _NVVIOOUTPUTCONFIG_V3
  • outputId : NVVIOTOPOLOGYTARGET
  • OutputPrepool : NV_META_COMMAND_CONVOLUTION_FUSE_DESC
  • outputRegion : _NVVIOOUTPUTCONFIG_V1, _NVVIOOUTPUTCONFIG_V2, _NVVIOOUTPUTCONFIG_V3
  • OutputResource : NV_D3D11_META_COMMAND_EXECUTE_CONVOLUTION_EX_DESC, NV_D3D11_META_COMMAND_EXECUTE_GEMM_DESC, NV_D3D12_META_COMMAND_EXECUTE_CONVOLUTION_EX_DESC, NV_D3D12_META_COMMAND_EXECUTE_GEMM_DESC
  • outputVideoLocked : _NVVIOOUTPUTSTATUS
  • outStatus : _NVVIOSTATUS
  • ov : _NV_GPU_PERF_PSTATES20_INFO_V2
  • overlapX : _NV_MOSAIC_GRID_TOPO_DISPLAY_V1, _NV_MOSAIC_GRID_TOPO_DISPLAY_V2, NV_MOSAIC_TOPO_DETAILS, NV_MOSAIC_TOPOLOGY
  • overlapY : _NV_MOSAIC_GRID_TOPO_DISPLAY_V1, _NV_MOSAIC_GRID_TOPO_DISPLAY_V2, NV_MOSAIC_TOPO_DETAILS, NV_MOSAIC_TOPOLOGY
  • ownerId : _NVVIOCAPS
  • ownerType : _NVVIOCAPS


  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all variables with links to the structures/unions they belong to:

- p -

  • Padding : _NV_SMP_ASSIST_REMAPCBDATA_V1, NV_META_COMMAND_CREATE_CONVOLUTION_EX_DESC
  • padding1 : NvShaderExtnStruct
  • pAnselFeatures : NVAPI_ANSEL_CONFIGURATION_STRUCT_V1
  • Params : NV_META_COMMAND_ACTIVATION_DESC
  • paramSize : _NVAPI_CU_KERNEL_LAUNCH_PARAMS, _NVAPI_CU_KERNEL_LAUNCH_PARAMS_EX
  • parity : _NV_HDR_CAPABILITIES_V3
  • path : NV_DISPLAY_PATH_INFO, NV_DISPLAY_PATH_INFO_V3
  • pbData : NV_I2C_INFO_V1, NV_I2C_INFO_V2, NV_I2C_INFO_V3
  • pbI2cRegAddress : NV_I2C_INFO_V1, NV_I2C_INFO_V2, NV_I2C_INFO_V3
  • pCallbackParam : _NV_CLIENT_CALLBACK_SETTINGS_SUPER_V1, _NV_GPU_CLIENT_CALLBACK_DATA_SUPER_V1
  • pciBus : _NVVIOPCIINFO
  • pciDeviceId : _NVVIOPCIINFO, NVLINK_DEVICE_INFO_V1
  • pciDomain : _NVVIOPCIINFO
  • pciLinkRate : _NVVIOPCIINFO
  • pciLinkWidth : _NVVIOPCIINFO
  • pciRevisionId : _NVVIOPCIINFO
  • pciSlot : _NVVIOPCIINFO
  • pciSubSystemId : _NVVIOPCIINFO
  • pclk : _NV_TIMING
  • pCoordinateSwizzling : NvAPI_D3D11_CREATE_FASTGS_EXPLICIT_DESC_V1, NvAPI_D3D11_CREATE_GEOMETRY_SHADER_EX_V5, NVAPI_D3D12_PSO_CREATE_FASTGS_EXPLICIT_DESC_V1, NVAPI_D3D12_PSO_GEOMETRY_SHADER_DESC_V5
  • pCubin : NVAPI_D3D12_CREATE_CUBIN_SHADER_PARAMS
  • pCustomSemantics : NvAPI_D3D11_CREATE_DOMAIN_SHADER_EX_V1, NvAPI_D3D11_CREATE_DOMAIN_SHADER_EX_V2, NvAPI_D3D11_CREATE_DOMAIN_SHADER_EX_V3, NvAPI_D3D11_CREATE_GEOMETRY_SHADER_EX_V5, NvAPI_D3D11_CREATE_HULL_SHADER_EX_V1, NvAPI_D3D11_CREATE_HULL_SHADER_EX_V2, NvAPI_D3D11_CREATE_PIXEL_SHADER_EX_V1, NvAPI_D3D11_CREATE_PIXEL_SHADER_EX_V2, NvAPI_D3D11_CREATE_VERTEX_SHADER_EX_V1, NvAPI_D3D11_CREATE_VERTEX_SHADER_EX_V2, NvAPI_D3D11_CREATE_VERTEX_SHADER_EX_V3, NVAPI_D3D12_PSO_DOMAIN_SHADER_DESC_V1, NVAPI_D3D12_PSO_GEOMETRY_SHADER_DESC_V5, NVAPI_D3D12_PSO_HULL_SHADER_DESC_V1, NVAPI_D3D12_PSO_VERTEX_SHADER_DESC_V1
  • pDesc : _NVAPI_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_EX_PARAMS_V1, _NVAPI_BUILD_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PARAMS_V1, _NVAPI_BUILD_RAYTRACING_OPACITY_MICROMAP_ARRAY_PARAMS_V1, _NVAPI_EMIT_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_POSTBUILD_INFO_PARAMS_V1, _NVAPI_EMIT_RAYTRACING_OPACITY_MICROMAP_ARRAY_POSTBUILD_INFO_PARAMS_V1, _NVAPI_GET_RAYTRACING_ACCELERATION_STRUCTURE_PREBUILD_INFO_EX_PARAMS_V1, _NVAPI_GET_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PREBUILD_INFO_PARAMS_V1, _NVAPI_GET_RAYTRACING_OPACITY_MICROMAP_ARRAY_PREBUILD_INFO_PARAMS_V1
  • pDevice : _NV_D3D12_MOSAIC_GETCOMPANIONALLOCATIONS, _NV_D3D12_MOSAIC_GETVIEWPORTANDGPUPARTITIONS, NVAPI_D3D12_CREATE_CUBIN_SHADER_PARAMS, NVAPI_D3D12_GET_CUDA_INDEPENDENT_DESCRIPTOR_OBJECT_PARAMS, NVAPI_D3D12_GET_CUDA_MERGED_TEXTURE_SAMPLER_OBJECT_PARAMS
  • pDMMUsageCounts : _NVAPI_D3D12_BUILD_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_INPUTS, _NVAPI_D3D12_RAYTRACING_GEOMETRY_DMM_ATTACHMENT_DESC
  • peak_luminance_index : _NV_HDR_CAPABILITIES_V3
  • pEDID : _NV_EDID_DATA_V1, _NV_EDID_DATA_V2
  • percentage : NV_GPU_DYNAMIC_PSTATES_INFO_EX
  • PerChannelScaling : NV_META_COMMAND_CREATE_CONVOLUTION_EX_DESC
  • perDMMDescs : _NVAPI_D3D12_BUILD_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_INPUTS
  • PeripheralRegionShadingRate : _NV_FOVEATED_RENDERING_CUSTOM_SHADING_RATE_PRESET_DESC_V1
  • perOMMDescs : _NVAPI_D3D12_BUILD_RAYTRACING_OPACITY_MICROMAP_ARRAY_INPUTS
  • PersistentResource : NV_D3D11_META_COMMAND_EXECUTE_CONVOLUTION_EX_DESC, NV_D3D11_META_COMMAND_EXECUTE_GEMM_DESC, NV_D3D11_META_COMMAND_INITIALIZE_CONVOLUTION_EX_DESC, NV_D3D11_META_COMMAND_INITIALIZE_GEMM_DESC, NV_D3D12_META_COMMAND_EXECUTE_CONVOLUTION_EX_DESC, NV_D3D12_META_COMMAND_EXECUTE_GEMM_DESC, NV_D3D12_META_COMMAND_INITIALIZE_CONVOLUTION_EX_DESC, NV_D3D12_META_COMMAND_INITIALIZE_GEMM_DESC
  • pFastGSCBData : _NV_SMP_ASSIST_GET_CONSTANTS_V3
  • pFastGSCBDataMRS_IS : _NV_SMP_ASSIST_GET_CONSTANTS_V3
  • pGeometryDescs : _NVAPI_D3D12_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_INPUTS_EX
  • phaseOffsetms : _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR
  • physicalGpuCount : _NV_LOGICAL_GPU_DATA_V1
  • physicalGpuHandles : _NV_LOGICAL_GPU_DATA_V1
  • phyType : NVLINK_LINK_STATUS_INFO_V1, NVLINK_LINK_STATUS_INFO_V2
  • phyVersion : NVLINK_LINK_STATUS_INFO_V1, NVLINK_LINK_STATUS_INFO_V2
  • picAspectRatio : NV_INFOFRAME_VIDEO
  • pIdentifierToCheck : _NVAPI_CHECK_DRIVER_MATCHING_IDENTIFIER_EX_PARAMS_V1
  • piecewiseLinearColorFixed : _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_COLOR_FIXED
  • piecewiseLinearData : _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR_COLOR_FIXED, _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR_RGB, _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR_RGBW, _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR_SINGLE_COLOR
  • piecewiseLinearRGB : _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_RGB
  • piecewiseLinearRGBW : _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_RGBW
  • piecewiseLinearSingleColor : _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_SINGLE_COLOR
  • pInfo : _NVAPI_GET_RAYTRACING_ACCELERATION_STRUCTURE_PREBUILD_INFO_EX_PARAMS_V1, _NVAPI_GET_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PREBUILD_INFO_PARAMS_V1, _NVAPI_GET_RAYTRACING_OPACITY_MICROMAP_ARRAY_PREBUILD_INFO_PARAMS_V1
  • Pixel_1x2 : _NV_PIXEL_SHADING_RATE_SAMPLE_ORDER_TABLE_V1
  • Pixel_2x1 : _NV_PIXEL_SHADING_RATE_SAMPLE_ORDER_TABLE_V1
  • Pixel_2x2 : _NV_PIXEL_SHADING_RATE_SAMPLE_ORDER_TABLE_V1
  • Pixel_2x4 : _NV_PIXEL_SHADING_RATE_SAMPLE_ORDER_TABLE_V1
  • Pixel_4x2 : _NV_PIXEL_SHADING_RATE_SAMPLE_ORDER_TABLE_V1
  • Pixel_4x4 : _NV_PIXEL_SHADING_RATE_SAMPLE_ORDER_TABLE_V1
  • pixelRepeat : NV_INFOFRAME_VIDEO
  • pixelShift : _NV_MOSAIC_GRID_TOPO_V2
  • pixelShiftType : _NV_MOSAIC_GRID_TOPO_DISPLAY_V2
  • pNodeMask : _NV_D3D12_MOSAIC_GETVIEWPORTANDGPUPARTITIONS
  • polarity : _NV_GSYNC_CONTROL_PARAMS_V1, _NV_GSYNC_CONTROL_PARAMS_V2
  • pOMMUsageCounts : _NVAPI_D3D12_BUILD_RAYTRACING_OPACITY_MICROMAP_ARRAY_INPUTS, _NVAPI_D3D12_RAYTRACING_GEOMETRY_OMM_ATTACHMENT_DESC
  • PoolMode : NV_META_COMMAND_CONVOLUTION_FUSE_DESC
  • portId : NV_I2C_INFO_V3
  • pOSAdapterID : _NV_DISPLAYCONFIG_PATH_INFO_V2
  • pOSAdapterId : _NV_LOGICAL_GPU_DATA_V1
  • position : _NV_DISPLAYCONFIG_SOURCE_MODE_INFO_V1
  • positionX : _NV_MANAGED_DEDICATED_DISPLAY_METADATA
  • positionY : _NV_MANAGED_DEDICATED_DISPLAY_METADATA
  • PostZCoverage : _NV_D3D11_FEATURE_DATA_RASTERIZER_SUPPORT
  • PostZCoverageEnable : NvAPI_D3D11_RASTERIZER_DESC_EX, NVAPI_D3D12_PSO_RASTERIZER_STATE_DESC_V1
  • posx : NV_DISPLAY_PATH
  • posy : NV_DISPLAY_PATH
  • pParams : _NVAPI_CU_KERNEL_LAUNCH_PARAMS, _NVAPI_CU_KERNEL_LAUNCH_PARAMS_EX
  • pPartitionCount : _NV_D3D12_MOSAIC_GETVIEWPORTANDGPUPARTITIONS
  • ppBufferDesc : _NV_D3D_LATELATCH_OBJECT_DESC_V1
  • ppCompanionResources : _NV_D3D12_MOSAIC_GETCOMPANIONALLOCATIONS
  • ppD3DLateLatchObject : _NV_D3D_LATELATCH_OBJECT_DESC_V1
  • ppD3DNvSMPAssist : _NV_SMP_ASSIST_INITIALIZE_PARAMS_V1
  • ppGeometryDescs : _NVAPI_D3D12_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_INPUTS_EX
  • ppNvGazeHandler : _NV_GAZE_HANDLER_INIT_PARAMS_V1, _NV_GAZE_HANDLER_INIT_PARAMS_V2
  • pPostbuildInfoDescs : _NVAPI_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_EX_PARAMS_V1, _NVAPI_BUILD_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PARAMS_V1, _NVAPI_BUILD_RAYTRACING_OPACITY_MICROMAP_ARRAY_PARAMS_V1
  • ppShadingRateResource : _NV_VRS_HELPER_GET_SHADING_RATE_RESOURCE_PARAMS_V1
  • ppVRSHelper : _NV_VRS_HELPER_INIT_PARAMS_V1
  • Precision : NV_META_COMMAND_CREATE_CONVOLUTION_EX_DESC, NV_META_COMMAND_CREATE_GEMM_DESC
  • pRects : _NV_D3D11_EXCLUSIVE_SCISSOR_RECTS_DESC_V1
  • pRemapCBData : _NV_SMP_ASSIST_GET_CONSTANTS_V3
  • PresentCount : _NV_PRESENT_BARRIER_FRAME_STATISTICS
  • presentEndTime : _NV_LATENCY_RESULT_PARAMS::FrameReport
  • presentFrameID : _NV_ASYNC_FRAME_MARKER_PARAMS_V1
  • PresentInSyncCount : _NV_PRESENT_BARRIER_FRAME_STATISTICS
  • presentStartTime : _NV_LATENCY_RESULT_PARAMS::FrameReport
  • previousFrameAFRIndex : NV_GET_CURRENT_SLI_STATE_V1, NV_GET_CURRENT_SLI_STATE_V2
  • primary : _NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_V1
  • productName : _NV_LICENSE_FEATURE_DETAILS_V2, _NV_LICENSE_FEATURE_DETAILS_V3, _NV_LICENSE_FEATURE_DETAILS_V4
  • profileName : _NVDRS_PROFILE_V1
  • ProgrammableSamplePositions : _NV_D3D11_FEATURE_DATA_RASTERIZER_SUPPORT
  • ProgrammableSamplePositionsEnable : NvAPI_D3D11_RASTERIZER_DESC_EX, NVAPI_D3D12_PSO_RASTERIZER_STATE_DESC_V1
  • projectionSizeHeight : _NV_SMP_ASSIST_GET_CONSTANTS_V3
  • projectionSizeWidth : _NV_SMP_ASSIST_GET_CONSTANTS_V3
  • property : NV_INFOFRAME_DATA
  • provIdx : _NV_GPU_CLIENT_ILLUM_ZONE_INFO_V1
  • pScissors : _NV_CUSTOM_RECTS_V1, _NV_SMP_ASSIST_GET_CONSTANTS_V3
  • psfSignalFormat : _NVVIOOUTPUTCONFIG_V1, _NVVIOOUTPUTCONFIG_V2, _NVVIOOUTPUTCONFIG_V3
  • pShaderName : NVAPI_D3D12_CREATE_CUBIN_SHADER_PARAMS
  • psoExtension : NVAPI_D3D12_PSO_EXTENSION_DESC_V1
  • pSources : _NVAPI_EMIT_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_POSTBUILD_INFO_PARAMS_V1, _NVAPI_EMIT_RAYTRACING_OPACITY_MICROMAP_ARRAY_POSTBUILD_INFO_PARAMS_V1
  • pstateId : _NV_GPU_PERF_PSTATES20_INFO_V2, NV_GPU_PERF_PSTATES20_INFO_V1, NV_GPU_PERF_PSTATES_INFO_V1, NV_GPU_PERF_PSTATES_INFO_V2
  • pstates : _NV_GPU_PERF_PSTATES20_INFO_V2, NV_GPU_PERF_PSTATES20_INFO_V1, NV_GPU_PERF_PSTATES_INFO_V1, NV_GPU_PERF_PSTATES_INFO_V2
  • pSwapChainBuffer : _NV_D3D12_MOSAIC_GETCOMPANIONALLOCATIONS, _NV_D3D12_MOSAIC_GETVIEWPORTANDGPUPARTITIONS
  • pViewport : _NV_D3D12_MOSAIC_GETVIEWPORTANDGPUPARTITIONS
  • pViewports : _NV_CUSTOM_RECTS_V1, _NV_D3D11_VIEWPORTS_SHADING_RATE_DESC_V1, _NV_SMP_ASSIST_GET_CONSTANTS_V3


  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all variables with links to the structures/unions they belong to:

- q -

  • qsyncEvent : NV_QSYNC_EVENT_DATA
  • QuadFillMode : NvAPI_D3D11_RASTERIZER_DESC_EX, NVAPI_D3D12_PSO_RASTERIZER_STATE_DESC_V1
  • quadro : _NVDRS_GPU_SUPPORT
  • quantizationRangeRgb : _NV_MONITOR_CAPS_VCDB
  • quantizationRangeYcc : _NV_MONITOR_CAPS_VCDB


  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all variables with links to the structures/unions they belong to:

- r -

  • range : NV_GPU_PSTATE20_CLOCK_ENTRY_V1
  • rayTracingCores : _NV_GPU_INFO_V2
  • rdmaHeapSize : _NV_D3D12_WORKSTATION_FEATURE_RDMA_PROPERTIES
  • rdmaInfo : _NV_D3D12_WORKSTATION_FEATURE_PROPERTIES
  • RefreshCount : _NV_PRESENT_BARRIER_FRAME_STATISTICS
  • refreshRate : _NV_GSYNC_STATUS_PARAMS_V1, _NV_GSYNC_STATUS_PARAMS_V2, NV_DISPLAY_PATH
  • refreshRate1K : _NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_V1
  • regAddrSize : NV_I2C_INFO_V1, NV_I2C_INFO_V2, NV_I2C_INFO_V3
  • RegisterMask : _NV_CUSTOM_SEMANTIC
  • RegisterNum : _NV_CUSTOM_SEMANTIC
  • registerSpace : NVAPI_D3D12_PSO_SET_SHADER_EXTENSION_SLOT_DESC_V1
  • RegisterSpecified : _NV_CUSTOM_SEMANTIC
  • relativeSizeDown : _NV_LMS_CUSTOM_CONFIG_V1
  • relativeSizeLeft : _NV_LMS_CUSTOM_CONFIG_V1
  • relativeSizeRight : _NV_LMS_CUSTOM_CONFIG_V1
  • relativeSizeUp : _NV_LMS_CUSTOM_CONFIG_V1
  • remoteDeviceInfo : NVLINK_LINK_STATUS_INFO_V1, NVLINK_LINK_STATUS_INFO_V2
  • remoteDeviceLinkNumber : NVLINK_LINK_STATUS_INFO_V1, NVLINK_LINK_STATUS_INFO_V2
  • RenderMode : _NV_VRS_HELPER_ENABLE_PARAMS_V1
  • renderSubmitEndTime : _NV_LATENCY_RESULT_PARAMS::FrameReport
  • renderSubmitStartTime : _NV_LATENCY_RESULT_PARAMS::FrameReport
  • renderTargetIndexOffset : _NV_MULTIVIEW_PARAMS_V1
  • rep : tagNV_TIMINGEXT
  • Reserved : _NV_CUSTOM_SEMANTIC
  • reserved : _NV_D3D12_GRAPHICS_CAPS_V1, _NV_D3D1x_GRAPHICS_CAPS_V1, _NV_D3D1x_GRAPHICS_CAPS_V2, _NV_DISPLAY_DRIVER_INFO, _NV_DISPLAY_DRIVER_INFO_V2, _NV_DISPLAY_PORT_INFO_V1, _NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_V1, _NV_DISPLAYCONFIG_PATH_INFO_V2, _NV_DISPLAYCONFIG_SOURCE_MODE_INFO_V1, _NV_EDID_DATA_V2, _NV_GET_ADAPTIVE_SYNC_DATA_V1, _NV_GET_VRR_INFO_V1, _NV_GPU_DISPLAYIDS, _NV_GPU_GSP_INFO_V1, _NV_GPU_INFO_V1, _NV_GPU_PERF_PSTATES20_INFO_V2, _NV_GPU_VIRTUALIZATION_INFO, _NV_GPU_VR_READY_V1, _NV_GSYNC_CAPABILITIES_V3, _NV_GSYNC_CONTROL_PARAMS_V1, _NV_GSYNC_CONTROL_PARAMS_V2, _NV_GSYNC_DISPLAY, _NV_GSYNC_GPU, _NV_GSYNC_STATUS_PARAMS_V2, _NV_HDMI_SUPPORT_INFO_V1, _NV_HDMI_SUPPORT_INFO_V2, _NV_HDR_CAPABILITIES_V1, _NV_HDR_CAPABILITIES_V2, _NV_HDR_CAPABILITIES_V3, _NV_LICENSABLE_FEATURES_V1, _NV_LICENSABLE_FEATURES_V2, _NV_LICENSABLE_FEATURES_V3, _NV_LICENSABLE_FEATURES_V4, _NV_LICENSE_FEATURE_DETAILS_V1, _NV_LICENSE_FEATURE_DETAILS_V2, _NV_LICENSE_FEATURE_DETAILS_V3, _NV_LICENSE_FEATURE_DETAILS_V4, _NV_LOGICAL_GPU_DATA_V1, _NV_LOGICAL_GPU_HANDLE_DATA, _NV_LOGICAL_GPUS, _NV_MANAGED_DEDICATED_DISPLAY_INFO, _NV_MANAGED_DEDICATED_DISPLAY_METADATA, _NV_MODIFIED_W_PARAMS, _NV_MONITOR_CAPS_GENERIC, _NV_MOSAIC_GRID_TOPO_V1, _NV_MOSAIC_GRID_TOPO_V2, _NV_MULTIGPU_CAPS_V1, _NV_MULTIGPU_CAPS_V2, _NV_PHYSICAL_GPUS, _NV_QUERY_MULTIVIEW_SUPPORT_PARAMS_V1, _NV_QUERY_SINGLE_PASS_STEREO_SUPPORT_PARAMS_V2, _NV_SET_ADAPTIVE_SYNC_DATA_V1
  • Reserved : _NV_SMP_ASSIST_DISABLE_PARAMS_V1
  • reserved : _NV_VRS_HELPER_DISABLE_PARAMS_V1, _NV_VRS_HELPER_PURGE_INTERNAL_RESOURCES_PARAMS_V1, _NVAPI_STEREO_CAPS, _NVDRS_APPLICATION_V3, _NVDRS_APPLICATION_V4, NV_GET_PREFERRED_STEREO_DISPLAY_V1, NV_GPU_CLOCK_FREQUENCIES_V1, NV_GPU_CLOCK_FREQUENCIES_V2, NV_GPU_PERF_PSTATES20_INFO_V1, NV_GPU_PSTATE20_BASE_VOLTAGE_ENTRY_V1, NV_GPU_PSTATE20_CLOCK_ENTRY_V1, NV_INFOFRAME_PROPERTY, NV_MOSAIC_DISPLAY_TOPO_STATUS, NV_QSYNC_EVENT_DATA, NV_SET_PREFERRED_STEREO_DISPLAY_V1, NvAPI_D3D11_CREATE_PIXEL_SHADER_EX_V2, NvAPI_D3D11_RASTERIZER_DESC_EX, NVAPI_D3D12_PSO_RASTERIZER_STATE_DESC_V1, NVLINK_LINK_STATUS_INFO_V1, NVLINK_LINK_STATUS_INFO_V2
  • reserved0 : _NV_GPU_INFO_V2, NV_TIMING_FLAG
  • reserved1 : _NV_GPU_INFO_V2, NV_GPU_CLOCK_FREQUENCIES_V2
  • reserved10 : _NVDRS_GPU_SUPPORT
  • reserved11 : _NVDRS_GPU_SUPPORT
  • reserved12 : _NVDRS_GPU_SUPPORT
  • reserved13 : _NV_MONITOR_CAPS_VSDB, _NVDRS_GPU_SUPPORT
  • reserved14 : _NVDRS_GPU_SUPPORT
  • reserved15 : _NVDRS_GPU_SUPPORT
  • reserved16 : _NVDRS_GPU_SUPPORT
  • reserved17 : _NVDRS_GPU_SUPPORT
  • reserved18 : _NVDRS_GPU_SUPPORT
  • reserved19 : _NVDRS_GPU_SUPPORT
  • reserved2 : _NV_GPU_INFO_V2, _NV_PHYSICAL_GPU_HANDLE_DATA, _NVAPI_STEREO_CAPS
  • reserved20 : _NVDRS_GPU_SUPPORT
  • reserved21 : _NVDRS_GPU_SUPPORT
  • reserved22 : _NVDRS_GPU_SUPPORT
  • reserved23 : _NVDRS_GPU_SUPPORT
  • reserved24 : _NVDRS_GPU_SUPPORT
  • reserved25 : _NVDRS_GPU_SUPPORT
  • reserved26 : _NVDRS_GPU_SUPPORT
  • reserved27 : _NVDRS_GPU_SUPPORT
  • reserved28 : _NVDRS_GPU_SUPPORT
  • reserved29 : _NVDRS_GPU_SUPPORT
  • reserved30 : _NVDRS_GPU_SUPPORT
  • reserved31 : _NVDRS_GPU_SUPPORT
  • reserved32 : _NVDRS_GPU_SUPPORT
  • reserved4 : _NVDRS_GPU_SUPPORT
  • reserved5 : _NVDRS_GPU_SUPPORT
  • reserved6 : _NV_MONITOR_CAPS_VSDB, _NVDRS_GPU_SUPPORT
  • reserved7 : _NVDRS_GPU_SUPPORT
  • reserved8 : _NV_MONITOR_CAPS_VSDB, _NVDRS_GPU_SUPPORT
  • reserved9 : _NVDRS_GPU_SUPPORT
  • reserved_sourceId : _NV_DISPLAYCONFIG_PATH_INFO_V1, _NV_DISPLAYCONFIG_PATH_INFO_V2
  • reservedBit1 : _NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_V1
  • reservedBits : _NV_D3D12_GRAPHICS_CAPS_V1, _NV_D3D1x_GRAPHICS_CAPS_V1, _NV_D3D1x_GRAPHICS_CAPS_V2
  • reservedData : _NVVIOOUTPUTCONFIG_V1, _NVVIOOUTPUTCONFIG_V2, _NVVIOOUTPUTCONFIG_V3
  • reservedEx : _NV_DISPLAY_DRIVER_INFO_V2, _NV_GET_ADAPTIVE_SYNC_DATA_V1, _NV_GET_VIRTUAL_REFRESH_RATE_DATA_V1, _NV_GET_VRR_INFO_V1, _NV_SET_ADAPTIVE_SYNC_DATA_V1, _NV_SET_VIRTUAL_REFRESH_RATE_DATA_V1, NVLINK_LINK_STATUS_INFO_V2
  • reservedInternal : _NV_GPU_DISPLAYIDS
  • resolution : _NV_DISPLAYCONFIG_SOURCE_MODE_INFO_V1
  • resolutionScale : _NV_SMP_ASSIST_SETUP_PARAMS_V1
  • ResourceHandle : NV_D3D11_META_COMMAND_RESOURCE
  • resultDataMaxSizeInBytes : _NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PREBUILD_INFO, _NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_ARRAY_PREBUILD_INFO
  • revision : _NV_GSYNC_CAPABILITIES_V1, _NV_GSYNC_CAPABILITIES_V2, _NV_GSYNC_CAPABILITIES_V3, NV_GPU_ARCH_INFO_V1, NV_GPU_ARCH_INFO_V2
  • revision_id : NV_GPU_ARCH_INFO_V2
  • rgb : _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_V1, _NV_GPU_CLIENT_ILLUM_ZONE_INFO_V1
  • rgbParams : _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_RGB, _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR_RGB
  • rgbQuantizationRange : NV_INFOFRAME_VIDEO
  • rgbw : _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_V1, _NV_GPU_CLIENT_ILLUM_ZONE_INFO_V1
  • rgbwParams : _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_RGBW, _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR_RGBW
  • rid : NvShaderExtnStruct
  • right : _NV_RECT
  • right_bar : NV_INFOFRAME_VIDEO
  • rightCoeffs : _NV_SMP_ASSIST_UPDATE_INSTANCEDSTEREO_DATA_PARAMS_V1
  • rightConst : _NV_SMP_ASSIST_UPDATE_INSTANCEDSTEREO_DATA_PARAMS_V1
  • riseTimems : _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR
  • RJ45_Ethernet : _NV_GSYNC_STATUS_PARAMS_V1, _NV_GSYNC_STATUS_PARAMS_V2
  • RJ45_IO : _NV_GSYNC_STATUS_PARAMS_V1, _NV_GSYNC_STATUS_PARAMS_V2
  • rotation : _NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_V1, _NV_MOSAIC_GRID_TOPO_DISPLAY_V1, _NV_MOSAIC_GRID_TOPO_DISPLAY_V2, NV_DISPLAY_PATH
  • rowCount : NV_MOSAIC_TOPO_DETAILS, NV_MOSAIC_TOPOLOGY
  • rows : _NV_MOSAIC_GRID_TOPO_V1, _NV_MOSAIC_GRID_TOPO_V2
  • rr : _NV_TIMING_INPUT, tagNV_TIMINGEXT
  • rrx1k : NV_MOSAIC_DISPLAY_SETTING_V2, tagNV_TIMINGEXT
  • rsvd : _NV_ASYNC_FRAME_MARKER_PARAMS_V1, _NV_CLIENT_CALLBACK_SETTINGS_SUPER_V1, _NV_GET_SLEEP_STATUS_PARAMS, _NV_GPU_CLIENT_CALLBACK_DATA_SUPER_V1, _NV_GPU_CLIENT_CALLBACK_UTILIZATION_DATA_V1, _NV_GPU_CLIENT_ILLUM_DEVICE_INFO_PARAMS_V1, _NV_GPU_CLIENT_ILLUM_DEVICE_INFO_V1, _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_COLOR_FIXED, _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_RGB, _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_RGBW, _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_SINGLE_COLOR, _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_PARAMS_V1, _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_V1, _NV_GPU_CLIENT_ILLUM_ZONE_INFO_DATA_RGB, _NV_GPU_CLIENT_ILLUM_ZONE_INFO_DATA_RGBW, _NV_GPU_CLIENT_ILLUM_ZONE_INFO_DATA_SINGLE_COLOR, _NV_GPU_CLIENT_ILLUM_ZONE_INFO_PARAMS_V1, _NV_GPU_CLIENT_ILLUM_ZONE_INFO_V1, _NV_GPU_CLIENT_PERIODIC_CALLBACK_SETTINGS_SUPER_V1, _NV_GPU_CLIENT_UTILIZATION_DATA_V1, _NV_GPU_CLIENT_UTILIZATION_PERIODIC_CALLBACK_SETTINGS_V1, _NV_LATENCY_MARKER_PARAMS, _NV_LATENCY_RESULT_PARAMS::FrameReport, _NV_LATENCY_RESULT_PARAMS, _NV_SET_REFLEX_SYNC_PARAMS, _NV_SET_SLEEP_MODE_PARAMS, NV_GPU_CLIENT_ILLUM_DEVICE_CONTROL_PARAMS_V1, NV_GPU_CLIENT_ILLUM_DEVICE_CONTROL_V1, NV_GPU_CLIENT_ILLUM_DEVICE_SYNC_V1
  • rsvd0 : _NV_LATENCY_MARKER_PARAMS
  • rsvdField : _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_PARAMS_V1
  • rxSublinkStatus : NVLINK_LINK_STATUS_INFO_V1, NVLINK_LINK_STATUS_INFO_V2


  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all variables with links to the structures/unions they belong to:

- s -

  • SampleCount : NvAPI_D3D11_RASTERIZER_DESC_EX, NVAPI_D3D12_PSO_RASTERIZER_STATE_DESC_V1
  • SamplePositionsX : NvAPI_D3D11_RASTERIZER_DESC_EX, NVAPI_D3D12_PSO_RASTERIZER_STATE_DESC_V1
  • SamplePositionsY : NvAPI_D3D11_RASTERIZER_DESC_EX, NVAPI_D3D12_PSO_RASTERIZER_STATE_DESC_V1
  • sampleRate : NV_INFOFRAME_AUDIO
  • sampleSize : NV_INFOFRAME_AUDIO
  • sampling : _NVVIOSTREAM
  • samplingFormat : _NVVIOCHANNELSTATUS
  • scaling : _NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_V1, NV_DISPLAY_PATH, NV_TIMING_FLAG
  • scanInfo : NV_INFOFRAME_VIDEO
  • scanInfoCEVideoFormats : _NV_MONITOR_CAPS_VCDB
  • scanInfoITVideoFormats : _NV_MONITOR_CAPS_VCDB
  • scanInfoPreferredVideoFormat : _NV_MONITOR_CAPS_VCDB
  • ScissorEnable : NvAPI_D3D11_RASTERIZER_DESC_EX
  • scissorRect : _NV_D3D11_EXCLUSIVE_SCISSOR_RECT_DESC_V1
  • scratchAccelerationStructureData : _NVAPI_D3D12_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_DESC_EX
  • scratchDataSizeInBytes : _NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PREBUILD_INFO, _NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_ARRAY_PREBUILD_INFO
  • scratchDisplacementMicromapArrayData : _NVAPI_D3D12_BUILD_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_DESC
  • scratchOpacityMicromapArrayData : _NVAPI_D3D12_BUILD_RAYTRACING_OPACITY_MICROMAP_ARRAY_DESC
  • sCustomRects : _NV_SMP_ASSIST_SETUP_PARAMS_V1
  • sdiSyncIn : _NVVIOOUTPUTSTATUS
  • sec : _NV_LICENSE_EXPIRY_DETAILS
  • sensor : NV_GPU_THERMAL_SETTINGS_V1, NV_GPU_THERMAL_SETTINGS_V2
  • serializedDataType : _NVAPI_CHECK_DRIVER_MATCHING_IDENTIFIER_EX_PARAMS_V1
  • settingId : _NVDRS_SETTING_V1, _SettingDWORDNameString, _SettingWSTRINGNameString
  • settingLocation : _NVDRS_SETTING_V1
  • settingName : _NVDRS_SETTING_V1
  • settingNameString : _SettingDWORDNameString, _SettingWSTRINGNameString
  • settingType : _NVDRS_SETTING_V1, _NVDRS_SETTING_VALUES
  • settingValues : _NVDRS_SETTING_VALUES, _SettingDWORDNameString, _SettingWSTRINGNameString
  • sFoveatedRenderingDesc : _NV_VRS_HELPER_ENABLE_PARAMS_V1
  • ShadingRateCustomPresetDesc : _NV_FOVEATED_RENDERING_DESC_V1
  • ShadingRatePreset : _NV_FOVEATED_RENDERING_DESC_V1
  • shadingRateTable : _NV_D3D11_VIEWPORT_SHADING_RATE_DESC_V1, _NV_VRS_HELPER_GET_SHADING_RATE_RESOURCE_PARAMS_V1
  • sharedSystemMemory : NV_DISPLAY_DRIVER_MEMORY_INFO_V1, NV_DISPLAY_DRIVER_MEMORY_INFO_V2, NV_DISPLAY_DRIVER_MEMORY_INFO_V3, NV_GPU_MEMORY_INFO_EX_V1
  • sHeight : NvSBox
  • sid : NvShaderExtnStruct
  • signalFormat : _NVVIOCHANNELSTATUS, _NVVIOINPUTCONFIG, _NVVIOOUTPUTCONFIG_V1, _NVVIOOUTPUTCONFIG_V2, _NVVIOOUTPUTCONFIG_V3, _NVVIOSIGNALFORMATDETAIL
  • signature : _NV_LICENSABLE_FEATURES_V1, _NV_LICENSABLE_FEATURES_V2, _NV_LICENSABLE_FEATURES_V3, _NV_LICENSABLE_FEATURES_V4
  • simEndTime : _NV_LATENCY_RESULT_PARAMS::FrameReport
  • simStartTime : _NV_LATENCY_RESULT_PARAMS::FrameReport
  • single : NV_GPU_PSTATE20_CLOCK_ENTRY_V1
  • singleBitErrors : NV_GPU_ECC_ERROR_INFO
  • singleColor : _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_V1, _NV_GPU_CLIENT_ILLUM_ZONE_INFO_V1
  • singleColorParams : _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_SINGLE_COLOR, _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR_SINGLE_COLOR
  • size : _NV_COLOR_DATA_V1, _NV_COLOR_DATA_V2, _NV_COLOR_DATA_V3, _NV_COLOR_DATA_V4, _NV_COLOR_DATA_V5, _NV_MONITOR_CAPABILITIES_V1, NV_INFOFRAME_DATA
  • Size : NV_META_COMMAND_TENSOR_DESC
  • size : NVAPI_D3D12_CREATE_CUBIN_SHADER_PARAMS
  • sizeOfEDID : _NV_EDID_DATA_V1, _NV_EDID_DATA_V2
  • sizeofEDID : NV_EDID_V2, NV_EDID_V3
  • SkipConnectionResource : NV_D3D11_META_COMMAND_EXECUTE_CONVOLUTION_EX_DESC, NV_D3D12_META_COMMAND_EXECUTE_CONVOLUTION_EX_DESC
  • SkipMode : NV_META_COMMAND_CONVOLUTION_FUSE_DESC
  • sleepIntervalUs : _NV_GET_SLEEP_STATUS_PARAMS
  • sLeftConfig : _NV_LMS_INSTANCED_STEREO_CONFIG_V1
  • sLeftEye : _NV_FOVEATED_RENDERING_UPDATE_GAZE_DATA_PARAMS
  • sLMS_ISConfig : _NV_SMP_ASSIST_GET_CONSTANTS_V3
  • sLMSConfig : _NV_SMP_ASSIST_GET_CONSTANTS_V3
  • sLMSCustomConfig : _NV_SMP_ASSIST_SETUP_PARAMS_V1
  • SlopeScaledDepthBias : NvAPI_D3D11_RASTERIZER_DESC_EX
  • sMonoData : _NV_FOVEATED_RENDERING_UPDATE_GAZE_DATA_PARAMS
  • smpDesc : NVAPI_D3D12_GET_CUDA_MERGED_TEXTURE_SAMPLER_OBJECT_PARAMS
  • smpte352 : _NVVIOCHANNELSTATUS
  • sMRS_ISConfig : _NV_SMP_ASSIST_GET_CONSTANTS_V3
  • sMRSConfig : _NV_SMP_ASSIST_GET_CONSTANTS_V3
  • sMRSCustomConfig : _NV_SMP_ASSIST_SETUP_PARAMS_V1
  • source : _NV_GSYNC_CONTROL_PARAMS_V1, _NV_GSYNC_CONTROL_PARAMS_V2
  • sourceAccelerationStructureData : _NVAPI_D3D12_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_DESC_EX
  • sourceDesktopRect : _NV_SCANOUT_INFORMATION
  • sourceId : _NV_DISPLAYCONFIG_PATH_INFO_V2, NV_DISPLAY_PATH, NV_VIEW_TARGET_INFO
  • sourceModeInfo : _NV_DISPLAYCONFIG_PATH_INFO_V1, _NV_DISPLAYCONFIG_PATH_INFO_V2
  • sourcePhysicalAddressA : _NV_MONITOR_CAPS_VSDB
  • sourcePhysicalAddressB : _NV_MONITOR_CAPS_VSDB
  • sourcePhysicalAddressC : _NV_MONITOR_CAPS_VSDB
  • sourcePhysicalAddressD : _NV_MONITOR_CAPS_VSDB
  • sourceToTargetRotation : _NV_SCANOUT_INFORMATION
  • sourceViewportRect : _NV_SCANOUT_INFORMATION
  • spanningOrientation : _NV_DISPLAYCONFIG_SOURCE_MODE_INFO_V1
  • speakerPlacement : NV_INFOFRAME_AUDIO
  • src0u : NvShaderExtnStruct
  • src1u : NvShaderExtnStruct
  • src2u : NvShaderExtnStruct
  • src3u : NvShaderExtnStruct
  • src4u : NvShaderExtnStruct
  • src5u : NvShaderExtnStruct
  • srcPartition : NV_CUSTOM_DISPLAY
  • sRightConfig : _NV_LMS_INSTANCED_STEREO_CONFIG_V1
  • sRightEye : _NV_FOVEATED_RENDERING_UPDATE_GAZE_DATA_PARAMS
  • sStereoData : _NV_FOVEATED_RENDERING_UPDATE_GAZE_DATA_PARAMS
  • StartPadding : NV_META_COMMAND_CREATE_CONVOLUTION_EX_DESC
  • startupDelay : _NV_GSYNC_CONTROL_PARAMS_V1, _NV_GSYNC_CONTROL_PARAMS_V2
  • static_metadata_descriptor_id : _NV_HDR_CAPABILITIES_V1, _NV_HDR_CAPABILITIES_V2, _NV_HDR_CAPABILITIES_V3, _NV_HDR_COLOR_DATA_V1, _NV_HDR_COLOR_DATA_V2
  • status : _NV_LICENSE_EXPIRY_DETAILS, tagNV_TIMINGEXT
  • streams : _NVVIOINPUTCONFIG
  • Stride : NV_META_COMMAND_CREATE_CONVOLUTION_EX_DESC, NV_META_COMMAND_TENSOR_DESC
  • structSizeIn : NVAPI_D3D12_CREATE_CUBIN_SHADER_PARAMS, NVAPI_D3D12_GET_CUDA_INDEPENDENT_DESCRIPTOR_OBJECT_PARAMS, NVAPI_D3D12_GET_CUDA_MERGED_TEXTURE_SAMPLER_OBJECT_PARAMS
  • structSizeOut : NVAPI_D3D12_CREATE_CUBIN_SHADER_PARAMS, NVAPI_D3D12_GET_CUDA_INDEPENDENT_DESCRIPTOR_OBJECT_PARAMS, NVAPI_D3D12_GET_CUDA_MERGED_TEXTURE_SAMPLER_OBJECT_PARAMS
  • subdivisionLevel : _NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_DESC, _NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_USAGE_COUNT, _NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_DESC, _NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_USAGE_COUNT
  • subLinkWidth : NVLINK_LINK_STATUS_INFO_V1, NVLINK_LINK_STATUS_INFO_V2
  • subSysDeviceId : NV_CHIPSET_INFO_v3, NV_CHIPSET_INFO_v4
  • subSysVendorId : NV_CHIPSET_INFO_v3, NV_CHIPSET_INFO_v4
  • super : _NV_GPU_CLIENT_CALLBACK_UTILIZATION_DATA_V1, _NV_GPU_CLIENT_PERIODIC_CALLBACK_SETTINGS_SUPER_V1, _NV_GPU_CLIENT_UTILIZATION_PERIODIC_CALLBACK_SETTINGS_V1
  • supportAI : _NV_MONITOR_CAPS_VSDB
  • supportDeepColor30bits : _NV_MONITOR_CAPS_VSDB
  • supportDeepColor36bits : _NV_MONITOR_CAPS_VSDB
  • supportDeepColor48bits : _NV_MONITOR_CAPS_VSDB
  • supportDeepColorYCbCr444 : _NV_MONITOR_CAPS_VSDB
  • supportDualDviOperation : _NV_MONITOR_CAPS_VSDB
  • supported : _NV_D3D12_WORKSTATION_FEATURE_PROPERTIES
  • supports_10b_12b_444 : _NV_HDR_CAPABILITIES_V2, _NV_HDR_CAPABILITIES_V3
  • supports_2160p60hz : _NV_HDR_CAPABILITIES_V2, _NV_HDR_CAPABILITIES_V3
  • supports_backlight_control : _NV_HDR_CAPABILITIES_V2, _NV_HDR_CAPABILITIES_V3
  • supports_global_dimming : _NV_HDR_CAPABILITIES_V2, _NV_HDR_CAPABILITIES_V3
  • supports_YUV422_12bit : _NV_HDR_CAPABILITIES_V2, _NV_HDR_CAPABILITIES_V3
  • supportsRotation : NV_MOSAIC_DISPLAY_TOPO_STATUS
  • supportsWindowedModeAutomatic : _NVAPI_STEREO_CAPS
  • supportsWindowedModeOff : _NVAPI_STEREO_CAPS
  • supportsWindowedModePersistent : _NVAPI_STEREO_CAPS
  • supportULMB : _NV_MONITOR_CAPS_GENERIC
  • supportVRR : _NV_MONITOR_CAPS_GENERIC
  • surfaceHandle : NVAPI_UAV_INFO_V1, NVAPI_UAV_INFO_V2
  • sViewOffset : _NV_DX_VIDEO_STEREO_INFO
  • sWidth : NvSBox
  • sX : NvSBox
  • sY : NvSBox
  • syncData : NV_GPU_CLIENT_ILLUM_DEVICE_CONTROL_V1
  • syncDelay : _NVVIOOUTPUTCONFIG_V1, _NVVIOOUTPUTCONFIG_V2, _NVVIOOUTPUTCONFIG_V3
  • syncEnable : _NVVIOOUTPUTCONFIG_V1, _NVVIOOUTPUTCONFIG_V2, _NVVIOOUTPUTCONFIG_V3, _NVVIOOUTPUTSTATUS
  • syncFormat : _NVVIOOUTPUTSTATUS
  • SyncMode : _NV_PRESENT_BARRIER_FRAME_STATISTICS
  • syncSkew : _NV_GSYNC_CONTROL_PARAMS_V1, _NV_GSYNC_CONTROL_PARAMS_V2
  • syncSource : _NVVIOOUTPUTCONFIG_V1, _NVVIOOUTPUTCONFIG_V2, _NVVIOOUTPUTCONFIG_V3, _NVVIOOUTPUTSTATUS
  • syncSourceIsOutput : _NV_GSYNC_CONTROL_PARAMS_V1, _NV_GSYNC_CONTROL_PARAMS_V2
  • syncState : _NV_GSYNC_DISPLAY
  • systemVideoMemory : NV_DISPLAY_DRIVER_MEMORY_INFO_V1, NV_DISPLAY_DRIVER_MEMORY_INFO_V2, NV_DISPLAY_DRIVER_MEMORY_INFO_V3, NV_GPU_MEMORY_INFO_EX_V1
  • szAdapterString : NV_DISPLAY_DRIVER_VERSION
  • szBuildBaseBranch : _NV_DISPLAY_DRIVER_INFO_V2
  • szBuildBranch : _NV_DISPLAY_DRIVER_INFO, _NV_DISPLAY_DRIVER_INFO_V2
  • szBuildBranchString : NV_DISPLAY_DRIVER_VERSION
  • szChipsetName : NV_CHIPSET_INFO_v1, NV_CHIPSET_INFO_v2, NV_CHIPSET_INFO_v3, NV_CHIPSET_INFO_v4
  • szSubSysVendorName : NV_CHIPSET_INFO_v3, NV_CHIPSET_INFO_v4
  • szVendorName : NV_CHIPSET_INFO_v1, NV_CHIPSET_INFO_v2, NV_CHIPSET_INFO_v3, NV_CHIPSET_INFO_v4


  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all variables with links to the structures/unions they belong to:

- t -

  • target : NV_GPU_THERMAL_SETTINGS_V1, NV_GPU_THERMAL_SETTINGS_V2, NV_VIEW_TARGET_INFO
  • target_max_luminance : _NV_HDR_CAPABILITIES_V2, _NV_HDR_CAPABILITIES_V3
  • target_min_luminance : _NV_HDR_CAPABILITIES_V2, _NV_HDR_CAPABILITIES_V3
  • targetDisplayHeight : _NV_SCANOUT_INFORMATION
  • targetDisplayWidth : _NV_SCANOUT_INFORMATION
  • targetId : _NV_DISPLAYCONFIG_PATH_TARGET_INFO_V2
  • TargetIndependentRasterWithDepth : _NV_D3D11_FEATURE_DATA_RASTERIZER_SUPPORT
  • TargetIndepentRasterWithDepth : NvAPI_D3D11_RASTERIZER_DESC_EX, NVAPI_D3D12_PSO_RASTERIZER_STATE_DESC_V1
  • targetInfo : _NV_DISPLAYCONFIG_PATH_INFO_V1, _NV_DISPLAYCONFIG_PATH_INFO_V2
  • targetInfoCount : _NV_DISPLAYCONFIG_PATH_INFO_V1, _NV_DISPLAYCONFIG_PATH_INFO_V2
  • targetViewportRect : _NV_SCANOUT_INFORMATION
  • TemporaryResource : NV_D3D11_META_COMMAND_EXECUTE_CONVOLUTION_EX_DESC, NV_D3D11_META_COMMAND_EXECUTE_GEMM_DESC, NV_D3D12_META_COMMAND_EXECUTE_CONVOLUTION_EX_DESC, NV_D3D12_META_COMMAND_EXECUTE_GEMM_DESC
  • tensorCores : _NV_GPU_INFO_V2
  • testColorChange : NV_DISPLAY_PORT_CONFIG
  • testLinkTrain : NV_DISPLAY_PORT_CONFIG
  • texDesc : NVAPI_D3D12_GET_CUDA_MERGED_TEXTURE_SAMPLER_OBJECT_PARAMS
  • Texture2D : _NV_D3D11_SHADING_RATE_RESOURCE_VIEW_DESC_V1
  • Texture2DArray : _NV_D3D11_SHADING_RATE_RESOURCE_VIEW_DESC_V1
  • textureHandle : NVAPI_D3D12_GET_CUDA_MERGED_TEXTURE_SAMPLER_OBJECT_PARAMS
  • textureRect : NV_SCANOUT_WARPING_DATA
  • timeInQueueUs : _NV_SET_REFLEX_SYNC_PARAMS
  • timeInQueueUsTarget : _NV_SET_REFLEX_SYNC_PARAMS
  • Timestamp : _NV_FOVEATED_RENDERING_UPDATE_GAZE_DATA_PARAMS
  • timestamp : _NV_GPU_CLIENT_CALLBACK_UTILIZATION_DATA_V1
  • timeStampms : NV_GPU_CLIENT_ILLUM_DEVICE_SYNC_V1
  • timing : _NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_V1, NV_CUSTOM_DISPLAY
  • timingOverride : _NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_V1
  • top : _NV_RECT
  • top_bar : NV_INFOFRAME_VIDEO
  • topo : NV_MOSAIC_TOPO_BRIEF
  • topoBriefs : _NV_MOSAIC_SUPPORTED_TOPO_INFO_V1, _NV_MOSAIC_SUPPORTED_TOPO_INFO_V2
  • topoBriefsCount : _NV_MOSAIC_SUPPORTED_TOPO_INFO_V1, _NV_MOSAIC_SUPPORTED_TOPO_INFO_V2
  • topos : NV_MOSAIC_SUPPORTED_TOPOLOGIES, NV_MOSAIC_TOPO_GROUP
  • totalCount : NV_MOSAIC_SUPPORTED_TOPOLOGIES
  • TransA : NV_META_COMMAND_CREATE_GEMM_DESC
  • TransB : NV_META_COMMAND_CREATE_GEMM_DESC
  • triangleMicromapBaseLocation : _NVAPI_D3D12_RAYTRACING_GEOMETRY_DMM_ATTACHMENT_DESC
  • triangleMicromapIndexBuffer : _NVAPI_D3D12_RAYTRACING_GEOMETRY_DMM_ATTACHMENT_DESC
  • triangleMicromapIndexFormat : _NVAPI_D3D12_RAYTRACING_GEOMETRY_DMM_ATTACHMENT_DESC
  • trianglePrimitiveFlagsBuffer : _NVAPI_D3D12_RAYTRACING_GEOMETRY_DMM_ATTACHMENT_DESC
  • triangles : _NVAPI_D3D12_RAYTRACING_GEOMETRY_DESC_EX, _NVAPI_D3D12_RAYTRACING_GEOMETRY_DMM_TRIANGLES_DESC, _NVAPI_D3D12_RAYTRACING_GEOMETRY_OMM_TRIANGLES_DESC
  • tvFormat : _NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_V1, NV_DISPLAY_PATH, NV_TIMING_FLAG
  • txSublinkStatus : NVLINK_LINK_STATUS_INFO_V1, NVLINK_LINK_STATUS_INFO_V2
  • type : _NV_GPU_CLIENT_ILLUM_DEVICE_INFO_V1, _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_V1, _NV_GPU_CLIENT_ILLUM_ZONE_INFO_V1, _NV_TIMING_INPUT, _NVAPI_D3D12_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_INPUTS_EX, _NVAPI_D3D12_RAYTRACING_GEOMETRY_DESC_EX, NV_GPU_CLIENT_ILLUM_DEVICE_CONTROL_V1, NV_INFOFRAME_DATA, NVAPI_D3D12_GET_CUDA_INDEPENDENT_DESCRIPTOR_OBJECT_PARAMS
  • typeId : NV_GPU_PSTATE20_CLOCK_ENTRY_V1


  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all variables with links to the structures/unions they belong to:

- u -

  • u32CurrentValue : _NVDRS_SETTING_V1
  • u32DefaultValue : _NVDRS_SETTING_VALUES
  • u32PredefinedValue : _NVDRS_SETTING_V1
  • u32Value : _NVDRS_SETTING_VALUES
  • uavSlot : NVAPI_D3D12_PSO_SET_SHADER_EXTENSION_SLOT_DESC_V1
  • uBlue : _NVVIOGAMMARAMP10, _NVVIOGAMMARAMP8
  • uEnabled : _NVVIOCOMPOSITERANGE
  • uGreen : _NVVIOGAMMARAMP10, _NVVIOGAMMARAMP8
  • uMax : _NVVIOCOMPOSITERANGE
  • uMin : _NVVIOCOMPOSITERANGE
  • unused : NV_D3D11_META_COMMAND_RESOURCE
  • uPowerOn : _NVVIOOUTPUTSTATUS
  • UpsampleMode : NV_META_COMMAND_CONVOLUTION_FUSE_DESC
  • uRange : _NVVIOCOMPOSITERANGE
  • uRed : _NVVIOGAMMARAMP10, _NVVIOGAMMARAMP8
  • UseAttributeSkipMask : NvAPI_D3D11_CREATE_GEOMETRY_SHADER_EX_V5, NVAPI_D3D12_PSO_GEOMETRY_SHADER_DESC_V5
  • UseCoordinateSwizzle : NvAPI_D3D11_CREATE_GEOMETRY_SHADER_EX_V5, NVAPI_D3D12_PSO_GEOMETRY_SHADER_DESC_V5
  • userFriendlyName : _NVDRS_APPLICATION_V1, _NVDRS_APPLICATION_V2, _NVDRS_APPLICATION_V3, _NVDRS_APPLICATION_V4
  • UseSpecificShaderExt : NvAPI_D3D11_CREATE_DOMAIN_SHADER_EX_V3, NvAPI_D3D11_CREATE_GEOMETRY_SHADER_EX_V5, NvAPI_D3D11_CREATE_HULL_SHADER_EX_V2, NvAPI_D3D11_CREATE_VERTEX_SHADER_EX_V3, NVAPI_D3D12_PSO_DOMAIN_SHADER_DESC_V3, NVAPI_D3D12_PSO_GEOMETRY_SHADER_DESC_V5, NVAPI_D3D12_PSO_HULL_SHADER_DESC_V2, NVAPI_D3D12_PSO_VERTEX_SHADER_DESC_V3
  • UseViewportMask : NvAPI_D3D11_CREATE_GEOMETRY_SHADER_EX_V5, NVAPI_D3D12_PSO_GEOMETRY_SHADER_DESC_V5
  • UseWithFastGS : NvAPI_D3D11_CREATE_DOMAIN_SHADER_EX_V2, NvAPI_D3D11_CREATE_DOMAIN_SHADER_EX_V3, NvAPI_D3D11_CREATE_HULL_SHADER_EX_V1, NvAPI_D3D11_CREATE_HULL_SHADER_EX_V2, NvAPI_D3D11_CREATE_VERTEX_SHADER_EX_V2, NvAPI_D3D11_CREATE_VERTEX_SHADER_EX_V3, NVAPI_D3D12_PSO_DOMAIN_SHADER_DESC_V2, NVAPI_D3D12_PSO_HULL_SHADER_DESC_V1, NVAPI_D3D12_PSO_VERTEX_SHADER_DESC_V2
  • uSyncSourceLocked : _NVVIOOUTPUTSTATUS
  • utilId : _NV_GPU_CLIENT_UTILIZATION_DATA_V1
  • utilization : NV_GPU_DYNAMIC_PSTATES_INFO_EX
  • utilizationPercent : _NV_GPU_CLIENT_UTILIZATION_DATA_V1
  • utils : _NV_GPU_CLIENT_CALLBACK_UTILIZATION_DATA_V1


  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all variables with links to the structures/unions they belong to:

- v -

  • validityMask : NV_MOSAIC_TOPO_DETAILS
  • Value : _NV_GPU_GET_ILLUMINATION_PARM_V1, _NV_GPU_SET_ILLUMINATION_PARM_V1
  • value : NV_GPU_PERF_PSTATES20_PARAM_DELTA
  • valueData : _NVDRS_BINARY_SETTING
  • valueLength : _NVDRS_BINARY_SETTING
  • valueRange : NV_GPU_PERF_PSTATES20_PARAM_DELTA
  • vblankIntervalUs : _NV_SET_REFLEX_SYNC_PARAMS
  • VBorder : _NV_TIMING
  • vcdb : _NV_MONITOR_CAPABILITIES_V1
  • vendorId : NV_CHIPSET_INFO_v1, NV_CHIPSET_INFO_v2, NV_CHIPSET_INFO_v3, NV_CHIPSET_INFO_v4
  • version : _NV_ASYNC_FRAME_MARKER_PARAMS_V1, _NV_BOARD_INFO, _NV_COLOR_DATA_V1, _NV_COLOR_DATA_V2, _NV_COLOR_DATA_V3, _NV_COLOR_DATA_V4, _NV_COLOR_DATA_V5, _NV_COMPUTE_GPU_TOPOLOGY_V2, _NV_CUSTOM_SEMANTIC, _NV_D3D11_EXCLUSIVE_SCISSOR_RECTS_DESC_V1, _NV_D3D11_SHADING_RATE_RESOURCE_VIEW_DESC_V1, _NV_D3D11_VIEWPORTS_SHADING_RATE_DESC_V1, _NV_D3D12_MOSAIC_GETCOMPANIONALLOCATIONS, _NV_D3D12_MOSAIC_GETVIEWPORTANDGPUPARTITIONS, _NV_D3D12_WORKSTATION_FEATURE_PROPERTIES, _NV_D3D_LATELATCH_OBJECT_DESC_V1, _NV_DISPLAY_DRIVER_INFO, _NV_DISPLAY_DRIVER_INFO_V2, _NV_DISPLAY_PORT_INFO_V1, _NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_V1, _NV_DISPLAYCONFIG_PATH_INFO_V1, _NV_DISPLAYCONFIG_PATH_INFO_V2, _NV_EDID_DATA_V1, _NV_EDID_DATA_V2, _NV_FOVEATED_RENDERING_CUSTOM_FOVEATION_PATTERN_PRESET_DESC_V1, _NV_FOVEATED_RENDERING_CUSTOM_SHADING_RATE_PRESET_DESC_V1, _NV_FOVEATED_RENDERING_DESC_V1, _NV_FOVEATED_RENDERING_GAZE_DATA_PER_EYE, _NV_FOVEATED_RENDERING_UPDATE_GAZE_DATA_PARAMS, _NV_GAZE_HANDLER_INIT_PARAMS_V1, _NV_GAZE_HANDLER_INIT_PARAMS_V2, _NV_GET_ADAPTIVE_SYNC_DATA_V1, _NV_GET_SLEEP_STATUS_PARAMS, _NV_GET_VIRTUAL_REFRESH_RATE_DATA_V1, _NV_GET_VRR_INFO_V1, _NV_GPU_CLIENT_ILLUM_DEVICE_INFO_PARAMS_V1, _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_PARAMS_V1, _NV_GPU_CLIENT_ILLUM_ZONE_INFO_PARAMS_V1, _NV_GPU_CLIENT_UTILIZATION_PERIODIC_CALLBACK_SETTINGS_V1, _NV_GPU_DISPLAYIDS, _NV_GPU_GET_ILLUMINATION_PARM_V1, _NV_GPU_GSP_INFO_V1, _NV_GPU_INFO_V1, _NV_GPU_INFO_V2, _NV_GPU_PERF_PSTATES20_INFO_V2, _NV_GPU_QUERY_ILLUMINATION_SUPPORT_PARM_V1, _NV_GPU_SET_ILLUMINATION_PARM_V1, _NV_GPU_VIRTUALIZATION_INFO, _NV_GPU_VR_READY_V1, _NV_GSYNC_CAPABILITIES_V1, _NV_GSYNC_CAPABILITIES_V2, _NV_GSYNC_CAPABILITIES_V3, _NV_GSYNC_CONTROL_PARAMS_V1, _NV_GSYNC_CONTROL_PARAMS_V2, _NV_GSYNC_DELAY, _NV_GSYNC_DISPLAY, _NV_GSYNC_GPU, _NV_GSYNC_STATUS, _NV_GSYNC_STATUS_PARAMS_V1, _NV_GSYNC_STATUS_PARAMS_V2, _NV_HDMI_SUPPORT_INFO_V1, _NV_HDMI_SUPPORT_INFO_V2, _NV_HDR_CAPABILITIES_V1, _NV_HDR_CAPABILITIES_V2, _NV_HDR_CAPABILITIES_V3, _NV_HDR_COLOR_DATA_V1, _NV_HDR_COLOR_DATA_V2, _NV_HDR_METADATA_V1, _NV_HEAP_PARAMS_V1, _NV_LATENCY_MARKER_PARAMS, _NV_LATENCY_RESULT_PARAMS, _NV_LICENSABLE_FEATURES_V1, _NV_LICENSABLE_FEATURES_V2, _NV_LICENSABLE_FEATURES_V3, _NV_LICENSABLE_FEATURES_V4, _NV_LICENSE_FEATURE_DETAILS_V1, _NV_LICENSE_FEATURE_DETAILS_V2, _NV_LICENSE_FEATURE_DETAILS_V3, _NV_LICENSE_FEATURE_DETAILS_V4, _NV_LOGICAL_GPU_DATA_V1, _NV_LOGICAL_GPUS, _NV_MANAGED_DEDICATED_DISPLAY_INFO, _NV_MANAGED_DEDICATED_DISPLAY_METADATA, _NV_MODIFIED_W_PARAMS, _NV_MONITOR_CAPABILITIES_V1, _NV_MONITOR_COLOR_DATA, _NV_MOSAIC_DISPLAY_SETTING_V1, _NV_MOSAIC_GRID_TOPO_DISPLAY_V2, _NV_MOSAIC_GRID_TOPO_V1, _NV_MOSAIC_GRID_TOPO_V2, _NV_MOSAIC_SUPPORTED_TOPO_INFO_V1, _NV_MOSAIC_SUPPORTED_TOPO_INFO_V2, _NV_MULTIGPU_CAPS_V2, _NV_MULTIVIEW_PARAMS_V1, _NV_PHYSICAL_GPUS, _NV_PIXEL_SHADING_RATE_SAMPLE_ORDER_TABLE_V1, _NV_QUERY_LATELATCH_SUPPORT_PARAMS, _NV_QUERY_MODIFIED_W_SUPPORT_PARAMS, _NV_QUERY_MULTIVIEW_SUPPORT_PARAMS_V1, _NV_QUERY_SINGLE_PASS_STEREO_SUPPORT_PARAMS_V1, _NV_QUERY_SINGLE_PASS_STEREO_SUPPORT_PARAMS_V2, _NV_QUERY_SMP_ASSIST_SUPPORT_PARAMS_V1, _NV_RESOURCE_PARAMS_V1, _NV_SCANOUT_INFORMATION, _NV_SCANOUT_INTENSITY_STATE_DATA, _NV_SCANOUT_WARPING_STATE_DATA, _NV_SET_ADAPTIVE_SYNC_DATA_V1, _NV_SET_REFLEX_SYNC_PARAMS, _NV_SET_SLEEP_MODE_PARAMS, _NV_SET_VIRTUAL_REFRESH_RATE_DATA_V1, _NV_SMP_ASSIST_DISABLE_PARAMS_V1, _NV_SMP_ASSIST_ENABLE_PARAMS_V1, _NV_SMP_ASSIST_GET_CONSTANTS_V3, _NV_SMP_ASSIST_INITIALIZE_PARAMS_V1, _NV_SMP_ASSIST_SETUP_PARAMS_V1, _NV_SMP_ASSIST_UPDATE_INSTANCEDSTEREO_DATA_PARAMS_V1, _NV_TIMING_INPUT, _NV_VIO_TOPOLOGY, _NV_VRS_HELPER_DISABLE_PARAMS_V1, _NV_VRS_HELPER_ENABLE_PARAMS_V1, _NV_VRS_HELPER_GET_SHADING_RATE_RESOURCE_PARAMS_V1, _NV_VRS_HELPER_INIT_PARAMS_V1, _NV_VRS_HELPER_LATCH_GAZE_PARAMS_V1, _NV_VRS_HELPER_PURGE_INTERNAL_RESOURCES_PARAMS_V1, _NVAPI_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_EX_PARAMS_V1, _NVAPI_BUILD_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PARAMS_V1, _NVAPI_BUILD_RAYTRACING_OPACITY_MICROMAP_ARRAY_PARAMS_V1, _NVAPI_CHECK_DRIVER_MATCHING_IDENTIFIER_EX_PARAMS_V1, _NVAPI_D3D12_SET_CREATE_PIPELINE_STATE_OPTIONS_PARAMS_V1, _NVAPI_EMIT_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_POSTBUILD_INFO_PARAMS_V1, _NVAPI_EMIT_RAYTRACING_OPACITY_MICROMAP_ARRAY_POSTBUILD_INFO_PARAMS_V1, _NVAPI_GET_RAYTRACING_ACCELERATION_STRUCTURE_PREBUILD_INFO_EX_PARAMS_V1, _NVAPI_GET_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PREBUILD_INFO_PARAMS_V1, _NVAPI_GET_RAYTRACING_OPACITY_MICROMAP_ARRAY_PREBUILD_INFO_PARAMS_V1, _NVAPI_RELOCATE_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PARAMS_V1, _NVAPI_RELOCATE_RAYTRACING_OPACITY_MICROMAP_ARRAY_PARAMS_V1, _NVAPI_STEREO_CAPS, _NVDRS_APPLICATION_V1, _NVDRS_APPLICATION_V2, _NVDRS_APPLICATION_V3, _NVDRS_APPLICATION_V4, _NVDRS_PROFILE_V1, _NVDRS_SETTING_V1, _NVDRS_SETTING_VALUES, _NVVIOCAPS, _NVVIOCOLORCONVERSION, _NVVIOCONFIG_V1, _NVVIOCONFIG_V2, _NVVIOCONFIG_V3, _NVVIOGAMMACORRECTION, _NVVIOPCIINFO, _NVVIOSTATUS, _NVVIOSYNCDELAY, NV_CHIPSET_INFO_v1, NV_CHIPSET_INFO_v2, NV_CHIPSET_INFO_v3, NV_CHIPSET_INFO_v4, NV_COMPUTE_GPU_TOPOLOGY_V1, NV_CUSTOM_DISPLAY, NV_DISPLAY_DRIVER_MEMORY_INFO_V1, NV_DISPLAY_DRIVER_MEMORY_INFO_V2, NV_DISPLAY_DRIVER_MEMORY_INFO_V3, NV_DISPLAY_DRIVER_VERSION, NV_DISPLAY_PATH_INFO, NV_DISPLAY_PATH_INFO_V3, NV_DISPLAY_PORT_CONFIG, NV_EDID_V1, NV_EDID_V2, NV_EDID_V3, NV_EVENT_REGISTER_CALLBACK, NV_GET_CURRENT_SLI_STATE_V1, NV_GET_CURRENT_SLI_STATE_V2, NV_GET_GPU_VIRTUAL_ADDRESS_V1, NV_GET_PREFERRED_STEREO_DISPLAY_V1, NV_GPU_ARCH_INFO_V1, NV_GPU_ARCH_INFO_V2, NV_GPU_CLIENT_ILLUM_DEVICE_CONTROL_PARAMS_V1, NV_GPU_CLOCK_FREQUENCIES_V1, NV_GPU_CLOCK_FREQUENCIES_V2, NV_GPU_DYNAMIC_PSTATES_INFO_EX, NV_GPU_ECC_CONFIGURATION_INFO, NV_GPU_ECC_ERROR_INFO, NV_GPU_ECC_STATUS_INFO, NV_GPU_GET_HDCP_SUPPORT_STATUS, NV_GPU_MEMORY_INFO_EX_V1, NV_GPU_PERF_PSTATES20_INFO_V1, NV_GPU_PERF_PSTATES_INFO_V1, NV_GPU_PERF_PSTATES_INFO_V2, NV_GPU_THERMAL_SETTINGS_V1, NV_GPU_THERMAL_SETTINGS_V2, NV_I2C_INFO_V1, NV_I2C_INFO_V2, NV_I2C_INFO_V3, NV_INFOFRAME_DATA, NV_INFOFRAME_PROPERTY, NV_LID_DOCK_PARAMS, NV_MOSAIC_DISPLAY_SETTING_V2, NV_MOSAIC_DISPLAY_TOPO_STATUS, NV_MOSAIC_SUPPORTED_TOPOLOGIES, NV_MOSAIC_TOPO_BRIEF, NV_MOSAIC_TOPO_DETAILS, NV_MOSAIC_TOPO_GROUP, NV_MOSAIC_TOPOLOGY, NV_SCANOUT_INTENSITY_DATA_V1, NV_SCANOUT_INTENSITY_DATA_V2, NV_SCANOUT_WARPING_DATA, NV_SET_PREFERRED_STEREO_DISPLAY_V1, NV_VIEW_TARGET_INFO, NVAPI_ANSEL_CONFIGURATION_STRUCT_V1, NvAPI_D3D11_CREATE_DOMAIN_SHADER_EX_V1, NvAPI_D3D11_CREATE_DOMAIN_SHADER_EX_V2, NvAPI_D3D11_CREATE_DOMAIN_SHADER_EX_V3, NvAPI_D3D11_CREATE_FASTGS_EXPLICIT_DESC_V1, NvAPI_D3D11_CREATE_GEOMETRY_SHADER_EX_V5, NvAPI_D3D11_CREATE_HULL_SHADER_EX_V1, NvAPI_D3D11_CREATE_HULL_SHADER_EX_V2, NvAPI_D3D11_CREATE_PIXEL_SHADER_EX_V1, NvAPI_D3D11_CREATE_PIXEL_SHADER_EX_V2, NvAPI_D3D11_CREATE_VERTEX_SHADER_EX_V1, NvAPI_D3D11_CREATE_VERTEX_SHADER_EX_V2, NvAPI_D3D11_CREATE_VERTEX_SHADER_EX_V3, NVAPI_D3D12_PSO_CREATE_FASTGS_EXPLICIT_DESC_V1, NVAPI_D3D12_PSO_DOMAIN_SHADER_DESC_V1, NVAPI_D3D12_PSO_ENABLE_DEPTH_BOUND_TEST_DESC_V1, NVAPI_D3D12_PSO_GEOMETRY_SHADER_DESC_V5, NVAPI_D3D12_PSO_HULL_SHADER_DESC_V1, NVAPI_D3D12_PSO_RASTERIZER_STATE_DESC_V1, NVAPI_D3D12_PSO_REQUEST_FAST_GEOMETRY_SHADER_DESC_V1, NVAPI_D3D12_PSO_SET_SHADER_EXTENSION_SLOT_DESC_V1, NVAPI_D3D12_PSO_VERTEX_SHADER_DESC_V1, NVAPI_UAV_INFO_V1, NVAPI_UAV_INFO_V2, NVLINK_GET_CAPS_V1, NVLINK_GET_STATUS_V1, NVLINK_GET_STATUS_V2
  • vertexBiasAndScaleBuffer : _NVAPI_D3D12_RAYTRACING_GEOMETRY_DMM_ATTACHMENT_DESC
  • vertexBiasAndScaleFormat : _NVAPI_D3D12_RAYTRACING_GEOMETRY_DMM_ATTACHMENT_DESC
  • vertexDisplacementVectorBuffer : _NVAPI_D3D12_RAYTRACING_GEOMETRY_DMM_ATTACHMENT_DESC
  • vertexDisplacementVectorFormat : _NVAPI_D3D12_RAYTRACING_GEOMETRY_DMM_ATTACHMENT_DESC
  • vertexFormat : NV_SCANOUT_WARPING_DATA
  • verticalDelay : _NVVIOSYNCDELAY
  • verticalLines : _NVVIOVIDEOMODE
  • vertices : NV_SCANOUT_WARPING_DATA
  • VFrontPorch : _NV_TIMING
  • vic : NV_INFOFRAME_VIDEO
  • vid1Out : _NVVIOOUTPUTSTATUS
  • vid2Out : _NVVIOOUTPUTSTATUS
  • video : NV_INFOFRAME_DATA
  • videoBridgePresent : _NV_MULTIGPU_CAPS_V1, _NV_MULTIGPU_CAPS_V2
  • videoLatency : _NV_MONITOR_CAPS_VSDB
  • videoMode : _NVVIOSIGNALFORMATDETAIL
  • videoStandard : _NVVIOVIDEOMODE
  • videoType : _NVVIOVIDEOMODE
  • vidIn : _NVVIOINPUTSTATUS
  • ViewDimension : _NV_D3D11_SHADING_RATE_RESOURCE_VIEW_DESC_V1
  • vioCaps : _NVVIODATAFORMATDETAIL
  • vioConfig : _NVVIOCONFIG_V1, _NVVIOCONFIG_V2, _NVVIOCONFIG_V3
  • vioGammaCorrectionType : _NVVIOGAMMACORRECTION
  • vioId : NVVIOTOPOLOGYTARGET
  • vioStatus : _NVVIOSTATUS
  • vioTarget : _NV_VIO_TOPOLOGY
  • vioTotalDeviceCount : _NV_VIO_TOPOLOGY
  • virtualizationMode : _NV_GPU_VIRTUALIZATION_INFO
  • vmode : _NV_GSYNC_CONTROL_PARAMS_V1, _NV_GSYNC_CONTROL_PARAMS_V2
  • volt_uV : NV_GPU_PSTATE20_BASE_VOLTAGE_ENTRY_V1
  • voltages : _NV_GPU_PERF_PSTATES20_INFO_V2, NV_GPU_PERF_PSTATES_INFO_V2
  • voltDelta_uV : NV_GPU_PSTATE20_BASE_VOLTAGE_ENTRY_V1
  • vpOffsets : _NV_SMP_ASSIST_SETUP_PARAMS_V1
  • vsdb : _NV_MONITOR_CAPABILITIES_V1
  • VSVDB_version : _NV_HDR_CAPABILITIES_V2, _NV_HDR_CAPABILITIES_V3
  • VSyncPol : _NV_TIMING
  • VSyncWidth : _NV_TIMING
  • VTotal : _NV_TIMING
  • VVisible : _NV_TIMING


  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all variables with links to the structures/unions they belong to:

- w -

  • w : NV_VIEWPORTF
  • warningFlags : NV_MOSAIC_DISPLAY_TOPO_STATUS
  • warpDown : _NV_LMS_CUSTOM_CONFIG_V1
  • warpLeft : _NV_LMS_CUSTOM_CONFIG_V1
  • warpRight : _NV_LMS_CUSTOM_CONFIG_V1
  • warpUp : _NV_LMS_CUSTOM_CONFIG_V1
  • width : _NV_MOSAIC_DISPLAY_SETTING_V1, _NV_RESOLUTION, _NV_TIMING_INPUT, _NVVIOOUTPUTREGION, NV_CUSTOM_DISPLAY, NV_DISPLAY_PATH, NV_MOSAIC_DISPLAY_SETTING_V2, NV_SCANOUT_INTENSITY_DATA_V1, NV_SCANOUT_INTENSITY_DATA_V2
  • WindowToClipSplitsX : _NV_SMP_ASSIST_REMAPCBDATA_V1
  • WindowToClipSplitsY : _NV_SMP_ASSIST_REMAPCBDATA_V1
  • WindowToClipX : _NV_SMP_ASSIST_REMAPCBDATA_V1
  • WindowToClipY : _NV_SMP_ASSIST_REMAPCBDATA_V1
  • WindowToClipZ : _NV_SMP_ASSIST_REMAPCBDATA_V1
  • workstationFeatureType : _NV_D3D12_WORKSTATION_FEATURE_PROPERTIES
  • wszCurrentValue : _NVDRS_SETTING_V1
  • wszDefaultValue : _NVDRS_SETTING_VALUES
  • wszPredefinedValue : _NVDRS_SETTING_V1
  • wszValue : _NVDRS_SETTING_VALUES


  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all variables with links to the structures/unions they belong to:

- x -

  • X : _NV_PIXEL_SRSO_2x1::NV_PIXEL_SRSO_2x1_X1
  • x : _NV_POSITION, _NVAPI_DIM3, _NVVIOOUTPUTREGION, NV_VIEWPORTF
  • X1 : _NV_PIXEL_SRSO_1x2, _NV_PIXEL_SRSO_2x1, _NV_PIXEL_SRSO_2x2, _NV_PIXEL_SRSO_2x4, _NV_PIXEL_SRSO_4x2, _NV_PIXEL_SRSO_4x4
  • X2 : _NV_PIXEL_SRSO_1x2, _NV_PIXEL_SRSO_2x1, _NV_PIXEL_SRSO_2x2, _NV_PIXEL_SRSO_2x4
  • X4 : _NV_PIXEL_SRSO_1x2, _NV_PIXEL_SRSO_2x1, _NV_PIXEL_SRSO_2x2
  • X8 : _NV_PIXEL_SRSO_1x2
  • xRatio : NV_CUSTOM_DISPLAY
  • XS : _NV_PIXEL_SRSO_2x1::NV_PIXEL_SRSO_2x1_X2, _NV_PIXEL_SRSO_2x1::NV_PIXEL_SRSO_2x1_X4


  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all variables with links to the structures/unions they belong to:

- y -

  • Y : _NV_PIXEL_SRSO_1x2::NV_PIXEL_SRSO_1x2_X1
  • y : _NV_POSITION, _NVAPI_DIM3, _NVVIOOUTPUTREGION, NV_VIEWPORTF
  • yccQuantizationRange : NV_INFOFRAME_VIDEO
  • year : _NV_LICENSE_EXPIRY_DETAILS
  • yRatio : NV_CUSTOM_DISPLAY
  • YS : _NV_PIXEL_SRSO_1x2::NV_PIXEL_SRSO_1x2_X2, _NV_PIXEL_SRSO_1x2::NV_PIXEL_SRSO_1x2_X4, _NV_PIXEL_SRSO_1x2::NV_PIXEL_SRSO_1x2_X8
  • YX : _NV_PIXEL_SRSO_2x2::NV_PIXEL_SRSO_2x2_X1, _NV_PIXEL_SRSO_2x4::NV_PIXEL_SRSO_2x4_X1, _NV_PIXEL_SRSO_4x2::NV_PIXEL_SRSO_4x2_X1, _NV_PIXEL_SRSO_4x4::NV_PIXEL_SRSO_4x4_X1
  • YXS : _NV_PIXEL_SRSO_2x2::NV_PIXEL_SRSO_2x2_X2, _NV_PIXEL_SRSO_2x2::NV_PIXEL_SRSO_2x2_X4, _NV_PIXEL_SRSO_2x4::NV_PIXEL_SRSO_2x4_X2


  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all variables with links to the structures/unions they belong to:

- z -

  • z : _NVAPI_DIM3
  • zoneLocation : _NV_GPU_CLIENT_ILLUM_ZONE_INFO_V1
  • zones : _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_PARAMS_V1, _NV_GPU_CLIENT_ILLUM_ZONE_INFO_PARAMS_V1


  • File List
  • Globals
File List
Here is a list of all files with brief descriptions:
nvapi.h
nvapi_lite_common.h
nvapi_lite_d3dext.h
nvapi_lite_salend.h
nvapi_lite_salstart.h
nvapi_lite_sli.h
nvapi_lite_stereo.h
nvapi_lite_surround.h
NvApiDriverSettings.h
nvHLSLExtns.h
nvHLSLExtnsInternal.h
nvShaderExtnEnums.h


  • File List
  • Globals
Data Structures | Macros | Typedefs | Enumerations | Functions | Variables
nvapi.h File Reference
#include "nvapi_lite_salstart.h"
#include "nvapi_lite_common.h"
#include "nvapi_lite_sli.h"
#include "nvapi_lite_surround.h"
#include "nvapi_lite_stereo.h"
#include "nvapi_lite_d3dext.h"
#include "nvapi_lite_salend.h"

Data Structures

struct | NV_EDID_V1
struct | NV_EDID_V2
struct | NV_EDID_V3
struct | NV_VIEWPORTF
struct | tagNV_TIMINGEXT
struct | _NV_TIMING
struct | NV_VIEW_TARGET_INFO
struct | NV_DISPLAY_PATH
struct | NV_DISPLAY_PATH_INFO_V3
struct | NV_DISPLAY_PATH_INFO
struct | _NV_POSITION
struct | _NV_RESOLUTION
struct | _NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_V1
struct | _NV_DISPLAYCONFIG_PATH_TARGET_INFO_V1
struct | _NV_DISPLAYCONFIG_PATH_TARGET_INFO_V2
struct | _NV_DISPLAYCONFIG_SOURCE_MODE_INFO_V1
struct | _NV_DISPLAYCONFIG_PATH_INFO_V1
struct | _NV_DISPLAYCONFIG_PATH_INFO_V2
struct | NV_GPU_PERF_PSTATES20_PARAM_DELTA
struct | NV_GPU_PSTATE20_CLOCK_ENTRY_V1
struct | NV_GPU_PSTATE20_BASE_VOLTAGE_ENTRY_V1
struct | NV_GPU_PERF_PSTATES20_INFO_V1
struct | _NV_GPU_PERF_PSTATES20_INFO_V2
struct | NV_DISPLAY_DRIVER_VERSION
struct | _NV_GPU_DISPLAYIDS
struct | _NV_BOARD_INFO
struct | NV_GPU_ARCH_INFO_V1
struct | NV_GPU_ARCH_INFO_V2
struct | NV_I2C_INFO_V1
struct | NV_I2C_INFO_V2
struct | NV_I2C_INFO_V3
struct | NV_GPU_GET_HDCP_SUPPORT_STATUS
struct | NV_COMPUTE_GPU_TOPOLOGY_V1
struct | _NV_COMPUTE_GPU
struct | _NV_COMPUTE_GPU_TOPOLOGY_V2
struct | NV_GPU_ECC_STATUS_INFO
struct | NV_GPU_ECC_ERROR_INFO
struct | NV_GPU_ECC_CONFIGURATION_INFO
struct | NV_QSYNC_EVENT_DATA
struct | NV_EVENT_REGISTER_CALLBACK
struct | NV_SCANOUT_INTENSITY_DATA_V1
struct | NV_SCANOUT_INTENSITY_DATA_V2
struct | _NV_SCANOUT_INTENSITY_STATE_DATA
struct | NV_SCANOUT_WARPING_DATA
struct | _NV_SCANOUT_WARPING_STATE_DATA
struct | _NV_SCANOUT_INFORMATION
struct | _NV_GPU_VIRTUALIZATION_INFO
struct | _NV_LOGICAL_GPU_DATA_V1
struct | _NV_LICENSE_EXPIRY_DETAILS
struct | _NV_LICENSE_FEATURE_DETAILS_V1
struct | _NV_LICENSE_FEATURE_DETAILS_V2
struct | _NV_LICENSE_FEATURE_DETAILS_V3
struct | _NV_LICENSE_FEATURE_DETAILS_V4
struct | _NV_LICENSABLE_FEATURES_V1
struct | _NV_LICENSABLE_FEATURES_V2
struct | _NV_LICENSABLE_FEATURES_V3
struct | _NV_LICENSABLE_FEATURES_V4
struct | NVLINK_GET_CAPS_V1
struct | NVLINK_DEVICE_INFO_V1
struct | NVLINK_LINK_STATUS_INFO_V1
struct | NVLINK_LINK_STATUS_INFO_V2
struct | NVLINK_GET_STATUS_V1
struct | NVLINK_GET_STATUS_V2
struct | _NV_GPU_INFO_V1
struct | _NV_GPU_INFO_V2
struct | _NV_GPU_VR_READY_V1
struct | _NV_GPU_GSP_INFO_V1
struct | NV_GPU_PERF_PSTATES_INFO_V1
struct | NV_GPU_PERF_PSTATES_INFO_V2
struct | NV_GPU_DYNAMIC_PSTATES_INFO_EX
struct | NV_GPU_THERMAL_SETTINGS_V1
struct | NV_GPU_THERMAL_SETTINGS_V2
struct | NV_GPU_CLOCK_FREQUENCIES_V1
struct | NV_GPU_CLOCK_FREQUENCIES_V2
struct | _NV_GPU_QUERY_ILLUMINATION_SUPPORT_PARM_V1
struct | _NV_GPU_GET_ILLUMINATION_PARM_V1
struct | _NV_GPU_SET_ILLUMINATION_PARM_V1
struct | _NV_GPU_CLIENT_ILLUM_DEVICE_INFO_DATA_MCUV10
struct | _NV_GPU_CLIENT_ILLUM_DEVICE_INFO_DATA_GPIO_PWM_RGBW
struct | _NV_GPU_CLIENT_ILLUM_DEVICE_INFO_DATA_GPIO_PWM_SINGLE_COLOR
struct | _NV_GPU_CLIENT_ILLUM_DEVICE_INFO_V1
struct | _NV_GPU_CLIENT_ILLUM_DEVICE_INFO_PARAMS_V1
struct | NV_GPU_CLIENT_ILLUM_DEVICE_SYNC_V1
struct | NV_GPU_CLIENT_ILLUM_DEVICE_CONTROL_V1
struct | NV_GPU_CLIENT_ILLUM_DEVICE_CONTROL_PARAMS_V1
struct | _NV_GPU_CLIENT_ILLUM_ZONE_INFO_DATA_RGB
struct | _NV_GPU_CLIENT_ILLUM_ZONE_INFO_DATA_RGBW
struct | _NV_GPU_CLIENT_ILLUM_ZONE_INFO_DATA_SINGLE_COLOR
struct | _NV_GPU_CLIENT_ILLUM_ZONE_INFO_V1
struct | _NV_GPU_CLIENT_ILLUM_ZONE_INFO_PARAMS_V1
struct | _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_RGB_PARAMS
struct | _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_RGB
struct | _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR
struct | _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR_RGB
struct | _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_RGB
struct | _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_COLOR_FIXED_PARAMS
struct | _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_COLOR_FIXED
struct | _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR_COLOR_FIXED
struct | _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_COLOR_FIXED
struct | _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_RGBW_PARAMS
struct | _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_RGBW
struct | _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR_RGBW
struct | _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_RGBW
struct | _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_SINGLE_COLOR_PARAMS
struct | _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_SINGLE_COLOR
struct | _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR_SINGLE_COLOR
struct | _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_SINGLE_COLOR
struct | _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_V1
struct | _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_PARAMS_V1
struct | _NV_DISPLAY_PORT_INFO_V1
struct | NV_DISPLAY_PORT_CONFIG
struct | _NV_HDMI_SUPPORT_INFO_V1
struct | _NV_HDMI_SUPPORT_INFO_V2
struct | NV_INFOFRAME_PROPERTY
struct | NV_INFOFRAME_VIDEO
struct | NV_INFOFRAME_AUDIO
struct | NV_INFOFRAME_DATA
struct | _NV_COLOR_DATA_V1
struct | _NV_COLOR_DATA_V2
struct | _NV_COLOR_DATA_V3
struct | _NV_COLOR_DATA_V4
struct | _NV_COLOR_DATA_V5
struct | _NV_HDR_CAPABILITIES_V1
struct | _NV_HDR_CAPABILITIES_V2
struct | _NV_HDR_CAPABILITIES_V3
struct | _NV_HDR_COLOR_DATA_V1
struct | _NV_HDR_COLOR_DATA_V2
struct | _NV_HDR_METADATA_V1
struct | NV_TIMING_FLAG
struct | _NV_TIMING_INPUT
struct | _NV_MONITOR_CAPS_VCDB
struct | _NV_MONITOR_CAPS_VSDB
struct | _NV_MONITOR_CAPS_GENERIC
struct | _NV_MONITOR_CAPABILITIES_V1
struct | _NV_MONITOR_COLOR_DATA
struct | NV_CUSTOM_DISPLAY
struct | _NV_EDID_DATA_V1
struct | _NV_EDID_DATA_V2
struct | _NV_GET_ADAPTIVE_SYNC_DATA_V1
struct | _NV_SET_ADAPTIVE_SYNC_DATA_V1
struct | _NV_GET_VIRTUAL_REFRESH_RATE_DATA_V1
struct | _NV_SET_VIRTUAL_REFRESH_RATE_DATA_V1
struct | NV_SET_PREFERRED_STEREO_DISPLAY_V1
struct | NV_GET_PREFERRED_STEREO_DISPLAY_V1
struct | _NV_MANAGED_DEDICATED_DISPLAY_INFO
struct | _NV_MANAGED_DEDICATED_DISPLAY_METADATA
struct | _NV_GET_VRR_INFO_V1
struct | NV_MOSAIC_TOPO_DETAILS
struct | NV_MOSAIC_TOPO_BRIEF
struct | _NV_MOSAIC_DISPLAY_SETTING_V1
struct | NV_MOSAIC_DISPLAY_SETTING_V2
struct | _NV_MOSAIC_SUPPORTED_TOPO_INFO_V1
struct | _NV_MOSAIC_SUPPORTED_TOPO_INFO_V2
struct | NV_MOSAIC_TOPO_GROUP
struct | _NV_MOSAIC_GRID_TOPO_DISPLAY_V1
struct | _NV_MOSAIC_GRID_TOPO_DISPLAY_V2
struct | _NV_MOSAIC_GRID_TOPO_V1
struct | _NV_MOSAIC_GRID_TOPO_V2
struct | NV_MOSAIC_DISPLAY_TOPO_STATUS
struct | NV_MOSAIC_TOPOLOGY
struct | NV_MOSAIC_SUPPORTED_TOPOLOGIES
struct | _NV_GSYNC_CAPABILITIES_V1
struct | _NV_GSYNC_CAPABILITIES_V2
struct | _NV_GSYNC_CAPABILITIES_V3
struct | _NV_GSYNC_GPU
struct | _NV_GSYNC_DISPLAY
struct | _NV_GSYNC_DELAY
struct | _NV_GSYNC_CONTROL_PARAMS_V1
struct | _NV_GSYNC_CONTROL_PARAMS_V2
struct | _NV_GSYNC_STATUS
struct | _NV_GSYNC_STATUS_PARAMS_V1
struct | _NV_GSYNC_STATUS_PARAMS_V2
struct | _NV_DX_VIDEO_STEREO_INFO
struct | _NV_JOIN_PRESENT_BARRIER_PARAMS
struct | _NV_PRESENT_BARRIER_FRAME_STATISTICS
struct | NvAPI_D3D11_RASTERIZER_DESC_EX
struct | NVAPI_ANSEL_FEATURE_CONFIGURATION_STRUCT
struct | NVAPI_ANSEL_CONFIGURATION_STRUCT_V1
struct | _NV_D3D11_FEATURE_DATA_RASTERIZER_SUPPORT
struct | _NV_CUSTOM_SEMANTIC
struct | NvAPI_D3D11_CREATE_GEOMETRY_SHADER_EX_V5
struct | NvAPI_D3D11_CREATE_VERTEX_SHADER_EX_V1
struct | NvAPI_D3D11_CREATE_VERTEX_SHADER_EX_V2
struct | NvAPI_D3D11_CREATE_VERTEX_SHADER_EX_V3
struct | NvAPI_D3D11_CREATE_HULL_SHADER_EX_V1
struct | NvAPI_D3D11_CREATE_HULL_SHADER_EX_V2
struct | NvAPI_D3D11_CREATE_DOMAIN_SHADER_EX_V1
struct | NvAPI_D3D11_CREATE_DOMAIN_SHADER_EX_V2
struct | NvAPI_D3D11_CREATE_DOMAIN_SHADER_EX_V3
struct | NvAPI_D3D11_CREATE_PIXEL_SHADER_EX_V1
struct | NvAPI_D3D11_CREATE_PIXEL_SHADER_EX_V2
struct | NvAPI_D3D11_CREATE_FASTGS_EXPLICIT_DESC_V1
struct | NVAPI_D3D12_PSO_EXTENSION_DESC_V1
struct | NVAPI_D3D12_PSO_RASTERIZER_STATE_DESC_V1
struct | NVAPI_D3D12_PSO_CREATE_FASTGS_EXPLICIT_DESC_V1
struct | NVAPI_D3D12_PSO_REQUEST_FAST_GEOMETRY_SHADER_DESC_V1
struct | NVAPI_D3D12_PSO_GEOMETRY_SHADER_DESC_V5
struct | NVAPI_D3D12_PSO_VERTEX_SHADER_DESC_V1
struct | NVAPI_D3D12_PSO_VERTEX_SHADER_DESC_V2
struct | NVAPI_D3D12_PSO_VERTEX_SHADER_DESC_V3
struct | NVAPI_D3D12_PSO_HULL_SHADER_DESC_V1
struct | NVAPI_D3D12_PSO_HULL_SHADER_DESC_V2
struct | NVAPI_D3D12_PSO_DOMAIN_SHADER_DESC_V1
struct | NVAPI_D3D12_PSO_DOMAIN_SHADER_DESC_V2
struct | NVAPI_D3D12_PSO_DOMAIN_SHADER_DESC_V3
struct | NVAPI_D3D12_PSO_ENABLE_DEPTH_BOUND_TEST_DESC_V1
struct | NVAPI_D3D12_PSO_SET_SHADER_EXTENSION_SLOT_DESC_V1
struct | _NV_HEAP_PARAMS_V1
struct | NVAPI_UAV_INFO_V1
struct | NVAPI_UAV_INFO_V2
struct | NV_GET_GPU_VIRTUAL_ADDRESS_V1
struct | NVAPI_META_COMMAND_DESC
struct | NV_META_COMMAND_TENSOR_DESC
struct | NV_META_COMMAND_ACTIVATION_DESC
struct | NV_META_COMMAND_OPTIONAL_TENSOR_DESC
struct | NV_META_COMMAND_OPTIONAL_ACTIVATION_DESC
struct | NV_META_COMMAND_PADDING_DESC
struct | NV_META_COMMAND_CREATE_CONVOLUTION_EX_DESC
struct | NV_META_COMMAND_CONVOLUTION_FUSE_DESC
struct | NV_META_COMMAND_CREATE_CONVOLUTION_EX_FUSED_DESC
struct | NV_META_COMMAND_CREATE_GEMM_DESC
struct | NV_D3D11_META_COMMAND_RESOURCE
struct | NV_D3D11_META_COMMAND_INITIALIZE_CONVOLUTION_EX_DESC
struct | NV_D3D11_META_COMMAND_EXECUTE_CONVOLUTION_EX_DESC
struct | NV_D3D11_META_COMMAND_INITIALIZE_GEMM_DESC
struct | NV_D3D11_META_COMMAND_EXECUTE_GEMM_DESC
struct | NV_D3D12_META_COMMAND_INITIALIZE_CONVOLUTION_EX_DESC
struct | NV_D3D12_META_COMMAND_EXECUTE_CONVOLUTION_EX_DESC
struct | NV_D3D12_META_COMMAND_INITIALIZE_GEMM_DESC
struct | NV_D3D12_META_COMMAND_EXECUTE_GEMM_DESC
struct | _NV_RESOURCE_PARAMS_V1
struct | _NV_MULTIGPU_CAPS_V1
struct | _NV_MULTIGPU_CAPS_V2
struct | _NV_QUERY_SINGLE_PASS_STEREO_SUPPORT_PARAMS_V1
struct | _NV_QUERY_SINGLE_PASS_STEREO_SUPPORT_PARAMS_V2
struct | _NV_QUERY_MULTIVIEW_SUPPORT_PARAMS_V1
struct | _NV_MULTIVIEW_PARAMS_V1
struct | _NV_QUERY_MODIFIED_W_SUPPORT_PARAMS
struct | _NV_MODIFIED_W_COEFFICIENTS
struct | _NV_MODIFIED_W_PARAMS
struct | _NV_D3D_LATELATCH_OBJECT_DESC_V1
struct | _NV_QUERY_LATELATCH_SUPPORT_PARAMS
struct | _NV_D3D12_MOSAIC_GETCOMPANIONALLOCATIONS
struct | _NV_D3D12_MOSAIC_GETVIEWPORTANDGPUPARTITIONS
struct | _NV_D3D1x_GRAPHICS_CAPS_V1
struct | _NV_D3D1x_GRAPHICS_CAPS_V2
struct | _NV_D3D12_GRAPHICS_CAPS_V1
struct | _NV_D3D11_EXCLUSIVE_SCISSOR_RECT_DESC_V1
struct | _NV_D3D11_EXCLUSIVE_SCISSOR_RECTS_DESC_V1
struct | _NV_D3D11_VIEWPORT_SHADING_RATE_DESC_V1
struct | _NV_D3D11_VIEWPORTS_SHADING_RATE_DESC_V1
struct | _NV_TEX2D_SRRV
struct | _NV_TEX2D_ARRAY_SRRV
struct | _NV_D3D11_SHADING_RATE_RESOURCE_VIEW_DESC_V1
struct | _NV_PIXEL_SRSO_1x2
struct | _NV_PIXEL_SRSO_1x2::NV_PIXEL_SRSO_1x2_X1
struct | _NV_PIXEL_SRSO_1x2::NV_PIXEL_SRSO_1x2_X2
struct | _NV_PIXEL_SRSO_1x2::NV_PIXEL_SRSO_1x2_X4
struct | _NV_PIXEL_SRSO_1x2::NV_PIXEL_SRSO_1x2_X8
struct | _NV_PIXEL_SRSO_2x1
struct | _NV_PIXEL_SRSO_2x1::NV_PIXEL_SRSO_2x1_X1
struct | _NV_PIXEL_SRSO_2x1::NV_PIXEL_SRSO_2x1_X2
struct | _NV_PIXEL_SRSO_2x1::NV_PIXEL_SRSO_2x1_X4
struct | _NV_PIXEL_SRSO_2x2
struct | _NV_PIXEL_SRSO_2x2::NV_PIXEL_SRSO_2x2_X1
struct | _NV_PIXEL_SRSO_2x2::NV_PIXEL_SRSO_2x2_X2
struct | _NV_PIXEL_SRSO_2x2::NV_PIXEL_SRSO_2x2_X4
struct | _NV_PIXEL_SRSO_2x4
struct | _NV_PIXEL_SRSO_2x4::NV_PIXEL_SRSO_2x4_X1
struct | _NV_PIXEL_SRSO_2x4::NV_PIXEL_SRSO_2x4_X2
struct | _NV_PIXEL_SRSO_4x2
struct | _NV_PIXEL_SRSO_4x2::NV_PIXEL_SRSO_4x2_X1
struct | _NV_PIXEL_SRSO_4x4
struct | _NV_PIXEL_SRSO_4x4::NV_PIXEL_SRSO_4x4_X1
struct | _NV_PIXEL_SHADING_RATE_SAMPLE_ORDER_TABLE_V1
struct | _NV_VRS_HELPER_LATCH_GAZE_PARAMS_V1
struct | _NV_FOVEATED_RENDERING_CUSTOM_SHADING_RATE_PRESET_DESC_V1
struct | _NV_FOVEATED_RENDERING_CUSTOM_FOVEATION_PATTERN_PRESET_DESC_V1
struct | _NV_FOVEATED_RENDERING_DESC_V1
struct | _NV_VRS_HELPER_ENABLE_PARAMS_V1
struct | _NV_VRS_HELPER_DISABLE_PARAMS_V1
struct | _NV_VRS_HELPER_GET_SHADING_RATE_RESOURCE_PARAMS_V1
struct | _NV_VRS_HELPER_PURGE_INTERNAL_RESOURCES_PARAMS_V1
struct | _NV_VRS_HELPER_INIT_PARAMS_V1
struct | _NV_FOVEATED_RENDERING_GAZE_DATA_PER_EYE
struct | _NV_FOVEATED_RENDERING_UPDATE_GAZE_DATA_PARAMS
struct | _NV_GAZE_HANDLER_INIT_PARAMS_V2
struct | _NV_GAZE_HANDLER_INIT_PARAMS_V1
struct | _NV_MRS_CUSTOM_CONFIG_V1
struct | _NV_MRS_INSTANCED_STEREO_CONFIG_V1
struct | _NV_LMS_CUSTOM_CONFIG_V1
struct | _NV_LMS_INSTANCED_STEREO_CONFIG_V1
struct | _NV_CUSTOM_RECTS_V1
struct | _NV_SMP_ASSIST_ENABLE_PARAMS_V1
struct | _NV_SMP_ASSIST_DISABLE_PARAMS_V1
struct | _NV_SMP_ASSIST_FASTGSCBDATA_V1
struct | _NV_SMP_ASSIST_FASTGSCBDATA_MRS_INSTANCED_STEREO_V1
struct | _NV_SMP_ASSIST_REMAPCBDATA_V1
struct | _NV_SMP_ASSIST_GET_CONSTANTS_V3
struct | _NV_SMP_ASSIST_SETUP_PARAMS_V1
struct | _NV_SMP_ASSIST_UPDATE_INSTANCEDSTEREO_DATA_PARAMS_V1
struct | _NV_SMP_ASSIST_INITIALIZE_PARAMS_V1
struct | _NV_QUERY_SMP_ASSIST_SUPPORT_PARAMS_V1
struct | _NV_GET_SLEEP_STATUS_PARAMS
struct | _NV_SET_SLEEP_MODE_PARAMS
struct | _NV_SET_REFLEX_SYNC_PARAMS
struct | _NV_LATENCY_RESULT_PARAMS
struct | _NV_LATENCY_RESULT_PARAMS::FrameReport
struct | _NV_LATENCY_MARKER_PARAMS
struct | _NV_ASYNC_FRAME_MARKER_PARAMS_V1
struct | NVAPI_D3D12_CREATE_CUBIN_SHADER_PARAMS
struct | NVAPI_D3D12_GET_CUDA_MERGED_TEXTURE_SAMPLER_OBJECT_PARAMS
struct | NVAPI_D3D12_GET_CUDA_INDEPENDENT_DESCRIPTOR_OBJECT_PARAMS
struct | _NVAPI_DIM3
struct | _NVAPI_CU_KERNEL_LAUNCH_PARAMS
struct | _NVAPI_CU_KERNEL_LAUNCH_PARAMS_EX
struct | _NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_USAGE_COUNT
struct | _NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_DESC
struct | _NVAPI_D3D12_BUILD_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_INPUTS
struct | _NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PREBUILD_INFO
struct | _NVAPI_GET_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PREBUILD_INFO_PARAMS_V1
struct | _NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_USAGE_COUNT
struct | _NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_DESC
struct | _NVAPI_D3D12_BUILD_RAYTRACING_OPACITY_MICROMAP_ARRAY_INPUTS
struct | _NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_ARRAY_PREBUILD_INFO
struct | _NVAPI_GET_RAYTRACING_OPACITY_MICROMAP_ARRAY_PREBUILD_INFO_PARAMS_V1
struct | _NVAPI_D3D12_SET_CREATE_PIPELINE_STATE_OPTIONS_PARAMS_V1
struct | _NVAPI_CHECK_DRIVER_MATCHING_IDENTIFIER_EX_PARAMS_V1
struct | _NVAPI_D3D12_RAYTRACING_GEOMETRY_OMM_ATTACHMENT_DESC
struct | _NVAPI_D3D12_RAYTRACING_GEOMETRY_DMM_ATTACHMENT_DESC
struct | _NVAPI_D3D12_RAYTRACING_GEOMETRY_DMM_TRIANGLES_DESC
struct | _NVAPI_D3D12_RAYTRACING_GEOMETRY_OMM_TRIANGLES_DESC
struct | _NVAPI_D3D12_RAYTRACING_GEOMETRY_DESC_EX
struct | _NVAPI_D3D12_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_INPUTS_EX
struct | _NVAPI_GET_RAYTRACING_ACCELERATION_STRUCTURE_PREBUILD_INFO_EX_PARAMS_V1
struct | _NVAPI_D3D12_BUILD_RAYTRACING_OPACITY_MICROMAP_ARRAY_DESC
struct | _NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_ARRAY_POSTBUILD_INFO_CURRENT_SIZE_DESC
struct | _NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_ARRAY_POSTBUILD_INFO_DESC
struct | _NVAPI_BUILD_RAYTRACING_OPACITY_MICROMAP_ARRAY_PARAMS_V1
struct | _NVAPI_RELOCATE_RAYTRACING_OPACITY_MICROMAP_ARRAY_PARAMS_V1
struct | _NVAPI_D3D12_BUILD_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_DESC
struct | _NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_POSTBUILD_INFO_CURRENT_SIZE_DESC
struct | _NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_POSTBUILD_INFO_DESC
struct | _NVAPI_BUILD_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PARAMS_V1
struct | _NVAPI_RELOCATE_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PARAMS_V1
struct | _NVAPI_EMIT_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_POSTBUILD_INFO_PARAMS_V1
struct | _NVAPI_EMIT_RAYTRACING_OPACITY_MICROMAP_ARRAY_POSTBUILD_INFO_PARAMS_V1
struct | _NVAPI_D3D12_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_DESC_EX
struct | _NVAPI_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_EX_PARAMS_V1
struct | _NV_D3D12_WORKSTATION_FEATURE_RDMA_PROPERTIES
struct | _NV_D3D12_WORKSTATION_FEATURE_PROPERTIES
class | INvAPI_DirectD3D12GraphicsCommandList
struct | _NVVIOCAPS
struct | _NVVIOCHANNELSTATUS
struct | _NVVIOINPUTSTATUS
struct | _NVVIOOUTPUTSTATUS
struct | _NVVIOSTATUS
struct | _NVVIOOUTPUTREGION
struct | _NVVIOGAMMARAMP8
struct | _NVVIOGAMMARAMP10
struct | _NVVIOSYNCDELAY
struct | _NVVIOVIDEOMODE
struct | _NVVIOSIGNALFORMATDETAIL
struct | _NVVIODATAFORMATDETAIL
struct | _NVVIOCOLORCONVERSION
struct | _NVVIOGAMMACORRECTION
struct | _NVVIOCOMPOSITERANGE
struct | _NVVIOOUTPUTCONFIG_V1
struct | _NVVIOOUTPUTCONFIG_V2
struct | _NVVIOOUTPUTCONFIG_V3
struct | _NVVIOSTREAM
struct | _NVVIOINPUTCONFIG
struct | _NVVIOCONFIG_V1
struct | _NVVIOCONFIG_V2
struct | _NVVIOCONFIG_V3
struct | NVVIOTOPOLOGYTARGET
struct | _NV_VIO_TOPOLOGY
struct | _NVVIOPCIINFO
struct | _NVAPI_STEREO_CAPS
struct | _NVDRS_GPU_SUPPORT
struct | _NVDRS_BINARY_SETTING
struct | _NVDRS_SETTING_VALUES
struct | _NVDRS_SETTING_V1
struct | _NVDRS_APPLICATION_V1
struct | _NVDRS_APPLICATION_V2
struct | _NVDRS_APPLICATION_V3
struct | _NVDRS_APPLICATION_V4
struct | _NVDRS_PROFILE_V1
struct | NV_CHIPSET_INFO_v4
struct | NV_CHIPSET_INFO_v3
struct | NV_CHIPSET_INFO_v2
struct | NV_CHIPSET_INFO_v1
struct | NV_LID_DOCK_PARAMS
struct | _NV_DISPLAY_DRIVER_INFO
struct | _NV_DISPLAY_DRIVER_INFO_V2
struct | _NV_PHYSICAL_GPU_HANDLE_DATA
struct | _NV_PHYSICAL_GPUS
struct | _NV_LOGICAL_GPU_HANDLE_DATA
struct | _NV_LOGICAL_GPUS
struct | _NV_CLIENT_CALLBACK_SETTINGS_SUPER_V1
struct | _NV_GPU_CLIENT_PERIODIC_CALLBACK_SETTINGS_SUPER_V1
struct | _NV_GPU_CLIENT_CALLBACK_DATA_SUPER_V1
struct | _NV_GPU_CLIENT_UTILIZATION_DATA_V1
struct | _NV_GPU_CLIENT_CALLBACK_UTILIZATION_DATA_V1
struct | _NV_GPU_CLIENT_UTILIZATION_PERIODIC_CALLBACK_SETTINGS_V1

Macros

#define | _NVAPI_H
#define | __cdecl
#define | NVAPI_API_NOT_INTIALIZED NVAPI_API_NOT_INITIALIZED
#define | DISPLAYPORT_STRUCTS_DEFINED
#define | NV_EDID_DATA_SIZE_MAX 1024
#define | NVFORMAT_MAKEFOURCC(ch0, ch1, ch2, ch3)
#define | NV_TIMING_STRUCTS_DEFINED
#define | NV_TIMING_H_SYNC_POSITIVE 0
#define | NV_TIMING_H_SYNC_NEGATIVE 1
#define | NV_TIMING_H_SYNC_DEFAULT NV_TIMING_H_SYNC_NEGATIVE
#define | NV_TIMING_V_SYNC_POSITIVE 0
#define | NV_TIMING_V_SYNC_NEGATIVE 1
#define | NV_TIMING_V_SYNC_DEFAULT NV_TIMING_V_SYNC_POSITIVE
#define | NV_TIMING_PROGRESSIVE 0
#define | NV_TIMING_INTERLACED 1
#define | NV_TIMING_INTERLACED_EXTRA_VBLANK_ON_FIELD2 1
#define | NV_TIMING_INTERLACED_NO_EXTRA_VBLANK_ON_FIELD2 2
#define | NV_VIEW_TARGET_INFO_VER MAKE_NVAPI_VERSION(NV_VIEW_TARGET_INFO,2)
#define | NVAPI_MAX_DISPLAY_PATH NVAPI_MAX_VIEW_TARGET
#define | NVAPI_ADVANCED_MAX_DISPLAY_PATH NVAPI_ADVANCED_MAX_VIEW_TARGET
#define | NV_DISPLAY_PATH_INFO_VER NV_DISPLAY_PATH_INFO_VER4
#define | NV_DISPLAY_PATH_INFO_VER4 MAKE_NVAPI_VERSION(NV_DISPLAY_PATH_INFO,4)
#define | NV_DISPLAY_PATH_INFO_VER3 MAKE_NVAPI_VERSION(NV_DISPLAY_PATH_INFO,3)
#define | NV_DISPLAY_PATH_INFO_VER2 MAKE_NVAPI_VERSION(NV_DISPLAY_PATH_INFO,2)
#define | NV_DISPLAY_PATH_INFO_VER1 MAKE_NVAPI_VERSION(NV_DISPLAY_PATH_INFO,1)
#define | NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_VER1 MAKE_NVAPI_VERSION(NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_V1,1)
#define | NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_VER NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_VER1
#define | _NV_DISPLAYCONFIG_PATH_INFO_V2 _NV_DISPLAYCONFIG_PATH_INFO
#define | NV_DISPLAYCONFIG_PATH_INFO_VER1 MAKE_NVAPI_VERSION(NV_DISPLAYCONFIG_PATH_INFO_V1,1)
#define | NV_DISPLAYCONFIG_PATH_INFO_VER2 MAKE_NVAPI_VERSION(NV_DISPLAYCONFIG_PATH_INFO_V2,2)
#define | NV_DISPLAYCONFIG_PATH_INFO_VER NV_DISPLAYCONFIG_PATH_INFO_VER2
#define | NVAPI_UNICODE_STRING_MAX 2048
#define | NVAPI_BINARY_DATA_MAX 4096
#define | NVAPI_MAX_GPU_PSTATE20_PSTATES 16
#define | NVAPI_MAX_GPU_PSTATE20_CLOCKS 8
#define | NVAPI_MAX_GPU_PSTATE20_BASE_VOLTAGES 4
#define | NV_GPU_PERF_PSTATES20_INFO_VER1 MAKE_NVAPI_VERSION(NV_GPU_PERF_PSTATES20_INFO_V1,1)
#define | NV_GPU_PERF_PSTATES20_INFO_VER2 MAKE_NVAPI_VERSION(NV_GPU_PERF_PSTATES20_INFO_V2,2)
#define | NV_GPU_PERF_PSTATES20_INFO_VER3 MAKE_NVAPI_VERSION(NV_GPU_PERF_PSTATES20_INFO_V2,3)
#define | NV_GPU_PERF_PSTATES20_INFO_VER NV_GPU_PERF_PSTATES20_INFO_VER3
#define | NV_DISPLAY_DRIVER_VERSION_VER MAKE_NVAPI_VERSION(NV_DISPLAY_DRIVER_VERSION,1)
#define | NV_GPU_DISPLAYIDS_VER1 MAKE_NVAPI_VERSION(NV_GPU_DISPLAYIDS,1)
#define | NV_GPU_DISPLAYIDS_VER2 MAKE_NVAPI_VERSION(NV_GPU_DISPLAYIDS,3)
#define | NV_GPU_DISPLAYIDS_VER NV_GPU_DISPLAYIDS_VER2
#define | NV_BOARD_INFO_VER1 MAKE_NVAPI_VERSION(NV_BOARD_INFO_V1,1)
#define | NV_BOARD_INFO_VER NV_BOARD_INFO_VER1
#define | NV_GPU_ARCH_INFO_VER_1 MAKE_NVAPI_VERSION(NV_GPU_ARCH_INFO_V1,1)
#define | NV_GPU_ARCH_INFO_VER_2 MAKE_NVAPI_VERSION(NV_GPU_ARCH_INFO_V2,2)
#define | NV_GPU_ARCH_INFO_VER NV_GPU_ARCH_INFO_VER_2
#define | NV_GPU_GET_HDCP_SUPPORT_STATUS_VER MAKE_NVAPI_VERSION(NV_GPU_GET_HDCP_SUPPORT_STATUS,1)
#define | NV_COMPUTE_GPU_TOPOLOGY_VER1 MAKE_NVAPI_VERSION(NV_COMPUTE_GPU_TOPOLOGY_V1,1)
#define | NV_COMPUTE_GPU_TOPOLOGY_VER MAKE_NVAPI_VERSION(NV_COMPUTE_GPU_TOPOLOGY_V2,2)
#define | NV_GPU_ECC_STATUS_INFO_VER MAKE_NVAPI_VERSION(NV_GPU_ECC_STATUS_INFO,1)
#define | NV_GPU_ECC_ERROR_INFO_VER MAKE_NVAPI_VERSION(NV_GPU_ECC_ERROR_INFO,1)
#define | NV_GPU_ECC_CONFIGURATION_INFO_VER MAKE_NVAPI_VERSION(NV_GPU_ECC_CONFIGURATION_INFO,1)
#define | NV_EVENT_REGISTER_CALLBACK_VERSION MAKE_NVAPI_VERSION(NV_EVENT_REGISTER_CALLBACK,1)
#define | NV_SCANOUT_INTENSITY_DATA_VER1 MAKE_NVAPI_VERSION(NV_SCANOUT_INTENSITY_DATA_V1, 1)
#define | NV_SCANOUT_INTENSITY_DATA_VER2 MAKE_NVAPI_VERSION(NV_SCANOUT_INTENSITY_DATA_V2, 2)
#define | NV_SCANOUT_INTENSITY_DATA_VER NV_SCANOUT_INTENSITY_DATA_VER2
#define | NV_SCANOUT_INTENSITY_STATE_VER MAKE_NVAPI_VERSION(NV_SCANOUT_INTENSITY_STATE_DATA, 1)
#define | NV_SCANOUT_WARPING_VER MAKE_NVAPI_VERSION(NV_SCANOUT_WARPING_DATA, 1)
#define | NV_SCANOUT_WARPING_STATE_VER MAKE_NVAPI_VERSION(NV_SCANOUT_WARPING_STATE_DATA, 1)
#define | NV_SCANOUT_INFORMATION_VER MAKE_NVAPI_VERSION(NV_SCANOUT_INFORMATION,1)
#define | NV_GPU_VIRTUALIZATION_INFO_VER1 MAKE_NVAPI_VERSION(NV_GPU_VIRTUALIZATION_INFO_V1,1)
#define | NV_GPU_VIRTUALIZATION_INFO_VER NV_GPU_VIRTUALIZATION_INFO_VER1
#define | NV_LOGICAL_GPU_DATA_VER1 MAKE_NVAPI_VERSION(NV_LOGICAL_GPU_DATA_V1,1)
#define | NV_LOGICAL_GPU_DATA_VER NV_LOGICAL_GPU_DATA_VER1
#define | NVAPI_NVLINK_COUNTER_MAX_TYPES 32
#define | NVAPI_NVLINK_MAX_LINKS 32
#define | NV_GPU_INFO_VER1 MAKE_NVAPI_VERSION(NV_GPU_INFO_V1, 1)
#define | NV_GPU_INFO_VER2 MAKE_NVAPI_VERSION(NV_GPU_INFO_V2, 2)
#define | NV_GPU_INFO_VER NV_GPU_INFO_VER2
#define | NV_GPU_VR_READY_VER1 MAKE_NVAPI_VERSION(NV_GPU_VR_READY_V1, 1)
#define | NV_GPU_VR_READY_VER NV_GPU_VR_READY_VER1
#define | NVAPI_GPU_MAX_BUILD_VERSION_LENGTH (0x0000040)
#define | NV_GPU_GSP_INFO_VER1 MAKE_NVAPI_VERSION(NV_GPU_GSP_INFO_V1, 1)
#define | NV_GPU_GSP_INFO_VER NV_GPU_GSP_INFO_VER1
#define | NVAPI_MAX_GPU_UTILIZATIONS 8
#define | NV_GPU_DYNAMIC_PSTATES_INFO_EX_VER MAKE_NVAPI_VERSION(NV_GPU_DYNAMIC_PSTATES_INFO_EX,1)
#define | NVAPI_MAX_THERMAL_SENSORS_PER_GPU 3
#define | NV_GPU_MAX_CLOCK_FREQUENCIES 3
#define | NV_GPU_CLOCK_FREQUENCIES_VER_1 MAKE_NVAPI_VERSION(NV_GPU_CLOCK_FREQUENCIES_V1,1)
#define | NV_GPU_CLOCK_FREQUENCIES_VER_2 MAKE_NVAPI_VERSION(NV_GPU_CLOCK_FREQUENCIES_V2,2)
#define | NV_GPU_CLOCK_FREQUENCIES_VER_3 MAKE_NVAPI_VERSION(NV_GPU_CLOCK_FREQUENCIES_V2,3)
#define | NV_GPU_CLOCK_FREQUENCIES_VER NV_GPU_CLOCK_FREQUENCIES_VER_3
#define | NV_GPU_QUERY_ILLUMINATION_SUPPORT_PARM_VER_1 MAKE_NVAPI_VERSION(NV_GPU_QUERY_ILLUMINATION_SUPPORT_PARM_V1,1)
#define | NV_GPU_QUERY_ILLUMINATION_SUPPORT_PARM_VER NV_GPU_QUERY_ILLUMINATION_SUPPORT_PARM_VER_1
#define | NV_GPU_GET_ILLUMINATION_PARM_VER_1 MAKE_NVAPI_VERSION(NV_GPU_GET_ILLUMINATION_PARM_V1,1)
#define | NV_GPU_GET_ILLUMINATION_PARM_VER NV_GPU_GET_ILLUMINATION_PARM_VER_1
#define | NV_GPU_SET_ILLUMINATION_PARM_VER_1 MAKE_NVAPI_VERSION(NV_GPU_SET_ILLUMINATION_PARM_V1,1)
#define | NV_GPU_SET_ILLUMINATION_PARM_VER NV_GPU_SET_ILLUMINATION_PARM_VER_1
#define | NV_GPU_CLIENT_ILLUM_CTRL_MODE_PIECEWISE_LINEAR_COLOR_ENDPOINTS 2
#define | NV_GPU_CLIENT_ILLUM_DEVICE_NUM_DEVICES_MAX 32
#define | NV_GPU_CLIENT_ILLUM_DEVICE_INFO_PARAMS_VER_1 MAKE_NVAPI_VERSION(NV_GPU_CLIENT_ILLUM_DEVICE_INFO_PARAMS_V1, 1)
#define | NV_GPU_CLIENT_ILLUM_DEVICE_INFO_PARAMS_VER NV_GPU_CLIENT_ILLUM_DEVICE_INFO_PARAMS_VER_1
#define | NV_GPU_CLIENT_ILLUM_DEVICE_CONTROL_PARAMS_VER_1 MAKE_NVAPI_VERSION(NV_GPU_CLIENT_ILLUM_DEVICE_CONTROL_PARAMS_V1, 1)
#define | NV_GPU_CLIENT_ILLUM_DEVICE_CONTROL_PARAMS_VER NV_GPU_CLIENT_ILLUM_DEVICE_CONTROL_PARAMS_VER_1
#define | NV_GPU_CLIENT_ILLUM_ZONE_NUM_ZONES_MAX 32
#define | NV_GPU_CLIENT_ILLUM_ZONE_INFO_PARAMS_VER_1 MAKE_NVAPI_VERSION(NV_GPU_CLIENT_ILLUM_ZONE_INFO_PARAMS_V1, 1)
#define | NV_GPU_CLIENT_ILLUM_ZONE_INFO_PARAMS_VER NV_GPU_CLIENT_ILLUM_ZONE_INFO_PARAMS_VER_1
#define | NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_PARAMS_VER_1 MAKE_NVAPI_VERSION(NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_PARAMS_V1, 1)
#define | NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_PARAMS_VER NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_PARAMS_VER_1
#define | NV_DISPLAY_PORT_INFO_VER1 MAKE_NVAPI_VERSION(NV_DISPLAY_PORT_INFO,1)
#define | NV_DISPLAY_PORT_INFO_VER2 MAKE_NVAPI_VERSION(NV_DISPLAY_PORT_INFO,2)
#define | NV_DISPLAY_PORT_INFO_VER NV_DISPLAY_PORT_INFO_VER2
#define | NV_DISPLAY_PORT_CONFIG_VER MAKE_NVAPI_VERSION(NV_DISPLAY_PORT_CONFIG,2)
#define | NV_DISPLAY_PORT_CONFIG_VER_1 MAKE_NVAPI_VERSION(NV_DISPLAY_PORT_CONFIG,1)
#define | NV_DISPLAY_PORT_CONFIG_VER_2 MAKE_NVAPI_VERSION(NV_DISPLAY_PORT_CONFIG,2)
#define | NV_HDMI_SUPPORT_INFO_VER1 MAKE_NVAPI_VERSION(NV_HDMI_SUPPORT_INFO_V1, 1)
#define | NV_HDMI_SUPPORT_INFO_VER2 MAKE_NVAPI_VERSION(NV_HDMI_SUPPORT_INFO_V2, 2)
#define | NV_HDMI_SUPPORT_INFO_VER NV_HDMI_SUPPORT_INFO_VER2
#define | NV_INFOFRAME_DATA_VER MAKE_NVAPI_VERSION(NV_INFOFRAME_DATA,1)
#define | NV_HDR_CAPABILITIES_VER1 MAKE_NVAPI_VERSION(NV_HDR_CAPABILITIES_V1, 1)
#define | NV_HDR_CAPABILITIES_VER2 MAKE_NVAPI_VERSION(NV_HDR_CAPABILITIES_V2, 2)
#define | NV_HDR_CAPABILITIES_VER3 MAKE_NVAPI_VERSION(NV_HDR_CAPABILITIES_V3, 3)
#define | NV_HDR_CAPABILITIES_VER NV_HDR_CAPABILITIES_VER3
#define | NV_HDR_COLOR_DATA_VER1 MAKE_NVAPI_VERSION(NV_HDR_COLOR_DATA_V1, 1)
#define | NV_HDR_COLOR_DATA_VER2 MAKE_NVAPI_VERSION(NV_HDR_COLOR_DATA_V2, 2)
#define | NV_HDR_COLOR_DATA_VER NV_HDR_COLOR_DATA_VER2
#define | NV_TIMING_INPUT_VER MAKE_NVAPI_VERSION(NV_TIMING_INPUT,1)
#define | NV_MONITOR_COLOR_CAPS_VER1 MAKE_NVAPI_VERSION(NV_MONITOR_COLOR_CAPS_V1,1)
#define | NV_MONITOR_COLOR_CAPS_VER NV_MONITOR_COLOR_CAPS_VER1
#define | NV_CUSTOM_DISPLAY_VER MAKE_NVAPI_VERSION(NV_CUSTOM_DISPLAY,1)
#define | NV_GET_ADAPTIVE_SYNC_DATA_VER1 MAKE_NVAPI_VERSION(NV_GET_ADAPTIVE_SYNC_DATA_V1,1)
#define | NV_GET_ADAPTIVE_SYNC_DATA_VER NV_GET_ADAPTIVE_SYNC_DATA_VER1
#define | NV_SET_ADAPTIVE_SYNC_DATA_VER1 MAKE_NVAPI_VERSION(NV_SET_ADAPTIVE_SYNC_DATA_V1,1)
#define | NV_SET_ADAPTIVE_SYNC_DATA_VER NV_SET_ADAPTIVE_SYNC_DATA_VER1
#define | NV_GET_VIRTUAL_REFRESH_RATE_DATA_VER1 MAKE_NVAPI_VERSION(_NV_GET_VIRTUAL_REFRESH_RATE_DATA_V1,1)
#define | NV_GET_VIRTUAL_REFRESH_RATE_DATA_VER NV_GET_VIRTUAL_REFRESH_RATE_DATA_VER1
#define | NV_SET_VIRTUAL_REFRESH_RATE_DATA_VER1 MAKE_NVAPI_VERSION(_NV_SET_VIRTUAL_REFRESH_RATE_DATA_V1,1)
#define | NV_SET_VIRTUAL_REFRESH_RATE_DATA_VER NV_SET_VIRTUAL_REFRESH_RATE_DATA_VER1
#define | NV_SET_PREFERRED_STEREO_DISPLAY_VER1 MAKE_NVAPI_VERSION(NV_SET_PREFERRED_STEREO_DISPLAY_V1,1)
#define | NV_SET_PREFERRED_STEREO_DISPLAY_VER NV_SET_PREFERRED_STEREO_DISPLAY_VER1
#define | NV_GET_PREFERRED_STEREO_DISPLAY_VER1 MAKE_NVAPI_VERSION(NV_GET_PREFERRED_STEREO_DISPLAY_V1,1)
#define | NV_GET_PREFERRED_STEREO_DISPLAY_VER NV_GET_PREFERRED_STEREO_DISPLAY_VER1
#define | NV_MANAGED_DEDICATED_DISPLAY_INFO_VER1 MAKE_NVAPI_VERSION(NV_MANAGED_DEDICATED_DISPLAY_INFO_V1,1)
#define | NV_MANAGED_DEDICATED_DISPLAY_INFO_VER NV_MANAGED_DEDICATED_DISPLAY_INFO_VER1
#define | NV_MANAGED_DEDICATED_DISPLAY_METADATA_VER1 MAKE_NVAPI_VERSION(NV_MANAGED_DEDICATED_DISPLAY_METADATA_V1,1)
#define | NV_MANAGED_DEDICATED_DISPLAY_METADATA_VER NV_MANAGED_DEDICATED_DISPLAY_METADATA_VER1
#define | NV_GET_VRR_INFO_VER1 MAKE_NVAPI_VERSION(NV_GET_VRR_INFO_V1,1)
#define | NV_GET_VRR_INFO_VER NV_GET_VRR_INFO_VER1
#define | NVAPI_MAX_MOSAIC_DISPLAY_ROWS 8
#define | NVAPI_MAX_MOSAIC_DISPLAY_COLUMNS 8
#define | NV_MOSAIC_TOPO_VALIDITY_VALID 0x00000000
#define | NV_MOSAIC_TOPO_VALIDITY_MISSING_GPU 0x00000001
#define | NV_MOSAIC_TOPO_VALIDITY_MISSING_DISPLAY 0x00000002
#define | NV_MOSAIC_TOPO_VALIDITY_MIXED_DISPLAY_TYPES 0x00000004
#define | NVAPI_MOSAIC_TOPO_DETAILS_VER MAKE_NVAPI_VERSION(NV_MOSAIC_TOPO_DETAILS,1)
#define | NVAPI_MOSAIC_TOPO_BRIEF_VER MAKE_NVAPI_VERSION(NV_MOSAIC_TOPO_BRIEF,1)
#define | NVAPI_MOSAIC_DISPLAY_SETTING_VER1 MAKE_NVAPI_VERSION(NV_MOSAIC_DISPLAY_SETTING_V1,1)
#define | NVAPI_MOSAIC_DISPLAY_SETTING_VER2 MAKE_NVAPI_VERSION(NV_MOSAIC_DISPLAY_SETTING_V2,2)
#define | NVAPI_MOSAIC_DISPLAY_SETTING_VER NVAPI_MOSAIC_DISPLAY_SETTING_VER2
#define | NV_MOSAIC_DISPLAY_SETTINGS_MAX 40
#define | NVAPI_MOSAIC_SUPPORTED_TOPO_INFO_VER1 MAKE_NVAPI_VERSION(NV_MOSAIC_SUPPORTED_TOPO_INFO_V1,1)
#define | NVAPI_MOSAIC_SUPPORTED_TOPO_INFO_VER2 MAKE_NVAPI_VERSION(NV_MOSAIC_SUPPORTED_TOPO_INFO_V2,2)
#define | NVAPI_MOSAIC_SUPPORTED_TOPO_INFO_VER NVAPI_MOSAIC_SUPPORTED_TOPO_INFO_VER2
#define | NV_MOSAIC_TOPO_IDX_DEFAULT 0
#define | NV_MOSAIC_TOPO_IDX_LEFT_EYE 0
#define | NV_MOSAIC_TOPO_IDX_RIGHT_EYE 1
#define | NV_MOSAIC_TOPO_NUM_EYES 2
#define | NV_MOSAIC_MAX_TOPO_PER_TOPO_GROUP 2
#define | NVAPI_MOSAIC_TOPO_GROUP_VER MAKE_NVAPI_VERSION(NV_MOSAIC_TOPO_GROUP,1)
#define | NV_MOSAIC_DISPLAYCAPS_PROBLEM_DISPLAY_ON_INVALID_GPU NV_BIT(0)
#define | NV_MOSAIC_DISPLAYCAPS_PROBLEM_DISPLAY_ON_WRONG_CONNECTOR NV_BIT(1)
#define | NV_MOSAIC_DISPLAYCAPS_PROBLEM_NO_COMMON_TIMINGS NV_BIT(2)
#define | NV_MOSAIC_DISPLAYCAPS_PROBLEM_NO_EDID_AVAILABLE NV_BIT(3)
#define | NV_MOSAIC_DISPLAYCAPS_PROBLEM_MISMATCHED_OUTPUT_TYPE NV_BIT(4)
#define | NV_MOSAIC_DISPLAYCAPS_PROBLEM_NO_DISPLAY_CONNECTED NV_BIT(5)
#define | NV_MOSAIC_DISPLAYCAPS_PROBLEM_NO_GPU_TOPOLOGY NV_BIT(6)
#define | NV_MOSAIC_DISPLAYCAPS_PROBLEM_NOT_SUPPORTED NV_BIT(7)
#define | NV_MOSAIC_DISPLAYCAPS_PROBLEM_NO_SLI_BRIDGE NV_BIT(8)
#define | NV_MOSAIC_DISPLAYCAPS_PROBLEM_ECC_ENABLED NV_BIT(9)
#define | NV_MOSAIC_DISPLAYCAPS_PROBLEM_GPU_TOPOLOGY_NOT_SUPPORTED NV_BIT(10)
#define | NV_MOSAIC_SETDISPLAYTOPO_FLAG_CURRENT_GPU_TOPOLOGY NV_BIT(0)
#define | NV_MOSAIC_SETDISPLAYTOPO_FLAG_NO_DRIVER_RELOAD NV_BIT(1)
#define | NV_MOSAIC_SETDISPLAYTOPO_FLAG_MAXIMIZE_PERFORMANCE NV_BIT(2)
#define | NV_MOSAIC_SETDISPLAYTOPO_FLAG_ALLOW_INVALID NV_BIT(3)
#define | NV_MOSAIC_DISPLAYTOPO_WARNING_DISPLAY_POSITION NV_BIT(0)
#define | NV_MOSAIC_DISPLAYTOPO_WARNING_DRIVER_RELOAD_REQUIRED NV_BIT(1)
#define | NV_MOSAIC_DISPLAY_TOPO_STATUS_VER MAKE_NVAPI_VERSION(NV_MOSAIC_DISPLAY_TOPO_STATUS,1)
#define | NVAPI_MAX_MOSAIC_DISPLAY_ROWS 8
#define | NVAPI_MAX_MOSAIC_DISPLAY_COLUMNS 8
#define | NVAPI_MAX_MOSAIC_TOPOS 16
#define | NVAPI_MOSAIC_TOPOLOGY_VER MAKE_NVAPI_VERSION(NV_MOSAIC_TOPOLOGY,1)
#define | NVAPI_MOSAIC_SUPPORTED_TOPOLOGIES_VER MAKE_NVAPI_VERSION(NV_MOSAIC_SUPPORTED_TOPOLOGIES,1)
#define | NVAPI_MAX_GSYNC_DEVICES 4
#define | NVAPI_GSYNC_BOARD_ID_P358 856
#define | NVAPI_GSYNC_BOARD_ID_P2060 8288
#define | NVAPI_GSYNC_BOARD_ID_P2061 8289
#define | NV_GSYNC_CAPABILITIES_VER1 MAKE_NVAPI_VERSION(NV_GSYNC_CAPABILITIES_V1,1)
#define | NV_GSYNC_CAPABILITIES_VER2 MAKE_NVAPI_VERSION(NV_GSYNC_CAPABILITIES_V2,2)
#define | NV_GSYNC_CAPABILITIES_VER3 MAKE_NVAPI_VERSION(NV_GSYNC_CAPABILITIES_V3,3)
#define | NV_GSYNC_CAPABILITIES_VER NV_GSYNC_CAPABILITIES_VER3
#define | NV_GSYNC_DISPLAY_VER MAKE_NVAPI_VERSION(NV_GSYNC_DISPLAY,1)
#define | NV_GSYNC_GPU_VER MAKE_NVAPI_VERSION(NV_GSYNC_GPU,1)
#define | NV_GSYNC_DELAY_VER MAKE_NVAPI_VERSION(NV_GSYNC_DELAY,1)
#define | NV_GSYNC_CONTROL_PARAMS_VER1 MAKE_NVAPI_VERSION(NV_GSYNC_CONTROL_PARAMS_V1,1)
#define | NV_GSYNC_CONTROL_PARAMS_VER2 MAKE_NVAPI_VERSION(NV_GSYNC_CONTROL_PARAMS_V2,2)
#define | NV_GSYNC_CONTROL_PARAMS_VER NV_GSYNC_CONTROL_PARAMS_VER2
#define | NV_GSYNC_STATUS_VER MAKE_NVAPI_VERSION(NV_GSYNC_STATUS,1)
#define | NVAPI_MAX_RJ45_PER_GSYNC 2
#define | NV_GSYNC_STATUS_PARAMS_VER1 MAKE_NVAPI_VERSION(NV_GSYNC_STATUS_PARAMS_V1,1)
#define | NV_GSYNC_STATUS_PARAMS_VER2 MAKE_NVAPI_VERSION(NV_GSYNC_STATUS_PARAMS_V2,2)
#define | NV_GSYNC_STATUS_PARAMS_VER NV_GSYNC_STATUS_PARAMS_VER2
#define | NV_STEREO_VIDEO_FORMAT_DEFINE
#define | NV_DX_VIDEO_STEREO_INFO_VER MAKE_NVAPI_VERSION(NV_DX_VIDEO_STEREO_INFO,1)
#define | NV_JOIN_PRESENT_BARRIER_PARAMS_VER1 MAKE_NVAPI_VERSION(NV_JOIN_PRESENT_BARRIER_PARAMS, 1)
#define | NV_PRESENT_BARRIER_FRAME_STATICS_VER1 MAKE_NVAPI_VERSION(NV_PRESENT_BARRIER_FRAME_STATISTICS,1)
#define | NVAPI_ANSEL_CONFIGURATION_STRUCT_VER1 MAKE_NVAPI_VERSION(NVAPI_ANSEL_CONFIGURATION_STRUCT_V1,1)
#define | NVAPI_ANSEL_CONFIGURATION_STRUCT_VER NVAPI_ANSEL_CONFIGURATION_STRUCT_VER1
#define | NV_CUSTOM_SEMANTIC_MAX_LIMIT 32
#define | NV_CUSTOM_SEMANTIC_VERSION MAKE_NVAPI_VERSION(NV_CUSTOM_SEMANTIC, 1)
#define | NVAPI_D3D11_CREATEGEOMETRYSHADEREX_2_VER_5 MAKE_NVAPI_VERSION(NvAPI_D3D11_CREATE_GEOMETRY_SHADER_EX_V5, 5)
#define | NVAPI_D3D11_CREATEGEOMETRYSHADEREX_2_VERSION NVAPI_D3D11_CREATEGEOMETRYSHADEREX_2_VER_5
#define | NVAPI_D3D11_CREATEVERTEXSHADEREX_VER_1 MAKE_NVAPI_VERSION(NvAPI_D3D11_CREATE_VERTEX_SHADER_EX_V1, 1)
#define | NVAPI_D3D11_CREATEVERTEXSHADEREX_VER_2 MAKE_NVAPI_VERSION(NvAPI_D3D11_CREATE_VERTEX_SHADER_EX_V2, 2)
#define | NVAPI_D3D11_CREATEVERTEXSHADEREX_VER_3 MAKE_NVAPI_VERSION(NvAPI_D3D11_CREATE_VERTEX_SHADER_EX_V2, 3)
#define | NVAPI_D3D11_CREATEVERTEXSHADEREX_VERSION NVAPI_D3D11_CREATEVERTEXSHADEREX_VER_3
#define | NVAPI_D3D11_CREATEHULLSHADEREX_VER_1 MAKE_NVAPI_VERSION(NvAPI_D3D11_CREATE_HULL_SHADER_EX_V1, 1)
#define | NVAPI_D3D11_CREATEHULLSHADEREX_VER_2 MAKE_NVAPI_VERSION(NvAPI_D3D11_CREATE_HULL_SHADER_EX_V1, 2)
#define | NVAPI_D3D11_CREATEHULLSHADEREX_VERSION NVAPI_D3D11_CREATEHULLSHADEREX_VER_2
#define | NVAPI_D3D11_CREATEDOMAINSHADEREX_VER_1 MAKE_NVAPI_VERSION(NvAPI_D3D11_CREATE_DOMAIN_SHADER_EX_V1, 1)
#define | NVAPI_D3D11_CREATEDOMAINSHADEREX_VER_2 MAKE_NVAPI_VERSION(NvAPI_D3D11_CREATE_DOMAIN_SHADER_EX_V2, 2)
#define | NVAPI_D3D11_CREATEDOMAINSHADEREX_VER_3 MAKE_NVAPI_VERSION(NvAPI_D3D11_CREATE_DOMAIN_SHADER_EX_V3, 3)
#define | NVAPI_D3D11_CREATEDOMAINSHADEREX_VERSION NVAPI_D3D11_CREATEDOMAINSHADEREX_VER_3
#define | NVAPI_D3D11_CREATEPIXELSHADEREX_VER_1 MAKE_NVAPI_VERSION(NvAPI_D3D11_CREATE_PIXEL_SHADER_EX_V1, 1)
#define | NVAPI_D3D11_CREATEPIXELSHADEREX_VER_2 MAKE_NVAPI_VERSION(NvAPI_D3D11_CREATE_PIXEL_SHADER_EX_V2, 2)
#define | NVAPI_D3D11_CREATEPIXELSHADEREX_VERSION NVAPI_D3D11_CREATEPIXELSHADEREX_VER_2
#define | NVAPI_D3D11_CREATEFASTGSEXPLICIT_VER1 MAKE_NVAPI_VERSION(NvAPI_D3D11_CREATE_FASTGS_EXPLICIT_DESC_V1, 1)
#define | NVAPI_D3D11_CREATEFASTGSEXPLICIT_VER NVAPI_D3D11_CREATEFASTGSEXPLICIT_VER1
#define | NV_PSO_EXTENSION_DESC_VER_1 MAKE_NVAPI_VERSION(NVAPI_D3D12_PSO_EXTENSION_DESC_V1, 1)
#define | NV_PSO_EXTENSION_DESC_VER NV_PSO_EXTENSION_DESC_VER_1
#define | NV_RASTERIZER_PSO_EXTENSION_DESC_VER_1 MAKE_NVAPI_VERSION(NVAPI_D3D12_PSO_RASTERIZER_STATE_DESC_V1, 1)
#define | NV_RASTERIZER_PSO_EXTENSION_DESC_VER_2 MAKE_NVAPI_VERSION(NVAPI_D3D12_PSO_RASTERIZER_STATE_DESC_V1, 2)
#define | NV_RASTERIZER_PSO_EXTENSION_DESC_VER NV_RASTERIZER_PSO_EXTENSION_DESC_VER_2
#define | NV_FASTGS_EXPLICIT_PSO_EXTENSION_VER_1 MAKE_NVAPI_VERSION(NVAPI_D3D12_PSO_CREATE_FASTGS_EXPLICIT_DESC_V1, 1)
#define | NV_FASTGS_EXPLICIT_PSO_EXTENSION_VER NV_FASTGS_EXPLICIT_PSO_EXTENSION_VER_1
#define | NV_FAST_GEOMETRY_SHADER_PSO_EXTENSION_VER_1 MAKE_NVAPI_VERSION(NVAPI_D3D12_PSO_REQUEST_FAST_GEOMETRY_SHADER_DESC_V1, 1)
#define | NV_FAST_GEOMETRY_SHADER_PSO_EXTENSION_VER NV_FAST_GEOMETRY_SHADER_PSO_EXTENSION_VER_1
#define | NV_GEOMETRY_SHADER_PSO_EXTENSION_DESC_VER_5 MAKE_NVAPI_VERSION(NVAPI_D3D12_PSO_GEOMETRY_SHADER_DESC_V5, 5)
#define | NV_GEOMETRY_SHADER_PSO_EXTENSION_DESC_VER NV_GEOMETRY_SHADER_PSO_EXTENSION_DESC_VER_5
#define | NV_VERTEX_SHADER_PSO_EXTENSION_DESC_VER_1 MAKE_NVAPI_VERSION(NVAPI_D3D12_PSO_VERTEX_SHADER_DESC_V1, 1)
#define | NV_VERTEX_SHADER_PSO_EXTENSION_DESC_VER_2 MAKE_NVAPI_VERSION(NVAPI_D3D12_PSO_VERTEX_SHADER_DESC_V2, 2)
#define | NV_VERTEX_SHADER_PSO_EXTENSION_DESC_VER_3 MAKE_NVAPI_VERSION(NVAPI_D3D12_PSO_VERTEX_SHADER_DESC_V3, 3)
#define | NV_VERTEX_SHADER_PSO_EXTENSION_DESC_VER NV_VERTEX_SHADER_PSO_EXTENSION_DESC_VER_3
#define | NV_HULL_SHADER_PSO_EXTENSION_DESC_VER_1 MAKE_NVAPI_VERSION(NVAPI_D3D12_PSO_HULL_SHADER_DESC_V1, 1)
#define | NV_HULL_SHADER_PSO_EXTENSION_DESC_VER_2 MAKE_NVAPI_VERSION(NVAPI_D3D12_PSO_HULL_SHADER_DESC_V2, 2)
#define | NV_HULL_SHADER_PSO_EXTENSION_DESC_VER NV_HULL_SHADER_PSO_EXTENSION_DESC_VER_2
#define | NV_DOMAIN_SHADER_PSO_EXTENSION_DESC_VER_1 MAKE_NVAPI_VERSION(NVAPI_D3D12_PSO_DOMAIN_SHADER_DESC_V1, 1)
#define | NV_DOMAIN_SHADER_PSO_EXTENSION_DESC_VER_2 MAKE_NVAPI_VERSION(NVAPI_D3D12_PSO_DOMAIN_SHADER_DESC_V2, 2)
#define | NV_DOMAIN_SHADER_PSO_EXTENSION_DESC_VER_3 MAKE_NVAPI_VERSION(NVAPI_D3D12_PSO_DOMAIN_SHADER_DESC_V3, 3)
#define | NV_DOMAIN_SHADER_PSO_EXTENSION_DESC_VER NV_DOMAIN_SHADER_PSO_EXTENSION_DESC_VER_3
#define | NV_ENABLE_DEPTH_BOUND_TEST_PSO_EXTENSION_DESC_VER_1 MAKE_NVAPI_VERSION(NVAPI_D3D12_PSO_ENABLE_DEPTH_BOUND_TEST_DESC_V1, 1)
#define | NV_ENABLE_DEPTH_BOUND_TEST_PSO_EXTENSION_DESC_VER NV_ENABLE_DEPTH_BOUND_TEST_PSO_EXTENSION_DESC_VER_1
#define | NV_SET_SHADER_EXTENSION_SLOT_DESC_VER_1 MAKE_NVAPI_VERSION(NVAPI_D3D12_PSO_SET_SHADER_EXTENSION_SLOT_DESC_V1, 1)
#define | NV_SET_SHADER_EXTENSION_SLOT_DESC_VER NV_SET_SHADER_EXTENSION_SLOT_DESC_VER_1
#define | NV_HEAP_PARAMS_VER_1 MAKE_NVAPI_VERSION(NV_HEAP_PARAMS_V1, 1)
#define | NV_HEAP_PARAMS_VER NV_HEAP_PARAMS_VER_1
#define | NVAPI_UAV_INFO_VER1 1
#define | NVAPI_UAV_INFO_VER2 MAKE_NVAPI_VERSION(NVAPI_UAV_INFO_V2, 2)
#define | NVAPI_UAV_INFO_VER NVAPI_UAV_INFO_VER2
#define | NV_GET_GPU_VIRTUAL_ADDRESS_VER1 MAKE_NVAPI_VERSION(NV_GET_GPU_VIRTUAL_ADDRESS_V1, 1)
#define | NV_GET_GPU_VIRTUAL_ADDRESS_VER NV_GET_GPU_VIRTUAL_ADDRESS_VER1
#define | NV_GET_GPU_VIRTUAL_ADDRESS NV_GET_GPU_VIRTUAL_ADDRESS_V1
#define | NV_META_COMMAND_MAX_TENSOR_DIM 5
#define | NV_META_COMMAND_ACTIVATION_MAX_PARAMS 2
#define | compile_time_assert(b) typedef char compile_time_assertion_failed_in_line_##__LINE__[(b)?1:-1]
#define | NV_META_COMMAND_NUM_SPATIAL_DIM 3
#define | ID3D11NvMetaCommand_VER1 MAKE_NVAPI_VERSION(IID3D11NvMetaCommand_V1, 1)
#define | ID3D11NvMetaCommand_VER ID3D11NvMetaCommand_VER1
#define | ID3D12NvMetaCommand_VER1 MAKE_NVAPI_VERSION(IID3D12NvMetaCommand_V1, 1)
#define | ID3D12NvMetaCommand_VER ID3D12NvMetaCommand_VER1
#define | NV_RESOURCE_PARAMS_VER_1 MAKE_NVAPI_VERSION(NV_RESOURCE_PARAMS_V1, 1)
#define | NV_RESOURCE_PARAMS_VER NV_RESOURCE_PARAMS_VER_1
#define | NV_MULTIGPU_CAPS_VER1 MAKE_NVAPI_VERSION(NV_MULTIGPU_CAPS_V1, 1)
#define | NV_MULTIGPU_CAPS_VER2 MAKE_NVAPI_VERSION(NV_MULTIGPU_CAPS_V2, 2)
#define | NV_MULTIGPU_CAPS_VER NV_MULTIGPU_CAPS_VER2
#define | NVAPI_COPY_ASYNCHRONOUSLY 1
#define | NVAPI_COPY_P2P_READ 2
#define | NVAPI_CPU_RESOURCE 0xffffffff
#define | FENCE_SYNCHRONIZATION_START(pMultiGPUDevice, hFence, Value, srcGpu, dstGpu)
#define | FENCE_SYNCHRONIZATION_END(pMultiGPUDevice, hFence, Value, srcGpu, dstGpu)
#define | NVAPI_PRESENT_COMPOSITING_CONFIG_FLAG_USE_VIDEO_BRIDGE 0x01
#define | NVAPI_PRESENT_COMPOSITING_CONFIG_FLAG_CLEAR_OUTBANDS 0x02
#define | NVAPI_PRESENT_COMPOSITING_CONFIG_FLAG_GET_VIDEO_BRIDGE_STATUS 0x80000000
#define | NVAPI_VIDEO_BRIDGE_STATUS_AVAILABLE 0
#define | NVAPI_VIDEO_BRIDGE_STATUS_NOT_AVAILABLE 1
#define | NVAPI_VIDEO_BRIDGE_STATUS_FAILED_ACCESS 2
#define | NVAPI_VIDEO_BRIDGE_STATUS_UNKNOWN 3
#define | NVAPI_ALL_GPUS 0
#define | ID3D11MultiGPUDevice_VER1 MAKE_NVAPI_VERSION(ID3D11MultiGPUDevice_V1, 1)
#define | ID3D11MultiGPUDevice_VER2 MAKE_NVAPI_VERSION(ID3D11MultiGPUDevice_V1, 2)
#define | ID3D11MultiGPUDevice_VER3 MAKE_NVAPI_VERSION(ID3D11MultiGPUDevice_V1, 3)
#define | ID3D11MultiGPUDevice_VER ID3D11MultiGPUDevice_VER3
#define | ALL_GPUS 0
#define | NV_QUERY_SINGLE_PASS_STEREO_SUPPORT_PARAMS_VER1 MAKE_NVAPI_VERSION(NV_QUERY_SINGLE_PASS_STEREO_SUPPORT_PARAMS_V1, 1)
#define | NV_QUERY_SINGLE_PASS_STEREO_SUPPORT_PARAMS_VER2 MAKE_NVAPI_VERSION(NV_QUERY_SINGLE_PASS_STEREO_SUPPORT_PARAMS_V2, 2)
#define | NV_QUERY_SINGLE_PASS_STEREO_SUPPORT_PARAMS_VER NV_QUERY_SINGLE_PASS_STEREO_SUPPORT_PARAMS_VER2
#define | NV_QUERY_MULTIVIEW_SUPPORT_PARAMS_VER1 MAKE_NVAPI_VERSION(NV_QUERY_MULTIVIEW_SUPPORT_PARAMS_V1, 1)
#define | NV_QUERY_MULTIVIEW_SUPPORT_PARAMS_VER NV_QUERY_MULTIVIEW_SUPPORT_PARAMS_VER1
#define | NV_MULTIVIEW_MAX_SUPPORTED_VIEWS 4
#define | NV_MULTIVIEW_PARAMS_VER1 MAKE_NVAPI_VERSION(NV_MULTIVIEW_PARAMS_V1, 1)
#define | NV_MULTIVIEW_PARAMS_VER NV_MULTIVIEW_PARAMS_VER1
#define | NV_QUERY_MODIFIED_W_SUPPORT_PARAMS_VER1 MAKE_NVAPI_VERSION(NV_QUERY_MODIFIED_W_SUPPORT_PARAMS_V1, 1)
#define | NV_QUERY_MODIFIED_W_SUPPORT_PARAMS_VER NV_QUERY_MODIFIED_W_SUPPORT_PARAMS_VER1
#define | NV_MODIFIED_W_MAX_VIEWPORTS 16
#define | NV_MODIFIED_W_PARAMS_VER1 MAKE_NVAPI_VERSION(NV_MODIFIED_W_PARAMS_V1, 1)
#define | NV_MODIFIED_W_PARAMS_VER NV_MODIFIED_W_PARAMS_VER1
#define | ID3DLateLatchObject_VER1 MAKE_NVAPI_VERSION(ID3DLateLatchObject_V1, 1)
#define | ID3DLateLatchObject_VER ID3DLateLatchObject_VER1
#define | NV_D3D_LATELATCH_OBJECT_DESC_VER1 MAKE_NVAPI_VERSION(NV_D3D_LATELATCH_OBJECT_DESC_V1, 1)
#define | NV_D3D_LATELATCH_OBJECT_DESC_VER NV_D3D_LATELATCH_OBJECT_DESC_VER1
#define | NV_QUERY_LATELATCH_SUPPORT_PARAMS_VER1 MAKE_NVAPI_VERSION(NV_QUERY_LATELATCH_SUPPORT_PARAMS_V1, 1)
#define | NV_QUERY_LATELATCH_SUPPORT_PARAMS_VER NV_QUERY_LATELATCH_SUPPORT_PARAMS_VER1
#define | NV_D3D12_MOSAIC_GETCOMPANIONALLOCATIONS_VER1 MAKE_NVAPI_VERSION(NV_D3D12_MOSAIC_GETCOMPANIONALLOCATIONS_V1, 1)
#define | NV_D3D12_MOSAIC_GETCOMPANIONALLOCATIONS_VER NV_D3D12_MOSAIC_GETCOMPANIONALLOCATIONS_VER1
#define | NV_D3D12_MOSAIC_GETVIEWPORTANDGPUPARTITIONS_VER1 MAKE_NVAPI_VERSION(NV_D3D12_MOSAIC_GETVIEWPORTANDGPUPARTITIONS_V1, 1)
#define | NV_D3D12_MOSAIC_GETVIEWPORTANDGPUPARTITIONS_VER NV_D3D12_MOSAIC_GETVIEWPORTANDGPUPARTITIONS_VER1
#define | NV_D3D1x_GRAPHICS_CAPS_VER1 MAKE_NVAPI_VERSION(NV_D3D1x_GRAPHICS_CAPS_V1, 1)
#define | NV_D3D1x_GRAPHICS_CAPS_VER2 MAKE_NVAPI_VERSION(NV_D3D1x_GRAPHICS_CAPS_V2, 2)
#define | NV_D3D1x_GRAPHICS_CAPS_VER NV_D3D1x_GRAPHICS_CAPS_VER2
#define | NV_D3D12_GRAPHICS_CAPS_VER1 MAKE_NVAPI_VERSION(NV_D3D12_GRAPHICS_CAPS_V1, 1)
#define | NV_D3D12_GRAPHICS_CAPS_VER NV_D3D12_GRAPHICS_CAPS_VER1
#define | NV_MAX_NUM_EXCLUSIVE_SCISSOR_RECTS 16
#define | NV_D3D11_EXCLUSIVE_SCISSOR_RECTS_DESC_VER1 MAKE_NVAPI_VERSION(NV_D3D11_EXCLUSIVE_SCISSOR_RECTS_DESC_V1, 1)
#define | NV_D3D11_EXCLUSIVE_SCISSOR_RECTS_DESC_VER NV_D3D11_EXCLUSIVE_SCISSOR_RECTS_DESC_VER1
#define | NV_MAX_PIXEL_SHADING_RATES 16
#define | NV_MAX_NUM_VIEWPORTS 16
#define | NV_VARIABLE_PIXEL_SHADING_TILE_WIDTH 16
#define | NV_VARIABLE_PIXEL_SHADING_TILE_HEIGHT 16
#define | NV_D3D11_VIEWPORTS_SHADING_RATE_DESC_VER1 MAKE_NVAPI_VERSION(NV_D3D11_VIEWPORTS_SHADING_RATE_DESC_V1, 1)
#define | NV_D3D11_VIEWPORTS_SHADING_RATE_DESC_VER NV_D3D11_VIEWPORTS_SHADING_RATE_DESC_VER1
#define | NV_D3D11_SHADING_RATE_RESOURCE_VIEW_DESC_VER1 MAKE_NVAPI_VERSION(NV_D3D11_SHADING_RATE_RESOURCE_VIEW_DESC_V1, 1)
#define | NV_D3D11_SHADING_RATE_RESOURCE_VIEW_DESC_VER NV_D3D11_SHADING_RATE_RESOURCE_VIEW_DESC_VER1
#define | ID3D11NvShadingRateResourceView_VER1 MAKE_NVAPI_VERSION(ID3D11NvShadingRateResourceView_V1, 1)
#define | ID3D11NvShadingRateResourceView_VER ID3D11NvShadingRateResourceView_VER1
#define | NV_PIXEL_SHADING_RATE_SAMPLE_ORDER_TABLE_VER1 MAKE_NVAPI_VERSION(NV_PIXEL_SHADING_RATE_SAMPLE_ORDER_TABLE_V1, 1)
#define | NV_PIXEL_SHADING_RATE_SAMPLE_ORDER_TABLE_VER NV_PIXEL_SHADING_RATE_SAMPLE_ORDER_TABLE_VER1
#define | NV_VRS_HELPER_LATCH_GAZE_PARAMS_VER1 MAKE_NVAPI_VERSION(NV_VRS_HELPER_LATCH_GAZE_PARAMS_V1, 1)
#define | NV_VRS_HELPER_LATCH_GAZE_PARAMS_VER NV_VRS_HELPER_LATCH_GAZE_PARAMS_VER1
#define | NV_FOVEATED_RENDERING_CUSTOM_SHADING_RATE_PRESET_DESC_VER1 MAKE_NVAPI_VERSION(NV_FOVEATED_RENDERING_CUSTOM_SHADING_RATE_PRESET_DESC_V1, 1)
#define | NV_FOVEATED_RENDERING_CUSTOM_SHADING_RATE_PRESET_DESC_VER NV_FOVEATED_RENDERING_CUSTOM_SHADING_RATE_PRESET_DESC_VER1
#define | NV_FOVEATED_RENDERING_CUSTOM_FOVEATION_PATTERN_PRESET_DESC_VER1 MAKE_NVAPI_VERSION(NV_FOVEATED_RENDERING_CUSTOM_FOVEATION_PATTERN_PRESET_DESC_V1, 1)
#define | NV_FOVEATED_RENDERING_CUSTOM_FOVEATION_PATTERN_PRESET_DESC_VER NV_FOVEATED_RENDERING_CUSTOM_FOVEATION_PATTERN_PRESET_DESC_VER1
#define | NV_FOVEATED_RENDERING_DESC_VER1 MAKE_NVAPI_VERSION(NV_FOVEATED_RENDERING_DESC_V1, 1)
#define | NV_FOVEATED_RENDERING_DESC_VER NV_FOVEATED_RENDERING_DESC_VER1
#define | MAX_NUMBER_OF_GAZE_DATA_PROVIDERS 8
#define | NV_VRS_HELPER_ENABLE_PARAMS_VER1 MAKE_NVAPI_VERSION(NV_VRS_HELPER_ENABLE_PARAMS_V1, 1)
#define | NV_VRS_HELPER_ENABLE_PARAMS_VER NV_VRS_HELPER_ENABLE_PARAMS_VER1
#define | NV_VRS_HELPER_DISABLE_PARAMS_VER1 MAKE_NVAPI_VERSION(NV_VRS_HELPER_DISABLE_PARAMS_V1, 1)
#define | NV_VRS_HELPER_DISABLE_PARAMS_VER NV_VRS_HELPER_DISABLE_PARAMS_VER1
#define | NV_VRS_HELPER_GET_SHADING_RATE_RESOURCE_PARAMS_VER1 MAKE_NVAPI_VERSION(NV_VRS_HELPER_GET_SHADING_RATE_RESOURCE_PARAMS_V1, 1)
#define | NV_VRS_HELPER_GET_SHADING_RATE_RESOURCE_PARAMS_VER NV_VRS_HELPER_GET_SHADING_RATE_RESOURCE_PARAMS_VER1
#define | NV_VRS_HELPER_PURGE_INTERNAL_RESOURCES_PARAMS_VER1 MAKE_NVAPI_VERSION(NV_VRS_HELPER_PURGE_INTERNAL_RESOURCES_PARAMS_V1, 1)
#define | NV_VRS_HELPER_PURGE_INTERNAL_RESOURCES_PARAMS_VER NV_VRS_HELPER_PURGE_INTERNAL_RESOURCES_PARAMS_VER1
#define | ID3DNvVRSHelper_VER1 MAKE_NVAPI_VERSION(ID3DNvVRSHelper_V1, 1)
#define | ID3DNvVRSHelper_VER ID3DNvVRSHelper_VER1
#define | NV_VRS_HELPER_INIT_PARAMS_VER1 MAKE_NVAPI_VERSION(NV_VRS_HELPER_INIT_PARAMS_V1, 1)
#define | NV_VRS_HELPER_INIT_PARAMS_VER NV_VRS_HELPER_INIT_PARAMS_VER1
#define | NV_FOVEATED_RENDERING_GAZE_DATA_PER_EYE_VER1 MAKE_NVAPI_VERSION(NV_FOVEATED_RENDERING_GAZE_DATA_PER_EYE_V1, 1)
#define | NV_FOVEATED_RENDERING_GAZE_DATA_PER_EYE_VER NV_FOVEATED_RENDERING_GAZE_DATA_PER_EYE_VER1
#define | NV_FOVEATED_RENDERING_UPDATE_GAZE_DATA_PARAMS_VER1 MAKE_NVAPI_VERSION(NV_FOVEATED_RENDERING_UPDATE_GAZE_DATA_PARAMS_V1, 1)
#define | NV_FOVEATED_RENDERING_UPDATE_GAZE_DATA_PARAMS_VER NV_FOVEATED_RENDERING_UPDATE_GAZE_DATA_PARAMS_VER1
#define | ID3DNvGazeHandler_VER2 MAKE_NVAPI_VERSION(ID3DNvGazeHandler_V2, 2)
#define | ID3DNvGazeHandler_VER ID3DNvGazeHandler_VER2
#define | ID3DNvGazeHandler_VER1 MAKE_NVAPI_VERSION(ID3DNvGazeHandler_V1, 1)
#define | NV_GAZE_HANDLER_INIT_PARAMS_VER2 MAKE_NVAPI_VERSION(NV_GAZE_HANDLER_INIT_PARAMS_V2, 2)
#define | NV_GAZE_HANDLER_INIT_PARAMS_VER NV_GAZE_HANDLER_INIT_PARAMS_VER2
#define | NV_GAZE_HANDLER_INIT_PARAMS_VER1 MAKE_NVAPI_VERSION(NV_GAZE_HANDLER_INIT_PARAMS_V1, 1)
#define | NV_SMP_ASSIST_FLAGS_DEFAULT 0x00000000
#define | NV_SMP_ASSIST_MAX_VIEWPORTS 16
#define | NV_SMP_ASSIST_MINIMAL_LEVEL_NUM_EYE_INDICES 4
#define | NV_SMP_ASSIST_ENABLE_PARAMS_VER1 MAKE_NVAPI_VERSION(NV_SMP_ASSIST_ENABLE_PARAMS_V1, 1)
#define | NV_SMP_ASSIST_ENABLE_PARAMS_VER NV_SMP_ASSIST_ENABLE_PARAMS_VER1
#define | NV_SMP_ASSIST_DISABLE_PARAMS_VER1 MAKE_NVAPI_VERSION(NV_SMP_ASSIST_DISABLE_PARAMS_V1, 1)
#define | NV_SMP_ASSIST_DISABLE_PARAMS_VER NV_SMP_ASSIST_DISABLE_PARAMS_VER1
#define | NV_SMP_ASSIST_GET_CONSTANTS_VER3 MAKE_NVAPI_VERSION(NV_SMP_ASSIST_GET_CONSTANTS_V3, 3)
#define | NV_SMP_ASSIST_GET_CONSTANTS_VER NV_SMP_ASSIST_GET_CONSTANTS_VER3
#define | NV_SMP_ASSIST_SETUP_PARAMS_VER1 MAKE_NVAPI_VERSION(NV_SMP_ASSIST_SETUP_PARAMS_V1, 1)
#define | NV_SMP_ASSIST_SETUP_PARAMS_VER NV_SMP_ASSIST_SETUP_PARAMS_VER1
#define | NV_SMP_ASSIST_UPDATE_INSTANCEDSTEREO_DATA_PARAMS_VER1 MAKE_NVAPI_VERSION(NV_SMP_ASSIST_UPDATE_INSTANCEDSTEREO_DATA_PARAMS_V1, 1)
#define | NV_SMP_ASSIST_UPDATE_INSTANCEDSTEREO_DATA_PARAMS_VER NV_SMP_ASSIST_UPDATE_INSTANCEDSTEREO_DATA_PARAMS_VER1
#define | ID3DNVSMPASSIST_VER1 MAKE_NVAPI_VERSION(ID3DNvSMPAssist_V1, 1)
#define | ID3DNVSMPASSIST_VER ID3DNVSMPASSIST_VER1
#define | NV_SMP_ASSIST_INITIALIZE_PARAMS_VER1 MAKE_NVAPI_VERSION(NV_SMP_ASSIST_INITIALIZE_PARAMS_V1, 1)
#define | NV_SMP_ASSIST_INITIALIZE_PARAMS_VER NV_SMP_ASSIST_INITIALIZE_PARAMS_VER1
#define | NV_QUERY_SMP_ASSIST_SUPPORT_PARAMS_VER1 MAKE_NVAPI_VERSION(NV_QUERY_SMP_ASSIST_SUPPORT_PARAMS_V1, 1)
#define | NV_QUERY_SMP_ASSIST_SUPPORT_PARAMS_VER NV_QUERY_SMP_ASSIST_SUPPORT_PARAMS_VER1
#define | NV_GET_SLEEP_STATUS_PARAMS_VER1 MAKE_NVAPI_VERSION(NV_GET_SLEEP_STATUS_PARAMS_V1, 1)
#define | NV_GET_SLEEP_STATUS_PARAMS_VER NV_GET_SLEEP_STATUS_PARAMS_VER1
#define | NV_SET_SLEEP_MODE_PARAMS_VER1 MAKE_NVAPI_VERSION(NV_SET_SLEEP_MODE_PARAMS_V1, 1)
#define | NV_SET_SLEEP_MODE_PARAMS_VER NV_SET_SLEEP_MODE_PARAMS_VER1
#define | NV_SET_REFLEX_SYNC_PARAMS_VER1 MAKE_NVAPI_VERSION(NV_SET_REFLEX_SYNC_PARAMS_V1, 1)
#define | NV_SET_REFLEX_SYNC_PARAMS_VER NV_SET_REFLEX_SYNC_PARAMS_VER1
#define | NV_LATENCY_RESULT_PARAMS_VER1 MAKE_NVAPI_VERSION(NV_LATENCY_RESULT_PARAMS_V1, 1)
#define | NV_LATENCY_RESULT_PARAMS_VER NV_LATENCY_RESULT_PARAMS_VER1
#define | NV_LATENCY_MARKER_PARAMS_VER1 MAKE_NVAPI_VERSION(NV_LATENCY_MARKER_PARAMS_V1, 1)
#define | NV_LATENCY_MARKER_PARAMS_VER NV_LATENCY_MARKER_PARAMS_VER1
#define | NV_ASYNC_FRAME_MARKER_PARAMS_VER1 MAKE_NVAPI_VERSION(NV_ASYNC_FRAME_MARKER_PARAMS_V1, 1)
#define | NV_ASYNC_FRAME_MARKER_PARAMS_VER NV_ASYNC_FRAME_MARKER_PARAMS_VER1
#define | NVAPI_GET_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PREBUILD_INFO_PARAMS_VER1 MAKE_NVAPI_VERSION(NVAPI_GET_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PREBUILD_INFO_PARAMS_V1, 1)
#define | NVAPI_GET_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PREBUILD_INFO_PARAMS_VER NVAPI_GET_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PREBUILD_INFO_PARAMS_VER1
#define | NVAPI_GET_RAYTRACING_OPACITY_MICROMAP_ARRAY_PREBUILD_INFO_PARAMS_VER1 MAKE_NVAPI_VERSION(NVAPI_GET_RAYTRACING_OPACITY_MICROMAP_ARRAY_PREBUILD_INFO_PARAMS_V1, 1)
#define | NVAPI_GET_RAYTRACING_OPACITY_MICROMAP_ARRAY_PREBUILD_INFO_PARAMS_VER NVAPI_GET_RAYTRACING_OPACITY_MICROMAP_ARRAY_PREBUILD_INFO_PARAMS_VER1
#define | NVAPI_D3D12_SET_CREATE_PIPELINE_STATE_OPTIONS_PARAMS_VER1 MAKE_NVAPI_VERSION(NVAPI_D3D12_SET_CREATE_PIPELINE_STATE_OPTIONS_PARAMS_V1, 1)
#define | NVAPI_D3D12_SET_CREATE_PIPELINE_STATE_OPTIONS_PARAMS_VER NVAPI_D3D12_SET_CREATE_PIPELINE_STATE_OPTIONS_PARAMS_VER1
#define | NVAPI_CHECK_DRIVER_MATCHING_IDENTIFIER_EX_PARAMS_VER1 MAKE_NVAPI_VERSION(NVAPI_CHECK_DRIVER_MATCHING_IDENTIFIER_EX_PARAMS_V1, 1)
#define | NVAPI_CHECK_DRIVER_MATCHING_IDENTIFIER_EX_PARAMS_VER NVAPI_CHECK_DRIVER_MATCHING_IDENTIFIER_EX_PARAMS_VER1
#define | NVAPI_GET_RAYTRACING_ACCELERATION_STRUCTURE_PREBUILD_INFO_EX_PARAMS_VER1 MAKE_NVAPI_VERSION(NVAPI_GET_RAYTRACING_ACCELERATION_STRUCTURE_PREBUILD_INFO_EX_PARAMS_V1, 1)
#define | NVAPI_GET_RAYTRACING_ACCELERATION_STRUCTURE_PREBUILD_INFO_EX_PARAMS_VER NVAPI_GET_RAYTRACING_ACCELERATION_STRUCTURE_PREBUILD_INFO_EX_PARAMS_VER1
#define | NVAPI_BUILD_RAYTRACING_OPACITY_MICROMAP_ARRAY_PARAMS_VER1 MAKE_NVAPI_VERSION(NVAPI_BUILD_RAYTRACING_OPACITY_MICROMAP_ARRAY_PARAMS_V1, 1)
#define | NVAPI_BUILD_RAYTRACING_OPACITY_MICROMAP_ARRAY_PARAMS_VER NVAPI_BUILD_RAYTRACING_OPACITY_MICROMAP_ARRAY_PARAMS_VER1
#define | NVAPI_RELOCATE_RAYTRACING_OPACITY_MICROMAP_ARRAY_PARAMS_VER1 MAKE_NVAPI_VERSION(NVAPI_RELOCATE_RAYTRACING_OPACITY_MICROMAP_ARRAY_PARAMS_V1, 1)
#define | NVAPI_RELOCATE_RAYTRACING_OPACITY_MICROMAP_ARRAY_PARAMS_VER NVAPI_RELOCATE_RAYTRACING_OPACITY_MICROMAP_ARRAY_PARAMS_VER1
#define | NVAPI_BUILD_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PARAMS_VER1 MAKE_NVAPI_VERSION(NVAPI_BUILD_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PARAMS_V1, 1)
#define | NVAPI_BUILD_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PARAMS_VER NVAPI_BUILD_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PARAMS_VER1
#define | NVAPI_RELOCATE_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PARAMS_VER1 MAKE_NVAPI_VERSION(NVAPI_RELOCATE_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PARAMS_V1, 1)
#define | NVAPI_RELOCATE_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PARAMS_VER NVAPI_RELOCATE_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PARAMS_VER1
#define | NVAPI_EMIT_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_POSTBUILD_INFO_PARAMS_VER1 MAKE_NVAPI_VERSION(NVAPI_EMIT_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_POSTBUILD_INFO_PARAMS_V1, 1)
#define | NVAPI_EMIT_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_POSTBUILD_INFO_PARAMS_VER NVAPI_EMIT_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_POSTBUILD_INFO_PARAMS_VER1
#define | NVAPI_EMIT_RAYTRACING_OPACITY_MICROMAP_ARRAY_POSTBUILD_INFO_PARAMS_VER1 MAKE_NVAPI_VERSION(NVAPI_EMIT_RAYTRACING_OPACITY_MICROMAP_ARRAY_POSTBUILD_INFO_PARAMS_V1, 1)
#define | NVAPI_EMIT_RAYTRACING_OPACITY_MICROMAP_ARRAY_POSTBUILD_INFO_PARAMS_VER NVAPI_EMIT_RAYTRACING_OPACITY_MICROMAP_ARRAY_POSTBUILD_INFO_PARAMS_VER1
#define | NVAPI_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_EX_PARAMS_VER1 MAKE_NVAPI_VERSION(NVAPI_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_EX_PARAMS_V1, 1)
#define | NVAPI_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_EX_PARAMS_VER NVAPI_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_EX_PARAMS_VER1
#define | NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_ARRAY_BYTE_ALIGNMENT 256
#define | NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_OC1_MAX_SUBDIVISION_LEVEL 12
#define | NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_BYTE_ALIGNMENT 256
#define | NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_DC1_MAX_SUBDIVISION_LEVEL 5
#define | NVAPI_D3D12_WORKSTATION_FEATURE_PROPERTIES_PARAMS_VER1 MAKE_NVAPI_VERSION(NVAPI_D3D12_WORKSTATION_FEATURE_PROPERTIES_PARAMS_V1,1)
#define | NVAPI_D3D12_WORKSTATION_FEATURE_PROPERTIES_PARAMS_VER NVAPI_D3D12_WORKSTATION_FEATURE_PROPERTIES_PARAMS_VER1
#define | NVAPI_D3D12_WORKSTATION_FEATURE_PROPERTIES_PARAMS NVAPI_D3D12_WORKSTATION_FEATURE_PROPERTIES_PARAMS_V1
#define | NVVIOOWNERID_NONE 0
#define | NVVIO_O_READ 0x00000000
#define | NVVIO_O_WRITE_EXCLUSIVE 0x00010001
#define | NVVIO_VALID_ACCESSRIGHTS
#define | NVVIO_OWNERID_INITIALIZED 0x80000000
#define | NVVIO_OWNERID_EXCLUSIVE 0x40000000
#define | NVVIO_OWNERID_TYPEMASK 0x0FFFFFFF
#define | NVAPI_MAX_VIO_DEVICES 8
#define | NVAPI_MAX_VIO_JACKS 4
#define | NVAPI_MAX_VIO_CHANNELS_PER_JACK 2
#define | NVAPI_MAX_VIO_STREAMS 4
#define | NVAPI_MIN_VIO_STREAMS 1
#define | NVAPI_MAX_VIO_LINKS_PER_STREAM 2
#define | NVAPI_MAX_FRAMELOCK_MAPPING_MODES 20
#define | NVAPI_GVI_MIN_RAW_CAPTURE_IMAGES 1
#define | NVAPI_GVI_MAX_RAW_CAPTURE_IMAGES 32
#define | NVAPI_GVI_DEFAULT_RAW_CAPTURE_IMAGES 5
#define | NVVIOCAPS_VIDOUT_SDI 0x00000001
#define | NVVIOCAPS_SYNC_INTERNAL 0x00000100
#define | NVVIOCAPS_SYNC_GENLOCK 0x00000200
#define | NVVIOCAPS_SYNCSRC_SDI 0x00001000
#define | NVVIOCAPS_SYNCSRC_COMP 0x00002000
#define | NVVIOCAPS_OUTPUTMODE_DESKTOP 0x00010000
#define | NVVIOCAPS_OUTPUTMODE_OPENGL 0x00020000
#define | NVVIOCAPS_VIDIN_SDI 0x00100000
#define | NVVIOCAPS_PACKED_ANC_SUPPORTED 0x00200000
#define | NVVIOCAPS_AUDIO_BLANKING_SUPPORTED 0x00400000
#define | NVVIOCLASS_SDI 0x00000001
#define | NVVIOCAPS_VER1 MAKE_NVAPI_VERSION(NVVIOCAPS,1)
#define | NVVIOCAPS_VER2 MAKE_NVAPI_VERSION(NVVIOCAPS,2)
#define | NVVIOCAPS_VER NVVIOCAPS_VER2
#define | NVVIOSTATUS_VER MAKE_NVAPI_VERSION(NVVIOSTATUS,1)
#define | NVVIOSYNCDELAY_VER MAKE_NVAPI_VERSION(NVVIOSYNCDELAY,1)
#define | NVVIOBUFFERFORMAT_R8G8B8 0x00000001
#define | NVVIOBUFFERFORMAT_R8G8B8Z24 0x00000002
#define | NVVIOBUFFERFORMAT_R8G8B8A8 0x00000004
#define | NVVIOBUFFERFORMAT_R8G8B8A8Z24 0x00000008
#define | NVVIOBUFFERFORMAT_R16FPG16FPB16FP 0x00000010
#define | NVVIOBUFFERFORMAT_R16FPG16FPB16FPZ24 0x00000020
#define | NVVIOBUFFERFORMAT_R16FPG16FPB16FPA16FP 0x00000040
#define | NVVIOBUFFERFORMAT_R16FPG16FPB16FPA16FPZ24 0x00000080
#define | NVVIOCOLORCONVERSION_VER MAKE_NVAPI_VERSION(NVVIOCOLORCONVERSION,1)
#define | NVVIOGAMMACORRECTION_VER MAKE_NVAPI_VERSION(NVVIOGAMMACORRECTION,1)
#define | MAX_NUM_COMPOSITE_RANGE 2
#define | NVVIOCONFIG_SIGNALFORMAT 0x00000001
#define | NVVIOCONFIG_DATAFORMAT 0x00000002
#define | NVVIOCONFIG_OUTPUTREGION 0x00000004
#define | NVVIOCONFIG_OUTPUTAREA 0x00000008
#define | NVVIOCONFIG_COLORCONVERSION 0x00000010
#define | NVVIOCONFIG_GAMMACORRECTION 0x00000020
#define | NVVIOCONFIG_SYNCSOURCEENABLE 0x00000040
#define | NVVIOCONFIG_SYNCDELAY 0x00000080
#define | NVVIOCONFIG_COMPOSITESYNCTYPE 0x00000100
#define | NVVIOCONFIG_FRAMELOCKENABLE 0x00000200
#define | NVVIOCONFIG_422FILTER 0x00000400
#define | NVVIOCONFIG_COMPOSITETERMINATE 0x00000800
#define | NVVIOCONFIG_DATAINTEGRITYCHECK 0x00001000
#define | NVVIOCONFIG_CSCOVERRIDE 0x00002000
#define | NVVIOCONFIG_FLIPQUEUELENGTH 0x00004000
#define | NVVIOCONFIG_ANCTIMECODEGENERATION 0x00008000
#define | NVVIOCONFIG_COMPOSITE 0x00010000
#define | NVVIOCONFIG_ALPHAKEYCOMPOSITE 0x00020000
#define | NVVIOCONFIG_COMPOSITE_Y 0x00040000
#define | NVVIOCONFIG_COMPOSITE_CR 0x00080000
#define | NVVIOCONFIG_COMPOSITE_CB 0x00100000
#define | NVVIOCONFIG_FULL_COLOR_RANGE 0x00200000
#define | NVVIOCONFIG_RGB_DATA 0x00400000
#define | NVVIOCONFIG_RESERVED_SDIOUTPUTENABLE 0x00800000
#define | NVVIOCONFIG_STREAMS 0x01000000
#define | NVVIOCONFIG_ANC_PARITY_COMPUTATION 0x02000000
#define | NVVIOCONFIG_ANC_AUDIO_REPEAT 0x04000000
#define | NVVIOCONFIG_ALLFIELDS
#define | NVVIOCONFIG_VALIDFIELDS
#define | NVVIOCONFIG_DRIVERFIELDS
#define | NVVIOCONFIG_GAMMAFIELDS ( NVVIOCONFIG_GAMMACORRECTION )
#define | NVVIOCONFIG_RMCTRLFIELDS
#define | NVVIOCONFIG_RMSKEWFIELDS ( NVVIOCONFIG_SYNCDELAY )
#define | NVVIOCONFIG_ALLOWSDIRUNNING_FIELDS
#define | NVVIOCONFIG_RMMODESET_FIELDS
#define | NVVIOCONFIG_VER1 MAKE_NVAPI_VERSION(NVVIOCONFIG_V1,1)
#define | NVVIOCONFIG_VER2 MAKE_NVAPI_VERSION(NVVIOCONFIG_V2,2)
#define | NVVIOCONFIG_VER3 MAKE_NVAPI_VERSION(NVVIOCONFIG_V3,3)
#define | NVVIOCONFIG_VER NVVIOCONFIG_VER3
#define | NV_VIO_TOPOLOGY_VER MAKE_NVAPI_VERSION(NV_VIO_TOPOLOGY,1)
#define | NVVIOTOPOLOGY_VER MAKE_NVAPI_VERSION(NVVIOTOPOLOGY,1)
#define | NVVIOPCIINFO_VER1 MAKE_NVAPI_VERSION(NVVIOPCIINFO_V1,1)
#define | NVVIOPCIINFO_VER NVVIOPCIINFO_VER1
#define | NVAPI_STEREO_CAPS_VER1 MAKE_NVAPI_VERSION(NVAPI_STEREO_CAPS,1)
#define | NVAPI_STEREO_CAPS_VER NVAPI_STEREO_CAPS_VER1
#define | NVAPI_STEREO_QUADBUFFERED_API_VERSION 0x2
#define | NVAPI_DRS_GLOBAL_PROFILE ((NvDRSProfileHandle) -1)
#define | NVAPI_SETTING_MAX_VALUES 100
#define | NVDRS_SETTING_VALUES_VER MAKE_NVAPI_VERSION(NVDRS_SETTING_VALUES,1)
#define | NVDRS_SETTING_VER1 MAKE_NVAPI_VERSION(NVDRS_SETTING_V1, 1)
#define | NVDRS_SETTING_VER NVDRS_SETTING_VER1
#define | NVDRS_APPLICATION_VER_V1 MAKE_NVAPI_VERSION(NVDRS_APPLICATION_V1,1)
#define | NVDRS_APPLICATION_VER_V2 MAKE_NVAPI_VERSION(NVDRS_APPLICATION_V2,2)
#define | NVDRS_APPLICATION_VER_V3 MAKE_NVAPI_VERSION(NVDRS_APPLICATION_V3,3)
#define | NVDRS_APPLICATION_VER_V4 MAKE_NVAPI_VERSION(NVDRS_APPLICATION_V4,4)
#define | NVDRS_APPLICATION_VER NVDRS_APPLICATION_VER_V4
#define | NVDRS_PROFILE_VER1 MAKE_NVAPI_VERSION(NVDRS_PROFILE_V1,1)
#define | NVDRS_PROFILE_VER NVDRS_PROFILE_VER1
#define | NV_CHIPSET_INFO_VER_1 MAKE_NVAPI_VERSION(NV_CHIPSET_INFO_v1,1)
#define | NV_CHIPSET_INFO_VER_2 MAKE_NVAPI_VERSION(NV_CHIPSET_INFO_v2,2)
#define | NV_CHIPSET_INFO_VER_3 MAKE_NVAPI_VERSION(NV_CHIPSET_INFO_v3,3)
#define | NV_CHIPSET_INFO_VER_4 MAKE_NVAPI_VERSION(NV_CHIPSET_INFO_v4,4)
#define | NV_CHIPSET_INFO NV_CHIPSET_INFO_v4
#define | NV_CHIPSET_INFO_VER NV_CHIPSET_INFO_VER_4
#define | NV_LID_DOCK_PARAMS_VER MAKE_NVAPI_VERSION(NV_LID_DOCK_PARAMS,1)
#define | NV_DISPLAY_DRIVER_INFO_VER1 MAKE_NVAPI_VERSION(NV_DISPLAY_DRIVER_INFO_V1, 1)
#define | NV_DISPLAY_DRIVER_INFO_VER2 MAKE_NVAPI_VERSION(NV_DISPLAY_DRIVER_INFO_V2, 2)
#define | NV_DISPLAY_DRIVER_INFO_VER NV_DISPLAY_DRIVER_INFO_VER2
#define | NV_PHYSICAL_GPUS_VER1 MAKE_NVAPI_VERSION(NV_PHYSICAL_GPUS_V1, 1)
#define | NV_PHYSICAL_GPUS_VER NV_PHYSICAL_GPUS_VER1
#define | NV_LOGICAL_GPUS_VER1 MAKE_NVAPI_VERSION(NV_LOGICAL_GPUS_V1, 1)
#define | NV_LOGICAL_GPUS_VER NV_LOGICAL_GPUS_VER1
#define | NV_GPU_CLIENT_UTIL_DOMAINS_MAX_V1 (4)
#define | NV_GPU_CLIENT_UTILIZATION_PERIODIC_CALLBACK_SETTINGS_VER1 MAKE_NVAPI_VERSION(NV_GPU_CLIENT_UTILIZATION_PERIODIC_CALLBACK_SETTINGS_V1, 1)
#define | NV_GPU_CLIENT_UTILIZATION_PERIODIC_CALLBACK_SETTINGS_VER NV_GPU_CLIENT_UTILIZATION_PERIODIC_CALLBACK_SETTINGS_VER1
#define | NVAPI_MAX_GPU_CLOCKS 32
#define | NVAPI_MAX_GPU_PUBLIC_CLOCKS 32
#define | NVAPI_MAX_GPU_PERF_CLOCKS 32
#define | NVAPI_MAX_GPU_PERF_VOLTAGES 16
#define | NVAPI_MAX_GPU_PERF_PSTATES 16
NvAPI_OGL_ExpertModeSet[Get] Functions
#define | NVAPI_OGLEXPERT_DETAIL_NONE 0x00000000
#define | NVAPI_OGLEXPERT_DETAIL_ERROR 0x00000001
#define | NVAPI_OGLEXPERT_DETAIL_SWFALLBACK 0x00000002
#define | NVAPI_OGLEXPERT_DETAIL_BASIC_INFO 0x00000004
#define | NVAPI_OGLEXPERT_DETAIL_DETAILED_INFO 0x00000008
#define | NVAPI_OGLEXPERT_DETAIL_PERFORMANCE_WARNING 0x00000010
#define | NVAPI_OGLEXPERT_DETAIL_QUALITY_WARNING 0x00000020
#define | NVAPI_OGLEXPERT_DETAIL_USAGE_WARNING 0x00000040
#define | NVAPI_OGLEXPERT_DETAIL_ALL 0xFFFFFFFF
#define | NVAPI_OGLEXPERT_REPORT_NONE 0x00000000
#define | NVAPI_OGLEXPERT_REPORT_ERROR 0x00000001
#define | NVAPI_OGLEXPERT_REPORT_SWFALLBACK 0x00000002
#define | NVAPI_OGLEXPERT_REPORT_PIPELINE_VERTEX 0x00000004
#define | NVAPI_OGLEXPERT_REPORT_PIPELINE_GEOMETRY 0x00000008
#define | NVAPI_OGLEXPERT_REPORT_PIPELINE_XFB 0x00000010
#define | NVAPI_OGLEXPERT_REPORT_PIPELINE_RASTER 0x00000020
#define | NVAPI_OGLEXPERT_REPORT_PIPELINE_FRAGMENT 0x00000040
#define | NVAPI_OGLEXPERT_REPORT_PIPELINE_ROP 0x00000080
#define | NVAPI_OGLEXPERT_REPORT_PIPELINE_FRAMEBUFFER 0x00000100
#define | NVAPI_OGLEXPERT_REPORT_PIPELINE_PIXEL 0x00000200
#define | NVAPI_OGLEXPERT_REPORT_PIPELINE_TEXTURE 0x00000400
#define | NVAPI_OGLEXPERT_REPORT_OBJECT_BUFFEROBJECT 0x00000800
#define | NVAPI_OGLEXPERT_REPORT_OBJECT_TEXTURE 0x00001000
#define | NVAPI_OGLEXPERT_REPORT_OBJECT_PROGRAM 0x00002000
#define | NVAPI_OGLEXPERT_REPORT_OBJECT_FBO 0x00004000
#define | NVAPI_OGLEXPERT_REPORT_FEATURE_SLI 0x00008000
#define | NVAPI_OGLEXPERT_REPORT_ALL 0xFFFFFFFF
#define | NVAPI_OGLEXPERT_OUTPUT_TO_NONE 0x00000000
#define | NVAPI_OGLEXPERT_OUTPUT_TO_CONSOLE 0x00000001
#define | NVAPI_OGLEXPERT_OUTPUT_TO_DEBUGGER 0x00000004
#define | NVAPI_OGLEXPERT_OUTPUT_TO_CALLBACK 0x00000008
#define | NVAPI_OGLEXPERT_OUTPUT_TO_ALL 0xFFFFFFFF
#define | NV_COMPUTE_GPU_TOPOLOGY_PHYSICS_CAPABLE NV_BIT(0)
#define | NV_COMPUTE_GPU_TOPOLOGY_PHYSICS_ENABLE NV_BIT(1)
#define | NV_COMPUTE_GPU_TOPOLOGY_PHYSICS_DEDICATED NV_BIT(2)
#define | NV_COMPUTE_GPU_TOPOLOGY_PHYSICS_RECOMMENDED NV_BIT(3)
#define | NV_COMPUTE_GPU_TOPOLOGY_CUDA_AVAILABLE NV_BIT(4)
#define | NV_COMPUTE_GPU_TOPOLOGY_CUDA_CAPABLE NV_BIT(16)
#define | NV_COMPUTE_GPU_TOPOLOGY_CUDA_DISABLED NV_BIT(17)
#define | NV_COMPUTE_GPU_TOPOLOGY_PHYSICS_AVAILABLE NV_BIT(21)
#define | NV_GPU_PERF_PSTATES_INFO_VER1 MAKE_NVAPI_VERSION(NV_GPU_PERF_PSTATES_INFO_V1,1)
#define | NV_GPU_PERF_PSTATES_INFO_VER2 MAKE_NVAPI_VERSION(NV_GPU_PERF_PSTATES_INFO_V2,2)
#define | NV_GPU_PERF_PSTATES_INFO_VER3 MAKE_NVAPI_VERSION(NV_GPU_PERF_PSTATES_INFO_V2,3)
#define | NV_GPU_PERF_PSTATES_INFO_VER NV_GPU_PERF_PSTATES_INFO_VER3
#define | NV_GPU_THERMAL_SETTINGS_VER_1 MAKE_NVAPI_VERSION(NV_GPU_THERMAL_SETTINGS_V1,1)
#define | NV_GPU_THERMAL_SETTINGS_VER_2 MAKE_NVAPI_VERSION(NV_GPU_THERMAL_SETTINGS_V2,2)
#define | NV_GPU_THERMAL_SETTINGS_VER NV_GPU_THERMAL_SETTINGS_VER_2

Typedefs

typedef enum _NV_DP_LINK_RATE | NV_DP_LINK_RATE
typedef enum _NV_DP_LANE_COUNT | NV_DP_LANE_COUNT
typedef enum _NV_DP_COLOR_FORMAT | NV_DP_COLOR_FORMAT
typedef enum _NV_DP_COLORIMETRY | NV_DP_COLORIMETRY
typedef enum _NV_DP_DYNAMIC_RANGE | NV_DP_DYNAMIC_RANGE
typedef enum _NV_DP_BPC | NV_DP_BPC
typedef enum _NV_GPU_CONNECTOR_TYPE | NV_GPU_CONNECTOR_TYPE
typedef enum _NV_DISPLAY_TV_FORMAT | NV_DISPLAY_TV_FORMAT
typedef enum _NV_SCALING | NV_SCALING
typedef enum _NV_ROTATE | NV_ROTATE
typedef enum _NV_FORMAT | NV_FORMAT
typedef enum _NV_TIMING_OVERRIDE | NV_TIMING_OVERRIDE
typedef struct tagNV_TIMINGEXT | NV_TIMINGEXT
typedef struct _NV_TIMING | NV_TIMING
typedef struct _NV_POSITION | NV_POSITION
typedef struct _NV_RESOLUTION | NV_RESOLUTION
typedef struct _NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_V1 | NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_V1
typedef NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_V1 | NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO
typedef struct _NV_DISPLAYCONFIG_PATH_TARGET_INFO_V1 | NV_DISPLAYCONFIG_PATH_TARGET_INFO_V1
typedef struct _NV_DISPLAYCONFIG_PATH_TARGET_INFO_V2 | NV_DISPLAYCONFIG_PATH_TARGET_INFO_V2
typedef NV_DISPLAYCONFIG_PATH_TARGET_INFO_V2 | NV_DISPLAYCONFIG_PATH_TARGET_INFO
typedef enum _NV_DISPLAYCONFIG_SPANNING_ORIENTATION | NV_DISPLAYCONFIG_SPANNING_ORIENTATION
typedef struct _NV_DISPLAYCONFIG_SOURCE_MODE_INFO_V1 | NV_DISPLAYCONFIG_SOURCE_MODE_INFO_V1
typedef struct _NV_DISPLAYCONFIG_PATH_INFO_V1 | NV_DISPLAYCONFIG_PATH_INFO_V1
typedef struct _NV_DISPLAYCONFIG_PATH_INFO_V2 | NV_DISPLAYCONFIG_PATH_INFO_V2
typedef NV_DISPLAYCONFIG_PATH_INFO_V2 | NV_DISPLAYCONFIG_PATH_INFO
typedef NV_DISPLAYCONFIG_SOURCE_MODE_INFO_V1 | NV_DISPLAYCONFIG_SOURCE_MODE_INFO
typedef enum _NV_DISPLAYCONFIG_FLAGS | NV_DISPLAYCONFIG_FLAGS
typedef NvU16 | NvAPI_UnicodeString[NVAPI_UNICODE_STRING_MAX]
typedef const NvU16 * | NvAPI_LPCWSTR
typedef enum _NV_GPU_PERF_VOLTAGE_INFO_DOMAIN_ID | NV_GPU_PERF_VOLTAGE_INFO_DOMAIN_ID
typedef enum _NV_GPU_PUBLIC_CLOCK_ID | NV_GPU_PUBLIC_CLOCK_ID
typedef enum _NV_GPU_PERF_PSTATE_ID | NV_GPU_PERF_PSTATE_ID
typedef struct _NV_GPU_PERF_PSTATES20_INFO_V2 | NV_GPU_PERF_PSTATES20_INFO_V2
typedef NV_GPU_PERF_PSTATES20_INFO_V2 | NV_GPU_PERF_PSTATES20_INFO
typedef void(* | NVAPI_OGLEXPERT_CALLBACK) (unsigned int categoryId, unsigned int messageId, unsigned int detailLevel, int objectId, const char *messageStr)
typedef struct _NV_GPU_DISPLAYIDS | NV_GPU_DISPLAYIDS
typedef enum _NV_GPU_OUTPUT_TYPE | NV_GPU_OUTPUT_TYPE
typedef enum _NV_GPU_TYPE | NV_GPU_TYPE
typedef enum _NV_GPU_BUS_TYPE | NV_GPU_BUS_TYPE
typedef struct _NV_BOARD_INFO | NV_BOARD_INFO_V1
typedef NV_BOARD_INFO_V1 | NV_BOARD_INFO
typedef enum _NV_GPU_ARCHITECTURE_ID | NV_GPU_ARCHITECTURE_ID
typedef enum _NV_GPU_ARCH_IMPLEMENTATION_ID | NV_GPU_ARCH_IMPLEMENTATION_ID
typedef enum _NV_GPU_CHIP_REVISION | NV_GPU_CHIP_REVISION
typedef NV_GPU_ARCH_INFO_V2 | NV_GPU_ARCH_INFO
typedef enum _NV_GPU_HDCP_FUSE_STATE | NV_GPU_HDCP_FUSE_STATE
typedef enum _NV_GPU_HDCP_KEY_SOURCE | NV_GPU_HDCP_KEY_SOURCE
typedef enum _NV_GPU_HDCP_KEY_SOURCE_STATE | NV_GPU_HDCP_KEY_SOURCE_STATE
typedef struct _NV_COMPUTE_GPU | NV_COMPUTE_GPU
typedef struct _NV_COMPUTE_GPU_TOPOLOGY_V2 | NV_COMPUTE_GPU_TOPOLOGY_V2
typedef NV_COMPUTE_GPU_TOPOLOGY_V2 | NV_COMPUTE_GPU_TOPOLOGY
typedef enum _NV_ECC_CONFIGURATION | NV_ECC_CONFIGURATION
typedef void(__cdecl * | NVAPI_CALLBACK_QSYNCEVENT) (NV_QSYNC_EVENT_DATA qyncEventData, void *callbackParam)
typedef struct NV_EVENT_REGISTER_CALLBACK * | PNV_EVENT_REGISTER_CALLBACK
typedef enum _NV_GPU_WORKSTATION_FEATURE_TYPE | NV_GPU_WORKSTATION_FEATURE_TYPE
typedef NV_SCANOUT_INTENSITY_DATA_V2 | NV_SCANOUT_INTENSITY_DATA
typedef struct _NV_SCANOUT_INTENSITY_STATE_DATA | NV_SCANOUT_INTENSITY_STATE_DATA
typedef struct _NV_SCANOUT_WARPING_STATE_DATA | NV_SCANOUT_WARPING_STATE_DATA
typedef struct _NV_SCANOUT_INFORMATION | NV_SCANOUT_INFORMATION
typedef enum _NV_VIRTUALIZATION_MODE | NV_VIRTUALIZATION_MODE
typedef struct _NV_GPU_VIRTUALIZATION_INFO | NV_GPU_VIRTUALIZATION_INFO_V1
typedef NV_GPU_VIRTUALIZATION_INFO_V1 | NV_GPU_VIRTUALIZATION_INFO
typedef struct _NV_LOGICAL_GPU_DATA_V1 | NV_LOGICAL_GPU_DATA_V1
typedef NV_LOGICAL_GPU_DATA_V1 | NV_LOGICAL_GPU_DATA
typedef struct _NV_GPU_INFO_V1 | NV_GPU_INFO_V1
typedef struct _NV_GPU_INFO_V2 | NV_GPU_INFO_V2
typedef NV_GPU_INFO_V2 | NV_GPU_INFO
typedef struct _NV_GPU_VR_READY_V1 | NV_GPU_VR_READY_V1
typedef NV_GPU_VR_READY_V1 | NV_GPU_VR_READY
typedef enum _NV_ADAPTER_TYPE | NV_ADAPTER_TYPE
typedef struct _NV_GPU_GSP_INFO_V1 | NV_GPU_GSP_INFO_V1
typedef NV_GPU_GSP_INFO_V1 | NV_GPU_GSP_INFO
typedef enum _NVAPI_GPU_PERF_DECREASE | NVAPI_GPU_PERF_DECREASE
typedef NV_GPU_PERF_PSTATES_INFO_V2 | NV_GPU_PERF_PSTATES_INFO
typedef NV_GPU_THERMAL_SETTINGS_V2 | NV_GPU_THERMAL_SETTINGS
typedef NV_GPU_CLOCK_FREQUENCIES_V2 | NV_GPU_CLOCK_FREQUENCIES
typedef enum _NV_GPU_ILLUMINATION_ATTRIB | NV_GPU_ILLUMINATION_ATTRIB
typedef struct _NV_GPU_QUERY_ILLUMINATION_SUPPORT_PARM_V1 | NV_GPU_QUERY_ILLUMINATION_SUPPORT_PARM_V1
typedef NV_GPU_QUERY_ILLUMINATION_SUPPORT_PARM_V1 | NV_GPU_QUERY_ILLUMINATION_SUPPORT_PARM
typedef struct _NV_GPU_GET_ILLUMINATION_PARM_V1 | NV_GPU_GET_ILLUMINATION_PARM_V1
typedef NV_GPU_GET_ILLUMINATION_PARM_V1 | NV_GPU_GET_ILLUMINATION_PARM
typedef struct _NV_GPU_SET_ILLUMINATION_PARM_V1 | NV_GPU_SET_ILLUMINATION_PARM_V1
typedef NV_GPU_SET_ILLUMINATION_PARM_V1 | NV_GPU_SET_ILLUMINATION_PARM
typedef struct _NV_GPU_CLIENT_ILLUM_DEVICE_INFO_DATA_MCUV10 | NV_GPU_CLIENT_ILLUM_DEVICE_INFO_DATA_MCUV10
typedef struct _NV_GPU_CLIENT_ILLUM_DEVICE_INFO_DATA_GPIO_PWM_RGBW | NV_GPU_CLIENT_ILLUM_DEVICE_INFO_DATA_GPIO_PWM_RGBW
typedef struct _NV_GPU_CLIENT_ILLUM_DEVICE_INFO_DATA_GPIO_PWM_SINGLE_COLOR | NV_GPU_CLIENT_ILLUM_DEVICE_INFO_DATA_GPIO_PWM_SINGLE_COLOR
typedef struct _NV_GPU_CLIENT_ILLUM_DEVICE_INFO_V1 | NV_GPU_CLIENT_ILLUM_DEVICE_INFO_V1
typedef struct _NV_GPU_CLIENT_ILLUM_DEVICE_INFO_PARAMS_V1 | NV_GPU_CLIENT_ILLUM_DEVICE_INFO_PARAMS_V1
typedef NV_GPU_CLIENT_ILLUM_DEVICE_INFO_PARAMS_V1 | NV_GPU_CLIENT_ILLUM_DEVICE_INFO_PARAMS
typedef NV_GPU_CLIENT_ILLUM_DEVICE_CONTROL_V1 | NV_GPU_CLIENT_ILLUM_DEVICE_CONTROL
typedef NV_GPU_CLIENT_ILLUM_DEVICE_CONTROL_PARAMS_V1 | NV_GPU_CLIENT_ILLUM_DEVICE_CONTROL_PARAMS
typedef struct _NV_GPU_CLIENT_ILLUM_ZONE_INFO_DATA_RGB | NV_GPU_CLIENT_ILLUM_ZONE_INFO_DATA_RGB
typedef struct _NV_GPU_CLIENT_ILLUM_ZONE_INFO_DATA_RGBW | NV_GPU_CLIENT_ILLUM_ZONE_INFO_DATA_RGBW
typedef struct _NV_GPU_CLIENT_ILLUM_ZONE_INFO_DATA_SINGLE_COLOR | NV_GPU_CLIENT_ILLUM_ZONE_INFO_DATA_SINGLE_COLOR
typedef struct _NV_GPU_CLIENT_ILLUM_ZONE_INFO_V1 | NV_GPU_CLIENT_ILLUM_ZONE_INFO_V1
typedef struct _NV_GPU_CLIENT_ILLUM_ZONE_INFO_PARAMS_V1 | NV_GPU_CLIENT_ILLUM_ZONE_INFO_PARAMS_V1
typedef NV_GPU_CLIENT_ILLUM_ZONE_INFO_PARAMS_V1 | NV_GPU_CLIENT_ILLUM_ZONE_INFO_PARAMS
typedef struct _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_RGB_PARAMS | NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_RGB_PARAMS
typedef struct _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_RGB | NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_RGB
typedef struct _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR | NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR
typedef struct _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR_RGB | NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR_RGB
typedef struct _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_RGB | NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_RGB
typedef struct _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_COLOR_FIXED_PARAMS | NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_COLOR_FIXED_PARAMS
typedef struct _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_COLOR_FIXED | NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_COLOR_FIXED
typedef struct _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR_COLOR_FIXED | NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR_COLOR_FIXED
typedef struct _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_COLOR_FIXED | NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_COLOR_FIXED
typedef struct _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_RGBW_PARAMS | NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_RGBW_PARAMS
typedef struct _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_RGBW | NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_RGBW
typedef struct _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR_RGBW | NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR_RGBW
typedef struct _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_RGBW | NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_RGBW
typedef struct _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_SINGLE_COLOR_PARAMS | NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_SINGLE_COLOR_PARAMS
typedef struct _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_SINGLE_COLOR | NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_SINGLE_COLOR
typedef struct _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR_SINGLE_COLOR | NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR_SINGLE_COLOR
typedef struct _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_SINGLE_COLOR | NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_SINGLE_COLOR
typedef struct _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_V1 | NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_V1
typedef struct _NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_PARAMS_V1 | NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_PARAMS_V1
typedef NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_PARAMS_V1 | NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_PARAMS
typedef struct _NV_DISPLAY_PORT_INFO_V1 | NV_DISPLAY_PORT_INFO_V1
typedef NV_DISPLAY_PORT_INFO_V1 | NV_DISPLAY_PORT_INFO
typedef struct _NV_HDMI_SUPPORT_INFO_V1 | NV_HDMI_SUPPORT_INFO_V1
typedef struct _NV_HDMI_SUPPORT_INFO_V2 | NV_HDMI_SUPPORT_INFO_V2
typedef NV_HDMI_SUPPORT_INFO_V2 | NV_HDMI_SUPPORT_INFO
typedef struct _NV_HDR_CAPABILITIES_V1 | NV_HDR_CAPABILITIES_V1
typedef struct _NV_HDR_CAPABILITIES_V2 | NV_HDR_CAPABILITIES_V2
typedef struct _NV_HDR_CAPABILITIES_V3 | NV_HDR_CAPABILITIES_V3
typedef NV_HDR_CAPABILITIES_V3 | NV_HDR_CAPABILITIES
typedef struct _NV_HDR_COLOR_DATA_V1 | NV_HDR_COLOR_DATA_V1
typedef struct _NV_HDR_COLOR_DATA_V2 | NV_HDR_COLOR_DATA_V2
typedef NV_HDR_COLOR_DATA_V2 | NV_HDR_COLOR_DATA
typedef struct _NV_TIMING_INPUT | NV_TIMING_INPUT
typedef struct _NV_MONITOR_COLOR_DATA | NV_MONITOR_COLOR_CAPS_V1
typedef NV_MONITOR_COLOR_CAPS_V1 | NV_MONITOR_COLOR_CAPS
typedef struct _NV_GET_ADAPTIVE_SYNC_DATA_V1 | NV_GET_ADAPTIVE_SYNC_DATA_V1
typedef NV_GET_ADAPTIVE_SYNC_DATA_V1 | NV_GET_ADAPTIVE_SYNC_DATA
typedef struct _NV_SET_ADAPTIVE_SYNC_DATA_V1 | NV_SET_ADAPTIVE_SYNC_DATA_V1
typedef NV_SET_ADAPTIVE_SYNC_DATA_V1 | NV_SET_ADAPTIVE_SYNC_DATA
typedef struct _NV_GET_VIRTUAL_REFRESH_RATE_DATA_V1 | NV_GET_VIRTUAL_REFRESH_RATE_DATA_V1
typedef NV_GET_VIRTUAL_REFRESH_RATE_DATA_V1 | NV_GET_VIRTUAL_REFRESH_RATE_DATA
typedef struct _NV_SET_VIRTUAL_REFRESH_RATE_DATA_V1 | NV_SET_VIRTUAL_REFRESH_RATE_DATA_V1
typedef NV_SET_VIRTUAL_REFRESH_RATE_DATA_V1 | NV_SET_VIRTUAL_REFRESH_RATE_DATA
typedef NV_SET_PREFERRED_STEREO_DISPLAY_V1 | NV_SET_PREFERRED_STEREO_DISPLAY
typedef NV_GET_PREFERRED_STEREO_DISPLAY_V1 | NV_GET_PREFERRED_STEREO_DISPLAY
typedef struct _NV_MANAGED_DEDICATED_DISPLAY_INFO | NV_MANAGED_DEDICATED_DISPLAY_INFO_V1
typedef NV_MANAGED_DEDICATED_DISPLAY_INFO_V1 | NV_MANAGED_DEDICATED_DISPLAY_INFO
typedef struct _NV_MANAGED_DEDICATED_DISPLAY_METADATA | NV_MANAGED_DEDICATED_DISPLAY_METADATA_V1
typedef NV_MANAGED_DEDICATED_DISPLAY_METADATA_V1 | NV_MANAGED_DEDICATED_DISPLAY_METADATA
typedef struct _NV_GET_VRR_INFO_V1 | NV_GET_VRR_INFO_V1
typedef NV_GET_VRR_INFO_V1 | NV_GET_VRR_INFO
typedef struct _NV_MOSAIC_DISPLAY_SETTING_V1 | NV_MOSAIC_DISPLAY_SETTING_V1
typedef struct NV_MOSAIC_DISPLAY_SETTING_V2 | NV_MOSAIC_DISPLAY_SETTING_V2
typedef NV_MOSAIC_DISPLAY_SETTING_V2 | NV_MOSAIC_DISPLAY_SETTING
typedef struct _NV_MOSAIC_SUPPORTED_TOPO_INFO_V1 | NV_MOSAIC_SUPPORTED_TOPO_INFO_V1
typedef struct _NV_MOSAIC_SUPPORTED_TOPO_INFO_V2 | NV_MOSAIC_SUPPORTED_TOPO_INFO_V2
typedef NV_MOSAIC_SUPPORTED_TOPO_INFO_V2 | NV_MOSAIC_SUPPORTED_TOPO_INFO
typedef struct _NV_GSYNC_CAPABILITIES_V1 | NV_GSYNC_CAPABILITIES_V1
typedef struct _NV_GSYNC_CAPABILITIES_V2 | NV_GSYNC_CAPABILITIES_V2
typedef struct _NV_GSYNC_CAPABILITIES_V3 | NV_GSYNC_CAPABILITIES_V3
typedef NV_GSYNC_CAPABILITIES_V3 | NV_GSYNC_CAPABILITIES
typedef enum _NVAPI_GSYNC_GPU_TOPOLOGY_CONNECTOR | NVAPI_GSYNC_GPU_TOPOLOGY_CONNECTOR
typedef enum _NVAPI_GSYNC_DISPLAY_SYNC_STATE | NVAPI_GSYNC_DISPLAY_SYNC_STATE
typedef struct _NV_GSYNC_GPU | NV_GSYNC_GPU
typedef struct _NV_GSYNC_DISPLAY | NV_GSYNC_DISPLAY
typedef enum _NVAPI_GSYNC_POLARITY | NVAPI_GSYNC_POLARITY
typedef enum _NVAPI_GSYNC_VIDEO_MODE | NVAPI_GSYNC_VIDEO_MODE
typedef enum _NVAPI_GSYNC_SYNC_SOURCE | NVAPI_GSYNC_SYNC_SOURCE
typedef struct _NV_GSYNC_DELAY | NV_GSYNC_DELAY
typedef struct _NV_GSYNC_CONTROL_PARAMS_V1 | NV_GSYNC_CONTROL_PARAMS_V1
typedef enum _NVAPI_GSYNC_MULTIPLY_DIVIDE_MODE | NVAPI_GSYNC_MULTIPLY_DIVIDE_MODE
typedef struct _NV_GSYNC_CONTROL_PARAMS_V2 | NV_GSYNC_CONTROL_PARAMS_V2
typedef NV_GSYNC_CONTROL_PARAMS_V2 | NV_GSYNC_CONTROL_PARAMS
typedef enum _NVAPI_GSYNC_DELAY_TYPE | NVAPI_GSYNC_DELAY_TYPE
typedef struct _NV_GSYNC_STATUS | NV_GSYNC_STATUS
typedef enum _NVAPI_GSYNC_RJ45_IO | NVAPI_GSYNC_RJ45_IO
typedef struct _NV_GSYNC_STATUS_PARAMS_V1 | NV_GSYNC_STATUS_PARAMS_V1
typedef struct _NV_GSYNC_STATUS_PARAMS_V2 | NV_GSYNC_STATUS_PARAMS_V2
typedef NV_GSYNC_STATUS_PARAMS_V2 | NV_GSYNC_STATUS_PARAMS
typedef enum _NV_STEREO_VIDEO_FORMAT | NV_STEREO_VIDEO_FORMAT
typedef struct _NV_DX_VIDEO_STEREO_INFO | NV_DX_VIDEO_STEREO_INFO
typedef enum _NVAPI_D3D11_INSERTWFI_FLAG | NVAPI_D3D11_INSERTWFI_FLAG
typedef struct _NV_JOIN_PRESENT_BARRIER_PARAMS | NV_JOIN_PRESENT_BARRIER_PARAMS
typedef enum _NV_PRESENT_BARRIER_SYNC_MODE | NV_PRESENT_BARRIER_SYNC_MODE
typedef struct _NV_PRESENT_BARRIER_FRAME_STATISTICS | NV_PRESENT_BARRIER_FRAME_STATISTICS
typedef struct NvAPI_D3D11_RASTERIZER_DESC_EX | NvAPI_D3D11_RASTERIZER_DESC_EX
typedef enum _NVAPI_ANSEL_FEATURE | NVAPI_ANSEL_FEATURE
typedef enum _NVAPI_ANSEL_FEATURE_STATE | NVAPI_ANSEL_FEATURE_STATE
typedef enum _NVAPI_ANSEL_HOTKEY_MODIFIER | NVAPI_ANSEL_HOTKEY_MODIFIER
typedef struct NVAPI_ANSEL_FEATURE_CONFIGURATION_STRUCT | NVAPI_ANSEL_FEATURE_CONFIGURATION_STRUCT
typedef struct NVAPI_ANSEL_CONFIGURATION_STRUCT_V1 | NVAPI_ANSEL_CONFIGURATION_STRUCT_V1
typedef NVAPI_ANSEL_CONFIGURATION_STRUCT_V1 | NVAPI_ANSEL_CONFIGURATION_STRUCT
typedef enum _NV_D3D11_FEATURE | NV_D3D11_FEATURE
typedef struct _NV_D3D11_FEATURE_DATA_RASTERIZER_SUPPORT | NV_D3D11_FEATURE_DATA_RASTERIZER_SUPPORT
typedef enum _NV_RESOLVE_MODE | NV_RESOLVE_MODE
typedef UINT | NvAPI_D3D11_SWIZZLE_MODE
typedef enum _NV_SWIZZLE_MODE | NV_SWIZZLE_MODE
typedef enum _NV_SWIZZLE_OFFSET | NV_SWIZZLE_OFFSET
typedef enum NV_CUSTOM_SEMANTIC_TYPE | NV_CUSTOM_SEMANTIC_TYPE
typedef struct _NV_CUSTOM_SEMANTIC | NV_CUSTOM_SEMANTIC
typedef struct NvAPI_D3D11_CREATE_GEOMETRY_SHADER_EX_V5 | NvAPI_D3D11_CREATE_GEOMETRY_SHADER_EX_V5
typedef NvAPI_D3D11_CREATE_GEOMETRY_SHADER_EX_V5 | NvAPI_D3D11_CREATE_GEOMETRY_SHADER_EX
typedef struct NvAPI_D3D11_CREATE_VERTEX_SHADER_EX_V1 | NvAPI_D3D11_CREATE_VERTEX_SHADER_EX_V1
typedef struct NvAPI_D3D11_CREATE_VERTEX_SHADER_EX_V2 | NvAPI_D3D11_CREATE_VERTEX_SHADER_EX_V2
typedef struct NvAPI_D3D11_CREATE_VERTEX_SHADER_EX_V3 | NvAPI_D3D11_CREATE_VERTEX_SHADER_EX_V3
typedef NvAPI_D3D11_CREATE_VERTEX_SHADER_EX_V3 | NvAPI_D3D11_CREATE_VERTEX_SHADER_EX
typedef struct NvAPI_D3D11_CREATE_HULL_SHADER_EX_V1 | NvAPI_D3D11_CREATE_HULL_SHADER_EX_V1
typedef struct NvAPI_D3D11_CREATE_HULL_SHADER_EX_V2 | NvAPI_D3D11_CREATE_HULL_SHADER_EX_V2
typedef NvAPI_D3D11_CREATE_HULL_SHADER_EX_V2 | NvAPI_D3D11_CREATE_HULL_SHADER_EX
typedef struct NvAPI_D3D11_CREATE_DOMAIN_SHADER_EX_V1 | NvAPI_D3D11_CREATE_DOMAIN_SHADER_EX_V1
typedef struct NvAPI_D3D11_CREATE_DOMAIN_SHADER_EX_V2 | NvAPI_D3D11_CREATE_DOMAIN_SHADER_EX_V2
typedef struct NvAPI_D3D11_CREATE_DOMAIN_SHADER_EX_V3 | NvAPI_D3D11_CREATE_DOMAIN_SHADER_EX_V3
typedef NvAPI_D3D11_CREATE_DOMAIN_SHADER_EX_V3 | NvAPI_D3D11_CREATE_DOMAIN_SHADER_EX
typedef struct NvAPI_D3D11_CREATE_PIXEL_SHADER_EX_V1 | NvAPI_D3D11_CREATE_PIXEL_SHADER_EX_V1
typedef struct NvAPI_D3D11_CREATE_PIXEL_SHADER_EX_V2 | NvAPI_D3D11_CREATE_PIXEL_SHADER_EX_V2
typedef NvAPI_D3D11_CREATE_PIXEL_SHADER_EX_V2 | NvAPI_D3D11_CREATE_PIXEL_SHADER_EX
typedef enum _NV_FASTGS_FLAGS | NV_FASTGS_FLAGS
typedef NvAPI_D3D11_CREATE_FASTGS_EXPLICIT_DESC_V1 | NvAPI_D3D11_CREATE_FASTGS_EXPLICIT_DESC
typedef enum _NV_PSO_EXTENSION | NV_PSO_EXTENSION
typedef NVAPI_D3D12_PSO_EXTENSION_DESC_V1 | NVAPI_D3D12_PSO_EXTENSION_DESC
typedef NVAPI_D3D12_PSO_RASTERIZER_STATE_DESC_V1 | NVAPI_D3D12_PSO_RASTERIZER_STATE_DESC
typedef NVAPI_D3D12_PSO_CREATE_FASTGS_EXPLICIT_DESC_V1 | NVAPI_D3D12_PSO_CREATE_FASTGS_EXPLICIT_DESC
typedef NVAPI_D3D12_PSO_REQUEST_FAST_GEOMETRY_SHADER_DESC_V1 | NVAPI_D3D12_PSO_REQUEST_FAST_GEOMETRY_SHADER_DESC
typedef NVAPI_D3D12_PSO_GEOMETRY_SHADER_DESC_V5 | NVAPI_D3D12_PSO_GEOMETRY_SHADER_DESC
typedef NVAPI_D3D12_PSO_VERTEX_SHADER_DESC_V3 | NVAPI_D3D12_PSO_VERTEX_SHADER_DESC
typedef NVAPI_D3D12_PSO_HULL_SHADER_DESC_V2 | NVAPI_D3D12_PSO_HULL_SHADER_DESC
typedef NVAPI_D3D12_PSO_DOMAIN_SHADER_DESC_V3 | NVAPI_D3D12_PSO_DOMAIN_SHADER_DESC
typedef NVAPI_D3D12_PSO_ENABLE_DEPTH_BOUND_TEST_DESC_V1 | NVAPI_D3D12_PSO_ENABLE_DEPTH_BOUND_TEST_DESC
typedef NVAPI_D3D12_PSO_SET_SHADER_EXTENSION_SLOT_DESC_V1 | NVAPI_D3D12_PSO_SET_SHADER_EXTENSION_SLOT_DESC
typedef enum _NV_COMPUTE_SHADER_DERIVATIVES | NV_COMPUTE_SHADER_DERIVATIVES
typedef struct _NV_HEAP_PARAMS_V1 | NV_HEAP_PARAMS_V1
typedef NV_HEAP_PARAMS_V1 | NV_HEAP_PARAMS
typedef NVAPI_UAV_INFO_V2 | NVAPI_UAV_INFO
typedef NvU64 | NV_META_COMMAND_BOOL
typedef ID3D11NvMetaCommand_V1 | ID3D11NvMetaCommand
typedef ID3D12NvMetaCommand_V1 | ID3D12NvMetaCommand
typedef struct _NV_RESOURCE_PARAMS_V1 | NV_RESOURCE_PARAMS_V1
typedef NV_RESOURCE_PARAMS_V1 | NV_RESOURCE_PARAMS
typedef struct _NV_MULTIGPU_CAPS_V1 | NV_MULTIGPU_CAPS_V1
typedef struct _NV_MULTIGPU_CAPS_V1 * | PNV_MULTIGPU_CAPS_V1
typedef struct _NV_MULTIGPU_CAPS_V2 | NV_MULTIGPU_CAPS_V2
typedef struct _NV_MULTIGPU_CAPS_V2 * | PNV_MULTIGPU_CAPS_V2
typedef NV_MULTIGPU_CAPS_V2 | NV_MULTIGPU_CAPS
typedef PNV_MULTIGPU_CAPS_V2 | PNV_MULTIGPU_CAPS
typedef ID3D11MultiGPUDevice_V1 | ID3D11MultiGPUDevice
typedef struct _NV_QUERY_SINGLE_PASS_STEREO_SUPPORT_PARAMS_V1 | NV_QUERY_SINGLE_PASS_STEREO_SUPPORT_PARAMS_V1
typedef struct _NV_QUERY_SINGLE_PASS_STEREO_SUPPORT_PARAMS_V2 | NV_QUERY_SINGLE_PASS_STEREO_SUPPORT_PARAMS_V2
typedef NV_QUERY_SINGLE_PASS_STEREO_SUPPORT_PARAMS_V2 | NV_QUERY_SINGLE_PASS_STEREO_SUPPORT_PARAMS
typedef struct _NV_QUERY_MULTIVIEW_SUPPORT_PARAMS_V1 | NV_QUERY_MULTIVIEW_SUPPORT_PARAMS_V1
typedef NV_QUERY_MULTIVIEW_SUPPORT_PARAMS_V1 | NV_QUERY_MULTIVIEW_SUPPORT_PARAMS
typedef struct _NV_MULTIVIEW_PARAMS_V1 | NV_MULTIVIEW_PARAMS_V1
typedef NV_MULTIVIEW_PARAMS_V1 | NV_MULTIVIEW_PARAMS
typedef struct _NV_QUERY_MODIFIED_W_SUPPORT_PARAMS | NV_QUERY_MODIFIED_W_SUPPORT_PARAMS_V1
typedef NV_QUERY_MODIFIED_W_SUPPORT_PARAMS_V1 | NV_QUERY_MODIFIED_W_SUPPORT_PARAMS
typedef struct _NV_MODIFIED_W_COEFFICIENTS | NV_MODIFIED_W_COEFFICIENTS
typedef struct _NV_MODIFIED_W_PARAMS | NV_MODIFIED_W_PARAMS_V1
typedef NV_MODIFIED_W_PARAMS_V1 | NV_MODIFIED_W_PARAMS
typedef ID3DLateLatchObject_V1 | ID3DLateLatchObject
typedef struct _NV_D3D_LATELATCH_OBJECT_DESC_V1 | NV_D3D_LATELATCH_OBJECT_DESC_V1
typedef NV_D3D_LATELATCH_OBJECT_DESC_V1 | NV_D3D_LATELATCH_OBJECT_DESC
typedef struct _NV_QUERY_LATELATCH_SUPPORT_PARAMS | NV_QUERY_LATELATCH_SUPPORT_PARAMS_V1
typedef NV_QUERY_LATELATCH_SUPPORT_PARAMS_V1 | NV_QUERY_LATELATCH_SUPPORT_PARAMS
typedef enum _IMPLICIT_SLI_CONTROL | IMPLICIT_SLI_CONTROL
typedef struct _NV_D3D12_MOSAIC_GETCOMPANIONALLOCATIONS | NV_D3D12_MOSAIC_GETCOMPANIONALLOCATIONS_V1
typedef NV_D3D12_MOSAIC_GETCOMPANIONALLOCATIONS_V1 | NV_D3D12_MOSAIC_GETCOMPANIONALLOCATIONS
typedef struct _NV_D3D12_MOSAIC_GETVIEWPORTANDGPUPARTITIONS | NV_D3D12_MOSAIC_GETVIEWPORTANDGPUPARTITIONS_V1
typedef NV_D3D12_MOSAIC_GETVIEWPORTANDGPUPARTITIONS_V1 | NV_D3D12_MOSAIC_GETVIEWPORTANDGPUPARTITIONS
typedef struct _NV_D3D1x_GRAPHICS_CAPS_V1 | NV_D3D1x_GRAPHICS_CAPS_V1
typedef struct _NV_D3D1x_GRAPHICS_CAPS_V2 | NV_D3D1x_GRAPHICS_CAPS_V2
typedef NV_D3D1x_GRAPHICS_CAPS_V2 | NV_D3D1x_GRAPHICS_CAPS
typedef struct _NV_D3D12_GRAPHICS_CAPS_V1 | NV_D3D12_GRAPHICS_CAPS_V1
typedef NV_D3D12_GRAPHICS_CAPS_V1 | NV_D3D12_GRAPHICS_CAPS
typedef struct _NV_D3D11_EXCLUSIVE_SCISSOR_RECT_DESC_V1 | NV_D3D11_EXCLUSIVE_SCISSOR_RECT_DESC_V1
typedef struct _NV_D3D11_EXCLUSIVE_SCISSOR_RECTS_DESC_V1 | NV_D3D11_EXCLUSIVE_SCISSOR_RECTS_DESC_V1
typedef NV_D3D11_EXCLUSIVE_SCISSOR_RECTS_DESC_V1 | NV_D3D11_EXCLUSIVE_SCISSOR_RECTS_DESC
typedef NV_D3D11_EXCLUSIVE_SCISSOR_RECT_DESC_V1 | NV_D3D11_EXCLUSIVE_SCISSOR_RECT_DESC
typedef struct _NV_D3D11_VIEWPORT_SHADING_RATE_DESC_V1 | NV_D3D11_VIEWPORT_SHADING_RATE_DESC_V1
typedef struct _NV_D3D11_VIEWPORTS_SHADING_RATE_DESC_V1 | NV_D3D11_VIEWPORTS_SHADING_RATE_DESC_V1
typedef NV_D3D11_VIEWPORTS_SHADING_RATE_DESC_V1 | NV_D3D11_VIEWPORTS_SHADING_RATE_DESC
typedef NV_D3D11_VIEWPORT_SHADING_RATE_DESC_V1 | NV_D3D11_VIEWPORT_SHADING_RATE_DESC
typedef enum _NV_SRRV_DIMENSION | NV_SRRV_DIMENSION
typedef struct _NV_TEX2D_SRRV | NV_TEX2D_SRRV
typedef struct _NV_TEX2D_ARRAY_SRRV | NV_TEX2D_ARRAY_SRRV
typedef struct _NV_D3D11_SHADING_RATE_RESOURCE_VIEW_DESC_V1 | NV_D3D11_SHADING_RATE_RESOURCE_VIEW_DESC_V1
typedef NV_D3D11_SHADING_RATE_RESOURCE_VIEW_DESC_V1 | NV_D3D11_SHADING_RATE_RESOURCE_VIEW_DESC
typedef ID3D11NvShadingRateResourceView_V1 | ID3D11NvShadingRateResourceView
typedef struct _NV_PIXEL_SRSO_1x2 | NV_PIXEL_SRSO_1x2
typedef struct _NV_PIXEL_SRSO_2x1 | NV_PIXEL_SRSO_2x1
typedef struct _NV_PIXEL_SRSO_2x2 | NV_PIXEL_SRSO_2x2
typedef struct _NV_PIXEL_SRSO_2x4 | NV_PIXEL_SRSO_2x4
typedef struct _NV_PIXEL_SRSO_4x2 | NV_PIXEL_SRSO_4x2
typedef struct _NV_PIXEL_SRSO_4x4 | NV_PIXEL_SRSO_4x4
typedef struct _NV_PIXEL_SHADING_RATE_SAMPLE_ORDER_TABLE_V1 | NV_PIXEL_SHADING_RATE_SAMPLE_ORDER_TABLE_V1
typedef NV_PIXEL_SHADING_RATE_SAMPLE_ORDER_TABLE_V1 | NV_PIXEL_SHADING_RATE_SAMPLE_ORDER_TABLE
typedef struct _NV_VRS_HELPER_LATCH_GAZE_PARAMS_V1 | NV_VRS_HELPER_LATCH_GAZE_PARAMS_V1
typedef NV_VRS_HELPER_LATCH_GAZE_PARAMS_V1 | NV_VRS_HELPER_LATCH_GAZE_PARAMS
typedef enum _NV_VRS_CONTENT_TYPE | NV_VRS_CONTENT_TYPE
typedef enum _NV_FOVEATED_RENDERING_SHADING_RATE_PRESET | NV_FOVEATED_RENDERING_SHADING_RATE_PRESET
typedef struct _NV_FOVEATED_RENDERING_CUSTOM_SHADING_RATE_PRESET_DESC_V1 | NV_FOVEATED_RENDERING_CUSTOM_SHADING_RATE_PRESET_DESC_V1
typedef NV_FOVEATED_RENDERING_CUSTOM_SHADING_RATE_PRESET_DESC_V1 | NV_FOVEATED_RENDERING_CUSTOM_SHADING_RATE_PRESET_DESC
typedef enum _NV_FOVEATED_RENDERING_FOVEATION_PATTERN_PRESET | NV_FOVEATED_RENDERING_FOVEATION_PATTERN_PRESET
typedef struct _NV_FOVEATED_RENDERING_CUSTOM_FOVEATION_PATTERN_PRESET_DESC_V1 | NV_FOVEATED_RENDERING_CUSTOM_FOVEATION_PATTERN_PRESET_DESC_V1
typedef NV_FOVEATED_RENDERING_CUSTOM_FOVEATION_PATTERN_PRESET_DESC_V1 | NV_FOVEATED_RENDERING_CUSTOM_FOVEATION_PATTERN_PRESET_DESC
typedef struct _NV_FOVEATED_RENDERING_DESC_V1 | NV_FOVEATED_RENDERING_DESC_V1
typedef NV_FOVEATED_RENDERING_DESC_V1 | NV_FOVEATED_RENDERING_DESC
typedef enum _NV_VRS_RENDER_MODE | NV_VRS_RENDER_MODE
typedef struct _NV_VRS_HELPER_ENABLE_PARAMS_V1 | NV_VRS_HELPER_ENABLE_PARAMS_V1
typedef NV_VRS_HELPER_ENABLE_PARAMS_V1 | NV_VRS_HELPER_ENABLE_PARAMS
typedef struct _NV_VRS_HELPER_DISABLE_PARAMS_V1 | NV_VRS_HELPER_DISABLE_PARAMS_V1
typedef NV_VRS_HELPER_DISABLE_PARAMS_V1 | NV_VRS_HELPER_DISABLE_PARAMS
typedef struct _NV_VRS_HELPER_GET_SHADING_RATE_RESOURCE_PARAMS_V1 | NV_VRS_HELPER_GET_SHADING_RATE_RESOURCE_PARAMS_V1
typedef NV_VRS_HELPER_GET_SHADING_RATE_RESOURCE_PARAMS_V1 | NV_VRS_HELPER_GET_SHADING_RATE_RESOURCE_PARAMS
typedef struct _NV_VRS_HELPER_PURGE_INTERNAL_RESOURCES_PARAMS_V1 | NV_VRS_HELPER_PURGE_INTERNAL_RESOURCES_PARAMS_V1
typedef NV_VRS_HELPER_PURGE_INTERNAL_RESOURCES_PARAMS_V1 | NV_VRS_HELPER_PURGE_INTERNAL_RESOURCES_PARAMS
typedef ID3DNvVRSHelper_V1 | ID3DNvVRSHelper
typedef struct _NV_VRS_HELPER_INIT_PARAMS_V1 | NV_VRS_HELPER_INIT_PARAMS_V1
typedef NV_VRS_HELPER_INIT_PARAMS_V1 | NV_VRS_HELPER_INIT_PARAMS
typedef enum _NV_GAZE_DATA_VALIDITY_FLAGS | NV_GAZE_DATA_VALIDITY_FLAGS
typedef struct _NV_FOVEATED_RENDERING_GAZE_DATA_PER_EYE | NV_FOVEATED_RENDERING_GAZE_DATA_PER_EYE_V1
typedef NV_FOVEATED_RENDERING_GAZE_DATA_PER_EYE_V1 | NV_FOVEATED_RENDERING_GAZE_DATA_PER_EYE
typedef struct _NV_FOVEATED_RENDERING_UPDATE_GAZE_DATA_PARAMS | NV_FOVEATED_RENDERING_UPDATE_GAZE_DATA_PARAMS_V1
typedef NV_FOVEATED_RENDERING_UPDATE_GAZE_DATA_PARAMS_V1 | NV_FOVEATED_RENDERING_UPDATE_GAZE_DATA_PARAMS
typedef ID3DNvGazeHandler_V2 | ID3DNvGazeHandler
typedef enum _NV_GAZE_DATA_TYPE | NV_GAZE_DATA_TYPE
typedef struct _NV_GAZE_HANDLER_INIT_PARAMS_V2 | NV_GAZE_HANDLER_INIT_PARAMS_V2
typedef NV_GAZE_HANDLER_INIT_PARAMS_V2 | NV_GAZE_HANDLER_INIT_PARAMS
typedef struct _NV_GAZE_HANDLER_INIT_PARAMS_V1 | NV_GAZE_HANDLER_INIT_PARAMS_V1
typedef enum NV_SMP_ASSIST_TYPE | NV_SMP_ASSIST_TYPE
typedef enum NV_SMP_ASSIST_LEVEL | NV_SMP_ASSIST_LEVEL
typedef enum NV_MRS_CONFIG | NV_MRS_CONFIG
typedef enum NV_LMS_CONFIG | NV_LMS_CONFIG
typedef struct _NV_MRS_CUSTOM_CONFIG_V1 | NV_MRS_CUSTOM_CONFIG_V1
typedef NV_MRS_CUSTOM_CONFIG_V1 | NV_MRS_CUSTOM_CONFIG
typedef struct _NV_MRS_INSTANCED_STEREO_CONFIG_V1 | NV_MRS_INSTANCED_STEREO_CONFIG_V1
typedef NV_MRS_INSTANCED_STEREO_CONFIG_V1 | NV_MRS_INSTANCED_STEREO_CONFIG
typedef struct _NV_LMS_CUSTOM_CONFIG_V1 | NV_LMS_CUSTOM_CONFIG_V1
typedef NV_LMS_CUSTOM_CONFIG_V1 | NV_LMS_CUSTOM_CONFIG
typedef struct _NV_LMS_INSTANCED_STEREO_CONFIG_V1 | NV_LMS_INSTANCED_STEREO_CONFIG_V1
typedef NV_LMS_INSTANCED_STEREO_CONFIG_V1 | NV_LMS_INSTANCED_STEREO_CONFIG
typedef enum _NV_SMP_ASSIST_EYE_INDEX | NV_SMP_ASSIST_EYE_INDEX
typedef struct _NV_CUSTOM_RECTS_V1 | NV_CUSTOM_RECTS_V1
typedef NV_CUSTOM_RECTS_V1 | NV_CUSTOM_RECTS
typedef struct _NV_SMP_ASSIST_ENABLE_PARAMS_V1 | NV_SMP_ASSIST_ENABLE_PARAMS_V1
typedef NV_SMP_ASSIST_ENABLE_PARAMS_V1 | NV_SMP_ASSIST_ENABLE_PARAMS
typedef struct _NV_SMP_ASSIST_DISABLE_PARAMS_V1 | NV_SMP_ASSIST_DISABLE_PARAMS_V1
typedef NV_SMP_ASSIST_DISABLE_PARAMS_V1 | NV_SMP_ASSIST_DISABLE_PARAMS
typedef struct _NV_SMP_ASSIST_FASTGSCBDATA_V1 | NV_SMP_ASSIST_FASTGSCBDATA_V1
typedef NV_SMP_ASSIST_FASTGSCBDATA_V1 | NV_SMP_ASSIST_FASTGSCBDATA
typedef struct _NV_SMP_ASSIST_FASTGSCBDATA_MRS_INSTANCED_STEREO_V1 | NV_SMP_ASSIST_FASTGSCBDATA_MRS_INSTANCED_STEREO_V1
typedef NV_SMP_ASSIST_FASTGSCBDATA_MRS_INSTANCED_STEREO_V1 | NV_SMP_ASSIST_FASTGSCBDATA_MRS_INSTANCED_STEREO
typedef struct _NV_SMP_ASSIST_REMAPCBDATA_V1 | NV_SMP_ASSIST_REMAPCBDATA_V1
typedef NV_SMP_ASSIST_REMAPCBDATA_V1 | NV_SMP_ASSIST_REMAPCBDATA
typedef struct _NV_SMP_ASSIST_GET_CONSTANTS_V3 | NV_SMP_ASSIST_GET_CONSTANTS_V3
typedef NV_SMP_ASSIST_GET_CONSTANTS_V3 | NV_SMP_ASSIST_GET_CONSTANTS
typedef struct _NV_SMP_ASSIST_SETUP_PARAMS_V1 | NV_SMP_ASSIST_SETUP_PARAMS_V1
typedef NV_SMP_ASSIST_SETUP_PARAMS_V1 | NV_SMP_ASSIST_SETUP_PARAMS
typedef struct _NV_SMP_ASSIST_UPDATE_INSTANCEDSTEREO_DATA_PARAMS_V1 | NV_SMP_ASSIST_UPDATE_INSTANCEDSTEREO_DATA_PARAMS_V1
typedef NV_SMP_ASSIST_UPDATE_INSTANCEDSTEREO_DATA_PARAMS_V1 | NV_SMP_ASSIST_UPDATE_INSTANCEDSTEREO_DATA_PARAMS
typedef ID3DNvSMPAssist_V1 | ID3DNvSMPAssist
typedef struct _NV_SMP_ASSIST_INITIALIZE_PARAMS_V1 | NV_SMP_ASSIST_INITIALIZE_PARAMS_V1
typedef NV_SMP_ASSIST_INITIALIZE_PARAMS_V1 | NV_SMP_ASSIST_INITIALIZE_PARAMS
typedef struct _NV_QUERY_SMP_ASSIST_SUPPORT_PARAMS_V1 | NV_QUERY_SMP_ASSIST_SUPPORT_PARAMS_V1
typedef NV_QUERY_SMP_ASSIST_SUPPORT_PARAMS_V1 | NV_QUERY_SMP_ASSIST_SUPPORT_PARAMS
typedef struct _NV_GET_SLEEP_STATUS_PARAMS | NV_GET_SLEEP_STATUS_PARAMS_V1
typedef NV_GET_SLEEP_STATUS_PARAMS_V1 | NV_GET_SLEEP_STATUS_PARAMS
typedef struct _NV_SET_SLEEP_MODE_PARAMS | NV_SET_SLEEP_MODE_PARAMS_V1
typedef NV_SET_SLEEP_MODE_PARAMS_V1 | NV_SET_SLEEP_MODE_PARAMS
typedef struct _NV_SET_REFLEX_SYNC_PARAMS | NV_SET_REFLEX_SYNC_PARAMS_V1
typedef NV_SET_REFLEX_SYNC_PARAMS_V1 | NV_SET_REFLEX_SYNC_PARAMS
typedef struct _NV_LATENCY_RESULT_PARAMS | NV_LATENCY_RESULT_PARAMS_V1
typedef NV_LATENCY_RESULT_PARAMS_V1 | NV_LATENCY_RESULT_PARAMS
typedef struct _NV_LATENCY_MARKER_PARAMS | NV_LATENCY_MARKER_PARAMS_V1
typedef NV_LATENCY_MARKER_PARAMS_V1 | NV_LATENCY_MARKER_PARAMS
typedef struct _NV_ASYNC_FRAME_MARKER_PARAMS_V1 | NV_ASYNC_FRAME_MARKER_PARAMS_V1
typedef NV_ASYNC_FRAME_MARKER_PARAMS_V1 | NV_ASYNC_FRAME_MARKER_PARAMS
typedef struct NVAPI_D3D12_CREATE_CUBIN_SHADER_PARAMS | NVAPI_D3D12_CREATE_CUBIN_SHADER_PARAMS
typedef struct NVAPI_D3D12_GET_CUDA_MERGED_TEXTURE_SAMPLER_OBJECT_PARAMS | NVAPI_D3D12_GET_CUDA_MERGED_TEXTURE_SAMPLER_OBJECT_PARAMS
typedef enum _NVAPI_D3D12_GET_CUDA_INDEPENDENT_DESCRIPTOR_OBJECT_TYPE | NVAPI_D3D12_GET_CUDA_INDEPENDENT_DESCRIPTOR_OBJECT_TYPE
typedef struct NVAPI_D3D12_GET_CUDA_INDEPENDENT_DESCRIPTOR_OBJECT_PARAMS | NVAPI_D3D12_GET_CUDA_INDEPENDENT_DESCRIPTOR_OBJECT_PARAMS
typedef struct _NVAPI_DIM3 | NVAPI_DIM3
typedef struct _NVAPI_CU_KERNEL_LAUNCH_PARAMS | NVAPI_CU_KERNEL_LAUNCH_PARAMS
typedef struct _NVAPI_CU_KERNEL_LAUNCH_PARAMS_EX | NVAPI_CU_KERNEL_LAUNCH_PARAMS_EX
typedef enum _NVAPI_D3D12_RAYTRACING_THREAD_REORDERING_CAPS | NVAPI_D3D12_RAYTRACING_THREAD_REORDERING_CAPS
typedef enum _NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_CAPS | NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_CAPS
typedef enum _NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_CAPS | NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_CAPS
typedef enum _NVAPI_D3D12_RAYTRACING_CAPS_TYPE | NVAPI_D3D12_RAYTRACING_CAPS_TYPE
typedef enum _NVAPI_D3D12_RAYTRACING_VALIDATION_FLAGS | NVAPI_D3D12_RAYTRACING_VALIDATION_FLAGS
typedef enum _NVAPI_D3D12_RAYTRACING_VALIDATION_MESSAGE_SEVERITY | NVAPI_D3D12_RAYTRACING_VALIDATION_MESSAGE_SEVERITY
typedef void(__stdcall * | NVAPI_D3D12_RAYTRACING_VALIDATION_MESSAGE_CALLBACK) (void *pUserData, NVAPI_D3D12_RAYTRACING_VALIDATION_MESSAGE_SEVERITY severity, const char *messageCode, const char *message, const char *messageDetails)
typedef enum _NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_BUILD_FLAGS | NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_BUILD_FLAGS
typedef enum _NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_FORMAT | NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_FORMAT
typedef struct _NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_USAGE_COUNT | NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_USAGE_COUNT
typedef struct _NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_DESC | NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_DESC
typedef struct _NVAPI_D3D12_BUILD_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_INPUTS | NVAPI_D3D12_BUILD_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_INPUTS
typedef struct _NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PREBUILD_INFO | NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PREBUILD_INFO
typedef struct _NVAPI_GET_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PREBUILD_INFO_PARAMS_V1 | NVAPI_GET_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PREBUILD_INFO_PARAMS_V1
typedef NVAPI_GET_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PREBUILD_INFO_PARAMS_V1 | NVAPI_GET_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PREBUILD_INFO_PARAMS
typedef enum _NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_ARRAY_BUILD_FLAGS | NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_ARRAY_BUILD_FLAGS
typedef enum _NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_FORMAT | NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_FORMAT
typedef struct _NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_USAGE_COUNT | NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_USAGE_COUNT
typedef struct _NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_DESC | NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_DESC
typedef struct _NVAPI_D3D12_BUILD_RAYTRACING_OPACITY_MICROMAP_ARRAY_INPUTS | NVAPI_D3D12_BUILD_RAYTRACING_OPACITY_MICROMAP_ARRAY_INPUTS
typedef struct _NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_ARRAY_PREBUILD_INFO | NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_ARRAY_PREBUILD_INFO
typedef struct _NVAPI_GET_RAYTRACING_OPACITY_MICROMAP_ARRAY_PREBUILD_INFO_PARAMS_V1 | NVAPI_GET_RAYTRACING_OPACITY_MICROMAP_ARRAY_PREBUILD_INFO_PARAMS_V1
typedef NVAPI_GET_RAYTRACING_OPACITY_MICROMAP_ARRAY_PREBUILD_INFO_PARAMS_V1 | NVAPI_GET_RAYTRACING_OPACITY_MICROMAP_ARRAY_PREBUILD_INFO_PARAMS
typedef enum _NVAPI_D3D12_PIPELINE_CREATION_STATE_FLAGS | NVAPI_D3D12_PIPELINE_CREATION_STATE_FLAGS
typedef struct _NVAPI_D3D12_SET_CREATE_PIPELINE_STATE_OPTIONS_PARAMS_V1 | NVAPI_D3D12_SET_CREATE_PIPELINE_STATE_OPTIONS_PARAMS_V1
typedef NVAPI_D3D12_SET_CREATE_PIPELINE_STATE_OPTIONS_PARAMS_V1 | NVAPI_D3D12_SET_CREATE_PIPELINE_STATE_OPTIONS_PARAMS
typedef enum _NVAPI_D3D12_SERIALIZED_DATA_TYPE_EX | NVAPI_D3D12_SERIALIZED_DATA_TYPE_EX
typedef struct _NVAPI_CHECK_DRIVER_MATCHING_IDENTIFIER_EX_PARAMS_V1 | NVAPI_CHECK_DRIVER_MATCHING_IDENTIFIER_EX_PARAMS_V1
typedef NVAPI_CHECK_DRIVER_MATCHING_IDENTIFIER_EX_PARAMS_V1 | NVAPI_CHECK_DRIVER_MATCHING_IDENTIFIER_EX_PARAMS
typedef enum _NVAPI_D3D12_RAYTRACING_ACCELERATION_STRUCTURE_BUILD_FLAGS_EX | NVAPI_D3D12_RAYTRACING_ACCELERATION_STRUCTURE_BUILD_FLAGS_EX
typedef enum _NVAPI_D3D12_RAYTRACING_GEOMETRY_TYPE_EX | NVAPI_D3D12_RAYTRACING_GEOMETRY_TYPE_EX
typedef enum _NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_SPECIAL_INDEX | NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_SPECIAL_INDEX
typedef struct _NVAPI_D3D12_RAYTRACING_GEOMETRY_OMM_ATTACHMENT_DESC | NVAPI_D3D12_RAYTRACING_GEOMETRY_OMM_ATTACHMENT_DESC
typedef enum _NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_PRIMITIVE_FLAGS | NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_PRIMITIVE_FLAGS
typedef struct _NVAPI_D3D12_RAYTRACING_GEOMETRY_DMM_ATTACHMENT_DESC | NVAPI_D3D12_RAYTRACING_GEOMETRY_DMM_ATTACHMENT_DESC
typedef struct _NVAPI_D3D12_RAYTRACING_GEOMETRY_DMM_TRIANGLES_DESC | NVAPI_D3D12_RAYTRACING_GEOMETRY_DMM_TRIANGLES_DESC
typedef struct _NVAPI_D3D12_RAYTRACING_GEOMETRY_OMM_TRIANGLES_DESC | NVAPI_D3D12_RAYTRACING_GEOMETRY_OMM_TRIANGLES_DESC
typedef struct _NVAPI_D3D12_RAYTRACING_GEOMETRY_DESC_EX | NVAPI_D3D12_RAYTRACING_GEOMETRY_DESC_EX
typedef enum _NVAPI_D3D12_RAYTRACING_INSTANCE_FLAGS_EX | NVAPI_D3D12_RAYTRACING_INSTANCE_FLAGS_EX
typedef struct _NVAPI_D3D12_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_INPUTS_EX | NVAPI_D3D12_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_INPUTS_EX
typedef struct _NVAPI_GET_RAYTRACING_ACCELERATION_STRUCTURE_PREBUILD_INFO_EX_PARAMS_V1 | NVAPI_GET_RAYTRACING_ACCELERATION_STRUCTURE_PREBUILD_INFO_EX_PARAMS_V1
typedef NVAPI_GET_RAYTRACING_ACCELERATION_STRUCTURE_PREBUILD_INFO_EX_PARAMS_V1 | NVAPI_GET_RAYTRACING_ACCELERATION_STRUCTURE_PREBUILD_INFO_EX_PARAMS
typedef struct _NVAPI_D3D12_BUILD_RAYTRACING_OPACITY_MICROMAP_ARRAY_DESC | NVAPI_D3D12_BUILD_RAYTRACING_OPACITY_MICROMAP_ARRAY_DESC
typedef struct _NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_ARRAY_POSTBUILD_INFO_CURRENT_SIZE_DESC | NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_ARRAY_POSTBUILD_INFO_CURRENT_SIZE_DESC
typedef enum _NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_ARRAY_POSTBUILD_INFO_TYPE | NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_ARRAY_POSTBUILD_INFO_TYPE
typedef struct _NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_ARRAY_POSTBUILD_INFO_DESC | NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_ARRAY_POSTBUILD_INFO_DESC
typedef struct _NVAPI_BUILD_RAYTRACING_OPACITY_MICROMAP_ARRAY_PARAMS_V1 | NVAPI_BUILD_RAYTRACING_OPACITY_MICROMAP_ARRAY_PARAMS_V1
typedef NVAPI_BUILD_RAYTRACING_OPACITY_MICROMAP_ARRAY_PARAMS_V1 | NVAPI_BUILD_RAYTRACING_OPACITY_MICROMAP_ARRAY_PARAMS
typedef struct _NVAPI_RELOCATE_RAYTRACING_OPACITY_MICROMAP_ARRAY_PARAMS_V1 | NVAPI_RELOCATE_RAYTRACING_OPACITY_MICROMAP_ARRAY_PARAMS_V1
typedef NVAPI_RELOCATE_RAYTRACING_OPACITY_MICROMAP_ARRAY_PARAMS_V1 | NVAPI_RELOCATE_RAYTRACING_OPACITY_MICROMAP_ARRAY_PARAMS
typedef struct _NVAPI_D3D12_BUILD_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_DESC | NVAPI_D3D12_BUILD_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_DESC
typedef struct _NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_POSTBUILD_INFO_CURRENT_SIZE_DESC | NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_POSTBUILD_INFO_CURRENT_SIZE_DESC
typedef enum _NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_POSTBUILD_INFO_TYPE | NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_POSTBUILD_INFO_TYPE
typedef struct _NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_POSTBUILD_INFO_DESC | NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_POSTBUILD_INFO_DESC
typedef struct _NVAPI_BUILD_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PARAMS_V1 | NVAPI_BUILD_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PARAMS_V1
typedef NVAPI_BUILD_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PARAMS_V1 | NVAPI_BUILD_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PARAMS
typedef struct _NVAPI_RELOCATE_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PARAMS_V1 | NVAPI_RELOCATE_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PARAMS_V1
typedef NVAPI_RELOCATE_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PARAMS_V1 | NVAPI_RELOCATE_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PARAMS
typedef struct _NVAPI_EMIT_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_POSTBUILD_INFO_PARAMS_V1 | NVAPI_EMIT_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_POSTBUILD_INFO_PARAMS_V1
typedef NVAPI_EMIT_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_POSTBUILD_INFO_PARAMS_V1 | NVAPI_EMIT_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_POSTBUILD_INFO_PARAMS
typedef struct _NVAPI_EMIT_RAYTRACING_OPACITY_MICROMAP_ARRAY_POSTBUILD_INFO_PARAMS_V1 | NVAPI_EMIT_RAYTRACING_OPACITY_MICROMAP_ARRAY_POSTBUILD_INFO_PARAMS_V1
typedef NVAPI_EMIT_RAYTRACING_OPACITY_MICROMAP_ARRAY_POSTBUILD_INFO_PARAMS_V1 | NVAPI_EMIT_RAYTRACING_OPACITY_MICROMAP_ARRAY_POSTBUILD_INFO_PARAMS
typedef struct _NVAPI_D3D12_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_DESC_EX | NVAPI_D3D12_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_DESC_EX
typedef struct _NVAPI_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_EX_PARAMS_V1 | NVAPI_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_EX_PARAMS_V1
typedef NVAPI_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_EX_PARAMS_V1 | NVAPI_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_EX_PARAMS
typedef enum _NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_STATE | NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_STATE
typedef enum _NVAPI_RAY_FLAGS_EX | NVAPI_RAY_FLAG_EX
typedef enum _NV_D3D12_WORKSTATION_FEATURE_TYPE | NV_D3D12_WORKSTATION_FEATURE_TYPE
typedef struct _NV_D3D12_WORKSTATION_FEATURE_RDMA_PROPERTIES | NV_D3D12_WORKSTATION_FEATURE_RDMA_PROPERTIES
typedef struct _NV_D3D12_WORKSTATION_FEATURE_PROPERTIES | NVAPI_D3D12_WORKSTATION_FEATURE_PROPERTIES_PARAMS_V1
typedef NvU32 | NVVIOOWNERID
typedef enum _NVVIOOWNERTYPE | NVVIOOWNERTYPE
typedef enum _NVVIOSIGNALFORMAT | NVVIOSIGNALFORMAT
typedef enum _NVVIOVIDEOSTANDARD | NVVIOVIDEOSTANDARD
typedef enum _NVVIOVIDEOTYPE | NVVIOVIDEOTYPE
typedef enum _NVVIOINTERLACEMODE | NVVIOINTERLACEMODE
typedef enum _NVVIODATAFORMAT | NVVIODATAFORMAT
typedef enum _NVVIOOUTPUTAREA | NVVIOOUTPUTAREA
typedef enum _NVVIOSYNCSOURCE | NVVIOSYNCSOURCE
typedef enum _NVVIOCOMPSYNCTYPE | NVVIOCOMPSYNCTYPE
typedef enum _NVVIOINPUTOUTPUTSTATUS | NVVIOINPUTOUTPUTSTATUS
typedef enum _NVVIOSYNCSTATUS | NVVIOSYNCSTATUS
typedef enum _NVVIOCAPTURESTATUS | NVVIOCAPTURESTATUS
typedef enum _NVVIOSTATUSTYPE | NVVIOSTATUSTYPE
typedef enum _NVVIOCONFIGTYPE | NVVIOCONFIGTYPE
typedef enum _NVVIOCOLORSPACE | NVVIOCOLORSPACE
typedef enum _NVVIOCOMPONENTSAMPLING | NVVIOCOMPONENTSAMPLING
typedef enum _NVVIOBITSPERCOMPONENT | NVVIOBITSPERCOMPONENT
typedef enum _NVVIOLINKID | NVVIOLINKID
typedef enum _NVVIOANCPARITYCOMPUTATION | NVVIOANCPARITYCOMPUTATION
typedef struct _NVVIOCAPS | NVVIOCAPS
typedef struct _NVVIOCHANNELSTATUS | NVVIOCHANNELSTATUS
typedef struct _NVVIOINPUTSTATUS | NVVIOINPUTSTATUS
typedef struct _NVVIOOUTPUTSTATUS | NVVIOOUTPUTSTATUS
typedef struct _NVVIOSTATUS | NVVIOSTATUS
typedef struct _NVVIOOUTPUTREGION | NVVIOOUTPUTREGION
typedef struct _NVVIOGAMMARAMP8 | NVVIOGAMMARAMP8
typedef struct _NVVIOGAMMARAMP10 | NVVIOGAMMARAMP10
typedef struct _NVVIOSYNCDELAY | NVVIOSYNCDELAY
typedef struct _NVVIOVIDEOMODE | NVVIOVIDEOMODE
typedef struct _NVVIOSIGNALFORMATDETAIL | NVVIOSIGNALFORMATDETAIL
typedef struct _NVVIODATAFORMATDETAIL | NVVIODATAFORMATDETAIL
typedef struct _NVVIOCOLORCONVERSION | NVVIOCOLORCONVERSION
typedef struct _NVVIOGAMMACORRECTION | NVVIOGAMMACORRECTION
typedef struct _NVVIOCOMPOSITERANGE | NVVIOCOMPOSITERANGE
typedef struct _NVVIOOUTPUTCONFIG_V1 | NVVIOOUTPUTCONFIG_V1
typedef struct _NVVIOOUTPUTCONFIG_V2 | NVVIOOUTPUTCONFIG_V2
typedef struct _NVVIOOUTPUTCONFIG_V3 | NVVIOOUTPUTCONFIG_V3
typedef struct _NVVIOSTREAM | NVVIOSTREAM
typedef struct _NVVIOINPUTCONFIG | NVVIOINPUTCONFIG
typedef struct _NVVIOCONFIG_V1 | NVVIOCONFIG_V1
typedef struct _NVVIOCONFIG_V2 | NVVIOCONFIG_V2
typedef struct _NVVIOCONFIG_V3 | NVVIOCONFIG_V3
typedef NVVIOOUTPUTCONFIG_V3 | NVVIOOUTPUTCONFIG
typedef NVVIOCONFIG_V3 | NVVIOCONFIG
typedef struct _NV_VIO_TOPOLOGY | NV_VIO_TOPOLOGY
typedef struct _NV_VIO_TOPOLOGY | NVVIOTOPOLOGY
typedef enum _NVVIOPCILINKRATE | NVVIOPCILINKRATE
typedef enum _NVVIOPCILINKWIDTH | NVVIOPCILINKWIDTH
typedef struct _NVVIOPCIINFO | NVVIOPCIINFO_V1
typedef NVVIOPCIINFO_V1 | NVVIOPCIINFO
typedef enum _NV_StereoRegistryProfileType | NV_STEREO_REGISTRY_PROFILE_TYPE
typedef enum _NV_StereoRegistryID | NV_STEREO_REGISTRY_ID
typedef struct _NVAPI_STEREO_CAPS | NVAPI_STEREO_CAPS_V1
typedef NVAPI_STEREO_CAPS_V1 | NVAPI_STEREO_CAPS
typedef enum _NV_FrustumAdjustMode | NV_FRUSTUM_ADJUST_MODE
typedef enum _NVAPI_STEREO_INIT_ACTIVATION_FLAGS | NVAPI_STEREO_INIT_ACTIVATION_FLAGS
typedef enum _NV_StereoSwapChainMode | NV_STEREO_SWAPCHAIN_MODE
typedef enum _NVDRS_SETTING_TYPE | NVDRS_SETTING_TYPE
typedef enum _NVDRS_SETTING_LOCATION | NVDRS_SETTING_LOCATION
typedef struct _NVDRS_GPU_SUPPORT | NVDRS_GPU_SUPPORT
typedef struct _NVDRS_BINARY_SETTING | NVDRS_BINARY_SETTING
typedef struct _NVDRS_SETTING_VALUES | NVDRS_SETTING_VALUES
typedef struct _NVDRS_SETTING_V1 | NVDRS_SETTING_V1
typedef NVDRS_SETTING_V1 | NVDRS_SETTING
typedef struct _NVDRS_APPLICATION_V1 | NVDRS_APPLICATION_V1
typedef struct _NVDRS_APPLICATION_V2 | NVDRS_APPLICATION_V2
typedef struct _NVDRS_APPLICATION_V3 | NVDRS_APPLICATION_V3
typedef struct _NVDRS_APPLICATION_V4 | NVDRS_APPLICATION_V4
typedef NVDRS_APPLICATION_V4 | NVDRS_APPLICATION
typedef struct _NVDRS_PROFILE_V1 | NVDRS_PROFILE_V1
typedef NVDRS_PROFILE_V1 | NVDRS_PROFILE
typedef struct _NV_DISPLAY_DRIVER_INFO | NV_DISPLAY_DRIVER_INFO_V1
typedef struct _NV_DISPLAY_DRIVER_INFO_V2 | NV_DISPLAY_DRIVER_INFO_V2
typedef NV_DISPLAY_DRIVER_INFO_V2 | NV_DISPLAY_DRIVER_INFO
typedef struct _NV_PHYSICAL_GPU_HANDLE_DATA | NV_PHYSICAL_GPU_HANDLE_DATA
typedef struct _NV_PHYSICAL_GPUS | NV_PHYSICAL_GPUS_V1
typedef NV_PHYSICAL_GPUS_V1 | NV_PHYSICAL_GPUS
typedef struct _NV_LOGICAL_GPU_HANDLE_DATA | NV_LOGICAL_GPU_HANDLE_DATA
typedef struct _NV_LOGICAL_GPUS | NV_LOGICAL_GPUS_V1
typedef NV_LOGICAL_GPUS_V1 | NV_LOGICAL_GPUS
typedef struct _NV_CLIENT_CALLBACK_SETTINGS_SUPER_V1 | NV_CLIENT_CALLBACK_SETTINGS_SUPER_V1
typedef NV_CLIENT_CALLBACK_SETTINGS_SUPER_V1 | NV_GPU_CLIENT_CALLBACK_SETTINGS_SUPER_V1
typedef struct _NV_GPU_CLIENT_PERIODIC_CALLBACK_SETTINGS_SUPER_V1 | NV_GPU_CLIENT_PERIODIC_CALLBACK_SETTINGS_SUPER_V1
typedef struct _NV_GPU_CLIENT_CALLBACK_DATA_SUPER_V1 | NV_GPU_CLIENT_CALLBACK_DATA_SUPER_V1
typedef enum _NV_GPU_CLIENT_UTIL_DOMAIN_ID | NV_GPU_CLIENT_UTIL_DOMAIN_ID
typedef struct _NV_GPU_CLIENT_UTILIZATION_DATA_V1 | NV_GPU_CLIENT_UTILIZATION_DATA_V1
typedef struct _NV_GPU_CLIENT_CALLBACK_UTILIZATION_DATA_V1 | NV_GPU_CLIENT_CALLBACK_UTILIZATION_DATA_V1
typedef void(__cdecl * | NV_GPU_CLIENT_UTILIZATION_PERIODIC_CALLBACK_V1) (NvPhysicalGpuHandle hPhysicalGpu, NV_GPU_CLIENT_CALLBACK_UTILIZATION_DATA_V1 *pData)
typedef struct _NV_GPU_CLIENT_UTILIZATION_PERIODIC_CALLBACK_SETTINGS_V1 | NV_GPU_CLIENT_UTILIZATION_PERIODIC_CALLBACK_SETTINGS_V1
typedef NV_GPU_CLIENT_UTILIZATION_PERIODIC_CALLBACK_SETTINGS_V1 | NV_GPU_CLIENT_UTILIZATION_PERIODIC_CALLBACK_SETTINGS

Enumerations

enum _NV_DP_LINK_RATE {
NV_DP_1_62GBPS = 6 , NV_DP_2_70GBPS = 0xA , NV_DP_5_40GBPS = 0x14 , NV_DP_8_10GBPS = 0x1E ,
NV_EDP_2_16GBPS = 8 , NV_EDP_2_43GBPS = 9 , NV_EDP_3_24GBPS = 0xC , NV_EDP_4_32GBPS = 0x10
}
enum | _NV_DP_LANE_COUNT { NV_DP_1_LANE = 1 , NV_DP_2_LANE = 2 , NV_DP_4_LANE = 4 }
enum | _NV_DP_COLOR_FORMAT { NV_DP_COLOR_FORMAT_RGB = 0 , NV_DP_COLOR_FORMAT_YCbCr422 , NV_DP_COLOR_FORMAT_YCbCr444 }
enum | _NV_DP_COLORIMETRY { NV_DP_COLORIMETRY_RGB = 0 , NV_DP_COLORIMETRY_YCbCr_ITU601 , NV_DP_COLORIMETRY_YCbCr_ITU709 }
enum | _NV_DP_DYNAMIC_RANGE { NV_DP_DYNAMIC_RANGE_VESA = 0 , NV_DP_DYNAMIC_RANGE_CEA }
enum _NV_DP_BPC {
NV_DP_BPC_DEFAULT = 0 , NV_DP_BPC_6 , NV_DP_BPC_8 , NV_DP_BPC_10 ,
NV_DP_BPC_12 , NV_DP_BPC_16
}
enum NV_EDID_FLAG {
NV_EDID_FLAG_DEFAULT = 0 , NV_EDID_FLAG_RAW = 1 , NV_EDID_FLAG_COOKED = 2 , NV_EDID_FLAG_FORCED = 3 ,
NV_EDID_FLAG_INF = 4 , NV_EDID_FLAG_HW = 5
}
enum _NV_GPU_CONNECTOR_TYPE {
NVAPI_GPU_CONNECTOR_VGA_15_PIN = 0x00000000 , NVAPI_GPU_CONNECTOR_TV_COMPOSITE = 0x00000010 , NVAPI_GPU_CONNECTOR_TV_SVIDEO = 0x00000011 , NVAPI_GPU_CONNECTOR_TV_HDTV_COMPONENT = 0x00000013 ,
NVAPI_GPU_CONNECTOR_TV_SCART = 0x00000014 , NVAPI_GPU_CONNECTOR_TV_COMPOSITE_SCART_ON_EIAJ4120 = 0x00000016 , NVAPI_GPU_CONNECTOR_TV_HDTV_EIAJ4120 = 0x00000017 , NVAPI_GPU_CONNECTOR_PC_POD_HDTV_YPRPB = 0x00000018 ,
NVAPI_GPU_CONNECTOR_PC_POD_SVIDEO = 0x00000019 , NVAPI_GPU_CONNECTOR_PC_POD_COMPOSITE = 0x0000001A , NVAPI_GPU_CONNECTOR_DVI_I_TV_SVIDEO = 0x00000020 , NVAPI_GPU_CONNECTOR_DVI_I_TV_COMPOSITE = 0x00000021 ,
NVAPI_GPU_CONNECTOR_DVI_I = 0x00000030 , NVAPI_GPU_CONNECTOR_DVI_D = 0x00000031 , NVAPI_GPU_CONNECTOR_ADC = 0x00000032 , NVAPI_GPU_CONNECTOR_LFH_DVI_I_1 = 0x00000038 ,
NVAPI_GPU_CONNECTOR_LFH_DVI_I_2 = 0x00000039 , NVAPI_GPU_CONNECTOR_SPWG = 0x00000040 , NVAPI_GPU_CONNECTOR_OEM = 0x00000041 , NVAPI_GPU_CONNECTOR_DISPLAYPORT_EXTERNAL = 0x00000046 ,
NVAPI_GPU_CONNECTOR_DISPLAYPORT_INTERNAL = 0x00000047 , NVAPI_GPU_CONNECTOR_DISPLAYPORT_MINI_EXT = 0x00000048 , NVAPI_GPU_CONNECTOR_HDMI_A = 0x00000061 , NVAPI_GPU_CONNECTOR_HDMI_C_MINI = 0x00000063 ,
NVAPI_GPU_CONNECTOR_LFH_DISPLAYPORT_1 = 0x00000064 , NVAPI_GPU_CONNECTOR_LFH_DISPLAYPORT_2 = 0x00000065 , NVAPI_GPU_CONNECTOR_VIRTUAL_WFD = 0x00000070 , NVAPI_GPU_CONNECTOR_USB_C = 0x00000071 ,
NVAPI_GPU_CONNECTOR_UNKNOWN = 0xFFFFFFFF
}
enum _NV_DISPLAY_TV_FORMAT {
NV_DISPLAY_TV_FORMAT_NONE = 0 , NV_DISPLAY_TV_FORMAT_SD_NTSCM = 0x00000001 , NV_DISPLAY_TV_FORMAT_SD_NTSCJ = 0x00000002 , NV_DISPLAY_TV_FORMAT_SD_PALM = 0x00000004 ,
NV_DISPLAY_TV_FORMAT_SD_PALBDGH = 0x00000008 , NV_DISPLAY_TV_FORMAT_SD_PALN = 0x00000010 , NV_DISPLAY_TV_FORMAT_SD_PALNC = 0x00000020 , NV_DISPLAY_TV_FORMAT_SD_576i = 0x00000100 ,
NV_DISPLAY_TV_FORMAT_SD_480i = 0x00000200 , NV_DISPLAY_TV_FORMAT_ED_480p = 0x00000400 , NV_DISPLAY_TV_FORMAT_ED_576p = 0x00000800 , NV_DISPLAY_TV_FORMAT_HD_720p = 0x00001000 ,
NV_DISPLAY_TV_FORMAT_HD_1080i = 0x00002000 , NV_DISPLAY_TV_FORMAT_HD_1080p = 0x00004000 , NV_DISPLAY_TV_FORMAT_HD_720p50 = 0x00008000 , NV_DISPLAY_TV_FORMAT_HD_1080p24 = 0x00010000 ,
NV_DISPLAY_TV_FORMAT_HD_1080i50 = 0x00020000 , NV_DISPLAY_TV_FORMAT_HD_1080p50 = 0x00040000 , NV_DISPLAY_TV_FORMAT_UHD_4Kp30 = 0x00080000 , NV_DISPLAY_TV_FORMAT_UHD_4Kp30_3840 = NV_DISPLAY_TV_FORMAT_UHD_4Kp30 ,
NV_DISPLAY_TV_FORMAT_UHD_4Kp25 = 0x00100000 , NV_DISPLAY_TV_FORMAT_UHD_4Kp25_3840 = NV_DISPLAY_TV_FORMAT_UHD_4Kp25 , NV_DISPLAY_TV_FORMAT_UHD_4Kp24 = 0x00200000 , NV_DISPLAY_TV_FORMAT_UHD_4Kp24_3840 = NV_DISPLAY_TV_FORMAT_UHD_4Kp24 ,
NV_DISPLAY_TV_FORMAT_UHD_4Kp24_SMPTE = 0x00400000 , NV_DISPLAY_TV_FORMAT_UHD_4Kp50_3840 = 0x00800000 , NV_DISPLAY_TV_FORMAT_UHD_4Kp60_3840 = 0x00900000 , NV_DISPLAY_TV_FORMAT_UHD_4Kp30_4096 = 0x00A00000 ,
NV_DISPLAY_TV_FORMAT_UHD_4Kp25_4096 = 0x00B00000 , NV_DISPLAY_TV_FORMAT_UHD_4Kp24_4096 = 0x00C00000 , NV_DISPLAY_TV_FORMAT_UHD_4Kp50_4096 = 0x00D00000 , NV_DISPLAY_TV_FORMAT_UHD_4Kp60_4096 = 0x00E00000 ,
NV_DISPLAY_TV_FORMAT_UHD_8Kp24_7680 = 0x01000000 , NV_DISPLAY_TV_FORMAT_UHD_8Kp25_7680 = 0x02000000 , NV_DISPLAY_TV_FORMAT_UHD_8Kp30_7680 = 0x04000000 , NV_DISPLAY_TV_FORMAT_UHD_8Kp48_7680 = 0x08000000 ,
NV_DISPLAY_TV_FORMAT_UHD_8Kp50_7680 = 0x09000000 , NV_DISPLAY_TV_FORMAT_UHD_8Kp60_7680 = 0x0A000000 , NV_DISPLAY_TV_FORMAT_UHD_8Kp100_7680 = 0x0B000000 , NV_DISPLAY_TV_FORMAT_UHD_8Kp120_7680 = 0x0C000000 ,
NV_DISPLAY_TV_FORMAT_UHD_4Kp48_3840 = 0x0D000000 , NV_DISPLAY_TV_FORMAT_UHD_4Kp48_4096 = 0x0E000000 , NV_DISPLAY_TV_FORMAT_UHD_4Kp100_4096 = 0x0F000000 , NV_DISPLAY_TV_FORMAT_UHD_4Kp100_3840 = 0x10000000 ,
NV_DISPLAY_TV_FORMAT_UHD_4Kp120_4096 = 0x11000000 , NV_DISPLAY_TV_FORMAT_UHD_4Kp120_3840 = 0x12000000 , NV_DISPLAY_TV_FORMAT_UHD_4Kp100_5120 = 0x13000000 , NV_DISPLAY_TV_FORMAT_UHD_4Kp120_5120 = 0x14000000 ,
NV_DISPLAY_TV_FORMAT_UHD_4Kp24_5120 = 0x15000000 , NV_DISPLAY_TV_FORMAT_UHD_4Kp25_5120 = 0x16000000 , NV_DISPLAY_TV_FORMAT_UHD_4Kp30_5120 = 0x17000000 , NV_DISPLAY_TV_FORMAT_UHD_4Kp48_5120 = 0x18000000 ,
NV_DISPLAY_TV_FORMAT_UHD_4Kp50_5120 = 0x19000000 , NV_DISPLAY_TV_FORMAT_UHD_4Kp60_5120 = 0x20000000 , NV_DISPLAY_TV_FORMAT_UHD_10Kp24_10240 = 0x21000000 , NV_DISPLAY_TV_FORMAT_UHD_10Kp25_10240 = 0x22000000 ,
NV_DISPLAY_TV_FORMAT_UHD_10Kp30_10240 = 0x23000000 , NV_DISPLAY_TV_FORMAT_UHD_10Kp48_10240 = 0x24000000 , NV_DISPLAY_TV_FORMAT_UHD_10Kp50_10240 = 0x25000000 , NV_DISPLAY_TV_FORMAT_UHD_10Kp60_10240 = 0x26000000 ,
NV_DISPLAY_TV_FORMAT_UHD_10Kp100_10240 = 0x27000000 , NV_DISPLAY_TV_FORMAT_UHD_10Kp120_10240 = 0x28000000 , NV_DISPLAY_TV_FORMAT_SD_OTHER = 0x30000000 , NV_DISPLAY_TV_FORMAT_ED_OTHER = 0x40000000 ,
NV_DISPLAY_TV_FORMAT_HD_OTHER = 0x50000000 , NV_DISPLAY_TV_FORMAT_ANY = 0x80000000
}
enum _NV_SCALING {
NV_SCALING_DEFAULT = 0 , NV_SCALING_GPU_SCALING_TO_CLOSEST = 1 , NV_SCALING_GPU_SCALING_TO_NATIVE = 2 , NV_SCALING_GPU_SCANOUT_TO_NATIVE = 3 ,
NV_SCALING_GPU_SCALING_TO_ASPECT_SCANOUT_TO_NATIVE = 5 , NV_SCALING_GPU_SCALING_TO_ASPECT_SCANOUT_TO_CLOSEST = 6 , NV_SCALING_GPU_SCANOUT_TO_CLOSEST = 7 , NV_SCALING_GPU_INTEGER_ASPECT_SCALING = 8 ,
NV_SCALING_MONITOR_SCALING = NV_SCALING_GPU_SCALING_TO_CLOSEST , NV_SCALING_ADAPTER_SCALING = NV_SCALING_GPU_SCALING_TO_NATIVE , NV_SCALING_CENTERED = NV_SCALING_GPU_SCANOUT_TO_NATIVE , NV_SCALING_ASPECT_SCALING = NV_SCALING_GPU_SCALING_TO_ASPECT_SCANOUT_TO_NATIVE ,
NV_SCALING_CUSTOMIZED = 255
}
enum _NV_ROTATE {
NV_ROTATE_0 = 0 , NV_ROTATE_90 = 1 , NV_ROTATE_180 = 2 , NV_ROTATE_270 = 3 ,
NV_ROTATE_IGNORED = 4
}
enum _NV_FORMAT {
NV_FORMAT_UNKNOWN = 0 , NV_FORMAT_P8 = 41 , NV_FORMAT_R5G6B5 = 23 , NV_FORMAT_A8R8G8B8 = 21 ,
NV_FORMAT_A16B16G16R16F = 113
}
enum _NV_TIMING_OVERRIDE {
NV_TIMING_OVERRIDE_CURRENT = 0 , NV_TIMING_OVERRIDE_AUTO , NV_TIMING_OVERRIDE_EDID , NV_TIMING_OVERRIDE_DMT ,
NV_TIMING_OVERRIDE_DMT_RB , NV_TIMING_OVERRIDE_CVT , NV_TIMING_OVERRIDE_CVT_RB , NV_TIMING_OVERRIDE_GTF ,
NV_TIMING_OVERRIDE_EIA861 , NV_TIMING_OVERRIDE_ANALOG_TV , NV_TIMING_OVERRIDE_CUST , NV_TIMING_OVERRIDE_NV_PREDEFINED ,
NV_TIMING_OVERRIDE_NV_PSF = NV_TIMING_OVERRIDE_NV_PREDEFINED , NV_TIMING_OVERRIDE_NV_ASPR , NV_TIMING_OVERRIDE_SDI , NV_TIMING_OVRRIDE_MAX
}
enum | _NV_DISPLAYCONFIG_SPANNING_ORIENTATION { NV_DISPLAYCONFIG_SPAN_NONE = 0 , NV_DISPLAYCONFIG_SPAN_HORIZONTAL = 1 , NV_DISPLAYCONFIG_SPAN_VERTICAL = 2 }
enum _NV_DISPLAYCONFIG_FLAGS {
NV_DISPLAYCONFIG_VALIDATE_ONLY = 0x00000001 , NV_DISPLAYCONFIG_SAVE_TO_PERSISTENCE = 0x00000002 , NV_DISPLAYCONFIG_DRIVER_RELOAD_ALLOWED = 0x00000004 , NV_DISPLAYCONFIG_FORCE_MODE_ENUMERATION = 0x00000008 ,
NV_FORCE_COMMIT_VIDPN = 0x00000010
}
enum | _NV_GPU_PERF_VOLTAGE_INFO_DOMAIN_ID { NVAPI_GPU_PERF_VOLTAGE_INFO_DOMAIN_CORE = 0 , NVAPI_GPU_PERF_VOLTAGE_INFO_DOMAIN_UNDEFINED = NVAPI_MAX_GPU_PERF_VOLTAGES }
enum _NV_GPU_PUBLIC_CLOCK_ID {
NVAPI_GPU_PUBLIC_CLOCK_GRAPHICS = 0 , NVAPI_GPU_PUBLIC_CLOCK_MEMORY = 4 , NVAPI_GPU_PUBLIC_CLOCK_PROCESSOR = 7 , NVAPI_GPU_PUBLIC_CLOCK_VIDEO = 8 ,
NVAPI_GPU_PUBLIC_CLOCK_UNDEFINED = NVAPI_MAX_GPU_PUBLIC_CLOCKS
}
enum _NV_GPU_PERF_PSTATE_ID {
NVAPI_GPU_PERF_PSTATE_P0 = 0 , NVAPI_GPU_PERF_PSTATE_P1 , NVAPI_GPU_PERF_PSTATE_P2 , NVAPI_GPU_PERF_PSTATE_P3 ,
NVAPI_GPU_PERF_PSTATE_P4 , NVAPI_GPU_PERF_PSTATE_P5 , NVAPI_GPU_PERF_PSTATE_P6 , NVAPI_GPU_PERF_PSTATE_P7 ,
NVAPI_GPU_PERF_PSTATE_P8 , NVAPI_GPU_PERF_PSTATE_P9 , NVAPI_GPU_PERF_PSTATE_P10 , NVAPI_GPU_PERF_PSTATE_P11 ,
NVAPI_GPU_PERF_PSTATE_P12 , NVAPI_GPU_PERF_PSTATE_P13 , NVAPI_GPU_PERF_PSTATE_P14 , NVAPI_GPU_PERF_PSTATE_P15 ,
NVAPI_GPU_PERF_PSTATE_UNDEFINED = NVAPI_MAX_GPU_PERF_PSTATES , NVAPI_GPU_PERF_PSTATE_ALL
}
enum | NV_GPU_PERF_PSTATE20_CLOCK_TYPE_ID { NVAPI_GPU_PERF_PSTATE20_CLOCK_TYPE_SINGLE = 0 , NVAPI_GPU_PERF_PSTATE20_CLOCK_TYPE_RANGE }
enum | NV_SYSTEM_TYPE { NV_SYSTEM_TYPE_UNKNOWN = 0 , NV_SYSTEM_TYPE_LAPTOP = 1 , NV_SYSTEM_TYPE_DESKTOP = 2 }
enum | _NV_GPU_OUTPUT_TYPE { NVAPI_GPU_OUTPUT_UNKNOWN = 0 , NVAPI_GPU_OUTPUT_CRT = 1 , NVAPI_GPU_OUTPUT_DFP = 2 , NVAPI_GPU_OUTPUT_TV = 3 }
enum | _NV_GPU_TYPE { NV_SYSTEM_TYPE_GPU_UNKNOWN = 0 , NV_SYSTEM_TYPE_IGPU = 1 , NV_SYSTEM_TYPE_DGPU = 2 }
enum _NV_GPU_BUS_TYPE {
NVAPI_GPU_BUS_TYPE_UNDEFINED = 0 , NVAPI_GPU_BUS_TYPE_PCI = 1 , NVAPI_GPU_BUS_TYPE_AGP = 2 , NVAPI_GPU_BUS_TYPE_PCI_EXPRESS = 3 ,
NVAPI_GPU_BUS_TYPE_FPCI = 4 , NVAPI_GPU_BUS_TYPE_AXI = 5
}
enum _NV_GPU_ARCHITECTURE_ID {
NV_GPU_ARCHITECTURE_T2X = 0xE0000020 , NV_GPU_ARCHITECTURE_T3X = 0xE0000030 , NV_GPU_ARCHITECTURE_T4X = 0xE0000040 , NV_GPU_ARCHITECTURE_T12X = 0xE0000040 ,
NV_GPU_ARCHITECTURE_NV40 = 0x00000040 , NV_GPU_ARCHITECTURE_NV50 = 0x00000050 , NV_GPU_ARCHITECTURE_G78 = 0x00000060 , NV_GPU_ARCHITECTURE_G80 = 0x00000080 ,
NV_GPU_ARCHITECTURE_G90 = 0x00000090 , NV_GPU_ARCHITECTURE_GT200 = 0x000000A0 , NV_GPU_ARCHITECTURE_GF100 = 0x000000C0 , NV_GPU_ARCHITECTURE_GF110 = 0x000000D0 ,
NV_GPU_ARCHITECTURE_GK100 = 0x000000E0 , NV_GPU_ARCHITECTURE_GK110 = 0x000000F0 , NV_GPU_ARCHITECTURE_GK200 = 0x00000100 , NV_GPU_ARCHITECTURE_GM000 = 0x00000110 ,
NV_GPU_ARCHITECTURE_GM200 = 0x00000120 , NV_GPU_ARCHITECTURE_GP100 = 0x00000130 , NV_GPU_ARCHITECTURE_GV100 = 0x00000140 , NV_GPU_ARCHITECTURE_GV110 = 0x00000150 ,
NV_GPU_ARCHITECTURE_TU100 = 0x00000160 , NV_GPU_ARCHITECTURE_GA100 = 0x00000170 , NV_GPU_ARCHITECTURE_AD100 = 0x00000190
}
enum _NV_GPU_ARCH_IMPLEMENTATION_ID {
NV_GPU_ARCH_IMPLEMENTATION_T20 = 0x00000000 , NV_GPU_ARCH_IMPLEMENTATION_T30 = 0x00000000 , NV_GPU_ARCH_IMPLEMENTATION_T35 = 0x00000005 , NV_GPU_ARCH_IMPLEMENTATION_T40 = 0x00000000 ,
NV_GPU_ARCH_IMPLEMENTATION_T124 = 0x00000000 , NV_GPU_ARCH_IMPLEMENTATION_NV40 = 0x00000000 , NV_GPU_ARCH_IMPLEMENTATION_NV41 = 0x00000001 , NV_GPU_ARCH_IMPLEMENTATION_NV42 = 0x00000002 ,
NV_GPU_ARCH_IMPLEMENTATION_NV43 = 0x00000003 , NV_GPU_ARCH_IMPLEMENTATION_NV44 = 0x00000004 , NV_GPU_ARCH_IMPLEMENTATION_NV44A = 0x0000000A , NV_GPU_ARCH_IMPLEMENTATION_NV46 = 0x00000006 ,
NV_GPU_ARCH_IMPLEMENTATION_NV47 = 0x00000007 , NV_GPU_ARCH_IMPLEMENTATION_NV49 = 0x00000009 , NV_GPU_ARCH_IMPLEMENTATION_NV4B = 0x0000000B , NV_GPU_ARCH_IMPLEMENTATION_NV4C = 0x0000000C ,
NV_GPU_ARCH_IMPLEMENTATION_NV4E = 0x0000000E , NV_GPU_ARCH_IMPLEMENTATION_NV50 = 0x00000000 , NV_GPU_ARCH_IMPLEMENTATION_NV63 = 0x00000003 , NV_GPU_ARCH_IMPLEMENTATION_NV67 = 0x00000007 ,
NV_GPU_ARCH_IMPLEMENTATION_G84 = 0x00000004 , NV_GPU_ARCH_IMPLEMENTATION_G86 = 0x00000006 , NV_GPU_ARCH_IMPLEMENTATION_G92 = 0x00000002 , NV_GPU_ARCH_IMPLEMENTATION_G94 = 0x00000004 ,
NV_GPU_ARCH_IMPLEMENTATION_G96 = 0x00000006 , NV_GPU_ARCH_IMPLEMENTATION_G98 = 0x00000008 , NV_GPU_ARCH_IMPLEMENTATION_GT200 = 0x00000000 , NV_GPU_ARCH_IMPLEMENTATION_GT212 = 0x00000002 ,
NV_GPU_ARCH_IMPLEMENTATION_GT214 = 0x00000004 , NV_GPU_ARCH_IMPLEMENTATION_GT215 = 0x00000003 , NV_GPU_ARCH_IMPLEMENTATION_GT216 = 0x00000005 , NV_GPU_ARCH_IMPLEMENTATION_GT218 = 0x00000008 ,
NV_GPU_ARCH_IMPLEMENTATION_MCP77 = 0x0000000A , NV_GPU_ARCH_IMPLEMENTATION_GT21C = 0x0000000B , NV_GPU_ARCH_IMPLEMENTATION_MCP79 = 0x0000000C , NV_GPU_ARCH_IMPLEMENTATION_GT21A = 0x0000000D ,
NV_GPU_ARCH_IMPLEMENTATION_MCP89 = 0x0000000F , NV_GPU_ARCH_IMPLEMENTATION_GF100 = 0x00000000 , NV_GPU_ARCH_IMPLEMENTATION_GF104 = 0x00000004 , NV_GPU_ARCH_IMPLEMENTATION_GF106 = 0x00000003 ,
NV_GPU_ARCH_IMPLEMENTATION_GF108 = 0x00000001 , NV_GPU_ARCH_IMPLEMENTATION_GF110 = 0x00000000 , NV_GPU_ARCH_IMPLEMENTATION_GF116 = 0x00000006 , NV_GPU_ARCH_IMPLEMENTATION_GF117 = 0x00000007 ,
NV_GPU_ARCH_IMPLEMENTATION_GF118 = 0x00000008 , NV_GPU_ARCH_IMPLEMENTATION_GF119 = 0x00000009 , NV_GPU_ARCH_IMPLEMENTATION_GK104 = 0x00000004 , NV_GPU_ARCH_IMPLEMENTATION_GK106 = 0x00000006 ,
NV_GPU_ARCH_IMPLEMENTATION_GK107 = 0x00000007 , NV_GPU_ARCH_IMPLEMENTATION_GK20A = 0x0000000A , NV_GPU_ARCH_IMPLEMENTATION_GK110 = 0x00000000 , NV_GPU_ARCH_IMPLEMENTATION_GK208 = 0x00000008 ,
NV_GPU_ARCH_IMPLEMENTATION_GM204 = 0x00000004 , NV_GPU_ARCH_IMPLEMENTATION_GM206 = 0x00000006 , NV_GPU_ARCH_IMPLEMENTATION_GP100 = 0x00000000 , NV_GPU_ARCH_IMPLEMENTATION_GP000 = 0x00000001 ,
NV_GPU_ARCH_IMPLEMENTATION_GP102 = 0x00000002 , NV_GPU_ARCH_IMPLEMENTATION_GP104 = 0x00000004 , NV_GPU_ARCH_IMPLEMENTATION_GP106 = 0x00000006 , NV_GPU_ARCH_IMPLEMENTATION_GP107 = 0x00000007 ,
NV_GPU_ARCH_IMPLEMENTATION_GP108 = 0x00000008 , NV_GPU_ARCH_IMPLEMENTATION_GV100 = 0x00000000 , NV_GPU_ARCH_IMPLEMENTATION_GV10B = 0x0000000B , NV_GPU_ARCH_IMPLEMENTATION_TU100 = 0x00000000 ,
NV_GPU_ARCH_IMPLEMENTATION_TU102 = 0x00000002 , NV_GPU_ARCH_IMPLEMENTATION_TU104 = 0x00000004 , NV_GPU_ARCH_IMPLEMENTATION_TU106 = 0x00000006 , NV_GPU_ARCH_IMPLEMENTATION_TU116 = 0x00000008 ,
NV_GPU_ARCH_IMPLEMENTATION_TU117 = 0x00000007 , NV_GPU_ARCH_IMPLEMENTATION_TU000 = 0x00000001 , NV_GPU_ARCH_IMPLEMENTATION_GA100 = 0x00000000 , NV_GPU_ARCH_IMPLEMENTATION_GA102 = 0x00000002 ,
NV_GPU_ARCH_IMPLEMENTATION_GA104 = 0x00000004 , NV_GPU_ARCH_IMPLEMENTATION_AD102 = 0x00000002 , NV_GPU_ARCH_IMPLEMENTATION_AD103 = 0x00000003 , NV_GPU_ARCH_IMPLEMENTATION_AD104 = 0x00000004
}
enum _NV_GPU_CHIP_REVISION {
NV_GPU_CHIP_REV_EMULATION_QT = 0x00000000 , NV_GPU_CHIP_REV_EMULATION_FPGA = 0x00000001 , NV_GPU_CHIP_REV_A01 = 0x00000011 , NV_GPU_CHIP_REV_A02 = 0x00000012 ,
NV_GPU_CHIP_REV_A03 = 0x00000013 , NV_GPU_CHIP_REV_UNKNOWN = 0xffffffff
}
enum NVAPI_GPU_WORKSTATION_FEATURE_MASK {
NVAPI_GPU_WORKSTATION_FEATURE_MASK_SWAPGROUP = 0x00000001 , NVAPI_GPU_WORKSTATION_FEATURE_MASK_STEREO = 0x00000010 , NVAPI_GPU_WORKSTATION_FEATURE_MASK_WARPING = 0x00000100 , NVAPI_GPU_WORKSTATION_FEATURE_MASK_PIXINTENSITY = 0x00000200 ,
NVAPI_GPU_WORKSTATION_FEATURE_MASK_GRAYSCALE = 0x00000400 , NVAPI_GPU_WORKSTATION_FEATURE_MASK_BPC10 = 0x00001000
}
enum | _NV_GPU_HDCP_FUSE_STATE { NV_GPU_HDCP_FUSE_STATE_UNKNOWN = 0 , NV_GPU_HDCP_FUSE_STATE_DISABLED = 1 , NV_GPU_HDCP_FUSE_STATE_ENABLED = 2 }
enum _NV_GPU_HDCP_KEY_SOURCE {
NV_GPU_HDCP_KEY_SOURCE_UNKNOWN = 0 , NV_GPU_HDCP_KEY_SOURCE_NONE = 1 , NV_GPU_HDCP_KEY_SOURCE_CRYPTO_ROM = 2 , NV_GPU_HDCP_KEY_SOURCE_SBIOS = 3 ,
NV_GPU_HDCP_KEY_SOURCE_I2C_ROM = 4 , NV_GPU_HDCP_KEY_SOURCE_FUSES = 5
}
enum | _NV_GPU_HDCP_KEY_SOURCE_STATE { NV_GPU_HDCP_KEY_SOURCE_STATE_UNKNOWN = 0 , NV_GPU_HDCP_KEY_SOURCE_STATE_ABSENT = 1 , NV_GPU_HDCP_KEY_SOURCE_STATE_PRESENT = 2 }
enum | _NV_ECC_CONFIGURATION { NV_ECC_CONFIGURATION_NOT_SUPPORTED = 0 , NV_ECC_CONFIGURATION_DEFERRED , NV_ECC_CONFIGURATION_IMMEDIATE }
enum NV_QSYNC_EVENT {
NV_QSYNC_EVENT_NONE = 0 , NV_QSYNC_EVENT_SYNC_LOSS = 1 , NV_QSYNC_EVENT_SYNC_GAIN = 2 , NV_QSYNC_EVENT_HOUSESYNC_GAIN = 3 ,
NV_QSYNC_EVENT_HOUSESYNC_LOSS = 4 , NV_QSYNC_EVENT_RJ45_GAIN = 5 , NV_QSYNC_EVENT_RJ45_LOSS = 6
}
enum | NV_EVENT_TYPE { NV_EVENT_TYPE_NONE = 0 , NV_EVENT_TYPE_QSYNC = 6 }
enum | _NV_GPU_WORKSTATION_FEATURE_TYPE { NV_GPU_WORKSTATION_FEATURE_TYPE_NVIDIA_RTX_VR_READY = 1 , NV_GPU_WORKSTATION_FEATURE_TYPE_QUADRO_VR_READY = NV_GPU_WORKSTATION_FEATURE_TYPE_NVIDIA_RTX_VR_READY , NV_GPU_WORKSTATION_FEATURE_TYPE_PROVIZ = 2 }
enum | NV_GPU_WARPING_VERTICE_FORMAT { NV_GPU_WARPING_VERTICE_FORMAT_TRIANGLESTRIP_XYUVRQ = 0 , NV_GPU_WARPING_VERTICE_FORMAT_TRIANGLES_XYUVRQ = 1 }
enum | NV_GPU_SCANOUT_COMPOSITION_PARAMETER { NV_GPU_SCANOUT_COMPOSITION_PARAMETER_WARPING_RESAMPLING_METHOD = 0 }
enum NV_GPU_SCANOUT_COMPOSITION_PARAMETER_VALUE {
NV_GPU_SCANOUT_COMPOSITION_PARAMETER_SET_TO_DEFAULT = 0 , NV_GPU_SCANOUT_COMPOSITION_PARAMETER_VALUE_WARPING_RESAMPLING_METHOD_BILINEAR = 0x100 , NV_GPU_SCANOUT_COMPOSITION_PARAMETER_VALUE_WARPING_RESAMPLING_METHOD_BICUBIC_TRIANGULAR = 0x101 , NV_GPU_SCANOUT_COMPOSITION_PARAMETER_VALUE_WARPING_RESAMPLING_METHOD_BICUBIC_BELL_SHAPED = 0x102 ,
NV_GPU_SCANOUT_COMPOSITION_PARAMETER_VALUE_WARPING_RESAMPLING_METHOD_BICUBIC_BSPLINE = 0x103 , NV_GPU_SCANOUT_COMPOSITION_PARAMETER_VALUE_WARPING_RESAMPLING_METHOD_BICUBIC_ADAPTIVE_TRIANGULAR = 0x104 , NV_GPU_SCANOUT_COMPOSITION_PARAMETER_VALUE_WARPING_RESAMPLING_METHOD_BICUBIC_ADAPTIVE_BELL_SHAPED = 0x105 , NV_GPU_SCANOUT_COMPOSITION_PARAMETER_VALUE_WARPING_RESAMPLING_METHOD_BICUBIC_ADAPTIVE_BSPLINE = 0x106
}
enum | _NV_VIRTUALIZATION_MODE { NV_VIRTUALIZATION_MODE_NONE = 0 , NV_VIRTUALIZATION_MODE_NMOS = 1 , NV_VIRTUALIZATION_MODE_VGX = 2 , NV_VIRTUALIZATION_MODE_HOST_VGPU = 3 }
enum _NV_ADAPTER_TYPE {
NV_ADAPTER_TYPE_UNKNOWN = 0x0 , NV_ADAPTER_TYPE_WDDM = NV_BIT(0) , NV_ADAPTER_TYPE_MCDM = NV_BIT(1) , NV_ADAPTER_TYPE_TCC = NV_BIT(2) ,
NV_ADAPTER_TYPE_LAST = 0xFFFFFFFF
}
enum _NVAPI_GPU_PERF_DECREASE {
NV_GPU_PERF_DECREASE_NONE = 0 , NV_GPU_PERF_DECREASE_REASON_THERMAL_PROTECTION = 0x00000001 , NV_GPU_PERF_DECREASE_REASON_POWER_CONTROL = 0x00000002 , NV_GPU_PERF_DECREASE_REASON_AC_BATT = 0x00000004 ,
NV_GPU_PERF_DECREASE_REASON_API_TRIGGERED = 0x00000008 , NV_GPU_PERF_DECREASE_REASON_INSUFFICIENT_POWER = 0x00000010 , NV_GPU_PERF_DECREASE_REASON_UNKNOWN = 0x80000000
}
enum NV_THERMAL_TARGET {
NVAPI_THERMAL_TARGET_NONE = 0 , NVAPI_THERMAL_TARGET_GPU = 1 , NVAPI_THERMAL_TARGET_MEMORY = 2 , NVAPI_THERMAL_TARGET_POWER_SUPPLY = 4 ,
NVAPI_THERMAL_TARGET_BOARD = 8 , NVAPI_THERMAL_TARGET_VCD_BOARD = 9 , NVAPI_THERMAL_TARGET_VCD_INLET = 10 , NVAPI_THERMAL_TARGET_VCD_OUTLET = 11 ,
NVAPI_THERMAL_TARGET_ALL = 15 , NVAPI_THERMAL_TARGET_UNKNOWN = -1
}
enum NV_THERMAL_CONTROLLER {
NVAPI_THERMAL_CONTROLLER_NONE = 0 , NVAPI_THERMAL_CONTROLLER_GPU_INTERNAL , NVAPI_THERMAL_CONTROLLER_ADM1032 , NVAPI_THERMAL_CONTROLLER_MAX6649 ,
NVAPI_THERMAL_CONTROLLER_MAX1617 , NVAPI_THERMAL_CONTROLLER_LM99 , NVAPI_THERMAL_CONTROLLER_LM89 , NVAPI_THERMAL_CONTROLLER_LM64 ,
NVAPI_THERMAL_CONTROLLER_ADT7473 , NVAPI_THERMAL_CONTROLLER_SBMAX6649 , NVAPI_THERMAL_CONTROLLER_VBIOSEVT , NVAPI_THERMAL_CONTROLLER_OS ,
NVAPI_THERMAL_CONTROLLER_UNKNOWN = -1
}
enum | NV_GPU_CLOCK_FREQUENCIES_CLOCK_TYPE { NV_GPU_CLOCK_FREQUENCIES_CURRENT_FREQ = 0 , NV_GPU_CLOCK_FREQUENCIES_BASE_CLOCK = 1 , NV_GPU_CLOCK_FREQUENCIES_BOOST_CLOCK = 2 , NV_GPU_CLOCK_FREQUENCIES_CLOCK_TYPE_NUM = NV_GPU_MAX_CLOCK_FREQUENCIES }
enum | _NV_GPU_ILLUMINATION_ATTRIB { NV_GPU_IA_LOGO_BRIGHTNESS = 0 , NV_GPU_IA_SLI_BRIGHTNESS = 1 }
enum NV_GPU_CLIENT_ILLUM_CTRL_MODE {
NV_GPU_CLIENT_ILLUM_CTRL_MODE_MANUAL_RGB = 0 , NV_GPU_CLIENT_ILLUM_CTRL_MODE_PIECEWISE_LINEAR_RGB , NV_GPU_CLIENT_ILLUM_CTRL_MODE_MANUAL = 0 , NV_GPU_CLIENT_ILLUM_CTRL_MODE_PIECEWISE_LINEAR ,
NV_GPU_CLIENT_ILLUM_CTRL_MODE_INVALID = 0xFF
}
enum NV_GPU_CLIENT_ILLUM_ZONE_LOCATION {
NV_GPU_CLIENT_ILLUM_ZONE_LOCATION_GPU_TOP_0 = 0x00 , NV_GPU_CLIENT_ILLUM_ZONE_LOCATION_GPU_FRONT_0 = 0x08 , NV_GPU_CLIENT_ILLUM_ZONE_LOCATION_GPU_BACK_0 = 0x0C , NV_GPU_CLIENT_ILLUM_ZONE_LOCATION_SLI_TOP_0 = 0x20 ,
NV_GPU_CLIENT_ILLUM_ZONE_LOCATION_INVALID = 0xFFFFFFFF
}
enum | NV_GPU_CLIENT_ILLUM_DEVICE_TYPE { NV_GPU_CLIENT_ILLUM_DEVICE_TYPE_INVALID = 0 , NV_GPU_CLIENT_ILLUM_DEVICE_TYPE_MCUV10 , NV_GPU_CLIENT_ILLUM_DEVICE_TYPE_GPIO_PWM_RGBW_V10 , NV_GPU_CLIENT_ILLUM_DEVICE_TYPE_GPIO_PWM_SINGLE_COLOR_V10 }
enum NV_GPU_CLIENT_ILLUM_ZONE_TYPE {
NV_GPU_CLIENT_ILLUM_ZONE_TYPE_INVALID = 0 , NV_GPU_CLIENT_ILLUM_ZONE_TYPE_RGB , NV_GPU_CLIENT_ILLUM_ZONE_TYPE_COLOR_FIXED , NV_GPU_CLIENT_ILLUM_ZONE_TYPE_RGBW ,
NV_GPU_CLIENT_ILLUM_ZONE_TYPE_SINGLE_COLOR
}
enum | NV_GPU_CLIENT_ILLUM_PIECEWISE_LINEAR_CYCLE_TYPE { NV_GPU_CLIENT_ILLUM_PIECEWISE_LINEAR_CYCLE_HALF_HALT = 0 , NV_GPU_CLIENT_ILLUM_PIECEWISE_LINEAR_CYCLE_FULL_HALT , NV_GPU_CLIENT_ILLUM_PIECEWISE_LINEAR_CYCLE_FULL_REPEAT , NV_GPU_CLIENT_ILLUM_PIECEWISE_LINEAR_CYCLE_INVALID = 0xFF }
enum NV_INFOFRAME_CMD {
NV_INFOFRAME_CMD_GET_DEFAULT = 0 , NV_INFOFRAME_CMD_RESET , NV_INFOFRAME_CMD_GET , NV_INFOFRAME_CMD_SET ,
NV_INFOFRAME_CMD_GET_OVERRIDE , NV_INFOFRAME_CMD_SET_OVERRIDE , NV_INFOFRAME_CMD_GET_PROPERTY , NV_INFOFRAME_CMD_SET_PROPERTY
}
enum | NV_INFOFRAME_PROPERTY_MODE { NV_INFOFRAME_PROPERTY_MODE_AUTO = 0 , NV_INFOFRAME_PROPERTY_MODE_ENABLE , NV_INFOFRAME_PROPERTY_MODE_DISABLE , NV_INFOFRAME_PROPERTY_MODE_ALLOW_OVERRIDE }
enum | NV_INFOFRAME_PROPERTY_BLACKLIST { NV_INFOFRAME_PROPERTY_BLACKLIST_FALSE = 0 , NV_INFOFRAME_PROPERTY_BLACKLIST_TRUE }
enum NV_INFOFRAME_FIELD_VALUE_AVI_SCANINFO {
NV_INFOFRAME_FIELD_VALUE_AVI_SCANINFO_NODATA = 0 , NV_INFOFRAME_FIELD_VALUE_AVI_SCANINFO_OVERSCAN , NV_INFOFRAME_FIELD_VALUE_AVI_SCANINFO_UNDERSCAN , NV_INFOFRAME_FIELD_VALUE_AVI_SCANINFO_FUTURE ,
NV_INFOFRAME_FIELD_VALUE_AVI_SCANINFO_AUTO = 7
}
enum NV_INFOFRAME_FIELD_VALUE_AVI_BARDATA {
NV_INFOFRAME_FIELD_VALUE_AVI_BARDATA_NOT_PRESENT = 0 , NV_INFOFRAME_FIELD_VALUE_AVI_BARDATA_VERTICAL_PRESENT , NV_INFOFRAME_FIELD_VALUE_AVI_BARDATA_HORIZONTAL_PRESENT , NV_INFOFRAME_FIELD_VALUE_AVI_BARDATA_BOTH_PRESENT ,
NV_INFOFRAME_FIELD_VALUE_AVI_BARDATA_AUTO = 7
}
enum | NV_INFOFRAME_FIELD_VALUE_AVI_ACTIVEFORMATINFO { NV_INFOFRAME_FIELD_VALUE_AVI_AFI_ABSENT = 0 , NV_INFOFRAME_FIELD_VALUE_AVI_AFI_PRESENT , NV_INFOFRAME_FIELD_VALUE_AVI_AFI_AUTO = 3 }
enum NV_INFOFRAME_FIELD_VALUE_AVI_COLORFORMAT {
NV_INFOFRAME_FIELD_VALUE_AVI_COLORFORMAT_RGB = 0 , NV_INFOFRAME_FIELD_VALUE_AVI_COLORFORMAT_YCbCr422 , NV_INFOFRAME_FIELD_VALUE_AVI_COLORFORMAT_YCbCr444 , NV_INFOFRAME_FIELD_VALUE_AVI_COLORFORMAT_FUTURE ,
NV_INFOFRAME_FIELD_VALUE_AVI_COLORFORMAT_AUTO = 7
}
enum | NV_INFOFRAME_FIELD_VALUE_AVI_F17 { NV_INFOFRAME_FIELD_VALUE_AVI_F17_FALSE = 0 , NV_INFOFRAME_FIELD_VALUE_AVI_F17_TRUE , NV_INFOFRAME_FIELD_VALUE_AVI_F17_AUTO = 3 }
enum NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION {
NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_NO_AFD = 0 , NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_RESERVE01 , NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_RESERVE02 , NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_RESERVE03 ,
NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_LETTERBOX_GT16x9 , NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_RESERVE05 , NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_RESERVE06 , NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_RESERVE07 ,
NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_EQUAL_CODEDFRAME = 8 , NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_CENTER_4x3 , NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_CENTER_16x9 , NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_CENTER_14x9 ,
NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_RESERVE12 , NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_4x3_ON_14x9 , NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_16x9_ON_14x9 , NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_16x9_ON_4x3 ,
NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_AUTO = 31
}
enum NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOCODEDFRAME {
NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOCODEDFRAME_NO_DATA = 0 , NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOCODEDFRAME_4x3 , NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOCODEDFRAME_16x9 , NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOCODEDFRAME_FUTURE ,
NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOCODEDFRAME_AUTO = 7
}
enum NV_INFOFRAME_FIELD_VALUE_AVI_COLORIMETRY {
NV_INFOFRAME_FIELD_VALUE_AVI_COLORIMETRY_NO_DATA = 0 , NV_INFOFRAME_FIELD_VALUE_AVI_COLORIMETRY_SMPTE_170M , NV_INFOFRAME_FIELD_VALUE_AVI_COLORIMETRY_ITUR_BT709 , NV_INFOFRAME_FIELD_VALUE_AVI_COLORIMETRY_USE_EXTENDED_COLORIMETRY ,
NV_INFOFRAME_FIELD_VALUE_AVI_COLORIMETRY_AUTO = 7
}
enum NV_INFOFRAME_FIELD_VALUE_AVI_NONUNIFORMPICTURESCALING {
NV_INFOFRAME_FIELD_VALUE_AVI_NONUNIFORMPICTURESCALING_NO_DATA = 0 , NV_INFOFRAME_FIELD_VALUE_AVI_NONUNIFORMPICTURESCALING_HORIZONTAL , NV_INFOFRAME_FIELD_VALUE_AVI_NONUNIFORMPICTURESCALING_VERTICAL , NV_INFOFRAME_FIELD_VALUE_AVI_NONUNIFORMPICTURESCALING_BOTH ,
NV_INFOFRAME_FIELD_VALUE_AVI_NONUNIFORMPICTURESCALING_AUTO = 7
}
enum NV_INFOFRAME_FIELD_VALUE_AVI_RGBQUANTIZATION {
NV_INFOFRAME_FIELD_VALUE_AVI_RGBQUANTIZATION_DEFAULT = 0 , NV_INFOFRAME_FIELD_VALUE_AVI_RGBQUANTIZATION_LIMITED_RANGE , NV_INFOFRAME_FIELD_VALUE_AVI_RGBQUANTIZATION_FULL_RANGE , NV_INFOFRAME_FIELD_VALUE_AVI_RGBQUANTIZATION_RESERVED ,
NV_INFOFRAME_FIELD_VALUE_AVI_RGBQUANTIZATION_AUTO = 7
}
enum NV_INFOFRAME_FIELD_VALUE_AVI_EXTENDEDCOLORIMETRY {
NV_INFOFRAME_FIELD_VALUE_AVI_EXTENDEDCOLORIMETRY_XVYCC601 = 0 , NV_INFOFRAME_FIELD_VALUE_AVI_EXTENDEDCOLORIMETRY_XVYCC709 , NV_INFOFRAME_FIELD_VALUE_AVI_EXTENDEDCOLORIMETRY_SYCC601 , NV_INFOFRAME_FIELD_VALUE_AVI_EXTENDEDCOLORIMETRY_ADOBEYCC601 ,
NV_INFOFRAME_FIELD_VALUE_AVI_EXTENDEDCOLORIMETRY_ADOBERGB , NV_INFOFRAME_FIELD_VALUE_AVI_EXTENDEDCOLORIMETRY_RESERVED05 , NV_INFOFRAME_FIELD_VALUE_AVI_EXTENDEDCOLORIMETRY_RESERVED06 , NV_INFOFRAME_FIELD_VALUE_AVI_EXTENDEDCOLORIMETRY_RESERVED07 ,
NV_INFOFRAME_FIELD_VALUE_AVI_EXTENDEDCOLORIMETRY_AUTO = 15
}
enum | NV_INFOFRAME_FIELD_VALUE_AVI_ITC { NV_INFOFRAME_FIELD_VALUE_AVI_ITC_VIDEO_CONTENT = 0 , NV_INFOFRAME_FIELD_VALUE_AVI_ITC_ITCONTENT , NV_INFOFRAME_FIELD_VALUE_AVI_ITC_AUTO = 3 }
enum NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION {
NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_NONE = 0 , NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_X02 , NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_X03 , NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_X04 ,
NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_X05 , NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_X06 , NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_X07 , NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_X08 ,
NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_X09 , NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_X10 , NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_RESERVED10 , NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_RESERVED11 ,
NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_RESERVED12 , NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_RESERVED13 , NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_RESERVED14 , NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_RESERVED15 ,
NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_AUTO = 31
}
enum NV_INFOFRAME_FIELD_VALUE_AVI_CONTENTTYPE {
NV_INFOFRAME_FIELD_VALUE_AVI_CONTENTTYPE_GRAPHICS = 0 , NV_INFOFRAME_FIELD_VALUE_AVI_CONTENTTYPE_PHOTO , NV_INFOFRAME_FIELD_VALUE_AVI_CONTENTTYPE_CINEMA , NV_INFOFRAME_FIELD_VALUE_AVI_CONTENTTYPE_GAME ,
NV_INFOFRAME_FIELD_VALUE_AVI_CONTENTTYPE_AUTO = 7
}
enum NV_INFOFRAME_FIELD_VALUE_AVI_YCCQUANTIZATION {
NV_INFOFRAME_FIELD_VALUE_AVI_YCCQUANTIZATION_LIMITED_RANGE = 0 , NV_INFOFRAME_FIELD_VALUE_AVI_YCCQUANTIZATION_FULL_RANGE , NV_INFOFRAME_FIELD_VALUE_AVI_YCCQUANTIZATION_RESERVED02 , NV_INFOFRAME_FIELD_VALUE_AVI_YCCQUANTIZATION_RESERVED03 ,
NV_INFOFRAME_FIELD_VALUE_AVI_YCCQUANTIZATION_AUTO = 7
}
enum NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELCOUNT {
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELCOUNT_IN_HEADER = 0 , NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELCOUNT_2 , NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELCOUNT_3 , NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELCOUNT_4 ,
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELCOUNT_5 , NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELCOUNT_6 , NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELCOUNT_7 , NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELCOUNT_8 ,
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELCOUNT_AUTO = 15
}
enum NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE {
NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_IN_HEADER = 0 , NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_PCM , NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_AC3 , NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_MPEG1 ,
NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_MP3 , NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_MPEG2 , NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_AACLC , NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_DTS ,
NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_ATRAC , NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_DSD , NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_EAC3 , NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_DTSHD ,
NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_MLP , NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_DST , NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_WMAPRO , NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_USE_CODING_EXTENSION_TYPE ,
NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_AUTO = 31
}
enum NV_INFOFRAME_FIELD_VALUE_AUDIO_SAMPLESIZE {
NV_INFOFRAME_FIELD_VALUE_AUDIO_SAMPLESIZE_IN_HEADER = 0 , NV_INFOFRAME_FIELD_VALUE_AUDIO_SAMPLESIZE_16BITS , NV_INFOFRAME_FIELD_VALUE_AUDIO_SAMPLESIZE_20BITS , NV_INFOFRAME_FIELD_VALUE_AUDIO_SAMPLESIZE_24BITS ,
NV_INFOFRAME_FIELD_VALUE_AUDIO_SAMPLESIZE_AUTO = 7
}
enum NV_INFOFRAME_FIELD_VALUE_AUDIO_SAMPLEFREQUENCY {
NV_INFOFRAME_FIELD_VALUE_AUDIO_SAMPLEFREQUENCY_IN_HEADER = 0 , NV_INFOFRAME_FIELD_VALUE_AUDIO_SAMPLEFREQUENCY_32000HZ , NV_INFOFRAME_FIELD_VALUE_AUDIO_SAMPLEFREQUENCY_44100HZ , NV_INFOFRAME_FIELD_VALUE_AUDIO_SAMPLEFREQUENCY_48000HZ ,
NV_INFOFRAME_FIELD_VALUE_AUDIO_SAMPLEFREQUENCY_88200KHZ , NV_INFOFRAME_FIELD_VALUE_AUDIO_SAMPLEFREQUENCY_96000KHZ , NV_INFOFRAME_FIELD_VALUE_AUDIO_SAMPLEFREQUENCY_176400KHZ , NV_INFOFRAME_FIELD_VALUE_AUDIO_SAMPLEFREQUENCY_192000KHZ ,
NV_INFOFRAME_FIELD_VALUE_AUDIO_SAMPLEFREQUENCY_AUTO = 15
}
enum NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE {
NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_USE_CODING_TYPE = 0 , NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_HEAAC , NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_HEAACV2 , NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_MPEGSURROUND ,
NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE04 , NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE05 , NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE06 , NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE07 ,
NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE08 , NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE09 , NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE10 , NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE11 ,
NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE12 , NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE13 , NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE14 , NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE15 ,
NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE16 , NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE17 , NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE18 , NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE19 ,
NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE20 , NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE21 , NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE22 , NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE23 ,
NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE24 , NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE25 , NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE26 , NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE27 ,
NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE28 , NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE29 , NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE30 , NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE31 ,
NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_AUTO = 63
}
enum NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION {
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_X_X_X_X_X_FR_FL =0 , NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_X_X_X_X_LFE_FR_FL , NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_X_X_X_FC_X_FR_FL , NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_X_X_X_FC_LFE_FR_FL ,
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_X_X_RC_X_X_FR_FL , NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_X_X_RC_X_LFE_FR_FL , NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_X_X_RC_FC_X_FR_FL , NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_X_X_RC_FC_LFE_FR_FL ,
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_X_RR_RL_X_X_FR_FL , NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_X_RR_RL_X_LFE_FR_FL , NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_X_RR_RL_FC_X_FR_FL , NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_X_RR_RL_FC_LFE_FR_FL ,
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_RC_RR_RL_X_X_FR_FL , NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_RC_RR_RL_X_LFE_FR_FL , NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_RC_RR_RL_FC_X_FR_FL , NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_RC_RR_RL_FC_LFE_FR_FL ,
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_RRC_RLC_RR_RL_X_X_FR_FL , NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_RRC_RLC_RR_RL_X_LFE_FR_FL , NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_RRC_RLC_RR_RL_FC_X_FR_FL , NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_RRC_RLC_RR_RL_FC_LFE_FR_FL ,
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRC_FLC_X_X_X_X_FR_FL , NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRC_FLC_X_X_X_LFE_FR_FL , NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRC_FLC_X_X_FC_X_FR_FL , NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRC_FLC_X_X_FC_LFE_FR_FL ,
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRC_FLC_X_RC_X_X_FR_FL , NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRC_FLC_X_RC_X_LFE_FR_FL , NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRC_FLC_X_RC_FC_X_FR_FL , NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRC_FLC_X_RC_FC_LFE_FR_FL ,
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRC_FLC_RR_RL_X_X_FR_FL , NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRC_FLC_RR_RL_X_LFE_FR_FL , NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRC_FLC_RR_RL_FC_X_FR_FL , NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRC_FLC_RR_RL_FC_LFE_FR_FL ,
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_FCH_RR_RL_FC_X_FR_FL , NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_FCH_RR_RL_FC_LFE_FR_FL , NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_TC_X_RR_RL_FC_X_FR_FL , NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_TC_X_RR_RL_FC_LFE_FR_FL ,
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRH_FLH_RR_RL_X_X_FR_FL , NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRH_FLH_RR_RL_X_LFE_FR_FL , NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRW_FLW_RR_RL_X_X_FR_FL , NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRW_FLW_RR_RL_X_LFE_FR_FL ,
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_TC_RC_RR_RL_FC_X_FR_FL , NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_TC_RC_RR_RL_FC_LFE_FR_FL , NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FCH_RC_RR_RL_FC_X_FR_FL , NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FCH_RC_RR_RL_FC_LFE_FR_FL ,
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_TC_FCH_RR_RL_FC_X_FR_FL , NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_TC_FCH_RR_RL_FC_LFE_FR_FL , NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRH_FLH_RR_RL_FC_X_FR_FL , NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRH_FLH_RR_RL_FC_LFE_FR_FL ,
NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRW_FLW_RR_RL_FC_X_FR_FL , NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRW_FLW_RR_RL_FC_LFE_FR_FL = 0X31 , NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_AUTO = 0x1FF
}
enum NV_INFOFRAME_FIELD_VALUE_AUDIO_LFEPLAYBACKLEVEL {
NV_INFOFRAME_FIELD_VALUE_AUDIO_LFEPLAYBACKLEVEL_NO_DATA = 0 , NV_INFOFRAME_FIELD_VALUE_AUDIO_LFEPLAYBACKLEVEL_0DB , NV_INFOFRAME_FIELD_VALUE_AUDIO_LFEPLAYBACKLEVEL_PLUS10DB , NV_INFOFRAME_FIELD_VALUE_AUDIO_LFEPLAYBACKLEVEL_RESERVED03 ,
NV_INFOFRAME_FIELD_VALUE_AUDIO_LFEPLAYBACKLEVEL_AUTO = 7
}
enum NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES {
NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_0DB = 0 , NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_1DB , NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_2DB , NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_3DB ,
NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_4DB , NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_5DB , NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_6DB , NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_7DB ,
NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_8DB , NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_9DB , NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_10DB , NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_11DB ,
NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_12DB , NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_13DB , NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_14DB , NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_15DB ,
NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_AUTO = 31
}
enum | NV_INFOFRAME_FIELD_VALUE_AUDIO_DOWNMIX { NV_INFOFRAME_FIELD_VALUE_AUDIO_DOWNMIX_PERMITTED = 0 , NV_INFOFRAME_FIELD_VALUE_AUDIO_DOWNMIX_PROHIBITED , NV_INFOFRAME_FIELD_VALUE_AUDIO_DOWNMIX_AUTO = 3 }
enum | NV_STATIC_METADATA_DESCRIPTOR_ID { NV_STATIC_METADATA_TYPE_1 = 0 }
enum | NV_HDR_CMD { NV_HDR_CMD_GET = 0 , NV_HDR_CMD_SET = 1 }
enum NV_HDR_MODE {
NV_HDR_MODE_OFF = 0 , NV_HDR_MODE_UHDA = 2 , NV_HDR_MODE_UHDA_PASSTHROUGH = 5 , NV_HDR_MODE_DOLBY_VISION = 7 ,
NV_HDR_MODE_EDR = 3 , NV_HDR_MODE_SDR = 4 , NV_HDR_MODE_UHDA_NB = 6 , NV_HDR_MODE_UHDBD = 2
}
enum NV_MOSAIC_TOPO_TYPE {
NV_MOSAIC_TOPO_TYPE_ALL , NV_MOSAIC_TOPO_TYPE_BASIC , NV_MOSAIC_TOPO_TYPE_PASSIVE_STEREO , NV_MOSAIC_TOPO_TYPE_SCALED_CLONE ,
NV_MOSAIC_TOPO_TYPE_PASSIVE_STEREO_SCALED_CLONE , NV_MOSAIC_TOPO_TYPE_MAX
}
enum NV_MOSAIC_TOPO {
NV_MOSAIC_TOPO_NONE , NV_MOSAIC_TOPO_BEGIN_BASIC , NV_MOSAIC_TOPO_1x2_BASIC = NV_MOSAIC_TOPO_BEGIN_BASIC , NV_MOSAIC_TOPO_2x1_BASIC ,
NV_MOSAIC_TOPO_1x3_BASIC , NV_MOSAIC_TOPO_3x1_BASIC , NV_MOSAIC_TOPO_1x4_BASIC , NV_MOSAIC_TOPO_4x1_BASIC ,
NV_MOSAIC_TOPO_2x2_BASIC , NV_MOSAIC_TOPO_2x3_BASIC , NV_MOSAIC_TOPO_2x4_BASIC , NV_MOSAIC_TOPO_3x2_BASIC ,
NV_MOSAIC_TOPO_4x2_BASIC , NV_MOSAIC_TOPO_1x5_BASIC , NV_MOSAIC_TOPO_1x6_BASIC , NV_MOSAIC_TOPO_7x1_BASIC ,
NV_MOSAIC_TOPO_END_BASIC = NV_MOSAIC_TOPO_7x1_BASIC + 9 , NV_MOSAIC_TOPO_BEGIN_PASSIVE_STEREO , NV_MOSAIC_TOPO_1x2_PASSIVE_STEREO = NV_MOSAIC_TOPO_BEGIN_PASSIVE_STEREO , NV_MOSAIC_TOPO_2x1_PASSIVE_STEREO ,
NV_MOSAIC_TOPO_1x3_PASSIVE_STEREO , NV_MOSAIC_TOPO_3x1_PASSIVE_STEREO , NV_MOSAIC_TOPO_1x4_PASSIVE_STEREO , NV_MOSAIC_TOPO_4x1_PASSIVE_STEREO ,
NV_MOSAIC_TOPO_2x2_PASSIVE_STEREO , NV_MOSAIC_TOPO_END_PASSIVE_STEREO = NV_MOSAIC_TOPO_2x2_PASSIVE_STEREO + 4 , NV_MOSAIC_TOPO_MAX
}
enum _NVAPI_GSYNC_GPU_TOPOLOGY_CONNECTOR {
NVAPI_GSYNC_GPU_TOPOLOGY_CONNECTOR_NONE = 0 , NVAPI_GSYNC_GPU_TOPOLOGY_CONNECTOR_PRIMARY = 1 , NVAPI_GSYNC_GPU_TOPOLOGY_CONNECTOR_SECONDARY = 2 , NVAPI_GSYNC_GPU_TOPOLOGY_CONNECTOR_TERTIARY = 3 ,
NVAPI_GSYNC_GPU_TOPOLOGY_CONNECTOR_QUARTERNARY = 4
}
enum | _NVAPI_GSYNC_DISPLAY_SYNC_STATE { NVAPI_GSYNC_DISPLAY_SYNC_STATE_UNSYNCED = 0 , NVAPI_GSYNC_DISPLAY_SYNC_STATE_SLAVE = 1 , NVAPI_GSYNC_DISPLAY_SYNC_STATE_MASTER = 2 }
enum | _NVAPI_GSYNC_POLARITY { NVAPI_GSYNC_POLARITY_RISING_EDGE = 0 , NVAPI_GSYNC_POLARITY_FALLING_EDGE = 1 , NVAPI_GSYNC_POLARITY_BOTH_EDGES = 2 }
enum _NVAPI_GSYNC_VIDEO_MODE {
NVAPI_GSYNC_VIDEO_MODE_NONE = 0 , NVAPI_GSYNC_VIDEO_MODE_TTL = 1 , NVAPI_GSYNC_VIDEO_MODE_NTSCPALSECAM = 2 , NVAPI_GSYNC_VIDEO_MODE_HDTV = 3 ,
NVAPI_GSYNC_VIDEO_MODE_COMPOSITE = 4
}
enum | _NVAPI_GSYNC_SYNC_SOURCE { NVAPI_GSYNC_SYNC_SOURCE_VSYNC = 0 , NVAPI_GSYNC_SYNC_SOURCE_HOUSESYNC = 1 }
enum | _NVAPI_GSYNC_MULTIPLY_DIVIDE_MODE { NVAPI_GSYNC_UNDEFINED_MODE = 0 , NVAPI_GSYNC_MULTIPLY_MODE = 1 , NVAPI_GSYNC_DIVIDE_MODE = 2 }
enum | _NVAPI_GSYNC_DELAY_TYPE { NVAPI_GSYNC_DELAY_TYPE_UNKNOWN = 0 , NVAPI_GSYNC_DELAY_TYPE_SYNC_SKEW = 1 , NVAPI_GSYNC_DELAY_TYPE_STARTUP = 2 }
enum | _NVAPI_GSYNC_RJ45_IO { NVAPI_GSYNC_RJ45_OUTPUT = 0 , NVAPI_GSYNC_RJ45_INPUT = 1 , NVAPI_GSYNC_RJ45_UNUSED = 2 }
enum | NVAPI_ALIAS_SURFACE_FLAG { NVAPI_ALIAS_SURFACE_FLAG_NONE = 0x00000000 , NVAPI_ALIAS_SURFACE_FLAG_USE_SUPER = 0x00000001 , NVAPI_ALIAS_SURFACE_FLAG_MASK = 0x00000001 }
enum _NV_STEREO_VIDEO_FORMAT {
NV_STEREO_VIDEO_FORMAT_NOT_STEREO = 0 , NV_STEREO_VIDEO_FORMAT_SIDE_BY_SIDE_LR = 1 , NV_STEREO_VIDEO_FORMAT_SIDE_BY_SIDE_RL = 2 , NV_STEREO_VIDEO_FORMAT_TOP_BOTTOM_LR = 3 ,
NV_STEREO_VIDEO_FORMAT_TOP_BOTTOM_RL = 4 , NV_STEREO_VIDEO_FORMAT_ROW_INTERLEAVE_LR = 5 , NV_STEREO_VIDEO_FORMAT_ROW_INTERLEAVE_RL = 6 , NV_STEREO_VIDEO_FORMAT_TWO_FRAMES_LR = 7 ,
NV_STEREO_VIDEO_FORMAT_MONO_PLUS_OFFSET = 8 , NV_STEREO_VIDEO_FORMAT_LAST = 9
}
enum | _NVAPI_D3D11_INSERTWFI_FLAG { NVAPI_D3D_BEGIN_UAV_OVERLAP_NO_WFI = 0x00000000 , NVAPI_D3D_BEGIN_UAV_OVERLAP_GFX_WFI = 0x00000001 , NVAPI_D3D_BEGIN_UAV_OVERLAP_COMP_WFI = 0x00000002 }
enum NVAPI_VSYNC_MODE {
NVAPI_VSYNC_DEFAULT , NVAPI_VSYNC_OFF , NVAPI_VSYNC_ON , NVAPI_VSYNC_ADAPTIVE ,
NVAPI_VSYNC_ADAPTIVE_HALF_REFRESH_RATE
}
enum | _NV_PRESENT_BARRIER_SYNC_MODE { PRESENT_BARRIER_NOT_JOINED = 0x00000000 , PRESENT_BARRIER_SYNC_CLIENT = 0x00000001 , PRESENT_BARRIER_SYNC_SYSTEM = 0x00000002 , PRESENT_BARRIER_SYNC_CLUSTER = 0x00000003 }
enum | NVAPI_QUAD_FILLMODE { NVAPI_QUAD_FILLMODE_DISABLED = 0 , NVAPI_QUAD_FILLMODE_BBOX = 1 , NVAPI_QUAD_FILLMODE_FULL_VIEWPORT = 2 }
enum | _NVAPI_ANSEL_FEATURE { NVAPI_ANSEL_FEATURE_UNKNOWN = 0 , NVAPI_ANSEL_FEATURE_BLACK_AND_WHITE = 1 , NVAPI_ANSEL_FEATURE_HUDLESS = 2 }
enum | _NVAPI_ANSEL_FEATURE_STATE { NVAPI_ANSEL_FEATURE_STATE_UNKNOWN = 0 , NVAPI_ANSEL_FEATURE_STATE_ENABLE = 1 , NVAPI_ANSEL_FEATURE_STATE_DISABLE = 2 }
enum | _NVAPI_ANSEL_HOTKEY_MODIFIER { NVAPI_ANSEL_HOTKEY_MODIFIER_UNKNOWN = 0 , NVAPI_ANSEL_HOTKEY_MODIFIER_CTRL = 1 , NVAPI_ANSEL_HOTKEY_MODIFIER_SHIFT = 2 , NVAPI_ANSEL_HOTKEY_MODIFIER_ALT = 3 }
enum | _NV_D3D11_FEATURE { NV_D3D11_FEATURE_RASTERIZER }
enum | _NV_RESOLVE_MODE { NV_RESOLVE_MODE_SAMPLE_0 }
enum _NV_SWIZZLE_MODE {
NV_SWIZZLE_POS_X = 0 , NV_SWIZZLE_NEG_X = 1 , NV_SWIZZLE_POS_Y = 2 , NV_SWIZZLE_NEG_Y = 3 ,
NV_SWIZZLE_POS_Z = 4 , NV_SWIZZLE_NEG_Z = 5 , NV_SWIZZLE_POS_W = 6 , NV_SWIZZLE_NEG_W = 7
}
enum | _NV_SWIZZLE_OFFSET { NV_SWIZZLE_OFFSET_X = 0 , NV_SWIZZLE_OFFSET_Y = 4 , NV_SWIZZLE_OFFSET_Z = 8 , NV_SWIZZLE_OFFSET_W = 12 }
enum NV_CUSTOM_SEMANTIC_TYPE {
NV_NONE_SEMANTIC = 0 , NV_X_RIGHT_SEMANTIC = 1 , NV_VIEWPORT_MASK_SEMANTIC = 2 , NV_XYZW_RIGHT_SEMANTIC = 3 ,
NV_VIEWPORT_MASK_2_SEMANTIC = 4 , NV_POSITION_SEMANTIC = 5 , NV_CLIP_DISTANCE_0_SEMANTIC = 6 , NV_CLIP_DISTANCE_1_SEMANTIC = 7 ,
NV_CULL_DISTANCE_0_SEMANTIC = 8 , NV_CULL_DISTANCE_1_SEMANTIC = 9 , NV_GENERIC_ATTRIBUTE_SEMANTIC = 10 , NV_PACKED_EYE_INDEX_SEMANTIC = 17 ,
NV_CUSTOM_SEMANTIC_MAX = NV_CUSTOM_SEMANTIC_MAX_LIMIT
}
enum | _NV_FASTGS_FLAGS { NV_FASTGS_USE_VIEWPORT_MASK = 0x01 , NV_FASTGS_OFFSET_RT_INDEX_BY_VP_INDEX = 0x02 , NV_FASTGS_STRICT_API_ORDER = 0x04 }
enum _NV_PSO_EXTENSION {
NV_PSO_RASTER_EXTENSION = 0 , NV_PSO_REQUEST_FASTGS_EXTENSION = 1 , NV_PSO_GEOMETRY_SHADER_EXTENSION = 2 , NV_PSO_ENABLE_DEPTH_BOUND_TEST_EXTENSION = 3 ,
NV_PSO_EXPLICIT_FASTGS_EXTENSION = 4 , NV_PSO_SET_SHADER_EXTNENSION_SLOT_AND_SPACE = 5 , NV_PSO_SET_SHADER_EXTENSION_SLOT_AND_SPACE = 5 , NV_PSO_VERTEX_SHADER_EXTENSION = 6 ,
NV_PSO_DOMAIN_SHADER_EXTENSION = 7 , NV_PSO_HULL_SHADER_EXTENSION = 9
}
enum | _NV_COMPUTE_SHADER_DERIVATIVES { NV_COMPUTE_SHADER_DERIVATIVE_NONE = 0 , NV_COMPUTE_SHADER_DERIVATIVE_GROUP_LINEAR = 1 , NV_COMPUTE_SHADER_DERIVATIVE_GROUP_QUADS = 2 }
enum | NV_D3D12_HEAP_FLAGS { NV_D3D12_HEAP_FLAG_NONE = 0 , NV_D3D12_HEAP_FLAG_CPUVISIBLE_VIDMEM = 1 }
enum NV_D3D_GRAPHICS_STATES {
NV_D3D_GRAPHICS_STATE_NONE = 0 , NV_D3D_GRAPHICS_STATE_IA_VERTEX_BUFFERS = (1 << 0) , NV_D3D_GRAPHICS_STATE_IA_INDEX_BUFFER = (1 << 1) , NV_D3D_GRAPHICS_STATE_IA_PRIMITIVE_TOPOLOGY = (1 << 2) ,
NV_D3D_GRAPHICS_STATE_DESCRIPTOR_HEAP = (1 << 3) , NV_D3D_GRAPHICS_STATE_GRAPHICS_ROOT_SIGNATURE = (1 << 4) , NV_D3D_GRAPHICS_STATE_COMPUTE_ROOT_SIGNATURE = (1 << 5) , NV_D3D_GRAPHICS_STATE_RS_VIEWPORTS = (1 << 6) ,
NV_D3D_GRAPHICS_STATE_RS_SCISSOR_RECTS = (1 << 7) , NV_D3D_GRAPHICS_STATE_PREDICATION = (1 << 8) , NV_D3D_GRAPHICS_STATE_OM_RENDER_TARGETS = (1 << 9) , NV_D3D_GRAPHICS_STATE_OM_STENCIL_REF = (1 << 10) ,
NV_D3D_GRAPHICS_STATE_OM_BLEND_FACTOR = (1 << 11) , NV_D3D_GRAPHICS_STATE_PIPELINE_STATE = (1 << 12) , NV_D3D_GRAPHICS_STATE_SO_TARGETS = (1 << 13) , NV_D3D_GRAPHICS_STATE_OM_DEPTH_BOUNDS = (1 << 14) ,
NV_D3D_GRAPHICS_STATE_SAMPLE_POSITIONS = (1 << 15) , NV_D3D_GRAPHICS_STATE_VIEW_INSTANCE_MASK = (1 << 16)
}
enum | NV_META_COMMAND_TENSOR_DATA_TYPE { NV_META_COMMAND_TENSOR_DATA_TYPE_FLOAT32 , NV_META_COMMAND_TENSOR_DATA_TYPE_FLOAT16 , NV_META_COMMAND_TENSOR_DATA_TYPE_UINT32 , NV_META_COMMAND_TENSOR_DATA_TYPE_COUNT }
enum | NV_META_COMMAND_TENSOR_LAYOUT { NV_META_COMMAND_TENSOR_LAYOUT_UNKNOWN , NV_META_COMMAND_TENSOR_LAYOUT_STANDARD , NV_META_COMMAND_TENSOR_LAYOUT_COUNT }
enum | NV_META_COMMAND_TENSOR_FLAGS { NV_META_COMMAND_TENSOR_FLAG_NONE = 0 , NV_META_COMMAND_TENSOR_FLAG_DATA_STATIC = 0x1 }
enum | NV_META_COMMAND_PRECISION { NV_META_COMMAND_PRECISION_FLOAT32 , NV_META_COMMAND_PRECISION_FLOAT16 , NV_META_COMMAND_PRECISION_MUL_FLOAT16_ADD_FLOAT32 , NV_META_COMMAND_PRECISION_COUNT }
enum NV_META_COMMAND_ACTIVATION_FUNCTION {
NV_META_COMMAND_ACTIVATION_FUNCTION_ELU , NV_META_COMMAND_ACTIVATION_FUNCTION_HARDMAX , NV_META_COMMAND_ACTIVATION_FUNCTION_HARD_SIGMOID , NV_META_COMMAND_ACTIVATION_FUNCTION_IDENTITY ,
NV_META_COMMAND_ACTIVATION_FUNCTION_LEAKY_RELU , NV_META_COMMAND_ACTIVATION_FUNCTION_LINEAR , NV_META_COMMAND_ACTIVATION_FUNCTION_LOG_SOFTMAX , NV_META_COMMAND_ACTIVATION_FUNCTION_PARAMETERIZED_RELU ,
NV_META_COMMAND_ACTIVATION_FUNCTION_PARAMETRIC_SOFTPLUS , NV_META_COMMAND_ACTIVATION_FUNCTION_RELU , NV_META_COMMAND_ACTIVATION_FUNCTION_SCALED_ELU , NV_META_COMMAND_ACTIVATION_FUNCTION_SCALED_TANH ,
NV_META_COMMAND_ACTIVATION_FUNCTION_SIGMOID , NV_META_COMMAND_ACTIVATION_FUNCTION_SOFTMAX , NV_META_COMMAND_ACTIVATION_FUNCTION_SOFTPLUS , NV_META_COMMAND_ACTIVATION_FUNCTION_SOFTSIGN ,
NV_META_COMMAND_ACTIVATION_FUNCTION_TANH , NV_META_COMMAND_ACTIVATION_FUNCTION_THRESHOLDED_RELU , NV_META_COMMAND_ACTIVATION_FUNCTION_COUNT
}
enum NV_META_COMMAND_PADDING_MODE {
NV_META_COMMAND_PADDING_ZEROS , NV_META_COMMAND_PADDING_MIRROR , NV_META_COMMAND_PADDING_CLAMP , NV_META_COMMAND_PADDING_CONSTANT ,
NV_META_COMMAND_PADDING_COUNT
}
enum NV_META_COMMAND_RESOURCE_TYPE {
NV_META_COMMAND_RESOURCE_TYPE_INPUT = 0 , NV_META_COMMAND_RESOURCE_TYPE_OUTPUT = 1 , NV_META_COMMAND_RESOURCE_TYPE_FILTER = 2 , NV_META_COMMAND_RESOURCE_TYPE_WEIGHT = 2 ,
NV_META_COMMAND_RESOURCE_TYPE_BIAS = 3 , NV_META_COMMAND_RESOURCE_TYPE_MATRIX_A = 0 , NV_META_COMMAND_RESOURCE_TYPE_MATRIX_B = 2 , NV_META_COMMAND_RESOURCE_TYPE_MATRIX_C = 3 ,
NV_META_COMMAND_RESOURCE_TYPE_PERSISTENT = 4 , NV_META_COMMAND_RESOURCE_TYPE_TEMPORARY = 5
}
enum | NV_META_COMMAND_CONVOLUTION_DIRECTION { NV_META_COMMAND_CONVOLUTION_DIRECTION_FORWARD , NV_META_COMMAND_CONVOLUTION_DIRECTION_BACKWARD , NV_META_COMMAND_CONVOLUTION_DIRECTION_COUNT }
enum | NV_META_COMMAND_CONVOLUTION_MODE { NV_META_COMMAND_CONVOLUTION_MODE_CONVOLUTION , NV_META_COMMAND_CONVOLUTION_MODE_CROSS_CORRELATION , NV_META_COMMAND_CONVOLUTION_MODE_COUNT }
enum NV_META_COMMAND_CONVOLUTION_POOL_MODE {
NV_META_COMMAND_CONVOLUTION_POOL_MODE_NONE , NV_META_COMMAND_CONVOLUTION_POOL_MODE_REDUCTION_MAX , NV_META_COMMAND_CONVOLUTION_POOL_MODE_REDUCTION_AVG , NV_META_COMMAND_CONVOLUTION_POOL_MODE_REDUCTION_MIN ,
NV_META_COMMAND_CONVOLUTION_POOL_MODE_COUNT
}
enum | NV_META_COMMAND_CONVOLUTION_UPSAMPLE_MODE { NV_META_COMMAND_CONVOLUTION_UPSAMPLE_MODE_NONE , NV_META_COMMAND_CONVOLUTION_UPSAMPLE_MODE_REPLICATE , NV_META_COMMAND_CONVOLUTION_UPSAMPLE_MODE_BILINEAR , NV_META_COMMAND_CONVOLUTION_UPSAMPLE_MODE_COUNT }
enum | NV_META_COMMAND_CONVOLUTION_SKIP_MODE { NV_META_COMMAND_CONVOLUTION_SKIP_MODE_NONE , NV_META_COMMAND_CONVOLUTION_SKIP_MODE_ADD , NV_META_COMMAND_CONVOLUTION_SKIP_MODE_CONCAT , NV_META_COMMAND_CONVOLUTION_SKIP_MODE_COUNT }
enum | NV_META_COMMAND_MATRIX_TRANSFORM { NV_META_COMMAND_MATRIX_TRANSFORM_NONE , NV_META_COMMAND_MATRIX_TRANSFORM_TRANSPOSE , NV_META_COMMAND_MATRIX_TRANSFORM_COUNT }
enum | NV_D3D12_RESOURCE_FLAGS { NV_D3D12_RESOURCE_FLAG_NONE = 0 , NV_D3D12_RESOURCE_FLAG_HTEX = 1 , NV_D3D12_RESOURCE_FLAG_CPUVISIBLE_VIDMEM = 2 }
enum | _IMPLICIT_SLI_CONTROL { DISABLE_IMPLICIT_SLI = 0 , ENABLE_IMPLICIT_SLI = 1 }
enum NV_PIXEL_SHADING_RATE {
NV_PIXEL_X0_CULL_RASTER_PIXELS , NV_PIXEL_X16_PER_RASTER_PIXEL , NV_PIXEL_X8_PER_RASTER_PIXEL , NV_PIXEL_X4_PER_RASTER_PIXEL ,
NV_PIXEL_X2_PER_RASTER_PIXEL , NV_PIXEL_X1_PER_RASTER_PIXEL , NV_PIXEL_X1_PER_2X1_RASTER_PIXELS , NV_PIXEL_X1_PER_1X2_RASTER_PIXELS ,
NV_PIXEL_X1_PER_2X2_RASTER_PIXELS , NV_PIXEL_X1_PER_4X2_RASTER_PIXELS , NV_PIXEL_X1_PER_2X4_RASTER_PIXELS , NV_PIXEL_X1_PER_4X4_RASTER_PIXELS
}
enum | _NV_SRRV_DIMENSION { NV_SRRV_DIMENSION_TEXTURE2D = 4 , NV_SRRV_DIMENSION_TEXTURE2DARRAY = 5 }
enum | _NV_VRS_CONTENT_TYPE { NV_VRS_CONTENT_TYPE_INVALID = 0x0 , NV_VRS_CONTENT_TYPE_FOVEATED_RENDERING = 0x1 , NV_VRS_CONTENT_TYPE_MAX = NV_VRS_CONTENT_TYPE_FOVEATED_RENDERING }
enum _NV_FOVEATED_RENDERING_SHADING_RATE_PRESET {
NV_FOVEATED_RENDERING_SHADING_RATE_PRESET_INVALID = 0 , NV_FOVEATED_RENDERING_SHADING_RATE_PRESET_HIGHEST_PERFORMANCE = 1 , NV_FOVEATED_RENDERING_SHADING_RATE_PRESET_HIGH_PERFORMANCE = 2 , NV_FOVEATED_RENDERING_SHADING_RATE_PRESET_BALANCED = 3 ,
NV_FOVEATED_RENDERING_SHADING_RATE_PRESET_HIGH_QUALITY = 4 , NV_FOVEATED_RENDERING_SHADING_RATE_PRESET_HIGHEST_QUALITY = 5 , NV_FOVEATED_RENDERING_SHADING_RATE_PRESET_CUSTOM = 6 , NV_FOVEATED_RENDERING_SHADING_RATE_PRESET_MAX = NV_FOVEATED_RENDERING_SHADING_RATE_PRESET_CUSTOM
}
enum _NV_FOVEATED_RENDERING_FOVEATION_PATTERN_PRESET {
NV_FOVEATED_RENDERING_FOVEATION_PATTERN_PRESET_INVALID = 0 , NV_FOVEATED_RENDERING_FOVEATION_PATTERN_PRESET_WIDE = 1 , NV_FOVEATED_RENDERING_FOVEATION_PATTERN_PRESET_BALANCED = 2 , NV_FOVEATED_RENDERING_FOVEATION_PATTERN_PRESET_NARROW = 3 ,
NV_FOVEATED_RENDERING_FOVEATION_PATTERN_PRESET_CUSTOM = 4 , NV_FOVEATED_RENDERING_FOVEATION_PATTERN_PRESET_MAX = NV_FOVEATED_RENDERING_FOVEATION_PATTERN_PRESET_CUSTOM
}
enum _NV_VRS_RENDER_MODE {
NV_VRS_RENDER_MODE_INVALID = 0 , NV_VRS_RENDER_MODE_MONO = 1 , NV_VRS_RENDER_MODE_LEFT_EYE = 2 , NV_VRS_RENDER_MODE_RIGHT_EYE = 3 ,
NV_VRS_RENDER_MODE_STEREO = 4 , NV_VRS_RENDER_MODE_MAX = NV_VRS_RENDER_MODE_STEREO
}
enum _NV_GAZE_DATA_VALIDITY_FLAGS {
NV_GAZE_ORIGIN_VALID = 0x1 , NV_GAZE_DIRECTION_VALID = 0x2 , NV_GAZE_LOCATION_VALID = 0x4 , NV_GAZE_VELOCITY_VALID = 0x8 ,
NV_GAZE_PUPIL_DIAMETER_VALID = 0x10 , NV_GAZE_EYE_OPENNESS_VALID = 0x20 , NV_GAZE_EYE_SACCADE_DATA_VALID = 0x40
}
enum | _NV_GAZE_DATA_TYPE { NV_GAZE_DATA_INVALID = 0 , NV_GAZE_DATA_MONO = 1 , NV_GAZE_DATA_STEREO = 2 , NV_GAZE_DATA_MAX = NV_GAZE_DATA_STEREO }
enum | NV_SMP_ASSIST_TYPE { NV_SMP_ASSIST_NONE = 0 , NV_SMP_ASSIST_MRS = 1 , NV_SMP_ASSIST_LMS = 2 , NV_SMP_ASSIST_NUM_TYPES }
enum | NV_SMP_ASSIST_LEVEL { NV_SMP_ASSIST_LEVEL_FULL = 0 , NV_SMP_ASSIST_LEVEL_PARTIAL = 1 , NV_SMP_ASSIST_LEVEL_MINIMAL = 2 , NV_SMP_ASSIST_NUM_LEVELS }
enum NV_MRS_CONFIG {
NV_MRS_CONFIG_BALANCED = 0 , NV_MRS_CONFIG_AGGRESSIVE = 1 , NV_MRS_CONFIG_OCULUSRIFT_CV1_CONSERVATIVE = 2 , NV_MRS_CONFIG_OCULUSRIFT_CV1_BALANCED = 3 ,
NV_MRS_CONFIG_OCULUSRIFT_CV1_AGGRESSIVE = 4 , NV_MRS_CONFIG_HTC_VIVE_CONSERVATIVE = 5 , NV_MRS_CONFIG_HTC_VIVE_BALANCED = 6 , NV_MRS_CONFIG_HTC_VIVE_AGGRESSIVE = 7 ,
NV_MRS_NUM_CONFIGS
}
enum NV_LMS_CONFIG {
NV_LMS_CONFIG_OCULUSRIFT_CV1_CONSERVATIVE = 0 , NV_LMS_CONFIG_OCULUSRIFT_CV1_BALANCED = 1 , NV_LMS_CONFIG_OCULUSRIFT_CV1_AGGRESSIVE = 2 , NV_LMS_CONFIG_HTC_VIVE_CONSERVATIVE = 3 ,
NV_LMS_CONFIG_HTC_VIVE_BALANCED = 4 , NV_LMS_CONFIG_HTC_VIVE_AGGRESSIVE = 5 , NV_LMS_NUM_CONFIGS
}
enum | _NV_SMP_ASSIST_EYE_INDEX { NV_SMP_ASSIST_EYE_INDEX_MONO = 0 , NV_SMP_ASSIST_EYE_INDEX_LEFT_EYE = 1 , NV_SMP_ASSIST_EYE_INDEX_RIGHT_EYE = 2 , NV_SMP_ASSIST_EYE_INDEX_INSTANCED_STEREO = 3 }
enum NV_LATENCY_MARKER_TYPE {
SIMULATION_START = 0 , SIMULATION_END = 1 , RENDERSUBMIT_START = 2 , RENDERSUBMIT_END = 3 ,
PRESENT_START = 4 , PRESENT_END = 5 , INPUT_SAMPLE = 6 , TRIGGER_FLASH = 7 ,
PC_LATENCY_PING = 8 , OUT_OF_BAND_RENDERSUBMIT_START = 9 , OUT_OF_BAND_RENDERSUBMIT_END = 10 , OUT_OF_BAND_PRESENT_START = 11 ,
OUT_OF_BAND_PRESENT_END = 12
}
enum | NV_OUT_OF_BAND_CQ_TYPE { OUT_OF_BAND_RENDER = 0 , OUT_OF_BAND_PRESENT = 1 , OUT_OF_BAND_IGNORE = 2 }
enum | _NVAPI_D3D12_GET_CUDA_INDEPENDENT_DESCRIPTOR_OBJECT_TYPE { NVAPI_D3D12_GET_CUDA_INDEPENDENT_DESCRIPTOR_OBJECT_SURFACE = 0 , NVAPI_D3D12_GET_CUDA_INDEPENDENT_DESCRIPTOR_OBJECT_TEXTURE = 1 , NVAPI_D3D12_GET_CUDA_INDEPENDENT_DESCRIPTOR_OBJECT_SAMPLER = 2 }
enum | _NVAPI_D3D12_RAYTRACING_THREAD_REORDERING_CAPS { NVAPI_D3D12_RAYTRACING_THREAD_REORDERING_CAP_NONE = 0x0 , NVAPI_D3D12_RAYTRACING_THREAD_REORDERING_CAP_STANDARD = NV_BIT(0) }
enum | _NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_CAPS { NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_CAP_NONE = 0x0 , NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_CAP_STANDARD = NV_BIT(0) }
enum | _NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_CAPS { NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_CAP_NONE = 0x0 , NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_CAP_STANDARD = NV_BIT(0) }
enum | _NVAPI_D3D12_RAYTRACING_CAPS_TYPE { NVAPI_D3D12_RAYTRACING_CAPS_TYPE_THREAD_REORDERING = 0 , NVAPI_D3D12_RAYTRACING_CAPS_TYPE_OPACITY_MICROMAP = 1 , NVAPI_D3D12_RAYTRACING_CAPS_TYPE_DISPLACEMENT_MICROMAP = 2 , NVAPI_D3D12_RAYTRACING_CAPS_TYPE_INVALID = -1 }
enum | _NVAPI_D3D12_RAYTRACING_VALIDATION_FLAGS { NVAPI_D3D12_RAYTRACING_VALIDATION_FLAG_NONE = 0x0 }
enum | _NVAPI_D3D12_RAYTRACING_VALIDATION_MESSAGE_SEVERITY { NVAPI_D3D12_RAYTRACING_VALIDATION_MESSAGE_SEVERITY_ERROR = 0x0 , NVAPI_D3D12_RAYTRACING_VALIDATION_MESSAGE_SEVERITY_WARNING = 0x1 }
enum | _NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_BUILD_FLAGS { NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_BUILD_FLAG_NONE = 0x0 , NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_BUILD_FLAG_PREFER_FAST_TRACE = NV_BIT(0) , NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_BUILD_FLAG_PREFER_FAST_BUILD = NV_BIT(1) }
enum | _NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_FORMAT { NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_FORMAT_DC1_64_TRIS_64_BYTES = 0x1 , NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_FORMAT_DC1_256_TRIS_128_BYTES = 0x2 , NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_FORMAT_DC1_1024_TRIS_128_BYTES = 0x3 }
enum | _NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_ARRAY_BUILD_FLAGS { NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_ARRAY_BUILD_FLAG_NONE = 0x0 , NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_ARRAY_BUILD_FLAG_PREFER_FAST_TRACE = NV_BIT(0) , NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_ARRAY_BUILD_FLAG_PREFER_FAST_BUILD = NV_BIT(1) }
enum | _NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_FORMAT { NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_FORMAT_OC1_2_STATE = 0x1 , NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_FORMAT_OC1_4_STATE = 0x2 }
enum | _NVAPI_D3D12_PIPELINE_CREATION_STATE_FLAGS { NVAPI_D3D12_PIPELINE_CREATION_STATE_FLAGS_NONE = 0 , NVAPI_D3D12_PIPELINE_CREATION_STATE_FLAGS_ENABLE_OMM_SUPPORT = NV_BIT(0) , NVAPI_D3D12_PIPELINE_CREATION_STATE_FLAGS_ENABLE_DMM_SUPPORT = NV_BIT(1) }
enum | _NVAPI_D3D12_SERIALIZED_DATA_TYPE_EX { NVAPI_D3D12_SERIALIZED_DATA_RAYTRACING_ACCELERATION_STRUCTURE_EX = 0x0 , NVAPI_D3D12_SERIALIZED_DATA_RAYTRACING_OPACITY_MICROMAP_ARRAY_EX = 0x1 , NVAPI_D3D12_SERIALIZED_DATA_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_EX = 0x2 }
enum _NVAPI_D3D12_RAYTRACING_ACCELERATION_STRUCTURE_BUILD_FLAGS_EX {
NVAPI_D3D12_RAYTRACING_ACCELERATION_STRUCTURE_BUILD_FLAG_NONE_EX = 0x0 , NVAPI_D3D12_RAYTRACING_ACCELERATION_STRUCTURE_BUILD_FLAG_ALLOW_UPDATE_EX = NV_BIT(0) , NVAPI_D3D12_RAYTRACING_ACCELERATION_STRUCTURE_BUILD_FLAG_ALLOW_COMPACTION_EX = NV_BIT(1) , NVAPI_D3D12_RAYTRACING_ACCELERATION_STRUCTURE_BUILD_FLAG_PREFER_FAST_TRACE_EX = NV_BIT(2) ,
NVAPI_D3D12_RAYTRACING_ACCELERATION_STRUCTURE_BUILD_FLAG_PREFER_FAST_BUILD_EX = NV_BIT(3) , NVAPI_D3D12_RAYTRACING_ACCELERATION_STRUCTURE_BUILD_FLAG_MINIMIZE_MEMORY_EX = NV_BIT(4) , NVAPI_D3D12_RAYTRACING_ACCELERATION_STRUCTURE_BUILD_FLAG_PERFORM_UPDATE_EX = NV_BIT(5) , NVAPI_D3D12_RAYTRACING_ACCELERATION_STRUCTURE_BUILD_FLAG_ALLOW_OMM_UPDATE_EX = NV_BIT(6) ,
NVAPI_D3D12_RAYTRACING_ACCELERATION_STRUCTURE_BUILD_FLAG_ALLOW_DISABLE_OMMS_EX = NV_BIT(7) , NVAPI_D3D12_RAYTRACING_ACCELERATION_STRUCTURE_BUILD_FLAG_ALLOW_OMM_OPACITY_STATES_UPDATE_EX = NV_BIT(8) , NVAPI_D3D12_RAYTRACING_ACCELERATION_STRUCTURE_BUILD_FLAG_ALLOW_DATA_ACCESS_EX = NV_BIT(9)
}
enum | _NVAPI_D3D12_RAYTRACING_GEOMETRY_TYPE_EX { NVAPI_D3D12_RAYTRACING_GEOMETRY_TYPE_TRIANGLES_EX = 0x0 , NVAPI_D3D12_RAYTRACING_GEOMETRY_TYPE_PROCEDURAL_PRIMITIVE_AABBS_EX = 0x1 , NVAPI_D3D12_RAYTRACING_GEOMETRY_TYPE_OMM_TRIANGLES_EX = 0x2 , NVAPI_D3D12_RAYTRACING_GEOMETRY_TYPE_DMM_TRIANGLES_EX = 0x3 }
enum | _NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_SPECIAL_INDEX { NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_SPECIAL_INDEX_FULLY_TRANSPARENT = -1 , NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_SPECIAL_INDEX_FULLY_OPAQUE = -2 , NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_SPECIAL_INDEX_FULLY_UNKNOWN_TRANSPARENT = -3 , NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_SPECIAL_INDEX_FULLY_UNKNOWN_OPAQUE = -4 }
enum | _NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_PRIMITIVE_FLAGS { NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_PRIMITIVE_FLAG_DECIMATE_01 = NV_BIT(0) , NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_PRIMITIVE_FLAG_DECIMATE_12 = NV_BIT(1) , NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_PRIMITIVE_FLAG_DECIMATE_20 = NV_BIT(2) }
enum _NVAPI_D3D12_RAYTRACING_INSTANCE_FLAGS_EX {
NVAPI_D3D12_RAYTRACING_INSTANCE_FLAG_NONE_EX = 0x0 , NVAPI_D3D12_RAYTRACING_INSTANCE_FLAG_TRIANGLE_CULL_DISABLE_EX = NV_BIT(0) , NVAPI_D3D12_RAYTRACING_INSTANCE_FLAG_TRIANGLE_FRONT_COUNTERCLOCKWISE_EX = NV_BIT(1) , NVAPI_D3D12_RAYTRACING_INSTANCE_FLAG_FORCE_OPAQUE_EX = NV_BIT(2) ,
NVAPI_D3D12_RAYTRACING_INSTANCE_FLAG_FORCE_NON_OPAQUE_EX = NV_BIT(3) , NVAPI_D3D12_RAYTRACING_INSTANCE_FLAG_FORCE_OMM_2_STATE_EX = NV_BIT(4) , NVAPI_D3D12_RAYTRACING_INSTANCE_FLAG_DISABLE_OMMS_EX = NV_BIT(5)
}
enum | _NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_ARRAY_POSTBUILD_INFO_TYPE { NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_ARRAY_POSTBUILD_INFO_CURRENT_SIZE = 0x0 }
enum | _NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_POSTBUILD_INFO_TYPE { NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_POSTBUILD_INFO_CURRENT_SIZE = 0x0 }
enum | _NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_STATE { NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_STATE_TRANSPARENT = 0 , NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_STATE_OPAQUE = 1 , NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_STATE_UNKNOWN_TRANSPARENT = 2 , NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_STATE_UNKNOWN_OPAQUE = 3 }
enum _NVAPI_RAY_FLAGS_EX {
NVAPI_RAY_FLAG_NONE_EX = 0x0 , NVAPI_RAY_FLAG_FORCE_OPAQUE_EX = NV_BIT( 0) , NVAPI_RAY_FLAG_FORCE_NON_OPAQUE_EX = NV_BIT( 1) , NVAPI_RAY_FLAG_ACCEPT_FIRST_HIT_AND_END_SEARCH_EX = NV_BIT( 2) ,
NVAPI_RAY_FLAG_SKIP_CLOSEST_HIT_SHADER_EX = NV_BIT( 3) , NVAPI_RAY_FLAG_CULL_BACK_FACING_TRIANGLES_EX = NV_BIT( 4) , NVAPI_RAY_FLAG_CULL_FRONT_FACING_TRIANGLES_EX = NV_BIT( 5) , NVAPI_RAY_FLAG_CULL_OPAQUE_EX = NV_BIT( 6) ,
NVAPI_RAY_FLAG_CULL_NON_OPAQUE_EX = NV_BIT( 7) , NVAPI_RAY_FLAG_SKIP_TRIANGLES_EX = NV_BIT( 8) , NVAPI_RAY_FLAG_SKIP_PROCEDURAL_PRIMITIVES_EX = NV_BIT( 9) , NVAPI_RAY_FLAG_FORCE_OMM_2_STATE_EX = NV_BIT(10)
}
enum | _NV_D3D12_WORKSTATION_FEATURE_TYPE { NV_D3D12_WORKSTATION_FEATURE_TYPE_PRESENT_BARRIER = 1 , NV_D3D12_WORKSTATION_FEATURE_TYPE_RDMA_BAR1_SUPPORT = 2 }
enum | _NVVIOOWNERTYPE { NVVIOOWNERTYPE_NONE , NVVIOOWNERTYPE_APPLICATION , NVVIOOWNERTYPE_DESKTOP }
enum _NVVIOSIGNALFORMAT {
NVVIOSIGNALFORMAT_NONE , NVVIOSIGNALFORMAT_487I_59_94_SMPTE259_NTSC , NVVIOSIGNALFORMAT_576I_50_00_SMPTE259_PAL , NVVIOSIGNALFORMAT_1035I_60_00_SMPTE260 ,
NVVIOSIGNALFORMAT_1035I_59_94_SMPTE260 , NVVIOSIGNALFORMAT_1080I_50_00_SMPTE295 , NVVIOSIGNALFORMAT_1080I_60_00_SMPTE274 , NVVIOSIGNALFORMAT_1080I_59_94_SMPTE274 ,
NVVIOSIGNALFORMAT_1080I_50_00_SMPTE274 , NVVIOSIGNALFORMAT_1080P_30_00_SMPTE274 , NVVIOSIGNALFORMAT_1080P_29_97_SMPTE274 , NVVIOSIGNALFORMAT_1080P_25_00_SMPTE274 ,
NVVIOSIGNALFORMAT_1080P_24_00_SMPTE274 , NVVIOSIGNALFORMAT_1080P_23_976_SMPTE274 , NVVIOSIGNALFORMAT_720P_60_00_SMPTE296 , NVVIOSIGNALFORMAT_720P_59_94_SMPTE296 ,
NVVIOSIGNALFORMAT_720P_50_00_SMPTE296 , NVVIOSIGNALFORMAT_1080I_48_00_SMPTE274 , NVVIOSIGNALFORMAT_1080I_47_96_SMPTE274 , NVVIOSIGNALFORMAT_720P_30_00_SMPTE296 ,
NVVIOSIGNALFORMAT_720P_29_97_SMPTE296 , NVVIOSIGNALFORMAT_720P_25_00_SMPTE296 , NVVIOSIGNALFORMAT_720P_24_00_SMPTE296 , NVVIOSIGNALFORMAT_720P_23_98_SMPTE296 ,
NVVIOSIGNALFORMAT_2048P_30_00_SMPTE372 , NVVIOSIGNALFORMAT_2048P_29_97_SMPTE372 , NVVIOSIGNALFORMAT_2048I_60_00_SMPTE372 , NVVIOSIGNALFORMAT_2048I_59_94_SMPTE372 ,
NVVIOSIGNALFORMAT_2048P_25_00_SMPTE372 , NVVIOSIGNALFORMAT_2048I_50_00_SMPTE372 , NVVIOSIGNALFORMAT_2048P_24_00_SMPTE372 , NVVIOSIGNALFORMAT_2048P_23_98_SMPTE372 ,
NVVIOSIGNALFORMAT_2048I_48_00_SMPTE372 , NVVIOSIGNALFORMAT_2048I_47_96_SMPTE372 , NVVIOSIGNALFORMAT_1080PSF_25_00_SMPTE274 , NVVIOSIGNALFORMAT_1080PSF_29_97_SMPTE274 ,
NVVIOSIGNALFORMAT_1080PSF_30_00_SMPTE274 , NVVIOSIGNALFORMAT_1080PSF_24_00_SMPTE274 , NVVIOSIGNALFORMAT_1080PSF_23_98_SMPTE274 , NVVIOSIGNALFORMAT_1080P_50_00_SMPTE274_3G_LEVEL_A ,
NVVIOSIGNALFORMAT_1080P_59_94_SMPTE274_3G_LEVEL_A , NVVIOSIGNALFORMAT_1080P_60_00_SMPTE274_3G_LEVEL_A , NVVIOSIGNALFORMAT_1080P_60_00_SMPTE274_3G_LEVEL_B , NVVIOSIGNALFORMAT_1080I_60_00_SMPTE274_3G_LEVEL_B ,
NVVIOSIGNALFORMAT_2048I_60_00_SMPTE372_3G_LEVEL_B , NVVIOSIGNALFORMAT_1080P_50_00_SMPTE274_3G_LEVEL_B , NVVIOSIGNALFORMAT_1080I_50_00_SMPTE274_3G_LEVEL_B , NVVIOSIGNALFORMAT_2048I_50_00_SMPTE372_3G_LEVEL_B ,
NVVIOSIGNALFORMAT_1080P_30_00_SMPTE274_3G_LEVEL_B , NVVIOSIGNALFORMAT_2048P_30_00_SMPTE372_3G_LEVEL_B , NVVIOSIGNALFORMAT_1080P_25_00_SMPTE274_3G_LEVEL_B , NVVIOSIGNALFORMAT_2048P_25_00_SMPTE372_3G_LEVEL_B ,
NVVIOSIGNALFORMAT_1080P_24_00_SMPTE274_3G_LEVEL_B , NVVIOSIGNALFORMAT_2048P_24_00_SMPTE372_3G_LEVEL_B , NVVIOSIGNALFORMAT_1080I_48_00_SMPTE274_3G_LEVEL_B , NVVIOSIGNALFORMAT_2048I_48_00_SMPTE372_3G_LEVEL_B ,
NVVIOSIGNALFORMAT_1080P_59_94_SMPTE274_3G_LEVEL_B , NVVIOSIGNALFORMAT_1080I_59_94_SMPTE274_3G_LEVEL_B , NVVIOSIGNALFORMAT_2048I_59_94_SMPTE372_3G_LEVEL_B , NVVIOSIGNALFORMAT_1080P_29_97_SMPTE274_3G_LEVEL_B ,
NVVIOSIGNALFORMAT_2048P_29_97_SMPTE372_3G_LEVEL_B , NVVIOSIGNALFORMAT_1080P_23_98_SMPTE274_3G_LEVEL_B , NVVIOSIGNALFORMAT_2048P_23_98_SMPTE372_3G_LEVEL_B , NVVIOSIGNALFORMAT_1080I_47_96_SMPTE274_3G_LEVEL_B ,
NVVIOSIGNALFORMAT_2048I_47_96_SMPTE372_3G_LEVEL_B , NVVIOSIGNALFORMAT_END
}
enum _NVVIOVIDEOSTANDARD {
NVVIOVIDEOSTANDARD_SMPTE259 , NVVIOVIDEOSTANDARD_SMPTE260 , NVVIOVIDEOSTANDARD_SMPTE274 , NVVIOVIDEOSTANDARD_SMPTE295 ,
NVVIOVIDEOSTANDARD_SMPTE296 , NVVIOVIDEOSTANDARD_SMPTE372
}
enum | _NVVIOVIDEOTYPE { NVVIOVIDEOTYPE_SD , NVVIOVIDEOTYPE_HD }
enum | _NVVIOINTERLACEMODE { NVVIOINTERLACEMODE_PROGRESSIVE , NVVIOINTERLACEMODE_INTERLACE , NVVIOINTERLACEMODE_PSF }
enum _NVVIODATAFORMAT {
NVVIODATAFORMAT_UNKNOWN = -1 , NVVIODATAFORMAT_R8G8B8_TO_YCRCB444 , NVVIODATAFORMAT_R8G8B8A8_TO_YCRCBA4444 , NVVIODATAFORMAT_R8G8B8Z10_TO_YCRCBZ4444 ,
NVVIODATAFORMAT_R8G8B8_TO_YCRCB422 , NVVIODATAFORMAT_R8G8B8A8_TO_YCRCBA4224 , NVVIODATAFORMAT_R8G8B8Z10_TO_YCRCBZ4224 , NVVIODATAFORMAT_X8X8X8_444_PASSTHRU ,
NVVIODATAFORMAT_X8X8X8A8_4444_PASSTHRU , NVVIODATAFORMAT_X8X8X8Z10_4444_PASSTHRU , NVVIODATAFORMAT_X10X10X10_444_PASSTHRU , NVVIODATAFORMAT_X10X8X8_444_PASSTHRU ,
NVVIODATAFORMAT_X10X8X8A10_4444_PASSTHRU , NVVIODATAFORMAT_X10X8X8Z10_4444_PASSTHRU , NVVIODATAFORMAT_DUAL_R8G8B8_TO_DUAL_YCRCB422 , NVVIODATAFORMAT_DUAL_X8X8X8_TO_DUAL_422_PASSTHRU ,
NVVIODATAFORMAT_R10G10B10_TO_YCRCB422 , NVVIODATAFORMAT_R10G10B10_TO_YCRCB444 , NVVIODATAFORMAT_X12X12X12_444_PASSTHRU , NVVIODATAFORMAT_X12X12X12_422_PASSTHRU ,
NVVIODATAFORMAT_Y10CR10CB10_TO_YCRCB422 , NVVIODATAFORMAT_Y8CR8CB8_TO_YCRCB422 , NVVIODATAFORMAT_Y10CR8CB8A10_TO_YCRCBA4224 , NVVIODATAFORMAT_R10G10B10_TO_RGB444 ,
NVVIODATAFORMAT_R12G12B12_TO_YCRCB444 , NVVIODATAFORMAT_R12G12B12_TO_YCRCB422
}
enum | _NVVIOOUTPUTAREA { NVVIOOUTPUTAREA_FULLSIZE , NVVIOOUTPUTAREA_SAFEACTION , NVVIOOUTPUTAREA_SAFETITLE }
enum | _NVVIOSYNCSOURCE { NVVIOSYNCSOURCE_SDISYNC , NVVIOSYNCSOURCE_COMPSYNC }
enum | _NVVIOCOMPSYNCTYPE { NVVIOCOMPSYNCTYPE_AUTO , NVVIOCOMPSYNCTYPE_BILEVEL , NVVIOCOMPSYNCTYPE_TRILEVEL }
enum | _NVVIOINPUTOUTPUTSTATUS { NVINPUTOUTPUTSTATUS_OFF , NVINPUTOUTPUTSTATUS_ERROR , NVINPUTOUTPUTSTATUS_SDI_SD , NVINPUTOUTPUTSTATUS_SDI_HD }
enum _NVVIOSYNCSTATUS {
NVVIOSYNCSTATUS_OFF , NVVIOSYNCSTATUS_ERROR , NVVIOSYNCSTATUS_SYNCLOSS , NVVIOSYNCSTATUS_COMPOSITE ,
NVVIOSYNCSTATUS_SDI_SD , NVVIOSYNCSTATUS_SDI_HD
}
enum | _NVVIOCAPTURESTATUS { NVVIOSTATUS_STOPPED , NVVIOSTATUS_RUNNING , NVVIOSTATUS_ERROR }
enum | _NVVIOSTATUSTYPE { NVVIOSTATUSTYPE_IN , NVVIOSTATUSTYPE_OUT }
enum | _NVVIOCONFIGTYPE { NVVIOCONFIGTYPE_IN , NVVIOCONFIGTYPE_OUT }
enum _NVVIOCOLORSPACE {
NVVIOCOLORSPACE_UNKNOWN , NVVIOCOLORSPACE_YCBCR , NVVIOCOLORSPACE_YCBCRA , NVVIOCOLORSPACE_YCBCRD ,
NVVIOCOLORSPACE_GBR , NVVIOCOLORSPACE_GBRA , NVVIOCOLORSPACE_GBRD
}
enum _NVVIOCOMPONENTSAMPLING {
NVVIOCOMPONENTSAMPLING_UNKNOWN , NVVIOCOMPONENTSAMPLING_4444 , NVVIOCOMPONENTSAMPLING_4224 , NVVIOCOMPONENTSAMPLING_444 ,
NVVIOCOMPONENTSAMPLING_422
}
enum | _NVVIOBITSPERCOMPONENT { NVVIOBITSPERCOMPONENT_UNKNOWN , NVVIOBITSPERCOMPONENT_8 , NVVIOBITSPERCOMPONENT_10 , NVVIOBITSPERCOMPONENT_12 }
enum _NVVIOLINKID {
NVVIOLINKID_UNKNOWN , NVVIOLINKID_A , NVVIOLINKID_B , NVVIOLINKID_C ,
NVVIOLINKID_D
}
enum | _NVVIOANCPARITYCOMPUTATION { NVVIOANCPARITYCOMPUTATION_AUTO , NVVIOANCPARITYCOMPUTATION_ON , NVVIOANCPARITYCOMPUTATION_OFF }
enum | _NVVIOPCILINKRATE { NVVIOPCILINKRATE_UNKNOWN = 0 , NVVIOPCILINKRATE_GEN1 = 1 , NVVIOPCILINKRATE_GEN2 = 2 , NVVIOPCILINKRATE_GEN3 = 3 }
enum _NVVIOPCILINKWIDTH {
NVVIOPCILINKWIDTH_UNKNOWN = 0 , NVVIOPCILINKWIDTH_x1 = 1 , NVVIOPCILINKWIDTH_x2 = 2 , NVVIOPCILINKWIDTH_x4 = 4 ,
NVVIOPCILINKWIDTH_x8 = 8 , NVVIOPCILINKWIDTH_x16 = 16
}
enum | _NV_StereoRegistryProfileType { NVAPI_STEREO_DEFAULT_REGISTRY_PROFILE , NVAPI_STEREO_DX9_REGISTRY_PROFILE , NVAPI_STEREO_DX10_REGISTRY_PROFILE }
enum | _NV_StereoRegistryID { NVAPI_CONVERGENCE_ID , NVAPI_FRUSTUM_ADJUST_MODE_ID }
enum | _NV_FrustumAdjustMode { NVAPI_NO_FRUSTUM_ADJUST , NVAPI_FRUSTUM_STRETCH , NVAPI_FRUSTUM_CLEAR_EDGES }
enum | _NVAPI_STEREO_INIT_ACTIVATION_FLAGS { NVAPI_STEREO_INIT_ACTIVATION_IMMEDIATE = 0X00 , NVAPI_STEREO_INIT_ACTIVATION_DELAYED = 0x01 }
enum | _NV_StereoSwapChainMode { NVAPI_STEREO_SWAPCHAIN_DEFAULT = 0 , NVAPI_STEREO_SWAPCHAIN_STEREO = 1 , NVAPI_STEREO_SWAPCHAIN_MONO = 2 }
enum | _NVDRS_SETTING_TYPE { NVDRS_DWORD_TYPE , NVDRS_BINARY_TYPE , NVDRS_STRING_TYPE , NVDRS_WSTRING_TYPE }
enum | _NVDRS_SETTING_LOCATION { NVDRS_CURRENT_PROFILE_LOCATION , NVDRS_GLOBAL_PROFILE_LOCATION , NVDRS_BASE_PROFILE_LOCATION , NVDRS_DEFAULT_PROFILE_LOCATION }
enum | NV_CHIPSET_INFO_FLAGS { NV_CHIPSET_INFO_HYBRID = 0x00000001 }
enum | _NV_GPU_CLIENT_UTIL_DOMAIN_ID { NV_GPU_CLIENT_UTIL_DOMAIN_GRAPHICS = 0 , NV_GPU_CLIENT_UTIL_DOMAIN_FRAME_BUFFER = 1 , NV_GPU_CLIENT_UTIL_DOMAIN_VIDEO = 2 , NV_GPU_CLIENT_UTIL_DOMAIN_RSVD = 3 }

Functions

NVAPI_INTERFACE NvAPI_Initialize ()
NVAPI_INTERFACE NvAPI_Unload ()
NVAPI_INTERFACE | NvAPI_GetErrorMessage (NvAPI_Status nr, NvAPI_ShortString szDesc)
NVAPI_INTERFACE | NvAPI_GetInterfaceVersionString (NvAPI_ShortString szDesc)
NVAPI_INTERFACE | NvAPI_GetInterfaceVersionStringEx (NvAPI_ShortString szDesc)
NVAPI_INTERFACE | NvAPI_GPU_GetEDID (NvPhysicalGpuHandle hPhysicalGpu, NvU32 displayOutputId, NV_EDID *pEDID)
__nvapi_deprecated_function ("Do not use this function - it is deprecated in release 290. Instead, use NvAPI_DISP_SetDisplayConfig.") NVAPI_INTERFACE NvAPI_SetViewEx(NvDisplayHandle hNvDisplay
__nvapi_deprecated_function ("Do not use this function - it is deprecated in release 290. Instead, use NvAPI_SYS_GetDriverAndBranchVersion.") NVAPI_INTERFACE NvAPI_GetDisplayDriverVersion(NvDisplayHandle hNvDisplay
NVAPI_INTERFACE | NvAPI_OGL_ExpertModeSet (NvU32 expertDetailLevel, NvU32 expertReportMask, NvU32 expertOutputMask, NVAPI_OGLEXPERT_CALLBACK expertCallback)
NVAPI_INTERFACE | NvAPI_OGL_ExpertModeGet (NvU32 *pExpertDetailLevel, NvU32 *pExpertReportMask, NvU32 *pExpertOutputMask, NVAPI_OGLEXPERT_CALLBACK *pExpertCallback)
NVAPI_INTERFACE | NvAPI_GPU_GetConnectedDisplayIds (__in NvPhysicalGpuHandle hPhysicalGpu, __inout_ecount_part_opt(*pDisplayIdCount, *pDisplayIdCount) NV_GPU_DISPLAYIDS *pDisplayIds, __inout NvU32 *pDisplayIdCount, __in NvU32 flags)
NVAPI_INTERFACE | NvAPI_GPU_GetAllDisplayIds (__in NvPhysicalGpuHandle hPhysicalGpu, __inout_ecount_part_opt(*pDisplayIdCount, *pDisplayIdCount) NV_GPU_DISPLAYIDS *pDisplayIds, __inout NvU32 *pDisplayIdCount)
NVAPI_INTERFACE | NvAPI_GPU_GetSystemType (NvPhysicalGpuHandle hPhysicalGpu, NV_SYSTEM_TYPE *pSystemType)
NVAPI_INTERFACE | NvAPI_GPU_GetActiveOutputs (NvPhysicalGpuHandle hPhysicalGpu, NvU32 *pOutputsMask)
NVAPI_INTERFACE | NvAPI_GPU_SetEDID (NvPhysicalGpuHandle hPhysicalGpu, NvU32 displayOutputId, NV_EDID *pEDID)
NVAPI_INTERFACE | NvAPI_GPU_GetOutputType (NvPhysicalGpuHandle hPhysicalGpu, NvU32 outputId, NV_GPU_OUTPUT_TYPE *pOutputType)
NVAPI_INTERFACE | NvAPI_GPU_ValidateOutputCombination (NvPhysicalGpuHandle hPhysicalGpu, NvU32 outputsMask)
NVAPI_INTERFACE | NvAPI_GPU_GetFullName (NvPhysicalGpuHandle hPhysicalGpu, NvAPI_ShortString szName)
NVAPI_INTERFACE | NvAPI_GPU_GetPCIIdentifiers (NvPhysicalGpuHandle hPhysicalGpu, NvU32 *pDeviceId, NvU32 *pSubSystemId, NvU32 *pRevisionId, NvU32 *pExtDeviceId)
NVAPI_INTERFACE | NvAPI_GPU_GetGPUType (__in NvPhysicalGpuHandle hPhysicalGpu, __inout NV_GPU_TYPE *pGpuType)
NVAPI_INTERFACE | NvAPI_GPU_GetBusType (NvPhysicalGpuHandle hPhysicalGpu, NV_GPU_BUS_TYPE *pBusType)
NVAPI_INTERFACE | NvAPI_GPU_GetBusId (NvPhysicalGpuHandle hPhysicalGpu, NvU32 *pBusId)
NVAPI_INTERFACE | NvAPI_GPU_GetBusSlotId (NvPhysicalGpuHandle hPhysicalGpu, NvU32 *pBusSlotId)
NVAPI_INTERFACE | NvAPI_GPU_GetIRQ (NvPhysicalGpuHandle hPhysicalGpu, NvU32 *pIRQ)
NVAPI_INTERFACE | NvAPI_GPU_GetVbiosRevision (NvPhysicalGpuHandle hPhysicalGpu, NvU32 *pBiosRevision)
NVAPI_INTERFACE | NvAPI_GPU_GetVbiosOEMRevision (NvPhysicalGpuHandle hPhysicalGpu, NvU32 *pBiosRevision)
NVAPI_INTERFACE | NvAPI_GPU_GetVbiosVersionString (NvPhysicalGpuHandle hPhysicalGpu, NvAPI_ShortString szBiosRevision)
__nvapi_deprecated_function ("Do not use this function - it is deprecated in release 455.") NVAPI_INTERFACE NvAPI_GPU_GetAGPAperture(NvPhysicalGpuHandle hPhysicalGpu
NVAPI_INTERFACE | NvAPI_GPU_GetCurrentPCIEDownstreamWidth (NvPhysicalGpuHandle hPhysicalGpu, NvU32 *pWidth)
NVAPI_INTERFACE | NvAPI_GPU_GetPhysicalFrameBufferSize (NvPhysicalGpuHandle hPhysicalGpu, NvU32 *pSize)
NVAPI_INTERFACE | NvAPI_GPU_GetVirtualFrameBufferSize (NvPhysicalGpuHandle hPhysicalGpu, NvU32 *pSize)
__nvapi_deprecated_function ("Do not use this function - it is deprecated in release 460.") NVAPI_INTERFACE NvAPI_GPU_GetQuadroStatus(NvPhysicalGpuHandle hPhysicalGpu
NVAPI_INTERFACE | NvAPI_GPU_GetBoardInfo (NvPhysicalGpuHandle hPhysicalGpu, NV_BOARD_INFO *pBoardInfo)
NVAPI_INTERFACE | NvAPI_GPU_GetRamBusWidth (NvPhysicalGpuHandle hPhysicalGpu, NvU32 *pBusWidth)
NVAPI_INTERFACE | NvAPI_GPU_GetArchInfo (NvPhysicalGpuHandle hPhysicalGpu, NV_GPU_ARCH_INFO *pGpuArchInfo)
NVAPI_INTERFACE | NvAPI_I2CRead (NvPhysicalGpuHandle hPhysicalGpu, NV_I2C_INFO *pI2cInfo)
NVAPI_INTERFACE | NvAPI_I2CWrite (NvPhysicalGpuHandle hPhysicalGpu, NV_I2C_INFO *pI2cInfo)
NVAPI_INTERFACE | NvAPI_GPU_WorkstationFeatureSetup (__in NvPhysicalGpuHandle hPhysicalGpu, __in NvU32 featureEnableMask, __in NvU32 featureDisableMask)
NVAPI_INTERFACE | NvAPI_GPU_WorkstationFeatureQuery (__in NvPhysicalGpuHandle hPhysicalGpu, __out_opt NvU32 *pConfiguredFeatureMask, __out_opt NvU32 *pConsistentFeatureMask)
NVAPI_INTERFACE | NvAPI_GPU_GetHDCPSupportStatus (NvPhysicalGpuHandle hPhysicalGpu, NV_GPU_GET_HDCP_SUPPORT_STATUS *pGetHDCPSupportStatus)
__nvapi_deprecated_function ("Do not use this function - it is deprecated in release 319.") NVAPI_INTERFACE NvAPI_GPU_CudaEnumComputeCapableGpus(__inout NV_COMPUTE_GPU_TOPOLOGY *pComputeTopo)
NVAPI_INTERFACE | NvAPI_GPU_GetTachReading (NvPhysicalGpuHandle hPhysicalGPU, NvU32 *pValue)
NVAPI_INTERFACE | NvAPI_GPU_GetECCStatusInfo (NvPhysicalGpuHandle hPhysicalGpu, NV_GPU_ECC_STATUS_INFO *pECCStatusInfo)
NVAPI_INTERFACE | NvAPI_GPU_GetECCErrorInfo (NvPhysicalGpuHandle hPhysicalGpu, NV_GPU_ECC_ERROR_INFO *pECCErrorInfo)
NVAPI_INTERFACE | NvAPI_GPU_ResetECCErrorInfo (NvPhysicalGpuHandle hPhysicalGpu, NvU8 bResetCurrent, NvU8 bResetAggregate)
NVAPI_INTERFACE | NvAPI_GPU_GetECCConfigurationInfo (NvPhysicalGpuHandle hPhysicalGpu, NV_GPU_ECC_CONFIGURATION_INFO *pECCConfigurationInfo)
NVAPI_INTERFACE | NvAPI_GPU_SetECCConfiguration (NvPhysicalGpuHandle hPhysicalGpu, NvU8 bEnable, NvU8 bEnableImmediately)
NVAPI_INTERFACE | NvAPI_GPU_QueryWorkstationFeatureSupport (NvPhysicalGpuHandle physicalGpu, NV_GPU_WORKSTATION_FEATURE_TYPE gpuWorkstationFeature)
NVAPI_INTERFACE | NvAPI_GPU_SetScanoutIntensity (NvU32 displayId, NV_SCANOUT_INTENSITY_DATA *scanoutIntensityData, int *pbSticky)
NVAPI_INTERFACE | NvAPI_GPU_GetScanoutIntensityState (__in NvU32 displayId, __inout NV_SCANOUT_INTENSITY_STATE_DATA *scanoutIntensityStateData)
NVAPI_INTERFACE | NvAPI_GPU_SetScanoutWarping (NvU32 displayId, NV_SCANOUT_WARPING_DATA *scanoutWarpingData, int *piMaxNumVertices, int *pbSticky)
NVAPI_INTERFACE | NvAPI_GPU_GetScanoutWarpingState (__in NvU32 displayId, __inout NV_SCANOUT_WARPING_STATE_DATA *scanoutWarpingStateData)
NVAPI_INTERFACE | NvAPI_GPU_SetScanoutCompositionParameter (NvU32 displayId, NV_GPU_SCANOUT_COMPOSITION_PARAMETER parameter, NV_GPU_SCANOUT_COMPOSITION_PARAMETER_VALUE parameterValue, float *pContainer)
NVAPI_INTERFACE | NvAPI_GPU_GetScanoutCompositionParameter (__in NvU32 displayId, __in NV_GPU_SCANOUT_COMPOSITION_PARAMETER parameter, __out NV_GPU_SCANOUT_COMPOSITION_PARAMETER_VALUE *parameterData, __out float *pContainer)
NVAPI_INTERFACE | NvAPI_GPU_GetScanoutConfiguration (NvU32 displayId, NvSBox *desktopRect, NvSBox *scanoutRect)
NVAPI_INTERFACE | NvAPI_GPU_GetScanoutConfigurationEx (__in NvU32 displayId, __inout NV_SCANOUT_INFORMATION *pScanoutInformation)
__nvapi_deprecated_function ("Do not use this function - it is deprecated in release 520. Instead, use NvAPI_GPU_GetLogicalGpuInfo.") NVAPI_INTERFACE NvAPI_GPU_GetAdapterIdFromPhysicalGpu(NvPhysicalGpuHandle hPhysicalGpu
NVAPI_INTERFACE | NvAPI_GPU_GetVirtualizationInfo (__in NvPhysicalGpuHandle hPhysicalGpu, __inout NV_GPU_VIRTUALIZATION_INFO *pVirtualizationInfo)
NVAPI_INTERFACE | NvAPI_GPU_GetLogicalGpuInfo (__in NvLogicalGpuHandle hLogicalGpu, __inout NV_LOGICAL_GPU_DATA *pLogicalGpuData)
NVAPI_INTERFACE | NvAPI_GPU_GetLicensableFeatures (__in NvPhysicalGpuHandle hPhysicalGpu, __inout NV_LICENSABLE_FEATURES *pLicensableFeatures)
NVAPI_INTERFACE | NvAPI_GPU_NVLINK_GetCaps (__in NvPhysicalGpuHandle hPhysicalGpu, __inout NVLINK_GET_CAPS *capsParams)
NVAPI_INTERFACE | NvAPI_GPU_NVLINK_GetStatus (__in NvPhysicalGpuHandle hPhysicalGpu, __inout NVLINK_GET_STATUS *statusParams)
NVAPI_INTERFACE | NvAPI_GPU_GetGPUInfo (__in NvPhysicalGpuHandle hPhysicalGpu, __inout NV_GPU_INFO *pGpuInfo)
NVAPI_INTERFACE | NvAPI_GPU_GetVRReadyData (__in NvPhysicalGpuHandle hPhysicalGpu, __inout NV_GPU_VR_READY *pGpuVrReadyData)
NVAPI_INTERFACE | NvAPI_GPU_GetGspFeatures (__in NvPhysicalGpuHandle hPhysicalGpu, __inout NV_GPU_GSP_INFO *pGspInfo)
NVAPI_INTERFACE | NvAPI_GPU_GetPerfDecreaseInfo (__in NvPhysicalGpuHandle hPhysicalGpu, __inout NvU32 *pPerfDecrInfo)
__nvapi_deprecated_function ("Do not use this function - it is deprecated in release 304. Instead, use NvAPI_GPU_GetPstates20.") NVAPI_INTERFACE NvAPI_GPU_GetPstatesInfoEx(NvPhysicalGpuHandle hPhysicalGpu
NVAPI_INTERFACE | NvAPI_GPU_GetPstates20 (__in NvPhysicalGpuHandle hPhysicalGpu, __inout NV_GPU_PERF_PSTATES20_INFO *pPstatesInfo)
NVAPI_INTERFACE | NvAPI_GPU_GetCurrentPstate (NvPhysicalGpuHandle hPhysicalGpu, NV_GPU_PERF_PSTATE_ID *pCurrentPstate)
NVAPI_INTERFACE | NvAPI_GPU_GetDynamicPstatesInfoEx (NvPhysicalGpuHandle hPhysicalGpu, NV_GPU_DYNAMIC_PSTATES_INFO_EX *pDynamicPstatesInfoEx)
NVAPI_INTERFACE | NvAPI_GPU_GetThermalSettings (NvPhysicalGpuHandle hPhysicalGpu, NvU32 sensorIndex, NV_GPU_THERMAL_SETTINGS *pThermalSettings)
NVAPI_INTERFACE | NvAPI_GPU_GetAllClockFrequencies (__in NvPhysicalGpuHandle hPhysicalGPU, __inout NV_GPU_CLOCK_FREQUENCIES *pClkFreqs)
NVAPI_INTERFACE | NvAPI_GPU_QueryIlluminationSupport (__inout NV_GPU_QUERY_ILLUMINATION_SUPPORT_PARM *pIlluminationSupportInfo)
NVAPI_INTERFACE | NvAPI_GPU_GetIllumination (NV_GPU_GET_ILLUMINATION_PARM *pIlluminationInfo)
NVAPI_INTERFACE | NvAPI_GPU_SetIllumination (NV_GPU_SET_ILLUMINATION_PARM *pIlluminationInfo)
NVAPI_INTERFACE | NvAPI_GPU_ClientIllumDevicesGetInfo (__in NvPhysicalGpuHandle hPhysicalGpu, __inout NV_GPU_CLIENT_ILLUM_DEVICE_INFO_PARAMS *pIllumDevicesInfo)
NVAPI_INTERFACE | NvAPI_GPU_ClientIllumDevicesGetControl (__in NvPhysicalGpuHandle hPhysicalGpu, __inout NV_GPU_CLIENT_ILLUM_DEVICE_CONTROL_PARAMS *pClientIllumDevicesControl)
NVAPI_INTERFACE | NvAPI_GPU_ClientIllumDevicesSetControl (__in NvPhysicalGpuHandle hPhysicalGpu, __inout NV_GPU_CLIENT_ILLUM_DEVICE_CONTROL_PARAMS *pClientIllumDevicesControl)
NVAPI_INTERFACE | NvAPI_GPU_ClientIllumZonesGetInfo (__in NvPhysicalGpuHandle hPhysicalGpu, __inout NV_GPU_CLIENT_ILLUM_ZONE_INFO_PARAMS *pIllumZonesInfo)
NVAPI_INTERFACE | NvAPI_GPU_ClientIllumZonesGetControl (__in NvPhysicalGpuHandle hPhysicalGpu, __inout NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_PARAMS *pIllumZonesControl)
NVAPI_INTERFACE | NvAPI_GPU_ClientIllumZonesSetControl (__in NvPhysicalGpuHandle hPhysicalGpu, __inout NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_PARAMS *pIllumZonesControl)
NVAPI_INTERFACE | NvAPI_Event_RegisterCallback (PNV_EVENT_REGISTER_CALLBACK eventCallback, NvEventHandle *phClient)
NVAPI_INTERFACE | NvAPI_Event_UnregisterCallback (NvEventHandle hClient)
NVAPI_INTERFACE | NvAPI_EnumNvidiaDisplayHandle (NvU32 thisEnum, NvDisplayHandle *pNvDispHandle)
NVAPI_INTERFACE | NvAPI_EnumNvidiaUnAttachedDisplayHandle (NvU32 thisEnum, NvUnAttachedDisplayHandle *pNvUnAttachedDispHandle)
NVAPI_INTERFACE | NvAPI_CreateDisplayFromUnAttachedDisplay (NvUnAttachedDisplayHandle hNvUnAttachedDisp, NvDisplayHandle *pNvDisplay)
NVAPI_INTERFACE | NvAPI_GetAssociatedNvidiaDisplayHandle (const char *szDisplayName, NvDisplayHandle *pNvDispHandle)
NVAPI_INTERFACE | NvAPI_DISP_GetAssociatedUnAttachedNvidiaDisplayHandle (const char *szDisplayName, NvUnAttachedDisplayHandle *pNvUnAttachedDispHandle)
NVAPI_INTERFACE | NvAPI_GetAssociatedNvidiaDisplayName (NvDisplayHandle NvDispHandle, NvAPI_ShortString szDisplayName)
NVAPI_INTERFACE | NvAPI_GetUnAttachedAssociatedDisplayName (NvUnAttachedDisplayHandle hNvUnAttachedDisp, NvAPI_ShortString szDisplayName)
NVAPI_INTERFACE | NvAPI_EnableHWCursor (NvDisplayHandle hNvDisplay)
NVAPI_INTERFACE | NvAPI_DisableHWCursor (NvDisplayHandle hNvDisplay)
NVAPI_INTERFACE | NvAPI_GetVBlankCounter (NvDisplayHandle hNvDisplay, NvU32 *pCounter)
NVAPI_INTERFACE | NvAPI_SetRefreshRateOverride (NvDisplayHandle hNvDisplay, NvU32 outputsMask, float refreshRate, NvU32 bSetDeferred)
NVAPI_INTERFACE | NvAPI_GetAssociatedDisplayOutputId (NvDisplayHandle hNvDisplay, NvU32 *pOutputId)
NVAPI_INTERFACE | NvAPI_GetDisplayPortInfo (__in_opt NvDisplayHandle hNvDisplay, __in NvU32 outputId, __inout NV_DISPLAY_PORT_INFO *pInfo)
NVAPI_INTERFACE | NvAPI_SetDisplayPort (NvDisplayHandle hNvDisplay, NvU32 outputId, NV_DISPLAY_PORT_CONFIG *pCfg)
NVAPI_INTERFACE | NvAPI_GetHDMISupportInfo (__in_opt NvDisplayHandle hNvDisplay, __in NvU32 outputId, __inout NV_HDMI_SUPPORT_INFO *pInfo)
NVAPI_INTERFACE | NvAPI_Disp_InfoFrameControl (__in NvU32 displayId, __inout NV_INFOFRAME_DATA *pInfoframeData)
NVAPI_INTERFACE | NvAPI_DISP_GetTiming (__in NvU32 displayId, __in NV_TIMING_INPUT *timingInput, __out NV_TIMING *pTiming)
NVAPI_INTERFACE | NvAPI_DISP_GetMonitorCapabilities (__in NvU32 displayId, __inout NV_MONITOR_CAPABILITIES *pMonitorCapabilities)
NVAPI_INTERFACE | NvAPI_DISP_GetMonitorColorCapabilities (__in NvU32 displayId, __inout_ecount_part_opt(*pColorCapsCount, *pColorCapsCount) NV_MONITOR_COLOR_CAPS *pMonitorColorCapabilities, __inout NvU32 *pColorCapsCount)
NVAPI_INTERFACE | NvAPI_DISP_EnumCustomDisplay (__in NvU32 displayId, __in NvU32 index, __inout NV_CUSTOM_DISPLAY *pCustDisp)
NVAPI_INTERFACE | NvAPI_DISP_TryCustomDisplay (__in_ecount(count) NvU32 *pDisplayIds, __in NvU32 count, __in_ecount(count) NV_CUSTOM_DISPLAY *pCustDisp)
NVAPI_INTERFACE | NvAPI_DISP_DeleteCustomDisplay (__in_ecount(count) NvU32 *pDisplayIds, __in NvU32 count, __in NV_CUSTOM_DISPLAY *pCustDisp)
NVAPI_INTERFACE | NvAPI_DISP_SaveCustomDisplay (__in_ecount(count) NvU32 *pDisplayIds, __in NvU32 count, __in NvU32 isThisOutputIdOnly, __in NvU32 isThisMonitorIdOnly)
NVAPI_INTERFACE | NvAPI_DISP_RevertCustomDisplayTrial (__in_ecount(count) NvU32 *pDisplayIds, __in NvU32 count)
__nvapi_deprecated_function ("Do not use this function - it is deprecated in release 290. Instead, use NvAPI_DISP_GetDisplayConfig.") NVAPI_INTERFACE NvAPI_GetView(NvDisplayHandle hNvDisplay
NVAPI_INTERFACE | NvAPI_GetSupportedViews (NvDisplayHandle hNvDisplay, NV_TARGET_VIEW_MODE *pTargetViews, NvU32 *pViewCount)
NVAPI_INTERFACE | NvAPI_DISP_GetDisplayIdByDisplayName (const char *displayName, NvU32 *displayId)
NVAPI_INTERFACE | NvAPI_DISP_GetDisplayConfig (__inout NvU32 *pathInfoCount, __out_ecount_full_opt(*pathInfoCount) NV_DISPLAYCONFIG_PATH_INFO *pathInfo)
NVAPI_INTERFACE | NvAPI_DISP_SetDisplayConfig (__in NvU32 pathInfoCount, __in_ecount(pathInfoCount) NV_DISPLAYCONFIG_PATH_INFO *pathInfo, __in NvU32 flags)
NVAPI_INTERFACE | NvAPI_DISP_GetAdaptiveSyncData (__in NvU32 displayId, __inout NV_GET_ADAPTIVE_SYNC_DATA *pAdaptiveSyncData)
NVAPI_INTERFACE | NvAPI_DISP_SetAdaptiveSyncData (__in NvU32 displayId, __in NV_SET_ADAPTIVE_SYNC_DATA *pAdaptiveSyncData)
NVAPI_INTERFACE | NvAPI_DISP_GetVirtualRefreshRateData (__in NvU32 displayId, __inout NV_GET_VIRTUAL_REFRESH_RATE_DATA *pVirtualRefreshRateData)
NVAPI_INTERFACE | NvAPI_DISP_SetVirtualRefreshRateData (__in NvU32 displayId, __in NV_SET_VIRTUAL_REFRESH_RATE_DATA *pVirtualRefreshRateData)
NVAPI_INTERFACE | NvAPI_DISP_SetPreferredStereoDisplay (__in NV_SET_PREFERRED_STEREO_DISPLAY *pPreferredStereoDisplay)
NVAPI_INTERFACE | NvAPI_DISP_GetPreferredStereoDisplay (__inout NV_GET_PREFERRED_STEREO_DISPLAY *pPreferredStereoDisplay)
NVAPI_INTERFACE | NvAPI_DISP_GetNvManagedDedicatedDisplays (__inout NvU32 *pDedicatedDisplayCount, __inout NV_MANAGED_DEDICATED_DISPLAY_INFO *pDedicatedDisplays)
NVAPI_INTERFACE | NvAPI_DISP_AcquireDedicatedDisplay (__in NvU32 displayId, __inout NvU64 *pDisplaySourceHandle)
NVAPI_INTERFACE | NvAPI_DISP_ReleaseDedicatedDisplay (__in NvU32 displayId)
NVAPI_INTERFACE | NvAPI_DISP_GetNvManagedDedicatedDisplayMetadata (__inout NV_MANAGED_DEDICATED_DISPLAY_METADATA *pDedicatedDisplayMetadata)
NVAPI_INTERFACE | NvAPI_DISP_SetNvManagedDedicatedDisplayMetadata (__inout NV_MANAGED_DEDICATED_DISPLAY_METADATA *pDedicatedDisplayMetadata)
NVAPI_INTERFACE | NvAPI_Disp_GetVRRInfo (__in NvU32 displayId, __inout NV_GET_VRR_INFO *pVrrInfo)
NVAPI_INTERFACE | NvAPI_Mosaic_GetSupportedTopoInfo (NV_MOSAIC_SUPPORTED_TOPO_INFO *pSupportedTopoInfo, NV_MOSAIC_TOPO_TYPE type)
NVAPI_INTERFACE | NvAPI_Mosaic_GetTopoGroup (NV_MOSAIC_TOPO_BRIEF *pTopoBrief, NV_MOSAIC_TOPO_GROUP *pTopoGroup)
NVAPI_INTERFACE | NvAPI_Mosaic_GetOverlapLimits (NV_MOSAIC_TOPO_BRIEF *pTopoBrief, NV_MOSAIC_DISPLAY_SETTING *pDisplaySetting, NvS32 *pMinOverlapX, NvS32 *pMaxOverlapX, NvS32 *pMinOverlapY, NvS32 *pMaxOverlapY)
NVAPI_INTERFACE | NvAPI_Mosaic_SetCurrentTopo (NV_MOSAIC_TOPO_BRIEF *pTopoBrief, NV_MOSAIC_DISPLAY_SETTING *pDisplaySetting, NvS32 overlapX, NvS32 overlapY, NvU32 enable)
NVAPI_INTERFACE | NvAPI_Mosaic_GetCurrentTopo (NV_MOSAIC_TOPO_BRIEF *pTopoBrief, NV_MOSAIC_DISPLAY_SETTING *pDisplaySetting, NvS32 *pOverlapX, NvS32 *pOverlapY)
NVAPI_INTERFACE | NvAPI_Mosaic_EnableCurrentTopo (NvU32 enable)
NVAPI_INTERFACE | NvAPI_Mosaic_SetDisplayGrids (__in_ecount(gridCount) NV_MOSAIC_GRID_TOPO *pGridTopologies, __in NvU32 gridCount, __in NvU32 setTopoFlags)
NVAPI_INTERFACE | NvAPI_Mosaic_ValidateDisplayGrids (__in NvU32 setTopoFlags, __in_ecount(gridCount) NV_MOSAIC_GRID_TOPO *pGridTopologies, __inout_ecount_full(gridCount) NV_MOSAIC_DISPLAY_TOPO_STATUS *pTopoStatus, __in NvU32 gridCount)
NVAPI_INTERFACE | NvAPI_Mosaic_EnumDisplayModes (__in NV_MOSAIC_GRID_TOPO *pGridTopology, __inout_ecount_part_opt(*pDisplayCount, *pDisplayCount) NV_MOSAIC_DISPLAY_SETTING *pDisplaySettings, __inout NvU32 *pDisplayCount)
NVAPI_INTERFACE | NvAPI_Mosaic_EnumDisplayGrids (__inout_ecount_part_opt(*pGridCount, *pGridCount) NV_MOSAIC_GRID_TOPO *pGridTopologies, __inout NvU32 *pGridCount)
NVAPI_INTERFACE | NvAPI_GetSupportedMosaicTopologies (NV_MOSAIC_SUPPORTED_TOPOLOGIES *pMosaicTopos)
NVAPI_INTERFACE | NvAPI_GetCurrentMosaicTopology (NV_MOSAIC_TOPOLOGY *pMosaicTopo, NvU32 *pEnabled)
NVAPI_INTERFACE | NvAPI_SetCurrentMosaicTopology (NV_MOSAIC_TOPOLOGY *pMosaicTopo)
NVAPI_INTERFACE | NvAPI_EnableCurrentMosaicTopology (NvU32 enable)
NVAPI_INTERFACE | NvAPI_GSync_EnumSyncDevices (__out NvGSyncDeviceHandle nvGSyncHandles[NVAPI_MAX_GSYNC_DEVICES], __out NvU32 *gsyncCount)
NVAPI_INTERFACE | NvAPI_GSync_QueryCapabilities (__in NvGSyncDeviceHandle hNvGSyncDevice, __inout NV_GSYNC_CAPABILITIES *pNvGSyncCapabilities)
NVAPI_INTERFACE | NvAPI_GSync_GetTopology (__in NvGSyncDeviceHandle hNvGSyncDevice, __inout_opt NvU32 *gsyncGpuCount, __inout_ecount_part_opt(*gsyncGpuCount, *gsyncGpuCount) NV_GSYNC_GPU *gsyncGPUs, __inout_opt NvU32 *gsyncDisplayCount, __inout_ecount_part_opt(*gsyncDisplayCount, *gsyncDisplayCount) NV_GSYNC_DISPLAY *gsyncDisplays)
NVAPI_INTERFACE | NvAPI_GSync_SetSyncStateSettings (__in NvU32 gsyncDisplayCount, __in_ecount(gsyncDisplayCount) NV_GSYNC_DISPLAY *pGsyncDisplays, __in NvU32 flags)
NVAPI_INTERFACE | NvAPI_GSync_GetControlParameters (__in NvGSyncDeviceHandle hNvGSyncDevice, __inout NV_GSYNC_CONTROL_PARAMS *pGsyncControls)
NVAPI_INTERFACE | NvAPI_GSync_SetControlParameters (__in NvGSyncDeviceHandle hNvGSyncDevice, __inout NV_GSYNC_CONTROL_PARAMS *pGsyncControls)
NVAPI_INTERFACE | NvAPI_GSync_AdjustSyncDelay (__in NvGSyncDeviceHandle hNvGSyncDevice, __in NVAPI_GSYNC_DELAY_TYPE delayType, __inout NV_GSYNC_DELAY *pGsyncDelay, __out_opt NvU32 *syncSteps)
NVAPI_INTERFACE | NvAPI_GSync_GetSyncStatus (__in NvGSyncDeviceHandle hNvGSyncDevice, __in NvPhysicalGpuHandle hPhysicalGpu, __inout NV_GSYNC_STATUS *status)
NVAPI_INTERFACE | NvAPI_GSync_GetStatusParameters (NvGSyncDeviceHandle hNvGSyncDevice, NV_GSYNC_STATUS_PARAMS *pStatusParams)
NVAPI_INTERFACE | NvAPI_D3D9_RegisterResource (IDirect3DResource9 *pResource)
NVAPI_INTERFACE | NvAPI_D3D9_UnregisterResource (IDirect3DResource9 *pResource)
NVAPI_INTERFACE | NvAPI_D3D9_AliasSurfaceAsTexture (IDirect3DDevice9 *pDev, IDirect3DSurface9 *pSurface, IDirect3DTexture9 **ppTexture, DWORD dwFlag)
NVAPI_INTERFACE | NvAPI_D3D9_StretchRectEx (IDirect3DDevice9 *pDevice, IDirect3DResource9 *pSourceResource, CONST RECT *pSourceRect, IDirect3DResource9 *pDestResource, CONST RECT *pDestRect, D3DTEXTUREFILTERTYPE Filter)
NVAPI_INTERFACE | NvAPI_D3D9_ClearRT (IDirect3DDevice9 *pDevice, NvU32 dwNumRects, CONST RECT *pRects, float r, float g, float b, float a)
NVAPI_INTERFACE | NvAPI_D3D9_GetSurfaceHandle (IDirect3DSurface9 *pSurface, NVDX_ObjectHandle *pHandle)
NVAPI_INTERFACE | NvAPI_D3D9_VideoSetStereoInfo (IDirect3DDevice9 *pDev, NV_DX_VIDEO_STEREO_INFO *pStereoInfo)
NVAPI_INTERFACE | NvAPI_D3D10_SetDepthBoundsTest (ID3D10Device *pDev, NvU32 bEnable, float fMinDepth, float fMaxDepth)
NVAPI_INTERFACE | NvAPI_D3D11_IsNvShaderExtnOpCodeSupported (__in IUnknown *pDev, __in NvU32 opCode, __out bool *pSupported)
NVAPI_INTERFACE | NvAPI_D3D11_SetNvShaderExtnSlot (__in IUnknown *pDev, __in NvU32 uavSlot)
NVAPI_INTERFACE | NvAPI_D3D12_SetNvShaderExtnSlotSpace (__in IUnknown *pDev, __in NvU32 uavSlot, __in NvU32 uavSpace)
NVAPI_INTERFACE | NvAPI_D3D12_SetNvShaderExtnSlotSpaceLocalThread (__in IUnknown *pDev, __in NvU32 uavSlot, __in NvU32 uavSpace)
NVAPI_INTERFACE | NvAPI_D3D11_SetNvShaderExtnSlotLocalThread (__in IUnknown *pDev, __in NvU32 uavSlot)
NVAPI_INTERFACE | NvAPI_D3D11_BeginUAVOverlapEx (__in IUnknown *pDeviceOrContext, __in NvU32 insertWFIFlags)
NVAPI_INTERFACE | NvAPI_D3D11_BeginUAVOverlap (__in IUnknown *pDeviceOrContext)
NVAPI_INTERFACE | NvAPI_D3D11_EndUAVOverlap (__in IUnknown *pDeviceOrContext)
NVAPI_INTERFACE | NvAPI_D3D11_GetResourceHandle (ID3D11Device *pDev, ID3D11Resource *pResource, NVDX_ObjectHandle *phObject)
NVAPI_INTERFACE | NvAPI_D3D_SetFPSIndicatorState (IUnknown *pDev, NvU8 doEnable)
NVAPI_INTERFACE | NvAPI_D3D9_Present (IDirect3DDevice9 *pDevice, IDirect3DSwapChain9 *pSwapChain, const RECT *pSourceRect, const RECT *pDestRect, HWND hDestWindowOverride, const RGNDATA *pDirtyRegion)
NVAPI_INTERFACE | NvAPI_D3D9_QueryFrameCount (IDirect3DDevice9 *pDevice, NvU32 *pFrameCount)
NVAPI_INTERFACE | NvAPI_D3D9_ResetFrameCount (IDirect3DDevice9 *pDevice)
NVAPI_INTERFACE | NvAPI_D3D9_QueryMaxSwapGroup (IDirect3DDevice9 *pDevice, NvU32 *pMaxGroups, NvU32 *pMaxBarriers)
NVAPI_INTERFACE | NvAPI_D3D9_QuerySwapGroup (IDirect3DDevice9 *pDevice, IDirect3DSwapChain9 *pSwapChain, NvU32 *pSwapGroup, NvU32 *pSwapBarrier)
NVAPI_INTERFACE | NvAPI_D3D9_JoinSwapGroup (IDirect3DDevice9 *pDevice, IDirect3DSwapChain9 *pSwapChain, NvU32 group, BOOL blocking)
NVAPI_INTERFACE | NvAPI_D3D9_BindSwapBarrier (IDirect3DDevice9 *pDevice, NvU32 group, NvU32 barrier)
NVAPI_INTERFACE | NvAPI_D3D_SetVerticalSyncMode (__in IUnknown *pDevice, __in NVAPI_VSYNC_MODE vsyncMode)
NVAPI_INTERFACE | NvAPI_D3D1x_Present (IUnknown *pDevice, IDXGISwapChain *pSwapChain, UINT SyncInterval, UINT Flags)
NVAPI_INTERFACE | NvAPI_D3D1x_QueryFrameCount (IUnknown *pDevice, NvU32 *pFrameCount)
NVAPI_INTERFACE | NvAPI_D3D1x_ResetFrameCount (IUnknown *pDevice)
NVAPI_INTERFACE | NvAPI_D3D1x_QueryMaxSwapGroup (IUnknown *pDevice, NvU32 *pMaxGroups, NvU32 *pMaxBarriers)
NVAPI_INTERFACE | NvAPI_D3D1x_QuerySwapGroup (IUnknown *pDevice, IDXGISwapChain *pSwapChain, NvU32 *pSwapGroup, NvU32 *pSwapBarrier)
NVAPI_INTERFACE | NvAPI_D3D1x_JoinSwapGroup (IUnknown *pDevice, IDXGISwapChain *pSwapChain, NvU32 group, BOOL blocking)
NVAPI_INTERFACE | NvAPI_D3D1x_BindSwapBarrier (IUnknown *pDevice, NvU32 group, NvU32 barrier)
NVAPI_INTERFACE | NvAPI_D3D12_QueryPresentBarrierSupport (__in ID3D12Device *pDevice, __out bool *pSupported)
NVAPI_INTERFACE | NvAPI_D3D12_CreatePresentBarrierClient (__in ID3D12Device *pDevice, __in IDXGISwapChain *pSwapChain, __out NvPresentBarrierClientHandle *pPresentBarrierClient)
NVAPI_INTERFACE | NvAPI_D3D12_RegisterPresentBarrierResources (__in NvPresentBarrierClientHandle presentBarrierClient, __in ID3D12Fence *pFence, __in ID3D12Resource **ppResources, __in NvU32 numResources)
NVAPI_INTERFACE | NvAPI_DestroyPresentBarrierClient (__in NvPresentBarrierClientHandle presentBarrierClient)
NVAPI_INTERFACE | NvAPI_JoinPresentBarrier (__in NvPresentBarrierClientHandle presentBarrierClient, __in NV_JOIN_PRESENT_BARRIER_PARAMS *pParams)
NVAPI_INTERFACE | NvAPI_LeavePresentBarrier (__in NvPresentBarrierClientHandle presentBarrierClient)
NVAPI_INTERFACE | NvAPI_QueryPresentBarrierFrameStatistics (__in NvPresentBarrierClientHandle presentBarrierClient, __out NV_PRESENT_BARRIER_FRAME_STATISTICS *pFrameStats)
NVAPI_INTERFACE | NvAPI_D3D12_CreateDDisplayPresentBarrierClient (__in ID3D12Device *pDevice, __in NvU32 sourceId, __out NvPresentBarrierClientHandle *pPresentBarrierClient)
NVAPI_INTERFACE | NvAPI_D3D11_CreateRasterizerState (__in ID3D11Device *pDevice, __in const NvAPI_D3D11_RASTERIZER_DESC_EX *pRasterizerDesc, __out ID3D11RasterizerState **ppRasterizerState)
NVAPI_INTERFACE | NvAPI_D3D_ConfigureAnsel (__in IUnknown *pDevice, __in NVAPI_ANSEL_CONFIGURATION_STRUCT *pNLSConfig)
NVAPI_INTERFACE | NvAPI_D3D11_CheckFeatureSupport (__in ID3D11Device *pDevice, __in NV_D3D11_FEATURE Feature, __out void *pFeatureSupportData, __in UINT FeatureSupportDataSize)
NVAPI_INTERFACE | NvAPI_D3D11_CreateImplicitMSAATexture2D (__in ID3D11Device *pDevice, __in const D3D11_TEXTURE2D_DESC *pDesc, __out ID3D11Texture2D **ppTexture2D)
NVAPI_INTERFACE | NvAPI_D3D12_CreateCommittedImplicitMSAATexture2D (__in ID3D12Device *pDevice, __in const D3D12_HEAP_PROPERTIES *pHeapProperties, D3D12_HEAP_FLAGS HeapFlags, __in const D3D12_RESOURCE_DESC *pDesc, D3D12_RESOURCE_STATES InitialResourceState, __in_opt const D3D12_CLEAR_VALUE *pOptimizedClearValue, REFIID riidResource, __out void **ppvResource)
NVAPI_INTERFACE | NvAPI_D3D11_ResolveSubresourceRegion (__in ID3D11Device *pDevice, __in ID3D11Texture2D *pDstResource, __in UINT DstSubresource, __in UINT DstX, __in UINT DstY, __in ID3D11Texture2D *pSrcResource, __in UINT SrcSubresource, __in_opt const RECT *pSrcRect, __in DXGI_FORMAT Format, __in NV_RESOLVE_MODE ResolveMode)
NVAPI_INTERFACE | NvAPI_D3D12_ResolveSubresourceRegion (__in ID3D12GraphicsCommandList1 *pCommandList, __in ID3D12Resource *pDstResource, __in UINT DstSubresource, __in UINT DstX, __in UINT DstY, __in ID3D12Resource *pSrcResource, __in UINT SrcSubresource, __in_opt RECT *pSrcRect, __in DXGI_FORMAT Format, __in NV_RESOLVE_MODE ResolveMode)
NVAPI_INTERFACE | NvAPI_D3D11_AliasMSAATexture2DAsNonMSAA (__in ID3D11Device *pDevice, __in ID3D11Texture2D *pInputTex, __out ID3D11Texture2D **ppOutTex)
NVAPI_INTERFACE | NvAPI_D3D11_CreateGeometryShaderEx_2 (__in ID3D11Device *pDevice, __in const void *pShaderBytecode, __in SIZE_T BytecodeLength, __in_opt ID3D11ClassLinkage *pClassLinkage, __in const NvAPI_D3D11_CREATE_GEOMETRY_SHADER_EX *pCreateGeometryShaderExArgs, __out ID3D11GeometryShader **ppGeometryShader)
NVAPI_INTERFACE | NvAPI_D3D11_CreateVertexShaderEx (__in ID3D11Device *pDevice, __in const void *pShaderBytecode, __in SIZE_T BytecodeLength, __in_opt ID3D11ClassLinkage *pClassLinkage, __in const NvAPI_D3D11_CREATE_VERTEX_SHADER_EX *pCreateVertexShaderExArgs, __out ID3D11VertexShader **ppVertexShader)
NVAPI_INTERFACE | NvAPI_D3D11_CreateHullShaderEx (__in ID3D11Device *pDevice, __in const void *pShaderBytecode, __in SIZE_T BytecodeLength, __in_opt ID3D11ClassLinkage *pClassLinkage, __in const NvAPI_D3D11_CREATE_HULL_SHADER_EX *pCreateHullShaderExArgs, __out ID3D11HullShader **ppHullShader)
NVAPI_INTERFACE | NvAPI_D3D11_CreateDomainShaderEx (__in ID3D11Device *pDevice, __in const void *pShaderBytecode, __in SIZE_T BytecodeLength, __in_opt ID3D11ClassLinkage *pClassLinkage, __in const NvAPI_D3D11_CREATE_DOMAIN_SHADER_EX *pCreateDomainShaderExArgs, __out ID3D11DomainShader **ppDomainShader)
NVAPI_INTERFACE | NvAPI_D3D11_CreatePixelShaderEx_2 (__in ID3D11Device *pDevice, __in const void *pShaderBytecode, __in SIZE_T BytecodeLength, __in_opt ID3D11ClassLinkage *pClassLinkage, __in const NvAPI_D3D11_CREATE_PIXEL_SHADER_EX *pCreatePixelShaderExArgs, __out ID3D11PixelShader **ppPixelShader)
NVAPI_INTERFACE | NvAPI_D3D11_CreateFastGeometryShaderExplicit (__in ID3D11Device *pDevice, __in const void *pShaderBytecode, __in SIZE_T BytecodeLength, __in_opt ID3D11ClassLinkage *pClassLinkage, __in const NvAPI_D3D11_CREATE_FASTGS_EXPLICIT_DESC *pCreateFastGSArgs, __out ID3D11GeometryShader **ppGeometryShader)
NVAPI_INTERFACE | NvAPI_D3D11_CreateFastGeometryShader (__in ID3D11Device *pDevice, __in const void *pShaderBytecode, __in SIZE_T BytecodeLength, __in_opt ID3D11ClassLinkage *pClassLinkage, __out ID3D11GeometryShader **ppGeometryShader)
NVAPI_INTERFACE | NvAPI_D3D11_DecompressView (__in ID3D11Device *pDevice, __in ID3D11DeviceContext *pDeviceContext, __in ID3D11View *pView)
NVAPI_INTERFACE | NvAPI_D3D12_CreateGraphicsPipelineState (__in ID3D12Device *pDevice, __in const D3D12_GRAPHICS_PIPELINE_STATE_DESC *pPSODesc, NvU32 numExtensions, __in const NVAPI_D3D12_PSO_EXTENSION_DESC **ppExtensions, __out ID3D12PipelineState **ppPSO)
NVAPI_INTERFACE | NvAPI_D3D12_CreateComputePipelineState (__in ID3D12Device *pDevice, __in const D3D12_COMPUTE_PIPELINE_STATE_DESC *pPSODesc, NvU32 numExtensions, __in const NVAPI_D3D12_PSO_EXTENSION_DESC **ppExtensions, __out ID3D12PipelineState **ppPSO)
NVAPI_INTERFACE | NvAPI_D3D12_SetDepthBoundsTestValues (__in ID3D12GraphicsCommandList *pCommandList, __in const float minDepth, __in const float maxDepth)
NVAPI_INTERFACE | NvAPI_D3D12_CreateReservedResource (__in ID3D12Device *pDevice, __in const D3D12_RESOURCE_DESC *pDesc, __in D3D12_RESOURCE_STATES InitialState, __in const D3D12_CLEAR_VALUE *pOptimizedClearValue, __in REFIID riid, __out void **ppvResource, __in bool bTexture2DArrayMipPack, __in ID3D12Heap *pHeap)
NVAPI_INTERFACE | NvAPI_D3D12_CreateHeap (__in ID3D12Device *pDevice, __in const D3D12_HEAP_DESC *pDesc, __in REFIID riid, __out void **ppvHeap)
NVAPI_INTERFACE | NvAPI_D3D12_CreateHeap2 (__in ID3D12Device *pDevice, __in const D3D12_HEAP_DESC *pDesc, __in const NV_HEAP_PARAMS *pNVHeapParams, __in REFIID riid, __out void **ppvHeap)
NVAPI_INTERFACE | NvAPI_D3D12_QueryCpuVisibleVidmem (__in ID3D12Device *pDevice, __out NvU64 *pTotalBytes, __out NvU64 *pFreeBytes)
NVAPI_INTERFACE | NvAPI_D3D12_ReservedResourceGetDesc (__in ID3D12Resource *pReservedResource, __out D3D12_RESOURCE_DESC *pDesc)
NVAPI_INTERFACE | NvAPI_D3D12_UpdateTileMappings (__in ID3D12CommandQueue *pCommandQueue, __in ID3D12Resource *pResource, __in UINT NumResourceRegions, __in const D3D12_TILED_RESOURCE_COORDINATE *pResourceRegionStartCoordinates, __in const D3D12_TILE_REGION_SIZE *pResourceRegionSizes, __in ID3D12Heap *pHeap, __in UINT NumRanges, __in const D3D12_TILE_RANGE_FLAGS *pRangeFlags, __in const UINT *pHeapRangeStartOffsets, __in const UINT *pRangeTileCounts, __in D3D12_TILE_MAPPING_FLAGS Flags)
NVAPI_INTERFACE | NvAPI_D3D12_CopyTileMappings (__in ID3D12CommandQueue *pCommandQueue, __in ID3D12Resource *pDstResource, __in const D3D12_TILED_RESOURCE_COORDINATE *pDstRegionStartCoordinate, __in ID3D12Resource *pSrcResource, __in const D3D12_TILED_RESOURCE_COORDINATE *pSrcRegionStartCoordinate, __in const D3D12_TILE_REGION_SIZE *pRegionSize, __in D3D12_TILE_MAPPING_FLAGS Flags)
NVAPI_INTERFACE | NvAPI_D3D12_ResourceAliasingBarrier (__in ID3D12GraphicsCommandList *pCommandList, __in UINT NumBarriers, __in const D3D12_RESOURCE_BARRIER *pBarriers)
NVAPI_INTERFACE | NvAPI_D3D12_CaptureUAVInfo (__in ID3D12Device *pDevice, __out NVAPI_UAV_INFO *pUAVInfo)
NVAPI_INTERFACE | NvAPI_D3D11_GetResourceGPUVirtualAddressEx (__in ID3D11Device *pDevice, __inout NV_GET_GPU_VIRTUAL_ADDRESS *pParams)
compile_time_assert (sizeof(NV_META_COMMAND_TENSOR_DESC)==112)
compile_time_assert (sizeof(NV_META_COMMAND_CREATE_CONVOLUTION_EX_DESC)==640)
compile_time_assert (sizeof(NV_META_COMMAND_CONVOLUTION_FUSE_DESC)==20)
compile_time_assert (sizeof(NV_META_COMMAND_CREATE_CONVOLUTION_EX_FUSED_DESC)==660)
NVAPI_INTERFACE | NvAPI_D3D11_EnumerateMetaCommands (__in ID3D11Device *pDevice, __inout NvU32 *pNumMetaCommands, __out_ecount_opt(*pNumMetaCommands) NVAPI_META_COMMAND_DESC *pDescs)
compile_time_assert (sizeof(NV_D3D11_META_COMMAND_INITIALIZE_CONVOLUTION_EX_DESC)==16)
compile_time_assert (sizeof(NV_D3D11_META_COMMAND_EXECUTE_CONVOLUTION_EX_DESC)==144)
compile_time_assert (sizeof(NV_D3D11_META_COMMAND_INITIALIZE_GEMM_DESC)==16)
compile_time_assert (sizeof(NV_D3D11_META_COMMAND_EXECUTE_GEMM_DESC)==96)
DECLARE_INTERFACE_ (__declspec(uuid("00BF193A-117B-42BC-BBCD-E964A0EA4F2B")) ID3D11NvMetaCommand_V1, IUnknown)
NVAPI_INTERFACE | NvAPI_D3D11_CreateMetaCommand (__in ID3D11Device *pDevice, __in REFGUID CommandId, __in_bcount(CreationParametersDataSize) const void *pCreationParametersData, __in NvU32 CreationParametersDataSize, __out ID3D11NvMetaCommand **ppMetaCommand)
NVAPI_INTERFACE | NvAPI_D3D11_InitializeMetaCommand (__in ID3D11DeviceContext *pDeviceContext, __in ID3D11NvMetaCommand *pMetaCommand, __in_bcount(InitializationParametersDataSize) const void *pInitializationParametersData, __in NvU32 InitializationParametersDataSize)
NVAPI_INTERFACE | NvAPI_D3D11_ExecuteMetaCommand (__in ID3D11DeviceContext *pDeviceContext, __in ID3D11NvMetaCommand *pMetaCommand, __in_bcount(ExecutionParametersDataSize) const void *pExecutionParametersData, __in NvU32 ExecutionParametersDataSize)
NVAPI_INTERFACE | NvAPI_D3D12_EnumerateMetaCommands (__in ID3D12Device *pDevice, __inout NvU32 *pNumMetaCommands, __out_ecount_opt(*pNumMetaCommands) NVAPI_META_COMMAND_DESC *pDescs)
compile_time_assert (sizeof(NV_D3D12_META_COMMAND_INITIALIZE_CONVOLUTION_EX_DESC)==8)
compile_time_assert (sizeof(NV_D3D12_META_COMMAND_EXECUTE_CONVOLUTION_EX_DESC)==72)
compile_time_assert (sizeof(NV_D3D12_META_COMMAND_INITIALIZE_GEMM_DESC)==8)
compile_time_assert (sizeof(NV_D3D12_META_COMMAND_EXECUTE_GEMM_DESC)==48)
NVAPI_INTERFACE | NvAPI_D3D12_CreateMetaCommand (__in ID3D12Device *pDevice, __in REFGUID CommandId, __in NvU32 NodeMask, __in_bcount(CreationParametersDataSize) const void *pCreationParametersData, __in NvU32 CreationParametersDataSize, __out ID3D12NvMetaCommand **ppMetaCommand)
NVAPI_INTERFACE | NvAPI_D3D12_InitializeMetaCommand (__in ID3D12GraphicsCommandList *pCommandlist, __in ID3D12NvMetaCommand *pMetaCommand, __in_bcount(InitializationParametersDataSize) const void *pInitializationParametersData, __in NvU32 InitializationParametersDataSize)
NVAPI_INTERFACE | NvAPI_D3D12_ExecuteMetaCommand (__in ID3D12GraphicsCommandList *pCommandlist, __in ID3D12NvMetaCommand *pMetaCommand, __in_bcount(ExecutionParametersDataSize) const void *pExecutionParametersData, __in NvU32 ExecutionParametersDataSize)
NVAPI_INTERFACE | NvAPI_D3D12_CreateCommittedResource (__in ID3D12Device *pDevice, __in const D3D12_HEAP_PROPERTIES *pHeapProperties, __in D3D12_HEAP_FLAGS HeapFlags, __in const D3D12_RESOURCE_DESC *pDesc, __in D3D12_RESOURCE_STATES InitialState, __in const D3D12_CLEAR_VALUE *pOptimizedClearValue, __in const NV_RESOURCE_PARAMS *pNVResourceParams, __in REFIID riid, __out_opt void **ppvResource, __out_opt bool *pSupported)
NVAPI_INTERFACE | NvAPI_D3D12_GetCopyableFootprints (__in ID3D12Device *pDevice, __in const D3D12_RESOURCE_DESC *pResourceDesc, __in const NV_RESOURCE_PARAMS *pNVResourceParams, __in UINT FirstSubresource, __in UINT NumSubresources, __in UINT64 BaseOffset, __out_ecount_opt(NumSubresources) D3D12_PLACED_SUBRESOURCE_FOOTPRINT *pLayouts, __out_ecount_opt(NumSubresources) UINT *pNumRows, __out_ecount_opt(NumSubresources) UINT64 *pRowSizeInBytes, __out_opt UINT64 *pTotalBytes)
NVAPI_INTERFACE | NvAPI_D3D12_CopyTextureRegion (__in ID3D12GraphicsCommandList *pCommandList, __in const D3D12_TEXTURE_COPY_LOCATION *pDst, __in UINT DstX, __in UINT DstY, __in UINT DstZ, __in const D3D12_TEXTURE_COPY_LOCATION *pSrc, __in_opt const D3D12_BOX *pSrcBox)
NVAPI_INTERFACE | NvAPI_D3D12_IsNvShaderExtnOpCodeSupported (__in ID3D12Device *pDevice, __in NvU32 opCode, __out bool *pSupported)
NVAPI_INTERFACE | NvAPI_D3D12_GetOptimalThreadCountForMesh (__in ID3D12Device *pDevice, __out NvU32 *pThreadCount)
NVAPI_INTERFACE | NvAPI_D3D_IsGSyncCapable (__in IUnknown *pDeviceOrContext, __in NVDX_ObjectHandle primarySurface, __out BOOL *pIsGsyncCapable)
NVAPI_INTERFACE | NvAPI_D3D_IsGSyncActive (__in IUnknown *pDeviceOrContext, __in NVDX_ObjectHandle primarySurface, __out BOOL *pIsGsyncActive)
NVAPI_INTERFACE | NvAPI_D3D1x_DisableShaderDiskCache (IUnknown *pDevice)
NVAPI_INTERFACE | NvAPI_D3D11_MultiGPU_GetCaps (__inout PNV_MULTIGPU_CAPS pMultiGPUCaps)
NVAPI_INTERFACE | NvAPI_D3D11_MultiGPU_Init (__in bool bEnable)
DECLARE_INTERFACE (ID3D11MultiGPUDevice_V1)
NVAPI_INTERFACE | NvAPI_D3D11_CreateMultiGPUDevice (__in ID3D11Device *pDevice, __in ULONG version, __out ULONG *currentVersion, __out ID3D11MultiGPUDevice **ppD3D11MultiGPUDevice, __in UINT maxGpus=ALL_GPUS)
NVAPI_INTERFACE | NvAPI_D3D_QuerySinglePassStereoSupport (__in IUnknown *pDevice, __inout NV_QUERY_SINGLE_PASS_STEREO_SUPPORT_PARAMS *pQuerySinglePassStereoSupportedParams)
NVAPI_INTERFACE | NvAPI_D3D_SetSinglePassStereoMode (__in IUnknown *pDevOrContext, __in NvU32 numViews, __in NvU32 renderTargetIndexOffset, __in NvU8 independentViewportMaskEnable)
NVAPI_INTERFACE | NvAPI_D3D12_QuerySinglePassStereoSupport (__in ID3D12Device *pDevice, __inout NV_QUERY_SINGLE_PASS_STEREO_SUPPORT_PARAMS *pQuerySinglePassStereoSupportedParams)
NVAPI_INTERFACE | NvAPI_D3D12_SetSinglePassStereoMode (__in ID3D12GraphicsCommandList *pCommandList, __in NvU32 numViews, __in NvU32 renderTargetIndexOffset, __in NvU8 independentViewportMaskEnable)
NVAPI_INTERFACE | NvAPI_D3D_QueryMultiViewSupport (__in IUnknown *pDevice, __inout NV_QUERY_MULTIVIEW_SUPPORT_PARAMS *pQueryMultiViewSupportedParams)
NVAPI_INTERFACE | NvAPI_D3D_SetMultiViewMode (__in IUnknown *pDevOrContext, __in NV_MULTIVIEW_PARAMS *pMultiViewParams)
NVAPI_INTERFACE | NvAPI_D3D_QueryModifiedWSupport (__in IUnknown *pDev, __inout NV_QUERY_MODIFIED_W_SUPPORT_PARAMS *pQueryModifiedWSupportedParams)
NVAPI_INTERFACE | NvAPI_D3D_SetModifiedWMode (__in IUnknown *pDevOrContext, __in NV_MODIFIED_W_PARAMS *psModifiedWParams)
NVAPI_INTERFACE | NvAPI_D3D12_QueryModifiedWSupport (__in ID3D12Device *pDevice, __inout NV_QUERY_MODIFIED_W_SUPPORT_PARAMS *pQueryModifiedWSupportedParams)
NVAPI_INTERFACE | NvAPI_D3D12_SetModifiedWMode (__in ID3D12GraphicsCommandList *pCommandList, __in NV_MODIFIED_W_PARAMS *pModifiedWParams)
DECLARE_INTERFACE (ID3DLateLatchObject_V1)
NVAPI_INTERFACE | NvAPI_D3D_CreateLateLatchObject (__in IUnknown *pDevice, __inout NV_D3D_LATELATCH_OBJECT_DESC *pLateLatchObjectDesc)
NVAPI_INTERFACE | NvAPI_D3D_QueryLateLatchSupport (__in IUnknown *pDevice, __inout NV_QUERY_LATELATCH_SUPPORT_PARAMS *pQueryLateLatchSupportParams)
NVAPI_INTERFACE | NvAPI_D3D_RegisterDevice (__in IUnknown *pDev)
NVAPI_INTERFACE | NvAPI_D3D11_MultiDrawInstancedIndirect (__in ID3D11DeviceContext *pDevContext11, __in NvU32 drawCount, __in ID3D11Buffer *pBuffer, __in NvU32 alignedByteOffsetForArgs, __in NvU32 alignedByteStrideForArgs)
NVAPI_INTERFACE | NvAPI_D3D11_MultiDrawIndexedInstancedIndirect (__in ID3D11DeviceContext *pDevContext11, __in NvU32 drawCount, __in ID3D11Buffer *pBuffer, __in NvU32 alignedByteOffsetForArgs, __in NvU32 alignedByteStrideForArgs)
NVAPI_INTERFACE | NvAPI_D3D_ImplicitSLIControl (__in IMPLICIT_SLI_CONTROL implicitSLIControl)
NVAPI_INTERFACE | NvAPI_D3D12_GetNeedsAppFPBlendClamping (__in ID3D12Device *pDevice, __out bool *pAppClampNeeded)
NVAPI_INTERFACE | NvAPI_D3D12_UseDriverHeapPriorities (__in ID3D12Device *pDevice)
NVAPI_INTERFACE | NvAPI_D3D12_Mosaic_GetCompanionAllocations (__inout NV_D3D12_MOSAIC_GETCOMPANIONALLOCATIONS *params)
NVAPI_INTERFACE | NvAPI_D3D12_Mosaic_GetViewportAndGpuPartitions (__inout NV_D3D12_MOSAIC_GETVIEWPORTANDGPUPARTITIONS *params)
NVAPI_INTERFACE | NvAPI_D3D1x_GetGraphicsCapabilities (__in IUnknown *pDevice, __in NvU32 structVersion, __inout NV_D3D1x_GRAPHICS_CAPS *pGraphicsCaps)
NVAPI_INTERFACE | NvAPI_D3D12_GetGraphicsCapabilities (__in IUnknown *pDevice, __in NvU32 structVersion, __inout NV_D3D12_GRAPHICS_CAPS *pGraphicsCaps)
NVAPI_INTERFACE | NvAPI_D3D11_RSSetExclusiveScissorRects (__in IUnknown *pContext, __in NV_D3D11_EXCLUSIVE_SCISSOR_RECTS_DESC *pExclusiveScissorRectsDesc)
NVAPI_INTERFACE | NvAPI_D3D11_RSSetViewportsPixelShadingRates (__in IUnknown *pContext, __in NV_D3D11_VIEWPORTS_SHADING_RATE_DESC *pShadingRateDesc)
DECLARE_INTERFACE_ (__declspec(uuid("E14BE7F6-8FF5-4F5E-B63A-AD016EB8FBE5")) ID3D11NvShadingRateResourceView_V1, ID3D11View)
NVAPI_INTERFACE | NvAPI_D3D11_CreateShadingRateResourceView (__in ID3D11Device *pDevice, __in ID3D11Resource *pShadingRateResource, __in NV_D3D11_SHADING_RATE_RESOURCE_VIEW_DESC *pShadingRateResourceViewDesc, __out ID3D11NvShadingRateResourceView **ppShadingRateResourceView)
NVAPI_INTERFACE | NvAPI_D3D11_RSSetShadingRateResourceView (__in IUnknown *pContext, __in ID3D11NvShadingRateResourceView *pShadingRateResourceView)
NVAPI_INTERFACE | NvAPI_D3D11_RSGetPixelShadingRateSampleOrder (__in IUnknown *pContext, __out NV_PIXEL_SHADING_RATE_SAMPLE_ORDER_TABLE *pSampleOrderTable)
NVAPI_INTERFACE | NvAPI_D3D11_RSSetPixelShadingRateSampleOrder (__in IUnknown *pContext, __in NV_PIXEL_SHADING_RATE_SAMPLE_ORDER_TABLE *pSampleOrderTable)
DECLARE_INTERFACE (ID3DNvVRSHelper_V1)
NVAPI_INTERFACE | NvAPI_D3D_InitializeVRSHelper (__in IUnknown *pDevice, __inout NV_VRS_HELPER_INIT_PARAMS *pInitializeVRSHelperParams)
DECLARE_INTERFACE (ID3DNvGazeHandler_V2)
DECLARE_INTERFACE (ID3DNvGazeHandler_V1)
NVAPI_INTERFACE | NvAPI_D3D_InitializeNvGazeHandler (__in IUnknown *pDevice, __inout NV_GAZE_HANDLER_INIT_PARAMS *pInitializeNvGazeHandlerParams)
DECLARE_INTERFACE (ID3DNvSMPAssist_V1)
NVAPI_INTERFACE | NvAPI_D3D_InitializeSMPAssist (__in IUnknown *pDevice, __inout NV_SMP_ASSIST_INITIALIZE_PARAMS *pSMPAssistInitParams)
NVAPI_INTERFACE | NvAPI_D3D_QuerySMPAssistSupport (__in IUnknown *pDev, __inout NV_QUERY_SMP_ASSIST_SUPPORT_PARAMS *pQuerySMPAssistSupportParams)
NVAPI_INTERFACE | NvAPI_D3D_GetSleepStatus (__in IUnknown *pDev, __in NV_GET_SLEEP_STATUS_PARAMS *pGetSleepStatusParams)
NVAPI_INTERFACE | NvAPI_D3D_SetSleepMode (__in IUnknown *pDev, __in NV_SET_SLEEP_MODE_PARAMS *pSetSleepModeParams)
NVAPI_INTERFACE | NvAPI_D3D_Sleep (__in IUnknown *pDev)
NVAPI_INTERFACE | NvAPI_D3D_SetReflexSync (__in IUnknown *pDev, __in NV_SET_REFLEX_SYNC_PARAMS *pSetReflexSyncParams)
NVAPI_INTERFACE | NvAPI_D3D_GetLatency (__in IUnknown *pDev, __out NV_LATENCY_RESULT_PARAMS *pGetLatencyParams)
NVAPI_INTERFACE | NvAPI_D3D_SetLatencyMarker (__in IUnknown *pDev, __in NV_LATENCY_MARKER_PARAMS *pSetLatencyMarkerParams)
NVAPI_INTERFACE | NvAPI_D3D12_SetAsyncFrameMarker (__in ID3D12CommandQueue *pCommandQueue, __in NV_ASYNC_FRAME_MARKER_PARAMS *pSetAsyncFrameMarkerParams)
NVAPI_INTERFACE | NvAPI_D3D12_NotifyOutOfBandCommandQueue (__in ID3D12CommandQueue *pCommandQueue, __in NV_OUT_OF_BAND_CQ_TYPE cqType)
NVAPI_INTERFACE | NvAPI_D3D12_SetCreateCommandQueueLowLatencyHint (__in ID3D12Device *pDevice)
NVAPI_INTERFACE | NvAPI_D3D12_CreateCubinComputeShaderExV2 (__inout NVAPI_D3D12_CREATE_CUBIN_SHADER_PARAMS *pParams)
NVAPI_INTERFACE | NvAPI_D3D12_CreateCubinComputeShader (__in ID3D12Device *pDevice, __in const void *pCubin, __in NvU32 size, __in NvU32 blockX, __in NvU32 blockY, __in NvU32 blockZ, __out NVDX_ObjectHandle *phShader)
NVAPI_INTERFACE | NvAPI_D3D12_CreateCubinComputeShaderEx (__in ID3D12Device *pDevice, __in const void *pCubin, __in NvU32 size, __in NvU32 blockX, __in NvU32 blockY, __in NvU32 blockZ, __in NvU32 dynSharedMemBytes, __in const char *pShaderName, __out NVDX_ObjectHandle *phShader)
NVAPI_INTERFACE | NvAPI_D3D12_CreateCubinComputeShaderWithName (__in ID3D12Device *pDevice, __in const void *pCubin, __in NvU32 size, __in NvU32 blockX, __in NvU32 blockY, __in NvU32 blockZ, __in const char *pShaderName, __out NVDX_ObjectHandle *phShader)
NVAPI_INTERFACE | NvAPI_D3D12_LaunchCubinShader (__in ID3D12GraphicsCommandList *pCommandList, __in NVDX_ObjectHandle hShader, __in NvU32 gridX, __in NvU32 gridY, __in NvU32 gridZ, __in const void *pParams, __in NvU32 paramSize)
NVAPI_INTERFACE | NvAPI_D3D12_DestroyCubinComputeShader (__in ID3D12Device *pDevice, __in NVDX_ObjectHandle hShader)
NVAPI_INTERFACE | NvAPI_D3D12_GetCudaMergedTextureSamplerObject (__inout NVAPI_D3D12_GET_CUDA_MERGED_TEXTURE_SAMPLER_OBJECT_PARAMS *pParams)
NVAPI_INTERFACE | NvAPI_D3D12_GetCudaIndependentDescriptorObject (__inout NVAPI_D3D12_GET_CUDA_INDEPENDENT_DESCRIPTOR_OBJECT_PARAMS *pParams)
NVAPI_INTERFACE | NvAPI_D3D12_GetCudaTextureObject (__in ID3D12Device *pDevice, __in D3D12_CPU_DESCRIPTOR_HANDLE texDesc, __in D3D12_CPU_DESCRIPTOR_HANDLE smpDesc, __out NvU32 *pTextureHandle)
NVAPI_INTERFACE | NvAPI_D3D12_GetCudaSurfaceObject (__in ID3D12Device *pDevice, __in D3D12_CPU_DESCRIPTOR_HANDLE uavDesc, __out NvU32 *pSurfaceHandle)
NVAPI_INTERFACE | NvAPI_D3D12_IsFatbinPTXSupported (__in ID3D12Device *pDevice, __out bool *pSupported)
NVAPI_INTERFACE | NvAPI_D3D12_CreateCuModule (__in ID3D12Device *pDevice, __in const void *pBlob, __in NvU32 size, __out NVDX_ObjectHandle *phModule)
NVAPI_INTERFACE | NvAPI_D3D12_EnumFunctionsInModule (__in ID3D12Device *pDevice, __in NVDX_ObjectHandle hModule, __inout NvU32 *pArraySize, __out const char **const pFunctionNames)
NVAPI_INTERFACE | NvAPI_D3D12_CreateCuFunction (__in ID3D12Device *pDevice, __in NVDX_ObjectHandle hModule, __in const char *pName, __out NVDX_ObjectHandle *phFunction)
NVAPI_INTERFACE | NvAPI_D3D12_LaunchCuKernelChain (__in ID3D12GraphicsCommandList *pCommandList, __in const NVAPI_CU_KERNEL_LAUNCH_PARAMS *pKernels, __in NvU32 numKernels)
NVAPI_INTERFACE | NvAPI_D3D12_LaunchCuKernelChainEx (__in ID3D12GraphicsCommandList *pCommandList, __in const NVAPI_CU_KERNEL_LAUNCH_PARAMS_EX *pKernels, __in NvU32 numKernels)
NVAPI_INTERFACE | NvAPI_D3D12_DestroyCuModule (__in ID3D12Device *pDevice, __in NVDX_ObjectHandle hModule)
NVAPI_INTERFACE | NvAPI_D3D12_DestroyCuFunction (__in ID3D12Device *pDevice, __in NVDX_ObjectHandle hFunction)
NVAPI_INTERFACE | NvAPI_D3D11_CreateCubinComputeShader (__in ID3D11Device *pDevice, __in const void *pCubin, __in NvU32 size, __in NvU32 blockX, __in NvU32 blockY, __in NvU32 blockZ, __out NVDX_ObjectHandle *phShader)
NVAPI_INTERFACE | NvAPI_D3D11_CreateCubinComputeShaderEx (__in ID3D11Device *pDevice, __in const void *pCubin, __in NvU32 size, __in NvU32 blockX, __in NvU32 blockY, __in NvU32 blockZ, __in NvU32 dynSharedMemBytes, __in const char *pShaderName, __out NVDX_ObjectHandle *phShader)
NVAPI_INTERFACE | NvAPI_D3D11_CreateCubinComputeShaderWithName (__in ID3D11Device *pDevice, __in const void *pCubin, __in NvU32 size, __in NvU32 blockX, __in NvU32 blockY, __in NvU32 blockZ, __in const char *pShaderName, __out NVDX_ObjectHandle *phShader)
NVAPI_INTERFACE | NvAPI_D3D11_LaunchCubinShader (__in ID3D11DeviceContext *pDeviceContext, __in NVDX_ObjectHandle hShader, __in NvU32 gridX, __in NvU32 gridY, __in NvU32 gridZ, __in const void *pParams, __in NvU32 paramSize, __in const NVDX_ObjectHandle *pReadResources, __in NvU32 numReadResources, __in const NVDX_ObjectHandle *pWriteResources, __in NvU32 numWriteResources)
NVAPI_INTERFACE | NvAPI_D3D11_DestroyCubinComputeShader (__in ID3D11Device *pDevice, __in NVDX_ObjectHandle hShader)
NVAPI_INTERFACE | NvAPI_D3D11_IsFatbinPTXSupported (__in ID3D11Device *pDevice, __out bool *pSupported)
NVAPI_INTERFACE | NvAPI_D3D11_CreateUnorderedAccessView (__in ID3D11Device *pDevice, __in ID3D11Resource *pResource, __in const D3D11_UNORDERED_ACCESS_VIEW_DESC *pDesc, __out ID3D11UnorderedAccessView **ppUAV, __out NvU32 *pDriverHandle)
NVAPI_INTERFACE | NvAPI_D3D11_CreateShaderResourceView (__in ID3D11Device *pDevice, __in ID3D11Resource *pResource, __in const D3D11_SHADER_RESOURCE_VIEW_DESC *pDesc, __out ID3D11ShaderResourceView **ppSRV, __out NvU32 *pDriverHandle)
NVAPI_INTERFACE | NvAPI_D3D11_CreateSamplerState (__in ID3D11Device *pDevice, __in const D3D11_SAMPLER_DESC *pSamplerDesc, __out ID3D11SamplerState **ppSamplerState, __out NvU32 *pDriverHandle)
NVAPI_INTERFACE | NvAPI_D3D11_GetCudaTextureObject (__in ID3D11Device *pDevice, __in NvU32 srvDriverHandle, __in NvU32 samplerDriverHandle, __out NvU32 *pCudaTextureHandle)
NVAPI_INTERFACE | NvAPI_D3D11_GetResourceGPUVirtualAddress (__in ID3D11Device *pDevice, __in const NVDX_ObjectHandle hResource, __out NvU64 *pGpuVA)
NVAPI_INTERFACE | NvAPI_D3D12_GetRaytracingCaps (__in ID3D12Device *pDevice, __in NVAPI_D3D12_RAYTRACING_CAPS_TYPE type, __out void *pData, __in size_t dataSize)
NVAPI_INTERFACE | NvAPI_D3D12_EnableRaytracingValidation (__in ID3D12Device5 *pDevice, __in NVAPI_D3D12_RAYTRACING_VALIDATION_FLAGS flags)
NVAPI_INTERFACE | NvAPI_D3D12_RegisterRaytracingValidationMessageCallback (__in ID3D12Device5 *pDevice, __in NVAPI_D3D12_RAYTRACING_VALIDATION_MESSAGE_CALLBACK pfnMessageCallback, __in_opt void *pUserData, __out void **pHandle)
NVAPI_INTERFACE | NvAPI_D3D12_UnregisterRaytracingValidationMessageCallback (__in ID3D12Device5 *pDevice, __in void *handle)
NVAPI_INTERFACE | NvAPI_D3D12_FlushRaytracingValidationMessages (__in ID3D12Device5 *pDevice)
NVAPI_INTERFACE | NvAPI_D3D12_GetRaytracingDisplacementMicromapArrayPrebuildInfo (__in ID3D12Device5 *pDevice, __inout NVAPI_GET_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PREBUILD_INFO_PARAMS *pParams)
NVAPI_INTERFACE | NvAPI_D3D12_GetRaytracingOpacityMicromapArrayPrebuildInfo (__in ID3D12Device5 *pDevice, __inout NVAPI_GET_RAYTRACING_OPACITY_MICROMAP_ARRAY_PREBUILD_INFO_PARAMS *pParams)
NVAPI_INTERFACE | NvAPI_D3D12_SetCreatePipelineStateOptions (__in ID3D12Device5 *pDevice, __in const NVAPI_D3D12_SET_CREATE_PIPELINE_STATE_OPTIONS_PARAMS *pState)
NVAPI_INTERFACE | NvAPI_D3D12_CheckDriverMatchingIdentifierEx (__in ID3D12Device5 *pDevice, __inout NVAPI_CHECK_DRIVER_MATCHING_IDENTIFIER_EX_PARAMS *pParams)
NVAPI_INTERFACE | NvAPI_D3D12_GetRaytracingAccelerationStructurePrebuildInfoEx (__in ID3D12Device5 *pDevice, __inout NVAPI_GET_RAYTRACING_ACCELERATION_STRUCTURE_PREBUILD_INFO_EX_PARAMS *pParams)
NVAPI_INTERFACE | NvAPI_D3D12_BuildRaytracingOpacityMicromapArray (__in ID3D12GraphicsCommandList4 *pCommandList, __in NVAPI_BUILD_RAYTRACING_OPACITY_MICROMAP_ARRAY_PARAMS *pParams)
NVAPI_INTERFACE | NvAPI_D3D12_RelocateRaytracingOpacityMicromapArray (__in ID3D12GraphicsCommandList4 *pCommandList, __in const NVAPI_RELOCATE_RAYTRACING_OPACITY_MICROMAP_ARRAY_PARAMS *pParams)
NVAPI_INTERFACE | NvAPI_D3D12_BuildRaytracingDisplacementMicromapArray (__in ID3D12GraphicsCommandList4 *pCommandList, __in NVAPI_BUILD_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PARAMS *pParams)
NVAPI_INTERFACE | NvAPI_D3D12_RelocateRaytracingDisplacementMicromapArray (__in ID3D12GraphicsCommandList4 *pCommandList, __in const NVAPI_RELOCATE_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PARAMS *pParams)
NVAPI_INTERFACE | NvAPI_D3D12_EmitRaytracingDisplacementMicromapArrayPostbuildInfo (__in ID3D12GraphicsCommandList4 *pCommandList, __in const NVAPI_EMIT_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_POSTBUILD_INFO_PARAMS *pParams)
NVAPI_INTERFACE | NvAPI_D3D12_EmitRaytracingOpacityMicromapArrayPostbuildInfo (__in ID3D12GraphicsCommandList4 *pCommandList, __in const NVAPI_EMIT_RAYTRACING_OPACITY_MICROMAP_ARRAY_POSTBUILD_INFO_PARAMS *pParams)
NVAPI_INTERFACE | NvAPI_D3D12_BuildRaytracingAccelerationStructureEx (__in ID3D12GraphicsCommandList4 *pCommandList, __in const NVAPI_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_EX_PARAMS *pParams)
NVAPI_INTERFACE | NvAPI_D3D12_QueryWorkstationFeatureProperties (__in ID3D12Device *pDevice, __inout NVAPI_D3D12_WORKSTATION_FEATURE_PROPERTIES_PARAMS *pWorkstationFeatureProperties)
NVAPI_INTERFACE | NvAPI_D3D12_CreateCommittedRDMABuffer (__in ID3D12Device *pDevice, __in NvU64 size, __in NvU32 heapCreationNodeMask, __in NvU32 heapVisibleNodeMask, __in REFIID riidResource, __out void **ppvResource, __out void **ppRDMAAddress)
NVAPI_INTERFACE | NvAPI_DirectD3D12GraphicsCommandList_Create (__in ID3D12GraphicsCommandList *pDXD3D12GraphicsCommandList, __out INvAPI_DirectD3D12GraphicsCommandList **ppReturnD3D12GraphicsCommandList)
NVAPI_INTERFACE | NvAPI_DirectD3D12GraphicsCommandList_Release (__in INvAPI_DirectD3D12GraphicsCommandList *pD3D12GraphicsCommandList)
NVAPI_INTERFACE | NvAPI_DirectD3D12GraphicsCommandList_Reset (__in INvAPI_DirectD3D12GraphicsCommandList *pD3D12GraphicsCommandList)
__nvapi_deprecated_function ("Do not use this function - it is deprecated in release 440.") NVAPI_INTERFACE NvAPI_VIO_GetCapabilities(NvVioHandle hVioHandle
__nvapi_deprecated_function ("Do not use this function - it is deprecated in release 290. Instead, use NvAPI_VIO_SetConfig.") NVAPI_INTERFACE NvAPI_VIO_SetCSC(NvVioHandle hVioHandle
__nvapi_deprecated_function ("Do not use this function - it is deprecated in release 290. Instead, use NvAPI_VIO_GetConfig.") NVAPI_INTERFACE NvAPI_VIO_GetCSC(NvVioHandle hVioHandle
NVAPI_INTERFACE | NvAPI_Stereo_CreateConfigurationProfileRegistryKey (NV_STEREO_REGISTRY_PROFILE_TYPE registryProfileType)
NVAPI_INTERFACE | NvAPI_Stereo_DeleteConfigurationProfileRegistryKey (NV_STEREO_REGISTRY_PROFILE_TYPE registryProfileType)
NVAPI_INTERFACE | NvAPI_Stereo_SetConfigurationProfileValue (NV_STEREO_REGISTRY_PROFILE_TYPE registryProfileType, NV_STEREO_REGISTRY_ID valueRegistryID, void *pValue)
NVAPI_INTERFACE | NvAPI_Stereo_DeleteConfigurationProfileValue (NV_STEREO_REGISTRY_PROFILE_TYPE registryProfileType, NV_STEREO_REGISTRY_ID valueRegistryID)
NVAPI_INTERFACE | NvAPI_Stereo_GetStereoSupport (__in NvMonitorHandle hMonitor, __out NVAPI_STEREO_CAPS *pCaps)
NVAPI_INTERFACE | NvAPI_Stereo_DecreaseSeparation (StereoHandle stereoHandle)
NVAPI_INTERFACE | NvAPI_Stereo_IncreaseSeparation (StereoHandle stereoHandle)
NVAPI_INTERFACE | NvAPI_Stereo_DecreaseConvergence (StereoHandle stereoHandle)
NVAPI_INTERFACE | NvAPI_Stereo_IncreaseConvergence (StereoHandle stereoHandle)
NVAPI_INTERFACE | NvAPI_Stereo_GetFrustumAdjustMode (StereoHandle stereoHandle, NV_FRUSTUM_ADJUST_MODE *pFrustumAdjustMode)
NVAPI_INTERFACE | NvAPI_Stereo_SetFrustumAdjustMode (StereoHandle stereoHandle, NV_FRUSTUM_ADJUST_MODE newFrustumAdjustModeValue)
NVAPI_INTERFACE | NvAPI_Stereo_CaptureJpegImage (StereoHandle stereoHandle, NvU32 quality)
NVAPI_INTERFACE | NvAPI_Stereo_InitActivation (__in StereoHandle hStereoHandle, __in NVAPI_STEREO_INIT_ACTIVATION_FLAGS flags)
NVAPI_INTERFACE | NvAPI_Stereo_Trigger_Activation (__in StereoHandle hStereoHandle)
NVAPI_INTERFACE | NvAPI_Stereo_CapturePngImage (StereoHandle stereoHandle)
NVAPI_INTERFACE | NvAPI_Stereo_ReverseStereoBlitControl (StereoHandle hStereoHandle, NvU8 TurnOn)
NVAPI_INTERFACE | NvAPI_Stereo_SetNotificationMessage (StereoHandle hStereoHandle, NvU64 hWnd, NvU64 messageID)
NVAPI_INTERFACE | NvAPI_D3D1x_CreateSwapChain (StereoHandle hStereoHandle, DXGI_SWAP_CHAIN_DESC *pDesc, IDXGISwapChain **ppSwapChain, NV_STEREO_SWAPCHAIN_MODE mode)
NVAPI_INTERFACE | NvAPI_D3D9_CreateSwapChain (StereoHandle hStereoHandle, D3DPRESENT_PARAMETERS *pPresentationParameters, IDirect3DSwapChain9 **ppSwapChain, NV_STEREO_SWAPCHAIN_MODE mode)
NV_DECLARE_HANDLE (NvDRSSessionHandle)
NV_DECLARE_HANDLE (NvDRSProfileHandle)
NVAPI_INTERFACE | NvAPI_DRS_CreateSession (NvDRSSessionHandle *phSession)
NVAPI_INTERFACE | NvAPI_DRS_DestroySession (NvDRSSessionHandle hSession)
NVAPI_INTERFACE | NvAPI_DRS_LoadSettings (NvDRSSessionHandle hSession)
NVAPI_INTERFACE | NvAPI_DRS_SaveSettings (NvDRSSessionHandle hSession)
NVAPI_INTERFACE | NvAPI_DRS_LoadSettingsFromFile (NvDRSSessionHandle hSession, NvAPI_UnicodeString fileName)
NVAPI_INTERFACE | NvAPI_DRS_SaveSettingsToFile (NvDRSSessionHandle hSession, NvAPI_UnicodeString fileName)
NVAPI_INTERFACE | NvAPI_DRS_CreateProfile (NvDRSSessionHandle hSession, NVDRS_PROFILE *pProfileInfo, NvDRSProfileHandle *phProfile)
NVAPI_INTERFACE | NvAPI_DRS_DeleteProfile (NvDRSSessionHandle hSession, NvDRSProfileHandle hProfile)
NVAPI_INTERFACE | NvAPI_DRS_SetCurrentGlobalProfile (NvDRSSessionHandle hSession, NvAPI_UnicodeString wszGlobalProfileName)
NVAPI_INTERFACE | NvAPI_DRS_GetCurrentGlobalProfile (NvDRSSessionHandle hSession, NvDRSProfileHandle *phProfile)
NVAPI_INTERFACE | NvAPI_DRS_GetProfileInfo (NvDRSSessionHandle hSession, NvDRSProfileHandle hProfile, NVDRS_PROFILE *pProfileInfo)
NVAPI_INTERFACE | NvAPI_DRS_SetProfileInfo (NvDRSSessionHandle hSession, NvDRSProfileHandle hProfile, NVDRS_PROFILE *pProfileInfo)
NVAPI_INTERFACE | NvAPI_DRS_FindProfileByName (NvDRSSessionHandle hSession, NvAPI_UnicodeString profileName, NvDRSProfileHandle *phProfile)
NVAPI_INTERFACE | NvAPI_DRS_EnumProfiles (NvDRSSessionHandle hSession, NvU32 index, NvDRSProfileHandle *phProfile)
NVAPI_INTERFACE | NvAPI_DRS_GetNumProfiles (NvDRSSessionHandle hSession, NvU32 *numProfiles)
NVAPI_INTERFACE | NvAPI_DRS_CreateApplication (NvDRSSessionHandle hSession, NvDRSProfileHandle hProfile, NVDRS_APPLICATION *pApplication)
NVAPI_INTERFACE | NvAPI_DRS_DeleteApplicationEx (NvDRSSessionHandle hSession, NvDRSProfileHandle hProfile, NVDRS_APPLICATION *pApp)
NVAPI_INTERFACE | NvAPI_DRS_DeleteApplication (NvDRSSessionHandle hSession, NvDRSProfileHandle hProfile, NvAPI_UnicodeString appName)
NVAPI_INTERFACE | NvAPI_DRS_GetApplicationInfo (NvDRSSessionHandle hSession, NvDRSProfileHandle hProfile, NvAPI_UnicodeString appName, NVDRS_APPLICATION *pApplication)
NVAPI_INTERFACE | NvAPI_DRS_EnumApplications (NvDRSSessionHandle hSession, NvDRSProfileHandle hProfile, NvU32 startIndex, NvU32 *appCount, NVDRS_APPLICATION *pApplication)
NVAPI_INTERFACE | NvAPI_DRS_FindApplicationByName (__in NvDRSSessionHandle hSession, __in NvAPI_UnicodeString appName, __out NvDRSProfileHandle *phProfile, __inout NVDRS_APPLICATION *pApplication)
NVAPI_INTERFACE | NvAPI_DRS_SetSetting (NvDRSSessionHandle hSession, NvDRSProfileHandle hProfile, NVDRS_SETTING *pSetting)
NVAPI_INTERFACE | NvAPI_DRS_GetSetting (NvDRSSessionHandle hSession, NvDRSProfileHandle hProfile, NvU32 settingId, NVDRS_SETTING *pSetting)
NVAPI_INTERFACE | NvAPI_DRS_EnumSettings (NvDRSSessionHandle hSession, NvDRSProfileHandle hProfile, NvU32 startIndex, NvU32 *settingsCount, NVDRS_SETTING *pSetting)
NVAPI_INTERFACE | NvAPI_DRS_EnumAvailableSettingIds (NvU32 *pSettingIds, NvU32 *pMaxCount)
NVAPI_INTERFACE | NvAPI_DRS_EnumAvailableSettingValues (NvU32 settingId, NvU32 *pMaxNumValues, NVDRS_SETTING_VALUES *pSettingValues)
NVAPI_INTERFACE | NvAPI_DRS_GetSettingIdFromName (NvAPI_UnicodeString settingName, NvU32 *pSettingId)
NVAPI_INTERFACE | NvAPI_DRS_GetSettingNameFromId (NvU32 settingId, NvAPI_UnicodeString *pSettingName)
NVAPI_INTERFACE | NvAPI_DRS_DeleteProfileSetting (NvDRSSessionHandle hSession, NvDRSProfileHandle hProfile, NvU32 settingId)
NVAPI_INTERFACE | NvAPI_DRS_RestoreAllDefaults (NvDRSSessionHandle hSession)
NVAPI_INTERFACE | NvAPI_DRS_RestoreProfileDefault (NvDRSSessionHandle hSession, NvDRSProfileHandle hProfile)
NVAPI_INTERFACE | NvAPI_DRS_RestoreProfileDefaultSetting (NvDRSSessionHandle hSession, NvDRSProfileHandle hProfile, NvU32 settingId)
NVAPI_INTERFACE | NvAPI_DRS_GetBaseProfile (NvDRSSessionHandle hSession, NvDRSProfileHandle *phProfile)
NVAPI_INTERFACE | NvAPI_SYS_GetChipSetInfo (NV_CHIPSET_INFO *pChipSetInfo)
NVAPI_INTERFACE | NvAPI_SYS_GetLidAndDockInfo (NV_LID_DOCK_PARAMS *pLidAndDock)
NVAPI_INTERFACE | NvAPI_SYS_GetDisplayIdFromGpuAndOutputId (NvPhysicalGpuHandle hPhysicalGpu, NvU32 outputId, NvU32 *displayId)
NVAPI_INTERFACE | NvAPI_SYS_GetGpuAndOutputIdFromDisplayId (NvU32 displayId, NvPhysicalGpuHandle *hPhysicalGpu, NvU32 *outputId)
NVAPI_INTERFACE | NvAPI_SYS_GetPhysicalGpuFromDisplayId (NvU32 displayId, NvPhysicalGpuHandle *hPhysicalGpu)
NVAPI_INTERFACE | NvAPI_SYS_GetDisplayDriverInfo (__inout NV_DISPLAY_DRIVER_INFO *pDriverInfo)
NVAPI_INTERFACE | NvAPI_SYS_GetPhysicalGPUs (__inout NV_PHYSICAL_GPUS *pPhysicalGPUs)
NVAPI_INTERFACE | NvAPI_SYS_GetLogicalGPUs (__inout NV_LOGICAL_GPUS *pLogicalGPUs)
NVAPI_INTERFACE | NvAPI_GPU_ClientRegisterForUtilizationSampleUpdates (__in NvPhysicalGpuHandle hPhysicalGpu, __in NV_GPU_CLIENT_UTILIZATION_PERIODIC_CALLBACK_SETTINGS *pCallbackSettings)
NVAPI_INTERFACE | NvAPI_Disp_GetHdrCapabilities (__in NvU32 displayId, __inout NV_HDR_CAPABILITIES *pHdrCapabilities)

Variables

NV_VIEW_TARGET_INFO * pTargetInfo
NV_VIEW_TARGET_INFO NV_TARGET_VIEW_MODE targetView
NV_DISPLAY_PATH_INFO * pPathInfo
NV_DISPLAY_PATH_INFO NV_TARGET_VIEW_MODE displayView
NV_DISPLAY_DRIVER_VERSION * pVersion
NvU32 * pSize
NvU32 * pRate
NvU32 * pStatus
void * | pOSAdapterId
NV_GPU_PERF_PSTATES_INFO * pPerfPstatesInfo
NV_GPU_PERF_PSTATES_INFO NvU32 inputFlags
NV_VIEW_TARGET_INFO * pTargets
NV_VIEW_TARGET_INFO NvU32 * pTargetMaskCount
NV_VIEW_TARGET_INFO NvU32 NV_TARGET_VIEW_MODE * pTargetView
NV_DISPLAY_PATH_INFO NvU32 * pPathCount
NV_DISPLAY_PATH_INFO NvU32 NV_TARGET_VIEW_MODE * pTargetViewMode
NVVIOCAPS * pAdapterCaps
NvU32 vioClass
NvU32 NVVIOOWNERTYPE ownerType
NvU32 bRelease
NvU32 * pWait
NVVIOCONFIG * pConfig
NVVIOCOLORCONVERSION * pCSC
NVVIOGAMMACORRECTION * pGamma
const NVVIOSYNCDELAY * | pSyncDelay
__inout NVVIOPCIINFO * pVioPCIInfo
NvU32 srcEnumIndex
NvU32 NvU32 destEnumIndex
NvU32 NvU32 NvU32 * pbCompatible
NvU32 * vioDeviceCount
NvU32 enumIndex
NvU32 NVVIOSIGNALFORMATDETAIL * pSignalFormatDetail
NvU32 NVVIODATAFORMATDETAIL * pDataFormatDetail
#define | NV_EDID_V1_DATA_SIZE 256
#define | NV_EDID_DATA_SIZE NV_EDID_V1_DATA_SIZE
#define | NV_EDID_VER1 MAKE_NVAPI_VERSION(NV_EDID_V1,1)
#define | NV_EDID_VER2 MAKE_NVAPI_VERSION(NV_EDID_V2,2)
#define | NV_EDID_VER3 MAKE_NVAPI_VERSION(NV_EDID_V3,3)
#define | NV_EDID_VER NV_EDID_VER3
typedef NV_EDID_V3 | NV_EDID
#define | NVAPI_MAX_VIEW_TARGET 2
#define | NVAPI_ADVANCED_MAX_VIEW_TARGET 4
#define | _NV_TARGET_VIEW_MODE_
enum _NV_TARGET_VIEW_MODE {
NV_VIEW_MODE_STANDARD = 0 , NV_VIEW_MODE_CLONE = 1 , NV_VIEW_MODE_HSPAN = 2 , NV_VIEW_MODE_VSPAN = 3 ,
NV_VIEW_MODE_DUALVIEW = 4 , NV_VIEW_MODE_MULTIVIEW = 5
}
typedef enum _NV_TARGET_VIEW_MODE | NV_TARGET_VIEW_MODE

NvAPI_OGL_ExpertModeDefaultsSet[Get] Functions

#define | NV_GPU_CONNECTED_IDS_FLAG_UNCACHED NV_BIT(0)
#define | NV_GPU_CONNECTED_IDS_FLAG_SLI NV_BIT(1)
#define | NV_GPU_CONNECTED_IDS_FLAG_LIDSTATE NV_BIT(2)
#define | NV_GPU_CONNECTED_IDS_FLAG_FAKE NV_BIT(3)
#define | NV_GPU_CONNECTED_IDS_FLAG_EXCLUDE_MST NV_BIT(4)
enum NV_MONITOR_CONN_TYPE {
NV_MONITOR_CONN_TYPE_UNINITIALIZED = 0 , NV_MONITOR_CONN_TYPE_VGA , NV_MONITOR_CONN_TYPE_COMPONENT , NV_MONITOR_CONN_TYPE_SVIDEO ,
NV_MONITOR_CONN_TYPE_HDMI , NV_MONITOR_CONN_TYPE_DVI , NV_MONITOR_CONN_TYPE_LVDS , NV_MONITOR_CONN_TYPE_DP ,
NV_MONITOR_CONN_TYPE_COMPOSITE , NV_MONITOR_CONN_TYPE_UNKNOWN = -1
}
NvU32 * pOutputsMask
NVAPI_INTERFACE | NvAPI_OGL_ExpertModeDefaultsSet (NvU32 expertDetailLevel, NvU32 expertReportMask, NvU32 expertOutputMask)
NVAPI_INTERFACE | NvAPI_OGL_ExpertModeDefaultsGet (NvU32 *pExpertDetailLevel, NvU32 *pExpertReportMask, NvU32 *pExpertOutputMask)
NVAPI_INTERFACE | NvAPI_EnumTCCPhysicalGPUs (NvPhysicalGpuHandle nvGPUHandle[NVAPI_MAX_PHYSICAL_GPUS], NvU32 *pGpuCount)
NVAPI_INTERFACE | NvAPI_EnumLogicalGPUs (NvLogicalGpuHandle nvGPUHandle[NVAPI_MAX_LOGICAL_GPUS], NvU32 *pGpuCount)
NVAPI_INTERFACE | NvAPI_GetPhysicalGPUsFromDisplay (NvDisplayHandle hNvDisp, NvPhysicalGpuHandle nvGPUHandle[NVAPI_MAX_PHYSICAL_GPUS], NvU32 *pGpuCount)
NVAPI_INTERFACE | NvAPI_GetPhysicalGPUFromUnAttachedDisplay (NvUnAttachedDisplayHandle hNvUnAttachedDisp, NvPhysicalGpuHandle *pPhysicalGpu)
NVAPI_INTERFACE | NvAPI_GetLogicalGPUFromDisplay (NvDisplayHandle hNvDisp, NvLogicalGpuHandle *pLogicalGPU)
NVAPI_INTERFACE | NvAPI_GetLogicalGPUFromPhysicalGPU (NvPhysicalGpuHandle hPhysicalGPU, NvLogicalGpuHandle *pLogicalGPU)
NVAPI_INTERFACE | NvAPI_GetPhysicalGPUsFromLogicalGPU (NvLogicalGpuHandle hLogicalGPU, NvPhysicalGpuHandle hPhysicalGPU[NVAPI_MAX_PHYSICAL_GPUS], NvU32 *pGpuCount)
NVAPI_INTERFACE | NvAPI_GetPhysicalGPUFromGPUID (NvU32 gpuId, NvPhysicalGpuHandle *pPhysicalGPU)
NVAPI_INTERFACE | NvAPI_GetGPUIDfromPhysicalGPU (NvPhysicalGpuHandle hPhysicalGpu, NvU32 *pGpuId)
NVAPI_INTERFACE | NvAPI_GPU_GetShaderSubPipeCount (NvPhysicalGpuHandle hPhysicalGpu, NvU32 *pCount)
NVAPI_INTERFACE | NvAPI_GPU_GetGpuCoreCount (NvPhysicalGpuHandle hPhysicalGpu, NvU32 *pCount)
__nvapi_deprecated_function ("Do not use this function - it is deprecated in release 290. Instead, use NvAPI_GPU_GetAllDisplayIds.") NVAPI_INTERFACE NvAPI_GPU_GetAllOutputs(NvPhysicalGpuHandle hPhysicalGpu
__nvapi_deprecated_function ("Do not use this function - it is deprecated in release 290. Instead, use NvAPI_GPU_GetConnectedDisplayIds.") NVAPI_INTERFACE NvAPI_GPU_GetConnectedOutputs(NvPhysicalGpuHandle hPhysicalGpu
#define | NVAPI_MAX_SIZEOF_I2C_DATA_BUFFER 4096
#define | NVAPI_MAX_SIZEOF_I2C_REG_ADDRESS 4
#define | NVAPI_DISPLAY_DEVICE_MASK_MAX 24
#define | NVAPI_I2C_SPEED_DEPRECATED 0xFFFF
#define | NV_I2C_INFO_VER3 MAKE_NVAPI_VERSION(NV_I2C_INFO_V3,3)
#define | NV_I2C_INFO_VER2 MAKE_NVAPI_VERSION(NV_I2C_INFO_V2,2)
#define | NV_I2C_INFO_VER1 MAKE_NVAPI_VERSION(NV_I2C_INFO_V1,1)
#define | NV_I2C_INFO_VER NV_I2C_INFO_VER3
enum NV_I2C_SPEED {
NVAPI_I2C_SPEED_DEFAULT , NVAPI_I2C_SPEED_3KHZ , NVAPI_I2C_SPEED_10KHZ , NVAPI_I2C_SPEED_33KHZ ,
NVAPI_I2C_SPEED_100KHZ , NVAPI_I2C_SPEED_200KHZ , NVAPI_I2C_SPEED_400KHZ
}
typedef NV_I2C_INFO_V3 | NV_I2C_INFO
#define | NV_LICENSE_MAX_COUNT 3
#define | NV_LICENSE_SIGNATURE_SIZE (128)
#define | NV_LICENSE_INFO_MAX_LENGTH (128)
#define | NV_LICENSE_FEATURE_DETAILS_VER1 MAKE_NVAPI_VERSION(NV_LICENSE_FEATURE_DETAILS_V1, 1)
#define | NV_LICENSE_FEATURE_DETAILS_VER NV_LICENSE_FEATURE_DETAILS_VER1
#define | NV_LICENSABLE_FEATURES_VER1 MAKE_NVAPI_VERSION(NV_LICENSABLE_FEATURES_V1, 1)
#define | NV_LICENSABLE_FEATURES_VER2 MAKE_NVAPI_VERSION(NV_LICENSABLE_FEATURES_V2, 2)
#define | NV_LICENSABLE_FEATURES_VER3 MAKE_NVAPI_VERSION(NV_LICENSABLE_FEATURES_V3, 3)
#define | NV_LICENSABLE_FEATURES_VER4 MAKE_NVAPI_VERSION(NV_LICENSABLE_FEATURES_V4, 4)
#define | NV_LICENSABLE_FEATURES_VER NV_LICENSABLE_FEATURES_VER4
enum _NV_LICENSE_FEATURE_TYPE {
NV_LICENSE_FEATURE_UNKNOWN = 0 , NV_LICENSE_FEATURE_VGPU = 1 , NV_LICENSE_FEATURE_NVIDIA_RTX = 2 , NV_LICENSE_FEATURE_QUADRO = NV_LICENSE_FEATURE_NVIDIA_RTX ,
NV_LICENSE_FEATURE_GAMING = 3 , NV_LICENSE_FEATURE_COMPUTE = 4
}
typedef char | NvAPI_LicenseString[NV_LICENSE_INFO_MAX_LENGTH]
typedef enum _NV_LICENSE_FEATURE_TYPE | NV_LICENSE_FEATURE_TYPE
typedef struct _NV_LICENSE_EXPIRY_DETAILS | NV_LICENSE_EXPIRY_DETAILS
typedef struct _NV_LICENSE_FEATURE_DETAILS_V1 | NV_LICENSE_FEATURE_DETAILS_V1
typedef struct _NV_LICENSE_FEATURE_DETAILS_V2 | NV_LICENSE_FEATURE_DETAILS_V2
typedef struct _NV_LICENSE_FEATURE_DETAILS_V3 | NV_LICENSE_FEATURE_DETAILS_V3
typedef struct _NV_LICENSE_FEATURE_DETAILS_V4 | NV_LICENSE_FEATURE_DETAILS_V4
typedef NV_LICENSE_FEATURE_DETAILS_V1 | NV_LICENSE_FEATURE_DETAILS
typedef struct _NV_LICENSABLE_FEATURES_V1 | NV_LICENSABLE_FEATURES_V1
typedef struct _NV_LICENSABLE_FEATURES_V2 | NV_LICENSABLE_FEATURES_V2
typedef struct _NV_LICENSABLE_FEATURES_V3 | NV_LICENSABLE_FEATURES_V3
typedef struct _NV_LICENSABLE_FEATURES_V4 | NV_LICENSABLE_FEATURES_V4
typedef NV_LICENSABLE_FEATURES_V4 | NV_LICENSABLE_FEATURES
#define | NVAPI_NVLINK_CAPS_SUPPORTED 0x00000001
#define | NVAPI_NVLINK_CAPS_P2P_SUPPORTED 0x00000002
#define | NVAPI_NVLINK_CAPS_SYSMEM_ACCESS 0x00000004
#define | NVAPI_NVLINK_CAPS_P2P_ATOMICS 0x00000008
#define | NVAPI_NVLINK_CAPS_SYSMEM_ATOMICS 0x00000010
#define | NVAPI_NVLINK_CAPS_PEX_TUNNELING 0x00000020
#define | NVAPI_NVLINK_CAPS_SLI_BRIDGE 0x00000040
#define | NVAPI_NVLINK_CAPS_SLI_BRIDGE_SENSABLE 0x00000080
#define | NVAPI_NVLINK_CAPS_POWER_STATE_L0 0x00000100
#define | NVAPI_NVLINK_CAPS_POWER_STATE_L1 0x00000200
#define | NVAPI_NVLINK_CAPS_POWER_STATE_L2 0x00000400
#define | NVAPI_NVLINK_CAPS_POWER_STATE_L3 0x00000800
#define | NVAPI_NVLINK_CAPS_VALID 0x00001000
#define | NVAPI_NVLINK_CAPS_NVLINK_VERSION_INVALID (0x00000000)
#define | NVAPI_NVLINK_CAPS_NVLINK_VERSION_1_0 (0x00000001)
#define | NVAPI_NVLINK_CAPS_NVLINK_VERSION_2_0 (0x00000002)
#define | NVAPI_NVLINK_CAPS_NCI_VERSION_INVALID (0x00000000)
#define | NVAPI_NVLINK_CAPS_NCI_VERSION_1_0 (0x00000001)
#define | NVAPI_NVLINK_CAPS_NCI_VERSION_2_0 (0x00000002)
#define | NVLINK_GET_CAPS_VER1 MAKE_NVAPI_VERSION(NVLINK_GET_CAPS_V1, 1)
#define | NVLINK_GET_CAPS_VER NVLINK_GET_CAPS_VER1
typedef NVLINK_GET_CAPS_V1 | NVLINK_GET_CAPS
#define | NVAPI_NVLINK_DEVICE_INFO_DEVICE_ID_FLAGS_NONE (0x00000000)
#define | NVAPI_NVLINK_DEVICE_INFO_DEVICE_ID_FLAGS_PCI (0x00000001)
#define | NVAPI_NVLINK_DEVICE_INFO_DEVICE_ID_FLAGS_UUID (0x00000002)
#define | NVAPI_NVLINK_STATUS_PHY_NVHS (0x00000001)
#define | NVAPI_NVLINK_STATUS_PHY_GRS (0x00000002)
#define | NVAPI_NVLINK_STATUS_PHY_INVALID (0x000000FF)
#define | NVAPI_NVLINK_STATUS_NVLINK_VERSION_1_0 (0x00000001)
#define | NVAPI_NVLINK_STATUS_NVLINK_VERSION_2_0 (0x00000002)
#define | NVAPI_NVLINK_STATUS_NVLINK_VERSION_INVALID (0x000000FF)
#define | NVAPI_NVLINK_STATUS_NCI_VERSION_1_0 (0x00000001)
#define | NVAPI_NVLINK_STATUS_NCI_VERSION_2_0 (0x00000002)
#define | NVAPI_NVLINK_STATUS_NCI_VERSION_INVALID (0x000000FF)
#define | NVAPI_NVLINK_STATUS_NVHS_VERSION_1_0 (0x00000001)
#define | NVAPI_NVLINK_STATUS_NVHS_VERSION_INVALID (0x000000FF)
#define | NVAPI_NVLINK_STATUS_GRS_VERSION_1_0 (0x00000001)
#define | NVAPI_NVLINK_STATUS_GRS_VERSION_INVALID (0x000000FF)
#define | NVAPI_NVLINK_STATUS_CONNECTED_TRUE (0x00000001)
#define | NVAPI_NVLINK_STATUS_CONNECTED_FALSE (0x00000000)
#define | NVAPI_NVLINK_STATUS_LOOP_PROPERTY_LOOPBACK (0x00000001)
#define | NVAPI_NVLINK_STATUS_LOOP_PROPERTY_LOOPOUT (0x00000002)
#define | NVAPI_NVLINK_STATUS_LOOP_PROPERTY_NONE (0x00000000)
#define | NVAPI_NVLINK_STATUS_REMOTE_LINK_NUMBER_INVALID (0x000000FF)
#define | NVAPI_NVLINK_REFCLK_TYPE_INVALID (0x00)
#define | NVAPI_NVLINK_REFCLK_TYPE_NVHS (0x01)
#define | NVAPI_NVLINK_REFCLK_TYPE_PEX (0x02)
#define | NVLINK_GET_STATUS_VER1 MAKE_NVAPI_VERSION(NVLINK_GET_STATUS_V1, 1)
#define | NVLINK_GET_STATUS_VER2 MAKE_NVAPI_VERSION(NVLINK_GET_STATUS_V2, 2)
#define | NVLINK_GET_STATUS_VER NVLINK_GET_STATUS_VER2
enum _NVAPI_NVLINK_DEVICE_INFO_DEVICE_TYPE {
NVAPI_NVLINK_DEVICE_INFO_DEVICE_TYPE_EBRIDGE , NVAPI_NVLINK_DEVICE_INFO_DEVICE_TYPE_NPU , NVAPI_NVLINK_DEVICE_INFO_DEVICE_TYPE_GPU , NVAPI_NVLINK_DEVICE_INFO_DEVICE_TYPE_SWITCH ,
NVAPI_NVLINK_DEVICE_INFO_DEVICE_TYPE_TEGRA , NVAPI_NVLINK_DEVICE_INFO_DEVICE_TYPE_NONE , NVAPI_NVLINK_DEVICE_INFO_DEVICE_UUID_INVALID
}
enum _NVAPI_NVLINK_STATUS_LINK_STATE {
NVAPI_NVLINK_STATUS_LINK_STATE_UNKNOWN , NVAPI_NVLINK_STATUS_LINK_STATE_INIT , NVAPI_NVLINK_STATUS_LINK_STATE_HWCFG , NVAPI_NVLINK_STATUS_LINK_STATE_SWCFG ,
NVAPI_NVLINK_STATUS_LINK_STATE_ACTIVE , NVAPI_NVLINK_STATUS_LINK_STATE_FAULT , NVAPI_NVLINK_STATUS_LINK_STATE_RECOVERY , NVAPI_NVLINK_STATUS_LINK_STATE_RECOVERY_AC ,
NVAPI_NVLINK_STATUS_LINK_STATE_RECOVERY_AX , NVAPI_NVLINK_STATUS_LINK_STATE_INVALID = 0xFFFFFFFF
}
enum _NVAPI_NVLINK_STATUS_SUBLINK_RX_STATE {
NVAPI_NVLINK_STATUS_SUBLINK_RX_STATE_UNKNOWN , NVAPI_NVLINK_STATUS_SUBLINK_RX_STATE_HIGH_SPEED_1 , NVAPI_NVLINK_STATUS_SUBLINK_RX_STATE_LOW_POWER , NVAPI_NVLINK_STATUS_SUBLINK_RX_STATE_TRAINING ,
NVAPI_NVLINK_STATUS_SUBLINK_RX_STATE_SAFE_MODE , NVAPI_NVLINK_STATUS_SUBLINK_RX_STATE_OFF , NVAPI_NVLINK_STATUS_SUBLINK_RX_STATE_TEST , NVAPI_NVLINK_STATUS_SUBLINK_RX_STATE_FAULT ,
NVAPI_NVLINK_STATUS_SUBLINK_RX_STATE_INVALID = 0xFF
}
enum _NVAPI_NVLINK_STATUS_SUBLINK_TX_STATE {
NVAPI_NVLINK_STATUS_SUBLINK_TX_STATE_UNKNOWN , NVAPI_NVLINK_STATUS_SUBLINK_TX_STATE_HIGH_SPEED_1 , NVAPI_NVLINK_STATUS_SUBLINK_TX_STATE_LOW_POWER , NVAPI_NVLINK_STATUS_SUBLINK_TX_STATE_TRAINING ,
NVAPI_NVLINK_STATUS_SUBLINK_TX_STATE_SAFE_MODE , NVAPI_NVLINK_STATUS_SUBLINK_TX_STATE_OFF , NVAPI_NVLINK_STATUS_SUBLINK_TX_STATE_TEST , NVAPI_NVLINK_STATUS_SUBLINK_TX_STATE_FAULT ,
NVAPI_NVLINK_STATUS_SUBLINK_TX_STATE_INVALID = 0xFF
}
typedef enum _NVAPI_NVLINK_DEVICE_INFO_DEVICE_TYPE | NVAPI_NVLINK_DEVICE_INFO_DEVICE_TYPE
typedef enum _NVAPI_NVLINK_STATUS_LINK_STATE | NVAPI_NVLINK_STATUS_LINK_STATE
typedef enum _NVAPI_NVLINK_STATUS_SUBLINK_RX_STATE | NVAPI_NVLINK_STATUS_SUBLINK_RX_STATE
typedef enum _NVAPI_NVLINK_STATUS_SUBLINK_TX_STATE | NVAPI_NVLINK_STATUS_SUBLINK_TX_STATE
typedef NVLINK_GET_STATUS_V2 | NVLINK_GET_STATUS
#define | NV_COLOR_DATA_VER1 MAKE_NVAPI_VERSION(NV_COLOR_DATA_V1, 1)
#define | NV_COLOR_DATA_VER2 MAKE_NVAPI_VERSION(NV_COLOR_DATA_V2, 2)
#define | NV_COLOR_DATA_VER3 MAKE_NVAPI_VERSION(NV_COLOR_DATA_V3, 3)
#define | NV_COLOR_DATA_VER4 MAKE_NVAPI_VERSION(NV_COLOR_DATA_V4, 4)
#define | NV_COLOR_DATA_VER5 MAKE_NVAPI_VERSION(NV_COLOR_DATA_V5, 5)
#define | NV_COLOR_DATA_VER NV_COLOR_DATA_VER5
enum | NV_COLOR_CMD { NV_COLOR_CMD_GET = 1 , NV_COLOR_CMD_SET , NV_COLOR_CMD_IS_SUPPORTED_COLOR , NV_COLOR_CMD_GET_DEFAULT }
enum NV_COLOR_FORMAT {
NV_COLOR_FORMAT_RGB = 0 , NV_COLOR_FORMAT_YUV422 , NV_COLOR_FORMAT_YUV444 , NV_COLOR_FORMAT_YUV420 ,
NV_COLOR_FORMAT_DEFAULT = 0xFE , NV_COLOR_FORMAT_AUTO = 0xFF
}
enum NV_COLOR_COLORIMETRY {
NV_COLOR_COLORIMETRY_RGB = 0 , NV_COLOR_COLORIMETRY_YCC601 , NV_COLOR_COLORIMETRY_YCC709 , NV_COLOR_COLORIMETRY_XVYCC601 ,
NV_COLOR_COLORIMETRY_XVYCC709 , NV_COLOR_COLORIMETRY_SYCC601 , NV_COLOR_COLORIMETRY_ADOBEYCC601 , NV_COLOR_COLORIMETRY_ADOBERGB ,
NV_COLOR_COLORIMETRY_BT2020RGB , NV_COLOR_COLORIMETRY_BT2020YCC , NV_COLOR_COLORIMETRY_BT2020cYCC , NV_COLOR_COLORIMETRY_DEFAULT = 0xFE ,
NV_COLOR_COLORIMETRY_AUTO = 0xFF
}
enum | _NV_DYNAMIC_RANGE { NV_DYNAMIC_RANGE_VESA = 0x0 , NV_DYNAMIC_RANGE_CEA = 0x1 , NV_DYNAMIC_RANGE_AUTO = 0xFF }
enum _NV_BPC {
NV_BPC_DEFAULT = 0 , NV_BPC_6 = 1 , NV_BPC_8 = 2 , NV_BPC_10 = 3 ,
NV_BPC_12 = 4 , NV_BPC_16 = 5
}
enum | _NV_COLOR_SELECTION_POLICY { NV_COLOR_SELECTION_POLICY_USER = 0 , NV_COLOR_SELECTION_POLICY_BEST_QUALITY = 1 , NV_COLOR_SELECTION_POLICY_DEFAULT = NV_COLOR_SELECTION_POLICY_BEST_QUALITY , NV_COLOR_SELECTION_POLICY_UNKNOWN = 0xFF }
enum _NV_DESKTOP_COLOR_DEPTH {
NV_DESKTOP_COLOR_DEPTH_DEFAULT = 0x0 , NV_DESKTOP_COLOR_DEPTH_8BPC = 0x1 , NV_DESKTOP_COLOR_DEPTH_10BPC = 0x2 , NV_DESKTOP_COLOR_DEPTH_16BPC_FLOAT = 0x3 ,
NV_DESKTOP_COLOR_DEPTH_16BPC_FLOAT_WCG = 0x4 , NV_DESKTOP_COLOR_DEPTH_16BPC_FLOAT_HDR = 0x5 , NV_DESKTOP_COLOR_DEPTH_MAX_VALUE = NV_DESKTOP_COLOR_DEPTH_16BPC_FLOAT_HDR
}
typedef enum _NV_DYNAMIC_RANGE | NV_DYNAMIC_RANGE
typedef enum _NV_BPC | NV_BPC
typedef enum _NV_COLOR_SELECTION_POLICY | NV_COLOR_SELECTION_POLICY
typedef enum _NV_DESKTOP_COLOR_DEPTH | NV_DESKTOP_COLOR_DEPTH
typedef struct _NV_COLOR_DATA_V1 | NV_COLOR_DATA_V1
typedef struct _NV_COLOR_DATA_V2 | NV_COLOR_DATA_V2
typedef struct _NV_COLOR_DATA_V3 | NV_COLOR_DATA_V3
typedef struct _NV_COLOR_DATA_V4 | NV_COLOR_DATA_V4
typedef struct _NV_COLOR_DATA_V5 | NV_COLOR_DATA_V5
typedef NV_COLOR_DATA_V5 | NV_COLOR_DATA
NVAPI_INTERFACE | NvAPI_Disp_ColorControl (NvU32 displayId, NV_COLOR_DATA *pColorData)
#define | NV_SOURCE_PID_CURRENT 0
#define | NV_HDR_METADATA_VER1 MAKE_NVAPI_VERSION(NV_HDR_METADATA_V1, 1)
#define | NV_HDR_METADATA_VER NV_HDR_METADATA_VER1
enum | _NV_COLORSPACE_TYPE { NV_COLORSPACE_sRGB = 0 , NV_COLORSPACE_xRGB = 1 , NV_COLORSPACE_REC2100 = 12 }
enum | _NV_DISPLAY_OUTPUT_MODE { NV_DISPLAY_OUTPUT_MODE_SDR = 0 , NV_DISPLAY_OUTPUT_MODE_HDR10 = 1 , NV_DISPLAY_OUTPUT_MODE_HDR10PLUS_GAMING = 2 }
enum | _NV_HDR_TONEMAPPING_METHOD { NV_HDR_TONEMAPPING_APP = 0 , NV_HDR_TONEMAPPING_GPU = 1 }
typedef enum _NV_COLORSPACE_TYPE | NV_COLORSPACE_TYPE
typedef struct _NV_HDR_METADATA_V1 | NV_HDR_METADATA_V1
typedef NV_HDR_METADATA_V1 | NV_HDR_METADATA
typedef enum _NV_DISPLAY_OUTPUT_MODE | NV_DISPLAY_OUTPUT_MODE
typedef enum _NV_HDR_TONEMAPPING_METHOD | NV_HDR_TONEMAPPING_METHOD
NVAPI_INTERFACE | NvAPI_Disp_HdrColorControl (__in NvU32 displayId, __inout NV_HDR_COLOR_DATA *pHdrColorData)
NVAPI_INTERFACE | NvAPI_Disp_SetSourceColorSpace (__in NvU32 displayId, __in NV_COLORSPACE_TYPE colorSpaceType)
NVAPI_INTERFACE | NvAPI_Disp_GetSourceColorSpace (__in NvU32 displayId, __inout NV_COLORSPACE_TYPE *pColorSpaceType, NvU64 sourcePID)
NVAPI_INTERFACE | NvAPI_Disp_SetSourceHdrMetadata (__in NvU32 displayId, __in NV_HDR_METADATA *pMetadata)
NVAPI_INTERFACE | NvAPI_Disp_GetSourceHdrMetadata (__in NvU32 displayId, __inout NV_HDR_METADATA *pMetadata, NvU64 sourcePID)
NVAPI_INTERFACE | NvAPI_Disp_SetOutputMode (__in NvU32 displayId, __inout NV_DISPLAY_OUTPUT_MODE *pDisplayMode)
NVAPI_INTERFACE | NvAPI_Disp_GetOutputMode (__in NvU32 displayId, __inout NV_DISPLAY_OUTPUT_MODE *pDisplayMode)
NVAPI_INTERFACE | NvAPI_Disp_SetHdrToneMapping (__in NvU32 displayId, __in NV_HDR_TONEMAPPING_METHOD hdrTonemapping)
NVAPI_INTERFACE | NvAPI_Disp_GetHdrToneMapping (__in NvU32 displayId, __inout NV_HDR_TONEMAPPING_METHOD *pHdrTonemapping)
#define | NV_MONITOR_CAPABILITIES_VER1 MAKE_NVAPI_VERSION(NV_MONITOR_CAPABILITIES_V1,1)
#define | NV_MONITOR_CAPABILITIES_VER NV_MONITOR_CAPABILITIES_VER1
enum | NV_MONITOR_CAPS_TYPE { NV_MONITOR_CAPS_TYPE_HDMI_VSDB = 0x1000 , NV_MONITOR_CAPS_TYPE_HDMI_VCDB = 0x1001 , NV_MONITOR_CAPS_TYPE_GENERIC = 0x1002 }
typedef struct _NV_MONITOR_CAPS_VCDB | NV_MONITOR_CAPS_VCDB
typedef struct _NV_MONITOR_CAPS_VSDB | NV_MONITOR_CAPS_VSDB
typedef struct _NV_MONITOR_CAPS_GENERIC | NV_MONITOR_CAPS_GENERIC
typedef struct _NV_MONITOR_CAPABILITIES_V1 | NV_MONITOR_CAPABILITIES_V1
typedef NV_MONITOR_CAPABILITIES_V1 | NV_MONITOR_CAPABILITIES
#define | NV_EDID_DATA_VER1 MAKE_NVAPI_VERSION(NV_EDID_DATA_V1, 1)
#define | NV_EDID_DATA_VER2 MAKE_NVAPI_VERSION(NV_EDID_DATA_V2, 2)
#define | NV_EDID_DATA_VER NV_EDID_DATA_VER2
typedef struct _NV_EDID_DATA_V1 | NV_EDID_DATA_V1
typedef struct _NV_EDID_DATA_V2 | NV_EDID_DATA_V2
typedef NV_EDID_DATA_V2 | NV_EDID_DATA
NVAPI_INTERFACE | NvAPI_DISP_GetEdidData (__in NvU32 displayId, __inout NV_EDID_DATA *pEdidParams, __inout NV_EDID_FLAG *pFlag)
#define | NV_MOSAIC_GRID_TOPO_VER1 MAKE_NVAPI_VERSION(NV_MOSAIC_GRID_TOPO_V1,1)
#define | NV_MOSAIC_GRID_TOPO_VER2 MAKE_NVAPI_VERSION(NV_MOSAIC_GRID_TOPO_V2,2)
#define | NV_MOSAIC_GRID_TOPO_VER NV_MOSAIC_GRID_TOPO_VER2
enum _NV_PIXEL_SHIFT_TYPE {
NV_PIXEL_SHIFT_TYPE_NO_PIXEL_SHIFT = 0 , NV_PIXEL_SHIFT_TYPE_2x2_TOP_LEFT_PIXELS = 1 , NV_PIXEL_SHIFT_TYPE_2x2_BOTTOM_RIGHT_PIXELS = 2 , NV_PIXEL_SHIFT_TYPE_2x2_TOP_RIGHT_PIXELS = 4 ,
NV_PIXEL_SHIFT_TYPE_2x2_BOTTOM_LEFT_PIXELS = 8
}
typedef struct _NV_MOSAIC_GRID_TOPO_DISPLAY_V1 | NV_MOSAIC_GRID_TOPO_DISPLAY_V1
typedef enum _NV_PIXEL_SHIFT_TYPE | NV_PIXEL_SHIFT_TYPE
typedef struct _NV_MOSAIC_GRID_TOPO_DISPLAY_V2 | NV_MOSAIC_GRID_TOPO_DISPLAY_V2
typedef NV_MOSAIC_GRID_TOPO_DISPLAY_V1 | NV_MOSAIC_GRID_TOPO_DISPLAY
typedef struct _NV_MOSAIC_GRID_TOPO_V1 | NV_MOSAIC_GRID_TOPO_V1
typedef struct _NV_MOSAIC_GRID_TOPO_V2 | NV_MOSAIC_GRID_TOPO_V2
typedef NV_MOSAIC_GRID_TOPO_V2 | NV_MOSAIC_GRID_TOPO

Macro Definition Documentation

◆ __cdecl

#define __cdecl

◆ _NVAPI_H

#define _NVAPI_H

◆ ALL_GPUS

#define ALL_GPUS 0

◆ compile_time_assert

#define compile_time_assert ( b ) typedef char compile_time_assertion_failed_in_line_##__LINE__[(b)?1:-1]

◆ DISPLAYPORT_STRUCTS_DEFINED

#define DISPLAYPORT_STRUCTS_DEFINED

◆ FENCE_SYNCHRONIZATION_END

#define FENCE_SYNCHRONIZATION_END | ( | pMultiGPUDevice,
 |  | hFence,
 |  | Value,
 |  | srcGpu,
 |  | dstGpu
 | ) |
Value:
pMultiGPUDevice->SetFence(srcGpu, hFence, Value); \
pMultiGPUDevice->WaitForFence(1 << (dstGpu), hFence, Value); \
Value++;

◆ FENCE_SYNCHRONIZATION_START

#define FENCE_SYNCHRONIZATION_START | ( | pMultiGPUDevice,
 |  | hFence,
 |  | Value,
 |  | srcGpu,
 |  | dstGpu
 | ) |
Value:
pMultiGPUDevice->SetFence(dstGpu, hFence, Value); \
pMultiGPUDevice->WaitForFence(1 << (srcGpu), hFence, Value); \
Value++;

Synchronization macros based on fences.

◆ ID3D11MultiGPUDevice_VER

#define ID3D11MultiGPUDevice_VER ID3D11MultiGPUDevice_VER3

◆ ID3D11MultiGPUDevice_VER1

#define ID3D11MultiGPUDevice_VER1 MAKE_NVAPI_VERSION(ID3D11MultiGPUDevice_V1, 1)

◆ ID3D11MultiGPUDevice_VER2

#define ID3D11MultiGPUDevice_VER2 MAKE_NVAPI_VERSION(ID3D11MultiGPUDevice_V1, 2)

◆ ID3D11MultiGPUDevice_VER3

#define ID3D11MultiGPUDevice_VER3 MAKE_NVAPI_VERSION(ID3D11MultiGPUDevice_V1, 3)

◆ ID3D11NvMetaCommand_VER

#define ID3D11NvMetaCommand_VER ID3D11NvMetaCommand_VER1

◆ ID3D11NvMetaCommand_VER1

#define ID3D11NvMetaCommand_VER1 MAKE_NVAPI_VERSION(IID3D11NvMetaCommand_V1, 1)

◆ ID3D11NvShadingRateResourceView_VER

#define ID3D11NvShadingRateResourceView_VER ID3D11NvShadingRateResourceView_VER1

◆ ID3D11NvShadingRateResourceView_VER1

#define ID3D11NvShadingRateResourceView_VER1 MAKE_NVAPI_VERSION(ID3D11NvShadingRateResourceView_V1, 1)

◆ ID3D12NvMetaCommand_VER

#define ID3D12NvMetaCommand_VER ID3D12NvMetaCommand_VER1

◆ ID3D12NvMetaCommand_VER1

#define ID3D12NvMetaCommand_VER1 MAKE_NVAPI_VERSION(IID3D12NvMetaCommand_V1, 1)

◆ ID3DLateLatchObject_VER

#define ID3DLateLatchObject_VER ID3DLateLatchObject_VER1

◆ ID3DLateLatchObject_VER1

#define ID3DLateLatchObject_VER1 MAKE_NVAPI_VERSION(ID3DLateLatchObject_V1, 1)

◆ ID3DNvGazeHandler_VER

#define ID3DNvGazeHandler_VER ID3DNvGazeHandler_VER2

◆ ID3DNvGazeHandler_VER1

#define ID3DNvGazeHandler_VER1 MAKE_NVAPI_VERSION(ID3DNvGazeHandler_V1, 1)

◆ ID3DNvGazeHandler_VER2

#define ID3DNvGazeHandler_VER2 MAKE_NVAPI_VERSION(ID3DNvGazeHandler_V2, 2)

◆ ID3DNVSMPASSIST_VER

#define ID3DNVSMPASSIST_VER ID3DNVSMPASSIST_VER1

◆ ID3DNVSMPASSIST_VER1

#define ID3DNVSMPASSIST_VER1 MAKE_NVAPI_VERSION(ID3DNvSMPAssist_V1, 1)

◆ ID3DNvVRSHelper_VER

#define ID3DNvVRSHelper_VER ID3DNvVRSHelper_VER1

◆ ID3DNvVRSHelper_VER1

#define ID3DNvVRSHelper_VER1 MAKE_NVAPI_VERSION(ID3DNvVRSHelper_V1, 1)

◆ MAX_NUMBER_OF_GAZE_DATA_PROVIDERS

#define MAX_NUMBER_OF_GAZE_DATA_PROVIDERS 8

◆ NV_ASYNC_FRAME_MARKER_PARAMS_VER

#define NV_ASYNC_FRAME_MARKER_PARAMS_VER NV_ASYNC_FRAME_MARKER_PARAMS_VER1

◆ NV_ASYNC_FRAME_MARKER_PARAMS_VER1

#define NV_ASYNC_FRAME_MARKER_PARAMS_VER1 MAKE_NVAPI_VERSION(NV_ASYNC_FRAME_MARKER_PARAMS_V1, 1)

◆ NV_CUSTOM_SEMANTIC_MAX_LIMIT

#define NV_CUSTOM_SEMANTIC_MAX_LIMIT 32

SUPPORTED OS: Windows 7 and higher

◆ NV_CUSTOM_SEMANTIC_VERSION

#define NV_CUSTOM_SEMANTIC_VERSION MAKE_NVAPI_VERSION(NV_CUSTOM_SEMANTIC, 1)

◆ NV_D3D11_EXCLUSIVE_SCISSOR_RECTS_DESC_VER

#define NV_D3D11_EXCLUSIVE_SCISSOR_RECTS_DESC_VER NV_D3D11_EXCLUSIVE_SCISSOR_RECTS_DESC_VER1

◆ NV_D3D11_EXCLUSIVE_SCISSOR_RECTS_DESC_VER1

#define NV_D3D11_EXCLUSIVE_SCISSOR_RECTS_DESC_VER1 MAKE_NVAPI_VERSION(NV_D3D11_EXCLUSIVE_SCISSOR_RECTS_DESC_V1, 1)

◆ NV_D3D11_SHADING_RATE_RESOURCE_VIEW_DESC_VER

#define NV_D3D11_SHADING_RATE_RESOURCE_VIEW_DESC_VER NV_D3D11_SHADING_RATE_RESOURCE_VIEW_DESC_VER1

◆ NV_D3D11_SHADING_RATE_RESOURCE_VIEW_DESC_VER1

#define NV_D3D11_SHADING_RATE_RESOURCE_VIEW_DESC_VER1 MAKE_NVAPI_VERSION(NV_D3D11_SHADING_RATE_RESOURCE_VIEW_DESC_V1, 1)

◆ NV_D3D11_VIEWPORTS_SHADING_RATE_DESC_VER

#define NV_D3D11_VIEWPORTS_SHADING_RATE_DESC_VER NV_D3D11_VIEWPORTS_SHADING_RATE_DESC_VER1

◆ NV_D3D11_VIEWPORTS_SHADING_RATE_DESC_VER1

#define NV_D3D11_VIEWPORTS_SHADING_RATE_DESC_VER1 MAKE_NVAPI_VERSION(NV_D3D11_VIEWPORTS_SHADING_RATE_DESC_V1, 1)

◆ NV_D3D12_GRAPHICS_CAPS_VER

#define NV_D3D12_GRAPHICS_CAPS_VER NV_D3D12_GRAPHICS_CAPS_VER1

◆ NV_D3D12_GRAPHICS_CAPS_VER1

#define NV_D3D12_GRAPHICS_CAPS_VER1 MAKE_NVAPI_VERSION(NV_D3D12_GRAPHICS_CAPS_V1, 1)

◆ NV_D3D12_MOSAIC_GETCOMPANIONALLOCATIONS_VER

#define NV_D3D12_MOSAIC_GETCOMPANIONALLOCATIONS_VER NV_D3D12_MOSAIC_GETCOMPANIONALLOCATIONS_VER1

◆ NV_D3D12_MOSAIC_GETCOMPANIONALLOCATIONS_VER1

#define NV_D3D12_MOSAIC_GETCOMPANIONALLOCATIONS_VER1 MAKE_NVAPI_VERSION(NV_D3D12_MOSAIC_GETCOMPANIONALLOCATIONS_V1, 1)

◆ NV_D3D12_MOSAIC_GETVIEWPORTANDGPUPARTITIONS_VER

#define NV_D3D12_MOSAIC_GETVIEWPORTANDGPUPARTITIONS_VER NV_D3D12_MOSAIC_GETVIEWPORTANDGPUPARTITIONS_VER1

◆ NV_D3D12_MOSAIC_GETVIEWPORTANDGPUPARTITIONS_VER1

#define NV_D3D12_MOSAIC_GETVIEWPORTANDGPUPARTITIONS_VER1 MAKE_NVAPI_VERSION(NV_D3D12_MOSAIC_GETVIEWPORTANDGPUPARTITIONS_V1, 1)

◆ NV_D3D1x_GRAPHICS_CAPS_VER

#define NV_D3D1x_GRAPHICS_CAPS_VER NV_D3D1x_GRAPHICS_CAPS_VER2

◆ NV_D3D1x_GRAPHICS_CAPS_VER1

#define NV_D3D1x_GRAPHICS_CAPS_VER1 MAKE_NVAPI_VERSION(NV_D3D1x_GRAPHICS_CAPS_V1, 1)

◆ NV_D3D1x_GRAPHICS_CAPS_VER2

#define NV_D3D1x_GRAPHICS_CAPS_VER2 MAKE_NVAPI_VERSION(NV_D3D1x_GRAPHICS_CAPS_V2, 2)

◆ NV_D3D_LATELATCH_OBJECT_DESC_VER

#define NV_D3D_LATELATCH_OBJECT_DESC_VER NV_D3D_LATELATCH_OBJECT_DESC_VER1

◆ NV_D3D_LATELATCH_OBJECT_DESC_VER1

#define NV_D3D_LATELATCH_OBJECT_DESC_VER1 MAKE_NVAPI_VERSION(NV_D3D_LATELATCH_OBJECT_DESC_V1, 1)

◆ NV_DISPLAYCONFIG_PATH_INFO_VER

#define NV_DISPLAYCONFIG_PATH_INFO_VER NV_DISPLAYCONFIG_PATH_INFO_VER2

◆ NV_DOMAIN_SHADER_PSO_EXTENSION_DESC_VER

#define NV_DOMAIN_SHADER_PSO_EXTENSION_DESC_VER NV_DOMAIN_SHADER_PSO_EXTENSION_DESC_VER_3

◆ NV_DOMAIN_SHADER_PSO_EXTENSION_DESC_VER_1

#define NV_DOMAIN_SHADER_PSO_EXTENSION_DESC_VER_1 MAKE_NVAPI_VERSION(NVAPI_D3D12_PSO_DOMAIN_SHADER_DESC_V1, 1)

◆ NV_DOMAIN_SHADER_PSO_EXTENSION_DESC_VER_2

#define NV_DOMAIN_SHADER_PSO_EXTENSION_DESC_VER_2 MAKE_NVAPI_VERSION(NVAPI_D3D12_PSO_DOMAIN_SHADER_DESC_V2, 2)

◆ NV_DOMAIN_SHADER_PSO_EXTENSION_DESC_VER_3

#define NV_DOMAIN_SHADER_PSO_EXTENSION_DESC_VER_3 MAKE_NVAPI_VERSION(NVAPI_D3D12_PSO_DOMAIN_SHADER_DESC_V3, 3)

◆ NV_ENABLE_DEPTH_BOUND_TEST_PSO_EXTENSION_DESC_VER

#define NV_ENABLE_DEPTH_BOUND_TEST_PSO_EXTENSION_DESC_VER NV_ENABLE_DEPTH_BOUND_TEST_PSO_EXTENSION_DESC_VER_1

◆ NV_ENABLE_DEPTH_BOUND_TEST_PSO_EXTENSION_DESC_VER_1

#define NV_ENABLE_DEPTH_BOUND_TEST_PSO_EXTENSION_DESC_VER_1 MAKE_NVAPI_VERSION(NVAPI_D3D12_PSO_ENABLE_DEPTH_BOUND_TEST_DESC_V1, 1)

◆ NV_FAST_GEOMETRY_SHADER_PSO_EXTENSION_VER

#define NV_FAST_GEOMETRY_SHADER_PSO_EXTENSION_VER NV_FAST_GEOMETRY_SHADER_PSO_EXTENSION_VER_1

◆ NV_FAST_GEOMETRY_SHADER_PSO_EXTENSION_VER_1

#define NV_FAST_GEOMETRY_SHADER_PSO_EXTENSION_VER_1 MAKE_NVAPI_VERSION(NVAPI_D3D12_PSO_REQUEST_FAST_GEOMETRY_SHADER_DESC_V1, 1)

◆ NV_FASTGS_EXPLICIT_PSO_EXTENSION_VER

#define NV_FASTGS_EXPLICIT_PSO_EXTENSION_VER NV_FASTGS_EXPLICIT_PSO_EXTENSION_VER_1

◆ NV_FASTGS_EXPLICIT_PSO_EXTENSION_VER_1

#define NV_FASTGS_EXPLICIT_PSO_EXTENSION_VER_1 MAKE_NVAPI_VERSION(NVAPI_D3D12_PSO_CREATE_FASTGS_EXPLICIT_DESC_V1, 1)

◆ NV_FOVEATED_RENDERING_CUSTOM_FOVEATION_PATTERN_PRESET_DESC_VER

#define NV_FOVEATED_RENDERING_CUSTOM_FOVEATION_PATTERN_PRESET_DESC_VER NV_FOVEATED_RENDERING_CUSTOM_FOVEATION_PATTERN_PRESET_DESC_VER1

◆ NV_FOVEATED_RENDERING_CUSTOM_FOVEATION_PATTERN_PRESET_DESC_VER1

#define NV_FOVEATED_RENDERING_CUSTOM_FOVEATION_PATTERN_PRESET_DESC_VER1 MAKE_NVAPI_VERSION(NV_FOVEATED_RENDERING_CUSTOM_FOVEATION_PATTERN_PRESET_DESC_V1, 1)

◆ NV_FOVEATED_RENDERING_CUSTOM_SHADING_RATE_PRESET_DESC_VER

#define NV_FOVEATED_RENDERING_CUSTOM_SHADING_RATE_PRESET_DESC_VER NV_FOVEATED_RENDERING_CUSTOM_SHADING_RATE_PRESET_DESC_VER1

◆ NV_FOVEATED_RENDERING_CUSTOM_SHADING_RATE_PRESET_DESC_VER1

#define NV_FOVEATED_RENDERING_CUSTOM_SHADING_RATE_PRESET_DESC_VER1 MAKE_NVAPI_VERSION(NV_FOVEATED_RENDERING_CUSTOM_SHADING_RATE_PRESET_DESC_V1, 1)

◆ NV_FOVEATED_RENDERING_DESC_VER

#define NV_FOVEATED_RENDERING_DESC_VER NV_FOVEATED_RENDERING_DESC_VER1

◆ NV_FOVEATED_RENDERING_DESC_VER1

#define NV_FOVEATED_RENDERING_DESC_VER1 MAKE_NVAPI_VERSION(NV_FOVEATED_RENDERING_DESC_V1, 1)

◆ NV_FOVEATED_RENDERING_GAZE_DATA_PER_EYE_VER

#define NV_FOVEATED_RENDERING_GAZE_DATA_PER_EYE_VER NV_FOVEATED_RENDERING_GAZE_DATA_PER_EYE_VER1

◆ NV_FOVEATED_RENDERING_GAZE_DATA_PER_EYE_VER1

#define NV_FOVEATED_RENDERING_GAZE_DATA_PER_EYE_VER1 MAKE_NVAPI_VERSION(NV_FOVEATED_RENDERING_GAZE_DATA_PER_EYE_V1, 1)

◆ NV_FOVEATED_RENDERING_UPDATE_GAZE_DATA_PARAMS_VER

#define NV_FOVEATED_RENDERING_UPDATE_GAZE_DATA_PARAMS_VER NV_FOVEATED_RENDERING_UPDATE_GAZE_DATA_PARAMS_VER1

◆ NV_FOVEATED_RENDERING_UPDATE_GAZE_DATA_PARAMS_VER1

#define NV_FOVEATED_RENDERING_UPDATE_GAZE_DATA_PARAMS_VER1 MAKE_NVAPI_VERSION(NV_FOVEATED_RENDERING_UPDATE_GAZE_DATA_PARAMS_V1, 1)

◆ NV_GAZE_HANDLER_INIT_PARAMS_VER

#define NV_GAZE_HANDLER_INIT_PARAMS_VER NV_GAZE_HANDLER_INIT_PARAMS_VER2

◆ NV_GAZE_HANDLER_INIT_PARAMS_VER1

#define NV_GAZE_HANDLER_INIT_PARAMS_VER1 MAKE_NVAPI_VERSION(NV_GAZE_HANDLER_INIT_PARAMS_V1, 1)

◆ NV_GAZE_HANDLER_INIT_PARAMS_VER2

#define NV_GAZE_HANDLER_INIT_PARAMS_VER2 MAKE_NVAPI_VERSION(NV_GAZE_HANDLER_INIT_PARAMS_V2, 2)

◆ NV_GEOMETRY_SHADER_PSO_EXTENSION_DESC_VER

#define NV_GEOMETRY_SHADER_PSO_EXTENSION_DESC_VER NV_GEOMETRY_SHADER_PSO_EXTENSION_DESC_VER_5

◆ NV_GEOMETRY_SHADER_PSO_EXTENSION_DESC_VER_5

#define NV_GEOMETRY_SHADER_PSO_EXTENSION_DESC_VER_5 MAKE_NVAPI_VERSION(NVAPI_D3D12_PSO_GEOMETRY_SHADER_DESC_V5, 5)

◆ NV_GET_GPU_VIRTUAL_ADDRESS

#define NV_GET_GPU_VIRTUAL_ADDRESS NV_GET_GPU_VIRTUAL_ADDRESS_V1

◆ NV_GET_GPU_VIRTUAL_ADDRESS_VER

#define NV_GET_GPU_VIRTUAL_ADDRESS_VER NV_GET_GPU_VIRTUAL_ADDRESS_VER1

◆ NV_GET_GPU_VIRTUAL_ADDRESS_VER1

#define NV_GET_GPU_VIRTUAL_ADDRESS_VER1 MAKE_NVAPI_VERSION(NV_GET_GPU_VIRTUAL_ADDRESS_V1, 1)

◆ NV_GET_SLEEP_STATUS_PARAMS_VER

#define NV_GET_SLEEP_STATUS_PARAMS_VER NV_GET_SLEEP_STATUS_PARAMS_VER1

◆ NV_GET_SLEEP_STATUS_PARAMS_VER1

#define NV_GET_SLEEP_STATUS_PARAMS_VER1 MAKE_NVAPI_VERSION(NV_GET_SLEEP_STATUS_PARAMS_V1, 1)

◆ NV_HEAP_PARAMS_VER

#define NV_HEAP_PARAMS_VER NV_HEAP_PARAMS_VER_1

◆ NV_HEAP_PARAMS_VER_1

#define NV_HEAP_PARAMS_VER_1 MAKE_NVAPI_VERSION(NV_HEAP_PARAMS_V1, 1)

◆ NV_HULL_SHADER_PSO_EXTENSION_DESC_VER

#define NV_HULL_SHADER_PSO_EXTENSION_DESC_VER NV_HULL_SHADER_PSO_EXTENSION_DESC_VER_2

◆ NV_HULL_SHADER_PSO_EXTENSION_DESC_VER_1

#define NV_HULL_SHADER_PSO_EXTENSION_DESC_VER_1 MAKE_NVAPI_VERSION(NVAPI_D3D12_PSO_HULL_SHADER_DESC_V1, 1)

◆ NV_HULL_SHADER_PSO_EXTENSION_DESC_VER_2

#define NV_HULL_SHADER_PSO_EXTENSION_DESC_VER_2 MAKE_NVAPI_VERSION(NVAPI_D3D12_PSO_HULL_SHADER_DESC_V2, 2)

◆ NV_JOIN_PRESENT_BARRIER_PARAMS_VER1

#define NV_JOIN_PRESENT_BARRIER_PARAMS_VER1 MAKE_NVAPI_VERSION(NV_JOIN_PRESENT_BARRIER_PARAMS, 1)

Macro for constructing the version field of NV_JOIN_PRESENT_BARRIER_PARAMS.

◆ NV_LATENCY_MARKER_PARAMS_VER

#define NV_LATENCY_MARKER_PARAMS_VER NV_LATENCY_MARKER_PARAMS_VER1

◆ NV_LATENCY_MARKER_PARAMS_VER1

#define NV_LATENCY_MARKER_PARAMS_VER1 MAKE_NVAPI_VERSION(NV_LATENCY_MARKER_PARAMS_V1, 1)

◆ NV_LATENCY_RESULT_PARAMS_VER

#define NV_LATENCY_RESULT_PARAMS_VER NV_LATENCY_RESULT_PARAMS_VER1

◆ NV_LATENCY_RESULT_PARAMS_VER1

#define NV_LATENCY_RESULT_PARAMS_VER1 MAKE_NVAPI_VERSION(NV_LATENCY_RESULT_PARAMS_V1, 1)

◆ NV_MAX_NUM_EXCLUSIVE_SCISSOR_RECTS

#define NV_MAX_NUM_EXCLUSIVE_SCISSOR_RECTS 16

◆ NV_MAX_NUM_VIEWPORTS

#define NV_MAX_NUM_VIEWPORTS 16

◆ NV_META_COMMAND_ACTIVATION_MAX_PARAMS

#define NV_META_COMMAND_ACTIVATION_MAX_PARAMS 2

◆ NV_META_COMMAND_MAX_TENSOR_DIM

#define NV_META_COMMAND_MAX_TENSOR_DIM 5

◆ NV_META_COMMAND_NUM_SPATIAL_DIM

#define NV_META_COMMAND_NUM_SPATIAL_DIM 3

◆ NV_MODIFIED_W_MAX_VIEWPORTS

#define NV_MODIFIED_W_MAX_VIEWPORTS 16

SUPPORTED OS: Windows 7 and higher

◆ NV_MODIFIED_W_PARAMS_VER

#define NV_MODIFIED_W_PARAMS_VER NV_MODIFIED_W_PARAMS_VER1

◆ NV_MODIFIED_W_PARAMS_VER1

#define NV_MODIFIED_W_PARAMS_VER1 MAKE_NVAPI_VERSION(NV_MODIFIED_W_PARAMS_V1, 1)

◆ NV_MULTIGPU_CAPS_VER

#define NV_MULTIGPU_CAPS_VER NV_MULTIGPU_CAPS_VER2

◆ NV_MULTIGPU_CAPS_VER1

#define NV_MULTIGPU_CAPS_VER1 MAKE_NVAPI_VERSION(NV_MULTIGPU_CAPS_V1, 1)

◆ NV_MULTIGPU_CAPS_VER2

#define NV_MULTIGPU_CAPS_VER2 MAKE_NVAPI_VERSION(NV_MULTIGPU_CAPS_V2, 2)

◆ NV_MULTIVIEW_MAX_SUPPORTED_VIEWS

#define NV_MULTIVIEW_MAX_SUPPORTED_VIEWS 4

◆ NV_MULTIVIEW_PARAMS_VER

#define NV_MULTIVIEW_PARAMS_VER NV_MULTIVIEW_PARAMS_VER1

◆ NV_MULTIVIEW_PARAMS_VER1

#define NV_MULTIVIEW_PARAMS_VER1 MAKE_NVAPI_VERSION(NV_MULTIVIEW_PARAMS_V1, 1)

◆ NV_PIXEL_SHADING_RATE_SAMPLE_ORDER_TABLE_VER

#define NV_PIXEL_SHADING_RATE_SAMPLE_ORDER_TABLE_VER NV_PIXEL_SHADING_RATE_SAMPLE_ORDER_TABLE_VER1

◆ NV_PIXEL_SHADING_RATE_SAMPLE_ORDER_TABLE_VER1

#define NV_PIXEL_SHADING_RATE_SAMPLE_ORDER_TABLE_VER1 MAKE_NVAPI_VERSION(NV_PIXEL_SHADING_RATE_SAMPLE_ORDER_TABLE_V1, 1)

◆ NV_PRESENT_BARRIER_FRAME_STATICS_VER1

#define NV_PRESENT_BARRIER_FRAME_STATICS_VER1 MAKE_NVAPI_VERSION(NV_PRESENT_BARRIER_FRAME_STATISTICS,1)

SUPPORTED OS: Windows 10 and higher

◆ NV_PSO_EXTENSION_DESC_VER

#define NV_PSO_EXTENSION_DESC_VER NV_PSO_EXTENSION_DESC_VER_1

◆ NV_PSO_EXTENSION_DESC_VER_1

#define NV_PSO_EXTENSION_DESC_VER_1 MAKE_NVAPI_VERSION(NVAPI_D3D12_PSO_EXTENSION_DESC_V1, 1)

◆ NV_QUERY_LATELATCH_SUPPORT_PARAMS_VER

#define NV_QUERY_LATELATCH_SUPPORT_PARAMS_VER NV_QUERY_LATELATCH_SUPPORT_PARAMS_VER1

◆ NV_QUERY_LATELATCH_SUPPORT_PARAMS_VER1

#define NV_QUERY_LATELATCH_SUPPORT_PARAMS_VER1 MAKE_NVAPI_VERSION(NV_QUERY_LATELATCH_SUPPORT_PARAMS_V1, 1)

◆ NV_QUERY_MODIFIED_W_SUPPORT_PARAMS_VER

#define NV_QUERY_MODIFIED_W_SUPPORT_PARAMS_VER NV_QUERY_MODIFIED_W_SUPPORT_PARAMS_VER1

◆ NV_QUERY_MODIFIED_W_SUPPORT_PARAMS_VER1

#define NV_QUERY_MODIFIED_W_SUPPORT_PARAMS_VER1 MAKE_NVAPI_VERSION(NV_QUERY_MODIFIED_W_SUPPORT_PARAMS_V1, 1)

◆ NV_QUERY_MULTIVIEW_SUPPORT_PARAMS_VER

#define NV_QUERY_MULTIVIEW_SUPPORT_PARAMS_VER NV_QUERY_MULTIVIEW_SUPPORT_PARAMS_VER1

◆ NV_QUERY_MULTIVIEW_SUPPORT_PARAMS_VER1

#define NV_QUERY_MULTIVIEW_SUPPORT_PARAMS_VER1 MAKE_NVAPI_VERSION(NV_QUERY_MULTIVIEW_SUPPORT_PARAMS_V1, 1)

◆ NV_QUERY_SINGLE_PASS_STEREO_SUPPORT_PARAMS_VER

#define NV_QUERY_SINGLE_PASS_STEREO_SUPPORT_PARAMS_VER NV_QUERY_SINGLE_PASS_STEREO_SUPPORT_PARAMS_VER2

◆ NV_QUERY_SINGLE_PASS_STEREO_SUPPORT_PARAMS_VER1

#define NV_QUERY_SINGLE_PASS_STEREO_SUPPORT_PARAMS_VER1 MAKE_NVAPI_VERSION(NV_QUERY_SINGLE_PASS_STEREO_SUPPORT_PARAMS_V1, 1)

◆ NV_QUERY_SINGLE_PASS_STEREO_SUPPORT_PARAMS_VER2

#define NV_QUERY_SINGLE_PASS_STEREO_SUPPORT_PARAMS_VER2 MAKE_NVAPI_VERSION(NV_QUERY_SINGLE_PASS_STEREO_SUPPORT_PARAMS_V2, 2)

◆ NV_QUERY_SMP_ASSIST_SUPPORT_PARAMS_VER

#define NV_QUERY_SMP_ASSIST_SUPPORT_PARAMS_VER NV_QUERY_SMP_ASSIST_SUPPORT_PARAMS_VER1

◆ NV_QUERY_SMP_ASSIST_SUPPORT_PARAMS_VER1

#define NV_QUERY_SMP_ASSIST_SUPPORT_PARAMS_VER1 MAKE_NVAPI_VERSION(NV_QUERY_SMP_ASSIST_SUPPORT_PARAMS_V1, 1)

◆ NV_RASTERIZER_PSO_EXTENSION_DESC_VER

#define NV_RASTERIZER_PSO_EXTENSION_DESC_VER NV_RASTERIZER_PSO_EXTENSION_DESC_VER_2

◆ NV_RASTERIZER_PSO_EXTENSION_DESC_VER_1

#define NV_RASTERIZER_PSO_EXTENSION_DESC_VER_1 MAKE_NVAPI_VERSION(NVAPI_D3D12_PSO_RASTERIZER_STATE_DESC_V1, 1)

◆ NV_RASTERIZER_PSO_EXTENSION_DESC_VER_2

#define NV_RASTERIZER_PSO_EXTENSION_DESC_VER_2 MAKE_NVAPI_VERSION(NVAPI_D3D12_PSO_RASTERIZER_STATE_DESC_V1, 2)

◆ NV_RESOURCE_PARAMS_VER

#define NV_RESOURCE_PARAMS_VER NV_RESOURCE_PARAMS_VER_1

◆ NV_RESOURCE_PARAMS_VER_1

#define NV_RESOURCE_PARAMS_VER_1 MAKE_NVAPI_VERSION(NV_RESOURCE_PARAMS_V1, 1)

◆ NV_SET_REFLEX_SYNC_PARAMS_VER

#define NV_SET_REFLEX_SYNC_PARAMS_VER NV_SET_REFLEX_SYNC_PARAMS_VER1

◆ NV_SET_REFLEX_SYNC_PARAMS_VER1

#define NV_SET_REFLEX_SYNC_PARAMS_VER1 MAKE_NVAPI_VERSION(NV_SET_REFLEX_SYNC_PARAMS_V1, 1)

◆ NV_SET_SHADER_EXTENSION_SLOT_DESC_VER

#define NV_SET_SHADER_EXTENSION_SLOT_DESC_VER NV_SET_SHADER_EXTENSION_SLOT_DESC_VER_1

◆ NV_SET_SHADER_EXTENSION_SLOT_DESC_VER_1

#define NV_SET_SHADER_EXTENSION_SLOT_DESC_VER_1 MAKE_NVAPI_VERSION(NVAPI_D3D12_PSO_SET_SHADER_EXTENSION_SLOT_DESC_V1, 1)

◆ NV_SET_SLEEP_MODE_PARAMS_VER

#define NV_SET_SLEEP_MODE_PARAMS_VER NV_SET_SLEEP_MODE_PARAMS_VER1

◆ NV_SET_SLEEP_MODE_PARAMS_VER1

#define NV_SET_SLEEP_MODE_PARAMS_VER1 MAKE_NVAPI_VERSION(NV_SET_SLEEP_MODE_PARAMS_V1, 1)

◆ NV_SMP_ASSIST_DISABLE_PARAMS_VER

#define NV_SMP_ASSIST_DISABLE_PARAMS_VER NV_SMP_ASSIST_DISABLE_PARAMS_VER1

◆ NV_SMP_ASSIST_DISABLE_PARAMS_VER1

#define NV_SMP_ASSIST_DISABLE_PARAMS_VER1 MAKE_NVAPI_VERSION(NV_SMP_ASSIST_DISABLE_PARAMS_V1, 1)

◆ NV_SMP_ASSIST_ENABLE_PARAMS_VER

#define NV_SMP_ASSIST_ENABLE_PARAMS_VER NV_SMP_ASSIST_ENABLE_PARAMS_VER1

◆ NV_SMP_ASSIST_ENABLE_PARAMS_VER1

#define NV_SMP_ASSIST_ENABLE_PARAMS_VER1 MAKE_NVAPI_VERSION(NV_SMP_ASSIST_ENABLE_PARAMS_V1, 1)

◆ NV_SMP_ASSIST_FLAGS_DEFAULT

#define NV_SMP_ASSIST_FLAGS_DEFAULT 0x00000000

◆ NV_SMP_ASSIST_GET_CONSTANTS_VER

#define NV_SMP_ASSIST_GET_CONSTANTS_VER NV_SMP_ASSIST_GET_CONSTANTS_VER3

◆ NV_SMP_ASSIST_GET_CONSTANTS_VER3

#define NV_SMP_ASSIST_GET_CONSTANTS_VER3 MAKE_NVAPI_VERSION(NV_SMP_ASSIST_GET_CONSTANTS_V3, 3)

◆ NV_SMP_ASSIST_INITIALIZE_PARAMS_VER

#define NV_SMP_ASSIST_INITIALIZE_PARAMS_VER NV_SMP_ASSIST_INITIALIZE_PARAMS_VER1

◆ NV_SMP_ASSIST_INITIALIZE_PARAMS_VER1

#define NV_SMP_ASSIST_INITIALIZE_PARAMS_VER1 MAKE_NVAPI_VERSION(NV_SMP_ASSIST_INITIALIZE_PARAMS_V1, 1)

◆ NV_SMP_ASSIST_MAX_VIEWPORTS

#define NV_SMP_ASSIST_MAX_VIEWPORTS 16

◆ NV_SMP_ASSIST_MINIMAL_LEVEL_NUM_EYE_INDICES

#define NV_SMP_ASSIST_MINIMAL_LEVEL_NUM_EYE_INDICES 4

◆ NV_SMP_ASSIST_SETUP_PARAMS_VER

#define NV_SMP_ASSIST_SETUP_PARAMS_VER NV_SMP_ASSIST_SETUP_PARAMS_VER1

◆ NV_SMP_ASSIST_SETUP_PARAMS_VER1

#define NV_SMP_ASSIST_SETUP_PARAMS_VER1 MAKE_NVAPI_VERSION(NV_SMP_ASSIST_SETUP_PARAMS_V1, 1)

◆ NV_SMP_ASSIST_UPDATE_INSTANCEDSTEREO_DATA_PARAMS_VER

#define NV_SMP_ASSIST_UPDATE_INSTANCEDSTEREO_DATA_PARAMS_VER NV_SMP_ASSIST_UPDATE_INSTANCEDSTEREO_DATA_PARAMS_VER1

◆ NV_SMP_ASSIST_UPDATE_INSTANCEDSTEREO_DATA_PARAMS_VER1

#define NV_SMP_ASSIST_UPDATE_INSTANCEDSTEREO_DATA_PARAMS_VER1 MAKE_NVAPI_VERSION(NV_SMP_ASSIST_UPDATE_INSTANCEDSTEREO_DATA_PARAMS_V1, 1)

◆ NV_TIMING_STRUCTS_DEFINED

#define NV_TIMING_STRUCTS_DEFINED

◆ NV_VARIABLE_PIXEL_SHADING_TILE_HEIGHT

#define NV_VARIABLE_PIXEL_SHADING_TILE_HEIGHT 16

◆ NV_VARIABLE_PIXEL_SHADING_TILE_WIDTH

#define NV_VARIABLE_PIXEL_SHADING_TILE_WIDTH 16

◆ NV_VERTEX_SHADER_PSO_EXTENSION_DESC_VER

#define NV_VERTEX_SHADER_PSO_EXTENSION_DESC_VER NV_VERTEX_SHADER_PSO_EXTENSION_DESC_VER_3

◆ NV_VERTEX_SHADER_PSO_EXTENSION_DESC_VER_1

#define NV_VERTEX_SHADER_PSO_EXTENSION_DESC_VER_1 MAKE_NVAPI_VERSION(NVAPI_D3D12_PSO_VERTEX_SHADER_DESC_V1, 1)

◆ NV_VERTEX_SHADER_PSO_EXTENSION_DESC_VER_2

#define NV_VERTEX_SHADER_PSO_EXTENSION_DESC_VER_2 MAKE_NVAPI_VERSION(NVAPI_D3D12_PSO_VERTEX_SHADER_DESC_V2, 2)

◆ NV_VERTEX_SHADER_PSO_EXTENSION_DESC_VER_3

#define NV_VERTEX_SHADER_PSO_EXTENSION_DESC_VER_3 MAKE_NVAPI_VERSION(NVAPI_D3D12_PSO_VERTEX_SHADER_DESC_V3, 3)

◆ NV_VRS_HELPER_DISABLE_PARAMS_VER

#define NV_VRS_HELPER_DISABLE_PARAMS_VER NV_VRS_HELPER_DISABLE_PARAMS_VER1

◆ NV_VRS_HELPER_DISABLE_PARAMS_VER1

#define NV_VRS_HELPER_DISABLE_PARAMS_VER1 MAKE_NVAPI_VERSION(NV_VRS_HELPER_DISABLE_PARAMS_V1, 1)

◆ NV_VRS_HELPER_ENABLE_PARAMS_VER

#define NV_VRS_HELPER_ENABLE_PARAMS_VER NV_VRS_HELPER_ENABLE_PARAMS_VER1

◆ NV_VRS_HELPER_ENABLE_PARAMS_VER1

#define NV_VRS_HELPER_ENABLE_PARAMS_VER1 MAKE_NVAPI_VERSION(NV_VRS_HELPER_ENABLE_PARAMS_V1, 1)

◆ NV_VRS_HELPER_GET_SHADING_RATE_RESOURCE_PARAMS_VER

#define NV_VRS_HELPER_GET_SHADING_RATE_RESOURCE_PARAMS_VER NV_VRS_HELPER_GET_SHADING_RATE_RESOURCE_PARAMS_VER1

◆ NV_VRS_HELPER_GET_SHADING_RATE_RESOURCE_PARAMS_VER1

#define NV_VRS_HELPER_GET_SHADING_RATE_RESOURCE_PARAMS_VER1 MAKE_NVAPI_VERSION(NV_VRS_HELPER_GET_SHADING_RATE_RESOURCE_PARAMS_V1, 1)

◆ NV_VRS_HELPER_INIT_PARAMS_VER

#define NV_VRS_HELPER_INIT_PARAMS_VER NV_VRS_HELPER_INIT_PARAMS_VER1

◆ NV_VRS_HELPER_INIT_PARAMS_VER1

#define NV_VRS_HELPER_INIT_PARAMS_VER1 MAKE_NVAPI_VERSION(NV_VRS_HELPER_INIT_PARAMS_V1, 1)

◆ NV_VRS_HELPER_LATCH_GAZE_PARAMS_VER

#define NV_VRS_HELPER_LATCH_GAZE_PARAMS_VER NV_VRS_HELPER_LATCH_GAZE_PARAMS_VER1

◆ NV_VRS_HELPER_LATCH_GAZE_PARAMS_VER1

#define NV_VRS_HELPER_LATCH_GAZE_PARAMS_VER1 MAKE_NVAPI_VERSION(NV_VRS_HELPER_LATCH_GAZE_PARAMS_V1, 1)

◆ NV_VRS_HELPER_PURGE_INTERNAL_RESOURCES_PARAMS_VER

#define NV_VRS_HELPER_PURGE_INTERNAL_RESOURCES_PARAMS_VER NV_VRS_HELPER_PURGE_INTERNAL_RESOURCES_PARAMS_VER1

◆ NV_VRS_HELPER_PURGE_INTERNAL_RESOURCES_PARAMS_VER1

#define NV_VRS_HELPER_PURGE_INTERNAL_RESOURCES_PARAMS_VER1 MAKE_NVAPI_VERSION(NV_VRS_HELPER_PURGE_INTERNAL_RESOURCES_PARAMS_V1, 1)

◆ NVAPI_ALL_GPUS

#define NVAPI_ALL_GPUS 0

◆ NVAPI_ANSEL_CONFIGURATION_STRUCT_VER

#define NVAPI_ANSEL_CONFIGURATION_STRUCT_VER NVAPI_ANSEL_CONFIGURATION_STRUCT_VER1

◆ NVAPI_ANSEL_CONFIGURATION_STRUCT_VER1

#define NVAPI_ANSEL_CONFIGURATION_STRUCT_VER1 MAKE_NVAPI_VERSION(NVAPI_ANSEL_CONFIGURATION_STRUCT_V1,1)

◆ NVAPI_BINARY_DATA_MAX

#define NVAPI_BINARY_DATA_MAX 4096

◆ NVAPI_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_EX_PARAMS_VER

#define NVAPI_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_EX_PARAMS_VER NVAPI_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_EX_PARAMS_VER1

◆ NVAPI_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_EX_PARAMS_VER1

#define NVAPI_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_EX_PARAMS_VER1 MAKE_NVAPI_VERSION(NVAPI_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_EX_PARAMS_V1, 1)

◆ NVAPI_BUILD_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PARAMS_VER

#define NVAPI_BUILD_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PARAMS_VER NVAPI_BUILD_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PARAMS_VER1

◆ NVAPI_BUILD_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PARAMS_VER1

#define NVAPI_BUILD_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PARAMS_VER1 MAKE_NVAPI_VERSION(NVAPI_BUILD_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PARAMS_V1, 1)

◆ NVAPI_BUILD_RAYTRACING_OPACITY_MICROMAP_ARRAY_PARAMS_VER

#define NVAPI_BUILD_RAYTRACING_OPACITY_MICROMAP_ARRAY_PARAMS_VER NVAPI_BUILD_RAYTRACING_OPACITY_MICROMAP_ARRAY_PARAMS_VER1

◆ NVAPI_BUILD_RAYTRACING_OPACITY_MICROMAP_ARRAY_PARAMS_VER1

#define NVAPI_BUILD_RAYTRACING_OPACITY_MICROMAP_ARRAY_PARAMS_VER1 MAKE_NVAPI_VERSION(NVAPI_BUILD_RAYTRACING_OPACITY_MICROMAP_ARRAY_PARAMS_V1, 1)

◆ NVAPI_CHECK_DRIVER_MATCHING_IDENTIFIER_EX_PARAMS_VER

#define NVAPI_CHECK_DRIVER_MATCHING_IDENTIFIER_EX_PARAMS_VER NVAPI_CHECK_DRIVER_MATCHING_IDENTIFIER_EX_PARAMS_VER1

◆ NVAPI_CHECK_DRIVER_MATCHING_IDENTIFIER_EX_PARAMS_VER1

#define NVAPI_CHECK_DRIVER_MATCHING_IDENTIFIER_EX_PARAMS_VER1 MAKE_NVAPI_VERSION(NVAPI_CHECK_DRIVER_MATCHING_IDENTIFIER_EX_PARAMS_V1, 1)

◆ NVAPI_COPY_P2P_READ

#define NVAPI_COPY_P2P_READ 2

SUPPORTED OS: Windows 7 and higher

◆ NVAPI_CPU_RESOURCE

#define NVAPI_CPU_RESOURCE 0xffffffff

SUPPORTED OS: Windows 7 and higher

◆ NVAPI_D3D11_CREATEDOMAINSHADEREX_VER_1

#define NVAPI_D3D11_CREATEDOMAINSHADEREX_VER_1 MAKE_NVAPI_VERSION(NvAPI_D3D11_CREATE_DOMAIN_SHADER_EX_V1, 1)

◆ NVAPI_D3D11_CREATEDOMAINSHADEREX_VER_2

#define NVAPI_D3D11_CREATEDOMAINSHADEREX_VER_2 MAKE_NVAPI_VERSION(NvAPI_D3D11_CREATE_DOMAIN_SHADER_EX_V2, 2)

◆ NVAPI_D3D11_CREATEDOMAINSHADEREX_VER_3

#define NVAPI_D3D11_CREATEDOMAINSHADEREX_VER_3 MAKE_NVAPI_VERSION(NvAPI_D3D11_CREATE_DOMAIN_SHADER_EX_V3, 3)

◆ NVAPI_D3D11_CREATEDOMAINSHADEREX_VERSION

#define NVAPI_D3D11_CREATEDOMAINSHADEREX_VERSION NVAPI_D3D11_CREATEDOMAINSHADEREX_VER_3

◆ NVAPI_D3D11_CREATEFASTGSEXPLICIT_VER

#define NVAPI_D3D11_CREATEFASTGSEXPLICIT_VER NVAPI_D3D11_CREATEFASTGSEXPLICIT_VER1

◆ NVAPI_D3D11_CREATEFASTGSEXPLICIT_VER1

#define NVAPI_D3D11_CREATEFASTGSEXPLICIT_VER1 MAKE_NVAPI_VERSION(NvAPI_D3D11_CREATE_FASTGS_EXPLICIT_DESC_V1, 1)

◆ NVAPI_D3D11_CREATEGEOMETRYSHADEREX_2_VER_5

#define NVAPI_D3D11_CREATEGEOMETRYSHADEREX_2_VER_5 MAKE_NVAPI_VERSION(NvAPI_D3D11_CREATE_GEOMETRY_SHADER_EX_V5, 5)

◆ NVAPI_D3D11_CREATEGEOMETRYSHADEREX_2_VERSION

#define NVAPI_D3D11_CREATEGEOMETRYSHADEREX_2_VERSION NVAPI_D3D11_CREATEGEOMETRYSHADEREX_2_VER_5

◆ NVAPI_D3D11_CREATEHULLSHADEREX_VER_1

#define NVAPI_D3D11_CREATEHULLSHADEREX_VER_1 MAKE_NVAPI_VERSION(NvAPI_D3D11_CREATE_HULL_SHADER_EX_V1, 1)

◆ NVAPI_D3D11_CREATEHULLSHADEREX_VER_2

#define NVAPI_D3D11_CREATEHULLSHADEREX_VER_2 MAKE_NVAPI_VERSION(NvAPI_D3D11_CREATE_HULL_SHADER_EX_V1, 2)

◆ NVAPI_D3D11_CREATEHULLSHADEREX_VERSION

#define NVAPI_D3D11_CREATEHULLSHADEREX_VERSION NVAPI_D3D11_CREATEHULLSHADEREX_VER_2

◆ NVAPI_D3D11_CREATEPIXELSHADEREX_VER_1

#define NVAPI_D3D11_CREATEPIXELSHADEREX_VER_1 MAKE_NVAPI_VERSION(NvAPI_D3D11_CREATE_PIXEL_SHADER_EX_V1, 1)

◆ NVAPI_D3D11_CREATEPIXELSHADEREX_VER_2

#define NVAPI_D3D11_CREATEPIXELSHADEREX_VER_2 MAKE_NVAPI_VERSION(NvAPI_D3D11_CREATE_PIXEL_SHADER_EX_V2, 2)

◆ NVAPI_D3D11_CREATEPIXELSHADEREX_VERSION

#define NVAPI_D3D11_CREATEPIXELSHADEREX_VERSION NVAPI_D3D11_CREATEPIXELSHADEREX_VER_2

◆ NVAPI_D3D11_CREATEVERTEXSHADEREX_VER_1

#define NVAPI_D3D11_CREATEVERTEXSHADEREX_VER_1 MAKE_NVAPI_VERSION(NvAPI_D3D11_CREATE_VERTEX_SHADER_EX_V1, 1)

◆ NVAPI_D3D11_CREATEVERTEXSHADEREX_VER_2

#define NVAPI_D3D11_CREATEVERTEXSHADEREX_VER_2 MAKE_NVAPI_VERSION(NvAPI_D3D11_CREATE_VERTEX_SHADER_EX_V2, 2)

◆ NVAPI_D3D11_CREATEVERTEXSHADEREX_VER_3

#define NVAPI_D3D11_CREATEVERTEXSHADEREX_VER_3 MAKE_NVAPI_VERSION(NvAPI_D3D11_CREATE_VERTEX_SHADER_EX_V2, 3)

◆ NVAPI_D3D11_CREATEVERTEXSHADEREX_VERSION

#define NVAPI_D3D11_CREATEVERTEXSHADEREX_VERSION NVAPI_D3D11_CREATEVERTEXSHADEREX_VER_3

◆ NVAPI_D3D12_SET_CREATE_PIPELINE_STATE_OPTIONS_PARAMS_VER

#define NVAPI_D3D12_SET_CREATE_PIPELINE_STATE_OPTIONS_PARAMS_VER NVAPI_D3D12_SET_CREATE_PIPELINE_STATE_OPTIONS_PARAMS_VER1

◆ NVAPI_D3D12_SET_CREATE_PIPELINE_STATE_OPTIONS_PARAMS_VER1

#define NVAPI_D3D12_SET_CREATE_PIPELINE_STATE_OPTIONS_PARAMS_VER1 MAKE_NVAPI_VERSION(NVAPI_D3D12_SET_CREATE_PIPELINE_STATE_OPTIONS_PARAMS_V1, 1)

◆ NVAPI_D3D12_WORKSTATION_FEATURE_PROPERTIES_PARAMS

#define NVAPI_D3D12_WORKSTATION_FEATURE_PROPERTIES_PARAMS NVAPI_D3D12_WORKSTATION_FEATURE_PROPERTIES_PARAMS_V1

◆ NVAPI_D3D12_WORKSTATION_FEATURE_PROPERTIES_PARAMS_VER

#define NVAPI_D3D12_WORKSTATION_FEATURE_PROPERTIES_PARAMS_VER NVAPI_D3D12_WORKSTATION_FEATURE_PROPERTIES_PARAMS_VER1

◆ NVAPI_D3D12_WORKSTATION_FEATURE_PROPERTIES_PARAMS_VER1

#define NVAPI_D3D12_WORKSTATION_FEATURE_PROPERTIES_PARAMS_VER1 MAKE_NVAPI_VERSION(NVAPI_D3D12_WORKSTATION_FEATURE_PROPERTIES_PARAMS_V1,1)

◆ NVAPI_EMIT_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_POSTBUILD_INFO_PARAMS_VER

#define NVAPI_EMIT_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_POSTBUILD_INFO_PARAMS_VER NVAPI_EMIT_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_POSTBUILD_INFO_PARAMS_VER1

◆ NVAPI_EMIT_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_POSTBUILD_INFO_PARAMS_VER1

#define NVAPI_EMIT_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_POSTBUILD_INFO_PARAMS_VER1 MAKE_NVAPI_VERSION(NVAPI_EMIT_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_POSTBUILD_INFO_PARAMS_V1, 1)

◆ NVAPI_EMIT_RAYTRACING_OPACITY_MICROMAP_ARRAY_POSTBUILD_INFO_PARAMS_VER

#define NVAPI_EMIT_RAYTRACING_OPACITY_MICROMAP_ARRAY_POSTBUILD_INFO_PARAMS_VER NVAPI_EMIT_RAYTRACING_OPACITY_MICROMAP_ARRAY_POSTBUILD_INFO_PARAMS_VER1

◆ NVAPI_EMIT_RAYTRACING_OPACITY_MICROMAP_ARRAY_POSTBUILD_INFO_PARAMS_VER1

#define NVAPI_EMIT_RAYTRACING_OPACITY_MICROMAP_ARRAY_POSTBUILD_INFO_PARAMS_VER1 MAKE_NVAPI_VERSION(NVAPI_EMIT_RAYTRACING_OPACITY_MICROMAP_ARRAY_POSTBUILD_INFO_PARAMS_V1, 1)

◆ NVAPI_GET_RAYTRACING_ACCELERATION_STRUCTURE_PREBUILD_INFO_EX_PARAMS_VER

#define NVAPI_GET_RAYTRACING_ACCELERATION_STRUCTURE_PREBUILD_INFO_EX_PARAMS_VER NVAPI_GET_RAYTRACING_ACCELERATION_STRUCTURE_PREBUILD_INFO_EX_PARAMS_VER1

◆ NVAPI_GET_RAYTRACING_ACCELERATION_STRUCTURE_PREBUILD_INFO_EX_PARAMS_VER1

#define NVAPI_GET_RAYTRACING_ACCELERATION_STRUCTURE_PREBUILD_INFO_EX_PARAMS_VER1 MAKE_NVAPI_VERSION(NVAPI_GET_RAYTRACING_ACCELERATION_STRUCTURE_PREBUILD_INFO_EX_PARAMS_V1, 1)

◆ NVAPI_GET_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PREBUILD_INFO_PARAMS_VER

#define NVAPI_GET_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PREBUILD_INFO_PARAMS_VER NVAPI_GET_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PREBUILD_INFO_PARAMS_VER1

◆ NVAPI_GET_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PREBUILD_INFO_PARAMS_VER1

#define NVAPI_GET_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PREBUILD_INFO_PARAMS_VER1 MAKE_NVAPI_VERSION(NVAPI_GET_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PREBUILD_INFO_PARAMS_V1, 1)

◆ NVAPI_GET_RAYTRACING_OPACITY_MICROMAP_ARRAY_PREBUILD_INFO_PARAMS_VER

#define NVAPI_GET_RAYTRACING_OPACITY_MICROMAP_ARRAY_PREBUILD_INFO_PARAMS_VER NVAPI_GET_RAYTRACING_OPACITY_MICROMAP_ARRAY_PREBUILD_INFO_PARAMS_VER1

◆ NVAPI_GET_RAYTRACING_OPACITY_MICROMAP_ARRAY_PREBUILD_INFO_PARAMS_VER1

#define NVAPI_GET_RAYTRACING_OPACITY_MICROMAP_ARRAY_PREBUILD_INFO_PARAMS_VER1 MAKE_NVAPI_VERSION(NVAPI_GET_RAYTRACING_OPACITY_MICROMAP_ARRAY_PREBUILD_INFO_PARAMS_V1, 1)

◆ NVAPI_PRESENT_COMPOSITING_CONFIG_FLAG_CLEAR_OUTBANDS

#define NVAPI_PRESENT_COMPOSITING_CONFIG_FLAG_CLEAR_OUTBANDS 0x02

◆ NVAPI_PRESENT_COMPOSITING_CONFIG_FLAG_GET_VIDEO_BRIDGE_STATUS

#define NVAPI_PRESENT_COMPOSITING_CONFIG_FLAG_GET_VIDEO_BRIDGE_STATUS 0x80000000

◆ NVAPI_PRESENT_COMPOSITING_CONFIG_FLAG_USE_VIDEO_BRIDGE

#define NVAPI_PRESENT_COMPOSITING_CONFIG_FLAG_USE_VIDEO_BRIDGE 0x01

PresentCompositingConfig method flags.

◆ NVAPI_RELOCATE_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PARAMS_VER

#define NVAPI_RELOCATE_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PARAMS_VER NVAPI_RELOCATE_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PARAMS_VER1

◆ NVAPI_RELOCATE_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PARAMS_VER1

#define NVAPI_RELOCATE_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PARAMS_VER1 MAKE_NVAPI_VERSION(NVAPI_RELOCATE_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PARAMS_V1, 1)

◆ NVAPI_RELOCATE_RAYTRACING_OPACITY_MICROMAP_ARRAY_PARAMS_VER

#define NVAPI_RELOCATE_RAYTRACING_OPACITY_MICROMAP_ARRAY_PARAMS_VER NVAPI_RELOCATE_RAYTRACING_OPACITY_MICROMAP_ARRAY_PARAMS_VER1

◆ NVAPI_RELOCATE_RAYTRACING_OPACITY_MICROMAP_ARRAY_PARAMS_VER1

#define NVAPI_RELOCATE_RAYTRACING_OPACITY_MICROMAP_ARRAY_PARAMS_VER1 MAKE_NVAPI_VERSION(NVAPI_RELOCATE_RAYTRACING_OPACITY_MICROMAP_ARRAY_PARAMS_V1, 1)

◆ NVAPI_UAV_INFO_VER

#define NVAPI_UAV_INFO_VER NVAPI_UAV_INFO_VER2

◆ NVAPI_UAV_INFO_VER1

#define NVAPI_UAV_INFO_VER1 1

◆ NVAPI_UAV_INFO_VER2

#define NVAPI_UAV_INFO_VER2 MAKE_NVAPI_VERSION(NVAPI_UAV_INFO_V2, 2)

◆ NVAPI_UNICODE_STRING_MAX

#define NVAPI_UNICODE_STRING_MAX 2048

◆ NVAPI_VIDEO_BRIDGE_STATUS_AVAILABLE

#define NVAPI_VIDEO_BRIDGE_STATUS_AVAILABLE 0

◆ NVAPI_VIDEO_BRIDGE_STATUS_FAILED_ACCESS

#define NVAPI_VIDEO_BRIDGE_STATUS_FAILED_ACCESS 2

◆ NVAPI_VIDEO_BRIDGE_STATUS_NOT_AVAILABLE

#define NVAPI_VIDEO_BRIDGE_STATUS_NOT_AVAILABLE 1

◆ NVAPI_VIDEO_BRIDGE_STATUS_UNKNOWN

#define NVAPI_VIDEO_BRIDGE_STATUS_UNKNOWN 3

Typedef Documentation

◆ ID3D11MultiGPUDevice

typedef ID3D11MultiGPUDevice_V1 ID3D11MultiGPUDevice

◆ ID3D11NvMetaCommand

typedef ID3D11NvMetaCommand_V1 ID3D11NvMetaCommand

◆ ID3D11NvShadingRateResourceView

typedef ID3D11NvShadingRateResourceView_V1 ID3D11NvShadingRateResourceView

◆ ID3D12NvMetaCommand

typedef ID3D12NvMetaCommand_V1 ID3D12NvMetaCommand

◆ ID3DNvGazeHandler

typedef ID3DNvGazeHandler_V2 ID3DNvGazeHandler

◆ ID3DNvSMPAssist

typedef ID3DNvSMPAssist_V1 ID3DNvSMPAssist

◆ ID3DNvVRSHelper

typedef ID3DNvVRSHelper_V1 ID3DNvVRSHelper

◆ NV_ASYNC_FRAME_MARKER_PARAMS

typedef NV_ASYNC_FRAME_MARKER_PARAMS_V1 NV_ASYNC_FRAME_MARKER_PARAMS

◆ NV_CUSTOM_RECTS

typedef NV_CUSTOM_RECTS_V1 NV_CUSTOM_RECTS

◆ NV_CUSTOM_RECTS_V1

typedef struct _NV_CUSTOM_RECTS_V1 NV_CUSTOM_RECTS_V1

◆ NV_CUSTOM_SEMANTIC

typedef struct _NV_CUSTOM_SEMANTIC NV_CUSTOM_SEMANTIC

◆ NV_CUSTOM_SEMANTIC_TYPE

typedef enum NV_CUSTOM_SEMANTIC_TYPE NV_CUSTOM_SEMANTIC_TYPE

◆ NV_D3D11_EXCLUSIVE_SCISSOR_RECT_DESC

typedef NV_D3D11_EXCLUSIVE_SCISSOR_RECT_DESC_V1 NV_D3D11_EXCLUSIVE_SCISSOR_RECT_DESC

◆ NV_D3D11_EXCLUSIVE_SCISSOR_RECTS_DESC

typedef NV_D3D11_EXCLUSIVE_SCISSOR_RECTS_DESC_V1 NV_D3D11_EXCLUSIVE_SCISSOR_RECTS_DESC

◆ NV_D3D11_EXCLUSIVE_SCISSOR_RECTS_DESC_V1

typedef struct _NV_D3D11_EXCLUSIVE_SCISSOR_RECTS_DESC_V1 NV_D3D11_EXCLUSIVE_SCISSOR_RECTS_DESC_V1

◆ NV_D3D11_FEATURE

typedef enum _NV_D3D11_FEATURE NV_D3D11_FEATURE

SUPPORTED OS: Windows 8 and higher SUPPORTED OS: Windows 10 and higher

◆ NV_D3D11_FEATURE_DATA_RASTERIZER_SUPPORT

typedef struct _NV_D3D11_FEATURE_DATA_RASTERIZER_SUPPORT NV_D3D11_FEATURE_DATA_RASTERIZER_SUPPORT

◆ NV_D3D11_SHADING_RATE_RESOURCE_VIEW_DESC

typedef NV_D3D11_SHADING_RATE_RESOURCE_VIEW_DESC_V1 NV_D3D11_SHADING_RATE_RESOURCE_VIEW_DESC

◆ NV_D3D11_SHADING_RATE_RESOURCE_VIEW_DESC_V1

typedef struct _NV_D3D11_SHADING_RATE_RESOURCE_VIEW_DESC_V1 NV_D3D11_SHADING_RATE_RESOURCE_VIEW_DESC_V1

◆ NV_D3D11_VIEWPORT_SHADING_RATE_DESC

typedef NV_D3D11_VIEWPORT_SHADING_RATE_DESC_V1 NV_D3D11_VIEWPORT_SHADING_RATE_DESC

◆ NV_D3D11_VIEWPORT_SHADING_RATE_DESC_V1

typedef struct _NV_D3D11_VIEWPORT_SHADING_RATE_DESC_V1 NV_D3D11_VIEWPORT_SHADING_RATE_DESC_V1

◆ NV_D3D11_VIEWPORTS_SHADING_RATE_DESC

typedef NV_D3D11_VIEWPORTS_SHADING_RATE_DESC_V1 NV_D3D11_VIEWPORTS_SHADING_RATE_DESC

◆ NV_D3D11_VIEWPORTS_SHADING_RATE_DESC_V1

typedef struct _NV_D3D11_VIEWPORTS_SHADING_RATE_DESC_V1 NV_D3D11_VIEWPORTS_SHADING_RATE_DESC_V1

◆ NV_D3D12_GRAPHICS_CAPS

typedef NV_D3D12_GRAPHICS_CAPS_V1 NV_D3D12_GRAPHICS_CAPS

◆ NV_D3D12_MOSAIC_GETCOMPANIONALLOCATIONS

typedef NV_D3D12_MOSAIC_GETCOMPANIONALLOCATIONS_V1 NV_D3D12_MOSAIC_GETCOMPANIONALLOCATIONS

◆ NV_D3D12_MOSAIC_GETCOMPANIONALLOCATIONS_V1

typedef struct _NV_D3D12_MOSAIC_GETCOMPANIONALLOCATIONS NV_D3D12_MOSAIC_GETCOMPANIONALLOCATIONS_V1

SUPPORTED OS: Windows 10 and higher

◆ NV_D3D12_MOSAIC_GETVIEWPORTANDGPUPARTITIONS

typedef NV_D3D12_MOSAIC_GETVIEWPORTANDGPUPARTITIONS_V1 NV_D3D12_MOSAIC_GETVIEWPORTANDGPUPARTITIONS

◆ NV_D3D12_MOSAIC_GETVIEWPORTANDGPUPARTITIONS_V1

typedef struct _NV_D3D12_MOSAIC_GETVIEWPORTANDGPUPARTITIONS NV_D3D12_MOSAIC_GETVIEWPORTANDGPUPARTITIONS_V1

SUPPORTED OS: Windows 10 and higher

◆ NV_D3D12_WORKSTATION_FEATURE_RDMA_PROPERTIES

typedef struct _NV_D3D12_WORKSTATION_FEATURE_RDMA_PROPERTIES NV_D3D12_WORKSTATION_FEATURE_RDMA_PROPERTIES

◆ NV_D3D12_WORKSTATION_FEATURE_TYPE

typedef enum _NV_D3D12_WORKSTATION_FEATURE_TYPE NV_D3D12_WORKSTATION_FEATURE_TYPE

◆ NV_D3D1x_GRAPHICS_CAPS

typedef NV_D3D1x_GRAPHICS_CAPS_V2 NV_D3D1x_GRAPHICS_CAPS

◆ NV_D3D1x_GRAPHICS_CAPS_V2

typedef struct _NV_D3D1x_GRAPHICS_CAPS_V2 NV_D3D1x_GRAPHICS_CAPS_V2

◆ NV_D3D_LATELATCH_OBJECT_DESC

typedef NV_D3D_LATELATCH_OBJECT_DESC_V1 NV_D3D_LATELATCH_OBJECT_DESC

◆ NV_D3D_LATELATCH_OBJECT_DESC_V1

typedef struct _NV_D3D_LATELATCH_OBJECT_DESC_V1 NV_D3D_LATELATCH_OBJECT_DESC_V1

◆ NV_DISPLAYCONFIG_PATH_INFO

typedef NV_DISPLAYCONFIG_PATH_INFO_V2 NV_DISPLAYCONFIG_PATH_INFO

◆ NV_DISPLAYCONFIG_SOURCE_MODE_INFO

typedef NV_DISPLAYCONFIG_SOURCE_MODE_INFO_V1 NV_DISPLAYCONFIG_SOURCE_MODE_INFO

◆ NV_FASTGS_FLAGS

typedef enum _NV_FASTGS_FLAGS NV_FASTGS_FLAGS

SUPPORTED OS: Windows 7 and higher

◆ NV_FOVEATED_RENDERING_CUSTOM_FOVEATION_PATTERN_PRESET_DESC

typedef NV_FOVEATED_RENDERING_CUSTOM_FOVEATION_PATTERN_PRESET_DESC_V1 NV_FOVEATED_RENDERING_CUSTOM_FOVEATION_PATTERN_PRESET_DESC

◆ NV_FOVEATED_RENDERING_CUSTOM_FOVEATION_PATTERN_PRESET_DESC_V1

typedef struct _NV_FOVEATED_RENDERING_CUSTOM_FOVEATION_PATTERN_PRESET_DESC_V1 NV_FOVEATED_RENDERING_CUSTOM_FOVEATION_PATTERN_PRESET_DESC_V1

◆ NV_FOVEATED_RENDERING_CUSTOM_SHADING_RATE_PRESET_DESC

typedef NV_FOVEATED_RENDERING_CUSTOM_SHADING_RATE_PRESET_DESC_V1 NV_FOVEATED_RENDERING_CUSTOM_SHADING_RATE_PRESET_DESC

◆ NV_FOVEATED_RENDERING_CUSTOM_SHADING_RATE_PRESET_DESC_V1

typedef struct _NV_FOVEATED_RENDERING_CUSTOM_SHADING_RATE_PRESET_DESC_V1 NV_FOVEATED_RENDERING_CUSTOM_SHADING_RATE_PRESET_DESC_V1

◆ NV_FOVEATED_RENDERING_DESC

typedef NV_FOVEATED_RENDERING_DESC_V1 NV_FOVEATED_RENDERING_DESC

◆ NV_FOVEATED_RENDERING_DESC_V1

typedef struct _NV_FOVEATED_RENDERING_DESC_V1 NV_FOVEATED_RENDERING_DESC_V1

◆ NV_FOVEATED_RENDERING_FOVEATION_PATTERN_PRESET

typedef enum _NV_FOVEATED_RENDERING_FOVEATION_PATTERN_PRESET NV_FOVEATED_RENDERING_FOVEATION_PATTERN_PRESET

◆ NV_FOVEATED_RENDERING_GAZE_DATA_PER_EYE

typedef NV_FOVEATED_RENDERING_GAZE_DATA_PER_EYE_V1 NV_FOVEATED_RENDERING_GAZE_DATA_PER_EYE

◆ NV_FOVEATED_RENDERING_GAZE_DATA_PER_EYE_V1

typedef struct _NV_FOVEATED_RENDERING_GAZE_DATA_PER_EYE NV_FOVEATED_RENDERING_GAZE_DATA_PER_EYE_V1

◆ NV_FOVEATED_RENDERING_SHADING_RATE_PRESET

typedef enum _NV_FOVEATED_RENDERING_SHADING_RATE_PRESET NV_FOVEATED_RENDERING_SHADING_RATE_PRESET

◆ NV_FOVEATED_RENDERING_UPDATE_GAZE_DATA_PARAMS

typedef NV_FOVEATED_RENDERING_UPDATE_GAZE_DATA_PARAMS_V1 NV_FOVEATED_RENDERING_UPDATE_GAZE_DATA_PARAMS

◆ NV_FOVEATED_RENDERING_UPDATE_GAZE_DATA_PARAMS_V1

typedef struct _NV_FOVEATED_RENDERING_UPDATE_GAZE_DATA_PARAMS NV_FOVEATED_RENDERING_UPDATE_GAZE_DATA_PARAMS_V1

◆ NV_GAZE_DATA_TYPE

typedef enum _NV_GAZE_DATA_TYPE NV_GAZE_DATA_TYPE

◆ NV_GAZE_DATA_VALIDITY_FLAGS

typedef enum _NV_GAZE_DATA_VALIDITY_FLAGS NV_GAZE_DATA_VALIDITY_FLAGS

◆ NV_GAZE_HANDLER_INIT_PARAMS

typedef NV_GAZE_HANDLER_INIT_PARAMS_V2 NV_GAZE_HANDLER_INIT_PARAMS

◆ NV_GAZE_HANDLER_INIT_PARAMS_V1

typedef struct _NV_GAZE_HANDLER_INIT_PARAMS_V1 NV_GAZE_HANDLER_INIT_PARAMS_V1

◆ NV_GAZE_HANDLER_INIT_PARAMS_V2

typedef struct _NV_GAZE_HANDLER_INIT_PARAMS_V2 NV_GAZE_HANDLER_INIT_PARAMS_V2

◆ NV_GET_SLEEP_STATUS_PARAMS

typedef NV_GET_SLEEP_STATUS_PARAMS_V1 NV_GET_SLEEP_STATUS_PARAMS

◆ NV_HEAP_PARAMS

typedef NV_HEAP_PARAMS_V1 NV_HEAP_PARAMS

◆ NV_HEAP_PARAMS_V1

typedef struct _NV_HEAP_PARAMS_V1 NV_HEAP_PARAMS_V1

◆ NV_JOIN_PRESENT_BARRIER_PARAMS

typedef struct _NV_JOIN_PRESENT_BARRIER_PARAMS NV_JOIN_PRESENT_BARRIER_PARAMS

SUPPORTED OS: Windows 10 and higher

◆ NV_LATENCY_MARKER_PARAMS

typedef NV_LATENCY_MARKER_PARAMS_V1 NV_LATENCY_MARKER_PARAMS

◆ NV_LATENCY_RESULT_PARAMS

typedef NV_LATENCY_RESULT_PARAMS_V1 NV_LATENCY_RESULT_PARAMS

◆ NV_LMS_CONFIG

typedef enum NV_LMS_CONFIG NV_LMS_CONFIG

◆ NV_LMS_CUSTOM_CONFIG

typedef NV_LMS_CUSTOM_CONFIG_V1 NV_LMS_CUSTOM_CONFIG

◆ NV_LMS_CUSTOM_CONFIG_V1

typedef struct _NV_LMS_CUSTOM_CONFIG_V1 NV_LMS_CUSTOM_CONFIG_V1

◆ NV_LMS_INSTANCED_STEREO_CONFIG

typedef NV_LMS_INSTANCED_STEREO_CONFIG_V1 NV_LMS_INSTANCED_STEREO_CONFIG

◆ NV_LMS_INSTANCED_STEREO_CONFIG_V1

typedef struct _NV_LMS_INSTANCED_STEREO_CONFIG_V1 NV_LMS_INSTANCED_STEREO_CONFIG_V1

◆ NV_META_COMMAND_BOOL

typedef NvU64 NV_META_COMMAND_BOOL

◆ NV_MODIFIED_W_COEFFICIENTS

typedef struct _NV_MODIFIED_W_COEFFICIENTS NV_MODIFIED_W_COEFFICIENTS

◆ NV_MODIFIED_W_PARAMS

typedef NV_MODIFIED_W_PARAMS_V1 NV_MODIFIED_W_PARAMS

◆ NV_MODIFIED_W_PARAMS_V1

typedef struct _NV_MODIFIED_W_PARAMS NV_MODIFIED_W_PARAMS_V1

◆ NV_MRS_CONFIG

typedef enum NV_MRS_CONFIG NV_MRS_CONFIG

◆ NV_MRS_CUSTOM_CONFIG

typedef NV_MRS_CUSTOM_CONFIG_V1 NV_MRS_CUSTOM_CONFIG

◆ NV_MRS_CUSTOM_CONFIG_V1

typedef struct _NV_MRS_CUSTOM_CONFIG_V1 NV_MRS_CUSTOM_CONFIG_V1

◆ NV_MRS_INSTANCED_STEREO_CONFIG

typedef NV_MRS_INSTANCED_STEREO_CONFIG_V1 NV_MRS_INSTANCED_STEREO_CONFIG

◆ NV_MRS_INSTANCED_STEREO_CONFIG_V1

typedef struct _NV_MRS_INSTANCED_STEREO_CONFIG_V1 NV_MRS_INSTANCED_STEREO_CONFIG_V1

◆ NV_MULTIGPU_CAPS

typedef NV_MULTIGPU_CAPS_V2 NV_MULTIGPU_CAPS

◆ NV_MULTIGPU_CAPS_V2

typedef struct _NV_MULTIGPU_CAPS_V2 NV_MULTIGPU_CAPS_V2

SUPPORTED OS: Windows 7 and higher

◆ NV_MULTIVIEW_PARAMS

typedef NV_MULTIVIEW_PARAMS_V1 NV_MULTIVIEW_PARAMS

◆ NV_PIXEL_SHADING_RATE_SAMPLE_ORDER_TABLE

typedef NV_PIXEL_SHADING_RATE_SAMPLE_ORDER_TABLE_V1 NV_PIXEL_SHADING_RATE_SAMPLE_ORDER_TABLE

◆ NV_PIXEL_SHADING_RATE_SAMPLE_ORDER_TABLE_V1

typedef struct _NV_PIXEL_SHADING_RATE_SAMPLE_ORDER_TABLE_V1 NV_PIXEL_SHADING_RATE_SAMPLE_ORDER_TABLE_V1

◆ NV_PIXEL_SRSO_2x1

typedef struct _NV_PIXEL_SRSO_2x1 NV_PIXEL_SRSO_2x1

◆ NV_PIXEL_SRSO_2x2

typedef struct _NV_PIXEL_SRSO_2x2 NV_PIXEL_SRSO_2x2

◆ NV_PIXEL_SRSO_2x4

typedef struct _NV_PIXEL_SRSO_2x4 NV_PIXEL_SRSO_2x4

◆ NV_PIXEL_SRSO_4x2

typedef struct _NV_PIXEL_SRSO_4x2 NV_PIXEL_SRSO_4x2

◆ NV_PIXEL_SRSO_4x4

typedef struct _NV_PIXEL_SRSO_4x4 NV_PIXEL_SRSO_4x4

◆ NV_PRESENT_BARRIER_FRAME_STATISTICS

typedef struct _NV_PRESENT_BARRIER_FRAME_STATISTICS NV_PRESENT_BARRIER_FRAME_STATISTICS

◆ NV_PRESENT_BARRIER_SYNC_MODE

typedef enum _NV_PRESENT_BARRIER_SYNC_MODE NV_PRESENT_BARRIER_SYNC_MODE

◆ NV_QUERY_LATELATCH_SUPPORT_PARAMS

typedef NV_QUERY_LATELATCH_SUPPORT_PARAMS_V1 NV_QUERY_LATELATCH_SUPPORT_PARAMS

◆ NV_QUERY_MODIFIED_W_SUPPORT_PARAMS

typedef NV_QUERY_MODIFIED_W_SUPPORT_PARAMS_V1 NV_QUERY_MODIFIED_W_SUPPORT_PARAMS

◆ NV_QUERY_MULTIVIEW_SUPPORT_PARAMS

typedef NV_QUERY_MULTIVIEW_SUPPORT_PARAMS_V1 NV_QUERY_MULTIVIEW_SUPPORT_PARAMS

◆ NV_QUERY_SINGLE_PASS_STEREO_SUPPORT_PARAMS

typedef NV_QUERY_SINGLE_PASS_STEREO_SUPPORT_PARAMS_V2 NV_QUERY_SINGLE_PASS_STEREO_SUPPORT_PARAMS

◆ NV_QUERY_SINGLE_PASS_STEREO_SUPPORT_PARAMS_V2

typedef struct _NV_QUERY_SINGLE_PASS_STEREO_SUPPORT_PARAMS_V2 NV_QUERY_SINGLE_PASS_STEREO_SUPPORT_PARAMS_V2

◆ NV_QUERY_SMP_ASSIST_SUPPORT_PARAMS

typedef NV_QUERY_SMP_ASSIST_SUPPORT_PARAMS_V1 NV_QUERY_SMP_ASSIST_SUPPORT_PARAMS

◆ NV_RESOURCE_PARAMS

typedef NV_RESOURCE_PARAMS_V1 NV_RESOURCE_PARAMS

◆ NV_RESOURCE_PARAMS_V1

typedef struct _NV_RESOURCE_PARAMS_V1 NV_RESOURCE_PARAMS_V1

◆ NV_SET_REFLEX_SYNC_PARAMS

typedef NV_SET_REFLEX_SYNC_PARAMS_V1 NV_SET_REFLEX_SYNC_PARAMS

◆ NV_SET_SLEEP_MODE_PARAMS

typedef NV_SET_SLEEP_MODE_PARAMS_V1 NV_SET_SLEEP_MODE_PARAMS

◆ NV_SMP_ASSIST_DISABLE_PARAMS

typedef NV_SMP_ASSIST_DISABLE_PARAMS_V1 NV_SMP_ASSIST_DISABLE_PARAMS

◆ NV_SMP_ASSIST_DISABLE_PARAMS_V1

typedef struct _NV_SMP_ASSIST_DISABLE_PARAMS_V1 NV_SMP_ASSIST_DISABLE_PARAMS_V1

◆ NV_SMP_ASSIST_ENABLE_PARAMS

typedef NV_SMP_ASSIST_ENABLE_PARAMS_V1 NV_SMP_ASSIST_ENABLE_PARAMS

◆ NV_SMP_ASSIST_ENABLE_PARAMS_V1

typedef struct _NV_SMP_ASSIST_ENABLE_PARAMS_V1 NV_SMP_ASSIST_ENABLE_PARAMS_V1

◆ NV_SMP_ASSIST_EYE_INDEX

typedef enum _NV_SMP_ASSIST_EYE_INDEX NV_SMP_ASSIST_EYE_INDEX

◆ NV_SMP_ASSIST_FASTGSCBDATA

typedef NV_SMP_ASSIST_FASTGSCBDATA_V1 NV_SMP_ASSIST_FASTGSCBDATA

◆ NV_SMP_ASSIST_FASTGSCBDATA_MRS_INSTANCED_STEREO

typedef NV_SMP_ASSIST_FASTGSCBDATA_MRS_INSTANCED_STEREO_V1 NV_SMP_ASSIST_FASTGSCBDATA_MRS_INSTANCED_STEREO

◆ NV_SMP_ASSIST_FASTGSCBDATA_MRS_INSTANCED_STEREO_V1

typedef struct _NV_SMP_ASSIST_FASTGSCBDATA_MRS_INSTANCED_STEREO_V1 NV_SMP_ASSIST_FASTGSCBDATA_MRS_INSTANCED_STEREO_V1

◆ NV_SMP_ASSIST_FASTGSCBDATA_V1

typedef struct _NV_SMP_ASSIST_FASTGSCBDATA_V1 NV_SMP_ASSIST_FASTGSCBDATA_V1

◆ NV_SMP_ASSIST_GET_CONSTANTS

typedef NV_SMP_ASSIST_GET_CONSTANTS_V3 NV_SMP_ASSIST_GET_CONSTANTS

◆ NV_SMP_ASSIST_GET_CONSTANTS_V3

typedef struct _NV_SMP_ASSIST_GET_CONSTANTS_V3 NV_SMP_ASSIST_GET_CONSTANTS_V3

SUPPORTED OS: Windows 7 and higher

◆ NV_SMP_ASSIST_INITIALIZE_PARAMS

typedef NV_SMP_ASSIST_INITIALIZE_PARAMS_V1 NV_SMP_ASSIST_INITIALIZE_PARAMS

◆ NV_SMP_ASSIST_INITIALIZE_PARAMS_V1

typedef struct _NV_SMP_ASSIST_INITIALIZE_PARAMS_V1 NV_SMP_ASSIST_INITIALIZE_PARAMS_V1

SUPPORTED OS: Windows 7 and higher

◆ NV_SMP_ASSIST_LEVEL

typedef enum NV_SMP_ASSIST_LEVEL NV_SMP_ASSIST_LEVEL

◆ NV_SMP_ASSIST_REMAPCBDATA

typedef NV_SMP_ASSIST_REMAPCBDATA_V1 NV_SMP_ASSIST_REMAPCBDATA

◆ NV_SMP_ASSIST_REMAPCBDATA_V1

typedef struct _NV_SMP_ASSIST_REMAPCBDATA_V1 NV_SMP_ASSIST_REMAPCBDATA_V1

◆ NV_SMP_ASSIST_SETUP_PARAMS

typedef NV_SMP_ASSIST_SETUP_PARAMS_V1 NV_SMP_ASSIST_SETUP_PARAMS

◆ NV_SMP_ASSIST_SETUP_PARAMS_V1

typedef struct _NV_SMP_ASSIST_SETUP_PARAMS_V1 NV_SMP_ASSIST_SETUP_PARAMS_V1

SUPPORTED OS: Windows 7 and higher

◆ NV_SMP_ASSIST_UPDATE_INSTANCEDSTEREO_DATA_PARAMS

typedef NV_SMP_ASSIST_UPDATE_INSTANCEDSTEREO_DATA_PARAMS_V1 NV_SMP_ASSIST_UPDATE_INSTANCEDSTEREO_DATA_PARAMS

◆ NV_SMP_ASSIST_UPDATE_INSTANCEDSTEREO_DATA_PARAMS_V1

typedef struct _NV_SMP_ASSIST_UPDATE_INSTANCEDSTEREO_DATA_PARAMS_V1 NV_SMP_ASSIST_UPDATE_INSTANCEDSTEREO_DATA_PARAMS_V1

◆ NV_SRRV_DIMENSION

typedef enum _NV_SRRV_DIMENSION NV_SRRV_DIMENSION

◆ NV_SWIZZLE_MODE

typedef enum _NV_SWIZZLE_MODE NV_SWIZZLE_MODE

◆ NV_SWIZZLE_OFFSET

typedef enum _NV_SWIZZLE_OFFSET NV_SWIZZLE_OFFSET

◆ NV_TEX2D_ARRAY_SRRV

typedef struct _NV_TEX2D_ARRAY_SRRV NV_TEX2D_ARRAY_SRRV

◆ NV_TEX2D_SRRV

typedef struct _NV_TEX2D_SRRV NV_TEX2D_SRRV

◆ NV_VRS_CONTENT_TYPE

typedef enum _NV_VRS_CONTENT_TYPE NV_VRS_CONTENT_TYPE

◆ NV_VRS_HELPER_DISABLE_PARAMS

typedef NV_VRS_HELPER_DISABLE_PARAMS_V1 NV_VRS_HELPER_DISABLE_PARAMS

◆ NV_VRS_HELPER_DISABLE_PARAMS_V1

typedef struct _NV_VRS_HELPER_DISABLE_PARAMS_V1 NV_VRS_HELPER_DISABLE_PARAMS_V1

◆ NV_VRS_HELPER_ENABLE_PARAMS

typedef NV_VRS_HELPER_ENABLE_PARAMS_V1 NV_VRS_HELPER_ENABLE_PARAMS

◆ NV_VRS_HELPER_ENABLE_PARAMS_V1

typedef struct _NV_VRS_HELPER_ENABLE_PARAMS_V1 NV_VRS_HELPER_ENABLE_PARAMS_V1

◆ NV_VRS_HELPER_GET_SHADING_RATE_RESOURCE_PARAMS

typedef NV_VRS_HELPER_GET_SHADING_RATE_RESOURCE_PARAMS_V1 NV_VRS_HELPER_GET_SHADING_RATE_RESOURCE_PARAMS

◆ NV_VRS_HELPER_GET_SHADING_RATE_RESOURCE_PARAMS_V1

typedef struct _NV_VRS_HELPER_GET_SHADING_RATE_RESOURCE_PARAMS_V1 NV_VRS_HELPER_GET_SHADING_RATE_RESOURCE_PARAMS_V1

◆ NV_VRS_HELPER_INIT_PARAMS

typedef NV_VRS_HELPER_INIT_PARAMS_V1 NV_VRS_HELPER_INIT_PARAMS

◆ NV_VRS_HELPER_INIT_PARAMS_V1

typedef struct _NV_VRS_HELPER_INIT_PARAMS_V1 NV_VRS_HELPER_INIT_PARAMS_V1

◆ NV_VRS_HELPER_LATCH_GAZE_PARAMS

typedef NV_VRS_HELPER_LATCH_GAZE_PARAMS_V1 NV_VRS_HELPER_LATCH_GAZE_PARAMS

◆ NV_VRS_HELPER_LATCH_GAZE_PARAMS_V1

typedef struct _NV_VRS_HELPER_LATCH_GAZE_PARAMS_V1 NV_VRS_HELPER_LATCH_GAZE_PARAMS_V1

SUPPORTED OS: Windows 7 and higher

◆ NV_VRS_HELPER_PURGE_INTERNAL_RESOURCES_PARAMS

typedef NV_VRS_HELPER_PURGE_INTERNAL_RESOURCES_PARAMS_V1 NV_VRS_HELPER_PURGE_INTERNAL_RESOURCES_PARAMS

◆ NV_VRS_HELPER_PURGE_INTERNAL_RESOURCES_PARAMS_V1

typedef struct _NV_VRS_HELPER_PURGE_INTERNAL_RESOURCES_PARAMS_V1 NV_VRS_HELPER_PURGE_INTERNAL_RESOURCES_PARAMS_V1

◆ NV_VRS_RENDER_MODE

typedef enum _NV_VRS_RENDER_MODE NV_VRS_RENDER_MODE

◆ NVAPI_ANSEL_CONFIGURATION_STRUCT

typedef NVAPI_ANSEL_CONFIGURATION_STRUCT_V1 NVAPI_ANSEL_CONFIGURATION_STRUCT

◆ NVAPI_ANSEL_CONFIGURATION_STRUCT_V1

typedef struct NVAPI_ANSEL_CONFIGURATION_STRUCT_V1 NVAPI_ANSEL_CONFIGURATION_STRUCT_V1

◆ NVAPI_ANSEL_FEATURE_CONFIGURATION_STRUCT

typedef struct NVAPI_ANSEL_FEATURE_CONFIGURATION_STRUCT NVAPI_ANSEL_FEATURE_CONFIGURATION_STRUCT

◆ NVAPI_ANSEL_FEATURE_STATE

typedef enum _NVAPI_ANSEL_FEATURE_STATE NVAPI_ANSEL_FEATURE_STATE

◆ NVAPI_ANSEL_HOTKEY_MODIFIER

typedef enum _NVAPI_ANSEL_HOTKEY_MODIFIER NVAPI_ANSEL_HOTKEY_MODIFIER

◆ NVAPI_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_EX_PARAMS

typedef NVAPI_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_EX_PARAMS_V1 NVAPI_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_EX_PARAMS

◆ NVAPI_BUILD_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PARAMS

typedef NVAPI_BUILD_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PARAMS_V1 NVAPI_BUILD_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PARAMS

◆ NVAPI_BUILD_RAYTRACING_OPACITY_MICROMAP_ARRAY_PARAMS

typedef NVAPI_BUILD_RAYTRACING_OPACITY_MICROMAP_ARRAY_PARAMS_V1 NVAPI_BUILD_RAYTRACING_OPACITY_MICROMAP_ARRAY_PARAMS

◆ NVAPI_CHECK_DRIVER_MATCHING_IDENTIFIER_EX_PARAMS

typedef NVAPI_CHECK_DRIVER_MATCHING_IDENTIFIER_EX_PARAMS_V1 NVAPI_CHECK_DRIVER_MATCHING_IDENTIFIER_EX_PARAMS

◆ NVAPI_CU_KERNEL_LAUNCH_PARAMS

typedef struct _NVAPI_CU_KERNEL_LAUNCH_PARAMS NVAPI_CU_KERNEL_LAUNCH_PARAMS

◆ NVAPI_CU_KERNEL_LAUNCH_PARAMS_EX

typedef struct _NVAPI_CU_KERNEL_LAUNCH_PARAMS_EX NVAPI_CU_KERNEL_LAUNCH_PARAMS_EX

SUPPORTED OS: Windows 10 and higher

◆ NvAPI_D3D11_CREATE_DOMAIN_SHADER_EX

typedef NvAPI_D3D11_CREATE_DOMAIN_SHADER_EX_V3 NvAPI_D3D11_CREATE_DOMAIN_SHADER_EX

◆ NvAPI_D3D11_CREATE_DOMAIN_SHADER_EX_V1

typedef struct NvAPI_D3D11_CREATE_DOMAIN_SHADER_EX_V1 NvAPI_D3D11_CREATE_DOMAIN_SHADER_EX_V1

SUPPORTED OS: Windows 7 and higher

◆ NvAPI_D3D11_CREATE_DOMAIN_SHADER_EX_V2

typedef struct NvAPI_D3D11_CREATE_DOMAIN_SHADER_EX_V2 NvAPI_D3D11_CREATE_DOMAIN_SHADER_EX_V2

◆ NvAPI_D3D11_CREATE_DOMAIN_SHADER_EX_V3

typedef struct NvAPI_D3D11_CREATE_DOMAIN_SHADER_EX_V3 NvAPI_D3D11_CREATE_DOMAIN_SHADER_EX_V3

◆ NvAPI_D3D11_CREATE_FASTGS_EXPLICIT_DESC

typedef NvAPI_D3D11_CREATE_FASTGS_EXPLICIT_DESC_V1 NvAPI_D3D11_CREATE_FASTGS_EXPLICIT_DESC

◆ NvAPI_D3D11_CREATE_GEOMETRY_SHADER_EX

typedef NvAPI_D3D11_CREATE_GEOMETRY_SHADER_EX_V5 NvAPI_D3D11_CREATE_GEOMETRY_SHADER_EX

◆ NvAPI_D3D11_CREATE_GEOMETRY_SHADER_EX_V5

typedef struct NvAPI_D3D11_CREATE_GEOMETRY_SHADER_EX_V5 NvAPI_D3D11_CREATE_GEOMETRY_SHADER_EX_V5

◆ NvAPI_D3D11_CREATE_HULL_SHADER_EX

typedef NvAPI_D3D11_CREATE_HULL_SHADER_EX_V2 NvAPI_D3D11_CREATE_HULL_SHADER_EX

◆ NvAPI_D3D11_CREATE_HULL_SHADER_EX_V1

typedef struct NvAPI_D3D11_CREATE_HULL_SHADER_EX_V1 NvAPI_D3D11_CREATE_HULL_SHADER_EX_V1

SUPPORTED OS: Windows 7 and higher

◆ NvAPI_D3D11_CREATE_HULL_SHADER_EX_V2

typedef struct NvAPI_D3D11_CREATE_HULL_SHADER_EX_V2 NvAPI_D3D11_CREATE_HULL_SHADER_EX_V2

◆ NvAPI_D3D11_CREATE_PIXEL_SHADER_EX

typedef NvAPI_D3D11_CREATE_PIXEL_SHADER_EX_V2 NvAPI_D3D11_CREATE_PIXEL_SHADER_EX

◆ NvAPI_D3D11_CREATE_PIXEL_SHADER_EX_V1

typedef struct NvAPI_D3D11_CREATE_PIXEL_SHADER_EX_V1 NvAPI_D3D11_CREATE_PIXEL_SHADER_EX_V1

SUPPORTED OS: Windows 7 and higher

◆ NvAPI_D3D11_CREATE_PIXEL_SHADER_EX_V2

typedef struct NvAPI_D3D11_CREATE_PIXEL_SHADER_EX_V2 NvAPI_D3D11_CREATE_PIXEL_SHADER_EX_V2

◆ NvAPI_D3D11_CREATE_VERTEX_SHADER_EX

typedef NvAPI_D3D11_CREATE_VERTEX_SHADER_EX_V3 NvAPI_D3D11_CREATE_VERTEX_SHADER_EX

◆ NvAPI_D3D11_CREATE_VERTEX_SHADER_EX_V1

typedef struct NvAPI_D3D11_CREATE_VERTEX_SHADER_EX_V1 NvAPI_D3D11_CREATE_VERTEX_SHADER_EX_V1

SUPPORTED OS: Windows 7 and higher

◆ NvAPI_D3D11_CREATE_VERTEX_SHADER_EX_V2

typedef struct NvAPI_D3D11_CREATE_VERTEX_SHADER_EX_V2 NvAPI_D3D11_CREATE_VERTEX_SHADER_EX_V2

◆ NvAPI_D3D11_CREATE_VERTEX_SHADER_EX_V3

typedef struct NvAPI_D3D11_CREATE_VERTEX_SHADER_EX_V3 NvAPI_D3D11_CREATE_VERTEX_SHADER_EX_V3

◆ NvAPI_D3D11_RASTERIZER_DESC_EX

typedef struct NvAPI_D3D11_RASTERIZER_DESC_EX NvAPI_D3D11_RASTERIZER_DESC_EX

SUPPORTED OS: Windows 7 and higher

◆ NvAPI_D3D11_SWIZZLE_MODE

typedef UINT NvAPI_D3D11_SWIZZLE_MODE

◆ NVAPI_D3D12_CREATE_CUBIN_SHADER_PARAMS

typedef struct NVAPI_D3D12_CREATE_CUBIN_SHADER_PARAMS NVAPI_D3D12_CREATE_CUBIN_SHADER_PARAMS

SUPPORTED OS: Windows 10 and higher

◆ NVAPI_D3D12_GET_CUDA_INDEPENDENT_DESCRIPTOR_OBJECT_PARAMS

typedef struct NVAPI_D3D12_GET_CUDA_INDEPENDENT_DESCRIPTOR_OBJECT_PARAMS NVAPI_D3D12_GET_CUDA_INDEPENDENT_DESCRIPTOR_OBJECT_PARAMS

◆ NVAPI_D3D12_GET_CUDA_INDEPENDENT_DESCRIPTOR_OBJECT_TYPE

typedef enum _NVAPI_D3D12_GET_CUDA_INDEPENDENT_DESCRIPTOR_OBJECT_TYPE NVAPI_D3D12_GET_CUDA_INDEPENDENT_DESCRIPTOR_OBJECT_TYPE

SUPPORTED OS: Windows 10 and higher

◆ NVAPI_D3D12_GET_CUDA_MERGED_TEXTURE_SAMPLER_OBJECT_PARAMS

typedef struct NVAPI_D3D12_GET_CUDA_MERGED_TEXTURE_SAMPLER_OBJECT_PARAMS NVAPI_D3D12_GET_CUDA_MERGED_TEXTURE_SAMPLER_OBJECT_PARAMS

SUPPORTED OS: Windows 10 and higher

◆ NVAPI_D3D12_PSO_CREATE_FASTGS_EXPLICIT_DESC

typedef NVAPI_D3D12_PSO_CREATE_FASTGS_EXPLICIT_DESC_V1 NVAPI_D3D12_PSO_CREATE_FASTGS_EXPLICIT_DESC

◆ NVAPI_D3D12_PSO_DOMAIN_SHADER_DESC

typedef NVAPI_D3D12_PSO_DOMAIN_SHADER_DESC_V3 NVAPI_D3D12_PSO_DOMAIN_SHADER_DESC

◆ NVAPI_D3D12_PSO_ENABLE_DEPTH_BOUND_TEST_DESC

typedef NVAPI_D3D12_PSO_ENABLE_DEPTH_BOUND_TEST_DESC_V1 NVAPI_D3D12_PSO_ENABLE_DEPTH_BOUND_TEST_DESC

◆ NVAPI_D3D12_PSO_EXTENSION_DESC

typedef NVAPI_D3D12_PSO_EXTENSION_DESC_V1 NVAPI_D3D12_PSO_EXTENSION_DESC

◆ NVAPI_D3D12_PSO_GEOMETRY_SHADER_DESC

typedef NVAPI_D3D12_PSO_GEOMETRY_SHADER_DESC_V5 NVAPI_D3D12_PSO_GEOMETRY_SHADER_DESC

◆ NVAPI_D3D12_PSO_HULL_SHADER_DESC

typedef NVAPI_D3D12_PSO_HULL_SHADER_DESC_V2 NVAPI_D3D12_PSO_HULL_SHADER_DESC

◆ NVAPI_D3D12_PSO_RASTERIZER_STATE_DESC

typedef NVAPI_D3D12_PSO_RASTERIZER_STATE_DESC_V1 NVAPI_D3D12_PSO_RASTERIZER_STATE_DESC

◆ NVAPI_D3D12_PSO_REQUEST_FAST_GEOMETRY_SHADER_DESC

typedef NVAPI_D3D12_PSO_REQUEST_FAST_GEOMETRY_SHADER_DESC_V1 NVAPI_D3D12_PSO_REQUEST_FAST_GEOMETRY_SHADER_DESC

◆ NVAPI_D3D12_PSO_SET_SHADER_EXTENSION_SLOT_DESC

typedef NVAPI_D3D12_PSO_SET_SHADER_EXTENSION_SLOT_DESC_V1 NVAPI_D3D12_PSO_SET_SHADER_EXTENSION_SLOT_DESC

◆ NVAPI_D3D12_PSO_VERTEX_SHADER_DESC

typedef NVAPI_D3D12_PSO_VERTEX_SHADER_DESC_V3 NVAPI_D3D12_PSO_VERTEX_SHADER_DESC

◆ NVAPI_D3D12_SET_CREATE_PIPELINE_STATE_OPTIONS_PARAMS

typedef NVAPI_D3D12_SET_CREATE_PIPELINE_STATE_OPTIONS_PARAMS_V1 NVAPI_D3D12_SET_CREATE_PIPELINE_STATE_OPTIONS_PARAMS

◆ NVAPI_D3D12_WORKSTATION_FEATURE_PROPERTIES_PARAMS_V1

typedef struct _NV_D3D12_WORKSTATION_FEATURE_PROPERTIES NVAPI_D3D12_WORKSTATION_FEATURE_PROPERTIES_PARAMS_V1

◆ NVAPI_DIM3

typedef struct _NVAPI_DIM3 NVAPI_DIM3

SUPPORTED OS: Windows 10 and higher

◆ NVAPI_EMIT_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_POSTBUILD_INFO_PARAMS

typedef NVAPI_EMIT_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_POSTBUILD_INFO_PARAMS_V1 NVAPI_EMIT_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_POSTBUILD_INFO_PARAMS

◆ NVAPI_EMIT_RAYTRACING_OPACITY_MICROMAP_ARRAY_POSTBUILD_INFO_PARAMS

typedef NVAPI_EMIT_RAYTRACING_OPACITY_MICROMAP_ARRAY_POSTBUILD_INFO_PARAMS_V1 NVAPI_EMIT_RAYTRACING_OPACITY_MICROMAP_ARRAY_POSTBUILD_INFO_PARAMS

◆ NVAPI_GET_RAYTRACING_ACCELERATION_STRUCTURE_PREBUILD_INFO_EX_PARAMS

typedef NVAPI_GET_RAYTRACING_ACCELERATION_STRUCTURE_PREBUILD_INFO_EX_PARAMS_V1 NVAPI_GET_RAYTRACING_ACCELERATION_STRUCTURE_PREBUILD_INFO_EX_PARAMS

◆ NVAPI_GET_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PREBUILD_INFO_PARAMS

typedef NVAPI_GET_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PREBUILD_INFO_PARAMS_V1 NVAPI_GET_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PREBUILD_INFO_PARAMS

◆ NVAPI_GET_RAYTRACING_OPACITY_MICROMAP_ARRAY_PREBUILD_INFO_PARAMS

typedef NVAPI_GET_RAYTRACING_OPACITY_MICROMAP_ARRAY_PREBUILD_INFO_PARAMS_V1 NVAPI_GET_RAYTRACING_OPACITY_MICROMAP_ARRAY_PREBUILD_INFO_PARAMS

◆ NvAPI_LPCWSTR

typedef const NvU16* NvAPI_LPCWSTR

◆ NVAPI_RELOCATE_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PARAMS

typedef NVAPI_RELOCATE_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PARAMS_V1 NVAPI_RELOCATE_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PARAMS

◆ NVAPI_RELOCATE_RAYTRACING_OPACITY_MICROMAP_ARRAY_PARAMS

typedef NVAPI_RELOCATE_RAYTRACING_OPACITY_MICROMAP_ARRAY_PARAMS_V1 NVAPI_RELOCATE_RAYTRACING_OPACITY_MICROMAP_ARRAY_PARAMS

◆ NVAPI_UAV_INFO

typedef NVAPI_UAV_INFO_V2 NVAPI_UAV_INFO

◆ NvAPI_UnicodeString

typedef NvU16 NvAPI_UnicodeString[NVAPI_UNICODE_STRING_MAX]

◆ PNV_MULTIGPU_CAPS

typedef PNV_MULTIGPU_CAPS_V2 PNV_MULTIGPU_CAPS

◆ PNV_MULTIGPU_CAPS_V2

typedef struct _NV_MULTIGPU_CAPS_V2 * PNV_MULTIGPU_CAPS_V2

Enumeration Type Documentation

◆ _NV_D3D11_FEATURE

enum _NV_D3D11_FEATURE

SUPPORTED OS: Windows 8 and higher SUPPORTED OS: Windows 10 and higher

Enumerator
NV_D3D11_FEATURE_RASTERIZER

◆ _NV_D3D12_WORKSTATION_FEATURE_TYPE

enum _NV_D3D12_WORKSTATION_FEATURE_TYPE
Enumerator
NV_D3D12_WORKSTATION_FEATURE_TYPE_PRESENT_BARRIER
NV_D3D12_WORKSTATION_FEATURE_TYPE_RDMA_BAR1_SUPPORT

◆ _NV_FASTGS_FLAGS

enum _NV_FASTGS_FLAGS

SUPPORTED OS: Windows 7 and higher

Enumerator
NV_FASTGS_USE_VIEWPORT_MASK
NV_FASTGS_OFFSET_RT_INDEX_BY_VP_INDEX
NV_FASTGS_STRICT_API_ORDER

◆ _NV_FOVEATED_RENDERING_FOVEATION_PATTERN_PRESET

enum _NV_FOVEATED_RENDERING_FOVEATION_PATTERN_PRESET
Enumerator
NV_FOVEATED_RENDERING_FOVEATION_PATTERN_PRESET_INVALID
NV_FOVEATED_RENDERING_FOVEATION_PATTERN_PRESET_WIDE
NV_FOVEATED_RENDERING_FOVEATION_PATTERN_PRESET_BALANCED
NV_FOVEATED_RENDERING_FOVEATION_PATTERN_PRESET_NARROW
NV_FOVEATED_RENDERING_FOVEATION_PATTERN_PRESET_CUSTOM
NV_FOVEATED_RENDERING_FOVEATION_PATTERN_PRESET_MAX

◆ _NV_FOVEATED_RENDERING_SHADING_RATE_PRESET

enum _NV_FOVEATED_RENDERING_SHADING_RATE_PRESET
Enumerator
NV_FOVEATED_RENDERING_SHADING_RATE_PRESET_INVALID
NV_FOVEATED_RENDERING_SHADING_RATE_PRESET_HIGHEST_PERFORMANCE
NV_FOVEATED_RENDERING_SHADING_RATE_PRESET_HIGH_PERFORMANCE
NV_FOVEATED_RENDERING_SHADING_RATE_PRESET_BALANCED
NV_FOVEATED_RENDERING_SHADING_RATE_PRESET_HIGH_QUALITY
NV_FOVEATED_RENDERING_SHADING_RATE_PRESET_HIGHEST_QUALITY
NV_FOVEATED_RENDERING_SHADING_RATE_PRESET_CUSTOM
NV_FOVEATED_RENDERING_SHADING_RATE_PRESET_MAX

◆ _NV_GAZE_DATA_TYPE

enum _NV_GAZE_DATA_TYPE
Enumerator
NV_GAZE_DATA_INVALID
NV_GAZE_DATA_MONO
NV_GAZE_DATA_STEREO
NV_GAZE_DATA_MAX

◆ _NV_GAZE_DATA_VALIDITY_FLAGS

enum _NV_GAZE_DATA_VALIDITY_FLAGS
Enumerator
NV_GAZE_ORIGIN_VALID
NV_GAZE_DIRECTION_VALID
NV_GAZE_LOCATION_VALID
NV_GAZE_VELOCITY_VALID
NV_GAZE_PUPIL_DIAMETER_VALID
NV_GAZE_EYE_OPENNESS_VALID
NV_GAZE_EYE_SACCADE_DATA_VALID

◆ _NV_PRESENT_BARRIER_SYNC_MODE

enum _NV_PRESENT_BARRIER_SYNC_MODE
Enumerator
PRESENT_BARRIER_NOT_JOINED | The client hasn't joined presentBarrier.
PRESENT_BARRIER_SYNC_CLIENT | The client joined the presentBarrier, but is not synchronized with any other presentBarrier clients. This happens if the back buffers of this client are composited instead of being flipped out to screen
PRESENT_BARRIER_SYNC_SYSTEM | The client joined the presentBarrier, and is synchronized with other presentBarrier clients within the system
PRESENT_BARRIER_SYNC_CLUSTER | The client joined the presentBarrier, and is synchronized with other clients within the system and across systems through QSync devices

◆ _NV_SMP_ASSIST_EYE_INDEX

enum _NV_SMP_ASSIST_EYE_INDEX
Enumerator
NV_SMP_ASSIST_EYE_INDEX_MONO
NV_SMP_ASSIST_EYE_INDEX_LEFT_EYE
NV_SMP_ASSIST_EYE_INDEX_RIGHT_EYE
NV_SMP_ASSIST_EYE_INDEX_INSTANCED_STEREO

◆ _NV_SRRV_DIMENSION

enum _NV_SRRV_DIMENSION
Enumerator
NV_SRRV_DIMENSION_TEXTURE2D
NV_SRRV_DIMENSION_TEXTURE2DARRAY

◆ _NV_SWIZZLE_MODE

enum _NV_SWIZZLE_MODE
Enumerator
NV_SWIZZLE_POS_X
NV_SWIZZLE_NEG_X
NV_SWIZZLE_POS_Y
NV_SWIZZLE_NEG_Y
NV_SWIZZLE_POS_Z
NV_SWIZZLE_NEG_Z
NV_SWIZZLE_POS_W
NV_SWIZZLE_NEG_W

◆ _NV_SWIZZLE_OFFSET

enum _NV_SWIZZLE_OFFSET
Enumerator
NV_SWIZZLE_OFFSET_X
NV_SWIZZLE_OFFSET_Y
NV_SWIZZLE_OFFSET_Z
NV_SWIZZLE_OFFSET_W

◆ _NV_VRS_CONTENT_TYPE

enum _NV_VRS_CONTENT_TYPE
Enumerator
NV_VRS_CONTENT_TYPE_INVALID
NV_VRS_CONTENT_TYPE_FOVEATED_RENDERING
NV_VRS_CONTENT_TYPE_MAX

◆ _NV_VRS_RENDER_MODE

enum _NV_VRS_RENDER_MODE
Enumerator
NV_VRS_RENDER_MODE_INVALID
NV_VRS_RENDER_MODE_MONO
NV_VRS_RENDER_MODE_LEFT_EYE
NV_VRS_RENDER_MODE_RIGHT_EYE
NV_VRS_RENDER_MODE_STEREO
NV_VRS_RENDER_MODE_MAX

◆ _NVAPI_ANSEL_FEATURE_STATE

enum _NVAPI_ANSEL_FEATURE_STATE
Enumerator
NVAPI_ANSEL_FEATURE_STATE_UNKNOWN |
NVAPI_ANSEL_FEATURE_STATE_ENABLE | Toggle feature on.
NVAPI_ANSEL_FEATURE_STATE_DISABLE | Toggle feature off.

◆ _NVAPI_ANSEL_HOTKEY_MODIFIER

enum _NVAPI_ANSEL_HOTKEY_MODIFIER
Enumerator
NVAPI_ANSEL_HOTKEY_MODIFIER_UNKNOWN |
NVAPI_ANSEL_HOTKEY_MODIFIER_CTRL | Use control in the hotkey combination.
NVAPI_ANSEL_HOTKEY_MODIFIER_SHIFT | Use shift in the hotkey combination.
NVAPI_ANSEL_HOTKEY_MODIFIER_ALT | Use alternate in the hotkey combination.

◆ _NVAPI_D3D12_GET_CUDA_INDEPENDENT_DESCRIPTOR_OBJECT_TYPE

enum _NVAPI_D3D12_GET_CUDA_INDEPENDENT_DESCRIPTOR_OBJECT_TYPE

SUPPORTED OS: Windows 10 and higher

Enumerator
NVAPI_D3D12_GET_CUDA_INDEPENDENT_DESCRIPTOR_OBJECT_SURFACE
NVAPI_D3D12_GET_CUDA_INDEPENDENT_DESCRIPTOR_OBJECT_TEXTURE
NVAPI_D3D12_GET_CUDA_INDEPENDENT_DESCRIPTOR_OBJECT_SAMPLER

◆ NV_CUSTOM_SEMANTIC_TYPE

enum NV_CUSTOM_SEMANTIC_TYPE
Enumerator
NV_NONE_SEMANTIC
NV_X_RIGHT_SEMANTIC
NV_VIEWPORT_MASK_SEMANTIC
NV_XYZW_RIGHT_SEMANTIC
NV_VIEWPORT_MASK_2_SEMANTIC
NV_POSITION_SEMANTIC
NV_CLIP_DISTANCE_0_SEMANTIC
NV_CLIP_DISTANCE_1_SEMANTIC
NV_CULL_DISTANCE_0_SEMANTIC
NV_CULL_DISTANCE_1_SEMANTIC
NV_GENERIC_ATTRIBUTE_SEMANTIC
NV_PACKED_EYE_INDEX_SEMANTIC
NV_CUSTOM_SEMANTIC_MAX

◆ NV_D3D_GRAPHICS_STATES

enum NV_D3D_GRAPHICS_STATES
Since
Release: 400
Enumerator
NV_D3D_GRAPHICS_STATE_NONE
NV_D3D_GRAPHICS_STATE_IA_VERTEX_BUFFERS
NV_D3D_GRAPHICS_STATE_IA_INDEX_BUFFER
NV_D3D_GRAPHICS_STATE_IA_PRIMITIVE_TOPOLOGY
NV_D3D_GRAPHICS_STATE_DESCRIPTOR_HEAP
NV_D3D_GRAPHICS_STATE_GRAPHICS_ROOT_SIGNATURE
NV_D3D_GRAPHICS_STATE_COMPUTE_ROOT_SIGNATURE
NV_D3D_GRAPHICS_STATE_RS_VIEWPORTS
NV_D3D_GRAPHICS_STATE_RS_SCISSOR_RECTS
NV_D3D_GRAPHICS_STATE_PREDICATION
NV_D3D_GRAPHICS_STATE_OM_RENDER_TARGETS
NV_D3D_GRAPHICS_STATE_OM_STENCIL_REF
NV_D3D_GRAPHICS_STATE_OM_BLEND_FACTOR
NV_D3D_GRAPHICS_STATE_PIPELINE_STATE
NV_D3D_GRAPHICS_STATE_SO_TARGETS
NV_D3D_GRAPHICS_STATE_OM_DEPTH_BOUNDS
NV_D3D_GRAPHICS_STATE_SAMPLE_POSITIONS
NV_D3D_GRAPHICS_STATE_VIEW_INSTANCE_MASK

◆ NV_EDID_FLAG

enum NV_EDID_FLAG
Enumerator
NV_EDID_FLAG_DEFAULT | the EDID which is actively used by the driver, it could be _RAW/_COOKED/_FORCED/_INF.
NV_EDID_FLAG_RAW | the EDID which is not modified by the driver. If there's no _FORCED edid engaged, it will be the unmodified monitor EDID from the I2C bus. Otherwise it is original _FORCED edid.
NV_EDID_FLAG_COOKED | the EDID has been modified by the driver for compatibility
NV_EDID_FLAG_FORCED | the EDID is forced by the end-user over s/w interface,
NV_EDID_FLAG_INF | the EDID is from monitor INF
NV_EDID_FLAG_HW | the EDID is from the monitor over I2C bus without any modification.

◆ NV_LMS_CONFIG

enum NV_LMS_CONFIG
Enumerator
NV_LMS_CONFIG_OCULUSRIFT_CV1_CONSERVATIVE
NV_LMS_CONFIG_OCULUSRIFT_CV1_BALANCED
NV_LMS_CONFIG_OCULUSRIFT_CV1_AGGRESSIVE
NV_LMS_CONFIG_HTC_VIVE_CONSERVATIVE
NV_LMS_CONFIG_HTC_VIVE_BALANCED
NV_LMS_CONFIG_HTC_VIVE_AGGRESSIVE
NV_LMS_NUM_CONFIGS

◆ NV_META_COMMAND_ACTIVATION_FUNCTION

enum NV_META_COMMAND_ACTIVATION_FUNCTION
Enumerator
NV_META_COMMAND_ACTIVATION_FUNCTION_ELU
NV_META_COMMAND_ACTIVATION_FUNCTION_HARDMAX
NV_META_COMMAND_ACTIVATION_FUNCTION_HARD_SIGMOID
NV_META_COMMAND_ACTIVATION_FUNCTION_IDENTITY
NV_META_COMMAND_ACTIVATION_FUNCTION_LEAKY_RELU
NV_META_COMMAND_ACTIVATION_FUNCTION_LINEAR
NV_META_COMMAND_ACTIVATION_FUNCTION_LOG_SOFTMAX
NV_META_COMMAND_ACTIVATION_FUNCTION_PARAMETERIZED_RELU
NV_META_COMMAND_ACTIVATION_FUNCTION_PARAMETRIC_SOFTPLUS
NV_META_COMMAND_ACTIVATION_FUNCTION_RELU
NV_META_COMMAND_ACTIVATION_FUNCTION_SCALED_ELU
NV_META_COMMAND_ACTIVATION_FUNCTION_SCALED_TANH
NV_META_COMMAND_ACTIVATION_FUNCTION_SIGMOID
NV_META_COMMAND_ACTIVATION_FUNCTION_SOFTMAX
NV_META_COMMAND_ACTIVATION_FUNCTION_SOFTPLUS
NV_META_COMMAND_ACTIVATION_FUNCTION_SOFTSIGN
NV_META_COMMAND_ACTIVATION_FUNCTION_TANH
NV_META_COMMAND_ACTIVATION_FUNCTION_THRESHOLDED_RELU
NV_META_COMMAND_ACTIVATION_FUNCTION_COUNT

◆ NV_META_COMMAND_CONVOLUTION_DIRECTION

enum NV_META_COMMAND_CONVOLUTION_DIRECTION
Enumerator
NV_META_COMMAND_CONVOLUTION_DIRECTION_FORWARD
NV_META_COMMAND_CONVOLUTION_DIRECTION_BACKWARD
NV_META_COMMAND_CONVOLUTION_DIRECTION_COUNT

◆ NV_META_COMMAND_CONVOLUTION_MODE

enum NV_META_COMMAND_CONVOLUTION_MODE
Enumerator
NV_META_COMMAND_CONVOLUTION_MODE_CONVOLUTION
NV_META_COMMAND_CONVOLUTION_MODE_CROSS_CORRELATION
NV_META_COMMAND_CONVOLUTION_MODE_COUNT

◆ NV_META_COMMAND_CONVOLUTION_POOL_MODE

enum NV_META_COMMAND_CONVOLUTION_POOL_MODE
Enumerator
NV_META_COMMAND_CONVOLUTION_POOL_MODE_NONE
NV_META_COMMAND_CONVOLUTION_POOL_MODE_REDUCTION_MAX
NV_META_COMMAND_CONVOLUTION_POOL_MODE_REDUCTION_AVG
NV_META_COMMAND_CONVOLUTION_POOL_MODE_REDUCTION_MIN
NV_META_COMMAND_CONVOLUTION_POOL_MODE_COUNT

◆ NV_META_COMMAND_CONVOLUTION_SKIP_MODE

enum NV_META_COMMAND_CONVOLUTION_SKIP_MODE
Enumerator
NV_META_COMMAND_CONVOLUTION_SKIP_MODE_NONE
NV_META_COMMAND_CONVOLUTION_SKIP_MODE_ADD
NV_META_COMMAND_CONVOLUTION_SKIP_MODE_CONCAT
NV_META_COMMAND_CONVOLUTION_SKIP_MODE_COUNT

◆ NV_META_COMMAND_CONVOLUTION_UPSAMPLE_MODE

enum NV_META_COMMAND_CONVOLUTION_UPSAMPLE_MODE
Enumerator
NV_META_COMMAND_CONVOLUTION_UPSAMPLE_MODE_NONE
NV_META_COMMAND_CONVOLUTION_UPSAMPLE_MODE_REPLICATE
NV_META_COMMAND_CONVOLUTION_UPSAMPLE_MODE_BILINEAR
NV_META_COMMAND_CONVOLUTION_UPSAMPLE_MODE_COUNT

◆ NV_META_COMMAND_MATRIX_TRANSFORM

enum NV_META_COMMAND_MATRIX_TRANSFORM
Enumerator
NV_META_COMMAND_MATRIX_TRANSFORM_NONE
NV_META_COMMAND_MATRIX_TRANSFORM_TRANSPOSE
NV_META_COMMAND_MATRIX_TRANSFORM_COUNT

◆ NV_META_COMMAND_PADDING_MODE

enum NV_META_COMMAND_PADDING_MODE
Enumerator
NV_META_COMMAND_PADDING_ZEROS
NV_META_COMMAND_PADDING_MIRROR
NV_META_COMMAND_PADDING_CLAMP
NV_META_COMMAND_PADDING_CONSTANT
NV_META_COMMAND_PADDING_COUNT

◆ NV_META_COMMAND_PRECISION

enum NV_META_COMMAND_PRECISION
Enumerator
NV_META_COMMAND_PRECISION_FLOAT32
NV_META_COMMAND_PRECISION_FLOAT16
NV_META_COMMAND_PRECISION_MUL_FLOAT16_ADD_FLOAT32
NV_META_COMMAND_PRECISION_COUNT

◆ NV_META_COMMAND_RESOURCE_TYPE

enum NV_META_COMMAND_RESOURCE_TYPE
Enumerator
NV_META_COMMAND_RESOURCE_TYPE_INPUT
NV_META_COMMAND_RESOURCE_TYPE_OUTPUT
NV_META_COMMAND_RESOURCE_TYPE_FILTER
NV_META_COMMAND_RESOURCE_TYPE_WEIGHT
NV_META_COMMAND_RESOURCE_TYPE_BIAS
NV_META_COMMAND_RESOURCE_TYPE_MATRIX_A
NV_META_COMMAND_RESOURCE_TYPE_MATRIX_B
NV_META_COMMAND_RESOURCE_TYPE_MATRIX_C
NV_META_COMMAND_RESOURCE_TYPE_PERSISTENT
NV_META_COMMAND_RESOURCE_TYPE_TEMPORARY

◆ NV_META_COMMAND_TENSOR_DATA_TYPE

enum NV_META_COMMAND_TENSOR_DATA_TYPE
Enumerator
NV_META_COMMAND_TENSOR_DATA_TYPE_FLOAT32
NV_META_COMMAND_TENSOR_DATA_TYPE_FLOAT16
NV_META_COMMAND_TENSOR_DATA_TYPE_UINT32
NV_META_COMMAND_TENSOR_DATA_TYPE_COUNT

◆ NV_META_COMMAND_TENSOR_FLAGS

enum NV_META_COMMAND_TENSOR_FLAGS
Enumerator
NV_META_COMMAND_TENSOR_FLAG_NONE
NV_META_COMMAND_TENSOR_FLAG_DATA_STATIC

◆ NV_META_COMMAND_TENSOR_LAYOUT

enum NV_META_COMMAND_TENSOR_LAYOUT
Enumerator
NV_META_COMMAND_TENSOR_LAYOUT_UNKNOWN
NV_META_COMMAND_TENSOR_LAYOUT_STANDARD
NV_META_COMMAND_TENSOR_LAYOUT_COUNT

◆ NV_MRS_CONFIG

enum NV_MRS_CONFIG
Enumerator
NV_MRS_CONFIG_BALANCED
NV_MRS_CONFIG_AGGRESSIVE
NV_MRS_CONFIG_OCULUSRIFT_CV1_CONSERVATIVE
NV_MRS_CONFIG_OCULUSRIFT_CV1_BALANCED
NV_MRS_CONFIG_OCULUSRIFT_CV1_AGGRESSIVE
NV_MRS_CONFIG_HTC_VIVE_CONSERVATIVE
NV_MRS_CONFIG_HTC_VIVE_BALANCED
NV_MRS_CONFIG_HTC_VIVE_AGGRESSIVE
NV_MRS_NUM_CONFIGS

◆ NV_PIXEL_SHADING_RATE

enum NV_PIXEL_SHADING_RATE
Enumerator
NV_PIXEL_X0_CULL_RASTER_PIXELS
NV_PIXEL_X16_PER_RASTER_PIXEL
NV_PIXEL_X8_PER_RASTER_PIXEL
NV_PIXEL_X4_PER_RASTER_PIXEL
NV_PIXEL_X2_PER_RASTER_PIXEL
NV_PIXEL_X1_PER_RASTER_PIXEL
NV_PIXEL_X1_PER_2X1_RASTER_PIXELS
NV_PIXEL_X1_PER_1X2_RASTER_PIXELS
NV_PIXEL_X1_PER_2X2_RASTER_PIXELS
NV_PIXEL_X1_PER_4X2_RASTER_PIXELS
NV_PIXEL_X1_PER_2X4_RASTER_PIXELS
NV_PIXEL_X1_PER_4X4_RASTER_PIXELS

◆ NV_SMP_ASSIST_LEVEL

enum NV_SMP_ASSIST_LEVEL
Enumerator
NV_SMP_ASSIST_LEVEL_FULL
NV_SMP_ASSIST_LEVEL_PARTIAL
NV_SMP_ASSIST_LEVEL_MINIMAL
NV_SMP_ASSIST_NUM_LEVELS

◆ NVAPI_QUAD_FILLMODE

enum NVAPI_QUAD_FILLMODE

SUPPORTED OS: Windows 7 and higher

Enumerator
NVAPI_QUAD_FILLMODE_DISABLED
NVAPI_QUAD_FILLMODE_BBOX
NVAPI_QUAD_FILLMODE_FULL_VIEWPORT

Function Documentation

◆ compile_time_assert() [1/12]

compile_time_assert ( sizeof(NV_D3D11_META_COMMAND_EXECUTE_CONVOLUTION_EX_DESC) = =144 )

◆ compile_time_assert() [2/12]

compile_time_assert ( sizeof(NV_D3D11_META_COMMAND_EXECUTE_GEMM_DESC) = =96 )

◆ compile_time_assert() [3/12]

compile_time_assert ( sizeof(NV_D3D11_META_COMMAND_INITIALIZE_CONVOLUTION_EX_DESC) = =16 )

◆ compile_time_assert() [4/12]

compile_time_assert ( sizeof(NV_D3D11_META_COMMAND_INITIALIZE_GEMM_DESC) = =16 )

◆ compile_time_assert() [5/12]

compile_time_assert ( sizeof(NV_D3D12_META_COMMAND_EXECUTE_CONVOLUTION_EX_DESC) = =72 )

◆ compile_time_assert() [6/12]

compile_time_assert ( sizeof(NV_D3D12_META_COMMAND_EXECUTE_GEMM_DESC) = =48 )

◆ compile_time_assert() [7/12]

compile_time_assert ( sizeof(NV_D3D12_META_COMMAND_INITIALIZE_CONVOLUTION_EX_DESC) = =8 )

◆ compile_time_assert() [8/12]

compile_time_assert ( sizeof(NV_D3D12_META_COMMAND_INITIALIZE_GEMM_DESC) = =8 )

◆ compile_time_assert() [9/12]

compile_time_assert ( sizeof(NV_META_COMMAND_CONVOLUTION_FUSE_DESC) = =20 )

◆ compile_time_assert() [10/12]

compile_time_assert ( sizeof(NV_META_COMMAND_CREATE_CONVOLUTION_EX_DESC) = =640 )

◆ compile_time_assert() [11/12]

compile_time_assert ( sizeof(NV_META_COMMAND_CREATE_CONVOLUTION_EX_FUSED_DESC) = =660 )

◆ compile_time_assert() [12/12]

compile_time_assert ( sizeof(NV_META_COMMAND_TENSOR_DESC) = =112 )

◆ DECLARE_INTERFACE() [1/5]

DECLARE_INTERFACE ( ID3D11MultiGPUDevice_V1 )

References __in, __in_opt, and __out.

◆ DECLARE_INTERFACE() [2/5]

DECLARE_INTERFACE ( ID3DNvGazeHandler_V1 )

◆ DECLARE_INTERFACE() [3/5]

DECLARE_INTERFACE ( ID3DNvGazeHandler_V2 )

◆ DECLARE_INTERFACE() [4/5]

DECLARE_INTERFACE ( ID3DNvSMPAssist_V1 )

SUPPORTED OS: Windows 7 and higher

References __in, and __inout.

◆ DECLARE_INTERFACE() [5/5]

DECLARE_INTERFACE ( ID3DNvVRSHelper_V1 )

◆ DECLARE_INTERFACE_() [1/2]

DECLARE_INTERFACE_ | ( | __declspec(uuid("00BF193A-117B-42BC-BBCD-E964A0EA4F2B")) | ID3D11NvMetaCommand_V1,
 |  | IUnknown |
 | ) |  |

◆ DECLARE_INTERFACE_() [2/2]

DECLARE_INTERFACE_ | ( | __declspec(uuid("E14BE7F6-8FF5-4F5E-B63A-AD016EB8FBE5")) | ID3D11NvShadingRateResourceView_V1,
 |  | ID3D11View |
 | ) |  |

References _Outptr_.

◆ NvAPI_D3D11_BeginUAVOverlapEx()

NVAPI_INTERFACE NvAPI_D3D11_BeginUAVOverlapEx | ( | __in IUnknown * | pDeviceOrContext,
 |  | __in NvU32 | insertWFIFlags
 | ) |  |

◆ NvAPI_D3D11_CreateCubinComputeShader()

NVAPI_INTERFACE NvAPI_D3D11_CreateCubinComputeShader | ( | __in ID3D11Device * | pDevice,
 |  | __in const void * | pCubin,
 |  | __in NvU32 | size,
 |  | __in NvU32 | blockX,
 |  | __in NvU32 | blockY,
 |  | __in NvU32 | blockZ,
 |  | __out NVDX_ObjectHandle * | phShader
 | ) |  |

SUPPORTED OS: Windows 10 and higher

◆ NvAPI_D3D11_CreateCubinComputeShaderEx()

NVAPI_INTERFACE NvAPI_D3D11_CreateCubinComputeShaderEx | ( | __in ID3D11Device * | pDevice,
 |  | __in const void * | pCubin,
 |  | __in NvU32 | size,
 |  | __in NvU32 | blockX,
 |  | __in NvU32 | blockY,
 |  | __in NvU32 | blockZ,
 |  | __in NvU32 | dynSharedMemBytes,
 |  | __in const char * | pShaderName,
 |  | __out NVDX_ObjectHandle * | phShader
 | ) |  |

SUPPORTED OS: Windows 10 and higher

◆ NvAPI_D3D11_CreateCubinComputeShaderWithName()

NVAPI_INTERFACE NvAPI_D3D11_CreateCubinComputeShaderWithName | ( | __in ID3D11Device * | pDevice,
 |  | __in const void * | pCubin,
 |  | __in NvU32 | size,
 |  | __in NvU32 | blockX,
 |  | __in NvU32 | blockY,
 |  | __in NvU32 | blockZ,
 |  | __in const char * | pShaderName,
 |  | __out NVDX_ObjectHandle * | phShader
 | ) |  |

SUPPORTED OS: Windows 10 and higher

◆ NvAPI_D3D11_CreateDomainShaderEx()

NVAPI_INTERFACE NvAPI_D3D11_CreateDomainShaderEx | ( | __in ID3D11Device * | pDevice,
 |  | __in const void * | pShaderBytecode,
 |  | __in SIZE_T | BytecodeLength,
 |  | __in_opt ID3D11ClassLinkage * | pClassLinkage,
 |  | __in const NvAPI_D3D11_CREATE_DOMAIN_SHADER_EX * | pCreateDomainShaderExArgs,
 |  | __out ID3D11DomainShader ** | ppDomainShader
 | ) |  |

◆ NvAPI_D3D11_CreateFastGeometryShader()

NVAPI_INTERFACE NvAPI_D3D11_CreateFastGeometryShader | ( | __in ID3D11Device * | pDevice,
 |  | __in const void * | pShaderBytecode,
 |  | __in SIZE_T | BytecodeLength,
 |  | __in_opt ID3D11ClassLinkage * | pClassLinkage,
 |  | __out ID3D11GeometryShader ** | ppGeometryShader
 | ) |  |

◆ NvAPI_D3D11_CreateFastGeometryShaderExplicit()

NVAPI_INTERFACE NvAPI_D3D11_CreateFastGeometryShaderExplicit | ( | __in ID3D11Device * | pDevice,
 |  | __in const void * | pShaderBytecode,
 |  | __in SIZE_T | BytecodeLength,
 |  | __in_opt ID3D11ClassLinkage * | pClassLinkage,
 |  | __in const NvAPI_D3D11_CREATE_FASTGS_EXPLICIT_DESC * | pCreateFastGSArgs,
 |  | __out ID3D11GeometryShader ** | ppGeometryShader
 | ) |  |

◆ NvAPI_D3D11_CreateGeometryShaderEx_2()

NVAPI_INTERFACE NvAPI_D3D11_CreateGeometryShaderEx_2 | ( | __in ID3D11Device * | pDevice,
 |  | __in const void * | pShaderBytecode,
 |  | __in SIZE_T | BytecodeLength,
 |  | __in_opt ID3D11ClassLinkage * | pClassLinkage,
 |  | __in const NvAPI_D3D11_CREATE_GEOMETRY_SHADER_EX * | pCreateGeometryShaderExArgs,
 |  | __out ID3D11GeometryShader ** | ppGeometryShader
 | ) |  |

◆ NvAPI_D3D11_CreateHullShaderEx()

NVAPI_INTERFACE NvAPI_D3D11_CreateHullShaderEx | ( | __in ID3D11Device * | pDevice,
 |  | __in const void * | pShaderBytecode,
 |  | __in SIZE_T | BytecodeLength,
 |  | __in_opt ID3D11ClassLinkage * | pClassLinkage,
 |  | __in const NvAPI_D3D11_CREATE_HULL_SHADER_EX * | pCreateHullShaderExArgs,
 |  | __out ID3D11HullShader ** | ppHullShader
 | ) |  |

◆ NvAPI_D3D11_CreateMetaCommand()

NVAPI_INTERFACE NvAPI_D3D11_CreateMetaCommand | ( | __in ID3D11Device * | pDevice,
 |  | __in REFGUID | CommandId,
 |  | __in_bcount(CreationParametersDataSize) const void * | pCreationParametersData,
 |  | __in NvU32 | CreationParametersDataSize,
 |  | __out ID3D11NvMetaCommand ** | ppMetaCommand
 | ) |  |

◆ NvAPI_D3D11_CreatePixelShaderEx_2()

NVAPI_INTERFACE NvAPI_D3D11_CreatePixelShaderEx_2 | ( | __in ID3D11Device * | pDevice,
 |  | __in const void * | pShaderBytecode,
 |  | __in SIZE_T | BytecodeLength,
 |  | __in_opt ID3D11ClassLinkage * | pClassLinkage,
 |  | __in const NvAPI_D3D11_CREATE_PIXEL_SHADER_EX * | pCreatePixelShaderExArgs,
 |  | __out ID3D11PixelShader ** | ppPixelShader
 | ) |  |

◆ NvAPI_D3D11_CreateSamplerState()

NVAPI_INTERFACE NvAPI_D3D11_CreateSamplerState | ( | __in ID3D11Device * | pDevice,
 |  | __in const D3D11_SAMPLER_DESC * | pSamplerDesc,
 |  | __out ID3D11SamplerState ** | ppSamplerState,
 |  | __out NvU32 * | pDriverHandle
 | ) |  |

SUPPORTED OS: Windows 10 and higher

◆ NvAPI_D3D11_CreateShaderResourceView()

NVAPI_INTERFACE NvAPI_D3D11_CreateShaderResourceView | ( | __in ID3D11Device * | pDevice,
 |  | __in ID3D11Resource * | pResource,
 |  | __in const D3D11_SHADER_RESOURCE_VIEW_DESC * | pDesc,
 |  | __out ID3D11ShaderResourceView ** | ppSRV,
 |  | __out NvU32 * | pDriverHandle
 | ) |  |

SUPPORTED OS: Windows 10 and higher

◆ NvAPI_D3D11_CreateUnorderedAccessView()

NVAPI_INTERFACE NvAPI_D3D11_CreateUnorderedAccessView | ( | __in ID3D11Device * | pDevice,
 |  | __in ID3D11Resource * | pResource,
 |  | __in const D3D11_UNORDERED_ACCESS_VIEW_DESC * | pDesc,
 |  | __out ID3D11UnorderedAccessView ** | ppUAV,
 |  | __out NvU32 * | pDriverHandle
 | ) |  |

SUPPORTED OS: Windows 10 and higher

◆ NvAPI_D3D11_CreateVertexShaderEx()

NVAPI_INTERFACE NvAPI_D3D11_CreateVertexShaderEx | ( | __in ID3D11Device * | pDevice,
 |  | __in const void * | pShaderBytecode,
 |  | __in SIZE_T | BytecodeLength,
 |  | __in_opt ID3D11ClassLinkage * | pClassLinkage,
 |  | __in const NvAPI_D3D11_CREATE_VERTEX_SHADER_EX * | pCreateVertexShaderExArgs,
 |  | __out ID3D11VertexShader ** | ppVertexShader
 | ) |  |

◆ NvAPI_D3D11_DestroyCubinComputeShader()

NVAPI_INTERFACE NvAPI_D3D11_DestroyCubinComputeShader | ( | __in ID3D11Device * | pDevice,
 |  | __in NVDX_ObjectHandle | hShader
 | ) |  |

SUPPORTED OS: Windows 10 and higher

◆ NvAPI_D3D11_GetCudaTextureObject()

NVAPI_INTERFACE NvAPI_D3D11_GetCudaTextureObject | ( | __in ID3D11Device * | pDevice,
 |  | __in NvU32 | srvDriverHandle,
 |  | __in NvU32 | samplerDriverHandle,
 |  | __out NvU32 * | pCudaTextureHandle
 | ) |  |

SUPPORTED OS: Windows 10 and higher

◆ NvAPI_D3D11_GetResourceGPUVirtualAddress()

NVAPI_INTERFACE NvAPI_D3D11_GetResourceGPUVirtualAddress | ( | __in ID3D11Device * | pDevice,
 |  | __in const NVDX_ObjectHandle | hResource,
 |  | __out NvU64 * | pGpuVA
 | ) |  |

SUPPORTED OS: Windows 10 and higher

◆ NvAPI_D3D11_GetResourceGPUVirtualAddressEx()

NVAPI_INTERFACE NvAPI_D3D11_GetResourceGPUVirtualAddressEx | ( | __in ID3D11Device * | pDevice,
 |  | __inout NV_GET_GPU_VIRTUAL_ADDRESS * | pParams
 | ) |  |

SUPPORTED OS: Windows 10

◆ NvAPI_D3D11_IsFatbinPTXSupported()

NVAPI_INTERFACE NvAPI_D3D11_IsFatbinPTXSupported | ( | __in ID3D11Device * | pDevice,
 |  | __out bool * | pSupported
 | ) |  |

SUPPORTED OS: Windows 10 and higher

◆ NvAPI_D3D11_LaunchCubinShader()

NVAPI_INTERFACE NvAPI_D3D11_LaunchCubinShader | ( | __in ID3D11DeviceContext * | pDeviceContext,
 |  | __in NVDX_ObjectHandle | hShader,
 |  | __in NvU32 | gridX,
 |  | __in NvU32 | gridY,
 |  | __in NvU32 | gridZ,
 |  | __in const void * | pParams,
 |  | __in NvU32 | paramSize,
 |  | __in const NVDX_ObjectHandle * | pReadResources,
 |  | __in NvU32 | numReadResources,
 |  | __in const NVDX_ObjectHandle * | pWriteResources,
 |  | __in NvU32 | numWriteResources
 | ) |  |

SUPPORTED OS: Windows 10 and higher

◆ NvAPI_D3D12_CaptureUAVInfo()

NVAPI_INTERFACE NvAPI_D3D12_CaptureUAVInfo | ( | __in ID3D12Device * | pDevice,
 |  | __out NVAPI_UAV_INFO * | pUAVInfo
 | ) |  |

◆ NvAPI_D3D12_CreateCommittedResource()

NVAPI_INTERFACE NvAPI_D3D12_CreateCommittedResource | ( | __in ID3D12Device * | pDevice,
 |  | __in const D3D12_HEAP_PROPERTIES * | pHeapProperties,
 |  | __in D3D12_HEAP_FLAGS | HeapFlags,
 |  | __in const D3D12_RESOURCE_DESC * | pDesc,
 |  | __in D3D12_RESOURCE_STATES | InitialState,
 |  | __in const D3D12_CLEAR_VALUE * | pOptimizedClearValue,
 |  | __in const NV_RESOURCE_PARAMS * | pNVResourceParams,
 |  | __in REFIID | riid,
 |  | __out_opt void ** | ppvResource,
 |  | __out_opt bool * | pSupported
 | ) |  |

◆ NvAPI_D3D12_CreateCubinComputeShader()

NVAPI_INTERFACE NvAPI_D3D12_CreateCubinComputeShader | ( | __in ID3D12Device * | pDevice,
 |  | __in const void * | pCubin,
 |  | __in NvU32 | size,
 |  | __in NvU32 | blockX,
 |  | __in NvU32 | blockY,
 |  | __in NvU32 | blockZ,
 |  | __out NVDX_ObjectHandle * | phShader
 | ) |  |

SUPPORTED OS: Windows 10 and higher

◆ NvAPI_D3D12_CreateCubinComputeShaderEx()

NVAPI_INTERFACE NvAPI_D3D12_CreateCubinComputeShaderEx | ( | __in ID3D12Device * | pDevice,
 |  | __in const void * | pCubin,
 |  | __in NvU32 | size,
 |  | __in NvU32 | blockX,
 |  | __in NvU32 | blockY,
 |  | __in NvU32 | blockZ,
 |  | __in NvU32 | dynSharedMemBytes,
 |  | __in const char * | pShaderName,
 |  | __out NVDX_ObjectHandle * | phShader
 | ) |  |

SUPPORTED OS: Windows 10 and higher

◆ NvAPI_D3D12_CreateCubinComputeShaderExV2()

NVAPI_INTERFACE NvAPI_D3D12_CreateCubinComputeShaderExV2 ( __inout NVAPI_D3D12_CREATE_CUBIN_SHADER_PARAMS * pParams )

◆ NvAPI_D3D12_CreateCubinComputeShaderWithName()

NVAPI_INTERFACE NvAPI_D3D12_CreateCubinComputeShaderWithName | ( | __in ID3D12Device * | pDevice,
 |  | __in const void * | pCubin,
 |  | __in NvU32 | size,
 |  | __in NvU32 | blockX,
 |  | __in NvU32 | blockY,
 |  | __in NvU32 | blockZ,
 |  | __in const char * | pShaderName,
 |  | __out NVDX_ObjectHandle * | phShader
 | ) |  |

SUPPORTED OS: Windows 10 and higher

◆ NvAPI_D3D12_CreateCuFunction()

NVAPI_INTERFACE NvAPI_D3D12_CreateCuFunction | ( | __in ID3D12Device * | pDevice,
 |  | __in NVDX_ObjectHandle | hModule,
 |  | __in const char * | pName,
 |  | __out NVDX_ObjectHandle * | phFunction
 | ) |  |

SUPPORTED OS: Windows 10 and higher

◆ NvAPI_D3D12_CreateCuModule()

NVAPI_INTERFACE NvAPI_D3D12_CreateCuModule | ( | __in ID3D12Device * | pDevice,
 |  | __in const void * | pBlob,
 |  | __in NvU32 | size,
 |  | __out NVDX_ObjectHandle * | phModule
 | ) |  |

SUPPORTED OS: Windows 10 and higher

◆ NvAPI_D3D12_CreateHeap2()

NVAPI_INTERFACE NvAPI_D3D12_CreateHeap2 | ( | __in ID3D12Device * | pDevice,
 |  | __in const D3D12_HEAP_DESC * | pDesc,
 |  | __in const NV_HEAP_PARAMS * | pNVHeapParams,
 |  | __in REFIID | riid,
 |  | __out void ** | ppvHeap
 | ) |  |

◆ NvAPI_D3D12_CreateMetaCommand()

NVAPI_INTERFACE NvAPI_D3D12_CreateMetaCommand | ( | __in ID3D12Device * | pDevice,
 |  | __in REFGUID | CommandId,
 |  | __in NvU32 | NodeMask,
 |  | __in_bcount(CreationParametersDataSize) const void * | pCreationParametersData,
 |  | __in NvU32 | CreationParametersDataSize,
 |  | __out ID3D12NvMetaCommand ** | ppMetaCommand
 | ) |  |

◆ NvAPI_D3D12_DestroyCubinComputeShader()

NVAPI_INTERFACE NvAPI_D3D12_DestroyCubinComputeShader | ( | __in ID3D12Device * | pDevice,
 |  | __in NVDX_ObjectHandle | hShader
 | ) |  |

SUPPORTED OS: Windows 10 and higher

◆ NvAPI_D3D12_DestroyCuFunction()

NVAPI_INTERFACE NvAPI_D3D12_DestroyCuFunction | ( | __in ID3D12Device * | pDevice,
 |  | __in NVDX_ObjectHandle | hFunction
 | ) |  |

SUPPORTED OS: Windows 10 and higher

◆ NvAPI_D3D12_DestroyCuModule()

NVAPI_INTERFACE NvAPI_D3D12_DestroyCuModule | ( | __in ID3D12Device * | pDevice,
 |  | __in NVDX_ObjectHandle | hModule
 | ) |  |

SUPPORTED OS: Windows 10 and higher

◆ NvAPI_D3D12_EnumFunctionsInModule()

NVAPI_INTERFACE NvAPI_D3D12_EnumFunctionsInModule | ( | __in ID3D12Device * | pDevice,
 |  | __in NVDX_ObjectHandle | hModule,
 |  | __inout NvU32 * | pArraySize,
 |  | __out const char **const | pFunctionNames
 | ) |  |

SUPPORTED OS: Windows 10 and higher

◆ NvAPI_D3D12_GetCudaIndependentDescriptorObject()

NVAPI_INTERFACE NvAPI_D3D12_GetCudaIndependentDescriptorObject ( __inout NVAPI_D3D12_GET_CUDA_INDEPENDENT_DESCRIPTOR_OBJECT_PARAMS * pParams )

◆ NvAPI_D3D12_GetCudaMergedTextureSamplerObject()

NVAPI_INTERFACE NvAPI_D3D12_GetCudaMergedTextureSamplerObject ( __inout NVAPI_D3D12_GET_CUDA_MERGED_TEXTURE_SAMPLER_OBJECT_PARAMS * pParams )

◆ NvAPI_D3D12_GetCudaSurfaceObject()

NVAPI_INTERFACE NvAPI_D3D12_GetCudaSurfaceObject | ( | __in ID3D12Device * | pDevice,
 |  | __in D3D12_CPU_DESCRIPTOR_HANDLE | uavDesc,
 |  | __out NvU32 * | pSurfaceHandle
 | ) |  |

SUPPORTED OS: Windows 10 and higher

◆ NvAPI_D3D12_GetCudaTextureObject()

NVAPI_INTERFACE NvAPI_D3D12_GetCudaTextureObject | ( | __in ID3D12Device * | pDevice,
 |  | __in D3D12_CPU_DESCRIPTOR_HANDLE | texDesc,
 |  | __in D3D12_CPU_DESCRIPTOR_HANDLE | smpDesc,
 |  | __out NvU32 * | pTextureHandle
 | ) |  |

SUPPORTED OS: Windows 10 and higher

◆ NvAPI_D3D12_IsFatbinPTXSupported()

NVAPI_INTERFACE NvAPI_D3D12_IsFatbinPTXSupported | ( | __in ID3D12Device * | pDevice,
 |  | __out bool * | pSupported
 | ) |  |

SUPPORTED OS: Windows 10 and higher

◆ NvAPI_D3D12_LaunchCubinShader()

NVAPI_INTERFACE NvAPI_D3D12_LaunchCubinShader | ( | __in ID3D12GraphicsCommandList * | pCommandList,
 |  | __in NVDX_ObjectHandle | hShader,
 |  | __in NvU32 | gridX,
 |  | __in NvU32 | gridY,
 |  | __in NvU32 | gridZ,
 |  | __in const void * | pParams,
 |  | __in NvU32 | paramSize
 | ) |  |

SUPPORTED OS: Windows 10 and higher

◆ NvAPI_D3D12_LaunchCuKernelChain()

NVAPI_INTERFACE NvAPI_D3D12_LaunchCuKernelChain | ( | __in ID3D12GraphicsCommandList * | pCommandList,
 |  | __in const NVAPI_CU_KERNEL_LAUNCH_PARAMS * | pKernels,
 |  | __in NvU32 | numKernels
 | ) |  |

◆ NvAPI_D3D12_LaunchCuKernelChainEx()

NVAPI_INTERFACE NvAPI_D3D12_LaunchCuKernelChainEx | ( | __in ID3D12GraphicsCommandList * | pCommandList,
 |  | __in const NVAPI_CU_KERNEL_LAUNCH_PARAMS_EX * | pKernels,
 |  | __in NvU32 | numKernels
 | ) |  |

◆ NvAPI_D3D_ConfigureAnsel()

NVAPI_INTERFACE NvAPI_D3D_ConfigureAnsel | ( | __in IUnknown * | pDevice,
 |  | __in NVAPI_ANSEL_CONFIGURATION_STRUCT * | pNLSConfig
 | ) |  |

Variable Documentation

◆ displayView

NV_DISPLAY_PATH_INFO NV_TARGET_VIEW_MODE displayView

◆ pTargetInfo

NV_VIEW_TARGET_INFO* pTargetInfo

◆ pVersion

NV_DISPLAY_DRIVER_VERSION* pVersion

◆ targetView

NV_VIEW_TARGET_INFO NV_TARGET_VIEW_MODE targetView


  • File List
  • Globals
Data Structures | Macros | Typedefs | Enumerations | Functions | Variables
nvapi_lite_common.h File Reference
#include "nvapi_lite_salstart.h"
#include "nvapi_lite_salend.h"

Data Structures

struct | _NV_RECT
struct | NvSBox
struct | NvGUID
struct | NV_DISPLAY_DRIVER_MEMORY_INFO_V1
struct | NV_DISPLAY_DRIVER_MEMORY_INFO_V2
struct | NV_DISPLAY_DRIVER_MEMORY_INFO_V3
struct | NV_GPU_MEMORY_INFO_EX_V1

Macros

#define | __nvapi_deprecated_function(message)
#define | __nvapi_deprecated_datatype(FirstRelease)
#define | NvU32TONvF32(_pData) *(NvF32 *)(_pData)
#define | NvF32TONvU32(_pData) *(NvU32 *)(_pData)
#define | NV_TRUE ((NvBool)(0 == 0))
#define | NV_FALSE ((NvBool)(0 != 0))
#define | NV_DECLARE_HANDLE(name) struct name##__ { int unused; }; typedef struct name##__ *name
#define | NVAPI_GENERIC_STRING_MAX 4096
#define | NVAPI_LONG_STRING_MAX 256
#define | NVAPI_SHORT_STRING_MAX 64
#define | NvGUID_Defined
#define | NVAPI_MAX_PHYSICAL_GPUS 64
#define | NVAPI_MAX_PHYSICAL_BRIDGES 100
#define | NVAPI_PHYSICAL_GPUS 32
#define | NVAPI_MAX_LOGICAL_GPUS 64
#define | NVAPI_MAX_AVAILABLE_GPU_TOPOLOGIES 256
#define | NVAPI_MAX_AVAILABLE_SLI_GROUPS 256
#define | NVAPI_MAX_GPU_TOPOLOGIES NVAPI_MAX_PHYSICAL_GPUS
#define | NVAPI_MAX_GPU_PER_TOPOLOGY 8
#define | NVAPI_MAX_DISPLAY_HEADS 2
#define | NVAPI_ADVANCED_DISPLAY_HEADS 4
#define | NVAPI_MAX_DISPLAYS NVAPI_PHYSICAL_GPUS * NVAPI_ADVANCED_DISPLAY_HEADS
#define | NVAPI_MAX_ACPI_IDS 16
#define | NVAPI_MAX_VIEW_MODES 8
#define | NVAPI_SYSTEM_MAX_HWBCS 128
#define | NVAPI_SYSTEM_HWBC_INVALID_ID 0xffffffff
#define | NVAPI_SYSTEM_MAX_DISPLAYS NVAPI_MAX_PHYSICAL_GPUS * NV_MAX_HEADS
#define | NV_MAX_HEADS 4
#define | NVAPI_MAX_HEADS_PER_GPU 32
#define | NV_MAX_VID_STREAMS 4
#define | NV_MAX_VID_STREAMS_EX 20
#define | NV_MAX_VID_PROFILES 4
#define | NVAPI_MAX_AUDIO_DEVICES 16
#define | MAKE_NVAPI_VERSION(typeName, ver) (NvU32)(sizeof(typeName) | ((ver)<<16))
#define | GET_NVAPI_VERSION(ver) (NvU32)((ver)>>16)
#define | GET_NVAPI_SIZE(ver) (NvU32)((ver) & 0xffff)
#define | NV_DISPLAY_DRIVER_MEMORY_INFO_VER_1 MAKE_NVAPI_VERSION(NV_DISPLAY_DRIVER_MEMORY_INFO_V1,1)
#define | NV_DISPLAY_DRIVER_MEMORY_INFO_VER_2 MAKE_NVAPI_VERSION(NV_DISPLAY_DRIVER_MEMORY_INFO_V2,2)
#define | NV_DISPLAY_DRIVER_MEMORY_INFO_VER_3 MAKE_NVAPI_VERSION(NV_DISPLAY_DRIVER_MEMORY_INFO_V3,3)
#define | NV_DISPLAY_DRIVER_MEMORY_INFO_VER NV_DISPLAY_DRIVER_MEMORY_INFO_VER_3
#define | NV_GPU_MEMORY_INFO_EX_VER_1 MAKE_NVAPI_VERSION(NV_GPU_MEMORY_INFO_EX_V1,1)
#define | NV_GPU_MEMORY_INFO_EX_VER NV_GPU_MEMORY_INFO_EX_VER_1
#define | NVAPI_DEFAULT_HANDLE 0
#define | NV_BIT(x) (1 << (x))

Typedefs

typedef unsigned __int64 | NvU64
typedef __int64 | NvS64
typedef signed int | NvS32
typedef unsigned long | NvU32
typedef unsigned long | temp_NvU32
typedef signed short | NvS16
typedef unsigned short | NvU16
typedef unsigned char | NvU8
typedef signed char | NvS8
typedef float | NvF32
typedef double | NvF64
typedef NvU8 | NvBool
typedef struct _NV_RECT | NV_RECT
typedef void * | StereoHandle
typedef struct NvGUID | NvLUID
typedef char | NvAPI_String[NVAPI_GENERIC_STRING_MAX]
typedef char | NvAPI_LongString[NVAPI_LONG_STRING_MAX]
typedef char | NvAPI_ShortString[NVAPI_SHORT_STRING_MAX]
typedef NvU16 | NvAPI_UnicodeShortString[NVAPI_SHORT_STRING_MAX]
typedef enum _NvAPI_Status | NvAPI_Status
typedef NV_DISPLAY_DRIVER_MEMORY_INFO_V3 | NV_DISPLAY_DRIVER_MEMORY_INFO
typedef NV_GPU_MEMORY_INFO_EX_V1 | NV_GPU_MEMORY_INFO_EX

Enumerations

enum _NvAPI_Status {
NVAPI_OK = 0 , NVAPI_ERROR = -1 , NVAPI_LIBRARY_NOT_FOUND = -2 , NVAPI_NO_IMPLEMENTATION = -3 ,
NVAPI_API_NOT_INITIALIZED = -4 , NVAPI_INVALID_ARGUMENT = -5 , NVAPI_NVIDIA_DEVICE_NOT_FOUND = -6 , NVAPI_END_ENUMERATION = -7 ,
NVAPI_INVALID_HANDLE = -8 , NVAPI_INCOMPATIBLE_STRUCT_VERSION = -9 , NVAPI_HANDLE_INVALIDATED = -10 , NVAPI_OPENGL_CONTEXT_NOT_CURRENT = -11 ,
NVAPI_INVALID_POINTER = -14 , NVAPI_NO_GL_EXPERT = -12 , NVAPI_INSTRUMENTATION_DISABLED = -13 , NVAPI_NO_GL_NSIGHT = -15 ,
NVAPI_EXPECTED_LOGICAL_GPU_HANDLE = -100 , NVAPI_EXPECTED_PHYSICAL_GPU_HANDLE = -101 , NVAPI_EXPECTED_DISPLAY_HANDLE = -102 , NVAPI_INVALID_COMBINATION = -103 ,
NVAPI_NOT_SUPPORTED = -104 , NVAPI_PORTID_NOT_FOUND = -105 , NVAPI_EXPECTED_UNATTACHED_DISPLAY_HANDLE = -106 , NVAPI_INVALID_PERF_LEVEL = -107 ,
NVAPI_DEVICE_BUSY = -108 , NVAPI_NV_PERSIST_FILE_NOT_FOUND = -109 , NVAPI_PERSIST_DATA_NOT_FOUND = -110 , NVAPI_EXPECTED_TV_DISPLAY = -111 ,
NVAPI_EXPECTED_TV_DISPLAY_ON_DCONNECTOR = -112 , NVAPI_NO_ACTIVE_SLI_TOPOLOGY = -113 , NVAPI_SLI_RENDERING_MODE_NOTALLOWED = -114 , NVAPI_EXPECTED_DIGITAL_FLAT_PANEL = -115 ,
NVAPI_ARGUMENT_EXCEED_MAX_SIZE = -116 , NVAPI_DEVICE_SWITCHING_NOT_ALLOWED = -117 , NVAPI_TESTING_CLOCKS_NOT_SUPPORTED = -118 , NVAPI_UNKNOWN_UNDERSCAN_CONFIG = -119 ,
NVAPI_TIMEOUT_RECONFIGURING_GPU_TOPO = -120 , NVAPI_DATA_NOT_FOUND = -121 , NVAPI_EXPECTED_ANALOG_DISPLAY = -122 , NVAPI_NO_VIDLINK = -123 ,
NVAPI_REQUIRES_REBOOT = -124 , NVAPI_INVALID_HYBRID_MODE = -125 , NVAPI_MIXED_TARGET_TYPES = -126 , NVAPI_SYSWOW64_NOT_SUPPORTED = -127 ,
NVAPI_IMPLICIT_SET_GPU_TOPOLOGY_CHANGE_NOT_ALLOWED = -128 , NVAPI_REQUEST_USER_TO_CLOSE_NON_MIGRATABLE_APPS = -129 , NVAPI_OUT_OF_MEMORY = -130 , NVAPI_WAS_STILL_DRAWING = -131 ,
NVAPI_FILE_NOT_FOUND = -132 , NVAPI_TOO_MANY_UNIQUE_STATE_OBJECTS = -133 , NVAPI_INVALID_CALL = -134 , NVAPI_D3D10_1_LIBRARY_NOT_FOUND = -135 ,
NVAPI_FUNCTION_NOT_FOUND = -136 , NVAPI_INVALID_USER_PRIVILEGE = -137 , NVAPI_EXPECTED_NON_PRIMARY_DISPLAY_HANDLE = -138 , NVAPI_EXPECTED_COMPUTE_GPU_HANDLE = -139 ,
NVAPI_STEREO_NOT_INITIALIZED = -140 , NVAPI_STEREO_REGISTRY_ACCESS_FAILED = -141 , NVAPI_STEREO_REGISTRY_PROFILE_TYPE_NOT_SUPPORTED = -142 , NVAPI_STEREO_REGISTRY_VALUE_NOT_SUPPORTED = -143 ,
NVAPI_STEREO_NOT_ENABLED = -144 , NVAPI_STEREO_NOT_TURNED_ON = -145 , NVAPI_STEREO_INVALID_DEVICE_INTERFACE = -146 , NVAPI_STEREO_PARAMETER_OUT_OF_RANGE = -147 ,
NVAPI_STEREO_FRUSTUM_ADJUST_MODE_NOT_SUPPORTED = -148 , NVAPI_TOPO_NOT_POSSIBLE = -149 , NVAPI_MODE_CHANGE_FAILED = -150 , NVAPI_D3D11_LIBRARY_NOT_FOUND = -151 ,
NVAPI_INVALID_ADDRESS = -152 , NVAPI_STRING_TOO_SMALL = -153 , NVAPI_MATCHING_DEVICE_NOT_FOUND = -154 , NVAPI_DRIVER_RUNNING = -155 ,
NVAPI_DRIVER_NOTRUNNING = -156 , NVAPI_ERROR_DRIVER_RELOAD_REQUIRED = -157 , NVAPI_SET_NOT_ALLOWED = -158 , NVAPI_ADVANCED_DISPLAY_TOPOLOGY_REQUIRED = -159 ,
NVAPI_SETTING_NOT_FOUND = -160 , NVAPI_SETTING_SIZE_TOO_LARGE = -161 , NVAPI_TOO_MANY_SETTINGS_IN_PROFILE = -162 , NVAPI_PROFILE_NOT_FOUND = -163 ,
NVAPI_PROFILE_NAME_IN_USE = -164 , NVAPI_PROFILE_NAME_EMPTY = -165 , NVAPI_EXECUTABLE_NOT_FOUND = -166 , NVAPI_EXECUTABLE_ALREADY_IN_USE = -167 ,
NVAPI_DATATYPE_MISMATCH = -168 , NVAPI_PROFILE_REMOVED = -169 , NVAPI_UNREGISTERED_RESOURCE = -170 , NVAPI_ID_OUT_OF_RANGE = -171 ,
NVAPI_DISPLAYCONFIG_VALIDATION_FAILED = -172 , NVAPI_DPMST_CHANGED = -173 , NVAPI_INSUFFICIENT_BUFFER = -174 , NVAPI_ACCESS_DENIED = -175 ,
NVAPI_MOSAIC_NOT_ACTIVE = -176 , NVAPI_SHARE_RESOURCE_RELOCATED = -177 , NVAPI_REQUEST_USER_TO_DISABLE_DWM = -178 , NVAPI_D3D_DEVICE_LOST = -179 ,
NVAPI_INVALID_CONFIGURATION = -180 , NVAPI_STEREO_HANDSHAKE_NOT_DONE = -181 , NVAPI_EXECUTABLE_PATH_IS_AMBIGUOUS = -182 , NVAPI_DEFAULT_STEREO_PROFILE_IS_NOT_DEFINED = -183 ,
NVAPI_DEFAULT_STEREO_PROFILE_DOES_NOT_EXIST = -184 , NVAPI_CLUSTER_ALREADY_EXISTS = -185 , NVAPI_DPMST_DISPLAY_ID_EXPECTED = -186 , NVAPI_INVALID_DISPLAY_ID = -187 ,
NVAPI_STREAM_IS_OUT_OF_SYNC = -188 , NVAPI_INCOMPATIBLE_AUDIO_DRIVER = -189 , NVAPI_VALUE_ALREADY_SET = -190 , NVAPI_TIMEOUT = -191 ,
NVAPI_GPU_WORKSTATION_FEATURE_INCOMPLETE = -192 , NVAPI_STEREO_INIT_ACTIVATION_NOT_DONE = -193 , NVAPI_SYNC_NOT_ACTIVE = -194 , NVAPI_SYNC_MASTER_NOT_FOUND = -195 ,
NVAPI_INVALID_SYNC_TOPOLOGY = -196 , NVAPI_ECID_SIGN_ALGO_UNSUPPORTED = -197 , NVAPI_ECID_KEY_VERIFICATION_FAILED = -198 , NVAPI_FIRMWARE_OUT_OF_DATE = -199 ,
NVAPI_FIRMWARE_REVISION_NOT_SUPPORTED = -200 , NVAPI_LICENSE_CALLER_AUTHENTICATION_FAILED = -201 , NVAPI_D3D_DEVICE_NOT_REGISTERED = -202 , NVAPI_RESOURCE_NOT_ACQUIRED = -203 ,
NVAPI_TIMING_NOT_SUPPORTED = -204 , NVAPI_HDCP_ENCRYPTION_FAILED = -205 , NVAPI_PCLK_LIMITATION_FAILED = -206 , NVAPI_NO_CONNECTOR_FOUND = -207 ,
NVAPI_HDCP_DISABLED = -208 , NVAPI_API_IN_USE = -209 , NVAPI_NVIDIA_DISPLAY_NOT_FOUND = -210 , NVAPI_PRIV_SEC_VIOLATION = -211 ,
NVAPI_INCORRECT_VENDOR = -212 , NVAPI_DISPLAY_IN_USE = -213 , NVAPI_UNSUPPORTED_CONFIG_NON_HDCP_HMD = -214 , NVAPI_MAX_DISPLAY_LIMIT_REACHED = -215 ,
NVAPI_INVALID_DIRECT_MODE_DISPLAY = -216 , NVAPI_GPU_IN_DEBUG_MODE = -217 , NVAPI_D3D_CONTEXT_NOT_FOUND = -218 , NVAPI_STEREO_VERSION_MISMATCH = -219 ,
NVAPI_GPU_NOT_POWERED = -220 , NVAPI_ERROR_DRIVER_RELOAD_IN_PROGRESS = -221 , NVAPI_WAIT_FOR_HW_RESOURCE = -222 , NVAPI_REQUIRE_FURTHER_HDCP_ACTION = -223 ,
NVAPI_DISPLAY_MUX_TRANSITION_FAILED = -224 , NVAPI_INVALID_DSC_VERSION = -225 , NVAPI_INVALID_DSC_SLICECOUNT = -226 , NVAPI_INVALID_DSC_OUTPUT_BPP = -227 ,
NVAPI_FAILED_TO_LOAD_FROM_DRIVER_STORE = -228 , NVAPI_NO_VULKAN = -229 , NVAPI_REQUEST_PENDING = -230 , NVAPI_RESOURCE_IN_USE = -231 ,
NVAPI_INVALID_IMAGE = -232 , NVAPI_INVALID_PTX = -233 , NVAPI_NVLINK_UNCORRECTABLE = -234 , NVAPI_JIT_COMPILER_NOT_FOUND = -235 ,
NVAPI_INVALID_SOURCE = -236 , NVAPI_ILLEGAL_INSTRUCTION = -237 , NVAPI_INVALID_PC = -238 , NVAPI_LAUNCH_FAILED = -239 ,
NVAPI_NOT_PERMITTED = -240 , NVAPI_CALLBACK_ALREADY_REGISTERED = -241 , NVAPI_CALLBACK_NOT_FOUND = -242 , NVAPI_INVALID_OUTPUT_WIRE_FORMAT = -243
}

Functions

NV_DECLARE_HANDLE (NvLogicalGpuHandle)
NV_DECLARE_HANDLE (NvPhysicalGpuHandle)
NV_DECLARE_HANDLE (NvDisplayHandle)
NV_DECLARE_HANDLE (NvMonitorHandle)
NV_DECLARE_HANDLE (NvUnAttachedDisplayHandle)
NV_DECLARE_HANDLE (NvVisualComputingDeviceHandle)
NV_DECLARE_HANDLE (NvEventHandle)
NV_DECLARE_HANDLE (NvHICHandle)
NV_DECLARE_HANDLE (NvGSyncDeviceHandle)
NV_DECLARE_HANDLE (NvVioHandle)
NV_DECLARE_HANDLE (NvTransitionHandle)
NV_DECLARE_HANDLE (NvAudioHandle)
NV_DECLARE_HANDLE (Nv3DVPContextHandle)
NV_DECLARE_HANDLE (Nv3DVPTransceiverHandle)
NV_DECLARE_HANDLE (Nv3DVPGlassesHandle)
NV_DECLARE_HANDLE (NvPcfClientHandle)
NV_DECLARE_HANDLE (NvSourceHandle)
NV_DECLARE_HANDLE (NvTargetHandle)
NV_DECLARE_HANDLE (NVDX_SwapChainHandle)
NV_DECLARE_HANDLE (NvPresentBarrierClientHandle)
NVAPI_INTERFACE | NvAPI_SYS_GetDriverAndBranchVersion (NvU32 *pDriverVersion, NvAPI_ShortString szBuildBranchString)
__nvapi_deprecated_function ("Do not use this function - it is deprecated in release 520. Instead, use NvAPI_GPU_GetMemoryInfoEx.") NVAPI_INTERFACE NvAPI_GPU_GetMemoryInfo(NvPhysicalGpuHandle hPhysicalGpu
NVAPI_INTERFACE | NvAPI_GPU_GetMemoryInfoEx (NvPhysicalGpuHandle hPhysicalGpu, NV_GPU_MEMORY_INFO_EX *pMemoryInfo)
NVAPI_INTERFACE | NvAPI_EnumPhysicalGPUs (NvPhysicalGpuHandle nvGPUHandle[NVAPI_MAX_PHYSICAL_GPUS], NvU32 *pGpuCount)
NV_DECLARE_HANDLE (NVDX_ObjectHandle)
NVAPI_INTERFACE | NvAPI_D3D_GetObjectHandleForResource (IUnknown *pDevice, IUnknown *pResource, NVDX_ObjectHandle *pHandle)

Variables

NV_DISPLAY_DRIVER_MEMORY_INFO * pMemoryInfo

Macro Definition Documentation

◆ __nvapi_deprecated_datatype

#define __nvapi_deprecated_datatype ( FirstRelease )

◆ __nvapi_deprecated_function

#define __nvapi_deprecated_function ( message )

◆ NV_DECLARE_HANDLE

#define NV_DECLARE_HANDLE ( name ) struct name##__ { int unused; }; typedef struct name##__ *name

◆ NV_FALSE

#define NV_FALSE ((NvBool)(0 != 0))

◆ NV_TRUE

#define NV_TRUE ((NvBool)(0 == 0))

◆ NvF32TONvU32

#define NvF32TONvU32 ( _pData ) *(NvU32 *)(_pData)

Macro to convert NvF32 to NvU32.

◆ NvU32TONvF32

#define NvU32TONvF32 ( _pData ) *(NvF32 *)(_pData)

Macro to convert NvU32 to NvF32.

Typedef Documentation

◆ NV_RECT

typedef struct _NV_RECT NV_RECT

◆ NvBool

typedef NvU8 NvBool

◆ NvF32

typedef float NvF32

◆ NvF64

typedef double NvF64

◆ NvS16

typedef signed short NvS16

◆ NvS32

typedef signed int NvS32

◆ NvS64

typedef __int64 NvS64

◆ NvS8

typedef signed char NvS8

◆ NvU16

typedef unsigned short NvU16

◆ NvU32

typedef unsigned long NvU32

◆ NvU64

typedef unsigned __int64 NvU64

◆ NvU8

typedef unsigned char NvU8

◆ temp_NvU32

typedef unsigned long temp_NvU32

Function Documentation

◆ NV_DECLARE_HANDLE()

NV_DECLARE_HANDLE ( NVDX_ObjectHandle )

Variable Documentation

◆ pMemoryInfo

NV_DISPLAY_DRIVER_MEMORY_INFO* pMemoryInfo


  • File List
  • Globals
Enumerations | Functions
nvapi_lite_d3dext.h File Reference
#include "nvapi_lite_salstart.h"
#include "nvapi_lite_common.h"
#include "nvapi_lite_salend.h"

Enumerations

enum NVAPI_DEVICE_FEATURE_LEVEL {
NVAPI_DEVICE_FEATURE_LEVEL_NULL = -1 , NVAPI_DEVICE_FEATURE_LEVEL_10_0 = 0 , NVAPI_DEVICE_FEATURE_LEVEL_10_0_PLUS = 1 , NVAPI_DEVICE_FEATURE_LEVEL_10_1 = 2 ,
NVAPI_DEVICE_FEATURE_LEVEL_11_0 = 3
}

Functions

NVAPI_INTERFACE | NvAPI_D3D11_CreateDevice (IDXGIAdapter *pAdapter, D3D_DRIVER_TYPE DriverType, HMODULE Software, UINT Flags, CONST D3D_FEATURE_LEVEL *pFeatureLevels, UINT FeatureLevels, UINT SDKVersion, ID3D11Device **ppDevice, D3D_FEATURE_LEVEL *pFeatureLevel, ID3D11DeviceContext **ppImmediateContext, NVAPI_DEVICE_FEATURE_LEVEL *pSupportedLevel)
NVAPI_INTERFACE | NvAPI_D3D11_CreateDeviceAndSwapChain (IDXGIAdapter *pAdapter, D3D_DRIVER_TYPE DriverType, HMODULE Software, UINT Flags, CONST D3D_FEATURE_LEVEL *pFeatureLevels, UINT FeatureLevels, UINT SDKVersion, CONST DXGI_SWAP_CHAIN_DESC *pSwapChainDesc, IDXGISwapChain **ppSwapChain, ID3D11Device **ppDevice, D3D_FEATURE_LEVEL *pFeatureLevel, ID3D11DeviceContext **ppImmediateContext, NVAPI_DEVICE_FEATURE_LEVEL *pSupportedLevel)
NVAPI_INTERFACE | NvAPI_D3D11_SetDepthBoundsTest (IUnknown *pDeviceOrContext, NvU32 bEnable, float fMinDepth, float fMaxDepth)


  • File List
  • Globals
nvapi_lite_salend.h File Reference


  • File List
  • Globals
Macros
nvapi_lite_salstart.h File Reference

Macros

#define | __nvapi_undef__ecount
#define | __ecount(size)
#define | __nvapi_undef__bcount
#define | __bcount(size)
#define | __nvapi_undef__in
#define | __in
#define | __nvapi_undef__in_ecount
#define | __in_ecount(size)
#define | __nvapi_undef__in_bcount
#define | __in_bcount(size)
#define | __nvapi_undef__in_z
#define | __in_z
#define | __nvapi_undef__in_ecount_z
#define | __in_ecount_z(size)
#define | __nvapi_undef__in_bcount_z
#define | __in_bcount_z(size)
#define | __nvapi_undef__in_nz
#define | __in_nz
#define | __nvapi_undef__in_ecount_nz
#define | __in_ecount_nz(size)
#define | __nvapi_undef__in_bcount_nz
#define | __in_bcount_nz(size)
#define | __nvapi_undef__out
#define | __out
#define | __nvapi_undef__out_ecount
#define | __out_ecount(size)
#define | __nvapi_undef__out_bcount
#define | __out_bcount(size)
#define | __nvapi_undef__out_ecount_part
#define | __out_ecount_part(size, length)
#define | __nvapi_undef__out_bcount_part
#define | __out_bcount_part(size, length)
#define | __nvapi_undef__out_ecount_full
#define | __out_ecount_full(size)
#define | __nvapi_undef__out_bcount_full
#define | __out_bcount_full(size)
#define | __nvapi_undef__out_z
#define | __out_z
#define | __nvapi_undef__out_z_opt
#define | __out_z_opt
#define | __nvapi_undef__out_ecount_z
#define | __out_ecount_z(size)
#define | __nvapi_undef__out_bcount_z
#define | __out_bcount_z(size)
#define | __nvapi_undef__out_ecount_part_z
#define | __out_ecount_part_z(size, length)
#define | __nvapi_undef__out_bcount_part_z
#define | __out_bcount_part_z(size, length)
#define | __nvapi_undef__out_ecount_full_z
#define | __out_ecount_full_z(size)
#define | __nvapi_undef__out_bcount_full_z
#define | __out_bcount_full_z(size)
#define | __nvapi_undef__out_nz
#define | __out_nz
#define | __nvapi_undef__out_nz_opt
#define | __out_nz_opt
#define | __nvapi_undef__out_ecount_nz
#define | __out_ecount_nz(size)
#define | __nvapi_undef__out_bcount_nz
#define | __out_bcount_nz(size)
#define | __nvapi_undef__inout
#define | __inout
#define | __nvapi_undef__inout_ecount
#define | __inout_ecount(size)
#define | __nvapi_undef__inout_bcount
#define | __inout_bcount(size)
#define | __nvapi_undef__inout_ecount_part
#define | __inout_ecount_part(size, length)
#define | __nvapi_undef__inout_bcount_part
#define | __inout_bcount_part(size, length)
#define | __nvapi_undef__inout_ecount_full
#define | __inout_ecount_full(size)
#define | __nvapi_undef__inout_bcount_full
#define | __inout_bcount_full(size)
#define | __nvapi_undef__inout_z
#define | __inout_z
#define | __nvapi_undef__inout_ecount_z
#define | __inout_ecount_z(size)
#define | __nvapi_undef__inout_bcount_z
#define | __inout_bcount_z(size)
#define | __nvapi_undef__inout_nz
#define | __inout_nz
#define | __nvapi_undef__inout_ecount_nz
#define | __inout_ecount_nz(size)
#define | __nvapi_undef__inout_bcount_nz
#define | __inout_bcount_nz(size)
#define | __nvapi_undef__ecount_opt
#define | __ecount_opt(size)
#define | __nvapi_undef__bcount_opt
#define | __bcount_opt(size)
#define | __nvapi_undef__in_opt
#define | __in_opt
#define | __nvapi_undef__in_ecount_opt
#define | __in_ecount_opt(size)
#define | __nvapi_undef__in_bcount_opt
#define | __in_bcount_opt(size)
#define | __nvapi_undef__in_z_opt
#define | __in_z_opt
#define | __nvapi_undef__in_ecount_z_opt
#define | __in_ecount_z_opt(size)
#define | __nvapi_undef__in_bcount_z_opt
#define | __in_bcount_z_opt(size)
#define | __nvapi_undef__in_nz_opt
#define | __in_nz_opt
#define | __nvapi_undef__in_ecount_nz_opt
#define | __in_ecount_nz_opt(size)
#define | __nvapi_undef__in_bcount_nz_opt
#define | __in_bcount_nz_opt(size)
#define | __nvapi_undef__out_opt
#define | __out_opt
#define | __nvapi_undef__out_ecount_opt
#define | __out_ecount_opt(size)
#define | __nvapi_undef__out_bcount_opt
#define | __out_bcount_opt(size)
#define | __nvapi_undef__out_ecount_part_opt
#define | __out_ecount_part_opt(size, length)
#define | __nvapi_undef__out_bcount_part_opt
#define | __out_bcount_part_opt(size, length)
#define | __nvapi_undef__out_ecount_full_opt
#define | __out_ecount_full_opt(size)
#define | __nvapi_undef__out_bcount_full_opt
#define | __out_bcount_full_opt(size)
#define | __nvapi_undef__out_ecount_z_opt
#define | __out_ecount_z_opt(size)
#define | __nvapi_undef__out_bcount_z_opt
#define | __out_bcount_z_opt(size)
#define | __nvapi_undef__out_ecount_part_z_opt
#define | __out_ecount_part_z_opt(size, length)
#define | __nvapi_undef__out_bcount_part_z_opt
#define | __out_bcount_part_z_opt(size, length)
#define | __nvapi_undef__out_ecount_full_z_opt
#define | __out_ecount_full_z_opt(size)
#define | __nvapi_undef__out_bcount_full_z_opt
#define | __out_bcount_full_z_opt(size)
#define | __nvapi_undef__out_ecount_nz_opt
#define | __out_ecount_nz_opt(size)
#define | __nvapi_undef__out_bcount_nz_opt
#define | __out_bcount_nz_opt(size)
#define | __nvapi_undef__inout_opt
#define | __inout_opt
#define | __nvapi_undef__inout_ecount_opt
#define | __inout_ecount_opt(size)
#define | __nvapi_undef__inout_bcount_opt
#define | __inout_bcount_opt(size)
#define | __nvapi_undef__inout_ecount_part_opt
#define | __inout_ecount_part_opt(size, length)
#define | __nvapi_undef__inout_bcount_part_opt
#define | __inout_bcount_part_opt(size, length)
#define | __nvapi_undef__inout_ecount_full_opt
#define | __inout_ecount_full_opt(size)
#define | __nvapi_undef__inout_bcount_full_opt
#define | __inout_bcount_full_opt(size)
#define | __nvapi_undef__inout_z_opt
#define | __inout_z_opt
#define | __nvapi_undef__inout_ecount_z_opt
#define | __inout_ecount_z_opt(size)
#define | __nvapi_undef__inout_bcount_z_opt
#define | __inout_bcount_z_opt(size)
#define | __nvapi_undef__inout_nz_opt
#define | __inout_nz_opt
#define | __nvapi_undef__inout_ecount_nz_opt
#define | __inout_ecount_nz_opt(size)
#define | __nvapi_undef__inout_bcount_nz_opt
#define | __inout_bcount_nz_opt(size)
#define | __nvapi_undef__deref_ecount
#define | __deref_ecount(size)
#define | __nvapi_undef__deref_bcount
#define | __deref_bcount(size)
#define | __nvapi_undef__deref_out
#define | __deref_out
#define | __nvapi_undef__deref_out_ecount
#define | __deref_out_ecount(size)
#define | __nvapi_undef__deref_out_bcount
#define | __deref_out_bcount(size)
#define | __nvapi_undef__deref_out_ecount_part
#define | __deref_out_ecount_part(size, length)
#define | __nvapi_undef__deref_out_bcount_part
#define | __deref_out_bcount_part(size, length)
#define | __nvapi_undef__deref_out_ecount_full
#define | __deref_out_ecount_full(size)
#define | __nvapi_undef__deref_out_bcount_full
#define | __deref_out_bcount_full(size)
#define | __nvapi_undef__deref_out_z
#define | __deref_out_z
#define | __nvapi_undef__deref_out_ecount_z
#define | __deref_out_ecount_z(size)
#define | __nvapi_undef__deref_out_bcount_z
#define | __deref_out_bcount_z(size)
#define | __nvapi_undef__deref_out_nz
#define | __deref_out_nz
#define | __nvapi_undef__deref_out_ecount_nz
#define | __deref_out_ecount_nz(size)
#define | __nvapi_undef__deref_out_bcount_nz
#define | __deref_out_bcount_nz(size)
#define | __nvapi_undef__deref_inout
#define | __deref_inout
#define | __nvapi_undef__deref_inout_z
#define | __deref_inout_z
#define | __nvapi_undef__deref_inout_ecount
#define | __deref_inout_ecount(size)
#define | __nvapi_undef__deref_inout_bcount
#define | __deref_inout_bcount(size)
#define | __nvapi_undef__deref_inout_ecount_part
#define | __deref_inout_ecount_part(size, length)
#define | __nvapi_undef__deref_inout_bcount_part
#define | __deref_inout_bcount_part(size, length)
#define | __nvapi_undef__deref_inout_ecount_full
#define | __deref_inout_ecount_full(size)
#define | __nvapi_undef__deref_inout_bcount_full
#define | __deref_inout_bcount_full(size)
#define | __nvapi_undef__deref_inout_ecount_z
#define | __deref_inout_ecount_z(size)
#define | __nvapi_undef__deref_inout_bcount_z
#define | __deref_inout_bcount_z(size)
#define | __nvapi_undef__deref_inout_nz
#define | __deref_inout_nz
#define | __nvapi_undef__deref_inout_ecount_nz
#define | __deref_inout_ecount_nz(size)
#define | __nvapi_undef__deref_inout_bcount_nz
#define | __deref_inout_bcount_nz(size)
#define | __nvapi_undef__deref_ecount_opt
#define | __deref_ecount_opt(size)
#define | __nvapi_undef__deref_bcount_opt
#define | __deref_bcount_opt(size)
#define | __nvapi_undef__deref_out_opt
#define | __deref_out_opt
#define | __nvapi_undef__deref_out_ecount_opt
#define | __deref_out_ecount_opt(size)
#define | __nvapi_undef__deref_out_bcount_opt
#define | __deref_out_bcount_opt(size)
#define | __nvapi_undef__deref_out_ecount_part_opt
#define | __deref_out_ecount_part_opt(size, length)
#define | __nvapi_undef__deref_out_bcount_part_opt
#define | __deref_out_bcount_part_opt(size, length)
#define | __nvapi_undef__deref_out_ecount_full_opt
#define | __deref_out_ecount_full_opt(size)
#define | __nvapi_undef__deref_out_bcount_full_opt
#define | __deref_out_bcount_full_opt(size)
#define | __nvapi_undef__deref_out_z_opt
#define | __deref_out_z_opt
#define | __nvapi_undef__deref_out_ecount_z_opt
#define | __deref_out_ecount_z_opt(size)
#define | __nvapi_undef__deref_out_bcount_z_opt
#define | __deref_out_bcount_z_opt(size)
#define | __nvapi_undef__deref_out_nz_opt
#define | __deref_out_nz_opt
#define | __nvapi_undef__deref_out_ecount_nz_opt
#define | __deref_out_ecount_nz_opt(size)
#define | __nvapi_undef__deref_out_bcount_nz_opt
#define | __deref_out_bcount_nz_opt(size)
#define | __nvapi_undef__deref_inout_opt
#define | __deref_inout_opt
#define | __nvapi_undef__deref_inout_ecount_opt
#define | __deref_inout_ecount_opt(size)
#define | __nvapi_undef__deref_inout_bcount_opt
#define | __deref_inout_bcount_opt(size)
#define | __nvapi_undef__deref_inout_ecount_part_opt
#define | __deref_inout_ecount_part_opt(size, length)
#define | __nvapi_undef__deref_inout_bcount_part_opt
#define | __deref_inout_bcount_part_opt(size, length)
#define | __nvapi_undef__deref_inout_ecount_full_opt
#define | __deref_inout_ecount_full_opt(size)
#define | __nvapi_undef__deref_inout_bcount_full_opt
#define | __deref_inout_bcount_full_opt(size)
#define | __nvapi_undef__deref_inout_z_opt
#define | __deref_inout_z_opt
#define | __nvapi_undef__deref_inout_ecount_z_opt
#define | __deref_inout_ecount_z_opt(size)
#define | __nvapi_undef__deref_inout_bcount_z_opt
#define | __deref_inout_bcount_z_opt(size)
#define | __nvapi_undef__deref_inout_nz_opt
#define | __deref_inout_nz_opt
#define | __nvapi_undef__deref_inout_ecount_nz_opt
#define | __deref_inout_ecount_nz_opt(size)
#define | __nvapi_undef__deref_inout_bcount_nz_opt
#define | __deref_inout_bcount_nz_opt(size)
#define | __nvapi_undef__deref_opt_ecount
#define | __deref_opt_ecount(size)
#define | __nvapi_undef__deref_opt_bcount
#define | __deref_opt_bcount(size)
#define | __nvapi_undef__deref_opt_out
#define | __deref_opt_out
#define | __nvapi_undef__deref_opt_out_z
#define | __deref_opt_out_z
#define | __nvapi_undef__deref_opt_out_ecount
#define | __deref_opt_out_ecount(size)
#define | __nvapi_undef__deref_opt_out_bcount
#define | __deref_opt_out_bcount(size)
#define | __nvapi_undef__deref_opt_out_ecount_part
#define | __deref_opt_out_ecount_part(size, length)
#define | __nvapi_undef__deref_opt_out_bcount_part
#define | __deref_opt_out_bcount_part(size, length)
#define | __nvapi_undef__deref_opt_out_ecount_full
#define | __deref_opt_out_ecount_full(size)
#define | __nvapi_undef__deref_opt_out_bcount_full
#define | __deref_opt_out_bcount_full(size)
#define | __nvapi_undef__deref_opt_inout
#define | __deref_opt_inout
#define | __nvapi_undef__deref_opt_inout_ecount
#define | __deref_opt_inout_ecount(size)
#define | __nvapi_undef__deref_opt_inout_bcount
#define | __deref_opt_inout_bcount(size)
#define | __nvapi_undef__deref_opt_inout_ecount_part
#define | __deref_opt_inout_ecount_part(size, length)
#define | __nvapi_undef__deref_opt_inout_bcount_part
#define | __deref_opt_inout_bcount_part(size, length)
#define | __nvapi_undef__deref_opt_inout_ecount_full
#define | __deref_opt_inout_ecount_full(size)
#define | __nvapi_undef__deref_opt_inout_bcount_full
#define | __deref_opt_inout_bcount_full(size)
#define | __nvapi_undef__deref_opt_inout_z
#define | __deref_opt_inout_z
#define | __nvapi_undef__deref_opt_inout_ecount_z
#define | __deref_opt_inout_ecount_z(size)
#define | __nvapi_undef__deref_opt_inout_bcount_z
#define | __deref_opt_inout_bcount_z(size)
#define | __nvapi_undef__deref_opt_inout_nz
#define | __deref_opt_inout_nz
#define | __nvapi_undef__deref_opt_inout_ecount_nz
#define | __deref_opt_inout_ecount_nz(size)
#define | __nvapi_undef__deref_opt_inout_bcount_nz
#define | __deref_opt_inout_bcount_nz(size)
#define | __nvapi_undef__deref_opt_ecount_opt
#define | __deref_opt_ecount_opt(size)
#define | __nvapi_undef__deref_opt_bcount_opt
#define | __deref_opt_bcount_opt(size)
#define | __nvapi_undef__deref_opt_out_opt
#define | __deref_opt_out_opt
#define | __nvapi_undef__deref_opt_out_ecount_opt
#define | __deref_opt_out_ecount_opt(size)
#define | __nvapi_undef__deref_opt_out_bcount_opt
#define | __deref_opt_out_bcount_opt(size)
#define | __nvapi_undef__deref_opt_out_ecount_part_opt
#define | __deref_opt_out_ecount_part_opt(size, length)
#define | __nvapi_undef__deref_opt_out_bcount_part_opt
#define | __deref_opt_out_bcount_part_opt(size, length)
#define | __nvapi_undef__deref_opt_out_ecount_full_opt
#define | __deref_opt_out_ecount_full_opt(size)
#define | __nvapi_undef__deref_opt_out_bcount_full_opt
#define | __deref_opt_out_bcount_full_opt(size)
#define | __nvapi_undef__deref_opt_out_z_opt
#define | __deref_opt_out_z_opt
#define | __nvapi_undef__deref_opt_out_ecount_z_opt
#define | __deref_opt_out_ecount_z_opt(size)
#define | __nvapi_undef__deref_opt_out_bcount_z_opt
#define | __deref_opt_out_bcount_z_opt(size)
#define | __nvapi_undef__deref_opt_out_nz_opt
#define | __deref_opt_out_nz_opt
#define | __nvapi_undef__deref_opt_out_ecount_nz_opt
#define | __deref_opt_out_ecount_nz_opt(size)
#define | __nvapi_undef__deref_opt_out_bcount_nz_opt
#define | __deref_opt_out_bcount_nz_opt(size)
#define | __nvapi_undef__deref_opt_inout_opt
#define | __deref_opt_inout_opt
#define | __nvapi_undef__deref_opt_inout_ecount_opt
#define | __deref_opt_inout_ecount_opt(size)
#define | __nvapi_undef__deref_opt_inout_bcount_opt
#define | __deref_opt_inout_bcount_opt(size)
#define | __nvapi_undef__deref_opt_inout_ecount_part_opt
#define | __deref_opt_inout_ecount_part_opt(size, length)
#define | __nvapi_undef__deref_opt_inout_bcount_part_opt
#define | __deref_opt_inout_bcount_part_opt(size, length)
#define | __nvapi_undef__deref_opt_inout_ecount_full_opt
#define | __deref_opt_inout_ecount_full_opt(size)
#define | __nvapi_undef__deref_opt_inout_bcount_full_opt
#define | __deref_opt_inout_bcount_full_opt(size)
#define | __nvapi_undef__deref_opt_inout_z_opt
#define | __deref_opt_inout_z_opt
#define | __nvapi_undef__deref_opt_inout_ecount_z_opt
#define | __deref_opt_inout_ecount_z_opt(size)
#define | __nvapi_undef__deref_opt_inout_bcount_z_opt
#define | __deref_opt_inout_bcount_z_opt(size)
#define | __nvapi_undef__deref_opt_inout_nz_opt
#define | __deref_opt_inout_nz_opt
#define | __nvapi_undef__deref_opt_inout_ecount_nz_opt
#define | __deref_opt_inout_ecount_nz_opt(size)
#define | __nvapi_undef__deref_opt_inout_bcount_nz_opt
#define | __deref_opt_inout_bcount_nz_opt(size)
#define | __nvapi_success
#define | __success(epxr)
#define | __nvapi__Ret_notnull_
#define | _Ret_notnull_
#define | __nvapi__Post_writable_byte_size_
#define | _Post_writable_byte_size_(n)
#define | __nvapi_Outptr_
#define | _Outptr_
#define | NVAPI_INTERFACE extern __success(return == NVAPI_OK) NvAPI_Status __cdecl

Macro Definition Documentation

◆ __bcount

#define __bcount ( size )

◆ __bcount_opt

#define __bcount_opt ( size )

◆ __deref_bcount

#define __deref_bcount ( size )

◆ __deref_bcount_opt

#define __deref_bcount_opt ( size )

◆ __deref_ecount

#define __deref_ecount ( size )

◆ __deref_ecount_opt

#define __deref_ecount_opt ( size )

◆ __deref_inout

#define __deref_inout

◆ __deref_inout_bcount

#define __deref_inout_bcount ( size )

◆ __deref_inout_bcount_full

#define __deref_inout_bcount_full ( size )

◆ __deref_inout_bcount_full_opt

#define __deref_inout_bcount_full_opt ( size )

◆ __deref_inout_bcount_nz

#define __deref_inout_bcount_nz ( size )

◆ __deref_inout_bcount_nz_opt

#define __deref_inout_bcount_nz_opt ( size )

◆ __deref_inout_bcount_opt

#define __deref_inout_bcount_opt ( size )

◆ __deref_inout_bcount_part

#define __deref_inout_bcount_part | ( | size,
 |  | length
 | ) |

◆ __deref_inout_bcount_part_opt

#define __deref_inout_bcount_part_opt | ( | size,
 |  | length
 | ) |

◆ __deref_inout_bcount_z

#define __deref_inout_bcount_z ( size )

◆ __deref_inout_bcount_z_opt

#define __deref_inout_bcount_z_opt ( size )

◆ __deref_inout_ecount

#define __deref_inout_ecount ( size )

◆ __deref_inout_ecount_full

#define __deref_inout_ecount_full ( size )

◆ __deref_inout_ecount_full_opt

#define __deref_inout_ecount_full_opt ( size )

◆ __deref_inout_ecount_nz

#define __deref_inout_ecount_nz ( size )

◆ __deref_inout_ecount_nz_opt

#define __deref_inout_ecount_nz_opt ( size )

◆ __deref_inout_ecount_opt

#define __deref_inout_ecount_opt ( size )

◆ __deref_inout_ecount_part

#define __deref_inout_ecount_part | ( | size,
 |  | length
 | ) |

◆ __deref_inout_ecount_part_opt

#define __deref_inout_ecount_part_opt | ( | size,
 |  | length
 | ) |

◆ __deref_inout_ecount_z

#define __deref_inout_ecount_z ( size )

◆ __deref_inout_ecount_z_opt

#define __deref_inout_ecount_z_opt ( size )

◆ __deref_inout_nz

#define __deref_inout_nz

◆ __deref_inout_nz_opt

#define __deref_inout_nz_opt

◆ __deref_inout_opt

#define __deref_inout_opt

◆ __deref_inout_z

#define __deref_inout_z

◆ __deref_inout_z_opt

#define __deref_inout_z_opt

◆ __deref_opt_bcount

#define __deref_opt_bcount ( size )

◆ __deref_opt_bcount_opt

#define __deref_opt_bcount_opt ( size )

◆ __deref_opt_ecount

#define __deref_opt_ecount ( size )

◆ __deref_opt_ecount_opt

#define __deref_opt_ecount_opt ( size )

◆ __deref_opt_inout

#define __deref_opt_inout

◆ __deref_opt_inout_bcount

#define __deref_opt_inout_bcount ( size )

◆ __deref_opt_inout_bcount_full

#define __deref_opt_inout_bcount_full ( size )

◆ __deref_opt_inout_bcount_full_opt

#define __deref_opt_inout_bcount_full_opt ( size )

◆ __deref_opt_inout_bcount_nz

#define __deref_opt_inout_bcount_nz ( size )

◆ __deref_opt_inout_bcount_nz_opt

#define __deref_opt_inout_bcount_nz_opt ( size )

◆ __deref_opt_inout_bcount_opt

#define __deref_opt_inout_bcount_opt ( size )

◆ __deref_opt_inout_bcount_part

#define __deref_opt_inout_bcount_part | ( | size,
 |  | length
 | ) |

◆ __deref_opt_inout_bcount_part_opt

#define __deref_opt_inout_bcount_part_opt | ( | size,
 |  | length
 | ) |

◆ __deref_opt_inout_bcount_z

#define __deref_opt_inout_bcount_z ( size )

◆ __deref_opt_inout_bcount_z_opt

#define __deref_opt_inout_bcount_z_opt ( size )

◆ __deref_opt_inout_ecount

#define __deref_opt_inout_ecount ( size )

◆ __deref_opt_inout_ecount_full

#define __deref_opt_inout_ecount_full ( size )

◆ __deref_opt_inout_ecount_full_opt

#define __deref_opt_inout_ecount_full_opt ( size )

◆ __deref_opt_inout_ecount_nz

#define __deref_opt_inout_ecount_nz ( size )

◆ __deref_opt_inout_ecount_nz_opt

#define __deref_opt_inout_ecount_nz_opt ( size )

◆ __deref_opt_inout_ecount_opt

#define __deref_opt_inout_ecount_opt ( size )

◆ __deref_opt_inout_ecount_part

#define __deref_opt_inout_ecount_part | ( | size,
 |  | length
 | ) |

◆ __deref_opt_inout_ecount_part_opt

#define __deref_opt_inout_ecount_part_opt | ( | size,
 |  | length
 | ) |

◆ __deref_opt_inout_ecount_z

#define __deref_opt_inout_ecount_z ( size )

◆ __deref_opt_inout_ecount_z_opt

#define __deref_opt_inout_ecount_z_opt ( size )

◆ __deref_opt_inout_nz

#define __deref_opt_inout_nz

◆ __deref_opt_inout_nz_opt

#define __deref_opt_inout_nz_opt

◆ __deref_opt_inout_opt

#define __deref_opt_inout_opt

◆ __deref_opt_inout_z

#define __deref_opt_inout_z

◆ __deref_opt_inout_z_opt

#define __deref_opt_inout_z_opt

◆ __deref_opt_out

#define __deref_opt_out

◆ __deref_opt_out_bcount

#define __deref_opt_out_bcount ( size )

◆ __deref_opt_out_bcount_full

#define __deref_opt_out_bcount_full ( size )

◆ __deref_opt_out_bcount_full_opt

#define __deref_opt_out_bcount_full_opt ( size )

◆ __deref_opt_out_bcount_nz_opt

#define __deref_opt_out_bcount_nz_opt ( size )

◆ __deref_opt_out_bcount_opt

#define __deref_opt_out_bcount_opt ( size )

◆ __deref_opt_out_bcount_part

#define __deref_opt_out_bcount_part | ( | size,
 |  | length
 | ) |

◆ __deref_opt_out_bcount_part_opt

#define __deref_opt_out_bcount_part_opt | ( | size,
 |  | length
 | ) |

◆ __deref_opt_out_bcount_z_opt

#define __deref_opt_out_bcount_z_opt ( size )

◆ __deref_opt_out_ecount

#define __deref_opt_out_ecount ( size )

◆ __deref_opt_out_ecount_full

#define __deref_opt_out_ecount_full ( size )

◆ __deref_opt_out_ecount_full_opt

#define __deref_opt_out_ecount_full_opt ( size )

◆ __deref_opt_out_ecount_nz_opt

#define __deref_opt_out_ecount_nz_opt ( size )

◆ __deref_opt_out_ecount_opt

#define __deref_opt_out_ecount_opt ( size )

◆ __deref_opt_out_ecount_part

#define __deref_opt_out_ecount_part | ( | size,
 |  | length
 | ) |

◆ __deref_opt_out_ecount_part_opt

#define __deref_opt_out_ecount_part_opt | ( | size,
 |  | length
 | ) |

◆ __deref_opt_out_ecount_z_opt

#define __deref_opt_out_ecount_z_opt ( size )

◆ __deref_opt_out_nz_opt

#define __deref_opt_out_nz_opt

◆ __deref_opt_out_opt

#define __deref_opt_out_opt

◆ __deref_opt_out_z

#define __deref_opt_out_z

◆ __deref_opt_out_z_opt

#define __deref_opt_out_z_opt

◆ __deref_out

#define __deref_out

◆ __deref_out_bcount

#define __deref_out_bcount ( size )

◆ __deref_out_bcount_full

#define __deref_out_bcount_full ( size )

◆ __deref_out_bcount_full_opt

#define __deref_out_bcount_full_opt ( size )

◆ __deref_out_bcount_nz

#define __deref_out_bcount_nz ( size )

◆ __deref_out_bcount_nz_opt

#define __deref_out_bcount_nz_opt ( size )

◆ __deref_out_bcount_opt

#define __deref_out_bcount_opt ( size )

◆ __deref_out_bcount_part

#define __deref_out_bcount_part | ( | size,
 |  | length
 | ) |

◆ __deref_out_bcount_part_opt

#define __deref_out_bcount_part_opt | ( | size,
 |  | length
 | ) |

◆ __deref_out_bcount_z

#define __deref_out_bcount_z ( size )

◆ __deref_out_bcount_z_opt

#define __deref_out_bcount_z_opt ( size )

◆ __deref_out_ecount

#define __deref_out_ecount ( size )

◆ __deref_out_ecount_full

#define __deref_out_ecount_full ( size )

◆ __deref_out_ecount_full_opt

#define __deref_out_ecount_full_opt ( size )

◆ __deref_out_ecount_nz

#define __deref_out_ecount_nz ( size )

◆ __deref_out_ecount_nz_opt

#define __deref_out_ecount_nz_opt ( size )

◆ __deref_out_ecount_opt

#define __deref_out_ecount_opt ( size )

◆ __deref_out_ecount_part

#define __deref_out_ecount_part | ( | size,
 |  | length
 | ) |

◆ __deref_out_ecount_part_opt

#define __deref_out_ecount_part_opt | ( | size,
 |  | length
 | ) |

◆ __deref_out_ecount_z

#define __deref_out_ecount_z ( size )

◆ __deref_out_ecount_z_opt

#define __deref_out_ecount_z_opt ( size )

◆ __deref_out_nz

#define __deref_out_nz

◆ __deref_out_nz_opt

#define __deref_out_nz_opt

◆ __deref_out_opt

#define __deref_out_opt

◆ __deref_out_z

#define __deref_out_z

◆ __deref_out_z_opt

#define __deref_out_z_opt

◆ __ecount

#define __ecount ( size )

◆ __ecount_opt

#define __ecount_opt ( size )

◆ __in

#define __in

◆ __in_bcount

#define __in_bcount ( size )

◆ __in_bcount_nz

#define __in_bcount_nz ( size )

◆ __in_bcount_nz_opt

#define __in_bcount_nz_opt ( size )

◆ __in_bcount_opt

#define __in_bcount_opt ( size )

◆ __in_bcount_z

#define __in_bcount_z ( size )

◆ __in_bcount_z_opt

#define __in_bcount_z_opt ( size )

◆ __in_ecount

#define __in_ecount ( size )

◆ __in_ecount_nz

#define __in_ecount_nz ( size )

◆ __in_ecount_nz_opt

#define __in_ecount_nz_opt ( size )

◆ __in_ecount_opt

#define __in_ecount_opt ( size )

◆ __in_ecount_z

#define __in_ecount_z ( size )

◆ __in_ecount_z_opt

#define __in_ecount_z_opt ( size )

◆ __in_nz

#define __in_nz

◆ __in_nz_opt

#define __in_nz_opt

◆ __in_opt

#define __in_opt

◆ __in_z

#define __in_z

◆ __in_z_opt

#define __in_z_opt

◆ __inout

#define __inout

◆ __inout_bcount

#define __inout_bcount ( size )

◆ __inout_bcount_full

#define __inout_bcount_full ( size )

◆ __inout_bcount_full_opt

#define __inout_bcount_full_opt ( size )

◆ __inout_bcount_nz

#define __inout_bcount_nz ( size )

◆ __inout_bcount_nz_opt

#define __inout_bcount_nz_opt ( size )

◆ __inout_bcount_opt

#define __inout_bcount_opt ( size )

◆ __inout_bcount_part

#define __inout_bcount_part | ( | size,
 |  | length
 | ) |

◆ __inout_bcount_part_opt

#define __inout_bcount_part_opt | ( | size,
 |  | length
 | ) |

◆ __inout_bcount_z

#define __inout_bcount_z ( size )

◆ __inout_bcount_z_opt

#define __inout_bcount_z_opt ( size )

◆ __inout_ecount

#define __inout_ecount ( size )

◆ __inout_ecount_full

#define __inout_ecount_full ( size )

◆ __inout_ecount_full_opt

#define __inout_ecount_full_opt ( size )

◆ __inout_ecount_nz

#define __inout_ecount_nz ( size )

◆ __inout_ecount_nz_opt

#define __inout_ecount_nz_opt ( size )

◆ __inout_ecount_opt

#define __inout_ecount_opt ( size )

◆ __inout_ecount_part

#define __inout_ecount_part | ( | size,
 |  | length
 | ) |

◆ __inout_ecount_part_opt

#define __inout_ecount_part_opt | ( | size,
 |  | length
 | ) |

◆ __inout_ecount_z

#define __inout_ecount_z ( size )

◆ __inout_ecount_z_opt

#define __inout_ecount_z_opt ( size )

◆ __inout_nz

#define __inout_nz

◆ __inout_nz_opt

#define __inout_nz_opt

◆ __inout_opt

#define __inout_opt

◆ __inout_z

#define __inout_z

◆ __inout_z_opt

#define __inout_z_opt

◆ __nvapi__Post_writable_byte_size_

#define __nvapi__Post_writable_byte_size_

◆ __nvapi__Ret_notnull_

#define __nvapi__Ret_notnull_

◆ __nvapi_Outptr_

#define __nvapi_Outptr_

◆ __nvapi_success

#define __nvapi_success

◆ __nvapi_undef__bcount

#define __nvapi_undef__bcount

◆ __nvapi_undef__bcount_opt

#define __nvapi_undef__bcount_opt

◆ __nvapi_undef__deref_bcount

#define __nvapi_undef__deref_bcount

◆ __nvapi_undef__deref_bcount_opt

#define __nvapi_undef__deref_bcount_opt

◆ __nvapi_undef__deref_ecount

#define __nvapi_undef__deref_ecount

◆ __nvapi_undef__deref_ecount_opt

#define __nvapi_undef__deref_ecount_opt

◆ __nvapi_undef__deref_inout

#define __nvapi_undef__deref_inout

◆ __nvapi_undef__deref_inout_bcount

#define __nvapi_undef__deref_inout_bcount

◆ __nvapi_undef__deref_inout_bcount_full

#define __nvapi_undef__deref_inout_bcount_full

◆ __nvapi_undef__deref_inout_bcount_full_opt

#define __nvapi_undef__deref_inout_bcount_full_opt

◆ __nvapi_undef__deref_inout_bcount_nz

#define __nvapi_undef__deref_inout_bcount_nz

◆ __nvapi_undef__deref_inout_bcount_nz_opt

#define __nvapi_undef__deref_inout_bcount_nz_opt

◆ __nvapi_undef__deref_inout_bcount_opt

#define __nvapi_undef__deref_inout_bcount_opt

◆ __nvapi_undef__deref_inout_bcount_part

#define __nvapi_undef__deref_inout_bcount_part

◆ __nvapi_undef__deref_inout_bcount_part_opt

#define __nvapi_undef__deref_inout_bcount_part_opt

◆ __nvapi_undef__deref_inout_bcount_z

#define __nvapi_undef__deref_inout_bcount_z

◆ __nvapi_undef__deref_inout_bcount_z_opt

#define __nvapi_undef__deref_inout_bcount_z_opt

◆ __nvapi_undef__deref_inout_ecount

#define __nvapi_undef__deref_inout_ecount

◆ __nvapi_undef__deref_inout_ecount_full

#define __nvapi_undef__deref_inout_ecount_full

◆ __nvapi_undef__deref_inout_ecount_full_opt

#define __nvapi_undef__deref_inout_ecount_full_opt

◆ __nvapi_undef__deref_inout_ecount_nz

#define __nvapi_undef__deref_inout_ecount_nz

◆ __nvapi_undef__deref_inout_ecount_nz_opt

#define __nvapi_undef__deref_inout_ecount_nz_opt

◆ __nvapi_undef__deref_inout_ecount_opt

#define __nvapi_undef__deref_inout_ecount_opt

◆ __nvapi_undef__deref_inout_ecount_part

#define __nvapi_undef__deref_inout_ecount_part

◆ __nvapi_undef__deref_inout_ecount_part_opt

#define __nvapi_undef__deref_inout_ecount_part_opt

◆ __nvapi_undef__deref_inout_ecount_z

#define __nvapi_undef__deref_inout_ecount_z

◆ __nvapi_undef__deref_inout_ecount_z_opt

#define __nvapi_undef__deref_inout_ecount_z_opt

◆ __nvapi_undef__deref_inout_nz

#define __nvapi_undef__deref_inout_nz

◆ __nvapi_undef__deref_inout_nz_opt

#define __nvapi_undef__deref_inout_nz_opt

◆ __nvapi_undef__deref_inout_opt

#define __nvapi_undef__deref_inout_opt

◆ __nvapi_undef__deref_inout_z

#define __nvapi_undef__deref_inout_z

◆ __nvapi_undef__deref_inout_z_opt

#define __nvapi_undef__deref_inout_z_opt

◆ __nvapi_undef__deref_opt_bcount

#define __nvapi_undef__deref_opt_bcount

◆ __nvapi_undef__deref_opt_bcount_opt

#define __nvapi_undef__deref_opt_bcount_opt

◆ __nvapi_undef__deref_opt_ecount

#define __nvapi_undef__deref_opt_ecount

◆ __nvapi_undef__deref_opt_ecount_opt

#define __nvapi_undef__deref_opt_ecount_opt

◆ __nvapi_undef__deref_opt_inout

#define __nvapi_undef__deref_opt_inout

◆ __nvapi_undef__deref_opt_inout_bcount

#define __nvapi_undef__deref_opt_inout_bcount

◆ __nvapi_undef__deref_opt_inout_bcount_full

#define __nvapi_undef__deref_opt_inout_bcount_full

◆ __nvapi_undef__deref_opt_inout_bcount_full_opt

#define __nvapi_undef__deref_opt_inout_bcount_full_opt

◆ __nvapi_undef__deref_opt_inout_bcount_nz

#define __nvapi_undef__deref_opt_inout_bcount_nz

◆ __nvapi_undef__deref_opt_inout_bcount_nz_opt

#define __nvapi_undef__deref_opt_inout_bcount_nz_opt

◆ __nvapi_undef__deref_opt_inout_bcount_opt

#define __nvapi_undef__deref_opt_inout_bcount_opt

◆ __nvapi_undef__deref_opt_inout_bcount_part

#define __nvapi_undef__deref_opt_inout_bcount_part

◆ __nvapi_undef__deref_opt_inout_bcount_part_opt

#define __nvapi_undef__deref_opt_inout_bcount_part_opt

◆ __nvapi_undef__deref_opt_inout_bcount_z

#define __nvapi_undef__deref_opt_inout_bcount_z

◆ __nvapi_undef__deref_opt_inout_bcount_z_opt

#define __nvapi_undef__deref_opt_inout_bcount_z_opt

◆ __nvapi_undef__deref_opt_inout_ecount

#define __nvapi_undef__deref_opt_inout_ecount

◆ __nvapi_undef__deref_opt_inout_ecount_full

#define __nvapi_undef__deref_opt_inout_ecount_full

◆ __nvapi_undef__deref_opt_inout_ecount_full_opt

#define __nvapi_undef__deref_opt_inout_ecount_full_opt

◆ __nvapi_undef__deref_opt_inout_ecount_nz

#define __nvapi_undef__deref_opt_inout_ecount_nz

◆ __nvapi_undef__deref_opt_inout_ecount_nz_opt

#define __nvapi_undef__deref_opt_inout_ecount_nz_opt

◆ __nvapi_undef__deref_opt_inout_ecount_opt

#define __nvapi_undef__deref_opt_inout_ecount_opt

◆ __nvapi_undef__deref_opt_inout_ecount_part

#define __nvapi_undef__deref_opt_inout_ecount_part

◆ __nvapi_undef__deref_opt_inout_ecount_part_opt

#define __nvapi_undef__deref_opt_inout_ecount_part_opt

◆ __nvapi_undef__deref_opt_inout_ecount_z

#define __nvapi_undef__deref_opt_inout_ecount_z

◆ __nvapi_undef__deref_opt_inout_ecount_z_opt

#define __nvapi_undef__deref_opt_inout_ecount_z_opt

◆ __nvapi_undef__deref_opt_inout_nz

#define __nvapi_undef__deref_opt_inout_nz

◆ __nvapi_undef__deref_opt_inout_nz_opt

#define __nvapi_undef__deref_opt_inout_nz_opt

◆ __nvapi_undef__deref_opt_inout_opt

#define __nvapi_undef__deref_opt_inout_opt

◆ __nvapi_undef__deref_opt_inout_z

#define __nvapi_undef__deref_opt_inout_z

◆ __nvapi_undef__deref_opt_inout_z_opt

#define __nvapi_undef__deref_opt_inout_z_opt

◆ __nvapi_undef__deref_opt_out

#define __nvapi_undef__deref_opt_out

◆ __nvapi_undef__deref_opt_out_bcount

#define __nvapi_undef__deref_opt_out_bcount

◆ __nvapi_undef__deref_opt_out_bcount_full

#define __nvapi_undef__deref_opt_out_bcount_full

◆ __nvapi_undef__deref_opt_out_bcount_full_opt

#define __nvapi_undef__deref_opt_out_bcount_full_opt

◆ __nvapi_undef__deref_opt_out_bcount_nz_opt

#define __nvapi_undef__deref_opt_out_bcount_nz_opt

◆ __nvapi_undef__deref_opt_out_bcount_opt

#define __nvapi_undef__deref_opt_out_bcount_opt

◆ __nvapi_undef__deref_opt_out_bcount_part

#define __nvapi_undef__deref_opt_out_bcount_part

◆ __nvapi_undef__deref_opt_out_bcount_part_opt

#define __nvapi_undef__deref_opt_out_bcount_part_opt

◆ __nvapi_undef__deref_opt_out_bcount_z_opt

#define __nvapi_undef__deref_opt_out_bcount_z_opt

◆ __nvapi_undef__deref_opt_out_ecount

#define __nvapi_undef__deref_opt_out_ecount

◆ __nvapi_undef__deref_opt_out_ecount_full

#define __nvapi_undef__deref_opt_out_ecount_full

◆ __nvapi_undef__deref_opt_out_ecount_full_opt

#define __nvapi_undef__deref_opt_out_ecount_full_opt

◆ __nvapi_undef__deref_opt_out_ecount_nz_opt

#define __nvapi_undef__deref_opt_out_ecount_nz_opt

◆ __nvapi_undef__deref_opt_out_ecount_opt

#define __nvapi_undef__deref_opt_out_ecount_opt

◆ __nvapi_undef__deref_opt_out_ecount_part

#define __nvapi_undef__deref_opt_out_ecount_part

◆ __nvapi_undef__deref_opt_out_ecount_part_opt

#define __nvapi_undef__deref_opt_out_ecount_part_opt

◆ __nvapi_undef__deref_opt_out_ecount_z_opt

#define __nvapi_undef__deref_opt_out_ecount_z_opt

◆ __nvapi_undef__deref_opt_out_nz_opt

#define __nvapi_undef__deref_opt_out_nz_opt

◆ __nvapi_undef__deref_opt_out_opt

#define __nvapi_undef__deref_opt_out_opt

◆ __nvapi_undef__deref_opt_out_z

#define __nvapi_undef__deref_opt_out_z

◆ __nvapi_undef__deref_opt_out_z_opt

#define __nvapi_undef__deref_opt_out_z_opt

◆ __nvapi_undef__deref_out

#define __nvapi_undef__deref_out

◆ __nvapi_undef__deref_out_bcount

#define __nvapi_undef__deref_out_bcount

◆ __nvapi_undef__deref_out_bcount_full

#define __nvapi_undef__deref_out_bcount_full

◆ __nvapi_undef__deref_out_bcount_full_opt

#define __nvapi_undef__deref_out_bcount_full_opt

◆ __nvapi_undef__deref_out_bcount_nz

#define __nvapi_undef__deref_out_bcount_nz

◆ __nvapi_undef__deref_out_bcount_nz_opt

#define __nvapi_undef__deref_out_bcount_nz_opt

◆ __nvapi_undef__deref_out_bcount_opt

#define __nvapi_undef__deref_out_bcount_opt

◆ __nvapi_undef__deref_out_bcount_part

#define __nvapi_undef__deref_out_bcount_part

◆ __nvapi_undef__deref_out_bcount_part_opt

#define __nvapi_undef__deref_out_bcount_part_opt

◆ __nvapi_undef__deref_out_bcount_z

#define __nvapi_undef__deref_out_bcount_z

◆ __nvapi_undef__deref_out_bcount_z_opt

#define __nvapi_undef__deref_out_bcount_z_opt

◆ __nvapi_undef__deref_out_ecount

#define __nvapi_undef__deref_out_ecount

◆ __nvapi_undef__deref_out_ecount_full

#define __nvapi_undef__deref_out_ecount_full

◆ __nvapi_undef__deref_out_ecount_full_opt

#define __nvapi_undef__deref_out_ecount_full_opt

◆ __nvapi_undef__deref_out_ecount_nz

#define __nvapi_undef__deref_out_ecount_nz

◆ __nvapi_undef__deref_out_ecount_nz_opt

#define __nvapi_undef__deref_out_ecount_nz_opt

◆ __nvapi_undef__deref_out_ecount_opt

#define __nvapi_undef__deref_out_ecount_opt

◆ __nvapi_undef__deref_out_ecount_part

#define __nvapi_undef__deref_out_ecount_part

◆ __nvapi_undef__deref_out_ecount_part_opt

#define __nvapi_undef__deref_out_ecount_part_opt

◆ __nvapi_undef__deref_out_ecount_z

#define __nvapi_undef__deref_out_ecount_z

◆ __nvapi_undef__deref_out_ecount_z_opt

#define __nvapi_undef__deref_out_ecount_z_opt

◆ __nvapi_undef__deref_out_nz

#define __nvapi_undef__deref_out_nz

◆ __nvapi_undef__deref_out_nz_opt

#define __nvapi_undef__deref_out_nz_opt

◆ __nvapi_undef__deref_out_opt

#define __nvapi_undef__deref_out_opt

◆ __nvapi_undef__deref_out_z

#define __nvapi_undef__deref_out_z

◆ __nvapi_undef__deref_out_z_opt

#define __nvapi_undef__deref_out_z_opt

◆ __nvapi_undef__ecount

#define __nvapi_undef__ecount

◆ __nvapi_undef__ecount_opt

#define __nvapi_undef__ecount_opt

◆ __nvapi_undef__in

#define __nvapi_undef__in

◆ __nvapi_undef__in_bcount

#define __nvapi_undef__in_bcount

◆ __nvapi_undef__in_bcount_nz

#define __nvapi_undef__in_bcount_nz

◆ __nvapi_undef__in_bcount_nz_opt

#define __nvapi_undef__in_bcount_nz_opt

◆ __nvapi_undef__in_bcount_opt

#define __nvapi_undef__in_bcount_opt

◆ __nvapi_undef__in_bcount_z

#define __nvapi_undef__in_bcount_z

◆ __nvapi_undef__in_bcount_z_opt

#define __nvapi_undef__in_bcount_z_opt

◆ __nvapi_undef__in_ecount

#define __nvapi_undef__in_ecount

◆ __nvapi_undef__in_ecount_nz

#define __nvapi_undef__in_ecount_nz

◆ __nvapi_undef__in_ecount_nz_opt

#define __nvapi_undef__in_ecount_nz_opt

◆ __nvapi_undef__in_ecount_opt

#define __nvapi_undef__in_ecount_opt

◆ __nvapi_undef__in_ecount_z

#define __nvapi_undef__in_ecount_z

◆ __nvapi_undef__in_ecount_z_opt

#define __nvapi_undef__in_ecount_z_opt

◆ __nvapi_undef__in_nz

#define __nvapi_undef__in_nz

◆ __nvapi_undef__in_nz_opt

#define __nvapi_undef__in_nz_opt

◆ __nvapi_undef__in_opt

#define __nvapi_undef__in_opt

◆ __nvapi_undef__in_z

#define __nvapi_undef__in_z

◆ __nvapi_undef__in_z_opt

#define __nvapi_undef__in_z_opt

◆ __nvapi_undef__inout

#define __nvapi_undef__inout

◆ __nvapi_undef__inout_bcount

#define __nvapi_undef__inout_bcount

◆ __nvapi_undef__inout_bcount_full

#define __nvapi_undef__inout_bcount_full

◆ __nvapi_undef__inout_bcount_full_opt

#define __nvapi_undef__inout_bcount_full_opt

◆ __nvapi_undef__inout_bcount_nz

#define __nvapi_undef__inout_bcount_nz

◆ __nvapi_undef__inout_bcount_nz_opt

#define __nvapi_undef__inout_bcount_nz_opt

◆ __nvapi_undef__inout_bcount_opt

#define __nvapi_undef__inout_bcount_opt

◆ __nvapi_undef__inout_bcount_part

#define __nvapi_undef__inout_bcount_part

◆ __nvapi_undef__inout_bcount_part_opt

#define __nvapi_undef__inout_bcount_part_opt

◆ __nvapi_undef__inout_bcount_z

#define __nvapi_undef__inout_bcount_z

◆ __nvapi_undef__inout_bcount_z_opt

#define __nvapi_undef__inout_bcount_z_opt

◆ __nvapi_undef__inout_ecount

#define __nvapi_undef__inout_ecount

◆ __nvapi_undef__inout_ecount_full

#define __nvapi_undef__inout_ecount_full

◆ __nvapi_undef__inout_ecount_full_opt

#define __nvapi_undef__inout_ecount_full_opt

◆ __nvapi_undef__inout_ecount_nz

#define __nvapi_undef__inout_ecount_nz

◆ __nvapi_undef__inout_ecount_nz_opt

#define __nvapi_undef__inout_ecount_nz_opt

◆ __nvapi_undef__inout_ecount_opt

#define __nvapi_undef__inout_ecount_opt

◆ __nvapi_undef__inout_ecount_part

#define __nvapi_undef__inout_ecount_part

◆ __nvapi_undef__inout_ecount_part_opt

#define __nvapi_undef__inout_ecount_part_opt

◆ __nvapi_undef__inout_ecount_z

#define __nvapi_undef__inout_ecount_z

◆ __nvapi_undef__inout_ecount_z_opt

#define __nvapi_undef__inout_ecount_z_opt

◆ __nvapi_undef__inout_nz

#define __nvapi_undef__inout_nz

◆ __nvapi_undef__inout_nz_opt

#define __nvapi_undef__inout_nz_opt

◆ __nvapi_undef__inout_opt

#define __nvapi_undef__inout_opt

◆ __nvapi_undef__inout_z

#define __nvapi_undef__inout_z

◆ __nvapi_undef__inout_z_opt

#define __nvapi_undef__inout_z_opt

◆ __nvapi_undef__out

#define __nvapi_undef__out

◆ __nvapi_undef__out_bcount

#define __nvapi_undef__out_bcount

◆ __nvapi_undef__out_bcount_full

#define __nvapi_undef__out_bcount_full

◆ __nvapi_undef__out_bcount_full_opt

#define __nvapi_undef__out_bcount_full_opt

◆ __nvapi_undef__out_bcount_full_z

#define __nvapi_undef__out_bcount_full_z

◆ __nvapi_undef__out_bcount_full_z_opt

#define __nvapi_undef__out_bcount_full_z_opt

◆ __nvapi_undef__out_bcount_nz

#define __nvapi_undef__out_bcount_nz

◆ __nvapi_undef__out_bcount_nz_opt

#define __nvapi_undef__out_bcount_nz_opt

◆ __nvapi_undef__out_bcount_opt

#define __nvapi_undef__out_bcount_opt

◆ __nvapi_undef__out_bcount_part

#define __nvapi_undef__out_bcount_part

◆ __nvapi_undef__out_bcount_part_opt

#define __nvapi_undef__out_bcount_part_opt

◆ __nvapi_undef__out_bcount_part_z

#define __nvapi_undef__out_bcount_part_z

◆ __nvapi_undef__out_bcount_part_z_opt

#define __nvapi_undef__out_bcount_part_z_opt

◆ __nvapi_undef__out_bcount_z

#define __nvapi_undef__out_bcount_z

◆ __nvapi_undef__out_bcount_z_opt

#define __nvapi_undef__out_bcount_z_opt

◆ __nvapi_undef__out_ecount

#define __nvapi_undef__out_ecount

◆ __nvapi_undef__out_ecount_full

#define __nvapi_undef__out_ecount_full

◆ __nvapi_undef__out_ecount_full_opt

#define __nvapi_undef__out_ecount_full_opt

◆ __nvapi_undef__out_ecount_full_z

#define __nvapi_undef__out_ecount_full_z

◆ __nvapi_undef__out_ecount_full_z_opt

#define __nvapi_undef__out_ecount_full_z_opt

◆ __nvapi_undef__out_ecount_nz

#define __nvapi_undef__out_ecount_nz

◆ __nvapi_undef__out_ecount_nz_opt

#define __nvapi_undef__out_ecount_nz_opt

◆ __nvapi_undef__out_ecount_opt

#define __nvapi_undef__out_ecount_opt

◆ __nvapi_undef__out_ecount_part

#define __nvapi_undef__out_ecount_part

◆ __nvapi_undef__out_ecount_part_opt

#define __nvapi_undef__out_ecount_part_opt

◆ __nvapi_undef__out_ecount_part_z

#define __nvapi_undef__out_ecount_part_z

◆ __nvapi_undef__out_ecount_part_z_opt

#define __nvapi_undef__out_ecount_part_z_opt

◆ __nvapi_undef__out_ecount_z

#define __nvapi_undef__out_ecount_z

◆ __nvapi_undef__out_ecount_z_opt

#define __nvapi_undef__out_ecount_z_opt

◆ __nvapi_undef__out_nz

#define __nvapi_undef__out_nz

◆ __nvapi_undef__out_nz_opt

#define __nvapi_undef__out_nz_opt

◆ __nvapi_undef__out_opt

#define __nvapi_undef__out_opt

◆ __nvapi_undef__out_z

#define __nvapi_undef__out_z

◆ __nvapi_undef__out_z_opt

#define __nvapi_undef__out_z_opt

◆ __out

#define __out

◆ __out_bcount

#define __out_bcount ( size )

◆ __out_bcount_full

#define __out_bcount_full ( size )

◆ __out_bcount_full_opt

#define __out_bcount_full_opt ( size )

◆ __out_bcount_full_z

#define __out_bcount_full_z ( size )

◆ __out_bcount_full_z_opt

#define __out_bcount_full_z_opt ( size )

◆ __out_bcount_nz

#define __out_bcount_nz ( size )

◆ __out_bcount_nz_opt

#define __out_bcount_nz_opt ( size )

◆ __out_bcount_opt

#define __out_bcount_opt ( size )

◆ __out_bcount_part

#define __out_bcount_part | ( | size,
 |  | length
 | ) |

◆ __out_bcount_part_opt

#define __out_bcount_part_opt | ( | size,
 |  | length
 | ) |

◆ __out_bcount_part_z

#define __out_bcount_part_z | ( | size,
 |  | length
 | ) |

◆ __out_bcount_part_z_opt

#define __out_bcount_part_z_opt | ( | size,
 |  | length
 | ) |

◆ __out_bcount_z

#define __out_bcount_z ( size )

◆ __out_bcount_z_opt

#define __out_bcount_z_opt ( size )

◆ __out_ecount

#define __out_ecount ( size )

◆ __out_ecount_full

#define __out_ecount_full ( size )

◆ __out_ecount_full_opt

#define __out_ecount_full_opt ( size )

◆ __out_ecount_full_z

#define __out_ecount_full_z ( size )

◆ __out_ecount_full_z_opt

#define __out_ecount_full_z_opt ( size )

◆ __out_ecount_nz

#define __out_ecount_nz ( size )

◆ __out_ecount_nz_opt

#define __out_ecount_nz_opt ( size )

◆ __out_ecount_opt

#define __out_ecount_opt ( size )

◆ __out_ecount_part

#define __out_ecount_part | ( | size,
 |  | length
 | ) |

◆ __out_ecount_part_opt

#define __out_ecount_part_opt | ( | size,
 |  | length
 | ) |

◆ __out_ecount_part_z

#define __out_ecount_part_z | ( | size,
 |  | length
 | ) |

◆ __out_ecount_part_z_opt

#define __out_ecount_part_z_opt | ( | size,
 |  | length
 | ) |

◆ __out_ecount_z

#define __out_ecount_z ( size )

◆ __out_ecount_z_opt

#define __out_ecount_z_opt ( size )

◆ __out_nz

#define __out_nz

◆ __out_nz_opt

#define __out_nz_opt

◆ __out_opt

#define __out_opt

◆ __out_z

#define __out_z

◆ __out_z_opt

#define __out_z_opt

◆ __success

#define __success ( epxr )

◆ _Outptr_

#define _Outptr_

◆ _Post_writable_byte_size_

#define _Post_writable_byte_size_ ( n )

◆ _Ret_notnull_

#define _Ret_notnull_

◆ NVAPI_INTERFACE

#define NVAPI_INTERFACE extern __success(return == NVAPI_OK) NvAPI_Status __cdecl


  • File List
  • Globals
Data Structures | Macros | Typedefs | Enumerations | Functions
nvapi_lite_sli.h File Reference
#include "nvapi_lite_salstart.h"
#include "nvapi_lite_common.h"
#include "nvapi_lite_salend.h"

Data Structures

struct | NV_GET_CURRENT_SLI_STATE_V1
struct | NV_GET_CURRENT_SLI_STATE_V2

Macros

#define | NV_GET_CURRENT_SLI_STATE_VER1 MAKE_NVAPI_VERSION(NV_GET_CURRENT_SLI_STATE_V1,1)
#define | NV_GET_CURRENT_SLI_STATE_VER2 MAKE_NVAPI_VERSION(NV_GET_CURRENT_SLI_STATE_V2,1)
#define | NV_GET_CURRENT_SLI_STATE_VER NV_GET_CURRENT_SLI_STATE_VER2
#define | NV_GET_CURRENT_SLI_STATE NV_GET_CURRENT_SLI_STATE_V2

Typedefs

typedef enum _NVAPI_D3D_SETRESOURCEHINT_CATEGORY | NVAPI_D3D_SETRESOURCEHINT_CATEGORY
typedef enum _NVAPI_D3D_SETRESOURCEHINT_SLI | NVAPI_D3D_SETRESOURCEHINT_SLI
typedef enum _NVAPI_D3D_RESOURCERENDERING_FLAG | NVAPI_D3D_RESOURCERENDERING_FLAG

Enumerations

enum | _NVAPI_D3D_SETRESOURCEHINT_CATEGORY { NVAPI_D3D_SRH_CATEGORY_SLI = 1 }
enum | _NVAPI_D3D_SETRESOURCEHINT_SLI { NVAPI_D3D_SRH_SLI_APP_CONTROLLED_INTERFRAME_CONTENT_SYNC = 1 , NVAPI_D3D_SRH_SLI_ASK_FOR_BROADCAST_USAGE = 2 , NVAPI_D3D_SRH_SLI_RESPECT_DRIVER_INTERFRAME_CONTENT_SYNC = 3 }
enum | _NVAPI_D3D_RESOURCERENDERING_FLAG { NVAPI_D3D_RR_FLAG_DEFAULTS = 0x00000000 , NVAPI_D3D_RR_FLAG_FORCE_DISCARD_CONTENT = 0x00000001 , NVAPI_D3D_RR_FLAG_FORCE_KEEP_CONTENT = 0x00000002 , NVAPI_D3D_RR_FLAG_MULTI_FRAME = 0x00000004 }

Functions

NVAPI_INTERFACE | NvAPI_D3D_GetCurrentSLIState (IUnknown *pDevice, NV_GET_CURRENT_SLI_STATE *pSliState)
NVAPI_INTERFACE | NvAPI_D3D_SetResourceHint (IUnknown *pDev, NVDX_ObjectHandle obj, NVAPI_D3D_SETRESOURCEHINT_CATEGORY dwHintCategory, NvU32 dwHintName, NvU32 *pdwHintValue)
NVAPI_INTERFACE | NvAPI_D3D_BeginResourceRendering (IUnknown *pDeviceOrContext, NVDX_ObjectHandle obj, NvU32 Flags)
NVAPI_INTERFACE | NvAPI_D3D_EndResourceRendering (IUnknown *pDeviceOrContext, NVDX_ObjectHandle obj, NvU32 Flags)

Macro Definition Documentation

◆ NV_GET_CURRENT_SLI_STATE

#define NV_GET_CURRENT_SLI_STATE NV_GET_CURRENT_SLI_STATE_V2

◆ NV_GET_CURRENT_SLI_STATE_VER

#define NV_GET_CURRENT_SLI_STATE_VER NV_GET_CURRENT_SLI_STATE_VER2

◆ NV_GET_CURRENT_SLI_STATE_VER2

#define NV_GET_CURRENT_SLI_STATE_VER2 MAKE_NVAPI_VERSION(NV_GET_CURRENT_SLI_STATE_V2,1)


  • File List
  • Globals
Typedefs | Enumerations | Functions
nvapi_lite_stereo.h File Reference
#include "nvapi_lite_salstart.h"
#include "nvapi_lite_common.h"
#include "nvapi_lite_salend.h"

Typedefs

typedef enum _NV_StereoActiveEye | NV_STEREO_ACTIVE_EYE
typedef enum _NV_StereoDriverMode | NV_STEREO_DRIVER_MODE
typedef enum _NVAPI_STEREO_SURFACECREATEMODE | NVAPI_STEREO_SURFACECREATEMODE

Enumerations

enum | _NV_StereoActiveEye { NVAPI_STEREO_EYE_RIGHT = 1 , NVAPI_STEREO_EYE_LEFT = 2 , NVAPI_STEREO_EYE_MONO = 3 }
enum | _NV_StereoDriverMode { NVAPI_STEREO_DRIVER_MODE_AUTOMATIC = 0 , NVAPI_STEREO_DRIVER_MODE_DIRECT = 2 }
enum | _NVAPI_STEREO_SURFACECREATEMODE { NVAPI_STEREO_SURFACECREATEMODE_AUTO , NVAPI_STEREO_SURFACECREATEMODE_FORCESTEREO , NVAPI_STEREO_SURFACECREATEMODE_FORCEMONO }

Functions

NVAPI_INTERFACE | NvAPI_Stereo_Enable (void)
NVAPI_INTERFACE | NvAPI_Stereo_Disable (void)
NVAPI_INTERFACE | NvAPI_Stereo_IsEnabled (NvU8 *pIsStereoEnabled)
NVAPI_INTERFACE | NvAPI_Stereo_CreateHandleFromIUnknown (IUnknown *pDevice, StereoHandle *pStereoHandle)
NVAPI_INTERFACE | NvAPI_Stereo_DestroyHandle (StereoHandle stereoHandle)
NVAPI_INTERFACE | NvAPI_Stereo_Activate (StereoHandle stereoHandle)
NVAPI_INTERFACE | NvAPI_Stereo_Deactivate (StereoHandle stereoHandle)
NVAPI_INTERFACE | NvAPI_Stereo_IsActivated (StereoHandle stereoHandle, NvU8 *pIsStereoOn)
NVAPI_INTERFACE | NvAPI_Stereo_GetSeparation (StereoHandle stereoHandle, float *pSeparationPercentage)
NVAPI_INTERFACE | NvAPI_Stereo_SetSeparation (StereoHandle stereoHandle, float newSeparationPercentage)
NVAPI_INTERFACE | NvAPI_Stereo_GetConvergence (StereoHandle stereoHandle, float *pConvergence)
NVAPI_INTERFACE | NvAPI_Stereo_SetConvergence (StereoHandle stereoHandle, float newConvergence)
NVAPI_INTERFACE | NvAPI_Stereo_SetActiveEye (StereoHandle hStereoHandle, NV_STEREO_ACTIVE_EYE StereoEye)
NVAPI_INTERFACE | NvAPI_Stereo_SetDriverMode (NV_STEREO_DRIVER_MODE mode)
NVAPI_INTERFACE | NvAPI_Stereo_GetEyeSeparation (StereoHandle hStereoHandle, float *pSeparation)
NVAPI_INTERFACE | NvAPI_Stereo_IsWindowedModeSupported (NvU8 *bSupported)
NVAPI_INTERFACE | NvAPI_Stereo_SetSurfaceCreationMode (__in StereoHandle hStereoHandle, __in NVAPI_STEREO_SURFACECREATEMODE creationMode)
NVAPI_INTERFACE | NvAPI_Stereo_GetSurfaceCreationMode (__in StereoHandle hStereoHandle, __in NVAPI_STEREO_SURFACECREATEMODE *pCreationMode)
NVAPI_INTERFACE | NvAPI_Stereo_Debug_WasLastDrawStereoized (__in StereoHandle hStereoHandle, __out NvU8 *pWasStereoized)
NVAPI_INTERFACE | NvAPI_Stereo_SetDefaultProfile (__in const char *szProfileName)
NVAPI_INTERFACE | NvAPI_Stereo_GetDefaultProfile (__in NvU32 cbSizeIn, __out_bcount_part_opt(cbSizeIn, *pcbSizeOut) char *szProfileName, __out NvU32 *pcbSizeOut)


  • File List
  • Globals
Macros | Functions
nvapi_lite_surround.h File Reference
#include "nvapi_lite_salstart.h"
#include "nvapi_lite_common.h"
#include "nvapi_lite_salend.h"

Macros

#define NV_MOSAIC_MAX_DISPLAYS (64)

Functions

NVAPI_INTERFACE | NvAPI_DISP_GetGDIPrimaryDisplayId (NvU32 *displayId)
NVAPI_INTERFACE | NvAPI_Mosaic_GetDisplayViewportsByResolution (NvU32 displayId, NvU32 srcWidth, NvU32 srcHeight, NV_RECT viewports[NV_MOSAIC_MAX_DISPLAYS], NvU8 *bezelCorrected)

Macro Definition Documentation

◆ NV_MOSAIC_MAX_DISPLAYS

#define NV_MOSAIC_MAX_DISPLAYS (64)


  • File List
  • Globals
Data Structures | Macros | Typedefs | Enumerations
NvApiDriverSettings.h File Reference

Data Structures

struct | _SettingDWORDNameString
struct | _SettingWSTRINGNameString

Macros

#define | OGL_AA_LINE_GAMMA_STRING L"Antialiasing - Line gamma"
#define | OGL_CPL_GDI_COMPATIBILITY_STRING L"OpenGL GDI compatibility"
#define | OGL_CPL_PREFER_DXPRESENT_STRING L"Vulkan/OpenGL present method"
#define | OGL_DEEP_COLOR_SCANOUT_STRING L"Deep color for 3D applications"
#define | OGL_DEFAULT_SWAP_INTERVAL_STRING L"OpenGL default swap interval"
#define | OGL_DEFAULT_SWAP_INTERVAL_FRACTIONAL_STRING L"OpenGL default swap interval fraction"
#define | OGL_DEFAULT_SWAP_INTERVAL_SIGN_STRING L"OpenGL default swap interval sign"
#define | OGL_EVENT_LOG_SEVERITY_THRESHOLD_STRING L"Event Log Severity Threshold"
#define | OGL_EXTENSION_STRING_VERSION_STRING L"Extension String version"
#define | OGL_FORCE_BLIT_STRING L"Buffer-flipping mode"
#define | OGL_FORCE_STEREO_STRING L"Force Stereo shuttering"
#define | OGL_IMPLICIT_GPU_AFFINITY_STRING L"Preferred OpenGL GPU"
#define | OGL_MAX_FRAMES_ALLOWED_STRING L"Maximum frames allowed"
#define | OGL_OVERLAY_PIXEL_TYPE_STRING L"Exported Overlay pixel types"
#define | OGL_OVERLAY_SUPPORT_STRING L"Enable overlay"
#define | OGL_QUALITY_ENHANCEMENTS_STRING L"High level control of the rendering quality on OpenGL"
#define | OGL_SINGLE_BACKDEPTH_BUFFER_STRING L"Unified back/depth buffer"
#define | OGL_SLI_MULTICAST_STRING L"Enable NV_gpu_multicast extension"
#define | OGL_THREAD_CONTROL_STRING L"Threaded optimization"
#define | OGL_TMON_LEVEL_STRING L"Event Log Tmon Severity Threshold"
#define | OGL_TRIPLE_BUFFER_STRING L"Triple buffering"
#define | AA_BEHAVIOR_FLAGS_STRING L"Antialiasing - Behavior Flags"
#define | AA_MODE_ALPHATOCOVERAGE_STRING L"Antialiasing - Transparency Multisampling"
#define | AA_MODE_GAMMACORRECTION_STRING L"Antialiasing - Gamma correction"
#define | AA_MODE_METHOD_STRING L"Antialiasing - Setting"
#define | AA_MODE_REPLAY_STRING L"Antialiasing - Transparency Supersampling"
#define | AA_MODE_SELECTOR_STRING L"Antialiasing - Mode"
#define | AA_MODE_SELECTOR_SLIAA_STRING L"Antialiasing - SLI AA"
#define | ANISO_MODE_LEVEL_STRING L"Anisotropic filtering setting"
#define | ANISO_MODE_SELECTOR_STRING L"Anisotropic filtering mode"
#define | ANSEL_ALLOW_STRING L"NVIDIA Predefined Ansel Usage"
#define | ANSEL_ALLOWLISTED_STRING L"Ansel flags for enabled applications"
#define | ANSEL_ENABLE_STRING L"Enable Ansel"
#define | APPIDLE_DYNAMIC_FRL_FPS_STRING L"Idle Application Max FPS Limit"
#define | APPIDLE_DYNAMIC_FRL_THRESHOLD_TIME_STRING L"Idle Application Threshold Time out in seconds"
#define | APPLICATION_PROFILE_NOTIFICATION_TIMEOUT_STRING L"Application Profile Notification Popup Timeout"
#define | APPLICATION_STEAM_ID_STRING L"Steam Application ID"
#define | BATTERY_BOOST_APP_FPS_STRING L"Battery Boost Application FPS"
#define | CPL_HIDDEN_PROFILE_STRING L"Do not display this profile in the Control Panel"
#define | CUDA_EXCLUDED_GPUS_STRING L"List of Universal GPU ids"
#define | D3DOGL_GPU_MAX_POWER_STRING L"Maximum GPU Power"
#define | EXPORT_PERF_COUNTERS_STRING L"Export Performance Counters"
#define | EXTERNAL_QUIET_MODE_STRING L"External Quiet Mode (XQM)"
#define | FRL_FPS_STRING L"Frame Rate Limiter"
#define | FXAA_ALLOW_STRING L"NVIDIA Predefined FXAA Usage"
#define | FXAA_ENABLE_STRING L"Enable FXAA"
#define | FXAA_INDICATOR_ENABLE_STRING L"Enable FXAA Indicator"
#define | LATENCY_INDICATOR_AUTOALIGN_STRING L"Autoalign flash indicator"
#define | MCSFRSHOWSPLIT_STRING L"SLI indicator"
#define | NV_QUALITY_UPSCALING_STRING L"NVIDIA Quality upscaling"
#define | OPTIMUS_MAXAA_STRING L"Maximum AA samples allowed for a given application"
#define | PHYSXINDICATOR_STRING L"Display the PhysX indicator"
#define | PREFERRED_PSTATE_STRING L"Power management mode"
#define | PREVENT_UI_AF_OVERRIDE_STRING L"No override of Anisotropic filtering"
#define | SHIM_MAXRES_STRING L"Maximum resolution allowed for a given application"
#define | SHIM_MCCOMPAT_STRING L"Optimus flags for enabled applications"
#define | SHIM_RENDERING_MODE_STRING L"Enable application for Optimus"
#define | SHIM_RENDERING_OPTIONS_STRING L"Shim Rendering Mode Options per application for Optimus"
#define | SLI_GPU_COUNT_STRING L"Number of GPUs to use on SLI rendering mode"
#define | SLI_PREDEFINED_GPU_COUNT_STRING L"NVIDIA predefined number of GPUs to use on SLI rendering mode"
#define | SLI_PREDEFINED_GPU_COUNT_DX10_STRING L"NVIDIA predefined number of GPUs to use on SLI rendering mode on DirectX 10"
#define | SLI_PREDEFINED_MODE_STRING L"NVIDIA predefined SLI mode"
#define | SLI_PREDEFINED_MODE_DX10_STRING L"NVIDIA predefined SLI mode on DirectX 10"
#define | SLI_RENDERING_MODE_STRING L"SLI rendering mode"
#define | VRPRERENDERLIMIT_STRING L"Virtual Reality pre-rendered frames"
#define | VRRFEATUREINDICATOR_STRING L"Toggle the VRR global feature"
#define | VRROVERLAYINDICATOR_STRING L"Display the VRR Overlay Indicator"
#define | VRRREQUESTSTATE_STRING L"VRR requested state"
#define | VRR_APP_OVERRIDE_STRING L"G-SYNC"
#define | VRR_APP_OVERRIDE_REQUEST_STATE_STRING L"G-SYNC"
#define | VRR_MODE_STRING L"Enable G-SYNC globally"
#define | VSYNCSMOOTHAFR_STRING L"Flag to control smooth AFR behavior"
#define | VSYNCVRRCONTROL_STRING L"Variable refresh Rate"
#define | VSYNC_BEHAVIOR_FLAGS_STRING L"Vsync - Behavior Flags"
#define | WKS_API_STEREO_EYES_EXCHANGE_STRING L"Stereo - Swap eyes"
#define | WKS_API_STEREO_MODE_STRING L"Stereo - Display mode"
#define | WKS_STEREO_DONGLE_SUPPORT_STRING L"Stereo - Dongle Support"
#define | WKS_STEREO_SUPPORT_STRING L"Stereo - Enable"
#define | WKS_STEREO_SWAP_MODE_STRING L"Stereo - swap mode"
#define | AO_MODE_STRING L"Ambient Occlusion"
#define | AO_MODE_ACTIVE_STRING L"NVIDIA Predefined Ambient Occlusion Usage"
#define | AUTO_LODBIASADJUST_STRING L"Texture filtering - Driver Controlled LOD Bias"
#define | EXPORT_PERF_COUNTERS_DX9_ONLY_STRING L"Export Performance Counters for DX9 only"
#define | ICAFE_LOGO_CONFIG_STRING L"ICafe Settings"
#define | LODBIASADJUST_STRING L"Texture filtering - LOD Bias"
#define | MAXWELL_B_SAMPLE_INTERLEAVE_STRING L"Enable sample interleaving (MFAA)"
#define | PRERENDERLIMIT_STRING L"Maximum pre-rendered frames"
#define | PS_SHADERDISKCACHE_STRING L"Shader Cache"
#define | PS_SHADERDISKCACHE_DLL_PATH_WCHAR_STRING L"shader cache path to dll"
#define | PS_SHADERDISKCACHE_MAX_SIZE_STRING L"Shader disk cache maximum size"
#define | PS_TEXFILTER_ANISO_OPTS2_STRING L"Texture filtering - Anisotropic sample optimization"
#define | PS_TEXFILTER_BILINEAR_IN_ANISO_STRING L"Texture filtering - Anisotropic filter optimization"
#define | PS_TEXFILTER_DISABLE_TRILIN_SLOPE_STRING L"Texture filtering - Trilinear optimization"
#define | PS_TEXFILTER_NO_NEG_LODBIAS_STRING L"Texture filtering - Negative LOD bias"
#define | QUALITY_ENHANCEMENTS_STRING L"Texture filtering - Quality"
#define | QUALITY_ENHANCEMENT_SUBSTITUTION_STRING L"Texture filtering - Quality Substitution"
#define | REFRESH_RATE_OVERRIDE_STRING L"Preferred refresh rate"
#define | SET_POWER_THROTTLE_FOR_PCIe_COMPLIANCE_STRING L"PowerThrottle"
#define | SET_VAB_DATA_STRING L"VAB Default Data"
#define | VSYNCMODE_STRING L"Vertical Sync"
#define | VSYNCTEARCONTROL_STRING L"Vertical Sync Tear Control"
#define | OGL_IMPLICIT_GPU_AFFINITY_ENV_VAR L"OGL_DEFAULT_RENDERING_GPU"
#define | OGL_IMPLICIT_GPU_AFFINITY_AUTOSELECT L"autoselect"
#define | OGL_IMPLICIT_GPU_AFFINITY_NUM_VALUES 1
#define | OGL_IMPLICIT_GPU_AFFINITY_DEFAULT OGL_IMPLICIT_GPU_AFFINITY_AUTOSELECT
#define | CUDA_EXCLUDED_GPUS_NONE L"none"
#define | CUDA_EXCLUDED_GPUS_NUM_VALUES 1
#define | CUDA_EXCLUDED_GPUS_DEFAULT CUDA_EXCLUDED_GPUS_NONE
#define | D3DOGL_GPU_MAX_POWER_DEFAULTPOWER L"0"
#define | D3DOGL_GPU_MAX_POWER_NUM_VALUES 1
#define | D3DOGL_GPU_MAX_POWER_DEFAULT D3DOGL_GPU_MAX_POWER_DEFAULTPOWER

Typedefs

typedef struct _SettingDWORDNameString | SettingDWORDNameString
typedef struct _SettingWSTRINGNameString | SettingWSTRINGNameString

Enumerations

enum ESetting {
OGL_AA_LINE_GAMMA_ID = 0x2089BF6C , OGL_CPL_GDI_COMPATIBILITY_ID = 0x2072C5A3 , OGL_CPL_PREFER_DXPRESENT_ID = 0x20D690F8 , OGL_DEEP_COLOR_SCANOUT_ID = 0x2097C2F6 ,
OGL_DEFAULT_SWAP_INTERVAL_ID = 0x206A6582 , OGL_DEFAULT_SWAP_INTERVAL_FRACTIONAL_ID = 0x206C4581 , OGL_DEFAULT_SWAP_INTERVAL_SIGN_ID = 0x20655CFA , OGL_EVENT_LOG_SEVERITY_THRESHOLD_ID = 0x209DF23E ,
OGL_EXTENSION_STRING_VERSION_ID = 0x20FF7493 , OGL_FORCE_BLIT_ID = 0x201F619F , OGL_FORCE_STEREO_ID = 0x204D9A0C , OGL_IMPLICIT_GPU_AFFINITY_ID = 0x20D0F3E6 ,
OGL_MAX_FRAMES_ALLOWED_ID = 0x208E55E3 , OGL_OVERLAY_PIXEL_TYPE_ID = 0x209AE66F , OGL_OVERLAY_SUPPORT_ID = 0x206C28C4 , OGL_QUALITY_ENHANCEMENTS_ID = 0x20797D6C ,
OGL_SINGLE_BACKDEPTH_BUFFER_ID = 0x20A29055 , OGL_SLI_MULTICAST_ID = 0x2092D3BE , OGL_THREAD_CONTROL_ID = 0x20C1221E , OGL_TMON_LEVEL_ID = 0x202888C1 ,
OGL_TRIPLE_BUFFER_ID = 0x20FDD1F9 , AA_BEHAVIOR_FLAGS_ID = 0x10ECDB82 , AA_MODE_ALPHATOCOVERAGE_ID = 0x10FC2D9C , AA_MODE_GAMMACORRECTION_ID = 0x107D639D ,
AA_MODE_METHOD_ID = 0x10D773D2 , AA_MODE_REPLAY_ID = 0x10D48A85 , AA_MODE_SELECTOR_ID = 0x107EFC5B , AA_MODE_SELECTOR_SLIAA_ID = 0x107AFC5B ,
ANISO_MODE_LEVEL_ID = 0x101E61A9 , ANISO_MODE_SELECTOR_ID = 0x10D2BB16 , ANSEL_ALLOW_ID = 0x1035DB89 , ANSEL_ALLOWLISTED_ID = 0x1085DA8A ,
ANSEL_ENABLE_ID = 0x1075D972 , APPIDLE_DYNAMIC_FRL_FPS_ID = 0x10835016 , APPIDLE_DYNAMIC_FRL_THRESHOLD_TIME_ID = 0x10835017 , APPLICATION_PROFILE_NOTIFICATION_TIMEOUT_ID = 0x104554B6 ,
APPLICATION_STEAM_ID_ID = 0x107CDDBC , BATTERY_BOOST_APP_FPS_ID = 0x10115C8C , CPL_HIDDEN_PROFILE_ID = 0x106D5CFF , CUDA_EXCLUDED_GPUS_ID = 0x10354FF8 ,
D3DOGL_GPU_MAX_POWER_ID = 0x10D1EF29 , EXPORT_PERF_COUNTERS_ID = 0x108F0841 , EXTERNAL_QUIET_MODE_ID = 0x10115C8D , FRL_FPS_ID = 0x10835002 ,
FXAA_ALLOW_ID = 0x1034CB89 , FXAA_ENABLE_ID = 0x1074C972 , FXAA_INDICATOR_ENABLE_ID = 0x1068FB9C , LATENCY_INDICATOR_AUTOALIGN_ID = 0x1095F170 ,
MCSFRSHOWSPLIT_ID = 0x10287051 , NV_QUALITY_UPSCALING_ID = 0x10444444 , OPTIMUS_MAXAA_ID = 0x10F9DC83 , PHYSXINDICATOR_ID = 0x1094F16F ,
PREFERRED_PSTATE_ID = 0x1057EB71 , PREVENT_UI_AF_OVERRIDE_ID = 0x103BCCB5 , SHIM_MAXRES_ID = 0x10F9DC82 , SHIM_MCCOMPAT_ID = 0x10F9DC80 ,
SHIM_RENDERING_MODE_ID = 0x10F9DC81 , SHIM_RENDERING_OPTIONS_ID = 0x10F9DC84 , SLI_GPU_COUNT_ID = 0x1033DCD1 , SLI_PREDEFINED_GPU_COUNT_ID = 0x1033DCD2 ,
SLI_PREDEFINED_GPU_COUNT_DX10_ID = 0x1033DCD3 , SLI_PREDEFINED_MODE_ID = 0x1033CEC1 , SLI_PREDEFINED_MODE_DX10_ID = 0x1033CEC2 , SLI_RENDERING_MODE_ID = 0x1033CED1 ,
VRPRERENDERLIMIT_ID = 0x10111133 , VRRFEATUREINDICATOR_ID = 0x1094F157 , VRROVERLAYINDICATOR_ID = 0x1095F16F , VRRREQUESTSTATE_ID = 0x1094F1F7 ,
VRR_APP_OVERRIDE_ID = 0x10A879CF , VRR_APP_OVERRIDE_REQUEST_STATE_ID = 0x10A879AC , VRR_MODE_ID = 0x1194F158 , VSYNCSMOOTHAFR_ID = 0x101AE763 ,
VSYNCVRRCONTROL_ID = 0x10A879CE , VSYNC_BEHAVIOR_FLAGS_ID = 0x10FDEC23 , WKS_API_STEREO_EYES_EXCHANGE_ID = 0x11AE435C , WKS_API_STEREO_MODE_ID = 0x11E91A61 ,
WKS_STEREO_DONGLE_SUPPORT_ID = 0x112493BD , WKS_STEREO_SUPPORT_ID = 0x11AA9E99 , WKS_STEREO_SWAP_MODE_ID = 0x11333333 , AO_MODE_ID = 0x00667329 ,
AO_MODE_ACTIVE_ID = 0x00664339 , AUTO_LODBIASADJUST_ID = 0x00638E8F , EXPORT_PERF_COUNTERS_DX9_ONLY_ID = 0x00B65E72 , ICAFE_LOGO_CONFIG_ID = 0x00DB1337 ,
LODBIASADJUST_ID = 0x00738E8F , MAXWELL_B_SAMPLE_INTERLEAVE_ID = 0x0098C1AC , PRERENDERLIMIT_ID = 0x007BA09E , PS_SHADERDISKCACHE_ID = 0x00198FFF ,
PS_SHADERDISKCACHE_DLL_PATH_WCHAR_ID = 0x0019A002 , PS_SHADERDISKCACHE_MAX_SIZE_ID = 0x00AC8497 , PS_TEXFILTER_ANISO_OPTS2_ID = 0x00E73211 , PS_TEXFILTER_BILINEAR_IN_ANISO_ID = 0x0084CD70 ,
PS_TEXFILTER_DISABLE_TRILIN_SLOPE_ID = 0x002ECAF2 , PS_TEXFILTER_NO_NEG_LODBIAS_ID = 0x0019BB68 , QUALITY_ENHANCEMENTS_ID = 0x00CE2691 , QUALITY_ENHANCEMENT_SUBSTITUTION_ID = 0x00CE2692 ,
REFRESH_RATE_OVERRIDE_ID = 0x0064B541 , SET_POWER_THROTTLE_FOR_PCIe_COMPLIANCE_ID = 0x00AE785C , SET_VAB_DATA_ID = 0x00AB8687 , VSYNCMODE_ID = 0x00A879CF ,
VSYNCTEARCONTROL_ID = 0x005A375C , TOTAL_DWORD_SETTING_NUM = 96 , TOTAL_WSTRING_SETTING_NUM = 5 , TOTAL_SETTING_NUM = 101 ,
INVALID_SETTING_ID = 0xFFFFFFFF
}
enum EValues_OGL_AA_LINE_GAMMA {
OGL_AA_LINE_GAMMA_DISABLED = 0x10 , OGL_AA_LINE_GAMMA_ENABLED = 0x23 , OGL_AA_LINE_GAMMA_MIN = 1 , OGL_AA_LINE_GAMMA_MAX = 100 ,
OGL_AA_LINE_GAMMA_NUM_VALUES = 4 , OGL_AA_LINE_GAMMA_DEFAULT = OGL_AA_LINE_GAMMA_DISABLED
}
enum EValues_OGL_CPL_GDI_COMPATIBILITY {
OGL_CPL_GDI_COMPATIBILITY_PREFER_DISABLED = 0x00000000 , OGL_CPL_GDI_COMPATIBILITY_PREFER_ENABLED = 0x00000001 , OGL_CPL_GDI_COMPATIBILITY_AUTO = 0x00000002 , OGL_CPL_GDI_COMPATIBILITY_NUM_VALUES = 3 ,
OGL_CPL_GDI_COMPATIBILITY_DEFAULT = OGL_CPL_GDI_COMPATIBILITY_AUTO
}
enum EValues_OGL_CPL_PREFER_DXPRESENT {
OGL_CPL_PREFER_DXPRESENT_PREFER_DISABLED = 0x00000000 , OGL_CPL_PREFER_DXPRESENT_PREFER_ENABLED = 0x00000001 , OGL_CPL_PREFER_DXPRESENT_AUTO = 0x00000002 , OGL_CPL_PREFER_DXPRESENT_NUM_VALUES = 3 ,
OGL_CPL_PREFER_DXPRESENT_DEFAULT = OGL_CPL_PREFER_DXPRESENT_AUTO
}
enum | EValues_OGL_DEEP_COLOR_SCANOUT { OGL_DEEP_COLOR_SCANOUT_DISABLE = 0 , OGL_DEEP_COLOR_SCANOUT_ENABLE = 1 , OGL_DEEP_COLOR_SCANOUT_NUM_VALUES = 2 , OGL_DEEP_COLOR_SCANOUT_DEFAULT = OGL_DEEP_COLOR_SCANOUT_ENABLE }
enum EValues_OGL_DEFAULT_SWAP_INTERVAL {
OGL_DEFAULT_SWAP_INTERVAL_TEAR = 0 , OGL_DEFAULT_SWAP_INTERVAL_VSYNC_ONE = 1 , OGL_DEFAULT_SWAP_INTERVAL_VSYNC = 1 , OGL_DEFAULT_SWAP_INTERVAL_VALUE_MASK = 0x0000FFFF ,
OGL_DEFAULT_SWAP_INTERVAL_FORCE_MASK = 0xF0000000 , OGL_DEFAULT_SWAP_INTERVAL_FORCE_OFF = 0xF0000000 , OGL_DEFAULT_SWAP_INTERVAL_FORCE_ON = 0x10000000 , OGL_DEFAULT_SWAP_INTERVAL_APP_CONTROLLED = 0x00000000 ,
OGL_DEFAULT_SWAP_INTERVAL_DISABLE = 0xffffffff , OGL_DEFAULT_SWAP_INTERVAL_NUM_VALUES = 9 , OGL_DEFAULT_SWAP_INTERVAL_DEFAULT = OGL_DEFAULT_SWAP_INTERVAL_VSYNC_ONE
}
enum | EValues_OGL_DEFAULT_SWAP_INTERVAL_FRACTIONAL { OGL_DEFAULT_SWAP_INTERVAL_FRACTIONAL_ZERO_SCANLINES = 0 , OGL_DEFAULT_SWAP_INTERVAL_FRACTIONAL_ONE_FULL_FRAME_OF_SCANLINES = 100 , OGL_DEFAULT_SWAP_INTERVAL_FRACTIONAL_NUM_VALUES = 2 , OGL_DEFAULT_SWAP_INTERVAL_FRACTIONAL_DEFAULT = 0U }
enum | EValues_OGL_DEFAULT_SWAP_INTERVAL_SIGN { OGL_DEFAULT_SWAP_INTERVAL_SIGN_POSITIVE = 0 , OGL_DEFAULT_SWAP_INTERVAL_SIGN_NEGATIVE = 1 , OGL_DEFAULT_SWAP_INTERVAL_SIGN_NUM_VALUES = 2 , OGL_DEFAULT_SWAP_INTERVAL_SIGN_DEFAULT = OGL_DEFAULT_SWAP_INTERVAL_SIGN_POSITIVE }
enum EValues_OGL_EVENT_LOG_SEVERITY_THRESHOLD {
OGL_EVENT_LOG_SEVERITY_THRESHOLD_DISABLE = 0 , OGL_EVENT_LOG_SEVERITY_THRESHOLD_CRITICAL = 1 , OGL_EVENT_LOG_SEVERITY_THRESHOLD_WARNING = 2 , OGL_EVENT_LOG_SEVERITY_THRESHOLD_INFORMATION = 3 ,
OGL_EVENT_LOG_SEVERITY_THRESHOLD_ALL = 4 , OGL_EVENT_LOG_SEVERITY_THRESHOLD_NUM_VALUES = 5 , OGL_EVENT_LOG_SEVERITY_THRESHOLD_DEFAULT = OGL_EVENT_LOG_SEVERITY_THRESHOLD_ALL
}
enum | EValues_OGL_FORCE_BLIT { OGL_FORCE_BLIT_ON = 1 , OGL_FORCE_BLIT_OFF = 0 , OGL_FORCE_BLIT_NUM_VALUES = 2 , OGL_FORCE_BLIT_DEFAULT = OGL_FORCE_BLIT_OFF }
enum | EValues_OGL_FORCE_STEREO { OGL_FORCE_STEREO_OFF = 0 , OGL_FORCE_STEREO_ON = 1 , OGL_FORCE_STEREO_NUM_VALUES = 2 , OGL_FORCE_STEREO_DEFAULT = OGL_FORCE_STEREO_OFF }
enum EValues_OGL_OVERLAY_PIXEL_TYPE {
OGL_OVERLAY_PIXEL_TYPE_NONE = 0x0 , OGL_OVERLAY_PIXEL_TYPE_CI = 0x1 , OGL_OVERLAY_PIXEL_TYPE_RGBA = 0x2 , OGL_OVERLAY_PIXEL_TYPE_CI_AND_RGBA = 0x3 ,
OGL_OVERLAY_PIXEL_TYPE_NUM_VALUES = 4 , OGL_OVERLAY_PIXEL_TYPE_DEFAULT = OGL_OVERLAY_PIXEL_TYPE_CI
}
enum EValues_OGL_OVERLAY_SUPPORT {
OGL_OVERLAY_SUPPORT_OFF = 0 , OGL_OVERLAY_SUPPORT_ON = 1 , OGL_OVERLAY_SUPPORT_FORCE_SW = 2 , OGL_OVERLAY_SUPPORT_NUM_VALUES = 3 ,
OGL_OVERLAY_SUPPORT_DEFAULT = OGL_OVERLAY_SUPPORT_OFF
}
enum EValues_OGL_QUALITY_ENHANCEMENTS {
OGL_QUALITY_ENHANCEMENTS_HQUAL = 0xfffffff6 , OGL_QUALITY_ENHANCEMENTS_QUAL = 0 , OGL_QUALITY_ENHANCEMENTS_PERF = 10 , OGL_QUALITY_ENHANCEMENTS_HPERF = 20 ,
OGL_QUALITY_ENHANCEMENTS_NUM_VALUES = 4 , OGL_QUALITY_ENHANCEMENTS_DEFAULT = OGL_QUALITY_ENHANCEMENTS_QUAL
}
enum EValues_OGL_SINGLE_BACKDEPTH_BUFFER {
OGL_SINGLE_BACKDEPTH_BUFFER_DISABLE = 0x0 , OGL_SINGLE_BACKDEPTH_BUFFER_ENABLE = 0x1 , OGL_SINGLE_BACKDEPTH_BUFFER_USE_HW_DEFAULT = 0xffffffff , OGL_SINGLE_BACKDEPTH_BUFFER_NUM_VALUES = 3 ,
OGL_SINGLE_BACKDEPTH_BUFFER_DEFAULT = OGL_SINGLE_BACKDEPTH_BUFFER_DISABLE
}
enum EValues_OGL_SLI_MULTICAST {
OGL_SLI_MULTICAST_DISABLE = 0x00 , OGL_SLI_MULTICAST_ENABLE = 0x01 , OGL_SLI_MULTICAST_FORCE_DISABLE = 0x02 , OGL_SLI_MULTICAST_ALLOW_MOSAIC = 0x04 ,
OGL_SLI_MULTICAST_NUM_VALUES = 4 , OGL_SLI_MULTICAST_DEFAULT = OGL_SLI_MULTICAST_DISABLE
}
enum | EValues_OGL_THREAD_CONTROL { OGL_THREAD_CONTROL_ENABLE = 0x00000001 , OGL_THREAD_CONTROL_DISABLE = 0x00000002 , OGL_THREAD_CONTROL_NUM_VALUES = 2 , OGL_THREAD_CONTROL_DEFAULT = 0U }
enum EValues_OGL_TMON_LEVEL {
OGL_TMON_LEVEL_DISABLE = 0 , OGL_TMON_LEVEL_CRITICAL = 1 , OGL_TMON_LEVEL_WARNING = 2 , OGL_TMON_LEVEL_INFORMATION = 3 ,
OGL_TMON_LEVEL_MOST = 4 , OGL_TMON_LEVEL_VERBOSE = 5 , OGL_TMON_LEVEL_NUM_VALUES = 6 , OGL_TMON_LEVEL_DEFAULT = OGL_TMON_LEVEL_MOST
}
enum | EValues_OGL_TRIPLE_BUFFER { OGL_TRIPLE_BUFFER_DISABLED = 0x00000000 , OGL_TRIPLE_BUFFER_ENABLED = 0x00000001 , OGL_TRIPLE_BUFFER_NUM_VALUES = 2 , OGL_TRIPLE_BUFFER_DEFAULT = OGL_TRIPLE_BUFFER_DISABLED }
enum EValues_AA_BEHAVIOR_FLAGS {
AA_BEHAVIOR_FLAGS_NONE = 0x00000000 , AA_BEHAVIOR_FLAGS_TREAT_OVERRIDE_AS_APP_CONTROLLED = 0x00000001 , AA_BEHAVIOR_FLAGS_TREAT_OVERRIDE_AS_ENHANCE = 0x00000002 , AA_BEHAVIOR_FLAGS_DISABLE_OVERRIDE = 0x00000003 ,
AA_BEHAVIOR_FLAGS_TREAT_ENHANCE_AS_APP_CONTROLLED = 0x00000004 , AA_BEHAVIOR_FLAGS_TREAT_ENHANCE_AS_OVERRIDE = 0x00000008 , AA_BEHAVIOR_FLAGS_DISABLE_ENHANCE = 0x0000000c , AA_BEHAVIOR_FLAGS_MAP_VCAA_TO_MULTISAMPLING = 0x00010000 ,
AA_BEHAVIOR_FLAGS_SLI_DISABLE_TRANSPARENCY_SUPERSAMPLING = 0x00020000 , AA_BEHAVIOR_FLAGS_DISABLE_CPLAA = 0x00040000 , AA_BEHAVIOR_FLAGS_SKIP_RT_DIM_CHECK_FOR_ENHANCE = 0x00080000 , AA_BEHAVIOR_FLAGS_DISABLE_SLIAA = 0x00100000 ,
AA_BEHAVIOR_FLAGS_DEFAULT = 0x00000000 , AA_BEHAVIOR_FLAGS_AA_RT_BPP_DIV_4 = 0xf0000000 , AA_BEHAVIOR_FLAGS_AA_RT_BPP_DIV_4_SHIFT = 28 , AA_BEHAVIOR_FLAGS_NON_AA_RT_BPP_DIV_4 = 0x0f000000 ,
AA_BEHAVIOR_FLAGS_NON_AA_RT_BPP_DIV_4_SHIFT = 24 , AA_BEHAVIOR_FLAGS_MASK = 0xff1f000f , AA_BEHAVIOR_FLAGS_NUM_VALUES = 18
}
enum EValues_AA_MODE_ALPHATOCOVERAGE {
AA_MODE_ALPHATOCOVERAGE_MODE_MASK = 0x00000004 , AA_MODE_ALPHATOCOVERAGE_MODE_OFF = 0x00000000 , AA_MODE_ALPHATOCOVERAGE_MODE_ON = 0x00000004 , AA_MODE_ALPHATOCOVERAGE_MODE_MAX = 0x00000004 ,
AA_MODE_ALPHATOCOVERAGE_NUM_VALUES = 4 , AA_MODE_ALPHATOCOVERAGE_DEFAULT = 0x00000000
}
enum EValues_AA_MODE_GAMMACORRECTION {
AA_MODE_GAMMACORRECTION_MASK = 0x00000003 , AA_MODE_GAMMACORRECTION_OFF = 0x00000000 , AA_MODE_GAMMACORRECTION_ON_IF_FOS = 0x00000001 , AA_MODE_GAMMACORRECTION_ON_ALWAYS = 0x00000002 ,
AA_MODE_GAMMACORRECTION_MAX = 0x00000002 , AA_MODE_GAMMACORRECTION_DEFAULT = 0x00000000 , AA_MODE_GAMMACORRECTION_DEFAULT_TESLA = 0x00000002 , AA_MODE_GAMMACORRECTION_DEFAULT_FERMI = 0x00000002 ,
AA_MODE_GAMMACORRECTION_NUM_VALUES = 8
}
enum EValues_AA_MODE_METHOD {
AA_MODE_METHOD_NONE = 0x0 , AA_MODE_METHOD_SUPERSAMPLE_2X_H = 0x1 , AA_MODE_METHOD_SUPERSAMPLE_2X_V = 0x2 , AA_MODE_METHOD_SUPERSAMPLE_1_5X1_5 = 0x2 ,
AA_MODE_METHOD_FREE_0x03 = 0x3 , AA_MODE_METHOD_FREE_0x04 = 0x4 , AA_MODE_METHOD_SUPERSAMPLE_4X = 0x5 , AA_MODE_METHOD_SUPERSAMPLE_4X_BIAS = 0x6 ,
AA_MODE_METHOD_SUPERSAMPLE_4X_GAUSSIAN = 0x7 , AA_MODE_METHOD_FREE_0x08 = 0x8 , AA_MODE_METHOD_FREE_0x09 = 0x9 , AA_MODE_METHOD_SUPERSAMPLE_9X = 0xA ,
AA_MODE_METHOD_SUPERSAMPLE_9X_BIAS = 0xB , AA_MODE_METHOD_SUPERSAMPLE_16X = 0xC , AA_MODE_METHOD_SUPERSAMPLE_16X_BIAS = 0xD , AA_MODE_METHOD_MULTISAMPLE_2X_DIAGONAL = 0xE ,
AA_MODE_METHOD_MULTISAMPLE_2X_QUINCUNX = 0xF , AA_MODE_METHOD_MULTISAMPLE_4X = 0x10 , AA_MODE_METHOD_FREE_0x11 = 0x11 , AA_MODE_METHOD_MULTISAMPLE_4X_GAUSSIAN = 0x12 ,
AA_MODE_METHOD_MIXEDSAMPLE_4X_SKEWED_4TAP = 0x13 , AA_MODE_METHOD_FREE_0x14 = 0x14 , AA_MODE_METHOD_FREE_0x15 = 0x15 , AA_MODE_METHOD_MIXEDSAMPLE_6X = 0x16 ,
AA_MODE_METHOD_MIXEDSAMPLE_6X_SKEWED_6TAP = 0x17 , AA_MODE_METHOD_MIXEDSAMPLE_8X = 0x18 , AA_MODE_METHOD_MIXEDSAMPLE_8X_SKEWED_8TAP = 0x19 , AA_MODE_METHOD_MIXEDSAMPLE_16X = 0x1a ,
AA_MODE_METHOD_MULTISAMPLE_4X_GAMMA = 0x1b , AA_MODE_METHOD_MULTISAMPLE_16X = 0x1c , AA_MODE_METHOD_VCAA_32X_8v24 = 0x1d , AA_MODE_METHOD_CORRUPTION_CHECK = 0x1e ,
AA_MODE_METHOD_6X_CT = 0x1f , AA_MODE_METHOD_MULTISAMPLE_2X_DIAGONAL_GAMMA = 0x20 , AA_MODE_METHOD_SUPERSAMPLE_4X_GAMMA = 0x21 , AA_MODE_METHOD_MULTISAMPLE_4X_FOSGAMMA = 0x22 ,
AA_MODE_METHOD_MULTISAMPLE_2X_DIAGONAL_FOSGAMMA = 0x23 , AA_MODE_METHOD_SUPERSAMPLE_4X_FOSGAMMA = 0x24 , AA_MODE_METHOD_MULTISAMPLE_8X = 0x25 , AA_MODE_METHOD_VCAA_8X_4v4 = 0x26 ,
AA_MODE_METHOD_VCAA_16X_4v12 = 0x27 , AA_MODE_METHOD_VCAA_16X_8v8 = 0x28 , AA_MODE_METHOD_MIXEDSAMPLE_32X = 0x29 , AA_MODE_METHOD_SUPERVCAA_64X_4v12 = 0x2a ,
AA_MODE_METHOD_SUPERVCAA_64X_8v8 = 0x2b , AA_MODE_METHOD_MIXEDSAMPLE_64X = 0x2c , AA_MODE_METHOD_MIXEDSAMPLE_128X = 0x2d , AA_MODE_METHOD_COUNT = 0x2e ,
AA_MODE_METHOD_METHOD_MASK = 0x0000ffff , AA_MODE_METHOD_METHOD_MAX = 0xf1c57815 , AA_MODE_METHOD_NUM_VALUES = 50 , AA_MODE_METHOD_DEFAULT = AA_MODE_METHOD_NONE
}
enum EValues_AA_MODE_REPLAY {
AA_MODE_REPLAY_SAMPLES_MASK = 0x00000070 , AA_MODE_REPLAY_SAMPLES_ONE = 0x00000000 , AA_MODE_REPLAY_SAMPLES_TWO = 0x00000010 , AA_MODE_REPLAY_SAMPLES_FOUR = 0x00000020 ,
AA_MODE_REPLAY_SAMPLES_EIGHT = 0x00000030 , AA_MODE_REPLAY_SAMPLES_MAX = 0x00000030 , AA_MODE_REPLAY_MODE_MASK = 0x0000000f , AA_MODE_REPLAY_MODE_OFF = 0x00000000 ,
AA_MODE_REPLAY_MODE_ALPHA_TEST = 0x00000001 , AA_MODE_REPLAY_MODE_PIXEL_KILL = 0x00000002 , AA_MODE_REPLAY_MODE_DYN_BRANCH = 0x00000004 , AA_MODE_REPLAY_MODE_OPTIMAL = 0x00000004 ,
AA_MODE_REPLAY_MODE_ALL = 0x00000008 , AA_MODE_REPLAY_MODE_MAX = 0x0000000f , AA_MODE_REPLAY_TRANSPARENCY = 0x00000023 , AA_MODE_REPLAY_DISALLOW_TRAA = 0x00000100 ,
AA_MODE_REPLAY_TRANSPARENCY_DEFAULT = 0x00000000 , AA_MODE_REPLAY_TRANSPARENCY_DEFAULT_TESLA = 0x00000000 , AA_MODE_REPLAY_TRANSPARENCY_DEFAULT_FERMI = 0x00000000 , AA_MODE_REPLAY_MASK = 0x0000017f ,
AA_MODE_REPLAY_NUM_VALUES = 20 , AA_MODE_REPLAY_DEFAULT = 0x00000000
}
enum EValues_AA_MODE_SELECTOR {
AA_MODE_SELECTOR_MASK = 0x00000003 , AA_MODE_SELECTOR_APP_CONTROL = 0x00000000 , AA_MODE_SELECTOR_OVERRIDE = 0x00000001 , AA_MODE_SELECTOR_ENHANCE = 0x00000002 ,
AA_MODE_SELECTOR_MAX = 0x00000002 , AA_MODE_SELECTOR_NUM_VALUES = 5 , AA_MODE_SELECTOR_DEFAULT = AA_MODE_SELECTOR_APP_CONTROL
}
enum | EValues_AA_MODE_SELECTOR_SLIAA { AA_MODE_SELECTOR_SLIAA_DISABLED = 0 , AA_MODE_SELECTOR_SLIAA_ENABLED = 1 , AA_MODE_SELECTOR_SLIAA_NUM_VALUES = 2 , AA_MODE_SELECTOR_SLIAA_DEFAULT = AA_MODE_SELECTOR_SLIAA_DISABLED }
enum EValues_ANISO_MODE_LEVEL {
ANISO_MODE_LEVEL_MASK = 0x0000ffff , ANISO_MODE_LEVEL_NONE_POINT = 0x00000000 , ANISO_MODE_LEVEL_NONE_LINEAR = 0x00000001 , ANISO_MODE_LEVEL_MAX = 0x00000010 ,
ANISO_MODE_LEVEL_DEFAULT = 0x00000001 , ANISO_MODE_LEVEL_NUM_VALUES = 5
}
enum EValues_ANISO_MODE_SELECTOR {
ANISO_MODE_SELECTOR_MASK = 0x0000000f , ANISO_MODE_SELECTOR_APP = 0x00000000 , ANISO_MODE_SELECTOR_USER = 0x00000001 , ANISO_MODE_SELECTOR_COND = 0x00000002 ,
ANISO_MODE_SELECTOR_MAX = 0x00000002 , ANISO_MODE_SELECTOR_DEFAULT = 0x00000000 , ANISO_MODE_SELECTOR_NUM_VALUES = 6
}
enum | EValues_ANSEL_ALLOW { ANSEL_ALLOW_DISALLOWED = 0 , ANSEL_ALLOW_ALLOWED = 1 , ANSEL_ALLOW_NUM_VALUES = 2 , ANSEL_ALLOW_DEFAULT = ANSEL_ALLOW_ALLOWED }
enum | EValues_ANSEL_ALLOWLISTED { ANSEL_ALLOWLISTED_DISALLOWED = 0 , ANSEL_ALLOWLISTED_ALLOWED = 1 , ANSEL_ALLOWLISTED_NUM_VALUES = 2 , ANSEL_ALLOWLISTED_DEFAULT = ANSEL_ALLOWLISTED_DISALLOWED }
enum | EValues_ANSEL_ENABLE { ANSEL_ENABLE_OFF = 0 , ANSEL_ENABLE_ON = 1 , ANSEL_ENABLE_NUM_VALUES = 2 , ANSEL_ENABLE_DEFAULT = ANSEL_ENABLE_ON }
enum EValues_APPLICATION_PROFILE_NOTIFICATION_TIMEOUT {
APPLICATION_PROFILE_NOTIFICATION_TIMEOUT_DISABLED = 0 , APPLICATION_PROFILE_NOTIFICATION_TIMEOUT_NINE_SECONDS = 9 , APPLICATION_PROFILE_NOTIFICATION_TIMEOUT_FIFTEEN_SECONDS = 15 , APPLICATION_PROFILE_NOTIFICATION_TIMEOUT_THIRTY_SECONDS = 30 ,
APPLICATION_PROFILE_NOTIFICATION_TIMEOUT_ONE_MINUTE = 60 , APPLICATION_PROFILE_NOTIFICATION_TIMEOUT_TWO_MINUTES = 120 , APPLICATION_PROFILE_NOTIFICATION_TIMEOUT_NUM_VALUES = 6 , APPLICATION_PROFILE_NOTIFICATION_TIMEOUT_DEFAULT = APPLICATION_PROFILE_NOTIFICATION_TIMEOUT_DISABLED
}
enum EValues_BATTERY_BOOST_APP_FPS {
BATTERY_BOOST_APP_FPS_MIN = 0x00000001 , BATTERY_BOOST_APP_FPS_MAX = 0x000003ff , BATTERY_BOOST_APP_FPS_NO_OVERRIDE = 0x00000000 , BATTERY_BOOST_APP_FPS_NUM_VALUES = 3 ,
BATTERY_BOOST_APP_FPS_DEFAULT = BATTERY_BOOST_APP_FPS_NO_OVERRIDE
}
enum | EValues_CPL_HIDDEN_PROFILE { CPL_HIDDEN_PROFILE_DISABLED = 0 , CPL_HIDDEN_PROFILE_ENABLED = 1 , CPL_HIDDEN_PROFILE_NUM_VALUES = 2 , CPL_HIDDEN_PROFILE_DEFAULT = CPL_HIDDEN_PROFILE_DISABLED }
enum | EValues_EXPORT_PERF_COUNTERS { EXPORT_PERF_COUNTERS_OFF = 0x00000000 , EXPORT_PERF_COUNTERS_ON = 0x00000001 , EXPORT_PERF_COUNTERS_NUM_VALUES = 2 , EXPORT_PERF_COUNTERS_DEFAULT = EXPORT_PERF_COUNTERS_OFF }
enum | EValues_EXTERNAL_QUIET_MODE { EXTERNAL_QUIET_MODE_ON = 0x00000001 , EXTERNAL_QUIET_MODE_OFF = 0x00000000 , EXTERNAL_QUIET_MODE_NUM_VALUES = 2 , EXTERNAL_QUIET_MODE_DEFAULT = EXTERNAL_QUIET_MODE_OFF }
enum EValues_FRL_FPS {
FRL_FPS_DISABLED = 0x00000000 , FRL_FPS_MIN = 0x00000000 , FRL_FPS_MAX = 0x000003ff , FRL_FPS_NUM_VALUES = 3 ,
FRL_FPS_DEFAULT = FRL_FPS_DISABLED
}
enum | EValues_FXAA_ALLOW { FXAA_ALLOW_DISALLOWED = 0 , FXAA_ALLOW_ALLOWED = 1 , FXAA_ALLOW_NUM_VALUES = 2 , FXAA_ALLOW_DEFAULT = FXAA_ALLOW_ALLOWED }
enum | EValues_FXAA_ENABLE { FXAA_ENABLE_OFF = 0 , FXAA_ENABLE_ON = 1 , FXAA_ENABLE_NUM_VALUES = 2 , FXAA_ENABLE_DEFAULT = FXAA_ENABLE_OFF }
enum | EValues_FXAA_INDICATOR_ENABLE { FXAA_INDICATOR_ENABLE_OFF = 0 , FXAA_INDICATOR_ENABLE_ON = 1 , FXAA_INDICATOR_ENABLE_NUM_VALUES = 2 , FXAA_INDICATOR_ENABLE_DEFAULT = FXAA_INDICATOR_ENABLE_OFF }
enum | EValues_LATENCY_INDICATOR_AUTOALIGN { LATENCY_INDICATOR_AUTOALIGN_DISABLED = 0x0 , LATENCY_INDICATOR_AUTOALIGN_ENABLED = 0x1 , LATENCY_INDICATOR_AUTOALIGN_NUM_VALUES = 2 , LATENCY_INDICATOR_AUTOALIGN_DEFAULT = LATENCY_INDICATOR_AUTOALIGN_ENABLED }
enum | EValues_MCSFRSHOWSPLIT { MCSFRSHOWSPLIT_DISABLED = 0x34534064 , MCSFRSHOWSPLIT_ENABLED = 0x24545582 , MCSFRSHOWSPLIT_NUM_VALUES = 2 , MCSFRSHOWSPLIT_DEFAULT = MCSFRSHOWSPLIT_DISABLED }
enum | EValues_NV_QUALITY_UPSCALING { NV_QUALITY_UPSCALING_OFF = 0 , NV_QUALITY_UPSCALING_ON = 1 , NV_QUALITY_UPSCALING_NUM_VALUES = 2 , NV_QUALITY_UPSCALING_DEFAULT = NV_QUALITY_UPSCALING_OFF }
enum | EValues_OPTIMUS_MAXAA { OPTIMUS_MAXAA_MIN = 0 , OPTIMUS_MAXAA_MAX = 16 , OPTIMUS_MAXAA_NUM_VALUES = 2 , OPTIMUS_MAXAA_DEFAULT = 0 }
enum | EValues_PHYSXINDICATOR { PHYSXINDICATOR_DISABLED = 0x34534064 , PHYSXINDICATOR_ENABLED = 0x24545582 , PHYSXINDICATOR_NUM_VALUES = 2 , PHYSXINDICATOR_DEFAULT = PHYSXINDICATOR_DISABLED }
enum EValues_PREFERRED_PSTATE {
PREFERRED_PSTATE_ADAPTIVE = 0x00000000 , PREFERRED_PSTATE_PREFER_MAX = 0x00000001 , PREFERRED_PSTATE_DRIVER_CONTROLLED = 0x00000002 , PREFERRED_PSTATE_PREFER_CONSISTENT_PERFORMANCE = 0x00000003 ,
PREFERRED_PSTATE_PREFER_MIN = 0x00000004 , PREFERRED_PSTATE_OPTIMAL_POWER = 0x00000005 , PREFERRED_PSTATE_MIN = 0x00000000 , PREFERRED_PSTATE_MAX = 0x00000005 ,
PREFERRED_PSTATE_NUM_VALUES = 8 , PREFERRED_PSTATE_DEFAULT = PREFERRED_PSTATE_OPTIMAL_POWER
}
enum | EValues_PREVENT_UI_AF_OVERRIDE { PREVENT_UI_AF_OVERRIDE_OFF = 0 , PREVENT_UI_AF_OVERRIDE_ON = 1 , PREVENT_UI_AF_OVERRIDE_NUM_VALUES = 2 , PREVENT_UI_AF_OVERRIDE_DEFAULT = PREVENT_UI_AF_OVERRIDE_OFF }
enum EValues_SHIM_MCCOMPAT {
SHIM_MCCOMPAT_INTEGRATED = 0x00000000U , SHIM_MCCOMPAT_ENABLE = 0x00000001U , SHIM_MCCOMPAT_USER_EDITABLE = 0x00000002U , SHIM_MCCOMPAT_MASK = 0x00000003U ,
SHIM_MCCOMPAT_VIDEO_MASK = 0x00000004U , SHIM_MCCOMPAT_VARYING_BIT = 0x00000008U , SHIM_MCCOMPAT_AUTO_SELECT = 0x00000010U , SHIM_MCCOMPAT_OVERRIDE_BIT = 0x80000000U ,
SHIM_MCCOMPAT_NUM_VALUES = 8 , SHIM_MCCOMPAT_DEFAULT = SHIM_MCCOMPAT_AUTO_SELECT
}
enum EValues_SHIM_RENDERING_MODE {
SHIM_RENDERING_MODE_INTEGRATED = 0x00000000U , SHIM_RENDERING_MODE_ENABLE = 0x00000001U , SHIM_RENDERING_MODE_USER_EDITABLE = 0x00000002U , SHIM_RENDERING_MODE_MASK = 0x00000003U ,
SHIM_RENDERING_MODE_VIDEO_MASK = 0x00000004U , SHIM_RENDERING_MODE_VARYING_BIT = 0x00000008U , SHIM_RENDERING_MODE_AUTO_SELECT = 0x00000010U , SHIM_RENDERING_MODE_OVERRIDE_BIT = 0x80000000U ,
SHIM_RENDERING_MODE_NUM_VALUES = 8 , SHIM_RENDERING_MODE_DEFAULT = SHIM_RENDERING_MODE_AUTO_SELECT
}
enum EValues_SHIM_RENDERING_OPTIONS {
SHIM_RENDERING_OPTIONS_DEFAULT_RENDERING_MODE = 0x00000000U , SHIM_RENDERING_OPTIONS_DISABLE_ASYNC_PRESENT = 0x00000001U , SHIM_RENDERING_OPTIONS_EHSHELL_DETECT = 0x00000002U , SHIM_RENDERING_OPTIONS_FLASHPLAYER_HOST_DETECT = 0x00000004U ,
SHIM_RENDERING_OPTIONS_VIDEO_DRM_APP_DETECT = 0x00000008U , SHIM_RENDERING_OPTIONS_IGNORE_OVERRIDES = 0x00000010U , SHIM_RENDERING_OPTIONS_RESERVED1 = 0x00000020U , SHIM_RENDERING_OPTIONS_ENABLE_DWM_ASYNC_PRESENT = 0x00000040U ,
SHIM_RENDERING_OPTIONS_RESERVED2 = 0x00000080U , SHIM_RENDERING_OPTIONS_ALLOW_INHERITANCE = 0x00000100U , SHIM_RENDERING_OPTIONS_DISABLE_WRAPPERS = 0x00000200U , SHIM_RENDERING_OPTIONS_DISABLE_DXGI_WRAPPERS = 0x00000400U ,
SHIM_RENDERING_OPTIONS_PRUNE_UNSUPPORTED_FORMATS = 0x00000800U , SHIM_RENDERING_OPTIONS_ENABLE_ALPHA_FORMAT = 0x00001000U , SHIM_RENDERING_OPTIONS_IGPU_TRANSCODING = 0x00002000U , SHIM_RENDERING_OPTIONS_DISABLE_CUDA = 0x00004000U ,
SHIM_RENDERING_OPTIONS_ALLOW_CP_CAPS_FOR_VIDEO = 0x00008000U , SHIM_RENDERING_OPTIONS_IGPU_TRANSCODING_FWD_OPTIMUS = 0x00010000U , SHIM_RENDERING_OPTIONS_DISABLE_DURING_SECURE_BOOT = 0x00020000U , SHIM_RENDERING_OPTIONS_INVERT_FOR_QUADRO = 0x00040000U ,
SHIM_RENDERING_OPTIONS_INVERT_FOR_MSHYBRID = 0x00080000U , SHIM_RENDERING_OPTIONS_REGISTER_PROCESS_ENABLE_GOLD = 0x00100000U , SHIM_RENDERING_OPTIONS_HANDLE_WINDOWED_MODE_PERF_OPT = 0x00200000U , SHIM_RENDERING_OPTIONS_HANDLE_WIN7_ASYNC_RUNTIME_BUG = 0x00400000U ,
SHIM_RENDERING_OPTIONS_EXPLICIT_ADAPTER_OPTED_BY_APP = 0x00800000U , SHIM_RENDERING_OPTIONS_ALLOW_DYNAMIC_DISPLAY_MUX_SWITCH = 0x01000000U , SHIM_RENDERING_OPTIONS_DISALLOW_DYNAMIC_DISPLAY_MUX_SWITCH = 0x02000000U , SHIM_RENDERING_OPTIONS_DISABLE_TURING_POWER_POLICY = 0x04000000U ,
SHIM_RENDERING_OPTIONS_NUM_VALUES = 28 , SHIM_RENDERING_OPTIONS_DEFAULT = 0x00000000U
}
enum EValues_SLI_GPU_COUNT {
SLI_GPU_COUNT_AUTOSELECT = 0x00000000 , SLI_GPU_COUNT_ONE = 0x00000001 , SLI_GPU_COUNT_TWO = 0x00000002 , SLI_GPU_COUNT_THREE = 0x00000003 ,
SLI_GPU_COUNT_FOUR = 0x00000004 , SLI_GPU_COUNT_NUM_VALUES = 5 , SLI_GPU_COUNT_DEFAULT = SLI_GPU_COUNT_AUTOSELECT
}
enum EValues_SLI_PREDEFINED_GPU_COUNT {
SLI_PREDEFINED_GPU_COUNT_AUTOSELECT = 0x00000000 , SLI_PREDEFINED_GPU_COUNT_ONE = 0x00000001 , SLI_PREDEFINED_GPU_COUNT_TWO = 0x00000002 , SLI_PREDEFINED_GPU_COUNT_THREE = 0x00000003 ,
SLI_PREDEFINED_GPU_COUNT_FOUR = 0x00000004 , SLI_PREDEFINED_GPU_COUNT_NUM_VALUES = 5 , SLI_PREDEFINED_GPU_COUNT_DEFAULT = SLI_PREDEFINED_GPU_COUNT_AUTOSELECT
}
enum EValues_SLI_PREDEFINED_GPU_COUNT_DX10 {
SLI_PREDEFINED_GPU_COUNT_DX10_AUTOSELECT = 0x00000000 , SLI_PREDEFINED_GPU_COUNT_DX10_ONE = 0x00000001 , SLI_PREDEFINED_GPU_COUNT_DX10_TWO = 0x00000002 , SLI_PREDEFINED_GPU_COUNT_DX10_THREE = 0x00000003 ,
SLI_PREDEFINED_GPU_COUNT_DX10_FOUR = 0x00000004 , SLI_PREDEFINED_GPU_COUNT_DX10_NUM_VALUES = 5 , SLI_PREDEFINED_GPU_COUNT_DX10_DEFAULT = SLI_PREDEFINED_GPU_COUNT_DX10_AUTOSELECT
}
enum EValues_SLI_PREDEFINED_MODE {
SLI_PREDEFINED_MODE_AUTOSELECT = 0x00000000 , SLI_PREDEFINED_MODE_FORCE_SINGLE = 0x00000001 , SLI_PREDEFINED_MODE_FORCE_AFR = 0x00000002 , SLI_PREDEFINED_MODE_FORCE_AFR2 = 0x00000003 ,
SLI_PREDEFINED_MODE_FORCE_SFR = 0x00000004 , SLI_PREDEFINED_MODE_FORCE_AFR_OF_SFR__FALLBACK_3AFR = 0x00000005 , SLI_PREDEFINED_MODE_NUM_VALUES = 6 , SLI_PREDEFINED_MODE_DEFAULT = SLI_PREDEFINED_MODE_AUTOSELECT
}
enum EValues_SLI_PREDEFINED_MODE_DX10 {
SLI_PREDEFINED_MODE_DX10_AUTOSELECT = 0x00000000 , SLI_PREDEFINED_MODE_DX10_FORCE_SINGLE = 0x00000001 , SLI_PREDEFINED_MODE_DX10_FORCE_AFR = 0x00000002 , SLI_PREDEFINED_MODE_DX10_FORCE_AFR2 = 0x00000003 ,
SLI_PREDEFINED_MODE_DX10_FORCE_SFR = 0x00000004 , SLI_PREDEFINED_MODE_DX10_FORCE_AFR_OF_SFR__FALLBACK_3AFR = 0x00000005 , SLI_PREDEFINED_MODE_DX10_NUM_VALUES = 6 , SLI_PREDEFINED_MODE_DX10_DEFAULT = SLI_PREDEFINED_MODE_DX10_AUTOSELECT
}
enum EValues_SLI_RENDERING_MODE {
SLI_RENDERING_MODE_AUTOSELECT = 0x00000000 , SLI_RENDERING_MODE_FORCE_SINGLE = 0x00000001 , SLI_RENDERING_MODE_FORCE_AFR = 0x00000002 , SLI_RENDERING_MODE_FORCE_AFR2 = 0x00000003 ,
SLI_RENDERING_MODE_FORCE_SFR = 0x00000004 , SLI_RENDERING_MODE_FORCE_AFR_OF_SFR__FALLBACK_3AFR = 0x00000005 , SLI_RENDERING_MODE_NUM_VALUES = 6 , SLI_RENDERING_MODE_DEFAULT = SLI_RENDERING_MODE_AUTOSELECT
}
enum EValues_VRPRERENDERLIMIT {
VRPRERENDERLIMIT_MIN = 0x00 , VRPRERENDERLIMIT_MAX = 0xff , VRPRERENDERLIMIT_APP_CONTROLLED = 0x00 , VRPRERENDERLIMIT_DEFAULT = 0x01 ,
VRPRERENDERLIMIT_NUM_VALUES = 4
}
enum | EValues_VRRFEATUREINDICATOR { VRRFEATUREINDICATOR_DISABLED = 0x0 , VRRFEATUREINDICATOR_ENABLED = 0x1 , VRRFEATUREINDICATOR_NUM_VALUES = 2 , VRRFEATUREINDICATOR_DEFAULT = VRRFEATUREINDICATOR_ENABLED }
enum | EValues_VRROVERLAYINDICATOR { VRROVERLAYINDICATOR_DISABLED = 0x0 , VRROVERLAYINDICATOR_ENABLED = 0x1 , VRROVERLAYINDICATOR_NUM_VALUES = 2 , VRROVERLAYINDICATOR_DEFAULT = VRROVERLAYINDICATOR_ENABLED }
enum EValues_VRRREQUESTSTATE {
VRRREQUESTSTATE_DISABLED = 0x0 , VRRREQUESTSTATE_FULLSCREEN_ONLY = 0x1 , VRRREQUESTSTATE_FULLSCREEN_AND_WINDOWED = 0x2 , VRRREQUESTSTATE_NUM_VALUES = 3 ,
VRRREQUESTSTATE_DEFAULT = VRRREQUESTSTATE_FULLSCREEN_ONLY
}
enum EValues_VRR_APP_OVERRIDE {
VRR_APP_OVERRIDE_ALLOW = 0 , VRR_APP_OVERRIDE_FORCE_OFF = 1 , VRR_APP_OVERRIDE_DISALLOW = 2 , VRR_APP_OVERRIDE_ULMB = 3 ,
VRR_APP_OVERRIDE_FIXED_REFRESH = 4 , VRR_APP_OVERRIDE_NUM_VALUES = 5 , VRR_APP_OVERRIDE_DEFAULT = VRR_APP_OVERRIDE_ALLOW
}
enum EValues_VRR_APP_OVERRIDE_REQUEST_STATE {
VRR_APP_OVERRIDE_REQUEST_STATE_ALLOW = 0 , VRR_APP_OVERRIDE_REQUEST_STATE_FORCE_OFF = 1 , VRR_APP_OVERRIDE_REQUEST_STATE_DISALLOW = 2 , VRR_APP_OVERRIDE_REQUEST_STATE_ULMB = 3 ,
VRR_APP_OVERRIDE_REQUEST_STATE_FIXED_REFRESH = 4 , VRR_APP_OVERRIDE_REQUEST_STATE_NUM_VALUES = 5 , VRR_APP_OVERRIDE_REQUEST_STATE_DEFAULT = VRR_APP_OVERRIDE_REQUEST_STATE_ALLOW
}
enum EValues_VRR_MODE {
VRR_MODE_DISABLED = 0x0 , VRR_MODE_FULLSCREEN_ONLY = 0x1 , VRR_MODE_FULLSCREEN_AND_WINDOWED = 0x2 , VRR_MODE_NUM_VALUES = 3 ,
VRR_MODE_DEFAULT = VRR_MODE_FULLSCREEN_ONLY
}
enum | EValues_VSYNCSMOOTHAFR { VSYNCSMOOTHAFR_OFF = 0x00000000 , VSYNCSMOOTHAFR_ON = 0x00000001 , VSYNCSMOOTHAFR_NUM_VALUES = 2 , VSYNCSMOOTHAFR_DEFAULT = VSYNCSMOOTHAFR_OFF }
enum EValues_VSYNCVRRCONTROL {
VSYNCVRRCONTROL_DISABLE = 0x00000000 , VSYNCVRRCONTROL_ENABLE = 0x00000001 , VSYNCVRRCONTROL_NOTSUPPORTED = 0x9f95128e , VSYNCVRRCONTROL_NUM_VALUES = 3 ,
VSYNCVRRCONTROL_DEFAULT = VSYNCVRRCONTROL_ENABLE
}
enum | EValues_VSYNC_BEHAVIOR_FLAGS { VSYNC_BEHAVIOR_FLAGS_NONE = 0x00000000 , VSYNC_BEHAVIOR_FLAGS_DEFAULT = 0x00000000 , VSYNC_BEHAVIOR_FLAGS_IGNORE_FLIPINTERVAL_MULTIPLE = 0x00000001 , VSYNC_BEHAVIOR_FLAGS_NUM_VALUES = 3 }
enum | EValues_WKS_API_STEREO_EYES_EXCHANGE { WKS_API_STEREO_EYES_EXCHANGE_OFF = 0 , WKS_API_STEREO_EYES_EXCHANGE_ON = 1 , WKS_API_STEREO_EYES_EXCHANGE_NUM_VALUES = 2 , WKS_API_STEREO_EYES_EXCHANGE_DEFAULT = WKS_API_STEREO_EYES_EXCHANGE_OFF }
enum EValues_WKS_API_STEREO_MODE {
WKS_API_STEREO_MODE_SHUTTER_GLASSES = 0 , WKS_API_STEREO_MODE_VERTICAL_INTERLACED = 1 , WKS_API_STEREO_MODE_TWINVIEW = 2 , WKS_API_STEREO_MODE_NV17_SHUTTER_GLASSES_AUTO = 3 ,
WKS_API_STEREO_MODE_NV17_SHUTTER_GLASSES_DAC0 = 4 , WKS_API_STEREO_MODE_NV17_SHUTTER_GLASSES_DAC1 = 5 , WKS_API_STEREO_MODE_COLOR_LINE = 6 , WKS_API_STEREO_MODE_COLOR_INTERLEAVED = 7 ,
WKS_API_STEREO_MODE_ANAGLYPH = 8 , WKS_API_STEREO_MODE_HORIZONTAL_INTERLACED = 9 , WKS_API_STEREO_MODE_SIDE_FIELD = 10 , WKS_API_STEREO_MODE_SUB_FIELD = 11 ,
WKS_API_STEREO_MODE_CHECKERBOARD = 12 , WKS_API_STEREO_MODE_INVERSE_CHECKERBOARD = 13 , WKS_API_STEREO_MODE_TRIDELITY_SL = 14 , WKS_API_STEREO_MODE_TRIDELITY_MV = 15 ,
WKS_API_STEREO_MODE_SEEFRONT = 16 , WKS_API_STEREO_MODE_STEREO_MIRROR = 17 , WKS_API_STEREO_MODE_FRAME_SEQUENTIAL = 18 , WKS_API_STEREO_MODE_AUTODETECT_PASSIVE_MODE = 19 ,
WKS_API_STEREO_MODE_AEGIS_DT_FRAME_SEQUENTIAL = 20 , WKS_API_STEREO_MODE_OEM_EMITTER_FRAME_SEQUENTIAL = 21 , WKS_API_STEREO_MODE_DP_INBAND = 22 , WKS_API_STEREO_MODE_USE_HW_DEFAULT = 0xffffffff ,
WKS_API_STEREO_MODE_DEFAULT_GL = 3 , WKS_API_STEREO_MODE_NUM_VALUES = 25 , WKS_API_STEREO_MODE_DEFAULT = WKS_API_STEREO_MODE_SHUTTER_GLASSES
}
enum EValues_WKS_STEREO_DONGLE_SUPPORT {
WKS_STEREO_DONGLE_SUPPORT_OFF = 0 , WKS_STEREO_DONGLE_SUPPORT_DAC = 1 , WKS_STEREO_DONGLE_SUPPORT_DLP = 2 , WKS_STEREO_DONGLE_SUPPORT_NUM_VALUES = 3 ,
WKS_STEREO_DONGLE_SUPPORT_DEFAULT = WKS_STEREO_DONGLE_SUPPORT_DAC
}
enum | EValues_WKS_STEREO_SUPPORT { WKS_STEREO_SUPPORT_OFF = 0 , WKS_STEREO_SUPPORT_ON = 1 , WKS_STEREO_SUPPORT_NUM_VALUES = 2 , WKS_STEREO_SUPPORT_DEFAULT = WKS_STEREO_SUPPORT_OFF }
enum EValues_WKS_STEREO_SWAP_MODE {
WKS_STEREO_SWAP_MODE_APPLICATION_CONTROL = 0x0 , WKS_STEREO_SWAP_MODE_PER_EYE = 0x1 , WKS_STEREO_SWAP_MODE_PER_EYE_PAIR = 0x2 , WKS_STEREO_SWAP_MODE_LEGACY_BEHAVIOR = 0x3 ,
WKS_STEREO_SWAP_MODE_PER_EYE_FOR_SWAP_GROUP = 0x4 , WKS_STEREO_SWAP_MODE_NUM_VALUES = 5 , WKS_STEREO_SWAP_MODE_DEFAULT = WKS_STEREO_SWAP_MODE_APPLICATION_CONTROL
}
enum EValues_AO_MODE {
AO_MODE_OFF = 0 , AO_MODE_LOW = 1 , AO_MODE_MEDIUM = 2 , AO_MODE_HIGH = 3 ,
AO_MODE_NUM_VALUES = 4 , AO_MODE_DEFAULT = AO_MODE_OFF
}
enum | EValues_AO_MODE_ACTIVE { AO_MODE_ACTIVE_DISABLED = 0 , AO_MODE_ACTIVE_ENABLED = 1 , AO_MODE_ACTIVE_NUM_VALUES = 2 , AO_MODE_ACTIVE_DEFAULT = AO_MODE_ACTIVE_DISABLED }
enum | EValues_AUTO_LODBIASADJUST { AUTO_LODBIASADJUST_OFF = 0x00000000 , AUTO_LODBIASADJUST_ON = 0x00000001 , AUTO_LODBIASADJUST_NUM_VALUES = 2 , AUTO_LODBIASADJUST_DEFAULT = AUTO_LODBIASADJUST_ON }
enum | EValues_EXPORT_PERF_COUNTERS_DX9_ONLY { EXPORT_PERF_COUNTERS_DX9_ONLY_OFF = 0x00000000 , EXPORT_PERF_COUNTERS_DX9_ONLY_ON = 0x00000001 , EXPORT_PERF_COUNTERS_DX9_ONLY_NUM_VALUES = 2 , EXPORT_PERF_COUNTERS_DX9_ONLY_DEFAULT = EXPORT_PERF_COUNTERS_DX9_ONLY_OFF }
enum | EValues_LODBIASADJUST { LODBIASADJUST_MIN = 0xffffff80 , LODBIASADJUST_MAX = 128 , LODBIASADJUST_NUM_VALUES = 2 , LODBIASADJUST_DEFAULT = 0 }
enum | EValues_MAXWELL_B_SAMPLE_INTERLEAVE { MAXWELL_B_SAMPLE_INTERLEAVE_OFF = 0 , MAXWELL_B_SAMPLE_INTERLEAVE_ON = 1 , MAXWELL_B_SAMPLE_INTERLEAVE_NUM_VALUES = 2 , MAXWELL_B_SAMPLE_INTERLEAVE_DEFAULT = MAXWELL_B_SAMPLE_INTERLEAVE_OFF }
enum EValues_PRERENDERLIMIT {
PRERENDERLIMIT_MIN = 0x00 , PRERENDERLIMIT_MAX = 0xff , PRERENDERLIMIT_APP_CONTROLLED = 0x00 , PRERENDERLIMIT_NUM_VALUES = 3 ,
PRERENDERLIMIT_DEFAULT = PRERENDERLIMIT_APP_CONTROLLED
}
enum | EValues_PS_SHADERDISKCACHE { PS_SHADERDISKCACHE_OFF = 0x00000000 , PS_SHADERDISKCACHE_ON = 0x00000001 , PS_SHADERDISKCACHE_NUM_VALUES = 2 , PS_SHADERDISKCACHE_DEFAULT = PS_SHADERDISKCACHE_ON }
enum | EValues_PS_SHADERDISKCACHE_MAX_SIZE { PS_SHADERDISKCACHE_MAX_SIZE_MIN = 0x0 , PS_SHADERDISKCACHE_MAX_SIZE_MAX = 0xffffffff , PS_SHADERDISKCACHE_MAX_SIZE_NUM_VALUES = 2 , PS_SHADERDISKCACHE_MAX_SIZE_DEFAULT = 0x1000 }
enum | EValues_PS_TEXFILTER_ANISO_OPTS2 { PS_TEXFILTER_ANISO_OPTS2_OFF = 0x00000000 , PS_TEXFILTER_ANISO_OPTS2_ON = 0x00000001 , PS_TEXFILTER_ANISO_OPTS2_NUM_VALUES = 2 , PS_TEXFILTER_ANISO_OPTS2_DEFAULT = PS_TEXFILTER_ANISO_OPTS2_OFF }
enum | EValues_PS_TEXFILTER_BILINEAR_IN_ANISO { PS_TEXFILTER_BILINEAR_IN_ANISO_OFF = 0x00000000 , PS_TEXFILTER_BILINEAR_IN_ANISO_ON = 0x00000001 , PS_TEXFILTER_BILINEAR_IN_ANISO_NUM_VALUES = 2 , PS_TEXFILTER_BILINEAR_IN_ANISO_DEFAULT = PS_TEXFILTER_BILINEAR_IN_ANISO_OFF }
enum | EValues_PS_TEXFILTER_DISABLE_TRILIN_SLOPE { PS_TEXFILTER_DISABLE_TRILIN_SLOPE_OFF = 0x00000000 , PS_TEXFILTER_DISABLE_TRILIN_SLOPE_ON = 0x00000001 , PS_TEXFILTER_DISABLE_TRILIN_SLOPE_NUM_VALUES = 2 , PS_TEXFILTER_DISABLE_TRILIN_SLOPE_DEFAULT = PS_TEXFILTER_DISABLE_TRILIN_SLOPE_OFF }
enum | EValues_PS_TEXFILTER_NO_NEG_LODBIAS { PS_TEXFILTER_NO_NEG_LODBIAS_OFF = 0x00000000 , PS_TEXFILTER_NO_NEG_LODBIAS_ON = 0x00000001 , PS_TEXFILTER_NO_NEG_LODBIAS_NUM_VALUES = 2 , PS_TEXFILTER_NO_NEG_LODBIAS_DEFAULT = PS_TEXFILTER_NO_NEG_LODBIAS_OFF }
enum EValues_QUALITY_ENHANCEMENTS {
QUALITY_ENHANCEMENTS_HIGHQUALITY = 0xfffffff6 , QUALITY_ENHANCEMENTS_QUALITY = 0x00000000 , QUALITY_ENHANCEMENTS_PERFORMANCE = 0x0000000a , QUALITY_ENHANCEMENTS_HIGHPERFORMANCE = 0x00000014 ,
QUALITY_ENHANCEMENTS_NUM_VALUES = 4 , QUALITY_ENHANCEMENTS_DEFAULT = QUALITY_ENHANCEMENTS_QUALITY
}
enum | EValues_QUALITY_ENHANCEMENT_SUBSTITUTION { QUALITY_ENHANCEMENT_SUBSTITUTION_NO_SUBSTITUTION = 0x00000000 , QUALITY_ENHANCEMENT_SUBSTITUTION_HIGHQUALITY_BECOMES_QUALITY = 0x00000001 , QUALITY_ENHANCEMENT_SUBSTITUTION_NUM_VALUES = 2 , QUALITY_ENHANCEMENT_SUBSTITUTION_DEFAULT = QUALITY_ENHANCEMENT_SUBSTITUTION_NO_SUBSTITUTION }
enum EValues_REFRESH_RATE_OVERRIDE {
REFRESH_RATE_OVERRIDE_APPLICATION_CONTROLLED = 0x00000000 , REFRESH_RATE_OVERRIDE_HIGHEST_AVAILABLE = 0x00000001 , REFRESH_RATE_OVERRIDE_LOW_LATENCY_RR_MASK = 0x00000FF0 , REFRESH_RATE_OVERRIDE_NUM_VALUES = 3 ,
REFRESH_RATE_OVERRIDE_DEFAULT = REFRESH_RATE_OVERRIDE_APPLICATION_CONTROLLED
}
enum | EValues_SET_POWER_THROTTLE_FOR_PCIe_COMPLIANCE { SET_POWER_THROTTLE_FOR_PCIe_COMPLIANCE_OFF = 0x00000000 , SET_POWER_THROTTLE_FOR_PCIe_COMPLIANCE_ON = 0x00000001 , SET_POWER_THROTTLE_FOR_PCIe_COMPLIANCE_NUM_VALUES = 2 , SET_POWER_THROTTLE_FOR_PCIe_COMPLIANCE_DEFAULT = SET_POWER_THROTTLE_FOR_PCIe_COMPLIANCE_OFF }
enum EValues_SET_VAB_DATA {
SET_VAB_DATA_ZERO = 0x00000000 , SET_VAB_DATA_UINT_ONE = 0x00000001 , SET_VAB_DATA_FLOAT_ONE = 0x3f800000 , SET_VAB_DATA_FLOAT_POS_INF = 0x7f800000 ,
SET_VAB_DATA_FLOAT_NAN = 0x7fc00000 , SET_VAB_DATA_USE_API_DEFAULTS = 0xffffffff , SET_VAB_DATA_NUM_VALUES = 6 , SET_VAB_DATA_DEFAULT = SET_VAB_DATA_USE_API_DEFAULTS
}
enum EValues_VSYNCMODE {
VSYNCMODE_PASSIVE = 0x60925292 , VSYNCMODE_FORCEOFF = 0x08416747 , VSYNCMODE_FORCEON = 0x47814940 , VSYNCMODE_FLIPINTERVAL2 = 0x32610244 ,
VSYNCMODE_FLIPINTERVAL3 = 0x71271021 , VSYNCMODE_FLIPINTERVAL4 = 0x13245256 , VSYNCMODE_VIRTUAL = 0x18888888 , VSYNCMODE_NUM_VALUES = 7 ,
VSYNCMODE_DEFAULT = VSYNCMODE_PASSIVE
}
enum | EValues_VSYNCTEARCONTROL { VSYNCTEARCONTROL_DISABLE = 0x96861077 , VSYNCTEARCONTROL_ENABLE = 0x99941284 , VSYNCTEARCONTROL_NUM_VALUES = 2 , VSYNCTEARCONTROL_DEFAULT = VSYNCTEARCONTROL_DISABLE }

Macro Definition Documentation

◆ AA_BEHAVIOR_FLAGS_STRING

#define AA_BEHAVIOR_FLAGS_STRING L"Antialiasing - Behavior Flags"

◆ AA_MODE_ALPHATOCOVERAGE_STRING

#define AA_MODE_ALPHATOCOVERAGE_STRING L"Antialiasing - Transparency Multisampling"

◆ AA_MODE_GAMMACORRECTION_STRING

#define AA_MODE_GAMMACORRECTION_STRING L"Antialiasing - Gamma correction"

◆ AA_MODE_METHOD_STRING

#define AA_MODE_METHOD_STRING L"Antialiasing - Setting"

◆ AA_MODE_REPLAY_STRING

#define AA_MODE_REPLAY_STRING L"Antialiasing - Transparency Supersampling"

◆ AA_MODE_SELECTOR_SLIAA_STRING

#define AA_MODE_SELECTOR_SLIAA_STRING L"Antialiasing - SLI AA"

◆ AA_MODE_SELECTOR_STRING

#define AA_MODE_SELECTOR_STRING L"Antialiasing - Mode"

◆ ANISO_MODE_LEVEL_STRING

#define ANISO_MODE_LEVEL_STRING L"Anisotropic filtering setting"

◆ ANISO_MODE_SELECTOR_STRING

#define ANISO_MODE_SELECTOR_STRING L"Anisotropic filtering mode"

◆ ANSEL_ALLOW_STRING

#define ANSEL_ALLOW_STRING L"NVIDIA Predefined Ansel Usage"

◆ ANSEL_ALLOWLISTED_STRING

#define ANSEL_ALLOWLISTED_STRING L"Ansel flags for enabled applications"

◆ ANSEL_ENABLE_STRING

#define ANSEL_ENABLE_STRING L"Enable Ansel"

◆ AO_MODE_ACTIVE_STRING

#define AO_MODE_ACTIVE_STRING L"NVIDIA Predefined Ambient Occlusion Usage"

◆ AO_MODE_STRING

#define AO_MODE_STRING L"Ambient Occlusion"

◆ APPIDLE_DYNAMIC_FRL_FPS_STRING

#define APPIDLE_DYNAMIC_FRL_FPS_STRING L"Idle Application Max FPS Limit"

◆ APPIDLE_DYNAMIC_FRL_THRESHOLD_TIME_STRING

#define APPIDLE_DYNAMIC_FRL_THRESHOLD_TIME_STRING L"Idle Application Threshold Time out in seconds"

◆ APPLICATION_PROFILE_NOTIFICATION_TIMEOUT_STRING

#define APPLICATION_PROFILE_NOTIFICATION_TIMEOUT_STRING L"Application Profile Notification Popup Timeout"

◆ APPLICATION_STEAM_ID_STRING

#define APPLICATION_STEAM_ID_STRING L"Steam Application ID"

◆ AUTO_LODBIASADJUST_STRING

#define AUTO_LODBIASADJUST_STRING L"Texture filtering - Driver Controlled LOD Bias"

◆ BATTERY_BOOST_APP_FPS_STRING

#define BATTERY_BOOST_APP_FPS_STRING L"Battery Boost Application FPS"

◆ CPL_HIDDEN_PROFILE_STRING

#define CPL_HIDDEN_PROFILE_STRING L"Do not display this profile in the Control Panel"

◆ CUDA_EXCLUDED_GPUS_DEFAULT

#define CUDA_EXCLUDED_GPUS_DEFAULT CUDA_EXCLUDED_GPUS_NONE

◆ CUDA_EXCLUDED_GPUS_NONE

#define CUDA_EXCLUDED_GPUS_NONE L"none"

◆ CUDA_EXCLUDED_GPUS_NUM_VALUES

#define CUDA_EXCLUDED_GPUS_NUM_VALUES 1

◆ CUDA_EXCLUDED_GPUS_STRING

#define CUDA_EXCLUDED_GPUS_STRING L"List of Universal GPU ids"

◆ D3DOGL_GPU_MAX_POWER_DEFAULT

#define D3DOGL_GPU_MAX_POWER_DEFAULT D3DOGL_GPU_MAX_POWER_DEFAULTPOWER

◆ D3DOGL_GPU_MAX_POWER_DEFAULTPOWER

#define D3DOGL_GPU_MAX_POWER_DEFAULTPOWER L"0"

◆ D3DOGL_GPU_MAX_POWER_NUM_VALUES

#define D3DOGL_GPU_MAX_POWER_NUM_VALUES 1

◆ D3DOGL_GPU_MAX_POWER_STRING

#define D3DOGL_GPU_MAX_POWER_STRING L"Maximum GPU Power"

◆ EXPORT_PERF_COUNTERS_DX9_ONLY_STRING

#define EXPORT_PERF_COUNTERS_DX9_ONLY_STRING L"Export Performance Counters for DX9 only"

◆ EXPORT_PERF_COUNTERS_STRING

#define EXPORT_PERF_COUNTERS_STRING L"Export Performance Counters"

◆ EXTERNAL_QUIET_MODE_STRING

#define EXTERNAL_QUIET_MODE_STRING L"External Quiet Mode (XQM)"

◆ FRL_FPS_STRING

#define FRL_FPS_STRING L"Frame Rate Limiter"

◆ FXAA_ALLOW_STRING

#define FXAA_ALLOW_STRING L"NVIDIA Predefined FXAA Usage"

◆ FXAA_ENABLE_STRING

#define FXAA_ENABLE_STRING L"Enable FXAA"

◆ FXAA_INDICATOR_ENABLE_STRING

#define FXAA_INDICATOR_ENABLE_STRING L"Enable FXAA Indicator"

◆ ICAFE_LOGO_CONFIG_STRING

#define ICAFE_LOGO_CONFIG_STRING L"ICafe Settings"

◆ LATENCY_INDICATOR_AUTOALIGN_STRING

#define LATENCY_INDICATOR_AUTOALIGN_STRING L"Autoalign flash indicator"

◆ LODBIASADJUST_STRING

#define LODBIASADJUST_STRING L"Texture filtering - LOD Bias"

◆ MAXWELL_B_SAMPLE_INTERLEAVE_STRING

#define MAXWELL_B_SAMPLE_INTERLEAVE_STRING L"Enable sample interleaving (MFAA)"

◆ MCSFRSHOWSPLIT_STRING

#define MCSFRSHOWSPLIT_STRING L"SLI indicator"

◆ NV_QUALITY_UPSCALING_STRING

#define NV_QUALITY_UPSCALING_STRING L"NVIDIA Quality upscaling"

◆ OGL_AA_LINE_GAMMA_STRING

#define OGL_AA_LINE_GAMMA_STRING L"Antialiasing - Line gamma"

◆ OGL_CPL_GDI_COMPATIBILITY_STRING

#define OGL_CPL_GDI_COMPATIBILITY_STRING L"OpenGL GDI compatibility"

◆ OGL_CPL_PREFER_DXPRESENT_STRING

#define OGL_CPL_PREFER_DXPRESENT_STRING L"Vulkan/OpenGL present method"

◆ OGL_DEEP_COLOR_SCANOUT_STRING

#define OGL_DEEP_COLOR_SCANOUT_STRING L"Deep color for 3D applications"

◆ OGL_DEFAULT_SWAP_INTERVAL_FRACTIONAL_STRING

#define OGL_DEFAULT_SWAP_INTERVAL_FRACTIONAL_STRING L"OpenGL default swap interval fraction"

◆ OGL_DEFAULT_SWAP_INTERVAL_SIGN_STRING

#define OGL_DEFAULT_SWAP_INTERVAL_SIGN_STRING L"OpenGL default swap interval sign"

◆ OGL_DEFAULT_SWAP_INTERVAL_STRING

#define OGL_DEFAULT_SWAP_INTERVAL_STRING L"OpenGL default swap interval"

◆ OGL_EVENT_LOG_SEVERITY_THRESHOLD_STRING

#define OGL_EVENT_LOG_SEVERITY_THRESHOLD_STRING L"Event Log Severity Threshold"

◆ OGL_EXTENSION_STRING_VERSION_STRING

#define OGL_EXTENSION_STRING_VERSION_STRING L"Extension String version"

◆ OGL_FORCE_BLIT_STRING

#define OGL_FORCE_BLIT_STRING L"Buffer-flipping mode"

◆ OGL_FORCE_STEREO_STRING

#define OGL_FORCE_STEREO_STRING L"Force Stereo shuttering"

◆ OGL_IMPLICIT_GPU_AFFINITY_AUTOSELECT

#define OGL_IMPLICIT_GPU_AFFINITY_AUTOSELECT L"autoselect"

◆ OGL_IMPLICIT_GPU_AFFINITY_DEFAULT

#define OGL_IMPLICIT_GPU_AFFINITY_DEFAULT OGL_IMPLICIT_GPU_AFFINITY_AUTOSELECT

◆ OGL_IMPLICIT_GPU_AFFINITY_ENV_VAR

#define OGL_IMPLICIT_GPU_AFFINITY_ENV_VAR L"OGL_DEFAULT_RENDERING_GPU"

◆ OGL_IMPLICIT_GPU_AFFINITY_NUM_VALUES

#define OGL_IMPLICIT_GPU_AFFINITY_NUM_VALUES 1

◆ OGL_IMPLICIT_GPU_AFFINITY_STRING

#define OGL_IMPLICIT_GPU_AFFINITY_STRING L"Preferred OpenGL GPU"

◆ OGL_MAX_FRAMES_ALLOWED_STRING

#define OGL_MAX_FRAMES_ALLOWED_STRING L"Maximum frames allowed"

◆ OGL_OVERLAY_PIXEL_TYPE_STRING

#define OGL_OVERLAY_PIXEL_TYPE_STRING L"Exported Overlay pixel types"

◆ OGL_OVERLAY_SUPPORT_STRING

#define OGL_OVERLAY_SUPPORT_STRING L"Enable overlay"

◆ OGL_QUALITY_ENHANCEMENTS_STRING

#define OGL_QUALITY_ENHANCEMENTS_STRING L"High level control of the rendering quality on OpenGL"

◆ OGL_SINGLE_BACKDEPTH_BUFFER_STRING

#define OGL_SINGLE_BACKDEPTH_BUFFER_STRING L"Unified back/depth buffer"

◆ OGL_SLI_MULTICAST_STRING

#define OGL_SLI_MULTICAST_STRING L"Enable NV_gpu_multicast extension"

◆ OGL_THREAD_CONTROL_STRING

#define OGL_THREAD_CONTROL_STRING L"Threaded optimization"

◆ OGL_TMON_LEVEL_STRING

#define OGL_TMON_LEVEL_STRING L"Event Log Tmon Severity Threshold"

◆ OGL_TRIPLE_BUFFER_STRING

#define OGL_TRIPLE_BUFFER_STRING L"Triple buffering"

◆ OPTIMUS_MAXAA_STRING

#define OPTIMUS_MAXAA_STRING L"Maximum AA samples allowed for a given application"

◆ PHYSXINDICATOR_STRING

#define PHYSXINDICATOR_STRING L"Display the PhysX indicator"

◆ PREFERRED_PSTATE_STRING

#define PREFERRED_PSTATE_STRING L"Power management mode"

◆ PRERENDERLIMIT_STRING

#define PRERENDERLIMIT_STRING L"Maximum pre-rendered frames"

◆ PREVENT_UI_AF_OVERRIDE_STRING

#define PREVENT_UI_AF_OVERRIDE_STRING L"No override of Anisotropic filtering"

◆ PS_SHADERDISKCACHE_DLL_PATH_WCHAR_STRING

#define PS_SHADERDISKCACHE_DLL_PATH_WCHAR_STRING L"shader cache path to dll"

◆ PS_SHADERDISKCACHE_MAX_SIZE_STRING

#define PS_SHADERDISKCACHE_MAX_SIZE_STRING L"Shader disk cache maximum size"

◆ PS_SHADERDISKCACHE_STRING

#define PS_SHADERDISKCACHE_STRING L"Shader Cache"

◆ PS_TEXFILTER_ANISO_OPTS2_STRING

#define PS_TEXFILTER_ANISO_OPTS2_STRING L"Texture filtering - Anisotropic sample optimization"

◆ PS_TEXFILTER_BILINEAR_IN_ANISO_STRING

#define PS_TEXFILTER_BILINEAR_IN_ANISO_STRING L"Texture filtering - Anisotropic filter optimization"

◆ PS_TEXFILTER_DISABLE_TRILIN_SLOPE_STRING

#define PS_TEXFILTER_DISABLE_TRILIN_SLOPE_STRING L"Texture filtering - Trilinear optimization"

◆ PS_TEXFILTER_NO_NEG_LODBIAS_STRING

#define PS_TEXFILTER_NO_NEG_LODBIAS_STRING L"Texture filtering - Negative LOD bias"

◆ QUALITY_ENHANCEMENT_SUBSTITUTION_STRING

#define QUALITY_ENHANCEMENT_SUBSTITUTION_STRING L"Texture filtering - Quality Substitution"

◆ QUALITY_ENHANCEMENTS_STRING

#define QUALITY_ENHANCEMENTS_STRING L"Texture filtering - Quality"

◆ REFRESH_RATE_OVERRIDE_STRING

#define REFRESH_RATE_OVERRIDE_STRING L"Preferred refresh rate"

◆ SET_POWER_THROTTLE_FOR_PCIe_COMPLIANCE_STRING

#define SET_POWER_THROTTLE_FOR_PCIe_COMPLIANCE_STRING L"PowerThrottle"

◆ SET_VAB_DATA_STRING

#define SET_VAB_DATA_STRING L"VAB Default Data"

◆ SHIM_MAXRES_STRING

#define SHIM_MAXRES_STRING L"Maximum resolution allowed for a given application"

◆ SHIM_MCCOMPAT_STRING

#define SHIM_MCCOMPAT_STRING L"Optimus flags for enabled applications"

◆ SHIM_RENDERING_MODE_STRING

#define SHIM_RENDERING_MODE_STRING L"Enable application for Optimus"

◆ SHIM_RENDERING_OPTIONS_STRING

#define SHIM_RENDERING_OPTIONS_STRING L"Shim Rendering Mode Options per application for Optimus"

◆ SLI_GPU_COUNT_STRING

#define SLI_GPU_COUNT_STRING L"Number of GPUs to use on SLI rendering mode"

◆ SLI_PREDEFINED_GPU_COUNT_DX10_STRING

#define SLI_PREDEFINED_GPU_COUNT_DX10_STRING L"NVIDIA predefined number of GPUs to use on SLI rendering mode on DirectX 10"

◆ SLI_PREDEFINED_GPU_COUNT_STRING

#define SLI_PREDEFINED_GPU_COUNT_STRING L"NVIDIA predefined number of GPUs to use on SLI rendering mode"

◆ SLI_PREDEFINED_MODE_DX10_STRING

#define SLI_PREDEFINED_MODE_DX10_STRING L"NVIDIA predefined SLI mode on DirectX 10"

◆ SLI_PREDEFINED_MODE_STRING

#define SLI_PREDEFINED_MODE_STRING L"NVIDIA predefined SLI mode"

◆ SLI_RENDERING_MODE_STRING

#define SLI_RENDERING_MODE_STRING L"SLI rendering mode"

◆ VRPRERENDERLIMIT_STRING

#define VRPRERENDERLIMIT_STRING L"Virtual Reality pre-rendered frames"

◆ VRR_APP_OVERRIDE_REQUEST_STATE_STRING

#define VRR_APP_OVERRIDE_REQUEST_STATE_STRING L"G-SYNC"

◆ VRR_APP_OVERRIDE_STRING

#define VRR_APP_OVERRIDE_STRING L"G-SYNC"

◆ VRR_MODE_STRING

#define VRR_MODE_STRING L"Enable G-SYNC globally"

◆ VRRFEATUREINDICATOR_STRING

#define VRRFEATUREINDICATOR_STRING L"Toggle the VRR global feature"

◆ VRROVERLAYINDICATOR_STRING

#define VRROVERLAYINDICATOR_STRING L"Display the VRR Overlay Indicator"

◆ VRRREQUESTSTATE_STRING

#define VRRREQUESTSTATE_STRING L"VRR requested state"

◆ VSYNC_BEHAVIOR_FLAGS_STRING

#define VSYNC_BEHAVIOR_FLAGS_STRING L"Vsync - Behavior Flags"

◆ VSYNCMODE_STRING

#define VSYNCMODE_STRING L"Vertical Sync"

◆ VSYNCSMOOTHAFR_STRING

#define VSYNCSMOOTHAFR_STRING L"Flag to control smooth AFR behavior"

◆ VSYNCTEARCONTROL_STRING

#define VSYNCTEARCONTROL_STRING L"Vertical Sync Tear Control"

◆ VSYNCVRRCONTROL_STRING

#define VSYNCVRRCONTROL_STRING L"Variable refresh Rate"

◆ WKS_API_STEREO_EYES_EXCHANGE_STRING

#define WKS_API_STEREO_EYES_EXCHANGE_STRING L"Stereo - Swap eyes"

◆ WKS_API_STEREO_MODE_STRING

#define WKS_API_STEREO_MODE_STRING L"Stereo - Display mode"

◆ WKS_STEREO_DONGLE_SUPPORT_STRING

#define WKS_STEREO_DONGLE_SUPPORT_STRING L"Stereo - Dongle Support"

◆ WKS_STEREO_SUPPORT_STRING

#define WKS_STEREO_SUPPORT_STRING L"Stereo - Enable"

◆ WKS_STEREO_SWAP_MODE_STRING

#define WKS_STEREO_SWAP_MODE_STRING L"Stereo - swap mode"

Typedef Documentation

◆ SettingDWORDNameString

typedef struct _SettingDWORDNameString SettingDWORDNameString

◆ SettingWSTRINGNameString

typedef struct _SettingWSTRINGNameString SettingWSTRINGNameString

Enumeration Type Documentation

◆ ESetting

enum ESetting
Enumerator
OGL_AA_LINE_GAMMA_ID
OGL_CPL_GDI_COMPATIBILITY_ID
OGL_CPL_PREFER_DXPRESENT_ID
OGL_DEEP_COLOR_SCANOUT_ID
OGL_DEFAULT_SWAP_INTERVAL_ID
OGL_DEFAULT_SWAP_INTERVAL_FRACTIONAL_ID
OGL_DEFAULT_SWAP_INTERVAL_SIGN_ID
OGL_EVENT_LOG_SEVERITY_THRESHOLD_ID
OGL_EXTENSION_STRING_VERSION_ID
OGL_FORCE_BLIT_ID
OGL_FORCE_STEREO_ID
OGL_IMPLICIT_GPU_AFFINITY_ID
OGL_MAX_FRAMES_ALLOWED_ID
OGL_OVERLAY_PIXEL_TYPE_ID
OGL_OVERLAY_SUPPORT_ID
OGL_QUALITY_ENHANCEMENTS_ID
OGL_SINGLE_BACKDEPTH_BUFFER_ID
OGL_SLI_MULTICAST_ID
OGL_THREAD_CONTROL_ID
OGL_TMON_LEVEL_ID
OGL_TRIPLE_BUFFER_ID
AA_BEHAVIOR_FLAGS_ID
AA_MODE_ALPHATOCOVERAGE_ID
AA_MODE_GAMMACORRECTION_ID
AA_MODE_METHOD_ID
AA_MODE_REPLAY_ID
AA_MODE_SELECTOR_ID
AA_MODE_SELECTOR_SLIAA_ID
ANISO_MODE_LEVEL_ID
ANISO_MODE_SELECTOR_ID
ANSEL_ALLOW_ID
ANSEL_ALLOWLISTED_ID
ANSEL_ENABLE_ID
APPIDLE_DYNAMIC_FRL_FPS_ID
APPIDLE_DYNAMIC_FRL_THRESHOLD_TIME_ID
APPLICATION_PROFILE_NOTIFICATION_TIMEOUT_ID
APPLICATION_STEAM_ID_ID
BATTERY_BOOST_APP_FPS_ID
CPL_HIDDEN_PROFILE_ID
CUDA_EXCLUDED_GPUS_ID
D3DOGL_GPU_MAX_POWER_ID
EXPORT_PERF_COUNTERS_ID
EXTERNAL_QUIET_MODE_ID
FRL_FPS_ID
FXAA_ALLOW_ID
FXAA_ENABLE_ID
FXAA_INDICATOR_ENABLE_ID
LATENCY_INDICATOR_AUTOALIGN_ID
MCSFRSHOWSPLIT_ID
NV_QUALITY_UPSCALING_ID
OPTIMUS_MAXAA_ID
PHYSXINDICATOR_ID
PREFERRED_PSTATE_ID
PREVENT_UI_AF_OVERRIDE_ID
SHIM_MAXRES_ID
SHIM_MCCOMPAT_ID
SHIM_RENDERING_MODE_ID
SHIM_RENDERING_OPTIONS_ID
SLI_GPU_COUNT_ID
SLI_PREDEFINED_GPU_COUNT_ID
SLI_PREDEFINED_GPU_COUNT_DX10_ID
SLI_PREDEFINED_MODE_ID
SLI_PREDEFINED_MODE_DX10_ID
SLI_RENDERING_MODE_ID
VRPRERENDERLIMIT_ID
VRRFEATUREINDICATOR_ID
VRROVERLAYINDICATOR_ID
VRRREQUESTSTATE_ID
VRR_APP_OVERRIDE_ID
VRR_APP_OVERRIDE_REQUEST_STATE_ID
VRR_MODE_ID
VSYNCSMOOTHAFR_ID
VSYNCVRRCONTROL_ID
VSYNC_BEHAVIOR_FLAGS_ID
WKS_API_STEREO_EYES_EXCHANGE_ID
WKS_API_STEREO_MODE_ID
WKS_STEREO_DONGLE_SUPPORT_ID
WKS_STEREO_SUPPORT_ID
WKS_STEREO_SWAP_MODE_ID
AO_MODE_ID
AO_MODE_ACTIVE_ID
AUTO_LODBIASADJUST_ID
EXPORT_PERF_COUNTERS_DX9_ONLY_ID
ICAFE_LOGO_CONFIG_ID
LODBIASADJUST_ID
MAXWELL_B_SAMPLE_INTERLEAVE_ID
PRERENDERLIMIT_ID
PS_SHADERDISKCACHE_ID
PS_SHADERDISKCACHE_DLL_PATH_WCHAR_ID
PS_SHADERDISKCACHE_MAX_SIZE_ID
PS_TEXFILTER_ANISO_OPTS2_ID
PS_TEXFILTER_BILINEAR_IN_ANISO_ID
PS_TEXFILTER_DISABLE_TRILIN_SLOPE_ID
PS_TEXFILTER_NO_NEG_LODBIAS_ID
QUALITY_ENHANCEMENTS_ID
QUALITY_ENHANCEMENT_SUBSTITUTION_ID
REFRESH_RATE_OVERRIDE_ID
SET_POWER_THROTTLE_FOR_PCIe_COMPLIANCE_ID
SET_VAB_DATA_ID
VSYNCMODE_ID
VSYNCTEARCONTROL_ID
TOTAL_DWORD_SETTING_NUM
TOTAL_WSTRING_SETTING_NUM
TOTAL_SETTING_NUM
INVALID_SETTING_ID

◆ EValues_AA_BEHAVIOR_FLAGS

enum EValues_AA_BEHAVIOR_FLAGS
Enumerator
AA_BEHAVIOR_FLAGS_NONE
AA_BEHAVIOR_FLAGS_TREAT_OVERRIDE_AS_APP_CONTROLLED
AA_BEHAVIOR_FLAGS_TREAT_OVERRIDE_AS_ENHANCE
AA_BEHAVIOR_FLAGS_DISABLE_OVERRIDE
AA_BEHAVIOR_FLAGS_TREAT_ENHANCE_AS_APP_CONTROLLED
AA_BEHAVIOR_FLAGS_TREAT_ENHANCE_AS_OVERRIDE
AA_BEHAVIOR_FLAGS_DISABLE_ENHANCE
AA_BEHAVIOR_FLAGS_MAP_VCAA_TO_MULTISAMPLING
AA_BEHAVIOR_FLAGS_SLI_DISABLE_TRANSPARENCY_SUPERSAMPLING
AA_BEHAVIOR_FLAGS_DISABLE_CPLAA
AA_BEHAVIOR_FLAGS_SKIP_RT_DIM_CHECK_FOR_ENHANCE
AA_BEHAVIOR_FLAGS_DISABLE_SLIAA
AA_BEHAVIOR_FLAGS_DEFAULT
AA_BEHAVIOR_FLAGS_AA_RT_BPP_DIV_4
AA_BEHAVIOR_FLAGS_AA_RT_BPP_DIV_4_SHIFT
AA_BEHAVIOR_FLAGS_NON_AA_RT_BPP_DIV_4
AA_BEHAVIOR_FLAGS_NON_AA_RT_BPP_DIV_4_SHIFT
AA_BEHAVIOR_FLAGS_MASK
AA_BEHAVIOR_FLAGS_NUM_VALUES

◆ EValues_AA_MODE_ALPHATOCOVERAGE

enum EValues_AA_MODE_ALPHATOCOVERAGE
Enumerator
AA_MODE_ALPHATOCOVERAGE_MODE_MASK
AA_MODE_ALPHATOCOVERAGE_MODE_OFF
AA_MODE_ALPHATOCOVERAGE_MODE_ON
AA_MODE_ALPHATOCOVERAGE_MODE_MAX
AA_MODE_ALPHATOCOVERAGE_NUM_VALUES
AA_MODE_ALPHATOCOVERAGE_DEFAULT

◆ EValues_AA_MODE_GAMMACORRECTION

enum EValues_AA_MODE_GAMMACORRECTION
Enumerator
AA_MODE_GAMMACORRECTION_MASK
AA_MODE_GAMMACORRECTION_OFF
AA_MODE_GAMMACORRECTION_ON_IF_FOS
AA_MODE_GAMMACORRECTION_ON_ALWAYS
AA_MODE_GAMMACORRECTION_MAX
AA_MODE_GAMMACORRECTION_DEFAULT
AA_MODE_GAMMACORRECTION_DEFAULT_TESLA
AA_MODE_GAMMACORRECTION_DEFAULT_FERMI
AA_MODE_GAMMACORRECTION_NUM_VALUES

◆ EValues_AA_MODE_METHOD

enum EValues_AA_MODE_METHOD
Enumerator
AA_MODE_METHOD_NONE
AA_MODE_METHOD_SUPERSAMPLE_2X_H
AA_MODE_METHOD_SUPERSAMPLE_2X_V
AA_MODE_METHOD_SUPERSAMPLE_1_5X1_5
AA_MODE_METHOD_FREE_0x03
AA_MODE_METHOD_FREE_0x04
AA_MODE_METHOD_SUPERSAMPLE_4X
AA_MODE_METHOD_SUPERSAMPLE_4X_BIAS
AA_MODE_METHOD_SUPERSAMPLE_4X_GAUSSIAN
AA_MODE_METHOD_FREE_0x08
AA_MODE_METHOD_FREE_0x09
AA_MODE_METHOD_SUPERSAMPLE_9X
AA_MODE_METHOD_SUPERSAMPLE_9X_BIAS
AA_MODE_METHOD_SUPERSAMPLE_16X
AA_MODE_METHOD_SUPERSAMPLE_16X_BIAS
AA_MODE_METHOD_MULTISAMPLE_2X_DIAGONAL
AA_MODE_METHOD_MULTISAMPLE_2X_QUINCUNX
AA_MODE_METHOD_MULTISAMPLE_4X
AA_MODE_METHOD_FREE_0x11
AA_MODE_METHOD_MULTISAMPLE_4X_GAUSSIAN
AA_MODE_METHOD_MIXEDSAMPLE_4X_SKEWED_4TAP
AA_MODE_METHOD_FREE_0x14
AA_MODE_METHOD_FREE_0x15
AA_MODE_METHOD_MIXEDSAMPLE_6X
AA_MODE_METHOD_MIXEDSAMPLE_6X_SKEWED_6TAP
AA_MODE_METHOD_MIXEDSAMPLE_8X
AA_MODE_METHOD_MIXEDSAMPLE_8X_SKEWED_8TAP
AA_MODE_METHOD_MIXEDSAMPLE_16X
AA_MODE_METHOD_MULTISAMPLE_4X_GAMMA
AA_MODE_METHOD_MULTISAMPLE_16X
AA_MODE_METHOD_VCAA_32X_8v24
AA_MODE_METHOD_CORRUPTION_CHECK
AA_MODE_METHOD_6X_CT
AA_MODE_METHOD_MULTISAMPLE_2X_DIAGONAL_GAMMA
AA_MODE_METHOD_SUPERSAMPLE_4X_GAMMA
AA_MODE_METHOD_MULTISAMPLE_4X_FOSGAMMA
AA_MODE_METHOD_MULTISAMPLE_2X_DIAGONAL_FOSGAMMA
AA_MODE_METHOD_SUPERSAMPLE_4X_FOSGAMMA
AA_MODE_METHOD_MULTISAMPLE_8X
AA_MODE_METHOD_VCAA_8X_4v4
AA_MODE_METHOD_VCAA_16X_4v12
AA_MODE_METHOD_VCAA_16X_8v8
AA_MODE_METHOD_MIXEDSAMPLE_32X
AA_MODE_METHOD_SUPERVCAA_64X_4v12
AA_MODE_METHOD_SUPERVCAA_64X_8v8
AA_MODE_METHOD_MIXEDSAMPLE_64X
AA_MODE_METHOD_MIXEDSAMPLE_128X
AA_MODE_METHOD_COUNT
AA_MODE_METHOD_METHOD_MASK
AA_MODE_METHOD_METHOD_MAX
AA_MODE_METHOD_NUM_VALUES
AA_MODE_METHOD_DEFAULT

◆ EValues_AA_MODE_REPLAY

enum EValues_AA_MODE_REPLAY
Enumerator
AA_MODE_REPLAY_SAMPLES_MASK
AA_MODE_REPLAY_SAMPLES_ONE
AA_MODE_REPLAY_SAMPLES_TWO
AA_MODE_REPLAY_SAMPLES_FOUR
AA_MODE_REPLAY_SAMPLES_EIGHT
AA_MODE_REPLAY_SAMPLES_MAX
AA_MODE_REPLAY_MODE_MASK
AA_MODE_REPLAY_MODE_OFF
AA_MODE_REPLAY_MODE_ALPHA_TEST
AA_MODE_REPLAY_MODE_PIXEL_KILL
AA_MODE_REPLAY_MODE_DYN_BRANCH
AA_MODE_REPLAY_MODE_OPTIMAL
AA_MODE_REPLAY_MODE_ALL
AA_MODE_REPLAY_MODE_MAX
AA_MODE_REPLAY_TRANSPARENCY
AA_MODE_REPLAY_DISALLOW_TRAA
AA_MODE_REPLAY_TRANSPARENCY_DEFAULT
AA_MODE_REPLAY_TRANSPARENCY_DEFAULT_TESLA
AA_MODE_REPLAY_TRANSPARENCY_DEFAULT_FERMI
AA_MODE_REPLAY_MASK
AA_MODE_REPLAY_NUM_VALUES
AA_MODE_REPLAY_DEFAULT

◆ EValues_AA_MODE_SELECTOR

enum EValues_AA_MODE_SELECTOR
Enumerator
AA_MODE_SELECTOR_MASK
AA_MODE_SELECTOR_APP_CONTROL
AA_MODE_SELECTOR_OVERRIDE
AA_MODE_SELECTOR_ENHANCE
AA_MODE_SELECTOR_MAX
AA_MODE_SELECTOR_NUM_VALUES
AA_MODE_SELECTOR_DEFAULT

◆ EValues_AA_MODE_SELECTOR_SLIAA

enum EValues_AA_MODE_SELECTOR_SLIAA
Enumerator
AA_MODE_SELECTOR_SLIAA_DISABLED
AA_MODE_SELECTOR_SLIAA_ENABLED
AA_MODE_SELECTOR_SLIAA_NUM_VALUES
AA_MODE_SELECTOR_SLIAA_DEFAULT

◆ EValues_ANISO_MODE_LEVEL

enum EValues_ANISO_MODE_LEVEL
Enumerator
ANISO_MODE_LEVEL_MASK
ANISO_MODE_LEVEL_NONE_POINT
ANISO_MODE_LEVEL_NONE_LINEAR
ANISO_MODE_LEVEL_MAX
ANISO_MODE_LEVEL_DEFAULT
ANISO_MODE_LEVEL_NUM_VALUES

◆ EValues_ANISO_MODE_SELECTOR

enum EValues_ANISO_MODE_SELECTOR
Enumerator
ANISO_MODE_SELECTOR_MASK
ANISO_MODE_SELECTOR_APP
ANISO_MODE_SELECTOR_USER
ANISO_MODE_SELECTOR_COND
ANISO_MODE_SELECTOR_MAX
ANISO_MODE_SELECTOR_DEFAULT
ANISO_MODE_SELECTOR_NUM_VALUES

◆ EValues_ANSEL_ALLOW

enum EValues_ANSEL_ALLOW
Enumerator
ANSEL_ALLOW_DISALLOWED
ANSEL_ALLOW_ALLOWED
ANSEL_ALLOW_NUM_VALUES
ANSEL_ALLOW_DEFAULT

◆ EValues_ANSEL_ALLOWLISTED

enum EValues_ANSEL_ALLOWLISTED
Enumerator
ANSEL_ALLOWLISTED_DISALLOWED
ANSEL_ALLOWLISTED_ALLOWED
ANSEL_ALLOWLISTED_NUM_VALUES
ANSEL_ALLOWLISTED_DEFAULT

◆ EValues_ANSEL_ENABLE

enum EValues_ANSEL_ENABLE
Enumerator
ANSEL_ENABLE_OFF
ANSEL_ENABLE_ON
ANSEL_ENABLE_NUM_VALUES
ANSEL_ENABLE_DEFAULT

◆ EValues_AO_MODE

enum EValues_AO_MODE
Enumerator
AO_MODE_OFF
AO_MODE_LOW
AO_MODE_MEDIUM
AO_MODE_HIGH
AO_MODE_NUM_VALUES
AO_MODE_DEFAULT

◆ EValues_AO_MODE_ACTIVE

enum EValues_AO_MODE_ACTIVE
Enumerator
AO_MODE_ACTIVE_DISABLED
AO_MODE_ACTIVE_ENABLED
AO_MODE_ACTIVE_NUM_VALUES
AO_MODE_ACTIVE_DEFAULT

◆ EValues_APPLICATION_PROFILE_NOTIFICATION_TIMEOUT

enum EValues_APPLICATION_PROFILE_NOTIFICATION_TIMEOUT
Enumerator
APPLICATION_PROFILE_NOTIFICATION_TIMEOUT_DISABLED
APPLICATION_PROFILE_NOTIFICATION_TIMEOUT_NINE_SECONDS
APPLICATION_PROFILE_NOTIFICATION_TIMEOUT_FIFTEEN_SECONDS
APPLICATION_PROFILE_NOTIFICATION_TIMEOUT_THIRTY_SECONDS
APPLICATION_PROFILE_NOTIFICATION_TIMEOUT_ONE_MINUTE
APPLICATION_PROFILE_NOTIFICATION_TIMEOUT_TWO_MINUTES
APPLICATION_PROFILE_NOTIFICATION_TIMEOUT_NUM_VALUES
APPLICATION_PROFILE_NOTIFICATION_TIMEOUT_DEFAULT

◆ EValues_AUTO_LODBIASADJUST

enum EValues_AUTO_LODBIASADJUST
Enumerator
AUTO_LODBIASADJUST_OFF
AUTO_LODBIASADJUST_ON
AUTO_LODBIASADJUST_NUM_VALUES
AUTO_LODBIASADJUST_DEFAULT

◆ EValues_BATTERY_BOOST_APP_FPS

enum EValues_BATTERY_BOOST_APP_FPS
Enumerator
BATTERY_BOOST_APP_FPS_MIN
BATTERY_BOOST_APP_FPS_MAX
BATTERY_BOOST_APP_FPS_NO_OVERRIDE
BATTERY_BOOST_APP_FPS_NUM_VALUES
BATTERY_BOOST_APP_FPS_DEFAULT

◆ EValues_CPL_HIDDEN_PROFILE

enum EValues_CPL_HIDDEN_PROFILE
Enumerator
CPL_HIDDEN_PROFILE_DISABLED
CPL_HIDDEN_PROFILE_ENABLED
CPL_HIDDEN_PROFILE_NUM_VALUES
CPL_HIDDEN_PROFILE_DEFAULT

◆ EValues_EXPORT_PERF_COUNTERS

enum EValues_EXPORT_PERF_COUNTERS
Enumerator
EXPORT_PERF_COUNTERS_OFF
EXPORT_PERF_COUNTERS_ON
EXPORT_PERF_COUNTERS_NUM_VALUES
EXPORT_PERF_COUNTERS_DEFAULT

◆ EValues_EXPORT_PERF_COUNTERS_DX9_ONLY

enum EValues_EXPORT_PERF_COUNTERS_DX9_ONLY
Enumerator
EXPORT_PERF_COUNTERS_DX9_ONLY_OFF
EXPORT_PERF_COUNTERS_DX9_ONLY_ON
EXPORT_PERF_COUNTERS_DX9_ONLY_NUM_VALUES
EXPORT_PERF_COUNTERS_DX9_ONLY_DEFAULT

◆ EValues_EXTERNAL_QUIET_MODE

enum EValues_EXTERNAL_QUIET_MODE
Enumerator
EXTERNAL_QUIET_MODE_ON
EXTERNAL_QUIET_MODE_OFF
EXTERNAL_QUIET_MODE_NUM_VALUES
EXTERNAL_QUIET_MODE_DEFAULT

◆ EValues_FRL_FPS

enum EValues_FRL_FPS
Enumerator
FRL_FPS_DISABLED
FRL_FPS_MIN
FRL_FPS_MAX
FRL_FPS_NUM_VALUES
FRL_FPS_DEFAULT

◆ EValues_FXAA_ALLOW

enum EValues_FXAA_ALLOW
Enumerator
FXAA_ALLOW_DISALLOWED
FXAA_ALLOW_ALLOWED
FXAA_ALLOW_NUM_VALUES
FXAA_ALLOW_DEFAULT

◆ EValues_FXAA_ENABLE

enum EValues_FXAA_ENABLE
Enumerator
FXAA_ENABLE_OFF
FXAA_ENABLE_ON
FXAA_ENABLE_NUM_VALUES
FXAA_ENABLE_DEFAULT

◆ EValues_FXAA_INDICATOR_ENABLE

enum EValues_FXAA_INDICATOR_ENABLE
Enumerator
FXAA_INDICATOR_ENABLE_OFF
FXAA_INDICATOR_ENABLE_ON
FXAA_INDICATOR_ENABLE_NUM_VALUES
FXAA_INDICATOR_ENABLE_DEFAULT

◆ EValues_LATENCY_INDICATOR_AUTOALIGN

enum EValues_LATENCY_INDICATOR_AUTOALIGN
Enumerator
LATENCY_INDICATOR_AUTOALIGN_DISABLED
LATENCY_INDICATOR_AUTOALIGN_ENABLED
LATENCY_INDICATOR_AUTOALIGN_NUM_VALUES
LATENCY_INDICATOR_AUTOALIGN_DEFAULT

◆ EValues_LODBIASADJUST

enum EValues_LODBIASADJUST
Enumerator
LODBIASADJUST_MIN
LODBIASADJUST_MAX
LODBIASADJUST_NUM_VALUES
LODBIASADJUST_DEFAULT

◆ EValues_MAXWELL_B_SAMPLE_INTERLEAVE

enum EValues_MAXWELL_B_SAMPLE_INTERLEAVE
Enumerator
MAXWELL_B_SAMPLE_INTERLEAVE_OFF
MAXWELL_B_SAMPLE_INTERLEAVE_ON
MAXWELL_B_SAMPLE_INTERLEAVE_NUM_VALUES
MAXWELL_B_SAMPLE_INTERLEAVE_DEFAULT

◆ EValues_MCSFRSHOWSPLIT

enum EValues_MCSFRSHOWSPLIT
Enumerator
MCSFRSHOWSPLIT_DISABLED
MCSFRSHOWSPLIT_ENABLED
MCSFRSHOWSPLIT_NUM_VALUES
MCSFRSHOWSPLIT_DEFAULT

◆ EValues_NV_QUALITY_UPSCALING

enum EValues_NV_QUALITY_UPSCALING
Enumerator
NV_QUALITY_UPSCALING_OFF
NV_QUALITY_UPSCALING_ON
NV_QUALITY_UPSCALING_NUM_VALUES
NV_QUALITY_UPSCALING_DEFAULT

◆ EValues_OGL_AA_LINE_GAMMA

enum EValues_OGL_AA_LINE_GAMMA
Enumerator
OGL_AA_LINE_GAMMA_DISABLED
OGL_AA_LINE_GAMMA_ENABLED
OGL_AA_LINE_GAMMA_MIN
OGL_AA_LINE_GAMMA_MAX
OGL_AA_LINE_GAMMA_NUM_VALUES
OGL_AA_LINE_GAMMA_DEFAULT

◆ EValues_OGL_CPL_GDI_COMPATIBILITY

enum EValues_OGL_CPL_GDI_COMPATIBILITY
Enumerator
OGL_CPL_GDI_COMPATIBILITY_PREFER_DISABLED
OGL_CPL_GDI_COMPATIBILITY_PREFER_ENABLED
OGL_CPL_GDI_COMPATIBILITY_AUTO
OGL_CPL_GDI_COMPATIBILITY_NUM_VALUES
OGL_CPL_GDI_COMPATIBILITY_DEFAULT

◆ EValues_OGL_CPL_PREFER_DXPRESENT

enum EValues_OGL_CPL_PREFER_DXPRESENT
Enumerator
OGL_CPL_PREFER_DXPRESENT_PREFER_DISABLED
OGL_CPL_PREFER_DXPRESENT_PREFER_ENABLED
OGL_CPL_PREFER_DXPRESENT_AUTO
OGL_CPL_PREFER_DXPRESENT_NUM_VALUES
OGL_CPL_PREFER_DXPRESENT_DEFAULT

◆ EValues_OGL_DEEP_COLOR_SCANOUT

enum EValues_OGL_DEEP_COLOR_SCANOUT
Enumerator
OGL_DEEP_COLOR_SCANOUT_DISABLE
OGL_DEEP_COLOR_SCANOUT_ENABLE
OGL_DEEP_COLOR_SCANOUT_NUM_VALUES
OGL_DEEP_COLOR_SCANOUT_DEFAULT

◆ EValues_OGL_DEFAULT_SWAP_INTERVAL

enum EValues_OGL_DEFAULT_SWAP_INTERVAL
Enumerator
OGL_DEFAULT_SWAP_INTERVAL_TEAR
OGL_DEFAULT_SWAP_INTERVAL_VSYNC_ONE
OGL_DEFAULT_SWAP_INTERVAL_VSYNC
OGL_DEFAULT_SWAP_INTERVAL_VALUE_MASK
OGL_DEFAULT_SWAP_INTERVAL_FORCE_MASK
OGL_DEFAULT_SWAP_INTERVAL_FORCE_OFF
OGL_DEFAULT_SWAP_INTERVAL_FORCE_ON
OGL_DEFAULT_SWAP_INTERVAL_APP_CONTROLLED
OGL_DEFAULT_SWAP_INTERVAL_DISABLE
OGL_DEFAULT_SWAP_INTERVAL_NUM_VALUES
OGL_DEFAULT_SWAP_INTERVAL_DEFAULT

◆ EValues_OGL_DEFAULT_SWAP_INTERVAL_FRACTIONAL

enum EValues_OGL_DEFAULT_SWAP_INTERVAL_FRACTIONAL
Enumerator
OGL_DEFAULT_SWAP_INTERVAL_FRACTIONAL_ZERO_SCANLINES
OGL_DEFAULT_SWAP_INTERVAL_FRACTIONAL_ONE_FULL_FRAME_OF_SCANLINES
OGL_DEFAULT_SWAP_INTERVAL_FRACTIONAL_NUM_VALUES
OGL_DEFAULT_SWAP_INTERVAL_FRACTIONAL_DEFAULT

◆ EValues_OGL_DEFAULT_SWAP_INTERVAL_SIGN

enum EValues_OGL_DEFAULT_SWAP_INTERVAL_SIGN
Enumerator
OGL_DEFAULT_SWAP_INTERVAL_SIGN_POSITIVE
OGL_DEFAULT_SWAP_INTERVAL_SIGN_NEGATIVE
OGL_DEFAULT_SWAP_INTERVAL_SIGN_NUM_VALUES
OGL_DEFAULT_SWAP_INTERVAL_SIGN_DEFAULT

◆ EValues_OGL_EVENT_LOG_SEVERITY_THRESHOLD

enum EValues_OGL_EVENT_LOG_SEVERITY_THRESHOLD
Enumerator
OGL_EVENT_LOG_SEVERITY_THRESHOLD_DISABLE
OGL_EVENT_LOG_SEVERITY_THRESHOLD_CRITICAL
OGL_EVENT_LOG_SEVERITY_THRESHOLD_WARNING
OGL_EVENT_LOG_SEVERITY_THRESHOLD_INFORMATION
OGL_EVENT_LOG_SEVERITY_THRESHOLD_ALL
OGL_EVENT_LOG_SEVERITY_THRESHOLD_NUM_VALUES
OGL_EVENT_LOG_SEVERITY_THRESHOLD_DEFAULT

◆ EValues_OGL_FORCE_BLIT

enum EValues_OGL_FORCE_BLIT
Enumerator
OGL_FORCE_BLIT_ON
OGL_FORCE_BLIT_OFF
OGL_FORCE_BLIT_NUM_VALUES
OGL_FORCE_BLIT_DEFAULT

◆ EValues_OGL_FORCE_STEREO

enum EValues_OGL_FORCE_STEREO
Enumerator
OGL_FORCE_STEREO_OFF
OGL_FORCE_STEREO_ON
OGL_FORCE_STEREO_NUM_VALUES
OGL_FORCE_STEREO_DEFAULT

◆ EValues_OGL_OVERLAY_PIXEL_TYPE

enum EValues_OGL_OVERLAY_PIXEL_TYPE
Enumerator
OGL_OVERLAY_PIXEL_TYPE_NONE
OGL_OVERLAY_PIXEL_TYPE_CI
OGL_OVERLAY_PIXEL_TYPE_RGBA
OGL_OVERLAY_PIXEL_TYPE_CI_AND_RGBA
OGL_OVERLAY_PIXEL_TYPE_NUM_VALUES
OGL_OVERLAY_PIXEL_TYPE_DEFAULT

◆ EValues_OGL_OVERLAY_SUPPORT

enum EValues_OGL_OVERLAY_SUPPORT
Enumerator
OGL_OVERLAY_SUPPORT_OFF
OGL_OVERLAY_SUPPORT_ON
OGL_OVERLAY_SUPPORT_FORCE_SW
OGL_OVERLAY_SUPPORT_NUM_VALUES
OGL_OVERLAY_SUPPORT_DEFAULT

◆ EValues_OGL_QUALITY_ENHANCEMENTS

enum EValues_OGL_QUALITY_ENHANCEMENTS
Enumerator
OGL_QUALITY_ENHANCEMENTS_HQUAL
OGL_QUALITY_ENHANCEMENTS_QUAL
OGL_QUALITY_ENHANCEMENTS_PERF
OGL_QUALITY_ENHANCEMENTS_HPERF
OGL_QUALITY_ENHANCEMENTS_NUM_VALUES
OGL_QUALITY_ENHANCEMENTS_DEFAULT

◆ EValues_OGL_SINGLE_BACKDEPTH_BUFFER

enum EValues_OGL_SINGLE_BACKDEPTH_BUFFER
Enumerator
OGL_SINGLE_BACKDEPTH_BUFFER_DISABLE
OGL_SINGLE_BACKDEPTH_BUFFER_ENABLE
OGL_SINGLE_BACKDEPTH_BUFFER_USE_HW_DEFAULT
OGL_SINGLE_BACKDEPTH_BUFFER_NUM_VALUES
OGL_SINGLE_BACKDEPTH_BUFFER_DEFAULT

◆ EValues_OGL_SLI_MULTICAST

enum EValues_OGL_SLI_MULTICAST
Enumerator
OGL_SLI_MULTICAST_DISABLE
OGL_SLI_MULTICAST_ENABLE
OGL_SLI_MULTICAST_FORCE_DISABLE
OGL_SLI_MULTICAST_ALLOW_MOSAIC
OGL_SLI_MULTICAST_NUM_VALUES
OGL_SLI_MULTICAST_DEFAULT

◆ EValues_OGL_THREAD_CONTROL

enum EValues_OGL_THREAD_CONTROL
Enumerator
OGL_THREAD_CONTROL_ENABLE
OGL_THREAD_CONTROL_DISABLE
OGL_THREAD_CONTROL_NUM_VALUES
OGL_THREAD_CONTROL_DEFAULT

◆ EValues_OGL_TMON_LEVEL

enum EValues_OGL_TMON_LEVEL
Enumerator
OGL_TMON_LEVEL_DISABLE
OGL_TMON_LEVEL_CRITICAL
OGL_TMON_LEVEL_WARNING
OGL_TMON_LEVEL_INFORMATION
OGL_TMON_LEVEL_MOST
OGL_TMON_LEVEL_VERBOSE
OGL_TMON_LEVEL_NUM_VALUES
OGL_TMON_LEVEL_DEFAULT

◆ EValues_OGL_TRIPLE_BUFFER

enum EValues_OGL_TRIPLE_BUFFER
Enumerator
OGL_TRIPLE_BUFFER_DISABLED
OGL_TRIPLE_BUFFER_ENABLED
OGL_TRIPLE_BUFFER_NUM_VALUES
OGL_TRIPLE_BUFFER_DEFAULT

◆ EValues_OPTIMUS_MAXAA

enum EValues_OPTIMUS_MAXAA
Enumerator
OPTIMUS_MAXAA_MIN
OPTIMUS_MAXAA_MAX
OPTIMUS_MAXAA_NUM_VALUES
OPTIMUS_MAXAA_DEFAULT

◆ EValues_PHYSXINDICATOR

enum EValues_PHYSXINDICATOR
Enumerator
PHYSXINDICATOR_DISABLED
PHYSXINDICATOR_ENABLED
PHYSXINDICATOR_NUM_VALUES
PHYSXINDICATOR_DEFAULT

◆ EValues_PREFERRED_PSTATE

enum EValues_PREFERRED_PSTATE
Enumerator
PREFERRED_PSTATE_ADAPTIVE
PREFERRED_PSTATE_PREFER_MAX
PREFERRED_PSTATE_DRIVER_CONTROLLED
PREFERRED_PSTATE_PREFER_CONSISTENT_PERFORMANCE
PREFERRED_PSTATE_PREFER_MIN
PREFERRED_PSTATE_OPTIMAL_POWER
PREFERRED_PSTATE_MIN
PREFERRED_PSTATE_MAX
PREFERRED_PSTATE_NUM_VALUES
PREFERRED_PSTATE_DEFAULT

◆ EValues_PRERENDERLIMIT

enum EValues_PRERENDERLIMIT
Enumerator
PRERENDERLIMIT_MIN
PRERENDERLIMIT_MAX
PRERENDERLIMIT_APP_CONTROLLED
PRERENDERLIMIT_NUM_VALUES
PRERENDERLIMIT_DEFAULT

◆ EValues_PREVENT_UI_AF_OVERRIDE

enum EValues_PREVENT_UI_AF_OVERRIDE
Enumerator
PREVENT_UI_AF_OVERRIDE_OFF
PREVENT_UI_AF_OVERRIDE_ON
PREVENT_UI_AF_OVERRIDE_NUM_VALUES
PREVENT_UI_AF_OVERRIDE_DEFAULT

◆ EValues_PS_SHADERDISKCACHE

enum EValues_PS_SHADERDISKCACHE
Enumerator
PS_SHADERDISKCACHE_OFF
PS_SHADERDISKCACHE_ON
PS_SHADERDISKCACHE_NUM_VALUES
PS_SHADERDISKCACHE_DEFAULT

◆ EValues_PS_SHADERDISKCACHE_MAX_SIZE

enum EValues_PS_SHADERDISKCACHE_MAX_SIZE
Enumerator
PS_SHADERDISKCACHE_MAX_SIZE_MIN
PS_SHADERDISKCACHE_MAX_SIZE_MAX
PS_SHADERDISKCACHE_MAX_SIZE_NUM_VALUES
PS_SHADERDISKCACHE_MAX_SIZE_DEFAULT

◆ EValues_PS_TEXFILTER_ANISO_OPTS2

enum EValues_PS_TEXFILTER_ANISO_OPTS2
Enumerator
PS_TEXFILTER_ANISO_OPTS2_OFF
PS_TEXFILTER_ANISO_OPTS2_ON
PS_TEXFILTER_ANISO_OPTS2_NUM_VALUES
PS_TEXFILTER_ANISO_OPTS2_DEFAULT

◆ EValues_PS_TEXFILTER_BILINEAR_IN_ANISO

enum EValues_PS_TEXFILTER_BILINEAR_IN_ANISO
Enumerator
PS_TEXFILTER_BILINEAR_IN_ANISO_OFF
PS_TEXFILTER_BILINEAR_IN_ANISO_ON
PS_TEXFILTER_BILINEAR_IN_ANISO_NUM_VALUES
PS_TEXFILTER_BILINEAR_IN_ANISO_DEFAULT

◆ EValues_PS_TEXFILTER_DISABLE_TRILIN_SLOPE

enum EValues_PS_TEXFILTER_DISABLE_TRILIN_SLOPE
Enumerator
PS_TEXFILTER_DISABLE_TRILIN_SLOPE_OFF
PS_TEXFILTER_DISABLE_TRILIN_SLOPE_ON
PS_TEXFILTER_DISABLE_TRILIN_SLOPE_NUM_VALUES
PS_TEXFILTER_DISABLE_TRILIN_SLOPE_DEFAULT

◆ EValues_PS_TEXFILTER_NO_NEG_LODBIAS

enum EValues_PS_TEXFILTER_NO_NEG_LODBIAS
Enumerator
PS_TEXFILTER_NO_NEG_LODBIAS_OFF
PS_TEXFILTER_NO_NEG_LODBIAS_ON
PS_TEXFILTER_NO_NEG_LODBIAS_NUM_VALUES
PS_TEXFILTER_NO_NEG_LODBIAS_DEFAULT

◆ EValues_QUALITY_ENHANCEMENT_SUBSTITUTION

enum EValues_QUALITY_ENHANCEMENT_SUBSTITUTION
Enumerator
QUALITY_ENHANCEMENT_SUBSTITUTION_NO_SUBSTITUTION
QUALITY_ENHANCEMENT_SUBSTITUTION_HIGHQUALITY_BECOMES_QUALITY
QUALITY_ENHANCEMENT_SUBSTITUTION_NUM_VALUES
QUALITY_ENHANCEMENT_SUBSTITUTION_DEFAULT

◆ EValues_QUALITY_ENHANCEMENTS

enum EValues_QUALITY_ENHANCEMENTS
Enumerator
QUALITY_ENHANCEMENTS_HIGHQUALITY
QUALITY_ENHANCEMENTS_QUALITY
QUALITY_ENHANCEMENTS_PERFORMANCE
QUALITY_ENHANCEMENTS_HIGHPERFORMANCE
QUALITY_ENHANCEMENTS_NUM_VALUES
QUALITY_ENHANCEMENTS_DEFAULT

◆ EValues_REFRESH_RATE_OVERRIDE

enum EValues_REFRESH_RATE_OVERRIDE
Enumerator
REFRESH_RATE_OVERRIDE_APPLICATION_CONTROLLED
REFRESH_RATE_OVERRIDE_HIGHEST_AVAILABLE
REFRESH_RATE_OVERRIDE_LOW_LATENCY_RR_MASK
REFRESH_RATE_OVERRIDE_NUM_VALUES
REFRESH_RATE_OVERRIDE_DEFAULT

◆ EValues_SET_POWER_THROTTLE_FOR_PCIe_COMPLIANCE

enum EValues_SET_POWER_THROTTLE_FOR_PCIe_COMPLIANCE
Enumerator
SET_POWER_THROTTLE_FOR_PCIe_COMPLIANCE_OFF
SET_POWER_THROTTLE_FOR_PCIe_COMPLIANCE_ON
SET_POWER_THROTTLE_FOR_PCIe_COMPLIANCE_NUM_VALUES
SET_POWER_THROTTLE_FOR_PCIe_COMPLIANCE_DEFAULT

◆ EValues_SET_VAB_DATA

enum EValues_SET_VAB_DATA
Enumerator
SET_VAB_DATA_ZERO
SET_VAB_DATA_UINT_ONE
SET_VAB_DATA_FLOAT_ONE
SET_VAB_DATA_FLOAT_POS_INF
SET_VAB_DATA_FLOAT_NAN
SET_VAB_DATA_USE_API_DEFAULTS
SET_VAB_DATA_NUM_VALUES
SET_VAB_DATA_DEFAULT

◆ EValues_SHIM_MCCOMPAT

enum EValues_SHIM_MCCOMPAT
Enumerator
SHIM_MCCOMPAT_INTEGRATED
SHIM_MCCOMPAT_ENABLE
SHIM_MCCOMPAT_USER_EDITABLE
SHIM_MCCOMPAT_MASK
SHIM_MCCOMPAT_VIDEO_MASK
SHIM_MCCOMPAT_VARYING_BIT
SHIM_MCCOMPAT_AUTO_SELECT
SHIM_MCCOMPAT_OVERRIDE_BIT
SHIM_MCCOMPAT_NUM_VALUES
SHIM_MCCOMPAT_DEFAULT

◆ EValues_SHIM_RENDERING_MODE

enum EValues_SHIM_RENDERING_MODE
Enumerator
SHIM_RENDERING_MODE_INTEGRATED
SHIM_RENDERING_MODE_ENABLE
SHIM_RENDERING_MODE_USER_EDITABLE
SHIM_RENDERING_MODE_MASK
SHIM_RENDERING_MODE_VIDEO_MASK
SHIM_RENDERING_MODE_VARYING_BIT
SHIM_RENDERING_MODE_AUTO_SELECT
SHIM_RENDERING_MODE_OVERRIDE_BIT
SHIM_RENDERING_MODE_NUM_VALUES
SHIM_RENDERING_MODE_DEFAULT

◆ EValues_SHIM_RENDERING_OPTIONS

enum EValues_SHIM_RENDERING_OPTIONS
Enumerator
SHIM_RENDERING_OPTIONS_DEFAULT_RENDERING_MODE
SHIM_RENDERING_OPTIONS_DISABLE_ASYNC_PRESENT
SHIM_RENDERING_OPTIONS_EHSHELL_DETECT
SHIM_RENDERING_OPTIONS_FLASHPLAYER_HOST_DETECT
SHIM_RENDERING_OPTIONS_VIDEO_DRM_APP_DETECT
SHIM_RENDERING_OPTIONS_IGNORE_OVERRIDES
SHIM_RENDERING_OPTIONS_RESERVED1
SHIM_RENDERING_OPTIONS_ENABLE_DWM_ASYNC_PRESENT
SHIM_RENDERING_OPTIONS_RESERVED2
SHIM_RENDERING_OPTIONS_ALLOW_INHERITANCE
SHIM_RENDERING_OPTIONS_DISABLE_WRAPPERS
SHIM_RENDERING_OPTIONS_DISABLE_DXGI_WRAPPERS
SHIM_RENDERING_OPTIONS_PRUNE_UNSUPPORTED_FORMATS
SHIM_RENDERING_OPTIONS_ENABLE_ALPHA_FORMAT
SHIM_RENDERING_OPTIONS_IGPU_TRANSCODING
SHIM_RENDERING_OPTIONS_DISABLE_CUDA
SHIM_RENDERING_OPTIONS_ALLOW_CP_CAPS_FOR_VIDEO
SHIM_RENDERING_OPTIONS_IGPU_TRANSCODING_FWD_OPTIMUS
SHIM_RENDERING_OPTIONS_DISABLE_DURING_SECURE_BOOT
SHIM_RENDERING_OPTIONS_INVERT_FOR_QUADRO
SHIM_RENDERING_OPTIONS_INVERT_FOR_MSHYBRID
SHIM_RENDERING_OPTIONS_REGISTER_PROCESS_ENABLE_GOLD
SHIM_RENDERING_OPTIONS_HANDLE_WINDOWED_MODE_PERF_OPT
SHIM_RENDERING_OPTIONS_HANDLE_WIN7_ASYNC_RUNTIME_BUG
SHIM_RENDERING_OPTIONS_EXPLICIT_ADAPTER_OPTED_BY_APP
SHIM_RENDERING_OPTIONS_ALLOW_DYNAMIC_DISPLAY_MUX_SWITCH
SHIM_RENDERING_OPTIONS_DISALLOW_DYNAMIC_DISPLAY_MUX_SWITCH
SHIM_RENDERING_OPTIONS_DISABLE_TURING_POWER_POLICY
SHIM_RENDERING_OPTIONS_NUM_VALUES
SHIM_RENDERING_OPTIONS_DEFAULT

◆ EValues_SLI_GPU_COUNT

enum EValues_SLI_GPU_COUNT
Enumerator
SLI_GPU_COUNT_AUTOSELECT
SLI_GPU_COUNT_ONE
SLI_GPU_COUNT_TWO
SLI_GPU_COUNT_THREE
SLI_GPU_COUNT_FOUR
SLI_GPU_COUNT_NUM_VALUES
SLI_GPU_COUNT_DEFAULT

◆ EValues_SLI_PREDEFINED_GPU_COUNT

enum EValues_SLI_PREDEFINED_GPU_COUNT
Enumerator
SLI_PREDEFINED_GPU_COUNT_AUTOSELECT
SLI_PREDEFINED_GPU_COUNT_ONE
SLI_PREDEFINED_GPU_COUNT_TWO
SLI_PREDEFINED_GPU_COUNT_THREE
SLI_PREDEFINED_GPU_COUNT_FOUR
SLI_PREDEFINED_GPU_COUNT_NUM_VALUES
SLI_PREDEFINED_GPU_COUNT_DEFAULT

◆ EValues_SLI_PREDEFINED_GPU_COUNT_DX10

enum EValues_SLI_PREDEFINED_GPU_COUNT_DX10
Enumerator
SLI_PREDEFINED_GPU_COUNT_DX10_AUTOSELECT
SLI_PREDEFINED_GPU_COUNT_DX10_ONE
SLI_PREDEFINED_GPU_COUNT_DX10_TWO
SLI_PREDEFINED_GPU_COUNT_DX10_THREE
SLI_PREDEFINED_GPU_COUNT_DX10_FOUR
SLI_PREDEFINED_GPU_COUNT_DX10_NUM_VALUES
SLI_PREDEFINED_GPU_COUNT_DX10_DEFAULT

◆ EValues_SLI_PREDEFINED_MODE

enum EValues_SLI_PREDEFINED_MODE
Enumerator
SLI_PREDEFINED_MODE_AUTOSELECT
SLI_PREDEFINED_MODE_FORCE_SINGLE
SLI_PREDEFINED_MODE_FORCE_AFR
SLI_PREDEFINED_MODE_FORCE_AFR2
SLI_PREDEFINED_MODE_FORCE_SFR
SLI_PREDEFINED_MODE_FORCE_AFR_OF_SFR__FALLBACK_3AFR
SLI_PREDEFINED_MODE_NUM_VALUES
SLI_PREDEFINED_MODE_DEFAULT

◆ EValues_SLI_PREDEFINED_MODE_DX10

enum EValues_SLI_PREDEFINED_MODE_DX10
Enumerator
SLI_PREDEFINED_MODE_DX10_AUTOSELECT
SLI_PREDEFINED_MODE_DX10_FORCE_SINGLE
SLI_PREDEFINED_MODE_DX10_FORCE_AFR
SLI_PREDEFINED_MODE_DX10_FORCE_AFR2
SLI_PREDEFINED_MODE_DX10_FORCE_SFR
SLI_PREDEFINED_MODE_DX10_FORCE_AFR_OF_SFR__FALLBACK_3AFR
SLI_PREDEFINED_MODE_DX10_NUM_VALUES
SLI_PREDEFINED_MODE_DX10_DEFAULT

◆ EValues_SLI_RENDERING_MODE

enum EValues_SLI_RENDERING_MODE
Enumerator
SLI_RENDERING_MODE_AUTOSELECT
SLI_RENDERING_MODE_FORCE_SINGLE
SLI_RENDERING_MODE_FORCE_AFR
SLI_RENDERING_MODE_FORCE_AFR2
SLI_RENDERING_MODE_FORCE_SFR
SLI_RENDERING_MODE_FORCE_AFR_OF_SFR__FALLBACK_3AFR
SLI_RENDERING_MODE_NUM_VALUES
SLI_RENDERING_MODE_DEFAULT

◆ EValues_VRPRERENDERLIMIT

enum EValues_VRPRERENDERLIMIT
Enumerator
VRPRERENDERLIMIT_MIN
VRPRERENDERLIMIT_MAX
VRPRERENDERLIMIT_APP_CONTROLLED
VRPRERENDERLIMIT_DEFAULT
VRPRERENDERLIMIT_NUM_VALUES

◆ EValues_VRR_APP_OVERRIDE

enum EValues_VRR_APP_OVERRIDE
Enumerator
VRR_APP_OVERRIDE_ALLOW
VRR_APP_OVERRIDE_FORCE_OFF
VRR_APP_OVERRIDE_DISALLOW
VRR_APP_OVERRIDE_ULMB
VRR_APP_OVERRIDE_FIXED_REFRESH
VRR_APP_OVERRIDE_NUM_VALUES
VRR_APP_OVERRIDE_DEFAULT

◆ EValues_VRR_APP_OVERRIDE_REQUEST_STATE

enum EValues_VRR_APP_OVERRIDE_REQUEST_STATE
Enumerator
VRR_APP_OVERRIDE_REQUEST_STATE_ALLOW
VRR_APP_OVERRIDE_REQUEST_STATE_FORCE_OFF
VRR_APP_OVERRIDE_REQUEST_STATE_DISALLOW
VRR_APP_OVERRIDE_REQUEST_STATE_ULMB
VRR_APP_OVERRIDE_REQUEST_STATE_FIXED_REFRESH
VRR_APP_OVERRIDE_REQUEST_STATE_NUM_VALUES
VRR_APP_OVERRIDE_REQUEST_STATE_DEFAULT

◆ EValues_VRR_MODE

enum EValues_VRR_MODE
Enumerator
VRR_MODE_DISABLED
VRR_MODE_FULLSCREEN_ONLY
VRR_MODE_FULLSCREEN_AND_WINDOWED
VRR_MODE_NUM_VALUES
VRR_MODE_DEFAULT

◆ EValues_VRRFEATUREINDICATOR

enum EValues_VRRFEATUREINDICATOR
Enumerator
VRRFEATUREINDICATOR_DISABLED
VRRFEATUREINDICATOR_ENABLED
VRRFEATUREINDICATOR_NUM_VALUES
VRRFEATUREINDICATOR_DEFAULT

◆ EValues_VRROVERLAYINDICATOR

enum EValues_VRROVERLAYINDICATOR
Enumerator
VRROVERLAYINDICATOR_DISABLED
VRROVERLAYINDICATOR_ENABLED
VRROVERLAYINDICATOR_NUM_VALUES
VRROVERLAYINDICATOR_DEFAULT

◆ EValues_VRRREQUESTSTATE

enum EValues_VRRREQUESTSTATE
Enumerator
VRRREQUESTSTATE_DISABLED
VRRREQUESTSTATE_FULLSCREEN_ONLY
VRRREQUESTSTATE_FULLSCREEN_AND_WINDOWED
VRRREQUESTSTATE_NUM_VALUES
VRRREQUESTSTATE_DEFAULT

◆ EValues_VSYNC_BEHAVIOR_FLAGS

enum EValues_VSYNC_BEHAVIOR_FLAGS
Enumerator
VSYNC_BEHAVIOR_FLAGS_NONE
VSYNC_BEHAVIOR_FLAGS_DEFAULT
VSYNC_BEHAVIOR_FLAGS_IGNORE_FLIPINTERVAL_MULTIPLE
VSYNC_BEHAVIOR_FLAGS_NUM_VALUES

◆ EValues_VSYNCMODE

enum EValues_VSYNCMODE
Enumerator
VSYNCMODE_PASSIVE
VSYNCMODE_FORCEOFF
VSYNCMODE_FORCEON
VSYNCMODE_FLIPINTERVAL2
VSYNCMODE_FLIPINTERVAL3
VSYNCMODE_FLIPINTERVAL4
VSYNCMODE_VIRTUAL
VSYNCMODE_NUM_VALUES
VSYNCMODE_DEFAULT

◆ EValues_VSYNCSMOOTHAFR

enum EValues_VSYNCSMOOTHAFR
Enumerator
VSYNCSMOOTHAFR_OFF
VSYNCSMOOTHAFR_ON
VSYNCSMOOTHAFR_NUM_VALUES
VSYNCSMOOTHAFR_DEFAULT

◆ EValues_VSYNCTEARCONTROL

enum EValues_VSYNCTEARCONTROL
Enumerator
VSYNCTEARCONTROL_DISABLE
VSYNCTEARCONTROL_ENABLE
VSYNCTEARCONTROL_NUM_VALUES
VSYNCTEARCONTROL_DEFAULT

◆ EValues_VSYNCVRRCONTROL

enum EValues_VSYNCVRRCONTROL
Enumerator
VSYNCVRRCONTROL_DISABLE
VSYNCVRRCONTROL_ENABLE
VSYNCVRRCONTROL_NOTSUPPORTED
VSYNCVRRCONTROL_NUM_VALUES
VSYNCVRRCONTROL_DEFAULT

◆ EValues_WKS_API_STEREO_EYES_EXCHANGE

enum EValues_WKS_API_STEREO_EYES_EXCHANGE
Enumerator
WKS_API_STEREO_EYES_EXCHANGE_OFF
WKS_API_STEREO_EYES_EXCHANGE_ON
WKS_API_STEREO_EYES_EXCHANGE_NUM_VALUES
WKS_API_STEREO_EYES_EXCHANGE_DEFAULT

◆ EValues_WKS_API_STEREO_MODE

enum EValues_WKS_API_STEREO_MODE
Enumerator
WKS_API_STEREO_MODE_SHUTTER_GLASSES
WKS_API_STEREO_MODE_VERTICAL_INTERLACED
WKS_API_STEREO_MODE_TWINVIEW
WKS_API_STEREO_MODE_NV17_SHUTTER_GLASSES_AUTO
WKS_API_STEREO_MODE_NV17_SHUTTER_GLASSES_DAC0
WKS_API_STEREO_MODE_NV17_SHUTTER_GLASSES_DAC1
WKS_API_STEREO_MODE_COLOR_LINE
WKS_API_STEREO_MODE_COLOR_INTERLEAVED
WKS_API_STEREO_MODE_ANAGLYPH
WKS_API_STEREO_MODE_HORIZONTAL_INTERLACED
WKS_API_STEREO_MODE_SIDE_FIELD
WKS_API_STEREO_MODE_SUB_FIELD
WKS_API_STEREO_MODE_CHECKERBOARD
WKS_API_STEREO_MODE_INVERSE_CHECKERBOARD
WKS_API_STEREO_MODE_TRIDELITY_SL
WKS_API_STEREO_MODE_TRIDELITY_MV
WKS_API_STEREO_MODE_SEEFRONT
WKS_API_STEREO_MODE_STEREO_MIRROR
WKS_API_STEREO_MODE_FRAME_SEQUENTIAL
WKS_API_STEREO_MODE_AUTODETECT_PASSIVE_MODE
WKS_API_STEREO_MODE_AEGIS_DT_FRAME_SEQUENTIAL
WKS_API_STEREO_MODE_OEM_EMITTER_FRAME_SEQUENTIAL
WKS_API_STEREO_MODE_DP_INBAND
WKS_API_STEREO_MODE_USE_HW_DEFAULT
WKS_API_STEREO_MODE_DEFAULT_GL
WKS_API_STEREO_MODE_NUM_VALUES
WKS_API_STEREO_MODE_DEFAULT

◆ EValues_WKS_STEREO_DONGLE_SUPPORT

enum EValues_WKS_STEREO_DONGLE_SUPPORT
Enumerator
WKS_STEREO_DONGLE_SUPPORT_OFF
WKS_STEREO_DONGLE_SUPPORT_DAC
WKS_STEREO_DONGLE_SUPPORT_DLP
WKS_STEREO_DONGLE_SUPPORT_NUM_VALUES
WKS_STEREO_DONGLE_SUPPORT_DEFAULT

◆ EValues_WKS_STEREO_SUPPORT

enum EValues_WKS_STEREO_SUPPORT
Enumerator
WKS_STEREO_SUPPORT_OFF
WKS_STEREO_SUPPORT_ON
WKS_STEREO_SUPPORT_NUM_VALUES
WKS_STEREO_SUPPORT_DEFAULT

◆ EValues_WKS_STEREO_SWAP_MODE

enum EValues_WKS_STEREO_SWAP_MODE
Enumerator
WKS_STEREO_SWAP_MODE_APPLICATION_CONTROL
WKS_STEREO_SWAP_MODE_PER_EYE
WKS_STEREO_SWAP_MODE_PER_EYE_PAIR
WKS_STEREO_SWAP_MODE_LEGACY_BEHAVIOR
WKS_STEREO_SWAP_MODE_PER_EYE_FOR_SWAP_GROUP
WKS_STEREO_SWAP_MODE_NUM_VALUES
WKS_STEREO_SWAP_MODE_DEFAULT


  • File List
  • Globals
Functions
nvHLSLExtns.h File Reference
#include "nvHLSLExtnsInternal.h"

Functions

int | NvShfl (int val, uint srcLane, int width=NV_WARP_SIZE)
int2 | NvShfl (int2 val, uint srcLane, int width=NV_WARP_SIZE)
int4 | NvShfl (int4 val, uint srcLane, int width=NV_WARP_SIZE)
int | NvShflUp (int val, uint delta, int width=NV_WARP_SIZE)
int | NvShflDown (int val, uint delta, int width=NV_WARP_SIZE)
int | NvShflXor (int val, uint laneMask, int width=NV_WARP_SIZE)
uint | NvAny (int predicate)
uint | NvAll (int predicate)
uint | NvBallot (int predicate)
int | NvGetLaneId ()
uint | NvGetSpecial (uint subOpCode)
uint | NvInterlockedAddFp16x2 (RWByteAddressBuffer uav, uint byteAddress, uint fp16x2Val)
uint | NvInterlockedMinFp16x2 (RWByteAddressBuffer uav, uint byteAddress, uint fp16x2Val)
uint | NvInterlockedMaxFp16x2 (RWByteAddressBuffer uav, uint byteAddress, uint fp16x2Val)
uint | NvInterlockedAddFp16x2 (RWByteAddressBuffer uav, uint byteAddress, float2 val)
uint | NvInterlockedMinFp16x2 (RWByteAddressBuffer uav, uint byteAddress, float2 val)
uint | NvInterlockedMaxFp16x2 (RWByteAddressBuffer uav, uint byteAddress, float2 val)
uint | NvInterlockedAddFp16x2 (RWTexture1D< float2 > uav, uint address, uint fp16x2Val)
uint | NvInterlockedMinFp16x2 (RWTexture1D< float2 > uav, uint address, uint fp16x2Val)
uint | NvInterlockedMaxFp16x2 (RWTexture1D< float2 > uav, uint address, uint fp16x2Val)
uint | NvInterlockedAddFp16x2 (RWTexture2D< float2 > uav, uint2 address, uint fp16x2Val)
uint | NvInterlockedMinFp16x2 (RWTexture2D< float2 > uav, uint2 address, uint fp16x2Val)
uint | NvInterlockedMaxFp16x2 (RWTexture2D< float2 > uav, uint2 address, uint fp16x2Val)
uint | NvInterlockedAddFp16x2 (RWTexture3D< float2 > uav, uint3 address, uint fp16x2Val)
uint | NvInterlockedMinFp16x2 (RWTexture3D< float2 > uav, uint3 address, uint fp16x2Val)
uint | NvInterlockedMaxFp16x2 (RWTexture3D< float2 > uav, uint3 address, uint fp16x2Val)
uint | NvInterlockedAddFp16x2 (RWTexture1D< float2 > uav, uint address, float2 val)
uint | NvInterlockedMinFp16x2 (RWTexture1D< float2 > uav, uint address, float2 val)
uint | NvInterlockedMaxFp16x2 (RWTexture1D< float2 > uav, uint address, float2 val)
uint | NvInterlockedAddFp16x2 (RWTexture2D< float2 > uav, uint2 address, float2 val)
uint | NvInterlockedMinFp16x2 (RWTexture2D< float2 > uav, uint2 address, float2 val)
uint | NvInterlockedMaxFp16x2 (RWTexture2D< float2 > uav, uint2 address, float2 val)
uint | NvInterlockedAddFp16x2 (RWTexture3D< float2 > uav, uint3 address, float2 val)
uint | NvInterlockedMinFp16x2 (RWTexture3D< float2 > uav, uint3 address, float2 val)
uint | NvInterlockedMaxFp16x2 (RWTexture3D< float2 > uav, uint3 address, float2 val)
uint2 | NvInterlockedAddFp16x4 (RWTexture1D< float4 > uav, uint address, uint2 fp16x2Val)
uint2 | NvInterlockedMinFp16x4 (RWTexture1D< float4 > uav, uint address, uint2 fp16x2Val)
uint2 | NvInterlockedMaxFp16x4 (RWTexture1D< float4 > uav, uint address, uint2 fp16x2Val)
uint2 | NvInterlockedAddFp16x4 (RWTexture2D< float4 > uav, uint2 address, uint2 fp16x2Val)
uint2 | NvInterlockedMinFp16x4 (RWTexture2D< float4 > uav, uint2 address, uint2 fp16x2Val)
uint2 | NvInterlockedMaxFp16x4 (RWTexture2D< float4 > uav, uint2 address, uint2 fp16x2Val)
uint2 | NvInterlockedAddFp16x4 (RWTexture3D< float4 > uav, uint3 address, uint2 fp16x2Val)
uint2 | NvInterlockedMinFp16x4 (RWTexture3D< float4 > uav, uint3 address, uint2 fp16x2Val)
uint2 | NvInterlockedMaxFp16x4 (RWTexture3D< float4 > uav, uint3 address, uint2 fp16x2Val)
uint2 | NvInterlockedAddFp16x4 (RWTexture1D< float4 > uav, uint address, float4 val)
uint2 | NvInterlockedMinFp16x4 (RWTexture1D< float4 > uav, uint address, float4 val)
uint2 | NvInterlockedMaxFp16x4 (RWTexture1D< float4 > uav, uint address, float4 val)
uint2 | NvInterlockedAddFp16x4 (RWTexture2D< float4 > uav, uint2 address, float4 val)
uint2 | NvInterlockedMinFp16x4 (RWTexture2D< float4 > uav, uint2 address, float4 val)
uint2 | NvInterlockedMaxFp16x4 (RWTexture2D< float4 > uav, uint2 address, float4 val)
uint2 | NvInterlockedAddFp16x4 (RWTexture3D< float4 > uav, uint3 address, float4 val)
uint2 | NvInterlockedMinFp16x4 (RWTexture3D< float4 > uav, uint3 address, float4 val)
uint2 | NvInterlockedMaxFp16x4 (RWTexture3D< float4 > uav, uint3 address, float4 val)
float | NvInterlockedAddFp32 (RWByteAddressBuffer uav, uint byteAddress, float val)
float | NvInterlockedAddFp32 (RWTexture1D< float > uav, uint address, float val)
float | NvInterlockedAddFp32 (RWTexture2D< float > uav, uint2 address, float val)
float | NvInterlockedAddFp32 (RWTexture3D< float > uav, uint3 address, float val)
uint2 | NvInterlockedAddUint64 (RWByteAddressBuffer uav, uint byteAddress, uint2 value)
uint2 | NvInterlockedMaxUint64 (RWByteAddressBuffer uav, uint byteAddress, uint2 value)
uint2 | NvInterlockedMinUint64 (RWByteAddressBuffer uav, uint byteAddress, uint2 value)
uint2 | NvInterlockedAndUint64 (RWByteAddressBuffer uav, uint byteAddress, uint2 value)
uint2 | NvInterlockedOrUint64 (RWByteAddressBuffer uav, uint byteAddress, uint2 value)
uint2 | NvInterlockedXorUint64 (RWByteAddressBuffer uav, uint byteAddress, uint2 value)
uint2 | NvInterlockedCompareExchangeUint64 (RWByteAddressBuffer uav, uint byteAddress, uint2 compare_value, uint2 value)
uint2 | NvInterlockedExchangeUint64 (RWByteAddressBuffer uav, uint byteAddress, uint2 value)
uint2 | NvInterlockedAddUint64 (RWTexture1D< uint2 > uav, uint address, uint2 value)
uint2 | NvInterlockedMaxUint64 (RWTexture1D< uint2 > uav, uint address, uint2 value)
uint2 | NvInterlockedMinUint64 (RWTexture1D< uint2 > uav, uint address, uint2 value)
uint2 | NvInterlockedAndUint64 (RWTexture1D< uint2 > uav, uint address, uint2 value)
uint2 | NvInterlockedOrUint64 (RWTexture1D< uint2 > uav, uint address, uint2 value)
uint2 | NvInterlockedXorUint64 (RWTexture1D< uint2 > uav, uint address, uint2 value)
uint2 | NvInterlockedCompareExchangeUint64 (RWTexture1D< uint2 > uav, uint address, uint2 compare_value, uint2 value)
uint2 | NvInterlockedExchangeUint64 (RWTexture1D< uint2 > uav, uint address, uint2 value)
uint2 | NvInterlockedAddUint64 (RWTexture2D< uint2 > uav, uint2 address, uint2 value)
uint2 | NvInterlockedMaxUint64 (RWTexture2D< uint2 > uav, uint2 address, uint2 value)
uint2 | NvInterlockedMinUint64 (RWTexture2D< uint2 > uav, uint2 address, uint2 value)
uint2 | NvInterlockedAndUint64 (RWTexture2D< uint2 > uav, uint2 address, uint2 value)
uint2 | NvInterlockedOrUint64 (RWTexture2D< uint2 > uav, uint2 address, uint2 value)
uint2 | NvInterlockedXorUint64 (RWTexture2D< uint2 > uav, uint2 address, uint2 value)
uint2 | NvInterlockedCompareExchangeUint64 (RWTexture2D< uint2 > uav, uint2 address, uint2 compare_value, uint2 value)
uint2 | NvInterlockedExchangeUint64 (RWTexture2D< uint2 > uav, uint2 address, uint2 value)
uint2 | NvInterlockedAddUint64 (RWTexture3D< uint2 > uav, uint3 address, uint2 value)
uint2 | NvInterlockedMaxUint64 (RWTexture3D< uint2 > uav, uint3 address, uint2 value)
uint2 | NvInterlockedMinUint64 (RWTexture3D< uint2 > uav, uint3 address, uint2 value)
uint2 | NvInterlockedAndUint64 (RWTexture3D< uint2 > uav, uint3 address, uint2 value)
uint2 | NvInterlockedOrUint64 (RWTexture3D< uint2 > uav, uint3 address, uint2 value)
uint2 | NvInterlockedXorUint64 (RWTexture3D< uint2 > uav, uint3 address, uint2 value)
uint2 | NvInterlockedCompareExchangeUint64 (RWTexture3D< uint2 > uav, uint3 address, uint2 compare_value, uint2 value)
uint2 | NvInterlockedExchangeUint64 (RWTexture3D< uint2 > uav, uint3 address, uint2 value)
uint3 | NvGetShadingRate ()
float | NvEvaluateAttributeAtSampleForVPRS (float attrib, uint sampleIndex, int2 pixelOffset)
float2 | NvEvaluateAttributeAtSampleForVPRS (float2 attrib, uint sampleIndex, int2 pixelOffset)
float3 | NvEvaluateAttributeAtSampleForVPRS (float3 attrib, uint sampleIndex, int2 pixelOffset)
float4 | NvEvaluateAttributeAtSampleForVPRS (float4 attrib, uint sampleIndex, int2 pixelOffset)
int | NvEvaluateAttributeAtSampleForVPRS (int attrib, uint sampleIndex, int2 pixelOffset)
int2 | NvEvaluateAttributeAtSampleForVPRS (int2 attrib, uint sampleIndex, int2 pixelOffset)
int3 | NvEvaluateAttributeAtSampleForVPRS (int3 attrib, uint sampleIndex, int2 pixelOffset)
int4 | NvEvaluateAttributeAtSampleForVPRS (int4 attrib, uint sampleIndex, int2 pixelOffset)
uint | NvEvaluateAttributeAtSampleForVPRS (uint attrib, uint sampleIndex, int2 pixelOffset)
uint2 | NvEvaluateAttributeAtSampleForVPRS (uint2 attrib, uint sampleIndex, int2 pixelOffset)
uint3 | NvEvaluateAttributeAtSampleForVPRS (uint3 attrib, uint sampleIndex, int2 pixelOffset)
uint4 | NvEvaluateAttributeAtSampleForVPRS (uint4 attrib, uint sampleIndex, int2 pixelOffset)
float | NvEvaluateAttributeSnappedForVPRS (float attrib, uint2 offset)
float2 | NvEvaluateAttributeSnappedForVPRS (float2 attrib, uint2 offset)
float3 | NvEvaluateAttributeSnappedForVPRS (float3 attrib, uint2 offset)
float4 | NvEvaluateAttributeSnappedForVPRS (float4 attrib, uint2 offset)
int | NvEvaluateAttributeSnappedForVPRS (int attrib, uint2 offset)
int2 | NvEvaluateAttributeSnappedForVPRS (int2 attrib, uint2 offset)
int3 | NvEvaluateAttributeSnappedForVPRS (int3 attrib, uint2 offset)
int4 | NvEvaluateAttributeSnappedForVPRS (int4 attrib, uint2 offset)
uint | NvEvaluateAttributeSnappedForVPRS (uint attrib, uint2 offset)
uint2 | NvEvaluateAttributeSnappedForVPRS (uint2 attrib, uint2 offset)
uint3 | NvEvaluateAttributeSnappedForVPRS (uint3 attrib, uint2 offset)
uint4 | NvEvaluateAttributeSnappedForVPRS (uint4 attrib, uint2 offset)
uint | NvWaveMatch (uint value)
uint | NvWaveMatch (uint2 value)
uint | NvWaveMatch (uint4 value)
uint | NvWaveMatch (float value)
uint | NvWaveMatch (float2 value)
uint | NvWaveMatch (float4 value)
uint4 | NvFootprintFine (uint texSpace, uint texIndex, uint smpSpace, uint smpIndex, uint texType, float3 location, uint gran, int3 offset=int3(0, 0, 0))
uint4 | NvFootprintCoarse (uint texSpace, uint texIndex, uint smpSpace, uint smpIndex, uint texType, float3 location, uint gran, int3 offset=int3(0, 0, 0))
uint4 | NvFootprintFineBias (uint texSpace, uint texIndex, uint smpSpace, uint smpIndex, uint texType, float3 location, uint gran, float bias, int3 offset=int3(0, 0, 0))
uint4 | NvFootprintCoarseBias (uint texSpace, uint texIndex, uint smpSpace, uint smpIndex, uint texType, float3 location, uint gran, float bias, int3 offset=int3(0, 0, 0))
uint4 | NvFootprintFineLevel (uint texSpace, uint texIndex, uint smpSpace, uint smpIndex, uint texType, float3 location, uint gran, float lodLevel, int3 offset=int3(0, 0, 0))
uint4 | NvFootprintCoarseLevel (uint texSpace, uint texIndex, uint smpSpace, uint smpIndex, uint texType, float3 location, uint gran, float lodLevel, int3 offset=int3(0, 0, 0))
uint4 | NvFootprintFineGrad (uint texSpace, uint texIndex, uint smpSpace, uint smpIndex, uint texType, float3 location, uint gran, float3 ddx, float3 ddy, int3 offset=int3(0, 0, 0))
uint4 | NvFootprintCoarseGrad (uint texSpace, uint texIndex, uint smpSpace, uint smpIndex, uint texType, float3 location, uint gran, float3 ddx, float3 ddy, int3 offset=int3(0, 0, 0))
uint | NvFootprintExtractLOD (uint4 blob)
uint | NvFootprintExtractReturnGran (uint4 blob)
uint2 | NvFootprintExtractAnchorTileLoc2D (uint4 blob)
uint3 | NvFootprintExtractAnchorTileLoc3D (uint4 blob)
uint2 | NvFootprintExtractOffset2D (uint4 blob)
uint3 | NvFootprintExtractOffset3D (uint4 blob)
uint2 | NvFootprintExtractBitmask (uint4 blob)
uint4 | NvFootprintFine (uint texSpace, uint texIndex, uint smpSpace, uint smpIndex, uint texType, float3 location, uint gran, out uint isSingleLod, int3 offset=int3(0, 0, 0))
uint4 | NvFootprintCoarse (uint texSpace, uint texIndex, uint smpSpace, uint smpIndex, uint texType, float3 location, uint gran, out uint isSingleLod, int3 offset=int3(0, 0, 0))
uint4 | NvFootprintFineBias (uint texSpace, uint texIndex, uint smpSpace, uint smpIndex, uint texType, float3 location, uint gran, float bias, out uint isSingleLod, int3 offset=int3(0, 0, 0))
uint4 | NvFootprintCoarseBias (uint texSpace, uint texIndex, uint smpSpace, uint smpIndex, uint texType, float3 location, uint gran, float bias, out uint isSingleLod, int3 offset=int3(0, 0, 0))
uint4 | NvFootprintFineLevel (uint texSpace, uint texIndex, uint smpSpace, uint smpIndex, uint texType, float3 location, uint gran, float lodLevel, out uint isSingleLod, int3 offset=int3(0, 0, 0))
uint4 | NvFootprintCoarseLevel (uint texSpace, uint texIndex, uint smpSpace, uint smpIndex, uint texType, float3 location, uint gran, float lodLevel, out uint isSingleLod, int3 offset=int3(0, 0, 0))
uint4 | NvFootprintFineGrad (uint texSpace, uint texIndex, uint smpSpace, uint smpIndex, uint texType, float3 location, uint gran, float3 ddx, float3 ddy, out uint isSingleLod, int3 offset=int3(0, 0, 0))
uint4 | NvFootprintCoarseGrad (uint texSpace, uint texIndex, uint smpSpace, uint smpIndex, uint texType, float3 location, uint gran, float3 ddx, float3 ddy, out uint isSingleLod, int3 offset=int3(0, 0, 0))
uint | NvActiveThreads ()
uint | NvWaveMultiPrefixInclusiveAdd (uint val, uint mask)
uint | NvWaveMultiPrefixExclusiveAdd (uint val, uint mask)
uint2 | NvWaveMultiPrefixInclusiveAdd (uint2 val, uint mask)
uint2 | NvWaveMultiPrefixExclusiveAdd (uint2 val, uint mask)
uint4 | NvWaveMultiPrefixInclusiveAdd (uint4 val, uint mask)
uint4 | NvWaveMultiPrefixExclusiveAdd (uint4 val, uint mask)
uint | NvWaveMultiPrefixInclusiveAnd (uint val, uint mask)
uint | NvWaveMultiPrefixExclusiveAnd (uint val, uint mask)
uint2 | NvWaveMultiPrefixInclusiveAnd (uint2 val, uint mask)
uint2 | NvWaveMultiPrefixExclusiveAnd (uint2 val, uint mask)
uint4 | NvWaveMultiPrefixInclusiveAnd (uint4 val, uint mask)
uint4 | NvWaveMultiPrefixExclusiveAnd (uint4 val, uint mask)
uint | NvWaveMultiPrefixInclusiveOr (uint val, uint mask)
uint | NvWaveMultiPrefixExclusiveOr (uint val, uint mask)
uint2 | NvWaveMultiPrefixInclusiveOr (uint2 val, uint mask)
uint2 | NvWaveMultiPrefixExclusiveOr (uint2 val, uint mask)
uint4 | NvWaveMultiPrefixInclusiveOr (uint4 val, uint mask)
uint4 | NvWaveMultiPrefixExclusiveOr (uint4 val, uint mask)
uint | NvWaveMultiPrefixInclusiveXOr (uint val, uint mask)
uint | NvWaveMultiPrefixExclusiveXOr (uint val, uint mask)
uint2 | NvWaveMultiPrefixInclusiveXOr (uint2 val, uint mask)
uint2 | NvWaveMultiPrefixExclusiveXOr (uint2 val, uint mask)
uint4 | NvWaveMultiPrefixInclusiveXOr (uint4 val, uint mask)
uint4 | NvWaveMultiPrefixExclusiveXOr (uint4 val, uint mask)
float3x3 | NvRtTriangleObjectPositions ()
float3x3 | NvRtMicroTriangleObjectPositions ()
float3x2 | NvRtMicroTriangleBarycentrics ()
bool | NvRtIsMicroTriangleHit ()
bool | NvRtIsBackFacing ()

Function Documentation

◆ NvActiveThreads()

uint NvActiveThreads ( )

References NvBallot().

Referenced by NvWaveMultiPrefixExclusiveAdd(), NvWaveMultiPrefixExclusiveAdd(), NvWaveMultiPrefixExclusiveAdd(), NvWaveMultiPrefixExclusiveAnd(), NvWaveMultiPrefixExclusiveAnd(), NvWaveMultiPrefixExclusiveAnd(), NvWaveMultiPrefixExclusiveOr(), NvWaveMultiPrefixExclusiveOr(), NvWaveMultiPrefixExclusiveOr(), NvWaveMultiPrefixExclusiveXOr(), NvWaveMultiPrefixExclusiveXOr(), NvWaveMultiPrefixExclusiveXOr(), NvWaveMultiPrefixInclusiveAdd(), NvWaveMultiPrefixInclusiveAdd(), NvWaveMultiPrefixInclusiveAdd(), NvWaveMultiPrefixInclusiveAnd(), NvWaveMultiPrefixInclusiveAnd(), NvWaveMultiPrefixInclusiveAnd(), NvWaveMultiPrefixInclusiveOr(), NvWaveMultiPrefixInclusiveOr(), NvWaveMultiPrefixInclusiveOr(), NvWaveMultiPrefixInclusiveXOr(), NvWaveMultiPrefixInclusiveXOr(), and NvWaveMultiPrefixInclusiveXOr().

◆ NvAll()

uint NvAll ( int predicate )

References g_NvidiaExt, and NV_EXTN_OP_VOTE_ALL.

◆ NvAny()

uint NvAny ( int predicate )

References g_NvidiaExt, and NV_EXTN_OP_VOTE_ANY.

◆ NvBallot()

uint NvBallot ( int predicate )

References g_NvidiaExt, and NV_EXTN_OP_VOTE_BALLOT.

Referenced by NvActiveThreads().

◆ NvEvaluateAttributeAtSampleForVPRS() [1/12]

float NvEvaluateAttributeAtSampleForVPRS | ( | float | attrib,
 |  | uint | sampleIndex,
 |  | int2 | pixelOffset
 | ) |  |

References g_NvidiaExt, and NV_EXTN_OP_VPRS_EVAL_ATTRIB_AT_SAMPLE.

◆ NvEvaluateAttributeAtSampleForVPRS() [2/12]

float2 NvEvaluateAttributeAtSampleForVPRS | ( | float2 | attrib,
 |  | uint | sampleIndex,
 |  | int2 | pixelOffset
 | ) |  |

References g_NvidiaExt, and NV_EXTN_OP_VPRS_EVAL_ATTRIB_AT_SAMPLE.

◆ NvEvaluateAttributeAtSampleForVPRS() [3/12]

float3 NvEvaluateAttributeAtSampleForVPRS | ( | float3 | attrib,
 |  | uint | sampleIndex,
 |  | int2 | pixelOffset
 | ) |  |

References g_NvidiaExt, and NV_EXTN_OP_VPRS_EVAL_ATTRIB_AT_SAMPLE.

◆ NvEvaluateAttributeAtSampleForVPRS() [4/12]

float4 NvEvaluateAttributeAtSampleForVPRS | ( | float4 | attrib,
 |  | uint | sampleIndex,
 |  | int2 | pixelOffset
 | ) |  |

References g_NvidiaExt, and NV_EXTN_OP_VPRS_EVAL_ATTRIB_AT_SAMPLE.

◆ NvEvaluateAttributeAtSampleForVPRS() [5/12]

int NvEvaluateAttributeAtSampleForVPRS | ( | int | attrib,
 |  | uint | sampleIndex,
 |  | int2 | pixelOffset
 | ) |  |

References g_NvidiaExt, and NV_EXTN_OP_VPRS_EVAL_ATTRIB_AT_SAMPLE.

◆ NvEvaluateAttributeAtSampleForVPRS() [6/12]

int2 NvEvaluateAttributeAtSampleForVPRS | ( | int2 | attrib,
 |  | uint | sampleIndex,
 |  | int2 | pixelOffset
 | ) |  |

References g_NvidiaExt, and NV_EXTN_OP_VPRS_EVAL_ATTRIB_AT_SAMPLE.

◆ NvEvaluateAttributeAtSampleForVPRS() [7/12]

int3 NvEvaluateAttributeAtSampleForVPRS | ( | int3 | attrib,
 |  | uint | sampleIndex,
 |  | int2 | pixelOffset
 | ) |  |

References g_NvidiaExt, and NV_EXTN_OP_VPRS_EVAL_ATTRIB_AT_SAMPLE.

◆ NvEvaluateAttributeAtSampleForVPRS() [8/12]

int4 NvEvaluateAttributeAtSampleForVPRS | ( | int4 | attrib,
 |  | uint | sampleIndex,
 |  | int2 | pixelOffset
 | ) |  |

References g_NvidiaExt, and NV_EXTN_OP_VPRS_EVAL_ATTRIB_AT_SAMPLE.

◆ NvEvaluateAttributeAtSampleForVPRS() [9/12]

uint NvEvaluateAttributeAtSampleForVPRS | ( | uint | attrib,
 |  | uint | sampleIndex,
 |  | int2 | pixelOffset
 | ) |  |

References g_NvidiaExt, and NV_EXTN_OP_VPRS_EVAL_ATTRIB_AT_SAMPLE.

◆ NvEvaluateAttributeAtSampleForVPRS() [10/12]

uint2 NvEvaluateAttributeAtSampleForVPRS | ( | uint2 | attrib,
 |  | uint | sampleIndex,
 |  | int2 | pixelOffset
 | ) |  |

References g_NvidiaExt, and NV_EXTN_OP_VPRS_EVAL_ATTRIB_AT_SAMPLE.

◆ NvEvaluateAttributeAtSampleForVPRS() [11/12]

uint3 NvEvaluateAttributeAtSampleForVPRS | ( | uint3 | attrib,
 |  | uint | sampleIndex,
 |  | int2 | pixelOffset
 | ) |  |

References g_NvidiaExt, and NV_EXTN_OP_VPRS_EVAL_ATTRIB_AT_SAMPLE.

◆ NvEvaluateAttributeAtSampleForVPRS() [12/12]

uint4 NvEvaluateAttributeAtSampleForVPRS | ( | uint4 | attrib,
 |  | uint | sampleIndex,
 |  | int2 | pixelOffset
 | ) |  |

References g_NvidiaExt, and NV_EXTN_OP_VPRS_EVAL_ATTRIB_AT_SAMPLE.

◆ NvEvaluateAttributeSnappedForVPRS() [1/12]

float NvEvaluateAttributeSnappedForVPRS | ( | float | attrib,
 |  | uint2 | offset
 | ) |  |

References g_NvidiaExt, and NV_EXTN_OP_VPRS_EVAL_ATTRIB_SNAPPED.

◆ NvEvaluateAttributeSnappedForVPRS() [2/12]

float2 NvEvaluateAttributeSnappedForVPRS | ( | float2 | attrib,
 |  | uint2 | offset
 | ) |  |

References g_NvidiaExt, and NV_EXTN_OP_VPRS_EVAL_ATTRIB_SNAPPED.

◆ NvEvaluateAttributeSnappedForVPRS() [3/12]

float3 NvEvaluateAttributeSnappedForVPRS | ( | float3 | attrib,
 |  | uint2 | offset
 | ) |  |

References g_NvidiaExt, and NV_EXTN_OP_VPRS_EVAL_ATTRIB_SNAPPED.

◆ NvEvaluateAttributeSnappedForVPRS() [4/12]

float4 NvEvaluateAttributeSnappedForVPRS | ( | float4 | attrib,
 |  | uint2 | offset
 | ) |  |

References g_NvidiaExt, and NV_EXTN_OP_VPRS_EVAL_ATTRIB_SNAPPED.

◆ NvEvaluateAttributeSnappedForVPRS() [5/12]

int NvEvaluateAttributeSnappedForVPRS | ( | int | attrib,
 |  | uint2 | offset
 | ) |  |

References g_NvidiaExt, and NV_EXTN_OP_VPRS_EVAL_ATTRIB_SNAPPED.

◆ NvEvaluateAttributeSnappedForVPRS() [6/12]

int2 NvEvaluateAttributeSnappedForVPRS | ( | int2 | attrib,
 |  | uint2 | offset
 | ) |  |

References g_NvidiaExt, and NV_EXTN_OP_VPRS_EVAL_ATTRIB_SNAPPED.

◆ NvEvaluateAttributeSnappedForVPRS() [7/12]

int3 NvEvaluateAttributeSnappedForVPRS | ( | int3 | attrib,
 |  | uint2 | offset
 | ) |  |

References g_NvidiaExt, and NV_EXTN_OP_VPRS_EVAL_ATTRIB_SNAPPED.

◆ NvEvaluateAttributeSnappedForVPRS() [8/12]

int4 NvEvaluateAttributeSnappedForVPRS | ( | int4 | attrib,
 |  | uint2 | offset
 | ) |  |

References g_NvidiaExt, and NV_EXTN_OP_VPRS_EVAL_ATTRIB_SNAPPED.

◆ NvEvaluateAttributeSnappedForVPRS() [9/12]

uint NvEvaluateAttributeSnappedForVPRS | ( | uint | attrib,
 |  | uint2 | offset
 | ) |  |

References g_NvidiaExt, and NV_EXTN_OP_VPRS_EVAL_ATTRIB_SNAPPED.

◆ NvEvaluateAttributeSnappedForVPRS() [10/12]

uint2 NvEvaluateAttributeSnappedForVPRS | ( | uint2 | attrib,
 |  | uint2 | offset
 | ) |  |

References g_NvidiaExt, and NV_EXTN_OP_VPRS_EVAL_ATTRIB_SNAPPED.

◆ NvEvaluateAttributeSnappedForVPRS() [11/12]

uint3 NvEvaluateAttributeSnappedForVPRS | ( | uint3 | attrib,
 |  | uint2 | offset
 | ) |  |

References g_NvidiaExt, and NV_EXTN_OP_VPRS_EVAL_ATTRIB_SNAPPED.

◆ NvEvaluateAttributeSnappedForVPRS() [12/12]

uint4 NvEvaluateAttributeSnappedForVPRS | ( | uint4 | attrib,
 |  | uint2 | offset
 | ) |  |

References g_NvidiaExt, and NV_EXTN_OP_VPRS_EVAL_ATTRIB_SNAPPED.

◆ NvFootprintCoarse() [1/2]

uint4 NvFootprintCoarse | ( | uint | texSpace,
 |  | uint | texIndex,
 |  | uint | smpSpace,
 |  | uint | smpIndex,
 |  | uint | texType,
 |  | float3 | location,
 |  | uint | gran,
 |  | int3 | offset = int3(0, 0, 0)
 | ) |  |

References __NvFootprint(), and NV_EXTN_FOOTPRINT_MODE_COARSE.

◆ NvFootprintCoarse() [2/2]

uint4 NvFootprintCoarse | ( | uint | texSpace,
 |  | uint | texIndex,
 |  | uint | smpSpace,
 |  | uint | smpIndex,
 |  | uint | texType,
 |  | float3 | location,
 |  | uint | gran,
 |  | out uint | isSingleLod,
 |  | int3 | offset = int3(0, 0, 0)
 | ) |  |

References __NvFootprint(), __NvGetSpecial(), NV_EXTN_FOOTPRINT_MODE_COARSE, and NV_SPECIALOP_FOOTPRINT_SINGLELOD_PRED.

◆ NvFootprintCoarseBias() [1/2]

uint4 NvFootprintCoarseBias | ( | uint | texSpace,
 |  | uint | texIndex,
 |  | uint | smpSpace,
 |  | uint | smpIndex,
 |  | uint | texType,
 |  | float3 | location,
 |  | uint | gran,
 |  | float | bias,
 |  | int3 | offset = int3(0, 0, 0)
 | ) |  |

References __NvFootprintBias(), and NV_EXTN_FOOTPRINT_MODE_COARSE.

◆ NvFootprintCoarseBias() [2/2]

uint4 NvFootprintCoarseBias | ( | uint | texSpace,
 |  | uint | texIndex,
 |  | uint | smpSpace,
 |  | uint | smpIndex,
 |  | uint | texType,
 |  | float3 | location,
 |  | uint | gran,
 |  | float | bias,
 |  | out uint | isSingleLod,
 |  | int3 | offset = int3(0, 0, 0)
 | ) |  |

References __NvFootprintBias(), __NvGetSpecial(), NV_EXTN_FOOTPRINT_MODE_COARSE, and NV_SPECIALOP_FOOTPRINT_SINGLELOD_PRED.

◆ NvFootprintCoarseGrad() [1/2]

uint4 NvFootprintCoarseGrad | ( | uint | texSpace,
 |  | uint | texIndex,
 |  | uint | smpSpace,
 |  | uint | smpIndex,
 |  | uint | texType,
 |  | float3 | location,
 |  | uint | gran,
 |  | float3 | ddx,
 |  | float3 | ddy,
 |  | int3 | offset = int3(0, 0, 0)
 | ) |  |

References __NvFootprintGrad(), and NV_EXTN_FOOTPRINT_MODE_COARSE.

◆ NvFootprintCoarseGrad() [2/2]

uint4 NvFootprintCoarseGrad | ( | uint | texSpace,
 |  | uint | texIndex,
 |  | uint | smpSpace,
 |  | uint | smpIndex,
 |  | uint | texType,
 |  | float3 | location,
 |  | uint | gran,
 |  | float3 | ddx,
 |  | float3 | ddy,
 |  | out uint | isSingleLod,
 |  | int3 | offset = int3(0, 0, 0)
 | ) |  |

References __NvFootprintGrad(), __NvGetSpecial(), NV_EXTN_FOOTPRINT_MODE_COARSE, and NV_SPECIALOP_FOOTPRINT_SINGLELOD_PRED.

◆ NvFootprintCoarseLevel() [1/2]

uint4 NvFootprintCoarseLevel | ( | uint | texSpace,
 |  | uint | texIndex,
 |  | uint | smpSpace,
 |  | uint | smpIndex,
 |  | uint | texType,
 |  | float3 | location,
 |  | uint | gran,
 |  | float | lodLevel,
 |  | int3 | offset = int3(0, 0, 0)
 | ) |  |

References __NvFootprintLevel(), and NV_EXTN_FOOTPRINT_MODE_COARSE.

◆ NvFootprintCoarseLevel() [2/2]

uint4 NvFootprintCoarseLevel | ( | uint | texSpace,
 |  | uint | texIndex,
 |  | uint | smpSpace,
 |  | uint | smpIndex,
 |  | uint | texType,
 |  | float3 | location,
 |  | uint | gran,
 |  | float | lodLevel,
 |  | out uint | isSingleLod,
 |  | int3 | offset = int3(0, 0, 0)
 | ) |  |

References __NvFootprintLevel(), __NvGetSpecial(), NV_EXTN_FOOTPRINT_MODE_COARSE, and NV_SPECIALOP_FOOTPRINT_SINGLELOD_PRED.

◆ NvFootprintExtractAnchorTileLoc2D()

uint2 NvFootprintExtractAnchorTileLoc2D ( uint4 blob )

◆ NvFootprintExtractAnchorTileLoc3D()

uint3 NvFootprintExtractAnchorTileLoc3D ( uint4 blob )

◆ NvFootprintExtractBitmask()

uint2 NvFootprintExtractBitmask ( uint4 blob )

◆ NvFootprintExtractLOD()

uint NvFootprintExtractLOD ( uint4 blob )

◆ NvFootprintExtractOffset2D()

uint2 NvFootprintExtractOffset2D ( uint4 blob )

◆ NvFootprintExtractOffset3D()

uint3 NvFootprintExtractOffset3D ( uint4 blob )

◆ NvFootprintExtractReturnGran()

uint NvFootprintExtractReturnGran ( uint4 blob )

◆ NvFootprintFine() [1/2]

uint4 NvFootprintFine | ( | uint | texSpace,
 |  | uint | texIndex,
 |  | uint | smpSpace,
 |  | uint | smpIndex,
 |  | uint | texType,
 |  | float3 | location,
 |  | uint | gran,
 |  | int3 | offset = int3(0, 0, 0)
 | ) |  |

References __NvFootprint(), and NV_EXTN_FOOTPRINT_MODE_FINE.

◆ NvFootprintFine() [2/2]

uint4 NvFootprintFine | ( | uint | texSpace,
 |  | uint | texIndex,
 |  | uint | smpSpace,
 |  | uint | smpIndex,
 |  | uint | texType,
 |  | float3 | location,
 |  | uint | gran,
 |  | out uint | isSingleLod,
 |  | int3 | offset = int3(0, 0, 0)
 | ) |  |

References __NvFootprint(), __NvGetSpecial(), NV_EXTN_FOOTPRINT_MODE_FINE, and NV_SPECIALOP_FOOTPRINT_SINGLELOD_PRED.

◆ NvFootprintFineBias() [1/2]

uint4 NvFootprintFineBias | ( | uint | texSpace,
 |  | uint | texIndex,
 |  | uint | smpSpace,
 |  | uint | smpIndex,
 |  | uint | texType,
 |  | float3 | location,
 |  | uint | gran,
 |  | float | bias,
 |  | int3 | offset = int3(0, 0, 0)
 | ) |  |

References __NvFootprintBias(), and NV_EXTN_FOOTPRINT_MODE_FINE.

◆ NvFootprintFineBias() [2/2]

uint4 NvFootprintFineBias | ( | uint | texSpace,
 |  | uint | texIndex,
 |  | uint | smpSpace,
 |  | uint | smpIndex,
 |  | uint | texType,
 |  | float3 | location,
 |  | uint | gran,
 |  | float | bias,
 |  | out uint | isSingleLod,
 |  | int3 | offset = int3(0, 0, 0)
 | ) |  |

References __NvFootprintBias(), __NvGetSpecial(), NV_EXTN_FOOTPRINT_MODE_FINE, and NV_SPECIALOP_FOOTPRINT_SINGLELOD_PRED.

◆ NvFootprintFineGrad() [1/2]

uint4 NvFootprintFineGrad | ( | uint | texSpace,
 |  | uint | texIndex,
 |  | uint | smpSpace,
 |  | uint | smpIndex,
 |  | uint | texType,
 |  | float3 | location,
 |  | uint | gran,
 |  | float3 | ddx,
 |  | float3 | ddy,
 |  | int3 | offset = int3(0, 0, 0)
 | ) |  |

References __NvFootprintGrad(), and NV_EXTN_FOOTPRINT_MODE_FINE.

◆ NvFootprintFineGrad() [2/2]

uint4 NvFootprintFineGrad | ( | uint | texSpace,
 |  | uint | texIndex,
 |  | uint | smpSpace,
 |  | uint | smpIndex,
 |  | uint | texType,
 |  | float3 | location,
 |  | uint | gran,
 |  | float3 | ddx,
 |  | float3 | ddy,
 |  | out uint | isSingleLod,
 |  | int3 | offset = int3(0, 0, 0)
 | ) |  |

References __NvFootprintGrad(), __NvGetSpecial(), NV_EXTN_FOOTPRINT_MODE_FINE, and NV_SPECIALOP_FOOTPRINT_SINGLELOD_PRED.

◆ NvFootprintFineLevel() [1/2]

uint4 NvFootprintFineLevel | ( | uint | texSpace,
 |  | uint | texIndex,
 |  | uint | smpSpace,
 |  | uint | smpIndex,
 |  | uint | texType,
 |  | float3 | location,
 |  | uint | gran,
 |  | float | lodLevel,
 |  | int3 | offset = int3(0, 0, 0)
 | ) |  |

References __NvFootprintLevel(), and NV_EXTN_FOOTPRINT_MODE_FINE.

◆ NvFootprintFineLevel() [2/2]

uint4 NvFootprintFineLevel | ( | uint | texSpace,
 |  | uint | texIndex,
 |  | uint | smpSpace,
 |  | uint | smpIndex,
 |  | uint | texType,
 |  | float3 | location,
 |  | uint | gran,
 |  | float | lodLevel,
 |  | out uint | isSingleLod,
 |  | int3 | offset = int3(0, 0, 0)
 | ) |  |

References __NvFootprintLevel(), __NvGetSpecial(), NV_EXTN_FOOTPRINT_MODE_FINE, and NV_SPECIALOP_FOOTPRINT_SINGLELOD_PRED.

◆ NvGetLaneId()

int NvGetLaneId ( )

References g_NvidiaExt, and NV_EXTN_OP_GET_LANE_ID.

◆ NvGetShadingRate()

uint3 NvGetShadingRate ( )

References g_NvidiaExt, and NV_EXTN_OP_GET_SHADING_RATE.

◆ NvGetSpecial()

uint NvGetSpecial ( uint subOpCode )

References __NvGetSpecial().

◆ NvInterlockedAddFp16x2() [1/8]

uint NvInterlockedAddFp16x2 | ( | RWByteAddressBuffer | uav,
 |  | uint | byteAddress,
 |  | float2 | val
 | ) |  |

References __fp32x2Tofp16x2(), __NvAtomicOpFP16x2(), and NV_EXTN_ATOM_ADD.

◆ NvInterlockedAddFp16x2() [2/8]

uint NvInterlockedAddFp16x2 | ( | RWByteAddressBuffer | uav,
 |  | uint | byteAddress,
 |  | uint | fp16x2Val
 | ) |  |

References __NvAtomicOpFP16x2(), and NV_EXTN_ATOM_ADD.

◆ NvInterlockedAddFp16x2() [3/8]

uint NvInterlockedAddFp16x2 | ( | RWTexture1D< float2 > | uav,
 |  | uint | address,
 |  | float2 | val
 | ) |  |

References __fp32x2Tofp16x2(), __NvAtomicOpFP16x2(), and NV_EXTN_ATOM_ADD.

◆ NvInterlockedAddFp16x2() [4/8]

uint NvInterlockedAddFp16x2 | ( | RWTexture1D< float2 > | uav,
 |  | uint | address,
 |  | uint | fp16x2Val
 | ) |  |

References __NvAtomicOpFP16x2(), and NV_EXTN_ATOM_ADD.

◆ NvInterlockedAddFp16x2() [5/8]

uint NvInterlockedAddFp16x2 | ( | RWTexture2D< float2 > | uav,
 |  | uint2 | address,
 |  | float2 | val
 | ) |  |

References __fp32x2Tofp16x2(), __NvAtomicOpFP16x2(), and NV_EXTN_ATOM_ADD.

◆ NvInterlockedAddFp16x2() [6/8]

uint NvInterlockedAddFp16x2 | ( | RWTexture2D< float2 > | uav,
 |  | uint2 | address,
 |  | uint | fp16x2Val
 | ) |  |

References __NvAtomicOpFP16x2(), and NV_EXTN_ATOM_ADD.

◆ NvInterlockedAddFp16x2() [7/8]

uint NvInterlockedAddFp16x2 | ( | RWTexture3D< float2 > | uav,
 |  | uint3 | address,
 |  | float2 | val
 | ) |  |

References __fp32x2Tofp16x2(), __NvAtomicOpFP16x2(), and NV_EXTN_ATOM_ADD.

◆ NvInterlockedAddFp16x2() [8/8]

uint NvInterlockedAddFp16x2 | ( | RWTexture3D< float2 > | uav,
 |  | uint3 | address,
 |  | uint | fp16x2Val
 | ) |  |

References __NvAtomicOpFP16x2(), and NV_EXTN_ATOM_ADD.

◆ NvInterlockedAddFp16x4() [1/6]

uint2 NvInterlockedAddFp16x4 | ( | RWTexture1D< float4 > | uav,
 |  | uint | address,
 |  | float4 | val
 | ) |  |

References __fp32x4Tofp16x4(), __NvAtomicOpFP16x2(), and NV_EXTN_ATOM_ADD.

◆ NvInterlockedAddFp16x4() [2/6]

uint2 NvInterlockedAddFp16x4 | ( | RWTexture1D< float4 > | uav,
 |  | uint | address,
 |  | uint2 | fp16x2Val
 | ) |  |

References __NvAtomicOpFP16x2(), and NV_EXTN_ATOM_ADD.

◆ NvInterlockedAddFp16x4() [3/6]

uint2 NvInterlockedAddFp16x4 | ( | RWTexture2D< float4 > | uav,
 |  | uint2 | address,
 |  | float4 | val
 | ) |  |

References __fp32x4Tofp16x4(), __NvAtomicOpFP16x2(), and NV_EXTN_ATOM_ADD.

◆ NvInterlockedAddFp16x4() [4/6]

uint2 NvInterlockedAddFp16x4 | ( | RWTexture2D< float4 > | uav,
 |  | uint2 | address,
 |  | uint2 | fp16x2Val
 | ) |  |

References __NvAtomicOpFP16x2(), and NV_EXTN_ATOM_ADD.

◆ NvInterlockedAddFp16x4() [5/6]

uint2 NvInterlockedAddFp16x4 | ( | RWTexture3D< float4 > | uav,
 |  | uint3 | address,
 |  | float4 | val
 | ) |  |

References __fp32x4Tofp16x4(), __NvAtomicOpFP16x2(), and NV_EXTN_ATOM_ADD.

◆ NvInterlockedAddFp16x4() [6/6]

uint2 NvInterlockedAddFp16x4 | ( | RWTexture3D< float4 > | uav,
 |  | uint3 | address,
 |  | uint2 | fp16x2Val
 | ) |  |

References __NvAtomicOpFP16x2(), and NV_EXTN_ATOM_ADD.

◆ NvInterlockedAddFp32() [1/4]

float NvInterlockedAddFp32 | ( | RWByteAddressBuffer | uav,
 |  | uint | byteAddress,
 |  | float | val
 | ) |  |

References __NvAtomicAddFP32().

◆ NvInterlockedAddFp32() [2/4]

float NvInterlockedAddFp32 | ( | RWTexture1D< float > | uav,
 |  | uint | address,
 |  | float | val
 | ) |  |

References __NvAtomicAddFP32().

◆ NvInterlockedAddFp32() [3/4]

float NvInterlockedAddFp32 | ( | RWTexture2D< float > | uav,
 |  | uint2 | address,
 |  | float | val
 | ) |  |

References __NvAtomicAddFP32().

◆ NvInterlockedAddFp32() [4/4]

float NvInterlockedAddFp32 | ( | RWTexture3D< float > | uav,
 |  | uint3 | address,
 |  | float | val
 | ) |  |

References __NvAtomicAddFP32().

◆ NvInterlockedAddUint64() [1/4]

uint2 NvInterlockedAddUint64 | ( | RWByteAddressBuffer | uav,
 |  | uint | byteAddress,
 |  | uint2 | value
 | ) |  |

References __NvAtomicOpUINT64(), and NV_EXTN_ATOM_ADD.

◆ NvInterlockedAddUint64() [2/4]

uint2 NvInterlockedAddUint64 | ( | RWTexture1D< uint2 > | uav,
 |  | uint | address,
 |  | uint2 | value
 | ) |  |

References __NvAtomicOpUINT64(), and NV_EXTN_ATOM_ADD.

◆ NvInterlockedAddUint64() [3/4]

uint2 NvInterlockedAddUint64 | ( | RWTexture2D< uint2 > | uav,
 |  | uint2 | address,
 |  | uint2 | value
 | ) |  |

References __NvAtomicOpUINT64(), and NV_EXTN_ATOM_ADD.

◆ NvInterlockedAddUint64() [4/4]

uint2 NvInterlockedAddUint64 | ( | RWTexture3D< uint2 > | uav,
 |  | uint3 | address,
 |  | uint2 | value
 | ) |  |

References __NvAtomicOpUINT64(), and NV_EXTN_ATOM_ADD.

◆ NvInterlockedAndUint64() [1/4]

uint2 NvInterlockedAndUint64 | ( | RWByteAddressBuffer | uav,
 |  | uint | byteAddress,
 |  | uint2 | value
 | ) |  |

References __NvAtomicOpUINT64(), and NV_EXTN_ATOM_AND.

◆ NvInterlockedAndUint64() [2/4]

uint2 NvInterlockedAndUint64 | ( | RWTexture1D< uint2 > | uav,
 |  | uint | address,
 |  | uint2 | value
 | ) |  |

References __NvAtomicOpUINT64(), and NV_EXTN_ATOM_AND.

◆ NvInterlockedAndUint64() [3/4]

uint2 NvInterlockedAndUint64 | ( | RWTexture2D< uint2 > | uav,
 |  | uint2 | address,
 |  | uint2 | value
 | ) |  |

References __NvAtomicOpUINT64(), and NV_EXTN_ATOM_AND.

◆ NvInterlockedAndUint64() [4/4]

uint2 NvInterlockedAndUint64 | ( | RWTexture3D< uint2 > | uav,
 |  | uint3 | address,
 |  | uint2 | value
 | ) |  |

References __NvAtomicOpUINT64(), and NV_EXTN_ATOM_AND.

◆ NvInterlockedCompareExchangeUint64() [1/4]

uint2 NvInterlockedCompareExchangeUint64 | ( | RWByteAddressBuffer | uav,
 |  | uint | byteAddress,
 |  | uint2 | compare_value,
 |  | uint2 | value
 | ) |  |

References __NvAtomicCompareExchangeUINT64().

◆ NvInterlockedCompareExchangeUint64() [2/4]

uint2 NvInterlockedCompareExchangeUint64 | ( | RWTexture1D< uint2 > | uav,
 |  | uint | address,
 |  | uint2 | compare_value,
 |  | uint2 | value
 | ) |  |

References __NvAtomicCompareExchangeUINT64().

◆ NvInterlockedCompareExchangeUint64() [3/4]

uint2 NvInterlockedCompareExchangeUint64 | ( | RWTexture2D< uint2 > | uav,
 |  | uint2 | address,
 |  | uint2 | compare_value,
 |  | uint2 | value
 | ) |  |

References __NvAtomicCompareExchangeUINT64().

◆ NvInterlockedCompareExchangeUint64() [4/4]

uint2 NvInterlockedCompareExchangeUint64 | ( | RWTexture3D< uint2 > | uav,
 |  | uint3 | address,
 |  | uint2 | compare_value,
 |  | uint2 | value
 | ) |  |

References __NvAtomicCompareExchangeUINT64().

◆ NvInterlockedExchangeUint64() [1/4]

uint2 NvInterlockedExchangeUint64 | ( | RWByteAddressBuffer | uav,
 |  | uint | byteAddress,
 |  | uint2 | value
 | ) |  |

References __NvAtomicOpUINT64(), and NV_EXTN_ATOM_SWAP.

◆ NvInterlockedExchangeUint64() [2/4]

uint2 NvInterlockedExchangeUint64 | ( | RWTexture1D< uint2 > | uav,
 |  | uint | address,
 |  | uint2 | value
 | ) |  |

References __NvAtomicOpUINT64(), and NV_EXTN_ATOM_SWAP.

◆ NvInterlockedExchangeUint64() [3/4]

uint2 NvInterlockedExchangeUint64 | ( | RWTexture2D< uint2 > | uav,
 |  | uint2 | address,
 |  | uint2 | value
 | ) |  |

References __NvAtomicOpUINT64(), and NV_EXTN_ATOM_SWAP.

◆ NvInterlockedExchangeUint64() [4/4]

uint2 NvInterlockedExchangeUint64 | ( | RWTexture3D< uint2 > | uav,
 |  | uint3 | address,
 |  | uint2 | value
 | ) |  |

References __NvAtomicOpUINT64(), and NV_EXTN_ATOM_SWAP.

◆ NvInterlockedMaxFp16x2() [1/8]

uint NvInterlockedMaxFp16x2 | ( | RWByteAddressBuffer | uav,
 |  | uint | byteAddress,
 |  | float2 | val
 | ) |  |

References __fp32x2Tofp16x2(), __NvAtomicOpFP16x2(), and NV_EXTN_ATOM_MAX.

◆ NvInterlockedMaxFp16x2() [2/8]

uint NvInterlockedMaxFp16x2 | ( | RWByteAddressBuffer | uav,
 |  | uint | byteAddress,
 |  | uint | fp16x2Val
 | ) |  |

References __NvAtomicOpFP16x2(), and NV_EXTN_ATOM_MAX.

◆ NvInterlockedMaxFp16x2() [3/8]

uint NvInterlockedMaxFp16x2 | ( | RWTexture1D< float2 > | uav,
 |  | uint | address,
 |  | float2 | val
 | ) |  |

References __fp32x2Tofp16x2(), __NvAtomicOpFP16x2(), and NV_EXTN_ATOM_MAX.

◆ NvInterlockedMaxFp16x2() [4/8]

uint NvInterlockedMaxFp16x2 | ( | RWTexture1D< float2 > | uav,
 |  | uint | address,
 |  | uint | fp16x2Val
 | ) |  |

References __NvAtomicOpFP16x2(), and NV_EXTN_ATOM_MAX.

◆ NvInterlockedMaxFp16x2() [5/8]

uint NvInterlockedMaxFp16x2 | ( | RWTexture2D< float2 > | uav,
 |  | uint2 | address,
 |  | float2 | val
 | ) |  |

References __fp32x2Tofp16x2(), __NvAtomicOpFP16x2(), and NV_EXTN_ATOM_MAX.

◆ NvInterlockedMaxFp16x2() [6/8]

uint NvInterlockedMaxFp16x2 | ( | RWTexture2D< float2 > | uav,
 |  | uint2 | address,
 |  | uint | fp16x2Val
 | ) |  |

References __NvAtomicOpFP16x2(), and NV_EXTN_ATOM_MAX.

◆ NvInterlockedMaxFp16x2() [7/8]

uint NvInterlockedMaxFp16x2 | ( | RWTexture3D< float2 > | uav,
 |  | uint3 | address,
 |  | float2 | val
 | ) |  |

References __fp32x2Tofp16x2(), __NvAtomicOpFP16x2(), and NV_EXTN_ATOM_MAX.

◆ NvInterlockedMaxFp16x2() [8/8]

uint NvInterlockedMaxFp16x2 | ( | RWTexture3D< float2 > | uav,
 |  | uint3 | address,
 |  | uint | fp16x2Val
 | ) |  |

References __NvAtomicOpFP16x2(), and NV_EXTN_ATOM_MAX.

◆ NvInterlockedMaxFp16x4() [1/6]

uint2 NvInterlockedMaxFp16x4 | ( | RWTexture1D< float4 > | uav,
 |  | uint | address,
 |  | float4 | val
 | ) |  |

References __fp32x4Tofp16x4(), __NvAtomicOpFP16x2(), and NV_EXTN_ATOM_MAX.

◆ NvInterlockedMaxFp16x4() [2/6]

uint2 NvInterlockedMaxFp16x4 | ( | RWTexture1D< float4 > | uav,
 |  | uint | address,
 |  | uint2 | fp16x2Val
 | ) |  |

References __NvAtomicOpFP16x2(), and NV_EXTN_ATOM_MAX.

◆ NvInterlockedMaxFp16x4() [3/6]

uint2 NvInterlockedMaxFp16x4 | ( | RWTexture2D< float4 > | uav,
 |  | uint2 | address,
 |  | float4 | val
 | ) |  |

References __fp32x4Tofp16x4(), __NvAtomicOpFP16x2(), and NV_EXTN_ATOM_MAX.

◆ NvInterlockedMaxFp16x4() [4/6]

uint2 NvInterlockedMaxFp16x4 | ( | RWTexture2D< float4 > | uav,
 |  | uint2 | address,
 |  | uint2 | fp16x2Val
 | ) |  |

References __NvAtomicOpFP16x2(), and NV_EXTN_ATOM_MAX.

◆ NvInterlockedMaxFp16x4() [5/6]

uint2 NvInterlockedMaxFp16x4 | ( | RWTexture3D< float4 > | uav,
 |  | uint3 | address,
 |  | float4 | val
 | ) |  |

References __fp32x4Tofp16x4(), __NvAtomicOpFP16x2(), and NV_EXTN_ATOM_MAX.

◆ NvInterlockedMaxFp16x4() [6/6]

uint2 NvInterlockedMaxFp16x4 | ( | RWTexture3D< float4 > | uav,
 |  | uint3 | address,
 |  | uint2 | fp16x2Val
 | ) |  |

References __NvAtomicOpFP16x2(), and NV_EXTN_ATOM_MAX.

◆ NvInterlockedMaxUint64() [1/4]

uint2 NvInterlockedMaxUint64 | ( | RWByteAddressBuffer | uav,
 |  | uint | byteAddress,
 |  | uint2 | value
 | ) |  |

References __NvAtomicOpUINT64(), and NV_EXTN_ATOM_MAX.

◆ NvInterlockedMaxUint64() [2/4]

uint2 NvInterlockedMaxUint64 | ( | RWTexture1D< uint2 > | uav,
 |  | uint | address,
 |  | uint2 | value
 | ) |  |

References __NvAtomicOpUINT64(), and NV_EXTN_ATOM_MAX.

◆ NvInterlockedMaxUint64() [3/4]

uint2 NvInterlockedMaxUint64 | ( | RWTexture2D< uint2 > | uav,
 |  | uint2 | address,
 |  | uint2 | value
 | ) |  |

References __NvAtomicOpUINT64(), and NV_EXTN_ATOM_MAX.

◆ NvInterlockedMaxUint64() [4/4]

uint2 NvInterlockedMaxUint64 | ( | RWTexture3D< uint2 > | uav,
 |  | uint3 | address,
 |  | uint2 | value
 | ) |  |

References __NvAtomicOpUINT64(), and NV_EXTN_ATOM_MAX.

◆ NvInterlockedMinFp16x2() [1/8]

uint NvInterlockedMinFp16x2 | ( | RWByteAddressBuffer | uav,
 |  | uint | byteAddress,
 |  | float2 | val
 | ) |  |

References __fp32x2Tofp16x2(), __NvAtomicOpFP16x2(), and NV_EXTN_ATOM_MIN.

◆ NvInterlockedMinFp16x2() [2/8]

uint NvInterlockedMinFp16x2 | ( | RWByteAddressBuffer | uav,
 |  | uint | byteAddress,
 |  | uint | fp16x2Val
 | ) |  |

References __NvAtomicOpFP16x2(), and NV_EXTN_ATOM_MIN.

◆ NvInterlockedMinFp16x2() [3/8]

uint NvInterlockedMinFp16x2 | ( | RWTexture1D< float2 > | uav,
 |  | uint | address,
 |  | float2 | val
 | ) |  |

References __fp32x2Tofp16x2(), __NvAtomicOpFP16x2(), and NV_EXTN_ATOM_MIN.

◆ NvInterlockedMinFp16x2() [4/8]

uint NvInterlockedMinFp16x2 | ( | RWTexture1D< float2 > | uav,
 |  | uint | address,
 |  | uint | fp16x2Val
 | ) |  |

References __NvAtomicOpFP16x2(), and NV_EXTN_ATOM_MIN.

◆ NvInterlockedMinFp16x2() [5/8]

uint NvInterlockedMinFp16x2 | ( | RWTexture2D< float2 > | uav,
 |  | uint2 | address,
 |  | float2 | val
 | ) |  |

References __fp32x2Tofp16x2(), __NvAtomicOpFP16x2(), and NV_EXTN_ATOM_MIN.

◆ NvInterlockedMinFp16x2() [6/8]

uint NvInterlockedMinFp16x2 | ( | RWTexture2D< float2 > | uav,
 |  | uint2 | address,
 |  | uint | fp16x2Val
 | ) |  |

References __NvAtomicOpFP16x2(), and NV_EXTN_ATOM_MIN.

◆ NvInterlockedMinFp16x2() [7/8]

uint NvInterlockedMinFp16x2 | ( | RWTexture3D< float2 > | uav,
 |  | uint3 | address,
 |  | float2 | val
 | ) |  |

References __fp32x2Tofp16x2(), __NvAtomicOpFP16x2(), and NV_EXTN_ATOM_MIN.

◆ NvInterlockedMinFp16x2() [8/8]

uint NvInterlockedMinFp16x2 | ( | RWTexture3D< float2 > | uav,
 |  | uint3 | address,
 |  | uint | fp16x2Val
 | ) |  |

References __NvAtomicOpFP16x2(), and NV_EXTN_ATOM_MIN.

◆ NvInterlockedMinFp16x4() [1/6]

uint2 NvInterlockedMinFp16x4 | ( | RWTexture1D< float4 > | uav,
 |  | uint | address,
 |  | float4 | val
 | ) |  |

References __fp32x4Tofp16x4(), __NvAtomicOpFP16x2(), and NV_EXTN_ATOM_MIN.

◆ NvInterlockedMinFp16x4() [2/6]

uint2 NvInterlockedMinFp16x4 | ( | RWTexture1D< float4 > | uav,
 |  | uint | address,
 |  | uint2 | fp16x2Val
 | ) |  |

References __NvAtomicOpFP16x2(), and NV_EXTN_ATOM_MIN.

◆ NvInterlockedMinFp16x4() [3/6]

uint2 NvInterlockedMinFp16x4 | ( | RWTexture2D< float4 > | uav,
 |  | uint2 | address,
 |  | float4 | val
 | ) |  |

References __fp32x4Tofp16x4(), __NvAtomicOpFP16x2(), and NV_EXTN_ATOM_MIN.

◆ NvInterlockedMinFp16x4() [4/6]

uint2 NvInterlockedMinFp16x4 | ( | RWTexture2D< float4 > | uav,
 |  | uint2 | address,
 |  | uint2 | fp16x2Val
 | ) |  |

References __NvAtomicOpFP16x2(), and NV_EXTN_ATOM_MIN.

◆ NvInterlockedMinFp16x4() [5/6]

uint2 NvInterlockedMinFp16x4 | ( | RWTexture3D< float4 > | uav,
 |  | uint3 | address,
 |  | float4 | val
 | ) |  |

References __fp32x4Tofp16x4(), __NvAtomicOpFP16x2(), and NV_EXTN_ATOM_MIN.

◆ NvInterlockedMinFp16x4() [6/6]

uint2 NvInterlockedMinFp16x4 | ( | RWTexture3D< float4 > | uav,
 |  | uint3 | address,
 |  | uint2 | fp16x2Val
 | ) |  |

References __NvAtomicOpFP16x2(), and NV_EXTN_ATOM_MIN.

◆ NvInterlockedMinUint64() [1/4]

uint2 NvInterlockedMinUint64 | ( | RWByteAddressBuffer | uav,
 |  | uint | byteAddress,
 |  | uint2 | value
 | ) |  |

References __NvAtomicOpUINT64(), and NV_EXTN_ATOM_MIN.

◆ NvInterlockedMinUint64() [2/4]

uint2 NvInterlockedMinUint64 | ( | RWTexture1D< uint2 > | uav,
 |  | uint | address,
 |  | uint2 | value
 | ) |  |

References __NvAtomicOpUINT64(), and NV_EXTN_ATOM_MIN.

◆ NvInterlockedMinUint64() [3/4]

uint2 NvInterlockedMinUint64 | ( | RWTexture2D< uint2 > | uav,
 |  | uint2 | address,
 |  | uint2 | value
 | ) |  |

References __NvAtomicOpUINT64(), and NV_EXTN_ATOM_MIN.

◆ NvInterlockedMinUint64() [4/4]

uint2 NvInterlockedMinUint64 | ( | RWTexture3D< uint2 > | uav,
 |  | uint3 | address,
 |  | uint2 | value
 | ) |  |

References __NvAtomicOpUINT64(), and NV_EXTN_ATOM_MIN.

◆ NvInterlockedOrUint64() [1/4]

uint2 NvInterlockedOrUint64 | ( | RWByteAddressBuffer | uav,
 |  | uint | byteAddress,
 |  | uint2 | value
 | ) |  |

References __NvAtomicOpUINT64(), and NV_EXTN_ATOM_OR.

◆ NvInterlockedOrUint64() [2/4]

uint2 NvInterlockedOrUint64 | ( | RWTexture1D< uint2 > | uav,
 |  | uint | address,
 |  | uint2 | value
 | ) |  |

References __NvAtomicOpUINT64(), and NV_EXTN_ATOM_OR.

◆ NvInterlockedOrUint64() [3/4]

uint2 NvInterlockedOrUint64 | ( | RWTexture2D< uint2 > | uav,
 |  | uint2 | address,
 |  | uint2 | value
 | ) |  |

References __NvAtomicOpUINT64(), and NV_EXTN_ATOM_OR.

◆ NvInterlockedOrUint64() [4/4]

uint2 NvInterlockedOrUint64 | ( | RWTexture3D< uint2 > | uav,
 |  | uint3 | address,
 |  | uint2 | value
 | ) |  |

References __NvAtomicOpUINT64(), and NV_EXTN_ATOM_OR.

◆ NvInterlockedXorUint64() [1/4]

uint2 NvInterlockedXorUint64 | ( | RWByteAddressBuffer | uav,
 |  | uint | byteAddress,
 |  | uint2 | value
 | ) |  |

References __NvAtomicOpUINT64(), and NV_EXTN_ATOM_XOR.

◆ NvInterlockedXorUint64() [2/4]

uint2 NvInterlockedXorUint64 | ( | RWTexture1D< uint2 > | uav,
 |  | uint | address,
 |  | uint2 | value
 | ) |  |

References __NvAtomicOpUINT64(), and NV_EXTN_ATOM_XOR.

◆ NvInterlockedXorUint64() [3/4]

uint2 NvInterlockedXorUint64 | ( | RWTexture2D< uint2 > | uav,
 |  | uint2 | address,
 |  | uint2 | value
 | ) |  |

References __NvAtomicOpUINT64(), and NV_EXTN_ATOM_XOR.

◆ NvInterlockedXorUint64() [4/4]

uint2 NvInterlockedXorUint64 | ( | RWTexture3D< uint2 > | uav,
 |  | uint3 | address,
 |  | uint2 | value
 | ) |  |

References __NvAtomicOpUINT64(), and NV_EXTN_ATOM_XOR.

◆ NvRtIsBackFacing()

bool NvRtIsBackFacing ( )

References g_NvidiaExt, and NV_EXTN_OP_RT_IS_BACK_FACING.

◆ NvRtIsMicroTriangleHit()

bool NvRtIsMicroTriangleHit ( )

References g_NvidiaExt, and NV_EXTN_OP_RT_IS_MICRO_TRIANGLE_HIT.

◆ NvRtMicroTriangleBarycentrics()

float3x2 NvRtMicroTriangleBarycentrics ( )

References g_NvidiaExt, and NV_EXTN_OP_RT_MICRO_TRIANGLE_BARYCENTRICS.

◆ NvRtMicroTriangleObjectPositions()

float3x3 NvRtMicroTriangleObjectPositions ( )

References g_NvidiaExt, and NV_EXTN_OP_RT_MICRO_TRIANGLE_OBJECT_POSITIONS.

◆ NvRtTriangleObjectPositions()

float3x3 NvRtTriangleObjectPositions ( )

References g_NvidiaExt, and NV_EXTN_OP_RT_TRIANGLE_OBJECT_POSITIONS.

◆ NvShfl() [1/3]

int NvShfl | ( | int | val,
 |  | uint | srcLane,
 |  | int | width = NV_WARP_SIZE
 | ) |  |

References __NvGetShflMaskFromWidth(), g_NvidiaExt, and NV_EXTN_OP_SHFL.

Referenced by NvShfl(), NvShfl(), NvWaveMultiPrefixExclusiveAdd(), NvWaveMultiPrefixExclusiveAdd(), NvWaveMultiPrefixExclusiveAdd(), NvWaveMultiPrefixExclusiveAnd(), NvWaveMultiPrefixExclusiveAnd(), NvWaveMultiPrefixExclusiveAnd(), NvWaveMultiPrefixExclusiveOr(), NvWaveMultiPrefixExclusiveOr(), NvWaveMultiPrefixExclusiveOr(), NvWaveMultiPrefixExclusiveXOr(), NvWaveMultiPrefixExclusiveXOr(), NvWaveMultiPrefixExclusiveXOr(), NvWaveMultiPrefixInclusiveAdd(), NvWaveMultiPrefixInclusiveAdd(), NvWaveMultiPrefixInclusiveAdd(), NvWaveMultiPrefixInclusiveAnd(), NvWaveMultiPrefixInclusiveAnd(), NvWaveMultiPrefixInclusiveAnd(), NvWaveMultiPrefixInclusiveOr(), NvWaveMultiPrefixInclusiveOr(), NvWaveMultiPrefixInclusiveOr(), NvWaveMultiPrefixInclusiveXOr(), NvWaveMultiPrefixInclusiveXOr(), and NvWaveMultiPrefixInclusiveXOr().

◆ NvShfl() [2/3]

int2 NvShfl | ( | int2 | val,
 |  | uint | srcLane,
 |  | int | width = NV_WARP_SIZE
 | ) |  |

References NvShfl().

◆ NvShfl() [3/3]

int4 NvShfl | ( | int4 | val,
 |  | uint | srcLane,
 |  | int | width = NV_WARP_SIZE
 | ) |  |

References NvShfl().

◆ NvShflDown()

int NvShflDown | ( | int | val,
 |  | uint | delta,
 |  | int | width = NV_WARP_SIZE
 | ) |  |

References __NvGetShflMaskFromWidth(), g_NvidiaExt, and NV_EXTN_OP_SHFL_DOWN.

◆ NvShflUp()

int NvShflUp | ( | int | val,
 |  | uint | delta,
 |  | int | width = NV_WARP_SIZE
 | ) |  |

References g_NvidiaExt, NV_EXTN_OP_SHFL_UP, and NV_WARP_SIZE.

◆ NvShflXor()

int NvShflXor | ( | int | val,
 |  | uint | laneMask,
 |  | int | width = NV_WARP_SIZE
 | ) |  |

References __NvGetShflMaskFromWidth(), g_NvidiaExt, and NV_EXTN_OP_SHFL_XOR.

◆ NvWaveMatch() [1/6]

uint NvWaveMatch ( float value )

References g_NvidiaExt, and NV_EXTN_OP_MATCH_ANY.

◆ NvWaveMatch() [2/6]

uint NvWaveMatch ( float2 value )

References g_NvidiaExt, and NV_EXTN_OP_MATCH_ANY.

◆ NvWaveMatch() [3/6]

uint NvWaveMatch ( float4 value )

References g_NvidiaExt, and NV_EXTN_OP_MATCH_ANY.

◆ NvWaveMatch() [4/6]

uint NvWaveMatch ( uint value )

References g_NvidiaExt, and NV_EXTN_OP_MATCH_ANY.

◆ NvWaveMatch() [5/6]

uint NvWaveMatch ( uint2 value )

References g_NvidiaExt, and NV_EXTN_OP_MATCH_ANY.

◆ NvWaveMatch() [6/6]

uint NvWaveMatch ( uint4 value )

References g_NvidiaExt, and NV_EXTN_OP_MATCH_ANY.

◆ NvWaveMultiPrefixExclusiveAdd() [1/3]

uint NvWaveMultiPrefixExclusiveAdd | ( | uint | val,
 |  | uint | mask
 | ) |  |

References __NvGetSpecial(), NV_SPECIALOP_THREADLTMASK, NvActiveThreads(), NvShfl(), and NvWaveMultiPrefixInclusiveAdd().

◆ NvWaveMultiPrefixExclusiveAdd() [2/3]

uint2 NvWaveMultiPrefixExclusiveAdd | ( | uint2 | val,
 |  | uint | mask
 | ) |  |

References __NvGetSpecial(), NV_SPECIALOP_THREADLTMASK, NvActiveThreads(), NvShfl(), and NvWaveMultiPrefixInclusiveAdd().

◆ NvWaveMultiPrefixExclusiveAdd() [3/3]

uint4 NvWaveMultiPrefixExclusiveAdd | ( | uint4 | val,
 |  | uint | mask
 | ) |  |

References __NvGetSpecial(), NV_SPECIALOP_THREADLTMASK, NvActiveThreads(), NvShfl(), and NvWaveMultiPrefixInclusiveAdd().

◆ NvWaveMultiPrefixExclusiveAnd() [1/3]

uint NvWaveMultiPrefixExclusiveAnd | ( | uint | val,
 |  | uint | mask
 | ) |  |

References __NvGetSpecial(), NV_SPECIALOP_THREADLTMASK, NvActiveThreads(), NvShfl(), and NvWaveMultiPrefixInclusiveAnd().

◆ NvWaveMultiPrefixExclusiveAnd() [2/3]

uint2 NvWaveMultiPrefixExclusiveAnd | ( | uint2 | val,
 |  | uint | mask
 | ) |  |

References __NvGetSpecial(), NV_SPECIALOP_THREADLTMASK, NvActiveThreads(), NvShfl(), and NvWaveMultiPrefixInclusiveAnd().

◆ NvWaveMultiPrefixExclusiveAnd() [3/3]

uint4 NvWaveMultiPrefixExclusiveAnd | ( | uint4 | val,
 |  | uint | mask
 | ) |  |

References __NvGetSpecial(), NV_SPECIALOP_THREADLTMASK, NvActiveThreads(), NvShfl(), and NvWaveMultiPrefixInclusiveAnd().

◆ NvWaveMultiPrefixExclusiveOr() [1/3]

uint NvWaveMultiPrefixExclusiveOr | ( | uint | val,
 |  | uint | mask
 | ) |  |

References __NvGetSpecial(), NV_SPECIALOP_THREADLTMASK, NvActiveThreads(), NvShfl(), and NvWaveMultiPrefixInclusiveOr().

◆ NvWaveMultiPrefixExclusiveOr() [2/3]

uint2 NvWaveMultiPrefixExclusiveOr | ( | uint2 | val,
 |  | uint | mask
 | ) |  |

References __NvGetSpecial(), NV_SPECIALOP_THREADLTMASK, NvActiveThreads(), NvShfl(), and NvWaveMultiPrefixInclusiveOr().

◆ NvWaveMultiPrefixExclusiveOr() [3/3]

uint4 NvWaveMultiPrefixExclusiveOr | ( | uint4 | val,
 |  | uint | mask
 | ) |  |

References __NvGetSpecial(), NV_SPECIALOP_THREADLTMASK, NvActiveThreads(), NvShfl(), and NvWaveMultiPrefixInclusiveOr().

◆ NvWaveMultiPrefixExclusiveXOr() [1/3]

uint NvWaveMultiPrefixExclusiveXOr | ( | uint | val,
 |  | uint | mask
 | ) |  |

References __NvGetSpecial(), NV_SPECIALOP_THREADLTMASK, NvActiveThreads(), NvShfl(), and NvWaveMultiPrefixInclusiveXOr().

◆ NvWaveMultiPrefixExclusiveXOr() [2/3]

uint2 NvWaveMultiPrefixExclusiveXOr | ( | uint2 | val,
 |  | uint | mask
 | ) |  |

References __NvGetSpecial(), NV_SPECIALOP_THREADLTMASK, NvActiveThreads(), NvShfl(), and NvWaveMultiPrefixInclusiveXOr().

◆ NvWaveMultiPrefixExclusiveXOr() [3/3]

uint4 NvWaveMultiPrefixExclusiveXOr | ( | uint4 | val,
 |  | uint | mask
 | ) |  |

References __NvGetSpecial(), NV_SPECIALOP_THREADLTMASK, NvActiveThreads(), NvShfl(), and NvWaveMultiPrefixInclusiveXOr().

◆ NvWaveMultiPrefixInclusiveAdd() [1/3]

uint NvWaveMultiPrefixInclusiveAdd | ( | uint | val,
 |  | uint | mask
 | ) |  |

References __NvGetSpecial(), __NvShflGeneric(), NV_SPECIALOP_THREADLTMASK, NV_WARP_SIZE_LOG2, NvActiveThreads(), and NvShfl().

Referenced by NvWaveMultiPrefixExclusiveAdd(), NvWaveMultiPrefixExclusiveAdd(), and NvWaveMultiPrefixExclusiveAdd().

◆ NvWaveMultiPrefixInclusiveAdd() [2/3]

uint2 NvWaveMultiPrefixInclusiveAdd | ( | uint2 | val,
 |  | uint | mask
 | ) |  |

References __NvGetSpecial(), __NvShflGeneric(), NV_SPECIALOP_THREADLTMASK, NV_WARP_SIZE_LOG2, NvActiveThreads(), and NvShfl().

◆ NvWaveMultiPrefixInclusiveAdd() [3/3]

uint4 NvWaveMultiPrefixInclusiveAdd | ( | uint4 | val,
 |  | uint | mask
 | ) |  |

References __NvGetSpecial(), __NvShflGeneric(), NV_SPECIALOP_THREADLTMASK, NV_WARP_SIZE_LOG2, NvActiveThreads(), and NvShfl().

◆ NvWaveMultiPrefixInclusiveAnd() [1/3]

uint NvWaveMultiPrefixInclusiveAnd | ( | uint | val,
 |  | uint | mask
 | ) |  |

References __NvGetSpecial(), __NvShflGeneric(), NV_SPECIALOP_THREADLTMASK, NV_WARP_SIZE_LOG2, NvActiveThreads(), and NvShfl().

Referenced by NvWaveMultiPrefixExclusiveAnd(), NvWaveMultiPrefixExclusiveAnd(), and NvWaveMultiPrefixExclusiveAnd().

◆ NvWaveMultiPrefixInclusiveAnd() [2/3]

uint2 NvWaveMultiPrefixInclusiveAnd | ( | uint2 | val,
 |  | uint | mask
 | ) |  |

References __NvGetSpecial(), __NvShflGeneric(), NV_SPECIALOP_THREADLTMASK, NV_WARP_SIZE_LOG2, NvActiveThreads(), and NvShfl().

◆ NvWaveMultiPrefixInclusiveAnd() [3/3]

uint4 NvWaveMultiPrefixInclusiveAnd | ( | uint4 | val,
 |  | uint | mask
 | ) |  |

References __NvGetSpecial(), __NvShflGeneric(), NV_SPECIALOP_THREADLTMASK, NV_WARP_SIZE_LOG2, NvActiveThreads(), and NvShfl().

◆ NvWaveMultiPrefixInclusiveOr() [1/3]

uint NvWaveMultiPrefixInclusiveOr | ( | uint | val,
 |  | uint | mask
 | ) |  |

References __NvGetSpecial(), __NvShflGeneric(), NV_SPECIALOP_THREADLTMASK, NV_WARP_SIZE_LOG2, NvActiveThreads(), and NvShfl().

Referenced by NvWaveMultiPrefixExclusiveOr(), NvWaveMultiPrefixExclusiveOr(), and NvWaveMultiPrefixExclusiveOr().

◆ NvWaveMultiPrefixInclusiveOr() [2/3]

uint2 NvWaveMultiPrefixInclusiveOr | ( | uint2 | val,
 |  | uint | mask
 | ) |  |

References __NvGetSpecial(), __NvShflGeneric(), NV_SPECIALOP_THREADLTMASK, NV_WARP_SIZE_LOG2, NvActiveThreads(), and NvShfl().

◆ NvWaveMultiPrefixInclusiveOr() [3/3]

uint4 NvWaveMultiPrefixInclusiveOr | ( | uint4 | val,
 |  | uint | mask
 | ) |  |

References __NvGetSpecial(), __NvShflGeneric(), NV_SPECIALOP_THREADLTMASK, NV_WARP_SIZE_LOG2, NvActiveThreads(), and NvShfl().

◆ NvWaveMultiPrefixInclusiveXOr() [1/3]

uint NvWaveMultiPrefixInclusiveXOr | ( | uint | val,
 |  | uint | mask
 | ) |  |

References __NvGetSpecial(), __NvShflGeneric(), NV_SPECIALOP_THREADLTMASK, NV_WARP_SIZE_LOG2, NvActiveThreads(), and NvShfl().

Referenced by NvWaveMultiPrefixExclusiveXOr(), NvWaveMultiPrefixExclusiveXOr(), and NvWaveMultiPrefixExclusiveXOr().

◆ NvWaveMultiPrefixInclusiveXOr() [2/3]

uint2 NvWaveMultiPrefixInclusiveXOr | ( | uint2 | val,
 |  | uint | mask
 | ) |  |

References __NvGetSpecial(), __NvShflGeneric(), NV_SPECIALOP_THREADLTMASK, NV_WARP_SIZE_LOG2, NvActiveThreads(), and NvShfl().

◆ NvWaveMultiPrefixInclusiveXOr() [3/3]

uint4 NvWaveMultiPrefixInclusiveXOr | ( | uint4 | val,
 |  | uint | mask
 | ) |  |

References __NvGetSpecial(), __NvShflGeneric(), NV_SPECIALOP_THREADLTMASK, NV_WARP_SIZE_LOG2, NvActiveThreads(), and NvShfl().


  • File List
  • Globals
Data Structures | Macros | Functions | Variables
nvHLSLExtnsInternal.h File Reference
#include "nvShaderExtnEnums.h"

Data Structures

struct NvShaderExtnStruct

Macros

#define | NV_EXTN_ATOM_AND 0
#define | NV_EXTN_ATOM_OR 1
#define | NV_EXTN_ATOM_XOR 2
#define | NV_EXTN_ATOM_ADD 3
#define | NV_EXTN_ATOM_MAX 6
#define | NV_EXTN_ATOM_MIN 7
#define | NV_EXTN_ATOM_SWAP 8
#define | NV_EXTN_ATOM_CAS 9

Functions

int | __NvGetShflMaskFromWidth (uint width)
void | __NvReferenceUAVForOp (RWByteAddressBuffer uav)
void | __NvReferenceUAVForOp (RWTexture1D< float2 > uav)
void | __NvReferenceUAVForOp (RWTexture2D< float2 > uav)
void | __NvReferenceUAVForOp (RWTexture3D< float2 > uav)
void | __NvReferenceUAVForOp (RWTexture1D< float4 > uav)
void | __NvReferenceUAVForOp (RWTexture2D< float4 > uav)
void | __NvReferenceUAVForOp (RWTexture3D< float4 > uav)
void | __NvReferenceUAVForOp (RWTexture1D< float > uav)
void | __NvReferenceUAVForOp (RWTexture2D< float > uav)
void | __NvReferenceUAVForOp (RWTexture3D< float > uav)
void | __NvReferenceUAVForOp (RWTexture1D< uint2 > uav)
void | __NvReferenceUAVForOp (RWTexture2D< uint2 > uav)
void | __NvReferenceUAVForOp (RWTexture3D< uint2 > uav)
void | __NvReferenceUAVForOp (RWTexture1D< uint4 > uav)
void | __NvReferenceUAVForOp (RWTexture2D< uint4 > uav)
void | __NvReferenceUAVForOp (RWTexture3D< uint4 > uav)
void | __NvReferenceUAVForOp (RWTexture1D< uint > uav)
void | __NvReferenceUAVForOp (RWTexture2D< uint > uav)
void | __NvReferenceUAVForOp (RWTexture3D< uint > uav)
void | __NvReferenceUAVForOp (RWTexture1D< int2 > uav)
void | __NvReferenceUAVForOp (RWTexture2D< int2 > uav)
void | __NvReferenceUAVForOp (RWTexture3D< int2 > uav)
void | __NvReferenceUAVForOp (RWTexture1D< int4 > uav)
void | __NvReferenceUAVForOp (RWTexture2D< int4 > uav)
void | __NvReferenceUAVForOp (RWTexture3D< int4 > uav)
void | __NvReferenceUAVForOp (RWTexture1D< int > uav)
void | __NvReferenceUAVForOp (RWTexture2D< int > uav)
void | __NvReferenceUAVForOp (RWTexture3D< int > uav)
uint | __NvAtomicOpFP16x2 (RWByteAddressBuffer uav, uint byteAddress, uint fp16x2Val, uint atomicOpType)
uint | __NvAtomicOpFP16x2 (RWTexture1D< float2 > uav, uint address, uint fp16x2Val, uint atomicOpType)
uint | __NvAtomicOpFP16x2 (RWTexture2D< float2 > uav, uint2 address, uint fp16x2Val, uint atomicOpType)
uint | __NvAtomicOpFP16x2 (RWTexture3D< float2 > uav, uint3 address, uint fp16x2Val, uint atomicOpType)
uint2 | __NvAtomicOpFP16x2 (RWTexture1D< float4 > uav, uint address, uint2 fp16x2Val, uint atomicOpType)
uint2 | __NvAtomicOpFP16x2 (RWTexture2D< float4 > uav, uint2 address, uint2 fp16x2Val, uint atomicOpType)
uint2 | __NvAtomicOpFP16x2 (RWTexture3D< float4 > uav, uint3 address, uint2 fp16x2Val, uint atomicOpType)
uint | __fp32x2Tofp16x2 (float2 val)
uint2 | __fp32x4Tofp16x4 (float4 val)
float | __NvAtomicAddFP32 (RWByteAddressBuffer uav, uint byteAddress, float val)
float | __NvAtomicAddFP32 (RWTexture1D< float > uav, uint address, float val)
float | __NvAtomicAddFP32 (RWTexture2D< float > uav, uint2 address, float val)
float | __NvAtomicAddFP32 (RWTexture3D< float > uav, uint3 address, float val)
uint2 | __NvAtomicCompareExchangeUINT64 (RWByteAddressBuffer uav, uint byteAddress, uint2 compareValue, uint2 value)
uint2 | __NvAtomicOpUINT64 (RWByteAddressBuffer uav, uint byteAddress, uint2 value, uint atomicOpType)
uint2 | __NvAtomicCompareExchangeUINT64 (RWTexture1D< uint2 > uav, uint address, uint2 compareValue, uint2 value)
uint2 | __NvAtomicOpUINT64 (RWTexture1D< uint2 > uav, uint address, uint2 value, uint atomicOpType)
uint2 | __NvAtomicCompareExchangeUINT64 (RWTexture2D< uint2 > uav, uint2 address, uint2 compareValue, uint2 value)
uint2 | __NvAtomicOpUINT64 (RWTexture2D< uint2 > uav, uint2 address, uint2 value, uint atomicOpType)
uint2 | __NvAtomicCompareExchangeUINT64 (RWTexture3D< uint2 > uav, uint3 address, uint2 compareValue, uint2 value)
uint2 | __NvAtomicOpUINT64 (RWTexture3D< uint2 > uav, uint3 address, uint2 value, uint atomicOpType)
uint4 | __NvFootprint (uint texSpace, uint texIndex, uint smpSpace, uint smpIndex, uint texType, float3 location, uint footprintmode, uint gran, int3 offset=int3(0, 0, 0))
uint4 | __NvFootprintBias (uint texSpace, uint texIndex, uint smpSpace, uint smpIndex, uint texType, float3 location, uint footprintmode, uint gran, float bias, int3 offset=int3(0, 0, 0))
uint4 | __NvFootprintLevel (uint texSpace, uint texIndex, uint smpSpace, uint smpIndex, uint texType, float3 location, uint footprintmode, uint gran, float lodLevel, int3 offset=int3(0, 0, 0))
uint4 | __NvFootprintGrad (uint texSpace, uint texIndex, uint smpSpace, uint smpIndex, uint texType, float3 location, uint footprintmode, uint gran, float3 ddx, float3 ddy, int3 offset=int3(0, 0, 0))
uint | __NvGetSpecial (uint subOpCode)
int | __NvShflGeneric (int val, uint srcLane, uint maskClampVal, out uint laneValid)

Variables

RWStructuredBuffer< NvShaderExtnStruct > g_NvidiaExt

Macro Definition Documentation

◆ NV_EXTN_ATOM_ADD

#define NV_EXTN_ATOM_ADD 3

◆ NV_EXTN_ATOM_AND

#define NV_EXTN_ATOM_AND 0

◆ NV_EXTN_ATOM_CAS

#define NV_EXTN_ATOM_CAS 9

◆ NV_EXTN_ATOM_MAX

#define NV_EXTN_ATOM_MAX 6

◆ NV_EXTN_ATOM_MIN

#define NV_EXTN_ATOM_MIN 7

◆ NV_EXTN_ATOM_OR

#define NV_EXTN_ATOM_OR 1

◆ NV_EXTN_ATOM_SWAP

#define NV_EXTN_ATOM_SWAP 8

◆ NV_EXTN_ATOM_XOR

#define NV_EXTN_ATOM_XOR 2

Function Documentation

◆ __fp32x2Tofp16x2()

uint __fp32x2Tofp16x2 ( float2 val )

Referenced by NvInterlockedAddFp16x2(), NvInterlockedAddFp16x2(), NvInterlockedAddFp16x2(), NvInterlockedAddFp16x2(), NvInterlockedMaxFp16x2(), NvInterlockedMaxFp16x2(), NvInterlockedMaxFp16x2(), NvInterlockedMaxFp16x2(), NvInterlockedMinFp16x2(), NvInterlockedMinFp16x2(), NvInterlockedMinFp16x2(), and NvInterlockedMinFp16x2().

◆ __fp32x4Tofp16x4()

uint2 __fp32x4Tofp16x4 ( float4 val )

Referenced by NvInterlockedAddFp16x4(), NvInterlockedAddFp16x4(), NvInterlockedAddFp16x4(), NvInterlockedMaxFp16x4(), NvInterlockedMaxFp16x4(), NvInterlockedMaxFp16x4(), NvInterlockedMinFp16x4(), NvInterlockedMinFp16x4(), and NvInterlockedMinFp16x4().

◆ __NvAtomicAddFP32() [1/4]

float __NvAtomicAddFP32 | ( | RWByteAddressBuffer | uav,
 |  | uint | byteAddress,
 |  | float | val
 | ) |  |

References __NvReferenceUAVForOp(), g_NvidiaExt, NV_EXTN_ATOM_ADD, and NV_EXTN_OP_FP32_ATOMIC.

Referenced by NvInterlockedAddFp32(), NvInterlockedAddFp32(), NvInterlockedAddFp32(), and NvInterlockedAddFp32().

◆ __NvAtomicAddFP32() [2/4]

float __NvAtomicAddFP32 | ( | RWTexture1D< float > | uav,
 |  | uint | address,
 |  | float | val
 | ) |  |

References __NvReferenceUAVForOp(), g_NvidiaExt, NV_EXTN_ATOM_ADD, and NV_EXTN_OP_FP32_ATOMIC.

◆ __NvAtomicAddFP32() [3/4]

float __NvAtomicAddFP32 | ( | RWTexture2D< float > | uav,
 |  | uint2 | address,
 |  | float | val
 | ) |  |

References __NvReferenceUAVForOp(), g_NvidiaExt, NV_EXTN_ATOM_ADD, and NV_EXTN_OP_FP32_ATOMIC.

◆ __NvAtomicAddFP32() [4/4]

float __NvAtomicAddFP32 | ( | RWTexture3D< float > | uav,
 |  | uint3 | address,
 |  | float | val
 | ) |  |

References __NvReferenceUAVForOp(), g_NvidiaExt, NV_EXTN_ATOM_ADD, and NV_EXTN_OP_FP32_ATOMIC.

◆ __NvAtomicCompareExchangeUINT64() [1/4]

uint2 __NvAtomicCompareExchangeUINT64 | ( | RWByteAddressBuffer | uav,
 |  | uint | byteAddress,
 |  | uint2 | compareValue,
 |  | uint2 | value
 | ) |  |

References __NvReferenceUAVForOp(), g_NvidiaExt, NV_EXTN_ATOM_CAS, and NV_EXTN_OP_UINT64_ATOMIC.

Referenced by NvInterlockedCompareExchangeUint64(), NvInterlockedCompareExchangeUint64(), NvInterlockedCompareExchangeUint64(), and NvInterlockedCompareExchangeUint64().

◆ __NvAtomicCompareExchangeUINT64() [2/4]

uint2 __NvAtomicCompareExchangeUINT64 | ( | RWTexture1D< uint2 > | uav,
 |  | uint | address,
 |  | uint2 | compareValue,
 |  | uint2 | value
 | ) |  |

References __NvReferenceUAVForOp(), g_NvidiaExt, NV_EXTN_ATOM_CAS, and NV_EXTN_OP_UINT64_ATOMIC.

◆ __NvAtomicCompareExchangeUINT64() [3/4]

uint2 __NvAtomicCompareExchangeUINT64 | ( | RWTexture2D< uint2 > | uav,
 |  | uint2 | address,
 |  | uint2 | compareValue,
 |  | uint2 | value
 | ) |  |

References __NvReferenceUAVForOp(), g_NvidiaExt, NV_EXTN_ATOM_CAS, and NV_EXTN_OP_UINT64_ATOMIC.

◆ __NvAtomicCompareExchangeUINT64() [4/4]

uint2 __NvAtomicCompareExchangeUINT64 | ( | RWTexture3D< uint2 > | uav,
 |  | uint3 | address,
 |  | uint2 | compareValue,
 |  | uint2 | value
 | ) |  |

References __NvReferenceUAVForOp(), g_NvidiaExt, NV_EXTN_ATOM_CAS, and NV_EXTN_OP_UINT64_ATOMIC.

◆ __NvAtomicOpFP16x2() [1/7]

uint __NvAtomicOpFP16x2 | ( | RWByteAddressBuffer | uav,
 |  | uint | byteAddress,
 |  | uint | fp16x2Val,
 |  | uint | atomicOpType
 | ) |  |

References __NvReferenceUAVForOp(), g_NvidiaExt, and NV_EXTN_OP_FP16_ATOMIC.

Referenced by NvInterlockedAddFp16x2(), NvInterlockedAddFp16x2(), NvInterlockedAddFp16x2(), NvInterlockedAddFp16x2(), NvInterlockedAddFp16x2(), NvInterlockedAddFp16x2(), NvInterlockedAddFp16x2(), NvInterlockedAddFp16x2(), NvInterlockedAddFp16x4(), NvInterlockedAddFp16x4(), NvInterlockedAddFp16x4(), NvInterlockedAddFp16x4(), NvInterlockedAddFp16x4(), NvInterlockedAddFp16x4(), NvInterlockedMaxFp16x2(), NvInterlockedMaxFp16x2(), NvInterlockedMaxFp16x2(), NvInterlockedMaxFp16x2(), NvInterlockedMaxFp16x2(), NvInterlockedMaxFp16x2(), NvInterlockedMaxFp16x2(), NvInterlockedMaxFp16x2(), NvInterlockedMaxFp16x4(), NvInterlockedMaxFp16x4(), NvInterlockedMaxFp16x4(), NvInterlockedMaxFp16x4(), NvInterlockedMaxFp16x4(), NvInterlockedMaxFp16x4(), NvInterlockedMinFp16x2(), NvInterlockedMinFp16x2(), NvInterlockedMinFp16x2(), NvInterlockedMinFp16x2(), NvInterlockedMinFp16x2(), NvInterlockedMinFp16x2(), NvInterlockedMinFp16x2(), NvInterlockedMinFp16x2(), NvInterlockedMinFp16x4(), NvInterlockedMinFp16x4(), NvInterlockedMinFp16x4(), NvInterlockedMinFp16x4(), NvInterlockedMinFp16x4(), and NvInterlockedMinFp16x4().

◆ __NvAtomicOpFP16x2() [2/7]

uint __NvAtomicOpFP16x2 | ( | RWTexture1D< float2 > | uav,
 |  | uint | address,
 |  | uint | fp16x2Val,
 |  | uint | atomicOpType
 | ) |  |

References __NvReferenceUAVForOp(), g_NvidiaExt, and NV_EXTN_OP_FP16_ATOMIC.

◆ __NvAtomicOpFP16x2() [3/7]

uint2 __NvAtomicOpFP16x2 | ( | RWTexture1D< float4 > | uav,
 |  | uint | address,
 |  | uint2 | fp16x2Val,
 |  | uint | atomicOpType
 | ) |  |

References __NvReferenceUAVForOp(), g_NvidiaExt, and NV_EXTN_OP_FP16_ATOMIC.

◆ __NvAtomicOpFP16x2() [4/7]

uint __NvAtomicOpFP16x2 | ( | RWTexture2D< float2 > | uav,
 |  | uint2 | address,
 |  | uint | fp16x2Val,
 |  | uint | atomicOpType
 | ) |  |

References __NvReferenceUAVForOp(), g_NvidiaExt, and NV_EXTN_OP_FP16_ATOMIC.

◆ __NvAtomicOpFP16x2() [5/7]

uint2 __NvAtomicOpFP16x2 | ( | RWTexture2D< float4 > | uav,
 |  | uint2 | address,
 |  | uint2 | fp16x2Val,
 |  | uint | atomicOpType
 | ) |  |

References __NvReferenceUAVForOp(), g_NvidiaExt, and NV_EXTN_OP_FP16_ATOMIC.

◆ __NvAtomicOpFP16x2() [6/7]

uint __NvAtomicOpFP16x2 | ( | RWTexture3D< float2 > | uav,
 |  | uint3 | address,
 |  | uint | fp16x2Val,
 |  | uint | atomicOpType
 | ) |  |

References __NvReferenceUAVForOp(), g_NvidiaExt, and NV_EXTN_OP_FP16_ATOMIC.

◆ __NvAtomicOpFP16x2() [7/7]

uint2 __NvAtomicOpFP16x2 | ( | RWTexture3D< float4 > | uav,
 |  | uint3 | address,
 |  | uint2 | fp16x2Val,
 |  | uint | atomicOpType
 | ) |  |

References __NvReferenceUAVForOp(), g_NvidiaExt, and NV_EXTN_OP_FP16_ATOMIC.

◆ __NvAtomicOpUINT64() [1/4]

uint2 __NvAtomicOpUINT64 | ( | RWByteAddressBuffer | uav,
 |  | uint | byteAddress,
 |  | uint2 | value,
 |  | uint | atomicOpType
 | ) |  |

References __NvReferenceUAVForOp(), g_NvidiaExt, and NV_EXTN_OP_UINT64_ATOMIC.

Referenced by NvInterlockedAddUint64(), NvInterlockedAddUint64(), NvInterlockedAddUint64(), NvInterlockedAddUint64(), NvInterlockedAndUint64(), NvInterlockedAndUint64(), NvInterlockedAndUint64(), NvInterlockedAndUint64(), NvInterlockedExchangeUint64(), NvInterlockedExchangeUint64(), NvInterlockedExchangeUint64(), NvInterlockedExchangeUint64(), NvInterlockedMaxUint64(), NvInterlockedMaxUint64(), NvInterlockedMaxUint64(), NvInterlockedMaxUint64(), NvInterlockedMinUint64(), NvInterlockedMinUint64(), NvInterlockedMinUint64(), NvInterlockedMinUint64(), NvInterlockedOrUint64(), NvInterlockedOrUint64(), NvInterlockedOrUint64(), NvInterlockedOrUint64(), NvInterlockedXorUint64(), NvInterlockedXorUint64(), NvInterlockedXorUint64(), and NvInterlockedXorUint64().

◆ __NvAtomicOpUINT64() [2/4]

uint2 __NvAtomicOpUINT64 | ( | RWTexture1D< uint2 > | uav,
 |  | uint | address,
 |  | uint2 | value,
 |  | uint | atomicOpType
 | ) |  |

References __NvReferenceUAVForOp(), g_NvidiaExt, and NV_EXTN_OP_UINT64_ATOMIC.

◆ __NvAtomicOpUINT64() [3/4]

uint2 __NvAtomicOpUINT64 | ( | RWTexture2D< uint2 > | uav,
 |  | uint2 | address,
 |  | uint2 | value,
 |  | uint | atomicOpType
 | ) |  |

References __NvReferenceUAVForOp(), g_NvidiaExt, and NV_EXTN_OP_UINT64_ATOMIC.

◆ __NvAtomicOpUINT64() [4/4]

uint2 __NvAtomicOpUINT64 | ( | RWTexture3D< uint2 > | uav,
 |  | uint3 | address,
 |  | uint2 | value,
 |  | uint | atomicOpType
 | ) |  |

References __NvReferenceUAVForOp(), g_NvidiaExt, and NV_EXTN_OP_UINT64_ATOMIC.

◆ __NvFootprint()

uint4 __NvFootprint | ( | uint | texSpace,
 |  | uint | texIndex,
 |  | uint | smpSpace,
 |  | uint | smpIndex,
 |  | uint | texType,
 |  | float3 | location,
 |  | uint | footprintmode,
 |  | uint | gran,
 |  | int3 | offset = int3(0, 0, 0)
 | ) |  |

References g_NvidiaExt, and NV_EXTN_OP_FOOTPRINT.

Referenced by NvFootprintCoarse(), NvFootprintCoarse(), NvFootprintFine(), and NvFootprintFine().

◆ __NvFootprintBias()

uint4 __NvFootprintBias | ( | uint | texSpace,
 |  | uint | texIndex,
 |  | uint | smpSpace,
 |  | uint | smpIndex,
 |  | uint | texType,
 |  | float3 | location,
 |  | uint | footprintmode,
 |  | uint | gran,
 |  | float | bias,
 |  | int3 | offset = int3(0, 0, 0)
 | ) |  |

References g_NvidiaExt, and NV_EXTN_OP_FOOTPRINT_BIAS.

Referenced by NvFootprintCoarseBias(), NvFootprintCoarseBias(), NvFootprintFineBias(), and NvFootprintFineBias().

◆ __NvFootprintGrad()

uint4 __NvFootprintGrad | ( | uint | texSpace,
 |  | uint | texIndex,
 |  | uint | smpSpace,
 |  | uint | smpIndex,
 |  | uint | texType,
 |  | float3 | location,
 |  | uint | footprintmode,
 |  | uint | gran,
 |  | float3 | ddx,
 |  | float3 | ddy,
 |  | int3 | offset = int3(0, 0, 0)
 | ) |  |

References g_NvidiaExt, and NV_EXTN_OP_FOOTPRINT_GRAD.

Referenced by NvFootprintCoarseGrad(), NvFootprintCoarseGrad(), NvFootprintFineGrad(), and NvFootprintFineGrad().

◆ __NvFootprintLevel()

uint4 __NvFootprintLevel | ( | uint | texSpace,
 |  | uint | texIndex,
 |  | uint | smpSpace,
 |  | uint | smpIndex,
 |  | uint | texType,
 |  | float3 | location,
 |  | uint | footprintmode,
 |  | uint | gran,
 |  | float | lodLevel,
 |  | int3 | offset = int3(0, 0, 0)
 | ) |  |

References g_NvidiaExt, and NV_EXTN_OP_FOOTPRINT_LEVEL.

Referenced by NvFootprintCoarseLevel(), NvFootprintCoarseLevel(), NvFootprintFineLevel(), and NvFootprintFineLevel().

◆ __NvGetShflMaskFromWidth()

int __NvGetShflMaskFromWidth ( uint width )

References NV_WARP_SIZE.

Referenced by NvShfl(), NvShflDown(), and NvShflXor().

◆ __NvGetSpecial()

uint __NvGetSpecial ( uint subOpCode )

References g_NvidiaExt, and NV_EXTN_OP_GET_SPECIAL.

Referenced by NvFootprintCoarse(), NvFootprintCoarseBias(), NvFootprintCoarseGrad(), NvFootprintCoarseLevel(), NvFootprintFine(), NvFootprintFineBias(), NvFootprintFineGrad(), NvFootprintFineLevel(), NvGetSpecial(), NvWaveMultiPrefixExclusiveAdd(), NvWaveMultiPrefixExclusiveAdd(), NvWaveMultiPrefixExclusiveAdd(), NvWaveMultiPrefixExclusiveAnd(), NvWaveMultiPrefixExclusiveAnd(), NvWaveMultiPrefixExclusiveAnd(), NvWaveMultiPrefixExclusiveOr(), NvWaveMultiPrefixExclusiveOr(), NvWaveMultiPrefixExclusiveOr(), NvWaveMultiPrefixExclusiveXOr(), NvWaveMultiPrefixExclusiveXOr(), NvWaveMultiPrefixExclusiveXOr(), NvWaveMultiPrefixInclusiveAdd(), NvWaveMultiPrefixInclusiveAdd(), NvWaveMultiPrefixInclusiveAdd(), NvWaveMultiPrefixInclusiveAnd(), NvWaveMultiPrefixInclusiveAnd(), NvWaveMultiPrefixInclusiveAnd(), NvWaveMultiPrefixInclusiveOr(), NvWaveMultiPrefixInclusiveOr(), NvWaveMultiPrefixInclusiveOr(), NvWaveMultiPrefixInclusiveXOr(), NvWaveMultiPrefixInclusiveXOr(), and NvWaveMultiPrefixInclusiveXOr().

◆ __NvReferenceUAVForOp() [1/28]

void __NvReferenceUAVForOp ( RWByteAddressBuffer uav )

References g_NvidiaExt.

Referenced by __NvAtomicAddFP32(), __NvAtomicAddFP32(), __NvAtomicAddFP32(), __NvAtomicAddFP32(), __NvAtomicCompareExchangeUINT64(), __NvAtomicCompareExchangeUINT64(), __NvAtomicCompareExchangeUINT64(), __NvAtomicCompareExchangeUINT64(), __NvAtomicOpFP16x2(), __NvAtomicOpFP16x2(), __NvAtomicOpFP16x2(), __NvAtomicOpFP16x2(), __NvAtomicOpFP16x2(), __NvAtomicOpFP16x2(), __NvAtomicOpFP16x2(), __NvAtomicOpUINT64(), __NvAtomicOpUINT64(), __NvAtomicOpUINT64(), and __NvAtomicOpUINT64().

◆ __NvReferenceUAVForOp() [2/28]

void __NvReferenceUAVForOp ( RWTexture1D< float > uav )

References g_NvidiaExt.

◆ __NvReferenceUAVForOp() [3/28]

void __NvReferenceUAVForOp ( RWTexture1D< float2 > uav )

References g_NvidiaExt.

◆ __NvReferenceUAVForOp() [4/28]

void __NvReferenceUAVForOp ( RWTexture1D< float4 > uav )

References g_NvidiaExt.

◆ __NvReferenceUAVForOp() [5/28]

void __NvReferenceUAVForOp ( RWTexture1D< int > uav )

References g_NvidiaExt.

◆ __NvReferenceUAVForOp() [6/28]

void __NvReferenceUAVForOp ( RWTexture1D< int2 > uav )

References g_NvidiaExt.

◆ __NvReferenceUAVForOp() [7/28]

void __NvReferenceUAVForOp ( RWTexture1D< int4 > uav )

References g_NvidiaExt.

◆ __NvReferenceUAVForOp() [8/28]

void __NvReferenceUAVForOp ( RWTexture1D< uint > uav )

References g_NvidiaExt.

◆ __NvReferenceUAVForOp() [9/28]

void __NvReferenceUAVForOp ( RWTexture1D< uint2 > uav )

References g_NvidiaExt.

◆ __NvReferenceUAVForOp() [10/28]

void __NvReferenceUAVForOp ( RWTexture1D< uint4 > uav )

References g_NvidiaExt.

◆ __NvReferenceUAVForOp() [11/28]

void __NvReferenceUAVForOp ( RWTexture2D< float > uav )

References g_NvidiaExt.

◆ __NvReferenceUAVForOp() [12/28]

void __NvReferenceUAVForOp ( RWTexture2D< float2 > uav )

References g_NvidiaExt.

◆ __NvReferenceUAVForOp() [13/28]

void __NvReferenceUAVForOp ( RWTexture2D< float4 > uav )

References g_NvidiaExt.

◆ __NvReferenceUAVForOp() [14/28]

void __NvReferenceUAVForOp ( RWTexture2D< int > uav )

References g_NvidiaExt.

◆ __NvReferenceUAVForOp() [15/28]

void __NvReferenceUAVForOp ( RWTexture2D< int2 > uav )

References g_NvidiaExt.

◆ __NvReferenceUAVForOp() [16/28]

void __NvReferenceUAVForOp ( RWTexture2D< int4 > uav )

References g_NvidiaExt.

◆ __NvReferenceUAVForOp() [17/28]

void __NvReferenceUAVForOp ( RWTexture2D< uint > uav )

References g_NvidiaExt.

◆ __NvReferenceUAVForOp() [18/28]

void __NvReferenceUAVForOp ( RWTexture2D< uint2 > uav )

References g_NvidiaExt.

◆ __NvReferenceUAVForOp() [19/28]

void __NvReferenceUAVForOp ( RWTexture2D< uint4 > uav )

References g_NvidiaExt.

◆ __NvReferenceUAVForOp() [20/28]

void __NvReferenceUAVForOp ( RWTexture3D< float > uav )

References g_NvidiaExt.

◆ __NvReferenceUAVForOp() [21/28]

void __NvReferenceUAVForOp ( RWTexture3D< float2 > uav )

References g_NvidiaExt.

◆ __NvReferenceUAVForOp() [22/28]

void __NvReferenceUAVForOp ( RWTexture3D< float4 > uav )

References g_NvidiaExt.

◆ __NvReferenceUAVForOp() [23/28]

void __NvReferenceUAVForOp ( RWTexture3D< int > uav )

References g_NvidiaExt.

◆ __NvReferenceUAVForOp() [24/28]

void __NvReferenceUAVForOp ( RWTexture3D< int2 > uav )

References g_NvidiaExt.

◆ __NvReferenceUAVForOp() [25/28]

void __NvReferenceUAVForOp ( RWTexture3D< int4 > uav )

References g_NvidiaExt.

◆ __NvReferenceUAVForOp() [26/28]

void __NvReferenceUAVForOp ( RWTexture3D< uint > uav )

References g_NvidiaExt.

◆ __NvReferenceUAVForOp() [27/28]

void __NvReferenceUAVForOp ( RWTexture3D< uint2 > uav )

References g_NvidiaExt.

◆ __NvReferenceUAVForOp() [28/28]

void __NvReferenceUAVForOp ( RWTexture3D< uint4 > uav )

References g_NvidiaExt.

◆ __NvShflGeneric()

int __NvShflGeneric | ( | int | val,
 |  | uint | srcLane,
 |  | uint | maskClampVal,
 |  | out uint | laneValid
 | ) |  |

References g_NvidiaExt, and NV_EXTN_OP_SHFL_GENERIC.

Referenced by NvWaveMultiPrefixInclusiveAdd(), NvWaveMultiPrefixInclusiveAdd(), NvWaveMultiPrefixInclusiveAdd(), NvWaveMultiPrefixInclusiveAnd(), NvWaveMultiPrefixInclusiveAnd(), NvWaveMultiPrefixInclusiveAnd(), NvWaveMultiPrefixInclusiveOr(), NvWaveMultiPrefixInclusiveOr(), NvWaveMultiPrefixInclusiveOr(), NvWaveMultiPrefixInclusiveXOr(), NvWaveMultiPrefixInclusiveXOr(), and NvWaveMultiPrefixInclusiveXOr().

Variable Documentation

◆ g_NvidiaExt

RWStructuredBuffer<NvShaderExtnStruct> g_NvidiaExt

Referenced by __NvAtomicAddFP32(), __NvAtomicAddFP32(), __NvAtomicAddFP32(), __NvAtomicAddFP32(), __NvAtomicCompareExchangeUINT64(), __NvAtomicCompareExchangeUINT64(), __NvAtomicCompareExchangeUINT64(), __NvAtomicCompareExchangeUINT64(), __NvAtomicOpFP16x2(), __NvAtomicOpFP16x2(), __NvAtomicOpFP16x2(), __NvAtomicOpFP16x2(), __NvAtomicOpFP16x2(), __NvAtomicOpFP16x2(), __NvAtomicOpFP16x2(), __NvAtomicOpUINT64(), __NvAtomicOpUINT64(), __NvAtomicOpUINT64(), __NvAtomicOpUINT64(), __NvFootprint(), __NvFootprintBias(), __NvFootprintGrad(), __NvFootprintLevel(), __NvGetSpecial(), __NvReferenceUAVForOp(), __NvReferenceUAVForOp(), __NvReferenceUAVForOp(), __NvReferenceUAVForOp(), __NvReferenceUAVForOp(), __NvReferenceUAVForOp(), __NvReferenceUAVForOp(), __NvReferenceUAVForOp(), __NvReferenceUAVForOp(), __NvReferenceUAVForOp(), __NvReferenceUAVForOp(), __NvReferenceUAVForOp(), __NvReferenceUAVForOp(), __NvReferenceUAVForOp(), __NvReferenceUAVForOp(), __NvReferenceUAVForOp(), __NvReferenceUAVForOp(), __NvReferenceUAVForOp(), __NvReferenceUAVForOp(), __NvReferenceUAVForOp(), __NvReferenceUAVForOp(), __NvReferenceUAVForOp(), __NvReferenceUAVForOp(), __NvReferenceUAVForOp(), __NvReferenceUAVForOp(), __NvReferenceUAVForOp(), __NvReferenceUAVForOp(), __NvReferenceUAVForOp(), __NvShflGeneric(), NvAll(), NvAny(), NvBallot(), NvEvaluateAttributeAtSampleForVPRS(), NvEvaluateAttributeAtSampleForVPRS(), NvEvaluateAttributeAtSampleForVPRS(), NvEvaluateAttributeAtSampleForVPRS(), NvEvaluateAttributeAtSampleForVPRS(), NvEvaluateAttributeAtSampleForVPRS(), NvEvaluateAttributeAtSampleForVPRS(), NvEvaluateAttributeAtSampleForVPRS(), NvEvaluateAttributeAtSampleForVPRS(), NvEvaluateAttributeAtSampleForVPRS(), NvEvaluateAttributeAtSampleForVPRS(), NvEvaluateAttributeAtSampleForVPRS(), NvEvaluateAttributeSnappedForVPRS(), NvEvaluateAttributeSnappedForVPRS(), NvEvaluateAttributeSnappedForVPRS(), NvEvaluateAttributeSnappedForVPRS(), NvEvaluateAttributeSnappedForVPRS(), NvEvaluateAttributeSnappedForVPRS(), NvEvaluateAttributeSnappedForVPRS(), NvEvaluateAttributeSnappedForVPRS(), NvEvaluateAttributeSnappedForVPRS(), NvEvaluateAttributeSnappedForVPRS(), NvEvaluateAttributeSnappedForVPRS(), NvEvaluateAttributeSnappedForVPRS(), NvGetLaneId(), NvGetShadingRate(), NvRtIsBackFacing(), NvRtIsMicroTriangleHit(), NvRtMicroTriangleBarycentrics(), NvRtMicroTriangleObjectPositions(), NvRtTriangleObjectPositions(), NvShfl(), NvShflDown(), NvShflUp(), NvShflXor(), NvWaveMatch(), NvWaveMatch(), NvWaveMatch(), NvWaveMatch(), NvWaveMatch(), and NvWaveMatch().


  • File List
  • Globals
Macros
nvShaderExtnEnums.h File Reference

Macros

#define | NV_SHADER_EXTN_VERSION 1
#define | NV_WARP_SIZE 32
#define | NV_WARP_SIZE_LOG2 5
#define | NV_EXTN_OP_SHFL 1
#define | NV_EXTN_OP_SHFL_UP 2
#define | NV_EXTN_OP_SHFL_DOWN 3
#define | NV_EXTN_OP_SHFL_XOR 4
#define | NV_EXTN_OP_VOTE_ALL 5
#define | NV_EXTN_OP_VOTE_ANY 6
#define | NV_EXTN_OP_VOTE_BALLOT 7
#define | NV_EXTN_OP_GET_LANE_ID 8
#define | NV_EXTN_OP_FP16_ATOMIC 12
#define | NV_EXTN_OP_FP32_ATOMIC 13
#define | NV_EXTN_OP_GET_SPECIAL 19
#define | NV_EXTN_OP_UINT64_ATOMIC 20
#define | NV_EXTN_OP_MATCH_ANY 21
#define | NV_EXTN_OP_FOOTPRINT 28
#define | NV_EXTN_OP_FOOTPRINT_BIAS 29
#define | NV_EXTN_OP_GET_SHADING_RATE 30
#define | NV_EXTN_OP_FOOTPRINT_LEVEL 31
#define | NV_EXTN_OP_FOOTPRINT_GRAD 32
#define | NV_EXTN_OP_SHFL_GENERIC 33
#define | NV_EXTN_OP_VPRS_EVAL_ATTRIB_AT_SAMPLE 51
#define | NV_EXTN_OP_VPRS_EVAL_ATTRIB_SNAPPED 52
#define | NV_EXTN_OP_HIT_OBJECT_TRACE_RAY 67
#define | NV_EXTN_OP_HIT_OBJECT_MAKE_HIT 68
#define | NV_EXTN_OP_HIT_OBJECT_MAKE_HIT_WITH_RECORD_INDEX 69
#define | NV_EXTN_OP_HIT_OBJECT_MAKE_MISS 70
#define | NV_EXTN_OP_HIT_OBJECT_REORDER_THREAD 71
#define | NV_EXTN_OP_HIT_OBJECT_INVOKE 72
#define | NV_EXTN_OP_HIT_OBJECT_IS_MISS 73
#define | NV_EXTN_OP_HIT_OBJECT_GET_INSTANCE_ID 74
#define | NV_EXTN_OP_HIT_OBJECT_GET_INSTANCE_INDEX 75
#define | NV_EXTN_OP_HIT_OBJECT_GET_PRIMITIVE_INDEX 76
#define | NV_EXTN_OP_HIT_OBJECT_GET_GEOMETRY_INDEX 77
#define | NV_EXTN_OP_HIT_OBJECT_GET_HIT_KIND 78
#define | NV_EXTN_OP_HIT_OBJECT_GET_RAY_DESC 79
#define | NV_EXTN_OP_HIT_OBJECT_GET_ATTRIBUTES 80
#define | NV_EXTN_OP_HIT_OBJECT_GET_SHADER_TABLE_INDEX 81
#define | NV_EXTN_OP_HIT_OBJECT_LOAD_LOCAL_ROOT_TABLE_CONSTANT 82
#define | NV_EXTN_OP_HIT_OBJECT_IS_HIT 83
#define | NV_EXTN_OP_HIT_OBJECT_IS_NOP 84
#define | NV_EXTN_OP_HIT_OBJECT_MAKE_NOP 85
#define | NV_EXTN_OP_RT_TRIANGLE_OBJECT_POSITIONS 86
#define | NV_EXTN_OP_RT_MICRO_TRIANGLE_OBJECT_POSITIONS 87
#define | NV_EXTN_OP_RT_MICRO_TRIANGLE_BARYCENTRICS 88
#define | NV_EXTN_OP_RT_IS_MICRO_TRIANGLE_HIT 89
#define | NV_EXTN_OP_RT_IS_BACK_FACING 90
#define | NV_EXTN_OP_RT_MICRO_VERTEX_OBJECT_POSITION 91
#define | NV_EXTN_OP_RT_MICRO_VERTEX_BARYCENTRICS 92
#define | NV_SPECIALOP_THREADLTMASK 4
#define | NV_SPECIALOP_FOOTPRINT_SINGLELOD_PRED 5
#define | NV_SPECIALOP_GLOBAL_TIMER_LO 9
#define | NV_SPECIALOP_GLOBAL_TIMER_HI 10
#define | NV_EXTN_TEXTURE_1D 2
#define | NV_EXTN_TEXTURE_1D_ARRAY 3
#define | NV_EXTN_TEXTURE_2D 4
#define | NV_EXTN_TEXTURE_2D_ARRAY 5
#define | NV_EXTN_TEXTURE_3D 6
#define | NV_EXTN_TEXTURE_CUBE 7
#define | NV_EXTN_TEXTURE_CUBE_ARRAY 8
#define | NV_EXTN_FOOTPRINT_MODE_FINE 0
#define | NV_EXTN_FOOTPRINT_MODE_COARSE 1

Macro Definition Documentation

◆ NV_EXTN_FOOTPRINT_MODE_COARSE

#define NV_EXTN_FOOTPRINT_MODE_COARSE 1

◆ NV_EXTN_FOOTPRINT_MODE_FINE

#define NV_EXTN_FOOTPRINT_MODE_FINE 0

◆ NV_EXTN_OP_FOOTPRINT

#define NV_EXTN_OP_FOOTPRINT 28

◆ NV_EXTN_OP_FOOTPRINT_BIAS

#define NV_EXTN_OP_FOOTPRINT_BIAS 29

◆ NV_EXTN_OP_FOOTPRINT_GRAD

#define NV_EXTN_OP_FOOTPRINT_GRAD 32

◆ NV_EXTN_OP_FOOTPRINT_LEVEL

#define NV_EXTN_OP_FOOTPRINT_LEVEL 31

◆ NV_EXTN_OP_FP16_ATOMIC

#define NV_EXTN_OP_FP16_ATOMIC 12

◆ NV_EXTN_OP_FP32_ATOMIC

#define NV_EXTN_OP_FP32_ATOMIC 13

◆ NV_EXTN_OP_GET_LANE_ID

#define NV_EXTN_OP_GET_LANE_ID 8

◆ NV_EXTN_OP_GET_SHADING_RATE

#define NV_EXTN_OP_GET_SHADING_RATE 30

◆ NV_EXTN_OP_GET_SPECIAL

#define NV_EXTN_OP_GET_SPECIAL 19

◆ NV_EXTN_OP_HIT_OBJECT_GET_ATTRIBUTES

#define NV_EXTN_OP_HIT_OBJECT_GET_ATTRIBUTES 80

◆ NV_EXTN_OP_HIT_OBJECT_GET_GEOMETRY_INDEX

#define NV_EXTN_OP_HIT_OBJECT_GET_GEOMETRY_INDEX 77

◆ NV_EXTN_OP_HIT_OBJECT_GET_HIT_KIND

#define NV_EXTN_OP_HIT_OBJECT_GET_HIT_KIND 78

◆ NV_EXTN_OP_HIT_OBJECT_GET_INSTANCE_ID

#define NV_EXTN_OP_HIT_OBJECT_GET_INSTANCE_ID 74

◆ NV_EXTN_OP_HIT_OBJECT_GET_INSTANCE_INDEX

#define NV_EXTN_OP_HIT_OBJECT_GET_INSTANCE_INDEX 75

◆ NV_EXTN_OP_HIT_OBJECT_GET_PRIMITIVE_INDEX

#define NV_EXTN_OP_HIT_OBJECT_GET_PRIMITIVE_INDEX 76

◆ NV_EXTN_OP_HIT_OBJECT_GET_RAY_DESC

#define NV_EXTN_OP_HIT_OBJECT_GET_RAY_DESC 79

◆ NV_EXTN_OP_HIT_OBJECT_GET_SHADER_TABLE_INDEX

#define NV_EXTN_OP_HIT_OBJECT_GET_SHADER_TABLE_INDEX 81

◆ NV_EXTN_OP_HIT_OBJECT_INVOKE

#define NV_EXTN_OP_HIT_OBJECT_INVOKE 72

◆ NV_EXTN_OP_HIT_OBJECT_IS_HIT

#define NV_EXTN_OP_HIT_OBJECT_IS_HIT 83

◆ NV_EXTN_OP_HIT_OBJECT_IS_MISS

#define NV_EXTN_OP_HIT_OBJECT_IS_MISS 73

◆ NV_EXTN_OP_HIT_OBJECT_IS_NOP

#define NV_EXTN_OP_HIT_OBJECT_IS_NOP 84

◆ NV_EXTN_OP_HIT_OBJECT_LOAD_LOCAL_ROOT_TABLE_CONSTANT

#define NV_EXTN_OP_HIT_OBJECT_LOAD_LOCAL_ROOT_TABLE_CONSTANT 82

◆ NV_EXTN_OP_HIT_OBJECT_MAKE_HIT

#define NV_EXTN_OP_HIT_OBJECT_MAKE_HIT 68

◆ NV_EXTN_OP_HIT_OBJECT_MAKE_HIT_WITH_RECORD_INDEX

#define NV_EXTN_OP_HIT_OBJECT_MAKE_HIT_WITH_RECORD_INDEX 69

◆ NV_EXTN_OP_HIT_OBJECT_MAKE_MISS

#define NV_EXTN_OP_HIT_OBJECT_MAKE_MISS 70

◆ NV_EXTN_OP_HIT_OBJECT_MAKE_NOP

#define NV_EXTN_OP_HIT_OBJECT_MAKE_NOP 85

◆ NV_EXTN_OP_HIT_OBJECT_REORDER_THREAD

#define NV_EXTN_OP_HIT_OBJECT_REORDER_THREAD 71

◆ NV_EXTN_OP_HIT_OBJECT_TRACE_RAY

#define NV_EXTN_OP_HIT_OBJECT_TRACE_RAY 67

◆ NV_EXTN_OP_MATCH_ANY

#define NV_EXTN_OP_MATCH_ANY 21

◆ NV_EXTN_OP_RT_IS_BACK_FACING

#define NV_EXTN_OP_RT_IS_BACK_FACING 90

◆ NV_EXTN_OP_RT_IS_MICRO_TRIANGLE_HIT

#define NV_EXTN_OP_RT_IS_MICRO_TRIANGLE_HIT 89

◆ NV_EXTN_OP_RT_MICRO_TRIANGLE_BARYCENTRICS

#define NV_EXTN_OP_RT_MICRO_TRIANGLE_BARYCENTRICS 88

◆ NV_EXTN_OP_RT_MICRO_TRIANGLE_OBJECT_POSITIONS

#define NV_EXTN_OP_RT_MICRO_TRIANGLE_OBJECT_POSITIONS 87

◆ NV_EXTN_OP_RT_MICRO_VERTEX_BARYCENTRICS

#define NV_EXTN_OP_RT_MICRO_VERTEX_BARYCENTRICS 92

◆ NV_EXTN_OP_RT_MICRO_VERTEX_OBJECT_POSITION

#define NV_EXTN_OP_RT_MICRO_VERTEX_OBJECT_POSITION 91

◆ NV_EXTN_OP_RT_TRIANGLE_OBJECT_POSITIONS

#define NV_EXTN_OP_RT_TRIANGLE_OBJECT_POSITIONS 86

◆ NV_EXTN_OP_SHFL

#define NV_EXTN_OP_SHFL 1

◆ NV_EXTN_OP_SHFL_DOWN

#define NV_EXTN_OP_SHFL_DOWN 3

◆ NV_EXTN_OP_SHFL_GENERIC

#define NV_EXTN_OP_SHFL_GENERIC 33

◆ NV_EXTN_OP_SHFL_UP

#define NV_EXTN_OP_SHFL_UP 2

◆ NV_EXTN_OP_SHFL_XOR

#define NV_EXTN_OP_SHFL_XOR 4

◆ NV_EXTN_OP_UINT64_ATOMIC

#define NV_EXTN_OP_UINT64_ATOMIC 20

◆ NV_EXTN_OP_VOTE_ALL

#define NV_EXTN_OP_VOTE_ALL 5

◆ NV_EXTN_OP_VOTE_ANY

#define NV_EXTN_OP_VOTE_ANY 6

◆ NV_EXTN_OP_VOTE_BALLOT

#define NV_EXTN_OP_VOTE_BALLOT 7

◆ NV_EXTN_OP_VPRS_EVAL_ATTRIB_AT_SAMPLE

#define NV_EXTN_OP_VPRS_EVAL_ATTRIB_AT_SAMPLE 51

◆ NV_EXTN_OP_VPRS_EVAL_ATTRIB_SNAPPED

#define NV_EXTN_OP_VPRS_EVAL_ATTRIB_SNAPPED 52

◆ NV_EXTN_TEXTURE_1D

#define NV_EXTN_TEXTURE_1D 2

◆ NV_EXTN_TEXTURE_1D_ARRAY

#define NV_EXTN_TEXTURE_1D_ARRAY 3

◆ NV_EXTN_TEXTURE_2D

#define NV_EXTN_TEXTURE_2D 4

◆ NV_EXTN_TEXTURE_2D_ARRAY

#define NV_EXTN_TEXTURE_2D_ARRAY 5

◆ NV_EXTN_TEXTURE_3D

#define NV_EXTN_TEXTURE_3D 6

◆ NV_EXTN_TEXTURE_CUBE

#define NV_EXTN_TEXTURE_CUBE 7

◆ NV_EXTN_TEXTURE_CUBE_ARRAY

#define NV_EXTN_TEXTURE_CUBE_ARRAY 8

◆ NV_SHADER_EXTN_VERSION

#define NV_SHADER_EXTN_VERSION 1

◆ NV_SPECIALOP_FOOTPRINT_SINGLELOD_PRED

#define NV_SPECIALOP_FOOTPRINT_SINGLELOD_PRED 5

◆ NV_SPECIALOP_GLOBAL_TIMER_HI

#define NV_SPECIALOP_GLOBAL_TIMER_HI 10

◆ NV_SPECIALOP_GLOBAL_TIMER_LO

#define NV_SPECIALOP_GLOBAL_TIMER_LO 9

◆ NV_SPECIALOP_THREADLTMASK

#define NV_SPECIALOP_THREADLTMASK 4

◆ NV_WARP_SIZE

#define NV_WARP_SIZE 32

◆ NV_WARP_SIZE_LOG2

#define NV_WARP_SIZE_LOG2 5


  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • v
  • w
Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- _ -

  • __bcount : nvapi_lite_salstart.h
  • __bcount_opt : nvapi_lite_salstart.h
  • __cdecl : nvapi.h
  • __cplusplus : defines.txt
  • __d3d10_1_h__ : defines.txt
  • __d3d10_h__ : defines.txt
  • __d3d11_h__ : defines.txt
  • __deref_bcount : nvapi_lite_salstart.h
  • __deref_bcount_opt : nvapi_lite_salstart.h
  • __deref_ecount : nvapi_lite_salstart.h
  • __deref_ecount_opt : nvapi_lite_salstart.h
  • __deref_inout : nvapi_lite_salstart.h
  • __deref_inout_bcount : nvapi_lite_salstart.h
  • __deref_inout_bcount_full : nvapi_lite_salstart.h
  • __deref_inout_bcount_full_opt : nvapi_lite_salstart.h
  • __deref_inout_bcount_nz : nvapi_lite_salstart.h
  • __deref_inout_bcount_nz_opt : nvapi_lite_salstart.h
  • __deref_inout_bcount_opt : nvapi_lite_salstart.h
  • __deref_inout_bcount_part : nvapi_lite_salstart.h
  • __deref_inout_bcount_part_opt : nvapi_lite_salstart.h
  • __deref_inout_bcount_z : nvapi_lite_salstart.h
  • __deref_inout_bcount_z_opt : nvapi_lite_salstart.h
  • __deref_inout_ecount : nvapi_lite_salstart.h
  • __deref_inout_ecount_full : nvapi_lite_salstart.h
  • __deref_inout_ecount_full_opt : nvapi_lite_salstart.h
  • __deref_inout_ecount_nz : nvapi_lite_salstart.h
  • __deref_inout_ecount_nz_opt : nvapi_lite_salstart.h
  • __deref_inout_ecount_opt : nvapi_lite_salstart.h
  • __deref_inout_ecount_part : nvapi_lite_salstart.h
  • __deref_inout_ecount_part_opt : nvapi_lite_salstart.h
  • __deref_inout_ecount_z : nvapi_lite_salstart.h
  • __deref_inout_ecount_z_opt : nvapi_lite_salstart.h
  • __deref_inout_nz : nvapi_lite_salstart.h
  • __deref_inout_nz_opt : nvapi_lite_salstart.h
  • __deref_inout_opt : nvapi_lite_salstart.h
  • __deref_inout_z : nvapi_lite_salstart.h
  • __deref_inout_z_opt : nvapi_lite_salstart.h
  • __deref_opt_bcount : nvapi_lite_salstart.h
  • __deref_opt_bcount_opt : nvapi_lite_salstart.h
  • __deref_opt_ecount : nvapi_lite_salstart.h
  • __deref_opt_ecount_opt : nvapi_lite_salstart.h
  • __deref_opt_inout : nvapi_lite_salstart.h
  • __deref_opt_inout_bcount : nvapi_lite_salstart.h
  • __deref_opt_inout_bcount_full : nvapi_lite_salstart.h
  • __deref_opt_inout_bcount_full_opt : nvapi_lite_salstart.h
  • __deref_opt_inout_bcount_nz : nvapi_lite_salstart.h
  • __deref_opt_inout_bcount_nz_opt : nvapi_lite_salstart.h
  • __deref_opt_inout_bcount_opt : nvapi_lite_salstart.h
  • __deref_opt_inout_bcount_part : nvapi_lite_salstart.h
  • __deref_opt_inout_bcount_part_opt : nvapi_lite_salstart.h
  • __deref_opt_inout_bcount_z : nvapi_lite_salstart.h
  • __deref_opt_inout_bcount_z_opt : nvapi_lite_salstart.h
  • __deref_opt_inout_ecount : nvapi_lite_salstart.h
  • __deref_opt_inout_ecount_full : nvapi_lite_salstart.h
  • __deref_opt_inout_ecount_full_opt : nvapi_lite_salstart.h
  • __deref_opt_inout_ecount_nz : nvapi_lite_salstart.h
  • __deref_opt_inout_ecount_nz_opt : nvapi_lite_salstart.h
  • __deref_opt_inout_ecount_opt : nvapi_lite_salstart.h
  • __deref_opt_inout_ecount_part : nvapi_lite_salstart.h
  • __deref_opt_inout_ecount_part_opt : nvapi_lite_salstart.h
  • __deref_opt_inout_ecount_z : nvapi_lite_salstart.h
  • __deref_opt_inout_ecount_z_opt : nvapi_lite_salstart.h
  • __deref_opt_inout_nz : nvapi_lite_salstart.h
  • __deref_opt_inout_nz_opt : nvapi_lite_salstart.h
  • __deref_opt_inout_opt : nvapi_lite_salstart.h
  • __deref_opt_inout_z : nvapi_lite_salstart.h
  • __deref_opt_inout_z_opt : nvapi_lite_salstart.h
  • __deref_opt_out : nvapi_lite_salstart.h
  • __deref_opt_out_bcount : nvapi_lite_salstart.h
  • __deref_opt_out_bcount_full : nvapi_lite_salstart.h
  • __deref_opt_out_bcount_full_opt : nvapi_lite_salstart.h
  • __deref_opt_out_bcount_nz_opt : nvapi_lite_salstart.h
  • __deref_opt_out_bcount_opt : nvapi_lite_salstart.h
  • __deref_opt_out_bcount_part : nvapi_lite_salstart.h
  • __deref_opt_out_bcount_part_opt : nvapi_lite_salstart.h
  • __deref_opt_out_bcount_z_opt : nvapi_lite_salstart.h
  • __deref_opt_out_ecount : nvapi_lite_salstart.h
  • __deref_opt_out_ecount_full : nvapi_lite_salstart.h
  • __deref_opt_out_ecount_full_opt : nvapi_lite_salstart.h
  • __deref_opt_out_ecount_nz_opt : nvapi_lite_salstart.h
  • __deref_opt_out_ecount_opt : nvapi_lite_salstart.h
  • __deref_opt_out_ecount_part : nvapi_lite_salstart.h
  • __deref_opt_out_ecount_part_opt : nvapi_lite_salstart.h
  • __deref_opt_out_ecount_z_opt : nvapi_lite_salstart.h
  • __deref_opt_out_nz_opt : nvapi_lite_salstart.h
  • __deref_opt_out_opt : nvapi_lite_salstart.h
  • __deref_opt_out_z : nvapi_lite_salstart.h
  • __deref_opt_out_z_opt : nvapi_lite_salstart.h
  • __deref_out : nvapi_lite_salstart.h
  • __deref_out_bcount : nvapi_lite_salstart.h
  • __deref_out_bcount_full : nvapi_lite_salstart.h
  • __deref_out_bcount_full_opt : nvapi_lite_salstart.h
  • __deref_out_bcount_nz : nvapi_lite_salstart.h
  • __deref_out_bcount_nz_opt : nvapi_lite_salstart.h
  • __deref_out_bcount_opt : nvapi_lite_salstart.h
  • __deref_out_bcount_part : nvapi_lite_salstart.h
  • __deref_out_bcount_part_opt : nvapi_lite_salstart.h
  • __deref_out_bcount_z : nvapi_lite_salstart.h
  • __deref_out_bcount_z_opt : nvapi_lite_salstart.h
  • __deref_out_ecount : nvapi_lite_salstart.h
  • __deref_out_ecount_full : nvapi_lite_salstart.h
  • __deref_out_ecount_full_opt : nvapi_lite_salstart.h
  • __deref_out_ecount_nz : nvapi_lite_salstart.h
  • __deref_out_ecount_nz_opt : nvapi_lite_salstart.h
  • __deref_out_ecount_opt : nvapi_lite_salstart.h
  • __deref_out_ecount_part : nvapi_lite_salstart.h
  • __deref_out_ecount_part_opt : nvapi_lite_salstart.h
  • __deref_out_ecount_z : nvapi_lite_salstart.h
  • __deref_out_ecount_z_opt : nvapi_lite_salstart.h
  • __deref_out_nz : nvapi_lite_salstart.h
  • __deref_out_nz_opt : nvapi_lite_salstart.h
  • __deref_out_opt : nvapi_lite_salstart.h
  • __deref_out_z : nvapi_lite_salstart.h
  • __deref_out_z_opt : nvapi_lite_salstart.h
  • __ecount : nvapi_lite_salstart.h
  • __ecount_opt : nvapi_lite_salstart.h
  • __fp32x2Tofp16x2() : nvHLSLExtnsInternal.h
  • __fp32x4Tofp16x4() : nvHLSLExtnsInternal.h
  • __in : nvapi_lite_salstart.h
  • __in_bcount : nvapi_lite_salstart.h
  • __in_bcount_nz : nvapi_lite_salstart.h
  • __in_bcount_nz_opt : nvapi_lite_salstart.h
  • __in_bcount_opt : nvapi_lite_salstart.h
  • __in_bcount_z : nvapi_lite_salstart.h
  • __in_bcount_z_opt : nvapi_lite_salstart.h
  • __in_ecount : nvapi_lite_salstart.h
  • __in_ecount_nz : nvapi_lite_salstart.h
  • __in_ecount_nz_opt : nvapi_lite_salstart.h
  • __in_ecount_opt : nvapi_lite_salstart.h
  • __in_ecount_z : nvapi_lite_salstart.h
  • __in_ecount_z_opt : nvapi_lite_salstart.h
  • __in_nz : nvapi_lite_salstart.h
  • __in_nz_opt : nvapi_lite_salstart.h
  • __in_opt : nvapi_lite_salstart.h
  • __in_z : nvapi_lite_salstart.h
  • __in_z_opt : nvapi_lite_salstart.h
  • __inout : nvapi_lite_salstart.h
  • __inout_bcount : nvapi_lite_salstart.h
  • __inout_bcount_full : nvapi_lite_salstart.h
  • __inout_bcount_full_opt : nvapi_lite_salstart.h
  • __inout_bcount_nz : nvapi_lite_salstart.h
  • __inout_bcount_nz_opt : nvapi_lite_salstart.h
  • __inout_bcount_opt : nvapi_lite_salstart.h
  • __inout_bcount_part : nvapi_lite_salstart.h
  • __inout_bcount_part_opt : nvapi_lite_salstart.h
  • __inout_bcount_z : nvapi_lite_salstart.h
  • __inout_bcount_z_opt : nvapi_lite_salstart.h
  • __inout_ecount : nvapi_lite_salstart.h
  • __inout_ecount_full : nvapi_lite_salstart.h
  • __inout_ecount_full_opt : nvapi_lite_salstart.h
  • __inout_ecount_nz : nvapi_lite_salstart.h
  • __inout_ecount_nz_opt : nvapi_lite_salstart.h
  • __inout_ecount_opt : nvapi_lite_salstart.h
  • __inout_ecount_part : nvapi_lite_salstart.h
  • __inout_ecount_part_opt : nvapi_lite_salstart.h
  • __inout_ecount_z : nvapi_lite_salstart.h
  • __inout_ecount_z_opt : nvapi_lite_salstart.h
  • __inout_nz : nvapi_lite_salstart.h
  • __inout_nz_opt : nvapi_lite_salstart.h
  • __inout_opt : nvapi_lite_salstart.h
  • __inout_z : nvapi_lite_salstart.h
  • __inout_z_opt : nvapi_lite_salstart.h
  • __nvapi__Post_writable_byte_size_ : nvapi_lite_salstart.h
  • __nvapi__Ret_notnull_ : nvapi_lite_salstart.h
  • __nvapi_deprecated_datatype : nvapi_lite_common.h
  • __nvapi_deprecated_function : nvapi_lite_common.h, nvapi.h, nvapi_lite_common.h
  • __nvapi_Outptr_ : nvapi_lite_salstart.h
  • __nvapi_success : nvapi_lite_salstart.h
  • __nvapi_undef__bcount : nvapi_lite_salstart.h
  • __nvapi_undef__bcount_opt : nvapi_lite_salstart.h
  • __nvapi_undef__deref_bcount : nvapi_lite_salstart.h
  • __nvapi_undef__deref_bcount_opt : nvapi_lite_salstart.h
  • __nvapi_undef__deref_ecount : nvapi_lite_salstart.h
  • __nvapi_undef__deref_ecount_opt : nvapi_lite_salstart.h
  • __nvapi_undef__deref_inout : nvapi_lite_salstart.h
  • __nvapi_undef__deref_inout_bcount : nvapi_lite_salstart.h
  • __nvapi_undef__deref_inout_bcount_full : nvapi_lite_salstart.h
  • __nvapi_undef__deref_inout_bcount_full_opt : nvapi_lite_salstart.h
  • __nvapi_undef__deref_inout_bcount_nz : nvapi_lite_salstart.h
  • __nvapi_undef__deref_inout_bcount_nz_opt : nvapi_lite_salstart.h
  • __nvapi_undef__deref_inout_bcount_opt : nvapi_lite_salstart.h
  • __nvapi_undef__deref_inout_bcount_part : nvapi_lite_salstart.h
  • __nvapi_undef__deref_inout_bcount_part_opt : nvapi_lite_salstart.h
  • __nvapi_undef__deref_inout_bcount_z : nvapi_lite_salstart.h
  • __nvapi_undef__deref_inout_bcount_z_opt : nvapi_lite_salstart.h
  • __nvapi_undef__deref_inout_ecount : nvapi_lite_salstart.h
  • __nvapi_undef__deref_inout_ecount_full : nvapi_lite_salstart.h
  • __nvapi_undef__deref_inout_ecount_full_opt : nvapi_lite_salstart.h
  • __nvapi_undef__deref_inout_ecount_nz : nvapi_lite_salstart.h
  • __nvapi_undef__deref_inout_ecount_nz_opt : nvapi_lite_salstart.h
  • __nvapi_undef__deref_inout_ecount_opt : nvapi_lite_salstart.h
  • __nvapi_undef__deref_inout_ecount_part : nvapi_lite_salstart.h
  • __nvapi_undef__deref_inout_ecount_part_opt : nvapi_lite_salstart.h
  • __nvapi_undef__deref_inout_ecount_z : nvapi_lite_salstart.h
  • __nvapi_undef__deref_inout_ecount_z_opt : nvapi_lite_salstart.h
  • __nvapi_undef__deref_inout_nz : nvapi_lite_salstart.h
  • __nvapi_undef__deref_inout_nz_opt : nvapi_lite_salstart.h
  • __nvapi_undef__deref_inout_opt : nvapi_lite_salstart.h
  • __nvapi_undef__deref_inout_z : nvapi_lite_salstart.h
  • __nvapi_undef__deref_inout_z_opt : nvapi_lite_salstart.h
  • __nvapi_undef__deref_opt_bcount : nvapi_lite_salstart.h
  • __nvapi_undef__deref_opt_bcount_opt : nvapi_lite_salstart.h
  • __nvapi_undef__deref_opt_ecount : nvapi_lite_salstart.h
  • __nvapi_undef__deref_opt_ecount_opt : nvapi_lite_salstart.h
  • __nvapi_undef__deref_opt_inout : nvapi_lite_salstart.h
  • __nvapi_undef__deref_opt_inout_bcount : nvapi_lite_salstart.h
  • __nvapi_undef__deref_opt_inout_bcount_full : nvapi_lite_salstart.h
  • __nvapi_undef__deref_opt_inout_bcount_full_opt : nvapi_lite_salstart.h
  • __nvapi_undef__deref_opt_inout_bcount_nz : nvapi_lite_salstart.h
  • __nvapi_undef__deref_opt_inout_bcount_nz_opt : nvapi_lite_salstart.h
  • __nvapi_undef__deref_opt_inout_bcount_opt : nvapi_lite_salstart.h
  • __nvapi_undef__deref_opt_inout_bcount_part : nvapi_lite_salstart.h
  • __nvapi_undef__deref_opt_inout_bcount_part_opt : nvapi_lite_salstart.h
  • __nvapi_undef__deref_opt_inout_bcount_z : nvapi_lite_salstart.h
  • __nvapi_undef__deref_opt_inout_bcount_z_opt : nvapi_lite_salstart.h
  • __nvapi_undef__deref_opt_inout_ecount : nvapi_lite_salstart.h
  • __nvapi_undef__deref_opt_inout_ecount_full : nvapi_lite_salstart.h
  • __nvapi_undef__deref_opt_inout_ecount_full_opt : nvapi_lite_salstart.h
  • __nvapi_undef__deref_opt_inout_ecount_nz : nvapi_lite_salstart.h
  • __nvapi_undef__deref_opt_inout_ecount_nz_opt : nvapi_lite_salstart.h
  • __nvapi_undef__deref_opt_inout_ecount_opt : nvapi_lite_salstart.h
  • __nvapi_undef__deref_opt_inout_ecount_part : nvapi_lite_salstart.h
  • __nvapi_undef__deref_opt_inout_ecount_part_opt : nvapi_lite_salstart.h
  • __nvapi_undef__deref_opt_inout_ecount_z : nvapi_lite_salstart.h
  • __nvapi_undef__deref_opt_inout_ecount_z_opt : nvapi_lite_salstart.h
  • __nvapi_undef__deref_opt_inout_nz : nvapi_lite_salstart.h
  • __nvapi_undef__deref_opt_inout_nz_opt : nvapi_lite_salstart.h
  • __nvapi_undef__deref_opt_inout_opt : nvapi_lite_salstart.h
  • __nvapi_undef__deref_opt_inout_z : nvapi_lite_salstart.h
  • __nvapi_undef__deref_opt_inout_z_opt : nvapi_lite_salstart.h
  • __nvapi_undef__deref_opt_out : nvapi_lite_salstart.h
  • __nvapi_undef__deref_opt_out_bcount : nvapi_lite_salstart.h
  • __nvapi_undef__deref_opt_out_bcount_full : nvapi_lite_salstart.h
  • __nvapi_undef__deref_opt_out_bcount_full_opt : nvapi_lite_salstart.h
  • __nvapi_undef__deref_opt_out_bcount_nz_opt : nvapi_lite_salstart.h
  • __nvapi_undef__deref_opt_out_bcount_opt : nvapi_lite_salstart.h
  • __nvapi_undef__deref_opt_out_bcount_part : nvapi_lite_salstart.h
  • __nvapi_undef__deref_opt_out_bcount_part_opt : nvapi_lite_salstart.h
  • __nvapi_undef__deref_opt_out_bcount_z_opt : nvapi_lite_salstart.h
  • __nvapi_undef__deref_opt_out_ecount : nvapi_lite_salstart.h
  • __nvapi_undef__deref_opt_out_ecount_full : nvapi_lite_salstart.h
  • __nvapi_undef__deref_opt_out_ecount_full_opt : nvapi_lite_salstart.h
  • __nvapi_undef__deref_opt_out_ecount_nz_opt : nvapi_lite_salstart.h
  • __nvapi_undef__deref_opt_out_ecount_opt : nvapi_lite_salstart.h
  • __nvapi_undef__deref_opt_out_ecount_part : nvapi_lite_salstart.h
  • __nvapi_undef__deref_opt_out_ecount_part_opt : nvapi_lite_salstart.h
  • __nvapi_undef__deref_opt_out_ecount_z_opt : nvapi_lite_salstart.h
  • __nvapi_undef__deref_opt_out_nz_opt : nvapi_lite_salstart.h
  • __nvapi_undef__deref_opt_out_opt : nvapi_lite_salstart.h
  • __nvapi_undef__deref_opt_out_z : nvapi_lite_salstart.h
  • __nvapi_undef__deref_opt_out_z_opt : nvapi_lite_salstart.h
  • __nvapi_undef__deref_out : nvapi_lite_salstart.h
  • __nvapi_undef__deref_out_bcount : nvapi_lite_salstart.h
  • __nvapi_undef__deref_out_bcount_full : nvapi_lite_salstart.h
  • __nvapi_undef__deref_out_bcount_full_opt : nvapi_lite_salstart.h
  • __nvapi_undef__deref_out_bcount_nz : nvapi_lite_salstart.h
  • __nvapi_undef__deref_out_bcount_nz_opt : nvapi_lite_salstart.h
  • __nvapi_undef__deref_out_bcount_opt : nvapi_lite_salstart.h
  • __nvapi_undef__deref_out_bcount_part : nvapi_lite_salstart.h
  • __nvapi_undef__deref_out_bcount_part_opt : nvapi_lite_salstart.h
  • __nvapi_undef__deref_out_bcount_z : nvapi_lite_salstart.h
  • __nvapi_undef__deref_out_bcount_z_opt : nvapi_lite_salstart.h
  • __nvapi_undef__deref_out_ecount : nvapi_lite_salstart.h
  • __nvapi_undef__deref_out_ecount_full : nvapi_lite_salstart.h
  • __nvapi_undef__deref_out_ecount_full_opt : nvapi_lite_salstart.h
  • __nvapi_undef__deref_out_ecount_nz : nvapi_lite_salstart.h
  • __nvapi_undef__deref_out_ecount_nz_opt : nvapi_lite_salstart.h
  • __nvapi_undef__deref_out_ecount_opt : nvapi_lite_salstart.h
  • __nvapi_undef__deref_out_ecount_part : nvapi_lite_salstart.h
  • __nvapi_undef__deref_out_ecount_part_opt : nvapi_lite_salstart.h
  • __nvapi_undef__deref_out_ecount_z : nvapi_lite_salstart.h
  • __nvapi_undef__deref_out_ecount_z_opt : nvapi_lite_salstart.h
  • __nvapi_undef__deref_out_nz : nvapi_lite_salstart.h
  • __nvapi_undef__deref_out_nz_opt : nvapi_lite_salstart.h
  • __nvapi_undef__deref_out_opt : nvapi_lite_salstart.h
  • __nvapi_undef__deref_out_z : nvapi_lite_salstart.h
  • __nvapi_undef__deref_out_z_opt : nvapi_lite_salstart.h
  • __nvapi_undef__ecount : nvapi_lite_salstart.h
  • __nvapi_undef__ecount_opt : nvapi_lite_salstart.h
  • __nvapi_undef__in : nvapi_lite_salstart.h
  • __nvapi_undef__in_bcount : nvapi_lite_salstart.h
  • __nvapi_undef__in_bcount_nz : nvapi_lite_salstart.h
  • __nvapi_undef__in_bcount_nz_opt : nvapi_lite_salstart.h
  • __nvapi_undef__in_bcount_opt : nvapi_lite_salstart.h
  • __nvapi_undef__in_bcount_z : nvapi_lite_salstart.h
  • __nvapi_undef__in_bcount_z_opt : nvapi_lite_salstart.h
  • __nvapi_undef__in_ecount : nvapi_lite_salstart.h
  • __nvapi_undef__in_ecount_nz : nvapi_lite_salstart.h
  • __nvapi_undef__in_ecount_nz_opt : nvapi_lite_salstart.h
  • __nvapi_undef__in_ecount_opt : nvapi_lite_salstart.h
  • __nvapi_undef__in_ecount_z : nvapi_lite_salstart.h
  • __nvapi_undef__in_ecount_z_opt : nvapi_lite_salstart.h
  • __nvapi_undef__in_nz : nvapi_lite_salstart.h
  • __nvapi_undef__in_nz_opt : nvapi_lite_salstart.h
  • __nvapi_undef__in_opt : nvapi_lite_salstart.h
  • __nvapi_undef__in_z : nvapi_lite_salstart.h
  • __nvapi_undef__in_z_opt : nvapi_lite_salstart.h
  • __nvapi_undef__inout : nvapi_lite_salstart.h
  • __nvapi_undef__inout_bcount : nvapi_lite_salstart.h
  • __nvapi_undef__inout_bcount_full : nvapi_lite_salstart.h
  • __nvapi_undef__inout_bcount_full_opt : nvapi_lite_salstart.h
  • __nvapi_undef__inout_bcount_nz : nvapi_lite_salstart.h
  • __nvapi_undef__inout_bcount_nz_opt : nvapi_lite_salstart.h
  • __nvapi_undef__inout_bcount_opt : nvapi_lite_salstart.h
  • __nvapi_undef__inout_bcount_part : nvapi_lite_salstart.h
  • __nvapi_undef__inout_bcount_part_opt : nvapi_lite_salstart.h
  • __nvapi_undef__inout_bcount_z : nvapi_lite_salstart.h
  • __nvapi_undef__inout_bcount_z_opt : nvapi_lite_salstart.h
  • __nvapi_undef__inout_ecount : nvapi_lite_salstart.h
  • __nvapi_undef__inout_ecount_full : nvapi_lite_salstart.h
  • __nvapi_undef__inout_ecount_full_opt : nvapi_lite_salstart.h
  • __nvapi_undef__inout_ecount_nz : nvapi_lite_salstart.h
  • __nvapi_undef__inout_ecount_nz_opt : nvapi_lite_salstart.h
  • __nvapi_undef__inout_ecount_opt : nvapi_lite_salstart.h
  • __nvapi_undef__inout_ecount_part : nvapi_lite_salstart.h
  • __nvapi_undef__inout_ecount_part_opt : nvapi_lite_salstart.h
  • __nvapi_undef__inout_ecount_z : nvapi_lite_salstart.h
  • __nvapi_undef__inout_ecount_z_opt : nvapi_lite_salstart.h
  • __nvapi_undef__inout_nz : nvapi_lite_salstart.h
  • __nvapi_undef__inout_nz_opt : nvapi_lite_salstart.h
  • __nvapi_undef__inout_opt : nvapi_lite_salstart.h
  • __nvapi_undef__inout_z : nvapi_lite_salstart.h
  • __nvapi_undef__inout_z_opt : nvapi_lite_salstart.h
  • __nvapi_undef__out : nvapi_lite_salstart.h
  • __nvapi_undef__out_bcount : nvapi_lite_salstart.h
  • __nvapi_undef__out_bcount_full : nvapi_lite_salstart.h
  • __nvapi_undef__out_bcount_full_opt : nvapi_lite_salstart.h
  • __nvapi_undef__out_bcount_full_z : nvapi_lite_salstart.h
  • __nvapi_undef__out_bcount_full_z_opt : nvapi_lite_salstart.h
  • __nvapi_undef__out_bcount_nz : nvapi_lite_salstart.h
  • __nvapi_undef__out_bcount_nz_opt : nvapi_lite_salstart.h
  • __nvapi_undef__out_bcount_opt : nvapi_lite_salstart.h
  • __nvapi_undef__out_bcount_part : nvapi_lite_salstart.h
  • __nvapi_undef__out_bcount_part_opt : nvapi_lite_salstart.h
  • __nvapi_undef__out_bcount_part_z : nvapi_lite_salstart.h
  • __nvapi_undef__out_bcount_part_z_opt : nvapi_lite_salstart.h
  • __nvapi_undef__out_bcount_z : nvapi_lite_salstart.h
  • __nvapi_undef__out_bcount_z_opt : nvapi_lite_salstart.h
  • __nvapi_undef__out_ecount : nvapi_lite_salstart.h
  • __nvapi_undef__out_ecount_full : nvapi_lite_salstart.h
  • __nvapi_undef__out_ecount_full_opt : nvapi_lite_salstart.h
  • __nvapi_undef__out_ecount_full_z : nvapi_lite_salstart.h
  • __nvapi_undef__out_ecount_full_z_opt : nvapi_lite_salstart.h
  • __nvapi_undef__out_ecount_nz : nvapi_lite_salstart.h
  • __nvapi_undef__out_ecount_nz_opt : nvapi_lite_salstart.h
  • __nvapi_undef__out_ecount_opt : nvapi_lite_salstart.h
  • __nvapi_undef__out_ecount_part : nvapi_lite_salstart.h
  • __nvapi_undef__out_ecount_part_opt : nvapi_lite_salstart.h
  • __nvapi_undef__out_ecount_part_z : nvapi_lite_salstart.h
  • __nvapi_undef__out_ecount_part_z_opt : nvapi_lite_salstart.h
  • __nvapi_undef__out_ecount_z : nvapi_lite_salstart.h
  • __nvapi_undef__out_ecount_z_opt : nvapi_lite_salstart.h
  • __nvapi_undef__out_nz : nvapi_lite_salstart.h
  • __nvapi_undef__out_nz_opt : nvapi_lite_salstart.h
  • __nvapi_undef__out_opt : nvapi_lite_salstart.h
  • __nvapi_undef__out_z : nvapi_lite_salstart.h
  • __nvapi_undef__out_z_opt : nvapi_lite_salstart.h
  • __NvAtomicAddFP32() : nvHLSLExtnsInternal.h
  • __NvAtomicCompareExchangeUINT64() : nvHLSLExtnsInternal.h
  • __NvAtomicOpFP16x2() : nvHLSLExtnsInternal.h
  • __NvAtomicOpUINT64() : nvHLSLExtnsInternal.h
  • __NvFootprint() : nvHLSLExtnsInternal.h
  • __NvFootprintBias() : nvHLSLExtnsInternal.h
  • __NvFootprintGrad() : nvHLSLExtnsInternal.h
  • __NvFootprintLevel() : nvHLSLExtnsInternal.h
  • __NvGetShflMaskFromWidth() : nvHLSLExtnsInternal.h
  • __NvGetSpecial() : nvHLSLExtnsInternal.h
  • __NvReferenceUAVForOp() : nvHLSLExtnsInternal.h
  • __NvShflGeneric() : nvHLSLExtnsInternal.h
  • __out : nvapi_lite_salstart.h
  • __out_bcount : nvapi_lite_salstart.h
  • __out_bcount_full : nvapi_lite_salstart.h
  • __out_bcount_full_opt : nvapi_lite_salstart.h
  • __out_bcount_full_z : nvapi_lite_salstart.h
  • __out_bcount_full_z_opt : nvapi_lite_salstart.h
  • __out_bcount_nz : nvapi_lite_salstart.h
  • __out_bcount_nz_opt : nvapi_lite_salstart.h
  • __out_bcount_opt : nvapi_lite_salstart.h
  • __out_bcount_part : nvapi_lite_salstart.h
  • __out_bcount_part_opt : nvapi_lite_salstart.h
  • __out_bcount_part_z : nvapi_lite_salstart.h
  • __out_bcount_part_z_opt : nvapi_lite_salstart.h
  • __out_bcount_z : nvapi_lite_salstart.h
  • __out_bcount_z_opt : nvapi_lite_salstart.h
  • __out_ecount : nvapi_lite_salstart.h
  • __out_ecount_full : nvapi_lite_salstart.h
  • __out_ecount_full_opt : nvapi_lite_salstart.h
  • __out_ecount_full_z : nvapi_lite_salstart.h
  • __out_ecount_full_z_opt : nvapi_lite_salstart.h
  • __out_ecount_nz : nvapi_lite_salstart.h
  • __out_ecount_nz_opt : nvapi_lite_salstart.h
  • __out_ecount_opt : nvapi_lite_salstart.h
  • __out_ecount_part : nvapi_lite_salstart.h
  • __out_ecount_part_opt : nvapi_lite_salstart.h
  • __out_ecount_part_z : nvapi_lite_salstart.h
  • __out_ecount_part_z_opt : nvapi_lite_salstart.h
  • __out_ecount_z : nvapi_lite_salstart.h
  • __out_ecount_z_opt : nvapi_lite_salstart.h
  • __out_nz : nvapi_lite_salstart.h
  • __out_nz_opt : nvapi_lite_salstart.h
  • __out_opt : nvapi_lite_salstart.h
  • __out_z : nvapi_lite_salstart.h
  • __out_z_opt : nvapi_lite_salstart.h
  • __success : nvapi_lite_salstart.h
  • _D3D9_H_ : defines.txt
  • _IMPLICIT_SLI_CONTROL : nvapi.h
  • _NV_ADAPTER_TYPE : nvapi.h
  • _NV_BPC : nvapi.h
  • _NV_COLOR_SELECTION_POLICY : nvapi.h
  • _NV_COLORSPACE_TYPE : nvapi.h
  • _NV_COMPUTE_SHADER_DERIVATIVES : nvapi.h
  • _NV_D3D11_FEATURE : nvapi.h
  • _NV_D3D12_WORKSTATION_FEATURE_TYPE : nvapi.h
  • _NV_DESKTOP_COLOR_DEPTH : nvapi.h
  • _NV_DISPLAY_OUTPUT_MODE : nvapi.h
  • _NV_DISPLAY_TV_FORMAT : nvapi.h
  • _NV_DISPLAYCONFIG_FLAGS : nvapi.h
  • _NV_DISPLAYCONFIG_PATH_INFO_V2 : nvapi.h
  • _NV_DISPLAYCONFIG_SPANNING_ORIENTATION : nvapi.h
  • _NV_DP_BPC : nvapi.h
  • _NV_DP_COLOR_FORMAT : nvapi.h
  • _NV_DP_COLORIMETRY : nvapi.h
  • _NV_DP_DYNAMIC_RANGE : nvapi.h
  • _NV_DP_LANE_COUNT : nvapi.h
  • _NV_DP_LINK_RATE : nvapi.h
  • _NV_DYNAMIC_RANGE : nvapi.h
  • _NV_ECC_CONFIGURATION : nvapi.h
  • _NV_FASTGS_FLAGS : nvapi.h
  • _NV_FORMAT : nvapi.h
  • _NV_FOVEATED_RENDERING_FOVEATION_PATTERN_PRESET : nvapi.h
  • _NV_FOVEATED_RENDERING_SHADING_RATE_PRESET : nvapi.h
  • _NV_FrustumAdjustMode : nvapi.h
  • _NV_GAZE_DATA_TYPE : nvapi.h
  • _NV_GAZE_DATA_VALIDITY_FLAGS : nvapi.h
  • _NV_GPU_ARCH_IMPLEMENTATION_ID : nvapi.h
  • _NV_GPU_ARCHITECTURE_ID : nvapi.h
  • _NV_GPU_BUS_TYPE : nvapi.h
  • _NV_GPU_CHIP_REVISION : nvapi.h
  • _NV_GPU_CLIENT_UTIL_DOMAIN_ID : nvapi.h
  • _NV_GPU_CONNECTOR_TYPE : nvapi.h
  • _NV_GPU_HDCP_FUSE_STATE : nvapi.h
  • _NV_GPU_HDCP_KEY_SOURCE : nvapi.h
  • _NV_GPU_HDCP_KEY_SOURCE_STATE : nvapi.h
  • _NV_GPU_ILLUMINATION_ATTRIB : nvapi.h
  • _NV_GPU_OUTPUT_TYPE : nvapi.h
  • _NV_GPU_PERF_PSTATE_ID : nvapi.h
  • _NV_GPU_PERF_VOLTAGE_INFO_DOMAIN_ID : nvapi.h
  • _NV_GPU_PUBLIC_CLOCK_ID : nvapi.h
  • _NV_GPU_TYPE : nvapi.h
  • _NV_GPU_WORKSTATION_FEATURE_TYPE : nvapi.h
  • _NV_HDR_TONEMAPPING_METHOD : nvapi.h
  • _NV_LICENSE_FEATURE_TYPE : nvapi.h
  • _NV_PIXEL_SHIFT_TYPE : nvapi.h
  • _NV_PRESENT_BARRIER_SYNC_MODE : nvapi.h
  • _NV_PSO_EXTENSION : nvapi.h
  • _NV_RESOLVE_MODE : nvapi.h
  • _NV_ROTATE : nvapi.h
  • _NV_SCALING : nvapi.h
  • _NV_SMP_ASSIST_EYE_INDEX : nvapi.h
  • _NV_SRRV_DIMENSION : nvapi.h
  • _NV_STEREO_VIDEO_FORMAT : nvapi.h
  • _NV_StereoActiveEye : nvapi_lite_stereo.h
  • _NV_StereoDriverMode : nvapi_lite_stereo.h
  • _NV_StereoRegistryID : nvapi.h
  • _NV_StereoRegistryProfileType : nvapi.h
  • _NV_StereoSwapChainMode : nvapi.h
  • _NV_SWIZZLE_MODE : nvapi.h
  • _NV_SWIZZLE_OFFSET : nvapi.h
  • _NV_TARGET_VIEW_MODE : nvapi.h
  • _NV_TARGET_VIEW_MODE_ : nvapi.h
  • _NV_TIMING_OVERRIDE : nvapi.h
  • _NV_VIRTUALIZATION_MODE : nvapi.h
  • _NV_VRS_CONTENT_TYPE : nvapi.h
  • _NV_VRS_RENDER_MODE : nvapi.h
  • _NVAPI_ANSEL_FEATURE : nvapi.h
  • _NVAPI_ANSEL_FEATURE_STATE : nvapi.h
  • _NVAPI_ANSEL_HOTKEY_MODIFIER : nvapi.h
  • _NVAPI_D3D11_INSERTWFI_FLAG : nvapi.h
  • _NVAPI_D3D12_GET_CUDA_INDEPENDENT_DESCRIPTOR_OBJECT_TYPE : nvapi.h
  • _NVAPI_D3D12_PIPELINE_CREATION_STATE_FLAGS : nvapi.h
  • _NVAPI_D3D12_RAYTRACING_ACCELERATION_STRUCTURE_BUILD_FLAGS_EX : nvapi.h
  • _NVAPI_D3D12_RAYTRACING_CAPS_TYPE : nvapi.h
  • _NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_BUILD_FLAGS : nvapi.h
  • _NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_POSTBUILD_INFO_TYPE : nvapi.h
  • _NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_CAPS : nvapi.h
  • _NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_FORMAT : nvapi.h
  • _NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_PRIMITIVE_FLAGS : nvapi.h
  • _NVAPI_D3D12_RAYTRACING_GEOMETRY_TYPE_EX : nvapi.h
  • _NVAPI_D3D12_RAYTRACING_INSTANCE_FLAGS_EX : nvapi.h
  • _NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_ARRAY_BUILD_FLAGS : nvapi.h
  • _NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_ARRAY_POSTBUILD_INFO_TYPE : nvapi.h
  • _NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_CAPS : nvapi.h
  • _NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_FORMAT : nvapi.h
  • _NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_SPECIAL_INDEX : nvapi.h
  • _NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_STATE : nvapi.h
  • _NVAPI_D3D12_RAYTRACING_THREAD_REORDERING_CAPS : nvapi.h
  • _NVAPI_D3D12_RAYTRACING_VALIDATION_FLAGS : nvapi.h
  • _NVAPI_D3D12_RAYTRACING_VALIDATION_MESSAGE_SEVERITY : nvapi.h
  • _NVAPI_D3D12_SERIALIZED_DATA_TYPE_EX : nvapi.h
  • _NVAPI_D3D_RESOURCERENDERING_FLAG : nvapi_lite_sli.h
  • _NVAPI_D3D_SETRESOURCEHINT_CATEGORY : nvapi_lite_sli.h
  • _NVAPI_D3D_SETRESOURCEHINT_SLI : nvapi_lite_sli.h
  • _NVAPI_GPU_PERF_DECREASE : nvapi.h
  • _NVAPI_GSYNC_DELAY_TYPE : nvapi.h
  • _NVAPI_GSYNC_DISPLAY_SYNC_STATE : nvapi.h
  • _NVAPI_GSYNC_GPU_TOPOLOGY_CONNECTOR : nvapi.h
  • _NVAPI_GSYNC_MULTIPLY_DIVIDE_MODE : nvapi.h
  • _NVAPI_GSYNC_POLARITY : nvapi.h
  • _NVAPI_GSYNC_RJ45_IO : nvapi.h
  • _NVAPI_GSYNC_SYNC_SOURCE : nvapi.h
  • _NVAPI_GSYNC_VIDEO_MODE : nvapi.h
  • _NVAPI_H : nvapi.h
  • _NVAPI_NVLINK_DEVICE_INFO_DEVICE_TYPE : nvapi.h
  • _NVAPI_NVLINK_STATUS_LINK_STATE : nvapi.h
  • _NVAPI_NVLINK_STATUS_SUBLINK_RX_STATE : nvapi.h
  • _NVAPI_NVLINK_STATUS_SUBLINK_TX_STATE : nvapi.h
  • _NVAPI_RAY_FLAGS_EX : nvapi.h
  • _NvAPI_Status : nvapi_lite_common.h
  • _NVAPI_STEREO_INIT_ACTIVATION_FLAGS : nvapi.h
  • _NVAPI_STEREO_SURFACECREATEMODE : nvapi_lite_stereo.h
  • _NVDRS_SETTING_LOCATION : nvapi.h
  • _NVDRS_SETTING_TYPE : nvapi.h
  • _NVVIOANCPARITYCOMPUTATION : nvapi.h
  • _NVVIOBITSPERCOMPONENT : nvapi.h
  • _NVVIOCAPTURESTATUS : nvapi.h
  • _NVVIOCOLORSPACE : nvapi.h
  • _NVVIOCOMPONENTSAMPLING : nvapi.h
  • _NVVIOCOMPSYNCTYPE : nvapi.h
  • _NVVIOCONFIGTYPE : nvapi.h
  • _NVVIODATAFORMAT : nvapi.h
  • _NVVIOINPUTOUTPUTSTATUS : nvapi.h
  • _NVVIOINTERLACEMODE : nvapi.h
  • _NVVIOLINKID : nvapi.h
  • _NVVIOOUTPUTAREA : nvapi.h
  • _NVVIOOWNERTYPE : nvapi.h
  • _NVVIOPCILINKRATE : nvapi.h
  • _NVVIOPCILINKWIDTH : nvapi.h
  • _NVVIOSIGNALFORMAT : nvapi.h
  • _NVVIOSTATUSTYPE : nvapi.h
  • _NVVIOSYNCSOURCE : nvapi.h
  • _NVVIOSYNCSTATUS : nvapi.h
  • _NVVIOVIDEOSTANDARD : nvapi.h
  • _NVVIOVIDEOTYPE : nvapi.h
  • _Outptr_ : nvapi_lite_salstart.h
  • _Post_writable_byte_size_ : nvapi_lite_salstart.h
  • _Ret_notnull_ : nvapi_lite_salstart.h


  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • v
  • w
Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- a -

  • AA_BEHAVIOR_FLAGS_AA_RT_BPP_DIV_4 : NvApiDriverSettings.h
  • AA_BEHAVIOR_FLAGS_AA_RT_BPP_DIV_4_SHIFT : NvApiDriverSettings.h
  • AA_BEHAVIOR_FLAGS_DEFAULT : NvApiDriverSettings.h
  • AA_BEHAVIOR_FLAGS_DISABLE_CPLAA : NvApiDriverSettings.h
  • AA_BEHAVIOR_FLAGS_DISABLE_ENHANCE : NvApiDriverSettings.h
  • AA_BEHAVIOR_FLAGS_DISABLE_OVERRIDE : NvApiDriverSettings.h
  • AA_BEHAVIOR_FLAGS_DISABLE_SLIAA : NvApiDriverSettings.h
  • AA_BEHAVIOR_FLAGS_ID : NvApiDriverSettings.h
  • AA_BEHAVIOR_FLAGS_MAP_VCAA_TO_MULTISAMPLING : NvApiDriverSettings.h
  • AA_BEHAVIOR_FLAGS_MASK : NvApiDriverSettings.h
  • AA_BEHAVIOR_FLAGS_NON_AA_RT_BPP_DIV_4 : NvApiDriverSettings.h
  • AA_BEHAVIOR_FLAGS_NON_AA_RT_BPP_DIV_4_SHIFT : NvApiDriverSettings.h
  • AA_BEHAVIOR_FLAGS_NONE : NvApiDriverSettings.h
  • AA_BEHAVIOR_FLAGS_NUM_VALUES : NvApiDriverSettings.h
  • AA_BEHAVIOR_FLAGS_SKIP_RT_DIM_CHECK_FOR_ENHANCE : NvApiDriverSettings.h
  • AA_BEHAVIOR_FLAGS_SLI_DISABLE_TRANSPARENCY_SUPERSAMPLING : NvApiDriverSettings.h
  • AA_BEHAVIOR_FLAGS_STRING : NvApiDriverSettings.h
  • AA_BEHAVIOR_FLAGS_TREAT_ENHANCE_AS_APP_CONTROLLED : NvApiDriverSettings.h
  • AA_BEHAVIOR_FLAGS_TREAT_ENHANCE_AS_OVERRIDE : NvApiDriverSettings.h
  • AA_BEHAVIOR_FLAGS_TREAT_OVERRIDE_AS_APP_CONTROLLED : NvApiDriverSettings.h
  • AA_BEHAVIOR_FLAGS_TREAT_OVERRIDE_AS_ENHANCE : NvApiDriverSettings.h
  • AA_MODE_ALPHATOCOVERAGE_DEFAULT : NvApiDriverSettings.h
  • AA_MODE_ALPHATOCOVERAGE_ID : NvApiDriverSettings.h
  • AA_MODE_ALPHATOCOVERAGE_MODE_MASK : NvApiDriverSettings.h
  • AA_MODE_ALPHATOCOVERAGE_MODE_MAX : NvApiDriverSettings.h
  • AA_MODE_ALPHATOCOVERAGE_MODE_OFF : NvApiDriverSettings.h
  • AA_MODE_ALPHATOCOVERAGE_MODE_ON : NvApiDriverSettings.h
  • AA_MODE_ALPHATOCOVERAGE_NUM_VALUES : NvApiDriverSettings.h
  • AA_MODE_ALPHATOCOVERAGE_STRING : NvApiDriverSettings.h
  • AA_MODE_GAMMACORRECTION_DEFAULT : NvApiDriverSettings.h
  • AA_MODE_GAMMACORRECTION_DEFAULT_FERMI : NvApiDriverSettings.h
  • AA_MODE_GAMMACORRECTION_DEFAULT_TESLA : NvApiDriverSettings.h
  • AA_MODE_GAMMACORRECTION_ID : NvApiDriverSettings.h
  • AA_MODE_GAMMACORRECTION_MASK : NvApiDriverSettings.h
  • AA_MODE_GAMMACORRECTION_MAX : NvApiDriverSettings.h
  • AA_MODE_GAMMACORRECTION_NUM_VALUES : NvApiDriverSettings.h
  • AA_MODE_GAMMACORRECTION_OFF : NvApiDriverSettings.h
  • AA_MODE_GAMMACORRECTION_ON_ALWAYS : NvApiDriverSettings.h
  • AA_MODE_GAMMACORRECTION_ON_IF_FOS : NvApiDriverSettings.h
  • AA_MODE_GAMMACORRECTION_STRING : NvApiDriverSettings.h
  • AA_MODE_METHOD_6X_CT : NvApiDriverSettings.h
  • AA_MODE_METHOD_CORRUPTION_CHECK : NvApiDriverSettings.h
  • AA_MODE_METHOD_COUNT : NvApiDriverSettings.h
  • AA_MODE_METHOD_DEFAULT : NvApiDriverSettings.h
  • AA_MODE_METHOD_FREE_0x03 : NvApiDriverSettings.h
  • AA_MODE_METHOD_FREE_0x04 : NvApiDriverSettings.h
  • AA_MODE_METHOD_FREE_0x08 : NvApiDriverSettings.h
  • AA_MODE_METHOD_FREE_0x09 : NvApiDriverSettings.h
  • AA_MODE_METHOD_FREE_0x11 : NvApiDriverSettings.h
  • AA_MODE_METHOD_FREE_0x14 : NvApiDriverSettings.h
  • AA_MODE_METHOD_FREE_0x15 : NvApiDriverSettings.h
  • AA_MODE_METHOD_ID : NvApiDriverSettings.h
  • AA_MODE_METHOD_METHOD_MASK : NvApiDriverSettings.h
  • AA_MODE_METHOD_METHOD_MAX : NvApiDriverSettings.h
  • AA_MODE_METHOD_MIXEDSAMPLE_128X : NvApiDriverSettings.h
  • AA_MODE_METHOD_MIXEDSAMPLE_16X : NvApiDriverSettings.h
  • AA_MODE_METHOD_MIXEDSAMPLE_32X : NvApiDriverSettings.h
  • AA_MODE_METHOD_MIXEDSAMPLE_4X_SKEWED_4TAP : NvApiDriverSettings.h
  • AA_MODE_METHOD_MIXEDSAMPLE_64X : NvApiDriverSettings.h
  • AA_MODE_METHOD_MIXEDSAMPLE_6X : NvApiDriverSettings.h
  • AA_MODE_METHOD_MIXEDSAMPLE_6X_SKEWED_6TAP : NvApiDriverSettings.h
  • AA_MODE_METHOD_MIXEDSAMPLE_8X : NvApiDriverSettings.h
  • AA_MODE_METHOD_MIXEDSAMPLE_8X_SKEWED_8TAP : NvApiDriverSettings.h
  • AA_MODE_METHOD_MULTISAMPLE_16X : NvApiDriverSettings.h
  • AA_MODE_METHOD_MULTISAMPLE_2X_DIAGONAL : NvApiDriverSettings.h
  • AA_MODE_METHOD_MULTISAMPLE_2X_DIAGONAL_FOSGAMMA : NvApiDriverSettings.h
  • AA_MODE_METHOD_MULTISAMPLE_2X_DIAGONAL_GAMMA : NvApiDriverSettings.h
  • AA_MODE_METHOD_MULTISAMPLE_2X_QUINCUNX : NvApiDriverSettings.h
  • AA_MODE_METHOD_MULTISAMPLE_4X : NvApiDriverSettings.h
  • AA_MODE_METHOD_MULTISAMPLE_4X_FOSGAMMA : NvApiDriverSettings.h
  • AA_MODE_METHOD_MULTISAMPLE_4X_GAMMA : NvApiDriverSettings.h
  • AA_MODE_METHOD_MULTISAMPLE_4X_GAUSSIAN : NvApiDriverSettings.h
  • AA_MODE_METHOD_MULTISAMPLE_8X : NvApiDriverSettings.h
  • AA_MODE_METHOD_NONE : NvApiDriverSettings.h
  • AA_MODE_METHOD_NUM_VALUES : NvApiDriverSettings.h
  • AA_MODE_METHOD_STRING : NvApiDriverSettings.h
  • AA_MODE_METHOD_SUPERSAMPLE_16X : NvApiDriverSettings.h
  • AA_MODE_METHOD_SUPERSAMPLE_16X_BIAS : NvApiDriverSettings.h
  • AA_MODE_METHOD_SUPERSAMPLE_1_5X1_5 : NvApiDriverSettings.h
  • AA_MODE_METHOD_SUPERSAMPLE_2X_H : NvApiDriverSettings.h
  • AA_MODE_METHOD_SUPERSAMPLE_2X_V : NvApiDriverSettings.h
  • AA_MODE_METHOD_SUPERSAMPLE_4X : NvApiDriverSettings.h
  • AA_MODE_METHOD_SUPERSAMPLE_4X_BIAS : NvApiDriverSettings.h
  • AA_MODE_METHOD_SUPERSAMPLE_4X_FOSGAMMA : NvApiDriverSettings.h
  • AA_MODE_METHOD_SUPERSAMPLE_4X_GAMMA : NvApiDriverSettings.h
  • AA_MODE_METHOD_SUPERSAMPLE_4X_GAUSSIAN : NvApiDriverSettings.h
  • AA_MODE_METHOD_SUPERSAMPLE_9X : NvApiDriverSettings.h
  • AA_MODE_METHOD_SUPERSAMPLE_9X_BIAS : NvApiDriverSettings.h
  • AA_MODE_METHOD_SUPERVCAA_64X_4v12 : NvApiDriverSettings.h
  • AA_MODE_METHOD_SUPERVCAA_64X_8v8 : NvApiDriverSettings.h
  • AA_MODE_METHOD_VCAA_16X_4v12 : NvApiDriverSettings.h
  • AA_MODE_METHOD_VCAA_16X_8v8 : NvApiDriverSettings.h
  • AA_MODE_METHOD_VCAA_32X_8v24 : NvApiDriverSettings.h
  • AA_MODE_METHOD_VCAA_8X_4v4 : NvApiDriverSettings.h
  • AA_MODE_REPLAY_DEFAULT : NvApiDriverSettings.h
  • AA_MODE_REPLAY_DISALLOW_TRAA : NvApiDriverSettings.h
  • AA_MODE_REPLAY_ID : NvApiDriverSettings.h
  • AA_MODE_REPLAY_MASK : NvApiDriverSettings.h
  • AA_MODE_REPLAY_MODE_ALL : NvApiDriverSettings.h
  • AA_MODE_REPLAY_MODE_ALPHA_TEST : NvApiDriverSettings.h
  • AA_MODE_REPLAY_MODE_DYN_BRANCH : NvApiDriverSettings.h
  • AA_MODE_REPLAY_MODE_MASK : NvApiDriverSettings.h
  • AA_MODE_REPLAY_MODE_MAX : NvApiDriverSettings.h
  • AA_MODE_REPLAY_MODE_OFF : NvApiDriverSettings.h
  • AA_MODE_REPLAY_MODE_OPTIMAL : NvApiDriverSettings.h
  • AA_MODE_REPLAY_MODE_PIXEL_KILL : NvApiDriverSettings.h
  • AA_MODE_REPLAY_NUM_VALUES : NvApiDriverSettings.h
  • AA_MODE_REPLAY_SAMPLES_EIGHT : NvApiDriverSettings.h
  • AA_MODE_REPLAY_SAMPLES_FOUR : NvApiDriverSettings.h
  • AA_MODE_REPLAY_SAMPLES_MASK : NvApiDriverSettings.h
  • AA_MODE_REPLAY_SAMPLES_MAX : NvApiDriverSettings.h
  • AA_MODE_REPLAY_SAMPLES_ONE : NvApiDriverSettings.h
  • AA_MODE_REPLAY_SAMPLES_TWO : NvApiDriverSettings.h
  • AA_MODE_REPLAY_STRING : NvApiDriverSettings.h
  • AA_MODE_REPLAY_TRANSPARENCY : NvApiDriverSettings.h
  • AA_MODE_REPLAY_TRANSPARENCY_DEFAULT : NvApiDriverSettings.h
  • AA_MODE_REPLAY_TRANSPARENCY_DEFAULT_FERMI : NvApiDriverSettings.h
  • AA_MODE_REPLAY_TRANSPARENCY_DEFAULT_TESLA : NvApiDriverSettings.h
  • AA_MODE_SELECTOR_APP_CONTROL : NvApiDriverSettings.h
  • AA_MODE_SELECTOR_DEFAULT : NvApiDriverSettings.h
  • AA_MODE_SELECTOR_ENHANCE : NvApiDriverSettings.h
  • AA_MODE_SELECTOR_ID : NvApiDriverSettings.h
  • AA_MODE_SELECTOR_MASK : NvApiDriverSettings.h
  • AA_MODE_SELECTOR_MAX : NvApiDriverSettings.h
  • AA_MODE_SELECTOR_NUM_VALUES : NvApiDriverSettings.h
  • AA_MODE_SELECTOR_OVERRIDE : NvApiDriverSettings.h
  • AA_MODE_SELECTOR_SLIAA_DEFAULT : NvApiDriverSettings.h
  • AA_MODE_SELECTOR_SLIAA_DISABLED : NvApiDriverSettings.h
  • AA_MODE_SELECTOR_SLIAA_ENABLED : NvApiDriverSettings.h
  • AA_MODE_SELECTOR_SLIAA_ID : NvApiDriverSettings.h
  • AA_MODE_SELECTOR_SLIAA_NUM_VALUES : NvApiDriverSettings.h
  • AA_MODE_SELECTOR_SLIAA_STRING : NvApiDriverSettings.h
  • AA_MODE_SELECTOR_STRING : NvApiDriverSettings.h
  • ALL_GPUS : nvapi.h
  • ANISO_MODE_LEVEL_DEFAULT : NvApiDriverSettings.h
  • ANISO_MODE_LEVEL_ID : NvApiDriverSettings.h
  • ANISO_MODE_LEVEL_MASK : NvApiDriverSettings.h
  • ANISO_MODE_LEVEL_MAX : NvApiDriverSettings.h
  • ANISO_MODE_LEVEL_NONE_LINEAR : NvApiDriverSettings.h
  • ANISO_MODE_LEVEL_NONE_POINT : NvApiDriverSettings.h
  • ANISO_MODE_LEVEL_NUM_VALUES : NvApiDriverSettings.h
  • ANISO_MODE_LEVEL_STRING : NvApiDriverSettings.h
  • ANISO_MODE_SELECTOR_APP : NvApiDriverSettings.h
  • ANISO_MODE_SELECTOR_COND : NvApiDriverSettings.h
  • ANISO_MODE_SELECTOR_DEFAULT : NvApiDriverSettings.h
  • ANISO_MODE_SELECTOR_ID : NvApiDriverSettings.h
  • ANISO_MODE_SELECTOR_MASK : NvApiDriverSettings.h
  • ANISO_MODE_SELECTOR_MAX : NvApiDriverSettings.h
  • ANISO_MODE_SELECTOR_NUM_VALUES : NvApiDriverSettings.h
  • ANISO_MODE_SELECTOR_STRING : NvApiDriverSettings.h
  • ANISO_MODE_SELECTOR_USER : NvApiDriverSettings.h
  • ANSEL_ALLOW_ALLOWED : NvApiDriverSettings.h
  • ANSEL_ALLOW_DEFAULT : NvApiDriverSettings.h
  • ANSEL_ALLOW_DISALLOWED : NvApiDriverSettings.h
  • ANSEL_ALLOW_ID : NvApiDriverSettings.h
  • ANSEL_ALLOW_NUM_VALUES : NvApiDriverSettings.h
  • ANSEL_ALLOW_STRING : NvApiDriverSettings.h
  • ANSEL_ALLOWLISTED_ALLOWED : NvApiDriverSettings.h
  • ANSEL_ALLOWLISTED_DEFAULT : NvApiDriverSettings.h
  • ANSEL_ALLOWLISTED_DISALLOWED : NvApiDriverSettings.h
  • ANSEL_ALLOWLISTED_ID : NvApiDriverSettings.h
  • ANSEL_ALLOWLISTED_NUM_VALUES : NvApiDriverSettings.h
  • ANSEL_ALLOWLISTED_STRING : NvApiDriverSettings.h
  • ANSEL_ENABLE_DEFAULT : NvApiDriverSettings.h
  • ANSEL_ENABLE_ID : NvApiDriverSettings.h
  • ANSEL_ENABLE_NUM_VALUES : NvApiDriverSettings.h
  • ANSEL_ENABLE_OFF : NvApiDriverSettings.h
  • ANSEL_ENABLE_ON : NvApiDriverSettings.h
  • ANSEL_ENABLE_STRING : NvApiDriverSettings.h
  • AO_MODE_ACTIVE_DEFAULT : NvApiDriverSettings.h
  • AO_MODE_ACTIVE_DISABLED : NvApiDriverSettings.h
  • AO_MODE_ACTIVE_ENABLED : NvApiDriverSettings.h
  • AO_MODE_ACTIVE_ID : NvApiDriverSettings.h
  • AO_MODE_ACTIVE_NUM_VALUES : NvApiDriverSettings.h
  • AO_MODE_ACTIVE_STRING : NvApiDriverSettings.h
  • AO_MODE_DEFAULT : NvApiDriverSettings.h
  • AO_MODE_HIGH : NvApiDriverSettings.h
  • AO_MODE_ID : NvApiDriverSettings.h
  • AO_MODE_LOW : NvApiDriverSettings.h
  • AO_MODE_MEDIUM : NvApiDriverSettings.h
  • AO_MODE_NUM_VALUES : NvApiDriverSettings.h
  • AO_MODE_OFF : NvApiDriverSettings.h
  • AO_MODE_STRING : NvApiDriverSettings.h
  • APPIDLE_DYNAMIC_FRL_FPS_ID : NvApiDriverSettings.h
  • APPIDLE_DYNAMIC_FRL_FPS_STRING : NvApiDriverSettings.h
  • APPIDLE_DYNAMIC_FRL_THRESHOLD_TIME_ID : NvApiDriverSettings.h
  • APPIDLE_DYNAMIC_FRL_THRESHOLD_TIME_STRING : NvApiDriverSettings.h
  • APPLICATION_PROFILE_NOTIFICATION_TIMEOUT_DEFAULT : NvApiDriverSettings.h
  • APPLICATION_PROFILE_NOTIFICATION_TIMEOUT_DISABLED : NvApiDriverSettings.h
  • APPLICATION_PROFILE_NOTIFICATION_TIMEOUT_FIFTEEN_SECONDS : NvApiDriverSettings.h
  • APPLICATION_PROFILE_NOTIFICATION_TIMEOUT_ID : NvApiDriverSettings.h
  • APPLICATION_PROFILE_NOTIFICATION_TIMEOUT_NINE_SECONDS : NvApiDriverSettings.h
  • APPLICATION_PROFILE_NOTIFICATION_TIMEOUT_NUM_VALUES : NvApiDriverSettings.h
  • APPLICATION_PROFILE_NOTIFICATION_TIMEOUT_ONE_MINUTE : NvApiDriverSettings.h
  • APPLICATION_PROFILE_NOTIFICATION_TIMEOUT_STRING : NvApiDriverSettings.h
  • APPLICATION_PROFILE_NOTIFICATION_TIMEOUT_THIRTY_SECONDS : NvApiDriverSettings.h
  • APPLICATION_PROFILE_NOTIFICATION_TIMEOUT_TWO_MINUTES : NvApiDriverSettings.h
  • APPLICATION_STEAM_ID_ID : NvApiDriverSettings.h
  • APPLICATION_STEAM_ID_STRING : NvApiDriverSettings.h
  • AUTO_LODBIASADJUST_DEFAULT : NvApiDriverSettings.h
  • AUTO_LODBIASADJUST_ID : NvApiDriverSettings.h
  • AUTO_LODBIASADJUST_NUM_VALUES : NvApiDriverSettings.h
  • AUTO_LODBIASADJUST_OFF : NvApiDriverSettings.h
  • AUTO_LODBIASADJUST_ON : NvApiDriverSettings.h
  • AUTO_LODBIASADJUST_STRING : NvApiDriverSettings.h


  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • v
  • w
Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- b -

  • BATTERY_BOOST_APP_FPS_DEFAULT : NvApiDriverSettings.h
  • BATTERY_BOOST_APP_FPS_ID : NvApiDriverSettings.h
  • BATTERY_BOOST_APP_FPS_MAX : NvApiDriverSettings.h
  • BATTERY_BOOST_APP_FPS_MIN : NvApiDriverSettings.h
  • BATTERY_BOOST_APP_FPS_NO_OVERRIDE : NvApiDriverSettings.h
  • BATTERY_BOOST_APP_FPS_NUM_VALUES : NvApiDriverSettings.h
  • BATTERY_BOOST_APP_FPS_STRING : NvApiDriverSettings.h
  • bRelease : nvapi.h


  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • v
  • w
Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- c -

  • compile_time_assert : nvapi.h
  • CPL_HIDDEN_PROFILE_DEFAULT : NvApiDriverSettings.h
  • CPL_HIDDEN_PROFILE_DISABLED : NvApiDriverSettings.h
  • CPL_HIDDEN_PROFILE_ENABLED : NvApiDriverSettings.h
  • CPL_HIDDEN_PROFILE_ID : NvApiDriverSettings.h
  • CPL_HIDDEN_PROFILE_NUM_VALUES : NvApiDriverSettings.h
  • CPL_HIDDEN_PROFILE_STRING : NvApiDriverSettings.h
  • CUDA_EXCLUDED_GPUS_DEFAULT : NvApiDriverSettings.h
  • CUDA_EXCLUDED_GPUS_ID : NvApiDriverSettings.h
  • CUDA_EXCLUDED_GPUS_NONE : NvApiDriverSettings.h
  • CUDA_EXCLUDED_GPUS_NUM_VALUES : NvApiDriverSettings.h
  • CUDA_EXCLUDED_GPUS_STRING : NvApiDriverSettings.h


  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • v
  • w
Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- d -

  • D3DOGL_GPU_MAX_POWER_DEFAULT : NvApiDriverSettings.h
  • D3DOGL_GPU_MAX_POWER_DEFAULTPOWER : NvApiDriverSettings.h
  • D3DOGL_GPU_MAX_POWER_ID : NvApiDriverSettings.h
  • D3DOGL_GPU_MAX_POWER_NUM_VALUES : NvApiDriverSettings.h
  • D3DOGL_GPU_MAX_POWER_STRING : NvApiDriverSettings.h
  • DECLARE_INTERFACE() : nvapi.h
  • DECLARE_INTERFACE_() : nvapi.h
  • destEnumIndex : nvapi.h
  • DISABLE_IMPLICIT_SLI : nvapi.h
  • DISPLAYPORT_STRUCTS_DEFINED : nvapi.h
  • displayView : nvapi.h


  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • v
  • w
Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- e -

  • ENABLE_IMPLICIT_SLI : nvapi.h
  • enumIndex : nvapi.h
  • ESetting : NvApiDriverSettings.h
  • EValues_AA_BEHAVIOR_FLAGS : NvApiDriverSettings.h
  • EValues_AA_MODE_ALPHATOCOVERAGE : NvApiDriverSettings.h
  • EValues_AA_MODE_GAMMACORRECTION : NvApiDriverSettings.h
  • EValues_AA_MODE_METHOD : NvApiDriverSettings.h
  • EValues_AA_MODE_REPLAY : NvApiDriverSettings.h
  • EValues_AA_MODE_SELECTOR : NvApiDriverSettings.h
  • EValues_AA_MODE_SELECTOR_SLIAA : NvApiDriverSettings.h
  • EValues_ANISO_MODE_LEVEL : NvApiDriverSettings.h
  • EValues_ANISO_MODE_SELECTOR : NvApiDriverSettings.h
  • EValues_ANSEL_ALLOW : NvApiDriverSettings.h
  • EValues_ANSEL_ALLOWLISTED : NvApiDriverSettings.h
  • EValues_ANSEL_ENABLE : NvApiDriverSettings.h
  • EValues_AO_MODE : NvApiDriverSettings.h
  • EValues_AO_MODE_ACTIVE : NvApiDriverSettings.h
  • EValues_APPLICATION_PROFILE_NOTIFICATION_TIMEOUT : NvApiDriverSettings.h
  • EValues_AUTO_LODBIASADJUST : NvApiDriverSettings.h
  • EValues_BATTERY_BOOST_APP_FPS : NvApiDriverSettings.h
  • EValues_CPL_HIDDEN_PROFILE : NvApiDriverSettings.h
  • EValues_EXPORT_PERF_COUNTERS : NvApiDriverSettings.h
  • EValues_EXPORT_PERF_COUNTERS_DX9_ONLY : NvApiDriverSettings.h
  • EValues_EXTERNAL_QUIET_MODE : NvApiDriverSettings.h
  • EValues_FRL_FPS : NvApiDriverSettings.h
  • EValues_FXAA_ALLOW : NvApiDriverSettings.h
  • EValues_FXAA_ENABLE : NvApiDriverSettings.h
  • EValues_FXAA_INDICATOR_ENABLE : NvApiDriverSettings.h
  • EValues_LATENCY_INDICATOR_AUTOALIGN : NvApiDriverSettings.h
  • EValues_LODBIASADJUST : NvApiDriverSettings.h
  • EValues_MAXWELL_B_SAMPLE_INTERLEAVE : NvApiDriverSettings.h
  • EValues_MCSFRSHOWSPLIT : NvApiDriverSettings.h
  • EValues_NV_QUALITY_UPSCALING : NvApiDriverSettings.h
  • EValues_OGL_AA_LINE_GAMMA : NvApiDriverSettings.h
  • EValues_OGL_CPL_GDI_COMPATIBILITY : NvApiDriverSettings.h
  • EValues_OGL_CPL_PREFER_DXPRESENT : NvApiDriverSettings.h
  • EValues_OGL_DEEP_COLOR_SCANOUT : NvApiDriverSettings.h
  • EValues_OGL_DEFAULT_SWAP_INTERVAL : NvApiDriverSettings.h
  • EValues_OGL_DEFAULT_SWAP_INTERVAL_FRACTIONAL : NvApiDriverSettings.h
  • EValues_OGL_DEFAULT_SWAP_INTERVAL_SIGN : NvApiDriverSettings.h
  • EValues_OGL_EVENT_LOG_SEVERITY_THRESHOLD : NvApiDriverSettings.h
  • EValues_OGL_FORCE_BLIT : NvApiDriverSettings.h
  • EValues_OGL_FORCE_STEREO : NvApiDriverSettings.h
  • EValues_OGL_OVERLAY_PIXEL_TYPE : NvApiDriverSettings.h
  • EValues_OGL_OVERLAY_SUPPORT : NvApiDriverSettings.h
  • EValues_OGL_QUALITY_ENHANCEMENTS : NvApiDriverSettings.h
  • EValues_OGL_SINGLE_BACKDEPTH_BUFFER : NvApiDriverSettings.h
  • EValues_OGL_SLI_MULTICAST : NvApiDriverSettings.h
  • EValues_OGL_THREAD_CONTROL : NvApiDriverSettings.h
  • EValues_OGL_TMON_LEVEL : NvApiDriverSettings.h
  • EValues_OGL_TRIPLE_BUFFER : NvApiDriverSettings.h
  • EValues_OPTIMUS_MAXAA : NvApiDriverSettings.h
  • EValues_PHYSXINDICATOR : NvApiDriverSettings.h
  • EValues_PREFERRED_PSTATE : NvApiDriverSettings.h
  • EValues_PRERENDERLIMIT : NvApiDriverSettings.h
  • EValues_PREVENT_UI_AF_OVERRIDE : NvApiDriverSettings.h
  • EValues_PS_SHADERDISKCACHE : NvApiDriverSettings.h
  • EValues_PS_SHADERDISKCACHE_MAX_SIZE : NvApiDriverSettings.h
  • EValues_PS_TEXFILTER_ANISO_OPTS2 : NvApiDriverSettings.h
  • EValues_PS_TEXFILTER_BILINEAR_IN_ANISO : NvApiDriverSettings.h
  • EValues_PS_TEXFILTER_DISABLE_TRILIN_SLOPE : NvApiDriverSettings.h
  • EValues_PS_TEXFILTER_NO_NEG_LODBIAS : NvApiDriverSettings.h
  • EValues_QUALITY_ENHANCEMENT_SUBSTITUTION : NvApiDriverSettings.h
  • EValues_QUALITY_ENHANCEMENTS : NvApiDriverSettings.h
  • EValues_REFRESH_RATE_OVERRIDE : NvApiDriverSettings.h
  • EValues_SET_POWER_THROTTLE_FOR_PCIe_COMPLIANCE : NvApiDriverSettings.h
  • EValues_SET_VAB_DATA : NvApiDriverSettings.h
  • EValues_SHIM_MCCOMPAT : NvApiDriverSettings.h
  • EValues_SHIM_RENDERING_MODE : NvApiDriverSettings.h
  • EValues_SHIM_RENDERING_OPTIONS : NvApiDriverSettings.h
  • EValues_SLI_GPU_COUNT : NvApiDriverSettings.h
  • EValues_SLI_PREDEFINED_GPU_COUNT : NvApiDriverSettings.h
  • EValues_SLI_PREDEFINED_GPU_COUNT_DX10 : NvApiDriverSettings.h
  • EValues_SLI_PREDEFINED_MODE : NvApiDriverSettings.h
  • EValues_SLI_PREDEFINED_MODE_DX10 : NvApiDriverSettings.h
  • EValues_SLI_RENDERING_MODE : NvApiDriverSettings.h
  • EValues_VRPRERENDERLIMIT : NvApiDriverSettings.h
  • EValues_VRR_APP_OVERRIDE : NvApiDriverSettings.h
  • EValues_VRR_APP_OVERRIDE_REQUEST_STATE : NvApiDriverSettings.h
  • EValues_VRR_MODE : NvApiDriverSettings.h
  • EValues_VRRFEATUREINDICATOR : NvApiDriverSettings.h
  • EValues_VRROVERLAYINDICATOR : NvApiDriverSettings.h
  • EValues_VRRREQUESTSTATE : NvApiDriverSettings.h
  • EValues_VSYNC_BEHAVIOR_FLAGS : NvApiDriverSettings.h
  • EValues_VSYNCMODE : NvApiDriverSettings.h
  • EValues_VSYNCSMOOTHAFR : NvApiDriverSettings.h
  • EValues_VSYNCTEARCONTROL : NvApiDriverSettings.h
  • EValues_VSYNCVRRCONTROL : NvApiDriverSettings.h
  • EValues_WKS_API_STEREO_EYES_EXCHANGE : NvApiDriverSettings.h
  • EValues_WKS_API_STEREO_MODE : NvApiDriverSettings.h
  • EValues_WKS_STEREO_DONGLE_SUPPORT : NvApiDriverSettings.h
  • EValues_WKS_STEREO_SUPPORT : NvApiDriverSettings.h
  • EValues_WKS_STEREO_SWAP_MODE : NvApiDriverSettings.h
  • EXPORT_PERF_COUNTERS_DEFAULT : NvApiDriverSettings.h
  • EXPORT_PERF_COUNTERS_DX9_ONLY_DEFAULT : NvApiDriverSettings.h
  • EXPORT_PERF_COUNTERS_DX9_ONLY_ID : NvApiDriverSettings.h
  • EXPORT_PERF_COUNTERS_DX9_ONLY_NUM_VALUES : NvApiDriverSettings.h
  • EXPORT_PERF_COUNTERS_DX9_ONLY_OFF : NvApiDriverSettings.h
  • EXPORT_PERF_COUNTERS_DX9_ONLY_ON : NvApiDriverSettings.h
  • EXPORT_PERF_COUNTERS_DX9_ONLY_STRING : NvApiDriverSettings.h
  • EXPORT_PERF_COUNTERS_ID : NvApiDriverSettings.h
  • EXPORT_PERF_COUNTERS_NUM_VALUES : NvApiDriverSettings.h
  • EXPORT_PERF_COUNTERS_OFF : NvApiDriverSettings.h
  • EXPORT_PERF_COUNTERS_ON : NvApiDriverSettings.h
  • EXPORT_PERF_COUNTERS_STRING : NvApiDriverSettings.h
  • EXTERNAL_QUIET_MODE_DEFAULT : NvApiDriverSettings.h
  • EXTERNAL_QUIET_MODE_ID : NvApiDriverSettings.h
  • EXTERNAL_QUIET_MODE_NUM_VALUES : NvApiDriverSettings.h
  • EXTERNAL_QUIET_MODE_OFF : NvApiDriverSettings.h
  • EXTERNAL_QUIET_MODE_ON : NvApiDriverSettings.h
  • EXTERNAL_QUIET_MODE_STRING : NvApiDriverSettings.h


  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • v
  • w
Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- f -

  • FENCE_SYNCHRONIZATION_END : nvapi.h
  • FENCE_SYNCHRONIZATION_START : nvapi.h
  • FRL_FPS_DEFAULT : NvApiDriverSettings.h
  • FRL_FPS_DISABLED : NvApiDriverSettings.h
  • FRL_FPS_ID : NvApiDriverSettings.h
  • FRL_FPS_MAX : NvApiDriverSettings.h
  • FRL_FPS_MIN : NvApiDriverSettings.h
  • FRL_FPS_NUM_VALUES : NvApiDriverSettings.h
  • FRL_FPS_STRING : NvApiDriverSettings.h
  • FXAA_ALLOW_ALLOWED : NvApiDriverSettings.h
  • FXAA_ALLOW_DEFAULT : NvApiDriverSettings.h
  • FXAA_ALLOW_DISALLOWED : NvApiDriverSettings.h
  • FXAA_ALLOW_ID : NvApiDriverSettings.h
  • FXAA_ALLOW_NUM_VALUES : NvApiDriverSettings.h
  • FXAA_ALLOW_STRING : NvApiDriverSettings.h
  • FXAA_ENABLE_DEFAULT : NvApiDriverSettings.h
  • FXAA_ENABLE_ID : NvApiDriverSettings.h
  • FXAA_ENABLE_NUM_VALUES : NvApiDriverSettings.h
  • FXAA_ENABLE_OFF : NvApiDriverSettings.h
  • FXAA_ENABLE_ON : NvApiDriverSettings.h
  • FXAA_ENABLE_STRING : NvApiDriverSettings.h
  • FXAA_INDICATOR_ENABLE_DEFAULT : NvApiDriverSettings.h
  • FXAA_INDICATOR_ENABLE_ID : NvApiDriverSettings.h
  • FXAA_INDICATOR_ENABLE_NUM_VALUES : NvApiDriverSettings.h
  • FXAA_INDICATOR_ENABLE_OFF : NvApiDriverSettings.h
  • FXAA_INDICATOR_ENABLE_ON : NvApiDriverSettings.h
  • FXAA_INDICATOR_ENABLE_STRING : NvApiDriverSettings.h


  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • v
  • w
Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- g -

  • g_NvidiaExt : nvHLSLExtnsInternal.h
  • GET_NVAPI_SIZE : nvapi_lite_common.h
  • GET_NVAPI_VERSION : nvapi_lite_common.h


  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • v
  • w
Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- i -

  • ICAFE_LOGO_CONFIG_ID : NvApiDriverSettings.h
  • ICAFE_LOGO_CONFIG_STRING : NvApiDriverSettings.h
  • ID3D11MultiGPUDevice : nvapi.h
  • ID3D11MultiGPUDevice_VER : nvapi.h
  • ID3D11MultiGPUDevice_VER1 : nvapi.h
  • ID3D11MultiGPUDevice_VER2 : nvapi.h
  • ID3D11MultiGPUDevice_VER3 : nvapi.h
  • ID3D11NvMetaCommand : nvapi.h
  • ID3D11NvMetaCommand_VER : nvapi.h
  • ID3D11NvMetaCommand_VER1 : nvapi.h
  • ID3D11NvShadingRateResourceView : nvapi.h
  • ID3D11NvShadingRateResourceView_VER : nvapi.h
  • ID3D11NvShadingRateResourceView_VER1 : nvapi.h
  • ID3D12NvMetaCommand : nvapi.h
  • ID3D12NvMetaCommand_VER : nvapi.h
  • ID3D12NvMetaCommand_VER1 : nvapi.h
  • ID3DLateLatchObject : nvapi.h
  • ID3DLateLatchObject_VER : nvapi.h
  • ID3DLateLatchObject_VER1 : nvapi.h
  • ID3DNvGazeHandler : nvapi.h
  • ID3DNvGazeHandler_VER : nvapi.h
  • ID3DNvGazeHandler_VER1 : nvapi.h
  • ID3DNvGazeHandler_VER2 : nvapi.h
  • ID3DNvSMPAssist : nvapi.h
  • ID3DNVSMPASSIST_VER : nvapi.h
  • ID3DNVSMPASSIST_VER1 : nvapi.h
  • ID3DNvVRSHelper : nvapi.h
  • ID3DNvVRSHelper_VER : nvapi.h
  • ID3DNvVRSHelper_VER1 : nvapi.h
  • IMPLICIT_SLI_CONTROL : nvapi.h
  • INPUT_SAMPLE : nvapi.h
  • inputFlags : nvapi.h
  • INVALID_SETTING_ID : NvApiDriverSettings.h


  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • v
  • w
Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- l -

  • LATENCY_INDICATOR_AUTOALIGN_DEFAULT : NvApiDriverSettings.h
  • LATENCY_INDICATOR_AUTOALIGN_DISABLED : NvApiDriverSettings.h
  • LATENCY_INDICATOR_AUTOALIGN_ENABLED : NvApiDriverSettings.h
  • LATENCY_INDICATOR_AUTOALIGN_ID : NvApiDriverSettings.h
  • LATENCY_INDICATOR_AUTOALIGN_NUM_VALUES : NvApiDriverSettings.h
  • LATENCY_INDICATOR_AUTOALIGN_STRING : NvApiDriverSettings.h
  • LODBIASADJUST_DEFAULT : NvApiDriverSettings.h
  • LODBIASADJUST_ID : NvApiDriverSettings.h
  • LODBIASADJUST_MAX : NvApiDriverSettings.h
  • LODBIASADJUST_MIN : NvApiDriverSettings.h
  • LODBIASADJUST_NUM_VALUES : NvApiDriverSettings.h
  • LODBIASADJUST_STRING : NvApiDriverSettings.h


  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • v
  • w
Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- m -

  • MAKE_NVAPI_VERSION : nvapi_lite_common.h
  • MAX_NUM_COMPOSITE_RANGE : nvapi.h
  • MAX_NUMBER_OF_GAZE_DATA_PROVIDERS : nvapi.h
  • MAXWELL_B_SAMPLE_INTERLEAVE_DEFAULT : NvApiDriverSettings.h
  • MAXWELL_B_SAMPLE_INTERLEAVE_ID : NvApiDriverSettings.h
  • MAXWELL_B_SAMPLE_INTERLEAVE_NUM_VALUES : NvApiDriverSettings.h
  • MAXWELL_B_SAMPLE_INTERLEAVE_OFF : NvApiDriverSettings.h
  • MAXWELL_B_SAMPLE_INTERLEAVE_ON : NvApiDriverSettings.h
  • MAXWELL_B_SAMPLE_INTERLEAVE_STRING : NvApiDriverSettings.h
  • MCSFRSHOWSPLIT_DEFAULT : NvApiDriverSettings.h
  • MCSFRSHOWSPLIT_DISABLED : NvApiDriverSettings.h
  • MCSFRSHOWSPLIT_ENABLED : NvApiDriverSettings.h
  • MCSFRSHOWSPLIT_ID : NvApiDriverSettings.h
  • MCSFRSHOWSPLIT_NUM_VALUES : NvApiDriverSettings.h
  • MCSFRSHOWSPLIT_STRING : NvApiDriverSettings.h


  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • v
  • w
Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- n -

  • NV_ADAPTER_TYPE : nvapi.h
  • NV_ADAPTER_TYPE_LAST : nvapi.h
  • NV_ADAPTER_TYPE_MCDM : nvapi.h
  • NV_ADAPTER_TYPE_TCC : nvapi.h
  • NV_ADAPTER_TYPE_UNKNOWN : nvapi.h
  • NV_ADAPTER_TYPE_WDDM : nvapi.h
  • NV_ASYNC_FRAME_MARKER_PARAMS : nvapi.h
  • NV_ASYNC_FRAME_MARKER_PARAMS_V1 : nvapi.h
  • NV_ASYNC_FRAME_MARKER_PARAMS_VER : nvapi.h
  • NV_ASYNC_FRAME_MARKER_PARAMS_VER1 : nvapi.h
  • NV_BIT : nvapi_lite_common.h
  • NV_BOARD_INFO : nvapi.h
  • NV_BOARD_INFO_V1 : nvapi.h
  • NV_BOARD_INFO_VER : nvapi.h
  • NV_BOARD_INFO_VER1 : nvapi.h
  • NV_BPC : nvapi.h
  • NV_BPC_10 : nvapi.h
  • NV_BPC_12 : nvapi.h
  • NV_BPC_16 : nvapi.h
  • NV_BPC_6 : nvapi.h
  • NV_BPC_8 : nvapi.h
  • NV_BPC_DEFAULT : nvapi.h
  • NV_CHIPSET_INFO : nvapi.h
  • NV_CHIPSET_INFO_FLAGS : nvapi.h
  • NV_CHIPSET_INFO_HYBRID : nvapi.h
  • NV_CHIPSET_INFO_VER : nvapi.h
  • NV_CHIPSET_INFO_VER_1 : nvapi.h
  • NV_CHIPSET_INFO_VER_2 : nvapi.h
  • NV_CHIPSET_INFO_VER_3 : nvapi.h
  • NV_CHIPSET_INFO_VER_4 : nvapi.h
  • NV_CLIENT_CALLBACK_SETTINGS_SUPER_V1 : nvapi.h
  • NV_CLIP_DISTANCE_0_SEMANTIC : nvapi.h
  • NV_CLIP_DISTANCE_1_SEMANTIC : nvapi.h
  • NV_COLOR_CMD : nvapi.h
  • NV_COLOR_CMD_GET : nvapi.h
  • NV_COLOR_CMD_GET_DEFAULT : nvapi.h
  • NV_COLOR_CMD_IS_SUPPORTED_COLOR : nvapi.h
  • NV_COLOR_CMD_SET : nvapi.h
  • NV_COLOR_COLORIMETRY : nvapi.h
  • NV_COLOR_COLORIMETRY_ADOBERGB : nvapi.h
  • NV_COLOR_COLORIMETRY_ADOBEYCC601 : nvapi.h
  • NV_COLOR_COLORIMETRY_AUTO : nvapi.h
  • NV_COLOR_COLORIMETRY_BT2020cYCC : nvapi.h
  • NV_COLOR_COLORIMETRY_BT2020RGB : nvapi.h
  • NV_COLOR_COLORIMETRY_BT2020YCC : nvapi.h
  • NV_COLOR_COLORIMETRY_DEFAULT : nvapi.h
  • NV_COLOR_COLORIMETRY_RGB : nvapi.h
  • NV_COLOR_COLORIMETRY_SYCC601 : nvapi.h
  • NV_COLOR_COLORIMETRY_XVYCC601 : nvapi.h
  • NV_COLOR_COLORIMETRY_XVYCC709 : nvapi.h
  • NV_COLOR_COLORIMETRY_YCC601 : nvapi.h
  • NV_COLOR_COLORIMETRY_YCC709 : nvapi.h
  • NV_COLOR_DATA : nvapi.h
  • NV_COLOR_DATA_V1 : nvapi.h
  • NV_COLOR_DATA_V2 : nvapi.h
  • NV_COLOR_DATA_V3 : nvapi.h
  • NV_COLOR_DATA_V4 : nvapi.h
  • NV_COLOR_DATA_V5 : nvapi.h
  • NV_COLOR_DATA_VER : nvapi.h
  • NV_COLOR_DATA_VER1 : nvapi.h
  • NV_COLOR_DATA_VER2 : nvapi.h
  • NV_COLOR_DATA_VER3 : nvapi.h
  • NV_COLOR_DATA_VER4 : nvapi.h
  • NV_COLOR_DATA_VER5 : nvapi.h
  • NV_COLOR_FORMAT : nvapi.h
  • NV_COLOR_FORMAT_AUTO : nvapi.h
  • NV_COLOR_FORMAT_DEFAULT : nvapi.h
  • NV_COLOR_FORMAT_RGB : nvapi.h
  • NV_COLOR_FORMAT_YUV420 : nvapi.h
  • NV_COLOR_FORMAT_YUV422 : nvapi.h
  • NV_COLOR_FORMAT_YUV444 : nvapi.h
  • NV_COLOR_SELECTION_POLICY : nvapi.h
  • NV_COLOR_SELECTION_POLICY_BEST_QUALITY : nvapi.h
  • NV_COLOR_SELECTION_POLICY_DEFAULT : nvapi.h
  • NV_COLOR_SELECTION_POLICY_UNKNOWN : nvapi.h
  • NV_COLOR_SELECTION_POLICY_USER : nvapi.h
  • NV_COLORSPACE_REC2100 : nvapi.h
  • NV_COLORSPACE_sRGB : nvapi.h
  • NV_COLORSPACE_TYPE : nvapi.h
  • NV_COLORSPACE_xRGB : nvapi.h
  • NV_COMPUTE_GPU : nvapi.h
  • NV_COMPUTE_GPU_TOPOLOGY : nvapi.h
  • NV_COMPUTE_GPU_TOPOLOGY_CUDA_AVAILABLE : nvapi.h
  • NV_COMPUTE_GPU_TOPOLOGY_CUDA_CAPABLE : nvapi.h
  • NV_COMPUTE_GPU_TOPOLOGY_CUDA_DISABLED : nvapi.h
  • NV_COMPUTE_GPU_TOPOLOGY_PHYSICS_AVAILABLE : nvapi.h
  • NV_COMPUTE_GPU_TOPOLOGY_PHYSICS_CAPABLE : nvapi.h
  • NV_COMPUTE_GPU_TOPOLOGY_PHYSICS_DEDICATED : nvapi.h
  • NV_COMPUTE_GPU_TOPOLOGY_PHYSICS_ENABLE : nvapi.h
  • NV_COMPUTE_GPU_TOPOLOGY_PHYSICS_RECOMMENDED : nvapi.h
  • NV_COMPUTE_GPU_TOPOLOGY_V2 : nvapi.h
  • NV_COMPUTE_GPU_TOPOLOGY_VER : nvapi.h
  • NV_COMPUTE_GPU_TOPOLOGY_VER1 : nvapi.h
  • NV_COMPUTE_SHADER_DERIVATIVE_GROUP_LINEAR : nvapi.h
  • NV_COMPUTE_SHADER_DERIVATIVE_GROUP_QUADS : nvapi.h
  • NV_COMPUTE_SHADER_DERIVATIVE_NONE : nvapi.h
  • NV_COMPUTE_SHADER_DERIVATIVES : nvapi.h
  • NV_CULL_DISTANCE_0_SEMANTIC : nvapi.h
  • NV_CULL_DISTANCE_1_SEMANTIC : nvapi.h
  • NV_CUSTOM_DISPLAY_VER : nvapi.h
  • NV_CUSTOM_RECTS : nvapi.h
  • NV_CUSTOM_RECTS_V1 : nvapi.h
  • NV_CUSTOM_SEMANTIC : nvapi.h
  • NV_CUSTOM_SEMANTIC_MAX : nvapi.h
  • NV_CUSTOM_SEMANTIC_MAX_LIMIT : nvapi.h
  • NV_CUSTOM_SEMANTIC_TYPE : nvapi.h
  • NV_CUSTOM_SEMANTIC_VERSION : nvapi.h
  • NV_D3D11_EXCLUSIVE_SCISSOR_RECT_DESC : nvapi.h
  • NV_D3D11_EXCLUSIVE_SCISSOR_RECT_DESC_V1 : nvapi.h
  • NV_D3D11_EXCLUSIVE_SCISSOR_RECTS_DESC : nvapi.h
  • NV_D3D11_EXCLUSIVE_SCISSOR_RECTS_DESC_V1 : nvapi.h
  • NV_D3D11_EXCLUSIVE_SCISSOR_RECTS_DESC_VER : nvapi.h
  • NV_D3D11_EXCLUSIVE_SCISSOR_RECTS_DESC_VER1 : nvapi.h
  • NV_D3D11_FEATURE : nvapi.h
  • NV_D3D11_FEATURE_DATA_RASTERIZER_SUPPORT : nvapi.h
  • NV_D3D11_FEATURE_RASTERIZER : nvapi.h
  • NV_D3D11_SHADING_RATE_RESOURCE_VIEW_DESC : nvapi.h
  • NV_D3D11_SHADING_RATE_RESOURCE_VIEW_DESC_V1 : nvapi.h
  • NV_D3D11_SHADING_RATE_RESOURCE_VIEW_DESC_VER : nvapi.h
  • NV_D3D11_SHADING_RATE_RESOURCE_VIEW_DESC_VER1 : nvapi.h
  • NV_D3D11_VIEWPORT_SHADING_RATE_DESC : nvapi.h
  • NV_D3D11_VIEWPORT_SHADING_RATE_DESC_V1 : nvapi.h
  • NV_D3D11_VIEWPORTS_SHADING_RATE_DESC : nvapi.h
  • NV_D3D11_VIEWPORTS_SHADING_RATE_DESC_V1 : nvapi.h
  • NV_D3D11_VIEWPORTS_SHADING_RATE_DESC_VER : nvapi.h
  • NV_D3D11_VIEWPORTS_SHADING_RATE_DESC_VER1 : nvapi.h
  • NV_D3D12_GRAPHICS_CAPS : nvapi.h
  • NV_D3D12_GRAPHICS_CAPS_V1 : nvapi.h
  • NV_D3D12_GRAPHICS_CAPS_VER : nvapi.h
  • NV_D3D12_GRAPHICS_CAPS_VER1 : nvapi.h
  • NV_D3D12_HEAP_FLAG_CPUVISIBLE_VIDMEM : nvapi.h
  • NV_D3D12_HEAP_FLAG_NONE : nvapi.h
  • NV_D3D12_HEAP_FLAGS : nvapi.h
  • NV_D3D12_MOSAIC_GETCOMPANIONALLOCATIONS : nvapi.h
  • NV_D3D12_MOSAIC_GETCOMPANIONALLOCATIONS_V1 : nvapi.h
  • NV_D3D12_MOSAIC_GETCOMPANIONALLOCATIONS_VER : nvapi.h
  • NV_D3D12_MOSAIC_GETCOMPANIONALLOCATIONS_VER1 : nvapi.h
  • NV_D3D12_MOSAIC_GETVIEWPORTANDGPUPARTITIONS : nvapi.h
  • NV_D3D12_MOSAIC_GETVIEWPORTANDGPUPARTITIONS_V1 : nvapi.h
  • NV_D3D12_MOSAIC_GETVIEWPORTANDGPUPARTITIONS_VER : nvapi.h
  • NV_D3D12_MOSAIC_GETVIEWPORTANDGPUPARTITIONS_VER1 : nvapi.h
  • NV_D3D12_RESOURCE_FLAG_CPUVISIBLE_VIDMEM : nvapi.h
  • NV_D3D12_RESOURCE_FLAG_HTEX : nvapi.h
  • NV_D3D12_RESOURCE_FLAG_NONE : nvapi.h
  • NV_D3D12_RESOURCE_FLAGS : nvapi.h
  • NV_D3D12_WORKSTATION_FEATURE_RDMA_PROPERTIES : nvapi.h
  • NV_D3D12_WORKSTATION_FEATURE_TYPE : nvapi.h
  • NV_D3D12_WORKSTATION_FEATURE_TYPE_PRESENT_BARRIER : nvapi.h
  • NV_D3D12_WORKSTATION_FEATURE_TYPE_RDMA_BAR1_SUPPORT : nvapi.h
  • NV_D3D1x_GRAPHICS_CAPS : nvapi.h
  • NV_D3D1x_GRAPHICS_CAPS_V1 : nvapi.h
  • NV_D3D1x_GRAPHICS_CAPS_V2 : nvapi.h
  • NV_D3D1x_GRAPHICS_CAPS_VER : nvapi.h
  • NV_D3D1x_GRAPHICS_CAPS_VER1 : nvapi.h
  • NV_D3D1x_GRAPHICS_CAPS_VER2 : nvapi.h
  • NV_D3D_GRAPHICS_STATE_COMPUTE_ROOT_SIGNATURE : nvapi.h
  • NV_D3D_GRAPHICS_STATE_DESCRIPTOR_HEAP : nvapi.h
  • NV_D3D_GRAPHICS_STATE_GRAPHICS_ROOT_SIGNATURE : nvapi.h
  • NV_D3D_GRAPHICS_STATE_IA_INDEX_BUFFER : nvapi.h
  • NV_D3D_GRAPHICS_STATE_IA_PRIMITIVE_TOPOLOGY : nvapi.h
  • NV_D3D_GRAPHICS_STATE_IA_VERTEX_BUFFERS : nvapi.h
  • NV_D3D_GRAPHICS_STATE_NONE : nvapi.h
  • NV_D3D_GRAPHICS_STATE_OM_BLEND_FACTOR : nvapi.h
  • NV_D3D_GRAPHICS_STATE_OM_DEPTH_BOUNDS : nvapi.h
  • NV_D3D_GRAPHICS_STATE_OM_RENDER_TARGETS : nvapi.h
  • NV_D3D_GRAPHICS_STATE_OM_STENCIL_REF : nvapi.h
  • NV_D3D_GRAPHICS_STATE_PIPELINE_STATE : nvapi.h
  • NV_D3D_GRAPHICS_STATE_PREDICATION : nvapi.h
  • NV_D3D_GRAPHICS_STATE_RS_SCISSOR_RECTS : nvapi.h
  • NV_D3D_GRAPHICS_STATE_RS_VIEWPORTS : nvapi.h
  • NV_D3D_GRAPHICS_STATE_SAMPLE_POSITIONS : nvapi.h
  • NV_D3D_GRAPHICS_STATE_SO_TARGETS : nvapi.h
  • NV_D3D_GRAPHICS_STATE_VIEW_INSTANCE_MASK : nvapi.h
  • NV_D3D_GRAPHICS_STATES : nvapi.h
  • NV_D3D_LATELATCH_OBJECT_DESC : nvapi.h
  • NV_D3D_LATELATCH_OBJECT_DESC_V1 : nvapi.h
  • NV_D3D_LATELATCH_OBJECT_DESC_VER : nvapi.h
  • NV_D3D_LATELATCH_OBJECT_DESC_VER1 : nvapi.h
  • NV_DECLARE_HANDLE : nvapi_lite_common.h, nvapi.h, nvapi_lite_common.h
  • NV_DESKTOP_COLOR_DEPTH : nvapi.h
  • NV_DESKTOP_COLOR_DEPTH_10BPC : nvapi.h
  • NV_DESKTOP_COLOR_DEPTH_16BPC_FLOAT : nvapi.h
  • NV_DESKTOP_COLOR_DEPTH_16BPC_FLOAT_HDR : nvapi.h
  • NV_DESKTOP_COLOR_DEPTH_16BPC_FLOAT_WCG : nvapi.h
  • NV_DESKTOP_COLOR_DEPTH_8BPC : nvapi.h
  • NV_DESKTOP_COLOR_DEPTH_DEFAULT : nvapi.h
  • NV_DESKTOP_COLOR_DEPTH_MAX_VALUE : nvapi.h
  • NV_DISPLAY_DRIVER_INFO : nvapi.h
  • NV_DISPLAY_DRIVER_INFO_V1 : nvapi.h
  • NV_DISPLAY_DRIVER_INFO_V2 : nvapi.h
  • NV_DISPLAY_DRIVER_INFO_VER : nvapi.h
  • NV_DISPLAY_DRIVER_INFO_VER1 : nvapi.h
  • NV_DISPLAY_DRIVER_INFO_VER2 : nvapi.h
  • NV_DISPLAY_DRIVER_MEMORY_INFO : nvapi_lite_common.h
  • NV_DISPLAY_DRIVER_MEMORY_INFO_VER : nvapi_lite_common.h
  • NV_DISPLAY_DRIVER_MEMORY_INFO_VER_1 : nvapi_lite_common.h
  • NV_DISPLAY_DRIVER_MEMORY_INFO_VER_2 : nvapi_lite_common.h
  • NV_DISPLAY_DRIVER_MEMORY_INFO_VER_3 : nvapi_lite_common.h
  • NV_DISPLAY_DRIVER_VERSION_VER : nvapi.h
  • NV_DISPLAY_OUTPUT_MODE : nvapi.h
  • NV_DISPLAY_OUTPUT_MODE_HDR10 : nvapi.h
  • NV_DISPLAY_OUTPUT_MODE_HDR10PLUS_GAMING : nvapi.h
  • NV_DISPLAY_OUTPUT_MODE_SDR : nvapi.h
  • NV_DISPLAY_PATH_INFO_VER : nvapi.h
  • NV_DISPLAY_PATH_INFO_VER1 : nvapi.h
  • NV_DISPLAY_PATH_INFO_VER2 : nvapi.h
  • NV_DISPLAY_PATH_INFO_VER3 : nvapi.h
  • NV_DISPLAY_PATH_INFO_VER4 : nvapi.h
  • NV_DISPLAY_PORT_CONFIG_VER : nvapi.h
  • NV_DISPLAY_PORT_CONFIG_VER_1 : nvapi.h
  • NV_DISPLAY_PORT_CONFIG_VER_2 : nvapi.h
  • NV_DISPLAY_PORT_INFO : nvapi.h
  • NV_DISPLAY_PORT_INFO_V1 : nvapi.h
  • NV_DISPLAY_PORT_INFO_VER : nvapi.h
  • NV_DISPLAY_PORT_INFO_VER1 : nvapi.h
  • NV_DISPLAY_PORT_INFO_VER2 : nvapi.h
  • NV_DISPLAY_TV_FORMAT : nvapi.h
  • NV_DISPLAY_TV_FORMAT_ANY : nvapi.h
  • NV_DISPLAY_TV_FORMAT_ED_480p : nvapi.h
  • NV_DISPLAY_TV_FORMAT_ED_576p : nvapi.h
  • NV_DISPLAY_TV_FORMAT_ED_OTHER : nvapi.h
  • NV_DISPLAY_TV_FORMAT_HD_1080i : nvapi.h
  • NV_DISPLAY_TV_FORMAT_HD_1080i50 : nvapi.h
  • NV_DISPLAY_TV_FORMAT_HD_1080p : nvapi.h
  • NV_DISPLAY_TV_FORMAT_HD_1080p24 : nvapi.h
  • NV_DISPLAY_TV_FORMAT_HD_1080p50 : nvapi.h
  • NV_DISPLAY_TV_FORMAT_HD_720p : nvapi.h
  • NV_DISPLAY_TV_FORMAT_HD_720p50 : nvapi.h
  • NV_DISPLAY_TV_FORMAT_HD_OTHER : nvapi.h
  • NV_DISPLAY_TV_FORMAT_NONE : nvapi.h
  • NV_DISPLAY_TV_FORMAT_SD_480i : nvapi.h
  • NV_DISPLAY_TV_FORMAT_SD_576i : nvapi.h
  • NV_DISPLAY_TV_FORMAT_SD_NTSCJ : nvapi.h
  • NV_DISPLAY_TV_FORMAT_SD_NTSCM : nvapi.h
  • NV_DISPLAY_TV_FORMAT_SD_OTHER : nvapi.h
  • NV_DISPLAY_TV_FORMAT_SD_PALBDGH : nvapi.h
  • NV_DISPLAY_TV_FORMAT_SD_PALM : nvapi.h
  • NV_DISPLAY_TV_FORMAT_SD_PALN : nvapi.h
  • NV_DISPLAY_TV_FORMAT_SD_PALNC : nvapi.h
  • NV_DISPLAY_TV_FORMAT_UHD_10Kp100_10240 : nvapi.h
  • NV_DISPLAY_TV_FORMAT_UHD_10Kp120_10240 : nvapi.h
  • NV_DISPLAY_TV_FORMAT_UHD_10Kp24_10240 : nvapi.h
  • NV_DISPLAY_TV_FORMAT_UHD_10Kp25_10240 : nvapi.h
  • NV_DISPLAY_TV_FORMAT_UHD_10Kp30_10240 : nvapi.h
  • NV_DISPLAY_TV_FORMAT_UHD_10Kp48_10240 : nvapi.h
  • NV_DISPLAY_TV_FORMAT_UHD_10Kp50_10240 : nvapi.h
  • NV_DISPLAY_TV_FORMAT_UHD_10Kp60_10240 : nvapi.h
  • NV_DISPLAY_TV_FORMAT_UHD_4Kp100_3840 : nvapi.h
  • NV_DISPLAY_TV_FORMAT_UHD_4Kp100_4096 : nvapi.h
  • NV_DISPLAY_TV_FORMAT_UHD_4Kp100_5120 : nvapi.h
  • NV_DISPLAY_TV_FORMAT_UHD_4Kp120_3840 : nvapi.h
  • NV_DISPLAY_TV_FORMAT_UHD_4Kp120_4096 : nvapi.h
  • NV_DISPLAY_TV_FORMAT_UHD_4Kp120_5120 : nvapi.h
  • NV_DISPLAY_TV_FORMAT_UHD_4Kp24 : nvapi.h
  • NV_DISPLAY_TV_FORMAT_UHD_4Kp24_3840 : nvapi.h
  • NV_DISPLAY_TV_FORMAT_UHD_4Kp24_4096 : nvapi.h
  • NV_DISPLAY_TV_FORMAT_UHD_4Kp24_5120 : nvapi.h
  • NV_DISPLAY_TV_FORMAT_UHD_4Kp24_SMPTE : nvapi.h
  • NV_DISPLAY_TV_FORMAT_UHD_4Kp25 : nvapi.h
  • NV_DISPLAY_TV_FORMAT_UHD_4Kp25_3840 : nvapi.h
  • NV_DISPLAY_TV_FORMAT_UHD_4Kp25_4096 : nvapi.h
  • NV_DISPLAY_TV_FORMAT_UHD_4Kp25_5120 : nvapi.h
  • NV_DISPLAY_TV_FORMAT_UHD_4Kp30 : nvapi.h
  • NV_DISPLAY_TV_FORMAT_UHD_4Kp30_3840 : nvapi.h
  • NV_DISPLAY_TV_FORMAT_UHD_4Kp30_4096 : nvapi.h
  • NV_DISPLAY_TV_FORMAT_UHD_4Kp30_5120 : nvapi.h
  • NV_DISPLAY_TV_FORMAT_UHD_4Kp48_3840 : nvapi.h
  • NV_DISPLAY_TV_FORMAT_UHD_4Kp48_4096 : nvapi.h
  • NV_DISPLAY_TV_FORMAT_UHD_4Kp48_5120 : nvapi.h
  • NV_DISPLAY_TV_FORMAT_UHD_4Kp50_3840 : nvapi.h
  • NV_DISPLAY_TV_FORMAT_UHD_4Kp50_4096 : nvapi.h
  • NV_DISPLAY_TV_FORMAT_UHD_4Kp50_5120 : nvapi.h
  • NV_DISPLAY_TV_FORMAT_UHD_4Kp60_3840 : nvapi.h
  • NV_DISPLAY_TV_FORMAT_UHD_4Kp60_4096 : nvapi.h
  • NV_DISPLAY_TV_FORMAT_UHD_4Kp60_5120 : nvapi.h
  • NV_DISPLAY_TV_FORMAT_UHD_8Kp100_7680 : nvapi.h
  • NV_DISPLAY_TV_FORMAT_UHD_8Kp120_7680 : nvapi.h
  • NV_DISPLAY_TV_FORMAT_UHD_8Kp24_7680 : nvapi.h
  • NV_DISPLAY_TV_FORMAT_UHD_8Kp25_7680 : nvapi.h
  • NV_DISPLAY_TV_FORMAT_UHD_8Kp30_7680 : nvapi.h
  • NV_DISPLAY_TV_FORMAT_UHD_8Kp48_7680 : nvapi.h
  • NV_DISPLAY_TV_FORMAT_UHD_8Kp50_7680 : nvapi.h
  • NV_DISPLAY_TV_FORMAT_UHD_8Kp60_7680 : nvapi.h
  • NV_DISPLAYCONFIG_DRIVER_RELOAD_ALLOWED : nvapi.h
  • NV_DISPLAYCONFIG_FLAGS : nvapi.h
  • NV_DISPLAYCONFIG_FORCE_MODE_ENUMERATION : nvapi.h
  • NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO : nvapi.h
  • NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_V1 : nvapi.h
  • NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_VER : nvapi.h
  • NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_VER1 : nvapi.h
  • NV_DISPLAYCONFIG_PATH_INFO : nvapi.h
  • NV_DISPLAYCONFIG_PATH_INFO_V1 : nvapi.h
  • NV_DISPLAYCONFIG_PATH_INFO_V2 : nvapi.h
  • NV_DISPLAYCONFIG_PATH_INFO_VER : nvapi.h
  • NV_DISPLAYCONFIG_PATH_INFO_VER1 : nvapi.h
  • NV_DISPLAYCONFIG_PATH_INFO_VER2 : nvapi.h
  • NV_DISPLAYCONFIG_PATH_TARGET_INFO : nvapi.h
  • NV_DISPLAYCONFIG_PATH_TARGET_INFO_V1 : nvapi.h
  • NV_DISPLAYCONFIG_PATH_TARGET_INFO_V2 : nvapi.h
  • NV_DISPLAYCONFIG_SAVE_TO_PERSISTENCE : nvapi.h
  • NV_DISPLAYCONFIG_SOURCE_MODE_INFO : nvapi.h
  • NV_DISPLAYCONFIG_SOURCE_MODE_INFO_V1 : nvapi.h
  • NV_DISPLAYCONFIG_SPAN_HORIZONTAL : nvapi.h
  • NV_DISPLAYCONFIG_SPAN_NONE : nvapi.h
  • NV_DISPLAYCONFIG_SPAN_VERTICAL : nvapi.h
  • NV_DISPLAYCONFIG_SPANNING_ORIENTATION : nvapi.h
  • NV_DISPLAYCONFIG_VALIDATE_ONLY : nvapi.h
  • NV_DOMAIN_SHADER_PSO_EXTENSION_DESC_VER : nvapi.h
  • NV_DOMAIN_SHADER_PSO_EXTENSION_DESC_VER_1 : nvapi.h
  • NV_DOMAIN_SHADER_PSO_EXTENSION_DESC_VER_2 : nvapi.h
  • NV_DOMAIN_SHADER_PSO_EXTENSION_DESC_VER_3 : nvapi.h
  • NV_DP_1_62GBPS : nvapi.h
  • NV_DP_1_LANE : nvapi.h
  • NV_DP_2_70GBPS : nvapi.h
  • NV_DP_2_LANE : nvapi.h
  • NV_DP_4_LANE : nvapi.h
  • NV_DP_5_40GBPS : nvapi.h
  • NV_DP_8_10GBPS : nvapi.h
  • NV_DP_BPC : nvapi.h
  • NV_DP_BPC_10 : nvapi.h
  • NV_DP_BPC_12 : nvapi.h
  • NV_DP_BPC_16 : nvapi.h
  • NV_DP_BPC_6 : nvapi.h
  • NV_DP_BPC_8 : nvapi.h
  • NV_DP_BPC_DEFAULT : nvapi.h
  • NV_DP_COLOR_FORMAT : nvapi.h
  • NV_DP_COLOR_FORMAT_RGB : nvapi.h
  • NV_DP_COLOR_FORMAT_YCbCr422 : nvapi.h
  • NV_DP_COLOR_FORMAT_YCbCr444 : nvapi.h
  • NV_DP_COLORIMETRY : nvapi.h
  • NV_DP_COLORIMETRY_RGB : nvapi.h
  • NV_DP_COLORIMETRY_YCbCr_ITU601 : nvapi.h
  • NV_DP_COLORIMETRY_YCbCr_ITU709 : nvapi.h
  • NV_DP_DYNAMIC_RANGE : nvapi.h
  • NV_DP_DYNAMIC_RANGE_CEA : nvapi.h
  • NV_DP_DYNAMIC_RANGE_VESA : nvapi.h
  • NV_DP_LANE_COUNT : nvapi.h
  • NV_DP_LINK_RATE : nvapi.h
  • NV_DX_VIDEO_STEREO_INFO : nvapi.h
  • NV_DX_VIDEO_STEREO_INFO_VER : nvapi.h
  • NV_DYNAMIC_RANGE : nvapi.h
  • NV_DYNAMIC_RANGE_AUTO : nvapi.h
  • NV_DYNAMIC_RANGE_CEA : nvapi.h
  • NV_DYNAMIC_RANGE_VESA : nvapi.h
  • NV_ECC_CONFIGURATION : nvapi.h
  • NV_ECC_CONFIGURATION_DEFERRED : nvapi.h
  • NV_ECC_CONFIGURATION_IMMEDIATE : nvapi.h
  • NV_ECC_CONFIGURATION_NOT_SUPPORTED : nvapi.h
  • NV_EDID : nvapi.h
  • NV_EDID_DATA : nvapi.h
  • NV_EDID_DATA_SIZE : nvapi.h
  • NV_EDID_DATA_SIZE_MAX : nvapi.h
  • NV_EDID_DATA_V1 : nvapi.h
  • NV_EDID_DATA_V2 : nvapi.h
  • NV_EDID_DATA_VER : nvapi.h
  • NV_EDID_DATA_VER1 : nvapi.h
  • NV_EDID_DATA_VER2 : nvapi.h
  • NV_EDID_FLAG : nvapi.h
  • NV_EDID_FLAG_COOKED : nvapi.h
  • NV_EDID_FLAG_DEFAULT : nvapi.h
  • NV_EDID_FLAG_FORCED : nvapi.h
  • NV_EDID_FLAG_HW : nvapi.h
  • NV_EDID_FLAG_INF : nvapi.h
  • NV_EDID_FLAG_RAW : nvapi.h
  • NV_EDID_V1_DATA_SIZE : nvapi.h
  • NV_EDID_VER : nvapi.h
  • NV_EDID_VER1 : nvapi.h
  • NV_EDID_VER2 : nvapi.h
  • NV_EDID_VER3 : nvapi.h
  • NV_EDP_2_16GBPS : nvapi.h
  • NV_EDP_2_43GBPS : nvapi.h
  • NV_EDP_3_24GBPS : nvapi.h
  • NV_EDP_4_32GBPS : nvapi.h
  • NV_ENABLE_DEPTH_BOUND_TEST_PSO_EXTENSION_DESC_VER : nvapi.h
  • NV_ENABLE_DEPTH_BOUND_TEST_PSO_EXTENSION_DESC_VER_1 : nvapi.h
  • NV_EVENT_REGISTER_CALLBACK_VERSION : nvapi.h
  • NV_EVENT_TYPE : nvapi.h
  • NV_EVENT_TYPE_NONE : nvapi.h
  • NV_EVENT_TYPE_QSYNC : nvapi.h
  • NV_EXTN_ATOM_ADD : nvHLSLExtnsInternal.h
  • NV_EXTN_ATOM_AND : nvHLSLExtnsInternal.h
  • NV_EXTN_ATOM_CAS : nvHLSLExtnsInternal.h
  • NV_EXTN_ATOM_MAX : nvHLSLExtnsInternal.h
  • NV_EXTN_ATOM_MIN : nvHLSLExtnsInternal.h
  • NV_EXTN_ATOM_OR : nvHLSLExtnsInternal.h
  • NV_EXTN_ATOM_SWAP : nvHLSLExtnsInternal.h
  • NV_EXTN_ATOM_XOR : nvHLSLExtnsInternal.h
  • NV_EXTN_FOOTPRINT_MODE_COARSE : nvShaderExtnEnums.h
  • NV_EXTN_FOOTPRINT_MODE_FINE : nvShaderExtnEnums.h
  • NV_EXTN_OP_FOOTPRINT : nvShaderExtnEnums.h
  • NV_EXTN_OP_FOOTPRINT_BIAS : nvShaderExtnEnums.h
  • NV_EXTN_OP_FOOTPRINT_GRAD : nvShaderExtnEnums.h
  • NV_EXTN_OP_FOOTPRINT_LEVEL : nvShaderExtnEnums.h
  • NV_EXTN_OP_FP16_ATOMIC : nvShaderExtnEnums.h
  • NV_EXTN_OP_FP32_ATOMIC : nvShaderExtnEnums.h
  • NV_EXTN_OP_GET_LANE_ID : nvShaderExtnEnums.h
  • NV_EXTN_OP_GET_SHADING_RATE : nvShaderExtnEnums.h
  • NV_EXTN_OP_GET_SPECIAL : nvShaderExtnEnums.h
  • NV_EXTN_OP_HIT_OBJECT_GET_ATTRIBUTES : nvShaderExtnEnums.h
  • NV_EXTN_OP_HIT_OBJECT_GET_GEOMETRY_INDEX : nvShaderExtnEnums.h
  • NV_EXTN_OP_HIT_OBJECT_GET_HIT_KIND : nvShaderExtnEnums.h
  • NV_EXTN_OP_HIT_OBJECT_GET_INSTANCE_ID : nvShaderExtnEnums.h
  • NV_EXTN_OP_HIT_OBJECT_GET_INSTANCE_INDEX : nvShaderExtnEnums.h
  • NV_EXTN_OP_HIT_OBJECT_GET_PRIMITIVE_INDEX : nvShaderExtnEnums.h
  • NV_EXTN_OP_HIT_OBJECT_GET_RAY_DESC : nvShaderExtnEnums.h
  • NV_EXTN_OP_HIT_OBJECT_GET_SHADER_TABLE_INDEX : nvShaderExtnEnums.h
  • NV_EXTN_OP_HIT_OBJECT_INVOKE : nvShaderExtnEnums.h
  • NV_EXTN_OP_HIT_OBJECT_IS_HIT : nvShaderExtnEnums.h
  • NV_EXTN_OP_HIT_OBJECT_IS_MISS : nvShaderExtnEnums.h
  • NV_EXTN_OP_HIT_OBJECT_IS_NOP : nvShaderExtnEnums.h
  • NV_EXTN_OP_HIT_OBJECT_LOAD_LOCAL_ROOT_TABLE_CONSTANT : nvShaderExtnEnums.h
  • NV_EXTN_OP_HIT_OBJECT_MAKE_HIT : nvShaderExtnEnums.h
  • NV_EXTN_OP_HIT_OBJECT_MAKE_HIT_WITH_RECORD_INDEX : nvShaderExtnEnums.h
  • NV_EXTN_OP_HIT_OBJECT_MAKE_MISS : nvShaderExtnEnums.h
  • NV_EXTN_OP_HIT_OBJECT_MAKE_NOP : nvShaderExtnEnums.h
  • NV_EXTN_OP_HIT_OBJECT_REORDER_THREAD : nvShaderExtnEnums.h
  • NV_EXTN_OP_HIT_OBJECT_TRACE_RAY : nvShaderExtnEnums.h
  • NV_EXTN_OP_MATCH_ANY : nvShaderExtnEnums.h
  • NV_EXTN_OP_RT_IS_BACK_FACING : nvShaderExtnEnums.h
  • NV_EXTN_OP_RT_IS_MICRO_TRIANGLE_HIT : nvShaderExtnEnums.h
  • NV_EXTN_OP_RT_MICRO_TRIANGLE_BARYCENTRICS : nvShaderExtnEnums.h
  • NV_EXTN_OP_RT_MICRO_TRIANGLE_OBJECT_POSITIONS : nvShaderExtnEnums.h
  • NV_EXTN_OP_RT_MICRO_VERTEX_BARYCENTRICS : nvShaderExtnEnums.h
  • NV_EXTN_OP_RT_MICRO_VERTEX_OBJECT_POSITION : nvShaderExtnEnums.h
  • NV_EXTN_OP_RT_TRIANGLE_OBJECT_POSITIONS : nvShaderExtnEnums.h
  • NV_EXTN_OP_SHFL : nvShaderExtnEnums.h
  • NV_EXTN_OP_SHFL_DOWN : nvShaderExtnEnums.h
  • NV_EXTN_OP_SHFL_GENERIC : nvShaderExtnEnums.h
  • NV_EXTN_OP_SHFL_UP : nvShaderExtnEnums.h
  • NV_EXTN_OP_SHFL_XOR : nvShaderExtnEnums.h
  • NV_EXTN_OP_UINT64_ATOMIC : nvShaderExtnEnums.h
  • NV_EXTN_OP_VOTE_ALL : nvShaderExtnEnums.h
  • NV_EXTN_OP_VOTE_ANY : nvShaderExtnEnums.h
  • NV_EXTN_OP_VOTE_BALLOT : nvShaderExtnEnums.h
  • NV_EXTN_OP_VPRS_EVAL_ATTRIB_AT_SAMPLE : nvShaderExtnEnums.h
  • NV_EXTN_OP_VPRS_EVAL_ATTRIB_SNAPPED : nvShaderExtnEnums.h
  • NV_EXTN_TEXTURE_1D : nvShaderExtnEnums.h
  • NV_EXTN_TEXTURE_1D_ARRAY : nvShaderExtnEnums.h
  • NV_EXTN_TEXTURE_2D : nvShaderExtnEnums.h
  • NV_EXTN_TEXTURE_2D_ARRAY : nvShaderExtnEnums.h
  • NV_EXTN_TEXTURE_3D : nvShaderExtnEnums.h
  • NV_EXTN_TEXTURE_CUBE : nvShaderExtnEnums.h
  • NV_EXTN_TEXTURE_CUBE_ARRAY : nvShaderExtnEnums.h
  • NV_FALSE : nvapi_lite_common.h
  • NV_FAST_GEOMETRY_SHADER_PSO_EXTENSION_VER : nvapi.h
  • NV_FAST_GEOMETRY_SHADER_PSO_EXTENSION_VER_1 : nvapi.h
  • NV_FASTGS_EXPLICIT_PSO_EXTENSION_VER : nvapi.h
  • NV_FASTGS_EXPLICIT_PSO_EXTENSION_VER_1 : nvapi.h
  • NV_FASTGS_FLAGS : nvapi.h
  • NV_FASTGS_OFFSET_RT_INDEX_BY_VP_INDEX : nvapi.h
  • NV_FASTGS_STRICT_API_ORDER : nvapi.h
  • NV_FASTGS_USE_VIEWPORT_MASK : nvapi.h
  • NV_FORCE_COMMIT_VIDPN : nvapi.h
  • NV_FORMAT : nvapi.h
  • NV_FORMAT_A16B16G16R16F : nvapi.h
  • NV_FORMAT_A8R8G8B8 : nvapi.h
  • NV_FORMAT_P8 : nvapi.h
  • NV_FORMAT_R5G6B5 : nvapi.h
  • NV_FORMAT_UNKNOWN : nvapi.h
  • NV_FOVEATED_RENDERING_CUSTOM_FOVEATION_PATTERN_PRESET_DESC : nvapi.h
  • NV_FOVEATED_RENDERING_CUSTOM_FOVEATION_PATTERN_PRESET_DESC_V1 : nvapi.h
  • NV_FOVEATED_RENDERING_CUSTOM_FOVEATION_PATTERN_PRESET_DESC_VER : nvapi.h
  • NV_FOVEATED_RENDERING_CUSTOM_FOVEATION_PATTERN_PRESET_DESC_VER1 : nvapi.h
  • NV_FOVEATED_RENDERING_CUSTOM_SHADING_RATE_PRESET_DESC : nvapi.h
  • NV_FOVEATED_RENDERING_CUSTOM_SHADING_RATE_PRESET_DESC_V1 : nvapi.h
  • NV_FOVEATED_RENDERING_CUSTOM_SHADING_RATE_PRESET_DESC_VER : nvapi.h
  • NV_FOVEATED_RENDERING_CUSTOM_SHADING_RATE_PRESET_DESC_VER1 : nvapi.h
  • NV_FOVEATED_RENDERING_DESC : nvapi.h
  • NV_FOVEATED_RENDERING_DESC_V1 : nvapi.h
  • NV_FOVEATED_RENDERING_DESC_VER : nvapi.h
  • NV_FOVEATED_RENDERING_DESC_VER1 : nvapi.h
  • NV_FOVEATED_RENDERING_FOVEATION_PATTERN_PRESET : nvapi.h
  • NV_FOVEATED_RENDERING_FOVEATION_PATTERN_PRESET_BALANCED : nvapi.h
  • NV_FOVEATED_RENDERING_FOVEATION_PATTERN_PRESET_CUSTOM : nvapi.h
  • NV_FOVEATED_RENDERING_FOVEATION_PATTERN_PRESET_INVALID : nvapi.h
  • NV_FOVEATED_RENDERING_FOVEATION_PATTERN_PRESET_MAX : nvapi.h
  • NV_FOVEATED_RENDERING_FOVEATION_PATTERN_PRESET_NARROW : nvapi.h
  • NV_FOVEATED_RENDERING_FOVEATION_PATTERN_PRESET_WIDE : nvapi.h
  • NV_FOVEATED_RENDERING_GAZE_DATA_PER_EYE : nvapi.h
  • NV_FOVEATED_RENDERING_GAZE_DATA_PER_EYE_V1 : nvapi.h
  • NV_FOVEATED_RENDERING_GAZE_DATA_PER_EYE_VER : nvapi.h
  • NV_FOVEATED_RENDERING_GAZE_DATA_PER_EYE_VER1 : nvapi.h
  • NV_FOVEATED_RENDERING_SHADING_RATE_PRESET : nvapi.h
  • NV_FOVEATED_RENDERING_SHADING_RATE_PRESET_BALANCED : nvapi.h
  • NV_FOVEATED_RENDERING_SHADING_RATE_PRESET_CUSTOM : nvapi.h
  • NV_FOVEATED_RENDERING_SHADING_RATE_PRESET_HIGH_PERFORMANCE : nvapi.h
  • NV_FOVEATED_RENDERING_SHADING_RATE_PRESET_HIGH_QUALITY : nvapi.h
  • NV_FOVEATED_RENDERING_SHADING_RATE_PRESET_HIGHEST_PERFORMANCE : nvapi.h
  • NV_FOVEATED_RENDERING_SHADING_RATE_PRESET_HIGHEST_QUALITY : nvapi.h
  • NV_FOVEATED_RENDERING_SHADING_RATE_PRESET_INVALID : nvapi.h
  • NV_FOVEATED_RENDERING_SHADING_RATE_PRESET_MAX : nvapi.h
  • NV_FOVEATED_RENDERING_UPDATE_GAZE_DATA_PARAMS : nvapi.h
  • NV_FOVEATED_RENDERING_UPDATE_GAZE_DATA_PARAMS_V1 : nvapi.h
  • NV_FOVEATED_RENDERING_UPDATE_GAZE_DATA_PARAMS_VER : nvapi.h
  • NV_FOVEATED_RENDERING_UPDATE_GAZE_DATA_PARAMS_VER1 : nvapi.h
  • NV_FRUSTUM_ADJUST_MODE : nvapi.h
  • NV_GAZE_DATA_INVALID : nvapi.h
  • NV_GAZE_DATA_MAX : nvapi.h
  • NV_GAZE_DATA_MONO : nvapi.h
  • NV_GAZE_DATA_STEREO : nvapi.h
  • NV_GAZE_DATA_TYPE : nvapi.h
  • NV_GAZE_DATA_VALIDITY_FLAGS : nvapi.h
  • NV_GAZE_DIRECTION_VALID : nvapi.h
  • NV_GAZE_EYE_OPENNESS_VALID : nvapi.h
  • NV_GAZE_EYE_SACCADE_DATA_VALID : nvapi.h
  • NV_GAZE_HANDLER_INIT_PARAMS : nvapi.h
  • NV_GAZE_HANDLER_INIT_PARAMS_V1 : nvapi.h
  • NV_GAZE_HANDLER_INIT_PARAMS_V2 : nvapi.h
  • NV_GAZE_HANDLER_INIT_PARAMS_VER : nvapi.h
  • NV_GAZE_HANDLER_INIT_PARAMS_VER1 : nvapi.h
  • NV_GAZE_HANDLER_INIT_PARAMS_VER2 : nvapi.h
  • NV_GAZE_LOCATION_VALID : nvapi.h
  • NV_GAZE_ORIGIN_VALID : nvapi.h
  • NV_GAZE_PUPIL_DIAMETER_VALID : nvapi.h
  • NV_GAZE_VELOCITY_VALID : nvapi.h
  • NV_GENERIC_ATTRIBUTE_SEMANTIC : nvapi.h
  • NV_GEOMETRY_SHADER_PSO_EXTENSION_DESC_VER : nvapi.h
  • NV_GEOMETRY_SHADER_PSO_EXTENSION_DESC_VER_5 : nvapi.h
  • NV_GET_ADAPTIVE_SYNC_DATA : nvapi.h
  • NV_GET_ADAPTIVE_SYNC_DATA_V1 : nvapi.h
  • NV_GET_ADAPTIVE_SYNC_DATA_VER : nvapi.h
  • NV_GET_ADAPTIVE_SYNC_DATA_VER1 : nvapi.h
  • NV_GET_CURRENT_SLI_STATE : nvapi_lite_sli.h
  • NV_GET_CURRENT_SLI_STATE_VER : nvapi_lite_sli.h
  • NV_GET_CURRENT_SLI_STATE_VER1 : nvapi_lite_sli.h
  • NV_GET_CURRENT_SLI_STATE_VER2 : nvapi_lite_sli.h
  • NV_GET_GPU_VIRTUAL_ADDRESS : nvapi.h
  • NV_GET_GPU_VIRTUAL_ADDRESS_VER : nvapi.h
  • NV_GET_GPU_VIRTUAL_ADDRESS_VER1 : nvapi.h
  • NV_GET_PREFERRED_STEREO_DISPLAY : nvapi.h
  • NV_GET_PREFERRED_STEREO_DISPLAY_VER : nvapi.h
  • NV_GET_PREFERRED_STEREO_DISPLAY_VER1 : nvapi.h
  • NV_GET_SLEEP_STATUS_PARAMS : nvapi.h
  • NV_GET_SLEEP_STATUS_PARAMS_V1 : nvapi.h
  • NV_GET_SLEEP_STATUS_PARAMS_VER : nvapi.h
  • NV_GET_SLEEP_STATUS_PARAMS_VER1 : nvapi.h
  • NV_GET_VIRTUAL_REFRESH_RATE_DATA : nvapi.h
  • NV_GET_VIRTUAL_REFRESH_RATE_DATA_V1 : nvapi.h
  • NV_GET_VIRTUAL_REFRESH_RATE_DATA_VER : nvapi.h
  • NV_GET_VIRTUAL_REFRESH_RATE_DATA_VER1 : nvapi.h
  • NV_GET_VRR_INFO : nvapi.h
  • NV_GET_VRR_INFO_V1 : nvapi.h
  • NV_GET_VRR_INFO_VER : nvapi.h
  • NV_GET_VRR_INFO_VER1 : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_AD102 : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_AD103 : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_AD104 : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_G84 : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_G86 : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_G92 : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_G94 : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_G96 : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_G98 : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_GA100 : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_GA102 : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_GA104 : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_GF100 : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_GF104 : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_GF106 : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_GF108 : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_GF110 : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_GF116 : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_GF117 : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_GF118 : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_GF119 : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_GK104 : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_GK106 : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_GK107 : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_GK110 : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_GK208 : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_GK20A : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_GM204 : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_GM206 : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_GP000 : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_GP100 : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_GP102 : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_GP104 : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_GP106 : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_GP107 : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_GP108 : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_GT200 : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_GT212 : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_GT214 : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_GT215 : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_GT216 : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_GT218 : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_GT21A : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_GT21C : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_GV100 : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_GV10B : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_ID : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_MCP77 : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_MCP79 : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_MCP89 : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_NV40 : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_NV41 : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_NV42 : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_NV43 : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_NV44 : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_NV44A : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_NV46 : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_NV47 : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_NV49 : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_NV4B : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_NV4C : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_NV4E : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_NV50 : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_NV63 : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_NV67 : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_T124 : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_T20 : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_T30 : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_T35 : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_T40 : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_TU000 : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_TU100 : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_TU102 : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_TU104 : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_TU106 : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_TU116 : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_TU117 : nvapi.h
  • NV_GPU_ARCH_INFO : nvapi.h
  • NV_GPU_ARCH_INFO_VER : nvapi.h
  • NV_GPU_ARCH_INFO_VER_1 : nvapi.h
  • NV_GPU_ARCH_INFO_VER_2 : nvapi.h
  • NV_GPU_ARCHITECTURE_AD100 : nvapi.h
  • NV_GPU_ARCHITECTURE_G78 : nvapi.h
  • NV_GPU_ARCHITECTURE_G80 : nvapi.h
  • NV_GPU_ARCHITECTURE_G90 : nvapi.h
  • NV_GPU_ARCHITECTURE_GA100 : nvapi.h
  • NV_GPU_ARCHITECTURE_GF100 : nvapi.h
  • NV_GPU_ARCHITECTURE_GF110 : nvapi.h
  • NV_GPU_ARCHITECTURE_GK100 : nvapi.h
  • NV_GPU_ARCHITECTURE_GK110 : nvapi.h
  • NV_GPU_ARCHITECTURE_GK200 : nvapi.h
  • NV_GPU_ARCHITECTURE_GM000 : nvapi.h
  • NV_GPU_ARCHITECTURE_GM200 : nvapi.h
  • NV_GPU_ARCHITECTURE_GP100 : nvapi.h
  • NV_GPU_ARCHITECTURE_GT200 : nvapi.h
  • NV_GPU_ARCHITECTURE_GV100 : nvapi.h
  • NV_GPU_ARCHITECTURE_GV110 : nvapi.h
  • NV_GPU_ARCHITECTURE_ID : nvapi.h
  • NV_GPU_ARCHITECTURE_NV40 : nvapi.h
  • NV_GPU_ARCHITECTURE_NV50 : nvapi.h
  • NV_GPU_ARCHITECTURE_T12X : nvapi.h
  • NV_GPU_ARCHITECTURE_T2X : nvapi.h
  • NV_GPU_ARCHITECTURE_T3X : nvapi.h
  • NV_GPU_ARCHITECTURE_T4X : nvapi.h
  • NV_GPU_ARCHITECTURE_TU100 : nvapi.h
  • NV_GPU_BUS_TYPE : nvapi.h
  • NV_GPU_CHIP_REV_A01 : nvapi.h
  • NV_GPU_CHIP_REV_A02 : nvapi.h
  • NV_GPU_CHIP_REV_A03 : nvapi.h
  • NV_GPU_CHIP_REV_EMULATION_FPGA : nvapi.h
  • NV_GPU_CHIP_REV_EMULATION_QT : nvapi.h
  • NV_GPU_CHIP_REV_UNKNOWN : nvapi.h
  • NV_GPU_CHIP_REVISION : nvapi.h
  • NV_GPU_CLIENT_CALLBACK_DATA_SUPER_V1 : nvapi.h
  • NV_GPU_CLIENT_CALLBACK_SETTINGS_SUPER_V1 : nvapi.h
  • NV_GPU_CLIENT_CALLBACK_UTILIZATION_DATA_V1 : nvapi.h
  • NV_GPU_CLIENT_ILLUM_CTRL_MODE : nvapi.h
  • NV_GPU_CLIENT_ILLUM_CTRL_MODE_INVALID : nvapi.h
  • NV_GPU_CLIENT_ILLUM_CTRL_MODE_MANUAL : nvapi.h
  • NV_GPU_CLIENT_ILLUM_CTRL_MODE_MANUAL_RGB : nvapi.h
  • NV_GPU_CLIENT_ILLUM_CTRL_MODE_PIECEWISE_LINEAR : nvapi.h
  • NV_GPU_CLIENT_ILLUM_CTRL_MODE_PIECEWISE_LINEAR_COLOR_ENDPOINTS : nvapi.h
  • NV_GPU_CLIENT_ILLUM_CTRL_MODE_PIECEWISE_LINEAR_RGB : nvapi.h
  • NV_GPU_CLIENT_ILLUM_DEVICE_CONTROL : nvapi.h
  • NV_GPU_CLIENT_ILLUM_DEVICE_CONTROL_PARAMS : nvapi.h
  • NV_GPU_CLIENT_ILLUM_DEVICE_CONTROL_PARAMS_VER : nvapi.h
  • NV_GPU_CLIENT_ILLUM_DEVICE_CONTROL_PARAMS_VER_1 : nvapi.h
  • NV_GPU_CLIENT_ILLUM_DEVICE_INFO_DATA_GPIO_PWM_RGBW : nvapi.h
  • NV_GPU_CLIENT_ILLUM_DEVICE_INFO_DATA_GPIO_PWM_SINGLE_COLOR : nvapi.h
  • NV_GPU_CLIENT_ILLUM_DEVICE_INFO_DATA_MCUV10 : nvapi.h
  • NV_GPU_CLIENT_ILLUM_DEVICE_INFO_PARAMS : nvapi.h
  • NV_GPU_CLIENT_ILLUM_DEVICE_INFO_PARAMS_V1 : nvapi.h
  • NV_GPU_CLIENT_ILLUM_DEVICE_INFO_PARAMS_VER : nvapi.h
  • NV_GPU_CLIENT_ILLUM_DEVICE_INFO_PARAMS_VER_1 : nvapi.h
  • NV_GPU_CLIENT_ILLUM_DEVICE_INFO_V1 : nvapi.h
  • NV_GPU_CLIENT_ILLUM_DEVICE_NUM_DEVICES_MAX : nvapi.h
  • NV_GPU_CLIENT_ILLUM_DEVICE_TYPE : nvapi.h
  • NV_GPU_CLIENT_ILLUM_DEVICE_TYPE_GPIO_PWM_RGBW_V10 : nvapi.h
  • NV_GPU_CLIENT_ILLUM_DEVICE_TYPE_GPIO_PWM_SINGLE_COLOR_V10 : nvapi.h
  • NV_GPU_CLIENT_ILLUM_DEVICE_TYPE_INVALID : nvapi.h
  • NV_GPU_CLIENT_ILLUM_DEVICE_TYPE_MCUV10 : nvapi.h
  • NV_GPU_CLIENT_ILLUM_PIECEWISE_LINEAR_CYCLE_FULL_HALT : nvapi.h
  • NV_GPU_CLIENT_ILLUM_PIECEWISE_LINEAR_CYCLE_FULL_REPEAT : nvapi.h
  • NV_GPU_CLIENT_ILLUM_PIECEWISE_LINEAR_CYCLE_HALF_HALT : nvapi.h
  • NV_GPU_CLIENT_ILLUM_PIECEWISE_LINEAR_CYCLE_INVALID : nvapi.h
  • NV_GPU_CLIENT_ILLUM_PIECEWISE_LINEAR_CYCLE_TYPE : nvapi.h
  • NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_COLOR_FIXED : nvapi.h
  • NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_COLOR_FIXED : nvapi.h
  • NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_COLOR_FIXED_PARAMS : nvapi.h
  • NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_RGB : nvapi.h
  • NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_RGB_PARAMS : nvapi.h
  • NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_RGBW : nvapi.h
  • NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_RGBW_PARAMS : nvapi.h
  • NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_SINGLE_COLOR : nvapi.h
  • NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_SINGLE_COLOR_PARAMS : nvapi.h
  • NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR : nvapi.h
  • NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR_COLOR_FIXED : nvapi.h
  • NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR_RGB : nvapi.h
  • NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR_RGBW : nvapi.h
  • NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR_SINGLE_COLOR : nvapi.h
  • NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_RGB : nvapi.h
  • NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_RGBW : nvapi.h
  • NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_SINGLE_COLOR : nvapi.h
  • NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_PARAMS : nvapi.h
  • NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_PARAMS_V1 : nvapi.h
  • NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_PARAMS_VER : nvapi.h
  • NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_PARAMS_VER_1 : nvapi.h
  • NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_V1 : nvapi.h
  • NV_GPU_CLIENT_ILLUM_ZONE_INFO_DATA_RGB : nvapi.h
  • NV_GPU_CLIENT_ILLUM_ZONE_INFO_DATA_RGBW : nvapi.h
  • NV_GPU_CLIENT_ILLUM_ZONE_INFO_DATA_SINGLE_COLOR : nvapi.h
  • NV_GPU_CLIENT_ILLUM_ZONE_INFO_PARAMS : nvapi.h
  • NV_GPU_CLIENT_ILLUM_ZONE_INFO_PARAMS_V1 : nvapi.h
  • NV_GPU_CLIENT_ILLUM_ZONE_INFO_PARAMS_VER : nvapi.h
  • NV_GPU_CLIENT_ILLUM_ZONE_INFO_PARAMS_VER_1 : nvapi.h
  • NV_GPU_CLIENT_ILLUM_ZONE_INFO_V1 : nvapi.h
  • NV_GPU_CLIENT_ILLUM_ZONE_LOCATION : nvapi.h
  • NV_GPU_CLIENT_ILLUM_ZONE_LOCATION_GPU_BACK_0 : nvapi.h
  • NV_GPU_CLIENT_ILLUM_ZONE_LOCATION_GPU_FRONT_0 : nvapi.h
  • NV_GPU_CLIENT_ILLUM_ZONE_LOCATION_GPU_TOP_0 : nvapi.h
  • NV_GPU_CLIENT_ILLUM_ZONE_LOCATION_INVALID : nvapi.h
  • NV_GPU_CLIENT_ILLUM_ZONE_LOCATION_SLI_TOP_0 : nvapi.h
  • NV_GPU_CLIENT_ILLUM_ZONE_NUM_ZONES_MAX : nvapi.h
  • NV_GPU_CLIENT_ILLUM_ZONE_TYPE : nvapi.h
  • NV_GPU_CLIENT_ILLUM_ZONE_TYPE_COLOR_FIXED : nvapi.h
  • NV_GPU_CLIENT_ILLUM_ZONE_TYPE_INVALID : nvapi.h
  • NV_GPU_CLIENT_ILLUM_ZONE_TYPE_RGB : nvapi.h
  • NV_GPU_CLIENT_ILLUM_ZONE_TYPE_RGBW : nvapi.h
  • NV_GPU_CLIENT_ILLUM_ZONE_TYPE_SINGLE_COLOR : nvapi.h
  • NV_GPU_CLIENT_PERIODIC_CALLBACK_SETTINGS_SUPER_V1 : nvapi.h
  • NV_GPU_CLIENT_UTIL_DOMAIN_FRAME_BUFFER : nvapi.h
  • NV_GPU_CLIENT_UTIL_DOMAIN_GRAPHICS : nvapi.h
  • NV_GPU_CLIENT_UTIL_DOMAIN_ID : nvapi.h
  • NV_GPU_CLIENT_UTIL_DOMAIN_RSVD : nvapi.h
  • NV_GPU_CLIENT_UTIL_DOMAIN_VIDEO : nvapi.h
  • NV_GPU_CLIENT_UTIL_DOMAINS_MAX_V1 : nvapi.h
  • NV_GPU_CLIENT_UTILIZATION_DATA_V1 : nvapi.h
  • NV_GPU_CLIENT_UTILIZATION_PERIODIC_CALLBACK_SETTINGS : nvapi.h
  • NV_GPU_CLIENT_UTILIZATION_PERIODIC_CALLBACK_SETTINGS_V1 : nvapi.h
  • NV_GPU_CLIENT_UTILIZATION_PERIODIC_CALLBACK_SETTINGS_VER : nvapi.h
  • NV_GPU_CLIENT_UTILIZATION_PERIODIC_CALLBACK_SETTINGS_VER1 : nvapi.h
  • NV_GPU_CLIENT_UTILIZATION_PERIODIC_CALLBACK_V1 : nvapi.h
  • NV_GPU_CLOCK_FREQUENCIES : nvapi.h
  • NV_GPU_CLOCK_FREQUENCIES_BASE_CLOCK : nvapi.h
  • NV_GPU_CLOCK_FREQUENCIES_BOOST_CLOCK : nvapi.h
  • NV_GPU_CLOCK_FREQUENCIES_CLOCK_TYPE : nvapi.h
  • NV_GPU_CLOCK_FREQUENCIES_CLOCK_TYPE_NUM : nvapi.h
  • NV_GPU_CLOCK_FREQUENCIES_CURRENT_FREQ : nvapi.h
  • NV_GPU_CLOCK_FREQUENCIES_VER : nvapi.h
  • NV_GPU_CLOCK_FREQUENCIES_VER_1 : nvapi.h
  • NV_GPU_CLOCK_FREQUENCIES_VER_2 : nvapi.h
  • NV_GPU_CLOCK_FREQUENCIES_VER_3 : nvapi.h
  • NV_GPU_CONNECTED_IDS_FLAG_EXCLUDE_MST : nvapi.h
  • NV_GPU_CONNECTED_IDS_FLAG_FAKE : nvapi.h
  • NV_GPU_CONNECTED_IDS_FLAG_LIDSTATE : nvapi.h
  • NV_GPU_CONNECTED_IDS_FLAG_SLI : nvapi.h
  • NV_GPU_CONNECTED_IDS_FLAG_UNCACHED : nvapi.h
  • NV_GPU_CONNECTOR_TYPE : nvapi.h
  • NV_GPU_DISPLAYIDS : nvapi.h
  • NV_GPU_DISPLAYIDS_VER : nvapi.h
  • NV_GPU_DISPLAYIDS_VER1 : nvapi.h
  • NV_GPU_DISPLAYIDS_VER2 : nvapi.h
  • NV_GPU_DYNAMIC_PSTATES_INFO_EX_VER : nvapi.h
  • NV_GPU_ECC_CONFIGURATION_INFO_VER : nvapi.h
  • NV_GPU_ECC_ERROR_INFO_VER : nvapi.h
  • NV_GPU_ECC_STATUS_INFO_VER : nvapi.h
  • NV_GPU_GET_HDCP_SUPPORT_STATUS_VER : nvapi.h
  • NV_GPU_GET_ILLUMINATION_PARM : nvapi.h
  • NV_GPU_GET_ILLUMINATION_PARM_V1 : nvapi.h
  • NV_GPU_GET_ILLUMINATION_PARM_VER : nvapi.h
  • NV_GPU_GET_ILLUMINATION_PARM_VER_1 : nvapi.h
  • NV_GPU_GSP_INFO : nvapi.h
  • NV_GPU_GSP_INFO_V1 : nvapi.h
  • NV_GPU_GSP_INFO_VER : nvapi.h
  • NV_GPU_GSP_INFO_VER1 : nvapi.h
  • NV_GPU_HDCP_FUSE_STATE : nvapi.h
  • NV_GPU_HDCP_FUSE_STATE_DISABLED : nvapi.h
  • NV_GPU_HDCP_FUSE_STATE_ENABLED : nvapi.h
  • NV_GPU_HDCP_FUSE_STATE_UNKNOWN : nvapi.h
  • NV_GPU_HDCP_KEY_SOURCE : nvapi.h
  • NV_GPU_HDCP_KEY_SOURCE_CRYPTO_ROM : nvapi.h
  • NV_GPU_HDCP_KEY_SOURCE_FUSES : nvapi.h
  • NV_GPU_HDCP_KEY_SOURCE_I2C_ROM : nvapi.h
  • NV_GPU_HDCP_KEY_SOURCE_NONE : nvapi.h
  • NV_GPU_HDCP_KEY_SOURCE_SBIOS : nvapi.h
  • NV_GPU_HDCP_KEY_SOURCE_STATE : nvapi.h
  • NV_GPU_HDCP_KEY_SOURCE_STATE_ABSENT : nvapi.h
  • NV_GPU_HDCP_KEY_SOURCE_STATE_PRESENT : nvapi.h
  • NV_GPU_HDCP_KEY_SOURCE_STATE_UNKNOWN : nvapi.h
  • NV_GPU_HDCP_KEY_SOURCE_UNKNOWN : nvapi.h
  • NV_GPU_IA_LOGO_BRIGHTNESS : nvapi.h
  • NV_GPU_IA_SLI_BRIGHTNESS : nvapi.h
  • NV_GPU_ILLUMINATION_ATTRIB : nvapi.h
  • NV_GPU_INFO : nvapi.h
  • NV_GPU_INFO_V1 : nvapi.h
  • NV_GPU_INFO_V2 : nvapi.h
  • NV_GPU_INFO_VER : nvapi.h
  • NV_GPU_INFO_VER1 : nvapi.h
  • NV_GPU_INFO_VER2 : nvapi.h
  • NV_GPU_MAX_CLOCK_FREQUENCIES : nvapi.h
  • NV_GPU_MEMORY_INFO_EX : nvapi_lite_common.h
  • NV_GPU_MEMORY_INFO_EX_VER : nvapi_lite_common.h
  • NV_GPU_MEMORY_INFO_EX_VER_1 : nvapi_lite_common.h
  • NV_GPU_OUTPUT_TYPE : nvapi.h
  • NV_GPU_PERF_DECREASE_NONE : nvapi.h
  • NV_GPU_PERF_DECREASE_REASON_AC_BATT : nvapi.h
  • NV_GPU_PERF_DECREASE_REASON_API_TRIGGERED : nvapi.h
  • NV_GPU_PERF_DECREASE_REASON_INSUFFICIENT_POWER : nvapi.h
  • NV_GPU_PERF_DECREASE_REASON_POWER_CONTROL : nvapi.h
  • NV_GPU_PERF_DECREASE_REASON_THERMAL_PROTECTION : nvapi.h
  • NV_GPU_PERF_DECREASE_REASON_UNKNOWN : nvapi.h
  • NV_GPU_PERF_PSTATE20_CLOCK_TYPE_ID : nvapi.h
  • NV_GPU_PERF_PSTATE_ID : nvapi.h
  • NV_GPU_PERF_PSTATES20_INFO : nvapi.h
  • NV_GPU_PERF_PSTATES20_INFO_V2 : nvapi.h
  • NV_GPU_PERF_PSTATES20_INFO_VER : nvapi.h
  • NV_GPU_PERF_PSTATES20_INFO_VER1 : nvapi.h
  • NV_GPU_PERF_PSTATES20_INFO_VER2 : nvapi.h
  • NV_GPU_PERF_PSTATES20_INFO_VER3 : nvapi.h
  • NV_GPU_PERF_PSTATES_INFO : nvapi.h
  • NV_GPU_PERF_PSTATES_INFO_VER : nvapi.h
  • NV_GPU_PERF_PSTATES_INFO_VER1 : nvapi.h
  • NV_GPU_PERF_PSTATES_INFO_VER2 : nvapi.h
  • NV_GPU_PERF_PSTATES_INFO_VER3 : nvapi.h
  • NV_GPU_PERF_VOLTAGE_INFO_DOMAIN_ID : nvapi.h
  • NV_GPU_PUBLIC_CLOCK_ID : nvapi.h
  • NV_GPU_QUERY_ILLUMINATION_SUPPORT_PARM : nvapi.h
  • NV_GPU_QUERY_ILLUMINATION_SUPPORT_PARM_V1 : nvapi.h
  • NV_GPU_QUERY_ILLUMINATION_SUPPORT_PARM_VER : nvapi.h
  • NV_GPU_QUERY_ILLUMINATION_SUPPORT_PARM_VER_1 : nvapi.h
  • NV_GPU_SCANOUT_COMPOSITION_PARAMETER : nvapi.h
  • NV_GPU_SCANOUT_COMPOSITION_PARAMETER_SET_TO_DEFAULT : nvapi.h
  • NV_GPU_SCANOUT_COMPOSITION_PARAMETER_VALUE : nvapi.h
  • NV_GPU_SCANOUT_COMPOSITION_PARAMETER_VALUE_WARPING_RESAMPLING_METHOD_BICUBIC_ADAPTIVE_BELL_SHAPED : nvapi.h
  • NV_GPU_SCANOUT_COMPOSITION_PARAMETER_VALUE_WARPING_RESAMPLING_METHOD_BICUBIC_ADAPTIVE_BSPLINE : nvapi.h
  • NV_GPU_SCANOUT_COMPOSITION_PARAMETER_VALUE_WARPING_RESAMPLING_METHOD_BICUBIC_ADAPTIVE_TRIANGULAR : nvapi.h
  • NV_GPU_SCANOUT_COMPOSITION_PARAMETER_VALUE_WARPING_RESAMPLING_METHOD_BICUBIC_BELL_SHAPED : nvapi.h
  • NV_GPU_SCANOUT_COMPOSITION_PARAMETER_VALUE_WARPING_RESAMPLING_METHOD_BICUBIC_BSPLINE : nvapi.h
  • NV_GPU_SCANOUT_COMPOSITION_PARAMETER_VALUE_WARPING_RESAMPLING_METHOD_BICUBIC_TRIANGULAR : nvapi.h
  • NV_GPU_SCANOUT_COMPOSITION_PARAMETER_VALUE_WARPING_RESAMPLING_METHOD_BILINEAR : nvapi.h
  • NV_GPU_SCANOUT_COMPOSITION_PARAMETER_WARPING_RESAMPLING_METHOD : nvapi.h
  • NV_GPU_SET_ILLUMINATION_PARM : nvapi.h
  • NV_GPU_SET_ILLUMINATION_PARM_V1 : nvapi.h
  • NV_GPU_SET_ILLUMINATION_PARM_VER : nvapi.h
  • NV_GPU_SET_ILLUMINATION_PARM_VER_1 : nvapi.h
  • NV_GPU_THERMAL_SETTINGS : nvapi.h
  • NV_GPU_THERMAL_SETTINGS_VER : nvapi.h
  • NV_GPU_THERMAL_SETTINGS_VER_1 : nvapi.h
  • NV_GPU_THERMAL_SETTINGS_VER_2 : nvapi.h
  • NV_GPU_TYPE : nvapi.h
  • NV_GPU_VIRTUALIZATION_INFO : nvapi.h
  • NV_GPU_VIRTUALIZATION_INFO_V1 : nvapi.h
  • NV_GPU_VIRTUALIZATION_INFO_VER : nvapi.h
  • NV_GPU_VIRTUALIZATION_INFO_VER1 : nvapi.h
  • NV_GPU_VR_READY : nvapi.h
  • NV_GPU_VR_READY_V1 : nvapi.h
  • NV_GPU_VR_READY_VER : nvapi.h
  • NV_GPU_VR_READY_VER1 : nvapi.h
  • NV_GPU_WARPING_VERTICE_FORMAT : nvapi.h
  • NV_GPU_WARPING_VERTICE_FORMAT_TRIANGLES_XYUVRQ : nvapi.h
  • NV_GPU_WARPING_VERTICE_FORMAT_TRIANGLESTRIP_XYUVRQ : nvapi.h
  • NV_GPU_WORKSTATION_FEATURE_TYPE : nvapi.h
  • NV_GPU_WORKSTATION_FEATURE_TYPE_NVIDIA_RTX_VR_READY : nvapi.h
  • NV_GPU_WORKSTATION_FEATURE_TYPE_PROVIZ : nvapi.h
  • NV_GPU_WORKSTATION_FEATURE_TYPE_QUADRO_VR_READY : nvapi.h
  • NV_GSYNC_CAPABILITIES : nvapi.h
  • NV_GSYNC_CAPABILITIES_V1 : nvapi.h
  • NV_GSYNC_CAPABILITIES_V2 : nvapi.h
  • NV_GSYNC_CAPABILITIES_V3 : nvapi.h
  • NV_GSYNC_CAPABILITIES_VER : nvapi.h
  • NV_GSYNC_CAPABILITIES_VER1 : nvapi.h
  • NV_GSYNC_CAPABILITIES_VER2 : nvapi.h
  • NV_GSYNC_CAPABILITIES_VER3 : nvapi.h
  • NV_GSYNC_CONTROL_PARAMS : nvapi.h
  • NV_GSYNC_CONTROL_PARAMS_V1 : nvapi.h
  • NV_GSYNC_CONTROL_PARAMS_V2 : nvapi.h
  • NV_GSYNC_CONTROL_PARAMS_VER : nvapi.h
  • NV_GSYNC_CONTROL_PARAMS_VER1 : nvapi.h
  • NV_GSYNC_CONTROL_PARAMS_VER2 : nvapi.h
  • NV_GSYNC_DELAY : nvapi.h
  • NV_GSYNC_DELAY_VER : nvapi.h
  • NV_GSYNC_DISPLAY : nvapi.h
  • NV_GSYNC_DISPLAY_VER : nvapi.h
  • NV_GSYNC_GPU : nvapi.h
  • NV_GSYNC_GPU_VER : nvapi.h
  • NV_GSYNC_STATUS : nvapi.h
  • NV_GSYNC_STATUS_PARAMS : nvapi.h
  • NV_GSYNC_STATUS_PARAMS_V1 : nvapi.h
  • NV_GSYNC_STATUS_PARAMS_V2 : nvapi.h
  • NV_GSYNC_STATUS_PARAMS_VER : nvapi.h
  • NV_GSYNC_STATUS_PARAMS_VER1 : nvapi.h
  • NV_GSYNC_STATUS_PARAMS_VER2 : nvapi.h
  • NV_GSYNC_STATUS_VER : nvapi.h
  • NV_HDMI_SUPPORT_INFO : nvapi.h
  • NV_HDMI_SUPPORT_INFO_V1 : nvapi.h
  • NV_HDMI_SUPPORT_INFO_V2 : nvapi.h
  • NV_HDMI_SUPPORT_INFO_VER : nvapi.h
  • NV_HDMI_SUPPORT_INFO_VER1 : nvapi.h
  • NV_HDMI_SUPPORT_INFO_VER2 : nvapi.h
  • NV_HDR_CAPABILITIES : nvapi.h
  • NV_HDR_CAPABILITIES_V1 : nvapi.h
  • NV_HDR_CAPABILITIES_V2 : nvapi.h
  • NV_HDR_CAPABILITIES_V3 : nvapi.h
  • NV_HDR_CAPABILITIES_VER : nvapi.h
  • NV_HDR_CAPABILITIES_VER1 : nvapi.h
  • NV_HDR_CAPABILITIES_VER2 : nvapi.h
  • NV_HDR_CAPABILITIES_VER3 : nvapi.h
  • NV_HDR_CMD : nvapi.h
  • NV_HDR_CMD_GET : nvapi.h
  • NV_HDR_CMD_SET : nvapi.h
  • NV_HDR_COLOR_DATA : nvapi.h
  • NV_HDR_COLOR_DATA_V1 : nvapi.h
  • NV_HDR_COLOR_DATA_V2 : nvapi.h
  • NV_HDR_COLOR_DATA_VER : nvapi.h
  • NV_HDR_COLOR_DATA_VER1 : nvapi.h
  • NV_HDR_COLOR_DATA_VER2 : nvapi.h
  • NV_HDR_METADATA : nvapi.h
  • NV_HDR_METADATA_V1 : nvapi.h
  • NV_HDR_METADATA_VER : nvapi.h
  • NV_HDR_METADATA_VER1 : nvapi.h
  • NV_HDR_MODE : nvapi.h
  • NV_HDR_MODE_DOLBY_VISION : nvapi.h
  • NV_HDR_MODE_EDR : nvapi.h
  • NV_HDR_MODE_OFF : nvapi.h
  • NV_HDR_MODE_SDR : nvapi.h
  • NV_HDR_MODE_UHDA : nvapi.h
  • NV_HDR_MODE_UHDA_NB : nvapi.h
  • NV_HDR_MODE_UHDA_PASSTHROUGH : nvapi.h
  • NV_HDR_MODE_UHDBD : nvapi.h
  • NV_HDR_TONEMAPPING_APP : nvapi.h
  • NV_HDR_TONEMAPPING_GPU : nvapi.h
  • NV_HDR_TONEMAPPING_METHOD : nvapi.h
  • NV_HEAP_PARAMS : nvapi.h
  • NV_HEAP_PARAMS_V1 : nvapi.h
  • NV_HEAP_PARAMS_VER : nvapi.h
  • NV_HEAP_PARAMS_VER_1 : nvapi.h
  • NV_HULL_SHADER_PSO_EXTENSION_DESC_VER : nvapi.h
  • NV_HULL_SHADER_PSO_EXTENSION_DESC_VER_1 : nvapi.h
  • NV_HULL_SHADER_PSO_EXTENSION_DESC_VER_2 : nvapi.h
  • NV_I2C_INFO : nvapi.h
  • NV_I2C_INFO_VER : nvapi.h
  • NV_I2C_INFO_VER1 : nvapi.h
  • NV_I2C_INFO_VER2 : nvapi.h
  • NV_I2C_INFO_VER3 : nvapi.h
  • NV_I2C_SPEED : nvapi.h
  • NV_INFOFRAME_CMD : nvapi.h
  • NV_INFOFRAME_CMD_GET : nvapi.h
  • NV_INFOFRAME_CMD_GET_DEFAULT : nvapi.h
  • NV_INFOFRAME_CMD_GET_OVERRIDE : nvapi.h
  • NV_INFOFRAME_CMD_GET_PROPERTY : nvapi.h
  • NV_INFOFRAME_CMD_RESET : nvapi.h
  • NV_INFOFRAME_CMD_SET : nvapi.h
  • NV_INFOFRAME_CMD_SET_OVERRIDE : nvapi.h
  • NV_INFOFRAME_CMD_SET_PROPERTY : nvapi.h
  • NV_INFOFRAME_DATA_VER : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_AUTO : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FCH_RC_RR_RL_FC_LFE_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FCH_RC_RR_RL_FC_X_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRC_FLC_RR_RL_FC_LFE_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRC_FLC_RR_RL_FC_X_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRC_FLC_RR_RL_X_LFE_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRC_FLC_RR_RL_X_X_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRC_FLC_X_RC_FC_LFE_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRC_FLC_X_RC_FC_X_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRC_FLC_X_RC_X_LFE_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRC_FLC_X_RC_X_X_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRC_FLC_X_X_FC_LFE_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRC_FLC_X_X_FC_X_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRC_FLC_X_X_X_LFE_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRC_FLC_X_X_X_X_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRH_FLH_RR_RL_FC_LFE_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRH_FLH_RR_RL_FC_X_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRH_FLH_RR_RL_X_LFE_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRH_FLH_RR_RL_X_X_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRW_FLW_RR_RL_FC_LFE_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRW_FLW_RR_RL_FC_X_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRW_FLW_RR_RL_X_LFE_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRW_FLW_RR_RL_X_X_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_RRC_RLC_RR_RL_FC_LFE_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_RRC_RLC_RR_RL_FC_X_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_RRC_RLC_RR_RL_X_LFE_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_RRC_RLC_RR_RL_X_X_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_TC_FCH_RR_RL_FC_LFE_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_TC_FCH_RR_RL_FC_X_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_TC_RC_RR_RL_FC_LFE_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_TC_RC_RR_RL_FC_X_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_TC_X_RR_RL_FC_LFE_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_TC_X_RR_RL_FC_X_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_FCH_RR_RL_FC_LFE_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_FCH_RR_RL_FC_X_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_RC_RR_RL_FC_LFE_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_RC_RR_RL_FC_X_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_RC_RR_RL_X_LFE_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_RC_RR_RL_X_X_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_X_RR_RL_FC_LFE_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_X_RR_RL_FC_X_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_X_RR_RL_X_LFE_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_X_RR_RL_X_X_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_X_X_RC_FC_LFE_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_X_X_RC_FC_X_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_X_X_RC_X_LFE_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_X_X_RC_X_X_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_X_X_X_FC_LFE_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_X_X_X_FC_X_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_X_X_X_X_LFE_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_X_X_X_X_X_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELCOUNT : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELCOUNT_2 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELCOUNT_3 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELCOUNT_4 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELCOUNT_5 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELCOUNT_6 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELCOUNT_7 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELCOUNT_8 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELCOUNT_AUTO : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELCOUNT_IN_HEADER : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_AUTO : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_HEAAC : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_HEAACV2 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_MPEGSURROUND : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE04 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE05 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE06 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE07 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE08 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE09 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE10 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE11 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE12 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE13 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE14 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE15 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE16 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE17 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE18 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE19 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE20 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE21 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE22 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE23 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE24 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE25 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE26 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE27 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE28 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE29 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE30 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE31 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_USE_CODING_TYPE : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_AACLC : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_AC3 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_ATRAC : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_AUTO : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_DSD : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_DST : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_DTS : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_DTSHD : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_EAC3 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_IN_HEADER : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_MLP : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_MP3 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_MPEG1 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_MPEG2 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_PCM : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_USE_CODING_EXTENSION_TYPE : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_WMAPRO : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_DOWNMIX : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_DOWNMIX_AUTO : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_DOWNMIX_PERMITTED : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_DOWNMIX_PROHIBITED : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_0DB : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_10DB : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_11DB : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_12DB : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_13DB : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_14DB : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_15DB : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_1DB : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_2DB : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_3DB : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_4DB : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_5DB : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_6DB : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_7DB : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_8DB : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_9DB : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_AUTO : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_LFEPLAYBACKLEVEL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_LFEPLAYBACKLEVEL_0DB : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_LFEPLAYBACKLEVEL_AUTO : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_LFEPLAYBACKLEVEL_NO_DATA : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_LFEPLAYBACKLEVEL_PLUS10DB : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_LFEPLAYBACKLEVEL_RESERVED03 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_SAMPLEFREQUENCY : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_SAMPLEFREQUENCY_176400KHZ : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_SAMPLEFREQUENCY_192000KHZ : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_SAMPLEFREQUENCY_32000HZ : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_SAMPLEFREQUENCY_44100HZ : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_SAMPLEFREQUENCY_48000HZ : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_SAMPLEFREQUENCY_88200KHZ : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_SAMPLEFREQUENCY_96000KHZ : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_SAMPLEFREQUENCY_AUTO : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_SAMPLEFREQUENCY_IN_HEADER : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_SAMPLESIZE : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_SAMPLESIZE_16BITS : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_SAMPLESIZE_20BITS : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_SAMPLESIZE_24BITS : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_SAMPLESIZE_AUTO : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_SAMPLESIZE_IN_HEADER : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_ACTIVEFORMATINFO : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_AFI_ABSENT : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_AFI_AUTO : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_AFI_PRESENT : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_16x9_ON_14x9 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_16x9_ON_4x3 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_4x3_ON_14x9 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_AUTO : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_CENTER_14x9 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_CENTER_16x9 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_CENTER_4x3 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_EQUAL_CODEDFRAME : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_LETTERBOX_GT16x9 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_NO_AFD : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_RESERVE01 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_RESERVE02 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_RESERVE03 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_RESERVE05 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_RESERVE06 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_RESERVE07 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_RESERVE12 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOCODEDFRAME : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOCODEDFRAME_16x9 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOCODEDFRAME_4x3 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOCODEDFRAME_AUTO : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOCODEDFRAME_FUTURE : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOCODEDFRAME_NO_DATA : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_BARDATA : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_BARDATA_AUTO : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_BARDATA_BOTH_PRESENT : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_BARDATA_HORIZONTAL_PRESENT : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_BARDATA_NOT_PRESENT : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_BARDATA_VERTICAL_PRESENT : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_COLORFORMAT : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_COLORFORMAT_AUTO : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_COLORFORMAT_FUTURE : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_COLORFORMAT_RGB : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_COLORFORMAT_YCbCr422 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_COLORFORMAT_YCbCr444 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_COLORIMETRY : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_COLORIMETRY_AUTO : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_COLORIMETRY_ITUR_BT709 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_COLORIMETRY_NO_DATA : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_COLORIMETRY_SMPTE_170M : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_COLORIMETRY_USE_EXTENDED_COLORIMETRY : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_CONTENTTYPE : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_CONTENTTYPE_AUTO : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_CONTENTTYPE_CINEMA : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_CONTENTTYPE_GAME : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_CONTENTTYPE_GRAPHICS : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_CONTENTTYPE_PHOTO : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_EXTENDEDCOLORIMETRY : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_EXTENDEDCOLORIMETRY_ADOBERGB : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_EXTENDEDCOLORIMETRY_ADOBEYCC601 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_EXTENDEDCOLORIMETRY_AUTO : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_EXTENDEDCOLORIMETRY_RESERVED05 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_EXTENDEDCOLORIMETRY_RESERVED06 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_EXTENDEDCOLORIMETRY_RESERVED07 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_EXTENDEDCOLORIMETRY_SYCC601 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_EXTENDEDCOLORIMETRY_XVYCC601 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_EXTENDEDCOLORIMETRY_XVYCC709 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_F17 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_F17_AUTO : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_F17_FALSE : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_F17_TRUE : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_ITC : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_ITC_AUTO : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_ITC_ITCONTENT : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_ITC_VIDEO_CONTENT : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_NONUNIFORMPICTURESCALING : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_NONUNIFORMPICTURESCALING_AUTO : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_NONUNIFORMPICTURESCALING_BOTH : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_NONUNIFORMPICTURESCALING_HORIZONTAL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_NONUNIFORMPICTURESCALING_NO_DATA : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_NONUNIFORMPICTURESCALING_VERTICAL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_AUTO : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_NONE : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_RESERVED10 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_RESERVED11 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_RESERVED12 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_RESERVED13 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_RESERVED14 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_RESERVED15 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_X02 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_X03 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_X04 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_X05 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_X06 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_X07 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_X08 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_X09 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_X10 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_RGBQUANTIZATION : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_RGBQUANTIZATION_AUTO : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_RGBQUANTIZATION_DEFAULT : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_RGBQUANTIZATION_FULL_RANGE : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_RGBQUANTIZATION_LIMITED_RANGE : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_RGBQUANTIZATION_RESERVED : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_SCANINFO : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_SCANINFO_AUTO : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_SCANINFO_FUTURE : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_SCANINFO_NODATA : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_SCANINFO_OVERSCAN : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_SCANINFO_UNDERSCAN : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_YCCQUANTIZATION : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_YCCQUANTIZATION_AUTO : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_YCCQUANTIZATION_FULL_RANGE : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_YCCQUANTIZATION_LIMITED_RANGE : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_YCCQUANTIZATION_RESERVED02 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_YCCQUANTIZATION_RESERVED03 : nvapi.h
  • NV_INFOFRAME_PROPERTY_BLACKLIST : nvapi.h
  • NV_INFOFRAME_PROPERTY_BLACKLIST_FALSE : nvapi.h
  • NV_INFOFRAME_PROPERTY_BLACKLIST_TRUE : nvapi.h
  • NV_INFOFRAME_PROPERTY_MODE : nvapi.h
  • NV_INFOFRAME_PROPERTY_MODE_ALLOW_OVERRIDE : nvapi.h
  • NV_INFOFRAME_PROPERTY_MODE_AUTO : nvapi.h
  • NV_INFOFRAME_PROPERTY_MODE_DISABLE : nvapi.h
  • NV_INFOFRAME_PROPERTY_MODE_ENABLE : nvapi.h
  • NV_JOIN_PRESENT_BARRIER_PARAMS : nvapi.h
  • NV_JOIN_PRESENT_BARRIER_PARAMS_VER1 : nvapi.h
  • NV_LATENCY_MARKER_PARAMS : nvapi.h
  • NV_LATENCY_MARKER_PARAMS_V1 : nvapi.h
  • NV_LATENCY_MARKER_PARAMS_VER : nvapi.h
  • NV_LATENCY_MARKER_PARAMS_VER1 : nvapi.h
  • NV_LATENCY_MARKER_TYPE : nvapi.h
  • NV_LATENCY_RESULT_PARAMS : nvapi.h
  • NV_LATENCY_RESULT_PARAMS_V1 : nvapi.h
  • NV_LATENCY_RESULT_PARAMS_VER : nvapi.h
  • NV_LATENCY_RESULT_PARAMS_VER1 : nvapi.h
  • NV_LICENSABLE_FEATURES : nvapi.h
  • NV_LICENSABLE_FEATURES_V1 : nvapi.h
  • NV_LICENSABLE_FEATURES_V2 : nvapi.h
  • NV_LICENSABLE_FEATURES_V3 : nvapi.h
  • NV_LICENSABLE_FEATURES_V4 : nvapi.h
  • NV_LICENSABLE_FEATURES_VER : nvapi.h
  • NV_LICENSABLE_FEATURES_VER1 : nvapi.h
  • NV_LICENSABLE_FEATURES_VER2 : nvapi.h
  • NV_LICENSABLE_FEATURES_VER3 : nvapi.h
  • NV_LICENSABLE_FEATURES_VER4 : nvapi.h
  • NV_LICENSE_EXPIRY_DETAILS : nvapi.h
  • NV_LICENSE_FEATURE_COMPUTE : nvapi.h
  • NV_LICENSE_FEATURE_DETAILS : nvapi.h
  • NV_LICENSE_FEATURE_DETAILS_V1 : nvapi.h
  • NV_LICENSE_FEATURE_DETAILS_V2 : nvapi.h
  • NV_LICENSE_FEATURE_DETAILS_V3 : nvapi.h
  • NV_LICENSE_FEATURE_DETAILS_V4 : nvapi.h
  • NV_LICENSE_FEATURE_DETAILS_VER : nvapi.h
  • NV_LICENSE_FEATURE_DETAILS_VER1 : nvapi.h
  • NV_LICENSE_FEATURE_GAMING : nvapi.h
  • NV_LICENSE_FEATURE_NVIDIA_RTX : nvapi.h
  • NV_LICENSE_FEATURE_QUADRO : nvapi.h
  • NV_LICENSE_FEATURE_TYPE : nvapi.h
  • NV_LICENSE_FEATURE_UNKNOWN : nvapi.h
  • NV_LICENSE_FEATURE_VGPU : nvapi.h
  • NV_LICENSE_INFO_MAX_LENGTH : nvapi.h
  • NV_LICENSE_MAX_COUNT : nvapi.h
  • NV_LICENSE_SIGNATURE_SIZE : nvapi.h
  • NV_LID_DOCK_PARAMS_VER : nvapi.h
  • NV_LMS_CONFIG : nvapi.h
  • NV_LMS_CONFIG_HTC_VIVE_AGGRESSIVE : nvapi.h
  • NV_LMS_CONFIG_HTC_VIVE_BALANCED : nvapi.h
  • NV_LMS_CONFIG_HTC_VIVE_CONSERVATIVE : nvapi.h
  • NV_LMS_CONFIG_OCULUSRIFT_CV1_AGGRESSIVE : nvapi.h
  • NV_LMS_CONFIG_OCULUSRIFT_CV1_BALANCED : nvapi.h
  • NV_LMS_CONFIG_OCULUSRIFT_CV1_CONSERVATIVE : nvapi.h
  • NV_LMS_CUSTOM_CONFIG : nvapi.h
  • NV_LMS_CUSTOM_CONFIG_V1 : nvapi.h
  • NV_LMS_INSTANCED_STEREO_CONFIG : nvapi.h
  • NV_LMS_INSTANCED_STEREO_CONFIG_V1 : nvapi.h
  • NV_LMS_NUM_CONFIGS : nvapi.h
  • NV_LOGICAL_GPU_DATA : nvapi.h
  • NV_LOGICAL_GPU_DATA_V1 : nvapi.h
  • NV_LOGICAL_GPU_DATA_VER : nvapi.h
  • NV_LOGICAL_GPU_DATA_VER1 : nvapi.h
  • NV_LOGICAL_GPU_HANDLE_DATA : nvapi.h
  • NV_LOGICAL_GPUS : nvapi.h
  • NV_LOGICAL_GPUS_V1 : nvapi.h
  • NV_LOGICAL_GPUS_VER : nvapi.h
  • NV_LOGICAL_GPUS_VER1 : nvapi.h
  • NV_MANAGED_DEDICATED_DISPLAY_INFO : nvapi.h
  • NV_MANAGED_DEDICATED_DISPLAY_INFO_V1 : nvapi.h
  • NV_MANAGED_DEDICATED_DISPLAY_INFO_VER : nvapi.h
  • NV_MANAGED_DEDICATED_DISPLAY_INFO_VER1 : nvapi.h
  • NV_MANAGED_DEDICATED_DISPLAY_METADATA : nvapi.h
  • NV_MANAGED_DEDICATED_DISPLAY_METADATA_V1 : nvapi.h
  • NV_MANAGED_DEDICATED_DISPLAY_METADATA_VER : nvapi.h
  • NV_MANAGED_DEDICATED_DISPLAY_METADATA_VER1 : nvapi.h
  • NV_MAX_HEADS : nvapi_lite_common.h
  • NV_MAX_NUM_EXCLUSIVE_SCISSOR_RECTS : nvapi.h
  • NV_MAX_NUM_VIEWPORTS : nvapi.h
  • NV_MAX_PIXEL_SHADING_RATES : nvapi.h
  • NV_MAX_VID_PROFILES : nvapi_lite_common.h
  • NV_MAX_VID_STREAMS : nvapi_lite_common.h
  • NV_MAX_VID_STREAMS_EX : nvapi_lite_common.h
  • NV_META_COMMAND_ACTIVATION_FUNCTION : nvapi.h
  • NV_META_COMMAND_ACTIVATION_FUNCTION_COUNT : nvapi.h
  • NV_META_COMMAND_ACTIVATION_FUNCTION_ELU : nvapi.h
  • NV_META_COMMAND_ACTIVATION_FUNCTION_HARD_SIGMOID : nvapi.h
  • NV_META_COMMAND_ACTIVATION_FUNCTION_HARDMAX : nvapi.h
  • NV_META_COMMAND_ACTIVATION_FUNCTION_IDENTITY : nvapi.h
  • NV_META_COMMAND_ACTIVATION_FUNCTION_LEAKY_RELU : nvapi.h
  • NV_META_COMMAND_ACTIVATION_FUNCTION_LINEAR : nvapi.h
  • NV_META_COMMAND_ACTIVATION_FUNCTION_LOG_SOFTMAX : nvapi.h
  • NV_META_COMMAND_ACTIVATION_FUNCTION_PARAMETERIZED_RELU : nvapi.h
  • NV_META_COMMAND_ACTIVATION_FUNCTION_PARAMETRIC_SOFTPLUS : nvapi.h
  • NV_META_COMMAND_ACTIVATION_FUNCTION_RELU : nvapi.h
  • NV_META_COMMAND_ACTIVATION_FUNCTION_SCALED_ELU : nvapi.h
  • NV_META_COMMAND_ACTIVATION_FUNCTION_SCALED_TANH : nvapi.h
  • NV_META_COMMAND_ACTIVATION_FUNCTION_SIGMOID : nvapi.h
  • NV_META_COMMAND_ACTIVATION_FUNCTION_SOFTMAX : nvapi.h
  • NV_META_COMMAND_ACTIVATION_FUNCTION_SOFTPLUS : nvapi.h
  • NV_META_COMMAND_ACTIVATION_FUNCTION_SOFTSIGN : nvapi.h
  • NV_META_COMMAND_ACTIVATION_FUNCTION_TANH : nvapi.h
  • NV_META_COMMAND_ACTIVATION_FUNCTION_THRESHOLDED_RELU : nvapi.h
  • NV_META_COMMAND_ACTIVATION_MAX_PARAMS : nvapi.h
  • NV_META_COMMAND_BOOL : nvapi.h
  • NV_META_COMMAND_CONVOLUTION_DIRECTION : nvapi.h
  • NV_META_COMMAND_CONVOLUTION_DIRECTION_BACKWARD : nvapi.h
  • NV_META_COMMAND_CONVOLUTION_DIRECTION_COUNT : nvapi.h
  • NV_META_COMMAND_CONVOLUTION_DIRECTION_FORWARD : nvapi.h
  • NV_META_COMMAND_CONVOLUTION_MODE : nvapi.h
  • NV_META_COMMAND_CONVOLUTION_MODE_CONVOLUTION : nvapi.h
  • NV_META_COMMAND_CONVOLUTION_MODE_COUNT : nvapi.h
  • NV_META_COMMAND_CONVOLUTION_MODE_CROSS_CORRELATION : nvapi.h
  • NV_META_COMMAND_CONVOLUTION_POOL_MODE : nvapi.h
  • NV_META_COMMAND_CONVOLUTION_POOL_MODE_COUNT : nvapi.h
  • NV_META_COMMAND_CONVOLUTION_POOL_MODE_NONE : nvapi.h
  • NV_META_COMMAND_CONVOLUTION_POOL_MODE_REDUCTION_AVG : nvapi.h
  • NV_META_COMMAND_CONVOLUTION_POOL_MODE_REDUCTION_MAX : nvapi.h
  • NV_META_COMMAND_CONVOLUTION_POOL_MODE_REDUCTION_MIN : nvapi.h
  • NV_META_COMMAND_CONVOLUTION_SKIP_MODE : nvapi.h
  • NV_META_COMMAND_CONVOLUTION_SKIP_MODE_ADD : nvapi.h
  • NV_META_COMMAND_CONVOLUTION_SKIP_MODE_CONCAT : nvapi.h
  • NV_META_COMMAND_CONVOLUTION_SKIP_MODE_COUNT : nvapi.h
  • NV_META_COMMAND_CONVOLUTION_SKIP_MODE_NONE : nvapi.h
  • NV_META_COMMAND_CONVOLUTION_UPSAMPLE_MODE : nvapi.h
  • NV_META_COMMAND_CONVOLUTION_UPSAMPLE_MODE_BILINEAR : nvapi.h
  • NV_META_COMMAND_CONVOLUTION_UPSAMPLE_MODE_COUNT : nvapi.h
  • NV_META_COMMAND_CONVOLUTION_UPSAMPLE_MODE_NONE : nvapi.h
  • NV_META_COMMAND_CONVOLUTION_UPSAMPLE_MODE_REPLICATE : nvapi.h
  • NV_META_COMMAND_MATRIX_TRANSFORM : nvapi.h
  • NV_META_COMMAND_MATRIX_TRANSFORM_COUNT : nvapi.h
  • NV_META_COMMAND_MATRIX_TRANSFORM_NONE : nvapi.h
  • NV_META_COMMAND_MATRIX_TRANSFORM_TRANSPOSE : nvapi.h
  • NV_META_COMMAND_MAX_TENSOR_DIM : nvapi.h
  • NV_META_COMMAND_NUM_SPATIAL_DIM : nvapi.h
  • NV_META_COMMAND_PADDING_CLAMP : nvapi.h
  • NV_META_COMMAND_PADDING_CONSTANT : nvapi.h
  • NV_META_COMMAND_PADDING_COUNT : nvapi.h
  • NV_META_COMMAND_PADDING_MIRROR : nvapi.h
  • NV_META_COMMAND_PADDING_MODE : nvapi.h
  • NV_META_COMMAND_PADDING_ZEROS : nvapi.h
  • NV_META_COMMAND_PRECISION : nvapi.h
  • NV_META_COMMAND_PRECISION_COUNT : nvapi.h
  • NV_META_COMMAND_PRECISION_FLOAT16 : nvapi.h
  • NV_META_COMMAND_PRECISION_FLOAT32 : nvapi.h
  • NV_META_COMMAND_PRECISION_MUL_FLOAT16_ADD_FLOAT32 : nvapi.h
  • NV_META_COMMAND_RESOURCE_TYPE : nvapi.h
  • NV_META_COMMAND_RESOURCE_TYPE_BIAS : nvapi.h
  • NV_META_COMMAND_RESOURCE_TYPE_FILTER : nvapi.h
  • NV_META_COMMAND_RESOURCE_TYPE_INPUT : nvapi.h
  • NV_META_COMMAND_RESOURCE_TYPE_MATRIX_A : nvapi.h
  • NV_META_COMMAND_RESOURCE_TYPE_MATRIX_B : nvapi.h
  • NV_META_COMMAND_RESOURCE_TYPE_MATRIX_C : nvapi.h
  • NV_META_COMMAND_RESOURCE_TYPE_OUTPUT : nvapi.h
  • NV_META_COMMAND_RESOURCE_TYPE_PERSISTENT : nvapi.h
  • NV_META_COMMAND_RESOURCE_TYPE_TEMPORARY : nvapi.h
  • NV_META_COMMAND_RESOURCE_TYPE_WEIGHT : nvapi.h
  • NV_META_COMMAND_TENSOR_DATA_TYPE : nvapi.h
  • NV_META_COMMAND_TENSOR_DATA_TYPE_COUNT : nvapi.h
  • NV_META_COMMAND_TENSOR_DATA_TYPE_FLOAT16 : nvapi.h
  • NV_META_COMMAND_TENSOR_DATA_TYPE_FLOAT32 : nvapi.h
  • NV_META_COMMAND_TENSOR_DATA_TYPE_UINT32 : nvapi.h
  • NV_META_COMMAND_TENSOR_FLAG_DATA_STATIC : nvapi.h
  • NV_META_COMMAND_TENSOR_FLAG_NONE : nvapi.h
  • NV_META_COMMAND_TENSOR_FLAGS : nvapi.h
  • NV_META_COMMAND_TENSOR_LAYOUT : nvapi.h
  • NV_META_COMMAND_TENSOR_LAYOUT_COUNT : nvapi.h
  • NV_META_COMMAND_TENSOR_LAYOUT_STANDARD : nvapi.h
  • NV_META_COMMAND_TENSOR_LAYOUT_UNKNOWN : nvapi.h
  • NV_MODIFIED_W_COEFFICIENTS : nvapi.h
  • NV_MODIFIED_W_MAX_VIEWPORTS : nvapi.h
  • NV_MODIFIED_W_PARAMS : nvapi.h
  • NV_MODIFIED_W_PARAMS_V1 : nvapi.h
  • NV_MODIFIED_W_PARAMS_VER : nvapi.h
  • NV_MODIFIED_W_PARAMS_VER1 : nvapi.h
  • NV_MONITOR_CAPABILITIES : nvapi.h
  • NV_MONITOR_CAPABILITIES_V1 : nvapi.h
  • NV_MONITOR_CAPABILITIES_VER : nvapi.h
  • NV_MONITOR_CAPABILITIES_VER1 : nvapi.h
  • NV_MONITOR_CAPS_GENERIC : nvapi.h
  • NV_MONITOR_CAPS_TYPE : nvapi.h
  • NV_MONITOR_CAPS_TYPE_GENERIC : nvapi.h
  • NV_MONITOR_CAPS_TYPE_HDMI_VCDB : nvapi.h
  • NV_MONITOR_CAPS_TYPE_HDMI_VSDB : nvapi.h
  • NV_MONITOR_CAPS_VCDB : nvapi.h
  • NV_MONITOR_CAPS_VSDB : nvapi.h
  • NV_MONITOR_COLOR_CAPS : nvapi.h
  • NV_MONITOR_COLOR_CAPS_V1 : nvapi.h
  • NV_MONITOR_COLOR_CAPS_VER : nvapi.h
  • NV_MONITOR_COLOR_CAPS_VER1 : nvapi.h
  • NV_MONITOR_CONN_TYPE : nvapi.h
  • NV_MONITOR_CONN_TYPE_COMPONENT : nvapi.h
  • NV_MONITOR_CONN_TYPE_COMPOSITE : nvapi.h
  • NV_MONITOR_CONN_TYPE_DP : nvapi.h
  • NV_MONITOR_CONN_TYPE_DVI : nvapi.h
  • NV_MONITOR_CONN_TYPE_HDMI : nvapi.h
  • NV_MONITOR_CONN_TYPE_LVDS : nvapi.h
  • NV_MONITOR_CONN_TYPE_SVIDEO : nvapi.h
  • NV_MONITOR_CONN_TYPE_UNINITIALIZED : nvapi.h
  • NV_MONITOR_CONN_TYPE_UNKNOWN : nvapi.h
  • NV_MONITOR_CONN_TYPE_VGA : nvapi.h
  • NV_MOSAIC_DISPLAY_SETTING : nvapi.h
  • NV_MOSAIC_DISPLAY_SETTING_V1 : nvapi.h
  • NV_MOSAIC_DISPLAY_SETTING_V2 : nvapi.h
  • NV_MOSAIC_DISPLAY_SETTINGS_MAX : nvapi.h
  • NV_MOSAIC_DISPLAY_TOPO_STATUS_VER : nvapi.h
  • NV_MOSAIC_DISPLAYCAPS_PROBLEM_DISPLAY_ON_INVALID_GPU : nvapi.h
  • NV_MOSAIC_DISPLAYCAPS_PROBLEM_DISPLAY_ON_WRONG_CONNECTOR : nvapi.h
  • NV_MOSAIC_DISPLAYCAPS_PROBLEM_ECC_ENABLED : nvapi.h
  • NV_MOSAIC_DISPLAYCAPS_PROBLEM_GPU_TOPOLOGY_NOT_SUPPORTED : nvapi.h
  • NV_MOSAIC_DISPLAYCAPS_PROBLEM_MISMATCHED_OUTPUT_TYPE : nvapi.h
  • NV_MOSAIC_DISPLAYCAPS_PROBLEM_NO_COMMON_TIMINGS : nvapi.h
  • NV_MOSAIC_DISPLAYCAPS_PROBLEM_NO_DISPLAY_CONNECTED : nvapi.h
  • NV_MOSAIC_DISPLAYCAPS_PROBLEM_NO_EDID_AVAILABLE : nvapi.h
  • NV_MOSAIC_DISPLAYCAPS_PROBLEM_NO_GPU_TOPOLOGY : nvapi.h
  • NV_MOSAIC_DISPLAYCAPS_PROBLEM_NO_SLI_BRIDGE : nvapi.h
  • NV_MOSAIC_DISPLAYCAPS_PROBLEM_NOT_SUPPORTED : nvapi.h
  • NV_MOSAIC_DISPLAYTOPO_WARNING_DISPLAY_POSITION : nvapi.h
  • NV_MOSAIC_DISPLAYTOPO_WARNING_DRIVER_RELOAD_REQUIRED : nvapi.h
  • NV_MOSAIC_GRID_TOPO : nvapi.h
  • NV_MOSAIC_GRID_TOPO_DISPLAY : nvapi.h
  • NV_MOSAIC_GRID_TOPO_DISPLAY_V1 : nvapi.h
  • NV_MOSAIC_GRID_TOPO_DISPLAY_V2 : nvapi.h
  • NV_MOSAIC_GRID_TOPO_V1 : nvapi.h
  • NV_MOSAIC_GRID_TOPO_V2 : nvapi.h
  • NV_MOSAIC_GRID_TOPO_VER : nvapi.h
  • NV_MOSAIC_GRID_TOPO_VER1 : nvapi.h
  • NV_MOSAIC_GRID_TOPO_VER2 : nvapi.h
  • NV_MOSAIC_MAX_DISPLAYS : nvapi_lite_surround.h
  • NV_MOSAIC_MAX_TOPO_PER_TOPO_GROUP : nvapi.h
  • NV_MOSAIC_SETDISPLAYTOPO_FLAG_ALLOW_INVALID : nvapi.h
  • NV_MOSAIC_SETDISPLAYTOPO_FLAG_CURRENT_GPU_TOPOLOGY : nvapi.h
  • NV_MOSAIC_SETDISPLAYTOPO_FLAG_MAXIMIZE_PERFORMANCE : nvapi.h
  • NV_MOSAIC_SETDISPLAYTOPO_FLAG_NO_DRIVER_RELOAD : nvapi.h
  • NV_MOSAIC_SUPPORTED_TOPO_INFO : nvapi.h
  • NV_MOSAIC_SUPPORTED_TOPO_INFO_V1 : nvapi.h
  • NV_MOSAIC_SUPPORTED_TOPO_INFO_V2 : nvapi.h
  • NV_MOSAIC_TOPO : nvapi.h
  • NV_MOSAIC_TOPO_1x2_BASIC : nvapi.h
  • NV_MOSAIC_TOPO_1x2_PASSIVE_STEREO : nvapi.h
  • NV_MOSAIC_TOPO_1x3_BASIC : nvapi.h
  • NV_MOSAIC_TOPO_1x3_PASSIVE_STEREO : nvapi.h
  • NV_MOSAIC_TOPO_1x4_BASIC : nvapi.h
  • NV_MOSAIC_TOPO_1x4_PASSIVE_STEREO : nvapi.h
  • NV_MOSAIC_TOPO_1x5_BASIC : nvapi.h
  • NV_MOSAIC_TOPO_1x6_BASIC : nvapi.h
  • NV_MOSAIC_TOPO_2x1_BASIC : nvapi.h
  • NV_MOSAIC_TOPO_2x1_PASSIVE_STEREO : nvapi.h
  • NV_MOSAIC_TOPO_2x2_BASIC : nvapi.h
  • NV_MOSAIC_TOPO_2x2_PASSIVE_STEREO : nvapi.h
  • NV_MOSAIC_TOPO_2x3_BASIC : nvapi.h
  • NV_MOSAIC_TOPO_2x4_BASIC : nvapi.h
  • NV_MOSAIC_TOPO_3x1_BASIC : nvapi.h
  • NV_MOSAIC_TOPO_3x1_PASSIVE_STEREO : nvapi.h
  • NV_MOSAIC_TOPO_3x2_BASIC : nvapi.h
  • NV_MOSAIC_TOPO_4x1_BASIC : nvapi.h
  • NV_MOSAIC_TOPO_4x1_PASSIVE_STEREO : nvapi.h
  • NV_MOSAIC_TOPO_4x2_BASIC : nvapi.h
  • NV_MOSAIC_TOPO_7x1_BASIC : nvapi.h
  • NV_MOSAIC_TOPO_BEGIN_BASIC : nvapi.h
  • NV_MOSAIC_TOPO_BEGIN_PASSIVE_STEREO : nvapi.h
  • NV_MOSAIC_TOPO_END_BASIC : nvapi.h
  • NV_MOSAIC_TOPO_END_PASSIVE_STEREO : nvapi.h
  • NV_MOSAIC_TOPO_IDX_DEFAULT : nvapi.h
  • NV_MOSAIC_TOPO_IDX_LEFT_EYE : nvapi.h
  • NV_MOSAIC_TOPO_IDX_RIGHT_EYE : nvapi.h
  • NV_MOSAIC_TOPO_MAX : nvapi.h
  • NV_MOSAIC_TOPO_NONE : nvapi.h
  • NV_MOSAIC_TOPO_NUM_EYES : nvapi.h
  • NV_MOSAIC_TOPO_TYPE : nvapi.h
  • NV_MOSAIC_TOPO_TYPE_ALL : nvapi.h
  • NV_MOSAIC_TOPO_TYPE_BASIC : nvapi.h
  • NV_MOSAIC_TOPO_TYPE_MAX : nvapi.h
  • NV_MOSAIC_TOPO_TYPE_PASSIVE_STEREO : nvapi.h
  • NV_MOSAIC_TOPO_TYPE_PASSIVE_STEREO_SCALED_CLONE : nvapi.h
  • NV_MOSAIC_TOPO_TYPE_SCALED_CLONE : nvapi.h
  • NV_MOSAIC_TOPO_VALIDITY_MISSING_DISPLAY : nvapi.h
  • NV_MOSAIC_TOPO_VALIDITY_MISSING_GPU : nvapi.h
  • NV_MOSAIC_TOPO_VALIDITY_MIXED_DISPLAY_TYPES : nvapi.h
  • NV_MOSAIC_TOPO_VALIDITY_VALID : nvapi.h
  • NV_MRS_CONFIG : nvapi.h
  • NV_MRS_CONFIG_AGGRESSIVE : nvapi.h
  • NV_MRS_CONFIG_BALANCED : nvapi.h
  • NV_MRS_CONFIG_HTC_VIVE_AGGRESSIVE : nvapi.h
  • NV_MRS_CONFIG_HTC_VIVE_BALANCED : nvapi.h
  • NV_MRS_CONFIG_HTC_VIVE_CONSERVATIVE : nvapi.h
  • NV_MRS_CONFIG_OCULUSRIFT_CV1_AGGRESSIVE : nvapi.h
  • NV_MRS_CONFIG_OCULUSRIFT_CV1_BALANCED : nvapi.h
  • NV_MRS_CONFIG_OCULUSRIFT_CV1_CONSERVATIVE : nvapi.h
  • NV_MRS_CUSTOM_CONFIG : nvapi.h
  • NV_MRS_CUSTOM_CONFIG_V1 : nvapi.h
  • NV_MRS_INSTANCED_STEREO_CONFIG : nvapi.h
  • NV_MRS_INSTANCED_STEREO_CONFIG_V1 : nvapi.h
  • NV_MRS_NUM_CONFIGS : nvapi.h
  • NV_MULTIGPU_CAPS : nvapi.h
  • NV_MULTIGPU_CAPS_V1 : nvapi.h
  • NV_MULTIGPU_CAPS_V2 : nvapi.h
  • NV_MULTIGPU_CAPS_VER : nvapi.h
  • NV_MULTIGPU_CAPS_VER1 : nvapi.h
  • NV_MULTIGPU_CAPS_VER2 : nvapi.h
  • NV_MULTIVIEW_MAX_SUPPORTED_VIEWS : nvapi.h
  • NV_MULTIVIEW_PARAMS : nvapi.h
  • NV_MULTIVIEW_PARAMS_V1 : nvapi.h
  • NV_MULTIVIEW_PARAMS_VER : nvapi.h
  • NV_MULTIVIEW_PARAMS_VER1 : nvapi.h
  • NV_NONE_SEMANTIC : nvapi.h
  • NV_OUT_OF_BAND_CQ_TYPE : nvapi.h
  • NV_PACKED_EYE_INDEX_SEMANTIC : nvapi.h
  • NV_PHYSICAL_GPU_HANDLE_DATA : nvapi.h
  • NV_PHYSICAL_GPUS : nvapi.h
  • NV_PHYSICAL_GPUS_V1 : nvapi.h
  • NV_PHYSICAL_GPUS_VER : nvapi.h
  • NV_PHYSICAL_GPUS_VER1 : nvapi.h
  • NV_PIXEL_SHADING_RATE : nvapi.h
  • NV_PIXEL_SHADING_RATE_SAMPLE_ORDER_TABLE : nvapi.h
  • NV_PIXEL_SHADING_RATE_SAMPLE_ORDER_TABLE_V1 : nvapi.h
  • NV_PIXEL_SHADING_RATE_SAMPLE_ORDER_TABLE_VER : nvapi.h
  • NV_PIXEL_SHADING_RATE_SAMPLE_ORDER_TABLE_VER1 : nvapi.h
  • NV_PIXEL_SHIFT_TYPE : nvapi.h
  • NV_PIXEL_SHIFT_TYPE_2x2_BOTTOM_LEFT_PIXELS : nvapi.h
  • NV_PIXEL_SHIFT_TYPE_2x2_BOTTOM_RIGHT_PIXELS : nvapi.h
  • NV_PIXEL_SHIFT_TYPE_2x2_TOP_LEFT_PIXELS : nvapi.h
  • NV_PIXEL_SHIFT_TYPE_2x2_TOP_RIGHT_PIXELS : nvapi.h
  • NV_PIXEL_SHIFT_TYPE_NO_PIXEL_SHIFT : nvapi.h
  • NV_PIXEL_SRSO_1x2 : nvapi.h
  • NV_PIXEL_SRSO_2x1 : nvapi.h
  • NV_PIXEL_SRSO_2x2 : nvapi.h
  • NV_PIXEL_SRSO_2x4 : nvapi.h
  • NV_PIXEL_SRSO_4x2 : nvapi.h
  • NV_PIXEL_SRSO_4x4 : nvapi.h
  • NV_PIXEL_X0_CULL_RASTER_PIXELS : nvapi.h
  • NV_PIXEL_X16_PER_RASTER_PIXEL : nvapi.h
  • NV_PIXEL_X1_PER_1X2_RASTER_PIXELS : nvapi.h
  • NV_PIXEL_X1_PER_2X1_RASTER_PIXELS : nvapi.h
  • NV_PIXEL_X1_PER_2X2_RASTER_PIXELS : nvapi.h
  • NV_PIXEL_X1_PER_2X4_RASTER_PIXELS : nvapi.h
  • NV_PIXEL_X1_PER_4X2_RASTER_PIXELS : nvapi.h
  • NV_PIXEL_X1_PER_4X4_RASTER_PIXELS : nvapi.h
  • NV_PIXEL_X1_PER_RASTER_PIXEL : nvapi.h
  • NV_PIXEL_X2_PER_RASTER_PIXEL : nvapi.h
  • NV_PIXEL_X4_PER_RASTER_PIXEL : nvapi.h
  • NV_PIXEL_X8_PER_RASTER_PIXEL : nvapi.h
  • NV_POSITION : nvapi.h
  • NV_POSITION_SEMANTIC : nvapi.h
  • NV_PRESENT_BARRIER_FRAME_STATICS_VER1 : nvapi.h
  • NV_PRESENT_BARRIER_FRAME_STATISTICS : nvapi.h
  • NV_PRESENT_BARRIER_SYNC_MODE : nvapi.h
  • NV_PSO_DOMAIN_SHADER_EXTENSION : nvapi.h
  • NV_PSO_ENABLE_DEPTH_BOUND_TEST_EXTENSION : nvapi.h
  • NV_PSO_EXPLICIT_FASTGS_EXTENSION : nvapi.h
  • NV_PSO_EXTENSION : nvapi.h
  • NV_PSO_EXTENSION_DESC_VER : nvapi.h
  • NV_PSO_EXTENSION_DESC_VER_1 : nvapi.h
  • NV_PSO_GEOMETRY_SHADER_EXTENSION : nvapi.h
  • NV_PSO_HULL_SHADER_EXTENSION : nvapi.h
  • NV_PSO_RASTER_EXTENSION : nvapi.h
  • NV_PSO_REQUEST_FASTGS_EXTENSION : nvapi.h
  • NV_PSO_SET_SHADER_EXTENSION_SLOT_AND_SPACE : nvapi.h
  • NV_PSO_SET_SHADER_EXTNENSION_SLOT_AND_SPACE : nvapi.h
  • NV_PSO_VERTEX_SHADER_EXTENSION : nvapi.h
  • NV_QSYNC_EVENT : nvapi.h
  • NV_QSYNC_EVENT_HOUSESYNC_GAIN : nvapi.h
  • NV_QSYNC_EVENT_HOUSESYNC_LOSS : nvapi.h
  • NV_QSYNC_EVENT_NONE : nvapi.h
  • NV_QSYNC_EVENT_RJ45_GAIN : nvapi.h
  • NV_QSYNC_EVENT_RJ45_LOSS : nvapi.h
  • NV_QSYNC_EVENT_SYNC_GAIN : nvapi.h
  • NV_QSYNC_EVENT_SYNC_LOSS : nvapi.h
  • NV_QUALITY_UPSCALING_DEFAULT : NvApiDriverSettings.h
  • NV_QUALITY_UPSCALING_ID : NvApiDriverSettings.h
  • NV_QUALITY_UPSCALING_NUM_VALUES : NvApiDriverSettings.h
  • NV_QUALITY_UPSCALING_OFF : NvApiDriverSettings.h
  • NV_QUALITY_UPSCALING_ON : NvApiDriverSettings.h
  • NV_QUALITY_UPSCALING_STRING : NvApiDriverSettings.h
  • NV_QUERY_LATELATCH_SUPPORT_PARAMS : nvapi.h
  • NV_QUERY_LATELATCH_SUPPORT_PARAMS_V1 : nvapi.h
  • NV_QUERY_LATELATCH_SUPPORT_PARAMS_VER : nvapi.h
  • NV_QUERY_LATELATCH_SUPPORT_PARAMS_VER1 : nvapi.h
  • NV_QUERY_MODIFIED_W_SUPPORT_PARAMS : nvapi.h
  • NV_QUERY_MODIFIED_W_SUPPORT_PARAMS_V1 : nvapi.h
  • NV_QUERY_MODIFIED_W_SUPPORT_PARAMS_VER : nvapi.h
  • NV_QUERY_MODIFIED_W_SUPPORT_PARAMS_VER1 : nvapi.h
  • NV_QUERY_MULTIVIEW_SUPPORT_PARAMS : nvapi.h
  • NV_QUERY_MULTIVIEW_SUPPORT_PARAMS_V1 : nvapi.h
  • NV_QUERY_MULTIVIEW_SUPPORT_PARAMS_VER : nvapi.h
  • NV_QUERY_MULTIVIEW_SUPPORT_PARAMS_VER1 : nvapi.h
  • NV_QUERY_SINGLE_PASS_STEREO_SUPPORT_PARAMS : nvapi.h
  • NV_QUERY_SINGLE_PASS_STEREO_SUPPORT_PARAMS_V1 : nvapi.h
  • NV_QUERY_SINGLE_PASS_STEREO_SUPPORT_PARAMS_V2 : nvapi.h
  • NV_QUERY_SINGLE_PASS_STEREO_SUPPORT_PARAMS_VER : nvapi.h
  • NV_QUERY_SINGLE_PASS_STEREO_SUPPORT_PARAMS_VER1 : nvapi.h
  • NV_QUERY_SINGLE_PASS_STEREO_SUPPORT_PARAMS_VER2 : nvapi.h
  • NV_QUERY_SMP_ASSIST_SUPPORT_PARAMS : nvapi.h
  • NV_QUERY_SMP_ASSIST_SUPPORT_PARAMS_V1 : nvapi.h
  • NV_QUERY_SMP_ASSIST_SUPPORT_PARAMS_VER : nvapi.h
  • NV_QUERY_SMP_ASSIST_SUPPORT_PARAMS_VER1 : nvapi.h
  • NV_RASTERIZER_PSO_EXTENSION_DESC_VER : nvapi.h
  • NV_RASTERIZER_PSO_EXTENSION_DESC_VER_1 : nvapi.h
  • NV_RASTERIZER_PSO_EXTENSION_DESC_VER_2 : nvapi.h
  • NV_RECT : nvapi_lite_common.h
  • NV_RESOLUTION : nvapi.h
  • NV_RESOLVE_MODE : nvapi.h
  • NV_RESOLVE_MODE_SAMPLE_0 : nvapi.h
  • NV_RESOURCE_PARAMS : nvapi.h
  • NV_RESOURCE_PARAMS_V1 : nvapi.h
  • NV_RESOURCE_PARAMS_VER : nvapi.h
  • NV_RESOURCE_PARAMS_VER_1 : nvapi.h
  • NV_ROTATE : nvapi.h
  • NV_ROTATE_0 : nvapi.h
  • NV_ROTATE_180 : nvapi.h
  • NV_ROTATE_270 : nvapi.h
  • NV_ROTATE_90 : nvapi.h
  • NV_ROTATE_IGNORED : nvapi.h
  • NV_SCALING : nvapi.h
  • NV_SCALING_ADAPTER_SCALING : nvapi.h
  • NV_SCALING_ASPECT_SCALING : nvapi.h
  • NV_SCALING_CENTERED : nvapi.h
  • NV_SCALING_CUSTOMIZED : nvapi.h
  • NV_SCALING_DEFAULT : nvapi.h
  • NV_SCALING_GPU_INTEGER_ASPECT_SCALING : nvapi.h
  • NV_SCALING_GPU_SCALING_TO_ASPECT_SCANOUT_TO_CLOSEST : nvapi.h
  • NV_SCALING_GPU_SCALING_TO_ASPECT_SCANOUT_TO_NATIVE : nvapi.h
  • NV_SCALING_GPU_SCALING_TO_CLOSEST : nvapi.h
  • NV_SCALING_GPU_SCALING_TO_NATIVE : nvapi.h
  • NV_SCALING_GPU_SCANOUT_TO_CLOSEST : nvapi.h
  • NV_SCALING_GPU_SCANOUT_TO_NATIVE : nvapi.h
  • NV_SCALING_MONITOR_SCALING : nvapi.h
  • NV_SCANOUT_INFORMATION : nvapi.h
  • NV_SCANOUT_INFORMATION_VER : nvapi.h
  • NV_SCANOUT_INTENSITY_DATA : nvapi.h
  • NV_SCANOUT_INTENSITY_DATA_VER : nvapi.h
  • NV_SCANOUT_INTENSITY_DATA_VER1 : nvapi.h
  • NV_SCANOUT_INTENSITY_DATA_VER2 : nvapi.h
  • NV_SCANOUT_INTENSITY_STATE_DATA : nvapi.h
  • NV_SCANOUT_INTENSITY_STATE_VER : nvapi.h
  • NV_SCANOUT_WARPING_STATE_DATA : nvapi.h
  • NV_SCANOUT_WARPING_STATE_VER : nvapi.h
  • NV_SCANOUT_WARPING_VER : nvapi.h
  • NV_SET_ADAPTIVE_SYNC_DATA : nvapi.h
  • NV_SET_ADAPTIVE_SYNC_DATA_V1 : nvapi.h
  • NV_SET_ADAPTIVE_SYNC_DATA_VER : nvapi.h
  • NV_SET_ADAPTIVE_SYNC_DATA_VER1 : nvapi.h
  • NV_SET_PREFERRED_STEREO_DISPLAY : nvapi.h
  • NV_SET_PREFERRED_STEREO_DISPLAY_VER : nvapi.h
  • NV_SET_PREFERRED_STEREO_DISPLAY_VER1 : nvapi.h
  • NV_SET_REFLEX_SYNC_PARAMS : nvapi.h
  • NV_SET_REFLEX_SYNC_PARAMS_V1 : nvapi.h
  • NV_SET_REFLEX_SYNC_PARAMS_VER : nvapi.h
  • NV_SET_REFLEX_SYNC_PARAMS_VER1 : nvapi.h
  • NV_SET_SHADER_EXTENSION_SLOT_DESC_VER : nvapi.h
  • NV_SET_SHADER_EXTENSION_SLOT_DESC_VER_1 : nvapi.h
  • NV_SET_SLEEP_MODE_PARAMS : nvapi.h
  • NV_SET_SLEEP_MODE_PARAMS_V1 : nvapi.h
  • NV_SET_SLEEP_MODE_PARAMS_VER : nvapi.h
  • NV_SET_SLEEP_MODE_PARAMS_VER1 : nvapi.h
  • NV_SET_VIRTUAL_REFRESH_RATE_DATA : nvapi.h
  • NV_SET_VIRTUAL_REFRESH_RATE_DATA_V1 : nvapi.h
  • NV_SET_VIRTUAL_REFRESH_RATE_DATA_VER : nvapi.h
  • NV_SET_VIRTUAL_REFRESH_RATE_DATA_VER1 : nvapi.h
  • NV_SHADER_EXTN_VERSION : nvShaderExtnEnums.h
  • NV_SMP_ASSIST_DISABLE_PARAMS : nvapi.h
  • NV_SMP_ASSIST_DISABLE_PARAMS_V1 : nvapi.h
  • NV_SMP_ASSIST_DISABLE_PARAMS_VER : nvapi.h
  • NV_SMP_ASSIST_DISABLE_PARAMS_VER1 : nvapi.h
  • NV_SMP_ASSIST_ENABLE_PARAMS : nvapi.h
  • NV_SMP_ASSIST_ENABLE_PARAMS_V1 : nvapi.h
  • NV_SMP_ASSIST_ENABLE_PARAMS_VER : nvapi.h
  • NV_SMP_ASSIST_ENABLE_PARAMS_VER1 : nvapi.h
  • NV_SMP_ASSIST_EYE_INDEX : nvapi.h
  • NV_SMP_ASSIST_EYE_INDEX_INSTANCED_STEREO : nvapi.h
  • NV_SMP_ASSIST_EYE_INDEX_LEFT_EYE : nvapi.h
  • NV_SMP_ASSIST_EYE_INDEX_MONO : nvapi.h
  • NV_SMP_ASSIST_EYE_INDEX_RIGHT_EYE : nvapi.h
  • NV_SMP_ASSIST_FASTGSCBDATA : nvapi.h
  • NV_SMP_ASSIST_FASTGSCBDATA_MRS_INSTANCED_STEREO : nvapi.h
  • NV_SMP_ASSIST_FASTGSCBDATA_MRS_INSTANCED_STEREO_V1 : nvapi.h
  • NV_SMP_ASSIST_FASTGSCBDATA_V1 : nvapi.h
  • NV_SMP_ASSIST_FLAGS_DEFAULT : nvapi.h
  • NV_SMP_ASSIST_GET_CONSTANTS : nvapi.h
  • NV_SMP_ASSIST_GET_CONSTANTS_V3 : nvapi.h
  • NV_SMP_ASSIST_GET_CONSTANTS_VER : nvapi.h
  • NV_SMP_ASSIST_GET_CONSTANTS_VER3 : nvapi.h
  • NV_SMP_ASSIST_INITIALIZE_PARAMS : nvapi.h
  • NV_SMP_ASSIST_INITIALIZE_PARAMS_V1 : nvapi.h
  • NV_SMP_ASSIST_INITIALIZE_PARAMS_VER : nvapi.h
  • NV_SMP_ASSIST_INITIALIZE_PARAMS_VER1 : nvapi.h
  • NV_SMP_ASSIST_LEVEL : nvapi.h
  • NV_SMP_ASSIST_LEVEL_FULL : nvapi.h
  • NV_SMP_ASSIST_LEVEL_MINIMAL : nvapi.h
  • NV_SMP_ASSIST_LEVEL_PARTIAL : nvapi.h
  • NV_SMP_ASSIST_LMS : nvapi.h
  • NV_SMP_ASSIST_MAX_VIEWPORTS : nvapi.h
  • NV_SMP_ASSIST_MINIMAL_LEVEL_NUM_EYE_INDICES : nvapi.h
  • NV_SMP_ASSIST_MRS : nvapi.h
  • NV_SMP_ASSIST_NONE : nvapi.h
  • NV_SMP_ASSIST_NUM_LEVELS : nvapi.h
  • NV_SMP_ASSIST_NUM_TYPES : nvapi.h
  • NV_SMP_ASSIST_REMAPCBDATA : nvapi.h
  • NV_SMP_ASSIST_REMAPCBDATA_V1 : nvapi.h
  • NV_SMP_ASSIST_SETUP_PARAMS : nvapi.h
  • NV_SMP_ASSIST_SETUP_PARAMS_V1 : nvapi.h
  • NV_SMP_ASSIST_SETUP_PARAMS_VER : nvapi.h
  • NV_SMP_ASSIST_SETUP_PARAMS_VER1 : nvapi.h
  • NV_SMP_ASSIST_TYPE : nvapi.h
  • NV_SMP_ASSIST_UPDATE_INSTANCEDSTEREO_DATA_PARAMS : nvapi.h
  • NV_SMP_ASSIST_UPDATE_INSTANCEDSTEREO_DATA_PARAMS_V1 : nvapi.h
  • NV_SMP_ASSIST_UPDATE_INSTANCEDSTEREO_DATA_PARAMS_VER : nvapi.h
  • NV_SMP_ASSIST_UPDATE_INSTANCEDSTEREO_DATA_PARAMS_VER1 : nvapi.h
  • NV_SOURCE_PID_CURRENT : nvapi.h
  • NV_SPECIALOP_FOOTPRINT_SINGLELOD_PRED : nvShaderExtnEnums.h
  • NV_SPECIALOP_GLOBAL_TIMER_HI : nvShaderExtnEnums.h
  • NV_SPECIALOP_GLOBAL_TIMER_LO : nvShaderExtnEnums.h
  • NV_SPECIALOP_THREADLTMASK : nvShaderExtnEnums.h
  • NV_SRRV_DIMENSION : nvapi.h
  • NV_SRRV_DIMENSION_TEXTURE2D : nvapi.h
  • NV_SRRV_DIMENSION_TEXTURE2DARRAY : nvapi.h
  • NV_STATIC_METADATA_DESCRIPTOR_ID : nvapi.h
  • NV_STATIC_METADATA_TYPE_1 : nvapi.h
  • NV_STEREO_ACTIVE_EYE : nvapi_lite_stereo.h
  • NV_STEREO_DRIVER_MODE : nvapi_lite_stereo.h
  • NV_STEREO_REGISTRY_ID : nvapi.h
  • NV_STEREO_REGISTRY_PROFILE_TYPE : nvapi.h
  • NV_STEREO_SWAPCHAIN_MODE : nvapi.h
  • NV_STEREO_VIDEO_FORMAT : nvapi.h
  • NV_STEREO_VIDEO_FORMAT_DEFINE : nvapi.h
  • NV_STEREO_VIDEO_FORMAT_LAST : nvapi.h
  • NV_STEREO_VIDEO_FORMAT_MONO_PLUS_OFFSET : nvapi.h
  • NV_STEREO_VIDEO_FORMAT_NOT_STEREO : nvapi.h
  • NV_STEREO_VIDEO_FORMAT_ROW_INTERLEAVE_LR : nvapi.h
  • NV_STEREO_VIDEO_FORMAT_ROW_INTERLEAVE_RL : nvapi.h
  • NV_STEREO_VIDEO_FORMAT_SIDE_BY_SIDE_LR : nvapi.h
  • NV_STEREO_VIDEO_FORMAT_SIDE_BY_SIDE_RL : nvapi.h
  • NV_STEREO_VIDEO_FORMAT_TOP_BOTTOM_LR : nvapi.h
  • NV_STEREO_VIDEO_FORMAT_TOP_BOTTOM_RL : nvapi.h
  • NV_STEREO_VIDEO_FORMAT_TWO_FRAMES_LR : nvapi.h
  • NV_SWIZZLE_MODE : nvapi.h
  • NV_SWIZZLE_NEG_W : nvapi.h
  • NV_SWIZZLE_NEG_X : nvapi.h
  • NV_SWIZZLE_NEG_Y : nvapi.h
  • NV_SWIZZLE_NEG_Z : nvapi.h
  • NV_SWIZZLE_OFFSET : nvapi.h
  • NV_SWIZZLE_OFFSET_W : nvapi.h
  • NV_SWIZZLE_OFFSET_X : nvapi.h
  • NV_SWIZZLE_OFFSET_Y : nvapi.h
  • NV_SWIZZLE_OFFSET_Z : nvapi.h
  • NV_SWIZZLE_POS_W : nvapi.h
  • NV_SWIZZLE_POS_X : nvapi.h
  • NV_SWIZZLE_POS_Y : nvapi.h
  • NV_SWIZZLE_POS_Z : nvapi.h
  • NV_SYSTEM_TYPE : nvapi.h
  • NV_SYSTEM_TYPE_DESKTOP : nvapi.h
  • NV_SYSTEM_TYPE_DGPU : nvapi.h
  • NV_SYSTEM_TYPE_GPU_UNKNOWN : nvapi.h
  • NV_SYSTEM_TYPE_IGPU : nvapi.h
  • NV_SYSTEM_TYPE_LAPTOP : nvapi.h
  • NV_SYSTEM_TYPE_UNKNOWN : nvapi.h
  • NV_TARGET_VIEW_MODE : nvapi.h
  • NV_TEX2D_ARRAY_SRRV : nvapi.h
  • NV_TEX2D_SRRV : nvapi.h
  • NV_THERMAL_CONTROLLER : nvapi.h
  • NV_THERMAL_TARGET : nvapi.h
  • NV_TIMING : nvapi.h
  • NV_TIMING_H_SYNC_DEFAULT : nvapi.h
  • NV_TIMING_H_SYNC_NEGATIVE : nvapi.h
  • NV_TIMING_H_SYNC_POSITIVE : nvapi.h
  • NV_TIMING_INPUT : nvapi.h
  • NV_TIMING_INPUT_VER : nvapi.h
  • NV_TIMING_INTERLACED : nvapi.h
  • NV_TIMING_INTERLACED_EXTRA_VBLANK_ON_FIELD2 : nvapi.h
  • NV_TIMING_INTERLACED_NO_EXTRA_VBLANK_ON_FIELD2 : nvapi.h
  • NV_TIMING_OVERRIDE : nvapi.h
  • NV_TIMING_OVERRIDE_ANALOG_TV : nvapi.h
  • NV_TIMING_OVERRIDE_AUTO : nvapi.h
  • NV_TIMING_OVERRIDE_CURRENT : nvapi.h
  • NV_TIMING_OVERRIDE_CUST : nvapi.h
  • NV_TIMING_OVERRIDE_CVT : nvapi.h
  • NV_TIMING_OVERRIDE_CVT_RB : nvapi.h
  • NV_TIMING_OVERRIDE_DMT : nvapi.h
  • NV_TIMING_OVERRIDE_DMT_RB : nvapi.h
  • NV_TIMING_OVERRIDE_EDID : nvapi.h
  • NV_TIMING_OVERRIDE_EIA861 : nvapi.h
  • NV_TIMING_OVERRIDE_GTF : nvapi.h
  • NV_TIMING_OVERRIDE_NV_ASPR : nvapi.h
  • NV_TIMING_OVERRIDE_NV_PREDEFINED : nvapi.h
  • NV_TIMING_OVERRIDE_NV_PSF : nvapi.h
  • NV_TIMING_OVERRIDE_SDI : nvapi.h
  • NV_TIMING_OVRRIDE_MAX : nvapi.h
  • NV_TIMING_PROGRESSIVE : nvapi.h
  • NV_TIMING_STRUCTS_DEFINED : nvapi.h
  • NV_TIMING_V_SYNC_DEFAULT : nvapi.h
  • NV_TIMING_V_SYNC_NEGATIVE : nvapi.h
  • NV_TIMING_V_SYNC_POSITIVE : nvapi.h
  • NV_TIMINGEXT : nvapi.h
  • NV_TRUE : nvapi_lite_common.h
  • NV_VARIABLE_PIXEL_SHADING_TILE_HEIGHT : nvapi.h
  • NV_VARIABLE_PIXEL_SHADING_TILE_WIDTH : nvapi.h
  • NV_VERTEX_SHADER_PSO_EXTENSION_DESC_VER : nvapi.h
  • NV_VERTEX_SHADER_PSO_EXTENSION_DESC_VER_1 : nvapi.h
  • NV_VERTEX_SHADER_PSO_EXTENSION_DESC_VER_2 : nvapi.h
  • NV_VERTEX_SHADER_PSO_EXTENSION_DESC_VER_3 : nvapi.h
  • NV_VIEW_MODE_CLONE : nvapi.h
  • NV_VIEW_MODE_DUALVIEW : nvapi.h
  • NV_VIEW_MODE_HSPAN : nvapi.h
  • NV_VIEW_MODE_MULTIVIEW : nvapi.h
  • NV_VIEW_MODE_STANDARD : nvapi.h
  • NV_VIEW_MODE_VSPAN : nvapi.h
  • NV_VIEW_TARGET_INFO_VER : nvapi.h
  • NV_VIEWPORT_MASK_2_SEMANTIC : nvapi.h
  • NV_VIEWPORT_MASK_SEMANTIC : nvapi.h
  • NV_VIO_TOPOLOGY : nvapi.h
  • NV_VIO_TOPOLOGY_VER : nvapi.h
  • NV_VIRTUALIZATION_MODE : nvapi.h
  • NV_VIRTUALIZATION_MODE_HOST_VGPU : nvapi.h
  • NV_VIRTUALIZATION_MODE_NMOS : nvapi.h
  • NV_VIRTUALIZATION_MODE_NONE : nvapi.h
  • NV_VIRTUALIZATION_MODE_VGX : nvapi.h
  • NV_VRS_CONTENT_TYPE : nvapi.h
  • NV_VRS_CONTENT_TYPE_FOVEATED_RENDERING : nvapi.h
  • NV_VRS_CONTENT_TYPE_INVALID : nvapi.h
  • NV_VRS_CONTENT_TYPE_MAX : nvapi.h
  • NV_VRS_HELPER_DISABLE_PARAMS : nvapi.h
  • NV_VRS_HELPER_DISABLE_PARAMS_V1 : nvapi.h
  • NV_VRS_HELPER_DISABLE_PARAMS_VER : nvapi.h
  • NV_VRS_HELPER_DISABLE_PARAMS_VER1 : nvapi.h
  • NV_VRS_HELPER_ENABLE_PARAMS : nvapi.h
  • NV_VRS_HELPER_ENABLE_PARAMS_V1 : nvapi.h
  • NV_VRS_HELPER_ENABLE_PARAMS_VER : nvapi.h
  • NV_VRS_HELPER_ENABLE_PARAMS_VER1 : nvapi.h
  • NV_VRS_HELPER_GET_SHADING_RATE_RESOURCE_PARAMS : nvapi.h
  • NV_VRS_HELPER_GET_SHADING_RATE_RESOURCE_PARAMS_V1 : nvapi.h
  • NV_VRS_HELPER_GET_SHADING_RATE_RESOURCE_PARAMS_VER : nvapi.h
  • NV_VRS_HELPER_GET_SHADING_RATE_RESOURCE_PARAMS_VER1 : nvapi.h
  • NV_VRS_HELPER_INIT_PARAMS : nvapi.h
  • NV_VRS_HELPER_INIT_PARAMS_V1 : nvapi.h
  • NV_VRS_HELPER_INIT_PARAMS_VER : nvapi.h
  • NV_VRS_HELPER_INIT_PARAMS_VER1 : nvapi.h
  • NV_VRS_HELPER_LATCH_GAZE_PARAMS : nvapi.h
  • NV_VRS_HELPER_LATCH_GAZE_PARAMS_V1 : nvapi.h
  • NV_VRS_HELPER_LATCH_GAZE_PARAMS_VER : nvapi.h
  • NV_VRS_HELPER_LATCH_GAZE_PARAMS_VER1 : nvapi.h
  • NV_VRS_HELPER_PURGE_INTERNAL_RESOURCES_PARAMS : nvapi.h
  • NV_VRS_HELPER_PURGE_INTERNAL_RESOURCES_PARAMS_V1 : nvapi.h
  • NV_VRS_HELPER_PURGE_INTERNAL_RESOURCES_PARAMS_VER : nvapi.h
  • NV_VRS_HELPER_PURGE_INTERNAL_RESOURCES_PARAMS_VER1 : nvapi.h
  • NV_VRS_RENDER_MODE : nvapi.h
  • NV_VRS_RENDER_MODE_INVALID : nvapi.h
  • NV_VRS_RENDER_MODE_LEFT_EYE : nvapi.h
  • NV_VRS_RENDER_MODE_MAX : nvapi.h
  • NV_VRS_RENDER_MODE_MONO : nvapi.h
  • NV_VRS_RENDER_MODE_RIGHT_EYE : nvapi.h
  • NV_VRS_RENDER_MODE_STEREO : nvapi.h
  • NV_WARP_SIZE : nvShaderExtnEnums.h
  • NV_WARP_SIZE_LOG2 : nvShaderExtnEnums.h
  • NV_X_RIGHT_SEMANTIC : nvapi.h
  • NV_XYZW_RIGHT_SEMANTIC : nvapi.h
  • NvActiveThreads() : nvHLSLExtns.h
  • NvAll() : nvHLSLExtns.h
  • NvAny() : nvHLSLExtns.h
  • NVAPI_ACCESS_DENIED : nvapi_lite_common.h
  • NVAPI_ADVANCED_DISPLAY_HEADS : nvapi_lite_common.h
  • NVAPI_ADVANCED_DISPLAY_TOPOLOGY_REQUIRED : nvapi_lite_common.h
  • NVAPI_ADVANCED_MAX_DISPLAY_PATH : nvapi.h
  • NVAPI_ADVANCED_MAX_VIEW_TARGET : nvapi.h
  • NVAPI_ALIAS_SURFACE_FLAG : nvapi.h
  • NVAPI_ALIAS_SURFACE_FLAG_MASK : nvapi.h
  • NVAPI_ALIAS_SURFACE_FLAG_NONE : nvapi.h
  • NVAPI_ALIAS_SURFACE_FLAG_USE_SUPER : nvapi.h
  • NVAPI_ALL_GPUS : nvapi.h
  • NVAPI_ANSEL_CONFIGURATION_STRUCT : nvapi.h
  • NVAPI_ANSEL_CONFIGURATION_STRUCT_V1 : nvapi.h
  • NVAPI_ANSEL_CONFIGURATION_STRUCT_VER : nvapi.h
  • NVAPI_ANSEL_CONFIGURATION_STRUCT_VER1 : nvapi.h
  • NVAPI_ANSEL_FEATURE : nvapi.h
  • NVAPI_ANSEL_FEATURE_BLACK_AND_WHITE : nvapi.h
  • NVAPI_ANSEL_FEATURE_CONFIGURATION_STRUCT : nvapi.h
  • NVAPI_ANSEL_FEATURE_HUDLESS : nvapi.h
  • NVAPI_ANSEL_FEATURE_STATE : nvapi.h
  • NVAPI_ANSEL_FEATURE_STATE_DISABLE : nvapi.h
  • NVAPI_ANSEL_FEATURE_STATE_ENABLE : nvapi.h
  • NVAPI_ANSEL_FEATURE_STATE_UNKNOWN : nvapi.h
  • NVAPI_ANSEL_FEATURE_UNKNOWN : nvapi.h
  • NVAPI_ANSEL_HOTKEY_MODIFIER : nvapi.h
  • NVAPI_ANSEL_HOTKEY_MODIFIER_ALT : nvapi.h
  • NVAPI_ANSEL_HOTKEY_MODIFIER_CTRL : nvapi.h
  • NVAPI_ANSEL_HOTKEY_MODIFIER_SHIFT : nvapi.h
  • NVAPI_ANSEL_HOTKEY_MODIFIER_UNKNOWN : nvapi.h
  • NVAPI_API_IN_USE : nvapi_lite_common.h
  • NVAPI_API_NOT_INITIALIZED : nvapi_lite_common.h
  • NVAPI_API_NOT_INTIALIZED : nvapi.h
  • NVAPI_ARGUMENT_EXCEED_MAX_SIZE : nvapi_lite_common.h
  • NVAPI_BINARY_DATA_MAX : nvapi.h
  • NVAPI_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_EX_PARAMS : nvapi.h
  • NVAPI_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_EX_PARAMS_V1 : nvapi.h
  • NVAPI_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_EX_PARAMS_VER : nvapi.h
  • NVAPI_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_EX_PARAMS_VER1 : nvapi.h
  • NVAPI_BUILD_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PARAMS : nvapi.h
  • NVAPI_BUILD_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PARAMS_V1 : nvapi.h
  • NVAPI_BUILD_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PARAMS_VER : nvapi.h
  • NVAPI_BUILD_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PARAMS_VER1 : nvapi.h
  • NVAPI_BUILD_RAYTRACING_OPACITY_MICROMAP_ARRAY_PARAMS : nvapi.h
  • NVAPI_BUILD_RAYTRACING_OPACITY_MICROMAP_ARRAY_PARAMS_V1 : nvapi.h
  • NVAPI_BUILD_RAYTRACING_OPACITY_MICROMAP_ARRAY_PARAMS_VER : nvapi.h
  • NVAPI_BUILD_RAYTRACING_OPACITY_MICROMAP_ARRAY_PARAMS_VER1 : nvapi.h
  • NVAPI_CALLBACK_ALREADY_REGISTERED : nvapi_lite_common.h
  • NVAPI_CALLBACK_NOT_FOUND : nvapi_lite_common.h
  • NVAPI_CALLBACK_QSYNCEVENT : nvapi.h
  • NVAPI_CHECK_DRIVER_MATCHING_IDENTIFIER_EX_PARAMS : nvapi.h
  • NVAPI_CHECK_DRIVER_MATCHING_IDENTIFIER_EX_PARAMS_V1 : nvapi.h
  • NVAPI_CHECK_DRIVER_MATCHING_IDENTIFIER_EX_PARAMS_VER : nvapi.h
  • NVAPI_CHECK_DRIVER_MATCHING_IDENTIFIER_EX_PARAMS_VER1 : nvapi.h
  • NVAPI_CLUSTER_ALREADY_EXISTS : nvapi_lite_common.h
  • NVAPI_CONVERGENCE_ID : nvapi.h
  • NVAPI_COPY_ASYNCHRONOUSLY : nvapi.h
  • NVAPI_COPY_P2P_READ : nvapi.h
  • NVAPI_CPU_RESOURCE : nvapi.h
  • NvAPI_CreateDisplayFromUnAttachedDisplay() : nvapi.h
  • NVAPI_CU_KERNEL_LAUNCH_PARAMS : nvapi.h
  • NVAPI_CU_KERNEL_LAUNCH_PARAMS_EX : nvapi.h
  • NVAPI_D3D10_1_LIBRARY_NOT_FOUND : nvapi_lite_common.h
  • NvAPI_D3D10_SetDepthBoundsTest() : nvapi.h
  • NvAPI_D3D11_AliasMSAATexture2DAsNonMSAA() : nvapi.h
  • NvAPI_D3D11_BeginUAVOverlap() : nvapi.h
  • NvAPI_D3D11_BeginUAVOverlapEx() : nvapi.h
  • NvAPI_D3D11_CheckFeatureSupport() : nvapi.h
  • NvAPI_D3D11_CREATE_DOMAIN_SHADER_EX : nvapi.h
  • NvAPI_D3D11_CREATE_DOMAIN_SHADER_EX_V1 : nvapi.h
  • NvAPI_D3D11_CREATE_DOMAIN_SHADER_EX_V2 : nvapi.h
  • NvAPI_D3D11_CREATE_DOMAIN_SHADER_EX_V3 : nvapi.h
  • NvAPI_D3D11_CREATE_FASTGS_EXPLICIT_DESC : nvapi.h
  • NvAPI_D3D11_CREATE_GEOMETRY_SHADER_EX : nvapi.h
  • NvAPI_D3D11_CREATE_GEOMETRY_SHADER_EX_V5 : nvapi.h
  • NvAPI_D3D11_CREATE_HULL_SHADER_EX : nvapi.h
  • NvAPI_D3D11_CREATE_HULL_SHADER_EX_V1 : nvapi.h
  • NvAPI_D3D11_CREATE_HULL_SHADER_EX_V2 : nvapi.h
  • NvAPI_D3D11_CREATE_PIXEL_SHADER_EX : nvapi.h
  • NvAPI_D3D11_CREATE_PIXEL_SHADER_EX_V1 : nvapi.h
  • NvAPI_D3D11_CREATE_PIXEL_SHADER_EX_V2 : nvapi.h
  • NvAPI_D3D11_CREATE_VERTEX_SHADER_EX : nvapi.h
  • NvAPI_D3D11_CREATE_VERTEX_SHADER_EX_V1 : nvapi.h
  • NvAPI_D3D11_CREATE_VERTEX_SHADER_EX_V2 : nvapi.h
  • NvAPI_D3D11_CREATE_VERTEX_SHADER_EX_V3 : nvapi.h
  • NvAPI_D3D11_CreateCubinComputeShader() : nvapi.h
  • NvAPI_D3D11_CreateCubinComputeShaderEx() : nvapi.h
  • NvAPI_D3D11_CreateCubinComputeShaderWithName() : nvapi.h
  • NvAPI_D3D11_CreateDevice() : nvapi_lite_d3dext.h
  • NvAPI_D3D11_CreateDeviceAndSwapChain() : nvapi_lite_d3dext.h
  • NvAPI_D3D11_CreateDomainShaderEx() : nvapi.h
  • NVAPI_D3D11_CREATEDOMAINSHADEREX_VER_1 : nvapi.h
  • NVAPI_D3D11_CREATEDOMAINSHADEREX_VER_2 : nvapi.h
  • NVAPI_D3D11_CREATEDOMAINSHADEREX_VER_3 : nvapi.h
  • NVAPI_D3D11_CREATEDOMAINSHADEREX_VERSION : nvapi.h
  • NvAPI_D3D11_CreateFastGeometryShader() : nvapi.h
  • NvAPI_D3D11_CreateFastGeometryShaderExplicit() : nvapi.h
  • NVAPI_D3D11_CREATEFASTGSEXPLICIT_VER : nvapi.h
  • NVAPI_D3D11_CREATEFASTGSEXPLICIT_VER1 : nvapi.h
  • NvAPI_D3D11_CreateGeometryShaderEx_2() : nvapi.h
  • NVAPI_D3D11_CREATEGEOMETRYSHADEREX_2_VER_5 : nvapi.h
  • NVAPI_D3D11_CREATEGEOMETRYSHADEREX_2_VERSION : nvapi.h
  • NvAPI_D3D11_CreateHullShaderEx() : nvapi.h
  • NVAPI_D3D11_CREATEHULLSHADEREX_VER_1 : nvapi.h
  • NVAPI_D3D11_CREATEHULLSHADEREX_VER_2 : nvapi.h
  • NVAPI_D3D11_CREATEHULLSHADEREX_VERSION : nvapi.h
  • NvAPI_D3D11_CreateImplicitMSAATexture2D() : nvapi.h
  • NvAPI_D3D11_CreateMetaCommand() : nvapi.h
  • NvAPI_D3D11_CreateMultiGPUDevice() : nvapi.h
  • NvAPI_D3D11_CreatePixelShaderEx_2() : nvapi.h
  • NVAPI_D3D11_CREATEPIXELSHADEREX_VER_1 : nvapi.h
  • NVAPI_D3D11_CREATEPIXELSHADEREX_VER_2 : nvapi.h
  • NVAPI_D3D11_CREATEPIXELSHADEREX_VERSION : nvapi.h
  • NvAPI_D3D11_CreateRasterizerState() : nvapi.h
  • NvAPI_D3D11_CreateSamplerState() : nvapi.h
  • NvAPI_D3D11_CreateShaderResourceView() : nvapi.h
  • NvAPI_D3D11_CreateShadingRateResourceView() : nvapi.h
  • NvAPI_D3D11_CreateUnorderedAccessView() : nvapi.h
  • NvAPI_D3D11_CreateVertexShaderEx() : nvapi.h
  • NVAPI_D3D11_CREATEVERTEXSHADEREX_VER_1 : nvapi.h
  • NVAPI_D3D11_CREATEVERTEXSHADEREX_VER_2 : nvapi.h
  • NVAPI_D3D11_CREATEVERTEXSHADEREX_VER_3 : nvapi.h
  • NVAPI_D3D11_CREATEVERTEXSHADEREX_VERSION : nvapi.h
  • NvAPI_D3D11_DecompressView() : nvapi.h
  • NvAPI_D3D11_DestroyCubinComputeShader() : nvapi.h
  • NvAPI_D3D11_EndUAVOverlap() : nvapi.h
  • NvAPI_D3D11_EnumerateMetaCommands() : nvapi.h
  • NvAPI_D3D11_ExecuteMetaCommand() : nvapi.h
  • NvAPI_D3D11_GetCudaTextureObject() : nvapi.h
  • NvAPI_D3D11_GetResourceGPUVirtualAddress() : nvapi.h
  • NvAPI_D3D11_GetResourceGPUVirtualAddressEx() : nvapi.h
  • NvAPI_D3D11_GetResourceHandle() : nvapi.h
  • NvAPI_D3D11_InitializeMetaCommand() : nvapi.h
  • NVAPI_D3D11_INSERTWFI_FLAG : nvapi.h
  • NvAPI_D3D11_IsFatbinPTXSupported() : nvapi.h
  • NvAPI_D3D11_IsNvShaderExtnOpCodeSupported() : nvapi.h
  • NvAPI_D3D11_LaunchCubinShader() : nvapi.h
  • NVAPI_D3D11_LIBRARY_NOT_FOUND : nvapi_lite_common.h
  • NvAPI_D3D11_MultiDrawIndexedInstancedIndirect() : nvapi.h
  • NvAPI_D3D11_MultiDrawInstancedIndirect() : nvapi.h
  • NvAPI_D3D11_MultiGPU_GetCaps() : nvapi.h
  • NvAPI_D3D11_MultiGPU_Init() : nvapi.h
  • NvAPI_D3D11_RASTERIZER_DESC_EX : nvapi.h
  • NvAPI_D3D11_ResolveSubresourceRegion() : nvapi.h
  • NvAPI_D3D11_RSGetPixelShadingRateSampleOrder() : nvapi.h
  • NvAPI_D3D11_RSSetExclusiveScissorRects() : nvapi.h
  • NvAPI_D3D11_RSSetPixelShadingRateSampleOrder() : nvapi.h
  • NvAPI_D3D11_RSSetShadingRateResourceView() : nvapi.h
  • NvAPI_D3D11_RSSetViewportsPixelShadingRates() : nvapi.h
  • NvAPI_D3D11_SetDepthBoundsTest() : nvapi_lite_d3dext.h
  • NvAPI_D3D11_SetNvShaderExtnSlot() : nvapi.h
  • NvAPI_D3D11_SetNvShaderExtnSlotLocalThread() : nvapi.h
  • NvAPI_D3D11_SWIZZLE_MODE : nvapi.h
  • NVAPI_D3D12_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_DESC_EX : nvapi.h
  • NVAPI_D3D12_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_INPUTS_EX : nvapi.h
  • NVAPI_D3D12_BUILD_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_DESC : nvapi.h
  • NVAPI_D3D12_BUILD_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_INPUTS : nvapi.h
  • NVAPI_D3D12_BUILD_RAYTRACING_OPACITY_MICROMAP_ARRAY_DESC : nvapi.h
  • NVAPI_D3D12_BUILD_RAYTRACING_OPACITY_MICROMAP_ARRAY_INPUTS : nvapi.h
  • NvAPI_D3D12_BuildRaytracingAccelerationStructureEx() : nvapi.h
  • NvAPI_D3D12_BuildRaytracingDisplacementMicromapArray() : nvapi.h
  • NvAPI_D3D12_BuildRaytracingOpacityMicromapArray() : nvapi.h
  • NvAPI_D3D12_CaptureUAVInfo() : nvapi.h
  • NvAPI_D3D12_CheckDriverMatchingIdentifierEx() : nvapi.h
  • NvAPI_D3D12_CopyTextureRegion() : nvapi.h
  • NvAPI_D3D12_CopyTileMappings() : nvapi.h
  • NVAPI_D3D12_CREATE_CUBIN_SHADER_PARAMS : nvapi.h
  • NvAPI_D3D12_CreateCommittedImplicitMSAATexture2D() : nvapi.h
  • NvAPI_D3D12_CreateCommittedRDMABuffer() : nvapi.h
  • NvAPI_D3D12_CreateCommittedResource() : nvapi.h
  • NvAPI_D3D12_CreateComputePipelineState() : nvapi.h
  • NvAPI_D3D12_CreateCubinComputeShader() : nvapi.h
  • NvAPI_D3D12_CreateCubinComputeShaderEx() : nvapi.h
  • NvAPI_D3D12_CreateCubinComputeShaderExV2() : nvapi.h
  • NvAPI_D3D12_CreateCubinComputeShaderWithName() : nvapi.h
  • NvAPI_D3D12_CreateCuFunction() : nvapi.h
  • NvAPI_D3D12_CreateCuModule() : nvapi.h
  • NvAPI_D3D12_CreateDDisplayPresentBarrierClient() : nvapi.h
  • NvAPI_D3D12_CreateGraphicsPipelineState() : nvapi.h
  • NvAPI_D3D12_CreateHeap() : nvapi.h
  • NvAPI_D3D12_CreateHeap2() : nvapi.h
  • NvAPI_D3D12_CreateMetaCommand() : nvapi.h
  • NvAPI_D3D12_CreatePresentBarrierClient() : nvapi.h
  • NvAPI_D3D12_CreateReservedResource() : nvapi.h
  • NvAPI_D3D12_DestroyCubinComputeShader() : nvapi.h
  • NvAPI_D3D12_DestroyCuFunction() : nvapi.h
  • NvAPI_D3D12_DestroyCuModule() : nvapi.h
  • NvAPI_D3D12_EmitRaytracingDisplacementMicromapArrayPostbuildInfo() : nvapi.h
  • NvAPI_D3D12_EmitRaytracingOpacityMicromapArrayPostbuildInfo() : nvapi.h
  • NvAPI_D3D12_EnableRaytracingValidation() : nvapi.h
  • NvAPI_D3D12_EnumerateMetaCommands() : nvapi.h
  • NvAPI_D3D12_EnumFunctionsInModule() : nvapi.h
  • NvAPI_D3D12_ExecuteMetaCommand() : nvapi.h
  • NvAPI_D3D12_FlushRaytracingValidationMessages() : nvapi.h
  • NVAPI_D3D12_GET_CUDA_INDEPENDENT_DESCRIPTOR_OBJECT_PARAMS : nvapi.h
  • NVAPI_D3D12_GET_CUDA_INDEPENDENT_DESCRIPTOR_OBJECT_SAMPLER : nvapi.h
  • NVAPI_D3D12_GET_CUDA_INDEPENDENT_DESCRIPTOR_OBJECT_SURFACE : nvapi.h
  • NVAPI_D3D12_GET_CUDA_INDEPENDENT_DESCRIPTOR_OBJECT_TEXTURE : nvapi.h
  • NVAPI_D3D12_GET_CUDA_INDEPENDENT_DESCRIPTOR_OBJECT_TYPE : nvapi.h
  • NVAPI_D3D12_GET_CUDA_MERGED_TEXTURE_SAMPLER_OBJECT_PARAMS : nvapi.h
  • NvAPI_D3D12_GetCopyableFootprints() : nvapi.h
  • NvAPI_D3D12_GetCudaIndependentDescriptorObject() : nvapi.h
  • NvAPI_D3D12_GetCudaMergedTextureSamplerObject() : nvapi.h
  • NvAPI_D3D12_GetCudaSurfaceObject() : nvapi.h
  • NvAPI_D3D12_GetCudaTextureObject() : nvapi.h
  • NvAPI_D3D12_GetGraphicsCapabilities() : nvapi.h
  • NvAPI_D3D12_GetNeedsAppFPBlendClamping() : nvapi.h
  • NvAPI_D3D12_GetOptimalThreadCountForMesh() : nvapi.h
  • NvAPI_D3D12_GetRaytracingAccelerationStructurePrebuildInfoEx() : nvapi.h
  • NvAPI_D3D12_GetRaytracingCaps() : nvapi.h
  • NvAPI_D3D12_GetRaytracingDisplacementMicromapArrayPrebuildInfo() : nvapi.h
  • NvAPI_D3D12_GetRaytracingOpacityMicromapArrayPrebuildInfo() : nvapi.h
  • NvAPI_D3D12_InitializeMetaCommand() : nvapi.h
  • NvAPI_D3D12_IsFatbinPTXSupported() : nvapi.h
  • NvAPI_D3D12_IsNvShaderExtnOpCodeSupported() : nvapi.h
  • NvAPI_D3D12_LaunchCubinShader() : nvapi.h
  • NvAPI_D3D12_LaunchCuKernelChain() : nvapi.h
  • NvAPI_D3D12_LaunchCuKernelChainEx() : nvapi.h
  • NvAPI_D3D12_Mosaic_GetCompanionAllocations() : nvapi.h
  • NvAPI_D3D12_Mosaic_GetViewportAndGpuPartitions() : nvapi.h
  • NvAPI_D3D12_NotifyOutOfBandCommandQueue() : nvapi.h
  • NVAPI_D3D12_PIPELINE_CREATION_STATE_FLAGS : nvapi.h
  • NVAPI_D3D12_PIPELINE_CREATION_STATE_FLAGS_ENABLE_DMM_SUPPORT : nvapi.h
  • NVAPI_D3D12_PIPELINE_CREATION_STATE_FLAGS_ENABLE_OMM_SUPPORT : nvapi.h
  • NVAPI_D3D12_PIPELINE_CREATION_STATE_FLAGS_NONE : nvapi.h
  • NVAPI_D3D12_PSO_CREATE_FASTGS_EXPLICIT_DESC : nvapi.h
  • NVAPI_D3D12_PSO_DOMAIN_SHADER_DESC : nvapi.h
  • NVAPI_D3D12_PSO_ENABLE_DEPTH_BOUND_TEST_DESC : nvapi.h
  • NVAPI_D3D12_PSO_EXTENSION_DESC : nvapi.h
  • NVAPI_D3D12_PSO_GEOMETRY_SHADER_DESC : nvapi.h
  • NVAPI_D3D12_PSO_HULL_SHADER_DESC : nvapi.h
  • NVAPI_D3D12_PSO_RASTERIZER_STATE_DESC : nvapi.h
  • NVAPI_D3D12_PSO_REQUEST_FAST_GEOMETRY_SHADER_DESC : nvapi.h
  • NVAPI_D3D12_PSO_SET_SHADER_EXTENSION_SLOT_DESC : nvapi.h
  • NVAPI_D3D12_PSO_VERTEX_SHADER_DESC : nvapi.h
  • NvAPI_D3D12_QueryCpuVisibleVidmem() : nvapi.h
  • NvAPI_D3D12_QueryModifiedWSupport() : nvapi.h
  • NvAPI_D3D12_QueryPresentBarrierSupport() : nvapi.h
  • NvAPI_D3D12_QuerySinglePassStereoSupport() : nvapi.h
  • NvAPI_D3D12_QueryWorkstationFeatureProperties() : nvapi.h
  • NVAPI_D3D12_RAYTRACING_ACCELERATION_STRUCTURE_BUILD_FLAG_ALLOW_COMPACTION_EX : nvapi.h
  • NVAPI_D3D12_RAYTRACING_ACCELERATION_STRUCTURE_BUILD_FLAG_ALLOW_DATA_ACCESS_EX : nvapi.h
  • NVAPI_D3D12_RAYTRACING_ACCELERATION_STRUCTURE_BUILD_FLAG_ALLOW_DISABLE_OMMS_EX : nvapi.h
  • NVAPI_D3D12_RAYTRACING_ACCELERATION_STRUCTURE_BUILD_FLAG_ALLOW_OMM_OPACITY_STATES_UPDATE_EX : nvapi.h
  • NVAPI_D3D12_RAYTRACING_ACCELERATION_STRUCTURE_BUILD_FLAG_ALLOW_OMM_UPDATE_EX : nvapi.h
  • NVAPI_D3D12_RAYTRACING_ACCELERATION_STRUCTURE_BUILD_FLAG_ALLOW_UPDATE_EX : nvapi.h
  • NVAPI_D3D12_RAYTRACING_ACCELERATION_STRUCTURE_BUILD_FLAG_MINIMIZE_MEMORY_EX : nvapi.h
  • NVAPI_D3D12_RAYTRACING_ACCELERATION_STRUCTURE_BUILD_FLAG_NONE_EX : nvapi.h
  • NVAPI_D3D12_RAYTRACING_ACCELERATION_STRUCTURE_BUILD_FLAG_PERFORM_UPDATE_EX : nvapi.h
  • NVAPI_D3D12_RAYTRACING_ACCELERATION_STRUCTURE_BUILD_FLAG_PREFER_FAST_BUILD_EX : nvapi.h
  • NVAPI_D3D12_RAYTRACING_ACCELERATION_STRUCTURE_BUILD_FLAG_PREFER_FAST_TRACE_EX : nvapi.h
  • NVAPI_D3D12_RAYTRACING_ACCELERATION_STRUCTURE_BUILD_FLAGS_EX : nvapi.h
  • NVAPI_D3D12_RAYTRACING_CAPS_TYPE : nvapi.h
  • NVAPI_D3D12_RAYTRACING_CAPS_TYPE_DISPLACEMENT_MICROMAP : nvapi.h
  • NVAPI_D3D12_RAYTRACING_CAPS_TYPE_INVALID : nvapi.h
  • NVAPI_D3D12_RAYTRACING_CAPS_TYPE_OPACITY_MICROMAP : nvapi.h
  • NVAPI_D3D12_RAYTRACING_CAPS_TYPE_THREAD_REORDERING : nvapi.h
  • NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_BUILD_FLAG_NONE : nvapi.h
  • NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_BUILD_FLAG_PREFER_FAST_BUILD : nvapi.h
  • NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_BUILD_FLAG_PREFER_FAST_TRACE : nvapi.h
  • NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_BUILD_FLAGS : nvapi.h
  • NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_BYTE_ALIGNMENT : nvapi.h
  • NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_POSTBUILD_INFO_CURRENT_SIZE : nvapi.h
  • NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_POSTBUILD_INFO_CURRENT_SIZE_DESC : nvapi.h
  • NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_POSTBUILD_INFO_DESC : nvapi.h
  • NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_POSTBUILD_INFO_TYPE : nvapi.h
  • NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PREBUILD_INFO : nvapi.h
  • NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_CAP_NONE : nvapi.h
  • NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_CAP_STANDARD : nvapi.h
  • NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_CAPS : nvapi.h
  • NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_DC1_MAX_SUBDIVISION_LEVEL : nvapi.h
  • NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_DESC : nvapi.h
  • NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_FORMAT : nvapi.h
  • NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_FORMAT_DC1_1024_TRIS_128_BYTES : nvapi.h
  • NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_FORMAT_DC1_256_TRIS_128_BYTES : nvapi.h
  • NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_FORMAT_DC1_64_TRIS_64_BYTES : nvapi.h
  • NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_PRIMITIVE_FLAG_DECIMATE_01 : nvapi.h
  • NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_PRIMITIVE_FLAG_DECIMATE_12 : nvapi.h
  • NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_PRIMITIVE_FLAG_DECIMATE_20 : nvapi.h
  • NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_PRIMITIVE_FLAGS : nvapi.h
  • NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_USAGE_COUNT : nvapi.h
  • NVAPI_D3D12_RAYTRACING_GEOMETRY_DESC_EX : nvapi.h
  • NVAPI_D3D12_RAYTRACING_GEOMETRY_DMM_ATTACHMENT_DESC : nvapi.h
  • NVAPI_D3D12_RAYTRACING_GEOMETRY_DMM_TRIANGLES_DESC : nvapi.h
  • NVAPI_D3D12_RAYTRACING_GEOMETRY_OMM_ATTACHMENT_DESC : nvapi.h
  • NVAPI_D3D12_RAYTRACING_GEOMETRY_OMM_TRIANGLES_DESC : nvapi.h
  • NVAPI_D3D12_RAYTRACING_GEOMETRY_TYPE_DMM_TRIANGLES_EX : nvapi.h
  • NVAPI_D3D12_RAYTRACING_GEOMETRY_TYPE_EX : nvapi.h
  • NVAPI_D3D12_RAYTRACING_GEOMETRY_TYPE_OMM_TRIANGLES_EX : nvapi.h
  • NVAPI_D3D12_RAYTRACING_GEOMETRY_TYPE_PROCEDURAL_PRIMITIVE_AABBS_EX : nvapi.h
  • NVAPI_D3D12_RAYTRACING_GEOMETRY_TYPE_TRIANGLES_EX : nvapi.h
  • NVAPI_D3D12_RAYTRACING_INSTANCE_FLAG_DISABLE_OMMS_EX : nvapi.h
  • NVAPI_D3D12_RAYTRACING_INSTANCE_FLAG_FORCE_NON_OPAQUE_EX : nvapi.h
  • NVAPI_D3D12_RAYTRACING_INSTANCE_FLAG_FORCE_OMM_2_STATE_EX : nvapi.h
  • NVAPI_D3D12_RAYTRACING_INSTANCE_FLAG_FORCE_OPAQUE_EX : nvapi.h
  • NVAPI_D3D12_RAYTRACING_INSTANCE_FLAG_NONE_EX : nvapi.h
  • NVAPI_D3D12_RAYTRACING_INSTANCE_FLAG_TRIANGLE_CULL_DISABLE_EX : nvapi.h
  • NVAPI_D3D12_RAYTRACING_INSTANCE_FLAG_TRIANGLE_FRONT_COUNTERCLOCKWISE_EX : nvapi.h
  • NVAPI_D3D12_RAYTRACING_INSTANCE_FLAGS_EX : nvapi.h
  • NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_ARRAY_BUILD_FLAG_NONE : nvapi.h
  • NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_ARRAY_BUILD_FLAG_PREFER_FAST_BUILD : nvapi.h
  • NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_ARRAY_BUILD_FLAG_PREFER_FAST_TRACE : nvapi.h
  • NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_ARRAY_BUILD_FLAGS : nvapi.h
  • NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_ARRAY_BYTE_ALIGNMENT : nvapi.h
  • NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_ARRAY_POSTBUILD_INFO_CURRENT_SIZE : nvapi.h
  • NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_ARRAY_POSTBUILD_INFO_CURRENT_SIZE_DESC : nvapi.h
  • NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_ARRAY_POSTBUILD_INFO_DESC : nvapi.h
  • NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_ARRAY_POSTBUILD_INFO_TYPE : nvapi.h
  • NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_ARRAY_PREBUILD_INFO : nvapi.h
  • NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_CAP_NONE : nvapi.h
  • NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_CAP_STANDARD : nvapi.h
  • NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_CAPS : nvapi.h
  • NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_DESC : nvapi.h
  • NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_FORMAT : nvapi.h
  • NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_FORMAT_OC1_2_STATE : nvapi.h
  • NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_FORMAT_OC1_4_STATE : nvapi.h
  • NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_OC1_MAX_SUBDIVISION_LEVEL : nvapi.h
  • NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_SPECIAL_INDEX : nvapi.h
  • NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_SPECIAL_INDEX_FULLY_OPAQUE : nvapi.h
  • NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_SPECIAL_INDEX_FULLY_TRANSPARENT : nvapi.h
  • NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_SPECIAL_INDEX_FULLY_UNKNOWN_OPAQUE : nvapi.h
  • NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_SPECIAL_INDEX_FULLY_UNKNOWN_TRANSPARENT : nvapi.h
  • NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_STATE : nvapi.h
  • NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_STATE_OPAQUE : nvapi.h
  • NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_STATE_TRANSPARENT : nvapi.h
  • NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_STATE_UNKNOWN_OPAQUE : nvapi.h
  • NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_STATE_UNKNOWN_TRANSPARENT : nvapi.h
  • NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_USAGE_COUNT : nvapi.h
  • NVAPI_D3D12_RAYTRACING_THREAD_REORDERING_CAP_NONE : nvapi.h
  • NVAPI_D3D12_RAYTRACING_THREAD_REORDERING_CAP_STANDARD : nvapi.h
  • NVAPI_D3D12_RAYTRACING_THREAD_REORDERING_CAPS : nvapi.h
  • NVAPI_D3D12_RAYTRACING_VALIDATION_FLAG_NONE : nvapi.h
  • NVAPI_D3D12_RAYTRACING_VALIDATION_FLAGS : nvapi.h
  • NVAPI_D3D12_RAYTRACING_VALIDATION_MESSAGE_CALLBACK : nvapi.h
  • NVAPI_D3D12_RAYTRACING_VALIDATION_MESSAGE_SEVERITY : nvapi.h
  • NVAPI_D3D12_RAYTRACING_VALIDATION_MESSAGE_SEVERITY_ERROR : nvapi.h
  • NVAPI_D3D12_RAYTRACING_VALIDATION_MESSAGE_SEVERITY_WARNING : nvapi.h
  • NvAPI_D3D12_RegisterPresentBarrierResources() : nvapi.h
  • NvAPI_D3D12_RegisterRaytracingValidationMessageCallback() : nvapi.h
  • NvAPI_D3D12_RelocateRaytracingDisplacementMicromapArray() : nvapi.h
  • NvAPI_D3D12_RelocateRaytracingOpacityMicromapArray() : nvapi.h
  • NvAPI_D3D12_ReservedResourceGetDesc() : nvapi.h
  • NvAPI_D3D12_ResolveSubresourceRegion() : nvapi.h
  • NvAPI_D3D12_ResourceAliasingBarrier() : nvapi.h
  • NVAPI_D3D12_SERIALIZED_DATA_RAYTRACING_ACCELERATION_STRUCTURE_EX : nvapi.h
  • NVAPI_D3D12_SERIALIZED_DATA_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_EX : nvapi.h
  • NVAPI_D3D12_SERIALIZED_DATA_RAYTRACING_OPACITY_MICROMAP_ARRAY_EX : nvapi.h
  • NVAPI_D3D12_SERIALIZED_DATA_TYPE_EX : nvapi.h
  • NVAPI_D3D12_SET_CREATE_PIPELINE_STATE_OPTIONS_PARAMS : nvapi.h
  • NVAPI_D3D12_SET_CREATE_PIPELINE_STATE_OPTIONS_PARAMS_V1 : nvapi.h
  • NVAPI_D3D12_SET_CREATE_PIPELINE_STATE_OPTIONS_PARAMS_VER : nvapi.h
  • NVAPI_D3D12_SET_CREATE_PIPELINE_STATE_OPTIONS_PARAMS_VER1 : nvapi.h
  • NvAPI_D3D12_SetAsyncFrameMarker() : nvapi.h
  • NvAPI_D3D12_SetCreateCommandQueueLowLatencyHint() : nvapi.h
  • NvAPI_D3D12_SetCreatePipelineStateOptions() : nvapi.h
  • NvAPI_D3D12_SetDepthBoundsTestValues() : nvapi.h
  • NvAPI_D3D12_SetModifiedWMode() : nvapi.h
  • NvAPI_D3D12_SetNvShaderExtnSlotSpace() : nvapi.h
  • NvAPI_D3D12_SetNvShaderExtnSlotSpaceLocalThread() : nvapi.h
  • NvAPI_D3D12_SetSinglePassStereoMode() : nvapi.h
  • NvAPI_D3D12_UnregisterRaytracingValidationMessageCallback() : nvapi.h
  • NvAPI_D3D12_UpdateTileMappings() : nvapi.h
  • NvAPI_D3D12_UseDriverHeapPriorities() : nvapi.h
  • NVAPI_D3D12_WORKSTATION_FEATURE_PROPERTIES_PARAMS : nvapi.h
  • NVAPI_D3D12_WORKSTATION_FEATURE_PROPERTIES_PARAMS_V1 : nvapi.h
  • NVAPI_D3D12_WORKSTATION_FEATURE_PROPERTIES_PARAMS_VER : nvapi.h
  • NVAPI_D3D12_WORKSTATION_FEATURE_PROPERTIES_PARAMS_VER1 : nvapi.h
  • NvAPI_D3D1x_BindSwapBarrier() : nvapi.h
  • NvAPI_D3D1x_CreateSwapChain() : nvapi.h
  • NvAPI_D3D1x_DisableShaderDiskCache() : nvapi.h
  • NvAPI_D3D1x_GetGraphicsCapabilities() : nvapi.h
  • NvAPI_D3D1x_JoinSwapGroup() : nvapi.h
  • NvAPI_D3D1x_Present() : nvapi.h
  • NvAPI_D3D1x_QueryFrameCount() : nvapi.h
  • NvAPI_D3D1x_QueryMaxSwapGroup() : nvapi.h
  • NvAPI_D3D1x_QuerySwapGroup() : nvapi.h
  • NvAPI_D3D1x_ResetFrameCount() : nvapi.h
  • NvAPI_D3D9_AliasSurfaceAsTexture() : nvapi.h
  • NvAPI_D3D9_BindSwapBarrier() : nvapi.h
  • NvAPI_D3D9_ClearRT() : nvapi.h
  • NvAPI_D3D9_CreateSwapChain() : nvapi.h
  • NvAPI_D3D9_GetSurfaceHandle() : nvapi.h
  • NvAPI_D3D9_JoinSwapGroup() : nvapi.h
  • NvAPI_D3D9_Present() : nvapi.h
  • NvAPI_D3D9_QueryFrameCount() : nvapi.h
  • NvAPI_D3D9_QueryMaxSwapGroup() : nvapi.h
  • NvAPI_D3D9_QuerySwapGroup() : nvapi.h
  • NvAPI_D3D9_RegisterResource() : nvapi.h
  • NvAPI_D3D9_ResetFrameCount() : nvapi.h
  • NvAPI_D3D9_StretchRectEx() : nvapi.h
  • NvAPI_D3D9_UnregisterResource() : nvapi.h
  • NvAPI_D3D9_VideoSetStereoInfo() : nvapi.h
  • NVAPI_D3D_BEGIN_UAV_OVERLAP_COMP_WFI : nvapi.h
  • NVAPI_D3D_BEGIN_UAV_OVERLAP_GFX_WFI : nvapi.h
  • NVAPI_D3D_BEGIN_UAV_OVERLAP_NO_WFI : nvapi.h
  • NvAPI_D3D_BeginResourceRendering() : nvapi_lite_sli.h
  • NvAPI_D3D_ConfigureAnsel() : nvapi.h
  • NVAPI_D3D_CONTEXT_NOT_FOUND : nvapi_lite_common.h
  • NvAPI_D3D_CreateLateLatchObject() : nvapi.h
  • NVAPI_D3D_DEVICE_LOST : nvapi_lite_common.h
  • NVAPI_D3D_DEVICE_NOT_REGISTERED : nvapi_lite_common.h
  • NvAPI_D3D_EndResourceRendering() : nvapi_lite_sli.h
  • NvAPI_D3D_GetCurrentSLIState() : nvapi_lite_sli.h
  • NvAPI_D3D_GetLatency() : nvapi.h
  • NvAPI_D3D_GetObjectHandleForResource() : nvapi_lite_common.h
  • NvAPI_D3D_GetSleepStatus() : nvapi.h
  • NvAPI_D3D_ImplicitSLIControl() : nvapi.h
  • NvAPI_D3D_InitializeNvGazeHandler() : nvapi.h
  • NvAPI_D3D_InitializeSMPAssist() : nvapi.h
  • NvAPI_D3D_InitializeVRSHelper() : nvapi.h
  • NvAPI_D3D_IsGSyncActive() : nvapi.h
  • NvAPI_D3D_IsGSyncCapable() : nvapi.h
  • NvAPI_D3D_QueryLateLatchSupport() : nvapi.h
  • NvAPI_D3D_QueryModifiedWSupport() : nvapi.h
  • NvAPI_D3D_QueryMultiViewSupport() : nvapi.h
  • NvAPI_D3D_QuerySinglePassStereoSupport() : nvapi.h
  • NvAPI_D3D_QuerySMPAssistSupport() : nvapi.h
  • NvAPI_D3D_RegisterDevice() : nvapi.h
  • NVAPI_D3D_RESOURCERENDERING_FLAG : nvapi_lite_sli.h
  • NVAPI_D3D_RR_FLAG_DEFAULTS : nvapi_lite_sli.h
  • NVAPI_D3D_RR_FLAG_FORCE_DISCARD_CONTENT : nvapi_lite_sli.h
  • NVAPI_D3D_RR_FLAG_FORCE_KEEP_CONTENT : nvapi_lite_sli.h
  • NVAPI_D3D_RR_FLAG_MULTI_FRAME : nvapi_lite_sli.h
  • NvAPI_D3D_SetFPSIndicatorState() : nvapi.h
  • NvAPI_D3D_SetLatencyMarker() : nvapi.h
  • NvAPI_D3D_SetModifiedWMode() : nvapi.h
  • NvAPI_D3D_SetMultiViewMode() : nvapi.h
  • NvAPI_D3D_SetReflexSync() : nvapi.h
  • NvAPI_D3D_SetResourceHint() : nvapi_lite_sli.h
  • NVAPI_D3D_SETRESOURCEHINT_CATEGORY : nvapi_lite_sli.h
  • NVAPI_D3D_SETRESOURCEHINT_SLI : nvapi_lite_sli.h
  • NvAPI_D3D_SetSinglePassStereoMode() : nvapi.h
  • NvAPI_D3D_SetSleepMode() : nvapi.h
  • NvAPI_D3D_SetVerticalSyncMode() : nvapi.h
  • NvAPI_D3D_Sleep() : nvapi.h
  • NVAPI_D3D_SRH_CATEGORY_SLI : nvapi_lite_sli.h
  • NVAPI_D3D_SRH_SLI_APP_CONTROLLED_INTERFRAME_CONTENT_SYNC : nvapi_lite_sli.h
  • NVAPI_D3D_SRH_SLI_ASK_FOR_BROADCAST_USAGE : nvapi_lite_sli.h
  • NVAPI_D3D_SRH_SLI_RESPECT_DRIVER_INTERFRAME_CONTENT_SYNC : nvapi_lite_sli.h
  • NVAPI_DATA_NOT_FOUND : nvapi_lite_common.h
  • NVAPI_DATATYPE_MISMATCH : nvapi_lite_common.h
  • NVAPI_DEFAULT_HANDLE : nvapi_lite_common.h
  • NVAPI_DEFAULT_STEREO_PROFILE_DOES_NOT_EXIST : nvapi_lite_common.h
  • NVAPI_DEFAULT_STEREO_PROFILE_IS_NOT_DEFINED : nvapi_lite_common.h
  • NvAPI_DestroyPresentBarrierClient() : nvapi.h
  • NVAPI_DEVICE_BUSY : nvapi_lite_common.h
  • NVAPI_DEVICE_FEATURE_LEVEL : nvapi_lite_d3dext.h
  • NVAPI_DEVICE_FEATURE_LEVEL_10_0 : nvapi_lite_d3dext.h
  • NVAPI_DEVICE_FEATURE_LEVEL_10_0_PLUS : nvapi_lite_d3dext.h
  • NVAPI_DEVICE_FEATURE_LEVEL_10_1 : nvapi_lite_d3dext.h
  • NVAPI_DEVICE_FEATURE_LEVEL_11_0 : nvapi_lite_d3dext.h
  • NVAPI_DEVICE_FEATURE_LEVEL_NULL : nvapi_lite_d3dext.h
  • NVAPI_DEVICE_SWITCHING_NOT_ALLOWED : nvapi_lite_common.h
  • NVAPI_DIM3 : nvapi.h
  • NvAPI_DirectD3D12GraphicsCommandList_Create() : nvapi.h
  • NvAPI_DirectD3D12GraphicsCommandList_Release() : nvapi.h
  • NvAPI_DirectD3D12GraphicsCommandList_Reset() : nvapi.h
  • NvAPI_DisableHWCursor() : nvapi.h
  • NvAPI_DISP_AcquireDedicatedDisplay() : nvapi.h
  • NvAPI_Disp_ColorControl() : nvapi.h
  • NvAPI_DISP_DeleteCustomDisplay() : nvapi.h
  • NvAPI_DISP_EnumCustomDisplay() : nvapi.h
  • NvAPI_DISP_GetAdaptiveSyncData() : nvapi.h
  • NvAPI_DISP_GetAssociatedUnAttachedNvidiaDisplayHandle() : nvapi.h
  • NvAPI_DISP_GetDisplayConfig() : nvapi.h
  • NvAPI_DISP_GetDisplayIdByDisplayName() : nvapi.h
  • NvAPI_DISP_GetEdidData() : nvapi.h
  • NvAPI_DISP_GetGDIPrimaryDisplayId() : nvapi_lite_surround.h
  • NvAPI_Disp_GetHdrCapabilities() : nvapi.h
  • NvAPI_Disp_GetHdrToneMapping() : nvapi.h
  • NvAPI_DISP_GetMonitorCapabilities() : nvapi.h
  • NvAPI_DISP_GetMonitorColorCapabilities() : nvapi.h
  • NvAPI_DISP_GetNvManagedDedicatedDisplayMetadata() : nvapi.h
  • NvAPI_DISP_GetNvManagedDedicatedDisplays() : nvapi.h
  • NvAPI_Disp_GetOutputMode() : nvapi.h
  • NvAPI_DISP_GetPreferredStereoDisplay() : nvapi.h
  • NvAPI_Disp_GetSourceColorSpace() : nvapi.h
  • NvAPI_Disp_GetSourceHdrMetadata() : nvapi.h
  • NvAPI_DISP_GetTiming() : nvapi.h
  • NvAPI_DISP_GetVirtualRefreshRateData() : nvapi.h
  • NvAPI_Disp_GetVRRInfo() : nvapi.h
  • NvAPI_Disp_HdrColorControl() : nvapi.h
  • NvAPI_Disp_InfoFrameControl() : nvapi.h
  • NvAPI_DISP_ReleaseDedicatedDisplay() : nvapi.h
  • NvAPI_DISP_RevertCustomDisplayTrial() : nvapi.h
  • NvAPI_DISP_SaveCustomDisplay() : nvapi.h
  • NvAPI_DISP_SetAdaptiveSyncData() : nvapi.h
  • NvAPI_DISP_SetDisplayConfig() : nvapi.h
  • NvAPI_Disp_SetHdrToneMapping() : nvapi.h
  • NvAPI_DISP_SetNvManagedDedicatedDisplayMetadata() : nvapi.h
  • NvAPI_Disp_SetOutputMode() : nvapi.h
  • NvAPI_DISP_SetPreferredStereoDisplay() : nvapi.h
  • NvAPI_Disp_SetSourceColorSpace() : nvapi.h
  • NvAPI_Disp_SetSourceHdrMetadata() : nvapi.h
  • NvAPI_DISP_SetVirtualRefreshRateData() : nvapi.h
  • NvAPI_DISP_TryCustomDisplay() : nvapi.h
  • NVAPI_DISPLAY_DEVICE_MASK_MAX : nvapi.h
  • NVAPI_DISPLAY_IN_USE : nvapi_lite_common.h
  • NVAPI_DISPLAY_MUX_TRANSITION_FAILED : nvapi_lite_common.h
  • NVAPI_DISPLAYCONFIG_VALIDATION_FAILED : nvapi_lite_common.h
  • NVAPI_DPMST_CHANGED : nvapi_lite_common.h
  • NVAPI_DPMST_DISPLAY_ID_EXPECTED : nvapi_lite_common.h
  • NVAPI_DRIVER_NOTRUNNING : nvapi_lite_common.h
  • NVAPI_DRIVER_RUNNING : nvapi_lite_common.h
  • NvAPI_DRS_CreateApplication() : nvapi.h
  • NvAPI_DRS_CreateProfile() : nvapi.h
  • NvAPI_DRS_CreateSession() : nvapi.h
  • NvAPI_DRS_DeleteApplication() : nvapi.h
  • NvAPI_DRS_DeleteApplicationEx() : nvapi.h
  • NvAPI_DRS_DeleteProfile() : nvapi.h
  • NvAPI_DRS_DeleteProfileSetting() : nvapi.h
  • NvAPI_DRS_DestroySession() : nvapi.h
  • NvAPI_DRS_EnumApplications() : nvapi.h
  • NvAPI_DRS_EnumAvailableSettingIds() : nvapi.h
  • NvAPI_DRS_EnumAvailableSettingValues() : nvapi.h
  • NvAPI_DRS_EnumProfiles() : nvapi.h
  • NvAPI_DRS_EnumSettings() : nvapi.h
  • NvAPI_DRS_FindApplicationByName() : nvapi.h
  • NvAPI_DRS_FindProfileByName() : nvapi.h
  • NvAPI_DRS_GetApplicationInfo() : nvapi.h
  • NvAPI_DRS_GetBaseProfile() : nvapi.h
  • NvAPI_DRS_GetCurrentGlobalProfile() : nvapi.h
  • NvAPI_DRS_GetNumProfiles() : nvapi.h
  • NvAPI_DRS_GetProfileInfo() : nvapi.h
  • NvAPI_DRS_GetSetting() : nvapi.h
  • NvAPI_DRS_GetSettingIdFromName() : nvapi.h
  • NvAPI_DRS_GetSettingNameFromId() : nvapi.h
  • NVAPI_DRS_GLOBAL_PROFILE : nvapi.h
  • NvAPI_DRS_LoadSettings() : nvapi.h
  • NvAPI_DRS_LoadSettingsFromFile() : nvapi.h
  • NvAPI_DRS_RestoreAllDefaults() : nvapi.h
  • NvAPI_DRS_RestoreProfileDefault() : nvapi.h
  • NvAPI_DRS_RestoreProfileDefaultSetting() : nvapi.h
  • NvAPI_DRS_SaveSettings() : nvapi.h
  • NvAPI_DRS_SaveSettingsToFile() : nvapi.h
  • NvAPI_DRS_SetCurrentGlobalProfile() : nvapi.h
  • NvAPI_DRS_SetProfileInfo() : nvapi.h
  • NvAPI_DRS_SetSetting() : nvapi.h
  • NVAPI_ECID_KEY_VERIFICATION_FAILED : nvapi_lite_common.h
  • NVAPI_ECID_SIGN_ALGO_UNSUPPORTED : nvapi_lite_common.h
  • NVAPI_EMIT_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_POSTBUILD_INFO_PARAMS : nvapi.h
  • NVAPI_EMIT_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_POSTBUILD_INFO_PARAMS_V1 : nvapi.h
  • NVAPI_EMIT_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_POSTBUILD_INFO_PARAMS_VER : nvapi.h
  • NVAPI_EMIT_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_POSTBUILD_INFO_PARAMS_VER1 : nvapi.h
  • NVAPI_EMIT_RAYTRACING_OPACITY_MICROMAP_ARRAY_POSTBUILD_INFO_PARAMS : nvapi.h
  • NVAPI_EMIT_RAYTRACING_OPACITY_MICROMAP_ARRAY_POSTBUILD_INFO_PARAMS_V1 : nvapi.h
  • NVAPI_EMIT_RAYTRACING_OPACITY_MICROMAP_ARRAY_POSTBUILD_INFO_PARAMS_VER : nvapi.h
  • NVAPI_EMIT_RAYTRACING_OPACITY_MICROMAP_ARRAY_POSTBUILD_INFO_PARAMS_VER1 : nvapi.h
  • NvAPI_EnableCurrentMosaicTopology() : nvapi.h
  • NvAPI_EnableHWCursor() : nvapi.h
  • NVAPI_END_ENUMERATION : nvapi_lite_common.h
  • NvAPI_EnumLogicalGPUs() : nvapi.h
  • NvAPI_EnumNvidiaDisplayHandle() : nvapi.h
  • NvAPI_EnumNvidiaUnAttachedDisplayHandle() : nvapi.h
  • NvAPI_EnumPhysicalGPUs() : nvapi_lite_common.h
  • NvAPI_EnumTCCPhysicalGPUs() : nvapi.h
  • NVAPI_ERROR : nvapi_lite_common.h
  • NVAPI_ERROR_DRIVER_RELOAD_IN_PROGRESS : nvapi_lite_common.h
  • NVAPI_ERROR_DRIVER_RELOAD_REQUIRED : nvapi_lite_common.h
  • NvAPI_Event_RegisterCallback() : nvapi.h
  • NvAPI_Event_UnregisterCallback() : nvapi.h
  • NVAPI_EXECUTABLE_ALREADY_IN_USE : nvapi_lite_common.h
  • NVAPI_EXECUTABLE_NOT_FOUND : nvapi_lite_common.h
  • NVAPI_EXECUTABLE_PATH_IS_AMBIGUOUS : nvapi_lite_common.h
  • NVAPI_EXPECTED_ANALOG_DISPLAY : nvapi_lite_common.h
  • NVAPI_EXPECTED_COMPUTE_GPU_HANDLE : nvapi_lite_common.h
  • NVAPI_EXPECTED_DIGITAL_FLAT_PANEL : nvapi_lite_common.h
  • NVAPI_EXPECTED_DISPLAY_HANDLE : nvapi_lite_common.h
  • NVAPI_EXPECTED_LOGICAL_GPU_HANDLE : nvapi_lite_common.h
  • NVAPI_EXPECTED_NON_PRIMARY_DISPLAY_HANDLE : nvapi_lite_common.h
  • NVAPI_EXPECTED_PHYSICAL_GPU_HANDLE : nvapi_lite_common.h
  • NVAPI_EXPECTED_TV_DISPLAY : nvapi_lite_common.h
  • NVAPI_EXPECTED_TV_DISPLAY_ON_DCONNECTOR : nvapi_lite_common.h
  • NVAPI_EXPECTED_UNATTACHED_DISPLAY_HANDLE : nvapi_lite_common.h
  • NVAPI_FAILED_TO_LOAD_FROM_DRIVER_STORE : nvapi_lite_common.h
  • NVAPI_FILE_NOT_FOUND : nvapi_lite_common.h
  • NVAPI_FIRMWARE_OUT_OF_DATE : nvapi_lite_common.h
  • NVAPI_FIRMWARE_REVISION_NOT_SUPPORTED : nvapi_lite_common.h
  • NVAPI_FRUSTUM_ADJUST_MODE_ID : nvapi.h
  • NVAPI_FRUSTUM_CLEAR_EDGES : nvapi.h
  • NVAPI_FRUSTUM_STRETCH : nvapi.h
  • NVAPI_FUNCTION_NOT_FOUND : nvapi_lite_common.h
  • NVAPI_GENERIC_STRING_MAX : nvapi_lite_common.h
  • NVAPI_GET_RAYTRACING_ACCELERATION_STRUCTURE_PREBUILD_INFO_EX_PARAMS : nvapi.h
  • NVAPI_GET_RAYTRACING_ACCELERATION_STRUCTURE_PREBUILD_INFO_EX_PARAMS_V1 : nvapi.h
  • NVAPI_GET_RAYTRACING_ACCELERATION_STRUCTURE_PREBUILD_INFO_EX_PARAMS_VER : nvapi.h
  • NVAPI_GET_RAYTRACING_ACCELERATION_STRUCTURE_PREBUILD_INFO_EX_PARAMS_VER1 : nvapi.h
  • NVAPI_GET_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PREBUILD_INFO_PARAMS : nvapi.h
  • NVAPI_GET_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PREBUILD_INFO_PARAMS_V1 : nvapi.h
  • NVAPI_GET_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PREBUILD_INFO_PARAMS_VER : nvapi.h
  • NVAPI_GET_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PREBUILD_INFO_PARAMS_VER1 : nvapi.h
  • NVAPI_GET_RAYTRACING_OPACITY_MICROMAP_ARRAY_PREBUILD_INFO_PARAMS : nvapi.h
  • NVAPI_GET_RAYTRACING_OPACITY_MICROMAP_ARRAY_PREBUILD_INFO_PARAMS_V1 : nvapi.h
  • NVAPI_GET_RAYTRACING_OPACITY_MICROMAP_ARRAY_PREBUILD_INFO_PARAMS_VER : nvapi.h
  • NVAPI_GET_RAYTRACING_OPACITY_MICROMAP_ARRAY_PREBUILD_INFO_PARAMS_VER1 : nvapi.h
  • NvAPI_GetAssociatedDisplayOutputId() : nvapi.h
  • NvAPI_GetAssociatedNvidiaDisplayHandle() : nvapi.h
  • NvAPI_GetAssociatedNvidiaDisplayName() : nvapi.h
  • NvAPI_GetCurrentMosaicTopology() : nvapi.h
  • NvAPI_GetDisplayPortInfo() : nvapi.h
  • NvAPI_GetErrorMessage() : nvapi.h
  • NvAPI_GetGPUIDfromPhysicalGPU() : nvapi.h
  • NvAPI_GetHDMISupportInfo() : nvapi.h
  • NvAPI_GetInterfaceVersionString() : nvapi.h
  • NvAPI_GetInterfaceVersionStringEx() : nvapi.h
  • NvAPI_GetLogicalGPUFromDisplay() : nvapi.h
  • NvAPI_GetLogicalGPUFromPhysicalGPU() : nvapi.h
  • NvAPI_GetPhysicalGPUFromGPUID() : nvapi.h
  • NvAPI_GetPhysicalGPUFromUnAttachedDisplay() : nvapi.h
  • NvAPI_GetPhysicalGPUsFromDisplay() : nvapi.h
  • NvAPI_GetPhysicalGPUsFromLogicalGPU() : nvapi.h
  • NvAPI_GetSupportedMosaicTopologies() : nvapi.h
  • NvAPI_GetSupportedViews() : nvapi.h
  • NvAPI_GetUnAttachedAssociatedDisplayName() : nvapi.h
  • NvAPI_GetVBlankCounter() : nvapi.h
  • NVAPI_GPU_BUS_TYPE_AGP : nvapi.h
  • NVAPI_GPU_BUS_TYPE_AXI : nvapi.h
  • NVAPI_GPU_BUS_TYPE_FPCI : nvapi.h
  • NVAPI_GPU_BUS_TYPE_PCI : nvapi.h
  • NVAPI_GPU_BUS_TYPE_PCI_EXPRESS : nvapi.h
  • NVAPI_GPU_BUS_TYPE_UNDEFINED : nvapi.h
  • NvAPI_GPU_ClientIllumDevicesGetControl() : nvapi.h
  • NvAPI_GPU_ClientIllumDevicesGetInfo() : nvapi.h
  • NvAPI_GPU_ClientIllumDevicesSetControl() : nvapi.h
  • NvAPI_GPU_ClientIllumZonesGetControl() : nvapi.h
  • NvAPI_GPU_ClientIllumZonesGetInfo() : nvapi.h
  • NvAPI_GPU_ClientIllumZonesSetControl() : nvapi.h
  • NvAPI_GPU_ClientRegisterForUtilizationSampleUpdates() : nvapi.h
  • NVAPI_GPU_CONNECTOR_ADC : nvapi.h
  • NVAPI_GPU_CONNECTOR_DISPLAYPORT_EXTERNAL : nvapi.h
  • NVAPI_GPU_CONNECTOR_DISPLAYPORT_INTERNAL : nvapi.h
  • NVAPI_GPU_CONNECTOR_DISPLAYPORT_MINI_EXT : nvapi.h
  • NVAPI_GPU_CONNECTOR_DVI_D : nvapi.h
  • NVAPI_GPU_CONNECTOR_DVI_I : nvapi.h
  • NVAPI_GPU_CONNECTOR_DVI_I_TV_COMPOSITE : nvapi.h
  • NVAPI_GPU_CONNECTOR_DVI_I_TV_SVIDEO : nvapi.h
  • NVAPI_GPU_CONNECTOR_HDMI_A : nvapi.h
  • NVAPI_GPU_CONNECTOR_HDMI_C_MINI : nvapi.h
  • NVAPI_GPU_CONNECTOR_LFH_DISPLAYPORT_1 : nvapi.h
  • NVAPI_GPU_CONNECTOR_LFH_DISPLAYPORT_2 : nvapi.h
  • NVAPI_GPU_CONNECTOR_LFH_DVI_I_1 : nvapi.h
  • NVAPI_GPU_CONNECTOR_LFH_DVI_I_2 : nvapi.h
  • NVAPI_GPU_CONNECTOR_OEM : nvapi.h
  • NVAPI_GPU_CONNECTOR_PC_POD_COMPOSITE : nvapi.h
  • NVAPI_GPU_CONNECTOR_PC_POD_HDTV_YPRPB : nvapi.h
  • NVAPI_GPU_CONNECTOR_PC_POD_SVIDEO : nvapi.h
  • NVAPI_GPU_CONNECTOR_SPWG : nvapi.h
  • NVAPI_GPU_CONNECTOR_TV_COMPOSITE : nvapi.h
  • NVAPI_GPU_CONNECTOR_TV_COMPOSITE_SCART_ON_EIAJ4120 : nvapi.h
  • NVAPI_GPU_CONNECTOR_TV_HDTV_COMPONENT : nvapi.h
  • NVAPI_GPU_CONNECTOR_TV_HDTV_EIAJ4120 : nvapi.h
  • NVAPI_GPU_CONNECTOR_TV_SCART : nvapi.h
  • NVAPI_GPU_CONNECTOR_TV_SVIDEO : nvapi.h
  • NVAPI_GPU_CONNECTOR_UNKNOWN : nvapi.h
  • NVAPI_GPU_CONNECTOR_USB_C : nvapi.h
  • NVAPI_GPU_CONNECTOR_VGA_15_PIN : nvapi.h
  • NVAPI_GPU_CONNECTOR_VIRTUAL_WFD : nvapi.h
  • NvAPI_GPU_GetActiveOutputs() : nvapi.h
  • NvAPI_GPU_GetAllClockFrequencies() : nvapi.h
  • NvAPI_GPU_GetAllDisplayIds() : nvapi.h
  • NvAPI_GPU_GetArchInfo() : nvapi.h
  • NvAPI_GPU_GetBoardInfo() : nvapi.h
  • NvAPI_GPU_GetBusId() : nvapi.h
  • NvAPI_GPU_GetBusSlotId() : nvapi.h
  • NvAPI_GPU_GetBusType() : nvapi.h
  • NvAPI_GPU_GetConnectedDisplayIds() : nvapi.h
  • NvAPI_GPU_GetCurrentPCIEDownstreamWidth() : nvapi.h
  • NvAPI_GPU_GetCurrentPstate() : nvapi.h
  • NvAPI_GPU_GetDynamicPstatesInfoEx() : nvapi.h
  • NvAPI_GPU_GetECCConfigurationInfo() : nvapi.h
  • NvAPI_GPU_GetECCErrorInfo() : nvapi.h
  • NvAPI_GPU_GetECCStatusInfo() : nvapi.h
  • NvAPI_GPU_GetEDID() : nvapi.h
  • NvAPI_GPU_GetFullName() : nvapi.h
  • NvAPI_GPU_GetGpuCoreCount() : nvapi.h
  • NvAPI_GPU_GetGPUInfo() : nvapi.h
  • NvAPI_GPU_GetGPUType() : nvapi.h
  • NvAPI_GPU_GetGspFeatures() : nvapi.h
  • NvAPI_GPU_GetHDCPSupportStatus() : nvapi.h
  • NvAPI_GPU_GetIllumination() : nvapi.h
  • NvAPI_GPU_GetIRQ() : nvapi.h
  • NvAPI_GPU_GetLicensableFeatures() : nvapi.h
  • NvAPI_GPU_GetLogicalGpuInfo() : nvapi.h
  • NvAPI_GPU_GetMemoryInfoEx() : nvapi_lite_common.h
  • NvAPI_GPU_GetOutputType() : nvapi.h
  • NvAPI_GPU_GetPCIIdentifiers() : nvapi.h
  • NvAPI_GPU_GetPerfDecreaseInfo() : nvapi.h
  • NvAPI_GPU_GetPhysicalFrameBufferSize() : nvapi.h
  • NvAPI_GPU_GetPstates20() : nvapi.h
  • NvAPI_GPU_GetRamBusWidth() : nvapi.h
  • NvAPI_GPU_GetScanoutCompositionParameter() : nvapi.h
  • NvAPI_GPU_GetScanoutConfiguration() : nvapi.h
  • NvAPI_GPU_GetScanoutConfigurationEx() : nvapi.h
  • NvAPI_GPU_GetScanoutIntensityState() : nvapi.h
  • NvAPI_GPU_GetScanoutWarpingState() : nvapi.h
  • NvAPI_GPU_GetShaderSubPipeCount() : nvapi.h
  • NvAPI_GPU_GetSystemType() : nvapi.h
  • NvAPI_GPU_GetTachReading() : nvapi.h
  • NvAPI_GPU_GetThermalSettings() : nvapi.h
  • NvAPI_GPU_GetVbiosOEMRevision() : nvapi.h
  • NvAPI_GPU_GetVbiosRevision() : nvapi.h
  • NvAPI_GPU_GetVbiosVersionString() : nvapi.h
  • NvAPI_GPU_GetVirtualFrameBufferSize() : nvapi.h
  • NvAPI_GPU_GetVirtualizationInfo() : nvapi.h
  • NvAPI_GPU_GetVRReadyData() : nvapi.h
  • NVAPI_GPU_IN_DEBUG_MODE : nvapi_lite_common.h
  • NVAPI_GPU_MAX_BUILD_VERSION_LENGTH : nvapi.h
  • NVAPI_GPU_NOT_POWERED : nvapi_lite_common.h
  • NvAPI_GPU_NVLINK_GetCaps() : nvapi.h
  • NvAPI_GPU_NVLINK_GetStatus() : nvapi.h
  • NVAPI_GPU_OUTPUT_CRT : nvapi.h
  • NVAPI_GPU_OUTPUT_DFP : nvapi.h
  • NVAPI_GPU_OUTPUT_TV : nvapi.h
  • NVAPI_GPU_OUTPUT_UNKNOWN : nvapi.h
  • NVAPI_GPU_PERF_DECREASE : nvapi.h
  • NVAPI_GPU_PERF_PSTATE20_CLOCK_TYPE_RANGE : nvapi.h
  • NVAPI_GPU_PERF_PSTATE20_CLOCK_TYPE_SINGLE : nvapi.h
  • NVAPI_GPU_PERF_PSTATE_ALL : nvapi.h
  • NVAPI_GPU_PERF_PSTATE_P0 : nvapi.h
  • NVAPI_GPU_PERF_PSTATE_P1 : nvapi.h
  • NVAPI_GPU_PERF_PSTATE_P10 : nvapi.h
  • NVAPI_GPU_PERF_PSTATE_P11 : nvapi.h
  • NVAPI_GPU_PERF_PSTATE_P12 : nvapi.h
  • NVAPI_GPU_PERF_PSTATE_P13 : nvapi.h
  • NVAPI_GPU_PERF_PSTATE_P14 : nvapi.h
  • NVAPI_GPU_PERF_PSTATE_P15 : nvapi.h
  • NVAPI_GPU_PERF_PSTATE_P2 : nvapi.h
  • NVAPI_GPU_PERF_PSTATE_P3 : nvapi.h
  • NVAPI_GPU_PERF_PSTATE_P4 : nvapi.h
  • NVAPI_GPU_PERF_PSTATE_P5 : nvapi.h
  • NVAPI_GPU_PERF_PSTATE_P6 : nvapi.h
  • NVAPI_GPU_PERF_PSTATE_P7 : nvapi.h
  • NVAPI_GPU_PERF_PSTATE_P8 : nvapi.h
  • NVAPI_GPU_PERF_PSTATE_P9 : nvapi.h
  • NVAPI_GPU_PERF_PSTATE_UNDEFINED : nvapi.h
  • NVAPI_GPU_PERF_VOLTAGE_INFO_DOMAIN_CORE : nvapi.h
  • NVAPI_GPU_PERF_VOLTAGE_INFO_DOMAIN_UNDEFINED : nvapi.h
  • NVAPI_GPU_PUBLIC_CLOCK_GRAPHICS : nvapi.h
  • NVAPI_GPU_PUBLIC_CLOCK_MEMORY : nvapi.h
  • NVAPI_GPU_PUBLIC_CLOCK_PROCESSOR : nvapi.h
  • NVAPI_GPU_PUBLIC_CLOCK_UNDEFINED : nvapi.h
  • NVAPI_GPU_PUBLIC_CLOCK_VIDEO : nvapi.h
  • NvAPI_GPU_QueryIlluminationSupport() : nvapi.h
  • NvAPI_GPU_QueryWorkstationFeatureSupport() : nvapi.h
  • NvAPI_GPU_ResetECCErrorInfo() : nvapi.h
  • NvAPI_GPU_SetECCConfiguration() : nvapi.h
  • NvAPI_GPU_SetEDID() : nvapi.h
  • NvAPI_GPU_SetIllumination() : nvapi.h
  • NvAPI_GPU_SetScanoutCompositionParameter() : nvapi.h
  • NvAPI_GPU_SetScanoutIntensity() : nvapi.h
  • NvAPI_GPU_SetScanoutWarping() : nvapi.h
  • NvAPI_GPU_ValidateOutputCombination() : nvapi.h
  • NVAPI_GPU_WORKSTATION_FEATURE_INCOMPLETE : nvapi_lite_common.h
  • NVAPI_GPU_WORKSTATION_FEATURE_MASK : nvapi.h
  • NVAPI_GPU_WORKSTATION_FEATURE_MASK_BPC10 : nvapi.h
  • NVAPI_GPU_WORKSTATION_FEATURE_MASK_GRAYSCALE : nvapi.h
  • NVAPI_GPU_WORKSTATION_FEATURE_MASK_PIXINTENSITY : nvapi.h
  • NVAPI_GPU_WORKSTATION_FEATURE_MASK_STEREO : nvapi.h
  • NVAPI_GPU_WORKSTATION_FEATURE_MASK_SWAPGROUP : nvapi.h
  • NVAPI_GPU_WORKSTATION_FEATURE_MASK_WARPING : nvapi.h
  • NvAPI_GPU_WorkstationFeatureQuery() : nvapi.h
  • NvAPI_GPU_WorkstationFeatureSetup() : nvapi.h
  • NvAPI_GSync_AdjustSyncDelay() : nvapi.h
  • NVAPI_GSYNC_BOARD_ID_P2060 : nvapi.h
  • NVAPI_GSYNC_BOARD_ID_P2061 : nvapi.h
  • NVAPI_GSYNC_BOARD_ID_P358 : nvapi.h
  • NVAPI_GSYNC_DELAY_TYPE : nvapi.h
  • NVAPI_GSYNC_DELAY_TYPE_STARTUP : nvapi.h
  • NVAPI_GSYNC_DELAY_TYPE_SYNC_SKEW : nvapi.h
  • NVAPI_GSYNC_DELAY_TYPE_UNKNOWN : nvapi.h
  • NVAPI_GSYNC_DISPLAY_SYNC_STATE : nvapi.h
  • NVAPI_GSYNC_DISPLAY_SYNC_STATE_MASTER : nvapi.h
  • NVAPI_GSYNC_DISPLAY_SYNC_STATE_SLAVE : nvapi.h
  • NVAPI_GSYNC_DISPLAY_SYNC_STATE_UNSYNCED : nvapi.h
  • NVAPI_GSYNC_DIVIDE_MODE : nvapi.h
  • NvAPI_GSync_EnumSyncDevices() : nvapi.h
  • NvAPI_GSync_GetControlParameters() : nvapi.h
  • NvAPI_GSync_GetStatusParameters() : nvapi.h
  • NvAPI_GSync_GetSyncStatus() : nvapi.h
  • NvAPI_GSync_GetTopology() : nvapi.h
  • NVAPI_GSYNC_GPU_TOPOLOGY_CONNECTOR : nvapi.h
  • NVAPI_GSYNC_GPU_TOPOLOGY_CONNECTOR_NONE : nvapi.h
  • NVAPI_GSYNC_GPU_TOPOLOGY_CONNECTOR_PRIMARY : nvapi.h
  • NVAPI_GSYNC_GPU_TOPOLOGY_CONNECTOR_QUARTERNARY : nvapi.h
  • NVAPI_GSYNC_GPU_TOPOLOGY_CONNECTOR_SECONDARY : nvapi.h
  • NVAPI_GSYNC_GPU_TOPOLOGY_CONNECTOR_TERTIARY : nvapi.h
  • NVAPI_GSYNC_MULTIPLY_DIVIDE_MODE : nvapi.h
  • NVAPI_GSYNC_MULTIPLY_MODE : nvapi.h
  • NVAPI_GSYNC_POLARITY : nvapi.h
  • NVAPI_GSYNC_POLARITY_BOTH_EDGES : nvapi.h
  • NVAPI_GSYNC_POLARITY_FALLING_EDGE : nvapi.h
  • NVAPI_GSYNC_POLARITY_RISING_EDGE : nvapi.h
  • NvAPI_GSync_QueryCapabilities() : nvapi.h
  • NVAPI_GSYNC_RJ45_INPUT : nvapi.h
  • NVAPI_GSYNC_RJ45_IO : nvapi.h
  • NVAPI_GSYNC_RJ45_OUTPUT : nvapi.h
  • NVAPI_GSYNC_RJ45_UNUSED : nvapi.h
  • NvAPI_GSync_SetControlParameters() : nvapi.h
  • NvAPI_GSync_SetSyncStateSettings() : nvapi.h
  • NVAPI_GSYNC_SYNC_SOURCE : nvapi.h
  • NVAPI_GSYNC_SYNC_SOURCE_HOUSESYNC : nvapi.h
  • NVAPI_GSYNC_SYNC_SOURCE_VSYNC : nvapi.h
  • NVAPI_GSYNC_UNDEFINED_MODE : nvapi.h
  • NVAPI_GSYNC_VIDEO_MODE : nvapi.h
  • NVAPI_GSYNC_VIDEO_MODE_COMPOSITE : nvapi.h
  • NVAPI_GSYNC_VIDEO_MODE_HDTV : nvapi.h
  • NVAPI_GSYNC_VIDEO_MODE_NONE : nvapi.h
  • NVAPI_GSYNC_VIDEO_MODE_NTSCPALSECAM : nvapi.h
  • NVAPI_GSYNC_VIDEO_MODE_TTL : nvapi.h
  • NVAPI_GVI_DEFAULT_RAW_CAPTURE_IMAGES : nvapi.h
  • NVAPI_GVI_MAX_RAW_CAPTURE_IMAGES : nvapi.h
  • NVAPI_GVI_MIN_RAW_CAPTURE_IMAGES : nvapi.h
  • NVAPI_HANDLE_INVALIDATED : nvapi_lite_common.h
  • NVAPI_HDCP_DISABLED : nvapi_lite_common.h
  • NVAPI_HDCP_ENCRYPTION_FAILED : nvapi_lite_common.h
  • NVAPI_I2C_SPEED_100KHZ : nvapi.h
  • NVAPI_I2C_SPEED_10KHZ : nvapi.h
  • NVAPI_I2C_SPEED_200KHZ : nvapi.h
  • NVAPI_I2C_SPEED_33KHZ : nvapi.h
  • NVAPI_I2C_SPEED_3KHZ : nvapi.h
  • NVAPI_I2C_SPEED_400KHZ : nvapi.h
  • NVAPI_I2C_SPEED_DEFAULT : nvapi.h
  • NVAPI_I2C_SPEED_DEPRECATED : nvapi.h
  • NvAPI_I2CRead() : nvapi.h
  • NvAPI_I2CWrite() : nvapi.h
  • NVAPI_ID_OUT_OF_RANGE : nvapi_lite_common.h
  • NVAPI_ILLEGAL_INSTRUCTION : nvapi_lite_common.h
  • NVAPI_IMPLICIT_SET_GPU_TOPOLOGY_CHANGE_NOT_ALLOWED : nvapi_lite_common.h
  • NVAPI_INCOMPATIBLE_AUDIO_DRIVER : nvapi_lite_common.h
  • NVAPI_INCOMPATIBLE_STRUCT_VERSION : nvapi_lite_common.h
  • NVAPI_INCORRECT_VENDOR : nvapi_lite_common.h
  • NvAPI_Initialize() : nvapi.h
  • NVAPI_INSTRUMENTATION_DISABLED : nvapi_lite_common.h
  • NVAPI_INSUFFICIENT_BUFFER : nvapi_lite_common.h
  • NVAPI_INTERFACE : nvapi_lite_salstart.h
  • NVAPI_INVALID_ADDRESS : nvapi_lite_common.h
  • NVAPI_INVALID_ARGUMENT : nvapi_lite_common.h
  • NVAPI_INVALID_CALL : nvapi_lite_common.h
  • NVAPI_INVALID_COMBINATION : nvapi_lite_common.h
  • NVAPI_INVALID_CONFIGURATION : nvapi_lite_common.h
  • NVAPI_INVALID_DIRECT_MODE_DISPLAY : nvapi_lite_common.h
  • NVAPI_INVALID_DISPLAY_ID : nvapi_lite_common.h
  • NVAPI_INVALID_DSC_OUTPUT_BPP : nvapi_lite_common.h
  • NVAPI_INVALID_DSC_SLICECOUNT : nvapi_lite_common.h
  • NVAPI_INVALID_DSC_VERSION : nvapi_lite_common.h
  • NVAPI_INVALID_HANDLE : nvapi_lite_common.h
  • NVAPI_INVALID_HYBRID_MODE : nvapi_lite_common.h
  • NVAPI_INVALID_IMAGE : nvapi_lite_common.h
  • NVAPI_INVALID_OUTPUT_WIRE_FORMAT : nvapi_lite_common.h
  • NVAPI_INVALID_PC : nvapi_lite_common.h
  • NVAPI_INVALID_PERF_LEVEL : nvapi_lite_common.h
  • NVAPI_INVALID_POINTER : nvapi_lite_common.h
  • NVAPI_INVALID_PTX : nvapi_lite_common.h
  • NVAPI_INVALID_SOURCE : nvapi_lite_common.h
  • NVAPI_INVALID_SYNC_TOPOLOGY : nvapi_lite_common.h
  • NVAPI_INVALID_USER_PRIVILEGE : nvapi_lite_common.h
  • NVAPI_JIT_COMPILER_NOT_FOUND : nvapi_lite_common.h
  • NvAPI_JoinPresentBarrier() : nvapi.h
  • NVAPI_LAUNCH_FAILED : nvapi_lite_common.h
  • NvAPI_LeavePresentBarrier() : nvapi.h
  • NVAPI_LIBRARY_NOT_FOUND : nvapi_lite_common.h
  • NVAPI_LICENSE_CALLER_AUTHENTICATION_FAILED : nvapi_lite_common.h
  • NvAPI_LicenseString : nvapi.h
  • NVAPI_LONG_STRING_MAX : nvapi_lite_common.h
  • NvAPI_LongString : nvapi_lite_common.h
  • NvAPI_LPCWSTR : nvapi.h
  • NVAPI_MATCHING_DEVICE_NOT_FOUND : nvapi_lite_common.h
  • NVAPI_MAX_ACPI_IDS : nvapi_lite_common.h
  • NVAPI_MAX_AUDIO_DEVICES : nvapi_lite_common.h
  • NVAPI_MAX_AVAILABLE_GPU_TOPOLOGIES : nvapi_lite_common.h
  • NVAPI_MAX_AVAILABLE_SLI_GROUPS : nvapi_lite_common.h
  • NVAPI_MAX_DISPLAY_HEADS : nvapi_lite_common.h
  • NVAPI_MAX_DISPLAY_LIMIT_REACHED : nvapi_lite_common.h
  • NVAPI_MAX_DISPLAY_PATH : nvapi.h
  • NVAPI_MAX_DISPLAYS : nvapi_lite_common.h
  • NVAPI_MAX_FRAMELOCK_MAPPING_MODES : nvapi.h
  • NVAPI_MAX_GPU_CLOCKS : nvapi.h
  • NVAPI_MAX_GPU_PER_TOPOLOGY : nvapi_lite_common.h
  • NVAPI_MAX_GPU_PERF_CLOCKS : nvapi.h
  • NVAPI_MAX_GPU_PERF_PSTATES : nvapi.h
  • NVAPI_MAX_GPU_PERF_VOLTAGES : nvapi.h
  • NVAPI_MAX_GPU_PSTATE20_BASE_VOLTAGES : nvapi.h
  • NVAPI_MAX_GPU_PSTATE20_CLOCKS : nvapi.h
  • NVAPI_MAX_GPU_PSTATE20_PSTATES : nvapi.h
  • NVAPI_MAX_GPU_PUBLIC_CLOCKS : nvapi.h
  • NVAPI_MAX_GPU_TOPOLOGIES : nvapi_lite_common.h
  • NVAPI_MAX_GPU_UTILIZATIONS : nvapi.h
  • NVAPI_MAX_GSYNC_DEVICES : nvapi.h
  • NVAPI_MAX_HEADS_PER_GPU : nvapi_lite_common.h
  • NVAPI_MAX_LOGICAL_GPUS : nvapi_lite_common.h
  • NVAPI_MAX_MOSAIC_DISPLAY_COLUMNS : nvapi.h
  • NVAPI_MAX_MOSAIC_DISPLAY_ROWS : nvapi.h
  • NVAPI_MAX_MOSAIC_TOPOS : nvapi.h
  • NVAPI_MAX_PHYSICAL_BRIDGES : nvapi_lite_common.h
  • NVAPI_MAX_PHYSICAL_GPUS : nvapi_lite_common.h
  • NVAPI_MAX_RJ45_PER_GSYNC : nvapi.h
  • NVAPI_MAX_SIZEOF_I2C_DATA_BUFFER : nvapi.h
  • NVAPI_MAX_SIZEOF_I2C_REG_ADDRESS : nvapi.h
  • NVAPI_MAX_THERMAL_SENSORS_PER_GPU : nvapi.h
  • NVAPI_MAX_VIEW_MODES : nvapi_lite_common.h
  • NVAPI_MAX_VIEW_TARGET : nvapi.h
  • NVAPI_MAX_VIO_CHANNELS_PER_JACK : nvapi.h
  • NVAPI_MAX_VIO_DEVICES : nvapi.h
  • NVAPI_MAX_VIO_JACKS : nvapi.h
  • NVAPI_MAX_VIO_LINKS_PER_STREAM : nvapi.h
  • NVAPI_MAX_VIO_STREAMS : nvapi.h
  • NVAPI_MIN_VIO_STREAMS : nvapi.h
  • NVAPI_MIXED_TARGET_TYPES : nvapi_lite_common.h
  • NVAPI_MODE_CHANGE_FAILED : nvapi_lite_common.h
  • NVAPI_MOSAIC_DISPLAY_SETTING_VER : nvapi.h
  • NVAPI_MOSAIC_DISPLAY_SETTING_VER1 : nvapi.h
  • NVAPI_MOSAIC_DISPLAY_SETTING_VER2 : nvapi.h
  • NvAPI_Mosaic_EnableCurrentTopo() : nvapi.h
  • NvAPI_Mosaic_EnumDisplayGrids() : nvapi.h
  • NvAPI_Mosaic_EnumDisplayModes() : nvapi.h
  • NvAPI_Mosaic_GetCurrentTopo() : nvapi.h
  • NvAPI_Mosaic_GetDisplayViewportsByResolution() : nvapi_lite_surround.h
  • NvAPI_Mosaic_GetOverlapLimits() : nvapi.h
  • NvAPI_Mosaic_GetSupportedTopoInfo() : nvapi.h
  • NvAPI_Mosaic_GetTopoGroup() : nvapi.h
  • NVAPI_MOSAIC_NOT_ACTIVE : nvapi_lite_common.h
  • NvAPI_Mosaic_SetCurrentTopo() : nvapi.h
  • NvAPI_Mosaic_SetDisplayGrids() : nvapi.h
  • NVAPI_MOSAIC_SUPPORTED_TOPO_INFO_VER : nvapi.h
  • NVAPI_MOSAIC_SUPPORTED_TOPO_INFO_VER1 : nvapi.h
  • NVAPI_MOSAIC_SUPPORTED_TOPO_INFO_VER2 : nvapi.h
  • NVAPI_MOSAIC_SUPPORTED_TOPOLOGIES_VER : nvapi.h
  • NVAPI_MOSAIC_TOPO_BRIEF_VER : nvapi.h
  • NVAPI_MOSAIC_TOPO_DETAILS_VER : nvapi.h
  • NVAPI_MOSAIC_TOPO_GROUP_VER : nvapi.h
  • NVAPI_MOSAIC_TOPOLOGY_VER : nvapi.h
  • NvAPI_Mosaic_ValidateDisplayGrids() : nvapi.h
  • NVAPI_NO_ACTIVE_SLI_TOPOLOGY : nvapi_lite_common.h
  • NVAPI_NO_CONNECTOR_FOUND : nvapi_lite_common.h
  • NVAPI_NO_FRUSTUM_ADJUST : nvapi.h
  • NVAPI_NO_GL_EXPERT : nvapi_lite_common.h
  • NVAPI_NO_GL_NSIGHT : nvapi_lite_common.h
  • NVAPI_NO_IMPLEMENTATION : nvapi_lite_common.h
  • NVAPI_NO_VIDLINK : nvapi_lite_common.h
  • NVAPI_NO_VULKAN : nvapi_lite_common.h
  • NVAPI_NOT_PERMITTED : nvapi_lite_common.h
  • NVAPI_NOT_SUPPORTED : nvapi_lite_common.h
  • NVAPI_NV_PERSIST_FILE_NOT_FOUND : nvapi_lite_common.h
  • NVAPI_NVIDIA_DEVICE_NOT_FOUND : nvapi_lite_common.h
  • NVAPI_NVIDIA_DISPLAY_NOT_FOUND : nvapi_lite_common.h
  • NVAPI_NVLINK_CAPS_NCI_VERSION_1_0 : nvapi.h
  • NVAPI_NVLINK_CAPS_NCI_VERSION_2_0 : nvapi.h
  • NVAPI_NVLINK_CAPS_NCI_VERSION_INVALID : nvapi.h
  • NVAPI_NVLINK_CAPS_NVLINK_VERSION_1_0 : nvapi.h
  • NVAPI_NVLINK_CAPS_NVLINK_VERSION_2_0 : nvapi.h
  • NVAPI_NVLINK_CAPS_NVLINK_VERSION_INVALID : nvapi.h
  • NVAPI_NVLINK_CAPS_P2P_ATOMICS : nvapi.h
  • NVAPI_NVLINK_CAPS_P2P_SUPPORTED : nvapi.h
  • NVAPI_NVLINK_CAPS_PEX_TUNNELING : nvapi.h
  • NVAPI_NVLINK_CAPS_POWER_STATE_L0 : nvapi.h
  • NVAPI_NVLINK_CAPS_POWER_STATE_L1 : nvapi.h
  • NVAPI_NVLINK_CAPS_POWER_STATE_L2 : nvapi.h
  • NVAPI_NVLINK_CAPS_POWER_STATE_L3 : nvapi.h
  • NVAPI_NVLINK_CAPS_SLI_BRIDGE : nvapi.h
  • NVAPI_NVLINK_CAPS_SLI_BRIDGE_SENSABLE : nvapi.h
  • NVAPI_NVLINK_CAPS_SUPPORTED : nvapi.h
  • NVAPI_NVLINK_CAPS_SYSMEM_ACCESS : nvapi.h
  • NVAPI_NVLINK_CAPS_SYSMEM_ATOMICS : nvapi.h
  • NVAPI_NVLINK_CAPS_VALID : nvapi.h
  • NVAPI_NVLINK_COUNTER_MAX_TYPES : nvapi.h
  • NVAPI_NVLINK_DEVICE_INFO_DEVICE_ID_FLAGS_NONE : nvapi.h
  • NVAPI_NVLINK_DEVICE_INFO_DEVICE_ID_FLAGS_PCI : nvapi.h
  • NVAPI_NVLINK_DEVICE_INFO_DEVICE_ID_FLAGS_UUID : nvapi.h
  • NVAPI_NVLINK_DEVICE_INFO_DEVICE_TYPE : nvapi.h
  • NVAPI_NVLINK_DEVICE_INFO_DEVICE_TYPE_EBRIDGE : nvapi.h
  • NVAPI_NVLINK_DEVICE_INFO_DEVICE_TYPE_GPU : nvapi.h
  • NVAPI_NVLINK_DEVICE_INFO_DEVICE_TYPE_NONE : nvapi.h
  • NVAPI_NVLINK_DEVICE_INFO_DEVICE_TYPE_NPU : nvapi.h
  • NVAPI_NVLINK_DEVICE_INFO_DEVICE_TYPE_SWITCH : nvapi.h
  • NVAPI_NVLINK_DEVICE_INFO_DEVICE_TYPE_TEGRA : nvapi.h
  • NVAPI_NVLINK_DEVICE_INFO_DEVICE_UUID_INVALID : nvapi.h
  • NVAPI_NVLINK_MAX_LINKS : nvapi.h
  • NVAPI_NVLINK_REFCLK_TYPE_INVALID : nvapi.h
  • NVAPI_NVLINK_REFCLK_TYPE_NVHS : nvapi.h
  • NVAPI_NVLINK_REFCLK_TYPE_PEX : nvapi.h
  • NVAPI_NVLINK_STATUS_CONNECTED_FALSE : nvapi.h
  • NVAPI_NVLINK_STATUS_CONNECTED_TRUE : nvapi.h
  • NVAPI_NVLINK_STATUS_GRS_VERSION_1_0 : nvapi.h
  • NVAPI_NVLINK_STATUS_GRS_VERSION_INVALID : nvapi.h
  • NVAPI_NVLINK_STATUS_LINK_STATE : nvapi.h
  • NVAPI_NVLINK_STATUS_LINK_STATE_ACTIVE : nvapi.h
  • NVAPI_NVLINK_STATUS_LINK_STATE_FAULT : nvapi.h
  • NVAPI_NVLINK_STATUS_LINK_STATE_HWCFG : nvapi.h
  • NVAPI_NVLINK_STATUS_LINK_STATE_INIT : nvapi.h
  • NVAPI_NVLINK_STATUS_LINK_STATE_INVALID : nvapi.h
  • NVAPI_NVLINK_STATUS_LINK_STATE_RECOVERY : nvapi.h
  • NVAPI_NVLINK_STATUS_LINK_STATE_RECOVERY_AC : nvapi.h
  • NVAPI_NVLINK_STATUS_LINK_STATE_RECOVERY_AX : nvapi.h
  • NVAPI_NVLINK_STATUS_LINK_STATE_SWCFG : nvapi.h
  • NVAPI_NVLINK_STATUS_LINK_STATE_UNKNOWN : nvapi.h
  • NVAPI_NVLINK_STATUS_LOOP_PROPERTY_LOOPBACK : nvapi.h
  • NVAPI_NVLINK_STATUS_LOOP_PROPERTY_LOOPOUT : nvapi.h
  • NVAPI_NVLINK_STATUS_LOOP_PROPERTY_NONE : nvapi.h
  • NVAPI_NVLINK_STATUS_NCI_VERSION_1_0 : nvapi.h
  • NVAPI_NVLINK_STATUS_NCI_VERSION_2_0 : nvapi.h
  • NVAPI_NVLINK_STATUS_NCI_VERSION_INVALID : nvapi.h
  • NVAPI_NVLINK_STATUS_NVHS_VERSION_1_0 : nvapi.h
  • NVAPI_NVLINK_STATUS_NVHS_VERSION_INVALID : nvapi.h
  • NVAPI_NVLINK_STATUS_NVLINK_VERSION_1_0 : nvapi.h
  • NVAPI_NVLINK_STATUS_NVLINK_VERSION_2_0 : nvapi.h
  • NVAPI_NVLINK_STATUS_NVLINK_VERSION_INVALID : nvapi.h
  • NVAPI_NVLINK_STATUS_PHY_GRS : nvapi.h
  • NVAPI_NVLINK_STATUS_PHY_INVALID : nvapi.h
  • NVAPI_NVLINK_STATUS_PHY_NVHS : nvapi.h
  • NVAPI_NVLINK_STATUS_REMOTE_LINK_NUMBER_INVALID : nvapi.h
  • NVAPI_NVLINK_STATUS_SUBLINK_RX_STATE : nvapi.h
  • NVAPI_NVLINK_STATUS_SUBLINK_RX_STATE_FAULT : nvapi.h
  • NVAPI_NVLINK_STATUS_SUBLINK_RX_STATE_HIGH_SPEED_1 : nvapi.h
  • NVAPI_NVLINK_STATUS_SUBLINK_RX_STATE_INVALID : nvapi.h
  • NVAPI_NVLINK_STATUS_SUBLINK_RX_STATE_LOW_POWER : nvapi.h
  • NVAPI_NVLINK_STATUS_SUBLINK_RX_STATE_OFF : nvapi.h
  • NVAPI_NVLINK_STATUS_SUBLINK_RX_STATE_SAFE_MODE : nvapi.h
  • NVAPI_NVLINK_STATUS_SUBLINK_RX_STATE_TEST : nvapi.h
  • NVAPI_NVLINK_STATUS_SUBLINK_RX_STATE_TRAINING : nvapi.h
  • NVAPI_NVLINK_STATUS_SUBLINK_RX_STATE_UNKNOWN : nvapi.h
  • NVAPI_NVLINK_STATUS_SUBLINK_TX_STATE : nvapi.h
  • NVAPI_NVLINK_STATUS_SUBLINK_TX_STATE_FAULT : nvapi.h
  • NVAPI_NVLINK_STATUS_SUBLINK_TX_STATE_HIGH_SPEED_1 : nvapi.h
  • NVAPI_NVLINK_STATUS_SUBLINK_TX_STATE_INVALID : nvapi.h
  • NVAPI_NVLINK_STATUS_SUBLINK_TX_STATE_LOW_POWER : nvapi.h
  • NVAPI_NVLINK_STATUS_SUBLINK_TX_STATE_OFF : nvapi.h
  • NVAPI_NVLINK_STATUS_SUBLINK_TX_STATE_SAFE_MODE : nvapi.h
  • NVAPI_NVLINK_STATUS_SUBLINK_TX_STATE_TEST : nvapi.h
  • NVAPI_NVLINK_STATUS_SUBLINK_TX_STATE_TRAINING : nvapi.h
  • NVAPI_NVLINK_STATUS_SUBLINK_TX_STATE_UNKNOWN : nvapi.h
  • NVAPI_NVLINK_UNCORRECTABLE : nvapi_lite_common.h
  • NvAPI_OGL_ExpertModeDefaultsGet() : nvapi.h
  • NvAPI_OGL_ExpertModeDefaultsSet() : nvapi.h
  • NvAPI_OGL_ExpertModeGet() : nvapi.h
  • NvAPI_OGL_ExpertModeSet() : nvapi.h
  • NVAPI_OGLEXPERT_CALLBACK : nvapi.h
  • NVAPI_OGLEXPERT_DETAIL_ALL : nvapi.h
  • NVAPI_OGLEXPERT_DETAIL_BASIC_INFO : nvapi.h
  • NVAPI_OGLEXPERT_DETAIL_DETAILED_INFO : nvapi.h
  • NVAPI_OGLEXPERT_DETAIL_ERROR : nvapi.h
  • NVAPI_OGLEXPERT_DETAIL_NONE : nvapi.h
  • NVAPI_OGLEXPERT_DETAIL_PERFORMANCE_WARNING : nvapi.h
  • NVAPI_OGLEXPERT_DETAIL_QUALITY_WARNING : nvapi.h
  • NVAPI_OGLEXPERT_DETAIL_SWFALLBACK : nvapi.h
  • NVAPI_OGLEXPERT_DETAIL_USAGE_WARNING : nvapi.h
  • NVAPI_OGLEXPERT_OUTPUT_TO_ALL : nvapi.h
  • NVAPI_OGLEXPERT_OUTPUT_TO_CALLBACK : nvapi.h
  • NVAPI_OGLEXPERT_OUTPUT_TO_CONSOLE : nvapi.h
  • NVAPI_OGLEXPERT_OUTPUT_TO_DEBUGGER : nvapi.h
  • NVAPI_OGLEXPERT_OUTPUT_TO_NONE : nvapi.h
  • NVAPI_OGLEXPERT_REPORT_ALL : nvapi.h
  • NVAPI_OGLEXPERT_REPORT_ERROR : nvapi.h
  • NVAPI_OGLEXPERT_REPORT_FEATURE_SLI : nvapi.h
  • NVAPI_OGLEXPERT_REPORT_NONE : nvapi.h
  • NVAPI_OGLEXPERT_REPORT_OBJECT_BUFFEROBJECT : nvapi.h
  • NVAPI_OGLEXPERT_REPORT_OBJECT_FBO : nvapi.h
  • NVAPI_OGLEXPERT_REPORT_OBJECT_PROGRAM : nvapi.h
  • NVAPI_OGLEXPERT_REPORT_OBJECT_TEXTURE : nvapi.h
  • NVAPI_OGLEXPERT_REPORT_PIPELINE_FRAGMENT : nvapi.h
  • NVAPI_OGLEXPERT_REPORT_PIPELINE_FRAMEBUFFER : nvapi.h
  • NVAPI_OGLEXPERT_REPORT_PIPELINE_GEOMETRY : nvapi.h
  • NVAPI_OGLEXPERT_REPORT_PIPELINE_PIXEL : nvapi.h
  • NVAPI_OGLEXPERT_REPORT_PIPELINE_RASTER : nvapi.h
  • NVAPI_OGLEXPERT_REPORT_PIPELINE_ROP : nvapi.h
  • NVAPI_OGLEXPERT_REPORT_PIPELINE_TEXTURE : nvapi.h
  • NVAPI_OGLEXPERT_REPORT_PIPELINE_VERTEX : nvapi.h
  • NVAPI_OGLEXPERT_REPORT_PIPELINE_XFB : nvapi.h
  • NVAPI_OGLEXPERT_REPORT_SWFALLBACK : nvapi.h
  • NVAPI_OK : nvapi_lite_common.h
  • NVAPI_OPENGL_CONTEXT_NOT_CURRENT : nvapi_lite_common.h
  • NVAPI_OUT_OF_MEMORY : nvapi_lite_common.h
  • NVAPI_PCLK_LIMITATION_FAILED : nvapi_lite_common.h
  • NVAPI_PERSIST_DATA_NOT_FOUND : nvapi_lite_common.h
  • NVAPI_PHYSICAL_GPUS : nvapi_lite_common.h
  • NVAPI_PORTID_NOT_FOUND : nvapi_lite_common.h
  • NVAPI_PRESENT_COMPOSITING_CONFIG_FLAG_CLEAR_OUTBANDS : nvapi.h
  • NVAPI_PRESENT_COMPOSITING_CONFIG_FLAG_GET_VIDEO_BRIDGE_STATUS : nvapi.h
  • NVAPI_PRESENT_COMPOSITING_CONFIG_FLAG_USE_VIDEO_BRIDGE : nvapi.h
  • NVAPI_PRIV_SEC_VIOLATION : nvapi_lite_common.h
  • NVAPI_PROFILE_NAME_EMPTY : nvapi_lite_common.h
  • NVAPI_PROFILE_NAME_IN_USE : nvapi_lite_common.h
  • NVAPI_PROFILE_NOT_FOUND : nvapi_lite_common.h
  • NVAPI_PROFILE_REMOVED : nvapi_lite_common.h
  • NVAPI_QUAD_FILLMODE : nvapi.h
  • NVAPI_QUAD_FILLMODE_BBOX : nvapi.h
  • NVAPI_QUAD_FILLMODE_DISABLED : nvapi.h
  • NVAPI_QUAD_FILLMODE_FULL_VIEWPORT : nvapi.h
  • NvAPI_QueryPresentBarrierFrameStatistics() : nvapi.h
  • NVAPI_RAY_FLAG_ACCEPT_FIRST_HIT_AND_END_SEARCH_EX : nvapi.h
  • NVAPI_RAY_FLAG_CULL_BACK_FACING_TRIANGLES_EX : nvapi.h
  • NVAPI_RAY_FLAG_CULL_FRONT_FACING_TRIANGLES_EX : nvapi.h
  • NVAPI_RAY_FLAG_CULL_NON_OPAQUE_EX : nvapi.h
  • NVAPI_RAY_FLAG_CULL_OPAQUE_EX : nvapi.h
  • NVAPI_RAY_FLAG_EX : nvapi.h
  • NVAPI_RAY_FLAG_FORCE_NON_OPAQUE_EX : nvapi.h
  • NVAPI_RAY_FLAG_FORCE_OMM_2_STATE_EX : nvapi.h
  • NVAPI_RAY_FLAG_FORCE_OPAQUE_EX : nvapi.h
  • NVAPI_RAY_FLAG_NONE_EX : nvapi.h
  • NVAPI_RAY_FLAG_SKIP_CLOSEST_HIT_SHADER_EX : nvapi.h
  • NVAPI_RAY_FLAG_SKIP_PROCEDURAL_PRIMITIVES_EX : nvapi.h
  • NVAPI_RAY_FLAG_SKIP_TRIANGLES_EX : nvapi.h
  • NVAPI_RELOCATE_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PARAMS : nvapi.h
  • NVAPI_RELOCATE_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PARAMS_V1 : nvapi.h
  • NVAPI_RELOCATE_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PARAMS_VER : nvapi.h
  • NVAPI_RELOCATE_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PARAMS_VER1 : nvapi.h
  • NVAPI_RELOCATE_RAYTRACING_OPACITY_MICROMAP_ARRAY_PARAMS : nvapi.h
  • NVAPI_RELOCATE_RAYTRACING_OPACITY_MICROMAP_ARRAY_PARAMS_V1 : nvapi.h
  • NVAPI_RELOCATE_RAYTRACING_OPACITY_MICROMAP_ARRAY_PARAMS_VER : nvapi.h
  • NVAPI_RELOCATE_RAYTRACING_OPACITY_MICROMAP_ARRAY_PARAMS_VER1 : nvapi.h
  • NVAPI_REQUEST_PENDING : nvapi_lite_common.h
  • NVAPI_REQUEST_USER_TO_CLOSE_NON_MIGRATABLE_APPS : nvapi_lite_common.h
  • NVAPI_REQUEST_USER_TO_DISABLE_DWM : nvapi_lite_common.h
  • NVAPI_REQUIRE_FURTHER_HDCP_ACTION : nvapi_lite_common.h
  • NVAPI_REQUIRES_REBOOT : nvapi_lite_common.h
  • NVAPI_RESOURCE_IN_USE : nvapi_lite_common.h
  • NVAPI_RESOURCE_NOT_ACQUIRED : nvapi_lite_common.h
  • NVAPI_SET_NOT_ALLOWED : nvapi_lite_common.h
  • NvAPI_SetCurrentMosaicTopology() : nvapi.h
  • NvAPI_SetDisplayPort() : nvapi.h
  • NvAPI_SetRefreshRateOverride() : nvapi.h
  • NVAPI_SETTING_MAX_VALUES : nvapi.h
  • NVAPI_SETTING_NOT_FOUND : nvapi_lite_common.h
  • NVAPI_SETTING_SIZE_TOO_LARGE : nvapi_lite_common.h
  • NVAPI_SHARE_RESOURCE_RELOCATED : nvapi_lite_common.h
  • NVAPI_SHORT_STRING_MAX : nvapi_lite_common.h
  • NvAPI_ShortString : nvapi_lite_common.h
  • NVAPI_SLI_RENDERING_MODE_NOTALLOWED : nvapi_lite_common.h
  • NvAPI_Status : nvapi_lite_common.h
  • NvAPI_Stereo_Activate() : nvapi_lite_stereo.h
  • NVAPI_STEREO_CAPS : nvapi.h
  • NVAPI_STEREO_CAPS_V1 : nvapi.h
  • NVAPI_STEREO_CAPS_VER : nvapi.h
  • NVAPI_STEREO_CAPS_VER1 : nvapi.h
  • NvAPI_Stereo_CaptureJpegImage() : nvapi.h
  • NvAPI_Stereo_CapturePngImage() : nvapi.h
  • NvAPI_Stereo_CreateConfigurationProfileRegistryKey() : nvapi.h
  • NvAPI_Stereo_CreateHandleFromIUnknown() : nvapi_lite_stereo.h
  • NvAPI_Stereo_Deactivate() : nvapi_lite_stereo.h
  • NvAPI_Stereo_Debug_WasLastDrawStereoized() : nvapi_lite_stereo.h
  • NvAPI_Stereo_DecreaseConvergence() : nvapi.h
  • NvAPI_Stereo_DecreaseSeparation() : nvapi.h
  • NVAPI_STEREO_DEFAULT_REGISTRY_PROFILE : nvapi.h
  • NvAPI_Stereo_DeleteConfigurationProfileRegistryKey() : nvapi.h
  • NvAPI_Stereo_DeleteConfigurationProfileValue() : nvapi.h
  • NvAPI_Stereo_DestroyHandle() : nvapi_lite_stereo.h
  • NvAPI_Stereo_Disable() : nvapi_lite_stereo.h
  • NVAPI_STEREO_DRIVER_MODE_AUTOMATIC : nvapi_lite_stereo.h
  • NVAPI_STEREO_DRIVER_MODE_DIRECT : nvapi_lite_stereo.h
  • NVAPI_STEREO_DX10_REGISTRY_PROFILE : nvapi.h
  • NVAPI_STEREO_DX9_REGISTRY_PROFILE : nvapi.h
  • NvAPI_Stereo_Enable() : nvapi_lite_stereo.h
  • NVAPI_STEREO_EYE_LEFT : nvapi_lite_stereo.h
  • NVAPI_STEREO_EYE_MONO : nvapi_lite_stereo.h
  • NVAPI_STEREO_EYE_RIGHT : nvapi_lite_stereo.h
  • NVAPI_STEREO_FRUSTUM_ADJUST_MODE_NOT_SUPPORTED : nvapi_lite_common.h
  • NvAPI_Stereo_GetConvergence() : nvapi_lite_stereo.h
  • NvAPI_Stereo_GetDefaultProfile() : nvapi_lite_stereo.h
  • NvAPI_Stereo_GetEyeSeparation() : nvapi_lite_stereo.h
  • NvAPI_Stereo_GetFrustumAdjustMode() : nvapi.h
  • NvAPI_Stereo_GetSeparation() : nvapi_lite_stereo.h
  • NvAPI_Stereo_GetStereoSupport() : nvapi.h
  • NvAPI_Stereo_GetSurfaceCreationMode() : nvapi_lite_stereo.h
  • NVAPI_STEREO_HANDSHAKE_NOT_DONE : nvapi_lite_common.h
  • NvAPI_Stereo_IncreaseConvergence() : nvapi.h
  • NvAPI_Stereo_IncreaseSeparation() : nvapi.h
  • NVAPI_STEREO_INIT_ACTIVATION_DELAYED : nvapi.h
  • NVAPI_STEREO_INIT_ACTIVATION_FLAGS : nvapi.h
  • NVAPI_STEREO_INIT_ACTIVATION_IMMEDIATE : nvapi.h
  • NVAPI_STEREO_INIT_ACTIVATION_NOT_DONE : nvapi_lite_common.h
  • NvAPI_Stereo_InitActivation() : nvapi.h
  • NVAPI_STEREO_INVALID_DEVICE_INTERFACE : nvapi_lite_common.h
  • NvAPI_Stereo_IsActivated() : nvapi_lite_stereo.h
  • NvAPI_Stereo_IsEnabled() : nvapi_lite_stereo.h
  • NvAPI_Stereo_IsWindowedModeSupported() : nvapi_lite_stereo.h
  • NVAPI_STEREO_NOT_ENABLED : nvapi_lite_common.h
  • NVAPI_STEREO_NOT_INITIALIZED : nvapi_lite_common.h
  • NVAPI_STEREO_NOT_TURNED_ON : nvapi_lite_common.h
  • NVAPI_STEREO_PARAMETER_OUT_OF_RANGE : nvapi_lite_common.h
  • NVAPI_STEREO_QUADBUFFERED_API_VERSION : nvapi.h
  • NVAPI_STEREO_REGISTRY_ACCESS_FAILED : nvapi_lite_common.h
  • NVAPI_STEREO_REGISTRY_PROFILE_TYPE_NOT_SUPPORTED : nvapi_lite_common.h
  • NVAPI_STEREO_REGISTRY_VALUE_NOT_SUPPORTED : nvapi_lite_common.h
  • NvAPI_Stereo_ReverseStereoBlitControl() : nvapi.h
  • NvAPI_Stereo_SetActiveEye() : nvapi_lite_stereo.h
  • NvAPI_Stereo_SetConfigurationProfileValue() : nvapi.h
  • NvAPI_Stereo_SetConvergence() : nvapi_lite_stereo.h
  • NvAPI_Stereo_SetDefaultProfile() : nvapi_lite_stereo.h
  • NvAPI_Stereo_SetDriverMode() : nvapi_lite_stereo.h
  • NvAPI_Stereo_SetFrustumAdjustMode() : nvapi.h
  • NvAPI_Stereo_SetNotificationMessage() : nvapi.h
  • NvAPI_Stereo_SetSeparation() : nvapi_lite_stereo.h
  • NvAPI_Stereo_SetSurfaceCreationMode() : nvapi_lite_stereo.h
  • NVAPI_STEREO_SURFACECREATEMODE : nvapi_lite_stereo.h
  • NVAPI_STEREO_SURFACECREATEMODE_AUTO : nvapi_lite_stereo.h
  • NVAPI_STEREO_SURFACECREATEMODE_FORCEMONO : nvapi_lite_stereo.h
  • NVAPI_STEREO_SURFACECREATEMODE_FORCESTEREO : nvapi_lite_stereo.h
  • NVAPI_STEREO_SWAPCHAIN_DEFAULT : nvapi.h
  • NVAPI_STEREO_SWAPCHAIN_MONO : nvapi.h
  • NVAPI_STEREO_SWAPCHAIN_STEREO : nvapi.h
  • NvAPI_Stereo_Trigger_Activation() : nvapi.h
  • NVAPI_STEREO_VERSION_MISMATCH : nvapi_lite_common.h
  • NVAPI_STREAM_IS_OUT_OF_SYNC : nvapi_lite_common.h
  • NvAPI_String : nvapi_lite_common.h
  • NVAPI_STRING_TOO_SMALL : nvapi_lite_common.h
  • NVAPI_SYNC_MASTER_NOT_FOUND : nvapi_lite_common.h
  • NVAPI_SYNC_NOT_ACTIVE : nvapi_lite_common.h
  • NvAPI_SYS_GetChipSetInfo() : nvapi.h
  • NvAPI_SYS_GetDisplayDriverInfo() : nvapi.h
  • NvAPI_SYS_GetDisplayIdFromGpuAndOutputId() : nvapi.h
  • NvAPI_SYS_GetDriverAndBranchVersion() : nvapi_lite_common.h
  • NvAPI_SYS_GetGpuAndOutputIdFromDisplayId() : nvapi.h
  • NvAPI_SYS_GetLidAndDockInfo() : nvapi.h
  • NvAPI_SYS_GetLogicalGPUs() : nvapi.h
  • NvAPI_SYS_GetPhysicalGpuFromDisplayId() : nvapi.h
  • NvAPI_SYS_GetPhysicalGPUs() : nvapi.h
  • NVAPI_SYSTEM_HWBC_INVALID_ID : nvapi_lite_common.h
  • NVAPI_SYSTEM_MAX_DISPLAYS : nvapi_lite_common.h
  • NVAPI_SYSTEM_MAX_HWBCS : nvapi_lite_common.h
  • NVAPI_SYSWOW64_NOT_SUPPORTED : nvapi_lite_common.h
  • NVAPI_TESTING_CLOCKS_NOT_SUPPORTED : nvapi_lite_common.h
  • NVAPI_THERMAL_CONTROLLER_ADM1032 : nvapi.h
  • NVAPI_THERMAL_CONTROLLER_ADT7473 : nvapi.h
  • NVAPI_THERMAL_CONTROLLER_GPU_INTERNAL : nvapi.h
  • NVAPI_THERMAL_CONTROLLER_LM64 : nvapi.h
  • NVAPI_THERMAL_CONTROLLER_LM89 : nvapi.h
  • NVAPI_THERMAL_CONTROLLER_LM99 : nvapi.h
  • NVAPI_THERMAL_CONTROLLER_MAX1617 : nvapi.h
  • NVAPI_THERMAL_CONTROLLER_MAX6649 : nvapi.h
  • NVAPI_THERMAL_CONTROLLER_NONE : nvapi.h
  • NVAPI_THERMAL_CONTROLLER_OS : nvapi.h
  • NVAPI_THERMAL_CONTROLLER_SBMAX6649 : nvapi.h
  • NVAPI_THERMAL_CONTROLLER_UNKNOWN : nvapi.h
  • NVAPI_THERMAL_CONTROLLER_VBIOSEVT : nvapi.h
  • NVAPI_THERMAL_TARGET_ALL : nvapi.h
  • NVAPI_THERMAL_TARGET_BOARD : nvapi.h
  • NVAPI_THERMAL_TARGET_GPU : nvapi.h
  • NVAPI_THERMAL_TARGET_MEMORY : nvapi.h
  • NVAPI_THERMAL_TARGET_NONE : nvapi.h
  • NVAPI_THERMAL_TARGET_POWER_SUPPLY : nvapi.h
  • NVAPI_THERMAL_TARGET_UNKNOWN : nvapi.h
  • NVAPI_THERMAL_TARGET_VCD_BOARD : nvapi.h
  • NVAPI_THERMAL_TARGET_VCD_INLET : nvapi.h
  • NVAPI_THERMAL_TARGET_VCD_OUTLET : nvapi.h
  • NVAPI_TIMEOUT : nvapi_lite_common.h
  • NVAPI_TIMEOUT_RECONFIGURING_GPU_TOPO : nvapi_lite_common.h
  • NVAPI_TIMING_NOT_SUPPORTED : nvapi_lite_common.h
  • NVAPI_TOO_MANY_SETTINGS_IN_PROFILE : nvapi_lite_common.h
  • NVAPI_TOO_MANY_UNIQUE_STATE_OBJECTS : nvapi_lite_common.h
  • NVAPI_TOPO_NOT_POSSIBLE : nvapi_lite_common.h
  • NVAPI_UAV_INFO : nvapi.h
  • NVAPI_UAV_INFO_VER : nvapi.h
  • NVAPI_UAV_INFO_VER1 : nvapi.h
  • NVAPI_UAV_INFO_VER2 : nvapi.h
  • NVAPI_UNICODE_STRING_MAX : nvapi.h
  • NvAPI_UnicodeShortString : nvapi_lite_common.h
  • NvAPI_UnicodeString : nvapi.h
  • NVAPI_UNKNOWN_UNDERSCAN_CONFIG : nvapi_lite_common.h
  • NvAPI_Unload() : nvapi.h
  • NVAPI_UNREGISTERED_RESOURCE : nvapi_lite_common.h
  • NVAPI_UNSUPPORTED_CONFIG_NON_HDCP_HMD : nvapi_lite_common.h
  • NVAPI_VALUE_ALREADY_SET : nvapi_lite_common.h
  • NVAPI_VIDEO_BRIDGE_STATUS_AVAILABLE : nvapi.h
  • NVAPI_VIDEO_BRIDGE_STATUS_FAILED_ACCESS : nvapi.h
  • NVAPI_VIDEO_BRIDGE_STATUS_NOT_AVAILABLE : nvapi.h
  • NVAPI_VIDEO_BRIDGE_STATUS_UNKNOWN : nvapi.h
  • NVAPI_VSYNC_ADAPTIVE : nvapi.h
  • NVAPI_VSYNC_ADAPTIVE_HALF_REFRESH_RATE : nvapi.h
  • NVAPI_VSYNC_DEFAULT : nvapi.h
  • NVAPI_VSYNC_MODE : nvapi.h
  • NVAPI_VSYNC_OFF : nvapi.h
  • NVAPI_VSYNC_ON : nvapi.h
  • NVAPI_WAIT_FOR_HW_RESOURCE : nvapi_lite_common.h
  • NVAPI_WAS_STILL_DRAWING : nvapi_lite_common.h
  • NvBallot() : nvHLSLExtns.h
  • NvBool : nvapi_lite_common.h
  • NVDRS_APPLICATION : nvapi.h
  • NVDRS_APPLICATION_V1 : nvapi.h
  • NVDRS_APPLICATION_V2 : nvapi.h
  • NVDRS_APPLICATION_V3 : nvapi.h
  • NVDRS_APPLICATION_V4 : nvapi.h
  • NVDRS_APPLICATION_VER : nvapi.h
  • NVDRS_APPLICATION_VER_V1 : nvapi.h
  • NVDRS_APPLICATION_VER_V2 : nvapi.h
  • NVDRS_APPLICATION_VER_V3 : nvapi.h
  • NVDRS_APPLICATION_VER_V4 : nvapi.h
  • NVDRS_BASE_PROFILE_LOCATION : nvapi.h
  • NVDRS_BINARY_SETTING : nvapi.h
  • NVDRS_BINARY_TYPE : nvapi.h
  • NVDRS_CURRENT_PROFILE_LOCATION : nvapi.h
  • NVDRS_DEFAULT_PROFILE_LOCATION : nvapi.h
  • NVDRS_DWORD_TYPE : nvapi.h
  • NVDRS_GLOBAL_PROFILE_LOCATION : nvapi.h
  • NVDRS_GPU_SUPPORT : nvapi.h
  • NVDRS_PROFILE : nvapi.h
  • NVDRS_PROFILE_V1 : nvapi.h
  • NVDRS_PROFILE_VER : nvapi.h
  • NVDRS_PROFILE_VER1 : nvapi.h
  • NVDRS_SETTING : nvapi.h
  • NVDRS_SETTING_LOCATION : nvapi.h
  • NVDRS_SETTING_TYPE : nvapi.h
  • NVDRS_SETTING_V1 : nvapi.h
  • NVDRS_SETTING_VALUES : nvapi.h
  • NVDRS_SETTING_VALUES_VER : nvapi.h
  • NVDRS_SETTING_VER : nvapi.h
  • NVDRS_SETTING_VER1 : nvapi.h
  • NVDRS_STRING_TYPE : nvapi.h
  • NVDRS_WSTRING_TYPE : nvapi.h
  • NvEvaluateAttributeAtSampleForVPRS() : nvHLSLExtns.h
  • NvEvaluateAttributeSnappedForVPRS() : nvHLSLExtns.h
  • NvF32 : nvapi_lite_common.h
  • NvF32TONvU32 : nvapi_lite_common.h
  • NvF64 : nvapi_lite_common.h
  • NvFootprintCoarse() : nvHLSLExtns.h
  • NvFootprintCoarseBias() : nvHLSLExtns.h
  • NvFootprintCoarseGrad() : nvHLSLExtns.h
  • NvFootprintCoarseLevel() : nvHLSLExtns.h
  • NvFootprintExtractAnchorTileLoc2D() : nvHLSLExtns.h
  • NvFootprintExtractAnchorTileLoc3D() : nvHLSLExtns.h
  • NvFootprintExtractBitmask() : nvHLSLExtns.h
  • NvFootprintExtractLOD() : nvHLSLExtns.h
  • NvFootprintExtractOffset2D() : nvHLSLExtns.h
  • NvFootprintExtractOffset3D() : nvHLSLExtns.h
  • NvFootprintExtractReturnGran() : nvHLSLExtns.h
  • NvFootprintFine() : nvHLSLExtns.h
  • NvFootprintFineBias() : nvHLSLExtns.h
  • NvFootprintFineGrad() : nvHLSLExtns.h
  • NvFootprintFineLevel() : nvHLSLExtns.h
  • NVFORMAT_MAKEFOURCC : nvapi.h
  • NvGetLaneId() : nvHLSLExtns.h
  • NvGetShadingRate() : nvHLSLExtns.h
  • NvGetSpecial() : nvHLSLExtns.h
  • NvGUID_Defined : nvapi_lite_common.h
  • NVINPUTOUTPUTSTATUS_ERROR : nvapi.h
  • NVINPUTOUTPUTSTATUS_OFF : nvapi.h
  • NVINPUTOUTPUTSTATUS_SDI_HD : nvapi.h
  • NVINPUTOUTPUTSTATUS_SDI_SD : nvapi.h
  • NvInterlockedAddFp16x2() : nvHLSLExtns.h
  • NvInterlockedAddFp16x4() : nvHLSLExtns.h
  • NvInterlockedAddFp32() : nvHLSLExtns.h
  • NvInterlockedAddUint64() : nvHLSLExtns.h
  • NvInterlockedAndUint64() : nvHLSLExtns.h
  • NvInterlockedCompareExchangeUint64() : nvHLSLExtns.h
  • NvInterlockedExchangeUint64() : nvHLSLExtns.h
  • NvInterlockedMaxFp16x2() : nvHLSLExtns.h
  • NvInterlockedMaxFp16x4() : nvHLSLExtns.h
  • NvInterlockedMaxUint64() : nvHLSLExtns.h
  • NvInterlockedMinFp16x2() : nvHLSLExtns.h
  • NvInterlockedMinFp16x4() : nvHLSLExtns.h
  • NvInterlockedMinUint64() : nvHLSLExtns.h
  • NvInterlockedOrUint64() : nvHLSLExtns.h
  • NvInterlockedXorUint64() : nvHLSLExtns.h
  • NVLINK_GET_CAPS : nvapi.h
  • NVLINK_GET_CAPS_VER : nvapi.h
  • NVLINK_GET_CAPS_VER1 : nvapi.h
  • NVLINK_GET_STATUS : nvapi.h
  • NVLINK_GET_STATUS_VER : nvapi.h
  • NVLINK_GET_STATUS_VER1 : nvapi.h
  • NVLINK_GET_STATUS_VER2 : nvapi.h
  • NvLUID : nvapi_lite_common.h
  • NvRtIsBackFacing() : nvHLSLExtns.h
  • NvRtIsMicroTriangleHit() : nvHLSLExtns.h
  • NvRtMicroTriangleBarycentrics() : nvHLSLExtns.h
  • NvRtMicroTriangleObjectPositions() : nvHLSLExtns.h
  • NvRtTriangleObjectPositions() : nvHLSLExtns.h
  • NvS16 : nvapi_lite_common.h
  • NvS32 : nvapi_lite_common.h
  • NvS64 : nvapi_lite_common.h
  • NvS8 : nvapi_lite_common.h
  • NvShfl() : nvHLSLExtns.h
  • NvShflDown() : nvHLSLExtns.h
  • NvShflUp() : nvHLSLExtns.h
  • NvShflXor() : nvHLSLExtns.h
  • NvU16 : nvapi_lite_common.h
  • NvU32 : nvapi_lite_common.h
  • NvU32TONvF32 : nvapi_lite_common.h
  • NvU64 : nvapi_lite_common.h
  • NvU8 : nvapi_lite_common.h
  • NVVIO_O_READ : nvapi.h
  • NVVIO_O_WRITE_EXCLUSIVE : nvapi.h
  • NVVIO_OWNERID_EXCLUSIVE : nvapi.h
  • NVVIO_OWNERID_INITIALIZED : nvapi.h
  • NVVIO_OWNERID_TYPEMASK : nvapi.h
  • NVVIO_VALID_ACCESSRIGHTS : nvapi.h
  • NVVIOANCPARITYCOMPUTATION : nvapi.h
  • NVVIOANCPARITYCOMPUTATION_AUTO : nvapi.h
  • NVVIOANCPARITYCOMPUTATION_OFF : nvapi.h
  • NVVIOANCPARITYCOMPUTATION_ON : nvapi.h
  • NVVIOBITSPERCOMPONENT : nvapi.h
  • NVVIOBITSPERCOMPONENT_10 : nvapi.h
  • NVVIOBITSPERCOMPONENT_12 : nvapi.h
  • NVVIOBITSPERCOMPONENT_8 : nvapi.h
  • NVVIOBITSPERCOMPONENT_UNKNOWN : nvapi.h
  • NVVIOBUFFERFORMAT_R16FPG16FPB16FP : nvapi.h
  • NVVIOBUFFERFORMAT_R16FPG16FPB16FPA16FP : nvapi.h
  • NVVIOBUFFERFORMAT_R16FPG16FPB16FPA16FPZ24 : nvapi.h
  • NVVIOBUFFERFORMAT_R16FPG16FPB16FPZ24 : nvapi.h
  • NVVIOBUFFERFORMAT_R8G8B8 : nvapi.h
  • NVVIOBUFFERFORMAT_R8G8B8A8 : nvapi.h
  • NVVIOBUFFERFORMAT_R8G8B8A8Z24 : nvapi.h
  • NVVIOBUFFERFORMAT_R8G8B8Z24 : nvapi.h
  • NVVIOCAPS : nvapi.h
  • NVVIOCAPS_AUDIO_BLANKING_SUPPORTED : nvapi.h
  • NVVIOCAPS_OUTPUTMODE_DESKTOP : nvapi.h
  • NVVIOCAPS_OUTPUTMODE_OPENGL : nvapi.h
  • NVVIOCAPS_PACKED_ANC_SUPPORTED : nvapi.h
  • NVVIOCAPS_SYNC_GENLOCK : nvapi.h
  • NVVIOCAPS_SYNC_INTERNAL : nvapi.h
  • NVVIOCAPS_SYNCSRC_COMP : nvapi.h
  • NVVIOCAPS_SYNCSRC_SDI : nvapi.h
  • NVVIOCAPS_VER : nvapi.h
  • NVVIOCAPS_VER1 : nvapi.h
  • NVVIOCAPS_VER2 : nvapi.h
  • NVVIOCAPS_VIDIN_SDI : nvapi.h
  • NVVIOCAPS_VIDOUT_SDI : nvapi.h
  • NVVIOCAPTURESTATUS : nvapi.h
  • NVVIOCHANNELSTATUS : nvapi.h
  • NVVIOCLASS_SDI : nvapi.h
  • NVVIOCOLORCONVERSION : nvapi.h
  • NVVIOCOLORCONVERSION_VER : nvapi.h
  • NVVIOCOLORSPACE : nvapi.h
  • NVVIOCOLORSPACE_GBR : nvapi.h
  • NVVIOCOLORSPACE_GBRA : nvapi.h
  • NVVIOCOLORSPACE_GBRD : nvapi.h
  • NVVIOCOLORSPACE_UNKNOWN : nvapi.h
  • NVVIOCOLORSPACE_YCBCR : nvapi.h
  • NVVIOCOLORSPACE_YCBCRA : nvapi.h
  • NVVIOCOLORSPACE_YCBCRD : nvapi.h
  • NVVIOCOMPONENTSAMPLING : nvapi.h
  • NVVIOCOMPONENTSAMPLING_422 : nvapi.h
  • NVVIOCOMPONENTSAMPLING_4224 : nvapi.h
  • NVVIOCOMPONENTSAMPLING_444 : nvapi.h
  • NVVIOCOMPONENTSAMPLING_4444 : nvapi.h
  • NVVIOCOMPONENTSAMPLING_UNKNOWN : nvapi.h
  • NVVIOCOMPOSITERANGE : nvapi.h
  • NVVIOCOMPSYNCTYPE : nvapi.h
  • NVVIOCOMPSYNCTYPE_AUTO : nvapi.h
  • NVVIOCOMPSYNCTYPE_BILEVEL : nvapi.h
  • NVVIOCOMPSYNCTYPE_TRILEVEL : nvapi.h
  • NVVIOCONFIG : nvapi.h
  • NVVIOCONFIG_422FILTER : nvapi.h
  • NVVIOCONFIG_ALLFIELDS : nvapi.h
  • NVVIOCONFIG_ALLOWSDIRUNNING_FIELDS : nvapi.h
  • NVVIOCONFIG_ALPHAKEYCOMPOSITE : nvapi.h
  • NVVIOCONFIG_ANC_AUDIO_REPEAT : nvapi.h
  • NVVIOCONFIG_ANC_PARITY_COMPUTATION : nvapi.h
  • NVVIOCONFIG_ANCTIMECODEGENERATION : nvapi.h
  • NVVIOCONFIG_COLORCONVERSION : nvapi.h
  • NVVIOCONFIG_COMPOSITE : nvapi.h
  • NVVIOCONFIG_COMPOSITE_CB : nvapi.h
  • NVVIOCONFIG_COMPOSITE_CR : nvapi.h
  • NVVIOCONFIG_COMPOSITE_Y : nvapi.h
  • NVVIOCONFIG_COMPOSITESYNCTYPE : nvapi.h
  • NVVIOCONFIG_COMPOSITETERMINATE : nvapi.h
  • NVVIOCONFIG_CSCOVERRIDE : nvapi.h
  • NVVIOCONFIG_DATAFORMAT : nvapi.h
  • NVVIOCONFIG_DATAINTEGRITYCHECK : nvapi.h
  • NVVIOCONFIG_DRIVERFIELDS : nvapi.h
  • NVVIOCONFIG_FLIPQUEUELENGTH : nvapi.h
  • NVVIOCONFIG_FRAMELOCKENABLE : nvapi.h
  • NVVIOCONFIG_FULL_COLOR_RANGE : nvapi.h
  • NVVIOCONFIG_GAMMACORRECTION : nvapi.h
  • NVVIOCONFIG_GAMMAFIELDS : nvapi.h
  • NVVIOCONFIG_OUTPUTAREA : nvapi.h
  • NVVIOCONFIG_OUTPUTREGION : nvapi.h
  • NVVIOCONFIG_RESERVED_SDIOUTPUTENABLE : nvapi.h
  • NVVIOCONFIG_RGB_DATA : nvapi.h
  • NVVIOCONFIG_RMCTRLFIELDS : nvapi.h
  • NVVIOCONFIG_RMMODESET_FIELDS : nvapi.h
  • NVVIOCONFIG_RMSKEWFIELDS : nvapi.h
  • NVVIOCONFIG_SIGNALFORMAT : nvapi.h
  • NVVIOCONFIG_STREAMS : nvapi.h
  • NVVIOCONFIG_SYNCDELAY : nvapi.h
  • NVVIOCONFIG_SYNCSOURCEENABLE : nvapi.h
  • NVVIOCONFIG_V1 : nvapi.h
  • NVVIOCONFIG_V2 : nvapi.h
  • NVVIOCONFIG_V3 : nvapi.h
  • NVVIOCONFIG_VALIDFIELDS : nvapi.h
  • NVVIOCONFIG_VER : nvapi.h
  • NVVIOCONFIG_VER1 : nvapi.h
  • NVVIOCONFIG_VER2 : nvapi.h
  • NVVIOCONFIG_VER3 : nvapi.h
  • NVVIOCONFIGTYPE : nvapi.h
  • NVVIOCONFIGTYPE_IN : nvapi.h
  • NVVIOCONFIGTYPE_OUT : nvapi.h
  • NVVIODATAFORMAT : nvapi.h
  • NVVIODATAFORMAT_DUAL_R8G8B8_TO_DUAL_YCRCB422 : nvapi.h
  • NVVIODATAFORMAT_DUAL_X8X8X8_TO_DUAL_422_PASSTHRU : nvapi.h
  • NVVIODATAFORMAT_R10G10B10_TO_RGB444 : nvapi.h
  • NVVIODATAFORMAT_R10G10B10_TO_YCRCB422 : nvapi.h
  • NVVIODATAFORMAT_R10G10B10_TO_YCRCB444 : nvapi.h
  • NVVIODATAFORMAT_R12G12B12_TO_YCRCB422 : nvapi.h
  • NVVIODATAFORMAT_R12G12B12_TO_YCRCB444 : nvapi.h
  • NVVIODATAFORMAT_R8G8B8_TO_YCRCB422 : nvapi.h
  • NVVIODATAFORMAT_R8G8B8_TO_YCRCB444 : nvapi.h
  • NVVIODATAFORMAT_R8G8B8A8_TO_YCRCBA4224 : nvapi.h
  • NVVIODATAFORMAT_R8G8B8A8_TO_YCRCBA4444 : nvapi.h
  • NVVIODATAFORMAT_R8G8B8Z10_TO_YCRCBZ4224 : nvapi.h
  • NVVIODATAFORMAT_R8G8B8Z10_TO_YCRCBZ4444 : nvapi.h
  • NVVIODATAFORMAT_UNKNOWN : nvapi.h
  • NVVIODATAFORMAT_X10X10X10_444_PASSTHRU : nvapi.h
  • NVVIODATAFORMAT_X10X8X8_444_PASSTHRU : nvapi.h
  • NVVIODATAFORMAT_X10X8X8A10_4444_PASSTHRU : nvapi.h
  • NVVIODATAFORMAT_X10X8X8Z10_4444_PASSTHRU : nvapi.h
  • NVVIODATAFORMAT_X12X12X12_422_PASSTHRU : nvapi.h
  • NVVIODATAFORMAT_X12X12X12_444_PASSTHRU : nvapi.h
  • NVVIODATAFORMAT_X8X8X8_444_PASSTHRU : nvapi.h
  • NVVIODATAFORMAT_X8X8X8A8_4444_PASSTHRU : nvapi.h
  • NVVIODATAFORMAT_X8X8X8Z10_4444_PASSTHRU : nvapi.h
  • NVVIODATAFORMAT_Y10CR10CB10_TO_YCRCB422 : nvapi.h
  • NVVIODATAFORMAT_Y10CR8CB8A10_TO_YCRCBA4224 : nvapi.h
  • NVVIODATAFORMAT_Y8CR8CB8_TO_YCRCB422 : nvapi.h
  • NVVIODATAFORMATDETAIL : nvapi.h
  • NVVIOGAMMACORRECTION : nvapi.h
  • NVVIOGAMMACORRECTION_VER : nvapi.h
  • NVVIOGAMMARAMP10 : nvapi.h
  • NVVIOGAMMARAMP8 : nvapi.h
  • NVVIOINPUTCONFIG : nvapi.h
  • NVVIOINPUTOUTPUTSTATUS : nvapi.h
  • NVVIOINPUTSTATUS : nvapi.h
  • NVVIOINTERLACEMODE : nvapi.h
  • NVVIOINTERLACEMODE_INTERLACE : nvapi.h
  • NVVIOINTERLACEMODE_PROGRESSIVE : nvapi.h
  • NVVIOINTERLACEMODE_PSF : nvapi.h
  • NVVIOLINKID : nvapi.h
  • NVVIOLINKID_A : nvapi.h
  • NVVIOLINKID_B : nvapi.h
  • NVVIOLINKID_C : nvapi.h
  • NVVIOLINKID_D : nvapi.h
  • NVVIOLINKID_UNKNOWN : nvapi.h
  • NVVIOOUTPUTAREA : nvapi.h
  • NVVIOOUTPUTAREA_FULLSIZE : nvapi.h
  • NVVIOOUTPUTAREA_SAFEACTION : nvapi.h
  • NVVIOOUTPUTAREA_SAFETITLE : nvapi.h
  • NVVIOOUTPUTCONFIG : nvapi.h
  • NVVIOOUTPUTCONFIG_V1 : nvapi.h
  • NVVIOOUTPUTCONFIG_V2 : nvapi.h
  • NVVIOOUTPUTCONFIG_V3 : nvapi.h
  • NVVIOOUTPUTREGION : nvapi.h
  • NVVIOOUTPUTSTATUS : nvapi.h
  • NVVIOOWNERID : nvapi.h
  • NVVIOOWNERID_NONE : nvapi.h
  • NVVIOOWNERTYPE : nvapi.h
  • NVVIOOWNERTYPE_APPLICATION : nvapi.h
  • NVVIOOWNERTYPE_DESKTOP : nvapi.h
  • NVVIOOWNERTYPE_NONE : nvapi.h
  • NVVIOPCIINFO : nvapi.h
  • NVVIOPCIINFO_V1 : nvapi.h
  • NVVIOPCIINFO_VER : nvapi.h
  • NVVIOPCIINFO_VER1 : nvapi.h
  • NVVIOPCILINKRATE : nvapi.h
  • NVVIOPCILINKRATE_GEN1 : nvapi.h
  • NVVIOPCILINKRATE_GEN2 : nvapi.h
  • NVVIOPCILINKRATE_GEN3 : nvapi.h
  • NVVIOPCILINKRATE_UNKNOWN : nvapi.h
  • NVVIOPCILINKWIDTH : nvapi.h
  • NVVIOPCILINKWIDTH_UNKNOWN : nvapi.h
  • NVVIOPCILINKWIDTH_x1 : nvapi.h
  • NVVIOPCILINKWIDTH_x16 : nvapi.h
  • NVVIOPCILINKWIDTH_x2 : nvapi.h
  • NVVIOPCILINKWIDTH_x4 : nvapi.h
  • NVVIOPCILINKWIDTH_x8 : nvapi.h
  • NVVIOSIGNALFORMAT : nvapi.h
  • NVVIOSIGNALFORMAT_1035I_59_94_SMPTE260 : nvapi.h
  • NVVIOSIGNALFORMAT_1035I_60_00_SMPTE260 : nvapi.h
  • NVVIOSIGNALFORMAT_1080I_47_96_SMPTE274 : nvapi.h
  • NVVIOSIGNALFORMAT_1080I_47_96_SMPTE274_3G_LEVEL_B : nvapi.h
  • NVVIOSIGNALFORMAT_1080I_48_00_SMPTE274 : nvapi.h
  • NVVIOSIGNALFORMAT_1080I_48_00_SMPTE274_3G_LEVEL_B : nvapi.h
  • NVVIOSIGNALFORMAT_1080I_50_00_SMPTE274 : nvapi.h
  • NVVIOSIGNALFORMAT_1080I_50_00_SMPTE274_3G_LEVEL_B : nvapi.h
  • NVVIOSIGNALFORMAT_1080I_50_00_SMPTE295 : nvapi.h
  • NVVIOSIGNALFORMAT_1080I_59_94_SMPTE274 : nvapi.h
  • NVVIOSIGNALFORMAT_1080I_59_94_SMPTE274_3G_LEVEL_B : nvapi.h
  • NVVIOSIGNALFORMAT_1080I_60_00_SMPTE274 : nvapi.h
  • NVVIOSIGNALFORMAT_1080I_60_00_SMPTE274_3G_LEVEL_B : nvapi.h
  • NVVIOSIGNALFORMAT_1080P_23_976_SMPTE274 : nvapi.h
  • NVVIOSIGNALFORMAT_1080P_23_98_SMPTE274_3G_LEVEL_B : nvapi.h
  • NVVIOSIGNALFORMAT_1080P_24_00_SMPTE274 : nvapi.h
  • NVVIOSIGNALFORMAT_1080P_24_00_SMPTE274_3G_LEVEL_B : nvapi.h
  • NVVIOSIGNALFORMAT_1080P_25_00_SMPTE274 : nvapi.h
  • NVVIOSIGNALFORMAT_1080P_25_00_SMPTE274_3G_LEVEL_B : nvapi.h
  • NVVIOSIGNALFORMAT_1080P_29_97_SMPTE274 : nvapi.h
  • NVVIOSIGNALFORMAT_1080P_29_97_SMPTE274_3G_LEVEL_B : nvapi.h
  • NVVIOSIGNALFORMAT_1080P_30_00_SMPTE274 : nvapi.h
  • NVVIOSIGNALFORMAT_1080P_30_00_SMPTE274_3G_LEVEL_B : nvapi.h
  • NVVIOSIGNALFORMAT_1080P_50_00_SMPTE274_3G_LEVEL_A : nvapi.h
  • NVVIOSIGNALFORMAT_1080P_50_00_SMPTE274_3G_LEVEL_B : nvapi.h
  • NVVIOSIGNALFORMAT_1080P_59_94_SMPTE274_3G_LEVEL_A : nvapi.h
  • NVVIOSIGNALFORMAT_1080P_59_94_SMPTE274_3G_LEVEL_B : nvapi.h
  • NVVIOSIGNALFORMAT_1080P_60_00_SMPTE274_3G_LEVEL_A : nvapi.h
  • NVVIOSIGNALFORMAT_1080P_60_00_SMPTE274_3G_LEVEL_B : nvapi.h
  • NVVIOSIGNALFORMAT_1080PSF_23_98_SMPTE274 : nvapi.h
  • NVVIOSIGNALFORMAT_1080PSF_24_00_SMPTE274 : nvapi.h
  • NVVIOSIGNALFORMAT_1080PSF_25_00_SMPTE274 : nvapi.h
  • NVVIOSIGNALFORMAT_1080PSF_29_97_SMPTE274 : nvapi.h
  • NVVIOSIGNALFORMAT_1080PSF_30_00_SMPTE274 : nvapi.h
  • NVVIOSIGNALFORMAT_2048I_47_96_SMPTE372 : nvapi.h
  • NVVIOSIGNALFORMAT_2048I_47_96_SMPTE372_3G_LEVEL_B : nvapi.h
  • NVVIOSIGNALFORMAT_2048I_48_00_SMPTE372 : nvapi.h
  • NVVIOSIGNALFORMAT_2048I_48_00_SMPTE372_3G_LEVEL_B : nvapi.h
  • NVVIOSIGNALFORMAT_2048I_50_00_SMPTE372 : nvapi.h
  • NVVIOSIGNALFORMAT_2048I_50_00_SMPTE372_3G_LEVEL_B : nvapi.h
  • NVVIOSIGNALFORMAT_2048I_59_94_SMPTE372 : nvapi.h
  • NVVIOSIGNALFORMAT_2048I_59_94_SMPTE372_3G_LEVEL_B : nvapi.h
  • NVVIOSIGNALFORMAT_2048I_60_00_SMPTE372 : nvapi.h
  • NVVIOSIGNALFORMAT_2048I_60_00_SMPTE372_3G_LEVEL_B : nvapi.h
  • NVVIOSIGNALFORMAT_2048P_23_98_SMPTE372 : nvapi.h
  • NVVIOSIGNALFORMAT_2048P_23_98_SMPTE372_3G_LEVEL_B : nvapi.h
  • NVVIOSIGNALFORMAT_2048P_24_00_SMPTE372 : nvapi.h
  • NVVIOSIGNALFORMAT_2048P_24_00_SMPTE372_3G_LEVEL_B : nvapi.h
  • NVVIOSIGNALFORMAT_2048P_25_00_SMPTE372 : nvapi.h
  • NVVIOSIGNALFORMAT_2048P_25_00_SMPTE372_3G_LEVEL_B : nvapi.h
  • NVVIOSIGNALFORMAT_2048P_29_97_SMPTE372 : nvapi.h
  • NVVIOSIGNALFORMAT_2048P_29_97_SMPTE372_3G_LEVEL_B : nvapi.h
  • NVVIOSIGNALFORMAT_2048P_30_00_SMPTE372 : nvapi.h
  • NVVIOSIGNALFORMAT_2048P_30_00_SMPTE372_3G_LEVEL_B : nvapi.h
  • NVVIOSIGNALFORMAT_487I_59_94_SMPTE259_NTSC : nvapi.h
  • NVVIOSIGNALFORMAT_576I_50_00_SMPTE259_PAL : nvapi.h
  • NVVIOSIGNALFORMAT_720P_23_98_SMPTE296 : nvapi.h
  • NVVIOSIGNALFORMAT_720P_24_00_SMPTE296 : nvapi.h
  • NVVIOSIGNALFORMAT_720P_25_00_SMPTE296 : nvapi.h
  • NVVIOSIGNALFORMAT_720P_29_97_SMPTE296 : nvapi.h
  • NVVIOSIGNALFORMAT_720P_30_00_SMPTE296 : nvapi.h
  • NVVIOSIGNALFORMAT_720P_50_00_SMPTE296 : nvapi.h
  • NVVIOSIGNALFORMAT_720P_59_94_SMPTE296 : nvapi.h
  • NVVIOSIGNALFORMAT_720P_60_00_SMPTE296 : nvapi.h
  • NVVIOSIGNALFORMAT_END : nvapi.h
  • NVVIOSIGNALFORMAT_NONE : nvapi.h
  • NVVIOSIGNALFORMATDETAIL : nvapi.h
  • NVVIOSTATUS : nvapi.h
  • NVVIOSTATUS_ERROR : nvapi.h
  • NVVIOSTATUS_RUNNING : nvapi.h
  • NVVIOSTATUS_STOPPED : nvapi.h
  • NVVIOSTATUS_VER : nvapi.h
  • NVVIOSTATUSTYPE : nvapi.h
  • NVVIOSTATUSTYPE_IN : nvapi.h
  • NVVIOSTATUSTYPE_OUT : nvapi.h
  • NVVIOSTREAM : nvapi.h
  • NVVIOSYNCDELAY : nvapi.h
  • NVVIOSYNCDELAY_VER : nvapi.h
  • NVVIOSYNCSOURCE : nvapi.h
  • NVVIOSYNCSOURCE_COMPSYNC : nvapi.h
  • NVVIOSYNCSOURCE_SDISYNC : nvapi.h
  • NVVIOSYNCSTATUS : nvapi.h
  • NVVIOSYNCSTATUS_COMPOSITE : nvapi.h
  • NVVIOSYNCSTATUS_ERROR : nvapi.h
  • NVVIOSYNCSTATUS_OFF : nvapi.h
  • NVVIOSYNCSTATUS_SDI_HD : nvapi.h
  • NVVIOSYNCSTATUS_SDI_SD : nvapi.h
  • NVVIOSYNCSTATUS_SYNCLOSS : nvapi.h
  • NVVIOTOPOLOGY : nvapi.h
  • NVVIOTOPOLOGY_VER : nvapi.h
  • NVVIOVIDEOMODE : nvapi.h
  • NVVIOVIDEOSTANDARD : nvapi.h
  • NVVIOVIDEOSTANDARD_SMPTE259 : nvapi.h
  • NVVIOVIDEOSTANDARD_SMPTE260 : nvapi.h
  • NVVIOVIDEOSTANDARD_SMPTE274 : nvapi.h
  • NVVIOVIDEOSTANDARD_SMPTE295 : nvapi.h
  • NVVIOVIDEOSTANDARD_SMPTE296 : nvapi.h
  • NVVIOVIDEOSTANDARD_SMPTE372 : nvapi.h
  • NVVIOVIDEOTYPE : nvapi.h
  • NVVIOVIDEOTYPE_HD : nvapi.h
  • NVVIOVIDEOTYPE_SD : nvapi.h
  • NvWaveMatch() : nvHLSLExtns.h
  • NvWaveMultiPrefixExclusiveAdd() : nvHLSLExtns.h
  • NvWaveMultiPrefixExclusiveAnd() : nvHLSLExtns.h
  • NvWaveMultiPrefixExclusiveOr() : nvHLSLExtns.h
  • NvWaveMultiPrefixExclusiveXOr() : nvHLSLExtns.h
  • NvWaveMultiPrefixInclusiveAdd() : nvHLSLExtns.h
  • NvWaveMultiPrefixInclusiveAnd() : nvHLSLExtns.h
  • NvWaveMultiPrefixInclusiveOr() : nvHLSLExtns.h
  • NvWaveMultiPrefixInclusiveXOr() : nvHLSLExtns.h


  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • v
  • w
Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- o -

  • OGL_AA_LINE_GAMMA_DEFAULT : NvApiDriverSettings.h
  • OGL_AA_LINE_GAMMA_DISABLED : NvApiDriverSettings.h
  • OGL_AA_LINE_GAMMA_ENABLED : NvApiDriverSettings.h
  • OGL_AA_LINE_GAMMA_ID : NvApiDriverSettings.h
  • OGL_AA_LINE_GAMMA_MAX : NvApiDriverSettings.h
  • OGL_AA_LINE_GAMMA_MIN : NvApiDriverSettings.h
  • OGL_AA_LINE_GAMMA_NUM_VALUES : NvApiDriverSettings.h
  • OGL_AA_LINE_GAMMA_STRING : NvApiDriverSettings.h
  • OGL_CPL_GDI_COMPATIBILITY_AUTO : NvApiDriverSettings.h
  • OGL_CPL_GDI_COMPATIBILITY_DEFAULT : NvApiDriverSettings.h
  • OGL_CPL_GDI_COMPATIBILITY_ID : NvApiDriverSettings.h
  • OGL_CPL_GDI_COMPATIBILITY_NUM_VALUES : NvApiDriverSettings.h
  • OGL_CPL_GDI_COMPATIBILITY_PREFER_DISABLED : NvApiDriverSettings.h
  • OGL_CPL_GDI_COMPATIBILITY_PREFER_ENABLED : NvApiDriverSettings.h
  • OGL_CPL_GDI_COMPATIBILITY_STRING : NvApiDriverSettings.h
  • OGL_CPL_PREFER_DXPRESENT_AUTO : NvApiDriverSettings.h
  • OGL_CPL_PREFER_DXPRESENT_DEFAULT : NvApiDriverSettings.h
  • OGL_CPL_PREFER_DXPRESENT_ID : NvApiDriverSettings.h
  • OGL_CPL_PREFER_DXPRESENT_NUM_VALUES : NvApiDriverSettings.h
  • OGL_CPL_PREFER_DXPRESENT_PREFER_DISABLED : NvApiDriverSettings.h
  • OGL_CPL_PREFER_DXPRESENT_PREFER_ENABLED : NvApiDriverSettings.h
  • OGL_CPL_PREFER_DXPRESENT_STRING : NvApiDriverSettings.h
  • OGL_DEEP_COLOR_SCANOUT_DEFAULT : NvApiDriverSettings.h
  • OGL_DEEP_COLOR_SCANOUT_DISABLE : NvApiDriverSettings.h
  • OGL_DEEP_COLOR_SCANOUT_ENABLE : NvApiDriverSettings.h
  • OGL_DEEP_COLOR_SCANOUT_ID : NvApiDriverSettings.h
  • OGL_DEEP_COLOR_SCANOUT_NUM_VALUES : NvApiDriverSettings.h
  • OGL_DEEP_COLOR_SCANOUT_STRING : NvApiDriverSettings.h
  • OGL_DEFAULT_SWAP_INTERVAL_APP_CONTROLLED : NvApiDriverSettings.h
  • OGL_DEFAULT_SWAP_INTERVAL_DEFAULT : NvApiDriverSettings.h
  • OGL_DEFAULT_SWAP_INTERVAL_DISABLE : NvApiDriverSettings.h
  • OGL_DEFAULT_SWAP_INTERVAL_FORCE_MASK : NvApiDriverSettings.h
  • OGL_DEFAULT_SWAP_INTERVAL_FORCE_OFF : NvApiDriverSettings.h
  • OGL_DEFAULT_SWAP_INTERVAL_FORCE_ON : NvApiDriverSettings.h
  • OGL_DEFAULT_SWAP_INTERVAL_FRACTIONAL_DEFAULT : NvApiDriverSettings.h
  • OGL_DEFAULT_SWAP_INTERVAL_FRACTIONAL_ID : NvApiDriverSettings.h
  • OGL_DEFAULT_SWAP_INTERVAL_FRACTIONAL_NUM_VALUES : NvApiDriverSettings.h
  • OGL_DEFAULT_SWAP_INTERVAL_FRACTIONAL_ONE_FULL_FRAME_OF_SCANLINES : NvApiDriverSettings.h
  • OGL_DEFAULT_SWAP_INTERVAL_FRACTIONAL_STRING : NvApiDriverSettings.h
  • OGL_DEFAULT_SWAP_INTERVAL_FRACTIONAL_ZERO_SCANLINES : NvApiDriverSettings.h
  • OGL_DEFAULT_SWAP_INTERVAL_ID : NvApiDriverSettings.h
  • OGL_DEFAULT_SWAP_INTERVAL_NUM_VALUES : NvApiDriverSettings.h
  • OGL_DEFAULT_SWAP_INTERVAL_SIGN_DEFAULT : NvApiDriverSettings.h
  • OGL_DEFAULT_SWAP_INTERVAL_SIGN_ID : NvApiDriverSettings.h
  • OGL_DEFAULT_SWAP_INTERVAL_SIGN_NEGATIVE : NvApiDriverSettings.h
  • OGL_DEFAULT_SWAP_INTERVAL_SIGN_NUM_VALUES : NvApiDriverSettings.h
  • OGL_DEFAULT_SWAP_INTERVAL_SIGN_POSITIVE : NvApiDriverSettings.h
  • OGL_DEFAULT_SWAP_INTERVAL_SIGN_STRING : NvApiDriverSettings.h
  • OGL_DEFAULT_SWAP_INTERVAL_STRING : NvApiDriverSettings.h
  • OGL_DEFAULT_SWAP_INTERVAL_TEAR : NvApiDriverSettings.h
  • OGL_DEFAULT_SWAP_INTERVAL_VALUE_MASK : NvApiDriverSettings.h
  • OGL_DEFAULT_SWAP_INTERVAL_VSYNC : NvApiDriverSettings.h
  • OGL_DEFAULT_SWAP_INTERVAL_VSYNC_ONE : NvApiDriverSettings.h
  • OGL_EVENT_LOG_SEVERITY_THRESHOLD_ALL : NvApiDriverSettings.h
  • OGL_EVENT_LOG_SEVERITY_THRESHOLD_CRITICAL : NvApiDriverSettings.h
  • OGL_EVENT_LOG_SEVERITY_THRESHOLD_DEFAULT : NvApiDriverSettings.h
  • OGL_EVENT_LOG_SEVERITY_THRESHOLD_DISABLE : NvApiDriverSettings.h
  • OGL_EVENT_LOG_SEVERITY_THRESHOLD_ID : NvApiDriverSettings.h
  • OGL_EVENT_LOG_SEVERITY_THRESHOLD_INFORMATION : NvApiDriverSettings.h
  • OGL_EVENT_LOG_SEVERITY_THRESHOLD_NUM_VALUES : NvApiDriverSettings.h
  • OGL_EVENT_LOG_SEVERITY_THRESHOLD_STRING : NvApiDriverSettings.h
  • OGL_EVENT_LOG_SEVERITY_THRESHOLD_WARNING : NvApiDriverSettings.h
  • OGL_EXTENSION_STRING_VERSION_ID : NvApiDriverSettings.h
  • OGL_EXTENSION_STRING_VERSION_STRING : NvApiDriverSettings.h
  • OGL_FORCE_BLIT_DEFAULT : NvApiDriverSettings.h
  • OGL_FORCE_BLIT_ID : NvApiDriverSettings.h
  • OGL_FORCE_BLIT_NUM_VALUES : NvApiDriverSettings.h
  • OGL_FORCE_BLIT_OFF : NvApiDriverSettings.h
  • OGL_FORCE_BLIT_ON : NvApiDriverSettings.h
  • OGL_FORCE_BLIT_STRING : NvApiDriverSettings.h
  • OGL_FORCE_STEREO_DEFAULT : NvApiDriverSettings.h
  • OGL_FORCE_STEREO_ID : NvApiDriverSettings.h
  • OGL_FORCE_STEREO_NUM_VALUES : NvApiDriverSettings.h
  • OGL_FORCE_STEREO_OFF : NvApiDriverSettings.h
  • OGL_FORCE_STEREO_ON : NvApiDriverSettings.h
  • OGL_FORCE_STEREO_STRING : NvApiDriverSettings.h
  • OGL_IMPLICIT_GPU_AFFINITY_AUTOSELECT : NvApiDriverSettings.h
  • OGL_IMPLICIT_GPU_AFFINITY_DEFAULT : NvApiDriverSettings.h
  • OGL_IMPLICIT_GPU_AFFINITY_ENV_VAR : NvApiDriverSettings.h
  • OGL_IMPLICIT_GPU_AFFINITY_ID : NvApiDriverSettings.h
  • OGL_IMPLICIT_GPU_AFFINITY_NUM_VALUES : NvApiDriverSettings.h
  • OGL_IMPLICIT_GPU_AFFINITY_STRING : NvApiDriverSettings.h
  • OGL_MAX_FRAMES_ALLOWED_ID : NvApiDriverSettings.h
  • OGL_MAX_FRAMES_ALLOWED_STRING : NvApiDriverSettings.h
  • OGL_OVERLAY_PIXEL_TYPE_CI : NvApiDriverSettings.h
  • OGL_OVERLAY_PIXEL_TYPE_CI_AND_RGBA : NvApiDriverSettings.h
  • OGL_OVERLAY_PIXEL_TYPE_DEFAULT : NvApiDriverSettings.h
  • OGL_OVERLAY_PIXEL_TYPE_ID : NvApiDriverSettings.h
  • OGL_OVERLAY_PIXEL_TYPE_NONE : NvApiDriverSettings.h
  • OGL_OVERLAY_PIXEL_TYPE_NUM_VALUES : NvApiDriverSettings.h
  • OGL_OVERLAY_PIXEL_TYPE_RGBA : NvApiDriverSettings.h
  • OGL_OVERLAY_PIXEL_TYPE_STRING : NvApiDriverSettings.h
  • OGL_OVERLAY_SUPPORT_DEFAULT : NvApiDriverSettings.h
  • OGL_OVERLAY_SUPPORT_FORCE_SW : NvApiDriverSettings.h
  • OGL_OVERLAY_SUPPORT_ID : NvApiDriverSettings.h
  • OGL_OVERLAY_SUPPORT_NUM_VALUES : NvApiDriverSettings.h
  • OGL_OVERLAY_SUPPORT_OFF : NvApiDriverSettings.h
  • OGL_OVERLAY_SUPPORT_ON : NvApiDriverSettings.h
  • OGL_OVERLAY_SUPPORT_STRING : NvApiDriverSettings.h
  • OGL_QUALITY_ENHANCEMENTS_DEFAULT : NvApiDriverSettings.h
  • OGL_QUALITY_ENHANCEMENTS_HPERF : NvApiDriverSettings.h
  • OGL_QUALITY_ENHANCEMENTS_HQUAL : NvApiDriverSettings.h
  • OGL_QUALITY_ENHANCEMENTS_ID : NvApiDriverSettings.h
  • OGL_QUALITY_ENHANCEMENTS_NUM_VALUES : NvApiDriverSettings.h
  • OGL_QUALITY_ENHANCEMENTS_PERF : NvApiDriverSettings.h
  • OGL_QUALITY_ENHANCEMENTS_QUAL : NvApiDriverSettings.h
  • OGL_QUALITY_ENHANCEMENTS_STRING : NvApiDriverSettings.h
  • OGL_SINGLE_BACKDEPTH_BUFFER_DEFAULT : NvApiDriverSettings.h
  • OGL_SINGLE_BACKDEPTH_BUFFER_DISABLE : NvApiDriverSettings.h
  • OGL_SINGLE_BACKDEPTH_BUFFER_ENABLE : NvApiDriverSettings.h
  • OGL_SINGLE_BACKDEPTH_BUFFER_ID : NvApiDriverSettings.h
  • OGL_SINGLE_BACKDEPTH_BUFFER_NUM_VALUES : NvApiDriverSettings.h
  • OGL_SINGLE_BACKDEPTH_BUFFER_STRING : NvApiDriverSettings.h
  • OGL_SINGLE_BACKDEPTH_BUFFER_USE_HW_DEFAULT : NvApiDriverSettings.h
  • OGL_SLI_MULTICAST_ALLOW_MOSAIC : NvApiDriverSettings.h
  • OGL_SLI_MULTICAST_DEFAULT : NvApiDriverSettings.h
  • OGL_SLI_MULTICAST_DISABLE : NvApiDriverSettings.h
  • OGL_SLI_MULTICAST_ENABLE : NvApiDriverSettings.h
  • OGL_SLI_MULTICAST_FORCE_DISABLE : NvApiDriverSettings.h
  • OGL_SLI_MULTICAST_ID : NvApiDriverSettings.h
  • OGL_SLI_MULTICAST_NUM_VALUES : NvApiDriverSettings.h
  • OGL_SLI_MULTICAST_STRING : NvApiDriverSettings.h
  • OGL_THREAD_CONTROL_DEFAULT : NvApiDriverSettings.h
  • OGL_THREAD_CONTROL_DISABLE : NvApiDriverSettings.h
  • OGL_THREAD_CONTROL_ENABLE : NvApiDriverSettings.h
  • OGL_THREAD_CONTROL_ID : NvApiDriverSettings.h
  • OGL_THREAD_CONTROL_NUM_VALUES : NvApiDriverSettings.h
  • OGL_THREAD_CONTROL_STRING : NvApiDriverSettings.h
  • OGL_TMON_LEVEL_CRITICAL : NvApiDriverSettings.h
  • OGL_TMON_LEVEL_DEFAULT : NvApiDriverSettings.h
  • OGL_TMON_LEVEL_DISABLE : NvApiDriverSettings.h
  • OGL_TMON_LEVEL_ID : NvApiDriverSettings.h
  • OGL_TMON_LEVEL_INFORMATION : NvApiDriverSettings.h
  • OGL_TMON_LEVEL_MOST : NvApiDriverSettings.h
  • OGL_TMON_LEVEL_NUM_VALUES : NvApiDriverSettings.h
  • OGL_TMON_LEVEL_STRING : NvApiDriverSettings.h
  • OGL_TMON_LEVEL_VERBOSE : NvApiDriverSettings.h
  • OGL_TMON_LEVEL_WARNING : NvApiDriverSettings.h
  • OGL_TRIPLE_BUFFER_DEFAULT : NvApiDriverSettings.h
  • OGL_TRIPLE_BUFFER_DISABLED : NvApiDriverSettings.h
  • OGL_TRIPLE_BUFFER_ENABLED : NvApiDriverSettings.h
  • OGL_TRIPLE_BUFFER_ID : NvApiDriverSettings.h
  • OGL_TRIPLE_BUFFER_NUM_VALUES : NvApiDriverSettings.h
  • OGL_TRIPLE_BUFFER_STRING : NvApiDriverSettings.h
  • OPTIMUS_MAXAA_DEFAULT : NvApiDriverSettings.h
  • OPTIMUS_MAXAA_ID : NvApiDriverSettings.h
  • OPTIMUS_MAXAA_MAX : NvApiDriverSettings.h
  • OPTIMUS_MAXAA_MIN : NvApiDriverSettings.h
  • OPTIMUS_MAXAA_NUM_VALUES : NvApiDriverSettings.h
  • OPTIMUS_MAXAA_STRING : NvApiDriverSettings.h
  • OUT_OF_BAND_IGNORE : nvapi.h
  • OUT_OF_BAND_PRESENT : nvapi.h
  • OUT_OF_BAND_PRESENT_END : nvapi.h
  • OUT_OF_BAND_PRESENT_START : nvapi.h
  • OUT_OF_BAND_RENDER : nvapi.h
  • OUT_OF_BAND_RENDERSUBMIT_END : nvapi.h
  • OUT_OF_BAND_RENDERSUBMIT_START : nvapi.h
  • ownerType : nvapi.h


  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • v
  • w
Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- p -

  • pAdapterCaps : nvapi.h
  • pbCompatible : nvapi.h
  • PC_LATENCY_PING : nvapi.h
  • pConfig : nvapi.h
  • pCSC : nvapi.h
  • pDataFormatDetail : nvapi.h
  • pGamma : nvapi.h
  • PHYSXINDICATOR_DEFAULT : NvApiDriverSettings.h
  • PHYSXINDICATOR_DISABLED : NvApiDriverSettings.h
  • PHYSXINDICATOR_ENABLED : NvApiDriverSettings.h
  • PHYSXINDICATOR_ID : NvApiDriverSettings.h
  • PHYSXINDICATOR_NUM_VALUES : NvApiDriverSettings.h
  • PHYSXINDICATOR_STRING : NvApiDriverSettings.h
  • pMemoryInfo : nvapi_lite_common.h
  • PNV_EVENT_REGISTER_CALLBACK : nvapi.h
  • PNV_MULTIGPU_CAPS : nvapi.h
  • PNV_MULTIGPU_CAPS_V1 : nvapi.h
  • PNV_MULTIGPU_CAPS_V2 : nvapi.h
  • pOSAdapterId : nvapi.h
  • pOutputsMask : nvapi.h
  • pPathCount : nvapi.h
  • pPathInfo : nvapi.h
  • pPerfPstatesInfo : nvapi.h
  • pRate : nvapi.h
  • PREFERRED_PSTATE_ADAPTIVE : NvApiDriverSettings.h
  • PREFERRED_PSTATE_DEFAULT : NvApiDriverSettings.h
  • PREFERRED_PSTATE_DRIVER_CONTROLLED : NvApiDriverSettings.h
  • PREFERRED_PSTATE_ID : NvApiDriverSettings.h
  • PREFERRED_PSTATE_MAX : NvApiDriverSettings.h
  • PREFERRED_PSTATE_MIN : NvApiDriverSettings.h
  • PREFERRED_PSTATE_NUM_VALUES : NvApiDriverSettings.h
  • PREFERRED_PSTATE_OPTIMAL_POWER : NvApiDriverSettings.h
  • PREFERRED_PSTATE_PREFER_CONSISTENT_PERFORMANCE : NvApiDriverSettings.h
  • PREFERRED_PSTATE_PREFER_MAX : NvApiDriverSettings.h
  • PREFERRED_PSTATE_PREFER_MIN : NvApiDriverSettings.h
  • PREFERRED_PSTATE_STRING : NvApiDriverSettings.h
  • PRERENDERLIMIT_APP_CONTROLLED : NvApiDriverSettings.h
  • PRERENDERLIMIT_DEFAULT : NvApiDriverSettings.h
  • PRERENDERLIMIT_ID : NvApiDriverSettings.h
  • PRERENDERLIMIT_MAX : NvApiDriverSettings.h
  • PRERENDERLIMIT_MIN : NvApiDriverSettings.h
  • PRERENDERLIMIT_NUM_VALUES : NvApiDriverSettings.h
  • PRERENDERLIMIT_STRING : NvApiDriverSettings.h
  • PRESENT_BARRIER_NOT_JOINED : nvapi.h
  • PRESENT_BARRIER_SYNC_CLIENT : nvapi.h
  • PRESENT_BARRIER_SYNC_CLUSTER : nvapi.h
  • PRESENT_BARRIER_SYNC_SYSTEM : nvapi.h
  • PRESENT_END : nvapi.h
  • PRESENT_START : nvapi.h
  • PREVENT_UI_AF_OVERRIDE_DEFAULT : NvApiDriverSettings.h
  • PREVENT_UI_AF_OVERRIDE_ID : NvApiDriverSettings.h
  • PREVENT_UI_AF_OVERRIDE_NUM_VALUES : NvApiDriverSettings.h
  • PREVENT_UI_AF_OVERRIDE_OFF : NvApiDriverSettings.h
  • PREVENT_UI_AF_OVERRIDE_ON : NvApiDriverSettings.h
  • PREVENT_UI_AF_OVERRIDE_STRING : NvApiDriverSettings.h
  • PS_SHADERDISKCACHE_DEFAULT : NvApiDriverSettings.h
  • PS_SHADERDISKCACHE_DLL_PATH_WCHAR_ID : NvApiDriverSettings.h
  • PS_SHADERDISKCACHE_DLL_PATH_WCHAR_STRING : NvApiDriverSettings.h
  • PS_SHADERDISKCACHE_ID : NvApiDriverSettings.h
  • PS_SHADERDISKCACHE_MAX_SIZE_DEFAULT : NvApiDriverSettings.h
  • PS_SHADERDISKCACHE_MAX_SIZE_ID : NvApiDriverSettings.h
  • PS_SHADERDISKCACHE_MAX_SIZE_MAX : NvApiDriverSettings.h
  • PS_SHADERDISKCACHE_MAX_SIZE_MIN : NvApiDriverSettings.h
  • PS_SHADERDISKCACHE_MAX_SIZE_NUM_VALUES : NvApiDriverSettings.h
  • PS_SHADERDISKCACHE_MAX_SIZE_STRING : NvApiDriverSettings.h
  • PS_SHADERDISKCACHE_NUM_VALUES : NvApiDriverSettings.h
  • PS_SHADERDISKCACHE_OFF : NvApiDriverSettings.h
  • PS_SHADERDISKCACHE_ON : NvApiDriverSettings.h
  • PS_SHADERDISKCACHE_STRING : NvApiDriverSettings.h
  • PS_TEXFILTER_ANISO_OPTS2_DEFAULT : NvApiDriverSettings.h
  • PS_TEXFILTER_ANISO_OPTS2_ID : NvApiDriverSettings.h
  • PS_TEXFILTER_ANISO_OPTS2_NUM_VALUES : NvApiDriverSettings.h
  • PS_TEXFILTER_ANISO_OPTS2_OFF : NvApiDriverSettings.h
  • PS_TEXFILTER_ANISO_OPTS2_ON : NvApiDriverSettings.h
  • PS_TEXFILTER_ANISO_OPTS2_STRING : NvApiDriverSettings.h
  • PS_TEXFILTER_BILINEAR_IN_ANISO_DEFAULT : NvApiDriverSettings.h
  • PS_TEXFILTER_BILINEAR_IN_ANISO_ID : NvApiDriverSettings.h
  • PS_TEXFILTER_BILINEAR_IN_ANISO_NUM_VALUES : NvApiDriverSettings.h
  • PS_TEXFILTER_BILINEAR_IN_ANISO_OFF : NvApiDriverSettings.h
  • PS_TEXFILTER_BILINEAR_IN_ANISO_ON : NvApiDriverSettings.h
  • PS_TEXFILTER_BILINEAR_IN_ANISO_STRING : NvApiDriverSettings.h
  • PS_TEXFILTER_DISABLE_TRILIN_SLOPE_DEFAULT : NvApiDriverSettings.h
  • PS_TEXFILTER_DISABLE_TRILIN_SLOPE_ID : NvApiDriverSettings.h
  • PS_TEXFILTER_DISABLE_TRILIN_SLOPE_NUM_VALUES : NvApiDriverSettings.h
  • PS_TEXFILTER_DISABLE_TRILIN_SLOPE_OFF : NvApiDriverSettings.h
  • PS_TEXFILTER_DISABLE_TRILIN_SLOPE_ON : NvApiDriverSettings.h
  • PS_TEXFILTER_DISABLE_TRILIN_SLOPE_STRING : NvApiDriverSettings.h
  • PS_TEXFILTER_NO_NEG_LODBIAS_DEFAULT : NvApiDriverSettings.h
  • PS_TEXFILTER_NO_NEG_LODBIAS_ID : NvApiDriverSettings.h
  • PS_TEXFILTER_NO_NEG_LODBIAS_NUM_VALUES : NvApiDriverSettings.h
  • PS_TEXFILTER_NO_NEG_LODBIAS_OFF : NvApiDriverSettings.h
  • PS_TEXFILTER_NO_NEG_LODBIAS_ON : NvApiDriverSettings.h
  • PS_TEXFILTER_NO_NEG_LODBIAS_STRING : NvApiDriverSettings.h
  • pSignalFormatDetail : nvapi.h
  • pSize : nvapi.h
  • pStatus : nvapi.h
  • pSyncDelay : nvapi.h
  • pTargetInfo : nvapi.h
  • pTargetMaskCount : nvapi.h
  • pTargets : nvapi.h
  • pTargetView : nvapi.h
  • pTargetViewMode : nvapi.h
  • pVersion : nvapi.h
  • pVioPCIInfo : nvapi.h
  • pWait : nvapi.h


  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • v
  • w
Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- q -

  • QUALITY_ENHANCEMENT_SUBSTITUTION_DEFAULT : NvApiDriverSettings.h
  • QUALITY_ENHANCEMENT_SUBSTITUTION_HIGHQUALITY_BECOMES_QUALITY : NvApiDriverSettings.h
  • QUALITY_ENHANCEMENT_SUBSTITUTION_ID : NvApiDriverSettings.h
  • QUALITY_ENHANCEMENT_SUBSTITUTION_NO_SUBSTITUTION : NvApiDriverSettings.h
  • QUALITY_ENHANCEMENT_SUBSTITUTION_NUM_VALUES : NvApiDriverSettings.h
  • QUALITY_ENHANCEMENT_SUBSTITUTION_STRING : NvApiDriverSettings.h
  • QUALITY_ENHANCEMENTS_DEFAULT : NvApiDriverSettings.h
  • QUALITY_ENHANCEMENTS_HIGHPERFORMANCE : NvApiDriverSettings.h
  • QUALITY_ENHANCEMENTS_HIGHQUALITY : NvApiDriverSettings.h
  • QUALITY_ENHANCEMENTS_ID : NvApiDriverSettings.h
  • QUALITY_ENHANCEMENTS_NUM_VALUES : NvApiDriverSettings.h
  • QUALITY_ENHANCEMENTS_PERFORMANCE : NvApiDriverSettings.h
  • QUALITY_ENHANCEMENTS_QUALITY : NvApiDriverSettings.h
  • QUALITY_ENHANCEMENTS_STRING : NvApiDriverSettings.h


  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • v
  • w
Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- r -

  • REFRESH_RATE_OVERRIDE_APPLICATION_CONTROLLED : NvApiDriverSettings.h
  • REFRESH_RATE_OVERRIDE_DEFAULT : NvApiDriverSettings.h
  • REFRESH_RATE_OVERRIDE_HIGHEST_AVAILABLE : NvApiDriverSettings.h
  • REFRESH_RATE_OVERRIDE_ID : NvApiDriverSettings.h
  • REFRESH_RATE_OVERRIDE_LOW_LATENCY_RR_MASK : NvApiDriverSettings.h
  • REFRESH_RATE_OVERRIDE_NUM_VALUES : NvApiDriverSettings.h
  • REFRESH_RATE_OVERRIDE_STRING : NvApiDriverSettings.h
  • RENDERSUBMIT_END : nvapi.h
  • RENDERSUBMIT_START : nvapi.h


  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • v
  • w
Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- s -

  • SET_POWER_THROTTLE_FOR_PCIe_COMPLIANCE_DEFAULT : NvApiDriverSettings.h
  • SET_POWER_THROTTLE_FOR_PCIe_COMPLIANCE_ID : NvApiDriverSettings.h
  • SET_POWER_THROTTLE_FOR_PCIe_COMPLIANCE_NUM_VALUES : NvApiDriverSettings.h
  • SET_POWER_THROTTLE_FOR_PCIe_COMPLIANCE_OFF : NvApiDriverSettings.h
  • SET_POWER_THROTTLE_FOR_PCIe_COMPLIANCE_ON : NvApiDriverSettings.h
  • SET_POWER_THROTTLE_FOR_PCIe_COMPLIANCE_STRING : NvApiDriverSettings.h
  • SET_VAB_DATA_DEFAULT : NvApiDriverSettings.h
  • SET_VAB_DATA_FLOAT_NAN : NvApiDriverSettings.h
  • SET_VAB_DATA_FLOAT_ONE : NvApiDriverSettings.h
  • SET_VAB_DATA_FLOAT_POS_INF : NvApiDriverSettings.h
  • SET_VAB_DATA_ID : NvApiDriverSettings.h
  • SET_VAB_DATA_NUM_VALUES : NvApiDriverSettings.h
  • SET_VAB_DATA_STRING : NvApiDriverSettings.h
  • SET_VAB_DATA_UINT_ONE : NvApiDriverSettings.h
  • SET_VAB_DATA_USE_API_DEFAULTS : NvApiDriverSettings.h
  • SET_VAB_DATA_ZERO : NvApiDriverSettings.h
  • SettingDWORDNameString : NvApiDriverSettings.h
  • SettingWSTRINGNameString : NvApiDriverSettings.h
  • SHIM_MAXRES_ID : NvApiDriverSettings.h
  • SHIM_MAXRES_STRING : NvApiDriverSettings.h
  • SHIM_MCCOMPAT_AUTO_SELECT : NvApiDriverSettings.h
  • SHIM_MCCOMPAT_DEFAULT : NvApiDriverSettings.h
  • SHIM_MCCOMPAT_ENABLE : NvApiDriverSettings.h
  • SHIM_MCCOMPAT_ID : NvApiDriverSettings.h
  • SHIM_MCCOMPAT_INTEGRATED : NvApiDriverSettings.h
  • SHIM_MCCOMPAT_MASK : NvApiDriverSettings.h
  • SHIM_MCCOMPAT_NUM_VALUES : NvApiDriverSettings.h
  • SHIM_MCCOMPAT_OVERRIDE_BIT : NvApiDriverSettings.h
  • SHIM_MCCOMPAT_STRING : NvApiDriverSettings.h
  • SHIM_MCCOMPAT_USER_EDITABLE : NvApiDriverSettings.h
  • SHIM_MCCOMPAT_VARYING_BIT : NvApiDriverSettings.h
  • SHIM_MCCOMPAT_VIDEO_MASK : NvApiDriverSettings.h
  • SHIM_RENDERING_MODE_AUTO_SELECT : NvApiDriverSettings.h
  • SHIM_RENDERING_MODE_DEFAULT : NvApiDriverSettings.h
  • SHIM_RENDERING_MODE_ENABLE : NvApiDriverSettings.h
  • SHIM_RENDERING_MODE_ID : NvApiDriverSettings.h
  • SHIM_RENDERING_MODE_INTEGRATED : NvApiDriverSettings.h
  • SHIM_RENDERING_MODE_MASK : NvApiDriverSettings.h
  • SHIM_RENDERING_MODE_NUM_VALUES : NvApiDriverSettings.h
  • SHIM_RENDERING_MODE_OVERRIDE_BIT : NvApiDriverSettings.h
  • SHIM_RENDERING_MODE_STRING : NvApiDriverSettings.h
  • SHIM_RENDERING_MODE_USER_EDITABLE : NvApiDriverSettings.h
  • SHIM_RENDERING_MODE_VARYING_BIT : NvApiDriverSettings.h
  • SHIM_RENDERING_MODE_VIDEO_MASK : NvApiDriverSettings.h
  • SHIM_RENDERING_OPTIONS_ALLOW_CP_CAPS_FOR_VIDEO : NvApiDriverSettings.h
  • SHIM_RENDERING_OPTIONS_ALLOW_DYNAMIC_DISPLAY_MUX_SWITCH : NvApiDriverSettings.h
  • SHIM_RENDERING_OPTIONS_ALLOW_INHERITANCE : NvApiDriverSettings.h
  • SHIM_RENDERING_OPTIONS_DEFAULT : NvApiDriverSettings.h
  • SHIM_RENDERING_OPTIONS_DEFAULT_RENDERING_MODE : NvApiDriverSettings.h
  • SHIM_RENDERING_OPTIONS_DISABLE_ASYNC_PRESENT : NvApiDriverSettings.h
  • SHIM_RENDERING_OPTIONS_DISABLE_CUDA : NvApiDriverSettings.h
  • SHIM_RENDERING_OPTIONS_DISABLE_DURING_SECURE_BOOT : NvApiDriverSettings.h
  • SHIM_RENDERING_OPTIONS_DISABLE_DXGI_WRAPPERS : NvApiDriverSettings.h
  • SHIM_RENDERING_OPTIONS_DISABLE_TURING_POWER_POLICY : NvApiDriverSettings.h
  • SHIM_RENDERING_OPTIONS_DISABLE_WRAPPERS : NvApiDriverSettings.h
  • SHIM_RENDERING_OPTIONS_DISALLOW_DYNAMIC_DISPLAY_MUX_SWITCH : NvApiDriverSettings.h
  • SHIM_RENDERING_OPTIONS_EHSHELL_DETECT : NvApiDriverSettings.h
  • SHIM_RENDERING_OPTIONS_ENABLE_ALPHA_FORMAT : NvApiDriverSettings.h
  • SHIM_RENDERING_OPTIONS_ENABLE_DWM_ASYNC_PRESENT : NvApiDriverSettings.h
  • SHIM_RENDERING_OPTIONS_EXPLICIT_ADAPTER_OPTED_BY_APP : NvApiDriverSettings.h
  • SHIM_RENDERING_OPTIONS_FLASHPLAYER_HOST_DETECT : NvApiDriverSettings.h
  • SHIM_RENDERING_OPTIONS_HANDLE_WIN7_ASYNC_RUNTIME_BUG : NvApiDriverSettings.h
  • SHIM_RENDERING_OPTIONS_HANDLE_WINDOWED_MODE_PERF_OPT : NvApiDriverSettings.h
  • SHIM_RENDERING_OPTIONS_ID : NvApiDriverSettings.h
  • SHIM_RENDERING_OPTIONS_IGNORE_OVERRIDES : NvApiDriverSettings.h
  • SHIM_RENDERING_OPTIONS_IGPU_TRANSCODING : NvApiDriverSettings.h
  • SHIM_RENDERING_OPTIONS_IGPU_TRANSCODING_FWD_OPTIMUS : NvApiDriverSettings.h
  • SHIM_RENDERING_OPTIONS_INVERT_FOR_MSHYBRID : NvApiDriverSettings.h
  • SHIM_RENDERING_OPTIONS_INVERT_FOR_QUADRO : NvApiDriverSettings.h
  • SHIM_RENDERING_OPTIONS_NUM_VALUES : NvApiDriverSettings.h
  • SHIM_RENDERING_OPTIONS_PRUNE_UNSUPPORTED_FORMATS : NvApiDriverSettings.h
  • SHIM_RENDERING_OPTIONS_REGISTER_PROCESS_ENABLE_GOLD : NvApiDriverSettings.h
  • SHIM_RENDERING_OPTIONS_RESERVED1 : NvApiDriverSettings.h
  • SHIM_RENDERING_OPTIONS_RESERVED2 : NvApiDriverSettings.h
  • SHIM_RENDERING_OPTIONS_STRING : NvApiDriverSettings.h
  • SHIM_RENDERING_OPTIONS_VIDEO_DRM_APP_DETECT : NvApiDriverSettings.h
  • SIMULATION_END : nvapi.h
  • SIMULATION_START : nvapi.h
  • SLI_GPU_COUNT_AUTOSELECT : NvApiDriverSettings.h
  • SLI_GPU_COUNT_DEFAULT : NvApiDriverSettings.h
  • SLI_GPU_COUNT_FOUR : NvApiDriverSettings.h
  • SLI_GPU_COUNT_ID : NvApiDriverSettings.h
  • SLI_GPU_COUNT_NUM_VALUES : NvApiDriverSettings.h
  • SLI_GPU_COUNT_ONE : NvApiDriverSettings.h
  • SLI_GPU_COUNT_STRING : NvApiDriverSettings.h
  • SLI_GPU_COUNT_THREE : NvApiDriverSettings.h
  • SLI_GPU_COUNT_TWO : NvApiDriverSettings.h
  • SLI_PREDEFINED_GPU_COUNT_AUTOSELECT : NvApiDriverSettings.h
  • SLI_PREDEFINED_GPU_COUNT_DEFAULT : NvApiDriverSettings.h
  • SLI_PREDEFINED_GPU_COUNT_DX10_AUTOSELECT : NvApiDriverSettings.h
  • SLI_PREDEFINED_GPU_COUNT_DX10_DEFAULT : NvApiDriverSettings.h
  • SLI_PREDEFINED_GPU_COUNT_DX10_FOUR : NvApiDriverSettings.h
  • SLI_PREDEFINED_GPU_COUNT_DX10_ID : NvApiDriverSettings.h
  • SLI_PREDEFINED_GPU_COUNT_DX10_NUM_VALUES : NvApiDriverSettings.h
  • SLI_PREDEFINED_GPU_COUNT_DX10_ONE : NvApiDriverSettings.h
  • SLI_PREDEFINED_GPU_COUNT_DX10_STRING : NvApiDriverSettings.h
  • SLI_PREDEFINED_GPU_COUNT_DX10_THREE : NvApiDriverSettings.h
  • SLI_PREDEFINED_GPU_COUNT_DX10_TWO : NvApiDriverSettings.h
  • SLI_PREDEFINED_GPU_COUNT_FOUR : NvApiDriverSettings.h
  • SLI_PREDEFINED_GPU_COUNT_ID : NvApiDriverSettings.h
  • SLI_PREDEFINED_GPU_COUNT_NUM_VALUES : NvApiDriverSettings.h
  • SLI_PREDEFINED_GPU_COUNT_ONE : NvApiDriverSettings.h
  • SLI_PREDEFINED_GPU_COUNT_STRING : NvApiDriverSettings.h
  • SLI_PREDEFINED_GPU_COUNT_THREE : NvApiDriverSettings.h
  • SLI_PREDEFINED_GPU_COUNT_TWO : NvApiDriverSettings.h
  • SLI_PREDEFINED_MODE_AUTOSELECT : NvApiDriverSettings.h
  • SLI_PREDEFINED_MODE_DEFAULT : NvApiDriverSettings.h
  • SLI_PREDEFINED_MODE_DX10_AUTOSELECT : NvApiDriverSettings.h
  • SLI_PREDEFINED_MODE_DX10_DEFAULT : NvApiDriverSettings.h
  • SLI_PREDEFINED_MODE_DX10_FORCE_AFR : NvApiDriverSettings.h
  • SLI_PREDEFINED_MODE_DX10_FORCE_AFR2 : NvApiDriverSettings.h
  • SLI_PREDEFINED_MODE_DX10_FORCE_AFR_OF_SFR__FALLBACK_3AFR : NvApiDriverSettings.h
  • SLI_PREDEFINED_MODE_DX10_FORCE_SFR : NvApiDriverSettings.h
  • SLI_PREDEFINED_MODE_DX10_FORCE_SINGLE : NvApiDriverSettings.h
  • SLI_PREDEFINED_MODE_DX10_ID : NvApiDriverSettings.h
  • SLI_PREDEFINED_MODE_DX10_NUM_VALUES : NvApiDriverSettings.h
  • SLI_PREDEFINED_MODE_DX10_STRING : NvApiDriverSettings.h
  • SLI_PREDEFINED_MODE_FORCE_AFR : NvApiDriverSettings.h
  • SLI_PREDEFINED_MODE_FORCE_AFR2 : NvApiDriverSettings.h
  • SLI_PREDEFINED_MODE_FORCE_AFR_OF_SFR__FALLBACK_3AFR : NvApiDriverSettings.h
  • SLI_PREDEFINED_MODE_FORCE_SFR : NvApiDriverSettings.h
  • SLI_PREDEFINED_MODE_FORCE_SINGLE : NvApiDriverSettings.h
  • SLI_PREDEFINED_MODE_ID : NvApiDriverSettings.h
  • SLI_PREDEFINED_MODE_NUM_VALUES : NvApiDriverSettings.h
  • SLI_PREDEFINED_MODE_STRING : NvApiDriverSettings.h
  • SLI_RENDERING_MODE_AUTOSELECT : NvApiDriverSettings.h
  • SLI_RENDERING_MODE_DEFAULT : NvApiDriverSettings.h
  • SLI_RENDERING_MODE_FORCE_AFR : NvApiDriverSettings.h
  • SLI_RENDERING_MODE_FORCE_AFR2 : NvApiDriverSettings.h
  • SLI_RENDERING_MODE_FORCE_AFR_OF_SFR__FALLBACK_3AFR : NvApiDriverSettings.h
  • SLI_RENDERING_MODE_FORCE_SFR : NvApiDriverSettings.h
  • SLI_RENDERING_MODE_FORCE_SINGLE : NvApiDriverSettings.h
  • SLI_RENDERING_MODE_ID : NvApiDriverSettings.h
  • SLI_RENDERING_MODE_NUM_VALUES : NvApiDriverSettings.h
  • SLI_RENDERING_MODE_STRING : NvApiDriverSettings.h
  • srcEnumIndex : nvapi.h
  • StereoHandle : nvapi_lite_common.h


  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • v
  • w
Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- t -

  • targetView : nvapi.h
  • temp_NvU32 : nvapi_lite_common.h
  • TOTAL_DWORD_SETTING_NUM : NvApiDriverSettings.h
  • TOTAL_SETTING_NUM : NvApiDriverSettings.h
  • TOTAL_WSTRING_SETTING_NUM : NvApiDriverSettings.h
  • TRIGGER_FLASH : nvapi.h


  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • v
  • w
Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- v -

  • vioClass : nvapi.h
  • vioDeviceCount : nvapi.h
  • VRPRERENDERLIMIT_APP_CONTROLLED : NvApiDriverSettings.h
  • VRPRERENDERLIMIT_DEFAULT : NvApiDriverSettings.h
  • VRPRERENDERLIMIT_ID : NvApiDriverSettings.h
  • VRPRERENDERLIMIT_MAX : NvApiDriverSettings.h
  • VRPRERENDERLIMIT_MIN : NvApiDriverSettings.h
  • VRPRERENDERLIMIT_NUM_VALUES : NvApiDriverSettings.h
  • VRPRERENDERLIMIT_STRING : NvApiDriverSettings.h
  • VRR_APP_OVERRIDE_ALLOW : NvApiDriverSettings.h
  • VRR_APP_OVERRIDE_DEFAULT : NvApiDriverSettings.h
  • VRR_APP_OVERRIDE_DISALLOW : NvApiDriverSettings.h
  • VRR_APP_OVERRIDE_FIXED_REFRESH : NvApiDriverSettings.h
  • VRR_APP_OVERRIDE_FORCE_OFF : NvApiDriverSettings.h
  • VRR_APP_OVERRIDE_ID : NvApiDriverSettings.h
  • VRR_APP_OVERRIDE_NUM_VALUES : NvApiDriverSettings.h
  • VRR_APP_OVERRIDE_REQUEST_STATE_ALLOW : NvApiDriverSettings.h
  • VRR_APP_OVERRIDE_REQUEST_STATE_DEFAULT : NvApiDriverSettings.h
  • VRR_APP_OVERRIDE_REQUEST_STATE_DISALLOW : NvApiDriverSettings.h
  • VRR_APP_OVERRIDE_REQUEST_STATE_FIXED_REFRESH : NvApiDriverSettings.h
  • VRR_APP_OVERRIDE_REQUEST_STATE_FORCE_OFF : NvApiDriverSettings.h
  • VRR_APP_OVERRIDE_REQUEST_STATE_ID : NvApiDriverSettings.h
  • VRR_APP_OVERRIDE_REQUEST_STATE_NUM_VALUES : NvApiDriverSettings.h
  • VRR_APP_OVERRIDE_REQUEST_STATE_STRING : NvApiDriverSettings.h
  • VRR_APP_OVERRIDE_REQUEST_STATE_ULMB : NvApiDriverSettings.h
  • VRR_APP_OVERRIDE_STRING : NvApiDriverSettings.h
  • VRR_APP_OVERRIDE_ULMB : NvApiDriverSettings.h
  • VRR_MODE_DEFAULT : NvApiDriverSettings.h
  • VRR_MODE_DISABLED : NvApiDriverSettings.h
  • VRR_MODE_FULLSCREEN_AND_WINDOWED : NvApiDriverSettings.h
  • VRR_MODE_FULLSCREEN_ONLY : NvApiDriverSettings.h
  • VRR_MODE_ID : NvApiDriverSettings.h
  • VRR_MODE_NUM_VALUES : NvApiDriverSettings.h
  • VRR_MODE_STRING : NvApiDriverSettings.h
  • VRRFEATUREINDICATOR_DEFAULT : NvApiDriverSettings.h
  • VRRFEATUREINDICATOR_DISABLED : NvApiDriverSettings.h
  • VRRFEATUREINDICATOR_ENABLED : NvApiDriverSettings.h
  • VRRFEATUREINDICATOR_ID : NvApiDriverSettings.h
  • VRRFEATUREINDICATOR_NUM_VALUES : NvApiDriverSettings.h
  • VRRFEATUREINDICATOR_STRING : NvApiDriverSettings.h
  • VRROVERLAYINDICATOR_DEFAULT : NvApiDriverSettings.h
  • VRROVERLAYINDICATOR_DISABLED : NvApiDriverSettings.h
  • VRROVERLAYINDICATOR_ENABLED : NvApiDriverSettings.h
  • VRROVERLAYINDICATOR_ID : NvApiDriverSettings.h
  • VRROVERLAYINDICATOR_NUM_VALUES : NvApiDriverSettings.h
  • VRROVERLAYINDICATOR_STRING : NvApiDriverSettings.h
  • VRRREQUESTSTATE_DEFAULT : NvApiDriverSettings.h
  • VRRREQUESTSTATE_DISABLED : NvApiDriverSettings.h
  • VRRREQUESTSTATE_FULLSCREEN_AND_WINDOWED : NvApiDriverSettings.h
  • VRRREQUESTSTATE_FULLSCREEN_ONLY : NvApiDriverSettings.h
  • VRRREQUESTSTATE_ID : NvApiDriverSettings.h
  • VRRREQUESTSTATE_NUM_VALUES : NvApiDriverSettings.h
  • VRRREQUESTSTATE_STRING : NvApiDriverSettings.h
  • VSYNC_BEHAVIOR_FLAGS_DEFAULT : NvApiDriverSettings.h
  • VSYNC_BEHAVIOR_FLAGS_ID : NvApiDriverSettings.h
  • VSYNC_BEHAVIOR_FLAGS_IGNORE_FLIPINTERVAL_MULTIPLE : NvApiDriverSettings.h
  • VSYNC_BEHAVIOR_FLAGS_NONE : NvApiDriverSettings.h
  • VSYNC_BEHAVIOR_FLAGS_NUM_VALUES : NvApiDriverSettings.h
  • VSYNC_BEHAVIOR_FLAGS_STRING : NvApiDriverSettings.h
  • VSYNCMODE_DEFAULT : NvApiDriverSettings.h
  • VSYNCMODE_FLIPINTERVAL2 : NvApiDriverSettings.h
  • VSYNCMODE_FLIPINTERVAL3 : NvApiDriverSettings.h
  • VSYNCMODE_FLIPINTERVAL4 : NvApiDriverSettings.h
  • VSYNCMODE_FORCEOFF : NvApiDriverSettings.h
  • VSYNCMODE_FORCEON : NvApiDriverSettings.h
  • VSYNCMODE_ID : NvApiDriverSettings.h
  • VSYNCMODE_NUM_VALUES : NvApiDriverSettings.h
  • VSYNCMODE_PASSIVE : NvApiDriverSettings.h
  • VSYNCMODE_STRING : NvApiDriverSettings.h
  • VSYNCMODE_VIRTUAL : NvApiDriverSettings.h
  • VSYNCSMOOTHAFR_DEFAULT : NvApiDriverSettings.h
  • VSYNCSMOOTHAFR_ID : NvApiDriverSettings.h
  • VSYNCSMOOTHAFR_NUM_VALUES : NvApiDriverSettings.h
  • VSYNCSMOOTHAFR_OFF : NvApiDriverSettings.h
  • VSYNCSMOOTHAFR_ON : NvApiDriverSettings.h
  • VSYNCSMOOTHAFR_STRING : NvApiDriverSettings.h
  • VSYNCTEARCONTROL_DEFAULT : NvApiDriverSettings.h
  • VSYNCTEARCONTROL_DISABLE : NvApiDriverSettings.h
  • VSYNCTEARCONTROL_ENABLE : NvApiDriverSettings.h
  • VSYNCTEARCONTROL_ID : NvApiDriverSettings.h
  • VSYNCTEARCONTROL_NUM_VALUES : NvApiDriverSettings.h
  • VSYNCTEARCONTROL_STRING : NvApiDriverSettings.h
  • VSYNCVRRCONTROL_DEFAULT : NvApiDriverSettings.h
  • VSYNCVRRCONTROL_DISABLE : NvApiDriverSettings.h
  • VSYNCVRRCONTROL_ENABLE : NvApiDriverSettings.h
  • VSYNCVRRCONTROL_ID : NvApiDriverSettings.h
  • VSYNCVRRCONTROL_NOTSUPPORTED : NvApiDriverSettings.h
  • VSYNCVRRCONTROL_NUM_VALUES : NvApiDriverSettings.h
  • VSYNCVRRCONTROL_STRING : NvApiDriverSettings.h


  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • v
  • w
Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- w -

  • WKS_API_STEREO_EYES_EXCHANGE_DEFAULT : NvApiDriverSettings.h
  • WKS_API_STEREO_EYES_EXCHANGE_ID : NvApiDriverSettings.h
  • WKS_API_STEREO_EYES_EXCHANGE_NUM_VALUES : NvApiDriverSettings.h
  • WKS_API_STEREO_EYES_EXCHANGE_OFF : NvApiDriverSettings.h
  • WKS_API_STEREO_EYES_EXCHANGE_ON : NvApiDriverSettings.h
  • WKS_API_STEREO_EYES_EXCHANGE_STRING : NvApiDriverSettings.h
  • WKS_API_STEREO_MODE_AEGIS_DT_FRAME_SEQUENTIAL : NvApiDriverSettings.h
  • WKS_API_STEREO_MODE_ANAGLYPH : NvApiDriverSettings.h
  • WKS_API_STEREO_MODE_AUTODETECT_PASSIVE_MODE : NvApiDriverSettings.h
  • WKS_API_STEREO_MODE_CHECKERBOARD : NvApiDriverSettings.h
  • WKS_API_STEREO_MODE_COLOR_INTERLEAVED : NvApiDriverSettings.h
  • WKS_API_STEREO_MODE_COLOR_LINE : NvApiDriverSettings.h
  • WKS_API_STEREO_MODE_DEFAULT : NvApiDriverSettings.h
  • WKS_API_STEREO_MODE_DEFAULT_GL : NvApiDriverSettings.h
  • WKS_API_STEREO_MODE_DP_INBAND : NvApiDriverSettings.h
  • WKS_API_STEREO_MODE_FRAME_SEQUENTIAL : NvApiDriverSettings.h
  • WKS_API_STEREO_MODE_HORIZONTAL_INTERLACED : NvApiDriverSettings.h
  • WKS_API_STEREO_MODE_ID : NvApiDriverSettings.h
  • WKS_API_STEREO_MODE_INVERSE_CHECKERBOARD : NvApiDriverSettings.h
  • WKS_API_STEREO_MODE_NUM_VALUES : NvApiDriverSettings.h
  • WKS_API_STEREO_MODE_NV17_SHUTTER_GLASSES_AUTO : NvApiDriverSettings.h
  • WKS_API_STEREO_MODE_NV17_SHUTTER_GLASSES_DAC0 : NvApiDriverSettings.h
  • WKS_API_STEREO_MODE_NV17_SHUTTER_GLASSES_DAC1 : NvApiDriverSettings.h
  • WKS_API_STEREO_MODE_OEM_EMITTER_FRAME_SEQUENTIAL : NvApiDriverSettings.h
  • WKS_API_STEREO_MODE_SEEFRONT : NvApiDriverSettings.h
  • WKS_API_STEREO_MODE_SHUTTER_GLASSES : NvApiDriverSettings.h
  • WKS_API_STEREO_MODE_SIDE_FIELD : NvApiDriverSettings.h
  • WKS_API_STEREO_MODE_STEREO_MIRROR : NvApiDriverSettings.h
  • WKS_API_STEREO_MODE_STRING : NvApiDriverSettings.h
  • WKS_API_STEREO_MODE_SUB_FIELD : NvApiDriverSettings.h
  • WKS_API_STEREO_MODE_TRIDELITY_MV : NvApiDriverSettings.h
  • WKS_API_STEREO_MODE_TRIDELITY_SL : NvApiDriverSettings.h
  • WKS_API_STEREO_MODE_TWINVIEW : NvApiDriverSettings.h
  • WKS_API_STEREO_MODE_USE_HW_DEFAULT : NvApiDriverSettings.h
  • WKS_API_STEREO_MODE_VERTICAL_INTERLACED : NvApiDriverSettings.h
  • WKS_STEREO_DONGLE_SUPPORT_DAC : NvApiDriverSettings.h
  • WKS_STEREO_DONGLE_SUPPORT_DEFAULT : NvApiDriverSettings.h
  • WKS_STEREO_DONGLE_SUPPORT_DLP : NvApiDriverSettings.h
  • WKS_STEREO_DONGLE_SUPPORT_ID : NvApiDriverSettings.h
  • WKS_STEREO_DONGLE_SUPPORT_NUM_VALUES : NvApiDriverSettings.h
  • WKS_STEREO_DONGLE_SUPPORT_OFF : NvApiDriverSettings.h
  • WKS_STEREO_DONGLE_SUPPORT_STRING : NvApiDriverSettings.h
  • WKS_STEREO_SUPPORT_DEFAULT : NvApiDriverSettings.h
  • WKS_STEREO_SUPPORT_ID : NvApiDriverSettings.h
  • WKS_STEREO_SUPPORT_NUM_VALUES : NvApiDriverSettings.h
  • WKS_STEREO_SUPPORT_OFF : NvApiDriverSettings.h
  • WKS_STEREO_SUPPORT_ON : NvApiDriverSettings.h
  • WKS_STEREO_SUPPORT_STRING : NvApiDriverSettings.h
  • WKS_STEREO_SWAP_MODE_APPLICATION_CONTROL : NvApiDriverSettings.h
  • WKS_STEREO_SWAP_MODE_DEFAULT : NvApiDriverSettings.h
  • WKS_STEREO_SWAP_MODE_ID : NvApiDriverSettings.h
  • WKS_STEREO_SWAP_MODE_LEGACY_BEHAVIOR : NvApiDriverSettings.h
  • WKS_STEREO_SWAP_MODE_NUM_VALUES : NvApiDriverSettings.h
  • WKS_STEREO_SWAP_MODE_PER_EYE : NvApiDriverSettings.h
  • WKS_STEREO_SWAP_MODE_PER_EYE_FOR_SWAP_GROUP : NvApiDriverSettings.h
  • WKS_STEREO_SWAP_MODE_PER_EYE_PAIR : NvApiDriverSettings.h
  • WKS_STEREO_SWAP_MODE_STRING : NvApiDriverSettings.h


  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • c
  • d
  • n
Here is a list of all functions with links to the files they belong to:

- _ -

  • __fp32x2Tofp16x2() : nvHLSLExtnsInternal.h
  • __fp32x4Tofp16x4() : nvHLSLExtnsInternal.h
  • __nvapi_deprecated_function() : nvapi.h, nvapi_lite_common.h
  • __NvAtomicAddFP32() : nvHLSLExtnsInternal.h
  • __NvAtomicCompareExchangeUINT64() : nvHLSLExtnsInternal.h
  • __NvAtomicOpFP16x2() : nvHLSLExtnsInternal.h
  • __NvAtomicOpUINT64() : nvHLSLExtnsInternal.h
  • __NvFootprint() : nvHLSLExtnsInternal.h
  • __NvFootprintBias() : nvHLSLExtnsInternal.h
  • __NvFootprintGrad() : nvHLSLExtnsInternal.h
  • __NvFootprintLevel() : nvHLSLExtnsInternal.h
  • __NvGetShflMaskFromWidth() : nvHLSLExtnsInternal.h
  • __NvGetSpecial() : nvHLSLExtnsInternal.h
  • __NvReferenceUAVForOp() : nvHLSLExtnsInternal.h
  • __NvShflGeneric() : nvHLSLExtnsInternal.h


  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • c
  • d
  • n
Here is a list of all functions with links to the files they belong to:

- c -

  • compile_time_assert() : nvapi.h


  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • c
  • d
  • n
Here is a list of all functions with links to the files they belong to:

- d -

  • DECLARE_INTERFACE() : nvapi.h
  • DECLARE_INTERFACE_() : nvapi.h


  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • c
  • d
  • n
Here is a list of all functions with links to the files they belong to:

- n -

  • NV_DECLARE_HANDLE() : nvapi.h, nvapi_lite_common.h
  • NvActiveThreads() : nvHLSLExtns.h
  • NvAll() : nvHLSLExtns.h
  • NvAny() : nvHLSLExtns.h
  • NvAPI_CreateDisplayFromUnAttachedDisplay() : nvapi.h
  • NvAPI_D3D10_SetDepthBoundsTest() : nvapi.h
  • NvAPI_D3D11_AliasMSAATexture2DAsNonMSAA() : nvapi.h
  • NvAPI_D3D11_BeginUAVOverlap() : nvapi.h
  • NvAPI_D3D11_BeginUAVOverlapEx() : nvapi.h
  • NvAPI_D3D11_CheckFeatureSupport() : nvapi.h
  • NvAPI_D3D11_CreateCubinComputeShader() : nvapi.h
  • NvAPI_D3D11_CreateCubinComputeShaderEx() : nvapi.h
  • NvAPI_D3D11_CreateCubinComputeShaderWithName() : nvapi.h
  • NvAPI_D3D11_CreateDevice() : nvapi_lite_d3dext.h
  • NvAPI_D3D11_CreateDeviceAndSwapChain() : nvapi_lite_d3dext.h
  • NvAPI_D3D11_CreateDomainShaderEx() : nvapi.h
  • NvAPI_D3D11_CreateFastGeometryShader() : nvapi.h
  • NvAPI_D3D11_CreateFastGeometryShaderExplicit() : nvapi.h
  • NvAPI_D3D11_CreateGeometryShaderEx_2() : nvapi.h
  • NvAPI_D3D11_CreateHullShaderEx() : nvapi.h
  • NvAPI_D3D11_CreateImplicitMSAATexture2D() : nvapi.h
  • NvAPI_D3D11_CreateMetaCommand() : nvapi.h
  • NvAPI_D3D11_CreateMultiGPUDevice() : nvapi.h
  • NvAPI_D3D11_CreatePixelShaderEx_2() : nvapi.h
  • NvAPI_D3D11_CreateRasterizerState() : nvapi.h
  • NvAPI_D3D11_CreateSamplerState() : nvapi.h
  • NvAPI_D3D11_CreateShaderResourceView() : nvapi.h
  • NvAPI_D3D11_CreateShadingRateResourceView() : nvapi.h
  • NvAPI_D3D11_CreateUnorderedAccessView() : nvapi.h
  • NvAPI_D3D11_CreateVertexShaderEx() : nvapi.h
  • NvAPI_D3D11_DecompressView() : nvapi.h
  • NvAPI_D3D11_DestroyCubinComputeShader() : nvapi.h
  • NvAPI_D3D11_EndUAVOverlap() : nvapi.h
  • NvAPI_D3D11_EnumerateMetaCommands() : nvapi.h
  • NvAPI_D3D11_ExecuteMetaCommand() : nvapi.h
  • NvAPI_D3D11_GetCudaTextureObject() : nvapi.h
  • NvAPI_D3D11_GetResourceGPUVirtualAddress() : nvapi.h
  • NvAPI_D3D11_GetResourceGPUVirtualAddressEx() : nvapi.h
  • NvAPI_D3D11_GetResourceHandle() : nvapi.h
  • NvAPI_D3D11_InitializeMetaCommand() : nvapi.h
  • NvAPI_D3D11_IsFatbinPTXSupported() : nvapi.h
  • NvAPI_D3D11_IsNvShaderExtnOpCodeSupported() : nvapi.h
  • NvAPI_D3D11_LaunchCubinShader() : nvapi.h
  • NvAPI_D3D11_MultiDrawIndexedInstancedIndirect() : nvapi.h
  • NvAPI_D3D11_MultiDrawInstancedIndirect() : nvapi.h
  • NvAPI_D3D11_MultiGPU_GetCaps() : nvapi.h
  • NvAPI_D3D11_MultiGPU_Init() : nvapi.h
  • NvAPI_D3D11_ResolveSubresourceRegion() : nvapi.h
  • NvAPI_D3D11_RSGetPixelShadingRateSampleOrder() : nvapi.h
  • NvAPI_D3D11_RSSetExclusiveScissorRects() : nvapi.h
  • NvAPI_D3D11_RSSetPixelShadingRateSampleOrder() : nvapi.h
  • NvAPI_D3D11_RSSetShadingRateResourceView() : nvapi.h
  • NvAPI_D3D11_RSSetViewportsPixelShadingRates() : nvapi.h
  • NvAPI_D3D11_SetDepthBoundsTest() : nvapi_lite_d3dext.h
  • NvAPI_D3D11_SetNvShaderExtnSlot() : nvapi.h
  • NvAPI_D3D11_SetNvShaderExtnSlotLocalThread() : nvapi.h
  • NvAPI_D3D12_BuildRaytracingAccelerationStructureEx() : nvapi.h
  • NvAPI_D3D12_BuildRaytracingDisplacementMicromapArray() : nvapi.h
  • NvAPI_D3D12_BuildRaytracingOpacityMicromapArray() : nvapi.h
  • NvAPI_D3D12_CaptureUAVInfo() : nvapi.h
  • NvAPI_D3D12_CheckDriverMatchingIdentifierEx() : nvapi.h
  • NvAPI_D3D12_CopyTextureRegion() : nvapi.h
  • NvAPI_D3D12_CopyTileMappings() : nvapi.h
  • NvAPI_D3D12_CreateCommittedImplicitMSAATexture2D() : nvapi.h
  • NvAPI_D3D12_CreateCommittedRDMABuffer() : nvapi.h
  • NvAPI_D3D12_CreateCommittedResource() : nvapi.h
  • NvAPI_D3D12_CreateComputePipelineState() : nvapi.h
  • NvAPI_D3D12_CreateCubinComputeShader() : nvapi.h
  • NvAPI_D3D12_CreateCubinComputeShaderEx() : nvapi.h
  • NvAPI_D3D12_CreateCubinComputeShaderExV2() : nvapi.h
  • NvAPI_D3D12_CreateCubinComputeShaderWithName() : nvapi.h
  • NvAPI_D3D12_CreateCuFunction() : nvapi.h
  • NvAPI_D3D12_CreateCuModule() : nvapi.h
  • NvAPI_D3D12_CreateDDisplayPresentBarrierClient() : nvapi.h
  • NvAPI_D3D12_CreateGraphicsPipelineState() : nvapi.h
  • NvAPI_D3D12_CreateHeap() : nvapi.h
  • NvAPI_D3D12_CreateHeap2() : nvapi.h
  • NvAPI_D3D12_CreateMetaCommand() : nvapi.h
  • NvAPI_D3D12_CreatePresentBarrierClient() : nvapi.h
  • NvAPI_D3D12_CreateReservedResource() : nvapi.h
  • NvAPI_D3D12_DestroyCubinComputeShader() : nvapi.h
  • NvAPI_D3D12_DestroyCuFunction() : nvapi.h
  • NvAPI_D3D12_DestroyCuModule() : nvapi.h
  • NvAPI_D3D12_EmitRaytracingDisplacementMicromapArrayPostbuildInfo() : nvapi.h
  • NvAPI_D3D12_EmitRaytracingOpacityMicromapArrayPostbuildInfo() : nvapi.h
  • NvAPI_D3D12_EnableRaytracingValidation() : nvapi.h
  • NvAPI_D3D12_EnumerateMetaCommands() : nvapi.h
  • NvAPI_D3D12_EnumFunctionsInModule() : nvapi.h
  • NvAPI_D3D12_ExecuteMetaCommand() : nvapi.h
  • NvAPI_D3D12_FlushRaytracingValidationMessages() : nvapi.h
  • NvAPI_D3D12_GetCopyableFootprints() : nvapi.h
  • NvAPI_D3D12_GetCudaIndependentDescriptorObject() : nvapi.h
  • NvAPI_D3D12_GetCudaMergedTextureSamplerObject() : nvapi.h
  • NvAPI_D3D12_GetCudaSurfaceObject() : nvapi.h
  • NvAPI_D3D12_GetCudaTextureObject() : nvapi.h
  • NvAPI_D3D12_GetGraphicsCapabilities() : nvapi.h
  • NvAPI_D3D12_GetNeedsAppFPBlendClamping() : nvapi.h
  • NvAPI_D3D12_GetOptimalThreadCountForMesh() : nvapi.h
  • NvAPI_D3D12_GetRaytracingAccelerationStructurePrebuildInfoEx() : nvapi.h
  • NvAPI_D3D12_GetRaytracingCaps() : nvapi.h
  • NvAPI_D3D12_GetRaytracingDisplacementMicromapArrayPrebuildInfo() : nvapi.h
  • NvAPI_D3D12_GetRaytracingOpacityMicromapArrayPrebuildInfo() : nvapi.h
  • NvAPI_D3D12_InitializeMetaCommand() : nvapi.h
  • NvAPI_D3D12_IsFatbinPTXSupported() : nvapi.h
  • NvAPI_D3D12_IsNvShaderExtnOpCodeSupported() : nvapi.h
  • NvAPI_D3D12_LaunchCubinShader() : nvapi.h
  • NvAPI_D3D12_LaunchCuKernelChain() : nvapi.h
  • NvAPI_D3D12_LaunchCuKernelChainEx() : nvapi.h
  • NvAPI_D3D12_Mosaic_GetCompanionAllocations() : nvapi.h
  • NvAPI_D3D12_Mosaic_GetViewportAndGpuPartitions() : nvapi.h
  • NvAPI_D3D12_NotifyOutOfBandCommandQueue() : nvapi.h
  • NvAPI_D3D12_QueryCpuVisibleVidmem() : nvapi.h
  • NvAPI_D3D12_QueryModifiedWSupport() : nvapi.h
  • NvAPI_D3D12_QueryPresentBarrierSupport() : nvapi.h
  • NvAPI_D3D12_QuerySinglePassStereoSupport() : nvapi.h
  • NvAPI_D3D12_QueryWorkstationFeatureProperties() : nvapi.h
  • NvAPI_D3D12_RegisterPresentBarrierResources() : nvapi.h
  • NvAPI_D3D12_RegisterRaytracingValidationMessageCallback() : nvapi.h
  • NvAPI_D3D12_RelocateRaytracingDisplacementMicromapArray() : nvapi.h
  • NvAPI_D3D12_RelocateRaytracingOpacityMicromapArray() : nvapi.h
  • NvAPI_D3D12_ReservedResourceGetDesc() : nvapi.h
  • NvAPI_D3D12_ResolveSubresourceRegion() : nvapi.h
  • NvAPI_D3D12_ResourceAliasingBarrier() : nvapi.h
  • NvAPI_D3D12_SetAsyncFrameMarker() : nvapi.h
  • NvAPI_D3D12_SetCreateCommandQueueLowLatencyHint() : nvapi.h
  • NvAPI_D3D12_SetCreatePipelineStateOptions() : nvapi.h
  • NvAPI_D3D12_SetDepthBoundsTestValues() : nvapi.h
  • NvAPI_D3D12_SetModifiedWMode() : nvapi.h
  • NvAPI_D3D12_SetNvShaderExtnSlotSpace() : nvapi.h
  • NvAPI_D3D12_SetNvShaderExtnSlotSpaceLocalThread() : nvapi.h
  • NvAPI_D3D12_SetSinglePassStereoMode() : nvapi.h
  • NvAPI_D3D12_UnregisterRaytracingValidationMessageCallback() : nvapi.h
  • NvAPI_D3D12_UpdateTileMappings() : nvapi.h
  • NvAPI_D3D12_UseDriverHeapPriorities() : nvapi.h
  • NvAPI_D3D1x_BindSwapBarrier() : nvapi.h
  • NvAPI_D3D1x_CreateSwapChain() : nvapi.h
  • NvAPI_D3D1x_DisableShaderDiskCache() : nvapi.h
  • NvAPI_D3D1x_GetGraphicsCapabilities() : nvapi.h
  • NvAPI_D3D1x_JoinSwapGroup() : nvapi.h
  • NvAPI_D3D1x_Present() : nvapi.h
  • NvAPI_D3D1x_QueryFrameCount() : nvapi.h
  • NvAPI_D3D1x_QueryMaxSwapGroup() : nvapi.h
  • NvAPI_D3D1x_QuerySwapGroup() : nvapi.h
  • NvAPI_D3D1x_ResetFrameCount() : nvapi.h
  • NvAPI_D3D9_AliasSurfaceAsTexture() : nvapi.h
  • NvAPI_D3D9_BindSwapBarrier() : nvapi.h
  • NvAPI_D3D9_ClearRT() : nvapi.h
  • NvAPI_D3D9_CreateSwapChain() : nvapi.h
  • NvAPI_D3D9_GetSurfaceHandle() : nvapi.h
  • NvAPI_D3D9_JoinSwapGroup() : nvapi.h
  • NvAPI_D3D9_Present() : nvapi.h
  • NvAPI_D3D9_QueryFrameCount() : nvapi.h
  • NvAPI_D3D9_QueryMaxSwapGroup() : nvapi.h
  • NvAPI_D3D9_QuerySwapGroup() : nvapi.h
  • NvAPI_D3D9_RegisterResource() : nvapi.h
  • NvAPI_D3D9_ResetFrameCount() : nvapi.h
  • NvAPI_D3D9_StretchRectEx() : nvapi.h
  • NvAPI_D3D9_UnregisterResource() : nvapi.h
  • NvAPI_D3D9_VideoSetStereoInfo() : nvapi.h
  • NvAPI_D3D_BeginResourceRendering() : nvapi_lite_sli.h
  • NvAPI_D3D_ConfigureAnsel() : nvapi.h
  • NvAPI_D3D_CreateLateLatchObject() : nvapi.h
  • NvAPI_D3D_EndResourceRendering() : nvapi_lite_sli.h
  • NvAPI_D3D_GetCurrentSLIState() : nvapi_lite_sli.h
  • NvAPI_D3D_GetLatency() : nvapi.h
  • NvAPI_D3D_GetObjectHandleForResource() : nvapi_lite_common.h
  • NvAPI_D3D_GetSleepStatus() : nvapi.h
  • NvAPI_D3D_ImplicitSLIControl() : nvapi.h
  • NvAPI_D3D_InitializeNvGazeHandler() : nvapi.h
  • NvAPI_D3D_InitializeSMPAssist() : nvapi.h
  • NvAPI_D3D_InitializeVRSHelper() : nvapi.h
  • NvAPI_D3D_IsGSyncActive() : nvapi.h
  • NvAPI_D3D_IsGSyncCapable() : nvapi.h
  • NvAPI_D3D_QueryLateLatchSupport() : nvapi.h
  • NvAPI_D3D_QueryModifiedWSupport() : nvapi.h
  • NvAPI_D3D_QueryMultiViewSupport() : nvapi.h
  • NvAPI_D3D_QuerySinglePassStereoSupport() : nvapi.h
  • NvAPI_D3D_QuerySMPAssistSupport() : nvapi.h
  • NvAPI_D3D_RegisterDevice() : nvapi.h
  • NvAPI_D3D_SetFPSIndicatorState() : nvapi.h
  • NvAPI_D3D_SetLatencyMarker() : nvapi.h
  • NvAPI_D3D_SetModifiedWMode() : nvapi.h
  • NvAPI_D3D_SetMultiViewMode() : nvapi.h
  • NvAPI_D3D_SetReflexSync() : nvapi.h
  • NvAPI_D3D_SetResourceHint() : nvapi_lite_sli.h
  • NvAPI_D3D_SetSinglePassStereoMode() : nvapi.h
  • NvAPI_D3D_SetSleepMode() : nvapi.h
  • NvAPI_D3D_SetVerticalSyncMode() : nvapi.h
  • NvAPI_D3D_Sleep() : nvapi.h
  • NvAPI_DestroyPresentBarrierClient() : nvapi.h
  • NvAPI_DirectD3D12GraphicsCommandList_Create() : nvapi.h
  • NvAPI_DirectD3D12GraphicsCommandList_Release() : nvapi.h
  • NvAPI_DirectD3D12GraphicsCommandList_Reset() : nvapi.h
  • NvAPI_DisableHWCursor() : nvapi.h
  • NvAPI_DISP_AcquireDedicatedDisplay() : nvapi.h
  • NvAPI_Disp_ColorControl() : nvapi.h
  • NvAPI_DISP_DeleteCustomDisplay() : nvapi.h
  • NvAPI_DISP_EnumCustomDisplay() : nvapi.h
  • NvAPI_DISP_GetAdaptiveSyncData() : nvapi.h
  • NvAPI_DISP_GetAssociatedUnAttachedNvidiaDisplayHandle() : nvapi.h
  • NvAPI_DISP_GetDisplayConfig() : nvapi.h
  • NvAPI_DISP_GetDisplayIdByDisplayName() : nvapi.h
  • NvAPI_DISP_GetEdidData() : nvapi.h
  • NvAPI_DISP_GetGDIPrimaryDisplayId() : nvapi_lite_surround.h
  • NvAPI_Disp_GetHdrCapabilities() : nvapi.h
  • NvAPI_Disp_GetHdrToneMapping() : nvapi.h
  • NvAPI_DISP_GetMonitorCapabilities() : nvapi.h
  • NvAPI_DISP_GetMonitorColorCapabilities() : nvapi.h
  • NvAPI_DISP_GetNvManagedDedicatedDisplayMetadata() : nvapi.h
  • NvAPI_DISP_GetNvManagedDedicatedDisplays() : nvapi.h
  • NvAPI_Disp_GetOutputMode() : nvapi.h
  • NvAPI_DISP_GetPreferredStereoDisplay() : nvapi.h
  • NvAPI_Disp_GetSourceColorSpace() : nvapi.h
  • NvAPI_Disp_GetSourceHdrMetadata() : nvapi.h
  • NvAPI_DISP_GetTiming() : nvapi.h
  • NvAPI_DISP_GetVirtualRefreshRateData() : nvapi.h
  • NvAPI_Disp_GetVRRInfo() : nvapi.h
  • NvAPI_Disp_HdrColorControl() : nvapi.h
  • NvAPI_Disp_InfoFrameControl() : nvapi.h
  • NvAPI_DISP_ReleaseDedicatedDisplay() : nvapi.h
  • NvAPI_DISP_RevertCustomDisplayTrial() : nvapi.h
  • NvAPI_DISP_SaveCustomDisplay() : nvapi.h
  • NvAPI_DISP_SetAdaptiveSyncData() : nvapi.h
  • NvAPI_DISP_SetDisplayConfig() : nvapi.h
  • NvAPI_Disp_SetHdrToneMapping() : nvapi.h
  • NvAPI_DISP_SetNvManagedDedicatedDisplayMetadata() : nvapi.h
  • NvAPI_Disp_SetOutputMode() : nvapi.h
  • NvAPI_DISP_SetPreferredStereoDisplay() : nvapi.h
  • NvAPI_Disp_SetSourceColorSpace() : nvapi.h
  • NvAPI_Disp_SetSourceHdrMetadata() : nvapi.h
  • NvAPI_DISP_SetVirtualRefreshRateData() : nvapi.h
  • NvAPI_DISP_TryCustomDisplay() : nvapi.h
  • NvAPI_DRS_CreateApplication() : nvapi.h
  • NvAPI_DRS_CreateProfile() : nvapi.h
  • NvAPI_DRS_CreateSession() : nvapi.h
  • NvAPI_DRS_DeleteApplication() : nvapi.h
  • NvAPI_DRS_DeleteApplicationEx() : nvapi.h
  • NvAPI_DRS_DeleteProfile() : nvapi.h
  • NvAPI_DRS_DeleteProfileSetting() : nvapi.h
  • NvAPI_DRS_DestroySession() : nvapi.h
  • NvAPI_DRS_EnumApplications() : nvapi.h
  • NvAPI_DRS_EnumAvailableSettingIds() : nvapi.h
  • NvAPI_DRS_EnumAvailableSettingValues() : nvapi.h
  • NvAPI_DRS_EnumProfiles() : nvapi.h
  • NvAPI_DRS_EnumSettings() : nvapi.h
  • NvAPI_DRS_FindApplicationByName() : nvapi.h
  • NvAPI_DRS_FindProfileByName() : nvapi.h
  • NvAPI_DRS_GetApplicationInfo() : nvapi.h
  • NvAPI_DRS_GetBaseProfile() : nvapi.h
  • NvAPI_DRS_GetCurrentGlobalProfile() : nvapi.h
  • NvAPI_DRS_GetNumProfiles() : nvapi.h
  • NvAPI_DRS_GetProfileInfo() : nvapi.h
  • NvAPI_DRS_GetSetting() : nvapi.h
  • NvAPI_DRS_GetSettingIdFromName() : nvapi.h
  • NvAPI_DRS_GetSettingNameFromId() : nvapi.h
  • NvAPI_DRS_LoadSettings() : nvapi.h
  • NvAPI_DRS_LoadSettingsFromFile() : nvapi.h
  • NvAPI_DRS_RestoreAllDefaults() : nvapi.h
  • NvAPI_DRS_RestoreProfileDefault() : nvapi.h
  • NvAPI_DRS_RestoreProfileDefaultSetting() : nvapi.h
  • NvAPI_DRS_SaveSettings() : nvapi.h
  • NvAPI_DRS_SaveSettingsToFile() : nvapi.h
  • NvAPI_DRS_SetCurrentGlobalProfile() : nvapi.h
  • NvAPI_DRS_SetProfileInfo() : nvapi.h
  • NvAPI_DRS_SetSetting() : nvapi.h
  • NvAPI_EnableCurrentMosaicTopology() : nvapi.h
  • NvAPI_EnableHWCursor() : nvapi.h
  • NvAPI_EnumLogicalGPUs() : nvapi.h
  • NvAPI_EnumNvidiaDisplayHandle() : nvapi.h
  • NvAPI_EnumNvidiaUnAttachedDisplayHandle() : nvapi.h
  • NvAPI_EnumPhysicalGPUs() : nvapi_lite_common.h
  • NvAPI_EnumTCCPhysicalGPUs() : nvapi.h
  • NvAPI_Event_RegisterCallback() : nvapi.h
  • NvAPI_Event_UnregisterCallback() : nvapi.h
  • NvAPI_GetAssociatedDisplayOutputId() : nvapi.h
  • NvAPI_GetAssociatedNvidiaDisplayHandle() : nvapi.h
  • NvAPI_GetAssociatedNvidiaDisplayName() : nvapi.h
  • NvAPI_GetCurrentMosaicTopology() : nvapi.h
  • NvAPI_GetDisplayPortInfo() : nvapi.h
  • NvAPI_GetErrorMessage() : nvapi.h
  • NvAPI_GetGPUIDfromPhysicalGPU() : nvapi.h
  • NvAPI_GetHDMISupportInfo() : nvapi.h
  • NvAPI_GetInterfaceVersionString() : nvapi.h
  • NvAPI_GetInterfaceVersionStringEx() : nvapi.h
  • NvAPI_GetLogicalGPUFromDisplay() : nvapi.h
  • NvAPI_GetLogicalGPUFromPhysicalGPU() : nvapi.h
  • NvAPI_GetPhysicalGPUFromGPUID() : nvapi.h
  • NvAPI_GetPhysicalGPUFromUnAttachedDisplay() : nvapi.h
  • NvAPI_GetPhysicalGPUsFromDisplay() : nvapi.h
  • NvAPI_GetPhysicalGPUsFromLogicalGPU() : nvapi.h
  • NvAPI_GetSupportedMosaicTopologies() : nvapi.h
  • NvAPI_GetSupportedViews() : nvapi.h
  • NvAPI_GetUnAttachedAssociatedDisplayName() : nvapi.h
  • NvAPI_GetVBlankCounter() : nvapi.h
  • NvAPI_GPU_ClientIllumDevicesGetControl() : nvapi.h
  • NvAPI_GPU_ClientIllumDevicesGetInfo() : nvapi.h
  • NvAPI_GPU_ClientIllumDevicesSetControl() : nvapi.h
  • NvAPI_GPU_ClientIllumZonesGetControl() : nvapi.h
  • NvAPI_GPU_ClientIllumZonesGetInfo() : nvapi.h
  • NvAPI_GPU_ClientIllumZonesSetControl() : nvapi.h
  • NvAPI_GPU_ClientRegisterForUtilizationSampleUpdates() : nvapi.h
  • NvAPI_GPU_GetActiveOutputs() : nvapi.h
  • NvAPI_GPU_GetAllClockFrequencies() : nvapi.h
  • NvAPI_GPU_GetAllDisplayIds() : nvapi.h
  • NvAPI_GPU_GetArchInfo() : nvapi.h
  • NvAPI_GPU_GetBoardInfo() : nvapi.h
  • NvAPI_GPU_GetBusId() : nvapi.h
  • NvAPI_GPU_GetBusSlotId() : nvapi.h
  • NvAPI_GPU_GetBusType() : nvapi.h
  • NvAPI_GPU_GetConnectedDisplayIds() : nvapi.h
  • NvAPI_GPU_GetCurrentPCIEDownstreamWidth() : nvapi.h
  • NvAPI_GPU_GetCurrentPstate() : nvapi.h
  • NvAPI_GPU_GetDynamicPstatesInfoEx() : nvapi.h
  • NvAPI_GPU_GetECCConfigurationInfo() : nvapi.h
  • NvAPI_GPU_GetECCErrorInfo() : nvapi.h
  • NvAPI_GPU_GetECCStatusInfo() : nvapi.h
  • NvAPI_GPU_GetEDID() : nvapi.h
  • NvAPI_GPU_GetFullName() : nvapi.h
  • NvAPI_GPU_GetGpuCoreCount() : nvapi.h
  • NvAPI_GPU_GetGPUInfo() : nvapi.h
  • NvAPI_GPU_GetGPUType() : nvapi.h
  • NvAPI_GPU_GetGspFeatures() : nvapi.h
  • NvAPI_GPU_GetHDCPSupportStatus() : nvapi.h
  • NvAPI_GPU_GetIllumination() : nvapi.h
  • NvAPI_GPU_GetIRQ() : nvapi.h
  • NvAPI_GPU_GetLicensableFeatures() : nvapi.h
  • NvAPI_GPU_GetLogicalGpuInfo() : nvapi.h
  • NvAPI_GPU_GetMemoryInfoEx() : nvapi_lite_common.h
  • NvAPI_GPU_GetOutputType() : nvapi.h
  • NvAPI_GPU_GetPCIIdentifiers() : nvapi.h
  • NvAPI_GPU_GetPerfDecreaseInfo() : nvapi.h
  • NvAPI_GPU_GetPhysicalFrameBufferSize() : nvapi.h
  • NvAPI_GPU_GetPstates20() : nvapi.h
  • NvAPI_GPU_GetRamBusWidth() : nvapi.h
  • NvAPI_GPU_GetScanoutCompositionParameter() : nvapi.h
  • NvAPI_GPU_GetScanoutConfiguration() : nvapi.h
  • NvAPI_GPU_GetScanoutConfigurationEx() : nvapi.h
  • NvAPI_GPU_GetScanoutIntensityState() : nvapi.h
  • NvAPI_GPU_GetScanoutWarpingState() : nvapi.h
  • NvAPI_GPU_GetShaderSubPipeCount() : nvapi.h
  • NvAPI_GPU_GetSystemType() : nvapi.h
  • NvAPI_GPU_GetTachReading() : nvapi.h
  • NvAPI_GPU_GetThermalSettings() : nvapi.h
  • NvAPI_GPU_GetVbiosOEMRevision() : nvapi.h
  • NvAPI_GPU_GetVbiosRevision() : nvapi.h
  • NvAPI_GPU_GetVbiosVersionString() : nvapi.h
  • NvAPI_GPU_GetVirtualFrameBufferSize() : nvapi.h
  • NvAPI_GPU_GetVirtualizationInfo() : nvapi.h
  • NvAPI_GPU_GetVRReadyData() : nvapi.h
  • NvAPI_GPU_NVLINK_GetCaps() : nvapi.h
  • NvAPI_GPU_NVLINK_GetStatus() : nvapi.h
  • NvAPI_GPU_QueryIlluminationSupport() : nvapi.h
  • NvAPI_GPU_QueryWorkstationFeatureSupport() : nvapi.h
  • NvAPI_GPU_ResetECCErrorInfo() : nvapi.h
  • NvAPI_GPU_SetECCConfiguration() : nvapi.h
  • NvAPI_GPU_SetEDID() : nvapi.h
  • NvAPI_GPU_SetIllumination() : nvapi.h
  • NvAPI_GPU_SetScanoutCompositionParameter() : nvapi.h
  • NvAPI_GPU_SetScanoutIntensity() : nvapi.h
  • NvAPI_GPU_SetScanoutWarping() : nvapi.h
  • NvAPI_GPU_ValidateOutputCombination() : nvapi.h
  • NvAPI_GPU_WorkstationFeatureQuery() : nvapi.h
  • NvAPI_GPU_WorkstationFeatureSetup() : nvapi.h
  • NvAPI_GSync_AdjustSyncDelay() : nvapi.h
  • NvAPI_GSync_EnumSyncDevices() : nvapi.h
  • NvAPI_GSync_GetControlParameters() : nvapi.h
  • NvAPI_GSync_GetStatusParameters() : nvapi.h
  • NvAPI_GSync_GetSyncStatus() : nvapi.h
  • NvAPI_GSync_GetTopology() : nvapi.h
  • NvAPI_GSync_QueryCapabilities() : nvapi.h
  • NvAPI_GSync_SetControlParameters() : nvapi.h
  • NvAPI_GSync_SetSyncStateSettings() : nvapi.h
  • NvAPI_I2CRead() : nvapi.h
  • NvAPI_I2CWrite() : nvapi.h
  • NvAPI_Initialize() : nvapi.h
  • NvAPI_JoinPresentBarrier() : nvapi.h
  • NvAPI_LeavePresentBarrier() : nvapi.h
  • NvAPI_Mosaic_EnableCurrentTopo() : nvapi.h
  • NvAPI_Mosaic_EnumDisplayGrids() : nvapi.h
  • NvAPI_Mosaic_EnumDisplayModes() : nvapi.h
  • NvAPI_Mosaic_GetCurrentTopo() : nvapi.h
  • NvAPI_Mosaic_GetDisplayViewportsByResolution() : nvapi_lite_surround.h
  • NvAPI_Mosaic_GetOverlapLimits() : nvapi.h
  • NvAPI_Mosaic_GetSupportedTopoInfo() : nvapi.h
  • NvAPI_Mosaic_GetTopoGroup() : nvapi.h
  • NvAPI_Mosaic_SetCurrentTopo() : nvapi.h
  • NvAPI_Mosaic_SetDisplayGrids() : nvapi.h
  • NvAPI_Mosaic_ValidateDisplayGrids() : nvapi.h
  • NvAPI_OGL_ExpertModeDefaultsGet() : nvapi.h
  • NvAPI_OGL_ExpertModeDefaultsSet() : nvapi.h
  • NvAPI_OGL_ExpertModeGet() : nvapi.h
  • NvAPI_OGL_ExpertModeSet() : nvapi.h
  • NvAPI_QueryPresentBarrierFrameStatistics() : nvapi.h
  • NvAPI_SetCurrentMosaicTopology() : nvapi.h
  • NvAPI_SetDisplayPort() : nvapi.h
  • NvAPI_SetRefreshRateOverride() : nvapi.h
  • NvAPI_Stereo_Activate() : nvapi_lite_stereo.h
  • NvAPI_Stereo_CaptureJpegImage() : nvapi.h
  • NvAPI_Stereo_CapturePngImage() : nvapi.h
  • NvAPI_Stereo_CreateConfigurationProfileRegistryKey() : nvapi.h
  • NvAPI_Stereo_CreateHandleFromIUnknown() : nvapi_lite_stereo.h
  • NvAPI_Stereo_Deactivate() : nvapi_lite_stereo.h
  • NvAPI_Stereo_Debug_WasLastDrawStereoized() : nvapi_lite_stereo.h
  • NvAPI_Stereo_DecreaseConvergence() : nvapi.h
  • NvAPI_Stereo_DecreaseSeparation() : nvapi.h
  • NvAPI_Stereo_DeleteConfigurationProfileRegistryKey() : nvapi.h
  • NvAPI_Stereo_DeleteConfigurationProfileValue() : nvapi.h
  • NvAPI_Stereo_DestroyHandle() : nvapi_lite_stereo.h
  • NvAPI_Stereo_Disable() : nvapi_lite_stereo.h
  • NvAPI_Stereo_Enable() : nvapi_lite_stereo.h
  • NvAPI_Stereo_GetConvergence() : nvapi_lite_stereo.h
  • NvAPI_Stereo_GetDefaultProfile() : nvapi_lite_stereo.h
  • NvAPI_Stereo_GetEyeSeparation() : nvapi_lite_stereo.h
  • NvAPI_Stereo_GetFrustumAdjustMode() : nvapi.h
  • NvAPI_Stereo_GetSeparation() : nvapi_lite_stereo.h
  • NvAPI_Stereo_GetStereoSupport() : nvapi.h
  • NvAPI_Stereo_GetSurfaceCreationMode() : nvapi_lite_stereo.h
  • NvAPI_Stereo_IncreaseConvergence() : nvapi.h
  • NvAPI_Stereo_IncreaseSeparation() : nvapi.h
  • NvAPI_Stereo_InitActivation() : nvapi.h
  • NvAPI_Stereo_IsActivated() : nvapi_lite_stereo.h
  • NvAPI_Stereo_IsEnabled() : nvapi_lite_stereo.h
  • NvAPI_Stereo_IsWindowedModeSupported() : nvapi_lite_stereo.h
  • NvAPI_Stereo_ReverseStereoBlitControl() : nvapi.h
  • NvAPI_Stereo_SetActiveEye() : nvapi_lite_stereo.h
  • NvAPI_Stereo_SetConfigurationProfileValue() : nvapi.h
  • NvAPI_Stereo_SetConvergence() : nvapi_lite_stereo.h
  • NvAPI_Stereo_SetDefaultProfile() : nvapi_lite_stereo.h
  • NvAPI_Stereo_SetDriverMode() : nvapi_lite_stereo.h
  • NvAPI_Stereo_SetFrustumAdjustMode() : nvapi.h
  • NvAPI_Stereo_SetNotificationMessage() : nvapi.h
  • NvAPI_Stereo_SetSeparation() : nvapi_lite_stereo.h
  • NvAPI_Stereo_SetSurfaceCreationMode() : nvapi_lite_stereo.h
  • NvAPI_Stereo_Trigger_Activation() : nvapi.h
  • NvAPI_SYS_GetChipSetInfo() : nvapi.h
  • NvAPI_SYS_GetDisplayDriverInfo() : nvapi.h
  • NvAPI_SYS_GetDisplayIdFromGpuAndOutputId() : nvapi.h
  • NvAPI_SYS_GetDriverAndBranchVersion() : nvapi_lite_common.h
  • NvAPI_SYS_GetGpuAndOutputIdFromDisplayId() : nvapi.h
  • NvAPI_SYS_GetLidAndDockInfo() : nvapi.h
  • NvAPI_SYS_GetLogicalGPUs() : nvapi.h
  • NvAPI_SYS_GetPhysicalGpuFromDisplayId() : nvapi.h
  • NvAPI_SYS_GetPhysicalGPUs() : nvapi.h
  • NvAPI_Unload() : nvapi.h
  • NvBallot() : nvHLSLExtns.h
  • NvEvaluateAttributeAtSampleForVPRS() : nvHLSLExtns.h
  • NvEvaluateAttributeSnappedForVPRS() : nvHLSLExtns.h
  • NvFootprintCoarse() : nvHLSLExtns.h
  • NvFootprintCoarseBias() : nvHLSLExtns.h
  • NvFootprintCoarseGrad() : nvHLSLExtns.h
  • NvFootprintCoarseLevel() : nvHLSLExtns.h
  • NvFootprintExtractAnchorTileLoc2D() : nvHLSLExtns.h
  • NvFootprintExtractAnchorTileLoc3D() : nvHLSLExtns.h
  • NvFootprintExtractBitmask() : nvHLSLExtns.h
  • NvFootprintExtractLOD() : nvHLSLExtns.h
  • NvFootprintExtractOffset2D() : nvHLSLExtns.h
  • NvFootprintExtractOffset3D() : nvHLSLExtns.h
  • NvFootprintExtractReturnGran() : nvHLSLExtns.h
  • NvFootprintFine() : nvHLSLExtns.h
  • NvFootprintFineBias() : nvHLSLExtns.h
  • NvFootprintFineGrad() : nvHLSLExtns.h
  • NvFootprintFineLevel() : nvHLSLExtns.h
  • NvGetLaneId() : nvHLSLExtns.h
  • NvGetShadingRate() : nvHLSLExtns.h
  • NvGetSpecial() : nvHLSLExtns.h
  • NvInterlockedAddFp16x2() : nvHLSLExtns.h
  • NvInterlockedAddFp16x4() : nvHLSLExtns.h
  • NvInterlockedAddFp32() : nvHLSLExtns.h
  • NvInterlockedAddUint64() : nvHLSLExtns.h
  • NvInterlockedAndUint64() : nvHLSLExtns.h
  • NvInterlockedCompareExchangeUint64() : nvHLSLExtns.h
  • NvInterlockedExchangeUint64() : nvHLSLExtns.h
  • NvInterlockedMaxFp16x2() : nvHLSLExtns.h
  • NvInterlockedMaxFp16x4() : nvHLSLExtns.h
  • NvInterlockedMaxUint64() : nvHLSLExtns.h
  • NvInterlockedMinFp16x2() : nvHLSLExtns.h
  • NvInterlockedMinFp16x4() : nvHLSLExtns.h
  • NvInterlockedMinUint64() : nvHLSLExtns.h
  • NvInterlockedOrUint64() : nvHLSLExtns.h
  • NvInterlockedXorUint64() : nvHLSLExtns.h
  • NvRtIsBackFacing() : nvHLSLExtns.h
  • NvRtIsMicroTriangleHit() : nvHLSLExtns.h
  • NvRtMicroTriangleBarycentrics() : nvHLSLExtns.h
  • NvRtMicroTriangleObjectPositions() : nvHLSLExtns.h
  • NvRtTriangleObjectPositions() : nvHLSLExtns.h
  • NvShfl() : nvHLSLExtns.h
  • NvShflDown() : nvHLSLExtns.h
  • NvShflUp() : nvHLSLExtns.h
  • NvShflXor() : nvHLSLExtns.h
  • NvWaveMatch() : nvHLSLExtns.h
  • NvWaveMultiPrefixExclusiveAdd() : nvHLSLExtns.h
  • NvWaveMultiPrefixExclusiveAnd() : nvHLSLExtns.h
  • NvWaveMultiPrefixExclusiveOr() : nvHLSLExtns.h
  • NvWaveMultiPrefixExclusiveXOr() : nvHLSLExtns.h
  • NvWaveMultiPrefixInclusiveAdd() : nvHLSLExtns.h
  • NvWaveMultiPrefixInclusiveAnd() : nvHLSLExtns.h
  • NvWaveMultiPrefixInclusiveOr() : nvHLSLExtns.h
  • NvWaveMultiPrefixInclusiveXOr() : nvHLSLExtns.h


  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • b
  • d
  • e
  • g
  • i
  • o
  • p
  • s
  • t
  • v
Here is a list of all variables with links to the files they belong to:

- _ -

  • __cplusplus : defines.txt
  • __d3d10_1_h__ : defines.txt
  • __d3d10_h__ : defines.txt
  • __d3d11_h__ : defines.txt
  • _D3D9_H_ : defines.txt

- b -

  • bRelease : nvapi.h

- d -

  • destEnumIndex : nvapi.h
  • displayView : nvapi.h

- e -

  • enumIndex : nvapi.h

- g -

  • g_NvidiaExt : nvHLSLExtnsInternal.h

- i -

  • inputFlags : nvapi.h

- o -

  • ownerType : nvapi.h

- p -

  • pAdapterCaps : nvapi.h
  • pbCompatible : nvapi.h
  • pConfig : nvapi.h
  • pCSC : nvapi.h
  • pDataFormatDetail : nvapi.h
  • pGamma : nvapi.h
  • pMemoryInfo : nvapi_lite_common.h
  • pOSAdapterId : nvapi.h
  • pOutputsMask : nvapi.h
  • pPathCount : nvapi.h
  • pPathInfo : nvapi.h
  • pPerfPstatesInfo : nvapi.h
  • pRate : nvapi.h
  • pSignalFormatDetail : nvapi.h
  • pSize : nvapi.h
  • pStatus : nvapi.h
  • pSyncDelay : nvapi.h
  • pTargetInfo : nvapi.h
  • pTargetMaskCount : nvapi.h
  • pTargets : nvapi.h
  • pTargetView : nvapi.h
  • pTargetViewMode : nvapi.h
  • pVersion : nvapi.h
  • pVioPCIInfo : nvapi.h
  • pWait : nvapi.h

- s -

  • srcEnumIndex : nvapi.h

- t -

  • targetView : nvapi.h

- v -

  • vioClass : nvapi.h
  • vioDeviceCount : nvapi.h


  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • i
  • n
  • p
  • s
  • t
Here is a list of all typedefs with links to the files they belong to:

- i -

  • ID3D11MultiGPUDevice : nvapi.h
  • ID3D11NvMetaCommand : nvapi.h
  • ID3D11NvShadingRateResourceView : nvapi.h
  • ID3D12NvMetaCommand : nvapi.h
  • ID3DLateLatchObject : nvapi.h
  • ID3DNvGazeHandler : nvapi.h
  • ID3DNvSMPAssist : nvapi.h
  • ID3DNvVRSHelper : nvapi.h
  • IMPLICIT_SLI_CONTROL : nvapi.h


  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • i
  • n
  • p
  • s
  • t
Here is a list of all typedefs with links to the files they belong to:

- n -

  • NV_ADAPTER_TYPE : nvapi.h
  • NV_ASYNC_FRAME_MARKER_PARAMS : nvapi.h
  • NV_ASYNC_FRAME_MARKER_PARAMS_V1 : nvapi.h
  • NV_BOARD_INFO : nvapi.h
  • NV_BOARD_INFO_V1 : nvapi.h
  • NV_BPC : nvapi.h
  • NV_CLIENT_CALLBACK_SETTINGS_SUPER_V1 : nvapi.h
  • NV_COLOR_DATA : nvapi.h
  • NV_COLOR_DATA_V1 : nvapi.h
  • NV_COLOR_DATA_V2 : nvapi.h
  • NV_COLOR_DATA_V3 : nvapi.h
  • NV_COLOR_DATA_V4 : nvapi.h
  • NV_COLOR_DATA_V5 : nvapi.h
  • NV_COLOR_SELECTION_POLICY : nvapi.h
  • NV_COLORSPACE_TYPE : nvapi.h
  • NV_COMPUTE_GPU : nvapi.h
  • NV_COMPUTE_GPU_TOPOLOGY : nvapi.h
  • NV_COMPUTE_GPU_TOPOLOGY_V2 : nvapi.h
  • NV_COMPUTE_SHADER_DERIVATIVES : nvapi.h
  • NV_CUSTOM_RECTS : nvapi.h
  • NV_CUSTOM_RECTS_V1 : nvapi.h
  • NV_CUSTOM_SEMANTIC : nvapi.h
  • NV_CUSTOM_SEMANTIC_TYPE : nvapi.h
  • NV_D3D11_EXCLUSIVE_SCISSOR_RECT_DESC : nvapi.h
  • NV_D3D11_EXCLUSIVE_SCISSOR_RECT_DESC_V1 : nvapi.h
  • NV_D3D11_EXCLUSIVE_SCISSOR_RECTS_DESC : nvapi.h
  • NV_D3D11_EXCLUSIVE_SCISSOR_RECTS_DESC_V1 : nvapi.h
  • NV_D3D11_FEATURE : nvapi.h
  • NV_D3D11_FEATURE_DATA_RASTERIZER_SUPPORT : nvapi.h
  • NV_D3D11_SHADING_RATE_RESOURCE_VIEW_DESC : nvapi.h
  • NV_D3D11_SHADING_RATE_RESOURCE_VIEW_DESC_V1 : nvapi.h
  • NV_D3D11_VIEWPORT_SHADING_RATE_DESC : nvapi.h
  • NV_D3D11_VIEWPORT_SHADING_RATE_DESC_V1 : nvapi.h
  • NV_D3D11_VIEWPORTS_SHADING_RATE_DESC : nvapi.h
  • NV_D3D11_VIEWPORTS_SHADING_RATE_DESC_V1 : nvapi.h
  • NV_D3D12_GRAPHICS_CAPS : nvapi.h
  • NV_D3D12_GRAPHICS_CAPS_V1 : nvapi.h
  • NV_D3D12_MOSAIC_GETCOMPANIONALLOCATIONS : nvapi.h
  • NV_D3D12_MOSAIC_GETCOMPANIONALLOCATIONS_V1 : nvapi.h
  • NV_D3D12_MOSAIC_GETVIEWPORTANDGPUPARTITIONS : nvapi.h
  • NV_D3D12_MOSAIC_GETVIEWPORTANDGPUPARTITIONS_V1 : nvapi.h
  • NV_D3D12_WORKSTATION_FEATURE_RDMA_PROPERTIES : nvapi.h
  • NV_D3D12_WORKSTATION_FEATURE_TYPE : nvapi.h
  • NV_D3D1x_GRAPHICS_CAPS : nvapi.h
  • NV_D3D1x_GRAPHICS_CAPS_V1 : nvapi.h
  • NV_D3D1x_GRAPHICS_CAPS_V2 : nvapi.h
  • NV_D3D_LATELATCH_OBJECT_DESC : nvapi.h
  • NV_D3D_LATELATCH_OBJECT_DESC_V1 : nvapi.h
  • NV_DESKTOP_COLOR_DEPTH : nvapi.h
  • NV_DISPLAY_DRIVER_INFO : nvapi.h
  • NV_DISPLAY_DRIVER_INFO_V1 : nvapi.h
  • NV_DISPLAY_DRIVER_INFO_V2 : nvapi.h
  • NV_DISPLAY_DRIVER_MEMORY_INFO : nvapi_lite_common.h
  • NV_DISPLAY_OUTPUT_MODE : nvapi.h
  • NV_DISPLAY_PORT_INFO : nvapi.h
  • NV_DISPLAY_PORT_INFO_V1 : nvapi.h
  • NV_DISPLAY_TV_FORMAT : nvapi.h
  • NV_DISPLAYCONFIG_FLAGS : nvapi.h
  • NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO : nvapi.h
  • NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_V1 : nvapi.h
  • NV_DISPLAYCONFIG_PATH_INFO : nvapi.h
  • NV_DISPLAYCONFIG_PATH_INFO_V1 : nvapi.h
  • NV_DISPLAYCONFIG_PATH_INFO_V2 : nvapi.h
  • NV_DISPLAYCONFIG_PATH_TARGET_INFO : nvapi.h
  • NV_DISPLAYCONFIG_PATH_TARGET_INFO_V1 : nvapi.h
  • NV_DISPLAYCONFIG_PATH_TARGET_INFO_V2 : nvapi.h
  • NV_DISPLAYCONFIG_SOURCE_MODE_INFO : nvapi.h
  • NV_DISPLAYCONFIG_SOURCE_MODE_INFO_V1 : nvapi.h
  • NV_DISPLAYCONFIG_SPANNING_ORIENTATION : nvapi.h
  • NV_DP_BPC : nvapi.h
  • NV_DP_COLOR_FORMAT : nvapi.h
  • NV_DP_COLORIMETRY : nvapi.h
  • NV_DP_DYNAMIC_RANGE : nvapi.h
  • NV_DP_LANE_COUNT : nvapi.h
  • NV_DP_LINK_RATE : nvapi.h
  • NV_DX_VIDEO_STEREO_INFO : nvapi.h
  • NV_DYNAMIC_RANGE : nvapi.h
  • NV_ECC_CONFIGURATION : nvapi.h
  • NV_EDID : nvapi.h
  • NV_EDID_DATA : nvapi.h
  • NV_EDID_DATA_V1 : nvapi.h
  • NV_EDID_DATA_V2 : nvapi.h
  • NV_FASTGS_FLAGS : nvapi.h
  • NV_FORMAT : nvapi.h
  • NV_FOVEATED_RENDERING_CUSTOM_FOVEATION_PATTERN_PRESET_DESC : nvapi.h
  • NV_FOVEATED_RENDERING_CUSTOM_FOVEATION_PATTERN_PRESET_DESC_V1 : nvapi.h
  • NV_FOVEATED_RENDERING_CUSTOM_SHADING_RATE_PRESET_DESC : nvapi.h
  • NV_FOVEATED_RENDERING_CUSTOM_SHADING_RATE_PRESET_DESC_V1 : nvapi.h
  • NV_FOVEATED_RENDERING_DESC : nvapi.h
  • NV_FOVEATED_RENDERING_DESC_V1 : nvapi.h
  • NV_FOVEATED_RENDERING_FOVEATION_PATTERN_PRESET : nvapi.h
  • NV_FOVEATED_RENDERING_GAZE_DATA_PER_EYE : nvapi.h
  • NV_FOVEATED_RENDERING_GAZE_DATA_PER_EYE_V1 : nvapi.h
  • NV_FOVEATED_RENDERING_SHADING_RATE_PRESET : nvapi.h
  • NV_FOVEATED_RENDERING_UPDATE_GAZE_DATA_PARAMS : nvapi.h
  • NV_FOVEATED_RENDERING_UPDATE_GAZE_DATA_PARAMS_V1 : nvapi.h
  • NV_FRUSTUM_ADJUST_MODE : nvapi.h
  • NV_GAZE_DATA_TYPE : nvapi.h
  • NV_GAZE_DATA_VALIDITY_FLAGS : nvapi.h
  • NV_GAZE_HANDLER_INIT_PARAMS : nvapi.h
  • NV_GAZE_HANDLER_INIT_PARAMS_V1 : nvapi.h
  • NV_GAZE_HANDLER_INIT_PARAMS_V2 : nvapi.h
  • NV_GET_ADAPTIVE_SYNC_DATA : nvapi.h
  • NV_GET_ADAPTIVE_SYNC_DATA_V1 : nvapi.h
  • NV_GET_PREFERRED_STEREO_DISPLAY : nvapi.h
  • NV_GET_SLEEP_STATUS_PARAMS : nvapi.h
  • NV_GET_SLEEP_STATUS_PARAMS_V1 : nvapi.h
  • NV_GET_VIRTUAL_REFRESH_RATE_DATA : nvapi.h
  • NV_GET_VIRTUAL_REFRESH_RATE_DATA_V1 : nvapi.h
  • NV_GET_VRR_INFO : nvapi.h
  • NV_GET_VRR_INFO_V1 : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_ID : nvapi.h
  • NV_GPU_ARCH_INFO : nvapi.h
  • NV_GPU_ARCHITECTURE_ID : nvapi.h
  • NV_GPU_BUS_TYPE : nvapi.h
  • NV_GPU_CHIP_REVISION : nvapi.h
  • NV_GPU_CLIENT_CALLBACK_DATA_SUPER_V1 : nvapi.h
  • NV_GPU_CLIENT_CALLBACK_SETTINGS_SUPER_V1 : nvapi.h
  • NV_GPU_CLIENT_CALLBACK_UTILIZATION_DATA_V1 : nvapi.h
  • NV_GPU_CLIENT_ILLUM_DEVICE_CONTROL : nvapi.h
  • NV_GPU_CLIENT_ILLUM_DEVICE_CONTROL_PARAMS : nvapi.h
  • NV_GPU_CLIENT_ILLUM_DEVICE_INFO_DATA_GPIO_PWM_RGBW : nvapi.h
  • NV_GPU_CLIENT_ILLUM_DEVICE_INFO_DATA_GPIO_PWM_SINGLE_COLOR : nvapi.h
  • NV_GPU_CLIENT_ILLUM_DEVICE_INFO_DATA_MCUV10 : nvapi.h
  • NV_GPU_CLIENT_ILLUM_DEVICE_INFO_PARAMS : nvapi.h
  • NV_GPU_CLIENT_ILLUM_DEVICE_INFO_PARAMS_V1 : nvapi.h
  • NV_GPU_CLIENT_ILLUM_DEVICE_INFO_V1 : nvapi.h
  • NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_COLOR_FIXED : nvapi.h
  • NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_COLOR_FIXED : nvapi.h
  • NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_COLOR_FIXED_PARAMS : nvapi.h
  • NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_RGB : nvapi.h
  • NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_RGB_PARAMS : nvapi.h
  • NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_RGBW : nvapi.h
  • NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_RGBW_PARAMS : nvapi.h
  • NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_SINGLE_COLOR : nvapi.h
  • NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_SINGLE_COLOR_PARAMS : nvapi.h
  • NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR : nvapi.h
  • NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR_COLOR_FIXED : nvapi.h
  • NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR_RGB : nvapi.h
  • NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR_RGBW : nvapi.h
  • NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR_SINGLE_COLOR : nvapi.h
  • NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_RGB : nvapi.h
  • NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_RGBW : nvapi.h
  • NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_SINGLE_COLOR : nvapi.h
  • NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_PARAMS : nvapi.h
  • NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_PARAMS_V1 : nvapi.h
  • NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_V1 : nvapi.h
  • NV_GPU_CLIENT_ILLUM_ZONE_INFO_DATA_RGB : nvapi.h
  • NV_GPU_CLIENT_ILLUM_ZONE_INFO_DATA_RGBW : nvapi.h
  • NV_GPU_CLIENT_ILLUM_ZONE_INFO_DATA_SINGLE_COLOR : nvapi.h
  • NV_GPU_CLIENT_ILLUM_ZONE_INFO_PARAMS : nvapi.h
  • NV_GPU_CLIENT_ILLUM_ZONE_INFO_PARAMS_V1 : nvapi.h
  • NV_GPU_CLIENT_ILLUM_ZONE_INFO_V1 : nvapi.h
  • NV_GPU_CLIENT_PERIODIC_CALLBACK_SETTINGS_SUPER_V1 : nvapi.h
  • NV_GPU_CLIENT_UTIL_DOMAIN_ID : nvapi.h
  • NV_GPU_CLIENT_UTILIZATION_DATA_V1 : nvapi.h
  • NV_GPU_CLIENT_UTILIZATION_PERIODIC_CALLBACK_SETTINGS : nvapi.h
  • NV_GPU_CLIENT_UTILIZATION_PERIODIC_CALLBACK_SETTINGS_V1 : nvapi.h
  • NV_GPU_CLIENT_UTILIZATION_PERIODIC_CALLBACK_V1 : nvapi.h
  • NV_GPU_CLOCK_FREQUENCIES : nvapi.h
  • NV_GPU_CONNECTOR_TYPE : nvapi.h
  • NV_GPU_DISPLAYIDS : nvapi.h
  • NV_GPU_GET_ILLUMINATION_PARM : nvapi.h
  • NV_GPU_GET_ILLUMINATION_PARM_V1 : nvapi.h
  • NV_GPU_GSP_INFO : nvapi.h
  • NV_GPU_GSP_INFO_V1 : nvapi.h
  • NV_GPU_HDCP_FUSE_STATE : nvapi.h
  • NV_GPU_HDCP_KEY_SOURCE : nvapi.h
  • NV_GPU_HDCP_KEY_SOURCE_STATE : nvapi.h
  • NV_GPU_ILLUMINATION_ATTRIB : nvapi.h
  • NV_GPU_INFO : nvapi.h
  • NV_GPU_INFO_V1 : nvapi.h
  • NV_GPU_INFO_V2 : nvapi.h
  • NV_GPU_MEMORY_INFO_EX : nvapi_lite_common.h
  • NV_GPU_OUTPUT_TYPE : nvapi.h
  • NV_GPU_PERF_PSTATE_ID : nvapi.h
  • NV_GPU_PERF_PSTATES20_INFO : nvapi.h
  • NV_GPU_PERF_PSTATES20_INFO_V2 : nvapi.h
  • NV_GPU_PERF_PSTATES_INFO : nvapi.h
  • NV_GPU_PERF_VOLTAGE_INFO_DOMAIN_ID : nvapi.h
  • NV_GPU_PUBLIC_CLOCK_ID : nvapi.h
  • NV_GPU_QUERY_ILLUMINATION_SUPPORT_PARM : nvapi.h
  • NV_GPU_QUERY_ILLUMINATION_SUPPORT_PARM_V1 : nvapi.h
  • NV_GPU_SET_ILLUMINATION_PARM : nvapi.h
  • NV_GPU_SET_ILLUMINATION_PARM_V1 : nvapi.h
  • NV_GPU_THERMAL_SETTINGS : nvapi.h
  • NV_GPU_TYPE : nvapi.h
  • NV_GPU_VIRTUALIZATION_INFO : nvapi.h
  • NV_GPU_VIRTUALIZATION_INFO_V1 : nvapi.h
  • NV_GPU_VR_READY : nvapi.h
  • NV_GPU_VR_READY_V1 : nvapi.h
  • NV_GPU_WORKSTATION_FEATURE_TYPE : nvapi.h
  • NV_GSYNC_CAPABILITIES : nvapi.h
  • NV_GSYNC_CAPABILITIES_V1 : nvapi.h
  • NV_GSYNC_CAPABILITIES_V2 : nvapi.h
  • NV_GSYNC_CAPABILITIES_V3 : nvapi.h
  • NV_GSYNC_CONTROL_PARAMS : nvapi.h
  • NV_GSYNC_CONTROL_PARAMS_V1 : nvapi.h
  • NV_GSYNC_CONTROL_PARAMS_V2 : nvapi.h
  • NV_GSYNC_DELAY : nvapi.h
  • NV_GSYNC_DISPLAY : nvapi.h
  • NV_GSYNC_GPU : nvapi.h
  • NV_GSYNC_STATUS : nvapi.h
  • NV_GSYNC_STATUS_PARAMS : nvapi.h
  • NV_GSYNC_STATUS_PARAMS_V1 : nvapi.h
  • NV_GSYNC_STATUS_PARAMS_V2 : nvapi.h
  • NV_HDMI_SUPPORT_INFO : nvapi.h
  • NV_HDMI_SUPPORT_INFO_V1 : nvapi.h
  • NV_HDMI_SUPPORT_INFO_V2 : nvapi.h
  • NV_HDR_CAPABILITIES : nvapi.h
  • NV_HDR_CAPABILITIES_V1 : nvapi.h
  • NV_HDR_CAPABILITIES_V2 : nvapi.h
  • NV_HDR_CAPABILITIES_V3 : nvapi.h
  • NV_HDR_COLOR_DATA : nvapi.h
  • NV_HDR_COLOR_DATA_V1 : nvapi.h
  • NV_HDR_COLOR_DATA_V2 : nvapi.h
  • NV_HDR_METADATA : nvapi.h
  • NV_HDR_METADATA_V1 : nvapi.h
  • NV_HDR_TONEMAPPING_METHOD : nvapi.h
  • NV_HEAP_PARAMS : nvapi.h
  • NV_HEAP_PARAMS_V1 : nvapi.h
  • NV_I2C_INFO : nvapi.h
  • NV_JOIN_PRESENT_BARRIER_PARAMS : nvapi.h
  • NV_LATENCY_MARKER_PARAMS : nvapi.h
  • NV_LATENCY_MARKER_PARAMS_V1 : nvapi.h
  • NV_LATENCY_RESULT_PARAMS : nvapi.h
  • NV_LATENCY_RESULT_PARAMS_V1 : nvapi.h
  • NV_LICENSABLE_FEATURES : nvapi.h
  • NV_LICENSABLE_FEATURES_V1 : nvapi.h
  • NV_LICENSABLE_FEATURES_V2 : nvapi.h
  • NV_LICENSABLE_FEATURES_V3 : nvapi.h
  • NV_LICENSABLE_FEATURES_V4 : nvapi.h
  • NV_LICENSE_EXPIRY_DETAILS : nvapi.h
  • NV_LICENSE_FEATURE_DETAILS : nvapi.h
  • NV_LICENSE_FEATURE_DETAILS_V1 : nvapi.h
  • NV_LICENSE_FEATURE_DETAILS_V2 : nvapi.h
  • NV_LICENSE_FEATURE_DETAILS_V3 : nvapi.h
  • NV_LICENSE_FEATURE_DETAILS_V4 : nvapi.h
  • NV_LICENSE_FEATURE_TYPE : nvapi.h
  • NV_LMS_CONFIG : nvapi.h
  • NV_LMS_CUSTOM_CONFIG : nvapi.h
  • NV_LMS_CUSTOM_CONFIG_V1 : nvapi.h
  • NV_LMS_INSTANCED_STEREO_CONFIG : nvapi.h
  • NV_LMS_INSTANCED_STEREO_CONFIG_V1 : nvapi.h
  • NV_LOGICAL_GPU_DATA : nvapi.h
  • NV_LOGICAL_GPU_DATA_V1 : nvapi.h
  • NV_LOGICAL_GPU_HANDLE_DATA : nvapi.h
  • NV_LOGICAL_GPUS : nvapi.h
  • NV_LOGICAL_GPUS_V1 : nvapi.h
  • NV_MANAGED_DEDICATED_DISPLAY_INFO : nvapi.h
  • NV_MANAGED_DEDICATED_DISPLAY_INFO_V1 : nvapi.h
  • NV_MANAGED_DEDICATED_DISPLAY_METADATA : nvapi.h
  • NV_MANAGED_DEDICATED_DISPLAY_METADATA_V1 : nvapi.h
  • NV_META_COMMAND_BOOL : nvapi.h
  • NV_MODIFIED_W_COEFFICIENTS : nvapi.h
  • NV_MODIFIED_W_PARAMS : nvapi.h
  • NV_MODIFIED_W_PARAMS_V1 : nvapi.h
  • NV_MONITOR_CAPABILITIES : nvapi.h
  • NV_MONITOR_CAPABILITIES_V1 : nvapi.h
  • NV_MONITOR_CAPS_GENERIC : nvapi.h
  • NV_MONITOR_CAPS_VCDB : nvapi.h
  • NV_MONITOR_CAPS_VSDB : nvapi.h
  • NV_MONITOR_COLOR_CAPS : nvapi.h
  • NV_MONITOR_COLOR_CAPS_V1 : nvapi.h
  • NV_MOSAIC_DISPLAY_SETTING : nvapi.h
  • NV_MOSAIC_DISPLAY_SETTING_V1 : nvapi.h
  • NV_MOSAIC_DISPLAY_SETTING_V2 : nvapi.h
  • NV_MOSAIC_GRID_TOPO : nvapi.h
  • NV_MOSAIC_GRID_TOPO_DISPLAY : nvapi.h
  • NV_MOSAIC_GRID_TOPO_DISPLAY_V1 : nvapi.h
  • NV_MOSAIC_GRID_TOPO_DISPLAY_V2 : nvapi.h
  • NV_MOSAIC_GRID_TOPO_V1 : nvapi.h
  • NV_MOSAIC_GRID_TOPO_V2 : nvapi.h
  • NV_MOSAIC_SUPPORTED_TOPO_INFO : nvapi.h
  • NV_MOSAIC_SUPPORTED_TOPO_INFO_V1 : nvapi.h
  • NV_MOSAIC_SUPPORTED_TOPO_INFO_V2 : nvapi.h
  • NV_MRS_CONFIG : nvapi.h
  • NV_MRS_CUSTOM_CONFIG : nvapi.h
  • NV_MRS_CUSTOM_CONFIG_V1 : nvapi.h
  • NV_MRS_INSTANCED_STEREO_CONFIG : nvapi.h
  • NV_MRS_INSTANCED_STEREO_CONFIG_V1 : nvapi.h
  • NV_MULTIGPU_CAPS : nvapi.h
  • NV_MULTIGPU_CAPS_V1 : nvapi.h
  • NV_MULTIGPU_CAPS_V2 : nvapi.h
  • NV_MULTIVIEW_PARAMS : nvapi.h
  • NV_MULTIVIEW_PARAMS_V1 : nvapi.h
  • NV_PHYSICAL_GPU_HANDLE_DATA : nvapi.h
  • NV_PHYSICAL_GPUS : nvapi.h
  • NV_PHYSICAL_GPUS_V1 : nvapi.h
  • NV_PIXEL_SHADING_RATE_SAMPLE_ORDER_TABLE : nvapi.h
  • NV_PIXEL_SHADING_RATE_SAMPLE_ORDER_TABLE_V1 : nvapi.h
  • NV_PIXEL_SHIFT_TYPE : nvapi.h
  • NV_PIXEL_SRSO_1x2 : nvapi.h
  • NV_PIXEL_SRSO_2x1 : nvapi.h
  • NV_PIXEL_SRSO_2x2 : nvapi.h
  • NV_PIXEL_SRSO_2x4 : nvapi.h
  • NV_PIXEL_SRSO_4x2 : nvapi.h
  • NV_PIXEL_SRSO_4x4 : nvapi.h
  • NV_POSITION : nvapi.h
  • NV_PRESENT_BARRIER_FRAME_STATISTICS : nvapi.h
  • NV_PRESENT_BARRIER_SYNC_MODE : nvapi.h
  • NV_PSO_EXTENSION : nvapi.h
  • NV_QUERY_LATELATCH_SUPPORT_PARAMS : nvapi.h
  • NV_QUERY_LATELATCH_SUPPORT_PARAMS_V1 : nvapi.h
  • NV_QUERY_MODIFIED_W_SUPPORT_PARAMS : nvapi.h
  • NV_QUERY_MODIFIED_W_SUPPORT_PARAMS_V1 : nvapi.h
  • NV_QUERY_MULTIVIEW_SUPPORT_PARAMS : nvapi.h
  • NV_QUERY_MULTIVIEW_SUPPORT_PARAMS_V1 : nvapi.h
  • NV_QUERY_SINGLE_PASS_STEREO_SUPPORT_PARAMS : nvapi.h
  • NV_QUERY_SINGLE_PASS_STEREO_SUPPORT_PARAMS_V1 : nvapi.h
  • NV_QUERY_SINGLE_PASS_STEREO_SUPPORT_PARAMS_V2 : nvapi.h
  • NV_QUERY_SMP_ASSIST_SUPPORT_PARAMS : nvapi.h
  • NV_QUERY_SMP_ASSIST_SUPPORT_PARAMS_V1 : nvapi.h
  • NV_RECT : nvapi_lite_common.h
  • NV_RESOLUTION : nvapi.h
  • NV_RESOLVE_MODE : nvapi.h
  • NV_RESOURCE_PARAMS : nvapi.h
  • NV_RESOURCE_PARAMS_V1 : nvapi.h
  • NV_ROTATE : nvapi.h
  • NV_SCALING : nvapi.h
  • NV_SCANOUT_INFORMATION : nvapi.h
  • NV_SCANOUT_INTENSITY_DATA : nvapi.h
  • NV_SCANOUT_INTENSITY_STATE_DATA : nvapi.h
  • NV_SCANOUT_WARPING_STATE_DATA : nvapi.h
  • NV_SET_ADAPTIVE_SYNC_DATA : nvapi.h
  • NV_SET_ADAPTIVE_SYNC_DATA_V1 : nvapi.h
  • NV_SET_PREFERRED_STEREO_DISPLAY : nvapi.h
  • NV_SET_REFLEX_SYNC_PARAMS : nvapi.h
  • NV_SET_REFLEX_SYNC_PARAMS_V1 : nvapi.h
  • NV_SET_SLEEP_MODE_PARAMS : nvapi.h
  • NV_SET_SLEEP_MODE_PARAMS_V1 : nvapi.h
  • NV_SET_VIRTUAL_REFRESH_RATE_DATA : nvapi.h
  • NV_SET_VIRTUAL_REFRESH_RATE_DATA_V1 : nvapi.h
  • NV_SMP_ASSIST_DISABLE_PARAMS : nvapi.h
  • NV_SMP_ASSIST_DISABLE_PARAMS_V1 : nvapi.h
  • NV_SMP_ASSIST_ENABLE_PARAMS : nvapi.h
  • NV_SMP_ASSIST_ENABLE_PARAMS_V1 : nvapi.h
  • NV_SMP_ASSIST_EYE_INDEX : nvapi.h
  • NV_SMP_ASSIST_FASTGSCBDATA : nvapi.h
  • NV_SMP_ASSIST_FASTGSCBDATA_MRS_INSTANCED_STEREO : nvapi.h
  • NV_SMP_ASSIST_FASTGSCBDATA_MRS_INSTANCED_STEREO_V1 : nvapi.h
  • NV_SMP_ASSIST_FASTGSCBDATA_V1 : nvapi.h
  • NV_SMP_ASSIST_GET_CONSTANTS : nvapi.h
  • NV_SMP_ASSIST_GET_CONSTANTS_V3 : nvapi.h
  • NV_SMP_ASSIST_INITIALIZE_PARAMS : nvapi.h
  • NV_SMP_ASSIST_INITIALIZE_PARAMS_V1 : nvapi.h
  • NV_SMP_ASSIST_LEVEL : nvapi.h
  • NV_SMP_ASSIST_REMAPCBDATA : nvapi.h
  • NV_SMP_ASSIST_REMAPCBDATA_V1 : nvapi.h
  • NV_SMP_ASSIST_SETUP_PARAMS : nvapi.h
  • NV_SMP_ASSIST_SETUP_PARAMS_V1 : nvapi.h
  • NV_SMP_ASSIST_TYPE : nvapi.h
  • NV_SMP_ASSIST_UPDATE_INSTANCEDSTEREO_DATA_PARAMS : nvapi.h
  • NV_SMP_ASSIST_UPDATE_INSTANCEDSTEREO_DATA_PARAMS_V1 : nvapi.h
  • NV_SRRV_DIMENSION : nvapi.h
  • NV_STEREO_ACTIVE_EYE : nvapi_lite_stereo.h
  • NV_STEREO_DRIVER_MODE : nvapi_lite_stereo.h
  • NV_STEREO_REGISTRY_ID : nvapi.h
  • NV_STEREO_REGISTRY_PROFILE_TYPE : nvapi.h
  • NV_STEREO_SWAPCHAIN_MODE : nvapi.h
  • NV_STEREO_VIDEO_FORMAT : nvapi.h
  • NV_SWIZZLE_MODE : nvapi.h
  • NV_SWIZZLE_OFFSET : nvapi.h
  • NV_TARGET_VIEW_MODE : nvapi.h
  • NV_TEX2D_ARRAY_SRRV : nvapi.h
  • NV_TEX2D_SRRV : nvapi.h
  • NV_TIMING : nvapi.h
  • NV_TIMING_INPUT : nvapi.h
  • NV_TIMING_OVERRIDE : nvapi.h
  • NV_TIMINGEXT : nvapi.h
  • NV_VIO_TOPOLOGY : nvapi.h
  • NV_VIRTUALIZATION_MODE : nvapi.h
  • NV_VRS_CONTENT_TYPE : nvapi.h
  • NV_VRS_HELPER_DISABLE_PARAMS : nvapi.h
  • NV_VRS_HELPER_DISABLE_PARAMS_V1 : nvapi.h
  • NV_VRS_HELPER_ENABLE_PARAMS : nvapi.h
  • NV_VRS_HELPER_ENABLE_PARAMS_V1 : nvapi.h
  • NV_VRS_HELPER_GET_SHADING_RATE_RESOURCE_PARAMS : nvapi.h
  • NV_VRS_HELPER_GET_SHADING_RATE_RESOURCE_PARAMS_V1 : nvapi.h
  • NV_VRS_HELPER_INIT_PARAMS : nvapi.h
  • NV_VRS_HELPER_INIT_PARAMS_V1 : nvapi.h
  • NV_VRS_HELPER_LATCH_GAZE_PARAMS : nvapi.h
  • NV_VRS_HELPER_LATCH_GAZE_PARAMS_V1 : nvapi.h
  • NV_VRS_HELPER_PURGE_INTERNAL_RESOURCES_PARAMS : nvapi.h
  • NV_VRS_HELPER_PURGE_INTERNAL_RESOURCES_PARAMS_V1 : nvapi.h
  • NV_VRS_RENDER_MODE : nvapi.h
  • NVAPI_ANSEL_CONFIGURATION_STRUCT : nvapi.h
  • NVAPI_ANSEL_CONFIGURATION_STRUCT_V1 : nvapi.h
  • NVAPI_ANSEL_FEATURE : nvapi.h
  • NVAPI_ANSEL_FEATURE_CONFIGURATION_STRUCT : nvapi.h
  • NVAPI_ANSEL_FEATURE_STATE : nvapi.h
  • NVAPI_ANSEL_HOTKEY_MODIFIER : nvapi.h
  • NVAPI_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_EX_PARAMS : nvapi.h
  • NVAPI_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_EX_PARAMS_V1 : nvapi.h
  • NVAPI_BUILD_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PARAMS : nvapi.h
  • NVAPI_BUILD_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PARAMS_V1 : nvapi.h
  • NVAPI_BUILD_RAYTRACING_OPACITY_MICROMAP_ARRAY_PARAMS : nvapi.h
  • NVAPI_BUILD_RAYTRACING_OPACITY_MICROMAP_ARRAY_PARAMS_V1 : nvapi.h
  • NVAPI_CALLBACK_QSYNCEVENT : nvapi.h
  • NVAPI_CHECK_DRIVER_MATCHING_IDENTIFIER_EX_PARAMS : nvapi.h
  • NVAPI_CHECK_DRIVER_MATCHING_IDENTIFIER_EX_PARAMS_V1 : nvapi.h
  • NVAPI_CU_KERNEL_LAUNCH_PARAMS : nvapi.h
  • NVAPI_CU_KERNEL_LAUNCH_PARAMS_EX : nvapi.h
  • NvAPI_D3D11_CREATE_DOMAIN_SHADER_EX : nvapi.h
  • NvAPI_D3D11_CREATE_DOMAIN_SHADER_EX_V1 : nvapi.h
  • NvAPI_D3D11_CREATE_DOMAIN_SHADER_EX_V2 : nvapi.h
  • NvAPI_D3D11_CREATE_DOMAIN_SHADER_EX_V3 : nvapi.h
  • NvAPI_D3D11_CREATE_FASTGS_EXPLICIT_DESC : nvapi.h
  • NvAPI_D3D11_CREATE_GEOMETRY_SHADER_EX : nvapi.h
  • NvAPI_D3D11_CREATE_GEOMETRY_SHADER_EX_V5 : nvapi.h
  • NvAPI_D3D11_CREATE_HULL_SHADER_EX : nvapi.h
  • NvAPI_D3D11_CREATE_HULL_SHADER_EX_V1 : nvapi.h
  • NvAPI_D3D11_CREATE_HULL_SHADER_EX_V2 : nvapi.h
  • NvAPI_D3D11_CREATE_PIXEL_SHADER_EX : nvapi.h
  • NvAPI_D3D11_CREATE_PIXEL_SHADER_EX_V1 : nvapi.h
  • NvAPI_D3D11_CREATE_PIXEL_SHADER_EX_V2 : nvapi.h
  • NvAPI_D3D11_CREATE_VERTEX_SHADER_EX : nvapi.h
  • NvAPI_D3D11_CREATE_VERTEX_SHADER_EX_V1 : nvapi.h
  • NvAPI_D3D11_CREATE_VERTEX_SHADER_EX_V2 : nvapi.h
  • NvAPI_D3D11_CREATE_VERTEX_SHADER_EX_V3 : nvapi.h
  • NVAPI_D3D11_INSERTWFI_FLAG : nvapi.h
  • NvAPI_D3D11_RASTERIZER_DESC_EX : nvapi.h
  • NvAPI_D3D11_SWIZZLE_MODE : nvapi.h
  • NVAPI_D3D12_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_DESC_EX : nvapi.h
  • NVAPI_D3D12_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_INPUTS_EX : nvapi.h
  • NVAPI_D3D12_BUILD_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_DESC : nvapi.h
  • NVAPI_D3D12_BUILD_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_INPUTS : nvapi.h
  • NVAPI_D3D12_BUILD_RAYTRACING_OPACITY_MICROMAP_ARRAY_DESC : nvapi.h
  • NVAPI_D3D12_BUILD_RAYTRACING_OPACITY_MICROMAP_ARRAY_INPUTS : nvapi.h
  • NVAPI_D3D12_CREATE_CUBIN_SHADER_PARAMS : nvapi.h
  • NVAPI_D3D12_GET_CUDA_INDEPENDENT_DESCRIPTOR_OBJECT_PARAMS : nvapi.h
  • NVAPI_D3D12_GET_CUDA_INDEPENDENT_DESCRIPTOR_OBJECT_TYPE : nvapi.h
  • NVAPI_D3D12_GET_CUDA_MERGED_TEXTURE_SAMPLER_OBJECT_PARAMS : nvapi.h
  • NVAPI_D3D12_PIPELINE_CREATION_STATE_FLAGS : nvapi.h
  • NVAPI_D3D12_PSO_CREATE_FASTGS_EXPLICIT_DESC : nvapi.h
  • NVAPI_D3D12_PSO_DOMAIN_SHADER_DESC : nvapi.h
  • NVAPI_D3D12_PSO_ENABLE_DEPTH_BOUND_TEST_DESC : nvapi.h
  • NVAPI_D3D12_PSO_EXTENSION_DESC : nvapi.h
  • NVAPI_D3D12_PSO_GEOMETRY_SHADER_DESC : nvapi.h
  • NVAPI_D3D12_PSO_HULL_SHADER_DESC : nvapi.h
  • NVAPI_D3D12_PSO_RASTERIZER_STATE_DESC : nvapi.h
  • NVAPI_D3D12_PSO_REQUEST_FAST_GEOMETRY_SHADER_DESC : nvapi.h
  • NVAPI_D3D12_PSO_SET_SHADER_EXTENSION_SLOT_DESC : nvapi.h
  • NVAPI_D3D12_PSO_VERTEX_SHADER_DESC : nvapi.h
  • NVAPI_D3D12_RAYTRACING_ACCELERATION_STRUCTURE_BUILD_FLAGS_EX : nvapi.h
  • NVAPI_D3D12_RAYTRACING_CAPS_TYPE : nvapi.h
  • NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_BUILD_FLAGS : nvapi.h
  • NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_POSTBUILD_INFO_CURRENT_SIZE_DESC : nvapi.h
  • NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_POSTBUILD_INFO_DESC : nvapi.h
  • NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_POSTBUILD_INFO_TYPE : nvapi.h
  • NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PREBUILD_INFO : nvapi.h
  • NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_CAPS : nvapi.h
  • NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_DESC : nvapi.h
  • NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_FORMAT : nvapi.h
  • NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_PRIMITIVE_FLAGS : nvapi.h
  • NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_USAGE_COUNT : nvapi.h
  • NVAPI_D3D12_RAYTRACING_GEOMETRY_DESC_EX : nvapi.h
  • NVAPI_D3D12_RAYTRACING_GEOMETRY_DMM_ATTACHMENT_DESC : nvapi.h
  • NVAPI_D3D12_RAYTRACING_GEOMETRY_DMM_TRIANGLES_DESC : nvapi.h
  • NVAPI_D3D12_RAYTRACING_GEOMETRY_OMM_ATTACHMENT_DESC : nvapi.h
  • NVAPI_D3D12_RAYTRACING_GEOMETRY_OMM_TRIANGLES_DESC : nvapi.h
  • NVAPI_D3D12_RAYTRACING_GEOMETRY_TYPE_EX : nvapi.h
  • NVAPI_D3D12_RAYTRACING_INSTANCE_FLAGS_EX : nvapi.h
  • NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_ARRAY_BUILD_FLAGS : nvapi.h
  • NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_ARRAY_POSTBUILD_INFO_CURRENT_SIZE_DESC : nvapi.h
  • NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_ARRAY_POSTBUILD_INFO_DESC : nvapi.h
  • NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_ARRAY_POSTBUILD_INFO_TYPE : nvapi.h
  • NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_ARRAY_PREBUILD_INFO : nvapi.h
  • NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_CAPS : nvapi.h
  • NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_DESC : nvapi.h
  • NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_FORMAT : nvapi.h
  • NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_SPECIAL_INDEX : nvapi.h
  • NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_STATE : nvapi.h
  • NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_USAGE_COUNT : nvapi.h
  • NVAPI_D3D12_RAYTRACING_THREAD_REORDERING_CAPS : nvapi.h
  • NVAPI_D3D12_RAYTRACING_VALIDATION_FLAGS : nvapi.h
  • NVAPI_D3D12_RAYTRACING_VALIDATION_MESSAGE_CALLBACK : nvapi.h
  • NVAPI_D3D12_RAYTRACING_VALIDATION_MESSAGE_SEVERITY : nvapi.h
  • NVAPI_D3D12_SERIALIZED_DATA_TYPE_EX : nvapi.h
  • NVAPI_D3D12_SET_CREATE_PIPELINE_STATE_OPTIONS_PARAMS : nvapi.h
  • NVAPI_D3D12_SET_CREATE_PIPELINE_STATE_OPTIONS_PARAMS_V1 : nvapi.h
  • NVAPI_D3D12_WORKSTATION_FEATURE_PROPERTIES_PARAMS_V1 : nvapi.h
  • NVAPI_D3D_RESOURCERENDERING_FLAG : nvapi_lite_sli.h
  • NVAPI_D3D_SETRESOURCEHINT_CATEGORY : nvapi_lite_sli.h
  • NVAPI_D3D_SETRESOURCEHINT_SLI : nvapi_lite_sli.h
  • NVAPI_DIM3 : nvapi.h
  • NVAPI_EMIT_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_POSTBUILD_INFO_PARAMS : nvapi.h
  • NVAPI_EMIT_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_POSTBUILD_INFO_PARAMS_V1 : nvapi.h
  • NVAPI_EMIT_RAYTRACING_OPACITY_MICROMAP_ARRAY_POSTBUILD_INFO_PARAMS : nvapi.h
  • NVAPI_EMIT_RAYTRACING_OPACITY_MICROMAP_ARRAY_POSTBUILD_INFO_PARAMS_V1 : nvapi.h
  • NVAPI_GET_RAYTRACING_ACCELERATION_STRUCTURE_PREBUILD_INFO_EX_PARAMS : nvapi.h
  • NVAPI_GET_RAYTRACING_ACCELERATION_STRUCTURE_PREBUILD_INFO_EX_PARAMS_V1 : nvapi.h
  • NVAPI_GET_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PREBUILD_INFO_PARAMS : nvapi.h
  • NVAPI_GET_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PREBUILD_INFO_PARAMS_V1 : nvapi.h
  • NVAPI_GET_RAYTRACING_OPACITY_MICROMAP_ARRAY_PREBUILD_INFO_PARAMS : nvapi.h
  • NVAPI_GET_RAYTRACING_OPACITY_MICROMAP_ARRAY_PREBUILD_INFO_PARAMS_V1 : nvapi.h
  • NVAPI_GPU_PERF_DECREASE : nvapi.h
  • NVAPI_GSYNC_DELAY_TYPE : nvapi.h
  • NVAPI_GSYNC_DISPLAY_SYNC_STATE : nvapi.h
  • NVAPI_GSYNC_GPU_TOPOLOGY_CONNECTOR : nvapi.h
  • NVAPI_GSYNC_MULTIPLY_DIVIDE_MODE : nvapi.h
  • NVAPI_GSYNC_POLARITY : nvapi.h
  • NVAPI_GSYNC_RJ45_IO : nvapi.h
  • NVAPI_GSYNC_SYNC_SOURCE : nvapi.h
  • NVAPI_GSYNC_VIDEO_MODE : nvapi.h
  • NvAPI_LicenseString : nvapi.h
  • NvAPI_LongString : nvapi_lite_common.h
  • NvAPI_LPCWSTR : nvapi.h
  • NVAPI_NVLINK_DEVICE_INFO_DEVICE_TYPE : nvapi.h
  • NVAPI_NVLINK_STATUS_LINK_STATE : nvapi.h
  • NVAPI_NVLINK_STATUS_SUBLINK_RX_STATE : nvapi.h
  • NVAPI_NVLINK_STATUS_SUBLINK_TX_STATE : nvapi.h
  • NVAPI_OGLEXPERT_CALLBACK : nvapi.h
  • NVAPI_RAY_FLAG_EX : nvapi.h
  • NVAPI_RELOCATE_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PARAMS : nvapi.h
  • NVAPI_RELOCATE_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PARAMS_V1 : nvapi.h
  • NVAPI_RELOCATE_RAYTRACING_OPACITY_MICROMAP_ARRAY_PARAMS : nvapi.h
  • NVAPI_RELOCATE_RAYTRACING_OPACITY_MICROMAP_ARRAY_PARAMS_V1 : nvapi.h
  • NvAPI_ShortString : nvapi_lite_common.h
  • NvAPI_Status : nvapi_lite_common.h
  • NVAPI_STEREO_CAPS : nvapi.h
  • NVAPI_STEREO_CAPS_V1 : nvapi.h
  • NVAPI_STEREO_INIT_ACTIVATION_FLAGS : nvapi.h
  • NVAPI_STEREO_SURFACECREATEMODE : nvapi_lite_stereo.h
  • NvAPI_String : nvapi_lite_common.h
  • NVAPI_UAV_INFO : nvapi.h
  • NvAPI_UnicodeShortString : nvapi_lite_common.h
  • NvAPI_UnicodeString : nvapi.h
  • NvBool : nvapi_lite_common.h
  • NVDRS_APPLICATION : nvapi.h
  • NVDRS_APPLICATION_V1 : nvapi.h
  • NVDRS_APPLICATION_V2 : nvapi.h
  • NVDRS_APPLICATION_V3 : nvapi.h
  • NVDRS_APPLICATION_V4 : nvapi.h
  • NVDRS_BINARY_SETTING : nvapi.h
  • NVDRS_GPU_SUPPORT : nvapi.h
  • NVDRS_PROFILE : nvapi.h
  • NVDRS_PROFILE_V1 : nvapi.h
  • NVDRS_SETTING : nvapi.h
  • NVDRS_SETTING_LOCATION : nvapi.h
  • NVDRS_SETTING_TYPE : nvapi.h
  • NVDRS_SETTING_V1 : nvapi.h
  • NVDRS_SETTING_VALUES : nvapi.h
  • NvF32 : nvapi_lite_common.h
  • NvF64 : nvapi_lite_common.h
  • NVLINK_GET_CAPS : nvapi.h
  • NVLINK_GET_STATUS : nvapi.h
  • NvLUID : nvapi_lite_common.h
  • NvS16 : nvapi_lite_common.h
  • NvS32 : nvapi_lite_common.h
  • NvS64 : nvapi_lite_common.h
  • NvS8 : nvapi_lite_common.h
  • NvU16 : nvapi_lite_common.h
  • NvU32 : nvapi_lite_common.h
  • NvU64 : nvapi_lite_common.h
  • NvU8 : nvapi_lite_common.h
  • NVVIOANCPARITYCOMPUTATION : nvapi.h
  • NVVIOBITSPERCOMPONENT : nvapi.h
  • NVVIOCAPS : nvapi.h
  • NVVIOCAPTURESTATUS : nvapi.h
  • NVVIOCHANNELSTATUS : nvapi.h
  • NVVIOCOLORCONVERSION : nvapi.h
  • NVVIOCOLORSPACE : nvapi.h
  • NVVIOCOMPONENTSAMPLING : nvapi.h
  • NVVIOCOMPOSITERANGE : nvapi.h
  • NVVIOCOMPSYNCTYPE : nvapi.h
  • NVVIOCONFIG : nvapi.h
  • NVVIOCONFIG_V1 : nvapi.h
  • NVVIOCONFIG_V2 : nvapi.h
  • NVVIOCONFIG_V3 : nvapi.h
  • NVVIOCONFIGTYPE : nvapi.h
  • NVVIODATAFORMAT : nvapi.h
  • NVVIODATAFORMATDETAIL : nvapi.h
  • NVVIOGAMMACORRECTION : nvapi.h
  • NVVIOGAMMARAMP10 : nvapi.h
  • NVVIOGAMMARAMP8 : nvapi.h
  • NVVIOINPUTCONFIG : nvapi.h
  • NVVIOINPUTOUTPUTSTATUS : nvapi.h
  • NVVIOINPUTSTATUS : nvapi.h
  • NVVIOINTERLACEMODE : nvapi.h
  • NVVIOLINKID : nvapi.h
  • NVVIOOUTPUTAREA : nvapi.h
  • NVVIOOUTPUTCONFIG : nvapi.h
  • NVVIOOUTPUTCONFIG_V1 : nvapi.h
  • NVVIOOUTPUTCONFIG_V2 : nvapi.h
  • NVVIOOUTPUTCONFIG_V3 : nvapi.h
  • NVVIOOUTPUTREGION : nvapi.h
  • NVVIOOUTPUTSTATUS : nvapi.h
  • NVVIOOWNERID : nvapi.h
  • NVVIOOWNERTYPE : nvapi.h
  • NVVIOPCIINFO : nvapi.h
  • NVVIOPCIINFO_V1 : nvapi.h
  • NVVIOPCILINKRATE : nvapi.h
  • NVVIOPCILINKWIDTH : nvapi.h
  • NVVIOSIGNALFORMAT : nvapi.h
  • NVVIOSIGNALFORMATDETAIL : nvapi.h
  • NVVIOSTATUS : nvapi.h
  • NVVIOSTATUSTYPE : nvapi.h
  • NVVIOSTREAM : nvapi.h
  • NVVIOSYNCDELAY : nvapi.h
  • NVVIOSYNCSOURCE : nvapi.h
  • NVVIOSYNCSTATUS : nvapi.h
  • NVVIOTOPOLOGY : nvapi.h
  • NVVIOVIDEOMODE : nvapi.h
  • NVVIOVIDEOSTANDARD : nvapi.h
  • NVVIOVIDEOTYPE : nvapi.h


  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • i
  • n
  • p
  • s
  • t
Here is a list of all typedefs with links to the files they belong to:

- p -

  • PNV_EVENT_REGISTER_CALLBACK : nvapi.h
  • PNV_MULTIGPU_CAPS : nvapi.h
  • PNV_MULTIGPU_CAPS_V1 : nvapi.h
  • PNV_MULTIGPU_CAPS_V2 : nvapi.h


  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • i
  • n
  • p
  • s
  • t
Here is a list of all typedefs with links to the files they belong to:

- s -

  • SettingDWORDNameString : NvApiDriverSettings.h
  • SettingWSTRINGNameString : NvApiDriverSettings.h
  • StereoHandle : nvapi_lite_common.h


  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • i
  • n
  • p
  • s
  • t
Here is a list of all typedefs with links to the files they belong to:

- t -

  • temp_NvU32 : nvapi_lite_common.h


  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • e
  • n
Here is a list of all enums with links to the files they belong to:

- _ -

  • _IMPLICIT_SLI_CONTROL : nvapi.h
  • _NV_ADAPTER_TYPE : nvapi.h
  • _NV_BPC : nvapi.h
  • _NV_COLOR_SELECTION_POLICY : nvapi.h
  • _NV_COLORSPACE_TYPE : nvapi.h
  • _NV_COMPUTE_SHADER_DERIVATIVES : nvapi.h
  • _NV_D3D11_FEATURE : nvapi.h
  • _NV_D3D12_WORKSTATION_FEATURE_TYPE : nvapi.h
  • _NV_DESKTOP_COLOR_DEPTH : nvapi.h
  • _NV_DISPLAY_OUTPUT_MODE : nvapi.h
  • _NV_DISPLAY_TV_FORMAT : nvapi.h
  • _NV_DISPLAYCONFIG_FLAGS : nvapi.h
  • _NV_DISPLAYCONFIG_SPANNING_ORIENTATION : nvapi.h
  • _NV_DP_BPC : nvapi.h
  • _NV_DP_COLOR_FORMAT : nvapi.h
  • _NV_DP_COLORIMETRY : nvapi.h
  • _NV_DP_DYNAMIC_RANGE : nvapi.h
  • _NV_DP_LANE_COUNT : nvapi.h
  • _NV_DP_LINK_RATE : nvapi.h
  • _NV_DYNAMIC_RANGE : nvapi.h
  • _NV_ECC_CONFIGURATION : nvapi.h
  • _NV_FASTGS_FLAGS : nvapi.h
  • _NV_FORMAT : nvapi.h
  • _NV_FOVEATED_RENDERING_FOVEATION_PATTERN_PRESET : nvapi.h
  • _NV_FOVEATED_RENDERING_SHADING_RATE_PRESET : nvapi.h
  • _NV_FrustumAdjustMode : nvapi.h
  • _NV_GAZE_DATA_TYPE : nvapi.h
  • _NV_GAZE_DATA_VALIDITY_FLAGS : nvapi.h
  • _NV_GPU_ARCH_IMPLEMENTATION_ID : nvapi.h
  • _NV_GPU_ARCHITECTURE_ID : nvapi.h
  • _NV_GPU_BUS_TYPE : nvapi.h
  • _NV_GPU_CHIP_REVISION : nvapi.h
  • _NV_GPU_CLIENT_UTIL_DOMAIN_ID : nvapi.h
  • _NV_GPU_CONNECTOR_TYPE : nvapi.h
  • _NV_GPU_HDCP_FUSE_STATE : nvapi.h
  • _NV_GPU_HDCP_KEY_SOURCE : nvapi.h
  • _NV_GPU_HDCP_KEY_SOURCE_STATE : nvapi.h
  • _NV_GPU_ILLUMINATION_ATTRIB : nvapi.h
  • _NV_GPU_OUTPUT_TYPE : nvapi.h
  • _NV_GPU_PERF_PSTATE_ID : nvapi.h
  • _NV_GPU_PERF_VOLTAGE_INFO_DOMAIN_ID : nvapi.h
  • _NV_GPU_PUBLIC_CLOCK_ID : nvapi.h
  • _NV_GPU_TYPE : nvapi.h
  • _NV_GPU_WORKSTATION_FEATURE_TYPE : nvapi.h
  • _NV_HDR_TONEMAPPING_METHOD : nvapi.h
  • _NV_LICENSE_FEATURE_TYPE : nvapi.h
  • _NV_PIXEL_SHIFT_TYPE : nvapi.h
  • _NV_PRESENT_BARRIER_SYNC_MODE : nvapi.h
  • _NV_PSO_EXTENSION : nvapi.h
  • _NV_RESOLVE_MODE : nvapi.h
  • _NV_ROTATE : nvapi.h
  • _NV_SCALING : nvapi.h
  • _NV_SMP_ASSIST_EYE_INDEX : nvapi.h
  • _NV_SRRV_DIMENSION : nvapi.h
  • _NV_STEREO_VIDEO_FORMAT : nvapi.h
  • _NV_StereoActiveEye : nvapi_lite_stereo.h
  • _NV_StereoDriverMode : nvapi_lite_stereo.h
  • _NV_StereoRegistryID : nvapi.h
  • _NV_StereoRegistryProfileType : nvapi.h
  • _NV_StereoSwapChainMode : nvapi.h
  • _NV_SWIZZLE_MODE : nvapi.h
  • _NV_SWIZZLE_OFFSET : nvapi.h
  • _NV_TARGET_VIEW_MODE : nvapi.h
  • _NV_TIMING_OVERRIDE : nvapi.h
  • _NV_VIRTUALIZATION_MODE : nvapi.h
  • _NV_VRS_CONTENT_TYPE : nvapi.h
  • _NV_VRS_RENDER_MODE : nvapi.h
  • _NVAPI_ANSEL_FEATURE : nvapi.h
  • _NVAPI_ANSEL_FEATURE_STATE : nvapi.h
  • _NVAPI_ANSEL_HOTKEY_MODIFIER : nvapi.h
  • _NVAPI_D3D11_INSERTWFI_FLAG : nvapi.h
  • _NVAPI_D3D12_GET_CUDA_INDEPENDENT_DESCRIPTOR_OBJECT_TYPE : nvapi.h
  • _NVAPI_D3D12_PIPELINE_CREATION_STATE_FLAGS : nvapi.h
  • _NVAPI_D3D12_RAYTRACING_ACCELERATION_STRUCTURE_BUILD_FLAGS_EX : nvapi.h
  • _NVAPI_D3D12_RAYTRACING_CAPS_TYPE : nvapi.h
  • _NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_BUILD_FLAGS : nvapi.h
  • _NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_POSTBUILD_INFO_TYPE : nvapi.h
  • _NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_CAPS : nvapi.h
  • _NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_FORMAT : nvapi.h
  • _NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_PRIMITIVE_FLAGS : nvapi.h
  • _NVAPI_D3D12_RAYTRACING_GEOMETRY_TYPE_EX : nvapi.h
  • _NVAPI_D3D12_RAYTRACING_INSTANCE_FLAGS_EX : nvapi.h
  • _NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_ARRAY_BUILD_FLAGS : nvapi.h
  • _NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_ARRAY_POSTBUILD_INFO_TYPE : nvapi.h
  • _NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_CAPS : nvapi.h
  • _NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_FORMAT : nvapi.h
  • _NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_SPECIAL_INDEX : nvapi.h
  • _NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_STATE : nvapi.h
  • _NVAPI_D3D12_RAYTRACING_THREAD_REORDERING_CAPS : nvapi.h
  • _NVAPI_D3D12_RAYTRACING_VALIDATION_FLAGS : nvapi.h
  • _NVAPI_D3D12_RAYTRACING_VALIDATION_MESSAGE_SEVERITY : nvapi.h
  • _NVAPI_D3D12_SERIALIZED_DATA_TYPE_EX : nvapi.h
  • _NVAPI_D3D_RESOURCERENDERING_FLAG : nvapi_lite_sli.h
  • _NVAPI_D3D_SETRESOURCEHINT_CATEGORY : nvapi_lite_sli.h
  • _NVAPI_D3D_SETRESOURCEHINT_SLI : nvapi_lite_sli.h
  • _NVAPI_GPU_PERF_DECREASE : nvapi.h
  • _NVAPI_GSYNC_DELAY_TYPE : nvapi.h
  • _NVAPI_GSYNC_DISPLAY_SYNC_STATE : nvapi.h
  • _NVAPI_GSYNC_GPU_TOPOLOGY_CONNECTOR : nvapi.h
  • _NVAPI_GSYNC_MULTIPLY_DIVIDE_MODE : nvapi.h
  • _NVAPI_GSYNC_POLARITY : nvapi.h
  • _NVAPI_GSYNC_RJ45_IO : nvapi.h
  • _NVAPI_GSYNC_SYNC_SOURCE : nvapi.h
  • _NVAPI_GSYNC_VIDEO_MODE : nvapi.h
  • _NVAPI_NVLINK_DEVICE_INFO_DEVICE_TYPE : nvapi.h
  • _NVAPI_NVLINK_STATUS_LINK_STATE : nvapi.h
  • _NVAPI_NVLINK_STATUS_SUBLINK_RX_STATE : nvapi.h
  • _NVAPI_NVLINK_STATUS_SUBLINK_TX_STATE : nvapi.h
  • _NVAPI_RAY_FLAGS_EX : nvapi.h
  • _NvAPI_Status : nvapi_lite_common.h
  • _NVAPI_STEREO_INIT_ACTIVATION_FLAGS : nvapi.h
  • _NVAPI_STEREO_SURFACECREATEMODE : nvapi_lite_stereo.h
  • _NVDRS_SETTING_LOCATION : nvapi.h
  • _NVDRS_SETTING_TYPE : nvapi.h
  • _NVVIOANCPARITYCOMPUTATION : nvapi.h
  • _NVVIOBITSPERCOMPONENT : nvapi.h
  • _NVVIOCAPTURESTATUS : nvapi.h
  • _NVVIOCOLORSPACE : nvapi.h
  • _NVVIOCOMPONENTSAMPLING : nvapi.h
  • _NVVIOCOMPSYNCTYPE : nvapi.h
  • _NVVIOCONFIGTYPE : nvapi.h
  • _NVVIODATAFORMAT : nvapi.h
  • _NVVIOINPUTOUTPUTSTATUS : nvapi.h
  • _NVVIOINTERLACEMODE : nvapi.h
  • _NVVIOLINKID : nvapi.h
  • _NVVIOOUTPUTAREA : nvapi.h
  • _NVVIOOWNERTYPE : nvapi.h
  • _NVVIOPCILINKRATE : nvapi.h
  • _NVVIOPCILINKWIDTH : nvapi.h
  • _NVVIOSIGNALFORMAT : nvapi.h
  • _NVVIOSTATUSTYPE : nvapi.h
  • _NVVIOSYNCSOURCE : nvapi.h
  • _NVVIOSYNCSTATUS : nvapi.h
  • _NVVIOVIDEOSTANDARD : nvapi.h
  • _NVVIOVIDEOTYPE : nvapi.h


  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • e
  • n
Here is a list of all enums with links to the files they belong to:

- e -

  • ESetting : NvApiDriverSettings.h
  • EValues_AA_BEHAVIOR_FLAGS : NvApiDriverSettings.h
  • EValues_AA_MODE_ALPHATOCOVERAGE : NvApiDriverSettings.h
  • EValues_AA_MODE_GAMMACORRECTION : NvApiDriverSettings.h
  • EValues_AA_MODE_METHOD : NvApiDriverSettings.h
  • EValues_AA_MODE_REPLAY : NvApiDriverSettings.h
  • EValues_AA_MODE_SELECTOR : NvApiDriverSettings.h
  • EValues_AA_MODE_SELECTOR_SLIAA : NvApiDriverSettings.h
  • EValues_ANISO_MODE_LEVEL : NvApiDriverSettings.h
  • EValues_ANISO_MODE_SELECTOR : NvApiDriverSettings.h
  • EValues_ANSEL_ALLOW : NvApiDriverSettings.h
  • EValues_ANSEL_ALLOWLISTED : NvApiDriverSettings.h
  • EValues_ANSEL_ENABLE : NvApiDriverSettings.h
  • EValues_AO_MODE : NvApiDriverSettings.h
  • EValues_AO_MODE_ACTIVE : NvApiDriverSettings.h
  • EValues_APPLICATION_PROFILE_NOTIFICATION_TIMEOUT : NvApiDriverSettings.h
  • EValues_AUTO_LODBIASADJUST : NvApiDriverSettings.h
  • EValues_BATTERY_BOOST_APP_FPS : NvApiDriverSettings.h
  • EValues_CPL_HIDDEN_PROFILE : NvApiDriverSettings.h
  • EValues_EXPORT_PERF_COUNTERS : NvApiDriverSettings.h
  • EValues_EXPORT_PERF_COUNTERS_DX9_ONLY : NvApiDriverSettings.h
  • EValues_EXTERNAL_QUIET_MODE : NvApiDriverSettings.h
  • EValues_FRL_FPS : NvApiDriverSettings.h
  • EValues_FXAA_ALLOW : NvApiDriverSettings.h
  • EValues_FXAA_ENABLE : NvApiDriverSettings.h
  • EValues_FXAA_INDICATOR_ENABLE : NvApiDriverSettings.h
  • EValues_LATENCY_INDICATOR_AUTOALIGN : NvApiDriverSettings.h
  • EValues_LODBIASADJUST : NvApiDriverSettings.h
  • EValues_MAXWELL_B_SAMPLE_INTERLEAVE : NvApiDriverSettings.h
  • EValues_MCSFRSHOWSPLIT : NvApiDriverSettings.h
  • EValues_NV_QUALITY_UPSCALING : NvApiDriverSettings.h
  • EValues_OGL_AA_LINE_GAMMA : NvApiDriverSettings.h
  • EValues_OGL_CPL_GDI_COMPATIBILITY : NvApiDriverSettings.h
  • EValues_OGL_CPL_PREFER_DXPRESENT : NvApiDriverSettings.h
  • EValues_OGL_DEEP_COLOR_SCANOUT : NvApiDriverSettings.h
  • EValues_OGL_DEFAULT_SWAP_INTERVAL : NvApiDriverSettings.h
  • EValues_OGL_DEFAULT_SWAP_INTERVAL_FRACTIONAL : NvApiDriverSettings.h
  • EValues_OGL_DEFAULT_SWAP_INTERVAL_SIGN : NvApiDriverSettings.h
  • EValues_OGL_EVENT_LOG_SEVERITY_THRESHOLD : NvApiDriverSettings.h
  • EValues_OGL_FORCE_BLIT : NvApiDriverSettings.h
  • EValues_OGL_FORCE_STEREO : NvApiDriverSettings.h
  • EValues_OGL_OVERLAY_PIXEL_TYPE : NvApiDriverSettings.h
  • EValues_OGL_OVERLAY_SUPPORT : NvApiDriverSettings.h
  • EValues_OGL_QUALITY_ENHANCEMENTS : NvApiDriverSettings.h
  • EValues_OGL_SINGLE_BACKDEPTH_BUFFER : NvApiDriverSettings.h
  • EValues_OGL_SLI_MULTICAST : NvApiDriverSettings.h
  • EValues_OGL_THREAD_CONTROL : NvApiDriverSettings.h
  • EValues_OGL_TMON_LEVEL : NvApiDriverSettings.h
  • EValues_OGL_TRIPLE_BUFFER : NvApiDriverSettings.h
  • EValues_OPTIMUS_MAXAA : NvApiDriverSettings.h
  • EValues_PHYSXINDICATOR : NvApiDriverSettings.h
  • EValues_PREFERRED_PSTATE : NvApiDriverSettings.h
  • EValues_PRERENDERLIMIT : NvApiDriverSettings.h
  • EValues_PREVENT_UI_AF_OVERRIDE : NvApiDriverSettings.h
  • EValues_PS_SHADERDISKCACHE : NvApiDriverSettings.h
  • EValues_PS_SHADERDISKCACHE_MAX_SIZE : NvApiDriverSettings.h
  • EValues_PS_TEXFILTER_ANISO_OPTS2 : NvApiDriverSettings.h
  • EValues_PS_TEXFILTER_BILINEAR_IN_ANISO : NvApiDriverSettings.h
  • EValues_PS_TEXFILTER_DISABLE_TRILIN_SLOPE : NvApiDriverSettings.h
  • EValues_PS_TEXFILTER_NO_NEG_LODBIAS : NvApiDriverSettings.h
  • EValues_QUALITY_ENHANCEMENT_SUBSTITUTION : NvApiDriverSettings.h
  • EValues_QUALITY_ENHANCEMENTS : NvApiDriverSettings.h
  • EValues_REFRESH_RATE_OVERRIDE : NvApiDriverSettings.h
  • EValues_SET_POWER_THROTTLE_FOR_PCIe_COMPLIANCE : NvApiDriverSettings.h
  • EValues_SET_VAB_DATA : NvApiDriverSettings.h
  • EValues_SHIM_MCCOMPAT : NvApiDriverSettings.h
  • EValues_SHIM_RENDERING_MODE : NvApiDriverSettings.h
  • EValues_SHIM_RENDERING_OPTIONS : NvApiDriverSettings.h
  • EValues_SLI_GPU_COUNT : NvApiDriverSettings.h
  • EValues_SLI_PREDEFINED_GPU_COUNT : NvApiDriverSettings.h
  • EValues_SLI_PREDEFINED_GPU_COUNT_DX10 : NvApiDriverSettings.h
  • EValues_SLI_PREDEFINED_MODE : NvApiDriverSettings.h
  • EValues_SLI_PREDEFINED_MODE_DX10 : NvApiDriverSettings.h
  • EValues_SLI_RENDERING_MODE : NvApiDriverSettings.h
  • EValues_VRPRERENDERLIMIT : NvApiDriverSettings.h
  • EValues_VRR_APP_OVERRIDE : NvApiDriverSettings.h
  • EValues_VRR_APP_OVERRIDE_REQUEST_STATE : NvApiDriverSettings.h
  • EValues_VRR_MODE : NvApiDriverSettings.h
  • EValues_VRRFEATUREINDICATOR : NvApiDriverSettings.h
  • EValues_VRROVERLAYINDICATOR : NvApiDriverSettings.h
  • EValues_VRRREQUESTSTATE : NvApiDriverSettings.h
  • EValues_VSYNC_BEHAVIOR_FLAGS : NvApiDriverSettings.h
  • EValues_VSYNCMODE : NvApiDriverSettings.h
  • EValues_VSYNCSMOOTHAFR : NvApiDriverSettings.h
  • EValues_VSYNCTEARCONTROL : NvApiDriverSettings.h
  • EValues_VSYNCVRRCONTROL : NvApiDriverSettings.h
  • EValues_WKS_API_STEREO_EYES_EXCHANGE : NvApiDriverSettings.h
  • EValues_WKS_API_STEREO_MODE : NvApiDriverSettings.h
  • EValues_WKS_STEREO_DONGLE_SUPPORT : NvApiDriverSettings.h
  • EValues_WKS_STEREO_SUPPORT : NvApiDriverSettings.h
  • EValues_WKS_STEREO_SWAP_MODE : NvApiDriverSettings.h


  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • e
  • n
Here is a list of all enums with links to the files they belong to:

- n -

  • NV_CHIPSET_INFO_FLAGS : nvapi.h
  • NV_COLOR_CMD : nvapi.h
  • NV_COLOR_COLORIMETRY : nvapi.h
  • NV_COLOR_FORMAT : nvapi.h
  • NV_CUSTOM_SEMANTIC_TYPE : nvapi.h
  • NV_D3D12_HEAP_FLAGS : nvapi.h
  • NV_D3D12_RESOURCE_FLAGS : nvapi.h
  • NV_D3D_GRAPHICS_STATES : nvapi.h
  • NV_EDID_FLAG : nvapi.h
  • NV_EVENT_TYPE : nvapi.h
  • NV_GPU_CLIENT_ILLUM_CTRL_MODE : nvapi.h
  • NV_GPU_CLIENT_ILLUM_DEVICE_TYPE : nvapi.h
  • NV_GPU_CLIENT_ILLUM_PIECEWISE_LINEAR_CYCLE_TYPE : nvapi.h
  • NV_GPU_CLIENT_ILLUM_ZONE_LOCATION : nvapi.h
  • NV_GPU_CLIENT_ILLUM_ZONE_TYPE : nvapi.h
  • NV_GPU_CLOCK_FREQUENCIES_CLOCK_TYPE : nvapi.h
  • NV_GPU_PERF_PSTATE20_CLOCK_TYPE_ID : nvapi.h
  • NV_GPU_SCANOUT_COMPOSITION_PARAMETER : nvapi.h
  • NV_GPU_SCANOUT_COMPOSITION_PARAMETER_VALUE : nvapi.h
  • NV_GPU_WARPING_VERTICE_FORMAT : nvapi.h
  • NV_HDR_CMD : nvapi.h
  • NV_HDR_MODE : nvapi.h
  • NV_I2C_SPEED : nvapi.h
  • NV_INFOFRAME_CMD : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELCOUNT : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_DOWNMIX : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_LFEPLAYBACKLEVEL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_SAMPLEFREQUENCY : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_SAMPLESIZE : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_ACTIVEFORMATINFO : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOCODEDFRAME : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_BARDATA : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_COLORFORMAT : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_COLORIMETRY : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_CONTENTTYPE : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_EXTENDEDCOLORIMETRY : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_F17 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_ITC : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_NONUNIFORMPICTURESCALING : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_RGBQUANTIZATION : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_SCANINFO : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_YCCQUANTIZATION : nvapi.h
  • NV_INFOFRAME_PROPERTY_BLACKLIST : nvapi.h
  • NV_INFOFRAME_PROPERTY_MODE : nvapi.h
  • NV_LATENCY_MARKER_TYPE : nvapi.h
  • NV_LMS_CONFIG : nvapi.h
  • NV_META_COMMAND_ACTIVATION_FUNCTION : nvapi.h
  • NV_META_COMMAND_CONVOLUTION_DIRECTION : nvapi.h
  • NV_META_COMMAND_CONVOLUTION_MODE : nvapi.h
  • NV_META_COMMAND_CONVOLUTION_POOL_MODE : nvapi.h
  • NV_META_COMMAND_CONVOLUTION_SKIP_MODE : nvapi.h
  • NV_META_COMMAND_CONVOLUTION_UPSAMPLE_MODE : nvapi.h
  • NV_META_COMMAND_MATRIX_TRANSFORM : nvapi.h
  • NV_META_COMMAND_PADDING_MODE : nvapi.h
  • NV_META_COMMAND_PRECISION : nvapi.h
  • NV_META_COMMAND_RESOURCE_TYPE : nvapi.h
  • NV_META_COMMAND_TENSOR_DATA_TYPE : nvapi.h
  • NV_META_COMMAND_TENSOR_FLAGS : nvapi.h
  • NV_META_COMMAND_TENSOR_LAYOUT : nvapi.h
  • NV_MONITOR_CAPS_TYPE : nvapi.h
  • NV_MONITOR_CONN_TYPE : nvapi.h
  • NV_MOSAIC_TOPO : nvapi.h
  • NV_MOSAIC_TOPO_TYPE : nvapi.h
  • NV_MRS_CONFIG : nvapi.h
  • NV_OUT_OF_BAND_CQ_TYPE : nvapi.h
  • NV_PIXEL_SHADING_RATE : nvapi.h
  • NV_QSYNC_EVENT : nvapi.h
  • NV_SMP_ASSIST_LEVEL : nvapi.h
  • NV_SMP_ASSIST_TYPE : nvapi.h
  • NV_STATIC_METADATA_DESCRIPTOR_ID : nvapi.h
  • NV_SYSTEM_TYPE : nvapi.h
  • NV_THERMAL_CONTROLLER : nvapi.h
  • NV_THERMAL_TARGET : nvapi.h
  • NVAPI_ALIAS_SURFACE_FLAG : nvapi.h
  • NVAPI_DEVICE_FEATURE_LEVEL : nvapi_lite_d3dext.h
  • NVAPI_GPU_WORKSTATION_FEATURE_MASK : nvapi.h
  • NVAPI_QUAD_FILLMODE : nvapi.h
  • NVAPI_VSYNC_MODE : nvapi.h


  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • a
  • b
  • c
  • d
  • e
  • f
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • v
  • w
Here is a list of all enum values with links to the files they belong to:

- a -

  • AA_BEHAVIOR_FLAGS_AA_RT_BPP_DIV_4 : NvApiDriverSettings.h
  • AA_BEHAVIOR_FLAGS_AA_RT_BPP_DIV_4_SHIFT : NvApiDriverSettings.h
  • AA_BEHAVIOR_FLAGS_DEFAULT : NvApiDriverSettings.h
  • AA_BEHAVIOR_FLAGS_DISABLE_CPLAA : NvApiDriverSettings.h
  • AA_BEHAVIOR_FLAGS_DISABLE_ENHANCE : NvApiDriverSettings.h
  • AA_BEHAVIOR_FLAGS_DISABLE_OVERRIDE : NvApiDriverSettings.h
  • AA_BEHAVIOR_FLAGS_DISABLE_SLIAA : NvApiDriverSettings.h
  • AA_BEHAVIOR_FLAGS_ID : NvApiDriverSettings.h
  • AA_BEHAVIOR_FLAGS_MAP_VCAA_TO_MULTISAMPLING : NvApiDriverSettings.h
  • AA_BEHAVIOR_FLAGS_MASK : NvApiDriverSettings.h
  • AA_BEHAVIOR_FLAGS_NON_AA_RT_BPP_DIV_4 : NvApiDriverSettings.h
  • AA_BEHAVIOR_FLAGS_NON_AA_RT_BPP_DIV_4_SHIFT : NvApiDriverSettings.h
  • AA_BEHAVIOR_FLAGS_NONE : NvApiDriverSettings.h
  • AA_BEHAVIOR_FLAGS_NUM_VALUES : NvApiDriverSettings.h
  • AA_BEHAVIOR_FLAGS_SKIP_RT_DIM_CHECK_FOR_ENHANCE : NvApiDriverSettings.h
  • AA_BEHAVIOR_FLAGS_SLI_DISABLE_TRANSPARENCY_SUPERSAMPLING : NvApiDriverSettings.h
  • AA_BEHAVIOR_FLAGS_TREAT_ENHANCE_AS_APP_CONTROLLED : NvApiDriverSettings.h
  • AA_BEHAVIOR_FLAGS_TREAT_ENHANCE_AS_OVERRIDE : NvApiDriverSettings.h
  • AA_BEHAVIOR_FLAGS_TREAT_OVERRIDE_AS_APP_CONTROLLED : NvApiDriverSettings.h
  • AA_BEHAVIOR_FLAGS_TREAT_OVERRIDE_AS_ENHANCE : NvApiDriverSettings.h
  • AA_MODE_ALPHATOCOVERAGE_DEFAULT : NvApiDriverSettings.h
  • AA_MODE_ALPHATOCOVERAGE_ID : NvApiDriverSettings.h
  • AA_MODE_ALPHATOCOVERAGE_MODE_MASK : NvApiDriverSettings.h
  • AA_MODE_ALPHATOCOVERAGE_MODE_MAX : NvApiDriverSettings.h
  • AA_MODE_ALPHATOCOVERAGE_MODE_OFF : NvApiDriverSettings.h
  • AA_MODE_ALPHATOCOVERAGE_MODE_ON : NvApiDriverSettings.h
  • AA_MODE_ALPHATOCOVERAGE_NUM_VALUES : NvApiDriverSettings.h
  • AA_MODE_GAMMACORRECTION_DEFAULT : NvApiDriverSettings.h
  • AA_MODE_GAMMACORRECTION_DEFAULT_FERMI : NvApiDriverSettings.h
  • AA_MODE_GAMMACORRECTION_DEFAULT_TESLA : NvApiDriverSettings.h
  • AA_MODE_GAMMACORRECTION_ID : NvApiDriverSettings.h
  • AA_MODE_GAMMACORRECTION_MASK : NvApiDriverSettings.h
  • AA_MODE_GAMMACORRECTION_MAX : NvApiDriverSettings.h
  • AA_MODE_GAMMACORRECTION_NUM_VALUES : NvApiDriverSettings.h
  • AA_MODE_GAMMACORRECTION_OFF : NvApiDriverSettings.h
  • AA_MODE_GAMMACORRECTION_ON_ALWAYS : NvApiDriverSettings.h
  • AA_MODE_GAMMACORRECTION_ON_IF_FOS : NvApiDriverSettings.h
  • AA_MODE_METHOD_6X_CT : NvApiDriverSettings.h
  • AA_MODE_METHOD_CORRUPTION_CHECK : NvApiDriverSettings.h
  • AA_MODE_METHOD_COUNT : NvApiDriverSettings.h
  • AA_MODE_METHOD_DEFAULT : NvApiDriverSettings.h
  • AA_MODE_METHOD_FREE_0x03 : NvApiDriverSettings.h
  • AA_MODE_METHOD_FREE_0x04 : NvApiDriverSettings.h
  • AA_MODE_METHOD_FREE_0x08 : NvApiDriverSettings.h
  • AA_MODE_METHOD_FREE_0x09 : NvApiDriverSettings.h
  • AA_MODE_METHOD_FREE_0x11 : NvApiDriverSettings.h
  • AA_MODE_METHOD_FREE_0x14 : NvApiDriverSettings.h
  • AA_MODE_METHOD_FREE_0x15 : NvApiDriverSettings.h
  • AA_MODE_METHOD_ID : NvApiDriverSettings.h
  • AA_MODE_METHOD_METHOD_MASK : NvApiDriverSettings.h
  • AA_MODE_METHOD_METHOD_MAX : NvApiDriverSettings.h
  • AA_MODE_METHOD_MIXEDSAMPLE_128X : NvApiDriverSettings.h
  • AA_MODE_METHOD_MIXEDSAMPLE_16X : NvApiDriverSettings.h
  • AA_MODE_METHOD_MIXEDSAMPLE_32X : NvApiDriverSettings.h
  • AA_MODE_METHOD_MIXEDSAMPLE_4X_SKEWED_4TAP : NvApiDriverSettings.h
  • AA_MODE_METHOD_MIXEDSAMPLE_64X : NvApiDriverSettings.h
  • AA_MODE_METHOD_MIXEDSAMPLE_6X : NvApiDriverSettings.h
  • AA_MODE_METHOD_MIXEDSAMPLE_6X_SKEWED_6TAP : NvApiDriverSettings.h
  • AA_MODE_METHOD_MIXEDSAMPLE_8X : NvApiDriverSettings.h
  • AA_MODE_METHOD_MIXEDSAMPLE_8X_SKEWED_8TAP : NvApiDriverSettings.h
  • AA_MODE_METHOD_MULTISAMPLE_16X : NvApiDriverSettings.h
  • AA_MODE_METHOD_MULTISAMPLE_2X_DIAGONAL : NvApiDriverSettings.h
  • AA_MODE_METHOD_MULTISAMPLE_2X_DIAGONAL_FOSGAMMA : NvApiDriverSettings.h
  • AA_MODE_METHOD_MULTISAMPLE_2X_DIAGONAL_GAMMA : NvApiDriverSettings.h
  • AA_MODE_METHOD_MULTISAMPLE_2X_QUINCUNX : NvApiDriverSettings.h
  • AA_MODE_METHOD_MULTISAMPLE_4X : NvApiDriverSettings.h
  • AA_MODE_METHOD_MULTISAMPLE_4X_FOSGAMMA : NvApiDriverSettings.h
  • AA_MODE_METHOD_MULTISAMPLE_4X_GAMMA : NvApiDriverSettings.h
  • AA_MODE_METHOD_MULTISAMPLE_4X_GAUSSIAN : NvApiDriverSettings.h
  • AA_MODE_METHOD_MULTISAMPLE_8X : NvApiDriverSettings.h
  • AA_MODE_METHOD_NONE : NvApiDriverSettings.h
  • AA_MODE_METHOD_NUM_VALUES : NvApiDriverSettings.h
  • AA_MODE_METHOD_SUPERSAMPLE_16X : NvApiDriverSettings.h
  • AA_MODE_METHOD_SUPERSAMPLE_16X_BIAS : NvApiDriverSettings.h
  • AA_MODE_METHOD_SUPERSAMPLE_1_5X1_5 : NvApiDriverSettings.h
  • AA_MODE_METHOD_SUPERSAMPLE_2X_H : NvApiDriverSettings.h
  • AA_MODE_METHOD_SUPERSAMPLE_2X_V : NvApiDriverSettings.h
  • AA_MODE_METHOD_SUPERSAMPLE_4X : NvApiDriverSettings.h
  • AA_MODE_METHOD_SUPERSAMPLE_4X_BIAS : NvApiDriverSettings.h
  • AA_MODE_METHOD_SUPERSAMPLE_4X_FOSGAMMA : NvApiDriverSettings.h
  • AA_MODE_METHOD_SUPERSAMPLE_4X_GAMMA : NvApiDriverSettings.h
  • AA_MODE_METHOD_SUPERSAMPLE_4X_GAUSSIAN : NvApiDriverSettings.h
  • AA_MODE_METHOD_SUPERSAMPLE_9X : NvApiDriverSettings.h
  • AA_MODE_METHOD_SUPERSAMPLE_9X_BIAS : NvApiDriverSettings.h
  • AA_MODE_METHOD_SUPERVCAA_64X_4v12 : NvApiDriverSettings.h
  • AA_MODE_METHOD_SUPERVCAA_64X_8v8 : NvApiDriverSettings.h
  • AA_MODE_METHOD_VCAA_16X_4v12 : NvApiDriverSettings.h
  • AA_MODE_METHOD_VCAA_16X_8v8 : NvApiDriverSettings.h
  • AA_MODE_METHOD_VCAA_32X_8v24 : NvApiDriverSettings.h
  • AA_MODE_METHOD_VCAA_8X_4v4 : NvApiDriverSettings.h
  • AA_MODE_REPLAY_DEFAULT : NvApiDriverSettings.h
  • AA_MODE_REPLAY_DISALLOW_TRAA : NvApiDriverSettings.h
  • AA_MODE_REPLAY_ID : NvApiDriverSettings.h
  • AA_MODE_REPLAY_MASK : NvApiDriverSettings.h
  • AA_MODE_REPLAY_MODE_ALL : NvApiDriverSettings.h
  • AA_MODE_REPLAY_MODE_ALPHA_TEST : NvApiDriverSettings.h
  • AA_MODE_REPLAY_MODE_DYN_BRANCH : NvApiDriverSettings.h
  • AA_MODE_REPLAY_MODE_MASK : NvApiDriverSettings.h
  • AA_MODE_REPLAY_MODE_MAX : NvApiDriverSettings.h
  • AA_MODE_REPLAY_MODE_OFF : NvApiDriverSettings.h
  • AA_MODE_REPLAY_MODE_OPTIMAL : NvApiDriverSettings.h
  • AA_MODE_REPLAY_MODE_PIXEL_KILL : NvApiDriverSettings.h
  • AA_MODE_REPLAY_NUM_VALUES : NvApiDriverSettings.h
  • AA_MODE_REPLAY_SAMPLES_EIGHT : NvApiDriverSettings.h
  • AA_MODE_REPLAY_SAMPLES_FOUR : NvApiDriverSettings.h
  • AA_MODE_REPLAY_SAMPLES_MASK : NvApiDriverSettings.h
  • AA_MODE_REPLAY_SAMPLES_MAX : NvApiDriverSettings.h
  • AA_MODE_REPLAY_SAMPLES_ONE : NvApiDriverSettings.h
  • AA_MODE_REPLAY_SAMPLES_TWO : NvApiDriverSettings.h
  • AA_MODE_REPLAY_TRANSPARENCY : NvApiDriverSettings.h
  • AA_MODE_REPLAY_TRANSPARENCY_DEFAULT : NvApiDriverSettings.h
  • AA_MODE_REPLAY_TRANSPARENCY_DEFAULT_FERMI : NvApiDriverSettings.h
  • AA_MODE_REPLAY_TRANSPARENCY_DEFAULT_TESLA : NvApiDriverSettings.h
  • AA_MODE_SELECTOR_APP_CONTROL : NvApiDriverSettings.h
  • AA_MODE_SELECTOR_DEFAULT : NvApiDriverSettings.h
  • AA_MODE_SELECTOR_ENHANCE : NvApiDriverSettings.h
  • AA_MODE_SELECTOR_ID : NvApiDriverSettings.h
  • AA_MODE_SELECTOR_MASK : NvApiDriverSettings.h
  • AA_MODE_SELECTOR_MAX : NvApiDriverSettings.h
  • AA_MODE_SELECTOR_NUM_VALUES : NvApiDriverSettings.h
  • AA_MODE_SELECTOR_OVERRIDE : NvApiDriverSettings.h
  • AA_MODE_SELECTOR_SLIAA_DEFAULT : NvApiDriverSettings.h
  • AA_MODE_SELECTOR_SLIAA_DISABLED : NvApiDriverSettings.h
  • AA_MODE_SELECTOR_SLIAA_ENABLED : NvApiDriverSettings.h
  • AA_MODE_SELECTOR_SLIAA_ID : NvApiDriverSettings.h
  • AA_MODE_SELECTOR_SLIAA_NUM_VALUES : NvApiDriverSettings.h
  • ANISO_MODE_LEVEL_DEFAULT : NvApiDriverSettings.h
  • ANISO_MODE_LEVEL_ID : NvApiDriverSettings.h
  • ANISO_MODE_LEVEL_MASK : NvApiDriverSettings.h
  • ANISO_MODE_LEVEL_MAX : NvApiDriverSettings.h
  • ANISO_MODE_LEVEL_NONE_LINEAR : NvApiDriverSettings.h
  • ANISO_MODE_LEVEL_NONE_POINT : NvApiDriverSettings.h
  • ANISO_MODE_LEVEL_NUM_VALUES : NvApiDriverSettings.h
  • ANISO_MODE_SELECTOR_APP : NvApiDriverSettings.h
  • ANISO_MODE_SELECTOR_COND : NvApiDriverSettings.h
  • ANISO_MODE_SELECTOR_DEFAULT : NvApiDriverSettings.h
  • ANISO_MODE_SELECTOR_ID : NvApiDriverSettings.h
  • ANISO_MODE_SELECTOR_MASK : NvApiDriverSettings.h
  • ANISO_MODE_SELECTOR_MAX : NvApiDriverSettings.h
  • ANISO_MODE_SELECTOR_NUM_VALUES : NvApiDriverSettings.h
  • ANISO_MODE_SELECTOR_USER : NvApiDriverSettings.h
  • ANSEL_ALLOW_ALLOWED : NvApiDriverSettings.h
  • ANSEL_ALLOW_DEFAULT : NvApiDriverSettings.h
  • ANSEL_ALLOW_DISALLOWED : NvApiDriverSettings.h
  • ANSEL_ALLOW_ID : NvApiDriverSettings.h
  • ANSEL_ALLOW_NUM_VALUES : NvApiDriverSettings.h
  • ANSEL_ALLOWLISTED_ALLOWED : NvApiDriverSettings.h
  • ANSEL_ALLOWLISTED_DEFAULT : NvApiDriverSettings.h
  • ANSEL_ALLOWLISTED_DISALLOWED : NvApiDriverSettings.h
  • ANSEL_ALLOWLISTED_ID : NvApiDriverSettings.h
  • ANSEL_ALLOWLISTED_NUM_VALUES : NvApiDriverSettings.h
  • ANSEL_ENABLE_DEFAULT : NvApiDriverSettings.h
  • ANSEL_ENABLE_ID : NvApiDriverSettings.h
  • ANSEL_ENABLE_NUM_VALUES : NvApiDriverSettings.h
  • ANSEL_ENABLE_OFF : NvApiDriverSettings.h
  • ANSEL_ENABLE_ON : NvApiDriverSettings.h
  • AO_MODE_ACTIVE_DEFAULT : NvApiDriverSettings.h
  • AO_MODE_ACTIVE_DISABLED : NvApiDriverSettings.h
  • AO_MODE_ACTIVE_ENABLED : NvApiDriverSettings.h
  • AO_MODE_ACTIVE_ID : NvApiDriverSettings.h
  • AO_MODE_ACTIVE_NUM_VALUES : NvApiDriverSettings.h
  • AO_MODE_DEFAULT : NvApiDriverSettings.h
  • AO_MODE_HIGH : NvApiDriverSettings.h
  • AO_MODE_ID : NvApiDriverSettings.h
  • AO_MODE_LOW : NvApiDriverSettings.h
  • AO_MODE_MEDIUM : NvApiDriverSettings.h
  • AO_MODE_NUM_VALUES : NvApiDriverSettings.h
  • AO_MODE_OFF : NvApiDriverSettings.h
  • APPIDLE_DYNAMIC_FRL_FPS_ID : NvApiDriverSettings.h
  • APPIDLE_DYNAMIC_FRL_THRESHOLD_TIME_ID : NvApiDriverSettings.h
  • APPLICATION_PROFILE_NOTIFICATION_TIMEOUT_DEFAULT : NvApiDriverSettings.h
  • APPLICATION_PROFILE_NOTIFICATION_TIMEOUT_DISABLED : NvApiDriverSettings.h
  • APPLICATION_PROFILE_NOTIFICATION_TIMEOUT_FIFTEEN_SECONDS : NvApiDriverSettings.h
  • APPLICATION_PROFILE_NOTIFICATION_TIMEOUT_ID : NvApiDriverSettings.h
  • APPLICATION_PROFILE_NOTIFICATION_TIMEOUT_NINE_SECONDS : NvApiDriverSettings.h
  • APPLICATION_PROFILE_NOTIFICATION_TIMEOUT_NUM_VALUES : NvApiDriverSettings.h
  • APPLICATION_PROFILE_NOTIFICATION_TIMEOUT_ONE_MINUTE : NvApiDriverSettings.h
  • APPLICATION_PROFILE_NOTIFICATION_TIMEOUT_THIRTY_SECONDS : NvApiDriverSettings.h
  • APPLICATION_PROFILE_NOTIFICATION_TIMEOUT_TWO_MINUTES : NvApiDriverSettings.h
  • APPLICATION_STEAM_ID_ID : NvApiDriverSettings.h
  • AUTO_LODBIASADJUST_DEFAULT : NvApiDriverSettings.h
  • AUTO_LODBIASADJUST_ID : NvApiDriverSettings.h
  • AUTO_LODBIASADJUST_NUM_VALUES : NvApiDriverSettings.h
  • AUTO_LODBIASADJUST_OFF : NvApiDriverSettings.h
  • AUTO_LODBIASADJUST_ON : NvApiDriverSettings.h


  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • a
  • b
  • c
  • d
  • e
  • f
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • v
  • w
Here is a list of all enum values with links to the files they belong to:

- b -

  • BATTERY_BOOST_APP_FPS_DEFAULT : NvApiDriverSettings.h
  • BATTERY_BOOST_APP_FPS_ID : NvApiDriverSettings.h
  • BATTERY_BOOST_APP_FPS_MAX : NvApiDriverSettings.h
  • BATTERY_BOOST_APP_FPS_MIN : NvApiDriverSettings.h
  • BATTERY_BOOST_APP_FPS_NO_OVERRIDE : NvApiDriverSettings.h
  • BATTERY_BOOST_APP_FPS_NUM_VALUES : NvApiDriverSettings.h


  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • a
  • b
  • c
  • d
  • e
  • f
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • v
  • w
Here is a list of all enum values with links to the files they belong to:

- c -

  • CPL_HIDDEN_PROFILE_DEFAULT : NvApiDriverSettings.h
  • CPL_HIDDEN_PROFILE_DISABLED : NvApiDriverSettings.h
  • CPL_HIDDEN_PROFILE_ENABLED : NvApiDriverSettings.h
  • CPL_HIDDEN_PROFILE_ID : NvApiDriverSettings.h
  • CPL_HIDDEN_PROFILE_NUM_VALUES : NvApiDriverSettings.h
  • CUDA_EXCLUDED_GPUS_ID : NvApiDriverSettings.h


  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • a
  • b
  • c
  • d
  • e
  • f
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • v
  • w
Here is a list of all enum values with links to the files they belong to:

- d -

  • D3DOGL_GPU_MAX_POWER_ID : NvApiDriverSettings.h
  • DISABLE_IMPLICIT_SLI : nvapi.h


  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • a
  • b
  • c
  • d
  • e
  • f
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • v
  • w
Here is a list of all enum values with links to the files they belong to:

- e -

  • ENABLE_IMPLICIT_SLI : nvapi.h
  • EXPORT_PERF_COUNTERS_DEFAULT : NvApiDriverSettings.h
  • EXPORT_PERF_COUNTERS_DX9_ONLY_DEFAULT : NvApiDriverSettings.h
  • EXPORT_PERF_COUNTERS_DX9_ONLY_ID : NvApiDriverSettings.h
  • EXPORT_PERF_COUNTERS_DX9_ONLY_NUM_VALUES : NvApiDriverSettings.h
  • EXPORT_PERF_COUNTERS_DX9_ONLY_OFF : NvApiDriverSettings.h
  • EXPORT_PERF_COUNTERS_DX9_ONLY_ON : NvApiDriverSettings.h
  • EXPORT_PERF_COUNTERS_ID : NvApiDriverSettings.h
  • EXPORT_PERF_COUNTERS_NUM_VALUES : NvApiDriverSettings.h
  • EXPORT_PERF_COUNTERS_OFF : NvApiDriverSettings.h
  • EXPORT_PERF_COUNTERS_ON : NvApiDriverSettings.h
  • EXTERNAL_QUIET_MODE_DEFAULT : NvApiDriverSettings.h
  • EXTERNAL_QUIET_MODE_ID : NvApiDriverSettings.h
  • EXTERNAL_QUIET_MODE_NUM_VALUES : NvApiDriverSettings.h
  • EXTERNAL_QUIET_MODE_OFF : NvApiDriverSettings.h
  • EXTERNAL_QUIET_MODE_ON : NvApiDriverSettings.h


  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • a
  • b
  • c
  • d
  • e
  • f
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • v
  • w
Here is a list of all enum values with links to the files they belong to:

- f -

  • FRL_FPS_DEFAULT : NvApiDriverSettings.h
  • FRL_FPS_DISABLED : NvApiDriverSettings.h
  • FRL_FPS_ID : NvApiDriverSettings.h
  • FRL_FPS_MAX : NvApiDriverSettings.h
  • FRL_FPS_MIN : NvApiDriverSettings.h
  • FRL_FPS_NUM_VALUES : NvApiDriverSettings.h
  • FXAA_ALLOW_ALLOWED : NvApiDriverSettings.h
  • FXAA_ALLOW_DEFAULT : NvApiDriverSettings.h
  • FXAA_ALLOW_DISALLOWED : NvApiDriverSettings.h
  • FXAA_ALLOW_ID : NvApiDriverSettings.h
  • FXAA_ALLOW_NUM_VALUES : NvApiDriverSettings.h
  • FXAA_ENABLE_DEFAULT : NvApiDriverSettings.h
  • FXAA_ENABLE_ID : NvApiDriverSettings.h
  • FXAA_ENABLE_NUM_VALUES : NvApiDriverSettings.h
  • FXAA_ENABLE_OFF : NvApiDriverSettings.h
  • FXAA_ENABLE_ON : NvApiDriverSettings.h
  • FXAA_INDICATOR_ENABLE_DEFAULT : NvApiDriverSettings.h
  • FXAA_INDICATOR_ENABLE_ID : NvApiDriverSettings.h
  • FXAA_INDICATOR_ENABLE_NUM_VALUES : NvApiDriverSettings.h
  • FXAA_INDICATOR_ENABLE_OFF : NvApiDriverSettings.h
  • FXAA_INDICATOR_ENABLE_ON : NvApiDriverSettings.h


  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • a
  • b
  • c
  • d
  • e
  • f
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • v
  • w
Here is a list of all enum values with links to the files they belong to:

- i -

  • ICAFE_LOGO_CONFIG_ID : NvApiDriverSettings.h
  • INPUT_SAMPLE : nvapi.h
  • INVALID_SETTING_ID : NvApiDriverSettings.h


  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • a
  • b
  • c
  • d
  • e
  • f
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • v
  • w
Here is a list of all enum values with links to the files they belong to:

- l -

  • LATENCY_INDICATOR_AUTOALIGN_DEFAULT : NvApiDriverSettings.h
  • LATENCY_INDICATOR_AUTOALIGN_DISABLED : NvApiDriverSettings.h
  • LATENCY_INDICATOR_AUTOALIGN_ENABLED : NvApiDriverSettings.h
  • LATENCY_INDICATOR_AUTOALIGN_ID : NvApiDriverSettings.h
  • LATENCY_INDICATOR_AUTOALIGN_NUM_VALUES : NvApiDriverSettings.h
  • LODBIASADJUST_DEFAULT : NvApiDriverSettings.h
  • LODBIASADJUST_ID : NvApiDriverSettings.h
  • LODBIASADJUST_MAX : NvApiDriverSettings.h
  • LODBIASADJUST_MIN : NvApiDriverSettings.h
  • LODBIASADJUST_NUM_VALUES : NvApiDriverSettings.h


  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • a
  • b
  • c
  • d
  • e
  • f
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • v
  • w
Here is a list of all enum values with links to the files they belong to:

- m -

  • MAXWELL_B_SAMPLE_INTERLEAVE_DEFAULT : NvApiDriverSettings.h
  • MAXWELL_B_SAMPLE_INTERLEAVE_ID : NvApiDriverSettings.h
  • MAXWELL_B_SAMPLE_INTERLEAVE_NUM_VALUES : NvApiDriverSettings.h
  • MAXWELL_B_SAMPLE_INTERLEAVE_OFF : NvApiDriverSettings.h
  • MAXWELL_B_SAMPLE_INTERLEAVE_ON : NvApiDriverSettings.h
  • MCSFRSHOWSPLIT_DEFAULT : NvApiDriverSettings.h
  • MCSFRSHOWSPLIT_DISABLED : NvApiDriverSettings.h
  • MCSFRSHOWSPLIT_ENABLED : NvApiDriverSettings.h
  • MCSFRSHOWSPLIT_ID : NvApiDriverSettings.h
  • MCSFRSHOWSPLIT_NUM_VALUES : NvApiDriverSettings.h


  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • a
  • b
  • c
  • d
  • e
  • f
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • v
  • w
Here is a list of all enum values with links to the files they belong to:

- n -

  • NV_ADAPTER_TYPE_LAST : nvapi.h
  • NV_ADAPTER_TYPE_MCDM : nvapi.h
  • NV_ADAPTER_TYPE_TCC : nvapi.h
  • NV_ADAPTER_TYPE_UNKNOWN : nvapi.h
  • NV_ADAPTER_TYPE_WDDM : nvapi.h
  • NV_BPC_10 : nvapi.h
  • NV_BPC_12 : nvapi.h
  • NV_BPC_16 : nvapi.h
  • NV_BPC_6 : nvapi.h
  • NV_BPC_8 : nvapi.h
  • NV_BPC_DEFAULT : nvapi.h
  • NV_CHIPSET_INFO_HYBRID : nvapi.h
  • NV_CLIP_DISTANCE_0_SEMANTIC : nvapi.h
  • NV_CLIP_DISTANCE_1_SEMANTIC : nvapi.h
  • NV_COLOR_CMD_GET : nvapi.h
  • NV_COLOR_CMD_GET_DEFAULT : nvapi.h
  • NV_COLOR_CMD_IS_SUPPORTED_COLOR : nvapi.h
  • NV_COLOR_CMD_SET : nvapi.h
  • NV_COLOR_COLORIMETRY_ADOBERGB : nvapi.h
  • NV_COLOR_COLORIMETRY_ADOBEYCC601 : nvapi.h
  • NV_COLOR_COLORIMETRY_AUTO : nvapi.h
  • NV_COLOR_COLORIMETRY_BT2020cYCC : nvapi.h
  • NV_COLOR_COLORIMETRY_BT2020RGB : nvapi.h
  • NV_COLOR_COLORIMETRY_BT2020YCC : nvapi.h
  • NV_COLOR_COLORIMETRY_DEFAULT : nvapi.h
  • NV_COLOR_COLORIMETRY_RGB : nvapi.h
  • NV_COLOR_COLORIMETRY_SYCC601 : nvapi.h
  • NV_COLOR_COLORIMETRY_XVYCC601 : nvapi.h
  • NV_COLOR_COLORIMETRY_XVYCC709 : nvapi.h
  • NV_COLOR_COLORIMETRY_YCC601 : nvapi.h
  • NV_COLOR_COLORIMETRY_YCC709 : nvapi.h
  • NV_COLOR_FORMAT_AUTO : nvapi.h
  • NV_COLOR_FORMAT_DEFAULT : nvapi.h
  • NV_COLOR_FORMAT_RGB : nvapi.h
  • NV_COLOR_FORMAT_YUV420 : nvapi.h
  • NV_COLOR_FORMAT_YUV422 : nvapi.h
  • NV_COLOR_FORMAT_YUV444 : nvapi.h
  • NV_COLOR_SELECTION_POLICY_BEST_QUALITY : nvapi.h
  • NV_COLOR_SELECTION_POLICY_DEFAULT : nvapi.h
  • NV_COLOR_SELECTION_POLICY_UNKNOWN : nvapi.h
  • NV_COLOR_SELECTION_POLICY_USER : nvapi.h
  • NV_COLORSPACE_REC2100 : nvapi.h
  • NV_COLORSPACE_sRGB : nvapi.h
  • NV_COLORSPACE_xRGB : nvapi.h
  • NV_COMPUTE_SHADER_DERIVATIVE_GROUP_LINEAR : nvapi.h
  • NV_COMPUTE_SHADER_DERIVATIVE_GROUP_QUADS : nvapi.h
  • NV_COMPUTE_SHADER_DERIVATIVE_NONE : nvapi.h
  • NV_CULL_DISTANCE_0_SEMANTIC : nvapi.h
  • NV_CULL_DISTANCE_1_SEMANTIC : nvapi.h
  • NV_CUSTOM_SEMANTIC_MAX : nvapi.h
  • NV_D3D11_FEATURE_RASTERIZER : nvapi.h
  • NV_D3D12_HEAP_FLAG_CPUVISIBLE_VIDMEM : nvapi.h
  • NV_D3D12_HEAP_FLAG_NONE : nvapi.h
  • NV_D3D12_RESOURCE_FLAG_CPUVISIBLE_VIDMEM : nvapi.h
  • NV_D3D12_RESOURCE_FLAG_HTEX : nvapi.h
  • NV_D3D12_RESOURCE_FLAG_NONE : nvapi.h
  • NV_D3D12_WORKSTATION_FEATURE_TYPE_PRESENT_BARRIER : nvapi.h
  • NV_D3D12_WORKSTATION_FEATURE_TYPE_RDMA_BAR1_SUPPORT : nvapi.h
  • NV_D3D_GRAPHICS_STATE_COMPUTE_ROOT_SIGNATURE : nvapi.h
  • NV_D3D_GRAPHICS_STATE_DESCRIPTOR_HEAP : nvapi.h
  • NV_D3D_GRAPHICS_STATE_GRAPHICS_ROOT_SIGNATURE : nvapi.h
  • NV_D3D_GRAPHICS_STATE_IA_INDEX_BUFFER : nvapi.h
  • NV_D3D_GRAPHICS_STATE_IA_PRIMITIVE_TOPOLOGY : nvapi.h
  • NV_D3D_GRAPHICS_STATE_IA_VERTEX_BUFFERS : nvapi.h
  • NV_D3D_GRAPHICS_STATE_NONE : nvapi.h
  • NV_D3D_GRAPHICS_STATE_OM_BLEND_FACTOR : nvapi.h
  • NV_D3D_GRAPHICS_STATE_OM_DEPTH_BOUNDS : nvapi.h
  • NV_D3D_GRAPHICS_STATE_OM_RENDER_TARGETS : nvapi.h
  • NV_D3D_GRAPHICS_STATE_OM_STENCIL_REF : nvapi.h
  • NV_D3D_GRAPHICS_STATE_PIPELINE_STATE : nvapi.h
  • NV_D3D_GRAPHICS_STATE_PREDICATION : nvapi.h
  • NV_D3D_GRAPHICS_STATE_RS_SCISSOR_RECTS : nvapi.h
  • NV_D3D_GRAPHICS_STATE_RS_VIEWPORTS : nvapi.h
  • NV_D3D_GRAPHICS_STATE_SAMPLE_POSITIONS : nvapi.h
  • NV_D3D_GRAPHICS_STATE_SO_TARGETS : nvapi.h
  • NV_D3D_GRAPHICS_STATE_VIEW_INSTANCE_MASK : nvapi.h
  • NV_DESKTOP_COLOR_DEPTH_10BPC : nvapi.h
  • NV_DESKTOP_COLOR_DEPTH_16BPC_FLOAT : nvapi.h
  • NV_DESKTOP_COLOR_DEPTH_16BPC_FLOAT_HDR : nvapi.h
  • NV_DESKTOP_COLOR_DEPTH_16BPC_FLOAT_WCG : nvapi.h
  • NV_DESKTOP_COLOR_DEPTH_8BPC : nvapi.h
  • NV_DESKTOP_COLOR_DEPTH_DEFAULT : nvapi.h
  • NV_DESKTOP_COLOR_DEPTH_MAX_VALUE : nvapi.h
  • NV_DISPLAY_OUTPUT_MODE_HDR10 : nvapi.h
  • NV_DISPLAY_OUTPUT_MODE_HDR10PLUS_GAMING : nvapi.h
  • NV_DISPLAY_OUTPUT_MODE_SDR : nvapi.h
  • NV_DISPLAY_TV_FORMAT_ANY : nvapi.h
  • NV_DISPLAY_TV_FORMAT_ED_480p : nvapi.h
  • NV_DISPLAY_TV_FORMAT_ED_576p : nvapi.h
  • NV_DISPLAY_TV_FORMAT_ED_OTHER : nvapi.h
  • NV_DISPLAY_TV_FORMAT_HD_1080i : nvapi.h
  • NV_DISPLAY_TV_FORMAT_HD_1080i50 : nvapi.h
  • NV_DISPLAY_TV_FORMAT_HD_1080p : nvapi.h
  • NV_DISPLAY_TV_FORMAT_HD_1080p24 : nvapi.h
  • NV_DISPLAY_TV_FORMAT_HD_1080p50 : nvapi.h
  • NV_DISPLAY_TV_FORMAT_HD_720p : nvapi.h
  • NV_DISPLAY_TV_FORMAT_HD_720p50 : nvapi.h
  • NV_DISPLAY_TV_FORMAT_HD_OTHER : nvapi.h
  • NV_DISPLAY_TV_FORMAT_NONE : nvapi.h
  • NV_DISPLAY_TV_FORMAT_SD_480i : nvapi.h
  • NV_DISPLAY_TV_FORMAT_SD_576i : nvapi.h
  • NV_DISPLAY_TV_FORMAT_SD_NTSCJ : nvapi.h
  • NV_DISPLAY_TV_FORMAT_SD_NTSCM : nvapi.h
  • NV_DISPLAY_TV_FORMAT_SD_OTHER : nvapi.h
  • NV_DISPLAY_TV_FORMAT_SD_PALBDGH : nvapi.h
  • NV_DISPLAY_TV_FORMAT_SD_PALM : nvapi.h
  • NV_DISPLAY_TV_FORMAT_SD_PALN : nvapi.h
  • NV_DISPLAY_TV_FORMAT_SD_PALNC : nvapi.h
  • NV_DISPLAY_TV_FORMAT_UHD_10Kp100_10240 : nvapi.h
  • NV_DISPLAY_TV_FORMAT_UHD_10Kp120_10240 : nvapi.h
  • NV_DISPLAY_TV_FORMAT_UHD_10Kp24_10240 : nvapi.h
  • NV_DISPLAY_TV_FORMAT_UHD_10Kp25_10240 : nvapi.h
  • NV_DISPLAY_TV_FORMAT_UHD_10Kp30_10240 : nvapi.h
  • NV_DISPLAY_TV_FORMAT_UHD_10Kp48_10240 : nvapi.h
  • NV_DISPLAY_TV_FORMAT_UHD_10Kp50_10240 : nvapi.h
  • NV_DISPLAY_TV_FORMAT_UHD_10Kp60_10240 : nvapi.h
  • NV_DISPLAY_TV_FORMAT_UHD_4Kp100_3840 : nvapi.h
  • NV_DISPLAY_TV_FORMAT_UHD_4Kp100_4096 : nvapi.h
  • NV_DISPLAY_TV_FORMAT_UHD_4Kp100_5120 : nvapi.h
  • NV_DISPLAY_TV_FORMAT_UHD_4Kp120_3840 : nvapi.h
  • NV_DISPLAY_TV_FORMAT_UHD_4Kp120_4096 : nvapi.h
  • NV_DISPLAY_TV_FORMAT_UHD_4Kp120_5120 : nvapi.h
  • NV_DISPLAY_TV_FORMAT_UHD_4Kp24 : nvapi.h
  • NV_DISPLAY_TV_FORMAT_UHD_4Kp24_3840 : nvapi.h
  • NV_DISPLAY_TV_FORMAT_UHD_4Kp24_4096 : nvapi.h
  • NV_DISPLAY_TV_FORMAT_UHD_4Kp24_5120 : nvapi.h
  • NV_DISPLAY_TV_FORMAT_UHD_4Kp24_SMPTE : nvapi.h
  • NV_DISPLAY_TV_FORMAT_UHD_4Kp25 : nvapi.h
  • NV_DISPLAY_TV_FORMAT_UHD_4Kp25_3840 : nvapi.h
  • NV_DISPLAY_TV_FORMAT_UHD_4Kp25_4096 : nvapi.h
  • NV_DISPLAY_TV_FORMAT_UHD_4Kp25_5120 : nvapi.h
  • NV_DISPLAY_TV_FORMAT_UHD_4Kp30 : nvapi.h
  • NV_DISPLAY_TV_FORMAT_UHD_4Kp30_3840 : nvapi.h
  • NV_DISPLAY_TV_FORMAT_UHD_4Kp30_4096 : nvapi.h
  • NV_DISPLAY_TV_FORMAT_UHD_4Kp30_5120 : nvapi.h
  • NV_DISPLAY_TV_FORMAT_UHD_4Kp48_3840 : nvapi.h
  • NV_DISPLAY_TV_FORMAT_UHD_4Kp48_4096 : nvapi.h
  • NV_DISPLAY_TV_FORMAT_UHD_4Kp48_5120 : nvapi.h
  • NV_DISPLAY_TV_FORMAT_UHD_4Kp50_3840 : nvapi.h
  • NV_DISPLAY_TV_FORMAT_UHD_4Kp50_4096 : nvapi.h
  • NV_DISPLAY_TV_FORMAT_UHD_4Kp50_5120 : nvapi.h
  • NV_DISPLAY_TV_FORMAT_UHD_4Kp60_3840 : nvapi.h
  • NV_DISPLAY_TV_FORMAT_UHD_4Kp60_4096 : nvapi.h
  • NV_DISPLAY_TV_FORMAT_UHD_4Kp60_5120 : nvapi.h
  • NV_DISPLAY_TV_FORMAT_UHD_8Kp100_7680 : nvapi.h
  • NV_DISPLAY_TV_FORMAT_UHD_8Kp120_7680 : nvapi.h
  • NV_DISPLAY_TV_FORMAT_UHD_8Kp24_7680 : nvapi.h
  • NV_DISPLAY_TV_FORMAT_UHD_8Kp25_7680 : nvapi.h
  • NV_DISPLAY_TV_FORMAT_UHD_8Kp30_7680 : nvapi.h
  • NV_DISPLAY_TV_FORMAT_UHD_8Kp48_7680 : nvapi.h
  • NV_DISPLAY_TV_FORMAT_UHD_8Kp50_7680 : nvapi.h
  • NV_DISPLAY_TV_FORMAT_UHD_8Kp60_7680 : nvapi.h
  • NV_DISPLAYCONFIG_DRIVER_RELOAD_ALLOWED : nvapi.h
  • NV_DISPLAYCONFIG_FORCE_MODE_ENUMERATION : nvapi.h
  • NV_DISPLAYCONFIG_SAVE_TO_PERSISTENCE : nvapi.h
  • NV_DISPLAYCONFIG_SPAN_HORIZONTAL : nvapi.h
  • NV_DISPLAYCONFIG_SPAN_NONE : nvapi.h
  • NV_DISPLAYCONFIG_SPAN_VERTICAL : nvapi.h
  • NV_DISPLAYCONFIG_VALIDATE_ONLY : nvapi.h
  • NV_DP_1_62GBPS : nvapi.h
  • NV_DP_1_LANE : nvapi.h
  • NV_DP_2_70GBPS : nvapi.h
  • NV_DP_2_LANE : nvapi.h
  • NV_DP_4_LANE : nvapi.h
  • NV_DP_5_40GBPS : nvapi.h
  • NV_DP_8_10GBPS : nvapi.h
  • NV_DP_BPC_10 : nvapi.h
  • NV_DP_BPC_12 : nvapi.h
  • NV_DP_BPC_16 : nvapi.h
  • NV_DP_BPC_6 : nvapi.h
  • NV_DP_BPC_8 : nvapi.h
  • NV_DP_BPC_DEFAULT : nvapi.h
  • NV_DP_COLOR_FORMAT_RGB : nvapi.h
  • NV_DP_COLOR_FORMAT_YCbCr422 : nvapi.h
  • NV_DP_COLOR_FORMAT_YCbCr444 : nvapi.h
  • NV_DP_COLORIMETRY_RGB : nvapi.h
  • NV_DP_COLORIMETRY_YCbCr_ITU601 : nvapi.h
  • NV_DP_COLORIMETRY_YCbCr_ITU709 : nvapi.h
  • NV_DP_DYNAMIC_RANGE_CEA : nvapi.h
  • NV_DP_DYNAMIC_RANGE_VESA : nvapi.h
  • NV_DYNAMIC_RANGE_AUTO : nvapi.h
  • NV_DYNAMIC_RANGE_CEA : nvapi.h
  • NV_DYNAMIC_RANGE_VESA : nvapi.h
  • NV_ECC_CONFIGURATION_DEFERRED : nvapi.h
  • NV_ECC_CONFIGURATION_IMMEDIATE : nvapi.h
  • NV_ECC_CONFIGURATION_NOT_SUPPORTED : nvapi.h
  • NV_EDID_FLAG_COOKED : nvapi.h
  • NV_EDID_FLAG_DEFAULT : nvapi.h
  • NV_EDID_FLAG_FORCED : nvapi.h
  • NV_EDID_FLAG_HW : nvapi.h
  • NV_EDID_FLAG_INF : nvapi.h
  • NV_EDID_FLAG_RAW : nvapi.h
  • NV_EDP_2_16GBPS : nvapi.h
  • NV_EDP_2_43GBPS : nvapi.h
  • NV_EDP_3_24GBPS : nvapi.h
  • NV_EDP_4_32GBPS : nvapi.h
  • NV_EVENT_TYPE_NONE : nvapi.h
  • NV_EVENT_TYPE_QSYNC : nvapi.h
  • NV_FASTGS_OFFSET_RT_INDEX_BY_VP_INDEX : nvapi.h
  • NV_FASTGS_STRICT_API_ORDER : nvapi.h
  • NV_FASTGS_USE_VIEWPORT_MASK : nvapi.h
  • NV_FORCE_COMMIT_VIDPN : nvapi.h
  • NV_FORMAT_A16B16G16R16F : nvapi.h
  • NV_FORMAT_A8R8G8B8 : nvapi.h
  • NV_FORMAT_P8 : nvapi.h
  • NV_FORMAT_R5G6B5 : nvapi.h
  • NV_FORMAT_UNKNOWN : nvapi.h
  • NV_FOVEATED_RENDERING_FOVEATION_PATTERN_PRESET_BALANCED : nvapi.h
  • NV_FOVEATED_RENDERING_FOVEATION_PATTERN_PRESET_CUSTOM : nvapi.h
  • NV_FOVEATED_RENDERING_FOVEATION_PATTERN_PRESET_INVALID : nvapi.h
  • NV_FOVEATED_RENDERING_FOVEATION_PATTERN_PRESET_MAX : nvapi.h
  • NV_FOVEATED_RENDERING_FOVEATION_PATTERN_PRESET_NARROW : nvapi.h
  • NV_FOVEATED_RENDERING_FOVEATION_PATTERN_PRESET_WIDE : nvapi.h
  • NV_FOVEATED_RENDERING_SHADING_RATE_PRESET_BALANCED : nvapi.h
  • NV_FOVEATED_RENDERING_SHADING_RATE_PRESET_CUSTOM : nvapi.h
  • NV_FOVEATED_RENDERING_SHADING_RATE_PRESET_HIGH_PERFORMANCE : nvapi.h
  • NV_FOVEATED_RENDERING_SHADING_RATE_PRESET_HIGH_QUALITY : nvapi.h
  • NV_FOVEATED_RENDERING_SHADING_RATE_PRESET_HIGHEST_PERFORMANCE : nvapi.h
  • NV_FOVEATED_RENDERING_SHADING_RATE_PRESET_HIGHEST_QUALITY : nvapi.h
  • NV_FOVEATED_RENDERING_SHADING_RATE_PRESET_INVALID : nvapi.h
  • NV_FOVEATED_RENDERING_SHADING_RATE_PRESET_MAX : nvapi.h
  • NV_GAZE_DATA_INVALID : nvapi.h
  • NV_GAZE_DATA_MAX : nvapi.h
  • NV_GAZE_DATA_MONO : nvapi.h
  • NV_GAZE_DATA_STEREO : nvapi.h
  • NV_GAZE_DIRECTION_VALID : nvapi.h
  • NV_GAZE_EYE_OPENNESS_VALID : nvapi.h
  • NV_GAZE_EYE_SACCADE_DATA_VALID : nvapi.h
  • NV_GAZE_LOCATION_VALID : nvapi.h
  • NV_GAZE_ORIGIN_VALID : nvapi.h
  • NV_GAZE_PUPIL_DIAMETER_VALID : nvapi.h
  • NV_GAZE_VELOCITY_VALID : nvapi.h
  • NV_GENERIC_ATTRIBUTE_SEMANTIC : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_AD102 : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_AD103 : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_AD104 : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_G84 : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_G86 : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_G92 : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_G94 : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_G96 : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_G98 : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_GA100 : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_GA102 : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_GA104 : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_GF100 : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_GF104 : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_GF106 : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_GF108 : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_GF110 : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_GF116 : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_GF117 : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_GF118 : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_GF119 : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_GK104 : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_GK106 : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_GK107 : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_GK110 : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_GK208 : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_GK20A : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_GM204 : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_GM206 : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_GP000 : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_GP100 : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_GP102 : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_GP104 : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_GP106 : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_GP107 : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_GP108 : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_GT200 : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_GT212 : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_GT214 : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_GT215 : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_GT216 : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_GT218 : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_GT21A : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_GT21C : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_GV100 : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_GV10B : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_MCP77 : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_MCP79 : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_MCP89 : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_NV40 : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_NV41 : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_NV42 : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_NV43 : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_NV44 : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_NV44A : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_NV46 : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_NV47 : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_NV49 : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_NV4B : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_NV4C : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_NV4E : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_NV50 : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_NV63 : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_NV67 : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_T124 : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_T20 : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_T30 : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_T35 : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_T40 : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_TU000 : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_TU100 : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_TU102 : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_TU104 : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_TU106 : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_TU116 : nvapi.h
  • NV_GPU_ARCH_IMPLEMENTATION_TU117 : nvapi.h
  • NV_GPU_ARCHITECTURE_AD100 : nvapi.h
  • NV_GPU_ARCHITECTURE_G78 : nvapi.h
  • NV_GPU_ARCHITECTURE_G80 : nvapi.h
  • NV_GPU_ARCHITECTURE_G90 : nvapi.h
  • NV_GPU_ARCHITECTURE_GA100 : nvapi.h
  • NV_GPU_ARCHITECTURE_GF100 : nvapi.h
  • NV_GPU_ARCHITECTURE_GF110 : nvapi.h
  • NV_GPU_ARCHITECTURE_GK100 : nvapi.h
  • NV_GPU_ARCHITECTURE_GK110 : nvapi.h
  • NV_GPU_ARCHITECTURE_GK200 : nvapi.h
  • NV_GPU_ARCHITECTURE_GM000 : nvapi.h
  • NV_GPU_ARCHITECTURE_GM200 : nvapi.h
  • NV_GPU_ARCHITECTURE_GP100 : nvapi.h
  • NV_GPU_ARCHITECTURE_GT200 : nvapi.h
  • NV_GPU_ARCHITECTURE_GV100 : nvapi.h
  • NV_GPU_ARCHITECTURE_GV110 : nvapi.h
  • NV_GPU_ARCHITECTURE_NV40 : nvapi.h
  • NV_GPU_ARCHITECTURE_NV50 : nvapi.h
  • NV_GPU_ARCHITECTURE_T12X : nvapi.h
  • NV_GPU_ARCHITECTURE_T2X : nvapi.h
  • NV_GPU_ARCHITECTURE_T3X : nvapi.h
  • NV_GPU_ARCHITECTURE_T4X : nvapi.h
  • NV_GPU_ARCHITECTURE_TU100 : nvapi.h
  • NV_GPU_CHIP_REV_A01 : nvapi.h
  • NV_GPU_CHIP_REV_A02 : nvapi.h
  • NV_GPU_CHIP_REV_A03 : nvapi.h
  • NV_GPU_CHIP_REV_EMULATION_FPGA : nvapi.h
  • NV_GPU_CHIP_REV_EMULATION_QT : nvapi.h
  • NV_GPU_CHIP_REV_UNKNOWN : nvapi.h
  • NV_GPU_CLIENT_ILLUM_CTRL_MODE_INVALID : nvapi.h
  • NV_GPU_CLIENT_ILLUM_CTRL_MODE_MANUAL : nvapi.h
  • NV_GPU_CLIENT_ILLUM_CTRL_MODE_MANUAL_RGB : nvapi.h
  • NV_GPU_CLIENT_ILLUM_CTRL_MODE_PIECEWISE_LINEAR : nvapi.h
  • NV_GPU_CLIENT_ILLUM_CTRL_MODE_PIECEWISE_LINEAR_RGB : nvapi.h
  • NV_GPU_CLIENT_ILLUM_DEVICE_TYPE_GPIO_PWM_RGBW_V10 : nvapi.h
  • NV_GPU_CLIENT_ILLUM_DEVICE_TYPE_GPIO_PWM_SINGLE_COLOR_V10 : nvapi.h
  • NV_GPU_CLIENT_ILLUM_DEVICE_TYPE_INVALID : nvapi.h
  • NV_GPU_CLIENT_ILLUM_DEVICE_TYPE_MCUV10 : nvapi.h
  • NV_GPU_CLIENT_ILLUM_PIECEWISE_LINEAR_CYCLE_FULL_HALT : nvapi.h
  • NV_GPU_CLIENT_ILLUM_PIECEWISE_LINEAR_CYCLE_FULL_REPEAT : nvapi.h
  • NV_GPU_CLIENT_ILLUM_PIECEWISE_LINEAR_CYCLE_HALF_HALT : nvapi.h
  • NV_GPU_CLIENT_ILLUM_PIECEWISE_LINEAR_CYCLE_INVALID : nvapi.h
  • NV_GPU_CLIENT_ILLUM_ZONE_LOCATION_GPU_BACK_0 : nvapi.h
  • NV_GPU_CLIENT_ILLUM_ZONE_LOCATION_GPU_FRONT_0 : nvapi.h
  • NV_GPU_CLIENT_ILLUM_ZONE_LOCATION_GPU_TOP_0 : nvapi.h
  • NV_GPU_CLIENT_ILLUM_ZONE_LOCATION_INVALID : nvapi.h
  • NV_GPU_CLIENT_ILLUM_ZONE_LOCATION_SLI_TOP_0 : nvapi.h
  • NV_GPU_CLIENT_ILLUM_ZONE_TYPE_COLOR_FIXED : nvapi.h
  • NV_GPU_CLIENT_ILLUM_ZONE_TYPE_INVALID : nvapi.h
  • NV_GPU_CLIENT_ILLUM_ZONE_TYPE_RGB : nvapi.h
  • NV_GPU_CLIENT_ILLUM_ZONE_TYPE_RGBW : nvapi.h
  • NV_GPU_CLIENT_ILLUM_ZONE_TYPE_SINGLE_COLOR : nvapi.h
  • NV_GPU_CLIENT_UTIL_DOMAIN_FRAME_BUFFER : nvapi.h
  • NV_GPU_CLIENT_UTIL_DOMAIN_GRAPHICS : nvapi.h
  • NV_GPU_CLIENT_UTIL_DOMAIN_RSVD : nvapi.h
  • NV_GPU_CLIENT_UTIL_DOMAIN_VIDEO : nvapi.h
  • NV_GPU_CLOCK_FREQUENCIES_BASE_CLOCK : nvapi.h
  • NV_GPU_CLOCK_FREQUENCIES_BOOST_CLOCK : nvapi.h
  • NV_GPU_CLOCK_FREQUENCIES_CLOCK_TYPE_NUM : nvapi.h
  • NV_GPU_CLOCK_FREQUENCIES_CURRENT_FREQ : nvapi.h
  • NV_GPU_HDCP_FUSE_STATE_DISABLED : nvapi.h
  • NV_GPU_HDCP_FUSE_STATE_ENABLED : nvapi.h
  • NV_GPU_HDCP_FUSE_STATE_UNKNOWN : nvapi.h
  • NV_GPU_HDCP_KEY_SOURCE_CRYPTO_ROM : nvapi.h
  • NV_GPU_HDCP_KEY_SOURCE_FUSES : nvapi.h
  • NV_GPU_HDCP_KEY_SOURCE_I2C_ROM : nvapi.h
  • NV_GPU_HDCP_KEY_SOURCE_NONE : nvapi.h
  • NV_GPU_HDCP_KEY_SOURCE_SBIOS : nvapi.h
  • NV_GPU_HDCP_KEY_SOURCE_STATE_ABSENT : nvapi.h
  • NV_GPU_HDCP_KEY_SOURCE_STATE_PRESENT : nvapi.h
  • NV_GPU_HDCP_KEY_SOURCE_STATE_UNKNOWN : nvapi.h
  • NV_GPU_HDCP_KEY_SOURCE_UNKNOWN : nvapi.h
  • NV_GPU_IA_LOGO_BRIGHTNESS : nvapi.h
  • NV_GPU_IA_SLI_BRIGHTNESS : nvapi.h
  • NV_GPU_PERF_DECREASE_NONE : nvapi.h
  • NV_GPU_PERF_DECREASE_REASON_AC_BATT : nvapi.h
  • NV_GPU_PERF_DECREASE_REASON_API_TRIGGERED : nvapi.h
  • NV_GPU_PERF_DECREASE_REASON_INSUFFICIENT_POWER : nvapi.h
  • NV_GPU_PERF_DECREASE_REASON_POWER_CONTROL : nvapi.h
  • NV_GPU_PERF_DECREASE_REASON_THERMAL_PROTECTION : nvapi.h
  • NV_GPU_PERF_DECREASE_REASON_UNKNOWN : nvapi.h
  • NV_GPU_SCANOUT_COMPOSITION_PARAMETER_SET_TO_DEFAULT : nvapi.h
  • NV_GPU_SCANOUT_COMPOSITION_PARAMETER_VALUE_WARPING_RESAMPLING_METHOD_BICUBIC_ADAPTIVE_BELL_SHAPED : nvapi.h
  • NV_GPU_SCANOUT_COMPOSITION_PARAMETER_VALUE_WARPING_RESAMPLING_METHOD_BICUBIC_ADAPTIVE_BSPLINE : nvapi.h
  • NV_GPU_SCANOUT_COMPOSITION_PARAMETER_VALUE_WARPING_RESAMPLING_METHOD_BICUBIC_ADAPTIVE_TRIANGULAR : nvapi.h
  • NV_GPU_SCANOUT_COMPOSITION_PARAMETER_VALUE_WARPING_RESAMPLING_METHOD_BICUBIC_BELL_SHAPED : nvapi.h
  • NV_GPU_SCANOUT_COMPOSITION_PARAMETER_VALUE_WARPING_RESAMPLING_METHOD_BICUBIC_BSPLINE : nvapi.h
  • NV_GPU_SCANOUT_COMPOSITION_PARAMETER_VALUE_WARPING_RESAMPLING_METHOD_BICUBIC_TRIANGULAR : nvapi.h
  • NV_GPU_SCANOUT_COMPOSITION_PARAMETER_VALUE_WARPING_RESAMPLING_METHOD_BILINEAR : nvapi.h
  • NV_GPU_SCANOUT_COMPOSITION_PARAMETER_WARPING_RESAMPLING_METHOD : nvapi.h
  • NV_GPU_WARPING_VERTICE_FORMAT_TRIANGLES_XYUVRQ : nvapi.h
  • NV_GPU_WARPING_VERTICE_FORMAT_TRIANGLESTRIP_XYUVRQ : nvapi.h
  • NV_GPU_WORKSTATION_FEATURE_TYPE_NVIDIA_RTX_VR_READY : nvapi.h
  • NV_GPU_WORKSTATION_FEATURE_TYPE_PROVIZ : nvapi.h
  • NV_GPU_WORKSTATION_FEATURE_TYPE_QUADRO_VR_READY : nvapi.h
  • NV_HDR_CMD_GET : nvapi.h
  • NV_HDR_CMD_SET : nvapi.h
  • NV_HDR_MODE_DOLBY_VISION : nvapi.h
  • NV_HDR_MODE_EDR : nvapi.h
  • NV_HDR_MODE_OFF : nvapi.h
  • NV_HDR_MODE_SDR : nvapi.h
  • NV_HDR_MODE_UHDA : nvapi.h
  • NV_HDR_MODE_UHDA_NB : nvapi.h
  • NV_HDR_MODE_UHDA_PASSTHROUGH : nvapi.h
  • NV_HDR_MODE_UHDBD : nvapi.h
  • NV_HDR_TONEMAPPING_APP : nvapi.h
  • NV_HDR_TONEMAPPING_GPU : nvapi.h
  • NV_INFOFRAME_CMD_GET : nvapi.h
  • NV_INFOFRAME_CMD_GET_DEFAULT : nvapi.h
  • NV_INFOFRAME_CMD_GET_OVERRIDE : nvapi.h
  • NV_INFOFRAME_CMD_GET_PROPERTY : nvapi.h
  • NV_INFOFRAME_CMD_RESET : nvapi.h
  • NV_INFOFRAME_CMD_SET : nvapi.h
  • NV_INFOFRAME_CMD_SET_OVERRIDE : nvapi.h
  • NV_INFOFRAME_CMD_SET_PROPERTY : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_AUTO : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FCH_RC_RR_RL_FC_LFE_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FCH_RC_RR_RL_FC_X_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRC_FLC_RR_RL_FC_LFE_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRC_FLC_RR_RL_FC_X_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRC_FLC_RR_RL_X_LFE_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRC_FLC_RR_RL_X_X_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRC_FLC_X_RC_FC_LFE_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRC_FLC_X_RC_FC_X_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRC_FLC_X_RC_X_LFE_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRC_FLC_X_RC_X_X_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRC_FLC_X_X_FC_LFE_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRC_FLC_X_X_FC_X_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRC_FLC_X_X_X_LFE_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRC_FLC_X_X_X_X_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRH_FLH_RR_RL_FC_LFE_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRH_FLH_RR_RL_FC_X_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRH_FLH_RR_RL_X_LFE_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRH_FLH_RR_RL_X_X_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRW_FLW_RR_RL_FC_LFE_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRW_FLW_RR_RL_FC_X_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRW_FLW_RR_RL_X_LFE_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_FRW_FLW_RR_RL_X_X_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_RRC_RLC_RR_RL_FC_LFE_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_RRC_RLC_RR_RL_FC_X_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_RRC_RLC_RR_RL_X_LFE_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_RRC_RLC_RR_RL_X_X_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_TC_FCH_RR_RL_FC_LFE_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_TC_FCH_RR_RL_FC_X_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_TC_RC_RR_RL_FC_LFE_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_TC_RC_RR_RL_FC_X_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_TC_X_RR_RL_FC_LFE_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_TC_X_RR_RL_FC_X_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_FCH_RR_RL_FC_LFE_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_FCH_RR_RL_FC_X_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_RC_RR_RL_FC_LFE_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_RC_RR_RL_FC_X_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_RC_RR_RL_X_LFE_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_RC_RR_RL_X_X_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_X_RR_RL_FC_LFE_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_X_RR_RL_FC_X_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_X_RR_RL_X_LFE_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_X_RR_RL_X_X_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_X_X_RC_FC_LFE_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_X_X_RC_FC_X_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_X_X_RC_X_LFE_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_X_X_RC_X_X_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_X_X_X_FC_LFE_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_X_X_X_FC_X_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_X_X_X_X_LFE_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELALLOCATION_X_X_X_X_X_X_FR_FL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELCOUNT_2 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELCOUNT_3 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELCOUNT_4 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELCOUNT_5 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELCOUNT_6 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELCOUNT_7 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELCOUNT_8 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELCOUNT_AUTO : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CHANNELCOUNT_IN_HEADER : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_AUTO : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_HEAAC : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_HEAACV2 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_MPEGSURROUND : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE04 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE05 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE06 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE07 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE08 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE09 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE10 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE11 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE12 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE13 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE14 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE15 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE16 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE17 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE18 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE19 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE20 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE21 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE22 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE23 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE24 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE25 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE26 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE27 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE28 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE29 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE30 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_RESERVE31 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGEXTENSIONTYPE_USE_CODING_TYPE : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_AACLC : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_AC3 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_ATRAC : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_AUTO : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_DSD : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_DST : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_DTS : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_DTSHD : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_EAC3 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_IN_HEADER : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_MLP : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_MP3 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_MPEG1 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_MPEG2 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_PCM : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_USE_CODING_EXTENSION_TYPE : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_CODINGTYPE_WMAPRO : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_DOWNMIX_AUTO : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_DOWNMIX_PERMITTED : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_DOWNMIX_PROHIBITED : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_0DB : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_10DB : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_11DB : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_12DB : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_13DB : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_14DB : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_15DB : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_1DB : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_2DB : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_3DB : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_4DB : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_5DB : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_6DB : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_7DB : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_8DB : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_9DB : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_LEVELSHIFTVALUES_AUTO : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_LFEPLAYBACKLEVEL_0DB : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_LFEPLAYBACKLEVEL_AUTO : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_LFEPLAYBACKLEVEL_NO_DATA : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_LFEPLAYBACKLEVEL_PLUS10DB : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_LFEPLAYBACKLEVEL_RESERVED03 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_SAMPLEFREQUENCY_176400KHZ : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_SAMPLEFREQUENCY_192000KHZ : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_SAMPLEFREQUENCY_32000HZ : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_SAMPLEFREQUENCY_44100HZ : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_SAMPLEFREQUENCY_48000HZ : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_SAMPLEFREQUENCY_88200KHZ : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_SAMPLEFREQUENCY_96000KHZ : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_SAMPLEFREQUENCY_AUTO : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_SAMPLEFREQUENCY_IN_HEADER : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_SAMPLESIZE_16BITS : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_SAMPLESIZE_20BITS : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_SAMPLESIZE_24BITS : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_SAMPLESIZE_AUTO : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AUDIO_SAMPLESIZE_IN_HEADER : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_AFI_ABSENT : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_AFI_AUTO : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_AFI_PRESENT : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_16x9_ON_14x9 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_16x9_ON_4x3 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_4x3_ON_14x9 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_AUTO : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_CENTER_14x9 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_CENTER_16x9 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_CENTER_4x3 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_EQUAL_CODEDFRAME : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_LETTERBOX_GT16x9 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_NO_AFD : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_RESERVE01 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_RESERVE02 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_RESERVE03 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_RESERVE05 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_RESERVE06 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_RESERVE07 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOACTIVEPORTION_RESERVE12 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOCODEDFRAME_16x9 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOCODEDFRAME_4x3 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOCODEDFRAME_AUTO : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOCODEDFRAME_FUTURE : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_ASPECTRATIOCODEDFRAME_NO_DATA : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_BARDATA_AUTO : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_BARDATA_BOTH_PRESENT : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_BARDATA_HORIZONTAL_PRESENT : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_BARDATA_NOT_PRESENT : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_BARDATA_VERTICAL_PRESENT : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_COLORFORMAT_AUTO : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_COLORFORMAT_FUTURE : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_COLORFORMAT_RGB : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_COLORFORMAT_YCbCr422 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_COLORFORMAT_YCbCr444 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_COLORIMETRY_AUTO : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_COLORIMETRY_ITUR_BT709 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_COLORIMETRY_NO_DATA : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_COLORIMETRY_SMPTE_170M : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_COLORIMETRY_USE_EXTENDED_COLORIMETRY : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_CONTENTTYPE_AUTO : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_CONTENTTYPE_CINEMA : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_CONTENTTYPE_GAME : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_CONTENTTYPE_GRAPHICS : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_CONTENTTYPE_PHOTO : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_EXTENDEDCOLORIMETRY_ADOBERGB : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_EXTENDEDCOLORIMETRY_ADOBEYCC601 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_EXTENDEDCOLORIMETRY_AUTO : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_EXTENDEDCOLORIMETRY_RESERVED05 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_EXTENDEDCOLORIMETRY_RESERVED06 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_EXTENDEDCOLORIMETRY_RESERVED07 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_EXTENDEDCOLORIMETRY_SYCC601 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_EXTENDEDCOLORIMETRY_XVYCC601 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_EXTENDEDCOLORIMETRY_XVYCC709 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_F17_AUTO : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_F17_FALSE : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_F17_TRUE : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_ITC_AUTO : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_ITC_ITCONTENT : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_ITC_VIDEO_CONTENT : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_NONUNIFORMPICTURESCALING_AUTO : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_NONUNIFORMPICTURESCALING_BOTH : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_NONUNIFORMPICTURESCALING_HORIZONTAL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_NONUNIFORMPICTURESCALING_NO_DATA : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_NONUNIFORMPICTURESCALING_VERTICAL : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_AUTO : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_NONE : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_RESERVED10 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_RESERVED11 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_RESERVED12 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_RESERVED13 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_RESERVED14 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_RESERVED15 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_X02 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_X03 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_X04 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_X05 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_X06 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_X07 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_X08 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_X09 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_PIXELREPETITION_X10 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_RGBQUANTIZATION_AUTO : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_RGBQUANTIZATION_DEFAULT : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_RGBQUANTIZATION_FULL_RANGE : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_RGBQUANTIZATION_LIMITED_RANGE : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_RGBQUANTIZATION_RESERVED : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_SCANINFO_AUTO : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_SCANINFO_FUTURE : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_SCANINFO_NODATA : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_SCANINFO_OVERSCAN : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_SCANINFO_UNDERSCAN : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_YCCQUANTIZATION_AUTO : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_YCCQUANTIZATION_FULL_RANGE : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_YCCQUANTIZATION_LIMITED_RANGE : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_YCCQUANTIZATION_RESERVED02 : nvapi.h
  • NV_INFOFRAME_FIELD_VALUE_AVI_YCCQUANTIZATION_RESERVED03 : nvapi.h
  • NV_INFOFRAME_PROPERTY_BLACKLIST_FALSE : nvapi.h
  • NV_INFOFRAME_PROPERTY_BLACKLIST_TRUE : nvapi.h
  • NV_INFOFRAME_PROPERTY_MODE_ALLOW_OVERRIDE : nvapi.h
  • NV_INFOFRAME_PROPERTY_MODE_AUTO : nvapi.h
  • NV_INFOFRAME_PROPERTY_MODE_DISABLE : nvapi.h
  • NV_INFOFRAME_PROPERTY_MODE_ENABLE : nvapi.h
  • NV_LICENSE_FEATURE_COMPUTE : nvapi.h
  • NV_LICENSE_FEATURE_GAMING : nvapi.h
  • NV_LICENSE_FEATURE_NVIDIA_RTX : nvapi.h
  • NV_LICENSE_FEATURE_QUADRO : nvapi.h
  • NV_LICENSE_FEATURE_UNKNOWN : nvapi.h
  • NV_LICENSE_FEATURE_VGPU : nvapi.h
  • NV_LMS_CONFIG_HTC_VIVE_AGGRESSIVE : nvapi.h
  • NV_LMS_CONFIG_HTC_VIVE_BALANCED : nvapi.h
  • NV_LMS_CONFIG_HTC_VIVE_CONSERVATIVE : nvapi.h
  • NV_LMS_CONFIG_OCULUSRIFT_CV1_AGGRESSIVE : nvapi.h
  • NV_LMS_CONFIG_OCULUSRIFT_CV1_BALANCED : nvapi.h
  • NV_LMS_CONFIG_OCULUSRIFT_CV1_CONSERVATIVE : nvapi.h
  • NV_LMS_NUM_CONFIGS : nvapi.h
  • NV_META_COMMAND_ACTIVATION_FUNCTION_COUNT : nvapi.h
  • NV_META_COMMAND_ACTIVATION_FUNCTION_ELU : nvapi.h
  • NV_META_COMMAND_ACTIVATION_FUNCTION_HARD_SIGMOID : nvapi.h
  • NV_META_COMMAND_ACTIVATION_FUNCTION_HARDMAX : nvapi.h
  • NV_META_COMMAND_ACTIVATION_FUNCTION_IDENTITY : nvapi.h
  • NV_META_COMMAND_ACTIVATION_FUNCTION_LEAKY_RELU : nvapi.h
  • NV_META_COMMAND_ACTIVATION_FUNCTION_LINEAR : nvapi.h
  • NV_META_COMMAND_ACTIVATION_FUNCTION_LOG_SOFTMAX : nvapi.h
  • NV_META_COMMAND_ACTIVATION_FUNCTION_PARAMETERIZED_RELU : nvapi.h
  • NV_META_COMMAND_ACTIVATION_FUNCTION_PARAMETRIC_SOFTPLUS : nvapi.h
  • NV_META_COMMAND_ACTIVATION_FUNCTION_RELU : nvapi.h
  • NV_META_COMMAND_ACTIVATION_FUNCTION_SCALED_ELU : nvapi.h
  • NV_META_COMMAND_ACTIVATION_FUNCTION_SCALED_TANH : nvapi.h
  • NV_META_COMMAND_ACTIVATION_FUNCTION_SIGMOID : nvapi.h
  • NV_META_COMMAND_ACTIVATION_FUNCTION_SOFTMAX : nvapi.h
  • NV_META_COMMAND_ACTIVATION_FUNCTION_SOFTPLUS : nvapi.h
  • NV_META_COMMAND_ACTIVATION_FUNCTION_SOFTSIGN : nvapi.h
  • NV_META_COMMAND_ACTIVATION_FUNCTION_TANH : nvapi.h
  • NV_META_COMMAND_ACTIVATION_FUNCTION_THRESHOLDED_RELU : nvapi.h
  • NV_META_COMMAND_CONVOLUTION_DIRECTION_BACKWARD : nvapi.h
  • NV_META_COMMAND_CONVOLUTION_DIRECTION_COUNT : nvapi.h
  • NV_META_COMMAND_CONVOLUTION_DIRECTION_FORWARD : nvapi.h
  • NV_META_COMMAND_CONVOLUTION_MODE_CONVOLUTION : nvapi.h
  • NV_META_COMMAND_CONVOLUTION_MODE_COUNT : nvapi.h
  • NV_META_COMMAND_CONVOLUTION_MODE_CROSS_CORRELATION : nvapi.h
  • NV_META_COMMAND_CONVOLUTION_POOL_MODE_COUNT : nvapi.h
  • NV_META_COMMAND_CONVOLUTION_POOL_MODE_NONE : nvapi.h
  • NV_META_COMMAND_CONVOLUTION_POOL_MODE_REDUCTION_AVG : nvapi.h
  • NV_META_COMMAND_CONVOLUTION_POOL_MODE_REDUCTION_MAX : nvapi.h
  • NV_META_COMMAND_CONVOLUTION_POOL_MODE_REDUCTION_MIN : nvapi.h
  • NV_META_COMMAND_CONVOLUTION_SKIP_MODE_ADD : nvapi.h
  • NV_META_COMMAND_CONVOLUTION_SKIP_MODE_CONCAT : nvapi.h
  • NV_META_COMMAND_CONVOLUTION_SKIP_MODE_COUNT : nvapi.h
  • NV_META_COMMAND_CONVOLUTION_SKIP_MODE_NONE : nvapi.h
  • NV_META_COMMAND_CONVOLUTION_UPSAMPLE_MODE_BILINEAR : nvapi.h
  • NV_META_COMMAND_CONVOLUTION_UPSAMPLE_MODE_COUNT : nvapi.h
  • NV_META_COMMAND_CONVOLUTION_UPSAMPLE_MODE_NONE : nvapi.h
  • NV_META_COMMAND_CONVOLUTION_UPSAMPLE_MODE_REPLICATE : nvapi.h
  • NV_META_COMMAND_MATRIX_TRANSFORM_COUNT : nvapi.h
  • NV_META_COMMAND_MATRIX_TRANSFORM_NONE : nvapi.h
  • NV_META_COMMAND_MATRIX_TRANSFORM_TRANSPOSE : nvapi.h
  • NV_META_COMMAND_PADDING_CLAMP : nvapi.h
  • NV_META_COMMAND_PADDING_CONSTANT : nvapi.h
  • NV_META_COMMAND_PADDING_COUNT : nvapi.h
  • NV_META_COMMAND_PADDING_MIRROR : nvapi.h
  • NV_META_COMMAND_PADDING_ZEROS : nvapi.h
  • NV_META_COMMAND_PRECISION_COUNT : nvapi.h
  • NV_META_COMMAND_PRECISION_FLOAT16 : nvapi.h
  • NV_META_COMMAND_PRECISION_FLOAT32 : nvapi.h
  • NV_META_COMMAND_PRECISION_MUL_FLOAT16_ADD_FLOAT32 : nvapi.h
  • NV_META_COMMAND_RESOURCE_TYPE_BIAS : nvapi.h
  • NV_META_COMMAND_RESOURCE_TYPE_FILTER : nvapi.h
  • NV_META_COMMAND_RESOURCE_TYPE_INPUT : nvapi.h
  • NV_META_COMMAND_RESOURCE_TYPE_MATRIX_A : nvapi.h
  • NV_META_COMMAND_RESOURCE_TYPE_MATRIX_B : nvapi.h
  • NV_META_COMMAND_RESOURCE_TYPE_MATRIX_C : nvapi.h
  • NV_META_COMMAND_RESOURCE_TYPE_OUTPUT : nvapi.h
  • NV_META_COMMAND_RESOURCE_TYPE_PERSISTENT : nvapi.h
  • NV_META_COMMAND_RESOURCE_TYPE_TEMPORARY : nvapi.h
  • NV_META_COMMAND_RESOURCE_TYPE_WEIGHT : nvapi.h
  • NV_META_COMMAND_TENSOR_DATA_TYPE_COUNT : nvapi.h
  • NV_META_COMMAND_TENSOR_DATA_TYPE_FLOAT16 : nvapi.h
  • NV_META_COMMAND_TENSOR_DATA_TYPE_FLOAT32 : nvapi.h
  • NV_META_COMMAND_TENSOR_DATA_TYPE_UINT32 : nvapi.h
  • NV_META_COMMAND_TENSOR_FLAG_DATA_STATIC : nvapi.h
  • NV_META_COMMAND_TENSOR_FLAG_NONE : nvapi.h
  • NV_META_COMMAND_TENSOR_LAYOUT_COUNT : nvapi.h
  • NV_META_COMMAND_TENSOR_LAYOUT_STANDARD : nvapi.h
  • NV_META_COMMAND_TENSOR_LAYOUT_UNKNOWN : nvapi.h
  • NV_MONITOR_CAPS_TYPE_GENERIC : nvapi.h
  • NV_MONITOR_CAPS_TYPE_HDMI_VCDB : nvapi.h
  • NV_MONITOR_CAPS_TYPE_HDMI_VSDB : nvapi.h
  • NV_MONITOR_CONN_TYPE_COMPONENT : nvapi.h
  • NV_MONITOR_CONN_TYPE_COMPOSITE : nvapi.h
  • NV_MONITOR_CONN_TYPE_DP : nvapi.h
  • NV_MONITOR_CONN_TYPE_DVI : nvapi.h
  • NV_MONITOR_CONN_TYPE_HDMI : nvapi.h
  • NV_MONITOR_CONN_TYPE_LVDS : nvapi.h
  • NV_MONITOR_CONN_TYPE_SVIDEO : nvapi.h
  • NV_MONITOR_CONN_TYPE_UNINITIALIZED : nvapi.h
  • NV_MONITOR_CONN_TYPE_UNKNOWN : nvapi.h
  • NV_MONITOR_CONN_TYPE_VGA : nvapi.h
  • NV_MOSAIC_TOPO_1x2_BASIC : nvapi.h
  • NV_MOSAIC_TOPO_1x2_PASSIVE_STEREO : nvapi.h
  • NV_MOSAIC_TOPO_1x3_BASIC : nvapi.h
  • NV_MOSAIC_TOPO_1x3_PASSIVE_STEREO : nvapi.h
  • NV_MOSAIC_TOPO_1x4_BASIC : nvapi.h
  • NV_MOSAIC_TOPO_1x4_PASSIVE_STEREO : nvapi.h
  • NV_MOSAIC_TOPO_1x5_BASIC : nvapi.h
  • NV_MOSAIC_TOPO_1x6_BASIC : nvapi.h
  • NV_MOSAIC_TOPO_2x1_BASIC : nvapi.h
  • NV_MOSAIC_TOPO_2x1_PASSIVE_STEREO : nvapi.h
  • NV_MOSAIC_TOPO_2x2_BASIC : nvapi.h
  • NV_MOSAIC_TOPO_2x2_PASSIVE_STEREO : nvapi.h
  • NV_MOSAIC_TOPO_2x3_BASIC : nvapi.h
  • NV_MOSAIC_TOPO_2x4_BASIC : nvapi.h
  • NV_MOSAIC_TOPO_3x1_BASIC : nvapi.h
  • NV_MOSAIC_TOPO_3x1_PASSIVE_STEREO : nvapi.h
  • NV_MOSAIC_TOPO_3x2_BASIC : nvapi.h
  • NV_MOSAIC_TOPO_4x1_BASIC : nvapi.h
  • NV_MOSAIC_TOPO_4x1_PASSIVE_STEREO : nvapi.h
  • NV_MOSAIC_TOPO_4x2_BASIC : nvapi.h
  • NV_MOSAIC_TOPO_7x1_BASIC : nvapi.h
  • NV_MOSAIC_TOPO_BEGIN_BASIC : nvapi.h
  • NV_MOSAIC_TOPO_BEGIN_PASSIVE_STEREO : nvapi.h
  • NV_MOSAIC_TOPO_END_BASIC : nvapi.h
  • NV_MOSAIC_TOPO_END_PASSIVE_STEREO : nvapi.h
  • NV_MOSAIC_TOPO_MAX : nvapi.h
  • NV_MOSAIC_TOPO_NONE : nvapi.h
  • NV_MOSAIC_TOPO_TYPE_ALL : nvapi.h
  • NV_MOSAIC_TOPO_TYPE_BASIC : nvapi.h
  • NV_MOSAIC_TOPO_TYPE_MAX : nvapi.h
  • NV_MOSAIC_TOPO_TYPE_PASSIVE_STEREO : nvapi.h
  • NV_MOSAIC_TOPO_TYPE_PASSIVE_STEREO_SCALED_CLONE : nvapi.h
  • NV_MOSAIC_TOPO_TYPE_SCALED_CLONE : nvapi.h
  • NV_MRS_CONFIG_AGGRESSIVE : nvapi.h
  • NV_MRS_CONFIG_BALANCED : nvapi.h
  • NV_MRS_CONFIG_HTC_VIVE_AGGRESSIVE : nvapi.h
  • NV_MRS_CONFIG_HTC_VIVE_BALANCED : nvapi.h
  • NV_MRS_CONFIG_HTC_VIVE_CONSERVATIVE : nvapi.h
  • NV_MRS_CONFIG_OCULUSRIFT_CV1_AGGRESSIVE : nvapi.h
  • NV_MRS_CONFIG_OCULUSRIFT_CV1_BALANCED : nvapi.h
  • NV_MRS_CONFIG_OCULUSRIFT_CV1_CONSERVATIVE : nvapi.h
  • NV_MRS_NUM_CONFIGS : nvapi.h
  • NV_NONE_SEMANTIC : nvapi.h
  • NV_PACKED_EYE_INDEX_SEMANTIC : nvapi.h
  • NV_PIXEL_SHIFT_TYPE_2x2_BOTTOM_LEFT_PIXELS : nvapi.h
  • NV_PIXEL_SHIFT_TYPE_2x2_BOTTOM_RIGHT_PIXELS : nvapi.h
  • NV_PIXEL_SHIFT_TYPE_2x2_TOP_LEFT_PIXELS : nvapi.h
  • NV_PIXEL_SHIFT_TYPE_2x2_TOP_RIGHT_PIXELS : nvapi.h
  • NV_PIXEL_SHIFT_TYPE_NO_PIXEL_SHIFT : nvapi.h
  • NV_PIXEL_X0_CULL_RASTER_PIXELS : nvapi.h
  • NV_PIXEL_X16_PER_RASTER_PIXEL : nvapi.h
  • NV_PIXEL_X1_PER_1X2_RASTER_PIXELS : nvapi.h
  • NV_PIXEL_X1_PER_2X1_RASTER_PIXELS : nvapi.h
  • NV_PIXEL_X1_PER_2X2_RASTER_PIXELS : nvapi.h
  • NV_PIXEL_X1_PER_2X4_RASTER_PIXELS : nvapi.h
  • NV_PIXEL_X1_PER_4X2_RASTER_PIXELS : nvapi.h
  • NV_PIXEL_X1_PER_4X4_RASTER_PIXELS : nvapi.h
  • NV_PIXEL_X1_PER_RASTER_PIXEL : nvapi.h
  • NV_PIXEL_X2_PER_RASTER_PIXEL : nvapi.h
  • NV_PIXEL_X4_PER_RASTER_PIXEL : nvapi.h
  • NV_PIXEL_X8_PER_RASTER_PIXEL : nvapi.h
  • NV_POSITION_SEMANTIC : nvapi.h
  • NV_PSO_DOMAIN_SHADER_EXTENSION : nvapi.h
  • NV_PSO_ENABLE_DEPTH_BOUND_TEST_EXTENSION : nvapi.h
  • NV_PSO_EXPLICIT_FASTGS_EXTENSION : nvapi.h
  • NV_PSO_GEOMETRY_SHADER_EXTENSION : nvapi.h
  • NV_PSO_HULL_SHADER_EXTENSION : nvapi.h
  • NV_PSO_RASTER_EXTENSION : nvapi.h
  • NV_PSO_REQUEST_FASTGS_EXTENSION : nvapi.h
  • NV_PSO_SET_SHADER_EXTENSION_SLOT_AND_SPACE : nvapi.h
  • NV_PSO_SET_SHADER_EXTNENSION_SLOT_AND_SPACE : nvapi.h
  • NV_PSO_VERTEX_SHADER_EXTENSION : nvapi.h
  • NV_QSYNC_EVENT_HOUSESYNC_GAIN : nvapi.h
  • NV_QSYNC_EVENT_HOUSESYNC_LOSS : nvapi.h
  • NV_QSYNC_EVENT_NONE : nvapi.h
  • NV_QSYNC_EVENT_RJ45_GAIN : nvapi.h
  • NV_QSYNC_EVENT_RJ45_LOSS : nvapi.h
  • NV_QSYNC_EVENT_SYNC_GAIN : nvapi.h
  • NV_QSYNC_EVENT_SYNC_LOSS : nvapi.h
  • NV_QUALITY_UPSCALING_DEFAULT : NvApiDriverSettings.h
  • NV_QUALITY_UPSCALING_ID : NvApiDriverSettings.h
  • NV_QUALITY_UPSCALING_NUM_VALUES : NvApiDriverSettings.h
  • NV_QUALITY_UPSCALING_OFF : NvApiDriverSettings.h
  • NV_QUALITY_UPSCALING_ON : NvApiDriverSettings.h
  • NV_RESOLVE_MODE_SAMPLE_0 : nvapi.h
  • NV_ROTATE_0 : nvapi.h
  • NV_ROTATE_180 : nvapi.h
  • NV_ROTATE_270 : nvapi.h
  • NV_ROTATE_90 : nvapi.h
  • NV_ROTATE_IGNORED : nvapi.h
  • NV_SCALING_ADAPTER_SCALING : nvapi.h
  • NV_SCALING_ASPECT_SCALING : nvapi.h
  • NV_SCALING_CENTERED : nvapi.h
  • NV_SCALING_CUSTOMIZED : nvapi.h
  • NV_SCALING_DEFAULT : nvapi.h
  • NV_SCALING_GPU_INTEGER_ASPECT_SCALING : nvapi.h
  • NV_SCALING_GPU_SCALING_TO_ASPECT_SCANOUT_TO_CLOSEST : nvapi.h
  • NV_SCALING_GPU_SCALING_TO_ASPECT_SCANOUT_TO_NATIVE : nvapi.h
  • NV_SCALING_GPU_SCALING_TO_CLOSEST : nvapi.h
  • NV_SCALING_GPU_SCALING_TO_NATIVE : nvapi.h
  • NV_SCALING_GPU_SCANOUT_TO_CLOSEST : nvapi.h
  • NV_SCALING_GPU_SCANOUT_TO_NATIVE : nvapi.h
  • NV_SCALING_MONITOR_SCALING : nvapi.h
  • NV_SMP_ASSIST_EYE_INDEX_INSTANCED_STEREO : nvapi.h
  • NV_SMP_ASSIST_EYE_INDEX_LEFT_EYE : nvapi.h
  • NV_SMP_ASSIST_EYE_INDEX_MONO : nvapi.h
  • NV_SMP_ASSIST_EYE_INDEX_RIGHT_EYE : nvapi.h
  • NV_SMP_ASSIST_LEVEL_FULL : nvapi.h
  • NV_SMP_ASSIST_LEVEL_MINIMAL : nvapi.h
  • NV_SMP_ASSIST_LEVEL_PARTIAL : nvapi.h
  • NV_SMP_ASSIST_LMS : nvapi.h
  • NV_SMP_ASSIST_MRS : nvapi.h
  • NV_SMP_ASSIST_NONE : nvapi.h
  • NV_SMP_ASSIST_NUM_LEVELS : nvapi.h
  • NV_SMP_ASSIST_NUM_TYPES : nvapi.h
  • NV_SRRV_DIMENSION_TEXTURE2D : nvapi.h
  • NV_SRRV_DIMENSION_TEXTURE2DARRAY : nvapi.h
  • NV_STATIC_METADATA_TYPE_1 : nvapi.h
  • NV_STEREO_VIDEO_FORMAT_LAST : nvapi.h
  • NV_STEREO_VIDEO_FORMAT_MONO_PLUS_OFFSET : nvapi.h
  • NV_STEREO_VIDEO_FORMAT_NOT_STEREO : nvapi.h
  • NV_STEREO_VIDEO_FORMAT_ROW_INTERLEAVE_LR : nvapi.h
  • NV_STEREO_VIDEO_FORMAT_ROW_INTERLEAVE_RL : nvapi.h
  • NV_STEREO_VIDEO_FORMAT_SIDE_BY_SIDE_LR : nvapi.h
  • NV_STEREO_VIDEO_FORMAT_SIDE_BY_SIDE_RL : nvapi.h
  • NV_STEREO_VIDEO_FORMAT_TOP_BOTTOM_LR : nvapi.h
  • NV_STEREO_VIDEO_FORMAT_TOP_BOTTOM_RL : nvapi.h
  • NV_STEREO_VIDEO_FORMAT_TWO_FRAMES_LR : nvapi.h
  • NV_SWIZZLE_NEG_W : nvapi.h
  • NV_SWIZZLE_NEG_X : nvapi.h
  • NV_SWIZZLE_NEG_Y : nvapi.h
  • NV_SWIZZLE_NEG_Z : nvapi.h
  • NV_SWIZZLE_OFFSET_W : nvapi.h
  • NV_SWIZZLE_OFFSET_X : nvapi.h
  • NV_SWIZZLE_OFFSET_Y : nvapi.h
  • NV_SWIZZLE_OFFSET_Z : nvapi.h
  • NV_SWIZZLE_POS_W : nvapi.h
  • NV_SWIZZLE_POS_X : nvapi.h
  • NV_SWIZZLE_POS_Y : nvapi.h
  • NV_SWIZZLE_POS_Z : nvapi.h
  • NV_SYSTEM_TYPE_DESKTOP : nvapi.h
  • NV_SYSTEM_TYPE_DGPU : nvapi.h
  • NV_SYSTEM_TYPE_GPU_UNKNOWN : nvapi.h
  • NV_SYSTEM_TYPE_IGPU : nvapi.h
  • NV_SYSTEM_TYPE_LAPTOP : nvapi.h
  • NV_SYSTEM_TYPE_UNKNOWN : nvapi.h
  • NV_TIMING_OVERRIDE_ANALOG_TV : nvapi.h
  • NV_TIMING_OVERRIDE_AUTO : nvapi.h
  • NV_TIMING_OVERRIDE_CURRENT : nvapi.h
  • NV_TIMING_OVERRIDE_CUST : nvapi.h
  • NV_TIMING_OVERRIDE_CVT : nvapi.h
  • NV_TIMING_OVERRIDE_CVT_RB : nvapi.h
  • NV_TIMING_OVERRIDE_DMT : nvapi.h
  • NV_TIMING_OVERRIDE_DMT_RB : nvapi.h
  • NV_TIMING_OVERRIDE_EDID : nvapi.h
  • NV_TIMING_OVERRIDE_EIA861 : nvapi.h
  • NV_TIMING_OVERRIDE_GTF : nvapi.h
  • NV_TIMING_OVERRIDE_NV_ASPR : nvapi.h
  • NV_TIMING_OVERRIDE_NV_PREDEFINED : nvapi.h
  • NV_TIMING_OVERRIDE_NV_PSF : nvapi.h
  • NV_TIMING_OVERRIDE_SDI : nvapi.h
  • NV_TIMING_OVRRIDE_MAX : nvapi.h
  • NV_VIEW_MODE_CLONE : nvapi.h
  • NV_VIEW_MODE_DUALVIEW : nvapi.h
  • NV_VIEW_MODE_HSPAN : nvapi.h
  • NV_VIEW_MODE_MULTIVIEW : nvapi.h
  • NV_VIEW_MODE_STANDARD : nvapi.h
  • NV_VIEW_MODE_VSPAN : nvapi.h
  • NV_VIEWPORT_MASK_2_SEMANTIC : nvapi.h
  • NV_VIEWPORT_MASK_SEMANTIC : nvapi.h
  • NV_VIRTUALIZATION_MODE_HOST_VGPU : nvapi.h
  • NV_VIRTUALIZATION_MODE_NMOS : nvapi.h
  • NV_VIRTUALIZATION_MODE_NONE : nvapi.h
  • NV_VIRTUALIZATION_MODE_VGX : nvapi.h
  • NV_VRS_CONTENT_TYPE_FOVEATED_RENDERING : nvapi.h
  • NV_VRS_CONTENT_TYPE_INVALID : nvapi.h
  • NV_VRS_CONTENT_TYPE_MAX : nvapi.h
  • NV_VRS_RENDER_MODE_INVALID : nvapi.h
  • NV_VRS_RENDER_MODE_LEFT_EYE : nvapi.h
  • NV_VRS_RENDER_MODE_MAX : nvapi.h
  • NV_VRS_RENDER_MODE_MONO : nvapi.h
  • NV_VRS_RENDER_MODE_RIGHT_EYE : nvapi.h
  • NV_VRS_RENDER_MODE_STEREO : nvapi.h
  • NV_X_RIGHT_SEMANTIC : nvapi.h
  • NV_XYZW_RIGHT_SEMANTIC : nvapi.h
  • NVAPI_ACCESS_DENIED : nvapi_lite_common.h
  • NVAPI_ADVANCED_DISPLAY_TOPOLOGY_REQUIRED : nvapi_lite_common.h
  • NVAPI_ALIAS_SURFACE_FLAG_MASK : nvapi.h
  • NVAPI_ALIAS_SURFACE_FLAG_NONE : nvapi.h
  • NVAPI_ALIAS_SURFACE_FLAG_USE_SUPER : nvapi.h
  • NVAPI_ANSEL_FEATURE_BLACK_AND_WHITE : nvapi.h
  • NVAPI_ANSEL_FEATURE_HUDLESS : nvapi.h
  • NVAPI_ANSEL_FEATURE_STATE_DISABLE : nvapi.h
  • NVAPI_ANSEL_FEATURE_STATE_ENABLE : nvapi.h
  • NVAPI_ANSEL_FEATURE_STATE_UNKNOWN : nvapi.h
  • NVAPI_ANSEL_FEATURE_UNKNOWN : nvapi.h
  • NVAPI_ANSEL_HOTKEY_MODIFIER_ALT : nvapi.h
  • NVAPI_ANSEL_HOTKEY_MODIFIER_CTRL : nvapi.h
  • NVAPI_ANSEL_HOTKEY_MODIFIER_SHIFT : nvapi.h
  • NVAPI_ANSEL_HOTKEY_MODIFIER_UNKNOWN : nvapi.h
  • NVAPI_API_IN_USE : nvapi_lite_common.h
  • NVAPI_API_NOT_INITIALIZED : nvapi_lite_common.h
  • NVAPI_ARGUMENT_EXCEED_MAX_SIZE : nvapi_lite_common.h
  • NVAPI_CALLBACK_ALREADY_REGISTERED : nvapi_lite_common.h
  • NVAPI_CALLBACK_NOT_FOUND : nvapi_lite_common.h
  • NVAPI_CLUSTER_ALREADY_EXISTS : nvapi_lite_common.h
  • NVAPI_CONVERGENCE_ID : nvapi.h
  • NVAPI_D3D10_1_LIBRARY_NOT_FOUND : nvapi_lite_common.h
  • NVAPI_D3D11_LIBRARY_NOT_FOUND : nvapi_lite_common.h
  • NVAPI_D3D12_GET_CUDA_INDEPENDENT_DESCRIPTOR_OBJECT_SAMPLER : nvapi.h
  • NVAPI_D3D12_GET_CUDA_INDEPENDENT_DESCRIPTOR_OBJECT_SURFACE : nvapi.h
  • NVAPI_D3D12_GET_CUDA_INDEPENDENT_DESCRIPTOR_OBJECT_TEXTURE : nvapi.h
  • NVAPI_D3D12_PIPELINE_CREATION_STATE_FLAGS_ENABLE_DMM_SUPPORT : nvapi.h
  • NVAPI_D3D12_PIPELINE_CREATION_STATE_FLAGS_ENABLE_OMM_SUPPORT : nvapi.h
  • NVAPI_D3D12_PIPELINE_CREATION_STATE_FLAGS_NONE : nvapi.h
  • NVAPI_D3D12_RAYTRACING_ACCELERATION_STRUCTURE_BUILD_FLAG_ALLOW_COMPACTION_EX : nvapi.h
  • NVAPI_D3D12_RAYTRACING_ACCELERATION_STRUCTURE_BUILD_FLAG_ALLOW_DATA_ACCESS_EX : nvapi.h
  • NVAPI_D3D12_RAYTRACING_ACCELERATION_STRUCTURE_BUILD_FLAG_ALLOW_DISABLE_OMMS_EX : nvapi.h
  • NVAPI_D3D12_RAYTRACING_ACCELERATION_STRUCTURE_BUILD_FLAG_ALLOW_OMM_OPACITY_STATES_UPDATE_EX : nvapi.h
  • NVAPI_D3D12_RAYTRACING_ACCELERATION_STRUCTURE_BUILD_FLAG_ALLOW_OMM_UPDATE_EX : nvapi.h
  • NVAPI_D3D12_RAYTRACING_ACCELERATION_STRUCTURE_BUILD_FLAG_ALLOW_UPDATE_EX : nvapi.h
  • NVAPI_D3D12_RAYTRACING_ACCELERATION_STRUCTURE_BUILD_FLAG_MINIMIZE_MEMORY_EX : nvapi.h
  • NVAPI_D3D12_RAYTRACING_ACCELERATION_STRUCTURE_BUILD_FLAG_NONE_EX : nvapi.h
  • NVAPI_D3D12_RAYTRACING_ACCELERATION_STRUCTURE_BUILD_FLAG_PERFORM_UPDATE_EX : nvapi.h
  • NVAPI_D3D12_RAYTRACING_ACCELERATION_STRUCTURE_BUILD_FLAG_PREFER_FAST_BUILD_EX : nvapi.h
  • NVAPI_D3D12_RAYTRACING_ACCELERATION_STRUCTURE_BUILD_FLAG_PREFER_FAST_TRACE_EX : nvapi.h
  • NVAPI_D3D12_RAYTRACING_CAPS_TYPE_DISPLACEMENT_MICROMAP : nvapi.h
  • NVAPI_D3D12_RAYTRACING_CAPS_TYPE_INVALID : nvapi.h
  • NVAPI_D3D12_RAYTRACING_CAPS_TYPE_OPACITY_MICROMAP : nvapi.h
  • NVAPI_D3D12_RAYTRACING_CAPS_TYPE_THREAD_REORDERING : nvapi.h
  • NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_BUILD_FLAG_NONE : nvapi.h
  • NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_BUILD_FLAG_PREFER_FAST_BUILD : nvapi.h
  • NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_BUILD_FLAG_PREFER_FAST_TRACE : nvapi.h
  • NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_POSTBUILD_INFO_CURRENT_SIZE : nvapi.h
  • NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_CAP_NONE : nvapi.h
  • NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_CAP_STANDARD : nvapi.h
  • NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_FORMAT_DC1_1024_TRIS_128_BYTES : nvapi.h
  • NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_FORMAT_DC1_256_TRIS_128_BYTES : nvapi.h
  • NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_FORMAT_DC1_64_TRIS_64_BYTES : nvapi.h
  • NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_PRIMITIVE_FLAG_DECIMATE_01 : nvapi.h
  • NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_PRIMITIVE_FLAG_DECIMATE_12 : nvapi.h
  • NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_PRIMITIVE_FLAG_DECIMATE_20 : nvapi.h
  • NVAPI_D3D12_RAYTRACING_GEOMETRY_TYPE_DMM_TRIANGLES_EX : nvapi.h
  • NVAPI_D3D12_RAYTRACING_GEOMETRY_TYPE_OMM_TRIANGLES_EX : nvapi.h
  • NVAPI_D3D12_RAYTRACING_GEOMETRY_TYPE_PROCEDURAL_PRIMITIVE_AABBS_EX : nvapi.h
  • NVAPI_D3D12_RAYTRACING_GEOMETRY_TYPE_TRIANGLES_EX : nvapi.h
  • NVAPI_D3D12_RAYTRACING_INSTANCE_FLAG_DISABLE_OMMS_EX : nvapi.h
  • NVAPI_D3D12_RAYTRACING_INSTANCE_FLAG_FORCE_NON_OPAQUE_EX : nvapi.h
  • NVAPI_D3D12_RAYTRACING_INSTANCE_FLAG_FORCE_OMM_2_STATE_EX : nvapi.h
  • NVAPI_D3D12_RAYTRACING_INSTANCE_FLAG_FORCE_OPAQUE_EX : nvapi.h
  • NVAPI_D3D12_RAYTRACING_INSTANCE_FLAG_NONE_EX : nvapi.h
  • NVAPI_D3D12_RAYTRACING_INSTANCE_FLAG_TRIANGLE_CULL_DISABLE_EX : nvapi.h
  • NVAPI_D3D12_RAYTRACING_INSTANCE_FLAG_TRIANGLE_FRONT_COUNTERCLOCKWISE_EX : nvapi.h
  • NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_ARRAY_BUILD_FLAG_NONE : nvapi.h
  • NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_ARRAY_BUILD_FLAG_PREFER_FAST_BUILD : nvapi.h
  • NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_ARRAY_BUILD_FLAG_PREFER_FAST_TRACE : nvapi.h
  • NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_ARRAY_POSTBUILD_INFO_CURRENT_SIZE : nvapi.h
  • NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_CAP_NONE : nvapi.h
  • NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_CAP_STANDARD : nvapi.h
  • NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_FORMAT_OC1_2_STATE : nvapi.h
  • NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_FORMAT_OC1_4_STATE : nvapi.h
  • NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_SPECIAL_INDEX_FULLY_OPAQUE : nvapi.h
  • NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_SPECIAL_INDEX_FULLY_TRANSPARENT : nvapi.h
  • NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_SPECIAL_INDEX_FULLY_UNKNOWN_OPAQUE : nvapi.h
  • NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_SPECIAL_INDEX_FULLY_UNKNOWN_TRANSPARENT : nvapi.h
  • NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_STATE_OPAQUE : nvapi.h
  • NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_STATE_TRANSPARENT : nvapi.h
  • NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_STATE_UNKNOWN_OPAQUE : nvapi.h
  • NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_STATE_UNKNOWN_TRANSPARENT : nvapi.h
  • NVAPI_D3D12_RAYTRACING_THREAD_REORDERING_CAP_NONE : nvapi.h
  • NVAPI_D3D12_RAYTRACING_THREAD_REORDERING_CAP_STANDARD : nvapi.h
  • NVAPI_D3D12_RAYTRACING_VALIDATION_FLAG_NONE : nvapi.h
  • NVAPI_D3D12_RAYTRACING_VALIDATION_MESSAGE_SEVERITY_ERROR : nvapi.h
  • NVAPI_D3D12_RAYTRACING_VALIDATION_MESSAGE_SEVERITY_WARNING : nvapi.h
  • NVAPI_D3D12_SERIALIZED_DATA_RAYTRACING_ACCELERATION_STRUCTURE_EX : nvapi.h
  • NVAPI_D3D12_SERIALIZED_DATA_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_EX : nvapi.h
  • NVAPI_D3D12_SERIALIZED_DATA_RAYTRACING_OPACITY_MICROMAP_ARRAY_EX : nvapi.h
  • NVAPI_D3D_BEGIN_UAV_OVERLAP_COMP_WFI : nvapi.h
  • NVAPI_D3D_BEGIN_UAV_OVERLAP_GFX_WFI : nvapi.h
  • NVAPI_D3D_BEGIN_UAV_OVERLAP_NO_WFI : nvapi.h
  • NVAPI_D3D_CONTEXT_NOT_FOUND : nvapi_lite_common.h
  • NVAPI_D3D_DEVICE_LOST : nvapi_lite_common.h
  • NVAPI_D3D_DEVICE_NOT_REGISTERED : nvapi_lite_common.h
  • NVAPI_D3D_RR_FLAG_DEFAULTS : nvapi_lite_sli.h
  • NVAPI_D3D_RR_FLAG_FORCE_DISCARD_CONTENT : nvapi_lite_sli.h
  • NVAPI_D3D_RR_FLAG_FORCE_KEEP_CONTENT : nvapi_lite_sli.h
  • NVAPI_D3D_RR_FLAG_MULTI_FRAME : nvapi_lite_sli.h
  • NVAPI_D3D_SRH_CATEGORY_SLI : nvapi_lite_sli.h
  • NVAPI_D3D_SRH_SLI_APP_CONTROLLED_INTERFRAME_CONTENT_SYNC : nvapi_lite_sli.h
  • NVAPI_D3D_SRH_SLI_ASK_FOR_BROADCAST_USAGE : nvapi_lite_sli.h
  • NVAPI_D3D_SRH_SLI_RESPECT_DRIVER_INTERFRAME_CONTENT_SYNC : nvapi_lite_sli.h
  • NVAPI_DATA_NOT_FOUND : nvapi_lite_common.h
  • NVAPI_DATATYPE_MISMATCH : nvapi_lite_common.h
  • NVAPI_DEFAULT_STEREO_PROFILE_DOES_NOT_EXIST : nvapi_lite_common.h
  • NVAPI_DEFAULT_STEREO_PROFILE_IS_NOT_DEFINED : nvapi_lite_common.h
  • NVAPI_DEVICE_BUSY : nvapi_lite_common.h
  • NVAPI_DEVICE_FEATURE_LEVEL_10_0 : nvapi_lite_d3dext.h
  • NVAPI_DEVICE_FEATURE_LEVEL_10_0_PLUS : nvapi_lite_d3dext.h
  • NVAPI_DEVICE_FEATURE_LEVEL_10_1 : nvapi_lite_d3dext.h
  • NVAPI_DEVICE_FEATURE_LEVEL_11_0 : nvapi_lite_d3dext.h
  • NVAPI_DEVICE_FEATURE_LEVEL_NULL : nvapi_lite_d3dext.h
  • NVAPI_DEVICE_SWITCHING_NOT_ALLOWED : nvapi_lite_common.h
  • NVAPI_DISPLAY_IN_USE : nvapi_lite_common.h
  • NVAPI_DISPLAY_MUX_TRANSITION_FAILED : nvapi_lite_common.h
  • NVAPI_DISPLAYCONFIG_VALIDATION_FAILED : nvapi_lite_common.h
  • NVAPI_DPMST_CHANGED : nvapi_lite_common.h
  • NVAPI_DPMST_DISPLAY_ID_EXPECTED : nvapi_lite_common.h
  • NVAPI_DRIVER_NOTRUNNING : nvapi_lite_common.h
  • NVAPI_DRIVER_RUNNING : nvapi_lite_common.h
  • NVAPI_ECID_KEY_VERIFICATION_FAILED : nvapi_lite_common.h
  • NVAPI_ECID_SIGN_ALGO_UNSUPPORTED : nvapi_lite_common.h
  • NVAPI_END_ENUMERATION : nvapi_lite_common.h
  • NVAPI_ERROR : nvapi_lite_common.h
  • NVAPI_ERROR_DRIVER_RELOAD_IN_PROGRESS : nvapi_lite_common.h
  • NVAPI_ERROR_DRIVER_RELOAD_REQUIRED : nvapi_lite_common.h
  • NVAPI_EXECUTABLE_ALREADY_IN_USE : nvapi_lite_common.h
  • NVAPI_EXECUTABLE_NOT_FOUND : nvapi_lite_common.h
  • NVAPI_EXECUTABLE_PATH_IS_AMBIGUOUS : nvapi_lite_common.h
  • NVAPI_EXPECTED_ANALOG_DISPLAY : nvapi_lite_common.h
  • NVAPI_EXPECTED_COMPUTE_GPU_HANDLE : nvapi_lite_common.h
  • NVAPI_EXPECTED_DIGITAL_FLAT_PANEL : nvapi_lite_common.h
  • NVAPI_EXPECTED_DISPLAY_HANDLE : nvapi_lite_common.h
  • NVAPI_EXPECTED_LOGICAL_GPU_HANDLE : nvapi_lite_common.h
  • NVAPI_EXPECTED_NON_PRIMARY_DISPLAY_HANDLE : nvapi_lite_common.h
  • NVAPI_EXPECTED_PHYSICAL_GPU_HANDLE : nvapi_lite_common.h
  • NVAPI_EXPECTED_TV_DISPLAY : nvapi_lite_common.h
  • NVAPI_EXPECTED_TV_DISPLAY_ON_DCONNECTOR : nvapi_lite_common.h
  • NVAPI_EXPECTED_UNATTACHED_DISPLAY_HANDLE : nvapi_lite_common.h
  • NVAPI_FAILED_TO_LOAD_FROM_DRIVER_STORE : nvapi_lite_common.h
  • NVAPI_FILE_NOT_FOUND : nvapi_lite_common.h
  • NVAPI_FIRMWARE_OUT_OF_DATE : nvapi_lite_common.h
  • NVAPI_FIRMWARE_REVISION_NOT_SUPPORTED : nvapi_lite_common.h
  • NVAPI_FRUSTUM_ADJUST_MODE_ID : nvapi.h
  • NVAPI_FRUSTUM_CLEAR_EDGES : nvapi.h
  • NVAPI_FRUSTUM_STRETCH : nvapi.h
  • NVAPI_FUNCTION_NOT_FOUND : nvapi_lite_common.h
  • NVAPI_GPU_BUS_TYPE_AGP : nvapi.h
  • NVAPI_GPU_BUS_TYPE_AXI : nvapi.h
  • NVAPI_GPU_BUS_TYPE_FPCI : nvapi.h
  • NVAPI_GPU_BUS_TYPE_PCI : nvapi.h
  • NVAPI_GPU_BUS_TYPE_PCI_EXPRESS : nvapi.h
  • NVAPI_GPU_BUS_TYPE_UNDEFINED : nvapi.h
  • NVAPI_GPU_CONNECTOR_ADC : nvapi.h
  • NVAPI_GPU_CONNECTOR_DISPLAYPORT_EXTERNAL : nvapi.h
  • NVAPI_GPU_CONNECTOR_DISPLAYPORT_INTERNAL : nvapi.h
  • NVAPI_GPU_CONNECTOR_DISPLAYPORT_MINI_EXT : nvapi.h
  • NVAPI_GPU_CONNECTOR_DVI_D : nvapi.h
  • NVAPI_GPU_CONNECTOR_DVI_I : nvapi.h
  • NVAPI_GPU_CONNECTOR_DVI_I_TV_COMPOSITE : nvapi.h
  • NVAPI_GPU_CONNECTOR_DVI_I_TV_SVIDEO : nvapi.h
  • NVAPI_GPU_CONNECTOR_HDMI_A : nvapi.h
  • NVAPI_GPU_CONNECTOR_HDMI_C_MINI : nvapi.h
  • NVAPI_GPU_CONNECTOR_LFH_DISPLAYPORT_1 : nvapi.h
  • NVAPI_GPU_CONNECTOR_LFH_DISPLAYPORT_2 : nvapi.h
  • NVAPI_GPU_CONNECTOR_LFH_DVI_I_1 : nvapi.h
  • NVAPI_GPU_CONNECTOR_LFH_DVI_I_2 : nvapi.h
  • NVAPI_GPU_CONNECTOR_OEM : nvapi.h
  • NVAPI_GPU_CONNECTOR_PC_POD_COMPOSITE : nvapi.h
  • NVAPI_GPU_CONNECTOR_PC_POD_HDTV_YPRPB : nvapi.h
  • NVAPI_GPU_CONNECTOR_PC_POD_SVIDEO : nvapi.h
  • NVAPI_GPU_CONNECTOR_SPWG : nvapi.h
  • NVAPI_GPU_CONNECTOR_TV_COMPOSITE : nvapi.h
  • NVAPI_GPU_CONNECTOR_TV_COMPOSITE_SCART_ON_EIAJ4120 : nvapi.h
  • NVAPI_GPU_CONNECTOR_TV_HDTV_COMPONENT : nvapi.h
  • NVAPI_GPU_CONNECTOR_TV_HDTV_EIAJ4120 : nvapi.h
  • NVAPI_GPU_CONNECTOR_TV_SCART : nvapi.h
  • NVAPI_GPU_CONNECTOR_TV_SVIDEO : nvapi.h
  • NVAPI_GPU_CONNECTOR_UNKNOWN : nvapi.h
  • NVAPI_GPU_CONNECTOR_USB_C : nvapi.h
  • NVAPI_GPU_CONNECTOR_VGA_15_PIN : nvapi.h
  • NVAPI_GPU_CONNECTOR_VIRTUAL_WFD : nvapi.h
  • NVAPI_GPU_IN_DEBUG_MODE : nvapi_lite_common.h
  • NVAPI_GPU_NOT_POWERED : nvapi_lite_common.h
  • NVAPI_GPU_OUTPUT_CRT : nvapi.h
  • NVAPI_GPU_OUTPUT_DFP : nvapi.h
  • NVAPI_GPU_OUTPUT_TV : nvapi.h
  • NVAPI_GPU_OUTPUT_UNKNOWN : nvapi.h
  • NVAPI_GPU_PERF_PSTATE20_CLOCK_TYPE_RANGE : nvapi.h
  • NVAPI_GPU_PERF_PSTATE20_CLOCK_TYPE_SINGLE : nvapi.h
  • NVAPI_GPU_PERF_PSTATE_ALL : nvapi.h
  • NVAPI_GPU_PERF_PSTATE_P0 : nvapi.h
  • NVAPI_GPU_PERF_PSTATE_P1 : nvapi.h
  • NVAPI_GPU_PERF_PSTATE_P10 : nvapi.h
  • NVAPI_GPU_PERF_PSTATE_P11 : nvapi.h
  • NVAPI_GPU_PERF_PSTATE_P12 : nvapi.h
  • NVAPI_GPU_PERF_PSTATE_P13 : nvapi.h
  • NVAPI_GPU_PERF_PSTATE_P14 : nvapi.h
  • NVAPI_GPU_PERF_PSTATE_P15 : nvapi.h
  • NVAPI_GPU_PERF_PSTATE_P2 : nvapi.h
  • NVAPI_GPU_PERF_PSTATE_P3 : nvapi.h
  • NVAPI_GPU_PERF_PSTATE_P4 : nvapi.h
  • NVAPI_GPU_PERF_PSTATE_P5 : nvapi.h
  • NVAPI_GPU_PERF_PSTATE_P6 : nvapi.h
  • NVAPI_GPU_PERF_PSTATE_P7 : nvapi.h
  • NVAPI_GPU_PERF_PSTATE_P8 : nvapi.h
  • NVAPI_GPU_PERF_PSTATE_P9 : nvapi.h
  • NVAPI_GPU_PERF_PSTATE_UNDEFINED : nvapi.h
  • NVAPI_GPU_PERF_VOLTAGE_INFO_DOMAIN_CORE : nvapi.h
  • NVAPI_GPU_PERF_VOLTAGE_INFO_DOMAIN_UNDEFINED : nvapi.h
  • NVAPI_GPU_PUBLIC_CLOCK_GRAPHICS : nvapi.h
  • NVAPI_GPU_PUBLIC_CLOCK_MEMORY : nvapi.h
  • NVAPI_GPU_PUBLIC_CLOCK_PROCESSOR : nvapi.h
  • NVAPI_GPU_PUBLIC_CLOCK_UNDEFINED : nvapi.h
  • NVAPI_GPU_PUBLIC_CLOCK_VIDEO : nvapi.h
  • NVAPI_GPU_WORKSTATION_FEATURE_INCOMPLETE : nvapi_lite_common.h
  • NVAPI_GPU_WORKSTATION_FEATURE_MASK_BPC10 : nvapi.h
  • NVAPI_GPU_WORKSTATION_FEATURE_MASK_GRAYSCALE : nvapi.h
  • NVAPI_GPU_WORKSTATION_FEATURE_MASK_PIXINTENSITY : nvapi.h
  • NVAPI_GPU_WORKSTATION_FEATURE_MASK_STEREO : nvapi.h
  • NVAPI_GPU_WORKSTATION_FEATURE_MASK_SWAPGROUP : nvapi.h
  • NVAPI_GPU_WORKSTATION_FEATURE_MASK_WARPING : nvapi.h
  • NVAPI_GSYNC_DELAY_TYPE_STARTUP : nvapi.h
  • NVAPI_GSYNC_DELAY_TYPE_SYNC_SKEW : nvapi.h
  • NVAPI_GSYNC_DELAY_TYPE_UNKNOWN : nvapi.h
  • NVAPI_GSYNC_DISPLAY_SYNC_STATE_MASTER : nvapi.h
  • NVAPI_GSYNC_DISPLAY_SYNC_STATE_SLAVE : nvapi.h
  • NVAPI_GSYNC_DISPLAY_SYNC_STATE_UNSYNCED : nvapi.h
  • NVAPI_GSYNC_DIVIDE_MODE : nvapi.h
  • NVAPI_GSYNC_GPU_TOPOLOGY_CONNECTOR_NONE : nvapi.h
  • NVAPI_GSYNC_GPU_TOPOLOGY_CONNECTOR_PRIMARY : nvapi.h
  • NVAPI_GSYNC_GPU_TOPOLOGY_CONNECTOR_QUARTERNARY : nvapi.h
  • NVAPI_GSYNC_GPU_TOPOLOGY_CONNECTOR_SECONDARY : nvapi.h
  • NVAPI_GSYNC_GPU_TOPOLOGY_CONNECTOR_TERTIARY : nvapi.h
  • NVAPI_GSYNC_MULTIPLY_MODE : nvapi.h
  • NVAPI_GSYNC_POLARITY_BOTH_EDGES : nvapi.h
  • NVAPI_GSYNC_POLARITY_FALLING_EDGE : nvapi.h
  • NVAPI_GSYNC_POLARITY_RISING_EDGE : nvapi.h
  • NVAPI_GSYNC_RJ45_INPUT : nvapi.h
  • NVAPI_GSYNC_RJ45_OUTPUT : nvapi.h
  • NVAPI_GSYNC_RJ45_UNUSED : nvapi.h
  • NVAPI_GSYNC_SYNC_SOURCE_HOUSESYNC : nvapi.h
  • NVAPI_GSYNC_SYNC_SOURCE_VSYNC : nvapi.h
  • NVAPI_GSYNC_UNDEFINED_MODE : nvapi.h
  • NVAPI_GSYNC_VIDEO_MODE_COMPOSITE : nvapi.h
  • NVAPI_GSYNC_VIDEO_MODE_HDTV : nvapi.h
  • NVAPI_GSYNC_VIDEO_MODE_NONE : nvapi.h
  • NVAPI_GSYNC_VIDEO_MODE_NTSCPALSECAM : nvapi.h
  • NVAPI_GSYNC_VIDEO_MODE_TTL : nvapi.h
  • NVAPI_HANDLE_INVALIDATED : nvapi_lite_common.h
  • NVAPI_HDCP_DISABLED : nvapi_lite_common.h
  • NVAPI_HDCP_ENCRYPTION_FAILED : nvapi_lite_common.h
  • NVAPI_I2C_SPEED_100KHZ : nvapi.h
  • NVAPI_I2C_SPEED_10KHZ : nvapi.h
  • NVAPI_I2C_SPEED_200KHZ : nvapi.h
  • NVAPI_I2C_SPEED_33KHZ : nvapi.h
  • NVAPI_I2C_SPEED_3KHZ : nvapi.h
  • NVAPI_I2C_SPEED_400KHZ : nvapi.h
  • NVAPI_I2C_SPEED_DEFAULT : nvapi.h
  • NVAPI_ID_OUT_OF_RANGE : nvapi_lite_common.h
  • NVAPI_ILLEGAL_INSTRUCTION : nvapi_lite_common.h
  • NVAPI_IMPLICIT_SET_GPU_TOPOLOGY_CHANGE_NOT_ALLOWED : nvapi_lite_common.h
  • NVAPI_INCOMPATIBLE_AUDIO_DRIVER : nvapi_lite_common.h
  • NVAPI_INCOMPATIBLE_STRUCT_VERSION : nvapi_lite_common.h
  • NVAPI_INCORRECT_VENDOR : nvapi_lite_common.h
  • NVAPI_INSTRUMENTATION_DISABLED : nvapi_lite_common.h
  • NVAPI_INSUFFICIENT_BUFFER : nvapi_lite_common.h
  • NVAPI_INVALID_ADDRESS : nvapi_lite_common.h
  • NVAPI_INVALID_ARGUMENT : nvapi_lite_common.h
  • NVAPI_INVALID_CALL : nvapi_lite_common.h
  • NVAPI_INVALID_COMBINATION : nvapi_lite_common.h
  • NVAPI_INVALID_CONFIGURATION : nvapi_lite_common.h
  • NVAPI_INVALID_DIRECT_MODE_DISPLAY : nvapi_lite_common.h
  • NVAPI_INVALID_DISPLAY_ID : nvapi_lite_common.h
  • NVAPI_INVALID_DSC_OUTPUT_BPP : nvapi_lite_common.h
  • NVAPI_INVALID_DSC_SLICECOUNT : nvapi_lite_common.h
  • NVAPI_INVALID_DSC_VERSION : nvapi_lite_common.h
  • NVAPI_INVALID_HANDLE : nvapi_lite_common.h
  • NVAPI_INVALID_HYBRID_MODE : nvapi_lite_common.h
  • NVAPI_INVALID_IMAGE : nvapi_lite_common.h
  • NVAPI_INVALID_OUTPUT_WIRE_FORMAT : nvapi_lite_common.h
  • NVAPI_INVALID_PC : nvapi_lite_common.h
  • NVAPI_INVALID_PERF_LEVEL : nvapi_lite_common.h
  • NVAPI_INVALID_POINTER : nvapi_lite_common.h
  • NVAPI_INVALID_PTX : nvapi_lite_common.h
  • NVAPI_INVALID_SOURCE : nvapi_lite_common.h
  • NVAPI_INVALID_SYNC_TOPOLOGY : nvapi_lite_common.h
  • NVAPI_INVALID_USER_PRIVILEGE : nvapi_lite_common.h
  • NVAPI_JIT_COMPILER_NOT_FOUND : nvapi_lite_common.h
  • NVAPI_LAUNCH_FAILED : nvapi_lite_common.h
  • NVAPI_LIBRARY_NOT_FOUND : nvapi_lite_common.h
  • NVAPI_LICENSE_CALLER_AUTHENTICATION_FAILED : nvapi_lite_common.h
  • NVAPI_MATCHING_DEVICE_NOT_FOUND : nvapi_lite_common.h
  • NVAPI_MAX_DISPLAY_LIMIT_REACHED : nvapi_lite_common.h
  • NVAPI_MIXED_TARGET_TYPES : nvapi_lite_common.h
  • NVAPI_MODE_CHANGE_FAILED : nvapi_lite_common.h
  • NVAPI_MOSAIC_NOT_ACTIVE : nvapi_lite_common.h
  • NVAPI_NO_ACTIVE_SLI_TOPOLOGY : nvapi_lite_common.h
  • NVAPI_NO_CONNECTOR_FOUND : nvapi_lite_common.h
  • NVAPI_NO_FRUSTUM_ADJUST : nvapi.h
  • NVAPI_NO_GL_EXPERT : nvapi_lite_common.h
  • NVAPI_NO_GL_NSIGHT : nvapi_lite_common.h
  • NVAPI_NO_IMPLEMENTATION : nvapi_lite_common.h
  • NVAPI_NO_VIDLINK : nvapi_lite_common.h
  • NVAPI_NO_VULKAN : nvapi_lite_common.h
  • NVAPI_NOT_PERMITTED : nvapi_lite_common.h
  • NVAPI_NOT_SUPPORTED : nvapi_lite_common.h
  • NVAPI_NV_PERSIST_FILE_NOT_FOUND : nvapi_lite_common.h
  • NVAPI_NVIDIA_DEVICE_NOT_FOUND : nvapi_lite_common.h
  • NVAPI_NVIDIA_DISPLAY_NOT_FOUND : nvapi_lite_common.h
  • NVAPI_NVLINK_DEVICE_INFO_DEVICE_TYPE_EBRIDGE : nvapi.h
  • NVAPI_NVLINK_DEVICE_INFO_DEVICE_TYPE_GPU : nvapi.h
  • NVAPI_NVLINK_DEVICE_INFO_DEVICE_TYPE_NONE : nvapi.h
  • NVAPI_NVLINK_DEVICE_INFO_DEVICE_TYPE_NPU : nvapi.h
  • NVAPI_NVLINK_DEVICE_INFO_DEVICE_TYPE_SWITCH : nvapi.h
  • NVAPI_NVLINK_DEVICE_INFO_DEVICE_TYPE_TEGRA : nvapi.h
  • NVAPI_NVLINK_DEVICE_INFO_DEVICE_UUID_INVALID : nvapi.h
  • NVAPI_NVLINK_STATUS_LINK_STATE_ACTIVE : nvapi.h
  • NVAPI_NVLINK_STATUS_LINK_STATE_FAULT : nvapi.h
  • NVAPI_NVLINK_STATUS_LINK_STATE_HWCFG : nvapi.h
  • NVAPI_NVLINK_STATUS_LINK_STATE_INIT : nvapi.h
  • NVAPI_NVLINK_STATUS_LINK_STATE_INVALID : nvapi.h
  • NVAPI_NVLINK_STATUS_LINK_STATE_RECOVERY : nvapi.h
  • NVAPI_NVLINK_STATUS_LINK_STATE_RECOVERY_AC : nvapi.h
  • NVAPI_NVLINK_STATUS_LINK_STATE_RECOVERY_AX : nvapi.h
  • NVAPI_NVLINK_STATUS_LINK_STATE_SWCFG : nvapi.h
  • NVAPI_NVLINK_STATUS_LINK_STATE_UNKNOWN : nvapi.h
  • NVAPI_NVLINK_STATUS_SUBLINK_RX_STATE_FAULT : nvapi.h
  • NVAPI_NVLINK_STATUS_SUBLINK_RX_STATE_HIGH_SPEED_1 : nvapi.h
  • NVAPI_NVLINK_STATUS_SUBLINK_RX_STATE_INVALID : nvapi.h
  • NVAPI_NVLINK_STATUS_SUBLINK_RX_STATE_LOW_POWER : nvapi.h
  • NVAPI_NVLINK_STATUS_SUBLINK_RX_STATE_OFF : nvapi.h
  • NVAPI_NVLINK_STATUS_SUBLINK_RX_STATE_SAFE_MODE : nvapi.h
  • NVAPI_NVLINK_STATUS_SUBLINK_RX_STATE_TEST : nvapi.h
  • NVAPI_NVLINK_STATUS_SUBLINK_RX_STATE_TRAINING : nvapi.h
  • NVAPI_NVLINK_STATUS_SUBLINK_RX_STATE_UNKNOWN : nvapi.h
  • NVAPI_NVLINK_STATUS_SUBLINK_TX_STATE_FAULT : nvapi.h
  • NVAPI_NVLINK_STATUS_SUBLINK_TX_STATE_HIGH_SPEED_1 : nvapi.h
  • NVAPI_NVLINK_STATUS_SUBLINK_TX_STATE_INVALID : nvapi.h
  • NVAPI_NVLINK_STATUS_SUBLINK_TX_STATE_LOW_POWER : nvapi.h
  • NVAPI_NVLINK_STATUS_SUBLINK_TX_STATE_OFF : nvapi.h
  • NVAPI_NVLINK_STATUS_SUBLINK_TX_STATE_SAFE_MODE : nvapi.h
  • NVAPI_NVLINK_STATUS_SUBLINK_TX_STATE_TEST : nvapi.h
  • NVAPI_NVLINK_STATUS_SUBLINK_TX_STATE_TRAINING : nvapi.h
  • NVAPI_NVLINK_STATUS_SUBLINK_TX_STATE_UNKNOWN : nvapi.h
  • NVAPI_NVLINK_UNCORRECTABLE : nvapi_lite_common.h
  • NVAPI_OK : nvapi_lite_common.h
  • NVAPI_OPENGL_CONTEXT_NOT_CURRENT : nvapi_lite_common.h
  • NVAPI_OUT_OF_MEMORY : nvapi_lite_common.h
  • NVAPI_PCLK_LIMITATION_FAILED : nvapi_lite_common.h
  • NVAPI_PERSIST_DATA_NOT_FOUND : nvapi_lite_common.h
  • NVAPI_PORTID_NOT_FOUND : nvapi_lite_common.h
  • NVAPI_PRIV_SEC_VIOLATION : nvapi_lite_common.h
  • NVAPI_PROFILE_NAME_EMPTY : nvapi_lite_common.h
  • NVAPI_PROFILE_NAME_IN_USE : nvapi_lite_common.h
  • NVAPI_PROFILE_NOT_FOUND : nvapi_lite_common.h
  • NVAPI_PROFILE_REMOVED : nvapi_lite_common.h
  • NVAPI_QUAD_FILLMODE_BBOX : nvapi.h
  • NVAPI_QUAD_FILLMODE_DISABLED : nvapi.h
  • NVAPI_QUAD_FILLMODE_FULL_VIEWPORT : nvapi.h
  • NVAPI_RAY_FLAG_ACCEPT_FIRST_HIT_AND_END_SEARCH_EX : nvapi.h
  • NVAPI_RAY_FLAG_CULL_BACK_FACING_TRIANGLES_EX : nvapi.h
  • NVAPI_RAY_FLAG_CULL_FRONT_FACING_TRIANGLES_EX : nvapi.h
  • NVAPI_RAY_FLAG_CULL_NON_OPAQUE_EX : nvapi.h
  • NVAPI_RAY_FLAG_CULL_OPAQUE_EX : nvapi.h
  • NVAPI_RAY_FLAG_FORCE_NON_OPAQUE_EX : nvapi.h
  • NVAPI_RAY_FLAG_FORCE_OMM_2_STATE_EX : nvapi.h
  • NVAPI_RAY_FLAG_FORCE_OPAQUE_EX : nvapi.h
  • NVAPI_RAY_FLAG_NONE_EX : nvapi.h
  • NVAPI_RAY_FLAG_SKIP_CLOSEST_HIT_SHADER_EX : nvapi.h
  • NVAPI_RAY_FLAG_SKIP_PROCEDURAL_PRIMITIVES_EX : nvapi.h
  • NVAPI_RAY_FLAG_SKIP_TRIANGLES_EX : nvapi.h
  • NVAPI_REQUEST_PENDING : nvapi_lite_common.h
  • NVAPI_REQUEST_USER_TO_CLOSE_NON_MIGRATABLE_APPS : nvapi_lite_common.h
  • NVAPI_REQUEST_USER_TO_DISABLE_DWM : nvapi_lite_common.h
  • NVAPI_REQUIRE_FURTHER_HDCP_ACTION : nvapi_lite_common.h
  • NVAPI_REQUIRES_REBOOT : nvapi_lite_common.h
  • NVAPI_RESOURCE_IN_USE : nvapi_lite_common.h
  • NVAPI_RESOURCE_NOT_ACQUIRED : nvapi_lite_common.h
  • NVAPI_SET_NOT_ALLOWED : nvapi_lite_common.h
  • NVAPI_SETTING_NOT_FOUND : nvapi_lite_common.h
  • NVAPI_SETTING_SIZE_TOO_LARGE : nvapi_lite_common.h
  • NVAPI_SHARE_RESOURCE_RELOCATED : nvapi_lite_common.h
  • NVAPI_SLI_RENDERING_MODE_NOTALLOWED : nvapi_lite_common.h
  • NVAPI_STEREO_DEFAULT_REGISTRY_PROFILE : nvapi.h
  • NVAPI_STEREO_DRIVER_MODE_AUTOMATIC : nvapi_lite_stereo.h
  • NVAPI_STEREO_DRIVER_MODE_DIRECT : nvapi_lite_stereo.h
  • NVAPI_STEREO_DX10_REGISTRY_PROFILE : nvapi.h
  • NVAPI_STEREO_DX9_REGISTRY_PROFILE : nvapi.h
  • NVAPI_STEREO_EYE_LEFT : nvapi_lite_stereo.h
  • NVAPI_STEREO_EYE_MONO : nvapi_lite_stereo.h
  • NVAPI_STEREO_EYE_RIGHT : nvapi_lite_stereo.h
  • NVAPI_STEREO_FRUSTUM_ADJUST_MODE_NOT_SUPPORTED : nvapi_lite_common.h
  • NVAPI_STEREO_HANDSHAKE_NOT_DONE : nvapi_lite_common.h
  • NVAPI_STEREO_INIT_ACTIVATION_DELAYED : nvapi.h
  • NVAPI_STEREO_INIT_ACTIVATION_IMMEDIATE : nvapi.h
  • NVAPI_STEREO_INIT_ACTIVATION_NOT_DONE : nvapi_lite_common.h
  • NVAPI_STEREO_INVALID_DEVICE_INTERFACE : nvapi_lite_common.h
  • NVAPI_STEREO_NOT_ENABLED : nvapi_lite_common.h
  • NVAPI_STEREO_NOT_INITIALIZED : nvapi_lite_common.h
  • NVAPI_STEREO_NOT_TURNED_ON : nvapi_lite_common.h
  • NVAPI_STEREO_PARAMETER_OUT_OF_RANGE : nvapi_lite_common.h
  • NVAPI_STEREO_REGISTRY_ACCESS_FAILED : nvapi_lite_common.h
  • NVAPI_STEREO_REGISTRY_PROFILE_TYPE_NOT_SUPPORTED : nvapi_lite_common.h
  • NVAPI_STEREO_REGISTRY_VALUE_NOT_SUPPORTED : nvapi_lite_common.h
  • NVAPI_STEREO_SURFACECREATEMODE_AUTO : nvapi_lite_stereo.h
  • NVAPI_STEREO_SURFACECREATEMODE_FORCEMONO : nvapi_lite_stereo.h
  • NVAPI_STEREO_SURFACECREATEMODE_FORCESTEREO : nvapi_lite_stereo.h
  • NVAPI_STEREO_SWAPCHAIN_DEFAULT : nvapi.h
  • NVAPI_STEREO_SWAPCHAIN_MONO : nvapi.h
  • NVAPI_STEREO_SWAPCHAIN_STEREO : nvapi.h
  • NVAPI_STEREO_VERSION_MISMATCH : nvapi_lite_common.h
  • NVAPI_STREAM_IS_OUT_OF_SYNC : nvapi_lite_common.h
  • NVAPI_STRING_TOO_SMALL : nvapi_lite_common.h
  • NVAPI_SYNC_MASTER_NOT_FOUND : nvapi_lite_common.h
  • NVAPI_SYNC_NOT_ACTIVE : nvapi_lite_common.h
  • NVAPI_SYSWOW64_NOT_SUPPORTED : nvapi_lite_common.h
  • NVAPI_TESTING_CLOCKS_NOT_SUPPORTED : nvapi_lite_common.h
  • NVAPI_THERMAL_CONTROLLER_ADM1032 : nvapi.h
  • NVAPI_THERMAL_CONTROLLER_ADT7473 : nvapi.h
  • NVAPI_THERMAL_CONTROLLER_GPU_INTERNAL : nvapi.h
  • NVAPI_THERMAL_CONTROLLER_LM64 : nvapi.h
  • NVAPI_THERMAL_CONTROLLER_LM89 : nvapi.h
  • NVAPI_THERMAL_CONTROLLER_LM99 : nvapi.h
  • NVAPI_THERMAL_CONTROLLER_MAX1617 : nvapi.h
  • NVAPI_THERMAL_CONTROLLER_MAX6649 : nvapi.h
  • NVAPI_THERMAL_CONTROLLER_NONE : nvapi.h
  • NVAPI_THERMAL_CONTROLLER_OS : nvapi.h
  • NVAPI_THERMAL_CONTROLLER_SBMAX6649 : nvapi.h
  • NVAPI_THERMAL_CONTROLLER_UNKNOWN : nvapi.h
  • NVAPI_THERMAL_CONTROLLER_VBIOSEVT : nvapi.h
  • NVAPI_THERMAL_TARGET_ALL : nvapi.h
  • NVAPI_THERMAL_TARGET_BOARD : nvapi.h
  • NVAPI_THERMAL_TARGET_GPU : nvapi.h
  • NVAPI_THERMAL_TARGET_MEMORY : nvapi.h
  • NVAPI_THERMAL_TARGET_NONE : nvapi.h
  • NVAPI_THERMAL_TARGET_POWER_SUPPLY : nvapi.h
  • NVAPI_THERMAL_TARGET_UNKNOWN : nvapi.h
  • NVAPI_THERMAL_TARGET_VCD_BOARD : nvapi.h
  • NVAPI_THERMAL_TARGET_VCD_INLET : nvapi.h
  • NVAPI_THERMAL_TARGET_VCD_OUTLET : nvapi.h
  • NVAPI_TIMEOUT : nvapi_lite_common.h
  • NVAPI_TIMEOUT_RECONFIGURING_GPU_TOPO : nvapi_lite_common.h
  • NVAPI_TIMING_NOT_SUPPORTED : nvapi_lite_common.h
  • NVAPI_TOO_MANY_SETTINGS_IN_PROFILE : nvapi_lite_common.h
  • NVAPI_TOO_MANY_UNIQUE_STATE_OBJECTS : nvapi_lite_common.h
  • NVAPI_TOPO_NOT_POSSIBLE : nvapi_lite_common.h
  • NVAPI_UNKNOWN_UNDERSCAN_CONFIG : nvapi_lite_common.h
  • NVAPI_UNREGISTERED_RESOURCE : nvapi_lite_common.h
  • NVAPI_UNSUPPORTED_CONFIG_NON_HDCP_HMD : nvapi_lite_common.h
  • NVAPI_VALUE_ALREADY_SET : nvapi_lite_common.h
  • NVAPI_VSYNC_ADAPTIVE : nvapi.h
  • NVAPI_VSYNC_ADAPTIVE_HALF_REFRESH_RATE : nvapi.h
  • NVAPI_VSYNC_DEFAULT : nvapi.h
  • NVAPI_VSYNC_OFF : nvapi.h
  • NVAPI_VSYNC_ON : nvapi.h
  • NVAPI_WAIT_FOR_HW_RESOURCE : nvapi_lite_common.h
  • NVAPI_WAS_STILL_DRAWING : nvapi_lite_common.h
  • NVDRS_BASE_PROFILE_LOCATION : nvapi.h
  • NVDRS_BINARY_TYPE : nvapi.h
  • NVDRS_CURRENT_PROFILE_LOCATION : nvapi.h
  • NVDRS_DEFAULT_PROFILE_LOCATION : nvapi.h
  • NVDRS_DWORD_TYPE : nvapi.h
  • NVDRS_GLOBAL_PROFILE_LOCATION : nvapi.h
  • NVDRS_STRING_TYPE : nvapi.h
  • NVDRS_WSTRING_TYPE : nvapi.h
  • NVINPUTOUTPUTSTATUS_ERROR : nvapi.h
  • NVINPUTOUTPUTSTATUS_OFF : nvapi.h
  • NVINPUTOUTPUTSTATUS_SDI_HD : nvapi.h
  • NVINPUTOUTPUTSTATUS_SDI_SD : nvapi.h
  • NVVIOANCPARITYCOMPUTATION_AUTO : nvapi.h
  • NVVIOANCPARITYCOMPUTATION_OFF : nvapi.h
  • NVVIOANCPARITYCOMPUTATION_ON : nvapi.h
  • NVVIOBITSPERCOMPONENT_10 : nvapi.h
  • NVVIOBITSPERCOMPONENT_12 : nvapi.h
  • NVVIOBITSPERCOMPONENT_8 : nvapi.h
  • NVVIOBITSPERCOMPONENT_UNKNOWN : nvapi.h
  • NVVIOCOLORSPACE_GBR : nvapi.h
  • NVVIOCOLORSPACE_GBRA : nvapi.h
  • NVVIOCOLORSPACE_GBRD : nvapi.h
  • NVVIOCOLORSPACE_UNKNOWN : nvapi.h
  • NVVIOCOLORSPACE_YCBCR : nvapi.h
  • NVVIOCOLORSPACE_YCBCRA : nvapi.h
  • NVVIOCOLORSPACE_YCBCRD : nvapi.h
  • NVVIOCOMPONENTSAMPLING_422 : nvapi.h
  • NVVIOCOMPONENTSAMPLING_4224 : nvapi.h
  • NVVIOCOMPONENTSAMPLING_444 : nvapi.h
  • NVVIOCOMPONENTSAMPLING_4444 : nvapi.h
  • NVVIOCOMPONENTSAMPLING_UNKNOWN : nvapi.h
  • NVVIOCOMPSYNCTYPE_AUTO : nvapi.h
  • NVVIOCOMPSYNCTYPE_BILEVEL : nvapi.h
  • NVVIOCOMPSYNCTYPE_TRILEVEL : nvapi.h
  • NVVIOCONFIGTYPE_IN : nvapi.h
  • NVVIOCONFIGTYPE_OUT : nvapi.h
  • NVVIODATAFORMAT_DUAL_R8G8B8_TO_DUAL_YCRCB422 : nvapi.h
  • NVVIODATAFORMAT_DUAL_X8X8X8_TO_DUAL_422_PASSTHRU : nvapi.h
  • NVVIODATAFORMAT_R10G10B10_TO_RGB444 : nvapi.h
  • NVVIODATAFORMAT_R10G10B10_TO_YCRCB422 : nvapi.h
  • NVVIODATAFORMAT_R10G10B10_TO_YCRCB444 : nvapi.h
  • NVVIODATAFORMAT_R12G12B12_TO_YCRCB422 : nvapi.h
  • NVVIODATAFORMAT_R12G12B12_TO_YCRCB444 : nvapi.h
  • NVVIODATAFORMAT_R8G8B8_TO_YCRCB422 : nvapi.h
  • NVVIODATAFORMAT_R8G8B8_TO_YCRCB444 : nvapi.h
  • NVVIODATAFORMAT_R8G8B8A8_TO_YCRCBA4224 : nvapi.h
  • NVVIODATAFORMAT_R8G8B8A8_TO_YCRCBA4444 : nvapi.h
  • NVVIODATAFORMAT_R8G8B8Z10_TO_YCRCBZ4224 : nvapi.h
  • NVVIODATAFORMAT_R8G8B8Z10_TO_YCRCBZ4444 : nvapi.h
  • NVVIODATAFORMAT_UNKNOWN : nvapi.h
  • NVVIODATAFORMAT_X10X10X10_444_PASSTHRU : nvapi.h
  • NVVIODATAFORMAT_X10X8X8_444_PASSTHRU : nvapi.h
  • NVVIODATAFORMAT_X10X8X8A10_4444_PASSTHRU : nvapi.h
  • NVVIODATAFORMAT_X10X8X8Z10_4444_PASSTHRU : nvapi.h
  • NVVIODATAFORMAT_X12X12X12_422_PASSTHRU : nvapi.h
  • NVVIODATAFORMAT_X12X12X12_444_PASSTHRU : nvapi.h
  • NVVIODATAFORMAT_X8X8X8_444_PASSTHRU : nvapi.h
  • NVVIODATAFORMAT_X8X8X8A8_4444_PASSTHRU : nvapi.h
  • NVVIODATAFORMAT_X8X8X8Z10_4444_PASSTHRU : nvapi.h
  • NVVIODATAFORMAT_Y10CR10CB10_TO_YCRCB422 : nvapi.h
  • NVVIODATAFORMAT_Y10CR8CB8A10_TO_YCRCBA4224 : nvapi.h
  • NVVIODATAFORMAT_Y8CR8CB8_TO_YCRCB422 : nvapi.h
  • NVVIOINTERLACEMODE_INTERLACE : nvapi.h
  • NVVIOINTERLACEMODE_PROGRESSIVE : nvapi.h
  • NVVIOINTERLACEMODE_PSF : nvapi.h
  • NVVIOLINKID_A : nvapi.h
  • NVVIOLINKID_B : nvapi.h
  • NVVIOLINKID_C : nvapi.h
  • NVVIOLINKID_D : nvapi.h
  • NVVIOLINKID_UNKNOWN : nvapi.h
  • NVVIOOUTPUTAREA_FULLSIZE : nvapi.h
  • NVVIOOUTPUTAREA_SAFEACTION : nvapi.h
  • NVVIOOUTPUTAREA_SAFETITLE : nvapi.h
  • NVVIOOWNERTYPE_APPLICATION : nvapi.h
  • NVVIOOWNERTYPE_DESKTOP : nvapi.h
  • NVVIOOWNERTYPE_NONE : nvapi.h
  • NVVIOPCILINKRATE_GEN1 : nvapi.h
  • NVVIOPCILINKRATE_GEN2 : nvapi.h
  • NVVIOPCILINKRATE_GEN3 : nvapi.h
  • NVVIOPCILINKRATE_UNKNOWN : nvapi.h
  • NVVIOPCILINKWIDTH_UNKNOWN : nvapi.h
  • NVVIOPCILINKWIDTH_x1 : nvapi.h
  • NVVIOPCILINKWIDTH_x16 : nvapi.h
  • NVVIOPCILINKWIDTH_x2 : nvapi.h
  • NVVIOPCILINKWIDTH_x4 : nvapi.h
  • NVVIOPCILINKWIDTH_x8 : nvapi.h
  • NVVIOSIGNALFORMAT_1035I_59_94_SMPTE260 : nvapi.h
  • NVVIOSIGNALFORMAT_1035I_60_00_SMPTE260 : nvapi.h
  • NVVIOSIGNALFORMAT_1080I_47_96_SMPTE274 : nvapi.h
  • NVVIOSIGNALFORMAT_1080I_47_96_SMPTE274_3G_LEVEL_B : nvapi.h
  • NVVIOSIGNALFORMAT_1080I_48_00_SMPTE274 : nvapi.h
  • NVVIOSIGNALFORMAT_1080I_48_00_SMPTE274_3G_LEVEL_B : nvapi.h
  • NVVIOSIGNALFORMAT_1080I_50_00_SMPTE274 : nvapi.h
  • NVVIOSIGNALFORMAT_1080I_50_00_SMPTE274_3G_LEVEL_B : nvapi.h
  • NVVIOSIGNALFORMAT_1080I_50_00_SMPTE295 : nvapi.h
  • NVVIOSIGNALFORMAT_1080I_59_94_SMPTE274 : nvapi.h
  • NVVIOSIGNALFORMAT_1080I_59_94_SMPTE274_3G_LEVEL_B : nvapi.h
  • NVVIOSIGNALFORMAT_1080I_60_00_SMPTE274 : nvapi.h
  • NVVIOSIGNALFORMAT_1080I_60_00_SMPTE274_3G_LEVEL_B : nvapi.h
  • NVVIOSIGNALFORMAT_1080P_23_976_SMPTE274 : nvapi.h
  • NVVIOSIGNALFORMAT_1080P_23_98_SMPTE274_3G_LEVEL_B : nvapi.h
  • NVVIOSIGNALFORMAT_1080P_24_00_SMPTE274 : nvapi.h
  • NVVIOSIGNALFORMAT_1080P_24_00_SMPTE274_3G_LEVEL_B : nvapi.h
  • NVVIOSIGNALFORMAT_1080P_25_00_SMPTE274 : nvapi.h
  • NVVIOSIGNALFORMAT_1080P_25_00_SMPTE274_3G_LEVEL_B : nvapi.h
  • NVVIOSIGNALFORMAT_1080P_29_97_SMPTE274 : nvapi.h
  • NVVIOSIGNALFORMAT_1080P_29_97_SMPTE274_3G_LEVEL_B : nvapi.h
  • NVVIOSIGNALFORMAT_1080P_30_00_SMPTE274 : nvapi.h
  • NVVIOSIGNALFORMAT_1080P_30_00_SMPTE274_3G_LEVEL_B : nvapi.h
  • NVVIOSIGNALFORMAT_1080P_50_00_SMPTE274_3G_LEVEL_A : nvapi.h
  • NVVIOSIGNALFORMAT_1080P_50_00_SMPTE274_3G_LEVEL_B : nvapi.h
  • NVVIOSIGNALFORMAT_1080P_59_94_SMPTE274_3G_LEVEL_A : nvapi.h
  • NVVIOSIGNALFORMAT_1080P_59_94_SMPTE274_3G_LEVEL_B : nvapi.h
  • NVVIOSIGNALFORMAT_1080P_60_00_SMPTE274_3G_LEVEL_A : nvapi.h
  • NVVIOSIGNALFORMAT_1080P_60_00_SMPTE274_3G_LEVEL_B : nvapi.h
  • NVVIOSIGNALFORMAT_1080PSF_23_98_SMPTE274 : nvapi.h
  • NVVIOSIGNALFORMAT_1080PSF_24_00_SMPTE274 : nvapi.h
  • NVVIOSIGNALFORMAT_1080PSF_25_00_SMPTE274 : nvapi.h
  • NVVIOSIGNALFORMAT_1080PSF_29_97_SMPTE274 : nvapi.h
  • NVVIOSIGNALFORMAT_1080PSF_30_00_SMPTE274 : nvapi.h
  • NVVIOSIGNALFORMAT_2048I_47_96_SMPTE372 : nvapi.h
  • NVVIOSIGNALFORMAT_2048I_47_96_SMPTE372_3G_LEVEL_B : nvapi.h
  • NVVIOSIGNALFORMAT_2048I_48_00_SMPTE372 : nvapi.h
  • NVVIOSIGNALFORMAT_2048I_48_00_SMPTE372_3G_LEVEL_B : nvapi.h
  • NVVIOSIGNALFORMAT_2048I_50_00_SMPTE372 : nvapi.h
  • NVVIOSIGNALFORMAT_2048I_50_00_SMPTE372_3G_LEVEL_B : nvapi.h
  • NVVIOSIGNALFORMAT_2048I_59_94_SMPTE372 : nvapi.h
  • NVVIOSIGNALFORMAT_2048I_59_94_SMPTE372_3G_LEVEL_B : nvapi.h
  • NVVIOSIGNALFORMAT_2048I_60_00_SMPTE372 : nvapi.h
  • NVVIOSIGNALFORMAT_2048I_60_00_SMPTE372_3G_LEVEL_B : nvapi.h
  • NVVIOSIGNALFORMAT_2048P_23_98_SMPTE372 : nvapi.h
  • NVVIOSIGNALFORMAT_2048P_23_98_SMPTE372_3G_LEVEL_B : nvapi.h
  • NVVIOSIGNALFORMAT_2048P_24_00_SMPTE372 : nvapi.h
  • NVVIOSIGNALFORMAT_2048P_24_00_SMPTE372_3G_LEVEL_B : nvapi.h
  • NVVIOSIGNALFORMAT_2048P_25_00_SMPTE372 : nvapi.h
  • NVVIOSIGNALFORMAT_2048P_25_00_SMPTE372_3G_LEVEL_B : nvapi.h
  • NVVIOSIGNALFORMAT_2048P_29_97_SMPTE372 : nvapi.h
  • NVVIOSIGNALFORMAT_2048P_29_97_SMPTE372_3G_LEVEL_B : nvapi.h
  • NVVIOSIGNALFORMAT_2048P_30_00_SMPTE372 : nvapi.h
  • NVVIOSIGNALFORMAT_2048P_30_00_SMPTE372_3G_LEVEL_B : nvapi.h
  • NVVIOSIGNALFORMAT_487I_59_94_SMPTE259_NTSC : nvapi.h
  • NVVIOSIGNALFORMAT_576I_50_00_SMPTE259_PAL : nvapi.h
  • NVVIOSIGNALFORMAT_720P_23_98_SMPTE296 : nvapi.h
  • NVVIOSIGNALFORMAT_720P_24_00_SMPTE296 : nvapi.h
  • NVVIOSIGNALFORMAT_720P_25_00_SMPTE296 : nvapi.h
  • NVVIOSIGNALFORMAT_720P_29_97_SMPTE296 : nvapi.h
  • NVVIOSIGNALFORMAT_720P_30_00_SMPTE296 : nvapi.h
  • NVVIOSIGNALFORMAT_720P_50_00_SMPTE296 : nvapi.h
  • NVVIOSIGNALFORMAT_720P_59_94_SMPTE296 : nvapi.h
  • NVVIOSIGNALFORMAT_720P_60_00_SMPTE296 : nvapi.h
  • NVVIOSIGNALFORMAT_END : nvapi.h
  • NVVIOSIGNALFORMAT_NONE : nvapi.h
  • NVVIOSTATUS_ERROR : nvapi.h
  • NVVIOSTATUS_RUNNING : nvapi.h
  • NVVIOSTATUS_STOPPED : nvapi.h
  • NVVIOSTATUSTYPE_IN : nvapi.h
  • NVVIOSTATUSTYPE_OUT : nvapi.h
  • NVVIOSYNCSOURCE_COMPSYNC : nvapi.h
  • NVVIOSYNCSOURCE_SDISYNC : nvapi.h
  • NVVIOSYNCSTATUS_COMPOSITE : nvapi.h
  • NVVIOSYNCSTATUS_ERROR : nvapi.h
  • NVVIOSYNCSTATUS_OFF : nvapi.h
  • NVVIOSYNCSTATUS_SDI_HD : nvapi.h
  • NVVIOSYNCSTATUS_SDI_SD : nvapi.h
  • NVVIOSYNCSTATUS_SYNCLOSS : nvapi.h
  • NVVIOVIDEOSTANDARD_SMPTE259 : nvapi.h
  • NVVIOVIDEOSTANDARD_SMPTE260 : nvapi.h
  • NVVIOVIDEOSTANDARD_SMPTE274 : nvapi.h
  • NVVIOVIDEOSTANDARD_SMPTE295 : nvapi.h
  • NVVIOVIDEOSTANDARD_SMPTE296 : nvapi.h
  • NVVIOVIDEOSTANDARD_SMPTE372 : nvapi.h
  • NVVIOVIDEOTYPE_HD : nvapi.h
  • NVVIOVIDEOTYPE_SD : nvapi.h


  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • a
  • b
  • c
  • d
  • e
  • f
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • v
  • w
Here is a list of all enum values with links to the files they belong to:

- o -

  • OGL_AA_LINE_GAMMA_DEFAULT : NvApiDriverSettings.h
  • OGL_AA_LINE_GAMMA_DISABLED : NvApiDriverSettings.h
  • OGL_AA_LINE_GAMMA_ENABLED : NvApiDriverSettings.h
  • OGL_AA_LINE_GAMMA_ID : NvApiDriverSettings.h
  • OGL_AA_LINE_GAMMA_MAX : NvApiDriverSettings.h
  • OGL_AA_LINE_GAMMA_MIN : NvApiDriverSettings.h
  • OGL_AA_LINE_GAMMA_NUM_VALUES : NvApiDriverSettings.h
  • OGL_CPL_GDI_COMPATIBILITY_AUTO : NvApiDriverSettings.h
  • OGL_CPL_GDI_COMPATIBILITY_DEFAULT : NvApiDriverSettings.h
  • OGL_CPL_GDI_COMPATIBILITY_ID : NvApiDriverSettings.h
  • OGL_CPL_GDI_COMPATIBILITY_NUM_VALUES : NvApiDriverSettings.h
  • OGL_CPL_GDI_COMPATIBILITY_PREFER_DISABLED : NvApiDriverSettings.h
  • OGL_CPL_GDI_COMPATIBILITY_PREFER_ENABLED : NvApiDriverSettings.h
  • OGL_CPL_PREFER_DXPRESENT_AUTO : NvApiDriverSettings.h
  • OGL_CPL_PREFER_DXPRESENT_DEFAULT : NvApiDriverSettings.h
  • OGL_CPL_PREFER_DXPRESENT_ID : NvApiDriverSettings.h
  • OGL_CPL_PREFER_DXPRESENT_NUM_VALUES : NvApiDriverSettings.h
  • OGL_CPL_PREFER_DXPRESENT_PREFER_DISABLED : NvApiDriverSettings.h
  • OGL_CPL_PREFER_DXPRESENT_PREFER_ENABLED : NvApiDriverSettings.h
  • OGL_DEEP_COLOR_SCANOUT_DEFAULT : NvApiDriverSettings.h
  • OGL_DEEP_COLOR_SCANOUT_DISABLE : NvApiDriverSettings.h
  • OGL_DEEP_COLOR_SCANOUT_ENABLE : NvApiDriverSettings.h
  • OGL_DEEP_COLOR_SCANOUT_ID : NvApiDriverSettings.h
  • OGL_DEEP_COLOR_SCANOUT_NUM_VALUES : NvApiDriverSettings.h
  • OGL_DEFAULT_SWAP_INTERVAL_APP_CONTROLLED : NvApiDriverSettings.h
  • OGL_DEFAULT_SWAP_INTERVAL_DEFAULT : NvApiDriverSettings.h
  • OGL_DEFAULT_SWAP_INTERVAL_DISABLE : NvApiDriverSettings.h
  • OGL_DEFAULT_SWAP_INTERVAL_FORCE_MASK : NvApiDriverSettings.h
  • OGL_DEFAULT_SWAP_INTERVAL_FORCE_OFF : NvApiDriverSettings.h
  • OGL_DEFAULT_SWAP_INTERVAL_FORCE_ON : NvApiDriverSettings.h
  • OGL_DEFAULT_SWAP_INTERVAL_FRACTIONAL_DEFAULT : NvApiDriverSettings.h
  • OGL_DEFAULT_SWAP_INTERVAL_FRACTIONAL_ID : NvApiDriverSettings.h
  • OGL_DEFAULT_SWAP_INTERVAL_FRACTIONAL_NUM_VALUES : NvApiDriverSettings.h
  • OGL_DEFAULT_SWAP_INTERVAL_FRACTIONAL_ONE_FULL_FRAME_OF_SCANLINES : NvApiDriverSettings.h
  • OGL_DEFAULT_SWAP_INTERVAL_FRACTIONAL_ZERO_SCANLINES : NvApiDriverSettings.h
  • OGL_DEFAULT_SWAP_INTERVAL_ID : NvApiDriverSettings.h
  • OGL_DEFAULT_SWAP_INTERVAL_NUM_VALUES : NvApiDriverSettings.h
  • OGL_DEFAULT_SWAP_INTERVAL_SIGN_DEFAULT : NvApiDriverSettings.h
  • OGL_DEFAULT_SWAP_INTERVAL_SIGN_ID : NvApiDriverSettings.h
  • OGL_DEFAULT_SWAP_INTERVAL_SIGN_NEGATIVE : NvApiDriverSettings.h
  • OGL_DEFAULT_SWAP_INTERVAL_SIGN_NUM_VALUES : NvApiDriverSettings.h
  • OGL_DEFAULT_SWAP_INTERVAL_SIGN_POSITIVE : NvApiDriverSettings.h
  • OGL_DEFAULT_SWAP_INTERVAL_TEAR : NvApiDriverSettings.h
  • OGL_DEFAULT_SWAP_INTERVAL_VALUE_MASK : NvApiDriverSettings.h
  • OGL_DEFAULT_SWAP_INTERVAL_VSYNC : NvApiDriverSettings.h
  • OGL_DEFAULT_SWAP_INTERVAL_VSYNC_ONE : NvApiDriverSettings.h
  • OGL_EVENT_LOG_SEVERITY_THRESHOLD_ALL : NvApiDriverSettings.h
  • OGL_EVENT_LOG_SEVERITY_THRESHOLD_CRITICAL : NvApiDriverSettings.h
  • OGL_EVENT_LOG_SEVERITY_THRESHOLD_DEFAULT : NvApiDriverSettings.h
  • OGL_EVENT_LOG_SEVERITY_THRESHOLD_DISABLE : NvApiDriverSettings.h
  • OGL_EVENT_LOG_SEVERITY_THRESHOLD_ID : NvApiDriverSettings.h
  • OGL_EVENT_LOG_SEVERITY_THRESHOLD_INFORMATION : NvApiDriverSettings.h
  • OGL_EVENT_LOG_SEVERITY_THRESHOLD_NUM_VALUES : NvApiDriverSettings.h
  • OGL_EVENT_LOG_SEVERITY_THRESHOLD_WARNING : NvApiDriverSettings.h
  • OGL_EXTENSION_STRING_VERSION_ID : NvApiDriverSettings.h
  • OGL_FORCE_BLIT_DEFAULT : NvApiDriverSettings.h
  • OGL_FORCE_BLIT_ID : NvApiDriverSettings.h
  • OGL_FORCE_BLIT_NUM_VALUES : NvApiDriverSettings.h
  • OGL_FORCE_BLIT_OFF : NvApiDriverSettings.h
  • OGL_FORCE_BLIT_ON : NvApiDriverSettings.h
  • OGL_FORCE_STEREO_DEFAULT : NvApiDriverSettings.h
  • OGL_FORCE_STEREO_ID : NvApiDriverSettings.h
  • OGL_FORCE_STEREO_NUM_VALUES : NvApiDriverSettings.h
  • OGL_FORCE_STEREO_OFF : NvApiDriverSettings.h
  • OGL_FORCE_STEREO_ON : NvApiDriverSettings.h
  • OGL_IMPLICIT_GPU_AFFINITY_ID : NvApiDriverSettings.h
  • OGL_MAX_FRAMES_ALLOWED_ID : NvApiDriverSettings.h
  • OGL_OVERLAY_PIXEL_TYPE_CI : NvApiDriverSettings.h
  • OGL_OVERLAY_PIXEL_TYPE_CI_AND_RGBA : NvApiDriverSettings.h
  • OGL_OVERLAY_PIXEL_TYPE_DEFAULT : NvApiDriverSettings.h
  • OGL_OVERLAY_PIXEL_TYPE_ID : NvApiDriverSettings.h
  • OGL_OVERLAY_PIXEL_TYPE_NONE : NvApiDriverSettings.h
  • OGL_OVERLAY_PIXEL_TYPE_NUM_VALUES : NvApiDriverSettings.h
  • OGL_OVERLAY_PIXEL_TYPE_RGBA : NvApiDriverSettings.h
  • OGL_OVERLAY_SUPPORT_DEFAULT : NvApiDriverSettings.h
  • OGL_OVERLAY_SUPPORT_FORCE_SW : NvApiDriverSettings.h
  • OGL_OVERLAY_SUPPORT_ID : NvApiDriverSettings.h
  • OGL_OVERLAY_SUPPORT_NUM_VALUES : NvApiDriverSettings.h
  • OGL_OVERLAY_SUPPORT_OFF : NvApiDriverSettings.h
  • OGL_OVERLAY_SUPPORT_ON : NvApiDriverSettings.h
  • OGL_QUALITY_ENHANCEMENTS_DEFAULT : NvApiDriverSettings.h
  • OGL_QUALITY_ENHANCEMENTS_HPERF : NvApiDriverSettings.h
  • OGL_QUALITY_ENHANCEMENTS_HQUAL : NvApiDriverSettings.h
  • OGL_QUALITY_ENHANCEMENTS_ID : NvApiDriverSettings.h
  • OGL_QUALITY_ENHANCEMENTS_NUM_VALUES : NvApiDriverSettings.h
  • OGL_QUALITY_ENHANCEMENTS_PERF : NvApiDriverSettings.h
  • OGL_QUALITY_ENHANCEMENTS_QUAL : NvApiDriverSettings.h
  • OGL_SINGLE_BACKDEPTH_BUFFER_DEFAULT : NvApiDriverSettings.h
  • OGL_SINGLE_BACKDEPTH_BUFFER_DISABLE : NvApiDriverSettings.h
  • OGL_SINGLE_BACKDEPTH_BUFFER_ENABLE : NvApiDriverSettings.h
  • OGL_SINGLE_BACKDEPTH_BUFFER_ID : NvApiDriverSettings.h
  • OGL_SINGLE_BACKDEPTH_BUFFER_NUM_VALUES : NvApiDriverSettings.h
  • OGL_SINGLE_BACKDEPTH_BUFFER_USE_HW_DEFAULT : NvApiDriverSettings.h
  • OGL_SLI_MULTICAST_ALLOW_MOSAIC : NvApiDriverSettings.h
  • OGL_SLI_MULTICAST_DEFAULT : NvApiDriverSettings.h
  • OGL_SLI_MULTICAST_DISABLE : NvApiDriverSettings.h
  • OGL_SLI_MULTICAST_ENABLE : NvApiDriverSettings.h
  • OGL_SLI_MULTICAST_FORCE_DISABLE : NvApiDriverSettings.h
  • OGL_SLI_MULTICAST_ID : NvApiDriverSettings.h
  • OGL_SLI_MULTICAST_NUM_VALUES : NvApiDriverSettings.h
  • OGL_THREAD_CONTROL_DEFAULT : NvApiDriverSettings.h
  • OGL_THREAD_CONTROL_DISABLE : NvApiDriverSettings.h
  • OGL_THREAD_CONTROL_ENABLE : NvApiDriverSettings.h
  • OGL_THREAD_CONTROL_ID : NvApiDriverSettings.h
  • OGL_THREAD_CONTROL_NUM_VALUES : NvApiDriverSettings.h
  • OGL_TMON_LEVEL_CRITICAL : NvApiDriverSettings.h
  • OGL_TMON_LEVEL_DEFAULT : NvApiDriverSettings.h
  • OGL_TMON_LEVEL_DISABLE : NvApiDriverSettings.h
  • OGL_TMON_LEVEL_ID : NvApiDriverSettings.h
  • OGL_TMON_LEVEL_INFORMATION : NvApiDriverSettings.h
  • OGL_TMON_LEVEL_MOST : NvApiDriverSettings.h
  • OGL_TMON_LEVEL_NUM_VALUES : NvApiDriverSettings.h
  • OGL_TMON_LEVEL_VERBOSE : NvApiDriverSettings.h
  • OGL_TMON_LEVEL_WARNING : NvApiDriverSettings.h
  • OGL_TRIPLE_BUFFER_DEFAULT : NvApiDriverSettings.h
  • OGL_TRIPLE_BUFFER_DISABLED : NvApiDriverSettings.h
  • OGL_TRIPLE_BUFFER_ENABLED : NvApiDriverSettings.h
  • OGL_TRIPLE_BUFFER_ID : NvApiDriverSettings.h
  • OGL_TRIPLE_BUFFER_NUM_VALUES : NvApiDriverSettings.h
  • OPTIMUS_MAXAA_DEFAULT : NvApiDriverSettings.h
  • OPTIMUS_MAXAA_ID : NvApiDriverSettings.h
  • OPTIMUS_MAXAA_MAX : NvApiDriverSettings.h
  • OPTIMUS_MAXAA_MIN : NvApiDriverSettings.h
  • OPTIMUS_MAXAA_NUM_VALUES : NvApiDriverSettings.h
  • OUT_OF_BAND_IGNORE : nvapi.h
  • OUT_OF_BAND_PRESENT : nvapi.h
  • OUT_OF_BAND_PRESENT_END : nvapi.h
  • OUT_OF_BAND_PRESENT_START : nvapi.h
  • OUT_OF_BAND_RENDER : nvapi.h
  • OUT_OF_BAND_RENDERSUBMIT_END : nvapi.h
  • OUT_OF_BAND_RENDERSUBMIT_START : nvapi.h


  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • a
  • b
  • c
  • d
  • e
  • f
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • v
  • w
Here is a list of all enum values with links to the files they belong to:

- p -

  • PC_LATENCY_PING : nvapi.h
  • PHYSXINDICATOR_DEFAULT : NvApiDriverSettings.h
  • PHYSXINDICATOR_DISABLED : NvApiDriverSettings.h
  • PHYSXINDICATOR_ENABLED : NvApiDriverSettings.h
  • PHYSXINDICATOR_ID : NvApiDriverSettings.h
  • PHYSXINDICATOR_NUM_VALUES : NvApiDriverSettings.h
  • PREFERRED_PSTATE_ADAPTIVE : NvApiDriverSettings.h
  • PREFERRED_PSTATE_DEFAULT : NvApiDriverSettings.h
  • PREFERRED_PSTATE_DRIVER_CONTROLLED : NvApiDriverSettings.h
  • PREFERRED_PSTATE_ID : NvApiDriverSettings.h
  • PREFERRED_PSTATE_MAX : NvApiDriverSettings.h
  • PREFERRED_PSTATE_MIN : NvApiDriverSettings.h
  • PREFERRED_PSTATE_NUM_VALUES : NvApiDriverSettings.h
  • PREFERRED_PSTATE_OPTIMAL_POWER : NvApiDriverSettings.h
  • PREFERRED_PSTATE_PREFER_CONSISTENT_PERFORMANCE : NvApiDriverSettings.h
  • PREFERRED_PSTATE_PREFER_MAX : NvApiDriverSettings.h
  • PREFERRED_PSTATE_PREFER_MIN : NvApiDriverSettings.h
  • PRERENDERLIMIT_APP_CONTROLLED : NvApiDriverSettings.h
  • PRERENDERLIMIT_DEFAULT : NvApiDriverSettings.h
  • PRERENDERLIMIT_ID : NvApiDriverSettings.h
  • PRERENDERLIMIT_MAX : NvApiDriverSettings.h
  • PRERENDERLIMIT_MIN : NvApiDriverSettings.h
  • PRERENDERLIMIT_NUM_VALUES : NvApiDriverSettings.h
  • PRESENT_BARRIER_NOT_JOINED : nvapi.h
  • PRESENT_BARRIER_SYNC_CLIENT : nvapi.h
  • PRESENT_BARRIER_SYNC_CLUSTER : nvapi.h
  • PRESENT_BARRIER_SYNC_SYSTEM : nvapi.h
  • PRESENT_END : nvapi.h
  • PRESENT_START : nvapi.h
  • PREVENT_UI_AF_OVERRIDE_DEFAULT : NvApiDriverSettings.h
  • PREVENT_UI_AF_OVERRIDE_ID : NvApiDriverSettings.h
  • PREVENT_UI_AF_OVERRIDE_NUM_VALUES : NvApiDriverSettings.h
  • PREVENT_UI_AF_OVERRIDE_OFF : NvApiDriverSettings.h
  • PREVENT_UI_AF_OVERRIDE_ON : NvApiDriverSettings.h
  • PS_SHADERDISKCACHE_DEFAULT : NvApiDriverSettings.h
  • PS_SHADERDISKCACHE_DLL_PATH_WCHAR_ID : NvApiDriverSettings.h
  • PS_SHADERDISKCACHE_ID : NvApiDriverSettings.h
  • PS_SHADERDISKCACHE_MAX_SIZE_DEFAULT : NvApiDriverSettings.h
  • PS_SHADERDISKCACHE_MAX_SIZE_ID : NvApiDriverSettings.h
  • PS_SHADERDISKCACHE_MAX_SIZE_MAX : NvApiDriverSettings.h
  • PS_SHADERDISKCACHE_MAX_SIZE_MIN : NvApiDriverSettings.h
  • PS_SHADERDISKCACHE_MAX_SIZE_NUM_VALUES : NvApiDriverSettings.h
  • PS_SHADERDISKCACHE_NUM_VALUES : NvApiDriverSettings.h
  • PS_SHADERDISKCACHE_OFF : NvApiDriverSettings.h
  • PS_SHADERDISKCACHE_ON : NvApiDriverSettings.h
  • PS_TEXFILTER_ANISO_OPTS2_DEFAULT : NvApiDriverSettings.h
  • PS_TEXFILTER_ANISO_OPTS2_ID : NvApiDriverSettings.h
  • PS_TEXFILTER_ANISO_OPTS2_NUM_VALUES : NvApiDriverSettings.h
  • PS_TEXFILTER_ANISO_OPTS2_OFF : NvApiDriverSettings.h
  • PS_TEXFILTER_ANISO_OPTS2_ON : NvApiDriverSettings.h
  • PS_TEXFILTER_BILINEAR_IN_ANISO_DEFAULT : NvApiDriverSettings.h
  • PS_TEXFILTER_BILINEAR_IN_ANISO_ID : NvApiDriverSettings.h
  • PS_TEXFILTER_BILINEAR_IN_ANISO_NUM_VALUES : NvApiDriverSettings.h
  • PS_TEXFILTER_BILINEAR_IN_ANISO_OFF : NvApiDriverSettings.h
  • PS_TEXFILTER_BILINEAR_IN_ANISO_ON : NvApiDriverSettings.h
  • PS_TEXFILTER_DISABLE_TRILIN_SLOPE_DEFAULT : NvApiDriverSettings.h
  • PS_TEXFILTER_DISABLE_TRILIN_SLOPE_ID : NvApiDriverSettings.h
  • PS_TEXFILTER_DISABLE_TRILIN_SLOPE_NUM_VALUES : NvApiDriverSettings.h
  • PS_TEXFILTER_DISABLE_TRILIN_SLOPE_OFF : NvApiDriverSettings.h
  • PS_TEXFILTER_DISABLE_TRILIN_SLOPE_ON : NvApiDriverSettings.h
  • PS_TEXFILTER_NO_NEG_LODBIAS_DEFAULT : NvApiDriverSettings.h
  • PS_TEXFILTER_NO_NEG_LODBIAS_ID : NvApiDriverSettings.h
  • PS_TEXFILTER_NO_NEG_LODBIAS_NUM_VALUES : NvApiDriverSettings.h
  • PS_TEXFILTER_NO_NEG_LODBIAS_OFF : NvApiDriverSettings.h
  • PS_TEXFILTER_NO_NEG_LODBIAS_ON : NvApiDriverSettings.h


  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • a
  • b
  • c
  • d
  • e
  • f
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • v
  • w
Here is a list of all enum values with links to the files they belong to:

- q -

  • QUALITY_ENHANCEMENT_SUBSTITUTION_DEFAULT : NvApiDriverSettings.h
  • QUALITY_ENHANCEMENT_SUBSTITUTION_HIGHQUALITY_BECOMES_QUALITY : NvApiDriverSettings.h
  • QUALITY_ENHANCEMENT_SUBSTITUTION_ID : NvApiDriverSettings.h
  • QUALITY_ENHANCEMENT_SUBSTITUTION_NO_SUBSTITUTION : NvApiDriverSettings.h
  • QUALITY_ENHANCEMENT_SUBSTITUTION_NUM_VALUES : NvApiDriverSettings.h
  • QUALITY_ENHANCEMENTS_DEFAULT : NvApiDriverSettings.h
  • QUALITY_ENHANCEMENTS_HIGHPERFORMANCE : NvApiDriverSettings.h
  • QUALITY_ENHANCEMENTS_HIGHQUALITY : NvApiDriverSettings.h
  • QUALITY_ENHANCEMENTS_ID : NvApiDriverSettings.h
  • QUALITY_ENHANCEMENTS_NUM_VALUES : NvApiDriverSettings.h
  • QUALITY_ENHANCEMENTS_PERFORMANCE : NvApiDriverSettings.h
  • QUALITY_ENHANCEMENTS_QUALITY : NvApiDriverSettings.h


  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • a
  • b
  • c
  • d
  • e
  • f
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • v
  • w
Here is a list of all enum values with links to the files they belong to:

- r -

  • REFRESH_RATE_OVERRIDE_APPLICATION_CONTROLLED : NvApiDriverSettings.h
  • REFRESH_RATE_OVERRIDE_DEFAULT : NvApiDriverSettings.h
  • REFRESH_RATE_OVERRIDE_HIGHEST_AVAILABLE : NvApiDriverSettings.h
  • REFRESH_RATE_OVERRIDE_ID : NvApiDriverSettings.h
  • REFRESH_RATE_OVERRIDE_LOW_LATENCY_RR_MASK : NvApiDriverSettings.h
  • REFRESH_RATE_OVERRIDE_NUM_VALUES : NvApiDriverSettings.h
  • RENDERSUBMIT_END : nvapi.h
  • RENDERSUBMIT_START : nvapi.h


  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • a
  • b
  • c
  • d
  • e
  • f
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • v
  • w
Here is a list of all enum values with links to the files they belong to:

- s -

  • SET_POWER_THROTTLE_FOR_PCIe_COMPLIANCE_DEFAULT : NvApiDriverSettings.h
  • SET_POWER_THROTTLE_FOR_PCIe_COMPLIANCE_ID : NvApiDriverSettings.h
  • SET_POWER_THROTTLE_FOR_PCIe_COMPLIANCE_NUM_VALUES : NvApiDriverSettings.h
  • SET_POWER_THROTTLE_FOR_PCIe_COMPLIANCE_OFF : NvApiDriverSettings.h
  • SET_POWER_THROTTLE_FOR_PCIe_COMPLIANCE_ON : NvApiDriverSettings.h
  • SET_VAB_DATA_DEFAULT : NvApiDriverSettings.h
  • SET_VAB_DATA_FLOAT_NAN : NvApiDriverSettings.h
  • SET_VAB_DATA_FLOAT_ONE : NvApiDriverSettings.h
  • SET_VAB_DATA_FLOAT_POS_INF : NvApiDriverSettings.h
  • SET_VAB_DATA_ID : NvApiDriverSettings.h
  • SET_VAB_DATA_NUM_VALUES : NvApiDriverSettings.h
  • SET_VAB_DATA_UINT_ONE : NvApiDriverSettings.h
  • SET_VAB_DATA_USE_API_DEFAULTS : NvApiDriverSettings.h
  • SET_VAB_DATA_ZERO : NvApiDriverSettings.h
  • SHIM_MAXRES_ID : NvApiDriverSettings.h
  • SHIM_MCCOMPAT_AUTO_SELECT : NvApiDriverSettings.h
  • SHIM_MCCOMPAT_DEFAULT : NvApiDriverSettings.h
  • SHIM_MCCOMPAT_ENABLE : NvApiDriverSettings.h
  • SHIM_MCCOMPAT_ID : NvApiDriverSettings.h
  • SHIM_MCCOMPAT_INTEGRATED : NvApiDriverSettings.h
  • SHIM_MCCOMPAT_MASK : NvApiDriverSettings.h
  • SHIM_MCCOMPAT_NUM_VALUES : NvApiDriverSettings.h
  • SHIM_MCCOMPAT_OVERRIDE_BIT : NvApiDriverSettings.h
  • SHIM_MCCOMPAT_USER_EDITABLE : NvApiDriverSettings.h
  • SHIM_MCCOMPAT_VARYING_BIT : NvApiDriverSettings.h
  • SHIM_MCCOMPAT_VIDEO_MASK : NvApiDriverSettings.h
  • SHIM_RENDERING_MODE_AUTO_SELECT : NvApiDriverSettings.h
  • SHIM_RENDERING_MODE_DEFAULT : NvApiDriverSettings.h
  • SHIM_RENDERING_MODE_ENABLE : NvApiDriverSettings.h
  • SHIM_RENDERING_MODE_ID : NvApiDriverSettings.h
  • SHIM_RENDERING_MODE_INTEGRATED : NvApiDriverSettings.h
  • SHIM_RENDERING_MODE_MASK : NvApiDriverSettings.h
  • SHIM_RENDERING_MODE_NUM_VALUES : NvApiDriverSettings.h
  • SHIM_RENDERING_MODE_OVERRIDE_BIT : NvApiDriverSettings.h
  • SHIM_RENDERING_MODE_USER_EDITABLE : NvApiDriverSettings.h
  • SHIM_RENDERING_MODE_VARYING_BIT : NvApiDriverSettings.h
  • SHIM_RENDERING_MODE_VIDEO_MASK : NvApiDriverSettings.h
  • SHIM_RENDERING_OPTIONS_ALLOW_CP_CAPS_FOR_VIDEO : NvApiDriverSettings.h
  • SHIM_RENDERING_OPTIONS_ALLOW_DYNAMIC_DISPLAY_MUX_SWITCH : NvApiDriverSettings.h
  • SHIM_RENDERING_OPTIONS_ALLOW_INHERITANCE : NvApiDriverSettings.h
  • SHIM_RENDERING_OPTIONS_DEFAULT : NvApiDriverSettings.h
  • SHIM_RENDERING_OPTIONS_DEFAULT_RENDERING_MODE : NvApiDriverSettings.h
  • SHIM_RENDERING_OPTIONS_DISABLE_ASYNC_PRESENT : NvApiDriverSettings.h
  • SHIM_RENDERING_OPTIONS_DISABLE_CUDA : NvApiDriverSettings.h
  • SHIM_RENDERING_OPTIONS_DISABLE_DURING_SECURE_BOOT : NvApiDriverSettings.h
  • SHIM_RENDERING_OPTIONS_DISABLE_DXGI_WRAPPERS : NvApiDriverSettings.h
  • SHIM_RENDERING_OPTIONS_DISABLE_TURING_POWER_POLICY : NvApiDriverSettings.h
  • SHIM_RENDERING_OPTIONS_DISABLE_WRAPPERS : NvApiDriverSettings.h
  • SHIM_RENDERING_OPTIONS_DISALLOW_DYNAMIC_DISPLAY_MUX_SWITCH : NvApiDriverSettings.h
  • SHIM_RENDERING_OPTIONS_EHSHELL_DETECT : NvApiDriverSettings.h
  • SHIM_RENDERING_OPTIONS_ENABLE_ALPHA_FORMAT : NvApiDriverSettings.h
  • SHIM_RENDERING_OPTIONS_ENABLE_DWM_ASYNC_PRESENT : NvApiDriverSettings.h
  • SHIM_RENDERING_OPTIONS_EXPLICIT_ADAPTER_OPTED_BY_APP : NvApiDriverSettings.h
  • SHIM_RENDERING_OPTIONS_FLASHPLAYER_HOST_DETECT : NvApiDriverSettings.h
  • SHIM_RENDERING_OPTIONS_HANDLE_WIN7_ASYNC_RUNTIME_BUG : NvApiDriverSettings.h
  • SHIM_RENDERING_OPTIONS_HANDLE_WINDOWED_MODE_PERF_OPT : NvApiDriverSettings.h
  • SHIM_RENDERING_OPTIONS_ID : NvApiDriverSettings.h
  • SHIM_RENDERING_OPTIONS_IGNORE_OVERRIDES : NvApiDriverSettings.h
  • SHIM_RENDERING_OPTIONS_IGPU_TRANSCODING : NvApiDriverSettings.h
  • SHIM_RENDERING_OPTIONS_IGPU_TRANSCODING_FWD_OPTIMUS : NvApiDriverSettings.h
  • SHIM_RENDERING_OPTIONS_INVERT_FOR_MSHYBRID : NvApiDriverSettings.h
  • SHIM_RENDERING_OPTIONS_INVERT_FOR_QUADRO : NvApiDriverSettings.h
  • SHIM_RENDERING_OPTIONS_NUM_VALUES : NvApiDriverSettings.h
  • SHIM_RENDERING_OPTIONS_PRUNE_UNSUPPORTED_FORMATS : NvApiDriverSettings.h
  • SHIM_RENDERING_OPTIONS_REGISTER_PROCESS_ENABLE_GOLD : NvApiDriverSettings.h
  • SHIM_RENDERING_OPTIONS_RESERVED1 : NvApiDriverSettings.h
  • SHIM_RENDERING_OPTIONS_RESERVED2 : NvApiDriverSettings.h
  • SHIM_RENDERING_OPTIONS_VIDEO_DRM_APP_DETECT : NvApiDriverSettings.h
  • SIMULATION_END : nvapi.h
  • SIMULATION_START : nvapi.h
  • SLI_GPU_COUNT_AUTOSELECT : NvApiDriverSettings.h
  • SLI_GPU_COUNT_DEFAULT : NvApiDriverSettings.h
  • SLI_GPU_COUNT_FOUR : NvApiDriverSettings.h
  • SLI_GPU_COUNT_ID : NvApiDriverSettings.h
  • SLI_GPU_COUNT_NUM_VALUES : NvApiDriverSettings.h
  • SLI_GPU_COUNT_ONE : NvApiDriverSettings.h
  • SLI_GPU_COUNT_THREE : NvApiDriverSettings.h
  • SLI_GPU_COUNT_TWO : NvApiDriverSettings.h
  • SLI_PREDEFINED_GPU_COUNT_AUTOSELECT : NvApiDriverSettings.h
  • SLI_PREDEFINED_GPU_COUNT_DEFAULT : NvApiDriverSettings.h
  • SLI_PREDEFINED_GPU_COUNT_DX10_AUTOSELECT : NvApiDriverSettings.h
  • SLI_PREDEFINED_GPU_COUNT_DX10_DEFAULT : NvApiDriverSettings.h
  • SLI_PREDEFINED_GPU_COUNT_DX10_FOUR : NvApiDriverSettings.h
  • SLI_PREDEFINED_GPU_COUNT_DX10_ID : NvApiDriverSettings.h
  • SLI_PREDEFINED_GPU_COUNT_DX10_NUM_VALUES : NvApiDriverSettings.h
  • SLI_PREDEFINED_GPU_COUNT_DX10_ONE : NvApiDriverSettings.h
  • SLI_PREDEFINED_GPU_COUNT_DX10_THREE : NvApiDriverSettings.h
  • SLI_PREDEFINED_GPU_COUNT_DX10_TWO : NvApiDriverSettings.h
  • SLI_PREDEFINED_GPU_COUNT_FOUR : NvApiDriverSettings.h
  • SLI_PREDEFINED_GPU_COUNT_ID : NvApiDriverSettings.h
  • SLI_PREDEFINED_GPU_COUNT_NUM_VALUES : NvApiDriverSettings.h
  • SLI_PREDEFINED_GPU_COUNT_ONE : NvApiDriverSettings.h
  • SLI_PREDEFINED_GPU_COUNT_THREE : NvApiDriverSettings.h
  • SLI_PREDEFINED_GPU_COUNT_TWO : NvApiDriverSettings.h
  • SLI_PREDEFINED_MODE_AUTOSELECT : NvApiDriverSettings.h
  • SLI_PREDEFINED_MODE_DEFAULT : NvApiDriverSettings.h
  • SLI_PREDEFINED_MODE_DX10_AUTOSELECT : NvApiDriverSettings.h
  • SLI_PREDEFINED_MODE_DX10_DEFAULT : NvApiDriverSettings.h
  • SLI_PREDEFINED_MODE_DX10_FORCE_AFR : NvApiDriverSettings.h
  • SLI_PREDEFINED_MODE_DX10_FORCE_AFR2 : NvApiDriverSettings.h
  • SLI_PREDEFINED_MODE_DX10_FORCE_AFR_OF_SFR__FALLBACK_3AFR : NvApiDriverSettings.h
  • SLI_PREDEFINED_MODE_DX10_FORCE_SFR : NvApiDriverSettings.h
  • SLI_PREDEFINED_MODE_DX10_FORCE_SINGLE : NvApiDriverSettings.h
  • SLI_PREDEFINED_MODE_DX10_ID : NvApiDriverSettings.h
  • SLI_PREDEFINED_MODE_DX10_NUM_VALUES : NvApiDriverSettings.h
  • SLI_PREDEFINED_MODE_FORCE_AFR : NvApiDriverSettings.h
  • SLI_PREDEFINED_MODE_FORCE_AFR2 : NvApiDriverSettings.h
  • SLI_PREDEFINED_MODE_FORCE_AFR_OF_SFR__FALLBACK_3AFR : NvApiDriverSettings.h
  • SLI_PREDEFINED_MODE_FORCE_SFR : NvApiDriverSettings.h
  • SLI_PREDEFINED_MODE_FORCE_SINGLE : NvApiDriverSettings.h
  • SLI_PREDEFINED_MODE_ID : NvApiDriverSettings.h
  • SLI_PREDEFINED_MODE_NUM_VALUES : NvApiDriverSettings.h
  • SLI_RENDERING_MODE_AUTOSELECT : NvApiDriverSettings.h
  • SLI_RENDERING_MODE_DEFAULT : NvApiDriverSettings.h
  • SLI_RENDERING_MODE_FORCE_AFR : NvApiDriverSettings.h
  • SLI_RENDERING_MODE_FORCE_AFR2 : NvApiDriverSettings.h
  • SLI_RENDERING_MODE_FORCE_AFR_OF_SFR__FALLBACK_3AFR : NvApiDriverSettings.h
  • SLI_RENDERING_MODE_FORCE_SFR : NvApiDriverSettings.h
  • SLI_RENDERING_MODE_FORCE_SINGLE : NvApiDriverSettings.h
  • SLI_RENDERING_MODE_ID : NvApiDriverSettings.h
  • SLI_RENDERING_MODE_NUM_VALUES : NvApiDriverSettings.h


  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • a
  • b
  • c
  • d
  • e
  • f
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • v
  • w
Here is a list of all enum values with links to the files they belong to:

- t -

  • TOTAL_DWORD_SETTING_NUM : NvApiDriverSettings.h
  • TOTAL_SETTING_NUM : NvApiDriverSettings.h
  • TOTAL_WSTRING_SETTING_NUM : NvApiDriverSettings.h
  • TRIGGER_FLASH : nvapi.h


  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • a
  • b
  • c
  • d
  • e
  • f
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • v
  • w
Here is a list of all enum values with links to the files they belong to:

- v -

  • VRPRERENDERLIMIT_APP_CONTROLLED : NvApiDriverSettings.h
  • VRPRERENDERLIMIT_DEFAULT : NvApiDriverSettings.h
  • VRPRERENDERLIMIT_ID : NvApiDriverSettings.h
  • VRPRERENDERLIMIT_MAX : NvApiDriverSettings.h
  • VRPRERENDERLIMIT_MIN : NvApiDriverSettings.h
  • VRPRERENDERLIMIT_NUM_VALUES : NvApiDriverSettings.h
  • VRR_APP_OVERRIDE_ALLOW : NvApiDriverSettings.h
  • VRR_APP_OVERRIDE_DEFAULT : NvApiDriverSettings.h
  • VRR_APP_OVERRIDE_DISALLOW : NvApiDriverSettings.h
  • VRR_APP_OVERRIDE_FIXED_REFRESH : NvApiDriverSettings.h
  • VRR_APP_OVERRIDE_FORCE_OFF : NvApiDriverSettings.h
  • VRR_APP_OVERRIDE_ID : NvApiDriverSettings.h
  • VRR_APP_OVERRIDE_NUM_VALUES : NvApiDriverSettings.h
  • VRR_APP_OVERRIDE_REQUEST_STATE_ALLOW : NvApiDriverSettings.h
  • VRR_APP_OVERRIDE_REQUEST_STATE_DEFAULT : NvApiDriverSettings.h
  • VRR_APP_OVERRIDE_REQUEST_STATE_DISALLOW : NvApiDriverSettings.h
  • VRR_APP_OVERRIDE_REQUEST_STATE_FIXED_REFRESH : NvApiDriverSettings.h
  • VRR_APP_OVERRIDE_REQUEST_STATE_FORCE_OFF : NvApiDriverSettings.h
  • VRR_APP_OVERRIDE_REQUEST_STATE_ID : NvApiDriverSettings.h
  • VRR_APP_OVERRIDE_REQUEST_STATE_NUM_VALUES : NvApiDriverSettings.h
  • VRR_APP_OVERRIDE_REQUEST_STATE_ULMB : NvApiDriverSettings.h
  • VRR_APP_OVERRIDE_ULMB : NvApiDriverSettings.h
  • VRR_MODE_DEFAULT : NvApiDriverSettings.h
  • VRR_MODE_DISABLED : NvApiDriverSettings.h
  • VRR_MODE_FULLSCREEN_AND_WINDOWED : NvApiDriverSettings.h
  • VRR_MODE_FULLSCREEN_ONLY : NvApiDriverSettings.h
  • VRR_MODE_ID : NvApiDriverSettings.h
  • VRR_MODE_NUM_VALUES : NvApiDriverSettings.h
  • VRRFEATUREINDICATOR_DEFAULT : NvApiDriverSettings.h
  • VRRFEATUREINDICATOR_DISABLED : NvApiDriverSettings.h
  • VRRFEATUREINDICATOR_ENABLED : NvApiDriverSettings.h
  • VRRFEATUREINDICATOR_ID : NvApiDriverSettings.h
  • VRRFEATUREINDICATOR_NUM_VALUES : NvApiDriverSettings.h
  • VRROVERLAYINDICATOR_DEFAULT : NvApiDriverSettings.h
  • VRROVERLAYINDICATOR_DISABLED : NvApiDriverSettings.h
  • VRROVERLAYINDICATOR_ENABLED : NvApiDriverSettings.h
  • VRROVERLAYINDICATOR_ID : NvApiDriverSettings.h
  • VRROVERLAYINDICATOR_NUM_VALUES : NvApiDriverSettings.h
  • VRRREQUESTSTATE_DEFAULT : NvApiDriverSettings.h
  • VRRREQUESTSTATE_DISABLED : NvApiDriverSettings.h
  • VRRREQUESTSTATE_FULLSCREEN_AND_WINDOWED : NvApiDriverSettings.h
  • VRRREQUESTSTATE_FULLSCREEN_ONLY : NvApiDriverSettings.h
  • VRRREQUESTSTATE_ID : NvApiDriverSettings.h
  • VRRREQUESTSTATE_NUM_VALUES : NvApiDriverSettings.h
  • VSYNC_BEHAVIOR_FLAGS_DEFAULT : NvApiDriverSettings.h
  • VSYNC_BEHAVIOR_FLAGS_ID : NvApiDriverSettings.h
  • VSYNC_BEHAVIOR_FLAGS_IGNORE_FLIPINTERVAL_MULTIPLE : NvApiDriverSettings.h
  • VSYNC_BEHAVIOR_FLAGS_NONE : NvApiDriverSettings.h
  • VSYNC_BEHAVIOR_FLAGS_NUM_VALUES : NvApiDriverSettings.h
  • VSYNCMODE_DEFAULT : NvApiDriverSettings.h
  • VSYNCMODE_FLIPINTERVAL2 : NvApiDriverSettings.h
  • VSYNCMODE_FLIPINTERVAL3 : NvApiDriverSettings.h
  • VSYNCMODE_FLIPINTERVAL4 : NvApiDriverSettings.h
  • VSYNCMODE_FORCEOFF : NvApiDriverSettings.h
  • VSYNCMODE_FORCEON : NvApiDriverSettings.h
  • VSYNCMODE_ID : NvApiDriverSettings.h
  • VSYNCMODE_NUM_VALUES : NvApiDriverSettings.h
  • VSYNCMODE_PASSIVE : NvApiDriverSettings.h
  • VSYNCMODE_VIRTUAL : NvApiDriverSettings.h
  • VSYNCSMOOTHAFR_DEFAULT : NvApiDriverSettings.h
  • VSYNCSMOOTHAFR_ID : NvApiDriverSettings.h
  • VSYNCSMOOTHAFR_NUM_VALUES : NvApiDriverSettings.h
  • VSYNCSMOOTHAFR_OFF : NvApiDriverSettings.h
  • VSYNCSMOOTHAFR_ON : NvApiDriverSettings.h
  • VSYNCTEARCONTROL_DEFAULT : NvApiDriverSettings.h
  • VSYNCTEARCONTROL_DISABLE : NvApiDriverSettings.h
  • VSYNCTEARCONTROL_ENABLE : NvApiDriverSettings.h
  • VSYNCTEARCONTROL_ID : NvApiDriverSettings.h
  • VSYNCTEARCONTROL_NUM_VALUES : NvApiDriverSettings.h
  • VSYNCVRRCONTROL_DEFAULT : NvApiDriverSettings.h
  • VSYNCVRRCONTROL_DISABLE : NvApiDriverSettings.h
  • VSYNCVRRCONTROL_ENABLE : NvApiDriverSettings.h
  • VSYNCVRRCONTROL_ID : NvApiDriverSettings.h
  • VSYNCVRRCONTROL_NOTSUPPORTED : NvApiDriverSettings.h
  • VSYNCVRRCONTROL_NUM_VALUES : NvApiDriverSettings.h


  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • a
  • b
  • c
  • d
  • e
  • f
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • v
  • w
Here is a list of all enum values with links to the files they belong to:

- w -

  • WKS_API_STEREO_EYES_EXCHANGE_DEFAULT : NvApiDriverSettings.h
  • WKS_API_STEREO_EYES_EXCHANGE_ID : NvApiDriverSettings.h
  • WKS_API_STEREO_EYES_EXCHANGE_NUM_VALUES : NvApiDriverSettings.h
  • WKS_API_STEREO_EYES_EXCHANGE_OFF : NvApiDriverSettings.h
  • WKS_API_STEREO_EYES_EXCHANGE_ON : NvApiDriverSettings.h
  • WKS_API_STEREO_MODE_AEGIS_DT_FRAME_SEQUENTIAL : NvApiDriverSettings.h
  • WKS_API_STEREO_MODE_ANAGLYPH : NvApiDriverSettings.h
  • WKS_API_STEREO_MODE_AUTODETECT_PASSIVE_MODE : NvApiDriverSettings.h
  • WKS_API_STEREO_MODE_CHECKERBOARD : NvApiDriverSettings.h
  • WKS_API_STEREO_MODE_COLOR_INTERLEAVED : NvApiDriverSettings.h
  • WKS_API_STEREO_MODE_COLOR_LINE : NvApiDriverSettings.h
  • WKS_API_STEREO_MODE_DEFAULT : NvApiDriverSettings.h
  • WKS_API_STEREO_MODE_DEFAULT_GL : NvApiDriverSettings.h
  • WKS_API_STEREO_MODE_DP_INBAND : NvApiDriverSettings.h
  • WKS_API_STEREO_MODE_FRAME_SEQUENTIAL : NvApiDriverSettings.h
  • WKS_API_STEREO_MODE_HORIZONTAL_INTERLACED : NvApiDriverSettings.h
  • WKS_API_STEREO_MODE_ID : NvApiDriverSettings.h
  • WKS_API_STEREO_MODE_INVERSE_CHECKERBOARD : NvApiDriverSettings.h
  • WKS_API_STEREO_MODE_NUM_VALUES : NvApiDriverSettings.h
  • WKS_API_STEREO_MODE_NV17_SHUTTER_GLASSES_AUTO : NvApiDriverSettings.h
  • WKS_API_STEREO_MODE_NV17_SHUTTER_GLASSES_DAC0 : NvApiDriverSettings.h
  • WKS_API_STEREO_MODE_NV17_SHUTTER_GLASSES_DAC1 : NvApiDriverSettings.h
  • WKS_API_STEREO_MODE_OEM_EMITTER_FRAME_SEQUENTIAL : NvApiDriverSettings.h
  • WKS_API_STEREO_MODE_SEEFRONT : NvApiDriverSettings.h
  • WKS_API_STEREO_MODE_SHUTTER_GLASSES : NvApiDriverSettings.h
  • WKS_API_STEREO_MODE_SIDE_FIELD : NvApiDriverSettings.h
  • WKS_API_STEREO_MODE_STEREO_MIRROR : NvApiDriverSettings.h
  • WKS_API_STEREO_MODE_SUB_FIELD : NvApiDriverSettings.h
  • WKS_API_STEREO_MODE_TRIDELITY_MV : NvApiDriverSettings.h
  • WKS_API_STEREO_MODE_TRIDELITY_SL : NvApiDriverSettings.h
  • WKS_API_STEREO_MODE_TWINVIEW : NvApiDriverSettings.h
  • WKS_API_STEREO_MODE_USE_HW_DEFAULT : NvApiDriverSettings.h
  • WKS_API_STEREO_MODE_VERTICAL_INTERLACED : NvApiDriverSettings.h
  • WKS_STEREO_DONGLE_SUPPORT_DAC : NvApiDriverSettings.h
  • WKS_STEREO_DONGLE_SUPPORT_DEFAULT : NvApiDriverSettings.h
  • WKS_STEREO_DONGLE_SUPPORT_DLP : NvApiDriverSettings.h
  • WKS_STEREO_DONGLE_SUPPORT_ID : NvApiDriverSettings.h
  • WKS_STEREO_DONGLE_SUPPORT_NUM_VALUES : NvApiDriverSettings.h
  • WKS_STEREO_DONGLE_SUPPORT_OFF : NvApiDriverSettings.h
  • WKS_STEREO_SUPPORT_DEFAULT : NvApiDriverSettings.h
  • WKS_STEREO_SUPPORT_ID : NvApiDriverSettings.h
  • WKS_STEREO_SUPPORT_NUM_VALUES : NvApiDriverSettings.h
  • WKS_STEREO_SUPPORT_OFF : NvApiDriverSettings.h
  • WKS_STEREO_SUPPORT_ON : NvApiDriverSettings.h
  • WKS_STEREO_SWAP_MODE_APPLICATION_CONTROL : NvApiDriverSettings.h
  • WKS_STEREO_SWAP_MODE_DEFAULT : NvApiDriverSettings.h
  • WKS_STEREO_SWAP_MODE_ID : NvApiDriverSettings.h
  • WKS_STEREO_SWAP_MODE_LEGACY_BEHAVIOR : NvApiDriverSettings.h
  • WKS_STEREO_SWAP_MODE_NUM_VALUES : NvApiDriverSettings.h
  • WKS_STEREO_SWAP_MODE_PER_EYE : NvApiDriverSettings.h
  • WKS_STEREO_SWAP_MODE_PER_EYE_FOR_SWAP_GROUP : NvApiDriverSettings.h
  • WKS_STEREO_SWAP_MODE_PER_EYE_PAIR : NvApiDriverSettings.h


  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • v
  • w
Here is a list of all macros with links to the files they belong to:

- _ -

  • __bcount : nvapi_lite_salstart.h
  • __bcount_opt : nvapi_lite_salstart.h
  • __cdecl : nvapi.h
  • __deref_bcount : nvapi_lite_salstart.h
  • __deref_bcount_opt : nvapi_lite_salstart.h
  • __deref_ecount : nvapi_lite_salstart.h
  • __deref_ecount_opt : nvapi_lite_salstart.h
  • __deref_inout : nvapi_lite_salstart.h
  • __deref_inout_bcount : nvapi_lite_salstart.h
  • __deref_inout_bcount_full : nvapi_lite_salstart.h
  • __deref_inout_bcount_full_opt : nvapi_lite_salstart.h
  • __deref_inout_bcount_nz : nvapi_lite_salstart.h
  • __deref_inout_bcount_nz_opt : nvapi_lite_salstart.h
  • __deref_inout_bcount_opt : nvapi_lite_salstart.h
  • __deref_inout_bcount_part : nvapi_lite_salstart.h
  • __deref_inout_bcount_part_opt : nvapi_lite_salstart.h
  • __deref_inout_bcount_z : nvapi_lite_salstart.h
  • __deref_inout_bcount_z_opt : nvapi_lite_salstart.h
  • __deref_inout_ecount : nvapi_lite_salstart.h
  • __deref_inout_ecount_full : nvapi_lite_salstart.h
  • __deref_inout_ecount_full_opt : nvapi_lite_salstart.h
  • __deref_inout_ecount_nz : nvapi_lite_salstart.h
  • __deref_inout_ecount_nz_opt : nvapi_lite_salstart.h
  • __deref_inout_ecount_opt : nvapi_lite_salstart.h
  • __deref_inout_ecount_part : nvapi_lite_salstart.h
  • __deref_inout_ecount_part_opt : nvapi_lite_salstart.h
  • __deref_inout_ecount_z : nvapi_lite_salstart.h
  • __deref_inout_ecount_z_opt : nvapi_lite_salstart.h
  • __deref_inout_nz : nvapi_lite_salstart.h
  • __deref_inout_nz_opt : nvapi_lite_salstart.h
  • __deref_inout_opt : nvapi_lite_salstart.h
  • __deref_inout_z : nvapi_lite_salstart.h
  • __deref_inout_z_opt : nvapi_lite_salstart.h
  • __deref_opt_bcount : nvapi_lite_salstart.h
  • __deref_opt_bcount_opt : nvapi_lite_salstart.h
  • __deref_opt_ecount : nvapi_lite_salstart.h
  • __deref_opt_ecount_opt : nvapi_lite_salstart.h
  • __deref_opt_inout : nvapi_lite_salstart.h
  • __deref_opt_inout_bcount : nvapi_lite_salstart.h
  • __deref_opt_inout_bcount_full : nvapi_lite_salstart.h
  • __deref_opt_inout_bcount_full_opt : nvapi_lite_salstart.h
  • __deref_opt_inout_bcount_nz : nvapi_lite_salstart.h
  • __deref_opt_inout_bcount_nz_opt : nvapi_lite_salstart.h
  • __deref_opt_inout_bcount_opt : nvapi_lite_salstart.h
  • __deref_opt_inout_bcount_part : nvapi_lite_salstart.h
  • __deref_opt_inout_bcount_part_opt : nvapi_lite_salstart.h
  • __deref_opt_inout_bcount_z : nvapi_lite_salstart.h
  • __deref_opt_inout_bcount_z_opt : nvapi_lite_salstart.h
  • __deref_opt_inout_ecount : nvapi_lite_salstart.h
  • __deref_opt_inout_ecount_full : nvapi_lite_salstart.h
  • __deref_opt_inout_ecount_full_opt : nvapi_lite_salstart.h
  • __deref_opt_inout_ecount_nz : nvapi_lite_salstart.h
  • __deref_opt_inout_ecount_nz_opt : nvapi_lite_salstart.h
  • __deref_opt_inout_ecount_opt : nvapi_lite_salstart.h
  • __deref_opt_inout_ecount_part : nvapi_lite_salstart.h
  • __deref_opt_inout_ecount_part_opt : nvapi_lite_salstart.h
  • __deref_opt_inout_ecount_z : nvapi_lite_salstart.h
  • __deref_opt_inout_ecount_z_opt : nvapi_lite_salstart.h
  • __deref_opt_inout_nz : nvapi_lite_salstart.h
  • __deref_opt_inout_nz_opt : nvapi_lite_salstart.h
  • __deref_opt_inout_opt : nvapi_lite_salstart.h
  • __deref_opt_inout_z : nvapi_lite_salstart.h
  • __deref_opt_inout_z_opt : nvapi_lite_salstart.h
  • __deref_opt_out : nvapi_lite_salstart.h
  • __deref_opt_out_bcount : nvapi_lite_salstart.h
  • __deref_opt_out_bcount_full : nvapi_lite_salstart.h
  • __deref_opt_out_bcount_full_opt : nvapi_lite_salstart.h
  • __deref_opt_out_bcount_nz_opt : nvapi_lite_salstart.h
  • __deref_opt_out_bcount_opt : nvapi_lite_salstart.h
  • __deref_opt_out_bcount_part : nvapi_lite_salstart.h
  • __deref_opt_out_bcount_part_opt : nvapi_lite_salstart.h
  • __deref_opt_out_bcount_z_opt : nvapi_lite_salstart.h
  • __deref_opt_out_ecount : nvapi_lite_salstart.h
  • __deref_opt_out_ecount_full : nvapi_lite_salstart.h
  • __deref_opt_out_ecount_full_opt : nvapi_lite_salstart.h
  • __deref_opt_out_ecount_nz_opt : nvapi_lite_salstart.h
  • __deref_opt_out_ecount_opt : nvapi_lite_salstart.h
  • __deref_opt_out_ecount_part : nvapi_lite_salstart.h
  • __deref_opt_out_ecount_part_opt : nvapi_lite_salstart.h
  • __deref_opt_out_ecount_z_opt : nvapi_lite_salstart.h
  • __deref_opt_out_nz_opt : nvapi_lite_salstart.h
  • __deref_opt_out_opt : nvapi_lite_salstart.h
  • __deref_opt_out_z : nvapi_lite_salstart.h
  • __deref_opt_out_z_opt : nvapi_lite_salstart.h
  • __deref_out : nvapi_lite_salstart.h
  • __deref_out_bcount : nvapi_lite_salstart.h
  • __deref_out_bcount_full : nvapi_lite_salstart.h
  • __deref_out_bcount_full_opt : nvapi_lite_salstart.h
  • __deref_out_bcount_nz : nvapi_lite_salstart.h
  • __deref_out_bcount_nz_opt : nvapi_lite_salstart.h
  • __deref_out_bcount_opt : nvapi_lite_salstart.h
  • __deref_out_bcount_part : nvapi_lite_salstart.h
  • __deref_out_bcount_part_opt : nvapi_lite_salstart.h
  • __deref_out_bcount_z : nvapi_lite_salstart.h
  • __deref_out_bcount_z_opt : nvapi_lite_salstart.h
  • __deref_out_ecount : nvapi_lite_salstart.h
  • __deref_out_ecount_full : nvapi_lite_salstart.h
  • __deref_out_ecount_full_opt : nvapi_lite_salstart.h
  • __deref_out_ecount_nz : nvapi_lite_salstart.h
  • __deref_out_ecount_nz_opt : nvapi_lite_salstart.h
  • __deref_out_ecount_opt : nvapi_lite_salstart.h
  • __deref_out_ecount_part : nvapi_lite_salstart.h
  • __deref_out_ecount_part_opt : nvapi_lite_salstart.h
  • __deref_out_ecount_z : nvapi_lite_salstart.h
  • __deref_out_ecount_z_opt : nvapi_lite_salstart.h
  • __deref_out_nz : nvapi_lite_salstart.h
  • __deref_out_nz_opt : nvapi_lite_salstart.h
  • __deref_out_opt : nvapi_lite_salstart.h
  • __deref_out_z : nvapi_lite_salstart.h
  • __deref_out_z_opt : nvapi_lite_salstart.h
  • __ecount : nvapi_lite_salstart.h
  • __ecount_opt : nvapi_lite_salstart.h
  • __in : nvapi_lite_salstart.h
  • __in_bcount : nvapi_lite_salstart.h
  • __in_bcount_nz : nvapi_lite_salstart.h
  • __in_bcount_nz_opt : nvapi_lite_salstart.h
  • __in_bcount_opt : nvapi_lite_salstart.h
  • __in_bcount_z : nvapi_lite_salstart.h
  • __in_bcount_z_opt : nvapi_lite_salstart.h
  • __in_ecount : nvapi_lite_salstart.h
  • __in_ecount_nz : nvapi_lite_salstart.h
  • __in_ecount_nz_opt : nvapi_lite_salstart.h
  • __in_ecount_opt : nvapi_lite_salstart.h
  • __in_ecount_z : nvapi_lite_salstart.h
  • __in_ecount_z_opt : nvapi_lite_salstart.h
  • __in_nz : nvapi_lite_salstart.h
  • __in_nz_opt : nvapi_lite_salstart.h
  • __in_opt : nvapi_lite_salstart.h
  • __in_z : nvapi_lite_salstart.h
  • __in_z_opt : nvapi_lite_salstart.h
  • __inout : nvapi_lite_salstart.h
  • __inout_bcount : nvapi_lite_salstart.h
  • __inout_bcount_full : nvapi_lite_salstart.h
  • __inout_bcount_full_opt : nvapi_lite_salstart.h
  • __inout_bcount_nz : nvapi_lite_salstart.h
  • __inout_bcount_nz_opt : nvapi_lite_salstart.h
  • __inout_bcount_opt : nvapi_lite_salstart.h
  • __inout_bcount_part : nvapi_lite_salstart.h
  • __inout_bcount_part_opt : nvapi_lite_salstart.h
  • __inout_bcount_z : nvapi_lite_salstart.h
  • __inout_bcount_z_opt : nvapi_lite_salstart.h
  • __inout_ecount : nvapi_lite_salstart.h
  • __inout_ecount_full : nvapi_lite_salstart.h
  • __inout_ecount_full_opt : nvapi_lite_salstart.h
  • __inout_ecount_nz : nvapi_lite_salstart.h
  • __inout_ecount_nz_opt : nvapi_lite_salstart.h
  • __inout_ecount_opt : nvapi_lite_salstart.h
  • __inout_ecount_part : nvapi_lite_salstart.h
  • __inout_ecount_part_opt : nvapi_lite_salstart.h
  • __inout_ecount_z : nvapi_lite_salstart.h
  • __inout_ecount_z_opt : nvapi_lite_salstart.h
  • __inout_nz : nvapi_lite_salstart.h
  • __inout_nz_opt : nvapi_lite_salstart.h
  • __inout_opt : nvapi_lite_salstart.h
  • __inout_z : nvapi_lite_salstart.h
  • __inout_z_opt : nvapi_lite_salstart.h
  • __nvapi__Post_writable_byte_size_ : nvapi_lite_salstart.h
  • __nvapi__Ret_notnull_ : nvapi_lite_salstart.h
  • __nvapi_deprecated_datatype : nvapi_lite_common.h
  • __nvapi_deprecated_function : nvapi_lite_common.h
  • __nvapi_Outptr_ : nvapi_lite_salstart.h
  • __nvapi_success : nvapi_lite_salstart.h
  • __nvapi_undef__bcount : nvapi_lite_salstart.h
  • __nvapi_undef__bcount_opt : nvapi_lite_salstart.h
  • __nvapi_undef__deref_bcount : nvapi_lite_salstart.h
  • __nvapi_undef__deref_bcount_opt : nvapi_lite_salstart.h
  • __nvapi_undef__deref_ecount : nvapi_lite_salstart.h
  • __nvapi_undef__deref_ecount_opt : nvapi_lite_salstart.h
  • __nvapi_undef__deref_inout : nvapi_lite_salstart.h
  • __nvapi_undef__deref_inout_bcount : nvapi_lite_salstart.h
  • __nvapi_undef__deref_inout_bcount_full : nvapi_lite_salstart.h
  • __nvapi_undef__deref_inout_bcount_full_opt : nvapi_lite_salstart.h
  • __nvapi_undef__deref_inout_bcount_nz : nvapi_lite_salstart.h
  • __nvapi_undef__deref_inout_bcount_nz_opt : nvapi_lite_salstart.h
  • __nvapi_undef__deref_inout_bcount_opt : nvapi_lite_salstart.h
  • __nvapi_undef__deref_inout_bcount_part : nvapi_lite_salstart.h
  • __nvapi_undef__deref_inout_bcount_part_opt : nvapi_lite_salstart.h
  • __nvapi_undef__deref_inout_bcount_z : nvapi_lite_salstart.h
  • __nvapi_undef__deref_inout_bcount_z_opt : nvapi_lite_salstart.h
  • __nvapi_undef__deref_inout_ecount : nvapi_lite_salstart.h
  • __nvapi_undef__deref_inout_ecount_full : nvapi_lite_salstart.h
  • __nvapi_undef__deref_inout_ecount_full_opt : nvapi_lite_salstart.h
  • __nvapi_undef__deref_inout_ecount_nz : nvapi_lite_salstart.h
  • __nvapi_undef__deref_inout_ecount_nz_opt : nvapi_lite_salstart.h
  • __nvapi_undef__deref_inout_ecount_opt : nvapi_lite_salstart.h
  • __nvapi_undef__deref_inout_ecount_part : nvapi_lite_salstart.h
  • __nvapi_undef__deref_inout_ecount_part_opt : nvapi_lite_salstart.h
  • __nvapi_undef__deref_inout_ecount_z : nvapi_lite_salstart.h
  • __nvapi_undef__deref_inout_ecount_z_opt : nvapi_lite_salstart.h
  • __nvapi_undef__deref_inout_nz : nvapi_lite_salstart.h
  • __nvapi_undef__deref_inout_nz_opt : nvapi_lite_salstart.h
  • __nvapi_undef__deref_inout_opt : nvapi_lite_salstart.h
  • __nvapi_undef__deref_inout_z : nvapi_lite_salstart.h
  • __nvapi_undef__deref_inout_z_opt : nvapi_lite_salstart.h
  • __nvapi_undef__deref_opt_bcount : nvapi_lite_salstart.h
  • __nvapi_undef__deref_opt_bcount_opt : nvapi_lite_salstart.h
  • __nvapi_undef__deref_opt_ecount : nvapi_lite_salstart.h
  • __nvapi_undef__deref_opt_ecount_opt : nvapi_lite_salstart.h
  • __nvapi_undef__deref_opt_inout : nvapi_lite_salstart.h
  • __nvapi_undef__deref_opt_inout_bcount : nvapi_lite_salstart.h
  • __nvapi_undef__deref_opt_inout_bcount_full : nvapi_lite_salstart.h
  • __nvapi_undef__deref_opt_inout_bcount_full_opt : nvapi_lite_salstart.h
  • __nvapi_undef__deref_opt_inout_bcount_nz : nvapi_lite_salstart.h
  • __nvapi_undef__deref_opt_inout_bcount_nz_opt : nvapi_lite_salstart.h
  • __nvapi_undef__deref_opt_inout_bcount_opt : nvapi_lite_salstart.h
  • __nvapi_undef__deref_opt_inout_bcount_part : nvapi_lite_salstart.h
  • __nvapi_undef__deref_opt_inout_bcount_part_opt : nvapi_lite_salstart.h
  • __nvapi_undef__deref_opt_inout_bcount_z : nvapi_lite_salstart.h
  • __nvapi_undef__deref_opt_inout_bcount_z_opt : nvapi_lite_salstart.h
  • __nvapi_undef__deref_opt_inout_ecount : nvapi_lite_salstart.h
  • __nvapi_undef__deref_opt_inout_ecount_full : nvapi_lite_salstart.h
  • __nvapi_undef__deref_opt_inout_ecount_full_opt : nvapi_lite_salstart.h
  • __nvapi_undef__deref_opt_inout_ecount_nz : nvapi_lite_salstart.h
  • __nvapi_undef__deref_opt_inout_ecount_nz_opt : nvapi_lite_salstart.h
  • __nvapi_undef__deref_opt_inout_ecount_opt : nvapi_lite_salstart.h
  • __nvapi_undef__deref_opt_inout_ecount_part : nvapi_lite_salstart.h
  • __nvapi_undef__deref_opt_inout_ecount_part_opt : nvapi_lite_salstart.h
  • __nvapi_undef__deref_opt_inout_ecount_z : nvapi_lite_salstart.h
  • __nvapi_undef__deref_opt_inout_ecount_z_opt : nvapi_lite_salstart.h
  • __nvapi_undef__deref_opt_inout_nz : nvapi_lite_salstart.h
  • __nvapi_undef__deref_opt_inout_nz_opt : nvapi_lite_salstart.h
  • __nvapi_undef__deref_opt_inout_opt : nvapi_lite_salstart.h
  • __nvapi_undef__deref_opt_inout_z : nvapi_lite_salstart.h
  • __nvapi_undef__deref_opt_inout_z_opt : nvapi_lite_salstart.h
  • __nvapi_undef__deref_opt_out : nvapi_lite_salstart.h
  • __nvapi_undef__deref_opt_out_bcount : nvapi_lite_salstart.h
  • __nvapi_undef__deref_opt_out_bcount_full : nvapi_lite_salstart.h
  • __nvapi_undef__deref_opt_out_bcount_full_opt : nvapi_lite_salstart.h
  • __nvapi_undef__deref_opt_out_bcount_nz_opt : nvapi_lite_salstart.h
  • __nvapi_undef__deref_opt_out_bcount_opt : nvapi_lite_salstart.h
  • __nvapi_undef__deref_opt_out_bcount_part : nvapi_lite_salstart.h
  • __nvapi_undef__deref_opt_out_bcount_part_opt : nvapi_lite_salstart.h
  • __nvapi_undef__deref_opt_out_bcount_z_opt : nvapi_lite_salstart.h
  • __nvapi_undef__deref_opt_out_ecount : nvapi_lite_salstart.h
  • __nvapi_undef__deref_opt_out_ecount_full : nvapi_lite_salstart.h
  • __nvapi_undef__deref_opt_out_ecount_full_opt : nvapi_lite_salstart.h
  • __nvapi_undef__deref_opt_out_ecount_nz_opt : nvapi_lite_salstart.h
  • __nvapi_undef__deref_opt_out_ecount_opt : nvapi_lite_salstart.h
  • __nvapi_undef__deref_opt_out_ecount_part : nvapi_lite_salstart.h
  • __nvapi_undef__deref_opt_out_ecount_part_opt : nvapi_lite_salstart.h
  • __nvapi_undef__deref_opt_out_ecount_z_opt : nvapi_lite_salstart.h
  • __nvapi_undef__deref_opt_out_nz_opt : nvapi_lite_salstart.h
  • __nvapi_undef__deref_opt_out_opt : nvapi_lite_salstart.h
  • __nvapi_undef__deref_opt_out_z : nvapi_lite_salstart.h
  • __nvapi_undef__deref_opt_out_z_opt : nvapi_lite_salstart.h
  • __nvapi_undef__deref_out : nvapi_lite_salstart.h
  • __nvapi_undef__deref_out_bcount : nvapi_lite_salstart.h
  • __nvapi_undef__deref_out_bcount_full : nvapi_lite_salstart.h
  • __nvapi_undef__deref_out_bcount_full_opt : nvapi_lite_salstart.h
  • __nvapi_undef__deref_out_bcount_nz : nvapi_lite_salstart.h
  • __nvapi_undef__deref_out_bcount_nz_opt : nvapi_lite_salstart.h
  • __nvapi_undef__deref_out_bcount_opt : nvapi_lite_salstart.h
  • __nvapi_undef__deref_out_bcount_part : nvapi_lite_salstart.h
  • __nvapi_undef__deref_out_bcount_part_opt : nvapi_lite_salstart.h
  • __nvapi_undef__deref_out_bcount_z : nvapi_lite_salstart.h
  • __nvapi_undef__deref_out_bcount_z_opt : nvapi_lite_salstart.h
  • __nvapi_undef__deref_out_ecount : nvapi_lite_salstart.h
  • __nvapi_undef__deref_out_ecount_full : nvapi_lite_salstart.h
  • __nvapi_undef__deref_out_ecount_full_opt : nvapi_lite_salstart.h
  • __nvapi_undef__deref_out_ecount_nz : nvapi_lite_salstart.h
  • __nvapi_undef__deref_out_ecount_nz_opt : nvapi_lite_salstart.h
  • __nvapi_undef__deref_out_ecount_opt : nvapi_lite_salstart.h
  • __nvapi_undef__deref_out_ecount_part : nvapi_lite_salstart.h
  • __nvapi_undef__deref_out_ecount_part_opt : nvapi_lite_salstart.h
  • __nvapi_undef__deref_out_ecount_z : nvapi_lite_salstart.h
  • __nvapi_undef__deref_out_ecount_z_opt : nvapi_lite_salstart.h
  • __nvapi_undef__deref_out_nz : nvapi_lite_salstart.h
  • __nvapi_undef__deref_out_nz_opt : nvapi_lite_salstart.h
  • __nvapi_undef__deref_out_opt : nvapi_lite_salstart.h
  • __nvapi_undef__deref_out_z : nvapi_lite_salstart.h
  • __nvapi_undef__deref_out_z_opt : nvapi_lite_salstart.h
  • __nvapi_undef__ecount : nvapi_lite_salstart.h
  • __nvapi_undef__ecount_opt : nvapi_lite_salstart.h
  • __nvapi_undef__in : nvapi_lite_salstart.h
  • __nvapi_undef__in_bcount : nvapi_lite_salstart.h
  • __nvapi_undef__in_bcount_nz : nvapi_lite_salstart.h
  • __nvapi_undef__in_bcount_nz_opt : nvapi_lite_salstart.h
  • __nvapi_undef__in_bcount_opt : nvapi_lite_salstart.h
  • __nvapi_undef__in_bcount_z : nvapi_lite_salstart.h
  • __nvapi_undef__in_bcount_z_opt : nvapi_lite_salstart.h
  • __nvapi_undef__in_ecount : nvapi_lite_salstart.h
  • __nvapi_undef__in_ecount_nz : nvapi_lite_salstart.h
  • __nvapi_undef__in_ecount_nz_opt : nvapi_lite_salstart.h
  • __nvapi_undef__in_ecount_opt : nvapi_lite_salstart.h
  • __nvapi_undef__in_ecount_z : nvapi_lite_salstart.h
  • __nvapi_undef__in_ecount_z_opt : nvapi_lite_salstart.h
  • __nvapi_undef__in_nz : nvapi_lite_salstart.h
  • __nvapi_undef__in_nz_opt : nvapi_lite_salstart.h
  • __nvapi_undef__in_opt : nvapi_lite_salstart.h
  • __nvapi_undef__in_z : nvapi_lite_salstart.h
  • __nvapi_undef__in_z_opt : nvapi_lite_salstart.h
  • __nvapi_undef__inout : nvapi_lite_salstart.h
  • __nvapi_undef__inout_bcount : nvapi_lite_salstart.h
  • __nvapi_undef__inout_bcount_full : nvapi_lite_salstart.h
  • __nvapi_undef__inout_bcount_full_opt : nvapi_lite_salstart.h
  • __nvapi_undef__inout_bcount_nz : nvapi_lite_salstart.h
  • __nvapi_undef__inout_bcount_nz_opt : nvapi_lite_salstart.h
  • __nvapi_undef__inout_bcount_opt : nvapi_lite_salstart.h
  • __nvapi_undef__inout_bcount_part : nvapi_lite_salstart.h
  • __nvapi_undef__inout_bcount_part_opt : nvapi_lite_salstart.h
  • __nvapi_undef__inout_bcount_z : nvapi_lite_salstart.h
  • __nvapi_undef__inout_bcount_z_opt : nvapi_lite_salstart.h
  • __nvapi_undef__inout_ecount : nvapi_lite_salstart.h
  • __nvapi_undef__inout_ecount_full : nvapi_lite_salstart.h
  • __nvapi_undef__inout_ecount_full_opt : nvapi_lite_salstart.h
  • __nvapi_undef__inout_ecount_nz : nvapi_lite_salstart.h
  • __nvapi_undef__inout_ecount_nz_opt : nvapi_lite_salstart.h
  • __nvapi_undef__inout_ecount_opt : nvapi_lite_salstart.h
  • __nvapi_undef__inout_ecount_part : nvapi_lite_salstart.h
  • __nvapi_undef__inout_ecount_part_opt : nvapi_lite_salstart.h
  • __nvapi_undef__inout_ecount_z : nvapi_lite_salstart.h
  • __nvapi_undef__inout_ecount_z_opt : nvapi_lite_salstart.h
  • __nvapi_undef__inout_nz : nvapi_lite_salstart.h
  • __nvapi_undef__inout_nz_opt : nvapi_lite_salstart.h
  • __nvapi_undef__inout_opt : nvapi_lite_salstart.h
  • __nvapi_undef__inout_z : nvapi_lite_salstart.h
  • __nvapi_undef__inout_z_opt : nvapi_lite_salstart.h
  • __nvapi_undef__out : nvapi_lite_salstart.h
  • __nvapi_undef__out_bcount : nvapi_lite_salstart.h
  • __nvapi_undef__out_bcount_full : nvapi_lite_salstart.h
  • __nvapi_undef__out_bcount_full_opt : nvapi_lite_salstart.h
  • __nvapi_undef__out_bcount_full_z : nvapi_lite_salstart.h
  • __nvapi_undef__out_bcount_full_z_opt : nvapi_lite_salstart.h
  • __nvapi_undef__out_bcount_nz : nvapi_lite_salstart.h
  • __nvapi_undef__out_bcount_nz_opt : nvapi_lite_salstart.h
  • __nvapi_undef__out_bcount_opt : nvapi_lite_salstart.h
  • __nvapi_undef__out_bcount_part : nvapi_lite_salstart.h
  • __nvapi_undef__out_bcount_part_opt : nvapi_lite_salstart.h
  • __nvapi_undef__out_bcount_part_z : nvapi_lite_salstart.h
  • __nvapi_undef__out_bcount_part_z_opt : nvapi_lite_salstart.h
  • __nvapi_undef__out_bcount_z : nvapi_lite_salstart.h
  • __nvapi_undef__out_bcount_z_opt : nvapi_lite_salstart.h
  • __nvapi_undef__out_ecount : nvapi_lite_salstart.h
  • __nvapi_undef__out_ecount_full : nvapi_lite_salstart.h
  • __nvapi_undef__out_ecount_full_opt : nvapi_lite_salstart.h
  • __nvapi_undef__out_ecount_full_z : nvapi_lite_salstart.h
  • __nvapi_undef__out_ecount_full_z_opt : nvapi_lite_salstart.h
  • __nvapi_undef__out_ecount_nz : nvapi_lite_salstart.h
  • __nvapi_undef__out_ecount_nz_opt : nvapi_lite_salstart.h
  • __nvapi_undef__out_ecount_opt : nvapi_lite_salstart.h
  • __nvapi_undef__out_ecount_part : nvapi_lite_salstart.h
  • __nvapi_undef__out_ecount_part_opt : nvapi_lite_salstart.h
  • __nvapi_undef__out_ecount_part_z : nvapi_lite_salstart.h
  • __nvapi_undef__out_ecount_part_z_opt : nvapi_lite_salstart.h
  • __nvapi_undef__out_ecount_z : nvapi_lite_salstart.h
  • __nvapi_undef__out_ecount_z_opt : nvapi_lite_salstart.h
  • __nvapi_undef__out_nz : nvapi_lite_salstart.h
  • __nvapi_undef__out_nz_opt : nvapi_lite_salstart.h
  • __nvapi_undef__out_opt : nvapi_lite_salstart.h
  • __nvapi_undef__out_z : nvapi_lite_salstart.h
  • __nvapi_undef__out_z_opt : nvapi_lite_salstart.h
  • __out : nvapi_lite_salstart.h
  • __out_bcount : nvapi_lite_salstart.h
  • __out_bcount_full : nvapi_lite_salstart.h
  • __out_bcount_full_opt : nvapi_lite_salstart.h
  • __out_bcount_full_z : nvapi_lite_salstart.h
  • __out_bcount_full_z_opt : nvapi_lite_salstart.h
  • __out_bcount_nz : nvapi_lite_salstart.h
  • __out_bcount_nz_opt : nvapi_lite_salstart.h
  • __out_bcount_opt : nvapi_lite_salstart.h
  • __out_bcount_part : nvapi_lite_salstart.h
  • __out_bcount_part_opt : nvapi_lite_salstart.h
  • __out_bcount_part_z : nvapi_lite_salstart.h
  • __out_bcount_part_z_opt : nvapi_lite_salstart.h
  • __out_bcount_z : nvapi_lite_salstart.h
  • __out_bcount_z_opt : nvapi_lite_salstart.h
  • __out_ecount : nvapi_lite_salstart.h
  • __out_ecount_full : nvapi_lite_salstart.h
  • __out_ecount_full_opt : nvapi_lite_salstart.h
  • __out_ecount_full_z : nvapi_lite_salstart.h
  • __out_ecount_full_z_opt : nvapi_lite_salstart.h
  • __out_ecount_nz : nvapi_lite_salstart.h
  • __out_ecount_nz_opt : nvapi_lite_salstart.h
  • __out_ecount_opt : nvapi_lite_salstart.h
  • __out_ecount_part : nvapi_lite_salstart.h
  • __out_ecount_part_opt : nvapi_lite_salstart.h
  • __out_ecount_part_z : nvapi_lite_salstart.h
  • __out_ecount_part_z_opt : nvapi_lite_salstart.h
  • __out_ecount_z : nvapi_lite_salstart.h
  • __out_ecount_z_opt : nvapi_lite_salstart.h
  • __out_nz : nvapi_lite_salstart.h
  • __out_nz_opt : nvapi_lite_salstart.h
  • __out_opt : nvapi_lite_salstart.h
  • __out_z : nvapi_lite_salstart.h
  • __out_z_opt : nvapi_lite_salstart.h
  • __success : nvapi_lite_salstart.h
  • _NV_DISPLAYCONFIG_PATH_INFO_V2 : nvapi.h
  • _NV_TARGET_VIEW_MODE_ : nvapi.h
  • _NVAPI_H : nvapi.h
  • _Outptr_ : nvapi_lite_salstart.h
  • _Post_writable_byte_size_ : nvapi_lite_salstart.h
  • _Ret_notnull_ : nvapi_lite_salstart.h


  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • v
  • w
Here is a list of all macros with links to the files they belong to:

- a -

  • AA_BEHAVIOR_FLAGS_STRING : NvApiDriverSettings.h
  • AA_MODE_ALPHATOCOVERAGE_STRING : NvApiDriverSettings.h
  • AA_MODE_GAMMACORRECTION_STRING : NvApiDriverSettings.h
  • AA_MODE_METHOD_STRING : NvApiDriverSettings.h
  • AA_MODE_REPLAY_STRING : NvApiDriverSettings.h
  • AA_MODE_SELECTOR_SLIAA_STRING : NvApiDriverSettings.h
  • AA_MODE_SELECTOR_STRING : NvApiDriverSettings.h
  • ALL_GPUS : nvapi.h
  • ANISO_MODE_LEVEL_STRING : NvApiDriverSettings.h
  • ANISO_MODE_SELECTOR_STRING : NvApiDriverSettings.h
  • ANSEL_ALLOW_STRING : NvApiDriverSettings.h
  • ANSEL_ALLOWLISTED_STRING : NvApiDriverSettings.h
  • ANSEL_ENABLE_STRING : NvApiDriverSettings.h
  • AO_MODE_ACTIVE_STRING : NvApiDriverSettings.h
  • AO_MODE_STRING : NvApiDriverSettings.h
  • APPIDLE_DYNAMIC_FRL_FPS_STRING : NvApiDriverSettings.h
  • APPIDLE_DYNAMIC_FRL_THRESHOLD_TIME_STRING : NvApiDriverSettings.h
  • APPLICATION_PROFILE_NOTIFICATION_TIMEOUT_STRING : NvApiDriverSettings.h
  • APPLICATION_STEAM_ID_STRING : NvApiDriverSettings.h
  • AUTO_LODBIASADJUST_STRING : NvApiDriverSettings.h


  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • v
  • w
Here is a list of all macros with links to the files they belong to:

- b -

  • BATTERY_BOOST_APP_FPS_STRING : NvApiDriverSettings.h


  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • v
  • w
Here is a list of all macros with links to the files they belong to:

- c -

  • compile_time_assert : nvapi.h
  • CPL_HIDDEN_PROFILE_STRING : NvApiDriverSettings.h
  • CUDA_EXCLUDED_GPUS_DEFAULT : NvApiDriverSettings.h
  • CUDA_EXCLUDED_GPUS_NONE : NvApiDriverSettings.h
  • CUDA_EXCLUDED_GPUS_NUM_VALUES : NvApiDriverSettings.h
  • CUDA_EXCLUDED_GPUS_STRING : NvApiDriverSettings.h


  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • v
  • w
Here is a list of all macros with links to the files they belong to:

- d -

  • D3DOGL_GPU_MAX_POWER_DEFAULT : NvApiDriverSettings.h
  • D3DOGL_GPU_MAX_POWER_DEFAULTPOWER : NvApiDriverSettings.h
  • D3DOGL_GPU_MAX_POWER_NUM_VALUES : NvApiDriverSettings.h
  • D3DOGL_GPU_MAX_POWER_STRING : NvApiDriverSettings.h
  • DISPLAYPORT_STRUCTS_DEFINED : nvapi.h


  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • v
  • w
Here is a list of all macros with links to the files they belong to:

- e -

  • EXPORT_PERF_COUNTERS_DX9_ONLY_STRING : NvApiDriverSettings.h
  • EXPORT_PERF_COUNTERS_STRING : NvApiDriverSettings.h
  • EXTERNAL_QUIET_MODE_STRING : NvApiDriverSettings.h


  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • v
  • w
Here is a list of all macros with links to the files they belong to:

- f -

  • FENCE_SYNCHRONIZATION_END : nvapi.h
  • FENCE_SYNCHRONIZATION_START : nvapi.h
  • FRL_FPS_STRING : NvApiDriverSettings.h
  • FXAA_ALLOW_STRING : NvApiDriverSettings.h
  • FXAA_ENABLE_STRING : NvApiDriverSettings.h
  • FXAA_INDICATOR_ENABLE_STRING : NvApiDriverSettings.h


  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • v
  • w
Here is a list of all macros with links to the files they belong to:

- g -

  • GET_NVAPI_SIZE : nvapi_lite_common.h
  • GET_NVAPI_VERSION : nvapi_lite_common.h


  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • v
  • w
Here is a list of all macros with links to the files they belong to:

- i -

  • ICAFE_LOGO_CONFIG_STRING : NvApiDriverSettings.h
  • ID3D11MultiGPUDevice_VER : nvapi.h
  • ID3D11MultiGPUDevice_VER1 : nvapi.h
  • ID3D11MultiGPUDevice_VER2 : nvapi.h
  • ID3D11MultiGPUDevice_VER3 : nvapi.h
  • ID3D11NvMetaCommand_VER : nvapi.h
  • ID3D11NvMetaCommand_VER1 : nvapi.h
  • ID3D11NvShadingRateResourceView_VER : nvapi.h
  • ID3D11NvShadingRateResourceView_VER1 : nvapi.h
  • ID3D12NvMetaCommand_VER : nvapi.h
  • ID3D12NvMetaCommand_VER1 : nvapi.h
  • ID3DLateLatchObject_VER : nvapi.h
  • ID3DLateLatchObject_VER1 : nvapi.h
  • ID3DNvGazeHandler_VER : nvapi.h
  • ID3DNvGazeHandler_VER1 : nvapi.h
  • ID3DNvGazeHandler_VER2 : nvapi.h
  • ID3DNVSMPASSIST_VER : nvapi.h
  • ID3DNVSMPASSIST_VER1 : nvapi.h
  • ID3DNvVRSHelper_VER : nvapi.h
  • ID3DNvVRSHelper_VER1 : nvapi.h


  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • v
  • w
Here is a list of all macros with links to the files they belong to:

- l -

  • LATENCY_INDICATOR_AUTOALIGN_STRING : NvApiDriverSettings.h
  • LODBIASADJUST_STRING : NvApiDriverSettings.h


  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • v
  • w
Here is a list of all macros with links to the files they belong to:

- m -

  • MAKE_NVAPI_VERSION : nvapi_lite_common.h
  • MAX_NUM_COMPOSITE_RANGE : nvapi.h
  • MAX_NUMBER_OF_GAZE_DATA_PROVIDERS : nvapi.h
  • MAXWELL_B_SAMPLE_INTERLEAVE_STRING : NvApiDriverSettings.h
  • MCSFRSHOWSPLIT_STRING : NvApiDriverSettings.h


  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • v
  • w
Here is a list of all macros with links to the files they belong to:

- n -

  • NV_ASYNC_FRAME_MARKER_PARAMS_VER : nvapi.h
  • NV_ASYNC_FRAME_MARKER_PARAMS_VER1 : nvapi.h
  • NV_BIT : nvapi_lite_common.h
  • NV_BOARD_INFO_VER : nvapi.h
  • NV_BOARD_INFO_VER1 : nvapi.h
  • NV_CHIPSET_INFO : nvapi.h
  • NV_CHIPSET_INFO_VER : nvapi.h
  • NV_CHIPSET_INFO_VER_1 : nvapi.h
  • NV_CHIPSET_INFO_VER_2 : nvapi.h
  • NV_CHIPSET_INFO_VER_3 : nvapi.h
  • NV_CHIPSET_INFO_VER_4 : nvapi.h
  • NV_COLOR_DATA_VER : nvapi.h
  • NV_COLOR_DATA_VER1 : nvapi.h
  • NV_COLOR_DATA_VER2 : nvapi.h
  • NV_COLOR_DATA_VER3 : nvapi.h
  • NV_COLOR_DATA_VER4 : nvapi.h
  • NV_COLOR_DATA_VER5 : nvapi.h
  • NV_COMPUTE_GPU_TOPOLOGY_CUDA_AVAILABLE : nvapi.h
  • NV_COMPUTE_GPU_TOPOLOGY_CUDA_CAPABLE : nvapi.h
  • NV_COMPUTE_GPU_TOPOLOGY_CUDA_DISABLED : nvapi.h
  • NV_COMPUTE_GPU_TOPOLOGY_PHYSICS_AVAILABLE : nvapi.h
  • NV_COMPUTE_GPU_TOPOLOGY_PHYSICS_CAPABLE : nvapi.h
  • NV_COMPUTE_GPU_TOPOLOGY_PHYSICS_DEDICATED : nvapi.h
  • NV_COMPUTE_GPU_TOPOLOGY_PHYSICS_ENABLE : nvapi.h
  • NV_COMPUTE_GPU_TOPOLOGY_PHYSICS_RECOMMENDED : nvapi.h
  • NV_COMPUTE_GPU_TOPOLOGY_VER : nvapi.h
  • NV_COMPUTE_GPU_TOPOLOGY_VER1 : nvapi.h
  • NV_CUSTOM_DISPLAY_VER : nvapi.h
  • NV_CUSTOM_SEMANTIC_MAX_LIMIT : nvapi.h
  • NV_CUSTOM_SEMANTIC_VERSION : nvapi.h
  • NV_D3D11_EXCLUSIVE_SCISSOR_RECTS_DESC_VER : nvapi.h
  • NV_D3D11_EXCLUSIVE_SCISSOR_RECTS_DESC_VER1 : nvapi.h
  • NV_D3D11_SHADING_RATE_RESOURCE_VIEW_DESC_VER : nvapi.h
  • NV_D3D11_SHADING_RATE_RESOURCE_VIEW_DESC_VER1 : nvapi.h
  • NV_D3D11_VIEWPORTS_SHADING_RATE_DESC_VER : nvapi.h
  • NV_D3D11_VIEWPORTS_SHADING_RATE_DESC_VER1 : nvapi.h
  • NV_D3D12_GRAPHICS_CAPS_VER : nvapi.h
  • NV_D3D12_GRAPHICS_CAPS_VER1 : nvapi.h
  • NV_D3D12_MOSAIC_GETCOMPANIONALLOCATIONS_VER : nvapi.h
  • NV_D3D12_MOSAIC_GETCOMPANIONALLOCATIONS_VER1 : nvapi.h
  • NV_D3D12_MOSAIC_GETVIEWPORTANDGPUPARTITIONS_VER : nvapi.h
  • NV_D3D12_MOSAIC_GETVIEWPORTANDGPUPARTITIONS_VER1 : nvapi.h
  • NV_D3D1x_GRAPHICS_CAPS_VER : nvapi.h
  • NV_D3D1x_GRAPHICS_CAPS_VER1 : nvapi.h
  • NV_D3D1x_GRAPHICS_CAPS_VER2 : nvapi.h
  • NV_D3D_LATELATCH_OBJECT_DESC_VER : nvapi.h
  • NV_D3D_LATELATCH_OBJECT_DESC_VER1 : nvapi.h
  • NV_DECLARE_HANDLE : nvapi_lite_common.h
  • NV_DISPLAY_DRIVER_INFO_VER : nvapi.h
  • NV_DISPLAY_DRIVER_INFO_VER1 : nvapi.h
  • NV_DISPLAY_DRIVER_INFO_VER2 : nvapi.h
  • NV_DISPLAY_DRIVER_MEMORY_INFO_VER : nvapi_lite_common.h
  • NV_DISPLAY_DRIVER_MEMORY_INFO_VER_1 : nvapi_lite_common.h
  • NV_DISPLAY_DRIVER_MEMORY_INFO_VER_2 : nvapi_lite_common.h
  • NV_DISPLAY_DRIVER_MEMORY_INFO_VER_3 : nvapi_lite_common.h
  • NV_DISPLAY_DRIVER_VERSION_VER : nvapi.h
  • NV_DISPLAY_PATH_INFO_VER : nvapi.h
  • NV_DISPLAY_PATH_INFO_VER1 : nvapi.h
  • NV_DISPLAY_PATH_INFO_VER2 : nvapi.h
  • NV_DISPLAY_PATH_INFO_VER3 : nvapi.h
  • NV_DISPLAY_PATH_INFO_VER4 : nvapi.h
  • NV_DISPLAY_PORT_CONFIG_VER : nvapi.h
  • NV_DISPLAY_PORT_CONFIG_VER_1 : nvapi.h
  • NV_DISPLAY_PORT_CONFIG_VER_2 : nvapi.h
  • NV_DISPLAY_PORT_INFO_VER : nvapi.h
  • NV_DISPLAY_PORT_INFO_VER1 : nvapi.h
  • NV_DISPLAY_PORT_INFO_VER2 : nvapi.h
  • NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_VER : nvapi.h
  • NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_VER1 : nvapi.h
  • NV_DISPLAYCONFIG_PATH_INFO_VER : nvapi.h
  • NV_DISPLAYCONFIG_PATH_INFO_VER1 : nvapi.h
  • NV_DISPLAYCONFIG_PATH_INFO_VER2 : nvapi.h
  • NV_DOMAIN_SHADER_PSO_EXTENSION_DESC_VER : nvapi.h
  • NV_DOMAIN_SHADER_PSO_EXTENSION_DESC_VER_1 : nvapi.h
  • NV_DOMAIN_SHADER_PSO_EXTENSION_DESC_VER_2 : nvapi.h
  • NV_DOMAIN_SHADER_PSO_EXTENSION_DESC_VER_3 : nvapi.h
  • NV_DX_VIDEO_STEREO_INFO_VER : nvapi.h
  • NV_EDID_DATA_SIZE : nvapi.h
  • NV_EDID_DATA_SIZE_MAX : nvapi.h
  • NV_EDID_DATA_VER : nvapi.h
  • NV_EDID_DATA_VER1 : nvapi.h
  • NV_EDID_DATA_VER2 : nvapi.h
  • NV_EDID_V1_DATA_SIZE : nvapi.h
  • NV_EDID_VER : nvapi.h
  • NV_EDID_VER1 : nvapi.h
  • NV_EDID_VER2 : nvapi.h
  • NV_EDID_VER3 : nvapi.h
  • NV_ENABLE_DEPTH_BOUND_TEST_PSO_EXTENSION_DESC_VER : nvapi.h
  • NV_ENABLE_DEPTH_BOUND_TEST_PSO_EXTENSION_DESC_VER_1 : nvapi.h
  • NV_EVENT_REGISTER_CALLBACK_VERSION : nvapi.h
  • NV_EXTN_ATOM_ADD : nvHLSLExtnsInternal.h
  • NV_EXTN_ATOM_AND : nvHLSLExtnsInternal.h
  • NV_EXTN_ATOM_CAS : nvHLSLExtnsInternal.h
  • NV_EXTN_ATOM_MAX : nvHLSLExtnsInternal.h
  • NV_EXTN_ATOM_MIN : nvHLSLExtnsInternal.h
  • NV_EXTN_ATOM_OR : nvHLSLExtnsInternal.h
  • NV_EXTN_ATOM_SWAP : nvHLSLExtnsInternal.h
  • NV_EXTN_ATOM_XOR : nvHLSLExtnsInternal.h
  • NV_EXTN_FOOTPRINT_MODE_COARSE : nvShaderExtnEnums.h
  • NV_EXTN_FOOTPRINT_MODE_FINE : nvShaderExtnEnums.h
  • NV_EXTN_OP_FOOTPRINT : nvShaderExtnEnums.h
  • NV_EXTN_OP_FOOTPRINT_BIAS : nvShaderExtnEnums.h
  • NV_EXTN_OP_FOOTPRINT_GRAD : nvShaderExtnEnums.h
  • NV_EXTN_OP_FOOTPRINT_LEVEL : nvShaderExtnEnums.h
  • NV_EXTN_OP_FP16_ATOMIC : nvShaderExtnEnums.h
  • NV_EXTN_OP_FP32_ATOMIC : nvShaderExtnEnums.h
  • NV_EXTN_OP_GET_LANE_ID : nvShaderExtnEnums.h
  • NV_EXTN_OP_GET_SHADING_RATE : nvShaderExtnEnums.h
  • NV_EXTN_OP_GET_SPECIAL : nvShaderExtnEnums.h
  • NV_EXTN_OP_HIT_OBJECT_GET_ATTRIBUTES : nvShaderExtnEnums.h
  • NV_EXTN_OP_HIT_OBJECT_GET_GEOMETRY_INDEX : nvShaderExtnEnums.h
  • NV_EXTN_OP_HIT_OBJECT_GET_HIT_KIND : nvShaderExtnEnums.h
  • NV_EXTN_OP_HIT_OBJECT_GET_INSTANCE_ID : nvShaderExtnEnums.h
  • NV_EXTN_OP_HIT_OBJECT_GET_INSTANCE_INDEX : nvShaderExtnEnums.h
  • NV_EXTN_OP_HIT_OBJECT_GET_PRIMITIVE_INDEX : nvShaderExtnEnums.h
  • NV_EXTN_OP_HIT_OBJECT_GET_RAY_DESC : nvShaderExtnEnums.h
  • NV_EXTN_OP_HIT_OBJECT_GET_SHADER_TABLE_INDEX : nvShaderExtnEnums.h
  • NV_EXTN_OP_HIT_OBJECT_INVOKE : nvShaderExtnEnums.h
  • NV_EXTN_OP_HIT_OBJECT_IS_HIT : nvShaderExtnEnums.h
  • NV_EXTN_OP_HIT_OBJECT_IS_MISS : nvShaderExtnEnums.h
  • NV_EXTN_OP_HIT_OBJECT_IS_NOP : nvShaderExtnEnums.h
  • NV_EXTN_OP_HIT_OBJECT_LOAD_LOCAL_ROOT_TABLE_CONSTANT : nvShaderExtnEnums.h
  • NV_EXTN_OP_HIT_OBJECT_MAKE_HIT : nvShaderExtnEnums.h
  • NV_EXTN_OP_HIT_OBJECT_MAKE_HIT_WITH_RECORD_INDEX : nvShaderExtnEnums.h
  • NV_EXTN_OP_HIT_OBJECT_MAKE_MISS : nvShaderExtnEnums.h
  • NV_EXTN_OP_HIT_OBJECT_MAKE_NOP : nvShaderExtnEnums.h
  • NV_EXTN_OP_HIT_OBJECT_REORDER_THREAD : nvShaderExtnEnums.h
  • NV_EXTN_OP_HIT_OBJECT_TRACE_RAY : nvShaderExtnEnums.h
  • NV_EXTN_OP_MATCH_ANY : nvShaderExtnEnums.h
  • NV_EXTN_OP_RT_IS_BACK_FACING : nvShaderExtnEnums.h
  • NV_EXTN_OP_RT_IS_MICRO_TRIANGLE_HIT : nvShaderExtnEnums.h
  • NV_EXTN_OP_RT_MICRO_TRIANGLE_BARYCENTRICS : nvShaderExtnEnums.h
  • NV_EXTN_OP_RT_MICRO_TRIANGLE_OBJECT_POSITIONS : nvShaderExtnEnums.h
  • NV_EXTN_OP_RT_MICRO_VERTEX_BARYCENTRICS : nvShaderExtnEnums.h
  • NV_EXTN_OP_RT_MICRO_VERTEX_OBJECT_POSITION : nvShaderExtnEnums.h
  • NV_EXTN_OP_RT_TRIANGLE_OBJECT_POSITIONS : nvShaderExtnEnums.h
  • NV_EXTN_OP_SHFL : nvShaderExtnEnums.h
  • NV_EXTN_OP_SHFL_DOWN : nvShaderExtnEnums.h
  • NV_EXTN_OP_SHFL_GENERIC : nvShaderExtnEnums.h
  • NV_EXTN_OP_SHFL_UP : nvShaderExtnEnums.h
  • NV_EXTN_OP_SHFL_XOR : nvShaderExtnEnums.h
  • NV_EXTN_OP_UINT64_ATOMIC : nvShaderExtnEnums.h
  • NV_EXTN_OP_VOTE_ALL : nvShaderExtnEnums.h
  • NV_EXTN_OP_VOTE_ANY : nvShaderExtnEnums.h
  • NV_EXTN_OP_VOTE_BALLOT : nvShaderExtnEnums.h
  • NV_EXTN_OP_VPRS_EVAL_ATTRIB_AT_SAMPLE : nvShaderExtnEnums.h
  • NV_EXTN_OP_VPRS_EVAL_ATTRIB_SNAPPED : nvShaderExtnEnums.h
  • NV_EXTN_TEXTURE_1D : nvShaderExtnEnums.h
  • NV_EXTN_TEXTURE_1D_ARRAY : nvShaderExtnEnums.h
  • NV_EXTN_TEXTURE_2D : nvShaderExtnEnums.h
  • NV_EXTN_TEXTURE_2D_ARRAY : nvShaderExtnEnums.h
  • NV_EXTN_TEXTURE_3D : nvShaderExtnEnums.h
  • NV_EXTN_TEXTURE_CUBE : nvShaderExtnEnums.h
  • NV_EXTN_TEXTURE_CUBE_ARRAY : nvShaderExtnEnums.h
  • NV_FALSE : nvapi_lite_common.h
  • NV_FAST_GEOMETRY_SHADER_PSO_EXTENSION_VER : nvapi.h
  • NV_FAST_GEOMETRY_SHADER_PSO_EXTENSION_VER_1 : nvapi.h
  • NV_FASTGS_EXPLICIT_PSO_EXTENSION_VER : nvapi.h
  • NV_FASTGS_EXPLICIT_PSO_EXTENSION_VER_1 : nvapi.h
  • NV_FOVEATED_RENDERING_CUSTOM_FOVEATION_PATTERN_PRESET_DESC_VER : nvapi.h
  • NV_FOVEATED_RENDERING_CUSTOM_FOVEATION_PATTERN_PRESET_DESC_VER1 : nvapi.h
  • NV_FOVEATED_RENDERING_CUSTOM_SHADING_RATE_PRESET_DESC_VER : nvapi.h
  • NV_FOVEATED_RENDERING_CUSTOM_SHADING_RATE_PRESET_DESC_VER1 : nvapi.h
  • NV_FOVEATED_RENDERING_DESC_VER : nvapi.h
  • NV_FOVEATED_RENDERING_DESC_VER1 : nvapi.h
  • NV_FOVEATED_RENDERING_GAZE_DATA_PER_EYE_VER : nvapi.h
  • NV_FOVEATED_RENDERING_GAZE_DATA_PER_EYE_VER1 : nvapi.h
  • NV_FOVEATED_RENDERING_UPDATE_GAZE_DATA_PARAMS_VER : nvapi.h
  • NV_FOVEATED_RENDERING_UPDATE_GAZE_DATA_PARAMS_VER1 : nvapi.h
  • NV_GAZE_HANDLER_INIT_PARAMS_VER : nvapi.h
  • NV_GAZE_HANDLER_INIT_PARAMS_VER1 : nvapi.h
  • NV_GAZE_HANDLER_INIT_PARAMS_VER2 : nvapi.h
  • NV_GEOMETRY_SHADER_PSO_EXTENSION_DESC_VER : nvapi.h
  • NV_GEOMETRY_SHADER_PSO_EXTENSION_DESC_VER_5 : nvapi.h
  • NV_GET_ADAPTIVE_SYNC_DATA_VER : nvapi.h
  • NV_GET_ADAPTIVE_SYNC_DATA_VER1 : nvapi.h
  • NV_GET_CURRENT_SLI_STATE : nvapi_lite_sli.h
  • NV_GET_CURRENT_SLI_STATE_VER : nvapi_lite_sli.h
  • NV_GET_CURRENT_SLI_STATE_VER1 : nvapi_lite_sli.h
  • NV_GET_CURRENT_SLI_STATE_VER2 : nvapi_lite_sli.h
  • NV_GET_GPU_VIRTUAL_ADDRESS : nvapi.h
  • NV_GET_GPU_VIRTUAL_ADDRESS_VER : nvapi.h
  • NV_GET_GPU_VIRTUAL_ADDRESS_VER1 : nvapi.h
  • NV_GET_PREFERRED_STEREO_DISPLAY_VER : nvapi.h
  • NV_GET_PREFERRED_STEREO_DISPLAY_VER1 : nvapi.h
  • NV_GET_SLEEP_STATUS_PARAMS_VER : nvapi.h
  • NV_GET_SLEEP_STATUS_PARAMS_VER1 : nvapi.h
  • NV_GET_VIRTUAL_REFRESH_RATE_DATA_VER : nvapi.h
  • NV_GET_VIRTUAL_REFRESH_RATE_DATA_VER1 : nvapi.h
  • NV_GET_VRR_INFO_VER : nvapi.h
  • NV_GET_VRR_INFO_VER1 : nvapi.h
  • NV_GPU_ARCH_INFO_VER : nvapi.h
  • NV_GPU_ARCH_INFO_VER_1 : nvapi.h
  • NV_GPU_ARCH_INFO_VER_2 : nvapi.h
  • NV_GPU_CLIENT_ILLUM_CTRL_MODE_PIECEWISE_LINEAR_COLOR_ENDPOINTS : nvapi.h
  • NV_GPU_CLIENT_ILLUM_DEVICE_CONTROL_PARAMS_VER : nvapi.h
  • NV_GPU_CLIENT_ILLUM_DEVICE_CONTROL_PARAMS_VER_1 : nvapi.h
  • NV_GPU_CLIENT_ILLUM_DEVICE_INFO_PARAMS_VER : nvapi.h
  • NV_GPU_CLIENT_ILLUM_DEVICE_INFO_PARAMS_VER_1 : nvapi.h
  • NV_GPU_CLIENT_ILLUM_DEVICE_NUM_DEVICES_MAX : nvapi.h
  • NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_PARAMS_VER : nvapi.h
  • NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_PARAMS_VER_1 : nvapi.h
  • NV_GPU_CLIENT_ILLUM_ZONE_INFO_PARAMS_VER : nvapi.h
  • NV_GPU_CLIENT_ILLUM_ZONE_INFO_PARAMS_VER_1 : nvapi.h
  • NV_GPU_CLIENT_ILLUM_ZONE_NUM_ZONES_MAX : nvapi.h
  • NV_GPU_CLIENT_UTIL_DOMAINS_MAX_V1 : nvapi.h
  • NV_GPU_CLIENT_UTILIZATION_PERIODIC_CALLBACK_SETTINGS_VER : nvapi.h
  • NV_GPU_CLIENT_UTILIZATION_PERIODIC_CALLBACK_SETTINGS_VER1 : nvapi.h
  • NV_GPU_CLOCK_FREQUENCIES_VER : nvapi.h
  • NV_GPU_CLOCK_FREQUENCIES_VER_1 : nvapi.h
  • NV_GPU_CLOCK_FREQUENCIES_VER_2 : nvapi.h
  • NV_GPU_CLOCK_FREQUENCIES_VER_3 : nvapi.h
  • NV_GPU_CONNECTED_IDS_FLAG_EXCLUDE_MST : nvapi.h
  • NV_GPU_CONNECTED_IDS_FLAG_FAKE : nvapi.h
  • NV_GPU_CONNECTED_IDS_FLAG_LIDSTATE : nvapi.h
  • NV_GPU_CONNECTED_IDS_FLAG_SLI : nvapi.h
  • NV_GPU_CONNECTED_IDS_FLAG_UNCACHED : nvapi.h
  • NV_GPU_DISPLAYIDS_VER : nvapi.h
  • NV_GPU_DISPLAYIDS_VER1 : nvapi.h
  • NV_GPU_DISPLAYIDS_VER2 : nvapi.h
  • NV_GPU_DYNAMIC_PSTATES_INFO_EX_VER : nvapi.h
  • NV_GPU_ECC_CONFIGURATION_INFO_VER : nvapi.h
  • NV_GPU_ECC_ERROR_INFO_VER : nvapi.h
  • NV_GPU_ECC_STATUS_INFO_VER : nvapi.h
  • NV_GPU_GET_HDCP_SUPPORT_STATUS_VER : nvapi.h
  • NV_GPU_GET_ILLUMINATION_PARM_VER : nvapi.h
  • NV_GPU_GET_ILLUMINATION_PARM_VER_1 : nvapi.h
  • NV_GPU_GSP_INFO_VER : nvapi.h
  • NV_GPU_GSP_INFO_VER1 : nvapi.h
  • NV_GPU_INFO_VER : nvapi.h
  • NV_GPU_INFO_VER1 : nvapi.h
  • NV_GPU_INFO_VER2 : nvapi.h
  • NV_GPU_MAX_CLOCK_FREQUENCIES : nvapi.h
  • NV_GPU_MEMORY_INFO_EX_VER : nvapi_lite_common.h
  • NV_GPU_MEMORY_INFO_EX_VER_1 : nvapi_lite_common.h
  • NV_GPU_PERF_PSTATES20_INFO_VER : nvapi.h
  • NV_GPU_PERF_PSTATES20_INFO_VER1 : nvapi.h
  • NV_GPU_PERF_PSTATES20_INFO_VER2 : nvapi.h
  • NV_GPU_PERF_PSTATES20_INFO_VER3 : nvapi.h
  • NV_GPU_PERF_PSTATES_INFO_VER : nvapi.h
  • NV_GPU_PERF_PSTATES_INFO_VER1 : nvapi.h
  • NV_GPU_PERF_PSTATES_INFO_VER2 : nvapi.h
  • NV_GPU_PERF_PSTATES_INFO_VER3 : nvapi.h
  • NV_GPU_QUERY_ILLUMINATION_SUPPORT_PARM_VER : nvapi.h
  • NV_GPU_QUERY_ILLUMINATION_SUPPORT_PARM_VER_1 : nvapi.h
  • NV_GPU_SET_ILLUMINATION_PARM_VER : nvapi.h
  • NV_GPU_SET_ILLUMINATION_PARM_VER_1 : nvapi.h
  • NV_GPU_THERMAL_SETTINGS_VER : nvapi.h
  • NV_GPU_THERMAL_SETTINGS_VER_1 : nvapi.h
  • NV_GPU_THERMAL_SETTINGS_VER_2 : nvapi.h
  • NV_GPU_VIRTUALIZATION_INFO_VER : nvapi.h
  • NV_GPU_VIRTUALIZATION_INFO_VER1 : nvapi.h
  • NV_GPU_VR_READY_VER : nvapi.h
  • NV_GPU_VR_READY_VER1 : nvapi.h
  • NV_GSYNC_CAPABILITIES_VER : nvapi.h
  • NV_GSYNC_CAPABILITIES_VER1 : nvapi.h
  • NV_GSYNC_CAPABILITIES_VER2 : nvapi.h
  • NV_GSYNC_CAPABILITIES_VER3 : nvapi.h
  • NV_GSYNC_CONTROL_PARAMS_VER : nvapi.h
  • NV_GSYNC_CONTROL_PARAMS_VER1 : nvapi.h
  • NV_GSYNC_CONTROL_PARAMS_VER2 : nvapi.h
  • NV_GSYNC_DELAY_VER : nvapi.h
  • NV_GSYNC_DISPLAY_VER : nvapi.h
  • NV_GSYNC_GPU_VER : nvapi.h
  • NV_GSYNC_STATUS_PARAMS_VER : nvapi.h
  • NV_GSYNC_STATUS_PARAMS_VER1 : nvapi.h
  • NV_GSYNC_STATUS_PARAMS_VER2 : nvapi.h
  • NV_GSYNC_STATUS_VER : nvapi.h
  • NV_HDMI_SUPPORT_INFO_VER : nvapi.h
  • NV_HDMI_SUPPORT_INFO_VER1 : nvapi.h
  • NV_HDMI_SUPPORT_INFO_VER2 : nvapi.h
  • NV_HDR_CAPABILITIES_VER : nvapi.h
  • NV_HDR_CAPABILITIES_VER1 : nvapi.h
  • NV_HDR_CAPABILITIES_VER2 : nvapi.h
  • NV_HDR_CAPABILITIES_VER3 : nvapi.h
  • NV_HDR_COLOR_DATA_VER : nvapi.h
  • NV_HDR_COLOR_DATA_VER1 : nvapi.h
  • NV_HDR_COLOR_DATA_VER2 : nvapi.h
  • NV_HDR_METADATA_VER : nvapi.h
  • NV_HDR_METADATA_VER1 : nvapi.h
  • NV_HEAP_PARAMS_VER : nvapi.h
  • NV_HEAP_PARAMS_VER_1 : nvapi.h
  • NV_HULL_SHADER_PSO_EXTENSION_DESC_VER : nvapi.h
  • NV_HULL_SHADER_PSO_EXTENSION_DESC_VER_1 : nvapi.h
  • NV_HULL_SHADER_PSO_EXTENSION_DESC_VER_2 : nvapi.h
  • NV_I2C_INFO_VER : nvapi.h
  • NV_I2C_INFO_VER1 : nvapi.h
  • NV_I2C_INFO_VER2 : nvapi.h
  • NV_I2C_INFO_VER3 : nvapi.h
  • NV_INFOFRAME_DATA_VER : nvapi.h
  • NV_JOIN_PRESENT_BARRIER_PARAMS_VER1 : nvapi.h
  • NV_LATENCY_MARKER_PARAMS_VER : nvapi.h
  • NV_LATENCY_MARKER_PARAMS_VER1 : nvapi.h
  • NV_LATENCY_RESULT_PARAMS_VER : nvapi.h
  • NV_LATENCY_RESULT_PARAMS_VER1 : nvapi.h
  • NV_LICENSABLE_FEATURES_VER : nvapi.h
  • NV_LICENSABLE_FEATURES_VER1 : nvapi.h
  • NV_LICENSABLE_FEATURES_VER2 : nvapi.h
  • NV_LICENSABLE_FEATURES_VER3 : nvapi.h
  • NV_LICENSABLE_FEATURES_VER4 : nvapi.h
  • NV_LICENSE_FEATURE_DETAILS_VER : nvapi.h
  • NV_LICENSE_FEATURE_DETAILS_VER1 : nvapi.h
  • NV_LICENSE_INFO_MAX_LENGTH : nvapi.h
  • NV_LICENSE_MAX_COUNT : nvapi.h
  • NV_LICENSE_SIGNATURE_SIZE : nvapi.h
  • NV_LID_DOCK_PARAMS_VER : nvapi.h
  • NV_LOGICAL_GPU_DATA_VER : nvapi.h
  • NV_LOGICAL_GPU_DATA_VER1 : nvapi.h
  • NV_LOGICAL_GPUS_VER : nvapi.h
  • NV_LOGICAL_GPUS_VER1 : nvapi.h
  • NV_MANAGED_DEDICATED_DISPLAY_INFO_VER : nvapi.h
  • NV_MANAGED_DEDICATED_DISPLAY_INFO_VER1 : nvapi.h
  • NV_MANAGED_DEDICATED_DISPLAY_METADATA_VER : nvapi.h
  • NV_MANAGED_DEDICATED_DISPLAY_METADATA_VER1 : nvapi.h
  • NV_MAX_HEADS : nvapi_lite_common.h
  • NV_MAX_NUM_EXCLUSIVE_SCISSOR_RECTS : nvapi.h
  • NV_MAX_NUM_VIEWPORTS : nvapi.h
  • NV_MAX_PIXEL_SHADING_RATES : nvapi.h
  • NV_MAX_VID_PROFILES : nvapi_lite_common.h
  • NV_MAX_VID_STREAMS : nvapi_lite_common.h
  • NV_MAX_VID_STREAMS_EX : nvapi_lite_common.h
  • NV_META_COMMAND_ACTIVATION_MAX_PARAMS : nvapi.h
  • NV_META_COMMAND_MAX_TENSOR_DIM : nvapi.h
  • NV_META_COMMAND_NUM_SPATIAL_DIM : nvapi.h
  • NV_MODIFIED_W_MAX_VIEWPORTS : nvapi.h
  • NV_MODIFIED_W_PARAMS_VER : nvapi.h
  • NV_MODIFIED_W_PARAMS_VER1 : nvapi.h
  • NV_MONITOR_CAPABILITIES_VER : nvapi.h
  • NV_MONITOR_CAPABILITIES_VER1 : nvapi.h
  • NV_MONITOR_COLOR_CAPS_VER : nvapi.h
  • NV_MONITOR_COLOR_CAPS_VER1 : nvapi.h
  • NV_MOSAIC_DISPLAY_SETTINGS_MAX : nvapi.h
  • NV_MOSAIC_DISPLAY_TOPO_STATUS_VER : nvapi.h
  • NV_MOSAIC_DISPLAYCAPS_PROBLEM_DISPLAY_ON_INVALID_GPU : nvapi.h
  • NV_MOSAIC_DISPLAYCAPS_PROBLEM_DISPLAY_ON_WRONG_CONNECTOR : nvapi.h
  • NV_MOSAIC_DISPLAYCAPS_PROBLEM_ECC_ENABLED : nvapi.h
  • NV_MOSAIC_DISPLAYCAPS_PROBLEM_GPU_TOPOLOGY_NOT_SUPPORTED : nvapi.h
  • NV_MOSAIC_DISPLAYCAPS_PROBLEM_MISMATCHED_OUTPUT_TYPE : nvapi.h
  • NV_MOSAIC_DISPLAYCAPS_PROBLEM_NO_COMMON_TIMINGS : nvapi.h
  • NV_MOSAIC_DISPLAYCAPS_PROBLEM_NO_DISPLAY_CONNECTED : nvapi.h
  • NV_MOSAIC_DISPLAYCAPS_PROBLEM_NO_EDID_AVAILABLE : nvapi.h
  • NV_MOSAIC_DISPLAYCAPS_PROBLEM_NO_GPU_TOPOLOGY : nvapi.h
  • NV_MOSAIC_DISPLAYCAPS_PROBLEM_NO_SLI_BRIDGE : nvapi.h
  • NV_MOSAIC_DISPLAYCAPS_PROBLEM_NOT_SUPPORTED : nvapi.h
  • NV_MOSAIC_DISPLAYTOPO_WARNING_DISPLAY_POSITION : nvapi.h
  • NV_MOSAIC_DISPLAYTOPO_WARNING_DRIVER_RELOAD_REQUIRED : nvapi.h
  • NV_MOSAIC_GRID_TOPO_VER : nvapi.h
  • NV_MOSAIC_GRID_TOPO_VER1 : nvapi.h
  • NV_MOSAIC_GRID_TOPO_VER2 : nvapi.h
  • NV_MOSAIC_MAX_DISPLAYS : nvapi_lite_surround.h
  • NV_MOSAIC_MAX_TOPO_PER_TOPO_GROUP : nvapi.h
  • NV_MOSAIC_SETDISPLAYTOPO_FLAG_ALLOW_INVALID : nvapi.h
  • NV_MOSAIC_SETDISPLAYTOPO_FLAG_CURRENT_GPU_TOPOLOGY : nvapi.h
  • NV_MOSAIC_SETDISPLAYTOPO_FLAG_MAXIMIZE_PERFORMANCE : nvapi.h
  • NV_MOSAIC_SETDISPLAYTOPO_FLAG_NO_DRIVER_RELOAD : nvapi.h
  • NV_MOSAIC_TOPO_IDX_DEFAULT : nvapi.h
  • NV_MOSAIC_TOPO_IDX_LEFT_EYE : nvapi.h
  • NV_MOSAIC_TOPO_IDX_RIGHT_EYE : nvapi.h
  • NV_MOSAIC_TOPO_NUM_EYES : nvapi.h
  • NV_MOSAIC_TOPO_VALIDITY_MISSING_DISPLAY : nvapi.h
  • NV_MOSAIC_TOPO_VALIDITY_MISSING_GPU : nvapi.h
  • NV_MOSAIC_TOPO_VALIDITY_MIXED_DISPLAY_TYPES : nvapi.h
  • NV_MOSAIC_TOPO_VALIDITY_VALID : nvapi.h
  • NV_MULTIGPU_CAPS_VER : nvapi.h
  • NV_MULTIGPU_CAPS_VER1 : nvapi.h
  • NV_MULTIGPU_CAPS_VER2 : nvapi.h
  • NV_MULTIVIEW_MAX_SUPPORTED_VIEWS : nvapi.h
  • NV_MULTIVIEW_PARAMS_VER : nvapi.h
  • NV_MULTIVIEW_PARAMS_VER1 : nvapi.h
  • NV_PHYSICAL_GPUS_VER : nvapi.h
  • NV_PHYSICAL_GPUS_VER1 : nvapi.h
  • NV_PIXEL_SHADING_RATE_SAMPLE_ORDER_TABLE_VER : nvapi.h
  • NV_PIXEL_SHADING_RATE_SAMPLE_ORDER_TABLE_VER1 : nvapi.h
  • NV_PRESENT_BARRIER_FRAME_STATICS_VER1 : nvapi.h
  • NV_PSO_EXTENSION_DESC_VER : nvapi.h
  • NV_PSO_EXTENSION_DESC_VER_1 : nvapi.h
  • NV_QUALITY_UPSCALING_STRING : NvApiDriverSettings.h
  • NV_QUERY_LATELATCH_SUPPORT_PARAMS_VER : nvapi.h
  • NV_QUERY_LATELATCH_SUPPORT_PARAMS_VER1 : nvapi.h
  • NV_QUERY_MODIFIED_W_SUPPORT_PARAMS_VER : nvapi.h
  • NV_QUERY_MODIFIED_W_SUPPORT_PARAMS_VER1 : nvapi.h
  • NV_QUERY_MULTIVIEW_SUPPORT_PARAMS_VER : nvapi.h
  • NV_QUERY_MULTIVIEW_SUPPORT_PARAMS_VER1 : nvapi.h
  • NV_QUERY_SINGLE_PASS_STEREO_SUPPORT_PARAMS_VER : nvapi.h
  • NV_QUERY_SINGLE_PASS_STEREO_SUPPORT_PARAMS_VER1 : nvapi.h
  • NV_QUERY_SINGLE_PASS_STEREO_SUPPORT_PARAMS_VER2 : nvapi.h
  • NV_QUERY_SMP_ASSIST_SUPPORT_PARAMS_VER : nvapi.h
  • NV_QUERY_SMP_ASSIST_SUPPORT_PARAMS_VER1 : nvapi.h
  • NV_RASTERIZER_PSO_EXTENSION_DESC_VER : nvapi.h
  • NV_RASTERIZER_PSO_EXTENSION_DESC_VER_1 : nvapi.h
  • NV_RASTERIZER_PSO_EXTENSION_DESC_VER_2 : nvapi.h
  • NV_RESOURCE_PARAMS_VER : nvapi.h
  • NV_RESOURCE_PARAMS_VER_1 : nvapi.h
  • NV_SCANOUT_INFORMATION_VER : nvapi.h
  • NV_SCANOUT_INTENSITY_DATA_VER : nvapi.h
  • NV_SCANOUT_INTENSITY_DATA_VER1 : nvapi.h
  • NV_SCANOUT_INTENSITY_DATA_VER2 : nvapi.h
  • NV_SCANOUT_INTENSITY_STATE_VER : nvapi.h
  • NV_SCANOUT_WARPING_STATE_VER : nvapi.h
  • NV_SCANOUT_WARPING_VER : nvapi.h
  • NV_SET_ADAPTIVE_SYNC_DATA_VER : nvapi.h
  • NV_SET_ADAPTIVE_SYNC_DATA_VER1 : nvapi.h
  • NV_SET_PREFERRED_STEREO_DISPLAY_VER : nvapi.h
  • NV_SET_PREFERRED_STEREO_DISPLAY_VER1 : nvapi.h
  • NV_SET_REFLEX_SYNC_PARAMS_VER : nvapi.h
  • NV_SET_REFLEX_SYNC_PARAMS_VER1 : nvapi.h
  • NV_SET_SHADER_EXTENSION_SLOT_DESC_VER : nvapi.h
  • NV_SET_SHADER_EXTENSION_SLOT_DESC_VER_1 : nvapi.h
  • NV_SET_SLEEP_MODE_PARAMS_VER : nvapi.h
  • NV_SET_SLEEP_MODE_PARAMS_VER1 : nvapi.h
  • NV_SET_VIRTUAL_REFRESH_RATE_DATA_VER : nvapi.h
  • NV_SET_VIRTUAL_REFRESH_RATE_DATA_VER1 : nvapi.h
  • NV_SHADER_EXTN_VERSION : nvShaderExtnEnums.h
  • NV_SMP_ASSIST_DISABLE_PARAMS_VER : nvapi.h
  • NV_SMP_ASSIST_DISABLE_PARAMS_VER1 : nvapi.h
  • NV_SMP_ASSIST_ENABLE_PARAMS_VER : nvapi.h
  • NV_SMP_ASSIST_ENABLE_PARAMS_VER1 : nvapi.h
  • NV_SMP_ASSIST_FLAGS_DEFAULT : nvapi.h
  • NV_SMP_ASSIST_GET_CONSTANTS_VER : nvapi.h
  • NV_SMP_ASSIST_GET_CONSTANTS_VER3 : nvapi.h
  • NV_SMP_ASSIST_INITIALIZE_PARAMS_VER : nvapi.h
  • NV_SMP_ASSIST_INITIALIZE_PARAMS_VER1 : nvapi.h
  • NV_SMP_ASSIST_MAX_VIEWPORTS : nvapi.h
  • NV_SMP_ASSIST_MINIMAL_LEVEL_NUM_EYE_INDICES : nvapi.h
  • NV_SMP_ASSIST_SETUP_PARAMS_VER : nvapi.h
  • NV_SMP_ASSIST_SETUP_PARAMS_VER1 : nvapi.h
  • NV_SMP_ASSIST_UPDATE_INSTANCEDSTEREO_DATA_PARAMS_VER : nvapi.h
  • NV_SMP_ASSIST_UPDATE_INSTANCEDSTEREO_DATA_PARAMS_VER1 : nvapi.h
  • NV_SOURCE_PID_CURRENT : nvapi.h
  • NV_SPECIALOP_FOOTPRINT_SINGLELOD_PRED : nvShaderExtnEnums.h
  • NV_SPECIALOP_GLOBAL_TIMER_HI : nvShaderExtnEnums.h
  • NV_SPECIALOP_GLOBAL_TIMER_LO : nvShaderExtnEnums.h
  • NV_SPECIALOP_THREADLTMASK : nvShaderExtnEnums.h
  • NV_STEREO_VIDEO_FORMAT_DEFINE : nvapi.h
  • NV_TIMING_H_SYNC_DEFAULT : nvapi.h
  • NV_TIMING_H_SYNC_NEGATIVE : nvapi.h
  • NV_TIMING_H_SYNC_POSITIVE : nvapi.h
  • NV_TIMING_INPUT_VER : nvapi.h
  • NV_TIMING_INTERLACED : nvapi.h
  • NV_TIMING_INTERLACED_EXTRA_VBLANK_ON_FIELD2 : nvapi.h
  • NV_TIMING_INTERLACED_NO_EXTRA_VBLANK_ON_FIELD2 : nvapi.h
  • NV_TIMING_PROGRESSIVE : nvapi.h
  • NV_TIMING_STRUCTS_DEFINED : nvapi.h
  • NV_TIMING_V_SYNC_DEFAULT : nvapi.h
  • NV_TIMING_V_SYNC_NEGATIVE : nvapi.h
  • NV_TIMING_V_SYNC_POSITIVE : nvapi.h
  • NV_TRUE : nvapi_lite_common.h
  • NV_VARIABLE_PIXEL_SHADING_TILE_HEIGHT : nvapi.h
  • NV_VARIABLE_PIXEL_SHADING_TILE_WIDTH : nvapi.h
  • NV_VERTEX_SHADER_PSO_EXTENSION_DESC_VER : nvapi.h
  • NV_VERTEX_SHADER_PSO_EXTENSION_DESC_VER_1 : nvapi.h
  • NV_VERTEX_SHADER_PSO_EXTENSION_DESC_VER_2 : nvapi.h
  • NV_VERTEX_SHADER_PSO_EXTENSION_DESC_VER_3 : nvapi.h
  • NV_VIEW_TARGET_INFO_VER : nvapi.h
  • NV_VIO_TOPOLOGY_VER : nvapi.h
  • NV_VRS_HELPER_DISABLE_PARAMS_VER : nvapi.h
  • NV_VRS_HELPER_DISABLE_PARAMS_VER1 : nvapi.h
  • NV_VRS_HELPER_ENABLE_PARAMS_VER : nvapi.h
  • NV_VRS_HELPER_ENABLE_PARAMS_VER1 : nvapi.h
  • NV_VRS_HELPER_GET_SHADING_RATE_RESOURCE_PARAMS_VER : nvapi.h
  • NV_VRS_HELPER_GET_SHADING_RATE_RESOURCE_PARAMS_VER1 : nvapi.h
  • NV_VRS_HELPER_INIT_PARAMS_VER : nvapi.h
  • NV_VRS_HELPER_INIT_PARAMS_VER1 : nvapi.h
  • NV_VRS_HELPER_LATCH_GAZE_PARAMS_VER : nvapi.h
  • NV_VRS_HELPER_LATCH_GAZE_PARAMS_VER1 : nvapi.h
  • NV_VRS_HELPER_PURGE_INTERNAL_RESOURCES_PARAMS_VER : nvapi.h
  • NV_VRS_HELPER_PURGE_INTERNAL_RESOURCES_PARAMS_VER1 : nvapi.h
  • NV_WARP_SIZE : nvShaderExtnEnums.h
  • NV_WARP_SIZE_LOG2 : nvShaderExtnEnums.h
  • NVAPI_ADVANCED_DISPLAY_HEADS : nvapi_lite_common.h
  • NVAPI_ADVANCED_MAX_DISPLAY_PATH : nvapi.h
  • NVAPI_ADVANCED_MAX_VIEW_TARGET : nvapi.h
  • NVAPI_ALL_GPUS : nvapi.h
  • NVAPI_ANSEL_CONFIGURATION_STRUCT_VER : nvapi.h
  • NVAPI_ANSEL_CONFIGURATION_STRUCT_VER1 : nvapi.h
  • NVAPI_API_NOT_INTIALIZED : nvapi.h
  • NVAPI_BINARY_DATA_MAX : nvapi.h
  • NVAPI_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_EX_PARAMS_VER : nvapi.h
  • NVAPI_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_EX_PARAMS_VER1 : nvapi.h
  • NVAPI_BUILD_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PARAMS_VER : nvapi.h
  • NVAPI_BUILD_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PARAMS_VER1 : nvapi.h
  • NVAPI_BUILD_RAYTRACING_OPACITY_MICROMAP_ARRAY_PARAMS_VER : nvapi.h
  • NVAPI_BUILD_RAYTRACING_OPACITY_MICROMAP_ARRAY_PARAMS_VER1 : nvapi.h
  • NVAPI_CHECK_DRIVER_MATCHING_IDENTIFIER_EX_PARAMS_VER : nvapi.h
  • NVAPI_CHECK_DRIVER_MATCHING_IDENTIFIER_EX_PARAMS_VER1 : nvapi.h
  • NVAPI_COPY_ASYNCHRONOUSLY : nvapi.h
  • NVAPI_COPY_P2P_READ : nvapi.h
  • NVAPI_CPU_RESOURCE : nvapi.h
  • NVAPI_D3D11_CREATEDOMAINSHADEREX_VER_1 : nvapi.h
  • NVAPI_D3D11_CREATEDOMAINSHADEREX_VER_2 : nvapi.h
  • NVAPI_D3D11_CREATEDOMAINSHADEREX_VER_3 : nvapi.h
  • NVAPI_D3D11_CREATEDOMAINSHADEREX_VERSION : nvapi.h
  • NVAPI_D3D11_CREATEFASTGSEXPLICIT_VER : nvapi.h
  • NVAPI_D3D11_CREATEFASTGSEXPLICIT_VER1 : nvapi.h
  • NVAPI_D3D11_CREATEGEOMETRYSHADEREX_2_VER_5 : nvapi.h
  • NVAPI_D3D11_CREATEGEOMETRYSHADEREX_2_VERSION : nvapi.h
  • NVAPI_D3D11_CREATEHULLSHADEREX_VER_1 : nvapi.h
  • NVAPI_D3D11_CREATEHULLSHADEREX_VER_2 : nvapi.h
  • NVAPI_D3D11_CREATEHULLSHADEREX_VERSION : nvapi.h
  • NVAPI_D3D11_CREATEPIXELSHADEREX_VER_1 : nvapi.h
  • NVAPI_D3D11_CREATEPIXELSHADEREX_VER_2 : nvapi.h
  • NVAPI_D3D11_CREATEPIXELSHADEREX_VERSION : nvapi.h
  • NVAPI_D3D11_CREATEVERTEXSHADEREX_VER_1 : nvapi.h
  • NVAPI_D3D11_CREATEVERTEXSHADEREX_VER_2 : nvapi.h
  • NVAPI_D3D11_CREATEVERTEXSHADEREX_VER_3 : nvapi.h
  • NVAPI_D3D11_CREATEVERTEXSHADEREX_VERSION : nvapi.h
  • NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_BYTE_ALIGNMENT : nvapi.h
  • NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_DC1_MAX_SUBDIVISION_LEVEL : nvapi.h
  • NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_ARRAY_BYTE_ALIGNMENT : nvapi.h
  • NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_OC1_MAX_SUBDIVISION_LEVEL : nvapi.h
  • NVAPI_D3D12_SET_CREATE_PIPELINE_STATE_OPTIONS_PARAMS_VER : nvapi.h
  • NVAPI_D3D12_SET_CREATE_PIPELINE_STATE_OPTIONS_PARAMS_VER1 : nvapi.h
  • NVAPI_D3D12_WORKSTATION_FEATURE_PROPERTIES_PARAMS : nvapi.h
  • NVAPI_D3D12_WORKSTATION_FEATURE_PROPERTIES_PARAMS_VER : nvapi.h
  • NVAPI_D3D12_WORKSTATION_FEATURE_PROPERTIES_PARAMS_VER1 : nvapi.h
  • NVAPI_DEFAULT_HANDLE : nvapi_lite_common.h
  • NVAPI_DISPLAY_DEVICE_MASK_MAX : nvapi.h
  • NVAPI_DRS_GLOBAL_PROFILE : nvapi.h
  • NVAPI_EMIT_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_POSTBUILD_INFO_PARAMS_VER : nvapi.h
  • NVAPI_EMIT_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_POSTBUILD_INFO_PARAMS_VER1 : nvapi.h
  • NVAPI_EMIT_RAYTRACING_OPACITY_MICROMAP_ARRAY_POSTBUILD_INFO_PARAMS_VER : nvapi.h
  • NVAPI_EMIT_RAYTRACING_OPACITY_MICROMAP_ARRAY_POSTBUILD_INFO_PARAMS_VER1 : nvapi.h
  • NVAPI_GENERIC_STRING_MAX : nvapi_lite_common.h
  • NVAPI_GET_RAYTRACING_ACCELERATION_STRUCTURE_PREBUILD_INFO_EX_PARAMS_VER : nvapi.h
  • NVAPI_GET_RAYTRACING_ACCELERATION_STRUCTURE_PREBUILD_INFO_EX_PARAMS_VER1 : nvapi.h
  • NVAPI_GET_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PREBUILD_INFO_PARAMS_VER : nvapi.h
  • NVAPI_GET_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PREBUILD_INFO_PARAMS_VER1 : nvapi.h
  • NVAPI_GET_RAYTRACING_OPACITY_MICROMAP_ARRAY_PREBUILD_INFO_PARAMS_VER : nvapi.h
  • NVAPI_GET_RAYTRACING_OPACITY_MICROMAP_ARRAY_PREBUILD_INFO_PARAMS_VER1 : nvapi.h
  • NVAPI_GPU_MAX_BUILD_VERSION_LENGTH : nvapi.h
  • NVAPI_GSYNC_BOARD_ID_P2060 : nvapi.h
  • NVAPI_GSYNC_BOARD_ID_P2061 : nvapi.h
  • NVAPI_GSYNC_BOARD_ID_P358 : nvapi.h
  • NVAPI_GVI_DEFAULT_RAW_CAPTURE_IMAGES : nvapi.h
  • NVAPI_GVI_MAX_RAW_CAPTURE_IMAGES : nvapi.h
  • NVAPI_GVI_MIN_RAW_CAPTURE_IMAGES : nvapi.h
  • NVAPI_I2C_SPEED_DEPRECATED : nvapi.h
  • NVAPI_INTERFACE : nvapi_lite_salstart.h
  • NVAPI_LONG_STRING_MAX : nvapi_lite_common.h
  • NVAPI_MAX_ACPI_IDS : nvapi_lite_common.h
  • NVAPI_MAX_AUDIO_DEVICES : nvapi_lite_common.h
  • NVAPI_MAX_AVAILABLE_GPU_TOPOLOGIES : nvapi_lite_common.h
  • NVAPI_MAX_AVAILABLE_SLI_GROUPS : nvapi_lite_common.h
  • NVAPI_MAX_DISPLAY_HEADS : nvapi_lite_common.h
  • NVAPI_MAX_DISPLAY_PATH : nvapi.h
  • NVAPI_MAX_DISPLAYS : nvapi_lite_common.h
  • NVAPI_MAX_FRAMELOCK_MAPPING_MODES : nvapi.h
  • NVAPI_MAX_GPU_CLOCKS : nvapi.h
  • NVAPI_MAX_GPU_PER_TOPOLOGY : nvapi_lite_common.h
  • NVAPI_MAX_GPU_PERF_CLOCKS : nvapi.h
  • NVAPI_MAX_GPU_PERF_PSTATES : nvapi.h
  • NVAPI_MAX_GPU_PERF_VOLTAGES : nvapi.h
  • NVAPI_MAX_GPU_PSTATE20_BASE_VOLTAGES : nvapi.h
  • NVAPI_MAX_GPU_PSTATE20_CLOCKS : nvapi.h
  • NVAPI_MAX_GPU_PSTATE20_PSTATES : nvapi.h
  • NVAPI_MAX_GPU_PUBLIC_CLOCKS : nvapi.h
  • NVAPI_MAX_GPU_TOPOLOGIES : nvapi_lite_common.h
  • NVAPI_MAX_GPU_UTILIZATIONS : nvapi.h
  • NVAPI_MAX_GSYNC_DEVICES : nvapi.h
  • NVAPI_MAX_HEADS_PER_GPU : nvapi_lite_common.h
  • NVAPI_MAX_LOGICAL_GPUS : nvapi_lite_common.h
  • NVAPI_MAX_MOSAIC_DISPLAY_COLUMNS : nvapi.h
  • NVAPI_MAX_MOSAIC_DISPLAY_ROWS : nvapi.h
  • NVAPI_MAX_MOSAIC_TOPOS : nvapi.h
  • NVAPI_MAX_PHYSICAL_BRIDGES : nvapi_lite_common.h
  • NVAPI_MAX_PHYSICAL_GPUS : nvapi_lite_common.h
  • NVAPI_MAX_RJ45_PER_GSYNC : nvapi.h
  • NVAPI_MAX_SIZEOF_I2C_DATA_BUFFER : nvapi.h
  • NVAPI_MAX_SIZEOF_I2C_REG_ADDRESS : nvapi.h
  • NVAPI_MAX_THERMAL_SENSORS_PER_GPU : nvapi.h
  • NVAPI_MAX_VIEW_MODES : nvapi_lite_common.h
  • NVAPI_MAX_VIEW_TARGET : nvapi.h
  • NVAPI_MAX_VIO_CHANNELS_PER_JACK : nvapi.h
  • NVAPI_MAX_VIO_DEVICES : nvapi.h
  • NVAPI_MAX_VIO_JACKS : nvapi.h
  • NVAPI_MAX_VIO_LINKS_PER_STREAM : nvapi.h
  • NVAPI_MAX_VIO_STREAMS : nvapi.h
  • NVAPI_MIN_VIO_STREAMS : nvapi.h
  • NVAPI_MOSAIC_DISPLAY_SETTING_VER : nvapi.h
  • NVAPI_MOSAIC_DISPLAY_SETTING_VER1 : nvapi.h
  • NVAPI_MOSAIC_DISPLAY_SETTING_VER2 : nvapi.h
  • NVAPI_MOSAIC_SUPPORTED_TOPO_INFO_VER : nvapi.h
  • NVAPI_MOSAIC_SUPPORTED_TOPO_INFO_VER1 : nvapi.h
  • NVAPI_MOSAIC_SUPPORTED_TOPO_INFO_VER2 : nvapi.h
  • NVAPI_MOSAIC_SUPPORTED_TOPOLOGIES_VER : nvapi.h
  • NVAPI_MOSAIC_TOPO_BRIEF_VER : nvapi.h
  • NVAPI_MOSAIC_TOPO_DETAILS_VER : nvapi.h
  • NVAPI_MOSAIC_TOPO_GROUP_VER : nvapi.h
  • NVAPI_MOSAIC_TOPOLOGY_VER : nvapi.h
  • NVAPI_NVLINK_CAPS_NCI_VERSION_1_0 : nvapi.h
  • NVAPI_NVLINK_CAPS_NCI_VERSION_2_0 : nvapi.h
  • NVAPI_NVLINK_CAPS_NCI_VERSION_INVALID : nvapi.h
  • NVAPI_NVLINK_CAPS_NVLINK_VERSION_1_0 : nvapi.h
  • NVAPI_NVLINK_CAPS_NVLINK_VERSION_2_0 : nvapi.h
  • NVAPI_NVLINK_CAPS_NVLINK_VERSION_INVALID : nvapi.h
  • NVAPI_NVLINK_CAPS_P2P_ATOMICS : nvapi.h
  • NVAPI_NVLINK_CAPS_P2P_SUPPORTED : nvapi.h
  • NVAPI_NVLINK_CAPS_PEX_TUNNELING : nvapi.h
  • NVAPI_NVLINK_CAPS_POWER_STATE_L0 : nvapi.h
  • NVAPI_NVLINK_CAPS_POWER_STATE_L1 : nvapi.h
  • NVAPI_NVLINK_CAPS_POWER_STATE_L2 : nvapi.h
  • NVAPI_NVLINK_CAPS_POWER_STATE_L3 : nvapi.h
  • NVAPI_NVLINK_CAPS_SLI_BRIDGE : nvapi.h
  • NVAPI_NVLINK_CAPS_SLI_BRIDGE_SENSABLE : nvapi.h
  • NVAPI_NVLINK_CAPS_SUPPORTED : nvapi.h
  • NVAPI_NVLINK_CAPS_SYSMEM_ACCESS : nvapi.h
  • NVAPI_NVLINK_CAPS_SYSMEM_ATOMICS : nvapi.h
  • NVAPI_NVLINK_CAPS_VALID : nvapi.h
  • NVAPI_NVLINK_COUNTER_MAX_TYPES : nvapi.h
  • NVAPI_NVLINK_DEVICE_INFO_DEVICE_ID_FLAGS_NONE : nvapi.h
  • NVAPI_NVLINK_DEVICE_INFO_DEVICE_ID_FLAGS_PCI : nvapi.h
  • NVAPI_NVLINK_DEVICE_INFO_DEVICE_ID_FLAGS_UUID : nvapi.h
  • NVAPI_NVLINK_MAX_LINKS : nvapi.h
  • NVAPI_NVLINK_REFCLK_TYPE_INVALID : nvapi.h
  • NVAPI_NVLINK_REFCLK_TYPE_NVHS : nvapi.h
  • NVAPI_NVLINK_REFCLK_TYPE_PEX : nvapi.h
  • NVAPI_NVLINK_STATUS_CONNECTED_FALSE : nvapi.h
  • NVAPI_NVLINK_STATUS_CONNECTED_TRUE : nvapi.h
  • NVAPI_NVLINK_STATUS_GRS_VERSION_1_0 : nvapi.h
  • NVAPI_NVLINK_STATUS_GRS_VERSION_INVALID : nvapi.h
  • NVAPI_NVLINK_STATUS_LOOP_PROPERTY_LOOPBACK : nvapi.h
  • NVAPI_NVLINK_STATUS_LOOP_PROPERTY_LOOPOUT : nvapi.h
  • NVAPI_NVLINK_STATUS_LOOP_PROPERTY_NONE : nvapi.h
  • NVAPI_NVLINK_STATUS_NCI_VERSION_1_0 : nvapi.h
  • NVAPI_NVLINK_STATUS_NCI_VERSION_2_0 : nvapi.h
  • NVAPI_NVLINK_STATUS_NCI_VERSION_INVALID : nvapi.h
  • NVAPI_NVLINK_STATUS_NVHS_VERSION_1_0 : nvapi.h
  • NVAPI_NVLINK_STATUS_NVHS_VERSION_INVALID : nvapi.h
  • NVAPI_NVLINK_STATUS_NVLINK_VERSION_1_0 : nvapi.h
  • NVAPI_NVLINK_STATUS_NVLINK_VERSION_2_0 : nvapi.h
  • NVAPI_NVLINK_STATUS_NVLINK_VERSION_INVALID : nvapi.h
  • NVAPI_NVLINK_STATUS_PHY_GRS : nvapi.h
  • NVAPI_NVLINK_STATUS_PHY_INVALID : nvapi.h
  • NVAPI_NVLINK_STATUS_PHY_NVHS : nvapi.h
  • NVAPI_NVLINK_STATUS_REMOTE_LINK_NUMBER_INVALID : nvapi.h
  • NVAPI_OGLEXPERT_DETAIL_ALL : nvapi.h
  • NVAPI_OGLEXPERT_DETAIL_BASIC_INFO : nvapi.h
  • NVAPI_OGLEXPERT_DETAIL_DETAILED_INFO : nvapi.h
  • NVAPI_OGLEXPERT_DETAIL_ERROR : nvapi.h
  • NVAPI_OGLEXPERT_DETAIL_NONE : nvapi.h
  • NVAPI_OGLEXPERT_DETAIL_PERFORMANCE_WARNING : nvapi.h
  • NVAPI_OGLEXPERT_DETAIL_QUALITY_WARNING : nvapi.h
  • NVAPI_OGLEXPERT_DETAIL_SWFALLBACK : nvapi.h
  • NVAPI_OGLEXPERT_DETAIL_USAGE_WARNING : nvapi.h
  • NVAPI_OGLEXPERT_OUTPUT_TO_ALL : nvapi.h
  • NVAPI_OGLEXPERT_OUTPUT_TO_CALLBACK : nvapi.h
  • NVAPI_OGLEXPERT_OUTPUT_TO_CONSOLE : nvapi.h
  • NVAPI_OGLEXPERT_OUTPUT_TO_DEBUGGER : nvapi.h
  • NVAPI_OGLEXPERT_OUTPUT_TO_NONE : nvapi.h
  • NVAPI_OGLEXPERT_REPORT_ALL : nvapi.h
  • NVAPI_OGLEXPERT_REPORT_ERROR : nvapi.h
  • NVAPI_OGLEXPERT_REPORT_FEATURE_SLI : nvapi.h
  • NVAPI_OGLEXPERT_REPORT_NONE : nvapi.h
  • NVAPI_OGLEXPERT_REPORT_OBJECT_BUFFEROBJECT : nvapi.h
  • NVAPI_OGLEXPERT_REPORT_OBJECT_FBO : nvapi.h
  • NVAPI_OGLEXPERT_REPORT_OBJECT_PROGRAM : nvapi.h
  • NVAPI_OGLEXPERT_REPORT_OBJECT_TEXTURE : nvapi.h
  • NVAPI_OGLEXPERT_REPORT_PIPELINE_FRAGMENT : nvapi.h
  • NVAPI_OGLEXPERT_REPORT_PIPELINE_FRAMEBUFFER : nvapi.h
  • NVAPI_OGLEXPERT_REPORT_PIPELINE_GEOMETRY : nvapi.h
  • NVAPI_OGLEXPERT_REPORT_PIPELINE_PIXEL : nvapi.h
  • NVAPI_OGLEXPERT_REPORT_PIPELINE_RASTER : nvapi.h
  • NVAPI_OGLEXPERT_REPORT_PIPELINE_ROP : nvapi.h
  • NVAPI_OGLEXPERT_REPORT_PIPELINE_TEXTURE : nvapi.h
  • NVAPI_OGLEXPERT_REPORT_PIPELINE_VERTEX : nvapi.h
  • NVAPI_OGLEXPERT_REPORT_PIPELINE_XFB : nvapi.h
  • NVAPI_OGLEXPERT_REPORT_SWFALLBACK : nvapi.h
  • NVAPI_PHYSICAL_GPUS : nvapi_lite_common.h
  • NVAPI_PRESENT_COMPOSITING_CONFIG_FLAG_CLEAR_OUTBANDS : nvapi.h
  • NVAPI_PRESENT_COMPOSITING_CONFIG_FLAG_GET_VIDEO_BRIDGE_STATUS : nvapi.h
  • NVAPI_PRESENT_COMPOSITING_CONFIG_FLAG_USE_VIDEO_BRIDGE : nvapi.h
  • NVAPI_RELOCATE_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PARAMS_VER : nvapi.h
  • NVAPI_RELOCATE_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PARAMS_VER1 : nvapi.h
  • NVAPI_RELOCATE_RAYTRACING_OPACITY_MICROMAP_ARRAY_PARAMS_VER : nvapi.h
  • NVAPI_RELOCATE_RAYTRACING_OPACITY_MICROMAP_ARRAY_PARAMS_VER1 : nvapi.h
  • NVAPI_SETTING_MAX_VALUES : nvapi.h
  • NVAPI_SHORT_STRING_MAX : nvapi_lite_common.h
  • NVAPI_STEREO_CAPS_VER : nvapi.h
  • NVAPI_STEREO_CAPS_VER1 : nvapi.h
  • NVAPI_STEREO_QUADBUFFERED_API_VERSION : nvapi.h
  • NVAPI_SYSTEM_HWBC_INVALID_ID : nvapi_lite_common.h
  • NVAPI_SYSTEM_MAX_DISPLAYS : nvapi_lite_common.h
  • NVAPI_SYSTEM_MAX_HWBCS : nvapi_lite_common.h
  • NVAPI_UAV_INFO_VER : nvapi.h
  • NVAPI_UAV_INFO_VER1 : nvapi.h
  • NVAPI_UAV_INFO_VER2 : nvapi.h
  • NVAPI_UNICODE_STRING_MAX : nvapi.h
  • NVAPI_VIDEO_BRIDGE_STATUS_AVAILABLE : nvapi.h
  • NVAPI_VIDEO_BRIDGE_STATUS_FAILED_ACCESS : nvapi.h
  • NVAPI_VIDEO_BRIDGE_STATUS_NOT_AVAILABLE : nvapi.h
  • NVAPI_VIDEO_BRIDGE_STATUS_UNKNOWN : nvapi.h
  • NVDRS_APPLICATION_VER : nvapi.h
  • NVDRS_APPLICATION_VER_V1 : nvapi.h
  • NVDRS_APPLICATION_VER_V2 : nvapi.h
  • NVDRS_APPLICATION_VER_V3 : nvapi.h
  • NVDRS_APPLICATION_VER_V4 : nvapi.h
  • NVDRS_PROFILE_VER : nvapi.h
  • NVDRS_PROFILE_VER1 : nvapi.h
  • NVDRS_SETTING_VALUES_VER : nvapi.h
  • NVDRS_SETTING_VER : nvapi.h
  • NVDRS_SETTING_VER1 : nvapi.h
  • NvF32TONvU32 : nvapi_lite_common.h
  • NVFORMAT_MAKEFOURCC : nvapi.h
  • NvGUID_Defined : nvapi_lite_common.h
  • NVLINK_GET_CAPS_VER : nvapi.h
  • NVLINK_GET_CAPS_VER1 : nvapi.h
  • NVLINK_GET_STATUS_VER : nvapi.h
  • NVLINK_GET_STATUS_VER1 : nvapi.h
  • NVLINK_GET_STATUS_VER2 : nvapi.h
  • NvU32TONvF32 : nvapi_lite_common.h
  • NVVIO_O_READ : nvapi.h
  • NVVIO_O_WRITE_EXCLUSIVE : nvapi.h
  • NVVIO_OWNERID_EXCLUSIVE : nvapi.h
  • NVVIO_OWNERID_INITIALIZED : nvapi.h
  • NVVIO_OWNERID_TYPEMASK : nvapi.h
  • NVVIO_VALID_ACCESSRIGHTS : nvapi.h
  • NVVIOBUFFERFORMAT_R16FPG16FPB16FP : nvapi.h
  • NVVIOBUFFERFORMAT_R16FPG16FPB16FPA16FP : nvapi.h
  • NVVIOBUFFERFORMAT_R16FPG16FPB16FPA16FPZ24 : nvapi.h
  • NVVIOBUFFERFORMAT_R16FPG16FPB16FPZ24 : nvapi.h
  • NVVIOBUFFERFORMAT_R8G8B8 : nvapi.h
  • NVVIOBUFFERFORMAT_R8G8B8A8 : nvapi.h
  • NVVIOBUFFERFORMAT_R8G8B8A8Z24 : nvapi.h
  • NVVIOBUFFERFORMAT_R8G8B8Z24 : nvapi.h
  • NVVIOCAPS_AUDIO_BLANKING_SUPPORTED : nvapi.h
  • NVVIOCAPS_OUTPUTMODE_DESKTOP : nvapi.h
  • NVVIOCAPS_OUTPUTMODE_OPENGL : nvapi.h
  • NVVIOCAPS_PACKED_ANC_SUPPORTED : nvapi.h
  • NVVIOCAPS_SYNC_GENLOCK : nvapi.h
  • NVVIOCAPS_SYNC_INTERNAL : nvapi.h
  • NVVIOCAPS_SYNCSRC_COMP : nvapi.h
  • NVVIOCAPS_SYNCSRC_SDI : nvapi.h
  • NVVIOCAPS_VER : nvapi.h
  • NVVIOCAPS_VER1 : nvapi.h
  • NVVIOCAPS_VER2 : nvapi.h
  • NVVIOCAPS_VIDIN_SDI : nvapi.h
  • NVVIOCAPS_VIDOUT_SDI : nvapi.h
  • NVVIOCLASS_SDI : nvapi.h
  • NVVIOCOLORCONVERSION_VER : nvapi.h
  • NVVIOCONFIG_422FILTER : nvapi.h
  • NVVIOCONFIG_ALLFIELDS : nvapi.h
  • NVVIOCONFIG_ALLOWSDIRUNNING_FIELDS : nvapi.h
  • NVVIOCONFIG_ALPHAKEYCOMPOSITE : nvapi.h
  • NVVIOCONFIG_ANC_AUDIO_REPEAT : nvapi.h
  • NVVIOCONFIG_ANC_PARITY_COMPUTATION : nvapi.h
  • NVVIOCONFIG_ANCTIMECODEGENERATION : nvapi.h
  • NVVIOCONFIG_COLORCONVERSION : nvapi.h
  • NVVIOCONFIG_COMPOSITE : nvapi.h
  • NVVIOCONFIG_COMPOSITE_CB : nvapi.h
  • NVVIOCONFIG_COMPOSITE_CR : nvapi.h
  • NVVIOCONFIG_COMPOSITE_Y : nvapi.h
  • NVVIOCONFIG_COMPOSITESYNCTYPE : nvapi.h
  • NVVIOCONFIG_COMPOSITETERMINATE : nvapi.h
  • NVVIOCONFIG_CSCOVERRIDE : nvapi.h
  • NVVIOCONFIG_DATAFORMAT : nvapi.h
  • NVVIOCONFIG_DATAINTEGRITYCHECK : nvapi.h
  • NVVIOCONFIG_DRIVERFIELDS : nvapi.h
  • NVVIOCONFIG_FLIPQUEUELENGTH : nvapi.h
  • NVVIOCONFIG_FRAMELOCKENABLE : nvapi.h
  • NVVIOCONFIG_FULL_COLOR_RANGE : nvapi.h
  • NVVIOCONFIG_GAMMACORRECTION : nvapi.h
  • NVVIOCONFIG_GAMMAFIELDS : nvapi.h
  • NVVIOCONFIG_OUTPUTAREA : nvapi.h
  • NVVIOCONFIG_OUTPUTREGION : nvapi.h
  • NVVIOCONFIG_RESERVED_SDIOUTPUTENABLE : nvapi.h
  • NVVIOCONFIG_RGB_DATA : nvapi.h
  • NVVIOCONFIG_RMCTRLFIELDS : nvapi.h
  • NVVIOCONFIG_RMMODESET_FIELDS : nvapi.h
  • NVVIOCONFIG_RMSKEWFIELDS : nvapi.h
  • NVVIOCONFIG_SIGNALFORMAT : nvapi.h
  • NVVIOCONFIG_STREAMS : nvapi.h
  • NVVIOCONFIG_SYNCDELAY : nvapi.h
  • NVVIOCONFIG_SYNCSOURCEENABLE : nvapi.h
  • NVVIOCONFIG_VALIDFIELDS : nvapi.h
  • NVVIOCONFIG_VER : nvapi.h
  • NVVIOCONFIG_VER1 : nvapi.h
  • NVVIOCONFIG_VER2 : nvapi.h
  • NVVIOCONFIG_VER3 : nvapi.h
  • NVVIOGAMMACORRECTION_VER : nvapi.h
  • NVVIOOWNERID_NONE : nvapi.h
  • NVVIOPCIINFO_VER : nvapi.h
  • NVVIOPCIINFO_VER1 : nvapi.h
  • NVVIOSTATUS_VER : nvapi.h
  • NVVIOSYNCDELAY_VER : nvapi.h
  • NVVIOTOPOLOGY_VER : nvapi.h


  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • v
  • w
Here is a list of all macros with links to the files they belong to:

- o -

  • OGL_AA_LINE_GAMMA_STRING : NvApiDriverSettings.h
  • OGL_CPL_GDI_COMPATIBILITY_STRING : NvApiDriverSettings.h
  • OGL_CPL_PREFER_DXPRESENT_STRING : NvApiDriverSettings.h
  • OGL_DEEP_COLOR_SCANOUT_STRING : NvApiDriverSettings.h
  • OGL_DEFAULT_SWAP_INTERVAL_FRACTIONAL_STRING : NvApiDriverSettings.h
  • OGL_DEFAULT_SWAP_INTERVAL_SIGN_STRING : NvApiDriverSettings.h
  • OGL_DEFAULT_SWAP_INTERVAL_STRING : NvApiDriverSettings.h
  • OGL_EVENT_LOG_SEVERITY_THRESHOLD_STRING : NvApiDriverSettings.h
  • OGL_EXTENSION_STRING_VERSION_STRING : NvApiDriverSettings.h
  • OGL_FORCE_BLIT_STRING : NvApiDriverSettings.h
  • OGL_FORCE_STEREO_STRING : NvApiDriverSettings.h
  • OGL_IMPLICIT_GPU_AFFINITY_AUTOSELECT : NvApiDriverSettings.h
  • OGL_IMPLICIT_GPU_AFFINITY_DEFAULT : NvApiDriverSettings.h
  • OGL_IMPLICIT_GPU_AFFINITY_ENV_VAR : NvApiDriverSettings.h
  • OGL_IMPLICIT_GPU_AFFINITY_NUM_VALUES : NvApiDriverSettings.h
  • OGL_IMPLICIT_GPU_AFFINITY_STRING : NvApiDriverSettings.h
  • OGL_MAX_FRAMES_ALLOWED_STRING : NvApiDriverSettings.h
  • OGL_OVERLAY_PIXEL_TYPE_STRING : NvApiDriverSettings.h
  • OGL_OVERLAY_SUPPORT_STRING : NvApiDriverSettings.h
  • OGL_QUALITY_ENHANCEMENTS_STRING : NvApiDriverSettings.h
  • OGL_SINGLE_BACKDEPTH_BUFFER_STRING : NvApiDriverSettings.h
  • OGL_SLI_MULTICAST_STRING : NvApiDriverSettings.h
  • OGL_THREAD_CONTROL_STRING : NvApiDriverSettings.h
  • OGL_TMON_LEVEL_STRING : NvApiDriverSettings.h
  • OGL_TRIPLE_BUFFER_STRING : NvApiDriverSettings.h
  • OPTIMUS_MAXAA_STRING : NvApiDriverSettings.h


  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • v
  • w
Here is a list of all macros with links to the files they belong to:

- p -

  • PHYSXINDICATOR_STRING : NvApiDriverSettings.h
  • PREFERRED_PSTATE_STRING : NvApiDriverSettings.h
  • PRERENDERLIMIT_STRING : NvApiDriverSettings.h
  • PREVENT_UI_AF_OVERRIDE_STRING : NvApiDriverSettings.h
  • PS_SHADERDISKCACHE_DLL_PATH_WCHAR_STRING : NvApiDriverSettings.h
  • PS_SHADERDISKCACHE_MAX_SIZE_STRING : NvApiDriverSettings.h
  • PS_SHADERDISKCACHE_STRING : NvApiDriverSettings.h
  • PS_TEXFILTER_ANISO_OPTS2_STRING : NvApiDriverSettings.h
  • PS_TEXFILTER_BILINEAR_IN_ANISO_STRING : NvApiDriverSettings.h
  • PS_TEXFILTER_DISABLE_TRILIN_SLOPE_STRING : NvApiDriverSettings.h
  • PS_TEXFILTER_NO_NEG_LODBIAS_STRING : NvApiDriverSettings.h


  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • v
  • w
Here is a list of all macros with links to the files they belong to:

- q -

  • QUALITY_ENHANCEMENT_SUBSTITUTION_STRING : NvApiDriverSettings.h
  • QUALITY_ENHANCEMENTS_STRING : NvApiDriverSettings.h


  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • v
  • w
Here is a list of all macros with links to the files they belong to:

- r -

  • REFRESH_RATE_OVERRIDE_STRING : NvApiDriverSettings.h


  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • v
  • w
Here is a list of all macros with links to the files they belong to:

- s -

  • SET_POWER_THROTTLE_FOR_PCIe_COMPLIANCE_STRING : NvApiDriverSettings.h
  • SET_VAB_DATA_STRING : NvApiDriverSettings.h
  • SHIM_MAXRES_STRING : NvApiDriverSettings.h
  • SHIM_MCCOMPAT_STRING : NvApiDriverSettings.h
  • SHIM_RENDERING_MODE_STRING : NvApiDriverSettings.h
  • SHIM_RENDERING_OPTIONS_STRING : NvApiDriverSettings.h
  • SLI_GPU_COUNT_STRING : NvApiDriverSettings.h
  • SLI_PREDEFINED_GPU_COUNT_DX10_STRING : NvApiDriverSettings.h
  • SLI_PREDEFINED_GPU_COUNT_STRING : NvApiDriverSettings.h
  • SLI_PREDEFINED_MODE_DX10_STRING : NvApiDriverSettings.h
  • SLI_PREDEFINED_MODE_STRING : NvApiDriverSettings.h
  • SLI_RENDERING_MODE_STRING : NvApiDriverSettings.h


  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • v
  • w
Here is a list of all macros with links to the files they belong to:

- v -

  • VRPRERENDERLIMIT_STRING : NvApiDriverSettings.h
  • VRR_APP_OVERRIDE_REQUEST_STATE_STRING : NvApiDriverSettings.h
  • VRR_APP_OVERRIDE_STRING : NvApiDriverSettings.h
  • VRR_MODE_STRING : NvApiDriverSettings.h
  • VRRFEATUREINDICATOR_STRING : NvApiDriverSettings.h
  • VRROVERLAYINDICATOR_STRING : NvApiDriverSettings.h
  • VRRREQUESTSTATE_STRING : NvApiDriverSettings.h
  • VSYNC_BEHAVIOR_FLAGS_STRING : NvApiDriverSettings.h
  • VSYNCMODE_STRING : NvApiDriverSettings.h
  • VSYNCSMOOTHAFR_STRING : NvApiDriverSettings.h
  • VSYNCTEARCONTROL_STRING : NvApiDriverSettings.h
  • VSYNCVRRCONTROL_STRING : NvApiDriverSettings.h


  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • v
  • w
Here is a list of all macros with links to the files they belong to:

- w -

  • WKS_API_STEREO_EYES_EXCHANGE_STRING : NvApiDriverSettings.h
  • WKS_API_STEREO_MODE_STRING : NvApiDriverSettings.h
  • WKS_STEREO_DONGLE_SUPPORT_STRING : NvApiDriverSettings.h
  • WKS_STEREO_SUPPORT_STRING : NvApiDriverSettings.h
  • WKS_STEREO_SWAP_MODE_STRING : NvApiDriverSettings.h


Data Structure Index
F | I | N | T | _
F
_NV_LATENCY_RESULT_PARAMS::FrameReport
I
INvAPI_DirectD3D12GraphicsCommandList
N
NV_CHIPSET_INFO_v1
NV_CHIPSET_INFO_v2
NV_CHIPSET_INFO_v3
NV_CHIPSET_INFO_v4
NV_COMPUTE_GPU_TOPOLOGY_V1
NV_CUSTOM_DISPLAY
NV_D3D11_META_COMMAND_EXECUTE_CONVOLUTION_EX_DESC
NV_D3D11_META_COMMAND_EXECUTE_GEMM_DESC
NV_D3D11_META_COMMAND_INITIALIZE_CONVOLUTION_EX_DESC
NV_D3D11_META_COMMAND_INITIALIZE_GEMM_DESC
NV_D3D11_META_COMMAND_RESOURCE
NV_D3D12_META_COMMAND_EXECUTE_CONVOLUTION_EX_DESC
NV_D3D12_META_COMMAND_EXECUTE_GEMM_DESC
NV_D3D12_META_COMMAND_INITIALIZE_CONVOLUTION_EX_DESC
NV_D3D12_META_COMMAND_INITIALIZE_GEMM_DESC
NV_DISPLAY_DRIVER_MEMORY_INFO_V1
NV_DISPLAY_DRIVER_MEMORY_INFO_V2
NV_DISPLAY_DRIVER_MEMORY_INFO_V3
NV_DISPLAY_DRIVER_VERSION
NV_DISPLAY_PATH
NV_DISPLAY_PATH_INFO
NV_DISPLAY_PATH_INFO_V3
NV_DISPLAY_PORT_CONFIG
NV_EDID_V1
NV_EDID_V2
NV_EDID_V3
NV_EVENT_REGISTER_CALLBACK
NV_GET_CURRENT_SLI_STATE_V1
NV_GET_CURRENT_SLI_STATE_V2
NV_GET_GPU_VIRTUAL_ADDRESS_V1
NV_GET_PREFERRED_STEREO_DISPLAY_V1
NV_GPU_ARCH_INFO_V1
NV_GPU_ARCH_INFO_V2
NV_GPU_CLIENT_ILLUM_DEVICE_CONTROL_PARAMS_V1
NV_GPU_CLIENT_ILLUM_DEVICE_CONTROL_V1
NV_GPU_CLIENT_ILLUM_DEVICE_SYNC_V1
NV_GPU_CLOCK_FREQUENCIES_V1
NV_GPU_CLOCK_FREQUENCIES_V2
NV_GPU_DYNAMIC_PSTATES_INFO_EX
NV_GPU_ECC_CONFIGURATION_INFO
NV_GPU_ECC_ERROR_INFO
NV_GPU_ECC_STATUS_INFO
NV_GPU_GET_HDCP_SUPPORT_STATUS
NV_GPU_MEMORY_INFO_EX_V1
NV_GPU_PERF_PSTATES20_INFO_V1
NV_GPU_PERF_PSTATES20_PARAM_DELTA
NV_GPU_PERF_PSTATES_INFO_V1
NV_GPU_PERF_PSTATES_INFO_V2
NV_GPU_PSTATE20_BASE_VOLTAGE_ENTRY_V1
NV_GPU_PSTATE20_CLOCK_ENTRY_V1
NV_GPU_THERMAL_SETTINGS_V1
NV_GPU_THERMAL_SETTINGS_V2
NV_I2C_INFO_V1
NV_I2C_INFO_V2
NV_I2C_INFO_V3
NV_INFOFRAME_AUDIO
NV_INFOFRAME_DATA
NV_INFOFRAME_PROPERTY
NV_INFOFRAME_VIDEO
NV_LID_DOCK_PARAMS
NV_META_COMMAND_ACTIVATION_DESC
NV_META_COMMAND_CONVOLUTION_FUSE_DESC
NV_META_COMMAND_CREATE_CONVOLUTION_EX_DESC
NV_META_COMMAND_CREATE_CONVOLUTION_EX_FUSED_DESC
NV_META_COMMAND_CREATE_GEMM_DESC
NV_META_COMMAND_OPTIONAL_ACTIVATION_DESC
NV_META_COMMAND_OPTIONAL_TENSOR_DESC
NV_META_COMMAND_PADDING_DESC
NV_META_COMMAND_TENSOR_DESC
NV_MOSAIC_DISPLAY_SETTING_V2
NV_MOSAIC_DISPLAY_TOPO_STATUS
NV_MOSAIC_SUPPORTED_TOPOLOGIES
NV_MOSAIC_TOPO_BRIEF
NV_MOSAIC_TOPO_DETAILS
NV_MOSAIC_TOPO_GROUP
NV_MOSAIC_TOPOLOGY
_NV_PIXEL_SRSO_1x2::NV_PIXEL_SRSO_1x2_X1
_NV_PIXEL_SRSO_1x2::NV_PIXEL_SRSO_1x2_X2
_NV_PIXEL_SRSO_1x2::NV_PIXEL_SRSO_1x2_X4
_NV_PIXEL_SRSO_1x2::NV_PIXEL_SRSO_1x2_X8
_NV_PIXEL_SRSO_2x1::NV_PIXEL_SRSO_2x1_X1
_NV_PIXEL_SRSO_2x1::NV_PIXEL_SRSO_2x1_X2
_NV_PIXEL_SRSO_2x1::NV_PIXEL_SRSO_2x1_X4
_NV_PIXEL_SRSO_2x2::NV_PIXEL_SRSO_2x2_X1
_NV_PIXEL_SRSO_2x2::NV_PIXEL_SRSO_2x2_X2
_NV_PIXEL_SRSO_2x2::NV_PIXEL_SRSO_2x2_X4
_NV_PIXEL_SRSO_2x4::NV_PIXEL_SRSO_2x4_X1
_NV_PIXEL_SRSO_2x4::NV_PIXEL_SRSO_2x4_X2
_NV_PIXEL_SRSO_4x2::NV_PIXEL_SRSO_4x2_X1
_NV_PIXEL_SRSO_4x4::NV_PIXEL_SRSO_4x4_X1
NV_QSYNC_EVENT_DATA
NV_SCANOUT_INTENSITY_DATA_V1
NV_SCANOUT_INTENSITY_DATA_V2
NV_SCANOUT_WARPING_DATA
NV_SET_PREFERRED_STEREO_DISPLAY_V1
NV_TIMING_FLAG
NV_VIEW_TARGET_INFO
NV_VIEWPORTF
NVAPI_ANSEL_CONFIGURATION_STRUCT_V1
NVAPI_ANSEL_FEATURE_CONFIGURATION_STRUCT
NvAPI_D3D11_CREATE_DOMAIN_SHADER_EX_V1
NvAPI_D3D11_CREATE_DOMAIN_SHADER_EX_V2
NvAPI_D3D11_CREATE_DOMAIN_SHADER_EX_V3
NvAPI_D3D11_CREATE_FASTGS_EXPLICIT_DESC_V1
NvAPI_D3D11_CREATE_GEOMETRY_SHADER_EX_V5
NvAPI_D3D11_CREATE_HULL_SHADER_EX_V1
NvAPI_D3D11_CREATE_HULL_SHADER_EX_V2
NvAPI_D3D11_CREATE_PIXEL_SHADER_EX_V1
NvAPI_D3D11_CREATE_PIXEL_SHADER_EX_V2
NvAPI_D3D11_CREATE_VERTEX_SHADER_EX_V1
NvAPI_D3D11_CREATE_VERTEX_SHADER_EX_V2
NvAPI_D3D11_CREATE_VERTEX_SHADER_EX_V3
NvAPI_D3D11_RASTERIZER_DESC_EX
NVAPI_D3D12_CREATE_CUBIN_SHADER_PARAMS
NVAPI_D3D12_GET_CUDA_INDEPENDENT_DESCRIPTOR_OBJECT_PARAMS
NVAPI_D3D12_GET_CUDA_MERGED_TEXTURE_SAMPLER_OBJECT_PARAMS
NVAPI_D3D12_PSO_CREATE_FASTGS_EXPLICIT_DESC_V1
NVAPI_D3D12_PSO_DOMAIN_SHADER_DESC_V1
NVAPI_D3D12_PSO_DOMAIN_SHADER_DESC_V2
NVAPI_D3D12_PSO_DOMAIN_SHADER_DESC_V3
NVAPI_D3D12_PSO_ENABLE_DEPTH_BOUND_TEST_DESC_V1
NVAPI_D3D12_PSO_EXTENSION_DESC_V1
NVAPI_D3D12_PSO_GEOMETRY_SHADER_DESC_V5
NVAPI_D3D12_PSO_HULL_SHADER_DESC_V1
NVAPI_D3D12_PSO_HULL_SHADER_DESC_V2
NVAPI_D3D12_PSO_RASTERIZER_STATE_DESC_V1
NVAPI_D3D12_PSO_REQUEST_FAST_GEOMETRY_SHADER_DESC_V1
NVAPI_D3D12_PSO_SET_SHADER_EXTENSION_SLOT_DESC_V1
NVAPI_D3D12_PSO_VERTEX_SHADER_DESC_V1
NVAPI_D3D12_PSO_VERTEX_SHADER_DESC_V2
NVAPI_D3D12_PSO_VERTEX_SHADER_DESC_V3
NVAPI_META_COMMAND_DESC
NVAPI_UAV_INFO_V1
NVAPI_UAV_INFO_V2
NvGUID
NVLINK_DEVICE_INFO_V1
NVLINK_GET_CAPS_V1
NVLINK_GET_STATUS_V1
NVLINK_GET_STATUS_V2
NVLINK_LINK_STATUS_INFO_V1
NVLINK_LINK_STATUS_INFO_V2
NvSBox
NvShaderExtnStruct
NVVIOTOPOLOGYTARGET
T
tagNV_TIMINGEXT
_
_NV_ASYNC_FRAME_MARKER_PARAMS_V1
_NV_BOARD_INFO
_NV_CLIENT_CALLBACK_SETTINGS_SUPER_V1
_NV_COLOR_DATA_V1
_NV_COLOR_DATA_V2
_NV_COLOR_DATA_V3
_NV_COLOR_DATA_V4
_NV_COLOR_DATA_V5
_NV_COMPUTE_GPU
_NV_COMPUTE_GPU_TOPOLOGY_V2
_NV_CUSTOM_RECTS_V1
_NV_CUSTOM_SEMANTIC
_NV_D3D11_EXCLUSIVE_SCISSOR_RECT_DESC_V1
_NV_D3D11_EXCLUSIVE_SCISSOR_RECTS_DESC_V1
_NV_D3D11_FEATURE_DATA_RASTERIZER_SUPPORT
_NV_D3D11_SHADING_RATE_RESOURCE_VIEW_DESC_V1
_NV_D3D11_VIEWPORT_SHADING_RATE_DESC_V1
_NV_D3D11_VIEWPORTS_SHADING_RATE_DESC_V1
_NV_D3D12_GRAPHICS_CAPS_V1
_NV_D3D12_MOSAIC_GETCOMPANIONALLOCATIONS
_NV_D3D12_MOSAIC_GETVIEWPORTANDGPUPARTITIONS
_NV_D3D12_WORKSTATION_FEATURE_PROPERTIES
_NV_D3D12_WORKSTATION_FEATURE_RDMA_PROPERTIES
_NV_D3D1x_GRAPHICS_CAPS_V1
_NV_D3D1x_GRAPHICS_CAPS_V2
_NV_D3D_LATELATCH_OBJECT_DESC_V1
_NV_DISPLAY_DRIVER_INFO
_NV_DISPLAY_DRIVER_INFO_V2
_NV_DISPLAY_PORT_INFO_V1
_NV_DISPLAYCONFIG_PATH_ADVANCED_TARGET_INFO_V1
_NV_DISPLAYCONFIG_PATH_INFO_V1
_NV_DISPLAYCONFIG_PATH_INFO_V2
_NV_DISPLAYCONFIG_PATH_TARGET_INFO_V1
_NV_DISPLAYCONFIG_PATH_TARGET_INFO_V2
_NV_DISPLAYCONFIG_SOURCE_MODE_INFO_V1
_NV_DX_VIDEO_STEREO_INFO
_NV_EDID_DATA_V1
_NV_EDID_DATA_V2
_NV_FOVEATED_RENDERING_CUSTOM_FOVEATION_PATTERN_PRESET_DESC_V1
_NV_FOVEATED_RENDERING_CUSTOM_SHADING_RATE_PRESET_DESC_V1
_NV_FOVEATED_RENDERING_DESC_V1
_NV_FOVEATED_RENDERING_GAZE_DATA_PER_EYE
_NV_FOVEATED_RENDERING_UPDATE_GAZE_DATA_PARAMS
_NV_GAZE_HANDLER_INIT_PARAMS_V1
_NV_GAZE_HANDLER_INIT_PARAMS_V2
_NV_GET_ADAPTIVE_SYNC_DATA_V1
_NV_GET_SLEEP_STATUS_PARAMS
_NV_GET_VIRTUAL_REFRESH_RATE_DATA_V1
_NV_GET_VRR_INFO_V1
_NV_GPU_CLIENT_CALLBACK_DATA_SUPER_V1
_NV_GPU_CLIENT_CALLBACK_UTILIZATION_DATA_V1
_NV_GPU_CLIENT_ILLUM_DEVICE_INFO_DATA_GPIO_PWM_RGBW
_NV_GPU_CLIENT_ILLUM_DEVICE_INFO_DATA_GPIO_PWM_SINGLE_COLOR
_NV_GPU_CLIENT_ILLUM_DEVICE_INFO_DATA_MCUV10
_NV_GPU_CLIENT_ILLUM_DEVICE_INFO_PARAMS_V1
_NV_GPU_CLIENT_ILLUM_DEVICE_INFO_V1
_NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_COLOR_FIXED
_NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_COLOR_FIXED
_NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_COLOR_FIXED_PARAMS
_NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_RGB
_NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_RGB_PARAMS
_NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_RGBW
_NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_RGBW_PARAMS
_NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_SINGLE_COLOR
_NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_MANUAL_SINGLE_COLOR_PARAMS
_NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR
_NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR_COLOR_FIXED
_NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR_RGB
_NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR_RGBW
_NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_PIECEWISE_LINEAR_SINGLE_COLOR
_NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_RGB
_NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_RGBW
_NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_DATA_SINGLE_COLOR
_NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_PARAMS_V1
_NV_GPU_CLIENT_ILLUM_ZONE_CONTROL_V1
_NV_GPU_CLIENT_ILLUM_ZONE_INFO_DATA_RGB
_NV_GPU_CLIENT_ILLUM_ZONE_INFO_DATA_RGBW
_NV_GPU_CLIENT_ILLUM_ZONE_INFO_DATA_SINGLE_COLOR
_NV_GPU_CLIENT_ILLUM_ZONE_INFO_PARAMS_V1
_NV_GPU_CLIENT_ILLUM_ZONE_INFO_V1
_NV_GPU_CLIENT_PERIODIC_CALLBACK_SETTINGS_SUPER_V1
_NV_GPU_CLIENT_UTILIZATION_DATA_V1
_NV_GPU_CLIENT_UTILIZATION_PERIODIC_CALLBACK_SETTINGS_V1
_NV_GPU_DISPLAYIDS
_NV_GPU_GET_ILLUMINATION_PARM_V1
_NV_GPU_GSP_INFO_V1
_NV_GPU_INFO_V1
_NV_GPU_INFO_V2
_NV_GPU_PERF_PSTATES20_INFO_V2
_NV_GPU_QUERY_ILLUMINATION_SUPPORT_PARM_V1
_NV_GPU_SET_ILLUMINATION_PARM_V1
_NV_GPU_VIRTUALIZATION_INFO
_NV_GPU_VR_READY_V1
_NV_GSYNC_CAPABILITIES_V1
_NV_GSYNC_CAPABILITIES_V2
_NV_GSYNC_CAPABILITIES_V3
_NV_GSYNC_CONTROL_PARAMS_V1
_NV_GSYNC_CONTROL_PARAMS_V2
_NV_GSYNC_DELAY
_NV_GSYNC_DISPLAY
_NV_GSYNC_GPU
_NV_GSYNC_STATUS
_NV_GSYNC_STATUS_PARAMS_V1
_NV_GSYNC_STATUS_PARAMS_V2
_NV_HDMI_SUPPORT_INFO_V1
_NV_HDMI_SUPPORT_INFO_V2
_NV_HDR_CAPABILITIES_V1
_NV_HDR_CAPABILITIES_V2
_NV_HDR_CAPABILITIES_V3
_NV_HDR_COLOR_DATA_V1
_NV_HDR_COLOR_DATA_V2
_NV_HDR_METADATA_V1
_NV_HEAP_PARAMS_V1
_NV_JOIN_PRESENT_BARRIER_PARAMS
_NV_LATENCY_MARKER_PARAMS
_NV_LATENCY_RESULT_PARAMS
_NV_LICENSABLE_FEATURES_V1
_NV_LICENSABLE_FEATURES_V2
_NV_LICENSABLE_FEATURES_V3
_NV_LICENSABLE_FEATURES_V4
_NV_LICENSE_EXPIRY_DETAILS
_NV_LICENSE_FEATURE_DETAILS_V1
_NV_LICENSE_FEATURE_DETAILS_V2
_NV_LICENSE_FEATURE_DETAILS_V3
_NV_LICENSE_FEATURE_DETAILS_V4
_NV_LMS_CUSTOM_CONFIG_V1
_NV_LMS_INSTANCED_STEREO_CONFIG_V1
_NV_LOGICAL_GPU_DATA_V1
_NV_LOGICAL_GPU_HANDLE_DATA
_NV_LOGICAL_GPUS
_NV_MANAGED_DEDICATED_DISPLAY_INFO
_NV_MANAGED_DEDICATED_DISPLAY_METADATA
_NV_MODIFIED_W_COEFFICIENTS
_NV_MODIFIED_W_PARAMS
_NV_MONITOR_CAPABILITIES_V1
_NV_MONITOR_CAPS_GENERIC
_NV_MONITOR_CAPS_VCDB
_NV_MONITOR_CAPS_VSDB
_NV_MONITOR_COLOR_DATA
_NV_MOSAIC_DISPLAY_SETTING_V1
_NV_MOSAIC_GRID_TOPO_DISPLAY_V1
_NV_MOSAIC_GRID_TOPO_DISPLAY_V2
_NV_MOSAIC_GRID_TOPO_V1
_NV_MOSAIC_GRID_TOPO_V2
_NV_MOSAIC_SUPPORTED_TOPO_INFO_V1
_NV_MOSAIC_SUPPORTED_TOPO_INFO_V2
_NV_MRS_CUSTOM_CONFIG_V1
_NV_MRS_INSTANCED_STEREO_CONFIG_V1
_NV_MULTIGPU_CAPS_V1
_NV_MULTIGPU_CAPS_V2
_NV_MULTIVIEW_PARAMS_V1
_NV_PHYSICAL_GPU_HANDLE_DATA
_NV_PHYSICAL_GPUS
_NV_PIXEL_SHADING_RATE_SAMPLE_ORDER_TABLE_V1
_NV_PIXEL_SRSO_1x2
_NV_PIXEL_SRSO_2x1
_NV_PIXEL_SRSO_2x2
_NV_PIXEL_SRSO_2x4
_NV_PIXEL_SRSO_4x2
_NV_PIXEL_SRSO_4x4
_NV_POSITION
_NV_PRESENT_BARRIER_FRAME_STATISTICS
_NV_QUERY_LATELATCH_SUPPORT_PARAMS
_NV_QUERY_MODIFIED_W_SUPPORT_PARAMS
_NV_QUERY_MULTIVIEW_SUPPORT_PARAMS_V1
_NV_QUERY_SINGLE_PASS_STEREO_SUPPORT_PARAMS_V1
_NV_QUERY_SINGLE_PASS_STEREO_SUPPORT_PARAMS_V2
_NV_QUERY_SMP_ASSIST_SUPPORT_PARAMS_V1
_NV_RECT
_NV_RESOLUTION
_NV_RESOURCE_PARAMS_V1
_NV_SCANOUT_INFORMATION
_NV_SCANOUT_INTENSITY_STATE_DATA
_NV_SCANOUT_WARPING_STATE_DATA
_NV_SET_ADAPTIVE_SYNC_DATA_V1
_NV_SET_REFLEX_SYNC_PARAMS
_NV_SET_SLEEP_MODE_PARAMS
_NV_SET_VIRTUAL_REFRESH_RATE_DATA_V1
_NV_SMP_ASSIST_DISABLE_PARAMS_V1
_NV_SMP_ASSIST_ENABLE_PARAMS_V1
_NV_SMP_ASSIST_FASTGSCBDATA_MRS_INSTANCED_STEREO_V1
_NV_SMP_ASSIST_FASTGSCBDATA_V1
_NV_SMP_ASSIST_GET_CONSTANTS_V3
_NV_SMP_ASSIST_INITIALIZE_PARAMS_V1
_NV_SMP_ASSIST_REMAPCBDATA_V1
_NV_SMP_ASSIST_SETUP_PARAMS_V1
_NV_SMP_ASSIST_UPDATE_INSTANCEDSTEREO_DATA_PARAMS_V1
_NV_TEX2D_ARRAY_SRRV
_NV_TEX2D_SRRV
_NV_TIMING
_NV_TIMING_INPUT
_NV_VIO_TOPOLOGY
_NV_VRS_HELPER_DISABLE_PARAMS_V1
_NV_VRS_HELPER_ENABLE_PARAMS_V1
_NV_VRS_HELPER_GET_SHADING_RATE_RESOURCE_PARAMS_V1
_NV_VRS_HELPER_INIT_PARAMS_V1
_NV_VRS_HELPER_LATCH_GAZE_PARAMS_V1
_NV_VRS_HELPER_PURGE_INTERNAL_RESOURCES_PARAMS_V1
_NVAPI_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_EX_PARAMS_V1
_NVAPI_BUILD_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PARAMS_V1
_NVAPI_BUILD_RAYTRACING_OPACITY_MICROMAP_ARRAY_PARAMS_V1
_NVAPI_CHECK_DRIVER_MATCHING_IDENTIFIER_EX_PARAMS_V1
_NVAPI_CU_KERNEL_LAUNCH_PARAMS
_NVAPI_CU_KERNEL_LAUNCH_PARAMS_EX
_NVAPI_D3D12_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_DESC_EX
_NVAPI_D3D12_BUILD_RAYTRACING_ACCELERATION_STRUCTURE_INPUTS_EX
_NVAPI_D3D12_BUILD_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_DESC
_NVAPI_D3D12_BUILD_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_INPUTS
_NVAPI_D3D12_BUILD_RAYTRACING_OPACITY_MICROMAP_ARRAY_DESC
_NVAPI_D3D12_BUILD_RAYTRACING_OPACITY_MICROMAP_ARRAY_INPUTS
_NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_POSTBUILD_INFO_CURRENT_SIZE_DESC
_NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_POSTBUILD_INFO_DESC
_NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PREBUILD_INFO
_NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_DESC
_NVAPI_D3D12_RAYTRACING_DISPLACEMENT_MICROMAP_USAGE_COUNT
_NVAPI_D3D12_RAYTRACING_GEOMETRY_DESC_EX
_NVAPI_D3D12_RAYTRACING_GEOMETRY_DMM_ATTACHMENT_DESC
_NVAPI_D3D12_RAYTRACING_GEOMETRY_DMM_TRIANGLES_DESC
_NVAPI_D3D12_RAYTRACING_GEOMETRY_OMM_ATTACHMENT_DESC
_NVAPI_D3D12_RAYTRACING_GEOMETRY_OMM_TRIANGLES_DESC
_NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_ARRAY_POSTBUILD_INFO_CURRENT_SIZE_DESC
_NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_ARRAY_POSTBUILD_INFO_DESC
_NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_ARRAY_PREBUILD_INFO
_NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_DESC
_NVAPI_D3D12_RAYTRACING_OPACITY_MICROMAP_USAGE_COUNT
_NVAPI_D3D12_SET_CREATE_PIPELINE_STATE_OPTIONS_PARAMS_V1
_NVAPI_DIM3
_NVAPI_EMIT_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_POSTBUILD_INFO_PARAMS_V1
_NVAPI_EMIT_RAYTRACING_OPACITY_MICROMAP_ARRAY_POSTBUILD_INFO_PARAMS_V1
_NVAPI_GET_RAYTRACING_ACCELERATION_STRUCTURE_PREBUILD_INFO_EX_PARAMS_V1
_NVAPI_GET_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PREBUILD_INFO_PARAMS_V1
_NVAPI_GET_RAYTRACING_OPACITY_MICROMAP_ARRAY_PREBUILD_INFO_PARAMS_V1
_NVAPI_RELOCATE_RAYTRACING_DISPLACEMENT_MICROMAP_ARRAY_PARAMS_V1
_NVAPI_RELOCATE_RAYTRACING_OPACITY_MICROMAP_ARRAY_PARAMS_V1
_NVAPI_STEREO_CAPS
_NVDRS_APPLICATION_V1
_NVDRS_APPLICATION_V2
_NVDRS_APPLICATION_V3
_NVDRS_APPLICATION_V4
_NVDRS_BINARY_SETTING
_NVDRS_GPU_SUPPORT
_NVDRS_PROFILE_V1
_NVDRS_SETTING_V1
_NVDRS_SETTING_VALUES
_NVVIOCAPS
_NVVIOCHANNELSTATUS
_NVVIOCOLORCONVERSION
_NVVIOCOMPOSITERANGE
_NVVIOCONFIG_V1
_NVVIOCONFIG_V2
_NVVIOCONFIG_V3
_NVVIODATAFORMATDETAIL
_NVVIOGAMMACORRECTION
_NVVIOGAMMARAMP10
_NVVIOGAMMARAMP8
_NVVIOINPUTCONFIG
_NVVIOINPUTSTATUS
_NVVIOOUTPUTCONFIG_V1
_NVVIOOUTPUTCONFIG_V2
_NVVIOOUTPUTCONFIG_V3
_NVVIOOUTPUTREGION
_NVVIOOUTPUTSTATUS
_NVVIOPCIINFO
_NVVIOSIGNALFORMATDETAIL
_NVVIOSTATUS
_NVVIOSTREAM
_NVVIOSYNCDELAY
_NVVIOVIDEOMODE
_SettingDWORDNameString
_SettingWSTRINGNameString


  • File List
  • Globals
Concepts.txt File Reference


  • File List
  • Globals
Variables
defines.txt File Reference

Variables

PREDEFINED | _D3D9_H_
PREDEFINED | __d3d10_h__
PREDEFINED | __d3d11_h__
PREDEFINED | __d3d10_1_h__
PREDEFINED | __cplusplus

Variable Documentation

◆ __cplusplus

PREDEFINED __cplusplus

◆ __d3d10_1_h__

PREDEFINED __d3d10_1_h__

◆ __d3d10_h__

PREDEFINED __d3d10_h__

◆ __d3d11_h__

PREDEFINED __d3d11_h__

◆ _D3D9_H_

PREDEFINED _D3D9_H_


  • File List
  • Globals
Deprecated.txt File Reference


  • File List
  • Globals
Documentation.txt File Reference


  • File List
  • Globals
legal.txt File Reference


  • File List
  • Globals
MainPage.txt File Reference


  • File List
  • Globals
nvapigroups.txt File Reference


Related Pages
Here is a list of all related documentation pages:
Legal Notice


  • File List
  • Globals
systemrequirements.txt File Reference